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End the chaos...
Welcome to Portfolio 6 — a program that takes
over the grunt work involved in getting you
organized and ends the chaos of naming,
tracking, and accessing digital files. Portfolio is
designed to help individuals and workgroups
keep their files organized, find them quickly
when needed, and then distribute them to
others via e-mail, CD, disk and the Web – with
as little effort as possible. The program is
designed to work with thousands, or even
hundreds of thousands of files at a time,
allowing both individual and large workgroups
to keep things organized.

Why do I need Portfolio?
In these days of digital media, it’s all too easy
for your electronic files to disintegrate into a
state of chaos. Without some way of making
order out of this chaos, you can end up with
some big problems: Pictures get lost. Fonts get
separated from the documents they belong in.
Wrong versions of images get used. Hours are
wasted hunting down documents and copying
them from machine to machine.

Portfolio is designed to get that kind of misery
out of your life. Here are some of the tasks that
Portfolio can help you with:

• Copy and renaming files that you download
from your digital camera.

• Find digital photos and other image files
anywhere on your system by typing only a word
or phrase.

• Preview an entire CD-ROM of stock
photography, without having to insert the CD.

• Create a slideshow of your favorite images.

• Build a web site containing a collection of
images.

• Collect a set of pictures to be burned on a CD.

• Access your files with a simple double-click,
without having to burrow through multiple
folders to find them.

How Portfolio Works
It’s quick and easy to view and retrieve images
in Portfolio catalogs because the catalog stores
only thumbnail images of the file — not the full
document or image. Portfolio creates pointers to
your original files, so the originals are always
available for copying to applications,
previewing, editing, and so on, while allowing
the catalog itself to be fast and efficient. 

In a workgroup setting, you can allow all users
full access to all catalog functions, or you can
designate catalog administrators to create,
maintain, and control access to catalogs for the
entire workgroup. With Portfolio installed on
their computers, members of your workgroup
on both Macintosh and Windows can
simultaneously search, view, and use items from
catalogs whose source files are located on one or
many network servers, shared volumes, CD-
ROMs or removable drives. 

Users can access the Portfolio Server remotely
using TCP/IP, and you can even create Web
pages of cataloged items. 

Introducing Portfolio 6
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What’s new in Portfolio 6?
Portfolio 6 takes a completely fresh approach to
the task of managing and distributing your
digital files. This version of Portfolio contains
literally dozens of program refinements and a
number of new features that bring
unprecedented ease and automation to asset
management. Significant new features include:

• FolderSync: A major product enhancement,
FolderSync synchronizes your Portfolio catalog
with your files and folders on disk in the most
intuitive way possible. You can now copy, move,
delete, and rename files on your hard drive or
file servers using a simple drag-and-drop
approach, without ever leaving the Portfolio
environment. Because your physical files stay
synchronized with your catalogs, Portfolio and
non-Portfolio users can work together without
confusion over how and where to find files.

• Portfolio Express Palette: This floating
palette brings your organized digital library
directly into your creative environment, with
instant access to your files from anywhere on
your system.

• Custom QuickFind: One of the most
powerful — and convenient — search tools ever
developed for Portfolio. With the new
QuickFind, you can perform a search of any
user-defined combination of fields right from
the main catalog window. You don’t even have
to open a window, pull down a menu, or click
on a button

• Create Web Pages: Builds web pages based
on your catalog contents with a few clicks, using
professionally-designed templates.

• Collect & Publish: Automatically collects
and copies images, linking them to a new

catalog and generating a free browser in which
to view the catalog.

• Instant Cataloging: A new super-fast way
to bring items into Portfolio. Just Control-click
(or right-click) any file, folder or disk to access
an Add to Portfolio contextual menu that lets
you catalog items as quickly as you get them.

• Batch Renaming and Keywording: This
new cataloging option can rename your files,
add keywords, and fill in other field values on
the fly as items are cataloged — so you don’t
have to do it later.

• Auto Move/Copy: Grabs images from a CD
or digital camera memory card and copies them
into a new location automatically as they’re
being cataloged. 

• Saved Views: Save and apply customized
view attributes such as fonts, colors and borders
to any gallery and apply them from a
convenient menu right in the main window.

• Edit Field Values tool: A new window that
lets you add, append, replace or delete values
from any field with unprecedented ease.

• Send via E-mail: E-mail your digital images
from within Portfolio, using your default e-mail
client.

• Rotate Original: This new command
changes orientation of original JPEGs, not just
the thumbnails.

• EXIF Support: Portfolio can now import
metadata embedded within the images created
by many of today's digital cameras.

• A streamlined interface, more contextual menus,
and many, many more enhancements.



System Requirements
To install and use Portfolio, you’ll need the
following hardware and software:

Portfolio 6 Macintosh:

• Mac OS 8.6 through 9.2
(Portfolio runs in Mac OS X’s classic
environment under Mac OS 9.2)
• Apple Power Macintosh
• A minimum of 32MB of application RAM
• 25MB of free hard disk space
• QuickTime 4.1.1 or higher strongly
recommended

Portfolio 6 Windows:

• Windows 98, Windows NT 4.0, Windows
2000, Windows ME or Windows XP•
• Pentium (133MHz or faster recommended)
• 32MB of system RAM
• 25MB of free hard disk space
• QuickTime 4.1.1 or higher strongly
recommended

Portfolio 6 Server Macintosh:

• Mac OS 8.6 through 9.2
• Apple Power Macintosh
• A minimum of 64MB of application RAM
• 25MB of free hard disk space
• QuickTime 4.1.1 or higher strongly
recommended

Portfolio 6 Server Windows:

• Windows 98, Windows NT (Service Pack 6 or
6a); Windows 2000 (Service Pack 2); Windows

XP; or Windows 98
• Pentium (133MHz or faster recommended)
• 32MB of system RAM
• 25MB of free hard disk space
• QuickTime 4.1.1 or higher strongly
recommended

Portfolio 6 SQL Connect:

• Windows 98, Windows NT 4.0, Windows
2000; or Windows XP
• Pentium (133MHz or faster recommended)
• 32MB of system RAM
• Supports MS SQL Server 6.5, 7 and Oracle 8i.

Installation
You can find instructions for quick and easy
installation on the Portfolio CD-ROM. If you
downloaded the Portfolio installer from our web
site, running the installer will place an
informational Read Me on your hard drive.

When you install Portfolio, the following items
will be placed on your hard drive:

Macintosh:

In the Extensis Portfolio 6 folder:

• Extensis Portfolio 6
• Portfolio Express 6
• Portfolio 6 Read Me
• Portfolio 6 User Guide.pdf
• HTML Templates folder
• Borders folder
• Saved Views folder
• Filters folder

3
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In the System Folder:

• PortfolioCMPlugin (in the Contextual Menu
Items folder) 
• Optional: Alias of Portfolio Express 6 (in
Startup Items)

Windows:

At the primary installation directory:

• Portfolio.exe
• Portfolio Express.exe
• Portfolio User Guide. pdf
• EToolbox.dll
• Gearpd.dll
• PortfolioCtxMenu.dll
• pstotxt3.dll
• Read Me.txt
• Portfolio6.tlb
• HTML Templates folder
• Borders folder
• Saved Views folder
• Filters folder

The following shortcuts are installed in the Start
menu:

• Portfolio 6.0
• Portfolio Express (also added to the Startup
group)
• Read Me
• Register Portfolio
• User Guide

Registration
It is important to register your copy of Portfolio
so we can provide you with the best possible
service. Registered users of Portfolio are eligible
for technical support, information regarding
new versions and products, discounts and
special offers on new products. 

Your registration number is located on the back
cover of this manual or was sent to you via
email if you purchased through our website. You
will need to enter that number to personalize
your copy of Portfolio. If you choose not to
personalize your copy, Portfolio will run in a
demonstration mode that allows you to use the
product for 30 days. You can purchase
additional registration numbers in the US at 1-
800-796-9798 or 1-503-274-2020. In Europe call
+44 (0) 16 04 636300.

Technical Support 
Technical Support is available directly through
the Extensis web site. Go to
http://www.extensis.com/support/ and fill out an
online support form for the quickest response.
Our tech support representatives will respond by
e-mail, usually within 24 hours on weekdays.
You can also visit the Portfolio area on the
Extensis website for answers to frequently asked
questions and troubleshooting tips. 

You can reach Technical Support by phone at
(503) 274-7030, Monday through Friday, 8:00
a.m. to 5:00 p.m. Pacific time. When calling for
technical support, please be at your computer
and have the following information available:
your Portfolio registration number, your
computer configuration, and your question or a
description of the difficulty you’re
experiencing—what specifically occurs and
when. Take note of any displayed error numbers
or messages and any other information you
think may be relevant.
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Portfolio helps you organize your digital files by
storing information about them in easy-to-use
visual catalogs. Instead of burrowing through
nested folders looking for files, or opening
document after document to find a needed
image, you can quickly browse thumbnail-sized
previews in your Portfolio catalog or perform a
search for a needed item using Portfolio’s
powerful search engine.

The following overview is designed to give you
an overall picture of how to set up and use
Portfolio. Each basic step is given a quick
summary, followed by a set of page references
that tell you exactly where to go in this User
Guide for more detailed instructions. Use this
section to get the “big picture” — then jump
into the chapters that follow for a step-by-step
guide to each Portfolio feature.

If you hate reading manuals, and want to
start using Portfolio as quickly as possible,
check out the brief Portfolio Quick Start
Guide that came with your copy of Portfolio.
In just a few pages, the Quick Start Guide
provides streamlined instructions for setting
up and using Portfolio without focusing on
many of the details covered in the User
Guide. 

1. CATALOG

You have to “catalog” your files — adding them
to a Portfolio catalog — so that Portfolio can
find them, preview them and track them. This
process includes creating a new catalog
document and then using various techniques to
add your digital files — photos, illustrations,

presentations, audio or video clips, and so on —
to the catalog.

Adding files to your catalog is as easy as
dropping them into an open catalog window, or
using the Add to Portfolio contextual menu,
which is available in the Finder or Windows
Explorer — even when Portfolio isn’t running!

• To create new catalogs, see page 9

• To open and access existing catalogs, see page 11

• To add items to a catalog, see page 14

2. CUSTOMIZE

Give your catalogs the look and style you want
to make information easy to find and display.
Choose between thumbnail, list and record
views. Customize each window (or gallery) in
Portfolio to display the background color,
thumbnail size, border, font, style, spacing, and
sort order you want.

5
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Drop your digital
media files into a
Portfolio catalog to get
the process started...



• To customize the look of a Portfolio catalog, see
page 38

• To save custom views, see page 42 

• To customize the Portfolio interface, see page 33

3. ACCESS

Preview files right in Portfolio, copy them to
another disk, drag them into programs such as
Photoshop® or QuarkXPress®, or edit them by
opening them in the application with which
they were created.

Using the Portfolio Express palette, you can also
open and access your cataloged images without
even launching Portfolio. Pull up images from
within QuarkXPress, Adobe Photoshop or any
other application.

• To preview files within Portfolio, see page 47

• To edit your original files, see page 50 

• To use files in other applications, see page 53

• To use the Portfolio Express palette, see page 114

4. ORGANIZE
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Give each gallery window in Portfolio its own look
— from background color to fonts

Access your cataloged
files from anywhere
on your system with
the Portfolio Express
palette

With Portfolio you don’t have to launch other
programs to see your images; you can preview
them by double-clicking any thumbnail



Using tools within Portfolio you can group,
organize and categorize your files by adding
keywords, descriptions, and other custom data.
There’s no limit to the number of keywords and
custom fields you can create.

Portfolio allows you to organize files not only
logically, but physically as well. Using the new
FolderSync feature, you can add, delete and
move folders on your hard drive or network
right from within Portfolio, allowing you to
manage your files more easily than ever.

• To create and assign keywords, see page 69

• To use custom fields, see page 72

• To group images into separate gallery windows,
see page 80

• To edit information about your files, see page 77

• To use FolderSync to organize your files on disk,
see page 61

5. FIND

Type a word or phrase in the QuickFind box on
the main toolbar to locate any cataloged file and
access it instantly. Use Portfolio’s powerful
search engine to find files using dozens of
different criteria. Search an individual catalog,
or search across multiple catalogs. 

• To quickly locate a file using Portfolio’s
QuickFind box, see page 89

• To use the Find command, see page 91

• To perform multi-catalog searches, see page 96

• To search for text inside of PDF and text files, see
page 97

• To save a set of search criteria for future use, see
page 94

7

Portfolio stores detailed information about each
item you catalog, so you can get your work organ-
ized quickly

Search one catalog — or
several at once — using
any combination of
search criteria with
Portfolio’s
Find command.



6. DISTRIBUTE

Rather than just help you organize your files,
Portfolio assists you in distributing files to other
users. You can send files via email with a click,
or collect an entire group of cataloged images
for burning to CD. The Create Web Pages
command turns a gallery of images in your
catalog into a ready-to-publish set of web pages. 

• To e-mail images from Portfolio, see page 99

• To collect files for copying to a disk or burning to
CD, see page 100

• To include a catalog and free viewer application
with your collections, see page 101

• To convert cataloged images into web pages, see
page 104

Outline of the User Guide
To help you find the information you need in
this user guide, here’s a brief outline of its
contents:

Chapter 1: Introduction — Installation,
system requirements and a description of
Portfolio 6’s new features.

Chapter 2: A Portfolio Overview — A
“big picture” overview of the process of setting
up and using Portfolio.

Chapter 3: Setting Up Portfolio 6 —
Outlines the process of creating and opening
catalogs, and adding items to them.

Chapter 4: Customizing Portfolio
catalogs — How to customize the look of
catalogs; creating and saving custom views.

Chapter 5: Managing your files with
Portfolio — Using Portfolio to preview, move,
copy, rename and edit your original files.

Chapter 6: Using FolderSync — How to
use FolderSync to manage files on disk and keep
your catalogs up to date.

Chapter 7: Organizing your files with
Portfolio — Using keywords, custom fields,
saved galleries and other tools to get your files
grouped, categorized and organized.

Chapter 8: Finding files with Portfolio —
Using Portfolio’s search engine to locate your
files quickly.

Chapter 9: Distributing files with
Portfolio — Publishing your files by e-mailing
them, burning them to CD or putting them on
the web.

Chapter 10: Using the Portfolio Express
palette — How to access your files from
anywhere on your computer system with the
Portfolio Express application.

Chapter 11: Catalog Administration —
Setting up access levels and security passwords,
creating custom fields and setting other
administrative options in Portfolio.

Chapter 12: Using Portfolio Server —
How to set up and administer the Portfolio
Server for large workgroups.

8
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This chapter will show you how to set up
Portfolio in order to organize, track and
distribute your digital files. It will tell you how
to create a new catalog, add items to that
catalog and use Portfolio’s powerful Cataloging
Options to streamline the process of cataloging
your collection of digital files.

Creating catalogs
Portfolio stores your collection of images,
graphics, digital photos and other media files in
a document called a Catalog. A catalog stores
only thumbnail images of your files (along with
whatever additional information you require),
and pointers to your original files – not the files
themselves (which you can store anywhere you
want). As a result, Catalogs are relatively small,
compact documents that let you preview and
organize your files without becoming unwieldy. 

Creating a new catalog when
launching Portfolio

The first time you launch Portfolio, a Welcome
screen offers you two options: You can either
create a new, empty catalog, or open an existing
catalog, as shown here.

Welcome Dialog Box options.

Create a new Portfolio catalog.

If you choose this option, you’ll first be
prompted to name and save a catalog. A blank
catalog containing no records is created and
opens on screen. You’re now ready to add items
to the catalog, using any of the methods
described in “Adding Items to a Catalog.”

Open an Existing Portfolio Catalog

Choosing this option presents you with a
standard Open dialog. Select a Portfolio catalog
to open it on screen. 

You can turn off the Welcome dialog box, so
that you don’t see it each time you launch
Portfolio, by turning off the Show Welcome
Dialog at Startup option in Preferences
(Edit > Preferences) or by checking the
“Don’t show this dialog at launch”
checkbox in the Welcome dialog box.

Setting up Portfolio 6
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Other ways to create a new
Portfolio catalog
There are two other ways to create a new
Portfolio catalog — from within the Portfolio
catalog itself, or on-the-fly when cataloging
from the Desktop. 

Creating a new catalog within Portfolio 

Choose File > New, or Press �-N (Mac) or
Control-N (Win). A blank catalog containing no
records is created and opens on screen. You’re
now ready to add items to the catalog, using
any of the methods described in “Adding Items
to Portfolio.”

By default, Portfolio adds an extension of
.fdb to the end of catalog names.
Technically, this three-letter extension isn’t
required on the Macintosh platform, but
preserving it ensures that your catalogs will
be readable by both Mac and Windows users
of Portfolio

When cataloging from the Desktop

Portfolio lets you add items from your hard
drive or network directly to a catalog by simply
Control-Clicking or Right-clicking on them
within Windows Explorer or the Macintosh
Finder (see “Instant Cataloging,” page 14).  If
you don’t have a catalog ready to receive these
items when cataloging, you can have Portfolio
create one for you on the fly. 

1 Control-click or Command-click on a file,
folder, or disk to catalog it.

2 Choose Add to Portfolio > New Catalog.

3 Name the New catalog, then name and save
the catalog as outlined in “Create a new
Portfolio catalog” above.



Opening catalogs in
Portfolio

In addition to the Welcome dialog box referred
to on page 9, there are several other ways you
can open an existing catalog in Portfolio.

• Double-click a catalog file (it’s the one with
the .fdb filename extension) from the Finder or
Windows Explorer.

When you create a Portfolio catalog, two
files are saved — the catalog file itself
(recognizable by the .fdb extension
appended to the end of its name) and an
administrative file (with an .adm extension)
which controls administrative access to the
catalog and is visible only when a catalog
is open. There’s no need for you to double-
click this file, but it must remain in the
same folder as the catalog.

• Use the recently-opened catalogs list in
Portfolio’s File menu (Windows version only).
Recently-opened catalogs appear in the File
menu, directly under the Print command. You
can choose any of the catalogs listed to open
them, bypassing the standard Open command.

• If you have the Catalogs palette displayed
(Window > Show Catalogs), you can click the
Open button, use the Open command on the
palette’s fly-out menu, or select a recently-used
catalog by name from the fly-out menu.

Converting Catalogs from
earlier versions of Portfolio
To access the new features added to Portfolio 6,
catalogs created in Portfolio 5.0 (or earlier) must
be converted to version 6 catalogs. Portfolio 6
can open version 5.x catalogs without
conversion, in a limited browsing mode.

Opening a 5.x catalog with Portfolio 6 in
Administrator mode allows the catalog to be
converted.

Although Portfolio is capable of opening
and converting catalogs created with
Portfolio 4.x (and earlier), for best results
we recommend that you first open and
convert such documents using Portfolio 5,
and then convert your catalogs from version
5.x to 6, as outlined below. 

To convert a Portfolio 5.0 catalog:

1 Make a backup copy of your original 5.x
catalog.

2 With no catalog open, choose Edit >
Preferences and set the Default open mode in
the General Preferences panel to Administrator.

This will automatically open the catalog in
Administrator mode. If the catalog requires a
password for Administrator level access, you
will be prompted to provide it. If you open the
catalog in any other mode, the catalog will
automatically be opened in a limited browsing
mode.

2 Open the catalog to be updated. 

You will be asked to confirm the conversion.
Once the catalog is converted to a Portfolio 6
catalog, you won’t be able to open it using Portfolio
5.x.
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3 Click OK.

The catalog is converted and all options
(catalog options, saved galleries, etc.) are
preserved.

Choose Cancel to leave the catalog version
unchanged, opening it in limited browsing
mode.

Converting catalogs from an earlier version
of Portfolio can take quite a bit of time —
depending on the size of the catalog. We
recommend performing such conversions on
the fastest machine possible and also
moving catalogs from network volumes or
servers to a local hard disk before
converting.

Catalog Access Levels &
Security
Every Portfolio catalog can be password-
protected for security. In addition, as the
Administrator of your catalog, you can assign
varying levels of access to different users.

The four possible levels of access are:

• Administrator: This mode provides full
access to all features. An administrator can
assign passwords to other users, create custom
fields, and control cataloging and startup
options that other users can’t. By default, when
you create a new Portfolio catalog, you have
Administrator access to that catalog. When a
catalog is opened in Administrator mode, no
one else can use it.

• Publisher: Publishers can add, remove,
export and edit items in a catalog, but can’t
access administrative functions such as creating
a new custom field, creating a master keyword
list or changing passwords.

• Editor: In Editor mode, you can search,
preview, access and edit information about
cataloged items, but you can’t add new items to
a catalog, rename files or export catalogs as web
pages or QuickTime movies. 

• Reader: As a Reader, you can view, search,
preview and copy items — but you can’t make
any changes in the catalog. It’s a “read-only”
mode. 

In Portfolio, each of these levels can have its
own password. Alternatively, a catalog
administrator can assign an access level and
password to individual users to more closely
control who has access to a catalog and what
level of access they have.

For details on how to set up access-level
passwords and create user-level access
privileges for a Portfolio catalog, see the
Catalog Administration chapter on page
121.

For now, here’s what you need to understand
about access privileges and security:

Opening a password-protected
catalog

If a catalog administrator has protected a catalog
with a password, you’ll be prompted to enter
the password each time you try to open the
catalog. Simply select the Access Level you want
to use (Administrator, Publisher, Editor or
Reader) from the Level pop-up menu, then type
in the password and click OK. 

12



Setting a default open mode

You can set your copy of Portfolio to open
catalogs in one of the four access-level modes
described on this page by default. If you know
that you have Publisher-level privileges to your
catalogs, for example, you can tell Portfolio to
automatically open catalogs in Publisher mode.

Or, if you are the administrator of your
Portfolio catalogs, you might want to have
Portfolio always open catalogs on your
computer in Administrator mode.

To set a default open mode:

Open Edit > Preferences. In the General
preferences panel, use the Default open mode
menu to select an access level. This will be the
level at which Portfolio attempts to open each
catalog.

Of course, regardless of which level is set,
you’ll still need to know the password (if there
is one) in order to open the catalog. 

Changing your access level

At any time you can change the level at which
you’re currently accessing a catalog. For
example, you may have opened a catalog in
Publisher mode, but then need to make some
changes to it (adding a new custom field, for
instance) that requires administrative access.
Without closing the catalog or quitting
Portfolio you can change your access level
from Publisher to Administrator, make the

required changes, then switch your access back
to Publisher again.

To change access levels:

1 Choose Catalog > Access, or press �-J (Mac)
or Ctrl-J (Windows), to open the Catalog
Access dialog box. 

2 Using the Level pop-up menu to switch to
the desired access level.

3 If necessary, enter a password and click OK.

Opening a served catalog

If your workgroup is using Portfolio Server
(which provides optimized performance for
workgroups that share Portfolio catalogs across a
network) you can open a Portfolio catalog using
the Connect to Servers command. 

To Open a catalog on a Portfolio Server:

1 Choose File > Connect to Servers, or press �-
Option-O (Mac) or Ctrl-Shift-O (Windows).

The Connect to Servers dialog will be
displayed.
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2. If a list of servers and catalogs appears, skip
to step 4 on the next page. (You’ll have to
expand each server entry (by clicking the
twisty triangle (Mac) or “+” symbol (Windows)
to see which served catalogs are available. If
the list is blank or if the server you want to
access does not appear: Click Add Server.

The Add Server dialog will be displayed.

3 Enter the Name or IP address of the server
that you want to connect to.

Portfolio will connect to the Server and display
a list of catalogs available on that Server.

4 Select the desired catalog from the list, then
click Open Catalog, or double-click the selected
catalog to open it.

You will be asked to enter a password if the
catalog requires it.

The next time you use the Connect to Servers
command, all the servers you added—and all
available catalogs on those servers—will be
displayed on the list, ready to open.

For more information on administering
catalogs, and cervers, refer to the “Catalog
Administration” and “Portfolio Server”
chapters of this User Guide.

Adding Items to Portfolio

In order to organize and track your files with
Portfolio, you must first add those files to a
Portfolio catalog. To add items to a Portfolio
catalog, you must have Publisher or
Administrator access to the catalog (as explained
on page 119). You can’t add items to a catalog
when in Editor or Reader mode.

You can catalog individual files (such as a JPEG
image, or an EPS graphic), or folders, or entire
volumes (such as your hard drive, a CD-ROM or
a Jaz disk).There are five different ways you can
add items to a Portfolio catalog. 

• Instant Cataloging. This is a new, fast way
to add items to Portfolio. Control-click (on a
Mac) or right-click (on Windows) a file, folder or
disk icon anywhere within the Macintosh
Finder or Windows Explorer and choose the
Add to Portfolio command submenu to see a list
of recently-used catalogs. Select the catalog to
which you’d like the selected items to be added.
If the catalog you need isn’t listed, choose Other
Catalog to open it.

• Drag & Drop. Simply drag a file, folder or
disk into an open catalog window to catalog it.
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FolderSync. Add a folder from your computer
or network to Portfolio’s Folder View by clicking
the New button in the Folder View pane, then
click the Sync button to catalog the contents of
the selected folder. See the FolderSync chapter
on page 61 for instructions on using FolderSync.

Add button. Click the Add button in the main
Portfolio Toolbar. Select any file, folder or disk
in the Open dialog box. If you select a folder or
disk, you can turn on the Include Subfolders
checkbox to catalog any files that are inside
folders nested within the selected folder or disk
volume.

Catalog menu. Choose Add Items from the
Catalog menu. Select any file, folder or disk in
the Open dialog box. If you select a folder or
disk, you can turn on the Include Subfolders
checkbox to catalog any files that are inside
folders nested within the selected folder or disk
volume

You can also add items to Portfolio as a hands-off

background operation, using Background
Cataloging. See page 43 for details.

Adding Placeholders
Normally, Portfolio creates a entry (also called a
“record” or “item”) for each digital file that you
catalog. But, in some cases, you may want to
enter a record in a Portfolio catalog for a file
that doesn’t exist — perhaps one that you
haven’t yet received or created. This is called a
Placeholder Record. Think of a Placeholder
Record as a stand-in for a file that you know
you’ll be including in your catalog, but that you
don’t have yet.

Placeholder Records behave just like other items
in a Portfolio catalog. You can assign them
keywords, add descriptions to them, perform
searches for them, and so on. The only
difference is that the Placeholder Record doesn’t
yet have a specific media file associated with it.
At any point in the future, you can link a
Placeholder Record to an actual file on disk,
turning it into a regular Portfolio catalog item. If
you give the Placeholder Record the same name
as the file you eventually link it to, Portfolio can
automatically find the file and catalog it when
you update the Placeholder.

To create a Placeholder Record

1 Choose Catalog > Create Placeholder.

2 Name the Placeholder Record. Type the
name into the Record’s Filename field. If
possible, this should be the name of the file
that the Placeholder is standing in for – the
one that you’ll eventually use to replace the
Placeholder. This will make updating much
easier later on. 

3 Specify a location (Optional). Click the
“Specify folder on disk” button to set the
location where you will eventually place the
file that the Placeholder Record is standing in
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for. If you don’t know where you’re going to
put the file, you can leave this blank. If you do
know it, setting this location will make
updating the Placeholder much easier.

4 Click OK. A new record with a thumbnail
containing the words “Placeholder” appears in
your catalog.

To link a Placeholder Record to a file

Linking a Placeholder Record to an actual file on
disk turns it into a regular Portfolio catalog
item. 

1 Select the Placeholder Record.

2 Choose Item > Update Items, or press
Command-U (Mac) or Control-U (Win)

If the name of the Placeholder Record exactly
matches the name of the file you’re linking to,
and you’ve specified the right folder in which to
find it, the Update Items command will
automatically link the record to the matching
file. 

If Portfolio doesn’t see a file with the same name
as the Placeholder Record in the current
directory, you’ll see an Open dialog box, in
which you can locate the desired file. Select the
file you want, then click Open.

Cataloging Options
When you add items to Portfolio, there are
many options available that determine exactly
how Portfolio stores information about your
files. You can control these various options by
choosing the Cataloging Options command
from the Catalog menu. By default, the
Cataloging Options window opens each time
you catalog files, unless you specifically tell it
not to do so by turning on the “Don’t show
when cataloging” checkbox in the Cataloging
Options window.
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Turn on this checkbox if you don’t want
the Cataloging Options dialog to open
every time you catalog files.
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Cataloging Options in Portfolio allow you to
perform very powerful tasks with a minimum of
effort. Here are some of the things you can do
when cataloging your images:

• Rename files

• Insert descriptive text about each cataloged file

• Add keywords

• Fill in custom fields associated with each
record

• Copy or move files from one location to
another

To change Cataloging Options, choose
Cataloging Options from the Catalog menu, or
press �-Option-D (Mac) or Ctrl-Shift-D
(Windows). This opens the Cataloging Options
window (shown on the previous page), where
you will find the options described below:

Assigning Properties

Portfolio allows you to store keywords and
descriptions for each of the digital files that you
catalog. In addition, you can create an
unlimited number of custom fields to store
other information about your files – dates, URLs,
numbers, or any other data you wish. To set up
custom fields in a catalog, see page 73.

Using Portfolio 6’s new Cataloging Options
window, you can assign these keywords,
descriptions and other field values to your files
while cataloging — rather than waiting and
assigning them after you’ve cataloged the items.

Assigning a description during
cataloging

Using this feature, you can insert a description
into the Description field of each file as it is
cataloged. For example, if you were cataloging a
folder of pictures of the Grand Canyon, you
could automatically assign the description
“Photo of the Grand Canyon, taken on May 14,
2001” to each file as it is being cataloged.
(Descriptions can be as long as 32,000
characters.)

1 In the Cataloging Options window, make
sure the Description tab is active in the Assign
Properties portion of the window.

2 Type a description into the Description field.

3 Click OK. 

4 The description you typed will be filled on
all the items you now catalog.

The description you type in here will
automatically be added to each record
you catalog



Assigning keywords during
cataloging

This feature adds the keywords you specify to
each of the files you catalog in Portfolio. If, for
example, you were going to catalog 100 photos
of a tropical beach, you could assign keywords
such as Beach, Ocean, Tropical, Sun or Seaside
to each item as it is being cataloged, saving you
the trouble of adding and assigning these
keywords later.

1 In the Cataloging Options window, make
sure the Keywords tab is active in the Assign
Properties portion of the window.

2 In Keyword entry field, type in a keyword
that you would like to add to each incoming
item that you are about to catalog. Remember,
the keywords you enter here will automatically
be applied to all the items you catalog. Or, to
use keywords that already appear in the Master
Keyword list, select the words in the list and
click the Assign button.

3 Press the Add button to add the keyword to
the list of Keywords that will be added. 

4 After you’ve inserted all the keywords you
want to include, click OK. 

5 The keywords you added will now be applied
to the items as you catalog them.

Assigning custom field values
during cataloging

This option fills in values for any of the custom
fields you’ve created in Portfolio as you catalog
files in Portfolio. For example, if you’ve created
a custom field that contains the name of the
photographer who shot each digital photo that
you catalog, you can have Portfolio fill in the
photographers name on the fly as you catalog
the images. 

In order to assign field values during
cataloging, you must already have set up
custom fields in your Portfolio catalog. See
Section 73 for instructions on how to do this.

1 In the Cataloging Options window, make
sure the Fields tab is active in the Assign
Properties portion of the window. You’ll see a
list of the custom fields available to you in the
catalog. (If there are no fields listed, it means
the catalog you are viewing does not contain
custom fields.)

2 Double-click the name of the custom field to
which you would like to assign a value. 
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3 Edit the field. Remember, the values you
enter here will be applied automatically to all
the items you next catalog. Click OK when
you’re done editing.

4 After you’ve edited the content for all the
custom field values you want to assign when
cataloging, click OK. 

5 Custom fields for the items you next catalog
will now be assigned the values you’ve set up.

Moving and copying files during
cataloging

Portfolio can copy or move files when
cataloging them, placing them in the exact
location you want. This is useful if you’re
pulling images off of a CD-ROM, digital camera
or memory card, and you want your Portfolio
catalog to link to new copies of the files that are
stored in a folder on your system or on your
network, rather than the original CD or storage
disk. Instead of first copying the files manually,
and then cataloging them, you can have
Portfolio handle both tasks — first copying the
files for you, then cataloging them — in one
step. 

Move vs. Copy

When cataloging, Portfolio can either move or
copy your original files. It’s important to
understand the difference: Copying a file makes
a duplicate of it in the new location, leaving the
original untouched. Moving a file places a copy
of the file in the new location and removes it
from its original location.

On the Macintosh, the “move” command
will not delete an item from its original
location if that location is on a different
volume than the destination. It will only
copy the file.

To have Portfolio move or copy files when
cataloging:

1 Expand the Cataloging Options window so
that the Move and Rename Options are visible. 

2 Turn on the Copy/Move Original Files
checkbox.

3 Choose to either Copy or Move files by
clicking the appropriate radio button.
Remember, copying a file makes a duplicate of
it in the new location, while moving it places a
copy of the file in the new location and
removes it from its original location.

4 Set a destination for the new files. Click the
folder icon to select the location in which
Portfolio will place the cataloged files.

5 Click OK. Portfolio will now either move or
copy each file you catalog to the specified
location.
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Renaming files during cataloging

Portfolio can rename your files as you catalog
them, saving you from having to rename each
one of them individually. This is particularly
useful if you’re downloading images from a
digital camera. As they are saved on the
camera’s memory card, the files may have
generic names such as PIC000045.JPG,
PIC000046.JPG, and so on. With Portfolio you
can automatically replace those names with
something more descriptive, such as “Bermuda
Holiday 01, Bermuda Holiday 02, etc…” 

Of course, you ultimately may want to give each
individual file an even more specific name;
Portfolio provides several easy ways to do this,
after you’ve cataloged the images. See page 51. 

To have Portfolio rename files during
cataloging:

1 Expand the Cataloging Options window so
that the Move and Rename Options are visible. 

2 Turn on the Rename Files checkbox.

3 Choose a naming scheme using the three
pop-up menus. The naming options available
are:

Text. Type a descriptive text string up to 31
characters long.

Number from. Enter any number. If you
catalog more than one file, Portfolio will
increment the number by one when naming
each file. If you enter the number 001, for

example, and catalog three images, their names
will contain the numbers 001, 002, and 003.

Original File name. Includes the original file
name within your new naming scheme.

None. Does not apply any renaming scheme to
your files.

You can apply these options in any order and
combination to make up the front, middle and
end of the new naming scheme.

4 Once you’ve entered the naming scheme
you want, click OK to apply the cataloging
options. The next files you catalog will be
automatically renamed according to the
scheme.

Remember to change these settings the next
time you catalog items, or the same names
and numbering will be applied to the next
batch of files.

Hiding the Cataloging Options
window

By default, Portfolio displays the Cataloging
Options window each time you catalog a new
file, folder or disk. This gives you a chance to
modify these options before cataloging items.
However, if you know that the options are set
correctly and don’t need to review them, you
can choose to keep this window hidden by
turning on the “Don’t show when cataloging”
checkbox at the bottom of the Cataloging
Options window. This allows you to catalog files
without an interrupting dialog box. 

If, after keeping Cataloging Options hidden, you
need to see them again in order to make
changes, simply choose Catalog > Cataloging
Options before cataloging a new item and turn
off the “Don’t show…” checkbox.
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Preferences for Cataloging
Options 

You can also keep the Cataloging Options
window hidden at any time by activating the
“Do not prompt for Cataloging Options”
checkbox in the Cataloging panel of the
Preferences dialog box (available via Edit >
Preferences). 

The three checkboxes in the “But still do the
following as configured” section of the
Cataloging Preferences panel let you determine
which cataloging options will be performed and
which will be ignored when the Cataloging
Options dialog is configured to remain hidden.

You can clear these checkboxes as a precaution
against moving or renaming files
unintentionally when cataloging. Leaving the
Rename Items checkbox turned off, for example,
means that Portfolio won’t rename files as you
catalog them unless you specifically show the
Cataloging Options dialog box to confirm the
renaming scheme.

Cataloging Summary. These checkboxes
determine how Portfolio handles problems that
it encounters when attempting to catalog files.
If you want Portfolio to alert you to a problem
— such as a corrupted file that cannot be
cataloged— during the cataloging process turn
on the “Report cataloging errors” checkbox. The
second option, “Log cataloging errors to file”

creates a text file in the same directory as your
catalog, logging all cataloging activity.

Advanced Cataloging
Options
For even greater control over how Portfolio
handles the process of cataloging your files, click
the Advanced button to open the Advanced
Cataloging Options window. You can also
choose Catalog > Advanced Cataloging Options
to go directly to this window. The options
available in the five panes within the window
control the following issues related to cataloging
new items:

• The quality and size of thumbnail images.

• The type of information Portfolio extracts
from your files when cataloging them.

• The creation of keywords from file names and
paths

• The automatic import of TIF, IPTC and EXIF
data into Portfolio

• File types that Portfolio automatically includes
or excludes when cataloging.



Thumbnail Options

The options in this panel determine how
Portfolio creates or extracts thumbnails of your
images for use in a Portfolio catalog.

Thumbnail Quality. Determines the level of
compression Portfolio applies to the thumbnails
stored in your catalog. The High setting yields
high-quality thumbnails (with low compression)
but increases the total size of your catalog. The
Low setting yields heavily-compressed
thumbnails of lower quality, but smaller
catalogs. The default is High. If you want to
keep the size of your catalogs as small as
possible, reduce this setting to Medium or Low.

This setting only applies if you choose to
have Portfolio generate, rather than extract,
thumbnails, as explained in the next section.

Thumbnail Size. This setting determines the
size (in pixels) of the thumbnails created and
stored by Portfolio — either 112 x 112 pixels, or
256 x 256 pixels. If you want to display 256 x
256 thumbnails in your catalogs, you must set
the Thumbnail size to the higher setting. If your
catalog views only require thumbnails that are
112 x 112, 64 x 64, or 32 x 32 pixels, you can
leave this setting on 112. The lower setting will
result in catalogs that are smaller in size.

Extracted vs. generated thumbnails. Many
graphics and page-layout programs
automatically create thumbnail-size preview
images and embed them in saved files. By

turning on the Extract Thumbnail checkbox,
you can have Portfolio extract these embedded
thumbnails instead of generating its own
thumbnails during the cataloging process. In
general, the thumbnails generated by Portfolio
are of higher quality and of more consistent size
than embedded thumbnails, so we recommend
that you keep Extract Thumbnails turned off.
There are, however, two reasons why you might
want to turn Extract Thumbnails on:

• Using extracted thumbnails may improve the
speed of cataloging, since Portfolio doesn’t have
to generate a thumbnail for each cataloged
image.

• Using extracted thumbnails allows Portfolio to
display thumbnails for files types not otherwise
supported. For example, Portfolio can’t generate
a thumbnail for QuarkXPress documents, but it
can extract the preview image that QuarkXPress
4.x and later embeds in each document. This
enables you to display a thumbnail image for
each cataloged QuarkXPress document, instead
of just displaying a QuarkXPress icon.

If you don’t want Portfolio to catalog files for
which it can’t either extract or generate a
thumbnail, turn on the Skip files without
thumbnails checkbox.

Video thumbnails. When you catalog digital
movie files with Portfolio, you have a few
additional thumbnail options.

• Use Poster Frame displays a thumbnail of the
first frame of a cataloged movie.

• The Use Frame # options lets you select a
specific frame that will be used to generate a
thumbnail. You can select a frame that appears a
specified number of seconds after the start of
the video clip.
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A highly-magnified view of two thumbnails — one
created with Portfolio’s High quality setting (Left)
and one created with the Low setting (Right). At
normal size, there’s not much difference.
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Properties Options

The Properties panel contains several options
that control the kind of information Portfolio
extracts from your files when cataloging them.

Extracting keywords and
descriptions

Many graphics programs (such as Adobe
Photoshop and Adobe Illustrator) allow you to
include a text description and keywords when
saving a file. Portfolio can automatically detect
and extract this embedded information and add
it to your catalog, saving you the trouble of
having to re-enter the information manually.
The options settings here apply both to when
you add items to Portfolio and to when you
update items, using the Update Item command
or the Extract Properties command.

To extract keywords from files when 
cataloging:

1 Turn on the Extract keywords checkbox.

2 Each time you catalog a file, any keywords
embedded in the file will automatically be
added to that item’s Keywords field in
Portfolio.

When updating items in Portfolio, select the
Replace radio button to have Portfolio replace
keywords with the ones extracted from your
files, or Merge to add the extracted keywords to
those that have already been entered in
Portfolio for each record. These radio buttons
have no effect when you’re adding new items
to Portfolio.

To extract a description from files when 
cataloging:

1 Turn on the Extract description checkbox.

2 Each time you catalog a file, any description
embedded in the file will automatically be
added to that item’s Description field in
Portfolio.

When updating items in Portfolio, select the
Replace radio button to have Portfolio replace
any currently-saved descriptions with the ones
extracted from your files. Choose Append to
paste the extracted descriptions at the end of
those that have already been entered in the
Description field for each record in Portfolio.
These radio buttons have no effect when you’re
adding new items to Portfolio.

Indexing document text

With the Index document text option turned
on, Portfolio indexes the text of Adobe PDF
(Portable Document Format) files, as well as
plain text documents, when they are cataloged.
Each word in the cataloged documents is saved
in the catalog index, allowing for fast searches
and retrievals.

Turning on text indexing slows down the
cataloging of PDF files. It is recommended
you turn this option on only if it is critical
that you be able to search for text within
PDF files when using Portfolio to retrieve
documents. 
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Exclusions. You have the option of excluding
words from Portfolio’s text-indexing operations.
You might want to exclude words in order to
speed indexing time and reduce the size of your
Portfolio catalogs. 

To exclude words from text indexing:

1 Click the Edit Exclusions List

2 In the entry field, type a word that you want
Portfolio to ignore when indexing

3 Click Add

4 Repeat Steps 2 and 3 to add as many words
as necessary to the exclusion list.

5 Click OK. 

Creating Keywords from Path

This is a powerful and important feature of
Portfolio that can save you hours of typing. By
turning on the Create keywords from paths
checkbox, you can have Portfolio add keywords
to each file you catalog, based on the name and
location of each file on disk. Portfolio does this
by examining the full path of each cataloged file
and then extracting the words in all or part of
that path to make keyword entries. The pop-up
menu determines how much of the path is used
to create keywords.

To illustrate how this works, imagine that you
catalog a file with the following path on your
computer: 

Hard Drive: Current Projects:
Newsletter: Travel Photos: Bermuda:
SUNSET.JPG

Here’s a list of each of the pop-up menu options
available and the resulting keywords produced
when you catalog this file:

Menu option Keywords produced
File Name SUNSET.JPG
File and Folder name SUNSET.JPG

Bermuda
Path Name SUNSET.JPG

Bermuda
Travel
Photos
Newsletter
Current
Projects

Path Name with Volume SUNSET.JPG
Bermuda
Travel
Photos
Newsletter
Current
Projects
Hard
Drive

As you can see, by creating keywords from
folder and path names, you can easily add a
large number of meaningful keywords to the
items in your catalog without having to type
them. In the example above, you would now be
able to easily search for the SUNSET.JPG picture
in Portfolio simply by typing words such as
Sunset, Bermuda, or Travel because they all were
automatically added as keywords.
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Creating Categories from Path

The Create Categories from Path feature works
exactly like Create Keywords from Path,
described above, except that the words Portfolio
extracts from pathnames are used to make new
Categories rather than keywords.

Categories are another organizational tool
available within Portfolio. With Categories, you
can create a hierarchical system of folders that
allows you to organize groups of records
visually.

For a discussion of Categories, see page 84.

Creating categories is an Administration-
level feature. You must be logged in as the
catalog administrator to turn this on.

Detecting watermarks

A Digimarc® watermark is special information
that may be embedded in an original file,
generally pertaining to copyright and licensed
use of an image. Digimarc watermarks can be
detected, displayed and embedded directly by
Portfolio.

Portfolio detects Digimarc data automatically
when cataloging files — provided that you have
Portfolio set up to generate its own thumbnails.
If you’ve chosen to extract thumbnails rather
than generate them, Portfolio does not scan for
watermarks, unless you have the Always detect
Digimarc option turned on. This options forces
Portfolio to generate thumbnails and examine
files for watermarks — overriding the Extract
Thumbnails option.

For more about reading and embedding
watermarks, see page 58.

Mappings

This is an advanced feature that allows you to
extract specific types of text data from certain
kinds of digital images. Here are some examples:

• TIFF images created by scanners may have
embedded tags that contain information about
the scanner make and model, and other details
about the creation of the files.

• Newswire photographs may contain
embedded IPTC tags that contain caption,
byline and source information.

• Photos from digital cameras may be tagged
with EXIF data, which contains specific
information about each photo, including
shutter speed, date photographed, flash settings,
and so on.

Typically, software that allows you to add such
information to a file (Photoshop’s File Info is a
good example) assigns a numeric ID, or Tag, to
each field of embedded data. Using Portfolio’s
Mappings feature you can map this field ID to a
Custom Field in your catalog, and have Portfolio
copy the source file data into the Custom Field.

Portfolio provides ready-to-use Tag Codes for
four popular formats:

• Photoshop

• IPTC

• TIF

• EXIF

You’ll find the Tag Codes for these formats
displayed in the Mappings tab of the Advanced
Cataloging Options. But you are not limited to
the pre-installed codes—you can add Tag codes
from any software that supports this
convention, and also add new codes as they
become available. 

2525



How to set up Mappings

To illustrate the process of setting up and using
a mapping, here are the steps you would follow
to extract the shutter speed EXIF tag from a
digital photo and store it in Portfolio:

1 Create a custom field.
In order to store the shutter speed, you need a
field in Portfolio in which to place the
information. Go to Catalog > Administration
and switch to the Custom Fields tab. Click
Add, type “Shutter Speed” in the Name field,
click OK and then click OK again in the
Catalog Administration dialog box to close it.
You now have a new custom field called
Shutter Speed in your catalog. (See the
“Portfolio Administration” section for much
more detail on how to create custom fields.)

2 From the Mappings list in the Advanced
Cataloging Options, scroll down to the EXIF
tag with the title Shutter Speed and Tag code of
37377 and double-click it to open it.

3 In the Mapping dialog, use the Field pop-up
menu to select the “Shutter Speed” custom
field that you just defined. Change the State
menu to On.

4 From the Action menu, choose either
Replace (to replace the contents of the custom
field you created in Step 1 with the tag data) or
Append (to append the tag data to any existing
data that may be in the custom field.)

5 Click OK to close the Mappings dialog box.

The next time you catalog photos containing
EXIF data, Portfolio will automatically extract
the shutter speed and place it in the Shutter
Speed custom field that you defined. 

Follow these same steps to set up mappings for
other EXIF tags, as well as IPTC and TIF tags.

To Enable or Disable an existing Mapping:

After you’ve created mappings, you may want to
enable or disable them temporarily, depending
on the particular files that you are cataloging. 

1 Open the Mappings panel in the Advanced
Cataloging Options.

2 On a Mac, the small checkmark in the first
column indicates that a mapping is enabled.
Click in this column to toggle each mapping
on (with a checkmark showing) or off (no
checkmark). On Windows, double-click a
mapping to open the Edit Mapping dialog box
and change the State drop-down menu to On.

Remember, simply enabling a mapping in this
list doesn’t make it active. You have to set up
the mapping (as described above), linking it to
a specific custom field in your catalog, in order
to import tag data.

Adding a Tag ID Code to the Mappings list

The most common embedded tags found in
digital images are pre-set for you in Portfolio,
but you can import data from additional
embedded tags, as long as you know the proper
ID code for each tag. Here’s how you set up new
mappings:

1 As with existing mappings, you need to
create a Custom Field for each source file
tagged field that you want to map. 

Follow the steps described above in “How to
set up Mappings.”

2 In the Mappings panel of Advanced
Cataloging Options, click the Add button.

3 Enter the Tag ID Code, and enter a Title for
the Tag.
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Data is extracted using the ID Code. The tag
Title is informational—you can name the tag
anything you like.

4 Assign one of your custom fields to the Tag
by selecting it from the Field pop-up menu.

5 Set the State to On or Off, and select the
appropriate Action from the Action pop-up. 

6. Click “OK” to accept the settings and return
to the Mappings tab.

7 Repeat these steps for all the tagged fields
that you want to map.

Notes about Mappings:

• Mappings (that are enabled) are used both
when you add new items to your catalog, and
when you use the Update Items command to
update existing records.

• You cannot map to keywords or descriptions.

• Some tags are automatically mapped to
keywords or descriptions. These tag codes
cannot also be used to map to a Custom Field.

• You cannot map one tag code to multiple
Custom Fields (but you can map multiple tags
to a single Custom Field, using the Append
action.)

File Types

Portfolio is capable of cataloging virtually every
type of digital file, and by default the program is
set up to catalog all file types. But if you want
Portfolio to catalog only specific types of files —
such as JPEG or TIFF files — or to ignore (and
therefore not catalog) certain types of files, you
can set such limitations up in the File Types
panel.

You may, for example, want to catalog all the
digital photos on your hard drive, telling
Portfolio to ignore every file except the JPEG
and TIFF files that it finds. Or, you may decide
you want to catalog every file in a folder except
for font files. You can specify such exceptions in
the File Types panel. 

To exclude certain file types from being cata-
loged:

1 In the File Types panel of the Advanced
Cataloging Options dialog box, change the
radio button setting from Catalog All File Types
to Catalog only the Following Type.

2 In the File Types list, clear the checkmark
next to each file type that you don’t want
Portfolio to catalog by clicking on the check
mark.

To add a File Type to the list of files includ-
ed/excluded

You only need to add file types to the list if
you want to exclude a type that does not
appear on the list, or if you will be excluding
some types and including other types that
do not appear on the list. 

1 Click the Add button in the File Types panel
of the Advanced Cataloging Options dialog
box.

2 Enter the file type information, or click
“Same As...” and locate a file of the same type.
Portfolio will copy the parameters of this file
type into the fields.

3 Click “OK” to add this file type to the list.
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File Type Preferences

When you define File Types in Advanced
Cataloging Options, there are two checkboxes,
giving you the choice of storing file type
definitions in the catalog itself or as a user
preference on your computer, or both. 

Store in Preferences (Store “Locally” on
Windows): With this preference, your decision
to include or exclude certain file types will not
affect other Portfolio users who choose to add
items to the catalog. 

Store in Catalog: All users of this catalog will
include/exclude this type of file when
cataloging.

Exclude

Using the Cataloging Options Exclude tab you
can force Portfolio to ignore files with a specific
filename by creating an “exclusions” list that
specifies an explicit set of file names or patterns. 

To add a File Name to the exclusions list:

1 In the Exclude panel, select the file name
search parameter from the pop-up menu:
Begins With, Contains, or Ends With. 

2 Enter the filename or partial name that you
want to exclude from cataloging. Letter case
(uppercase/lowercase) is ignored.

3 Click “Add.” 

Portfolio searches each pathname and each
segment of the path for text strings matching
any of the parameters you enter. For example: If
you enter “Begins with: DUP” and “Ends with:
97” Portfolio will exclude “Duplicate_PH050,”
“Report_97,” and “C:\Duplicates\Image.jpg”

Creating Disk Previews
Normally, Portfolio allows you to preview each
item you catalog by directly opening the original
file and displaying a preview of it within
Portfolio. However, when cataloging files, you
also have the option of creating disk previews,
which allow you to preview images in Portfolio
without the original file being present. 

When Disk Previews is turned on, Portfolio
saves it’s own preview copy of each item in your
catalog — separate from the original file itself —
as a JPEG image in a location that you specify.
Using Disk Previews offers two advantages:

• You can preview items in Portfolio much
faster, because Portfolio doesn’t have to render
the file first. It simply opens the preview image.

• You can preview items that are offline. For
example, if you create Disk Previews, you can
view full-size previews of items cataloged from a
CD-ROM without the CD even being mounted.

Of course, using Disk Previews will slow down
the cataloging process (as Portfolio has to create
a preview file for each cataloged image) and will
require more space on disk, as Portfolio now has
to store a preview file for each cataloged item. 

Creating Disk Previews is an Administrative
function in Portfolio, meaning that you
must have Administrator-level access to
enable this feature. For more information
about Administration, see page 119.

To create Disk Previews:

1 Choose Catalog > Administration and open
the Previews panel in the Catalog
Administration dialog box.

2 Enable the Generate Previews checkbox.
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3 Click the folder button to select a location
for the preview images. This is where Portfolio
will store each preview file — one for each
item you catalog.

4 Set the level of Preview quality. This
determines the level of JPEG compression
Portfolio applies to the previews. Higher
quality previews will take up more space on
disk, but will be more faithful representations
of your original images.

5 Set a maximum size (in pixels) for the
preview images. The maximum size of the long
side of a preview image is 1000 pixels. You can
set the maximum size to any value between
100 and 999.

6 Click OK. Portfolio will now create a preview
JPEG file for each image that you catalog.

Generating disk previews for files
already cataloged

You can have Portfolio generate disk previews
for your files, even after they’ve been cataloged,
using the following procedure:

1 Turn on Generate Previews, as described on
the previous page.

2 Select the items in your catalog for which
you want to create disk previews.

3 Choose Item > Regenerate Thumbnail.

Disk previews also will be generated in you
have Generate Previews turned on when
updating an existing item in Portfolio.

Portfolio Preferences
Most of the user preferences contained in
Portfolio’s Preferences window (Edit >
Preferences) are discussed elsewhere in this User
Guide, in connection with the specific features
to which the preferences relate. However, some
of the preferences — those of a more general
nature — are summarized in this section.

Preferences — General

These options primarily relate to how Portfolio
displays thumbnails, shows previews and
handles the deleting of cataloged items.

Prompt to Save Untitled Galleries: When
selected, Portfolio will always prompt you to
save untitled (unsaved) gallery windows with a
dialog box like this:

If you leave this off, you’ll be able to open a
new gallery, then later close it without Portfolio
prompting you to save it.
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Confirm Delete from Catalog: By default,
Portfolio warns you with a confirmation dialog
box each time delete an item from a catalog, as
this is an irreversible action. If you don’t want
the warning, turn this check box off.

Show Welcome Dialog at Startup: Turns
off the Welcome dialog box that offers to open
an existing catalog or create a new catalog each
time you launch Portfolio. 

Autoplay Movie and Sound Files When
Previewed: When selected, movie and sound
files are played automatically in preview
windows; you don’t need to click the Play
button.

Fit Preview to Window: When selected,
images are automatically scaled to fit preview
windows. When unchecked, images appear at
100% and scroll bars appear in the window to
allow you to view the entire image.

Display Multipage Icon on Thumbnail:
When selected, a small multiple-page icon is
added to the lower right-hand corner of PDF,
PowerPoint®, and TIFF files that contain more
than one page.

Delete Key: Choose to have the Delete key on
your keyboard either delete items from the
catalog or the gallery.

Double-click Item to: This option allows you
to define how Portfolio behaves when you
double-click a thumbnail. You can have it open
the Item Properties window for the item, open a
preview of the item, or open the original item
for editing (using the file’s “parent” application).

Default Open Mode: Set your copy of
Portfolio to open catalogs in one of the four
access-level modes (Reader, Editor, Publisher, or
Administrator) described earlier in this chapter.
See page 119 for details.

Image Dimensions: Select the unit of measure
for displaying image dimensions. Applies to
displays in gallery and preview windows. Note
that pixels are the only unit of measure used in
height and width fields.

Cataloging Preferences

These preferences are explained in detail earlier
in this chapter, under the heading “Preferences
for Cataloging Options” on page 21

QuickFind Preferences

The QuickFind preferences are covered in
Chapter 8, under the heading “Customizing
QuickFind searches” on page 89.

Advanced Preferences

You probably won’t have to touch the Advanced
Preferences; the default settings are correct for
the vast majority of Portfolio users.

Index Node Size: This setting controls the
block size written to the Portfolio database. As a
rule, this number should be kept at 8K. (Older
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versions of Portfolio — prior to version 5.0 —
required a smaller node size of 1K.)

Language: Sets the sort tables that are used for
a catalog. If you create a catalog for a language
other than English, change the language here so
that values will sort properly in that language.

Use Aliases to Track Files: Available on the
Mac version of Portfolio only, this option causes
Portfolio to use aliases internally to track the
location of cataloged files. The benefit is that if
cataloged items are moved on disk, Portfolio can
track where they’ve moved — just as an alias in
the Mac OS can “follow” the movement of its
original parent file. Turning this option on may
make it easier for Mac users to track and find
cataloged items whenever they’ve been moved
on disk and it is necessary to update a catalog to
reflect those changes.
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One of Portfolio’s strengths is its ability to
display many different views of your files. You
can view large or small thumbnails, full-size
previews, or simple text-based lists of your
cataloged images. You can create views that
display many file details, or just the basics. You
can change the fonts, background colors, and
other attributes of gallery windows to give your
catalogs the look and feel you want. 

This section shows you how to completely
customize the Portfolio environment to create
catalogs that are styled and tailored to your
exact needs.

Customizing the Portfolio
environment
Portfolio offers an extremely flexible working
environment, with many options for
configuring and controlling the program’s main
components. Here’s an explanation of each part
of the main Portfolio window. 

The Toolbar. Contains buttons for several of
Portfolio’s main functions, including Find, Get
Info, E-mail and Collect. You can also use
buttons on the toolbar to switch between
Portfolio’s three main views: Thumbnail, Record
and List. 

Customizing Portfolio Catalogs

Folver View pane Gallery windowsStatus bar

Toolbar QuickFind box

The Portfolio Window



You can hide or show the Toolbar by
activating or deactivating the Toolbar
command in the View menu. 

QuickFind. One of the Toolbar’s most powerful
features is the QuickFind field. You can search
for items in a catalog based on information in
any searchable field simply by typing a string of
text in the QuickFind field and pressing Return.
You determine exactly which fields QuickFind
searches by configuring the QuickFind panel in
Edit > Preferences. See page for 89 for details on
using QuickFind.

Folder View. The Folder View window allows
you to display actual hierarchical folders from
your computer system or your network within
Portfolio. You can create, move and delete
folders on your system, and move files into and
out of them, without ever having to switch to
the Finder (Macintosh) or Explorer (Windows).
Folder View also lets you easily synchronize the
contents of any folder on your computer or
network with your Portfolio catalogs. For much
more on using Folder View and FolderSync see
the FolderSync section of “Managing Your Files
with Portfolio.”

Status Bar. In the Windows version of
Portfolio, you can hide or show the gray Status
Bar that runs along the bottom of gallery
windows by activating or deactivating the Status
Bar command in the View menu. On the
Macintosh, there is no Status Bar displayed
along the bottom edge of galleries, and no
corresponding command in the View menu.

Dockable palettes

Portfolio uses a system of dockable palettes to
display and access information when you’re
working with Portfolio catalogs. Each of these
palettes can be hidden or displayed by using the
corresponding Show or Hide commands in the

Window menu. The available palettes (and their
corresponding functions) are:

Catalogs. Displays a list of all catalogs you
currently have open, allowing you to easily
switch between them. The palette also lets you
specify which catalogs will be searched when
performing a Find in multiple catalogs.

Categories. This palette allows you to organize
your files into hierarchical categories and
subcategories. The folders displayed in the
Categories palette aren’t “real” folders on disk;
they’re just virtual folders within Portfolio that
allow you to organize groups of records visually.
For information about how to use Categories,
see page 84.

If you want to use portfolio to group your
images into real folders on your hard drive or
your network, use FolderSync instead of
Categories. 

Galleries. Displays a list of all the saved
galleries within the currently-opened catalog.
Galleries are windows containing specific
records within your catalog. For information
about how to use Galleries, see page 80.

Master Keywords. If you have administrative
access to Portfolio, you can set up a list of
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master keywords that can be used to organize,
group, and categorize the items in your catalog.
You define Master Keywords in the Keywording
panel of Catalog > Administration. See the
“Setting Up Master Keywords” section of
Organizing Your Files with Portfolio. Once
you’ve set up Master Keywords, you can assign
them to records using this palette, and retrieve
keyworded items using the palette’s Find
command.

Custom Fields. If, as the administrator of a
Portfolio catalog, you’ve defined any custom
fields that contain pre-defined values, each of
these value lists can be opened as a palette from
which you can both assign values to records and
find records that containing those values. See
“Displaying custom field as palettes” in Chapter
7. 

Any combination of these palettes can be
docked together to form a single, tabbed palette
by simply dropping one on top of the other, as
illustrated here. 

The Scripts menu

Portfolio offers extensive scripting support via
AppleScript on the Macintosh and via scripting
languages such as Visual Basic, Visual C++, Java
or any other scripting language that can be used
to access OLE Automation.

The Scripts menu appears in Portfolio only
when valid scripts of the types described above
are placed in a folder named “Scripts” located in
the same folder as the Portfolio application.

Scripts and applications located in the Scripts
folder are added to the Scripts menu and are
available as regular menu commands.

For information and examples on the scripting
interface for each platform, refer to the “Scripts”
folder on the Extensis CD.

Extensis Technical Support cannot provide
instruction on how to use the various
scripting languages.

Catalogs, Galleries and
Views
In order to understand your options when
customizing Portfolio catalogs, it’s important to
understand the relationship between catalogs,
galleries and views. 

A catalog is the entire database containing all
the items you’ve cataloged using Portfolio. You
can display all these items at once, or a subset of
those items based on a search or selection. You
can create multiple catalogs and open them
separately or at the same time. (Portfolio can
keep as many catalogs open as you like, limited
only by your computer’s memory. It can also
search for content in more than one catalog at a
time. See page 96 for details.)

Each individual window in Portfolio is called a
gallery. A gallery can display all of the items in
your catalog — or a subset of them. Suppose
you have 5,000 images in your catalog. Using
one of Portfolio’s search tools, you locate all
images tagged with the keyword “Ocean” and
find 135 matching images. In this case, you
have a catalog of 5,000 images, but a gallery of
135 images. 

With Portfolio, you can open and display more
than one gallery at a time. Each gallery is a
separate window or view into your catalog of
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images. You can also save a gallery — freezing a
particular subset of your images in one
particular window. Once you’ve saved a gallery,
you can open that subset of images and display
them in their own gallery window simply by
selecting the name of the saved Gallery from
the Galleries palette. A photographer may create
a catalog of his entire body of work, but save
one gallery containing portrait photos, and
another gallery containing landscape photos.
For information about saving and using
galleries, see the Using Galleries section in the
“Organizing Your Files with Portfolio” chapter.

Within each gallery window, you can also have
multiple views. A View is a combination of
attributes — background color, fonts, font color,
thumbnail size, grid spacing, and field data—
that determine the style of a gallery window.

All of these attributes can be changed using the
Customize View command and can be saved
permanently as Saved Views that you can then
apply to any gallery at any time. 

One catalog can contain multiple galleries, and
each gallery can be displayed using multiple
saved views. 

Thumbnail, Record, and List
Views

There are three main “types” of views available
in Portfolio, each of which can be customized to
create any number of unique custom views:

Thumbnail view

Thumbnail view, the default view in
Portfolio, displays your cataloged items in an
adjustable grid of small thumbnail-sized
previews, as shown in the figure in the left
column of this page. Information about each
cataloged item appears under each thumbnail. 

You can switch to Thumbnail view by clicking
the Thumbnail View button on the Toolbar
or by pressing �-T (Mac) or Control-T
(Windows).

By default, only the filename for each item is
shown in Thumbnail View, but you can choose
to display the contents of any Portfolio fields
under the thumbnails. Using the Customize
View command, you can also choose from four
different sizes of thumbnails, and select the
font, size and formatting used to display field
data. See “Customizing Gallery Views” below for
details on doing this customization.
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List view

List View displays the information you
have stored in your Portfolio catalogs in a
spreadsheet-style list format. By default, fields
such as the file size and type, modification, and
volume are listed, but this set of fields can be
edited using the Customize Views command
and you can specify exactly what field
information you want to appear in the columns
of the list.

When in List View, a panel appears at the
bottom of the gallery displaying the thumbnail
of the currently selected record, along with its
associated keywords and description.

Switch to list view by clicking the List View
button on the main Toolbar, or by pressing
�-L (Mac) or Ctrl-L (Win). 

Record view.

Record View allows you to view each
cataloged item along with any stored data
associated with it. In this view, you can see the
list of all the keywords associated with a file, for
example, or view an entire description, along
with any other custom field data you may have
entered. Choose Record View when you want to
access numerous details about a set of records
without having to open and view the properties
of each item one at a time.

The fonts, colors, thumbnail sizes, etc. of record
views can also be customized, as outlined in the
“Customizing Gallery Views” section below.

Switch to record view by clicking the Record
View button on the main Toolbar, or by pressing
�-R (Mac) or Control-R (Win). 

Record view options

All three of Portfolio’s main views— Thumbnail,
Record and List — allow you to do some basic
customization, tinkering with fonts, text sizes,
and background colors, for example. But Record
views have a few unique options, which you can
access in View > Customize.
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Display as List. By default, Record View
displays just one record at a time. Turn this
option on to view a scrolling list of Portfolio
records, each record with its own set of field
data displayed. This makes it easy to compare
records and move from one item to the next
when browsing records.

Show field names. Displays the name of each
field used in a record view. This option is on by
default, but turning it off makes record views
more visually compact. 

Edit. With this powerful option turned on, you
can edit field information as you work with it in
record view. For example, you can type in
descriptions, add or remove keywords, or fill in
other custom field values as you move from
record to record. 

Customizing Gallery Views
To customize thumbnail, list and record views,
choose either View > Customize (�-D on Mac;
Control-D on Windows) or Gallery > Customize
View to open the Customize Gallery dialog box. 

You can give each view in Portfolio a unique
look by customizing the thumbnails, fonts,
background colors, borders and spacing, as
outlined below:

Type

On Macintosh, use the font, size and style pop-
up menus to apply formatting to all text fields
displayed within the current gallery. On
Windows, click the Font button, then use the
Font, Font style, Size, and Effects lists in the
standard Font dialog box to select the desired
formatting. Don’t choose the Font color in this
dialog box; you set that using the Text Color
drop-down menu in the Customize Gallery
dialog box.

You can choose only one font, size and style
for all the field text displayed in any view.

Thumbnail size (available in
Thumbnail and Record views
only)

Choose from four different standard sizes, from
32 pixels by 32 pixels up to 256 pixels by 256
pixels. Note that Portfolio can’t display
thumbnails that are larger than the ones you
generated when you first cataloged your files. By
default, Portfolio generates thumbnails that are
112 by 112 pixels, so if you want to display 256
x 256 thumbnails in your catalogs, you must set
the Thumbnail size to the higher setting in the
Advanced Cataloging Options dialog before
items are cataloged, as explained earlier in the
previous chapter.

To generate larger thumbnails for items already
cataloged, set the Advanced Cataloging Options
the way you want, then choose Item >
Regenerate Thumbnail to force Portfolio to build
new thumbnails.
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Border (available in Thumbnail
and Record views only)

You can apply a graphic border, or frame,
around each thumbnail to give your Portfolio
catalog a unique look. To apply a border, choose
one of the pre-defined borders from the Border
menu. You can also create your own borders in
any graphics application.

Creating new borders

You can create a custom border from any
bitmapped image, such as a PICT, TIFF or BMP
file. Create the border in a graphics program
such as Photoshop, then simply copy and paste
the border into Portfolio to apply it in a custom
view. 

To add a custom border:

1 Create the border in a graphics application. 

To create borders that fit nicely around the
thumbnails, follow the pixel dimensions
shown in the following table:

Thumbnail size Border size

32 x 32 40 x 40

64 x 64 80 x 80

112 x 112 140 x 140

256 x 256 320 x 320

2 Set the transparency color of the border.

Portfolio looks at the center pixel of your border
image and sets that as the designated
transparency color. Any part of your border
that is the same color as the center pixel will
appear transparent. This allows you to create
borders that allow portions of the background
color to show through. If you don’t want the

background color to show through any portion
of your border, make sure the center pixel is a
color that isn’t used anywhere else in your
border design.

3 Copy the finished border image to the
clipboard in your graphics program.

If you’ve edited the image in a program
such as Photoshop, make sure you’ve
flattened the final image and that you’re
copying the whole image, not just a single
layer of it.

4 Paste the new border into Portfolio.

Open the Customize Gallery dialog box if it’s
not already open (�-D on Mac, Ctrl-D on
Windows) and from the Thumbnail options,
choose Border > Edit. Click New to open the
Define Borders dialog box. Then, click Paste to
paste the border image.

Alternatively you can save the border image
from your image-editing program as a
standalone PICT, TIFF or BMP file, and then
import the border into Portfolio using the
Import button in the Define Borders dialog
box.

5 Name the border and save it.

Type a name into the Border Name field and
click Save. Click OK in the Borders list to
return to the Customize Gallery dialog box.

6 Apply the border to a view.

Choose your newly-saved border from the
Border menu and click Apply.

Border files saved into the Borders folder in
the Portfolio 6 directory will be included in
all new catalogs that you create.
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Copying and pasting borders

You can copy custom borders from one Portfolio
catalog to another, allowing you to transfer your
favorite borders into a new catalog.

To copy a border to another catalog:

1 Open the Customize Gallery dialog box (�-
D on Mac, Ctrl-D on Windows) and from the
Thumbnail options, choose Border > Edit. 

2 Select the border you want to copy from the
saved borders listed in the Borders dialog box.
Click Edit.

3 In the Define Borders dialog box, click Copy
to transfer the border image to the Clipboard.

4 Paste the border. You can paste the border
into another catalog (as outlined in the
“Creating a new border” section above) or into
an image-editing program in order to modify
it.

Background color

Use this control to select a background color for
the current Portfolio gallery. 

Mac: Click the Background color swatch to
open the standard Mac color picker and select
the color you want. Click OK.

Windows: Choose one of the pre-defined
colors from the Background Color drop-down
menu, or choose Other from the menu to use
the standard Windows color picker to define a
new color, then Click OK.

Fields

In all three types of views — Thumbnail, List
and Record — you can choose exactly which
data fields are displayed on screen. You can also

determine the order in which those fields are
displayed.

Simply choose the field you want included in a
view from the scrolling list of fields in the
Customize Gallery dialog box.

To show or hide fields

In the Field list in the Customize Gallery dialog
box, select the fields you want to show. A
checkmark to the left of each field name
indicates that a field is activated; click in the
checkmark column to toggle fields on or off.

To change the order of fields

Drag the field names in the Field list into the
order you want.

Controlling the display of multi-line fields

Some fields, such as Description and Keyword,
can consist of multiple lines of text. When
customizing a record view, you can control how
many lines of text will be displayed on screen
without scrolling. 
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For such fields, the number of lines to be
displayed in record view is shown to the right of
the field name in the Fields list in the
Customize Gallery dialog box, as shown here.

To change the number of lines displayed for
each field:

Macintosh: For each field, click on the
number to reveal a pop-up menu. Choose a
number of lines to display, from 1 to 20.

Windows: For each field, click on the
number to open the Set Number of Rows
dialog box. Type the number of lines you’d
like to display and click OK.

Spacing (Thumbnail view only)

This setting controls the amount of grid spacing
(in pixels) between thumbnails. The default is 5
pixels. You can use any number between 0 and
99 to create a tighter or looser grid.

Thumbnail sizes

Choose from the four standard sizes: 256 x 256,
112 x 112, 64 x 64, or 32 x 32 pixels.

Saved Options

See the section on “Saved Options for a gallery”
on page 82 for an explanation of these options.

Setting a catalog to open at
startup

You can select one or more Catalogs to open
automatically each time you start Portfolio.

To set up a Catalog to open on startup:

1 With the catalog open, choose Catalog >
Open on Startup.

— or —

2 Open the Catalogs palette (Windows > Show
Catalogs). Highlight the catalog in the list,
then choose “Open Catalog on Startup” from
the palette fly-out menu.

A checkmark appears beside the menu
command indicating that this catalog will be
opened automatically when Portfolio is
launched. By turning this setting on in various
Portfolio catalogs, you can have multiple
catalogs open automatically each time you
launch Portfolio.

To stop a catalog form opening at startup, select
the Open on Startup command again to remove
the checkmark.
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Setting a catalog to stay open

Normally, a Portfolio catalog is automatically
closed if you close all of its gallery windows. But
you can force a catalog to stay open, even if all
of its windows are closed. This allows you to
search across multiple catalogs without needing
to have any gallery windows open.

To keep a catalog permanently open:

1 Open the Catalogs palette (Windows > Show
Catalogs). 

2 Highlight the desired catalog.

3 From the Catalog palette fly-out menu,
choose “Keep Open.”

Saving Your Customized Views

Once you’ve customized a gallery view —
changing fonts, background color, border,
hiding or showing various fields, and so on —
you can save all these attributes as a saved view.
You can then apply this view to any gallery in
your catalog at any time, using the Saved Views
menu. Several pre-defined saved views are
included as part of Portfolio’s default catalog
configuration.

To save a view:

1 Use the Customize View command (as
described in the previous section) to set up a
view exactly as you want it and apply your
settings to the current gallery window.

2 Choose Save (or Save As) from the Saved
Views pop-up menu, which is to the left of the
Sort menu on the status bar that runs along
the top of the gallery window.

3 Name the view and click OK.

4 The name of the saved view now appears in
the Saved Views menu.

To apply a saved view:

1 Choose the view by name from the Saved
Views menu, as shown here.

To rename or delete a saved view:

1 Choose Edit List from the Saved Views
menu. 

2 Select the view that you want to rename or
delete from the list, then click the Rename or
Delete buttons.

Setting a view as the default view

You can assign your current view as the new
default view for a catalog, so that Portfolio will
display that view every time the catalog is
opened. 

To set the current view as the default:

1 Choose View > Customize to open the
Customize Gallery dialog box. 
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2 Click the Save as Default button (in the
lower left corner).

3 Click OK to dismiss the dialog box. The
current view is now the default for the catalog.

Restoring Factory Settings

Click the Factory Settings button in the
Customize Gallery dialog boxat any time to
revert the view settings to those that were
originally set as defaults in Portfolio.

Background Cataloging
Instead of manually adding items to Portfolio,
you can automate the cataloging process by
designating “watch” folders or directories that
Portfolio will check at designated intervals. New
files dropped in these folders will automatically
be added to a catalog, and modified files will be
updated.

Overview of Background
Cataloging

When items are added to the designated
“watch” folder, they are cataloged automatically,
using the current settings in Cataloging Options
(Catalog > Cataloging Options). Only new or
modified items are cataloged. You can create as
many different automations as you like, and
specify a check frequency that the folders are
checked in increments that range from 5
seconds to 1 day.

When the Background Cataloging dialog
(Catalog > Background Cataloging) is opened,
Portfolio verifies the path to the Watch folder. If
a problem is encountered, an alert icon is
displayed next to the automation. The

automation cannot be enabled until the path is
corrected or changed. 

Running in Silent Mode

If you’re actually using Portfolio while
Background Cataloging is turned on, you
probably don’t want it interrupting your work
when it’s time for it to do its job. That’s what
“Silent Mode” is for — it keeps Background
Cataloging completely in the background.

Normally, when Portfolio catalogs items, it
displays a Cataloging Status dialog box, showing
its progress as it examines each item and
catalogs it. 

When you turn on the Run in Silent Mode
option in the Automations Settings dialog box,
cataloging will proceed without displaying the
Cataloging Status dialog box. 

When running in Silent Mode, newly cataloged
records will not be added to the active Gallery.
This allows you to perform other work in
Portfolio without being interrupted.

FolderSync vs. Background
Cataloging.

Don’t confuse Background Cataloging with
Portfolio 6’s new FolderSync feature.. Both
involve interaction between your Portfolio
catalog and the folders and files on your
computer or network, but they serve different
functions.

Background Cataloging simply automates the
cataloging process. It watches a folder and if
new files are added to the folder, it catalogs
them — no questions asked. Background
Cataloging is a one-way street; it brings new
items into your catalog, and never removes
them. 
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FolderSync also “watches” folders on disk, but it
does so in order to display these folders within
Portfolio and to help you manage the files they
contain. You can use FolderSync not only to add
new items to a catalog, but to create, move and
delete files and folders right from within
Portfolio. FolderSync alerts you to any changes
made in “watched” folders, giving you the
option of cataloging new items, removing items
or updating them — anything needed to “sync”
your catalog up with your files on disk.

To set up a Background Cataloging automa-
tion:

1 Choose Catalog > Background Cataloging. 

The Background Cataloging dialog is displayed.

2 Click “New.” 

The Automations Settings dialog is displayed.

3 Enter a name for the automation.

4 Click the Folder button (or Browse button)
and specify the folder that you want Portfolio
to watch and automatically catalog.

Note: Do not select the same folder for
Background Cataloging and Disk Previews.
Doing so will disable Background
Cataloging.

5 Turn on Include Sub-folder if you want
Portfolio to watch (and catalog) any folders
located within your target folder. Enable the
Run in Silent Mode option if you don’t want to
be interrupted by the Cataloging Status dialog
box while Background Cataloging automations
are running (see “Running in Silent Mode” on
the previous page).

6 When you have completed setting up the
automation, click “OK.”

7 Enable the automation by clicking to the left
of the automation’s name. Active Automations
appear with a checkmark next to them in the
Background Cataloging dialog box.

8 Click “Done.”

To enable existing Background Cataloging
automation(s):

1 Open the catalog for which you want to
enable the Background Cataloging automation.

2 Choose Catalog > Background Cataloging.
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Portfolio will check the pathnames for existing
automations and display an alert icon if any
problems were encountered.

3 Place a checkmark in front of each
automation that you want to enable.

4 Click “Done.”

Portfolio will begin checking the Watch folder
at the interval specified for the automation.

To clear an alert icon associated with an
automation:

1 Select the automation on the list, then click
Edit.

2 Click the Folder icon and relocate the
appropriate Watch folder.

3 Click Done to close the Automation Settings
dialog.

4 Reopen the Background Cataloging dialog
(Catalog > Background Cataloging) and verify
that the alert icon is no longer present.

Reopening the Background Cataloging dialog
forces Portfolio to recheck the path. If the
dialog is not reopened, Portfolio will have no
way of knowing that a correction has been
made.

Catalog Properties
You can view general information and statistics
about any catalog by choosing Catalog >
Properties to open the Catalog Properties dialog
box. Here’s what you can do with the Catalog
Properties dialog box:

• Get details such as the total number of items
in your catalog, total number of keywords used,
catalog size on disk, creation date, and so on. 

• View and copy the path to the catalog file on
disk.

• View all the keywords used in the Catalog,
along with their frequency.

To do this, select the Statistics tab, then click the
Calculate (Mac) or Calculate Now (Windows)
button. Portfolio lists each keyword and
indicates how many cataloged items have each
keyword assigned.

• Save all the keywords used in a document to a
text file. First click the Calculate button to
generate the keywords list. Then click Export
Keywords (Mac) or Save Keywords to File
(Windows) to save the list as a text file.
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Once you’ve created a Portfolio catalog and
filled it with your own digital files, there are
many tools at your disposal that make it easy to
view, organize and manage your work. This
chapter will tell you how to use Portfolio to
handle the following tasks:

• Preview images, audio and video clips and
other documents

• Get detailed information about each file

• Edit original files

• Rotate images

• Rename files

• Keep your catalog up to date

Previewing & Editing Files
Portfolio can directly open most image, movie
and sound files, allowing you to quickly preview
cataloged items. This saves you from having to
launch the programs that were used to create
the items in order to view them.

NOTE: Some file types cannot be previewed. If
Portfolio is unable to preview a file, a prompt
appears asking if you want to view the file using
the program that created it. 

To preview an item:

• Double-click a thumbnail in any gallery
window.
•Double-click any item listed in a List View

• Select the item, then press �-Option-I (Mac)
or Ctrl-Alt-I (Windows)

• Double-click a thumbnail in an Item
Properties window.

• Control-Click (Mac) or Right-click (Windows)
a thumbnail, and choose the Preview Original
command from the pop-up menu.

By default, Portfolio previews a file when a
thumbnail is double-clicked, but you can
have it open the Item Properties window or
edit the original file with a double-click
instead by changing this behavior in the User
Preferences dialog box. Choose Edit >
Preferences and in the first pop-up menu set
the result of a double-click to Show Preview
or Show Properties or Edit Original.

Unless items were cataloged using the Disk
Previews option (described on page 28 in the
“Setting up Portfolio” chapter), Portfolio must
be able to locate a file in order to preview it. If
the original file that was cataloged cannot be
found, Portfolio will prompt you to find the
missing file. If the cataloged file was on a
removable disk, such as a CD-ROM, Portfolio
will prompt you to insert the missing disk. 

If you want Portfolio to be able to show
previews of images that are offline (on a CD-
ROM that is on the shelf, for example) you
must use the Disk Previews features, as
described on page 28.

Managing your files with Portfolio
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The Preview Window

The Preview window has buttons that allow you
to zoom in, zoom out or fit the image to the
size of the Preview window. The Switch to
Original button is active only if you’re using
Portfolio’s Disk Previews feature, described on
page 28 in the Cataloging Options section.
Clicking it replaces Portfolio’s own JPEG preview
image with a fresh one created directly from the
source file. 

If you are previewing a multi-page document,
such as a PowerPoint document or PDF file, the
preview window has standard navigation
buttons that allow you to move from page to
page within the document.

Previewing audio/video files

When you preview audio or video files, a
standard QuickTime control bar appears in the
Preview window, allowing you to play back the
audio or video content. By default, playback
begins automatically when you open a preview
window.

If you don’t want audio and video files to play
back automatically when you preview them,

choose Edit > Preferences and turn off the
“Autoplay Movie and Sound files when
Previewed” option in the General preferences
panel.

Getting information about
your files
Portfolio stores very detailed information about
every file that you catalog. This information
includes data that Portfolio itself collects during
cataloging, such as each file’s creation date, file
size, image dimensions, file type, and so on. It
also includes information that you may add to a
Portfolio record, such as a description,
keywords, or other data that you may add using
custom fields.

All of this information is available in the Get
Info/Properties window. To open Item
Properties, select a thumbnail and click the Get
Info/Properties button on the toolbar, or press
�-I (Mac) or Alt-Enter (Windows). Switch
between the General, Keywords, and Fields tabs
to view the details for each file.

Make Item Properties open by default when
you double-click a thumbnail going to Edit >
Preferences and setting the “Double-click”
item preference to “Show Properties” in the
General panel.



Item Properties navigation
buttons

The four navigation buttons at the bottom of
the Item Properties window — First, Next,
Previous, and Last — allow you to navigate from
item to item in your catalog, so that you can get
information about each item in succession. This
makes it easy to access information about a
series of items, without having to repeatedly
open and close the Item Properties window.

You can also navigate from record to record in
Item Properties using the following keyboard
shortcuts:

To do this... Press this shortcut....

Move to next item Windows: Control-�
Mac: �-�

Move to previous item Windows: Control-�
Mac:�-�

Toggle between Control-Tab
General, Keywords
and Fields tabs

If you don’t have any records selected in the
current gallery window when you open Item
Properties, the navigational buttons (and
keyboard shortcuts) allow you to move
among all the records in the gallery. If you
do have certain thumbnails selected, the
buttons and shortcuts allow you to navigate
among the selected items only.

Editing information using
Item Properties
The Item Properties window isn’t just for getting
information. You can also use this window to
edit Portfolio records. You can add a description,
rename files, add keywords and fill in custom
fields using Item Properties. See the section on
“Organizing your Files with Portfolio” for details
on how to use Item Properties to edit records.

Rotating images
Portfolio can rotate JPEG images, making it easy
for you to switch your digital photos from
portrait to landscape orientation (or vice versa)
without having to open and edit the files
individually. This is especially useful if you’ve
cataloged a number of photos from a digital
camera and have a combination of horizontally
or vertically aligned photos that need to be
adjusted.

To rotate a JPEG image:

1 Select the item(s) you want to rotate. 

You can select an individual thumbnail or
select multiple thumbnails. (To select multiple
thumbnails, hold down the � key (Mac) or
Control key (Windows) while clicking on each
selection.

2 From the Item menu, choose Rotate Original
JPEG and select one of the three submenu
options: 90 degrees clockwise, 90 degrees
counterclockwise, or 180 degrees.

3 A progress dialog appears as each item is
rotated.
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For quicker image rotation, you can press 
�-] (Mac) or Control-] (Windows) to rotate a
selected image clockwise, and 
Command-[ (Mac) or Control –[ (Windows)
to rotate a selected image counterclockwise.

Portfolio rotates JPEG images only. To rotate
images saved in other formats, you must
open the files in an image-editing program
and perform the rotation in the editing
application.

Rotate Thumbnail only

Portfolio also gives you the option of rotating
only the thumbnail of any image, leaving the
original untouched. Follow the same procedure
outlined above for rotating an original JPEG
image, but choose the rotation commands from
the Item > Rotate Thumbnail sub-menu instead.

Editing original files
You can jump directly from Portfolio into any
other program in order to edit your cataloged
files.

To edit a file:

1 In any Portfolio gallery, select the item you
want to edit.

2 Choose Item >Original > Edit, or just press
�-E (Mac) or Ctrl-E (Windows).

3 Portfolio launches the program needed to
edit the original file and opens the file in that
program. 

Portfolio generally remembers the name and
location of the program last used to edit any
particular type of file. If necessary (such as the
very first time you attempt to edit a file of a

particular type) you’ll be prompted to choose an
application. Portfolio will remember the choice
in the future.

If you frequently use Portfolio to edit original
files, you might want to configure the
program’s preferences so that double-
clicking a thumbnail opens the original for
editing instead of previewing. Choose Edit >
Preferences and in the first pop-up menu set
the result of a double-click to Edit Original.

Moving, copying and
deleting files
You can move, copy, rename, and delete your
original files, all from within Portfolio. All of the
actions that you perform on your original files
can be accessed from the Original submenu in
the Item menu.

To copy a file:

1 In any Portfolio gallery, select the items you
want to copy.

2 Choose Item > Original > Copy

3 In the dialog box, choose a destination
folder for the copied item(s), then click Choose
(Mac) or OK (Windows).
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4 Portfolio copies the file(s) you selected to the
folder you specified. The original files remain
untouched. 

To move a file:

1 In any Portfolio gallery, select the items you
want to move.

2 Choose Item > Original > Move

3 In the dialog box, choose a destination
folder for the moved item(s), then click Choose
(Mac) or OK (Windows).

Portfolio moves the original file(s) to the new
folder location you specified and updates the
catalog, automatically recording the new
location of the cataloged items.

Copying items has no effect on your
catalogs. Moving a file, however, updates its
record in the Portfolio, with the path now
pointing to the file’s new location. 

Renaming Files

Portfolio provides five ways to easily rename the
original files that you catalog:

• You can rename files as you catalog them,
using the batch Rename feature in Cataloging
Options. This is useful for naming batches of
files imported from a digital camera or scanner.
See page 20 for details about using this feature.

• Rename an individual file by selecting a
thumbnail and choosing Item > Original >
Rename, and type a new name in the Rename
File dialog box. This command is also available
as a contextual menu within Portfolio, which
you can access by Control-clicking (Mac) or
right-clicking (Win) a thumbnail.

• Select a thumbnail and press �-Option-N
(Mac) or Control-Shift-N (Windows), then type
a new name in the Rename File dialog box.

• Open the Item Properties window for any item
in your catalog and to type a new name in the
Name field. To open Item Properties, select a
thumbnail and click the Get Info button on the
toolbar, or press �-I (Mac) or Alt-Enter
(Windows).

• During a Slideshow, click the Rename button
on the Slideshow controller and type a new
name in the Rename File dialog box. See pages
108-110 for information about creating
slideshows in Portfolio.

Linking to a new file
In certain situations, you may want to retain a
Portfolio record — including its description,
keywords, and other data — but link the record
to a completely different file. For example, you
might edit an image, then use the Save As
command to save the file under a new name.
You want Portfolio to point to the new version of
the file, but still retain all the information you
stored in the old record.

You can do this using the Link to New File
command, which lets you hook up any existing
item to a different original file. 

To link an existing item to a new original file:

1 Select the thumbnail of the item you want
to re-link.

2 Choose Item > Original > Link to New File.

3 Specify the new file.



4 Portfolio catalogs the file, which is now
linked to the existing item in your catalog, and
updates the record with any new information
(such as the new thumbnail image).

Removing items from a
catalog
Portfolio provides several easy ways to remove
items from a catalog. Keep in mind that deleting
an item from a Portfolio catalog does not delete
the original image; it simply removes Portfolio’s
internal record about the file. Your original file
remains untouched.

You can delete original files using Portfolio,
too. Use Item > Original > Delete. This will
remove the record from Portfolio and move
the original file to the Trash (Mac) or
Recycle Bin (Windows).  On the Mac, items
on a networked volume deleted in this
manner will be deleted without moving them
to the Trash.

To remove an item from a catalog (without
deleting the original file):

• Click the Delete button in the Toolbar. 

• Choose Item->Delete

• Control-click (Mac) or right-click (Windows)
on a thumbnail and choose Delete from the
contextual pop-up menu.

• Press the Delete key.

You can configure the Delete key action in
your Preferences to remove items from the
current gallery instead of actually deleting
them from the catalog. (To do so, go to Edit
> Preferences and in the General Preferences
panel, change the Delete key menu from
Remove from Catalog to Delete from
Gallery.)

The Confirm Delete warning

Whenever you delete an item from a catalog,
using any of the methods listed above, Portfolio
presents a confirmation dialog box to make sure
you’re performing the action you intended. The

dialog gives you the choice of deleting the item
from the gallery (making it invisible, but leaving
it in the catalog) or deleting it from both the
gallery and the catalog. 

If you don’t want to delete the item from either
the gallery or the catalog, click Cancel. 

If you meant to delete the original file on disk,
click Cancel, and choose Item > Original >
Delete instead.

If you don’t want the Confirm Delete warning
to appear each time you delete an item, you can
turn it off. Choose Edit > Preferences and clear
the checkbox for Confirm Delete from Catalog
in the General Preferences.
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Dragging cataloged images
into other programs
While Portfolio is the perfect tool for managing
and organizing your files, most of your creative
work probably happens outside of Portfolio — in
other programs that you use to edit images,
build documents, create presentations, lay out
pages for print publication, develop web
content, and so on. 

Moving from Portfolio to these other
applications is usually a simple drag-and-drop
affair. Here are some of the ways that you can
easily use Portfolio to work with images in other
programs:

• Drag a thumbnail into a drag-and-drop savvy
document (such as Word on the Macintosh) to
place a copy of the image in that document.

• Drag a thumbnail on top of an alias (or
shortcut) of an editing program, such as Adobe
Photoshop, Illustrator or Macromedia FreeHand

to open the image with that program.

• Drag a thumbnail to the desktop or a folder
window to move the original file to that
location.

• Option-drag (Mac) or Control-drag (Win) a
thumbnail to the desktop or a folder window to
copy the original file to the new location.

• Drag a thumbnail into an e-mail message to
send a copy of the image as an attachment.

• Drag a thumbnail into a QuarkXPress
document to place the image in an XPress
layout. If you drop the thumbnail on a picture
box, the selected image will be placed in the
existing picture box; otherwise, Portfolio will
create its own new picture box for the image.

Dragging thumbnails from Portfolio into
QuarkXPress requires the presence of QX-
Drag & Drop, an XTension that must be
installed in Quark’s XTension folder. The
Portfolio 6.0 Installer attempts to install
QX-Drag & Drop into the proper location
during the Portfolio installation process. If,
for any reason, this XTension was not
installed during the initial Portfolio
installation, you can copy to the XTension
folder yourself from the Portfolio 6.0 CD or
download it from the Extensis website.

The Portfolio Express palette provides an
even easier way to use your cataloged files in
other programs. The compact palette floats
above other document windows and can be
accessed from within any other program
with one keystroke. See the Portfolio Express
chapter for details.

53

Place images in your
documents by drag-
ging thumbnails into

any drag & drop
aware program 



Keeping Catalogs Updated
In order for a Portfolio catalog to be useful, it
has to accurately represent the actual files you
have stored on your computer and on your
network. This requires that you keep your
catalogs up to date, so that Portfolio knows the
location and status of every file in your catalog.

If you’re using Portfolio’s new FolderSync
feature, described in the next chapter, keeping
catalogs up to date is a breeze. Portfolio will
automatically watch the folders on your hard
drive or network containing your cataloged files
and alert you any time a file is added, moved,
deleted or edited. One click of the Sync button
brings your catalog up to date with the files on
disk. (See the next chapter for full instructions
on using FolderSync.)

Even without using FolderSync, though,
Portfolio contains several tools that make it easy
to update any item in your catalog.

Understanding Portfolio’s
“update” logic

When working with Portfolio catalogs, it’s
important to understand how Portfolio
determines whether a file is a new item (and
therefore needs to be cataloged) or is an
existing item that simply needs to be updated:

• If a file has a filename that does not match
any cataloged items, Portfolio considers it new
and catalogs it.

• If a file has a filename that matches an
existing item, but has a unique location (path),
Portfolio also considers it new and catalogs it.

• If a file’s name and location both match,
Portfolio recognizes it as an item that has
already been cataloged. It then looks at the file’s

modification date. Items with matching
modification dates are ignored (because they’re
identical to the items already in the catalog).
Files with different modification dates are
updated. 

Updating files that have changed

Some reasons why you might need to update
items in your catalog:

• You’ve moved, renamed, or deleted some of
the files, folders and volumes in your catalog.

• You’ve edited some files and so Portfolio’s
information about these files (such as size and
modification date) is no longer accurate.

• A cataloged image has been modified and the
thumbnail in Portfolio no longer matches the
actual content of the image.

Portfolio includes a suite of “update” commands
that accommodate each of these situations.

Updating to change file location

When a file has been moved to a new location
— but nothing else about it has changed — you
can update it quickly using the Change Path
command.

1 Select the item(s) for which you want to
update the path.

2 Choose Item > Change Path.

3 The Update Item dialog box opens,
prompting you to find the designated file in its
new location. 

4 Select the file, then click Select (Mac) or
Open (Windows)
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5 The item in Portfolio now points to the
correct location of the original file.

When you update a file using this method,
Portfolio automatically searches for other files
that need updating in the same directory and
offers to update them as well. If you turn on
the Search Subdirectories checkbox in the
Update Location dialog box, Portfolio will look
for matching files in the subfolders as well.

Updating path via drag-and-drop

If you know that you’ve moved some files that
are in your catalog, there’s an even easier way to
update the catalog with the new path
information — using drag and drop. This
method will work only if you’ve moved
cataloged files to a new location and have not
changed the filenames.

1 In the Finder (or Windows Explorer) select
the icons of the files that have been moved.

2 Hold down the Option key (Mac) or Control
key (Windows) while dragging the icons into
the Portfolio catalog.

Make sure you’re dragging the files into the
same catalog in which they were originally
cataloged before they were moved.

3 Portfolio presents a dialog, confirming that
you want to update the path of these files.

4 Click OK. Note that this updates the path of
the file only — not its thumbnail or any other
properties.

When you use this method, files are
matched by Filename in the Windows
version of Portfolio and by Filename and
Creation Date in the Mac version. Don’t use
this drag-and-drop method of updating on
Windows unless you are sure you don’t have
duplicate filenames in your catalog.

Updating to Extract Properties

In some situations, you may find yourself with
cataloged files that have been edited and now
contain new information — such as embedded
keywords — that is missing from the Portfolio
record. Or, you may need to extract properties
from files that were originally cataloged when
the Extract Keywords feature was turned off in
Advanced Cataloging Options. This can be done
easily using the Extract Properties command.
Extract Properties doesn’t worry about the file’s
thumbnail or modification date; it just goes
back to the original file, extracts any relevant
information it can, and adds or replaces the
information to the record in Portfolio.

1 Make sure you have your Advanced
Cataloging Options set the way you want, with
Extract Keywords and/or Extract Description
turned on.

2 Select the item(s) for which you want to
extract new information.
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3 Choose Item > Extract Properties.

4 Portfolio re-examines the file and updates all
“metadata” in connection with it, such as file
size, modification date, and embedded
information.

Portfolio will replace, merge or append data
based on the options you’ve chosen in the
Properties tab of Advanced Cataloging
Options. See page 23 for details.

Updating to Regenerate Thumbnails

This update command simply makes Portfolio
re-examine each selected file and build a new
up-to-date thumbnail image. It’s useful if you
originally cataloged items with the 112-pixel
thumbnail setting and now would prefer to
have 256-pixel thumbnails instead. 

This feature is also valuable for generating
(or updating) disk preview files for existing
Portfolio records if Generate Previews is
turned on in the Previews panel of Catalog
Administration. (For information about disk
previews, see page 28.)

1 Select the item(s) for which you want to
generate a new thumbnail.

2 Choose Item > Regenerate Thumnail.

3 Portfolio re-examines each file and generates
a new thumbnail for it.

Updating Everything

The Update command performs a complete
update of each selected record that has been
modified since you originally cataloged it,
confirming the location of each file (or asking
you to find it, if necessary), extracting properties
from it, and generating a fresh thumbnail. In

short, the Update command is the equivalent of
using Change Path and Extract Properties and
Regenerate Thumbnail. Note, however, that the
Update command only updates items that have
been modified since they were cataloged (as
indicated by a newer modification date).

1 Select the item(s) you want to update. To
update all items, choose Edit > Select All (�-A
on Mac, Ctrl-A on Windows).

2 Choose Item > Update, or press �-U (Mac)
or Ctrl-U (Windows).

3 Portfolio searches for each item’s source file
using the pathname stored in the item record.
If the source file is found, and its modification
date is more recent than the one originally
recorded in Portfolio, the record is updated. If
the source file cannot be found, you are
prompted to locate it. If you select a new file
for the selected item, the record is updated
with information from the new file, based on
your current Cataloging Options settings.

If the source file cannot be found and you click
“Skip File” when prompted to locate the file,
the selected record is left untouched.

Find Missing Originals

If your files get moved, renamed, or deleted after
you catalog them, it’s possible for Portfolio to
lose track of them. With the Find Missing
Originals command, you can easily locate any
such “lost” files and then either re-link them to
Portfolio — or strip them out of your catalog.

Portfolio searches for missing files on
mounted volumes only. If a volume
containing cataloged item source files is
not mounted, Portfolio will not report on
those files.
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To check for Missing Files:

1 Choose Catalog > Find Other > Missing
Originals, or press �-M (Mac) or Ctrl-M
(Windows).

Portfolio compares each item’s pathname as
stored in the catalog record against all
mounted volumes to see if the source file can
be found at that location. The results are
reported in the Missing Files dialog.

2 If Missing Files were located, select each
item, then click either the Update or the Delete
button at the bottom of the dialog to update
the catalog.

Update: Initiates a catalog Update and allows
you to manually locate the missing source file.

Delete: Deletes the item from the catalog.

You can select and update or delete multiple
items on the list. Press Shift while choosing
items from the list to select contiguously.
Press � (Mac) or Control (Windows) to
select non-contiguously.

Printing your catalogs
Although you will typically find and select a
catalog item either to edit the source file, view
it, or use it in another document, you might
want to print from the catalog itself—to show a
selection of images to a client, for example, or
to evaluate items for possible use in a
document. 

Choosing the Print command from the File
menu prints the contents of the active gallery
window. To print thumbnails or a list of catalog
items, select the items you want to include and
place them into a gallery window. Select the
appropriate gallery view (Thumbnail, List,
Record). Customize the gallery view just the way

you want it to appear, including sorting,
manually reordering items, borders, background
color, and so on. When the Gallery is set up just
the way you want it, choose File > Print.

Printing Options

In the Print dialog box, you’ll find the following
options:

Header/Footer: Fill in any text that you’d like
to appear as a header or footer in the printed
versions of your galleries. 

Margins: Set page margins in inches. The
default is 0.5 inches on the top, bottom and
sides of the page.

Page Numbering: You can turn page
numbering on or off, and set a starting number
by typing a number in the Starting Page
Number field (called “Number Pages From” on
the Mac).

Thumbnail Layout Grid: Allows you to
specify a layout grid size for printing. The
default is 4x4 — a page with 16 image cells, 4
across and 4 down.

Portfolio scales thumbnails to fit the grid
you specify. With a smaller grid setting
(such as 2x2) the thumbnails are likely to be
stretched to fit, potentially causing pixelated
images. 
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Print Using: You can opt to have Portfolio
print just the low-resolution thumbnails that
you have stored in your catalog (by choosing
Thumbnails in catalog) or full-resolution images
(by choosing Actual images). This choice is
available via a pop-up menu on the Mac, and as
radio buttons on Windows.

Quality: This setting determines how much
high-resolution data Portfolio uses when
printing images. The Best setting is a printer-
intensive task. Some printers are not equipped
with enough memory to support the amount of
data being downloaded to the printer. If you
experience problems, try switching to the
“Better” or “Good” setting.

Printing Single Images

You can print a single full-size image by
choosing File > Print from a Preview window.
However, for best results it is recommended that
you use the Edit Original command to open a
cataloged image in its original application and
print it from there.

Using DigiMarc
Watermarks
A Digimarc watermark is a special form of
embedded information that is invisibly
incorporated into an image file, generally
pertaining to copyright and licensed use of an
image. Digimarc watermarks can be detected,
displayed, and embedded directly by Portfolio.

You can have Portfolio detect Digimarc data
automatically when items are cataloged by
selecting this option from the Advanced
Cataloging Options window, as explained on
page 25.) 

Using the Read Digimarc ID command you can
have Portfolio examine a file for a Digimarc
watermark, then display information about the
watermark. When Portfolio displays the
Digimarc information you can click a button to
go directly to the Digimarc website to obtain
more information about the watermark’s creator.
You can also embed your own Digimarc
watermark in an image file.

Detecting watermarks

If you have your Advanced Cataloging Options
configured to detect watermarks, you can
display the Watermark status of each file by
displaying the Watermarked field in any gallery
view. (See page 40 to learn how to display a
specific field in a view)

If watermark detection is turned on and you
display the Watermarked field, each item in
your gallery will display one of three states:
Watermark Detected,Watermark Not Detected,
or Watermark Unknown.

Portfolio only detects watermarks in TIFF
and JPEG files that do not contain extra
channels.

Reading Digimarc watermark data

Reading a watermark is the process of extracting
and displaying the specific copyright, creator
and URL information contained in the
watermark. To read watermark data:

1 Select the item(s) for which you want to
display watermark information.

2 Choose Item > Read Digimarc ID.

If a single Gallery item is selected when you use
the Read Digimarc ID command, Portfolio will
display the watermark information as well as
record it in the item record.
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If more than one item is selected, Portfolio will
record the data in each item’s record and display
a summary of the results that includes how
many source files were scanned and how many
items were found to have watermark data
embedded in them.

Note: The Read Digimarc command can be used to
detect watermark data in any catalog access mode,
however watermark data will only be written to the
database in Editor, Publisher, or Administrator
mode.

Displaying the Digimarc Watermark URL: 

Most watermarks include a URL linking to the
Digimarc web site, where more information
about the watermark’s creator may be available.
To see this URL in Portfolio, customize your
gallery view so that the Watermark URL field is
one of the fields displayed. (See page 40 for
details about customizing views to include
specific fields.)

Embedding Digimarc
Watermarks

Portfolio allows you to embed a Digmarc
watermark directly into a file using the Embed
Digimarc ID command. Before you attempt this,
keep the following important points in mind:

• You must be registered with Digimarc and
have a unique Creator ID to be able to embed
watermarks. Visit the Digimarc website at
www.digimarc.com to register and get your ID.

• Portfolio can only embed watermarks in JPEG
and certain kind of TIFF files. Portfolio does not
embed watermarks in other file formats, in 16-
bit or multichannel TIFF files, including CMYK
images and grayscale images with alpha
channels.

Watermarks are permanent data stored in
your original files. It is strongly
recommended that you save unwatermarked
back ups of your images.

To embed a Digimarc watermark: 

Select the item(s) that you wish to have
watermarked.

Choose Item > Embed Digimarc ID

Enter your Creator ID and choose the data that
you want to embed in the file. This can include
a Copyright year, and an optional Content flag
that marks images as Restricted or Adult.

Configure the Durability and Target Output
settings for the watermark. For an explanation
of these items, see the watermarking_guide.pdf
on your Portfolio CD.

Click Embed to complete the process. Portfolio
will add the specified data to the selected
item(s).
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FolderSync is one of the most important and
powerful new features in Portfolio 6 — a
dramatic new tool that lets you synchronize the
contents of any folder on your computer or
network with your Portfolio catalogs — or vice
versa. 

What is FolderSync?
FolderSync creates a link between specific
folders on your computer system and items in a
Portfolio catalog. Once you add a folder to
FolderSync’s Folder View panel, you can move
items into that folder by simply dragging

thumbnails into the folder from within
Portfolio. Conversely, files that are moved into
that folder on your computer system (using
either the Mac’s Finder or Windows Explorer)
can automatically be cataloged in Portfolio, so
that the contents of your Portfolio catalog
exactly match the contents of your folders on
disk.

FolderSync does more than just display the
folders and files you have on disk; you can use it
to create, move and delete folders, too, so that
you can actually manage your disk files from
within Portfolio — putting your cataloged files
exactly where you want them.

Using FolderSync

Portfolio’s Folder View
exactly mirrors selected
hierarchical folders on
your system or network,
allowing you to manage
files from within Portfolio 
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Here are some of the typical ways you might use
FolderSync:

• Use Portfolio to organize your files on disk by
dragging thumbnails into folders from within a
Portfolio catalog. 

• Add an existing set of nested folders from your
hard drive (or network) to Portfolio’s Folder
View and then catalog the contents of all the
folders with one click of the Sync button

• Have Portfolio watch any number of folders
on your network and provide a visual alert every
time a file has been added, modified or deleted
from those folders.

• Move cataloged files from one folder to
another on your network, without having to
leave Portfolio or manually update your
Portfolio catalogs.

• Have other users in your workgroup add items
to a catalog by simply dropping files into folders
that are being watched by FolderSync; one click
of the Sync button will bring them into your
catalog. 

Displaying the Folder View
window
In order to use FolderSync, you must have the
Folder View pane displayed in the main
Portfolio window, as shown on the previous
page. If it isn’t already visible, choose View >
Folders to make the pane visible.

Initially, the Folder View pane is blank. Any
folders on your hard drive or computer network
that you want to keep synchronized with
Portfolio will appear in this pane after you add
them.

Adding a new root folder
To begin using FolderSync, you must tell
Portfolio which folder (or folders) on your
system you want it to “watch.” If you want
Portfolio to monitor a hierarchy of nested
folders, you have to point Portfolio to the “root”
or the topmost of the folders.

To add a new folder to Folder View:

1 Click the New button at the top of the
Folder View pane.

2 Select the folder on your system that you
would like to keep synchronized with Portfolio. 

A standard dialog box opens, asking you to
choose a folder. If you want Portfolio to monitor
an entire hierarchy of nested folders, select the
topmost (or “root” ) of the hierarchy. Portfolio
will automatically “see” the subfolders and
include them in Folder View. Click the Choose
button (Macintosh) or OK button (Windows) to
select the folder.

Folder View
pane



You can also use the New Folder button in
the dialog to create a new folder on your
system and add it to Portfolio’s Folder View.

3 The folder (or folders) you selected will now
appear in a hierarchical listing in the Folder
View. 

A root folder appears in Folder View with a
small “filing box” icon. 

4 Click the Sync button to synchronize the
contents of the newly-added folders with the
current Portfolio catalog.

Whenever you add a new folder to the Folder
View pane, its name initially appears in bold,
indicating that it contains files that have not
yet been synchronized with Portfolio. Clicking
the Sync button forces Portfolio to examine the
contents of the selected folders and catalog any
uncataloged items that are in the folder. 

If you add empty folders to the Folder View
pane, they don’t appear in bold, because
there are no files within them that need to
be synchronized with Portfolio.

5 The FolderSync dialog box appears, listing all
the files Portfolio will catalog in order to
synchronize with the folder. Click the Sync
button to continue the cataloging process.

Removing a root folder
When you remove a root folder from the Folder
View pane, Portfolio stops “watching” the folder
on disk, and no longer keeps the folder
synchronized with the contents of your catalog.

Removing a root folder doesn’t delete the
folder from your hard disk or network, nor
does it delete any of the files in it; it simply
“disconnects” the folder from Portfolio. 

To remove a root folder from Folder View:

1 Select the root folder you want to remove in
the Folder View pane.

Make sure you’ve selected a root folder and not
a subfolder.

2 Click the Remove  button at the top of the
Folder View pane.

Be sure to use the Remove button in the
Folder View pane, and not the Delete button
on the main Portfolio, which is used to
delete items from the Portfolio catalog itself.

3 Portfolio presents a warning that it will no
longer watch the root folder that you are
removing from the Folder View list. Click OK.
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4 The root folder no longer appears in the
Folder View list, meaning Portfolio will no
longer track its contents for you. The items
that were stored in the removed folder are not
deleted from the catalog.

Viewing the contents of a
folder using Folder View
Once you’ve added a root folder (from your
hard drive or network) to the Folder View pane,
you can use Portfolio to quickly view the
contents of any available folder inside that
folder, or in the root folder itself.

To view the contents of a folder:

1 Double-click a folder in the Folder View
pane.

2 Files in the selected folder appear in the
current Portfolio gallery.

To view the contents of nested folders:

1 Hold down the Option key (Macintosh) or
Control key (Windows) when double-clicking a
folder in the Folder View pane.

2 Files in the selected folder and all of its sub-
folders appear in the current Portfolio gallery.

NOTE: If the name of a folder in the Folder
View window appears in bold, it means that
files in the corresponding folder on your
system were added, removed or modified
since the last time you clicked the Sync
button. If you want your Portfolio catalog to
be updated to reflect those changes, click the
Sync button either before or after double-
clicking the folder. 

Moving files using the
Folder View pane
You can use Portfolio to easily move and copy
cataloged files in or out of any of the folders
that appear in the Folder View pane. In other
words, there’s no need to switch to the
Macintosh Finder or Windows Explorer to move
files from folder to folder as you organize them
— Portfolio does it for you.

To move an item into a folder using the
Folder View pane:

1. Drag the thumbnail of any cataloged item
into a folder displayed in the Folder View pane.

2. Portfolio automatically moves the file into
the corresponding folder on your computer
system and updates the Portfolio catalog to
reflect the file’s new location.
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3. The thumbnail of the file disappears from
the current gallery view to indicate that it has
been moved.

Moving files from one folder to another:

1 Double-click a folder in the Folder View
pane so that the files in the selected folder are
visible in the current Portfolio gallery.

2 Drag the thumbnail of any cataloged item
into another folder displayed in the Folder
View pane.

3 Portfolio automatically moves the file into
the corresponding folder on your computer
system and updates the Portfolio catalog to
reflect the file’s new location.

Moving files across volumes works just like
the Finder/Explorer, copying the files to the
new locations without deleting or moving the
originals.

Copying files using the
Folder View pane
To copy files from one Folder View folder to
another, hold down the Option key while
dragging the files on a Mac, or the Control key
while dragging files on Windows. This works
just as it does when copying files in the Finder
or Windows Explorer. 

When you copy a file from one Folder View
folder to another, you are making a
duplicate of that file — which will result in
two identical copies of the original file and
two records your Portfolio catalog. If you
don’t want duplicate files or records, be sure
to move the file, not copy it, as explained on
the previous page.

Creating new folders using
FolderSync

With FolderSync, you can create new folders —
or new subfolders of existing folders — right in
Portfolio and use these folders to group and
categorize your images on disk. There’s no need
to switch to the Macintosh Finder or Windows
Explorer to set up these folders. You can add,
delete and move folders on your hard drive or
network right in Portfolio’s Folder View pane.

To create a new root folder:

1 Make sure you don’t have any existing
folders selected in the Folder View pane. 

2 Click the New button at the top of the
Folder View pane.

3 In the folder selection dialog box, pick a
location for the new folder and click the New
button (Mac) or New Folder button (Windows).
Click Choose or OK to confirm the selection 

4 The folder you created will now appear as a
new root folder in the Folder View. 

To create a new subfolder:

1 Select one of the folders already visible in
the Folder View pane. 

2 Click the New button at the top of the
Folder View pane. 

3 A new folder is created as a subfolder of the
one you had selected.
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Synchronizing your folders

When the name of a folder in the Folder View
pane turns bold, it means that the files in that
folder have somehow changed since the last
time you synchronized the folder with Portfolio.
Among the possible “changes” that may have
occurred:

• A cataloged file was modified. 

• A file was removed from the folder using the
Finder (Mac) or Explorer (Windows). 

• A new file was added to the folder.

• An existing file was renamed.

To update your Portfolio catalog to reflect
any of these changes:

1 Select the folder in the Folder View panel
than needs to be synchronized. Only folders
with bold names require synchronization. To
select multiple folders that need to be
synchronized, just select the parent folder; the
subfolders will be included in the sync
automatically.

2 Click the Sync button. 

3 Confirm the changes that have been made
in the FolderSync dialog box.

The dialog box lists every change that has been
made in the folder since it was last
synchronized with Portfolio. Files that have
been removed appear with a red “X” while files
that have been added to the folder appear with
a green  “+” sign. Files that have been modified
or renamed appear with a yellow checkmark
next to their names.

If, for any reason, you don’t want Portfolio to
be updated to reflect these changes (the wrong
files were put in the folder by accident, for
example), click Cancel, and your Portfolio
catalog will remain unchanged.

4 Click the Sync button in the FolderSync
dialog box.

When you click the button, Portfolio catalogs
any new files in the folder, and updates the
records of any previously-cataloged files that
have been modified. Records for files that have
been moved or are otherwise missing are
deleted only if you turn on the Delete Records
for Missing Source Files checkbox at the
bottom of the dialog box.

5 The selected folder in the Folder View pane
should no longer be bold, as the contents are
now synchronized with the Portfolio catalog.

See the next page for important notes on
using FolderSync
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Important notes on using
FolderSync

• Synchronized folders may stay “bold” for a
few moments as Portfolio recans the folders in
the Folder View panel to confirm the changes
resulting from a sync.

This delay may be longer if many folders
and files are in the directories that are being
synced.

• If files have been removed from a folder and
you don’t turn on the Delete Records for
Missing Source Files checkbox in the FolderSync
dialog box when using the Sync command, your
folder will remain “unsynced” and in bold. This
is because Portfolio still contains a record for a
file that is no longer in that folder. To fully sync
up the folder, activate the Delete Records for
Missing Source Files checkbox and re-sync the
folder.

• When you rename a file outside of Portfolio
(using the Finder or Windows Explorer), the
renamed file will be considered a “new” file by
Portfolio when synchronizing. When you sync
the folder containing the renamed file, the
catalog record for that file — including its
keywords, description and any other stored data
— will be deleted and a new record will be
created for the newly-named file. For this
reason, we recommend using the renaming
features within Portfolio to make such changes.

• When you move a file from one FolderSync
folder to another outside of Portfolio (using the
Finder or Windows Explorer), Portfolio
recognizes the file has moved and turns two
folders bold — the one from which the file was
removed and the one to which it was added. You
must synchronize the parent folder of both of these

folders at the same time in order for Portfolio to
properly update the catalog. Otherwise, Portfolio
will delete the record for the file’s original
location and create a new record for the file in
its new location. While this will keep your
catalog up to date, it could result in you losing
information that was stored in the original
record. Portfolio will always update records
properly when you move files from one
FolderSync folder to another within Portfolio.

Switching to Windows
Explorer or the Finder
You can easily switch from Portfolio’s Folder
View to the Windows Explorer or Mac Finder to
see how your files appear in their actual folders
on disk.

Windows: Right-click on the name of any
folder listed in the Folder View pane.Choose
Explore from the pop-up menu that appears.

Mac: Control-click on the name of any folder
listed in the Folder View pane. Choose Reveal in
Finder from the pop-up menu that appears.
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One of the main purposes of Portfolio is to help
you sort, arrange, categorize and organize your
files. This helps you work more efficiently,
eliminates the problem of lost or misplaced files,
and streamlines the process of finding and
distributing your digital files on demand.

This chapter covers how to use the numerous
tools within Portfolio that help you organize
files with the minimum effort. These tools
include:

• Keywords

• Custom Fields

• Galleries

• Categories

• The Item Properties window

• The Edit Field Values window

Keywords
Keywords are descriptive words and phrases that
you can assign to your cataloged files in order to
categorize and classify them. If you had an
image of a tropical beach at sunset, for example,
you might assign it keywords such as Sand,
Beach, Ocean, Sunset, Tropical, Vacation,
Recreation, Outdoor, and so on. Any of these
terms would make it easier to group the image
along with other related images, and also make
it easier to search for the file. In Portfolio, there’s
no limit to the number of different keywords
that you can assign to a record. 

Adding keywords automatically

Even if you haven’t typed a single keyword in
Portfolio, the images in your catalogs may
already have at least some keywords. This is
because Portfolio includes two features that
keyword items automatically as they are
cataloged:

• Extract keywords. If you have this option
turned on, Portfolio extracts keywords that are
embedded in certain kinds of documents. Many
graphics programs (such as Adobe Photoshop
and Adobe Illustrator) allow you to include
embedded keywords when saving a file.) Images
in many stock photography collections are
keyworded in this manner. See page 23 for
information about using the Extract Keywords
feature.

• Create keywords from path. With this
Advanced Cataloging Option, Portfolio adds
keywords to each file you catalog, based on the
name and location of each file on disk. See page
24 for information about using this powerful
auto-keywording feature.

Seven ways to add keywords

Portfolio provides several convenient ways to
add keywords to the items in your catalog:

METHOD 1: Add them during cataloging 

Using Portfolio 6’s new Cataloging Options, you
can assign keywords to multiple items as they
are being cataloged. For details, see the
“Assigning keywords during cataloging” section
on page 18.

Organizing your files with Portfolio



70

METHOD 2: Use the Edit Keywords command

This method is useful if you have to add the
same keywords to a number of different files:

1 Select the item(s) to which you want to
assign keywords in a gallery window. 

2 Choose Item > Edit Keywords, or press �-
Option-K (Mac) or Ctrl-Shift-K (Windows).

The Edit Keywords dialog opens. All the
keywords that have already been assigned to at
least one of the selected items are displayed in
the keywords list.

3 Type a keyword in the text box, then click
Add.

The “State” of the keyword is changed to
“Add,” indicating that it will be added to the
catalog and assigned to the selected items.

You don’t have to click “Assign” after you
add a keyword—“Add” implies “Assign”
(that is, all keywords with either Add or
Assign in the State field will be assigned to
all selected items in the active Gallery when
the dialog is closed. “Add” just tells you it’s
a new keyword).

4 Click OK to when you’re done adding
keywords.

If you close the dialog by clicking Cancel,
the keywords you added will not be applied.

METHOD 3: The Item Properties window

You can add keywords to each individual item
through its Item Properties window (Choose
Item > Properties, or Item > Get Info/Properties
on the Mac). This method works particularly
well if you have different keywords that you’d
like to assign to each record. See the “Using the

Item Properties window” section later in this
chapter for details.

METHOD 4: Use Record View

You can also edit the keywords for any item
directly when you’re in a record view and have
the Edit checkbox turned on in the Customize
View dialog box.

To edit keywords in a record view:

1 Click anywhere in the Keywords field of the
record to activate keyword editing.

2 To add keyword, type it in the text entry
field, then click the “+” button. 

3 To remove a keyword, select it from the list,
then click the “-” button.

Turn the Edit option on when
customizing a record view and you can

add and remove keywords directly



You can edit any editable data field in
record view using this same approach.

METHOD 5: Keywording with Edit Field Values

Portfolio’s new Edit Field Values command
makes it easy to add, remove or replace
keywords across an entire selection of items.
For instructions on how to use it, see the
“Using the Edit Field Values command” section
later in this chapter.

METHOD 6: Use the Master Keywords palette

If the administrator of your catalog has created a
set of master keywords, these are available on
the Master Keywords palette. Choose Window >
Master Palettes > Show Master Keywords to
display the palette, or press �-K (Mac) or Ctrl-K
(Windows).

Setting up Master Keywords requires
Administrative access to the catalog. See the
Portfolio Administration chapter for details
on creating master keywords.

To assign a keyword from the palette:

1 Select the item(s) to which you want to add
a keyword.

2 Select the word on the Master Keywords
palette that you’d like to assign to the item(s).

3 Click the Assign button on the palette.

You can also drag and drop keywords from the
Master Keywords palette to assign them.

1 Drag a keyword from the Master Keywords
palette and drop it on any thumbnail to assign
the keyword to that item.

2 To assign keywords to multiple items, first
select the items in the gallery, then drop a
keyword on any one of the selected items. The
keyword is automatically assigned to all the
selected items.

METHOD 7: Drag and drop text

You can select text from any drag-and-drop
savvy program (such as Microsoft Word) and
drag the selection on to a Portfolio thumbnail to
assign the words in the selected text as
keywords. 

Five ways to avoid typing
keywords

If you find typing and entering keywords
tedious — and most users do! — take note that
several of the techniques referenced in this
section are specifically designed to keep manual
keywording to a minimum:

• Convert file and folder names into keywords
when cataloging (see page 24).

• Assign keywords during cataloging using
Cataloging Options (see page 23).

• Import an existing Master keywords list into
the Master Keywords palette (see page 124).
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• Drag and drop keywords onto thumbnails to
assign them (see page 71).

• Use the Edit Field Values command to assign a
keyword to multiple records (see page 78).

Removing keywords

There are four quick ways to remove unwanted
keywords:

Use the Edit Field Values command to remove a
keyword from a selected group of records. See
the “Using the Edit Field Values command”
section later in this chapter.

In the Keywords panel of the Item Properties
window, select a keyword, then click Remove.
You can Shift-click to select multiple keywords
or �-click (Mac) or Ctrl-click (Windows) to
select multiple non-contiguous keywords in the
list and delete them all at once.

In the Edit Keywords dialog box, select a
keyword, then click Remove.

In a record view (with Edit enabled) you can
select keywords and click the “-” button to
delete them.

Viewing Keywords

You can view the keywords associated with a
selected item in the following locations: 

• At the bottom of the gallery window in List
view (View > List).

• In any thumbnail, record or list view (View >
Record), if keywords have been included in the
view. 

• In the Keywords tab of the Item Properties
dialog (Item > Item Properties: Keywords)

• In the Edit Keywords dialog box (Item > Edit
Keywords).

When keywords are shown, the number beside
each keyword indicates how many items in the
catalog have that keyword assigned. 

Custom Fields
Custom fields allow you to store just about any
type of information you want — a date, a
number, a block of text, or a URL — about the
items you catalog, giving you much more
flexibility when it comes to organizing,
categorizing and searching for your files.

Custom fields are perfect for organizing your
files based on information that isn’t strictly a
“keyword” or a “description.” For instance, you
might want to add a field for a URL that points
to a web site related to the cataloged image, or a
“Photographer” field to a catalog of digital
photos, or a field to hold price information or
stock numbers.

Portfolio lets you create and use six types of
custom fields:

• Date/Time: Enter date and/or time values.
You could use this field type to create a Custom
Field for image publication dates, for example. 
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• Decimal: Enter decimal point numeric values.
This field type would be useful for custom fields
containing stock image prices.

• Integer: Enter regular numeric values. This
field type is ideal for custom fields containing
catalog part or stock numbers (as long as they
contain only numeric values).

• String: Enter single line text values. Can be
used for any number of custom fields, including
photographer or artist names.

• Text Block: Enter multiple lines of text with
line breaks. 

• URL: This field type is used for Web and other
URL addresses. It creates an active hyperlink
that can be displayed in gallery views.

Creating custom fields is an administrative
function in Portfolio. To create custom fields,
you must have Administrator-level access to
the catalog. See the “Portfolio
Administration” chapter for details.

Adding Custom Fields to a
catalog

To add a custom field, you have to open your
catalog in Administrator mode. To determine if
you’re in Administrator mode, pull down the
Catalog menu. If the Administration command
is dimmed out you’re not in Administrator
mode. Choose Catalog > Access, change the
Catalog Access level to Administrator and enter
the password if necessary, then Click OK.

2 Choose Catalog > Administration, or press
�-Option-J (Mac) or Ctrl-Shift-J (Windows).

3 Select the Custom Fields tab.

4 Click Add.

The Custom Field Definition dialog box is
displayed.

5 Enter a name for the field in the Name text
box.

6 Choose the field type from the Type pop-up
menu.

The field type determines the values that can
be entered into this field. (See the “Guide to
Custom Field Types below). NOTE: Field types
cannot be changed once they are defined.

7 Select the appropriate remaining options for
the field type you selected, then click “OK” to
return to the Custom Fields tab.

8 When you have finished adding Custom
Fields, click OK to close the Catalog
Administration dialog.

Guide to Custom Field Types

The following is a complete guide to the
attributes associated with each of the custom
field types you can create in Portfolio.

Date/Time: This field type allows you to enter
date and/or time values into your records. You
can elect to have Time values not displayed by
deselecting the “Display Time” option in the
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Date/Time Custom Field Definition dialog.
Date/Time fields include multiple values, and/or
can be configured as a predefined list.

Times are always assumed when searching
on Date/Time fields. That is, if a time value
has been entered into the field (either by
extraction from the source file when the item
was cataloged, or by entering a time in the
field) and then hidden by turning off
“Display Time,” the time will still be noted
by Portfolio when a search is generated. For
example: Searching for “5/20/02” will not
find a record which contains “5/20/02 3:00
pm” because the request is interpreted as
“5/20/02 12:00:00.” This is true even if the
time is not being displayed.

Decimal: In this field type, you can enter
decimal point numeric values with a precision
up to 8 decimal points. Decimal fields can
include multiple values, and/or be configured as
a predefined list. To set the Precision, select it
from the pop-up.

Integer: For regular numeric values. Integer
fields include multiple values, and/or can be
configured as a predefined list.

String: This field type is designed for single line
text values. You can specify a maximum string
length for the field by entering the number of
allowable characters in the Length text box. The
data in a String Field can be from 1 to 249
characters long, and include multiple values,
and/or be configured as a predefined list. String
fields cannot contain multi-lined text (for multi-
line text, use Text Blocks).

URL: This field type allows you to enter Web
and other URL addresses. If the syntax is correct
for a URL, the data will become an active
hyperlink on Windows, and on Mac OS systems
with Internet Config properly set up. To create

an active link, enter any reference in URL
format including: http, ftp, telnet, gopher, even
local files or applications. Typically URL data
might look like: http://www.extensis.com;
ftp://ftp.extensis.com/pub/file1.zip;
http://www.extensis.com/buynow/cgi?sku=0123
45; mailto:username@extensis.com. 

When you edit a URL to add data to it (Item >
Item Properties) the Title that you enter is
displayed in the record and becomes the active
link (Portfolio links the Title to the actual URL
in the URL field). You can give the URL any Title
you like—the Title does not need to refer to the
actual URL. 

Note: When importing data into a URL field
(Import > Field Values), Portfolio treats the URL
field as a multi-valued field with two values. The
first value is the Title and the second value is
the URL address. If you wish to import URLs
into Portfolio they must conform to this format.
Portfolio follows the same formatting when
exporting URL data. . 

URL fields cannot be set up with a
predefined list, cannot have multiple values,
and must have both title and URL fields
filled.

Text Block: Text Blocks are multi-lined fields
that can be any length up to 32K. This field type
allows you to add multiple lines of text to
records; you can include line breaks or carriage
returns. 

Text blocks are word-indexed, allowing even
these longer fields to be searched extremely
quickly. The Text Block field cannot be sorted or
phrase-searched.
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Multiple Value Lists

Multi-value lists allow you to specify custom
fields (except URLs and Text Blocks) that can
contain more than one value, such as multiple
vendor names or multiple item pricing. 

To set up a Custom Field with Multiple Values
turn on the Multiple Values checkbox when
setting up a custom field in the Custom Fields
Definition dialog box, as outlined on the
previous page.

Predefined Lists

With all custom fields (except URLs and Text
Blocks) you can set up predefined lists of values
so that users can select from your ready-to-use
choices when filling in a custom field. 

For example, suppose you create a custom field
called Status that you use to track the
completion status of each item in your catalog.
You might define four values — Preliminary, In
Progress, Final Review, Complete — and use
those values to label your images. Here’s how
you would set up the pre-defined values:

1 When defining the Status custom field, turn
on the Predefined List checkbox.

2 Click the Edit List button

3 In the Edit Custom List dialog box, enter
each of the four values you want to use in this
field; click the Add button to insert each item
into the list.

4 If you want only these four terms to be used
in this field, check the Allow only words from
List checkbox.

5 Click OK to finish defining the field.

Alternatively, you can import the values for a
predefined list from a text file. In the text file,

each value should be separated by a hard
return. Click the Import button in the Edit
Custom List dialog box to select the text file
and import the values into your predefined list.

Now, when users go to edit this field using any
of Portfolio’s standard field-editing tools (such
as the Fields panel of the Item Properties
window or the Edit Field Values dialog box, or
a record view in which the Status field is
displayed) the four predefined choices will be
available via a pop-up menu (Mac) or drop-
down menu (Windows), as shown here.

75



Editing and Using Custom Fields

Once custom fields have been defined, you can
edit them in your catalog using most of the
same methods discussed earlier in this chapter
for editing keywords:

• Add them during cataloging by assigning field
values in the Cataloging Options dialog box, as
explained on page 18.

• Open the Fields panel of the Item Properties
window and double-click on a field to edit its
contents.

• Customize a record view so that your custom
fields are visible and the Edit option is turned
on in the Customize View dialog box. See page
38.

• Use the Edit Field Values command to add,
remove or replace the content of any field across
a selection of records.

Displaying custom fields as
palettes

To make using custom fields even easier,
Portfolio has the ability to display the values
you set up in a predefined list as a palette —
similar to the Master Keywords palette described
earlier in this chapter. This allows you to easily
assign field values with just a few clicks — and
without having to open individual records.

When you create a custom field with a
predefined list of values, a new palette bearing
the name of that custom field automatically
appears in the Windows menu, under the
Master Palettes submenu. 

To use the example given earlier, creating a
custom field called Status with a list of four
predefined values would add a Show Status

command to the Window > Master Palettes
submenu, as shown here.

Choosing the Show Status command opens a
new palette called Status, containing the
predefined list of values that you can use in the
custom field.

Assigning custom field values using a palette

Custom field palettes (also called Master
Palettes) work exactly like the Master Keywords
palette described earlier:

1 Select the item(s) for which you want to fill
in a field value.

2 Select the entry on the custom field palette
that you’d like to assign to the item(s).

3 Click the Assign button on the palette.

You can also drag and drop the entries from
custom palettes on to thumbnails to assign
them.
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1 Drag a value from a custom field palette and
drop it on any thumbnail to assign the entry
to the corresponding custom field for that
item.

2 To assign values to multiple items, first select
the items in the gallery, then drop a custom
field palette entry on any one of the selected
items. The value is automatically assigned to
all the selected items.

Returning to the example of the custom field
containing job status: To assign 10 items in
your catalog the status of In Progress, you
would select those items in the gallery window,
click on the words “In Progress” on the Status
custom field palette (as shown above) and then
click the Assign button.

Editing and replacing
record information
Portfolio stores a great deal of information
about your files — keywords, descriptions, and
so on. This section covers the best ways to edit
that information — both on an item-by-item
basis and in batches.

Using the Item Properties/Get
Info Window

An easy way to quickly add and edit
information about your files is the Item
Properties window, described in the “Getting
information about your files” section on page
48.

Using the Item Properties window’s navigation
buttons and keyboard shortcuts, you can easily
move from item to item in your catalog, typing
descriptions and adding custom field data for
each record.

For example, suppose you need to add a text
description to the Description field of 25
different items in your catalog. Here’s how you
could use Item Properties to quickly add the
information

1 Select the thumbnails of the 25 items you
want to edit.

You can Shift-Click in a gallery to select a range
of thumbnails. To select multiple non-
contiguous items in a gallery window, �-Click
(Macintosh) or Control-click (Windows) the
thumbnails.

2 Open the Item Properties window.

You can do this by clicking the Get
Info/Properties button on the toolbar, or by
pressing �-I (Mac) or Alt-Enter (Windows). The
information for the first of your selected
images is displayed in the Item Properties
window.

3. Click in the Description field and type your
description.

4. When you’re done typing the description,
press �-Right Arrow (Mac) or Alt-Right Arrow
(Windows) to advance to the next record.
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The Item Properties window moves directly to
the next selected item, so you can type in the
next description.  

5. Repeat Steps 3 and 4 until you’ve filled in
the Description field for all 25 selected items.

You can use this same technique — navigating
from item to item within the Item Properties
window — to edit keywords and custom field
data for any cataloged file.

Batch record editing

The Item Properties window (described above) is
useful for editing field values for individual files
— typing a unique description for each file, for
example — but sometimes you need to edit add
or remove the same information for a number of
items. For example, you might want to:

• Assign the keyword “sunset” to 70 different
images at once.

• Add a photographer’s name to a custom field
for all 150 items in the current gallery.

• Clear all the descriptions and keywords for all
the items in your Portfolio catalog.

• Find all the occurrences of one particular
keyword and replace it with a different keyword.

To handle these tasks, use the Edit Field Values
command, described below.

Using the Edit Field Values
command

Edit Field Values is designed to speed up the
process of adding, removing and editing values
in virtually all editable Portfolio fields, including
Keywords, Description, and any of your custom
fields. 

To edit field values:

1 Select the thumbnails of the items you want
to edit.

The Edit Field Values commands operate only
on selected items. If you want to edit values in
all the records in a gallery, choose Edit > Select
All to select the entire gallery.

2 Choose Item > Edit Field Values to open the
Edit Field Values dialog box. 

3 Select the field you want to edit from the
Field to Edit menu.

All editable fields — including your custom
fields — are displayed in the menu.

4 Select an action from the Action radio
buttons. 

Depending on the field you choose to edit, you
can Replace, Delete, Add or Append data.

5 Specify the value that you want to add,
change, or delete in the Value field. In the case
of a Replace action, you have to specify both
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the value you’re replacing and the value you’re
replacing it with.

6 Click the Apply button.

Sorting records 
You can sort the contents of a Portfolio catalog
by most fields — including any of the custom
fields that you create. Sorting items by filename,
size, color mode, file type, or other criteria can
make it easier to browse through and organize a
collection of files. 

You can also sort items in your catalog into a
custom order by simply dragging thumbnails
into any position you want. Sorting via drag
and drop isn’t practical if you’re trying to put
a large number of files in a strict order, but it
can be useful if you simply want to rearrange
a smaller number of items into exactly the
order you want.

Sorting a gallery

To sort files, use the Sort menu available in the
upper right corner of the status bar that runs
along the top of each gallery window (right
under the main Toolbar). By default, this menu
simply says “Unsorted.” Choose any of the 22
criteria in the menu to apply a sort order to the
current gallery. (By default, galleries are always
sorted by the order in which items were
cataloged.)

After you’ve sorted a gallery using the Sort
menu, the current sort field remains displayed
in the menu, so you can see the sort order for
any gallery window at a glance.

Keeping a gallery permanently
sorted

If you want to keep a gallery permanently sorted,
you can set a sort order when you customize a
gallery view. 

1 Choose View > Customize to open the
Customize Gallery dialog box and switch to
the Saved Options pane.

2 In the Sorting section, turn on the Keep
Sorted checkbox.

3 Choose the field to use for sorting and sort
order (ascending or descending) from the pop-
up menus. 
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4 Click OK to apply the sort settings.

When you have the Keep Sorted option
turned on for a gallery window, the Sort
menu in that window is dimmed out. 

Organizing with Galleries
Another useful tool for sorting, grouping and
organizing files in Portfolio is to create and save
multiple galleries — separate windows that
allow you to display different groups of the
items contained in your catalog. Each gallery
can have its own style and sort order. (For a
general explanation of galleries, see page 35.) 

Opening a New Gallery

By default, a Portfolio contains only one gallery
— a single window displaying all your cataloged
items. At any time, however, you can open
additional galleries (windows) and select exactly
which items you want displayed in them. For
example, you may have a large catalog
containing 5,000 images, but would like one
window that contains only the 20 images that
you plan to use for a specific project. You can
create a new gallery to view those 20 selected
items. 

Creating multiple galleries has no effect on
the number of items in your catalog;
galleries are simply different windows into
the same catalog.

To open a new gallery:

1 Choose Gallery > New, or press �-G (Mac) or
Ctrl-G (Windows).

Alternatively, if you have the Galleries palette
displayed (Window > Show Galleries) you can

click the New button, or choose New from the
palette’s fly-out menu. An empty “Untitled”
gallery opens.

2 Fill the gallery with the items you want to
include in it. There are several ways to do this:

• Choose Catalog > Find All to show all your
cataloged items in the new window.

• Drag thumbnails from another gallery into the
new gallery.

• Use the Edit menu’s Copy and Paste
commands to copy and paste thumbnails from
another gallery into the new gallery.

• Use the Edit menu’s Cut and Paste commands
to cut items from one gallery and move them
into the new one. (Remember, cutting items
from a gallery doesn’t delete them from the
catalog; it just removes them from the current
window.)

• Perform a search for a selected set of records —
such as those containing a particular keyword.
(See the “Search Tools” chapter for details on
performing specific searches).

Saving a Gallery

After opening up a new gallery you have the
option of saving it — freezing a particular subset
of your images in one particular window. Once
you’ve saved a gallery, you can open that subset
of images and display them in their own gallery
window simply be selecting the name of the
saved gallery from the Galleries palette.
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To Save a Gallery:

1 Make sure the gallery window contains all
the items you want and and looks just as you
want it to be saved.

2 Sort or manually reorder the gallery items
exactly as you want them to appear.

3 Choose Gallery > Save, or press �-S (Mac) or
Ctrl-S (Windows).

The “Save Gallery” dialog box is displayed.

4 Enter a name for the Saved Gallery, then
click OK.

Your saved gallery will appear in the list of
galleries when you choose Gallery > List, and
on the Galleries palette.

To open a saved gallery:

1 Double-click the gallery that you want to
open on the Galleries palette (Window > Show
Galleries), or select the gallery name on the
palette and click the Open button.

— or —

1 Choose Gallery > List Galleries, or press �-
Option-G (Mac OS) or Ctrl-Shift-G (Windows)
to open the Saved Galleries list.

2 Double-click the the gallery that you want to
open from the list, or select the gallery name
and then click the Open button.

To rename a gallery:

1 Choose Gallery > List Galleries, or press �-
Option-G (Mac OS) or Ctrl-Shift-G (Windows)
to open the Saved Galleries list.

2 Select the gallery you want to rename and
click the Rename button.

3 Type the new name in the Rename Gallery
dialog box and click OK.

— or —

1 Select the gallery you want to rename on the
Galleries palette and choose Rename Gallery
from the palette’s fly-out menu.

To delete a gallery:

1 Choose Gallery > List Galleries, or press �-
Option-G (Mac OS) or Ctrl-Shift-G (Windows)
to open the Saved Galleries list.

2 Select the gallery you want to delete and
click the Delete button.

— or —

1 Select the gallery you want to delete on the
Galleries palette and choose Delete Gallery
from the palette’s fly-out menu.
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Making changes to saved galleries

If you make changes to a saved gallery —
finding a different set of items in the window,
or modifying the view settings, for example —
you’ll be asked if you want to save the changes
when you try to close the gallery. The options
are: 

Save: Overwrites the current Saved Gallery.

Cancel: Returns to the Gallery.

Save As...: Allows you to save the changes to a
new Gallery name, preserving the previously
saved gallery intact.

Don’t Save: Discards the changes and closes
the Gallery.

Saved Options for a gallery

Normally, a saved gallery contains a specific
subset of your files. But using the Saved Options
panel of the Customize Gallery dialog box, you
can create “dynamic” galleries that
automatically search and sort your current
records according to specific criteria. Using these
options you can create a gallery that:

• Automatically retrieves files based on a saved
set of search criteria when opened.

• Automatically sorts records based on a specific
field when opened.

• Automatically opens whenever you open the
catalog.

To set up these options, choose Gallery >
Customize View switch to the Saved Options
panel.

To set up a Find Gallery:

A Find Gallery is one that automatically
performs a saved search each time it is opened:

1 In the Saved Options panel of the Customize
Gallery dialog box, turn on the Load Saved
Find when Opened checkbox.

2 Select the search criteria that you want to
use from the Saved Find menu. 

In order to create a Find Gallery, you have to
have already created at least one Saved
Find. See page 94 in Chapter 8 for
instructions. 

3 Click OK, then save the gallery, as explained
in the “Saving a gallery” section earlier in this
chapter.

Each time your Find Gallery is opened, the
records will be searched and selected using the
Find criteria in the Saved Find that you
designated in step 2.

To set up a self-sorting gallery:

1 In the Saved Options panel of the Customize
Gallery dialog box, turn on the Keep Sorted
checkbox.

2 Choose the field you want to use as the sort
key from the Sort Order menu.
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3 Click OK, then save the gallery, as explained
in the “Saving a gallery” section earlier in this
chapter.

Each time this saved gallery is opened, the
records will automatically be sorted using the
sort order you specified. 

Setting a gallery to open at startup

You can set up your catalog so that a specific
gallery is displayed when the catalog is initially
opened.

1 In the Saved Options panel of the Customize
Gallery dialog box, turn on the Open at
Startup checkbox.

2 Click OK to save the setting.

— or —

1 Open the Catalogs palette.

2 Choose Open Gallery at Startup (or Display
Gallery on Open from the palette fly-out menu
on the Catalogs palette.

The specified Gallery will open automatically
whenever this catalog is opened.

Deleted Items in saved galleries

If items that are in a saved gallery are deleted
from the catalog while you are using a different
gallery, the items will still be displayed when the
saved gallery is opened. However, the thumbnail
will be appear as “Item Deleted.” To eliminate
the missing items from the Gallery, choose View
> Refresh, then resave the gallery.

Deleting Items from a Gallery

When items are deleted from a gallery, they are
removed only from the current view, not from
the catalog. This allows you to create galleries

that display exactly the images you want to see.
If you’ve searched for a set of images and found
that it contains a few images that you don’t
want to display with the others, simply delete
the ones you don’t want in the gallery. 

To delete items from a gallery (without
removing them from the catalog):

1 Select the item(s) that you want to delete.

2 Click the Delete button on the Toolbar. 

3 Select the Delete fromGallery radio button in
the dialog box, then click OK.

— or —

2 Choose Item > Delete. 

3 In the Confirm Delete dialog box, choose
Delete from Gallery, then click OK.

— or —

2 choose Edit > Cut. You can also press �-X
(Mac) or Ctrl-X (Windows).

The selected item(s) will be deleted from the
gallery window, but not from the catalog.

If you have your preferences properly
configured, you can also delete items from a
gallery by pressing the Delete or Backspace
key. By default, the Delete key removes items
from your catalog, but you can change the
delete key action to Delete from Gallery in
the General panel of Preferences. See page
38.
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Using Categories
Portfolio offers the ability to organize groups of
records visually, using a folder-like hierarchy
which is accessible through the Categories
palette. 

For example, you might want to use this feature
to:

• Organize all the versions of a job file, such as
low and high resolution images, RGB version,
CMYK files, etc.

• Arrange all the elements of a print job, such as
the document files, images, and fonts

• Categorize your image content using a system
of hierarchical “keywords” so that you have a
general category, (such as Animals) within
which is nested narrower topics (Birds) and sub-
topics (Waterfowl).

The Categories palette consists of a hierarchy of
folders that are linked to items in the catalog.
By double-clicking a folder icon on this palette

you can display all the cataloged items in a
folder and, optionally its subfolders.

Using options on the Categories palette you can
create the folder hierarchy manually, then drag
items from the catalog onto the Categories

palette folders to link them. Or you can catalog
an entire job of items in nested subfolders
automatically by dragging folders from the
desktop (Mac) or Explorer (Windows) directly
onto the Categories palette. When you drag
folders onto the Categories palette, items in
those folders are automatically added to the
catalog and linked to their respective category
folders (sub-directories become sub-categories).

By working with data the other direction—
dragging folders from the Categories palette to
the hard drive—you can create a copy of an
entire job (folders, subfolders, and the cataloged
contents), or any number of individual folders
and contents, on any local or network volume
in one easy step.

Categories vs. FolderSync

The Categories feature is similar to Portfolio 6’s
new FolderSync feature. Both Categories and
FolderSync help you organize your digital files
into an hierarchical folder structure — but they
take very different approaches to these tasks. 

The Categories feature uses a nested folder
structure to help you organize your files. But the
folders you see on the Categories palette are
virtual folders. While they can be based on a set
of folders from your computer system, they
aren’t real folders that exist on your network or
hard drive. They simply provide a way for you
to mentally group and organize files within the
Portfolio environment. There’s no “live” link
between the folders on your computer and the
“folders” in the Categories palette. When you
drag items into folders on the Categories palette,
nothing happens to the original files on disk;
they stay where they are.

The Categories palette also can generate a brand
new set of folders on disk that exactly mirror
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the hierarchy that you set up on the palette —
but it can’t move files into existing folders on
your system.

FolderSync, on the other hand, allows you to
organize your files in real folders on disk.
Double-clicking a folder in Portfolio’s Folder
View shows you the actual contents of that
folder on disk. With FolderSync, there is always
a “live” connection between Portfolio and the
folders on your hard drive or network. When
you move and group files in Portfolio using
FolderSync, you are moving the original files, in
real time, on your hard drive or network.
Foldersync isn’t just a categorization tool, it’s a
file management tool.

While the Categories feature is a powerful
organizational tool, most users are best
served by using FolderSync, which
organizes files both logically and physically
on disk.

Creating categories

To begin working with Categories, choose
Window > Show Categories to open the
Categories palette (as shown on the previous
page). You  must have Administrator access to a
catalog in order to create categories.

To add an existing folder to the Categories
palette:

1 Make sure the Categories palette is open. 

2 On your computer, use the Finder (Mac) or
Explorer (Windows) to locate the folder and
sub-folders that you wish to add to the
Category.

3 Drag the top-level folder from the
Finder/Explorer and drop it onto the

Categories palette in Portfolio, or onto another
folder on the palette.

The folder hierarchy will be recreated on the
Categories palette, and folder contents will be
cataloged and linked to the appropriate folders
on the palette.

4 Double-click a folder to display the cataloged
contents in a Gallery window.

To create a new category using the Categories
palette:

1 On the Categories palette, click the New
button or choose New from the palette fly-out
menu.

You will be prompted to enter a name for the
folder.

2 Enter the folder name, then click OK.

A folder is created at the selected level (below
the currently selected folder) on the Categories
palette.

3 Continue creating folders (steps 1 and 2)
until all the folders have been created.

4 Drag the folders up and down as necessary
until the folder hierarchy is as you like it.

Use the insertion bar to gauge exactly where to
drop each folder.

To remove a Category:

1 On the Categories palette, select the
Category that you want to delete, then click
the Delete button at the bottom of the palette,
or choose Delete Category from the fly-out
menu.
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Assigning items to categories

Once you’ve established categories, you can use
them to group cataloged files.

To link cataloged items to an existing
category:

1 Make sure you’ve got the Categories palette
open.

2 Select the item(s) that you want to
categorize, then drag and drop them into the
desired category on the Categories palette. 

The selected Gallery items will be linked to the
folder.

— or —

1 Select the items in the gallery. 

2 On the Categories palette, select the target
category.

3 From the Categories palette fly-out menu,
choose Apply Records to Category.

The selected Gallery items will be linked to the
category “folder.”

To display cataloged items in a specific
category:

1 Double-click the desired category folder on
the Categories palette.

2 Items in the selected folder will be displayed
in the Gallery. If you want to display items in a
Category and all sub-categories, choose Show
Records in Sub-categories from the palette fly-
out menu.

Items in the selected folder and all sub-folders
will be displayed in the Gallery.

To remove cataloged items from a category:

1 Select the items that you want to remove
from the category.

2 Click the Remove button on the Categories
palette, or choose Remove Records from
Category from the fly-out menu.

The selected catalog items will be removed from
the category folder, but not from the Gallery or
Catalog.

Creating folders on disk

After you’ve categorized you files, Portfolio can
replicate your organized folder structure on disk.
Note that this process doesn’t move your
original files; it makes copies of your files in a
new location, based on the folder structure on
the Categories palette.

To create a category-based file and folder
structure on disk from your Categories:

1 On the Categories palette, select the top-
level folder that you want to create the
Category from.

2 Drag the folder to the Finder (Mac) or
Explorer (Windows).

A dialog is displayed asking if you want to create
one folder for all the items, or if you prefer to
maintain the folder hierarchy.

— or —

1 Choose Create on Disk from the palette fly-
out menu, then choose a folder where you
want the items to be stored.

2 Click Create one folder to have all items
placed in a single folder, or Create all folders to
maintain folder hierarchy.
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Portfolio will create new “real” folders on disk
that correspond with each of the folders on the
Categories palette and a copy of each original
file will be placed in the appropriate folder. 

Generating Categories automatically

Portfolio allows you to create categories
automatically based on the names of the folders
that contain the files you catalog. 

To illustrate: Suppose you have a file stored in a
folder called September, which is nested inside a
folder called Current Assignments. If you have
Create Paths as Categories turned on in the
Advanced Cataloging Options, then when you
catalog the file, Portfolio will automatically
create categories called September and Current
Assignments, — and will link the cataloged file
to those categories. 

You must have Administrator-level access to a
catalog in order to generate categories. 

To set up the Create Paths as Categories,
read about the Advanced Cataloging
Options on page 25.
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One of Portfolio’s most important functions is
to help you search for and retrieve your digital
files when you need them. When you think
about it, the whole point of cataloging,
keywording and categorizing your images is so
that ultimately you’ll be able to find and use
them as quickly as possible.

This chapter covers the various powerful tools
available within Portfolio to perform lightning-
fast searches that give you access to the files you
need on demand. This will cover:

• Using the Toolbar’s QuickFind field

• Performing advanced, multi-criteria searches

• Searching across multiple Portfolio catalogs

To quickly find your cataloged files when
you’re not running Portfolio or when you’re
working in other programs, such as Adobe
Photoshop or QuarkXPress, use the Portfolio
Express palette, as described in the next
chapter. The Portfolio Express palette is the
quickest way to grab the files you need for
use in other programs.

QuickFind
The easiest and most accessible search tool in
Portfolio 6 is the new QuickFind box, located on
the right side of the Toolbar. QuickFind allows
you to search for files based on the content of
any combination of fields, without having to click
a button, pull down a menu or open a Find
dialog box. It’s the fastest, easiest way to
perform a file search. 

To perform a QuickFind search:

1 Click in the QuickFind box

2 Type a word or phrase in the box and press
Return.

By default, QuickFind searches the filename,
description and keyword fields, using a
“contains” search. To change the fields that are
searched by QuickFind, see “Configuring
QuickFind Preferences” below.

3 Matching items appear in the current
Portfolio gallery.

TIP: The text you’ve typed in the QuickFind box
remains selected after you’ve pressed Return and
performed a search. To do another QuickFind
search, all you have to do is type another search
word or phrase and press Return again. 

Customizing QuickFind searches

You can choose exactly which fields QuickFind
includes (and which it ignores) when doing
searches by adjusting the QuickFind Preferences.
This is what makes the QuickFind so powerful;
you can “tune” it to perform any multi-field
search you want. The settings you choose in
QuickFind preferences, also affect the QuickFind
box in the Portfolio Express palette (explained
on page 61.)

Finding files with Portfolio

QuickFind box in
the Toolbar
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Changing the QuickFind Preferences:

1 With a catalog open, choose Edit >
Preferences, and switch to the QuickFind
panel. 

2 In the list of fields, choose the ones you
want to include in QuickFind searches by
clicking next to them. 

Fields included in a QuickFind search appear
with a checkmark next to them. QuickFind
searches the filename, description and keyword
fields by default. Turning on the “QuickFind
opens new Gallery” checkbox causes the results
of a QuickFind search to be displayed in a new
gallery window.

3 Click OK to confirm your settings.

QuickFind preferences are saved on a
catalog-by-catalog basis. In other words,
each catalog has its own QuickFind
preferences and has to be configured
separately. This also means that all users
who have shared access to a catalog have to
use the same QuickFind settings.

Searching from palettes
The Master Keywords palette and any other
palettes you may have created from custom
fields (see page 76) also provide an easy way to
perform simple searches without having to open
any dialog boxes. 

To search from the Master Keywords Palette,
locate the desired keyword on the palette, then
click the Find button, or just double-click the
keyword. All items with the selected keyword
will be displayed in the active gallery window. 

On Windows, select any word on the Master
Keywords palettte, then type the first letter
of the keyword that you want to find to
jump right to it. On Macintosh, type a letter
in the text entry field of the palette to move
the cursor to the entries starting with that
letter.

For super-fast 
keyword searches:
Double-click a
keyword on the
palette



On any other palette created from a custom
field, just double-click any value on the palette
to find items in your catalog that contain that
value (or select a value and click the Find button
on the palette).

Using the Find Command
For many Portfolio users, the simple multi-field
search possible using the QuickFind box is all
that is needed. However, Portfolio’s
sophisticated search engine can also perform
complex searches using multiple criteria.
Complex searches can be saved so that queries
can be performed again with a minimum of
effort.

Portfolio’s Find command allows you to search
any fields in any combination, with specific
search parameters. Portfolio can display the
results of the search in the current gallery
window (completely replacing the previous
contents, if any), or in a new gallery window.

There are three ways to access the Find window:

• Click the Find button on the toolbar.

• Choose Catalog > Find.

• Press �-F (Mac) or Ctrl-F (Windows).

Finding all items

There are four ways to quickly find all the
items in the current catalog:

• Choose Catalog > Find All.

• Open the Find window and click the “Find
All” button.

• Open the Finds palette and click the Find All
button.

• Press �-Option-F (Mac) or Ctrl-Shift-F
(Windows).

Searching for specific items

1 Open the Find window (using one of the
three methods described above) and make sure
you’re on the Criteria tab.

2 Select the criteria you want to use for the
search by choosing a search field from the Field
menu, as shown here.

See the table on the next page for a description
of the attributes you can use in your search. 

3 Select a match option from the middle
menu. 

There are anywhere from 8 to 14 different
options, depending on the field you’re
searching. You can look for perfect matches
(such as “equals” or “matches”) or less rigid
matches (such as “contains” or “does not end
with”).
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Search option... Finds this...

Cataloged The date and time that an item was first cataloged in Portfolio

Color Mode Color modes: Unknown, Black & White, Grayscale, RGB, CMYK, YUV, Lab, 
and YCCK

Created The date the original file was created

Extension Win The item’s three-character file extension

Description The item’s file description

File Size The item’s file size

Filename The item’s name

Height The item’s height, in pixels (empty if thumbnails were extracted)

Width The item’s width, in pixels (empty if thumbnails were extracted)

Horizontal Resolution The item’s horizontal resolution, in dpi

Vertical Resolution The item’s vertical resolution, in dpi

Keywords Any keywords assigned to the item(s)

Last Modified The date the original file was last modified

Last Updated The date the item was last updated in the catalog

Creator Mac The four-character file creator code for the item (empty if cataloged on 
Windows)

File Type Mac The four-character file type code for the item (empty if cataloged on 
Windows)

Zone Mac AppleTalk Zone where item’s file is located (empty if cataloged on 
Windows)

Path The file path (location) for the item., including the filename

Short Filename Win 16-bit DOS path and filename
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Search option... Finds this...

Thumbnail Size The item’s thumbnail size, in pixels: 32 (icon), 64, 112, 256. (This field 
will be empty in catalogs converted from earlier versions of Portfolio)

Multipage Count Items matching a particular page count

PlaceHolder Items created as PlaceHolder Records

Watermarked Items with the indicated watermark

WatermarkURL Items with the indicated watermarkURL

Custom Fields Any custom fields that have been created for the current catalog

Volume The physical drive or disk on which the item resides

Directory Path The full directory path for an item, not including the filename
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4 Select the other Find options.

The three checkboxes in the dialog box
determine where Portfolio searches for your
items and how it displays the results. The
options are:

Find in Gallery: If you turn on this checkbox,
Portfolio will search only the items that are in
your current gallery, ignoring all other records
in your catalog. This is useful for doing
progressively narrower searches to zero in on a
target file. If you want Portfolio to scan every
item in your catalog for possible matches, make
sure this option remains unchecked.

Display Results in New Gallery: Creates a
new window (gallery) for the find results. If you
don’t turn this on, found items are displayed in
the current gallery window, replacing the items
that were there.

Search Multiple Catalogs: This option is
dimmed out unless you have more than one
catalog opened. If you do have two or more
catalogs opened, you can turn this on to have
Portfolio search all the opened catalogs for
matching items. See “Searching Across Multiple
Catalogs” later in this chapter for details.

5 Click Find to start the search.

Searching using multiple criteria
(complex searches)

The Find window also allows you to perform
more complex searches based on multiple
criteria — matching file type, creation date and
keyword, for example.

To perform a complex search:

1 In the Find window, click the More Choices
button to expand the window to include
addition criteria.

You can expand the window to include up to
five different lines of search criteria.

( After expanding the window, you can click the
Fewer Choices button to shrink the window for
simpler searches.) 

2 Configure the search criteria as described in
Steps 2, 3 and 4 in “Searching for specific
items” on the previous page.

3 Set the “And/Or” menu for each search line
as needed to refine your search.

4 Click Find to start the search.

Saving Finds
If you routinely need to locate particular types
of items in a catalog, you can name and save a
Find that will retrieve those items.

Your saved finds appear in the Saved Finds pop-
up menu in the Find window. Whenever you
want to use a Saved Find, choose its name from
the menu or select the Find from the pop-down
menu using the Saved Finds button on the
Toolbar, or double-click the saved find on the
Finds palette.

To save a Find:

1 Set up your search in the Find dialog box, as
described above.
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2 Choose Save As from the Saved Finds pop-up
menu. 

3 Type a name for the new find in the Save
Find dialog box.

4 Click OK to return to the Find window.

Portfolio stores the search definition you just
created in the catalog.

To use a Saved Find:

You can activate a Saved Find in several ways:

• Choose the Saved Find from the Saved Finds
menu in the Find window.

• Choose the Saved Find from the pop-down
menu on the Toolbar, as shown here.

• Open the Finds palette (Window > Show
Finds) and double-click the name of a Saved
Find on the palette.

• Select a Saved Find on the Finds palette, then
either click the Find button, or choose Find
from the palette’s fly-out menu.

• “Attach” the Saved Find to a Saved Gallery, so
that opening the gallery automatically runs the
find. (To do this, go to the Saved Options panel
in the Customize Gallery dialog box and turn
on the Load Saved Find when Opened
checkbox; see “Saved Options for a gallery” on
page 82.)

To change the attributes of a Saved Find:

1 From Criteria panel in the Find window,
choose the Find you want to change from the
Saved Finds pop-up menu.

— or —

1 From the Finds palette, choose the Find you
want to change and the choose Edit Find from
the fly-out menu.

2 Modify the search criteria using the standard
Find dialog options, then choose Save from the
Saved Finds pop-up menu.

To Rename, Duplicate, or Delete a Saved Find:

1 From Criteria panel in the Find window,
choose Edit List from the Saved Finds pop-up
menu.

2 In the List Saved Finds dialog box, select the
Saved Find that you want to edit. 

3 Click the appropriate button to Rename,
Duplicate or Delete the Find.

4 Click OK to return to the Find window.

— or —

1 From the Finds palette, select the Find that
you want to rename or delete. 

2 From the fly-out menu, choose Delete Find
or Rename Find.
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The Default Find

Each time you open the Find window (or
choose Default from the Saved Finds pop-up
menu) Portfolio populates the search fields and
pop-ups with the attributes specified in the
Default Saved Find. You can edit the Default
Find so that the Find command will be preset to
retrieve the items you use most often. 

To change the Default Find:

1. Open the Find window and set up the search
fields as you want them to be by default.

2. Choose “Save as Default” from the Saved
Finds pop-up.

Searching Across Multiple
Catalogs
One of Portfolio’s most powerful searching
features is its ability to find items by searching
multiple open catalogs. 

Portfolio can only search through open
catalogs. If you want a search to span
multiple catalogs, make sure the appropriate
catalogs are open.

To search multiple catalogs:

1 Open all catalogs that you wish to include in
the search.

Open catalogs will be displayed on the Catalogs
palette and on the Catalogs tab of the Find
window (Catalog > Find). 

You do not need to include a catalog in a search
just because it is open, but you cannot search
through closed catalogs.

2 On the Catalogs palette or in the Catalogs
tab of the Find window, select the catalogs that
you want to include in the search.

A magnifying-glass icon to the left of a catalog
name indicates that the catalog will be
included in the search. No icon indicates that
the catalog will be excluded from the search.

3 In the Find window, enable the Search
Multiple Catalogs checkbox in the Criteria
panel.

4 Configure the search parameters in the Find
window (just as you would for a standard one-
catalog search) and then click Find.

5 The results of the multi-catalog search will
be displayed in a new gallery window called
Items Found. Because this gallery contains
items from more than one catalog, it can’t be
customized or saved. The temporary Items
Found gallery window does allow you to
preview any of the found items, view
properties and locate the original files.
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Finding Placeholder Items
You can easily locate all of the placeholders that
you created so that you can keep track of which
placeholders you have created, update one or
more placeholders from the source file, or delete
them if they are no longer needed.

For information about creating and using
Placeholder Records, see pages 15-16.

To find all Placeholder records, choose Catalog >
Find Other > Placeholder Items. A new Gallery
will be opened, and all the Placeholder records
will be displayed.

Finding Document Text
The Find Document Text command allows you
to find words or phrases within the text of
cataloged documents, as opposed to in the
item’s record, as with other Portfolio word
searches.

Portfolio only indexes the text found in plain
text files and PDF documents. 

To find text in a cataloged document:

1 Choose Catalog > Find Other > Document
Text. 

2 Enter the words or phrases that you wish to
search for in the Words to Find box.

3 Choose the desired search criteria from the
pop-up menus. The various Find Options are
identical to those in the standard Find dialog
box.

4 Click Find to start the search.

Finding Missing Originals

The Find Missing Original command is a
specialized search that verifies that there is still a
valid path pointing to an original file for each
item in your catalog. If Portfolio can’t find a file
on disk corresponding with each catalog item, it
lists the missing originals so that you can either
update your catalog or delete the items.

To locate missing files:

1 Choose Catalog > Find Other > Missing
Originals, or press �-M (Mac) or Ctrl-M
(Windows).

2 Any missing items will be displayed in the
Missing Files dialog box. 

3 To update or delete any of items for which
an original is missing, select the missing item
in the list, then click the Update or Delete
buttons.

Notes on Searching

Keep the following points in mind when
working with the Portfolio search engine:

Indexing

Portfolio indexes all fields to speed searching.
Fields, including Text Block custom fields are
indexed at the word level, which means that you
can search these fields quickly by individual
words but not by phrases. 

When you search on indexed fields, choose
“matches” or “starts with” from the modifier
pop-up menu for the fastest possible searches.
Searches using “contains” or “ends with” can be
slower when working with very large catalogs.
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Date/Time Fields

Times are always assumed when searching fields
of the type “Date/Time,” even if a time is not
entered, and when the “Display Time” option
for the field is disabled. That is, if a time value
was entered into the field (either by extraction
from the source file when the item was
cataloged or by entering a time in the field) and
then hidden by turning off “Display Time,” the
time will still be noted by Portfolio when a
search is requested. For example: Searching for
“9/15/99” will not find a record which contains
“9/15/99 3:00 pm” because the request is
interpreted as “9/15/99 12:00:00 am.” This is
true even if the time is not being displayed.

Portfolio stores dates following the
computer’s Date and Time settings. If Short
Dates are used, Portfolio only records the
last two digits of the year, possibly resulting
in erroneous find results. To avoid this
potential problem, use the operating system’s
Long Dates format.
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Ultimately, most of the digital files you work
with every day probably end up going
somewhere. You may e-mail documents to
colleagues, burn images to a CD, upload files to
a remote file server, or publish them on a web
site. 

That’s why an important aspect of managing
your digital files is being able to quickly and
easily distribute them to other users. Portfolio is
equipped with several features designed to
greatly streamline the job of collecting and
sending your files to other users. This chapter
covers:

• E-mailing files from Portfolio

• Collecting images for archiving and
publication

• Creating web pages from cataloged images

• Creating slideshow presentations of your
images

E-mailing files
Portfolio 6 now makes it possible to e-mail
images and other digital media files to other
users from within a Portfolio catalog by
connecting directly to your computer’s e-mail
program. This provides a convenient way to
distribute images or send out proofs without
having to manually launch your e-mail program
and attach an image in order to send it.

To e-mail a file from Portfolio:

1 Select the item (or items) that you want to
send from the current gallery window.

2 Click the E-mail button on the Toolbar.

Portfolio launches the default e-mail program
on your system, creates a new e-mail message,
and adds the file(s) you selected as an
attachment.

3 Address the e-mail and fill in the subject and
body text as usual.

While there’s no inherent limit to the size or
number of items that you can attach to an
e-mail from within Portfolio, your e-mail
client software, network e-mail server and/or
your internet service provider may have
limitations on the size of attachments. If
you have very large attachments, it might
be better to collect these together using
Portfolio’s Collect command, and then
transfer them over the internet using FTP.

On a Macintosh, you can change the
default e-mail program that is launched by
Portfolio using the Internet control panel.
Go to the E-mail tab in the control panel,
and select a program from the Default E-
mail Application pop-up menu at the
bottom of the panel.

Collecting images for
distribution
As a Portfolio user, you might frequently find it
useful to collect together a group of cataloged
files, copying the files from their various
locations on your computer system or network
into a single location. This is the purpose of
Portfolio’s new Collect command, which not
only copies and collects files, but can also create
a new catalog containing those files, and even
create a copy of Portfolio Browser — a simple,

Distributing files with Portfolio
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read-only version of Portfolio that you are free
to distribute with your catalogs. Automatically
collecting images, linking them to a new catalog
and generating a browser in which to view the
catalog streamlines the process of sharing
Portfolio context with other users and makes it
especially easy to publish collections of images
to CD-RW.

Here are some of the ways you might want to
use the Collect feature:

• Copy files scattered across your network on to
a single Zip or Jazz disk or CD-RW for archiving
or distribution to another user.

• Copy a select set of images to a new folder on
the network so others can use and access them

• Create a new catalog containing only the
images you select (leaving your original catalog
unchanged) and send this along with its
associated files to another user.

• Burn a collection of images to CD-RW,
including not only the images, but a catalog of
those images, and Portfolio Browser, so that
other users can open and view the catalog
without having to buy or own Portfolio.

Using the Collect command

Portfolio’s Collect feature operates on a whole
gallery of images at once. Therefore, the first step
when using it is to set up your current gallery so
that it contains only the files you want to include
in your collection. You can do this by:

• Performing a search that reveals only the files
you want to include.

• Double-clicking a Folder View folder to reveal
only the contents of a particular folder.

• Creating a new gallery (by choosing Gallery >
New) and then dragging only the items you
want into the new gallery.

Select a destination
for the collected files

Catalog the collected
files in a new
Portfolio catalog

Select a name and
destination for the

new catalog

Include Portfolio Browser to view
the catalog, with or without
user documentation

Collect the files into one “flat”
folder, or keep the nested

folder structure of the original
files

The Collect Window

Approximate size of newly
collected files and catalog

Windows only: Set the
name of the target volume

in the new catalog
(when creating CDs)



• Selecting and deleting thumbnails that you
don’t want to include using the Delete key
(assuming that in your General Preferences, you
have the Delete key set to remove items from a
gallery, not delete them from a catalog). 

Preserving Folder Hierarchy

When collecting files, Portfolio gives you the
option of preserving the folder hierarchy of the
collected files. By default, this option is turned
off, meaning that Portfolio collects all the files
into a single folder — regardless of how the
originals were arranged on disk. 

If you turn on the Preserve Folder Hierarchy
check box in the Collect dialog box, Portfolio
will reconstruct the entire nested folder
structure of the collected files when it copies
them, exactly mirroring the hierarchical
arrangement of the originals. The hierarchy
always starts with the topmost (parent) folder
that contains all the files you’ve selected.

Creating an archive catalog

If you turn on the Create Archive Catalog
option in the Collect dialog box, Portfolio
automatically creates a new catalog for the files
you are collecting. The items in the new catalog
are linked to the new copies of your files, not
the originals. This is especially useful when you
are collecting to another disk (such as a CD)
because it ensures that the catalog is pointing to
the copies of the files that you are distributing,
not to the ones still on your own hard drive or
network.

The new catalog created by the Collect
command is a clone of your original catalog,
preserving all your custom fields, data, and
saved views. This makes it easy to distribute

catalogs with exactly the look and style that you
want.

It is not recommended that you save the
archive catalog into the same folder as the
collected images, as this might make it
difficult for users of your collection to locate
and open the catalog file itself. Instead you
might save the catalog to the root level of
your destination and collect the images into
a separate subfolder called “Images”

Setting a volume name
(Windows only)

When creating a CD on Windows, it’s critical
that you correctly set the name of the
destination volume, so that the paths in your
new catalog point to files on the soon-to-be-
burned CD, and not to your own hard drive or
network volume. To make this possible, the
Windows version of Portfolio includes an option
in the Collect window called “Use this Volume
name in Archive Catalog.” By putting the name
of the CD volume that you are creating in this
field, your archive catalog will include that name
in the final path for your collected files.

Creating a Portfolio Browser

Portfolio Browser is a free read-only version of
Portfolio. The Portfolio Browser application
allows users to open a Portfolio catalog, view
thumbnails and previews, perform searches
using keywords and other criteria, but it doesn’t
allow them to add, edit or remove items from a
catalog. It also doesn’t connect to catalogs
served by Portfolio Server in a networked
environment.

You are free to distribute a copy of Portfolio
Browser with any of the catalogs you create
using your copy of Portfolio. The Collect feature
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has the ability to create and include the
Portfolio Browser with your collection
automatically, saving you the trouble of having
to manually find and copy the application
yourself each time you distribute files.

The Collect command can only create and
include Portfolio Browser for the specific
platform — Mac or Windows — on which
you are running Portfolio. If you are
running Portfolio on Macintosh, but also
want to include a Windows version of the
Portfolio Browser (to make a hybrid CD, for
example) you’ll have to copy the Windows
version of the browser from your original
Portfolio CD. (You might want to keep a
copy of the browser on your hard drive, so
that you can copy it as needed, without
having to retrieve it from the original CD
each time.)

To collect files with the Collect command:

1 Make sure the files you want to include in
your collection are the ones displayed in the
current gallery.

2 Click the Collect button on the Toolbar, or
choose Gallery > Collect.

3 Select a Destination for the collection.

Click the Folder button (Macintosh) or Browse
button (Windows) to select a folder into which
your new collection will be copied. You can
select an existing folder, or create a new one in
the Choose a Folder/Browse for Folder dialog
box.

4 Turn on Preserve Folder Hierarchy if you
want Portfolio to copy the collected files into
hierarchical folders.

Leave this unchecked if you want the files
collected into a single folder. See the
“Preserving Folder Hierarchy” section above for
an explanation of this feature.

5 If you want to create a new catalog for the
collection, turn on Create Archive Catalog.

See “Creating an Archive Catalog” above for an
explanation. If you don’t need a new catalog
for the files you are collecting, leave this
option unchecked. If you turn it on, you have
to specify a name and location for the new
catalog.

The Create Archive Catalog command won’t
work if other users are logged into the
catalog. This is because Portfolio must
ensure that no changes are taking place in
the catalog when cloning it. Make sure that
no other copies of Portfolio (or the Portfolio
Express palette) have the catalog open when
you use create an archive catalog.

6 Windows users: If you are burning the
collection to a CD, turn on the “Use this
Volume name in Archive Catalog” and fill in
the name that you will ultimately give to the
CD, so that the paths in your archive catalog
will work correctly. (See discussion of this
feature on the previous page)

7 Turn on the Include Browser checkbox if you
want to create a copy of the free Portfolio
Browser for inclusion with your collection.
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This option is available only if you have
chosen to create a new catalog for the
collection. Turn on the Include User Guide if
you want electronic documentation for the
browser to be included in the collection.

8 Note the total size of your collection (in
megabytes) in the Estimated Size field near the
bottom of the window to make sure you have
sufficient room on the target volume for the
collection.

9 Click Collect. 

Portfolio will make copies of all the items in the
current gallery and create a catalog, browser and
documentation according to the options you
specified.

Creating CDs from
Portfolio
The Collect feature (described immediately
above) is perfect for creating CDs of your
cataloged images. Portfolio handles most of the
tasks involved — copying files to a destination
disk, creating a new catalog for the files, and
generating a copy of Portfolio Browser.

For a step-by-step guide to creating hybrid CDs
using the Collect feature, see the “Creating
Hybrid CDs with Portfolio” document on the
Portfolio CD. (You can also download this
document from the Extensis website.)
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How to set up a CD using Collect
When using the Collect feature to burn images to CD along with a catalog and a copy of
Portfolio Browser, you can organize the collected files however you want — in a series of
nested folders, or a single flat folder — but a structure similar to the one shown below is
strongly recommended.

Collect the images them-
selves into their own root

folder ; include as many
subfolders as you want

Include the free
Portfolio  Browser,

which is collected into
its own folder 

Keep the archive catalog
file separate from the
images and easily 
accessible

If you’re making a hybrid
Mac/Win CD, don’t forget
to include a copy of
Portfolio Browser for the
both platforms. A copy of
the Mac and Win browsers
is available on the Portfolio
6 CD



Web Publishing with
Portfolio
Portfolio 6 offers two different levels of web
publishing support. On the more basic level is
the new Create Web Pages feature. This
makes it extremely easy to create web pages
from your Portfolio catalogs without having to
build pages from scratch or work directly with
HTML code. The web pages generated using the
Create Web Pages feature are static web pages —
a frozen “snapshot” of your Portfolio content at
the moment you export it.

On a more sophisticated level is PortWeb, a
web server plug-in that establishes a connection
between a web server and either a Portfolio
Server or a Portfolio catalog on disk. PortWeb
provides a dynamic link between web-based
users and Portfolio catalogs, so users can search
a Portfolio database using only a web browser to
submit queries. With PortWeb, you can do
dynamic web publishing, so that users who
browse your website see up-to-the-minute
content when querying Portfolio. Setting up and
using PortWeb requires a good knowledge of
web server configuration and administration.

PortWeb is not installed with Portfolio 6, but is
available to you at no additional charge as a
registered Portfolio user. Download the PortWeb
plug-in, along with accompanying
documentation, from the Extensis web site. See
the Portfolio 6 READ ME file for details.

Creating Web Pages

The Create Web Pages feature in Portfolio is
designed to help you turn your catalogs into
polished, professional-looking web pages with
just a few clicks. You have three options for
generating web pages:

• You can create simple web pages based on the
look of your current gallery.

• You can generate more complex pages based
on a set of pre-defined HTML templates that can
be modified or used “as is.”

• With some knowledge of HTML, you can
create and save your own HTML templates to
build custom web pages that include your own
images, logos, headers, footers, and so on.

In this section, we’ll cover each of these
methods:

To create web pages based on a Portfolio
gallery:

1 Select the thumbnails of the images that you
want to include on your web pages.

The Create Web Pages command acts only on
selected items. If you want to include all the
images displayed in your gallery window,
choose Edit > Select All.

2 Choose Item > Create Web Pages, or press �-
H (Macintosh) or Ctrl-H (Windows).
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3 Select the Use Current Settings radio button. 

With this option, the fonts, fields, thumbnail
size and background color of the current gallery
view are automatically applied to create web
pages that look very similar to the Portfolio
catalog itself; you don’t have to work with the
underlying HTML code at all. To change the
look of your web pages, just customize the
Portfolio gallery using the Customize View
command (see pages 38-43 for complete details
on how to do this) and the same formatting is
used in the generation of the web pages.

(To generate web pages containing more
complex HTML formatting, don’t turn on Use
Current View Settings. Instead, activate the Use
Templates radio button and use one of the pre-
defined HTML Templates available in the Create
Web Pages dialog box, or create your own HTML
template, as explained in the next section.) 

Some attributes of a customized view cannot
be converted to HTML and will not appear
in your exported web pages. Specifically,
borders and spacing (between thumbnails)
are not converted.

IMPORTANT: When creating web pages,
Portfolio exports thumbnails at the size they
were when cataloged, not at the selected
display size in the Gallery window. For best
results, make sure your cataloged images all
have stored thumbnails of a uniform size
(either all 112 x 112, or all 256 x 256). Use
the Regenerate Thumbnails command (page
55) if you need to recreate consistently-sized
thumbnails

4 (Optional) Turn on the Copy Original and
Link to Thumbnail checkbox. 

Turn this option on if you want the thumbnails
in your web pages hyperlinked to full-size copies

of your original files. With this option active,
Portfolio automatically copies original files into
an Images folder that resides within the target
folder for your web pages. It also adds the
needed HTML tags to your web pages so that
the thumbnails are linked to the original files in
the Images folder. (Relative links are used, so the
links remain valid even if you move the folder
containing your web pages to another computer
— such as a web server — after creating them.)

Keep in mind that some of your original
files may not be in a format that can be
opened in a web browser. Linking to
originals in such cases may result in a
hyperlink that downloads the original
instead of displaying it in the web browser.

5 Preview your web pages by clicking the
Preview button.

Click this button if you want to see a quick
preview of how your exported web pages are
going to look. The Preview button launches

105105

Catalog
converted to
web page
using Preview



your system’s default web browser and opens
the first page of your exported images. If you
don’t like the result, switch back to Portfolio,
close the Create Web Pages dialog box and edit
the current gallery settings before trying again. 

NOTE: Hyperlinks to local files won’t work in the
Preview page, so you’ll only be able to view the first
page of your HTML export. To create working
hyperlinks and view all exported pages, use the
Export command. The Preview button is designed
only to give you a quick preview of how an
exported page will look.

6 If the preview looks good, return to Portfolio
and click the Export button. 

Portfolio prompts you to enter a file name for
the first web page, and specify a location for the
HTML files that are created.

If more than one page of HTML is required to
display all the images you selected, Portfolio
generates additional pages and places them in
the same location as the first file. All the Web
page files start with the file name you entered,
followed by a hyphen (“-”) and a number
corresponding the page number. For example, if
the first file was named “PortWeb.htm”, the
second file will be named “PortWeb-1.htm,” etc.

7 Click “Save” to start the export process.

Portfolio also creates a folder named “Thumbs”
at the same location as the Web pages. Portfolio
stores JPEG thumbnails of each of the selected
items in the Thumbs folder. If you chose the
“Copy Originals and Link to Thumbnails”
option in Step 4, Portfolio also creates an Images
folder for the copies. If any files (either the
HTML files or the thumbnail images) already
exist in this location, you will be asked whether
you want to replace the files or stop the export
process.

To create web pages based on an HTML
Template:

To create a more sophisticated web design, you
can use one of the pre-defined HTML templates
included with Portfolio and listed in the Create
Web Pages dialog box. 

Here are the steps for using a template to export
your web pages:

1 Follow Steps 1 and 2 above, selecting the
images you want to include in your web pages
and opening the Create Web Pages dialog box.

2 Activate the Use Template radio button.

3 Select a template from the list of pre-defined
templates.

4 (Optional) Click Edit to open the Edit HTML
dialog box.

This allows you to adjust some of the template
settings so you can “fine-tune” the results of
your HTML export. (If you have a knowledge
of HTML, you can edit the code used to
generate the Header, Footer and Item sections
of the web pages, as outlined below in the next
section.)

5 In the Table Grid fields, enter the number of
rows and columns of thumbnails that you
want to display on each page, then click Save.
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This selection controls how many items fit on
a page, and as a result, how many pages are
generated for each export based on the number
of items you have selected.

6 Follow Steps 5 and 6 above to preview and
export your web pages.

Creating your own HTML
templates

With a good working knowledge of HTML, you
can create your own templates and use these to
generate web pages:

To create a template, choose Item > Create Web
Pages, or press �-H (Macintosh) or Ctrl-H
(Windows) to open the Create Web Pages dialog
box. Then, click the Add button to build a new
template.

Working with the Edit HTML dialog box

The three HTML data tabs in the Edit HTML
dialog represent the three portions of an HTML
document (Header, Item, Footer). The Header is
the set of tags at the top of the file, the Item is
the set of tags written once for each record
being written into a page, and the Footer is the
set of tags written at the end of the file.

The following rules apply to each block:

Header:

• The header must contain the <HTML> tag
and the <BODY> tag.

• Because the grid layout is generated as a table,
the Header must end with a <TABLE> tag. 

• See the “Export HTML Macros” section below
for acceptable macros within the Header.

Item:

• The item tab should contain all of the
formatting for a particular table cell, including
the opening <TD> tag and the closing </TD>
tag.

• Portfolio will generate the row tags (<TR> and
</TR>) on its own, based upon the grid
dimensions. Do not include these tags in any of
the cells (unless you are adding your own rows
at the top or bottom of the table).

• The key to properly configuring the Item tab
is in using macros. Please refer to other parts of
this section for information on how to use
macros.

Footer:

• The Footer must start by closing out the table
with a </TABLE> tag.

• The Footer should close out with </BODY>
and </HTML> tags.

• See the “Export HTML Macros” section for
acceptable macros within the Footer..

Export HTML Macros:

Portfolio uses a macro language in the HTML
Templates to allow for substitution of variable
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data at the time the HTML files are actually
generated. All macros start and end with a %
sign, so the proper use would be %macro%. To
display a “%” sign in the actual HTML, use two
consecutive % signs in the template (i.e. “%%”
in the template produces one “%” in the
generated output). The macros are case-
insensitive.

The table on the next page lists the supported
macros within the different blocks

Technical Notes on Exporting
HTML

• Using the %fieldname%@x makes use of two
different form controls (the drop-down menu
and the scrolling list box). Because of this, the
page must contain a <FORM> tag for these tags
to be interpreted properly. 

The <FORM> tag can be either in the Item block
or in the Header. If you plan to have a separate
set of form controls on the page, put the
<FORM> tag towards the beginning of the item
block (usually just after the <TD> tag) and the
</FORM> tag towards the end (usually just
before the </TD> tag). This will prevent the
controls from accidentally causing data to be
submitted via your Submit control.

• To display a large text box for a multi-line
field, wrap the field in a TEXTAREA tag.

Example: <TEXTAREA COLS=50 ROWS = 3
WRAP =”SOFT”
NAME=”Description”>%Description%</TEXTAR
EA>

• Results: This will cause a scrollable box 3 rows
by 50 characters to be drawn with the contents
of the record’s Description field displayed. Note
that this is also a FORM control, so the previous
note regarding FORM tags applies here as well.

• As with any HTML code, results will vary
based on what make and version of browser the
viewer is using. It is recommended that you test
the generated results with any browsers with
which you anticipate your visitors might access
the pages.

Slideshows
The Portfolio Slideshow feature lets you create
slide shows from your catalog images (not
thumbnails) that can run automatically—with
the images being advanced in specified intervals
—or that can be manually advanced. You can
even save slideshows as standalone QuickTime
movies, so that you can distribute them to other
users.

Portfolio uses the images in the active gallery for
the slide show. The screen is blanked and the
images are displayed against the background
color of the current gallery view. You can elect
to show images at their actual image size, or to
have them scaled up to fit as much of the
display screen as possible. (If an item is too big
for the screen, it is automatically scaled down.) 

When locating items for a Slideshow, if a disk
preview is available, it will be displayed. If no
disk preview is found and the source file cannot
be found, the item thumbnail is displayed.

To set up a Slideshow:

1 Choose View > Slideshow Options.

2 In the Slideshow Options dialog box, choose
from Manual or Timed in the Control section.
With a manual slideshow, you advance from
image to image using the arrow keys, or the
VCR-like onscreen slideshow controls. A timed
show advances from slide to slide
automatically. You can set a time delay of up to
99 seconds.
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3 Choose a display size. Actual Size displays
the images at the actual size of the source file
image. Full screen allows Portfolio to scale the
image up to fit the display screen. In all cases,
if the image is too large, it will be scaled down
to fit.

4 Set the other slideshow options. 

Turn on the Continuous Loop checkbox if
you’re creating an auto-running slideshow and
want it to loop continuously. If you want to
display a field with the images in the slideshow
— the filename, for example, or a caption
saved in a custom field — turn on the Display
Field checkbox and select the field from the
pop-up menu. When you run the slideshow,
the field text will appear along the bottom of
the screen (in the font being used in the
current gallery) under the images.

5 Click OK when you’ve adjusted all the
settings. You’re ready to run your slideshow.

To run a Slideshow:

1 Configure a gallery window with the items
you would like to be displayed in the
slideshow, and drag the items in the order in
which you want them to be shown.

NOTE: A slideshow can contain still images, 3D
images, movies, and sounds. Anything that can be
previewed in Portfolio can be displayed in the
slideshow.

2 Choose View > Slideshow, or press �-; (Mac)
or Ctrl-; (Windows).

3 For manually run slide shows, click the
arrows on the controller to move to the next or
previous item. Alternatively, you can press the
Page Up and Page Down keys to advance

through a show. Click the first/last arrows to
move to the beginning or the end of the show. 

4 Timed slideshows begin automatically, but
you can stop and start the presentation and
restart using the pause button on the mini-
controller. 

If the Slideshow is not on “Continuous Loop”
it will end when the last item has been
displayed.

5 To stop the slideshow and return to the
gallery window, press the Stop button on the
controller, or just press Esc on your keyboard.

Keep in mind when using a timed delay that
images do not start loading until after the
delay period and it can take up to a few
seconds for larger images to load.

Edit during Slideshows

The manual controller (shown above) allows
you to delete, copy, move and rename files
during a slideshow. With this feature, you can
use a slideshow to preview a number of images
at full-screen and organize them as you go.
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Auto-starting slideshows

You can also have a slideshow run automatically
when a catalog is opened. To set this up go to
Catalog > Administration and open the Startup
tab (this requires that you have administrative
access to the catalog). In the On Startup section
of the panel, turn on the Run Slideshow
checkbox.

Saving a slideshow as a
QuickTime movie

The Export QuickTime Movie option exports
slideshows from the catalog and saves them in
QuickTime movie format. You can specify
transitions for the movie when the slideshow is
exported.

To export a slideshow as a QuickTime movie:

1. Open the gallery that you’d like to export as
a QuickTime slideshow.

2.Choose Item > Create QuickTime Movie.

A dialog box will be displayed asking you to
enter specifics about the size of the movie.

3. Set the movie size (in pixels), the timing of
each slide and the Transition Effects you’d like
to use 

4. Click OK and save the movie file. 

5. You will be asked to name the movie file and
specify the location where you want to save it.

6. Click “Save.” 

If the original image (the item’s source file)
cannot be found when the Slideshow is
exported, the catalog thumbnail is exported
instead. If you export a QuickTime movie file
(.mov), the resulting movie file will be blank.
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All Blocks

%prev% Link to previous page. This will be the name of the previous file 
generated in the series of files. If this is the first file in the series, the 
name of the current file is substituted.

Example: <A HREF=”%prev%”>Previous Page</A>

Results: A hyperlink (“Previous Page”) is displayed. When clicked, it
takes the user to the previous page in the generated series.

%next% Link to next page. This will be the name of the next file generated in the 
series of files. If this is the last file in the series, the name of the current 
file is substituted.

Example: <A HREF=”%next%”>Next Page</A>

Results: A hyperlink (“Next Page”) is displayed. When clicked, it takes 
the user to the next page in the generated series.

%page% Substitutes a number indicating which page in the series is being 
generated.

Example: <TITLE>Portfolio Search - %page%</TITLE>

Results: The text “Portfolio Search – 1” is displayed in the title bar of the 
browser window. (Assuming this is the first page in the series and 
assuming this tag is placed in the header prior to a <BODY> tag.)

Item Block Only

%thumbnail% Substitutes a relative path to the thumbnail file for the current 
record (located in the Images subfolder). This is most commonly 
used to display the thumbnail on the page.

Example: <IMG SRC=”%thumbnail%”>

Results: Thumbnail is displayed on the web page.

%fieldname% Substitutes text data from the named field in the current record. For 
multi-valued fields, the text will be displayed as comma-delimited values 
(the same way it is displayed in Thumbnail view).

Example: <B>%filename%</B>

Results: “image001.jpg” is displayed in bold. (Assuming the record’s 
filename is “image001.jpg”.)

Macros used in Portfolio’s HTML Templates



112

%fieldname^x% Substitutes the value x from a multi-valued in the current record.
If there are less than x values in the field, an empty string is 
substituted. x can only be a value between 1 and 9. The primary
use of this field is for URLs.

Example: <A HREF=”%myurl%^2”>%myurl%^1</A>

Results: A hyperlink is generated in which the source is the URL 
value of the field (i.e. the second value in MYURL), and the text 
displayed on screen is the title value (i.e the first value in 
MYURL.)

%fieldname%@x Substitutes text data from from the named field in the current 
record. However, the data in the field will be displayed as either 
a drop-down list or a scrolling list box. This macro is intended 
primarily for multi-valued fields. Substituting a value of 0 for x 
results in a drop-down list being generated. Substituting a value 
of 1 through 9 for x results in a scrolling list box of x lines being 
generated.

Example: %keywords%@0

Results: The keyword list for the record is displayed as a drop-
down list, with the first keyword displayed.

Example: %keywords%@5

Results: The keyword list for the record is displayed as a scrolling
list box that is 5 rows in height.

Macros used in Portfolio’s HTML Templates (cont’d)
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The Portfolio Express palette, new to Portfolio 6,
is a floating palette that makes the contents of
your Portfolio catalogs instantly available within
any application, at any time, via a global
keyboard shortcut. It allows you to find, copy,
open, and use any file you’ve cataloged —
without even launching and opening Portfolio. The
palette displays small thumbnails of each item
in your catalog along with its filename. 

Some of the ways you can use the Portfolio
Express palette include:

• Locate images quickly using the palette, then
double-click them to open them in Adobe
Photoshop, or any other image-editing software
you specify.

• Open the palette when in QuarkXPress to find
and place images in an XPress layout, without
having to use the Get Picture command.

• When writing an e-mail message, grab an
image from the palette and drag it in as an e-
mail attachment.

• Grab logos, clip art, or other images from the
palette and drag them straight into a
PowerPoint slide or Word document (Macintosh
only).

• Find any image on disk with unprecedented
speed by simply pressing the Portfolio Express
hotkey, selecting the image on the palette and
choosing the Reveal in Finder/Reveal in Explorer
command.

• Copy original image files to a new location or
another disk by simply dragging thumbnails
from the palette directly to the new location.

The Portfolio Express palette is designed to
provide quick, easy access to your images
from anywhere on your system. It doesn’t
allow you to catalog new items in Portfolio,
edit existing Portfolio records, add
keywords, or perform any other file
management tasks. The job of the
Portfolio Express palette is make it easy for
you to grab cataloged items and use them.
To edit your Portfolio catalogs and do any
other file management, use the main
Portfolio application (which you can
launch from the palette).

Using the Portfolio Express palette

Choose catalogs

QuickFind

Launch Portfolio

Double-click
to edit an

original image

Drag and
drop into

documents

Select a
thumbnail,

then use fly-
out menu to

show file in
Finder or
Explorer

Portfolio Express Palette
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Setting up Portfolio
Express 
The Portfolio Express palette is a separate and
distinct application from Portfolio. By default, it
is installed in the same folder as the main
Portfolio application and is configured as a
startup application on your computer system.

To launch Portfolio Express for the first time:

Macintosh: If you opted to have the Portfolio
Express palette installed as a startup application,
it should already be running. Press the default
hotkey — Control-�-P — to make the palette
visible. (You can confirm that it is running by
checking your Application menu to see if
Portfolio Express is listed among the programs
that are currently active.) If the Portfolio Express
application isn’t running in the background,
double-click the Portfolio Express icon in the
Portfolio 6.0 folder on your hard drive to start it
up.

Windows: The Portfolio Express palette will be
installed as a startup application, and should be
running in the background. Press the default
hotkey (Control-Shift-P) to make the palette
visible. You can also double-click the Portfolio
Express icon in the System Tray. If the Portfolio
Express application isn’t running in the
background, choose Portfolio Express from
Programs > Extensis > Portfolio 6.0 in the Start
Menu.

Configuring Portfolio Express
palette as a startup application

If, for some reason, the Portfolio Express palette
is not configured to run in the background
automatically on the startup of your computer,
you can set it up to do so. Having Portfolio
Express start and run automatically in the

background makes it possible for you to access
your images the moment you need them by
simply pressing the Portfolio Express palette hot
key.

Making Portfolio Express auto-start on
Macintosh:

1 Drop an alias of the Portfolio Express
application into the Startup Items folder
located inside the System Folder.

2 On restart, Portfolio Express will launch
automatically.

Making Portfolio Express auto-start on
Windows:

1 From the Start menu, choose Settings >
Taskbar & Start Menu.

2 In the Taskbar and Start menu Properties
dialog box, switch to the Advanced tab.

3 Click the Advanced button. 

This opens the Start Menu directory.

4 Drag a shortcut of the Portfolio Express
palette program into Start Menu > Programs >
Startup.

5 Any items in this Startup folder will be
launched automatically the next time you
restart your computer.

Opening Catalogs with the
Portfolio Express palette

The first time you launch the Portfolio Express
palette, the palette is blank, with the words “no
open catalogs” displayed in the catalog menu.



To open a catalog, choose the Open Catalog
menu from the fly-out on the right side of the
palette. To open a recently-used catalog, choose
it from the catalog menu on the palette. The
Portfolio Express palette remembers the last
several catalogs you’ve opened. 

If the catalog you want to open isn’t on the
menu of recently-used catalogs, choose Other
Catalog from the menu and select any other
Portfolio catalog to access it through the palette.

Once you’ve opened catalogs using the palette,
you can switch among them using the catalog
menu at the top of the palette. (Opened catalogs
are always listed at the top of the menu.)

Opening a Portfolio catalog with the
Portfolio Express palette is just like opening
a catalog with the main Portfolio
application. If the catalog is password-
protected, you’ll be prompted to enter the
appropriate password in order to open the
catalog from the palette.

The Portfolio Express
Hotkey
As long as the Portfolio Express palette is
running in the background, you’ll be able to
access cataloged images by simply pressing the
Portfolio Express hotkey.

To set the hotkey for the Portfolio Express
palette:

1 Choose the Set Hot Key command from the
fly-out menu on the right side of the palette.

2 On Windows, make sure the “Hot key
enabled” checkbox is turned on. Then, click in
the Hot Key field and press the key
combination you want to use. On Macintosh,

simply press the desired key combination when
the dialog box opens.

3 Click OK to activate the new hotkey.

The hotkey both hides and shows the
Portfolio Express palette. 

Hiding vs. Quitting
In order for the palette to be available via
hotkey or by double-clicking the palette icon in
the Windows System Tray, the Portfolio Express
application has to be running in the
background. Therefore, when closing the
palette, it’s recommended that you hide the
palette, without quitting the application itself. 

To hide the palette:

You can hide with palette (without quitting the
Portfolio Express application) using any of the
following methods:

• Click the close box in the palette title bar.

• Choose Hide Portfolio Express from the palette
fly-out menu.
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To quit the palette application:

There may be times when you want to quit
Portfolio Express completely, so that it is no
longer running in the background. (If you do so,
you’ll have to re-launch the application in order
to use the hotkey and access the palette again.)
You can quit the application using any of the
following methods:

• Choose Quit Portfolio Express from the
palette’s fly-out menu.

• On Macintosh, switch to Portfolio Express
using the Application menu, then choose File >
Quit.

• On Windows, right-click the Portfolio Express
icon in the System Tray and choose Exit
Portfolio Express from the pop-up menu.

Searching for files using
Portfolio Express palette 
Once you have a catalog opened in the palette,
you can search for any item using the
QuickFind box located near the top of the
palette, just below the catalog pop-up menu.

The QuickFind box in the Portfolio Express
palette works exactly like the QuickFind box in
the main Portfolio application (see page 89 in
Chapter 8). It allows you to search for files based
on the content of any combination of fields.
The specific combination of fields included in
the QuickFind search is determined by the
QuickFind Preferences in Portfolio (see
“Customizing QuickFind searches” on page 89).

Perform a QuickFind search from
the palette

To perform a QuickFind search using the palette,
click in the QuickFind box, type a word or
phrase in the box and then press Return.
Matching items appear in the palette.

Finding all items from the palette

To display all items in a catalog, click and hold
on the “magnifying glass” button to the right of
the QuickFind field to access a Find All pop-up
menu.

Accessing (and using) files
from the Portfolio Express
palette
You can use the Portfolio Express palette to
directly access cataloged items in any of the
following ways:

• Double-click a thumbnail to edit the original
file. You can also do this by selecting a
thumbnail and choosing the Edit Original
command from the fly-out menu

• Drag a thumbnail on top of an alias (or
shortcut) of an editing program, such as Adobe
Photoshop, Illustrator or FreeHand to open the
image with that program.

• Drag a thumbnail into a drag-and-drop savvy
document (such as Word on the Macintosh) to
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place a copy of the image in that document.

• Select a thumbnail and choose the Reveal in
Finder command (or, Reveal in Explorer, on
Windows) from the fly-out menu to show the
original file in the Finder (or Windows
Explorer).

• Click the Portfolio button in the upper right
corner of the palette, or choose the Switch to
Portfolio command from the fly-out menu to
open the currently-open catalog in Portfolio.

• Drag a thumbnail from the palette into an e-
mail message to send a copy of the image as an
attachment.

• Drag a thumbnail into a QuarkXPress
document to place the image in an XPress
layout. If you drop the thumbnail on a picture
box, the selected image will be placed in the

existing picture box; otherwise, Portfolio Express
will create its own new picture box for the
image.

Dragging thumbnails from the Portfolio
Express palette (or from Portfolio itself) into
QuarkXPress requires the presence of QX-
Drag & Drop, an XTension that must be
installed in Quark’s XTension folder. The
Portfolio 6.0 Installer attempts to install QX-
Drag & Drop into the proper location during
the Portfolio installation process. If, for any
reason, this XTension was not installed
during the initial Portfolio installation, you
can copy to the XTension folder yourself
from the Portfolio 6.0 CD.
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Portfolio is specifically designed to be used in
workgroups, with multiple users sharing catalogs
over a network. 

In such a networked environment, it’s critical
that you be able to control not only who can
access a catalog, but what level of access that
user should have. 

To illustrate: In a workgroup, one user may be
tasked with configuring a Portfolio catalog, while
someone else might have the job of adding new
items to the pre-configured catalog. Still other
users might have responsibility only for using
items that others have put in the catalog. Each
user requires a different level of access to the
catalog. Portfolio allows you to set up such
access levels, as explained below.

In addition to covering access levels, this
chapter also explains how to maintain Portfolio
catalogs and how to use catalog functions in a
multi-user environment. It also covers specific
Portfolio functions that are reserved only for the
catalog Administrator, but that are critical for
setting up a useful and convenient cataloging
system.

Catalog Access Levels
Portfolio catalogs can be password-protected for
security. When passwords are set by the catalog

Administrator, users are prompted to enter a
password each time they open a catalog. 

As the Administrator of your catalog, you can
also assign varying levels of access to different
users — controlling which functions users can
or cannot use within Portfolio.

The four possible levels of access are:

• Administrator: This mode provides full
access to all features. An administrator can
assign passwords to other users, create custom
fields, and control cataloging and startup
options that other users can’t. When a catalog is
opened in Administrator mode, no one else can
use it. When you create a new catalog, you are
automatically in Administrator mode for that
catalog. 

• Publisher: Publishers can add, remove,
export and edit items in a catalog, but can’t
access administrative functions such as creating
a new custom field, creating a master keyword
list or changing passwords.

• Editor: In Editor mode, you can search,
preview, access and edit information about
cataloged items, but you can’t add new items to
a catalog, rename files, or export catalogs as web
pages or QuickTime movies. 

• Reader: As a Reader, you can view, search,
preview and copy items — but you can’t make
any changes in the catalog. It’s a read-only
mode. 

In Portfolio, each of these levels can have its
own password, Alternatively, you can assign an
access level and password to individual users
(which is called “user-based access,” as
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explained later in this chapter) to more closely
control who has access to a catalog and what
level of access they have. Whether you assign
passwords by access level or by user, access levels
function the same.

Portfolio access levels are inherited; that is, the
Administrator level includes the privileges of all
other levels (in addition to its other privileges),
the Publisher level includes the privileges of the
Editor and Reader levels, and so on.

About Administrator Mode
Administrator — the highest level access —
provides access to all catalog functions,
including creating custom fields and editing the
Master Keyword List. Other users can enter data
in custom fields that the Administrator creates,
and apply keywords to items from the Master
Keywords List. 

The Administrator is responsible for setting all
access level passwords, and Administrator is the
only access level that can change passwords.
When a catalog is created it is automatically
given Administrator level access, so that you will
have access to all the features and functions
necessary to set up the catalog.

IMPORTANT: A shared catalog cannot be
accessed by other users when it is in use by
the Administrator. Only one person at a
time can access a catalog when it is in
Administrator mode. If you can’t log in
using Administrator mode, it’s likely because
another copy of Portfolio (or the Portfolio
Express palette) has the same catalog
opened already.

Opening a catalog in
Administrator mode:

You’ll need to open a catalog in Administrator
mode if you want to create custom fields,create
a master list of keywords, set passwords or
access any of the other features in the Catalog
Administration dialog box. 

To log in using Administrator mode:

Choose Catalog > Access, or press �-J (Mac) or
Ctrl-J (Windows). Select Administrator from
the Mode pop-up menu, then enter the correct
password (if a password has been set) and click
OK. 

For more information about changing your
current access level, see page 13 in Chapter 3.

Password-protecting a
catalog

You can add password-protection to any
catalog. Because multiple users can use a single
Portfolio catalog simultaneously across a
network, password protection is strongly
recommended when a catalog is shared on a
network. Password protection is not necessary,
however, if you are the single user of a catalog
on your own computer.



The first step in password protecting a catalog
is to decide which of Portfolio’s two access
methods you want to use — Level-based access
or User-based access:

• Level-based access: Level-based access
allows all users to open a catalog in any one of
the four levels (Reader, Editor, Publisher, or
Administrator) with a single shared password. In
other words, no matter how many catalog users
there are, you set up only four passwords — one
for each of the standard access levels. All users
logging in with the same access level (all
“Publishers,” for example ) also share the same
password. This was the standard access method
available in earlier versions of Portfolio. 

• User-based access: User-based access allows
you to assign different access levels and
passwords for each individual user. 

To choose an access level method:

1 With a catalog open in Administrator mode
(see previous page) choose Catalog >
Administration. Go to the Passwords tab.

2 Choose between the Level-based Access or
User-Based Access radio buttons.

3 You’re now ready to set passwords using the
access method you’ve chosen.

Setting passwords (with Level-
based Access)

Simply click the Set button for each of the four
levels to set a password for each level in the Set
Passwords dialog box. Click OK after entering
and confirming each password.

Passwords must be between 4 and 12
characters in length.

Setting passwords (with User-
based Access)

With User-based access, you’ll have to set up a
password for each user who will be accessing
your catalog

To set user-based access passwords:

1 Make sure you’ve turned on the User-based
Access radio button in the Passwords tab of the
Catalog Administration dialog box.
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2 Click the Edit User Access button. 

3 In the User Access dialog box, click the New
button, assign a username, password and access
level for one user, then click OK.

4 Repeat the previous step as needed for each
person who will be accessing the catalog.

5 When you’re finished adding users, click OK
to return to the Catalog Administration dialog
box.

The catalog must be closed and reopened
before the password changes take effect.

To change individual users and/or passwords:

1 In the Catalog Administration dialog box,
click the Edit User Access button.

The Users and Groups dialog box is displayed.

2 Select the desired user, then click Edit or
Delete, depending on what changes you want
to make.

Once a catalog is password-protected with a
password for any access level, a password
prompt is displayed whenever the catalog is
opened. Users can then choose their access
level from the Level pop-up menu, enter the
correct password and click OK to open the
catalog.

Even if you set only a Reader password,
users logging in as Editor, Publisher, or
Administrator will need that Reader
password to gain access to the catalog. If
you only set an Administrator password,
however, you won’t need to enter a password
to access the catalog in other access levels.

Importing and Exporting user
lists

If you plan to have a group of users accessing
multiple Portfolio catalogs, you can create a
Users list in one catalog, then export it for use
in other catalogs, rather than having to enter
username and password information manually
in each catalog.

To export a User Access list:

1 Open the catalog in Administrator mode, as
explained earlier in this chapter. 

2 Choose Catalog > Administration to open
the Catalog Administration dialog box

3 Click the Passwords tab.

4 Under the User-level Access section, click the
Edit User Access button.

5 Click Export.

6 Enter a name and location for the text file
that will be created from the Users list.

7 Click Save.
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To import a Users list:

1 Open the catalog in Administrator mode, as
explained earlier in this chapter. 

2 Choose Catalog > Administration to open
the Catalog Administration dialog box

3 Click the Passwords tab.

4 Under the User-level Access section, click the
Edit User Access button.

5 Click Import.

6 Locate and open the text file containing
your Portfolio Users and Groups list.

Creating a Master
Keywords List
Establishing a Master Keywords list for a catalog
can help you maintain consistent keywords
among the items in the catalog, or across
catalogs. With a Master Keyword list, you can
ensure that only the keywords in the list are
used in the catalog.

Once you’ve set up a Master Keyword list, your
list automatically appears in a number of places
within Portfolio:

• On the Master Keywords palette (visible by
choosing Window > Master Palettes > Show
Master Keywords).

• In the keywords panel of the Item Properties
window.

• In the keywords panel of the Cataloging
Options window.

You can enter Master Keywords manually, or
you can import them from an existing text file.

To add keywords to the Master Keywords list:

1 Choose Catalog > Administration, or press
�-Option-J (Mac) or Ctrl-Shift-J (Windows).

2 Click the Keywording tab to select it.

3 Type new keywords into the text box at the
top of the dialog, then click Add.

If you enter a word that is already on the list,
the Add button will be dimmed.

4 When you have finished adding Master
Keywords, click OK to save the changes and
close the dialog.
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To Rename or Delete Master Keywords:

1 In the Keywording panel of the Catalog
Administration dialog box, select the specific
keyword that you want to Rename or Delete,
then click the appropriate button.

If you selected Rename, enter a new name for
the keyword.

2 When you have finished working with
Master Keywords, click OK to close the dialog
and save the changes.

Deleting a keyword from the Master
Keyword list does not remove it from any
items that have that keyword assigned to
them. If you want to change keywords that
have already been applied to items
(changing all occurrences of “Fast” to
“Rapid,” for example) use Item > Edit Field
Values to replace one keyword with another. 

Exporting and Importing
Keywords

You can export the Master Keywords list from
one catalog and import it into another. This is
handy if you want to share keywords across
multiple catalogs. You can also export the
standard keywords from any catalog, import it
into the Master Keywords list of another catalog,
then work with the list to rename, add, or
remove keywords to build a suitable Master
Keywords list.

Portfolio exports keywords to a file in which
each keyword is delimited by a Return character,
so you can also import lists of Master Keywords
from any suitable text file.

To Export a list of Master Keywords:

1 Choose Catalog > Administration, or press
�-Option-J (Mac) or Ctrl-Shift-J (Windows).

2 Click the Keywording tab to select it.

3 Click Export

4 Specify a name and location for the exported
file, then click Save.

To Import any list of keywords to the Master
Keywords list:

1 Choose Catalog > Administration, or press
�-Option-J (Mac) or Ctrl-Shift-J (Windows).

2 Click the Keywording tab to select it.

3 Click the Import button on the Keywording
tab and locate the file containing the keywords
that you want to import.

The keyword list must be a plain text file with a
hard Return character separating each keyword
entry.

4 Click Open.

The keywords will be added to the Master
Keywords list.

Adding Custom Fields

Portfolio allows you to create an unlimited
number of custom fields to store text, dates,
URLs or other types of information associated
with items in your catalogs. Creating and using
custom fields is fully covered in Chapter 7 (see
pages 72-77).

Setting Catalog Startup
Options
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As a catalog administrator, you also have control
over a number of actions that occur when a
catalog is opened. 

These options are available on the Startup panel
of the Catalog Administration dialog box.

Open Find Dialog: Turn this option on if you
want Portfolio’s Find command to automatically
be activated at startup, allowing you to
immediately begin a complex search. This can
be useful if you know the first action that you
typically perform in Portfolio involves using the
search criteria controls in the Find dialog box.

Open MKL Palette: Opens the Master
Keywords Palette on startup, saving users from
having to open it manually.

Run Slideshow: Puts Portfolio into full-screen
Slideshow mode on startup, presenting a
slideshow (using whatever Slideshow options
you’ve designated) on the default items in your
catalog. This can be useful if you’re using
Portfolio to give kiosk-style presentations and
want to launch immediately into the
presentation when someone opens a catalog.
See page 108 for details about using the
Slideshow feature.

Disable Link to Original: This option
disables the ability to preview an image within
Portfolio using the Preview command.

Turning on Disable Link to Original does not
prevent a user from being able to find, move or

otherwise access an original file on disk, as
long as the user has appropriate network
access privileges. It simply disables
Portfolio’s internal link to the original file for
the purpose of opening and previewing it.

Custom Splashscreen: You can add your own
splashscreen to a Portfolio catalog so that this
screen appears (for a duration of four seconds)
each time a catalog is opened. When you
launch Portfolio, the custom slashscreen appears
immediately after the standard Portfolio 6
splashscreen.

To add a custom splashscreen:

1 In the Startup panel of Catalog
Administration, click the Open button in the
Custom Splashscreen section.

2 In the Open dialog box, select a JPEG image
to use as splashscreen.

3 The selected image will appear in the
Custom Splashscreen section of the dialog box
and will be used as a splashscreen the next
time you open the catalog.

To remove a custom splashscreen:

1 In the Startup panel of Catalog
Administration, click the Clear button in the
Custom Splashscreen section.

Note: Large splashscreens add to catalog size and
can take a long time to load. It’s good practice to
size your splashscreen so that it is no larger than
necessary.
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Setting Preview Options
(Disk Preview)
The administrative options allows to you create
disk previews of each item you catalog, so that
you can preview images in Portfolio without the
original file being present. For complete details
see page 28 in Chapter 3.

Importing and Exporting
Data
Portfolio includes some powerful tools for
importing data into a catalog or exporting it out
for use in other applications. 

Using the Import Field Values command you
can bring data from an another database into
Portfolio by matching fields from the database
with specific fields in Portfolio. Conversely, you
can export values from any Portfolio field into a
text file for use in a database or spreadsheet, for
example. You can also export keyword and
description as pnot data that can be embedded
directly into most files and can be accessed from
within programs such as Photoshop.

Importing field values into a
catalog

To set up a database file for import into a
Portfolio catalog, it should be exported from
your database application as a plain text file,
with tab-delimited fields and a carriage return
between each record. 

See the technical notes at the end of this
section for more information about
formatting a text file for import.

The first record in the text file should contain
the database field headers. (This first record will
be used to match your database fields with fields

in your Portfolio catalog and will not be
imported as a record.)

Portfolio should be pre-configured with any
required custom fields prior to initiating the
import. Otherwise, data targeted for custom
fields will not be imported.

To Import Field Values:

1 Make sure you’ve set up any custom fields in
your catalog needed to store the data you’re
about to import. For information about
creating custom fields, see page 73.

2 Make sure the data you’re trying to import is
a plain text file, formatted as described above
with a tab separating each field value and a
return separating each record.

3 Choose File > Import Field Values and locate
the text file to be imported.

The field headers from the text file should
appear along the left column of the Import
Field Values dialog box, under the heading
Import File Fields. 
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4 Match each field header in the text file with
the appropriate Portfolio catalog field name
listed in the right-hand column. Move the file
fields and Portfolio fields up and down the list
to reorder their relative position. 

Click between the two columns to activate the
Import pop-up menu, as shown above. This
allows you to select the appropriate import
operator — Key, Import or Skip — for each
field. The operators work as follows:

Key (=) defines the key relationship. The
selected field in the imported data will be
searched for matching values in the
corresponding field in the Portfolio catalog.
Only one Key relationship can be designated for
the import.

Import (-->) indicates that the field in the text
file will be imported into the catalog field
indicated to the right of the arrow.

Skip (x) indicates that the field in the text file
will not be imported into the catalog.

5 When you have finished setting up the
import fields, you can save the settings for
future use. To do so, select “Save As...”  from
the Saved Sets pop-up menu. 

6 When you are ready to import the database,
click “Import.”

Portfolio will examine the field value data in
the second record in the text file (the first
record with actual data, since the first record
holds the field headers) for appropriate data
types by comparing each value in the record
with the paired Portfolio field type specified at
the start of the import. If a value does not
match, a warning is presented, allowing you to
cancel the import.

If all record types match, Portfolio will import
the data. As the import progresses, data in any
field which does not match the paired Portfolio
field type, is skipped.

Replace Multi-valued Field Data

When this checkbox in the Import Field Values
dialog box is turned on, values imported into a
multi-valued field overwrite the values in the
Portfolio record. When unchecked,  the values
being imported are added to the end of the list
in the Portfolio record.

Technical notes about importing
text files

Because the import text file is delimited by tabs
between fields and carriage returns between
records, make sure your data does not contain
either of these characters within a field, as it will
cause unexpected results on Importing. Portfolio
follows the ASCII standard by recognizing ASCII
11 as the Vertical Tab character. This character
should be used to denote a linebreak within a
field (such as in a text block like the Description
field). Portfolio also recognizes ASCII 29 as the
Group Separator character. This character should
be used to delimit values within a multi-valued
field (such as the Keywords field). If you are
exporting multi-line or multi-valued data from
other databases, make sure to use these
characters. Some other databases that support
multi-valued or multi-lined fields (such as
FileMaker Pro) also support these standards.

Exporting data to a text file

You can export your Portfolio catalog data to a
text file, specifying which fields will be exported
and which fields will be skipped. Only data for
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the selected items in the active Gallery will be
exported.

To export catalog fields as text:

1 In the Gallery window, select the items for
which you want to export text data. 

To select the entire catalog, choose Catalog >
Find All.

2 Choose File > Export > Text File. (on
Windows, choose File > Export to Text File).

3 Click in the left-most column of the Catalog
Fields list to enable or disable items from
export. A checkmark indicates that the item
will be exported. 

4 Click Export.

5 Enter a name for the file and indicate the
storage location, then click OK.

Portfolio will begin exporting the records and
will display a progress bar to keep you posted
on its progress. When exporting is complete,
you will have a tab-delimited text file
containing information from each item record
that you selected. In the file, each field within
a record is delimited by a tab, and each record
is delimited with a carriage return.

Technical notes about importing
text files

Because the exported text file is delimited by
tabs between fields and carriage returns between
records, Portfolio cannot use either of these
characters within a field, as it will result in an
improperly formatted file. 

Therefore, Portfolio follows the ASCII standard
by using ASCII 11 as the Vertical Tab character.
This character will be used to denote a linebreak
within a field (such as in a text block like the
Description field). Portfolio also uses ASCII 29 as
the Group Separator character. This character
will be used to delimit values within a multi-
valued field (such as the Keywords field). Some
other databases that support multi-valued or
multi-lined fields (such as FileMaker Pro) also
support these standards.

Exporting pnot Data (Mac
version only)

The Macintosh version of Portfolio allows you
to embed the keywords and descriptions you
create in Portfolio directly into your original
image files. Portfolio places this embedded data
in the pnot resource within each file, so that the
information can be accessed using any Mac
program that can open and read pnot data, such
as Photoshop. Once you’ve exported pnot data,
you can view keywords and descriptions for
your original images within Photoshop itself
using Photoshop’s File Info command.

Before exporting pnot data make sure your
catalog is up to date, so that Portfolio can
successfully find all the selected original image
files. You also may want to verify that the
original files you want to add the data to are not
stored on a CD or other write-protected volume
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and therefore cannot be updated with the new
data.

To export pnot data to your original files:

1 Select the items to which you’d like to
export the keyword and description data.

If the original file for any item cannot be
found, it will be skipped.

2 Choose File > Export > pnot Data...

3 Using the checkboxes, select the data you
would like to export to the original files —
Description, Keywords, and Thumbnail.

If you select Keywords, you can elect to replace
any keywords currently embedded in the item’s
source file, or append the keywords to the end
of any existing list. Turning on Thumbnail
embed’s Portfolio’s own thumbnail version of
the image back into the original file.

4 Click OK.

The fields you selected will be written to the
original files of the selected items.

You can view this information by opening an
image with embedded data in Photoshop and
using the File Info command. The Description
data from Portfolio is placed in the Caption field
within Photoshop.

Because this data is embedded in files as a
Mac resource, it will not be visible in
Windows applications.

Importing and Exporting Views,
Borders and HTML Templates

You can transfer saved views, thumbnail borders
and HTML Templates (used to create web pages)
from catalog to catalog using Portfolio’s import
and export capabilities. 

The saved view, border and HTML files that
you place in the Saved Views, Borders and
HTML Templates folder in the Portfolio 6
application folder will automatically be
included in each new catalog that you
create.

To export a saved view:

1 From the Saved Views pop-up menu (in the
upper right corner of each gallery windows)
choose Edit List.

2 In the Saved Views window, select a view
that you want to export.

3 Click the Export button

4 Choose a name and destination for the
exported view, which will be saved as a .pvw
file. Click Save.

Views saved into the Saved Views folder in the
Portfolio 6 folder will automatically be
included in all new catalogs.

To import a saved view:

1 From the Saved Views pop-up menu (in the
upper right corner of each gallery windows)
choose Edit List.

2 In the Saved Views window, click the Import
button
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3 Choose a saved view file from the Saved
Views folder (in the Portfolio 6 folder) or from
another location where you’ve exported view
files.

4 Click Done.

To export an HTML Template:

1 Choose Item > Create Web Pages.

2 In the Create Web Pages dialog box, click on
the name of the HTML template you want to
export, then click the Edit button.

3 In the Edit HTML dialog box, click Export,
choose a name and destination for the
exported template, which will be saved as an
html file. Click Save.

Templates saved into the HTML Templates
folder in the Portfolio 6 folder will
automatically be included in all new catalogs.

To import an HTML Template:

1 Choose Item > Create Web Pages.

2 In the Create Web Pages dialog box, click the
Add button.

3 In the Edit HTML dialog box, click the
Import button. 

4 Choose an HTML template from the HTML
Templates folder (in the Portfolio 6 folder) or
from another location where you’ve exported
HTML template files. Click Open.

5 Give the imported template a name by
filling in the Name field in the Edit HTML
dialog box, then click Save.

For more on using HTML templates see pages
106-108 and pages 11-112.

Importing a thumbnail border

Borders created in other programs and saved as
PICT, TIFF or BMP files can be imported into
Portfolio and used as frames around
thumbnails in both thumbnail and record
views. See pages 39-40 in Chapter 4 for details
about using and importing borders.

Maintaining a Catalog
This section covers some of the work you may
have to do to keep your catalogs in good
condition.

Recovering Damaged Catalogs

Should you ever have trouble opening a
Portfolio catalog and suspect that it may have
been damaged, you may be able to recover it
using the Recover command. Another time to
run the Recovery command is when you
experience crashes when sorting or searching on
a particular field.

To Recover a catalog:

1 Close the catalog that you want to recover. 

You cannot run the Recover command on an
open catalog.

2 Choose Recover from the Catalog menu.

A directory dialog box is displayed.

3 Locate the catalog you want to recover, then
click Open.

A second directory dialog box is displayed.
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4 Type a new name for the recovered catalog,
select where you want to save it, then click
Save.

A progress window is displayed as Portfolio
checks the catalog and attempts to repair the
damage. 

5 When the completed status report is
displayed, click OK.

Open the recovered catalog to verify that all the
items are intact.

Using Portfolio on a
Network
A single Portfolio catalog can contain references
to source files on multiple hard disks, network
servers, CD-ROM discs, or removable disks,
whether these media are mounted or not. When
Portfolio needs to retrieve a source file that
resides on a network volume, it automatically
mounts that volume, prompting for a volume
password when required.

If a source file is stored on removable media,
such as floppy disks or CD-ROMs, Portfolio
prompts for the disk by name. Portfolio also
prompts for source files that have been moved
or renamed.

Shared Catalogs

Portfolio provides two ways to share catalogs in
a multi-user, networked environment:

Filesharing: Filesharing uses standard system
networking to share catalogs on either a
dedicated file server somewhere or on a user’s
computer (provided that filesharing is turned
on). Users connect to these catalogs by choosing
Open, navigating to the particular volume, and
selecting the catalog itself. Each user’s Portfolio

application (client) intelligently sets flags within
the catalog file itself to control things such as
when other users are allowed to access the
catalog, and when other users should be blocked
from writing to a particular record. For example,
when one user writes to a record, other users
accessing the catalog are blocked from writing
to that record. Filesharing does not require the
addition of Portfolio Server software, but fewer
users can access catalogs simultaneously. Catalog
operations like searching are much slower than
with Portfolio Server software installed.

Client/Server: In this networking scheme,
special Portfolio Server software is used to
manage catalogs on a Windows NT or Mac OS
server machine. The Portfolio Server application
opens the catalogs, and monitors the network
for clients. End-users, running standard Portfolio
application software (client), access the Server
using the Connect to Server command. Once
connected to the server users can select catalogs
to open. The server software then controls all
catalog access. Portfolio Server software allows a
larger number of simultaneous users, and most
catalog operations are performed significantly
faster.

The number of users permitted to connect
simultaneously is set by the multi-user
license agreement. Additional connection
requests will be refused by the Portfolio
Server when this limit is reached.

SQL Server: Using Portfolio SQL Connect
software you can keep catalogs on your SQL
server and access them from the Portfolio client.
This provides all of the advantages of using
Portfolio to manage your catalogs, but keep the
data on your SQL Server. Portfolio SQL Connect
software is sold separately.
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Network Security Protection

Your organization is authorized to use as many
copies of Portfolio as designated in your site
license agreement. When you run Portfolio on a
network, the application checks the network to
see how many copies of Portfolio with the same
serial number are running. If the program finds
that more duplicate serial numbers are in use
than are in the site license agreement, an alert
box appears. Click OK to close the alert box.
Another user must quit Portfolio before you can
launch the copy that you want to use.

If you did not purchase a Portfolio site
license, only one copy of Portfolio per serial
number may be in use on your network.

Filesharing Network Concerns

In a typical network scenario, many users might
open Portfolio, locate items they want, and
leave Portfolio running in the background while
they switch to other applications to edit source
files, work on other documents, read e-mail, and
so forth. Meanwhile, at any given time, only
some of those users would be actively using the
catalog to search for and preview items they
might be interested in, while fewer still might
be adding or updating items, keywords, or
descriptions.

The greater the number of users who have a
catalog open, the slower individual searches will
be, depending on what tasks the users are
performing in Portfolio. The speed of the
network and computer can also affect the
performance of Portfolio.

If you want to limit who can write to or read
from a catalog, you can set passwords as
described in earlier in this chapter on pages 120-
123. Whether or not your catalog is password-

protected, it is essential that you set up the
necessary network access conditions.

If you are experiencing performance problems
in a multi-user network environment, your
situation may benefit from installing a Portfolio
Server to manage catalog access.

Administering Served
Catalogs
Catalog Administration is a single-user function.
That is, a catalog that is open in Administrator
mode cannot be opened by anyone else. 

On the Portfolio Server, where catalogs are
shared with other users simultaneously, this
means that others will not be able to access the
catalog while you are using it in Administration
mode. When you open a catalog as the
Administrator, all other users are locked out. 

If other users have the catalog open when you
change to Administrator mode, they will be
logged off immediately. To prevent this from
happening, we suggest that you use options in
the Server Administration dialog (see Chapter
12) to give users a time period in which to log
themselves off (by closing the catalog), or give
them a time period after which they will be
logged off. 

To prevent users from being logged off
inadvertently, a served catalog cannot be
opened in Administrator mode, even if you set
the Default Open Mode to Administrator in the
Preferences dialog box. In this case, the catalog
will default to Publisher mode when it opens.
You can then alert your users and switch to
Administrator mode (Catalog > Access).

While you have the catalog open in
Administrator mode it will not appear on the
Connect to Servers dialog for other users even
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though the catalog is still being served. To
release the catalog for other users, either close it
or change to a different access mode (Publisher,
Editor, Reader).

For additional information on setting up
catalogs on a Portfolio Server, see the next
chapter of this User Guide.
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The Portfolio Server is a powerful catalog server,
allowing access to Portfolio catalogs using
standard Portfolio 6 application software. Unlike
typical server applications however, the
Portfolio Server is easy to set up and use, and
requires almost no maintenance.

This chapter covers the setup, configuration of
and administration of Portfolio Server.

While standard Portfolio 6.0 application
software is capable of providing access to shared
catalogs through standard system filesharing,
the Portfolio Server provides superior
performance in multi-user situations. Using the
Portfolio Server instead of regular system
networking yields:

• Increased performance in a networked
environment

• Increased number of simultaneous
connections

• Connection to Portfolio SQL Connect
(software sold separately) 

With Portfolio Server you can:

• Connect remotely to the server (using TCP/IP)

• Manage the Server and Catalogs from the
standard Portfolio 6 application (client)

• Keep Catalogs open on the Server while they
are being administered

Server vs. Catalog
Administration
When using the Portfolio 6.0 application in
conjunction with the Portfolio Server, two
different types of Administration are available:

Server Administration: The Server
Administrator has permission to administer the
Portfolio Server. In addition, the Server
Administrator creates, opens, and closes
Catalogs on the Server. Client access is added
through adding special multi-user serial
numbers to the Server. Server Administrator
duties are described in this section.

Catalog Administration: The Catalog
Administrator has permission to access
Administrator level functions for particular
Catalog(s). Catalog Administration is discussed
starting on page 119.

System Requirements for
Portfolio Server

Macintosh:

Mac OS 8.6 through 9.2
Apple Power Macintosh
A minimum of 64MB of application RAM
25MB of free hard disk space
QuickTime 4.1.1 or higher strongly
recommended
TCP/IP Services installed

Windows:

Windows 98, Windows NT (Service Pack 6 or
6a); Windows 2000 (Service Pack 2); Windows

Administering Portfolio Server
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XP; or Windows 98
Pentium (133MHz or faster recommended)
32MB of system RAM
25MB of free hard disk space
QuickTime 4.1.1 or higher strongly
recommended

Portfolio 6 SQL Connect:

Windows 98, Windows NT 4.0, Windows 2000;
orWindows XP
Pentium (133MHz or faster recommended)
32MB of system RAM. Windows NT 4 or 2000,
Pentium, 32MB RAM; supports MS SQL Server
6.5, 7 and Oracle 8i.
TCP/IP Services installed

Portfolio Server software will normally benefit a
great deal from a faster processor, more physical
memory, multiple processors, faster network
connections, and faster hard drives (such as
Ultrawide SCSI drives).

Extensis does not provide Technical Support
for configuring TCP/IP Services, setting up
DNS services, configuring a firewall, or other
networking issues. For assistance with these
issues, please consult your System
Administrator or the product vendor’s
technical support.

Installing the Server
Installing the Portfolio Server is quick and easy.
Simply launch the installer and allow it to guide
you.

The Portfolio Server application has no interface
itself; access to Server features is handled
through standard Portfolio 6.0 application
software. 

Note: On Windows, the Portfolio Server is a system

service. This service must be started on the Server
before it will be active. To do so, open the
“Services” Control Panel. Select “Portfolio Server”
from the list and click “Start.” 

To access a Portfolio Server:

Open the Portfolio 6.0 application. From the
File menu choose “Administer Servers...” Select a
Server, then click “Administer.” From the
Administer Services dialog you can add and
administer one or more Portfolio Servers.

Administering a Portfolio
Server
Portfolio Servers are accessed and administered
from the Portfolio 6 application via the
Administer Servers command. 

Once a Portfolio Server has been made available
to the network, the Server Administrator can:

• Create Catalogs to be served

• Serve and Unserve catalogs

• Open and close Portfolio SQL Connect (sold
separately) catalogs

• Log off individual users



• Set/change Server Administration passwords

• Add multiple user access by entering special
multi-user serial numbers

Refer to other sections of this Portfolio User Guide
for assistance in creating, managing, and
administering catalogs.

Adding a Portfolio Server

Before you can serve catalogs on your Portfolio
Server you must make the server available—that
is, tell the Portfolio application where to find
the server. You do this through the Server
Administration dialog.

To add a Portfolio Server:

1 Launch the Portfolio 6 application.

You do not need to have a catalog open.

2 Choose File > Administer Servers.

The Administer Servers dialog will be
displayed. If no servers have been added, the
servers list will be blank.

3 Click Add Server

4 Enter the name and IP address for the Server.

5 Click OK

The Server is added to the list and will be
available for users to access. Selecting the
Server name on the list will activate the
Administer, Remove Server, and Edit Server
buttons.

Accessing a Portfolio Server for
Administration

When one or more Portfolio Servers have been
added (made available), you can administer
them by creating and serving Catalogs. To do
that, you must first access the Server through
the Server Administration dialog.

To access a Portfolio Server:

1 Launch the Portfolio 6.0 application.

The Portfolio Server can be accessed via the
Portfolio application from anywhere on the
network or internet. With Portfolio 6.0 there is
no separate Server Administration software.

2 From the File menu, choose “Administer
Servers.”

The Administer Servers dialog is displayed.

If no server names appear on the list, you will
have to add them before they can be
administered.

3 Select the desired Portfolio Server from the
list, then click “Administer...”

You will be asked to enter the Server
Administrator password. The first time you
access a Portfolio Server as the Administrator,
you will be prompted to serialize the Server.

4 Enter the Server Administrator password,
then click “OK.”
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The first time you access a Portfolio Server as
the Administrator the password will be blank.
You can enter a password, or just click “OK”
and set the password later.

The Server Administration dialog for the
selected Portfolio Server will be displayed, and
any served catalogs for that Server will be
listed. 

You can view any users connected to served
catalogs by clicking the expansion icon, or by
double-clicking the catalog name.

From the Server Administration dialog you can
create, serve and unserve catalogs, log off users,
set the password for the selected Server, and
add the Server serial code.

Creating Catalogs on a Server

From the Administration dialog for the selected
server you can create new (empty) catalogs to be
served on a Portfolio Server.

To add a Catalog to a Portfolio Server:

1 Open the Server Administration dialog (File
> Administer Servers > [select server] >
Administer).

2 Click New.

The New Catalog dialog will be displayed.

3 Enter the name of the catalog that you wish
to create.

On Windows, and on Mac OS if compatibility
with Windows users is required, catalogs must
be given an “.fdb” filename extension.

4 Click OK.

The Catalog will be added to the list of
Catalogs in the “Catalogs” folder on the Server
machine.

— or —

1 Create a Catalog from the Portfolio client.

2 Copy the catalog (via the operating system)
to the Portfolio Server’s “Catalogs” folder.

You can now serve the catalog to make it
available to your users. 

Serving and Unserving Catalogs

To serve (open for use) a Catalog on a Portfolio
Server:

1 Open the Server Administration dialog (File
> Administer Server > [select server] >
Administer).

2 Click “Serve...”

A list of available Catalogs on the Portfolio
Server will be displayed.

— or —

2 Navigate through folders and volumes
accessible to the Portfolio Server to locate the
Catalog to be served.

Catalogs do not have to be located in the
Catalogs folder to be served.

3 Select the Catalog that you want to serve,
then click “Serve.”

The Catalog will become available to Portfolio
users.
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When a catalog is first served it is opened
automatically in Administrator mode. To
make the catalog available to users, close
the catalog or change access mode to a level
lower than Administrator (Publisher, Editor,
or Reader).

To unserve a Catalog on a Portfolio Server:

1 Open the Server Administration dialog for
the server (File > Administer Servers > [select
server] > Administer).

2 From the list of served Catalogs, select the
Catalog that you wish to unserve (make
unavailable).

3 Click Unserve

If users are connected to the Catalog, a
warning dialog will be displayed. You can enter
a delay time in minutes before the Catalog
closes.

Connected users will be notified of the
imminent closing so that they can close open
windows and connections related to that
Catalog.

Notes on Unserved Catalogs

• Portfolio Server and source images: As with the
filesharing model of multi-user Portfolio access,
the Server does not serve the original files, only
the records of cataloged items. What this means
is that the client machine must have access via
the file system to the original file in order to
perform functions that require the source file,
such as Preview (unless the option “Generate
Previews” was enabled when the item was
cataloged); Copy; Move; Rename; etc.

• Server Port number: The Portfolio Server

operates via port 2903. In order to avoid
conflicts with other applications, make sure no
other server software is using this port on the
server machine. (We are currently unaware of
any other application that uses this port
address.) Be aware that if you have clients
attempting to access the server through a
corporate firewall, you may have to have the
network administrator open a hole in the
firewall for this port.

Logging Off Users

1 Open the Server Administration dialog for
the server (File > Administer Servers > [select
server] > Administer).

2 From the list of served Catalogs, locate the
Catalog with users that you wish to log off,
then click the expansion arrow to view a list of
active users on the Catalog.

3 Select the user that you want to log off.

4 Click Log Off User.

That user will be logged off immediately.

To allow users a time frame within which
they can log themselves off (by closing their
copy of the catalog), use the Unserve
command.

Server Administrator Password

To set or change the Portfolio Server
Administrator password:

1 Open the Server Administration dialog for
the server (File > Administer Servers > [select
server] > Administer).

2 Click Set Password
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The Set Password dialog will be displayed.

3 Enter and confirm the new Server
Administrator password, then click “OK.”

To exit the dialog without affecting the
password, click “Cancel.”

Serialization
In Portfolio 6.0, the Portfolio Server is activated
with a single Portfolio Server serial code.
(Portfolio SQL Connect is activated with a single
SQL Serial Code.)

The first time you attempt to administer a
Portfolio Server you will be prompted to enter
the serial code. You can also access the Serial
Codes dialog from the Server Administration
dialog (File > Administer Servers > [select server]
> Administer > Serialize). 

Multi-user serial numbers (licenses) allow users
to connect to the Portfolio Server, up to the
limit of users for that serial number. The multi-
user serial number is entered at each
workstation when the Portfolio 6.0 application
(client) is installed. The Portfolio Server tracks
how many connections are open at one time,
and limits access to the catalog to the maximum
number of connections for that serial number.
To add additional connections, simply contact
Extensis Customer Service to purchase
additional multi-user serial numbers.

To serialize a Portfolio Server:

1 Open the Server Administration dialog for
the server (File > Administer Servers > [select
server] > Administer).

2 Click Serialize.

The Serial Codes dialog is displayed.

3 Click Add.

The Add Serial Code dialog is displayed.

4 Enter the Portfolio Server Serial Code (and/or
SQL Connect Serial Code), then click OK.

When you click OK you will be returned to the
Serial Codes dialog. The newly entered codes
will be listed.

5 Click Done to return to the Server
Administration dialog.

Removing a Portfolio Server or
SQL Connect Serial Code

This feature is helpful if you wish to move a
serial number from one server to another, such
as when setting up a Portfolio Server in a
different location. 

Note that the serial can be used on only one
Portfolio Server at a time.

To remove the serial number from a Portfolio
Server, or to remove SQL Connect:

1 Open the Administration dialog for the
server (File > Administer Servers > [select
server] > Administer).

2 Click Serialize

The Serial Codes dialog is displayed.

3 Select the Serial Code that you wish to
remove, then click Delete.

The serial code will be removed from the list,
and those connections will no longer be
available on the selected server.
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Providing Users with
Access to Served Catalogs
Once a catalog is served you will want to give
users access to the catalog. The process from a
Server Administration standpoint is summarized
here.

To access served catalogs: 

1 Note the name given to the Portfolio
Server(s) that you wish to give access to. 

Server names are displayed on the Connect to
Servers dialog (File > Connect to Servers) and
the Administer Servers dialog (File >
Administer Servers). 

2 Give this name to your Portfolio users.

3 On the user’s machine, launch Portfolio 6.0,
then choose File > Connect to Servers

The Connect to Servers dialog will be
displayed. 

4 Choose Add Server and enter the name and
IP address of the Portfolio Server.

The client application will poll the Server and
display any catalogs being served. 

5 Click OK then click Done.

The user can now open catalogs served on that
Server.

Notes on Accessing Served Catalogs:

• Client machines must have TCP services active
to access the Server. For Mac OS clients, the
machine must be using Open Transport TCP 1.1
or higher; classic networking is not supported.

• Clients can access a served catalog in

Administrator mode, but all other users must be
logged off first. You can log users off from the
Server Administration dialog, or users can
simply disconnect.

• The client application will attempt to open the
catalog in the mode set in the user's Preferences.
If the preference is set to Administrator, the
client application will automatically attempt to
connect to the catalog in Publisher mode.

The user will be asked to enter a Password if
the catalog requires it.

• For more information on installing and using
the client, refer to the other sections of this User
Guide.
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A
Access levels 12, 119

changing 13
Adding items to catalogs 14
Administration. See Catalog Administration
Administrator mode 12, 120
Advanced Cataloging Options 21

properties options 23
Advanced preferences 30

B
Background cataloging 43
Background color 40
Batch record editing 78
Borders 39, 129

C
Catalog Administration 119
Catalog Properties 45
Cataloging options 16-17

advanced options 21-22
assigning custom field values 18
assigning descriptions 17
assigning keywords 18
assigning properties 17
hiding the window 20

Cataloging Summary 21
Catalogs

access Levels 12
adding items to 14
cataloging options 16-17
converting from earlier versions 11
creating 9
defined 35
opening 9, 11
opening at startup 41
opening served 13
password-protected 12-13

permanently opened 42
recovering 130
removing items from 52
security 12
setting a default open mode 13
shared 131
startup options 125
updating 54

Catalogs palette 34
Categories 84

assigning 86
comparison with FolderSync 84
creating 85
creating folders on disk 86
removing 85

Categories palette 34
Change Path command 54
Client/Server use 131
Collect 99-100

window 100
Complex searches 94
Confirm Delete warning 52
Copying files 19, 50, 65
Create Web Pages 104
Creating a Portfolio Browser 101
Creating an archive catalog 101
Creating catalogs 9
Creating Categories from Path 25
Creating CD archives 101, 103
Creating Keywords from Path 24, 69
Custom fields 72-73

adding 73
displaying as palettes 76
editing 76
predefined lists 75
types 73

Custom Splashscreen 125
Customizing 33-34

Index



D
Date/Time fields 98
Decimal fields 74
Default find 96
Default open mode 13, 30
Delete key behavior 30
Deleting (from a gallery) 83
Description

assign during cataloging. See Cataloging
options

Digimarc 58
Disable Link to Original 125
Disk previews 28, 56
Display as List option 38
Dockable palettes 34

displaying custom fields 76
Double-click behavior 30
Dragging items into other documents 53

E
E-mailing files 99
Edit Field Values command 71, 78
Edit Keywords command 70
Edit records in place 38
Editing original files 50
Editor mode 12
Exclude files by name 28
Excluding file types 27
Exclusions 24
EXIF tags 25
Export QuickTime Movie 110
Exporting data 127-128

technical notes 128
Express palette. See Portfolio Express
Extract Properties command 55
Extracting keywords and descriptions 23, 69

F
fdb file extension 10
Fields 40
File Types options 27

Find All 91
Find Galleries 82
Find in Gallery 94
Find missing originals 56, 97
Find window 91

setting a default 96
Finding document text 97
Finding items in catalogs 89
Folder View pane 62, 64
FolderSync 61-62

adding root folders 62
copying files 65
creating new folders 65
defined 61
moving files 64
removing root folders 63
switching to Explorer/Finder 67
synchronizing 66

FreeHand, using with 53

G
Galleries

changing a saved gallery 82
creating new 80
customizing 38
defined 35-36
delete items from 83
deleting 81
keeping sorted 79
opening saved 81
organizing with 80
rename 81
saved options 82
searching within 94
self-sorting 82
setting up find gallery  82
sorting 79

Galleries palette 34
Get Info 48, 77
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H
Header/Footer (printing) 57
HTML Macros 107-108, 111
HTML Templates 106, 111, 129

creating your own 107
technical notes 108

I
Illustrator, using with 53
Importing field values 126

handling multi-valued field data 127
technical notes 127

Indexing document text 23
Indexing fields 97
Installation 3
Instant Cataloging 10, 14
Integer field 74
Introduction 1
IPTC tags 25
Item properties 48, 70, 77

navigation buttons 49

K
Keywords 69, 123

adding 69
how to avoid typing 71
importing/exporting 124
removing 72
viewing 72

L
Level-based access 121
Linking to a new file 51
List view 37

M
Maintaining catalogs 130
Mappings 25
Margins (printing) 57
Master Keywords palette 34-35, 71, 123, 125
Moving files 19, 51, 64
Multipage icon on thumbnail 30
Multiple value lists 75

N
Network use 131
New features 2

O
Opening catalogs 9, 11

opening served catalogs 13
Opening galleries 80
Overview 5

P
Page numbering (printing) 57
Passwords 12, 120-121

administrative 139
changing 122
importing/exporting 122
setting 121

Photoshop, using with 53
Placeholder records 15, 97
pnot data 128
Portfolio Browser 101-102
Portfolio Express 113

accessing files with 116
hiding 115
hotkey 115
opening catalogs with 114
overview 113
setting up 114
starting up 114
using to search 116

Portfolio Server 135
access a server 137
adding a server 137
creating catalogs 138
installing 136
logging off users 139
providing access to users 141
requirements 135
unserving a catalog 138

PortWeb 104
Predefined lists 75
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Preferences 21, 29, 90
Preserving Folder Hierarchy 101
Preview window 48
Previewing items 47

audio/video files 48
Printing 57
Publisher mode 12

Q
QuarkXPress, using with 53
QuickFind 89

customizing 89
QuickTime 110
QX-Drag & Drop 53, 117

R
Reader mode 12
Record view 37, 70
Regenerate Thumbnails 56
Registration 4
Removing items 52
Renaming files 20, 51, 67
Restoring factory settings 43
Root folders 62
Rotating images 49

S
Saving finds 94
Saving galleries 80
Saving views 42

importing/exporting 129
Scripts menu 35
Search criteria 92
Search functions 89
Searching from palettes 90
Security 12, 120, 132
Serialization 140
Served catalogs 13, 132
Server. See Portfolio Server
Setting a volume name 101
Shared catalogs 131
Show/Hide fields 40

Silent mode 43
Slideshows 108, 125

auto-starting 110
editing during 109
running 109
saved as QuickTime movie 110
setting up 108

Sorting records 79
SQL server 131, 136
Status Bar 34
String fields 74
Synchronizing folders 66
System Requirements 3

T
Technical Support 4
Text Block fields 74
Text indexing 23
Thumbnail

borders 39
layout grid for print 57
options 22
quality 22
regenerating 56
rotating 50
size 38
spacing 41

Thumbnail view 36
TIF tags 25
Toolbar 33
Type options 38

U
Units of measure 30
Updating catalogs 54
URL fields 74
User Guide outline 8
User-based access 121

V
Video thumbnails 22
Views
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default 42
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record view 37
saving 42
thumbnail 36

W
Watermarks 25, 58
Web Publishing 104
Welcome Dialog Box 9
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