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DesignWorkshop Tutorials

Introductory

        Start Here - Key Concepts

DesignWorkshop is a fast, fun, and easy program to learn. Because of its unique live 3D modeling interface, it makes 
a big difference if you take a few minutes to read about a few key concepts before you start up the software.

When learning DesignWorkshop, the most important things to understand are 1) how to use the Eye tool and the 
Look tool for live 3D viewing, 2) how to move 3D crosshair around, and how to align it easily and accurately, and 3) 
how to know exactly where objects are located in the 3D modeling space, so you can create and adjust your model 
accurately.

After spending a few minutes on these basic concepts, you'll be all ready to create your first project - a complete 
simple house.

        First Tutorial - Building a Classic House

This highly-recommended 12 part step-by-step tutorial will introduce you to modeling with DesignWorkshop, starting 
with a quick overview of key concepts, and then taking you through core functions including creating and reshaping 
objects, duplicating, changing object colors, the Wallify command, and making openings. Along the way you will 
construct your own model of a classic house.

Intermediate

        Building a Contoured Site Model

This tutorial takes you step by step through the process of making a site model based on a contour drawing.

        Constructing a Spatial Dormer

This tutorial takes you step by step through the process of adding a classic gable dormer to a typical residential 
pitched roof. Shows the power of the trim tool and fit to object feature.
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DesignWorkshop Tutorial

Start Here - Key Concepts for DesignWorkshop

Contents

We at Artifice believe DesignWorkshop crosses a threshold of ease and power of use to make real three-dimensional 
architectural design in a digital environment practical for the first time.

DesignWorkshop has a simple, clear, classic-Macintosh interface to provide you with tremendous modeling flexibility, 
using just a few commands.

This design-oriented environment will let you get to work with a minimum of training time. However, 3D modeling is 
still at the top of the computer-graphics pyramid, and you'll probably need to spend a few hours and focus your 
energy to learn the key methods of DesignWorkshop. At first, DesignWorkshop will probably seem both familiar and 
alien, because, while it draws heavily from its ancestors, there's never been a 3D program quite like this before.

We like to break down the process of learning DesignWorkshop into four levels (severely abbreviated here), each one 
providing a foundation for the next. 

Viewing 

To get started, copy the application and sample file to your hard disk, and open the sample file with the 
DesignWorkshop application. Try out the direct-manipulation 3D viewing tools -- Eye and Look. Dragging in the scene 
with the Eye tool moves the viewpoint around the scene. To move into or out from the scene hold down the Option 
key (the Alt key for Windows) while dragging up or down. Also try out the 2D zooming and scrolling functions. Use the 
Window menu to open another window onto the model, and use the View menu functions to try out a variety of 
viewing and shading options in either window. 

Basic Blocks, Openings, and Manipulations 

The crucial methods of creating and manipulating blocks and openings are covered in detail in the next section of the 
manual. It is recommended that you take about an hour to carefully work through the introductory tutorial, and then 
come back to this summary learning outline. Once you have worked through the first structured tutorial, you'll be 
ready to start building objects on your own.

Picking up again at the end of the introductory tutorial, this learning guide will walk you through similar operations 
over again, but only in outline, so you can fill in the details as you go, modeling something simple but of interest to 
you.

Quit DesignWorkshop and start it up again by double-clicking on the application icon. This will give you a default new 
session with a new file open. Start out again by drawing a simple block. First click on the Block tool, then drag out the 
plan rectangle of the block in the scene with the 3D crosshair, and, without letting up on the mouse button, option-
drag (depress the Option key (the Alt key for Windows) and drag) upward to pull up the height or "z" dimension of the 
block, finally letting go when you see what you want. Notice that the 3D crosshair stays at whatever height you leave 
it. To get the crosshair instantly back to the ground plane, type the number "0" on the keyboard. Between blocks you 
can also move the 3D crosshair to any height by option-dragging the mouse with the mouse button released.

To turn a massing block into a set of walls enclosing space, select it and give the Edit menu Wallify command. To put 
an opening in one of those walls, first click on it to select it, then click on the Opening tool icon in the tool palette. 



Position the cursor over the selected wall block, and you'll see it become a 2D crosshair in the face of the block.

 

2D crosshair in block face

Press the mouse button where you want to start, and drag out the opening. Do this in a wireframe view, and then 
again in a shaded view, where the operation can be rather slow but visually effective. After you've drawn an opening, 
select it by clicking in it, and drag by one of its selection handles to resize it, or drag from the middle to move the 
opening around in the wall.

Experiment with drawing 2D objects on the ground plane, and then making them three-dimensional by extruding 
them. First draw a shape with the Polyline tool, clicking at each point along the line string, and double-clicking to end 
it as an open polyline. DesignWorkshop will automatically supply a missing segment if necessary to form a solid when 
extruding.

 

option-dragging with the 3D crosshair
to extrude a polyline into a solid.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 
crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 



an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 
crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 
an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

 

Space-jumping to a handle, then dragging it

When object-snapping is on, you can Space-Jump to non-selected handles as well.

At this point you should be ready to explore most of the palette tools and menu commands. However, one important 
general issue remains for building sophisticated models. 

Positioning in Three Dimensions 

Up to this point, the tool use has mostly assumed working from the ground plane, zero elevation. We need to add to 
that the technique of working at other elevations in space. The two key tools for accurate working in free 3D space 
are the Space-Jump and "projection lines." Space-Jump, detailed above, allows instant setting of the crosshair to the 
elevation of an existing object handle, for instance to draw a roof on top of a wall or building mass. Projection lines 
are like outline shadows cast from objects at any height in space down onto the ground plane. You may have already 
noticed that these show automatically for selected objects and objects being created. The projection lines for other 
objects can be turned on and off with functions in the Arrange menu.



Your perceptual system will automatically and unconsciously use the projection lines in building a correct mental 
model of the 3D scene. For instance, without projection lines you might not be able to see the difference between a 
small block close to the view point and high above the ground versus a large block in the distance sitting on the 
ground.

 

How high above the ground is each of these three blocks?

Projection lines are also very useful for specific alignment tasks, used together with the little foot at zero elevation on 
the vertical line of the 3D crosshair. This crosshair foot becomes visible when the crosshair is lifted above or below 
zero elevation. Then it becomes helpful to align the crosshair foot with the plan grid and the plan projection lines of 
various objects, to ensure that crosshair positions in space are actually as intended.

Other functions that support particular alignment needs are drawing by coordinate entry in the location bar at the 
bottom of the model window, and the Object Info box (opened from the Layout menu), which allows display and direct 
editing of key object parameters including height and elevation. Sometimes it may be necessary to use orthographic 
views (plan, section, elevation) to check the relative position of objects in space. DesignWorkshop facilitates this, 
supporting both multiple windows of one model (for instance, for a plan view, an elevation view, and a working 
perspective, all at once) and also opening more than one model at a time. You can cut and paste objects between 
models using standard Macintosh clipboard methods. 

Power Functions 

After mastering the knack of drawing in free 3D space with the core tools of DesignWorkshop, you will have the basis 
for putting to use any remaining functions. High among these are the four Working Orientations, which let you rotate 



your 3D crosshair 'drafting machine from plan to elevation, or to any other rotation and position in the model world. 
Other advanced functions include shadow-cast renderings, animated sun studies and walkthroughs calculated 
directly to QuickTime movies, etc. With Apple System 7, DesignWorkshop supports publishing live 2D views of a 3D 
model out to subscribe-capable drawing/drafting software, permitting a whole drawing set and a multi-person project 
team to continuously synchronize to the 3D design model.
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Building A Classic House

        Introductory Level 

For an easy way to quickly learn a useful cross-section of DesignWorkshop modeling techniques, work through the 
following tutorial sections. If you're an experienced Macintosh user, expect each section to take about 30 minutes.

This tutorial will introduce you to the basics of DesignWorkshop, starting with making a simple block, and then take 
you through the core functions including reshaping objects, duplicating, changing object colors, using the Wallify 
command, and making openings. Along the way you will construct your own model of a classic house.

In the first half of the tutorial, you'll build and render the massing model of a classic house with a front porch.

         1 - Conceptual Overview

         2 - Basic Massing

         3 - Front Porch

         4 - Porch Steps

         5 - Colors and Shadowcasting

In the second half of the tutorial you'll transform the massing model into a more realistic spatial building model with 
walls and door and windows openings. These parts move a bit more quickly than the previous sections, as they 
assume that you are already familiar with the techniques and terminology covered in the first half of the tutorial.

         6 - The "Wallify" Command

         7 - Adding Openings

         8 - Moving Through the Model

         9 - Viewing and Rendering

         10 - Details - Railings

         11 - Details - Window Frames

         12 - Details - Chimney

When you've worked through these steps, you'll be ready to take on your own design and modeling projects. Happy 
modeling! 

Contents | Next Section
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Intermediate Tutorial - Building a Contoured Site Model

        Intermediate Level 

This tutorial takes you step by step through the process of making a contour-pancake type site model based on a 
contour drawing.

This type of site model is especially useful for architectural design purposes, because it provides a very clear 
indication of the ground elevations in any view of a model. Mesh-type site models tend to look more realistic in 
presentation renderings, but often make it hard to 'read' the ground while designing.

         1 - Tracing the Contours

         2 - Extruding the Contours

Contents | Next Section
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Constructing a Spatial Dormer

        Intermediate Level 

This tutorial shows specifically how to add a classic gable dormer to a pitched roof.

More generally, it also provides an example of what how to apply the Trim tool and the Fit to Object command. 

         1 - Dormer Exterior

         2 - Dormer Finishing
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Part 1 -- Key Concepts for DesignWorkshop

Contents | Next Section

We at Artifice believe DesignWorkshop crosses a threshold of ease and power of use to make real three-dimensional 
architectural design in a digital environment practical for the first time.

DesignWorkshop has a simple, clear, classic-Macintosh interface to provide you with tremendous modeling flexibility, 
using just a few commands.

This design-oriented environment will let you get to work with a minimum of training time. However, 3D modeling is 
still at the top of the computer-graphics pyramid, and you'll probably need to spend a few hours and focus your 
energy to learn the key methods of DesignWorkshop. At first, DesignWorkshop will probably seem both familiar and 
alien, because, while it draws heavily from its ancestors, there's never been a 3D program quite like this before.

We like to break down the process of learning DesignWorkshop into four levels (severely abbreviated here), each one 
providing a foundation for the next. 

Viewing 

To get started, copy the application and sample file to your hard disk, and open the sample file with the 
DesignWorkshop application. Try out the direct-manipulation 3D viewing tools -- Eye and Look. Dragging in the scene 
with the Eye tool moves the viewpoint around the scene. To move into or out from the scene hold down the Option 
key (the Alt key for Windows) while dragging up or down. Also try out the 2D zooming and scrolling functions. Use the 
Window menu to open another window onto the model, and use the View menu functions to try out a variety of 
viewing and shading options in either window. 

Basic Blocks, Openings, and Manipulations 

The crucial methods of creating and manipulating blocks and openings are covered in detail in the next section of the 
manual. It is recommended that you take about an hour to carefully work through the introductory tutorial, and then 
come back to this summary learning outline. Once you have worked through the first structured tutorial, you'll be 
ready to start building objects on your own.

Picking up again at the end of the introductory tutorial, this learning guide will walk you through similar operations 
over again, but only in outline, so you can fill in the details as you go, modeling something simple but of interest to 
you.

Quit DesignWorkshop and start it up again by double-clicking on the application icon. This will give you a default new 
session with a new file open. Start out again by drawing a simple block. First click on the Block tool, then drag out the 
plan rectangle of the block in the scene with the 3D crosshair, and, without letting up on the mouse button, option-
drag (depress the Option key (the Alt key for Windows) and drag) upward to pull up the height or "z" dimension of the 
block, finally letting go when you see what you want. Notice that the 3D crosshair stays at whatever height you leave 
it. To get the crosshair instantly back to the ground plane, type the number "0" on the keyboard. Between blocks you 
can also move the 3D crosshair to any height by option-dragging the mouse with the mouse button released.

To turn a massing block into a set of walls enclosing space, select it and give the Edit menu Wallify command. To put 
an opening in one of those walls, first click on it to select it, then click on the Opening tool icon in the tool palette. 



Position the cursor over the selected wall block, and you'll see it become a 2D crosshair in the face of the block.

 

2D crosshair in block face

Press the mouse button where you want to start, and drag out the opening. Do this in a wireframe view, and then 
again in a shaded view, where the operation can be rather slow but visually effective. After you've drawn an opening, 
select it by clicking in it, and drag by one of its selection handles to resize it, or drag from the middle to move the 
opening around in the wall.

Experiment with drawing 2D objects on the ground plane, and then making them three-dimensional by extruding 
them. First draw a shape with the Polyline tool, clicking at each point along the line string, and double-clicking to end 
it as an open polyline. DesignWorkshop will automatically supply a missing segment if necessary to form a solid when 
extruding.

 

option-dragging with the 3D crosshair
to extrude a polyline into a solid.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 
crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 



an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 
crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 
an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

 

Space-jumping to a handle, then dragging it

When object-snapping is on, you can Space-Jump to non-selected handles as well.

At this point you should be ready to explore most of the palette tools and menu commands. However, one important 
general issue remains for building sophisticated models. 

Positioning in Three Dimensions 

Up to this point, the tool use has mostly assumed working from the ground plane, zero elevation. We need to add to 
that the technique of working at other elevations in space. The two key tools for accurate working in free 3D space 
are the Space-Jump and "projection lines." Space-Jump, detailed above, allows instant setting of the crosshair to the 
elevation of an existing object handle, for instance to draw a roof on top of a wall or building mass. Projection lines 
are like outline shadows cast from objects at any height in space down onto the ground plane. You may have already 
noticed that these show automatically for selected objects and objects being created. The projection lines for other 
objects can be turned on and off with functions in the Arrange menu.



Your perceptual system will automatically and unconsciously use the projection lines in building a correct mental 
model of the 3D scene. For instance, without projection lines you might not be able to see the difference between a 
small block close to the view point and high above the ground versus a large block in the distance sitting on the 
ground.

 

How high above the ground is each of these three blocks?

Projection lines are also very useful for specific alignment tasks, used together with the little foot at zero elevation on 
the vertical line of the 3D crosshair. This crosshair foot becomes visible when the crosshair is lifted above or below 
zero elevation. Then it becomes helpful to align the crosshair foot with the plan grid and the plan projection lines of 
various objects, to ensure that crosshair positions in space are actually as intended.

Other functions that support particular alignment needs are drawing by coordinate entry in the location bar at the 
bottom of the model window, and the Object Info box (opened from the Layout menu), which allows display and direct 
editing of key object parameters including height and elevation. Sometimes it may be necessary to use orthographic 
views (plan, section, elevation) to check the relative position of objects in space. DesignWorkshop facilitates this, 
supporting both multiple windows of one model (for instance, for a plan view, an elevation view, and a working 
perspective, all at once) and also opening more than one model at a time. You can cut and paste objects between 
models using standard Macintosh clipboard methods. 

Power Functions 

After mastering the knack of drawing in free 3D space with the core tools of DesignWorkshop, you will have the basis 
for putting to use any remaining functions. High among these are the four Working Orientations, which let you rotate 



your 3D crosshair 'drafting machine from plan to elevation, or to any other rotation and position in the model world. 
Other advanced functions include shadow-cast renderings, animated sun studies and walkthroughs calculated 
directly to QuickTime movies, etc. With Apple System 7, DesignWorkshop supports publishing live 2D views of a 3D 
model out to subscribe-capable drawing/drafting software, permitting a whole drawing set and a multi-person project 
team to continuously synchronize to the 3D design model.
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Part 2 -- Basic Massing
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1. If you haven't already installed DesignWorkshop (or DesignWorkshop Lite), install DesignWorkshop now by 
dragging the application folder onto your hard disk. 

2.Start up the DesignWorkshop application by double-clicking on the application icon. 

3. Thoughtfully look over the application environment. Notice the standard menu bar across the top of the screen, the 
tool palette on the left, the document window with the location bar across the bottom. Within the document window, 
notice the 3D workspace itself, with the 3D crosshair, grid lines at 5' spacing, and a north arrow. Move your mouse 
around and watch how the crosshair moves around in the modeling space.

This 3D crosshair is your fundamental tool in DesignWorkshop. Move the mouse forward to move the crosshair 
toward the back of the modeling environment. Pull the mouse back toward you so the crosshair is near the front side, 
or south, of the background grids. Observe that the 3D crosshair is actually in the modeling space, moving in 
perspective.

Now hold down the Option key (the Alt key for Windows) on your keyboard, and again move the mouse forward and 
backward. The 3D crosshair will move up and down vertically in the modeling space. Release and reapply the Option 
key while dragging some more. By combining plain- and option-dragging you can move the 3D crosshair freely about 
in space. Notice also that when the crosshair is lifted up off the ground plane, a little cross foot is visible at zero 
elevation. By watching this "crosshair foot", you can always track the crosshair's location relative to basic plan 
alignments.

Move the crosshair around in 3D until it feels comfortable. The next step is to start building. 

4. Draw a block to be the mass of a simple two-story building: Click on the Block tool, tap the zero key to make sure 
the crosshair is on the ground plane, and then drag out a rectangle on the floor of the workspace, aligned to the 
background grid as shown below. Without releasing the mouse button, use your non-mouse hand to hold down the 
Option key (the Alt key for Windows) and drag up the height of the block with the mouse. As you option-drag, watch 
the number in the "V" field of the location bar to arrive at a height of 20 feet.



 

Creating a block in 3D

If the block comes out wrong at first, just Undo and draw it again. After some practice, creating a block like this in 
perspective will become second nature. 

5. Notice that your crosshair ends up at the elevation of the top of the block. The crosshair can be moved up and 
down in the model space at any time by dragging the mouse with the Option key (the Alt key for Windows) down 
("option-dragging"). But there are also some shortcuts for getting where you want to work quickly. First, watch the 
crosshair while you type the number "0" on the keyboard again (without clicking the mouse at all). The crosshair 
drops to zero elevation. You can jump to any elevation from 0 to 9 similarly with one keystroke.

More usefully, you can also jump to any handle on a selected block. To get the crosshair back to the top of the 
massing block, position the 2D cursor over one of the top corner handles of the block, temporarily ignoring what's 
going on in 3D. Then hit the space bar on the keyboard. The 3D crosshair "space-jumps" to the exact 3D location of 
any handle under the 2D cursor, and out the relative coordinates in the location bar are zeroed out.

Try this out. With the block you've made still selected, position the drawing cursor over the selection handle at the 
front, left, top corner of the massing block, and then just tap the space-bar on your keyboard. If the crosshair was 
already aligned to the same height as that corner of the block, only the numbers in the right half of the location bar 
will change (they should all read "0" after the space jump). However, frequent use of the space jump is a good habit 
to develop -- it's a crucial tool to help you accurately establish the correct elevation to draw at.



6. Now draw a block for a roof. The Block tool should still be highlighted in the tool palette, and the crosshair should 
be at the correct height due to the last space jump, so you can just position the crosshair horizontally and draw. 
Confirm that the Z field of the location bar reads 20', then move the crosshair off from the block corner a foot to the 
west and to the south for an overhang, then drag horizontally to the diagonally opposite corner, so the location bar E 
field reads 27 and the S field reads 22, and then finally hold down the Option key (the Alt key for Windows) and 
continue dragging upward a few feet until the V field reads 10. As you draw, notice that a projection of your block in 
plan is continuously updated on the ground plane (at zero elevation). These "projection lines" are an important aid to 
perception of depth in the perspective space -- use them to help size and position the roof block.

When you release the mouse button, the Block tool stays on, and the last block stays selected (until you draw 
another) so its projection lines remain visible.

 

Drawing a block for the roof

7. Now, let's adjust our view to make the next step easier. Click on the Eye tool, and then to move a few degrees 
around the model to the right, drag the eye cursor across the window gradually to the right, and also up a little. Stop 
when your view of the model matches the next illustration.

8. Now make that coarse block into a gable roof. Notice that the block has mid-edge handles showing, which can be 
distinguished as unfilled white squares. In general, dragging on a mid-edge handle moves one edge of an object, 



changing its shape rather than its overall size.

First click on the selection arrow (in the tool palette) to return to the default mode. Then space-jump the 3D crosshair 
to the top mid-edge handle on the south, front, of the roof block (by positioning the 2D cursor, and then tapping the 
crosshair).

Then mouse-down and drag the edge to form half a ridge line in the middle of the roof. Watch the projection lines on 
the ground plane to help align to the center.

Then space-jump to the top back mid-edge handle, and drag it to join the other at the ridge line, completing the gable 
form.



You should now have a gable roof. Pull down the View menu and turn on Shading to see the solid mass of the little 
house. Double click the selection arrow to deselect everything and get the handles out of the way.

 

Shaded view of the gable roof

9. Select the Eye tool and drag the eye cursor around the window a bit to admire your creation, and the dynamic view 
manipulation of DesignWorkshop. When you're done admiring, return the view to about the same angle we just used, 
looking downward and toward the east end of the little building. 

10. This would be a good time to save your work. As with any software, with DesignWorkshop you should save 
frequently. Use the File menu Save command. Then for convenience turn off shading by pulling down the View menu 
to the Wireframe command.
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Part 3 -- Front Porch
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1. Now we'll add a front porch to the cottage, starting with a block for the porch floor. Select the Block tool again from 
the tool palette, and then type the zero key to drop the 3D crosshair down to the ground plane. Move the crosshair 
horizontally to align with the front left (southeast) corner of the building. Starting at that corner, drag out a block which 
goes 6' to the east, the full 20' width of the building to the north, and upward 2'.

2. We'll use a slightly different approach to create the porch roof. Noticing that the porch roof block will be similar in 
size to the porch floor block, we'll clone the block we just made and then turn the clone into a porch roof.

The cloning is easy. With the porch floor block still selected, since it was just created, pull down the Edit menu and 
give the Duplicate command.

Next move the new block into the right location in plan. Typing the arrow keys will move a selected object one snap-
grid space at a time. Since the Duplicate function offsets the new object by two snap-grid units south and east, type 
the Up arrow key twice, and the left arrow key twice, to put the new block in exactly the same place as the porch floor.



 

Shaded view of the gable roof

Now, option-drag on the selected block to lift it straight up into position. Option-drag upward until the V field in the 
location bar reads 10', meaning the block has moved upward that much. (This will give 8' head room over the 2' high 
porch.)

 

Shaded view of the gable roof

3. With the porch roof in place, the next step is to adjust its shape. A slightly different view will be helpful for this, so 
get the Eye tool, and drag your view point downward a little. When done, the view should match the next illustration. 
After you've worked with the DesignWorkshop Eye tool and Look tool for a while, you'll find that adjusting your view to 
get the best angle on things as you work becomes almost unconscious, like moving your head to see things better in 
real life.



While you're still getting used to DesignWorkshop, avoid trying to do a lot of block building when the view direction is 
too close to horizontal, as indicated by the horizon line being visible below the top of the document window. Because 
of the natural geometry of perspective projections, the 3D crosshair may seem to get "stuck" above the horizon. If this 
happens, just type 0 to bring the crosshair back to the ground, or use the Eye tool to change the view direction.

Returning to the process of forming the porch roof, we'll pull down the top front edge of the roof block about a foot, 
leaving a foot of fascia. First space-jump to the top front mid-edge handle of the roof, then option-drag it downward 
one foot.

To finish the porch roof, pull up the top back edge, establishing the pitch Space-Jump to the top back edge of the 
porch roof block, then option-drag to pull it upward two feet.



 

Shaded view of the gable roof

4. Your new porch roof needs some structure to hold it up. We'll make one post, and then duplicate it across the front 
of the porch. In this case it's probably easiest to place the first post in the right place by drawing it down from the top, 
rather than up from the bottom.

To do this, click on the Block tool again, and then space-jump to the front-most bottom handle of the porch roof. Then 
press the mouse button and carefully drag out a half-foot by half-foot rectangle, watching the projection lines at the 
ground plane (and so the location bar reads E -0.5, S -0.5), and then option-drag downward until the post just sits on 
the porch floor block (V -8.0).



The finished post should match the next illustration.

5. Duplicating the posts is easy. First, notice the orientation of the north arrow. The posts will want to duplicate to the 
north. Pull down the Edit menu and give the Duplicate Multiple command. The porch is 20' wide, so set the total 
number of objects to 5, the displacement eastward to 0, the displacement southward to -5', and the vertical 
displacement to 0 (since north equals negative south). Then click OK to duplicate the objects.
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1. Stairs up to the porch will complete the massing model. Prepare to construct the stairs by zooming in two-
dimensionally on the porch area. Click on the Zoom In tool (at the bottom right of the tool palette) and drag out a 
zoom rectangle as shown below.

The zoomed-in view will look like this. Notice the change in the zoom percentage tool.



The projection lines of the new porch posts will help place the steps. Type 0 to ground the crosshair, then move it 
over to coincide with the front edge of the porch, at the north side of the middle post. Then tap the space bar. This will 
zero out the relative coordinates in the location bar (E, S, and V), even though since there is no object handle behind 
the crosshair, the crosshair won't change position. By zeroing the relative coordinates at a reference location, E, S, 
and V can be used to measure the distance to the next object location.

To begin the first step, move the crosshair 3' to the east (so the relative coordinates read E 3, S 0, and V 0). Then 
drag out the plan of the step, northward parallel to the porch 4.5', and back toward the porch one foot, and option-
drag half a foot upward.

Now multiple duplicate, much as before, to make the rest of the steps. Use the Edit menu Duplicate Multiple 
command, matching the settings shown in the illustration below.



The steps will appear as below.

2. Notice that the north-most post is just hanging off the end of the porch. Click on it to make it the only selected 
block, then type once with the down-arrow key, to nudge the post 6" southward onto the porch.



3. That completes the construction of the basic massing model. Click on the Zoom Percent tool to restore the zoom to 
100%, then give the View menu Shading command to admire your efforts.
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1. For a more realistic view, get the Eye tool and drag down and to the right to look at the front facade of the building.

2. From this vantage point a more likely color can be chosen for the walls of the cottage. Select everything but the 
roofs by getting the arrow tool and dragging a selection rectangle across the lower half of the building. (Because of 
the likelihood that objects will extend beyond the viewing window in 3D, a selection rectangle in DesignWorkshop 
selects any object inside it or crossing it.) When the correct objects are selected, double-click on the color indicator 
icon in the tool palette to open the color picker. Pick a bright yellow color (from near the center of the picker wheel, so 
it's not too saturated).



When you click OK, this new color will be assigned to the selected objects, and will become the current color, used 
for any new objects you draw.

That completes the creation of the massing model of a simple cottage! To complete this section of the tutorial, pull 
down the View menu and give the Shadow Casting command.



3. Depending on the relative speed of your Macintosh, it may take up to the better part of a minute to finish the initial 
shadow calculation. When that's done, get the Eye tool and move in increments all the way around the model.



Notice how much more quickly the model redraws, yet observe the shadows visible all around, even on the back wall 
of the cottage. This is because shadows in DesignWorkshop are calculated as 3D objects in the model space, not just 
as a screen bitmap, so after the initial calculation the shadows are valid for any view of the model, until the sun time 
or the model geometry is changed.

4. You now have the basics for building solid models in DesignWorkshop. Be sure to save your work, and it take a 
quick break before going on to the next section.

In the next section of the DesignWorkshop tutorial, you'll learn how to quickly turn the massing model into a full 
spatial model with an interior, solid walls, and door and window openings.

Previous Section | Contents | Next Section

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index

© 1998 Artifice, Inc. - All Rights Reserved. 





4.2.6 - DW Tutorial -- 6 

 Artifice, Inc.
DesignWorkshop Tutorial

Part 6 -- The "Wallify" Command
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1. Architectural design often proceeds from massing models, solid all the way through, to hollow models with 
interiors, which we call spatial models. DesignWorkshop facilitates the development of your project from massing to 
space-defining with the Wallify command. Before you wallify, however, you should establish a block underneath the 
walls of the building for substructure and to be the ground floor of the building. (Note that the ground floor of most 
buildings is not literally right at grade. Even at this basic levels, most environment modelers begin to oversimplify 
when they assume the ground and the ground floor are identical!)

Here's what your model should look like when you've completed the first five parts of this tutorial.

2. To define the substructure block, first click on the main massing block of the cottage to select it.



Then click on the Trim tool in the tool palette, and move the crosshair over the selected block. Notice that the 
crosshair has a different character when you're in the trim tool. We call this kind of crosshair the "faces crosshair", 
and it's used by several DesignWorkshop tools. (There is a lot of internal complexity to DesignWorkshop to allow it to 
automatically provide various different crosshairs according to your working context).

The Trim tool uses the faces crosshair because trims are defined by a trim line you draw on the surface of an object 
or group. Cut the massing block 2' above the ground, level with the porch floor, by first positioning the crosshair at a 
point 2' up from the ground edge of the building side, and somewhat in from the side edge. Then press down the 
mouse button to pin the trim line at that point, and drag sideways first, then up and down carefully to get the trim line 
exactly horizontal. (If it's close enough, the snap grid will make it exact.) When you release the mouse button, the cut 
will be extended all the way through the massing block, perpendicular to the face on which you drew the trim line.



3. Click on the Selection Arrow tool, then click on the lower block to select it. Its handles should appear.

If another block is selected instead, click again until you have the walls selected as shown above. Then give the Edit 
menu Wallify command. When the wall thickness dialog box appears, just click OK (or hit Return) to accept the 
default half-foot thickness. Your massing block becomes four walls, mitered together at the corners. Even though you 
can't see inside yet, if you look closely, you can see the change in the projection lines, which are now doubled all the 
way around.
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Part 7 - Adding Openings
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1. Now we'll proceed to put door and window openings. To start with a first opening, click on the south wall so it's the 
only object selected, then click the Opening tool in the tool palette. When you move the crosshair over the selected 
block, it switches to a 2D crosshair within the face you're drawing in. Move the crosshair around the face until it's 
positioned where you want the first corner of a second floor opening to be, and then just drag a rectangle to make the 
opening. If you're using an older Mac, this process may be slow while you're working in a shaded view, so after 
dragging the rectangle keep the mouse still with the button down until the window is redrawn at the size you want. 
Then release the button, and the opening will be complete.

2. Switch to a wireframe view for speed, with the View menu Wireframe command, and draw another opening next to 
the first. Start at one corner of the window opening, and drag to the other corner of the window you want, to cut 
through the opening.



Cut two more openings in the south wall for the first floor level.



3. Use the Eye tool to adjust your view around to the right, so you're looking more at the east, front, facade of the 
cottage. Also move a little closer in to the facade to the view shown, by option-dragging with the Eye tool to move into 
the scene.



4. Select the east wall of the cottage...

...and cut another second floor window opening as shown.



5. We'll use another method to make the next two openings. Choose the Arrow tool from the tool palette, then click 
right in the middle of the window opening you just made to select the opening. Then give the Edit menu Duplicate 
command. When an opening is selected, this command duplicates it, just like any other DesignWorkshop object.



The new, second opening ends up selected. Click the right arrow key once to nudge the new window 6" away from 
the first.

Then Duplicate again. This time, take the new, third, window, and drag it across the east wall to the north side of the 
facade (to match the next illustration). Observe that openings in DesignWorkshop also drag just like other objects, 
although they are constrained within their parent object.



6. Working the same way, draw three openings at the ground floor level of the east facade. Position the windows as 
shown.



7. It looks like the front door should be where that last opening is. To change the window-size opening into a door-
size opening, choose the Arrow tool, then, with the opening still selected, grab one of its lower handles, and slowly 
drag this straight down to the bottom of the wall. (If you go too fast, you may not be able to drag all the way to the 
bottom edge of the wall. In this case, just drag the corner up a bit, then back down more slowly.)



8. That's enough to give a good sense of the basics of the transition to a spatial model. You wallified, then created, 
duplicated, moved, and resized openings. Now use the View menu Shadow Casting command to shine sun on your 
model.
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1. Now let's go inside! Choose the Eye tool...

...and swing around to the left nearly 180 degrees (which may take a more than one motion) until you're looking 
straight into the back of the house...



...then option-drag with the Eye tool to move forward, until you're right inside the space of the cottage.

When you release the mouse button, the view will redraw with shading, and look about as shown in the next 
illustration.



2. To look around the wide-open space inside the cottage, use the Look tool. While the Eye tool moves the eye point, 
or "the point you're looking from", around the model space like you're sliding around the surface of a sphere, the Look 
tool moves the "point you're looking at", as if you're standing still at the center of a sphere, looking around in different 
directions. Just drag the Look tool somewhat carefully in the direction you want to look toward.

3. Now we'll create a window opening from inside the cottage. Use the Look tool to look toward the left, or north, wall 
inside the cottage.



4. Shade the model for dramatic impact, then click on the wall to select it, and drag out the window opening just as 
before.

5. Your current view points can be saved in DesignWorkshop at any time, so you can get back to a particular eye and 
look location easily. When your view matches the last illustration, use the View menu Set View command to save the 
view. Name the view as you like in the dialog box that comes up, and then notice that the new view is automatically 
added to the user views area at the bottom of the View menu.
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Part 9 -- Viewing and Rendering
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1. To get your view points back to a standard overview, give the View menu Initial View command. Then give the View 
menu Shadow Casting command to bring back the shadows, which were canceled when the model was changed.

2. Now that we have something to look at, we'll quickly go through some of the other viewing possibilities. First, give 
the View menu Plan command.



Then turn on sectioning with the View menu Section command. This doesn't actually cut the geometry of your model, 
but shows it as if it had been cut and pochéd.

Use the Zoom In tool to frame the plan view more closely...



...like this.

3. Then give the View menu Elevation > South command to see a section view looking toward the north.



Do the View menu Sectioning command again to turn off (uncheck) sectioning, and see a regular south elevation.



4. Click once on the Zoom Percent tool in the tool palette, to restore normal 100% zoom, and then give the View 
menu Initial View command (by menu, or by the command key shortcut) to return, full circle, back at the overview.

5. That completes the second section of the tutorial! Moving around in DesignWorkshop should be starting to feel a 
bit more natural now, since you've worked through the most important and fundamental functions.

From here on, it's mostly details!
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1. To continue on your own for some more practice, start by making railings for the porch and front steps. For detailed 
work like this you'll want a finer snap grid. To change the setting select "Dimensions..." from the Preferences sub 
menu in the Layout menu. Setting the snap grid to 0.25' should be fine for now.

To make a railing set the z of the cursor to 5 feet. Use the visual cues of DesignWorkshop to line up the cursor 
properly and make a box as shown below. The size of the block is 5.5' east, 0.5' south, and 0.25' vertically.



Continue making similar blocks between the posts to serve as railings. Leave a gap between the posts where the 
stairs pass.

2. Now make a block which will serve as the railing for the stairs. It should line up with the post and the dimensions of 
the block are 3' east, 0.5' south, and 0.25' vertically. The location of the block is 5 feet off the ground.



Select the faces mode tool from the tool pallette. It is right above the eye tool. Select the eastern-most face of the 
block you just made.

Now click on the face and while holding down the Option key (the Alt key for Windows) drag the mouse downward. 
This pulls the selected face of the object downward, resulting in a sloping block to serve as a hand railing. Continue 
pulling down until the change in the vertical location of the face is -1.5' as shown in the location bar.



Duplicate the block you just made and move it over to line up with the post on the other side of the stairs. 

3. There needs to be a post at the bottom of the stairs to support the railing. To do this make a block that is half-a-foot 
square in plan. Make the block a couple feet high, but don't drag it all the way up to the railing.

Now you will fit the post you just made to meet flush against the railing. To do this go to the Arrange menu and from 
the Fit sub-menu select Upward.



This makes the selected object expand upwards until it meets another object. In this case that means the post 
extends upwards until it meets the railing.

Now duplicate this post and move the new one to the other stair-railing.
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1. Window frames are next in order of detailing the cottage. To quickly make window frames make a single block in 
the approximate proportions of your windows which is 0.25 feet deep. Then cut openings in this block using the 
opening tool to represent glass.

2. Next you will Copy this object into the clipboard using the Edit menu's Copy command. Now select an opening in 
the cottage by clicking once on the opening. Select Paste from the Edit menu and you will see a dialog box for 
pasting into openings. In this case we want the pasted object to scale by height and width of the opening, but not 
depth. And we want the pasted object to align with the center of opening.



When you click OK the window frame you copied into the clipboard will be pasted into the opening that you selected.

3. Now select each opening and paste the window frame into each one.



4. Now make a block to paste in for the front door, just follow the same procedure as above and you should have no 
problems. 

5. Now just render it and admire what you've accomplished.
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1. After adding a chimney you will have a fairly complete spatial model. Set the cursor to the height of the top of the 
chimney. For this cottage that will be even with the ridgleline of the roof, so select the roof block and Space Jump to 
the top mid-edge handle.

2. Now select the block tool and position the cursor in the x and y planes to make the chimney. Use visual cues such 
as the foot of the 3D crosshair and projection lines, along with numerical information from the location bar to get the 
proper position.



3. Make a block for the chimney with the correct horizontal dimensions, but only pull it down a few feet for now.

4. Once again you'll use the fit command, as you did when making the stair railing. This time, however, you'll fit 
downward. Select the chimney block and choose Arrange > Fit Object > Downward. The block will expand downward 
until it hits another object, in this case the roof.



5. Now you'll probably want to change the color of the chimney. All that's left is to shadow cast the model and admire 
the work you've done.

The cottage interior can also be constructed using and extending the methods covered in this tutorial. The finishing 
touches might be to copy and paste in furniture and cabinetry from the 3D libraries. Then you'll be ready to take on 
your own project.
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You can use just about any existing 2D contour drawing to build a 3D contoured site model in DesignWorkshop. This 
tutorial shows how to build a contoured site model working from a pixel image of a contour drawing.

If your starting point is a drawing on paper, you would start by scanning the drawing, which will give you a pixel image 
of the drawing. Save this in PICT format so it can be opened in DesignWorkshop as a background image. Any 
background image can be traced accurately in the plan or elevation views.

Alternatively, if your starting point is a computer drawing in DXF, object PICT, or PowerCADD Scaled PICT format, 
you can import the drawing into the 3D modeling space directly, instead of scanning first. As a result, you can work 
with the drawing directly in perspective as well as in plan view. 

1. To follow along with this tutorial exactly, you can use the file name Contours.pict on the DesignWorkshop CD-ROM. 
It can be found in the Accessories:Backgrounds folder. 

2. Once you have a PICT file of the contour drawing of your site go to plan view in DesignWorkshop. In the File menu 
go to Background > Open.... Select the PICT you are going to use and it shows up as a background image. Every 20 
pixels in the PICT will be scaled to one working unit in DesignWorkshop, by default this means there will be 20 pixels 
per feet. With this knowledge you can scale your PICT before opening it as a background. In this tutorial we did not 
scale the PICT, we will scale the entire model towards the end. Either method is OK.

3. Now you'll want to zoom in so you see the background in its entirety and not much else. Use to 2D zoom tool in the 
lower left corner of the tool pallette to do this. You'll probably want a finer grid snap than 0.5 feet, so set this to 0.25 



feet by selecting Preferences > Snap Grid from the Layout menu.

4. Now you want to find the corner of the contour drawing with the highest elevation. In our case, this is the upper 
right corner. Most of the contour lines we make will begin from this corner. Now with the polyline tool, start at the 
highest corner and trace around the nearest contour line making a closed loop around the highest corner. You are 
making polyline "pancakes" which will later be extruded upwards so you'll end up with a series of layers forming your 
contour model. When this polyline is finished continue to the next contour line. Again starting at the highest corner 
and tracing the contour. Continue the process for each contour line.

5. Some of the contours on the drawing are likely to be different than they are drawn. For example we are making a 
flat area for the footprint of the building. So when a contour reaches the edge of the building location we are wrapping 
it around where the building will go and continuing it on the other side. To clarify this we have used the pencil tool to 
show where the contour lines are going in our model.



6. Just continue tracing the contours as polylines, always starting and finishing each polyline at the highest corner.

7. Now we'll make a polyline tracing the building footprint.



8. In this contour drawing we know the size of the lot, and the property lines are drawn on the map, so for scaling 
later, we'll make a polyline which traces the property line.

9. Now we'll go back and trace a couple contours that we missed. In each of the lower corners is a contour that we 
couldn't trace from the highest corner because their "pancake" never meets with that corner.
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1. After completing part 1 of this tutorial close the background and go to perspective view and you'll see all the 
polylines you've made as flat 2D objects on the ground plane.

2. Now select the polyline of the lowest elevation and extrude it to the height of your contours. In this case that is one 
foot. Now would be a good time to change the grid snap to one foot. Once it is extruded hide the object. Select the 
next lowest polyline and extrude it upwards one foot, then move it up a foot and hide it. Continue upwards so the next 
one is extruded a foot and moved up two feet.



Continue this process until you've extruded and positioned all the contours. Extrude the polyline representing the 
building mass and position it's properly in elevation.

3. When you cancel the hide you should see something like what is shown below -- a fairly complete contour model. 
The scale is correct in the z dimension, but not in the x and y dimensions.



4. Select the object that traces the property line and note the size of the object as shown in the Object Info floating 
window. In this case the object is 50.5 feet wide when it should be 112 feet.

5. Dividing the size it should be by the size it is shows we need to scale the model by 221.78%. Select all and group 
the entire model. Choose Scale from the Edit menu and enter 221.78% as the North-South and East-West numbers. 
Leave the vertical at 100% because it is already correct.



Now your model is scaled correctly.

6. Here all we've done is changed the colors and added a couple blocks for the roof of the building. Now you'll 
probably want to add trees from the libraries provided with DesignWorkshop, or make your own trees and other 
landscaping objects.
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This is a step by step process for layout and modeling of gable dormers on a pitched roof, suitable for a detailed 
building model. It takes a lot more words to describe, than it takes time to do! (At least, after you've practiced it a few 
times...)

This tutorial begins at the point of you having the shell of a building. Exterior walls, and the slabs of the roof have 
already been modeled. Refer to the cottage tutorial if you are unsure how to get this far.

1. Position and size the dormer by making a simple block to represent the walls of the dormer. In this tutorial we are 
making a six-foot wide dormer. Be sure to make the block long enough that it extends well into the "attic space" inside 
the roof slab.

Check this dormer massing block in front and side elevation views, to make sure you have it where you want it.



2. Next, make little roof slabs for the dormer itself, and tilt these up (selecting their inner face with the faces tool, then 
dragging or nudging the edge face upward). Make the length of the dormer roof pieces short enough that they don't 
touch the main roof. In this tutorial we are using a 12/12 roof pitch.

3.Then, when they are at the correct pitch, use the Arrange menu Fit Object > North command to extend the 
little dormer roof pieces over to the main roof slab.



4. Now, select the dormer massing block, and wallify it (in the Edit menu), setting the appropriate wall thickness.

5. While the walls are still selected, use the Arrange menu Fit Object > Upward command to fit the walls up 
into the dormer roof.



6. Use the Trim tool to slice the extra ear off the front wall of the dormer, where it sticks above the dormer roof 
after the Fit Object > Upward operation.

7. The innermost piece of wall from the dormer massing block is just scrap. Select this piece, and delete it (by typing 
the Delete key (the Backspace key for Windows). 

8. Go to a side elevation view, and zoom in so you can see the dormer pieces well. Then select one dormer side wall, 
and use the Trim tool to slice it along the front surface of the main roof slab. Select and delete the inner scrap piece 
of that wall. Repeat for the other dormer side wall.



9. The dormer should now be externally complete.
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1. Use the Opening tool to cut the desired window opening in the front wall of the dormer.

2. The last step is to cut out the main roof slab where the dormer space connects with the attic space. There are a 
couple of approaches to this.

A very quick, but approximate, approach is to select the main roof slab, and then use the Poly-Opening tool to cut 
around the inside of the dormer walls and roof to make the appropriate opening.



But this results in the faces of the opening in the roof being at the wrong angle for a dormer. (They'd be good for a 
skylight though.)

So we'll show you a more accurate way to get all the pieces to line up nicely. 

3. Using the Trim tool on the main upper face of the main roof slab, make three parallel cuts, along the fall line of the 
roof pitch, aligned with the center of the dormer and with the inside of each of the dormer side walls.



4. This produces two strips in the main roof, which need to be trimmed at a compound angle. (This tricky cut is 
horizontal along a level line perpendicular to the eave line, but is angled relative to a level line parallel to the eave 
line, and it's also angled relative to the face of the main roof slabs.)

To make the correct trim, select one of the strips of main roof slab, and Group it with itself. Then use the Trim tool 
on the front elevation face of the group bounding box, to slice aligned with the underside of the dormer roof. Repeat 
for the other strip of main roof slab.

5. Now there's just a little clean-up work. Delete the lower, scrap portion of one of the roof strips.

Then select the lower portion of the other roof strip, and again Group it with itself. This time, use the Trim tool on 
the top or side face of the group bounding box, to cut a filler piece for where the main roof crosses below the dormer.



6. Finally, select and delete the inner scrap piece of roof slab, and then select the lower filler piece, space-jump to a 
corner handle, and stretch it parallel to the eave line of the main roof, until it matches the width of the front of the 
dormer, and fills the gap in the main roof.

That's it! Once you've made one dormer, you can group its parts, and duplicate the dormer around your project as 
required. To save time making the opening in the roof slab, include a section of the main roof as part of your dormer 
group as well.

In the next couple of screen shots we added a window frame, which you can easily do using the Paste Into Opening 
feature as discussed in the cottage tutorial.
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