
About Gloodle

Displays the version number and copyright information for Gloodle.

Copyright (C) 1998    Alan Lorence
Brought to you by Impulse, Inc.

Toolbar: none

Shortcut: none

Help Menu



All history colors

This command will set all shapes to colors from the color history.

The first shape is set to the first history color, the second shape to the second history color, and so on.    
When the last history color is assigned, the first history color is used again.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



All random colors

This command will set all shapes to random colors.

Note that there are some restrictions on the colors that will be chosen.    For instance, very dark colors will 
not be chosen, nor will colors with very low saturation.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



All this color

This command will set all shapes to the color of the selected shape.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



All this size

This command will set all shapes to the size of the selected shape.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Arrange Icons

Use this command to arrange the icons for minimized drawings at the bottom of the main window.    If 
there is an open drawing at the bottom of the main window, then some or all of the icons may not be 
visible because they will be underneath it.

Toolbar: none

Shortcut: none

Window Menu



AutoChange Hue

When active changes the hue of the drawing color automatically.

There are two settings: the "direction" of change, and the speed of change.    The Up option causes the 
hue to change toward the right (purple-red) in the Colors Window, then wrap around to the left edge.    The 
Down option causes it to change to the left (orange-red), wrapping around to the right.    Up & Down 
causes the hue to change toward the right (purple-red) first, but then reverse direction and move back 
toward the left (orange-red).    Down & Up is similar, but moves to the left (orange-red) first, then switches 
toward the right (purple-red).    Random chooses a random hue and moves toward it.

The speed at which the hue changes is set using the Speed slider.    The hue changes only while globs 
are being drawn -- it is not a timed change.

Note that when you Undo drawing with this function active, the color does not return to its starting value.    
You must use the color history "Previous" button to reselect the starting color.

Tip: Use this function set on Random with the AutoChange Sat and AutoChange Val functions set on 
Random as well to see the widest variations of color as you draw.
Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: You can use the 1 and Q keys to change the hue manually while drawing instead of using this 
function.

Toolbar:

Shortcut: none

Colors Menu



AutoChange Sat

When active changes the saturation of the drawing color automatically.

There are two settings: the "direction" of change, and the speed of change.    The Up & Down option 
causes the saturation to change toward the top (most color) in the Colors Window, then reverse direction 
and move toward the bottom (least color).    The Up option causes the saturation to change toward the top 
(most color) in the Colors Window, then stop when it reaches the maximum (top).    The Down option 
causes it to change toward the bottom (least color) then stop when it reaches the minimum (bottom).    
The Down & Up option is similar to Up & Down but moves toward the bottom (least color) first, then 
toward the top (most color).    The Random option chooses a random saturation and moves toward it.

The speed at which the saturation changes is set using the Speed slider.    The saturation changes only 
while globs are being drawn -- it is not a timed change.

Note that when you Undo drawing with this function active, the color does not return to its starting value.    
You must use the color history "Previous" button to reselect the starting color.

Tip: Use this function set on Random with the AutoChange Hue and AutoChange Val functions set on 
Random as well to see the widest variations of color as you draw.
Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: You can use the 2 and W keys to change the saturation manually while drawing instead of using this 
function.

Toolbar:

Shortcut: none

Colors Menu



AutoChange Val

When active changes the value of the drawing color automatically.

There are two settings: the "direction" of change, and the speed of change.    The Up & Down option 
causes the value to change toward the top (brightest) in the Colors Window, then reverse direction and 
move toward the bottom (darkest).    The Up option causes the value to change toward the top (brightest) 
in the Colors Window, then stop when it reaches the maximum (top).    The Down option causes it to 
change toward the bottom (darkest) then stop when it reaches the minimum (bottom).    The Down & Up 
option is similar to Up & Down but moves toward the bottom (darkest) first, then toward the top (brightest). 
The Random option chooses a random value and moves toward it.

The speed at which the value changes is set using the Speed slider.    The value changes only while globs 
are being drawn -- it is not a timed change.

Note that when you Undo drawing with this function active, the color does not return to its starting value.    
You must use the color history "Previous" button to reselect the starting color.

Tip: Use this function set on Random with the AutoChange Hue and AutoChange Satl functions set on 
Random as well to see the widest variations of color as you draw.
Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: You can use the 3 and E keys to change the value manually while drawing instead of using this 
function.

Toolbar:

Shortcut: none

Colors Menu



Background Color

Sets the background color of the drawing to the current color.

Note that if a background image is loaded and covers the entire drawing, the background color will not be 
visible.

Toolbar: none

Shortcut: none

Colors Menu



Cascade

Use this command to arrange multiple open drawings in an overlapped fashion. 

Toolbar: none

Shortcut: none

Window Menu



Clear

Removes all globs from the drawing, regardless of the position of the Drawing History slider.

Undo/Redo can be used on this command.

Toolbar:

Shortcut: Ctrl+W

View Menu



Clear all colors

This command will clear the color history, and leave only the current color.    You will be prompted to 
confirm first.

Toolbar: none

Shortcut: none

Colors Window Context Menu



Close

Closes the active drawing.    If the drawing has not been saved since it was last modified, you will be 
prompted to save first.

Toolbar: none

Shortcut: Ctrl+F4

File Menu



Color History

The color history (displayed in the Colors Window) shows the last 20 colors used.

A color is added to the history under the following conditions:

· When the hue/sat window is clicked in and released.
· When the val window is clicked in and released.
· When AutoChange Hue, Val, or Sat is used and drawing stops.
· When Sample Color is used.
· When a shape of a different color is selected (via the Shapes Window, [ or ] keys, or the Sample Shape 

command).

A color is NOT added to the history when the color is manually adjusted with the 1 or Q, 2 or W, 3 or E 
keys.

You may select a color from the history by clicking on it (in the history), or by using the next color or 
previous color buttons:

  

The current history color is designated by a black and white box.

The color history can be used as a miniature drawing color palette.    The color history can be saved and 
loaded, and by choosing colors only from the history, you limit the drawing colors.    Several color history 
files are supplied with Gloodle in the colors folder.

To remove a color from the history (in preparation for saving the history for example) use the Delete color 
command.

Colors Window



Color values

The color values dialog is accessed by clicking the  button of the Colors Window.

In this dialog you can set the HSV or RGB values directly, if you know the values for a color you are trying 
to obtain.    The color preview window will update as the values change.

Tip: Use the arrow buttons to convert the values you changed to the other colorspace (RGB or HSV).

Toolbar: none

Shortcut: none

Colors Window



Colors

Toggles display of the Colors Window.    If the Colors Window is visible, makes it non-visible; if it is not 
visible makes it visible.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Toolbar: none

Shortcut: Ctrl+2

View Menu



Colors Menu

The Colors menu offers the following commands:

AutoChange Hue Change the hue while drawing.
AutoChange Sat Change the saturation while drawing.
AutoChange Val Change the value while drawing.
Simulate Depth Modify the colors to simulate depth.
Sample Color Get a color from the drawing.
Sample Shape Get a shape from the drawing.
Background Color Set the background color.

The Colors menu is only shown when at least one drawing is open.

Menus



Colors Window

This window is used for choosing the drawing color. 

The current drawing color is displayed, as is a history of the last 20 colors used (the Color History).    You 
can also enter the color values directly by clicking the color values button:

The drawing color is made up of three components: hue, saturation, and value.    The hue is the base 
color, such as red, yellow, blue, etc.    Saturation is the amount of color; think of the saturation as how 
vibrant the color is.    Value is the brightness of the color.

The larger multi-colored window at the right is used to change the hue and saturation of the color.    If you 
pick a spot in this window and move left or right (without moving up or down) you would be changing the 
hue of the drawing color.    If you were to move up and down (without moving left or right) you would be 
changing the saturation.

The smaller window at the left (fades from white at the top to black at the bottom) is used to change the 
value of the color.    The closer to the top, the brighter the color; if the value is near the bottom, the color 
will be dark.

The AutoChange Hue, Sat, and Val functions allow the hue, saturation, and value of the drawing color to 
change automatically while drawing.    You may also use the 1 and Q keys to manually change the hue 
while drawing.    Similarly, the 2 and W keys can be used to manually change the saturation, and the 3 
and E keys can be used to change the value.

R-click on this window to bring up the Colors Window Context Menu.

Toolbar: none

Shortcut: Ctrl+2 to toggle visibility

Gloodle Windows



Colors Window Context Menu

The context menu displayed by R-clicking on the Colors Window offers the following commands:

Random color Chooses a random color.
Delete color Remove a color from the history.
Clear all colors Remove all colors from the history.
Save colors Save the color history.
Load colors Load the color history.

None of these commands are available anywhere else -- you can only access them by R-clicking on the 
Colors Window. 

Context Menus



Contacting Impulse

Impulse, Inc.
7250 Peak Drive #102
Las Vegas      NV    89128
(702) 948-1100

To order Gloodle or other Impulse products call
1-800-328-0184

http://www.coolfun.com

To order Gloodle or for technical support email: sales@coolfun.com

For information on educational discounts: 
educate@coolfun.com



Context Menus

Context menus are the menus that are shown when the Right mouse button is clicked.    The menu will 
change depending on where the R-click occurred.

The following context menus are available in Gloodle:

Drawing R-click on a drawing for this menu.
Shapes Window R-click on the Shapes Window for this menu.
Colors Window R-click on the Colors Window for this menu.

Menus



Copy

Copy globs from the drawing to the Gloodle clipboard (not the Windows clipboard). 

Choose which globs to copy.    If the Entire Drawing option is used, every glob from the first glob in the 
drawing to the last glob displayed (the position of the Drawing History slider) is copied to the Gloodle 
clipboard.    If the Last Section Only option is used, every glob from the start of the previous drawing 
section to the last glob displayed is copied.

Toolbar:

Shortcut: Ctrl+C,    Ctrl+Ins

Edit Menu



Create Movie

Create an AVI format movie or sequence of image (BMP) files of the drawing regeneration.

First enter a filename.    The extension of the filename will determine if an image sequence or a movie is 
generated.

Create Image Sequence

If the file type selected is BMP, or the filename extension in BMP, or no file extension is supplied when the 
file type is "All supported formats", a sequence of BMP images will be generated.    The filename you 
enter is used as the base, and a numeric sequence indicating the frame number is appended to the 
name.

For example, if you entered the name "Gloodle.bmp", the actual filenames saved would be 
"Gloodle000.bmp", "Gloodle001.bmp", etc.

Due to this appending of digits to the filename entered, the check to see if the file exists will not be 
accurate.    For instance, if a file "test.bmp" already exists, and you enter "test.bmp" as the base filename 
for the sequence, you will get a message that "test.bmp" already exists, and will be asked to confirm the 
overwrite.    Actually "test.bmp" will NOT be overwritten, since the filename used will be "test000.bmp", 
"test001.bmp", etc.    Alternately, if the file "hello000.bmp" exists, and you enter the name "hello.bmp", you 
will NOT be notified that a file will be overwritten, but the file "hello000.bmp" WILL be overwritten.    The 
point is be careful when naming the sequence.

After naming the file(s) you will be presented with the Create Image Sequence options dialog:

There are two settings for creating a sequence: Number of Frames, and frame size. 

The size can be set by either specifying the Scale as a percent of the drawing size, or by specifying the 
Width and Height directly.    If Scale is changed the Width and Height values will be updated, but the 
drawing aspect ratio will not be changed.    If you want to change the aspect ratio of the sequence (stretch 
it, or squash it) you must enter the Width and Height directly.    Changing the Width and Height values will 
not update the Scale value.

The First frame empty option does just what it says: when checked, the first frame of the sequence will be 
empty.    The Movie options are disabled, since they are not applicable to an image sequence.



Create Movie

If the file type selected is AVI, or the filename extension is AVI, a movie will be created instead of a 
sequence of frames.    The filename will be used exactly as it was entered; there is no appending of digits. 
Next you will be presented with the Create Movie options dialog:

There are three settings for creating a movie: Number of Frames, playback rate, and frame size.

The size can be set by either specifying the Scale as a percent of the drawing size, or by specifying the 
Width and Height directly.    If Scale is changed the Width and Height values will be updated, but the 
drawing aspect ratio will not be changed.    If you want to change the aspect ratio of the sequence (stretch 
it, or squash it) you must enter the Width and Height directly.    Changing the Width and Height values will 
not update the Scale value.

The First frame empty option does just what it says: when checked, the first frame of the sequence will be 
empty. 

The Movie options display the frame rate in frames per second (fps), and the total length of the movie in 
seconds.    The length in seconds is calculated from the number of frames and fps and cannot be entered 
directly.

After selecting these options, you must select a compression method:



Use Compressor to select a compression method.    This will vary, based on which codecs (compressors) 
are installed on your machine.    You can also select Compression Quality with most compressors, where 
high quality results in a better looking movie, but a larger file size.    You may also be able to change the 
Key Frame Every setting, which is how often a key frame is inserted in the movie.    Lower numbers 
indicate more key frames which improves quality, but may increase file size.    Data Rate may also be 
specified, although typically only one of Key Frame or Data Rate is specified.    The higher the value for 
Data Rate, the better the movie quality, but the larger the filesize.    The About button gives information on 
the selected compressor, and the Configure button allows selection of compressor-specific settings.

Creation of an AVI movie may take some time to complete, depending on the compression settings 
chosen, the size of the movie frames, and the number of frames.    For this reason, it is possible to press 
ESC to cancel creation of the movie.    You will be prompted to confirm the cancellation, and then can 
choose to save or delete the partial movie.

Toolbar: none

Shortcut: none

Image Menu
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Cut

Removes globs from the drawing and places them on the Gloodle clipboard (not the Windows clipboard).

Choose which globs to cut.    If the Entire Drawing option is used, every glob from the first glob in the 
drawing to the last glob displayed (the position of the Drawing History slider) is removed and copied to the 
Gloodle clipboard.    If the Last Section Only option is used, every glob from the start of the previous 
drawing section to the last glob displayed is removed and copied.

Toolbar:

Shortcut: Ctrl+X,    Shift+Del

Edit Menu



Define Pattern

Uses the globs in the active drawing to define a pattern for pattern drawing.

Choose which globs to use in the pattern.    If the Entire Drawing option is used, every glob from the first 
glob in the drawing to the last glob displayed (the position of the Drawing History slider) is used in the 
pattern.    If the Last Section Only option is used, every glob from the start of the previous drawing section 
to the last glob displayed is used.

Toolbar: none

Shortcut: Ctrl+E

Edit Menu



Delete colors

This command will remove the current color from    the color history.    You will be prompted to confirm first.

Toolbar: none

Shortcut: none

Colors Window Context Menu



Drawing Context Menu

The context menu displayed by R-clicking on a drawing offers the following commands:

Save Image Save the drawing as a BMP or JPG file.
Regenerate Redraw the entire drawing.
Clear Remove all globs from the drawing.
Background Color Set the background color.
Load background Use an image as the background.
Remove background Remove image from background.

All of these commands are available from other places (menus, toolbar), but have been added here for 
convenience.

Context Menus
Menus



Drawing History

Toggles display of the Drawing History Window.    If the Drawing History Window is visible, makes it non-
visible; if it is not visible makes it visible.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Toolbar: none

Shortcut: Ctrl+3

View Menu



Drawing History Window

The drawing history is a timeline of globs that have been added to the drawing.    You can use it to move 
back through the sections of a drawing.

The slider points to the last glob visible.    If the slider is at the far right, all globs in the drawing are visible 
(none are hidden).    By moving the slider to the left, globs become hidden.

The tic marks on the slider indicate drawing sections.    A section is created:

· When drawing manually (by dragging) and the mouse button is released.
· After each line (when drawing with lines).
· After using the Image Import function.
· When pasting globs into a drawing.

(Note: A maximum of 10 sections is held in the Drawing History.    If a drawing contains more than 10 
sections only the last 10 sections are indicated by the slider -- the rest of the sections are combined to 
form the first section.    Therefore, only the last 10 sections of a drawing can be undone.)

The previous section  and next section 
 buttons can be used to move the pointer one section at a time.    The slider can also be moved 

manually (click on the slider and drag it) and will "settle" at the tic marks.

A note about moving the slider.    When the slider is moved to the left, the drawing will regenerate from the 
first glob to the new last glob (the slider position).    When moving to the right, only the globs from the 
previous slider position are redrawn.    Therefore, moving to the left takes much more time than moving to 
the right.    An exception to the "regeneration when moving left" case is when the slider is in the last 
section added (between the right end and the previous tic mark).    In order to reduce the time spent 
redrawing, a "snapshot" of the drawing is taken before globs are added -- this is the Undo Image, and is 
the state of the drawing at the start of the last section added.    If the slider is moved to the left but does 
not move left of the previous tic, the undo image is displayed, and only the globs past this point need to 
be redrawn, resulting in a greatly reduced delay.    (Note that color changes applied to early portions of the 
drawing result in the undo image needing to be remade to show the changes.    That is what the 
"Rebuilding Undo Image..." message indicates.)

If the slider is not at the far right and globs are added to the drawing (with the exception of the Paste 
command), the globs from the slider position to the end of the drawing are deleted before the new globs 
are added.    If a very large number of globs must be deleted (after an image import for example) there 
may be a slight delay before the new globs are added.

The Drawing History plays an important role in letting you make modifications to previous sections of the 
drawing, as well as giving you 10 levels of drawing Undo.    Using the slider you can remove earlier 
sections of the drawing, insert new globs, change the color of previous sections, etc.    The Tutorials 
explain these types of functions.

Toolbar: none

Shortcut: Ctrl+3 to toggle visibility



Gloodle Windows



Drawing Menu

The Drawing menu offers the following commands:

Mirror Horizontal Adds globs mirrored about a horizontal line.
Mirror Vertical Adds globs mirrored about a vertical line.
Mirror Both Mirror Horizontal and Mirror Vertical combined.
Polar Mirror Adds globs in a circular pattern.
Lines Draws lines of globs.
Jitter Scatters globs around.
Skipping Control rate at which globs are drawn.
Pattern Draws with a pattern of globs.

The Drawing menu is only shown when at least one drawing is open.

The state of most of the drawing modes is saved when Gloodle is exited and restored when Gloodle is 
run again.

Menus



Edit Menu

The Edit menu offers the following commands:

Undo Undo/Redo the last action.
Cut Remove globs from the drawing, putting them on the clipboard.
Copy Copy globs from the drawing to the clipboard.
Paste Paste globs from the clipboard to the drawing.
Define Pattern Create a pattern from globs in a drawing for use in pattern drawing.

The Edit menu is only shown when at least one drawing is open.

Menus



Exit

Exits Gloodle.    If any open drawings have been modified since they were last saved, you will be asked if 
you want to save each first.

Toolbar: none

Shortcut: Alt+F4

File Menu 



File menu commands

The File menu offers the following commands:

New Creates a new drawing.
Open Opens an existing drawing.
Close Closes an opened drawing.
Save Saves an open drawing using the same file name.
Save As Saves an open drawing to a specified file name.
Print             Prints a drawing.
Print Preview Displays the drawing on the screen as it would appear printed.
Print Setup        Selects a printer and printer connection.
Exit  Exits Gloodle.

Note that the Close, Save, Save As, Print, and Print Preview commands are only shown when a drawing 
is open.

Menus



Full Screen

Used to enter and exit full screen mode.    When in full screen mode the Gloodle windows (Colors, 
Shapes, Drawing History), the Toolbars, Status Bar, and menus all disappear.

Tips:
- Ctrl+Shift+F6 to switch to the next drawing.
- Use + (or =) and - keys to change shape size.
- Use [ and ] keys to change shape.
- Use Ctrl+2 to make Colors Window visible.

Press Ctrl+F (or TAB) to exit full screen mode.

It is also possible to get to full screen mode in steps.    While not in full screen mode, press the TAB key to 
remove the Gloodle windows (Colors, Shapes, Drawing History), press again to remove the Toolbars and 
Status Bar, press one more time to enter full screen mode.    If TAB is pressed again, full screen mode will 
be exited.

Toolbar: none

Shortcut: Ctrl+F

View Menu



Help Menu

The Help menu offers the following commands:

Tip of the Day Shows a Tip for using Gloodle.
Help Topics Find a help topic.
About Gloodle Shows version number and copyright info.

Menus



Help Topics

Displays the contents file for Gloodle Help.

Toolbar: none

Shortcut: F1

Help Menu



Image Menu

The Image menu offers the following commands:

Save Save the drawing as a BMP or JPG file.
Create Movie Save a movie of the regeneration sequence.
Load Background Use an image as the background.
Remove Background Remove image from background.
Import Convert an image to globs.
Size when printed Determine drawing size when printed.
Information Shows information about the drawing.

The Image menu is only shown when at least one drawing is open.

Menus



Import

Convert an image into globs, using the current glob shape and size.

First enter a filename.    Supported image formats are BMP and JPG.

There are several options available that change the way the image is converted to globs: Colors, Glob 
order, Number, Background, and Size. 

When the Preserve image colors option is selected, the globs are colored based on the colors of the 
image.    Use the slider to change the number of colors used.    Note that the fewer the colors the faster 
the drawing will regenerate, but more colors usually means the glob colors will more closely match the 
image colors.    The Use new colors option will color the globs based on the current color and any 
AutoChange (Hue, Sat, or Val) settings.

The Ordered option adds the globs in a regular pattern, starting from the upper left corner of the drawing 
and moving across, then down.    The get order from image option sorts the globs based on the colors in 
the image.    The darkest colored globs will be added first, and the lightest will be added last (similar to the 
way the Simulate Depth command works). 

The Number of globs can be changed depending on the glob density you want.    Note that the total 
number of globs added is also determined by the size of the current glob shape -- the smaller the current 
glob shape, the greater the number of globs added. 

You may choose to Keep the background, or Remove it.    If the background is to be removed, the color of 
the first pixel in the image (the upper left corner) is used, and any portion of the image that contains that 
color will not have a glob added. 

The way the image is "mapped" to the drawing is determined by the Size setting.    The Fit drawing option 
makes the image fit in the drawing, but does not distort the image.    The image may not cover the entire 
drawing area, but it will retain its original proportions.    The Squash/Stretch option resizes the image to 
the drawing size, changing the proportions of the image if needed.    The Normal option does not change 
the size of the image at all, but if the image is smaller than the drawing it is centered in the drawing; if it is 
larger than the drawing, only as much of the image as can fit is loaded, starting at the upper left corner.    
The resized image is then converted to globs.    (See the Load Background Image command for examples 
of the three sizing options.)



While the import is occurring, the progress is indicated in the Status Bar as a percentage.    A large 
drawing size with a large number of globs may take some time to import, and even more time to 
regenerate.    For this reason, it is possible to cancel the import operation by pressing ESC.    You will be 
prompted to confirm the cancellation.    If you confirm and globs have already been added, a message will 
be shown informing you of this:

What this means is that although you cancelled the import, a large number of globs may have been 
added already.    They are hidden, but still in the drawing (note the position of the Drawing History slider). 
If you move the Drawing History slider to the right, the globs will be shown.    Warning: If you use the 
Drawing History "Next section" button, all of the globs that you didn't want shown before will now be 
drawn, and there is no way to cancel it.    The globs will not be deleted from the drawing until you add 
more globs.    Since there may be a very large number of globs that must be deleted, there may be a 
slight delay when you first draw.

Tip: Use this function, then Define a pattern from it and use that to draw with.

Toolbar: none

Shortcut: none

Image Menu



Information

Displays information about the drawing.    Displays the number of globs, number of colors, size of the 
drawing in pixels, and RGB values for the background color of the drawing:

If the Drawing History slider is not at the far right, you will see the number of hidden globs as well:

The background color RGB values can be used to duplicate the background color from another drawing.

The Sample Color function could be used for this, but due to the way colors are represented in some 
display modes (16-bit), sampling the color may not return the exact color.

Toolbar: none

Shortcut: none

Image Menu



Jitter

When active, "scatters" globs instead of placing them at the exact mouse cursor position.

The slider controls the amount of jitter.

When this function is active, extra globs are drawn.    The higher the amount of jitter, the greater the 
number of globs added.

Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: Use the 5 and T keys to change the amount of jitter while drawing.

Toolbar:

Shortcut: J

Drawing Menu



Large

This command will set the size of the selected shape to Large, the maximum of the three sizes.

Tip: Use the + (or =) and - keys to change shape size.    This only works when a drawing is open and is 
the active window.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Lines

When active, lines of globs are drawn instead of individual globs.

The slider controls the number of globs to be drawn on the line (the line density).

The first click in the drawing after Lines mode is turned on will determine the starting point for the line(s). 
Each following click draws a line (or lines) to that point, and "guide lines" are drawn.    To start a new line 
without connecting to the previous line, hold the Ctrl key while clicking; the guide lines will not move while 
Ctrl is held.    To place the endpoint of a line outside of the drawing area, press and hold the Shift key 
while the mouse cursor is still in the drawing area.    The line(s) can be drawn outside the drawing as long 
as Shift is held.

Lines mode can be used with any of the mirroring modes and Jitter.    The Skipping setting has no effect in 
Lines mode.

Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: Once in a while the guide lines may not get erased from the drawing.    If this occurs, minimize the 
drawing, then restore it for a quick "clean up".

Toolbar:

Shortcut: L

Drawing Menu



Load Background

Load an image to use as the background for the drawing.

After selecting an image file (BMP or JPG) to use as the background, you must choose how the image 
will be fit to the drawing.

The Fit drawing option makes the image fit in the drawing, but does not distort the image.    The image 
may not cover the entire drawing area, but it will retain its original proportions.    The Squash/Stretch 
option resizes the image to the drawing size, changing the proportions of the image if needed.    The 
Normal option does not change the size of the image at all, but if the image is smaller than the drawing it 
is centered in the drawing; if it is larger than the drawing, only as much of the image as can fit is loaded, 
starting at the upper left corner.

The background image is stored in the Gloodle drawing file as a JPEG image at a very high quality 
setting.

To remove an image from the background, use the Remove Background command.



Toolbar: none

Shortcut: none

Image Menu



Load colors

This command will load a color history from file.

The colors are stored in files with the GCH extension, for Gloodle Color History.    Note that a file called 
GDLlastGDL.gch is automatically created upon exit from Gloodle.    This file will be used to restore the 
Colors Window when the program is run again.

Toolbar: none

Shortcut: none

Colors Window Context Menu



Load state

This command will load the state of the Shapes Window from file.    The colors, sizes, and selected shape 
are loaded.

The state is stored in a file with the GSS extension, for Gloodle Shape State.    Note that a file called 
GDLlastGDL.gss is automatically created upon exit from Gloodle.    This file will be used to restore the 
Shapes Window when the program is run again.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Medium

This command will set the size of the selected shape to Medium, the middle size of the three sizes.

Tip: Use the + (or =) and - keys to change shape size.    This only works when a drawing is open and is 
the active window.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Menus

The following menus are available in Gloodle when no drawings are open:

File Open and save drawings, create new drawings, print.
View Control display of toolbars, status line, Gloodle windows.
Help Program information.

Once at least one drawing is open, additional menus are available:

File Open and save drawings, create new drawings, print.
Edit Clipboard operations (copy, paste).
View Control display of toolbars, status line, Gloodle windows.
Drawing Control how globs are drawn.
Image Save images, movies;    Load images to use in Gloodle.
Colors Color functions.
Window Arrange open drawing windows.
Help Program information.



Mirror Both

When active, causes globs to be added mirrored twice: once along a horizontal line running through the 
center (or mirror) point, and once along a vertical line running through the center point.

Note that only one of the mirroring modes (Horizontal, Vertical, Both, Polar) can be active at a time.

Toolbar:

Shortcut: B

Drawing Menu



Mirror Horizontal

When active, causes globs to be added mirrored along a vertical line running through the center (or 
mirror) point.

Note that only one of the mirroring modes (Horizontal, Vertical, Both, Polar) can be active at a time.

Toolbar:

Shortcut: H

Drawing Menu



Mirror Vertical

When active, causes globs to be added mirrored along a horizontal line running through the center (or 
mirror) point.

Note that only one of the mirroring modes (Horizontal, Vertical, Both, Polar) can be active at a time.

Toolbar:

Shortcut: V

Drawing Menu



Move Center

Allows placement of the center (or mirror) point -- the point that the mirroring drawing functions use as 
"center".

When this command is used, the cursor changes  and moves to the current center point for the 
drawing.    To change its position, move the cursor and L-click.    To cancel, press ESC, R-click, or select 
the function again instead of L-clicking.

Undo/Redo can be used on this command.

To place the center point back at the default position of the physical center of the drawing, use the Reset 
Center command.

Toolbar:

Shortcut: none

View Menu



New drawing

Use this to create a new drawing.

A few common drawing sizes are provided, but you can also enter the width and height directly.

When Lock aspect ratio is checked, the height edit box is disabled, and the height is calculated from the 
width based on the ratio of width to height at the time the box is checked.

Toolbar:

Shortcut: Ctrl+N

File Menu



Open drawing

Use this to open an existing Gloodle drawing.

Tip: The File Menu also contains a list of the last 4 drawings opened (the Most Recently Used files).    
Drawings selected from this list open immediately.

Toolbar:

Shortcut: Ctrl+O

File Menu



Overview of Gloodle

A Gloodle drawing is made up of two primary elements: shapes (globs) and colors.    All aspects of 
Gloodle use some combination of these two elements.

There are several different drawing modes that can be used for various effects, and a variety of functions 
to change the colors of the globs.    It is the combination of these drawing modes and functions that allows 
you to make fantastic Gloodle drawings so easily.

Some of the drawing modes available include Mirroring, Jitter, Lines, and Skipping.    A few of the coloring 
functions allow you to Simulate Depth and AutoChange colors.

More specialized functions allow you to convert an image into globs and define patterns of globs to use in 
your drawings.

Gloodle also allows you to export image files of your drawings, as well as create movies or image 
sequences of the drawing.

Quick Start
Windows
Menus
Context Menus
Shortcuts
Tutorials



Paste

Add globs to the drawing from the Gloodle clipboard (not the Windows clipboard).

When the globs are added the original colors of the globs on the clipboard can be used by selecting the 
Preserve colors option, or the current color settings (including AutoChange Hue, Sat, and Val) can be 
used by selecting the Use new colors option.

If the Drawing History slider is not at the far right, the pasted globs will be inserted into the drawing at the 
slider position.

Toolbar:

Shortcut: Ctrl+V,    Shift+Ins

Edit Menu



Pattern

When a pattern is defined and Pattern mode is active, the pattern is drawn instead of individual globs.

When the globs are added the original colors in the pattern can be used by selecting the Preserve colors 
option, or the current color settings (including AutoChange Hue, Sat, and Val) can be used by selecting 
the Use new colors option.

When in Pattern mode, the cursor will appear as .    See the word of warning below.

Pattern mode can be used with all mirroring modes.    Jitter, Skipping, and Lines modes have no effect 
when in Pattern mode.

A word of warning: When Pattern mode is active, it is quite possible to add many thousands of globs to a 
drawing with a single mouse click.    This is due to the fact that a defined pattern can have a large number 
of globs in it, and if mirroring is active, the number of globs added can be 2, 4, or anywhere up to 50 times 
the number of globs in the pattern (depending on the current mirroring mode)!

Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.

Toolbar:

Shortcut: A

Drawing Menu



Polar Mirror

When active, causes globs to be added in a circular pattern around the center (or mirror) point.

Select the number of copies to be added.    The minimum number of copies is 2, and the maximum 
number is 50.

Note that only one of the mirroring modes (Horizontal, Vertical, Both, Polar) can be active at a time.

Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: Use the keys 4 and R to change the number of copies while drawing.

Toolbar:

Shortcut: P

Drawing Menu



Print

Print the drawing.    Allows selection of printer, printer properties, and number of copies.

Will then display the Size when printed dialog, which allows you to review and/or change the size of the 
drawing on the printer.    Note that clicking Cancel in this dialog will not cancel printing, but any changes 
made to the print size will be ignored.

(The Size when printed dialog is shown in case the printer settings were changed, or a different printer 
was selected.)

Toolbar:

Shortcut: Ctrl+P

File Menu



Print Preview

Views the drawing as it would appear when printed.

First displays the Size when printed dialog, which allows you to review and/or change the size of the 
drawing on the printer.    Note that clicking Cancel in this dialog will not cancel the preview, but any 
changes made to the print size will be ignored.

Will then display a representation of the drawing as it will appear when printed.    Since the preview 
occupies the same window as the drawing, you can maximize the drawing to see more of the preview 
page or preview buttons.

Toolbar:

Shortcut: none

File Menu



Print Setup

Use this to select a printer, and change the printer options.    This is where you choose the page 
orientation (Portrait or Landscape) as well.

Toolbar: none

Shortcut: none

File Menu



Quick Start

After installation, Gloodle is configured with two of the drawing functions enabled: Polar Mirror and Jitter. 
So just open a new drawing and start doodling!

1) Open a new drawing.    Select New from the File Menu, click the  button on the toolbar, or press 
Ctrl+N.

2) Click OK or press Enter to accept the default drawing size.

3) Draw by clicking in the drawing window and dragging (keep the mouse button pressed).    Move at a 
medium speed.

That's all there is to it!    You can select a different shape, change the color of the shape, change the size 
of the shape -- there are many drawing options and functions to try.    Change the color:

4) Click in the Colors Window on a color that you want to use.    The shape that is selected changes color, 
and now when you draw that color is used.

Let's try one of my favorite commands now: the Simulate Depth command.

5) Select Simulate Depth from the Colors menu, click the  button on the toolbar, or press Ctrl+D.

6) Click OK or press Enter to accept the default settings.

You should see the drawing regenerate, and the last part of the drawing is now shaded from dark to 
bright.    To get a better idea of what the Simulate Depth command can do, clear the drawing and try 
again:

7) Select Clear from the View menu, click the  button on the toolbar, press Ctrl+W, or R-click on the 
drawing and select Clear.    Press OK to clear the drawing.

8) Draw again, this time start near the edge of the drawing and move toward the center, so all the globs 
converge.    here's what my drawing looks like:

9) Now Simulate Depth again.    See how the globs appear to come out of the depths of the drawing?    
Here's what my drawing looks like:



That's a quick introduction to the basics of Gloodle.    Pretty simple, isn't it?    You may want to take a look 
at some of the other drawing functions and commands, but I suggest just playing around with Gloodle.    
Try some of the functions, change colors, change shapes; just have fun!    If you prefer, you can take a 
look at the Tutorials.

Tutorials
Menus



Random color

This command will choose a random color.

Note that there are some restrictions on the colors that will be chosen.    For instance, very dark colors will 
not be chosen, nor will colors with very low saturation.

This command is also available from the Shapes Window Context Menu.

Toolbar: none

Shortcut: none

Colors Window Context Menu



Random color

This command will choose a random color.

Note that there are some restrictions on the colors that will be chosen.    For instance, very dark colors will 
not be chosen, nor will colors with very low saturation.

This command is also available from the Colors Window Context Menu.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Random history color

This command will set the selected shape to a random color from the color history.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Regenerate

Redraws the entire drawing, from the first glob to the last glob to be drawn.    Note that the last glob to be 
drawn is not necessarily the last glob in the drawing, depending on the position of the Drawing History 
slider.

Toolbar:

Shortcut: Ctrl+R,    F5

View Menu



Remove Background

Removes the background image, if one is in use in the drawing.

Can only be used after the Load Background Image command has been used to load an image.

Toolbar: none

Shortcut: none

Image Menu



Reset Center

Restores the center (or mirror) point to its default position at the physical center of the drawing.

Unlike the Move Center command, Undo/Redo does NOT work for this command.

Toolbar: none

Shortcut: none

View Menu



Sample Color

Get the color of a glob in a drawing.    Can also be used to get the background color or pick a color from 
the background image, if one is loaded.

When this command is selected, the cursor will change to an eyedropper .    L-click to choose the color. 
R-click, press ESC, or select this function again to cancel.

Note that when this command is selected, the Sample Shape command will be deactivated.

Toolbar:

Shortcut: Ctrl+Alt+C

Colors Menu



Sample Shape

Get the shape of a glob in a drawing.

When this command is selected, the cursor will change to an eyedropper .    L-click on a glob in the 
drawing to choose its shape.    R-click, press ESC, or select this function again to cancel.

Note that when this command is selected, the Sample Color command will be deactivated.

Toolbar:

Shortcut: Ctrl+Alt+S

Colors Menu



Save

Saves the active drawing with the current name.    If the drawing is new and has not been saved yet, you 
will be prompted to "Save As" and need to specify the name.    You may keep the default name if you 
choose.

Toolbar:

Shortcut: Ctrl+S

File Menu



Save

Save the drawing as an image file (BMP or JPG).    If the JPG file type is selected, or the filename 
extension is JPG, the Image Quality must be set:

Higher quality settings result in better looking images, but larger file sizes.    Lower quality settings result 
in file sizes that are much smaller, but the image may be blocky, blurry, or otherwise unacceptable.

Note: This command only saves the drawing as an image file; like taking a snapshot of the drawing.    To 
save the drawing with all of the glob and color information, use the File Save command.

Tip: A JPG file is usually much smaller than a BMP file of the same drawing.

Toolbar: none

Shortcut: none

Image Menu



Save As

Saves the drawing but allows its name to be specified first.

Toolbar: none

Shortcut: none

File Menu



Save colors

This command will save a color history to file.

The colors are stored in files with the GCH extension, for Gloodle Color History.    Note that a file called 
GDLlastGDL.gch is automatically created upon exit from Gloodle.    This file will be used to restore the 
Colors Window when the program is run again.

Toolbar: none

Shortcut: none

Colors Window Context Menu



Save state

This command will save the state of the Shapes Window to file.    The colors, sizes, and selected shape 
are saved.

The state is stored in a file with the GSS extension, for Gloodle Shape State.    Note that a file called 
GDLlastGDL.gss is automatically created upon exit from Gloodle.    This file will be used to restore the 
Shapes Window when the program is run again.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Shapes

Toggles display of the Shapes Window.    If the Shapes Window is visible, makes it non-visible; if it is not 
visible makes it visible.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Toolbar: none

Shortcut: Ctrl+1

View Menu



Shapes Window

This window displays all of the glob shapes available for drawing. 

Each shape is shown in its current size and color.    The selected shape has a square drawn around it, 
and will be used for drawing.

R-click on this window to bring up the Shapes Window Context Menu.

Tip: The Shapes Window can be resized.
Tip: You can drag the color from one shape to another.

Note that Gloodle contains a large number of glob shapes, but it is possible to add additional shapes to 
Gloodle if you are so inclined.

Toolbar: none

Shortcut: Ctrl+1 to toggle visiblilty

Gloodle Windows



Shapes Window Context Menu

The context menu displayed by R-clicking on the Shapes Window offers the following commands:

Small Select the small size for this shape.
Medium Select the medium size for this shape.
Large Select the large size for this shape.
Random color Chooses a random color.
Random history color Chooses a random color from the color history.
All this size Make all shapes the same size.
All this color Make all shapes the same color.
All random colors Chooses random colors for all shapes.
All history colors Colors shapes using history colors.
Save state Save the settings of the shapes.
Load state Load the settings of the shapes.

Most of these commands are not available anywhere else -- you can only access them by R-clicking on 
the Shapes Window. 

Context Menus



Shortcuts

Here is a list of all of the keyboard shortcuts for Gloodle commands and functions:

1 increase hue
Q decrease hue
2 increase saturation
W decrease saturation
3 increase value
E decrease value

4 increase Polar Mirror count
R decrease Polar Mirror count
5 increase Jitter
T decrease Jitter
6 increase Skipping
Y decrease Skipping
+ increase shape size
= increase shape size
- decrease shape size
[ previous shape
] next shape

H mirror Horizontal
V mirror Vertical
B Mirror Both
P Polar Mirror
L Lines
J Jitter
S Skipping
A Pattern

Ctrl+R Regenerate
F5 Regenerate
Ctrl+W Clear (wipe)
Ctrl+F Fullscreen
Ctrl+E Define Pattern
Ctrl+D Simulate depth
Ctrl+Alt+C Sample Color
Ctrl+Alt+S Sample Shape

Ctrl+1 Shapes Window
Ctrl+2 Colors Window
Ctrl+3 Drawing History Window

Ctrl+Ins Paste
Ctrl+V Paste
Ctrl+Del Cut
Ctrl+X Cut
Shift+Ins Copy
Ctrl+C Copy

Ctrl+N New
Ctrl+O Open
Ctrl+S Save
Ctrl+P Print



Ctrl+F4 Close
Alt+F4 Exit

Ctrl+Shift+F6 Switch between drawings

F1 Help
Shift+F1 Context Help

TAB Goes to fullscreen mode in steps.    One press and Gloodle windows turn off.    Press 
again and toolbars and status bar turn off.    Press again and are in fullscreen mode.    Press again and 
back to normal.

Ctrl When held while clicking on a toolbar icon, the dialog (if one exists for the function) is 
skipped, and the function is toggled.

Ctrl When held while in line mode, allows a new line to be started.

Shift When held while in line mode, allows drawing outside the image limits.

Spacebar Same as Enter in Dialogs.

ESC Same as Cancel in Dialogs.

Note: some of the shortcuts will only work when a drawing is open and is the active window (for example, 
pressing Ctrl+D when the Drawing Window is active does nothing).



Simulate Depth

Changes the colors of globs in the drawing to simulate depth.

There are three sets of options that must be set: Apply Depth to, Simulate Depth Using, and Depth 
Range.

The Apply Depth to options set which globs to affect.    If the Entire Drawing option is used, every glob 
from the first glob in the drawing to the last glob displayed (the position of the Drawing History slider) is 
affected.    If the Last Section Only option is used, every glob from the start of the previous drawing 
section to the last glob displayed is affected.

The Simulate Depth Using options determine how the colors will be changed.    The Light option changes 
the value of the glob colors, making the earliest globs (the globs "deeper" in the drawing) darker, and the 
last globs drawn (the globs "on top") lightest.    The ChromaDepth (tm) option changes the colors of the 
globs to fit the ChromaDepth (tm) 3-D color palette to make drawings to be viewed with ChromaDepth 
(tm) 3-D glasses.    (In brief, the earliest globs are made blue, and the globs on top are made red, with 
other colors in between.    For more information on ChromaDepth (tm) 3-D, check out Chromatek Inc. at 
http://www.chromatek.com).

The Depth Range sliders determine the start and end colors, in effect setting how "deep" the globs 
appear to be.    The slider labeled Bottom sets the color of the earliest globs affected.    The slider labled 
Top sets the color of the last globs drawn.

Tip: Glob shapes that are not too shiny (do not have a bright highlight spot on them) work better with the 
ChromaDepth (tm) option.

Toolbar:

Shortcut: Ctrl+D

Colors Menu



Size when printed

Sets the size of the drawing when printed.

The Dots per unit value converts the image size (measured in pixels) to a physical size on the printer 
(measured in either inches, cm, or mm).    This conversion uses the resolution information returned by the 
selected printer.    Below the Cancel button is a representation of the page (in white) and the drawing (in 
dark grey).    Change the Dots per unit value to resize the drawing on the page.    The Max size button 
maximizes the size of the drawing to fill as much of the page as possible.    The Center on page option 
centers the drawing on the page.

The drawing may not end up exactly centered, due to the fact that the printable area on the page may not 
be centered.    That is, there may be a wider margin on the right side of the page than on the left side due 
to the design of the printer.

The Dots per unit value cannot be changed to allow the drawing to be larger than the page size.    That is, 
there is a lower limit on the Dots per unit value based on the drawing size, paper size, and printer 
resolution.

Tip: To change the paper orientation (portrait or landscape) use the Print Setup command.

Toolbar: none

Shortcut: none

Image Menu



Skipping

Controls the rate at which globs are drawn.    When this function is not active, globs are added as fast as 
possible, resulting in a solid line of globs on faster computers.    In order to get more spacing between 
globs, turn this function on.

The slider controls the rate at which globs are drawn.    When the amount of skipping is greater, there will 
be a larger gap between globs.

The skip multiplier should only be increased if the maximum amount of skipping provided by the slider 
alone is not enough.

Skipping is only active whenever drawing "by hand" -- it has no effect when in Lines mode, when pasting, 
when drawing with a pattern, or when converting an image to globs.

Tip: Ctrl+click on the toolbar button for this function to toggle it (on/off) without bringing up its dialog.
Tip: Use the 6 and Y keys to change the amount of skipping while drawing.

Toolbar:

Shortcut: S

Drawing Menu



Small

This command will set the size of the selected shape to Small, the minimum of the three sizes.

Tip: Use the + (or =) and - keys to change shape size.    This only works when a drawing is open and is 
the active window.

Toolbar: none

Shortcut: none

Shapes Window Context Menu



Status Bar

Toggles display of the Status bar.    If the Status Bar is visible, makes it non-visible; if it is not visible 
makes it visible.

The Status Bar is found at the bottom of the screen and displays information about Gloodle commands 
and displays status messages when certain commands are being carried out.    Also displays a progress 
indicator (as a completion percentage) when time-consuming functions are being processed, and 
indicates if the Num lock, Caps lock, and Scroll lock keys are active.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Toolbar: none

Shortcut: none

View Menu



Tile

Use this command to vertically arrange multiple open drawings in a non-overlapped fashion.

Toolbar: none

Shortcut: none

Window Menu



Tip of the Day

Shows a tip for using Gloodle.    If you check the "Show tips at startup" option, a tip will be shown every 
time Gloodle is run.

Toolbar: none

Shortcut: none

Help Menu



Toolbar

Toggles display of the first Toolbar.    If the first Toolbar is visible, makes it non-visible; if it is not visible 
makes it visible.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Tip: The toolbars can be moved.    Click on a part of the toolbar that does not contain a button and drag 
the toolbar to the position you want it.    Toolbars can be moved to any side of the screen, and can even 
be undocked (converted to a window).    When a toolbar is undocked it can be resized.

Toolbar: none

Shortcut: none

View Menu



Toolbar2

Toggles display of the second Toolbar.    If the second Toolbar is visible, makes it non-visible; if it is not 
visible makes it visible.

The display state (visible or not) is saved when Gloodle is exited and restored the next time Gloodle is 
run.

Tip: The toolbars can be moved.    Click on a part of the toolbar that does not contain a button and drag 
the toolbar to the position you want it.    Toolbars can be moved to any side of the screen, and can even 
be undocked (converted to a window).    When a toolbar is undocked it can be resized.

Toolbar: none

Shortcut: none

View Menu



Tutorial #1

This tutorial will cover the following aspects of Gloodle: Skipping, Undo, Drawing History Window.

You may want to read the Quick Start section first.

First, create a New drawing.    Any size will do.    Select any shape, but I will use the first (the shiny 
sphere) most often in the tutorials.    Make it any color you like, preferably something that isn't too dark. 

1) Turn on Polar Mirror and set it to 5 or so copies, and turn off Jitter.

2) Draw a little bit.    Do the globs in your drawing blend together, so it looks like you have created a solid 
stream of globs, similar to the image below?

This "solid stream" look is fine, if that's what you like.    Now try turning on Skipping:

3)    Select Skipping from the Drawing menu, click the  button on the toolbar, or press S.    Don't 
change the slider position, just turn it on.    Now try drawing again.    I'm going to Clear my drawing, to 
avoid confusion.    Here's what I have with Skipping turned on:

Notice how there is more space in between the globs?    (I couldn't exactly duplicate the previous 
drawing.)    If there still isn't space between the globs, select Skipping again, but this time move the slider 
up (toward the right) a bit, or a lot if you really want to see what skipping does.    Here's what I got:



A little too much skipping, but you get the point.    Find a skipping setting that you like -- it will be saved 
and restored whenever Gloodle is run.

4)    Now that you have the globs being drawn at a rate that you like, clear the drawing, then draw three 
times, selecting a different color for each.    Here's what I have:

Let's say you don't like that last section (the dirty yellow color).    Since it was the last section drawn, I can 
just Undo it:

5) Select Undo Drawing from the Edit menu, click the  button on the toolbar, or press Ctrl+Z.    The 
dirty yellow section goes away.    Take a look at the Drawing History Window (if it is not visible, select 
Drawing History from the View menu, or press Ctrl+3 to make it visible).    See how the slider is not at the 
far right end?    This tells you that there are hidden globs.    Now put the globs "back" by selecting Redo 
Drawing from the Edit menu, clicking the 

 button on the toolbar, or pressing Ctrl+Z.    This is Redo -- it is like Undoing the Undo.    The dirty 
yellow globs come back, and now the Drawing History slider is at the far right.

6) Undo again to make the dirty yellow globs disappear again.    Now select a different color, then move 
the Drawing History slider to the far right.    You can do this by clicking on the slider and dragging it, or by 

clicking the next section button  or by using Undo again.    The dirty yellow globs have changed to the 
new color!    I selected green, so now I have:



Okay, so now you can change the color of a section of the drawing, but what if you want to get rid of that 
last section entirely?

7) You could use Undo again to hide the last section of the drawing, but let's use the Drawing History 

slider instead.    Drag the slider, or click the previous section button .    Now just select the color you 
want to use, and just draw.    The hidden globs are deleted from the drawing, replaced by the new globs.    
Here's what I did:

Note that all of the hidden globs will be deleted when new globs are added.    Even though we've been 
moving the Drawing History slider to the tic marks at the start of sections, you can drag the slider to any 
position (it doesn't have to be at a tic mark) and then change color, or add new globs.

Let's use the Drawing History slider to do something else. 

8) Position the slider so the last section is hidden.    Now select the Simulate Depth function (select 

Simulate Depth from the Colors menu, click , or use Ctrl+D) and take a look at the options.    You can 
choose to affect the Entire Drawing, or the Last Section Only.    Ignore the other options for now.    Select 
Last Section Only, and click OK.



Now Undo the Simulate Depth, and select Simulate Depth again.    This time select the Entire Drawing 
option and click OK.

Notice the difference?    Now move the Drawing History slider to the far right, so no globs are hidden.    
The Entire Drawing option was used, so why didn't this last section get shaded too?    Hidden globs "don't 
count" in Gloodle -- any function that has an Entire Drawing option only works on the visible portion of the 
drawing.    (The position of the Drawing History slider is the last glob as far as Gloodle is concerned.)

One last thing.    To save a drawing, use the File Save command.    To just save a "snapshot" of the 
drawing as an image file, choose Save from the Image menu, or R-click on the drawing and choose Save 
Image.

The next tutorial is Tutorial #2
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Tutorial #2

This tutorial will cover the following functions: Lines, Cut/Copy, Paste, Move Center, Load Background.

You may want to read Tutorial #1 first.

First, create a New drawing.    Any size will do.    Select any shape, but I will use the first (the shiny 
sphere) most often in the tutorials.    Make it any color you like, preferably something that isn't too dark. 

1) Turn on Polar Mirror and set it to 5 or so copies, and turn off Jitter.

2) Draw a few sections in the drawing (at least 2).    Here's what I have:

I used Simulate Depth, Last Section Only after drawing each section (because I like it).    Now create 
another New drawing, and turn on Lines mode:

3) Select Lines from the Drawing menu, or click the  button on the toolbar, or Press L.    Just click On 
then OK.    In the new drawing, click, then move the mouse.    Since Lines mode is active, you will see 
some guide lines to show you where the lines of globs will be placed.    Click again to place the globs.    
Note that you do not drag while drawing in lines mode -- the lines connect the points at which you click.    
Add a few lines.    Here's my drawing:

Once again I've used Simulate Depth, but this time on Entire Drawing.    Looking at my two drawings side 
by side, I realize that the drawing with lines might look pretty good with the dark blue section from my 
other drawing.    So let's add it!



4) Make the first drawing active (click on its title bar).    Since the dark blue globs are the first section of 
that drawing, I'll need to move the Drawing History slider back so the blue globs are the last ones shown. 
(Since they were the first drawn, they will be the only globs shown.)    Now select the Copy command from 

the Edit menu, click the  button on the toolbar, or press Ctrl+C or Shift+Ins.    Now select Last Section 
Only (although in this case it doesn't matter, since Entire Drawing gives the same results).    The blue 
globs (in my drawing) have now been copied to the Gloodle clipboard, and can now be pasted into the 
second drawing.

5) Make the second drawing (the lines drawing) active.    Now select Paste from the Edit menu, click the 

 button on the toolbar, or press Ctrl+V or Ctrl+Ins.    Select the Preserve Colors option and click OK.    
The globs are pasted at the position of the Drawing History slider in their original colors.    Here's what I 
have:

By moving the Drawing History slider before you paste, you can also put the globs before all of the lines:

The difference is not drastic in this example, but it could be important in your drawings.    Let's try a little 
variation on this.    The section of blue globs are still on the clipboard, but it wouldn't make much 
difference to the drawing to paste them again, since they will just be added on top of the previously 
pasted version.    There is a way to paste to a different area of the drawing though:

6) Select the Move Center command from the View menu, or by clicking the  button on the toolbar.    
The cursor will change and move to the current center.    Now move the cursor to the point that you want 
to paste at and L-click (R-click will cancel, as will ESC).    You have just moved the point about which all 
mirroring occurs, and the reference point for Copy/Cut, Paste, and Create Pattern.



7) Paste again, and you'll see the globs added at the point that you moved the center to.    Here's my 
drawing:

My drawing is a little small, so I could only move the center point a little bit, but you can see that there is a 
copy of the blue globs on top of the drawing, a little to the right and down from the original copy.    You can 
put the reference point back at the physical center of the drawing using the Reset Center command of the 
View menu.

A note about moving the center: The Copy (and Cut) commands use this center position to reference the 
position of the globs as well.    If the globs do not paste where you thought they should, it is probably 
because the drawing that the globs were copied or cut from had its center point moved at the time they 
were copied or cut. 

Even though we've been using Copy, Cut is very similar to Copy, but the globs are removed (deleted) 
from the drawing and then placed on the clipboard.

Let's look at one more aspect of Paste: the Use new colors option.

8) Clear a drawing, or create a new one.    Since there should still be globs on the clipboard, select Paste, 
but this time select the Use new colors option.    What happens is the globs are added in the current 
drawing color, not in the colors that they originally had.

What can you do with this?    One thing that you can do with it is change the color of a section of globs 
that have more than one color to begin with.    In Tutorial #1 we changed the color of a section of globs, 
but that won't work in cases where the section changes color (after Simulate Depth has been applied to it 
for example).    In my drawing shown above, you can see that the blue globs that had been shaded from 



dark to light are now solid yellow.    If I use Simulate Depth on them, the result is I have changed a blue 
shaded section of a drawing into a yellow shaded section.

You can also use Paste with Use new colors to remove the colors from a section of a drawing.    Just Cut 
the section, then Paste it in the same place using the Use new colors option.

Okay, one last thing for this Tutorial.    It is possible to change the background color of a drawing.    Just R-
click on the drawing and select Background Color, or select Background color from the Colors menu.    
Even better, you can also use an image as the background for a drawing:

9) With any drawing you have open now, select Load background from the Image menu or R-click on the 
drawing and select Load background.    Now find a BMP or JPG image that you want to use.    You must 
choose how you want the image to fit in the drawing.    For now, just select Squash/Stretch so the image 
will fill the entire drawing and click OK.    Here's what I have:

For a comparison of the three sizing methods, see Load background.    To get rid of the background 
image, use Remove background from the Image menu, or R-click on the drawing and select Remove 
background.

The next tutorial is Tutorial #3
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Tutorial #3

This tutorial will cover the following functions: AutoChange Hue, AutoChange Sat, AutoChange Val, 
Import, Define Pattern, Pattern.

You may want to read Tutorial #2 first.

First, create a New drawing.    Any size will do.    Select any shape, but I will use the first (the shiny 
sphere) most often in the tutorials.    Make it any color you like, preferably something that isn't too dark. 

1) Turn on Polar Mirror and set it to 5 or so copies, and turn On Jitter if you want to.    (I will, because I like 
jitter.)    Now turn on AutoChange:

2) Select AutoChange Hue from the Colors menu or click the  button on the toolbar.    Select the Up 
option, and click OK.    Draw for a while.    The color changes as you draw -- more accurately, only the hue 
changes.    Here's what I drew:

The hue changed from blue to purple as I drew.    Select AutoChange Hue again, and change the speed 
slider.    Move it all the way to the right (fast).    Now draw again.    The hue changes much more quickly 
now.    Here's what I have:

I tried to duplicate the previous drawing as closely as possible.    The other direction options (Down, etc.) 
are explained in the AutoChange Hue section.

The AutoChange Sat function is similar, but instead of changing the hue, it changes the saturation of the 
drawing color.    Similarly, AutoChange Val changes the value of the drawing color.    One thing to note 



about AutoChange Sat and Val: if the Up or Down options are selected, they will change until they reach 
the top or bottom (maximum or minimum).    If you have these functions active and the color isn't 
changing, that is probably the reason.

For the most variety of colors, turn on all three:

3) Turn on AutoChange Hue.    Turn on AutoChange Sat, select the Random option, and move the slider a 
bit toward the fast end.    Turn on AutoChange Val, select Random, and move the slider toward the fast 
end.    Now draw, and watch the colors change!

Leave the AutoChange functions On for now.    If you have just drawn a lot of globs, you might want to 
either clear them, or create a New drawing, then draw something new, but not too many globs (at least at 
first) because we are going to create a pattern from these globs:

4) Select Define Pattern from the Edit menu, or press Ctrl+E.    Choose Entire Drawing, then click OK.    
You won't see anything happen, but the globs in that drawing have now been used to create a pattern of 
globs.    In order to draw with the pattern:

5) Select Pattern from the Drawing menu, click the  button on the toolbar, or press Ctrl+A.    Choose 
the Preserve Colors option and click OK.    Now create a new drawing (or clear one that is already open). 
Notice that the cursor has changed to something that looks like the Pattern button on the toolbar.    This is 
an indication that Pattern mode is active.    Click once in the drawing.    Instead of a couple of globs being 
drawn, a few (depending on your mirroring settings) copies of the pattern are added.    I used the drawing 
above as my pattern, and this is my pattern drawing:



Note that I made my drawing size a little bigger, because I knew that drawing with a pattern would need a 
little more room.    Also note that Jitter, Skipping, and Lines mode are ignored or turned off when in pattern 
mode.

In Tutorial #2 we loaded an image to use as a background in our drawing.    Now we're going to do 
something different with an image file: convert it to globs!

6) Open a new drawing, or clear one that is already open.    Select Import from the Image menu, then 
choose a BMP or JPG image.    I'm going to use an image of a Troll Doll (C) Russ that I scanned and 
cleaned up:

Select the Preserve image colors, get order from image, Background Remove, and Size Fit drawing 
options.    Do not move the Number of globs slider, and click OK.    The image will be converted to globs.    
Here's my drawing:



The background was removed because we had that option selected, and the background was a single 
uniform color -- it's important to have a solid colored background if you want to remove it when importing. 
Although Import has several other options, we're only going to look at one of the others: Use new colors. 
(For a discussion of the other options, see the Import section.)

7) Open a new drawing, or clear an old one.    Select Import again, and select the same image as before 
so you can compare the results.    Now select the Use new colors option -- leave all other settings the 
same -- and click OK.    Here's what I got:

The colors are all "weird" because the AutoChange Hue, Sat, and Val functions were still active.    It can 
provide a pretty neat effect.

One thing I like to do is use the Import function, then define a pattern from it, and draw with the pattern.    
Here's a simple example:



That's just one way that Gloodle's functions can be combined -- there are many other combinations that 
can be used.

This concludes the tutorials.    I hope they have given you an idea of what is possible with Gloodle.    The 
important thing for you to do now is experiment with the various settings, commands, and functions, play, 
and have fun! 
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Tutorials

These tutorials cover some of the aspects of Gloodle that you might not discover on your own, at least not 
right away.    It might be best to look through them in order.

Quick Start
Tutorial #1 Covers Skipping, Undo, Drawing History.
Tutorial #2 Covers Line, Cut/Paste, Move Center.
Tutorial #3 Covers AutoChange, Patterns, Import.

Overview



Undo

Undo the last action, if possible.    Also Redo the last action, if possible.    The menu text will change to 
indicate the action that can be undone or redone.

Actions that can be undone and the menu text for each:

Drawing Undo Drawing
Cut Undo Cut
Paste Undo Paste
Simulate Depth Undo Simulate Depth
Move Center Undo Move Center
Clear Drawing Undo Clear Drawing

When the action has been undone, the menu messages change from "Undo" to "Redo".

Note that Undo Drawing just moves the Drawing History slider back (to the left) one section, and Redo 
Drawing moves it forward (to the right) one section.    If the Drawing History slider is moved using the 
Drawing History buttons or by moving the slider manually, the Undo/Redo Drawing command becomes 
disabled.    Further undo or redo of drawing must then be accomplished using the Drawing History 
window.

When drawing has been undone using either this command or the Drawing History window, the globs that 
were "undone" are still present in the drawing.    They are not actually deleted until more globs are added. 
This applies after the Clear Drawing function has been used as well.    If a large number of globs have 
been undone or cleared, there may be a slight delay before new globs are added.

Toolbar:

Shortcut: Ctrl+Z

Edit Menu



View Menu

The View menu offers the following commands:

Move Center Place mirror point anywhere.
Reset Center Return mirror point to center of drawing.
Regenerate Redraw the entire drawing.
Clear Remove all globs from the drawing.
Full Screen Enter or Exit fullscreen mode.
Shapes Toggle display of Shapes window.
Colors Toggle display of Colors window.
Drawing History Toggle display of Drawing History window.
Toolbar Toggle display of Toolbar.
Toolbar 2 Toggle display of the other Toolbar.
Status Bar Toggle display of Status Bar.

The Move Center, Reset Center, Regenerate, Clear, and Full Screen commands are only shown when at 
least one drawing is open.

The state (visible or not) of the Toolbars, Status Bar, and Gloodle windows (Shapes, Colors, Drawing 
History) is saved when Gloodle is exited and restored when Gloodle is run again.

Menus



What is Gloodle?

Gloodle is "Doodling with Globs".

Gloodle allows anyone to quickly and easily create interesting, colorful, detailed images with a surprising 
amount of depth and "3D-ness".

By drawing with 3D-rendered shapes (globs) and supplying a variety of coloring functions, Gloodle allows 
you to create wonderful images, produce unique web graphics, and just have simple, creative fun!

Gloodle is Copyright (C) 1998    Alan Lorence

Gloodle is brought to you by Impulse, Inc. 

Overview
Credits



Window Menu

The Window menu offers the following commands:

Cascade Arranges drawings in an overlapped fashion.
Tile Arranges drawings in non-overlapped tiles.
Arrange Icons Arranges icons of minimized drawings.

The Window menu is only shown when at least one drawing is open.

Menus



Gloodle Windows

There are three "tool" windows you will use in Gloodle.    They are:

Shapes Select the shape to use for drawing.
Colors Select the drawing color.
Drawing History Used to undo drawing.

Overview



Adding Shapes to Gloodle

What follows is information on the glob shape images used by Gloodle, and how they were created.    You 
can use this as a guideline for adding new shapes to Gloodle.

Warning:    It is possible that in the process of adding shapes you may do something incorrectly, causing 
Gloodle not to run anymore, or having problems with certain drawings.    Add shapes at your own risk.    
Create a backup copy of the shapes folder first, so if something goes wrong you can always restore the 
original shapes folder.    If you do not keep a backup copy of the folder and things go wrong, you may 
need to reinstall Gloodle.

The shape image files

The shape images are uncompressed BMP images, 24-bit.

There are three sizes: 12x12, 20x20, and 26x26.    These are approximate sizes -- you may change them 
by a pixel or two to get better results.    The main idea is to make the sizes look consistent for all shapes 
(the small sphere looks about the same size as the small torus, etc.).

The image must be no larger than 28x28.

The file names are very important.    Gloodle shape files must contain 3 characters, followed by the bmp 
extension.    Some examples of valid shape filenames:

100.bmp
M01.bmp
b02.bmp

The first character must be the same for all three sizes, and must not be the same
as any other shapes.    Valid first characters are: 0-9, A-Z, and a-z.    (Filenames are sorted alphabetically.)

When naming shape files, use the next available first character.    For example, if the last filename in your 
shapes folder (when sorted by name) is S02.bmp, the filename of next shape you add should start with 
the letter T (uppercase).    If the last filename is Z02.bmp, the next should start with the letter a 
(lowercase).    (If the last filename starts with the letter z, there is no room for additional shapes.)

The second digit is only used because Windows 95 sees the filenames A01.bmp and a01.bmp as the 
same name.    Therefore when you must start using lowercase first characters for filenames, you must 
change the second digit to 1.    For example, the filenames a00.bmp and f02.bmp are incorrect.    They 
should be named a10.bmp and f12.bmp.

The third digit indicates shape size.    0 is small, 1 is medium, and 2 is large.    You do not need to have all 
three present.    If the file for one or two of the sizes for a shape is missing, the corresponding sizes will 
not be available for that shape.

There is a maximum of 62 shapes that can be used by this version of Gloodle.    The filename z12.bmp is 
the last available filename.

Creating the Shapes

The important thing to remember about Gloodle shapes is they should all look 3D.    For this reason, I 
recommend using a 3D program to render the shapes, although a paint program can also be used.



All of the shapes shipped with Gloodle were modeled with Organica and rendered with Imagine (both 
programs are by Impulse, Inc.)

When rendering the shapes:

I suggest using a solid colored shape.    Shapes with more than one color will work, but the colors of the 
shape in Gloodle will be unpredictable, and the different colors may detract from the 3D look of the shape.

Zoom so the shape fills as much of the frame as possible.    With such small image sizes, you need every 
pixel you can get.

Use a solid background color that will not appear in the shape.    Gloodle samples the first pixel (upper left 
corner) in the image for the background, which is then removed from the image.

Turn off anti-aliasing.    Very important, unless you can mask the shape against the background some 
other way.    The shape must not be anti-aliased against the background.

Use only one light.    Set the lighting angle to 35 horizontal, 35 vertical.    (An angle of 0 horizontal, 0 
vertical would be straight on -- the light source at the camera position.      We need the light source to the 
right and above the camera position.)    If the lighting angle is not correct, the new shape will not fit well 
with the other Gloodle shapes.

After rendering, you may need to use a paint program to clean up the edges a bit.    Rendering at these 
very small image sizes may produce some "odd" pixels.

Note: If you render larger and use a paint program to reduce the size of the image, make sure that the 
image is not resampled.    You do not want the shape to be anti-aliased against the background.

Name the files appropriately, then start up Gloodle (Gloodle only loads the shapes at startup).

Once again, use this procedure at your own risk.




