
Help File for Panorama 32
This help file contains the full documentation for the version of  Panorama 32 with which it was 
packaged. There is no written documentation, but you should be able to find all that you need to begin 
work with Panorama 32 in here.

When you're using Panorama 32's dialog boxes, you can get help on that dialog box by pressing F1 or 
clicking the "Help" button, if one is available.

Introduction
This section offers general information on Panorama 32, tells you where you can get the latest version, 
and answers licensing questions

Procedures
This section tells you how to go about doing basic things in Panorama 32, and explains some of 
Panorama 32's features.

Commands
This section gives you information on each of Panorama 32's menu commands.

Keyboard Commands
This section defines the keyboard equivalents for all of Panorama 32's functions.

Panorama 32 is Copyright ©1996, 1997 by Shaun Ivory



Introduction to Panorama 32

Legal Disclaimer
Panorama 32 is supplied on an as-is basis. The author offers no warranty of its fitness for any purpose 
whatsoever, and accepts no liability whatsoever for any loss or damage incurred by its use. Period. Here 
is the license

Panorama 32 is not a supported product. Shaun Ivory accepts no commitment or liability to address any 
problems that may be encountered in using it; however, Shaun is always interested to hear about any 
bugs or deficiencies.

What is Panorama 32?
Panorama 32 is the finest Free Microsoft Windows 95 and WindowsNT wallpaper manager.    It has the 
following features:
· Changes your wallpaper at user-configurable intervals from every second up to every 24 hours
· Runs in the explorer's system tray, so it doesn't clutter the Taskbar!
· Seamless support for JPEG, GIF and PNG files!
· The main window can be configured to stay on top of all the other windows
· The wallpaper files may be changed in order, or randomly
· You can choose to automatically tile small bitmaps (i.e. width or height less than half that of the 

screen)
· Automatically searches your hard disk for image files.

Where can I get the latest version?
The current home of this program is http://www.ivory.org/free.html.
This is subject to change, however.    An Internet search for Wallpaper and Panorama will probably yield 
success if the listed WWW address is vacant.

Acknowledgements
The people listed in the "credits" dialog box in Panorama 32: Chris Rosa, Donna Gladhill and Ana 
Carder, all helped by pointing out bugs and suggesting improvements.

CImage C++ Class Library: Copyright (c) 1995, Alejandro Aguilar Sierra <asierra@servidor.unam.mx>

The JPEG code was supplied by the work of the Independent JPEG Group.    The copyright reads as 
follows: Copyright (C) 1991-1996, Thomas G. Lane.

The PNG code was supplied by libpng.    The libpng copyright reads as follows:

Copyright (c) 1995, 1996 Guy Eric Schalnat, Group 42, Inc.
Contributing Authors:
Andreas Dilger
Dave Martindale
Guy Eric Schalnat
Paul Schmidt
Tim Wegner

zlib is Copyright (c) 1995-1996 Jean-loup Gailly and Mark Adler

Much of the text editing was done with Alan Phillips' Programmer's File Editor: 
http://www.lancs.ac.uk/people/cpaap/pfe/

Using And Distributing Panorama 32
Panorama 32 may be freely used for any purpose. You may use it privately or in the course of your work; 
there is no fee, and no registration is required. You may distribute it to anyone, and you may place it on 



any archive or bulletin board system. You may not charge anyone for it other than a reasonable fee to 
cover your distribution costs. Normally, you should distribute Panorama 32 in the form as supplied by the 
author; however, you may repackage it to suit the conventions and needs of an archive or bulletin board 
system. Panorama 32 may not be distributed as part of any commercial product without a prior licence 
agreement.

Panorama 32 may be reviewed for any publication, whether in hard copy or electronic form, without the 
author's prior permission.



Procedures

Running Panorama 32
Configuring Panorama 32
Adding Files



Configuring Panorama 32

There are several way you can change the behavior and appearance of Panorama 32.

Change Interval
Options|Preferences, Options Tab
The change interval is fully configurable.    You can change the length of time in the Preferences property 
page.

Icon Location
Options|Preferences, View Tab
You can cause Panorama 32 to put a small icon in the "System Tray" area when it is minimized, thus 
conserving space on the Task Bar.



Running Panorama 32

You can run Panorama 32 in one of several ways:
1. From the Start Menu or the File Menu in Program Manager, select Run and type:

d:\path\panorama.exe
where d: is the drive and path is the directory in which the panorama.exe file can be found

2. Select the Panorama 32 icon from the Start Menu or Program Manager, where it was placed during 
installation

3. Place Panorama 32 in the Startup group, so it always runs when you restart your computer



Commands

Most of Panorama 32's functions are accessed through the menu bar at the top, or the popup menus that 
appear when the tray icon is clicked or the right mouse button is clicked inside the program.

The File Menu
The Edit Menu
The Options Menu
The View Menu
The Help Menu

Command Line Options



License

Panorama is "unsupported freeware."

You may not modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable 
laws specifically prohibit such restriction), or create derivative works based on the Software, or remove 
any proprietary notices or labels on the Software.

Title, ownership rights, and intellectual property rights in and to the Software shall remain with Shaun 
Ivory. The Software is protected by the copyright laws of the United States and international copyright 
treaties.

Unless otherwise provided by written agreement with Shaun Ivory, this software is provided "as is" without 
warranty of any kind, expressed or implied, including, but not limited to, the implied warranties of 
merchantibility of fitness for a particular purpose. The entire risk as to the quality and performance of the 
Software is borne by you. Should the Software prove defective, you and not Shaun Ivory assume the 
entire cost of any service and repair. This disclaimer of warranty constitutes an essential part of the 
agreement. SOME STATES DO NOT ALLOW EXCLUSIONS OF AN IMPLIED WARRANTY, SO THIS 
DISCLAIMER MAY NOT APPLY TO YOU AND YOU MAY HAVE OTHER LEGAL RIGHTS THAT VARY 
FROM STATE TO STATE OR BY JURISDICTION.

While reasonable efforts have been made to assure the accuracy of this software, in no event shall Shaun 
Ivory be liable for direct, indirect, special, incidental, or consequential damages resulting from any defect 
in this software.

This license will terminate automatically if you fail to comply with the limitations described above. On 
termination, you must destroy all copies of the Software.

What do you want for nothing? 

Shaun Ivory 

shaun@ivory.org



File Menu

New
Keyboard shortcut: Ctrl+N
Start a new wallpaper list.

Open...
Keyboard shortcut: Ctrl+O
Open an existing wallpaper list.

Save
Keyboard shortcut: Ctrl+S
Save the currently open wallpaper list file.

Set as wallpaper
Keyboard shortcut: Enter
Use the currently selected wallpaper file as wallpaper.

Scan disks
Search your disks for image files.    See Scan Disks

Next wallpaper file
Keyboard shortcut: Ctrl+X
Advance to the next wallpaper in the wallpaper list.

Previous wallpaper file
Keyboard shortcut: Ctrl+P
Return to the previous wallpaper in the wallpaper list. Note that the previous wallpaper file is non-existent 
in Random switch mode.

Exit
Keyboard shortcut: Alt+F4
Exit Panorama 32.



Edit Menu

Remove files
Keyboard shortcut: Del
Remove files from the current wallpaper list.

Delete files
Keyboard shortcut: Ctrl+Del
Delete files from the list and from your local storage.

Add files
Keyboard shortcut: Insert
Add files to the current wallpaper list. See Adding Files.

Properties
Keyboard shortcut: Alt+Enter
Display and change the properties of the currently selected wallpaper file.    See Properties

Move up
Keyboard shortcut: Alt+Up
Move the current wallpaper file up in the list

Move down
Keyboard shortcut: Alt+Down
Move the current wallpaper file down in the list

Edit bitmap file
Keyboard shortcut: Ctrl+Enter
Edit the currently selected wallpaper file in the paint program associated with the image type

Clear wallpaper
Keyboard shortcut: Ctrl+R
Remove the current wallpaper, replacing it with a blank background.



Edit Menu;Preferences;Suspend;Font

Preferences
Display and change the behavior and appearance of Panorama 32.    See Preferences.

Suspend
Keyboard shortcut: Ctrl+U
Stop changing wallpaper temporarily.

When Panorama 32 is suspended, the time-left portion of the status area looks like this: 
When Panorama 32 is not suspended, the time-left portion of status area looks like this: 

Font
Keyboard shortcut: Ctrl+F
Change the font used to display the wallpaper file list.



View Menu

Toolbar
Toggle display of the toolbar.    When the toolbar is displayed, a check-mark will appear next to this menu 
item

Tooltips
Toggle display of tooltips.    Tooltips give short descriptions of the program's controls when the mouse 
cursor lingers over a control for a few seconds. When tooltips are displayed, a check-mark will appear 
next to this menu item

Hide desktop icons
Keyboard shortcut: Ctrl+I
When Panorama 32 operates under Windows 95 or Windows NT 4.0, you can temporarily hide the 
desktop icons, to avoid disturbing your view of your lovely wallpaper.

Show full pathname in list
Keyboard shortcut: Ctrl+D
Show the entire pathname of the files in the file list, including their path names.

Sort
Ascending, full pathname: Sort the files in the list in ascending order, using the entire path, 
including drive and directory.
Descending, full pathname: Sort the files in the list in descending order, using the entire path, 
including drive and directory.
Ascending, filename only: Sort the files in the list in ascending order, using the only the filename.
Descending, filename only: Sort the files in the list in descending order, using the only the filename.

Refresh list
Keyboard shortcut: F5
This command will cause all files in the current file list to be scanned immediately, to ensure that all the 
files exist and that Panorama has the correct values, such as Width, Height, Color Depth.



Help Menu

Contents
Keyboard shortcut: F1
Display the table of contents of the Help system.

About
Display program, environment and copyright information.



Adding Files

There are several ways to add wallpaper files to the current filelist:

1. Edit|Add files.    To add multiple files, select the files by holding down the keyboard Shift or Control 
key, while selecting files with the mouse.

2. Drag and drop. To add files using this method, open Explorer or your file manager, select the file or 
files, drag them to the Panorama 32 window and drop them.

3. File|Scan disks. This method allows you to add all the image files on selected hard disks at once.



Scan Disks

This dialog will allow you to search any or all of your hard disks and network disks to locate supported 
image files to add to the wallpaper file list.

Drive and directory
List of drives to search and the directories to start the recursive search from.    To change the start 
directory, double-click on the drive to change.

BMP files
If this check-box is selected, include files with the extensions BMP or RLE.

JPG files
If this check-box is selected, include files with the extensions JPG, JPE or JPEG.

PNG files
If this check-box is selected, include files with the extension PNG.

GIF files
If this check-box is selected, include files with the extensions GIF.

Custom
If this check-box is selected, files with the extensions listed in the edit box to the right will be included in 
the scan.    By default, the edit control will contain the following extensions: *.BMP, *.RLE, *.PGN, *.GIF, 
*.JPG, *.JPE and *.JPEG.    Note that all extensions listed in this box must be separated by semi-colons.

Search directory
The search start directory for the currently selected drive.

Browse
Pick a search start directory for the currently selected drive.

Scanning Directory



Display the directory currently being scanned.

Scan
Begin the search.

Stop
End the search.



Information

Filename
Displays the filename of the currently selected wallpaper file.

Size
Displays the size, in bytes, of the currently selected wallpaper file.

Resolution
Displays the dimensions, in pixels, and the bit-depth, or color resolution of the currently selected 
wallpaper file.

Thumbnail
Displays a thumbnail of the currently selected wallpaper file.



Options

Tiling Options
Always Tile
Always tile the currently selected wallpaper file, regardless of the global setting for tiling options

Never Tile
Never tile the currently selected wallpaper file, regardless of the global setting for tiling options.

Scale to screen * †
Scale the selected image to the full size of the screen, shrinking or stretching as necessary.

Default
If this is selected, the decision to tile or scale this wallpaper will be based on the global tiling settings 
found in the Preferences dialog.

Background Color
Default
Use the default background color

Change
Change the background color to be used with this wallpaper file

* This feature is not available on Windows NT 3.51
† This feature is only available on Windows 95 if you have installed Microsoft Plus!.    As an alternative, 
you can download the following file using FTP:

ftp://ftp.microsoft.com/developr/drg/truetype/w95gray.exe.

The author does not offer support for nor guarantee the existence of this product.



Preferences

These options let you change the behavior and appearance of Panorama 32:
View
Options
Desktop
JPEG
Hot-Keys



Options

Default Background Color
Set the default background color for all wallpaper files.    This option can be overridden for individual 
wallpaper files in the Edit|Properties dialog

Tile images smaller than ½ of screen height or width
Automatically tile images whose size is less than or equal one-half the size of the screen.    This option 
can be overridden for individual wallpaper files in the Edit|Properties dialog

Scaling options * †
Scaling an image causes the image to exactly fill the screen.    These options can be overridden for 
individual wallpaper files in the Edit|Properties dialog.

No default scaling
No automatic scaling will take place.

Scale all images
Scale all images, regardless of size.

Scale proportional images only
Automatically scale images whose aspect ratio (Width:Height) matches (or nearly matches) the 
aspect ratio of the screen.

Scale images smaller than ½ of screen height or width
Automatically scale images whose size is less than or equal one-half the size of the screen.

Note: If an image is a candidate for both automatic tiling and automatic scaling, it will be tiled.

* This feature is not available on Windows NT 3.51
† This feature is only available on Windows 95 if you have installed Microsoft Plus!.    As an alternative, 
you can download the following file using FTP:



ftp://ftp.microsoft.com/developr/drg/truetype/w95gray.exe.

The author does not offer support for nor guarantee the existence of this product.



Command Line Options

The following command line options are available:

-N Select next wallpaper in sequence, then immediately exit.

-X This switch will provide 4 new options in the Options|Preferences|View property page.    These 
trouble-shooting options allow you to turn off the following features, in the unlikely event they are causing 
problems on your computer: the bitmap displayed on the File menu, the gradient on the program's title 
bar, the bitmap background in the "About..." dialog, and the display of menu hints in the title bar.





Hot-Key Preferences

This dialog will allow you to change the hot-keys associated with Panorama 32

Next Wallpaper Hotkey
The global hot-key combination which will cause Panorama 32 to advance to the next file in the wallpaper 
sequence.

Previous Wallpaper Hotkey
The global hot-key combination which will cause Panorama 32 to return to the previous file in the 
wallpaper sequence.

Use Windows Keyboard Hotkeys
If this option is selected, the key combinations Win+X and Win+P may be used to change the wallpaper.    
The Win key is only available on computers whose keyboards have a key labeled with the Windows 
symbol.



JPEG Preferences

This dialog box will allow you to control the conversion of JPG files to Windows-compatible BMP files.

Convert to Grayscale
Convert all JPG images to grayscale images.

Dither to 256 colors
Reduce colors to 256 by dithering.

No Dithering
Display JPG as-is, with no color reduction.



Options

Change Interval
Set the amount of time between wallpaper changes. Minimum is 1 second, maximum is 23 hours, 59 
minutes, 59 seconds.

Change Order
Random: Change wallpaper in random order.
In Sequence: Change wallpaper in the order in which they appear in the file list.

Change wallpaper at startup
Change the wallpaper each time Panorama 32 is started.



View Preferences

Minimize to system tray
When Panorama 32 is minimized, a small icon will be displayed in the system tray area, as follows:

Start in system tray
Start Panorama 32 in the system tray

Keep window on top
Always keep the Panorama 32 no top of all other windows

Show toolbar
Toggle display of the toolbar in the main window.

Show tooltips
Toggle display of tooltips.    Tooltips give short descriptions of the program's controls when the mouse 
cursor lingers over a control for a few seconds.

Turn off "Exit" confirmation
Turn off the annoying message that asks you whether or not you really want to quit.

Don't test file existence of File|Open
Don't check for the existence of each file when opening a wallpaper list.    This will speed the loading time 
for very large lists. 



Properties

The Properties dialog allows you to view and change properties of the selected wallpaper file.

These are the options available:
Information
Options



About Panorama 32

This dialog box offers information about Panorama 32 and the operating system on which it is running.

Version
The version of this release.

Compile date
Actual compile date.

Platform
Which platform we are on.

Memory
How much memory is free.



Credits

This dialog lists those people who used Panorama 32 and gave me the criticism that forced me to 
improve it.

Thanks again!



Search

Panorama 32 uses a searching mechanism called Interactive Search.    Just start typing the name of the 
file you want to find.

As you type more letters and narrow down the search you will be able to select the file you are searching 
for.

To end the search without changing the selection that was in effect before the start of the search, press 
the Escape key or click the primary mouse button outside the search area.

To select the file highlighted during the search, press Enter.



Non Existent File Warning

This warning dialog will alert the user when a file in the list is missing.

Leave
Leave this file in the list

Leave All
Leave all missing files in the list

Remove
Remove this file from the list

Remove All
Remove all missing files from the list



Keyboard Commands

     Key       Command
     Ctrl+N    File|New
     Ctrl+O    File|Open...
     Ctrl+S    File|Save
     Enter     File|Set as wallpaper
     Ctrl+X    File|Next wallpaper file
     Ctrl+P    File|Previous wallpaper file

     Delete    Edit|Remove file
     Ctrl+Del  Edit|Delete file
     Insert    Edit|Add files...
     Alt+Enter Edit|Properties
     Alt+Up    Edit|Move up
     Alt+Down  Edit|Move down
     Ctrl+R    Edit|Clear Wallpaper
     Ctrl+Enter Edit|Edit bitmap file

     Ctrl+F    Options|Font
     Ctrl+U    Options|Suspend

     Ctrl+I    View|Hide desktop icons
     Ctrl+D    View|Show full pathname in list



Panorama 32 currently supports Microsoft Windows BMP files, Compuserve GIF, JPEG and PNG files.






