
Presto! ImageFolio Context Help

Welcome to the world of Presto! ImageFolio!!

You will get simple explanations about the functions in Presto! ImageFolio from the on-line help. For more 
detailed information, please refer to your User's Manual.

Choose a topic for help from the following:

Screen Introduction

Keyboard

Menus and Commands

Tools

Palette Control



Screen Introduction

When you start Presto! ImageFolio, the image editing screen displays the following parts:

Title Bar

Menu Bar

Tool Bar

Image Editing Area

Image Windows

Toolbox

Tool Control

Palette Control

Status Bar

Rulers
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Title Bar

The title bar indicates the name of the software "Presto! ImageFolio".



Menu Bar

The menu bar lists the available menus. In each menu, there is a list of commands. The menu commands 
indicate the tasks you might want to perform.

To open a menu, click on the menu or press its underlined letter while pressing and holding the [Alt] key. 

To invoke (or activate) a command, point to it and click or strike the underlined letter in the command 
name. To close a menu without choosing a command, click anywhere outside of the menu or press the 
[Esc] key.



Tool Bar

The icons in the tool bar offer quick and convenient access to several menu commands. The following 
lists the functions of all menu commands that have proprietary icons in the tool bar.

Click on the icons to execute the related commands.



Image Editing Area

The image editing area is that large portion in the center of the screen where you can work on your 
image. The "Image Canvas" you actually use to work on your image appears as a window in that area; it 
can be moved and sized within this image editing area through the general Windows operating method.



Image Window

Each image canvas appears as an image window in the image editing area. If the image canvas is 
actually larger than the image window, two scroll bars appear. The vertical scroll bar allows you to view 
the hidden upper and lower portions of the image. The horizontal scroll bar allows you to view its hidden 
left and right portions.



Toolbox

The Toolbox is composed of two major sections: the selection tools and the painting tools. In default you 
can see 20 tools displayed in the Toolbox; but some of the tool buttons contain a little down arrow at the 
lower right corner, which indicates that here is a group of tools and the other tools are hidden beneath the 
current tool. To display the hidden tools, click on the tool button while pressing and holding the [Alt] key, or 
click the right mouse button.



Tool Control

The Tool Control window contains options for setting the current selected tool in the Toolbox. The items of 
setting vary for different tools.



Palette Control

The Palette Control is used for color selection. For different ways to select colors, there are two different 
types of display for operation in the Palette Control window.

Note:

The number of colors that the image canvas can display is independent of the system's display mode. In 
other words, you can edit a 256-color canvas even though your system only has a 16-color display. In 
such case, halftone patterns are used to simulate the 256 colors.

Detailed instructions on selecting colors are provided under the topics Palette Control.



Status Bar

The Status Bar is located at the very bottom of the image editing screen. The Status Bar consists of the 
status box and the message box.

The status box displays the X,Y coordinates indicating where the pointer is on your active image window.

The message box displays a message about the item that the pointer is currently on.

During processing, the status and message boxes indicate the command you have selected and the 
progress of the operation. You may press the [Esc] key to abandon the process before it is complete if 
necessary.



Rulers

The rulers can help you edit precisely. You can change the ruler's measure units from the Preferences 
dialog box.



Keyboard

This section lists the keyboard shortcut for executing specific commands and the subsidiary keys while 
using the mouse to edit the images.

Keyboard Usage in General

Keyboard Usage for Tools

Keyboard Usage for Selection

Keyboard Usage for Palette Control



Keyboard Usage in General

The following table lists the general keyboard usage in Presto! ImageFolio.

Key Function

[Alt] Combined with the underlined letter of an 
item on the menu bar, pulls down and open 
the menu. (To invoke a menu command, or a 
dialog box action, press the appropriate 
underlined letter.)

[Ctrl]+ [N] New

[Ctrl]+ [O] Open

[Ctrl]+ [S] Save

[Ctrl]+ [R] Revert

[Ctrl]+ [P] Print

[Ctrl]+[Z] Undo

[Ctrl]+[X] Cut

[Ctrl]+[C] Copy

[Ctrl]+[V] Paste

[Ctrl]+[I] Fill In Pattern

[Del] Clear

[F1] Help Index

[F2] Toggle display of all panels

[F3] Toggle Toolbox display

[F4] Toggle Tool Control display

[F5] Toggle Palette Control display

[F6] Toggle Rulers Display

[F7] Toggle Tool Bar display

[F8] Toggle Status Bar display

[F9] Toggle Title Bar display

[F10] Toggle Layer Manager display

[Ctrl]+[1] Change the screen layout to Layout 1

[Ctrl]+[2] Change the screen layout to Layout 2

[Ctrl]+[3] Change the screen layout to user-defined 
layout

[Ctrl]+[F] Last Filter

[Shift]+[F5] Cascade

[Shift]+[F4] Tile



[Enter] Executes the current command

[Esc] Cancels the current command while 
processing

[+] Zoom in

[-] Zoom out

Keyboard Usage for Tools

The keyboard usage for tools is combined with the mouse actions to edit the image.

Different functions are performed for different tools while holding the [Shift], [Ctrl] or [Alt] key and 
clicking/dragging the mouse:

Tool Operation Function

Rectangle [Shift]+drag the left button

[Alt]+drag the left button

Draw a square

Draw a rectangle starting 
from its center

Ellipse [Shift]+drag the left button

[Alt]+drag the left button

Draw a circle

Draw an ellipse starting 
from its center

Curve [Shift]+drag on the node

[Shift]+click the right 
button

[Ctrl]+click the left button

Click the right button

Generate control points

Close the curve segments

Remove the last generated 
node

Complete the curve 
segments

Line [Shift]+drag the left button Draw a line in an angle of 
45 degree increments

Gradation Click the right button Select multiple colors for 
generating gradation

Paintbrush, 
Airbrush

Click or drag the left 
button

Click or drag the right 
button

Paint with foreground color

Paint with background color

Text, Text Along 
Path

Click the right button Complete the process

Stamp [Shift]+click the left button Pick the image for stamping 
or set the starting point for 
cloning

Image Hose [Shift]+click the left button

Click the right button

Avoid overlapping sprayed 
images

Define Image Hose Pattern

Texture Brush Click the right button Select a texture pattern



Zoom [Shift]+drag the left button

[Ctrl]+click the left button

Click the right button

[Esc]

Fit a part of the image in 
image window (magnified)

Zoom out

Actual size display

Return to the editing area 
from Full Screen display

Eyedropper Click the left button

Click the right button

Pick foreground color

Pick background color

Blur/Sharpen Brush Click or drag the left 
button

Click or drag the right 
button

Blur the image

Sharpen the image

Brightness/
Contrast Brush

Click or drag the left 
button

Click or drag the right 
button

Brighten the image

Darken the image

Free-hand Rescale [Shift]+drag the left button Rescale proportionally

Free-hand Rotate [Shift]+drag the left button Rotate in 45 degree 
increments

The following keyboard/mouse operation works no matter what tool you have selected currently.

Operation Function

[1]+click the left button Zoom in

[2]+click the left button Zoom out

[3]+drag the left button Panning the image

[4]+click the left button Pick foreground color in a true-color 
image

[5]+click the left button Pick background color in a true-
color image



Keyboard Usage for Selection

The keyboard usage for selection should be combined with the mouse actions to define the selection 
outline.

Holding the following keys while dragging the mouse generates different effects:

Tool Operation Function

Selectors as 
Rectangle Selector, 
Ellipse Selector, 
Magic Wand, etc.

[Shift]+drag the left button

[Ctrl]+drag the left button

Increase the selected area

Exclude the selected area

Rectangle Selector [Shift]+drag the left button

[Alt]+drag the left button

Select a square area

Select from the center of 
the rectangle

Ellipse Selector [Shift]+drag the left button

[Alt]+drag the left button

Select a circular area

Select from the center of 
the ellipse

Free-hand Selector Double click the mouse 
left button

Completing the selection

Path Selector [Shift]+drag on the node

[Ctrl]+click the left button

[Shift]+click the right 
button

Click the right button

Generate control points

Remove the last generated 
node

Create an enclosed area 
from the first to last node

Complete the selection

Selector Brush Drag the left button 

[Ctrl]+drag the left button

Add Selection 

Exclude Selection

Move Tool Drag the left button

[Ctrl]+drag the left button

[Alt]+drag the left button

Move the selected object

Change the active layer 

Move the selection frame

When a tool 
capable of creating 
selections is active

Click the right button Invoke the mask options



Keyboard Usage for Palette Control

The table below lists the keyboard and mouse operations for editing the color palette in the scratch pad.

Keyboard/Mouse Operation Function

Click Mouse Left Button Pick a foreground or background color

[Shift]+Click Left Button Select or deselect colors

[Shift]+Click Right Button Deselect all the currently selected color

[Shift]+Drag through a 
block of colors

Select a block of colors

[D] Delete the selected colors

[Ctrl]+Click Left Button Insert the selected colors starting from the 
color grid you are now on

[Alt]+Click Left Button Replace the colors of the color grid you 
are on with the selected ones

Menus and Commands

There are several pull-down menus located on the menu bar. Each menu contains a list of commands to 
execute special functions for image processing.

Choose a menu from the following list to view the command function under it.

File

Edit

Select

View

Process

Transform

Window

Help



File Menu

The following commands are included in the File menu:

New

Open

Save

Save As

Revert

Image Manager

Select TWAIN Source

Acquire

Stitch

Print Setup

Print

Set as Wallpaper (Tiled)

Set as Wallpaper (Centered)

Preferences

Exit



New

The New command creates a new canvas. To create a new canvas, do the following:

1. Open the File menu and select New or click on its icon to initiate this command on the tool bar. The 
New dialog box appears.

2. Select the image type for your image. The image type indicates a number of colors to be used in 
creating your image. The following table illustrates the number of colors used for each type:

Type Number of Colors

Black & White 2

Index 16 Gray 16 shades of gray

Index 256 Gray 256 shades of gray

Index 16 Color 16

Index 256 Color 256

24-bit True Color 16.7 million

The number of colors that the canvas can display is independent of the display type. This means that 
you can edit a 256 color canvas, for example, even if your system only has a 16 color display. In that 
case, halftone patterns are used to simulate the 256 colors.

3. Enter the image resolution in the Resolution text box. Higher resolutions provide better images, but 
take more disk space and more time to process.

4. Click on the Image Size pull down list box to select the size of your image canvas.

Enter the size in the Custom text boxes if you select the Custom Defined option. And select the 
appropriate unit from the full down list box.

The amount of memory required to create the canvas and the amount of available free memory are 
displayed at the bottom of the dialog box.

5. Click on the [New] button.

A new canvas is created with an untitled filename and filled with the current background color.



Open

The Open command is used to load an already existing image file. To open an image file, do as follows:

1. Open the File menu and select Open, or click on the Open icon on the tool bar. The Open dialog box 
appears.

2. Locate the drive and directory containing the file(s) you want to open.

The software displays the names of all files in that directory that are of the type selected in the Files of 
Type box. To display a different type of files, select the type you want from the Files of Type box.

3. From the list of files, select the file you want to open.

Note:

You can open multiple files by clicking on the file names while holding down the [Ctrl] key to select non-
contiguous files, or on the file names while holding down the [Shift] key to select contiguous files.

Whenever you select a file, the lower part of the dialog box will display the information about the 
image for your reference.

4. If the [option] button is enabled, you can set the file format option for opening the image. The setting 
will be memorized and used until you change it next time.

5. Click on the [Open] button to open the file; or click on the [cancel] button to abandon the process.

The Open dialog box is the default option for opening image files. You can also select to display image 
previews before opening images files, which is helpful for you to identify the images and ensure you open 
the right ones. To display the image previews, you need to enable the Open File with Thumbnail View 
option in the Preferences dialog box.

All the image files appear as shrunken copies for your identification. If the image file you want to open is 
in another folder, click the [Change Directory] button to locate it. In this dialog box, you can select single 
or multiple image thumbnails with the same method as in the default Open dialog box. After you have 
selected the files to open, click on [OK] to open them.



Save

Save is used to save an image that already exists on disk. After saving, you can keep on working on the 
image. It is a good idea to save often to prevent accidental loss of the image changes you have created.

In addition to open the File menu and select Save, a shortcut method to invoke the Save command is to 
press [Ctrl]+[S].



Save As

This command saves a new or previously existing file you have been working on. You can name a new 
file or save an existing file under a new name and preserve the original file in its previously saved form. To 
save a new or existing file:

1. Open the File menu and click on Save As, or click on its icon on the tool bar. The Save As dialog box 
appears.

2. Select the location you want to save the image.

3. Click on the extension that corresponds to the image format of the file to be saved in the Save as 
Type box.

4. Enter the filename for the image in the File Name text box, or go to the list box and choose an 
existing filename for the image.

Note:

If you key in an extension in the File Name text box rather than clicking on the extension in the Save as 
Type box, even though the list box doesn’t change, what you have keyed in takes precedence over what 
is shown in the Save as Type box.

5. If the [Option] button is enabled, you should set the saving option for the selected file format.

If you selected the JPG compressed file extension, you need to set the compression level when the 
JPEG Compression Control dialog box pops up. The compression level determines by how much an 
image is compressed. This has no direct relationship to the actual compression ratio achieved but the 
higher the level, the greater the amount of compression. After the image is saved, the File Information 
box will display the final compression ratio, image size, etc.

If you select the TIF extension, you should also choose whether to compress the image in the pop-up 
dialog box.

6. Click on the [Save] button to save; click on the [Cancel] button to cancel the process.



Revert

After an image has been modified, if you are not satisfied with the changes, you can abandon all the 
changes by reverting the image to its last saved condition. Execute the Revert command in the File menu 
to reload the file again.



Image Manager

The Image Manager command under the File menu invokes the Image Explorer provided with Presto! 
ImageFolio. It allows you to view an image before actually opening it to ensure that it is the image you 
want to load on screen. Moreover, it offers functions of acquiring images, adding properties to images, 
renaming/deleting/sorting files, etc.

The three options in this command give you a chance to select to invoke the Image Explorer in its full 
view, aligned left or bottom.



Select TWAIN Source 

Presto! ImageFolio supports the TWAIN driver interface to give you access to images from any input 
device with a TWAIN driver interface such as scanners. This interface protocol was developed by several 
leading hardware and software manufacturers in order to establish a standard in the combined use of 
input devices and software applications. As long as the input device provides a TWAIN driver, it can work 
with Presto! ImageFolio without any problem.

If you plan to use an input device that has a TWAIN driver with Presto! ImageFolio, you should first install 
the driver with the hardware on your computer according to your device's manual before entering image 
data from it into Presto! ImageFolio.

To input an image using a TWAIN source, you need to first select the TWAIN source in your system. Open 
the File menu and choose Select TWAIN Source command. A dialog box appears.

All the TWAIN sources installed on your system will be listed in the Sources box. Click on the device you 
want to use and press the [Select] button.

See also:

Acquire



Acquire

To acquire image input from a TWAIN source, open the File menu and select the Acquire command after 
selecting the TWAIN source. The Acquire option inputs the image directly to Presto! ImageFolio, and the 
Acquire with Auto Process option can automatically make corrections to the input image on colors, 
orientations, etc.

A dialog box will appear for your further operation no matter which option you have selected. The dialog 
box varies for different devices because manufacturers design their own user interface. You may refer to 
the user’s manual of the TWAIN device for details on inputting images from this dialog box.

If you have selected the Acquire with Auto Process option, after inputting the image, the software will 
automatically make corrections to the input image before it is displayed on screen.

See also:

Select TWAIN Source



Stitch

The Stitch command under the File menu can stitch or merge two or more images into one. This is 
especially helpful when you need to scan a picture of dimensions exceeding the scanning width of your 
scanner. You can even scan the image(s) in the Stitch dialog box before stitching them.

With the Auto Stitch and Semi-auto Stitch functions, you can easily join back the separated parts of 
images produced by several scanning into one whole image. Manual Stitch, however, is mostly applied 
when stitching images with pronounced differences.

To stitch images:

1. Choose the Stitch command under the File menu. or click on its icon on the tool bar. The Stitch dialog 
box appears with the Main Image tab active.

2. Click on the [Import] button to load the image file you want to do stitching from, or the [Scan] button 
to input an image from your TWAIN scanner (the scanning process is the same as using the Acquire 
command). The image type, size, resolution, and a shrunken copy of the selected file (the stitching 
image) are displayed.

If the image is not in the right direction you want to stitch with, click on the [Rotate] button and select 
an option to rotate the image in clockwise/counterclockwise 90 degree, or 180 degree.

3. Select the Rest Image tab and load the image you want to stitch the main image to with the same 
procedure as in step 2. The image type, size, resolution, and a shrunken copy of the selected file are 
displayed.

4. Select the Stitch Image tab for stitch setting.

5. If any of the Main and Rest images is askew, click on the [Deskew] button below the shrunken image 
to adjust it.

After you click [Deskew], the image will appear in the image editing area with a straight line that has 
two reversed crossed nodes at both ends. Point to any of the nodes until the cursor changes into a 
double-headed arrow, and drag the nodes to have the line aligned with any of the object edge that 
should be vertically straight after the adjustment. Then click the right mouse button to start the 
deskew process.

The Stitch dialog box will appear again after the deskew process.

6. Select a Stitch Control option, either top, right, bottom, or left of the Main Image depending on where 
you want to put the Rest Image picture.

Note:

The Rest Image will be converted to reflect the image type of picture it is stitching on.

7. Adjust the Overlap Range in Auto Stitch slider to set the overlapping width of the images. An 
overlapping frame locates in the Rest Image to help you identify the stitching position. The frame 
moves as you adjust the slider.

8. Select a way, Manual, Semi-auto or Auto, to stitch the image in the Stitch Method section.

Manual Stitch

You have to specify the overlapping reference points precisely on both the main and the rest images.

To stitch images manually:

1. Select the Manual option in the Stitch Method section. The image editing area appears with the 
overlapping range of both images. You will see a stitching frame in the stitching image.



2. Move the stitching frame to the reference portion to be overlapped and click. The stitching frame with 
the stitching reference portion will move to the receiving image.

3. Move the stitching frame to the overlapping reference portion in the receiving image and click. The 
images are stitched.

Note:

If the edges of two images of different lengths or size are to be linked in the matching, you can only stitch 
the images manually.

Semi-auto Stitch

You have to specify the overlapping reference portions but it does not have to be as precise as is needed 
for Manual Stitching. The difference between manual and semi-auto stitch is that semi-auto stitch can 
adjust the sizes and contrast of the edges of stitched images. Follow the instructions below to execute 
semi-auto stitch:

1. Select the Semi-auto option in the Stitch Method section.  The  image  editing area appears with the 
overlapping range of both images. You will see a stitching frame in the stitching image.

2. Move the stitching frame to the reference portion to be overlapped and click. The stitching frame with 
the stitching reference portion will move to the receiving image.

3. Move the stitching frame to the overlapping reference portion in the receiving image and click. The 
images are stitched.

Note:

You do not need to align the overlapping portion very precisely because the overlapping reference 
range has a tolerance of 10 pixels. 

If you select the Top or Bottom option from the Stitch Control, the width of the two images should be the 
same or of no more than a 3% difference. If you select the Left or Right option, the height of the two 
images should be the same or of no more than a 3% difference.

Note:

To use Semi-auto Stitching, the Main image has to be a 24-bit true color or a 256 gray scale image.

Auto Stitch

You do not need to specify any reference point for stitching. The program will automatically calculate and 
stitch the images.

Adjust the Overlap Range in Auto Stitch slider to set the overlapping width of the images. A overlapping 
frame locates in the Rest Image to help you identify the stitching position. The frame moves as you adjust 
the slider.

If you select the Top or Bottom option from the Stitch Control, the width of the two images should be the 
same or of no more than a 3% difference. If you select the Left or Right option, the height of the two 
images should be the same or of no more than a 3% difference.

Note:

For Auto Stitch, the Main image has to be a 24-bit true color or a 256 gray scale image.



Print Setup

The Print Setup command allows you to change the settings your printer has been configured to print 
with. In default, these settings are the ones specified in the Control Panel's Printer option during your 
Windows installation. To change the default settings, do the following:

1. Open the File menu and click on Print Setup. The Print Setup dialog box appears.

2. Make all necessary changes.

3. Click on the [OK] button to save the changes and return to the image canvas; click on the [Cancel] 
button to close the box and return to the image canvas without saving the changes made.

See also:

Print



Print

The Print command under the File menu provides users with different options for printing and image 
output formats. To print an image:

1. Open the File menu and choose Print, or click on its icon on the tool bar, the Print dialog box appears.

In default, the Printer tab is active. The information about the current printer, port configuration and 
page orientation setups are displayed in the upper part of the dialog box. These can only be changed 
through the commands in the Print Setup dialog box. If you want to change any of these items, click 
on [Setup] at the right.

2. Enter the number of copies you want to print in the Copies text box.

3. Select the orientation of the paper as portrait or landscape.

4. The Set Margin section allows you to set the top and left margins. You may also choose to print the 
image horizontally or vertically on the middle of a page.

You can change the position’s coordinates and units from the Unit pull down list box.

5. If you want to rescale the image while printing, select the Rescale tab to make related setting.

6. Click on the Fit In Page check box if you want to rescale the image in relation to the size of the paper 
used.

If you need to change the size of the paper, select the correct size from the Paper Size list box.

7. You can set the scaling ratio by entering its size in the Target Image section or by entering the X 
(horizontal ratio) and Y (vertical ratio) values in the Rescale Factor section. You can also specify the 
scaling ratio by dragging the slider between the 10% and maximum rescale proportion indicated.

If you have enabled the Keep Ratio option, you can enter either the width or the height of the rescaled 
image. The software will automatically determine the other value for you.

If you have disabled the Keep Ratio option, you have to enter both the width and height to rescale the 
image. If the values you enter are not proportional, the rescaled image will be distorted.

8. Enter the horizontal and vertical resolutions of printing in the Resolution text boxes.

9. Due to the different effects generated by various types of printers, the colors printed may not be 
completely the same as those displayed on screen. If you want to adjust the colors of printing, select 
the Enhancement tab.

10. The Auto Correction function includes three options: Gamma, Auto Density and Unsharp Mask. If you 
enable the Auto Correction function, you can choose whether to execute these three options.

The Gamma option adjusts the brightness level of the printed image. The higher the value, the 
brighter the printed image.

The Auto Density option is used to sharpen dull images or tone down overly sharp ones by 
redistributing the gray shades in them. Click on the [Option] button to adjust the printing effect. The 
setting in the pop-up dialog box is the same as the procedure of setting the Density Control command 
under the Process menu.

The Unsharp Mask option is used to sharpen the portion of image where the color values among 
pixels have sound differences. Click on the [Option] button to adjust the sharpen level. This process is 
the same as the function of the Unsharp Mask option in the Sharpen command under the Process 
menu.

11. The Print Variation function enables you to adjust the image colors on screen and print previews for 
clear reference.



To use the Print Variation function, enable the Use Print Variation option and click on the [Print 
Variation] button. The Variations dialog box appears.

The setting in this dialog box is mostly the same as that for the Variations command under the 
Process menu. The difference is that you can print the image previews to check the actual colors 
printed before the real image is printed.

When adjusting the colors in the image, the Sample image will be the one you actually print out. 
Therefore, you can first print the image previews by clicking on the [Print Adjust Page] button to 
compare the printed color effect with the image previews shown on screen. Because the Sample 
image should be the one you are satisfied with, compare the printed image previews with the Sample 
image on the screen, and find out the printed image preview closest to the effect you desire, then 
make it the Sample image on the screen. You can adjust the image as many times you want to find 
out the best effect for the image.

After you obtain the best effect for the image, make it the Sample image and click [OK] to return to the 
Print dialog box.

12. Click on the [Print] button to print; click on the [OK] button to save the settings but not print the image 
immediately; click on the [Cancel] button to abandon all the changes and return to the image canvas 
without printing.

See also:

Print Setup

Density Control

Sharpen

Variations



Set as Wallpaper (Tiled)

An image edited in Presto! ImageFolio can directly be set as the Wallpaper of Windows desktop. Select 
the Set as Wallpaper (Tiled) command from the File menu to duplicate the image and fill the entire screen 
as tiles.



Set as Wallpaper (Centered)

An image edited in Presto! ImageFolio can directly be set as the Wallpaper of Windows desktop. Select 
the Set as Wallpaper (Centered) command from the File menu to place the image at the center of screen.



Preferences

The options in Preferences dialog box are provided for setting some features as you run Presto! 
ImageFolio.

Monitor Gamma

The Monitor Gamma option allows you to compensate for differences among monitors. You may adjust 
the RGB channels separately and precisely on screen to view images in their real colors.

To set Monitor Gamma, follow these steps:

1. Enable the Monitor Gamma option (click in the check box) and click on the [Set Gamma Value] 
button. The Monitor Gamma dialog box pops up.

2. Select Separate to adjust the RGB channels separately, or All to adjust three channels at once.

3. Drag the slider(s) to make the color of each small block inside the red, green, and blue color blocks in 
the Separate section or the gray color block in the All section look the same as their  surrounding 
colors. The color of the small block changes as you move the slider.

You can also type in the gamma values directly for more precise setting.

4. Click on the [OK] button to record the gamma value.

View Images with Common Palette

When you simultaneously open several image files, you may either want to use a different color palette to 
view/edit each image, or use a common palette for all the images (this in view of the fact that different 
images were possibly processed with each its own color palette). If you choose to view each image using 
its own palette, thus letting you view an image in its own form, the color palette of the current active 
image will take charge of all the displayed colors in the inactive background images. If you choose to view 
all the images with a system-defined common palette, all the images will appear better when screened 
but the performance of the overall system will be slowed down (this is because the system-defined palette 
must first override the individual palettes of the different images).

Undo Enabled

Enable or disable the Undo command under the Edit menu.

Close TWAIN Window after Acquiring Image

After you have input an image from the TWAIN device, the Acquire dialog box may be closed 
immediately. If you want to input another image, you have to execute the Acquire command again. 
However, if you disable this option, the Acquire dialog box will stay on screen after an image is input and 
wait for your further action. You may input images one after another without interruption.

Open File with Thumbnail View

This option offers you an opportunity to display image previews before opening images files, which is 
helpful to identify the images and ensure you open the right ones.

File Recall Level

You can quickly open any of the last few images you worked on by choosing the file name listed in the 
lower part of the File menu. This option specifies the number of recorded image files from 1 to 7 to be 
recalled.

Adobe Plugin Path

Specify the directory storing the third-party plug-in programs to utilize special effect filters. The software 
will search for all the plug-ins and add them into the Process menu next time you restart it.



Ruler Unit

The Ruler Unit list box allows you to select a measure unit for the rulers in the image window. You can 
use inches, centimeters or pixels as measure unit.



Exit

To quit Presto! ImageFolio, select the Exit command under the File menu.

If your image has been modified and not saved yet, a dialog box will appear and prompt you to save the 
file. Click on the [Yes] button to save the image, the [No] button to ignore the image modification and exit 
the software, or the [Cancel] button to quit the Exit command.



Edit Menu

The Edit menu contains the following commands for editing images:

Undo

Cut

Copy

Paste

Paste as New

Stroke

Clear

Crop

Duplicate Document

Save as Pattern

Define Pattern

Fill In Pattern

Magic Touch



Undo

The Undo option cancels the last action Presto! ImageFolio performed. The last action you performed is 
displayed at the right of the Undo command. Click on this command or the Undo icon on the tool bar to 
undo or redo the action.

This function is disabled in default; however, you can enable it by using the Preferences command under 
the File menu. With Undo turned off, the program doesn't have to keep track of your actions, and devotes 
more memory to run other features. The general operation speed is thus faster in disabled mode.

Note:

Not all the commands or functions in the software can be canceled by the Undo command. If this is the 
case, the Undo command name will change as Can’t Undo.



Cut

The Cut command removes a selected portion of image and places it on the Windows clipboard. You can 
use the Paste command to place the image content last cut and put on the clipboard back onto the 
original image, or paste it to another document. Only the last cut content resides in the clipboard. To cut a 
portion of the image, do the following:

1. Select an area by dragging across the area with a selector from the Toolbox.

2. Open the Edit menu, and click on the Cut command. The content of the selected area is removed.

Note:

The keyboard shortcut to execute the Cut command is [Ctrl]+[X].

See also:

Paste

Paste as New



Copy

The Copy function enables you to make a copy of your selected image (or portion of image) and place it 
on the Windows clipboard. The original image is unaffected by the Copy command. You could use the 
Paste options to move the content last copied on the clipboard to another document. Only the last copied 
content resides in the clipboard. To copy a portion of image:

1. Select an area of the image by dragging across the area with a selector from the Toolbox.

2. Open the Edit menu, and click on the Copy command. A copy of the selected area then resides in the 
clipboard.

Note:

The keyboard shortcut for copying the image is [Ctrl]+[C].

See also:

Paste

Paste as New



Paste

The Paste command pastes the content that was last cut or copied to the clipboard onto your image. The 
command works only when there is already a content in the clipboard. To paste, do the following:

1. Open the Edit menu, and click on the Paste command.

A "phantom window" (sort of a window floating on screen) appears displaying the content of the 
clipboard.

2. Move the pointer into the floating window. The pointer's shape then changes to an arrowhead-shaped 
cross.

3. Drag the phantom window to the location on your image where you want to paste its content. Note 
that any part to be pasted that exceeds the image canvas in size will be lost.

Furthermore, if the clipboard content contains more colors than that of the current image canvas, the 
content's colors are automatically converted to match the colors of the canvas.

4. Click the left mouse button outside of the phantom window to paste the content.

Note:

The keyboard shortcut to execute the Paste command is [Ctrl] + [V].

See also:

Cut

Copy

Paste as New



Paste as New

This function enables you to paste the content of the clipboard in the form of a new document. The new 
canvas size depends on the size of the clipboard's content. To paste the content as a new document, 
open the Edit menu and click on the Paste as New command. A new image window containing the 
clipboard's content appears in the image editing area.

See also:

Cut

Copy

Paste



Clear

The Clear command deletes a selected portion of the image. This way of deleting is similar to that of the 
removing action of the Cut command, but with a major difference: the content deleted will not reside in the 
clipboard. In other words, you can't bring back the portion you deleted using the Clear command. To 
delete a portion of the image, do the following:

1. Select an area by dragging across the area with a selector from the Toolbox.

2. Open the Edit menu, and click on the Clear command. The deleted portion is then filled with 
background color.

Note:

You can also press the [Del] key on the keyboard to delete the selected portion.



Stroke

The Stroke function enables you to add outlines around the selected portion of image. The program will 
draw outlines along the selection frame using foreground color. You can select to draw outlines outside, 
inside or over the selection frame. To produce this effect:

1. Select a portion of image with selectors in the Toolbox.

2. Pick a foreground color in the color palette.

3. Open the Edit menu and select the Stroke command. A dialog box appears.

4. Set the thickness of the outlines to be added with the Stroke Size option. The effective values are 
from 1 to 20 pixels.

5. Set the Feather options by dragging the slider or entering the percentage directly.

6. Select the position of drawing the outlines inside the selection frame (Inside), outside the selection 
frame (Outside) or over the selection frame (Center).

7. Click on the [OK] button.



Crop

The Crop command enables you to cut out unwanted rectangular portions of image. If your selected area 
is not rectangular, the image canvas will be cropped to the smallest rectangle in the selected area. The 
image left is then rectangular. To crop a portion of image:

1. Select an area by dragging across the area with a selector in the Toolbox.

2. Open the Edit menu, and click on the Crop command. 

Note:

The Crop function can not be performed when you select a portion of image with feathering and make it 
floating.



Duplicate Document

The Duplicate Document function enables you to place into a new canvas but within the same image 
editing screen the reproduction of an existing image. When you execute the Duplicate Document 
command, a new canvas appears on screen containing the same image as that in the current active 
image editing window.



Save As Pattern

Presto! ImageFolio allows you to fill inside the selection frame with tiled images which in view is similar to 
filling with patterns of user-defined images. The pattern used to fill the area can be defined by saving a 
selected portion of image as a pattern file or placing the image on the clipboard.

The Save As Pattern command can save the selected portion on an image as a pattern file used to fill. 
You may save the image as any accepted file format in one of the category folders under the \Pattern 
sub-directory of ImageFolio’s program directory.



Define Pattern

Presto! ImageFolio allows you to fill inside the selection frame with a single color of tiled images which in 
view is similar to filling with patterns of user-defined images. The Define Pattern is used to specify the 
color or image pattern you want to fill.

To define filled pattern:

1. Select the Define Pattern command from the Edit menu. The Define Pattern dialog box appears.

2. In the Fill in Pattern Using section, select the color or image you want to fill in the selection frame.

The right box will display the color or image you have selected to use.

If you have picked a foreground or background color for filling in, choose the Foreground Color or 
Background Color option.

If you have placed the image to fill in onto the clipboard, choose the Clipboard Bitmap option.

If you have saved the image to fill in, choose the Pattern Bitmap option. When you click on the [Select 
Pattern] button below, the pattern files located in the \PATTERN sub-directory under the software’s 
program directory will be shown in a pop-up dialog box. You may also click on the [Change Directory] 
button to locate other image files for using as your pattern.

You may click on each tab to view different categories of patterns provided by the software. Select the 
pattern you want to use.

3. If you have chosen the Clipboard Bitmap or Pattern Bitmap option at last step, adjust the vertical and 
horizontal shifting length among the rows of tiled images by the Vertical Shift 50%, Horizontal Shift 
50% or None option in the Shift Control section. The percentage value indicates the shifting length 
versus the tile size of the pattern.

4. Click on the [OK] button to save the settings.



Fill In Pattern

The Fill In Pattern command allows you to fill inside the selection frame with a single color or tiled images 
which in view is similar to filling with patterns of user-defined images.

1. Select a portion of image with selectors in the Toolbox.

2. Specify the color or pattern you want to use in the Define Pattern dialog box.

3. Open the Edit menu and click on the Fill In Pattern command, or click on its icon on the tool bar.

See also:

Define Pattern



Magic Touch

The Magic Touch options supplies powerful functions for adding 3D effects and shadows to selected 
image portions in very simple steps, which makes your work much easier and more efficient.

3D Effect

Add Shadow



3D Effect

The software supplies magic touch for generating 3D effect on an object in the image by applying different 
directions of light and different levels of depth. This amazing function can be achieved by a single, simple 
step.

1. Select the object or portion of image you want to generate 3D effect.

2. Open the Edit menu and choose the 3D Effect option from the Magic Touch command, or click on the 
3D Effect icon on the tool bar. A dialog box appears.

3. Click on one of the nine direction buttons to set the direction that the source of light comes from.

4. In the Depth section, select the level of depth as High, Middle or Low, for the image to protrude from 
the canvas.

5. If you want to generate a depressed effect of the image instead of protruding from the canvas, enable 
the Invert option.

6. Click on [OK] to apply the effect.



Add Shadow

The software can produce the effect of projecting light on a selected object and make the shadow of the 
object fallen upon the background. As you can adjust the transparency and feathering levels of the 
shadow, it can reflect the distance of the light source by the lightness of the shadow.

Note:

The Add Shadow function is only available when there is a selected portion on the current active layer.

To add shadow to an image:

1. Select the object or portion of image you want to add shadow on the current active layer.

2. Open the Edit menu and choose the Add Shadow option from the Magic Touch command, or click on 
the Add Shadow icon on the tool bar. A dialog box appears.

3. Click on one of the nine direction buttons to set the direction that the source of light comes from.

4. In the Feathering section, select the level of feathering as High, Middle or None, for the shadow. The 
higher the feathering, the longer the distance of light source.

5. Click on [OK] to apply the effect.

The selected image will be moved to a new layer and the shadow will be generated on another new layer 
lower than the one containing the selected image. You can change the transparency of the shadow layer 
in the Layer Option dialog box. The more transparency you specify, the lighter the shadow, and the more 
distance from the light source.



Select Menu

The Select menu contains all the commands about the editing of selections.

Load Mask

Save Mask

All

Invert

None

Make Floating

Discard Floating

Copy Floating

While using one of the selectors or the tools that can generate selection outlines, you may click the right 
mouse button in the image window to invoke a pop-up menu for options on selection. These options 
include Invert, Discard Floating, Make Floating, etc. This function gives you more convenience on editing 
selections.



Load Mask

You can load a pre-defined mask for the usage of any image.

To load a mask:

1. Open the Select menu and select the Load Mask command. The Load Mask dialog box appears.

2. Select the mask you want to load and click on the [OK] button. The selected mask will be loaded in at 
the same location on the current image as the location it was originally saved at.



Save Mask

A selection frame can be saved with the MSK file extension for later usage on any image.

To save a mask:

1. Open the Select menu and select the Save Mask command. The Save Mask dialog box appears.

2. Select the directory you want the mask to be saved in and enter a filename for the mask. The mask 
file should be specified with a .MSK extension.

3. Click on the [OK] button.



All

The All command enables you to select an entire image. To do so, select All from the Select menu, or 
click on its icon on the tool bar.



Invert

A selected area is normally an area enclosed by a selection frame, and editing is usually done in the 
selected area. But you can also invert the selection, which means to have a selected area outside of the 
selection frame and edit that area outside of the frame.

To invert the selection:

1. Use a selector to select a portion of the image.

2. Select None from the Select menu, or click on its icon on the tool bar.

Click again to reverse the selection back to the enclosed area inside the outline(s).



None

Before having made any change to a selected portion, you can abandon the selection by using the None 
command. After having made changes to a selected portion, you can also use the None command to fix 
the floating image on canvas.

To abandon the selection you can also simply click on the Select None icon on the tool bar, click the left 
mouse button outside of the selection, or make another selection elsewhere in the image editing window.



Make Floating

The Floating feature allows you to work on a selected portion of image without affecting the original 
image. You can move and edit the selected portion, then merge it back onto the original image.

Make Floating makes your selection a floating image for further editing. The canvas beneath the floating 
image will be filled with the background color.

Note:

The software automatically makes the selected portion of image floating as long as you move or edit the 
selected image.



Discard Floating

The Floating feature allows you to work on a selected portion of image without affecting the original 
image. You can move and edit the selected portion, then paste it back onto the original image.

To discard the changes you have made to a selected portion, use the Discard Floating command to 
remove the floating selection.



Copy Floating

Copy Floating enables you to keep the floating image after you have fixed the selection on the canvas.

The shortcut for Copy Floating is to click and drag a floating image while pressing and holding the [Alt] 
key.

Note:

If you want to keep the original image and modify only the floating image, execute Copy Floating 
immediately after you make the selection before you make any change to the floating image or move it.



View Menu

The commands provided under the View menu are related to the display on the image editing screen or 
the information about the system and documents. They are:

Zoom In

Zoom Out

Actual Size

Fit in Window

Full Screen

Add a Vew

Layout

Information



Zoom In

This command enables you to obtain a magnified view of the image. Such function is convenient when 
you want to edit or enhance the image with precision at any ratio from 2 to 16 times of the image size. 
The same function is also provided by the Zoom tool in the Toolbox.

To zoom in, follow the steps below:

1. Open the View menu and click on Zoom In command. A list of ratio options appears to the right of the 
command name.

2. Select the ratio by which you want the image to be zoomed in.

Note:

A shorcut method to zoom in is to press the [+] key (magnifying by one level) on the keyboard. This 
method can be utilized at any time no matter which tool you are actually using.

See also:

Zoom

Zoom Out

Actual size

Fit in Window

Full Screen



Zoom Out

This command enables you to obtain a reduced view of the image. Such function is convenient when you 
want to edit or enhance the image as precision at any ratio from 1/2 to 1/16 of the image size. The same 
function is also provided by the Zoom tool in the Toolbox.

To zoom out, note these steps:

1. Open the View menu and click on Zoom Out. A list of ratio options appears to the right of the 
command name.

2. Select the ratio by which you want the image to be zoomed out.

Note:

A shortcut method to zoom out is to press the [-] key (reducing by one level) on the keyboard. This 
method can be utilized at any time no matter which tool you are actually using.

See also:

Zoom

Zoom In

Actual Size

Fit in Window

Full Screen



Actual Size

Select this command to have an enlarged or reduced view of image restored to its original size.

See also:

Zoom

Zoom In

Zoom Out

Fit in Window

Full Screen



Fit in Window

Use the Fit in Window command under the View menu to display the entire image in the image window 
frame.

See also:

Zoom

Zoom In

Zoom Out

Actual Size

Full Screen



Full Screen

Use the Full Screen command to display the image in a full screen size. Press [Esc] to return to the 
editing screen.

See also:

Zoom

Zoom In

Zoom Out

Actual Size

Fit in Window



Add a View

You can use the Add a View command under the View menu to produce a copy of the image in order to 
view different size ratios of the image at the same time. When you edit any one of the different image 
ratios, the others will be changed at the same time.



Layout

Most palette windows on the screen can be hidden by the options in the Layout command.

Select the Layout option from the View menu. You can hide or show any palette window on the pop-up 
list, including Toolbox, Toolbar, Palette Control, Tool Control, etc. When a check mark appears at the left 
of the option name, that palette window is displayed.

When you have made necessary modifications on the screen layout, you can save it for your usual 
usage. At the lower part of the Layout pop-up option, Layout 1 and 2 are the default screen layouts 
defined by the software. Use the Save as My Layout to save the current screen layout as your own 
layout. You can select My Layout option to change the screen to the layout you defined anytime.

See also:

Changing the Screen Layout



Information

The Information command under the View menu provides information about the current active image and 
system status.

Clicking on either the command or its icon brings up a dialog box with Document and System tabs. Click 
on either tab to view the related information.

With the Document tab activated, the right and bottom of the small sample image show the image 
dimensions. The Unit pull-down list allows you to change the measure unit for the image dimensions. The 
[Previous] and [Next] buttons allow you to view the previous and next document information.

The system information illustrates the information about the CPU, disk and Windows.



Process Menu

The options in the Process menu are designed to fine tune images or enhance them through special 
effects. Scanned or captured images usually need post-processing to make them look more natural and 
real. The Process menu contains the following commands:

Brightness/Contrast

Hue/Saturation

Tone Map

Density Control

Variations

Effect Browser

Photo Fun

Plugin Filters

Smooth

Sharpen

Emboss

Texturize

Average

Fragment

Mosaic

Others



Brightness/Contrast

The Brightness/Contrast command is used to change the brightness and contrast of the image pixels, 
much as the brightness/contrast controls work on a monitor by increasing or decreasing the brightness 
and contrast levels between pixels. To alter the brightness/contrast level of the image, invoke the Set 
Brightness and Contrast dialog box:

1. Open the Process menu and click on the Brightness/Contrast command. The Set Brightness and 
Contrast dialog box appears.

2. Select a Channel option for processing, either Red, Green, Blue, or All.

3. Enter a value in the Brightness and Contrast text boxes, or drag the sliders to set a value.

4. The Sample image changes accordingly as you drag the sliders or enter the values. You can compare 
the Sample image to the Original to clearly identify your adjustment.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

5. Click on the [OK] button to effect the change.

Note:

You can restore the original settings by clicking on anywhere of the gray area in the Original image.



Hue/Saturation

The Hue/Saturation command is used to change the hue and saturation of the image’s colors. To alter the 
hue/saturation of the image, do as instructed below:

1. Open the Process menu and click on the Hue/Saturation command. The Set Hue and Saturation 
dialog box appears.

2. Enter a value in the Hue and Saturation text boxes, or drag the sliders to set the values.

The Hue setting measures the color attributes in degrees from -180 to 180 according to the HLS color 
wheel. The color sequence on the HLS wheel is counter-clockwise from the red to the purple colors of 
the rainbow. Notice that the hue changes when you move the slider.

The saturation of colors is specified by percentages. Negative percentages decrease the intensity of 
color pixels in the image. Setting the saturation to -100% causes the image color to change to pure 
gray. Positive percentages increase the intensity of color pixels in the image so as to enhance the 
purity of colors.

3. The Sample image changes accordingly as you drag the sliders or enter the values. You can compare 
the Sample image to the Original to clearly identify your adjustment.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

4. Click on the [OK] button to effect the change.

Note:

You can restore the original settings by clicking on anywhere of the gray area in the Original image.



Tone Map

The Tone Map command is used to alter the brightness value of each pixel in the image by directly 
changing the mapping curve of gray/color values.

The horizontal axis represents the input’s brightness level and the vertical axis represents the output’s 
brightness level. “0" represents pure black, and ”255" pure white. To adjust the mapping:

1. Choose the Tone Map command from the Process menu. The Color/Gray Map dialog box appears.

2. Select a Channel option for processing, either Red, Green, Blue, or All.

3. Choose a way to adjust the map from the Method options.

If you choose the Gamma option, you can enter a gamma value in the Gamma text box. Enter a 
higher value to lighten the midtone area or enter a lower value to darken the midtone area. The shape 
of the mapping curve will change according to your settings.

If you choose the Linear option, the default gamma value is 1.0. The image will retain its original 
outlook.

If you choose the User Defined option, select the way to change the mapping curve as smooth curve 
or free shape from the two small illustrations. When the smooth curve is selected, several nodes will 
appear on the mapping curve. You may drag the nodes to form the desired shape of the curve. When 
the free shape is selected, point to anywhere on the mapping curve and drag it to form the shape 
corresponding to the image outlook you want. Changing the slope of the line adjusts the contrast; 
changing the level of the line adjusts the brightness.

4. The Sample image changes accordingly as you modify the shape of the mapping curve or enter the 
values. You can compare the Sample image to the Original to clearly identify your adjustment.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

5. Click on the [OK] button to start the process.

Note:

You can restore the original settings by clicking on anywhere of the gray area in the Original image.



Density Control

The Density Control command is used to sharpen dull images or tone down overly sharp ones by 
redistributing the gray shades in them. This function enables you to enhance contrast and adjust 
brightness levels by limiting the input and output ranges of gray/color values in the image. In effect, 
highlighted, shadowed and midtone areas in the image will be enhanced. In other words, it calculates the 
histogram of the image.

The horizontal axis of the histogram represents the gray/color value in the image, and the vertical axis 
represents the number of pixels corresponding to that value. The input range refers to the range of 
gray/color values in the original image, and the output range refers to that after adjusting the image 
settings.

To adjust the density of image, follow these steps:

1. Choose the Density Control command from the Process menu. A Density Control dialog box appears.

2. Select a Channel option for processing, either Red, Green, Blue, or All.

3. Drag the triangular sliders to select the input and output ranges.

To increase the contrast and bring out the details of the image, you can decrease the input range. The 
pixels to the left of the left input slider will be black, or mapped to the lowest value of the output range; 
the pixels to the right of the right input slider will then be white, or mapped to the highest value of the 
output range.

On the other hand, you can reduce the output range to decrease contrast and lighten the shadowed 
areas, or darken the highlighted areas. Drag the left slider to the right for decreasing contrast and 
lightening the shadowed areas, or drag the right one to the left for decreasing contrast and darkening 
the highlighted areas.

4. The Sample image changes accordingly as you drag the sliders or enter the values. You can compare 
the Sample image to the Original to clearly identify your adjustment.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

5. You may click on the [Auto] button to have the software adjust the density automatically.

6. Click on the [OK] button to effect the change.

Note:

You can restore the original settings by clicking on anywhere of the gray area in the Original image.



Variations

The Variations dialog box provides you with a preview mode to adjust dark, midtone and light areas of an 
image in hue, saturation, or brightness/contrast. It enables your instant comparison between the original 
images and the result of changes you may make on it.

To use Variations:

1. Select the Variations command from the Process menu. The Variations dialog box appears.

In the left portion of the Variations window, you have nine image previews showing different effects of 
hue and brightness adjustments. Among them, Sample represents your current selection taken from 
the eight surrounding possibilities.

The six previews at the top and bottom of the Sample reflect the hue adjustments to the Sample 
image; the two previews at the left and right of the Sample show brightness adjustments.

On the right hand portion of the dialog box are two images: the left hand one is your current selection 
(same as the Sample image on the left portion of the box); on the right hand side is a copy of your 
original image. Placed side by side, they enable you to compare the effects of your adjustments in 
relation to the original.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

2. Drag the slider of the Finer and Coarser line to define the adjustment level as a slight or more 
pronounced adjustment.

Your setting will be immediately reflected on the left side previews.

3. Click on the preview (among the eight) which best satisfy your need. The selected preview will move 
into the Sample position, and the surrounding previews will change according to the new Sample.

Note:

You may recall the Original as the Sample image by clicking on anywhere of the gray area in the Original 
image.

4. The default setting for the area to be changed in the image is Full, which means changes to the whole 
image. If you want to change only the light, midtone, or dark area in the image, click to select the 
Highlights, Midtones, or Shadows option respectively.

5. If you want to change  the saturation of the image, click on the Saturation option. The left half of the 
dialog box then displays only three image previews: the Sample as well as the effects of lower (less) 
and higher (more) saturation. Use the same procedure as in Steps 2 and 3 to adjust the saturation of 
the image.

6. If you want to change the image’s brightness and contrast, click on the Bright/Contrast option. The 
three top image previews reflect the effects of enhancing contrast, and the three bottom ones the 
effects of reducing contrast. The three left image previews reflect the effects of decreasing brightness, 
and the three right ones the effects of increasing brightness. Use the same procedure as in Steps 2 
and 3 to adjust the brightness/contrast of the image.

7. After you obtain a satisfying Sample, click on the [OK] button to start the process of adjustment, or 
click on [Cancel] to abandon the process.



Effect Browser

The Effect Browser dialog box offers an overview of image alternations processed with all the provided 
special effects under the Process menu. You can observe the different effects of the image, modify the 
processing factors, and select the one you need to start the real process to the image.

To view the effects:

1. Select the Effect Browser command from the Process menu. The Effect Browser dialog box pops up.

The left half of the dialog box is lined with the image previews processed by different effects. Each 
effect name is illustrated under its corresponding image preview. You may move the scroll bar below 
to go through all the image previews.

The right half of the dialog box contains the original and sample images. The sample image refers to 
the image preview that is currently selected.

The Sample image can be zoomed in or out for comparison to the original. Click once on the [+] 
button to zoom in the image by one level; or click on the [-] button to zoom out the image by one level.

The rectangle frame displayed in the Original image marked out the current portion of the image 
shown in the Sample area. You can drag the frame in the original image, or directly drag the mouse 
pointer in the sample image to pan the view in the Sample area.

2. Click on the image preview of the effect you want.

3. If you want to change the options for the effect, click on the [Option] button under the Sample image. 
The dialog box related to the chosen effect, same as the one when you invoke the effect directly from 
the Process menu, will appear for your modification.

4. Click on [OK] to start the process.



Photo Fun

The Photo Fun dialog box provides several pre-defined templates for your usage, such as photo frames, 
calendars, greeting cards, etc. The sketch or format of these templates is pre-defined and fixed. You can 
add your favorite image into the template and make your own work.

To apply this effect:

1. Open the image you want to add to a template.

2. Select Photo Fun from the Process menu. The Photo Fun dialog box appears.

3. Go through the tabs of categories and choose the template you want to use for your image.

4. Click on [OK] to start the process.

Related Topic:

Producing a Template for Photo Fun



Plug-in Filters

This software supplies an interface for utilizing third-party plug-ins which are software programs providing 
special effect filters. If you want to use plug-ins effects, you should set the path of the plug-in programs in 
the Adobe Plug-in Path option of Preferences dialog box (all the plug-in programs should be kept in one 
directory). The software will search for all the plug-ins and add them into the Plug-in Filters option under 
Process menu next time you restart it.



Smooth

The Smooth command allows you to soften an image by four options: Smooth, Smooth More, Smooth 
Edge and Gaussian Blur.

Choose Smooth to slightly soften the image. If you want to make the image look even softer, choose 
Smooth More. The Smooth Edge option only softens the edges of objects in the image.

The Gaussian Blur option softens the image like the gradual color fading out of the distance from the light 
source. It produces an effect as if the image were out of focus of eyes. To apply this effect, you have to 
set the smoothing level in the pop-up dialog box.

Drag the slider to specify the number of pixels for Radius. The number of pixels reflects the smoothing 
level of the image; the more the pixels, the softer the image.



Sharpen

In order to improve its clarity, the Sharpen command allows you sharpen an image by four options: 
Sharpen, Sharpen More, Sharpen Edge and Unsharp Mask.

The Sharpen option makes the image only a little clearer. The Sharpen More option sharpens the image 
even further. The Sharpen Edge option only sharpens the edges of objects in the image.

The Unsharp Mask option sharpens the area where the colors among neighboring pixels in the image 
have sound difference. When you execute this command, the software will calculate the color values of 
the pixels in the image and find out the part of image with sound difference of neighboring pixels, then 
sharpen both edges of the neighboring colors and smooth the other portion of image. The viewing effect 
is like bringing a hazy image into focus and showing the edges clearly of all the objects. There are three 
factors you should specify for applying this effect.

The Amount slider sets the sharpening level for the edges that should be enhanced. The Radius slider 
specifies the smoothing level that the other portion of image should be softened. The Threshold option 
specifies the levels of color difference where the edges should be sharpened; that is, only the area with 
the color difference higher than the specified threshold level should be sharpened. The higher the 
threshold level, the less edges in the image should be sharpened.



Emboss

The Emboss filter enables you to make the image stand out from the paper surface or stand in relief 
against its background. The emboss process coats the image with mostly foreground color on the surface 
of objects, and with midtone colors from the originals for object outlines.

You can set the direction and depth for the emboss effect for your images. Also, you may coat on the 
surface of objects in the image with any color by selecting it as foreground color.

To utilize this effect:

1. Choose a foreground color for coating on the emboss surface in the image.

2. Select the Emboss command from the Process menu. The following dialog box appears.

3. In the Direction option click on one of the eight arrow buttons matching the emboss direction you 
want.

4. In the Depth section select the depth of emboss as High, Middle or Low.

5. Click on the [OK] button.



Texturize

This command coats the canvas surface by a specified texture pattern, which produces an outlook for the 
image as if it were made up with that specific material. The foreground color you select will be applied to 
the texture pattern.

Various texture pattern files are provided with several categories in the \TEXTURE sub-directory of the 
software’s program directory, such as stones, cloths, water waves, sands, etc. You can generate your 
own texture pattern by creating the pattern, saving it as a bitmap file, and then placing it in one of the 
category folders under the \TEXTURE sub-directory.

To apply a texture to the image:

1. Use the selectors in the Toolbox to outline the portion of image you want to apply a texture. If there is 
no such selection, the texture will be applied to the whole canvas.

2. Select the foreground color you want to use with the texture pattern.

3. Select the Texturize command from the Process menu. The Load Texture dialog box appears.

4. Choose a texture pattern from the thumbnail previews.

If your texture file is not stored in the \TEXTURE sub-directory, click the [Change Directory] button to 
locate the right path.

5. When you have selected the texture pattern you need, click on the [OK] button to apply the texture.



Average

The Average command averages the values of each pixel and its surrounding pixels in an image to 
generate the new values of the image colors. This will produce a vague image.

To apply this function:

1. Click on Average in the Process menu. The Average dialog box appears.

2. Set the pixel block size for calculating the new values of image colors by dragging the Size slider. For 
example, if you select 5x5, for each pixel in the image, the new value will be the average from the 
values of itself and its 24 surrounding pixels (totally 25 pixels).

3. Click on [OK] to start the process.



Fragment

When executing the Fragment function, the software will move the image in up, down, left and right 
directions to generate four temporary images, and then overlap the four images with certain level of 
transparency to produce a special effect. In view the final image looks like a photograph seriously out of 
focus.

To apply this effect:

1. Open the Process menu and select Fragment. A Fragment dialog box appears.

2. Select the distance for moving the image in four directions. The higher the value, the more obvious 
the effect.

3. Click on [OK] to start the process.



Mosaic

The Mosaic command is used to display an image as a series of mosaic tiles. The colors of the tiles are 
averaged with the original image colors and according to the tile size selected. To achieve this effect:

1. Open the Process menu and click on the Mosaic command. The Mosaic dialog box appears.

2. Select the tile size you want by dragging the slider.

3. Click on [OK] to start the process.



Others

The Others option in the Process menu contains several special image processing effects.

Add Noise

Despeckle

Diffuse

Find Edge

Tiles

Trace Contour

Solarize



Add Noise

The Add Noise command can randomly generate color pixels in different levels of brightness of the 
original colors in the image, which in view looks like the noise generated by TV screens.

To generate this effect:

1. Select the Add Noise option of Others command from the Process menu. The Add Noise dialog box 
appears.

2. Drag the slider in the Frequency option to set the density for generating color pixels on the image. 
The higher the frequency, the more density the color pixels.

3. In the Intensity option set the level of brightness for the generated color pixels compared to the 
original colors in the image.

If you set the intensity between 0 and 50, the color pixels generated will be lighter than the original 
colors; while setting the intensity between 0 and -50, the color pixels will be darker.

4. Click on the [OK] button.



Despeckle

The Despeckle command automatically clears the small speckles on the image. It will only clear a single 
pixel with great contrast in relation to its surrounding color pixels in order to avoid accidental erasing of 
the real image.



Diffuse

The Diffuse command blurs the image by diffusing its colors. The blurred image looks like an image seen 
through a plane water surface.



Find Edge

The Find Edge command is used to automatically find and display the edges of the objects on the image 
canvas with white or gray shades on a gray-scaled image, and with the original colors of the areas at the 
side of the edges of the image on an RGB color image.



Tiles

This command can cut an image into small square pieces and rearrange them to form the image. In view 
the effect is more like a jigsaw puzzle fitted by square pieces.

To utilize this function:

1. Open the Process menu and select Tiles option of Others command. The following dialog box 
appears.

2. In the Size of Tiles option set the dimension of the square pieces fitting the image in a range of 4x4 to 
50x50 pixels.

3. Set the range of width among the pieces measured by the percentage of the tile size in the Maximum 
Offset option.

4. Select the background under the image pieces as Foreground Color, Background Color, Unaltered 
Image (the original image) or Inverted Image.

5. Click on the [OK] button.



Trace Contour

The Trace Contour filter converts images into a bi-level format in which image outlines are clearly marked. 
For a gray-scaled image, the outlines contain only black and white pixels; and for an RGB color image, 
they contain up to eight colors (black, white, red, green, blue, cyan, magenta, and yellow).

This command is specially useful when you need to find the edges of the objects in an image and repaint 
its objects with different colors.

To utilize the function:

1. Open the Process menu and select Trace Contour option of Others command. The following dialog 
box appears.

2. In the Level option drag the slider to set the difference between the values of any two neighboring 
colors in the image. While tracing image outlines, only when the difference of  two neighboring colors 
reaches the specified level can the border between them be traced.

3. Selecting the Upper or Lower option decides the color and position of the image outline between 
neighboring colors. If you check the Upper option, the outlines will be traced with the colors of higher 
values between neighboring colors; if you check the Lower option however, the outlines will be traced 
with the colors of lower values.

4. Click on the [OK] button.



Solarize

Applying the Solarize function makes an image look like a over-exposed photograph.

Click on the command name to start the function.



Transform Menu

The commands under the Transform menu are used to flip, rotate, or convert either the whole image or a 
selected portion of the image. Generally speaking, these commands transform the position, size, or colors 
of an image without changing its shape and pattern.

The Transform menu contains the following options:

Invert

Mirror

Rotate

Rescale Image

Change Image

Expand Canvas



Invert

The Invert command reverses the brightness and color of an image. Click on the Invert command to 
invert. Click again to get back the original image.



Mirror

The Mirror command flips the image vertically, horizontally, or diagonally. When you select this command, 
three options for mirroring directions, vertical, horizontal, and diagonal, pop up at the right of the 
command for your selection.



Rotate

The Rotate command rotates the image in three options. Whenever you click on the Rotate command, a 
sub-menu pops up for your selection:

The Left option rotates the image by 90 degree counter-clockwise.

The Right option rotates the image by 90 degree clockwise.

The Any Degree option allows you to rotate at any angle the selected portion of an image or the entire 
image. To execute this:

1. Click on Any Degree. A dialog box appears.

2. Click on the clockwise (CW) or counter-clockwise (CCW) option for the rotating direction.

3. Enter the rotation angle.

4. Click on the [OK] button to start rotating the image.



Rescale Image

The Rescale function allows you to change the size, resolution, and scaling factors for part of, or the 
entire image. You can easily enlarge or shrink an image proportionally or with proportion distortion.

1. Select the Rescale Image command from the Transform menu. The Rescale dialog box appears.

The Source Image field displays the original size and resolution of the image.

2. You can set the scaling ratio by entering its size in the Target Image section or by entering the X 
(horizontal ratio) and Y (vertical ratio) values in the Rescale Factor. You can also specify the scaling 
ratio by dragging the pointer in the scroll bars between the 10% and 1000% values indicated.

If you have enabled the Keep Ratio option, you can enter either the width or the height of the rescaled 
image. The software will automatically determine the other value for you.

If you have disabled the Keep Ratio option, you have to enter both the width and height to rescale the 
image. If the values you enter are not proportional, the rescaled image will be distorted.

3. Enter the horizontal and vertical resolutions of printing in the Resolution text boxes.

4. Click on [OK] to start rescaling the image, or [Cancel] to abandon the process.



Change Image

The Change Image function allows you to convert the image canvas format. To convert an image:

1. Choose the Change Image command from the Transform menu, or click on its icon in the tool bar. 
The Change Image Type dialog box appears.

2. Select a Target Type option which corresponds to the image conversion you want.

Note:

Dimmed options are not applicable to the active image.

3. Click on the [Set Convert] button to specify a converting method.

Approach:

This option converts original colors from the picture to the approaching ones within the system's 
indexed color palette.

Adaptive:

This option calculates the color pixel values and determines the most suitable colors for the image.

Diffused:

This option averages the bright and dark color pixels on the image.

Dithering:

This option converts the image using different patterns and sizes to generate special effects. Both the 
Dithering Pattern options and Pattern Size options allow you to execute conversions with different 
pattern and size.

4. If you want to use a new canvas for the converted image, enable the Create a New Image option.

5. Click on the [OK] button to complete the conversion.



Expand Canvas

The Expand Canvas function in the Transform menu lets you increase the size of canvas without 
influencing the image size. You can set the image position on the canvas after the expansion.

To expand the canvas:

1. Select Expand Canvas from the Transform menu. A dialog box appears.

2. The Source Image field displays the current image size. Set the canvas size you want to expand in 
the Target Image option.

3. In the Source Image Offset section, use the values of X, Y axes or the nine direction buttons to set the 
position of the original image on the expanded canvas.

You can also move the mouse pointer into the preview window at left and drag the black rectangle to 
set the position of the original image.

4. Click the [OK] button to expand the canvas.



Window Menu

The commands in the Window menu enable you to manage all of the image windows on screen when you 
have loaded multiple image files.

Cascade

Tile

Arrange Icon

Close All

Quick Close



Cascade

While several documents are opened on screen, you may select the way they are shown under the 
Window menu.

The Cascade command arranges the image windows in a diagonally overlapping pattern.

To select this command, open the Window menu and click on the command name.



Tile

While several documents are opened on screen, you may select the way they are shown under the 
Window menu.

The Tile command arranges the image windows so that all of the windows can be seen at once.

To select this command, open the Window menu and click on the command name.



Arrange Icons

If any of the simultaneously opened documents temporarily does not need editing, it is recommended to 
minimize it into a small title bar containing the file name of the image. It can be placed at the bottom of the 
image editing area by clicking on the Minimize button at the upper right corner of the image window.

The Arrange Icons command arranges the small title bars evenly across the bottom of the windows.

To restore an image, double click on its title bar, click on the Maximize button, or open the Window menu 
and click on its file name listed at the lower part of the Window menu.



Close All

To close all the documents on the screen at the same time, select the Close All command under the 
Window menu. If any of the documents modified has not yet been saved, a dialog box will pop up to 
prompt you to save it. Click on the [Yes] button to save the image; or click on the [No] button to ignore the 
image modification.



Quick Close

If you are sure that all desired modifications to the images have been saved, you can close all the 
documents by the Quick Close command instead of Close All. The software will then not prompt you for 
any unsaved processing of the images.



Help Menu

Besides the messages shown on the status bar, click on the Help menu for more information on any of 
the tools, commands and dialog boxes.

In the software, move the pointer on any menu, command or icon and press [F1] to invoke a simple help 
message about the item.



Tools

The upper row of the Toolbox contains six selectors for selecting a portion of image to edit without 
affecting other portions of the image.

Painting tools are located in the other part of the Toolbox. To select a tool, simply click on it.

Before using the tools for editing, you can set their respective Tool Control options. These options vary 
according to the tool selected.

Selectors

Tools

Tool Control Options



Selectors

The tools used to select images, called selectors, are provided in the Toolbox. These powerful selection 
tools enables you to outline any irregularities on the objects in the images.

To further add a portion to the portion of image you just previously selected, press and hold the [Shift] key 
while selecting the area of the image with the selectors.

To exclude a portion from your previous selection, press and hold the [Ctrl] key while selecting the area to 
be excluded with the selectors.

To abandon the selection altogether, do one of the following:

* Click the left mouse button outside of the selection frame when the Rectangle or Ellipse Selector is 
active.

* Choose the None command from the Select menu, or click on its icon on the tool bar.

To move a selected portion of the image:

1. Move the mouse pointer inside the selected area.

2. Click and drag the selection to the desired location.

3. Release the mouse button.

The Toolbox contains the following selectors:

      Rectangle Selector  

      Ellipse Selector  

      Free-hand Selector  

      Path Selector  

      Magic Wand  

      Selector Brush  

      Move Tool  



Tools

Painting tools are used to add drawings, change colors or reform the image. To select a tool, simply click 
on it.

      Rectangle  

      Ellipse  

      Line  

      Curve  

      Paint Bucket  

      Gradation  

      Paintbrush  

      Airbrush  

      Text  

      Text Along Path  

      Stamp  

      Image Hose  

      Texture Brush  

      Eraser  

      Eyedropper  

      Pan  

      Zoom  

      Blur/Sharpen Brush  

      Brightness/Darkness Brush  

      Hue/Saturation Brush  

      Smudge  

      Free-hand Rescale  



      Free-hand Rotate  

      Slant  



Rectangle

This tool is used to create rectangles or squares. You may choose the starting point of the rectangle at 
any of its corners or its center. To draw a rectangle:

1. Click on the Rectangle tool. If it is not displayed in the Toolbox, click on the Ellipse, Curve or Line tool 
while pressing and holding the [Alt] key to find it.

2. Set the size, pattern and style in the Tool Control options.

3. Move the mouse pointer to the selected starting point (one of its corners or its center) of the rectangle 
to be drawn.

4. Press and hold the left mouse button if you are starting from one of the corners. If you are starting 
from the center, hold down the [Alt] key with the left mouse button.

5. Drag the pointer diagonally to the opposite corner of the rectangle. A rectangle appears.

6. Release the mouse button.

To draw a square, hold down the [Shift] key while dragging the mouse.



Ellipse

You use this tool to draw ellipses or circles. The program allows you to start drawing an ellipse from any 
point on its rim or its center. To create an ellipse, follow these steps:

1. Click on the Ellipse tool. If it is not displayed in the Toolbox, click on the Rectangle, Curve or Line tool 
while pressing and holding the [Alt] key to find it.

2. Set the size, pattern and style in the Tool Control options. If you enable the Anti-alias option, the 
edges of the generated ellipse will automatically be smoothed.

3. Move your mouse pointer to the starting point of the ellipse to be drawn (any point of its rim or its 
center).

4. Press and hold the left mouse button if you are starting from its rim. If you are starting from the center, 
hold down the [Alt] key with the left mouse button.

5. Drag the pointer diagonally to the opposite point on the rim. An ellipse appears.

6. Release the mouse button.

To draw a perfect circle, hold down the [Shift] key while dragging the mouse.



Line

Use the Line tool to draw straight lines. To draw a straight line:

1. Click on the Line tool. If it is not displayed in the Toolbox, click on the Rectangle, Curve or Ellipse tool 
while pressing and holding the [Alt] key to find it.

2. Set the size and pattern for drawing in the Tool Control options. If you enable the Anti-alias option, the 
edges of the generated line will automatically be straightened.

3. Point to where you want to begin drawing.

4. Press and hold the left mouse button.

5. Drag the pointer to draw a line.

6. Release the mouse button.

Holding the [Shift] key while drawing the line produces a horizontal, vertical or 45 degree slanted line.



Curve

This tool allows you to draw a bezier curve by setting two nodes and four control points: the nodes locate 
at both ends and the control points are extended from the nodes for helping you to adjust the height and 
slope of the curve. The location of the nodes and control points can be adjusted until you are satisfied 
with the shape and position of the curve.

To draw with the Curve tool:

1. Click on the Curve tool. If it is not displayed in the Toolbox, click on the Rectangle, Ellipse or Line tool 
while pressing and holding the [Alt] key to find it.

2. Set the Tool Control options.

3. Place the mouse pointer to where you want to start drawing your curve.

4. Click the left mouse button to set the beginning of the curve. Do not release the mouse button.

5. Drag the mouse pointer in the direction you want the curve drawn. As you drag, two control points 
appear and move in opposite directions from the node. The distance between the control points and 
the node determines the height or depth of the curve. The angle of the control points determines the 
curve’s slope.

6. When the control points are in the desired position, release the mouse button.

7. Repeat step 4 to set the other end of the first curve segment you want to create. A second node 
appears and connected to the first.

8. Drag to generate two control points for this node.

9. Release the mouse button. You may drag the nodes and control points to adjust the shape of your 
curve segment.

If you did not drag from the nodes to generate control points in previous steps, you may hold the 
[Shift] key and drag from the nodes to create control points anytime.

10. Click and drag the pointer outside the nodes and control points to form another adjacent segment of 
curve linking with the first one. Repeat steps 7 through 9 to complete all the segments in the curve 
you want to create.

Before fixing the curve segments, you can click on any node to activate the control points of the curve 
segment connected and adjust the curve.

To remove the last node generated, hold the [Ctrl] key and click the left mouse button.

If you want to create a closed area with the curve segments, hold [Shift] and click the right mouse 
button to generate a new segment connecting from the last node to the first one.

11. When you are satisfied with the shape of your curve, click the right mouse button to fix the curve.

Note:

If you did not drag to generate control points for the nodes, the drawing will become a straight line. Hence 
you can use this tool to produce adjacent segments of straight lines.



Paint Bucket

The Paint Bucket enables you to fill a selected enclosed portion of image with a color you choose. It fills a 
selected area with the foreground color according to the calculated range of the original color pixel. When 
you click on a single pixel of that color with the bucket cursor, the program takes this pixel as the standard 
to calculate the color value and to decide which other pixels to fill with your new color.

To use the Paint Bucket:

1. Click on the Paint Bucket tool.

2. Set the color range for calculating and the filling pattern in Tool Control options.

The Range option sets the surface range of an area of given color to be filled with another color. The 
filling range is decided by a color pixel from the image as well as by the tint you set for the color you 
select as replacement color. The effective value of filling range is from 1 to 255.

3. Move the pointer to the portion you selected.

4. Click on the left mouse button to fill the area with the foreground color.

Note that if the area you want to fill is not completely enclosed, the paint bucket color will “leak” and fill 
the surrounding area with that same color (or a certain range of it).



Gradation

This tool enables you to create a gradual transition from the foreground color to the background color, or 
color gradation of multiple colors with linear, radial or square shape.

You can select multiple colors to create a “rainbow” color gradation. In the Tool Control options, you can 
select the direction of gradation as linear, radial or square.

Moreover, you can generate lighting effect on the image with this tool. In effect, it looks like putting a light 
source at any point on the image and the light spreading with different levels of brightness along the 
cursor path.

To create a color gradation, do as follows:

1. Use the selectors to outline the area you want the gradient colors generated. If there is no such 
selection made, the program will generate a gradation of colors for the whole canvas.

2. Select the Gradation tool.

3. Bring up the Tool Control window if it is not shown.

4. In Tool Control window, select an option for gradient colors by pulling down the Options list. The “Fg & 
Bg” option generates a gradual transition from the foreground color to the background color. The 
“Multicolor” option uses all the colors you choose in sequence to create the color gradation.

5. Set the color transition manner as RGB or HUE by the Mode pull-down list.

The RGB option changes the colors according to the colors you specified. The HUE option generates 
the gradation according to the color sequence from the foreground to background colors on the HLS 
color wheel: HUE- option creates color transition in clockwise sequence; and HUE+ option creates 
color transition in counterclockwise sequence on the color wheel.

You can create a “rainbow” color gradation by using the HUE mode.

6. Select the colors you want to use for generating color gradation.

If you have selected “Fg & Bg” option, select the foreground and background colors.

If you have selected “Multicolor,” move the pointer inside the selection frame and click the right 
mouse button. A dialog box appears for selecting colors used to create the gradation.

The Choose pull-down list includes several pre-defined gradation manners for your application. If you 
want to define your own color gradation, select User Defined.

In this dialog box, the spectrum and primary palette are displayed for selecting colors. The Color color 
box shows the selected color each time you pick a color from the spectrum or primary palette. If the 
color you want to choose is not shown in the palette, you can type in the values of RGB or HLS 
channels to specify the color. 

The colors in the Start and End color boxes are automatically loaded from the foreground and 
background colors in default. You can change the foreground and background colors by dragging 
colors into the start and end color boxes.

Click and drag the selected color to the color strip at the middle of the dialog box. The colors you pick 
will be placed where you drag and release the mouse button. A color flag will appear on the top of the 
color strip to identify the exact location of the color. These flags can be dragged in the range of the 
length above the color strip. If you drag a flag out of the range, that color will be removed from the 
color strip. The colors in the Color, Start and End color boxes can be dragged everywhere into the 
color strip. The color gradation will be generated as you select the colors.

You can preview the color gradation generated by each kind of transition manners with the RGB, 
HUE+ and HUE- options in the Mode section. The setting here is identical with the Mode setting in the 



Tool Control window.

If you want to make the space equal among the selected colors on the color strip, click on the 
[Equalize] button to rearrange the position of colors.

After you are satisfied with the color gradation in the color strip, you can save it with the GRD file 
extension by clicking the [Save] button and you can recall the gradation later with the [Load] button.

Click on [OK] when you have finished working on the colors.

7. Select the shape of gradation as linear, radial or square from the Shape pull-down list.

A linear gradation changes color in one direction as specified by the cursor path, while a radial 
gradation changes color in concentric circles from the center outwards according to the cursor path. A 
square gradation changes color in concentric squares from the center outwards according to the 
cursor path.

8. Move the mouse pointer to where you want to start the gradation.

9. Press and hold the left mouse button.

10. Drag the mouse pointer to the ending point of gradation.

11. Release the mouse button.

To generate lighting effect:

1. Use the selectors to outline the area you want the lighting effect generated. If there is no such 
selection made, the program will make lighting for the whole canvas.

2. Select the Gradation tool.

3. Bring up the Tool Control window if it is not shown.

4. In Tool Control window, select the Lighting option by pulling down the Options list.

5. Select the foreground and background colors you want to use to generate the gradation of brightness.

The program uses the changes of gray levels between the foreground and background colors to 
generate the gradation of brightness.

6. Select the shape of lighting as linear, radial or square from the Shape pull-down list.

A linear lighting generates gradation of brightness in one direction as specified by the cursor path, 
while a radial lighting generates gradation of brightness in concentric circles from the center outwards 
according to the cursor path. A square lighting generates gradation of brightness in concentric 
squares from the center outwards according to the cursor path.

7. Move the mouse pointer to where you want to put the light source.

8. Press and hold the left mouse button.

9. Drag the mouse pointer to the ending point of lighting.

10. Release the mouse button.



Paintbrush

This tool allows you to draw lines free-handily as if you were drawing with a real paintbrush.

To draw with the paintbrush:

1. Click on the Paintbrush tool.

2. Set the Tool Control options for the Paintbrush.

Specify the size, feathering and shape of the paintbrush. With the Line tab active, you can set the 
spacing between efficient painting points and select the style of the line.

3. Place the mouse pointer to the point you want to start tracing your line.

4. Press and hold the left mouse button to paint with the foreground color, or the right mouse button to 
paint with the background color.

5. Drag the mouse pointer along the line path you want. The line appears along the cursor path as you 
drag.

6. Release the mouse button where you want the line to end.



Airbrush

The airbrush produces a shading effect on the image by spraying color pixels on the image, conveying to 
it an impression of depth. The sprayed color is gradually applied towards the edges of the picture so as to 
make the sprayed color blend in with the surrounding colors’ pixels. In other words, the density of 
sprayed pixels decreases from the middle of the image to its edges. To use the airbrush:

1. Click on the Airbrush tool.

2. Set the Tool Control options for the Airbrush tool.

The Spacing option determines the space between the sprayed points while you are dragging the 
mouse.

The Pressure option influences the density and thickness of the drawn line. Use this option to specify 
the heaviness of coverage by a selected color. The pressure range is from 10% to 100%; the higher 
the pressure the heavier the coverage with that color.

With the Style tab active, you can select, from the Option list box, the shading effect produced by the 
Airbrush tool. The Spatter option generates splashed color pixels, and the Fatting option produces 
smooth gradations of foreground color from the middle of line toward the edge.

3. Drag the pointer across the image to airbrush. Use the left mouse button to drag for applying the 
foreground color, and the right mouse button for applying the background color.

The speed at which you drag the pointer will affect the spray’s appearance.

4. Release the mouse button.



Text

You can enter text anywhere on an image with the Text tool. The software supports all the fonts installed 
in Windows 95.

The Text tool provides options for selecting fonts, font styles, and character sizes. After inputting text, you 
can reshape it by changing the dimensions of the text.

To enter the text:

1. Click on the Text tool. If it is not displayed in the Toolbox, click on the Text Along Path tool while 
pressing and holding the [Alt] key to find it.

2. Bring up the Tool Control options if it is not displayed on screen.

3. Click on the down arrow in Envelop list box to display a list of envelope shapes and select the one 
you want to use.

If none of the envelopes in the list are similar to the text shape you need, you may select  
(freehand reshaping) to define your own envelope.

If you do not need to apply an envelop for the text, select the  option.

4. In the Control option, choose Envelop for retaining the shape of the envelop you have selected or 
Control for reforming the text shape freely when you will further adjust the text shape later.

5. If you enable the Anti-alias option, the outline of the text characters will automatically be smoothed.

6. Move the cursor to where you want the text to start and click. A Font dialog box appears.

7. Select the font, the font style, and the character size. The Sample box will display an example of the 
selection you made.

8. In the Effects window, select whether you want the text to be stroked or underlined.

9. If you want the text character to be placed vertically, enable the Portrait option.

10. Enter the text in the Text box.

11. Click on [OK] to input the text.

12. A rectangle with eight square nodes around the text appears on the canvas. Drag the nodes to 
change the shape and size of the text.

If you have selected Control in step 4, four nodes will be displayed on the corners of the rectangle, 
each with two control points (which will appear when you click on any of the nodes), for your further 
adjustment of the text shape. Use the hand pointer to drag the nodes and control points, and form 
your text envelope.

Note:

Hold the [Shift] key while dragging the nodes on the corners to resize the rectangle as square; hold the 
[Ctrl] key while dragging the nodes on the corners to change the shape of the rectangle. If you are in 
Control mode, you can not use the [Ctrl] key after you have irregularly changed the shape of the 
envelope.

13. If you have selected freehand reshaping, after you have completed adjusting the text shape, you can 
save the envelope for later usage. Select Envelop tab from the Tool Control options and click on 
[Save Envelop]. The envelop is saved with ELP file extension. You may recall the envelop later with 
the [Load Envelop] button when you select freehand reshaping.

14. Click the right mouse button to fix the text shape.



Note:

The added text will be automatically outlined for further edition. After you finish, abandon the selection to 
fix the text.



Text Along Path

This tool allows you to insert text on the image and place the text along a defined curve path. To complete 
this effect, you must define a curve path and adjust the text position along the path.

To generate text along path:

1. Click on the Text Along Path tool. If it is not displayed in the Toolbox, click on the Text tool while 
pressing and holding the [Alt] key to find it.

2. Bring up the Tool Control options if it is not displayed on screen.

3. Click at the point you want to start the text in the image to enter the text as you would do when using 
the Text tool.

4. With the Option tab active, enable the Phantom option to display the text reference frame while 
adjusting the path and position.

5. Drag the StartPos slider to set the starting position of the first text character along the path.

6. Drag the Spacing slider to set the spacing between text characters.

7. Activate the Text tab.

8. From the Orientation list box, select the text to be placed vertically (upright) or rotated according to 
the curve path.

9. From the Alignment list box, select the text to be aligned with the curve path by the top, bottom or 
baseline of the text.

10. If you enable the Anti-alias option, the outline of the text characters will automatically be smoothed.

11. Define the curve path as you would do when using the Curve tool.

12. Before clicking the right mouse button, you can adjust the text position and path by changing the 
shape of the curve path or modifying the settings in the Tool Control options. With the Option tab 
active, click on the [Text] button to modify the text if it is necessary.

13. Click the right mouse button to complete the process.

Note:

The added text will be automatically outlined for further edition. After you finish, abandon the selection to 
fix the text.



Stamp

The Stamp tool has two different functions: one is like a stamp which copies (stamps) a portion of image 
to another area you specify on the image with your cursor, and the other is the cloning feature which can 
trace an image or part of an image on the same or another canvas with specified shape, transparency 
and feathering options.

The clone function can create different effects with one image, combine several pieces of images into 
one, and generate tiled pattern from an image.

To use the stamp:

1. Click on the Stamp tool.

2. Select the Mode tab in the Tool Control window.

3. Select to use the Stamp or Clone function from the Mode option.

To apply the Stamp function:

1. Select the Option tab in Tool Control and set the size of the stamp to copy the image by the Size 
option.

2. Set the shape and feather value you want for the stamp.

3. Move the cursor to the selected area you want to copy.

4. Hold the [Shift] key and click. The stamp has picked up a copy of the image selection.

5. Move the pointer to anywhere on the canvas you want to stamp, and click.

To apply the Clone function:

1. Select the Option tab and set the size used for each movement of cloning by the Size option.

2. Set the shape and feather value you want.

Different sizes and shapes generate different effects of an image.

3. To use the Clone function to trace one copy of the image, activate the Mode tab and select Single in 
the Source option. If you want to generate tiled pattern with the image, select Tile in this option.

Note:

The image used for tiled pattern is usually only a small portion of the image. Before proceeding on to the 
next step, you should first select the portion of image used for tiled pattern.

4. Move the cursor to the starting point on the source image you want to trace.

5. Hold the [Shift] key and click.

6. Move the cursor to the destination canvas where you want to start tracing the image.

7. Click and drag the mouse to trace the image until the image appears in the area you want to fill. A “+” 
sign keeps moving in the source image while you are moving the mouse, which illustrates the current 
position in the source image being traced.



Image Hose

This tool sprays a series of pre-defined images along your cursor path, like water (the images) flowing out 
of a hose (the mouse cursor). This function can easily fill the canvas with a set of images in sequence or 
randomly to achieve a special art design.

Five sets of images are provided with this tool. You can also define your own sets of images to replace 
the default ones.

To apply the Image Hose:

1. Select the Image Hose tool.

2. Choose a set of pre-defined images from the Source pull-down list in the Tool Control options.

If you want to define your own set of images, read the instructions below.

3. Select Linear, Random or Fixedness in the Direction option to spray the set of images in sequence, 
randomly or fixed on the first grid.

4. Move the mouse pointer to where you want to start spraying the images.

5. Click and drag the mouse to paint the images on the canvas.

If you do not want the sprayed images overlapped with each other, hold down the [Shift] key while 
dragging the mouse.

6. Release the mouse button.

Related Topic:

Defining Image Hose



Texture Brush

This tool coats the canvas surface by a specified texture pattern along the cursor path, which produces 
an  outlook for the image as if the canvas were made up with that specific material. The foreground color 
you select will be applied to the texture pattern.

Various texture pattern files are provided in the \PENBRUSH sub-directory of the ImageFolio program 
directory, such as stones, cloths, water waves, sands, etc. You can generate your own texture pattern by 
creating the pattern as a bitmap file before using this tool.

To apply a texture with Texture Brush:

1. Select the Texture Brush tool.

2. Set the size, shape and feathering options in the Tool Control window.

3. Select the foreground color you want to use with the texture pattern.

4. Move the pointer into the image and click the right mouse button. The Select Texture dialog box 
appears.

5. Choose a texture pattern you want. If you want to use a pattern defined by yourself, click on the 
[Change Directory] button to locate the pattern file.

6. When you have selected the texture pattern you need, click on the [OK] button to close the dialog 
box.

7. Move the mouse pointer to where you want to start applying the texture.

8. Click and drag the mouse to paint the texture on the canvas.

9. Release the mouse button.



Eyedropper

The eyedropper picks up the color from a pixel in the image. This means that even though you may not 
be sure of which color it corresponds to on your palette, you can still select the exact color you want in the 
image.

To pick a color, select the Eyedropper tool from the Toolbox and click on the color you want to pick from 
the image (click the left button to pick foreground color, and right button background color).



Eraser

This tool erases all the pixels it passes on except for those of the background color. That is, it paints the 
portion of image along the cursor path with background color. Because you can set the transparency of 
erasing, the image can look as if blurred while the cursor passes through it. To use the Eraser:

1. Click on the Eraser tool.

2. Bring up the Tool Control options if it is not displayed currently.

3. Set the eraser size for processing. If you want to erase foreground color only, select Fg. Color in 
Options; if not, select All Colors instead.

4. Move the pointer to the image.

5. Press and hold the left mouse button as you drag it over any part of the image you want to use the 
eraser on.

6. Release the mouse button.



Pan

This tool enables you to move an image within its own canvas. If the actual image is larger than the 
canvas, and you want to edit some part of it that is unseen on screen because of the limits set by the 
canvas, Pan allows you to bring into editing view any of the unseen parts. Using Pan is similar to using 
the scroll bars except that you can move your image horizontally and vertically simultaneously within the 
canvas. To use the Pan:

1. Click on the Pan tool. If it is not displayed in the Toolbox, click on the Zoom tool while pressing and 
holding the [Alt] key to find it.

2. Place the mouse pointer on the image.

3. Press and hold the mouse as you drag the image until you can see the portion of image you want to 
edit.

4. Release the mouse button.



Zoom

This tool enables you to obtain a magnified or a reduced view of the image. Such function is convenient 
when you want to edit or enhance the image with precision at any ratio from 16 times to 1/16 of the image 
size.

To magnify or reduce the image with the Zoom tool, do the following:

1. Click on the Zoom tool.

2. Move the mouse cursor to the position you want to zoom in on the image canvas.

3. Click the left mouse button to magnify the image; hold the [Ctrl] key and click to reduce the image.

4. Click the right mouse button to view the image in its original size.

You may also magnify a specific portion of the image in the canvas for precision editing. This is useful 
when you want to concentrate your editing on certain objects without viewing other parts of the image 
canvas. To do this, move your mouse cursor to the starting point of the specific portion selected to be 
magnified, hold the [Shift] key, drag the mouse pointer over the portion, and release the mouse button 
when you have dragged to the ending point of the portion.

Note:

A shorcut method to zoom in and out is to press the [+] (magnifying by one level) or [-] (reducing by one 
level) key on the keyboard. This method can be utilized at any time no matter which tool you are actually 
using.

Related Topics:

Zoom In

Zoom Out

Actual Size

Fit in Window

Full Screen



Blur/Sharpen Brush

The Blur/Sharpen Brush enables you to create a blurred or sharp visual effect on the image along the 
cursor path, by decreasing or increasing the color contrast values of abutting pixels.

To blur or sharpen the image:

1. Click on the Blur/Sharpen Brush tool. If it is not displayed in the Toolbox, click on the 
Brightness/Darkness Brush or Hue/Saturation Brush tool while pressing and holding the [Alt] key to 
find it.

2. Set the size and shape in the Tool Control options.

3. Move the mouse pointer to the starting point of the area to blur or sharpen.

4. Hold and drag the mouse button: the left button to blur and the right one to sharpen the image.

5. Release the mouse button.



Brightness/Darkness Brush

The Brightness/Darkness Brush enables you to brighten or darken the image along the cursor path.

To use this tool:

1. Click on the Brightness/Darkness Brush tool. If it is not displayed in the Toolbox, click on the 
Blur/Sharpen Brush or Hue/Saturation Brush tool while pressing and holding the [Alt] key to find it.

2. Set the size and shape in the Tool Control options.

3. Move the mouse cursor to the starting point of the area to be brightened or darkened.

4. Hold and drag the mouse button: the left button to brighten and the right one to darken the image.

5. Release the mouse button.



Hue/Saturation Brush

This tool paints on your image using translucent shades of a color you choose. The original shape of the 
image is not affected. Only the color along the cursor path is replaced with the selected shade of color. 
The effect produced is that you will see the image as if through a piece of color tinted glass.

If you change only the hue of the image, some color shades of the original image are retained. If you 
change the saturation at the same time, full saturation of the selected color can also be achieved.

To paint with the Hue/Saturation Brush:

1. Click on the Hue/Saturation Brush tool. If it is not displayed in the Toolbox, click on the 
Brightness/Darkness Brush or Blur/Sharpen Brush tool while pressing and holding the [Alt] key to find 
it.

2. Invoke the Tool Control options if it is not displayed on screen.

3. Set the size and shape for the brush. If you need to change the saturation, select Hue & Sat in Mode 
Option; if not, select Hue Only instead.

4. Move your mouse pointer to the starting point of painting.

5. Click and drag the mouse over the painting path.

6. Release the mouse button.



Smudge

The Smudge tool is used to randomly mix pixels in an area. It works like an artist who mixes colors with 
chalk or pastels. It can add a textured look to a picture.

To use the Smudge tool:

1. Select the Smudge tool.

2. Set the size, shape and spacing for the tool in the Tool Control options.

The Spacing option determines the mixing level of smudging.

3. Move the mouse pointer to where you want to start smudging.

4. Click and drag the mouse to smudge the canvas.

5. Release the mouse button.



Free-hand Rescale

This tool enables you to magnify or reduce the dimensions of a selected area on the image. Before using 
this function, you must first select a specific area for processing. To rescale a portion of the image:

1. Select the portion of image you want to rescale with the selectors.

2. Click on the Free-hand Rescale tool. If it is not displayed in the Toolbox, click on the Free-hand Rotate 
tool while pressing and holding the [Alt] key to find it.

A rectangle with eight small square nodes on its corners and at the middle of its sides appears around 
the selected area.

3. Use the mouse to drag a node from any of the corners to magnify or reduce the selected area. Or 
drag a node on any side of the rectangle to rescale the image horizontally or vertically: a node from 
the top or bottom side to rescale vertically, and a node from the left or right side to rescale 
horizontally.

You can proportionally rescale the selected image by pressing and holding the [Shift] key while 
dragging the nodes on the corners of the rectangle around the selection outline.

4. Release the mouse button.

Related Topic:

Rescale Image



Free-hand Rotate

This tool allows you to rotate a selected portion of image to any angle. To rotate the image:

1. Select the portion in the image to be rotated with the selectors.

2. Click on the Free-hand Rotate tool. If it is not displayed in the Toolbox, click on the Free-hand Rescale 
tool while pressing and holding the [Alt] key to find it.

Four square nodes appear on the four corners of the rectangular area containing the selected portion.

3. Move the mouse pointer to any of the nodes.

4. Click and drag the node to rotate the image.

Hold the [Shift] key while dragging the node to rotate the image in 45-degree increments.

The status bar displays the rotating degree when you are dragging the nodes.

5. Release the mouse button.



Slant

This tool distorts the image of a selected portion by extending it to a parallelogram, a trapezoid,  a 
perspective view or an irregular shape (freehand distortion).

To use the Slant tool:

1. Select the portion of image you want to apply the Slant tool.

2. Click on the Slant icon. A rectangle with four small square nodes on its corners appears around the 
selected area.

3. Select the shape you want to change the image as parallelogram, perspective, trapezoid or freehand 
distortion in the Tool Control options.

4. Drag the nodes on the rectangle to set the shape.

If you have selected to change the image as parallel, you may drag the nodes horizontally or vertically 
but must in the same direction. Once you have dragged the first node horizontally, you can only drag 
all the nodes horizontally later except that you restart the tool (select another tool and then re-select 
this tool), and vice versa.

If you have selected to change the image as perspective, trapezoid or freehand  distortion, you can 
not drag a node out of the range exceeding its opposite sides.

5. Release the mouse button.



Tool Control Options

The Tool Control options determine how a tool behaves. For example, you may want to change the 
thickness of the line when drawing a rectangle with the Rectangle tool.

Choose the Tool Control option from the Layout command under the View menu to bring up or hide the 
Tool Control options.

The Tool Control options vary for different tools. The window may contain the following common options:

Size

Shape

Feather

Style

Pattern

Spacing



Size

The Size option is used to specify the line width or the size of the selected tool. The size range is from 1 
to 100; the higher the value the larger the size. Drag the slider to set the size.



Shape

This option offers several types of shapes for the selected painting tool. For example, you can choose a 
round or a square paintbrush to paint an image. Click on the pop up list box and select a shape for the 
tool you are going to use.

When you are using the Stamp tool, the Shape option determines the shape of the stamp as square or 
circular.



Feather

The Feather option allows you to soften the covering effect of the edges of your tools by bending their 
edge color into the background. This option ranges from level 1 to 15. Drag the slider to increase the 
setting and soften the edges of the tool, or to decrease the setting and sharpen its edges.

By the Feather control, you may select the image with its edge blurred and diffused into the background 
color so as to produce a feeling of depth between the selected image and its canvas. Drag the slider to 
set the level of feathering by percentage before defining the selection frame by the selection tools.



Style

This option allows you to draw hollow or solid color rectangles and ellipses. Click on the pop up list box 
and select a style for the tool you are going to use.



Pattern

The software offers several tool effects or patterns to apply to graphics. Click on the pop up list box and 
select a pattern for your tool.



Spacing

The Spacing option specifies the space between every two contiguous efficient painting points of a tool 
along the cursor path. When you set the spacing as 1, the painted drawing will be generated repeatedly 
along the cursor path without interruption. The larger the spacing specified, the less can the tool paint 
within the same length of path, and the more the distance between every two efficient painting points.



Rectangle Selector

This selector allows you to make a rectangular selection of a portion of image. You may choose to make 
the selection from any of the corners or the center. To select a rectangular portion:

1. Click on the Rectangle Selector. If it is not displayed in the Toolbox, click on the Ellipse Selector while 
pressing and holding the [Alt] key to find it.

2. Move the mouse pointer to the selected starting point (one of its corners or its center) of the rectangle 
for making selection.

3. Press and hold the left mouse button if you are starting from one of the corners. If you are starting 
from the center, hold down the [Alt] key with the left mouse button.

4. Drag the pointer diagonally to the opposite corner of the area you want to capture as rectangle.

5. Release the mouse button. The selected portion of image appears in a rectangular frame.

To select a square portion, press and hold the [Shift] key while dragging the mouse.



Ellipse Selector

This selector allows you to select an elliptical portion of image for editing. You can start to make the 
selection from any point on its rim or its center. To select an elliptical portion:

1. Click on the Ellipse Selector. If it is not displayed currently, clicking on the Rectangle Selector icon 
while holding the [Alt] key changes the icon into the Ellipse Selector.

2. Move your mouse pointer to the starting point of the ellipse for making selection (any point of its rim or 
its center).

3. Press and hold the left mouse button if you are starting from its rim. If you are starting from the center, 
hold down the [Alt] key with the left mouse button.

4. Drag the pointer diagonally starting from one chosen point to form an elliptical frame around the area 
you want to capture.

5. Release the mouse button at the opposite point of your diagonal trace.

To select a circular portion, hold down the [Shift] key while dragging the mouse.



Free-hand Selector

This selector allows you to select an irregularly shaped portion manually anywhere on the image. You can 
use it to select an object with irregular or sharp edges. To select an irregular portion:

1. Click on the Free-hand Selector.

2. Move the pointer to the beginning of the irregular edge.

3. Click and hold the left mouse button.

4. Drag the pointer along the edge to select.

5. When you reach the starting point of a sharp part of the edge, release the mouse button. As you 
move the mouse, a straight line appears and stretches out following your movement to capture the 
sharp part of the edge.

6. Move the pointer to the end of the sharp side and click.

7. Keep on selecting using the same procedure until the entire object has been selected.

8. Double click to finish the selection.



Path Selector

The Path Selector defines the selection outline by framing an enclosed area on the image with curve or 
line segments. The operating method is similar with that of the Curve tool. The difference is that the Curve 
tool draws real curves and the Path Selector only draws selection outlines.

To define a selection outline with the Path Selector:

1. Click on the Path Selector.

2. Place the mouse pointer to where you want to start defining your curve.

3. Click the left mouse button to set the beginning of the curve. Do not release the mouse button.

4. Drag the mouse pointer in the direction you want the curve generated. As you drag, two control points 
appear and move in opposite directions from the node. The distance between the control points and 
the node determines the height or depth of the curve. The angle of the control points determines the 
curve’s slope.

5. When the control points are in the desired position, release the mouse button.

6. Repeat step 3 to set the other end of the first curve segment you want to create. A second node 
appears and connected to the first.

7. Drag to generate two control points for this node.

8. Release the mouse button. You may drag the nodes and control points to adjust the shape of your 
curve segment.

If you did not drag from the nodes to generate control points in previous steps, you may hold the 
[Shift] key and drag from the nodes to create control points anytime.

9. Click and drag the pointer outside the nodes and control points to form another adjacent segment of 
curve linking with the first one. Repeat steps 6 through 8 to complete all the segments in the curve 
you want to create.

Before fixing the curve segments, you can click on any node to activate the control points of the curve 
segment connected and adjust the curve.

To remove the last node generated, hold the [Ctrl] key and click the left mouse button.

10. When you are satisfied with the shape of your curve, click the right mouse button to create an 
enclosed selection frame with the curve segments. A new segment is generated connecting from the 
last node to the first one.

Note:

If you did not drag to generate control points for the nodes, the drawing will become a straight line. Hence 
you can use this tool to produce selection frames composed of adjacent segments of straight lines.



Magic Wand

This tool automatically defines the outline of the area to be selected according to a specific color range 
set by the user. It selects a portion of image from the color pixels or from the color definition of that image 
portion. This function is useful for quick selection of an area of same color, or of an area which falls within 
a specific color range set by the user.

1. Click on the Magic Wand icon.

2. Set the options in the Tool Control window.

The Range option is specially designed to set the range of a selected color. If the color range is set to 
1, the magic wand will only select from the image the color pixels exactly the same as the one you 
picked for the tool’s effect. When you set a higher value in Range (maximum of 255), the selector will 
also affect different tints in the area selected according to the color pixels that correspond to your 
settings. This is very useful when you want to select for editing an area with different tints of the same 
color.

3. Click on the color to use in defining the selection of an area of the image.



Move Tool

After a selection is defined, this tool allows you to move the selected image or selection outline to other 
parts of an image or another canvas. In a multi-layer image, it can be used to rapidly activate the layer 
containing the object clicked by the user.

To use the Move tool:

1. Click on the Move icon.

2. Move the mouse pointer into the selected frame. The shape of the mouse pointer changes to a four-
arrowed cross.

3. Move the selected image or selection frame.

If you want to move the selected image, press and hold the left mouse button.

If you want to move the selection frame, hold down the [Alt] key while pressing the left mouse button.

4. Drag the selected image or selection frame to a new location.

If you drag it out of the canvas, the selected image or selection frame will be moved to another 
canvas or a new one, depending on where you drop it.

5. Release the mouse button.

In a multi-layer image, you can click on any object to activate the layer while holding the [Ctrl] key. Please 
refer to the Layer Management chapter for details.



Selector Brush

This tool works like a free-hand brush and defines enclosed selections according to the width and shape 
the brush is set at. It thus enables you to define the enclosure’s outlines. To draw an enclosed frame with 
the brush set at the required width, follow these steps:

1. Click on the Selector Brush icon.

2. Set the brush size (its width will define the width of the frame you will select) and shape from the Tool 
Control options.

3. Move the mouse pointer to the point you want to start selecting a portion of image with the brush.

4. Press and hold the left mouse button as you move the mouse pointer to draw your selection of an 
image portion with the activated brush.

Press the [Ctrl] key with the left mouse button while going over the same area if you want to deselect 
the area just drawn.

Note:

If a selection has been made before you want to further add a selected area with the Selector Brush, start 
drawing outside the original selection frame, or the selected portion will be moved.

5. Release the mouse button.



Palette Control

Each image canvas has its own color palette. For each new image canvas, a color palette corresponding 
to the image type you select is generated. This is the default color palette for your image canvas.

The default color palette for the current active image canvas is generated according to the image type 
you specified in the New dialog box. For example, if you selected the image type "Index 256-Color", a 
color palette containing 256 colors is attributed to the image canvas; or if you selected "24-Bit True Color", 
your color palette contains 16.7 million colors.

The Palette Control window has three different working modes: Native, Appendix and Edit modes. 
Different modes of Palette Control are illustrated with different outlooks for enhanced functions.

Foreground/Background Color

The foreground and background colors are selected from the color palette with the color picker or set by 
the color channel sliders.

In the color palette, click on a color from the color palette with the left mouse button to select a foreground 
color and the right button to select a background.

The software can memorize three foreground and background colors that were previous selected by the 
user. You may hold the [Alt] key and click inside the foreground or background color box to recall the 
previous selected colors by sequence.

Clicking on the Swap arrows exchanges the foreground and background colors. If you want to use black 
and white as foreground and background colors, click on the Black & White button.



Native Palette
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Palette Control in Native Mode

When you select the Native command in the Palette Control menu, the Palette Control switches into 
Native mode.

In the Native Palette area, you have three methods for selecting foreground and background colors: by 
using a universal color spectrum, a user-defined palette, or the color channel setting sliders. You can 
toggle among the three by clicking on the toggle switch.

The universal color spectrum contains all the colors existing in the natural world.

The user-defined palette should be produced by yourself. It could contain all the colors you like to use 
most. You may define several different palettes for different usage and save them as palette files. When 
you need to use any of the palettes, load the palette into the user-defined palette area by the command in 
the Palette Control menu. Once you have loaded a palette, the software will automatically remember the 
palette and display it each time you invoke the software unless you load another palette.

The color channel setting sliders enable you to set the value of each color channel (like the hue, lightness 
and saturation in HLS mode) to compose a color that can not be clearly identified in the palette. This is 
useful if you need to paint with a specific color of which you know the color channel composition. Drag the 
sliders directly to make the setting.



Palette Control in Appendix Mode

When you select the Appendix command in the Palette Control menu, the Palette Control switches into 
Appendix mode.

The Appendix Palette area contains three types of palettes for selection of colors: the HLS color table, the 
primary palette of the active image, and the loaded bitmap. You can toggle among the three by clicking on 
the toggle switch.

The HLS color table displays the hue, lightness and saturation of the colors. First select the hue of the 
color by dragging the triangular slider under the hue bar below. Then click the right color in the color table 
according to the lightness and saturation of the color.

The primary palette refers to the default color palette of the current active image. If the active image is a 
true-color one, a system-defined 256-color palette will be loaded here.

The number of display columns in the primary palette can be changed by clicking the right mouse button 
in the gray area of the Palette Control window and selecting the Alternative Primary Columns option from 
the pop-up menu.

The loaded bitmap is an image that you have loaded by the Load Bitmap command of the Palette Control 
menu.

Selecting Colors from Loaded Bitmap

The loaded bitmap contains colors you want to use for the current image. Even though you may not be 
sure of which color it corresponds to on your palette, you can still select the exact color you want in the 
image.

If the loaded image is larger than the displayed window, you can bring other parts of the image into view 
by dragging inside the window while pressing and holding the [Shift] key.

Select colors from the bitmap by clicking the left or right mouse button for foreground or background color.



Palette Control in Edit Mode

Not only can you select colors to paint on your image canvas from the color palettes through the Palette 
Control, but you can also change the color composition on the palette through the Palette Control 
commands and create a secondary color palette for other canvas usage.

To edit a customized palette, you select colors from all the available palettes and use the scratch pad for 
creating a new palette. Select the Edit command from the Palette Control menu.

The user-defined palette of the Native Palette is enlarged for the usage of a scratch pad. The color grids 
in the scratch pad can be changed in size (so as to change the number of columns at the same time). 
Click the right mouse button in the gray area of the Palette Control window and select the Alternative 
Secondary Columns option from the pop-up menu.

The palette in the scratch pad is independent of the current canvas type. You may pick colors from any of 
the available palettes to display in the scratch pad; load colors from palette files; or get the colors you use 
most in the primary palette to produce a secondary palette in the scratch pad.



Palette Control Menu

When you click on the Menu button in the Palette Control window, a list of commands for palette control 
pops up for your selection.

RGB/HLS Color Modes

The RGB/HLS command is used to toggle between RGB and HLS color modes. When the current color 
mode is HLS, selecting the RGB command changes the color mode to RGB, and the command itself is 
changed to “HLS.” The color channels in the Native Palette area change according to the setting here.

Working Modes

The two commands, Native and Appendix, reflect the viewing modes of the Palette Control respectively. 
Selecting any of the commands changes the Palette Control to its corresponding view.

Load

The Load command allows you to load a palette from a file previously saved with .PAL extension to the 
scratch pad.

Save

The Save command saves the palette in the scratch pad with the required use of a filename with a .PAL 
extension.

Retrieve

The Retrieve command loads all the colors from the primary palette into the scratch pad.

Append

The Append command appends colors from a .PAL file into the scratch pad starting from the next empty 
color grid in the scratch pad.

Sort by Hue or Light

The Sort command can rearrange the color order in the scratch pad by the sequence of colors in the HLS 
color wheel (the Hue option) or by color tint, from lightest to darkest (the Light option).

Gradient

The Gradient command can create a gradation of colors between foreground and background colors in 
the scratch pad. First select a blocked area containing the grids to hold the generated gradient colors in 
the scratch pad, then select this command to create a gradation of colors from foreground to background 
colors in the blocked area.

Realize

The Realize command applies a whole scratch pad palette as your primary palette. In Black & White 
mode, this command is ineffective. In other modes, the Set Convert dialog box will appear, and you can 
then select a way to convert the image’s color scheme. If you select the Pseudo Color option, the 
software will use the color grid of the new palette for color conversions of your image, in accordance with 
the color positions in the grid of the old palette. In 24-bit true color mode, this function works by reducing 
palette colors according to the colors in new palette. A new 256-color canvas with the converted image 
will be generated after color reduction.

Most Used

This command gets the colors used most in the current canvas into the scratch pad. In 24-bit true color 
mode, the software will get the 256 colors used most in the canvas. In color modes other than 24-bit true 



color, this function produces the same effect as the Retrieve command.

Loaded Bitmap

The Load Bitmap command allows you to load an image and select colors from it. When you are in the 
Native mode, the loaded image is not displayed. You can see the loaded image and select colors from it 
in the Appendix or Edit mode.

Hide

The Hide command functions the same as the Palette Control command in the Layout options under the 
View menu. Choosing this command hides the palette control window from the screen. To bring back the 
palette control window, pressing [F5] is the easiest way.



Layer Manager

To manage multi-layer images, you need the Layer Manager provided in the software. To invoke the Layer 
Manager, open the View menu and select the Layer Manager option from the Layout pop-up menu, or 
press the [F10] key.

The background of the canvas is always the lowest layer and shown at the very bottom of all the layers in 
the Layer Manager. The other layers are arranged from low to high by their overlapping order from back 
to front. The highlighted layer is currently selected.

The View column in the Layer Manager sets the display status of the layers. When an eye appears in the 
grid, the layer is displayed. Click in the grid to toggle the displaying of the layer.

The Group column indicates the grouping status of the layers. Clicking in any grid of the column groups 
the corresponding layer with the one currently selected.

The Mask column indicates the mask contained in a layer.

The Name column holds the name of a layer; and the Preview column displays a shrunken copy of the 
image on the layer. Because the shrunken image will continuously reflect the change while you are 
editing the image, the processing speed will become slower. If you want to speed up the processing, you 
may hide the Preview column by clicking the right mouse button inside the Layer Manager and disabling 
the Show Preview command in the pop-up menu.

When you click on the Layer Menu icon, a list of commands pops up for your selection of managing 
layers.

A layer can be selected by clicking on the Name or Preview column in the Layer Manager. When a layer 
is selected, the entire row of the layer is highlighted. All the editing and processing operations will be 
applied only on that layer, except that some of the commands are meant to apply to the whole image, 
such as Change Image, Expand Canvas, the commands under the View menu, Duplicate Document, etc.

While editing a selected layer, you can decide whether to view the other layers for convenience on 
editing.

Related Topics:

Multiple-layer Images

Layer Menu

Moving Objects on Grouped Layers

Drag-and-drop Mouse Operation in Layer Manager
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Multiple-layer Images

The software supports multiple layers in an image for complicated editing of multiple objects and masks 
composition.

Just imagine that the canvas of the image is the background of several transparent sheets with the same 
size of the canvas, each containing organized object(s). Through the part of the transparent sheets that 
has nothing or has objects with certain level of transparency, the background can be revealed. You can 
edit the object(s) on individual transparent sheet without affecting others. When you place the sheets 
together, the entire image is composed of all the objects on the transparent sheets though probably some 
part of the objects is not visible because of the overlapping objects on other sheets.

The pieces of transparent sheets are termed layers. A layer can hold both image and mask. The 
transparent level of a layer determines how the pixels on the layer mix with those of other layers and the 
background.

An image with multiple layers should be stored with the POF file extension in Presto! ImageFolio. Only the 
true-color or indexed 256 gray-scaled images can utilize the multi-layer function.

Layer and Mask

A mask can be applied to a layer for restricting the working range and the displayed area of the image on 
the layer. If no mask is applied by the user, the mask for the layer covers none of the pixels on the image, 
which means you can edit the whole canvas and display the entire image on the layer. This is the default 
mask setting for a new generated layer.

The mask used for a layer can be created as a gray-scaled image by the user or converted from a 
colored image. The area of black color in a gray-scaled image used as a mask completely reveals the 
image on a layer; the area of white color in the gray-scaled image entirely covers the pixels of the image 
on a layer; the area of different gray scales in the gray-scaled image reveals the image on a layer by 
different levels of transparency.



Layer Menu

When you click on the Layer Menu icon in the Layer Manager, the following commands pops up in the 
layer menu for managing the layers:

New

Paste as New Layer

Duplicate

Make Object to Layer

Delete

Make Layer to Mask

Copy Mask

Option

Interleave

Merge

Merge All



New

To add a blank layer into an image:

1. Select the layer that you want to add a blank layer upon.

2. Click on the New icon in the Layer Manager, or select the New command from the Layer menu.

3. When the Layer Option dialog box appears, make the necessary setting and click on [OK] to start the 
process.

Note:

If you have made a floating selection on any previous existing layer before executing the New command, 
the floating image will appear on the new generated layer for your further editing.



Paste as New Layer

If you have placed certain image on the clipboard, you may paste it on a new layer in the image. To paste 
as a new layer:

1. Make sure you have placed the desired image onto the clipboard. (You can refer to the Editing 
Images chapter for the methods of moving images onto the clipboard.)

2. Select the layer that you want to add a new layer upon.

3. Open the Layer menu and select the Paste as New Layer command.

The pasted image is aligned to the upper left corner of the layer. If the pasted image is larger than the 
canvas, the portion that exceeds the dimensions of the canvas will be lost.



Duplicate

The content of a layer can be duplicated to a new upper layer. After you select the Duplicate command 
from the Layer menu, a new layer containing the same content appears on the top of the selected layer. 
The name of the new layer will be automatically assigned as copy of the duplicated layer.



Make Object to Layer

After you have made a selection on an image and made it floating, you can move the selected object to a 
new layer on the top of the current layer.

1. Select the portion of image you want to move and make it floating.

2. Open the Layer menu and choose Make Object to Layer.

3. When the Layer Option dialog box appears, make the necessary setting and click on [OK] to start the 
process.

The selected image will appear on the new generated layer at the exact position it was placed on the 
previous layer.



Delete

If a layer is no longer needed, you should remove it to save memory and disk space.

1. Highlight the layer you want to delete.

2. Select the Delete command from the Layer menu.



Make Layer to Mask

After you have produced a layer with the image you want to use as mask, you can apply the image to the 
layer you need to generate mask. To generate a mask:

1. Select the layer with the image used as mask.

2. Choose the Make Layer to Mask command from the Layer menu. A dialog box appears.

3. Select the layer you want to apply the mask from the pull-down list.

4. Click on [OK] to transform the image into the mask of the specified layer.

If you have used a colored image for generating the mask, the software will automatically transform it into 
gray scales and then apply it as mask.



Copy Mask

The mask of a layer can be copied to other layers so that the transparency and restriction for displayed 
pixels are also applied to those layers.

1. Select the layer containing the mask you want to copy.

2. Choose the Copy Mask command from the Layer menu. A dialog box appears.

3. Select the layer you want to apply the same mask from the pull-down list.

4. Click on [OK] to copy the mask.



Option

Whenever you double click in the Preview or Name column of a layer, or select the Layer Option 
command from the Layer menu, the Layer Option dialog box pops up.

You can change the name of the layer in the Name text box. Drag the slider in the Transparency option to 
specify the transparency of the layer. The transparency setting decides the mixing level of the pixels in 
this layer with those in other layers.



Interleave

In a stereoscope, you can see a stereo image united by two photographs of an object, taken from slightly 
different angles, with the effect of depth and solidity. On a computer screen, the unity of two photographs 
composing a stereo image is achieved by the interleaved scanning of odd and even lines in the image.

To produce a stereo image, therefore you have to prepare two images of the same object or scene, taken 
from slightly different angles, then overlap them in different layers, and make their odd and even lines of 
pixels interleaved.

1. Place the two images used for a stereo image on two different layers of the same canvas.

2. Open the Layer menu and select Interleave command.

3. Use the Move tool to adjust the images to proper positions for composing the stereo image.

The odd lines of an image and the even lines of the other image will mix together to compose a stereo 
image. You can see the effect through a stereoscope.



Merge

After finished editing the images on multiple layers, you may combine some of the layers as one to save 
storage space if you are sure they will not be changed.

The Merge command in the Layer menu can combine the layers which are currently displayed and keep 
the hidden layers in the image. To merge some of the layers in an image:

1. Click in the grids of the View column to display all the layers you want to combine.

2. Select the Merge command from the Layer menu.

The merged layer will appear as the lowest layer you have selected to combine.



Merge All

If you are sure the images on all the layers will not be changed, you can merge all the layers into one and 
save the image with any file format.

The Merge All command in the Layer menu combines all the layers that are currently displayed and 
removes all the hidden layers. The result of the combination will become only one layer left in the image. 
To merge all the layers in an image:

1. Click in the grids of the View column to display all the layers you want to combine and hide those you 
want to remove.

2. Select the Merge All command from the Layer menu.

3. When a dialog box appears asking you whether to discard the hidden layers, answer [OK] to process 
or [Cancel] to abandon the combination.



Moving Objects on Grouped Layers

The objects located on several grouped layers can be moved at once to a different position or out of the 
canvas. This function should be executed by the Move tool in the Toolbox.

1. Click in the grid(s) of the Group column to group the selected layer(s) with the current active layer.

2. Select the Move tool in the Toolbox.

3. Move the mouse pointer into any of the objects on the grouped layers.

4. Drag the pointer to another position or out of the canvas.

If you drag the pointer to another canvas, the grouped layers will be duplicated to that canvas. If you 
drag the pointer to the empty space in the image editing area, a new canvas will be generated with 
the grouped layers.

5. Release the mouse button.

Moreover, you can use the Move tool to activate a layer by clicking on the object of the layer while holding 
the [Ctrl] key.



Drag-and-drop Mouse Operation in Layer Manager

Some of the commands in the Layer menu can be invoked by drag-and-drop operation in the Layer 
Manager window. The Mask, Preview and Name columns are usually the starting pointing of the drag-
and-drop operation.

Operation Function

Drag from the Preview or 
Name column to the Trash-can 
icon

Delete the layer

Drag from the Preview or 
Name column and drop on the 
top of the Preview or Name 
column of another layer

Move the former layer to the 
upper layer of the latter layer 
or combine the images on the 
two layers by calculation

Drag from the Preview or 
Name column and drop on the 
Mask column of another layer

Convert the image of the 
former layer to the mask of the 
latter layer

Drag from the Mask column 
and drop on the New icon

Convert the mask of the 
former layer to image of a new 
layer

Drag from the Mask column 
and drop on the Mask column 
of another layer

Copy the mask of the former 
layer to the latter layer or 
combine the two masks by 
calculation

Drag from the Preview or 
Name column and drop in the 
current image window

Duplicate the selected layer

Drag from the Preview or 
Name column and drop in 
another image window

Duplicate the selected layer to 
another image



Changing the Screen Layout

Most palette windows on the screen can be hidden, and their outlook or location can be changed easily. 
Therefore, you can compose your own screen that is most convenient for your work.

Most palette windows are docked in a specific gray area on the screen. You can move them within the 
gray area or drag it out to make it an independent window. Click and drag the left mouse button on the 
edge of a palette window to change its location. Drop the palette window in the gray area to move it inside 
the docked area. Drop the palette window in the image editing area to make it independent.

Clicking the right mouse button within the gray area of any palette window brings up a menu containing all 
the command options for hiding/displaying the on-screen palette windows in the Layout option of the View 
menu. The lower part of the pop-up menu varies depending on which palette window you have clicked in.

You can change the size, default or smaller size, of all the icons in the Toolbox and Tool Bar by clicking 
the right mouse button in their gray area and selecting the Large Icon option from the pop-up menu.

The icons in Toolbox and Tool Bar can be lined with different numbers of columns. Change the number of 
columns by clicking the right mouse button on the gray area in the Toolbox window and selecting the 
Alternative Columns option from the pop-up menu.



Drag-and-drop Mouse Operation Between Canvases

Utilizing the Windows drag-and-drop feature, the software allows you to move a portion of image to a new 
canvas or to other canvases without using the Cut, Copy, Paste and Paste as New commands. Steps to 
follow:

1. Select an image area by dragging across the area with a selector from the Toolbox.

2. Move the mouse pointer into the selected area.

3. Press and hold down the left mouse button.

4. Drag the mouse anywhere in the empty space outside of the image where you will create a new 
canvas; or drag the mouse to another image canvas to place the selected image into it. The pointer’s 
shape changes to a hand scratching a piece of paper.

5. Release the mouse button.

6. Make changes to the selection if necessary.

7. Click the left mouse button outside of the selection in the image window to fix the selection on the 
destination canvas.



Defining Image Hose

To use your own set of images for Image Hose, you must first create the set of images and then replace 
one of the default sources.

To define a set of images:

1. Create the set of images you want to use for Image Hose on a canvas as you would create and edit 
any image.

2. Place the series of images in grids and note the grid size (width and height) while arranging the 
images.

3. Use the Save As command in the File menu to save the canvas as you would for any image.

4. In the Source option, select a set of source to be defined with the saved images.

5. Click the right mouse button in the image window. A dialog box appears.

Whenever you want to replace a set of pre-defined source, you may arouse this dialog box while 
using the tool.

6. The upper left area of the dialog box displays the current image file and its size used for the image 
hose. Click on the [Select Image File] button at the middle right of the dialog box to select the file you 
have created before.

The selected image will appear in the preview window with default grid lines.

7. Set the grid size according to the width and height you noted on step 2 in the Width and Height 
options. The grid lines in the preview window changes according to your setting.

8. Enable or disable the Use Mask option.

When a mask is used, you should define a color and the color range (Mask Range) for producing the 
mask. The area of mask color in the image will become 100% transparent when you spray the images 
on the canvas.

If you want to use a mask, move the pointer into the preview window and click on the color you want 
to become transparent. The selected color is shown in the color box of Mask Color section.

9. Set the Valid Grid option to specify the image in grids valid for image hose. The valid source for using 
with image hose are the first few grids from the upper left to the lower right counting row by row 
specified in this option.

10. Click on the [OK] button.



Producing a Template for Photo Fun

Templates for Photo Fun are defined by multi-layer images. Therefore, it is easy for you to change the 
elements in a template or create a personal template with multiple layers.

To change some of the elements in a template, open the template file (*.POF) you want to change from 
the category folders in the Photofun sub-directory under the software’s program directory. You can 
change the image located on any layer in the template by the general editing procedure of multiple layers 
except the layer named “$PICTURE$” which would be applied with the image you want to combine with 
the template, so it should remain in the template.

To create a new template, generate a multi-layer image with one of the layers named “$PICTURE$” 
which is reserved for combining with another image. Then save the template with POF extension to one of 
the category folders in the Photofun sub-directory.



Converting Mask to Image

The mask of a layer can be converted to a gray-scaled image on a new layer. In this way you can modify 
the shape and transparency of a mask and then apply the new image to the layer again as mask.

To convert a mask to image:

1. Select the layer whose mask you want to convert.

2. Drag the Mask icon from the Mask column to the New icon in the Layer Manager.

A new layer containing the gray-scaled image converted from the mask appears on the top of the 
previous selected layer.



Combining Images and Masks on Two Layers

By computing the color values of the pixels in two images, you can create different special effects while 
combining images of two layers. This is similar to splitting the pixels of two images to RGB channels, 
applying the computing function to the corresponding pairs of the individual channels, and then 
recombining the resulting channels to form a new RGB color image.

With the same procedure, you can also combine the masks of two layers by different computing methods 
to produce various effects on the image.

This function can be used to color gray-scale images and manipulate or compare two images. You can 
get numerous results from different computing methods and settings.

To apply this function:

1. Make the images you need to combine on two different layers.

2. Drag the Name or Mask column of the layer containing the image or mask you want to use as source 
for computing to that of the destination layer. The result of combination will replace the image or mask 
of the destination layer.

If you dragged the Name column of the layer, the software will combine the images of the two layers. 
However if you dragged the Mask column, it will combine the masks of the two layers.

A list of option now pops up for your selection:

If you dragged the Name column, the first option is used for changing the position of the layer. If you 
dragged the Mask column, the first option is used for copying the mask to the destination layer.

All the other options are computing methods for combining the images or masks.

AND

This method combines the individual pair of pixels on corresponding location of two layers by applying a 
logical AND processing.

OR

This method combines the individual pair of pixels on corresponding location of two layers by applying a 
logical OR processing.

Add

Use this method to add the individual pixel values in the two layers. You can produce an average of two 
images or convert a gray-scale image to a tinted color image.

Subtract

This method subtracts the pixel values in the destination layer from those in the source layer. In result it 
can remove color values from images.

Multiply

Multiplying image pixel values with themselves is a useful method of increasing depth and contrast in a 
light image. If you multiply an image by itself, all pixel values (except 255) get darker. The smaller the 
values the darker they get.

Difference

This method is used to compare two images. When two images are the same, the result will be a pure 
black image. If there is any difference it will be shown.



Lighter

This method combines the images into a new lighter image. It picks the lighter values after comparing the 
pixel values of the images.

Darker

This method combines the images into a new darker image. It picks the darker values after comparing the 
pixel values of the images.

Paste Into

This method enables you to paste the image of a layer into another according to the mask of the latter 
layer.

Intersection

This method keeps the part that the masks of two layers intersect to produce a new mask for the 
destination layer.




