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PREFACE How To Use This Guide
What’s Included In This Guide
This guide describes the procedures to install and configure CedeFTP, and do any 
other day-to-day FTP tasks.

• Chapter 1, “CedeFTP Overview,” highlights the major features of CedeFTP.
• Chapter 2, “System Requirements,” details the minimum hardware specifica-

tions necessary to run CedeFTP.
• Chapter 3, “Installing CedeFTP,” describes the processes of installing and unin-

stalling CedeFTP.
• Chapter 4, “Configuring CedeFTP,” covers set up and customizing of CedeFTP, 

including user accounts, security features and registration information.
• Chapter 5, “Running CedeFTP,” tells you how to operate an FTP client.
• Chapter 6, “Technical Notes,” details the protocol and command support in 

CedeFTP.
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vi
Using This Guide
Review the first chapter to acquaint yourself with the features that CedeFTP pro-
vides.

Then read any chapter that’s about configuration or operational functions that you 
are unfamiliar with. Each chapter includes an overview of how the components 
work, what it can do for you, strategies for using it, how to set it up and how to 
administer it over time.

Some chapters end with a section called “Where To Find More Information.” This 
section points you to the Web sites and other reference material containing more 
information about the component.

Getting Additional Information
In addition to this document, you will find information about CedeFTP in:

• The product and support pages at http://www.nsctech.com.
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CHAPTER 1 CedeFTP Overview
CedeFTP enables computers to transfer files over your network or the Internet. It 
supports the latest File Transfer Protocol (FTP) features and provides security 
extensions to protect your information. The software is suited to transferring data-
base, medical, archive, scientific and multimedia files.

Designed For Your Pocket PC
CedeFTP sports the latest Microsoft “look-and-feel” and includes navigation tools 
(like multi-select mode) designed to minimize user input and display data in a com-
pact and easy-to-use fashion. In addition, you can run CedeFTP in the “back-
ground” so you can perform other tasks while transferring files!

Smart File Transfers
CedeFTP can send and receive files and folders (recursively) with a few quick taps. 
The software also includes error recovery and mirroring capabilities that enable you 
to resume broken files transfers and synchronize data at regular intervals!  
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Built-In File Management Functions
CedeFTP lets you manage local and remote files, including the ability to create new 
folders, delete and rename files, change permissions and send custom commands. 

Time Saving Features
You can configure CedeFTP to automatically dial, hang-up and use common FTP 
settings (like passive and overwrite modes) to help your work more efficiently. The 
software also includes an “address book” to manage FTP site login information.

Firewall And FTP Proxy Friendly
Firewalls restrict access to your network and impose many restrictions on the web 
services behind them. CedeFTP lets you to configure the protocol and the TCP/IP 
operation, including bandwidth throttle, of your FTP client.

Perfect For Developers
The registered version of CedeFTP lets you configure and run FTP operations from 
the command line, so you can develop and deploy your applications faster!

Where To Find More Information
Request for Comments (RFC) documents provide an overview of a protocol or ser-
vice and details about how the protocol should work. If you are a new system 
administrator, you will probably find some of the background information in an 
RFC helpful. Experienced administrators can find the technical details of a protocol 
in these documents. You can search for RFC documents by number at this Web site:

http://www.faqs.org/rfc
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Where To Find More Information
For details about FTP, see RFC 959.
CedeFTP User Guide 3



CedeFTP Overview

4
 CedeFTP User Guide



CHAPTER 2 System Requirements
The minimum requirements your device needs to run CedeFTP are:

• A 200Mhz ARM or XScale processor.
• 16MB RAM.
• 1MB of storage; 8MB or more recommended.
• Microsoft Pocket PC 2000/2002/2003 operating system.
• A TCP/IP network connection.
• External storage devices and memory cards are supported.
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CHAPTER 3 Installing CedeFTP
This chapter describes the procedures to install and uninstall CedeFTP.

NOTE: If you have purchased CedeFTP from an on-line distributor, print out your 
receipt and make a back-up copy of the software.

Installing

Perform the following steps to install CedeFTP: 

1. Open Microsoft Windows Explorer (Start > Programs > Accessories > Win-
dows Explorer) on your desktop computer.

2. Double-click the Setup.exe icon located in the CedeFTP folder.
3. Click Install.
4. Read the license agreement carefully. If you agree to the terms, click Accept to 

launch Microsoft ActiveSync.
5. Follow the on-screen instructions. 

You can also install CedeFTP on your device:

1. Copy or download the CedeFTP.PPC3_ARM.CAB file to your device.
1. Open Microsoft File Explorer (Start > Programs > File Explorer).
2. Locate and tap the CedeFTP .CAB file (specified above).
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3. Follow the on-screen instructions.

Uninstalling

Perform the following steps to uninstall CedeFTP: 

1. If CedeFTP is running on your device, exit the application.
2. Open Microsoft ActiveSync on your desktop computer.
3. Select the Add/Remove Programs options in the Tools menu.
4. Select Noisette Software CedeFTP in the application list.
5. Click the Remove button.
6. Follow the on-screen instructions.
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CHAPTER 4 Configuring CedeFTP
To configure CedeFTP, open the application and choose the Settings... option in the 
Tools menu.
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Step 1: Configure General Settings
The General settings lets you specify the guest email password and default transfer 
folders.

1. Anonymous password. Enter a password for use on public (anonymous) FTP 
sites. The format for the email address is: username@yourdomain.com. For 
example, johndoe@hotmail.com.

2. Remote folder. Enter the default location to look for files and folders on FTP 
sites. The root (‘/’ forward slash with no quotes) folder is recommended.

3. Local folder. Enter or select the location on your device to store FTP files.
4. Use system icons. Check this option if you want to use application or “associ-

ated” icons in the local view.
5. Open address book. Select this option if you want to open the address book 

when CedeFTP starts.
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Step 2: Configure Connection Settings
Step 2: Configure Connection Settings
The Connection settings let you specify your FTP proxy server (if required), RAS 
connection and bandwidth throttle settings.

1. Use proxy server. Check this option if your Internet service provider requires 
you to configure a proxy server for FTP usage. If you do not require this setting, 
skip to step 4. 

NOTE: Ask your network administrator if you do not understand what this setting is 
for.

2. Proxy address. Enter the IP or name of your proxy server.
3. Proxy port. Enter the TCP port for FTP connections.
4. Open RAS at start-up. Select this option if you want CedeFTP to automati-

cally dial/hang-up your Internet connection. Skip to step 7 if you do not enable 
this setting.

5. Select RAS connection. Choose the connection to dial.
6. Close on exit. Check this option if you want CedeFTP to hang-up on exit.
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7. Configure advanced connection settings. Tap this button to configure the 
bandwidth throttle.

Configure Advanced Connection Settings
The bandwidth throttle lets you limit the speed of your FTP transfers. This feature 
was introduced to handle slow or error prone network connections.

1. Enable network throttle. Check this option if you want to limit the network 
utilization of your FTP connection.

2. Maximum transfer speed. If you have enabled the network throttle, enter the 
maximum transfer speed (KB/s). We recommend 8 KB/s or less for slow or 
unreliable connections.
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Step 3: Configure Transfer Settings
Step 3: Configure Transfer Settings
The Transfer settings let you specify the default data and write modes.

1. ASCII/Binary mode. Check this option to use binary data transfers (recom-
mended); otherwise ASCII (or text) will be used.

2. Convert links to folders. Check this option to make symbolic links (a UNIX 
facility) appear as folders in the remote view. Otherwise they will be referenced 
as files.

3. Skip ALLO command. Select this setting to skip the FTP allocate (ALLO) 
command in upload sequences.

4. Active/passive connection mode. Enable this setting to use passive (client to 
server) data connections for sending/receiving file data. Note that active con-
nections involve the server connecting to the client which is a security risk and 
is therefore refused by many servers.

5. Write mode. Select the default write mode for sending/receiving files.
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CHAPTER 5 Using CedeFTP
In this next section, we will examine how to operate CedeFTP.
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The Main Display

1. Viewbar. Change between remote, local and history (control channel) views.
2. Pathbar. Displays the current folder or location.
3. Context menu. Tap and hold to display shortcut options.
4. Forward/backward buttons. Changes to the previous or next folder.
5. Header control. Displays current sorting order. Tap to change sort order.
6. File and folder view. Displays relevant file and folder information.
7. Menu and toolbar. Commands and options.
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The Menu And Toolbar
The Menu And Toolbar

1. Parent folder. Change to the parent directory.
2. Refresh view. Update file and folder information.
3. Download. Get selected [remote view] files and folders from the FTP server.
4. Upload. Send selected [local view] files and folder to the FTP server.
5. ASCII/Binary toggle. Switch between ASCII and binary mode.

Connecting To Remote Computers
To connect to a FTP server, select the Open... option in the File menu. Enter the 
remote server's name (or IP address), your username and password. Enable the 
Save in Address Book checkbox if you want to reuse this data in the future. Tap 
Connect to start the FTP session.
CedeFTP User Guide 17
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If you have previously saved server information to the address book, you can 
access it through the Address Book... option in the File menu.

NOTE: You must register CedeFTP to use the address book.

Viewing History Information
After connecting to a FTP server, CedeFTP will display a "history" (control chan-
nel) view. This display allows you to read server messages, errors and the progress 
of FTP operations. You can switch to this view at any time by tapping the History 
tab or selecting the History option in the View menu.
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Viewing File Information
Viewing File Information
CedeFTP maintains remote and local file views for performing FTP operations. 
The remote view (View > Remote) is available when you are connected to a server, 
while the local view (View > Local) can be accessed at any time. Both views dis-
play the name, date, size and permissions of each file entry. The software includes 
several unique features to help you navigate this information:

• File data can be sorted by tapping the header labels.
• Using the Multi-Select option in the Edit menu, it is possible to select multiple  

file entries with single taps; without holding down the control or shift keys.
• Double-tap a folder to display it's contents.

  WORK IN PROGRESS
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CHAPTER 6 Technical Notes
This section contains advanced system and protocol details for CedeFTP.

Port Range
CedeFTP uses the TCP ports between 2500 and 3000 for data connections. If your 
device is behind a firewall, you should update the network rules to allow incoming 
traffic (for PORT commands) in this range.
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Command Line Parameters
CedeFTP supports the following command line parameters:

PARAMETER DESCRIPTION/SYNTAX

address FTP host address. Syntax:

address <SP> [IP | DNS name]

port FTP port (default 21). Syntax:

port <SP> #

user Login username (default “anonymous”). Syntax:

user <SP> username

pass Login password (default CedeFTP preferences). Syntax:

pass <SP> password

acct Login account (default none). Syntax:

acct <SP> account

ldir Local folder. Syntax:

ldir <SP> folder

Remember to use quotes to specify folders with spaces in the 
filename.

rdir Remote folder. Syntax:

rdir <SP> folder

send, put Send file to FTP host. Syntax:

send <sp> filename or put <sp> filename

Remember to use quotes to specify filenames with spaces.

recv, get Get file from FTP host. Syntax:

recv <sp> filename or get <sp> filename

rest Restart position for send/receive. Syntax:

rest <sp> offset

ascii ASCII mode.

binary Binary mode.

pasv Use passive connections.

port Use active connections.

dial Dial default RAS connection.
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Command Line Parameters
Note unspecified options will default to the application preferences.

Examples
The following example will download the file screenshot.jpg from the FTP server 
at 192.168.1.2. CedeFTP will launch in the background (accessible from the system 
tray) and automatically exit when the download is complete.

CedeFTP.exe /address 192.168.1.2 /user someone /pass mypass /rdir Pub /ldir "My 
Documents" /get screenshot.jpg /binary /pasv /hide /quit

hangup Hangup RAS connection on exit.

status Show operation success/failed dialog.

hide Run CedeFTP in the background. You can open the applica-
tion through the system tray (Start > Today).

quit Exit the application when command line processing is com-
plete.

PARAMETER DESCRIPTION/SYNTAX
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APPENDIX A FTP Commands
COMMAND DESCRIPTION/SYNTAX RFC

LIST List file information in current/specified directory. Usage:

LIST [<sp> pathname] <CRLF>

959

NLIST List file names. Usage:

NLIST [<sp> pathname] <CRLF>

959

CWD/XCWD Change working directory.  Usage:

CWD/XCWD <sp> directory <CRLF>

959

CDUP/XCUP Change to parent directory. Usage:

 CDUP/XCUP <CRLF>

959

PORT Specify remote IP address for data transfer (server to client). 
Usage:

PORT <sp> b0, b1, b2, b3, b4, b5 <CRLF>

959

PASV Passive data transfer (client to server). Usage:

PASV <CRLF>

959
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TYPE Set representation type. Usage:

TYPE <sp> [A | I | L 8 | N | T | AN | AT] <CRLF>

959

ALLO Allocate storage space (ignored). Usage:

ALLO <sp> filesize <CRLF>

959

STOR Store (upload) file. Usage:

STOR <sp> filename <CRLF>

959

STOU Store unique file. The server will generate and return a file-
name in the reply.

STOU <CRLF>

959

APPE Append file. Usage:

APPE <sp> filename <CRLF>

959

RETR Retrieve (download) file. Usage:

RETR <sp> filename <CRLF>

959

PWD/XPWD Print working directory. Usage:

PWD/XPWD <CRLF>

959

ABOR Stop current operation. Usage:

ABOR <CRLF>

959

USER Set username. Usage:

USER <sp> username <CRLF>

959

PASS Set password. Usage:

PASS <sp> password <CRLF>

959

ACCT Set account (ignored). Usage:

ACCT <sp> account-info <CRLF>

959

DELE Delete file. Usage:

DELE <sp> filename <CRLF>

959

RMD/XRMD Remove directory. Usage:

RMD/XRMD <sp> directory <CRLF>

959

MKD/XMKD Create directory. Usage:

MKD/XMKD <sp> directory <CRLF>

959

COMMAND DESCRIPTION/SYNTAX RFC
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RNFR Rename from. Must be followed by RNTO command. Usage:

RNFR <sp> filename <CRLF>

959

RNTO Rename to. Usage:

RNTO <sp> filename <CRLF>

959

SYST System command. Return host operating system informa-
tion. Usage:

SYST <CRLF>

959

MODE Set transmission mode. Usage:

MODE <sp> [S] <CRLF>

959

STRU Set file structure. Usage:

STRU <sp> [F | R] <CRLF>

959

STAT Status. Return information about the current operation. 
Usage:

STAT [<sp> pathname] <CRLF>

959

REIN Reinitialize. This command terminates a user, flushing all 
IO. Usage:

REIN <CRLF>

959/
EXT

MDTM Set/get file modification time. Usage:

MDTM <sp> pathname <CRLF>
and

MDTM <sp> timevalue <sp> pathname <CRLF>

EXT

SIZE Return the size of a file (using current representation type). 
Usage:

SIZE <sp> pathname <CRLF>

EXT

FEAT Feature command. Show server capabilities. Usage:

FEAT <CRLF>

2389

OPTS Options command. Allows the client to set command behav-
ior. Usage:

OPTS <sp> command [<sp> options] <CRLF>

2389

COMMAND DESCRIPTION/SYNTAX RFC
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HELP Display command and syntax information. Usage:

HELP [<sp> command] <CRLF>

959

NOOP No operation. Usage:

NOOP <CRLF>

959

EPRT Extended PORT command. Usage:

EPRT <sp> <d><net-prt><d><net-addr><d><tcp-port><d>

2428

EPSV Extended PASV command. Usage:

        EPSV [<sp> ALL] <CRLF>

2428

QUIT Logout. Usage:

QUIT <CRLF>

959

COMMAND DESCRIPTION/SYNTAX RFC
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