
COPYWRITER 

    Thanx for using CopyWriter!
        I am developing and maintaining CopyWriter just for fun. It's a basic 
        editor, build the way I like it. I hope people do recognize quality 
        behind basic looks. 
        CopyWriter is around for more then two years now, and still most time
        is spend finetuning the program. I've downloaded enormous amounts of
        other programs to find out what I do like and what not. The result is 
        CopyWriter. Not to much functions, but enough to complete a wide range 
        of tasks. 
        I wish to thank all the people who support me with suggestions, tips, 
        code and encouraging thank-you emails. Without these people CopyWriter
        wouldn't be what it is: the Swiss army knife off editors.
  
    More information
        Details about the program can be found in the documentation file, wich 
        can be reached by pressing Ctrl+F1. CopyWriter has a lot of functions
        that are not incorporated into the menu. To get an overview of this
        functions, press F1.
  
    Major changes since Version 2.02
        - Customize the Tools menu with CopyWriter utilities.
        - Optimized Word file open functions. 
        - Optimized Install and Uninstall functions.
        - Large code cleanup to make the program faster and more reliable.
        - A enormous amount of tiny bug fixes small changes.

    License
        By using CopyWriter you agree with the license wich is included in the 
        documentation file and can be found at the end of this file.

    Contact
        Mail: laurenz@planet.nl
        Updates: http://home.planet.nl/~gaale131

VERSION HISTORY

    Version 2.03 (2003-08-26)
 
        New
        - Users can customize the Tools menu by placing shortcuts in the
            CopyWriter folder.

        Improvements and code optimization
        - Old associations are now restored after deinstallation or unchecking
            the association checkboxes on the Settings form. 
        - Optimized Word file open functions. Don't need external converter 
            anymore.
        - Internal code cleanup to make program faster, smaller and more 
            reliable.
        - Improved Text Specifications form (mixed formatting specs are now 
            showed).
        - My Files and Recent Files dialog buttons are now properly enabled/
            disabled.
        - Changed extension processing in Save procedures (Filter dependant, 



            not extension dependant).
        - Modified and improved Fullscreen function (no screen flicker, 
            position is better remembered).
        - Goto Line command scrolls now to nice position in stead of screen 
            bottom.
        - Find function scrolls now to nice position in stead of screen bottom.
        - Optimized print function (no flickering screen anymore).
        - Auto Words form now utilize Copy/Paste functions.

        Bugfixes
        - When changing the default filetype the filetype of the current open 
            file was changed. 
  
        User interface and cosmetical
        - Replaced original icon with square shaped icon.
        - Changes flat look to standard Windows look.
        - Changed default font from Verdana to Courier New.
        - Standard View option is now called Writers Mode, wich is not 
            the default.
        - Removed Basic Menu option.
        - Added Custom popupmenu to Find dialog.
        - Removed Maximize/Restore and Minimize functions from View menu.
        - Changed Settings shortcut to F4.
        - Changed Fullscreen, Maximize/Restore shortcuts.
        - Removed Minimize shortcut.
        - Main window is now centered on screen when application is first used.
        - Documentation menu item is now hidden if Documentation files doesn't 
            exist.
        - Fixed problem that prevents the Auto Words menu item to show correct 
            on first run.
        - Changed Additional Functions layout. 
        - Modified Details form.
        - Removed Sean Young and D-TNT from Credits form.
        - Added Robert Dunn and Peter 

    Version 2.02 (2003-04-23)

        New
        - Can open Wordfiles!
        - Option to close program with Esc key.

        Improvements and code optimization
        - My Files Open dialog uses now same filters as Main Open dialog.
        - Binary Files are now 100% read only.
        - Improved extension processing (not case sensitive anymore).
        - Switched inc/dec Fontsize and inc/dec Indent shortcuts.
        - After Fullscreen command focus was lost. Fixed problem.

        Bugfixes
        - None.
  
        User interface and cosmetical
        - Added Sean Young to credits for his Word converter.
        - Changed button order on all forms to be more Windows standard.
        - Added 'Build' to Details.
        - Modified Run settings: removed 'Confirm Save' option, added browse 
            dialog to search for *.exe file.



    Version 2.01 (2003-03-05)

        New
        - View > Stay on Top (Ctrl+M).
        - Line spacing shortcuts (Ctrl+1, Ctrl+2, Ctrl+5).
        - Super and Subscript shortcuts (Ctrl+=, Ctrl+Shift+=).
        - Increase indent (Ctrl+Shift+.) and decrease indent (Ctrl+Shift+,)
        - Tools > Run (See Settings for options).
        - Open binary files and display them correct.
        - RTF and TXT files can now be printed via Explorer contextmenu.
        - Reg Tweaks to: Add custom file extensions to the CopyWriter open 
            dialog, print files direct from Explorer and associate custom file 
            types.
 
        Improvements and code optimization
        - The Go To Line dialogs 'Mark' function performs now exactly the same 
            as the Standard Mark Line function (Ctrl+Shift+G).
        - Fullscreen now ignores taskbar settings.
        - Undo works now fine with auto indent, bullets and numbering 
            functions.
        - Files with an extension other then *.rtf or *.RTF are saved as 
            textfiles.
        - All editor movement shortcuts (Alt+Z etc.) are now disabled if 
            Standard View mode is used.
        - Rebuild installation package and changed installer options.
            Installer now uses C:\Program Files\CopyWriter as default path in 
            stead    of C:\Program Files\Page Up\CopyWriter.
        - Removed *.HTML filter from My Files Add File Dialog. 
        - Disabled 'Remove double spaces' function.
        - Removed space that was inserted after insertdate/time.

        Bugfixes
        - Last character of ASCII map (Ctrl+K) is now displayed correct.
        - Form now restores its position correct with the taskbar at an other 
            position then bottom.

        User interface and cosmetical
        - Changed Insert Clip shortcuts (Ctrl+1..4) to Alt+1..4 to make room 
            for the Line spacing shortcuts.
        - Removed View > Vertical Scrollbar menu item.
        - Updated/Corrected Addional Functions text and printed output.
        - Changed version number to 'Version 2.01'.
        - Modified Credits form (Added 'Swiss Army knife' sentence and 
            'Michael Mason' to credits)
        - Modified About form (Copywriter date > 2003, color URL)
        - Modified Setup form (Changed 'Don't use this version and quit 
            (Registry uninstall)' to 'Remove installed version and quit 
            (Registry uninstall)')
        - Changed text of message indicating a file is moved/deleted/renamed.
        - Changed formstyle type of easteregg form.
        - Settings: Changed 'Explorer Context menu' to 'Send to CopyWriter 
            menu item'

    Version 2.00 (2002-12-11)

        New



        - Replaced RTF hepfile by HTML helpfile.
        - Explorer File > New menu contains now CopyWriter TXT and RTF Files.
        - Added alternative popup menu (Ctrl+Space or Shift+Right mouse).
        - Added new shortcut to default popup menu (Ctrl+Alt+Space).
        - Shift+Left Mouse Click on statusbar changes statusbar position.

        Improvements and code optimization
        - Finally: Undo after insert (date/time/clips/autowords/characters) and
            custom edit actions (change case/switch characters).
        - Increased amount of adjustable tabstops from 20 to 32.
        - Added 'Default' to Tab size dropdownlist.
        - Removed *.HTML filter from File Dialogs and Settings form.
        - My Files and Recent Files popup menu items are now disabled if no 
            file is selected.
        - Removed Confirmation dialog when deleting an empty entry in My Files.
        - Changed default lines per page from 60 to 58 (correspondenting with 
            default margins/fontsize).
        - Changed external filenames (CopyWriterHelp.html > Help.htm and
            CopyWriterAutoWords.txt > Autowords.txt)
  
        Bugfixes
        - Fixed bug that prevented default font from loading after opening a 
            TXT file.

        User interface and cosmetical
        - Rebuild Install. 
        - Changed version number to 'Version 2.00'.
        - Added 'Enable/disable smart quotes' shortcut to Shortcuts form.
        - Addes 'Activate default popup menu' and 'Activate alternative popup
            menu shortcuts to Shortcuts form.
        - Credits: Moved 'Henk Schaap' from 'Additional Development' to 'Beta 
            Testing.'
        - Credits: Moved 'Brendon Toogood' from 'Beta Testing' to 'Special 
            Thanks'.
        - Credits: Removed 'Your Name?' from 'Beta Testing' section.
        - About: Removed link to www.download.com
        - About: Removed text about '1001-Editors Project' from Easter Egg.
        - Changed 'No nonsense wordprocessor' in 'General purpose editor'.
        - Changed a lot of text concerning the Setup Dialog.
        - Edit Auto Words form: removed underlined 'O' (Options).
        - Added info to EXE properties.

    Version 2.00 - Beta 3 (2002-09-26) 

        New
        - View > Standard View (Ctrl+0)

        Improvements and code optimization
        - None

        Bugfixes
        - Help file is now loaded correct.

        User interface and cosmetical
        - Changed version number to 'Version 2.00 - Beta 3'.
        - Added to Special Thanx form: Thomas Stutz,
        - CopyWriter displays now correct in Windows XP.



        - Menu item name changed ('Aditional functions' > 'Additional 
            Functions')
        - Removed Basic Menu item from View menu and changed shortcut to 
            Ctrl+F6
        - Updated/Corrected Addional functions text and printed output.
        - Setup: if no version detected, '1.79 and lower or None' > Changed to 
            'None'
 
    Version 2.00 - Beta 2 (2002-08-30)

        New
        - Auto Spaces, Tabs, Dashes, Bullets and Numbering function.
        - Backspace deletes two spaces when possible.
        - Shift+Return shortcut to override Auto Indent, Bullets and Numbering.
        - Statusbar now displays 'BINARY' when a binary file is loaded.
        - Statusbar shows total bytes of (TXT) file.
        - Context menu on statusbar.
        - Basic Statusbar switch (F6)
        - CopyWriter now reliable opens files up to 2048 Kb.
        - My Files/Recent Files Ctrl+I shows file path of selected file.
            Added context menu with this options.
        - Add current file to My Files (Ctrl+A).
        - Clear List button on Recent Files.
        - Four Clips to copy selected text to memory (Ctrl+Shift+1 .. 4)
            and paste them back (Ctrl+1..4)
        - Auto Words function added (Alt+\)
        - About > Details (Ctrl+I)
        - Help > Documentation.
        - Help > Aditional Functions.

        Improvements and code optimization
        - Statusbar is not longer updated when turned off.
        - Statusbar is turned of during Replace All procedure to speedup 
            process.
        - Optimized Switch Characters function (speed and apearence).
        - Optimized Change Case function (speed and apearence).
        - Change Case function now change case of all characters (like ë).
        - Change Case function now isn't stopped by non alphabet characters 
            (like 9 or $).
        - Install now reset all settings to default.
        - If a file association is claimed by an other application the Settings 
            form association checkboxes are now properly unchecked.
        - If a file association is claimed by an other application and 
            CopyWriter
            will not remove the association on uninstall.
        - Text Specifications form now let you set font name and size without 
            messing up fontstyle propertys. 
        - Replace and Replace All commands now also remember last found text.
        - Removed Remove Format function before saving TXT files.
        - New File loads now default font.
        - After a Print Selection command the cursor now returns to the 
            original position.
        - Print margins are now 1.00 inch by default (was 0.50 inch) 

        Bugfixes
        - None



        User interface and cosmetical
        - Changed version number to 'Version 2.00 - Beta 2'.
        - Added 3 betatesters to Credits form: Stanislav Dragnev,
            Brendon Toogood, Fabian Lessle.
        - Added credit for StripReloc.
        - Removed credits for some sites, changed text concerning D-TNT forum 
            to: 'On line programming help: All the members of the D-TNT forum'.
        - Renamed Statusbar panel 'Characters' to 'Chars'.
        - Switched position of statusbar panels 'Chars' and 'Words'. 
        - Changed example date in Settings form to: '31-12-2002/12-31-2002/
            2002-12-31'.
        - Changed dialog that appears when a search operation could'nt find 
            text to: 'No more text found. Retry from begin of text?'
            Also changed dialog buttons. User will now abort the search by 
            default and has to press 'Retry' to try again form the begin of 
            text. Dialog type changed form 'Confirmation' to 'Information'.
        - Changed Remove Format dialog text to 'Remove ALL formatting and set 
            font to default?'
        - Changed Print Options checkbox caption to: 'Print Filename, Date/Time 
            and Pagenumber'.
        - Print Options dialog OK button now receives focus in stead of 
            Left Margin combobox.
        - Print Options form now closes with Ctrl+Shift+P in stead of Ctrl+P. 
        - Redesigned Settings form, added Auto Indent, Bullets and Numbering 
            setting.
        - Redesigned View menu.
        - Basic menu now also hides Search > Find Selection.
        - User will now be prompted before install executes.
        - Added Confirmation dialogs to Add and Delete functions on MyFiles 
            form.
        - Added default OK button to Text Specifications form.
        - Removed standard dropdown menus on Settings form.
        - Changed Statusbar on click event to Basic Statusbar in stead of 
            Statusbar Top.
        - Redesigned Insert menu
        - Checked/adjusted Tab order of all buttons and controls.
        - Checked/adjusted all shortcuts on forms and menu.
        - Added 'Easteregg'.

    Version 2.00 - Beta 1 (2002-07-01) 
    - First release, nothing changed.

LICENSE

    General
        By using CopyWriter you agree with the points discribed below. 

    Warranty
        The author shall not be held responsible for any damages, direct or 
        indirect, that may arise from the use of CopyWriter. The author accepts 
        no commitment or liability to support CopyWriter or to address any 
        problems that may be encountered in using it. The program is provided 
        'as is' without any warranty of any kind. 

    Distribution
        CopyWriter is Freeware. You may use CopyWriter for any purpose, private 



        or commercial, without payment or registration. You may freely 
        redistribute CopyWriter, subject to the following limitations:

        - You may not charge a fee.
        - You may not include CopyWriter as part of a product for which a fee 
            is charged.
        - You may not alter any part of CopyWriter without the express 
            permission of the author.
        - Any reverse engineering, decompilation or modification of CopyWriter 
            is strictly prohibited.

    Copyright
        The author retains all rights, present and future, to CopyWriter. 
        Copyright (c) 2000/2003 PageUp/Laurenz van Gaalen.


