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How to use the help file

The help file may be read chapter by chapter.  To do so, click the "summary or contents" button in the Help  
window. A page named "Contents" appears. The fat and underlined text refers to links that will take you to the  
chapters if you double click on it. The normal underlined text takes you to subheadings within the chapters. To 
return from a link (jump), push the "previous" button. Some images contain links too. The "linked" elements in such 
an image are marked by a box (see for instance the drawing toolbox). If the mouse pointer is over a link, the  
pointer  changes into  a  pointing  hand. Dotted  underlined  text  will  give  a  pop-up window.  To quit  the  pop-up 
window, click anywhere except on a link. To get help on one of the three main window types, activate one of the 
windows by clicking on it and then push the help icon under the menu bar.
To know more about the options in a particular dialogue window, push the help button in the dialogue window 
concerned or use the "?" button in the top right corner of that window if it is available.
To go rapidly to a section in the helpfile dealing with a particular menu item or button (icon) in one of the tool bars,  
click the  button and then select an item from the menu or click an icon in one of the tool bars. 
In this file,  fat text indicates either a heading or some kind of definition.  Italic text refers to a menu or to menu 
items.
Use the "index" push-button on top of the help window in order to search for keywords.
If you can not find what you are looking for, drop me a line at: deweille@bram.org.
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Introduction

XL-Plot is the eXtra-Light version of the freeware program Serf. Serf, is a program that is specifically meant for 
electrophysiologists and can be found on the web as well (on june 2001 the site was: 
http://www.bram.org/serf/serf.shtml, but it may change in the future). The most recent version of XLPlot may be 
found at http://www.bram.org/xlplot/xlplot.shtml .

The primary purpose of  XL-Plot  is  to  create a figure for  scientific  publication  rapidly.  It  contains a few basic  
statistical  functions,  such  as  Students  t-test  and  linear  correlation  of  two  sets  of  data  (two  columns  in  a  
spreadsheet).  XL-Plot  has  a  number  of  build-in  functions  that  can  be  fitted  to  the  data  in  columns  on  a 
spreadsheet or to a curve in a graph. The user can easily add fitting functions of  his own design. Additional 
options are convolution, Fourier Transformation and Matrix inversion.

XL-Plot accepts tab- or comma-delimited ASCII (*.txt files) as input. It outputs a vector drawing (*.his file; a xlplot  
format that may be exported to other vector drawing programs).
The program is build around two types of window each having its own menu and preference settings:
* Windows showing vector drawings (drawing sheets).
* Windows showing columns of numerical data (spreadsheets).
Items in the latter two types of window may communicate such that a modification in a column in a spreadsheet 
results in a change in the associated graph.

The icons in the program icon bar:

   Open a new, empty, drawing sheet.

   Open a new, empty, spreadsheet.

 
   Open file, same as the File>Open menu item.

   Save file, same as the File>Save menu item.

   Delete, the deleted item is copied to the clipboard.

   Copy to clipboard.

   Paste clipboard contents.

   Repeat last action.

   Enable text sizing in the current drawing sheet.

   Create a line plot, same as the Modify/Data>Line Plot menu item.

   Create a bar plot, same as the Modify/Data>Bar Plot menu item.

   Import bitmap onto a drawingsheet, same as the Bitmap>import bitmap menu item.

   Save bitmap, similar to the Bitmap>save bitmap menu item.

   Menu help. Click this icon and then select a menu item or an icon in the toolbar.

   Help, the help file.
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Getting Started

This chapter helps you on your way to use XLPlot without going into much detail using a step-by-step approach. It 
is by no means exhaustive. To get all out of XLPlot, please refer to the other chapters or search the help file for  
keywords.

1 Create your first graph:   We will draw a parabola f(x) = (x-5)**2

step 1.1 Start XLPlot. 
step 1.2 From the File menu (it is the only available right now), choose new.  
step 1.3 In the "Select File Type" dialogue window, choose "spreadsheet" and push "OK". A blank spreadsheet  

"document1" is created.
step 1.4 Click in the spreadsheet cell at column 1, row 1. 

Then type (without  the quote  marks): "mV"  followed  by <RETURN>,  then  type  "0" <RETURN>,  "1" 
<RETURN> etc.    until "10" <RETURN>. If you type a wrong character, use the <BACKSPACE> key.

step 1.5 Click in the spreadsheet cell at column 2, row 1. 
Then type (without the quote marks): "mA" followed by <RETURN>, then type "25" , "16" , "9" , "4" , "1" ,  
"0" , "1" , "4" , "9" ,  "16" , "25", where each number is followed by a <RETURN>.

The spreadsheet should now look like:

step 1.6 Click on  "column" key number 1 and, while keeping the left mouse button depressed, move onto column 
key 2 and release the mouse button. Now the two columns 1 & 2 are selected:

step 1.7 From the Modify/Data menu select Line Plot. 
step 1.8 In the "Set Columns" dialogue window check "X". This means that column 1 will be the X-coordinate.

step 1.9 advance one column by pushing the  button. As "Y" is the default, nothing needs to be done here. 
Hence, column 2 will furnish the Y-coordinate.

step 1.10Push the "OK" button. A new drawing window "document2" is created containing the graph:
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step 1.11From the  File menu choose  save (document2 needs to be the active window. If you have clicked on 
document1, reactivate document2 by clicking on its title bar before going to the File menu).
In  the  "Save"  dialogue  window  type  "step1"  as  filename.  The  title  bar  now  reads  "step1.his"  (the 
extension is added automatically).
Note that the column keys 1 & 2 in the spreadsheet now contain a "°" character. This means that these 
columns are linked with a graph on a drawing sheet. The use of these links is the subject of the next 
exercise. 

2 Edit the graph using the spreadsheet

If you just carried out step 1, leave the program and restart it. (It is not necessary to save document1).
step 2.1 From the File menu choose open and load "step1.his" that was created in step 1.  A drawing window is  

created containing the parabola.
step 2.2 Click on one of the elements of the graph. Eight little boxes appear around the graph. It is now selected:

step 2.3 Push the "copy" icon  in the program window icon bar. The graph is now copied to the clipboard.
step 2.4 From the File menu choose new.
step 2.5 In the "Select File Type" dialogue window, choose "spreadsheet" and push "OK". A blank spreadsheet  

"document1" is created.
step 2.6 Click in the spreadsheet cell at column 1, row 1. 
step 2.7 Push the "paste" icon  in the program window icon bar. The graph data are pasted onto columns 1 & 

2. Note that the column keys 1 & 2 in the spreadsheet contain a "°" character. This means that these  
columns are linked with the graph on the drawing sheet.

step 2.8 Move the spreadsheet such that both graph and columns are visible. 
step 2.9 Click in the cell  at column 2 and row 7. It contains "0". Then type "10" followed by <RETURN>. The  

contents of the cell are replaced by "10" and the curve in the graph is updated:
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step 2.10Select undo from the Edit menu. The original curve is restored. Cell [2,7] reads "0" again.
step 2.11Click on the row key number 2, thereby selecting row 2:

step 2.12Push the "delete"  icon   in the program icon  bar.  The  row is  deleted  and the curve  in the graph 
modified.

step 2.13Close all windows without saving.

3 Changing the layout of the graph.

step 3.1 Open file step1.his (as in step 2).
step 3.2 Double-click on one of the axes (and hence not on the curve). The "Axes" dialogue window appears.
step 3.3 Under "Y-axis" on the right, replace "To" "30" by "To" "25".

Set "Major tick every" "5".
Set "Minor tick every" "1".
Set "X-axis crosses at" "-2".
Push the "OK" button.

step 3.4 Double-click on the curve. The "Curve properties" dialogue window appears.
step 3.5 Uncheck the "connect points with line" checkbox. Push the "OK" button. The graph should now look like:

step 3.6 Select save as from the File menu and give "step3" as new file name (the extension .his will be added 
automatically).

6



4 Fitting a function to a curve.

step 4.1 Open file step3.his, created in step 3.
step 4.2 Double-click on one of the data points (open circles). The "Curve properties" dialogue window appears. 

Move it such that the graph on the drawing sheet becomes visible.
step 4.3 Push the "Function" button. The "Fit" dialogue window appears on top of the previous one. If necessary  

move it to uncover the graph.
step 4.4 From the list of functions select '*parabola" and push the "<<" button. The text in the edit box now reads: 

"a+b*(X-x0)^2", the definition of a parabola. Push the "OK" button.
step 4.5 In the "Curve properties" dialogue window that now reappears, push the "Do Fit" button.
step 4.6 The "Fit" dialogue box reappears and the fitted curve is plotted onto the graph (in red). The estimated 

parameters are: a=0 (or very close to it), b=1 and x0=5. Push the "OK" button.
step 4.7 Push the "OK" button in the "Curve properties" dialogue window. The graph should now look like:

While the curve in step 1.10 had its data points interconnected by line segments, this graph has its data 
points interconnected by a smooth function.

step 4.8 Save the drawing sheet as "step4.his".

5a Students t-test

step 5.1 Create a new spreadsheet and enter data as in step 1:

step 5.2 Select columns 1 & 2 (as in step 1.6).
step 5.3 From the "Modify/Data" menu choose "Get column stats". The following dialogue window pops up:
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It shows means, standard deviations and standard errors of the means for the two columns. Supposing 
that  the data are paired (e.g.  each pair  of  data in a row has been obtained before and after some 
manipulation), then the probability (P) that the two samples of data in columns 1 and 2 belong to the 
same parent population is 2.3%.

step 5.4 Push the "OK" button. The dialogue window disappears.
step 5.5 Click on the spreadsheet cell at column 4, row 1 and push the paste icon in the program icon bar. The  

statistical data are now available on the spreadsheet for future manipulation:

5b Fishers F-test

step 5.6 Start a fresh spreadsheet and enter the following data in three columns:

step 5.7 Select columns 1,2 & 3 (as in step 1.6).
step 5.8 From the "Modify/Data" menu choose "Get column stats". The following dialogue window pops up:
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Because the t-test is not valid if one disposes of more than 2 sets of data, Fishers F-test (or one-way 
ANOVA) is carried out. The small P indicates that the three columns of data do not come from the same 
population. In order to know which is (are) the data set(s) that deviate, Tukey's multiple comparison test (q-
test) is carried out next. As the number of data sets may be large (256 columns is the maximum), the result 
is not shown in the dialogue box. Push the "OK" button and paste the clipboard onto the spreadsheet:

 

During Tukey's algorithm, the means are sorted in ascending order, which in this case happens to be 
column 1,2 and 3. Then the q-test is carried out  between every possible pair  of  columns. It can be  
concluded here that the data in columns 2 and 3 do not come from different populations, while the data 
in column 1 is significantly different from the rest.
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6 Creating a graph using functions: we'll make a sine wave

step 6.1 Create a new spreadsheet (see step 1)
step 6.2 In column 1, row 1 enter "s". In column 2, row 1 enter "V" (see step 1)
step 6.3 Click in cell column 1, row 2 and then click in the spreadsheet edit box:

step 6.4 Type (without the quote marks) "=(lin-2)*0.01" followed by <RETURN>
step 6.5 Click in cell column 2, row 2 and then click in the spreadsheet edit box. 
step 6.6 Type (without the quote marks) "=sin(2*pi*2*" (N.B. no <return> !).
step 6.7 RIGHT mouse click in cell column 1, row 2. The following should show:

step 6.8 Type ")", followed by <RETURN>. The result is:

We've now entered two formula and the (not too exciting) result is shown.
In cell [C1:L2] we have:  "=(lin-2)*0.01", which means "show the line (row) index diminished by two and 
multiplied by 0.01" or "(2-2)*0.01", which equals "0".
In  cell  [C2:L2]  we  have  "=sin(2*pi*2*[C1:L2])",  which  means  the  sine(2*pi*f*t),  where  f=2  and  t  is 
furnished by the contents of cell [C1:L2]. This amounts to: "=sin(4*pi*0)", which equals "0".

step 6.9 Click in the cell at column 1, row 2, and while keeping the left mouse button depressed move the mouse 
pointer downwards, moving it over the bottom window border. The window will scroll. Release the mouse 
button when you point in the spreadsheet cell at column 2, row 102: 
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Now all cells in the range from column 1, line 2 to column 2, line 102 are selected.
step 6.10From the Fill menu choose down copy. Now all formula will be copied downwards:

step 6.11Push the "home" key: .
In order to plot the two columns, we could proceed as in step 1.6 through 1.11. Here we'll follow an  
alternative method.

step 6.12Click the column key number 1:

step 6.13  From the Modify/Data menu select Set as X-column.
step 6.14Click the column key number 2 and from the Modify/Data menu select Set as Y-column.

 The X and Y columns are now indicated on the column keys.
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step 6.15From the Modify/Data menu select Line plot. A new drawing sheet is created with the following graph:

We will combine this graph with the result of step 4.
step 6.16Click on one of the elements of the graph. Eight little boxes will indicate that the graph is selected.
step 6.17Push the copy icon in the program icon bar.
step 6.18Open the file "step4.his".
step 6.19Enlarge the window to show an empty place where you'd like to paste the sine wave and click once on 

this spot. That is where the center of the sine wave graph will be.
step 6.20 Push the paste icon in the program icon bar:

step 6.21Finally push the "save" icon  to save the modified step4.his file.

7 A few last details: We'll make figure "step4" ready for publication.

step 7.1 If it is not open yet, open file "step4.his". Size the window such that we have room to work.
step 7.2 Select  the  parabola  graph  by  clicking  once  on  it.  Depress  the  <SHIFT>  key  and  while  keeping  it 

depressed click once on the sine wave graph. Release the shift key. Now both graphs are selected. 
step 7.3 Click on either graph, and while maintaining the left mouse button depressed, move it to the right and 

slightly to the bottom. The two graphs move. Release the mouse button when there is a reasonable left 
margin.

step 7.4 Unselect the graphs by clicking anywhere on the sheet.
step 7.5 From the "drawing tool box" click the text tool:

step 7.6 Click left of the parabola and type "A".
Click left of the sine wave and type "B".
Click underneath the parabola and type "a parabola".
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Click underneath the sine and type "a sine".
Then select the "arrow" tool from the drawing tool box (just left of the text tool).

step 7.7 Select both the "A" and the "B" text objects by clicking on them and using the shift key as in step 7.2.

step 7.8 Click on the "font tool"  and change the font size to "16". The result is now like:

step 7.9 Click the "align tool"   in the drawing tool box. A dialogue window pops up. Choose the following 
settings and push the "OK" button:

step 7.10Select the two graphs, click the align tool and push the "OK" button in the dialogue window.
step 7.11Similarly bottom-align the two text objects "a parabola" and "a sine".
step 7.12Select the "a parabola" text object and move the object to the left or the right using the horizontal arrow 

keys on your keyboard. Do the same with the "a sine" object. 
step 7.13Save the file. The result may resemble:
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8 Deleting objects and dissociating a graph.

step 8.1 Load file "step4.his" that was modified and saved in step 7.
step 8.2 Click above and left of the "A" on the drawing sheet. While keeping the left mouse button depressed 

move mouse downward and to the right until you reached a point just below and to the right of the text "a  
sine":

step 8.3 Release the mouse button and push the "delete" icon  from the program icon bar. The five selected 
objects will be deleted. The sine wave graph remains.

step 8.4 Click on the sinewave graph and choose Dissociate from the Edit menu. The graph is now dissociated 
into several elements. Click anywhere on the drawing sheet to unselect the objects, select the sine wave 
and then drag it to the left:

step 8.5 Double-click on the sine wave. Then RIGHT mouse click until the scissors cursor appears.

step 8.6 Move the cursor as in the figure and left-mouse click to cut the sine wave in two.
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step 8.7 Unselect by clicking anywhere. Select the left sine period and drag it to the left:

9 Creating a bar plot with error bars.

step 9.1 Start XLPlot. 
step 9.2 From the File menu (it is the only available right now), choose new.  
step 9.3 In the "Select File Type" dialogue window, choose "spreadsheet" and push "OK". A blank spreadsheet  

"document1" is created.
step 9.4 Click in the spreadsheet cell at column 1, row 1. 

Then type (without the quote marks): "50" followed by <RETURN>, then type "72" <RETURN>,and "66" 
<RETURN>. If you type a wrong character, use the <BACKSPACE> key.

step 9.5 Click in the spreadsheet cell at column 2, row 1. 
Then  type  (without  the  quote  marks):  "25",  "10"   and  "15"  where  each  number  is  followed  by  a 
<RETURN>.

step 9.6 Click in the spreadsheet cell at column 3, row 1. 
Then  type  (without  the  quote  marks):  "58",  "74"   and  "33"  where  each  number  is  followed  by  a 
<RETURN>.

step 9.7 Click in the spreadsheet cell at column 4, row 1. 
Then  type  (without  the  quote  marks):  "15",  "12"   and  "3"  where  each  number  is  followed  by  a  
<RETURN>.
Columns 1 and 3 contain the means of some experiment, while columns 2 and 4 contain the standard 
errors of the means.
The spreadsheet should look like:

step 9.8 Select the columns 1 through 4 (see step 1) and from the Modify/Data menu select Bar Plot. The "Set 
Columns" dialogue window pops up:
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step 9.9 In the "Set Columns" dialogue window check "Y" (the default). This means that column 1 will be the Y-
coordinate.  

step 9.10Advance one column by pushing the  button.  Check "SEM". Hence, column 2 will furnish the Error 
bar.
Advance again, check "Y", advance again one column (we are now at column 4) and check "SEM".
Push "OK". The following graph will be created:

step 9.11 In The dialogue window that pops up, carry out the indicated modifications (fill colour, show lower half) 
and push the "OK" button.

This results in:

The representation of the white columns may be changed similarly after double clicking on one of the 
white bars.
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10 Spreadsheet slidebar demo.

step 10.1  From the File menu choose open and load the spreadsheet file "sbardemo.txt" that should reside in your 
xlplot directory. The spreadsheet should look like:

                  

Column 3 contains a cosine that is a function of the line index (lin) and column 4 contains a sine function.

step 10.2 Select columns 3 and 4 (as in step 1.6) and choose line plot from the Modify/Data menu. After having set 
column 3 as the "x" column and column 4 as the "y" column in the dialogue window that pops up, a new 
drawing sheet is created with a graph containing a circle as shown to the right. As can be seen from the  
formula  in  the spreadsheet  edit  box:  "=sin([C2:L$4]*(lin-2)*0.03141)",  the frequency of  the sinewave is  
determined by the contents of the cell at column 2 and line 4. This cell contains a slidebar. After selecting  
this cell, the spreadsheet edit box will show: "=sbar(1,4,11)", meaning that the sinewave frequency may 
vary between 1 and 11 depending on the position of the cursor, which here is 4. The frequency of the  
cosine at column 3 similarly depends on the setting of the slidebar at column 2 and line 2.

step 10.3 In the slidebar at column 2 and line 4, click on the space between the central cursor and the  gadget: 

.  The sinewave frequency changes from 4 to 5 (it  is  incremented by 10% of  the difference 
between the slidebar's minimum (1) and maximum (11) settings). The data in column 4 change and the 
graph, which is linked to columns 3 and 4, changes accordingly into:

and  clicking the   gadget  gives:
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The spreadsheet

A spreadsheet is a text document that organises data in columns and rows. A blank spreadsheet can be created  
by using the File>new menu option. An existing spreadsheet is read by using the File>open option from the menu 
or clicking the open file icon. From the open file dialogue window select type=Spreadsheet files. Tab-delimited or  
comma-delimited files need to have the extension *.txt in order to be read. Because software that comes with  
some laboratory equipment saves data in MS-Excel *.xls format, XL-Plot reads this file format, although without  
parsing formulas that it may contain. It just reads the numerical result.

There are two ways to enter data in a spreadsheet cell. 
i) Click on the cell you wish to edit and type the new text. Upon pressing the return key or one of the arrows on the  
keyboard the old text is replaced by the new text. Depending on which key was pressed, a next neighbour cell is 
highlighted. 
ii) Click on the cell you wish to edit and then click in the edit box. Modify the text in the edit box and press the  
return key. The cursor in the edit box can be moved using the arrow keys on the keyboard. 
The latter method is recommended to edit formulas, as cell references can be entered by the mouse rather than 
the keyboard. Text is considered to represent a formula or an equation if the first character is a "=" sign (e.g.  
=1+2). Formulas are hidden and show up only in the edit box. The spreadsheet merely shows the result of the 
equation (e.g. 3 in the previous example).

Numerical data may be entered in one of three formats:
1) in floating point format (e.g. 1.23e-5).
2) in "time" format hh:mm:ss, where hh=hours, mm=minutes and ss=seconds. hh,mm and ss may be floating  
point. The latter is useful only to enter fractions of a second (e.g. 0:0:0.66). The "time" format may not be used in 
formulas. Hence "12:30:00" is OK, but "=12:30:00" is not. In stead, use the time() function to enter time data in 
formulas.
3) a date may be entered as "dd/mm/yyyy", where dd=days is an integer value between 1 and 31, mm=month is 
an integer value between 1 and 12 and yyyy is the year. The "date" format may not be used in formulas. Hence 
"24/02/1999" is OK, but "=24/02/1999" is not. In stead, use the date() function to enter date data in formulas. 
 
Selecting multiple cells. 
There are  two  ways  to  select  multiple  cells.  i)  Click  on  a  cell  and,  while  maintaining  the  left  mouse button 
depressed, move the mouse pointer. ii) Click on a cell and release the left mouse button. Then press the shift key 
and  click  on a  second cell,  release the left  mouse  button and release the shift  key.  Now multiple  cells  are  
highlighted.

Selecting rows.
Click on a row key (showing the row index). To select multiple rows, click in a row key and move the mouse while 
keeping the left mouse button depressed. A second way to select multiple rows is to click on a row key and then  
on a second key, while depressing the shift key on your keyboard.

Selecting columns.
Click on a column key (showing the column index). To select multiple columns, click in a column key and move the  
mouse while keeping the left mouse button depressed. A second way to select multiple columns is to click on a  
column key and then on a second key, while depressing the shift key on your keyboard. The third way is to click  
on a column key and then to click on other column keys while keeping the control key depressed. This option is  
available only for multiple column selection and results in a selection of columns that is not contingent.
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Formulas
Create equations by typing the "=" character as the first character in a cell. After having saved the spreadsheet on  

disk, the file may be imported in Microsoft Excel. Most of the functions, though not all, will be 
recognised by Excel. The following math functions are supported in XL-Plot:

+ addition (e.g. =1+2)
- subtraction or negation
* multiplication
/ division
** or ^ power (e.g. 2**3)
AND or & logical AND
OR   or | logical OR
NOT or ~ logical NOT
>= larger than or equal, returns 1 (true) or 0 (false)
<= smaller than or equal
= equals (returns 1 if equal, else returns 0)
> larger than (e.g. 5>2 returns 1 (true))
< smaller than
cin returns the column index of the spreadsheet cell
lin returns the line (row) index of the spreadsheet cell
sqrt(v) or sqr(v)  square root of v (e.g. =sqr(4))
exp(v) exponential of v
ln(v) natural logarithm of v
log(v) decimal logarithm of v
pi returns half the circumference of a circle with unit radius
rand(v) returns a random number between 0 and v
sin(v) sine of v, argument in radians
cos(v) cosine of v
tan(v) tangent of v
asin(v) arcsine of v, returns angle in radians
acos(v) arccosine of v
atan(v) arctangent of v
sign(v) sign of v, returns -1 or +1
int(v) returns the integer value of v
min(range) minimum  value  of  the  range  of  spreadsheet  cells,  where  range  is  of  the  form:  

"Cn:Lm,Cnn:Lmm" with n,m,nn and mm being indices of columns "C" or lines "L".
max(range) maximum of the range of cells
cimin(range) returns the column index of the minimum of the range of cells
limin(range) returns the line(row) index of the minimum of the range of cells
cimax(range) returns the column index of the maximum of the range of cells
limax(range) returns the line(row) index of the maximum of the range of cells
sum(range) sum of the range of cells
average(range) average of the range of cells
mean(range) synonym of average
stdev(range) standard deviation of the range of cells
sem(range) standard error of the mean of the range of cells
erf(v) error function of v. (twice the integral of the Gaussian distribution with 0 mean and variance of  

½).
erfc(v) the complementary error function (1-erf(v)).
erfcx(v) the scaled complementary error function.
cell(c,l) returns the numerical value of the spreadsheet cell at column c and line l. If the cell contains 

text, if the cell is empty or if the formula it contains is erroneous, the function returns 0 (zero). 
binom(n,k) returns the coefficient of the k'th term of an n-binomial.
gamma(x) returns  gamma(x).  Gamma  has  the  properties:  gamma(n+1)=n!  and  x*gamma(x)  = 

gamma(x+1).
chidist(c2,df) returns the probability of a chi-2 at df degrees of freedom.
tdens(t,df,s) returns the probability-density of the t-function for t at df degrees of freedom, single sided 

(s=1) or double sided (s=2).
tdist(t,df,s) returns the probability of  a t-value at df degrees of freedom, single sided (s=1) or double 

sided (s=2). It is the integral of tdens(t,df,s).
fdens(x,df1,df2) returns the probability density of Fisher's F-function for x at df1 (data sets) and df2 (total N-1) 
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degrees of freedom.
fdist(x,df1,df2) returns the probability for a F-value (x) at df1 and df2 degrees of freedom. It is the integral of  

fdens(x,df1,df2).
qprob(q,df1,df2) returns the probability for a q-value at df1 and df2 degrees of freedom (multiple comparison 

test).
time(h,m,s) takes three parameters h (hours), m (minutes) and s (seconds)  and returns the "time" format: 

"h:m:s". h,m and s may be floating point. Hence "=time(1.5,0,0)" returns "1:30:0".
date(h,m,s) takes three parameters d (days), m (months) and y (years)  and returns the "date" format:  

"d/m/y".
hour(h) interprets h as hours and sets output to the "time" format. Hence "hour(0.5) returns "0:30:0".
minute(m) interprets m as minutes and sets output to the "time" format.
second(s) interprets s as seconds and sets output to the "time" format.
date(d,m,y) takes three parameters d (days), m (months) and y (years)  and returns the "date" format:  

"d/m/y".
year(n) returns the duration in days of n years. The return value depends on context and defaults to 

365.
month(n) returns the duration in days of n months. The return value depends on context and defaults to 

30.
float(v) converts v, if it is in "h:m:s" or d/m/y format, to a floating point number (in seconds and days  

after  31/12/0  respectively),  otherwise  it  does  not  do  anything.  Hence "=float(time(0,1,1))" 
returns "61".

ctime this is a macro that is replaced by the current time. It takes no aguments. Hence, "=ctime" 
returns for example "18:24:06".

cdate this is a macro that is replaced by the current date. It takes no aguments. Hence, "=cdate"  
returns for example "18/14/1996".

sbar(mi,c,ma) displays a horizontal slidebar in the spreadsheet cell. The slidebar cursor can be moved by 
the user. This function returns a value (c) between the minimum value (mi) and the maximum 
value (ma) depending on the position of the cursor.

  
How to enter the range of cells or a reference to a single cell in a formula.
Several functions such as SUM() and SEM() require a range of spreadsheet cells as argument. There are two 
ways to enter such a range in a formula:
 i) Type it (e.g. "mean(C2:L2,C2:L300)", N.B.: do not type the quotation characters), or 
ii) in the spreadsheet edit box type "=mean(" and place the cursor behind the bracket "(". Then right-button-click  
the first cell of the range in the spreadsheet and move the mouse while keeping the right mouse button depressed.  
Release the mouse button at the last cell to be included. The range selected for the function appears in the edit  
box, the closing bracket ")" is added and the corresponding cells in the spreadsheet are highlighted in yellow.  
Many functions, like sin(), only demand a single parameter. If you wish this parameter to be a reference rather  
than a number, type for instance "=sin[C2:L3]". A second way to enter the reference is the following: in the edit  
box type "=sin" (a bracket is not necessary here), then right-button click the cell that contains the argument. The 
text string  will  then read: "=sin[Cn,Lm]",  where  n and m are  the  indices of  the cell  containing  the  argument.  
Observe that the type of bracket used is not important for the mathematical result: "{", "(" and "[" are OK. However  
for mouse-editing they make a difference: only the reference to a single cell is entered after a square bracket "[" or  
any symbol other than "{" or "(", whereas a range of cells will appear after "{" or "(". 

How to modify the range of cells in a formula.
Again there are two ways to do this: i) re-type the new range, or ii) Click on the cell containing the formula. In the  
edit box, place the cursor anywhere between the brackets delimiting the function's argument. Then right-button-
click the new first cell in the spreadsheet and move the mouse while maintaining the right button depressed. The 
new  range  replaces  the  old  one  automatically.  The reference  of  single-argument  functions  can  be changed 
similarly.
 
What happens if you copy and paste a formula?
If  you paste a formula onto a cell  in the same or another spreadsheet, the column and line (row) indices are  
incremented or decremented such that the relative distance between the cell that receives the formula and the 
cell(s) the formula is referring to remain(s) the same in the original and the copy. An example explains this more  
clearly. Say a cell at column 2, line 3 contains the formula "=SIGN[C1:L5]". After having copied the cell you paste 
it at column 2, line 4. The formula in the receiving cell will then read: "=SIGN[C1:L6]". If you don't want the index to 
change when pasting, put a "$" sign in front of the index in the original cell (e.g. "=SIGN[C1:L$5]"). 
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What will happen to references if you delete or insert spreadsheet cells?
If a (number of) cell(s) is deleted or inserted, the cells below or to the right of the deleted/inserted cell(s) will shift  
position. The references contained in the shifted cells are updated such that they still refer to the same cell as 
before, with one exception: cells referring to deleted cells will not be updated. Hence, the former cells will refer to 
cells that have taken the position of the deleted cells. XL-Plot does not warn you of such a mishap, unless the  
formula containing the reference has become nonsense (not because it can not detect such events, but to prevent 
overclicking). 
 
How to create a function that depends on a running index.
Either the current column index or the current line index can be used as a running index to create "functions". To 
do this use "cin" (column index) or "lin" (line index) in your formula e.g. "=sqrt(3+lin*3) will result in "3" if the cell  
containing the formula is at line 2. It will return "6" if it is at line 11.
 
What is the function "cell()" good for?
Cell(c,l) retrieves the contents of a cell at column c and line (row) l. As c and l may be functions themselves, the  
indices may thus be the result of a calculation or a Boolean expression.

Self-referencing
Self  referencing  as for  example  in "=1+cell(cin,lin)",  is  not  recommended and in general  will  be  punished  by 
unpredictable  results.  However,  no error  message  is  issued, since it  is  possible  to  construct perfectly  stable 
systems of cells that contain self references or circular references. 

Calculations in date format
The program internally stores date data as the number of days since 31st Dec of the year 0 according to the  
Gregorian calendar. This number of days may be retrieved using the function "float()". In general, math operations 
on dates give results that are not meaningful. There are a few exceptions. Suppose two spreadsheet cells, (C1:L1)  
and (C2:L1), each contain a date, then "=float((C1:L1)-(C2:L1))" returns the difference in days between the two  
dates. With the functions year(n) and month(n) one can add (or subtract) a certain number of years or months to  
(from) dates. Hence, if cell (C1:L1) contains a date, say 12/10/1999, then the expression "=(C1:L1)+year(2)" will  
return 12/10/2001. The addition of dates, years, months and days is neither commutative nor associative. As the 
program's formula parser supposes the normal associativity and commutativity rules, the user should explicitly  
indicate the order in which math operations have to occur. For example "=(C1:L1)+year(2)" will not give the same 
result  as  "=year(2)+(C1:L1)".  Typing  "=(C1:L1)+year(2)+month(1)"  is  dubious  since  the  parser  may  first  add 
year(2) and month(1), applying the normal associativity rule for addition, before adding it to the date. To be sure of  
the result type "=((C1:L1)+year(2))+month(1)".

Slide bar
A  horizontal  slidebar   is  displayed  in  a  spreadsheet  cell  when  using  the  function 
"=SBAR(minimum,current value,maximum)". Minimum and maximum set the range of values the current value (or  
cursor position) may adopt. The initial "current value" is immaterial, but may not be left blank. The sbar() function  
may be part of a more intricate formula, e.g. "=1+sbar(0,5,10)", but it should appear only once in a spreadsheet  
cell. The resolution of the slidebar is 1/100, therefore clicking on one of the two gadgets  at the extremities of 
the slide bar  will  increment or  decrement the  current  value by 1% of  the difference between  maximum and 
minimum. Clicking between an endpoint gadget and the central cursor will change the current value by 10%. The  
central cursor may be moved by dragging it with the mouse. As with all other spreadsheet functions, the sbar()  
arguments may be functions or references. However, it is useless to assign a function or reference to "current  
value" as it will be replaced by a floating point number as soon as the user actions the slidebar.
The output of a spreadsheet cell  containing a slidebar may be used for example as a parameter in a function  
defining a column of spreadsheet cells. If this column is linked to a graph on a drawing sheet, then moving the 
slidebar cursor will change the data in the spreadsheet and hence the graph. See the "getting started" section for  
an example.

The Edit menu.
The edit  menu allows you  to copy,  paste,  delete  and otherwise  manipulate data in  the  spreadsheet.  As the 
functions of most of the menu items is self evident, they will not be described here. Even so, a few points merit  
attention.
* When pasting the clipboard contents on the spreadsheet, it suffices to click the top left cell where you wish to 

paste. The structure of the clipboard contents will determine how many cells will be modified.
* When pasting on the spreadsheet after  having highlighted entire  rows or  columns,  the paste  becomes an 
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"insert/paste". This is not a bug, but a shortcut. 
* Copy vs. Copy values. When copying text from a spreadsheet cell you copy the text you have previously entered 

in the cell.  This text  might have been a formula (e.g.  "=exp(-20*[C1:L1])"). If you paste the contents of the 
clipboard, the new cell will contain "=exp(-20*[Cn:Lm])", where n and m will depend on source and destination. If  
you wish to copy (and thus paste afterwards) the numerical result of the equation rather than the equation itself,  
use copy values. Note that this is a slightly different approach than used by Microsoft Excel, where you make this 
choice upon pasting rather than upon copying.

* Copy L <--> C copies the selection, interchanging columns and rows.
* Delete removes cells from the spreadsheet, while Clear replaces them by empty cells.
* When deleting, be aware that references to the deleted cells may not be valid anymore. XL-Plot does not protest,  

unless formulas really make no sense.
*  When  using  the  Replace menu  item,  formulas  will  be  affected  too.  Hence  "Replace  4  by  7"  will  change 

references if they contain the number 4.
* Select All selects the whole spreadsheet.
* The Remove Links item will remove all links with the selected columns in all graphs in all drawing sheets. To  

remove the link with only one graph, select the graph and then choose the  Edit>Remove Link item from the 
drawing sheet menu. More on links in the paragraph "How to deal with links between spreadsheets and drawing 
sheets" at the end of the document.

* The Save Prefs menu item writes the current window settings (in this case just its size) to disk. Newly created 
windows will have this default size.

The Fill menu
In order to copy the contents of a single cell to a range of cells use the  Fill>right   commands or the  Fill>down 
commands.  First,  left-mouse-button select a range of cells and then issue one of the commands from the  Fill 
menu.
Right copy will copy the contents of the left-most cells to the right. 
Right value will copy the numerical value (rather than the formula, if be) to the right. 
Right increment will copy the numerical value of the left-most cell to the right, incrementing by 1 as it proceeds to  
the right.
Right decrement does similarly, but decrementing by 1.
Right interpolation fills empty cells (and only empty cells) by interpolating between the numerical values of non-
empty cells that need to be contained in the highlighted selection. If the beginning and/or end of the range of  
selected cells is empty, extrapolation is carried out if possible. Extrapolation is carried out only if the highlighted 
selection of cells contains at least two non-empty cells. Cells containing non-numerical text are considered to 
represent the value 0 (zero). 
If you wish to carry out the same fill command with another selection of cells, right-mouse-button select the new 
range and the last issued fill command will be carried out automatically. Note that right-mouse select applies to the 
fill menu only. Hence, it does not repeat for instance a previous Edit>delete action. Use the repeat icon in the icon 
bar or Edit>Repeat last from the menu to repeat edit actions. 
The Fill>down commands behave analogously by copying the contents of the top-most cell(s) downward.
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The Modify/Data menu

Line Plot and Bar Plot
These menu items are used to create a graph on a drawing sheet. Before issuing one of these two commands you 
need to indicate which of the columns contain the data to be plotted. There are two ways to do this:
Method 1) select  a column that  contains data for  the x-axis by clicking  on the column key at  the top of  the  
spreadsheet and then select Modify/Data>Set X-column from the menu. Then select a column that contains the y-
data and choose Modify/Data>Set Y-column from the menu. Optionally, you may select a column that contains 
values for the error bars (a symbol whose size indicates the statistical error in the associated y-data point) by  
choosing the Modify/Data>Set Error-column from the menu. Hence, this method allows you to select at maximum 
three columns, but the order of the columns is unimportant.
Method 2) select a number of columns that you wish to use for your graph. If  you issue the Plot command a  
dialogue window will pop up asking you to specify which of them contain x, y or error data. Here the order of  
columns is important. An x-column (there may be more than one) has to precede the associated y-columns. An 
error column refers to the column preceding it. Hence, if column 1 contains x-data and column 2 error data, the 
error bars will be plotted horizontally as they are assumed to refer to errors in the x-data. Two x-columns have to 
be separated by at least 1 column containing y-data. 

  Use the left and right button in the dialogue box to go to the next or previous column.
Create histogram in a   new document or on the   clipboard. By default, the histogram will  be created in a 
drawing window of its own. To transport the new histogram to another drawing sheet, select the histogram by  
clicking once on it, then copy or delete it (^c or ^x or the copy or delete command from the Edit menu) and paste it  
(^v or the paste command from the Edit menu) onto the other drawing sheet. If you select the "create histogram on  
clipboard" option, the histogram will be created on the clipboard. This is, however, less intuitive as nothing seems  
to happen until you issue the paste command after having selected a drawing sheet.
After being drawn, the graph will be linked to the columns in the spreadsheet, meaning that a modification in one  
of the columns will alter the graph.

 Columns that maintain a link with a graph are marked by a '°' character in front of the column index.  
The link can be removed by either clicking on the graph and selecting Edit>Remove Link from the drawing sheet 
menu or by selecting the columns and selecting Edit>Remove Links from the spreadsheet menu. The latter action 
will also remove links with other graphs on other drawing sheets if they exist. More on links in the paragraph "How  
to deal with links between spreadsheets and drawing sheets" at the end of the document.
  
Creating graphs with the X-axis labels in time or date format.
If a new graph is created from spreadsheet columns, where the column furnishing the X data is entirely in time or  
date format, then the X-axis labels will be in time or date format too. Double clicking on one of the axes in the  
graph will activate the Axes dialogue box as usual. Note however that the x-coordinates are now in time or date 
format. If the user enters a floating point number (rather than a time or a date) in one of the X-axis edit boxes, then  
a new dialogue box will pop up upon exit of the Axes dialogue box. In this box the user indicates if the graph  
should remain in time/date format or should be converted to floating point (seconds/days). To convert the X-axis  
from floating point (seconds/days) to time/date format do similarly (hence type at least one entry in time or date  
format).
If the graph's X-axis is in date format, the Axes dialogue box is slightly different from the usual one in that the  
major and minor tick size should be entered in multiples of years (y), months (m) or days (d). Since the length of  
years and months is not constant (leap years, February is shorter than December) this results in non-equidistant  
ticks in the graph.

Frequency histogram
Creates a  frequency histogram or  a  probability-density  histogram of  the  currently  selected  column. Only one 
column can be selected for this option. In the dialogue window that pops up, the minimum value and the maximum 
value in the column are indicated along with a suggested number of classes (bins) for the histogram. This number  
of classes is estimated using the formula: Nclass=1 + 3.322 10log(N), where N is the number of data points in the 
spreadsheet  column. Check  the "normalise"  box  if  you wish  to  create  a  probability-density  function,  leave  it 
unchecked otherwise.

Create polygon
To create a polygon for use on a drawing sheet, select two columns of data, the first containing the x-coordinates 
(in screen pixels) and the second containing the corresponding y-coordinates. Alternatively, the x and y columns  
may be selected using the  Set X column and  Set Y column commands from the  The Modify/Data  menu. Then 
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choose Create polygon.
Example:

   x column:                y column:

=10*cos(0.5*pi)     =10*sin(0.5*pi)
=10*cos(1.3*pi)     =10*sin(1.3*pi)
=10*cos(0.1*pi)     =10*sin(0.1*pi)
=10*cos(0.9*pi)     =10*sin(0.9*pi)
=10*cos(1.7*pi)     =10*sin(1.7*pi)
=10*cos(0.5*pi)     =10*sin(0.5*pi)

gives as result:      
A few other examples are included in the file: "polygons.txt" in the program directory.

Note that the X&Y coordinates of polygon (in screen pixels) on a drawing sheet may be copied to a spreadsheet  
using the copy and paste icons on the program icon bar.

Get Column Stats
After having selected one or two columns, this menu item pops up a box showing statistics of  the column(s) 
including mean, estimation of the standard deviation, error of the mean and, in case of two columns, the Student's 
t-test probabilities. If the number of columns selected is larger than 2, the result of Fisher's F-test is returned (1 
way anova). If the F-test gives a probability below 5%, then Tukey's multiple comparison test (q-test) is carried out  
as well. Paste the data on a spreadsheet (after having closed the dialogue box) to get all the statistics.
 
Resize column/line length
Graphs that contain a lot of data points (>5000) slow down the process of data manipulation and in general are 
rather useless. If a link between the graph and columns in the spreadsheet exist, the number of data points can be 
reduced by choosing Modify/Data>Resize column/line length from the menu. The number of data points will be 
reduced either by removing every n-th data point or by averaging n points to give a single point in return. You can  
select the final number of points in the selection of spreadsheet cells (and hence the graph) by indicating it in the  
dialogue window that pops up.
 
Sort numerical data
Numbers in a range of selected spreadsheet cells can be sorted in ascending or descending order using this  
menu item. A dialogue window will ask you to give these details. If spreadsheet cells in more than one column are  
selected, the cells in the "key column" will be sorted and the data in the neighbouring cells in the same row (line)  
will be moved upwards or downwards along with the data in the "key column". 

For the Do Fit and the Set Fit function items see the "Fitting a function to data" topic.
 
Set Column Widths
The column widths in your spreadsheet can be changed by placing the mouse cursor between two column keys.  
The mouse cursor will change shape. Now press the left mouse button and drag it to the left or the right. A vertical 
line will  appear,  indicating the new width. Release the mouse  button.  This  way the size  of a  single  column 
changes. In order to modify the widths of all columns homogeneously, use the Modify/Data>Set Column Widths 
from the  menu.  A dialogue window will  pop  up.  Fill  in the width in number of screen pixels  (default  60).  All 
columns, not only those selected, will adopt the new width.

Set Line Heights
The line heights in your spreadsheet can be changed by placing the mouse cursor between two line (row) keys. 
The mouse cursor will change shape. Now press the left mouse button and drag it up or down. A horizontal line  
will appear, indicating the new height. Release the mouse button. This way the size of a single line changes. In 
order to modify the heights of all rows homogeneously, use the Modify/Data>Set Line Heights from the menu. A 
dialogue window will pop up. Fill in the height in number of screen pixels (default 20). All rows, not only those  
selected, will adopt the new height.
  
Fourier transform
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The Fourier transform of data contained in 1, 2 or 3 columns can be taken and will be returned in the form of new  
columns of data in the same spreadsheet or as a graph on a drawing sheet (depending on your choice in the  
dialogue window that will appear after selection of this menu option). If the data points are not equidistant, you 
need to  provide a column of  x-data.  These x-data  are then used to create columns of  equidistant  points  by 
interpolation before the transform is taken. Therefore, data points are equidistant upon return. Forward Fourier  
transformation (from the time domain to the frequency domain) is assumed, unless a column of x-data is provided 
that mentions the x-unit: "mHz", "Hz" or "KHz" in the spreadsheet cell just above the column of numerical data.  
Note that inverse transformation (from the frequency to the time domain) of columns that lack imaginary data may 
lead to  results that  have no physical meaning.  For the forward transform, a column of  imaginary data  is not  
required. When issuing the  Modify/Data>Fourier transform command, a dialogue window pops up that asks to 
specify which column contains the x, real and imaginary data. 
  
(de-)Convolution
This  menu  command  takes  two  columns  in  the  spreadsheet.  If  the  two  columns contain  identical  data,  the 
convolution of the columns will result in the auto-correlation function, while if they contain different data, the result  
will be the crosscorrelation function. If the two columns have different length, the shorter column will be padded 
with zeroes. For (de-)convolution one has to specify which of the two columns is the template. The method used 
here for both convolution and deconvolution makes use of the convolution theorem: It states that if  g(t) is the  

convolution (¤) of  x(t) and y(t), then the Fourier transform of  g(t) , G(f),  is the product of the Fourier transforms of  
x(t) and y(t), or:

if  g(t) = x(t) ¤ y(t) then G(f) = X(f) . Y(f) 

and hence g(t) =F-1{ X(f) . Y(f)}, where F-1 stands for the inverse Fourier transformation.
Now, if x(t) is the template and g(t) the data, than we can deconvolve g(t) to get y(t) with: y(t) = F -1{ G(f) / X(f)}. 
Because of the use of the Fourier intermediate, the data are considered to be periodic and the result  will be 
periodic too.

 
 Invert augmented matrix
This  option allows you  to  solve a  system of  N  linear  equations  with  N unknowns.  If  you select  a  range of  
spreadsheet cells that contains the N*(N+1) augmented matrix, make sure that the dimensions (N lines and N+1  
columns) are correct. If not, it is assumed that the entire spreadsheet is intended to be inverted. As the result of 
the inversion will be pasted in-place, the data in the entire spreadsheet will be modified. As an example, suppose  
there are three unknowns a=1, b=2 and c=3 and you have three equations: 2a+3b-c=5, a+b+c=6 and -2b+3c=5. 
Fill in the matrix as follows:

After inversion the result will be:

The last column lists the result: a=1, b=2 and c=3.

25



The drawing sheet

The primary function of the drawing sheet is to display graphs that you have created using a spreadsheet. In  
addition  to this  function,  you can  draw rectangles, circles,  lines and  add text  to your  graph  to complete  the 
presentation of the data. The graphical elements ("objects") of the drawing sheet are stored internally as vector 
drawings (as opposed to bitmaps) and can be exported to other vector drawing programs by copying a selection 
of  objects in  XL-Plot (^c or  Edit>Copy from the menu or clicking the copy icon),  followed by a "paste" in  the 
receiving program. An other way to export the contents of the drawing sheet to a third party program is to save the 
graphs in Windows metafile format  and reload them in the receiving program (see the  "Saving  data"  section 
further down in this file).
A blank drawing sheet can be created by using the File>new menu option. An existing drawing sheet is read by 
using the File>open option from the menu or clicking the open file icon. From the open file dialogue window select  
type=Histogram files *.his.

How to select a graphical object.
An object is selected by clicking once on it. Eight little squares then mark the bounding rectangle (selection box) of  
the selected object. By clicking on empty space between objects,  the previous selection is abolished and the  
selection box disappears. 

How to select multiple objects.
Multiple objects can be selected by pressing the shift key on your keyboard, while clicking once on each object to  
include. To un-select an object in a list of selected objects, click once again on the object you wish to exclude from 
the selection, while maintaining the shift key depressed. A second way to select multiple objects is to depress the 
right mouse button and dragging the mouse while keeping the button depressed. All objects that are entirely within 
the rectangle that now appears will be selected. To select all objects in the current layer, choose Edit>Select all 
(Ctrl A) from the menu.To select all objects on the sheet, choose Edit>Select all layers (Ctrl W) from the menu.

How to move objects.
Click once on the object you wish to move, thereby selecting it. Then click again and, while maintaining the right  
mouse button depressed, drag the object to the new location on the sheet. Multiple objects are moved similarly.

How to size objects.
Select the object. It has 8 little squares around it. If the mouse cursor gets over one of them it changes into a  
vertically, horizontally or a diagonally pointing pair of arrows. Depress the right mouse button and drag the pointer 
until the object has the appropriate size. Use the corner squares to change dimension in two directions and use  
the other squares to change size in one direction only. If you are sizing objects such as squares or circles, you  
may wish that the bounding rectangle remains or becomes a square. Press the shift key while dragging to do so,  
release the shift key only after having released the mouse button. In order to maintain the original proportions of  
the object, press the control (Ctrl) key and release it after having released the mouse button. N.B. If multiple  
objects are selected,  the  effects of  the shift  and the control keys will  apply to the bounding rectangle of  the 
ensemble of objects rather than each individual object. If text is sized, the result will be the best approximation 
given the constraints of the true-type character set of the text object in question. 
Sizing graphs.
Graphs behave like other objects in this respect with one exception: data-point symbols (squares, circles) will keep 
their original sizes. Text on the graph axes will  also change size, unless the   Fix text size box in the Axes 
dialogue window has been checked or the Enable text sizing item in the Tools menu has been unchecked.
Sizing lines
Sizing lines is slightly different from other objects. When selecting a line segment, only two little selection squares 
appear at the ends of the line. If the mouse cursor moves over one of them it changes into a cross. Depress the  
right mouse button and drag it. The end of the line segment will follow the cross. If the shift key is pressed while  
dragging, the line will become horizontal, vertical or will make an angle of 45° with the x-axis, depending on how  
close it was to one of those conditions when the shift key was pressed. The control key has no effect here. 
Sizing text
If text is sized, the result will be the best approximation given the constraints of the true-type character set of the  
text object in question. Often one wishes the text size to be identical in all objects on the sheet. To prevent text  
from scaling each time an object is sized, disable (uncheck) Enable text sizing in the Tools menu.
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The drawing tool window.

Whenever the window of a drawing sheet is activated (e.g. by clicking on it) its menu replaces the previously  
displayed menu in the main window and the drawing tool window pops up. The name of the file associated with 
the drawing window is shown in its title bar. The drawing tool window contains a series of buttons that allow you to  
draw objects or to modify their appearance. The larger buttons in the upper row are for modification, while the 
smaller ones in the lower row are mostly for creation. The function of each button will be described in detail below.
 

 This is the default tool upon activation of a drawing window. It is used to select graphical objects on the sheet,  
to move and to size them using the left mouse button. When drawing a line onto the drawing sheet using the right 
mouse button while in 'arrow tool' mode, the coordinates of the extremities of the line and it length (in cm) will be  
transferred to the bottom line of a spreadsheet. Hence, this tool can be used to measure and record distances on  
the drawing sheet. The coordinate [0,0] is located in the top left corner. If no spreadsheet is open, a new one will 
be created. If a single spreadsheet is open, the data will be pasted on that one. If more than one spreadsheet is  
open, a dialogue window will allow choosing between them or to create a new one. It is also possible to select a  
spreadsheet prior to transfer, or to change spreadsheet later, using the Transfer manual input to ... item from the 
Tools menu.
 

 Use this tool if you wish to include text in the drawing sheet. The cursor changes shape. The default true-type  
character set (font) will be used, unless you click on a location that already contains text. In the latter case the 
original font will be used and text can be modified. You remain in "text mode" until another tool in the drawing tool 
window is selected.  
 

  Use this tool if you wish to draw a line. The cursor changes shape. After having drawn a line, the default tool 
(the arrow pointer) automatically replaces it. In order to draw a perfect horizontal, vertical or diagonal line, depress 
the shift key on the keyboard while you draw a line.

 Use this tool to draw a polygon. With each right-mouse click a node is added. To stop adding nodes, either  
click (once) on the first node or double-click. The former method creates a closed figure. In order to draw perfect  
horizontal, vertical or diagonal lines, depress the shift key on the keyboard while you draw the polygon. A polygon 
can also be created using the Create polygon command from the spreadsheet menu.

To edit an existing polygon, double-click on one of its line segments. Instead of the usual selection box which is  
marked by eight little squares, the polygon object is highlighted by having little squares at each of its nodes. In  
addition the mouse pointer changes shape: 

 In this (move node) mode, each of the nodes can be moved independently of  the rest of the polygon by  
dragging it with the mouse.
Right clicking the mouse changes the mouse pointer successively into:

 This is the delete node mode. Left-clicking on a node will remove it from the polygon. To delete multiple nodes, 
draw a rectangle around them.

 This is the add node mode. Left-clicking on a polygon segment will add a node to the polygon.

 This is the cut polygon mode. Left-clicking on a polygon segment will cut the polygon in two.

When in polygon edit mode, use "undo" from the menu to undo the last move, addition or deletion.

Click the  button to quit the polygon edit mode. Then use "undo" from the menu to restore the original polygon.

 Use this tool to draw a transparent (open) rectangle. In order to draw a perfect square, keep the shift key 
depressed while you draw. The cursor changes back into the pointer tool after having drawn the rectangle.
 

 Use this tool to draw a filled (closed) rectangle. In order to draw a perfect square, keep the shift key depressed 
while you draw. The cursor changes into the pointer tool after having drawn the rectangle.
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 Use this tool to draw a transparent (open) ellipse. In order to draw a perfect circle, keep the shift key depressed 
while you draw. The cursor changes into the pointer tool after having drawn the ellipse.
 

 Use this tool to draw a filled (closed) ellipse. In order to draw a perfect circle, keep the shift key depressed  
while you draw. The cursor changes into the pointer tool after having drawn the ellipse.
  

 With the magnifying glass you can zoom in into a particular scene of the drawing. The centre of magnification 
will be where you left mouse click on the sheet. To zoom out right mouse click on the sheet. The tool will remain 
the magnifying glass until you select another tool. Besides using the magnifying glass, one can zoom in by typing 
^f (control F) or zoom out by typing ^b (control B).
  

  XL-Plot uses 8 bit indexed colour bitmaps having palettes that may be different for each drawing window 
and that may be modified by the user. To find out what are the colour and the colour index of a particular pixel on  
the sheet, use the pipette tool. When clicking on a location on the sheet, the box right of the pipette tool (the 
colour index box) will indicate the colour and its index. The pipette will stay until another tool is selected. If you 
select an object on the drawing sheet using the pointer tool and then right mouse click on the colour index box, 
then the fill colour of the selected object will change into the pipette colour.  Left mouse clicking on the colour 
index box will change the border colour of the object. 
  

 Has the same effect as the menu item Tools>Text Font. If no objects on the drawing sheet are selected, this 
option will allow you to set the default true type font. If a (text) object is selected it will allow you to change its font.  
When editing a text object, an alternate dialogue window pops up allowing insertion of special characters, such 
as ± or ².

 If  a text object is selected, this option will rotate the text 90°.
  

 Has the same effect  as  the  menu item  Tools>Align.  Use  this  button to  align and/or  redistribute multiple 
selected objects. A dialogue window pops up in which you can specify the alignment. The following alignment 
rules are observed:
1) If  "line width" is unchecked, the floating point coordinates of the extremes (left-most, top-most etc.) of  the 
object are used for alignment. If "line width" is checked, half the line width (=pensize) is added to the extremes for  
alignment.
2) Text bottom alignment refers to the imaginary line the text is sitting on, ignoring eventual underhang (as in the 
letter "g"). Hence the letters "a" and "q" will be aligned conventionally as in this text. Text top alignment will be  
carried out with respect to the upper limit of the bounding selection rectangle (the box on the sheet with the 8 little 
squares).
3) Redistribution is carried out with respect to the outer-most objects. 
  

 To change the colour of text, lines and border lines of objects click this button. A dialogue window displaying  
the  palette  associated  with  the  current  drawing  sheet  pops  up.  The  current  border  colour  of  the  object  is  
highlighted by a white square. If you click in one of the little squares the border lines of the object change colour  
and the dialogue window disappears.  The first  little box in the palette (index=0) is transparent.  Hence, it  will  
remove  the  border  lines  of  the object  (unless the object  is  a line or  text,  since the object  would  disappear  
altogether). If the selected object is an undissociated graph, the colour of the axes will change. To change the  
colour of other elements of a graph, double click on the element concerned. If this option is used while no object is 
selected, the default line colour will be changed. 
  

 To change the fill colour of objects click this button. A dialogue window displaying the palette associated with 
the current drawing sheet pops up. The current fill colour of the object is highlighted by a white square. Clicking in  
one of the little squares changes the fill colour of the object and the dialogue window disappears. The first little box  
in the palette (index=0) is transparent. Hence it will change a filled square into a open square. If the selected  
object is an undissociated graph, the fill colour may be changed by double clicking on the element concerned. If  
this option is used while no object is selected, the default fill colour will be changed.
 

 Use this tool to change the style of a line into a dotted or dashed one or to add arrow heads to the ends of a  
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line.
  

 Has the same effect as the menu item Tools>Pen Size. Click this button to change line width (pensize). A 
dialogue window pops up indicating the current line width of the object.  Upon selection of the new width, the 
dialogue window disappears.  If  the selected object  is an undissociated  graph, the line  width of  the axes will  
change. To change the line width of other elements of a graph, double click on the element concerned. If this  
option is used while no object is selected, the default pensize will be changed. Pen size is in computer screen 
pixels. When printing a drawing sheet the overall appearance of the design will  remain the same. Hence, the  
resolution may change when printing, but not the line width.
 

 If no object is selected, this box displays the current default background colour (here yellow), foreground 
colour (here blue) and the size and name of the current default true-type font ("Arial" in this example). If one or  
more objects are selected, this box indicates the properties of the object(s) selected. If you wish to change the 
border colour of a selected object into the current foreground colour, left mouse click in this box. To change the fill  
colour, right mouse click.

 When this tool is chosen, the arrow pointer changes into a  pointer and one can rotate the currently selected 
bitmap  using  the  mouse or  the  keyboard  arrows.  Using  the  arrows  will  change  the  angle  of  rotation  by  1' 
increments. Simultaneously pressing the control key will increase the increment to 45'.  The center of rotation is  
located in the center of the image. The actual angle of rotation (in degrees) is shown in the status bar (the lower  
bar of the program's window). The precision of rotation increases by removing the mouse pointer further from the  
center of rotation. The bitmap rotation mode remains active until another tool, such as the arrow tool, is selected 
from the drawing toolbox. See the Rotate item from the bitmap menu for further details and options.

 With this tool parts of bitmaps, polygons or associated objects may be dissected and copied in place. When 
clicking the tool, the cursor changes into a alternate arrow pointer. Use it to draw a selection rectangle onto the 
drawing sheet. Upon release of the left mouse button a new (associated) object will be created in place containing  
a duplicate of each object within the selection rectangle, also if it was part of an associated object. If the selection  
rectangle partly overlaps a bitmap or polygon, only that part of the bitmap or polygon will be duplicated that is  
within the bounding rectangle. Hence the main interest of this tool is to cut out and duplicate parts of bitmaps and 
polygons. If a single object is selected (highlighted by 8 small squares around it) prior to choosing the tool, only  
(part  of)  the  highlighted  object  will  be  duplicated,  ignoring  other  objects  that  might  be  within  the  selection 
rectangle.

 If a single bitmap object is selected, the drawing toolbox expands, showing this bitmap-specific tool. Its action 
is identical  to the  Bitmap>Adjust contrast menu item and allows for changing the contrast of  the image.  The 
"bitmap contrast" dialogue box displays one out of five available response curves or "profiles" that determine how 
the intensity of each pixel in the bitmap will be modified.

In the profile, current intensity runs from left (black) to right (white) and the new, modified, intensity runs from 
bottom to top. In order to increase contrast,  choose a slope larger than unity. Inversely, to decrease contrast  
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choose a slope less than unity. To invert the colours of an image choose a slope of -1. Other effects, such as  
solarisation, can be obtained with still other profiles, which may be of the user's design. Example:

To go to the next or to the previous profile, push one of the    buttons.  To modify the current profile do 
either of the following: 1) change slope and offset using the slide bars. Note that the slope changes polarity (from 
+1 to –1 or vice versa) when the slide bar cursor is in the middle. 2) Click on one of the nodes in the profile and 
move it up or down, while keeping the left mouse button depressed. 
Use the "Save" and "Load" buttons to save and load your profiles on (from) disk. Pushing the "default" button will 
restore the default profiles.

 If a single bitmap object is selected, the drawing toolbox expands, showing this bitmap-specific tool. An image 
consists of three colour layers: red, green and blue, which together define all the colours of the visible spectrum. 
With this tool the red layer may be moved with respect to the green and blue layers. When clicking the tool, the  
cursor changes shape. The red layer can than be moved by either displacing the cursor while maintaining the left  
mouse button depressed or by pressing the arrow keys on the keyboard. With the arrow keys on the keyboard the 
image is  displaced one  image pixel  at  the  time (this  may be larger  or  smaller  than  a  monitor  screen pixel). 
Pressing the control key at the same time makes the image move 10x faster. The tool remains active until an other  
tool, such as the default pointer, is selected.

 With this tool the green colour layer may be moved with respect to the red and blue layers.

 With this tool the blue colour layer may be moved with respect to the red and green layers.
For example, moving the red layer in the figure underneath to the left and the blue layer to the right gives:

How to change the colour palette.
The program uses 8 bit indexed colour bitmaps to display the contents of a drawing sheet. Each drawing sheet  

has its own dedicated palette. You may change drawing object colours by clicking the  or the  buttons in the 
drawing  tool  window or  by selecting the menu items  Tools>Outline  colour or  Tools>Fill  colour.  Whereas the 
drawing tool buttons only allow you to pick a colour, the menu items also allow you to modify the palette itself.  
After having selected one of the two menu items, a dialogue window pops up displaying the current palette. To 
save or load a palette, push the "save" or "load" buttons. A second window comes up requesting a "*.mpl" file  
name. Do not change the "*.mpl" extension. To revert to the program-defined default palette, push "default". To  
change the RGB (red, green, blue) values of one of the palette entries, click on a little coloured box in the palette.  
The selected box is highlighted by a white square around it and the box marked "old" now displays the selected 
colour along with its index number. Next move the Red, Green and Blue slide bars to change the colour. The new 
colour appears in the "new" box. To enter the new colour in the palette, push the "OK" button. To copy the colour 
from one index to another, carry out the following sequence: 1) Click the little box to be copied, 2) push the "from" 
button, 3) click the little box to copy to, 4) push the "to" button and finally 5) push the "Copy" button. To create a  
gradient of colours carry out the following sequence: 1) Click the little box that contains the starting colour, 2) push 
the "from" button, 3) click the little box where you wish to end the gradient, 4) push the "to" button and finally 5) 
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push the "Spread" button. Push the "Done" button when you're done editing.
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The Bitmap menu. 

Import bitmap
Windows bitmaps (*.BMP) and uncompressed TIFF bitmaps may be added to the drawingsheet using this menu 
option. A rectangular object with the proportions of the original image (but usually of smaller size)  will be created.  
The border colour and border line width can be changed as for rectangles. The image can be sized as the other 
objects. Press the control key while sizing if you wish the original proportions to be conserved.
To restore the height/width proportion, double click on the image. In the dialogue box that appears, change the  
horizontal and vertical resolutions to identical values or click one of the buttons "1/8", "1/4" etc. The button "1" sets  
the horizontal and vertical resolutions to the monitor screen resolution of 72 pixels/inch. The button "1/2" sets the  
image size to half (144 p/i) etc. Most printers have at least a resolution of 600 pixels/inch.
A second way to import a bitmap is by copying it from a bitmap editor such as Photoshop and pasting it on the  
drawing sheet. Bitmaps can be exported similarly or by issuing the command:

Save bitmap
This menu option is enabled if a single bitmap object is selected. Select the bitmap format in the first dialogue  
window that pops up. Note that the 16-bit bitmap (32768 colours, a Windows 3.x format) is now almost obsolete 
and most bitmap programs such as Photoshop and Corel Photopaint will refuse to load it. Enter a file name in the  
next dialogue window that pops up. Note the difference with the menu item "Copy window as bitmap".

Bitmaps can also be saved by clicking the   button or by pressing ^S (control S). While the menu selection 
prompts for the number of bitmap colours, the latter two actions assume the last used colour depth. Hence, these 
are shortcuts. Note that if no bitmap is selected, ^S will save the drawing sheet.

Copy window as bitmap
The current window or the entire drawing sheet is copied to the clipboard in windows bitmap (*.BMP) format when  
selecting this menu item. The resolution can be chosen in the dialogue box that will pop up. The contents of the 
clipboard may then be pasted in a program that accepts bitmaps (photo shop, corel photo paint etc) for further  
modification.

Rotate
This menu option is enabled only if a single bitmap object is selected. In the dialogue box that comes up, one of  
two options may be chosen: "freehand" or a specific angle of rotation. If freehand is chosen, then the arrow pointer 
changes into a  pointer and one can rotate the bitmap using the mouse. This option is equivalent to pushing the 

 tool in the drawing toolbox. The center of rotation is located in the center of the image. The actual angle of  
rotation (in degrees) is shown in the status bar (the lower bar of the program's window). The precision of rotation  
increases by removing the mouse pointer further from the center of rotation. The rotation mode remains active  
until another tool, such as the arrow tool, is selected from the drawing toolbox. 
Bitmaps are rectangular objects having horizontal and vertical borders. When rotating an image over for example 
45°, the pixel colours at the corners of the rectangle become undefined. These pixels will be attributed the colour  
marked as "fill colour" in the dialogue box. To change the fill colour push the "fill colour" button and select one in  
the second dialogue box  that  pops  up.  If  the "keep bitmap  size"  box  is  checked, part  of  the rotated image  
disappears because it lies outside the bitmap boundaries. Uncheck this box in order to replace the original bitmap 
by one that will be just as large as to contain the entire rotated image (apparent after the rotation is done).

Remove noise
This menu option is enabled only if a single bitmap object is selected. The bitmap is passed through a 3x3-pixel  
median filter.

Smooth
This menu option is enabled only if a single bitmap object is selected. The bitmap is passed through a 3x3-pixel  
(Gaussian) smoothing filter.
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Original + noise       Smoothing filter Median filter

Thresholding
In the dialogue window, that pops up after selecting this menu item, a graph representing the "intensity density  
histogram" is shown along with two vertical red lines. The density histogram shows how often pixels of a certain 
intensity (i.e. the sum of red, green and blue pixel values)  appear in the bitmap. In the histogram, intensity runs  
from left to right. The two vertical lines, that indicate the lower and upper thresholds, can be moved by dragging 
them with the mouse to the left or to the right. Pixels having intensities below the lower threshold or above the 
upper threshold will be replaced by the mask colour shown underneath the histogram. The mask colour may be  
changed by pushing the "mask colour" button. In that case a second dialogue window pops up, showing a palette  
from which a new colour may be chosen. This menu item is enabled only if a single bitmap object is selected.

Pseudo colours
The colours of a bitmap may be replaced by a pseudo colour gradient. In the dialogue window, that pops up after  
selecting this menu item, the gradient is shown on the left and three sets of three slidebars  on the right. 
With the slidebars the red (R), green (G) and blue (B) components of bottom, middle and top colours of  the 
gradient can be set. The middle colour settings will be ignored if the  box is unchecked. To see the effect of the 
settings on the currently selected bitmap check the "preview" box. Click "OK" to apply the pseudo colour gradient  
to the current bitmap. 
If a pseudo colour gradient had been applied to the bitmap before, the text underneath the gradient shows "This  
bitmap has pseudo-colours". In that case,  the gradient shown in  the dialogue box corresponds to the current  
bitmap gradient rather than the default gradient. The default corresponds to the last gradient applied to one of the  
the drawing sheet's bitmaps (allowing to apply the same gradient to multiple bitmaps) or, if none had been applied,  
the program default.
Pushing the "Make Bar" button creates a new bitmap object on the drawing sheet containing the gradient. This 
menu item is enabled only if a single bitmap object is selected.

Bitmap math
A few basic mathematical operations (addition, subtraction, multiplication, division, ANDing, ORing and XORing)  
can be carried out between two bitmaps using this menu option. After selecting the Bitmap math menu item, the 

dialogue window shown underneath pops up. Use the  buttons to choose the images. Offset and amplification 
of the brightness of the starting images can be set with the horizontal slidebars. Above the slidebars, a grey scale  

is shown to give an idea of how the colour distribution of the image will be affected. Click the  button to reset 
the offset and scale to default (0 offset, scaling 1). After the addition, subtraction, multiplication or division of the  
two bitmaps, post-amplification can be carried out with the "post scale" slidebar. Pushing the "preview" button will  
show the result. Bitmaps of unequal sizes will be aligned at the top left corner.
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Anaglyph/Merge
Two bitmaps can be combined into either a red-green or a red-blue anaglyph. If the two bitmaps depict the same  
scene  with  a  slight  parallax,  the  resulting  anaglyph  will  appear  to  be  three-dimensional  when  viewed  with  
red/green or red/blue glasses:
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The red colour component of a bitmap may be combined with the green colour component of a second bitmap and 
the blue component of a third with the "RGB Merge" option. If the three bitmaps were obtained for example from 
the same histo-chemical preparation using three differently coloured marker dyes, one red, one green and one 
blue, the resulting image will show the three markers superimposed:

To select the bitmaps for the operation push the  button in the "Set RGB bitmaps" dialogue window. Then push 

the  button to indicate that the current bitmap will provide the "red" information. The button will change into , 
indicating that the currently displayed bitmap will be used for the red component. Proceed similarly for the "green" 
and/or the "blue" bitmap. Prior to combining the bitmaps, their contrast profiles may be changed. To do so push  

one of the the  buttons. The "bitmap contrast" dialogue box, described above, pops up up, showing the contrast 
profile used in the previous "anaglyph/merge" session. The profile is marked "Red", "Green" or "Blue", depending 
on the colour of the button clicked. The contrast option is active if the  box is checked. The result, but not the 
original images will be affected by the contrast option.
The same bitmap may furnish the red, green and blue components, allowing to modify the contrast of each colour 
component separately or to create special effects.
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The Tools menu. 

The actions of the menu items in this menu are almost identical to those of the  Align,  Outline colour,  

Fill colour,  Text Font,  Pen Size and  Adjust contrast icons in the drawing tool box. In short: they allow 

you to align multiple objects, to change the (border-)line colour, the fill colour, true-type text font (size, bold etc.), 
the width of lines and bitmap contrast respectively.
In order to change the colour palette of the current (and only the current) sheet, choose either the Outline colour 
or  Fill colour menu item. Upon selection of one of these menu items a dialogue window pops up that contains, 
apart from the option to select a new colour index, several options to change the red-green-blue values of the  
palette entries.   

Flip vertically, Flip horizontally
These items from the Tools pull down menu are for transforming the currently selected objects into their mirror 
images. Text objects may change position if they are part of a multiple selection, but will remain normal readable 
text objects. Similarly, undissociated histograms will not be transformed in their mirror images, but may change 
position if part of a multiple selection.
   
Enable text sizing
If an object containing text is sized, the font size changes as well. To prevent text from scaling, uncheck this menu  
item.

Transfer manual input to ...
When drawing a line onto the drawing sheet using the  right  mouse button while in 'arrow tool' mode (i.e. after 
having selected the arrow tool from the drawing tool box) the coordinates of the extremities of the line and it length  
(in cm) will  be transferred to the bottom line of a  spreadsheet.  If  no spreadsheet is open, a new one will  be  
created. If a single spreadsheet is open, the data will  be pasted on that one. If more than one spreadsheet is  
open, a dialogue window will  allow choosing between them or to create a new one. It  is possible to select a  
spreadsheet prior to transfer, or to change spreadsheet later, using this menu item.

Alternate characters.

This dialogue window shows the alternate ASCII character set associated with the current text font.  Alternate  
characters can be inserted in a text object being edited by:
1) mouse-selecting a character and pushing the "insert" button or
2) typing the <Alt> code formed by the combination of the numbers in the first column and row. For example to 
insert a ±, type 0177, while maintaining the <Alt> key depressed. NB, the leading 0 should be typed also.
The insert button is disabled if no text object is currently being edited. Each drawing sheet has its own alternate 
character dialogue window, so many of them may be open simultaneously. The font in this window is updated  
each time a new text object is selected.
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The Edit menu. 

* After having selected a number of graphical objects, these objects can be copied to the clipboard by issuing the 
Edit>Copy command from the menu, typing "Ctrl C" on the keyboard or by clicking the copy icon in the icon bar on 
top of the main window. To paste the object(s) elsewhere on the drawing sheet or onto another drawing sheet,  
click once at the location on the sheet where the new object has to go and issue the Edit>Paste command from 
the menu,  type "Ctrl  V"  on  the  keyboard  or  click  the paste  icon in  the  icon bar.  If  the copied object  is  an  
undissociated graph, the coordinates of the data points may be pasted onto a spreadsheet as well. In the latter  
case, links between the spreadsheet columns and the data in the graph are established, such that a modification 
in the spreadsheet column will cause the graph to be redrawn with the new modified data. * To break the link with  
the spreadsheet, issue the Edit>Remove Link command from the menu. To delete objects, issue the Edit>Delete 
command from the menu, type "Ctrl X" on the keyboard or click the delete icon in the icon bar. The object has not  
disappeared altogether, as it has been copied to the clipboard. Hence it can still be pasted elsewhere. All objects 
on a drawing sheet can be selected by the  Edit>select all menu item (Ctrl A). This item is especially useful if  
objects have become invisible, extremely small or have been moved outside of the drawing sheet.
* Multiple objects can be grouped into a single composite object by the Edit>Associate command or by typing "Ctrl 
G" on the keyboard.  Edit>Dissociate or "Ctrl D" does the reverse, it dissociates a composite object into multiple 
objects. When dissociating a graph, it looses the possibility to have its axes or its data redefined and is reduced to 
a mere set of vectors. This dissociation of graph and the removal of its hidden data is irreversible.
Add Legend This menu item creates skeleton legend(s) to the currently selected histogram(s). The legend text 

may then be edited using the text tool .
* The order in which objects appear on the screen may be changed by one of the Edit>Arrange>xx commands. To 
make  the  selected  object  the  front-most  object  issue  Arrange>to  front.  To  move  it  to  the  background  use 
Arrange>to back. The Arrange>approach (Ctrl P) or Arrange>remove (Ctrl R) commands do the same thing one 
step at a time, thus allowing an object to be inserted between two other objects.
* When exporting an object as vectors (WMF) to another program, a polygon such as a curve in a graph can be 
exported as a single object or as a series of line segments (multiple objects). Some programs find it difficult to  
dissociate a polygon into line segments. If that is the case, choose the "multiple objects" option. Set your choice 
using the Edit>Copy preferences menu item.
* The Edit>Save prefs menu item saves the current window size and the current default text font to disk. These 
settings will then apply to newly created or opened drawing windows.

Curve properties.

When double-clicking on one of the elements of a curve in a graph, the "curve properties" dialogue window pops  
up, allowing the user to edit the attributes of a curve in a graph or to fit a curve. The data points in a graph may be 
connected by line segments and/or be represented by symbols. Use the "connect points with line" checkbox to 
switch drawing of line segments on or off. If checked, the "line width" slide bar and the "line colour" push button 
define the thickness of the line connecting the data points and allow you to select the line colour respectively. In  
the latter case, a second dialogue window ,displaying the palette associated with the current drawing window, 
pops up. The current line colour is highlighted by a white square. If you click in one of the little squares, the colour  
changes and the dialogue window disappears. The first little box in the palette (index=0) is transparent.
The "symbol" panel groups a number of options that define form, size and colour of the symbol representing each  
data point in the currently selected curve. Note that if the "connect points with line" checkbox is unchecked and 
symbol is "none", the curve disappears completely. The associated data however, remain available. If the "bars" 
option is selected, XL-Plot draws a bar between the data point and the x-axis of the graph. This option is used for  
example when drawing dwell time histograms or probability-density distributions. The "symbol size" has no effect 
when in "bar mode". If the currently selected curve has error data associated with it, then error bar drawing may  
be switched on or off by selecting the appropriate checkboxes in the upper right panel of the dialogue window.
The "fit" panel shows three push buttons:
1) Before starting to fit, push the "Function" button to select a fitting function. A second dialogue window will pop 
up, displaying several fit options and fit functions.
2) Push the "Do Fit" button to start fitting. After fitting, the same window pops up again, now showing the fitted  
parameters and the error of fit.
3) To remove a fitted curve, push the "Remove" button.
Two vertical red lines are drawn in the graph on the drawing sheet. These two lines delimit the x-range of data  
points that will be used to obtain the fit. The slide bars marked "fit range from" and "to" control the positions of the 
two red lines. The "line width" slide bar and the "line colour" push button determine width and colour of the fitted  
function trace. The "Fitting functions to data" chapter supplies additional information.
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The lower left corner of the dialogue window indicates whether the graph data are linked with columns of data on a 
spreadsheet and if so, to which spreadsheet and which columns. 
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How to modify the axes of a graph

To modify the axes of a graph, double click on one of its elements (ticks or text such as the numbers along one of  
the axes). Make sure that the graph is not associated with other objects. A dialogue window pops up showing both  
X and Y axis options if the object is a line plot and Y-axis options only if the object is a bar plot. For each of the 
axes the beginning (minimum) and end (maximum) values are defined by the text in the edit boxes "From" and 
"To". The distance between major and minor  ticks can be set by editing the "Major tick every" and "Minor tick 
every" boxes. Note that if "scale type" is set to "log", the "Major tick" edit box is labelled "Major tick log". This edit  
box then shows log-base 10 as default, but this may be changed to any other base as long as it is larger than 
zero. The place where the Y axis crosses the X axis can be set in the "Y axis crosses at" edit box. If the value 
entered here is lower than in the "From" box or larger than in the "To" box, the axes will not intersect in the graph.
The orientation of ticks and scale type is set by selecting the appropriate  radiobutton.
A grid can be laid over the graph by checking  vertical grid and/or  horizontal grid. The grid lines associated 
with the minor ticks will be dotted if the  minor grid dotted box is checked.
Per default, axes are drawn with ticks having numbers alongside. If    X or Y  calibration bar is checked, a 
horizontal or vertical calibration bar is drawn in stead with a size equal to the value entered in the "Bar size" edit  
box. The position of the calibration bar is determined by the values entered in the "Bars(s) at" edit boxes.
The units of the axes or any other text that accompanies an axis can be entered in the lower-most edit box. 
Each time a graph the user sizes a graph, the text size changes too. This behaviour can be switched off by  
checking  Fixed text size.
If a new graph was created from spreadsheet columns, where the column furnishing the X data is entirely in time 
or date format, then the X-axis labels will be in time or date format too. Double clicking on one of the axes in the  
graph will activate the Axes dialogue box as usual. Note however that the x-coordinates are now in time or date 
format. If the user enters a floating point number (rather than a time or a date) in one of the X-axis edit boxes,  
then a new dialogue box will pop up upon exit of the Axes dialogue box. In this box the user indicates if the graph 
should remain in time/date format or should be converted to floating point (seconds/days). To convert the X-axis  
from floating point (seconds/days) to time/date format do similarly (hence type at least one entry in time or date  
format).
If the graph's X-axis is in date format, the Axes dialogue box is slightly different from the usual one in that the  
major and minor tick size should be entered in multiples of years (y), months (m) or days (d). Since the length of  
years and months is not constant (leap years, February is shorter than December) this results in non-equidistant  
ticks in the graph.

Layout of error bars

This dialogue window pops up after having double-clicked on one of the error bars in a graph. Use the upper slide  
bar to change the error bar width and the slide bar below it  to change the pen width. The pen colour can be 
changed by pushing the "pen colour" button. A second dialogue window will then pop up containing 256 little  
coloured squares. Click on the one with the colour of your choice. The error bars depict ± SEM. To show only the 
upper half (+SEM) or lower half (-SEM), (un)check the appropriate check boxes. If the graph contains many data  
points, the error bars may clutter the graph. In that case, the confidence limits may be depicted by a line that runs  
parallel to the data points (option: draw as a line). 
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Layers

Selection of a drawing object may become more difficult if the number of drawing objects on the drawing sheet increases or if a 
several small objects reside on top of for example a large square or bitmap. In order to prevent inadvertent selection of the 
wrong object, objects can be organised onto different layers. When working on one layer, objects on other layers are (almost) 
out of reach of the user. To change layer select Window>Go to layer and select either one of the predefined layers 1 through 
10 or select other to go to a layer with a higher index. In the latter case a dialogue box comes up containing an edit box 
wherein the desired layer number (any positive number below 1 billion) should be typed. The dialogue box also shows a list of 
layers currently containing drawing objects. Hence, Window>Go to layer>other may be used as well to get the list of occupied 
layers if one has lost track of the number of layers in use. After the new layer has been selected, the current layer index is 
shown at the right on the window status bar (i.e. the lower boundary of the application window). A second benefit of the layer 
approach is the possibility to eliminate from view or gray-out the objects of other layers while working with the current layer. To 
do so, select Draw lower layers>draw not or Draw lower layers>draw soft(er) from the Window menu. The first option 
eliminates objects not belonging to the current layer from view, while the second draws them with colours that are intermediate 
between the object colour and the background colour. Draw soft(er) should be used with caution if the layers contain many 
bitmaps, since it takes processor time to gray-out bitmaps and may therefore reduce overall performance. 
Although the goal of the layer approach is to prevent selection of objects other than those belonging to the current layer, the 
need may be sometimes felt to select them anyway. This can be done by maintaining the control key depressed while clicking 

on objects. Note that most functions, such as the cut tool , will also work on objects on other layers if the control key is held 
down.

How to deal with links between spreadsheets and drawing sheets.

Establishing and removing links.
Links between a spreadsheet column and a graph are established in three ways.
1) By pasting the contents of the clipboard on both the spreadsheet and the drawing sheet.
2) By copying one or more spreadsheet columns and issuing the Modify/Data>Line Plot or the Modify/Data>Bar 
Plot from the spreadsheets menu.
3) By copying a graph and pasting it on a spreadsheet.
If  a spreadsheet  column and  a  graph  on a drawing  sheet are  linked,  data in the graph  can be modified  by 
modifying the numbers in the spreadsheet column. For example, removal of  a spreadsheet cell will result in the  
removal of a data point in the graph. The modifications take effect immediately. There is an important exception to  
this rule: If an entire "linked" column is deleted from the spreadsheet, the plot on the drawing sheet will remain 
intact. The link is simply removed. 

 Columns in a spreadsheet that maintain a link with a graph are marked by a '°' character in front of the 
column index.
A link can be removed by either clicking on the graph and selecting Edit>Remove Link from the drawing sheet 
menu or by selecting the columns and selecting Edit>Remove Links from the spreadsheet menu. The latter action 
will also remove links with other graphs on other drawing sheets if they exist. Hence, to remove only the link with 
one graph, select the graph and then choose the Edit>Remove Link item from the drawing sheet menu.

How to know what is linked to what?
To know whether a curve in a graph is linked to a spreadsheet and if so, to which column(s), double-click on an  
element (line segment or symbol) of the curve. The "curve properties" dialogue window appears. In the lower left  
corner of this  window you find  the  name of the spreadsheet  (if  any) to which the curve is  linked along with  
information about columns that contain the x, y and error bar data. In some cases, especially in very crowded 
graphs, a curve may be completely hidden by other curves that are drawn over it. In that case, select the column 
in the spreadsheet that is suspected to contain the data while depressing the control key on the keyboard.

 Now a question mark appears in the column index key. Then return to the graph and double click on 
any curve while depressing the control key. The "curve properties" dialogue window appears with information 
about which curve is linked to the spreadsheet column with the question mark.
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Fitting a function to data. 

Functions can be fitted to your data in each of the three types of window. The function can be one of the build-in 
functions (marked by an asterix in the Fit dialogue window) or one that is defined by the user. Before starting the  
fit routine the user has to select or define i) the function to fit and ii) the range of data points to fit the function to.  
The way to do this differs slightly for each of the three windows. 

The spreadsheet.
i) The fit routine requires two arrays of data: one for the x-values and one for the y-values. These data correspond  
to two columns that needs to be indicated. There are several  ways to do this.  a) By selecting a column and  
choosing Modify/Data->Set X-column from the menu, then selecting a second column and choosing Modify/Data-
>Set Y-column from the menu. An x and a y will appear in the column bar. A third column may be chosen using 
Modify/Data->Set Error-column, that may be used as a weight during fitting. A second (more rapid) way is b) to  
select two columns (not less, not more), the first column will be considered to contain the x-data and the second  
will  be considered to contain the y-data. If you wish c) to fit only a part of the numerical data in two adjacent  
columns, you may select the spreadsheet cells that contain the data to be fitted. ii) Click the set fit function item 
from the Modify/Data menu to choose a function. To start the fit routine select Do fit from the same menu or click 
the fit icon. 

The drawing window.
Only data in an undissociated graph can be fitted. Once a graph is dissociated, it is reduced to a simple set of  
vector elements. To fit one of the curves in a graph, double click on one of its elements (the line elements or the  
symbols, but not one of the axes of the graph) and a dialogue window will pop up containing, amongst others, two  
slide bars titled "fit range from" and "to" and two buttons saying "function" and "Do fit". Moreover, two red vertical  
lines will appear in the graph. i) Use the slide bars to indicate which data points to fit. ii) use the "function" button 
to select the fitting function. Then proceed by clicking "Do fit".

The "Select Fit function" and "Fit" dialogue window.
To choose a function in this window, either double click one of the functions listed under "list of functions" or click  
once and push the "<<" button. The function name and its formula now appear in the upper left edit box. The 
formula can be modified in order to create a new one. During compilation of a formula, lower case letters will be  
converted to upper case, hence the compiler does not distinguish between them. Before using the newly created  
formula, click the ">>" button to save it.
The variables to fit are listed underneath the edit box. Do not attempt to use "X", "Y" or function names such as 
"exp" as variable names since they are reserved and will lead to unexpected results. The user can put constraints  
on the range of values that the fit parameters may adopt by checking V<0 (variable must be negative), fixed (do 
not fit this parameter, but keep it constant) or V>0 (variable must be positive). The maximum of fit iterations can be 
set in the "iterations" edit box. The following functions may be used in fit formulas:
+ addition
- subtraction or negation
* multiplication
/ division
** or ^ power (e.g. 2**3)
 AND or & logical AND
OR   or | logical OR
NOT or ~ logical NOT
>= larger than or equal, returns 1 (true) or 0 (false)
<= smaller than or equal
= equals (returns 1 if equal, else returns 0)
> larger than (e.g. 5>2 returns 1 (true))
< smaller than
sqrt or sqr square root
exp exponential
ln natural logarithm
log decimal logarithm
 pi half the circumference of a circle with unit radius
sin sine, argument in radians
cos cosine
tan tangent
asin arcsine, returns angle in radians
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acos arccosine
atan arctangent
erf error function, the integral of a Gaussian with mean 0 and variance ½.
erfc complement of the error function (erfc=1-erf(x)).
y returns the y-data value (y[i]) corresponding to the current x-data value (x[i]). (e.g. y<=val 

returns 0 if y[i] larger than val. This option can be used for example for thresholding.)

Click the "cancel" or "OK" button to quit the fit dialogue window.
Start fitting by selecting "Do Fit" from the context described above. After estimation of the fit parameters, the same 
fit dialogue window pops up, now showing the estimated variables, the estimated errors of each variable and the 
chi-2 error of fit underneath the formula edit box. The program carries out the Fisher's F-test if a different function 
or the same function with different number of degrees of freedom has been fitted to the same data previously. The  
result of this test indicates whether the current function fits the data significantly better than the previous function.  
A P<0.05 indicates a significant difference. 
In case of fitting a curve on a drawing sheet the fitted function is drawn. The estimated parameters may be copied  
as text to the clipboard by pressing the copy icon:  in the fit dialogue window. The residues of fit may be copied 

to the the clipboard by pressing .

Build-in fit  functions are: line, Hill,  Bolzmann, 1,  2 or 3 eponentials,  Gaussians (1, 2 or 3, equidistant or both 
equidistant and equivariance),  hyperbola, parabola, power, Lorenzians, logistic,  log, log normal,  Langmuir and 
sigmoids.

Linear regression. 
If the first function (*line) of the list of functions is selected, a single step, linear regression routine is used rather 
than the iterative non-linear curve fitting routine. In that case, the correlation coefficient, r, and the probability, P, 
that correlation is absent between X and Y data is shown upon return.

Saving data.

The File menu contains three items that deal with saving your data on hard-disk: Save, Save As and Save with 
links. The Save As menu item prompts for a file name. It is not necessary to type the file extension (e.g. ".txt") in  

the "Save" dialogue box. The Save menu item, whose action is identical to the  button in the icon bar, rewrites 
a file on disk after it has been modified by the user. It does not prompt for a file name. The  Save command 
behaves as the Save As command if the document is a newly created one.
Spreadsheets are saved with the extension ".txt". They contain only simple text and can therefore be read by  
most word-processing programs. Before writing the file on disk, cell references and function names are translated  
into a format that can be understood by the english version of MS Excel.  However, not all functions that are 
provided by XL-Plot have an equivalent in MS Excel (e.g. fdens(), sbar() and cdate) and will generate an error  
message. At this date, MS Excel does not (yet) support multiple languages, and hence a french version of Excel 
may not understand the function names in ".txt" files.
Drawing sheets are saved with the extension ".his". They contain data in a format that is specific for XL-Plot and  
thereby can not be read by other programs. To copy vector drawings to other programs use the Copy item in the 
Edit menu and paste the contents of the clipboard, which are then in Windows Matafile (WMF) format, in the 
receiving program. The WMF standard comprises a large number of functions and possibilities. In fact too large,  
since most programs, including XL-Plot, do not care to handle all those functions and possibilities with the result 
that some aspects of the original drawing are lost in the receiving program. Recent versions of the programs of  
Microsoft, who is the inventor of WMF, are an exeption (e.g. Powerpoint): they display a drawing copied from XL-
Plot correctly.
Upon saving a drawing sheet with the Save command, the links between histograms and spreadsheets are lost. 
Generally this is not a problem, since the histograms contain all the data necessary to re-establish a new link with  
a new spreadsheet in case the need is felt to edit the histogram or to add new data points to it. Just copy the  
histogram to the spreadsheet. However, if most of the essential data are on the spreadsheet rather than on the 
drawing sheet, recreation of the graphs from the spreadsheet every time one reloads the spreadsheet may be 
somewhat tedious. This situation presents itself for example if the spreadsheet contains a number of slide bars 
used  to  animate  a  graphical  demonstration  of  a  function.  To  save  the  drawing  sheet  and  it's  associated 
spreadsheets in a single file use the menu item Save with links. This file remains a ".his" file. Upon loading of a 
"linked" his file, the spreadsheets that were saved with it will be displayed and the links with the drawing sheet will  
be re-establised. The program remembers if the loaded drawing sheet was originally a "linked" file. This means 
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that upon closing the window after an editing session, issuing the  Save command or pushing the "save" button, 
the file will be saved with the linked spreadsheets.
The drawing sheet may be saved as a Windows bitmap (*.bmp) or a Windows metafile (*.wmf). To do so, select 
the "bitmap" or "windows metafile" format from the "File>Save as" dialogue box. In the second dialogue box that 
will pop up, either the bitmap resolution or the WMF format version may be set. Enhanced WMF is required for 
some recent programs, but is not correctly treated by older ones.
Bitmaps are saved in windows *bmp format. To save a bitmap on a drawing sheet, first select a single bitmap and 

then 1) issue the  save bitmap command from the  bitmap menu or 2) click the   button or 3) press ^S. While 
action 1 prompts for the number of bitmap colours, actions 2 and 3 assume the last used colour depth. Hence, 2  
and 3 are shortcuts. Note that if no bitmap is selected, ^S will save the drawing sheet.
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