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 Starting, Saving, and Closing a Publication
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Starting a Publication
Starting a Publication
Starting with a PageWizard
Starting with a Template
Making Your Own Template
Changing a Template
Starting a Publication from Scratch (Blank)
Opening an Existing Publication

Saving, Naming and Closing Your Publication (Plus a Hint)
Saving and Naming Your Publication
Closing Your Publication
Exiting Publisher
A Hint for Freeing Some Space on Your Hard Disk



 Starting a Publication
The first thing you do when you start a new publication is choose how much guidance you'd like from 
Publisher.    If you're new to desktop publishing, you may want to use one of Publisher's PageWizards or 
templates to help you get started.    Or, start from scratch and do it all on your own.

To start a new publication
1 From the File menu, choose Create New Publication.
2 Choose from the following options:

PageWizards:    A PageWizard asks several questions, and then uses your answers to create a 
publication.    When you choose this button, Publisher displays a list of PageWizards for you to 
choose from.
Templates:  A template is a    ready-made design that already contains the basic layout and format 
for a specific type of publication.    When you choose this button, Publisher displays a list of 
templates for you to choose from.
Blank Page:    This option starts you off with a single page publication with one-inch guides.    The 
rest is up to you.

3 If you've chosen to use a PageWizard or a template, in the Publication Name list box, choose which 
PageWizard or template you want to use.

4 Choose the OK button.

Note
You can also make a specific part of a publication using a PageWizard.    For more information, 

see the Creating Special Effects with Page Wizards topic referenced below.

Tip
If you want to get an idea of how to create a publication yourself, start with the Tutorial in your 

Microsoft Publisher User's Guide first, and then try creating your own publication later.

What if...
I choose Templates or PageWizards and Publisher cannot find them?
Templates and PageWizards are copied to your hard disk during Setup, and placed in directories 

called Template and PageWiz.    You may have deleted the files, or moved them to a directory that 
Publisher does not know about.    To be sure that all the Templates and PageWizards will be available, run 
Setup again.

See also
Starting with a PageWizard
Starting with a Template
Starting a Publication from Scratch (Blank)
Saving and Naming Your Publication
Closing Your Publication
Creating Special Effects with PageWizards
Running the Setup Program
Create New Publication Command (File Menu)



 Starting with a PageWizard
PageWizards are the fastest way to create professional-looking publications.    A PageWizard asks you 
what you want to do and then uses your answers to complete the task for you.    Each PageWizard is 
named for what it can make for you.    For example, the PageWizard used to create a calendar is called 
Calendar.

To start a publication using a PageWizard
1 From the File menu, choose Create New Publication.
2 Choose the PageWizard button.
3 From the list of PageWizards, choose the type of publication you want to create.
4 Choose the OK button.

Publisher displays the dialog box for the PageWizard you've chosen.
5 In the PageWizard dialog box, answer the question provided by the PageWizard, and then choose 

Next to move to the next question.
You can choose the Cancel button at any time to stop creating the publication.    Choose the button 
to the left of the Next button if you want to return to the last question, or the button to the right of the 
Cancel button if you want to start the PageWizard over.

6 When you've answered all the questions, choose the Create It button.

Note
In addition to PageWizards that help you start a specific type of publication, Publisher also 

provides PageWizards that help you create a part of a publication, such as a headline.    For more 
information, see the Creating Special Effects With PageWizards topic referenced below.

Tip
A publication created by a PageWizard is no different from other publications.    You are free to 

change it, save it, print it, and open it as you would any other publication.

What if...
I choose PageWizards and Publisher cannot find them?
PageWizards are copied to your hard disk during setup and placed in a directory called    

PageWiz.    You may have deleted the files, or moved them to a directory that Publisher does not know 
about.    To be sure that all the PageWizards will be available, run the Setup program again.    For more 
information on rerunning Setup, see the Running the Setup Program topic referenced below.

See also
Creating Special Effects With PageWizards
Running the Setup Program
Saving and Naming Your Publication
Printing and Stopping Printing
Opening an Existing Publication
Create New Publication Command (File Menu)



 Starting with a Template
A template is a ready-made design that already contains the basic layout and format for a specific type 
of publication, such as a newsletter or form.    All you have to do is add the text and pictures you want.    
To protect a template from changes, Publisher gives you a copy of the original, which you use to create 
your publication.

To start a publication using a template
1 From the File menu, choose Create New Publication.
2 Choose the Templates button.
3 From the list of templates, choose the type of publication you want to create.
4 Choose the OK button.
5 Replace Publisher's sample text and pictures with the text and pictures for your publication.

Note
Once Publisher gives you a copy of the template, it is just like any other publication.    You can 

add to and change it in any way you want.

Tip
When you save your new publication, you can create a new template at the same time by 

choosing Template in the Save As box.    You cannot change the original Publisher Templates, but you can 
always make changes to templates you've created yourself.    For more information, see the Making Your 
Own Template and Saving and Naming Your Publication topics referenced below.

What if...
I choose Templates and Publisher cannot find them?
Templates are copied to your hard disk during setup and placed in a directory called Template.    

You may have deleted the files, or moved them to a directory that Publisher does not know about.    To be 
sure that all the Templates will be available, run the Setup program again.    For more information on 
rerunning Setup, see the Running the Setup Program topic referenced below.

See also
Making Your Own Template
Saving and Naming Your Publication
Running the Setup Program
Adding and Changing Text
Adding and Changing Pictures
Changing a Template
Create New Publication Command (File Menu)



 Making Your Own Template
You can save time by making your own template for publications you create on a regular basis, instead 
of starting from scratch each time.    Any publication you create can be saved as a template.

A template might include

layout guides

styles

number of columns per page

headers

footers

drawn objects

text or articles you use frequently

pictures

empty frames where you can put text or pictures

To create a template
1 Create a new publication that contains the layout, words, and design elements you want to include 

in every version of your publication.
If you need help creating a publication, see the topics on starting a publication referenced below.

2 From the File menu, choose Save As.
3 In the Publication Name box, type a name for your template.
4 Choose the Template check box in the lower right corner of the dialog box.

An X in the box indicates the option is chosen.
5 Choose the OK button.

Note
To protect a template from changes, Publisher gives you a copy of the original when you open it 

to create a new publication.    If you want to change the original, see the Changing a Template    topic 
referenced below.

Tip
When you save a publication as a template, Publisher automatically saves the file to the Template 

directory.    The next time you choose Templates when you want to create a new publication, your 
template will be listed with the other Publisher templates.

See also
Starting with a PageWizard
Starting with a Template
Starting a Publication from Scratch (Blank)
Changing a Template
Save As Command (File Menu)



 Changing a Template
When you use a template, Publisher actually gives you a copy of it in order to preserve the original.    You 
add to and change the copy to create a new publication.    However, when you want to permanently 
change a template, you need to open the original rather than a copy.

To change a template
1 From the File menu, choose Open Existing Publication.
2 In the Directories box, double-click the Template directory.
3 From the list of templates under Publication Name, choose the template you want to change.
4 Choose the OK button.
5 Change any of the elements of the template.
6 From the File Menu, choose Save to permanently change the original template.

--Or--
From the File Menu, choose Save As to save the changed version as a new template and preserve 
the original.    For information on saving a publication as a template, see the Making Your Own 
Template topic referenced below.

See also
Making Your Own Template
Starting with a Template
Open Existing Publication Command (File Menu)
Save As Command (File Menu)



 Starting a Publication from Scratch (Blank)
You can always start from scratch if you want to.    Publisher provides you with a single blank page with 
one-inch guides.    The rest is up to you.    If you're not sure where to start, try creating a publication with 
the help of a PageWizard first, and then try it on your own.

To begin creating a publication from scratch
1 From the File menu, choose Create New Publication.
2 Choose the Blank Page button.
3 Choose the OK button.

To create your publication, see the topics referenced below.

See also
Starting a Publication
Starting with a PageWizard
Starting with a Template
Saving and Naming Your Publication
Setting Up Your Publication
Laying Out the Page
Adding Text
Adding a Picture to Your Publication: the Basics
Create New Publication Command (File Menu)



 Opening an Existing Publication
You can always open and make changes to a publication you've already created.

 To open an existing publication
1 From the File menu, choose Open Existing Publication.
2 In the Publication Name box, type the file name you want or choose it from the list.
3 Choose the OK button.

Tip
After you've made changes to your publication, you can save the publication with the same name 

if you want to replace the original.    Or, save it with a new name to create a new version while preserving 
the original.    For more information, see the Saving and Naming Your Publication topic referenced below.

What if...
I can't find a publication I created earlier?
The publication may be in a directory you haven't tried.    From the File menu, choose Open 

Existing Publication.    In the Publication Name box, type the name of the file you want and double-click 
each directory name.    If you still can't find your publication, open the Windows File Manager and choose 
Help, to learn about the Windows Find command.

See also
Laying Out the Page
Adding Text
Adding a Picture to Your Publication: the Basics
Using Publisher with Other Applications
Saving and Naming Your Publication
Open Existing Publication Command (File Menu)



 Saving and Naming Your Publication
In order to preserve a publication you've created so you can use it again, you need to save a copy of it.    
The first time you save a publication, Publisher asks you to give it a name and then to choose where you 
want it to be saved.    Later, when you make changes to the publication, use the Save command to 
replace the last version of your publication with the new one.

To save a publication
1 From the File menu, choose Save.

If this is the first time you have saved the publication, the Save As dialog box is displayed and 
Publisher asks you for more information.

2 In the Publication Name box, type a descriptive name, no longer than eight characters, for the 
publication.

3 To save an extra copy (backup) of the file, choose the Backup option.    To save the publication as a 
template you can use to create other publications, choose the Template option.
An X in the check box indicates the option is chosen.

4 Choose the drive and directory in which you want to save the file.
Publisher saves the file to the directory specified in the Directories list box, unless you are saving a 
template, or unless you choose another directory.

5 Choose the OK button.
To save your changes as a separate publication

1 From the File menu, choose Save As.
2 In the Publication Name box, type a file name, no longer than eight letters, for the new version of the 

publication.
3 Choose the OK button.

The original version of your publication is preserved under the old name.

Notes
Publisher adds the three-letter extension .PUB to your filename to help you identify it later.
Once you've chosen a printer for a publication, Publisher saves the name of the printer with the 

publication and formats the publication for that printer until you specify another.

Tips
If you don't want to keep the changes you've made to a publication, choose Close Publication 

from the File menu, and then choose No when Publisher suggests saving your changes.
To quickly save changes you've made to your publication, hold down CTRL and press S.

See also
Closing Your Publication
Exiting Publisher
Save Command (File Menu)
Save As Command (File Menu)



 Closing Your Publication
Publisher allows only one open publication at a time. When you finish working on a publication, you have 
to close it before you can work on another one.

To close a publication
1 From the File menu, choose Close Publication.

Publisher displays a message asking if you want to save any changes you've made to the 
publication.

2 To save the changes you've made since you last saved your publication, choose the Yes button.
To erase those changes, choose the No button.
To continue working on the publication, choose the Cancel button.

Note
After you've closed a publication, a blank publication will automatically appear on your screen.    

At this point, you can start work on a new publication, open an existing one, or exit Publisher.

See also
Saving and Naming Your Publication
Exiting Publisher
Close Publication Command (File Menu)



 Exiting Publisher
When you're finished using Publisher, it's a good idea to exit before switching to another application or 
turning off your computer.    This is called exiting the application.    If you have a publication open when 
you exit, Publisher asks if you want to save any changes you might have made, and then automatically 
closes the publication.

To exit Publisher
1 From the File Menu, choose Exit Publisher.

Publisher displays a message asking if you want to save any changes you've made to the 
publication.

2 To save changes you've made since you last saved your publication, choose the Yes button.
To erase those changes, choose the No button.
To continue working in the publication, choose the Cancel button.

Tip
To quickly exit Publisher, hold down ALT and press F4.

See also
Closing Your Publication
Exit Publisher Command (File Menu)



 A Hint for Freeing Some Space on Your Hard Disk
Your hard disk is a piece of hardware in your computer that is used to permanently store files that 
contain your work, such as your Publisher publications.    When you run out of space on your hard disk, 
you'll notice that your computer is unable to complete certain tasks.    If you've regularly been getting 
messages while working in Publisher that say "System disk is locked" or "System disk is full" (where 
"system disk" refers to your hard disk) you may want to free up some space on your hard disk.    If you're 
not receiving these messages, you don't need to follow this procedure.

 To free some space on your hard disk
1 From Publisher's File menu, choose Exit.
2 In Windows Program Manager, double-click on the Main group.
3 In the Main group window, double-click on the File Manager icon.
4 In File Manager, double-click on the MSPUB or the WINDOWS directory.

Each of these directories contain a number of sub-directories.    Below is a list of files located in 
these sub-directories that you can delete.    After deleting these files, you can still run Publisher, you 
just won't have some of the extras that come with it.    Before deleting anything, it's a good idea to 
figure out which, if any, files you want to keep so you can make sure you don't delete them. 

ClipArt
You can delete any of your Publisher ClipArt files.    These have a .CGM file extension and are 
located in your MSPUB\CLIPART directory. 

Templates
You can delete any of the files in the MSPUB\TEMPLATE directory.    These are the templates Publisher 
came with as well as any you've saved to that directory.    If you've saved templates of your own that 
you want to keep, make sure that you do not delete those files.

PageWizards
If you don't plan to use a particular PageWizard, you can delete it from the MSPUB\PAGEWIZ directory. 
Each PageWizard file has a name that corresponds to what it creates so you can easily identify 
which files you want to remove.

Text Converters
You can delete any of the files with a .CNV file extension located in your WINDOWS\MSAPPS\TEXTCONV 
directory.    These are your text converters and allow you to import files from other word processing 
applications.    You can delete specific converters for word processing applications you know you 
won't use or you can delete all of them.

Picture Converters
You can delete any of the files with an .FLT extension located in your WINDOWS\MSAPPS\GRAPHFLT 
directory.    These are your picture converters and allow you to import picture files from other 
graphics applications.    You can delete specific converters for graphics applications you know you 
won't use or you can delete all of them.

Help
You can delete Publisher's MSPUB.HLP file which is located in your MSPUB directory.    Remember, if 
you delete MSPUB.HLP, what you're currently reading will no longer be available!    Be sure to close 
Publisher Help before you delete it.

5 Click on the name of a file you want to delete.
6 From the File menu, choose Delete.
7 Check the name of the file you are about to delete in the Delete box.
8 Choose Delete to delete the file.

--Or--
Choose Cancel to return to File Manager without deleting the file.

Note
If, later, you decide that you want any of the files you've deleted, just run the Setup program 

again.    For more information, see the Running the Setup Program topic referenced below.



For more information about working with your Windows File Manager, refer to your Windows User 
manual.

See also
Running the Setup Program



 Setting Up Your Publication
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

What to Decide Before You Begin
Setting the Unit of Measure
Choosing a Printer
Choosing a Paper Size and Page Orientation
Choosing the Type of Publication You Want to Create

Setting Up Your Publication
Setting and Changing the Page Size
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Hiding Layout Guides

Adding Pages
Adding Pages to Your Publication
Copying Pages
Deleting Pages
Moving Between Pages
Choosing Your View of the Page:    Actual Size, Magnified, or Reduced 

Adding Text and Pictures That Will Repeat on Every Page (Such as Page Numbers or 
Letterheads)

Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Hiding the Background for a Single Page
Adding or Removing Page Numbers
Adding Page Numbers to a Publication with Facing Pages
Removing Page Numbers from a Publication with Facing Pages
Adding Text to Page Numbers
Choosing a Starting Page Number
Adding Headers and Footers



 Setting the Unit of Measure
For each publication you create in Publisher, you can choose from four units of measure--inches, 
centimeters, points, or picas--though Publisher automatically starts with the unit of measure set in the    
Windows Control Panel.    The unit of measure you choose is used for most measurements in your 
publication, such as margins and paragraph indents, and determines how Publisher displays the rulers.

To set the unit of measure
1 From the Options menu, choose Settings.
2 In the Measurements box, choose a unit of measure.    To see more choices, click the arrow to the 

right of the Measurements box.
3 Choose the OK button.

Note
 Once you've set the unit of measure, you just type in a number whenever you're asked to specify 

a measurement--Publisher will always remember the unit of measure you've set.

Tip
 For any specific dialog box entry, you can use a unit of measure that's different from the one 

you've chosen for your publication; just type the number followed by the new unit (in for inches, cm for 
centimeters, pt for points, and pi for picas).    Publisher converts the entry to an equivalent measurement 
in the system you've chosen for the publication.

What if...
I change the unit of measurement for the whole publication while I'm working on it?
Objects that you've already placed on the page won't move, but they may not line up with the new 

ruler marks.    If you want these objects to line up, you'll need to reposition them manually.    For more 
information on positioning text and pictures, see the Moving a Frame or Drawn Object topic referenced 
below.

See also
Moving a Frame or Drawn Object
Using the Rulers
Settings Command (Options Menu)



 Choosing a Printer
It's very important to choose a printer for your publication before you create it.    A printer's capabilities 
determine the fonts, styles, and paper size you can use and the area of your page that will print.

 To choose a printer
1 From the File menu, choose Print Setup.

The name of the printer you're currently using is displayed in the Specific Printer list box.    If no 
printer is displayed, see the "What if..." section below for more information.

2 To see the available printers, click the arrow to the right of the Specific Printer list box.    If no other 
printers are listed, Windows is set up to use only one printer.

3 Choose the printer you want.
4 Choose the OK button.

Note
Once you've chosen a printer, Publisher stores the name of that printer with your publication and 

will print the publication on that printer until you specify another.    This way, you can be sure of the printed 
look of your publication.

What if...
The printer I want to use isn't listed in the Printer box?
To add a printer to the list, you need to install its printer driver in Windows.    For information on 

how to do this, switch to the Windows Program Manager and click the Main icon; in the Main window, 
double-click the Control Panel icon; from the Help menu, choose Procedures, scroll down to the section 
Working With Printers, and choose Installing New Printers.    Follow the instructions to add the printer you 
want to use.    You can also find this information in your Windows manual.

I want to change the printer for a publication after I've created it?
You can change the printer at any time, but this may change the way Publisher displays and 

prints your publication.    If the printer you change to doesn't support the fonts you've chosen, Publisher 
will substitute fonts that the new printer will support.    If you don't like the new look, change back to the 
original printer and Publisher will print your publication as it looked before.

See also
Print Setup Command (File Menu)
A Checklist Before You Print
Printing and Stopping Printing



 Choosing a Paper Size and Page Orientation
The printer you're using determines the choices you have for both paper size and the orientation of your 
publication on the paper when it's printed.    For example, some printers can print on only one size of 
paper or only in a portrait orientation.

The orientation you choose for your publication determines the way it's printed on the paper in your 
printer.    If you choose portrait orientation your publication will be taller than it is wide.    If you choose 
landscape orientation your publication will be wider than it is tall.

To choose a paper size
1 From the File menu, choose Print Setup.
2 Under Paper, choose the paper size you want.

To see more choices, click the arrow to the right of the Size box.    If the printer can print on only one 
size of paper, Publisher won't give you another choice.

3 Choose the OK button.
To choose portrait or landscape orientation

1 From the File menu, choose Print Setup.
2 Under Orientation, choose the page orientation you want.

If no page orientation option is offered, the printer you've chosen can only print in portrait orientation.
3 Choose the OK button.

Notes
In order to make choices your printer can print, it's important to choose a printer before you 

choose the paper size and orientation for your publication.    For more information on choosing a printer, 
see the Choosing a Printer topic referenced below.

You cannot mix portrait and landscape page orientations in a publication.

See also
Print Setup Command (File Menu)
Choosing a Printer
A Checklist Before You Print



 Choosing the Type of Publication You Want to Create
Publisher provides several basic layouts for different kinds of publications, such as a book, a greeting 
card, or a full-page newsletter.    Any publication you create is based on one of these layouts.    You can 
use the exact layout Publisher provides, or change it to suit your needs.    For more information on 
choosing a layout for your publication, see Chapter 3, "Publication Layout," in your Microsoft Publisher 
User's Guide.

 To choose a layout for the type of publication you want to create
1 From the Page menu, choose Page Setup.
2 Under Layout Option, choose the general type of publication that best matches the type of 

publication you want to create.
Full Page: Prints one page to a piece of paper.    You can staple the pages together to create a 
publication such as a newsletter or flyer.    Publisher uses the Full Page option unless you specify 
otherwise.
Book:    Prints two pages to a piece of paper.    You can copy the pages back to back, and then fold 
them to create a publication such as a book, brochure, or magazine.
Tent Card:    Prints two pages to a piece of paper, one page upside down.    You'll fold the page once 
to create a publication such as a place card for a table setting, or a simple greeting card with a 
picture on the front.    You'll need to hand write any words you may want on the inside of the card.
Side-fold Greeting Card:    Prints four pages on a piece of paper, with two of the pages upside 
down.    You'll fold the paper twice to create a card that has text or a picture on the front, and words 
on the inside right page.    The pages of the card are read from left to right.
Top-fold Greeting Card:    Prints four pages on a piece of paper, with two of the pages upside 
down.    You'll    fold the paper twice to create a publication that has text or a picture on the front, and 
words on the inside bottom page.    The pages of the card are read from the top to the bottom.
Index Card:  Prints one page on each piece of paper.    Choose this option if you want to create a 
single-sided card.
Business Card:    Prints one card on each piece of paper.    Choose this option to create a standard-
sized business card.

3 Under Page Size, type a measurement in the Width and Height boxes if you want a page size other 
than the one Publisher proposes.

4 Choose the OK button.

Note
Publisher automatically chooses a page size when you choose a layout option.    This page size is 

based on the type of publication you want to create, the size of the paper you'll be printing on, and the 
number of pages that will print on each piece of paper.    The measurements below the Width and Height 
boxes in the Page Setup dialog box show the maximum allowable page size.

See also
Page Setup Command (Page Menu)
Setting and Changing the Page Size
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)



 Setting and Changing the Page Size
When you set the page size for your publication, you're telling Publisher how big you want the 
publication to be.    For example, to create a 2-inch by 3.5-inch business card, you'd choose a page size 
of 2 inches by 3.5 inches.    Or, if you're using the metric system, you'd choose a 5-cm by 8.5-cm page 
size to create a 5-cm by 8.5-cm card.

 To set or change the page size
1 From the Page menu, choose Page Setup.
2 Under Layout Option, choose a layout for your publication.

In the Page Size box, Publisher suggests a page size for the layout you've chosen.    Publisher also 
displays a Preview picture and a brief description of the layout.

3 To accept the page size Publisher suggests, choose the OK button.
To choose another page size, type new page dimensions into the Width and Height boxes.    As you 
move between the Width and Height boxes, the Preview picture is updated to show any changes 
you've made.

4 Choose the OK button.

Note
When setting the page size for a folding card or greeting card, specify the size you want the card 

to be after it's folded.    Publisher prints all the parts of the card on one piece of paper; you fold it into its 
final form.

What if...
I change the page size after I've put text and pictures in my publication?
The page size changes, but the objects on the page remain in their original positions.    You'll 

need to move and resize them manually.
I choose a page size that's bigger than the maximum height or width indicated in the Page Size 

box?
Publisher alerts you when the page size you've chosen is larger than the maximum size 

recommended.    Publisher calculates this page size from the layout you've chosen and the paper size 
used in your printer.    You can either type in a new height and/or width, choose a larger paper size for 
your printer (if that's possible), or switch to a printer that uses larger paper.

See also
Choosing a Paper Size and Page Orientation
Choosing a Printer
Page Setup Command (Page Menu)



 Setting and Changing Layout Guides
Publisher provides layout guides to help you position text and pictures with precision and consistency 
from page to page.    Unlike margins and columns in a word processor, guides don't affect how text flows 
or the position of text and pictures on the page.    The vertical and horizontal guides simply form a 
nonprinting grid--a set of visual cues to help you lay out your publication.

Guides can be enhanced by a magnetic-like pull that helps snap objects into place.    To find out how to 
use rulers and guides to help you position objects on the page, see the Aligning Objects on the Page 
with Snap To topic referenced below.

 To set or change layout guides
1 From the Layout menu, choose Layout Guides.
2 Under Layout Guides, type measurements for the guides that will outline the margins of your 

publication (left, right, top, and bottom) and set the number of column and row guides you want in 
your layout.
The Preview picture shows how the guides will look in your publication.    Each time you switch 
between boxes under Layout Guides, the Preview picture is updated to reflect any changes you've 
made.

3 Choose the OK button.

Tips
If you're not sure of the type of guides you want or where to put them, first try creating a 

publication with a PageWizard or template.    Templates and PageWizards provide layout guides, already 
in place, for you to use.

To quickly hide or show the layout guides you've chosen for your publication, hold down CTRL and 
press G.

What if...
I change guides after I've laid out text and pictures on the page?
The objects you've already placed on the page will not move, but you'll need to reposition them if 

you want them to line up with the new guides.
I can't see some or all of my guides?
Parts of your guides may be hidden by opaque objects that you've placed over them. They're still 

there; they're just hidden. If all of your guides are hidden, you may have chosen the Hide Layout Guides 
command from the Options menu. Choose Show Layout Guides from the Options menu to make the 
guides reappear.

See also
Aligning Objects on the Page with Snap To
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Layout Guides Command (Layout Menu)
Hide Layout Guides Command (Options Menu)



 Setting and Changing Layout Guides for Facing Pages (as for a Book)
When you create a publication with facing pages, such as a book, you can set your publication guides to 
mirror each other--one set for the right page and one set for the left.    Although you see and work on only 
one page at a time, the guides for all even pages will share one layout and the guides for all odd pages 
will share the reverse, or "mirror," of that layout.

To set layout guides for facing pages
1 From the Layout menu, choose Layout Guides.
2 Under Layout Guides, type measurements for the guides that will outline the margins of your 

publication (left, right, top, and bottom), and set the number of row and column guides you want.
3 Choose Create Two Backgrounds with Mirrored Guides.
4 Choose the OK button.

Note
When you create a publication with mirrored guides, you automatically create a left background 

and a right background.    If there's an object on the background of your publication when you choose 
Create Two Backgrounds with Mirrored Guides, that object is copied onto the background of both pages. 

Tips
Add all the things you want to appear on every page of your publication, such as a page number 

mark or logo, to the background before choosing Create Two Backgrounds with Mirrored Guides.    
Publisher will copy everything from the original background to the new background for you.

A mirrored-page layout is a good choice if you plan on binding your publication.    Just be sure to 
set the guide for the inside margin (the left margin of the right page) to leave enough room to allow for the 
binding.

To quickly hide or show the layout guides you've chosen for your publication, hold down CTRL and 
press G.

What if...
I change my layout from facing pages to regular pages?
Publisher will use the right-hand background of your facing pages for all pages.    If you switch 

back to facing pages, Publisher recreates the left-hand background you were using before you changed 
to regular pages. 

See also
Setting and Changing Layout Guides
Hiding Layout Guides
Layout Guides Command (Layout Menu)



 Hiding Layout Guides
At times, you may want to hide your layout guides to preview the way your publication will look when it's 
printed.    You can continue to snap objects to the guides even when the guides are hidden.

To hide layout guides
From the Options menu, choose Hide Layout Guides.

To display layout guides again
From the Options menu, choose Show Layout Guides.

Tip
To quickly hide or show the layout guides you've chosen for your publication, hold down CTRL and 

press G.

See also
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Aligning Objects on the Page with Snap To
Hide Layout Guides Command (Options Menu)



 Adding Pages to Your Publication
You can add pages to your publication at any time.    When adding pages to a publication, each page you 
add will have the nonprinting layout guides you've set for your publication and any objects you've added 
to the background.

 To add a new page to your publication
1 Turn to where you want to insert the new page.    If there is only one page in your publication, you're 

already there.
2 From the Page menu, choose Insert Pages.
3 In the Number of New Pages box, type the number of new pages you want to add.
4 Choose Before Current Page or After Current Page to indicate where you want the new pages to be 

added.
5 Under Options, choose one of the following:

Insert Blank Pages: Inserts one or more blank pages.
Automatically Create Text Frames:  Inserts one or more pages, each with a single text frame on it 
ready for you to type in text. 
Duplicate All Objects On The Page:  Inserts one or more pages, each of which is an exact copy of 
the page whose number you type in the box to the right of the option.    All frames and drawn objects 
will be copied, but not the contents of the frames.    You might use this option to create several 
pages of a newsletter with the same layout.

6 Choose the OK button.

Tips
If you're working with a publication that contains facing pages, such as a book or magazine, and 

you want to insert pages into the middle of the publication, it's best to insert an even number of pages.    
This ensures that the page layout of your publication is retained (right-hand pages remain the right-hand 
pages, and left-hand pages remain the left-hand pages).

To quickly add one new blank page after the current page, hold down CTRL and press N.

What if...
I can't see my layout guides after I insert a new page?
You probably chose the Automatically Create Text Frames option and Publisher has placed a new 

frame in front of your guides.    If you need to see the layout guides, or do not wish to have a text frame on 
this page, click in the middle of the page to select the frame, and then resize it, make it transparent, or 
delete it.    To find out more about making a frame transparent, see the Adding Patterns and Color to 
Frames and Drawn Objects topic referenced below.

See also
Adding Patterns and Color to Frames and Drawn Objects
Moving Between Pages
Insert Pages Command (Page Menu)



 Copying Pages
When you copy a page, Publisher copies all the objects on the page you've specified and duplicates 
them on a new page.    To avoid repeating material, Publisher does not duplicate the contents of text and 
picture frames.    If you want    to repeat the text and pictures from one page to another, you'll need to 
copy them to the new page yourself.

 To copy a page of your publication
1 Turn to where you want to insert the new page.
2 From the Page menu, choose Insert Pages.
3 In the Number of New Pages box, type the number of new pages you want to add.
4 Choose Before Current Page or After Current Page to indicate where you want the new pages to be 

added.
5 Under Options, choose Duplicate All Objects On The Page.
6 In the box to the right of the Duplicate All Objects On The Page option, type the number of the page 

that you want to copy.
7 Choose the OK button.

Publisher always duplicates your layout guides and any objects placed on the background.

Tips
If you want to copy the text within a frame, remember you can use the Highlight Story command, 

copy the text, and then insert the text into the corresponding frame on the new page.    For more 
information on copying text, see the Copying Text topic referenced below.

If the page you're copying has only a few pictures on it,    you can duplicate the page and then 
copy the text or pictures one by one.    However, if there are several stories and pictures you want to copy, 
it's faster to insert a blank page, select all of the objects at once using the Selection tool, and then copy 
the objects to the new page yourself using the Copy Objects command.    For more information on 
selecting several objects at once, see the Selecting a Frame or Drawn Object topic referenced below.    
For information on copying pictures, see the Copying a Picture or Drawn Object topic referenced below.

See also
Copying Text
Selecting a Frame or Drawn Object
Copying a Picture or Drawn Object
Adding Pages to Your Publication
Moving Between Pages
Insert Pages Command (Page Menu)



 Deleting Pages
You can remove pages of your publication at any time.    Deleting a page removes it, along with all 
objects on it, except for text in connected text frames.

 To delete a page
1 Turn to the page you want to delete.
2 From the Page menu, choose Delete Page.

 To restore a deleted page
Immediately after deleting the page, from the Edit menu, choose Undo Delete Page.

Notes
If in deleting a page you delete a text frame from the middle of a chain of connected frames, this 

does not break the chain or delete any text.    Publisher connects the remaining frames and automatically 
reflows the text.    For more information on deleting pages containing connected text frames, see the 
Disconnecting and Reconnecting Text Frames topic referenced below.

Deleting the only page in a publication will delete all the objects on the page, leaving you with a 
single, blank page.

Tip
If you're working with a publication that contains facing pages, such as a book or magazine, and 

you want to delete pages from the middle of the publication, it's best to delete an even number of pages. 
This ensures that the page layout of your publication is retained (right-hand pages remain the right-hand 
pages, and left-hand pages remain the left-hand pages).

See also
Disconnecting and Reconnecting Text Frames
Adding Pages to Your Publication
Moving Between Pages
Delete Page Command (Page Menu)



 Moving Between Pages
You can move between the pages of your publication using the page controls located in the lower-left 
corner of Publisher's window.    You can move forward or backward by a single page, or jump to the first 
or last page of your publication by using the page control arrows.    You can also type in any page 
number and go directly to that page.

Click this button to turn to the first page of your publication.

Click this button to turn to the last page of your publication.

Click this button to turn back a single page.

Click this button to turn forward a single page.
 To turn to a specific page

1 Click in the number box next to the word Page in the page controls.
2 Type the number of the page you want to turn to.
3 Press ENTER to jump to that page.

Tips
The page controls also indicate whether you are on the foreground page or the background.
      This button replaces the page controls when you're on the background of your publication.    

When you're on the background of a publication with facing pages, you will see two of these symbols, 
representing the left- and right-hand background.    You can move between the left and right background 
by clicking the appropriate button.

To quickly move to the next page, press F5.
To quickly move to the previous page, hold down CTRL and press F5.

See also
Adding Pages to Your Publication



 Adding Text and Pictures That Will Repeat on Every Page
When you create a publication with several pages, there may be some objects you want to appear on 
every page, such as text, pictures, or drawn objects.    In Publisher, you place these objects on the 
background.

The background appears behind each page of your publication.    Objects placed on the background are 
displayed in the same place on each of your publication's pages.    For example, if you put your company 
name and address in the upper-left corner of the background, it will appear in the upper-left corner of 
each page throughout the publication unless you specify otherwise.

To add, change, or delete objects that repeat on every page
1 From the Page menu, choose Go to Background.
2 Add the text, pictures, and drawn objects that you want to repeat on every page of your publication. 

You can add, change, or delete these objects just as you would on a page of your publication.
3 From the Page menu, choose Go to Foreground to return to your page.

Notes
Text on your page will not wrap around objects on the background.
A text frame on your page cannot be connected to a text frame on the background.

Tip
To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.

What if...
I accidentally put something on the background that should be on a page of my publication, or 

vice versa?
You can move objects between a publication page and the background, just as you would 

between publication pages.    Use the scratch area, or the Cut and Paste commands on the Edit menu.    
For more information on moving objects, see the Moving a Frame or Drawn Object topic referenced 
below.

See also
Moving a Frame or Drawn Object
Go to Background Command (Page Menu)
Cut Command (Edit Menu)
Paste Command (Edit Menu)
Repeating Text and Pictures on Facing Pages (as for a Book)
Hiding the Background for a Single Page
Adding or Removing Page Numbers
Creating Headers and Footers
Using the Scratch Area
Deleting a Picture Frame or Drawn Object
Deleting Text Frames



 Repeating Text and Pictures on Facing Pages (as for a Book)
Publications with facing pages, such as a book or pamphlet, have two backgrounds--one for the left-
hand pages and one for the right-hand pages. 

You can add text, pictures, or drawn objects that will repeat on every page of a publication with facing 
pages.    Simply position these objects on the background of one page and have Publisher mirror the 
objects for you on the background of the facing page, or you can copy and position the objects on the 
background of the facing page yourself.

To add objects that will repeat on every page before you've created facing pages
1 From the Page menu, choose Go to Background.
2 Add text, pictures, and drawn objects where you want them to appear on all right-hand pages of 

your publication.
You can add, change, and delete objects just as you would on a page of your publication.

3 From the Layout menu, choose Layout Guides.
4 Choose the Create Two Backgrounds With Mirrored Guides box.

Publisher will create a background for the left-hand page that mirrors the background for the right-
hand page.    All the objects that you've placed on the current background are mirrored on the new 
background for the left-hand page.

5 Choose the OK button.
6 From the Page menu, choose Go to Foreground to return to your page.

To add objects that will repeat on every page after you've created facing pages
1 Follow steps 1-2 above.
2 Select all the objects that you want to appear on both pages of your publication.
3 From the Edit menu, choose Copy.
4 In the page controls, choose the unselected button to switch to the other background. 
5 From the Edit menu, choose Paste Objects.
6 Position the objects to mirror the facing page.
7 To return to working on the pages in your publication, choose Go to Foreground from the Page 

menu.
To add objects to the left- or right-hand background only

1 Turn to an odd-numbered page in your publication.
2 From the Page menu, choose Go to Background.
3 Add the objects that you want to appear on the right-hand pages of your publication.
4 In the page controls, choose the left button to switch to the left-hand background.
5 Add the objects that you want to appear on the left-hand pages of your publication.
6 From the Page menu, choose Go to Foreground to return to your page.

Note
If you've already had Publisher mirror objects on the background of facing pages, and you want 

to add and mirror a new object, you'll need to mirror it manually.    To mirror a new object on the 
background of facing pages, follow the second procedure above.

Tip
To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.

What if...
I no longer want to use the mirrored backgrounds?
Choose Layout Guides from the Layout menu, and then choose the Create Two Backgrounds 

with Mirrored Guides check box to clear it.    An X in the check box indicates that it is chosen; the box is 
empty when it is cleared.    Publisher will use the right-hand background for all pages of your publication, 
and save the left-hand background.    If you decide you want to use mirrored backgrounds after all, just 



choose Create Two Backgrounds with Mirrored Guides again, and Publisher will restore the left-hand 
background.

See also
Go to Background Command (Page Menu)
Layout Guides Command (Layout Menu)
Hiding the Background for a Single Page
Adding or Removing Page Numbers
Creating Headers and Footers
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Using the Scratch Area
Selecting a Frame or Drawn Object
Aligning Objects on the Page with Snap To
Using the Rulers



 Hiding the Background for a Single Page
You may not want the objects on the background to show through on a specific page of your publication. 
For example, you may not want a page number on the first page of a newsletter, report, or proposal.    
You can hide everything on a background, or you can hide just one object. 

To hide all background objects for a single page
1 Turn to the page that contains the background text, pictures, or drawn objects you want to hide.
2 From the Page menu, choose Ignore Background. 

If you want to turn the background back on, choose Ignore Background again.
To hide one background object for a single page

1 On your publication's page, draw a box that covers the Background object you want to hide.
2 From the Layout menu, choose Shading. 
3 In the Style box, choose White.
4 Choose the OK button.
5 From the Layout menu, choose Border.
6 In the Thickness box, choose None.
7 Choose the OK button.

When you print your publication, you will not see the box, but it will hide the background object it 
covers.

Notes
Hiding the background does not delete any objects from the background.    It simply keeps them 

from displaying or printing on the pages you choose.
You can hide the background for as many pages of your publication as you want, but you will 

need to hide it for each page individually.

See also
Ignore Background Command (Page Menu)
Shading Command (Layout Menu)
Adding Text and Pictures That Will Repeat on Every Page
Adding Drawn Objects: Boxes, Lines, and Ovals
Adding Patterns and Color to Frames and Drawn Objects



 Adding or Removing Page Numbers
Publisher keeps track of the number of pages in your publication.    You can print or view page numbers 
by adding a page-number mark, a pound sign (#), to the background of your publication.

To have page numbers appear on every page
1 From the Page menu, choose Go to Background.
2 Create a text frame where you want the page number to appear.
3 From the Page menu, choose Insert Page Numbers. 

Publisher inserts a page-number mark (#) in the selected text frame.    When you print or view the 
pages of your publication, this mark is replaced by the actual number of the page.

4 From the Page menu, choose Go to Foreground to return to your page. 
 To remove all page numbers

1 From the Page menu, choose Go to Background.
2 Select the page-number mark (#) in the text frame.
3 From the Edit menu, choose Delete Text.

You can also choose Delete Text Frame if you want to delete the frame as well as the text.
To hide the page number for a single page

1 On the Foreground page, draw a box that covers the page-number mark (#).
2 From the Layout menu, choose Shading. 
3 In the Style box, choose White.
4 Choose the OK button.
5 From the Layout menu, choose Border.
6 In the Thickness box, choose None.
7 Choose the OK button.

Note
If you're numbering a publication with facing pages, such as a book or brochure, you'll need to put 

a page-number mark on both backgrounds.    For more information on repeating objects on facing pages, 
see the Repeating Text and Pictures on Facing Pages (as for a Book) topic referenced below.

Tips
You can format page numbers as you would any other text.    For example, you can change a 

page number's font, style, or alignment within its text frame.    For more information on choosing fonts and 
styles and changing text alignment, see the topics referenced below.

To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.

See also
Go to Background Command (Page Menu)
Insert Page Numbers Command (Page Menu)
Repeating Text and Pictures on Facing Pages (as for a Book)
Choosing the Font, Size, and Position of Text
Aligning Text in Text Frames
Adding Text and Pictures That Will Repeat on Every Page
Adding Text to Page Numbers
Adding Drawn Objects: Boxes, Lines, and Ovals
Creating Frames for Text and Pictures
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Adding Patterns and Color to Frames and Drawn Objects



 Adding Page Numbers to a Publication with Facing Pages
Before you set up a publication with facing pages, think about where you want the page numbers to 
appear.    For example, if you want page numbers in the bottom left and right corners of a book, you will 
place one page number mark in the bottom right corner of the background.    You can then have 
Publisher mirror the page for you.    Publisher will automatically create a facing page with the page 
number mark in the bottom left corner.

If your publication already has facing pages when you decide to add page numbers, you will need to 
follow the procedure below to copy and position the page number frame on the background of the facing 
page yourself. 

 To add page numbers before you've created facing pages
1 From the Page menu, choose Go to Background.
2 On the Toolbar, choose the Text Frame tool.
3 Create a text frame where you want the page number to appear on all right-hand pages. 
4 From the Page menu, choose Insert Page Numbers.

Publisher inserts the page-number mark, a pound sign (#).    The pound sign appears only on the 
background; Publisher replaces it with the appropriate page number on the foreground when you 
print.

5 From the Layout menu, choose Layout Guides.
6 Choose the Create Two Backgrounds With Mirrored Guides check box.
7 Choose the OK button.

Publisher will create a second background for the left-hand page which mirrors the background for 
the right-hand page.

8 To resume working on the pages in your publication, choose Go to Foreground from the Page menu.
 To add page numbers after you've created facing pages

1 Turn to any right-hand page in your publication.
2 Follow steps 1-4 in the above procedure.
3 Select the text frame which contains the page-number mark.
4 From the Edit menu, choose Copy Text Frame.
5 In the page controls, click the left button to move to the left background.
6 From the Edit Menu, choose Paste Object.
7 Position the text frame to mirror the facing page.
8 To return to the pages of your publication, choose Go to Foreground from the Page menu.

Note
To add text to the page number (for example, the word "Page"), place the insertion point before or 

after the page-number mark.    Type the text you want to appear with each page number.

Tips
To number only odd-numbered pages, put the page-number mark only on the right background.    

To number only even-numbered pages, put the page number mark only on the left background.
To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.
To zoom in for a close-up view of your page to precisely position page numbers, from the Page 

menu, choose 200% Size.    When you're done positioning the page number, press F9 to quickly switch to 
show Page view, or choose the view you want from the page menu.    For more information, see the 
Choosing Your View of the Page: Actual Size, Magnified, or Reduced topic referenced below.

See also
Choosing Your View of the Page:    Actual Size, Magnified, or Reduced
Repeating Text and Pictures on Facing Pages (as for a Book)
Adding or Removing Page Numbers



Adding Text to Page Numbers
Choosing a Starting Page Number
Creating Frames for Text and Pictures
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Choosing the Font, Size, and Position of Text



 Removing Page Numbers from a Publication with Facing Pages
 You can easily remove page numbers from facing pages.

To remove page numbers from facing pages
1 From the Edit menu, choose Go to Background.
2 Select the text frame containing the page-number mark (#).
3 From the Edit menu, choose Delete Text Frame.
4 In the page controls, choose the unselected button to switch to the other background.
5 Repeat steps 1 through 3    to remove the page-number mark from the facing page.
6 To return to the pages of your publication, choose Go to Foreground from the Page menu.

Tip
To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.

See also
Adding or Removing Page Numbers



 Adding Text to Page Numbers
Sometimes you may want the page numbers in your publication to include more than just a number.    
For example, you may want to add text, such as the word "page," or a section number in front of every 
page number.

 To add text to page numbers
1 From the Page menu, choose Go to Background.
2 Position the insertion point next to the page-number mark (#), and type the text you want to appear 

on every page.
3 From the Page menu, choose Go to Foreground to return to your page.

Tip
To quickly move to the background or foreground of your publication, hold down CTRL and press 

M.

What if...
The page number, or the text that accompanies it, is too small when it's printed?
You can change the font and size of a page number and associated text just as you would any 

other text in Publisher.    In the case of the page number, you'll format the page-number mark.    For more 
information on changing the font or size of text, see the Choosing the Font, Size, and Position of Text 
topic referenced below.

See also
Choosing the Font, Size, and Position of Text
Go to Background Command (Page Menu)
Adding or Removing Page Numbers
Adding Text and Pictures That Will Repeat on Every Page
Creating Frames for Text and Pictures



 Choosing a Starting Page Number
Publisher numbers the pages of your publication starting with the number one, unless you tell it 
otherwise.    For example, if you're producing a pamphlet that has several sections created separately, 
you'll want the sections to be numbered consecutively--one section starting with page one, another with 
page 15, and so on--as they would appear when bound together.

 To choose a starting page number other than one
1 From the Options menu, choose Settings.
2 In the Starting Page Number box, type the starting page number of your choice.
3 Choose the OK button.

What if...
I want my page numbers to start somewhere other than on the first page?
You will have to type the page numbers yourself.    To do this, on each page create a text frame 

where you want the page numbers to appear.    You can then start with any page and type in any page 
number you want.    However, if the number of pages in your publication changes, you'll need to update 
each page number. 

See also
Settings Command (Options Menu)
Adding or Removing Page Numbers
Adding Text and Pictures That Will Repeat on Every Page



Laying Out the Page 
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

The Basics for Putting Objects on a Page
Choosing Your View of the Page: Actual Size, Magnified, or Reduced
Creating Frames for Text and Pictures
Creating Several Frames with the Same Margins and Columns
Adding Drawn Objects: Boxes, Lines, and Ovals
Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Selecting a Frame or Drawn Object

Arranging Objects on the Page
Creating Columns and Rows Using Layout Guides
Creating    Columns Within a Text Frame
Moving a Frame or Drawn Object
Copying a Frame or Drawn Object
Resizing a Frame or Drawn Object
Deleting Text Frames
Deleting a Picture Frame or Drawn Object
Aligning Objects on the Page with Snap To
Layering Text, Pictures, and Drawn Objects

Using Your Layout Tools
The Undo Command
Using the Rulers
Moving a Ruler or Its Zero Point (Origin)
Hiding the Rulers
Using the Scratch Area



 Choosing Your View of the Page: Actual Size, Magnified, or Reduced
Publisher lets you choose from several different views of your page.    You can zoom in for a close-up, 
you can view the page as a whole, or you can view the page at twice its actual size.

Full Page the full page, reduced so you can see everything at once

25% the full page at one-quarter of its actual size

33% the full page at one-third of its actual size

50% a portion of the page at half of its actual size

66% a portion of the page at two-thirds of its actual size

75% a portion of the page at three-quarters of its actual size

Actual Size a portion of the page at its actual size

200% a portion of the page at twice its actual size

Use Full Page view to see the layout of the entire page, switch to Actual Size view to read or change text 
you've added, or try 200% view for positioning something precisely.

To change your view of the page
From the Page menu, choose the view you want. 
A check mark on the menu beside the command indicates the view you are currently using. 

Note
You can move between views faster if you choose Hide Pictures from the Options menu.    This 

speeds up the rate at which your screen redraws the page.

Tips
When you are zoomed in and working on a small portion of the page, you will want to periodically 

see how your work looks in the context of the entire page.    Press the F9 key to quickly switch back and 
forth between your current view and Actual Size.

To view a particular object at a particular size, be sure to select it before you choose a view.    
Publisher changes the view of the page and displays as much as will fit of the object, text, or picture that 
you've selected.    If nothing is selected, Publisher displays the upper-left corner of the page.

How much of the page you see in any view depends on the page size, the size of your screen, 
and the resolution of your monitor.    To see more of your page, hide the rulers by choosing Hide Rulers 
from the Options menu.

See also
Selecting a Frame or Drawn Object



 Creating Frames for Text and Pictures
In Publisher, text and pictures are contained within movable, sizable frames.    Putting text and pictures in 
frames makes it easy to move and arrange them in your publication.

Frames also make planning your publication easy.    For example, you can create frames for each block 
of text and each picture you want in your publication.    Before adding the text and pictures, arrange, 
resize, or copy the frames to plan the look of your publication.    Finally, when you're satisfied with your 
plan, just insert text and pictures into the frames.

 To create a frame
1 On the Toolbar, choose the Text, Picture, or WordArt Frame tool.
2 On the page, position the mouse pointer where you want the upper-left corner of the frame to start.
3 While holding down the mouse button, drag the mouse diagonally until the frame is the size you 

want.
4 Release the mouse button to complete the frame.

 To create several frames
1 On the Toolbar, with the right mouse button, choose the tool for the type of frame you want to create.

This locks the tool, allowing you to create several frames of the same type.    If you choose a frame 
tool with the left mouse button, you'll need to choose the tool again each time you want to create 
another frame.

2 When you're finished creating frames, position the mouse pointer on the scratch area and click with 
either button.    This unlocks the tool and you're ready to choose another.

See also
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Resizing a Frame or Drawn Object
Adding Text
Adding Publisher's ClipArt
Adding a Picture From Another Application



 Creating Several Frames with the Same Margins and Columns
If you need to create several text or picture frames that have the same size margins and the same 
number of columns, you can specify these settings for all the frames before you create them.

 To create several frames that have the same margins and columns
1 On the Toolbar, choose the Text, Picture, or WordArt Frame tool.
2 From the Layout menu, choose Frame Columns and Margins if you are creating text frames, or 

Frame Margins if you are creating picture frames.
3 Under Margins, type measurements for the left, right, top, and bottom margins that you want.
4 If you're creating text frames, in the Number of Columns box, type the number of columns you want 

for each frame.    In the Column Gutter box, type in the amount of space you want between the 
columns (Publisher proposes a standard measurement).

5 Choose the OK button.
6 Create the frames that you want.

All frames that you create will have the same margins and columns that you've set with the Frame 
Columns and Margins command until you set new ones.

Notes
For every publication you create, Publisher uses the following standard settings until you specify 

new ones: text frames margins are set at 0.08-inch (0.21 cm if you're using the metric system), one 
column per frame, and 0.17-inch (0.425 cm if you're using the metric system) column gutters. Picture 
frame margins are set at 0 (zero). To return to these standard settings at any time, from the Layout menu, 
choose the Frame Columns and Margins command, and then type the settings back into the appropriate 
text boxes.

When you follow the procedure above to create frames with different margins and columns, the 
settings that you specify will be used for each additional frame created.    If you want to create more 
frames with different margins and columns than those you've set with the Frame Columns and Margins 
Command, you'll need to follow steps 1 through 5 above again before creating the new frames.

Changing the settings for one type of frame does not affect the settings for the other type.    For 
example, changing the margins for all new picture frames you create will not change the margins for all 
new text frames.

Tip
If you don't know how many columns you want or how big to make the margins for the text or 

picture frame you're creating, see one of the topics referenced below for more information.

See also
Creating Frames for Text and Pictures
Creating Columns and Rows Using Layout Guides
Creating Columns Within a Text Frame
Changing the Margins Within a Text Frame
Adding Space (Margins) Around a Picture



 Selecting a Frame or Drawn Object
To work with a specific frame or drawn object--for example, to add a shadow to a text frame or change 
the size of a box you've drawn--you have to select it.    When you select an object, "handles" appear, 
indicating that the object has been selected.    You can select one object at a time, or several objects at 
once.

 To select one object
Click the frame or drawn object.
You can click anywhere in a text or picture frame to select it, but you must click the edge of a 

drawn object.
 To select a group of objects

While holding down the CTRL key, click each object you want to select.
 To quickly select a group of objects

1 From the Toolbar, choose the Selection tool.
2 Position the mouse pointer outside of the group of objects you want to select.
3 While holding down the mouse button, drag the mouse until all the objects you want to select are 

surrounded by a dotted box.
4 Release the mouse button.    All the objects that were entirely within the box are now selected.

 To cancel a selection
Hold down the CTRL key and click the object whose selection you want to cancel.

What if...
I can't select a particular frame or drawn object?
Check to see if it's on the background.    If it is, you need to move to the background of your 

publication before you can select it.    See the Adding Text and Pictures That Will Repeat on Every Page 
topic referenced below.

See also
Adding Text and Pictures That Will Repeat on Every Page
Moving a Frame or Drawn Object
Resizing a Frame or Drawn Object
Deleting Text Frames
Deleting a Picture Frame or Drawn Object
Aligning Objects on the Page with Snap To



 Creating Columns and Rows Using Layout Guides
Arranging text and pictures into columns and rows organizes your publication and makes it easier to 
read.    You can create columns and rows by setting column and row guides, and then aligning frames 
and drawn objects to the guides.

 To set column and row guides
1 From the Layout menu, choose Layout Guides.
2 In the Number of Columns box, specify the number of columns you want for your publication. 
3 In the Number of Rows box, specify the number of rows you want.

As you move between boxes, Publisher automatically updates the Preview picture to show you how 
the guides will look in your publication.

4 Choose the OK button.

Note
Column and row guides are useful for positioning text frames, picture frames, and drawn objects 

in your publication.    However, they do not affect the way text flows within a frame.    For information on 
setting text columns in a text frame, see the Creating Columns Within a Text Frame topic referenced 
below.

Tips
You're not required to use guides, they're just a helpful aid for positioning objects in your 

publication.    If you've set guides and you decide you don't want to use them, simply choose Layout 
Guides from the Layout menu again, and then set the number of columns and rows back to 1.

If you're not sure of the type of guides you want or where to put them, first try creating a 
publication with a PageWizard or template to get ideas.    Templates and PageWizards can provide layout 
guides, already in place, for you to use.

You can set row and column guides to exert a magnet-like pull that snaps objects into alignment 
with the guides.    For more information on Publisher's Snap To commands, see the Aligning Objects on 
the Page with Snap To topic referenced below.

You can hide or look at the layout guides you've chosen for your publication by choosing Hide 
Layout Guides or Show Layout Guides from the Options menu.    For a shortcut to hide or see the layout 
guides, hold down CTRL and press G.

See also
Creating Columns Within a Text Frame
Aligning Objects on the Page with Snap To
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Layout Guides Command (Layout Menu)



 
 Creating Columns Within a Text Frame

To divide the text of a single story into columns, you just create a text frame, set the number of columns 
you want in the frame, and then insert the story--the text will be divided into columns automatically.    If 
you don't specify the number of columns, Publisher will display the text as a single column.

 To create columns within a text frame
1 Select the text frame you want to add columns to.
2 From the Layout menu, choose Frame Columns and Margins.
3 In the Number of Columns box, type the number of columns you want.
4 In the Column Gutter box, type the amount of space you want between columns.

Publisher proposes a standard measurement.
5 Choose the OK button.

 To set the same number of columns for each new text frame
1 On the Toolbar, select the Text Frame tool.
2 From the Layout menu, choose Frame Columns and Margins.
3 In the Number of Columns box, type the number of columns you want. 
4 In the Column Gutter box, type the amount of space you want between the columns (Publisher 

proposes a standard measurement).
5 Choose the OK button.

Each new frame that you create in the publication will have the number of columns you've specified. 
If you later want to create frames with a different number of columns, follow steps 1 through 5 above 
to specify new settings.

Tip
All columns within a single text frame are the same size.    If you want columns of different widths 

within the same story, you will need to create a separate text frame for each column and connect the 
frames.    For more information on connecting frames, see the Displaying Long Stories in Connected Text 
Frames topic referenced below.

See also
Displaying Long Stories in Connected Text Frames
Creating Columns and Rows Using Layout Guides
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Creating Frames for Text and Pictures
Frame Columns and Margins Command (Layout Menu)



 Moving a Frame or Drawn Object
You can move objects around on any page by selecting the objects and dragging them to a new position.

You can also move objects to a different page by selecting the objects and either (1) dragging them onto 
the scratch area, changing to a different page, and then dragging them from the scratch area onto the 
new page, or (2) cutting them, changing to a different page (or a different publication), and pasting them 
onto the new page. 

 To move an object or group of objects by dragging
1 Select the object or objects you want to move.
2 Position the mouse pointer over the edge of a selected object until the mouse pointer changes to the 

Mover.
3 While holding down the mouse button, drag the object to the new position.    If you're moving the 

object to another page, drag it onto the scratch area, switch to a new page in your publication, and 
drag the object onto the new page.

4 Release the mouse button.
When moving a frame, the contents of the frame won't move to the new position until you've 
released the mouse button. 
 To move an object or group of objects using the Cut command

1 Select the object or group of objects you want to move.
2 From the Edit menu, choose Cut.

When you cut an object, it is saved to the Clipboard.    A copy of it can then be pasted from the 
Clipboard to another location.    The object you've cut will remain on the Clipboard until you cut or 
copy another object.

3 Turn to a new page in your current publication, or, from the File menu, choose Open Existing 
Publication, and open another publication you want to paste the object or objects into.

4 From the Edit menu, choose Paste.
A copy of the selected object or objects is pasted into the middle of the current page.

Tips
To drag an object or group of objects in a straight line either vertically or horizontally, hold down 

the SHIFT key while you drag the objects.
To quickly move an object or group of objects you've selected, hold down SHIFT and press DEL to 

remove the objects.    Turn to a new page of your publication, hold down SHIFT and press INS, to paste the 
object or group of objects into a new location.

See also
Selecting a Frame or Drawn Object
Resizing a Frame or Drawn Object
Deleting a Picture Frame or Drawn Object
Aligning Objects on the Page with Snap To
Cut Command (Edit Menu)
Paste Command (Edit Menu)



 Copying a Frame or Drawn Object
If you want to make several frames or drawn objects that are exactly the same, you can simply create 
the original object and then copy it as many times as you need.    When you copy an object, a duplicate 
of it is saved to the Clipboard, ready to be pasted to another location.

 To copy an object or group of objects
1 Select the object or group of objects you want to copy.
2 From the Edit menu, choose Copy.

The name of the type of object you're copying follows the command name so you can confirm you're 
copying the correct object.    For example, the command appears as Copy Text Frame if the object 
you are copying is a text frame.

3 If you want to put the copy on a different page of your publication, turn to that page.    If you want to 
put the copy into another publication, from the File menu, choose Open Existing Publication and 
open that publication.

4 From the Edit menu, choose Paste once for each copy of the object you want.
A copy of the selected object or group of objects is pasted into the middle of the page. 

Note
If all the text frames of a story are copied and pasted to another location, the frames and the text 

they contain are duplicated.    If only a few of the frames in a chain of connected text frames are copied, 
only the frames, and not the text they contain, are duplicated.    For more information on copying 
connected text frames, see the Disconnecting and Reconnecting Text Frames topic referenced below.

Tips
To quickly make a copy of the object or group of objects you've selected, hold down CTRL and 

press C or INS.
To quickly paste the object or group of objects you've copied into your publication, hold down 

CTRL and press V, or hold down SHIFT and press INS.

What if...
I choose Paste but don't get what I expect?
The Clipboard can only hold one set of objects at a time.    When you copy something to the 

Clipboard, it replaces what was there before.    You may have copied something over what you wanted to 
paste from the Clipboard.    Copy the object you wanted to paste and try again.

See also
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Copy Command (Edit Menu)
Paste Command (Edit Menu)



 Resizing a Frame or Drawn Object
You can change the size of a frame or drawn object at any time.    When you change the size of a text 
frame, the text automatically rewraps to fit the new frame size.    Similarly, if you change the size of a 
picture frame, the picture automatically shrinks or expands to fit it.

 To change the size of a frame or drawn object
1 Select the object you want to change.

Only one object can be resized at a time.
2 Position the mouse pointer over one of the handles until it changes to the Resizer.
3 While holding down the mouse button, drag one of the handles until the frame or drawn object is the 

size you want.
4 Release the mouse button.

When resizing a frame, the contents of the frame won't move to fill the new space until you've 
released the mouse button.    If you've resized a text frame, the text automatically rewraps to fit the 
new frame size.    If you've resized a picture frame, the picture is automatically resized to fit.
 To cancel a change you've made to the size of a frame or drawn object

Immediately after changing the size of an object, from the Edit menu, choose Undo Resize 
Object.

Note
If you resize a text or picture frame that already contains text or pictures, the change can affect 

the look of the text or picture.    To find out more about how changing the size of a text or picture frame will 
affect its contents, see the Resizing Text Frames or Shrinking or Enlarging a Picture topics referenced 
below.

Tip
To quickly cancel a change you've just made to the size of a frame or drawn object, immediately 

hold down ALT and press BACKSPACE.

See also
Resizing Text Frames
Shrinking or Enlarging a Picture
Selecting a Frame or Drawn Object



 Deleting a Picture Frame or Drawn Object
To remove a picture frame or drawn object from your publication permanently, delete it.    Remember, 
when you delete a picture frame, you also delete its contents. 

For information on how to delete a text frame, see the Deleting Text Frames topic referenced below.
 To delete a picture frame or drawn object

1 Select the picture frame or drawn object you want to delete.
2 Press the DEL key.

You can also remove a selected object or group of objects by choosing Delete from the Edit menu.    
The name of the type of object you're deleting follows the command name so you can confirm that 
you're deleting the correct object.
 To restore a deleted picture frame or drawn object

Immediately after deleting the object, from the Edit menu, choose Undo Delete Object.

Tip
To quickly restore an object you've just deleted, immediately hold down ALT and press BACKSPACE.

What if...
I've selected an object, but choosing DEL from the Edit menu doesn't delete it?
You may have selected a text frame.    Text frames cannot be deleted with the DEL key.    To delete 

a text frame you must select it and choose the    Delete Text Frame command from the Edit menu.

See also
Selecting a Frame or Drawn Object
Deleting Text Frames



 Aligning Objects on the Page with Snap To
Layout guides and rulers have a magnetic quality: if you move an object close to a guide or align it with a 
tick mark on a ruler, the edge of the object will snap to the guide or tick mark.    The Snap to Guides and 
Snap to Ruler Marks options provide a means for precisely aligning and positioning all objects you place 
on the page.

 To turn on Snap To for guides or rulers
From the Options menu, choose Snap to Guides or Snap to Ruler Marks.
A check mark appears next to the command name, indicating that the command is turned on.    To 

turn either Snap To command off, from the Options menu, choose the command again.    The check mark 
disappears, indicating that the command is turned off.

 To snap an object or group of objects to a guide
1 Turn on Snap to Guides.
2 Select the object or objects you want to snap to a guide.
3 Position the mouse pointer over the edge of a selected object until you see the Mover.
4 While holding down the mouse button, drag the object close to the guide you want to align it to until 

the edge closest to the guide snaps to the guide.
You can snap an object to any place on a guide and to any guide in your layout.

5 When the object you're moving is snapped to a guide in the location you want, release the mouse 
button to complete the move.
 To snap an object or group of objects to a tick mark on a ruler

1 Turn on Snap to Ruler Marks.
2 Select the object or objects you want to snap to a tick mark on a ruler.

Lines will appear on the inside edge of each ruler marking the width, length, and position of the 
object you've selected.

3 Position the mouse pointer over the edge of a selected object until you see the Mover.
4 While holding down the mouse button, slowly drag the object in any direction.

As you drag the object, notice that the object moves in increments equal to the distance between 
two tick marks.    Also notice that the lines on the rulers that mark the length, width, and position of 
the object you're moving snap to each tick mark as you drag.

5 When the object you're moving is snapped to a tick mark in the location you want, release the 
mouse button to complete the move.

Notes
When you move a guide or ruler, the objects you've snapped to them do not move.
When you move a group of objects, the left edge of the left-most object snaps to the ruler tick 

marks.    The other objects in the group move with the left-most object.

Tips
Turn off the Snap To commands when you want to position objects close to guides but not on 

them, or when you want to position an object between two tick marks on a ruler.
To quickly turn on or off Snap to Guides, hold down CTRL and press W.

See also
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Using the Rulers
Setting and Changing Layout Guides
Snap to Guides Command (Options Menu)
Snap to Ruler Marks Command (Options Menu)



 Layering Text, Pictures, and Drawn Objects
You can place objects in front of, in back of, or overlapping other objects to enhance your layout or 
create interesting design effects.    For example, you can place a picture frame containing ClipArt over a 
text frame containing the main story of your publication, and the text will automatically wrap around the 
picture.

You can either draw the objects on the page in the order you want them to be layered--the last object 
drawn is always in front of any other objects--or relayer objects already on the page by choosing one of 
the following commands:

Send to Back:    When an object is sent to the back, it is placed behind all other objects on the page 
except objects on the background.

Bring to Front:    When an object is brought to the front it is placed in front of all other objects on the 
page.
 To change the order in which objects are layered

1 Select the object or objects whose order you want to change.
2 From the Layout menu, choose Bring to Front or Send to Back.

Notes
These commands can work on multiple objects.    If you select a number of objects and then use 

the Bring to Front or Send to Back command, the selected objects will be placed in front of or in back of 
all other objects on the page as a group, and their order in relation to each other will stay the same.

When a text or picture frame is placed over another text frame, the underlying text will wrap 
around the frame on top of it.    This is very useful for adding pictures, captions, and headlines to 
newsletters and other publications.

Objects moved onto the page from the scratch area are automatically placed behind all objects 
on the current page.

Tips
To quickly use Bring to Front for an object or group of objects you've selected, hold down CTRL 

and press F.

To quickly use Send to Back for an object or group of objects you've selected, hold down CTRL 
and press Z.

See also
Creating Frames for Text and Pictures
Adding Drawn Objects: Boxes, Lines, and Ovals
Adding Patterns and Color to Frames and Drawn Objects
Adding Shadows Behind Frames or Drawn Objects



 The Undo Command
You can undo many different commands and procedures in Publisher by choosing the Undo command 
immediately after you've carried out the command or procedure.    For example, you can undo creating 
and deleting frames and drawn objects, moving and resizing them, and adding borders and shadows to 
them.

To undo a command or procedure
Immediately following the command or procedure you want to undo, from the Edit menu, choose 

Undo.
A description of what will be undone follows the command name--for example, Undo Create 

Object.    Once Undo is chosen, Redo replaces it on the Edit menu, allowing you to reverse the Undo 
command.

Tips
The Undo command can be a valuable design aid.    You can try new ideas, like resizing, moving, 

or shading an object; if you don't like the change, just choose Undo.
To quickly cancel your last command or procedure, immediately hold down ALT and press 

BACKSPACE.

What if...
The Undo command is not available when I open the Edit menu?
The Undo command cannot reverse all actions you might complete in your publication.    For 

example, adding new pages or inserting a picture cannot be undone.    When an action you've completed 
cannot be reversed, the Undo command is unavailable, or "dimmed," on the Edit menu and cannot be 
chosen.

See also
Undo Command (Edit Menu)



 Using the Rulers
Publisher provides rulers at the top and left side of every publication.    Use them to help you create 
objects of a specific size and to position or resize objects with precision. You can also move the rulers 
anywhere on the page, or set them to exert a magnet-like pull that snaps objects into alignment with the 
ruler tick marks for precise positioning and measurement.

 To use the rulers when creating an object
1 On the Toolbar, choose the tool for the frame or drawn object you want to create.
2 Position the mouse pointer where you want the upper-left corner of the object to be.

A line on each of the two rulers marks the position of the mouse pointer.    (If you don't see the lines 
right away, move the mouse pointer around; the line on each ruler moves to follow the mouse 
pointer.)

3 Drag the mouse diagonally to create the object.    As you create the object, a shadow along the 
inside edge of each ruler reflects the object's width and length.
Use the ruler shadows to measure the size of the object as you create it.    The rulers show the width 
and length of the object as long as it's selected.
 To use the rulers when moving an object or group of objects

1 Select the object or group of objects you want to move.
2 Position the mouse pointer over the object you've selected until it changes to the Mover.

When the mouse pointer changes shape, the selected object is ready to be moved.
3 Drag the selected object to move it. 

The shadows on the rulers shift with the object as it's being dragged to reflect the object's new 
position.
 To snap an object or group of objects to a ruler's tick marks

1 From the Options menu, choose Snap to Ruler Marks.
A check mark appears next to the command name when the option is on.    If a check mark already 
appears next to the command name, Snap to Ruler Mark is on and you do not have to choose it 
again. 

2 Select the object or group of objects you want to snap into alignment with the tick marks on the 
rulers.
Lines will appear on the inside edge of each ruler marking the width, length, and position of the 
object you've selected.

3 Move the mouse pointer over the edge of the object until you see the Mover.
4 While holding down the mouse button, slowly drag the object in any direction.

As you drag the object, notice that the object moves in increments equal to the distance between 
two tick marks.    Also notice that the lines on the rulers that mark the length, width, and position of 
the object you're moving snap to each tick mark as you drag.

5 When the object you're moving is snapped to a tick mark at the location you want, release the 
mouse button to complete the move.

Note
When you move a group of objects, the left edge of the left-most object snaps to the ruler tick 

marks.    The other objects in the group move with the left-most object.

Tip
To quickly hide or show the rulers, hold down CTRL and press K.

See also
Selecting a Frame or Draw Object
Moving a Ruler or Its Zero Point (Origin)
Aligning Objects on the Page with Snap To
Hiding the Rulers
Creating Frames for Text and Pictures



Adding Drawn Objects: Boxes, Lines, and Ovals
Snap to Ruler Marks Command (Options Menu)



 Moving a Ruler or Its Zero Point (Origin)
Sometimes you may want to move a ruler next to, or closer to, the object you're creating or positioning, 
to make precise measuring easier.    In Publisher, you can move the rulers anywhere you want within the 
workspace.    You can also move either ruler's zero point.    This enables you to start your measurements 
from the ruler's zero point no matter where you're positioning the object on the page. 

 To move a ruler
1 Position the mouse pointer over the ruler you want to move.

The mouse pointer changes to two-headed arrow.
2 While holding down the mouse button, drag the ruler to a new position.

 To move both rulers at the same time
1 Position the mouse pointer on the button where the two rulers intersect.

The mouse pointer changes to a two-headed arrow.
2 While holding down the mouse button, drag the rulers to a new position.

 To move both zero points at the same time
1 Position the mouse pointer on the button where the two rulers intersect.

The mouse pointer changes to a two-headed arrow.
2 Click the right mouse button.
3 Hold down the right mouse button and drag the zero points to their new location. Release the mouse 

button to complete the move.
 To reset the zero point

Double-click the ruler.
The horizontal ruler's zero point is reset to the left edge of your publication.    The vertical ruler's 

zero point is reset to the top of your publication.    Double-clicking the intersection of the two rulers resets 
both zero points.

Tip
To quickly hide or show the rulers, hold down CTRL and press K.

See also
Using the Rulers
Hiding the Rulers



 Hiding the Rulers
If you'd like to have more on-screen work space and you don't need to use the rulers for positioning 
objects, you can hide them without affecting the position of any object in your publication.

 To hide the rulers
From the Options menu, choose Hide Rulers.
The rulers "disappear," and the Show Rulers command takes the place of Hide Rulers on the 

Options menu.    Choose Show Rulers to display the rulers again.

Note
Snap To is still active when the rulers are hidden.    A check mark next to the command name on 

the Options menu indicates that the command is turned on.    To turn off Snap To, from the Options menu, 
choose Snap to Ruler Marks.

Tip
To quickly hide or show the rulers, hold down CTRL and press K.

See also
Moving a Ruler or Its Zero Point (Origin)
Using the Rulers
Aligning Objects on the Page with Snap To
Hide Rulers Command (Options Menu)



 Using the Scratch Area
For most projects, it's nice to have some extra room to spread out the project pieces as you work.    
Publisher provides a scratch area around your publication that you can use like a desk for setting aside 
parts of your publication as you assemble it.

Whatever you put entirely onto the scratch area remains visible as you move from page to page of your 
publication, and objects on the scratch area are saved when you quit Publisher.    You can also use the 
scratch area as a convenient way to move objects from one page to the next without cutting and pasting.

 To move an object onto the scratch area
1 Select the object or objects you want to move onto the scratch area.
2 Drag the objects all the way off the page and onto the scratch area.

You can leave objects on the scratch area as long as you want.    You can also switch to another 
page of your publication and drag the objects onto the new page.

Notes
If an object is partly on the scratch area and partly on the page, only the part on the page will 

print.    You can use this feature to create bleed art in your publication.
You can resize and format objects on the scratch area just as you would if they were on the page.

See also
Selecting a Frame or Drawn Object
Moving a Frame or Drawn Object
Moving Between Pages



 Adding and Changing Text
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Adding and Positioning Text on the Page
Adding Text
Creating Columns Within a Text Frame
Displaying Long Stories in Connected Text Frames
Disconnecting and Reconnecting Text Frames
Copying a Text Frame
Moving a Text Frame Within a Publication
Moving a Text Frame Between Publications
Resizing Text Frames
Deleting Text Frames

Adding Text That Will Appear on Every Page (Such as Page Numbers or Letterheads)
Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Hiding the Background for a Single Page
Adding or Removing Page Numbers
Adding Page Numbers to a Publication with Facing Pages
Removing Page Numbers from a Publication with Facing Pages
Adding Text to Page Numbers
Choosing a Starting Page Number
Creating Headers and Footers

Adding and Changing Text Created with Another Application
Adding a Piece of Text from Another Application
Adding an Entire File of Text from Another Application
Exporting Text Created in Publisher to Another Application

Changing Text in Text Frames
Choosing the Text You Want to Change
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text for You
Checking Text for Spelling Errors
Removing and Retyping Text
Copying Text
Moving Text
Deleting Text
Hyphenating Words

Spacing and Aligning Text
Aligning Text in Text Frames
Changing the Margins Within a Text Frame
Inserting or Removing a Tab Stop
Changing the Alignment or Leader for a Tab Stop
Indenting Your Text
Creating a Numbered or Bulleted List
Creating Tables
Changing the Space Between Letters (Kerning)
Changing the Space Between Lines of Text (Leading) and Paragraphs



Choosing Fonts and Styles for Text
Choosing the Font, Size, and Position of Text
Choosing Styles: Bold, Italic, Underlined
Choosing Colors for Text
Adding WordArt to Your Publication
Changing WordArt

Tips For Adding Special Kinds of Text
Creating Fancy First Letters: Dropped and Raised
Creating Headlines
Creating Captions
Creating Sidebars and Pull Quotes
Creating Headers and Footers
Creating Footnotes



 Adding Text
To add text to a publication, you create a box called a frame and then put text into it.    You can type text 
directly into the frame or import text created with another application.    For more information on importing 
text from another application, see the Adding a Piece of Text Created in Another Application or Adding an 
Entire File from Another Application topics referenced below.

To add text
1 From the Toolbar, choose the Text Frame tool.
2 Drag the mouse diagonally until the frame is the size you want.
3 From the Page menu, choose Actual Size

When you first create a publication, Publisher shows you the whole page to make planning your 
layout easy.    When you're ready to add text or position objects precisely, you'll want to view the 
page at its actual size.    For more information, see the Choosing Your View of the Page: Actual Size, 
Magnified, or Reduced topic referenced below.

4 Start typing.
To add text to existing text

Click the insertion point where you want to add text, and then begin typing.

Notes
In Publisher, text contained in a text frame is called a story.    A story can be a one-line caption or 

a ten-page article.    If a story is too big for one frame, you create more frames and connect them until all 
the text in the story is displayed.    You create a different frame or series of frames for each story in a 
publication.

If you type more text than a frame can hold, Publisher stores the text that won't fit in the overflow 
area.    You can add frames and connect them to display the text in the overflow area.    For more on 
connecting frames, see the Displaying Long Stories in Connected Text Frames topic referenced below.

When you resize a text frame, you will not lose any text but it will be repositioned to fit within the 
current frame.    If the text won't fit in the resized frame, it will be moved to a connected frame.    If you 
haven't yet created a connected frame, the text will not be visible, but it will be stored in the overflow area 
until you create a connected text frame.

Tip
If you want a single story to appear in several columns, you can set up columns in the frame.    

See the Creating Columns Within a Text Frame topic referenced below.

See also
Adding a Piece of Text from Another Application
Adding an Entire File of Text from Another Application
Choosing Your View of the Page: Actual Size, Magnified, or Reduced
Displaying Long Stories in Connected Text Frames
Creating Columns Within a Text Frame
Resizing a Frame or Drawn Object
Adding Pages to Your Publication



 Displaying Long Stories in Connected Text Frames
When the text of a single story won't fit in one text frame, you can display the extra text by connecting 
empty frames to the original frame.    The extra text will flow from the original frame into each connected 
frame until all the text of the story is displayed.

Each text frame has a connect button in the lower-right corner.    This button changes to show you how 
much text a frame contains and whether it's connected to other frames.    Use the connect button to 
guide you as you connect frames to display your text:

The frame is empty, or it's big enough to display all of the story it contains.
The frame contains a story that is too big to fit within it; text that does not fit within the frame is 

stored in the overflow area.    Make the frame bigger or connect it to another frame to see the remaining 
text.

The frame is connected to another frame.    If a story is too big to fit within the frame, the text that 
does not fit will flow into and be displayed in the frame that it's connected to. 

 To connect two text frames
1 If the frames don't already exist, create two text frames.
2 Select the text frame where you want the story to begin (it can already have the story in it).
3 Click the selected frame's connect button.

You can now turn to another page if the text frame you want to connect to is on another page of your 
publication.

4 Click anywhere within the second text frame to connect the two frames together.
This frame must be empty.
Any extra text from the first frame will flow into the empty frame.    If you've connected two empty 
frames, you can now type or insert text into the first frame.    Publisher fits as much text as it can in 
the connected frames, and stores any text that doesn't fit in the overflow area of the second frame.
 To connect more than two frames at a time

1 Create the number of text frames you want to connect.
2 Select the text frame where you want the story to begin.
3 With the right mouse button, click the selected frame's connect button.

You can now turn to another page if the frames you want to connect to are on other pages of your 
publication.

4 With the left mouse button, click anywhere on each empty frame you want to add to the chain in the 
order you want them connected.
Any extra text from the first frame will flow into the empty frames.    If you've connected all empty 
frames, you can now type or insert text into the first frame.    Publisher fits as much text as it can in 
the connected frames, and stores any text that doesn't fit in the overflow area of the last frame.

5 Click outside any text frame to stop connecting frames.

Tips
When you use the Import Text command to add a story from another publication or application, 

you can choose to have Publisher automatically create and connect enough frames for the story.    For 
more information, see the Adding an Entire File of Text From Another Application topic referenced below.

What if...
I connected to the wrong frame?
Immediately after connecting to the wrong frame, before you do anything else, choose Undo Text 

Frame Linking from the Edit menu.    This places the text from the last connected text frame back into the 
frame preceding it, and breaks the connection between the two frames.

See also
Import Text Command (File Menu)
Adding an Entire File of Text from Another Application



Disconnecting and Reconnecting Text Frames
Resizing a Frame or Drawn Object



 Disconnecting and Reconnecting Text Frames
Connected text frames can be disconnected and reconnected to other text frames any time you want to 
change the way a story is displayed in your publication.    For example, you may want a story that 
currently appears on pages 2, 3, and 4 to appear on pages 2, 4, and 5.    All you have to do is disconnect 
the frame on page 3, reconnect the frames on pages 2 and 4 , and then connect to a new frame on page 
5.

 To disconnect text frames
1 Select the text frame preceding the one you want to disconnect.
2 Click the connect button of the selected frame.

Publisher breaks the connection between the selected frame and all the frames in the chain that 
follow it.    Any text that was in the disconnected frames will be pulled back into the overflow area of 
the frame you've selected.    You can connect the currently selected frame to empty frames, and the 
text in its overflow area will be displayed in the newly connected frames.

3 If you do not want to connect the selected frame to a new frame at this time, click anywhere outside 
a text frame.
 To reconnect text frames

1 Select the text frame you want to reconnect to empty text frames.
2 Click the connect button of the selected frame.
3 Click any empty text frame to connect it to the selected frame.

Publisher displays the text that was stored in the overflow area of the selected frame, in the newly 
added frame.    If the newly added frame is the first of a chain of empty frames, the other frames in 
the chain will also be connected.    If the newly added frame is in the middle of a chain, it will be 
disconnected from the frame preceding it and reconnected, with all the frames following it, to the 
frame you've selected. 

Note
When you disconnect two frames that appear in the middle of a chain, you break only that single 

connection and the result is two chains.    The first chain contains all the text of the story, although some 
may be contained in the overflow area.    There is no text in the second series of frames, but they remain 
connected, and you can add text to them or connect them to other frames at any time.

Tips
To move from one frame to the next frame in a chain of connected frames, select a frame, and 

hold down CTRL and press TAB.    To move from one frame to the previous frame in a chain of connected 
frames, select a frame, and hold down CTRL and press SHIFT and TAB.

To see all the frames that are connected on the current page, select one of the text frames 
containing the story, and then choose Highlight Story from the Edit menu.

See also
Displaying Long Stories in Connected Text Frames
Creating Frames for Text and Pictures



 Copying a Text Frame
If you want to create several text frames that are exactly the same, you can simply create the original 
frame and then copy it to the Clipboard.    Once an object has been copied to the Clipboard, you can 
paste as many copies of it as you need into any publication you choose.

 To copy a text frame
1 Select the text frame you want to copy.
2 From the Edit menu, choose Copy Text Frame.
3 If you want to put the copy on a different page of your publication, turn to that page. If you want to 

put the copy into another publication, from the File menu, choose Open Existing Publication and 
open that publication.

4 From the Edit menu, choose Paste Object(s) once for each copy of the text frame you want.
A copy of the frame is pasted into the middle of the window. 

Note
If all the frames in a chain of connected text frames are copied and pasted into another location, 

the frames and any text they contain are duplicated.    If only a few of the frames in a chain of connected 
frames are copied, only the frames, and not the text they contain, are duplicated.    For more information 
on connecting text frames, see the Displaying Long Stories in Connected Text Frames and Disconnecting 
and Reconnecting Text Frames topics referenced below.

Tips
You can copy text frames as a group instead of one frame at a time.    To copy text frames, drag 

the selection box around all of the text frames.    Then move the group to a new position, page, or 
publication.    For more information on selecting several frames at once, see the Selecting a Frame or 
Drawn Object topic referenced below.

To quickly copy a text frame you've selected, hold down CTRL and press C or INS.
To quickly paste a copy of a text frame you've copied to the Clipboard into your publication, hold 

down CTRL and press V, or hold down SHIFT and press INS.

What if...
I choose Paste but the wrong object is pasted?
The Clipboard can only hold one set of objects at a time.    When you copy something to the 

Clipboard, it replaces what was there before.    You may have copied something over the frame or frames 
you wanted to paste from the Clipboard.    First, from the Edit menu, choose Undo Paste Object(s).    
Then, copy the frame or frames you want to duplicate and try again.

See also
Displaying Long Stories in Connected Text Frames
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object
Moving a Text Frame Within a Publication
Moving a Text Frame Between Publications
Moving a Frame or Drawn Object



 Moving a Text Frame Within a Publication
You can move a text frame anywhere in your publication by selecting the frame and dragging it to a new 
position. You can also move a text frame to a different publication.    For more information, see the 
Moving a Text Frame Between Publications topic referenced below.

 To move a text frame
1 Select the text frame you want to move.
2 Position the mouse pointer over the edge of the selected frame until the mouse pointer changes to 

the Mover.
3 Hold down the mouse button and drag the frame to the new position. 

As you drag, a dotted line indicates the text frame's new position.    When you release the mouse 
button, the frame and any text it contains will move to the new location.
 To move a text frame between pages

1 Move the text frame onto the scratch area using the procedure above.
2 Turn to the page you want to move the text frame to.
3 Move the text frame onto the new page using the procedure above. 

Tips
You can move several text frames as a group instead of one frame at a time.    To move a group 

of text frames, drag the selection box around all of the frames.    Then move the group to a new position, 
page, or publication.    For more information on selecting text frames at once, see the Selecting a Frame 
or Drawn Object topic referenced below.

To drag a text frame or group of text frames in a straight line either vertically or horizontally, hold 
down SHIFT while you move the frames.

What if...
I accidentally change the size of the text frame?
You probably dragged one of the square handles on the text frame.    Before you do anything 

else, restore the text frame to its original size by choosing Undo Resize Object from the Edit menu.    Try 
moving the frame again, making sure you see the Mover before you begin.

See also
Moving a Text Frame Between Publications
Displaying Long Stories in Connected Text Frames
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object
Copying a Text Frame
Resizing Text Frames
Deleting Text Frames
Aligning Objects on the Page with Snap To



 Moving a Text Frame Between Publications
You can move a text frame from one publication to another.    Use the Cut command to move the text 
frames to the Clipboard, open the publication you want to move the frames to, and then paste the frame 
into the new publication. 

 To move a text frame between publications
1 Select the text frame you want to move.
2 From the Edit menu, choose Cut.
3 From the File menu, choose Open Existing Publication and open the publication you want to paste 

the text frame into.
Publisher prompts you to save any changes you've made to the publication you're moving the text 
frame from.

4 From the Edit menu, choose Paste Object(s).
A copy of the selected text frame is pasted into the middle of the current window.    You can then 
move or resize the object however you want.

Note
If all the frames in a chain of connected text frames are cut and pasted into another location at 

the same time, the frames and any text they contain are moved.    If only a few of the frames in a chain of 
connected frames are cut, only the frames, and not the text they contain, are moved.    When you cut a 
few frames from a chain, the remaining frames are reconnected, and any text that was in the frames that 
you cut is stored in the overflow area of the last frame in the chain.    For more information on how to 
connect text frames, see the Displaying Long Stories in Connected Text frames and the Disconnecting 
and Reconnecting Text Frames topics referenced below.

Tips
You can move text frames as a group instead of one frame at a time.    To move a group of text 

frames, drag the selection box around all of the frames.    Then move the group to a new position, page, 
or publication.    For more information on selecting several text frames at once, see the Selecting a Frame 
or Drawn Object topic referenced below.

To easily move text frames from one publication to another, open Publisher twice so you have two 
sessions running at the same time.    In one session, open the publication you want to move the text 
frame from.    In the other session, open the publication you will move the text frame to.    Then, arrange 
the publications side by side on the screen and work between them.

To quickly move a text frame you've selected, hold down CTRL and press X, or hold down SHIFT 
and press DELETE.    This places the text frame on the Clipboard.    Then, turn to the page you want to 
move the text frame to, hold down CTRL, and press V, or hold down SHIFT and press INS.    This quickly 
pastes the text frame back into your publication.

See also
Moving a Text Frame Within a Publication
Opening an Existing Publication
Displaying Long Stories in Connected Text Frames
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object
Copying a Text Frame
Resizing Text Frames
Deleting Text Frames
Aligning Objects on the Page with Snap To



 Resizing Text Frames
You can change the size of a text frame at any time.    When you resize a frame, the text automatically 
rewraps to fit the new frame size.    If you make a connected frame smaller, text that no longer fits in the 
resized frame automatically flows to the next connected frame.    If you make a connected frame larger, 
the text from the next connected frame flows back into the resized frame.    For more information on 
connecting text frames, see the Displaying Long Stories in Connected Text Frames topics referenced 
below.

 To change the size of a text frame
1 Select the text frame you want to change.

Only one frame can be resized at a time.
2 Position the mouse pointer over one of the frame's eight    handles until the mouse pointer changes 

to the Resizer.
3 Hold down the mouse button and drag the handle until the text frame is the size you want.

As you drag the handle, a dotted line shows you the frame's new size.    When you release the 
mouse button, the frame changes size.    The text automatically rewraps to fit the new frame size.
 To cancel a change you've made to the size of a text frame

Immediately after changing the size of a text frame, from the Edit menu, choose Undo Resize 
Object.

Note
When you change the size of a text frame, its margins remain the same width and height.    For 

more information on changing margins, see the Changing the Margins Within a Text Frame topic 
referenced below.

Tips
When you want to change the size of a text frame and keep its proportions the same, hold down 

SHIFT as you drag one of the four corner handles of the frame.
When you want to change the size of a text frame and keep the center of the frame in the same 

place, hold down CTRL as you change its size.
When you want to change the size of a text frame, keep its proportions, and keep the frame's 

center in the same place, hold down SHIFT and press CTRL as you drag one of the four corner handles of 
the frame.

To quickly cancel a change you've just made to the size of a text frame, immediately hold down 
ALT and press BACKSPACE.

What if..
I can't see all my text after I make a text frame smaller?
If the resized frame isn't connected to any other frames, the text may be stored in its overflow 

area.    If the resized frame is connected to other frames, the text may be displayed in the next connected 
frame.    For more information on connecting text frames, see the Displaying Long Stories in Connected 
Text Frames topic referenced below.

I end up with empty text frames after I make a connected text frame larger?
The larger frame can now hold more text.    Text from connected frames that follow it will be pulled 

back into the larger frame until it's full.    This may leave some of the other frames in the chain of 
connected frames empty.    For more information on connecting text frames, see the Displaying Long 
Stories in Connected Text Frames topic referenced below.

See also
Displaying Long Stories in Connected Text Frames
Changing the Margins Within a Text Frame
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object



 Deleting Text Frames
To permanently remove a text frame from your publication, delete it.    When you delete a text frame, you 
remove the frame and the text in the frame, unless it's connected to other text frames.

 To delete a text frame or group of text frames
1 Select the text frame or group of text frames you want to delete.
2 From the Edit menu, choose Delete Text Frame if you've selected one text frame or Delete Object(s) 

if you've selected a group of text frames.
If you have selected a group of text frames to delete, you can also press the DELETE key.
 To restore a deleted text frame or group of text frames

Immediately after deleting the text frame or group of text frames, from the Edit menu, choose 
Undo Delete Object(s).

Note
If all the frames in a chain of connected text frames are deleted, both the frames and any text 

they contain are deleted.    If only a few of the frames in a chain of connected frames are deleted, only the 
frames, and not the text they contain, are deleted.    When you delete a few frames from a chain, the 
remaining frames are reconnected, and any text that was in the frames that you deleted is stored in the 
overflow area of the last frame in the chain.    For more information on how to connect text frames, see the 
Displaying Long Stories in Connected Text Frames and the Disconnecting and Reconnecting Text Frames 
topics referenced below.

Tip
To quickly restore a text frame you've just deleted, immediately hold down ALT and press 

BACKSPACE.

What if...
I want to delete a text frame but I can't select it?
The frame you're trying to delete may be on the background.    From the Page menu, choose Go 

to Background and try again.    Remember, if you delete a frame from the background, it will disappear 
from every page of your publication.

See also
Displaying Long Stories in Connected Text Frames
Disconnecting and Reconnecting Text Frames
Selecting a Frame or Drawn Object
Adding Text and Pictures That Will Repeat on Every Page



 Choosing the Text You Want to Change
Whenever you want to change text you've typed or imported, you need to identify which text it is you 
want to change.    This is called highlighting text.

 To highlight text
1 Position the insertion point in front of the first letter of the text you want to highlight.
2 While holding down the mouse button, drag the mouse to extend the highlight over the text you want 

to change.
 To highlight all the text in a story

1 Click anywhere in the text of the story.
2 From the Edit menu, choose Highlight Story.

 To remove highlighting from text
Simply click anywhere.

Tip
To use the shortcuts for highlighting text shown in the table below, place the insertion point where 

you want to begin highlighting text, and then:

Press To highlight

F8 or CTRL+A The entire story

SHIFT+LEFT or RIGHT ARROW Text one character at a time to the left or right.

--Or--

If a character is already highlighted, pressing SHIFT and holding 
down LEFT or RIGHT ARROW cancels or extends the highlight.

SHIFT+UP or DOWN ARROW One line of text up or down.

--Or--

If a line is already highlighted, pressing SHIFT and holding down UP 
or DOWN ARROW cancels or extends the highlight.

SHIFT+HOME Text to the beginning of a line

SHIFT+END Text to the end of a line

CTRL+SHIFT+LEFT ARROW The previous word

CTRL+SHIFT+RIGHT ARROW The next word

CTRL+SHIFT+HOME Text to the beginning of the current frame

CTRL+SHIFT+END Text to the end of the current frame

CTRL+SHIFT+UP ARROW All text in a paragraph to the left of the insertion point

CTRL+SHIFT+DOWN ARROW All text in a paragraph to the right of the insertion point

See also
Highlight Story Command (Edit Menu)
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text for You
Removing and Retyping Text
Checking Text for Spelling Errors



 Having Publisher Find the Text You Want to Change
Publisher can find any piece of text you specify.    For example, you can search for a word, phrase, 
number, or punctuation mark to help you quickly locate a part of a story.

To find a piece of text you specify
1 Place the insertion point anywhere in the story that contains the specific piece of text you want to 

find.
2 From the Edit menu, choose Find.
3 In the Find What box, type the text that you want to find.
4 Choose the Match Whole Word Only check box if you want to find a specific word, such as    

"bicycle," and ignore longer variations of the word, such as "bicycles."
An X in the check box indicates that it is chosen.

5 Choose the Match Case check box if you want to find text that matches the exact combination of 
upper and lower case letters you've typed in the Find What box, such as "Then."
An X in the check box indicates that it is chosen.

6 Under Direction, choose Down if you want to search from the insertion point to the end of the story 
or Up if you want to search from the insertion point to the beginning of the story.

7 Choose the Find Next button to find the next occurrence of the specified text.
When Publisher finds the text you specified, Publisher shows you the place in the story where it is 
located.

8 When you're finished, choose the Cancel button to return to the story.

Notes
Publisher will not search for text in the overflow area.
To have Publisher find a special character, such as a tab character or an end of paragraph mark, 

type the character combinations listed in the table below:

Type To find

^^ A caret character (^)

? Any single character.    For example, if you want to find all occurrences of the words 
"sing" and "ring", type ?ing

^? A question mark

^- An optional hyphen

^~ A nonbreaking hyphen

^n A line break

^p The end of a paragraph

^s A nonbreaking space

^t A tab stop

^w A white space.    For example, a tab character or a space between words

Tips
Change to Actual Size view before you start your search to be sure you can read the results 

when Publisher locates a word or special character.
Sometimes, the word Publisher locates may be hidden by the Find dialog box.    If you can't see 

the word Publisher has located for you, drag the dialog box to the corner of your window.

See also
Choosing the Text You Want to Change
Having Publisher Find and Change Text for You
Removing and Retyping Text
Checking Text for Spelling Errors



Find Command (Edit Menu)
Replace Command (Edit Menu)



 Having Publisher Find and Change Text for You
Publisher can replace a piece of text with text you specify throughout an entire story or within highlighted 
text.

To replace specified text with new text
1 Place the insertion point anywhere in the story that contains the specific piece of text you want to 

find and replace.
You can also highlight a block of text that contains the specific piece text you want to replace.    If 
you don't highlight any text, Publisher searches the entire story.

2 From the Edit menu, choose Replace.
3 In the Find What box, type the text you want to search for.
4 In the Replace With box, type the replacement text.

If you want to remove the text you're searching for without replacing it, leave the Replace With box 
blank.

5 Select the Match Whole Word Only check box if you want to find a specific word, such as    "bicycle," 
and ignore longer variations of the word, such as "bicycles."
An X in the check box indicates that it is chosen.

6 Select the Match Case check box if you want to find only the text that matches the exact 
combination of upper and lower case letters you've typed in the Find What box, such as "Then."
An X in the check box indicates that it is chosen.

7 Choose from the following options:
Find Next: finds the next occurrence of the text you're searching for without replacing the current 
occurrence.
With this option, Publisher does not search for specified text in text that's stored in the overflow 
area.
Replace: replaces the current occurrence, and then finds the next occurrence of the text you're 
searching for.
Publisher replaces the current occurrence and finds the next occurrence of the specified text in text 
displayed in text frames, not in text contained in the overflow area.
Replace All: automatically replaces all occurrences of the text you're searching for with the 
replacement text.
With this option, Publisher searches for and replaces all occurrences of the specified text both in 
text displayed in text frames on the page of a publication and on the scratch area.    Publisher also 
searches for and replaces all occurrences of the specified text contained in the overflow area.
Close: returns you to the story.

Note
To have Publisher search for or replace text with special characters, such as tab characters, type 

the character combinations listed in the table below:

Type To find or replace with

^^ A caret character (^)

^? A question mark

^- An optional hyphen

^~ A nonbreaking hyphen

^c The contents of the Clipboard

^m The contents of the Find What box.    For example, if you have typed the word "fish" 
in the Find What box and want to replace it with the word "fishes", type ^mes in the 
Replace With box.

^n A line break



^p The end of a paragraph

^s A nonbreaking space

^t A tab stop

Tips
Change to Actual Size view before you start your search to be sure you can read the results 

when Publisher locates and replaces a word or special character.
Sometimes, the word Publisher locates may be hidden by the Replace dialog box.    If you can't 

see the word Publisher has located for you, drag the dialog box to the corner of your window.

What if...
I accidentally make replacements I don't want?
Immediately after choosing the Replace or Replace All button, from the Edit menu, choose Undo.

See also
The Undo Command
Choosing the Text You Want to Change
Having Publisher Find the Text You Want to Change
Removing and Retyping Text
Checking Text for Spelling Errors
Replace Command (Edit Menu)
Find Command (Edit Menu)



 Checking Text for Spelling Errors
Publisher can check the spelling of a single word or an entire story.    Using a dictionary of one hundred 
thousand words, Publisher looks for misspellings and incorrect capitalizations.

To check the spelling of text
1 Place the insertion point anywhere in the story you want to check for spelling errors.
2 From the Options menu, choose Check Spelling.
3 If you want Publisher to ignore words in all capital letters in the spelling check, choose the Skip ALL-

CAPITAL Words check box.
An X in the check box indicates that it is chosen.

4 If you want Publisher to automatically check all the stories in a publication, choose the Check All 
Stories check box. 
An X in the check box indicates the option is chosen.

5 Each time Publisher finds a word that is not in the dictionary, you can do one of the following:
Choose the Ignore button to leave the word unchanged or Ignore All to leave all subsequent 

occurrences of the word unchanged.
In the Change To box, type a correction.    Then, choose the Change button to insert the 

correction in the text or choose Change All to insert the correction in the text for each occurrence of the 
misspelled word.

Choose the Add button to leave the word unchanged and add it to the dictionary.
In the Suggestions box, choose a word from the list.    Then choose the Change button to insert 

the suggested word in the text or the Change All button to insert the suggested word in the text for each 
occurrence of the misspelled word.

Choose the Close button to return to the story.
To check the spelling of a single word

1 Double-click or highlight the word that you want to check for spelling errors.
2 From the Options menu, choose Check Spelling.
3 If the word is spelled correctly, Publisher displays a box that confirms the correct spelling and asks if 

you want to check the spelling of the rest of the story.
Choose the No button to end the spelling check.
You can also choose the Yes button to check the spelling of the rest of the story.    See steps 3-5 in 
the first procedure for information on how to do this.

4 If the word is spelled incorrectly, see step 5 in the first procedure.    After you've corrected the 
spelling, Publisher will continue to check the rest of the story.

5 Choose the Close button at any time to end the spelling check and return to your publication.

Notes
Publisher starts checking text for spelling errors from the location of the insertion point.
Publisher will also check for spelling errors in stories on the scratch area and the background.    

Just click in a text frame on the background or in the scratch area and follow one of the above 
procedures.

What if...
Check Spelling is unavailable?
You may have forgotten to place the insertion point in the story.

See also
Choosing the Text You Want to Change
Removing and Retyping Text



 Removing and Retyping Text
After you've added text to your publication, you can change or refine the text as much as you like.    This 
often involves replacing existing text with new text.

Below are three basic ways of removing and replacing text you want to change.    The BACKSPACE key is 
convenient for changing text you've just typed.    The DELETE key is best for removing a few characters or 
removing highlighted text you don't want to retype.    Replacing highlighted text by typing is a quick 
method for retyping or replacing existing text.

 To remove characters with the BACKSPACE key
1 Position the insertion point after the characters you want to remove.

If you've just finished typing something you want to change, the insertion point should already be in 
position.

2 Press the BACKSPACE key until all of the characters you want to remove are gone.
3 To replace the characters you've removed, just begin typing.

 To remove characters with the DELETE key
1 Highlight the text or position the insertion point just before the characters you want to remove.
2 Press the DELETE key until all the characters that you want to remove are gone.
3 To replace the text you've removed, just begin typing.

 To replace highlighted text by typing new text
1 From the Options menu, choose Settings.
2 Choose Typing Replaces Selection.
3 Choose the OK button.
4 Highlight the text you want to replace.
5 Type the new text.

Publisher replaces the text that is highlighted with the new text you type, and will continue to do this 
in every publication you create until you turn off Typing Replaces Selection.

What if...
I accidentally remove text?
Immediately after removing the text, before you do anything else, choose Undo Typing from the 

Edit menu.    The text will reappear in your publication.

See also
Choosing the Text You Want to Change
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text for You
Deleting Text
Settings Command (Options Menu)
Copying Text
Moving Text
Adding a Piece of Text from Another Application



 Copying Text
You can copy text from one place to another within a publication, or from one publication to another.    
First, you copy the text--the copy is placed on the Clipboard.    Then, you paste the text.    When you 
paste text, Publisher makes a copy of the text that's on the Clipboard and places it in the text frame 
where you've positioned the insertion point.    You can paste that text repeatedly until you copy 
something else onto the Clipboard.

 To copy text
1 Highlight the text you want to copy.
2 From the Edit menu, choose Copy Text.
3 Position the insertion point where you want the text to appear.

If you want to copy the text to another publication, you can close one publication and open another 
without affecting the text on the Clipboard.

4 From the Edit menu, choose Paste Text.

Tips
To quickly copy text you've highlighted to the Clipboard, press and hold CTRL and press C or INS.
To quickly paste the text you've copied into your publication, hold down CTRL and press V, or hold 

down SHIFT and press INS.

See also
Copy Command (Edit Menu)
Copying Pages
Moving Text
Removing and Retyping Text
Deleting Text
Choosing the Text You Want to Change



 Moving Text
You can move text from one place to another within a publication, or from one publication to another.    
First, you cut the text--this removes it from its current location and places it on the Clipboard.    Then, you 
paste it.    When you paste text, Publisher makes a copy of the text that's on the Clipboard and places it 
in the text frame where you've positioned the insertion point.    You can paste that text repeatedly until 
you cut or copy something else onto the Clipboard.

 To move text
1 Highlight the text you want to move.
2 From the Edit menu, choose Cut Text.
3 Position the insertion point in the text frame where you want the text to appear. 

If you want to move the text to another publication, you can close one publication and open another 
without affecting the text on the Clipboard.

4 From the Edit menu, choose Paste Text.

Tip
To quickly cut text you've highlighted, hold down CTRL and press X, or hold down SHIFT and press 

DEL.
To quickly paste the text you've moved into your publication, hold down CTRL and press V, or hold 

down SHIFT and press INS.

What if...
I accidentally cut text?
Immediately after cutting the text, before you do anything else, choose either the Undo Cut Text 

or the Paste Text command from the Edit menu. The text will reappear in your publication.

See also
Cut Command (Edit Menu)
Copying Text
Removing and Retyping Text
Deleting Text
Choosing the Text You Want to Change



 Deleting Text
Deleting text removes it from the publication permanently.    If you want to move text within a story, or 
from one publication to another, you'll need to use the Cut and Paste commands.    For more information 
on moving text, see the Moving Text topic referenced below.

 To delete text one character at a time with the DELETE key
1 Position the insertion point before the character you want to delete.
2 Press the DELETE key.

 To delete text one character at a time with the BACKSPACE key
1 Position the insertion point after the character you want to delete.
2 Press the BACKSPACE key.

 To delete highlighted text
1 Highlight the text you want to delete.
2 Press the DELETE key.

You can also choose Delete Text from the Edit menu.

What if...
I accidentally delete text?
Immediately after deleting the text, before you do anything else, choose Undo Delete Text from 

the Edit menu.

See also
Delete Command (Edit Menu)
Undo Command (Edit Menu)
Moving Text
Copying Text
Removing and Retyping Text
Choosing the Text You Want to Change



 Hyphenating Words
You can hyphenate words yourself, or you can have Publisher do it automatically.    Hyphenate words 
yourself when the spelling of a word includes a hyphen, such as "well-rounded," or when you want to 
control the length of each line.    Use the following kinds of hyphens to hyphenate words manually:

regular hyphen Use for words that are always hyphenated and can be split at the 
end of a line, such as well-rounded.

optional hyphen Use for words that are only hyphenated when they won't fit at the 
end of a line.    When you make changes to your text, the word will 
not remain hyphenated if it does not appear at the end of the line.

nonbreaking hyphen Use for words that you do not want split between two lines, such as 
the name James Brown-Smith.

Use Publisher to automatically hyphenate words if you: 1) anticipate changing text and the hyphens in 
the text will need to change too, 2) want to create a less ragged right margin or eliminate white gaps in 
justified text, or 3) are hyphenating many words.    When Publisher hyphenates for you, you don't have to 
worry about redoing hyphens when you make changes to your text because Publisher takes care of it.

To hyphenate words manually
1 Place the insertion point where you want a hyphen.
2 Press the key(s) for the kind of hyphen you want.

Press For this kind of hyphen

HYPHEN (-) regular hyphen

CTRL+HYPHEN (-) optional hyphen

CTRL+ALT+HYPHEN (-) nonbreaking hyphen

To have Publisher automatically hyphenate text for you
1 Highlight the text you want to hyphenate, or click anywhere in the text if you want to hyphenate the 

entire story.
2 From the Options menu, choose Hyphenate.
3 In the Hyphenation Zone box, accept the suggested measurement, or type a new measurement.

For a more even right edge to your text or for fewer white gaps in justified text, type a smaller 
measurement in the Hyphenation Zone.    For fewer hyphens or if you dislike short single syllables at 
the end or beginning of lines, type a larger measurement in the Hyphenation Zone.

4 An X in the Confirm check box indicates that Publisher will display each word to be hyphenated in 
the Hyphenate At box.    For each word, choose the Yes button to insert a hyphen, the No button to 
skip the word shown, or the Cancel button to stop the hyphenation process.    If you want Publisher 
to insert hyphens automatically without first displaying them, choose the Confirm button to remove 
the X from the check box. 

5 Choose the OK button.

Tips
You can search a story for optional and nonbreaking hyphens by using the Find and Replace 

command.    For more information, see the Having Publisher Find the Text You Want to Change and 
Having Publisher Find and Change Text for You topics referenced below.

To quickly hyphenate words using Publisher's Hyphenate command, hold down CTRL and press H.

See also
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text for You
The Undo Command
Checking Text for Spelling Errors





 Aligning Text in Text Frames
Whenever you type a story, Publisher begins each line at the left margin of the frame.    This alignment 
works best for the main text of a publication because it is easiest to read and allows even word spacing. 
For specific pieces of text, however, you may want to choose a different alignment.    For example, in a 
newsletter you can center the headline of a one-column article over the text.    In Publisher, you can align 
text in four ways: 1) with the left margin, 2) with the right margin, 3) centered between margins, and 4) 
with both margins (justified).

To change the alignment of text
1 Click anywhere in the paragraph you want to align.

--Or--
If you want to align more than one paragraph, highlight the paragraphs you want to align.

2 On the Toolbar, choose the alignment you want.

Choose When you want to

L (left) Align a paragraph at the left margin.    The right side of the paragraph is not aligned.

C (centered) Center a paragraph between the left and right margins.

R (right) Align a paragraph at the right margin. The left side of the paragraph is not aligned.

J (justified) Align a paragraph evenly between the right and left margins.    Space is added 
between words as needed.

Tips
You can use centered text for headlines, pull quotes, and sidebars, and for invitations and 

greeting cards.    For more information on headlines, pull quotes, and sidebars, see the Creating 
Headlines and the Creating Sidebars and Pull Quotes topics referenced below.

You can use right-aligned text for captions.    It is not recommended for the main text of an article 
because it is more difficult to read.    For more information on captions, see the Creating Captions topic 
referenced below.

If you use justified text, you may find that your text contains uneven spacing and white gaps you 
don't want.    You can create fewer gaps by hyphenating your text.    For more information, see the 
Hyphenating Words topic referenced below.

You can also align the whole frame to guides or to marks on the rulers.    For more information, 
see the Aligning Objects on the Page with Snap To topic referenced below.

You can use the following keyboard shortcuts to align paragraphs you've highlighted.    For 
example, to justify the paragraphs you've highlighted, hold down CTRL and press J.

Press When you want to

CTRL+E Center a paragraph

CTRL+J Align a paragraph evenly between the right and left margins

CTRL+L Align a paragraph at the left margin

CTRL+R Align a paragraph at the right margin

CTRL+Q Return a paragraph to standard format (left alignment, no indents, no space before or 
after paragraphs, default tabs, single-spacing)

See also
Creating Headlines
Creating Sidebars and Pull Quotes
Creating Captions
Hyphenating Words
Aligning Objects on the Page with Snap To
Inserting or Removing a Tab Stop



Changing the Alignment or Leader for a Tab Stop
Indenting Your Text



 Changing the Margins Within a Text Frame 
Adding space around text in your publication sets the text off from the rest of your publication and makes 
it easier to read.    You can add space by changing the margins within the text frame.

 To change the margins within a text frame
1 Select the frame whose margins you want to change.
2 From the Layout menu, choose Frame Columns and Margins.
3 Under Margins, in the Left and Right box, type the amount of space you want between your frame 

and the left and right edges of your text. 
4 Under Margins, in the Top and Bottom box, type the amount of space you want between your frame 

and the top and bottom edges of your text.
5 Choose the OK button.

Notes
When you change the size of a text frame, its margins remain the same width and height.
The margins you set for a text frame also affect how text within the frame wraps around frames 

placed on top of it.    The margins you set will determine how much space there is between the text and 
the frame it's wrapped around. 

What if...
I can't see all of the text after I change the margins?
The size of a text frame does not change when you adjust its margins.    Therefore, if you 

increase the size of the margins, the text may not fit in the smaller space.    Some of the text may have 
been moved into any connected text frames or into the overflow area of the current frame.    For more 
information on connecting text frames, see the Displaying Long Stories in Connected Text Frames topic 
referenced below.

See also
Displaying Long Stories in Connected Text Frames
Indenting Your Text
Frame Columns and Margins Command (Layout Menu)
Layering Text, Pictures, and Drawn Objects



 Inserting or Removing a Tab Stop
Tab stops help you align text precisely within a text frame.    For example, you can use tab stops for 
aligning information in a table or indenting the first line of a paragraph.    When you press the TAB key, 
Publisher inserts a space and moves the insertion point forward to the next tab stop.    You can use 
Publisher's preset, half-inch tab stops, or you can set your own.

To set a tab stop
1 From the Format menu, choose Tabs.
2 In the Tab Positions box, type a measurement.

The measurement you type is the distance you want from the left margin of the text frame to the tab 
stop.    You can also choose an alignment and leader for the tab stop in the Alignment and Leader 
boxes.    For more information, see the Changing the Alignment or Leader for a Tab Stop topic 
referenced below.

3 Choose the Set button.
For each additional tab stop you want to create, in the Tab Positions box, type the measurement for 
the tab stop and choose the Set button.

4 Choose the OK button.
To set a tab stop for existing text

1 Click in the text you want to align with tab stops, or highlight several paragraphs at once.
If you haven't highlighted several paragraphs, the tab stops you set will apply only to the paragraph 
you've clicked in.

2 Follow steps 2-4 above.
3 Position the insertion point in front of the text you want    to move and press the TAB key.

To remove a tab stop
1 From the Format menu, choose Tabs.
2 In the Tab Positions box, highlight the measurement you want to remove.
3 Choose the Delete button.

You can also choose the Delete All Tabs button to remove all the tabs you've set.
4 Choose the OK button.

Tip
When positioning tab stops, move the horizontal ruler's zero point to the edge of the text frame in 

which you're inserting the tab stop.    This makes it much easier to measure the distance from the edge of 
the text frame to where you want your tab stop to be.    For more information on working with the rulers, 
see the Using Rulers topic referenced below.

See also
Changing the Alignment or Leader for a Tab Stop
Using the Rulers
Tabs Command (Format Menu)



 Changing the Alignment or Leader for a Tab Stop
Publisher automatically lines up the left edge of your text at the tab stop.    However, you can change this 
alignment at any time.    For example, in the case of numbers, you might want each number to align at 
the decimal point.

You can also set a leader for each tab stop.    A leader is the symbol or character that fills in the space 
between where you pressed the TAB key and the tab stop position.

 To change the alignment and leader for a tab stop
1 Click in the paragraph or text that contains the tab stop you want to change, or highlight several 

paragraphs at once.
If you haven't highlighted several paragraphs, the changes you make will apply only to the 
paragraph you've clicked in.

2 From the Format menu, choose Tabs.
3 In the Tab Positions box, choose the tab position you want to align or add a leader to.
4 Under Alignment, choose the alignment option you want.
5 Under Leader, choose the leader option you want.
6 Choose the Set button.
7 If you want to change the alignment or leader for other tab stops in the paragraph, repeat steps 3-6 

above.
8 When you're done making changes, choose the OK button.

See also
Inserting or Removing a Tab Stop
Tabs Command (Format Menu)



 Indenting Your Text
Indents can be used to offset the first line of text in a paragraph, or to draw attention to specific 
paragraphs by making them narrower than the rest of the text in the story.    For example, you can call 
attention to a large quotation by indenting both the left and right margins to center it within the body of a 
story.

To quickly indent the first line of one paragraph
1 Position the insertion point in front of the line you want to indent.
2 Press the TAB key.

To indent the first line of one or more paragraphs
1 Click in the paragraph whose first line you want to indent, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing.
3 Under Indents, in the First Line Indent box, type a measurement for how much you want the first line 

of each paragraph indented.
The First Line Indent is measured from the left indent of the highlighted paragraphs, not from the 
edge of the frame.

4 Choose the OK button.
To indent one or more paragraphs

1 Click in the paragraph you want to indent, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing.
3 Under Indents, in the Left Indent box, type an indent measurement for the left side of the paragraph.
4 Under Indents, in the Right Indent box, type an indent measurement for the right side of the 

paragraph.
5 Choose the OK button.

To remove indents from a paragraph
1 Click in the paragraph with the indents you want to remove, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing.
3 Under Indents, in the Left and Right Indent boxes, type 0 (zero).
4 Choose the OK button.

To set a hanging indent for one or more paragraphs
1 Click in the paragraph where you want to set the hanging indent, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing.
3 Under Indents, in the Left Indent box, type the measurement for the amount of space you want to 

indent the text.    All the text in the highlighted paragraphs, except for the first line, will appear to the 
left of this location.

4 Under Indents, in the First Line Indent box, type a negative number equal to the measurement you 
typed in the Left Indent box (for example, type -1.5 if the left indent is 1.5).
This number indicates how far the first line of text appears to the left of the rest of the text in the 
paragraph.

5 Choose the OK button.

Tip
Hanging indents are useful for arranging certain types of information such as bibliographies and 

lists.    For more information, see the Creating a Numbered or Bulleted List topic referenced below.

See also
Creating a Numbered or Bulleted List
Inserting or Removing a Tab Stop
Indents and Spacing Command (Format Menu)



 Creating a Numbered or Bulleted List
Numbered and bulleted lists are created using "hanging" indents.    This means that the text of each item 
in the list "hangs" to the right of a number or bullet.    Using hanging indents ensures that the numbers or 
bullets are precisely aligned with the items in the list.

To create a numbered list
1 In the text frame where you're going to put your list, type a number where you want your list to 

begin.
If you're creating a list from text that's already in the frame, type the number to the left of the text for 
the first list item.

2 Press the TAB key.
3 Highlight or type the text that you want to follow the number.    This is the text that receives the 

hanging indent.
4 From the Format menu, choose Indents and Spacing.
5 Under Indents, in the Left Indent box, type the measurement for the amount of space you want to 

indent the text of the list.    The numbers will appear to the left of this location.
6 In the First Line Indent box, type a negative equivalent of the measurement in the Left Indent box 

(for example, type -1.5 if the left indent is 1.5).
This number indicates how far the number appears to the left of the text.

7 Choose the OK button.
8 Press ENTER to begin the next item in the list.    Publisher automatically applies the same hanging 

indent to each item in the list until you return to normal paragraph formatting.    When you're done 
creating the list, hold down CTRL and press X to return to left-aligned paragraph formatting.
 To create a bulleted list

1 Create a text frame.
2 Type your list in the frame.
3 From the Toolbar, select the Box, Rounded Box, or Oval Tool.
4 Position the insertion point outside the text frame and to the left of the first item in the list, and then 

draw the shape you've chosen to use as a bullet.
5 From the Layout menu, choose Shading.
6 Under Style, choose the pattern you want to fill the shape you've drawn.
7 Choose the OK button.
8 Position the bullet or a copy of the bullet to the left of each list item.

Tips
If you're creating several bullets, make one bullet exactly the way you want it first, and then make 

copies of that bullet by each item in the list.    This ensures that all your bullets will be the same size.    For 
more information on moving objects, see the Moving a Frame or Drawn Object topic referenced below.

You can use the rulers to help you align the bullets.    Move the horizontal ruler so that you can 
use its bottom edge to align the bullet with the item in the list, and then move the vertical ruler so you can 
use its edge to align all the bullets in a straight line.    For more information about working with rulers, see 
the Using the Rulers topic referenced below.

To align the text in the list closer to the bullets, make the left margin of the text frame containing 
the list smaller.    For more information on changing margins, see the Changing the Margins Within a Text 
Frame topic referenced below.

See also
Moving a Frame or Drawn Object
Using the Rulers
Creating Frames for Text and Pictures
Changing the Margins Within a Text Frame
Indenting Your Text
Indents and Spacing Command (Format Menu)





 Creating Tables
Tables help you organize information and provide a quick reference for your readers.    Publisher 
provides a PageWizard to make tables fast and easy to create.

To create a table
1 On the Toolbar, choose the PageWizard tool.
2 While holding down the mouse button, drag the mouse to indicate the size you want the table to be 

and where you want it to appear.
3 In the PageWizard dialog box, choose Table.
4 Choose the OK button.
5 In the series of dialog boxes the PageWizard displays, answer the questions to indicate what you 

want your table to look like.    After you answer each question, choose the Next button to go on.
6 Choose the Create It button to place the table in your publication.
7 Choose the OK button.

Tip
You can create tables in text frames using tabs and columns, just as you would with a word 

processor.    However, you'll find it easier to use the PageWizard.

See also
Creating Special Effects with PageWizards



 Changing the Space Between Letters (Kerning)
You may find that there is more or less space between some letters than between others, particularly 
when you type large letters, as in headlines.    You can adjust the amount of space between the letters in 
a word to make the entire word look more evenly spaced.    In the publishing world, this is called 
"kerning." 

To adjust the space between letters
1 Highlight the letters or text you want to change.

Publisher applies the change to the space after each letter you've highlighted.    So, if you've 
highlighted the letters "k" and "e" in "kerning," and you choose to squeeze them together, "k," "e," 
and "r" get squeezed together.    If you want just the "k" and the "e" to be closer together, then only 
highlight the "k."

2 From the Format menu, choose Spacing Between Characters.
3 Under Spacing Between Characters, choose either the Squeeze Letters Together or Move Letters 

Apart option button.
4 In the By This Amount box, Publisher suggests a number for the amount of space to add or remove 

between letters.    Use this amount, or type a number for the amount of space that you want.
When entering an amount of your own, if you do not choose a unit of measurement, Publisher will 
automatically assume the measurement you've entered is in points.

5 Choose the OK button.
To restore the space between letters

1 Highlight the letters or text you want to change.
2 From the Format menu, choose Spacing Between Characters.
3 Under Spacing Between Characters, choose the Normal option button.
4 Choose the OK button.

See also
Choosing the Font, Size, and Position of Text
Changing the Space Between Lines of Text (Leading) and Paragraphs
Spacing Between Characters Command (Format Menu)



 Changing the Space Between Lines of Text (Leading) and Paragraphs
Publisher automatically uses single-line spacing, but you can specify how much space, or leading, you 
want to appear between lines of text.    Most publications use single- or double-spaced lines.

To change the spacing between lines of text
1 Click in the paragraph you want to change, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing.
3 Under Line Spacing, in the Space Between Lines box, type the number of spaces you want between 

each line of text. 
You can type any number between 0.33 spaces and 124 spaces.    For example, type 2 if you want 
double-spaced lines.

4 Choose the OK button.
To add space before or after paragraphs

1 Click in the paragraph you want to change, or highlight several paragraphs.
2 From the Format menu, choose Indents and Spacing. 
3 Under Line Spacing, in the Space Before Paragraph or Space After Paragraph box, type the number 

of spaces you want to add.

Tips
If you want to change the spacing for an entire story, select any frame in the story, choose 

Highlight Story from the Edit menu, and then follow the above procedure.
To quickly change text to single- or double-spacing, highlight the text you want to change, then 

click the single-space or double-space button on the Toolbar.
The height of the line is determined by the point size you've chosen for your text.    If you want to 

experiment, you can use the Point Size box on the Toolbar to change the size of your text. 

Tip
You can use the following keyboard shortcuts to quickly change the linespacing of paragraphs 

you've highlighted.    For example, to double-space the paragraphs you've highlighted, hold down CTRL 

and press 2.

Press When you want to

CTRL+1 Single-space lines

CTRL+2 Double-space lines

CTRL+5 Space lines 1 1/2 lines apart

CTRL+0 (ZERO) Remove the space just before the paragraphs

CTRL+Q Return the paragraphs to standard format (left alignment, no indents, no space 
before or after paragraphs, default tabs, single-spacing)

See also
Choosing the Font, Size, and Position of Text
Changing the Space Between Letters (Kerning)
Indents and Spacing Command (Format Menu)



 Choosing the Font, Size, and Position of Text
The font you choose and the size of your text establish the personality of your publication and focus the 
reader's attention.    It's usually most effective to use one font for the body of your publication and 
perhaps one or two additional fonts for headings or headlines.

To quickly choose the font and size of your text
1 Highlight the text you want to change.
2 In the Font box on the Toolbar, choose or type in a font.
3 In the Point Size box on the Toolbar, choose or type in a point size.

To choose the font, size, and position of your text
1 Highlight the text you want to change.
2 From the Format menu, choose Character.
3 In the Font box, type in the font you want or choose one from the list.

To choose a font from the list, click the arrow to the right of the Font box and then click the font you 
want.

4 In the Point Size box, choose or type in the size you want.
Publisher lists all the sizes available for the font you've chosen.

5 Under Super/Subscript, select the position you want.
Superscript text appears partially above the rest of the line.

Subscript text appears partially below the rest of the line.
6 Choose the OK button.

Tips
If your story is displayed in several connected text frames, click in any one of the frames, and 

then choose the Highlight Story command to be sure to highlight all the text in the story.
You can quickly add or remove a subscript or superscript format from text you've highlighted 

using the following keyboard shortcuts.    For example, to add a subscript format to highlighted text, hold 
down CTRL and press EQUAL SIGN (=).

Press When you want to

CTRL+EQUAL SIGN (=) Add or remove a subscript format

CTRL+SHIFT+PLUS SIGN (+) Add or remove a superscript format

CTRL+SPACEBAR Remove styles and a subscript or superscript format

What if...
The font or size I want doesn't appear in the font or size list?
Fonts and font sizes are determined by your printer and any printer cartridges you might be using. 

It's important to specify a printer in order to see all the fonts and sizes available to you.    For more 
information, see the Choosing a Printer topic referenced below.

Some of my letters are clipped off in the frame?
Your text will print normally.    Sometimes, the screen font your computer uses to display your text 

is slightly larger or smaller than the font you've chosen to print with.

See also
Choosing a Printer
Changing the Space Between Letters (Kerning)
Changing the Space Between Lines of Text (Leading) and Paragraphs
Choosing Colors for Text
Character Command (Format Menu)



 Choosing Styles: Bold, Italic, Underlined
Styles draw attention to text, without changing the original font.    You can format text with one style or 
several styles, but it's usually best to limit the number of styles you use within a single publication to 
keep it from looking cluttered.

 To change the style of text
1 Highlight the text you want to change.
2 From the Format menu, choose Character.
3 Under Style, choose the style or styles you want to apply to the highlighted text.

An X in the check box indicates the style is chosen.
4 Choose the OK button.

 To remove a style from text
1 Highlight the text you want to change.
2 From the Format menu, choose Character.
3 Under Style, choose the styles you want to clear from the highlighted text.
4 Choose the OK button.

Tips
For a shortcut to adding or removing styles from your text, on the Toolbar, click the buttons with 

the letter B, I, or U to add or remove the Bold, Italic, or Underline style.
You can apply more than one style to text, but text cannot have more than one capitalization style 

or more than one underline style. In other words, a character can be both bold and underlined, but it 
cannot be both single- and double-underlined.

You can quickly add or remove styles from text you've highlighted using the following keyboard 
shortcuts.    For example, to make highlighted text bold, hold down CTRL and press B.

Press When you want to 

CTRL+B Make highlighted text bold

CTRL+I Italicize highlighted text

CTRL+U Underline highlighted text

CTRL+SPACEBAR Remove styles and a subscript or superscript format from highlighted text

What if...
My printed copy doesn't show the styles I've chosen?
Some printers cannot print all the styles available in Publisher.    For more information, see the "A 

font or style you choose doesn't appear on the printed copy" topic referenced below

See also
Choosing the Font, Size, and Position of Text
A font or style you choose doesn't appear on the printed copy
Character Command (Format Menu)



 Choosing Colors for Text
In Publisher, you can choose from eight colors for your text.    Usually, it's best to use color only if you 
have access to a color printer, although sometimes color can be useful even if you don't.    For example, 
you might want to write small red notes to yourself in the scratch area of your publication, which can 
easily be seen but won't print when you print your publication.

To choose a color for text
1 Highlight the text you want to add color to.
2 From the Format menu, choose Character.
3 In the Color list box, choose the color you want.

To see all the colors available to you, click the arrow to the right of the Color list box.    Once the list 
is displayed, click the color you want the highlighted text to be.

4 Choose the OK button.

See also
Adding WordArt to Your Publication
Adding Patterns and Color to Text Frames and Drawn Objects



 Creating Fancy First Letters: Dropped and Raised
You can use fancy first letters to introduce a story or to dress up a page.    Fancy first letters use a 
different font and larger point size than the text in the body of the story.    You can have a PageWizard 
create a fancy first letter for you, or you can create one yourself using WordArt.

 To have Publisher create a fancy first letter for you
1 On the Toolbar, choose the PageWizard tool.
2 Position the mouse pointer where you want the upper-left corner of the letter to be.

If you want a dropped first letter, position the mouse pointer level with the top of the first line of text 
in the story.    If you want a raised first letter, position the mouse pointer above the top of the first line 
of text.

3 Hold down the mouse button and drag the mouse until you've created a dotted box the exact size 
and position of the fancy first letter you want.
It will be easier to judge the size the fancy first letter should be if you create the PageWizard frame 
inside the text frame that contains the story.    The text in the story will move to make room for the 
PageWizard frame.

4 From the list of PageWizards, choose Fancy First Letters.
5 Choose the OK button.
6 In the series of dialog boxes the PageWizard displays, answer the questions to indicate what you 

want your fancy first letter to look like.    After you answer each question, choose the Next button to 
go on.

7 Choose the Create It button to place the fancy first letter in your publication.
8 Choose the OK button.

 To create a fancy first letter yourself with WordArt
1 On the Toolbar, choose the WordArt Frame tool.
2 Position the mouse pointer where you want the upper-left corner of the letter to be.
3 Hold down the mouse button and drag the mouse until you've created a dotted box the exact size 

and position of the fancy first letter you want.
It will be easier to judge the size the fancy first letter should be if you create the WordArt frame 
inside the text frame that contains the story.    The text in the story will move to make room for the 
WordArt frame.
Publisher shows you the WordArt box.

4 In the Text box, type the first letter of the story.
5 Choose the Apply button to see your text in the Preview area.
6 In the Font list box, choose a font.
7 In the Size list box, choose Fit to Frame. 

Publisher finds a font size that fits the frame you've created.
8 Choose the OK button to add the letter to your publication.

Notes
The easiest way to create a fancy first letter is to first create a text frame and add the story, then 

add the fancy first letter.    (Don't forget to delete the first letter of the story!)    It's easier to choose the 
appropriate size and position for the fancy first letter when you can see how much space the story you're 
adding it to occupies in your publication.

You may need to experiment with the WordArt frame size.    You can resize a WordArt frame like a 
text or picture frame.    When you resize the frame, the fancy first letter shrinks or expands accordingly.    
The fancy first letter should be in proportion with the rest of the story and the rest of the publication.    A 
good rule of thumb is to begin with a WordArt frame that is three times taller than one line of text in the 
body of the story.    A long story can accommodate a larger fancy first letter.

Tip
Fancy first letters can be used to visually balance out a page.    For example, a fancy first letter in 

the upper-left corner of a page can be used to balance out a photograph in the lower-right corner of the 



page.

See also
Moving a Frame or Drawn Object
Creating Special Effects with PageWizards
Adding WordArt to Your Publication
Changing WordArt



 Creating Headlines 
You can easily create eye-catching headlines like the ones you see in newspapers and magazines.    You 
can have a Publisher PageWizard create the headline for you, or you can create one yourself using 
WordArt.

 To have Publisher create a headline for you
1 On the Toolbar, choose the PageWizard tool.
2 Position the mouse pointer where you want the upper-left corner of the headline to be.
3 Hold down the mouse button and drag the mouse until you've created a dotted box the exact size 

and position of the headline you want. 
4 In the PageWizard box, choose Newsletter Banner.
5 Choose the OK button.
6 In the series of dialog boxes the PageWizard displays, answer the questions to indicate what you 

want your headline to look like.    After you answer each question, choose the Next button to go on.
7 Choose the Create It button to place the headline in your publication.
8 Choose the OK button.

 To create a headline yourself with WordArt
1 On the Toolbar, choose the WordArt Frame tool.
2 Position the mouse pointer where you want the upper-left corner of the headline to be.
3 Hold down the mouse button and drag the mouse until you've created a dotted box the exact size 

and position of the headline you want..
4 In the Text box, type the headline.
5 In the Font box, choose a font.
6 Choose the Apply button to see your text in the Preview area.
7 In the Size box, choose Fit to Frame. 

Publisher finds a font size that fits the frame you've created.
8 Choose the OK button to add the headline to your publication.

Tips
For illustrated examples of special kinds of text such as headlines, sidebars, pull quotes, and 

captions, see the "Access to Publisher" section of your Microsoft Publisher User's Guide.
To connect a headline with the main text, use a bit less space below the headline than above it.    

For more information, see the Changing the Space Between Lines of Text (Leading) and Paragraphs topic 
referenced below.

You can choose from a variety of WordArt options to give a headline polish and finesse.    For 
example, you can add a shadow behind each letter of    your WordArt text or stretch the letters vertically to 
fill the frame.    For more information, see the Adding WordArt to Your Publication topic referenced below.

See also
Adding WordArt to Your Publication
Changing WordArt
Adding Borders and BorderArt to Frames
Adding Shadows Behind Frames or Drawn Objects
Adding Patterns and Color to Text Frames and Drawn Objects



 Creating Captions
A caption is text that describes a picture.    For example, if you are creating a brochure that contains a 
chart, you can place a caption briefly explaining the chart's significance next to the chart.    To make 
positioning and changing a caption easy, you'll first create a text frame, and then type the text for the 
caption.

 To create a caption
1 Create a text frame next to the picture you want to describe.

You can put the text frame anywhere on the page, even on top of existing text.    The existing text will 
move to make room for the new frame.

2 Type the text for the caption.

Tips
For illustrated examples of special kinds of text such as headlines, sidebars, pull quotes, and 

captions, see the "Access to Publisher" section of the Microsoft Publisher User's Guide.
If you want to move a picture and its caption, remember to select the picture and caption together. 

For more information, see the Moving a Frame or Drawn Object topic referenced below.
For contrast with the text in the main article, you can use a different point size or style for a 

caption.    For more information on choosing fonts, font sizes, and styles, see the topics referenced below.

See also
Moving a Frame or Drawn Object
Choosing the Font, Size, and Position of Text
Choosing Styles: Bold, Italic, Underlined
Adding Text
Layering Text, Pictures, and Drawn Objects
Adding a Picture to Your Publication: the Basics



 Creating Sidebars and Pull Quotes
You can dress up a publication using sidebars or pull quotes.    A sidebar is a short article that relates to a 
larger one.    It is usually positioned next to or within the main article.    For example, an article on a travel 
destination might have a sidebar containing information on transportation costs located in a column next 
to the article.

A pull quote is a quotation taken from the text of an article and set in a different point size or font style.    
Pull quotes can break up text, draw a reader's attention to the page, and provide a quick summary of a 
section of text.

To create a sidebar or pull quote
1 Create a text frame.

You can put the text frame anywhere on the page, even on top of existing text.    The existing text will 
move to make room for the new frame.

2 Type the text for the sidebar or pull quote.

Note
Sidebars and pull quotes shouldn't catch the reader's eye to the extent that they overshadow the 

main article.    When you design a sidebar or pull quote, keep in mind that it should play a supporting role. 

Tips
To call attention to a sidebar or pull quote, you can add a color, pattern, border, or shadow to the 

text frame.    For more information, see the topics referenced below.
To separate a pull quote from the main text, try using indents and line breaks to give the pull 

quote an interesting shape.    Or change the margins within the text frame that contains the pull quote.    
See the topics referenced below for more information or see the "Access to Publisher" section of the 
Microsoft Publisher User's Guide for illustrated examples.

See also
Adding Patterns and Color to Text Frames and Drawn Objects
Adding Borders and BorderArt to Frames
Adding Shadows Behind a Frame or Drawn Object
Choosing the Font, Size, and Position of Text
Choosing Styles: Bold, Italic, Underlined
Changing the Space Between Lines of Text (Leading) and Paragraphs
Adding WordArt to Your Publication
Adding Text



 Creating Headers and Footers
A header is any text, pictures, or drawn objects that appear at the top of each page of your publication.    
A footer is any text, pictures, or drawn objects that appear at the bottom of each page.

Publisher provides a background where you can place text, pictures, and drawn objects that you want to 
appear on every page.    For example, you might place a footer with your company address and logo in 
the lower-right corner of the background.    This footer will appear in the lower-right corner of each page 
of your publication.

 To add, change, or delete a header or footer
1 From the Page menu, choose Go to Background.

If you've never worked with the background of a publication before, see the Adding Text and 
Pictures That Will Repeat on Every Page topic referenced below.

2 Add the text, pictures, and drawn objects that you want to repeat on every page of your publication, 
or change or delete existing ones.

3 From the Page menu, choose Go to Foreground to return to your page.

Tip
To quickly move between the background and foreground of your publication, hold down CTRL 

and press M.

What if...
I put objects on my page that cover up a header or footer on the background?
If you want to see all of the header or footer, you will need to reposition the objects, move the 

header or footer to a new position on the background, or make the objects that are covering your header 
or footer transparent.    To make an object transparent, from the Layout menu, choose Shading.    In the 
Style box, choose the first box in the upper-left corner.    The preview box displays the word "clear."    
Choose the OK button. You cannot make text or pictures transparent.

See also
Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Go to Background Command (Page Menu)
Hiding the Background for a Single Page
Shading Command (Layout Menu)



 Creating Footnotes
A footnote is a note of reference, explanation, or comment usually placed at the bottom of the page or at 
the back of a chapter or publication.    To create a footnote at the bottom of a page, first add an 
identifying mark or number to the text the footnote relates to, then create a text frame and type the 
footnote.

To add a footnote mark or number
1 Position the insertion point in the text where you want the footnote mark or number.
2 From the Format menu, choose Character.
3 Under Super/Subscript, choose Superscript.
4 Choose the OK button.
5 Type the footnote mark or number.
6 To resume typing normally-positioned text, choose Character from the Format menu.    Then, choose 

Normal under Super/Subscript, and choose the OK button.
To add a footnote

1 At the bottom of the page or story, create a text frame that extends from the left margin to the right 
margin.

2 Type the footnote mark or number, and then type the footnote.

Note
To delete a footnote, you must delete both the footnote mark or number and the text frame that 

contains the footnote.

Tip
You can quickly add or remove a subscript or superscript format from text you've highlighted 

using the following keyboard shortcuts.    For example, to add subscript to highlighted text, press hold 
down CTRL and press EQUAL SIGN (=).

Press When you want to

CTRL+EQUAL SIGN (=) Add or remove a subscript format

CTRL+SHIFT+PLUS SIGN (+) Add or remove a superscript format

CTRL+SPACEBAR Remove styles and a subscript or superscript format

What if...
The story wraps around the footnote, so that text appears below or to the side of the footnote?
You've placed the text frame that contains your footnote on top of the story, so the story is moving 

to make room for the footnote.    To avoid having text wrap below or to the side of the footnote, make sure 
the text frame that contains the footnote covers the bottom of the text frame that contains the story. 

See also
Adding Text



 Adding and Changing Pictures
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Putting Pictures on the Page
Adding a Picture to Your Publication: the Basics
Adding Publisher's ClipArt 
Adding a Picture from Another Application
Copying a Picture From a Document in Another Application
Adding a Picture That You Create and Change in Publisher
Adding a Picture That You Want to Use and Update in Several Locations
Adding Space (Margins) Around a Picture
Creating Several Picture Frames with the Same Margins
Adding Drawn Objects: Boxes, Lines, and Ovals

Positioning Pictures on the Page
Copying a Picture or Drawn Object
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications
Deleting a Picture or Drawn Object
Aligning Objects on the Page with Snap To
Layering Text, Pictures, and Drawn Objects
Using the Rulers
Moving a Ruler or Its Zero Point (Origin)
Using the Scratch Area

Adding Pictures That Will Appear on Every Page
Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Hiding the Background for a Single Page
Creating Headers and Footers

Changing Pictures
Shrinking or Enlarging a Picture
Cropping a Picture
Restoring a Picture's Size or Proportions



 Adding a Picture to Your Publication: the Basics
You have several options to choose from when adding a picture.    Below is a short description of each 
option.    Topics that deal specifically with each of these options are referenced at the end of this topic.

ClipArt    The easiest way to get started adding pictures is to use ClipArt, Publisher's ready-made 
images.    These images cover a wide variety of themes and interests and are perfect for illustrating 
a point, decorating a card, or enhancing a newsletter.

Pictures Created in Other Applications    There are four ways to add a picture created in another 
application to your publication: 

Import a picture from another application while within Publisher.
Copy a picture in the application where it was created and paste it into your publication. 
Open an application from within Publisher and create a picture.
Import a picture that's linked to the file where the original is stored.    This type of picture is 

automatically updated every time the original is changed.
Every Publisher picture is contained in its own picture frame (this frame is invisible when you print your 
publication).    When you add a picture, you can draw a frame for it on your own or have Publisher draw 
one for you.    Draw a frame on your own if you want to control the picture's position and size.    Have 
Publisher draw it for you if you want the picture brought in at the size it was originally made.

 To make a picture frame
1 On the Toolbar, choose the Picture Frame tool.
2 Position the mouse pointer where you want the upper left corner of the picture to appear.
3 Holding down the mouse button, drag the mouse diagonally down to the right until the frame is the 

size and shape you want.
As you drag, use Publisher's rulers or your publication's layout guides as a point of reference for 
positioning the picture on the page.    Try to keep the proportions of the frame similar to those of the 
picture (if you know them) so the picture won't be distorted in Publisher.

4 Release the mouse button to complete the frame.

Notes
You can make a simple drawing with boxes, lines, and ovals using the drawing tools from 

Publisher's Toolbar.    Most likely, you'll use these shapes as decorative elements and turn to other 
graphics applications for pictures.    See the Adding Drawn Objects: Boxes, Lines, and Ovals topic 
referenced below for more information.

When you first put pictures on the page, you'll find it easiest to work with the page in Full Page 
view.    This view shows you the entire page as you position and size the picture.    When you're ready to 
position pictures more precisely, you may find one of Publisher's close-up views more helpful.    For more 
information, see the Choosing Your View of the Page: Actual Size, Magnified, or Reduced topic 
referenced below.

Tips
To make a square frame, hold down the SHIFT key as you make the frame.    Release the mouse 

button before you release the SHIFT key or the picture may not be square.
To make one picture frame right after another, click the Picture Frame tool with the right mouse 

button to lock it.    This allows you to create several frames in a row without reselecting the tool.    When 
you've finished making picture frames, choose the Selection tool to unlock it.

If you have any trouble adding a picture from another application, see First Aid for adding and 
changing a picture in Chapter 6, "Pictures", in the Microsoft Publisher User's Guide.    This section 
contains a list of solutions to common problems with importing and changing pictures.

See also
Adding Publisher's ClipArt
Adding a Picture from Another Application
Copying a Picture from a Document in Another Application
Adding a Picture That You Create and Change in Publisher
Adding a Picture That You Want to Use and Update in Several Locations



Adding Drawn Objects: Boxes, Lines, and Ovals
Choosing Your View of the Page: Actual Size, Magnified, or Reduced



 Adding Publisher's ClipArt
Publisher provides ready-made pictures, called ClipArt, that you can add to your publication.    To add 
ClipArt, you create a picture frame first, and then insert the ClipArt into the frame.    You can position 
ClipArt anywhere in your publication--including over text, pictures, and drawn objects.    If you place 
ClipArt over a text frame, the text in the frame moves to wrap around the ClipArt.

 To add ClipArt to your publication
1 On the Toolbar, choose the Picture Frame tool.
2 Create a picture frame where you want to place the picture.

You can also have Publisher automatically create a picture frame for you and insert the ClipArt 
you've chosen at the size it was created in the middle of the window.    Publisher places the ClipArt 
over any text or pictures already in the middle of the window.    To do this, skip steps 1 and 2 and 
begin with step 3.

3 From the File Menu, choose Import Picture.
4 In the Directories box, double-click the ClipArt directory.
5 In the Picture Name box, choose the ClipArt you want.
6 Choose the Preview button to confirm what the ClipArt looks like.
7 Choose the OK button.

Publisher inserts the ClipArt into the frame.
 To replace one piece of ClipArt with another

1 Select the picture frame that contains the ClipArt you want to replace.
2 Follow steps 3-7 above.

Tips
To change the size of your ClipArt while maintaining its proportions, hold down the SHIFT key and 

drag one of the four corner handles to resize the ClipArt frame.
If you have any trouble adding ClipArt, see First Aid for adding and changing a picture in Chapter 

6, "Pictures," in the Microsoft Publisher User's Guide.    This section contains a list of solutions to common 
problems with importing and changing pictures.

What if...
The ClipArt I've added appears distorted?
When you import ClipArt, it is automatically resized to fit the frame you created for it.    If the frame 

you've created is larger or smaller than the ClipArt you're importing, the ClipArt may be stretched or 
compressed to fit the frame.

You can change the ClipArt back to its original size (the size it was when it was created) with the 
Scale Picture command.    From the Format menu, choose Scale Picture.    Choose the Original Size 
check box, and then choose the OK button.    Publisher changes the frame to fit the art at its original size.

See also
Import Picture Command (File Menu)
Adding a Picture to Your Publication:    the Basics
Adding a Picture from Another Application
Shrinking or Enlarging a Picture
Cropping a Picture
Restoring a Picture's Size or Proportions
Scale Picture Command (Format Menu)



 Adding a Picture from Another Application
There are four ways to add a picture to your publication.    This is the simplest method of adding a picture 
that you're not likely to change after you've added it, such as ClipArt.    This procedure works for most of 
the pictures that you can add to a Publisher publication.    For information on other ways of adding a 
picture, see the topics on adding a picture referenced below.

To import a picture from another application
1 On the Toolbar, choose the Picture Frame tool.
2 Create a picture frame where you want to place the picture.

You can also have Publisher automatically create a picture frame for you and insert the picture 
you've chosen at the size it was created in the middle of the window.    Publisher places the picture 
over any text or pictures already in the middle of the window.    To do this, skip steps 1 and 2 and 
begin with step 3.

3 From the Publisher File menu, choose Import Picture.
4 In the Directories box, double-click the directory where the file containing the picture you want to 

insert is saved.
If the directory containing the file you want to add is not displayed, double-click the c:\ folder and 
then double-click the directory you want.

5 In the Picture Name box, choose or type the name of the file containing the picture you want to add.
If you can't find the picture you want to add, in the List Type of Files box, choose the type of file you 
want to add.    Once you've chosen a file type, Publisher displays all the files of that type stored in 
the current directory. Publisher can convert and open the following types of pictures:

Bitmapped (paint-type) pictures.
These pictures are created by programs such as Windows Paintbrush.    Scanners create another 

kind of bitmap known as a TIFF (Tag Image File Format).    BMP, PCX and TIF are file extensions for 
bitmaps.

Draw-type (object-oriented) pictures.
These are made by many Windows applications--for example a Corel Draw! or Windows Draw 

drawing or an Excel chart.    This category also includes Encapsulated PostScript (EPS) pictures, which 
are stored in a format best printed by a PostScript printer, and Computer Graphics Metafile (CGM), the 
format of Publisher's ClipArt.    CGM, DRW, EPS, and WMF are file extensions for draw-type pictures.

6 To see a preview of the picture before you add it, click the Preview button.
7 Choose the OK button when you're ready to add the picture.

Tips
To change the size of your picture while maintaining its proportions, hold down the SHIFT key and 

drag one of the four corner handles to resize the picture frame.
If you have any trouble adding a picture from another application, see First Aid for adding and 

changing a picture in Chapter 6, "Pictures", in the Microsoft Publisher User's Guide.    This section 
contains a list of solutions to common problems with importing and changing pictures.

What if...
My picture is distorted?
The picture frame you created for it was probably larger or smaller than the original picture.    You 

can correct this by restoring the picture to its original size (the size it was when it was created) or you can 
resize it manually.    See the Restoring a Picture's Size or Proportions topic referenced below.

See also
Adding a Picture to Your Publication: the Basics
Copying a Picture from a Document in Another Application
Adding a Picture That You Want to Use and Update in Several Locations
Using Publisher with Other Applications
Restoring a Picture's Size or Proportions
Shrinking or Enlarging a Picture
Adding Borders and BorderArt to Drawn Objects



Import Picture Command (File Menu)



 Adding Space (Margins) Around a Picture
You may want to emphasize a picture by adding space around it to visually set it off from the rest of a 
column or page.    You can increase the amount of space around a picture by setting margins within the 
picture's frame; Publisher automatically changes the size of the picture to fit within the margins.

 To add or change margins in a picture frame
1 Select the picture frame you want to change.
2 From the Layout menu, choose Frame Margins.
3 In the Left and Right and Top and Bottom boxes, type the amount of space you want on the left and 

right sides of the picture, and at the top and bottom of the picture.
4 Choose the OK button.

Note
When you change the size of a picture frame, the margins always remain the same size.    For 

example, if you set half-inch margins around a picture, they will remain half-inch margins, even if you 
decide to shrink or expand the picture frame.

Tip
For an interesting design effect, you can add a pattern or color to the margins in a selected 

picture frame.    From the Layout menu, choose Shading.    Under Style, choose the pattern you want, and 
under Color, choose a color for the pattern in the Foreground box and the color you want behind the 
pattern in the Background box. Choose the OK button to add the color and pattern you've chosen to the 
selected frame.

What if...
I want to add margins but keep my picture at its current size?
First, add the margins.    The picture will become smaller.    Then, position the mouse pointer on a 

corner frame handle until you see the Resizer.    Drag the handle to increase the size of the frame until the 
picture is the size you want.

See also
Shrinking or Enlarging a Picture
Adding Borders and BorderArt to Drawn Objects



 Creating Several Picture Frames with the Same Margins
If you need to make several picture frames that have the same size margins, you can set the margins for 
all the frames before you create them.

 To create several picture frames with the same margins
1 On the Toolbar, choose the Picture Frame tool.
2 From the Layout menu, choose Frame Margins.
3 Under Margins, type the measurements that you want for the left and right and top and bottom 

margins of each picture frame.
4 Choose the OK button.
5 Create the frames that you want.

All picture frames that you create will have the same margins that you've specified with the Frame 
Margins command until you choose new measurements.

Notes
To create picture frames with new settings,    you'll need to follow steps 1 through 4 above again 

before creating the new frames, or select each frame with the settings you want to change and change 
them individually.

When you start a publication, Publisher uses a margin setting of 0 (zero) for every picture frame 
you create.    To return to the standard setting at any time, choose the Picture Frame tool, then choose 
Frame Margins from the Layout menu and type 0 back into both text boxes.

Tips
You can choose other settings in addition to margins before creating a series of frames with the 

same properties.    For example, you might set the margins, border, and colors for pictures frames, and 
then create several in a row.

You can create text frames with the same properties in the same way you create picture frames 
with the same properties.    For more information, see the Creating Several Frames with the Same 
Margins and Columns topic referenced below.

See also
Creating Several Frames with the Same Margins and Columns



 Copying a Picture or Drawn Object
If you want to make several boxes, lines, ovals, or pictures that are exactly the same, you can simply 
copy the original drawn object or picture to the Clipboard.    Once a picture or drawn object has been 
copied to the Clipboard you can paste as many copies of it as you need into any publication you choose. 

 To copy a picture or drawn object
1 Select the picture or drawn object you want to copy.
2 From the Edit menu, choose Copy.
3 If you want to put the copy or copies on a different page of your publication, turn to that page.    If 

you want to put the copy or copies in another publication, from the File menu, open the publication 
you want to paste the copies into.

4 From the Edit menu, choose Paste once for each copy of the picture or drawn object you want.
A copy of the selected object will appear in the middle of the page. 

Tips
You can copy pictures or drawn objects as a group instead of one object at a time.    To copy a 

group of pictures and drawn objects, drag the selection box around all of the objects.    Then move the 
group to a new position, page, or publication.    For more information on selecting several objects at once, 
see the Selecting a Frame or Drawn Object topic referenced below.

To quickly copy of the picture or drawn object you've selected to the Clipboard, hold down CTRL 
and press C or INS.

To quickly paste the picture or drawn object you've copied into your publication, hold down CTRL 
and press V, or hold down SHIFT and press INS.

What if...
I choose Paste but don't get what I expect?
When you copy something to the Clipboard, it replaces what was there before.    You may have 

copied over the picture or drawn object you wanted to paste from the Clipboard.    Copy the correct picture 
or drawn object one more time, then try pasting it again.

See also
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications
Deleting a Picture or Drawn Object
Selecting a Frame or Drawn Object



 Moving a Picture or Drawn Object Within a Publication
You can move a box, line, oval, or picture anywhere in your publication by selecting the drawn object or 
picture, then dragging it to a new position.

 To move a picture or drawn object on a page
1 Select the picture or drawn object you want to move.

2 Position the mouse pointer over the selected object until the mouse pointer changes to the Mover.
3 Hold down the mouse button and drag the object to the new position. 

As you drag, a dotted line indicates the object's new position.    When you release the mouse button, 
the object will move to the new location.

4 Release the mouse button to complete the move. 
 To move a picture or drawn object between pages

1 Move the object onto the scratch area using the procedure above.
2 Turn to the page you want to move the object to.
3 Move the object onto the new page using the procedure above.

Tips
You can move pictures or drawn objects as a group instead of one object at a time.    To move a 

group of pictures and drawn objects, drag the selection box around all of the objects.    Then move the 
group to a new position, page, or publication.    For more information on selecting several objects at once, 
see the Selecting a Frame or Drawn Object topic referenced below.

You can use the scratch area to store a picture or drawn object if you aren't yet sure where you 
want it.

To drag a picture or drawn object in a straight line either vertically or horizontally, hold down SHIFT 

while you move the object.

See also
Moving a Picture or Drawn Object Between Publications
Selecting a Frame or Drawn Object
Resizing a Frame or Drawn Object
Deleting a Picture Frame or Drawn Object
Aligning Objects on the Page with Snap To



 Moving a Picture or Drawn Object Between Publications
You can move a picture or drawn object from one publication to another by using the Cut command to 
move the object to the Clipboard, opening the publication you want to move it to, and then using the 
Paste command to insert the object into the new publication.

 To move a picture or drawn object between publications
1 Select the picture or drawn object you want to move to another publication.
2 From the Edit menu, choose Cut.

The name of the Cut command changes to reflect the type of object you've selected, for example 
Cut Picture Frame.

3 From the File menu, choose Open Existing Publication and open the publication where you want to 
paste the object.

4 Turn to the page you want to move the object to.
5 From the Edit menu, choose Paste Object(s).

A copy of the object is pasted in the middle of the screen.    You can then move or resize the object 
anyway you want.

Tip
To quickly move a picture or drawn object you've selected, hold down CTRL and press X or hold 

down SHIFT and press DEL.    This places the picture or drawn object on the Clipboard.    Then, turn to the 
page you want to move the object to, hold down CTRL and press V or hold down SHIFT and press INS to 
quickly paste the picture or drawn object back into your publication.

What if...
I choose Paste but don't get what I expect?
When you copy something to the Clipboard, it replaces what was there before.    You may have 

copied over the picture or drawn object you wanted to paste from the Clipboard.    Copy the correct picture 
or drawn object one more time, then try pasting it again.

See also
Moving a Picture or Drawn Object Within a Publication
Selecting a Frame or Drawn Object
Resizing a Frame or Drawn Object
Deleting a Picture Frame or Drawn Object
Aligning Objects on the Page with Snap To



 Deleting a Picture or Drawn Object
To permanently remove a box, line, oval, or picture from your publication, delete it.

 To delete a picture or drawn object
1 Select the drawn object or the picture frame containing the picture you want to delete.
2 Press the DELETE key.

You can also remove a selected object or group of objects by choosing Delete from the Edit menu.    
The name of the type of object you're deleting follows the command name so you can confirm that 
you're deleting the correct object.
 To restore a deleted object

Immediately after deleting the object, from the Edit menu, choose Undo Delete Object.

Tip
To quickly restore a picture or drawn object you've just deleted, immediately hold down ALT and 

press BACKSPACE.

See also
Copying a Picture or Drawn Object
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications



 Shrinking or Enlarging a Picture
You can change the size of a picture in Publisher by changing the size of the picture frame that contains 
it.    If you don't like the way your picture looks after you've changed it, Publisher can return the picture 
back to the size it was when originally created.

 To quickly shrink or enlarge a picture
1 Select the frame that contains the picture you want to change.
2 Position the mouse pointer on a corner frame handle until you see the Resizer.
3 Drag the handle to increase or decrease the size of the frame. 

The picture shrinks or expands accordingly.
 To shrink or enlarge a picture while maintaining its proportions

1 Select the frame that contains the picture you want to change.
2 Position the mouse pointer on a corner frame handle until you see the Resizer.
3 Press the SHIFT key while dragging the handle to increase or decrease the size of the frame.    The 

picture shrinks or expands while maintaining its proportions.

Note
When you shrink or enlarge a picture, the new size will not appear until you finish dragging and 

release the mouse button.

Tip
If you want to change the size of a picture by a specific percentage, select the picture frame, and 

then choose Scale Picture from the Format menu.    In the Scale Height and Scale Width boxes, type the 
percentage of the original width or height you want the picture resized to. 

To shrink or enlarge a picture and keep its center in the same place, hold down CTRL while you 
resize the picture.

What if...
I want to restore a picture to the size it was when it was originally created?
From the Format menu, choose Scale Picture, and then choose the Original Size check box.    An 

X in the check box indicates the option is chosen.

See also
Scale Picture Command (Format Menu)
Cropping a Picture



 Cropping a Picture
You may need to conceal, or "crop," parts of a picture to make it fit on the page or to focus on a specific 
part of the picture.    For example, you can crop a picture of a map so that only one area or neighborhood 
is visible.

 To conceal parts of a picture
1 Select the frame that contains the picture you want to change.
2 On the Toolbar, choose the Cropping button.
3 Position the mouse pointer over one of the eight frame handles until you see it change to the 

Cropper.
4 Drag the frame handle to move the edge of the frame and conceal parts of the picture you don't 

want to see.
Drag the handle out again if you want to see the concealed parts of the picture.

5 On the Toolbar, choose the Cropping button again to turn it off.

What if...
I want to see the concealed parts of the picture again?
Select the picture frame.    Choose the Cropping button, and then drag the frame handles until the 

whole image is visible again.
I want to make the picture smaller or larger without concealing any of it?
Make sure the Cropping button is turned off.    Select the picture frame, press the SHIFT key, and 

then drag a corner frame handle until the picture is the size you want.

See also
Crop Picture Command (Format Menu)
Shrinking or Enlarging a Picture



 Restoring a Picture's Size or Proportions
You may not like a change you've made to a picture.    For example, you may have distorted it by 
changing its size, or trimmed more off of it than you'd planned.    If this happens, you can either return to 
the previous version of the picture or restore the picture to the size and proportions it had when it was 
created in the original application.

 To undo a change to a picture
 Immediately after completing the action that changed the picture, before you do anything 

else, from the Edit menu, choose Undo Resize Object.
 To restore a picture to its original size or proportions

1 Select the frame that contains the picture whose shape or size you want to restore.
2 From the Format menu, choose Scale Picture.
3 Choose the Original Size check box.

An X in the check box indicates the option is chosen.
4 Choose the OK button.

What if...
Undo Resize Object is not available on the Edit menu?
You may have made another change to your publication after you resized the picture but before 

you tried to restore the picture.    Once you make another change, the command is no longer available. 

See also
Adding Space (Margins) Around a Picture
Shrinking or Enlarging a Picture
Cropping a Picture
Scale Picture Command (Format Menu)



 Adding Drawn Objects, Borders, Shadows, and Other Special Design Effects
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Adding Special Text Effects
Adding WordArt to Your Publication
Changing WordArt
Resizing a WordArt Frame
Creating Special Effects with PageWizards

Adding Decorative Lines and Shapes
Adding Drawn Objects: Boxes, Lines, and Ovals
Adding Lines and Arrows
Adding Bullets

Positioning Drawn Objects on the Page
Resizing a Drawn Object
Copying a Drawn Object
Moving a Drawn Object Within a Publication
Moving a Drawn Object Between Publications
Deleting a Drawn Object

Adding Borders, Shadows, Patterns, and Colors
Adding Borders and BorderArt to Frames
Adding Borders and BorderArt to Drawn Objects
Adding Shadows Behind Frames or Drawn Objects
Adding Patterns and Color to Frames and Drawn Objects

Adding Final Touches
Layering Text, Pictures, and Drawn Objects



 Adding WordArt to Your Publication
WordArt offers a variety of fonts, point sizes, and unusual ways to position text that add polish and 
finesse to any kind of Publisher publication.    For example, you could create a publication title in 48-point 
type and position it vertically down the page, or stretch the letters to make them look wider or taller.    You 
can also add patterns, colors, and shadows to WordArt text.

Just as you create a frame to add text or a picture to your publication, you create a WordArt frame to add 
WordArt.    After you create and position the frame where you want it, Publisher displays the WordArt 
box, where you can type the text and specify how it will look.

 To add WordArt
1 From the Toolbar, choose the WordArt Frame tool.
2 Position the mouse pointer where you want the upper left corner of the frame to begin.
3 Hold down the left mouse button, and then drag the mouse diagonally until your frame is the size 

you want.
4 Release the mouse button.

Publisher displays the WordArt box. 
5 Type the text you want for your WordArt.
6 Choose the Apply button to see your text in the Preview box.
7 Choose from the WordArt options to specify the way your text will look. 

To get help on the various options available to you, choose the Help button in the WordArt box.
8 When you're ready to place the WordArt into your publication, choose the OK button.

Notes
In the WordArt box, if you choose a point size that can't fit into the frame you've drawn, Publisher 

will display a message asking if you want to automatically enlarge the frame.    Choose the OK button to 
have Publisher automatically enlarge the frame.    Choose the Cancel button to remain in the WordArt 
box.    Publisher will prompt you to choose another option such as a smaller point size or Best Fit from the 
Size list.

You can position, move, copy, and delete a WordArt frame just like a picture or text frame.    For 
information on positioning, moving, copying, and deleting frames, see the relevant topics referenced 
below.

You can resize a WordArt frame like a text or picture frame, but the text of your WordArt may be 
displayed differently in the frame depending upon the size option you chose when creating your WordArt. 
For more information, see the Resizing a WordArt Frame topic referenced below.

See also
Changing WordArt
Aligning Objects on the Page with Snap To
Moving a Frame or Drawn Object
Copying a Frame or Drawn Object
Deleting a Picture Frame or Drawn Object
Resizing a WordArt Frame



 Changing WordArt
After you've added WordArt to your publication, you can easily change it at any time.

 To change WordArt
1 In your publication, double-click the WordArt you want to change.

Publisher displays the WordArt box.    Your WordArt is displayed in the preview area as it looks in 
your publication.

2 To make changes to the WordArt text, in the Text box, highlight the text you want to change.
3 Type the new text.
4 To make other changes, choose the appropriate font, size, position (style), color (fill), alignment, and 

other options.
For more information on WordArt options, choose the Help button in the WordArt box.

Note
In the WordArt box, if you choose a point size that can't fit into the frame you've drawn, Publisher 

will display a message asking if you want to automatically enlarge the frame.    Choose the OK button to 
have Publisher automatically enlarge the frame.    Choose the Cancel button to remain in the WordArt 
box.    Publisher will prompt you to choose a smaller point size or Best Fit from the Size list.

Tip
You can see how the changes you've made will look in your publication before you close the 

WordArt box.    After you've made the changes you want, choose the Apply button.    Then, position the 
mouse pointer over the title bar of the WordArt box.    Hold down the mouse button and drag the box to 
the bottom of your screen so you can see the WordArt frame in your publication.    Release the mouse 
button.    The changes you've made will appear in your publication and the WordArt box stays on your 
screen, so you can make additional changes if you want.

See also
Adding WordArt to Your Publication
Resizing a WordArt Frame



 Resizing a WordArt Frame
In Publisher, you can resize a WordArt frame like a text or picture frame.    What happens to the text 
when you shrink or enlarge the frame depends upon the point size you've chosen for the text in the 
WordArt box.

If you've chosen Best Fit for the size of your WordArt, resizing your WordArt is just like resizing a picture; 
the WordArt shrinks or expands accordingly.    If you've chosen a specific point size for your WordArt, 
Publisher keeps the text at that size no matter what you do to the frame.

 To change the size of a WordArt frame
1 Position the mouse pointer on one of the frame handles until you see the Resizer.
2 While holding down the mouse button, drag one of the handles in or out until the frame is the size 

you want.
As you drag the handle, a dotted line indicates the frame's new size.    When you release the mouse 
button, the frame will change to the new size.

Note
If you've chosen a specific point size and then shrink the frame to a size that's smaller than that 

size, Publisher will crop the text.    If you've chosen a specific point size and then enlarge the size of the 
frame, Publisher will add white space (margins) around the text.

See also
Changing WordArt



 Creating Special Effects with PageWizards
Publisher's PageWizards can quickly create and add certain features to a publication for you.    For 
example, you can create a small illustrative calendar just by answering a few questions.    A PageWizard 
does the rest.

Choose To have Publisher help you create

Calendar A small calendar that's ideal for a newsletter or brochure.

Note-It Pop-up notes where you can leave helpful comments and reminders for 
yourself and others working on your publication.

Coupon A coupon that you can use in newsletters, advertisements, flyers, and 
brochures.

Table A table like those used in most business forms.    You can use tables to 
organize information in a report or to provide a quick reference for your 
readers in a newsletter.

Newsletter Banner An eye-catching headline like you see in magazines and newspapers.

Fancy First Letter An initial letter with a different font and larger point size than the text in the 
body of the story.    You can use fancy first letters to introduce a story or to 
dress up a page.

Ad An advertisement that you can use, for example, in a newsletter to announce 
upcoming events.

To create part of a publication using a PageWizard
1 On the Toolbar, choose the PageWizard tool.
2 Position the mouse pointer where you want the upper-left corner of the part you're adding to your 

publication.
3 Hold down the mouse button and drag the mouse until you've created a dotted box the size and 

position of the part you want to add. 
4 Release the mouse button.

Publisher displays the PageWizard dialog box.
5 From the list of PageWizards, choose what you want to create.
6 Choose the OK button.
7 In the series of dialog boxes the PageWizard displays, answer the questions to indicate what you 

want your results to look like.    After you answer each question, choose the Next button to go on.
8 Choose the Create It button.

When a PageWizard creates part of a publication, such as a coupon or a table, it creates several 
individual objects that make up the whole.    Although they're created together, these objects remain 
separate in your publication.    Therefore, if you want to move a part of your publication that a 
PageWizard has created, you'll need to select all of the objects in that part of the publication and 
move them as a group.    For more information on selecting several objects at once, see the 
Selecting a Frame or Drawn Object topic referenced below.

Tip
You can get an idea of the special publication features Publisher can create without adding them 

to your publication.    Choose the PageWizard tool, create a dotted box with the tool, and, from the list, 
choose the feature you're interested in.    Once you've finished answering the questions Publisher asks, 
choose Cancel if you don't want to add the feature to your publication.

What if...
I don't like the way the new objects look when the PageWizard is finished?
Once the PageWizard is finished, the objects it created are just like any others.    You can delete, 

move, and size them in any way you want.    If you want to start over from the beginning, just delete all the 
new objects and use the PageWizard again.



See also
Selecting a Frame or Drawn Object



 Adding Drawn Objects: Boxes, Lines, and Ovals
You can draw boxes, lines, and ovals with drawing tools from the Toolbar.    Use drawn objects to add 
finishing touches or unique designs to your publication.    For example, use lines to separate blocks of 
text or ovals to surround pull quotes or captions.

 To draw a box, rounded box, line, or oval
1 On the Toolbar, choose the Box, Rounded Box, Line, or Oval drawing tool.
2 Position the mouse pointer where you want to begin drawing the drawn object.
3 Drag the mouse until the drawn object is the size you want.

Note
You can change the thickness of a line or transform it into an arrow for special emphasis in your 

publication.    For more information, see the Adding Lines and Arrows topic referenced below.

Tips
You can draw a perfect circle or square by holding down the SHIFT key while you draw the object. 

You can draw a perfect vertical, horizontal, or 45-degree-angle line if you hold down the SHIFT key while 
you draw the line.    When you use the Line tool and SHIFT key together, you can create different shapes 
such as triangles and other polygons. 

To draw an object whose center is located at the point where you start drawing, hold down the 
CTRL key as you draw.

See also
Adding Lines and Arrows
Aligning Objects on the Page with Snap To
Layering Text, Pictures, and Drawn Objects



 Adding Lines and Arrows
Lines can help you organize information and can provide graphic accents.    For example, a thick bold 
line can be a visual clue that a new chapter is beginning.    Arrows call attention to important information. 
For example, if you draw a map of historic buildings in your area, arrows can help identify key locations 
for your readers.

To draw a line
1 On the Toolbar, choose the Line tool.
2 Position the mouse pointer where you want the line to begin.
3 Drag the mouse until the line is the size you want.

To draw an arrow
1 Draw a line.
2 On the Toolbar, choose one of the arrow buttons.

 To add thickness and color to a line or arrow
1 Draw a line or arrow.
2 From the Layout menu, choose Line.
3 Under Thickness, choose a thickness.

You can also type a measurement for the thickness you want in the 10 pt box.
4 Under Color, choose a color.
5 Choose the OK button.

Tips
To draw a perfect vertical, horizontal, or 45-degree-angle line, hold down the SHIFT key as you 

draw the line.
To draw a line whose center is located at the point where you started drawing, hold down the 

CTRL key as you draw.
Experiment with the Line tool to create different shapes, such as triangles and other polygons.
You may want to use lines thinner than one point, called hairlines, in your publication.    To create 

a hairline, type a number less than 1 in the 10 pt box under Thickness.    For example, type .50 to create a 
hairline one-half point wide.

What if...
The Line command is unavailable on the Layout menu?
First, select the line or arrow, then choose Line from the Layout menu.

See also
Adding Drawn Objects: Boxes, Lines, and Ovals



 Adding Bullets
You can make bullets using Publisher's drawing tools.    Bullets are useful for setting off each item in a 
list or calling attention to a particular point in an article or story.

 To create a bullet
1 On the Toolbar, choose the Box, Rounded Box, or Oval tool.
2 Position the mouse pointer where you want the bullet to appear.    Then draw the shape you've 

chosen for the bullet.
3 From the Layout menu, choose Shading.
4 Under Style, choose the pattern you want to fill the shape you've drawn.
5 Choose the OK button.

 To add bullets to a list
1 Create a text frame.

You can also position the insertion point in an existing text frame where you want the list to begin.
2 Type each item of your list.
3 Follow the procedure above to create and shade a bullet next to the first item in the list.
4 From the Edit menu, choose Copy.
5 From the Edit menu, choose Paste.

A copy of the bullet is pasted in the middle of the window.
6 Position the mouse pointer over the edge of the bullet until the mouse pointer changes to the Mover.
7 Hold down the mouse button and drag the bullet next to the second item in the list.

As you drag, a dotted line indicates the bullet's new position.    When you release the mouse button, 
the bullet will move to the new position.

8 Repeat steps 5-7 in this procedure for each item in the list.

Tips
You may find it essential to view the page close-up while positioning the bullets.    To view the 

page close-up, choose 200% Size from the Page menu.    When you have positioned the bullets, choose 
Full Page or Actual Size from the Page menu to return to a less-magnified view of the page.    For more 
information, see the Choosing Your View of the Page: Actual Size, Magnified, or Reduced topic 
referenced below. 

You can use the rulers to help you align the bullets.    Use the top edge of the horizontal ruler to 
align the bullet with the item in the list, and then use the vertical ruler to align all the bullets in a straight 
line.    You might want to turn on Snap to Rulers for easier positioning.    For more information, see the 
Using Rulers and Aligning Objects on the Page with Snap To topics referenced below.

If you want to move a bulleted list to a new position on the page, you need to select the text frame 
and the bullets together, then move them as a group.    For more information on how to move objects, see 
the Moving a Frame or Drawn Object topic referenced below.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced
Using the Rulers
Aligning Objects on the Page with Snap To
Changing the Margins Within a Text Frame
Moving a Frame or Drawn Object
Adding Drawn Objects: Boxes, Lines, and Ovals
Copying a Frame or Drawn Object
Creating Frames for Text and Pictures



 Resizing a Drawn Object
You can change the size of a box, line, or oval by shrinking or enlarging it.    You can stretch, squeeze, or 
adjust a drawn object's proportions any way you want.    Or you can change the size of the object while 
keeping its proportions the same.

 To change the size of a drawn object
1 Select the drawn object you want to change.
2 Position the mouse pointer over one of the object's eight handles until you see the Resizer.
3 Drag the Resizer until the object is the size you want.

As you drag the handle, a dotted line indicates the object's new size.    When you release the mouse 
button, the object will change to the new size.

Notes
When you want to change the size of a drawn object and keep its proportions the same, hold 

down SHIFT as you drag one of the four corner handles of the drawn object.
When you want to change the size of a drawn object and keep the center of the object in the 

same place, hold down CTRL as you change its size.
When you want to change the size of a drawn object, keep the same proportions, and keep the 

object's center in the same place, hold down SHIFT and press CTRL as you drag one of the four corner 
handles of the drawn object.

To quickly cancel a change you've just made to the size of a drawn object, immediately hold down 
ALT and press BACKSPACE.

See also
Shrinking or Enlarging a Picture



 Copying a Drawn Object
If you want to make several boxes, lines, or ovals that are exactly the same, you can simply copy the 
original drawn object to the Clipboard.    Once a drawn object has been copied to the Clipboard you can 
paste as many copies of it as you need into any publication you choose.

 To copy a drawn object
1 Select the object you want to copy.
2 From the Edit menu, choose Copy.
3 If you want to put the copy on a different page of your publication, turn to that page. If you want to 

put the copy in another publication, from the File menu, choose Open Existing Publication and open 
the publication you want to copy the drawn objects into.

4 From the Edit menu, choose Paste once for each copy of the object you want.
A copy of the selected drawn object will appear in the middle of the window.    You can then move or 
resize the drawn object any way you want.

Tips
You can copy several drawn objects as a group instead of one object at a time.    To copy a group 

of drawn objects, drag the selection box around all of the objects.    Then choose Copy from the Edit 
menu.    For more information on selecting several objects at once, see the Selecting a Frame or Drawn 
Object topic referenced below.

To quickly copy a drawn object you've selected to the Clipboard, hold down CTRL and press C or 
INS.

To quickly paste a drawn object you've copied to the Clipboard into your publication, hold down 
CTRL and press V, or hold down SHIFT and press INS.

What if...
I choose Paste but the wrong object is pasted?
The Clipboard can only hold one set of objects at a time.    When you copy something to the 

Clipboard, it replaces what was there before.    You may have copied over what you wanted to paste from 
the Clipboard.    Copy the object you wanted to paste and try again.

See also
Selecting a Frame or Drawn Object
Disconnecting and Reconnecting Text Frames
Moving a Frame or Drawn Object



Moving a Drawn Object Within a Publication
You can move a drawn object anywhere in your publication by selecting the drawn object and dragging it 
to a new position.

You can also move drawn objects to a different publication.    For more information on moving a drawn 
object to a different publication, see the Moving a Drawn Object Between Publications topic referenced 
below. 

 To move a drawn object by dragging
1 Select the drawn object you want to move.
2 Position the mouse pointer over the edge of the drawn object until the mouse pointer changes to the 

Mover.
3 Hold down the mouse button and drag the object to the new position. 

As you drag, a dotted line indicates the drawn object's new position.    When you release the mouse 
button, the drawn object will move to the new position.
 To move a drawn object between pages

1 Move the drawn object onto the scratch area using the procedure above.
2 Turn to the page you want to move the drawn object to.
3 Move the drawn object onto the new page using the procedure above.

Tips
You can move several drawn objects as a group instead of one object at a time.    To move a 

group of drawn objects, drag the selection box around all of the objects.    Then move the group to a new 
position, page, or publication.    For more information on selecting several drawn objects at once, see the 
Selecting a Frame or Drawn Object topic referenced below.

You can use the scratch area to store a drawn object if you aren't yet sure where you want it.
To drag a drawn object in a straight line either vertically or horizontally, hold down SHIFT while you 

move the drawn object.

See also
Moving a Drawn Object Between Publications
Selecting a Frame or Drawn Object
Resizing a Drawn Object
Deleting a Drawn Object



 Moving a Drawn Object Between Publications
You can move a drawn object from one publication to another by using the Cut command to move the 
drawn object to the Clipboard, opening the publication you want to move it to, and then using the Paste 
command to insert the drawn object into the new publication.

 To move a drawn object between publications
1 Select the drawn object you want to move.
2 From the Edit menu, choose Cut.
3 From the File menu, choose Open Existing Publication and open the publication you want to paste 

the drawn object into.
Publisher prompts you to save any changes you've made to the publication you're moving the drawn 
object from.

4 From the Edit menu, choose Paste Object(s).
A copy of the selected drawn object is pasted into the middle of the current window.    You can then 
move or resize the drawn object any way you want.

Tips
You can move drawn objects as a group instead of one object at a time.    To move a group of 

drawn objects, drag the selection box around all of the objects.    Then move the group to a new position, 
page, or publication.    For more information on selecting several drawn objects at once, see the Selecting 
a Frame or Drawn Object topic referenced below.

To quickly move a drawn object you've selected, hold down SHIFT and press DELETE or hold down 
CTRL and press X.    This places the drawn object on the Clipboard. Then, turn to a new page, hold down 
SHIFT and press INSERT or hold down CTRL and press V.    This quickly pastes the drawn object back into 
your publication.

See also
Selecting a Frame or Drawn Object
Moving a Drawn Object Within a Publication
Resizing a Drawn Object
Deleting a Drawn Object



 Deleting a Drawn Object
To remove a line, box, rounded box, or oval from your publication permanently, delete it.

 To delete a drawn object
1 Select the line, box, rounded box, or oval you want to delete.
2 Press the DELETE key.

 To restore a deleted drawn object
Immediately after deleting the drawn object, from the Edit menu, choose Undo Delete Object.

Tip
To quickly restore a drawn object you've just deleted, immediately hold down ALT and press 

BACKSPACE.

See also
Resizing a Drawn Object
Copying a Drawn Object
Moving a Drawn Object Within a Publication
Moving a Drawn Object Between Publications



 Adding Borders and BorderArt to Frames
Borders provide a decorative way to enclose text or pictures.    Add simple line borders using the Border 
command, or fancier designs such as triangles or palm trees using the BorderArt command.    With 
simple line borders, Publisher is preset to add equal borders to all sides of a frame, but you can choose 
a single side, or vary the thickness of the border from side to side if you prefer.

To put a simple line border around a frame
1 Select the frame you want to put a border around.
2 From the Layout menu, choose Border.
3 Under Border, the Select All Sides check box is automatically chosen to place the border on all sides 

of your frame.    If you only want a border on one side of the frame, click the side where you want a 
border to appear. 

4 Under Thickness, choose the line thickness you want, or type a thickness in the 10 pt box.
You can type any thickness from 0.25 points to 127 points, including thicknesses in 0.25 increments, 
such as 1.75 pt or 0.50 pt.

5 In the Color box, choose a color.
To see all the colors available, click the arrow to the right of the Color box. 

6 Choose the OK button.
7 If you want to put a border on another side of the frame, repeat steps 1-6.

To put BorderArt around a frame
1 Select the frame you want to put the BorderArt around.
2 From the Layout menu, choose BorderArt.
3 In the Available Borders box, choose a border from the list.

A picture of the border appears under Preview, and Publisher recommends a width (size) in the 
Border Size box.

4 In the Border Size box, type a measurement if you want to change the width of the border.
5 Press TAB to update the Preview picture if you've typed a new measurement in the Border Size box.

Choose the Use Recommended Size check box if you want to return the border to the size 
Publisher proposed.    An X in the check box indicates that Publisher will return the border to its 
recommended size.

6 Choose the OK button.

Tip
You may want to use simple line borders thinner than one point in your publication.    To create a 

very thin line border, type a number less than 1 in the 10 pt box under Thickness in the Border dialog box. 
For example, type .50 to create a border one-half point wide.

If you want to enclose several objects with a border, draw a box around those objects and then 
add a border or BorderArt to the box.    For more information on adding Borders and BorderArt to a box, 
see the Adding a Border or BorderArt to Drawn Objects topic referenced below.

What if...
I add a border and my picture shrinks, or some of my text is no longer visible?
Publisher centers the border over the selected frame but it does not change the size of the frame. 

Because Publisher always displays your picture or text within the border, the larger you make the border, 
the less room you may have for a picture or text within the frame.    You can reduce the size of your 
border, increase the size of your frame, or connect an additional text frame to display text that no longer 
fits if the border is around a text frame.

I can't choose Border or BorderArt from the menu?
You must select a frame before you can choose Border or BorderArt from the menu.    You can 

only add a border or BorderArt to one frame at a time.

See also
Adding Borders and BorderArt to Drawn Objects
Adding Shadows Behind Frames or Drawn Objects





 Adding Borders and BorderArt to Drawn Objects
You can emphasize a box, a rounded box, or an oval by adding a simple line border or color to its 
outline.    Or, to drawn attention to a square-cornered box you've created, add fancier designs such as 
triangles or palm trees using BorderArt.

To put a simple line border on a box, rounded box, or oval
1 Select the box, rounded box, or oval you want to put a border on.
2 From the Layout menu, choose Border.
3 Under Thickness, choose the line thickness you want, or type a thickness in the 10 pt box.

You can type any thickness from 0.25 points to 127 points, including thicknesses in 0.25 increments, 
such as 1.75 pt or 0.50 pt.

4 In the Color box, choose a color.
To see all the colors in the list, click the arrow to the right of the Color box.

5 Choose the OK button.
To put BorderArt on a square-cornered box

1 Select the square-cornered box you want to put the BorderArt on.
2 From the Layout menu, choose BorderArt.
3 In the Available Borders box, choose a border from the list.

A picture of the border appears under Preview, and Publisher recommends a width (size) for the 
border in the Border Size box.

4 In the Border Size box, type a measurement if you want to change the width of the border.
5 Press TAB to update the Preview picture if you've typed a new measurement in the Border Size box.

Choose the Use Recommended Size check box if you want to return the border to the size 
Publisher proposed.    An X in the check box indicates that Publisher will return the border to its 
recommended size.

6 Choose the OK button.

Tip
You can add thickness and color to a line using the Line command from the Layout menu.    For 

more information, see the Adding Lines and Arrows topic referenced below.
You may want to use borders thinner than one point in your publication.    To create a very thin line 

border, type a number less than 1 in the 10 pt box under Thickness.    For example, type .50 to create a 
border one-half point wide.

If you want to enclose several objects with a border, draw a box around those objects and then 
add a border or BorderArt to the box.

What if...
I can't choose Border or BorderArt from the menu?
If you're adding a simple border, you must select a box, rounded box, or oval before you can 

choose Border from the menu.    If you're adding BorderArt, you must select a square-cornered box before 
you can choose BorderArt from the menu.    You can only add a border or BorderArt to one object at a 
time.

See also
Adding Shadows Behind Frames or Drawn Objects
Adding Lines and Arrows



 Adding Shadows Behind Frames or Drawn Objects
You can add a shadow behind any object except a line or arrow.    You can add shadows to make blocks 
of text, pictures, and drawn objects appear to float on the page, giving your publication a sense of depth.

 To add a shadow
1 Select the frame or drawn object you want to add a shadow to.
2 On the Toolbar, choose the Shadow button.

Tips
Publisher's shadows always appear along the right and bottom edges of the frame or drawn 

object.    If you want to place a shadow in a different position, copy the object you want to add the shadow 
to.    Then, fill the copy with a color or pattern and layer and position the copy behind the object to create 
your own shadow.    For more information, see the Adding Patterns and Color to Frames and Drawn 
Objects topic referenced below.

To quickly add a shadow to the frame or drawn object you've selected, hold down CTRL and press 

D.

See also
Adding Patterns and Color to Frames and Drawn Objects
Copying a Frame or Drawn Object
Moving a Frame or Drawn Object
Layering Text, Pictures, and Drawn Objects
Adding Borders and BorderArt to Frames
Adding Borders and BorderArt to Drawn Objects



 Adding Patterns and Color to Frames and Drawn Objects
Patterns can add texture and depth to images, while color can highlight important information.      You can 
add both patterns and color to text and WordArt frames, picture frames that contain Publisher's ClipArt, 
and drawn objects.

To add a pattern or color to a frame or drawn object
1 Select the frame or drawn object you want to add the pattern to.
2 From the Layout menu, choose Shading.
3 Under Style, choose a pattern.

The Sample area to the right of your choices shows you the way your pattern will look.
4 Under Color, choose a color for the pattern in the Foreground box and the color you want to appear 

behind the pattern in the Background box.
5 Choose the OK button.

Note
In most cases, the only way to add a pattern or color to a picture (other than Publisher's ClipArt) 

is to add it to the picture's frame margin.    For more information, see the Adding Space (Margins) Around 
a Picture topic referenced below. 

What if...
I try to print colors with a black and white printer?
If you have a black and white printer, colors will be printed as black or white.    To make sure that 

everything is visible, you should convert colors you want to print to black before using a black and white 
printer.

See also
Adding Space (Margins) Around a Picture
Choosing Colors for Text
Adding Shadows Behind Frames or Drawn Objects



 Printing Your Publication
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

A Checklist Before You Print
Choosing a Page Orientation
Previewing Your Publication
Printing and Stopping Printing
Choosing the Number of Copies You Want to Print
Printing Specific Pages of Your Publication

Troubleshooting Printing Problems
A font or style you chose doesn't appear on the printed copy
The text in your publication prints, but doesn't look as you expected it to
The page numbers of a book aren't in consecutive order after you copy the pages and fold them
Some words in a greeting card don't print
Your publication takes a long time to print, or after awhile it stops printing altogether
The edges of the publication pages don't print on the paper 
The publication doesn't print at all



 A Checklist Before You Print
It's a good idea to make sure your printer is set up as you've planned to avoid unexpected problems.    
For example, if you've created your publication without having chosen a printer first, the look of your 
current publication may change once you do choose a printer.    Here's a checklist you can use as a 
reference.    Check each item in the list, and choose the topic to the right if you want to review the 
procedure.

Confirm the following:
1 The type of publication chosen Choosing the Publication You Want to Create
2 The printer you've chosen Choosing a Printer
3 The paper size and source    Print Setup Command (File Menu)
4 The paper orientation Print Setup Command (File Menu)



 Choosing a Page Orientation
The orientation you choose for your publication determines the way it's printed on the paper in your 
printer.    If you choose portrait orientation your publication will be taller than it is wide.    If you choose 
landscape orientation your publication will be wider than it is tall.

To choose portrait or landscape orientation
1 From the File menu, choose Print Setup.
2 Under Orientation, choose the page orientation you want.

If no page orientation option is offered, the printer you've chosen can only print in portrait orientation.
3 Choose the OK button.

Notes
In order to make choices your printer can print, it's important to choose a printer before you 

choose the orientation for your publication.    For more information on choosing a printer, see the 
Choosing a Printer topic referenced below.

You cannot mix portrait and landscape page orientations in a publication.

See also
Choosing a Printer
Print Setup Command (File Menu)
A Checklist Before You Print



 Previewing Your Publication
When you print your publication, layout guides, text frames, and picture frames don't print.    You can turn 
off Publisher's display of these elements so you can see how the pages of your publication will look 
when they print.    Then, you can display these elements again when you want to continue working.

 To see how a publication will look when it's printed
1 From the Options menu, choose Hide Object Boundaries.
2 From the Options menu, choose Hide Layout Guides.
3 From the Page menu, choose Actual Size to see your publication at the exact size it will print.

You can also choose Full Page from the Page menu to see a miniature view of the layout of the 
entire page.

4 Use the page controls to turn from one page to another to review your design.
 To show object boundaries and layout guides again

1 From the Options menu, choose Show Object Boundaries.
2 From the Options menu, choose Show Layout Guides.

Tips
To quickly switch between Actual Size view and the view you're currently using, press F9.
To quickly hide or show the layout guides you've chosen for your publication, hold down CTRL and 

press G.
To quickly hide or show object boundaries, hold down CTRL and press Y.

What if...
I hide the boundaries but some are still visible?
The boundaries you see are probably borders--perhaps very thin ones.    If you want to remove a 

border, select the picture or text frame.    From the Layout menu, choose Border.    Under Thickness, 
choose None, and then choose OK.



 Printing and Stopping Printing
Once you've confirmed that you've chosen the correct printer (and font cartridge if appropriate) and 
connected the printer, you're ready to go.

 To print your publication
1 From the File menu, choose Print.
2 Choose the OK button.

Publisher automatically prints all pages of your publication.    For information on the available 
choices in the Print dialog box, see the Print Command (File Menu) topic referenced below.
 To stop your publication from printing after it's already started

In the Printing status box, choose the Cancel button.
Some pages that have already been sent to the printer or print manager may still print after you 

choose the Cancel button.

Tip
To quickly print the current publication, hold down CTRL and press P.    Publisher prints your 

publication using the preset settings in the Print dialog box.

What if...
My printed publication doesn't look the way I expected it to, or it just doesn't print?
There are several stumbling blocks you may encounter while trying to print.    The topics 

referenced below cover some of the most common problems and provide recommendations for possible 
solutions.

See also
Print Command (File Menu)
A font or style you chose doesn't appear on the printed copyt
The text in your publication prints, but doesn't look as you expected it to
The page numbers of a book aren't in consecutive order after you copy the pages and fold them
Some words in a greeting or tent card don't print
Your publication takes a long time to print, or after awhile it stops printing altogether
The edges of the publication pages don't print
The publication doesn't print at all



 Choosing the Number of Copies You Want to Print
You can specify the number of copies of your publication that you want Publisher to print.    Some 
printers will also collate copies for you.    To find out if the printer you're using can collate copies, check 
the printer's reference manual.

 To choose the number of copies you want to print
1 From the File menu, choose Print.
2 In the Copies box, type the number of copies you want Publisher to print.
3 To have the copies you're printing collated, choose the Collate Copies check box.

An X in the check box indicates that the option is selected.

See also
Print Command (File Menu)
Printing Specific Pages of Your Publication



 Printing Specific Pages of Your Publication
Publisher prints all the pages of your publication unless you identify a specific range of pages to be 
printed. 

 To print specific pages of your publication
1 From the File menu, choose Print.
2 Under Print Range, choose Pages.
3 In the From box, type the first page number in the range of pages you want to print.
4 In the To box, type the last page number in the range of pages you want to print.

If you only want to print one page, type the same number that you typed in the From box.

See also
Print Command (File Menu)
Choosing the Number of Copies You Want to Print



 A font or style you chose doesn't appear on the printed copy

Explanation #1
The printer you used to print the publication may not be the same printer you specified when you 

created your publication, and Publisher replaced the fonts and styles you chose with those available on 
the new printer.    Or, after creating your publication, you may have chosen a printer which is not capable 
of printing the fonts or styles you specified. 

Recommendation: Change back to the original printer by choosing Print Setup from the File 
menu.    For more information, see the Choosing a Printer topic referenced below.    Or, check your printer 
manual to confirm which fonts and styles your printer can print.    Then, make the appropriate adjustments 
to your publication so it uses only the fonts and styles your printer can print.

Explanation #2
You may have chosen a printer or cartridge that cannot print the font or style, such as bold or 

italic, you chose.
Recommendation: The fonts and styles you can choose in your publication are determined by 

your printer or a cartridge you have.    Sometimes, a printer or cartridge can print the font you want, but 
not the style you want.    If your printer uses a cartridge, make sure the cartridge you specified in the 
Windows Control Panel is in the printer.    Then, check your printer manual and the cover of your font 
cartridge to confirm which fonts and styles your printer can print.    Make sure the fonts you've chosen for 
your publication are among those listed.

More about adding fonts
For more information, see "Adding fonts" in the "Improving your printer's performance" section of 

Chapter 8, "Printing," in your Microsoft Publisher User's Guide.

See also
Choosing a Printer



 The text in your publication prints, but doesn't look as you expected it to

Explanation #1:    The fonts or styles that print are different from the ones you chose when you 
created your publication

The printer you used to print the publication may not be the same printer you specified when you 
created your publication, and Publisher replaced the fonts and styles you chose with those available on 
the new printer.    Or, after creating your publication, you may have chosen a printer which is not capable 
of printing the fonts or styles you specified. 

Recommendation: Change back to the original printer by choosing Print Setup from the File 
menu.    For more information, see the Choosing a Printer topic referenced below.    Or, change your 
publication so it uses only the fonts and styles your printer can print.

Explanation #2:    Some text doesn't show up
The new printer doesn't have the fonts you've chosen and has substituted a larger font.    This 

made the text larger, and therefore too big for the frames you've created.    Publisher places the text it can 
no longer fit in the frames in the overflow area.

Recommendation: Create and connect new text frames to display the remaining text, or change 
the point size to decrease the size of the text.

Explanation #3: There is more white space in the frame
The new printer doesn't have the font you've chosen and has substituted a smaller font.    This 

made the text smaller, and therefore left some frames or parts of frames empty.
Recommendation: Resize the text frames, or change the point size to increase the size of the 

text.

General recommendations
If your printer uses a cartridge, make sure the cartridge you specified in the Windows Control 

Panel is in the printer.    You might also check your printer manual and the cover of your cartridge to 
confirm the fonts you can print.

You may be able to improve the look of text printed on your printer (particularly a dot-matrix 
printer) by using a type manager.    A type manager is an application that increases the number and 
flexibility of the fonts you use by generating an image of your font that is used for both your screen and 
your printer.    This guarantees that text, no matter what size or font you choose, will look on the screen as 
it will when it's printed.    Check with your local software dealer to learn more about which type manager 
will best suit your needs.    For more information about getting your publication to print the way you want, 
see "Improving your printer's performance" in Chapter 8, "Printing," of your Microsoft Publisher User's 
Guide.

See also
Choosing a Printer



 The page numbers of a book aren't in consecutive order after you copy the pages and fold 
them

Explanation
The number of pages you're printing is not divisible by four.    Publisher assumes you plan to print 

two pages to a sheet of paper--this is called a two-page spread.    Because a book format is based on a 
four-page count--two pages printed on each side of a piece of paper--printing a book only works if the 
number of pages in your publication is divisible by four.    This provides for pages to be copied back-to-
back to complete the publication.    If the number of pages is not divisible by four, you will end up with a 
single spread on one sheet of paper, with no other spread to be copied to the back of it.

Recommendation: Add blank pages to the end of your publication until the total number of 
pages is divisible by four.    For example, if the publication has thirteen pages, add three.

More about printing books
For more information, see "Printing books, pamphlets, and brochures" in the "Special 

considerations for printing " section of Chapter 8, "Printing," in your Microsoft Publisher User's Guide.

See also
Adding Pages to Your Publication



 Some words in a greeting or tent card don't print

Explanation
When Publisher prints a greeting or tent card, it prints some of the pages upside down 

(depending on the type of card) to prepare the card for folding.    Some printers have trouble printing text 
upside down and therefore Publisher is unable to print the text or picture on these pages in the greeting 
card.

Recommendation: Use WordArt to create all text for greeting cards and invitations to guarantee 
proper printing.    Publisher prints WordArt as a picture, so your printer will print the upside-down text as it 
would any other picture, regardless of your printer's text-printing capabilities.

Note
Some printers can't print text or pictures on upside down pages.    If your printer falls into this 

category, Publisher will tell you so and stop the print job.

More about printing greeting cards and tent cards
For more information, see "Printing greeting cards and tent cards" in the "Special printing 

considerations" section of Chapter 8, "Printing," in your Microsoft Publisher User's Guide.

See also
Adding WordArt to Your Publication



 Your publication takes a long time to print, or after a while, it stops printing altogether

Explanation #1
You have a large picture or a lot of different fonts in your publication that need to be prepared for 

printing before your publication can print.    This may take some time, but your publication will print 
eventually.

Recommendation: If you want a rough draft of the publication, you can choose the Draft Option 
in the Print box when you print.    This prints your publication as quickly and efficiently as possible. 
Depending on your printer, this may mean that your printer only prints the text of your publication, or 
prints the text and pictures but prints them in a lower resolution.    Choose the Draft option and 
experiment.

Explanation #2
If your computer is connected to a network printer (a printer which many people share and are 

connected to by a network cable), there's a network print manager that controls the order in which files 
are passed to the network printer for printing.    There's also a print manager in Windows that passes files 
to the network print manager.    When you print a file on a network printer, you can save time by bypassing 
the Windows print manager and sending the file directly to the network print manager.    If you're printing 
on a printer that is directly connected to your computer this procedure will not save you time.

Recommendation: Turn off the Windows Print Manager.
1 In the Main group in Windows, choose Control Panel.
2 Choose Printers.

3 In the bottom-left corner of the dialog box,    choose the Use Print Manager check box.    When 
there's no longer an X in the box, you've turned off Print Manager.

Note
If you switch to printing on a printer that is directly connected to your computer (not a network 

printer), follow steps 1 through 3 above to reactivate the Windows Print Manager.

Explanation #3
You may not have enough space on your hard disk.    The printing speed may depend on the 

amount of free space if you're using the Windows Print Manager.    Print Manager makes a copy of each 
publication specifically to send to the printer.

Recommendation: Free several megabytes of disk space in the same drive as Windows and try 
printing again.    Or, print one page of your publication at a time.    For more information on freeing space 
on your hard disk, see the A Hint for Freeing Some Space on Your Hard Disk topic referenced below.

General recommendation 
If you consistently have trouble printing your publications, you may want to consider adding 

memory to your printer.    This provides greater capabilities for printing graphics and fonts, as well as 
speeding up the printing time and freeing up the computer sooner for your use.    See your printer's 
manual for information regarding its current memory and your options for increasing it.

More about printing problems
For more information, see "The printer doesn't work as fast as usual or doesn't work at all" in the 

"First Aid for getting your publication to print" section of Chapter 8, "Printing," in your Microsoft Publisher 
User's Guide.

See also
Choosing a Printer
A Hint for Freeing Some Space on Your Hard Disk



 The edges of your publication's pages don't print

Explanation
You've placed some objects in your publication in your printer's nonprinting area.    Many printers 

don't print all the way to the edge of the paper.    Objects in the nonprinting area won't appear when you 
print your publication.
Recommendation: Test your printer to see what size the nonprinting area is.

1 On the Toolbar, choose the Box tool.
2 Draw a box the exact size of the publication page on your screen.
3 From the Layout menu, choose Shading, and then choose a pattern or color to fill the box.
4 Print the page.

The portion of the printed page that isn't shaded is your printer's nonprinting area.
Move the objects on the page so they're within the area of the page that will print.



 The publication doesn't print at all

Explanation
There could be several reasons why your printer does not print at all.    It could be as simple as 

having not turned the printer on or connected the printer to your computer properly.    Refer to your printer 
manual to confirm that you've connected to your printer properly.    For more information on printer 
problems and possible solutions, see "First Aid for getting your publication to print" in Chapter 8, 
"Printing," of your Microsoft Publisher User's Guide.





 Using Publisher with Other Applications
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Adding and Changing Text Created with Another Application
Adding a Piece of Text from Another Application
Adding an Entire File of Text from Another Application
Exporting Text Created in Publisher to Another Application

Adding and Changing Pictures Created with Another Application
Adding a Picture from Another Application
Copying a Picture from a Document in Another Application
Adding a Picture That You Create and Change in Publisher
Adding a Picture That You Want to Use and Update in Several Locations



 Adding a Piece of Text from Another Application
If you want to add a piece of text that was created in another Windows application, you can copy it to the 
Clipboard and then paste it into your publication. 

 To copy a piece of text and paste it into your publication
1 In the Windows application that you want to copy text from, highlight the text you want to copy.
2 From the application's Edit menu, choose Copy.
3 Switch to the Publisher publication you want to add the text to.
4 Create a text frame or select the text frame where you want to paste the text you've copied.

If the text frame already has text in it, position the insertion point within the text where you want the 
added text to begin.

5 From Publisher's Edit menu, choose Paste Text.
Publisher puts the text into the selected text frame.    If the text frame isn't large enough to hold all 
the text, Publisher displays a dialog box asking if you want to automatically flow the text into your 
publication.

6 Choose Yes if you want Publisher to automatically flow the text into the publication.
--Or--
Choose No if you want to keep the text in the frame's overflow area.
If you choose Yes, Publisher selects an empty frame, beginning with the empty frame farthest to the 
left, and asks if you want to flow the text into that frame.    Publisher automatically connects and 
flows the text into the empty text frames you specify.    If there is still more text than can be displayed 
after all the existing empty frames you've specified have been connected, Publisher automatically 
adds a page to your publication, creates a text frame the size of the page guides, and flows text into 
it.    Publisher adds as many pages as are necessary to hold all the added text.    For more 
information on flowing text through connected frames, see the Displaying Long Stories in Connected 
Text Frames topic referenced below.

See also
Displaying Long Stories in Connected Text Frames
Adding Text
Disconnecting and Reconnecting Text Frames
Adding an Entire File of Text from Another Application



 Adding an Entire File of Text from Another Application
You may want to add a story to your publication that you've created in a word processing program; or 
you may want to add a story someone else has created and given to you on a diskette.    Publisher can 
convert the file format of the word processor documents listed below, and in most cases preserve the 
character and paragraph formatting of the text.

Word processing files Publisher will convert

Word Perfect 5.0 and 5.1

Microsoft Word for Windows, 1.0 and 1.1

Microsoft Works for Windows word processing files (files with .WPS extension)

Microsoft Works 2.0 word processing files (files with .WPS extension)

Microsoft Word for DOS, 3.0-5.X
ASCII

WordStar 3.3, 3.4, and 4.0

Microsoft Windows Write

PC-8 (line breaks will be preserved but not the text formatting)

 To add a text file from another application
1 Create a text frame for the file you want to add.

Or, if the text frame already exists, select the frame.
2 From the File menu, choose Import Text.
3 In the List Type of Files box, select the type of file you want to add.    To    see all the file types 

available to you, click the arrow to the right of the box.
Once you've chosen a file type, Publisher displays all the files of that type stored in the current 
directory so you can check to see if the file you want is there.

4 If the file you want to add is not displayed, in the Directories box, double-click the c:\ drive to see a 
list of all the directories stored on your hard drive.
If the directory that contains the file you want to add isn't displayed in the Directories box, choose a 
different drive from the Drive box.

5 Double-click the directory that contains the file you want to add.
6 From the list below the Text Name box, choose the file you want to add by clicking on it, or type the 

name of the file in the Text Name box.
6 Choose the OK button.

Publisher puts the text into the selected text frame.    If the text frame isn't large enough to hold all of 
the text, Publisher displays a dialog box asking if you want Publisher to    automatically flow the text 
into your publication.

7 Choose Yes if you want Publisher to automatically flow the text.
--Or--
Choose No if you want to keep the text in the overflow area.
If you choose Yes, Publisher selects an empty frame, beginning with the empty frame farthest to the 
left, and asks if you want to flow the text into that frame. Publisher automatically connects and flows 
the text into the empty text frames you specify.    If there is still more text than can be displayed after 
all the existing empty frames you've specified have been connected,    Publisher automatically adds 
a page to your publication, creates a text frame the size of the page, and flows text into it.    
Publisher adds as many pages as are necessary to hold all the added text.    For more information 
on flowing text through connected frames, see the Displaying Long Stories in Connected Text 
Frames topic referenced below.

Note
When you add a file created in another application to your publication, you are adding a copy of 

the original.    The original remains untouched and saved in its original location.



What if...
The type of file I want to add doesn't appear in the List Type of Files box?

Publisher may not be able to import  that type of file or you may not have installed the filter for 
importing that type of file.    First, run Publisher Setup again and choose to install filters.    If the type 
of file you want to import still isn't listed, you'll need to save a copy of the file as plain text in the 
application where it was created and then import the plain text file into your publication.    A plain text 
file, also known as an ASCII file, is text without formatting.    For information on saving a file as plain 
text, see the documentation for the application in which you created the file.

The Import Text command is unavailable, or "grayed"?
The text frame may not be selected.    Try clicking inside the text frame and then choosing the 

Import Text command again.

See also
Displaying Long Stories in Connected Text Frames
Adding Text
Disconnecting and Reconnecting Text Frames
Adding a Piece of Text from Another Application
Import Text Command (File Menu)



 Exporting Text Created in Publisher to Another Application
To export pieces of text or stories created in Publisher to another application, just copy the text, switch to 
the other application, and paste the text into the application from the Clipboard.

When exporting entire stories created in Publisher to another application, you can preserve text 
formatting by saving the file with a new name and the file format used by the application you're exporting 
it to.    The original text in your Publisher publication won't be removed or changed.

 To export text created in Publisher to another application
1 Highlight the text you want to use in another publication or application.
2 From the Edit menu, choose Copy.
3 Switch to the application you want to export the text to.
4 Position the insertion point where you want the text to appear.
5 From the application's Edit menu, choose Paste.

 To save a Publisher story so you can use it in another application or publication
1 Click inside the text frame that contains the story and, from the Edit menu, choose Highlight Story.
2 From the File menu, choose Save As.
3 Choose the Save Selection As check box.

An X in the check box indicates that it is chosen.
4 In the Save Selection As list box, choose a file format used by the application where you want to put 

the text.
For example, if the application into which you will put the text can import  RTF files, choose RTF.    To 
see all the file formats available to choose from, click the arrow to the right of the Save Selection As list box.

5 In the Publication Name box, type a name for the file that will contain the text you've highlighted.    Use the extension 
proposed by Publisher.

6 In the Directories box, choose the directory where you want to store the file if it is different from the current directory.

7 In the Drives box, choose the drive where you want to store the file it if is different from the current drive.

8 Choose the OK button.
Publisher creates a file containing the text you've highlighted.    This file can now be used in another 
publication or application.    See the application's documentation for more information on its insert or 
import command.

What if...
The Save Selection As check box is unavailable?
You may not have highlighted any text before choosing the Save As command.    Highlight the text 

and try the rest of the procedure again.

See also
Copying Text
Save As Command (File Menu)



 Copying a Picture from a Document in Another Application
There are four ways to add a picture to your publication.    Use this method when the picture you want to 
add is only part of a file saved in another application, or when you don't plan on saving the picture in the 
application you created it in.    In this method, you copy the picture in the application where you created it 
and paste it into your publication.    For information on other ways of adding a picture, see the topics on 
adding a picture referenced below.

To copy or move a picture created in another Windows application to your publication
1 In the application you've used to create the picture, select the picture you want to add to your 

publication.
2 From the application's Edit menu, choose Copy or Cut.

Choose Copy if you want to add a copy of the picture to your publication and leave the original in the 
application.    Choose Cut if you want to add a copy of the picture and delete the original from the 
application.

3 Switch to Publisher and open the publication you want to add the picture to.
4 From Publisher's Edit menu, choose Paste.

Publisher automatically creates a frame in the middle of the window and inserts the picture in the 
frame for you at the same size it was created in the original application.    You can now position and 
resize the picture as much as you want.

See also
Adding a Picture to Your Publication:    The Basics
Adding a Picture That You Create and Change in Publisher
Adding a Picture You Want to Use and Update in Several Locations
Adding a Picture from Another Application
Shrinking or Enlarging a Picture
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications



 Adding a Picture That You Create and Change in Publisher
There are four ways to add a picture to your publication.    Use this method to create a picture with a 
Windows graphics application at the same time you are creating a publication.    While working on the 
publication, you can start the graphics application, create or change pictures that you've created, and 
insert the pictures into your publication automatically.    This is useful for adding a picture if you know 
you're likely to make a lot of changes to it before you're done with your publication.

The first procedure below tells you how to find out if an application can be started from within Publisher. 
For information on the three other ways of adding a picture, see the topics on adding a picture 
referenced below.

 To find out if an application can be started from within Publisher
1 From the Edit menu, choose Insert Object.
2 In the Type of Object box, Publisher lists all the applications that you can start from within Publisher.

To add a picture you plan to change often
1 Create a picture frame or select one you've already created.
2 From the Edit Menu, choose Insert Object.
3 In the Type of Object box, choose the type of picture you want to add.    Publisher only lists the 

applications that support this procedure.
4 Choose the OK button.

You are now in the application that you chose in the Type of Object box.    You are also still in 
Publisher.

5 Create a picture or, from the File menu of the graphic's application, open the picture file if it's already 
been created.

6 From the File menu of the graphics application, choose the command which will close the 
application.    Usually, the command name will be Exit.
The picture will be placed within the selected picture frame in your Publisher publication.
To edit a picture from within Publisher

1 Double-click the picture you want to edit. 
You are now in the application where the picture was created.    You are also still in Publisher.

2 Make the changes you want to the picture.
3 From the File menu of the graphics application, choose the command which will close the 

application.    Usually, the command name will be Exit.
Your changes appear in the picture in your application.

What if...
The application I want to use to create my picture is not on this list?
It may not be an application that supports this procedure.    You can still import or copy and paste 

a picture from that application into your publication.    For more information, see the Adding a Picture From 
Another Application topic referenced below.

See also
Adding a Picture to Your Publication:    The Basics
Adding a Picture from    Another Application
Copying a Picture from a Document in Another Application
Adding a Picture You Want to Use and Update in Several Locations
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications
Adding Borders and BorderArt to Frames
Adding Borders and BorderArt to Drawn Objects



 Adding a Picture That You Want to Use and Update in Several Locations
There are four ways to add a picture to your publication.    Use this method to link a picture or chart 
you've imported to the file where the original is stored.    When changes are made to the original, 
Publisher automatically updates the picture or chart in your publication.    This is particularly useful when 
you've included the same picture or chart in several publications or documents; Publisher can update 
each publication automatically.    For information on other ways of adding a picture, see the topics on 
adding a picture referenced below.

To add a picture or chart that's updated in your publication
1 From the Edit menu, choose Insert Object.
2 In the Type of Object box, double-click the type of object you want to add.

Publisher opens the application needed to create the object you've chosen.
3 In the application, create a new object or open a file containing an object you've already created..
4 From the application's Edit menu, choose Copy.
5 Switch to Publisher without closing the application where the object was created.
6 From Publisher's Edit menu, choose Paste Special.
7 Under Source, choose a file format for the object you're pasting.

Choose To

Native Paste the object into your publication with its original file format ( the format it had 
when you copied it).

MetaFilePict Paste the object into your publication as a metafile.    Select this option when you 
want to treat the object like a picture, for example if you want to crop it. 

Bitmap Paste the object into your publication as a bitmap.    Select this option when you want 
to treat the object like a picture and are unable to use the MetaFilePict option.

8 Choose the Paste Link button.
Publisher pastes the object into a picture frame you've selected, or it creates a picture frame, 
positions it in the middle of the window, and adds the picture.    You can move the picture anywhere 
in your publication. 
The picture or chart you've added is now linked to its original file.    Each time you open your 
publication, Publisher checks the original file for changes and updates the picture in your 
publication.

What if...
The link between an object I've pasted into my publication and the file where the original is stored 

is broken?
If the file containing the original object is moved to a new location, the link between the copy in 

your publication and the original is broken.    Publisher warns you when a link has been broken.    To re-
establish a link, you can either move the file containing the original object back to where it was when you 
copied it or you can copy the object again using the procedure above.

The Paste Special command is unavailable?
The application you're using may not be one that supports this procedure.    If this is the case, you 

can still import or copy and paste a picture from that application into your publication but you won't be 
able to link it to its original file.    For more information, see the Adding a Picture From Another Application 
topic referenced below.

See also
Adding a Picture from Another Application
Adding a Picture to Your Publication:    The Basics
Copying a Picture from a Document in Another Application
Adding a Picture That You Create and Change in Publisher
Moving a Picture or Drawn Object Within a Publication
Moving a Picture or Drawn Object Between Publications





MENU COMMANDS
Click the name of a menu for a description of the menu and its commands.

The File Menu
The Edit Menu
The Page Menu
The Layout Menu
The Format Menu
The Options Menu
The Help Menu



 Unavailable Commands
Sometimes, you can't choose a command, because the command appears grayed or dimmed on the 
menu.    This means the command is "unavailable."    For example, the Paste command is unavailable 
until you've cut or copied an object or text onto the Clipboard.    If a command is unavailable, you 
probably need to do one of the following before you can use the command:

Create a text, picture, or WordArt frame or a drawn object.
You can't use some commands unless you've created one of Publisher's objects.    For 

information on creating frames and drawn objects, see the Creating Frames for Text and Pictures and 
Adding Drawn Objects: Boxes, Lines, and Ovals topics referenced below.

Select the text, picture, or WordArt frame, or drawn object that you want to use the command on.
Publisher needs to know which object you want to crop, cut, delete, and the like.    For information 

on selecting objects, see the Selecting a Frame or Drawn Object topic referenced below.
Highlight the text you want to use the command on.
Publisher needs to know which part of a story you want to underline, copy, delete, and the like.    

For information on highlighting text, see the Choosing Text You Want to Change topic referenced below.

If you've followed the instructions above and the command you want to use is still unavailable, see the 
Menu Commands index referenced below to get specific information on that command.

Note
You can reverse or cancel many different commands and procedures in Publisher by choosing 

the Undo command immediately after you've carried out the command or procedure.    However, the Undo 
command cannot reverse all actions you might complete in your publication.    For example, adding new 
pages or importing a picture cannot be undone.    When an action you've completed cannot be reversed, 
the Undo command is unavailable on the Edit menu and cannot be chosen.

To check the spelling of a story, you must place the insertion point anywhere in the story.

See also
Creating Frames for Text and Pictures
Adding Drawn Object: Boxes, Lines, and Ovals
Selecting a Frame or Drawn Object
Choosing the Text You Want to Change
Menu Commands
Paste Command (Edit Menu)
Undo Command (Edit Menu)
The Undo Command
Checking Text for Spelling Errors



 Starting Publisher
Each time you open Publisher, Publisher displays four options that you can choose from to start a new 
publication or open an existing publication.    You can choose one of Publisher's PageWizards or 
templates, start from scratch, or work on a publication you've already created.

To start working on a publication
1 Choose from the following options:

PageWizards:    A PageWizard asks several questions, and then uses your answers to create a 
publication or complete a specific task.    When you choose this button, Publisher displays a list of 
PageWizards for you to choose from.    For more information on PageWizards, see the Starting with 
a PageWizard topic referenced below.
Templates:  A template is a    ready-made design that already contains the basic layout and format 
for a specific type of publication.    When you choose this button, Publisher displays a list of 
templates for you to choose from.    For more information on templates, see the topics referenced 
below.
Blank Page:    This option starts you off with a single page publication with one-inch guides.    The 
rest is up to you. 
Open: This option opens a publication you've already created.

2 If you've chosen to use a PageWizard or a template, in the list box underneath the options buttons, 
choose which PageWizard or template you want to use.
If you've chosen to open an existing publication, in the Publication Name box, type the filename you 
want or choose it from the list.    For more information, see the Opening an Existing Publication topic 
referenced below.

3 Choose the OK button.

Tip
If you want to get an idea of how to create a publication yourself, start with the Tutorial in your 

Microsoft Publisher User's Guide first, and then try creating your own publication later.

What if...
I choose Templates or PageWizards and Publisher cannot find them?
Templates and PageWizards are copied to your hard disk during Setup, and placed in directories 

called Template and PageWiz.    You may have deleted the files, or moved them to a directory that 
Publisher does not know about.    To be sure that all the Templates and PageWizards will be available, run 
Setup again.

See also
Starting with a PageWizard
Starting with a Template
Making Your Own Template
Changing a Template
Starting a Publication from Scratch (Blank)
Opening an Existing Publication
Saving and Naming Your Publication
Closing Your Publication
Create New Publication Command (File Menu)



THE FILE MENU
The File menu contains the commands you'll use to 1) create, save, and print a publication, and 2) add 
text and pictures from another Publisher publication or application.    Click the name of the command you 
want to see for more information.

Create New Publication
Starts a new publication.    You can get help with creating your publication by using a Publisher 
PageWizard or a template, or create a publication from scratch.

Open Existing Publication
Opens an existing Publisher publication, a word processing document, or the contents of a template.

Close Publication
Closes a publication that you are working on without leaving Publisher.    Before you close a publication, 
Publisher always asks if you want to save changes you've made to it.

Save
Keeps changes you've made to an existing publication.    Publisher saves the file in the current directory 
and copies it over any file with the same name in that directory.

Save As
Saves a new publication, saves a copy of an existing publication under a new name, or creates a 
template you can use to start additional publications.    You can also use the Save As command to 
change the location or the file format of a publication, or to save a selection of text to be used in another 
publication or Windows application.

Import Text
Imports text from another publication in Publisher or text created in another application.

Import Picture
Imports a picture created in another application or a picture from Publisher's ClipArt file.

Print
Prints any part or all of your publication using the printer specified in Publisher or in the Printers section 
of the Windows Control Panel.

Print Setup
Displays a list of printers you can use to print a publication, and contains other printing options such as 
size and orientation of paper.

Exit Publisher
Closes Publisher and whatever publication you may be working on.    If you have not saved changes 
you've made to the publication, Publisher asks if you want to save those changes.



THE EDIT MENU
The Edit menu contains the commands you'll use to make changes to your publication.    Click the name 
of the command you want to see for more information.

Undo
Reverses the last command or procedure you completed.

Cut
Removes the highlighted text or selected object from the publication and puts it on the Clipboard. 

Copy
Copies the highlighted text or selected object to the Clipboard.

Paste
Inserts a copy of the Clipboard contents into your publication.

Paste Special
Inserts a copy of a picture from another Windows application, such as a chart created in Excel, a picture 
created in Windows Paintbrush, or data from a spreadsheet, into your publication.    The copy is 
automatically updated when changes are made to the original file.

Delete
Removes the highlighted text or selected object from the publication.

Delete Picture Frame
Removes the selected picture frame.

Delete Text Frame
Removes the selected text frame.

Highlight Story
Highlights all the text in a story from the first frame to the last frame.

Edit {Object Name}
Lets you make changes to a picture from another Windows application, such as an Excel spreadsheet, a 
Paintbrush picture, or WordArt, and added to a publication using the Insert Object command.

Insert Object
Lets you add or change a picture created in other applications, such as a chart created in Excel, a 
picture created in Windows Paintbrush, or data from a spreadsheet, from within your Publisher 
publication.

Find
Searches for specified text in a story.

Replace
Searches for and replaces specified text in a story.



THE PAGE MENU
The Page menu contains the commands you'll use to 1) change your view of the page, 2) set the 
number of pages printed on one piece of paper and the page size of a publication, 3) add and delete 
pages, and 4) work on the background of a publication.    Click the name of the command you want to 
see for more information.

Full Page
Displays a miniature view of the entire page.

25% Size
Displays the entire page at one-quarter of its actual size.

33% Size
Displays the entire page at one-third of its actual size.

50% Size
Displays a portion of the page at half of its actual size.

66% Size
Displays a portion of the page at two-thirds of its actual size.

75% Size
Displays a portion of the page at three-quarters of its actual size.

Actual Size
Displays the selected part of the current page as it will appear when printed.

200% Size
Displays a portion of the page at twice its actual size.

Insert Pages
Adds a specified number of pages before or after the current page.

Delete Page
Removes the current page and its contents except for text in a connected text frame.

Insert Page Numbers
Prints a page number on each page of the publication.

Ignore Background
Hides all objects on the background of the current page.

Go to Background
Displays the background, where you can place objects that you want to repeat on each page of a 
publication.

Page Setup
Displays options for setting the publication page size and the number of pages of a publication that you 
want printed on one piece of paper.



THE LAYOUT MENU
The Layout menu contains the commands you'll use to lay out your publication, arrange objects on a 
page, and add finishing touches.    Click the name of the command you want to see for more information.

Layout Guides
Provides options for setting guides that you can use to plan a publication and precisely align objects on a 
page.

Frame Columns and Margins
Provides options for setting margins and columns for text in the selected text frame.

Frame Margins
Provides options for setting margins in the selected picture frame.

Bring to Front
Moves the selected object in front of all other objects on the page.

Send to Back
Moves the selected object in back of all other objects on the page.

Line
Provides options for adding thickness, color, and arrowheads to the selected line.

Border
Provides options for adding a simple line border to the selected object or frame.    Options will differ 
according to the type of object or frame selected.

BorderArt
Provides options for adding a border with a fancy design, such as triangles or palm trees, to the selected 
object or frame.

Shading
Displays twenty-four possible patterns for filling the selected object.    Foreground and background colors 
can be specified for any pattern.

Shadow
Applies a shadow to the right and bottom edges of the selected object.



THE FORMAT MENU
The Format menu contains the commands you'll use to change 1) the appearance and spacing of 
highlighted text, 2) the size of a picture, and 3) how much of a picture you want to appear on the page.    
Click the name of the command you want to see for more information.

Character
Provides options for specifying the font, style, size, and color of the highlighted characters.

Spacing Between Characters
Provides options for specifying the distance between the highlighted characters.

Indents and Spacing
Provides options for specifying paragraph indents and alignment, and spacing between highlighted lines 
and paragraphs.

Tabs
Provides options for setting, clearing, and aligning tabs for the highlighted text.

Scale Picture
Enlarges or shrinks the selected picture.

Crop Picture
Conceals part of the selected picture.



THE OPTIONS MENU
The Options menu contains the commands you'll use to 1) hide object edges, guides, rulers, and 
pictures, 2) turn the Snap To commands on and off, 3) set the starting page number, the unit of 
measurement, and the Typing Replaces Selection option, for a specific publication, and 4) proofread 
text.    Click the name of the command you want to see for more information.

Check Spelling
Checks a story for errors such as misspellings and incorrect capitalizations, and then assists in making 
corrections.

Hyphenate
Provides options for automatically hyphenating text.

Snap to Ruler Marks
Aligns objects precisely with the marks on the rulers.

Snap to Guides
Aligns objects precisely with the layout guides.

Hide Pictures
Hides all pictures in a publication.    Each picture is replaced by a rectangle the size of the picture frame 
that contains the picture.

Hide Rulers
Hides the rulers that are located at the top and left sides of the workspace.

Hide Status Line
Hides the bar extending across the bottom of the window which displays informative messages such as 
what a command you've chosen will do.

Hide Layout Guides
Hides the guides you use to position objects in a publication.

Hide Object Boundaries
Hides object edges.

Settings
Provides options for setting the starting page number, the units of measurement to be used, the shapes 
that the mouse pointer changes into, and the Typing Replaces Selection option.



THE HELP MENU
The Help menu contains the commands you'll use to get help with creating a publication and to get 
information about this version of Publisher.    Click the name of the command you want to see for more 
information.

Index
Displays a list of the information contained in Help.

Keyboard Shortcuts
Displays lists of each shortcut key combination and its resulting action.

How to Use Help
Provides instructions for using Help.

Introduction to Publisher
Displays a short demonstration illustrating basic Publisher concepts you need to know before starting a 
publication.

About Microsoft Publisher
Displays the product version number, copyright notice, and amount of available memory and disk space.



 Create New Publication Command (File Menu)
The Create New Publication command starts a new publication.    You can get help creating your 
publication by using a Publisher PageWizard or template, or create a publication from scratch.

Create New Publication dialog box options

PageWizards
1 Choose the PageWizards button to have Publisher build a publication for you.    The PageWizard will 

ask you a series of questions then use your answers to create a custom publication.
2 From the list of publications in the box below the PageWizards button, choose the one you want.

Templates
1 Choose the Templates button to open one of Publisher's ready-made publications.    You can fill in 

the blanks of the pre-existing layout with your own headlines, stories, and pictures. 
2 From the list of templates in the box below the Templates button, choose the one you want.

Blank Page
Choose the Blank Page button to create a publication that you make from scratch.    Publisher 

starts you off with a single page publication with one-inch guides.    The rest is up to you.

OK
Choose the OK button to create the type of publication you've chosen.

Cancel
Choose the Cancel button to return to the current page without beginning a new publication.

What if...
I choose Templates or PageWizards and Publisher can't find them?
Templates and PageWizards are copied to your hard disk during Setup, and placed in directories 

called Template and PageWiz.    You may have deleted the files, or moved them to a directory that 
Publisher does not know about.    To be sure that all the templates and PageWizards will be available, run 
Setup again.

See also
Starting a Publication
Starting with a PageWizard
Starting with a Template
Starting a Publication from Scratch (Blank)



 Open Existing Publication Command (File Menu)
The Open Existing Publication command lets you 1) open and work on a publication that you've already 
created in Publisher, 2) create a new publication from a file created in a word processing application, and 
3) look at or change the contents of a template.    For information on how to change a template, see the 
Changing a Template topic referenced below.

Open dialog box options

Publication Name
Type the name of the Publisher publication you want to see or work on, or choose a name from the 
Publication Name list box.
If the publication you want to open isn't listed in the list box, or if Publisher can't open the publication 
whose name you type, you may need to specify a different drive or directory in the Drives or 
Directories box, or specify a new file type in the List Type of Files box.

Drives
Choose another drive if the file you want to use is stored on another drive in your computer.
For example, choose drive A if the publication or file is stored on a floppy disk.

Directories
Double-click the directory where the file you want to work on is stored.
Publisher automatically displays the Publisher directory unless you choose another.

List Type of Files
Choose the type of file you want to work on.    To see all of the available types of files, click the arrow 
to the right of the List Type of Files box.
When you choose a type of file, the Publication Name box displays a list of all the files on the 
current directory that have that type of file format.    You can work on a file created in another word 
processing application, but it must have a file format that Publisher can convert.    Publisher can 
convert and open files created in the following word processing applications:

Word Perfect 5.0 and 5.1
Microsoft Word for Windows, 1.0 and 1.1
Microsoft Works for Windows word processing files (files with the .WPS extension)
Microsoft Works 2.0 word processing files (files with the .WPS extension) 
Microsoft Word for DOS, 3.0-5.X

ASCII

WordStar 3.3, 3.4, and 4.0
Microsoft Windows Write
PC-8 (line breaks will be preserved but not the text formatting)

For more information, see the Adding an Entire File from Another Application topic referenced below.

Read Only
Choose the Read Only check box to prevent making any permanent changes to the file.
An X in the check box indicates the option is chosen.    You can change or copy the file, but the 
original remains unchanged. 

OK
Choose the OK button to close the publication you are currently working on and open the file you've 
chosen.

Cancel
Choose the Cancel button to return to the current publication without opening another file.

See also
Changing a Template
Adding an Entire File of Text From Another Application



Opening an Existing Publication



 Close Publication Command (File Menu)
The Close Publication command puts away a publication that you are working on without leaving 
Publisher.    Publisher allows only one open publication at a time.    When you finish working on a 
publication, you have to close it before you can work on another one.    If you have made any changes to 
your publication since you last saved it, Publisher displays a message asking if you want to save those 
changes.

Publisher message options

Yes
Choose the Yes button to save changes you've made since you last saved your publication.

No
Choose the No button to erase changes you've made since you last saved your publication.

Cancel
Choose the Cancel button to continue working on the publication.

See also
Closing Your Publication
Save Command (File Menu)
Save As Command (File Menu)



 Save Command (File Menu)
The Save command keeps changes you've made to an existing publication.    Publisher saves the file in 
the current directory and copies it over any file with the same name in that directory.    If you have just 
created a new publication and are making changes to it for the first time, Publisher displays the Save As 
dialog box.    For more information, see the Save As Command (File Menu) topic referenced below .

Note
If you want to save changes to a publication and keep the original version as well, use the Save 

As command and give the new version a different name.    For more information, see the Save As 
Command (File Menu) topic referenced below.

Tip
To quickly save changes you've made to a publication, hold down CTRL and press S.

See also
Save As Command (File Menu)
Saving and Naming Your Publication



 Save As Command (File Menu)
The Save As command saves 1) a new publication, 2) a copy of an existing publication under a new 
name, or 3) highlighted text so you can use it in another publication or Windows application.    You can 
also use this command to create a template that you can use to start other publications, or to change the 
location or file format  of a publication.    For more information on creating and changing templates, see 
the Starting with a Template and Changing a Template topics referenced below.

Save As dialog box options

Publication Name
If you are working on a new publication and saving it for the first time, type a name for the 

publication.
If you want to save a copy of an existing publication under a new name, type a new name.
If you want to save a selection of text to be used in another publication or application, type a 

name for the file where the text will be saved.

Save Selection As
The Save Selection As option is available only if you've highlighted text in your publication.    An X 

in the check box indicates the option is chosen
1 Choose the Save Selection As check box to use highlight text in another publication or 
application.
2 If you want the file to be saved so that you can use it in another application, in the Save Selection 
As list box, choose a type of file format.    To see all of the available file formats, click the arrow to the right 
of the Save Selection As box.

If you're not sure where you'll be using the file or how to save the file, choose Plain Text.    This 
lets you use the file in most word processing applications.    For more information, see the Exporting Text 
Created in Publisher to Another Application topic referenced below.

List Files of Type
This unavailable option appears in the dialog box if you haven't highlighted text in your publication.    
When you save a publication using the Save As command, your publication will always be saved as 
a Publisher file.

Directories
Double-click another directory to save the file or publication in a different directory from the one 
currently chosen.

Drives
Choose another drive if you want to save the publication or file on another drive.
For example, choose drive A if you want to save the publication or file on a floppy disk.

Template
Choose the Template check box to save a copy of the publication or file as a template in the 
Template directory.
You can use this copy as a pattern for other publications.    An X in the check box indicates the 
option is chosen.

Backup
Choose the Backup check box to save the current version of the publication and a backup copy with 
the .BAK file name extension.
An X in the check box indicates the option is chosen.

OK
Choose the OK button to accept the options you've chosen.

Cancel
Choose the Cancel button to return to the publication without saving changes.



See also
Starting with a Template
Changing a Template
Exporting Text Created in Publisher to Another Application
Save Command (File Menu)
Saving and Naming Your Publication



 Import Text Command (File Menu)
The Import Text command imports text from another publication or text created in another application 
into your publication.

Import Text dialog box options

Text Name
Type the name of the file that you want to import into the current publication, or choose one from the 
Text Name list box.
If the file you want to import isn't listed in the list box, or if Publisher can't open the file whose name 
you type, you may need to specify a different drive or directory in the Drives or Directories box, or 
specify a new file type in the List Type of Files box.

Drives
Choose another drive if the file you want to use is stored on another drive in your computer.
For example, choose drive A if the file is stored on a floppy disk.

Directories
Double-click the directory where the file you want to work on is stored.
Publisher automatically displays the Publisher directory unless you choose another.

List Type of Files
Choose the type of file you want to import.    To see all the file types available to you, click the arrow 
to the right of the List Type of Files box.
When you choose a type of file, the Text Name list box displays a list of all the files on the current 
directory that have that type of file format.    You can import a file created in another word processing 
application, but it must have a file format that Publisher can convert.    Publisher can convert and 
open files created in the following word processing applications:

Word Perfect 5.0 and 5.1
Microsoft Word for Windows, 1.0 and 1.1
Microsoft Works for Windows word processing files (files with the .WPS extension)
Microsoft Works 2.0 word processing files (files with the .WPS extension) 
Microsoft Word for DOS, 3.0-5.X

ASCII

WordStar 3.3, 3.4, and 4.0
Microsoft Windows Write
PC-8 (line breaks will be preserved but not the text formatting)

For more information see the Adding an Entire File of Text from Another Application topic referenced 
below.

OK
Choose the OK button to import the file you've chosen.

Cancel
Choose the Cancel button to return to Publisher without importing text.

What If...
The Import Text command is unavailable?
The text frame may not be selected.    Click inside the text frame and then choose the Import Text 

command again.

See also
Adding an Entire File of Text From Another Application
Exporting Text Created in Publisher to Another Application



 Import Picture Command (File Menu)
The Import Picture command imports 1) a picture from a file of ready-made pictures called ClipArt or 2) a 
picture from another graphics application into your publication.    To control the size and position of the 
picture you want to import, first draw a picture frame where you want the picture.    Then, choose the 
Import Picture command.    You can change the size of a picture you've imported with this command, but 
you can't make changes to the picture itself.    For more information on the different ways you can add 
pictures to a publication, see the topics referenced below.

Import Picture dialog box options

Picture Name
Choose the picture file you want to add from the list.
If the file you want to import is not on the list, you may have to specify a different drive or directory in 
the Drives or Directories box, or specify a new file type in the List Type of Files box.

Drives
Choose a drive if the picture file is located on a drive other than the one currently chosen.
For example, choose drive A if the picture file is on a floppy disk.

Directories
Double-click the directory where the picture file you want to import is saved.

List Type of Files
Choose the type of file you want to import.    To see all of the types of files available to you, click the 
arrow to the right of the List Type of Files box.
When you choose a type of file, the Picture Name list box displays a list of all the files on the current 
directory that have that type of file format.
Publisher can convert and open the following types of pictures:

Bitmapped (paint-type) pictures.
These pictures are created by programs such as Windows Paintbrush.    Scanners create another 

kind of bitmap known as a TIFF (Tag Image File Format).    BMP, PCX and TIF are file extensions for 
bitmaps.

Draw-type (object-oriented) pictures.
These are made by many Windows applications--for example a Corel Draw! or Windows Draw 

drawing or an Excel chart.    This category also includes Encapsulated PostScript (EPS) pictures, which 
are stored in a format best printed by a PostScript printer, and Computer Graphics Metafile (CGM), the 
format of Publisher's ClipArt.    CGM, DRW, EPS, and WMF are file extensions for draw-type pictures.

Picture Preview
Choose the Picture Preview button to preview the picture you've chosen before importing it into your 
publication.

OK
Choose the OK button to import the picture you've chosen.

Cancel
Choose the Cancel button to return to Publisher without importing the picture.

Note
If you do not draw a picture frame for the picture you want to import, Publisher draws a frame and 

imports the picture, positioning it in the middle of the page.

See also
Adding Publisher's ClipArt 
Adding a Picture from Another Application
Copying a Picture from a Document in Another Application



Adding a Picture That You Create and Change in Publisher
Adding a Picture That You Want to Use and Update in Several Locations
Moving a Frame or Drawn Object
Copying a Frame or Drawn Object
Insert Object Command (Edit Menu)
Paste Special Command (Edit Menu)



 Print Command (File Menu)
The Print command prints your publication or any part of it, using the printer specified in Publisher or in 
the Printers section of the Windows Control Panel.    For information on printers, see the topics 
referenced below.

Print dialog box options

Printer
Displays the kind of printer you are currently connected to.

Print Range
Choose All to print the entire publication.
Choose Pages to print a range of pages.
In the From box, type the first page number you want to print.    In the To box, type the last page 

number you want to print.

Print Quality
To see all of the resolutions available to you, click the arrow to the right of the Print Quality box.

Choose High resolution for the best printing quality of your publication.    Keep in mind that 
printing takes more time because this option puts more dots per inch (dpi) on the page.

Choose Low resolution to save time in printing.    This option puts fewer dots per inch on the 
page.    As a result, printing goes faster, but the printed quality of your publication is not as sharp.

Choose Medium resolution for a compromise on printing time and printed quality of your 
publication.

Choose Draft to quickly print only the text of a publication.    For some printers, the Draft option 
also prints objects.

Copies
Type the number of copies you want printed.
Publisher prints all the copies of each page at one time unless you choose Collate Copies.

Collate Copies
Choose the Collate Copies check box to automatically print one copy at a time, from beginning to 
end.
An X in the check box indicates that the option is chosen.    Turn off this option to speed up printing 
of multiple copies of publications.    The Collate Copies check box is unavailable if your printer 
cannot print collated copies.

Print to File
Choose the Print to File check box to save a copy of your publication exactly as it was formatted in 
Publisher. 
An X in the check box indicates the option is chosen.    If you choose this option, you can save a file 
using a printer driver for a printer that is not actually connected to your printer.    You can then take 
the file and print it somewhere else, or print it from another computer that does not have Publisher. 

Print Crop Marks
Choose the Print Crop Marks check box to print crop marks that help you precisely trim the pages of 
your publication if the page size you've chosen is smaller than the paper you're printing on.
An X in the check box indicates the option is chosen.

OK
Choose the OK button to print your publication.

Cancel
Choose the Cancel button to return to your publication without printing.

Setup



Choose the Setup button to see the Print Setup dialog without using the File menu.

Note
The printing options you choose for printing an individual publication, such as number of copies 

and resolution, are not saved with that publication.    When you print the publication again, you will need to 
choose the options you want.

Tip
To print your publication using a keyboard shortcut, hold down CTRL and press P.

What if...
Publisher displays a message when I choose Print from the File menu?
See the A Checklist Before You Print topic referenced below.    Keep in mind that choosing a 

different printer for a publication may change the way the publication looks.

See also
Printing Your Publication
Choosing a Printer
A Checklist Before You Print
Print Setup Command (File Menu)



 Print Setup Command (File Menu)
The Print Setup command lets you choose the printer you want to use, and other printing options such 
as the orientation and size of paper.    In order to make choices that your printer can print, it's important 
to choose a printer before you select these options.    For more information on choosing a printer, see the 
Choosing a Printer topic referenced below.

Print Setup dialog box

Printer
Choose Default Printer to print your publication with the printer you are currently using.
Publisher displays the name of the printer you're using under the Default Printer button.
Choose Specific Printer to print your publication with one of the printers installed in Windows.    

To see all of the printers available to you, click the arrow to the right of the Specific Printer list box.    
Choose the printer you want to use from the box.

Orientation
Choose Portrait to print a page that's taller than it is wide.
Choose Landscape to print a page that's wider than it is tall.
When you choose an orientation for a publication, the picture to the left of the options changes to 

reflect your choice.    The Landscape option may not be available depending on the printer you're using 
and the paper size you've chosen.

Paper
Accept the suggested paper Size, or choose one from the list of paper sizes.    To see all of the 

paper sizes available to you, click the arrow to the right of the Size list box.    The list contains paper sizes 
that can be loaded into your printer, not necessarily the sizes that are actually loaded into the printer at 
the time of printing.

Accept the suggested paper Source, or choose one from the list that specifies other sources 
(upper tray, lower tray, or manual feed).    To see all of the sources available to you, click the arrow to the 
right of the Source list box.

OK
Choose the OK button to accept the printing options you've chosen.

Cancel
Choose the Cancel button to return to the publication using the current printing options.

Options
Choose the Options button to see a dialog box that lets you choose additional printing options that 
you can store with the current publication.    Choose the Help button to get information on the 
various options.
The Options button is unavailable if these additional options are not provided by the current printer 
driver.

See also
Choosing a Printer
Printing Your Publication



 Exit Publisher Command (File Menu)
The Exit Publisher command closes Publisher and any publication that you may be working on.    If you 
have made any changes to your publication since you last saved it, Publisher displays a message asking 
if you want to save those changes.

Publisher message options

Yes
Choose the Yes button to save changes you've made since you last saved your publication.

No
Choose the No button to erase changes you've made since you last saved your publication.

Cancel
Choose the Cancel button to return to the publication without saving changes.

Tip
To quickly exit Publisher, press F3.    Publisher will still ask if you want to save any changes you've 

made.

See also
Exiting Publisher
Closing Your Publication
Close Publication Command (File Menu)



 Undo Command (Edit Menu)
The Undo command reverses the last command or procedure you've completed.    For example, if you 
just added the bold style to a headline in a story, choosing Undo Format cancels the bold formatting.    
You must choose Undo immediately after applying a command or procedure.    Once Undo is chosen, 
Redo replaces it on the menu, allowing you to reverse the Undo command.    The words following "Undo" 
change according to what will be undone (for example, Undo Create Object).

Note
The Undo command is unavailable when the last action completed cannot be reversed.

Tip
To quickly undo the last command or procedure you've completed, hold down ALT and press 

BACKSPACE.

See also
The Undo Command



 Cut Command (Edit Menu)
The Cut command removes a selected object or highlighted text from a publication, and places it on the 
Clipboard until another object is cut or copied to the Clipboard.    The words following "Cut" change 
according to what is selected (for example, Cut Text Frame) or highlighted.    This command is 
unavailable if nothing is selected or highlighted.

Note
The Clipboard can only hold one set of objects at a time.    When you cut an object or text from 

your publication, it replaces what was previously stored on the Clipboard.

Tip
To quickly cut a selected object or highlighted text to the Clipboard, hold down CTRL and press X, 

or hold down SHIFT and press DEL.

See also
Moving Text
Moving a Frame or Drawn Object
Copying Text
Copying a Frame or Drawn Object
Copy Command (Edit Menu)
Paste Command (Edit Menu)



 Copy Command (Edit Menu)
The Copy command puts a copy of a selected object or highlighted text on the Clipboard.    The words 
following "Copy" change according to what is selected or highlighted (for example, Copy Text Frame).    
This command is unavailable if nothing is selected or highlighted.

Notes
If all the text frames of a story are copied and then pasted into another location, the frames and 

the text they contain are duplicated.    If only a few of the frames in a chain of text frames are copied, only 
the frames, and not the text they contain, are duplicated.    For more information on copying text frames, 
see the Copying a Text Frame topic referenced below.

The Clipboard can only hold one set of objects at a time.    When you copy an object or text to the 
Clipboard, it replaces what was there before.

Tip
To quickly copy a selected object or highlighted text to the Clipboard, hold down CTRL and press 

C, or hold down CTRL and press INS.

See also
Copying Text
Copying a Text Frame
Copying a Frame or Drawn Object
Moving Text
Moving a Frame or Drawn Object
The Undo Command
Paste Command (Edit Menu)



 Paste Command (Edit Menu)
The Paste Command inserts a copy of the contents of the Clipboard into your publication.    If you're 
pasting text, Publisher inserts the text at the insertion point.    If you're pasting objects, Publisher inserts 
the objects as close as possible to the center of the window.    The words following "Paste" change 
according to what is on the Clipboard (for example, Paste Object).    This command is unavailable if the 
Clipboard is empty.

Tip
To quickly paste objects or text from the Clipboard into your publication, hold down CTRL and 

press V, or hold down SHIFT and press INS.

See also
Copying Text
Copying a Frame or Drawn Object
Moving Text
Moving a Frame or Drawn Object
The Undo Command
Undo Command (Edit Menu)
Cut Command (Edit Menu)
Copy Command (Edit Menu)



 Paste Special Command (Edit Menu)
The Paste Special command inserts a copy of a picture from another Windows application, such as a 
Paintbrush picture, data from a spreadsheet, or an Excel chart, into your publication.    The copy is linked 
to the original file, and is automatically updated when changes are made to that file. 

Paste Special dialog box options

Source:
Choose a file format for the object you're pasting.

Choose To

Native Paste the object into your publication with its original file format ( the format it had 
when you copied it).

MetaFilePict Paste the object into your publication as a metafile.    Select this option when you 
want to treat the object like a picture, for example if you want to crop it. 

Bitmap Paste the object into your publication as a bitmap.    Select this option when you want 
to treat the object like a picture and are unable to use the MetaFilePict option.

Paste
Choose the Paste button to insert the picture into the publication without linking the picture to its 
original file.
This is exactly like choosing Paste from the Edit menu.

Paste Link
Choose the Paste Link button to insert the picture into the publication and establish an automatic 
link between the picture and its original file. 
With this link, each time changes are made to the original file, Publisher updates the picture in your 
publication.

OK
Choose the OK button to paste the picture into your publication.

Cancel
Choose the Cancel button to return to the current page without pasting a new picture into the 
publication.

Note
You can use the Paste Special command to insert charts and spreadsheets from such programs 

as Windows Work or Excel, or tables from a word processor such as Windows Word.    Although you 
might not ordinarily think of charts, spreadsheets, and tables as "pictures," Publisher considers them as 
such when you insert them using this method.

What if...
The Paste Special Command is unavailable?
The application you're using may not be one that supports this procedure.    If this is the case, you 

can still import or copy and paste a picture from that application into your publication but you won't be 
able to like it to its original file.    For more information, see the Adding a Picture from Another Application 
topic referenced below. 

See also
Adding a Picture from Another Application
Adding a Picture That You Want to Use and Update in Several Locations
Copying Text
Copying a Frame or Drawn Object
Moving Text
Moving a Frame or Drawn Object



Paste Command (Edit Menu)



 Delete Command (Edit Menu)
The Delete command removes highlighted text or a selected object from the publication.    The words 
following "Delete" change according to what is highlighted or selected (for example, Delete Text).    This 
command is unavailable if nothing is selected or highlighted.

See also
Deleting Text
Deleting Text Frames
Deleting a Picture Frame or Drawn Object
The Undo Command



 Delete Picture Frame Command (Edit Menu)
The Delete Picture Frame command removes a selected picture frame and the picture it contains.    This 
command is unavailable if a picture frame is not selected.

See also
Deleting a Picture Frame or Drawn Object
The Undo Command



 Delete Text Frame Command (Edit Menu)
The Delete Text Frame command removes a selected text frame.    If the text frame is connected to 
another text frame, Publisher puts the text from the deleted frame into the connected frame or its 
overflow area.    If the deleted frame is not connected to another frame, any text it contains will be 
deleted along with the frame.    This command is unavailable if a text frame is not selected.

For information on connecting text frames and deleting text frames, see the Disconnecting and 
Reconnecting Text Frames and Deleting Text Frames    topics referenced below.

See also
Disconnecting and Reconnecting Text Frames
Deleting Text Frames 
The Undo Command



 Highlight Story Command (Edit Menu)
The Highlight Story command highlights all the text in a story from the first frame to the last frame.    Click 
anywhere within a text frame, and then choose Highlight Story from the Edit menu to highlight the story.

Tip
To quickly highlight a story, place the insertion point in the text, and press F8, or hold down CTRL 

and press A.

See also
Choosing the Text You Want to Change



 Edit {Object Name} Command (Edit Menu)
The Edit {Object Name} command lets you make changes to a picture that you created in another 
Windows application, such as a Paintbrush picture or an Excel spreadsheet, and added to a publication 
using the Insert Object command.    Publisher remembers the application that the picture was created in, 
and starts it from within your publication when you want to make changes.

Select the picture you want to change, and choose Edit {Object Name} from the Edit menu.    The 
command will change according to the type of picture you've selected.    For example, the command 
appears as Edit Excel Chart if the object you selected is an Excel chart.    You can now make any 
changes you want to the chart using the application it was created in.

Notes
You can use the Edit {Object Name} command to make changes to charts and spreadsheets from 

such programs as Windows Work or Excel, or tables from a word processor like Windows Word.    
Although you might not ordinarily think of charts, spreadsheets, and tables as "pictures," Publisher 
considers them as such when you change them using this method.

You can also quickly make changes to a picture that you inserted into a publication using the 
Insert Object command.    Simply double-click picture.    You are now free to make any changes you want 
to the picture using the application it was created in.

See also
Adding a Picture That You Create and Change in Publisher
Insert Object Command (Edit Menu)



 Insert Object Command (Edit Menu)
The Insert Object command adds or changes pictures created in other applications, such as a chart 
created in Excel, a picture created in Windows Paintbrush, or data from a spreadsheet. Publisher 
remembers the application used to create the picture, and starts it from within your publication when you 
want to make changes.

Insert Object dialog box

Type of Object
Choose the application you want to use to create the picture.
--Or--
Choose the application used to create the picture that you want to add to a publication.
Some examples of available applications are Winworks, Excel, and Draw.    To see all of the 
applications available to you, scroll through the list.    Publisher only lists the applications that can be 
used with this command.

OK
Choose the OK button to have Publisher open the application you've chosen.

Cancel
Choose the Cancel button to return to your publication without inserting a new picture.

Notes
You can use the Insert Object command to make, add or change charts and spreadsheets from 

such programs as Windows Works or Excel, or tables from a word processor like Windows Word.    
Although you might not ordinarily think of charts, spreadsheets, and tables as "pictures," Publisher 
considers them as such when you change them using this method.

After you've created the picture or chosen an existing picture that you want to add to the 
publication, choose Update from the File menu.    The picture is now displayed in the application in which 
it was created.    Choose Exit from the File menu of the application to return to the current page of the 
publication.

After creating or adding a picture with this command, you can easily change the picture later.    
Simply double-click the picture.    You can now make your changes in the application that the picture was 
created in.    For more information, see the Adding a Picture from Another Application topic referenced 
below.

See also
Adding a Picture from Another Application
Copying a Picture from a Document in Another Application
Adding a Picture That You Create and Change in Publisher
Adding a Picture That You Want to Use and Update in Several Locations
Adding Publisher's ClipArt 
Moving a Frame or Drawn Object
Copying a Frame or Drawn Object
Import Picture Command (File Menu)



 Find Command (Edit Menu)
The Find command searches for specified text to help you quickly locate part of a story.

Find dialog box options

Find What
Type the text that you want to find in the story.

Match Whole Word Only
Choose the Match Whole Word Only check box if you want to find a specific word, such as "bicycle," 
and ignore longer variations of the word, such as "bicycles" and "bicycled."
An X in the check box indicates the option is chosen.

Match Case
Choose the Match Case check box if you want to find only the text that matches the exact 
combination of uppercase and lowercase letters you've typed in the Find What box, such as "Then."
An X in the check box indicates the option is chosen.

Direction
Choose Up to search from the insertion point to the beginning of the story.
Choose Down to search from the insertion point to the end of the story.

Find Next
Choose the Find Next button to find each occurrence of the specified text.
When Publisher finds the text you've specified, Publisher shows you the place in the story where it's 
located.

Cancel
Choose the Cancel button to stop the search and return to the story.

See also
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text For You
Replace Command (Edit Menu)



 Replace Command (Edit Menu)
The Replace command searches for and replaces specified text in a story.

Replace dialog box options

Find What
Type the text that you want to find in the story.

Replace With
Type the replacement text.
If you want to remove text from the story without replacing it, leave the Replace With box empty.

Match Whole Word Only
Choose the Match Whole Word Only check box if you want to find a specific word, such as    
"bicycle," and ignore longer variations of the word, such as "bicycles" or "bicycled."
An X in the check box indicates the option is chosen.

Match Case
Choose the Match Case check box if you want to find only the text that matches the exact 
combination of uppercase and lowercase letters you've typed in the Find What box, such as "Then."
An X in the check box indicates the option is chosen.

Find Next
Choose the Find Next button to find each occurrence of the text you're searching for without 
replacing the current occurrence.

Replace
Choose the Replace button to insert the replacement text and to find the next occurrence of the text 
you're searching for.

Replace All
Choose the Replace All button to replace all occurrences of the text you're searching for without 
confirming each replacement first..

Cancel
Choose the Cancel button to stop searching for and replacing the text you've specified.
This does not remove any of the changes already made.

See also
Having Publisher Find the Text You Want to Change
Having Publisher Find and Change Text For You
Find Command (Edit Menu)



 Full Page (Page Menu)
The Full Page command displays a miniature view of the entire page.    You can use this view to see the 
layout of the whole page.    A check mark on the menu beside the command indicates that you are using 
this view.

Tip
You can quickly switch between Full Page and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced



 25% Size Command (Page Menu)
The 25% Size command displays the entire page at one-quarter of its actual size.    A check mark on the 
menu beside the command indicates that you are using this view.

Tip
You can quickly switch between 25% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 33% Size Command (Page Menu)
The 33% Size command displays the entire page at one-third of its actual size.    A check mark on the 
menu beside the command indicates that you are using this view.

Tip
You can quickly switch between 33% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 50% Size Command (Page Menu)
The 50% Size command displays a portion of the page at one-half of its actual size.    A check mark on 
the menu beside the command indicates that you are using this view.

Tip
You can quickly switch between 50% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 66% Size Command (Page Menu)
The 66% Size command displays a portion of the page at two-thirds of its actual size.    A check mark on 
the menu beside the command indicates that you are using this view.

Tip
You can quickly switch between 66% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 75% Size Command (Page Menu)
The 75% Size command displays a portion of the page at three-quarters of its actual size.    A check 
mark on the menu beside the command indicates that you are using this view.

Tip
You can quickly switch between 75% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 Actual Size Command (Page Menu)
The Actual Size command displays a close-up of the selected part of the current page.    This is how your 
page will look when it's printed.      You can use this view to add, read, or change text, or to position an 
object precisely.    A check mark on the menu beside the command indicates that you are using this view.

Note
If you haven't selected any part of the page, Publisher displays the upper-left corner of the page.

Tip
You can quickly switch between Actual Size and Full Page views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 200% Size Command (Page Menu)
The 200% Size command displays the page at twice its actual size.    A check mark on the menu beside 
the command indicates that you are using this view.

Tip
You can quickly switch between 200% Size and Actual Size views by pressing F9.

See also
Choosing Your View of the Page: Actual Size, Magnified, or Reduced 



 Insert Pages Command (Page Menu)
The Insert Pages command adds the number of pages you choose before or after the current page of a 
publication.

Insert Pages dialog box options

Number of Pages
Type the number of new pages you want to add to the publication.

Before Current Page
Choose if you want to insert the page or pages before the page you are currently working on.

After Current Page
Choose if you want to insert the page or pages after the page you are currently working on.

Options
Choose Insert Blank Pages to add only blank pages to the publication.
Choose Automatically Create Text Frames to create a text frame from margin to margin on 

each of the new pages.
Choose Duplicate All Objects On The Page to copy all objects, but not the contents of frames, 

from a page you specify to all of the new pages.    The number in the box to the right of the button is the 
page number of the page from which you are copying the objects.    Frames and their properties will be 
copied, but the contents of frames will not.

Tip
To quickly add one new blank page after the current page, hold down CTRL and press N.

See also
Adding Pages to Your Publication
Deleting Pages
Delete Page Command (Page Menu)
Moving Between Pages
Adding or Removing Page Numbers



 Delete Page Command (Page Menu)
The Delete Page command removes the current page and its contents.    After a page is removed, 
Publisher displays the next page, or, if there is no page following the page that was deleted, Publisher 
displays the previous page.

Notes
If you delete the only page in a publication, only the contents of the page are deleted.    A single 

blank page remains.
If you delete a page containing a text frame that is connected to a text frame on another page, 

Publisher puts the text from the deleted frame into the connected frame or its overflow area.    For 
information on connecting text frames, see the Disconnecting and Reconnecting Text Frames topic 
referenced below.

See also
Disconnecting and Reconnecting Text Frames
Deleting Pages
Adding Pages to Your Publication
Insert Pages Command (Page Menu)
Moving Between Pages



 Insert Page Numbers Command (Page Menu)
The Insert Page Numbers command prints a page number on each page of a publication after you've put 
a page-number mark on the background of your publication.    For information on how to put a page-
number mark on the background, see the topics on page numbers referenced below.

See also
Adding or Removing Page Numbers
Adding Page Numbers to a Publication with Facing Pages
Adding New Pages to your Publication
Insert Pages Command (Page Menu)



 Ignore Background Command (Page Menu)
The Ignore Background command hides the objects on the background for the current page.    A check 
mark on the menu next to the command indicates that the background for the current page is hidden.    
For information on how to use the background, see the topics referenced below.

See also
Setting Up Your Publication
Adding Text and Pictures That Will Repeat on Every Page
Go to Background Command (Page Menu)



 Go to Background Command (Page Menu)
The Go to Background command displays the background of a publication page.    The background is 
where you can place objects that you want to repeat on each page of a publication.    When you choose 
the Go to Background command, the Go to Foreground command replaces it on the menu.    Choose Go 
to Foreground to return to the page that you were working on.    For information on how to use the 
background, see the topics referenced below.

Publications that have facing pages have two backgrounds, one for the left page and one for the right 
page.    For information on using two backgrounds, see the Repeating Text and Pictures on Facing 
Pages (as for a Book) topic referenced below.

Note
 When you're on the background, this symbol replaces the page controls in the lower-left corner of 

the window.    When you're working with facing pages and you go to the background, you will see two of 
these symbols representing both backgrounds.

Tip
To quickly move between the background and foreground, hold down CTRL and press M.

See also
Setting Up Your Publication
Adding Text and Pictures That Will Repeat on Every Page
Repeating Text and Pictures on Facing Pages (as for a Book)
Hiding the Background for a Single Page
Ignore Background Command (Page Menu)



 Page Setup Command (Page Menu)
The Page Setup command lets you choose 1) a layout option (full page, book, and so on), 2) the number 
of pages of a publication you want printed on one piece of paper, and 3) the size of the publication's 
page.

When you start a new publication, Publisher automatically sets the page size to match the size of the 
paper in your printer.    If you want the size of your publication to be different than the size of the printer 
paper, you'll need to choose a different page size.

Page Setup dialog box options

Layout Options
Depending upon the number of pages you have inserted in your publication to begin with, you may 
need to insert additional pages for the layout option that you choose.

Choose Full Page to print one page on each sheet of paper.
Choose Book to print two pages (arranged left and right) on each sheet of paper.
Choose Tent Card to print two pages (arranged top and bottom) on each sheet of paper.
Choose Greeting Card to print four pages (arranged two by two) on each sheet of paper.
Choose Index Card to print one page on each sheet of paper.
Choose Business Card to print one page on each sheet of paper.

Page Size
In the Width box, accept the suggested width measurement for the page, or type the 

measurement you want.
In the Height box, accept the suggested height measurement for the page or type the 

measurement you want.
Depending on the layout option you've chosen, a maximum width and height measurement is 

displayed beneath each box.    Publisher alerts you when the page size you've chosen is larger than the 
maximum size recommended.    Publisher calculates this page size from the layout you've chosen and the 
paper size used in your printer.    You can either type in a new height and/or width, choose a larger paper 
size for your printer if possible, or switch to a printer that uses larger paper.

Preview
Displays a miniature view of each layout option with a brief description each time you choose an 
option.

OK
Choose the OK button to accept the layout options you've chosen.

Cancel
Choose the Cancel button to return to the publication with the original settings for the page.

See also
Setting and Changing the Page Size
Adding Pages to Your Publication
Insert Pages Command (Page Menu)



 Layout Guides Command (Layout Menu)
The Layout Guides command provides options for setting 1) guides for margins or space at each of the 
four edges of the page, 2) row and column guides for the page that you can use to lay out a publication, 
and 3) two backgrounds.    For information on how to precisely align objects to the guides you've set, see 
the Aligning Objects on the Page with Snap To topic referenced below.

Layout Guides dialog box options

Layout Guides
In the Left box, type a measurement for the amount of empty space you want at the left edge of 

each page of the publication.
In the Right box, type a measurement for the amount of space you want at the right edge of each 

page of the publication.
In the Top box, type a measurement for the amount of space you want at the top of each page of 

the publication.
In the Bottom box, type a measurement for the amount of space you want at the bottom of each 

page of the publication.
Use the guides you set as reference lines.    Place all objects within these lines to create a border 

of empty space around the page. 
In the Number of Columns box, type the number of columns you want divide the page into.
In the Number of Rows box, type the number of rows you want to divide the page into.

Preview
Displays a miniature view of the layout guides you've chosen.

Create Two Backgrounds With Mirrored Guides
Choose the Create Two Background check box to create two backgrounds for a publication with 
facing pages (such as a book or pamphlet).
An X in the check box indicates the option is chosen.    Under Layout Guides, the Left and Right 
boxes change to Inside and Outside.

OK
Choose the OK button to use the options you've chosen.

Cancel
Choose the Cancel button to return to the page, keeping the guides Publisher suggests or the 
guides you chose previously.

Notes
Guides don't affect how text flows or the position of objects on the page; they are just a visual 

reference for laying out the page.    You can place objects on top of guides.
Guides cannot be seen behind frames and opaque drawn objects.    They are visible behind 

transparent drawn objects.

Tip
To quickly hide or show layout guides, hold down CTRL and press G.

See also
Aligning Objects on the Page with Snap To
Setting and Changing Layout Guides
Setting and Changing Layout Guides for Facing Pages (as for a Book)
Hide Layout Guides Command (Options Menu)



 Frame Margins Command (Layout Menu)
The Frame Margins command provides options for setting the margins in selected picture frames.    This 
command is only available if a picture frame is selected.

Frame Margins dialog box

Margins
In the Left and Right box, type a measurement for the amount of space you want at the left and 

right edges of the picture frame.
In the Top and Bottom box, type a measurement for the amount of space you want at the top 

and bottom edges of the picture frame.

OK
Choose the OK button to add the options to the selected frame.

Cancel
Choose the Cancel button to return to the current page, keeping the options Publisher suggests or 
the options you chose previously.

See also
Creating Several Picture Frames with the Same Margins
Adding Space (Margins) Around a Picture



 Frame Columns and Margins Command (Layout Menu)
The Frame Columns and Margins command provides options for setting the margins and columns for 
text in selected text frames.    This command is only available if a text frame is selected.

Frame Columns and Margins dialog box

Margins
In the Left and Right box, type a measurement for the amount of space you want at the left and 

right edges of the text frame.
In the Top and Bottom box, type a measurement for the amount of space you want at the top 

and bottom edges of the text frame.
In the Number of Columns box, type the number of columns you want for the text.
In the Column Gutter box, type a measurement for the amount of space you want between each 

column of text.

OK
Choose the OK button to add the margins and columns to the selected frame.

Cancel
Choose the Cancel button to return to the current page, keeping the options Publisher suggests or 
the options you chose previously.

See also
Creating Columns Within a Text Frame
Creating Several Frames with the Same Margins and Columns



 Bring to Front Command (Layout Menu)
The Bring to Front command moves a selected object in front of all the unselected objects on the page. 
You can also use this command for a group of selected objects.    The selected objects stay in the same 
order in which each was created, and are placed as a group in front of the unselected objects on the 
page.

Tip
To quickly put a selected object in front of all the unselected objects on the page, hold down CTRL 

and press F.

See also
Layering Text, Pictures, and Drawn Objects
Send to Back Command (Layout Menu)



 Send to Back Command (Layout Menu)
The Send to Back command moves a selected object behind all the unselected objects on the page.    
You can use this command for a group of selected objects.    The selected objects stay in the same 
order, and are placed as a group behind all the unselected objects on the page.

See also
Layering Text, Pictures, and Drawn Objects
Bring to Front Command (Layout Menu)



 Line Command (Layout Menu)
The Line command provides options for adding thickness, color, and arrowheads to selected lines.    This 
command is only available if a line is selected.

Line dialog box options

Thickness
Choose how thick you want the line to be.
--Or--
Type a new measurement in the 10 pt box.
There are 72 points to one inch, so if you type 36, the selected line will be one-half inch wide.    
Publisher accepts measurements from 0.25 points to 127 points.

Color
Choose a color for the line.
To see all the available colors, click the arrow to the right of the Color box.

Arrowhead options
Choose a type of arrowhead for the line.

OK
Choose the OK button to add the options you've chosen to the line.

Cancel
Choose the Cancel button to return to the current page without changing the line.

Tip
You may want to use lines thinner than one point, called hairlines, in your publication.    To create 

a hairline, type a number less than 1 in the 10 pt box under Thickness.    For example, type .50 to create a 
hairline one-half point wide.

See also
Adding Drawn Objects: Boxes, Lines, and Ovals
Adding Lines and Arrows



 Border Command (Layout Menu)
The Border Style command provides options for adding a simple outline around selected frames and all 
drawn objects except for lines.    Options vary depending upon the type of object selected.    This 
command is only available if an object is selected.

Border dialog box options (for frames)

Border
Choose the Select All Sides check box to add a border to each side of the frame.    An X in the 
checkbox indicates the option is chosen.
--Or--
In the picture in the Border box, click each side of the frame you want to add a border to.    Each 
time you click a side, in the Thickness box, choose how thick you want the border to be .

Thickness
Select how thick you want the border to be.    If you have selected a side of the frame, the word in 
parentheses changes according to where you're adding the border.
--Or--
Type a new measurement in the 10 pt box.
There are 72 points to one inch, so if you type 36, the selected line will be one-half inch wide.    
Publisher accepts measurements from 0.25 points to 127 points.

Color
Choose a color for the border.
To see all of the available colors, click the arrow to the right of the Color box.

OK
Choose the OK button to add the border you've chosen to the frame.

Cancel
Choose the Cancel button to return to the current page without adding a new border.

Note
The frame in the Border box changes according to the thickness you've chosen.

Border dialog box options (for drawn objects)

Thickness
Choose how thick you want the border to be.
--Or--
Type a new measurement in the 10 pt box.
There are 72 points to one inch, so if you type 36, the selected line will be one-half inch wide.    
Publisher accepts measurements from 0.25 points to 127 points.

Color 
Choose a color for the border.
To see all the available colors, click the arrow to the right of the Color box.

OK
Choose the OK button to add the border you've chosen to the drawn object.

Cancel
Choose the Cancel button to return to the current page without adding a new border.

Tip
You may want to use borders thinner than one point in your publication.    To create very thin 



borders, type a number less than 1 in the 10 pt box under Thickness.    For example, type .50 to create a 
border one-half point wide.

See also
Adding Borders and BorderArt to Frames
Adding Borders and BorderArt to Drawn Objects
BorderArt Command (Layout Menu)



 BorderArt Command (Layout Menu)
The BorderArt command provides options for adding fancy borders with designs such as triangles and 
palm trees, to selected boxes and frames.    You can choose from an alphabetical list of the available 
borders and see a preview of these borders in the dialog box. 

BorderArt dialog box options

Available Borders
Choose a border from the list.
To see all of the borders available to you, scroll through the list.

Border Size
Type a measurement for how big you want the border to be.
Publisher accepts measurements from 4 points to 127 points.

Use Recommended Size
Choose the Use Recommended Size check box to add the border you've chosen at the size 
Publisher recommends.
An X in the check box indicates that it is chosen.

Preview
Displays a miniature view of the box or frame with the border you've chosen.

OK
Choose the OK button to add the border you've chosen to the selected box or frame.

Cancel
Choose the Cancel button to return to the current page without adding a new border.

See also
Adding Borders and BorderArt to Frames
Adding Borders and BorderArt to Drawn Objects
Border Command (Layout Menu)



 Shading Command (Layout Menu)
The Shading command provides options for filling the inside of a selected object with one of a variety of 
possible patterns.    You can also choose colors for the pattern and colors for the area behind the pattern.

Shading Dialog Box Options

Style
Choose a pattern to fill the selected object.    If you choose the top box in the left corner, the selected 
object will be clear.

Preview
Displays the pattern and colors you've chosen.

Color
In the Foreground box, choose a color for the pattern.
To see all of the colors available to you, click the arrow to the right of the Foreground box.
In the Background box, choose a color for the area behind the pattern.
To see all of the colors available to you, click the arrow to the right of the Background box.

OK
Choose the OK button to add the pattern and colors you've chosen.

Cancel
Choose the Cancel button to return to the page without adding a new pattern and color to the 
selected object.

See also
Adding Patterns and Color to Frames and Drawn Objects



 Shadow Command (Layout Menu)
The Shadow command adds a shadow to the right and bottom edges of all selected objects except lines 
and arrows.    A check mark on the menu next to the command indicates the selected object has a 
shadow.

Tip
To quickly add a shadow to a selected object, hold down CTRL and press D.    You can also add a 

shadow using the appropriate button on the Toolbar.

See also
Adding Shadows Behind Frames or Drawn Objects



 Character Command (Format Menu)
The Character command provides options for changing the appearance of highlighted characters.    
These options include font, styles, point size, and color.    You can apply more than one style 
simultaneously.

Character dialog box options

Font
Type a font name.
--Or--
Choose one from the list.
To see all of the available fonts, click the arrow to the right of the Font box.    Publisher lists all the 
fonts available with the printer you've chosen for the publication.    You can type a different font name 
if you plan to use another printer that supports the new font.

Style
Choose the styles you want to apply to the highlighted characters.
A character can have more than one style at once, but it cannot have both capitals styles, or both 
underlined styles at once.

Point Size
Type or choose a point size for the highlighted characters.
To see all the available point sizes, click the arrow to the right of the Point Size box.

Color
Choose a color from the list.
To see all the available colors, click the arrow to the right of the color box.    You must have a color 
monitor to display text you add color to, and a color printer to print text with the colors you've 
chosen.

Super/Subscript
Choose Normal to position characters on the regular line of text.
Choose Superscript to raise characters above the regular line of text and reduce their point size.
Choose Subscript to lower character below the regular line of text and reduce their point size.

OK
Choose the OK button to add the fonts, styles, point size, and color you've chosen.

Cancel
Choose the Cancel button to return to the current page without changing the appearance of the 
highlighted characters.

Note
You can change the font, point size, and some styles (bold, italic, and underline) quickly by 

choosing the appropriate buttons on the Toolbar.    See the topics referenced below for more information.

Tip
You can use the following keyboard shortcuts to quickly format highlighted text.    For example, to 

make highlighted text bold, hold down CTRL and press B.

Press When you want to

CTRL+SPACEBAR Remove styles and subscript or superscript from highlighted text

CTRL+B Make highlighted text bold

CTRL+I Italicize highlighted text

CTRL+U Underline highlighted text



CTRL+EQUAL SIGN (=) Apply subscript format

CTRL+PLUS SIGN (+) Apply superscript format

See also
Choosing the Font, Size, and Position of Text
Choosing Styles: Bold, Italic, Underlined
Choosing Colors for Text



 Spacing Between Characters (Format Menu)
The Spacing Between Characters command provides options for specifying the distance between 
highlighted characters that look unevenly spaced.

Spacing Between Characters dialog box options

Spacing Between Characters
Choose Normal to space characters as they are when typed.
Choose Squeeze Letters Together for less space between highlighted characters.
Choose Move Letters Apart for more space between highlighted characters.
In the By This Amount box, Publisher suggests a measurement and gives the range of 

measurements for the option you've chosen.    Choose the measurement Publisher suggests, or type a 
new measurement.

OK
Choose the OK button to change the spacing of the highlighted characters.

Cancel
Choose the Cancel button to return to the current page without changing the spacing of the 
highlighted characters.

See also
Changing the Space Between Letters (Kerning)
Indents and Spacing Command (Format Menu)
Changing the Space Between Lines of Text (Leading) and Paragraphs



 Indents and Spacing Command (Format Menu)
The Indents and Spacing command provides options for specifying paragraph indents and alignment, 
and the spacing between lines and paragraphs.

Indents and Spacing dialog box options

Indents
In the Left Indent box, type a measurement for the amount of space you want to indent 

paragraphs from the left margin of the text frame.    All the text in the highlighted paragraphs, except for 
the first line, will appear to the right of this location.    You cannot type a negative measurement.

In the First Line Indent box, type a measurement for the amount of space you want to indent the 
first line of the paragraph from the left indent.    A positive measurement indicates how far the first line of 
text will be to the right of the rest of the text in the paragraph.    A negative measurement will produce a 
hanging indent.

In the Right Indent box, type a measurement for the amount of space you want to indent 
paragraphs from the right margin of the text frame.    All text in the highlighted paragraphs will appear to 
the left of this location.

Line Spacing
In the Space Between Lines box, type the number of spaces you want between each line of text. 

For example, type 2 if you want double-spaced lines.    You can type any number between .33 and 124 
spaces.

In the Space Before Paragraphs box, type the number of lines you want to add before each 
paragraph.

In Space After Paragraphs box, type the number of lines you want to add after each paragraph.

Alignment
Choose Left to align a paragraph at the left indent or margin.
Choose Center to center a paragraph between indents or margins.
Choose Right to align a paragraph at the right indent or margin.
Choose Justified to spread out words so that they fill the line evenly from the left indent or 

margin to the right indent or margin.

OK
Choose the OK button to add the indents, spacing, and alignment you've chosen to the highlighted 
paragraphs.

Cancel
Choose the Cancel button to return to the current page without adding new indents, spacing, or 
alignment to the highlighted paragraphs.

Tip
You can quickly add spacing and align highlighted paragraphs using the following keyboard 

shortcuts.    For example, to single-space lines, hold down CTRL and press 1.

Press When you want to 

CTRL+E Center the paragraphs

CTRL+J Align the paragraphs evenly between the right and left margins

CTRL+L Align paragraphs at the left margin

CTRL+R Align paragraphs at the right margin

CTRL+1 Single-space lines

CTRL+2 Double-space lines

CTRL+5 Space lines 1 1/2 lines apart

CTRL+0 (ZERO) Remove the space just before the paragraph



CTRL+Q Return paragraph to standard format (left alignment, no indents, no space before or 
after paragraphs, default tabs, single spacing)

See also
Indenting Your Text
Aligning Text in Text Frames
Changing the Space Between Lines of Text (Leading) and Paragraphs
Creating a Numbered or Bulleted List
Creating Tables



 Tabs Command (Format Menu)
The Tabs command provides options for setting, clearing, and aligning tab stops for highlighted text.

Tabs dialog box options

Tab Positions
Type a measurement for the distance you want the tab stop to be from the left edge of the text 
frame.

Alignment
This option decides how the text aligns with the tab stop.

Choose Left to align the left edge of the text with the tab stop.
Choose Center to center the text at the tab stop.
Choose Right to align the right edge of the text with the tab stop.    When the tab's space is filled, 

the text moves to the right.
Choose Decimal to align the decimal point of numbers with the tab stop.    Text without a decimal 

point aligns as for a left-aligned tab stop.

Leader
This option provides choices for characters that you can use to fill the space between the place 
where you press the TAB key and where the tab stops.

Choose None for empty space.
Choose Dot to have dots fill the tab space.
Choose Dash to have dashes fill the tab space.
Choose Line to have lines fill the tab space.

Set
Choose the Set button each time you type or choose a tab measurement in the Tab Positions box or 
choose an Alignment or Leader.
This button is unavailable if there is no measurement in the Tab Positions box.

Delete
Choose the Delete button to remove the chosen tab measurement in the Tab Positions box.
This button is unavailable if there is no measurement in the Tab Positions box.

Delete All Tabs
Choose the Delete All Tabs button to remove all of the tabs you've set.

OK
Choose the OK button to set the tab stops you've specified.

Cancel
Choose the Cancel button to return to the current page without making any changes to the tab 
stops.

See also
Inserting or Removing a Tab Stop
Changing the Alignment or Leader for a Tab Stop
Creating a Numbered or Bulleted List
Creating Tables



 Scale Picture Command (Format Menu)
The Scale Picture command displays the percentage of the height and width of the selected picture 
relative to its original size.    By changing these percentages, you can shrink or enlarge the picture by a 
precise proportion.    This command is only available if you've selected a picture.

Scale Picture dialog box

Scale Height
Type the percentage by which you want to increase or decrease the height of the selected picture.

Scale Width
Type the percentage by which you want to increase or decrease the width of the selected picture.

Original Size
Choose the Original Size check box to return the picture to the size it was when originally created.
An X in the check box indicates the option is chosen.    The Scale Height and Scale Width boxes 
change to 100 percent and become unavailable.

OK
Choose the OK button to shrink or enlarge the selected picture.

Cancel
Choose the OK button to return to the current page without making any changes.

See also
Shrinking or Enlarging a Picture
Cropping a Picture
Crop Picture Command (Format Menu)
Restoring a Picture's Size or Proportions



 Crop Picture Command (Format Menu)
The Crop Picture command lets you trim or conceal parts of a selected picture.    When you choose this 
command, a check mark appears next to the command on the menu, and the first button on the Toolbar 
is automatically chosen.    Now you can crop the selected picture.

To crop a picture
1 From the Format menu, choose Crop Picture.
2 Position the mouse pointer over any of the eight frame handles until you see it change shape into 

the Cropper.
3 Drag the Cropper toward the middle of the picture frame until the picture is the size you want.

Drag the Cropper out again if you want to see more of the picture.
4 From the Layout menu, choose Crop Picture again to turn off the command.

See also
Cropping a Picture
Shrinking or Enlarging a Picture
Scale Picture Command (Format Menu)
Restoring a Picture's Size or Proportion



 Check Spelling Command (Options Menu)
The Check Spelling command lets you check a story for errors like misspellings and incorrect 
capitalizations.    You can also add words to Publisher's dictionary. 

Check Spelling dialog box options

Not in Dictionary
Displays a word that Publisher does not recognize.

Change To
Type a correction if the Suggestions list does not contain an appropriate suggestion.

Suggestions
Choose a word from the list of suggested corrections.

Skip ALL CAPITAL Words
Choose the Skip ALL CAPITAL Words check box to have Publisher ignore words in all capital letters.
An X in the check box indicates the option is chosen.

Check All Stories
Choose the Check All Stories check box to have Publisher automatically check all stories in your 
publication, beginning with the one currently selected.
An X in the check box indicates the option is chosen.

Ignore
Choose the Ignore button to leave the word unchanged.

Ignore All
Choose the Ignore All button to leave all occurrences of the word in the current story unchanged.
If you've chosen the Check All Stories check box, Publisher leaves all occurrences of the word in all 
stories unchanged.

Change
Choose the Change button to insert the correction from the Change To box in the text.

Change All
Choose the Change All button to insert the correction from the Change To box in the text for each 
occurrence of the misspelled word.

Add
Choose the Add button to leave the word unchanged and add it to the dictionary.

Close
Choose the Close button to return to the current story.

See also
Checking Text for Spelling Errors



 Hyphenate Command (Options Menu)
The Hyphenate command hyphenates highlighted text or a story automatically, providing options for 
setting the line length of text in a text frame.

Hyphenate dialog box options

Hyphenate At
Displays each word that Publisher hyphenates if Confirm is turned on.

Hyphenation Zone
Type a measurement for the area at the end of a line where you want words to be hyphenated.
For a more even right edge to your text or for fewer white gaps in justified text, type a smaller 
measurement in the Hyphenation Zone box.    For fewer hyphens, or if you dislike short single 
syllables at the end or beginning of lines, type a larger measurement in the Hyphenation Zone box.

Check All Stories
Choose the Check All Stories check box to have Publisher automatically hyphenate all stories in 
your publication, beginning with the one currently selected.

Confirm
Choose the Confirm check box to see each word that Publisher wants to hyphenate in the 
Hyphenate at box before Publisher hyphenates it.
An X in the check box indicates the option is chosen.

OK
If Confirm is turned on, choosing the OK button causes the OK button to be replaced by the Yes and 
No buttons, and the first word to be hyphenated appears in the Hyphenate At box.
If Confirm is turned off, choosing the OK button closes the dialog box and starts automatic 
hyphenation.

Yes
Choose the Yes button to hyphenate the displayed word.

No
Choose the No button to skip the current word without hyphenating it and display the next word for 
hyphenation.

Cancel
Choose the Cancel button to stop hyphenation. 
This does not remove hyphens already inserted.

Tip
To quickly hyphenate highlighted text or a story automatically, hold down CTRL and press H.

See also
Hyphenating Words



 Snap to Ruler Marks Command (Options Menu)
The Snap to Ruler Marks command lets you align objects you are creating, moving, or positioning, 
precisely with the marks on the rulers.    When you choose this command, as you move an object, the 
edge of the object will "snap to" the tick mark on the ruler.    A check mark next to the command on the 
menu indicates this command is on turned on.    Choose the Snap to Ruler Marks command again to turn 
it off.

See also
Aligning Objects on the Page with Snap To
Snap to Guides Command (Options Menu)



 Snap to Guides Command (Options Menu)
The Snap to Guides command lets you align objects you are creating, moving, or positioning, precisely 
with the layout guides.    When you choose this command, you can move an object close to a guide, and 
the edge of the object will "snap to" the guide.    A check mark next to the command on the menu 
indicates this command is on turned on.    Choose the Snap to Guides command again to turn it off.

Tip
To quickly snap objects to guides, hold down CTRL and press W.

See also
Aligning Objects on the Page with Snap To
Snap to Ruler Marks Command (Options Menu)



 Hide Pictures Command (Options Menu)
The Hide Pictures command hides all pictures in a publication.    When you choose this command, each 
picture is replaced by an opaque rectangle the size of the picture frame that contains the picture, and 
Show Pictures replaces Hide Pictures on the Options menu.    Choose Show Pictures to display the 
pictures.

Note
When you print a publication using the Hide Pictures command, neither the pictures nor the 

rectangles hiding the pictures are printed.

Tip
Choosing Hide Pictures speeds up any action that requires Publisher to redraw what you see on 

the screen, for example changing views,    You can also choose Hide Pictures to speed up printing when 
you want a rough draft of your publication.



 Hide Rulers Command (Options Menu)
The Hide Rulers command hides the rulers that are located at the top and left sides of the workspace.    
You can use this command to enlarge the workspace of a publication.    When you choose this 
command, the rulers "disappear" and Show Rulers replaces Hide Rulers on the Options Menu.    Choose 
Show Rulers to display the rulers.

Tip
To quickly hide or show the rulers, hold down CTRL and press K.

See also
Hiding the Rulers
Using the Rulers
Moving a Ruler or Its Zero Point (Origin)



 Hide Status Line Command (Options Menu)
The Hide Status Line command hides the bar extending across the bottom of the window which displays 
informative messages such as what a command you've selected will do.    You can choose this command 
to enlarge the workspace for a publication.    When you choose this command, the status line 
"disappears," and Show Status Line replaces Hide Status Line on the Options menu.    Choose Show 
Status Line to display the status line.



 Hide Layout Guides Command (Options Menu)
The Hide Layout Guides command hides the guides you can use to position objects in a publication.    
When you choose this command, the layout guides "disappear" and Show Layout Guides appears on 
the Options menu.    Choose Show Layout Guides to display the layout guides.

Tip
To quickly hide or show the layout guides, hold down CTRL and press G.

See also
Setting and Changing Layout Guides
Layout Guides Command (Layout Menu)



 Hide Object Boundaries (Options Menu)
The Hide Object Boundaries command hides the edges of frames which are visible only on your screen. 
This command gives you an idea of what a publication will look like when it is printed.    When you 
choose this command, the edges of frames "disappear" and Show Object Boundaries replaces Hide 
Object Boundaries on the Options menu.    Choose Show Object Boundaries to display the edges.

See also
Previewing Your Publication



 Settings Command (Options Menu)
The Settings command provides options that are set and remembered for a specific publication.    These 
options are 1) the page number you want to begin with, 2) the unit of measurement to be used 
throughout a publication, 3) the shapes that the mouse pointer changes into, and 4) Typing Replaces 
Selection.    The unit of measurement you choose is used for most measurements in your publication, 
such as margins and paragraph indents, and determines how Publisher displays the rulers.

Settings dialog box options

Starting Page Number
Type the page number that you want to begin your publication with.

Measurements
Choose a unit of measurement from the list.
To see the available units of measurement, click the arrow to the right of the Measurements box.
For any specific dialog box entry, you can use a unit of measure that's different from the one you've 
chosen for your publication; simply type the number and the new unit (in for inches, cm for 
centimeters, pt for points and pi for picas).    Publisher converts the entry to an equivalent 
measurement in the system you've chosen for the publication.

Typing Replaces Selection
Choose the Typing Replaces Selection check box to replace highlighted text with new text you type. 
Publisher continues to do this in every publication you create until you turn off Typing Replaces 
Selection.
An X in the check box indicates the option is chosen.

Helpful Pointers
Choose the Helpful Pointers check box to have Publisher use descriptive pointers when the mouse 
pointer changes shape to crop, move, or resize objects.
An X in the check box indicates the option is chosen.

OK
Choose the OK button to use the selected options.

Cancel 
Choose the Cancel button to return to the current page using the options previously selected.

See also
Setting the Unit of Measure
Removing and Retyping Text



 Index Command (Help Menu)
The Index command displays a list of the information contained in Help.

Options

Step-By-Step Help
Step-by-Step Help topics reflect the order in which you'll create a publication from start to finish, and 
the kinds of things you need to think about as you go.    Each topic contains an explanation of a 
Publisher feature related to the task at hand, and then a detailed numbered procedure you can 
follow to complete your task.    If you're new to desktop publishing, start at the beginning and learn 
as you go.    Click the name of the topic to see a list of related topics.

Reference
The Reference section is divided into three sections.    Click one of the section names to get the 
following information:

How to Use Help provides a list of Help topics containing information on the best ways to get 
help on a publication.    Click the name of the topic you want to see.

Menu Commands provides a list of Publisher menus arranged in the order they appear on the 
menu bar.    Click the name of a menu to learn about each command on that menu.

Keyboard Shortcuts provides a list of topics that tells you how to quickly initiate Publisher 
commands and actions using the keyboard.    Click the name of the topic you want to see.

If you're familiar with other desktop publishing applications, or have already begun to learn the 
basic skills of working with Publisher, the Reference section can provide you with quick information while 
you work.    For example, if you choose Menu Commands and then choose The Edit Menu, you can learn 
what the Undo command does.



 Keyboard Shortcuts Command (Help Menu)
The Keyboard Shortcuts command provides a list of topics that tells you how to initiate Publisher 
commands and actions quickly using the keyboard.



 How To Use Help Command (Help Menu)
The How To Use Help command provides instructions for using Help.



 Introduction to Publisher Command (Help Menu)
The Introduction to Publisher command displays a short demonstration illustrating basic Publisher 
concepts you need to know before starting a publication.



 About Microsoft Publisher Command (Help Menu)
The About Microsoft Publisher command displays the product version number and copyright notice.



 How to Use Help
Click one of the topics below to see related information.    Scroll down to see all the topics in the list.

Asking for Help
What Is Help?
How Is Help Organized?
How Do I Get Help? 
Help Buttons
Help Menus

Finding the Information You Want
Choosing a Help Topic
Browsing Help Topics
Backtracking Through Help Topics
Searching for Information Using Keywords
Getting Definitions from Dotted Underlined Words
Getting Information Related to a Topic

Viewing the Information You Want
Seeing All of the Information in a Help Topic (Scrolling)
Resizing the Help Window

Working With Help and Your Application
Looking at Your Publication and Help Together on the Screen
Opening a Help File from Another Application

Customizing Help
Adding Notes to a Help Topic (Annotating)
Marking a Topic You Want to Use Often

Printing and Exiting Help
Printing a Help Topic
Minimizing (Shrinking) or Closing the Help Window



 What Is Help?
Help provides a quick way for you to get the information you need without ever opening a book or taking 
your eyes off the screen.    When you use Help, your publication remains visible and unchanged on the 
screen until you decide you want to continue working on it.

You can access Help at any time by pressing the F1 key or by choosing Index from the Help menu.    A 
Help button is also available within each dialog box, so you can get Help specific to the task at hand 
without having to look it up in the Index.    For a detailed overview of how to access Help, see the How 
Do I Get Help? topic referenced below.

See also
How Do I Get Help? 
How Is Help Organized?



 How Is Help Organized?
Publisher Help is divided into two sections:

 Step-by-Step Help
The topics contained    in Step-by-Step Help follow a recommended order for the steps you'll take to 
create a publication from start to finish.    Click a category under Step-by-Step Help to see a list of 
related topics.    Each topic contains an explanation of a Publisher feature related to the topic title, 
and then a detailed, numbered procedure you can follow to complete your task.    If you're new to 
desktop publishing, start at the beginning and learn as you go.
 Reference
The Reference section is divided into three sections:

How to Use Help provides a list of Help topics which describe how to get Help effectively and 
efficiently while working in Publisher.

Menu Commands provides a list of Publisher menus arranged in the order they appear on the 
menu bar.    Click any of the menu titles to learn about their associated commands and dialog boxes.

Keyboard Shortcuts provides a list of topics that tells you how to quickly initiate Publisher 
commands and actions using the keyboard.

Note
If you're familiar with other desktop publishing applications or have already begun to learn the 

basic skills of working with Publisher, the Reference section can provide you with quick information while 
you work.    For example, if you choose Menu Commands and then choose The Edit Menu, you can 
quickly scan all the commands on that menu and what they do.



 How Do I Get Help?
There are three ways to get Help in Publisher.    Use whichever one best suits your needs.

 Index
From the Help menu, choose Index to explore the range of topics available to you in Help.

 Help Button
Click the Help Button located in each dialog box to get specific information about the choices 

available in that dialog box.
 F1

You can press F1 at any time to get Help on the active feature.    For example, if you choose the 
Text Frame tool and press F1, Publisher shows you Help on how to use the Text Frame tool.



 Help Buttons
Help has five buttons across the top of the Help window that make it easy to explore and get the Help 
information you want.    For example, if you've read three Help topics in a row and decide you want to 
read the first one again, press the Back button twice to see the first topic.    If a button is not available, 
the button name and icon appear dimmed.

Choose To display

Index The Help Index for Publisher.

Back The last topic you read.    Help moves back one topic at a time in the reverse 
order you read each topic, until you return to the Help Index.

Browse<< The previous topic in a series of related topics.    When you reach the first topic 
in the series, the button is dimmed.

Browse>> The next topic in a series of related topics.,    When you reach the last topic in 
the series, the button is dimmed.

Search A list of topic-related words, called keywords, that you can use to locate 
information of interest to you.    Just type a word or select a keyword from the 
list.    If the word you type is not a keyword, scroll through the list to find a word 
that is similar to the one you want to search for.

 To choose a Help button
Position the mouse pointer on the Help button and click the mouse button.

See also
Browsing Help Topics
Backtracking Through Help Topics
Searching for Information Using Keywords



 Help Menus
Below is a short summary of the menus found in the Help window and their associated commands.

The File Menu
Choose To

Open Open an existing Help file.

You can use this command to open the Help file for any application you're 
running in Windows, not just the Help file for Publisher.

Print Topic Print the topic currently displayed in the Help window.

Print Setup Choose a printer or setup your currently selected printer to print Help topics 
the way you want. 

Exit Exit Help. 

When closing, Help saves any annotations or bookmarks you've created.

Note
For more information on opening Help files and printing Help topics, see the topics referenced 

below.

The Edit Menu
Choose To

Copy Copy the text of the current Help topic to the Clipboard.    From the Clipboard, 
you can paste the text into another application or document.

Annotate Add your own notes or comments to the current topic.

After you add your notes or comments and choose the OK button, a green 
paper clip icon appears in the top left corner of the topic.    To see your note or 
comments, position the mouse pointer on the paper clip and click.    For more 
information, see the Adding Notes to a Help Topic (Annotating) topic 
referenced below.

Tip
To quickly copy a Help topic onto the Clipboard, hold down CTRL and press INS.

The Bookmark Menu
Choose To

Define Mark the current topic so you can find the topic quickly.    You can also use this 
command to remove a bookmark from a topic. 

Publisher displays the name of the topic or the name you've chosen for the 
bookmark the next time you choose Define.    Choose the bookmark name to 
see the topic.    For more information on bookmarks, see the Marking a Topic 
You Want to Use Often topic referenced below.

The Help Menu
Choose To

Using Help F1 Display the Help Index for the Using Help topics.

About Display information about Publisher, including the program name, version 
number, and copyright notice.

See also
Opening a Help File from Another Application
Printing a Help Topic
Adding Notes to a Help Topic (Annotating)



Marking a Topic You Want to Use Often



 Choosing a Help Topic
When you need help creating your publication, choose Index from Publisher's Help menu.    The Help 
Index contains two sections, Step-by-Step Help and Reference.    Use the categories listed under Step-
by-Step Help when you want to see a list of topics that include information on how to create a publication 
from start to finish.    Use the categories listed under Reference when you want information on Publisher 
menus and commands, keyboard shortcuts. or the best ways to get Help.

 To choose a Help topic
1 From the Help menu, choose Index.
2 Under Step-by-Step Help or Reference, click on a category to see a list of related topics.

See also
How Is Help Organized?



 Browsing Help Topics
Publisher's Help topics have been organized into categories to aid you in finding information quickly.    At 
times, you may want to read all the topics in a particular category before beginning a task.    For 
example, you might read all the Adding and Changing Text topics before adding text to your publication. 
You can browse a group of related topics without returning to the index by choosing one of the Browse 
buttons at the top of the Help window.

 To read the next topic in a category
Choose the Browse >> button at the top of the Help window.

 To read the previous topic in a category
Choose the Browse << button at the top of the Help window.

Notes
When you reach the last topic in a category, the Browse>> button is dimmed.
When you reach the first topic in a category, the Browse<< button is dimmed.

Tip
To go back to where you started, press the Back button until you reach the topic you want.

See also
Backtracking Through Help Topics



 Backtracking Through Help Topics
You can backtrack through Help topics you've read with the Back button.    Each time you choose the 
Back button, the Help window displays the Help topic you read previously up to the first topic displayed 
when the Help window was opened.    When you reach the first topic, the Back button is dimmed.    The 
record of which topics you read is erased each time you shrink or close the Help window.

 To backtrack through Help topics 
Choose the Back button at the top of the Help window.

See also
Browsing Help Topics



 Searching for Information Using Keywords
As an alternative to looking through a list of Help topics to find the information you need, you can have 
Help search for topics associated with a keyword or phrase.    For example, if you want Help on printing 
your publication, you can type printing and Help will display all the topics associated with the keyword 
"printing".    Then you can choose the topic you want to view.

 To search for a topic
1 Choose the Search button at the top of the Help window.
2 In the Search For box, type the word or phrase you want to find.

You can also scroll through the list of keywords directly underneath the Search For box to find the 
word or phrase you want.

3 Choose the Search button.
4 From the Topics Found list, choose the topic you want to view.
5 Choose the Go To button to go to the topic you've chosen.

Tip
If you aren't sure exactly what you want to look for or how to spell it, you can type a portion of a 

word or phrase, and the Search For list box will show you possible keyword matches as you type.    For 
example, if you type pr in the Search For box, a maximum of 6 keywords or phrases beginning with the 
letters "pr" will appear in the list box.    Choose a word or phrase that is similar to the one you're looking 
for.    Scroll down to see all the words or phrases in the list . 



 Getting Definitions from Dotted Underlined Words
Within Help topics, you'll often see words and phrases with a dotted underline.    If you have a color 
monitor, these words or phrases will be green.    When you click these words, they provide you with a 
quick definition and an illustration where appropriate.    For example, if you click the words "Text Frame 
tool," a small window will appear that contains a brief definition of the words and a small picture of the 
Text Frame tool button.

 To get a definition
1 Position the mouse pointer on the word or phrase with a dotted underline.

When the mouse pointer changes to a hand, click and hold the mouse button to get the definition.
2 Release the mouse button when you're done reading the definition.

See also
Getting Information Related to a Topic



 Getting Information Related to a Topic
Underlined topic titles appear at the end of a Help topic under the heading "See also."    If you have a 
color monitor, these titles are green.    You can use these underlined titles to jump quickly to topics that 
contain information related to the topic you've just read.

 To go to a related topic
1 Scroll down to the end of the topic.
2 Under See also, click the name of the topic you want to read.

Tip
To go back to the previous topic, choose the Back button at the top of the Help window.

See also
Getting Definitions from Dotted Underlined Words



 Seeing All of the Information in a Help Topic (Scrolling)
Sometimes you need to move a window's contents horizontally or vertically to see all the information it 
contains.    This is called scrolling    You can use the scroll bars-- the bars with arrows located on the right 
and bottom edges of the window--to scroll through a topic in the Help window.

 To scroll through information in a Help topic
1  In the scroll bar at the right edge of the window, click the scroll arrow that points in the direction you 

want to go.
For example, in the bottom right corner of the window, click the arrow pointing down to see the next 
line of text.

2 If you want to scroll more than one line of text, hold down the mouse button.
As you scroll, notice that the gray box moves up or down in the scroll bars to show your position in 
the current Help topic.

3 Release the mouse button to stop scrolling.
 To scroll quickly

1 Position the mouse pointer on the gray box located in the scroll bar at the right edge of the window.
2 Drag the gray box in the direction you want to scroll.

The position of the box in the scroll bar tells you where you are in the topic.    For example, when the 
box is halfway down the scroll bar, you will be halfway through the topic when you release the 
mouse button.

3 Release the mouse button to stop scrolling.

See also
Resizing the Help Window



 Resizing the Help Window
You can resize the Help window to make reading a topic easier.    For example, you might want to widen 
the window to see all of the information in a table.    You resize a Help window just like you would any 
other window.

 To resize the Help window
1 Position the mouse pointer on a border or corner of the Help window until you see a two-headed 

arrow.
2 Drag the border or corner in or out to shrink or enlarge the window.

As you drag, a gray line moves to show you the size the window will be when you release the 
mouse button.    If you drag a border, the window size changes only on the side of the border you 
drag.    If you drag a corner, the two adjoining sides move at the same time.

3 Release the mouse button when the window is the size you want.
To cancel the resizing, press ESC anytime before you release the mouse button.
 To quickly enlarge the Help window

Click the Maximize button in the top-right corner of the Help window.    The Help window will fill 
the screen.

See also
Seeing All of the Information in a Help Topic (Scrolling)



 Looking at Your Publication and Help Together on the Screen
If you resize and arrange both Help and the publication window you're working on, you can work on your 
publication and read a Help topic at the same time.

 To resize the publication window
1 From the Control menu of the publication window, choose Restore.
2 Position the mouse pointer on a border or corner of the window until you see a two-headed arrow.
3 Drag the corner or border of the window in until you can see only the part of the publication you are 

working on.
As you drag, a gray line moves to show you the size the window will be when you release the 
mouse button.    If you drag a border, the window size changes only on the side of the border you 
drag.    If you drag a corner, the two adjoining sides move at the same time.

4 Release the mouse button when the window is about half the size of your screen.
To cancel the resizing, press ESC anytime before you release the mouse button.
 To resize the Help window

1 Select the Help window.
2 Position the mouse pointer on a border or corner of the window until you see a two-headed arrow.
3 Drag the corner or border of the window in until you can see only the part you want to read.

As you drag, a gray line moves to show you the size the window will be when you release the 
mouse button.    If you drag a border, the window size changes only on the side of the border you 
drag.    If you drag a corner, the two adjoining sides move at the same time.

4 Release the mouse button when the window is the size you want.
To cancel the resizing, press ESC anytime before you release the mouse button.
 To arrange the Help and publication windows

1 Select the Help window.
2 Position the mouse pointer on the title bar of the window.
3 Drag the window to one side of the screen.

As you drag, an outline of the window moves to show you where the window will be when you 
release the mouse button.

4 Release the mouse button when the window is positioned where you want.
To cancel the move, press ESC anytime before you release the mouse button.

5 Select the publication window.
6 Follow steps 2-4 of this procedure to position the publication window next to the Help window.

See also
Resizing the Help Window
Seeing All of the Information in a Help Topic (Scrolling)



 Opening a Help File from Another Application
You can open the Help file for any application that uses Windows Help.    You don't have to be using the 
application whose Help you want to read.    For example, if you've inserted a chart from Microsoft Excel 
for Windows into a Publisher publication, you can open the Excel Help file at any time to get information 
about Excel's advanced charts.

 To open a Help file
1 From the File menu in Publisher's Help window, choose Open.
2 Double-click the directory where the other application is located.

For example, if you want to use the Help file for Excel, choose the Excel directory.
3 Choose the Help file you want to read from the list box.
4 Choose the Open button.

 To return to Publisher's Help file
1 From the File menu in the Help window, choose Open.
2 Double-click the Publisher directory.
3 Choose MSPUB.HLP from the Files list box.
4 Choose the Open button.

Note
Only files with .HLP extensions can be opened in the Help window.



 Adding Notes to a Help Topic (Annotating)
You can add your own notes or comments to a Help topic in the form of annotations.    For example, if 
you want to add your own tips to Help topics you used to make a brochure, you can make an annotation 
to each of the topics.    Help will place a paper clip icon to the left of each topic title you annotate to 
remind you that a note is attached to that topic.

 To add an annotation to the current Help topic
1 From the Edit menu in the Help window, choose Annotate.
2 In the Annotation box, type your note or comment.
3 Choose the OK button.

A paper clip icon will appear to the left of the topic title.
 To read an annotation

1 Go to the topic where you made the annotation.
2 Position the mouse pointer on the paper icon and click.
3 Choose the OK button when you have finished reading the annotation.

 To remove an annotation
1 Go to the topic where you made the annotation.
2 Position the mouse pointer on the paper clip icon and click.
3 Choose the Delete button.

Note
You can add text to an annotation at any time.    Just open the annotation you want to add text to 

and type the additional text into the Annotation box.    Choose the OK button when you're done.



 Marking a Topic You Want to Use Often
Just as you can place bookmarks in a book to mark specific references, you can place bookmarks to 
mark Help topics you use frequently.    Help puts the titles of those topics in a special list you can read by 
choosing the Bookmark menu.

 To place a bookmark at the current topic
1 From the Bookmark menu in the Help window, choose Define.
2 If the name you want for the bookmark is the name you see in the Bookmark Name box, choose the 

OK button.
--Or--
In the Bookmark Name box, type a name for the bookmark and then choose the OK button.
 To go to a marked topic

From the Bookmark menu in the Help window, choose the name of the bookmark you want to go 
to.

 To remove a bookmark
1 From the Bookmark menu in Help, choose Define.
2 Click the topic or bookmark name you want to remove.
3 Choose the Delete button.

Note
Help can't display more than nine bookmarks at once under Define.    If you have more than nine 

bookmarks, choose More from the Bookmark menu to see a list of all the bookmarks.    Then choose a 
bookmark from the list box, and choose the OK button.



 Printing a Help Topic
If you use a Help topic often, you may want to print it.    Then you can easily refer to it while you're 
creating your publication.

 To print the current topic
From the File menu in Help, choose Print Topic.



 Minimizing (Shrinking) or Closing the Help Window
If you've finished using Help for the moment,    but may want to use it again soon, minimize the Help 
window. When you minimize Help, the window closes and a question mark icon appears on the desktop. 
When you double-click the icon, Help reappears, showing the last topic you viewed.

 To minimize Help
Click the Minimize button in the upper-right corner of the Help window.

 To close Help
Double-click the Control menu box.

Note
When you close Help and then reopen it, the window will be the same size and in the same 

location as it was when you closed it.

Tip
To quickly close the Help window, hold down ALT and press F4.



 Keyboard Shortcuts
Click one of the categories below to learn how to quickly carry out Publisher commands and actions 
using the keyboard.    Scroll down to the see all the categories in the list.

Using Microsoft Windows and Publisher Menus and Commands
Working in Windows
Moving and Making Choices in Dialog Boxes
Choosing Publisher Menus and Commands

Viewing and Editing a Publication
Adding and Viewing Pages
Cutting and Pasting Objects
Modifying Objects
Saving, Printing, and Exiting Publisher

Working with Text
Moving the Insertion Point in Text
Highlighting Text
Adding Breaks and Hyphens
Formatting Characters
Cutting and Pasting Text
Formatting Paragraphs



 Keyboard Shortcuts: Working in Windows
You can use the following key combinations to perform basic Windows functions quickly.    For example, 
to close Publisher or a dialog box, hold down ALT and press F4.

Press When you want to

ALT+SPACEBAR Open the Control menu of Publisher or of a dialog box.

ALT+F4 Close Publisher or a dialog box.

ALT+ESC Switch to the window of another open application.

This works only if you have another application window that's open.

ALT+TAB Switch to another application window.

If the application is minimized, pressing ALT+TAB restores the application to a 
window.

CTRL+ESC Switch to the Task List.

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or message box 
displayed, pressing F1 will display the Publisher Help Index.



 Keyboard Shortcuts: Moving and Making Choices in Dialog Boxes
You can use the following key combinations to quickly move or make choices in a dialog box.    For 
example, to move to an option or group whose underlined letter matches the letter you type, hold down 
ALT and press the letter.

Press When you want to

TAB Move to the next option, text box, or list box 

SHIFT+TAB Move to the previous option, text box, or list box

ALT+letter Move to an option or group whose underlined letter matches the letter you 
typed

HOME Move to the first item or character in a list or text box

END Move to the last item or character in a list or text box

F4 Open or close a drop-down list box

UP or DOWN ARROW Choose an item above or below the one you've chosen in a list box

SPACEBAR Choose or clear a check box

SHIFT+DIRECTION KEY Extend the highlight in a text box character by character

SHIFT+HOME Extend the highlight to the first character in a text box

SHIFT+END Extend the highlight to the last character in a text box

ENTER Close the dialog box and save the choices you made

--Or--

Choose the option from a list box, close the dialog box, and save the choices 
you made

ESC or ALT+F4 Close a dialog box (same as the Cancel button)

Publisher returns to the current page of the publication without making any 
changes.

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 displays the Publisher Help Index.



 Keyboard Shortcuts: Choosing Publisher Menus and Commands
You can use the following key combinations to quickly choose menus and commands.

Press When you want to

ALT or F10 Highlight the menu bar

After you have moved to the menu bar, you can use the following key combinations.

Press When you want to

Letter key Choose the menu or command whose underlined letter matches the letter 
you typed

LEFT or RIGHT ARROW Move among menus

UP or DOWN ARROW Move among commands on a menu

ENTER Choose the highlighted menu or command

ESC Cancel the highlighted command and return to the menu bar

--Or--

Leave the menu bar and return to your publication

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Adding and Viewing Pages
You can use the following key combinations to quickly add new pages and view different parts of a 
publication.    For example, to go to the previous page of a publication, hold down CTRL and press F5.

Press When you want to

F9 Move between your current page view and Actual Size view

PGUP In Actual Size view, move up within a page

PGDN In Actual Size view, move down within a page

F5 Go to the next page

CTRL+F5 Go to the previous page

CTRL+G Hide or show the layout guides

CTRL+K Hide or show the rulers

CTRL+M Move between the background and the current page

CTRL+N Add one new blank page after the current page

CTRL+W Turn Snap to Guides on or off

CTRL+Y Hide or show the boundary of all frames throughout a publication

F1 Get help on a command you've chosen, an open dialog box, or an error message.

If you haven't chosen anything and there's no dialog box or error message displayed, 
pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Cutting and Pasting Objects
Select the object you want to cut, copy, paste, or delete.    Then, use the following key combinations to 
quickly complete the action.    For example, to copy a selected picture, hold down CTRL and press C.

Press When you want to

CTRL+C or CTRL+INS Copy an object you've selected to the Clipboard

CTRL+X  or SHIFT+DEL Move an object you've selected to the Clipboard

CTRL+V or SHIFT+INS Paste an object from the Clipboard into your publication

Publisher pastes the object in the middle of the page.

DEL Delete an object you've selected (except for text frames)

ALT+BACKSPACE Undo the last action.

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 will display the Publisher Help index.

Note
To delete a selected text frame , from the Edit menu, choose Delete Text Frame.

See also
Cutting and Pasting Text
Delete Text Frame Command (Edit Menu)



 Keyboard Shortcuts: Modifying Objects
You can use the following key combinations to quickly change the appearance or order on the page of    
any selected text, picture, or WordArt frame or drawn object.    For example, to add a shadow to a text 
frame, select the text frame, then hold down CTRL and press D.

Press When you want to

CTRL+D Add a shadow to any object you've selected except a line

CTRL+F Put an object you've selected in front of all other objects on the page

CTRL+Z Put an object you've selected behind all other objects on the page

CTRL+T Make an object you've selected transparent if it is opaque or opaque if it is transparent.

CTRL+Y Hide or show the boundary of all frames throughout a publication

F1 Get help on a command you've chosen, an open dialog box, or an error message.

If you haven't chosen anything and there's no dialog box or error message displayed, 
pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Saving, Printing, and Exiting Publisher
You can use the following key combinations to quickly save and print publications, and to exit Publisher. 
For example, to save changes to a publication, hold down CTRL and press S.

Press When you want to

CTRL+P Print part or all of a publication

CTRL+S Save changes to a publication

ALT+F4 Close Publisher or a dialog box

F1 Get help on a command you've chosen, an open dialog box, or an error message.

If you haven't chosen anything and there's no dialog box or error message displayed, 
pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Moving the Insertion Point in Text
You can use the following key combinations to quickly move the insertion point within text.    For 
example, to move the insertion point to the right one word, hold down CTRL and press the RIGHT ARROW 
key.

Press When you want to move the insertion point

UP ARROW Up one line.    If the insertion point is located in a line directly below an 
overlapping frame, pressing the UP ARROW key moves the insertion point to 
the line directly above the frame.

DOWN ARROW Down one line.    If the insertion point is located in a line directly above an 
overlapping frame, pressing the DOWN ARROW key moves the insertion point 
to the line directly below the frame.

RIGHT ARROW Right one character.    If the insertion points moves past the end of a line, it 
moves to the beginning of the next line.    If the next line is in another, text 
frame, the insertion point moves to that text frame.

LEFT ARROW Left one character.    If the insertion point moves past the beginning of a line, 
it moves to the end of the previous line.    If the previous line is in another text 
frame, the insertion point moves to that text frame.

CTRL+RIGHT ARROW Right one word.    If the insertion point moves past the end of a line, it moves 
to the beginning of the next line.    If the next line is in another text frame, the 
insertion point moves to that text frame.

CTRL+LEFT ARROW Left one word.    If the insertion point moves past the beginning of a line, it 
moves to the end of the previous line.    If the previous line is in another text 
frame, the insertion point moves to that text frame.

HOME To the beginning of a line.    If the insertion point is located in the second half 
of a line of text that is divided by an overlapping frame, pressing HOME moves 
the insertion point to the right edge of the frame.

END To the end of a line.    If the insertion point is located in the first half of a line 
of text that is divided by an overlapping frame, pressing END moves the 
insertion point to the left edge of the frame.

CTRL+UP ARROW To the previous paragraph break.    If the previous paragraph break is in 
another text frame, the insertion point moves to that text frame.

CTRL+DOWN ARROW To the next paragraph break.    If the next paragraph break is in another text 
frame, the insertion point moves to that text frame.

CTRL+HOME In front of the first character in the text frame.

CTRL+END After the last displayed character in the text frame.

CTRL+SHIFT+ENTER From one text frame to the next connected frame.    Text to the right of the 
insertion point will also be moved to the next frame.



 Keyboard Shortcuts: Highlighting Text
You can use the following key combinations to quickly highlight text.    For example, to highlight text from 
the insertion point to the beginning of the line of text where it's located, hold down SHIFT and press HOME.

Press When you want to highlight

F8 or CTRL+A The entire Story

SHIFT+LEFT or RIGHT ARROW One character at a time to the left or right beginning at the insertion 
point

If a character is already highlighted, this cancels the highlight.

SHIFT+DOWN or UP ARROW One line of text up or down beginning at the insertion point

If a line is already highlighted, this cancels the highlight

SHIFT+HOME Text from the insertion point to the beginning of a line

SHIFT+END Text from the insertion point to the end of a line

CTRL+SHIFT+LEFT ARROW The word before the insertion point

CTRL+SHIFT+RIGHT ARROW The word following the insertion point

CTRL+SHIFT+HOME Text from the insertion point to the beginning of the current text frame

CTRL+SHIFT+END Text from the insertion point to the end of the current text frame

CTRL+SHIFT+DOWN ARROW All the text in a paragraph following the insertion point

CTRL+SHIFT+UP ARROW All the text in a paragraph before the insertion point

Press When you want to

F1 Get help on a command you've chosen, an open dialog box, or an 
error message.

If you haven't chosen anything and there's no dialog box or error 
message displayed, pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Adding Breaks and Hyphens
You can use the following key combinations to add breaks and hyphens to text.    For example, to end 
one line of text and begin another one without starting a new paragraph, hold down SHIFT and press 
ENTER.

Press When you want to

ENTER Begin a new paragraph

SHIFT+ENTER End one line and begin another line without starting a new paragraph

CTRL+ENTER End one column of text and begin a new column of text

CTRL+SHIFT+SPACEBAR Add a nonbreaking space

HYPHEN (-) Add a regular hyphen

CTRL+HYPHEN (-) Add an optional hyphen

CTRL+ALT+HYPHEN (-) Add a nonbreaking hyphen

CTRL+H Add hyphens automatically (Hyphenate command)

ALT+BACKSPACE Undo the last action

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Formatting Characters
You can use the following key combinations to change the appearance of highlighted characters.    For 
example, to make highlighted text bold, hold down CTRL and press B.

Press When you want to 

CTRL+SPACEBAR Remove styles and subscript or superscript formatting from highlighted 
text

CTRL+B Make highlighted text bold

CTRL+I Italicize highlighted text

CTRL+U Underline highlighted text

CTRL+EQUAL SIGN (=) Apply or remove subscript formatting

CTRL+SHIFT+PLUS SIGN (+) Apply or remove superscript formatting

F1 Get help on a command you've chosen, an open dialog box, or an 
error message.

If you haven't chosen anything and there's no dialog box or error 
message displayed, pressing F1 will display the Publisher Help index.

Tip
After you've changed the appearance of highlighted text you can use the same keyboard shortcut 

to remove the style or format you chose.    For example, highlight bold text and press CTRL+B to remove 
the bold style.



 Keyboard Shortcuts: Cutting and Pasting Text
You can use the following key combinations to move, copy, paste, or delete highlighted text.    For 
example, to copy highlighted text to the Clipboard, hold down CTRL and press C.

Press When you want to 

CTRL+C or CTRL+INS Place a copy of highlighted text on the Clipboard

CTRL+V or SHIFT+INS Insert text from the Clipboard at the insertion point in your publication

BACKSPACE Delete the character to the left of the insertion point

If you've chosen the Typing Replaces Selection option with the Settings 
command on the Options menu, pressing BACKSPACE deletes highlighted text.

DEL Delete the character to the right of the insertion point

--Or--

Delete all of the highlighted text.

CTRL+X or SHIFT+DEL Move highlighted text out of your publication and onto the Clipboard

ALT+BACKSPACE Undo your last action

F1 Get help on a command you've chosen, an open dialog box, or an error 
message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 will display the Publisher Help index.



 Keyboard Shortcuts: Formatting Paragraphs
You can use the following key combinations to change the alignment, line spacing, or paragraph spacing 
of highlighted paragraphs.    For example, to justify paragraphs you've highlighted, hold down CTRL and 
press J.

Press When you want to 

CTRL+E Center a paragraph

CTRL+J Align a paragraph evenly between the right and left margins

CTRL+L Align a paragraph at the left margin

CTRL+R Align a paragraph at the right margin

CTRL+1 Single-space lines

CTRL+2 Double-space lines

CTRL+5 Space lines 1 1/2 lines apart

CTRL+0 (ZERO) Remove the space just before the paragraph

CTRL+Q Return a paragraph to standard format (left alignment, no indents, no space before 
or after the paragraph, default tabs, single spacing)

F1 Get help on a command you've chosen, an open dialog box, or an error message.

If you haven't chosen anything and there's no dialog box or error message 
displayed, pressing F1 will display the Publisher Help index.



Actual Size
A view that shows a selected part of a publication as it will look when it is printed.    You can choose 
Actual Size view from the Page menu.



annotation
A note or comment you can add to a Help topic by choosing Annotate from the Edit menu in Help. 



application
Software that helps you perform specific tasks.    For example, Publisher is a desktop publishing 
application that helps you create different types of publications.    There are hundreds of different 
applications that help you do everything from creating a spreadsheet to drawing a picture. 



arrow button
Three buttons that appear on the Toolbar when the Line tool or a line is selected.



background
The area in Publisher where you can place text, pictures, and drawn objects that you want to repeat on 
every page.    The Background commands are located at the bottom of the Page menu.



bleed art
A picture or shaded drawn object that runs off the edge of a page.



bitmap
An image, usually a paint-type graphic, that is composed of a series of black and white or colored pixels 
(little squares).



bookmark
You can create bookmarks to mark Help topics you use frequently.    You can jump to a marked topic 
anytime by choosing the topic title from the Bookmark menu in Help.



border
A plain or decorative outline you can add to text, picture, or WordArt frames, or drawn objects.



Box tool
The sixth tool on the Toolbar.    Use this tool to create square-cornered boxes.



bullet
A dot or small square used to designate items in a list.



caption
Text that describes a photograph or illustration.



cartridge
A piece of hardware that is plugged into a printer to supply one or more fonts.



characters
Letters, numbers, spaces, punctuation marks, and various symbols that make up the text of a 
publication.



check box
A box next to an option within a dialog box.    An X appears in the box when the option is chosen.    Click 
the box to add or remove the X.



choose
To use a mouse or key combination to specify an item in Publisher.    For example, you choose a 
command from a menu by clicking the command name.



click
To press and release the mouse button.



ClipArt
A file of ready-made art provided by Publisher.    You can see the file by choosing the Import Picture 
command from the File menu, then choosing the ClipArt directory under Directories.



Clipboard
A temporary, invisible storage area for cut or copied information.    You can paste the contents of the 
clipboard into another Publisher publication or into another Windows application.    The clipboard will hold 
only one item at a time.



column break
Inserted when you want to end one column of text and begin another.



connect
To join two or more text frames together.    When text frames are connected, text that will not fit into one 
text frame will automatically be displayed in the next text frame.



connect button
The gray button in the lower-right corner of a text frame.    This button changes to reflect the frame's 
status. 

The frame is empty, or all the text in the story fits and is currently displayed in the frame.
There is more text in the story than can fit in this frame; the remaining text is stored in the 

overflow area.    Make the frame bigger, or connect another frame to it to see the remaining text.
The frame is connected to another frame and any extra text is displayed in the connected frame.



Control menu
The menu appearing on all Windows and some non-Windows applications that has commands that 
move, change the size of, and close the current window.    Publisher's Control menu is located in the top 
left corner of the publication window.



create a frame
1 From the Toolbar, choose the text, picture, or Word Art frame tool.
2 Position the mouse pointer where you want the upper-left corner of the frame to begin.
3 Hold down the left mouse button, and then drag the mouse diagonally until your frame is the size 

you want.
4 Release the mouse button.



crop
To hide parts of a picture that you don't want displayed.    You can crop a selected picture using the 
cropping button on the right side of the Toolbar or by choosing Crop Picture from the Format menu.



Cropper
The scissors shape that the mouse pointer changes to when you're ready to crop a picture frame.    To 
see the Cropper, you must choose the cropping button on the Toolbar, then position the mouse pointer on 
one of the eight frame handles. 



cropping button
When a picture frame is selected, the first button on the right side of the Toolbar is the cropping button.



dialog box
A window that displays options for you to choose or type that give Publisher information needed to carry 
out a command or action.    A dialog box is your way of "conversing" with Publisher.



directory
The information on your computer's hard disk is organized into different directories for easy access.    
Each directory contains files that are associated by the tasks they perform or the application that created 
them.    Files you create are usually stored in the directory of the application that created them.



disk
A place for permanently storing information such as the files needed to run an application or the files that 
contain your work.    This term, unless specified, can refer to either your computer's internal hard disk or 
to a floppy disk that can be inserted into your computer's a or b drive.



double-click
To press the left mouse button twice, in quick succession.



double-space button
This button is located in the right-hand corner of the Toolbar when a text frame is selected. Click this 
button to change the space between lines of selected text to double-spacing.



drag
You drag the mouse to complete a number of procedures in Publisher.    For example, you drag to move 
an object, to create a frame, or to extend a highlight.

To drag the mouse
1 Position the mouse pointer at the location specified in the procedure.
2 Hold down the appropriate mouse button as you move the mouse diagonally.

You should always hold down the left mouse button unless the right mouse button is specified in the 
procedure.

3 Release the mouse button when you're finished moving the mouse.



drawn object
A line, box, rounded box, or oval created using one of the drawing tools on the Toolbar.



drawing tools
The four tools from the Toolbar used to draw lines, boxes, rounded boxes, and ovals.



drive
Location where the information for operating applications, and the contents of the files you create with 
them, are stored.    Usually, your computer's hard disk is considered drive C. If you have one or two slots 
for inserting floppy disks, the first slot is considered drive A and the second slot is considered drive B.    
This may vary depending on the type of computer you have and the way you have set it up.



dropped
Describes a large initial letter that's dropped below the first line of text in a story.      Usually, the top of the 
initial letter is aligned with the top of the first line of text in the story.



edge
Object borders which can be displayed on the screen but do not print.



facing pages
When you choose a book layout for your publication, Publisher starts you out with two facing pages, like 
the left- and right-hand pages of a finished book.



file extension
A period and three letters added to the end of the name of a file.    File extensions usually indicate what 
the file contains or which application created the file.    For example, a file created in Publisher has the 
extension .PUB.



file format or file type
The way in which the information in a file is arranged and structured.    File formats often determine what 
applications can use a file.    For example, a file created in one word-processing application may have a 
file format that other word-processing applications can't recognize.    More general file formats such as 
plain text and RTF can be read by many different applications.



filter
A filter translates or converts one type of file to another type of file.



floppy disk
A disk made of thin, flexible plastic used for storing files.    You can load a floppy disk into your 
computer's a or b drive.



footer
A line of text at the bottom of each page that can contain such information as a publication's author, title, 
chapter, page number, or date of issue.



font
A family of letters, numbers, punctuation marks, and symbols with a similar shape or design.    Each font 
has one or more sizes (measured in points) to choose from.



Font box
A box on the Toolbar containing a list of the fonts available to you, given the printer you have chosen.      
To see the list, click the arrow to the right of the box.    To choose a font, click the font name you want to 
choose.



format
Formats dictate the way text appears on a page.    In Publisher you can apply formats to characters and 
paragraphs.    Character formats include font, type style (bold, italic, underlined, superscript, and 
subscript), and point size.    Paragraph formats include alignment (left, right, centered, and justified), 
indents, tabs, and line spacing (single-space and double-space).



frame
Primary building block of a Publisher publication.    Text, pictures, and WordArt are all placed in frames 
which can be moved, copied, sized, and formatted. 



frame break
Inserted when you want to move the insertion point from one text frame to the next connected frame.    
Text to the right of the insertion point will also be moved to the next frame.



Full Page
A view that shows the entire page of a publication.    You can choose Full Page view from the Page 
menu.



guides
Vertical and horizontal lines that form a nonprinting grid--a visual reference on your screen that helps 
you lay out your publication.



gutter
Extra space along the inside edge of a page to accommodate binding, such as in a book.    Also refers to 
the space between two columns of text.



handles
Eight square indicators, located at each corner and at the midpoint of each side of a frame or drawn 
object.    Use handles to size and crop frames and to size drawn objects.



hanging indent
When the first line of a paragraph extends to the left of the paragraph.    A hanging indent is controlled by 
the Left Indent and First Line Indent boxes of the Format Indents and Spacing command.



header
A line of text at the top of each page that can contain such information as a publication's author, title, 
chapter, page number, or date of issue.



highlight
You mark text that you want to copy, edit, format, or move by highlighting it. 

1 Position the mouse pointer before the first character of the text that you want to highlight.
2 Hold down the mouse button and move the mouse to extend the highlight.



hyphen
A punctuation mark used to connect the parts of a compound word or between syllables of a word, 
especially when divided at the end of a line.    Publisher provides three kinds of hyphens: regular, 
optional, and nonbreaking.



Hyphenation Zone
An area at the right margin where words are hyphenated.



icon
A graphical representation of one of an application's features.    Publisher uses many icons, for example 
the tools on the Toolbar.    Windows uses icons to represent other applications.



import
To insert a picture or file of text from another application into the publication or document you're working 
on.    You can import a picture or text file by using the Import Picture and Import Text commands on the 
File menu 



insertion point
When a text frame is selected and you've moved the mouse pointer over the text in the frame, the    
mouse pointer changes to an "I-beam" shape.    This is called the insertion point.    If you click in the 
frame where you want to add or change text the insertion point changes to a blinking bar indicating 
where added text will be placed.



justify
To align a paragraph so that each line is flush with the right and left margins or indents.    Spaces are 
enlarged between words to make the text evenly fill the text column.



kern
To adjust the amount of space between adjacent characters in a word to make the word look more 
evenly spaced.    You can kern characters by using the Spacing Between Characters command on the 
Format menu.



keyboard shortcut
A special key or key combination that quickly carries out a command or action.    Press the keyboard 
shortcut to execute the command or action without first choosing a menu or a button on the Toolbar.    
The keyboard shortcut for a command is listed to the right of the command name on the menu.    To see 
a list of keyboard shortcuts organized according to type of command or action, from the Help menu, 
choose Keyboard Shortcuts.



keypad
The keys that are located at the far right side of the keyboard.



leading
The distance from the bottom of one line of text to the bottom of the next line of text.    Leading is 
measured in points.



line break
Inserted when you want to end one line and start another without starting a new paragraph.



line spacing
Amount of space between the bottom of one line to the bottom of the next line, based on the height of 
one line.    The height of a line is determined by the font size you've chosen.



Line tool
The fifth tool on the Toolbar.    Use this tool to create lines.



line-spacing buttons  

When a text frame is selected, Publisher displays two buttons in the right-hand corner of the Toolbar for 
quickly changing the space between selected lines--the single-space button and the double-space button.



list box
Part of a dialog box that contains items for you to choose.    Some list boxes stay the same size; others 
drop down to display the list of items.



margins
The white space that surrounds text or a picture.    Margins can be set within a text or picture frame or 
created by leaving space between objects as you position frames and drawn objects on the page.



maximize
To enlarge a window or icon so that it fills the screen.    You can maximize a window by clicking the 
Maximize button in the upper-right corner of the window, or by choosing Maximize from the Control 
menu.    You can maximize an icon by double-clicking on it.



measurement
A number you type in a dialog box in one of the following units:

Units Equivalent Measurement

centimeters (cm) 1 cm = 0.39 in = 28 pt

inches (in or ") 1 in = 72 pt = 6pi = 2.54 cm

picas (pi) 1 pi = 1/6 in = 12 pt = 0.42 cm

points (pt) 1 pt = 1/72 in = 1/12 pi = 0.035 cm



memory (random access memory, RAM)
The temporary information storage area your computer uses to run applications and perform other 
necessary tasks.    When you turn off the computer, all information in your computer's memory that you 
have not saved to a disk using the Save or Save As command is lost.



menu bar
The horizontal bar at the top of the window containing the names of all of Publisher's menus.



metafile
A file containing a list of instructions that an application can follow for drawing a particular picture.



minimize
To shrink a window or application so that it becomes an icon.    You can minimize an application by 
clicking on the Minimize button in the upper-right corner of the window or by choosing Minimize from the 
Control menu.    To restore in an application that you have minimized, double-click the icon.



mirror
When a book is laid out, facing pages mirror each other.    For example, if page numbers appear in the 
bottom-left corner of the left-hand pages they will appear in the bottom-right corner of the right-hand 
pages.



monitor
The screen of your computer.



mouse pointer
An arrow which moves on the screen as you move the mouse.    Use it to point to items you want to 
select or choose.



Mover
The moving van shape that the mouse pointer changes to when you're ready to move a frame or drawn 
object.    To see the Mover, you must position the mouse pointer on one of the edges of a selected frame 
or drawn object.



network
A connection (by cable) that links computers to each other allowing them to communicate and share 
information.    A network can also connect your computer to a printer.    Often, the location of a file is 
referred to as "on a network."    This means that the file is located on the hard disk of another computer 
connected to the network.



nonbreaking hyphen
Use for words that you do not want split between two lines, such as the phrase "forget-me-not."



 
nonbreaking space
Used in place of a normal space when you want to prevent a line break between two words.



object
Any of the following elements created in Publisher: a text, picture, or Word Art frame; a line, arrow, box, 
rounded box, or oval.



opaque object
Any object--a text, picture, or WordArt frame, a box, a rounded box, or an oval--that hides another object 
or guide beneath it.



option
The choices you can make in a dialog box.    For example, if you choose Print Setup from the File menu, 
you can choose either the Landscape option or the Portrait option for your page orientation.



optional hyphen
Use to hyphenate words that will not fit on one line.    When you use an optional hyphen, the word will not 
remain hyphenated if you make changes to the text and the word no longer appears at the end of a line.



orientation
The orientation you choose for your publication determines the way it's printed on your printer's paper.    
You can choose from two different orientations:    portrait (your publication will be taller than it is wide) or 
landscape (it will be wider than it is tall).



original size
Size of clip art or a picture created in another application before it was brought into a Publisher 
publication.



Oval tool
The eighth tool on the Toolbar.    Use this tool to create ovals.



overflow area
Publisher stores text here that will not fit in the currently selected text frame.      You can't see text stored 
in the overflow area but Publisher changes the symbol on the frame's connect button to indicate that text 
is stored there.



PageWizard
A Publisher feature that helps you create any of the following publications quickly and automatically: a 
greeting card, a newsletter, a calendar, an advertising flyer, or a business form.    You can also use 
PageWizards to create a part of a publication, such as a small calendar, a headline, a banner, a coupon, 
or a fancy first letter.



PageWizard tool
The ninth tool on the Toolbar.    Use this tool to indicate the position and size of an object you want a 
PageWizard to make for you.



page controls
The page controls are located in the lower-left corner of Publisher's window.    You can type in any page 
number and go directly to that page, or use the arrows as shown below.

Click here To

Turn to the first page of your publication.
Turn to the last page of your publication.
Turn back a single page.
Turn forward a single page.
This symbol replaces the page controls when you're on the background.    When you're working 

with facing pages you will see two of these symbols--one for the left-hand background and one for the 
right-hand background.    Click them to move from one background to the other.



pica
A standard unit of measurement used in publishing, equal to 1/6 inch (0.42 centimeters).    Picas are 
used to measure all aspects of a publication, including text, pictures, and layout.



Picture Frame tool
The third tool on the Toolbar.    This tool is used to create frames that contain the pictures in your 
publication.



point
The smallest unit of measurement used in publishing.    Points are most often used to describe letter 
height.    The points used in Publisher are US points, not Didot points.    There are 12 US points in one 
pica, 72 in one inch, and 28 in one centimeter. 



point size or font size
The height of the characters in a font, usually measured in points.    There are 72 points per inch and 28 
points per centimeter.



Point size box
A box on the Toolbar containing a list of point sizes available for the font currently selected in the Font 
box.    To see the list, click the arrow to the right of the box.    To choose a point size, click the size you 
want.



printer driver
A file that provides fonts and printing instructions to the printer.    Windows comes with printer-driver files 
for most of the commonly used printers.



pull quote
A quotation taken from the main text of an article and set in a larger type size or different font or style.



raised
Describes a large initial letter that extends above the first line of text in a story.    This is useful for 
drawing attention to the beginning of a story.



regular hyphen
Use for words that are always hyphenated and can be split at the end of a line, such as "well-rounded."



Resizer
The shape that the mouse pointer changes to when you're ready to resize a frame or drawn object.    To 
see the Resizer, you must select the object you want to resize and position the mouse pointer over one of 
the object's resize handles.



resolution
Sharpness of the on-screen image or fineness of detail in the final printout, expressed in dots per inch.



Rounded Box tool
The seventh tool on the Toolbar.    Use this tool to create rectangles with rounded corners.



scaling
Changing the size of a picture in Publisher.    You do this by changing the size of the picture frame that 
contains it



scratch area
The part of the workspace outside the page area where you can temporarily place objects until you want 
to use them.



scroll
Sometimes you need to move a window's contents horizontally or vertically to see all the information in a 
window.    This is called scrolling.    To scroll, click one of the arrows in the scroll bars at the right and 
bottom of the window.



select
To choose an object by positioning the mouse pointer over the object and clicking with the left mouse 
button.    When an object is selected, square handles appear at each corner and the midpoint of each 
side of the object.



selection box
The dotted outline of a rectangle that appears when you hold down the left mouse button and drag the 
mouse.    As you drag the mouse, the selection box expands.    All objects that are within the selection 
box when you release the mouse button will be selected. 



Selection tool
Used to mark objects and highlight text.    The selection tool is the left-most button on the toolbar.



shading
To fill a drawn object with a pattern.    Publisher offers a number of different patterns for shading.    The 
Shading command is located on the Layout menu.



shadow button
The third button on the right-hand side of the Toolbar when a frame or drawing tool is selected, or when 
a picture frame or drawn object has been drawn on the page.      Click this button to add a shadow to a 
selected object or one you plan to create.



shadow
A reflection that can be added to all objects except lines and arrows.



sidebar
A smaller, self-contained article usually positioned to the side of or inside the main article.



single-space button
This button is located in the right-hand corner of the Toolbar when a text frame is selected.    Click this 
button to change the spacing between lines of selected text to single-spacing.



Snap To
Publisher offers the Snap To option for aligning objects precisely with layout guides and tick marks on 
the rulers.    With Snap to Guides or Snap to Rulers turned on, you can move an object close to a guide 
or ruler and the edge of the object will "snap to" the guide or ruler mark.



story
Refers to all the text contained by a frame or series of connected frames.    A story can be any length--a 
word, a sentence, a paragraph, or many paragraphs.



style
The aspects of a word or character's appearance that can be changed without changing the original font. 
For example, text can have bold, italic, or underlined style. Text can have more than one style at a time.



style buttons  

 

When a text frame is selected, Publisher's Toolbar displays three style buttons for changing the style of 
text quickly.    To change styles quickly, highlight the text you want to change and click the bold, italic, or 
underlined button to add or remove the style.



subscript
Text that appears slightly lower in a line than text around it.



superscript
Text that appears slightly higher in a line than the text around it.



switch
Within Windows, you can switch easily from one open application to another.
To switch from one application to another:

1 In the application you're currently using, click the minimize arrow in the upper-right corner of the 
window.    The minimize arrow is pointing down.

2 In Windows Program Manager, double-click the icon for the application you want to switch to.



tab stop
Measured position for placing and aligning text at a specific place on the page 



tab stop alignment
Publisher automatically lines up the left edge of your text at a tab stop.    However, you can change this 
alignment at any time using the Tabs command on the Format menu.    Publisher gives you four 
alignments to choose from--left, center, right or decimal.



tab stop leader
The symbol or character that fills in the space between where you pressed the tab key and the tab stop 
position. 



tab stop position
A measurement you determine for every tab stop you set.    This measurement is the distance from the 
left edge of the current text frame to the tab stop.



Task list
A Windows feature that allows you to see a list of the applications you have open.    When you hold down 
ctrl and press esc, Windows displays a window with a list of the applications currently running and 
buttons that allow you to easily switch from one application to another.



template
A model publication that contains settings, text, and formats you can save and use later to create other 
publications.



text box
A box within a dialog box where you type information needed to carry out the chosen command.    The 
text box may be blank when the dialog box appears or may contain text that you can change if desired.



Text Frame tool
The second tool on the Toolbar.    This tool is used to create frames that contain the text in your 
publication.



title bar
The horizontal bar at the top of the window above the menu that contains the title of the current 
application or dialog box.    On many windows the title bar also contains that Control menu box in the left 
corner and the Maximize and Minimize buttons in the right corner.



Toolbar
The row of buttons across the top of the Publisher window.    The buttons on the left are used to create 
and manipulate objects.    The buttons on the right appear when a tool is selected or after an object has 
been created, and provide shortcuts for commonly used Publisher commands.



toggle
By choosing the appropriate command or pressing shortcut keys, you can 1) turn on or initiate certain 
commands or actions or 2) switch from one command or action to another.    For example, holding CTRL 
and pressing M toggles between the background and foreground page of a publication.



transparent object
Any object--a text, picture, or WordArt frame, a box, a rounded rectangle, or an oval--that doesn't hide 
objects layered underneath it.



Typing Replaces Selection
A feature that allows you to replace text you've highlighted with new text.    When you choose Typing 
Replaces Selection, any key you press replaces the text you've highlighted.



window
The rectangular area on the screen in which you view an application or dialog box.



Windows Control Panel
Location of Windows settings.    You can customize Windows by changing these settings to suit your 
needs.    For example, you can change the unit of measurement used by every application running in 
Windows, or the window colors if you have a color monitor.    To open the Windows Control Panel, open 
the Main window, then double-click on the Control Panel icon.



WordArt
Special effects for text that you can use to enhance any kind of Publisher publication.    Options include a 
wide variety of fonts and unusual ways to manipulate text, for example, upside down or vertically down 
the page.



workspace
The area in a Publisher window containing the publication page and the scratch area.



WordArt Frame tool
The fourth tool on the Toolbar.    This tool is used to create frames in your publication that contain text with 
special WordArt effects.



zero point
The location of the zero on Publisher's rulers.    Publisher automatically aligns both zero points with the 
left edge of the paper,    but you can move them to help you align objects and set measurements.



 Low Memory
Your computer uses a temporary storage area called Random Access Memory, or RAM, to run most 
applications.    Right now, there isn't enough memory available to continue the task you've been working 
on.    Follow the instructions provided below to free up memory.    Remember that you'll need to exit this 
Help window before you can continue the procedure below.    To exit Help, from the File menu, choose 
Exit.

 To free up memory so that Publisher can continue
1 Choose the OK button to close the message box and return to your publication.
2 From the File menu, choose Save to protect the work you've done so far.
3 Click the Minimize button in the upper-right corner of the Publisher window to shrink Publisher to 

icon while you close other applications.
4 Close any open applications.    For example, if you're running Microsoft Word for Windows, choose 

Exit from Word's File menu.
5 Double-click the Publisher icon to reopen the Publisher window.
6 Try completing the task again.

Note
In some cases, you may not be able to complete a task even after saving your work and closing 

other applications.    In this case, you may try exiting and restarting Windows and Publisher.

See also
A Hint for Freeing Some Space on Your Hard Disk



 Publisher could not find a TMP directory or there's no more room in the TMP directory
Publisher uses a storage area on your hard disk where it temporarily places work files.    The location of 
this storage area is indicated in your AUTOEXEC.BAT file with the line:

set TMP=c:\ <Directory name>
The directory name is the name of the directory that Publisher (and possibly other Windows applications) 
uses to store temporary files as it works.    Check your AUTOEXEC.BAT file to be sure that the line shown 
above appears.    You can open your AUTOEXEC.BAT file in any word-processing program.    If the line does 
not appear, add it to your file and try again.    If the line does appear in your AUTOEXEC.BAT file, try some 
of the following recommendations.

Recommendations
Delete all of the files that are in the TMP directory.    Don't worry, this is just a temporary storage 

area so it's okay to delete the files.
Check the amount of disk space you have left on your hard disk by typing chkdsk at the c:\ 

prompt and then pressing ENTER.
Example: c:\chkdsk 

To free up space on your hard disk, delete some files and try again.    To be sure you don't delete 
any files you might need later, copy the files you want to delete to a backup disk before deleting them.    
For more information on freeing up space on your hard disk, see the A Hint for Freeing Some Space on 
Your Hard disk topic referenced below.

If your TMP directory is empty and your AUTOEXEC.BAT file contains the reference to the TMP 
directory as listed above, check your DOS CONFIG.SYS file.    It can be opened in any word-processing 
program.    There should be a line that looks something like this:

FILES=20
You may have a different number of files depending on how your computer was set up.    Increase 
this number by five and try again.

See also
A Hint for Freeing Some Space on Your Hard Disk



 Running the Setup Program
When you run the Setup program to install Publisher, all the files Publisher needs are automatically 
copied to your hard disk.    You may have accidentally moved or deleted a file that Publisher needs to 
complete a task.    The message box that Publisher is displaying indicates which file Publisher needs.    
When you run the Setup program again, pay special attention to the choices you make and the 
instructions you're given. 

 To run Publisher Setup
1 Close Publisher.
2 Put the Publisher Setup disk in drive A or B and close the drive door.
3 Type the letter of the drive that contains the disk followed by a colon.    For example type a: if the 

disk is in drive A.
4 Press ENTER.
5 Type setup
6 Press ENTER.
7 Follow the instructions on the screen and the instructions displayed in the Publisher message box.

Note
For more information on setting up Publisher, refer to your Microsoft Publisher User's Guide.



 Publisher is already using an instance of this file
With Windows, it's possible to start more than one instance of Publisher.    However, if a file is open in 
one instance of Publisher, you cannot open it in another.    You can either close the second instance of 
Publisher and work in the first where the file is located, or close the file in the first instance of Publisher, 
and then open it in the second.

This is also true with imported text files.    If you import a text file into one instance of Publisher, you 
cannot import the same text file into a second instance while the first is still running.



 This file is Read Only
Files can be locked to prevent others from changing them.    This is what is meant by Read Only.    You 
can read it, but you can't make changes and then save them to the file.    You may be working with a text 
file or an entire publication that has been set as read only.

If you want to make changes to a read-only file, you can use the Save As command to save the file 
under another name.    The renamed version will not be read only, and you can make your changes to 
that version.

If you need to change the status of the Read Only file, check your DOS or Windows manual for 
instructions on how to do this.



 Publisher could not locate the directory containing the Publisher Templates
When you run the Setup program to install Publisher, all the templates that come with Publisher are 
stored in a directory called TEMPLATE.    If there is a file that is also called TEMPLATE in the same location, 
Publisher may not be able to locate the templates you request.    Check to make sure that TEMPLATE does 
not exist as a filename in your MSPUB directory.

If you have accidentally removed the template directory or the files it contained, run the Setup program 
again, and choose Custom Installation to install the templates.    Publisher will copy the directory to your 
hard disk again.

See also
Running the Setup Program



 Publisher's Custom Dictionary is full
There is no more room in Publisher's Custom Dictionary.    You will have to delete some words from it 
before you can add any more.

The custom dictionary file is called CUSTOM.DIC and is a standard text file.    It is located in a subdirectory 
called \MSAPPS\PROOF in your Windows directory.    You can open the file in any word-processing 
application, delete some words to make room for new ones, and then save your changes.



 There may be a hardware or software problem
All tasks require that Publisher use your computer hardware.    If there is a problem with your computer--
the hard disk is full, or a floppy disk is damaged--Publisher may not be able to complete the current task, 
and may be forced to close down.    If this happens, it's a good idea to turn off your computer and start 
again.    The following list suggests some of the most common hardware problems you can run into.

Your hard disk is full or damaged
Hard disk space is required for several different tasks.    Check your hard disk using the DOS 

command chkdsk to verify the amount of disk space you have.    Copy outdated files to a floppy disk 
and then delete them from your hard disk to free up space.    If you're unable to run any DOS 
commands, it's possible your hard disk has been damaged.    See your local dealer for information 
on evaluating and possibly replacing the hard disk.

A floppy disk is full or damaged
You can check the amount of space available on a floppy disk by changing to the drive where the 
floppy is located and typing dir at the DOS prompt.    DOS indicates the number of bytes free.    This is 
the amount of space left on your floppy disk for file storage.    Floppy disks are easily damaged. Try 
using a new floppy disk if you have problems storing files on the current disk.

A Network system is no longer connected or is inaccessible
If you're using files located on a network, it's possible that your computer got disconnected from the 
network, or that the network stopped working during your current work session.    This may interfere 
with Publisher's ability to locate the files it needs to complete tasks.    Close Publisher and check that 
you're still connected to the network and the network is functioning properly.

Another person is working on the file you want to use
If you're running your computer connected to a network, it may be that certain files can only be used 
by one person at a time.    If Publisher is having trouble opening a file, check to be sure it is not 
being used by someone else.



 Publisher can't open the server application
When you add a picture or chart using the Insert Object or Paste Special command, you are actually 
adding it using the application it was created in.    Publisher is now unable to open that application.    It's 
possible that there isn't enough memory available to complete the task.    Follow the instructions 
provided below to free up memory.    Remember that you'll need to exit this Help window before you can 
continue the procedure below.    To exit Help, from the File menu, choose Exit.

 To free up memory so that Publisher can continue
1 Choose the OK button to close the message box and return to your publication.
2 From the File menu, choose Save to protect the work you've done so far.
3 Click the Minimize button in the upper-right corner of the Publisher window to shrink Publisher to an 

icon while you close other applications.
4 Close any open applications.    For example, if you're running Microsoft Word for Windows, choose 

Exit from Word's File menu.
5 Double-click the Publisher icon to reopen the Publisher window.
6 Try adding the picture or chart again.

Note
If you've followed the procedure above and still can't complete the task, you may not have 

properly installed the application you want to use on your hard disk.    Try running the application's setup 
program again.    For more information, refer to the application's user guide.



 Publisher can't find the file your publication is linked to
When you use Publisher's Paste Special command, you make a copy of a picture or chart that is linked 
with the file where the original is stored.    When changes are made to the original, Publisher 
automatically updates the picture or chart in your publication.    Publisher can't find the original file and so 
can't update the copy in your publication.    The following list contains some common explanations and 
possible solutions.

You may have deleted the picture or chart your publication is linked to.
Create a new picture or chart in the appropriate application and then paste it into your publication 
using Publisher's Paste Special command.    For more information, see the Adding a Picture That 
You Want to Use and Update in Several Locations topic referenced below.

You may have deleted the application the picture or chart was created in.
If you've deleted the application the picture or chart was created in.    You will have to reinstall it 
using the application's setup program.    For more information on running the setup program, refer to 
the application's user's guide.

You may have moved the application the picture or chart was created in.
When you use the Paste Special command to link the original chart or picture to your publication, 
Publisher remembers the location of the application.    If you change this location, Publisher can't 
find the application and can't update your chart or picture.    If this is the case, move the application 
back to the original location.    If you can't remember or don't know the original location, you can 
paste a new copy of the chart or picture into your publication to establish a new link.    For more 
information, see the Adding a Picture That You Want to Use and Update in Several Locations topic 
referenced below.

The application the chart or picture was created in may not be installed correctly on your hard 
disk.

If none of the above explanations are correct, the application the chart or picture was created in may 
not have been installed correctly on your hard disk.    Try running the application's setup program 
again.    For more information on running the setup program, refer to the application's user's guide.

See also
Adding a Picture That You Want to Use and Update in Several Locations



 Publisher doesn't recognize the picture you're trying to paste
Pictures are stored in different file formats.    Publisher uses converters to recognize and translate 
different formats into a form it can work with.    If Publisher doesn't recognize a picture you're trying to 
paste, there are two possible explanations: 

One of Publisher's converters is missing
The converter Publisher needs to translate the picture's file format has been moved or deleted, or 
was not properly installed when you installed Publisher.    Try running the Setup program again, and 
choose Custom Installation to install converters for word processors and graphics.    For more 
information, see the Running the Setup Program topic referenced below.

Publisher doesn't have a converter for your picture's file format
Publisher may not have a converter for the type of picture you're trying to paste.    If so, try returning 
to the application where the picture was created and save the file in a format Publisher recognizes. 
For a list of the file formats Publisher recognizes, see the "What's in a picture?" section of Chapter 
6, "Pictures," in your Microsoft Publisher User's Guide.

See also
Running the Setup Program



 Publisher can't find or read a file
If you're unable to access a file that's on a floppy disk or network, one of the following problems may 
have occurred:

The file name you've typed doesn't exist
Check to make sure that the file name you've typed is correct.    If you're opening a file with the 
Open Existing Publication command, the name of your file should be listed under Publication Name 
in the Open Existing Publication dialog box.

The floppy disk is not in the drive 
If you're using a file located on a floppy disk, make sure that the floppy disk you're using is firmly 
inserted into the drive.    Sometimes there's also a lever or button next to where you insert your 
floppy disk that you need to turn or push after inserting a disk in the drive.

Your link to the network where the file is located has been disconnected
If you're using a file located on a network, it's possible that your computer has been disconnected 
from the network, or that the network stopped working during your current work session.    This may 
interfere with Publisher's ability to locate your file.    Close Publisher and check that you're still 
connected to the network and the network is functioning properly.

See also
There may be a hardware or software problem


