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Open

Opens a selected folder, message, or attachment. If nothing is selected, this command is unavailable.

See Also

Opening and Saving an Attachment

Reading a Message



Move

Moves a selected message or folder. If nothing is selected, this command is unavailable. 
You cannot move the Inbox, Outbox, Sent Mail, and Deleted Mail folders.
You can create a new folder when you move a selected message or folder.
You can also move folders and messages by dragging them to another folder or to the Inbox, 

Outbox, or Deleted Mail folder. Folders moved to the Deleted Mail folder are deleted.

If a message is selected, the Move Message dialog box is selected. If a folder is selected, the Move 
Folder dialog box appears. For information on these dialog boxes, choose one of the following topics:

 Move To
 Type
 New

See also

Moving a Folder Within a Folder

Moving Messages Between Folders



Move To

Choose the folder that you want to move the selected folder or message to.



Type

This box displays the type of folder you have selected. You can move a message, but not a folder, 
between shared private folders.



New

Choose New to create a new folder. After you have created the new folder, it is highlighted in the 
Move To box.



Copy (File menu)

Copies the selected message or folder into another folder. To copy selected text to the Clipboard, use 
the Copy command on the Edit menu. If nothing is selected, this command is unavailable.

When you copy a folder, all folder contents, including subfolders, are copied.
You can create a new folder that the selected message or folder will be copied to.

If a message is selected, the Copy Message dialog box appears. If a folder is selected, the Copy Folder 
dialog box appears. For information on these dialog boxes, choose one of the following topics:
 Copy To
 Type
 New

See also

Moving a Folder Within a Folder

Moving Messages Between Folders



Copy To

Choose the folder you want to put the copy in.



Type

This box displays the type of folder you have selected. You can copy a message, but not a folder, 
between shared and private folders.



New

Choose New to create a new folder. After you have created the new folder, it appears highlighted 
in the Copy To box.



Delete (File menu)

Deletes a selected message or folder. To delete text from a message, use the Delete command on the 
Edit menu. If nothing is selected or the selection cannot be deleted, this command is unavailable. 

Deleted messages are moved to the Deleted Mail folder. Messages deleted from the Deleted Mail 
folder are permanently deleted.

When you delete a folder, all its messages and subfolders are also deleted.

See also

Deleting or Retrieving a Message

Deleting a Folder

Copying, Moving, or Deleting Information Within a Message



Save As

Saves a selected message or a message that is open in a Read Note form to a text file. 
By default, message text is saved to a text file with a file extension of .TXT. The default file name 

is the first eight letters of the message subject. 
To save multiple messages in a single text file, select the messages and save them under a 

single name. 
If you save the selected message to a file with an existing filename, you can either replace the 

existing file or append the message text to it.

See Also

Opening and Saving an Attachment

Saving a Message as a Text File



Save Attachment

Saves a file that is attached to a message. An attachment appears in your message as an icon of the 
application that created the file, or with a default document icon if the application is not available. If there 
is no attached file in the selected or open message, this command is unavailable. 

When you choose Save Attachment, the Save Attachment dialog box appears. For information on the 
dialog box, choose one of the following topics:
 Attached Files
 File Name
 Save
 Save All
 Close

See Also

Opening and Saving an Attachment



Attached Files

This box lists all the files that are attached to the message. 
Select the file you want to save, or choose the Save All button to save all the attached files.



File Name

This box displays the filename of the selected attachment. You can save the attached file with this 
name or type a new name.

All the files in the current directory are displayed below the File Name box. If you attempt to save the 
attached file with the name of a file that already exists, Mail asks if you want to overwrite the existing 
file.



Save

Choose Save to save the selected attachment in the location specified.



Save All

Choose Save All to save all the files attached to the open message in the location specified.



Close

Choose Close to close the dialog box without saving the attachment. To save the attachment, you 
must choose Save or Save All. 



Message Finder

Searches for and lists messages according to criteria you specify.

When you choose Message Finder, the Message Finder dialog box appears. For information on the 
dialog box, choose one of the following topics:
 From
 Subject
 Recipients
 Message Text
 Where To Look
 Start
 Stop
 Message List

See Also

Finding a Message



From

Type the name of the message sender. To find messages from more than one sender, separate 
the names with semicolons (;).



Subject

Type the message subject you want to find. To find more than one subject, separate them with 
semicolons (;).



Recipients

Type the name of the message recipient. To find more than one recipient, separate their names 
with semicolons (;).



Message Text

Type the message text you want to find. To find more than one string of text, separate them with 
semicolons (;).



Where To Look

Choose this button to select the folders you want to search. You can search all your folders or a 
single folder selected in the list. If you select a folder with subfolders, the subfolders are also searched.



Start

Choose the Start button to begin the search for the messages with the search criteria you have 
entered in this dialog box. Messages that meet the criteria appear in the Message Finder window.



Stop

Choose the Stop button to end the search. If you are searching a large number of messages, you 
can stop the search when the message you are looking for is displayed by choosing the Stop button.



Message List

Messages that meet the criteria are displayed in the message list. 

To open one of the messages, double-click it, or highlight the message using the arrow keys and 
then press ENTER.



New Folder

Creates a new mail folder. Folders can be accessible only to you (private folders) or accessible to other 
members of your workgroup or domain (shared folders).

If you create a shared folder, you can specify other users' access privileges. 
If a folder in the Folders list is selected when you create a new folder, the new folder is created as 

a subfolder of the selected one.

When you choose New Folder, the New Folder dialog box appears. For information about the dialog 
box, choose one of the following topics:
 Name
 Comment
 Other Users Can
 Type
 Options
 Level

See Also

Creating a Folder or Subfolder



Name

Type the name of the folder. The folder name is displayed in the Folders list in the folder window.

Folder names can be made up of several words, up to 128 characters for private folders, 26 
characters for shared folders.



Options 

Choose this button to specify the folder level and other users' access to the folder, and to provide 
a comment that is displayed as a folder property. 



Comment

You can type a comment to remind yourself or others what the folder contains.



Other Users Can

If you are creating a shared folder, set the access other users have to messages in the folder:
Read: Other users can only read messages in the folder.
Write: Other users can save, move, or copy messages into the folder.
Delete: Other users can delete the folder or any messages it contains.



Type

Choose the type of folder:
Private: Choose this option to create a folder that only you have access to.
Shared: Choose this option to create a folder that other users in your workgroup or domain have 

access to. If you want to provide group access to a message, you can save it in a shared folder.



Level

Indicate the level at which you want to place the new folder:
Top-Level Folder: Choose this option to place the new folder at the top level. Top-level folders 

are always visible in the Folders list.
Subfolder Of: Choose this option to make the new folder a subfolder of the selected folder. 

Subfolders are stored inside other folders and can be hidden in the Folders list. 



Folder Properties

Checks or changes a folder's properties, including name, level, shared folder privileges, and comment.

When you choose Folder Properties, the Folder Properties dialog box appears. For information on the 
dialog box, choose one of the following topics:
 Name
 Type
 Comment
 Other Users Can
 Options
 Level

See Also

Creating a Folder or Subfolder

Moving a Folder Within a Folder



Print

Prints a selected message or messages. Messages are printed as text in the system font.

When you choose Print, the Print dialog box appears. For information on the dialog box, choose one of 
the following topics:
 Printer
 Print Multiple Notes on a Page
 Print Quality
 Setup button

See Also

Printing a Message

Print Setup command



Printer

This line shows the printer that is currently selected. 

To select another printer, choose the Setup button.



Print Quality

This box displays the selected print quality. 

To change the print quality, choose the down arrow and select the print quality you want from the 
list. Lower print quality generally prints faster.



Setup

Choose Setup to change printers or to set printing options.



Print Multiple Notes On A Page

Select this option to print as many messages as will fit on a page. 

If this option is not selected, each printed message begins on a new page.



Print Setup 

Selects a printer and sets its options.

When you choose Print Setup, the Print Setup dialog box appears. The contents of this dialog box 
depend on the printer you select, but options such as the following are normally available:
 Printer
 Form
 Orientation
 2-Sided Printing
 More button
 Network button

See also

Printing a Message

Print command



Printer

Select either the default printer you have set up in Windows, or another printer. To see the 
available printers, choose the down arrow in the Specific Printer box, or press ALT+P and then ALT+DOWN 

ARROW.



Orientation

Select either portrait or landscape orientation for printing messages. Portrait is the default 
orientation; landscape prints along the page's long axis.



Form

Choose the form that corresponds to the paper size and shape you want.



2-Sided Printing

If your printer supports two-sided printing, choose the option you want:
None: Select None to print on one side of the paper only.
Long Side: Select Long Side to print on both sides of the paper if you want to bind your pages 

along the long edge, like a book.
Short Side: Select Short Side to print on both sides of the paper if you want to bind your pages 

along the short edge, like a notepad. 



More

Depending on the printer you have selected, you may have more printer options. If so, choose this 
button to display a dialog box with the appropriate options for the printer you have chosen.



Network

Choose this button to select a network printer. 



Exit

Quits Mail.

By default, messages in the Deleted Mail folder are deleted when you quit Mail. If you turn off this 
option, you must delete messages in the Deleted Mail folder manually. Choose the Options command 
from the Mail menu to change this option.

Mail prompts you to save any modified Send Note forms that are open. If you have messages in 
the Outbox, Mail asks if you want to send them before quitting Mail.

If you have other Mail-enabled applications running, this command does not sign you out of Mail. 
Other Mail-enabled applications can continue to use the postoffice, and you don't need to enter your 
password to restart Mail.

See Also

Exit and Sign Out command



Exit and Sign Out

Quits Mail and closes all Mail-enabled applications.

Use this command to prevent unauthorized access to your mail when you are going to be away 
from your computer for an extended period of time.



Import Folder

Moves or copies Mail folders from another message file to your primary message file.
When you import a folder with subfolders, all the subfolders are imported. You can cancel the 

selection of subfolders that you don't want to import.
If a message file is protected with a password, you must provide the password before you can 

import folders.

When you choose Import Folder, the Import Folders dialog box appears. Enter the filename and, if 
necessary, specify the drive and directory path of the folder to be imported. By default, the file extension 
for a mail folder is .MMF.

Once you have specified a file, the Folders to Import dialog box appears. For information on the dialog 
box, choose the Help button in the dialog box, or press F1 when the dialog box is open.

See Also

Export Folder command

Exporting Mail Folders

Importing Mail Folders



Export Folder

Moves or copies Mail folders into another message file.
You can export selected folders or all your folders. Only the messages in the selected folders are 

exported.
When you export a subfolder, it is moved to the top level in the export message file. If you want to 

select some but not all the subfolders, the multiple folder selection rules specify what messages are 
exported.

You can create a new backup message file when you export folders. Backup message files are 
not password protected.

You can select a date range for the messages you want to export.

When you choose Export Folder, the Export Folders dialog box appears. Enter the filename and, if 
necessary, specify the drive and directory path where you want to store the exported folder. By default, 
the file extension for a mail folder is .MMF.

Once you have specified a file, the Folders to Export dialog box appears. For information on the dialog 
box, choose the Help button in the dialog box, or press F1 when the dialog box is open.

See Also

Exporting Mail Folders

Import Folder command

Importing Mail Folders



Import/Export Folders

Use the Import/Export Folders dialog box to select the mail file to which you want to import/export 
folders. For more information on the dialog box, choose one of the following topics:
 Import/Export File Name
 Directories
 List Files of Type
 Drives
 Network button



Export File Name

Enter the name of the file that is to contain the folders you want to export, or select a file name 
from the list below.

By default, the export file name is EXPORT.MMF.



Directories

Shows the directory path of the files listed.
If the file you want is in a different directory, select the path you want.



List Files of Type

Shows the file extension of the files listed. By default, Mail files have the extension .MMF.
To display files with a different extension, select a different file type from the list provided.



Drives

To view files on a different disk than the one shown, select the disk you want from the list 
provided.



Network

Choose this button to export folders to a Mail file located on a shared network resource. 



Import/Export Folders

Use the Import/Export Folders dialog box to select the mail file from which you want to import/export 
folders. For more information on the dialog box, choose one of the following topics:
 Import/Export File Name
 Directories
 List Files of Type
 Drives
 Network button



Import File Name

Enter the name of the file that contains the folders you want to import, or select a file name from 
the list below.



Directories

Shows the directory path of the files listed.
If the file you want is in a different directory, select the path you want.



List Files of Type

Shows the file extension of the files listed. By default, Mail files have the extension .MMF.
To display files with a different extension, select a different file type from the list provided.



Drives

To view files on a different disk than the one shown, select the disk you want from the list 
provided.



Network

Choose this button to import folders from a Mail file located on a shared network resource. 



Import/Export Folders

Select the folders you want to import/export.
You can import/export all folders or only the folders you select in the Folders to Import list.
All subfolders are displayed in the Folders list. When you select a folder, all its subfolders are also 

selected. You can cancel the selection of subfolders you don't want to import.

For information about the buttons in this dialog box, choose one of the following topics:
 Move
 Copy
 Close
 Options

See also

Export Folder command

Exporting Mail Folders

Importing Mail Folders



Move

Choose Move to move the selected folders from the import file to your primary message file. The 
contents of selected folders are removed from the import file, but the empty folders are not deleted.



Copy

Choose Copy to copy the selected folders to your primary message file.



Close

Choose Close to close this dialog box when you have finished copying or moving folders into your 
primary message file.



Options

Choose Options to select a date range for the messages you want to import.



Import/Export Folders

Select the folders you want to import/export.
You can import/export all folders or only folders you select in the Folders To Export list.
All subfolders are displayed in the Folders list. When you select a folder, all its subfolders are also 

selected. You can cancel the selection of subfolders you don't want to export.

For information about the buttons in this dialog box, choose one of the following topics:
 Move
 Copy
 Close
 Options

See also

Import Folder command

Exporting Mail Folders

Importing Mail Folders



Move

Choose Move to move the selected folders from your primary message file to the export file. The 
contents of selected folders are removed from your primary message file, but the empty folders are not 
deleted.



Copy

Choose Copy to copy the selected folders to the export message file.



Close

Choose Close to close this dialog box when you have finished copying or moving folders into the 
export message file.



Options

Choose Options to select a date range for the messages you want to export.



Options

Use this dialog box to import or export all messages or messages within a specific date range.

For information on this dialog box, choose one of the following topics:
 All Messages
 Messages Received or Modified



All Messages

Select this option to import or export all the messages in the selected folders.



Messages Received or Modified

Select this option to save messages within the date range specified in the From and To boxes.

From

Select this check box to import or export messages received after the date entered in the date box.

To

Select this check box to import or export messages received before the date entered in the date 
box.
To import or export messages that you received between two dates, select both check boxes and enter 
the earlier date in the From box and the later date in the To box.



Duplicate Folder Name 

A folder in the primary message file has the same name as a folder in the import or export message file.

For information on the options in this dialog box, choose one of the following topics:
 Save Latest Version of All Messages
 Save All Messages
 Rename Destination Folder
 Don't Prompt On Remaining Duplicate Folder Names



Save Latest Version Of All Messages

Mail checks the message headers of all duplicate messages and moves or copies the message only if it 
is the latest version.



Save All Messages

All messages are saved in both folders. If the duplicate messages are identical, the messages are not 
copied or moved. If there are two versions of a message, both versions are saved.



Rename Destination Folder

You are prompted for a new name for the folder you are moving or copying. All the contents of the 
source folder are moved into the renamed destination folder. 



Don't Prompt On Remaining Duplicate Folder Names

Select this check box if you want all folders with duplicate names to be handled the same way. If 
you do not select this option, you are prompted each time a duplicate name is found.



Rename Folder

Use this dialog box to enter a name for the new folder you are moving or copying. The copy of the folder 
receives this name; the original retains its original name.



Undo

Reverses the last editing action. You must use the Undo command immediately following the action you 
want to undo. 

If the action cannot be undone, the Undo command is unavailable.
To cancel an Undo operation, choose the Undo command again. 



Cut

Removes selected text from a message and moves it to the Clipboard.
The text you cut remains on the Clipboard until you cut or copy something else.
You can also press CTRL+X to cut selected text and move it to the Clipboard.
If no text is selected, the Cut command is unavailable.
To remove selected text without moving it to the Clipboard, press the DEL key.

See also

Copying Information Between Messages

Copying, Moving, or Deleting Information Within a Message



Copy (Edit menu)

Copies the selected text or object to the Clipboard. To copy a message from one folder to another, 
choose the Copy command from the File menu.

Once text or objects are copied to the Clipboard, you can paste them into another location.
The text you copy remains on the Clipboard until you cut or copy something else.
You can also press CTRL+C to copy selected text to the Clipboard.
If no text is selected, the Copy command is unavailable.

See Also

Copying, Moving, or Deleting Information Within a Message

Copying Information Between Messages



Paste

Inserts the contents of the Clipboard into a message at the insertion point.
You can also press CTRL+V to paste the contents of the Clipboard.
The Paste command is unavailable if the Clipboard is empty or if the information on the Clipboard 

is of an unknown format and cannot be pasted into the message.

See Also

Copying, Moving, or Deleting Information Within a Message

Copying Information Between Messages

Copying Information from a File



Paste Special

Pastes an object from the Clipboard into a message.

An object retains the formatting and other characteristics it had in the application that created it. For 
example, you can copy part of a Microsoft Excel spreadsheet and paste it as an object into a message. 
The message recipient can double-click the object to open it in Excel and edit or print the object.

When you choose Paste Special, the Paste Special dialog box appears. For information on the dialog 
box, choose one of the following topics:
 Source
 Data Type
 Paste

See Also

Embedding an Object in a Message

Working with an Embedded Object



Source

This line displays the application used to create the object and the file the object came from, if that 
information is available.



Data Type

Select the type of object you want to paste. If the application used to create the object supports object 
linking and embedding (OLE), the application type should be listed.



Paste

Choose Paste to insert the object from the Clipboard into the message at the insertion point.



Delete (Edit menu)

Removes selected text. To delete a message from a folder, choose the Delete command from the File 
menu. Deleted text is not moved to the Clipboard. 

If you delete text by accident, you can immediately choose the Undo command to restore it.
You can also press the DEL key to remove selected text.

See Also

Deleting a Folder

Deleting or Retrieving a Message

Copying, Moving, or Deleting Information Within a Message



Select All

Selects the entire contents of a message, or the entire To, Cc, or Subject box, or all the messages in a 
message list.

See Also

Copying Information Between Two Messages



Spelling

Checks the spelling of the selected text or, if no text is selected, of the entire message text and the 
Subject line.

To have Mail check the spelling of every message before it is sent, select the Check Spelling Of 
Messages Before Sending option, using the Options command from the Mail menu.

When you choose Spelling, the Spelling dialog box appears. For information about the dialog box, 
choose one of the following topics:
 Not in Dictionary
 Change To
 Suggestions
 Add
 Ignore
 Ignore All
 Change
 Change All
 Suggest
 Always Suggest
 Ignore All UPPERCASE



Not In Dictionary

This box displays a word that the spelling checker finds a problem with or cannot identify.



Change To

Type the correct spelling of the misspelled word, or select a word from the Suggestions box.
To replace the word in your message with the word in the Change To box, choose the Change 

button.
If the word is not misspelled, choose the Ignore button to leave the word unchanged and continue 

the spelling check.



Suggestions

This box displays alternative spellings for the misspelled word. To view the suggested words, choose 
the Suggest button or select the Always Suggest option.

To replace a misspelled word with one of the suggested words, select the suggested word and 
then choose the Change button.



Add

Choose Add to add a word to your personal dictionary.

If you often use words that the spelling checker cannot identify, such as proper names, you may want 
to add them to a personal dictionary.



Ignore

Choose Ignore to leave the misspelled word unchanged. The spelling checker continues to 
search the selected text or message.



Ignore All

Choose Ignore All to ignore all further instances of the misspelled word in the message.



Change

Choose Change to replace the misspelled word with the word in the Change To box. This button 
changes to Delete if the word is a repeated word.



Change All

Choose Change All to correct the spelling of all instances of the misspelled word in the message.



Suggest

Choose Suggest to display alternative spellings for the misspelled word. If the Always Suggest 
option is selected, alternative words are displayed automatically.



Always Suggest

Select this option for alternative spelling suggestions every time a misspelled word is found.

The spelling checker may run more slowly with this option selected.



Ignore All UPPERCASE

Select this option if you want the spelling checker to ignore words that have all capital letters.



Insert Object

Creates an object, or inserts an object in a message, or both.

When you choose Insert Object, the Insert Object dialog box appears. 
In the Object Type box, choose the object type you want to insert.

See Also

Embedding an Object in a Message

Working with an Embedded Object

Paste Special command



Object

Opens an embedded object in the application that was used to create it. 

Use this command to activate objects that include sound or animation, or to open an attached file. You 
must have access to the type of application that created it.

See Also

Embedding an Object in a Message

Working with an Embedded Object



Edit Attached Object command

Opens the application used to create the selected object.
This command changes depending on the type of object selected. For example, if the selected 

object is a Microsoft WordArt object, the command reads "Edit MS WordArt Object."
When you close the object's application, the changes are automatically updated in the message.
You can also double-click an object to open the application used to edit it.
Some objects have editing options available from another menu that appears when you choose 

this command.

See Also

Embedding an Object in a Message

Working with an Embedded Object



Edit or Activate Object command

Activates or edit the selected object. Depending on the type of object, you may have several choices on 
this menu.



Insert From File

Inserts the text from a file into a message. This command inserts ANSI text only; other document 
formats may be illegible.

When you issue Insert From File, the Insert From File dialog box appears. Select the file whose text you 
want to insert, and then choose OK. If the file is not a text file (extension .TXT), the inserted text may be 
illegible.

See Also

Copying Information from a File



Insert From File

Inserts the text from a file into a message. This command inserts ANSI text only; other document 
formats may be illegible.

When you issue Insert From File, the Insert From File dialog box appears. Select the file whose text you 
want to insert, and then choose OK. If the file is not a text file (extension .TXT), the inserted text may be 
illegible.
 File Name
 List Files as Type
 Directories
 Drives
 Network



File Name

 Type the name of the file you want to insert, or select a file from the list.    If this file is not a text file, the 
inserted text may be illegible.



Directories

Shows the directory path of the files listed.

 If the file you want is in a different directory, select the path you want



Drives

 To view files on a different disk than the one shown, select the disk you want from the list provide.



Network Button

 Choose this button to insert files located on a shared network resource.



List File as Type

You can insert any type of document into a file; the file is converted to ASCII text.    Shows the file 
extension of the files listed.

 To display files with a different extension, select a different file type from the list provided.



Shared Folders

Lists the shared folders in your postoffice.
You may not have access to all shared folders. The person who creates the folder assigns access 

privileges for that folder.
Another way to display the Shared Folders list is to choose the Private Folders button above the 

Folders list.
This command is available only when the Private Folders list is displayed.

See Also

Creating a Folder or Subfolder

Expanding and Collapsing Folders



Private Folders

Lists your private folders.
Private folders are stored with your message file; only you can view or alter them.
The button above the Folders list toggles the display between shared and private folders.
This command is available only when the Shared Folders list is displayed.

See Also

Creating a Folder or Subfolder

Expanding and Collapsing Folders



New Messages

Checks for new messages in the Inbox or Shared Folders list.



Sort By Sender

Arranges your messages alphabetically by the name of the sender.
You can also sort messages by sender by choosing the From button, located above the message 

list.
To reverse the order, hold down the CTRL key and choose the From button above the message 

list.



Sort By Subject

Arranges your messages alphabetically by message subject.
You can also sort messages by subject by choosing the Subject button above the message list.
To reverse the order, hold down the CTRL key and choose the Subject button above the message 

list.



Sort By Date

Arranges your messages according to the date each message was sent.
You can also sort messages by date by choosing the Received button above the message list.
The dates are arranged with the latest message at the bottom of the list. To reverse the order, 

hold down the CTRL key and choose the Received button above the message list.



Sort By Priority

Arranges your message list with the highest priority messages at the top.
High-priority messages are marked with an exclamation point. Low-priority messages are marked 

with a down arrow. 
To reverse the order, hold down the CTRL key and from the View menu, choose Sort by Priority.



Split

Activates the split bar between the folders list and the message list. Move the split bar right or left to 
provide more space for the folders list or the message list.

To move the split bar, you can either drag it or use the arrow keys and then press ENTER.
You can move the split bar with the mouse by clicking it and dragging it to the position you want. 
You can also resize the From, Subject, and Received columns this way.



Status Bar

Shows or hides the status bar at the bottom of the Mail window. When this command is checked on the 
menu, the status bar is displayed.

The status bar displays information about menu commands, the number of read and unread messages 
in the open folder, the time, and the current status of Mail.



Tool Bar

Shows or hides the toolbar. When this command is checked on the menu, the toolbar is displayed.

The toolbar contains buttons for Mail's most frequently used commands.



Previous

Displays the previous message in the message list.

See Also

Reading a Message



Next

Displays the next message in the message list.

See Also

Reading a Message



Open Inbox

Displays the Inbox message list.
You can also open the Inbox by double-clicking Inbox in the Folders list.

See Also

Expanding and Collapsing Folders



Change Font

Toggles the display font of the message between the normal font and a fixed font. The default normal 
font is Helv 10-point, and the default fixed-pitch font is Courier 10-point.

Messages that are composed with a fixed font are sometimes easier to read when they are 
displayed with a fixed font, especially if the message contains tables.



Compose Note

Displays a Send Note form for composing a new message.
You can also display a new Send Note form by choosing the Compose button on the tool bar, or 

by pressing CTRL+N.

To move the insertion point in the Send Note form, press TAB.

For information on the Send Note form, choose one of the following topics:
 Send
 Check Names
 Attach
 Options
 Address
 To
 Cc
 Subject
 Message text area

See Also

Sending a Message



Send

Choose this button to send the message in the Send Note form to all the addressees indicated.

The message is placed in your Outbox until it is actually sent. 



Check Names

Choose this button to verify the names of all addressees on both the To and Cc lines in the Send 
Note form.

Correct names are underlined. If Mail cannot find one or more names in the postoffice, it prompts you 
to correct them. 



Attach

Choose this button to attach an object to the message. In the Attach dialog box that appears, 
select the object that contains the file you want to attach, and then choose the Attach button. 

To close the Attach dialog box without attaching an object, choose the Close button.



Options

Choose this button to set options for the message you are sending. In the dialog box that 
appears, you can set the following options:

Return Receipt: Choose this check box if you want a return receipt when each 
addressee reads the message.

Save Sent Messages: Choose this check box to keep a copy of the message you 
sent. The message is saved in your Sent Mail folder, if you have one. 

Priority: Choose the priority of the message. By default, messages are given normal 
priority. 

Messages with high priority are indicated in the user's message list with an exclamation 
mark; messages with low priority are indicated with a down arrow. 

Address

Choose this button to select addressees from the postoffice directory or from your personal 
address book. For information on the Address dialog box, choose the Help button in the dialog box, or 
press F1 when the dialog box is active.



To

Enter the names of the addressees for the message. 

You must enter at least one name in the To box before you can send the message. 



Cc

Enter the names of those to whom you want to send a copy of the message. 



Subject

Enter the subject of your message.



Message text area

Enter your message text. 



Address

Use this dialog box to address your message. For information on the Address dialog box, choose one of 
the following topics:
 Names List
 Open Directory button
 Personal Address Book button
 Find button
 New Name button
 To button
 Cc button
 Add To Personal Address Book button
 Details button
 To box
 Cc box



Names List

Lists all names in the current address book or the results of the most recent search. Group aliases 
are indicated by bold type. To list the users included in a group alias, choose the Details button.



Open Directory 

Choose this button or press CTRL+L to open an address book different from the one named at the 
top of the dialog box.



Personal Address Book 

Choose this button or press CTRL+P to open your personal address book. 



Find 

Choose this button or press CTRL+F to find all the names in the current address book that match 
or contain the name you specify. 



New Name 

Choose this button to add a new name and address to your Personal Address Book or to address 
a message to another mail system. You can add a gateway address or the name and address of a user 
on another mail postoffice.



To button

Choose this button to add all selected names in the names list to the To line of your message. 



Cc button

Choose this button to add all selected names in the names list to the Cc line of your message. 



Add to Personal Address Book 

Choose this button to add all selected names in the names list to your personal address book. 



Details 

Choose this button for detailed information about the selected name in the names list. If more 
than one name is selected, the Details button is unavailable



To box

Enter the names of the addressees of your message. The To box must contain at least one name 
before you can send your message.



Cc box

Enter the names of the addressees who are to receive a copy of your message. 



Reply

Opens a Send Note form addressed to the sender of the selected or open message.

When you choose Reply, the form is opened with the sender's name in the To box. The subject of the 
original message in the Subject box, prefaced by RE:, and the original message text is in the message 
area. Attachments and linked or embedded objects from the original message are not copied to the reply 
message.

You can edit the original message text when composing your reply.

See Also

Replying to a Message



Reply To All

Opens a Send Note form addressed to the sender and all recipients of the selected or open message.

When you choose Reply To All, the form is opened with the original sender's and recipients' names in 
the To box and all the Cc recipients' names in the Cc box. The subject of the original message is entered 
in the Subject box, prefaced by RE:, and the original message text is entered in the message body.

You can edit the original message text when composing your reply.

See Also

Replying to a Message



Forward

Opens a Send Note form containing a message to be forwarded to addressees you specify. 

When you choose Forward, the form is opened with the subject of the original message in the Subject 
box, prefaced by FW:. The original message text is entered in the message body. Any attachments and 
linked or embedded objects from the original message are copied into the forwarded message.

You can edit the original message text before you forward it.

See Also

Forwarding a Message



Address Book

Use the Address Book command to open the Address Book.
Use the Address Book to find user names, add or delete names in your Personal Address Book, 

get details about a user, or browse another user directory.
If a Send Note form is open, the Address Book is displayed with To and Cc boxes you can use to 

address the message.

For information on the Address Book, choose one of the following topics:
 Names List
 Open Directory button
 Personal Address Book button
 Search button
 Add Entry button
 To button
 Cc button
 Add To Personal Address Book button
 Details button
 To box
 Cc box

See Also

Creating or Modifying a Personal Group

Getting Details About a User

Updating Your Personal Address Book

Using Mail's Address List



Search 

Choose this button to search the current address book for the name indicated.



Add Entry 

Choose this button to add a name to your personal address book or to add a custom address to 
the Compose Note form. 



Name Finder

Type the name, or first part of a name, you want to search for in the directory list. For example, you can 
search for all names that begin with the letters "rob." The name finder displays Robert Maxwell as well 
as Maria Robbins.

Find button

Choose Find to search the current directory.

Cancel button

Choose Cancel to close this dialog box without performing a search.



Personal Groups

Creates or changes a personal mail group.
Creating a personal group makes it easy to address messages to a group of people you send 

mail to often.

When you choose Personal Groups, the Personal Groups dialog box appears. For information on the 
dialog box, choose one of the following topics:
 Personal Group List
 New
 Edit
 Remove
 Close

See Also

Creating or Modifying a Personal Group



Personal Group List

This box lists your personal groups.



New

Choose New to create a new personal group and add names to it.



Edit

Choose Edit to change the selected personal group.



Remove

Choose Remove to delete the selected personal group.



Close

Choose Close to accept the changes and close this dialog box.



Options

Sets options for working in Mail. The options you set take effect immediately.

When you choose Options, the Options dialog box appears. For information on the dialog box, choose 
one of the following topics:
 Save Copy of Outgoing Messages in Sent Mail Folder
 Check Spelling of Messages Before Sending
 Add Recipients to Personal Address Book
 Check for New Mail Every __ Minutes
 When New Mail Arrives
 Empty Deleted Mail Folder When Exiting
 Server button

See Also

Setting Mail Options

Setting Message Options



Save Copy Of Outgoing Messages In Sent Mail Folder

Select this option to save a copy of each message you send in the Sent Mail folder.



Check Spelling Of Messages Before Sending

Select this option if you want Mail to check spelling automatically before you send each message.



Add Recipients To Personal Address Book

Select this option to add recipients of all your messages to your Personal Address Book.



Check For New Mail Every _ Minutes

Specify how often Mail checks for new mail. You must enter a number between 1 and 9999.



When New Mail Arrives

Specify how you want to be notified when new mail arrives. You can select one, both, or neither of these 
options. 

Sound Chime: Mail sounds a chime whenever you receive a new message.
Flash Envelope: The Windows cursor arrow briefly turns to an envelope when you receive a new 

message.



Empty Deleted Mail Folder When Exiting

Select this option to delete messages in the Deleted Mail folder when you quit Mail.

If you don't select this option, deleted messages accumulate in the Deleted Mail folder until you delete 
them.



Server
Choose Server to display or change the server options, such as the location of your message file 

or Inbox. Specific options depend on the type of mail server you are using.



Change Password

Changes the password of your Mail acocunt.

When you choose Change Password, the Change Password dialog box appears. For information about 
the dialog box, choose one of the following topics:
 Old Password
 New Password
 Verify New Password

See Also

Changing Your Password



Old Password

Type your current password in this box.



New Password

Type your new password in this box.



Verify New Password

Type your new password again to verify that you have typed it correctly.



Backup

Creates a backup copy of your message file.

It is a good idea to back up your message file from time to time. If there is a problem with the computer 
that holds your message file, you can use the backup to restore your message file. 

Take care of your backup message file: it is not protected by your password.
When you open a backup file, you are asked if you want to make the backup file your primary 

message file. You can read, delete, and move messages within an unconverted backup file, but you can 
compose or send new messages only from your primary message file.

When you choose Backup, the Backup dialog box appears. Choose the drive name and directory path 
where you want to save the backup file, and then give it a filename. By default, the file extension for mail 
files is .MMF.

See Also

Backing Up and Restoring Your Message File



New Window

Displays a new Mail folder window.
You can display the contents of two or more folders at once by opening new windows, each 

containing a separate folder.
You can reduce a window to an icon by choosing the Minimize button in the upper-right corner of 

the window.



Tile

Arranges all open Mail windows so they appear side by side.
You can use this command to find a window that may be hidden under other windows.



Cascade

Stacks all open Mail windows so all the window titles are visible. 
You can use this command to find a window that may be hidden under other windows.



Arrange Icons

Organizes the window icons across the bottom of the Mail workspace.
You can use this command to find icons that may be out of view in the Mail window.
To reduce a Mail window to an icon, choose the Minimize button in the upper-right corner of the 

window.
You can move a folder or message by dragging it to an icon.



Open Windows

The list at the bottom of the Window menu displays the Mail windows you have open or minimized in the 
Mail workspace.

To view one of the windows in the list, click it, or type the number of the window.
The window that is currently displayed in the Mail workspace has a check mark next to it on the 

Window menu.
If you have more than nine windows open, the More Windows command is displayed at the 

bottom of the list. Choose this command to display a list of all the open windows.



More Windows

Displays a list of all open Mail windows. This command is available only if you have more than nine Mail 
windows open.

To display one of the windows in the list, double-click its name. Or select the name using the 
arrow keys and then press ENTER.



Meeting Request

This is the Meeting Request message form for Microsoft Schedule+. You can accept, decline, or 
tentatively schedule the requested meeting.

For more information on this dialog box, choose one of the following topics:
 Accept button
 Decline button
 Tentative button
 View Schedule button
 Meeting information
 Send Response



Accept 

Choose this button to accept this meeting. The meeting is automatically added to your 
Appointment Book.



Decline 

Choose this button to decline this meeting. 



Tentative 

Choose this button to tentatively accept this meeting time. The meeting is automatically added as 
a tentative appointment in your Appointment Book.



View Schedule 

Choose this button to view your schedule before replying to this meeting request.



Meeting Information

This area contains the name of the person who is organizing the meeting, the meeting time, and other 
details of the meeting request.



Send Response

If you select the Send Response check box, the meeting organizer is sent your response.



Meeting Canceled

This is the Meeting Canceled message form for Microsoft Schedule+. This message appears whenever 
a meeting has been canceled by the meeting organizer. The word "Canceled" in the subject line 
indicates that the meeting is canceled.

For more information on this dialog box, choose one of the following topics:
 Remove From Schedule
 View Schedule
 Meeting Information
 Notes



Remove From Schedule

 Choose this button to remove the meeting from your Appointment Book.



View Schedule

 Choose this button to view your schedule before canceling the meeting in your Appointment Book.



Meeting Information

This area contains the name of the person who is canceling the meeting, the meeting time, and other 
meeting details.



Notes

This section contains any additional notes sent with the meeting cancelation.



Send Response

This is similar to the Send Response message form for Microsoft Schedule+.

For more information on this dialog box, choose one of the following topics:
 Send
 Meeting Information
 Notes



Send

Choose this button to send a meeting response to the meeting organizer.



Meeting Information

This area of the dialog box contains the name of the person who sent the meeting request. The 
subject line indicates whether the attendee has accepted, tentatively accepted, or declined the meeting 
request.



Notes

This section of the dialog box contains any additional notes to be sent with the reply.



Forward Meeting Request

This is the Forward Meeting Request message form for Microsoft Schedule+. Use this form to forward a 
meeting request.

For more information on this dialog box, choose one of the following topics:
 Send button
 Check Names button
 Address button
 To
 Subject
 When



Send

Choose this button to send the meeting request to the name on the To line.



Check Names

Choose this button to verify the user name or names on the To line.



Address 

Choose this button to open the Address Book.



To

Type the name of the person you want to forward the meeting request to, or choose a name from 
the Address Book.



Subject

This line displays the meeting subject.



When

This line displays the meeting date and time.



Meeting Response

This is the Meeting Response message form for Microsoft Schedule+. This message indicates whether 
or not a person can attend a meeting you organized.

For information on this dialog box, choose one of the following topics:

View Schedule

Choose this button to open Schedule+ and display your schedule.



Where To Look 

Use this dialog box to search one or all of your folders for messages that meet the search criteria you 
specify in the Message Finder.

Look in all folders

Select this option to search all folders for messages with the search criteria specified in the 
Message Finder.

Look in

To search only one folder, select the folder from the list.

See Also

Finding a Message



File Exists 

There is already a file with this name in this location. You can save the file in another location, or you 
can choose one of the buttons available in this dialog box:

Append to

Choose Append to to add this file to the end of an existing file with the same name.

Overwrite

Choose Overwrite to replace the existing file with this file. The existing file is deleted.



Message Viewer window

The message viewer window shows the folders list on the left side of the window. The 
message headers in the open folder are displayed on the right side of the window. 

Each message listed is accompanied by an icon that indicates the status of the message:
Unopened message
Open message
Unsent message
Message with attached file
High-priority message
Low-priority message

You can minimize any message viewer window, but the Outbox and at least one other folder 
window can never be closed. 

The Outbox message viewer window does not have a folders list.

For information about components of the message viewer window, choose one of the 
following topics:
 Folders list
 From
 Subject
 Received

Folders List

The folders list displays either your private folders or the shared folders in your postoffice. To 
change the view from private to shared, choose the Private Folders or Shared Folders button 
at the top of the folders list.

A plus sign (+) indicates that a folder has subfolders. To view the subfolders, choose 
the plus sign, or highlight the folder using the arrow keys, and then type the plus sign key.

A minus sign () indicates that subfolders are displayed. To hide the subfolders, choose 
the minus sign, or highlight the folder using the arrow keys, and then press the minus sign key.

To show all folders, press CTRL+PLUS SIGN; to hide all folders, press CTRL+MINUS SIGN.

From

This list shows who messages are from and the current status of each message. Messages that you 
sent are preceded by "To:" and list the first addressee. 

You can quickly select a block of messages by clicking the left side of the message list and dragging the 
selection.

To display the messages in alphabetical order, choose the From button at the top of the list. To 
reverse the order, press CTRL and choose the From button.



Subject list

This list shows the subject line of each message. You can change the size of the subject list by moving 
the mouse pointer over the line on either side of the Subject button and dragging the button margin.

To view the messages in alphabetical order by subject, choose the Subject button. To reverse the 
order, press CTRL and choose the Subject button.



Received list

This list shows the date and time each message is received.
To view the messages in chronological order, choose the Received button. To reverse the order, 

press CTRL and choose the Received button.



Edit Personal Group

Use this dialog box to add names to, or delete names from, a personal group.

For information about this dialog box, choose one of the following topics:
 Names List
 Open Directory button
 Personal Address Book button
 Find button
 New Name button
 Add button
 Remove button
 Group members

See Also

Creating or Modifying a Personal Group



Add 

Choose the Add button to add the names(s) selected in the address list to the group.



Remove 

Choose this button to remove the name selected in the names list from your personal address 
book. 

When you remove a name from your personal address book, the name is also removed from all 
personal groups. To remove a name only from a personal group, select the name in the Group Members 
list and press DELETE.



Group Members

This box lists the members of the personal group. To delete a group member, select the name, and then 
press the DELETE key.



New Group 

Use this dialog box to create a new personal group.

New group name

Type the name of the group you want to create. Group names can be any length and more than 
one word.

Create

Choose Create to add the group to your Personal Address Book. The Edit Personal Groups 
dialog box is displayed for you to add group members.

See Also

Creating or Modifying a Personal Group



Open Directory 

This dialog box lists the directories on your Mail system. To select another directory, double-click the 
name of the other directory, or use the arrow keys to highlight it and then press ENTER.

Set Default

Choose Set Default to open the selected directory each time you open the Address Book.



New 

Use this dialog box to add the addresses of mail users to your Personal Address Book.

There are two ways to enter custom addresses. You can type an address directly in the message you 
are composing, or you can type the information in this dialog box. If you enter the information in this 
dialog box, Mail automatically inserts the correct syntax for the address.

Create What Kind Of Entry

Select the type of mail system where the new user address is located.

See Also

Updating Your Personal Address Book



Details or New User 

This dialog box displays information about a user or group. The fields in this dialog box depend on your 
mail system. 



Attach 

Use this dialog box to attach a file to a message.
Select the file you want to attach, specifying a different drive or directory path, if necessary, and 

then choose the Attach button.
To close the dialog box without attaching a file, choose the Close button.

See Also

Attaching a File



Read Note form

The Read Note form displays the message header information and the message text.
You can reply to or forward the message by choosing the Reply, Reply All, or Forward button.
You can see user address information by double-clicking any name in the message header.
You can edit only the message text and the Subject line.

See Also

Reading a Message



Undeliverable Mail Notice

The message could not be delivered to the recipient. Your postoffice may not be accessible at this time. 
You can try resending the message by choosing Send Again.



Return Receipt

The return receipt message displays the date and time the message you sent was opened by the 
recipient.



To select folders for import or export

Click the folder you want to select. To cancel a folder selection, click the folder again.
To select multiple folders, hold down CTRL while selecting the folders.
To extend a selection from one folder to another, hold down the SHIFT key while selecting the 

second folder.



Multiple Selection Rules For Importing or Exporting Folders

When you select a folder, all its subfolders are also selected.
A single folder selected at any level is created at the top level of the destination message file.
If you don't want to copy all the subfolders under a selected folder, you can cancel the selection 

of those folders. The folders necessary to maintain the folder hierarchy between selected subfolders are 
maintained. If you have canceled the selection of these folders, they will be empty in the destination folder 
and serve only as placeholders.



Exporting Mail Folders

To export one or more Mail folders

1. From the File menu, choose Export Folder (ALT, F, E).

2. Select the message file (.MMF file) you want to export messages to and then choose the OK 
button.

If you want to create a new message file, type the name for the new file in the File Name box and 
then choose OK.

3. If applicable, type the password for the message file.

You are prompted for a password only if the message file you selected is password protected.

4. Select the All Folders option to export all the messages in your message file, or select the Selected 
Folders option to export only the folders you select. Then select the folders you want to export.

If you select a folder with subfolders, the subfolders are also exported. There are multiple folder 
selection rules that specify what happens when you select some but not all the subfolders.

5. To export messages within a date range, choose the Options button. In the Options dialog box you 
can choose to export all the messages in the selected folders, or only those messages received or 
modified during a specified date range.

To export all messages received after a specific date, select the From check box and enter the 
date.

To export all messages received before a specific date, select the To check box and enter the 
date.

To export messages between two dates, select both check boxes. Enter the earlier date in the 
From box and the later in the To box.

6. Choose the Copy button to copy the selected folders to the export message file, or choose the 
Move button to move the selected folders to the export message file.

If there are folders with the same name in both the export and primary message files, Mail prompts 
you to choose how you want to resolve conflicting folder names.

7. Choose the Close button.

See Also

Export Folder command

Import Folder command

Importing Mail Folders



Conflicting Folder Names

If the name of the folder you are importing or exporting conflicts with a folder of the same name in the 
destination message file, you can choose one of the following options to resolve the conflict.

Save Latest Version Of All Messages: Mail checks the message headers of all duplicate 
messages and moves or copies the message only if it is the latest version.

Save All Messages: All messages are saved in both folders. If the duplicate messages are 
identical, the messages are not copied or moved. If there are two versions of a message, both versions 
are saved.

Rename Destination Folder: You are prompted for a new name for the folder you are moving or 
copying.



Importing Mail Folders

To import one or more Mail folders

1. From the File menu, choose Import Folder (ALT, F, I).

2. Select the message file (.MMF file) you want to import messages from and then choose the OK 
button.

3. If applicable, type the password for the message file.

You are prompted for the password only if the message file is password protected.

4. Select the All Folders option to import all the messages into your primary message file, or select 
the Selected Folders option to import only the folders you select. Then select the folders you want 
to import.

If you select a folder with subfolders, the subfolders are also imported. There are multiple folder 
selection rules that specify what happens when you select some but not all the subfolders.

5. To import messages within a date range, choose the Options button. In the Options dialog box you 
can choose to import all the messages in the selected folders, or only those messages received or 
modified during a specified date range.

To import all messages received after a specific date, select the From check box and enter the 
date.

To import all messages received before a specific date, select the To check box and enter the 
date.

To import messages between two dates, select both check boxes. Enter the earlier date in the 
From box and the later in the To box.

6. Choose the Copy button to copy the selected folders to your primary message file, or choose the 
Move button to move the selected folders to your primary message file.

If there are folders with the same name in both the export and primary message files, Mail prompts 
you to choose how you want to resolve conflicting folder names.

7. Choose the Close button.

See Also

Export Folder command

Exporting Mail Folders

Import Folder command



Postoffice Manager

Manages the Workgroup Postoffice (WGPO). The Postoffice Manager command appears only on the 
administrator's Mail menu; it displays the Postoffice Manager dialog box.

With the Postoffice Manager, you can:
Add users to the WGPO.
Modify existing user accounts.
Remove users from the WGPO.
Compress shared folders to manage the disk space where the WGPO is installed.

For more information on the Postoffice Manager command and on managing a Workgroup Postoffice, 
see the Windows NT System Guide.



Check Names dialog box

Mail has found more than one name that matches the name you entered in the To or Cc line.Choose the 
message recipient's name from the list provided.

To get more information about a name in the list, double-click the name, or select the name and 
then choose the Details button.

See Also

Verifying User Names



Contents

Starts Help and displays the topics in Help for Microsoft Windows NT Mail. 



Search for Help On

Opens the Search dialog box for Help. You can look up Help information by choosing keywords in the 
dialog box. 



How to Use Help

Explains how to use Help. 



About Mail

Displays version and copyright information about Microsoft Windows NT Mail. 



Postoffice Manager

Use the Postoffice Manager dialog box to manage user accounts on your postoffice. For information on 
this dialog box, choose one of the following topics:
 Users List
 Details button
 Remove User button
 Shared Folders button



Users List

Lists the names of all users with accounts on your postoffice.
To edit a user account, double-click the user's name.



Details 

Choose the Details button to view and edit account of the user whose name is selected in the 
Users List. 



Remove User

Choose the Remove User button to remove the account of the user whose name is selected in 
the Users List.



Shared Folders

Choose the Shared Folders button to view the current status of shared folders on your postoffice, 
and to manage the size of the shared folders.



Details

Use the Details dialog box to view and edit information about individual user accounts. The title bar 
contains the name of the user whose account information is displayed. 

For information on the dialog box, choose one of the following topics:
 Name
 Mailbox
 Password
 Phone #1
 Phone #2
 Office
 Department
 Notes



Name

Shows the name of the user who owns the account. This name appears in the To, From, and Cc lines of 
messages sent to or from the user's mailbox. 



Mailbox

Shows the name of the mailbox associated with the user account. This is the name the user enters in 
the Mail Sign In dialog box to connect to the postoffice. Mailbox names must be unique within the 
postoffice. 



Password

Contains the user's password. The user enters the password in the Mail Sign In dialog box to connect to 
the postoffice. For security reasons, only asterisks are shown after a password has been stored, and the 
number of asterisks displayed does not correspond to the number of characters in the password. 

If a user forgets the password, you can enter a new one here. If a user changes the password, the 
contents of this box is also changed. 



Phone #1

Contains the account user's telephone, modem, or fax number. 

This box is not used by Mail. Entries are optional and for your information only. 



Phone #2

Contains the account user's telephone, modem, or fax number. 

This box is not used by Mail. Entries are optional and for your information only. 



Office

Contains the location of the account user's office.

This box is not used by Mail. Entries are optional and for your information only. 



Department

Contains the name of the department where the account user works.

This box is not used by Mail. Entries are optional and for your information only.



Notes

Contains any information you want to keep with this account.

This box is not used by Mail. Entries are optional and for your information only.



Add User

Use this dialog box to add a new user to your postoffice. For information on the dialog box, choose one 
of the following topics:
 Name
 Mailbox
 Password
 Phone #1
 Phone #2
 Office
 Department
 Notes



Shared Folders

Use the Shared Folders dialog box to view the status of shared folders on your postoffice and to 
compress them.

To recover the disk space occupied by recoverable bytes in folders, choose the Compress button. 



Using the Address List

The Address Book lists users in your postoffice. You can also access your Personal Address Book from 
it.

To add recipients from the address list

1. Choose the Compose button, or from the Mail menu, choose Compose Note (ALT, M, N).

2. Choose the Address button to display the Address Book with the list of users in your postoffice.

3. Press a key to scroll the list to the first name beginning with that letter. To scroll to another letter, 
press BACKSPACE and then the letter.

To find a name, choose the Search button  or press CTRL+F.

4. To add names from the address list to the To or Cc box, do one of the following:
Select the name in the address list and choose the To or Cc button.
Double-click the name in the address list to add it to the box whose button is highlighted in the 

Add area of the dialog box.
Drag the name from the address list to the To or Cc box.
Press TAB to move the insertion point to the To or Cc box and type the names, separated by 

semicolons (;).

To remove a name, select it and press the BACKSPACE or DEL key.

5. To return to the Send Note form, choose OK.

To add recipients from your Personal Address Book

1. In the Address Book, choose the Personal Address Book button  or press CTRL+P.

Your Personal Address Book shows the users you've selected from the address list. It also contains the 
personal groups you've created.
2. Select the recipients and choose the To or Cc button.

See Also

Creating or Modifying a Personal Group

Getting Details About a User

Updating Your Personal Address Book

Verifying User Names



Directory button      

Choose the Directory button to choose either the postoffice list or your Personal Address Book.

The mail directory that is currently open is selected. To open another directory, select it and 
choose the OK button.



Personal Address Book button    

You can store the names of people you frequently send messages to in your Personal Address Book.

Your Personal Address Book can contain any name in the postoffice list.



Updating Your Personal Address Book

To add a name to your Personal Address Book

1. From the Mail menu, choose Address Book (ALT, M, D).

2. From the address list, select the name and choose the  Add Names button or press CTRL+A.

3. To close the Personal Address Book, press the ESC key.

You can also add names to your Personal Address Book when composing a message by selecting the 
names in the Address Book and choosing the Add Names button (CTRL+A).

To remove a name from your Personal Address Book

1. From the Mail menu, choose Address Book (ALT, M, D).

2. Choose the  Personal Address Book button or press CTRL+P.

3. Select the name that you want to remove.
4. Choose the Remove button.

You can also remove names from your Personal Address Book when composing a message by 
choosing the Personal Address Book button, selecting the names in the address list, and choosing the 
Remove button.

See Also

Creating or Modifying a Personal Group

Using Mail's Address List



Add Names button

 

Choose the Add Names button to add a name to your Personal Address Book.



Attaching a File

You can attach a file to a message with the Attach button, or you can drag the file from the File Manager 
to a message. 

To attach a file

1. Choose the Compose button, or from the Mail menu, choose Compose (ALT, M, N).

2. Move the insertion point to the location in the body of the message where you want the file icon to 
appear.

If you don't specify a location, the file icon is inserted at the beginning of the message.

3. Choose the Attach button.

4. In the Attach dialog box, type the path and filename in the File Name box, or select a file by using 
the Drives and Directories boxes, and then choose the Attach button.

The file's icon appears in the message body.

5. Repeat step 4 until you have attached all the files you want, and then choose the Close button.

To drag a file from the File Manager

1. Choose the Compose button, or from the Mail menu choose Compose Note (ALT, M, N).

2. Display the File Manager window.

3. In the File Manager, locate the file you want to attach to the message.

4. Drag the file icon where you want it to appear in the message.

You can drag a file icon from the File Manager to the Outbox on Mail's workspace. When you drop the 
file icon, a Send Note form appears, with the file icon in the message body.

See Also

Copying Information Between Messages

Embedding an Object in a Message



Backing Up and Restoring Your Message File

To back up your message file

1. From the Mail menu, choose Backup (ALT, M, B).

2. In the File Name box, specify where you want the backup stored.

3. Choose the OK button.

To restore a backup message file

If you try to start Mail and it can't locate your message file, a dialog box appears asking you to choose a 
message file. 

1. Locate the backup file.

Mail asks if you want to convert the backup file to your message file.

2. Choose the OK button.

The backup file becomes your message file, and your mailbox opens to display the messages and 
folders you had when you backed up the file. New messages you receive will be added to the 
Inbox.

If you don't convert the backup file, you can read the messages in the file, delete them, and move them 
to folders. However, you won't be able to send or receive new messages.

See Also

Exporting Mail Folders

Importing Mail Folders

Signing In to or Out of Mail

Working Offline



Changing Your Password

To change your password

1. From the Mail menu, choose Change Password (ALT, M, C).

2. Type your old password and press TAB.

For security, you do not see the characters as you type them.

3. Type your new password and press TAB. Passwords are case sensitive.

4. To verify the new password, type it again and choose the OK button.

The OK button remains unavailable until your new password and the verification of your new 
password match exactly. 

Your new password is registered; you'll be required to use it the next time you sign in to Mail.

See Also

Signing Into or Out of Mail



Copying Information from a File

To copy information from a file

1. Open the file that contains the information.

2. Select the information you want to copy.

3. From the Edit menu, choose Copy.

Mail copies the information to the Clipboard.

4. Switch to the message you are composing, or open a new Send Note form.

5. In the body of the message, move the insertion point to the location where you want to paste the 
information.

6. From the Edit menu, choose Paste (ALT, E, P).

You can use this procedure to copy information from an MS-DOS application if the application can 
access the Clipboard. See the application's documentation for information about using the Clipboard.

To copy text from a text file into a message

1. From the Edit menu, choose Insert From File (ALT, E, F).

2. Select the text file you want to copy into the message.

3. Choose the OK button.

The entire contents of the text file are copied into the message.

See Also

Attaching a File

Copying Information Between Messages

Embedding an Object in a Message



Copying Information Between Messages

To copy information from another message

1. Display the message you want to copy from.

2. Select the information you want to copy.

3. From the Edit menu, choose Copy (ALT, E, C), and then close the message by pressing ESC.

4. From the Window menu, choose the message you are composing, or choose the Compose button 
(CTRL+N) to display a new Send Note form.

5. Move the insertion point to the location where you want to paste the information.

6. From the Edit menu, choose Paste (ALT, E, P), or press CTRL+V.

See Also

Copying Information from a File

Embedding an Object in a Message



Creating a Folder or Subfolder

To create a folder

1. With the Folders list displayed, choose New Folder from the File menu (ALT, F, N).

2. In the Name box, type a name for the folder.

A folder name can consist of any combination of characters and spaces. 

3. Under Type, select Private or Shared.

4. To assign access permissions to a shared folder, choose the Options button, and then select the 
permissions in the Other Users Can box.

5. Choose the OK button.

The folder is included in the Folders list in alphabetic order.

To rename a folder

1. In the folder list, select the folder name you want to change.

2. From the File menu, choose Folder Properties (ALT, F, F).

3. Type the new folder name, and then choose the OK button.

To create a subfolder

1. From the New Folder dialog box, choose the Options button.

2. In the Name box, type a name for the subfolder.

3. Under Level, select the Subfolder Of option button, select a folder, and then choose the OK button.

If a folder is selected in the folder list, any new folder you create is a subfolder of the selected folder.

To make a subfolder a top-level folder

1. Select the folder you want to move.

2. From the File menu, choose Folder Properties (ALT, F, F).

3. In the Folder Properties dialog box, select the Top Level Folder option, and then choose the OK 
button.

See Also

Deleting a Folder

Expanding and Collapsing Folders

Moving a Folder Within a Folder

Moving Messages Between Folders



Private Folder

A folder that is available only to the person who creates it.



Shared Folder

A folder that is available to anyone who can connect to the postoffice. 

The person who creates a shared folder can define other users' access to read, edit (write), or delete 
messages contained in the folder. By default, other users have read and write access. 



Creating or Modifying a Personal Group

To create a personal group

1. From the Mail menu, choose Personal Groups (ALT, M, G).

2. Choose the New button.

3. In the New Group Name box, type a name for the group and choose the Create button.

4. To add names from the address list to your group, select the name(s) and choose the Add button or 
press ALT+A, or type the names directly in the Group Members box.

5. Choose the OK button.

To add or remove a name from a personal group

1. From the Mail menu, choose Personal Groups (ALT, M, G).

2. In the Groups list, select the name of the group you want to modify.

3. Choose the Edit button.

The Address Book appears with the group members listed in the bottom box. 

4. Add or remove a group member:

 To add a name, select it from the address list and then choose the Add button, or type the name 
in the Group Members box.

 To remove a name, select it from the list and press DEL or BACKSPACE.
5. Choose the OK button.
6. Choose the Done button in the Personal Groups dialog box.

See Also

Updating Your Personal Address Book

Using Mail's Address List



Deleting a Folder

To delete a folder

1. In the folders list, select the folder you want to delete.

2. Choose the Delete button, or from the File menu, choose Delete (ALT, F, D).

The messages in the folder and any of its subfolders are moved to the Deleted Mail folder . You 
can retrieve messages and folders from the Deleted Mail folder. 

Depending on the Mail options you have set, the messages are either kept in the Deleted Mail 
folder until you quit Mail, when they are deleted permanently, or they remain in the Deleted Mail 
folder until you empty it.

See Also

Creating a Folder or Subfolder

Deleting or Retrieving a Message

Expanding and Collapsing Folders

Setting Mail Options



Deleting or Retrieving a Message

You can delete a message you are reading, or you can select and delete one or more messages in the 
message list.

To delete a message you are reading

Choose the Delete button, or from the File menu, choose Delete (ALT, F, D).

To delete a message in the message list

Drag the selected message(s) to the Deleted Mail folder.

When you delete a message, the next message in the message list is opened, in chronological order.

To retrieve a deleted message

1. Open the Deleted Mail folder.

2. Select the message(s) you want to retrieve.

3. Drag the message(s) to another folder, or from the File menu, choose Move (ALT, F, M), and select a 
folder from the list.

See Also

Deleting a Folder



Finding a Message

To search for a message

1. From the File menu, choose Message Finder (ALT, F, G).

2. Fill in the boxes with the information you want to find.

Example

3. To specify the folder(s) to be searched, choose the Where to Look button and select all folders or a 
specific folder, then choose the OK button.

4. Choose the Start button.

Mail searches the folder(s) you specified and lists the messages in the order it finds them. 

When the message you're searching for is listed, choose the Stop button.

You can read and process messages in the Message Finder window as you do in any other folder. 
If you delete a message in the Message Finder window, it is also deleted from the folder it is stored 
in.

If you frequently search for messages containing specific information, you can minimize the Message 
Finder window and leave it on the Mail workspace. Then, when you want to find a message, expand the 
window and choose the Start button. You can have as many Message Finder windows as you want.

See Also

Deleting or Retrieving a Message

Reading a Message



Example

You can include multiple criteria in a search box by separating the items with semicolons.

For example, to find messages from Nick Holtz and Pamela McKee with the words "production reports" 
in the subject, you would type "Nick Holtz; Pamela McKee" in the From box and "production reports" in 
the Subject box.



Forwarding a Message

You can forward a message that's either open or selected in the message list.

To forward a message

1. Choose the Forward button, or from the Mail menu, choose Forward (CTRL+F).

2. In the To box, specify the recipient(s) of the message.

3. To add comments, press TAB to move the insertion point to the message body and type.

4. Choose the Send button.

You can also drag the message from the message list to the Outbox. When you drop the message, a 
Send Note form appears with the text of the original message. You can then address the message and 
send it.

See Also

Attaching a File

Replying to a Message

Using Mail's Address List



Getting Detailed Information About a User

To get detailed information about a user

1. From the Mail menu, choose Address Book (ALT, M, D).

2. Select the user's name. 

3. Choose the Details button.

Mail displays the Details dialog box.

You can also get details about a user by double-clicking any name in the Address Book or names in the 
To or Cc boxes in message forms.

See Also

Updating Your Personal Address Book

Using Mail's Address List



Embedding an Object in a Message

To embed an object in a message

1. Open the document that has the information you want to include in the message and copy the 
information to the Clipboard.

2. Switch to Mail.

3. Choose the Compose button, or from the Mail menu, choose Compose Note (ALT, M, N).

4. From the Edit menu, choose Paste Special (ALT, E, S).

5. In the Data Type list, select the object format. 

6. Choose the Paste button.

To create and embed a new object within Mail

1. In the Send Note form, move the insertion point to the location where you want to insert the object.

2. From the Edit menu, choose Insert Object (ALT, E, I).

The Insert Object dialog box lists the Windows-based applications that can create objects.

3. Select the application you want to use and choose the OK button.

The application's window opens on top of the Mail window.

4. Create the object.

5. From the application's File menu, choose Update, or close the application.

The object is inserted in your message.

See Also

Attaching a File

Working with an Embedded Object



Setting Message Options

To set message options

1. In the Send Note window, choose the Options button.

2. Select the options you want:

To receive a return receipt message when a recipient reads your message, select the Return 
Receipt check box. 

To save a copy of the message in the Sent Mail folder, select the Save Sent Messages check 
box.

To set a priority for the message in the recipient's message list, select the High, Normal, or Low 
option.
3. Choose the OK button.

See Also

Sending a Message

Setting Mail Options



Creating and Using a Message Template

To create a message template

1. Choose the Compose button, or from the Mail menu, choose Compose Note (ALT, M, N).

2. Address the message to the people you will be sending it to regularly. 

3. Type the subject and template information.

4. Close the message window by double-clicking the Send Note window's close box or by pressing 
CTRL+F4.

Mail asks if you want to save the message.

5. Choose the Yes button.

To use a message template

1. Display the message for forwarding by doing one of the following:

Select the message, and from the Mail menu, choose Forward (ALT, M, F).

Drag the message header to the Outbox icon.
2. Fill in the message. If necessary, change the list of recipients.
3. Choose the Send button.

You may find it convenient to store all your message templates in a single folder.

See Also

Creating a Folder or Subfolder

Moving Messages Between Folders

Using Mail's Address List



Moving Messages Between Folders

You can move a message that is open or selected in the message list.

To move or copy a message that is open

1. Choose the Move button, or from the File menu, choose Move (ALT, F, M) or Copy (ALT, F, C).

2. In the Move To or Copy To box, select the folder you want to move the message to.

If you want a new folder, choose the New button and type a name for the folder.

3. Choose OK.

To move or copy a selected message

Drag the message from the message list to the folder in the folders list.

When you move a message, the next message in the message list is opened, in chronological order.

See Also

Creating a Folder or Subfolder

Expanding and Collapsing Folders

Moving a Folder Within a Folder



Moving a Folder Within a Folder

To move a folder within a folder

In the folders list, drag the folder you want to move to the folder you want to store it in.

You can also move folders with the Folder Properties command on the File menu.

To promote a subfolder to a top-level folder, drag the subfolder anywhere in the folder list while holding 
down the HOME key.

See Also

Creating a Folder or Subfolder

Expanding and Collapsing Folders

Moving Messages Between Folders



Opening and Saving an Attachment

To open a file attached to a message

In the message body, double-click the file icon.

To save an attached file

1. From the File menu, choose Save Attachment (ALT, F, A).

2. Save the file in one of these ways:

    To save an attached file in the current directory, select it in the Attachments list and choose the Save 
button. If multiple files are attached, you can save all of them in the current directory by choosing the 
Save All button.

    To save a selected file under a different filename, type it in the File Name box.
    To save the file in a different directory, choose the drive and directory where you want to save the file.

3. When you've saved all the files, choose the Done button.

See Also

Attaching a File



Printing a Message

You can print a message that's either open or selected in the message list.

To print a message

1. From the File menu, choose Print (CTRL+P).

The standard Windows Print dialog box is displayed, with the check box for printing multiple 
messages on a page selected. If you don't clear the box, the messages are printed continuously 
without page breaks between them.

2. Choose the OK button.

Embedded objects are printed, but attached files are not. Attached files must be printed from the 
application used to create them.

See Also

Opening and Saving an Attachment

Saving a Message as a Text File



Reading a Message

To quickly display a message with the mouse, double-click its header.

To read a message

1. If necessary, expand the folders list to display the folder with the message you want to read.

2. Open the folder.

3. From the message list, select the message you want to read.

4. Press ENTER, or from the File menu, choose Open (ALT, F, O).

5. If necessary, click the scroll bar or press the PAGE DOWN key to read the entire message.

6. To read other messages in the list, choose the Previous or Next button, or from the View menu, 
choose Previous (ALT, V, P) or Next (ALT, V, N).

7. To close a message window, press ESC or CTRL+F4.

See Also

Deleting or Retrieving a Message

Moving Messages Between Folders

Replying to a Message

Saving a Message as a Text File



Replying to a Message

You can reply to a message that's open or selected in the message list.

To reply to a message

1. Address your message in one of two ways:

To reply only to the sender, choose the Reply button, or from the Mail menu, choose Reply 
(ALT, M, R).

To reply to the sender and everyone in the To and Cc boxes, choose the Reply All button, or from 
the Mail menu choose Reply To All (ALT, M, A).

2. Type your reply.
3. Choose the Send button.

The contents of the original message are included in the message body. You can add your own 
comments to the original, or you can delete the original contents.

See Also

Attaching a File

Forwarding a Message



Saving an Unsent Message

To save an unsent message

1. Double-click the Send Note window's close box, or press CTRL+F4.

Mail asks if you want to save the changes to the message.

2. To close the window and save the message in your Inbox, choose Yes.

You can display the message later and finish composing it.

Messages that you've saved before sending are indicated by the Open Message icon in the message 
list.
    Open Message icon

See Also

Creating and Using a Message Template

Sending a Message



Sending a Message

To send a message

1. Choose the Compose button, or from the Mail menu, choose Compose Note (ALT, M, N).

2. In the To box, type the user name of the recipient.

Separate multiple names with semicolons (;).

You can type the first few characters of a user's name and have Mail supply the rest of the name by 
pressing ALT+K.

3. If you want people to receive courtesy copies, press TAB or ALT+C to move the insertion point to the 
Cc box and type the user names. 

4. Press TAB or ALT+J to move the insertion point to the Subject box and type the subject.

The subject appears in the message list of the recipient's Inbox.

5. Press TAB to move the insertion point to the message body and type your message.

6. Choose the Send button (ALT+S).

A copy of the message is placed in the Sent Mail folder if you've chosen that option from the Options 
command on the Mail menu.

See Also

Attaching a File

Copying Information from a File

Using Mail's Address List



Setting Mail Options

To set Mail options

To display the Options dialog box, choose Options from the Mail menu (ALT, M, O).

To select options applied to messages you send

To keep a copy of every message you send in the Sent Mail folder, select the Save Copy Of 
Outgoing Messages In Sent Mail Folder check box.

To add message recipients to your Personal Address Book, select the Add Recipients To 
Personal Address Book check box.

To select options applied to messages you receive

In the Check For New Mail box, type how often you want Mail to check for new messages.
If you want Mail to notify you audibly when you receive a new message, select the Sound Chime 

check box.
If you want Mail to briefly change the mouse pointer to an envelope icon when you receive a 

message, select the Flash Envelope check box.

To empty the Deleted Mail folder when quitting Mail

Select the Empty Deleted Mail Folder When Exiting check box.

See Also

Setting Message Options

Working Offline



Signing Into or Out of Mail

To sign into Mail

1. From the Main group, double-click the Mail icon.

2. Type your mailbox name and password in the Sign In dialog box.

For security, Mail does not display the characters as you type them in the Password box.

To have Mail sign in automatically

1. Select the Mail icon in the Main group.

2. From the Program Manager File menu, choose Properties (ALT, F, P).

3. On the Command line, following the path statement for MSMAIL32.EXE, type one space and then 
your mailbox name.

4. To have Mail automatically enter your mailbox name and password, after your mailbox name type 
one space and then your password.

To sign out of Mail

From the File menu, choose Exit and Sign Out (ALT, F, T).

If another application that uses the postoffice is running, such as Schedule+, this command closes and 
signs you out of it as well.

To exit but not sign out of Mail

From the File menu, choose Exit (ALT, F, X).

If another application that uses the postoffice is running, such as Schedule+, this command closes Mail 
but leaves you signed in to your mailbox.

If no other applications that use the postoffice are running, this command closes and signs you out of 
Mail.



Saving a Message as a Text File

You can save a message that's open or selected in the message list.

To save a message as a text file

1. From the File menu, choose Save As (ALT, F, S).

In the Save As dialog box, the first eight characters of the message's subject are entered in the 
subject field, followed by the .TXT extension. Unless you type another extension, Mail adds .TXT to 
the filename to remind you that the file is a text file.

2. You can type a new filename in the File Name box, or change the drive or directory.

3. Choose the OK button.

If the filename you specify already exists, you are given the option of replacing the existing file with 
the new file(s) or appending the new file(s) to the existing file.

See Also

Opening and Saving an Attachment



Verifying User Names

To verify a user name

1. In the To or Cc box, type part or all of the message recipient's name.

2. Choose the Check Names button or, if you are ready to send the message, choose the Send 
button.

If you have entered only the first part of a name, Mail fills in the rest of the name. If there are 
multiple names that contain these characters, you are presented with a list of names to choose 
from.

User names that have been verified appear underlined, and cannot be modified.

See Also

Updating Your Personal Address Book

Using Mail's Address List



Copying, Moving, or Deleting Information Within a Message

To copy, move, or delete information

1. Select the information.

2. Do one of the following:

To copy the information to the Clipboard, press CTRL+C.

To move the information to the Clipboard, press CTRL+X.

To delete the information, press DEL.

To paste cut or copied text

1. Move the insertion point to the location in the message where you want the information.

2. From the Edit menu, choose Paste (ALT, E, P), or press CTRL+V.

See Also

Copying Information Between Messages 

Copying Information from a File



Working with an Embedded Object

To modify an object

1. In the message body, double-click the object, or select the object, and from the Edit menu, choose 
the Object command (ALT, E, O).

The application used to create the object opens with the object ready for editing.

2. Edit the object.

3. From the application's File menu, choose the Update command, or close the application.

The object in your Mail message is updated to reflect the changes.

To activate an object

1. In the message body, select the object as you would text.

2. From the Edit menu, choose Object (ALT, E, O).

The menu displays the commands available for working with that object.

3. Choose the command that activates the object.

See Also

Embedding an Object In a Message



Working Offline

The computer you will be working with offline must have Mail and a version of Microsoft Windows 
installed.

Before working offline, you must have your message file on the computer or disk you will be working 
with offline. Your Personal Address Book is copied with the message file.

To work offline

1. Start Mail.

If the computer is not connected to your postoffice, a message appears asking if you want to work 
offline.

2. Choose the OK button.

A dialog box appears, asking for your password. 

3. Type your password, and choose the OK button.

4. If Mail cannot find your message file, you are requested to specify the path to it.

After you finish composing a message, choose the Send button. The message is moved to the Outbox. 
When you connect to your postoffice, the messages in your Outbox are automatically sent.

See Also

Saving an Unsent Message

Signing Into or Out of Mail



Expanding and Collapsing Folders

To expand or collapse a folder

Choose the plus sign beside the folder or subfolder to show its subfolders. Choose the minus sign 
beside a folder or subfolder to hide its subfolders.

To expand or collapse all folders:

To show all folders, press CTRL+PLUS SIGN. To show only the first level of folders, press 
CTRL+MINUS SIGN.

See Also

Creating a Folder or Subfolder

Deleting a Folder

Moving a Folder Within a Folder

Moving Messages Between Folders



To select a single name

Choose the name in the address list.
If necessary, press TAB    to move the highlight to the address list, and then use the arrow keys or 

PAGE UP, PAGE DOWN, HOME, or END to highlight the name you want to add.

To select multiple names

Hold down CTRL, and click each name you want to add. To select a range of names, click the first 
name, hold down SHIFT, and click the last name.



 To find a name

1. In the Address Book, choose the Search button (CTRL+F) 

Mail displays the Name Finder dialog box. 
2. Type the name or the first part of the name you're looking for. Mail searches first and last names.
3. Choose the Find button.

Mail searches the address list for names that start with the characters you typed. If it finds any, 
they are displayed in the Address Book. You can select names from this list and add them to the 
message. 



Outbox

The Outbox is a permanent part of the Mail workspace. When you send a message, it is temporarily 
moved to the Outbox until Mail can send it.

When you are working offline, sent mail is stored in the Outbox until you connect to your 
postoffice and sign in.

You can quickly forward messages and files by dragging them to the Outbox.



To select a file

1. Double-click the filename.

2. To select a different disk drive, choose the down arrow in the box and double-click the drive.

3. To select a different directory path, double-click a directory.



To drag a message

Place the mouse pointer over the selected message(s), hold down the left mouse button, and 
drag the pointer over the folder you want to store the message in. When you release the mouse button, 
the message is moved to the folder. (To leave a copy in the original folder, hold down CTRL and drag.)



Deleted Mail Folder

The Deleted Mail folder is a permanent folder that stores messages you delete. If you display 
the Deleted Mail folder and then minimize it, the Deleted Mail folder icon appears on the Mail 
workspace. Besides using the Delete button or the Delete command on the Edit menu, you 
can delete messages by dragging them either to the Deleted Mail folder or to the Deleted Mail 
folder icon.

The Options command on the Mail menu provides an option to empty the Deleted Mail folder 
when quitting Mail. If this option is selected, you can retrieve a deleted message from the 
Deleted Mail folder until you quit Mail. If the option is not selected, the message stays in the 
Deleted Mail folder until you select and delete it.

Details dialog box

The Details dialog box displays information about a user. This user information is filled in either 
by the administrator or by the user when the account is set up on the postoffice. Once this 
information is entered, only the administrator can change it.

You can change the Name and Comment boxes if you are viewing user details from your 
Personal Address Book. If you change a name, the new name appears in your Personal 
Address Book instead of the Mail user name. You can use this new name to address 
messages.

Folders list

The Folders list displays either your private folders or the shared folders on your postoffice. To change 
the view from private to shared, choose the Private Folders button at the top of the Folders list.

A plus sign (+) indicates that a folder has subfolders. To view the subfolders, choose the plus sign, or 
highlight the folder using the arrow keys and then press the PLUS SIGN key.

A minus sign () indicates that subfolders are displayed. To hide the subfolders, choose the minus sign, 
or highlight the folder using the arrow keys and then press the MINUS SIGN key.

To show or hide all folders, press CTRL+PLUS SIGN or CTRL+MINUS SIGN, respectively.



Attachment

An attachment or attached file is a file that is included with a message. The attachment is displayed in 
the message as an icon representing the type of file it is. For example, a Microsoft Word document is 
represented by the Word icon with the name of the file.

If you have the appropriate application on your computer, you can double-click the icon to view or edit 
the attached file.



 To save a file in a different drive or directory

To select a different drive, choose the down arrow in the Drives box, and then select a drive from 
the list.

To select a different directory path in the Directories box, double-click a directory.



To select a message or multiple messages

Click the message name in the message list.
To select multiple messages, hold down CTRL and click the messages.

To select a range of messages

Do either of the following:
In the message list, drag the pointer in the margin to the left of the message icons.
Select the first message in the range, and then hold down SHIFT and click the last 

message in the range.

Message List 

The message list is the portion of the folder window that displays message headers for the messages in 
the open folder. To move the highlight to the message list, click in the message list with the mouse, or 
press TAB until it is highlighted.



To expand and collapse folders

If the folder has a plus sign (+) next to it, click it to show its subfolders. If the folder has a minus 
sign (-), click it to collapse its subfolders.

To expand all folders in the Folders list

Press TAB to move the highlight to the Folders list and press CTRL+PLUS SIGN.



To open a folder

Double-click the folder.



Clipboard

The Clipboard is a temporary storage area in your computer's memory for cut or copied information.



To select text

Drag with the mouse, or press and hold down SHIFT+arrow keys to highlight the text.



Message file

The message file stores all of your messages and folders. The file has an .MMF extension and is 
stored on your own computer.

You can import folders from another message file or export folders to another message file using the 
Import Folder and Export Folder commands.



User name

A unique name is assigned to each Mail user by the administrator or by the user when the account is 
set up. Use this name to address messages to the user. 

You can either type the name in the To or Cc box in a Send Note form or choose the Address button 
and choose the name from the Address Book.



Sent Mail folder

The Sent Mail folder is a permanent folder in the folder list.

If you want to keep a copy of the messages you send, choose the Options command from the Mail 
menu and select the Save Copy Of Outgoing Messages In Sent Mail Folder check box.



Insertion point

The insertion point is a blinking vertical bar that indicates where text you type appears, or where the 
contents of the Clipboard are placed if you choose the Paste command from the Edit menu.

You position the insertion point by clicking with the mouse or by using the arrow keys.



Inbox

The Inbox folder is a permanent folder in the Folders list; you can't delete it.

New messages you receive are stored in the Inbox.



Postoffice

The postoffice is a directory on one of the computers in your workgroup. The postoffice stores the 
Mail files that establish and control access to Mail. 

If the computer that has the postoffice is not online, you can still work with Mail but you cannot send 
or receive messages.



Password

Your password is a word or group of characters that you type to gain access to your mail. You enter 
your password when you sign in to Mail the first time. If an account has already been set up for you, 
your administrator may have given you a password already. After signing in the first time, you should 
change your password to one that is easy to remember.



Checking the Spelling of a Mail Message

You can check the spelling of a mail message before you send it. 

To check the spelling of a mail message

1. From the Edit menu, choose Spelling, or press F7. The Compose Note window must be active. 

2. The spelling check starts automatically. If Mail finds a word that does not appear in its dictionary, it 
highlights the word in the message text and prompts you to change the word, ignore it, or add it to 
the dictionary. Choose the button that corresponds to your choice. 

If you want Mail to suggest an alternate word, choose the Suggest button. If you want Mail always 
to suggest an alternate word, select the Always Suggest check box. If you want Mail always to 
ignore words that appear in all uppercase, select the Ignore All UPPERCASE checkbox. 

3. To stop the spelling check before it is finished, choose the Cancel button. 




