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File menu commands

The File menu offers the following commands:

Read Read a 3D object or image from a file.

Save As Save the current 3D scene or object. 

Render to 
file

Render current scene to DIB/BMP file in arbitrary resolution.

New Creates a new 3d object using the New Object Dialog

New Font 
Logo

Creates a new 3d object from a text string using the New Font 
Logo Dialog

Exit Exits GLView.

Next:
View Menu



New object dialog

With this dialog predefined 3D objects can be created. 
The New object dialog offers the following options:

Type The type of object to be created.

Predefined objects :
Meshes:
ronny, icosahedron, wheel,cylinder,
cylindery,spherey,coney VRML conform aligned at the Y-axis
Surface objects: sphere suface, cylinder surfaces ,plane
recursive subdivision objects:sphere(r,stepsx),
VRML objects:
„height field from image“ creates a GLView VRML image height 
field node.

Steps x The number of subdivision in the horizontal (x) direction or the u 
direction for surface objects.
(or the number of recursive subdivision steps for sphere)

Steps y The number of subdivision in the horizontal (y) direction or the v 
direction for surfaces objects.

Umin 
-umax,
vmin -vmax

the parameter range in the u and v direction, valid for surface types 
like    sphere surface, plane.

Radius the radius for objects like a cylinder, sphere.

Height the height for objects like a cylinder

Next:
New Font Logo Dialog



New font logo dialog

With this dialog a 3D logo out of a arbitrary string of text and a Windows installed TrueType font can be 
created.
The New font logo dialog offers the following options:

Text a string, multiple lines are supported.

Font pop ups a font selection dialog, to specify the type of True Type 
font used for creating 3D Data.

Extrude if checked the 2D text outline will be extruded in the z direction, 
otherwise the text will be created as a set of flat polygons.

Extrusion 
factor

the amount of extrusion in the z-direction.

Top if checked, the top set of faces of the extruded solids are 
generated.

Bottom if checked, the bottom set of faces of the extruded solids are 
generated.

Invert if checked the text outline will be subtracted from an enclosing 
rectangle, to create an "inverted" like effect. (For some letters like i 
or fonts with self intersecting outlines this may no work correctly)

invert size a scale factor relative to the bounding box of the cube for the 
enclosing rectangle (> 1.0)

Texture 
Parameters

normallly a xy parameter generation function will work for texture 
mapping of font objects.
If checked for better results for the side facets of extruded objects, 
the texture will properly wrapped along the character outlines.

Align Changes Text Alignment
Outline only Only the outlines are computed, the resulting geometry if written to 

a VRML file will be an IndexedLineSet, otherwise an 
IndexedFaceSet.

Next:
View Menu



Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Link Pastes from the clipboard a link to data in another application.
Insert New 
Object

Inserts and embeds an object, such as a chart or an equation in a document.

Links List and edit links to embedded documents.



WWW menu commands

The WWW menu offers the following commands:

Open Url Opens a WWW VRML url using the Open URL Dialog

Load all 
inlines 

If the scene contains unreaded references to other files (local or 
remote), these files will be loaded. (Usefull if LOD Nodes are 
combined with WWWInline.)

Abort Load The current Network operation will be canceld. This is the same as 
the stop button in the toolbar. The button is gray if there is currently 
no background operation.

Reload Reload current scene, if scene has a URL it will be reloaded from 
host. Inlines, textures and anchors, will not be reloaded from host. 
Disable WWW->Options->use files from cache instead if you want 
to completely refresh a cached copy of the scene.

Options Changes WWW / VRML Options    using the WWW Options Dialog

Next:
View Menu



Open URL dialog

With this dialog access to World-Wide-Web 3D Vrml scenes is managed 
The Open URL dialog offers the following options:

URL Enter a URL here, as soon <Enter> is pressed GLView tries to 
connect to the specified host and to retreive the file.
Also a local filename can be entered. 
You can copy and paste a VRML url from your Web-Browser into 
this edit field using CTRL-V. For Netscape you can use the right 
mouse button menu and select "Copy this link location". GLView 
currently supports the http: and ftp protocol.

History Displays the list of recently opened documents.
A single click on a entry copies the entry to the URL edit field, a 
double-click directly loads the document.

Add Files to 
History

If checked local files are added to the history, otherwise only WWW 
URL's.

Save 
History

the whole history is saved to disk. Normaly done automatically.

Clear 
History

The history list is cleared.

OK The specified URL is loaded

Next:
View Menu



WWW / VRML options dialog

The WWW Options    dialog offers the following options:

Inline 
Loading

A VRML file can contain references to other VRML or Texture files. 
For a complex scene with many references this may take time. If 
"never" is selected references are not expanded, GLView displays 
unloaded Inlines with a wireframe box, if this box has been 
specified by the author. "if needed" means the rendering engine 
decides when to load a inline, "always" will load all inlines. Loading 
of texture files is still delayed, until Texture Mapping is enabled with 
Rendering->textured. 

Starting 
Texture 
Load

A VRML file can contain references to texture image files. These 
files tend to be large, much larger than the VRML file itself. Texture 
display loading and rendering can be requested using the Render-
>Textured command or the corresponding toolbar button. This flag 
specifies the inital texture load mode. "Don´t load" loads Textures 
only after a request, "ask" will ask after the scene loading, and 
always will directly load the textures. Default : Always

max inline 
level

Inlines can be deeply nested, or might containing a loop of 
references. This parameters specifies a maximum inline loading 
level.

Use *** A VRML file can contain ShapeHints nodes controlling backface 
culling, light sources, cameras, backgrounds or materials. 
Unchecking one of these check boxes disables the corresponding 
VRML nodes, GLView global settings will then be used. Disabling 
of VRML lights is recommended, if the scene contains many lights, 
affecting rendering performance or resulting into a too bright image.

Keep Host 
Connection

If checked the socket connection to the WWW host is maintained. 
Usally a scene contains inlinine objects refering the same host, so 
Network performance is improved. 

Incremental 
updates

During inline loading / texture loading a incremental display update 
is done. If multithreading is enabled (default) this option is not 
necessary, because new elements are added to the scene 
automatically.

Use files 
from 
GLView 
cache

If checked, GLView tries to load a URL file from the cache directory, 
instead of retreiving it from the Internet. 
Example usage : a complex WRL scene has been partly retreived 
from the Internet. Load the scene using the "scene.wrl.vrl" url file. 
Already transfered inlines + textures will be read from the cache, 
missing ones from the Internet. Checked by default.

Autoplay 
animations

If checked (default) a scene containing animation (i.e. VRML 2.0 
TimeSensors or GLView animation nodes), the animation is started 
at the loading of the file.

Cache 
Directory

Specify a unique directory here, where GLView can store Internet 
files and which also serves as a cache for future reuse. GLView will 



store all retreived URL´s into this directory.
You can    manually delete files from this directory, if you need more 
disc-space. The vrl files are containing the orginal URL location of a 
file, they can be copied to create a personal hot list directory.
These VRL files can be dropped from the Explorer or file manager 
into GLView, if the corresponding datafile is present, the scene is 
loading from cache, missing URL´s are beeing retreived from the 
internet. GLView currently also unzip´s all compressed data-set´s.

Email 
address

Your email address (for retreiving FTP files and future networking 
enhancements.)

Path To 
WWW 
Browser

The full pathame to your WorldWideWeb Browser, GLView will 
spawn this program for viewing HTML files or URL´s with unknown 
MIME-type.. If Netscape is running, GLView will use DDE to force 
the WWW-Browser to display unhandled urls´s.

Light Scale a global scale factor    affecting the intensity of VRML scene lights. 
If you enable VRML scene lights, the scene might look to bright, 
because the scene author has used too many or too bright ligts, 
use the scale factor to dim down these lights. (Default 1.0)

Internet 
Config ...

Opens the Internet configuration dialog.

OK, Apply The changes are applied

The Internet configuration dialog offers the following options:

Access 
Type
preconfig

if enabled (the default) internet configuration settings (like proxy 
configuration) from the Windows Control-Panel settings are used. 

Use proxy if enabled the fields below specify proxy information
Proxy 
server

Name of the proxy server.
By default, its assumed that the specified proxy is a CERN 
proxy. For example, "proxy" defaults to a CERN proxy called 
"proxy" that listens at port 80 (decimal). More than one proxy 
can be specified, including different proxies for the different 
protocols. For example, if you specify "ftp=ftp://ftp-gw proxy:21", 
FTP requests are made through the FTP proxy "ftp-gw" which 
listens at port 21 (default for FTP). All other requests (for 
example, HTTP requests) are made through the CERN proxy 
called "proxy" which listens at port 80. 

Proxy 
bypass

An optional list of host names or IP addresses, or both, that are 
known locally. Requests to these names are not routed through 
the proxy. The list can contain wildcards, such as "157.55.* 
*int*", meaning any IP address starting with 157.55, or any name 
containing the substring "int", will bypass the proxy. 

If this parameter specifies the "<local>" macro as the only entry, the 
function bypasses any host name that does not contain a period. 
For example, "www.microsoft.com" would be routed to the proxy, 
whereas "internet" would not. 

Num GLView use multiple threads for reading internet data, higher 



Threads numbers means more parallel internet sessions. The minimum 
must be 1 thread, the default is 5.

It is currently not possible to change the proxy parameters after an internet access from GLView has 
already occured. The workaroud is, to change these settings, and restart GLView.

Next:
View Menu



View menu commands

The View menu offers the following commands:

Tool Bar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Url Bar Shows or hides the Url bar.

Next:
Camera Menu



Pixelformat menu commands

The Pixelformat menu offers the following commands:

Set Shows the Set Pixelformat dialog. Once a Pixelformat has been 
choosen, it can not be changed, restart GLView with the /x option.

Info Shows short information about the number of available pixelformats

Enumerate Shows the Set Pixelformat dialog, to allow a browse through all 
available pixelformats

Next:
Camera Menu



Camera menu commands

The Camera menu changes the camera action associated with a mouse drag operation in the drawing 
area.
The Camera menu offers the following commands:

Reset Reset the camera to view the whole object in the xy plane from the 
+z direction.This function is also recommended after loading of a 
VRML scene with a strange camera or with a camera viewing 
empty space. Reset will also compute proper values for the camera 
target distance, near and far clipping planes.
After reset you can always use the Orbit camera mode, because 
the camera target point is in the center of the model.

Viewpoints 
....

The camera viewing parameters can be manually changed. For 
VRML scenes containing multiple cameras, a predefined camera 
can be choosen. The Z distance parameter is related to the walking 
speed, change it if the walk speed is to small or large. For inside of 
a room type scenes is usefull to enter hight view angles e.g. like 90 
or higher.
This dialog can be activated by pressing the space bar.

Move Move the camera with the mouse horizontal / vertical

Rotate Rotate the camera with the mouse horizontal / vertical around the 
center, 
Shift: zoom horizontal, 
Control:Move horizontal/vertical

Turn Turn the camera with the mouse left-right / up-down around the 
position

Zoom Change the zoom scale with the    the mouse horizontal

Roll Rotate the camera orientation (up direction) with the mouse 
horizontal 

Walk Turn the camera with the mouse left-right horizontal, 
Move in-out vertical
Shift :move horizontal/vertical: 
Control : pan up/down /left right

Fly Similar to walk, but a two-click walk. The first click turns on walking, 
move the mouse to change direction, second click stops moving.

Relative 
Move

If enabled camera movements Walk/Fly/Pan are relative to the 
current viewing direction. 
If disabled movement is relative to a global world up direction. 
These World-Up direction is derived from the selected VRML 
camera (Y by default). Note VRML scenes use normally Y as up, 
instead of Z. The world-up direction can be edited using the 
Camera->Viewpoint dialog.
This mode is more convienient to walk around in in room type 
scenes or scenes with some ground plane.

Spin If checked automatically rotate the camera until a mouse button is 



pressed.

Auto Spin If checked GLView automatically enters Spin mode after a while. 
This mode can be enabled automatically at start up using the 
Options->Config dialog.

Animate 
Viewpoints 

Activating this function will do a automatic fly through all viewpoints 
defined in a VRML scene or the viewpoints which had been 
manually created using the Viewpoint dialog->Save new function.

Next:
Rendering Menu



Right mouse button menu

A click with with the right mouse button in the view area displays a menu with commonly used functions:

Next 
Viewpoint

Sets or animates to the next predefined viewpoint. If the current 
viewpoint is the last, a wrap to the first viewpoint occurs.

Prev 
Viewpoint

Sets or animates to the previous viewpoint. If the current viewpoint 
is the first, a wrap to the last viewpoint occurs.

Viewpoint
s ....

Opens the viewpoint dialog.
This dialog can be activated also by pressing the space bar or by 
using the entry in the camera menu.

Seek to The camera is moved to the object at the mouse position. 
The position at the time the right mouse button was pressed is used, 
allowing quick access using only one mouse click. 
This function will also set the orbit center to the computed 
intersection point, afterwards the Orbit navigation mode can be used 
to walk around the selected object. 

Camera ... Opens the Camera menu

Render ... Opens the Rendering menu.

Tools... Open the Tools menu.



Rendering menu commands

With the Rendering menu, the type of rendering    is choosen.
The Rendering menu offers the following commands:
Some options are only available in the OpenGL version.

Options Shows the Rendering Options sub-menu.

Style Shows the Rendering Style Dialog. 
The rendering settings for vertices, edges, faces, bounding boxes 
and normals can be specified in detail.

Animate Toggles Animation On/Off, also available as Toolbar button.

Time Shows the Time Dialog
Change of animation time paramters, usefull if the currently loaded 
VRML scene contains GLView animation nodes or for VRML 2.0 
scenes.

Wireframe Changes the rendering style to wireframe, only the edges of the 
model are displayed.

Vertices Changes the rendering style to vertices, only the vertices of the 
model are displayed.

Boxes Changes the rendering style to bounding boxes, only the bounding 
box of each object in the scene tree is displayed.

Solid Changes the rendering style to solid. Edges and faces of the model 
are displayed, lights are turned off.

Non 
Lighted

Changes the rendering style to non lighted. The faces of the model 
are displayed but not lighted. In order to have a visible contrast 
between faces, the scene should have enabled textures or color 
settings per face or vertex. This mode is faster that the lighted 
modes and also faster as solid.
For certain scenes with lighting already precomputed using 
radiosity this mode is also recommended.

Flat Changes the rendering style to flat. The faces of the model are 
displayed and are flat lighted.

Gouraud Changes the rendering style to gouraud. The faces of the model 
are displayed and are smooth lighted. GLView automatically 
calculates the required vertex normals.

Lighted If checked, edges or vertices are lighted for rendering modes 
wireframe and vertices.

Colored If checked, the model will be rendered with local vertex colors, if 
available in the dataset. If there are no local vertex colors but local 
face colors, faces will be individually colored.

Textured If checked, the model will be textured, if a texture has been read in 
with Material->LoadTexture or texture nodes are present in a VRML 



scene.

Normals If checked, vertex normals will be displayed as lines at the model 
vertices.

Related:
Rendering Style Dialog

Next:
Rendering Options Menu



Rendering Options menu commands

With the Rendering Options menu, rendering atttributes can be changed.
The Rendering Options menu offers the following commands:

Backface 
Cull

Toggles automatic removal of backfacing facets, enabled by 
default. (If the model looks wrong after input, disable or flip 
backface culling)
.

Reverse. 
Culling

Reverse the type of facets removed by backface culling, has a 
effect only if Backface Cull is enabled.

Flip Object 
Normals

Flip the direction of    the objects normals. Useful if the object 
appears very dark after import from GEO or RAW files.

2 Sided 
Lighting

If checked, 2 sided lighting is enabled.

Local 
Viewer

If checked, the model will be rendered with local viewer lighting 
applied.

Antialiased 
Lines

Wireframe Rendering will be rendered anti-aliased. This takes 
more time to render.

Transparen
cy

Work in progress: For VRML files containing materials with 
transparency, this will enable transparency using a "delayed blend" 
approach.

Next:
Material Menu



Rendering Style dialog

With the Rendering Style dialog detailed rendering settings can be independently changed for vertices 
edges face and normals.
The Rendering Style dialog    offers the following options:

visible check if item should be visible

lighted check if item should be lighted if lightsources are enabled

smooth check if item should be smooth shaded, i.e. color of face is 
smoothly interpolated depending on light-effect at corners. For 
edges lighted and smooth should usually be checked together.

Textured check if item should be textured. In this context the effect is that 
object vertex texture parameters are used if available.

Colored check if item should be rendered using local object per vertex or 
face color information, otherwise or local information is not present 
global settings are used.

Color if checked color from the color edit field is used, otherwise the 
global material setting applies. This can be used to render faces 
and edges together    with different diffuse colors.

Color Color edit field (R G B number). Can be edited with the color dialog 
using the Color ... pushbutton.

Draw Style Popups the Drawstyle dialog.
Currently fully implemented only for vertex items.
A symbol like a sphere or cube can be rendered at each vertex, 
which for many vertices in the model need much more time to 
render.

Next:
Material Menu



Time dialog

Using this dialog the current animation time parameters can be controled.

Start/Stop This button toggles animation on/off. Available also in Toolbar.

T the current time.

Pause Pauses animation at current time, the time slider below can be 
used to drag through time.

t0 t1 Animation start and ending time.

Dt animation time step, For high speed machines this value should be 
lowered e.g. from 0.1 to 0.05 or 0.01.

play 
realtime

instead of t / dt / to/t1    the current system time is used as 
animation clock.
This is the default setting and also recommeded for playing VRML 
2.0 animations.

Wrap automatically cycles the animation

Related:

Next:
Options Menu



Material menu commands

The Material menu offers the following commands:

Edit Shows the Material Edit dialogbox. 
Individual material colors can be edited by entering a    Red 
Green Blue Tripple, or by using the Edit Button. For more 
information about the parameters read about the OpenGL 
function glMaterial. To change the "basic" color use the diffuse 
entry, to change the highlight color, use the specular entry.

Load Loads a Material Setting from a file. The file format is 
compatible with Silicon Graphics Inventor Material files.

Background Changes the background color using the color dialog. Can be 
overriden by specifying a DEF Background Info { string "r g b"} 
in a VRML 1.0 file or by using a Background node in VRML 2.0.

Background 
Image

Sets or changes a background image.

Clear 
Background

Clears the current background image.

Fog Changes Fog Options

Load Texture Loads a Texture image from a file. Currently DIB,BMP, GIF, 
TGA, JPEG, PPM and RGB image files are supported.
If the model has no texture vertex parameters, a default xy 
projection is used. Use Rendering->Textured commandto 
enable/disable texture mapping.

Texture 
Options

Changes Texture Mapping Options, including GL mapping 
function, repeat options and texture transformation matrix.
Texture Options Dialog

Parameter Opens the Parameter Dialog to apply custom texture vertex 
parameters computation to the current object.

Related:
Rendering Menu
Texture Options Dialog
Next:
Options Menu



Texture Options (Material Menu)

Use this dialogbox to change OpenGL texture mapping options. For VRML scenes containing Textures 
and Texturecoordinates entry Type should be set to <none> and the transformation values to the default 
ones.
Type Choose a GL texture parameter function.

Min-Filter Changes the pixel interpolation function for texture minification. 
nearest or mipmap_nearest_nearest is the fastest mode.

Mag-Filter Changes the pixel interpolation function for texture magnification, 
e.g. if you zoom in near a object. nearest is the fastest mode, 
bilinear gives a better quality image, but is slower.

Repeat Choose, if texture should be repeated in x and y parameter 
direction

Scale 
Rotate 
Translate

Sets the texture matrix, using scale the texture repetition can be 
changed

max texture 
size

specifies an upper limit on texture size. If texture image files takes 
up too much memory because there are many different or large 
images, in memory textures are scaled down to this numer. Should 
be a power of two.

Perspective 
correction

Choose, if texture looks distored or seems to randomly jump on 
camera movements. No perspective correction is faster.

Related:
Rendering Menu
Material Menu



Parameter dialog

With the parameter dialog texture mapping parameters are assigned to each vertex of the current object. 
Parameters are associated with a GLView object and can be stored to or    retreived from a GLView data-
file.    GL texture generation function must be disabled, in order to use the objects parameters or texture 
mapping. Paramter generations is currently only supported for a single object scene, resulting from the 
loading of a 3DV / OBJ /GEO/RAW file or after Tools->Combine has been applied for DXF/VRML scenes.

The parameter dialog    offers the following options:

surface The type of 2D surface the object is mapped on
xyz: the xyplane
xzy the xzplane
sphere a surrounding sphere
cylinder a surrounding cylinder

source object input data for computing parameters,
native: objects xyz coordinate or uv rectangle for quad mesh 
surfaces (Default)
vertex color: the current per vertex colors (if any)
vertex normals: the current per vertex normals
vertex parameters: the current per vertex parameters (if any)

function type of mapping from input data to parameter space e.g. plane,    
sphere
normally project, meaning map each vertex to the nearest point on 
the surrounding surface.

mapping additional mapping function (experimental)

normalize 
to object 
bounds

if checked vertex input data will be first normalized from the objects 
bounding box to a -1 1 unit cube. Should normally be enabled.

scale
rotate
translate

additional parameter transformation.

enable Check this to enable the parameter computation, make sure that 
the GL-Texture Options „function“ is switched to <None>

Apply apply current settings, but leave dialog open.

Next:
Material Menu



Tools menu commands

The Tools menu offers the following commands:

Tree Editor Opens the Tree Editor Dialog

Morph Opens the Morph Dialog
If a VRML scene containing a GLView Morph node has been 
loaded the first morph node will be edited. (E.g Morphed.*.wrl)
For single object scenes (3DV Files) a VRML scene with a Morph 
Node will be constructed.

Defom Opens the Deform Menu

Combine If the current model is stored in a tree-database (i.e. after DXF or 
VRML-Input), this tree database is combined into one single object. 
This usually results in faster rendering performance, but some 
scene attributes like textures, inlines and animation nodes are lost.

Triangulate All facets of the current object are converted to triangular facets. 
Usefull after a object with convex facets or facets with attached 
holes has been imported.

Info Display information about the current object like number of vertices 
and facets / triangles, window size, render time...

Related:
Deform Menu
Next:
Options Menu



Deform menu commands

The Deform menu offers the following commands:

Sphere Opens the Deform Sphere Dialog .

Related:

Next:
Options Menu



Tree Editor dialog
The Tree Editor windows allows the inspection of the VRML scene tree.
Double-Clicking on a item displays further sub-items:

Item                       Subitem  
Group-Node child nodes
Node fields
MF-Fields MF-Field field elements

Nodes contained in Group-Nodes can be arbitray dragged and dropped. Cut & Copy & Paste allows 
arbitrary structure modification. Please note that Paste dosn´t include a copy of the copied / cut node but 
a reference. This is equivalent of writing "USE Node" in a VRML ascii file.
GLView will automatically name unnamed nodes, if you paste a node a second time into the tree.

File
View Use refresh, if after naming / renaming nodes, the display might be 

out of sync.

Node

Field Edit, edit the field value of a SFField

Related:

Next:
Morph Dialog
Options Menu



Morph dialog
The Morph object modifies an object vertex coordinates, depending on time. Morphing looks best with 
highresolution objects, with "use normals" enabled.

Type Type of morphing:
Sphere: the object is morphed into a sphere
Cylinder: the objects is morphed into a cylinder
Box: the object is morphed into a Box
Melt: apply the Melt effect from, Glenn M. Lewis, Dr. 
Dobbs'Journal, 07 1994 P.g 86

use 
normals

if checked a hermite like interpolation function will be used, other 
wise a linear one.

Normal 
scale

scale factors for the normals

radius another scale factor for the destination

Related:

Next:
Options Menu



Deform sphere dialog

Works currenlty with single object scenes only. (3DV, Tools->comine).

A immaginery sphere will be installed in the scene, all object points inside the sphere will be attracted to 
the sphere center / or will be pushed away (depending on factor). Can give funny effects on objects like 
ronny or cow. Like parameter this effect only works on single object scenes.

The Deform sphere dialog offers the following commands:

enable if checked, the deform sphere will be enabled, uncheck it to disable 
sphere.

Drag if checked, the deform sphere can be translated with the mouse, 
after the dialog has been closed. After a camera menu options this 
drag option has to be rechecked in order to translate the sphere.

Center / 
radius

parameters of sphere

factor amount of deforming <1 modest >1 large, <0 reverses direction

Related:

Next:
Options Menu



Options menu commands

The Options menu offers the following commands:

Register 
Filetypes

Allows the optional association of GLView with different file 
extensions in the Windows system Registry.

Config Opens the .Configuration Dialog.

OpenGL :
Pixelformat Opens the Pixelformat Submenu Dialog submenu. 

GL Info Displays a dialog with information about the currently used 
OpenGL driver. E.g. to find out, if the OpenGL Graphics is 
accelerated or not. 

Direct 3D :
Direct 3D Opens the Direct 3D configuration Dialog dialog. 

Fullscreen Switches to Direct 3D fullscreen mode, fullscreen mode can be 
terminated using the <ESCAPE> key. 

Config dialog

The config options dialog    offers the following options:

print time if checked render time after each update will be displayed in the 
status bar.

Degrade If enabled GLView will switch during camera mouse movements to 
a different render mode, for faster feedback. Degrade mode 
BoundingBox is recommended for complex VRML worlds.

Save 
window 
size 

if checked, GLView will save the last window size at program end. 

Win size x/y An inital window size can be specified x> =320,    y>= 200. 0 means 
using Windows defaults, >2048 means maximized. Using a smaller 
size is reommended if GLVIew is called from an external WWW 
Browser and the systems rendering speed is limited using a large 
window size.
.

enable 
autospin 

if checked, GLView starts with AutoSpin enabled. 

The following options are currently only meaningfull for the OpenGL version
Build 
triangles 
strips

build triangle strips for objects on file import. This could give better 
performance on some type of objects.

Use gl 
cache

Internally an OpenGl -display list for object will be build after each 
change, and reused if only some settings like camera are changed. 
(non recommended for VRML scenes with "Logic")

use gl A gl-implementation may support extensions like the VERTEX 



extensions ARRAY extension, if checked GLView will use such extensions.

Draw 
directly to 
screen

normally rendering is done to an invisible background image buffer, 
which will be made visible by copying the pixel-content to the 
screen, at the end of the rendering cylce. If checked rendering 
occurs triangle by triangle directly on the screen. Usefull    for 
compare speed e.g. Wireframe GDI versus OGL, or for big scenes 
like Vertex-Drawstyle Sphere enabled.

Update 
colors

if checked, on focus change to another Windows application with a 
colormap (e.g. Paint program), pixel values in the GLView window 
will be adapted to the new system color table.

Zoom by 2 instead of rendering in fullsize, the rendering occurs in 1/4 the 
resolution, and the pixels are then copied to the screen. 
Unfortunately the OpenGL pixelcopy function is so slow, so that this 
function is currently useless.

16 Bit Z-
Buffer

GLView by default enables a OpenGL Pixelformat with a 32Bit Z-
Buffer depth, enabling this switch is forcing the selection of a 16-Bit 
Z-buffer. The current OpenGL z-buffer depth information is 
available in the Tools->Info dialog box.



Direct 3D Options dialog

The Direct 3D options dialog offers the following options:

Dither If enabled Direct 3D will dither the resulting image, resulting in less 
banding effects, better image qualtiy, but a slower rendering speed

Highlights if enabled, specular hightlights are displayed

Stipple enables stippled alpha

Driver Direct 3D supports several drivers:

Ramp Emulation:
Pro:very fast software rendering,
Con: some material properties doesn´t work, color per vertex 
doesnt work

RGB Emulation:
Pro: all material properties work, some color per vertex support

Other drivers can appear if a graphics board with D3D hardware 
support is installed.

Texture 
Mode

The different drivers support a different set of texture formats.
E.g. the Ramp-Emulation driver supports only the „Palette 8“ format 
meaning GLView need to reduce all texture images to a 8-Bit 
palette image.

Fullscreen 
Mode

The display mode used for fullscreen rendering. A 8-Bit mode is 
sufficient for the Ramp Driver, a 16-Bit mode is needed for RGB 
mode.



Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple views of multiple 
documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Split Split the active window into panes.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version and license information of GLView.



Basics

Quick Tour

Start the program
drag around with the mouse (this is camera->rotate mode)
try camera->zoom mode and camera->roll mode
camera->reset will bring back the default view

try render menu:
render->wireframe (or toolbar)
render->flat
render->gouraud
..
now once again
render>wireframe
& render->lighted you get a lighted wireframe display

try material menu
material->load choose a predefined material from the list box

material ->edit
click with the mouse in the diffuse entry field,
now press EDIT to edit the diffuse color using the Windows color dialog box
choose a color , Exit & Apply

material->Load texture
choose a texture e.g. brick.rgb

using material->Texture options you can change OpenGL texture mapping parameters
try to enter scale numbers like 3 3 3 in the scale edit field

Try the filtering options only if you have time or a hardware acellerator



Switch off texture mapping using Render->textured or the Toolbar button.

Say Tools->deform->sphere
enable the check boxes for enable and drag
drag around with the mouse, the model should deform to a imaginery sphere, (which is unfortunable
currently invisible). If you do not see an effect, change the radius edit field to higher numbers (negative
numbers are
also working).

To create a spinning logo :
Restart GLView.

File->NewFontLogo

enter the logo text.

"ok"

a 3D logo should now come up and rotates.

If you want it textured check the "Texture Parameters" check box in the dialog, and load
a texture like brick.rgb with Material->LoadTexture

It´s possible to create some funny symbols by using addtional TrueType fonts from
CorelDraw or similar programs, and using symbol fonts like windings.

Basic navigation:

For a "one object" data file or any scene after Camera->Reset has been applied
use Camera->Orbit mode

Mouse Movements orbits the viewer around the object
Control + horizontal movement zooms
Shift + horizontal movement rolls , 
Cursor keys are also orbiting around the object

For a "scene" data file like a room or house etc.
use Camera->Walk mode

vertical mouse movements are moving in and out the scene
horizontal mouse movements are turning the view direction to the left or right
Shift + vertical mouse movements are turning the view direction to up or downt
Control +    mouse movements are moving left/right up/down

All mouse movements are repeated after a while, movement is relative to the point, 
where the mouse movement was paused.



Performance tips

General :
use a small window size (a default (small) size can be specified in Options->Config)
use a small dataset
use a graphics card with fast pixel transfer.

make sure Rendering -> Options -> Backface culling is checked (might be disabled by GLVIEW)
(for VRML files a ShapeHints node in the file will have precedence )

For DXF-Files use the Tools->Combine command

Texture-mapping is quite fast in non-lighted mode : select Render->Non lighted
If accepatable disable Texture Options->perspective correction

Use wireframe, or lighted vertices modes for complex data set to adjust camera,
than switch to gouraud or enable Options->Config->degrade on move with style set to bounding box.

Enable Render->Style->Vertex->Drawstyle only for data sets with few vertices.

Try to check options->build_tristrips before loading a file.

Try to disable VRML scene lights using the www->options dialog and/or 
try the Tools->Combine command,eventually with checking Options->Config->build triangle strips
before.

Textures image files could be prescaled to a power of two, and should not be to large.
eg. 128*128 might be enough (depends on a "normal" window size, and max visible texture size).



License Agreement

the following License Agreement is valid:

Lizenzvertrag für GLView 2.09

Copyright

Das Softwareprogramm GLView, das auf Installations-CD oder Programm-Disketten erworben werden 
kann, enthält urheberrechtlich geschützte Computerdaten. Die diesen Lizenzbestimmungen nicht 
entsprechende Nutzung des Programmes kann zivil- und strafrechtliche Konsequenzen nach sich ziehen. 
Das zu dieser Software gehörende Benutzerhandbuch, sowie der gesamte andere Lieferunfang sind 
auch urheberrechtlich geschützt. Holger Grahn sowie die Firma VISUAL ILLUSIONS Graphic & 
MultiMedia systems / MKC    SOFTWARE ( im folgenden MKC UND HOLGER GRAHN ), sind alleinige 
Inhaber aller urheberrechtlichen Nutzungsrechte.

Der Erwerber von GLView hat mit dem Kauf der Datenträger und des Handbuchs noch nicht das Recht 
der Nutzung dieser Programme erworben, sondern nur das sachenrechtliche Eigentum verbunden mit 
der rechtsgeschäftlichen übertragbaren Möglichkeit, das nachstehende unwiderrufliche Angebot von MKC 
UND HOLGER GRAHN zum Abschluß eines Lizenzvertrages anzunehmen. Erst durch die Annahme 
dieses Angebots erwirbt der Käufer oder sein Rechtsnachfolger die Berechtigung zur vertragsmäßigen 
Nutzung der urheberrechtlich geschützten Programme. Die Berechtigung kann nur durch Vorlage der 
schriftlichen Bestätigung von MKC UND HOLGER GRAHN, daß ihr die Annahmeerklärung zugegangen 
ist, nachgewiesen werden.

Lizenzierung

MKC UND HOLGER GRAHN gewährt durch diese Vereinbarung dem Erwerber (Lizenznehmer) zeitlich 
und örtlich unbegrenzt das nichtausschließliche Recht zur Nutzung dieses Programmpakets und seiner 
Update-Versionen. Die lizenzierte Nutzung ist wie folgt eingeschränkt:

1. Der Lizenznehmer darf das Handbuch sowie die Programme und die sie enthaltenden 
Datenträger nicht für gewerbliche Zwecke veräußern, vermieten, verleihen oder Dritten 
überlassen. Die Programmleistungen dürfen ohne schriftliche Einwilligung von MKC UND 
HOLGER GRAHN entgeltlich Dritten zugänglich gemacht werden. Entwickelt und/oder verbreitet 
der Lizenznehmer seinerseits Programme, die nur zusammen mit GLView arbeiten, so hat er 
diese Verbindung zwischen den Programmen in dem Programm, auf der Verpackung und in den 
Handbüchern deutlich zu machen.

2. Die Herstellung von Programmkopien ist unzulässig. Der Lizenznehmer ist jedoch befugt, Kopien 
der Programme von den Disketten auf die Festplatte seines Computers zu übertragen, soweit 
diese Prozedur der bestimmungsmäßigen Nutzung der Programme dient. Diese 
Programminstallation darf sich aber nur auf einem einzelnen Computer zur Zeit befinden. Der 
Lizenznehmer ist ferner befugt, zur Sicherung der Programme auf geeigneten Datenträgern eine 
Backup-Kopie derselben anzufertigen. Diese Kopien unterliegen den gleichen Bestimmungen 
und Beschränkungen wie die originalen Datenträger.

Gewährleistung und Haftungsbegrenzung

1. MKC leistet 6 Monate Gewähr für die einwandfreie physikalische Beschaffenheit bei Lieferung 
der magnetischen, bzw. optischen Datenträger, sowie der Benutzerhandbücher. Physikalisch 
fehlerhafte Exemplare werden durch fehlerbereinigte ersetzt. Hinsichtlich der Software endet 
jegliche Gewährleistung, wenn der Lizenznehmer oder Dritte eine Veränderung an ihr vornimmt.



Wandlung und Minderung sind ausgeschlossen. Eventueller Schadenersatz beschränkt sich 
lediglich auf Erstattung des Kaufpreises. Haftung über diesen Betrag hinaus ist ausgeschlossen.

2. Die Erstellung absolut "fehlerfreier" Programme und Benutzungsanleitungen ist häufig nicht 
möglich. Deshalb wird die Gewährleistung für die Funktionsfähigkeit der Programme abweichend 
von den gesetzlichen Bestimmungen geregelt.

3. Jede Haftung, insbesondere Ersatzansprüche für Folgeschäden jeglicher Art, die nicht    durch 
vorsätzliches oder grob fahrlässiges Verhalten herbeigeführt wurden, sind ausgeschlossen.
MKC UND HOLGER GRAHN haften auch nicht für eventuelle Schäden, die durch von MKC UND 
HOLGER GRAHN beauftragten Firmen, insbesondere Distributoren und Händler, entstehen.

4. Die Haftbarkeit    von MKC UND HOLGER GRAHN erstreckt sich des weiteren auch nicht auf in 
GLView implementierte Programme anderer Hersteller.

Schlußbestimmung

1. Der Lizenznehmer ist verpflichtet, die Software unverzüglich beim Hersteller, durch die der 
Software beiliegende Registrierungskarte, zu registrieren.

2. Erfüllungsort für alle aus dieser Vereinbarung resultierenden Pflichten und Verbindlichkeiten ist 
Norderstedt bzw. Berlin.

3. Es gilt das Recht der Bundesrepublik Deutschland. Sollten einige der hier genannten 
Bestimmungen unwirksam sein, so werden Sie durch gültige ersetzt. Dies berührt nicht die 
Gültigkeit der übrigen Bestimmungen.



Technical support

You can reach the technical support team through the following offices and ON - Line- Services:
 
Europe

VISUAL ILLUSIONS GMM systems
MKC SOFTWARE
Hasselbusch 71
24558 Henstedt- Ulzburg
Germany

eMail 

101326.2466@compuserve.com

Fax

04193-969420

Compuserve- Forum
GOWORD: GLVIEW
Internet: http://www.glview.com

United Staates of America

EMD Enterprises
73 East Forrest Avenue
Suite 20
Shrewsbury, PA 17361

Support: (717) 235-4423
FAX: (717) 227-9746

eMail: support@emdent.com

WWW-SITE: http://www.emdent.com

Compuserve- Forum
GOWORD: GLVIEW




