
Welcome

Thank you for trying Font Xplorer Lite - limited free version of our full-featured font viewer/manager Font 
Xplorer.

You can navigate through all topics by pressing the << and >> buttons above this help text. If you followed 
a jump to new topic, use the Back button to get back to the previous one that contained the jump.

Sometimes there are menu choices referenced in the help text. If you see something like (View -> User 
Text), it means that in order to run the command the topic talks about you must choose the User Text 
command from the View menu.

There are some images that guide you to important stuff:

 points to an important note

 points to a tip

 points to a warning
Also, this help file lists only those shortcut (accelerator) keys that are not visible in menus. The best way 
to learn shortcut keys is to look at the menu commands and note the shortcuts available. By using 
shortcuts you can dramatically improve your working speed.

Have fun!

Moon Software team



Introduction

Font Xplorer Lite contains only little subset of Font Xplorer's functionality but it is still fully functional font 
viewer program with the following major features:

You see how each installed font looks, so it's very easy to compare fonts
Unload, uninstall, copy, move, delete fonts
Print character map of selected font
Save bitmap sample of selected font
View compherensive information about selected font (full name, copyright, embedding info, 

available character sets, installation status etc.)
Advanced, resizeable character map that displays all font's scripts, so you can see characters 

present in Cyrillic and other scripts, if available in font
Filter fonts by character set, so you can only see symbol fonts or fonts containing full Cyrillic 

character set for example
Integrated Repair Wizard will solve most common problems with fonts



Basics

When you run Font Xplorer, you'll see a list of fonts that are installed (actually loaded) in your system. 
Each font is drawn with its own face so you can very easily choose the best font for your task. That way, 
you'll have a complete overview of fonts available in your system or in a disk folder. You can change the 
size of the fonts displayed (View -> Font Size), toggle the display of font names (View -> Font names),or 
only display fonts that have a specific character set (Filter -> Character Set) etc. This last mode is very 
useful if you want to see only symbol fonts for example, or all fonts that contain cyrillic characters...

By right-clicking on the font list, the font context-menu is displayed. This menu contains some useful 
commands that allow you to manipulate selected font(s). Try right-clicking any object since many objects 
have a special context-menu that lists commands available for that object.

To refresh the font listing use the Refresh command in the View menu.

Please see the following topics for a detailed description of the functionality of Font Xplorer.



Moving Around

You can navigate through the list of fonts with the arrow keys. This is an ordinary Windows list box where 
up and down arrows move to the previous/next font. Home moves to the top and End moves to the end 
of the listing. In addition, if you want to jump directly to a font that starts with a specified letter, just press 
that character key on the keyboard. Press it again and the next font that starts with this character will be 
selected. For example if you are on the top of the list, but want to jump to fonts whose name starts with T, 
just press the T key on keyboard and your are there.

To find the previous/next checked font use Ctrl+Up / Down
To scroll a whole page at a time use Page Up/Page Down
For fast scrolling, you can hold down the Ctrl key when dragging the scroll bar. Fonts will then not 

be drawn on the list during scrolling; instead, you'll see a tooltip with the current topmost font name.



Character Map

Font Xplorer has a very cool Character Map (View -> Character Map). You can also display it by double-
clicking on a font file in the listing (if you have not changed this default behavior from Options). What 
makes it different from other character maps is that it is fully resizeable and can display characters from 
any script that font contains. That way you can display, for example, extended cyrillic characters. This is 
not possible with the Windows Character Map or with most competitive products.

To add a character into copy area with the mouse, hold down the Ctrl key when clicking on the 
character or press the Spacebar key.

You can use the Backspace key to remove characters from the copy area one by one (you don't 
need to activate the text box first!).

You can use the Enter key to toggle between the Font Xplorer main window and the Character 
Map.

By right-clicking on the character map area, you can display a popup menu that has additional    
commands, like copying selected symbol to the Windows clipboard in different formats, etc.



Displaying Font Information

The Font info panel displays useful info (font full name, copyright, version, available scripts, installation 
status etc.) about an activated font.

To show/hide the font information window choose the Font Information command from the View 
menu.

 You can also toggle this mode with the mouse, if you hold down the first mouse button while you 
press the right mouse button on a font listing.



Character Sets

Sometimes you may want to display only symbol fonts or fonts that contain Cyrillic or Greek characters. 
For this, Font Xplorer has a feature that allows you to display only loaded fonts that include a specified 
character set.

Open the Character Set submenu from the Filter menu. Choose a character set. The name of 
the currently active character set filter is visible on the status bar and Font Xplorer displays only fonts that 
contain selected character set.

Alternately, you can change the character set filter by clicking on the status bar, where the active 
character set filter name is displayed. This displays the same Charset submenu.

If character set filter is active then Font Xplorer window caption ends with the * symbol.

 This feature lists only fonts that actually have character set info embedded for the chosen character 
set (i.e. that character set is supported by this font). For example some Hebrew fonts are symbol fonts 
and have no character set info. Those fonts will not show up in the filtered listing.



Printing

Font Xplorer allows you to print your fonts in sample sheets. There are several pre-designed sample 
sheets available; you only have to select the font(s) you want to print and invoke the printing command.

1. Select one or more fonts you want print. If you want to print all listed fonts, you don't need to select 
anything.

2. Choose the Print command from the Font menu. The Print dialog is displayed.

3. Choose the sheet type you want to print from the right pane. You'll see its description on info labels.

4. From the Options tab, you can set several printing options such as margins, number of copies, 
sample text and more.

5. Set your printer options by pressing the Printer button. Set page orientation to portrait and size to A4 
or Letter.

6. Press the OK to start printing.



Font Management

Font Xplorer makes font management a snap since you can see what each font looks like. The basics of 
font/file management are very easy:

First you should select font of interest, then:
To delete the selected font(s) choose the Delete command from the Font menu. You can also 

press the Delete key on keyboard.
To copy or move selected the selected font(s) choose the Copy to or Move to command from the 

Font menu. This displays a submenu that contains your favorite "copy-to" folders (called Destinations) 
plus a command called Browse for Folder that allows you to browse to a destination folder if the folder 
you want to copy/move files to is not listed in the submenu. You can use the Destinations tab in the 
Options window to edit your destination folders that appear in the submenu.

To load/install/unload and uninstall selected font(s) choose the appropriate command from the 
Font menu. See the special Installing Fonts topic that discusses these procedures further.

 If you right-click on the font listing, a popup menu will be displayed which contains the    most often 
used font management commands.

 Font Xplorer is smart enough to save you from tasks like uninstalling a font before deletion, etc., so 
that you can dedicate yourself to your project without worrying about extra stuff.



Installing & Uninstalling Fonts

Font Xplorer has several functions that enable you to install/uninstall fonts. Here we discuss the purpose 
of each one. Before we continue, you should read the Loading vs Installing Explained topic that tells you 
what exactly we mean by    "loading" or "installing" a font. To make things easier to read, we will use 
"installing" to refer to the installing/loading/uninstalling/unloading procedure.

If you want to install a few fonts, you can select the fonts you want to install and choose the 
Install Font command from the Font menu or from the popup menu that appears if you right-click on the 
font list.

If you want to install all fonts in a disk folder, you can select all fonts in the list and use the method 
above, but it is much easier to use the Install Font (by Folder) command from the Tools menu. This 
displays the standard Browse for Folder window that allows you to pick a folder that contains the fonts 
you want to install. The rest is done automatically by Font Xplorer.



Options

You can customize Font Xplorer in several ways through the Options dialog.
To display the Options dialog use the Options command from the Tools menu.

The Options dialog consists of several tabs:

General - contains settings to alter look and behavior of the program

Destinations - lists folders you use most frequently as copy/move targets. If you have certain folders that 
you copy/move files to often, put them into this list. Then, they will appear under the Copy to/Move to 
menus for quick access . This avoids browsing for the same folders over and over if you want to 
copy/move fonts.

 You can return to the "factory settings" any time by pressing the Defaults button in the Options dialog. 
You can experiment with different settings to see how they affect the program and return to default 
settings at anytime.



Save Image

The Save Image tool can generate a graphics image (bitmap file, BMP) with a font sample text. The 
sample image generated can look like this:

If you want to save images of selected font(s), use the Save Image command in the Font menu.

You can change colors, alignment, margins, text that is displayed and much more. Since this tool is used 
mostly by advanced users, we don't provide descriptions of all controls in this window. The best way to 
learn how changing the options affects the final result is to switch on live preview mode (press the 
Preview button). Now you see all changes in preview window.

You can use variables in text areas. This allows you to use real font names, file names and other info in 
your text.

 Please note that the final image(s) will be saved according to your instructions on the Output Folder & 
Naming tab.

 Existing image files with the same names will be overwritten without warning.
 You can restore the default text and background color by right-clicking on the color buttons with the 

mouse.



Repair Wizard

Repair Wizard (Tools -> Repair Wizard) helps you resolve many common font problems. It will scan the 
Windows registry for invalid font entries and can also restore the "magic" of the Windows system fonts 
folder.



Loading vs Installing Explained

You may wonder what the difference is between "loading a font" and "installing a font". While different 
programs may use different terms for these actions, in Font Xplorer they mean the following:

Loading

Loads font into the Windows font table but does not make it available permanently. A loaded font is 
available to programs only until the current Windows session ends or until you manually unload it 
(whichever comes first). By loading a font, you usually make it available for specific job. For example, if 
you need a special font only for one document: then usually you won't have it installed all the time. But if 
you need to work with this document, you can load this font, and unload it when you are done (you don't 
have to unload, it will not be loaded on next windows session).

Unloading

Unloading fonts means removing fonts from Windows font table so they cannot be used in programs any 
more. If the font is permanently installed (see below) and you unload it, it will be available if you load it 
again or after you restart Windows.

Installing or permanently installing

Loading + adding a font reference to the Windows registry so the font will be available now and after 
Windows is restarted. That is usually what you want to do. Windows ,then at startup, automatically loads 
all fonts that are listed in the registry.

Uninstalling

Means completely removing a font from the font table (unloading) and from the registry so it will not be 
available any more. After uninstalling a font, you cannot use it until you install or load it again. The font file 
itself is not deleted (if you don't choose to do this specifically).

 Some Windows versions do not allow you to unload fonts that reside in the system fonts folder (usually 
C:\Windows\Fonts). You can uninstall them (they still will be displayed but are actually uninstalled) and 
then they will not be loaded in next Windows session.



Limitations

User limitations

The Windows operating system has some significant font limitations. When Windows 95 first hit the 
market,we were told that there is no limit to the number of fonts that can be installed. But actually, there 
is, and the limit is quite low; you can have only around 1000 fonts loaded. Some may say that this is 
enough. It is if your fonts are well organized and you load them when needed, but the problem is that 
there is no exact limit to the number of fonts; it depends on the size of font file names. The total size of 
font file names with path cannot exceed 10 KB. That means the shorter your font folder names and font 
names are, the more fonts you can have installed. This also applies to Windows 98. See Microsoft 
Knowledge Base article Q131943 for more info on this matter...

This limitation also limits Font Xplorer. Font Xplorer is designed so that you can see all fonts drawn with 
their own face. When you browse disk fonts, Font Xplorer will load all the fonts before it can display them. 
If a folder contains many fonts, that may become impossible due to the Windows font limit. Font Xplorer 
tries to detect this problem and will warn you with an error message.

We suggest that you do not keep more than 250 fonts in each folder. If you have more, it may be 
impossible to display disk fonts if you also have a large number of fonts installed in the system. 
Remember, if you already have 800 fonts permanently installed then you only have about 100-200 free 
places. So if one of your disk folders contains more than that, you are in trouble (fonts will be drawn using 
wrong face and any kind of other font problems).

Developer limitations

From a developer's perspective there are some problematic issues involved in writing a program like Font 
Xplorer because the operating system doesn't provide enough information about fonts. Windows 
reference counts font resources, but there is not a documented way to find out how many times a font is 
loaded. For example to unload a font, it's reference count must be zero. If a font is loaded 3 times by 
different programs and Font Xplorer tries to unload it, it is possible that the font will not be unloaded since 
other programs have loaded it too. There are workarounds for this, but ,unfortunately, there may be times 
where those tweaks do not work perfectly.

Registry

All installed fonts are listed in the Windows registry so the operating system will know which fonts it 
should load on the next startup. Each registry key consists of the font name and font file name. Windows 
Software Development Kit (SDK) specifies that font entries in the registry for TrueType fonts should be in 
the following form:

Font full name (TrueType) = font file name

e.g 

Arial Bold Italic (TrueType) = arialbi.ttf

Unfortunately, there are some applications that write the wrong data to the registry when they install fonts. 
Some apps write "True Type" instead of "TrueType"; some don't write "TrueType" at all, only the font 
name etc. This makes it very difficult to check if fonts are permanently installed or not (listed in the 
registry). To do this we need to construct a string containing font name and appending phrase " 
(TrueType)" to it. Then we check to see if that key exists. But if another program has written the key in a 
different, non-standard, form, it becomes very difficult, since we cannot guess all the possible ways 
programs can write font entries. So, that all means that sometimes Font Xplorer may give wrong 
information about font installation status (especially if you have used different utilities to install fonts).

Additionally it seems that it's impossible to unload fonts that are installed from Windows system fonts 
folder (especially under Windows 98)



Troubleshooting

This topic contains some suggestions and useful info on how to avoid font problems in your PC.

To avoid problems install only 500 fonts maximum. Please see the Limitations topic about Windows font 
limitations. You can load and unload fonts dynamically if you need them, so there is no real need to keep 
fonts you don't use installed.

Don't touch the symbol font named Marlett. That font is used by Windows to draw parts of screen 
elements, like images on buttons that you see in upper left corner of each window, scrollbar thumb 
triangles and so on. If you uninstall or delete it, your screen will become unreadable. If that has already 
happened to you then, you just need to reinstall the font.

If you start getting weird font related problems, run the Font Xplorer Repair Wizard. It is able to correct 
most simple font related problems. If a font start to draw with another font's face, then the Rebuild Font 
Cache option in Repair Wizard will probably help.

If you want to run the Windows Font Viewer application by double-clicking on a font file but nothing 
happens, then you probably have reached the Windows font limit. Font Viewer needs to temporarily load 
the font for viewing but is unable to do so. For some odd reason, it does not display any error messages; 
it just won't run. You need to uninstall a few hundred of fonts.

 If you have problems that you cannot resolve using Font Xplorer and this help file, you can e-mail tech 
support. Please paste your system info (Help -> Copy System Info) into your e-mail message along with 
your problem description. Be as detailed as possible with your problem description and reproduce any 
error messages you get and/or exact steps necessary to recreate the problem.
See also Printing Problems topic.



Printing Problems

Every kind of printing depends of the quality of the printer driver. If you have a good driver, you can get 
nice printouts, but if you have poor driver, you may have a lot of problems. Usually printer drivers have 
many options that you can set from the Control Panel or directly from Printer Setup in a print dialog. We 
suggest you play with different settings to see how they affect printing time and output quality. Here are 
few tips that may help you to get better printouts.

If there is option named something like "Use Printer Fonts," don't use it. Printer fonts may be slightly 
different than screen fonts, so if you print sample sheets using printer fonts, you may see different output 
than what you see on screen. Also, the printer character table may contain some symbols that are not 
actually available in TrueType fonts and vice versa.

If parts of an image are missing from the printout and you have option to send the image to the printer in 
either bitmap or vector form, use the bitmap option. This usually makes printing a lot faster and saves you 
from many problems that may appear when printing complex images. However, this may also require you 
to have a lot of memory installed in your printer.



Uninstalling

Removing Font Xplorer from your system is very easy. This will remove the program files from your hard 
disk as well as the settings from the registry:

1. Click here  to open the Control Panel's Add/Remove Programs applet.
2. Find the Font Xplorer entry in the list and select it.
3. Note step 4 and then close this help file. Otherwise the uninstaller cannot delete it from your 
system.
4. Press the Add/Remove button to start removing the application and follow the instructions on the 
screen.



How To Buy

Prices

Please note: Latest prices are listed in our web site, prices listed here are guaranteed until December 31, 
1999.

All our software products come with unconditional 30-day money back guarantee!

Products are distributed electronically - after your payment is confirmed, you can download full version of 
purchased software from our web site. That also means you do not receive diskette or printed manuals 
(you can copy the downloaded file to a diskette if you wish, also you can print out online help if you prefer 
printed documentation).

single user license $19.95

3-user license $49

5-user license $89

10-user license $159

site license* $399

(*) Site license covers a single organization in one place (building complex). If you buy a site license, you may use the program in 
unlimited number of computers in your company within this area.

Prices are subject to change.

How to Order

We have a special ordering section in our web site so you can order our products with different credit 
cards, fax or purchase order easily. 

We have also some international representatives. Currently you can buy our products from the following 
representatives:

Australia/New Zealand:

Aquarian Technologies
PO Box 820
Castlemaine, VIC, 3450

Phone: +61(0)3 5470-6812
Sales phone: 1800-240-774
Fax: +61(0)3 5470-6803
E-mail: tim@aquatee.com
Web: http://www.aquatee.com

Germany/Austria/Switzerland:

sharible Magazine - Leserservice
Masurenweg 1
D-85521 Ottobrunn
Germany

Fon & fax (ISDN) +49 +89 6085 1220
E-mail: service@sharible.de
Web: http://www.sharible.de
AOL: sharible



CompuServe: GO SHARIBLE



FontLoader

FontLoader's shell context-menu extension allows users to load/unload/install and uninstall fonts directly 
by right-clicking on a font file or folder containing fonts in the Windows Explorer, avoiding the painful font 
installation routine that Windows offers by default. Also, FontLoader makes it easy to load/unload/install or 
uninstall font groups. Users can build their own font groups to load on demand by just clicking on the 
program icon in the system tray area near the clock. 

FontLoader is small (optional resident group loader is only around 70 KB file) and fast. It doesn't eat your 
system resources and it doesn't need additional runtime files. FontLoader works with True Type fonts 
only.

Yes we wrote it, so it is designed to work hand in hand with Font Xplorer. For more info about FontLoader 
and other software by Moon Software point your web browser to our homepage.



Other Font Utilities

Font properties extension from Microsoft (freeware) 

If you right click on a font file in Windows 95, Windows 98 or Windows NT, its basic properties are 
displayed. This extension adds several new property tabs to this properties dialog box. These include 
information relating to font origination and copyright, the type sizes to which hinting and smoothing are 
applied, and the code pages supported by extended character sets. Useful tool and highly recommended.

Click here to display the Internet homepage where you can download this utility.

Windows 95 font smoother from Microsoft (freeware)

Font smoothing is one of several system enhancements originally included in the Plus! pack for Windows 
95. Now you can make full use of the benefits of this technology, making text easier to read and more 
pleasant to look at, without having to purchase the Plus! Pack. 

 Microsoft Windows 98 and Microsoft Windows NT 4 have font smoothing built-in.
Windows 98 - Font smoothing can be activated via the 'Effects' tab on the 'Display Properties' 

control panel.
Windows NT 4 - Font smoothing is activated via the 'Plus' tab on the 'Display Properties' control 

panel. 

Click here to display the Internet homepage where you can download this utility.



Contact Information

If you have any questions, problems or ideas about our software, feel free to contact us. We really 
appreciate your feedback, even it is not positive. You will also find many other interesting programs and 
utilities on our homepage.

Please check our web site for the latest contact information since the info on this page may be outdated if 
you have very old version of the software.

Web:

http://www.moonsoftware.com

General information e-mail:

info@moonsoftware.com

Support e-mail:

support@moonsoftware.com

Fax number in USA:

(520) 441-6819

Postal address:

Moon Software OÜ
Karja 2 - 58
Paide 72717
Estonia (Europe)



What You Get

Font Xplorer Lite is the little brother of our full-featured Font Xplorer application. Font Xplorer has many 
unique and powerful features that make it the best font viewer/manager available. At only $19.95, there is 
no better font tool for the money (or for more money, too).

Font Xplorer contains all the features of Font Xplorer Lite plus:
Browse and view fonts that are not installed. Simply select a disk folder from Windows Explorer-

like tree and Font Xplorer shows you all fonts in that folder. You can install them on the fly, see which 
ones are already installed and more...

Work with multiple fonts (copy/move/install/print etc) simultaneously
Display your own text in the font list to easily find the perfect font for a specified task
All functions & tools needed to install/load/uninstall and unload fonts
Print all fonts at once or only selected fonts, print different professional sample sheets. Print one 

font per sheet or multiple fonts per sheet.
Display only marked fonts, so you can filter and display only a subset of your fonts
Zoom in on selected symbols in a character map so you can see every detail
View font metrics information
Keep favorite folders, so you can switch to your font folders with a single mouse click
Find duplicate fonts from your disk(s)
Save bitmap images of selected fonts or of a font folder
Rename fonts to full names (from arialbi.ttf to Arial Bold Italic.ttf) with undo support
Tweak the Windows fonts folder to display either a list of installed fonts or a simple file listing like 

any other folder
And much more...

So, to say it simply, you get the best font viewing and management software available. And all our 
software comes with unconditional 30-day money back guarantee, so don't wait, get hands on today! 



Variables

You can use variables everywhere you see the Insert Variable command button (titles with $). For Lite 
version, that is only in Save Image window. Lite version has only support for few generaic variables, 
mostly referencing font information. Since different functions allow different variables, only variables 
available to a particular function are listed in the Insert Variable window that pops up after you press the 
button. Click on a variable to see it's short description. 

In general,a specific variable is replaced with special information if the command containing variable is 
executed. If you use the $FX_FILENAME in a command line of an external program, then, before the 
command line is passed to the external program, Font Xplorer replaces the variable with actual data, e.g. 
the $FX_FILENAME variable is replaced with the actual file name of the selected font. That way your 
external program knows which font you have selected in your font list and takes action on this font.

Experiment with different variables to see how they work.
 All variable names are case sensitive! You must enter them in all UPPER CASE!

Supported variables:
$FX_FILENAME - File name (without full path) of active font like: Arialn.ttf
$FX_FILEPATH - File name with full path of active font, like: c:\windows\fonts\Arialn.ttf. Since this is a 
long filename, if you are going to pass it on the command line to an external program use it between 
double quotes. Otherwise, if there is more than 1 command line parameter and file name contains 
space(s), problems may arise.

$FX_COPYRIGHT - Returns font copyright string, e.g., Copyright 1992 Monotype Corporation. 

$FX_FACENAME - Returns font full name, e.g., Arial Italic

$FX_SCRIPT - Returns font script (depends on Font Xplorer active character set), like: Western



Installation Status Indicators

Font Xplorer allows you to easily see which fonts are installed and which ones are not by showing 
installation status images for each font entry in the font listing.

To show/hide the installation status images use the Installation Status command in the View 
menu.

Those status images are only displayed for fonts that do not have a default installation status. For default 
status there is no image (see below).

You may need to read the topic that discusses terms "loaded", "installed", "permanently installed" etc. if 
you have not done so already.

Images explained:

No image:

Loaded fonts mode: the font is permanently installed in your system.

Disk fonts mode: the font is NOT installed or loaded in your system

 Green image:

Both modes: Font is loaded but not permanently installed.

 Blue image:

Disk fonts mode only: Font from this file is installed permanently.

 Lilac image:

Disk fonts mode only: The same font is installed from a different file/folder. This means that a font with 
this name is permanently installed in your system, but not directly from this file. For example you have 
folder D:\Fonts and your default fonts are in C:\Windows\Fonts folder. You have an Arial font file in both 
folders. You have the Arial font installed from the C:\Windows\Fonts folder but if you browse disk fonts 
and go to D:\Fonts folder, you see that the Arial font has lilac status image, because it is installed from 
another folder. If you delete this font from D:\Fonts folder (has lilac image), it is still available from another 
location.




