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Installation Instructions

Installing the programs from the CD - Windows
1) Insert the program CD into the CD-ROM drive.

2) Windows 95 - Click on the Start menu and select the Run option.  Windows
3.1x - From the Windows Program Manager, click once in the File menu option
to display the File menu and select Run.

3) In the Run dialog box, type D:\START.EXE,  and press Enter. If your CD-
ROM drive letter is not D, substitute accordingly.

4) Follow the on screen prompts to complete the installation.

On-Line Documentation

Please note that in order to access the on-line documentation, you need to install
the On-Line viewer utility at least once. Follow steps one & two above and in the
Run dialog box type D:\ACROREAD.EXE and press Enter.

The manual file is called MANUAL.PDF and is located on the CD in the
MANUALS directory (D:\MANUALS\MANUAL.PDF). Start the Viewer utility
by double clicking on the icon from its program group and access this file from
the CD.

To install Home Gourmet on a Macintosh system :

1. Put the Home Gourmet CD in your CD drive.

2. Double-click the Home Gourmet Installer icon.

3. If you have more than one hard disk on your system, specify the hard disk on

which you�d like to install Home Gourmet.

4. Click the Install button.

To start Home Gourmet on a PC or Mac:

Double-click the Home Gourmet icon.

NOTE: You can also start Home Gourmet by double-clicking any of the
cookbook icons.

This will start up Home Gourmet and automatically open the cookbook file
associated with the icon you double-clicked.
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Getting Started

Welcome to Home Gourmet

Welcome to Key Home Gourmet, the most sophisticated and powerful cooking program
ever written. Home Gourmet takes the drudgery and difficulty out of planning meals,
leaving you time for the things you enjoy, like cooking, dining and entertaining.

Home Gourmet makes cooking more enjoyable because it automates your recipe filing
and meal planning. Just look at some of the many ways Home Gourmet can save you time
and help you enjoy cooking more:

• Never lose track of recipes. With Home Gourmet, your recipes are always at
your fingertips.

• Save time finding the right recipe for the occasion. Home Gourmet finds the
recipes for the ingredients you have or the foods you like to eat in a fraction of
the time it takes you to consult a single cookbook.

• Print your recipes the way you want. Print your recipes with any typeface you
want on a variety of page sizes.

• Print complete shopping lists automatically. Just tell Home Gourmet which
recipes you plan to prepare and it will create a complete shopping list, including
the amount of each ingredient.

• Create quick nutritional analyses of foods, recipes, and even entire meals.
• Get quick access to information about cooking and foods with an on-line cooking

glossary, a table of yields and equivalents, and suggestions for seasonings and
food substitutions.

An Overview of Home Gourmet
Home Gourmet is designed to let you create, file, and retrieve recipes the same way you
do now, only in a more efficient and enjoyable manner.  So before we discuss how Home
Gourmet works, let’s review how you probably file and retrieve recipes now.

Recipes, Cookbooks, and Ingredients

When you prepare a meal from a recipe, you probably refer to a cookbook or to your own
file of recipes. If you know the recipe you want, you locate its name in the index of the
appropriate cookbook or look for it under the appropriate index tab of your card file. You
then turn to the page of the cookbook or pull out the index card, and there’s your recipe.

Home Gourmet works the same way. Recipes are stored in files on disk called,
appropriately enough, cookbooks. To look for and display recipes with Home Gourmet,
you first open a cookbook, just as you open a physical cookbook. Home Gourmet lets you
create as many cookbooks as you have disk space for, and the recipes in each cookbook
can be organized according to whichever categories you choose. You can have up to 8,000
recipes in each cookbook.

Home Gourmet makes it a snap to create recipes because it comes with a database of
commonly used recipe ingredients, so you’ll rarely have to type a full ingredient name!
You can automatically create nutritional analyses and shopping lists of your recipes, with
just the click of a button.
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How Home Gourmet’s Nutritional Analysis Works

Home Gourmet puts a wealth of nutritional information at your fingertips. With Home
Gourmet, you can prepare a nutritional analysis of a recipe or look up the nutritional
content of individual foods, automatically, without scanning nutrition tables or doing a lot
of complicated recipe math.

To provide this instant nutritional analysis, Home Gourmet comes with an Ingredients
List that includes nutrient values for over 4,000 food items. The nutrition information for
this Ingredients List comes from United States Department of Agriculture (USDA) research
publications. Additional information was obtained from food manufacturers.

To make this list easier and more practical for cooks to use in creating recipes, we have
shortened some of the names of foods, but always with the intent of retaining the USDA’s
meaning as to the specific nature of the food. More information about USDA nutritional
publications can be obtained by writing:

Superintendent of Documents
U.S. Government Printing Office
Washington, D.C. 20402

How to Use This Manual
This User’s Guide tells you how to use Home Gourmet on both IBM PC (or compatible)
and Macintosh systems, although pictures of the program depict the PC version only. In
some cases, the methods you use for accomplishing certain tasks may be different on a PC
than they are on a Macintosh. When this occurs, it is clearly noted; just be sure to follow
the instructions carefully.

Installing Home Gourmet
Before installing Home Gourmet on a PC or Macintosh, please make sure your system
meets the following requirements.

For a PC system:

• Microsoft Windows version 3.1
• MS-DOS version 5.0 or higher
• 386, 486 or higher IBM or compatible PC with a clock speed of at least 25 MHz
• At least 4 MB of RAM
• CD ROM drive with a transfer rate of at least 150K/sec
• MSCDEX V2.2 or later for CD ROM support
• A hard disk with about 3 MB of free disk space

For a Macintosh system:

• A Mac Plus or later computer running System 6.0 or higher
• 2 MB of RAM
• A hard disk with about 3 MB free disk space
• CD ROM drive with a transfer rate of at least 150K/sec

To install Home Gourmet on an IBM or compatible PC:

Please refer to the section Installing the Programs from the CD.
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To install Home Gourmet on a Macintosh system :

1. Put the Home Gourmet CD in your CD drive.
2. Double-click the Home Gourmet Installer icon.
3. If you have more than one hard disk on your system, specify the hard disk on

which you’d like to install Home Gourmet.
4. Click the Install button.

To start Home Gourmet on a PC or Mac:

Double-click the Home Gourmet icon.

NOTE: You can also start Home Gourmet by double-clicking any of the cookbook icons.
This will start up Home Gourmet and automatically open the cookbook file associated
with the icon you double-clicked.

The Home Gourmet Workspace
In Home Gourmet, the Workspace contains a variety of windows that let you perform
different tasks (for example, cookbooks and recipes have their own types of windows,
because you do different things with them). These windows can be placed on top of one
another and you can move from window to window with the click of a mouse button.

Let’s take a look at the Home Gourmet Workspace. At the top of the Workspace is the
menu bar, from which you choose the commands that you want Home Gourmet to execute.

The Control Bar

Beneath the menu bar is the Control Bar, a strip of buttons that let you perform the most
common Home Gourmet functions with a single button click. The Control Bar is context-
sensitive, which means that it changes depending on what you’re currently doing in the
Home Gourmet program.

Home Gourmet automatically tells you which task a Control Bar button performs in a
given situation; move your mouse pointer over a button, and a text message describing the
current task performed by that button appears in the Control Bar. For a complete description
of the Control Bar and its functions, see The Control Bar in the section Tools.

The Cookbook Window

Below the Control Bar is the cookbook window. Only one cookbook can be opened at one
time. The window contains the name of the cookbook in its title bar, and the names of the
cookbook’s categories are displayed on the left side of the cookbook window like the
chapter titles in the table of contents of a book. You can change the look of many parts of
the program with the Preferences command. See the section, Tools, later in the manual for
more information.

The Control Bar
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When you click on a category name, that category’s recipes appear in a list of recipes on
the right side of the window. To open recipes from the cookbook, you first click on the
names of the categories in the cookbook that contain the recipes you wish to open. (Click
on “*** All Categories ***” on a PC or “***All Recipes***” on a Mac to display all
recipes in the cookbook.)

Next, choose the recipes you want from the recipes list on the right. When you’ve selected
the recipes you want to open, click the Open button. The selected recipes are opened and
appear in individual windows in the Home Gourmet Workspace.

The Selected Recipes List (PC only)

Every Home Gourmet cookbook has its own Selected Recipes List, which lets you maintain
a group of selected recipes to open or print. You place recipes on this list by clicking on the
names of recipes in the cookbook window and then clicking the Select Recipes button, or
by using the Search Recipes command on the Recipe menu to find recipes that match
certain criteria. You can’t close the Selected Recipes List window, but you can minimize
it.

The Recipe Clipboard (Mac only)

Every Home Gourmet cookbook has its own Recipe Clipboard, which lets you maintain
a group of selected recipes to open or print. Place recipes on the Recipe Clipboard by
clicking on the names of recipes in the cookbook window and then clicking the Add to
Clipboard button, or by using the Search Recipes command on the Recipe menu to find
recipes that match certain criteria.

When you perform a search, the Recipe Clipboard automatically opens and the recipes
you located are displayed. You can choose groups of recipes to display from the Recipe
Clipboard window just as you do from the cookbook window. To display the Recipe
Clipboard, choose Recipe Clipboard from the Window menu or press COMMAND+2.

Quitting Home Gourmet

To quit the Home Gourmet program:

On a PC, choose Exit from the File menu OR, on a Macintosh, choose Quit from the File
menu.

The Cookbook Window



6

Cookbooks
About Cookbooks
Anyone who has done much cooking knows that cookbooks are structured collections of
recipes, arranged to make finding and using recipes as convenient as possible. For this
reason, cookbooks are usually organized into chapters based upon some sort of categorization
of recipes. For example, recipes may be categorized by:

The type of food poultry, beef dishes, vegetarian meals, etc.
Course or position in the meal appetizers, salads, main dishes, desserts, etc.
Regional, national, or ethnic foods Chinese, Italian, Cajun, Provencal, etc.
The author or source of the recipe

Almost all conventional cookbooks are organized by categories, but almost always by only
one type of category, with each recipe in the cookbook assigned to only one category.
Home Gourmet’s electronic cookbooks are organized by categories as well, but unlike
conventional cookbooks, Home Gourmet cookbooks can be organized any way you like,
by the type of food, by course, by region or ethnic origin, by source, or all at the same time!

While you can only open one cookbook at a time, you can save any number of cookbooks
on disk (limited only by disk space). And since each cookbook can save up to 8,000
recipes, you can probably even store all your recipes in one cookbook, if you find that
more convenient.

Creating a New Cookbook
File names for Home Gourmet’s cookbooks are limited to eight characters on a PC (and
are automatically given a .MCF extension) or 31 characters on a Macintosh.

To create a new cookbook:

1. If you already have a cookbook open, close it. You can only open one cookbook
at a time.

2. Choose New Cookbook from the File menu.
3. Type a name for the new cookbook.

PC NOTE:  The first eight letters of the cookbook name become the DOS file name
(shown in the DOS File Name text box) for the cookbook. You can change this DOS file
name by typing a different name in the DOS File Name text box.

4. On a PC, click the OK button.  On a Mac, click the Save button.
The cookbook window for the new cookbook appears on the screen, along with the
Categories dialog box. You’ll create the categories for the new cookbook using this dialog
box.

5. For each category that you wish to add to the cookbook, type the category name
and then click the Add button.  As you add each category, it appears in alphabetical
order in the list.

6. Click the OK button when you’ve finished adding categories.
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Opening a Cookbook
You can open only one cookbook at a time.

To open a cookbook:

1. If you already have a cookbook open, close it.
2. Choose Open Cookbook from the File menu, or click the Open Cookbook button

on the Control Bar.
3. Scroll the list until the cookbook you want to open appears.  If necessary, change

to another drive or directory/folder to locate the cookbook.
4. Click the cookbook you wish to open and then click OK.  The cookbook window

for the selected cookbook appears.
The cookbook window is a software version of a cookbook’s table of contents:  on the left
are the cookbook’s categories, laid out like the chapters of a cookbook; on the right are the
recipes in the selected category or categories. Getting Started describes the Cookbook
Window and the accompanying Selected Recipes List Window (on a PC) or Recipe
Clipboard (on a Mac) in detail.

Renaming, Copying, and Backing Up Cookbooks
You can make a copy of a cookbook with the Save Cookbook As command on the File
menu. The new copy of the cookbook becomes the current open cookbook, and subsequent
changes you make to recipes or menus will be saved to the new version of the cookbook.
You can also use Save Cookbook As to save a cookbook to a different disk-drive or to a
different directory/folder.

Use this command to rename cookbooks, to back up your cookbook files, or to make
copies of your recipes to give to other Home Gourmet users.

To rename or make a copy of a cookbook:

1. Choose Save Cookbook As from the File menu.
2. Type a new name for the cookbook.

Choose a different drive and/or directory/folder to save the copy of the cookbook
to if you want.

3. On a PC, click the OK button.  On a Mac, click the Save button.

NOTE:  Use the instructions above to back up your cookbooks frequently as you work.
First, use Save Cookbook As to save the cookbook to a floppy disk as a backup. Then, use
Save Cookbook As again to save the cookbook in its original location, so that subsequent
changes to your recipes and menus will be made to the original version of the cookbook
and not to your backup.

Deleting a Cookbook
The Delete Cookbook command on the File menu lets you delete one or more cookbooks,
without leaving Home Gourmet.

Before you delete a cookbook, you may want to make sure you have a backup copy of it. To
make a backup of a cookbook, see Renaming, Copying, and Backing Up a Cookbook, in
the preceding section.
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To delete a cookbook:

1. Choose Delete Cookbook from the File Menu.
2. If the cookbook you wish to delete is on a different disk-drive or directory/folder,

change to that location.
3. Click on the cookbook you wish to delete.
4. Click the Delete button.
5. On a PC, click the Yes button to confirm that you want to delete the cookbook.

On a Mac, click the Delete button to confirm that you want to delete the cookbook.

Editing a Cookbook’s Categories
Once you’ve created a cookbook, you can still add categories to it, remove categories from
it, and rename its categories using the Categories command on the File menu. The
Categories command also lets you save the current categories as a template to provide
categories for future cookbooks.

To add a category to an existing cookbook:

1. Open the cookbook to which you wish to add a category or categories.
2. Choose Categories from the File menu.
3. For each category that you wish to add to the cookbook, type the category name

and then click the Add button.
As you add each category, it appears in alphabetical order in the list box.

NOTE:  You can avoid entering a cookbook’s categories one at a time by using the current
category template. To use the template, see Using the Current Category Template later in
this section.

To remove a category from a cookbook:

1. Open the cookbook from which you wish to remove a category or categories.
2. Choose Categories from the File menu.
3. Type the name for the category you wish to remove from the cookbook or click

the category name in the list.
4. On a PC, click the Delete button.  On a Mac, click the Remove button.

NOTE:  If a category has any recipes assigned to it when you attempt to delete it, a dialog
box appears to tell you that the category cannot be deleted. If you still want to delete the
category, open each recipe assigned to it and de-select the category name from the recipe.

To rename a category :

1. Open the cookbook containing the category or categories you wish to rename,
and choose Categories from the File menu.

2. Type the name for the category you wish to rename or click the category name in
the list.

3. Click the Rename button.
4. Type a new name for the category and then click the OK button.

To save a cookbook’s categories as a template for future cookbooks:

1. Open the cookbook containing the category or categories you wish to use as a
template, and choose Categories from the File menu.
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2. Click the Save as Template button.
3. On a PC, click the Yes button to save the current categories as the new Category

Template.  On a Mac, click the Replace button to save the current categories as
the new Category Template.

The next time you create a cookbook, you can automatically assign it the template’s
categories without having to enter them again.

To use the Category Template with a new cookbook:

1. Create a new cookbook with the New Cookbook command.
2. When the Categories dialog box appears, click the Use Template button.
3. Add new categories or remove categories until you have the categories you wish

to use.
4. Click the OK button.

The categories displayed in the Categories list box become the categories for the new
cookbook.

Copying Recipes from One Cookbook to Another
You can move recipes, one by one, from one cookbook to another by using Copy Recipe or
Cut Recipe to place a single recipe on the Clipboard and then using the Paste Recipe
command to place the recipe into a different cookbook (See Cutting, Copying, and Pasting
Recipes in the Recipes section for more information.). If you want to copy a group of
recipes from one cookbook to another, however, it’s easiest to use the Copy Recipes
command on the File menu.

To copy recipes to another cookbook on a PC:

1. Choose Copy Recipes from the File menu.
In the upper-left of the Copy Recipes dialog box is the name of the cookbook
from which you wish to copy recipes. By default this is the currently open
cookbook, but you can choose any cookbook.

2. If you want to copy from a cookbook other than the open cookbook, click the
Open button on the left of the dialog box and specify a different cookbook.

3. Choose the cookbook to which you wish to copy recipes by clicking the Open
button on the right of the dialog box and specifying a different cookbook, or
click the New button and type the name of a new cookbook to contain the recipes.

4. In the Categories list in the lower-left of the dialog box, click the names of the
categories containing the recipes you wish to copy, or click Select All to display
all recipes in the cookbook.

5. In the Recipes list in the lower-right of the dialog box, click the names of the
recipes you wish to copy, or click Select All to select all recipes in the list.

6. Click the Copy button.
You can repeat this procedure with as many different files as you like. (Click the Switch
button to reverse the cookbooks you’re copying from and to.) When you’re finished copying
recipes, click Cancel.

To copy recipes to another cookbook on a Mac:

1. In the window of an open cookbook (or Recipe Clipboard window), click on the
names of the recipes that you wish to copy to another cookbook.

2. Choose Copy Recipes To from the File menu.
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3. If you wish to copy the recipes to a cookbook in a folder other than the current
folder, choose the appropriate folder and/or disk drive.

4. Click on the name of the cookbook to which you wish to copy the selected recipes.
5. Click the Copy Here button.

The recipes are copied to the specified cookbook file.

Deleting a Group of Recipes from a Cookbook

There are a few different ways to delete recipes. You can delete the current recipe with the
Delete Current Recipe command (on the Recipe menu) or cut the current recipe from the
cookbook (to the Clipboard) with the Cut Recipe command (also on the Recipe menu).
When you wish to delete a group of recipes from a cookbook, however, use the Delete
Recipes command on the File menu.

To delete a group of recipes on a PC:

1. Choose Delete Recipes from the File menu.
On the left of the dialog box is a list of the categories in the current cookbook; on
the right is a list box that will contain the recipes in the categories that you
select.

2. Click on the category or categories containing the recipes you wish to delete, or
click Select All to display all recipes in the cookbook.
As you click on each category, the recipes in that category are added to the
Recipes list.
To make a contiguous selection of categories, click on the name of the first
recipe and then drag down (or up) to the name of the last category. To make a
non-contiguous selection, hold down the CTRL key while clicking the appropriate
category names.

3. In the Recipes list box, click on the names of the recipes that you wish to delete.
4. Click the Delete button.
5. Click Yes to confirm that you want to delete the recipes.

The recipes are deleted and Home Gourmet returns you to the Delete Recipes dialog box,
to allow you to continue deleting recipes, if you wish. When you’re finished, click Cancel.

To delete a group of recipes on a Mac:

1. In the cookbook window (or Recipe Clipboard window), click on the names of
the recipes that you wish to delete from the cookbook.

2. Choose Delete Recipes from the File menu.
A dialog box appears, asking you to confirm that you want to delete the first
recipe in the group of selected recipes.

3. To delete recipes selectively, click the Delete button to delete one recipe at a
time.

To delete the entire selection of recipes, click the Delete All button.

Printing a Cookbook (PC only)
Before you print with Home Gourmet for the first time, you should use the Page Setup
command on the File menu to specify your printing preferences, such as the fonts, type
sizes, and styles to use, as well as page margins. Also make sure your printer is set up
correctly with the Printer Setup command on the File menu.
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To print a cookbook (or multiple recipes):

1. Click on the cookbook window to make it the current active window, and then
choose Print Cookbook from the File menu (or click the Print button on the
Control Bar).
On the left of the dialog box is a list of all categories in the current cookbook; on
the right is a list that will contain all the recipes in each of the categories that
you select from the Categories list on the left.

2. Click on the names of the categories containing the recipes that you want to
print.
When you click on a category name in the Categories list box, all the recipes in
that category appear in the Recipes list box on the right, already selected for
printing. As you click on additional categories, the recipes are added to the
Recipes list.
To select a contiguous group of categories, click on the first category name and
then drag down or up to the name of the last category in the group.
To select a non-contiguous group of categories, hold down the CTRL key as you
click on each category name.

NOTE:  Click the Select All button to select all the cookbook’s categories and all recipes
in the cookbook.

3. If you don’t want to print all the recipes in the categories you’ve selected, click
on the names of only those recipes you want to print.

4. Choose the general printing options you want by clicking on the appropriate
check boxes.

Choose... To...
Include Nutrition Print a per-serving nutritional analysis of each recipe

following the recipe.
Page Numbers Print page numbers at the bottom of each printed page.
Print Ingredients Print ingredients in columns with headings (Amount,,
in Columns Measure,, Ingredient,, Preparation).
One Recipe Per Page Prints only one recipe per page. (Otherwise,Home Gourmet

prints as many recipes as will fit on each page.)

5. Choose the Selected categories and recipesprinting options you want by clicking
the appropriate check boxes:

Choose... To...
Complete Recipes Print each recipe in full.
Category Index Print an alphabetized listing of all selected categories.
Recipe Index Print an alphabetized listing of all selected recipes.
Recipe Names Print an alphabetized listing of all selected recipes, organized by
by Category category.

6. Click the Print button.
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NOTE:  The Complete Recipes option is the only one that’s selected by default. If you de-
select it without choosing one of the other options, nothing can be printed, and a dialog
box will appear when you click the Print button, asking you to choose one of the printing
options.

Printing the Selected Recipes List (PC only)

The Selected Recipes List lets you group together any number of recipes in the current
cookbook. You can then print just those recipes. For example, you can select and then
print only the recipes for a dinner party you are planning.

To print all recipes in the Selected Recipes List:

1. Click on the cookbook window (or Selected Recipes List window) to make it the
current active window, and then choose Print Cookbook from the File menu (or
click the Print button on the Control Bar).

2. In the Categories list box, click on “* Selected Recipes.”
3. If you don’t want to print all the recipes in the Selected Recipes List, click on the

names of only those recipes that you want to print.
4. Choose the printing options you wish to use to print the selected recipes.
5. Click the Print button.

Printing a Cookbook (Mac only)

Before you print with Home Gourmet for the first time, it’s a good idea to use the Page
Setup command to specify your paper size and page orientation preferences.

To print a cookbook (or multiple recipes):

1. Click on the cookbook window to make it the current active window.
2. If you wish to print a selection of recipes rather than the entire cookbook, select

the recipes that you wish to print in the cookbook window.
To select a category (or group of categories) for printing, click the category name(s)
in the categories list on the left side of a cookbook window. All the recipes in the
selected category or categories will appear in the recipes list on the right. Then
click on the names of the recipes you wish to print in the recipes list on the right.
To select a contiguous group of categories, hold down the SHIFT key as you
click on the first and last category names in the group.

The Print Cookbook Dialog Box
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To select a non-contiguous group of categories, hold down the COMMAND key
as you click on each category name.

3. Choose the Print Cookbook command from the File menu, or click the Print
button on the Control Bar.

4. Click the appropriate radio button to choose whether to print the Entire Cookbook
(all recipes in the cookbook file) or just the recipes currently selected in the
cookbook or Recipe Clipboard window.

5. Click on the appropriate radio button to choose whether to print the recipes as a
book or as 3 x 5 or 4 x 6 recipe cards.

6. If you choose to print the recipes in book form, choose the printing options you
want by clicking on the appropriate check boxes:

Choose... To...
Recipes Print each recipe in full.
Include Nutrition Prints a per-serving nutritional analysis of each recipe.
Include Daily Values Print per-serving Daily Values for each recipe.
Number Pages Print page numbers and the cookbook name at the bottom of

each printed page.
Start Recipes on New Page Print only one recipe per page. (Otherwise, Home Gourmet

prints as many recipes as will fit on each page.)
Title Page Print a title page for the cookbook.
Alphabetical Index Print an alphabetized listing of all selected recipes,, along

with their page numbers (if page numbering is selected).
Category Index Print an alphabetized listing of all selected recipes, organized

by category, along with their page numbers (if page
numbering is selected).

If you choose to print the recipes in recipe card form, click the appropriate radio button to
choose whether to feed the cards from the center or left side of the printer’s paper feed.

7. Click the Print button.
8. Choose the additional print options, such as the number of copies, range of pages

to print, and the font and type size with which to print the recipes.
9. Click the Print button.

Printing the Recipe Clipboard (Mac only)

The Recipe Clipboard lets you group together any number of recipes in the current cookbook.
You can then print just those recipes. For example, you can select and then print only the
recipes for a dinner party you are planning.

To print the recipes in the Recipe Clipboard:

1. Click on the Recipe Clipboard window to make it the current active window, or
choose Recipe Clipboard from the Window menu.

2. To print all recipes on the Recipe Clipboard, choose Select All Recipes from the
Edit menu; to print only a selection of recipes on the Recipe Clipboard, click on
the names of those recipes that you wish to print.

3. Choose Print Recipe Clipboard from the File menu (or click the Print button on
the Control Bar).

4. Click the Selected Items radio button.
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5. Choose the printing options you wish to use to print the selected recipes.
See the preceding section, Printing a Cookbook, for detailed information on
cookbook printing options.

6. Click the Print button.
7. Choose the additional print options such as you want and click the Print button.

Tools
About the Home Gourmet Tools
The Home Gourmet Control Bar and Tools menu offer a variety of special features designed
to help make managing recipes faster and easier for you. The Wine List lets you create and
maintain a personal wine list, while the Glossary, Seasonings, Substitutions, and Yields
& Equivalents commands give you instant access to cooking terminology, measures, and
ideas for seasoning foods and substituting ingredients. The Preferences command lets you
customize the way Home Gourmet performs certain tasks.(The remaining Tools are covered
elsewhere in this manual.

The Control Bar

The Control Bar is the strip of buttons containing pictures that appears just below the
menu bar. See Setting Home Gourmet Preferences later for how to move the Control Bar.

The Control Bar is context-sensitive; that is, it changes according to the task you’re currently
performing in Home Gourmet. For example, when you first start Home Gourmet, only
three buttons appear:  the buttons for Help, Delete, and Open Cookbook. When you open
a cookbook, more buttons appear.

The buttons perform different tasks depending on what you’re doing in the program. For
example, if a recipe window is active, the recipe is printed; if a shopping list window is
active, the shopping list is printed.

NOTE:  To see what a button does, position the arrow pointer over the button. The button’s
function is displayed on the Control Bar.

The Wine List Manager

Home Gourmet lets you keep track of your wines with the Wine List command. This
command is useful if you collect wines or if you entertain and like to keep wine information
handy.

When you create a wine list, you create one entry for each type of wine for a single year.
The type is determined by the wine’s maker, type, and year. You can have two wines of a
different type from the same maker and year, or two wines with the same maker type but
from different years. However, you can’t have two 1991 Cabernet entries for the same
maker. Instead, record in the Bottles in Stock text box that you have two bottles of the
1991 Cabernet in stock.

To create a wine list:

1. Choose Wine List from the Tools menu.
2. To add a wine to the list, click the New button.
3. Type the name of the wine’s producer.
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4. Press TAB to move to the Type text box and enter the type of the wine: Bordeaux,
Champagne, Zinfandel, etc.

5. Press TAB to move to the Color text box and type the wine’s color.
6. Press TAB to move to the Year text box and type the year of the wine.
7. Add information to the remaining fields (optional): You can enter up to 9999

bottles in stock.
8. Click the Save button to save the wine to the wine list.

Continue adding wines in this fashion.
9. On a PC, click the Close button when you’re finished.

On a Mac, click the Wine List window’s close box or choose Close Window from the
Window menu when you’re done.

Modifying the Wine List

Once you’ve created your wine list, you can change it whenever you please by choosing
the Wine List command again. You can add new wines to the list as well as modify wines
already on the list.

To edit the wine list:

1. Open the wine list by choosing Wine List from the Tools menu.
2. To add a new wine to the list, click the New button and type the information

about the wine.
3. Click the Save button to save the information about the new wine to the wine

list.
4. To edit one of the wines in the list, click the name of the wine you want to edit

and then click the Edit button, or double-click the name of the wine you want to
edit.

5. Make any changes you like to the wine information by modifying the text in the
appropriate text boxes.

6. To delete a wine from the wine list, click the name of the wine in the list and
then click the Remove button.
The wine will be permanently removed. Be careful with removing wines from
the list with this button; it is one of the few commands in Home Gourmet that
cannot be reversed with the Undo command.

7. Click the Save button to save your changes to the wine list.
8. On a PC, click the Close button when you’re finished editing the wine list.

On a Mac, click the Wine List window’s close box or choose the Close Window command
from the Window menu when you’re finished editing the wine list.

The Wine List Dialog Box



16

Printing the Wine List

When you print your wine list, the number of bottles of each type of wine is printed,
followed by the maker, type, vintage year, and color.

To print the wine list:

1. Open the wine list by choosing Wine List from the Tools menu.
2. On a PC, click the Print button.

On a Mac, choose Print Wine List from the File menu.

Using the Glossary
The cooking glossary provides you with instant access to definitions for over 500 of the
most commonly used cooking and food terms.

To find a term in the glossary:

1. Choose Glossary from the Tools menu.
2. Select the term you want defined by typing the first few letters of the term or by

clicking its name in the list.

As you type, the list scrolls to display the term in the list that most closely
matches the letters you’re typing. The term’s definition appears in the Definition
box to the right.

3. On a PC, click the Close button to exit the Glossary.
On a Mac, click the Glossary window’s close box or choose the Close Window
command from the Window menu to exit the Glossary.

Finding the Right Seasoning to Use

The Seasonings command provides suggestions for using spices and herbs in two different
ways:  either view suggestions for a specific seasoning or suggested seasonings for use
with a specific food or dish.

To find food items for which to use a specific seasoning:

1. Choose the Seasonings command from the Tools menu.
2. On a PC, click the Seasonings given a Food Item option.

On a Mac, click the Seasoning to Foods option.
3. In the text box above the Seasonings list box, type the name of the seasoning or

click its name in the list.

The Glossary Dialog Box
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To find a seasoning for a food or dish:

1. Choose the Seasonings command from the Tools menu.
2. On a PC, click the Foods given a Seasoning option.

On a Mac, click the Food to Seasonings option.
3. In the text box above the Foods list box, type the name of the dish or foodstuff

for which to view suggested seasonings (or click its name in the list).
A collection of appropriate seasoning suggestions appears in the Seasonings text box on
the right.

To exit the Seasonings feature, click the Close button (on a PC) or click the close box to
close the Seasonings window, or choose the Close Window command from the Window
menu (on a Mac).

Finding Ingredient Substitutions

The Substitutions command gives you access to a handy reference of substitutions for a
variety of common recipe ingredients. Use these substitutes for ingredients that you or the
people you are serving can’t eat, or for ingredients that you don’t have on hand when
preparing a recipe.

NOTE:  The substitutions provided by Home Gourmet are at best only approximate
substitutes to be used in the preparation of your recipes. The nutritional and caloric values
of your recipes may be significantly affected. Taste and texture may also be affected, but
less dramatically.

To find a substitute for an ingredient:

1. Choose the Substitutions command from the Tools menu.
2. In the text box above the Ingredients list box, type the name of the item for

which you need a substitute (or click its name in the list).
3. On a PC, click the Close button when you’re finished.

On a Mac, click the close box to close the Substitutions window (or choose Close Window
from the Window menu) when you’re finished.

Finding Yields and Equivalents

The Yields & Equivalents command provides a handy cross-reference for translating
between different measurement units of a given type of food. An equivalent is the same
physical amount of an ingredient expressed in different measurement units. A yield is the
amount of a raw item remaining after it has been processed in some fashion; for example,
three and one-half pounds of almonds in the shell will yield one pound of shelled almonds.

To find a yield or equivalent for an ingredient:

1. Choose the Yields & Equivalents command from the Tools menu.
2. Select the item in the Ingredients list for which you want a yield or equivalent by

typing the first few letters of the item name in the text box above the Ingredients
list box (or by clicking its name in the list).
As you type, the list scrolls to display the term in the list that most closely
matches the letters you’re typing. Yields and/or equivalents for the selected
item appear in the Yields & Equivalents box.

3. On a PC, click the Close button when you’re finished.  On a Mac, click the close
box (or choose Close Window from the Window menu) when you’re finished.
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Setting Home Gourmet Preferences

The Preferences command on the Tools menu lets you custom-configure the way you perform
tasks with Home Gourmet. When you choose the Preferences command, a dialog box
appears that lets you specify the measurement system to use in creating recipes as well as
options for finding, displaying, and storing recipes on disk.

To set Home Gourmet preferences:

1. Choose Preferences from the Tools menu.
2. Click the radio button for the Measurement system you wish to use. The default

is Combined.
3. Click the appropriate radio button to choose whether to display ingredient amounts

as Common Fractions or Decimals. The default is Common Fractions. If you
choose Decimals, click the radio button for the number of decimal places you
wish to display.

4. Click the appropriate check boxes for the edit and display options.
5. Choose whether to save recipes in Compressed or Uncompressed format.

If you choose Compressed, Home Gourmet automatically compresses recipes when you
save them to save disk space, up to 50% of a regular save. This process may take slightly
longer than a regular save on some systems.

If you change this setting from Compressed to Uncompressed, recipes you create or edit
subsequently are saved in uncompressed format, but other recipes remain  compressed. If
you change back to Compressed, all recipes subsequently created or edited are compressed
when they are saved.

PC NOTE: In the Preferences dialog box, you can also choose where to place the Control
Bar on the screen (or to hide the Control Bar by choosing “None”) and specify what colors
are used in various parts of the program on-screen.

MAC NOTE: You can move the Control Bar to any place on your screen by clicking in the
shaded bar on the left of the Control Bar and dragging it to any place you prefer. The
Control Bar can also be hidden (and re-displayed) with the Hide Control Bar/Show Control
Bar command on the Window menu.

6. When you’re finished setting your preferences, click the OK button to save the
preferences for subsequent sessions with Home Gourmet.



19

Recipes
About Recipes
Recipes are the heart of Home Gourmet and the reason you purchased the program, so
Home Gourmet is designed to help you enter, organize, and locate your recipes as quickly
as possible.

When you create a recipe with Home Gourmet, it appears in a window resembling a
recipe card; by opening multiple recipes you can “flip through” the “recipe cards” by
quickly clicking on the appropriate “cards.” Each recipe window supports two views:
Edit View, which is designed to let you create and modify recipes as quickly as possible;
and Full View, which displays the recipe as it will look when printed, allowing you to read
the recipe more easily.

This section will tell you everything you need to know to store, organize, find, and print all
your favorite recipes using Home Gourmet.

Opening Recipes
The cookbook window lets you see at a glance all the categories and recipes in a cookbook,
and lets you open the recipes you choose by just pointing and clicking. The cookbook
window remains open for as long as the cookbook is open, although you can minimize it to
an icon if you choose.

The cookbook window is divided into two lists. In the list on the left are the categories in
the cookbook, like the chapter titles in the table of contents in a cookbook; following each
category name is a number indicating the number of recipes in that category. On the right
is a list containing the names of the recipes in the currently selected categories.

To open recipes from the cookbook window:

1. If the cookbook window is not the current active window, make it the active
window by clicking on it or by choosing it from the Window menu.

2. In the list of categories on the left, click on the names of the categories containing
the recipes that you wish to open.
As you click on each category name, the recipes associated with that category
are displayed in the list on the right.

3. In the recipes list on the right, click on the names of the recipes that you wish to
open.
On a PC, select contiguous groups of recipes by holding down the SHIFT key
while clicking on them. Select non-contiguous recipes by holding down the CTRL
while clicking on them.
On a Mac, select contiguous groups of recipes by holding down the SHIFT key
while clicking on them. Select non-contiguous recipes by holding down the
COMMAND while clicking on them.

4. Click the Open button.
 You can also open a single recipe by double-clicking its name in the recipe list.

NOTE:  Home Gourmet opens as many recipes as it has system resources for. If you
select more recipes than there are resources for, Home Gourmet displays a message
telling you know the maximum number of recipes that can be opened, and then opens that
number of recipes.
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Finding Recipes
Home Gourmet offers two fast and powerful commands for locating recipes, Find Recipe
and Search Recipes.

Find Recipe works like an automated cookbook index; it displays an alphabetized listing
of all recipes in the current cookbook, allowing you to choose by name the recipe you want
to open.

The Search Recipes command lets you quickly scan a cookbook for recipes that meet an
almost unlimited variety of criteria. In fact, you can search on any part of a recipe, and
combine your search requirements to make a search as specific or as general as you want.

Finding a Recipe by Name

The Find Recipe (Open Recipe on a Mac) command lets you open a recipe by choosing its
name from a list or by typing its name.

To find a recipe by name:

1. On a PC, choose Find Recipe from the Recipe menu.
On a Mac, choose Open Recipe from the Recipe menu.

2. Type the name of the recipe that you wish to open.  You can also scroll the list
until you see the name of the recipe that you wish to open and then click the
recipe name.

3. Click the Open button.

Searching for Recipes that Meet Your Requirements

Home Gourmet lets you look for recipes that call for certain ingredients, are in a certain
category, are from a certain source, or any combination of these criteria.

For example, if you have guests coming for dinner and only have a few ingredients on
hand, you can search for recipes that call for those ingredients. You could tell Home
Gourmet to find all recipes that: contain shrimp or chicken, call for garlic, and are in the
Italian or Chinese categories. For picky eaters, you can even search for recipes that don’t
include broccoli!

This is all done with a single command, Search Recipes, on the Recipe menu. The Search
Recipes dialog box lets you build search lines, which are like sentences telling Home
Gourmet what you’re looking for in a recipe. You can combine as many search lines as
you wish in order to create your own search criteria, so that you can be as general or as
specific as you want when looking for recipes.

Each search line consists of three components:

The part of the recipe you want to search
The type of search to be done
What you want to search for

To search for recipes that match your requirements:

1. Choose Search Recipes from the Recipe menu.
2. In the first list box, on the far left, click on the part of the recipe to search.
3. In the second list box, in the middle, click on the type of search you want to do.
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4. In the third list box, on the far right, tell Home Gourmet what you want it to
look for.
Separate words or phrases by typing commas between them.

5. Click the Add Line button to add the line to the Search Criteria list box.
You can repeat steps 2 through 5 above to add as many search lines to the Search Criteria
list box as you like.  To remove a search line from the Search Criteria list box, click on the
line and then click the Delete Line button. To remove all search lines from the Search
Criteria list box, click the Clear Search button.

To edit a search line, click on the line, click the Edit Line button, and then change the line
as you see fit. When you’re finished editing, click the Save Line button.

6. Click the appropriate button to choose to search by ALL of the criteria or ANY
of the criteria.

7. Click the Search button.
 If no recipes are found, Home Gourmet tells you it didn’t find any recipes matching your
criteria. When you click OK, Home Gourmet returns to the Search Recipes dialog box, to
let you try different search criteria. Do a new search or click Cancel to close the Search
Recipes dialog box.

 If recipes matching your criteria are found...

 On the PC:  Home Gourmet displays a dialog box telling you the number of recipes
found. When you click OK, Home Gourmet closes the Search Recipes dialog box and
displays the Selected Recipes window, a list of all recipes found.

 On the Mac:  Home Gourmet displays the Recipe Clipboard, which contains a list of all
recipes found.

8. Click on the recipes that appeal to you and then click the Open button. Home
Gourmet opens the selected recipes.

NOTE:  Home Gourmet automatically saves your search criteria so that you can do
successive searches without having to repeatedly re-enter your search requirements. If you
don’t want Home Gourmet to save your search criteria, you can de-activate this feature
with the Preferences command on the Tools menu. See Setting Home Gourmet Preferences
in the Tools section.

The Search Dialog Box
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Creating a New Recipe

Creating recipes is perhaps the single most important task performed by Home Gourmet.
This section is divided into the following groups of procedures:

Creating, naming, and saving a new recipe
Entering basic recipe information
Specifying categories for a recipe
Entering ingredients
The Ingredients List and nutritional information
Typing directions
Recipe options

To create, name, and save a new recipe:

1. Choose New Recipe from the Recipe menu, or click the New Recipe button on
the Control Bar.

2. Type the name of the recipe in the Recipe Name text box.
3. Click the Save button.

To enter basic recipe information:

1. Press TAB to move to the Recipe By text box.
2. Type the name of the recipe’s author.

You can use this area to record the name of the cook who created the recipe or
the cookbook it came from.

 3. Press TAB to move to the Servings text box.
 4. Type the number of servings the recipe makes.

Home Gourmet uses this number to adjust the ingredient amounts for a variable number
of servings (up to 999). In many recipes, this amount is the number of individuals the
recipe serves. In some recipes, however, this number indicates the number of units produced:
loaves, cakes, pies, etc.

NOTE:  Some recipes, particularly those for breads, were not intended by their authors to
be scaled. If you are creating a recipe that you feel shouldn’t be scaled, use the Notes text
box to indicate that the recipe serving size should not be altered.

 5. Press TAB to move to the Preparation Time text box.
 6. Type, in hours and minutes, the approximate amount of time required to prepare

the recipe.

The New Recipe Dialog Box
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To designate hours, type a number followed by a colon otherwise, Home Gourmet will
assume only minutes are intended and will convert the time to hours and minutes based on
the number of minutes. For example, if you type “3:00,” the preparation time will be three
hours and no minutes; but if you type “300,” Home Gourmet will assume you mean 300
minutes and will convert it to five hours and no minutes.

You don’t have to specify the amount of preparation time. If you don’t enter a preparation
time, the default time of zero hours and minutes will be used.

To specify categories for a recipe:

1. Click the Categories button.
2. Click the check box beside each appropriate category name. You can choose up

to ten categories for any one recipe.
3. If you wish to add or change a category, click the Edit Categories button.

The Cookbook Categories dialog box appears, to allow you to add to or modify
the categories in the current cookbook. For more information, see Editing a
Cookbook’s Categories in the Cookbooks.
Make your changes and then click OK to return to the Recipe Categories dialog
box.

4. Click the OK button to save your category specifications and exit the dialog box.
The area following Categories lets you enter the recipe’s ingredients. For each ingredient,
you type the amount, followed by the measurement unit, the ingredient name, and the way
you want the ingredient repared prior to cooking. You’ll repeat the instructions below for
each ingredient you enter in a recipe.

To enter ingredients for a recipe:

1. Press TAB to move to the Amount column of the Ingredients list box.
2. Type the amount of the ingredient.

You can type either decimal or fractional amounts.
3. Press TAB to move to the Unit column of the Ingredients list box.
4. Type a measurement unit.

 Home Gourmet’s fast-auto feature “fills in” the text box with the name of the unit that it
“guesses” you want, based on the letters typed so far. The portion of the unit name that
you didn’t type appears selected, which means you can continue typing to specify a different
unit.

If the auto-fill unit name is the one you want, you can just press TAB to move to the next
column. If it’s not, you can click on another unit name in the list or continue typing to find
a different standard unit. If you wish to use a non-standard measurement unit one not in
the listjust type any non-standard name you wish.

NOTE:  A non-standard unit name is treated as a “whole” for nutritional information. For
example, if you type “stick” to indicate a stick of butter, Home Gourmet will assume that
you mean a whole unit of butter in stick form when it calculates nutritional information
for the recipe.

5. Press TAB to move to the Ingredient column and type the name of the ingredient.
As you type the ingredient name, a list appears below it, showing you a list of food items
maintained for the purpose of providing nutritional information (known as the Ingredients
List).  The item most like the one you’re typing appears highlighted and appears “auto-
filled” in the text box where you’re typing.
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NOTE:  The items that appear in all capital letters (in bold type on a Mac) are the items
in the Ingredients List whose volume nutritional information is maintained in whole
quantities (such as an egg, a slice of bread, a whole banana) rather than in standard
measurement units (cups, liters, tablespoons, etc.). When you choose such an item, specify
either a whole unit or a weight unit in the Unit column, or the nutritional analysis for the
recipe may be inaccurate.

To enter an ingredient not on the Ingredients List, just type any name you wish. You won’t
be asked to provide additional information about this ingredient unless you create a
nutritional analysis of the recipe.

6. Press TAB to move to the Preparation Method column of the Ingredients list box
and type any relevant information about how the ingredient should be prepared
prior to cooking.

As you type, a drop-down list of preparation methods. The item most like the one you’re
typing appears highlighted in the list; it also appears “auto-filled” in the area where you’re
typing. If you type a name not already in the list, it will be added to Home Gourmet’s list
of preparation methods when you save the recipe.

To enter recipe directions:

1. Click the Directions button.
2. Type the recipe’s directions, up to 10,000 characters.

PC NOTE:  To create a degree symbol, hold down the ALT key while typing 0176 on your
numeric keypad. This may not work for all fonts.

MAC NOTE:  To create a degree symbol, press OPTION+SHIFT+8. This may not work
for all fonts.

3. On a PC, click the OK button to save your changes or Cancel to close the dialog
box without saving changes. The Save button lets you save what you’ve typed so
far and continue typing more text.

On a Mac, click the window’s close box to save the directions.

The text areas Suggested Wine, Serving Ideas, and Notes are optional features where you
can enter additional information about the recipe or suggestions for what to serve with the
meal.

To enter recipe options (Suggested Wine, Serving Ideas, Notes):

1. Press TAB to move to the Suggested Wine text box.
2. Type a wine suggestion, then press TAB to move to the Serving Ideas text box.
3. Type serving ideas, such as other foods or recipes to serve with the recipe.

For example, if you have a two-part recipe, such as a meat dish served with a certain
sauce, you may want to divide it into two recipes and use the Serving Ideas area in each
recipe to store a reference to the companion recipe.

4. Press TAB or use the mouse to move to the Notes text box.
5. Type your notes for the recipe.

For example, you might want to note special instructions for the recipe, or information
about the restaurant or cookbook where the recipe originated. The Notes text area can
hold up to 1,000 characters.
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Recipe Ingredients and Nutritional Information
You may wish to use an ingredient name not on the Ingredients List that nevertheless
describes an item for which Home Gourmet maintains nutritional information. For
example, you might be typing a recipe that calls for “Grecian laurel leaves or bay leaves.”
Home Gourmet doesn’t have nutritional information for Grecian laurel leaves, but it
does for bay leaves.

Home Gourmet lets you create just such a link, called an association. Furthermore, Home
Gourmet offers a variety of convenient and easy ways to associate ingredients and
nutritional data. In addition, Home Gourmet also lets you display a nutritional analysis
of an ingredient in the recipe window, so you can check on an ingredient’s nutritional
content even as you enter it.

To create a nutritional association for an ingredient:

1. On a PC, in the recipe’s Ingredient column, double-click the name of the ingredient
for which you wish to create a nutritional association (or click on the name and
press ALT+A).
On a Mac, in the recipe’s Ingredient column, click on the name of the ingredient
and choose Link With Ingredient from the Edit menu.

2. Click the name of the food item with which you want to associate the ingredient.
Scroll the list if the appropriate item is not in view, or type the name of the food
item in the text box above the list.

3. Click the OK button.

PC NOTE:  You can also make an association “on the fly” as you enter an ingredient. As
you type the ingredient name, a drop-down menu containing the Ingredients List appears.
Holding down the CTRL key, click the name of the food item you wish to associate with
the ingredient. The new ingredient is now linked to one on the Ingredients List and can
use its nutritional information when you create a nutritional analysis of a recipe. To remove
a nutritional association, double-click the ingredient name or select the ingredient name
and press ALT+A. Then press the DELETE key to remove the association and click the
OK button. The ingredient appears in the regular typeface to indicate that it is an ingredient
without a nutritional association.

To display the nutritional profile of an ingredient in the recipe window:

On a PC, click with the right-side mouse button on the name of the ingredient for which
you wish to display a nutritional profile (or click on the name and press ALT+N).

On a Mac, click on the name of the ingredient and choose Ingredient Analysis from the
Tools menu.

Editing and Viewing Recipes
Home Gourmet supports two views of recipes:  Edit View, where you create and change
a recipe, and Full View, which shows how a recipe will look when printed. Edit View
makes creating and modifying recipes a snap; Full View makes it easy to read recipes
quickly.
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Editing a Recipe

Home Gourmet gives you complete freedom in editing your recipes just open the recipe
you want to modify and make whatever changes you like. Once you save a recipe, however,
your changes become permanent. If you want to add to or otherwise change a recipe but
retain the old recipe information, first make a copy of the recipe using the Save Recipe As
command. See Making a Copy of a Recipe and Renaming a Recipe later in this section for
information on making copies of recipes.

To edit a recipe:

1. Open the recipe from the cookbook window or locate it using the Find Recipe or
Search Recipes commands.

2. Make your changes to the recipe.
For complete information on working in a recipe window, see Creating a New
Recipe in this section. You can also copy, cut, paste and delete rows within a
recipe, or even copy, cut or paste an entire recipe. All of these commands are
located on the Edit menu (you can also use the shortcut keys listed next to the
commands on the menu.).

3. Click the Save button to save your changes.

Viewing a Recipe with Full View

Full View lets you view a recipe in the format similar to the one used when the recipe is
printed. In Full View, recipes can be read easily from a distance, so if you use your computer
in the kitchen, use Full View to see the recipe clearly.

To display a recipe with Full View:

 1. Open the recipe to be viewed.
 2. Click the Full View button. The recipe window changes to display a scrollable

text area. The Full View button changes to Edit.
3. To return to Edit view, click the Edit button.

The Full View Window
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Making a Copy of a Recipe
When you want to make a copy of a recipe, use the Save Recipe As command. This saves
a copy of the recipe with a different name to the current cookbook. Use Save Recipe As to
make changes to a recipe and keep a copy in its original form as well.

To make a copy of a recipe:

1. Open the recipe you want to duplicate.
2. Choose Save Recipe As from the Recipe menu.
3. Type a new name for the recipe and click the OK button.

Renaming a Recipe

Renaming recipes in Home Gourmet is simple, just give it a new name and save it!

To rename a recipe:

1. Open the recipe you want to rename.
2. Type a new name for the recipe in the Recipe Name text box.
3. Click the Save button to save the recipe with its new name.

The recipe is saved with its new name to the current cookbook. Its name is changed in the
cookbook window.

Deleting the Current Recipe
Home Gourmet provides you with a variety of ways to remove unwanted recipes from a
cookbook: the Delete Recipes command on the File menu lets you remove a group of
recipes from a cookbook at one time; Cut Recipe, on the Edit menu, lets you remove a
recipe from a cookbook while at the same time placing a copy of the recipe on the Clipboard.
If you wish to permanently remove the current recipe quickly, use the Delete Current
Recipe command on the Recipe menu.

To delete the current recipe:

1. If it’s not already open, open the recipe you wish to delete.
2. Choose Delete Current Recipe from the Recipe menu or click the Delete button

on the Control Bar.
3. Click Yes to confirm that you want to delete the recipe.

NOTE: This operation cannot be reversed with the Undo command. Use with care!

Printing a Recipe (PC only)
Before you print with Home Gourmet for the first time, you should use the Printer Setup
and Page Setup commands to specify your printing preferences, such as paper size and
orientation, fonts, and margins.

To print a recipe:

1. Make sure the recipe you want to print is the current active window.
2. Choose Print Recipe from the File menu or click the Print button on the Control

Bar.
3. Click the check boxes for the print options you want:
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Choose... To...
Include Nutrition Information Print a per-serving nutritional analysis following

the recipe.
Include Shopping List Print a shopping list for the recipe.
Print Page Numbers Print a page number at the bottom of each page.
Print Ingredients in Columns Print ingredients in columns with headings

(Amount,, Unit,, Ingredient,, Preparation).
One Recipe Per Page Start a new page for each recipe.

4. To print all recipes currently open in the Home Gourmet Workspace, click the
Print All Open Recipes button.

5. To print more than one copy of a recipe, type the number of copies you want in
the Copies text box.

6. Click the OK button.

Printing a Recipe (Mac only)
Before you print with Home Gourmet for the first time, you should use the Page Setup
command to specify your printing preferences, such as the size and orientation of the
paper.

To print a recipe:

1. Make sure the recipe you want to print is the current active window.
2. Choose Print Recipe from the File menu or click the Print button on the Control

Bar.
3. Click the appropriate radio button for the type of page you wish to print on: Full

Pages (uses the current paper size last specified with Page Setup), 3 x 5 Cards,
or 4 x 6 Cards.

If you choose Full Pages, click the check boxes for the print options you want:

Choose..., To...
Include Nutrition Print a per-serving nutritional analysis following the recipe.
Include Daily Values Print the per-serving Daily Values for the recipe.
Include Shopping List Print a shopping list for the recipe.
Number Pages Print a page number at the bottom of each page.

If you choose 3 x 5 Cards or 4 x 6 Cards, click the appropriate radio button for Center Feed
or Left Feed.

4. Click the Print button.
5. To print more than one copy of a recipe, type the number of copies you want in

the Copies text box.
6. Specify the font and type size you wish to print with.

If you’re printing on index cards, you may want to use a smaller font.
7. Click the OK button.
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Scaling a Recipe
With the Scale Recipe command, Home Gourmet lets you adjust the ingredient amounts
for a recipe to accommodate a different number of servings than the original recipe. Note,
however, that, for a variety of reasons related to food chemistry, some recipes simply
cannot be reliably scaled. Some culinary experts warn against scaling complex recipes by
more than a factor of two, and against scaling recipes for baked goods at all.

To scale a recipe:

1. Make sure that the recipe you want to scale is the current active window.
2. Choose Scale Recipe from the Recipe menu or click the Scale Recipe button on

the Control Bar.
3. Type the new serving size and click the OK button.

The ingredient amounts are adjusted to accommodate the new serving size. In addition,
where appropriate, the measurement units are also changed.

Changing a Recipe’s Measurement Units
When it comes to dealing with different measurement systems for recipes, Home Gourmet
offers you unprecedented flexibility. With the Preferences command, you can specify
whether you want to use the American (i.e., English) measurement system or the Metric
system, or both, and specify up to three decimal places for Metric amounts (see Setting
Home Gourmet Preferences in the Tools section for more information on choosing a
measurement system with the Preferences command).

The Preferences command specifies the measurement system in use when you create a
recipe. If you wish to change the measurement system of an existing recipe (or of some of
the ingredients in a recipe), you can use the Change Units command on the Recipe menu.
Change Units not only lets you change from one measurement system to another, it even
lets you change between volume and weight measures for most ingredients.  In addition,
for any given measure, it displays a list of possible alternative measures from which you
can choose the unit of measurement you find most appropriate.

To change a recipe’s measurement units:

1. Open the recipe that you wish to change.
2. Choose Change Units from the Recipe menu.
3. To change the measurement unit for a single ingredient, click on the ingredient

in the list box on the left to select it.
4. Click on the new measurement unit (in the Change To list box) that you wish to

use.
Repeat steps 3 and 4 to change other ingredients in the recipe.

5. To change all ingredients in the recipe to one measurement system, Metric or
American, click either the Change All to Metric or Change All to American
button.

When you’re finished, click the OK button.

Creating a Nutritional Analysis of a Recipe

You can get a per-serving nutritional analysis of a recipe with the Nutrition Analysis
command. The nutritional analysis includes the total cholesterol, fat, calorie (kcal),
carbohydrate, fiber, and nutrient content of the recipe.
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To create a nutritional analysis of a recipe:

1. Make sure the recipe for which you want to create a nutritional analysis is the
active window.

2. On a PC, choose Nutrition Analysis from the Recipe menu.
On a Mac, choose Nutritional Analysis from the Tools menu or click the
Nutritional Analysis button on the Control Bar.

3. To view the Daily Values for the recipe, click the Daily Values button.
This displays the nutrient amounts provided by one serving of the recipe,
expressed as a percentage of the new FDA-recommended daily intake of those
nutrients.
Click the Cancel button to return to the Nutrition dialog box.

4. To print a copy of the nutritional analysis, click the Print button.
5. On a PC, click Cancel to close the dialog box.

On a Mac, click Done to close the dialog box.

NOTE:  If you use the Nutrition Analysis command with a recipe that uses ingredients not
on the Home Gourmet Ingredients List, a dialog box will appear, displaying a list of the
ingredients in the recipe but not in the Ingredients List. You can choose OK (Continue on
a Mac) to display the nutritional analysis with only the nutritional information currently
available, or Cancel to end the procedure without displaying a nutritional analysis.

Shopping Lists for Recipes
With Home Gourmet, you can print shopping lists for recipes or for groups of recipes as
menus.

To create a shopping list for a recipe or group of recipes:

1. For a single recipe, make sure the recipe for which you want a shopping list is
the current active window.

MAC NOTE:  For a group of recipes, click on the names of the recipes in the cookbook
window that you wish to add to the shopping list.

2. On a PC, choose Shopping List from the Recipe menu.
On a Mac, choose Build Shopping List from the Shopping List menu.
Click on the Add Basic Shopping List button to add items you’ve placed on the
Basic Shopping List to the recipe shopping list, both on screen and when you
print the shopping list. See The Basic Shopping List later.

3. On a PC, click the Close button to close the shopping list.
On a Mac, click the close button of the shopping list window to close the shopping
list.

You can add, delete, cut, copy and paste items on the list by using the buttons in the dialog
box (on a PC) or the commands on the Edit and Shopping List menus (on a Mac).

Printing a Shopping List

When you print a shopping list, it’s printed with your current page size and type style
settings. To change the page size or type style for the shopping list, close the list, adjust
your settings with the Printer Setup and/or Page Setup commands, and then return to the
shopping list.
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To print a shopping list on a PC:

Click the Print button.

To print a shopping list on a Mac:

1. With the shopping list window active, choose Print Shopping List from the File
menu or click the Print button on the Control Bar.

2. Choose the options you wish to print with and click the Print button.

The Basic Shopping List
Home Gourmet lets you create and maintain a shopping list of staple grocery items that
you purchase on almost every trip to the store. The items on this list can be added to the
shopping lists you create for recipes.

To create a Basic Shopping List on a PC:

1. Choose Basic Shopping List from the Tools menu.
2. To add an item to the Basic Shopping List, click the Add line button.
3. Type in the appropriate information and click Add and Continue to add another

item or OK when you’re finished entering items.
4. Click OK to save the list.

To create a Basic Shopping List on a Mac:

1. Choose Edit Basic Shopping List from the Shopping List menu.
2. To add an item to the Basic Shopping List: type the item name in the Item

column; press TAB to move to the Amount column and type an amount (if you
wish); press TAB to move to the Store Location column and type a store location
for the item.

3. Type comments or notes in the “Recipe/Notes” column if you wish.
4. Continue adding items in this manner; when you’re done, choose Save Shopping

List from the Shopping List menu.
 5. Click the Basic Shopping List’s close box or choose Close Window from the

Window menu.
After creating the Basic Shopping List, you can make changes to it at any time.

To edit items in the Basic Shopping List on a PC:

1. Choose Basic Shopping List from the Tools menu.
2. Click on the item you want to edit.
3. Click the Edit button.
4. Modify the item information. And click the OK button to save your changes.

To edit items in the Basic Shopping List on a Mac:

1. Choose Edit Basic Shopping List from the Shopping List menu.
2. Edit the items that you wish to change.
3. Choose Save Shopping List from the Shopping List menu.

To remove items from the Basic Shopping List (PC or Mac):

1. With the Basic Shopping List displayed, click on the number of the item(s) in
the list that you wish to remove.

2. On a PC, click the Delete button.
On a Mac, choose Clear Row(s) from the Edit menu.
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Excluding Basic Shopping List Items

“Excluding” or “hiding” a basic shopping list item means that, while you wish to keep the
item on the Basic Shopping List for future use, you don’t want it added to the next recipe
shopping lists to which you plan to add Basic Shopping List items.

For example, you may not buy dog food frequently on every trip to the grocery store. By
marking “dog food” as excluded, it won’t appear on the next shopping list you create for a
recipe. When you want to add dog food to your shopping lists, you simply remove the
“exclusion mark” in the Basic Shopping List window using the directions below.

To hide Basic Shopping List items on a PC:

1. With the Basic Shopping List displayed, choose each item that you want to hide.
2. Click the Hide button.

 To include hidden items, click on the item and click the Unhide button.

To exclude Basic Shopping List items on a Mac:

With the Basic Shopping List dialog box displayed, click in the Exclude column of each
item in the list that you wish to exclude.

To include items again, simple click in the Exclude column to remove the “X”.  You print
the Basic Shopping List as you would any other type of shopping list.

Saving a Recipe as an Ingredient

Some recipes contain other recipes. For example, a recipe in the Famous American Chefs
cookbook, “Lamb Spirals with Goat Cheese Ravioli,” calls for “Beurre Blanc,” a classic
white sauce that can be used for other recipes as well. However, including “Beurre Blanc”
as an ingredient in the “Lamb Spirals” recipe can make the nutritional analysis of the
recipe inaccurate. To solve this problem, you simply save the recipe, and all its nutritional
information, as an ingredient in the Ingredients List.

To save a recipe as an ingredient:

1. Open the recipe you wish to save as an ingredient.
2. Choose Save as Ingredient from the Recipe menu.

 The recipe and all its nutritional information is saved as an ingredient in the Ingredients
List. You can now use it as an ingredient in your recipes.

Recipe Cost Analysis

To help you keep track of your food costs, Home Gourmet includes cost analysis for both
recipes and menus. However, this cost analysis is based on the individual costs of
ingredients, and food costs vary widely depending on a number of factorsseasonality,
regional costs, weather, etc. For this reason, ingredients in the Home Gourmet Ingredients
List do not come with costs, although you can add them with the Ingredients List command
on the Tools menu.

To find the cost of a recipe:

1. Open the recipe for which you want a cost analysis. To perform a cost analysis
for a group of recipes, highlight those recipes in the cookbook window.

2. Choose Cost Analysis from the Recipe menu. On a PC, click the Close button
when you’re done with the cost analysis.
On a Mac, click the OK button when you’re done with the cost analysis.
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Ingredients
About Ingredients
One of the ways Home Gourmet makes it easy to type in all your recipes is through the
use of the built-in Ingredients List, which includes nutrition, store location, and cost
information for over 4,000 food items. With this list, you can automatically create nutritional
and cost analyses of your recipes, and add store locations to shopping lists. You can also
add thousands of your own ingredients to the Ingredients List.

This section explains how to find information on specific ingredients; how to add ingredients
to the Ingredients List, for future use in recipes and menus; how to edit ingredients already
on the Ingredients List; and information on adding store location and cost to food items on
the Ingredients List.

Ingredients and Nutrition Analysis
Home Gourmet puts a wealth of nutritional information at your fingertips. With Home
Gourmet, you can prepare a nutritional analysis of a recipe, or look up the nutritional
content of individual food items, automatically, without scanning nutrition tables or doing
a lot of complicated recipe math.

Sometimes an item on the Ingredients List describes a foodstuff for which the nutritional
information is based on a whole unit, such as an egg, a stick of butter, etc., as opposed to
a standard measurement unit, such as a cup or a tablespoon. For example, if you were to
specify a cup of bananas, but had chosen the item in the Ingredients List for whole rather
than sliced bananas, your nutrition information for the recipe would be slightly inaccurate.

Home Gourmet helps you avoid this problem by:

Making the information in the Ingredients List as descriptive as possible, including
information about whether the item is in a whole or standard volume measurement unit.

Displaying in capital letters (bold type on a Mac) the names of all items with nutritional
data based on whole units on the Ingredients List only (in a recipe they are in plain text).

As a final note, Home Gourmet calculates its nutritional analyses based on only that
portion of a food which is actually consumed; refuse such as bone, shell, or other unused
or inedible parts of an ingredient, is factored out of the analysis. This makes your nutritional
profiles much more accurate.

Ingredients and Cost Analysis
In addition to nutritional analysis, Home Gourmet also supports cost analysis, so that you
can determine the cost of a recipe or menu. However, since food costs can vary dramatically
with variables such as geography, we do not include costs for ingredients.

You can, however, add costs to the food items in the Ingredients List.  For information on
using the Ingredients List command to add cost information to an ingredient, see Editing
Ingredient Information in this section.
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Store Location
With Home Gourmet you can track ingredients by the location of items in your grocery
store. You can even sort shopping lists by store location, allowing you to group items
together by store location. This way, you can tailor your shopping lists to make it easier to
find what you’re looking for when you shop for groceries.

For information on using the Ingredients List command to add store location information
to an ingredient, see Editing Ingredient Information later in this section.

Finding and Displaying Ingredient Information
Home Gourmet provides two convenient ways of viewing (and editing) ingredient
information: with the Ingredients List command on the Tools menu and from within a
recipe window.

The Ingredients List command on the Tools menu is the “housekeeping” command you’ll
use to maintain your Ingredients List. This command lets you find, display, edit, copy, and
delete nutritional and other information for any item in the Ingredients List. You can enter
or modify an ingredient’s weight and volume amounts, store location, cost, and nutritional
data.

With the exception of calories (kcal), percent refuse, and vitamin A, for which special
measurement units have been provided, all nutritional characteristics of an ingredient are
given in grams, milligrams, and micrograms. Nutritional information is for the amount of
the ingredient specified; this amount may be in either metric or American units.

To view ingredient information:

1. Choose the Ingredients List command from the Tools menu.
2. In the text box above the Ingredients list box, type the first few letters of the

name of the ingredient you wish to view.
3. Click the Edit button (or double-click the ingredient name in the list).

When you’re done viewing the ingredient information, repeat the process to view another
ingredient, or click Cancel (Done on a Mac) to exit the dialog box.

To view ingredient information from a recipe window on a PC:

With the recipe open, click the name of the ingredient you wish to view with the right
mouse button.

OR

With the recipe open, click the name of the ingredient you wish to view and press ALT+N.

To find ingredient information from a recipe window on a Mac:

With the appropriate recipe window open, click the name of the ingredient you wish to
view and choose Ingredient Analysis from the Tools menu.

NOTE: You can also change ingredient information from within a recipe. To do this, click
the Edit button on the Ingredient Analysis dialog box. This, in effect, executes the Ingredients
List command and automatically selects the current ingredient for editing; all you have to
do is provide the new information. For more information on editing an ingredient with the
Ingredients List command, see Editing Ingredient Information, later in this section.
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Adding an Ingredient
You can add ingredient information for new food items to the Ingredients List, expanding
Home Gourmet’s nutritional and cost analysis capabilities. Once you add ingredient
information for a new food item, it is available for use with all your future recipes.

Most commercial foods now provide nutritional information about the product on the
package. You can use this information, along with price and store location, to add frequently
used commercial food products to the Ingredients List.

To add a new ingredient to the Ingredients List:

1. Choose the Ingredients List command from the Tools menu.
2. Click the New button.
3. Type the name of the food item in the Ingredient Name text box.
4. Press TAB to move to the Weight text box and type the food item’s weight as it

appears on the package.
In addition to its name, a weight measure is the only information you must supply
to Home Gourmet.

5. Choose the weight unit listed on the product package from the list of weight
units.

6. Press TAB to move to the Volume Equiv text box and type the food item’s volume
amount as it appears on the product package.

7. Choose the volume measurement unit listed on the product package from the list
of volume units.

8. Add the cost, store location, and nutritional information (from the product
package).

Press TAB to move from field to field. If you leave a nutrient field blank, the letters “N/A”
appear to indicate that information for that nutrient is “not available.”

9. When you’re finished adding ingredient information, click the Save button.
Continue adding ingredients in this manner.

10. On a PC, when you’re finished, click the Close button.
On a Mac, click the Done button when you’re finished.

Editing Ingredient Information
The Ingredients List command on the Tools menu lets you change the ingredient information
for any item in the Ingredients List. You can also make a copy of an ingredient and save it
with a different nameand delete ingredients that you don’t use from the list.

To edit an ingredient:

1. Choose the Ingredients List command from the Tools menu.
2. In the text box above the Ingredients list box, type the first few letters of the

name of the ingredient you wish to view.
3. Click the Edit button (or double-click the ingredient name in the list).
4. Make any changes you like to the information for the food item, including name,

amount, and nutrient data.
Press TAB to move from field to field. If you delete the information in a nutrient
field, the letters “N/A” appear, indicating that information for that nutrient is
“not available.”

5. Click the Save button to save your changes.
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To copy/renamean ingredient:

1. Choose the Ingredients List command from the Tools menu.
2. In the text box above the Ingredients list box, type the first few letters of the

name of the ingredient you wish to view.
3. Click the Edit button to display the selected ingredient.
4. Give the food item a new name.

If you don’t give the item a new name, a dialog box will appear, asking you to
give the item a different name.

5. If you wish, make any changes you like to the ingredient’s cost, store location, or
nutrition information.

6. On a PC, click on the Save button to rename the ingredient, or click on Copy to
create a new ingredient with the new name.

On a Mac, click the Save button, then click on Rename to rename the ingredient or click
on Create New to create a new ingredient with the new name.

To remove an ingredient from the Ingredients List:

1. Choose the Ingredients List command from the Tools menu.
2. Select the item you wish to remove from the Ingredients List, either by clicking

it with the mouse or by typing the first few characters of the ingredient name in
the text box.

3. Click the Remove button.
4. On a PC, click on the OK button to confirm that you want to delete the ingredient.

On a Mac, click the Remove button to confirm that you want to delete the
ingredient.
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