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Links from Whacked Pages
After whacking a page, you can select one or more links from that page to be whacked as well.    The 
following paragraphs show you how to add those associated links to the WebWhacker Group list so they 
can be whacked as well. 

1.    To add more links from the whacked page, click once on the page to select it.    Then click on the Add 
Links icon.    You can also select Add Links... from the Group menu. 

2.      You will see the Add Links dialog, which displays a list of all links that are on this page.    If the text is 
black, the link can be added to the Group list.    If the text is gray, the link cannot be added to the Group 
list. 

If there is no symbol to the left of the link, that link has not been added to the Group list.    If the symbol to 
the left of the link is a page, that link has been whacked.    If the symbol is a globe, that link is in the Group 
list but has not been whacked. 

3.    Select and mark the links you want to add to the Group list by selecting links and using buttons, or by 
double-clicking on the link.    You can mark or unmark some or all of the links.    A marked link displays a 
globe icon in the left column.    For more information on selecting multiple links, refer to Selecting Multiple 
Objects.    Click Add when you are finished marking links to be added to the Group list. 

4.    You now see the URL in the Group list.    The globe icon in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The knife in the second column indicates that 
this URL is set "To be Whacked".

If you want to change the whacking flag for one or more URLs, go to Step 3: Enable or Disable Whack.

If all of the URLs are set correctly and you want to start whacking, refer to Step 4: Whack.
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URLs from GrabNet
You can add a URL to WebWhacker by dragging or copying an object from GrabNet.    To do so, simply 
drag any GrabNet object that includes a URL and drop into an open WebWhacker Group window. 

You can also copy any GrabNet object that includes a URL and paste it into an open WebWhacker group 
window.    For more information on dragging or copying objects from GrabNet, refer to    GrabNet Help. 

You now see the URL in the Group list.    The globe icon in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The knife in the second column indicates that 
this URL is set "To be Whacked".

If you want to change the whacking flag for one or more URLs, go to Step 3: Enable or Disable Whack.

If all of the URLs are set correctly and you want to start whacking, refer to Step 4: Whack.
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New URL
You can manually add a new URL to the WebWhacker Group list that was created or opened in Step 1.

1.    To add a new URL, select New URL... from the Group menu.

2.    In the New URL dialog, type or paste the URL you want to add and press Enter. 

3.    You now see the URL in the Group list.    The globe icon in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The knife in the second column indicates that 
this URL is set "To be Whacked".

If you want to change the whacking flag for one or more URLs, go to Step 3: Enable or Disable Whack.

If all of the URLs are set correctly and you want to start whacking, refer to Step 4: Whack.
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Group
You can close a WebWhacker Group window without deleting its contents.    Multiple Groups can be 
opened at the same time. 

To close a Group window, select Close Group from the File menu, or press Ctrl+W.    You can also click 
on the CloseBox in the upper-left corner of the window. 
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Configuring WebWhacker
WebWhacker uses your Web browser to view Web pages and other objects that have been whacked.    
The following procedure shows you how to configure WebWhacker with the location and name of your 
Web browser.    For more information on this and other WebWhacker preferences, refer to Preferences.

For information on which Web browsers can be used with WebWhacker, refer to System Requirements.

1.    Select Preferences... from the Options menu.    You will then see the Preferences dialog.

2.    Click on the Browse button.    You will see the standard Open dialog.

3.    Navigate to and select the desired Web browser application.    When the correct Web browser is 
highlighted, select OK.    You will then see the path and filename in the Web Browser: field.

4.    Also on the Preferences dialog, enter your e-mail address in the E-mail: field.    Many Web sites 
require the e-mail address of the user requesting a page from their server.    If you do not have an e-mail 
address, enter your name in this field.

5.    The HTTP Proxy: and Port: fields are used when WebWhacker must go through a proxy server 
(firewall) to access the Web.    If your Web browser is configured for a proxy server, then WebWhacker 
will have to be configured as well.

If you use a proxy server, enter the name or IP address of the proxy server in the Proxy field, then enter 
the Port number in the Port field.    To get the Proxy server name, IP address and Port number, ask your 
System Administrator.

You have now configured WebWhacker.    Select OK to save your changes.
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an Object
Any WebWhacker object can be copied to the Windows Clipboard.    Only one object at a time can be 
copied.    If a whacked object is copied, only the URL is copied.    An object that is copied can be pasted 
into a different Group list or another application using the Paste command. 

A WebWhacker object can also be copied by dragging it from one Group list to another.    When it is 
dropped into another Group, it is set as Remote and To Be Whacked one level.    For more information, 
refer to Dragging Objects to Another Group.

To copy a WebWhacker object, select the desired object and click on the Copy icon.    You can also select 
Copy from the Edit menu, or press Ctrl+C. 

You can now paste the object.    For information on how to paste an object into a Group list, refer to 
Pasting an object.
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New Group
On your local drive, a Group contains all pages, images and other objects that have been whacked. 

To keep these files organized, you should keep each Group in a separate subdirectory.    The name of the 
Group can (and should) be the same name as the subdirectory.

1.    To create a new Group, select the New Group   icon  .    You can also select New Group... from the File 
menu, or press Ctrl+N.

2.    You will see the New   WebWhacker   Group dialog  .    Make sure the location for the new subdirectory 
and Group is where you want.    If not, navigate to the desired location.

3.    To create a new subdirectory (folder) for this Group, click on the New Folder button. 

4.    You will see the Create Folder dialog.    Type the folder name and press Enter.    The name of the 
folder (subdirectory) must conform to DOS naming conventions.

5.    Back on the New   WebWhacker   Group dialog  , double-click on the new directory to make that the 
default directory.

6.    Then enter the Group name in the File Name: field and press Enter.    The Group name also must 
conform to DOS naming conventions.

You have now created a new subdirectory (folder) and Group.
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Limitations

Image maps, or images that contain "hot spots" to link to several other pages, are not supported. 
The image itself will be downloaded and viewable, but the links it contained on the Web will not be active. 
These links are dynamically passed from a program on the server. 

Some servers return an HTML document and an OK status when an invalid URL is presented to 
the server.    For instance, if a document references an image that does not exist, the server sends an 
HTML document with information instead of the image. 

WebWhacker cannot tell the difference and assumes that the image was downloaded properly.      
This could cause problems when displaying the document that references the image.

HTTP is the only protocol that is supported (no FTP, Gopher, NNTP, News, Mail, etc.)
The HTTP protocol POST method is not supported.
Authentication is not supported.    WebWhacker cannot whack sites that require a username and 

password.
Some Web browsers navigate to their defined Home Page upon startup.    Therefore, if a 

WebWhacker URL is used to launch the Web browser (i.e., it was not already running), the browser may 
not navigate to the selected URL, but to its defined Home Page.    All subsequent navigations from 
WebWhacker will send the browser to the correct URL.

After whacking multiple times, the Web browser may not update the Table of Contents screen that 
is generated after a whack.    Select Reload to refresh the browser screen and see the updated Table of 
Contents screen.

Normal limitations of the World Wide Web apply to whacking pages.    WebWhacker, like your 
Web browser, will occasionally be unable to obtain a page from its site. 

This can be due to the server being down, the server being too busy, the URL is no longer valid, 
etc.    WebWhacker reports specific errors to help you take the appropriate action.
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Object
When you delete a WebWhacker object using the Cut command as described in the following procedure, 
you can then paste the object to another Group list or another application.    Only one object at a time can 
be deleted with the Cut command.    To remove more than one object at a time, refer to Deleting Multiple 
Objects.

When you cut a page object, all images and other objects associated with that page will also be deleted. 
After deletion, all remaining pages in the Group list will be relinked to point back to remote Web locations 
as necessary.    If an object is referenced on two or more whacked pages, that object will not be deleted 
until all referring pages are deleted as well. 

To cut a WebWhacker object, select the object and click on the Cut icon.    You can also select Cut from 
the Edit menu, or press Ctrl+X. 

You can now use the Paste command to paste the object into the same or a different Group list.
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Multiple Objects
One or more WebWhacker objects can be permanently removed using the Delete command.    The 
Delete command does not place the objects on the Windows Clipboard, so they cannot be pasted using 
the Paste command.    All objects associated with cleared pages will also be deleted. 

1.    Select the object or objects to be removed.    For more information, refer to Selecting Multiple Objects. 

2.    Select Delete from the Edit menu.    You can also press Ctrl+D or the Delete key. 

The objects are removed from the Group list, and the Clipboard is not modified. 
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Group
To delete a Group, use the Windows File Manager to delete the directory that contains the Group. 

To delete some or all objects within a Group, refer to Deleting Multiple Objects.
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of Warranty
In using this software, you understand and agree that this software is provided as is without warranty of 
any kind. The entire risk as to the results and performance of using this software lies entirely with you, the 
user. ForeFront Group does not make any warranties, either expressed or implied, including but not 
limited to implied warranties of merchantability and fitness for a particular purpose, with respect to this 
software.

In no event shall ForeFront Group be liable for any consequential, incidental, or special damages 
whatsoever (including without limitation damages for loss of critical data, loss of profits, interruption of 
business, and the like) arising out of the use or inability to use this software. Because some states do not 
allow the exclusion or limitation of liability for consequential or incidental damages, the above limitations 
may not apply to you.

Although ForeFront Group would appreciate any feedback and bug reports, it shall not be responsible for 
correcting any problems which you discover or otherwise help you maintain and use this software.    
Furthermore, ForeFront Group may at any time replace, modify, alter, improve, enhance or change this 
software.
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Objects to Another Group
You can move or copy WebWhacker objects and paste them into another Group list by dragging them 
from one Group list and dropping them on another.    For more information on dragging and dropping, 
refer to Using Drag & Drop.
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Page Link URL
You can drag a page link URL (underlined text) from a Web browser page and drop it on the 
WebWhacker Group list that was created or opened in Step 1. 

When the URL is dropped into the WebWhacker Group list, the file name for the page is entered as the 
Label. When that page is whacked, the Label will be updated with the name of the page. 

Before a page can be grabbed from the Web browser, WebWhacker must know the location and name of 
your Web browser.    To configure WebWhacker for your Web browser, refer to Configuring 
WebWhacker.

Since you will be dragging from the browser to WebWhacker, make sure both applications can be seen 
on the screen at the same time. 

1.    In the Web browser, simply drag the page link URL to the WebWhacker Group list. 

2.    You now see the URL in the Group list.    The globe icon in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The knife in the second column indicates that 
this URL is set "To be Whacked".

If you want to change the whacking flag for one or more URLs, go to Step 3: Enable or Disable Whack.

If all of the URLs are set correctly and you want to start whacking, refer to Step 4: Whack.
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Edit / Cut

The Cut option on the Edit menu allows you remove a single WebWhacker object from the Group list.    
You can also cut the selected object by selecting the Cut icon, or by pressing Ctrl+X.    For more 
information on how to cut a object, refer to Cutting an Object.

When you use the Cut command to delete a WebWhacker object, that object can be pasted into the 
same or different Group list using the Paste command.    For more information, refer to Pasting an Object.

It can also be used to remove text from an object's Properties.    For more information on modifying an 
object's properties, refer to Editing Object Properties. 

Multiple objects cannot be removed with the Cut command.    To remove multiple objects, use the Delete 
command.    For more information, refer to Deleting Multiple Objects.

Edit / Copy

The Copy option on the Edit menu allows you copy a single WebWhacker object.    Multiple objects 
cannot be copied.    You can also copy the selected object by selecting the Copy icon, or by pressing 
Ctrl+C.    For more information on how to copy a object, refer to Copying an Object.

This option can also be used to copy text from an object's properties.    For more information on modifying 
an object's properties, refer to Editing Object Properties. 

When you use the Copy command to copy an object, that object can be pasted into the same or different 
Group list using the Paste command.    For more information, refer to Pasting an Object.

Edit / Paste

The Paste option on the Edit menu allows you paste a URL into the current WebWhacker Group list.    
Multiple objects cannot be pasted.    You can also paste the object or text by selecting the Paste icon, or 
by pressing Ctrl+V.    For more information on how to paste a object, refer to Pasting an Object.

This option can also be used to paste text into an object's properties.    For more information on modifying 
an object's properties, refer to Editing Object Properties.

You can paste an object that was cut or copied with the Cut or Copy commands.    For more information, 
refer to Cutting an Object and    Copying an Object.

Edit / Delete
The Delete option on the Edit menu allows you to permanently remove multiple WebWhacker objects.    
You can also delete the selected objects or text by pressing Ctrl+D, or by pressing the Delete key.    The 
Delete command does not place the deleted items or text in the Clipboard, so they can not be pasted with 
the Paste command.    For more information on deleting multiple objects, refer to Deleting Multiple 
Objects. 

This option can also be used to remove text from an object's properties.    For more information on 
modifying an object's properties, refer to Editing Object Properties. 



Edit / Select All
The Select All option on the Edit menu allows you select all of the WebWhacker objects in the current 
Group list.    For more information, refer to Selecting Multiple Objects. 

This command is useful when selecting objects to enable or disable the whacking flag.    For more 
information, refer to Step 3: Enable or Disable Whack. 

This command is also useful when selecting multiple objects to be deleted.    For more information, refer 
to Deleting Multiple Objects.

Edit / Enable Whack
The Enable Whack option on the Edit menu allows you to specify that the selected WebWhacker 
objects will be downloaded on the next whack.    You can also enable the whacking of the selected objects 
by pressing Ctrl+A.    For more information on enabling the whacking of selected objects, refer to Step 3: 
Enable or Disable Whack. 

Edit / Disable Whack
The Disable Whack option on the Edit menu allows you to specify that the selected WebWhacker 
objects will not be downloaded on the next whack.    You can also disable the whacking of the selected 
objects by pressing Ctrl+R.    For more information on disabling the whacking of selected objects, refer to 
Step 3: Enable or Disable Whack. 
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Object Properties 
The only WebWhacker property that can be changed is the URL of an unwhacked object. 

1.    To edit the URL of an object that has not been whacked, click on the URL Properties icon.    You can 
also select URL Properties... from the Options menu. 

2.    You will see the Properties dialog.    Edit the URL, then select OK. 
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Constraints
The evaluation copy of WebWhacker available for download from ForeFront's Web site expires 30 days 
from installation. 

WebWhacker Groups more than 30 days old cannot be accessed with the evaluation software. 

The evaluation software also stamps all pages with a header and footer notifying the user that an 
evaluation copy of the software is being used. 

Permanent purchased copies of WebWhacker do not have any expiration limits, and they do not stamp 
downloaded pages with the evaluation header and footer.
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File / New Group...
The New Group... option on the File menu displays the New   WebWhacker   Group dialog   which allows 
you to create a new WebWhacker Group to contain a list of pages, images and other objects that have 
been or will be whacked.    A Group contains objects from one Web site, but you can include objects from 
any sites in your Group.    On your local drive, this Group will contain all pages and other object files that 
have been whacked. 

To keep these files organized, you should keep each Group in a separate folder.    The name of the Group 
can (and should) be the same name as the folder.    For information on how to create a new Group, refer 
to Creating a New Group. 

File / Open Group...
The Open Group... option on the File menu displays the Open   WebWhacker   Group dialog   which allows 
you to open an existing WebWhacker Group list.    For instructions on how to open an existing Group, 
refer to Opening an Existing Group. 

File / Close Group
The Close Group option on the File menu allows you to close the current WebWhacker Group list.    You 
can also close the Group by pressing Ctrl+W.    For more information, refer to Closing a Group.

File / Whack

The Whack option on the File menu starts the whacking process of copying the selected pages and 
objects from the Web to your local drive.    The whacking process can also be started by selecting the 
Start Whacking icon.    For more information, refer to Step 4: Whack. 

File / Stop Whacking

The Stop Whacking option on the File menu stops the whacking process.    The whacking process can 
also be stopped by selecting the Stop Whacking icon.    For more information, refer to Whacking One 
Page.

File / [MRU List]
The Most Recently Used (MRU) list allows you to quickly open the most recently used WebWhacker 
Groups.    Selecting one of these Groups is the same as selecting Open Group... from the File menu.

File / Exit
The Exit option on the File menu allows you quit the WebWhacker application.
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the Current Page URL
WebWhacker can grab the URL of the page currently displayed in the Web browser and add it to the 
Group list created or opened in Step 1.

Before a page can be grabbed from the Web browser, WebWhacker must know the location and name of 
your Web browser.    To configure WebWhacker for your Web browser, refer to Configuring 
WebWhacker.

1.    To grab the current page URL from the Web browser, click on the Grab URL icon.    You can also grab 
the URL by selecting Grab URL from the Group menu. 

2.    You now see the URL in the Group list.    The globe icon in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The knife in the second column indicates that 
this URL is set "To be Whacked".

If you want to change the whacking flag for one or more URLs, go to Step 3: Enable or Disable Whack.

If all of the URLs are set correctly and you want to start whacking, refer to Step 4: Whack. 
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Group / Grab URL

The Grab URL option on the Group menu allows you to grab the current URL from the Web browser.    
You can also Grab the current URL by selecting the Grab URL icon.    For instructions on how to grab a 
URL from the Web browser, refer to Adding a URL Manually. 

Group / View URL
The View URL option on the Group menu allows you to view the contents of the selected URL using the 
Web Browser.    This is the same as double-clicking on the object in the Group list.    For more information, 
refer to Navigating with Objects.

Group / View Table of Contents
The View Table of Contents option on the Group menu allows you to view the Table of Contents page 
using the Web Browser.    You can also view the Table of Contents by pressing Ctrl+T.    This Table of 
Contents page is automatically created after whacking, and contains a list of all WebWhacker objects in 
the current Group that have been whacked.    For more information, refer to Whacking One Page. 

By default, this Table of Contents page is displayed after whacking.    To not display this page after 
whacking, refer to Preferences.

Group / New URL...
The New URL... option on the Group menu displays the New URL dialog which allows you to manually 
enter a new URL into the current Group list.    For instructions on how to add a new URL, refer to Adding a 
New URL. 

Group / Add Links...

The Add Links... option on the Group menu displays the Add Links dialog which allows you to add page 
links from the selected whacked page to the current WebWhacker Group list.    You can also add links by 
selecting the Add Links icon. 

The menu option and icon are enabled if the selected object is a whacked (downloaded) page; they are 
not enabled if a remote URL is selected. 

The Add Links dialog lists all links contained in the page, and allows you to add some or all of these 
pages to the Group list, so that they also may be whacked.    For instructions on how to add associated 
links, refer to Adding Links from Whacked Pages. 
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Help / Contents
The Contents option on the Help menu displays this WebWhacker Help file.    You can also display this 
Help file by pressing F1.

Help / Quick Start
The Quick Start option on the Help menu displays the WebWhacker Quick Start dialog which is a brief 
description of how to whack pages. 

In addition, this Help Guide has a Quick Tutorial which leads you step-by-step through five easy lessons 
to help you learn the major features of WebWhacker.

Help / Open Sample Group
The Open Sample Group option on the Help menu displays a WebWhacker Group list consisting of 
several pages that are ready to whack.    You can start the whacking process by clicking on the Start 
Whacking icon.    You can also learn how to create your own Group list in the Quick Tutorial.

This Open Sample Group is also available from the Welcome screen.    You can also open this Sample 
Group by selecting the File / Open Group... command.    For more information, refer to Opening an 
Existing Group.

Help / About WebWhacker...
The About GrabNet... option on the Help menu displays the About   WebWhacker   dialog   which includes 
the version number, copyright and other information.
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Create a New Group
In this lesson you will create a new Group.    This Group will contain a list of pages that will be (or have 
been) whacked. 

A Group usually contains pages from one Web site, but you can include pages from any sites in your 
Group.    On your local drive, this Group will contain all text and image files that have been whacked. 

To keep these files organized, you should keep each Group in a separate folder (subdirectory).    The 
name of the Group can (and should) be the same name as the folder.

In this lesson you will create a Group called FFG, and store it in a directory also called FFG.

1.    To create a new Group, select the New Group   icon  .    You will see the New WebWhacker Group 
dialog. 

2.    To create a new directory (folder) for this Group, click on the New Folder button. 

3.    You will see the Create Folder dialog.    Type the name FFG and press Enter.

4.    Back on the New WebWhacker Group dialog, double-click on the FFG directory to make that the 
default directory.

5.    Then enter the name FFG in the File Name: field and press Enter.

You have now created a new Group and directory (folder) called FFG.    You are now ready to add a URL 
to the Group list, which is done in Lesson 2.



{ewl FH_BMP.DLL,FH_BMP,s_wwlogo.bmp}Lesson 2: 
Add a URL
In this lesson you will add the URL of The ForeFront Group's home page to the Group that you just 
created in Lesson 1. 

You can get the URL of the page to be whacked using several different methods.    For this Tutorial, you 
will enter it manually.

1.    To add a new URL, select New URL... from the Group menu.    You will see the New URL dialog. 

2.    Enter the following URL:

http://www.ffg.com

And press Enter.

3.    You now see that URL in the Group list.    The globe in the first column of the list indicates that this 
URL has not been whacked and is still out on the Web.    The sword in the second column indicates that 
this URL is set "To be Whacked."

You are now ready to start whacking, which is done in Lesson 3.
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Whack and View
In this lesson you will whack the URL that was added in Lesson 2 and view the whacked page using your 
Web browser.      This whacking process will copy the text and images from the Web to your local drive.

Before you can start whacking, you need to configure WebWhacker for your Web browser and Internet 
connection.    To configure WebWhacker, refer to Configuring   WebWhacker  .

1.    After configuring WebWhacker, begin the whacking process by clicking on the Start Whacking icon.    
You will see the progress on the Status Bar as the text and images are copied to your local drive.    You 
can continue using your computer for other tasks while the whacking progresses. 

You can stop the whack at any time by pressing the Stop Whacking icon.

2.    When the whacking has completed, you will see the Web browser displaying a Table of Contents for 
the whacked page.    Notice that the Location: is a local file name.    Click on the link for ForeFront 
Group, Inc.    You can now see the text and images for that page which has been copied to your local 
drive.

3.    Go back to WebWhacker.    After whacking, notice that the globe in the first column of the list has 
been changed to a page to indicate that the URL is now on your local drive.    And notice that the sword 
has been removed from the second column to indicate that it not set "To be Whacked."

You have now successfully whacked one page. 

Lesson 4 will show you how to whack all of the all of the pages that have links on this page.    Lesson 5 
will show you how to whack an entire Web site.
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Add Links
In this lesson you will add all of the page links to the Group list which are on the page that you just 
whaked in Lesson 3.    Then you will whack and view those additional pages.

1.    To add links from the whacked page, click once on the ForeFront Group, Inc. URL to select it.    Then 
click on the Add Links icon.

2.    You will then see the Add Links dialog.    On this dialog you can select the links you want to whack.    
You can mark or unmark some or all of the links displayed.

For this Tutorial, click on the Mark All button to select all links to be whacked.    Notice how a Globe is 
added to the left of each URL.    This symbol indicates that the URL has not yet been whacked and is still 
out on the Web.

Then click on the Add button to add these URLs to the Group list.    Notice how the Group list now 
includes those URLs, and they are set "To Be Whacked".

3.    Click on the Start Whacking icon to begin whacking the selected pages.    If it cannot whack a page 
because it no longer exists, you will see a message that one or more items could not be whacked.

4.    When it is finished whacking the pages, you will see the Web browser with the updated Table of 
Contents for this Group.    You may need to select Reload on the Web browser to refresh this screen.

The next level of pages are now on your local drive.    Lesson 5 will show you how to whack several levels 
of a site.
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Whack All Levels
In this Lesson, you will whack all of the pages in the ForeFront Group's Web site, using the URL that 
you added in Lesson 2.

1.    Go to the top of the Group list and click once on the first URL (ForeFront Group, Inc.) to select it.    
Then select Whack Levels... from the Options menu.

2.    You will then see the Whack Levels dialog.    Select All Levels Down.    Make sure the Follow 
external links box is not checked.    Then select OK.

Notice on the Group list that the second column of the first line has a sword, and behind the sword are 
several pages.    This indicates that more than one level is set to be whacked.

3.    Click on the Start Whacking icon to begin whacking all of the levels in the site. 

4.    When it is finished whacking, you will see the Web browser with the Table of Contents for this Group. 
If necessary, select Reload to refresh the browser screen.

The entire ForeFront Group Web site is now on your local drive.

You have now completed this Tutorial. 

Return to Table of Contents.
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with Objects
All WebWhacker objects contain the name and location of the page or object on the Web site.    If the 
WebWhacker object has been whacked, it also contains the name and location on the local drive.    The 
following paragraphs show you how to navigate to either the location on the local drive or on the Web site. 

WebWhacker must be configured for the correct Web browser before you can use that browser for object 
navigation.    For more information, refer to Configuring   WebWhacker  . 

1.    To display an object, you can:
a.    double-click on the object,

b.    drag the object to the Web browser, or

c.    select View URL from the Group menu. 

2.    If you navigate using an object that has been whacked, the Web browser will display the page or 
object from the local drive. 

3.    If you navigate using an object that has not been whacked, the Web browser will display that page 
from the Web. 

4.    If you drag an object to the Web browser, it will display that page or object from the Web.

5.    If the object has been whacked and you want to navigate out to the Web, hold down the Ctrl key 
while double-clicking on the URL. 
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an Existing Group
An existing Group contains a list of URLs and other objects that have been or will be whacked.

You can add more URLs to this Group as desired.    You may want to keep URLs from other Web sites in 
a separate Group.    If so, refer to Creating a New Group.

1.    To open an existing Group, select the Open Group icon from the File menu.    You can also select 
Open Group... from the File menu, or press Ctrl-O. 

2.    You will see the Open   WebWhacker   Group dialog  .    Navigate to and select the desired folder.    Then 
select the desired Group. 

You now see the list of URLs currently in this Group.
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Options / URL Properties...

The URL Properties... option on the Options menu displays the Properties dialog which allows you to 
view or edit the properties of the selected WebWhacker object.    You can also display the Properties 
dialog by selecting the URL Properties icon.    For more information on viewing and editing an object's 
properties, refer to Viewing Object Properties and Editing Object Properties. 

Options / Whack Levels...
The Whack Levels... option on the Options menu displays the Whack Levels dialog which allows you to 
view and change the number of page levels that will be whacked below the selected URL.    You can also 
choose whether external links will be whacked as well.    For more information on whacking several page 
levels, refer to Whacking Several Page Levels. 

Options / Group Properties...
The Group Properties... option on the Options menu displays the Group Properties dialog which allows 
you to view the properties associated with the current WebWhacker Group list.    This information is not 
modifiable.    For more information on Group properties, refer to Viewing Group Properties.

Options / Preferences...
The Preferences... option on the Options menu displays the Preferences dialog which allows you 
configure WebWhacker to your own specifications. 

The Web Browser: field is where the path and filename of the Web browser is specified.    To specify the 
Web browser, click on the Browse button.    You will see the standard Open dialog.    Navigate to and 
select the Web browser file, then select OK.    You will then see the path and filename of your Web 
browser.    An example would be:
C:\IEXPLORE\IEXPLORE.EXE

The E-mail: field is where you enter your e-mail address.    Many Web sites require the e-mail address of 
the user requesting a page from their server.    If you do not have an e-mail address, enter your name in 
this field. 

The HTTP Proxy: and Port: fields are used when WebWhacker must go through a proxy server (firewall) 
to access the Web.    If your Web browser is configured for a proxy server, then WebWhacker will have to 
be configured as well. 

If you use a proxy server, enter the name or IP address of the proxy server in the HTTP Proxy: field, then 
enter the Port number in the Port: field.    To get the Proxy server name, IP address and Port number, ask 
your System Administrator. 

The Number of Retries: field indicates the number of times that WebWhacker will attempt to request the 
desired object from the Web server before giving up. 

The Reconnect Delay: field indicates the number of seconds that WebWhacker will pause before 
retrying. 

If the View Table of Contents after Whacking option is turned on, the Table of Contents page will be 
displayed in the Web browser after whacking.    By default, this option is turned on.    For more information 
on the Table of Contents, refer to Whacking One Page.



If the Use Absolute Addressing option is turned on, all page links will include the fully qualified path 
name to the destination file.    If this option is turned off, only the filename is specified in the page link.    By 
default, this option is turned off.    You should turn this option on only if your Web browser cannot find the 
destination file when you click on a page link.

If the Show Welcome Dialog at Startup option is turned on, the Welcome dialog will be displayed when 
you start WebWhacker.    By default, this option is turned on.    For more information, refer to What is on 
the Welcome Screen?

The View Details option allows you to select which fields will be displayed in the WebWhacker Group 
list.    By default, both the Label and URL fields will be displayed.    You can display only one field to make 
the Group list narrower.

The Sort By option allows you to select the way in which the objects in the WebWhacker Group list are 
arranged.    By default, the objects are displayed in the order in which they are added.    The Group list can 
also be sorted alphabetically according to the Label or URL.
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A WebWhacker object that was copied or cut can be pasted into a Group list.    A Group list cannot 
contain duplicate objects.    When an object is pasted, it is set as Remote and To Be Whacked one level.    
If a whacked object is pasted, only the URL is pasted.

The following steps show you how to paste an object.    These steps assume that you have already used 
either the Copy or Cut command to place the object on the Windows Clipboard. 

To paste what is in the Clipboard into the current Group list, click on the Paste icon.    You can also select 
Paste from the Edit menu, or press Ctrl+V.    The object now appears in the Group list. 
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Tutorial
The following is a quick Tutorial that will show you how to use WebWhacker to whack a site from the 
Web and view the resulting pages as they are stored on your local drive.    This Tutorial will use the 
ForeFront Group site on the Web as the location to be whacked.

When whacking a site, you can whack one page, several pages or several levels of pages at one time.    
This Tutorial will show you how to use all three methods of whacking.

             Lesson 1: Create a New Group  
             Lesson 2: Add a URL  
             Lesson 3: Whack and View  
             Lesson 4: Add Links  
             Lesson 5: Whack All Levels  
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Multiple Objects 
You may want to select multiple WebWhacker objects in a Group list so you can enable or disable 
whacking, or marked to add to a Group list.    You can also drag one or more objects to another 
application. 

There are three ways to select multiple objects:

a.    To select a contiguous block of objects, hold down the Shift key while selecting the first and last in a 
list of objects. 

b.    To select several non-contiguous objects, hold down the Ctrl key while selecting multiple objects.

c.    To select all objects in the Group list, choose Select All from the Edit menu.
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Groups
The first step when whacking is to create a new Group or open an existing Group.    This Group contains a 
list of pages and other objects that will be or have been whacked. 

A Group usually contains pages and objects from one Web site, but can include pages and objects from 
any sites.    Multiple Groups can be opened at the same time.    During the whacking process, all 
downloaded URLs are relinked to local files within the Group.

Creating a New Group

Opening an Existing Group
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Add URL
The second step is to add a URL to the Group that was created or opened in Step 1.    This can be done 
several different ways. 

Grabbing the Current Page URL

Dragging a Page Link URL

Adding a New URL

Adding Links from Whacked Pages

Adding URLs from   GrabNet  
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The third step is to set or clear the "To be Whacked" flag for selected WebWhacker URLs.    As a URL is 
added to the Group list, it is set To be Whacked, signified by the knife symbol in the second column of the 
Group list.    You can clear (disable) whacking for one or more URLs so they will not be whacked at this 
time. 

After a page is whacked, the flag is turned off (disabled).    You can turn on (enable) the flag so the page 
can be whacked again.    The following paragraphs show you how to enable or disable the whacking of 
one or more pages in a Group list.    If all pages in the Group list are set the way you want, this step may 
be skipped and you can go directly to Step 4: Whack. 

1.    Select the pages that you want to enable or disable to be whacked.    For more information on 
selecting multiple objects, refer to Selecting Multiple Objects. 

2.    To enable whacking for the selected objects, select Enable Whack from the Edit menu.    You can 
also press Ctrl+A.    The knife appears in the second column of the selected objects in the Group list. 

3.    To disable whacking for the selected objects, select Disable Whack from the Edit menu.    You can 
also press Ctrl+R.    The knife is removed from the second column of the selected objects in the Group 
list. 

When all of the pages are set correctly and you want to start whacking, refer to Step 4: Whack. 
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Whack
The final step is to start the whacking process.    This will copy the text, images and other objects from the 
Web to your local drive. 

Only those objects that are set "To be Whacked" will be downloaded.    For more information on enabling 
or disabling the whacking flag, refer to Step 3: Enable or Disable Whack.

After whacking, you can view what has been downloaded by using your Web browser.    To configure 
WebWhacker for your Web browser, refer to Configuring   WebWhacker  . 

Whacking One Page

Whacking Several Page Levels
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Requirements

Windows 3.1 running in Enhanced Mode.
4 MB RAM.    Additional memory will make WebWhacker run faster.
10 MB disk space or more.    Since WebWhacker stores images and text from the Web browser, 

the disk space required is determined by the number and size of images and text blocks you grab.
A Web browser.    Any Web browser that supports the SpyGlass SDI standard (includes Internet 

Explorer, Netscape Navigator and Enhanced Mosaic 2.0) can be used to view local files from 
WebWhacker. These browsers also enable retrieval of current page information when "grabbing" URLs 
to whack. 

Since WebWhacker makes independent network connections to desired pages (sites), a Web 
browser is not necessary for WebWhacker "whacking", but is only needed for viewing the resulting 
groups of local files.

An active connection to the Internet with a Winsock-compliant network product. 
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Uninstalling WebWhacker
To remove WebWhacker from your system, simply delete the    directory where WebWhacker was 
installed. 

You can then remove the WebWhacker icons and group that were added to the Program Manager.

One or more files may have been installed into the WINDOWS\SYSTEM directory, but those files should not 
be deleted as they may be used by other applications.
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WebWhacker
If you would like to use WebWhacker with existing "whacked" data, you may do so.    Simply install 
WebWhacker into any subdirectory and navigate to the location of an existing Group using the Open 
Group dialog. 

Note that the evaluation copy of WebWhacker expires 30 days from installation and will be unable to 
open Groups greater than 30 days old.    For more information, refer to Evaluation Constraints.

If you whacked pages with the evaluation copy of WebWhacker and have the extra headers and footers, 
simply rewhack those pages with the permanent version of WebWhacker and those headers and footers 
will be removed.
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& Drop
You can use Drag & Drop in several different ways to make the manipulation of WebWhacker objects 
very easy and intuitive.    Below are the various ways to use Drag & Drop within WebWhacker. 

a.    To create a URL object in WebWhacker, drag a page link URL from the Web browser to the Group 
list.    For more information, refer to Dragging a Page Link URL. 

b.    To display a WebWhacker object in the Web browser, drag it from WebWhacker to the Web browser. 
For more information, refer to Object Navigation.

c.    To move WebWhacker objects from one Group list to another, drag them from the source Group to 
the destination Group.    During this drag, they are removed (deleted) from the source Group.    When they 
are dropped into the destination Group, they are set as Remote and To Be Whacked one level.

d.    To copy WebWhacker objects from one Group list to another, hold down the Ctrl key while dragging 
them from the source Group to the destination Group.    During this drag, they are not removed from the 
source Group.    When they are dropped into the destination Group, they are set as Remote and To Be 
Whacked one level.
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View / Details
The Details option on the View menu allows you to select which fields will be displayed in the 
WebWhacker Group list.    By default, both the Label and URL fields will be displayed.    You can display 
only one field to make the Group list narrower.    This option can also be specified under Options / 
Preferences.

View / Sort By
The Sort By option on the View menu allows you to select the way in which the objects in the 
WebWhacker Group list are arranged.    By default, the objects are displayed in the order in which they 
are added.    The Group list can also be sorted alphabetically according to the Label or URL.        This 
option can also be specified under Options / Preferences.

View / Tool Bar
The Tool Bar option on the View menu allows you to specify whether Large   icons   or Normal   (small)   
icons will be displayed as the Tool Bar.    By default, Normal icons will be displayed.

View / Status Bar
The Status Bar option on the View menu allows you to specify if the Status Bar will be displayed at the 
bottom of the WebWhacker window.    This Status Bar displays information concerning the whacking 
progress, menu items and icons.



{ewl FH_BMP.DLL,FH_BMP,s_wwlogo.bmp}Viewing 
Group Properties
Every WebWhacker Group has several properties.    These properties can be viewed but not modified. 

To view these properties, select Group Properties... from the Options menu.    You will see the Group 
Properties dialog.

All WebWhacker Groups have the following four properties: 

Name:    This is the name of the file that stores information about the Group. 

Location:    This is the location of the Group on the local drive. 

Date Modified:    This is the date and time that any object in the Group was last modified. 

The DOS Compatible File Names box indicates that the whacked object filenames have been modified 
to conform to DOS naming conventions or to DOS-compatible filenames.    Files in a Group whacked on a 
Macintosh or Windows 95 computer can be used on a Windows 3.1 computer if this option was selected 
when the Group was created on those other machines.
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Every object has several properties.    You can view the properties of only one object at a time. 

To view the properties of a selected object, click on the URL Properties icon.    You can also select URL 
Properties... from the Options menu.    You will then see the Properties dialog.

All WebWhacker objects have the following three properties:

Label:    This is either the page name or the file name of the selected object. 

URL:    This is the location of the object on the Web.    If it has not been whacked, this field is editable and 
the data in the field can be changed. 

Status:    The Status is either Downloaded (has been whacked) or Remote (has not been whacked). 

If the selected object has been whacked, then the Properties dialog will also include:

Remote Modified:    This is the date and time that the object on the Web was last modified. 

Whacked:    This is the date and time that the object was last downloaded. 

Local Filename:    This is the location of the object on the local drive. 

And the following three buttons:

Links... -- This button displays the Links dialog which contains a list of all links that are on this page.    If 
the icon to the left of the link is a page, that link has been whacked.    If the icon is a globe, that link is in 
the Group list but has not been whacked.    The Links list is not editable.    To add links to be whacked, use 
the Add Links icon.    For more information on adding links, refer to Adding associated URLs from 
whacked pages.

Images... -- This button displays the Images dialog, which is a list of all image objects that are on the 
selected page.    If the icon to the left of the filename is a square object, the image has been whacked.    If 
the icon is a globe, the image has not been whacked. 

Errors... -- This button displays Errors dialog, which is a list of errors that have occurred when whacking 
the selected object.    If this button is inactive, then this object was last whacked successfully.    If 
WebWhacker is unable to download an object, the URL in the Group displays as red text. 



WebWhacker Icons

(Small or Large)
(click on an icon to go to its description)

The New Group icon allows you to create a new Group by displaying the New   WebWhacker   Group   
dialog.    It is the same as selecting New Group... from the File menu, or pressing Ctrl+N.    For more 
information, refer to Creating a New Group.

The Open Group icon allows you to open an existing Group by displaying the Open   WebWhacker   Group   
dialog.    It is the same as selecting Open Group... from the File menu, or pressing Ctrl+O.    For more 
information, refer to Opening an Existing Group.

The Start Whacking icon whacks or downloads all pages, images and other objects in the Group list that 
are marked "To Be Whacked", indicated by a knife in the second column of the Group list.    It is the same 
as selecting Whack from the File menu.    For more information, refer to Whacking.

The Stop Whacking icon stops a whack in progress. The page being downloaded is completed, all pages 
already downloaded are relinked, and remaining pages are skipped.    This is the same as selecting Stop 
Whacking from the File menu.    For more information, refer to Whacking.

The Cut icon cuts the selected object or text and places it in the Windows Clipboard so it can be pasted 
elsewhere.    It is the same as selecting Cut from the Edit menu, or pressing Ctrl+X.    For more 
information, refer to Cutting an Object.

The Copy icon copies the selected object or text and places it in the Windows Clipboard so it can be 
pasted elsewhere.    It is the same as selecting Copy from the Edit menu, or pressing Ctrl+C.    For more 
information, refer to Copying an Object.

The Paste icon pastes the selected object or text into the selected Group or field.    It is the same as 
selecting Paste from the Edit menu, or pressing Ctrl+V.    For more information, refer to Pasting an 
Object.

The Grab URL icon adds the page currently displayed in the Web browser to the selected Group list.    
Selecting this icon also automatically attaches the page title to the URL object.    This is the same as 
selecting Grab URL from the Group menu.    For more information, refer to Grabbing the Current Page 
URL.

The Add Links icon displays the Add Links dialog for the selected whacked page.    This is the same as 
selecting Add Links... from the Group menu.    For more information, refer to Adding Links from Whacked 
Pages.

The URL Properties icon displays the Properties dialog which gives basic information for the selected 
object.    This is the same as selecting URL Properties... from the Options menu.    For more information, 



refer to Viewing Object Properties.
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The following screens describe the various ways to use WebWhacker to whack pages from the Web and 
store them on your local drive.

For a short tutorial on how to use WebWhacker, refer to Quick Tutorial.

The four steps of whacking are:

             Step 1: Groups  
             Step 2: Add URL  
             Step 3: Enable or Disable Whack  
             Step 4: Whack  
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1.    To begin whacking, click on the Start Whacking icon.    You can also start whacking by selecting 
Whack from the File menu. 

2.    You will see the whacking progress as the pages, images and other objects are copied to your local 
drive.    You can continue using your computer for other tasks while the whacking progresses. 

3.    You can stop the whack at any time by pressing the Stop Whacking icon.    If you click on this icon, the 
page being downloaded is completed, all pages already downloaded are relinked, and all remaining 
pages are skipped.    This is the same as selecting Stop Whacking from the File menu.

4.    By default, when the whacking is complete you will see the Web browser displaying a Table of 
Contents of the whacked page(s).    To view a whacked page, click on the appropriate link.    You can turn 
off the displaying of the Web browser after whacking.    For more information, refer to Preferences. 

5.    Go back to WebWhacker.    Notice that the globe in the first column of a whacked object has been 
changed to a file symbol to indicate that the object is now on your local drive.    And notice that the knife 
has been removed from the second column to indicate that it not set "To be Whacked".

6.    If WebWhacker is unable to download a page or other file, the object in the Group list displays as red 
text and the specific error is recorded.    To view the error message, select the URL and click on the URL 
Properties icon.    You can also select URL Properties... from the Options menu. 

This will display the Properties dialog, where you can click on the Errors... button to view the problem 
with this URL. 

7.    If you want to whack the pages that have links on the page you just whacked, refer to Add associated 
URLs from whacked pages.
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Several Page Levels
In addition to manually adding and whacking the links on a page, you can automatically download an 
entire site or subset of a site. 

Whacking several levels will add linked pages to the group for the indicated number of levels and whack 
all the added links.    You may download an entire site using the "all" levels option, as well as include links 
external to the site (one level). 

1.    Select the URL you want to whack.    Then select Whack Levels... from the Options menu.

2.        This will display the Whack Levels dialog, where you can choose to whack a specific number of 
levels or all levels down from the selected URL. 

If you choose to Include External Links, those external links will be whacked only to one level 
regardless of the number of levels specified for the internal links. 

3.    When you have completed the Whack Levels dialog, click OK.    Notice on the Group list that the 
second column of the URL has a knife, and behind the knife are several pages.    This indicates that more 
than one level is to be whacked. 

4.    To begin whacking, click on the Start Whacking icon.    You can also start whacking by selecting 
Whack from the File menu. 

5.    You will see the whacking progress as the text, images and other objects are copied to your local 
drive.    You can continue using your computer for other tasks while the whacking progresses. 

6.    You can stop the whack at any time by pressing the Stop Whacking icon.    If you click on this icon, the 
page being downloaded is completed, all pages already downloaded are relinked, and all remaining 
pages are skipped.    This is the same as selecting Stop Whacking from the File menu.

7.    By default, when the whacking is complete you will see the Web browser displaying a Table of 
Contents of the whacked page(s).    To view a whacked page, click on the appropriate link.    You can turn 
off the displaying of the Web browser after whacking.    For more information, refer to "Preferences". 

8.    Go back to WebWhacker.    Notice that the globe in the first column of a whacked object has been 
changed to a file icon to indicate that the object is now on your local drive.    And notice that the knife has 
been removed from the second column to indicate that it not set "To be Whacked".

9.    If WebWhacker is unable to download a page or other file, the object in the Group list displays as red 
text and the specific error is recorded.    To view the error message, select the URL and click on the URL 
Properties icon.    You can also select URL Properties... from the Options menu. 

This will display the Properties dialog, where you can click on the Errors... button to view the problem 
with this URL. 
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Groups?
A WebWhacker Group contains a list of one or more URL, page or other objects that have been or will be 
whacked.    This Group may contains objects from one Web site, but it can include objects from any Web 
sites.    After any page in a Group is whacked, all local pages within that Group are relinked or remapped 
to point to the "new" local pages. 

To keep these pages and objects organized, you should keep each Group list in a separate folder.    The 
name of the Group can (and should) be the same name as the folder. 

Once any page is downloaded, the links it contains may also be added to the list and downloaded.    A 
group may contain any number of pages added as starting points, added from a downloaded page's links, 
or added automatically by whacking levels.    All pages within a group will interlink locally if related. 

There are two icon columns to the left of pages in the Group list.    The first indicates local or remote 
status of the page.    Local (whacked) pages display a file symbol, while remote pages display a globe 
symbol.    A knife symbol may appear in the second column, indicating that the page will be downloaded 
on the next Whack.    A knife overlaying a single page means one level will be downloaded, and a knife 
overlaying multiple pages means multiple levels will be downloaded. 
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WebWhacker Objects?
A WebWhacker object is any item in a Group list.    There are three types of WebWhacker objects:

URL (Universal Resource Locator) -- a location out on the Web; also referred to as an unwhacked page. 
An example would be:    http://www.ffg.com

Page -- a file on your local drive containing HTML (HyperText Markup Language) code; also referred to as 
a whacked page.    An example would be: 
C:\WEBWHACK\FFG\FFG.HTM

Other Object -- this can be any other file that can be displayed on or associated with a Web page.    
Examples are files containing images, sounds, videos or other programs. 
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Quick Start?
Below is a brief explanation of how to use WebWhacker to whack pages.    This information is also 
displayed on the Quick Start dialog which is accessible from the Welcome screen or from the Help / Quick 
Start menu.

In addition to this Quick Start, this Help Guide also contains a Quick Tutorial.    In five easy lessons it 
leads you through using WebWhacker in a variety of different ways.

You can also refer to Whacking for complete explanations of all options available to you when whacking.

When you've found a Web page you would like to save locally:

1. Create a Group. 

Click on the New Group icon to create a new group.    A "Group" is a way to organize the pages you 
collect.    It can consist of the pages from one Web site or pages from several sites that are in the same 
category, for, example, Weather pages or Wine pages. 

2. Add a URL to the Group. 

Click on the Grab URL icon to add the current page from the Web browser.    Repeat this step if you have 
more.    Or use New URL from the File menu.    Refer to Whacking for other methods.    To automatically 
download levels below a URL, choose Whack Levels from the Options menu.

New URLs have two symbols.    A large globe means this URL is remote, or has not been downloaded.    A 
knife indicates the page will be downloaded on the next Whack.    All URLs with a knife will be 
downloaded.

3. Download. 

Click on the Start Whacking icon.    WebWhacker connects to the Internet and downloads the pages and 
their images.    After whacking, pages successfully downloaded show a file symbol instead of the globe, 
indicating the pages are now local. 

4. Add Links from downloaded pages. 

Optionally, click on the Add Links icon.    From the Add Links dialog, you can review the list of links on 
downloaded pages and add some of these pages to the group.    Mark and Add additional links to the 
group and whack again.

5. View pages in a Group. 
View any page in your group by double-clicking on it to display it in your browser.    If the URL has a large 
globe next to it, your browser will navigate to the Web to display the page.    If the URL has a page icon 
with a small globe inside, your browser will display the page from your desktop instead.
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WebWhacker?
WebWhacker is a program developed by the ForeFront Group, Inc., that downloads entire Web pages 
or groups of pages, including text (HTML), images and other objects to store them on the local desktop.    
It is a tool designed to reduce your dependency on an Internet connection. 

The downloaded pages, images and other objects are relinked locally for later browsing without an 
Internet connection - right from the local desktop!    "Whacked" information can be viewed and navigated 
locally with any Web browser and is a mirror image of the same information on the World Wide Web. 
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the Welcome Screen?

The Quick Start button on the Welcome screen displays the Quick Start dialog which is a brief 
description of how to whack pages.    In addition, this Help Guide has a Quick Tutorial which leads you 
step-by-step through five easy lessons to help you learn the major features of WebWhacker.

This Help Guide also has a topic area called Whacking which contains complete explanations of all the 
different ways to use this program.

The Sample Group button displays a Group list consisting of several pages that are ready to whack.    
You can start the whacking process by clicking on the Start Whacking icon.    You can also learn how to 
create your own Group list in the Quick Tutorial.

The New Group button displays a dialog so you can create your own Group list.    For more information 
on how to create a new Group, refer to Creating a New Group.

The Open Group button displays a dialog so you can open an existing Group.    For more information on 
how to open an existing Group, refer to Opening an Existing Group.

The Help button displays this Help Guide.

The Done button cancels the display of the Welcome screen and activates the WebWhacker menus.    If 
you would like for the Welcome screen to not be displayed when you start WebWhacker, refer to 
Preferences.
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Menu
Window / Cascade
The Cascade option on the Window menu arranges the WebWhacker Group windows in an overlapping 
style, like offset note cards.

Window / Tile
The Tile option on the Window menu arranges the WebWhacker Group windows in a tiled style, with 
each window displayed in its own space within the WebWhacker application window.

Window / Arrange Icons
The Arrange Icons option on the Window menu arranges the WebWhacker Group window icons when 
they are minimized.

Window / [Window List]
The list of windows appears after all other menu items.    Each list item is preceded by a number, which 
you can type to display that window.    The active WebWhacker window is indicated by a check mark 
before its number.    The order of windows in the list is the order in which you opened the windows.    
When you close a window, the list is renumbered.
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