
About SmartWhois

SmartWhois is a useful network information utility that allows you to find out all available information about an IP address, host 
name, or domain, including country, state or province, city, name of the network provider, administrator and technical support contact 
information.

Unlike standard Whois utilities, SmartWhois can find the information about a computer located in any part of the world, intelligently 
querying the right database and delivering all the related records within a few seconds. The program can retrieve information from 
more than 20 servers all over the world.

SmartWhois can save obtained information to an archive file. Users can load this archive the next time the program is launched and 
add more information to it. This feature allows you to build and maintain your own database of IP addresses and host names. You 
can also load a list of IP addresses as a text file and have SmartWhois process the whole list.

SmartWhois is capable of caching query results, which reduces the time needed to query an address; if the information is in the 
cache file it is immediately displayed and no connections to the whois servers are required.



        What's New

Version 3.3

· INFO and BIZ domains are supported;
· Domain expiry dates are displayed when available;
· You can now drag-and-drop data from/to the application window;
· More command line options have been implemented;
· You can now select the fields to be included in the output text file when saving results;
· Windows XP themes are supported;
· Many bug fixes.

Version 3.2

· URL de-obfuscation: the program automatically decodes URLs when you paste them into the input window;
· Command line parameters are now supported (useful if you call SmartWhois from another application);
· NO (Norway) domains are now supported;
· A red domain icon is displayed on the left panel if the domain you searched for was not found;
· If the Internic whois server is temporarily down, the program tries to obtain data from an alternative server;

Version 3.1

· An interface to Web search engines has been added to the right panel’s context menu;
· LU (Luxembourg) domains are now supported;
· A few bug fixes.

Version 3.0

· The application was re-written from scratch;
· A new interface;
· Added a Whois console for custom queries;
· Domain batch processing;
· Results can be saved as an HTML file;
· CH (Switzerland) and LI (Liechtenstein) domains are now supported;
· Problems with NZ (New Zealand) and CA (Canada) domain queries solved;
· Country codes reference;
· Ability to add user notes;
· Many other improvements.



License Agreement

Please read the following terms and conditions carefully before using this software. Your use of this software indicates your 
acceptance of this license agreement. If you do not agree with the terms of this license, you must remove this software from your 
storage devices and cease to use the product.

Copyright
This software is copyrighted 1998-2001, TamoSoft, Inc. SmartWhois is a trademark of TamoSoft, Inc. The use and copyright of this 
software is governed by international copyright treaties. TamoSoft, Inc. retains full title and rights to this software and 
documentation, and in no way does the license granted diminish the intellectual property rights of TamoSoft, Inc. You must not 
redistribute the registration codes provided, on paper, electronically, or in any other form.

Evaluation Version
This is not free software. You are hereby licensed to use this software for evaluation purposes without charge for a period of 30 
days. Using this software after the evaluation period violates copyright laws and may result in severe civil and criminal penalties. 

Registered Version
One registered copy of this software may be used by a single person who uses the software personally on one or more computers, 
or it may be installed on a single workstation used non- simultaneously by more than one person, but not both.

Disclaimer
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, 
INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.    IN 
NO EVENT WILL TAMOSOFT INC. BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING INCIDENTAL OR CONSEQUENTIAL 
DAMAGES, ARISING FROM THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND IT, AND AGREE TO BE BOUND BY ITS TERMS. 

Governing Law
This Agreement will be governed by the laws of the Republic of Cyprus.

Distribution
This software may be distributed freely in its original unmodified and unregistered form. The distribution must include all files of its 
original distribution. Distributors may not charge any money for it. Anyone distributing this software for any kind of remuneration 
must first contact us for authorization.

Other Restrictions
You may not modify, reverse engineer, decompile, or disassemble this software in any way, including changing or removing any 
messages or windows.



Quick Start

If you don’t like reading long manuals and you are already familiar with the Internet, this is probably the only chapter 
you need to read to get started. 

Step 1. 
Launch the program.

Step 2. 
Type in or paste an IP address, hostname, or domain name. An example of an IP address query is shown below:

 
A hostname query: 

A domain name query:

Step 3. 
Make an IP address or hostname query by clicking Query =>As IP/Hostname or simply by pressing the Enter key. 

Or

Make a domain query by clicking Query => As Domain or press the Enter key while holding down the Ctrl key (Ctrl+Enter).



Main Window and Menu

The program main window consists of the input area where you can enter your query, the menu and toolbar for performing standard 
operations, and the output window where query results are displayed. The output window consists of the IP address tree (the left 
panel), which lists all queried IP addresses, and the text area (the right panel), where the information is displayed. 

To obtain information about an IP address, hostname, or domain just enter it in the input box and hit the Enter key (Ctrl+Enter in 
case of domain queries), or click on the Query button. Alternatively you can choose a recent query from the drop-down list. If you 
would like to learn more about the difference between IP addresses, hostnames, and domains, please see the Types of Queries 
chapter.

SmartWhois displays information obtained from the whois servers as a set of items represented by icons. A query result does not 
necessarily contain all of the items because the amount of data returned by whois servers depends on the specific IP address. Click 
here to see the meaning of the icons. 

The left panel displays all the IP addresses and domain names you have queried during the session represented by icons. Every IP 
address in the tree is represented by a thread that consists of several branches. The parent branch is the IP address that you 
entered. The child branches are the net blocks in which this IP address was found. You can browse through the branches by clicking 
on them. When a new query is sent all the old threads are collapsed and a new thread is created.    Click here to see the meaning of 
the icons.

Main Menu 

File

Clear - clears the output window, both the IP address tree and the text area.

Open – opens a SmartWhois archive or batch file. If a SmartWhois archive is opened its contents are displayed. If some results are 
already present in the IP address tree and text area, they will be merged with the archived data. If a batch file is opened, all IP 
addresses or domain names contained in it are processed. 



Save Current Result - saves the current result from the text area into a SmartWhois archive or HTML file.

Save All Results As… - saves all the results from the IP address tree and text area into a SmartWhois archive.

Print Current Result - prints the current text area.
 
Exit - closes the program.

Edit

Copy - copies selected text from the text area to the clipboard. 

Paste - pastes the clipboard contents into the input area.

Select All - selects all text in the text area.

View

Toolbar - shows or hides the toolbar.

Status Bar - shows or hides the status bar.

Source - opens a window that shows raw information as it was received from the whois server.

Whois Console – opens a window for making a custom query. You can specify the whois server you want to query and make a 
specific type of query.

My Notes – opens a window where you can enter your notes about IP addresses, hostnames, or domain names. 

Country codes    - opens a window with the list of countries and two letter codes assigned to them. 

Settings

Fonts – opens the Font dialog. The Main Window font is used for the menus, toolbar and status bar, the Left Panel font for the IP 
address tree, and the Right Panel font for the text area.

Colors – opens the Background colors dialog for the Left Panel or Right Panel.

Resolve IP address to hostname – check this item if you want SmartWhois to perform a reverse DNS lookup. See the Configuring 
SmartWhois chapter for more information.

Ping hosts – check this item if you want SmartWhois to ping hosts. See the Configuring SmartWhois chapter for more information.

Options – opens the configuration dialog.

Help

Contents – opens the help file.

Search For Help On – opens the SmartWhois help index.

About – shows the About window.

Right-clicking on a parent branch of the IP address tree pops up the following menu:

Save - saves the information about the selected IP address and its default net block into a SmartWhois archive or HTML file.

Refresh - refreshes the information about the selected IP address.

Delete - deletes the information about the selected IP address and all the child branches.

View Source - opens a window and shows raw information as it was received from the whois server.



My Notes – opens a window where you can put your notes about IP addresses, hostnames or domain names. 

Right-clicking on the right panel pops up a context menu with the following commands:

Copy – copies selected text to the clipboard.

Select All - selects all text in the text area.

Search for – allows you to search for the selected text using one of the major Web search engines.



Icons and Their Meanings 

Left Panel

IP address or net block; the information is obtained online.

IP address or net block; the information is obtained from the local cache or is loaded from a SmartWhois archive.

Domain; the information is obtained online.

Domain; the information is obtained from the local cache or is loaded from a SmartWhois archive.

Domain not found; the information is obtained online.

Domain not found; the information is obtained from the local cache or is loaded from a SmartWhois archive.

Right Panel

IP address or domain that was queried, as well as optional ping and hostname information.

Default (the narrowest) net block assigned to the IP address. For domain queries, this icon shows the domain’s IP address, if any.

IP address / domain owner. It can be a company name for corporate networks or an Internet Service Provider (ISP) name for dial-up 
connections.

Administrative contact and all the related information: address, telephone and fax numbers, e-mail, etc.

Technical contact and all the related information: address, telephone and fax numbers, e-mail, etc.

Billing contact and all the related information: address, telephone and fax numbers, e-mail, etc.

Name servers assigned to the IP address / domain.

Registered internal Internet name of the network, registration date (sometimes the registration information last modification date) 
and the source of the information.
 



Types of Queries

Information For Beginners

It’s important to understand the difference between IP addresses, hostnames, and domains. An IP address is a unique number that 
identifies a computer on the Internet, for example 205.181.112.65. You may want to obtain information about an IP address to find 
out who is the real sender of an e-mail message, or who is attacking your computer. 

A hostname is just an easy-to-remember name corresponding to an IP address. For example, www.microsoft.com is the name for 
the IP address 207.46.230.219. A whois query for www.microsoft.com and 207.46.230.219    returns exactly the same information. 

Domains are different from hostnames and IP addresses. A domain is a network name registered to someone. Domain queries 
provide information about the owner of a domain name. For example, if you want to purchase the cats.com domain name to make a 
web site about cats, you may want to contact the current owner of this domain to discuss the deal. To obtain the information about 
the domain name owner you need make a domain query.

SmartWhois is capable of performing both IP address/hostname and domain name queries.

IP Address / Hostname Queries 

To obtain information about an IP address or a hostname, just enter it in the input box and hit the Enter key, or click on the Query 
button and select As IP / Hostname. You can choose a recently queried IP address or host name from the drop-down list. Examples 
of IP addresses are 204.71.203.160, 216.115.104.67, or 195.14.130.100. Examples of hostnames are bsads.looksmart.com, 
jump.altavista.com, or www.ebay.com. SmartWhois also supports IP addresses with wildcards, such as 193.1.*.* or 193.1.217.* . In 
this case the program will scan the specified range of addresses and display all entries found.

Domain Queries

If you want to query a domain registration database, enter a domain name and hit the Enter key while holding the Ctrl key, or just 
select As Domain from the Query drop-down menu. The examples of valid domain names are netcom.com, volvo.se, or 
digiserve.co.uk. Don’t use the “www” prefix in your domain queries; for example www.microsoft.com is not a valid domain query 
(albeit a valid hostname query).

Custom Queries

If you need to query a non-default whois server or make a special query, click View => Whois Console from the menu, or click 
Query button and select Custom Query.

SmartWhois uses 4 main servers for IP queries and more than 20 regional whois servers to obtain domain registration records. Note 
that there are many countries that don’t have whois databases, and information for such national domains cannot be obtained. 
SmartWhois currently covers:

International domains: COM, NET, ORG, INFO, and BIZ; 
US domains: EDU, GOV, MIL, and US; 
Almost all of the European domains;
Canada, Mexico, Brazil, Japan, New Zealand, Australia, Singapore, Thailand, Taiwan, South Korea, and a number of other 
countries.



Batch Processing

SmartWhois can process lists of IP addresses, hostnames, or domain names saved as plain text files. The valid format for such 
batch files is simple: each line must begin with an IP address, hostname, or domain. If you want to process domain names, they 
must be located in a separate file from IP addresses and hostnames. If an IP address, hostname, or domain name is followed by 
other characters/words placed on the same line, there must be at least one space separating them from the first word on a line. 
Below is an example of a batch file, which is a standard web server log:

133.169.11.1 - - [10/Apr/2000:08:09:32 -0400] "GET /en.htm HTTP/1.0" 200 5413 "-" "Mozilla/4.0 (compatible; MSIE 4.01; Windows 
98)"
24.19.132.144 - - [10/Apr/2000:08:09:33 -0400] "GET /images/l2.gif HTTP/1.1" 200 848 "http://www.tamos.com/" 
"Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
194.45.56.32 - - [10/Apr/2000:08:09:34 -0400] "GET /download.htm HTTP/1.0" 200 10921 "http://www.tamos.com/" "Mozilla/4.61 
[en] (WinNT; I)"

Another sample batch file:

203.160.224.66 
199.107.4.10 
ns0.apecs.co.jp
161.196.244.104
24.94.163.6 
pool0142.cvx25-bradley.dialup.earthlink.net
210.145.100.82

An example of a domain name batch file:

toyota.com
starpower.net
force9.co.uk
volvo.se

You can automate batch processing using command line options. 



Command Line Options

SmartWhois supports command line parameters specifying IP address/hostname/domain, as well as files to be opened/saved.

Simple Parameters

To launch SmartWhois and make it query an IP address/hostname, you don't need to use any parameters except the IP 
address/hostname itself:

SW3.EXE 207.46.197.113
SW3.EXE www.yahoo.com

For domain queries, the domain name should be followed by "d":

SW3.EXE yahoo.com d
SW3.EXE etrade.com d

Complex Parameters

You can use command line parameters for performing complex batch tasks, such as loading a list of IP addresses, processing the 
list, saving the obtained results into a text file, and exiting. The following parameters exist:

-b specifies that the program should work in batch mode. This parameter is mandatory.
-si specifies that the next argument is a source file containing a list of IP addresses.
-sd specifies that the next argument is a source file containing a list of domains.
-ot specifies that the next argument is an output file, and that the results should be saved as text.
-oa specifies that the next argument is an output file, and that the results should be saved as a SmartWhois archive.
-c Specifies that the program should be closed when done. If you use this parameter, it should always be the last one.

Examples:

SW3.EXE -b -si C:\LOGS\list.txt -ot C:\LOGS\results.txt
The program reads IP addresses from list.txt, processes the list, and saves the results to results.txt in plain text format.

SW3.EXE -b -sd C:\LOGS\domains.txt 
The program reads domains from list.txt and processes the list without saving results.

SW3.EXE -b -sd C:\LOGS\list.txt -oa "C:\Business Data\my domains.sw3" -c
The program reads domains from list.txt, processes the list, saves the results to mydomains.sw3 as a SmartWhois archive, and 
exits.

Important: Files names containing spaces must be enclosed in quotation marks (" ").



Saving Results

SmartWhois allows you to save query results as a SmartWhois archive, TXT, or HTML file. If you want to save the current query 
output to a SmartWhois archive, click File =>Save Current Result =>As SmartWhois Archive. In this case the contents of the IP 
address tree and the text area related to the current query are saved.    To save query results as HTML or TXT file, click File =>Save 
Current Result =>As HTML File / As Text File. Only the information from Text Area will be saved. 

You can also save all query results to a SmartWhois archive by clicking File =>Save All Results As … . All contents of the IP tree 
and the corresponding output will be saved. 

If you’re saving results as a text file, you can specify the data fields to be saved; for example, you can exclude name servers or 
billing contact from the output file. Click Settings => Options => Misc. => Saving to configure the options. 

Additionally, you can drag the contents of the left or right panel to any folder. If you drag data from the left panel, the resulting file will 
be in SW3 (SmartWhois archive format). If you drag data from the right panel, the resulting file will be in HTML format.



Whois Console

Whois Console is used for making special queries or for querying a non-default whois server. Sometimes a standard query output 
would create a need for making a special query to obtain more detailed information. Here is an example of a standard query output 
for the domain macrovision.co.jp:

You see that Tech and Admin information cannot be retrieved with a standard query. Let’s suppose you need to obtain the technical 
support contact information. You can open the Whois Console by clicking View => Whois Console or Query => Custom Query, 
type in whois.nic.ad.jp for whois server and YM676JP /e for query, where YM676JP is the administrator’s handle and /e is used for 
suppressing Japanese output. Click Connect and you will see the following output:



Whois Console has a built-in list of many whois servers located all over the world. To select a server from the list, click on the small 
button on the left from the Connect button. If you want to customize or update this list, you can do that by editing the file named 
whois-servers.dat located in the application folder.



My Notes

You can save your notes about domains or IP addresses using the View => My Notes dialog.    To add notes, just type them in the 
Edit Notes field, then enter the IP address or domain and click Add/Update button. If you want to view or edit a note, click on an 
item in the list and the corresponding text will appear in the Edit Notes box. To remove a note, right click on it and choose Delete 
Record. Whenever SmartWhois displays information about an IP address or domain, it checks for corresponding user notes. If they 
exist, SmartWhois displays a hyperlink at the bottom of the right panel indicating that you entered certain information about the 
given IP address or domain in the past. You can click on the hyperlink to have your notes displayed.



Country Codes

Every country in the world is assigned a two-letter abbreviation. These abbreviations are used for identifying the geographic location 
of a hostname or domain, and are also called Top Level Domains (TLD). You can see the list of TLDs by clicking View => Country 
Codes. You can sort the entries by country names or codes by clicking the Country or Code column at the top of the window. 

The most up-to-date official TLD list is available at http://www.iana.org/cctld/cctld-whois.htm.



Configuring SmartWhois

You can customize the program’s configuration by clicking Settings => Options. 

Whois Servers

This tab allows you to specify whois servers for each part of the world. There are four standard whois servers for sending queries 
about InterNIC (US, Canada, and a few other countries), European, Asian, and Australian IP addresses. Sometimes a standard 
whois server might be down, so you can change it for an alternate user-defined whois server. 

The Query time-out slider sets the time limit for each query. If no information is received during the specified time the query is 
canceled. Depending on the speed of your Internet connection and the accessibility of whois servers you may want to increase or 
decrease the query timeout. 
 

Network

Resolve IP address to host name – if this box is checked, the program will try to resolve the host name for the entered IP address 
when you send a query.

Check if host is reachable (ping) – checks if the host is reachable at the moment by pinging it. If the box is checked, SmartWhois 
sends pings (echo requests) to the host and waits for the reply. If the host is geographically too far away from you, some of the 
pings can be lost en route because this kind of network packets has the lowest priority. Due to this reason the program usually 
sends more than one ping (4 by default) and the response time is calculated as a mean value. The time-out slider sets the maximum 
time the program will wait for ping replies.

Both name resolution and pinging are performed simultaneously with the whois server queries and do not require extra time. 

Use Socks Firewall – check this box if your PC is a part of a LAN and doesn’t have direct access to the Internet. SmartWhois can 
access the Internet through firewalls using the SOCKS5 protocol with or without authentication. You must enter the host address 
and port to be able to use this feature. If you are behind a firewall, you may also want to check the Don’t resolve hostnames 
locally box. This is useful when your computer doesn’t have access to a DNS server. If this box is checked, SmartWhois will not try 
to resolve the whois server addresses locally. Rather, the program will pass them to the SOCKS server for resolving. The only 
limitation for computers that don’t have access to a DNS server is that SmartWhois will be able to process only IP address and 
domain queries, but not hostname queries.

Cache Settings

SmartWhois is capable of caching the output of all queries, as well as maintaining a DNS lookup results cache for future use. If you 
enter an IP address or a host name that has been previously queried the program finds the query results in the cache and 
immediately displays the information even if you are not connected to the Internet.

Enable data caching – use this checkbox to enable this feature. 

You can change the maximum cache size using the Maximum cache size box. When the limit is reached the oldest records are 
removed from the cache. The current cache file size is displayed in the box with the same name. 

Auto-save interval, min. – allows you to enable or disable cache auto-saving and set the auto-saving interval. 

View Cache – allows you to view cached records. 

Clear Cache – purge the cache.

Enable IP address / hostname caching – check this box if you want SmartWhois to cache DNS queries. On the Internet a Domain 
Name Server (DNS) mechanism is used for resolving hostnames to IP addresses. Usually your computer queries the DNS of your 
Internet Service Provider (ISP) for an IP address corresponding to a hostname. However it is possible to have DNS information 
stored on your local computer, which may make the program work faster. 

View Local – allows you to view cached DNS records. 

Clear Local DNS – purge the DNS cache.

Remember that hostnames corresponding to IP addresses can be changed by their owner. The whois server authority 
can change high-level DNS records, and if you have an old record in your local DNS cache SmartWhois might be 
unable to access these hosts. Clearing the local DNS cache can solve this problem.

Miscellaneous Settings 



General

Run on Windows Startup – if this box is checked, the program is automatically launched every time you start Windows.

Clear query history on exit – clears the program’s drop-down list from the recent queries. 

Disable auto-sorting when processing batch files – prevents the program from automatically sorting the right panel’s list when 
processing batch files. This allows you to see the list of IP address as it appears in the input batch file. 

Disable ping when processing batch files – prevents the program from pinging each host or IP address contained in the batch 
while making queries. 

Automatically de-obfuscate URLs – check this box to have the program decode obscure (or standard) URLs when you paste 
them to the input field. An examples of such URL is: http://new.sec.34333QQ@193490259912/o%62s%63ur%65%2e%68t%6D .

Save all nodes when dragging – this option controls the contents of the SmartWhois archive that is created when you drag data 
from the application window. If this box is checked, the resulting file contains data for all nodes on the left panel. If this box is not 
checked, only the currently selected node will be saved.

Custom ping message – allows you to change the default string contained in ping packets.    To use this feature, check this box and 
type your own message in the textbox below. 

Saving

This pane allows you to include/exclude various data fields when you save results as a text file.



How to Purchase SmartWhois 

This program is a 30-day evaluation version. If you would like to continue using it after 30 days, you must purchase it. Below is the 
pricing for the fully functional, unrestricted version of the program: 

License Price, US
1 User License $29.00
5 User License $120.00
10 User License $190.00

Call us for pricing on larger site licenses.

As a registered customer, you are entitled to: 

· Free updates that will be released within 1 year from the date of purchase;
· Information on updates and new products;
· Free technical support. 

We accept credit cards orders, orders by phone and fax, checks, and wire transfers. Prices, terms, and conditions are subject to 
change without notice; please check our web site for the latest product offerings and prices.

http://www.tamos.com/order/



Contacting Us

Questions? Comments? Suggestions? Bug reports? Don’t hesitate to contact us. 

http://www.tamos.com/

If you have a question that is not answered in this manual, please take a minute to check our Frequently Asked Questions page 
before contacting technical support. There is a good chance that you will find the answer there. When describing your problem, 
please be as specific as possible. A detailed description of the problem will help us solve it much faster. Please don’t forget to 
mention the OS version, the program version and build (Help => About), and all other details that you think may be relevant.



Other Products by TamoSoft

CommView 

CommView is a program for monitoring Internet and Local Area Network (LAN) activity capable of capturing and analyzing network 
packets. It gathers information about data passing through your dial-up connection or Ethernet card and decodes the analyzed data. 
With CommView you can see the list of network connections and vital IP statistics and examine individual packets. IP packets are 
decoded down to the lowest layer with full analysis of the main IP protocols: TCP, UDP, and ICMP. Full access to raw data is also 
provided in real time. CommView is a helpful tool for LAN administrators, security professionals, network programmers, or anyone 
who wants to have a full picture of the traffic going through one's PC or LAN segment.

More information

Essential NetTools

Essential NetTools is a set of network tools useful in diagnosing networks and monitoring your computer's network connections. It's 
a Swiss Army knife for everyone interested in a set of powerful network tools for everyday use. The program includes a NetStat 
utility that shows your computer's network connections and open ports and maps them to the owning application. It also features a 
fast NetBIOS scanner, a NetBIOS Auditing Tool for checking LAN security, and a monitor of external connections to your computer's 
shared resources, as well as a process monitor that displays information about all the programs and services running on your 
computer. Other useful tools are included, such as Ping, TraceRoute, and NSLookup. Additional features include report generation 
in HTML, text, and comma delimited formats and a customizable interface. The program is an easy-to-use and powerful 
replacement for such Windows utilities as nbtstat, netstat, and NetWatcher. It incorporates many advanced features that standard 
Windows tools can't offer.

More information 

DigiSecret

DigiSecret is an easy-to-use, secure, and powerful application for file encryption and sharing. It utilizes strong and time-proven 
encryption algorithms for creating encrypted archives, self-extracting EXE files, and sharing files with your associates and friends. 
DigiSecret also includes powerful and intelligent file compression; you no longer need .zip files when you can have encrypted and 
compressed DigiSecret files. The program is integrated with the Windows shell, and you can perform operations on files by right-
clicking on them. It also fully supports drag-and-drop operations.

More information




