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This manual is designed for use in conjunction with the included Ultimatte Overview
Manual  that provides more complete information about how Ultimatte works and
how to achieve the best results. Also, this manual assumes that you are familiar with
Adobe After Effects and understand its basic operation. 

Throughout this document, references to blue screening, blue backing areas, etc.
would apply to green when green is used as a backing color.

We suggest that you read through this manual (it’s short!) and follow along tutorial-
style to get up to speed on Ultimatte as quickly as possible.

how to contact us

In addition to reading the Ultimatte Overview Manual, you can learn more about blue-
screen compositing techniques and the latest news on our After Effects plug-ins by
visiting the Ultimatte web site at www.ultimatte.com

Technical support is available from 8:00 AM to 4:30 PM Pacific time at (818) 993-8007
or you can send e-mail to support@ultimatte.com.

Ultimatte Corporation
20554 Plummer Street
Chatsworth, CA 91311
tel: (818) 993-8007
fax: (818) 993-3762

www.ultimatte.com  

about this user guide
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Ultimatte bluescreen image compositing and matting software for Adobe After Effects
produces seamless composited images using the same patented algorithms as in
Ultimatte's Oscar and Emmy-award winning systems. With Ultimatte, you can create
flawless composites of the highest quality, retaining all details, shadows and trans-
parencies. 

Ultimatte is NOT a simplistic chroma-keyer, but the same full-fledged, professional qual-
ity blue and green screen system used in major motion pictures, on television and in mul-
timedia productions of the highest caliber.  Fine hair detail, water, shadows, smoke, glass
and reflections, even blurred edges are all composited flawlessly and automatically. With
Ultimatte, you achieve totally realistic-looking composited scenes that would otherwise
be too dangerous, impossible or impractical. Use Ultimatte to place your talent in any
situation without the expense of transporting them and their entourage to a location
shoot. 

Ultimatte provides four plug-ins for After Effects: Screen Correction, Grain Killer,
Ultimatte and Black Matting

minimum system requirements

Ultimatte will run on any system configured to run Adobe After Effects.

installation and security key

The key must be connected in order for the software to run. If the key is not connected,
the Ultimatte software will run in demo mode and render a grid over its output. 

Macintosh:
Make sure your computer is shut down, then install the Ultimatte security key on the
Apple Desktop Bus.  Re-boot your computer and then insert the Ultimatte CD in your
CD-ROM drive and run the Ultimatte Installation program.  Also, drag the Images and
Projects folders into a directory of your choosing on the hard drive of your computer.

Windows:
Make sure your computer is shut down, then install the Ultimatte security key on your
computer’s parallel port. Re-boot your computer and then insert the Ultimatte CD in your
CD-ROM drive and run the Ultimatte Installation program.  Choose both the “Install Plug-
ins” and the “Install Projects” options.

Ultimatte for Adobe After Effects
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Screen Correction
compensates for anomalies in the blue screen; uneven lighting,
smudges, seams, or blue set pieces. Using an exact copy of the
problematic blue screen with the subject matter removed, this
e ffect will rid the foreground of these unwanted anomalies, cre-
ating a new image against a perfect blue backing.

Grain Killer
reduces noise in the screen area of the foreground often creat-
ed by film grain, video noise, or compression.  

Ultimatte
creates the matte and seamlessly composites foreground ele-
ments into a background scene retaining all detail. If the cam-
era can see it, Ultimatte can composite it.

Black Matting
is the newest Ultimatte plug-in that lets you create composites
from foregrounds shot against black, such as fireworks or
explosions. Because it is designed to work with black backing
areas, it does not work with Screen Correction or Grain Killer
and is used by itself.

Ultimatte for Adobe After Effects consists of four plug-ins which can be used to cre-
ate flawless composites:  

To obtain the best results, use the plug-ins in the following
order: Screen Correction, Grain Killer and then Ultimatte. Black
Matting is used by itself.

getting started
Ultimatte for Adobe After Effects



page 3

Background
The image that will replace the 
backing color of the foreground in the
final composite. Also noted as BG.

Backing 
The blue or green screen area.

Black Matting
This plug-in lets you use black as a
backing color (perfect for explosions!)

Composite
The foreground image (with the 
backing area and flare removed) 
combined with the background clip.

Flare
Contamination of the blue (green)
screen on to the foreground subject.
Also referred to as spill.

Foreground
The subject matter against the 
backing color. Also noted as FG.

Grain Killer
This plug-in reduces noise in the
screen area of the foreground often
created by film grain, video noise, or
compression.

Matte
A black, gray and white image that is
used to determine the percentage of
foreground and background values.
Also referred to as alpha channel.

Print-thru
When areas of the background are 

visible through the foreground subject
where they should not be seen, or
when the foreground is not opaque in
areas that should be opaque. 

Processed Foreground
The foreground image with the backing
area suppressed to black and all flare
removed. 

Screen Correction
This plug-in compensates for anom-
alies in the blue screen; uneven light-
ing, smudges, seams, or blue set
pieces. Using an exact copy of the
problematic blue screen element with
the subject matter removed, this effect
will rid the foreground of these unwant-
ed anomalies, giving the impression of
being shot against a perfect blue field.

S c reen Correction Scene
An identical copy of the original fore-
ground with no props or talent. 

Veiling
A colorized haze over the background.

Ultimatte
The compositing plug-in which seam-
lessly composites foreground elements
into a background scene retaining all
detail. If the camera can see it,
Ultimatte can composite it.

For more complete discussions of
t h e s e, please see the Ultimatte
Overview Manual.

terminology
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A completed U l t i m a t t e project in
Adobe After Effects

Creating the Project
After you have installed the U l t i m a t t e plug-ins, begin by opening After Effects and
creating a new project using the File>New Project menu item. Load the Foreground,
Screen Correction, and Background footage into the project. To achieve the highest quality
on your projects, be sure to import clips with little or no compression.

Above is an example of a typical Ultimatte Composite in After Effects.  This is an example of
a typical Ultimatte Effects panel within After Effects. All Ultimatte effects are located in
Effects>Ultimatte. Drag and drop the Background, Screen Correction and the Foreground
onto the Comp 1 icon within the project window. This will assure that your clips are perfectly
aligned. Remember to keep the Foreground clip above the Background clip in the time layout
window.

getting started
Ultimatte Tutorial
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The following tools are commonly used during the
Ultimatte process:

Effects Switch

Twirl Down
Arrow

View Pull
Down Menu

Eyedropper

Sampled
Screen Color

Slider

Number
Field
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Effects Switch: This box will allow the effect to
easily be turned on or off.

Eyedropper: The eyedropper tool is used by
placing the tip over the desired area and 
clicking the mouse to collect data. 

Eyeball: This icon allows a layer to remain in the
time layout without being visible. “Closing”  the
eyeball for the screen correction layer will allow
the clip to be used as a reference layer.

Info Palette: This palette contains RGB values
and will be helpful when using Grain Killer. The
Info palette is located in Windows>Palettes>Info.

Number Field: Click once on any underlined
number field to enter a numeric setting. In the dia-
log box, type in the desired value, click OK.

Slider: This option allows you to click and drag
on the triangular handle to change settings.
Holding the Option (Mac) / Alt (Windows) key
while moving this control will update the Comp
window for every value. Remember that After
Effects does not  allow for real time rendering,
therefore allow time for settings to change. .

Twirl Down Arrow: Click once on this icon to
expose or collapse controls.

Zoom: Located in the tools palette, the zoom
tool will allow a closer view of the image. Hold the
Option (Mac) or the Alt (Windows) key while click-
ing to "zoom out" of the frame. 

getting started
tools and icons
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For best results use Screen Correction, then 
Grain Killer followed by Ultimatte.

Screen Correction compensates for anomalies in the backing area such as uneven
lighting, smudges, seams, variations in the backing color, blue set pieces, and
unwanted shadows cast by set pieces. By using an exact copy of the problematic
blue screen element with the foreground subject matter omitted as a reference,
U l t i m a t t e ' s algorithms will automatically correct the foreground so that the levels of
the blue (green) screen are the same throughout each frame. Screen Correction d i f-
ferentiates between foreground elements and backing flaws, thereby allowing the
Ultimatte algorithms to retain all foreground detail without compromise because of
a poorly shot foreground element.  For more detailed information, see the S c r e e n

C o r r e c t i o n section in the Ultimatte Overview Manual. 

Screen Correction 
corrects uneven lighting, smudges & 

set pieces

+
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the process
Screen Correction

In the Time Layout window, be sure to align the Screen Correction layer perfectly with
the in/out position of the Foreground Layer.

Switch the view (eyeball) to off on the Screen
Correction layer.

Select the foreground clip in the Time Layout Window.

Change “Switches” to “Transfer Controls” in the
Time Layout. 

Change the Foreground
transfer mode by dragging
from “Normal” to
“Luminescent Premul”. 

N o r m a l
D i s s o l v e
Dancing Dissolve
A d d
M u l t i p l y
S c r e e n
O v e r l a y
Soft Light
Hard Light
D a r k e n
L i g h t e n
D i f f e r e n c e
H u e
S a t u r a t i o n
C o l o r
L u m i n o s i t y

Stencil A l p h a
Stencil Luma
Silhouette A l p h a
Silhouette Luma

Luminescent Premul
Alpha A d d
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With the Foreground clip still selected, apply
Effects>Ultimatte>Screen Correction
from the menu bar.

In the effects dialog box, use the eyedropper tool to sample the blue or green backing
color of the FG (foreground) image that appears in the viewing area. Be careful to select
an area of backing unobscured by any FG detail (smoke, hair, reflections in glass, or
shadow areas).

Set the Correction Layer pull down menu to the Screen
Correction layer.

Set the View pull down menu to Corrected Foreground.
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Using the Screen Correction Matte Controls

The controls in this menu are used to isolate the foreground image from the backing. When

using Screen Correction the matte should have perfect density or be slightly over-dense,

but never under-dense. If an object that should have an opaque matte has a semi-trans-

parent matte, Screen Correction will try to partially correct that object, thereby making it

closer to the actual backing color. This will cause more print-thru problems when the

Ultimatte plug-in is used.

You can use the Matte Density control to stop print-thru in bright foreground objects or the

Black Gloss control to prevent print-thru in black glossy or dark foreground objects. 

• Set the View pull-down window to “Matte” and decide if there are any areas that appear

gray (transparent) in your foreground subject matte that should be white (opaque).  

• Adjust the Matte Density and/or Black Gloss values slightly by using the slider.

• Set your view back to "Corrected Foreground" to view the results.

You’ve finished with Screen Correction! If you want to learn more about how it works,

please read the appropriate section of the informative "Ultimatte Overview Manual."
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Screen Correction Summary

• Switch the eyeball off for the Screen Correction layer

• In the Time Layout Window, Select the Foreground layer

• Change the Transfer Control to Luminescent Premul for the
Foreground

• Select Effects>Ultimatte>Screen Correction

• Sample the Backing Color of the foreground layer

• In the Effects Box, set the Correction layer pull-down menu to
the Screen Correction layer

• Set the View pull-down menu to Corrected Foreground 
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If you are using Screen Correction, use it before you use
Grain Killer

Grain Killer is an exclusive Ultimatte feature which removes film grain or video noise from

only the blue screen area.  Ultimatte is so good at compositing fine detail that any noise in

the backing will be composited onto the background, adding to noise which resides in the

background scene.  This is often very subtle and unnoticeable.  However, if you want a per-

fectly clean composite, especially where the noise problem is compounded by multi-layer

composites, Grain Killer will remove the noise from the background without softening the

foreground subject. For a more complete discussion of Grain Killer, please see the

Ultimatte Overview Manual.

Remember that if you are using Screen Correction, use it before you use Grain Killer.

Before Grain Killer 
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Grain Killer
to clean up grainy & noisy backing 

After Grain Killer 
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the process
Grain Killer

Sample The Backing Color

In the effects dialog box, use the eyedropper tool to sample the backing color of the FG
(foreground) image that appears in the viewing area. Be careful to select an area of back-
ing unobscured by any FG detail (smoke, hair, reflections in glass, or shadow areas). 

In the Effects dialog box,
switch the View pull
down menu to Filter
Area.

Be sure that the After Effects
Info palette is visible.

This process will define areas of the backing to be filtered. The white areas represent fil-
ter areas (screen ), while the black and colored sections represent areas not to filter (sub-
ject and transitions areas). Ideally, the settings should be such that the film grain or video
noise in the backing color become part of the filtered area (white).

While moving the cursor over these black pixels, take note of the RGB values in the Info
palette. For example, when the cursor touches a black pixel of the screen area, the RGB
values might be “7,15,3 .”  Another black pixel might have RGB values of “18, 9, 2” and 

Define the Filter Area
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a third pixel may have RGB values of “14, 8, 0.”  Enter the highest value in the respective off-
set control on the Grain Killer effects panel. In this example, set the Red Offset to “18,” the
Green Offset to “15,” and the Blue Offset to “3.”

Repeat this process until the screen area is white, ADDING the largest value to the appropri-
ate offset control. Therefore if the next set of RGB values is “5, 2, 1,” the new Red Offset value
should be “23.” (Previous setting 18 + 5 = 23) Follow this procedure in the G and B channels.

Master Offset will increase the Red, Green and Blue offset simultaneously and is additive to
the individual offset controls.  For example, if the RGB values “24, 32, and 11” were observed,
adjust the Master Offset to the lowest of the RGB values: “11.” This will quickly change the
range of the offsets. 

Switch between the filtered foreground and the foreground to determine if filtering is occurring
in the subject matter.

• Set the View pull down menu to Filtered Foreground. 

The Matte Density and Black Gloss controls are used to isolate the foreground image from the
backing. The control names are the same as in Ultimatte, but they are used differently. When
using Grain Killer the matte channel controls the amount of filtering that will occur in trans-
parent areas and edges. If the matte is under dense, then too much filtering will occur in the
semi-transparent areas, thereby giving the impression of a softer image or a loss of detail.
Therefore, attempt to create either a perfectly dense or over dense matte.

Set these controls using the following guidelines.

• Matte Density: Use this control to stop filtering in bright foreground objects. 

• Black Gloss: Use this control to stop filtering in black glossy or dark foreground objects. 

Before Grain Killer After Grain Killer

Adjust Matte Density and Black Gloss Controls if necessary
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Grain Killer Summary

• In the Time Layout Window, Select the Foreground Layer

• Change the Transfer Control to Luminescent Premul for the
Foreground Layer

• Select Effects>Ultimatte>Grain Killer

• Sample the Backing Color

•In the Effects dialog box, Set the Offset Controls

• Adjust Matte Density and Black Gloss Controls if necessary

• Set the View pull-down menu to Filtered Foreground 
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If you’re using Screen Correction or Grain Killer, use them
before you composite with Ultimatte. If your backing area
is black, skip this section and go to the Black Matting
Section on Page 25.

Now that you've prepared your shots using Screen Correction and Grain Killer, you're

ready to composite the elements together using Ultimatte.  It will take the output from

the Screen Correction and Grain Killer presets and combine the foreground and back-

ground images using a matte to create a new composited image. Ultimatte has the

unique ability to composite anything that the camera can see, including but not limited

to smoke, shadows, glass, reflections, fine detail and motion blur.

Ultimatte compositing
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the process
Ultimatte

Select the foreground clip in the Comp Time Layout Window

If you haven’t already done so, Change
“Switches” to “Transfer Controls” in the Time
Layout. 

Change the Foreground
transfer mode by dragging
from “Normal” to
“Luminescent Premul”. 

N o r m a l
D i s s o l v e
Dancing Dissolve
A d d
M u l t i p l y
S c r e e n
O v e r l a y
Soft Light
Hard Light
D a r k e n
L i g h t e n
D i f f e r e n c e
H u e
S a t u r a t i o n
C o l o r
L u m i n o s i t y

Stencil A l p h a
Stencil Luma
Silhouette A l p h a
Silhouette Luma

Luminescent Premul
Alpha A d d

With the Foreground clip still selected, apply
Effects>Ultimatte>Ultimatte from the menu bar.
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This completes the tutorial section.  The following pages describe each of the Ultimatte

plug-in controls.  You can also find additional information about these and all of the other
controls for th Ultimatte plug-ins in the informative Ultimatte Overview Manual.

Sample the Backing Color
In the effects dialog box, use the eyedropper tool to sample the backing color of the FG
(foreground) image that appears in the viewing area. Be careful to select an area of back-
ing unobscured by any FG detail (smoke, hair, reflections in glass or shadow areas).

Set the Matte Controls
Now click on the "Matte Controls" button in the Ultimatte Effect Editor window and use the
view drop-down menu to select "Matte.”  The matte will appear in the window.

The white areas represent opaque foreground subject matter, the black areas represent the
backing areas which will be replaced by the new background image, and the gray areas rep-
resent partially transparent or transition areas. Reducing the density of the foreground
object's matte can reduce dark matte lines in the composite.

Set the Flare Controls
Finally, click on the “Flare” tab to bring up Ultimatte’s flare controls and set the “View” to
“Composite.”  Often objects in the foreground shot will pick up some blue spill or flare.
Ultimatte’s algorithms automatically suppress the flare, but if the flare on the subject is
excessive, you can use these controls to compensate. You can correct excessive flare by
adjusting the Gray Balance and Black Balance controls found on the Flare menu.  When
blue spill is a problem, try slightly higher settings for each of these and Ultimatte will remove
the blue that has “spilled.”



Matte Density: Use this control to stop

print-thru in bright foreground objects.

Warning:  Advancing this control too far

can cause hard, dark edges around fore-

ground subjects.

Black Gloss: Use this control to stop print-

thru in black glossy or dark foreground

objects. Warning: Advancing this control too far can cause dark edges around the

foreground subject and shadows will darken and become opaque.

Black Gloss 2: Use this control to stop print-thru on dark foreground objects that have an

excessive amount of spill from the backing. This control adjusts the foreground prior to gener-

ating the matte, thereby giving the appearance of being both a matte control and a flare control.

Warning: Advancing this control too far can alter the color of the foreground objects.

Red Density: (not available for red backing): Use this control to reduce dark edges from red-

dish objects (flesh-tones). Warning: Reducing this control too much can cause print-

thru in reddish foreground objects.

Green Density: (not available for green backing): Use this control to reduce dark edges from

greenish objects (plants). Warning: Reducing this control too much can cause print-thru

in greenish foreground objects.

Blue Density: (not available for blue backing): Use this control to reduce dark edges from

bluish objects. (blue jeans) Warning: Reducing this control too much can cause print-

thru in bluish foreground objects.
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Ultimatte controls 
The first 6 Matte Controls are used for print-thru,
dark edges and glowing edges.
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These matte controls are used to adjust the

white and gray areas of the matte channel.

This will dramatically affect the nature of

foreground objects' edges, the opacity of

transparent objects, and the noise in the

background image.  Use these controls

sparingly as they WILL result in the loss of foreground detail. The proper technique for deal-

ing with imperfections in the screen is through the use of Screen Correction and Grain Killer.

Clean Up: Used to reduce imperfections or small amounts of noise in the backing.

Warning: Advancing this control too far will result in a "cut and paste" look.
Background noise will be reduced, but foreground detail will also be reduced. 

Clean Up Balance: Used only when the Clean Up control has been adjusted, this control

determines how much influence the Clean Up control will have on the foreground and back-

ground images. If using the Clean Up control causes glowing or dark edges, Clean Up

Balance can be used to reduce this problem.

BG Level Balance: Use this control to override the automatic setting of the Background

level as turned on by the matte, which is based on where the backing color was selected.

Decreasing this control can enhance the appearance of fine foreground detail, but will dark-

en the background image and increase "visual noise.” Increasing this control can remove

"visual noise" and brighten dark edges. Warning: Advancing this control too far can
cause foreground objects' edges to glow.

Shadow Noise: Use this control to reduce noise in shadows and glare areas. Warning:
Decreasing the control too much will reduce fine detail.

Matte Sizing: Use this control to adjust the size of the matte channel, often referred to as

“choking the matte.”  It can be used to reduce matte lines.  Warning: Advancing this con-
trol too far will result in a loss of detail.

The next 5 Matte Controls are for hard edges,
glowing edges and screen imperfections.



The Ultimatte algorithms will automat-
ically suppress flare caused from the
backing onto foreground subject mat-
ter. The flare controls are used to sup-
press excessive spill.

White Balance: Use this control to
remove excessive spill on bright 
foreground objects.

Gray Balance: Use this control to remove excessive spill on midrange foreground objects.

Black Balance: Use this control to remove excessive spill on dark foreground objects.

Gate 1/3: ("Gate one three") Use this control to reproduce blues, greens, or cyans. 

For blue screen: At 100%, blues will be reproduced.  At 50%, blues will become cyan. At 0%,
greens will be reproduced and blues/cyans will turn green.

For green screen: At 100%, greens will be reproduced.  At 50%, greens will become cyan.
At 0%, blues will be reproduced and greens/cyans will turn blue.

Gate 2: Use this control to reproduce the following colors:

For blue screen: used to reproduce pinks, purples, and magentas that will turn red when blue
is subtracted. Warning: Since skin tones are pinkish, advancing this control too far
may add blue to the skin tones.

For green screen: used to reproduce yellows and oranges that will turn red when green is
subtracted.  Warning: Since skin tones are pinkish, advancing this control too far may
add green to the skin tones.

Ultimatte controls
Flare Controls for excessive spill & miscolored
subject matter

page 22
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These controls are used to override
the automatic suppression of the
backing color. The Ultimatte process
uses the selected backing color to
suppress the backing to black. An
indication that the automatic settings
did not suppress enough backing is "veiling" or a colorized haze over the background. An
indication that the automatic settings suppressed too much backing is darkened or miscol-
ored foreground edges and transparencies. In most cases these controls will be left at their
default settings. 

Master: This control overrides the automatic suppression of the red, green and blue chan-
nels simultaneously.  Increasing this control will increase the brightness in the screen area.
Decreasing this control will cause a darkening of the edges and transparencies.

Red Veil: This control overrides the automatic suppression of the red channel.  Increasing
this control will increase the amount of red veiling (residue) left in the backing area.
Decreasing this control will cause foreground edges and transparencies to become cyan.

Green Veil: This control overrides the automatic suppression of the green channel.
Increasing this control will increase the amount of green veiling (residue) left in the backing
area. Decreasing this control will cause foreground edges and transparencies to
become magenta.

Blue Veil: This control overrides the automatic suppression of the blue channel. Increasing
this control will increase the amount of blue veiling (residue) left in the backing area.
Decreasing this control will cause foreground edges and transparencies to become yellow.

Veil Controls to correct a miscolored 
background or foreground edges 
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Ultimatte Summary

• In the Time Layout Window, Select the Foreground Layer

• Change Transfer Control to Luminescent Premul for the
Foreground layer

• Choose Effects>Ultimatte>Ultimatte 

• Sample the Backing Color

• In the Effects dialog box, set the Matte, Flare, and Screen
Controls, if necessary

• Set the View pull-down menu to Composite 



Use the Black Matting plug-in instead of the
Ultimatte plug-in if your footage is shot against
black.

The black matting plug-in is used when you have footage which is shot against a

black or nearly black backing area. It is particularly useful when shooting self-illu-

minated subjects such as fireworks, explosions, flames, lightning effects and other

specialized subject matter.

Black Matting
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The Black Matting plug-in is used by itself and
will not work with Screen Correction or Grain
Killer.



Black Matting Compositing
the process
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Select the foreground clip in the Comp Time Layout Window

If you haven’t already done so, Change
“Switches” to “Transfer Controls” in the Time
Layout. 

Change the Foreground
transfer mode by dragging
from “Normal” to
“Luminescent Premul”. 

N o r m a l
D i s s o l v e
Dancing Dissolve
A d d
M u l t i p l y
S c r e e n
O v e r l a y
Soft Light
Hard Light
D a r k e n
L i g h t e n
D i f f e r e n c e
H u e
S a t u r a t i o n
C o l o r
L u m i n o s i t y

Stencil A l p h a
Stencil Luma
Silhouette A l p h a
Silhouette Luma

Luminescent Premul
Alpha A d d

With the Foreground clip still selected, apply
Effects>Ultimatte>Black Matting from the menu bar.
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Sample the Backing Color
In the effects dialog box, use the eyedropper tool to sample the black backing color of the
FG (foreground) image that appears in the viewing area. Be sure to select an area of back-
ing unobscured by any FG detail (smoke, thin, almost transparent sections of flames, etc.).

There are just five controls that influence the look of your composite when using the black
matting plug-in.  In most cases, you should be able to just pick the black backing color using
the eyedropper and you’ll be able to create an excellent composite.

If necessary, you can use the provided Offset, Density and Cleanup controls to adjust the
density of colors in the foreground subject and clean-up the matte.  You will find a more com-
plete description of the controls used when black matting on the following page.

As with other Ultimatte controls, a little experimentation will help you to learn how the con-
trols work and the effect that their use will have on your final composite.



Black Matting controls

Offset: The value for the offset is set when you sample the black backing area using
the eyedropper tool.  You can use this control’s slider to override the value established
by the selection of the backing color.

Red Density: Adjusts the density of the Red component in the Foreground subject.
This allow you to fine-tune the look of semi-transparent areas of the Foreground
Subject.

Green Density: Adjusts the density of the Green component in the Foreground sub-
ject.  This allow you to fine-tune the look of semi-transparent areas of the Foreground
Subject.

Blue Density: Adjusts the density of the Blue component in the Foreground subject.
This allow you to fine-tune the look of semi-transparent areas of the Foreground
Subject.

Clean Up:  Used to reduce imperfections or small amounts of noise in the backing.
Warning: Advancing the Clean Up control too far will result in a "cut and paste"
look. Background noise will be reduced, but foreground detail will also be
reduced. 

Clean Up Balance: Used only when the Clean Up control has been adjusted, this con-
trol determines how much influence the Clean Up control will have on the foreground
and background images. If using the Clean Up control causes glowing or dark edges,
Clean Up Balance can be used to reduce this problem.
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All of the usual After Effects features are available when using Ultimatte (eg.,
keyframes).

Color Correction

Color Correction should always occur after the matte has been generated by
Ultimatte. After Effects has quite an extensive set of color controls, located under
Effect >Image Control. 

Garbage Matte

Several methods can be applied to create garbage mattes. The most direct method
is to use Mask Handles or Mask Vertices.

• Double click on the foreground clip in the Time Layout window to expose the
Foreground layer. Switch the pull down menu (currently displaying “none”) to
“Mask Handles.” 

• Grab one of the 8 handles on the outside edge of the image. Drag handle into the
frame. View Composition window to see the change. 

• Using “Mask Vertices” will produce a similar effect. Use the pen tool from the Tool
box to create points and curves to outline the unwanted portion of the frame. 

• Advancing the clip and changing the mask position will allow a track matte to be
created.

Luminescent Premul

Luminescent Premul (luminescent premultiply) is the transfer mode that Ultimatte
uses to combine images using a true additive mix. Try using other transfer modes
to create various special effects. 

For more information regarding any of these tips, consult the Adobe After Effects
Documentation. 

After Effects Controls
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