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 Game collections

Game collections
Chessica stores its games in game collections. A game collection is a single disk file that can hold many 
different games and even other collections. A collection within a collection is called a subcollection. 
Collections can be compared with disk directories (folders), but they offer several advantages:

- They save disk space because games are stored within a single file and not as separate files on disk.
- A collection allows a very flexible hierarchical storage of games.
- You can simply copy a complete collection together with all its games by copying the collection disk 

file.
- A collection or game can have a long descriptive name (up to 31 characters long).

In the example shown above you can see part of the Open game and Save game dialog. In this case it 
displays a collection with the name Kasparov Karpov all games. This collection includes many 
subcollections, the first subcollection shown is Leningrad 1975 and the last one visible is Moscow SU 
championship 1988. These subcollections are shown indented. Subcollections can be nested several 
levels deep, but this example uses only one level.
The collection Worldchampionship 1984 is currently selected. The games stored in the current 
collection are shown in the rightmost list box.



 Introduction

Please, read this chapter thoroughly after installing Chessica for the first time.

Introduction topics:
About the manual and help file
Quick start
How do I...
Solving checkmate problems

____________________________________

About the manual and help file
In the Chessica manual and help file it is assumed that you have some basic knowledge about the 
Windows environment. For example, it assumes that you are familiar with standard Windows terminology 
like windows, buttons, clicking, etc. For information about a specific topic refer to the Index in the printed 
manual. From within Chessica you can select an item from the Help menu to activate the Chessica on-
line Help system.

Quick start
Playing your first game

Playing a game against Chessica is simply a matter of starting the program and making your first 
move on the chessboard. Chessica will automatically respond with a counter move. After finishing the 

game select New Game from the File menu (or press  on the Toolbar) to start a new game.
Note: If the settings of Chessica have been changed and the program does not react as expected, 

select Restore Factory Settings from the File menu to restore Chessica to a predefined state.

Playing with Black
To play with Black, Set Opponents to Computer-Player and select Start Thinking from the Engine 

menu (or press  on the Toolbar). If you like, you can rotate the board 180 degrees by selecting 
Board, Rotate from the Settings menu (or press 

 on the Toolbar).

Saving your game
To save a game select Save Game from the File menu. The top-left list box should now display the file 
YOURGAM.GAM. If not, move to the CHESSICA\GAMES directory.
Select YOURGAM.GAM and type a name at the Descriptive Name control. Press Save to write the 
game to disk.

Setting the time controls
The easiest way to change the time control is to select a predefined level from the Level menu. You 
can select Custom from the Level menu to define other time controls.

How do I..
This topic explains some the basic actions you need know when you play a game of chess against 
Chessica.

Make a move on the chessboard
- Move the pointer over the piece you want to move.
- Press down the mouse button and keep it pressed.



- Draw the piece to its destination square.
- Release the mouse button.

If the piece magically returns to its starting square it might be that:
- You did not make a legal move.
- It is not your turn to move (the computer is to move).

Take back or replay moves
There are two possible methods:
- Use the slider bar to walk through the game. This slider bar can be found in the Toolbar at the top of 

the screen. You can use the slider bar at any moment to move through the game.
- In the moves view, click on the move you want to go to.

Tell Chessica to start or stop thinking

Start/stop thinking is a toggle action controlled by  on the Toolbar and the Start Thinking/Move Now 
item from the Engine menu.
If the chess engine is currently thinking, it will stop thinking and make a move; if the chess engine is not 
thinking (idle or anticipating) it will start thinking.

To abort the chess engine, you can press  on the Toolbar or select Abort Thinking from the Engine 
menu. The chess engine will abort the search and will not produce a move.

Multiple Document Interface (MDI)
One of the most important features of Chessica is that you can have several games loaded into memory 
at the same time. For example, you can play a game in one window and browse through games on disk 
in another window.
You can immediately select one of the loaded games by clicking on one of the game buttons 

 on the Toolbar. The loaded games are also listed at the end of the Window menu.
If you open a game using the Open Game option from the File menu, Chessica creates a new game 
window. Also, if you start a new game, you can optionally create a new game window.
Therefore, it is important to explicitly close the games that are no longer needed.

Solving checkmate problems
If you want to search for a checkmate in the current position, select Find CheckMate from the Engine 
menu. This will active the dedicated mate solver. The mate solver will search for the shortest checkmate 
in the current position and automatically make the move on the chessboard if it finds a checkmate.
Depending on the position and the depth of the checkmate, solving for mate can take a long time. You 

can abort the mate solver by pressing  on the Toolbar or select Abort Thinking from the Engine 
menu. The chess engine will abort the search and will not produce a move.

While the mate solver will always find the shortest possible checkmate, the chess engine will sometimes 
find a checkmate very quickly when Analysis mode is selected, especially if you set the engine to Brute 
Force





 Opponents

The Opponents menu contains the following items.

Player-Player
You play both White and Black.

Player-Computer
You play with White, the computer has Black.

Computer-Player
The computer plays with White, you play with Black. You might want to rotate the screen board using the 
Board sub menu in the Settings menu.

Computer-Computer
The computer plays with both White and Black. This is a demo play mode.

Analysis
The analysis mode is similar to Player-Player: you can make moves for both White and Black. However, 
the chess engine will always calculate on the current position in the background. You can therefore 
immediately view the chess engines opinion of the current position.
The mode is especially useful if you want to analyze a game.

Note: While Analysis is selected the Level settings are ignored.



 Level settings

The Level menu contains the options for the time control of the game.

Layout topics:
Predefined levels
Custom levels
Available time controls

See also: View Settings

____________________________________

Predefined levels
40/2:00 moves/hours
A standard tournament level in which both White and Black must play at least 40 moves in 2 hours.

5 minutes/game
A speed chess game mode. Both White and Black may take up to 5 minutes for the complete game.

Fischer 90min+15sec
Fischer time control. The game starts with 90 minutes for the complete game, but after each move 15 
seconds will be added to the available time.

Bronstein 90min+15sec
Fischer time control. The game starts with 90 minutes for the complete game, but after each move up to 
15 seconds, but not more than the time used for the last move, will be added to the available time.

10 sec/move
The chess engine will think about 10 seconds per move on average. Since this is an average level, the 
chess engine might take more or less time per move. For example, after playing the first moves, the 
engine might take more than 10 seconds for a move because it was able to save some time during 
opening book play.

5 ply
The chess engine will always think 5 ply (half moves) deep.

Infinite
A level in which the chess engine will not stop thinking unless it is forced to move or it encounters 
checkmate. This can be useful if you want the chess engine to analyze a specific position for a long time. 
However, in that case selecting Analysis mode might be a more convenient method.

Custom levels
This activates the Custom level dialog. This dialog allows you to freely define any level. It is also possible 
to set different time controls for the computer and player.

Separate time control make it possible to compensate for differences in strength between a human player 
and the computer. You can, for example, set the computers level to 2 ply while, at the same time, you play 
with a time control of    5 minutes/game.

You can switch between different time control and same time control by pressing the respective button in 



the Custom level dialog.

Available time controls

Chessica offers a wide variety of time controls.

Tournament level
Standard time control where the player must make a certain number of moves within a fixed amount of 
time. After the required number of moves has been completed, the game normally continues with a 
different time control.

Rapid or speed chess
A time control whereby the complete game must be played within a certain fixed amount of time.

Fischer
A special time control invented by IGM Bobby Fischer. The complete game must be played within a 
fixed amount of time, but after each move is completed a certain amount of time is added to the clock. 
The Fischer time control reduces the risk of extreme time pressure during the last phase of the game.

Bronstein
A relatively new time control proposed by IGM Bronstein. This time control is based on the Fischer 
system but it deviates on one important aspect: the amount of time added to the clock is never more 
than the time used for the last move. This eliminates a side effect of the Fischer time control: both 
players can make null moves to collect more time on the clock.

Average search
The chess engine will, on average, use the set amount of time. However, depending on the position, 
the actual time used by the engine may vary considerably. This time control is only applicable for the 
chess engine.

Fixed depth
The chess engine will search up to a fixed ply depth. This depth is defined in ply (one move for white 
or black). Of course, this time control is only applicable for the chess engine. 



 New game

To start a new game, select New Game from the File menu or press  on the Toolbar.

If a game window is currently opened, Chessica will ask you to:
Create new frame

Create a new game window for the new game. Any existing games will remain unchanged.
Keep current frame

Start a new game in the current window. The game in the current window will be lost.

See also: Open game, Save game, Set up position, MDI.



 Open game

This chapter describes the extensive Open game dialog.

Open Game topics:
Open game dialog
Delete a game or collection

See also: Save game, Game collections.

____________________________________

Open game dialog
To open an existing game, select Open Game from the File menu. In addition to a standard open dialog, 
the Open Game dialog has two extra list boxes: the Collections list box and the Games list box. Chessica 
Games are stored in a game collection. Since a single game collection can hold many different chess 
games, these two list boxes display extra information about the contents of the current collection.

Collections list box
Displays the long name of the game collections and all its subcollections. The name of the game 
collection is shown as the first entry of the list box. Subcollections are shown indented.

Games list box
Displays the games stored in the currently selected collection or subcollection. To open a game, select a 
name from this list box and press the Open button.



To open a game:
- Select the correct path from the Directories list box.
- Select a file from the File Names list box.
- Select a collection name form the Collections list box.
- Select a game from the Games list box.
- Press the Open button or double-click on the game name to open the game.

Delete game or collection
To delete a game or collection, select the item to delete, even if it is already selected, and press the 
delete button. You will be asked to confirm the delete operation.
The Delete button is available in both the Open game dialog and the Save game dialog.



 Open next game

This option opens the next game from the active collection in the current game window.
Using this option, you can easily browse through all games in a collection. If the end of a collection is 
reached, Open next game will optionally open the first game of a collection.
Before you can use Open next game, you must previously have opened a game from a collection using 
the Open game.

Note: Open next game will replace the current game without warning!

See also: New game, Open game.



 Save game

This chapter describes the Save game dialog.

Save Game topics:
Save game dialog
Delete game or collection
Rename game or collection
Create new collection

See also: Open game, Game collections.

____________________________________

Save game dialog
To save the current game select Save Game from the File menu. The Save Game dialog will appear with 
two special list boxes: the Collections list box and the Games list box. For more information about these 
list boxes refer to the Open game dialog topic and the topic about Game collections.

To save a new game:
- Make sure you have selected a collection (there should be an entry in the Collections list box).
- Type a name at the Descriptive Name edit control.
- Press the Save button to save the game.

To overwrite an existing game, select its name from the Games list box and press the Save button. You 
will be asked to confirm the overwrite action.

Rename game or collection
To rename a game or collection, press the Rename button. You can enter up to 31 characters for the new 
name. This option cannot be used to change the DOS filename of the collection disk file. To rename a 
disk file use a method described in your DOS or Windows manual.

Create new collection
To create a new collection, press the New button. You can enter up to 31 characters for the descriptive 
name.
If a new collection is created, a unique DOS filename will automatically be assigned to the collection disk 
file.





 Duplicate game

Duplicate game creates a new game window and copies the current game to this window.

This can be very useful if you want to analyze a game without changing it.

See also: New game, Open game.



 Set up position

The set up mode can be used to enter a new starting position for a game.

Select Set up Position from the File menu or    press  on the Toolbar to enter the set up mode.

Set up topics:
Modifying the chessboard
Set up buttons
Castling flags

See also: New game

____________________________________

Modifying the chessboard

Adding a Piece
To add a piece to the position select the piece button and use the selected piece as a stamp.
Stamping twice on the same square will remove the piece from the square.
To remove the stamp, click outside the board on the dialog background.

Removing a piece
You can remove a piece by simply dragging it outside the board and then releasing the button.
Note: If you are using a stamp, you must first remove the stamp by clicking outside the board.

Moving a Piece
A piece can be moved on the board by dragging it from one square to another.
Note: If you are using a stamp, you must first remove the stamp by clicking outside the board.

Set up buttons

Clear
Clear the position on the chessboard.

Original
Restore the position as on the board when the Set up mode was entered.

Initial
Put the initial position for the chess game on the board.

Undo
Undo the previous action on the board.

Castling flags
These check boxes determine whether or not castling is allowed:
0-0 King-side (short) castling allowed
0-0-0 Queen-side (long) castling allowed.
Note: If a certain type of castling is physically impossible, because a required chess piece is missing, the 

option will be disabled.





    Print game

Chessica allows the user to print the current game in many different ways. Print game supports fully 
configurable diagrams of the highest possible quality at any size, figurine notation and many more.

Print game topics:
Print game dialog
Text settings dialog
Preview window

See also: Print setup, Export game.

____________________________________

Print game dialog
To activate the Print game dialog, select Print Game from the File menu. The print game dialog allows 
the user to control the way in which the game is printed. Other settings, such as output device, paper size 
and page orientation, can be controlled from Print Setup

Text
Use figurines

Enable figurines in move notation. If this option is disabled, the characters defined in the Text 
settings dialog will be used.

Options...
This button activates the Text settings dialog.

Title
The title of the game which will be printed at the top of each page.

Print options
Controls which items are to be be printed.
To print a diagram at a certain move, add at @ as the first character of the move comment. Refer to 
Movelist view for more information regarding move comment.

Diagram
Diagram size

Controls the size of the diagram. Normally, a value of 200 equals 2 inches.
Hatch lines

The number of hatch lines used in each black square.
Line width

Controls the relative thickness of the hatch lines.
Strict hatching

Favor hatching accuracy over diagram size. If this option is enabled, the diagram size might be 
adjusted to assure accurate hatching.

Preview
Enables the print Preview window. If the print preview window is already opened, its contents will be 
updated.

Text settings dialog
With this dialog the user can control the text settings such as justification and move notation. Print game 
and Export game share the same dialog. Therefore changes made in this dialog will influence both Print 



game and Export game.

Layout
Controls the justification of the printed moves. 

Moves
Short notation

Use short (abbreviated) notation instead of long notation. For example: Nf3 instead of Ng1-f3.
Piece characters

Controls which characters will be used to indicate the chess pieces. The standard setting is 
NBRQK which means N for knight, B for bishop, R for Rook, Q for Queen and K for King.

Symbols
Controls which symbols are used to indicate check, castling, en passant, etc.

Preview window
The preview window gives an impression of the game as it will be printed by the output device. Since the 
printer resolution and metrics normally differ from the screen resolution and metrics, the preview should 
not be seen as an exact representation of the result on the printer.
When the Preview window is active, you can press the <Page-Up> and <Page-Down> keys to flip through 
the different pages.





 Print setup

Print setup is a standard Windows dialog that allows the user to configure the printer for a specific 
application.

Print setup topics:
Print setup dialog

See also: Print game

____________________________________

Print setup dialog

Printer
Selects the output device to be used by Print game.

Orientation
Selects the page orientation used by Print game.

Paper
Selects the paper size and paper source used by Print game.

Options...
Activates the printer specific printer settings dialog.



 Export game

Export game will save the current game in a readable text format. This option is usesful if you want to use 
the game notation in a word processor.
It can also be used to exchange the game notation with another chess program or chess database that 
supports text import.

Export game topics:
Export game dialog
Export settings dialog

See also: Print game

____________________________________

Export game dialog
To activate the Export game dialog, select Export game from the File menu.

Export file type
ASCII (DOS) Text

Selects the ASCII character map.
The ASCII character map uses a different location for some characters (especially language 
specific characters like é, ä and ö). Selecting the incorrect mapping might give unwanted results for 
some player names etc.

ANSI (Windows) Text
Selects the ANSI character map.

Settings
Activates the Export settings dialog.

Export settings dialog
With this dialog the user can control the export settings such as line width and move notation. Print game 
and Export game share the same dialog. Therefore, changes made in this dialog will influence both Print 
game and Export game.

Layout
Controls the position of the line break. If the length of a line exceeds the given length, Export game 
inserts a line break character and continues on the next line. You might want to disable the line break 
option if your exported game will be used in a word processor.

Moves
Short notation

Use short (abbreviated) notation instead of long notation. For example: Nf3 instead of Ng1-f3.
Piece characters

Controls which characters will be used to indicate the chess pieces. The standard setting is 
NBRQK which means N for knight, B for bishop, R for Rook, Q for Queen and K for King.

Symbols
Controls which symbols are used to indicate check, castling, en passant, etc.





 Views

Each game window contains one or more child windows that display game information in a specific 
format. These child windows are called views. You can easily recognize a view by its miniature caption 
bar.

Available views:
Book view
Board view
Clocks view
Variation view
Movelist view
Game Info view
Preview Board view

See also: View settings.

____________________________________

Book view
The Book view displays the available opening book moves. 

The opening book can be controlled by selecting Opening Book from the Engine menu.
The layout of the Book view can be controlled by the Book sub menu from the Settings menu.

If opening book moves are available, the chess engine will automatically choose a move from the opening 
book.

You can also play a move from the opening book by double-clicking on it.

A dot next to the move indicates the frequency. The bigger the dot, the more often the move is selected 
by the chess engine. A move without a frequency dot is never played by the chess engine.

Board view
The Board view shows the current position.

The Board view can be configured by the Board sub menu from the Settings menu.
You can add coordinates to the Board view by selecting Preferences from the File menu.

You can easily adjust the size of the Board view using the mouse. The Board view    will automatically 
choose the closest matching chess set.
You can also select the True Type piece set if you want a different aspect ratio between the horizontal and 
vertical size of the chessboard.

Clocks view
The Clocks view shows the chess clocks.

The Clocks view can be configured using the Clocks sub menu from the Settings menu.

Variation view



The Variation view displays the moves the chess engine is considering.

The layout of this view can be controlled by the Variation sub menu from the Settings menu.

Above, part of the Variation view is displayed. The current line reflects the variation currently under 
consideration by the chess engine. The line, directly above the current line is called the main line. The 
main line represents the best result so far. If the chess engine stops thinking, it will play the move shown 
in the main line. The variation view also shows the previous main lines.

1. The current move number under consideration.
2. Total number of moves possible in the current position.
3. Number of positions evaluated by the engine.
4. Time used from start of search.
5. Brute force search depth in ply.
6. Selective search depth in ply (half moves).
7. Evaluation of the current position in pawn units. A value of 1.00 means the engine is about one 

pawn up, a value of    -1.00 means the engine is about one pawn behind. 
8. The actual move variation. The variation represents the optimal move sequence as calculated by 

the chess engine.

Moves made by the user will be printed in blue. Move played by the opening Book or by the chess engine 
will be printed in red. Lines produced by the chess engine during anticipating will be printed in white.

If you select a move in one of the main lines, the Preview Board will automatically show the position after 
this move is played.

Game Info view
The Game Info view controls the game information such as player names, etc. To edit any of the fields of 
the Game Info view click on the edit box or use the drop down list box.

Movelist view
The Movelist view displays the move notation of the game and the move comment.

The layout of this view can be controlled by the Movelist sub menu from the Settings menu.

At the bottom of the Movelist view, move comment is displayed. To edit the move comment, click on the 
edit box. If the first character of the move comment is a @, Print game will print a diagram at this move 
number.



Preview Board
The Preview Board is a separate chessboard window that can be used when replaying the moves in the 
Variation view.
When a move in one of the    main lines is selected, the Preview Board shows the position after the move 
is played. This can be very handy when analyzing the move lines produced by the chess engine.

When the chess engine is thinking and new move lines arrive, the Preview Board will automatically be 
updated and show the position after the move line is played.



 View settings

The Settings menu contains the options that influence the views.

The settings of a specific view can also be adjusted by clicking with the right mouse button on the title bar 
of a view.

See also: Views

____________________________________

Board
Size

Choose the size of the chessboard from a list of five available sizes.
Rotate

Rotate the chessboard ont the screen 180 degrees.
True Type Pieces

Use a scalable True Type chess set instead of the normal bitmap chess set. While, the True Type 
chess set might not be as attractive as the bitmap chess set, it allows a fully scalable chessboard 
which might be useful if the vertical and horizontal aspect ratio of your screen differ.

Clocks
Analogue

Toggle between the digital and analogue chess clocks.

Movelist
Short Notation

Show the moves in the Movelist view in short (abbreviated) notation.
Figurines

Use graphical figurines instead of plain characters to indicate the chess pieces in the notation.
Move Time

Show two extra columns next to the moves indicating the time used for each move.
Comment

Toggle the Move comment edit control.

Book
Short Notation

Show the moves in the Board view in short (abbreviated) notation.
Figurines

Use graphical figurines instead of plain characters to indicate the chess pieces in the notation.

Variation
Short Notation

Show the moves in the Variation view in short (abbreviated) notation.
Figurines

Use graphical figurines instead of plain characters to indicate the chess pieces in the notation.
Evaluation

Toggle display of the evaluation in the move lines.
Depth

Toggle display of the depth in the move lines.
Time Used

Toggle display of the time used in the move lines.
Positions Seen

Toggle display of the number of positions seen in the move lines.



Mode Index
Toggle display of the move index in the move lines.

Current Line
Toggle display of the Current line.

Preview Board
Always on Top

Determines whether this view should always stay in front of other views.



    Engine settings

These settings control the chess engine.

Engine settings topics:
Anticipating
Opening Book
Learn Mode
Beginner Mode
Brute Force
Hash Table

See also: Find Checkmate

____________________________________

Anticipating
Controls whether the chess engine uses its opponents time to think ahead. When this option is enabled, 
Chessica plays better.

Opening Book
Controls the opening book. Like a human chess player, Chessica has knowledge about standard 
openings. The standard opening information used by the chess engine is stored in a file called an opening 
book. The opening book helps Chessica play a better, more varied game.

None
Disable the opening book.

Standard
Select the standard opening book. This standard book contains a wide range of standard chess 
openings.

Tournament
Select the tournament book. This opening book was especially designed for the chess engine. 
Chessica plays better when the tournament book is selected.

Learn Mode
When the learn mode is enabled, the chess engine will store its search results in a permanent disk file for 
future reference. Chessica plays more varied when this option is enabled.

Beginner Mode
Chessica plays considerably weaker when the beginner mode is activated.

Brute Force
The brute force option influences the search process of the chess engine. Normally, the chess engine 
only considers the moves which it considers interesting. When the brute force option is activated, the 
chess engine will consider all legal moves.
Enabling brute force can give surprising results in some positions.



Hash Table
The chess engine uses a special table to store its evaluations during the search. After the chess engine 
has evaluated (judged) a certain position, the position, together with the evaluation, is stored in the hash 
table. The next time the chess engine encounters the same position, it can skip the time consuming 
evaluation process and use the value stored in the hash table directly.
The hash table can increase the search speed of the chess engine significantly, especially in end-games.

Note: Normally a larger hash table will give better results. However, do not make the hash table larger 
than the available    physical memory. If you have the Windows virtual memory option enabled and 
the selected hash table does not fit in physical memory, Windows will swap part of the hash table to 
disk. Since this is    very slow and the chess engine accesses the complete hash table many times 
per second, this will result in an extremely slow performance. If this happens, reduce the hash table 
size.



 Preferences

The Preferences dialog controls the global settings. To activate the Preferences dialog, select 
Preferences from the File menu.

See also: View settings, Engine settings, Level settings.

____________________________________

Text Font
Activates a font selection dialog from which you can select the font typeface and size. This font will be 
used in the views for all non move texts.

Moves Font
Activates a font selection dialog from which you can select the font typeface and size. This font will be 
used in the views for the moves.

Colors
Activates a color selection dialog from which you can select the colors that will be used in the views.

Warning Sound
A system beep will sound when an illegal move is made or whenever the computer makes a move.

Animation Speed
Sets the piece animation. The value must be in the range 1 to 9 were 1 selects the slowest animation.

Piece characters
Determine the characters that will be used to indicate the chess pieces for the moves notation in the 
Book, Variation and Moves view. These piece characters are only visible if the Figurines option for the 
view is disabled.

Auto Arrange Views
When this option is selected, Chessica automatically rearranges the position and size of the views 
whenever the game window is resized or a new layout is selected.



 Layouts

The Layout menu contains the options that influence the layout of the game window. A layout determines 
whether views are visible or not, their size and position and also the settings as found in the Settings 
menu.

Layout topics:
Predefined layouts
Custom layout

See also: Preferences, View Settings

____________________________________

Predefined layouts
The layout menu lists several predefined layouts. Some layouts are suited for game play, others are more 
suited for analysis. You are free to change the layout at any moment.
The standard layouts Play, Replay, Review, Analysis and Big Chessboard do not adjust the size of the 
game window. Therefore, you might need to maximize the game window after selecting one of these 
layouts.
The small layouts Small Play, Small Replay and Small Analysis automatically adjust the size of the game 
window for an optimal fit.

Custom layout
Besides the predefined layouts, you can also define your own, custom layout. Arrange the views anyway 
you like them and select Save from the Custom menu item. Next time you select Load from the Custom 
this layout will be restored.



 SmartBoard

Chessica supports the SmartBoard. The Tasc SmartBoard is a high quality wooden chessboard that can 
be connected to the PC. Its dimensions are 420 mm x 420 mm x 24mm and every square has an LED 
(small lamp) which is used to indicate the computers move. Since the SmartBoard features true piece 
recognition (it detects which piece is on which square), playing on the SmartBoard is very convenient. 
You can also take back moves and start a new game without touching your computer.
For more information about the SmartBoard contact your dealer or contact TASC directly for the address 
of your nearest SmartBoard dealer. Refer to About in the Help menu for more information about how to 
contact us.

To activate the SmartBoard select SmartBoard from the    File menu or press  on the Toolbar. This will 
link the SmartBoard to the active game.

If the SmartBoard is not automatically detected a dialog will appear asking you to select the port to which 
the SmartBoard is connected. If Chessica does not detect the SmartBoard, even after selecting the 
correct port, you should refer to the installation instructions that came with the SmartBoard for more help 
on configuring the SmartBoard. Once the correct configuration has been detected, Chessica will 
automatically store the information in its configuration file.

As soon as the SmartBoard is activated a floating SmartBoard window will appear automatically. This 
window will always show the position as it is read from the SmartBoard. The SmartBoard is linked with 
only one game window at a time.

To avoid conflicts, the SmartBoard will automatically be de-activated if you change the current position of 
the SmartBoard game using the mouse or keyboard. In this case you can simply press the SmartBoard 
button to re-activate the SmartBoard.



 Troubleshooting

This chapter contains troubleshooting information.

____________________________________

Performance of the chess engine is extremely low
The size of the Hash Table is probably too large. Reduce the hash table size to the minimal value by 
selecting Hash Table from the Engine menu. Is the hash table is larger than the available physical 
memory, Windows will swap memory to disk. This can bring the chess engine to a virtual standstill. Of 
course, every application uses memory, so minimizing the number of active application will increase the 
memory available for the hash table.

Chessica does not start due to missing file
Besides the files in the Chessica home directory (normally C:\CHESSICA), Chessica needs a standard 
Windows library called WINMEM32.DLL. This file is not included with all versions of Windows. If required, 
the Chessica installation program will automatically add this file to your version of Windows. However, if 
you have upgraded or re-installed Windows on your computer, this file might be missing. In this case, 
Windows will report The file ..\CHESSICA.EXE (or one of its components) could not be found. If this 
happens, you must run the Chessica Installation program to re-install this file.

Windows reports a fatal error or crashes
Some older video drivers are not be compatible with Chessica. Contact your computer dealer to obtain 
the latest version or use the standard VGA or Super VGA video driver included with Windows.

Result on printer not as expected
If the printer output is garbled, you might have exceeded the printer (memory) capacity. In this case, 
reducing the size of the diagram can solve the problem. It might also help if you change the printer mode 
on the printer settings dialog. You can activate the printer settings dialog by pressing the Options button 
in the Print Setup dialog.

Chessica does not respond as expected
If Chessica, for some reason, does not respond the way you would expect it to, you might have changed 
settings you were unaware of. In this case, you can select Restore Factory Settings from the File menu 
to restore Chessica to its predefined state.



    Glossary



Chess engine
The part of Chessica that calculates the chess moves.



Collection
A disk file (with the extension .GAM) containing one or more chess games.



Current line
Move variation, generated by the chess engine, that shows the current thinking status of the chess 
engine.



Main line
Move variation, generated by the chess engine, that shows the best search result so far.



Subcollection
A subcollection is a collection within a collection. Subcollections can be nested several levels deep.



Toolbar
A button bar displayed at the top of    the main Chessica window with buttons for commonly used actions. 
The Toolbar also has a slider with which you can quickly walk through a game.



User interface
The part of Chessica that handles the user interaction.



View
Child window within a game window, displaying game information. Views can be recognized by their 
miniature caption bar.






