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Welcome to the Adobe PageMaker 6.5 Tryout

dobe PageMaker 6.5 gives you the tools and

the power to create professional publica-

tions on the desktop. You can use

PageMaker to create virtually any type of publica-

tion, from newsletters and brochures to color cata-

logs and magazines to interactive pages on the

World Wide Web. Whether you are a beginner con-

structing your first newsletter, or an experienced art

director or designer, the layout and design tools in

PageMaker give you professional results.

About the Tryout
The Adobe PageMaker 6.5 Tryout version demon-

strates most of the extensive capabilities of

PageMaker 6.5. You’ll see enough of the retail ver-

sion features to give you a good idea of how

PageMaker works. The Tryout version is for dem-

onstration purposes only. In some instances, com-

ponents of the retail version have been left out. In

other cases, capability has been altered.

To find out about the full capabilities of the retail

version of PageMaker 6.5, review the facts and fea-

tures brochure in the Tryout folder. In Windows,

the file is called PM65Broch.pdf. On the Macintosh,

the file is called PM65 Brochure.pdf.

Stand-alone applications

The following applications are not included with the

Tryout version:

• Adobe Distiller, used to create PDF files in

PageMaker

• Adobe Table 3.0, a versatile table editor for use in

PageMaker

A • Dictionary Editor, for creating new user dictio-

naries, importing word lists, and revising spelling

and hyphenation in PageMaker

• Quark Converter, for converting QuarkXPress

documents into PageMaker documents

Plug-ins

The following plug-ins are not included with the

Tryout version:

• Build Booklet

• Export Adobe PDF

• HTML Export

• HTML Import

• ODBC (Open Database Connectivity) Import

• PageMaker 4.0-5.0 Publication Converter

• Photoshop Effects, with the exception of Water-

color and Glowing Edges

• Save for Service Provider

Color libraries and color management

Crayon and Greys are the only color libraries in-

cluded in the Tryout version.

While the Kodak Color Management System is in-

cluded in the Tryout version, the Gamma Control

Panel (used to calibrate the monitor) is not.

Scripts and templates

PageMaker 6.5 includes some 70 scripts in the

Scripts palette. A number of these scripts create tem-

plates which you can use to build publications. Only
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five scripts are included in the Tryout version:

Nested Group, Nested Ungroup, Merge Frame

Story, Split Frame Story, and a calendar template.

Filters

A subset of PageMaker 6.5 filters is included in the

Tryout version. Text filters include Word, RTF, and

Text Only. Graphic filters include WMF, PICT,

TIFF, GIF, JPEG, and EPS.

Publication size

The maximum number of pages per new publication

is 10 pages in the Tryout version.

Printing

Any page printed to a printer device, or output as a

PostScript or PDF file, includes a band across the

center of the page reading “Adobe PageMaker 6.5.”

You can print only one copy of a publication each

time you print.

Saving and exporting

You cannot save or export Tryout publications be-

cause the Save, Save As, and Export commands are

disabled.

Online Help

The Tryout includes a comprehensive online Help

file that documents all the features of the retail ver-

sion of PageMaker 6.5, including keyboard short-

cuts. The Tryout does not include the Script

Language Guide online Help file.

Online license agreement

An online license agreement appears when you in-

stall the Adobe PageMaker Tryout version.

Personalization and serial number

No personalization setup is required during the in-

stall.

Installing the Tryout on Microsoft
Windows 95 and Windows NT 4.0
Although this document covers installation for Win-

dows and Macintosh platforms, the Tryout includes

a version for either Windows or Macintosh, but not

both.

You must install the Tryout onto your hard drive;

you cannot run the application from a CD-ROM

drive. For Windows installations, all files are in-

stalled on your hard drive in a folder named

PM65Try, with the exception of files relevant to

ATM, TWAIN, and OLE, which are installed in the

Windows folder.

The Tryout is for single users only; multiple users

cannot run the Adobe PageMaker Tryout from an

application installed on a network server.

Note: The retail version of Adobe PageMaker 6.5 for
Windows supports multiple users running from a single
application installed on a network server.

System requirements

To use the Adobe PageMaker 6.5 Tryout in Win-

dows, you need the following:

• An Intel486 processor with a minimum of 8

megabytes (MB) of application random-access

memory (RAM) for Windows 95, and 16 MB of

RAM for Windows NT 4.0

• Microsoft Windows 95 or Windows NT 4.0

Workstation operation system

• 26 MB space available on your hard drive for

minimum installation

• VGA display card

Note: The recommended PageMaker memory require-
ments are in addition to the memory required by your
system software.

For best performance, Adobe Systems recommends

the following hardware and software:

• Pentium or greater processor
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• 24 MB or more of RAM installed

• 63 MB available hard drive space for a typical in-

stallation, plus 12 MB for temporary space needed

during the installation process

• High-resolution video display card (24-bit or

greater Super VGA)

To install the Tryout onto your hard drive:

1 Exit all programs, and turn off virus-detection and

screen-saver software on your computer. This frees

up memory for installation and prevents possible

conflicts between the PageMaker 6.5 installer and

other programs.

2 Open the PM65Try folder, and then double-click

the Setup icon.

Note: Personalization information and serial number are
not required for installation of the Tryout.

3 Click Next and follow the on-screen instructions

until installation is complete, and then click OK.

Installing the Tryout on the
Macintosh
Although this document covers installation for Win-

dows and Macintosh platforms, the Tryout includes

a version for either Windows or Macintosh, but not

both.

You must install the Adobe PageMaker Tryout onto

your hard drive; you cannot run PageMaker from a

CD-ROM drive. For the Macintosh, all files are in-

stalled in a folder named Adobe PageMaker 6.5 Try-

out, with the exception of files related to TWAIN,

Microsoft OLE files, and PANOSE numbers, which

are installed in specific locations in the System

folder.

The Tryout is for single users only; multiple users

cannot run the Adobe PageMaker Tryout from an

application installed on a network server.

The Tryout has been optimized for both Macintosh

and Power Macintosh. The installer will automati-

cally install the correct version on your computer.

System requirements

To use the Adobe PageMaker 6.5 Tryout on the

Macintosh, you need the following:

• An Apple Macintosh computer with a 68030 pro-

cessor (or greater) with a minimum of 6 MB of ap-

plication RAM, or a Power Macintosh with a

minimum of 9 MB of application RAM (Application

memory is the amount of memory left over after the

system has started.)

• 26 MB available hard drive space for minimum

installation

• Apple system software version 7.1 or later

Note: PageMaker memory requirements are in addition
to the memory required by your system software.

For best performance, Adobe Systems recommends

the following hardware and software:

• A PowerPC™ processor

• Apple system software 7.5.3 or later

• A high-resolution video display card (24-bit dis-

play)

• 12 MB or more of RAM available to PageMaker

• A PostScript® printer

To install the Tryout onto your hard drive:

1 Quit all programs and restart your computer with

only system extensions and those extensions re-

quired by your CD-ROM drive. (If you have System

7.5 or later, you can open the Extensions Manager

Control Panel, select the appropriate System option

from the Sets pop-up menu, and then restart your

computer.)

This step frees up memory for installation and pre-

vents possible conflicts between the PageMaker 6.5

installer and other programs or extensions. You will

be required to restart your computer after installa-

tion.

2 Open the Adobe PageMaker 6.5 Tryout folder and

double-click the Install PageMaker 6.5 Tryout icon.

Note: Personalization information and serial number are
not required for installation of the Tryout.
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3 Click Continue and follow the on-screen

instructions until installation is complete, and then

click OK to restart your computer.

Starting Adobe PageMaker
Depending on the system software you are using, do

one of the following:

• In Windows, choose Adobe PageMaker 6.5 Try-

out from the Start > Programs > Adobe PageMaker

6.5 menu.

• On the Macintosh, double-click the Adobe

PageMaker 6.5 Tryout icon in the Adobe PageMaker

6.5 Tryout folder. When the PageMaker startup

screen appears, you are ready to open or create a

publication and begin working.

Removing the Adobe PageMaker
6.5 Tryout from your hard drive
Be sure to delete the Tryout from your hard drive be-

fore installing the retail version of PageMaker 6.5. If

you have both the Tryout and the retail version in-

stalled on your machine, and you double-click to

open a publication, the Tryout launches.

In Windows, the Uninstall feature lets you remove

all folders and files installed on your hard drive by

the PageMaker installer.

To uninstall the Adobe PageMaker Tryout in
Windows:

1 Exit  the Adobe PageMaker Tryout.

2 In Windows, choose Start > Settings > Control

Panel, and then double-click the Add/Remove Pro-

gram option.

3 Select an option in the list box at the bottom of the

dialog box, and then click Add/Remove.

4 Follow the on-screen instructions until the Adobe

PageMaker Tryout application files are removed.

5 Restart Windows.

To remove the Adobe PageMaker Tryout from a
Macintosh:

1 Quit the Adobe PageMaker Tryout.

2 Drag the Adobe PageMaker Tryout folder to the

Trash.

3 If you don’t plan to install the retail version of

PageMaker 6.5, you may want to remove unwanted

files from your System folder relating to TWAIN,

Microsoft OLE, PANOSE, and ColorSync.

Technical support
Since the Tryout is for demonstration purposes

only, you don’t receive complimentary support

from Adobe technical support staff. However, auto-

mated technical information is available free of

charge, 24 hours a day, 7 days a week, through the

following sources:

• The Adobe home page on the World Wide Web

(http://www.adobe.com)

• Forums on CompuServe (GO ADOBEAPP) and

America Online (keyword: Adobe); forums and

availability may vary by country

• FaxYI, a fax-based service that provides the latest

technical information about Adobe products and

services (call 1-206-628-5737)

• Adobe’s bulletin board system, available by mo-

dem at 1-206-623-6984

• E-mail at techdocs@adobe.com; in the subject

line, type 100099 to receive an index of technical

documents available via e-mail
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Adobe PageMaker 6.5 Tutorial

he best way to learn PageMaker is to

try it yourself. This chapter is a tutorial that

guides you through some basic PageMaker

skills as you create and print a letterhead and bro-

chure for the fictitious company Earth & Ware, a

garden center.

This tutorial, which was originally printed in the

Adobe PageMaker 6.5 User Guide, uses some com-

mands that are disabled in the Tryout, such as Save

and Save As, and contains cross-references to topics

and chapters in the user guide. None of this should

hinder your successful completion of the tutorial les-

sons.

You’ll learn how to:

• Set up page and printer options and position ruler

guides.

• Create a template.

• Type and format text, and define text styles.

• Set indents and tabs.

• Work with threaded text blocks.

• Resize, move, and rotate objects.

• Place text and graphics from other applications.

• Print a PageMaker publication.

This tutorial assumes that you have a working

knowledge of your computer hardware and

operating system—Windows 95, Windows NT, or

Macintosh System 7.1 or later—and that you have

successfully installed PageMaker 6.5.

If your screen doesn’t match our
samples

The fonts in our sample illustrations may differ

slightly from those that appear on your screen. This

means that the fonts and printers we used to create

this book differ from yours. In most cases, the dif-

ferences are insignificant. Your results depend on

several factors:

• The screen and printer fonts you have installed.

• Whether or not you use a type-management pro-

gram.

• The printer you choose.

The practice publications in this book are designed

for either US letter-size paper or international A-4

paper. Instructions apply to both document sizes.

We have provided approximate metric equivalents

for inch measurements.

T
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Starting a new publication
When you start a new publication, you first

establish the characteristics of the publication pages

(size, orientation, and margins), whether it will be

printed on one side or two, and the printer you’ll use

for the final version of your publication.

1 Launch PageMaker 6.5. When the PageMaker

opening screen disappears, you’ll see an empty appli-

cation window.

2 Choose New from the File menu (File > New).

The Document Setup dialog box appears with

PageMaker’s default settings, which you will change

in the next few steps.

3 Deselect the Double-sided option.

4 Click in the margin text boxes and set these mar-

gins:

• Left: 2.25 inches (57mm)

• Right: 1 inch (25mm)

• Top: 2.75 inches (70mm)

• Bottom: 1.5 inches (38mm)

5 In Windows, use the Compose to Printer

option to select the printer you plan to use for the fi-

nal version of your publication. (This may not be the

desktop printer you’ll use to print drafts or proofs.)

6 Set the Target Printer Resolution to match

the printer you’ll use to print the final copy of your

publication. PageMaker uses this resolution to cor-

rectly scale bitmap images when you resize them us-

ing magic stretch. See “Resizing 1-Bit Bitmap Im-

ages” on page 199 for more information.

7 Click OK.

You will see an untitled publication window con-

taining the pasteboard and a letter-size,

vertical page.

Publication

page

Pasteboard

Toolbox

Positioning ruler guides
PageMaker provides nonprinting guides to help you

align and position objects on the page. The page al-

ready has margin guides—a dotted or colored rect-

angle that represents the page margins you specified

in the Document Setup dialog box. Now you’ll add

ruler guides to help position the logo and company

address for the letterhead.

1 Make sure a checkmark appears beside the Snap

to Rulers command on the View menu.
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When Snap to Rulers is selected, PageMaker pulls

the pointer into line with each tick mark on the ruler

when you create your guides. This ensures exact

placement of the ruler guides.

2 Press Command + Option and click in the upper

left corner of the page (Macintosh), or press Shift

and click using the right mouse button in the upper

left corner of the page (Windows).

This action centers your view in the upper left corner

of the page and changes the page display to the actual

size of the page, so you can place the ruler guides

precisely.

Magnified view of the upper
left corner of the page.

3 Position the pointer on the horizontal ruler

(which extends across the top of the publication win-

dow) and drag down to the 11⁄4-inch (3.2cm) mark

on the vertical ruler. A horizontal ruler guide ap-

pears.

When you click and drag the pointer changes to a
from here… two-way arrow until you

release the mouse button.

4 Use the scroll bars or the hand tool to move the

view to the lower left corner of the page.

5 Create three more ruler guides as follows:

• Drag a vertical guide to the 11⁄8-inch mark on the

horizontal ruler.

• Drag a vertical guide to the 21⁄4-inch mark on the

horizontal ruler.

• Drag a horizontal guide to the 93⁄4-inch mark on

the vertical ruler.

Drag first vertical guide

Drag second vertical guide

Drag horizontal guide 

6 Choose Lock Guides from the View menu (View

> Lock Guides).

When Lock Guides is selected, PageMaker locks the

ruler guides in place, so you can’t accidentally repo-

sition them.

Saving your work
Now that you’ve completed the layout grid, you’ll

want to save your work. It’s a good idea to save your

work often to avoid losing it in a power failure or

other disruption. PageMaker gives you two ways to

save your work: as a publication or as a template. A

template is a predesigned model for other publica-

tions.

In this exercise, we’ll show you how to save the let-

terhead you create as a template, so you can use a

copy of it to produce an actual letter.

1 Choose Save from the File menu to save your

work (File > Save).

The Save Publication As dialog box appears.



2 On the Macintosh, choose Template for the Save

As option. In Windows, choose Template from the

Save as Type pop-up menu.

Note: If you modify a template and want to save it as a
template under a different name, choose Save As from the
File menu and specify Template again. That’s because
PageMaker defaults to Publication when you save a file
under a new name.

3 In the PageMaker 6.5 folder on your hard drive,

open the Lesson1 folder of the Tutorial folder and

type the filename Letter into the text box.

4 Click OK (Macintosh) or Save (Windows).

On the Macintosh, PageMaker automatically uses a

template icon for your file, which you can view using

the Finder. In Windows, PageMaker automatically

adds a .T65 extension to the filename, which speci-

fies that the file is a template.

The Letter file contains a blank page with the

layout grid you created. In the next exercise, you add

text and graphics.

Typing text
For the letterhead you create here, you’ll type the ad-

dress of a fictitious garden center called Earth &

Ware. First, you’ll set the text defaults—the format-

ting that PageMaker applies to every new text block

you create.

If the master page icon (in the lower left corner of the

publication window) is black, you are working on

the master page, which contains basic design ele-

ments, such as page numbers, that are common to

most or all pages in your publication. Click the page

1 icon to turn to page 1.

1 Choose Character from the Type menu (Type >

Character) and change only what is indicated in the

illustration on this page. Then click OK.

When no text is selected and you change the

type specifications, you reset the default formatting

for all new text you type in the active publication.

Everything you type now appears in your chosen

font and size. You can override these new defaults

by selecting the text and changing it, or you can set

new defaults by choosing formatting options with

no text selected.

The font Helvetica is used in our sample illustrations.
If you’re working in Windows, you can substitute
Arial, which is similar to Helvetica.

2 Choose 200% Size from the Zoom To submenu

on the View menu (View > Zoom To > 200% Size).

3 Use the scroll bars or the hand tool to move to the

lower left corner of the page.

4 Select the text tool from the toolbox.

The pointer tool turns into an I-beam.

You are now ready to create a text block for the text

you’ll type.
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5 Position the tiny horizontal tick mark on the I-

beam at the intersection of the leftmost vertical guide

and the horizontal guide at the bottom of the page.

6 Drag the I-beam down and to the right until you

intersect the next vertical ruler guide, as shown

below, and then release the mouse button.

This creates a text block that controls the width of

the text.

Drag from here…

Blinking cursor indicates

the insertion point

for text you type

to here

7 Type the street address shown in the illustration

on this page for the Earth & Ware garden center,

pressing Return (Macintosh) or Enter (Windows)

after each line to create a new line.

If text wraps to the next line, select the pointer tool,

click on the text block, and then drag a right corner

handle to the right until the text fits on the line.

8 If your text block is not positioned as shown, select

the pointer tool, and click inside the text block to se-

lect it. Drag the block as necessary to align the text

within the margins as shown.

If a down arrow appears in the lower window-shade

handle, drag it down to reveal all the text in the

block. When the handle is empty, there is no addi-

tional text to reveal.

The top edge

aligns with the

horizontal guide

The right edge

aligns with the

vertical guide

Formatting text characters
The text you’ve typed so far is 7-point Helvetica with

10-point leading (the vertical spacing between two

lines of text). That’s because you previously se-

lected 7-point Helvetica as the default size and font

and 10-point as the default leading.

You can select any text in a publication and use

commands on the Type menu to apply formatting

that is different from the defaults. In this

exercise, you’ll practice formatting text.

1 Select the text tool and click anywhere in the text.

2 Choose Select All from the Edit menu to select all

the text you typed so far (Edit > Select All).

3 Choose 14 from the Leading submenu on the

Type menu (Type > Leading > 14). If 14 is not avail-

able, choose Other from the Leading menu, and

type 14 in the dialog box that appears.

Text with 10-point leading Text with 14-point leading
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Formatting paragraphs
Certain formatting decisions, such as alignment (cen-

tered or justified, for example), indents, and tab po-

sitions, apply to an entire paragraph. To format a

paragraph, you must use the text tool. You can for-

mat a single paragraph by either clicking three times

anywhere in the paragraph to select the paragraph or

clicking an insertion point anywhere in the para-

graph. PageMaker begins a new paragraph each time

you press Return (Macintosh) or Enter (Windows).

1 If the address is not already selected, select a por-

tion of all three paragraphs in the address by drag-

ging the text tool from the first line to the last line.

2 Choose Align Center from the Alignment sub-

menu on the Type menu (Type > Alignment > Align

Center).

Align Left Align Center

3 Choose Save from the File menu (File > Save) be-

fore proceeding.

If you like, you can spend a few minutes experiment-

ing with the text formatting commands on the Type

menu. For example, change the font and the size, or

try different type styles. When you’re done, choose

Revert from the File menu (File > Revert) to discard

all the changes you’ve made since you last saved your

work.

Drawing a box
Now you’ll draw a black box around the address to

add visual appeal.

1 Select the rectangle tool from the

toolbox.

When you move the pointer onto the page,

it becomes a crossbar.

2 Choose 1 pt from the Stroke submenu on the

Element menu (Element > Stroke > 1 pt).

A stroke is the thickness (or weight) of the border of

shapes you create—in this case, for the box you’re

about to draw.

By choosing formatting options from the

Element menu before you begin drawing, and with

nothing selected, you set the default formatting for

all new objects you add to your publication or tem-

plate. You can override the default formatting by se-

lecting an object and changing its formatting, or you

can set new defaults by choosing formatting options

with no object selected.

3 To draw the box, click the crossbar on the

intersection of the ruler guides at the upper

left corner of the text block, and then drag

to the lower right corner of the text block,

as shown below.

Drag from here…

to here
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If you align the box precisely with the ruler guides, it

may be difficult to distinguish the top and sides of

the box from the ruler guides. Choose Show Guides

from the View menu (View > Show Guides) to dis-

play the ruler guides; choose View > Hide Guides to

make them invisible.

Drawing lines
Now you’ll draw two horizontal lines in the box you

created to separate the lines of the address.

1 Select the constrained-line tool in

the toolbox.

2 Click the crossbar on the left side of the box be-

neath the first line of the address, and then drag it to

the right side of the box, as shown below. Repeat to

draw a line under the second line of the address.

Drag from here…

Repeat for second line

under city and state

to here

3 Choose Save from the File menu to save your work

(File > Save).

Placing a graphic
PageMaker offers a variety of ways to manage graph-

ics in your publication. In this exercise, you’ll place a

graphic from another application into your publica-

tion to use as a company logo.

In this exercise, you’ll place a company logo at the

top of the letterhead.

1 Select the pointer tool from the toolbox.

2 Choose Actual Size from the View menu (View >

Actual Size).

3 Use the scroll bars or the hand tool to move to the

upper left corner of the page.

Note: If ruler guides are hidden, choose Show Guides
from the View menu to display the ruler guides.

4 Choose Place from the File menu (File > Place).

Select the Logo.tif file from the Lesson1 folder of the

Tutorial folder (in the PageMaker 6.5 folder), and

then click OK (Macintosh) or Open (Windows).

5 Click near the top of the page to place the logo.

6 While the logo is still selected, position the

pointer tool over the center of the logo, click, and

drag it into alignment with the top and leftmost

ruler guides.

When you move an object, the cursor turns into an arrow.

For more information on placing and modifying a

graphic, see Chapter 11, “Importing, Linking, and

Exporting.”
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Resizing a graphic
In this exercise, you’ll resize the graphic you just

placed, maintaining its original proportions so that it

fits neatly between the two vertical ruler guides you

created earlier.

1 Using the pointer tool, select the graphic if it is not

already selected.

2 Hold down the Shift key, click the lower right

handle of the graphic, and drag it to the rightmost

vertical ruler guide.

Note: Pressing the Shift key while you drag ensures that
PageMaker maintains the proportions of the original
graphic as you resize it. You must release the mouse but-
ton before you release the Shift key for this to work.

While pressing the Shift key, and then line it up between
size the graphic… the two vertical rulers.

3 Choose Save from the File menu to save your work

(File > Save).

Congratulations on completing your first

PageMaker template! You have combined text and

graphics to create a simple letterhead for Earth &

Ware, a fictitious garden center. Now we’ll show you

an easy way to use the template. You’ll place a letter

on the page and turn a copy of your template into a

PageMaker publication.

Placing a letter on the letterhead
Keep your template open as you get ready to place a

text file on the letterhead page. Placing text is similar

to placing a graphic.

1 Choose Fit in Window from the View menu (View

> Fit in Window).

2 Select the pointer tool from the toolbox.

3 Choose Place from the File menu (File > Place).

4 In the Place Document dialog box, select the Text

file from the Lesson1 folder of the Tutorial folder (in

the PageMaker 6.5 folder), and then click OK

(Macintosh) or Open (Windows).

In Windows, click Open in the Import Filter

dialog box.

5 Position the loaded text icon as shown below and

click.

After the text flows onto the letterhead, it has win-

dowshade handles indicating that it is selected. If a

down arrow appears in the lower

windowshade handle, drag it down to reveal all the

text in the block. When the handle is empty, the text

block contains no additional text.

When you click the loaded the story flows onto
text icon here… the page.

6 Choose Save As from the File menu, and

then choose Publication as the Save As option

(Macintosh) or choose Publication from the Save As

Type pop-up menu (Windows).

7 Open the Lesson1 folder, type the file name Let-

ter1 into the dialog box, and then click OK

(Macintosh) or Save (Windows).

Printing the letterhead
You are now ready to print the letterhead

you created.

Macintosh Note: Be sure you select the PSPrinter 8.3.1
(or later) driver in the Chooser when printing to a
PostScript printer. See Chapter 12, “Printing Publica-
tions,” for more information.
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To print:

1 Choose Print from the File menu (File > Print) to

open the Print Document dialog box.

Settings for a PostScript printer

2 If you’re printing to a PostScript printer, select a

PPD option.

For more information see “PostScript Printer De-

scription Files” on page 394.

3 Click Print.

4 After the file has printed, choose Close from the

File menu (File > Close).

Creating a brochure
Now that you’ve learned some PageMaker funda-

mentals, we’ll guide you through additional tech-

niques that are essential to creating distinctive

publications. You’ll create a brochure for

the fictitious garden center, Earth & Ware, as you

learn how to:

• Work with master pages to provide a consistent

look for a publication.

• Create, import, rotate, and resize objects.

• Overlap text and graphics.

• Work with text in story editor.

• Work with multiple open publications.

• Print a publication.

Opening a template
PageMaker comes with several prebuilt templates

that include a page design, text styles, and text and

graphics placeholders to simplify your work.

Template for brochure

PageMaker templates offer two major benefits: they

provide a fast, easy way to create professionally de-

signed documents, and you can use them repeatedly

to establish a consistent design theme for publica-

tions. You can focus on the content of publications,

because the design decisions have already been

made.

We’ve provided a template for the brochure you’ll

create. From the template, you’ll create a new bro-

chure, adding text, a logo, and graphics.

The template has two pages. You will work only on

page 1 to create the brochure in this tutorial. After

you’ve finished, you can use page 2 to create your

own version of the brochure.

For more information on creating and using tem-

plates, see “Starting a Publication from a Template”

on page 23.

To open a template:

1 Choose Open from the File menu (File > Open).

2 In the Open Publication dialog box, select

the BrochUS file from the Lesson2 folder of the Tu-

torial folder (in the PageMaker 6.5 folder). If you
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will be printing on A4-size paper, select the

BrochINT file.

3 Click OK to open a copy of the file and begin.

An untitled publication window opens. Some of the

work has already been done for you: the margins are

set and several guides are positioned to create a de-

sign grid. Having a prebuilt grid is one advantage of

using a template.

Creating columns
Everything you see on the page is actually on

the master page. The master page contains design

elements common to every page in a publication.

Master pages provide a foundation for most publica-

tions that you create in PageMaker. They help estab-

lish a consistent look within and between

publications, and save you time.

For more information on using master pages,

see Chapter 3, “Constructing a Publication.”

You’ll modify this master page by adding column

guides, which you’ll use to position text.

Master page

Design elements on the master page appear on every page in the pub-
lication, but you can omit them from specific pages if needed.

Column guides are nonprinting vertical lines that let

you align text and graphics within the publication.

Creating column guides on the master page ensures

that the columns are identical throughout the publi-

cation. For this brochure, you’ll create four col-

umns.

TIP: PRESS COMMAND

+; (MACINTOSH) OR

CTRL +; (WINDOWS) TO

HIDE OR DISPLAY

GUIDES, INCLUDING

COLUMN GUIDES.

HIDE THEM WHEN YOU

WANT TO SEE APPROXI-

MATELY HOW THE

PRINTED PAGE WILL

LOOK. DISPLAY THEM

WHEN YOU NEED TO

POSITION AN ELEMENT.

To create columns:

1 Click the master page icon to move to the master

page.

2 Choose Column Guides from the Layout menu

(Layout > Column Guides).

3 Type 4 for Number of Columns, and then press

Tab or click in the Space Between Columns text box

and type .25 (.64cm).

4 Click OK to close the dialog box.

Column guides appear, dividing your page into four

equal columns.

The brochure, after you create columns.



18ADOBE PAGEMAKER 6.5 TRYOUT
Tutorial

and TIFF are often your best choices on both the

Macintosh and in Windows, although you should

avoid EPS if you’re printing to a non-PostScript

printer.

The brochure, after you place the graphics

The next step is to place one TIFF graphic on the

right side of the page and a smaller TIFF graphic on

the left side of the page.

1 Make sure Snap to Guides on the View menu is

selected (View > Snap to Guides).

The Snap to Guides option helps you align

objects with the guides and rulers. When you cre-

ate, place, or move an object, PageMaker pulls it

into line with the nearest guide.

2 Choose Place from the File menu (File > Place),

select the Flowers.tif file from the Lesson2 folder of

the Tutorial folder, and then click OK (Macintosh)

or Open (Windows).

3 Position the loaded icon as shown on the next

page, and then click at the intersection of the 17⁄8-

inch (4.5cm) horizontal guide and the left edge of

the third column to place the graphic.

5 Click the page 1 icon to return to page 1, where

you’ll be doing your work in this tutorial.

6 If you don’t see the column guides on page 1,

choose Copy Master Guides from the Layout menu

(Layout > Copy Master Guides).

For more information on using column guides, see

Chapter 3, “Constructing a Publication.”

Saving your work
It’s a good idea to save your work now, before you go

any further.

1 Choose Save from the File menu (File >

Save).

2 Open the Lesson2 folder of the Tutorial folder,

click in the text box, and type Brochure for the file

name.

3 Select Publication as the Save As option, and then

click OK (Macintosh) or Save (Windows).

Placing graphics
PageMaker lets you import graphics in a variety of

formats, including WMF (Windows metafile), EMF

(enhanced metafile), BMP (Windows bitmap), GIF,

PICT, TIFF, and EPS (encapsulated PostScript). EPS
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If the upper left corner of the graphic is not

positioned as shown here, click the pointer on the

graphic and drag the graphic into position.

The upper left corner

of the graphic should

be positioned here

4 Choose Place from the File menu (File > Place),

select the Bouquet.tif file from the Lesson2 folder in

the Tutorial folder, and then click OK (Macintosh)

or Open (Windows).

5 Position the loaded icon as shown, and then click

at the intersection of the 51⁄4-inch (13.3cm) horizon-

tal guide and the left margin.

Creating and styling a heading
Now you’ll create a text block in which you’ll type

the heading for the brochure. You’ll position the

heading to span the first three columns.

The brochure, after you add a heading

1 Select the text tool and position the I-beam at the

intersection of the top and left margin guides.

2 Drag the I-beam diagonally to define the text

block. Drag from the 1-inch (2.5cm) mark on the

horizontal ruler over to the right edge of the third

column and down to the 11⁄4 inch (3.2cm) mark on

the vertical ruler.

When you release the mouse button, you will see a

blinking cursor at your starting position.

3 Type FLOWERS.

Note: You might want to change the view by choosing
75% Size from the Zoom To submenu on the View menu.

4 If FLOWERS is not already highlighted, select the

text tool and double-click the word FLOWERS to

select it.

5 Choose Force Justify from the Alignment sub-

menu on the Type menu (Type > Alignment >

Force Justify).

This distributes the characters evenly over the width

of the text block.

6 Choose Character from the Type menu (Type >

Character), and set type attributes to match those in

the Character Specifications dialog box shown here.

If Helvetica is not available, choose Arial (Windows)
or another font.



20ADOBE PAGEMAKER 6.5 TRYOUT
Tutorial

7 Click OK to close the dialog box.

You may need to adjust the position of the

heading or the width of the text block to match the

illustration below. Use the pointer tool to select the

text block and position it. Leave 1⁄4 inch (.6cm) be-

tween the letter F and the left page margin, and posi-

tion the baseline of the letters (the imaginary line on

which the letters rest) on the horizontal guide at the

11⁄4-inch (3.2cm) mark on the vertical ruler.

Changing type style and
alignment
You can use the commands on the Type menu

to format text. Some of these commands (Font, Size,

and Type Style, for example) apply to characters.

Other commands (such as Paragraph, Indents/

Tabs, and Alignment), apply to entire paragraphs.

To make a change to a specific character or para-

graph, the text tool must be selected and the charac-

ters must be highlighted, or an insertion point must

be clicked in the paragraph. If you select more than

one paragraph, the changes will apply to all the se-

lected paragraphs.

Note: If you choose commands from the Type menu with-
out any characters or paragraphs selected, you’ll reset the
default attributes, which will apply to all new text you
type.

For more information about formatting text,

see Chapter 4, “Text Formatting and Word

Processing.”

Lorem ipsum dolor 
sit amet, consectet 
etuer adipiscing elit 
sed diam nonum 
nibh euismod tinci 
dunt ut laoreet do 
magna aliquam era

volutpat. Ut wisi ad 
enim minum quis.

Lorem ipsum dolor 
sit amet, consectet 
etuer adipiscing elit 
sed diam nonum 
nibh euismod tinci 
dunt ut laoreet do 
magna aliquam era

volutpat. Ut wisi ad 
enim minum quis.

Some formatting commands apply to characters (for example, type
style, tracking, font, type size, and leading). Here we used the Type
Style command to italicize a word.

Lorem ipsum

dolor sit amet, con 
sectet etuer adip 
iscing elit sed diam 
nonum nibh euis 
euismod tinci dunt 
ut laoreet do 
magna aliquam era

volutpat quis.

Lorem ipsum

dolor sit amet, con 

sectet etuer adip 
iscing elit sed diam 
nonum nibh euis 

euismod tinci dunt 
ut laoreet do 

magna aliquam era

volutpat quis.

Some formatting commands apply to paragraphs (for example,
paragraph spacing, indents, tabs, and alignment). Here we used the
Alignment command to center the
paragraph.

Using the Control palette
The Control palette is an alternative to moving,

resizing, and rotating an element manually.

Using the Control palette, you have precise

control over text and graphics and can make

several changes without changing tools or choosing

commands.

The settings and options available in the Control

palette change according to what you select in the

PageMaker window.
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When you select graphics and text objects with the

pointer tool, you can enter precise numeric values in

the Control palette to move, resize, rotate, scale, and

crop the objects. When you click in a text object with

the text tool, you can apply formatting to text and

paragraphs.

In this tutorial, you’ll use the Control palette

to precisely rotate a text block in the brochure.

For more information on how to use the

Control palette to format text, see Chapter 4, “Text

Formatting and Word Processing.” For more infor-

mation on how to use the Control palette to move,

resize, and transform graphics, see Chapter 6,

“Graphics and Text Objects.”

Control palette with objects selected

Control palette with text selected

Rotating and moving a text block
PageMaker provides extensive control over the ob-

jects in your publication. You can position graphics

and text blocks precisely, rotate them in .01-degree

increments, and resize them to exact specifications.

You can rotate an object (text or graphics) by

using the rotating tool in the toolbox, the Rotate op-

tion on the Control palette, or both. For this exer-

cise, you’ll use the rotating tool to rotate an object,

while viewing the angle of rotation on the Control

palette. When you finish rotating the object, you’ll

set the angle of rotation precisely with the Control

palette before dragging the object into position on

the brochure.

First, create the text block you will rotate.

1 Select the text tool, move to the pasteboard

(as shown), and then drag to create a text block ap-

proximately 1-inch (2.5cm) wide and 1⁄2-inch

(1.3cm) long.

2 Type SPRING.

3 With the text selected, format it in 14-point

Helvetica using the Size command on the Type

menu (Type > Size).

Now you’ll rotate and move the text block.

1 Use the zoom tool to magnify the area around the

word SPRING and the letter F in FLOWERS, or

press Command + Spacebar (Macintosh) or Ctrl +

Spacebar (Windows) and drag diagonally over the

area.

2 Choose Show Control Palette from the

Window menu to open the Control palette (Win-

dow > Show Control Palette).

3 Select the pointer tool, and click the SPRING text

block. (You can also use the rotating tool to select

objects you wish to rotate.)

The text block has windowshade handles at
the top and bottom, indicating that it is selected.

4 Select the rotating tool, and position

the starburst over the center of the

text block.
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The location on the text block where you click the

starburst is called the fixed point. Rotating an object

moves it around its fixed point.

The pointer changes to a starburst.

5 Drag the starburst counterclockwise to rotate the

text block. Continue rotating until the base-line of

SPRING is parallel to the left edge of the F in FLOW-

ERS and the angle of rotation shown on the Control

palette is approximately 90 degrees.

SPRINGSPRING S
P

R
IN

G
S

P
R

IN
G

You may need to move SPRING closer to FLOW-

ERS to view and align both text blocks. Select the

pointer tool and drag the SPRING text block closer

to the F in FLOWERS.

6 To ensure that the angle of rotation is exactly 90

degrees, be sure that the number displayed in the

Rotate option on the Control palette is 90. If not,

type 90, and then press Return (Macintosh) or Enter

(Windows).

Rotating option

7 Select the pointer tool, and click the SPRING text

block again.

8 Drag the rotated text block into position next to

the F in FLOWERS, as shown below. The bottom of

the letter S in SPRING should rest on the baseline of

FLOWERS.

S
P

R
IN

G

F L O W
9 Choose Save from the File menu to save your

work before proceeding to the next exercise

(File > Save).

Placing a text file
Placing text in PageMaker is similar to placing a

graphic. In this step, you’ll place a text file in the bro-

chure. To view the entire brochure, choose Fit in

Window from the View submenu on the Layout

menu. (Layout > View > Fit in Window)

The brochure, after you place the first column
of the text file

1 Make sure there is not a checkmark next to

the Autoflow command on the Layout menu (Lay-

out > Autoflow). If there is, choose Autoflow to de-

select it.

Autoflow is useful for flowing all the text in

a file into a publication. In this case, however,

you want to place the text column-by-column.

2 Choose Place from the File menu (File > Place).
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3 In the Place Document dialog box, select the

E&WText file from the Lesson2 folder of the

Tutorial folder, and then click OK (Macintosh) or

Open (Windows).

4 Position the loaded text icon at the intersection of

the left margin and the horizontal guide at the 2-

inch (5cm) mark on the ruler, and then click to

place the text.

A down arrow in the bottom windowshade handle

indicates there is more text to be placed.

Loaded text icon

When you click the loaded text icon, text flows from the
point where you clicked to the bottom of the column.

Creating threaded text blocks
One of the strongest features in PageMaker

is the flexibility of text objects. You can move them,

break them apart, and change their shapes as the

page layout and graphic images in your publication

dictate, while keeping the flow of the story intact.

The brochure, after you place the second text block

In PageMaker, you can create separate text

blocks in the same story to accommodate any page

design. These threaded text blocks can be on the

same page or on different pages. In this exercise,

you’ll flow a second text block from the same story

into the second column of your brochure.

For more information on working with threaded

text objects, see Chapter 4, “Text Formatting and

Word Processing.”

1 Using the pointer tool, drag the bottom window-

shade of the text block up to the 51⁄8-inch (13cm)

mark on the vertical ruler.

When you move the windowshade up,
the text block shortens. This is called
“rolling up the windowshade.”

2 Click the down arrow in the bottom windowshade

handle.
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The loaded text icon appears.

3 Position the loaded text icon at the left edge of the

second column at the 2-inch (5cm) horizontal

guide, and click to place the text.

The text flows into the second column.

4 Roll up the bottom windowshade of the second

text block until both columns of text are equal in

length.

Dragging to place text
Now you’ll create the final text block. The process

you’ll use—called drag-placing—lets you place text

in any area you define, even across multiple col-

umns.

The brochure, after you place the third text block

1 Click the down arrow in the bottom windowshade

handle of the second text block.

The loaded text icon appears.

2 Position the loaded text icon at the intersection of

the 51⁄4-inch (13.3cm) horizontal guide and the right

edge of the bouquet graphic.

3 Drag diagonally to the intersection of two guides

shown below, and then release the mouse button.

Drag from here…

to here

4 If necessary, move or resize the text block with the

pointer tool.

The top of the text in the block should be even with

the top edge of the bouquet graphic you placed ear-

lier. You can resize a text block by dragging one of its

handles, just as you resize a graphic.

Indicates text from the same story

is threaded into another block

Indicates there is no more text to be placed

5 Choose Save from the File menu to save

your work before going on to the next exercise (File

> Save).
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Using paragraph styles
A paragraph style is a set of attributes that define the

look of a paragraph: its font, type style and size,

alignment, and so on. The most efficient way to use

PageMaker is to create and apply paragraph styles. A

style might include the following attributes:

Font: Helvetica… Type size: 24 points…
Leading: 28 points… Type style: Bold…
Color: Blue… Alignment: Left…
Tab settings: 1 inch from the left margin

Changing a paragraph style
Styles let you change the formatting of many para-

graphs at once by simply changing the definition of

the style that has been applied to those paragraphs.

In this exercise, you’ll edit the paragraph headings in

the publication to make them stand out from the

body text. One change to the Headline style changes

all paragraphs in the brochure that have the Head-

line style applied.

For more information on using and defining styles,

see Chapter 4, “Text Formatting and Word Process-

ing.”

1 Choose Show Styles from the Window menu to

open the Styles palette (Window > Show Styles).

2 Double-click Headline in the list of styles.

This opens the Style Options dialog box. The for-

matting attributes of the Headline style appear at the

bottom of the dialog box.

You can change formatting by clicking the buttons

at the right side of the dialog box. In this exercise,

you’ll enlarge the typeface and make it bold.

Style definition of Headline

Change formatting

by clicking these

buttons

Styles palette • When you choose Windows > Show
Styles, the Styles palette appears, which lists the styles
defined for the publication. Use the Styles palette to ap-
ply a style to a paragraph; just click in the paragraph
with the text tool and then click a style name.

A Click the close box to close the Styles palette.

B The highlighted style indicates the style of para-
graph containing the text tool.

C A plus icon (+) indicates that the formatting of the
selected paragraph has been modified since the style
was applied.

D Click to open the Styles palette menu.

E A disk icon indicates that a style was imported from
a document that was created in a word-processing
application.

F Resize the Styles palette by dragging the Resize box.

G Click the trash button to delete a style.

H Click the new style button to quickly create a
new style.

A

B, C

D

E

F

H G
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3 Click the Char… button to open the Character

Specifications dialog box.

4 Select 10 for Size, and then click Bold for

Type Style.

5 Click OK to return to the Style Options

dialog box.

The style definition now includes the changes you

made to the Headline style.

6 Click OK to close the dialog box.

When you click OK in the Style Options dialog box,

all the headings change to the new style. To view

these changes, select 75% Size from the Zoom To

submenu in the View menu (View > Zoom To >

75% Size).

The headings in the brochure now stand out from the rest of the text.

Setting indents, tabs, and leaders
In desktop publishing, indents and tabs are used to

precisely position text within tables, columns, and

paragraphs. Indents move text from the left and

right edges of a text block. Tabs position text at spe-

cific locations relative to the left and right edges of a

text block.

The brochure, after you set an indent and a tab.

In this exercise, you’ll indent the price at the

bottom of the brochure and format the price

to make it stand out more clearly. When you’re

done, you’ll add another price and apply the same

indents and formatting in two quick steps.

For more information on setting and using tabs, see

Chapter 4, “Text Formatting and Word Processing.”

1 Use the zoom tool to magnify the bottom of the

third text block, or press Command + Space-bar

(Macintosh) or Ctrl + Spacebar (Windows) and

drag diagonally over the area.

2 Using the text tool, click after the word

UMBRA, and then press Tab.

Pressing Tab creates the space for the leader

dots you’re about to add. A leader is a repeated pat-

tern, such as a series of dots or dashes, placed in

a row between items in a table.
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Indents and Tabs

A Left tab icon sets a tab stop inward from the left mar-
gin of the text block.

B Right tab icon sets a tab stop inward from the right
margin of the text block.

C Leader box specifies a leader style for a tab stop.

D Reset abandons tab settings and returns to the de-
fault tabs.

E Center tab icon sets a tab stop that centers text in the
text block.

F First-line indent marker sets the indentation of the
first line of a paragraph.

G Left indent marker sets the indentation of text from
the left margin of the text block.

H Decimal tab icon lines up numbers at their decimal
point.

I Default tab marker indicates preset tab stops.

J Right indent marker sets the indentation of text from
the right margin of the text block.

K Position box displays the amount of indentation for
tabs and indents.

L Apply shows the effects of the tab and indent changes
you have made while the dialog box is displayed.

A B DC

H J K L

E

F

G I

3 Choose Indents/Tabs from the Type menu (Type

> Indents/Tabs).

4 Drag the first-line indent marker to the right until

you see 1 inch (25mm) in the Position edit box.

Positioning the first-line indent marker moves the

line 1 inch from the left margin.

Left-indent marker

First-line indent marker

TIP: YOU’LL FIND

THE DECIMAL TAB

USEFUL FOR ALIGNING

NUMBERS BY THEIR

DECIMAL POINTS.

5 Select the right tab icon, position the pointer any-

where on the ruler, click, and drag the right tab

marker to the 3-inch (76mm) position.

The Position edit box reflects the placement of the

tab marker.

Positioning the right tab aligns the price 3 inches

from the left margin.

The tab marker you just positioned is selected (high-

lighted). All the default tab markers to the left of the

new tab disappear.

Drag to here
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6 With the tab selected, click the Leader list box, and

select the leader dots ( . . . ) from the pop-up menu.

In the publication, leader dots will fill the tab space

between the item description and the price.

7 Click Apply and compare your results with

the illustration below.

The Apply button displays your formatting changes

before you exit the dialog box, so you can modify

them quickly. If you’re satisfied, click OK.

8 Using the text tool, click after the last number in

the price, and then press Return (Macintosh) or En-

ter (Windows).

9 Enter a second price by typing UMBRA,

pressing the Tab key, and then typing 3.45.

Copying a graphic between
publications
PageMaker lets you open several publications at

once, and then copy any object in a publication into

another open publication. You’ll now open the let-

terhead you created earlier, and copy the logo from

the letterhead into the brochure.

1 Choose Fit in Window from the View menu for

this exercise (View > Fit in Window).

2 Choose Open from the File menu (File > Open),

select the Letter1 file from the Lesson1 folder of the

Tutorial folder (in the PageMaker 6.5 folder), and

then click OK.

3 Choose Tile from the Window menu

(Window > Tile) to view the two publications side

by side.

4 Using the pointer tool, drag the E&W logo from

the letterhead into the layout window for the bro-

chure, and release the logo anywhere on the page or

pasteboard.
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5 Close the Letter1 window by clicking its

Close box.

Close box

6 Enlarge the Brochure window to fill the entire ap-

plication window by clicking its Zoom box.

Zoom box

Managing windows in PageMaker
Each PageMaker publication opens in its own win-

dow. You can click any visible window to activate it

(bring it to the front), or you can activate any open

PageMaker publication from the Window menu.

When you choose the name of a publication from

the menu, a submenu appears listing the layout win-

dow for the publication as well as each of the stories

currently open in story editor. You can bring any

window in any open publication to the front of your

screen by choosing its name from the submenu.

Positioning and resizing the logo
Now that you have a copy of the E&W logo in your

Brochure window, you can position and resize it to

fit the brochure.

The brochure, after you position and resize the logo.

1 Use the pointer tool to drag the logo into

the upper right corner of the page, aligned with

the top and right page margins as shown.

2 To resize the logo and retain its original propor-

tions, hold down the Shift key as you drag the lower

left handle of the logo to measure exactly 1-inch

(25mm) wide. (You must release the mouse button

before you release the Shift key for this to work.)

Press the Shift key while you resize
a graphic to retains its original proportions.

3 Choose Save from the File menu to save

your work (File > Save).
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It’s a good idea to save your work now, before you

print the brochure in the next exercise.

Printing the publication
After you look over the brochure on the screen,

you’re ready to print a proof copy for a final

review on paper. A proof copy does not show graph-

ics. Since graphics can take a long time to print,

printing a proof copy can save time when you only

want to proofread text. After you’ve reviewed the

proof copy and made any necessary changes to the

publication, you’ll print a final copy that includes the

graphics.

Note: For best results, if the final output will be printed to
a PostScript printer, the proof should also be printed to a
PostScript printer.

Macintosh Note: Select the PSPrinter 8.3.1 driver in the
Chooser when printing to a PostScript printer. See Chap-
ter 12, “Printing Publications,” for more information.

To print a proof version:

1 Choose Print from the File menu to open the Print

Document dialog box (File > Print).

Settings for a PostScript printer

2 Windows only: Select the name of an available

printer for the Printer option.

This printer can be the one you specified in the Page

Setup dialog box for the final printout of your publi-

cation, or it can be a desktop printer for a proof

copy.

3 If you’re printing to a PostScript printer, select a

printer file for the PPD option.

For more information on printer files,

see “PostScript Printer Description Files” on page

394.

4 Select the Proof option.

5 Click Ranges in the Pages option and type

1 so that PageMaker will print only the page you’ve

completed.

6 Click Print.

Proof of the brochure

7 Check your proof copy to see that it matches ours,

make any changes, and then choose Save from the

File menu (File > Save).

Now you can print the final copy of the brochure,

including the graphics.

To print the final version:

1 Choose Print from the File menu (File > Print).
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2 If the printer you’ll use to print the final version

differs from the one you used for your proof copy,

change it now in the Print To (Windows only) and

PPD options (PostScript printers only).

3 Click the Proof option to deselect it.

4 Click Print.

Final copy of the brochure

The project is complete
Congratulations! You’ve created and printed a bro-

chure and letterhead with PageMaker. Now that

you’ve learned the basics of PageMaker, remember

to read about or explore the other powerful features

available to you. These include:

• Multiple master pages to provide control and

flexibility in page design.

• Multiple layers for structuring complex docu-

ments and making the design and editing process

easier and faster.

• Frames for laying out pages before content

(final text and graphics) is available.

• Hyperlinks palette to let you jump from specified

text or graphics to other pages or to other docu-

ments on the World Wide Web.

• Color Management for consistent and reliable

color output.

• Expert kerning and tracking controls for high-

quality typography.
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