
Welcome to Help

Use the Help system to learn more about Inspiration® 6.

Find answers to your questions.
Learn how to create diagrams using symbols, text and links.
Learn how to create symbols using the Draw tools and add your new symbols to the symbol library.
Learn how to create and organize outlines.
Learn how to add Internet access to your diagrams and outlines
Learn how to enhance your diagrams and outlines using text, symbol, line, link and color options.
Learn how to customize Inspiration using templates and options for setting margins, headers and footers, 

and default font.
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Inspiration® Customer Service

We at Inspiration Software®, Inc. are committed to assisting our customers. If you have comments, questions or 
need help working with Inspiration, you can contact us by phone, fax or e-mail. You can also connect directly to 
Inspiration Technical Support by choosing Help on the Web on the Help menu.

Inspiration Software, Inc. provides customer service and technical support for registered users. Be sure to register 
so you can take advantage of our support services.

When you contact us, please provide your serial number. Our support services are open Monday through Friday 
from 8 a.m. to 5 p.m. Pacific Time. Our telephone number is (503) 297-3004. Our Fax number is (503) 297-4676. 
Our e-mail address is techsupport@inspiration.com. We look forward to hearing from you!



Entering your main idea

When you begin constructing a diagram, you start with your main idea. When you open Inspiration®, a new 
untitled diagram with a Main Idea symbol appears.

Type your main idea over the text "main idea" that appears in the Main Idea symbol.

Now you're ready to add topics that expand or explain the main idea.

{button ,AL("Creating diagrams;Scrolling to the Main Idea symbol;Adding idea symbols;Changing the main idea",0,`',`')} Related 
Topics 



A visual thinking tool

In Inspiration®, you think and learn visually. Inspiration provides you with the tools that let you create a picture of 
your ideas or concepts in the form of a diagram. It also provides an integrated outlining environment for you to 
develop your ideas into organized written documents.

When you work with visual representations of ideas, you easily see how one idea relates to others. Learning and 
thinking become active rather than passive. You discover where your deepest knowledge lies, and where the gaps 
in your understanding are. When you create a visual map of ideas, you can recall the details better than if you had 
read a paragraph. That's because you can see it in your mind.

If you have an idea that you want to expand, whether it's an idea for a written document or the illustration of a key 
concept, Inspiration can help you organize your thoughts and save you time. Use the visual diagramming part of 
the program to play with your ideas, to arrange them and group  in other words, to clarify your thinking.

When you need a different kind of structure, you can use the integrated outlining part of the program to organize your 
ideas in outline form. Inspiration's outline environment is perfect for creating structure for written documents, 
speeches and plans.

{button ,AL("About the Inspiration views;Creating a diagram;Creating an outline",0,`',`')} Related topics 



Creating a diagram

When you create a diagram using Inspiration®, you use symbols to represent your ideas. As you get your ideas 
down in visual form, it becomes easier to see how you want the ideas to relate to each other. You use links, lines 
that connect symbols, to show the way ideas and concepts flow and how they relate to each other.

 

What do you want to do?

Enter your main idea 

Add an idea symbol 

Move a symbol 

Connect ideas using links 

Add notes to a symbol 

Create an outline from a diagram 



Uses of diagrams

In Inspiration® you can create many types of visual diagrams. It doesn’t matter if you’re planning a trip, looking at 
cause and effect, or developing your understanding of a complex concept. The kind of diagram you create in 
Inspiration depends on the idea you want to develop. Here are some of the different types of diagrams you can 
easily build using Inspiration:

Concept map 

Idea map 

Web

Storyboard 

{button ,AL("About the Inspiration views;Creating a diagram",0,`',`')} Related topics 



Concept map

A concept map is a hierarchical diagram used to represent a set of concepts beginning with the most general or 
most important and then working down to more specific detail. Key concepts are connected by links that have 
descriptive words on them explaining the relationship between the concepts.

Concept maps are often used to illustrate scientific or historical concepts or for other types of knowledge mapping.

The Projectile diagram is an example of a concept map.

 



Uses of outlines

When you make an outline, you create a hierarchical structure for a report or plan. An outline helps you organize 
written documents, speeches or plans by providing a framework for your ideas, and by letting you order the flow of 
information.

You will find outlining particularly useful for planning and for structuring your ideas when writing. While the 
structure of an outline is simple, outlines can help you organize very complex material.

Working in Outline view makes it easy for you to see how your ideas are organized. It’s also easy to arrange your 
ideas in a specific order. When you’re writing a report, you can enter your ideas in your outline, organize them, 
then write the report by entering notes text for each idea.

Here are some of the ways you can use outlines:

Creating the structure for written reports and stories
Planning
Organizing notes
Writing instructional material

{button ,AL("About the Inspiration views;Creating an outline",0,`',`')} Related topics 



About the Inspiration® views

Inspiration® has two main views or environments: Diagram view and Outline view. As you work, both keep track of 
your ideas. Sometimes you will work exclusively in Diagram view to create a diagram or a map showing how ideas 
or concepts interconnect. Other times you will work in Outline view where you might organize and write a report.

{button ,AL("Uses of Diagrams;Uses of Outlines",0,`',`')} Related topics 



Diagram view

Inspiration has two main views or environments: Diagram view and Outline view. As you work, both keep track of 
your ideas. You can use Diagram view to create a diagram or a map showing how ideas or concepts interconnect. 
Other times you will work in Outline view where you might organize and write a report.

To switch from Outline view to Diagram view, click the Diagram button on the toolbar.

Here’s what Diagram view looks like:

{button ,AL("Uses of Diagrams",0,`',`')} Related topics 



Outline view

Inspiration® has two main views or environments: Diagram view and Outline view. As you work, both keep track of 
your ideas. You can use Outline view to create an outline of your ideas or organize and write a report.

To switch from Diagram view to Outline view, click the Outline button on the toolbar.

 

Here’s what Outline view looks like:

 

{button ,AL("Uses of Outlines",0,`',`')} Related topics 
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Idea map

Idea mapping is a visual brainstorming technique used to generate ideas and develop thoughts. An idea map 
starts with the main idea or problem in the middle of the screen. You record ideas associated with the main idea in 
symbols that radiate out from the main idea. The symbols connect to the main idea with links. Sub-ideas or 
specific details are then added to those ideas. You let the ideas flow and then step back and look at main themes, 
patterns or possible solutions.

Idea maps can be used for individual or group brainstorming, planning, problem solving, report writing, strategy 
development and company visions.

The Blue diagram is an example of an idea map.

 



Web

A web is a visual map that shows how different bits of information relate to each other. A web has a main idea or 
core concept at the center, with different categories of information connected to it. Ideas, facts and information are 
connected to the categories to support them.

Webbing is particularly useful when you’re analyzing a story or brainstorming ideas for a plan or written report.

The Secret Garden diagram is an example of a web.

 



Storyboard

A storyboard is a visual way to organize projects such as multimedia presentations or the design of a Web page. A 
storyboard helps you plan what you’re going to say and show, and figure out what ideas belong at the beginning, 
middle and end. In a storyboard, each symbol can represent a different slide, screen or page.

My Biography diagram is an example of a storyboard. 

 



The idea symbol

When you select an idea symbol on your diagram, handles appear that give you access to different functions.

To resize the symbol, click and drag any of the four handles.

 



The Diagram toolbar

When you’re working in Diagram view, there’s a Diagram toolbar at the top of your screen. You can use it to 
quickly add symbols and links to your diagram, as well as to change the style of your symbols. The Diagram 
toolbar appears automatically. 

Here are the tools available on the Diagram toolbar:

 
Outline Switches to Outline view

 

New Look  Sets default attributes such as shape, 
color and fonts for new symbols and links

 

RapidFire™ Lets you enter linked ideas quickly

 

Link Creates a link between two symbols

 

Add Note Opens the notes text window for the 
selected symbol

 

Create Adds a new, linked symbol in a horizontal 
or vertical direction

 

Create Adds a new, linked symbol in a diagonal 
direction

 

Position Lets you move (scroll) the diagram 
around on your screen

 

Arrange Lets you arrange symbols into various 
types of charts

 

Spell Lets you check the spelling in your 
document



The Draw toolbar

When you’re putting your ideas down in a diagram, you also have access to a Draw toolbar at the bottom of your 
screen. You use the tools on the Draw toolbar to draw basic shapes to add emphasis in your diagram, as well as 
to create new symbols for your diagram. The Draw toolbar also includes tools that help you nudge symbols and 
apply color. The Draw toolbar appears automatically. 

Here are the tools available on the Draw toolbar:

 
Selection Turns off a tool and returns the cursor to a 
pointer

 
Freeform Line Draws freeform lines

 
Line Draws straight lines

 
Oval Draws ovals or circles

 
Polygon Draws polygons, or many-sided figures

 
Rectangle Draws rectangles or squares

 
Rounded Rectangle Draws rectangles or squares 
with rounded corners

 
Text Box Draws a text box

 
Nudge Left, Right, Up, Down
Moves a symbol or drawn object 
one pixel at a time in the direction 
you choose

 
Fill Color Changes the fill color of the selected 
symbols or draw objects

 
Line Color Changes the line color of the selected 
symbols, links or draw objects

 
Multicolor Changes the color of multicolor symbols

 
Text Color Changes the text color of the selected 
symbols, links, or text 



About the diagram tools

Inspiration® gives you lots of different tools to make it easy for you to capture and organize your ideas in 
diagrams. In Diagram view, you have two toolbars: the Diagram toolbar and the Draw toolbar. You also have 
hundreds of symbols in the symbol libraries that come with Inspiration. The Symbol palette displays the libraries 
where you select symbols to put in your diagram. 

 



The grid

You can use the grid to align symbols as you add them to your diagram. On your screen, the grid looks like graph 
paper.

When the grid is displayed and you create a symbol, the symbol snaps to the grid. If you want to position symbols 
more precisely, you can turn the grid off. 

To turn on the grid, on the Utility menu, choose Grid Lines.
A check mark indicates that the Grid Lines are turned on.



Page lines

You can show page lines to help you see how your diagram will fit on the paper when it’s printed. 

To display the page lines, on the Utility menu, choose Page Lines.
A check mark indicates that the Page Lines are displayed.



The Symbol palette

Inspiration® comes with libraries of symbols for you to use in your diagrams. To see the contents of a library, use 
the Symbol palette on the left side of your screen. You can choose from among the library symbols for your 
diagram, or you can add your own symbols to the libraries. Like the toolbars, the Symbol palette appears 
automatically. 

To display the different libraries on the palette, click the Next Library button 
 or the Previous Library button 
 at the top of the palette.

To go directly to a specific library, click the Select Library button 
 at the top of the palette, choose a symbol category, and then choose a symbol library.

If you hold the pointer over a symbol palette icon for a few seconds, a preview of the image appears.

 

Note… The first six images are the same in each library. You can always use these basic symbol shapes and 
always add the Text Only symbol no matter what library appears on the palette.



The Status bar

As you work in Inspiration, you will notice there’s a Status bar toward the bottom of your screen that displays 
information about toolbar buttons and, in Diagram view, library symbols. When you position the pointer over a 
button or symbol on your screen, the Status bar displays information about that item.

The Status bar is also where magnified text appears in Diagram view. When you’re working on a diagram in a 
reduced view and you want to know what the text is in a symbol, position the pointer over the symbol. The text 
appears magnified in the Status bar.

 



The scroll bars

When you’re working in Diagram view or Outline view, you have access to two scroll bars: one on the right side of 
the screen and one across the bottom of your screen.

The bottom scroll bar also includes tools. You use the tools that appear on the left side of the bottom scroll bar to 
enlarge or decrease the size of the diagram or outline in the window. 

Here are the tools available on the bottom scroll bar:

 



Adding idea symbols

You choose the way you build your diagram. 

You might want to add all your main topics first, then expand each of them. Or you might want to add the first main 
topic and expand it with related ideas before continuing to another main topic. 

What do you want to do?

Enter your Main Idea 

Use the Create tools to add a connected idea in any direction 

Use the RapidFire™ tool to add connected ideas quickly 

Use the Symbol palette to add a specific symbol anywhere on your diagram 

Use Point & Type to add an unconnected symbol anywhere on your diagram 

Use Command (Ctrl) to add a connected idea anywhere on your diagram 

Use Command (Ctrl) to add an unconnected idea anywhere on your diagram 

Insert an idea between linked symbols 

Change a symbol shape 



Using the Create tools to add an idea in any direction

You can use the Create tools on the Diagram toolbar to attach an idea to the Main Idea symbol or to any other 
symbol in a diagram. The symbol appears in the direction you choose.

To use the Create tools to add an idea in any direction:

1 Select the idea symbol on your diagram that the new idea relates to by clicking it.

2 On the Diagram toolbar, click the arrow on either of the Create buttons that points in the direction where you 
want to add the new idea. 

Each arrow on the button works like a separate tool. Position the pointer over the one you want to use, then 
click it. 

 
The new symbol appears on your diagram connected to the primary symbol in the direction you chose. The new 
symbol is selected and ready for you to enter an idea. 

 
3 Type your idea in the symbol.

You can now add another idea symbol to the one you just created, or you can select another symbol in the 
diagram and repeat the process described above.

{button ,AL("Adding idea symbols;Inserting a symbol between linked ideas;Using point and type to add an unconnected 
idea;Using the Symbol palette to add a specific symbol;Changing a symbol shape",0,`',`')} Related topics 



Using the RapidFire™ tool to add ideas quickly

You use the RapidFire™ tool when you want to add a series of connected ideas to the Main Idea or any other idea 
symbol. 

The advantage of using the RapidFire tool is that you can concentrate on adding the ideas, rather than creating 
symbols one at a time. Each symbol you add is automatically linked to the idea symbol you start with.

To use the RapidFire tool to add ideas quickly:

1 Select the Main Idea symbol or any other idea symbol to which you want to add a series of related ideas.

2 Click the RapidFire button on the Diagram toolbar to turn on the RapidFire tool.

The RapidFire icon appears in the symbol to show you the tool is turned on. You’re ready to begin typing ideas. 

 
3 Type an idea, and then press Return (Macintosh) or Enter (Windows) after each idea.

Your ideas appear as symbols on the diagram. They’re all connected to the symbol where you started, and 
they progress around that symbol in a clockwise direction. 

 
4 To turn the RapidFire tool off, click the RapidFire button or anywhere on the background of your diagram.

{button ,AL("Adding idea symbols;Inserting a symbol between linked ideas;Using point and type to add an unconnected 
idea;Using the Symbol palette to add a specific symbol;Changing a symbol shape",0,`',`')} Related topics 



Using Command (Ctrl) to add a connected idea

You can use a keyboard command to add linked ideas. This lets you control where your symbols are located. For 
a complete list of keyboard shortcuts, see Using keyboard and mouse shortcuts.

To use Command (Ctrl) to add a connected idea:

1 Select the idea symbol to which you want to connect a new symbol.

2 Press and hold down the Command key (Macintosh) or Ctrl key (Windows), and then click where you want to 
place the new symbol.

The new linked symbol appears on your diagram.

3 Type your idea in the new symbol.

Or

Without typing any text, continue to add symbols by clicking a primary symbol, pressing Command (Macintosh) or Ctrl 
(Windows), and then clicking where you want the next new symbol to appear.

{button ,AL("Using the Symbol palette to add a specific symbol;Inserting a symbol between linked ideas;Using Command (Ctrl) to 
add connected ideas;Using Command (Ctrl) to add unconnected ideas;Using point and type to add an unconnected idea",0,`',`')} 
Related topics 



Using Command (Ctrl) to add an unconnected idea

You can use the Command key (Macintosh) or the Ctrl key (Windows) to add a new unconnected idea symbol in 
any location you want.

To use Command (Ctrl) to add an unconnected idea:

1 Make sure no symbol is selected.

2 Press the Command key (Macintosh) or the Ctrl key (Windows), and then click where you want to place the 
new symbol. 

The new unconnected symbol appears on your diagram. 

3 Type your idea in the new symbol.

{button ,AL("Using the Symbol palette to add a specific symbol;Connecting ideas using links;Using Command (Ctrl) to add a 
connected idea;Using point and type to add an unconnected idea",0,`',`')} Related topics 



Using the Symbol palette to add a specific symbol

You can select a specific graphic on the Symbol palette and have it appear as an unconnected idea symbol 
anywhere on your diagram. You can also replace a symbol with one from the palette. To replace a symbol with one 
from the palette, see Changing a symbol shape.

To use the Symbol palette to add a specific symbol:

1 On the palette, click the symbol you want, and then drag it onto the diagram. 

2 When the symbol is in the location you want, release the mouse button.

The unconnected symbol appears where you dropped it.

Aside… You can link the unconnected symbol to another symbol in the diagram at any time. For information 
about drawing links, see Connecting ideas using links.

{button ,AL("Changing a symbol shape;Adding a specific symbol using the Symbol palette;Adding idea symbols",0,`',`')} Related 
topics 



Adding a specific symbol using point and click

1 Click in the diagram on the location where you want to add the symbol.

A cross hair marks the spot where you click.

 
2 Click the symbol on the Symbol palette you want to add to the diagram.

The unconnected symbol appears where you clicked in the diagram.

2 Type your idea in the new symbol.

Aside… You can link the unconnected symbol to another symbol in the diagram at any time. For information 
about drawing links, see Connecting ideas using links.



Changing a symbol shape

You can change a symbol’s shape at any time.

To change a symbol’s shape:

1 Select the symbol or symbols you want to change.

2 On the Symbol palette, click the library symbol you want to use in its place.

The symbol on your diagram changes to the library symbol.



Using Point & Type to add an unconnected idea

To add an idea symbol quickly, you can point to the place on your diagram where you want to add the idea and 
begin typing. Inspiration® will pop a symbol shape around your idea to hold your text.

To use Point & Type to add an unconnected idea symbol:

Click on an open space in the diagram where you want to add the symbol, and then type.
The unconnected symbol appears where you typed your idea.

Aside… You can link the unconnected symbol to another symbol in the diagram at any time. For information 
about drawing links, see Connecting ideas using links.

{button ,AL("Using the Symbol palette to add a specific symbol;Connecting ideas using links;Using Command (Ctrl) to add 
unconnected ideas",0,`',`')} Related topics 



Inserting a symbol between linked ideas

While working on your diagram you may decide to add a symbol between two other symbols you’ve already 
created. The Insert Symbol command lets you do this quickly, leaving the new symbol linked to the two original 
ones.

To insert a symbol between linked ideas:

1 Select the link that connects the two idea symbols between which you want to insert a new symbol.

 
2 On the Symbol menu, choose Insert Symbol. 

The new symbol appears linked to both of the original symbols.

 
3 Enter the idea in the new symbol.

Tip… You can drag the symbols to provide more space for the new symbol. See Moving a symbol for more 
information.

{button ,AL("Adding idea symbols",0,`',`')} Related topics 



Moving a symbol

As you’re building your diagram, you will often want to move a symbol to another location. One of the simplest 
ways to move symbols around on your diagram is to click and drag them.

To move a symbol:

1 Select the symbol or symbols you want to move. 

To select multiple symbols, hold down the Shift key and click the ones you want.

Or

If the symbols are next to each other, you can click and drag the pointer across the symbols until the marquee 
appears around them, then release the mouse. You don’t need to fully enclose the symbols to select them.

 
2 Drag the symbol or symbols to the new location.

Tip… For information about moving symbols precisely, see Positioning a symbol precisely.



Connecting ideas using links

Links show the relationships and connections between ideas. When you use the RapidFire™ and Create tools, 
your ideas are automatically linked. Even though Inspiration® sometimes adds links for you, you may want to 
create your own.

 

What do you want to do?

Use the Link button to connect symbols 

Connect symbols by dragging a link from one symbol to another 

Change the location where a link connects to an idea symbol 

Add text to a link 



Using the Link tool to connect symbols

As you are working, you can use the Link tool to quickly create links between symbols. 

To use the Link tool to connect symbols:

1 Click the Link button on the Diagram toolbar.

 
2 Select the primary idea symbol, the one from which you want to originate the link.

3 Select the secondary idea symbol, the one you want to link to.

The link appears and the arrowhead points to the secondary symbol.

4 Repeat the process to link more symbols together. 

5 To turn off the Link tool, click the Link button again, or click anywhere in the diagram background. 

{button ,AL("Changing link connections;Labeling the connections between ideas",0,`',`')} Related topics 



Connecting symbols by dragging a link

You can drag a link from one idea symbol to another to connect the symbols.

To connect symbols by dragging a link:

1 Select the primary idea symbol, the symbol you want to draw the link from.

2 Position the pointer over the diamond-shaped handle where you want the link to begin.

 
3 Click and drag until the pointer touches the secondary idea symbol and highlights it. (Don’t release the mouse 

button yet.)

On the highlighted symbol, you can see all the possible connecting points. 

 
4 Position the pointer where you want to attach the link, then release the mouse button.

Inspiration draws the link between the two symbols. 

Tip… A symbol can have 8 or 32 connection points for links. The default is 8 connections. You can set the 
number of connection points to 32 for your document using the Diagram properties on the File menu. Or, you 
can access the 32 connection points by pressing the Command key (Macintosh) or Ctrl key (Windows) at the 
same time you drag the link.

{button ,AL("Changing link connections;Labeling the connections between ideas",0,`',`')} Related topics 



Changing a link's connection

You can move either end of a link the end that’s attached to the primary idea or the end that’s attached to the 
secondary idea.

To change a link’s connection:

1 Select the link you want to move.

2 Click the selection handle at the end of the link you want to move, then drag the link until you reach the place 
on the symbol where you want to connect.

As you drag the link, the connecting points on the symbol are highlighted to show you where you can attach 
it. When the pointer covers the connecting point where you want the symbol to attach, release the mouse 
button.

 

Tip… A symbol can have 8 or 32 connection points for links. The default is 8 connections. You can set the 
number of connection points to 32 for your document using the Diagram properties on the File menu. Or, you 
can access the 32 connection points by pressing the Command key (Macintosh) or Ctrl key (Windows) at the 
same time you drag the link.

{button ,AL("Labeling the connections between ideas",0,`',`')} Related topics 



Labeling the connections between ideas

Each time a link is drawn, either by you or automatically by Inspiration®, a text box appears along the link when 
the link is selected. You can add text to describe the link connection. 

 

To add text to a link:

1 Select the link to which you want to add text. 

2 Type your text.

3 When you finish typing, click elsewhere on the diagram. 

The text appears across the link on your diagram. 

Tip… After you add text to a link, you can always edit the text later. Click the link to select it, and then click in 
the text area and type.

{button ,AL("Moving text on a link",0,`',`')} Related topics 



Moving text on a link

After you add text to a link, you can move the text so that it appears in a specific location along the link.

To move text on a link:

1 Select the link that has the text you want to move.

The text box is highlighted, and a dot appears beneath the text.

 
2 Click the dot and drag the text box along the link to its new location.



Adding notes text to a symbol

After you’ve added an idea symbol to your diagram that uses a word or a short phrase, you can expand your idea 
by adding notes text to the idea symbol. 

You will find making notes is a valuable way to detail your diagram or to convert your diagram into a written report. 
You can add notes to any symbol. The notes can be a few sentences or paragraphs of information. Don’t worry 
about cluttering up your diagram with a lot of text. The notes text is hidden until you want to see it.

To add notes to a symbol:

1 Select the symbol to which you want to add or change notes text.

2 On the Diagram toolbar, click the Add Note button.

The Notes window opens.
3 Enter the notes text for the idea symbol.

4 When you finish, click the close box (Macintosh) or the close button (Windows) on the title bar of the Notes 
window.

The Notes window closes and you return to the diagram. The box at the handle at the upper left of the 
selected symbol is filled, indicating the symbol has notes text.

5 To open the notes window, select the symbol, and then double-click the upper left symbol handle.

 

Tip… Press Command+Y (Macintosh) or Ctrl+Y (Windows) to open a Notes window or close a Notes window 
for a selected idea symbol. For a complete list of keyboard shortcuts, see Using keyboard and mouse 
shortcuts.

{button ,AL("Printing notes text for a diagram;Printing notes text for a symbol;Viewing or editing notes text for a diagram;Viewing 
or editing notes text for a symbol",0,`',`')} Related topics 



Viewing or editing notes text for a symbol

After you add notes text to a symbol, you can view and edit the notes text for the symbol. You can also view and 
edit all the notes text for a diagram. See Viewing or editing notes text for a diagram.

To view or edit notes text for a symbol:

1 Select the symbol.

2 Double-click the resize handle in the upper-left corner.

The Notes window appears.

3 Make any changes to the notes text, and then click the close box (Macintosh) or close button (Windows) on the 
title bar of the Notes window.

{button ,AL("Printing notes text for a diagram;Printing notes text for a symbol;Viewing or editing notes text for a diagram",0,`',`')} 
Related topics 



Viewing or editing notes text for a diagram

After you add notes text to symbols on your diagram, you can view and edit the notes text for all the symbols on 
the diagram.

To view or edit notes text for a diagram:

1 On the View menu, choose Notes List.

All the notes for the diagram are displayed. 

2 Make any changes to your notes.

3 Click the Diagram button on the toolbar to return to Diagram view.

{button ,AL("Printing notes text for a diagram;Printing notes text for a symbol;Viewing or editing notes text for a symbol",0,`',`')} 
Related topics 



Creating an outline

After you have your ideas in a visual format, you can continue to develop and organize them in written form using 
Outline view. You can easily create an outline from your diagram by changing to Outline view. Changes you make 
in Outline view are automatically made in Diagram view, and vice versa. 

You can also create an outline without adding text to your symbols. When you switch to Outline view, Inspiration® 
creates an outline using the symbol labels (a symbol with the label “Sun” becomes a topic “Sun” in the outline). 
The symbol labels serve as placeholders for topics as you develop your outline. When you return to Diagram view, 
the topic text appears in the symbols. If you do not want symbol labels to appear as topic text, you can turn off the 
Picture-to-topic feature. To turn off Picture-to-topic, choose Application Properties on the File menu. In the 
Application Properties dialog box, clear the Picture-to-topic check box. 

To switch between Diagram and Outline view:

On the Diagram toolbar, click the Outline button. 
Or

On the View menu, choose Outline.



Working with the diagram

After you have some of your ideas down, and you begin to make connections and add links, you can organize and 
rearrange your diagram. 

What do you want to do?

Magnify or reduce the view of your diagram 

Select all or part of your diagram 

Copy and paste symbols 

Cut and paste symbols 

Delete a symbol and its links 

Delete a link 

Change your Main Idea symbol 



Magnifying and reducing the view

When you want to see more of your diagram or outline in the window, you zoom out. When you want to make your 
symbols or topics look bigger, you zoom in. You can also zoom in or out to a specific percentage. Use the buttons 
in the lower left of the window to zoom in or out. 

Note… Zooming in and out does not change the actual size of the document, only the magnification at which 
you see it. To scale idea symbols, see Resizing symbols.

To zoom out: 

To zoom in: 

To zoom to a specific percentage: 



Zooming out

Click the Zoom Out button 

 in the lower left of the window.
Or

On the View menu, choose Zoom Out



Zooming in

Click the Zoom In 

 button in the lower left of the window.
Or

On the View menu, choose Zoom In.



Zooming to a specific percentage

Click the percentage area next in the lower left of the window, then select the size you want.
Or

On the View menu, choose Zoom, then select the percentage you want.

 



Fitting the entire diagram into the window

On the View menu, choose Zoom, then select Fit To Window.
Or

Click the percentage area next to the Zoom In button in the lower left of the window, then select Fit To Window. 

Tip…You can also use Command+E (Macintosh) or Ctrl+E (Windows) to do a Fit To Window.



Reading text in reduced view

Sometimes, when you zoom out on a large diagram, it is difficult to read the text in symbols. To make it easy to 
read the text, a magnified version of the text appears in the Status bar.

To read the text on the diagram when you are in a reduced view:

Position the pointer over the symbol or link containing the text you want to read.
The text is displayed in the Status bar in the lower left of the window.



Positioning the diagram in the window

Sometimes you will want to position a diagram in the window so you can see parts of it more easily. The Position 
tool makes it easy to take a section of the diagram and move it around within the window. 

To position the diagram in the window:

1 Click the Position tool to turn it on. 

 
The pointer becomes a grabber hand.

2 Click and drag the grabber hand in the direction you want the diagram to move. 

You can click and drag as many times as you need until you get the diagram where you want it in the 
window.

3 Click the Position tool again to turn the tool off.

Tip… You can also hold down Command+Option (Macintosh) or Ctrl+Alt (Windows) and drag to move the 
diagram in the window.



Scrolling to a selected object

If you have scrolled away from a selected object, you can easily return to it and have it appear in the center of the 
Diagram view window.

To scroll to and center a selected object in the window:

On the Edit menu, choose Scroll To Selection.



Scrolling to the Main Idea symbol

You can quickly scroll to the Main Idea symbol. 

To scroll to and select the Main Idea symbol:

On the Edit menu, choose Select Main Idea.
The Main Idea symbol appears and is centered in the screen.

Tip… You can also press Command+M (Macintosh) or Ctrl+M (Windows) to select the Main Idea symbol. For a 
complete list of keyboard shortcuts, see Using keyboard shortcuts.



Hiding parts of the diagram

You may want to single out an idea or concept so you can develop it more completely. To do that, it’s helpful to 
show only that portion of your diagram while you are working. You may also want to see just the higher level view 
of the diagram. You can also hide subsymbols for a symbol.

To hide all but a specific part of the diagram:

1 Select the idea symbol you want to view.

Note…You can select any symbol except the Main Idea symbol.

2 On the View menu, choose Focus In. 

The symbol and its subtopics appear on the screen. The rest of your diagram is hidden.

3 To view your complete diagram again, on the View menu, choose Focus Out.

The whole diagram reappears.



Hiding a symbol's subtopics

1 Select the symbol for which you want to hide the subtopics.

2 On the View menu, choose View Subtopics, then select Hide

Or

Press Command+H (Macintosh) or Ctrl+H (Windows). 

Tip… When you hide a symbol’s subtopics, the square handle on the bottom left corner of the symbol is filled. 
You can double-click the square handle to show the hidden symbols. If the handle is not filled, you can double-
click it to hide the subtopic symbols.

{button ,AL("Displaying symbol subtopics",0,`',`')} Related topics 



Displaying a symbol's subtopics

1 Select the symbol that has hidden subtopics.

You can tell a symbol has hidden subtopics when the square in the lower left corner of the symbol is filled.

2 On the View menu, choose View Subtopics, then select Show 

Or

Press Command+H (Macintosh) or Ctrl+H (Windows).

{button ,AL("Hiding symbol subtopics",0,`',`')} Related topics 



Select object commands

Inspiration® has some special commands that you can use to quickly select all or parts of your diagram as you 
organize information.

To select all objects: 

To select all symbols: 

To select all links: 

To select all draw objects: 

To select all symbols at a specific level: 



Selecting all objects on the diagram

On the Edit menu, choose Select All.
Everything on your diagram is selected.



Selecting all symbols on the diagram

On the Edit menu, choose Select, then select Symbols.



Selecting all links on the diagram

On the Edit menu, choose Select, then select Links.



Selecting all draw objects on the diagram

On the Edit menu, choose Select, then select Draw Objects.



Selecting all symbols at a specific level

You can work on all the symbols at a particular level at once. For example, you might want to change the fill color 
of all symbols at a specific level at one time.

To select all the symbols at a specific level:

1 Select a symbol at the level that you want to work on.

2 On the Edit menu, choose Select, then select This Level.

All symbols at that level are selected.



Copying and pasting symbols

Copying and pasting works the same way in Inspiration® as it does in other programs. You might want to copy a 
section of a diagram, for example, to paste it into another program.

Note… To import graphics from other programs, see Importing graphics for symbols. To export diagrams you 
create in Inspiration to other programs, see Using Inspiration documents with other applications.

To copy and paste a symbol:

1 Select the symbol or symbols you want to copy.

2 On the Edit menu, choose Copy. 

3 Click the place on the diagram where you want the copy of the symbol to appear.

4 On the Edit menu, choose Paste. 

The copy of the symbol appears in its place.

Tip… If you’re not sure where you want the copy to appear, paste it in any empty space on the diagram. You 
can always move it later. 

{button ,AL("Cutting and pasting symbols",0,`',`')} Related topics 



Cutting and pasting symbols

Cutting and pasting works the same way in Inspiration® as it does in other programs. You might want to cut a 
section of a diagram, for example, to paste it into another location on your diagram.

To cut and paste a symbol:

1 Select the symbol or symbols you want to cut.

2 On the Edit menu, choose Cut. 

The selected symbol disappears from the diagram.

3 Click the place on the diagram where you want the symbol to appear.

4 On the Edit menu, choose Paste. 

The symbol appears in its new location.

Note… Any links contained within the area you cut and paste are retained. Any links to symbols outside that 
area are deleted.

{button ,AL("Copying and pasting symbols",0,`',`')} Related topics 



Undoing changes

Undo cancels the last change you made. 

On the Edit menu, choose Undo or press Command+Z (Macintosh) or Ctrl+Z (Windows). 



Deleting a symbol and its links

As you’re working, you may want to delete some symbols and links from your diagram.

To delete a symbol and its links:

1 Select the symbol you want to delete.

2 Press the Delete or Backspace key.

Or

On the Edit menu, choose Clear.

Note… When you delete a symbol using this method, you automatically delete any links that connect it to other 
symbols. The text in the symbol, any notes text and any text in the links are also deleted.

{button ,AL("Deleting a symbol without deleting its links",0,`',`')} Related topics 



Deleting a symbol without deleting its links

If you’ve created a symbol that is linked between two or more other symbols, you can delete that symbol and the 
links will reattach to the other symbols.

1 Select the symbol that you want to delete.

2 On the Symbol menu, choose Delete Symbol (Keep Links).

The symbol disappears and the links redraw themselves between the other linked symbols.

 
When you use the Delete Symbol (Keep Links) command, the symbol in the middle is deleted, and the links between 
the remaining symbols reconnect.



Deleting a link

You can delete any link. When you delete a link, you remove the relationship between the primary and secondary 
symbols. The remaining symbol or symbols become unconnected ideas.

To delete a link:

1 Select the link you want to delete.

2 Press the Delete or Backspace key. 

Or

On the Edit menu, choose Clear. 
The link and any text on the link disappear.



Changing the main idea

You can change your diagram so that another idea symbol replaces the Main Idea symbol as the center of your 
diagram. You will find this useful when you discover that the flow of your diagram has shifted focus as you develop 
your ideas.

When you change the main idea, the outline view of your diagram also reflects the change.

To change the main idea:

1 Select the symbol that you want to be the main idea.

2 On the Symbol menu, choose Change Main Idea.

A message box appears, telling you that Inspiration® will rebuild your diagram to reflect the change.

3 Click Yes.

Click No to return to the diagram without changing the main idea.



Changing text styling for symbols or links

You can change the way the text in your symbols looks using the commands on the Format menu. You can select 
your favorite font, change the size and make text bold or italic, for example.

For contrast, you might want to make the text that appears in your links look different from the text that describes 
your ideas. Or you could give a group of related symbols and links one text style to maintain a certain theme, while 
giving another group on the diagram a different look. 

To change text style:

To change text font: 

To change text size: 

To change text color: 

To change the color of selected words: 



Changing text font for symbols or links

1 Select the symbol or link that contains the text you want to change.

Tip… To change all text on the diagram at one time, including text in both symbols and links, on the Edit menu, 
choose Select All. 

2 On the Format menu, choose Font, then select the font you want. 

Tip… For Windows*, if you want to use a font that does not show on the Font menu, choose More Fonts on the 
Font menu. For more information see Using fonts not on the Inspiration Font menu.

{button ,AL("Using fonts not on the Inspiration Font menu;Changing text style;Changing text size;Changing text color;Changing 
text font",0,`',`')} Related topics 



Changing text style for symbols or links

1 Select the symbol or link that contains the text you want to change.

Tip… To change all text on the diagram at one time, including text in both symbols and links, on the Edit menu, 
choose Select All. 

2 On the Format menu, choose Style, then select the style you want. 

{button ,AL("Returning text to the default style;Changing text size;Changing text color;Changing text font;Changing text 
styling",0,`',`')} Related topics 



Changing text size for symbols or links

1 Select the symbols and links that contain the text where you want to change the point size.

Tip… To change all text on the diagram at one time, including text in both symbols and links, on the Edit menu, 
choose Select All. 

2 Choose one of the following, depending on what you want to do:

To select a size that’s on the Size drop-down list, on the Format menu, choose Size, then select the point 
size you want.

Or

To use a size that’s not on the Size drop-down list, on the Format menu, choose Size, then select Other. In the dialog 
box, enter the size you want, and click OK.
Or

To increase or decrease the size of selected text one point size at a time, on the Format menu, choose Size, then 
select Increase or Decrease.

Tip… To change the text size for all future symbols or links you add to the diagram, select the symbol or link 
with the text size you want, and then click the New Look button on the Diagram toolbar.

{button ,AL("Returning text to the default style;Changing text style;Changing text color;Changing text font",0,`',`')} Related topics 



Using fonts not on the Inspiration® Font menu

If you are using Inspiration® on a computer running Windows*, you can use fonts that do not appear on the 
Inspiration Font menu.

To use fonts not on the Inspiration Font menu:

1 Select the objects where you want to use the new font.

You can select any combination of items a single symbol, all links, a draw object and a symbol, and so on.

2 On the Font menu, choose More Fonts.

The Font dialog box appears.

3 On the Font drop-down menu, choose the font you want to use for the selected items.

4 Select the size you want to use for the selected items.

The font and size are applied to the selected items.

Tip… If you’re using Windows, you can change the fonts that appear on the Inspiration Font menu. On the File 
menu, click Application Properties. Click the Font tab, select a font to add or remove from the Font menu. Then 
click Add or Remove. 

{button ,AL("Changing text styling",0,`',`')} Related topics 



Changing text color for symbols or links

You can change the color of text that appears on a symbol or link.

To change the text color on a symbol or link:

1 Select the symbol or link for which you want to change text color.

2 Do one of the following:

On the Draw toolbar, click the Text Color button, and then select the color you want.

Or

On the Effect menu, choose Text Color, and then select the color you want.
The text in the symbol or link changes to the color you selected.

{button ,AL("Changing the color of selected words;Returning text to the default style;Changing text style;Changing text 
size;Changing text font",0,`',`')} Related topics 



Changing the color of selected words on a symbol or link

You can change the color of selected text that appears on a symbol or link.

To change the color of selected text on a symbol or link:

1 Select the symbol or link for which you want to change text color.

2 Select the words for which you want to change the color.

3 Do one of the following:

On the Draw toolbar, click the Text Color button, and then select the color you want.

Or

On the Effect menu, choose Text Color, and then select the color you want.
The selected words change to the color you selected.



Ending text editing

When you finish typing your text, here are two common ways you can leave text editing mode:

Click outside the item you’re working on in an empty place in the diagram.
Or

Press Shift+Return (Macintosh) or Shift+Enter (Windows) or the Escape key to leave text editing and select 
the item you’ve been working on.



Justifying text

You can change the text justification (whether text is centered or flush right or left) for symbols and links.

To justify text:

1 Select the symbols or links you want to change.

2 On the Format menu, choose Text Justify, then select Left, Center or Right. 



Returning text to the default style

If you select part of the text in a symbol or link and make changes to its appearance, you can return the text to its 
original style by using the Revert To Style command on the Format menu.

To return text to the default style:

1 Select the symbols or links that you want to change back to the default look.

2 On the Format menu, choose Revert To Style. 



Changing the way symbols grow as you add text

You can change the way symbols grow to fit your text.

To change the way symbols grow as you add text:

1 On the Symbol menu, choose Auto Symbol Grow.

2 Select one of the following:

To have the symbol grow vertically from the middle as you add text, select Standard. (This is the default 
setting.)

Or

To have the symbol maintain its height-to-width ratio as you add text, select Proportional. 
Or

To have the symbol remain the same size as you add text, select Off. If the text does not fit wholly within the symbol, 
part of your text is displayed followed by an ellipsis. 
Or

To set a width for the symbol by dragging it to a specific width, and then have the symbol grow vertically down the 
screen as you add text, select Fixed Width. 

Note… If your symbol has captioned text, the settings for Auto Symbol Grow don’t affect the symbol size 
because the text is outside the symbol image area.



Using text from an idea symbol in a caption

You can have text appear below the symbol as a caption, rather than have it appear inside the symbol. This is 
especially useful for symbols that are detailed images.

To use text from an idea symbol in a caption:

1 Select the symbol whose text area you want to move.

2 On the Symbol menu, choose Captioned Symbol.

Inspiration® moves the text area so it appears below the symbol.

If you decide later on that you want to have the text area appear inside the symbol, select the symbol, then on the 
Symbol menu, select Captioned Symbol again to turn the feature off.



Adding the date to your diagram

You can add today’s date to your diagram.

To add today’s date to your diagram:

1 Click on your diagram where you want the date to appear.

2 On the Edit menu, choose Paste Date.

Inspiration® pastes the date on your diagram.

Tip… You can change the format in which the date will appear when you use the Paste Date option. On the File 
menu, choose Application Properties, then select another format on the Date/Time Format drop-down list. Now 
when you choose Paste Date it will provide the date in the format you specified.



Setting a new look for symbols

When you create a symbol you like, or change the look of a symbol, you can save these changes and apply them 
to new symbols you draw. You can also select symbols you’ve already drawn, and apply the new look to them, as 
well.

To set a new look for symbol:

1 Select the symbol that has the look you want to use.

2 On the Diagram toolbar, click the New Look button.

Or

On the Edit menu, choose Set New Look.
You see a preview of what the symbol will look like.

Now, whenever you create a new symbol or link, it has the look you specified.

{button ,AL("Applying a new look to symbols;Setting a new look for links",0,`',`')} Related topics 



Setting a new look for links

When you create a link you like, or change the look of a link, you can save these changes and apply them to new 
links you draw. You can also select links you’ve already drawn, and apply the new look to them, as well.

To set a new look for links:

1 Select the symbol that has the look you want to use.

2 On the Diagram toolbar, click the New Look button.

Or

On the Edit menu, choose Set New Look.
You see a preview of what the symbol will look like.

Now, whenever you create a new symbol or link, it has the look you specified.

{button ,AL("Applying a new look to links;Setting a new look for symbols",0,`',`')} Related topics 



Applying a new look to symbols

After you set a new look for symbols, you can apply the look to symbols you’ve already drawn.

To apply a new look to an existing symbol:

1 Select the symbol or symbols that you want to apply the new look to.

2 On the Edit menu, choose Paste New Look.

Inspiration® updates the symbols (except the symbol size).

{button ,AL("Setting a new look for symbols",0,`',`')} Related Topics 



Applying a new look to links

After you set a new look for links, you can apply the look to links you’ve already drawn.

To apply a new look to an existing link:

1 Select the link or links that you want to apply the new look to.

2 On the Edit menu, choose Paste New Look.

Inspiration® updates the links.

{button ,AL("Setting a new look for links",0,`',`')} Related Topics 



Using the symbol libraries

There are hundreds of symbols available in the symbol libraries. You can display each library, one at a time, on the 
Symbol palette so you can see what’s in each one.

To display different libraries on the Symbol palette:

On the Symbol palette, click the Previous 
 or Next button 
 to display the next or previous symbol library.
Or

To go directly to a different library, click the Select Library button , choose a symbol category (for example, Animals-
Plants), and then select the library you want to view. 
The symbols from that library appear on the palette.

{button ,AL("Changing idea symbols using the Symbol palette;Using the Symbol palette to add a specific symbol",0,`',`')} Related 
topics 



Changing symbol shapes using the Symbol Palette

There are hundreds of symbols available in the symbol libraries. After you choose a library, you can select a 
symbol from the library using the Symbol Palette.

To change a symbol shape using the Symbol palette:

1 Select the symbol you want to change.

2 Click the symbol icon you want on the palette.

Tip… If you hold the pointer over a library symbol for a few seconds, you see a larger preview of the image.

{button ,AL("Using the symbol libraries",0,`',`')} Related topics 



Using animated symbols

Animated symbols can add a new dimension to your diagrams. A number of animated symbols are included in the 
symbol libraries. You can also create your own animated symbols by importing animated GIF files (see Importing 
graphics for symbols for more information). 

To determine if a symbol is animated, point to a symbol on the Symbol palette to view a preview of the symbol. For 
example, preview the lightbulb symbol in the Basic library. The lightbulb flashes on and off. 

You can turn off animation using the Application Properties. When you turn off animation, only the first frame of the 
symbol displays.

To turn off animated symbols:

1 On the File menu, choose Application Properties.

2 In the Application Properties dialog box, clear the Animate GIFs check box.



Copying and pasting a graphic onto a diagram

On the Macintosh*, you can copy and paste PICT, JPEG and GIF files. In Windows* you can copy and paste 
WMF, GIF, JPEG and BMP files.

Inspiration® automatically assigns a captioned text area below the graphic, making the graphic a captioned 
symbol. You can also position the caption inside the graphic. See Changing the location of the caption on an 
imported graphic.

Note… You can also install imported graphics into the symbol libraries. See Installing a custom graphic into a 
symbol library.

To copy and paste a graphic onto a diagram:

1 In the draw or paint program, copy the graphic you want to use to the clipboard.

2 Open the Inspiration diagram where you want to use the graphic.

3 Select the symbol you want to replace.

Tip… You can also click anywhere on the diagram to paste the graphic without replacing a symbol.

4 On the Edit menu, choose Paste.

Your graphic replaces the selected symbol. If the original symbol had text in it, the text appears as a caption 
below the new symbol. Or, if the symbol did not have text, there’s a text area below the symbol.

{button ,AL("Resizing a symbol or graphic;Changing the location of the caption on an imported graphic;Dragging and dropping a 
graphic into a diagram;Inserting a graphic from a file;Installing a custom graphic into a symbol library",0,`',`')} Related topics 



Importing graphics for symbols

You can use a graphic from a draw or paint program to represent an idea. You can also use a scanned photograph 
or any other graphic image as an idea symbol. 

On the Macintosh*, you can import PICT, JPEG and GIF files. In Windows* you can import WMF, BMP, GIF and 
JPEG files.

There are several ways to import a graphic:

Copy and paste a graphic onto a diagram

Drag and drop a graphics file onto a diagram

Insert a graphic from a file

Inspiration automatically assigns a captioned text area below an imported graphic, making the graphic a captioned 
symbol. You can also position the caption inside the graphic. See Changing the location of the caption on an 
imported graphic.

Note… You can also install imported graphics into the symbol libraries. See Installing a custom graphic into a 
symbol library.



Dragging and dropping a graphics file onto a diagram

On the Macintosh*, you can drag and drop PICT, JPEG and GIF files. In Windows* you can drag and drop WMF, 
BMP, GIF and JPEG files.

Inspiration® automatically assigns a captioned text area below the graphic, making the graphic a captioned 
symbol. You can also position the caption inside the graphic. See Changing the location of the caption on an 
imported graphic.

Note… You can install imported graphics into the symbol libraries. See Installing a custom graphic into a 
symbol library.

To drag and drop a graphics file onto a diagram:

1 Open the folder containing the source file (the graphic you want to place in your diagram). Arrange the program 
windows so that both the source file and the Inspiration window are visible. You must be able to see the 
information you want to drag as well as the location where you want to drop it.

2 Select the graphics file, and then drag it into the location you want it to appear.

Tip… You can also select multiple files and drag them onto the diagram.

3 Release the mouse button.

Note… You can also open the file containing the graphic and drag and drop the graphic onto your diagram; 
however, support for drag and drop of graphics varies from program to program. If you experience difficulty 
dragging and dropping a graphic directly from another program into Inspiration, make sure the program 
supports drag and drop.

{button ,AL("Resizing a symbol or graphic;Changing the location of the caption on an imported graphic;Inserting a graphic from a 
file;Copying and pasting graphics from other programs;Installing a custom graphic into a symbol library",0,`',`')} Related topics 



Inserting a graphic from a file

On the Macintosh*, you can import PICT, JPEG and GIF files. In Windows* you can import WMF, BMP, GIF and 
JPEG files.

Inspiration® automatically assigns a captioned text area below the graphic, making the graphic a captioned 
symbol. You can also position the caption inside the graphic. See Changing the location of the caption on an 
imported graphic.

Note… You can install imported graphics into the symbol libraries. See Installing a custom graphic into a 
symbol library.

To insert a graphic from a file:

1 Click on the diagram where you want to place the graphic.

2 On the Edit menu, choose Insert Graphic.

3 Select the file you want to insert, and then click Open.

The graphic appears on the diagram.

{button ,AL("Resizing a symbol or graphic;Changing the location of the caption on an imported graphic;Copying and pasting 
graphics from other programs;Dragging and dropping a graphic into a diagram;Installing a custom graphic into a symbol 
library",0,`',`')} Related topics 



Changing the location of the caption on an imported graphic

When you import a graphic into a diagram, Inspiration® automatically places the text area beneath the graphic, 
making it a captioned symbol. You can also place the caption inside the graphic if you wish.

To change the location of the caption on an imported graphic:

1 Select the graphic.

2 On the Symbol menu, choose Captioned Symbol.

The text box is now inside the graphic.

Note… When the Captioned Symbol command is on it has a check next to it. When you choose the command 
it turns it off.



Using the custom strip symbol

You can use the custom strip symbol to easily create a special symbol with a name or icon in it. Custom strips 
leave room to add text, but still provide an image to relate to. 

Custom Strip Symbol

The custom strip symbol is one of the six standard symbols that appear in each symbol library on the Symbol 
palette. When you place the custom strip symbol in your diagram, the strip area is blank. You can enter text or 
draw a simple picture in the blank area. 

First, you place the custom strip symbol in your diagram. Then you add the text or graphic. After you create a 
custom strip symbol, you can save it to use in other diagrams by installing it in a symbol library. 

To install a custom symbol in a symbol library, see Installing a custom graphic into a symbol library

Note… If you display your diagram at a reduced size, strip symbols may appear solid because the image in the 
symbol is too small to reproduce.

{button ,AL("Adding a custom strip symbol;Adding a picture to a custom strip symbol;Adding text to a custom strip 
symbol;Copying and pasting graphics into a custom strip symbol (MacOS only)",0,`',`')} Related topics 



Adding a custom strip symbol

You can use the custom strip symbol to easily create a special symbol with a name or picture in it. Custom strips 
leave room to add text, but still provide an image to relate to. 

To add a custom strip symbol:

On the Symbol palette, click and drag the custom strip symbol to the location on the diagram where you 
would like it to appear.

{button ,AL("Adding a picture to a custom strip symbol;Adding text to a custom strip symbol;Copying and pasting graphics into a 
custom strip symbol (MacOS only)",0,`',`')} Related topics 



Adding text to a custom strip symbol

You can use the custom strip symbol to easily create a special symbol with a name or picture in it. Custom strips 
leave room to add text, but still provide an image to relate to. 

To add text to a custom strip symbol:

1 Add the custom strip symbol to your diagram. See Adding a custom strip symbol.

2 Select the custom strip symbol.

3 Click the strip area in the symbol or on the Symbol menu, choose Edit Custom Strip. 

 
The Strip Symbol Editor dialog box appears.

4 Click Text Editor.

5 Enter the text you want to appear in the strip area.

The text appears in the text box in the middle of the dialog box. The Preview image shows what the strip will 
look like.

Tip… To display a person’s name vertically one character at a time, enter the name one character at a time, 
pressing Return (Macintosh) or Enter (Windows) after each letter.

6 If necessary, change the font and text style using the drop-down lists.

7 When you finish, click OK.

The custom strip symbol appears in your diagram with the text you entered in the strip.

{button ,AL("Adding a picture to a custom strip symbol;Copying and pasting graphics into a custom strip symbol (MacOS 
only)",0,`',`')} Related topics 



Adding a picture to a custom strip symbol

You can use the custom strip symbol to easily create a special symbol with a name or picture in it. Custom strips 
leave room to add text, but still provide an image to relate to. 

To add a picture to a custom strip symbol:

1 Add the custom strip symbol to your diagram. See Adding a custom strip symbol.

2 Select the custom strip symbol.

3 Click the strip area in the symbol or on the Symbol menu, choose Edit Custom Strip.

 
The Strip Symbol Editor dialog box appears.

4 Click Fat Bits Editor.

5 Use the pointer to create a picture in the Fat Bits Editor box. 

Here are some techniques you can use.

Click a location to change a black pixel to white.
Click and drag to draw a continuous line.
To draw a thinner line, hold down the Command key (Macintosh) or Ctrl key (Windows) as you draw.
To draw an even thinner line, hold down the Option key (Macintosh) or Ctrl+Shift keys (Windows) while you 

draw.
6 To erase your drawing and begin again, click the Clear button.

7 When you finish, click OK.

The custom strip symbol appears in your diagram with the picture you drew in the strip.

{button ,AL("Adding text to a custom strip symbol;Copying and pasting graphics into a custom strip symbol (MacOS only)",0,`',`')} 
Related topics 



Copying and pasting a graphic into a custom strip symbol (MacOS only)

On a Macintosh, you can copy and paste a graphic into a custom strip symbol. 

To copy and paste a graphic into a custom strip symbol:

1 In a drawing or graphics program, copy the graphic to the clipboard.

2 Open the Inspiration document in which you want to add the graphic to a custom strip symbol.

3 Add a custom strip symbol to your diagram. See Adding a custom strip symbol.

4 Click the strip area in the symbol.

 
The Strip Symbol Editor dialog box appears.

5 Click Paste.

The graphic appears in the strip. It is automatically resized to fit inside the strip area.

6 Click OK.

{button ,AL("Adding text to a custom strip symbol;Adding a picture to a custom strip symbol",0,`',`')} Related topics 



Resizing a symbol or graphic

You can manually change the size of any symbol or imported graphic. 

To resize a symbol or graphic:

1 Select the graphic.

2 Drag a handle at any corner of the graphic to increase or reduce the size of the graphic.

Tip… To retain the height to width proportions of the graphic, hold down the Command key (Macintosh) or Ctrl 
key (Windows) as you drag.

 
3 When the graphic is the size you want, release the mouse button.

Tip… You can return a graphic to its original size by choosing Original Size Graphic on the Edit menu. 



Returning a graphic to its original size

After you resize a graphic or symbol, you can return it to its original size.

To return a graphic to its original size:

1 Select the graphic.

2 On the Edit menu, choose Original Size Graphic.

The graphic changes back to the size it was when you pasted it into your document.



Changing the fill color of a symbol

1 Select the symbol or symbols you want to change.

2 Do one of the following:

On the Draw toolbar, click the Fill Color button, and then select the color you want.

Or

On the Effect menu, choose Fill Color, and then select the color you want.

Note… To change the colors of a multicolor symbol, or an imported GIF, see Changing the color of multicolor 
symbols.

{button ,AL("Adding a pattern to a symbol;Changing text color;Changing the colors of a multicolor symbol;Changing the line color 
for a symbol",0,`',`')} Related topics 



Changing the line color of a symbol

The line color includes the border or frame around the symbol and the shadow.

To change the line color of a symbol:

1 Select the symbol or symbols you want to change.

2 Do one of the following:

On the Draw toolbar, click the Line Color button, and then select the color you want.

Or

On the Effect menu, choose Line Color, then select the color you want. 

Note… Changing the line color on color versions of Inspiration® symbols changes the color of the frame and 
the shadow around the image.

{button ,AL("Adding a shadow to a symbol;Adding a pattern to symbol borders;Changing the fill color of a symbol",0,`',`')} Related 
topics 



Changing the colors of a multicolor symbol

You can change the colors of any multicolor symbol in the symbol libraries. You can also change the color of 
multicolor GIFs that you import.

To change the colors of a multicolor symbol:

1 Select the symbol for which you want to change colors.

2 Do one of the following:

Click the Multicolor button on the Draw toolbar.

 
Or

On the Effect menu choose Multicolor.
3 The existing colors on the symbol appear on a menu listed in order of most frequently occurring to least 

frequently occurring. Click the arrow next to a color to choose a new color from the color menu.

Tip… After you choose new colors, you can click Revert on the color menu to return the symbol to its original 
colors.



Changing the thickness of a frame

1 Select the symbol or symbols for which you want to change the thickness of the frame.

2 On the Effect menu, choose Line Thickness, then select the line thickness you want to use.

{button ,AL("Adding a shadow to a symbol;Changing symbol borders to a dashed line;Changing the line color for a 
symbol",0,`',`')} Related topics 



Changing a frame to a dashed line

1 Select the symbol or symbols for you which want to change the frame to a dashed line.

2 On the Effect menu, choose Dashed Lines.

{button ,AL("Adding a shadow to a symbol;Changing the line color for a symbol",0,`',`')} Related topics 



Adding a shadow to a frame

1 Select the symbol or symbols to which you want to add a shadow.

2 On the Symbol menu, choose Shadow.

When there’s a check mark next to Shadow on the menu, it means the feature is turned on.



Adding a pattern to a symbol

1 Select the symbol or symbols to which you want to add a pattern.

2 On the Effect menu, choose Fill Pattern, then select the pattern you want. 

 
We added a white text background to the symbol with the fill pattern.

{button ,AL("Changing the fill color of a symbol;Changing the text background to white",0,`',`')} Related topics 



Adding a pattern to a symbol line or frame

1 Select the symbol or symbols to which you want to add a pattern to the symbol line or frame.

2 On the Effect menu, choose Line Pattern, then select a pattern for the line or frame. 

{button ,AL("Changing the line color for a symbol",0,`',`')} Related topics 



Changing text background to white

1 Select the symbol or symbols with the text background you want to change.

2 On the Effect menu, choose White Text Background.

The area directly behind your text turns white.

{button ,AL("Adding a pattern to a symbol",0,`',`')} Related topics 



Managing the symbol libraries

You can tailor the Symbol palette to make it more convenient to access symbols you use most often. 

For example, you can create a library that includes symbols from other libraries, as well as graphics you’ve 
imported into Inspiration® and objects you draw using the Draw tools. You can also delete a custom symbol. You 
can also easily share symbol libraries with other computers.

What do you want to do?

Create a new symbol library 

Create a new symbol category 

Copy a symbol library 

Move a symbol between libraries

Delete a symbol from a library 

Install a custom graphic into a symbol library 

Copy and paste a graphic into a symbol library 

Drag and drop a graphic into a symbol library 

Import a graphics file into a symbol library 

Share a symbol library on your computer with another computer 



Installing a custom graphic into a symbol library

If you want a graphic to be available for use on a regular basis, install it into a symbol library. You can install 
imported graphics or custom symbols you create using the draw tools directly from your diagrams.

You can also import graphics created in other programs directly into the symbol libraries. On the Macintosh*, you 
can import PICT, JPEG and GIF files. In Windows*, you can import WMF, BMP, JPEG and GIF files. To import a 
graphic into a symbol library, see the following topics:

Copying and pasting a graphic into a symbol library

Dragging and dropping a graphics file into a symbol library

Importing a graphics file into a symbol library.

To install a custom graphic on your diagram into a symbol library:

1 Select the graphic on the diagram that you want to install.

2 On the Symbol palette, display the library to which you want to add the graphic. 

Note… There must be an open slot at the bottom of the library in order to add the symbol. If there are no open 
slots in the library, Inspiration® creates a new library called User 1 under the Custom category. When no slots 
are available in User 1, Inspiration creates a User 2 library and so on. To create a new library for custom 
symbols, see Creating a new symbol library.

3 On the Utility menu, choose Install User Symbol.

The Symbol Size dialog box appears.

4 Select Standard Symbol Size or Actual Size, and then click OK.

Choose Standard Symbol Size to size the symbol equivalent to the other Inspiration symbols.
Choose Actual Size to retain the original size of the graphic.

When your symbol is installed, it appears at the bottom of the Symbol palette entries. It’s now ready for your 
use.

{button ,AL("Deleting a symbol from a symbol library;Moving a symbol to another library",0,`',`')} Related topics 



Copying and pasting a graphic into a symbol library

You can copy and paste graphics created in other programs directly into the symbol libraries. On the Macintosh*, 
you can copy and paste PICT, JPEG and GIF files. In Windows*, you can copy and paste BMP, WMF, JPEG and 
GIF files.

To copy and paste a graphic into a symbol library:

1 Copy the graphic to the clipboard.

2 On the Utility menu, choose Edit Symbol Libraries.

The Edit Symbol Libraries dialog box appears.

3 On the Library 1 drop-down list, select the library to which you want to paste the graphic.

Note… There must be an open slot at the bottom of the library in order to add the symbol. If there are no open 
slots in the library, Inspiration® creates a new library called User 1 under the Custom category. When no slots 
are available in User 1, Inspiration creates a User 2 library and so on. To create a new library for imported 
symbols, see Creating a new symbol library.

4 Click Paste Graphic.

The Symbol Size dialog box appears.

5 Select Standard Symbol Size or Actual Size and then click OK.

6 In the Label box, enter a name for the symbol.

7 Click OK.

When your symbol is installed, it appears at the top of the Symbol palette entries. It’s now ready for your use.

{button ,AL("Deleting a symbol from a symbol library;Moving a symbol to another library",0,`',`')} Related topics 



Importing a graphics file into a symbol library

You can import graphics files created in other programs directly into the symbol libraries. On the Macintosh*, you 
can import PICT, JPEG and GIF files. In Windows*, you can import BMP, WMF, JPEG and GIF files.

To import a graphics file into a symbol library:

1 On the Utility menu, choose Edit Symbol Libraries.

The Edit Symbol Libraries dialog box appears.

2 On the Library 1 drop-down list, select the library to which you want to import the graphic.

Note… There must be an open slot at the bottom of the library in order to add the symbol. If there are no open 
slots in the library, Inspiration® creates a new library called User 1 under the Custom category. When no slots 
are available in User 1, Inspiration creates a User 2 library and so on. To create a new library for imported 
symbols, see Creating a new symbol library.

3 Click Import Graphic.

4 Select the graphic you want to install, and then click Open.

The Symbol Size dialog box appears.

5 Select Standard Symbol Size or Actual Size, and then click OK.

6 In the Label box, enter a name for the symbol.

7 Click OK.

When your symbol is installed, it appears at the top of the Symbol palette entries. It’s now ready for your use.

{button ,AL("Deleting a symbol from a symbol library;Moving a symbol to another library",0,`',`')} Related topics 



Dragging and dropping a graphics file into a symbol library

You can drag and drop graphics files created in other programs directly into the symbol libraries. On the 
Macintosh*, you can drag and drop PICT, JPEG and GIF files. In Windows*, you can drag and drop BMP, WMF, 
JPEG and GIF files.

To drag and drop a graphics file into a symbol library:

1 Open the folder containing the source file (the graphic you want to install into the symbol library). Arrange the 
program windows so that both the source file and the Symbol palette are visible. You must be able to see the 
information you want to drag as well as the location where you want to drop it.

2 On the Symbol palette, select the library to which you want to install the graphic.

Note… There must be an open slot at the bottom of the library in order to add the symbol. If there are no open 
slots in the library, Inspiration® creates a new library called User 1 under the Custom category. When no slots 
are available in User 1, Inspiration creates a User 2 library and so on. To create a new library for custom 
symbols, see Creating a new symbol library. 

3 Select the graphic, and then drag it to the Symbol palette.

4 Release the mouse button.

The Symbol Size dialog box appears.

5 Select Standard Symbol Size or Actual Size, and then click OK.

When your symbol is installed, it appears at the top of the Symbol palette entries. It’s now ready for your use.

Note… You can also open the file containing the graphic and drag and drop the graphic onto the Symbol 
palette; however, support for drag and drop of graphics varies from program to program. If you experience 
difficulty dragging and dropping a graphic directly from another program into Inspiration, make sure the 
program supports drag and drop.

{button ,AL("Deleting a symbol from a symbol library;Moving a symbol to another library",0,`',`')} Related topics 



Moving a symbol to another library

You can move symbols between libraries using the Edit Symbol Libraries dialog box. When you move a symbol, 
Inspiration® copies the symbol to the new location.

To move a symbol to another library:

1 On the Utility menu, choose Edit Symbol Libraries.

The Edit Symbol Libraries dialog box appears. 

2 On either the Library 1 or the Library 2 drop-down list, display the library to which you want to add one or more 
symbols.

When you open the dialog box, Library 1 displays the current symbol library in Diagram view.

3 On the other library drop-down list, display the library that contains the symbol you want to copy.

4 Select the symbol you want to copy, then drag it to the other library.

As you drag the symbol, you see its outline. When you position it over the other library, a red line appears in 
the location where the symbol will be placed. 

5 When the symbol is in the location you want, release the mouse button.

A copy of the symbol appears in its new location.

Note… You can also change the order of symbols within a library. Click and drag a symbol to move it to a new 
location in the same library.

6 In the Label box, enter a name for the symbol.

If the symbol already has a name, you can change it if you want. In Diagram view, the symbol’s label 
appears in the status bar when you move the pointer over the symbol in the Symbol palette.

7 Copy as many symbols from library to library as you wish.

You can select different libraries from the Library 1 or Library 2 drop-down lists as needed.

8 When you finish, click OK.

If you change your mind, click Cancel.

{button ,AL("Copying a symbol library;Creating a new symbol library",0,`',`')} Related topics 



Deleting a symbol from a library

When you delete a symbol from a library, it is no longer available in the symbol libraries to use in your new 
documents. 

To delete a symbol from a library:

1 On the Utility menu, choose Edit Symbol Libraries.

The Edit Symbol Libraries dialog box appears. 

2 On either the Library 1 or Library 2 drop-down list, display the library on which you want to delete a symbol.

Note… A symbol can’t be deleted if it appears in the current document.

3 Select the symbol, then drag it to the Trash icon in the Edit Symbol Library dialog box. As you drag the symbol, 
you see its outline. 

4 When the symbol outline covers the Trash icon, release the mouse button.

5 When you finish, click OK.

If you change your mind, click Cancel.

{button ,AL("Deleting a symbol library",0,`',`')} Related topics 



Copying a symbol library

A symbol library is an INL file stored in the Inspiration® Libraries 6 folder inside the Inspiration 6 folder.

To copy a symbol library:

1 Navigate to the Inspiration 6 folder, and double-click it to open it.

2 Double-click the Inspiration Libraries 6 folder.

3 Double-click the folder that contains the symbol library. 

Note… The name of the folder is the Category name that the library appears under on the Symbol palette, for 
example Animals-Plants.

4 Select the symbol library file.

Note… The name of the file is the Library name that appears on the Symbol palette plus the INL extension, for 
example Birds.inl.

5 Copy the file.

To share the symbol library with another computer, see Sharing a symbol library with another computer.



Deleting a symbol library

A symbol library is a single file stored in the Inspiration Libraries 6 folder inside the Inspiration 6 folder. When you 
delete a symbol library, it is no longer available on the Symbol palette. 

To delete a symbol library:

1 Navigate to the Inspiration 6 folder, and double-click it to open it.

2 Double-click the Inspiration Libraries 6 folder.

3 Double-click the folder that contains the symbol library.

Note… The name of the folder is the Category name that the library appears under on the Symbol palette, for 
example Animals-Plants.

4 Select the symbol library file.

Note… The name of the file is the Library name that appears on the Symbol palette plus the INL extension, for 
example Birds.inl.

5 Drag the file to the Trash icon (Macintosh) or Recycle icon (Windows) on the desktop. 

{button ,AL("Deleting a symbol from a symbol library",0,`',`')} Related topics 



Creating a new symbol library

You can create your own symbol libraries for graphics you import or create using the draw tools. You can also copy 
the symbols you use frequently into a custom symbol library.

To create a symbol library:

1 On the Utility menu, choose New Symbol Library.

The Add New Library dialog box appears.

2 On the Category drop-down menu, choose the category you want the new library to appear under.

Note… You can place a symbol library under any category on the Symbol palette. If you do not choose a 
category, Inspiration® places a new symbol library under the Custom category.

3 Enter the name for the new library.

4 Click OK to create the library or click Cancel to exit without creating a new library. 

You can also create your own symbol categories. See Creating a new symbol category.



Creating a new symbol category

You can create your own symbol categories for symbol libraries that you use frequently. A category is a group of 
libraries with similar characteristics, for example Animals-Plants.

To create a new symbol category:

1 Quit Inspiration®.    On the File menu choose Quit (Exit).

2 Create a new folder in the Inspiration Libraries 6 folder inside the Inspiration folder.

3 Name the folder the same name as the category you want to appear on the Symbol palette.

For example, if you want a category called “Windsurfing,” then name the folder “Windsurfing.” 

4 Restart Inspiration.

The new category appears alphabetically in the list of categories on the Symbol palette. You can now place 
symbol libraries into the new category. 

{button ,AL("Creating a new symbol library",0,`',`')} Related topics 



Sharing a symbol library with another computer

You can share a symbol library with another computer running Inspiration® by copying the symbol library file to a 
floppy disk (or network server), and then copying the file to the Inspiration Libraries 6 folder inside the Inspiration 6 
folder on the other computer. 

To share a symbol library with another computer:

1 Save the symbol library file to a floppy disk (or network server). See Copying a symbol library.

2 Insert the floppy disk in the computer (or connect to the network server) with which you want to share the 
symbol library.

3 Navigate to the Inspiration 6 folder.

4 Open the Inspiration Libraries 6 folder.

5 Select the symbol category under which you want the library to appear (for example, Animals-Plants), and then 
open the folder 

6 Copy the symbol library file on the diskette or network server to the category folder.



Arranging symbols on a diagram

You can use the Arrange tool to arrange the symbols and links on your diagram into various types of tree charts or 
into a web in which your ideas radiate from your main idea. You can arrange the whole diagram or selected parts.

Note… Any objects or text you created using the tools on the Draw toolbar are not included when you 
rearrange your diagram.

To arrange symbols on a diagram:

1 To arrange all the symbols on the diagram, on the Diagram toolbar, click the Arrange button.

 
Or

On the Symbol menu, choose Arrange. 
The Arrange dialog box appears.

2 In the Diagram Type box, select the type of chart you want.

To retain a cluster arrangement, select Cluster. Inspiration® will adjust the arrangement for you. 

Tip… To preserve the left-to-right order between idea symbols and make only minor adjustments to the 
arrangement, select Clean Up Arrange. 

Tip… To size the symbols on your diagram by level, select Size By Level. The symbols at each level in the 
hierarchy are sized equivalently. The symbols at the top of the hierarchy are largest, and the symbols at the 
bottom are smallest.

3 Click OK.

Note… You can also arrange part of your diagram. To arrange part of your diagram, select the symbol from 
which you want to start the arrange. Click the Arrange button on the toolbar. In the Arrange dialog box, clear the 
Entire Diagram check box. 



Drawing different shaped links

You can change the shape of a link between symbols to reinforce the relationship between ideas, to give the link 
specific meaning or to make links appear more formal or more casual.

Here are the shapes you can use:

Standard links attach symbols using straight lines.

Auto-90 links attach symbols with 90-degree angles, which make them appear more formal. 

Curved links appear more casual or friendly. There are two types of curves you can use one with a single bend 
and one with a double bend. 

Custom links bend in the directions in which you draw them. You might use a custom link to show a 
communication link or to bend a link around another unrelated symbol.



Drawing a standard link

Standard links attach symbols using straight lines.

 

To draw a standard link:

1 Select the link or links you want to change.

2 On the Link menu, choose Standard.



Drawing a 90-degree link

Auto-90 links attach symbols with 90-degree angles, which make them appear more formal. 

 

To draw a 90-degree link:

1 Select the link or links you want to change. 

2 On the Link menu, choose Auto-90.



Drawing a curved link

Curved links appear more casual or friendly. There are two types of curves you can use one with a single bend 
and one with a double bend. 

 

To draw a curved link:

1 Select the link or links you want to change.

2 On the Link menu, choose Curved Link (3 pts) for a rounded curve. 

Or

On the Link menu, choose Curved Link (4 pts) for a snake-like curve.

{button ,AL("Adjusting a curved link;Drawing a custom link",0,`',`')} Related topics 



Adjusting a curved link

You can change the degree of the curves in both types of curved links. 

To adjust a curved link:

1 Select the curved link you want to adjust.

2 Drag one of the link handles (the red rectangles) that appears at the ends or in the middle of the link.

Tip… You may want to move the end of a link so it attaches at a different place. To move an end of a link, click 
and drag its link handle to its new location. 

{button ,AL("Using a curved link",0,`',`')} Related topics 



Drawing a custom link

Custom links are made up of segments. They are often used to show that communication occurs between two 
symbols. 

 

To draw a custom link:

1 Select the symbol where you want the link to start.

2 Drag one of the diamond-shaped handles and draw the first segment of the link.

3 Press Option (Macintosh) or Ctrl+Shift (Windows) and drag in the new direction to draw the second segment of 
the link.

You don’t need to hold down the Option (Ctrl+Shift) key(s). Just press and release it whenever you want to 
change direction.

4 Make as many segments as you need.

5 To complete the link, drag it over the symbol to which you want to attach the link, then release the mouse 
button when the link is in the position you want.

Tip… You can make new segments in a link you’ve already drawn. Select the link, then press Option 
(Macintosh) or Ctrl+Shift (Windows) as you click on the link where you want to make the segment, then drag 
the segment.

{button ,AL("Removing all segments from a link",0,`',`')} Related topics 



Removing all segments from a link

You can remove all segments you’ve added to a custom link. 

To remove all segments from a link:

1 Select the link or links where you want to remove the segments.

2 On the Link menu, choose Straighten Link to return the link to a straight line. 

{button ,AL("Drawing a custom link",0,`',`')} Related topics 



Reversing a link

You can change the direction of a link using the Reverse Link command on the Link menu. Doing this reverses the 
relationship between the ideas and affects your outline structure.

To reverse a link:

1 Select the link you want to reverse.

2 On the Link menu, choose Reverse Link. 

The link changes so that the arrow points in the opposite direction. 

Note… When you reverse a link, it changes the relationship of topics in Outline view.



Changing the arrowheads on a link

You can change the direction and the style of arrowheads on links. To show a two-way relationship between two 
idea symbols, for example, you could add arrowheads to both ends of the link. Other times, you may want no 
arrowheads for a link.

Note… Changing the arrowhead direction on a link has no effect on the relationship between the ideas. 

To change the arrowhead on a link:

1 Select the link for which you want to the change the arrowhead.

2 On the Link menu, do one or both of the following:

Choose Arrow Head Starting Point, then select the arrowhead style you want.

Or

Choose Arrow Head Ending Point, then select the arrowhead style you want.

Tip… If you don’t want any arrowheads, select None on both menus.



Keeping exact connecting points between a link and symbol

Whenever you move a symbol on your diagram, Inspiration® automatically moves the link with it, adjusting where 
the link attaches to the symbol, if necessary. If you don’t want Inspiration to reposition the link that is, you want to 
keep the link attached to an exact connecting point

you can freeze it in place. 

To freeze a link:

1 Select the link or links you want to freeze.

2 On the Link menu, choose Freeze Link Position.

Now when you drag a symbol, the point at which the link connects will not change. 

Although freezing stops Inspiration from repositioning a link when you move a symbol, you can always move the 
link yourself. Just click on the end of the link and drag it to another position on the symbol.



Hiding a link

If you want, you can hide a link between two symbols on your diagram. When you hide a link, the relationship 
between ideas remains the same, and continues to show in your outline. 

To hide a link:

1 Select the link or links that you want to hide.

2 On the Link menu, choose Hide Link.

A check mark appears next to the command on the menu to show you that it is turned on. Any text you 
added to the link remains visible, even though the link is hidden.

{button ,AL("Showing a hidden link",0,`',`')} Related topics 



Showing a hidden link

1 To show a hidden link, click the end point where the link would be to select it. 

When the two handles and the text box appear, you know the link is selected.

2 On the Link menu, choose Hide Link again to turn the feature off. 

{button ,AL("Hiding a link",0,`',`')} Related topics 



Changing the color of a link

1 Select the link or links you want to color.

2 On the Draw toolbar, click the Line Color button, then select the color you want.

Or

On the Effect menu, choose Line Color, and then select the color you want. 
All selected links are automatically recolored.
Tip… To select all the links in your diagram so you can change them all at the same time, on the Edit menu, choose 
Select, then select Links. Then make the changes you want. 



Changing the style of a link

You have several options available to make your links  both the lines and the arrowheads

more distinctive. You might use a patterned link or a dashed line to show a tentative connection between ideas, for 
example, and a thicker, solid line to show a stronger connection. 
After you create a link you like, you can use the New Look button to save that look as the new default so you can use 
it for new links you draw. See Setting a new look for links.

What do you want to do?

Change the thickness of a link 

Fill a link with a pattern 

Change a link to a dashed line 



Changing the thickness of a link

1 Select the link or links you want to change.

2 On the Effect menu, choose Line Thickness, then select the thickness you want.

{button ,AL("Filling a link with a pattern",0,`',`')} Related topics 



Filling a link with a pattern

1 Select the link or links you want to change. 

2 On the Effect menu, choose Line Pattern, then select the pattern you want.

All parts of the link lines, including the arrowheads, are filled with the pattern you selected.

{button ,AL("Changing the color of a link;Changing a link to a dashed line",0,`',`')} Related topics 



Changing a link to a dashed line

1 Select the link or links you want to convert to dashed lines.

2 On the Effect menu, choose Dashed Lines.

The selected links change to dashed lines. The arrowheads remain solid.



Changing the color of the background

When you’re working in Diagram view, you can change the color of the background that appears on your screen.

To change the color of the background:

On the Effect menu, choose Background Color, and then select the color you want. 



Adding a frame to a symbol

You can add frames to your symbols and then change the color and style of the frame. 

To add a frame to a symbol:

1 Select the symbol to which you want to add a frame.

2 On the Symbol menu, choose Frame.

A frame appears around the symbol.

3 To turn off the frame, on the Symbol menu, choose Frame.

{button ,AL("Adding a shadow to a symbol;Changing the thickness of a frame;Adding a pattern to symbol borders;Changing the 
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Adding Internet hyperlinks to a diagram

A hyperlink (also referred to as an “URL” or “Internet address”) is a “hot spot” that allows you to jump from 
Inspiration® to a location on the Internet. To add a hyperlink to your diagram, you can type an URL (Internet 
address) where you want the hyperlink to appear or you can assign a URL to selected text in the diagram. When 
you click a hyperlink, your browser starts and opens the URL.

You can add hyperlinks to symbols, links, notes text and drawings you create with the Draw tools. The hyperlinks 
are active in Outline view and Notes List view as well.

When you export your diagram to a Web page, the hyperlinks are also active in the exported document. To export 
a diagram to a Web page, see Using Inspiration documents with other applications.
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Adding a hyperlink

You can add hyperlinks to topics, subtopics, symbols, links, notes text and drawings you create with the Draw 
tools. The hyperlinks are active in Diagram view, Outline view and Notes List view.

Note… To add a hyperlink, make sure Hyperlink Auto-detection is turned on. On the Utility menu, choose 
Internet, and then select Hyperlink Auto-detection. A check mark next to the menu item means it is turned on. 

To add a hyperlink:

Type the Internet address (URL) where you want the hyperlink to appear. For example: 
www.inspiration.com

After you complete adding the hyperlink, when you move the mouse pointer over the link, the pointer becomes a 

 icon. This icon indicates the hyperlink is “live” and ready to start your browser. 

{button ,AL("Editing a hyperlink;Removing a hyperlink;Turning off automatica detection of URL hyperlinks;Turning off 
hyperlinks",0,`',`')} Related topics 



Adding a hyperlink to selected text

You can assign hyperlinks to selected text in topics, subtopics, symbols, links, notes text and drawings you create 
with the Draw tools. The hyperlinks are active in Diagram view, Outline view and Notes List view.

To add a hyperlink to selected text:

1 Select the text to which you want to assign the hyperlink.

2 On the Utility menu, choose Internet, and then select URL Hyperlink.

The URL Hyperlink dialog box appears.

3 The text you selected appears in the Hyperlink Text box.

Tip… You can edit the text in the Hyperlink Text box if you wish.

4 In the Hyperlink Address box, enter the Internet address (URL) that you want to assign to the text. For example:

www.inspiration.com

5 Click OK.

Note… When you assign a URL at the end of a text area (for example, the text at the end of a topic or symbol), 
text you type after the hyperlink is included in the hyperlink. To prevent text that follows a hyperlink from being 
included in the hyperlink, type all the text in the symbol or topic first, and then add the hyperlink.

{button ,AL("Editing a hyperlink;Removing a hyperlink",0,`',`')} Related topics 



Editing a hyperlink

1 Click directly before the first character in the link or directly after the last character.

2 Drag the mouse pointer across the link, and then release the mouse button.

Tip… You can also use the arrow keys to move the cursor inside the link.

3 Edit the text, and then click away from the link.

Note… You can also turn off hyperlinks when you want to edit a hyperlink. Turning off hyperlinks prevents you 
from unintentionally starting your browser while you are editing a hyperlink. See Turning off hyperlinks.



Removing a hyperlink

Select the hyperlink, and then press Clear (Macintosh) or Delete (Windows).
Or

1 Select the text to which the Internet address (URL) is assigned.

2 On the Utility menu, choose Internet, and then select URL Hyperlink.

The URL Hyperlink dialog box appears.

3 Click Remove Hyperlink.

4 Click OK.



Turning off automatic detection of URL hyperlinks

You can turn off automatic detection of URL hyperlinks if you do not want an Internet address (URL) that you add 
to your document to be automatically formatted as a hyperlink.

To turn off automatic detection of URL hyperlinks:

Do one of the following:
On the Utility menu, choose Internet, and then select URL Hyperlink Auto-detection to clear the check mark 
and turn off the feature.

Or

On the File menu, choose Application Properties. Clear the URL Hyperlink Auto-detection check box.



Turning off hyperlinks

You can turn off automatic hyperlinks if you do not want Internet addresses (URLs) that you add to your document 
to be active. This can be useful when you want to edit Internet addresses in a document.

To turn off hyperlinks:

Do one of the following:
On the Utility menu, choose Internet, and then select Live Hyperlinks to clear the check mark and turn off the 
feature.

Or

On the File menu, choose Application Properties. Clear the Live Hyperlinks check box.



Aligning symbols

When you are fine tuning your diagram you may find it useful to align symbols in various ways. 

To align symbols with each other:

1 Select the symbols you want to align.

You need to select at least two symbols to make the Align command available.

2 On the Symbol menu, choose Align, then select the arrangement you want.

Each choice on the Align submenu shows how the selected symbols will align.

The symbols rearrange themselves to reflect your choice.



Spacing symbols evenly

Use the Evenly Space Symbols option when you want to have an even amount of space between certain symbols.

To space symbols evenly:

1 Select the symbols you want to arrange.

2 You need to select at least three symbols to make the Evenly Space command available. 

3 On the Symbol menu, choose Evenly Space, then select Horizontal or Vertical.



Making symbols the same size

If you want to make a symbol the exact same size as another symbol, but you don’t want to change anything else, 
you can use the Paste Size command. 

To make symbols the same size:

1 Select the symbol that has the size you want to use.

2 On the Edit menu, choose Copy.

A copy of the symbol is now available on the clipboard.

3 Select the symbols you want to make the same size.

4 On the Edit menu, choose Paste Size.

You can size symbols by level using the Arrange button. See Arranging symbols on a diagram.



Positioning a symbol precisely

Sometimes, you just want to move a symbol a tiny bit to get the alignment just right. Inspiration® lets you move 
your symbols one pixel at a time using the Nudge tools on the Draw toolbar. 

Click the Nudge tool that points in the direction you want to move the symbol.

To position a symbol precisely:

1 Select the symbol or symbols you want to nudge. 

2 Click the arrow button on the toolbar that nudges the symbol in the direction you want to go.

Click the arrow button or click and hold down the arrow button until the symbol is in the right position.

Tip… You can also use Command+Shift+Arrow key (Macintosh) or Ctrl+Shift+Arrow key (Windows) to nudge 
symbols using your keyboard. For a complete list of keyboard shortcuts, see Using keyboard and mouse 
shortcuts.

Note… You don’t have to turn Grid Snap off to use the Nudge tools. They work the same way, whether the grid 
is on or off.

{button ,AL("Positioning symbols without grid snap",0,`',`')} Related topics 



Positioning symbols using grid snap

You can use grid snap to automatically position symbols within the squares of the grid. When the grid is on, the 
grid lines appear, and symbols snap to the grid when you move them.

Note… Grid snap doesn’t affect draw objects. 

To position symbols using grid snap:

On the Utility menu, choose Grid Snap. 
A check mark appears next to the command.

To turn off grid snap, choose Grid Snap on the Utility menu again.

Tip… To temporarily suspend Grid Snap, press the Option key (Ctrl+Shift keys) while dragging a symbol, then 
release the Option key (Ctrl+Shift keys) when the symbol is where you want it.

Tip… To specify the height and width of the grid, choose Diagram Properties on the File menu. Click the 
Options tab. Enter measurements in the Grid Width box and Grid Height box, and then click OK.

{button ,AL("Hiding the grid lines",0,`',`')} Related topics 



Hiding the grid lines

You can use the grid without the lines showing.

To hide the grid lines:

On the Utility menu, choose Grid Lines to remove the check in front of the command. 
To make the lines reappear, choose Grid Lines again.



Showing the rulers

You can use the rulers to position objects in your diagram horizontally and vertically.

To show the rulers:

On the View menu, choose Rulers.
One ruler appears across the top of the window and another ruler appears along the left side of the window.

To hide the rulers, on the View menu, choose rulers again to turn them off.

Tip… You can set the measurement units on the rulers to centimeters or inches. To set the measurement units, 
choose Application Properties on the File menu. On the Measurement Units drop-down menu, choose 
Centimeters or Inches.



Adjusting the diagram for page breaks

In Diagram view, you can have Inspiration® move any symbols split by a page boundary so that each symbol fits 
entirely on the page.

To adjust the diagram for page breaks:

On the Symbol menu, choose Adjust For Page Breaks.
The diagram is adjusted so that each symbol fits within the page.



Brand, name, or trademark owned by another company.



Using the menu and keyboard commands

Each menu is arranged in a table with their menu commands, keystrokes and a summary statement about each 
command. 

Here are the menus:

File menu 

Edit menu 

View menu 

Format menu 

Symbol menu 

Link menu 

Outline menu 

Effect menu 

Utility menu 

Window menu 

Help menu 



File menu

Menu
Command

MacOS 
Keystrokes

Windows 
Keystroke
s

Command Summary

New Command+N Ctrl+N Opens a new, untitled 
Inspiration document.

Open Command+O Ctrl+O Displays a list of 
Inspiration® 6 
documents and lets 
you open an existing 
document or import 
other documents.

Template Opens an Inspiration 
template document.

Family Opens the Family 
submenu.

Open Child F6 F6 Opens a new or 
existing Child 
document for the 
selected symbol or 
topic.

Open All 
Children

Opens all Child 
documents for the 
active window.

Open Entire 
Family

Opens all Child 
documents for the 
active document.

Open Any 
Child

Displays a list of Child 
documents in the 
active document so 
you can open one 
more.

Delete Child Deletes a Child 
document for the 
selected symbol or 
topic.

Adopt Makes an existing 
document into a Child 
document for the 
selected symbol or 
topic.

Close Command+W Ctrl+W Closes the active 
window.

Save Command+S Ctrl+S Saves the current 
document.

Save As Saves the current 
document with a new 
or different name or 
location.

Save As Template Saves the current 
document as a 
template.

Export Exports the outline or 
diagram information to 
another file format.

Revert To Saved Discards the changes 
to the current 
document and reads in 
the previously saved 
version.



Print Options Allows the setting of 
printing options, such 
as Fit to 1 Page, Print 
Symbol Handles, Print 
Entire Family and Print 
Hidden Subtopics.

Print Preview Command+; Ctrl+; Displays how a 
document will appear 
when printed.

Page Setup Contains standard 
choices for paper size 
and printing 
enhancements.

Print Command+P Ctrl+P Prints the current 
document.

Diagram Properties Sets default properties 
for diagrams: symbols, 
links, margins, 
header/footer and 
other options.

Outline Properties Sets default properties 
for outlines: topic font, 
margins, 
header/footer, layout, 
prefix and other 
options.

Application 
Properties

Sets default options for 
Inspiration: toolbars 
and other options.

Quit (Macintosh) or 
Exit (Windows)

Command+Q Ctrl+Q Exits Inspiration and 
returns to the Desktop.

Edit menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Undo Command+Z Ctrl+Z Reverses the last 
action.

Cut Command+X Ctrl+X Copies the selected 
items to the Clipboard 
and removes them 
from the document.

Copy Command+C Ctrl+C Copies the selected 
items to the Clipboard 
and leaves them in the 
document.

Paste Command+V Ctrl+V Pastes the contents of 
the Clipboard into the 
document.

Clear Delete Backspace 
or Delete

Deletes the selected 
items.

Scroll to Selection Command+9 Ctrl+9 Centers the selected 
item within the window.

Select Main Idea Command+M Ctrl+M Selects the Main Idea 
and centers it in the 
window.

Select All Command+A Ctrl+A Selects everything on 
your diagram or 
outline.

Select Opens the Select 
submenu.



Symbols Selects all symbols.

Links Selects all links.

Subtopics Command+ 
Shift+M

Ctrl+Shift+
M

Selects all subtopics.

This Level Command+ 
Shift+N

Ctrl+Shift+
N

Selects all items at the 
specified level.

Draw Objects Selects all draw 
objects.

Set New Look F5 F5 Sets the selected 
symbol or link as the 
default for new 
symbols or links.

Paste New Look Pastes the new default 
look on selected 
symbols or links.

Paste Size Command+
Shift+V

Ctrl+Shift+
V

Assigns the size of a 
selected symbol to one 
or more symbols in the 
diagram.

Paste Date Command+0
(zero)

Ctrl+0
(zero)

Inserts the current 
date into the selected 
item.

Original Size 
Graphic

Returns a resized 
imported graphic to its 
original size.

Insert Graphic Imports a graphic.

Publish
(MacOS* only) 

Opens the Create 
Publisher and 
Subscribe To 
submenu. These 
commands share 
information with other 
applications on an 
AppleTalk network. 
The commands are 
available on 
computers running 
with System 7.

Create 
Publisher 
(MacOS only)

Saves the items 
selected in the 
diagram to an edition 
file that can be shared 
with other users on the 
network.

Subscribe To 
(MacOS only)

Opens an edition file 
and copies it into the 
Inspiration® 
document.

Subscribe 
Options 
(MacOS only)

Allows the deletion of 
a publisher or 
subscriber, or change 
options that affect the 
publisher or 
subscriber.

Hide/Show 
Borders 
(MacOS only)

Shows or hides a thick 
rectangle around any 
publishers or 
subscribers.

View menu

Menu MacOS Windows 



Command Keystroke Keystroke Command Summary

Outline
(in Diagram view)

Command+T Ctrl+T Switches from 
Diagram to Outline 
view.

Diagram
(in Outline view)

Command+T Ctrl+T Switches from Outline 
to Diagram view.

Focus In Command+ 
Shift+X

Ctrl+Shift+
X

Displays a specific 
area of the diagram or 
outline. The rest of the 
document is 
temporarily hidden.

Focus Out Command+ 
Shift+Y

Ctrl+Shift+
Y

Returns to the full 
outline or diagram 
from a focused view.

Notes List View Displays a diagram as 
a text list. This 
simultaneously allows 
the display and 
development of notes 
text.

Zoom Opens a submenu of 
size options to reduce 
or enlarge the view of 
the diagram in the 
window.

Fit to Window Command+E Ctrl+E Reduces the view of 
the diagram so it fits in 
the window.

Zoom In Command+= Ctrl+= Enlarges the view of 
the diagram. Each 
Zoom In creates 
greater magnification. 
A diagram can be 
magnified up to 200% 
of its original size.

Zoom Out Command+- Ctrl+- Reduces the view of 
the diagram. Each 
Zoom Out reduces the 
size. A diagram can be 
reduced to 6% of its 
original size.

View Subtopics Contains viewing 
options for the 
selected topic.

Show/Hide Command+H Ctrl+H Shows or hides 
subtopics for the 
selected topic.

Show All Shows all hidden 
subtopics.

View Notes Text Contains viewing 
options for notes text.

Show/Hide Command+Y Ctrl+Y Shows or hides notes 
text for the selected 
symbol or topic.

Show All Shows all hidden 
notes text.

Hide All Hides all notes text.

Show Levels Command+8 Ctrl+8 Controls how many 
levels of detail are 
shown in Diagram or 
Outline view.



Page Lines Shows or hides page 
lines.

Rulers Command+
Shift+G

Ctrl+Shift+
G

Shows or hides the 
document rulers.

Symbol Palette F8 F8 Shows or hides the 
Symbol palette in 
Diagram view.

Toolbar Displays the Toolbar 
submenu.

Toggle On Command+
F8

Ctrl+F8 Displays the toolbars.

Toggle Off Command+
F8

Ctrl+F8 Hides the toolbars.

Diagram Shows or hides the 
Diagram toolbar.

Draw Shows or hides the 
Draw toolbar.

Outline Shows or hides the 
Outline toolbar.

Notes List 
View

Shows or hides the 
Notes List View 
toolbar.

Status Bar Shows or hides the 
Status bar.

Toolbar Style Displays the toolbar 
Style submenu.

Icon and Text Displays the toolbars 
using icons and text.

Icon Only Displays the toolbars 
using only icons.

Text Only Displays the toolbars 
using only text.

Tool Tips Shows or hides tips 
that identify tools 
onscreen.

Format menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Font Opens the Font 
submenu so you can 
select a new font for 
the selection.

Size Opens the Size 
submenu so you can 
select a new font size 
for the selection.

Increase Command+
Shift+>

Ctrl+Shift+
>

Increases the size of 
the text to the next 
point size on the list.

Decrease Command+
Shift+<

Ctrl+Shift+
<

Decreases the size of 
the text to the previous 
point size on the list.

Style Opens the Style 
submenu so you can 
select a new font style 
for the selection.

Bold Command +B Ctrl+B Changes text to bold.



Italic Command +I Ctrl+I Changes text to italic.

Underline Command +U Ctrl+U Changes text to 
underlined.

Outline
(MacOS only)

Changes text to 
outlined.

Shadowed 
(MacOS only)

Changes text to 
shadowed.

Condensed 
(MacOS only)

Changes text to 
condensed.

Superscript Changes text to 
superscript.

Subscript Changes text to 
subscript.

All Caps Changes text to all 
capitalized.

Text Justify Opens the Text Justify 
submenu so you can 
select a new text 
alignment for the 
selection.

Left Command+
Shift+L

Ctrl+Shift+
L

Aligns the text on the 
left margin.

Center Command+
Shift+C

Ctrl+Shift+
C

Centers the text.

Right Command+
Shift+R

Ctrl+Shift+
R

Aligns the text on the 
right margin.

Revert To Style Changes selective 
styling of text back to 
the original text style in 
the symbol.

Fractional Fonts
(MacOS only)

Command+
Shift+F

Improves the way your 
text looks onscreen 
and when you print.

Printer Fonts Wrap
(Windows only)

Makes the appearance 
of text in symbols 
onscreen parallel with 
the way text looks 
when you print.

Symbol menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Insert Symbol Inserts a symbol along 
a link, breaking the link 
and reconnecting it to 
the appropriate 
symbols. If multiple 
links are selected, the 
symbol is inserted and 
connected to all the 
links.

Delete Symbol 
(Keep Links)

Deletes a selected 
symbol and logically 
connects its links to 
the appropriate 
symbols.

Align Contains submenu 
with commands to 
align the tops, 
horizontal centers, 



bottoms, left sides, 
vertical centers or right 
sides of two or more 
symbols.

Evenly Space Takes three or more 
selected symbols and 
places equal amounts 
of space (vertically or 
horizontally) between 
them.

Arrange Command+7 Ctrl+7 Arranges the selected 
symbol and its 
subtopics into various 
tree charts, 
organizational charts 
or cluster diagrams.

Adjust for Page 
Breaks

Moves symbols so 
they are fully 
contained within a 
page boundary.

Group (Ungroup) Command+G Ctrl+G Joins selected 
symbols and draw 
objects so they move 
and change as a 
single object. 

If the items are already 
grouped, the 
command changes to 
Ungroup, which 
separates the grouped 
items back into 
separate symbols or 
objects.

Shadow Adds a drop-shadow 
to the selected 
symbols.

Frame Adds a frame to the 
selected symbols.

Captioned Symbol Changes the location 
of the text area for 
selected symbols. 
When checked, the 
text area is beneath 
the symbol.

Auto Symbol Grow Controls whether or 
not the selected 
symbol grows 
automatically to fit its 
text.

Standard Allows the selected 
symbols to grow 
vertically.

Proportional Allows the selected 
symbols to grow while 
maintaining their 
aspect ratio.

Off Allows a symbol to 
remain the same size 
as more text is added. 
The extra text is 
hidden, and can be 
viewed by double-
clicking the symbol.



Fixed Width Allows you to resize 
the symbol to a set 
width and have the 
symbol grow vertically 
as more text is added.

Edit Custom Strip Displays the Strip 
Symbol Editor dialog 
box for a selected 
Custom Strip Symbol, 
where you can add 
text or pictures to the 
symbol strip area. 

Change Main Idea Changes the Main 
Idea in a diagram and 
rebuilds the diagram 
and outline.

Link menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Arrow Head Starting 
Point

Contains submenu of 
arrow heads. Places a 
selected arrow head at 
the starting point of the 
link.

Arrow Head Ending 
Point

Contains submenu of 
arrow heads. Places 
an arrow head at the 
ending point of a link.

Standard Sets the link type for 
the selected link to a 
straight line.

Auto-90 Sets the link type for 
the selected link to 
horizontal and vertical 
lines at 90-degree 
angles.

Curved Link (3 pts) Sets the link type for 
the selected link to a 
Bezier curve-shaped 
link.

Curved Link (4 pts) Sets the link type for 
the selected link to a 
Bezier curve-shaped 
link with a snake 
shape.

Straighten Link Removes all bend 
points on a link and 
straightens it.

Freeze Link Position Command+, Ctrl+, Fixes a link in its 
current location on its 
symbols so that it’s not 
automatically adjusted. 

Reverse Link Flips the direction of 
the selected link both 
logically and visually.

Hide Link Hides and shows a 
link.

Outline menu

Menu MacOS Windows 



Command Keystroke Keystroke Command Summary

Add Topic Command+G Ctrl+G Creates a blank topic 
beneath and at the 
same level as the 
previously selected 
topic.

Insert Subtopic Command+K Ctrl+K Creates a blank 
indented subtopic 
beneath the previously 
selected topic.

Smart Topic Insert F9 F9 Inserts a new topic into 
an outline. If you select 
a topic that is followed 
by another topic at the 
same level, a new 
topic is inserted after 
the selected topic. If 
you select a topic that 
is followed by one or 
more visible subtopics, 
a new subtopic is 
inserted after the 
selected topic.

Insert Higher Level 
Topic

Command+J Ctrl+J Adds a new topic 
beneath the previously 
selected topic but at a 
higher level in the 
hierarchy.

Move Left Command+L Ctrl+L Moves a topic one 
position to the left and 
promotes it and its 
subtopics one level.

Move Right Command+R Ctrl+R Moves a topic one 
position to the right 
and demotes it and its 
subtopics one level.

Flip Up Command+’ Ctrl+’ Moves a topic up one 
position in the outline 
while keeping it at the 
same level.

Flip Down Command+/ Ctrl+/ Moves a topic down 
one position in the 
outline while keeping it 
at the same level.

Promote Command+[ Ctrl+[ Moves all the 
subtopics of the 
selected topic one 
position to the left and 
promotes them one 
level in the hierarchy.

Demote Command+] Ctrl+] Moves all of the topics 
that are at the same 
level and beneath the 
selected topic one 
position to the right 
and demotes them one 
level in the hierarchy.

Collect and Move Allows the gathering of 
several topics together 
and moves or copies 
them under one topic.

Split Topic Command+` Ctrl+` Breaks the selected 
topic into two topics.



Show Prefix Shows or hides prefix 
labels on the screen.

Set Notes Text Command+E Ctrl+E Splits the notes text 
and adds the text 
that’s in front of the 
cursor to the topic text.

Set Page Break Sets the page breaks 
for a document.

Sort Ascending Sorts topic text in 
alphanumeric order 
beginning with 0 or A.

Sort Descending Sorts topic text in 
alphanumeric order 
beginning with 9 or Z.

Effect menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Line Thickness Contains a submenu 
that lets you change 
the thickness of 
selected lines of 
symbols, links or draw 
objects.

Dashed Lines Turns selected lines to 
dashed lines for 
symbols, links and 
draw objects.

Fill Pattern Contains a submenu 
that lets you add 
patterns to the inside 
of selected symbols, 
draw objects and link 
arrowheads.

Line Pattern Contains a submenu 
that lets you add 
patterns to selected 
lines of symbols, links 
or draw objects.

White Text 
Background

Turns text 
backgrounds of 
selected symbols to 
white.

Send To Back Moves the selected 
object to the 
background.

Bring To Front Moves the selected 
object to the 
foreground.

Fill Color Contains a palette that 
lets you change the 
color inside symbols 
and draw objects.

Line Color Contains a palette that 
lets you change the 
color of a border or 
frame around a symbol 
and its shadow, the 
color of a symbol strip, 
the lines of draw 
objects or the color of 
links.



Multicolor Lets you change the 
colors of multicolor 
symbols and imported 
GIFs.

Text Color Contains a palette that 
lets you change the 
color of the text inside 
a symbol, link or text 
object.

Background Color Contains a palette that 
lets you change the 
background color of 
the diagram or outline 
window.

Color Selections Lets you specify the 
last 24 colors on the 
Inspiration® color 
palette.

Utility menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Find Command+F Ctrl+F Searches all text areas 
in an outline or 
diagram for specified 
text.

Find Next F3 F3 Searches all text areas 
in an outline or 
diagram for text 
specified in the last 
Find command.

Replace Searches all text areas 
in an outline or 
diagram for specified 
text and then lets you 
replace the old text 
with new text.

Spell Check F7 F7 Checks the spelling of 
Inspiration® 
documents.

Summation Command+
Shift+=

Ctrl+Shift+
=

Totals numbers or 
dollars in Topic 
Headings of symbol 
text.

Show Checklist Shows or hides the 
checklist check boxes 
on screen.

Internet Displays the Internet 
submenu.

URL 
Hyperlink

Lets you assign an 
URL to selected text.

URL 
Hyperlink 
Auto-
Detection

Turns on or off 
automatic detection of 
hyperlinks.

Live 
Hyperlinks

Turns on or off 
hyperlinks.

Change Grid Contains a submenu 
that lets you add or 
delete grid columns 
and rows in the 



diagram.

Grid Snap Turns the automatic 
grid alignment on or off 
for the diagram.

Grid Lines Hides or shows grid 
lines in the diagram.

Install User Symbol Installs the selected 
symbol, imported 
graphic or grouped 
Draw object into a 
symbol library.

New Symbol Library Lets you add a new 
symbol library to the 
Symbol palette.

Edit Symbol 
Libraries

Lets you reconfigure 
the symbols in the 
symbol libraries.

Window menu

Menu 
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

Cascade Arranges the open 
Inspiration® windows 
in an overlapping order 
within the Inspiration 
window.

Tile Arranges the open 
Inspiration windows in 
a side-by-side order 
within the Inspiration 
window.

Names of open 
documents

Lists open Inspiration 
documents so you can 
move among windows 
by choosing the 
document name.

Help menu

Menu
Command

MacOS 
Keystroke

Windows 
Keystroke Command Summary

About Inspiration Displays a window 
containing information 
about Inspiration® 
Software, Inc.

Inspiration Help F1 Displays the Help 
menu.

Help on the Web Starts your browser 
and opens 
Inspiration’s technical 
support Web site.

Inspiration Online 
Community

Starts your browser 
and opens 
Inspiration’s online 
forum for Inspiration 
users.

Using keyboard and mouse shortcuts

Inspiration® provides many useful keyboard shortcuts that can save you time and make it easier to edit diagrams 
and outlines. Since Inspiration is designed for users who have different types of keyboards, there are multiple 



keyboard shortcuts for some frequently used commands. Experiment with the commands to determine which 
keyboard shortcuts suit your needs. 

Shortcuts for editing text 

Shortcuts for selecting text 

Shortcuts for selecting topics 

Shortcuts for moving topics 

Shortcuts for inserting topics 

Shortcuts for scrolling in Diagram view 

Shortcuts for selecting or moving in Diagram view 

Shortcuts for creating new symbols 



Shortcuts for editing text

When editing text, you can use these shortcuts to move the insertion point and to select text. When command 
names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed by the Windows 
command name in parenthesis. For example, Quit (Exit).

To move to Keystrokes Keypad keystrokes

Beginning of topic Command+Home (Ctrl+Home)

End of topic Command+End (Ctrl+End)

Beginning of line Home (Home)

End of line End (End)

Left one character Left Arrow (Left Arrow)

Right one character Right Arrow (Right Arrow)

Left one word Command+Left Arrow** 
(Ctrl+Left Arrow)** 

Right one word Command+Right Arrow** 
(Ctrl+Right Arrow)** 

Up one line Up Arrow (Up Arrow)

Down one line Down Arrow (Down Arrow)

Up one paragraph Command+Up Arrow** 
(Ctrl+Up Arrow)** 

Down one paragraph Command+Down Arrow** 
(Ctrl+Down Arrow)** 

Scroll up one page Control+Up Arrow (Page Up) Page Up

Scroll down one page Control+Down Arrow 
(Page Down)

Page Down

Scroll left one page Control+Left Arrow 
(Ctrl+Page Up)

Command+Page Up

Scroll right one page Control+Right Arrow 
(Ctrl+Page Down)

Command+Page Down

Shortcuts for selecting text

When editing text, you can use these shortcuts to select text. When command names for the MacOS* and 
Windows* differ, the MacOS command name is listed first, followed by the Windows command name in 
parenthesis. For example, Quit (Exit).

To select text Keystroke Keypad keystroke

Extend selection to 
beginning of topic 

Command+Shift+Home 
(Ctrl+Shift+Home)

Extend selection to end of 
topic

Command+Shift+End 
(Ctrl+Shift+End)

Extend selection to 
beginning of line

Shift+Home (Shift+Home)

Extend selection to end of 
line

Shift+End (Shift+End)

Extend selection left one 
character

Shift+Left Arrow 
(Shift+Left Arrow)

Extend selection right one 
character

Shift+Right Arrow 
(Shift+Right Arrow)

Extend selection left one 
word

Command+Shift+Left Arrow 
(Ctrl+Shift+Left Arrow)

Extend selection right one 
word

Command+Shift+Right Arrow 
(Ctrl+Shift+Right Arrow)

Extend selection up one 
line

Shift+Up Arrow 
(Shift+Up Arrow)



Extend selection down 
one line

Shift+Down Arrow 
(Shift+Down Arrow)

Extend selection up one 
paragraph

Command+Shift+Up Arrow 
(Ctrl+Shift+Up Arrow)

Extend selection down 
one paragraph

Command+Shift+Down Arrow 
(Ctrl+Shift+Down Arrow)

To end text entry Shift+Return (Shift+Enter) Shift+Enter (Shift+Enter)

To add a Tab character 
(MacOS only)

Option+Tab 

Shortcuts for selecting topics

When command names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed 
by the Windows command name in parenthesis. For example, Quit (Exit). In Outline view, if you select a topic 
instead of a text area, the keys have the following effect: 

To do this Keystroke Keypad keystroke

Select previous topic Up Arrow (Up Arrow)

Select next topic Down Arrow (Down Arrow)

Select next topic above at 
same level

Command+Up Arrow 
(Ctrl+Up Arrow)

Select next topic below at 
same level

Command+Down Arrow 
(Ctrl+Down Arrow)

Select Superior topic Command+Left Arrow 
(Ctrl+Left Arrow)

Select Superior topic and 
hide

Command+Shift+Left Arrow 
(Ctrl+Shift+Left Arrow)

Select Inferior topic and 
show it

Command+Shift+Right Arrow 
(Ctrl+Shift+Right Arrow)

Select Inferior topic Command+Right Arrow 
(Ctrl+Right Arrow)

Select Main Idea Command+M or Home (Home)

Scroll to top left Command+Home (Ctrl+Home)

Scroll to bottom right Command+End (Ctrl+End)

Shortcuts for moving topics

When command names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed 
by the Windows command name in parenthesis. For example, Quit (Exit). In Outline view, if you select a topic 
instead of a text area, the keys have the following effect:

To move a topic Keystroke Keypad keystroke

Move topic left (Move Left) Command+L or Shift+Left Arrow 
(Ctrl+L or Shift+Left Arrow)

Move topic right (Move Right) Command+R or Shift+Right Arrow 
(Ctrl+R    or Shift+Right Arrow)

Move topic up (Flip Up) Command+’ or Shift+Up Arrow 
(Ctrl+’ or Shift+Up Arrow)

Move topic down (Flip Down) Command+/ or Shift+Down Arrow 
(Ctrl+/ or Shift+Down Arrow)

Shortcuts for inserting topics

When command names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed 
by the Windows command name in parenthesis. For example, Quit (Exit). In Outline view, if you select a topic 
instead of a text area, the keys have the following effect:

To insert a topic Keystroke Keypad keystroke



Insert Topic if no 
subtopics; otherwise, 
insert subtopic

F9 (F9)

Shortcuts for scrolling in Diagram view

You can use the following keyboard commands to move around in your document when you are not in text editing. 
When command names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed 
by the Windows command name in parenthesis. For example, Quit (Exit).

To scroll Keystroke Keypad keystroke

Left one grid box Left Arrow (Left Arrow)

Right one grid box Right Arrow (Right Arrow)

Up one grid box Up Arrow (Up Arrow)

Down one grid box Down Arrow (Down Arrow)

Scroll to top left Command+Home (Ctrl+Home)

Scroll to bottom right Command+End (Ctrl+End)

Scroll up one page Page Up (Page Up)

Scroll down one page Page Down (Page Down)

Scroll left one page Command+Page Up 
(Ctrl+Page Up)

Control+ Left Arrow 
(MacOS only)

Scroll right one page Command+Page Down 
(Ctrl+Page Down)

Control+Right Arrow 
(MacOS only)

Shortcuts for selecting or moving in Diagram view

You can use the following keyboard commands to select objects in your document when you are not in text editing. 
When command names for the MacOS* and Windows* differ, the MacOS command name is listed first, followed 
by the Windows command name in parenthesis. For example, Quit (Exit).

To select or move selection Keystroke Keypad keystroke

Select Main Idea Command+M or Home 
(Ctrl+M or Home)

Move cursor selection left one 
grid

Left Arrow

Move cursor selection right one 
grid

Right Arrow

Move cursor selection up one 
grid

Up Arrow

Move cursor selection down one 
grid

Down Arrow

Move selected symbols left one 
grid

Shift+Left Arrow 
(Shift+Left Arrow)

Move selected symbols right one 
grid

Shift+Right Arrow 
(Shift+Right Arrow)

Move selected symbols up one 
grid

Shift+Up Arrow 
(Shift+Up Arrow)

Move selected symbols down 
one grid

Shift+Down Arrow 
(Shift+Down Arrow)

Nudge selection left one pixel Option+Left Arrow 
(Ctrl+Shift+Left Arrow)

Nudge selection right one pixel Option+Right Arrow 
(Ctrl+Shift+Right Arrow)

Nudge selection up one pixel Option+Up Arrow 
(Ctrl+Shift+Up Arrow)

Nudge selection down one pixel Option+Down Arrow 
(Ctrl+Shift+Down Arrow)



Move diagram within document 
window (Position Hand)

Command+Option 
(Ctrl+Alt)

Shortcuts for creating new symbols

When a symbol is selected, these commands make new symbols in relationship to the selected symbol. If the 
Diagram Properties option, Power Diagramming Keys is checked, these keys operate as stated whether or not you 
are in text editing. When command names for the MacOS* and Windows* differ, the MacOS command name is 
listed first, followed by the Windows command name in parenthesis. For example, Quit (Exit).

With a symbol selected Keystroke Keypad keystroke

Make a symbol to the left Command+Left Arrow 
(Ctrl+Left Arrow)

Make a symbol to the right Command+Right Arrow 
(Ctrl+Right Arrow)

Make a symbol above Command+Up Arrow 
(Ctrl+Up Arrow)

Make a symbol below Command+Down Arrow 
(Ctrl+Down Arrow)

With a symbol selected or 
when in text editing

Keystroke Keypad keystroke

RapidFire™ F9 (F9)

Create new symbol where you 
click, linked to the currently 
selected symbol

Command+Click (Ctrl+Click)

MacOS System 7 and Inspiration®

Inspiration® is designed to work with System 6.0.4 and higher of the MacOS* operating system. Some additional 
features are available when running Inspiration under System 7 or higher.

Inspiration has Publish and Subscribe options, supports 32-bit addressing, Apple Events, virtual memory and 
TrueType fonts.
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Using Publish and Subscribe

You can use the Publish and Subscribe commands to share information with other applications under the MacOS* 
or on an AppleTalk network. 

To exchange information between applications, you first designate the material you would like to have updated 
automatically. This information is called the publisher. You save this information to a file called an edition, then 
choose the destination document and indicate where you want the edition inserted. The inserted material is called 
a subscriber. Once you have set up publishers and subscribers within documents, the information is 
automatically updated when changes are made to the publisher.

This is useful, for example, when you are developing a logo in AppleWorks* that you would like to use in many 
places in an Inspiration® document. When the logo is modified in AppleWorks, it is automatically updated in the 
Inspiration document. This way, whenever you revise the logo it is immediately revised in any Inspiration document 
that uses it.

You can also create a diagram in Inspiration that is used in another application. When the diagram is modified, it is 
automatically updated in the other application. This way you can be sure your other file is up to date whenever you 
revise the diagram in Inspiration.

For the most part, Inspiration follows the standard guidelines set up by Apple for Publish and Subscribe. If you 
haven’t set up a publisher or subscriber in MacOS applications before, see the documentation that came with your 
MacOS System software. 
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Creating publishers

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

You can create publishers in Diagram view that contain all or part of a diagram. Each publisher is identified in 
Inspiration® by a border. You can create multiple publishers in a single diagram. Inspiration does not support 
publishers in Outline view or Notes List view.

To create a publisher:

1 Open a document in Diagram view.

2 Select what you would like to publish.

Your selection can include symbols, links, draw objects and imported graphics.

3 On the Edit menu, choose Publish, then select Create Publisher.

The Publish dialog box appears. A preview of the selected items appears at the left side of the dialog box.

4 Select a destination directory, enter the name of the edition, then click Publish.

Everything within the border is stored in the publisher. The edition file is created and you are returned to the 
diagram.

Tip… You can duplicate or save a copy of a document that has publishers. Inspiration warns you if you open 
two documents that have the same publisher at the same time.
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Creating a subscriber in Diagram view

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

You can create subscribers in Diagram view or Outline view. When you create a subscriber in Diagram view, 
Inspiration® copies the edition file and handles the subscriber as a symbol. You can resize, move, link or add 
symbol text to it.

When you create a subscriber in Outline view, the subscriber is handled as an imported graphic in the Notes Text 
window. You can resize the graphic. When you switch to Diagram view, the subscriber appears in the symbol’s 
Notes Text window.

Although you can’t create a subscriber in Notes List view, Inspiration will display subscribers.

To create a subscriber in Diagram view:

1 Open a document in Diagram view.

2 To replace a symbol with the subscriber symbol you are creating, select the symbol you want to replace.

Or

To add a subscriber symbol to your diagram without replacing a symbol, click on the diagram where you want the 
subscriber symbol to appear. 

3 On the Edit menu, choose Publish, then select Subscribe To. 

The Subscribe dialog box appears.

4 Select a directory, then select an edition file.

A preview of the selected edition file appears at the left side of the dialog box.

5 Click Subscribe.

The edition file is copied into the diagram.

Inspiration handles the subscriber as a symbol. You can move, resize, group, link or add text to it.

Note… For more information about Subscribe options, see the documentation that came with your MacOS 
System 7 software.
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Creating a subscriber in Outline view

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

You can create subscribers in Diagram view or Outline view. When you create a subscriber in Diagram view, 
Inspiration® copies the edition file and handles the subscriber as a symbol. You can resize, move, link or add 
symbol text to it.

When you create a subscriber in Outline view, the subscriber is handled as an imported graphic in the Notes Text 
window. You can resize the graphic. When you switch to Diagram view, the subscriber appears in the symbol’s 
Notes Text window.

Although you can’t create a subscriber in Notes List view, Inspiration will display subscribers.

To create a subscriber in Outline view:

1 Open a document in Outline view.

2 Select a topic.

3 On the Edit menu, choose Publish, then select Subscribe To.

The Subscribe dialog box appears.

4 Select a directory, then select an edition file.

A preview of the selected edition file appears at the left side of the dialog box.

5 Click Subscribe.

The edition file is copied into the notes text.

Inspiration handles the subscriber as an imported graphic in the Notes Text window. You can resize or delete it. 
When you switch to Diagram view, the subscriber appears in the symbol’s Notes Text window.

Note… For more information about Subscribe options, see the documentation that came with your MacOS 
System software.
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Canceling a subscriber

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

To cancel a subscriber:

1 Click to select the subscriber.

2 On the Edit menu, choose Publish, then select Subscribe Options.

A dialog box appears to remove the subscriber or publisher.

3 Click Cancel Subscriber.
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Canceling a publisher

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

To cancel a publisher:

1 Click to select publisher.

2 On the Edit menu, choose Publish, then select Subscribe Options.

A dialog box appears to remove the subscriber or publisher.

3 Click Cancel Publisher.
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Showing publish and subscribe borders

Note… You can use the Publish and Subscribe commands to share information with other applications only 
under the MacOS* or on an AppleTalk network.

You can show or hide the borders around a publisher or subscriber on your diagram.

To show the borders around a publisher or subscriber, on the Edit menu, choose Publish, then select Show 
Borders.
Or

To hide the borders around a publisher or subscriber, on the Edit menu, choose Publish, then select Hide 
Borders.

You can resize the border on a publisher to change the publisher area, or resize the border on a subscriber to 
enlarge or reduce the subscriber’s size.



Creating an Inspiration® diagram using AlphaSmart

Following are tips for using Inspiration with AlphaSmart* or other “intelligent keyboard” products.

To create a diagram using AlphaSmart:

1 Create the AlphaSmart document. Enter each item you want to be a symbol in the Inspiration diagram. Press 
Return (Macintosh) or Enter (Windows) at the end of each item. (Each item must be on a separate line.)

2 Connect the AlphaSmart to the computer running Inspiration.

3 Start Inspiration.

4 Click the RapidFire™ button on the toolbar.

5 Send the AlphaSmart document to Inspiration.

Inspiration creates a symbol for each item in the AlphaSmart document.



Creating an Inspiration® outline using AlphaSmart

Following are tips for using Inspiration with AlphaSmart* or other “intelligent keyboard” products.

To create an outline using AlphaSmart:

1 Create the AlphaSmart document. Enter each item you want to be a separate topic in the Inspiration outline. 
Press Return (Macintosh) or Enter (Windows) at the end of each item. (Each item must be on a separate line.)

2 Connect the AlphaSmart to the computer running Inspiration. 

3 Start Inspiration. 

4 On the File menu, choose Application Properties. 

5 On the Return Key (Macintosh) or Enter Key (Windows) drop-down menu, choose New Topic, and then click 
OK. 

6 Send the AlphaSmart document to Inspiration. 

Inspiration creates a topic for each item in the AlphaSmart document. 



Troubleshooting

On occasion, you may need to do some minor troubleshooting as you’re using Inspiration. Here are two special 
troubleshooting procedures:

Recovering a document if your computer unexpectedly shuts down 

Managing memory under the MacOS 



Recovering a document

Your computer may occasionally shut down unexpectedly, such as when there’s a power failure. When you restart 
your machine, Inspiration® will try to recover the documents that were open when the shutdown occurred. 
Inspiration automatically saves your documents for emergency recovery while you work.

To recover a document:

1 Restart your computer and open Inspiration.

A message appears explaining that Inspiration will recover any documents that were open. 

2 Click OK.

Inspiration opens the recovered document.

3 To save the file with the original document name, on the File menu, choose Save As, then enter the document 
name.

You can now continue your work on the document.



Managing the memory on the MacOS

If you usually work with large documents, have lots of windows open or add lots of graphics to your diagrams, you 
may want to increase the amount of memory allocated to Inspiration®. For more information about allocating 
memory under the MacOS*, see your MacOS user’s guide.



A note about Power Diagramming Keys

In Diagram view, if Power Diagramming Keys is on, shortcuts for editing text using the arrow keys create symbols 
in the direction of the arrows. To turn Power Diagramming Keys on or off, on the File menu, choose Diagram 
Properties, then select the Options tab.



Using the draw tools

You use the draw tools to enhance your diagrams with special lines and boxes and to create your own symbols 
that you can install in the symbol libraries.

Objects you create with the Draw toolbar are not treated as symbols unless they are installed in the symbol 
libraries. They appear in Diagram view, but don’t have a corresponding topic in Outline view. They also don’t have 
a notes text area and you can’t link to them.

You can enhance draw objects just as you can enhance symbols. You can fill them with color and change their 
borders, for instance.

What do you want to do?

Draw a freeform shape 

Draw a straight line 

Draw an oval or a circle 

Draw a polygon or triangle 

Draw a rectangle or square 

Draw a rounded rectangle or square 

Draw a text box 
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Drawing a freeform shape

You use the Freeform tool to make freehand drawings. 

To draw a freeform shape:

1 On the Draw toolbar, click the Freeform Line button.

The pointer turns into a cross hair.
2 Position the cross hair where you want your drawing to begin.

3 Hold down the mouse button and draw.

4 When you finish a line, release the mouse button.

5 Draw as many lines as you wish.

To turn the Freeform tool off, click the button again or click the Selection button  on the Draw toolbar.



Drawing a straight line

You use the Line tool to draw straight lines at any angle. You can also draw exact horizontal, vertical or 45-degree 
lines.

To draw a straight line at any angle:

1 On the Draw toolbar, click the Line button.

 
The pointer turns into a cross hair.

2 Position the cross hair where you want the line to begin, drag to where you want the line to end, and then 
release the mouse button.

As you draw, you can adjust the angle of the line.

3 To turn the Line tool off, click the button again or click the Selection button  on the Draw toolbar.

Tip… To draw a horizontal, vertical or 45-degree line, hold down the Shift key, then drag the line. As you drag, 
the line snaps to a 45-degree angle or a vertical or horizontal position. When you finish drawing, release the 
mouse button first, then release the Shift key.



Drawing an oval or circle

You use the Oval tool to draw ovals and circles.

To draw an oval or a circle:

1 On the Draw toolbar, click the Oval button.

 
The pointer turns into a cross hair.

2 Position the cross hair in the approximate location where you want one side of the oval.

3 To draw an oval, drag the shape until it’s the size you want, then release the mouse button.

Or

To draw a circle, hold down the Shift key, drag the circle, release the mouse button and then release the Shift key.
As you drag, the circle becomes proportionally larger.

4 To turn the Oval tool off, click the button again or click the Selection button  on the Draw toolbar.



Drawing a polygon

You can use the Polygon tool to draw objects such as triangles. A polygon is a series of attached straight lines.

To draw a polygon:

1 On the Draw toolbar, click the Polygon button.

 
The pointer turns into a cross hair.

2 Click where you want your polygon to begin.

3 Click again where you want the first line to end.

If you want to constrain the line to a 45-degree, vertical or horizontal line, hold down the Shift key when you 
click.

4 Continue to click where you want each succeeding line to end.

 
To complete the polygon, do one of the following:
If you want a closed polygon, click on the starting point.
Or

If you want an open polygon, double-click at the point where you want to complete the shape.
6 To turn the Polygon tool off, click the button again or click the Selection button  on the Draw toolbar.



Drawing a rectangle or square

You use the Rectangle tool to draw rectangles and squares.

To draw a rectangle or square:

1 On the Draw toolbar, click the Rectangle button.

 
The pointer turns into a cross hair.

2 Position the cross hair where you want a corner of the rectangle or square to begin.

3 To draw a rectangle, drag the shape you want, then release the mouse button.

Or

To draw a square, hold down the Shift key, drag the square, release the mouse button and then release the Shift key.
As you drag, the square becomes proportionally larger.

4 To turn the Rectangle tool off, click the button again or click the Selection button  on the Draw toolbar.



Drawing a rounded rectangle or square

You use the Rounded Rectangle tool to draw a rounded rectangle or square. A rounded rectangle or square has 
straight sides and rounded corners.

To draw a rounded rectangle or square:

1 On the Draw toolbar, click the Rounded Rectangle button.

 
The pointer turns into a cross hair.

2 Position the cross hair where you want a corner of the rounded rectangle to begin.

3 To draw a rounded rectangle, drag the shape you want, then release the mouse button.

Or

To draw a rounded square, hold down the Shift key, drag the square, release the mouse button and then release the 
Shift key.
As you drag, the square becomes proportionally larger.

4 To turn the Rounded Rectangle tool off, click the button again or click the Selection button  on the Draw toolbar.



Drawing a text box

You use the Text Box tool to add a title to a diagram, for example, or to add a text box to a draw object you want to 
use as a symbol. 

To draw a text box:

1 On the Draw toolbar, click the Text Box button.

 
The pointer turns into a cross hair.

2 Position the cross hair where you want the corner of the text box to begin.

3 Drag the text box until it’s the size you want.

4 Enter your text in the box.

The box grows vertically from the bottom down as you add more text.

5 Click elsewhere on the diagram to deselect the text box and turn off the Text Box tool.

Tip… To change the width of the text box, click the frame of the box to select it so that the resize handles show, 
then drag any of the four handles to the right or left.



Selecting a draw object

Before you can work with an object you’ve drawn, you need to select it.

To select a draw object:

If the draw object has no fill color, click anywhere on the line or border of the object.
Or

If the draw object has a fill color, click anywhere in the object.
When you select the object, its resize handles appear.

 



Resizing a draw object

When you resize a shape, you make it smaller or larger. You can proportionally resize most shapes you draw; that 
is, keep the same height to width ratio.

Besides resizing polygons as a shape, you can also resize individual segments.

To resize a draw object:

1 Select the object.

2 Position the pointer over one of the resize handles and drag to change the size.

As you drag, a dotted rectangle indicates the new size of the object.

3 When the object is the size you want, release the mouse button.

After you resize a draw object, you can return it to its original size by choosing Return to Original Size on the 
Edit menu.

Note… When you resize a straight line, the line itself changes size. You don’t see a dotted rectangle.

Tip… If you want to proportionally resize a draw object, hold down the Command key (Macintosh) or Ctrl key 
(Windows) as you drag. If you hold down the Shift key as you resize a straight line, the line is constrained to a 
45-degree, horizontal or vertical angle.



Sending a symbol or draw object to the back of a stack

You can draw an object and place it behind an idea symbol. You can position draw objects so they overlap, or 
create a stack of symbols or objects. To get the right effect, you may need to change the order of the objects in the 
stack. To do this, you use the Send To Back and Bring To Front commands.

To send a symbol or draw object to the back of a stack:

1 Select the symbol or draw object you want to send to the back of a stack.

 
2 On the Effect menu, choose Send To Back.

The symbol or object moves to the back.

3 To deselect the symbol or draw object, click on the diagram.

 
You can now move the other symbols or objects to make the arrangement you want.
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Bringing a symbol or draw object to the front of a stack

You can draw an object and place it behind an idea symbol. You can position draw objects so they overlap, or 
create a stack of symbols or objects. To get the right effect, you may need to change the order of the objects in the 
stack. To do this, you use the Send To Back and Bring To Front commands.

To bring a symbol or draw object to the front of a stack:

1 Select the symbol or draw object you want to bring to the front of a stack.

You may need to move one or more of the symbols or objects that cover the one you want to bring to the 
front.

 
2 On the Effect menu, choose Bring To Front.

The symbol or object moves to the front and is selected.

 
You can now move the other symbols or objects to make the arrangement you want.
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Grouping symbols or draw objects

Once you’ve created some symbols or drawn some objects and arranged them to suit your needs, you may want 
to group them. Grouping is particularly helpful when you’re making your own symbol. Once you group a set of 
objects, they all move as a unit, and any enhancements you make (such as fill color or border width) affect the 
whole group.

To group a set of symbols or draw objects:

1 Select the symbols or objects you want to group.

To select more than one item, hold down the Shift key and click each one, or drag a selection box, called a 
marquee, around the items.

2 On the Symbol menu, choose Group.

Or

Press Command+G (Macintosh) or Ctrl+G (Windows).
The selection boxes on each individual item disappear, and a selection box for the group appears around the items.
To ungroup, select the group and on the Symbol menu, choose Group again. 
To move or change one of the items, click an open space in the diagram, then select the one you want to work with.



Creating an outline

When you create an outline in Inspiration®, you’re making a structure for a report or document of some kind. You 
enter your ideas in a clear and concise way as you prepare to write. You begin with your main idea, which is the 
focus of your document. Then you add the topics you want to cover. A topic generally contains one idea or piece of 
information. Topics can have subtopics, which provide more detail. An outline can have up to 99 levels of 
subtopics.

In Inspiration outlines, as in diagrams, you can add notes to any topic or subtopic. Notes are the tool you use to 
flesh out your ideas. A note can be one or two sentences or several paragraphs. When you add notes to an 
outline, you’re well on your way to developing a complete written report, story or proposal, for example. 

Here’s an example of an outline:

 

What do you want to do?

Switch to Outline view 

Enter your main idea 

Add topics to your outline 

Add subtopics to your outline 

Edit text in your outline 

Create a diagram from your outline 



About the outline tools

When you switch to Outline view from Diagram view, the toolbars and menus change to provide you with the tools 
you need to create and edit outlines and develop written documents. When you work in Outline view, the Outline 
toolbar appears automatically at the top of your screen.

Here are the tools available on the Outline toolbar:

Diagram Switches to Diagram view

Add Topic Adds a topic below and at the same 
level as the selected topic

Add Sub Adds a subtopic below and one level to 
the right of the selected topic

 
Add Note Moves the cursor into the Notes text 
area for the selected topic

Left Moves a topic and its subtopics to the left one 
level

Right Moves a topic and its subtopics to the right 
one level

+- Sub Hides or shows the subtopics for the 
selected topic

+- Note Hides or shows notes text for the selected 
topic

Prefix Lets you change the prefix labels for the 
outline

Spell Checks the spelling in your outline

Switching to Outline view

When you open Inspiration®, if you’re in Diagram view, you first need to switch to Outline view.

To switch from Diagram view to Outline view:

On the Diagram toolbar, click the Outline button.

Or

On the View menu, choose Outline.
The Main Idea placeholder is already selected, ready for you to type your own main idea.

Tip… You can set Inspiration to always open in Outline view by creating a new default template. See Creating a 
template from an Inspiration document to create a new template. To change the default template, see 
Specifying a new default template.



Entering your main idea

To enter the main idea on your outline, type your main idea for the project.
The text you type appears in place of the words Main Idea. 



Adding a topic

Topics are the main areas you want to include, or points you want to make, in your outline. 

To add a topic:

1 Select the topic under which you want to add a new topic.

2 On the Outline toolbar, click the Add Topic button.

 
Or

On the Outline menu, choose Add Topic 
Inspiration® inserts a new topic below the selected topic and automatically assigns it a prefix.

 
If you selected Dad, then added a topic, here’s where it would appear.

3 Enter your topic.

Tip... Here’s a quick keyboard shortcut to add a topic at the same level at which you’ve been working, press 
Command+G (Macintosh) or Ctrl+G (Windows). For a complete list of keyboard shortcuts, see Using keyboard 
and mouse shortcuts.

{button ,AL("Deleting a topic;Adding a subtopic;Inserting a higher level topic;Inserting topics or subtopics using smart 
insert",0,`',`')} Related topics 



Adding a subtopic

In your outline, a topic can also be a subtopic. Subtopics are ideas or pieces of information that are subordinate to 
or add supplemental information to a topic. When you add a subtopic it is indented under the topic you have 
selected.

Here’s an example of an outline that includes both topics and subtopics:

When you add a subtopic to a topic, it’s indented one level below the selected topic.

To add a subtopic:

1 Select the topic where you want to add the subtopic.

To select a topic, click to the left of its prefix. A rectangle appears around the topic to show you it’s selected.

 
2 On the Outline toolbar, click the Add Sub button.

 
Or

On the Outline menu, choose Insert Subtopic
Inspiration inserts a new indented subtopic below the selected topic.
A + sign appears next to the topic to show that it has a subtopic.

 
The new subtopic is indented below the selected topic. A + appears next to the topic, Dad, indicating that it now has a 
subtopic.

3 Enter the text for the subtopic.

{button ,AL("Adding a topic;Deleting a topic;Inserting topics or subtopics using smart insert",0,`',`')} Related topics 



Inserting a higher level topic

As you add topics and subtopics to your outline, you will sometimes find you want to add a new topic that is at a 
higher level of importance to the topic you are currently working on. You use the Insert Higher Level Topic 
command on the Outline menu for this.

Here’s an example:

Note… You can use the Insert Higher Level Topic command for all topics and subtopics except for the Main 
Idea topic and first level topics.

To insert a higher level topic:

1 Select the topic after which you want to insert a higher level topic.

2 On the Outline menu, choose Insert Higher Level Topic.

A new topic appears below the topic you selected and at the next higher level in your outline.

3 Enter the text for the new topic.

{button ,AL("Deleting a topic",0,`',`')} Related topics 



Inserting topics or subtopics using the smart insert feature

As you develop your outline, you will find the smart insert feature helpful. Here’s how it works:

If you select a topic that is followed by another topic at the same level, a new topic is inserted after the 
selected topic. 

If you select a topic that is followed by one or more visible subtopics, a new subtopic is inserted after the 
selected topic.

Note… To hide and show subtopics, see Hiding and showing subtopics.

To insert a new topic or subtopic using the smart insert feature:

1 Select the topic under which you want to insert a new topic or subtopic.

2 Press the F9 key.

Or

On the Outline menu, choose Smart Topic Insert.
3 Enter your text.

{button ,AL("Deleting a topic",0,`',`')} Related topics 



Adding notes text to an outline

Once you’ve created an outline that includes topics and subtopics, you can develop your ideas by adding notes. 
This is where you do your writing. You can add anything from one sentence to multiple paragraphs.

To add notes to a topic:

1 Select the topic to which you want to add notes.

2 Press Return (Macintosh) or Enter (Windows).

Or

On the Outline toolbar, click the Add Note button.
The cursor appears below the selected topic so you can type your notes.

3 Enter your notes.

Note... A + appears next to a topic to show that it has subtopics; a - appears to show that it doesn’t have 

subtopics. If the  or 

 is outlined, it means the topic has notes text.

 

Tip... To hide or show notes text, see Hiding and showing notes text.

{button ,AL("Copying and pasting a graphic into notes text;Dragging and dropping a graphic into notes text;Inserting a graphic 
file into notes text",0,`',`')} Related topics 



Editing text in an outline

You can change the text you’ve entered for any topic, subtopic or notes text. 

To edit text in your outline:

1 Select the text where you want to edit.

The pointer becomes an I-beam cursor.

2 Do one of the following:

Enter the new text.

Or

Drag to select the text you want to replace, then enter the new text.

{button ,AL("Deleting a topic",0,`',`')} Related topics 



Creating a diagram from an outline

Once you have been working in Outline view you may want to go to Diagram view to create a diagram from your 
outline. You can easily create a diagram from your outline by changing to Diagram view. Changes you make in 
Outline view are automatically made in Diagram view, and vice versa. 

To switch between Outline view and Diagram view:

On the Outline toolbar, click the Diagram button. 
Or

On the View menu, choose Diagram.



Selecting all or part of an outline

You can use special commands on the Edit menu to select all or part of your outline.

To select everything on your outline: 

To select all topics at a particular level: 

To select all subtopics for a specific topic: 

To select the Main Idea: 



Selecting everything on your outline

1 Select a topic.

2 On the Edit menu, choose Select All.

Everything on your outline is selected.



Selecting all topics at a particular level

You can work on all the topics at a level at one time.

To select all topics at a particular level:

1 Select a topic at the level you want to work on.

2 On the Edit menu, choose Select, then select This Level.

All topics at that level are selected.



Selecting all subtopics for a specific topic

1 Select the topic that has the subtopics you want to select.

2 On the Edit menu, choose Select, then select Subtopics.

Both the topic and its subtopics are selected.



Selecting the Main Idea topic

On the Edit menu, choose Select Main Idea.



Moving a topic to the left

If you find that a topic belongs at a higher level in your outline, you can move it to the left. You can also move 
topics to the right so they are at a lower level. 

To move a topic to the left:

1 Select the topic you want to move to the left.

2 Do one of the following:

On the Outline toolbar, click the Left button.

Or

On the Outline menu, choose Move Left.
The topic moves to the left, which raises it one level. If the topic has subtopics, they are moved also maintaining their 
subtopic status.

Tip… To quickly move a topic to the left, press Command+L (Macintosh) or Ctrl+L (Windows) or press 
Shift+Tab. In Windows*, you may need to reset the default function of the Tab key. Choose Application 
Properties on the File menu, then select Move Right-Left in the Outline View Tab Key drop-down list.

{button ,AL("Moving a topic by dragging it;Promoting a set of subtopics to topics;Moving a topic to the right",0,`',`')} Related 
topics 



Moving a topic to the right

To use the Move Right command, the topic immediately above the topic you want to move must be at the same 
level or lower. 

To move a topic to the right:

1 Select the topic you want to move to the right.

 
2 Do one of the following:

On the Outline toolbar, click the Right button.

 
Or

On the Outline menu, choose Move Right.
The topic moves to the right, making it a subtopic to the topic. If the topic has subtopics, they are moved also 
maintaining their subtopic status.

Tip… To quickly move a selected topic to the right, press Command+R (Macintosh) or Ctrl+R (Windows) or 
press Tab. In Windows*, you may need to reset the default function of the Tab key. To do that, choose 
Application Properties on the File menu. Then select Move Right-Left in the Outline View Tab Key drop-down 
list.

{button ,AL("Moving a topic by dragging it;Demoting a set of topics;Moving a topic to the left",0,`',`')} Related topics 



Hiding and showing subtopics

To make it easier to organize your outline, it’s often useful to hide the subtopics so you can concentrate on the 
main topics. If the topic has a + in front of it, it means the topic has subtopics that you can hide or show.

To hide subtopics for a single topic: 

To display hidden subtopics for a single topic: 

To display all hidden subtopics in an outline: 



Hiding subtopics for a single topic

If a topic has a + in front of it, it means the topic has subtopics that you can hide or show.

To hide subtopics for a single topic:

1 Select the topic for which you want to hide the subtopics.

2 Do one of the following:

On the Outline toolbar, click the +-Sub button.

 
Or 

On the View menu, choose View Subtopics, then select Hide.
Tip… You can also double-click to the left of the topic’s prefix to show and hide subtopics.

{button ,AL("Displaying all hidden subtopics in an outline;Displaying hidding subtopics for a single topic",0,`',`')} Related topics 



Displaying hidden subtopics for a single topic

If a topic has a + in front of it, it means the topic has subtopics that you can hide or show.

To display hidden subtopics for a single topic:

1 Select the topic that has hidden subtopics.

2 Do one of the following:

On the Outline toolbar, click the +-Sub button.

 
Or

On the View menu, choose View Subtopics, then select Show.

Tip… You can also double-click to the left of the topic’s prefix to show and hide subtopics.

{button ,AL("Hiding subtopics for a single topic",0,`',`')} Related topics 



Displaying all hidden subtopics in an outline

On the View menu, choose View Subtopics, then select Show All.
All subtopics in the outline appear.

{button ,AL("Specifying how many outline levels to show",0,`',`')} Related topics



Hiding and showing notes text

As you add notes text, you will want to be able to hide the text so you can work with the organization of the outline. 
You can hide notes text for selected topics or you can hide the notes text for all topics in the outline. If the topic 

has an outlined  or 

 in front of it, it means the topic has notes.
To hide notes text for a single topic: 
To display hidden notes text for a single topic:
To hide or show all notes text in an outline: 



Hiding notes text for a single topic

You can hide notes text for selected topics. If the topic has an outlined  or 

 in front of it, it means the topic has notes.

To hide notes text for a single topic:

1 Select the topic for which you want to hide notes text.

2 Do one of the following:

On the Outline toolbar, click the +-Note button.

 
Or

On the View menu, choose View Notes Text, then select Hide.

Tip… To hide the notes text for a topic, you can also double-click the  or the 

 to the left of the topic.

{button ,AL("Displaying hidden notes text for a single topic;Hiding or showing all notes text in an outline",0,`',`')} Related topics 



Displaying hidden notes text for a single topic

You can display notes text for selected topics in the outline. If the topic has an outlined  or 

 in front of it, it means the topic has notes.

To display hidden notes text for a single topic:

1 Select the topic for which you want to display the notes text.

2 Do one of the following:

On the Outline toolbar, click the +-Note button.

 
Or

On the View menu, choose View Notes Text, then select Show.

Tip… To show the notes text for a topic, you can also double-click the  or the 

 to the left of the topic.

{button ,AL("Hiding notes text for a single topic;Hiding or showing all notes text in an outline",0,`',`')} Related topics 



Hiding or showing all notes text in an outline

You can hide or show the notes text for all the topics in the outline.

To hide or show all notes text in an outline:

Do one of the following:
To hide all the notes text, choose View Notes Text on the View menu, then select Hide All.

Or

To show all the notes text, choose View Notes Text on the View menu, then select Show All.

{button ,AL("Displaying hidden notes text for a single topic;Hiding notes text for a single topic",0,`',`')} Related topics 



Moving a topic by dragging it

You can drag a topic (and its subtopics) up or down in the outline, keeping the topic at the same level of 
importance. You can also drag topics to the right or left, changing the topic’s level of importance.

To move a topic and its subtopics by dragging them:

1 Select the topic you want to move, then hold the mouse button down while you drag it in the outline.

While you drag, the topic remains in its original position until you release the mouse button. You can tell 
where the topic’s new location will be by watching the dotted rectangle as you drag. The dark dot in the 
upper left of the rectangle indicates the level of the topic’s new location.

 
2 When the topic is where you want it to appear, release the mouse button.

 
The topic (and its subtopics if there are any) appears in the new location. 

{button ,AL("Consolidating several topics under one topic;Moving a topic down using the Flip Down command;Moving a topic up 
using the Flip Up command",0,`',`')} Related topics 



Promoting a set of subtopics to topics

Promoting topics is useful when you’re working with a group of topics.

When you have a number of subtopics you want to move to the left that is, to promote them in the outline hierarchy

you can use the Promote command on the Outline menu to move them all at the same time.

To promote a set of subtopics to topics:

1 Select the topic that contains the subtopic or subtopics you want to move one level to the left.

2 On the Outline menu, choose Promote.
The subtopic or subtopics move to the left one level, raising them in the outline hierarchy.

{button ,AL("Demoting a set of topics;Moving a topic to the left",0,`',`')} Related topics 



Demoting a set of topics

When you want to move a set of topics one level to the right (or demote them in the outline hierarchy) you can use 
the Demote command on the Outline menu to move them all at once. 

When you demote a set of topics, they become subtopics to the selected topic. Any subtopics contained by topics 
you demote also move one level to the right.

To demote a set of topics:

1 Select the topic immediately above the set of topics you want to move to the right.

2 On the Outline menu, choose Demote.

The topics move to the right one level, making them subtopics of the selected topic.

{button ,AL("Moving a topic to the right;Promoting a set of subtopics to topics",0,`',`')} Related topics 



Moving a topic up using the Flip Up command

When you want to move a topic and its subtopics up in the order of an outline, you can use the Flip Up command. 
To move a topic and its subtopics down in the order of an outline, you use the Flip Down command. These 
commands are on the Outline menu.

To move a topic up using the Flip Up command:

1 Select the topic you want to move up in the outline.

 
2 On the Outline menu, choose Flip Up.

The topic and its subtopics move up, changing places with the topic above it.

 

Tip… You can also select a topic and press Command (Ctrl)+’ or Shift+Up Arrow to move the topic up in the 
outline. 

{button ,AL("Moving a topic down using the Flip Down command",0,`',`')} Related topics 



Moving a topic down using the Flip Down command

To move a topic and its subtopics down in the order of an outline, you use the Flip Down command. 

To move a topic down using the Flip Down command:

1 Select the topic you want to move down in the outline.

2 On the Outline menu, choose Flip Down.

The topic and its subtopics move down, changing places with the topic below it.

Tip… You can also select a topic and press Command (Ctrl)+/ or Shift+Down Arrow to move the topic down in 
the outline. 

{button ,AL("Moving a topic up using the Flip Up command",0,`',`')} Related topics 



Copying and pasting a topic

You can copy one or more topics and their subtopics and then paste them into another location. Or you can paste 
them in another outline or into a document in another application. 

To copy and paste a topic:

1 Select the topic you want to copy.

All subtopics will be copied along with the topic.

2 On the Edit menu, choose Copy.

3 Select the topic under which you want to paste the topic.

4 On the Edit menu, choose Paste.

The topic and its subtopics, if any, appear in the new location. The original topic and its subtopics remain in 
their original location.



Cutting and pasting a topic

You can cut one or more topics and their subtopics and then paste them in another location. Or you can paste 
them in another outline or into a document in another application. 

When you cut a topic, the original disappears from the outline.

To cut and paste a topic:

1 Select the topic you want to cut and paste.

All subtopics will be moved along with the topic.

2 On the Edit menu, choose Cut.

3 Select the topic under which you want to paste the topic.

4 On the Edit menu, choose Paste. 

The topic and its subtopics, if any, appear in the new location. The original topic and its subtopics no longer 
appear in their original location.



Consolidating several topics under one topic

As you’re organizing information in your outline, you might find that several ideas in different locations throughout 
the outline really fit under one topic. 

You can use the Collect and Move command to consolidate ideas that are scattered throughout the outline under 
one roof. You can also choose to copy the selected topics and place them under one topic, while leaving the 
originals intact in the outline. 

To consolidate several topics under one topic:

1 Select the topic under which you want to place the other topics.

A rectangle appears around the selected topic.

2 Hold the Shift key down as you select the topics you want to consolidate.

A dotted rectangle appears around each topic you select.

You don’t need to select each subtopic. 

3 On the Outline menu, choose Collect and Move.

The Collect Options dialog box appears.

4 In the Collect Options dialog box, do one of the following:

Click Move Collected Topics to move the topics under the selected topic.

Or

Click Copy Collected Topics to copy the topics and place them under the selected topic, and leave the originals intact 
in the outline.

5 Click OK. 



Splitting a topic into two topics

If you discover that a topic contains two ideas and you want to split it, you can use the Split Topic command on the 
Outline menu to make two separate topics. 

When you split a topic that has no subtopics, both parts remain at the same level in your outline. When you split a 
topic that has a subtopic, the second portion becomes a subtopic.

You can also split notes text. When you do this, the information in front of the cursor remains notes text and the 
remainder becomes a new topic. 

To split a topic or notes text:

1 In the topic or the notes text you want to split, click the location in the text where you want to break it.

 
2 On the Outline menu, choose Split Topic.

The topic or notes text divides.

 



Creating a topic that includes line breaks

You might want to break a longer topic into several lines. For example, you may want to have a list of information 
appear as one topic with each item having its own line. Then, when you switch to Diagram view, the list appears in 
one symbol.

Normally, when you press Return (Macintosh) or Enter (Windows) at the end of a topic in Outline view, 
Inspiration® automatically changes to notes text mode. You can override this by using the Set Notes Text 
command on the Outline menu.

To create a topic that includes line breaks:

1 Select the topic to which you want to add more text, then press Return (Macintosh) or Enter (Windows).

A blinking cursor appears on the next line. You’re now ready to add notes text, which you will convert to topic 
text.

2 Enter the text you want, pressing Return (Macintosh) or Enter (Windows) wherever you want to break a line.

3 When you finish, click in the text where you want the topic text to end.

4 On the Outline menu, choose Set Notes Text.
All text in front of the cursor becomes part of the topic heading. Any text beyond the cursor becomes notes 
text.

 



Deleting a topic

As you’re working, you may want to delete some topics in your outline. There are several ways to do this.

Whenever you delete a topic, you automatically delete its subtopics. If you don’t want to delete the subtopics, you 
can copy them and paste them elsewhere, or you can promote them one level so they’re no longer subtopics.

To delete a topic:

1 Select the topic you want to delete.

2 Do one of the following:

Press the Delete key.

Or

On the Edit menu, choose Clear.

{button ,AL("Promoting a set of subtopics to topics",0,`',`')} Related topics 



Sorting topics

If you’re creating a list of names and addresses in Outline view, for example, you can sort topics or subtopics in 
ascending or descending alphanumeric order.

To sort topics:

1 Select the main idea or a topic, then do one of the following:

To sort the topics in ascending alphanumeric order (where 0 and A are first), choose Sort Ascending on the 
Outline menu. 

Or

To sort the topics in descending alphanumeric order (where 9 and Z are first), choose Sort Descending on the Outline 
menu.

2 Click Yes in the message box that appears.

The topics at the level you selected are rearranged in the order you chose.



Working in different views

Sometimes it’s helpful to limit the number of levels of your outline you see while you’re working. You may also 
want to zoom in so you can see a larger view of your outline on screen as you’re working. You can also focus your 
attention on a particular topic and its subtopics by displaying only that topic and its subtopics on your screen.

To specify how many outline levels to show: 

To focus on one topic and its subtopics: 

To magnify or reduce the view of the outline: 



Specifying how many outline levels to show

It’s sometimes helpful to show only some levels of subtopics for a selected topic as you work. You do this by 
selecting a topic that has subtopics you want to hide, and then specifying how many levels of subtopics you want 
to see. 

To specify the number of levels of subtopics to display:

1 Select the topic or subtopic you want to start with.

You’re going to be specifying how many levels of subtopics below the selected topic you want to show on 
your outline.

2 On the View menu, choose Show Levels.

The Show Levels dialog box appears.

3 In the Show Levels box, enter the number of levels you want to display below the selected topic, then click OK.

Note... The number of levels you chose appear for the selected topic. All subtopics below the level you 
specified are hidden.

{button ,AL("Hiding and showing subtopics",0,`',`')} Related topics 



Focusing on one topic and its subtopics

You can hide parts of your outline while you work so you can focus in on a specific section of your outline. When 
you focus in, you have the entire screen to work in.

To focus on one topic and its subtopics:

1 Select the topic you want to focus on.

2 On the View menu, choose Focus In.

The topic and its subtopics appear alone on the screen where you can work on them without being 
distracted by the rest of the outline.

3 To display your complete outline again, on the View menu, choose Focus Out.

The entire outline reappears, including the topic you focused in on and its changes.

Tip… You can use the Focus In command as often as you want to isolate topics and subtopics as you work.



Changing the look of topics at a specific level

You can quickly change the look of the text in your outline by using fonts and colors you prefer. You might want to 
make the main topics all one color and one font, all the second level topics another color or font, and so on. 

To change the look of the text in your outline:

1 On the File menu, choose Outline Properties, then click the Topic Font tab if it is not displayed. 

2 In the Topic Level box, click the topic level with the font and style you want to change.

You can click All Items to change everything, or All Topic Levels to change all topics, or Notes Text to change 
the notes text.

3 On the Font drop-down list, select the font you want to use.

4 On the Size drop-down list, select the size you want.

5 If you want to change the style of the font, click one or more of the Style check boxes.

For example, you could select the Bold and the ALL CAPS check boxes to make bold text in all uppercase 
letters.

6 On the Color drop-down list, select a color for the text.

7 Click OK.

Your outline appears with the new look.

Tip... To return text you’ve changed using the Properties tool to its original look, click the Factory Settings 
button in the Topic Font tab in the Properties dialog box.

{button ,AL("Returning text to its original look;Changing text styling for selected topics;Changing the text styling of letters, words 
or phrases within topics",0,`',`')} Related topics 



Changing text styling for selected topics

If you want to change the text styling of only a couple of topics, or even a word within a topic, you use the 
commands on the Format menu.

To change the text styling of selected topics:

1 Select the topic or topics you want to change.

You can select several topics by holding down the Shift key and clicking each topic. You can also select text 
within a topic by dragging.

2 On the Format menu, do one or more of the following:

To change the font, choose Font, then select the font you want. 

Or

To change the size of the text to a specific point size, choose Size, then select the size you want.
Or

To change the style of the text (to italic, for example), choose Style, then select the style you want.
Or

To increase the size of the text to the next point size on the list, choose Increase Font Size.
Or

To decrease the size of the text to the next point size on the list, choose Decrease Font Size.
Or

To change the text justification of the topics, choose Text Justify, then select Left, Center or Right justify.

{button ,AL("Changing the color of selected topics;Returning text to its original look;Changing the text styling of letters, words or 
phrases within topics;Changing the look of topics at a specific level",0,`',`')} Related topics 



Changing the color of selected topics

1 Select the topic or topics you want to change.

You can select several topics by holding down the Shift key and clicking each topic. You can also select text 
within a topic by dragging.

2 On the Effect menu, choose Text Color, and then select the color on the color menu.

{button ,AL("Changing the color of words within topics",0,`',`')} Related topics 



Changing the color of letters, words or phrases within topics

1 Select the word or words you want to change.

2 On the Effect menu, choose Text Color, and then select the color on the color menu.



Changing the text styling of letters, words or phrases within topics

You can add emphasis to words or phases within topics and their Notes text by using selective text styling. 
Selective text styling changes fonts, font sizes and styles for individual text selections.

Note… Selective styling will not change the global formatting for topics and notes text. To change the global 
settings, see Changing the look of topics at a specific level.

To change the text styling of words:

1 Select the letters, word, phrase, or block of text you want to change.

2 On the Format menu, choose the Font, Size and Style options you want to apply to the text.

{button ,AL("Returning text to its original look;Changing text styling for selected topics;Changing the look of topics at a specific 
level",0,`',`')} Related topics 



Returning text to its original look

If you change the look of text in your outline and then later decide you want to change it back to the topic’s style as 
set in Outline Properties, you can use the Revert To Style command on the Format menu. 

To change text back to its original look:

1 Select the topic you want to change back to the original look.

2 On the Format menu, choose Revert To Style.

The text reverts to the format of the topic.



Selecting different prefixes for your outline

There’s a variety of prefix styles you can use with your outlines. Inspiration® automatically uses the standard 
Roman Numeral method of prefixes. You might find that a bullet serves your purpose if your outline is simple, for 
example. Or you might want to use the Legal style of prefix if your outline is very complex. You can even use your 
own custom prefixes.

To select different prefixes for your outline:

You can quickly select new prefixes from those already available in Inspiration.

On the Outline toolbar, click the Prefix button, then select the prefix style you want.

Here are your choices:

Working Format

Roman Numerals

AlphaNumerals

Legal

Numeric 

No prefix 

Bullet 

Custom

{button ,AL("Changing the font and style of prefixes;Creating custom prefixes;Showing and hiding prefixes",0,`',`')} Related topics 



Changing the font and style of prefixes

You can select prefixes and use a different font and text style for them in the Outline Properties dialog box.

To change the font and style of prefixes:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Prefix tab.

3 On the Prefix drop-down list, select the prefix style you want.

4 Click Custom Font and Style to change the font and text style.

5 Make your choices.

6 Click OK.

{button ,AL("Selecting different prefixes for your outline;Creating custom prefixes;Showing and hiding prefixes",0,`',`')} Related 
topics 



Creating custom prefixes

1 On the Outline toolbar, click the Prefix button, then select Custom.

The Custom Prefix Labels dialog box appears.

2 Enter the prefixes you want for each level of the outline.

3 Click OK.

If you want the first level prefix to appear as part of the second level, and so on, select the Appending Prefixes 
check box. Then your prefixes would look something like this:

 

{button ,AL("Selecting different prefixes for your outline;Changing the font and style of prefixes;Showing and hiding 
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Showing and hiding prefixes

Sometimes it’s easier to work without the prefixes showing. You can choose to show or hide all prefixes.

To show and hide prefixes:

To hide all prefixes, on the Outline menu, choose Show Prefix to deselect it. 
Or

To show all prefixes, on the Outline menu, choose Show Prefix again to select it.



Setting page breaks in the outline

You can use automatic pagination or set specific page breaks. Set Page Break forces a page break before a 
specific topic in Outline view or Notes List view. You see the results when you Print Preview or print your 
document. 

To set a page break:

1 Select the topic where you want the break to occur, or where you want to remove the page break.

2 On the Format menu, choose Set Page Break.

A triangle appears to the left of the topic showing that a page break is set. If you select a topic that already 
has a page break set, the command will remove the page break. 

{button ,AL("Previewing a document before printing;Printing a document",0,`',`')} Related topics 



Copying and pasting a graphic into notes text

On the Macintosh*, you can copy and paste PICT, JPEG and GIF files into notes text. In Windows* you can copy 
and paste WMF, BMP, JPEG and GIF files.

Note… You can add only one graphic to a topic. When you add another graphic, the second graphic replaces 
the first.

To copy and paste a graphic into notes text:

1 In a paint or draw application, copy the image you want to use in your outline.

2 In Outline view, select the topic where you want to paste the graphic.

3 On the Edit menu, choose Paste.

The graphic appears at the end of the notes text for the selected topic. If your notes are hidden, Inspiration 
displays the notes text as it adds the graphic. 



Dragging and dropping a graphics file into notes text

On the Macintosh*, you can drag and drop PICT, JPEG and GIF files into notes text. In Windows* you can drag 
and drop WMF, BMP, JPEG and GIF files.

Note… You can add only one graphic to a topic. When you add another graphic, the second graphic replaces 
the first.

To drag and drop a graphics file into notes text:

1 Open the folder containing the source file (the graphic you want to place in your notes text). Arrange the 
program windows so that both the source file and the Inspiration® window are visible. You must be able to see 
the information you want to drag as well as the location where you want to drop it.

2 Select the source file, and then drag it to the notes text where you want it to appear.

3 Release the mouse button.

The graphic appears at the end of the notes text for the selected topic. If your notes are hidden, Inspiration 
displays the notes text as it adds the graphic. 

Note… You can also open the file containing the graphic and drag and drop the graphic onto the topic; 
however, support for drag and drop of graphics varies from program to program. If you experience difficulty 
dragging and dropping a graphic directly from another program into Inspiration, make sure the program 
supports drag and drop.



Inserting a graphics file into notes text

On the Macintosh*, you can import PICT, JPEG and GIF files into notes text. In Windows* you can import WMF, 
BMP, JPEG and GIF files.

Note… You can add only one graphic to a topic. When you add another graphic, the second graphic replaces 
the first.

To insert a graphics file into notes text:

1 In Outline view, select the topic where you want the graphic to appear in notes text.

2 On the Edit menu, choose Insert Graphic.

3 Select the file you want to insert, and then click Open.

The graphic appears at the end of the notes text for the selected topic. If your notes are hidden, Inspiration 
displays the notes text as it adds the graphic. 



Quickly printing a document

Inspiration® prints the document you display on the screen. For example, to print a diagram, first display it on the 
screen, then print it. 

Notes… When you print a diagram, the notes text for your diagram prints as a separate document after your 
diagram prints. To turn off notes text printing, choose Print Options on the File Menu. In the Print Options dialog 
box, clear the Notes List check box.

When you print a diagram, the default is Fit to 1 Page, which fits the diagram on one page. To change the 
default, see Setting print options.

To quickly print a document:

1 Open the document you want to print.

2 On the File menu, choose Print.

Or

Press Command+P (Macintosh) or Ctrl+P (Windows).
The Print dialog box for the printer you’re using appears. 

3 The choices that appear are worded differently depending on the printer and printer software you’re using. In 
general, here is the information you enter:

The pages you want to print
all, for example, or a range of pages

The number of copies you want
4 To proceed, click Print (OK).

Your document prints.

Tip... To print a section of a diagram or outline, use the Focus In command on the View menu to show the 
symbols or topic and subtopics you want to print.

{button ,AL("Improving font spacing with Laser printers;Previewing a document before printing;Setting page orientation, paper 
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Printing notes text for a symbol

You can print the notes text for a symbol or you can print the notes text for an entire diagram.

To print notes text for a symbol:

1 Open the diagram for which you want to print the notes text.

2 Select the symbol for which you want to print notes text.

3 Double-click the upper left handle to open the notes text window.

4 On the File menu, choose print.

Or

Press Command+P (Macintosh) or Ctrl+P (Windows).
The Print dialog box for the printer you’re using appears. 

5 To proceed, click Print (OK).

{button ,AL("Printing notes text for a diagram",0,`',`')} Related topics 



Printing notes text for a diagram

You can print the notes text for a symbol or you can print the notes text for an entire diagram.

To print notes text for a diagram:

1 Open the diagram for which you want to print notes text.

2 On the View menu, choose Notes List View.

The notes for the diagram appear.

3 On the File menu, choose Print.

Or

Press Command+P (Macintosh) or Ctrl+P (Windows).
The Print dialog box for the printer you’re using appears. 

4 To proceed, click Print (OK).

{button ,AL("Printing notes text for a symbol",0,`',`')} Related topics 



Previewing a document before printing

Before you print, it’s a good idea to see how your document will look on the printed page. The Print Preview 
command on the File menu shows you a reduced view of your document. You can zoom in if you want to see parts 
of a page in full size view. 

If you decide you’re ready to print your document, you can do so from the Print Preview window.

To see a preview of your document before you print:

1 Display the document you want to print.

For example, if you want to print a diagram, make sure you’re in Diagram view.

2 On the File menu, choose Print Preview.

The Print Preview window appears, showing you a reduced view of the first page of your document. 

Tip... If you’re printing a multiple-page diagram, it’s helpful to see where the page breaks will be. To see page 
breaks while working on the document in Diagram view, turn on the page lines. For more information, see 
Showing and hiding page lines.

3 If you want, zoom in on the document by clicking the magnifying glass  on the area you want to examine 
closely. 

Click the magnifying glass again to zoom out.

4 If the document has more than one page, click the Next Page button to display the following page.

To return to a preceding page, click the Prev. Page button.

Tip... About diagrams if you’re printing a multiple-page diagram, you can go directly to a specific page. Click the 
page you want to see on the Document Page icon above the Next Page button.

5 When you finish previewing, do one of the following:

To print the document, click Print.

Or

To leave the Print Preview window without printing, click Cancel.



Showing and hiding page lines

While working on a diagram, it is useful to see how it will fit on printed pages. You can use the Page Lines 
command to make the page lines visible on the screen. Page lines are turned off by default.

To show the page lines, on the View menu, choose Page Lines. 
The check mark in front of the command indicates the page lines are on.

To hide the page lines again, choose Page Lines.



Setting print options for documents

You can choose specific options such as Fit Diagram to for diagrams, printing only displayed topics for outlines, 
and printing only your notes text.    See descriptions of the options below.

To set print options for documents:

1 On the File menu, choose Print Options.

The Print Options dialog box appears.

2 Set the options the way you want, then click OK.

Tip… To preview the options you’ve selected, in the Print Options dialog box, click Preview. When you finish 
previewing, click Cancel to return to your document, or click Print to print it. 

Diagram Options

Normal - Smart Page Breaks 

Normal - Full Size 

Fit to 1 Page 

Fit Diagram To 

Print Symbol Handles 

Page Ordering 

Outline Options

Print Hidden Notes 

Print Hidden Subtopics 

General Options

Print Without Greyscale 

Print Entire Family 



Setting page orientation, paper size and source

If you preview your document, especially a diagram, and find that it’s wider than one page, you may want to print 
in landscape rather than portrait page orientation. 

Using the Page Setup dialog box, you can set the paper size and paper source at the same time you select the 
page orientation.

To set the page orientation, paper size and source:

1 On the File menu, choose Page Setup.

2 The Page Setup dialog box appears.

3 Select the orientation you want along with the paper size and source.

4 Click OK.



Improving font spacing with laser printers

You can improve the way your fonts look when you print them, and when you see them on screen. There are two 
commands: Fractional Fonts (Macintosh) or Printer Font Wrap (Windows).

To improve font spacing on the Macintosh*:

On the Macintosh, some printers and some fonts can take advantage of fractional spacing to improve the way your 
text looks when you print. Fractional spacing also ensures that your text wraps and shows properly in reduced 
views.

On the Format menu, choose Fractional Fonts.
Choose Fractional Fonts again to turn the feature off.

To improve font spacing in Windows*:

In Windows, if you find that text is being clipped when you print a diagram, use the Printer Fonts Wrap command. 
This feature makes the text wrap and placement in symbols on screen reflect the text wrap and placement you will 
get when you print. However, the fonts on your screen may appear to be too close together.

On the Format menu, choose Printer Fonts Wrap.
Choose Printer Fonts Wrap again to turn the feature off.



Tips for printing multiple-page diagrams

Here are some tips that can make printing multiple-page diagrams easier. 

Before you select the print settings in the Print Options dialog box, zoom out on your diagram to see where 
the page lines appear. Click the Zoom Out button 
 on the bottom scroll bar as many times as you need to see the page lines. If you can’t see the page lines on your 
screen, on the View menu, choose Page Lines to turn them on.

While in Diagram view, you can have Inspiration® reposition your symbols slightly so they fit intact on the 
pages. On the Symbol menu, choose Adjust For Page Breaks to automatically move symbols slightly so that they 
won’t split across two pages.

At print time, you can also use the Normal - Smart Page Breaks setting in the Print Options dialog box to 
automatically adjust the symbols in a diagram so they fit intact on a page. The diagram prints in actual size, and will 
fill as many pages as necessary. See Setting print options for a document. 

To have your diagram easily fit on one page, use the Fit to 1 Page setting in the Print Options dialog box. 
The diagram is automatically centered and reduced so that it prints on one page. See Setting print options for a 
document.

To make small adjustments as you move single symbols or groups of symbols, use the Nudge tools on the 
Draw toolbar. See Positioning a symbol precisely.

If you need to move the entire diagram at once, choose Select All on the Edit menu, then drag the diagram 
to the location you want.

Make your final adjustments when viewing the diagram in actual size (100 percent). It’s difficult to make fine 
adjustments when you’ve zoomed out.



Working Format prefix option

You see the + and - signs indicating whether there are notes and subtopics both on screen and on printed 
versions. 



Roman Numerals prefix option

Uses Roman Numerals for main topics (I, II, III, A, B, C, 1, 2, 3, etc.)



AlphaNumerals prefix option

Uses upper case letters to label main topics in outline documents. Otherwise like the Roman Numeral format (A, 
B, C, 1, 2, 3, a, b, c, etc.)



Legal prefix option

1.0, 2.0, 1.1, 1.2, 1.1.1, 1.1.2, etc.



Numeric prefix option

Uses numbers for each level (1, 2, 3, 1, 2, 3, etc.) in an outline document.



No Prefix option

On printed outline documents, there are no prefixes. You see the + and - signs indicating whether there are notes 
and subtopics on screen. 



Bullet prefix option

Uses a single bullet for all levels in an outline document.



Custom prefix option

Lets you specify your own system of prefixes in an outline document. 



Normal-Smart Page Breaks print option

Prints multiple-page diagrams so that symbols fit within the margins of each page and are kept intact. This option 
may spread symbols slightly to avoid splitting them between pages. 



Normal-Full Size print option

Prints the diagram as it appears on the screen. 



Fit to 1 Page print option

Reduces the size of the printed diagram and centers it so it fits on one page. 



Fit Diagram To print option

Reduces a multiple-page diagram so it fits on the number of pages you specify. You tell Inspiration how many 
pages high and how many pages wide you want the printed diagram to cover, and then Inspiration automatically 
resizes your diagram proportionately to fit the space you entered. For example, if you create a diagram that covers 
six pages (it's two pages high and three pages wide), you could reduce the printed diagram so that it prints on only 
two pages (one page high and two pages wide). 



Print Symbol Handles print option

Prints the handles on the symbols that you see when a symbol is selected. When the handles are printed, you can 
tell which symbols have notes text, children or hidden subtopics.



Page Ordering print option

Lets you specify the order in which multiple-page diagrams print. You can choose either Horizontal or Vertical 
order.



Print Symbol Text print option

Prints the text in the idea symbol above the notes text.



Print Hidden Notes print option

Prints all the notes, even if they're hidden at the time you print.



Print Hidden Subtopics print option

Prints all subtopics, even if they're hidden at the time you print.



Print Without Greyscale print option

Prints all diagrams, outlines and text documents in black and white, regardless of their color. When this option is 
selected, any grey tones appear as white. 



Print Entire Family print option

Prints all child documents for the file. When this option is not selected, only the document that is displayed prints.



Opening a new document

When you want to open a new, untitled document, use the New command on the File menu. You can open a new 
document while in Diagram or Outline view. A new document has the attributes of the default template you are 
using.

To open a new document:

On the File menu, choose New.

{button ,AL("Opening a template to create a new document;Saving a new or existing document;Specifying a new default 
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Opening an existing document

1 On the File menu, choose Open.

The Open dialog box appears listing the names of your Inspiration® documents.

2 Select the document you want to open, then click Open.

Tip… The last four Inspiration files you used are listed at the bottom of the File menu (depending on the size of 
your screen, the files are listed individually or inside a Recent Files submenu). On the File menu, choose the 
name of the file you want to open.

{button ,AL("Closing a document and keeping Inspiration open;Closing a document and quitting Inspiration;Saving a new or 
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Opening a template to create a new document

Templates are starter documents you can use as worksheets or style sheets. To use a template, you open the one 
you want to work with and then save it as your own document under a new name. Inspiration® has two kinds of 
templates, worksheets and style sheets. 

For more information on working with Inspiration templates, see Using and creating Inspiration templates.

To open a template to create a new document:

1 On the File menu, choose Template.

The Open dialog box appears listing the names of your Inspiration templates.

2 Select the template document you want to open, then click Open.

{button ,AL("Closing a document and keeping Inspiration open;Closing a document and quitting Inspiration;Saving a new or 
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Saving a new or existing document

Whenever you are working on a document, it’s a good idea to save it on a regular basis. To save your document 
for the first time, or to save a document you’ve already saved before under the current name, use the Save 
command. 

On the File menu, choose Save. 
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Giving an existing document a new name

To save a document and give it a new name, use the Save As command on the File menu.

To give an existing document a new name:

1 On the File menu, choose Save As. 

2 Enter a name for the document.

3 Select the folder where you want to store the document.

4 Click Save.



Closing a document and keeping Inspiration® open

You can close a document and continue to work in Inspiration®. For example, you can continue to work in 
Inspiration by opening another document.

To close a document and keep Inspiration open:

1 To close your document and keep Inspiration open, on the File menu, choose Close.

If you’ve made changes, Inspiration asks if you want to save those changes.

2 Click Yes to save your changes and close your document.

{button ,AL("Closing a document and quitting Inspiration",0,`',`')} Related topics 



Closing a document and quitting Inspiration®

You can close a document and quit Inspiration®.

To close a document and quit Inspiration:

1 To close your document and quit Inspiration, on the File menu, choose Quit (Macintosh) or Exit (Windows).

If you’ve made changes to your document, Inspiration asks if you want to save those changes.

2 Click Yes to save your changes and quit Inspiration.

{button ,AL("Closing a document and keeping Inspiration open",0,`',`')} Related topics 



Reverting to the last saved document

If you work on a document and then decide you don’t want to save the changes you’ve made, you can discard 
your changes and have Inspiration® open the previously saved version.

To revert to the last saved document:

1 On the File menu, choose Revert to Saved.

Inspiration asks if you want to discard all changes to your document.

2 To discard your changes and return to your previously saved document, click OK.

Or

To return to your current document with your changes intact, click Cancel.

{button ,AL("Undoing changes",0,`',`')} Related topics 



Moving an Inspiration® document from the Macintosh to Windows

You can move Inspiration documents, including Inspiration® templates, between the Macintosh* and Windows*. 
After you move a document from one platform to another, you can open it in Inspiration.

Note… Inspiration 6 for the MacOS* can open documents created in Inspiration 4 for Windows (or later). 

To move an Inspiration document from the Macintosh to Windows:

1 Add the Windows-based INS extension to the name of the file.

For example, change the file name WINDSURF to WINDSURF.INS

2 Make sure the file name does not have any of the following characters in it: 

\      |      /      ?    :    <    >    *    ²

3 Save the MacOS-based file to a floppy disk.

Note… If you have access to a network server that is connected to MacOS-based and Windows-based 
computers, you can place the file on the network and then open it.

4 Insert the floppy disk in the floppy disk drive of the Windows computer.

5 Start Inspiration.

6 On the File menu, choose Open.

7 Select the file you want to open, then click Open.

{button ,AL("Moving an Inspiration document from Windows to the Macintosh;Sharing a symbol library with another 
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Moving an Inspiration® document from Windows to the Macintosh

You can move Inspiration® documents, including templates, between Windows* and the Macintosh*. After you 
move a document from one platform to another, you can open it in Inspiration. 

Note… Inspiration 6 for Windows can open documents created in Inspiration 4.1 for the MacOS* (or later). 

To move an Inspiration document from Windows to the Macintosh:

1 Save the Windows-based file to a floppy disk.

Note… If you have access to a network server that is connected to Windows-based and MacOS-based 
computers, you can place the file on the network and then open it.

2 Insert the floppy disk in the floppy disk drive of the Macintosh.

3 On the Macintosh, click Open on the File menu in Inspiration.

Note… You cannot double-click the file to open it. You must open the file from within Inspiration by choosing 
Open on the File menu. 

4 Select the file you want to open, then click Open.

{button ,AL("Moving an Inspiration document from the Macintosh to Windows;Sharing a symbol library with another 
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Tracking your project using the checklist

As you work on a project, you can use the checklist to track your progress. You can check off topics in Outline 
view or symbols in Diagram view. If you check off a topic in Outline view, the corresponding symbol in Diagram 
view is also checked off.

When you turn on the checklist, a check box appears to the left of each topic or in the lower-right corner of each 
symbol. 

To turn on the checklist:

On the Utility menu, choose Show Checklist.
In Outline view, a check box appears to the left of each topic. In Diagram view, a check box appears in the 
lower-right corner of each symbol. To check a box, select it. To clear the box, select it again.



Opening a document created in another application

You can import documents that were created in other applications. Inspiration® can convert the following formats:

MORE 3.x (MacOS* only)
Microsoft* Word RTF 
RTF documents from a variety of word processing applications
Plain text documents created by a variety of word processing applications
Inspiration documents that were created in earlier versions of Inspiration or on another platform. 

Inspiration for the MacOS will open documents created in all versions of Inspiration beginning with 4.0 as 
well as in Inspiration for Windows*, versions 4.1 and higher.

Inspiration for Windows will open documents created in Inspiration 4.1 and higher for the MacOS and 
Inspiration 4.0 and higher for Windows.

Inspiration 5.0 (and later) documents can be read by both the MacOS and Windows versions of Inspiration 
regardless of the platform on which they were created.

Note… To move Inspiration documents from the Macintosh* to Windows, see Moving Inspiration documents 
from the Macintosh to Windows. To move Inspiration documents from Windows to the Macintosh, see Moving 
Inspiration documents from Windows to the Macintosh.

To open a document created in another application:

1 On the File menu, choose Open.

The Open dialog box appears. Inspiration shows you the names of any documents that can be imported.

2 Navigate to the folder where the document is located.

3 Select the file you want to import.

4 Click Open.

If you are using Windows, you can specify what type of document you want to open. On the Files Of Type drop-
down list, select the type you want. Here are your choices:

Inspiration (.INS) opens other Inspiration documents.
Plain (.TXT) opens plain text documents in Outline view. When Inspiration opens a text document, it looks 

for paragraph returns to determine outline topics. The first sentence of a paragraph becomes an outline topic, and the 
remaining sentences become notes text.

RTF (.RTF) opens rich text format documents in Outline view. Inspiration retains most of the structure of the 
original document. 

{button ,AL("Using Inspiration documents with other applications",0,`',`')} Related topics 



Using Inspiration® documents with other applications

Once you’ve created a diagram or outline in Inspiration® you can export it for use in a variety of other applications. 

You can save a picture of your diagram as a graphic, which can then be opened in a variety of graphic and word 
processing documents. You can also save your Inspiration outlines and notes text pages as text documents.

To save an Inspiration diagram as a graphic: 

To save an Inspiration document as a text file: 

Note… For information about converting Inspiration documents to Web pages, see Using Inspiration outline 
documents on the World Wide Web.



Saving an Inspiration® diagram as a graphic

1 Display the document in Diagram view.

2 On the File menu, choose Export.

The Export Options (Macintosh) or Export (Windows) dialog box appears.

3 In the Diagram Formats list, click the graphic format in which you want to export the diagram.

Note… When you export a diagram in the following formats, only the visible items in the diagram are included 
in the graphic. Hidden symbols and links are not exported. If you are focused in on a portion of the diagram 
when you save the diagram as a graphic, only that portion is exported. Here are the options:

Windows Metafile (Windows) 

Bitmap File (Windows) 

PICT (Mac Pict File) 

JPEG 

HTML-Single Web Page

4 Click Save.

The Save As dialog box appears.

5 Navigate to the folder where you want to save the graphic.

6 Enter a name for the graphic.

Inspiration® automatically uses your main idea as the name and assigns the appropriate file extension, but 
you can change it if you want.

7 Click Save.

The diagram is saved as a graphic and can be placed in another document.

{button ,AL("Saving an Inspiration document as a text file;Using Inspiration documents with other applications",0,`',`')} Related 
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Saving an Inspiration® document as a text file

1 Display the document in Outline view.

2 On the File menu, choose Export.

The Export dialog box appears.

3 In the Outline Formats list, select the format in which you want to save your Inspiration® outline. Here are the 
options:

MacWrite (MacOS) 

MacWrite II RTF (MacOS) 

More 3.x (MacOS) 

Microsoft PowerPoint RTF 

MS Word 3 RTF (MacOS) 

Microsoft Word RTF 

Plain Text 

WordPerfect RTF 

Ami Pro RTF (Windows) 

RTF (Windows) 

MacOS RTF (Windows) 

ClarisWorks RTF 

Microsoft Project (MPX) 

HTML-Multiple Web Pages 

HTML-Single Web Page 

Note… For information about exporting Inspiration outlines as single- and multiple-page HTML documents, see 
Using Inspiration outline documents on the World Wide Web.

4 In the Export Options list, select the options you want. Here are the options:

Export Prefixes 

Export Hidden Subtopics 

Export Hidden Notes 

Substitute Spaces For Tabs 

No Outline Format 

Limit Lines To 72 Characters 

One Page Per Topic 

Table of Contents 

5 Click Save.

The Save As dialog box appears.

6 Navigate to the location where you want to save the document.

7 Enter a name for the document.

Inspiration automatically names the document after the outline main idea. You can save the file with this 
name and not erase your original Inspiration file.

7 Click Save.

{button ,AL("Saving an Inspiration diagram as a graphic;Using Inspiration documents with other applications",0,`',`')} Related 
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Using Inspiration® outline documents on the World Wide Web

You can turn your outline and notes pages into an HTML document, which can be opened by a Web browser such 
as Netscape Navigator* or Microsoft Internet Explorer*.

Outlines saved in HTML format include hyperlinks, so you can construct both simple and multilevel Web pages 
from an Inspiration® outline. Any hyperlinks (URL hyperlinks) in your outline are retained in the exported 
document. When you convert an outline, you can specify how you want the HTML document to be formatted. 

Note… The HTML export may create many files, including JPEG files for any graphics you have in the outline. 
These files need to be kept together in order to browse them. The additional files are named based on the first 
file name you select.

There are several options for converting an outline to HTML:

Save the outline as a single Web page When you save your outline as a single scrollable Web page, the main idea 
becomes the title of the HTML document and appears in large type at the top of the page. Topics, subtopics and 
notes text appear as the body of the document. At the end of the page, “Back to Top” appears in hypertext. When 
you click “Back to Top,” you return to the top of the page. 

Save the outline as a single Web page with a table of contents This option is useful when each of your topics and 
subtopics includes notes text. When you save your outline as a single scrollable Web page with a table of 
contents, the main idea becomes the title of the HTML document and appears in large type at the top. 

Below the title is the table of contents, which is composed of the topics and subtopics. When you click a topic or 
subtopic, you jump to the corresponding topic or subtopic and notes text within the outline. In the body of the Web 
page, each topic is separated by a horizontal line. At the end of the page, “Back to Top” appears in hypertext. You 
click “Back to Top” to return to the top of the page.

Save the outline as a single Web page with a separate table of contents page This option is useful when your 
Inspiration document includes many short first- and second-level topics; for example, a company directory. When 
you choose this option, Inspiration creates two HTML files, a table of contents and a page that contains all the 
topics, subtopics and notes text. The main idea becomes the title of the table of contents and appears in large type 
at the top. The first level topics are listed below the title in hypertext format. When you click a topic, you jump to 
the corresponding topic in the second file.

In the body of the second page, each topic is separated by a horizontal line. At the end of the page, “Back” 
appears in hypertext. When you click “Back,” you return to the table of contents.

Save the outline as multiple Web pages This option is useful when your Inspiration document includes many topics 
and subtopics with a substantial amount of notes text. When you choose this option, Inspiration creates a set of 
HTML files. The main idea becomes the title of the table of contents, and the first level topics are listed below the 
title in hypertext format. 

Each first level topic, along with its subtopics and notes text, appears on its own separate page. The first level 
topic becomes the title of the page, and the subtopics and notes text appear below it. 

When you click a topic on the table of contents, you jump to the corresponding page. At the end of each topic 
page, “Back” appears in hypertext. When you click “Back,” you return to the table of contents.
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Tips for converting Inspiration® documents to HTML format

HTML (Hypertext Markup Language) is designed to be quick and efficient when used on the Internet. It is intended 
to make Web pages readable on a variety of computers and monitors. Below are some guidelines to follow when 
you want to convert your Inspiration document to HTML format.

If you use prefix labels, keep them simple. Web browsers don’t support many of the complex prefixes 
available in Inspiration.

Don’t worry about formatting your text. When you convert an Inspiration document to HTML format, all the 
fonts, font sizes and styles automatically convert to the Web browser’s    default settings.

Avoid using brackets
< and >
in your document. Web browsers interpret brackets as commands and will hide them and the text between them.

Be aware that your HTML document will not include any children you’ve created in your Inspiration 
document. If you want to export a child document, you need to create a separate file for it.

Avoid using slashes
/ and \
and quotation marks in the names you assign to the HTML files. 
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Saving an outline as a single Web page

When you save your outline as a single scrollable Web page, the main idea becomes the title of the HTML 
document and appears in large type at the top of the page. Topics, subtopics and notes text appear as the body of 
the document. At the end of the page, “Back to Top” appears in hypertext. 

To save an outline as a single Web page:

1 In Outline view, display the outline that you want to convert to HTML format.

2 On the File menu, choose Export.

The Export dialog box appears.

3 On the Outline Formats list, select HTML-Single Web Page.

4 Click Save.

The Save As dialog box appears.

5 Navigate to the folder where you want to save the document.

6 Enter a name for the document.

Inspiration® automatically uses your main idea as the name and assigns the appropriate file extension. You 
can change the name of the file if you want.

7 Click Save.

You can now open the document in a Web browser and use it as a Web page on the Internet.

Note… The HTML export may create many files, including JPEG files for any graphics you have in the outline. 
These files need to be kept together in order to browse them. The additional files are named based on the first 
file name you select.
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Saving an outline as a single Web page with a table of contents

When you save your outline as a single scrollable Web page with a table of contents, the main idea becomes the 
title of the HTML document and appears in large type at the top. Below the title is the table of contents, which is 
comprised of the topics and subtopics. In the body of the Web page, each topic is separated by a horizontal line. 
At the end of the page, “Back to Top” appears in hypertext. 

To save an outline as a single Web page with a table of contents:

1 In Outline view, display the outline that you want to convert to HTML format.

2 On the File menu, choose Export.

The Export dialog box appears.

3 On the Outline Formats list, select HTML-Single Web Page.

4 On the Export options list, turn off the One Page Per Topic and Table of Contents options.

5 Click Save.

The Save As dialog box appears.

6 Navigate to the folder where you want to save the document.

7 Enter a name for the document.

Inspiration® automatically uses your main idea as the name and assigns the appropriate file extension. You 
can change the name of the file if you want.

8 Click Save.

You can now open the document in a Web browser and use it as a Web page on the Internet.

Note… The HTML export may create many files, including JPEG files for any graphics you have in the outline. 
These files need to be kept together in order to browse them. The additional files are named based on the first 
file name you select.
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Saving an outline as a single Web page with a separate table of contents

When you save an outline as a single Web page with a separate table of contents, Inspiration creates two HTML 
files, a table of contents and a page that contains all the topics, subtopics and notes text. The main idea becomes 
the title of the table of contents and appears in large type at the top. The first level topics are listed below the title 
in hypertext format. 

In the body of the second page, each topic is separated by a horizontal line. At the end of the page, “Back” 
appears in hypertext. When you click “Back”, you return to the table of contents.

To save an outline as a single Web page with a separate table of contents:

1 In Outline view, display the outline that you want to convert to HTML format.

2 On the File menu, choose Export.

The Export dialog box appears.

3 On the Outline Formats list, select HTML-Multiple Web Page.

4 On the Export options list, select Table of Contents.

5 Click Save.

The Save As dialog box appears.

6 Navigate to the folder where you want to save the document.

7 Enter a name for the document.

Inspiration® automatically uses your main idea as the name and assigns the appropriate file extension. You 
can change the name of the file if you want.

8 Click Save.

You can now open the document in a Web browser and use it as a Web page on the Internet.

Note… The HTML export may create many files, including JPEG files for any graphics you have in the outline. 
These files need to be kept together in order to browse them. The additional files are named based on the first 
file name you select.
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Saving an outline as multiple Web pages

When you save an outline as a multilayered Web page, Inspiration® creates a set of HTML files. The main idea 
becomes the title of the table of contents, and the first level topics are listed below the title in hypertext format. 
Each first level topic, along with its subtopics and notes text, appears on a separate page. The first level topic 
becomes the title of the page, and the subtopics and notes text appear below it. At the end of each topic page, 
“Back” appears in hypertext. When you click “Back,” you return to the table of contents.

To save an outline as multiple Web pages:

1 In Outline view, display the outline that you want to convert to HTML format.

2 On the File menu, choose Export.

The Export dialog box appears.

3 On the Outline Formats list, select HTML-Multiple Web Page.

4 On the Export options list, select One Page Per Topic.

5 Click Save.

The Save As dialog box appears.

6 Navigate to the folder where you want to save the document.

7 Enter a name for the document.

Inspiration automatically uses your main idea as the name and assigns the appropriate file extension. You 
can change the name of the file if you want.

8 Click Save.

You can now open the document in a Web browser and use it as a Web page on the Internet.

Note… The HTML export may create many files, including JPEG files for any graphics you have in the outline. 
These files need to be kept together in order to browse them. The additional files are named based on the first 
file name you select.
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Creating and managing Inspiration® families

When you are working with a large, complex diagram or outline, it’s easy to manage the information by layering or 
leveling it when you use the Family options. In Inspiration®, a “family” is a document that includes one or more 
subdocuments, or “children.”

When you create a “child” in an Inspiration document, Inspiration opens a separate diagram or outline and links it 
to the symbol or topic you are working on in the original document. The original document, then, becomes the 
“Family Head.”

When you create a family, you can quickly switch among the children and between the children and the main 
diagram or outline. 

A word about the family hierarchy Each symbol or topic in an Inspiration document can have a child attached to 
it. And, once you create a child, you can add additional child documents to the symbols or topics in that child. 

Note… To print Inspiration children and families, see Setting Print options for documents. To check the spelling 
in families, see Checking the spelling in Inspiration documents.
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Creating a child 

When you create a child, you need to have your diagram or outline open in Inspiration® and on screen.

1 Select the symbol or topic to which you want to add a child.

2 On the File menu, choose Family, then select Open Child.

Tip… In Diagram view, to quickly open a child for a symbol, double-click the upper right selection handle. 

A new window appears with the symbol or topic you selected. The name of the window on the title bar is the 
text from the idea symbol. It has a bullet in front it, indicating that the window is a Child window.

Note… The number of bullets in front of the window title indicates how far down the child is in the family 
hierarchy. 

3 Create a diagram or outline using the Inspiration tools and commands.

4 To close the Child window and return to the parent diagram or outline, click the Close box (Macintosh) or Close 
button (Windows).

When you return to the parent document, the symbol or topic to which you added a child now shows you 
there is a hidden child:

In Outline view, a 

 appears to the left of the topic.
In Diagram view, the square in the upper right corner of the symbol is filled with red.

Tip… In Diagram view, if you want to see which symbols have children, you can display the symbol handles for 
all symbols whether or not the symbols are selected. On the File menu, select Diagram Properties. In the 
Diagram Properties dialog box, click the Options tab, then select the Always Show Symbol Handles and click 
OK.
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Opening a child for a symbol or a topic

You can quickly open any or all children for an Inspiration® document. 

To open a child for a symbol or topic:

1 Select the symbol or topic for which you want to open the child.

2 On the File menu, choose Family, then select Open Child.

Tip… Here’s a shortcut to open a Child window for a specific symbol or topic. In Diagram view, double-click the 
red square handle in the upper right corner of the symbol. In Outline view, double-click the shadowed box to the 
left of the topic.
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Opening a specific child

You can use the Open Any Child command to open a specific child. This is helpful when you are working with a 
document that has a lot of children. 

To open a specific child:

1 On the File menu, choose Family, then select Open Any Child. 

The Open Any Child dialog box appears.

2 Select the child you want to open.

3 Click OK.

The child you select opens in a separate Child window.
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Opening all first level children for the current diagram or outline

On the File menu, choose Family, then select Open All Children. 
All the first level children in the current window open in separate Child windows. This command does not 
open grandchildren (second level children or below).
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Opening an entire family

On the File menu, choose Family, then select Open Entire Family.
All of the Child windows you’ve created for the Inspiration® document open in separate Child windows. 
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Switching between an open Child window and Family Head window

If you open a number of windows for an Inspiration® family, you can use the Window menu to quickly switch back 
and forth. You can do this even if you have several levels of the family hierarchy open.

You can also use keyboard commands to access a child’s parent or grandparent. See Directly accessing an open 
Parent or Grandparent window.

On the Window menu, choose the name of the Child window or the Family Head window that you want to 
open.
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Directly accessing an open Parent or Grandparent window

1 Press Command+Title Bar (Macintosh) or Ctrl+F7 (Windows). 

A menu appears with the names of the parent or grandparents for the child.

2 Click the Parent or Grandparent window you want to display.

The window for the selected parent or grandparent appears. 



Deleting a child

You can delete any child from a family. You can also remove a child from a family, and turn the child into a 
separate Inspiration® document.    To remove a child, see Removing a child and saving it as a new Inspiration 
document.

When you delete a child from a family, you also delete any family members below that child from your Inspiration 
document. 

Note… Before you delete a child, you first need to have saved the Inspiration document.

To delete a child:

1 Select the symbol or topic with the child that you want to delete.

2 On the File menu, choose Family, then select Delete Child.

A message box appears, asking you if you want to save the child as a new file.

3 To delete the child, click No.
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Removing a child from a family and saving it as a new Inspiration document

You can remove a child from a family, and turn the child into a separate Inspiration® document. When you remove 
a child from a family, the family members below that child become part of the new Inspiration document.

To remove a child and save it as a new Inspiration document:

1 Select the symbol or topic with a child that you want to save as a new document.

2 On the File menu, choose Family, then select Delete Child.

A message box appears, asking you if you want to save the child as a new file.

3 To remove the child and save it as a new Inspiration document, click Yes.

The Save As dialog box appears.

4 Navigate to the location where you want to save the new Inspiration document.

5 Enter a new name for the document if you want.

The new document already has the name of the child as its name.

6 Click Save.

The child is removed from the current Inspiration document, and is now a new Inspiration document.
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Adding another Inspiration® document as a child

You can link another Inspiration® document to one of the symbols or topics in your current document.

When you add another Inspiration document to a diagram or outline, Inspiration copies it, then adds it as a child to 
the symbol or topic you select. The original document being added is unaffected.

Note… You can’t add an Inspiration document that is currently open.

To add another Inspiration document as a child:

1 Select the symbol or topic to which you want to add the child.

2 On the File menu, choose Family, then select Adopt.

The Open dialog box appears.

3 Navigate to the Inspiration document that you want to add as a child.

4 Click Open.

Inspiration copies the selected document, and adds it to the current document as a child to the selected 
symbol or topic.
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Checking the spelling in Inspiration® documents

You can check and correct the spelling of your document using the built-in spell checker. The spell checker uses 
two dictionaries: the Inspiration® Main Dictionary and the Inspiration User Dictionary. You can add words to or 
delete words from the User Dictionary. The spell checker looks up words in the Main Dictionary first, and then 
checks the User Dictionary.

To check the spelling of an Inspiration document:

1 Click the Spell button on the toolbar. 

Or

Choose Spell Check on the Utility menu.
The Spell Check dialog box appears.

2 If you’ve added children to your document, select the Check Family check box to check the spelling of the 
entire family.

3 Click Start.

Inspiration searches for words it doesn’t recognize. It displays unrecognized words next to Misspelled. If 
there’s a similar word in the Inspiration dictionary, it displays it in the Change To box. If there are other 
possible spellings in the dictionary, they are displayed in the Alternates box.

Tip… If the Auto Suggest check box isn’t selected, click Suggest to have Inspiration search the dictionaries for 
alternative spellings.

4 Do one of the following when Inspiration reaches a word it doesn’t recognize:

To change the word Inspiration doesn’t recognize to the word in the Change To box, click Change.
To change the word to one of the alternates, select the word, then click Change.
To type the correct spelling, click the Change To box, then type the correct spelling.
To ignore the word for this instance, click Ignore Once.
To ignore all occurrences of the word, click Ignore All.
To add the word to the Inspiration dictionary, click Add Word.

After you click your choice, Inspiration automatically continues to the next word it doesn’t recognize.

When the spelling check is complete, a message box appears telling you Inspiration has finished checking 
the spelling.

5 Click OK, then click Close.



Finding text in Inspiration® documents

You can find text in your document using the Find command. Find searches all text areas in a diagram or outline 
for the specified text. 

To find a word or phrase:

1 Display the document in the view in which you want to check the text.

2 Position the cursor where you want the search to start.

3 On the Utility menu, choose Find.

The Find dialog box appears.

4 Type the characters, word or phrase you want to find.

5 Optionally select from the search options described below.

Match Whole Word Only 

Match Case 

Check Family 

6 Click Find Next to begin the search, or click Close to stop the search.

Find looks through the text, stops at each occurrence of the search text, and highlights it.

7 Click Find Next to continue the search until it finds the next occurrence or reaches the end of the text.

8 Click Close to end the search.

Tip… Inspiration® remembers the last character, word, or phrase you searched for. After you click Close, you 
can restart your search by choosing Find Next on the Utility menu or by pressing F3. You can also select a new 
word and press F3 to find the next occurrence of the word.

Note… In Diagram view, Find searches through all of the showing symbols, their notes text, and all the showing 
link text. If you have hidden symbols, their text will not be searched. In Outline view and Notes List view all text 
is searched whether or not it is hidden.
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Replacing text in Inspiration® documents

You can find and then replace text in your document using the replace command. Replace searches all text areas 
in a diagram or outline for the specified text and then lets you replace the old text with new text. 

To replace a word or phrase:

1 Display the document in the view in which you want to check the text.

2 Position the cursor where you want the search to start.

3 On the Utility menu, choose Replace.

The Replace dialog box appears.

4 Type the characters, word or phrase you want to find in the Find What box.

5 Type the characters, word or phase to replace the found text in the Replace With box. 

6 Optionally select from the search options described below.

Match Whole Word Only 

Match Case 

Check Family 

7 Click Find Next to begin the search, or click Close to stop the search.

It looks through the text, stops at each occurrence of the search text, and highlights it.

8 Click Replace to replace the found text with the text in the Replace With box, or click Find Next to continue the 
search without making a change. Inspiration® continues the search until it finds the next occurrence or reaches 
the end of the text.

To replace all occurrences of the text in the document, click Replace All. Inspiration will automatically 
continue searching and replacing until it reaches the end of the text.

9 Click Close to end the replace process.

Note… In Diagram view, Replace searches through all of the showing symbols, their notes text, and all the 
showing link text. If you have hidden symbols, their text will not be searched. In Outline view and Notes List 
view all text is searched whether or not it is hidden.



Adding numbers and dollars

If you are using Inspiration® to track expenses, do high level budgeting or project planning it is useful to be able to 
quickly add up numbers. The Summation feature is useful whenever you need quick, simple addition. 

When Inspiration sums it looks for numbers in each level of subtopics under the selected topic. The values are 
added, then inserted in the selected topic at the insertion point. If the topic is selected and you are not in the text 
editor, the total is placed at the end of the topic. If a number already exists in the topic, Inspiration replaces the 
number with the summed number.

To add numbers and dollars:

1 Enter numeric data or dollar amounts in the subtopic or subsymbol text.

For example, to total the number of dollars in an expense report, type a dollar sign and the amount. If the 
dollar amount is surrounded by text be sure and put a space before and after the dollar amount. To total the 
number of people hours in an outline, enter the number, a space and then type “people hours” in each one of 
the subtopics you want included in the summation process. 

2 Select a topic or symbol with subtopics you want to add.

3 To sum all numbers in the entire outline or diagram, select the Main Idea topic or symbol. When only a topic or 
symbol is selected, only the subtopics for that item are summed.

4 On the Utility menu, choose Summation.

5 Select a Search For option.

To have Inspiration calculate only topics or symbols with numbers, select Search For General Numbers. 
Topics or symbols with dollar amounts are ignored.

To have Inspiration add only topics or symbols preceded by $ (dollar sign), select Search For Currency 
Numbers. (The currency symbol will vary on versions of Inspiration sold outside the United States.)

6 If you want to look for dollars or numbers surrounded by specific text, type the text into the Preceded By and 
Followed By fields.

These settings let you further control which figures Summation adds. You can embed number or dollars in 
text or have spaces that precede them. Summation will search and add numbers and dollars using your 
criteria exactly as specified. As you select your options Inspiration displays an example of what it will search 
for in the lower part of the dialog box.

For example, to total the number of people hours in an outline, select General Numbers, and type “people 
hours” in the Followed By box. To total the number of dollars, select Currency Numbers and leave the 
Preceded By and Followed By boxes blank.

7 Select Create Subtotals.

When selected, subtotals are inserted in the parent subtopics that have subtopics with numbers being 
summed. To suppress the insertion of the subtopic totals, deselect this option.

8 Click OK or press Return (Enter) to perform the summation or click Cancel to cancel this option and return to 
your diagram or outline.

Summation adds the numbers from the lowest subtopic upward and places the total in the selected topic or 
symbol.



Arranging document windows so you see each window

When you open several Inspiration® documents at the same time, for example, an entire family, you can arrange 
the document windows so you can see all of them at the same time. 

To arrange document windows so you can see each window:

On the Window menu, choose Tile. 
All of the open Inspiration documents are rearranged so they appear side by side in the Inspiration window.
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Arranging document windows so they overlap

On the Window menu, choose Cascade. 
All of the open Inspiration® documents are rearranged so that you can see the title bar of each document. 
You can see all of the document in front.
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Quickly switching between open Inspiration® documents

On the Window menu, choose the document you want to display.



Using and creating Inspiration® templates

Templates are starter documents that you use as worksheets or style sheets. The untitled document that opens 
when you make a new diagram is the default template. The templates that were installed with Inspiration provide 
you with beginning documents from which you can quickly build your own documents.

Worksheet templates are designed for other people to add the content. For example, a worksheet template might 
include the basic content for a cause and effect diagram or a character web.

Style sheets are blank diagrams and outlines that are set up with your favorite fonts, symbol shapes and 
formatting. Style sheets can be formatted for your personal letters or for the way you like your general Diagram 
view to open. The Basic template is an example of a style sheet.

To use a template to create your own document: 

To create a template from an Inspiration document: 

To edit a template 

To copy a template: 

To share a template with another computer: 

To specify a different default template: 



Using an Inspiration® template to create your own document

Inspiration® includes a variety of templates to help you get started on creating your own documents. When you 
make a new Inspiration document using a template, a new, untitled document opens in Diagram view. 

After the new document opens, you see placeholder text that you can select and add your own ideas. As you 
work, you can move symbols, for example, change their colors, and use the Symbol palette to change the types of 
symbols.

To use an Inspiration template to create your own document:

1 On the File menu, choose Template.

The Open Template dialog box appears.

2 Select the template on which you want to base a new document.

3 Click Open.

The diagram template opens as a new, untitled document.



Creating a template from an Inspiration® document

You can use any Inspiration® document as the basis for a new template. Use the Inspiration tools and commands 
to design the look you want for your template. You will find it useful to set the preferences for both Diagram view 
and Outline view of your document using the property sheets. For information about setting preferences, see 
Setting the preferences for Diagram view and Setting the preferences for Outline view.

When you create a new template, you add it to Inspiration’s collection of templates to make it available at any 
time. You can specify that the new template be the default Inspiration document that opens when you choose New 
on the File menu.

To create a template using an Inspiration document:

1 Create an Inspiration document that you want to save as a template.

2 On the File menu, choose Save As Template.

3 Enter a name for the template.

4 To assign the new template as the default Inspiration template that Inspiration opens when you choose New on 
the File menu, select the Set As Default check box.

If you select this option, all new Inspiration documents will be based on the new template.

5 Click Save.



Editing an Inspiration® template

You can change the characteristics of any of the templates that come with Inspiration®. Then you can save the 
template with your changes, either replacing the old template or giving the modified template a different name.

To edit an Inspiration template:

1 On the File menu, choose Template.

The Open Template dialog box appears.

2 Select the template you want to edit.

3 Click Edit.

The template opens, and its name is displayed on the Inspiration title bar.

4 Using the Inspiration tools and commands, make the changes you want.

When you finish making changes, on the File menu, choose Save.



Copying Inspiration® templates

An Inspiration® template is a single Inspiration document stored in the Inspiration Templates folder inside the 
Inspiration 6 folder.

To copy an Inspiration template:

1 Open the Inspiration 6 folder.

2 Double-click the Inspiration Templates folder.

3 Select the template you want to copy, for example Language Arts-Literary Web. 

Note… In Windows, the file has an INS extension, for example Language Arts-Literary Web.ins.

4 Copy the file.

Note… To share the template with another computer, see Sharing templates with other computers.



Sharing templates with other computers

You can share a template with another computer running Inspiration® by copying the template file to a floppy disk 
(or network server), and then copying the file to the Inspiration Templates folder on the other computer. 

To share a template with another computer:

1 Save the template to a floppy disk (or network server). See Copying an Inspiration template.

Note… If you are copying a template on a Macintosh to a Windows-based computer, you must add the INS 
extension to the file name. For example, change the file name “Language Arts-Literary Web” to “Language Arts-
Literary Web.ins.”

2 Insert the floppy disk into the computer with which you want to share the template.

3 Navigate to the Inspiration 6 folder and double-click it to open it.

4 Double-click the Inspiration Templates folder.

5 Navigate to the drive containing the template you want to share.

5 Select the template, and drag it to the Inspiration Templates folder.



Specifying a new default template

You can change the default template on which new Inspiration® documents are based.

To specify a new default template:

1 On the File menu, choose Save As.

The Save As Template dialog box appears.

2 Select the template that you want to specify as the default template.

3 Click Set Default.

When you replace the default Inspiration template, all new Inspiration documents are based on the new 
default template. The old Inspiration default template, which is named Basic, is retained in the template 
folder in case you want to use it as the default template in the future.



Setting the preferences for the Inspiration® application

You use the Application Properties dialog box to control the appearance and functions of Inspiration®. The settings 
you choose in this dialog box apply to all documents in Inspiration. You can specify which toolbars you want to 
display, for example, and which date and time format you want to use when you paste a date in your documents. 

Note… If you are using Windows, the Application Properties dialog box also has a Fonts tab. For information 
about using the Fonts tab, see Specifying which fonts show on the Inspiration font menu.

To set the preferences for the Inspiration application:

1 On the File menu, choose Application Properties. 

The Application Properties dialog box appears.

2 Specify the settings you want for the Inspiration window, then click OK. To specify settings, you select items on 
the drop-down lists or you select check boxes. Here are your choices:

Symbol Palette Select this item to have the Symbol palette on in Diagram view.

Diagram Toolbar Select this item to have the Diagram toolbar on in Diagram view.
Draw Toolbar Select this item to have the Draw toolbar on in Diagram view.
Outline Toolbar Select this item to have the Outline toolbar on in Outline view.
Notes List Toolbar Select this item to display the Notes List toolbar in Notes List view.

Status Bar Select this item to have the Status bar appear at the bottom of the screen. In Diagram view, the status 
bar displays the text in selected symbols and the titles of symbols on the Symbol palette. In both Diagram view 
and Outline view, the status bar displays a short description of the toolbar buttons.

Tool Tips Select this item to display tool tips when you point to tools and buttons in the Inspiration screen.
Auto-synch Doc. To Printer Select this item to have Inspiration automatically adjust the printer selection for 
documents when you select a different printer.

Note… If you change the printer you are using, the setting for percentage print reduction changes to 100 
percent. If you are working with a document that you’ve specified to be printed at less than 100 percent, you 
need to use the Page Setup dialog box on the File menu to change the settings back.

Show Tip of the Day Select this item to display a tip about using Inspiration each time you start Inspiration.

Picture-to-topic Select this item to automatically display symbol labels as topic text in Outline view when no text is 
entered in the symbols in Diagram view. 
URL Hyperlink Auto-detection Select this item when you want Internet addresses (URLs) in a diagram or outline to 
be automatically detected and formatted as hyperlinks. 

Live Hyperlinks Select this item to make Internet addresses (URLs) in a diagram or outline active hyperlinks. 
When Live Hyperlinks is selected, you can click a hyperlink to start your browser and go to the URL. 

Animate GIFs Select this item to activate the animated symbols in your diagram. Clear this check box to turn off 
animation. Turning off animated symbols can make a diagram with many animated symbols display faster. 
Date/Time Format Select the format you want from the drop-down list. You can choose from Short Date (7/4/97), 
Long Date (Fri, July 4, 1997), or Short Date And Time (7/4/97 6:00 PM).

Outline View Tab Key Select the function from the drop-down list you want for the Tab key in Outline view. Your 
can choose from:

Move Right-Left, which allows you to press Tab to move a topic to the right one level, and to press 
Shift+Tab to move a topic to the left one level.

Standard Tab, which allows you to press Tab to move text to the next tab stop.

Next Topic, which allows you to press Tab to move the cursor to the next topic.

Set Default Template Select a new default template from the drop-down list. A template is the starter document 
with your default settings, or form you want to use when you open a new document in Inspiration. For more 
information about templates, see “Using and creating Inspiration templates” earlier in this chapter.

Return key (Macintosh) or Enter key (Windows) Select the function you want to assign to the Return key 
(Macintosh) or Enter key (Windows) when you are working in Outline view. 

Enter key (Macintosh) or Enter key on numeric keypad (Windows) Select the function you want to assign to 
the Enter key (Macintosh) or Enter key on the numeric keypad (Windows) when you are working in Outline view. 



Measurement Units Select a unit of measurement for the grid and rulers. This measurement applies to outline 
layout, margins, and headers and footers.
Auto Save Enter a number of minutes in the Auto Save box to specify how often you want to automatically save your 
documents. Auto Save is used for emergency recovery of documents if your system unexpectedly shuts down.

Factory Settings Click Factory Settings to return all options in the Application Properties dialog box to their 
original settings.
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Specifying which fonts show on the Inspiration® Font menu (Windows)

If you are using Windows*, you can specify which fonts you want listed on the Inspiration® Font menu. When 
Inspiration is installed on your computer, it automatically lists approximately 18 fonts in the Font menu. You can 
change which fonts are available in the Font list. When you remove fonts from use in Inspiration, they remain 
available to other applications on your computer.

To specify the fonts on the Inspiration Font menu (Windows):

1 On the File menu, click Application Properties.

The Application Properties dialog box appears.

2 Click the Fonts tab.

3 Do one or both of the following:

Select a font that you want to have appear on the Font menu, then click Add.

Or

Select a font that you want to remove from the Font menu, then click Remove.

Note… In Windows, Inspiration doesn’t let you remove fonts that are currently in use in your diagram.

4 When you finish, click OK.

To return the font configuration to Inspiration’s default setting, click Factory Settings. 



Setting the preferences for Diagram view

You use the Diagram Properties dialog box to configure features and commands used in Diagram view. You can 
set the appearance of symbols and links to suit your needs, for example, and you can specify the automatic 
behavior of features such as the grid and diagram arranging. 

When you change the preference settings in the Diagram Properties dialog box, the new settings affect only the 
current Inspiration® document. New documents use the default settings. 

If you want to use the new settings you specify in other Inspiration documents, you can create a template that 
uses the settings. For more information, see Creating a template from an Inspiration document. You can also 
modify the basic Inspiration default template to reflect your changes. 

To set the preferences for Diagram view:

On the File menu, choose Diagram Properties.
You can set preferences for the following:

Symbols 

Links 

Margins 

Headers and Footers 

Special Options 
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Setting the preferences for symbols

You use the Symbol preferences to control the appearance of the basic or default

symbol for a diagram. For example, you can specify the symbol shape, fill color, text style and frame color for the 
default symbol. 
The settings in the Symbol preferences apply to the current Inspiration® document and to new symbols made in that 
document.

Note… As you work in Diagram view, you can change the way new symbols look without using the Diagram 
Properties dialog box. Select a symbol that has the look you want, then on the Diagram toolbar, click the New 
Look button.

To set the preferences for symbols:

1 On the File menu, choose Diagram Properties.

The Diagram Properties dialog box appears.

2 Click the Symbol tab to bring it to the front.

3 Specify the settings you want for new symbols in the current Inspiration document. See Symbol preferences for 
descriptions of each setting.

4 When you finish, click another tab to continue setting preferences, or click OK to accept your changes and 
close the Diagram Properties dialog box.

Tip… To return all the Symbol settings to Inspiration’s original configuration, click Factory Settings.
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Symbol preferences

To access the Symbol preferences, choose Diagram properties on the File menu, and then click the Symbol tab. 
The settings in the Symbol preferences apply to the current Inspiration® document and to new symbols made in 
that document. Following are descriptions of each setting.

Fill Color Select a fill color for symbols in the Fill Color drop-down palette. 

Line Color Select a color for the symbol border and shadow in the Line Color drop-down palette. 

Text Color Select a color for text in symbols and text boxes you draw in the Text Color drop-down palette. 

Fill Pattern Select a fill pattern for symbols in the Fill Pattern drop-down palette. 
Line Pattern Select a pattern for the border and shadow on symbols in the Line Pattern drop-down palette. 
Line Thickness Select a thickness for symbol borders in the Line Thickness drop-down list. 
Symbol Libraries To specify which symbol shape you want as the default shape for each new symbol you create in 
your diagram, click one of the symbols on the palette at the bottom of the Diagram Properties dialog box. To pick a 
symbol from another library, select another library on the Symbol Libraries drop-down list.

White Text Background Select the White Text Background check box to make a white background for text in 
symbols that have dark fill color or heavy fill patterns.

Shadow Select the Shadow check box to place a shadow on symbols you add to your diagram. A shadow adds a 3-D 
effect to symbols, helping them to stand out in the diagram. The shadow color and line pattern is the same as the 
border.
Auto Symbol Grow To change the way symbols change size as more text is added to them, select your choice on 
the Auto Symbol Grow drop-down list. When this option is on, symbols grow as you enter text in them so the text is 
always inside the symbol. You can turn Auto Symbol Grow off or you can specify a different way for the symbol to 
change as you enter text. 

Note… Auto Symbol Grow does not affect picture-style symbols that have captioned text (text that appears 
below the symbol). Captioned text below symbols such as an animal or a holiday symbol expands vertically and 
remains the width of the symbol.

Select Standard to have the symbol grow vertically from the middle as you add text. The symbol’s width 
remains the same.

Select Proportional to have the symbol maintain its height and width ratio as it grows to accept more text.

Select Off to have the symbol remain the same size as you add more text. The text fills the available space 
in the Symbol’s text area, and then is hidden from view. Three dots below the text indicate that there is 
hidden text.

Select Fixed Width to have the symbol grow vertically down the screen to accept more text. As the symbol 
grows, the top remains in position, and the symbol’s width remains the same.

Text Justification To set the text alignment in symbols and text boxes, select your choice in the Text Justification 
drop-down list. 

Select Left to have the text align on the left side.

Select Center to have the text align along the center point.

Select Right to have the text align on the right side.

Font To select a font and text style for all new symbols in your diagram, click Font. In the Font dialog box, you can 
choose a different font, specify a font size and style. When you finish in the Font dialog box, click OK.

Factory Settings To change all the settings in the Symbol tab back to their original Inspiration settings, click Factory 
Settings.
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Setting the preferences for links

You use Link preferences to control the appearance of the default links in a diagram. You can specify that links 
connecting symbols in a diagram are of a certain line weight and color, for example, and you can specify the 
shape of links. The settings you make in the Link tab apply to the current Inspiration® document.

Note… As you work in Diagram view, you can change the way new links will look without using the Diagram 
Properties dialog box. Select a link that has the look you want, then on the Diagram toolbar, click the New Look 
button.

To set the preferences for links:

1 On the File menu, choose Diagram Properties.

The Diagram Properties dialog box appears.

2 Click the Link tab to bring it to the front.

3 Specify the settings you want for new links in the current Inspiration document, then click OK. See Link 
preferences for a description of each setting.

4 When you finish, click another tab to continue setting preferences, or click OK to accept your changes and 
close the Diagram Properties dialog box.

Note… To return all the Link settings to Inspiration’s original configuration, click Factory Settings.
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Link preferences

To access the Link preferences, choose Diagram Properties on the File menu, and then click the Link tab. The 
settings in the Link preferences apply to the current Inspiration® document, and to new links made in that 
document. Following are descriptions of each Link setting.

Thickness Select a thickness for links in the Thickness drop-down list.

Color Select a color for links in the Color drop-down palette. 
Text Color Select a color for the text you enter in links in the Color drop-down palette. 

Arrow Head You can specify two types of arrowheads for links in the Link tab, one for the starting point of a link 
and one for the ending point. Inspiration’s default setting is to add an arrowhead at the link ending point, and not 
place an arrowhead at the beginning point. You can also specify that no arrowhead appears.

To specify an arrowhead style for the beginning point of a link, select a style in the Starting Point drop-down 
list. 

To specify an arrowhead style for the ending point of a link, select a style in the Ending Point drop-down list. 

Type Select the type of link you want to use in your diagram in the Type drop-down list. 

Select Standard to attach symbols with links that are straight lines.

Select Auto-90 to attach symbols with links that form in 90-degree angles. 

Select Curved Link (3 pts) to attach symbols with links that bend with a rounded curve.

Select Curved Link (4 pts) to attach symbols with links that bend with a snake-like curve.

Text Justification To set the text alignment for text within links, select your choice in the Text Justification drop-
down list. 

Select Left to have the text align on the left side.

Select Center to have the text align along the center point.

Select Right to have the text align on the right side.

Dashed Line Select the Dashed Line check box to make the links you draw dashed lines.

White Text Background Select the White Text Background check box to make the area behind the text in links 
appear white. A white text background is useful to make text stand out when the diagram background is filled with a 
color that’s close to the text color.
Freeze Links To keep links attached to the exact points where they are first connected to symbols, select the Freeze 
Links check box. When you move symbols, Inspiration doesn’t adjust the connecting points of the links.

32 Link Connection Points To set the number of connection points on an idea symbol to 32, select the 32 Link 
Connection Points check box. When you drag a link from one symbol to another you can connect the link to one of 
the 32 connection points. Clearing this item makes only 8 connection points available on an idea symbol.

Font To select a font and text style for the text you type in links, click Font. In the Font dialog box, you can choose a 
different font and specify a font size and style. When you finish in the Font dialog box, click OK.

Factory Settings To change all the options in the Link tab back to their original Inspiration settings, click Factory 
Settings.
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Setting the preferences for margins in diagrams

The margins are the amount of space between the printed diagram and the edges of a page. You can make the 
margins smaller or larger for Inspiration® diagrams you print.

To set the preferences for margins in diagrams:

1 On the File menu, choose Diagram Properties.

The Diagram Properties dialog box appears.

2 Click the Margins tab to bring it to the front.

3 Enter a measurement in the Top, Bottom, Left and Right boxes, as needed.

If you specify a margin that is less than your printer will allow, Inspiration automatically changes the margins 
you enter to the minimum amount for your printer.

4 Click another tab to continue setting preferences, or click OK to accept your changes and close the Diagram 
Properties dialog box.

Note… To return the margins to Inspiration’s original configuration, click Factory Settings.
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Setting headers and footers on diagrams

Inspiration® doesn’t automatically place headers or footers on the page when you print diagrams. If you prefer to 
include a header or footer when you print your diagram, you can specify the placement as well as the content of 
the header or footer. 

To set headers and footers for diagrams:

1 On the File menu, choose Diagram Properties.

The Diagram Properties dialog box appears.

2 Click the Header/Footer tab to bring it to the front.

3 On the Header and Footer drop-down lists, select the items you want to include in headers or footers.

You can specify a header for the left, center and right side of the page top, and a footer for the left, center 
and right side of the page bottom.

Tip… You can create your own custom header or footer. On any of the drop-down lists, click Custom. Then 
enter the text you want in the Header or Footer box that appears below the Header and Footer drop-down lists.

4 Set the other header and footer options as needed:

First Page Only To print the header and footer only on the first page, select First Page Only.

Number Pages From To set the starting page number for the document, click Number Pages From and enter a 
number. 
Reserve Space For To specify an amount of space you want to reserve at the top or bottom of the page for headers 
or footers, enter a measurement in the Reserve Space For box. Entering a measurement here ensures that your 
diagram doesn’t print over a header or footer.

Use Today’s Date/Use Last Saved Date This option sets the type of date used for headers and footers. 
Click Use Today’s Date to include the current date whenever the document is printed. Click Use Last Saved 
Date to use the date the document was saved the last time.

Header and Footer Fonts To change the font or font style of the headers or footers, click Header Font or Footer Font 
and make your changes in the Font dialog box that appears.

Factory Settings To return all options to their original settings, click Factory Settings.

5 When you finish, click OK.
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Setting special options for diagram view

You use the Options tab in the Diagram Properties dialog box to set special options for the grid and for the default 
diagram type.

To set special options for diagram view:

1 On the File menu, choose Diagram Properties.

The Diagram Properties dialog box appears.

2 Click the Options tab to bring it to the front.

3 Specify the settings you want for the options in the current Inspiration® diagram, then click OK. See Special 
Option preferences for descriptions of each setting.

4 When you finish, click OK.
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Special Option preferences

To access the Options preferences for diagrams, choose Diagram Properties on the File menu, and then click the 
Options tab. The settings in the Options preferences apply to the current Inspiration® document. Following are 
descriptions of each Option setting.

Grid Snap Select this option to automatically have the Grid Snap option on. When the grid is turned on, Inspiration 
places symbols within the squares of the grid.

Grid Lines Select this option to automatically display the grid lines on the screen in Diagram view. If the grid is turned 
off, the lines don’t appear on the screen.

Page Lines Select this option to automatically display the page lines on the screen in Diagram view. You use the 
page lines to see how your diagram fits within the pages when it prints.

Rulers Select this option to automatically display the vertical and horizontal rulers on the screen.
Power Diagramming Keys Select this option to allow the creation of new, connected symbols, even when you are 
editing text. While editing text, you can press the Command (Ctrl) key, then press an arrow key to create a new, 
connected symbol in the direction of the arrow. When this option is not selected, the arrow keys move the cursor up, 
down, right and left within text. 

Always Show Symbol Handles Select this option to display the handles of all symbols, even when they’re not 
selected. When this option is on, it’s easy to see which symbols have notes text, children or hidden subtopics. 
When the symbol is not selected, the handles that indicate notes text, children or hidden topics appear gray. When 
the symbol is selected, the filled handles turn red.

Draw Links Under Symbols Select this option to allow Inspiration to place links that cross other symbols beneath 
the symbols rather than on the top of the symbols. 

Dynamic Page Allocation Select this option to allow Inspiration to dynamically allocate pages to a diagram as 
they’re needed. When this option is selected, Inspiration begins a new diagram by displaying nine pages (three 
across the top and sides). It then adds more pages as the diagram grows. When this option is not selected, 
Inspiration allocates the maximum 638 pages to a new diagram.

Suppress Misc. Thoughts In Outline view, Inspiration automatically lists ideas that are not connected directly or 
indirectly to the main topic under a topic named Miscellaneous Thoughts. If you prefer to not display these topics 
while working in Outline view, select the Suppress Misc. Thoughts check box. 

Move Symbols Due To Overlaps This option tells Inspiration what to do when it detects symbols that will overlap 
as you change views or display hidden topics. For example, if you’ve added or moved topics in Outline view, then 
switch to Diagram view, some topics may overlap. 

You select an option from the Move Symbols Due To Overlaps drop-down list. 
Select Ask Each Time to have Inspiration ask you if you want to rearrange the diagram every time it notices 
that symbols will overlap.

Select Let Overlap to have Inspiration automatically let the symbols overlap.

Select Rearrange to have Inspiration automatically rearrange the diagram to prevent symbols from 
overlapping.

Diagram Zoom Percentage Select a zoom percentage on the Diagram Zoom Percentage drop-down list to 
display your Inspiration documents at the zoom percentage you specify. This option is useful if you prefer to work 
in a reduced view.

Grid Width/Grid Height Use the Grid Width and Height boxes to change the width and height of the default grid box 
dimensions. The width and height measurements are in centimeters or inches (To set the measurement units to 
centimeters or inches, see “Setting the preferences for the Inspiration application” earlier in this chapter). Enter 
different numbers to change the dimensions.

Greek Text Below This option controls the size of text that Inspiration ‘greeks,’ or displays as a gray block when 
the diagram is displayed in reduced views. Greeking text helps documents with lots of text display more quickly. 
Inspiration automatically greeks text below three points. You can enter a higher or lower point size. 

Factory Settings To return all options to their original settings, click Factory Settings.
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Setting the preferences for Outline view

You use the Outline Properties dialog box to configure features and commands used in Outline view. The settings 
you make in the Outline Properties dialog box also affect notes text and Notes List view topics.

When you change the preference settings in the Outline Properties dialog box, the new settings affect only the 
current Inspiration® document. New documents use the default settings. 

If you want to be able to use the settings you specify for outlines in other Inspiration documents, you can create a 
new Inspiration template that includes the settings as the default configuration. See Creating a template from an 
Inspiration document. You can also modify the basic Inspiration default template to reflect your changes.

To set the preferences for Outline view:

On the File menu, choose Outline Properties.
You can set preferences for the following:

Text 

Margins 

Headers and footers 

Document layout 

Outline prefixes 

Default zoom setting 
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Setting the preferences for text in outlines

You use the Font settings in the Outline Properties dialog box to change the default font and text style for one or 
more topic levels in an outline. You can also specify the font and text style you want to use for notes text and for 
Notes List view topics. 

When you change the preferences for the font you use in an outline, you select the topic level or type of text for 
which you want to choose a font and text style. Then you specify which style attributes you want to assign to the 
font.

To set the preferences for text in outlines:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Topic Font tab to bring it to the front. 

3 Select the topic level or type of text for which you want to specify a font and text style. Here are your choices:

All Items Select this option to apply your choice of font and text style to all topic levels in the outline, to the 
notes text and to Notes List view topics.

All Topic Levels Select this option to apply your choice of font and text style to the main idea and all topics and 
subtopics in the outline.
You can also select an individual topic level. For example, you can select Main Idea or Level 1, and then apply your 
choice of font and text style to that level only. That way, you can specify a font and text style for each individual level.

Notes List Topics Select this option to apply your choice of font and text style to all the text in Notes List 
view.

Notes Text Select this option to apply your choice of font and text style to all the notes text.
4 Do one or more of the following for the selected topic level or text:

On the Color drop-down palette, select a color for the font.
On the Font drop-down list, select a new font for the selected topic level or text.
On the Size drop-down list, select a size for the font.
Click one or more text styles you want to apply to the font.

5 When you finish, do one of the following:

Select another outline level or type of text for which to select a font and text style, then use the above 
procedure to specify your choices.

Or

Click another tab to set other preferences for outlines.
Or

If you are finished setting preferences, click OK to accept all your changes.
Note… To return the text preferences to the original configuration, click Factory Settings.
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Setting the preferences for margins in outlines

The margins are the amount of space between the printed outline and notes text or notes list topics on a page and 
the edges of the page. You can make the margin smaller or larger for Inspiration documents you print.

To set the preferences for margins in outlines:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Margins tab to bring it to the front.

3 Enter a measurement in the Top, Bottom, Left and Right boxes, as needed.

If you specify a margin that is less than your printer will allow, Inspiration automatically changes the margins 
you enter to the minimum amount for your printer.

4 Do one of the following:

Click another tab to set other preferences for outlines.

Or

If you are finished setting preferences, click OK to accept all your changes.

Note… To return the margins to Inspiration’s original configuration, click Factory Settings.
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Setting headers and footers for outlines

Inspiration® automatically places a header on each outline, notes text or Notes List view page when you print. If 
you want to change the header or add a footer, you can specify the placement as well as the content of the header 
or footer. 

To set headers and footers for outlines:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Header/Footer tab to bring it to the front.

3 On the Header and Footer drop-down lists, select the items you want to include in headers or footers.

You can specify a header for the left, center and right side of the page top, and a footer for the left, center 
and right side of the page bottom.

Tip… You can create your own custom header or footer. On any of the drop-down lists, click Custom. Then 
enter the text you want in the Header or Footer box that appears below the Header and Footer drop-down lists.

4 Set the other header and footer options as needed:

Skip First Page To begin headers and footers on the second page rather than the first, select the Skip First 
Page check box.

Number Pages From To set the starting page number for the document, click Number Pages From and enter a 
number. 
Space Between: Header/Text To specify the distance you want between the header and the top of the text on a 
printed page, enter a measurement in the Header/Text box. 
Space Between: Text/Footer To specify the distance you want between the bottom of the text and the footer on a 
printed page, enter a measurement in the Text/Footer box. 

Use Today’s Date/Use Last Saved Date This option sets the date used for headers and footers. Click Use 
Today’s Date to include the current date whenever the document is printed. Click Use Last Saved Date to 
use the date the document was saved the last time.

Header and Footer Fonts To change the font or text style of the headers or footers, click Header Font or Footer Font 
and make your changes in the Font dialog box that appears.

Factory Settings To return all options to their original settings, click Factory Settings.

5 When you finish, do one of the following:

Click another tab to set other preferences for outlines.

Or

If you are finished setting preferences, click OK to accept all your changes.
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Setting the layout preferences in outlines

You use the Layout tab in the Outline Properties dialog box to set preferences for the levels of topics you want to 
print, and to specify the spacing between lines and the amount of indentation you want for topics.

You also use the Layout tab to specify how you want notes text and Notes List view topics to appear on a printed 
page.

To set the layout preferences for outlines:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Layout tab to bring it to the front.

3 Specify your choices for printing, spacing and indentation for the outline. Here are your choices:

Main Idea Select this option to print the main idea at the beginning of the outline.

Topic Headings To Level Select this option, then enter the number of topic levels you want to print in the Topic 
Headings To Level box. When you print your outline, only the topics to the level you specify print. For example, if you 
set the level to two, when you print the outline, the main idea, the level one and the level two topics print. Other topics 
below level two don’t print. If you are also printing notes text, the text for all levels prints.

Tip… If you’ve entered notes text for the topics in your outline, you can print your outline as a complete written 
document with paragraphs. To do this, clear the Topic Headings To Level check box. When the document 
prints, only the notes text appears on the page. 

New Page At Level Use this option to create page breaks at the topic level you specify. For example, if you 
enter two in the New Page At Level box, Inspiration® begins a new page each time it encounters a level two 
topic in your outline. This option is useful when you want to begin pages with key ideas.

Print Prefixes To Level Use this option to specify to which level you want to include prefix labels in an outline. 
Line Spacing To change the amount of space between the lines in notes text and Notes List view topics, select an 
option on the Line Spacing drop-down list. Your choices are Single Space, 1.5 Space, Double Space or Triple Space.

Topic Spacing To change the amount of space between the topics in an outline, select an option on the 
Topic Spacing drop-down list. Your choices are Single Space, 1.5 Space, Double Space or Triple Space.

Indent: Each Level To change the distance each topic is indented to the right from the prior topic level in an outline, 
enter a measurement in the Each Level box.
Indent: Notes Text To change the distance the notes text is indented to the right from its topic, enter a measurement 
in the Notes Text box.

Space Between: Prefix/Topic Heading To set the distance between the beginning of the prefix label and 
the beginning of the topic, enter a measurement in the Prefix/Topic Heading box.

Factory Settings To return all options to their original settings, click Factory Settings.
4 Do one of the following:

Click another tab to set other preferences for outlines.

Or

If you are finished setting preferences, click OK to accept all your changes.
Tip… To see how your settings affect the printed outline, click Print Preview on the File menu. 
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Setting the preferences for outline prefixes

You use the Prefix tab in the Outline Properties dialog box to set the type of prefixes you want to use in an outline. 
You have a variety of styles from which to choose. You can even create your own custom style of prefix. To create 
custom prefixes, see Creating custom prefixes.

When you set the preferences for a prefix label, you first select the style of prefix you want to use. Then you 
choose a font and text style to use for the prefix.

To set the preferences for outline prefixes:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Prefix tab to bring it to the front.

3 Click the prefix style you want on the Prefix drop-down list. Here are your choices:

Working Format 

Roman Numerals 

AlphaNumerals 

Legal 

Numeric 

No Prefix 

Bullets 

Custom 

4 Do one of the following:

To have the prefix appear in the same font and style as the outline topics, click Font And Style Of Topic 
Level.

Or

To change the prefix font and text style, click Custom Font And Style, then select a font from the Font drop-down list 
and click the style you want.

5 Do one of the following:

Click another tab to set other preferences for outlines.

Or

If you are finished setting preferences, click OK to accept all your changes.
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Setting the zoom preference for outlines and Notes List view

You use the Options tab in the Outline Properties dialog box to set the default zoom percentage for a document. 
When you open the document, it appears at the zoom percentage you specify. This option is useful when you are 
creating a new template that will be used on very small or very large screens.

To set the default zoom percentage for Outline view:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears.

2 Click the Options tab.

3 On the Zoom drop-down list, click the zoom percentage at which you want the outline to automatically open.

4 Do one of the following:

Click another tab to set other preferences for outlines.

Or

If you are finished setting preferences, click OK to accept all your changes.
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Turning on or off toolbars or the status bar

To turn off all tool bars:

On the View menu, choose Toolbar, then select Toggle Off or press Command+F8 (Macintosh) or Ctrl+F8 
(Windows).

To return the toolbars to their previous state, on the View menu, choose Toolbar, and then select Toggle On 
or press Command+F8 (Macintosh) or Ctrl+F8 (Windows).

To turn off a specific toolbar or status bar:

On the View menu, choose Toolbar, then select the toolbar or status bar you want to turn on or off.
When the toolbar or status bar is displayed, a check mark appears next to the option.
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Turning on or off Tool Tips

On the View menu choose Tool Tips. 
When the Tool Tips are displayed, a check mark appears next to the option.
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Turning on or off the Symbol palette

On the View menu choose Symbol palette or press F8. 
When the Symbol Palette is displayed, a check mark appears next to the option.
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Showing or hiding icons and text on the toolbars

Inspiration® normally displays the toolbars with both text and icons. You can change them to display only icons or 
only text.

To show only text on the toolbars:

On the View menu, choose Toolbar Style, and then select Text Only.

To show only icons on the toolbars:

On the View menu, choose Toolbar Style, and then select Icon Only.

To show both text and icons on the toolbars:

On the View menu, choose Toolbar Style, and then select Icon and Text.



Adding grid columns or rows

You can quickly add rows and columns of space in your diagram. This is a quick way for you to increase spacing 
between symbols. You can only add grid columns or rows when the grid is on.

To add a grid column or row:

1 Click in a grid box where you want the row or column added.

2 On the Utility menu, choose Change Grid, then select Insert Grid Row or Insert Grid Column. 
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Deleting grid columns or rows

You can quickly delete rows or columns of space in your diagram. This is a quick way for you to move symbols 
closer together. You can only delete grid columns or rows when the grid is on.

To delete a grid column or row:

1 Click in a grid box in the row or column you want to delete.

2 On the Utility menu, choose Change Grid, then select Delete Grid Row or Delete Grid Column.

A message asks: “All symbols in this column (or row) will be deleted. Are you sure that you want to delete 
this column (or row)?”

3 Click OK to delete it or Cancel to stop the deletion.
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Working in Notes List view

If you are creating a non-hierarchical diagram such as a flow chart, or a diagram that contains many unconnected 
symbols, you can use Notes List view to enter and edit your notes text. Notes List view is useful when you want to 
produce a written document from a non-hierarchical diagram.

When you look at your diagram in Notes List view, it appears as a list of topics with no indentations. Notes text you 
enter appears below each topic, just as it does in Outline view. As you write and edit in Notes List view, you can 
change the text style, and you can print your document.

You can reorder topics in Notes List view without affecting their order in Diagram view or Outline view. You can edit 
the text in the topics, but you can’t add or delete them.

The toolbar in Notes List view uses several of the same tools you use in Outline view. Here is the Notes List view 
toolbar:

Diagram Switches to Diagram view

 
Add Note Moves the cursor into the Notes text 
area for the selected topic

Flip Up Moves a selected topic up one position

Flip Down Moves a selected topic down one 
position

Show/Hide Notes Shows or shows notes text for 
the selected topic

Spell Checks the spelling in your notes text
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Switching to Notes List view

1 Display the document in Diagram view.

2 On the View menu, choose Notes List.

The Notes List window opens, and the text from the symbols in your diagram appears as a list. Any notes 
text you’ve entered appears below its topic.

You can now edit and rearrange the topics to suit your needs without affecting the arrangement of the 
diagram.

3 To return to Diagram view, click the Diagram button on the Notes List toolbar.

 

{button ,AL("Working in Notes List view",0,`',`')} Related topics 



Changing the appearance of all text in Notes List view

If you plan to print your Inspiration® document while working in Notes List view, you can change the appearance 
of the text to suit your needs. You can change the look of all of the text at once, or you can change only the text 
that you select. Changes you make in Notes List view don’t affect the appearance of text in Diagram view or 
Outline view.

To change the appearance of all text in Notes List view:

1 On the File menu, choose Outline Properties.

The Outline Properties dialog box appears with Notes List view topics selected.

2 Select the changes you want.

3 Click OK.
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Changing the appearance of selected text in Notes List view

If you plan to print your Inspiration® document while working in Notes List view, you can change the appearance 
of the text to suit your needs. You can change the look of all of the text at once, or you can change only the text 
that you select. Changes you make in Notes List view don’t affect the appearance of text in Diagram view or 
Outline view.

To change the appearance of selected text in Notes List view:

1 Select the topic or notes text you want to change.

2 On the Format menu, choose the types of changes you want to make.

Tip… You can change the color of selected text by choosing Text Color on the Effect menu and selecting a 
color on the palette.



Specifying a color on the Inspiration® color menu

You can specify the last 24 colors that are available on the Inspiration® color menu.

To specify a color on the color menu:

1 On the Effect menu, choose Color Selections.

2 Select a color that you want to change.

3 Click a Color Picker on the right side of the dialog box:

CMYK Picker

Crayon Picker

HLS Picker

HSV Picker

HTML Picker

RGB Picker

4 Use the tools in the dialog box to specify the New color, and then click OK.

5 Click OK to close the custom color palette.



Windows Metafile (Windows) diagram format option

The Windows Metafile export option saves the diagram in a standard Windows format (WMF) that that can be 
opened in graphics, presentation and page layout applications.



Bitmap File (Windows) diagram format option

The Bitmap File (Windows) option saves the diagram in the standard Microsoft Windows graphic format (BMP).



PICT (Mac Pict File) diagram format option

The PICT (Mac Pict File) option saves the diagram as a PICT or PICT2 file that can be opened in graphics, 
presentation and page layout applications.



JPEG diagram format option

The JPEG option saves the diagram as a JPEG file that can be opened in graphics presentations, page layout 
applications or Web pages. 



HTML-Single Web Page diagram format option

The HTML-Single Web Page option saves the graphic in the HTML format for use on the World Wide Web. The 
diagram shrinks so that it fits on a 640-pixel-wide screen. The height is adjusted proportionally. Any URL 
hyperlinks in the file are retained as hyperlinks in the HTML file. This export makes two files: an HTML file and a 
JPEG file. Both files need to remain together to view the HTML file in a browser. HTML exports only the main 
diagram. If you want to include children, they must be exported as separate files.



MacWrite (MacOS) outline format option

The MacWrite (MacOS) outline format option saves an unformatted text-only document with outline indentations 
that can be opened in MacWrite.



MacWrite II RTF (MacOS) outline format option

The MacWrite II RTF (MacOS) outline format option saves a formatted document that includes text and any 
graphics placed in the outline that can be opened in MacWrite II. When you open the document in MacWrite II, a 
dialog box appears, asking you if you want to convert the RTF data. Click Yes to convert the document with 
formatting.



More 3.x (MacOS) outline format option

The More 3.x (MacOS) outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in More 3.0. 



Microsoft PowerPoint RTF outline format option

The Microsoft PowerPoint RTF outline format option saves a formatted document with text and any graphics 
placed in the outline that can be opened in Microsoft PowerPoint. The main idea becomes the presentation title, 
and each first level topic becomes a separate slide. Second level and lower topics become slide content.



MS Word 3 RTF (MacOS) outline format option

The MS Word 3 RTF (MacOS) outline format option saves a fully-formatted text-only document that can be 
opened in Microsoft Word 3.x for the MacOS. The converted document can be opened in outline view in Word or a 
text document. When you open the document in Word, a dialog box may appear, asking if you want to convert the 
RTF data. Click Yes to convert the document with formatting.



Microsoft Word RTF outline format option

The Microsoft Word RTF outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in Microsoft Word 4.0 and higher. When you open the document in Word, 
a dialog box may appear, asking if you want to convert the RTF data. Click Yes to open the formatted document. 



Plain Text outline format option

The Plain Text outline format option saves an unformatted text-only document with outline indentations.



WordPerfect RTF outline format option

The WordPerfect RTF outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in WordPerfect. 



Ami Pro RTF (Windows) outline format option

The Ami Pro RTF (Windows) outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in Ami Pro.



RTF (Windows) outline format

The RTF (Windows) outline format option saves a formatted document that includes text and any graphics placed 
in the outline that can be opened in any Windows application that reads the Microsoft RTF format.



MacOS RTF (Windows) outline format option

The MacOS RTF (Windows) outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in any MacOS application that reads the Microsoft RTF format. 



ClarisWorks RTF outline format option

The ClarisWorks RTF outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in ClarisWorks.



Microsoft Project (MPX) outline format option

The Microsoft Project (MPX) outline format option saves a formatted document that includes text and any graphics 
placed in the outline that can be opened in Microsoft Project.



HTML-Multiple Web Pages outline format option

The HTML-Multiple Web Pages outline format option saves the outline as an HTML document with a separate 
page for the table of contents and for each first-level topic, depending on the options you choose. The resulting 
document can be opened with any World Wide Web browser. 



HTML-Single Web Page outline format option

The HTML-Single Web Page outline format option saves the outline as a single page HTML document that can be 
opened with any World Wide Web browser.



Export Prefixes option

The Export Prefixes export option includes the outline's topic prefixes in the saved document.



Export Hidden Subtopics option

The Export Hidden Subtopics option includes all topics and subtopics in the saved document, even if you have 
hidden the subtopics.



Export Hidden Notes option

The Export Hidden Notes option includes all notes text in the saved document, even if you have hidden the notes 
text.



Substitute Spaces For Tabs export option

The Substitute Spaces For Tabs export option replaces tabs with spaces for indentation levels in the outline. 



No Outline Format export option

The No Outline Format export option (applies only to documents you want to export to Microsoft Word). Exports 
your Inspiration outline in a word processing format that does not apply Microsoft Word outlining styles. If you 
leave this option unchecked, Word can open the Inspiration document in outline format.



Limit Lines To 72 Characters export option

Limit Lines To 72 Characters export option lets you force a line break each 72 characters. Use this option when 
you want to open your Inspiration document in e-mail applications that require line breaks at the end of each line.



One Page Per Topic export option

The One Page Per Topic export option places each main outline topic on a separate page of an HTML Web page 
document. The topic's notes and subtopics are placed on the same page as the main topic. This option is available 
only when you select HTML-Multiple Web Pages in the Outline Formats list. 



Table of Contents export option

The Table of Contents export option uses the outline topics to create a table of contents at the top of a single-page 
HTML document. This option is available only when you select HTML-Single Web Page in the Outline Formats list.



Match Whole Word Only find option

The Match Whole Word Only option finds whole words only. When selected, Inspiration will not find occurrences of 
the search text inside other words. It will only search for occurrences of the whole word.



Match Case find option

The Match Case option finds only those occurrences of the search text that exactly match the upper and 
lowercase letters you specify. When deselected, Inspiration finds all occurrences of the search text, ignoring the 
case of the letters.



Check Family find option

The Check Family option checks through the entire family document. When deselected, Inspiration searches only 
the family member in the active window.



Style Sheet template

A style sheet template is a blank diagram or outline that is set up with your favorite fonts, symbol shapes and 
formatting. For example, a style sheet might include the formatting you prefer for personal letters or the general 
attributes you prefer for Diagram view.



Worksheet template

Worksheet templates are designed for other people to add the content. For example, a worksheet template might 
include the basic content for a cause and effect diagram or a character web.




