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Copyright © 1998 by Site Technologies 

This manual and the software described in it are
copyrighted with all rights reserved. Your rights o
ownership are subject to the limitations and 
restrictions imposed by copyright laws. Under th
copyright laws, you may not copy this manual or
software, in whole or in part, without prior written
consent of Site Technologies except in the norm
use of the software or to make a backup copy.

It is against the law to copy, reproduce, or transm
any part of the manual or software in any form o
by any means (including translation to another 
language, computer language, or format) except 
permitted by the Copyright Act of the United 
States (Title 17, United States Code). You are 
permitted to write the contents of the software int
the machine memory of your computer so that th
software can be executed. The software may be
associated with one computer and may be used 
more one than one person on that computer, or 
may be associated with one person and used by
that person on more than one computer. Howeve
in no event shall two or more persons use the 
software at the same time. 

You are also permitted by law to make working 
copies of the software, solely for your own use, 
subject to the following restrictions. Working 
copies must be treated in the same way as the 
original and labeled with the Copyright notice tha
is on the original copy of the software. If you eve
sell, lend, or give away the original copy of the 
software, all working copies must also be sold, 
lent, or given to the same person or destroyed. N
copy, original or working, may be used while any
other copy, original or working, is in use.

Warranty. If you discover physical defects in the 
media on which this software is distributed, or in
the manual distributed with the software, Site 
Technologies will replace the media or manual a
no charge to you, provided you return the item to
be replaced, postage prepaid, with proof of 
purchase to Site Technologies during the 90-day
period after you purchased the product.
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Except as specifically stated above, Site 
Technologies makes no other warranties, expres
or implied, with respect to the software, media, o
manual including (but not limited to) implied 
warranties of merchantability and fitness for a 
particular purpose. Site Technologies reserves th
right to revise this software and manual without 
obligation to notify any person of such revision. 

In no event will Site Technologies be liable for 
loss of profits or goodwill or other indirect, 
special, incidental, or consequential damages 
resulting from any defect in the software, media,
or manual. Site Technologies’ liability for 
damages to you or others will in no event exceed
the total amount paid by you for the product. In 
particular, Site Technologies shall have no liabilit
for any data stored in or used with Site 
Technologies’ products, including the costs of 
recovering such data.

The warranty and remedies set forth above are 
exclusive and in lieu of all others, oral or written,
express or implied. No Site Technologies dealer,
agent, or employee is authorized to make any 
modification, extension, or addition to this 
warranty.

Some states do not allow limitations on how long
an implied warranty lasts or the exclusion or 
limitation of implied warranties or liability for 
incidental or consequential damages, so the abo
limitation or exclusion may not apply to you. This
warranty gives you specific legal rights and you 
may also have other rights which vary from state
to state.

Site Technologies
380 El Pueblo Road

Scotts Valley, CA 95066
Phone: 800/367-4334



Registration and Technical Support

he 
To receive upgrade information and technical 
support, make sure you register your QuickSite 
software. Be sure to include the program serial 
number you received from Sales. 

If you have any questions or comments about 
QuickSite, please contact our Technical Support
department. 

QuickSite Technical Support:

Phone: 408/461-3020 

Hours: 8:00am to 5:00pm Pacific Standard Time,
Monday through Friday, except holidays. 
 

 

Site Technologies can also be reached through t
World Wide Web on the Internet: 

http://www.sitetech.com
E-mail: tech_support@sitetech.com

or by mail:
Site Technologies
Attn: Technical Support
380 El Pueblo Road
Scotts Valley, CA 95066
Please have the following information handy when you call:
Serial number     ______________________
The serial number is located on the installation 
disk envelope. This number is required to obtain 
technical support.

QuickSite version     _____________
Select About QuickSite from the Help menu.

System information     
Check your computer’s hardware and software 
configurations and note them below.

Computer      _____________________________          

Operating system     ___________________

Total memory     ________________
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Introduction

Welcome to Site Technologies QuickSite 3.0, the most productive way t
create, manage, and sell through your Web site on the World Wide Web
Using QuickSite, you can create a professional-looking Web site. Wheth
you want to create a personal site for your friends and family or a comp
business presence with forms, download files, catalog, advertising, and
links to other Web sites, QuickSite makes it easy!

This guide gets you started with QuickSite. 

Chapter 1, Installing and Starting QuickSite

Chapter 2, The Basics of Web Site Creation

Chapter 3, Designing Web Pages

Chapter 4, Working with Special Features

Chapters 2 through 4 are walkthroughs that let you explore various 
QuickSite features and learn as you do. The walkthroughs provide the m
steps to access these features and perform selected tasks.

For those interested in scripting, Appendix A: Automation Scripting 
describes QuickSite’s special command language which can be used to
create and launch automated scripts.

Full descriptions of all features can be found in QuickSite’s online Help.
You can access Help from the Help menu in QuickSite. 
QuickSite 3.0 Getting Started Guide ix
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About QuickSite 3.0
QuickSite 3.0 includes all the award-winning features from its 2.5 versio
plus a host of new ones. See What’s new in Version 3.0?, page xii. 

Web site wizards
QuickSite wizards walk you through Web site creation and managemen
tasks to help you produce a well-organized site. There’s even a wizard 
ensure consistent style for your site!

QuickSite library
QuickSite has a library of predefined, reusable content such as graphic
forms, tables, links, and pages to give you a head start on creating your
site. If you have existing documents and graphics, you can include them
the QuickSite library or your own custom library. See Using libraries, page 
4-1.

WYSIWYG++ Layout Designer
What you see is what you get! QuickSite’s exclusive WYSIWYG++ Layo
Designer lets you position, size, and create each element of your page 
directly on the page itself. You can import information from Microsoft 
Word or Excel, drag and drop graphics, and create and modify tables in
WYSIWYG designer. See Exploring the Layout Designer, page 3-1.

Advanced HTML Editor
In addition to the Layout Designer, you can use QuickSite’s HTML Edito
to add and edit HTML code by hand or with templates. See Using 
QuickSite’s HTML Editor, page 3-14.

Web site management
QuickSite’s powerful Web site management features make it easy to cha
update, and backup your site. You can import an existing site into Quick
and easily make changes to it (Importing a site, page 4-4). You can add 
entire new sections to your site instantly with the Multi-level Menu Wiza
(For more information..., page 2-16). You can test your site on two browse
at the same time (Dueling browsers, page 3-22). 
x QuickSite 3.0 Getting Started Guide
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Catalog building
You can use QuickSite Catalog Builder to build a catalog of products an
services, and publish it on the World Wide Web in minutes. You can imp
your existing product database, fully design your catalog pages, arrang
your products into categories, and create sale prices. See Building a 
commerce catalog, page 4-5.

Site promotion
You can increase the number of qualified visitors to your site with 
QuickSite’s Site Promotion Wizard. It allows you to register your site wit
popular World Wide Web search engines automatically. Se Promoting your 
site, page 4-14.

Site templates
QuickSite offers a library of templates that you can use as the basis for 
own Web site. You can also add your own site templates. See Insert a site 
template, page 4-3 and Add a site template, page 4-2.

HyperSite technology
At the click of your mouse button you have the technology available to 
create HTML files (without knowledge of HTML code), import HTML-
coded files, and publish your complete site onto the Internet service you
have selected. See Chapter 3, Designing Web Pages.

Database technology
QuickSite’s advanced database technology makes it easy to organize a
update the information in your Web site so you can focus your efforts on
improving your Web site — changing the content and organization, mak
layout more visually appealing, and helping users navigate your site in 
quickest and easiest way possible.

Other features
QuickSite supports ActiveX, Java, forms, and frames. There is a full HTM
and script tag database for your use, plus professionally-designed site 
page templates. See Chapter 3, Designing Web Pages and Chapter 4, 
Working with Special Features.
QuickSite 3.0 Getting Started Guide xi
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What’s new in Version 3.0?
QuickSite 3.0 includes PDQ\ýQHZýIHDWXUHVýDQGýKHOSIXOýFRQWHQWýWRýPDNHý\RXUý
VLWHýGHYHORSPHQWýHIIRUWVýJRýVPRRWKO\ýDQGýPRUHýSURGXFWLYHO\ïý

Site Architect
The Site Architect makes it easy to organize the structure of your Web s
in a format where you can actually see a diagram of the page hierarchy.
Site Architect may be used when you first create the site through the N
Project Wizard or later when you want to visualize your Web site design
See Using the Site Architect, page 2-17.

AdStream
The AdStream feature provides the ability to easily create up to five link
panels for advertising banners or announcements. Each banner is made
ordinary text pages in QuickSite and can be programmed to display for
specific number of seconds. AdStream properties are designed to be ap
to a frame page that is used to display rotating banner content. The 
AdStream project, installed with QuickSite, demonstrates the AdStream
capability. Adding advertising, page 4-16.

QuickSite macro variables
QuickSite macro variables are now available to power users. The value
assigned to the variable is inserted wherever the QuickSite macro is ins
in a page. Macro variables greatly easy the task of maintaining Web pa
and duplicate content that appears in multiple places in a site. A single 
change to the variable will update every occurrence in the entire site. 
QuickSite macros, page 4-19.

Add-in libraries
The QuickSite library architecture is the same as any other QuickSite 
project file. A QuickSite library is essentially a Web site project. Any 
project in QuickSite 2.5.2 or later can be used as an add-in library. By “
in” we mean you can use the library in addition to the standard QuickSi
library, which is installed with QuickSite. You can create as many add-in
libraries as you want. Each can hold a virtually limitless amount of 
prefabricated content components. Open an add-in library, page 4-2.
xii QuickSite 3.0 Getting Started Guide
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• The Site Search library provides a static search page for a Web site.
The search engine requires no server-side component and has no 
“moving parts.” This feature builds a static JavaScript index into the S
Search page component which results in an extremely fast search of 
titles in the site. 

• The OrderEasy library  provides sample category and product page 
templates for the OrderEasy commerce catalog system. Additional 
content specific to the InternetMall/OrderEasy support may be adde
this library. A sample project, OESAMPLE, installed with QuickSite 
demonstrates OrderEasy. See OrderEasy commerce support, page 4-13.

GuestWorld template
A new template for GuestWorld has been added to the QuickSite library
See Insert a site template, page 4-3. 

OpenCube scrolling content support
OpenCube is the maker of the Smooth Scroll II Java applet. QuickSite 3
automatically generates applet code that supports this applet. See Adding 
scrolling content, page 4-15.

Automatic Meta tags
New automatic Meta tags for search engines are now generated for eve
page. And you can still define Meta tags manually. See About Meta tags, 
page 3-18.

Easier library editing
The Library menu option, Edit Library, provides a new dialog that displa
all libraries in the QuickSite program directory (the QuickSite library plu
any add-ins). This makes it easy to select library files for editing purpos

The new Library menu option, Open Add-In Library, lets you open any o
the add-in libraries so you can add specialty content to the current proje
See Using libraries, page 4-1.

Project INI editor
A new button to edit the project INI file has been added to the Project ta
the Preferences dialog (in Edit menu). See Setting/resetting preferences, 
page 2-21.
QuickSite 3.0 Getting Started Guide xiii
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Forced lower case filenames
The Build Web Site dialog (in the Project menu) now has an option to cre
a site that uses all lower case links to images and HTML files. This opti
set “on” by default, eliminates the problem of some server environments
supporting case-sensitivity.

Enhanced error notification in the To-Do list
When an image file is missing during the build process, QuickSite 
automatically marks the To-Do list for the missing image component. To
Do list entries marked as such are unmarked when the image file is no 
longer missing. See Create a To-Do list, page 2-20.

Enhanced paragraph linking
Enhanced paragraph linking and inclusion You can now utilize paragrap
components within the home or menu pages. Previously paragraph 
components could only be part of a text page. 

You can also now use the !INCLUDE directive to insert a paragraph 
component into any page. This makes it possible to define a single boil
plate piece of text, and physically insert it many times throughout your s
If the paragraph text needs to be changed, you only need to change it i
paragraph component. See Insert paragraph components, page 3-18.

Improved site import
The site import feature has been enhanced so that URL component title
names are created without the http://. Leaving a http:// reference in the 
title could potentially cause linkage problems when published. See 
Importing a site, page 4-4.

Direct technical support links
The Help menu now includes a link to the Site Technologies technical 
support and updates page on our Web site. This option launches a brow
and connects to the appropriate URL. An Internet connection must exis
when using this new feature. 

On-Line Registration
The registration dialog has been enhanced to include buttons to comple
the online registration process as well as access the QuickSite home p
xiv QuickSite 3.0 Getting Started Guide
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Advanced developer features
QuickSite 3.0 is a full-featured, professional Web site development toolk
It offers advanced capabilities such as macros, automation scripting, AP
calls, and project reports. Chapter 4, Working with Special Features.

To learn more...

)RUýWKHýPRVWýFXUUHQWýLQIRUPDWLRQýDERXWý4XLFN6LWHýDQGýRWKHUý6LWHý
7HFKQRORJLHVýSURGXFWVñýYLVLWý6LWHý7HFKQRORJLHVý:HEýVLWHýDWýKWWSãîî
ZZZïVLWHWHFKïFRPïý2XU Web site contains product descriptions, reviews, 
specifications, downloadable demo software; bulletins, press releases, 
frequently asked questions. Just click Support or other appropriate button 
there. 
QuickSite 3.0 Getting Started Guide xv
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Installing and Starting QuickSite

Chapter 1 explains how to install, start, and register QuickSite software
your computer. It also QuickSite’s startup window and describes QuickS
registration and troubleshooting options.

Before you install...
Before installing QuickSite, you need your hardware, software, and We
server to be set up properly.

Hardware requirements
Your computer hardware should satisfy these minimum requirements:

• IBM or compatible personal computer with 486DX2/66 or higher 
processor.

• CD ROM drive.

• 16 MB of RAM.

• 23 MB of available hard disk space.

• VGA or higher resolution color monitor.

• Mouse or other pointing device.

• Internet connection — either direct (such as an ISDN or T1 link) or d
up using a modem (preferably 14,400 bps or higher) for publishing y
finished site to your Web server (see Web server, page 1-2).
QuickSite 3.0 Getting Started Guide 1-1
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Software requirements
Software requirements include:

• Microsoft Windows 95.

• Any Web browser program, such as Netscape Navigator, NCSA Mos
or Microsoft Internet Explorer.

Web server
To host your Web site on the World Wide Web, you need access to a W
server that is visible to the Internet fulltime. You can set up and maintai
your own Web server individually (on a UNIX machine, PC, or Macintos
or you can rent space on a server owned and maintained by a third-par
Internet Service Provider (ISP). The Web server must have FTP (File 
Transfer Protocol) capability to publish your Web site.

ISPs, such as America Online, Compuserve, HoloNet, Netcom, Earthlin
and UUNet, offer hosting services for your Web site including FTP 
capability. Many of these services offer multiple levels of service. Prices
very based on the speed your site can be accessed and the amount of 
available for you to store your site’s HTML files and images. To locate IS
in your area, ask your software retailer, consult the phone book, or visit
these Web sites: http://thedirectory.org (The Directory) and http://
thelist.iworld.com (The List).

If your Web site is an intranet  (a Web site that is used only within your 
company), you need to host your Web site locally. Hosting your Web sit
locally requires a Web server with FTP capability but you do not need a
ISP.
1-2 QuickSite 3.0 Getting Started Guide
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Installing QuickSite software
QuickSite installation is easy. After a few questions, the Quicksite 
installation wizard copies the software and creates a Site Technologies
QuickSite program group in Windows.

Note If you have a previous version of QuickSite installed on your computer, 
QuickSite 3.0 automatically renames the library files from the previous 
version to libraryname.dbt.old and libraryname.dbf.old.

1. Download the QuickSite 3.0 installation program from the Site 
Technologies Web site, go to http://www.sitetech.com, click on the 
Download button, click QuickSite, select the installation file, and sav
to a temporary directory on your hard drive. After the file has 
downloaded, double-click the installation program file (.exe) to 
decompress the installation files and open the installer.

If you are installing from a CD, insert the CD in the appropriate disk
drive on your computer to automatically launch the QuickSite 
installation wizard. 

2. Answer the QuickSite installation wizard prompts. Unless there is a
need to change the installation path, install in the default QuickSite 
folder, c:\qs. 

Note If you install elsewhere, do not place QuickSite on one drive and its
components or project files on another drive. Also be sure the Gifs 
folder is inside the QuickSite folder.

3. When installation is done, click Yes to open the QuickSite ReadMe for 
late-breaking information not in the QuickSite online Help and 
documentation. Click the close button, , to close the QuickSite 
ReadMe document. 

4. Click the QuickSite icon, , to start the QuickSite program. Take a
moment to examine the QuickSite startup window and read about it
menu bar and toolbar features below. 
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About the QuickSite startup window
The QuickSite startup window displays the QuickSite logo. At the top is
control bar with standard Windows functions. Below that are a menu ba
and toolbar.

The menu bar
The menu bar lists the options you can click to access QuickSite functio
In the startup window, most of the menu options are greyed-out and 
unavailable because you must have a project open to use those options

menu bar
toolbar

control bar
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The same menu bar appears in the Project View, the window you se
after you create a new project or open an existing one. All of the me
options are accessible from the Project View. See What’s in a QuickSite 
project?, page 2-13. 

This menu Contains options to...

File Create new, open, save, or close a project ; import a page or site; imp
bookmarks; restore or backup a project; exit.

Edit Undo changes; cut, copy, paste, insert, delete, and find items (pages 
components); set properties; access designers; add Meta tags and To
lists; change page status; convert layout objects to HTML code; find a
replace text; change preferences.

Insert Insert pages (menu, text, and form) and components (paragraph, tab
image, script, resource file, URL, and external HTML file); insert a pag
template, a configuration section, and configuration components.

View Access Site Architect; visualize To Do lists; expand and collapse men
sections (menu pages and all their components); move through the 
Project View; show or hide items.

Project Build Web pages; build, test, and publish the Web site; check spelling
check URLs; compress the project file; use native linking (revert from
Site Architect).

Catalog Edit the catalog database; set catalog component properties; insert 
catalog components; clean out catalog images; upload (publish) catal
access commerce setup on Internet.

Library  Create, open, edit, and copy to project libraries; open add-in libraries

Wizards Run wizards for creating and managing the Web site and individual We
pages.

Help Display and search online Help; register QuickSite; link to Technical 
Support via Internet; display product and version information.
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The toolbar
The toolbar contains buttons that represent various shortcuts to access 
functions.

Tip When you point to a tool in the toolbar, QuickSite displays the tool 
description under the tool and at the bottom of the window.

Tool Menu or Hint Function

File | Open Project Opens a Web site project.

File | Close Project Closes the current Web site project.

Edit | Cut Web Page Cuts contents from a project page/component an
copies it to the Windows Clipboard.

Edit | Copy Web 
Page 

Copies contents from a project page/component
to the Windows Clipboard.

Edit | Paste/Insert 
Web Page 

Pastes contents from the Windows Clipboard into
a project page/component.

Insert | Text Page Adds a text page.

File | Import 
HTML File 

Imports an HTML file into the current page.

Project | Build Web 
Site 

Builds the entire current Web site project.

Project | Build Web 
Page 

Builds the current Web page only.

Project | Test Web 
Site 

Tests the current Web site project.

Project | Publish Builds the current Web site project and uploads 
your site to the Web server.
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Project | Spell 
Check

Checks the spelling in your Web site project.

Edit | Designers | 
HTML Editor

Launches the default design surface (HTML 
Editor, Layout Designer, or Third-party Editor).

Page Properties Defines page properties. Alternate access by 
right-clicking on page.

Catalog | Edit 
Catalog Database

Launches the Catalog Manager which you use t
add a catalog to your Web site.

Graphics 
Properties Wizard

Wizard to define graphics styles.

Edit | Change Web 
Page Status 

Toggle to change the status of a project page/
component.

Edit | Delete Web 
Page 

Permanently deletes the current Web page.

View | Collapse Collapses the Project View.

View | Expand Expands the Project View.

Edit | Find Web 
Pages 

Finds one or more Web pages.

Mark/Return 
Position

Toggle: Marks current position in the Project 
View/Returns to marked position.

Site Architect Opens Site Architect.

Help | Contents Displays online help.
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Windows control functions
QuickSite has standard Windows 95 control functions.

Click on the Site Technologies QuickSite icon at the upper left of the 
window to access a dropdown menu with Restore, Move, Size, Minimiz
Maximize, and Close options.

Click on any of these buttons, , to change window size. The left 
button reduces the window to a button on the task bar (at the bottom), t
middle button enables single/multiple window(s) display, and the right 
button closes the window.

Exiting and restarting QuickSite
You can exit QuickSite and return to Windows any time. When you are 
ready for another session, QuickSite is easy to start up again.

To exit QuickSite
You can exit QuickSite by several paths.

From the File menu in the menu bar, click Exit. Or click the close button
. Or double-click the QuickSite icon at top left of the window.

QuickSite terminates and returns you to Windows.

To restart QuickSite
Click the QuickSite icon in the Site Technologies QuickSite program gro
(see Other QuickSite group applications, page 1-9).

The QuickSite startup window appears on your screen.
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Other QuickSite group applications
The basic Site Technologies QuickSite program group includes these it

Registering QuickSite
Take a moment to register online via the Internet. 

1. Connect to the World Wide Web.

From the Help menu, click Register Site Technologies QuickSite 3.0

2. Enter the registration number.

3. Click Complete Registration. 

If you bought QuickSite through the SiteTechnologies Web site, Sal
will email you the registration serial number. If you ordered by phon
Sales will give you registration number over the phone.

Note You must be registered to turn off the QuickSite logo button, 
which automatically appears on each Web page you create. For mor
turning this button off, refer to the QuickSite Help, which you access
from the Help menu in QuickSite. 

4. Click the close button, , at the upper-right corner of the QuickSite
screen to exit QuickSite and restart your registered QuickSite.

QuickSite QuickSite program. 

QuickSite Help QuickSite online Help.

QuickSite Readme Readme document with late-breaking notes
about features and other issues not 
contained in the QuickSite documentation.
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Troubleshooting and updating QuickSite
If you cannot get a QuickSite feature to work or you have a question 
unanswered by this guide or QuickSite’s online Help, we recommend 
consulting QuickSite’s FAQs (Frequently Asked Questions) on Site 
Technologies Web site.

Site Technologies continuously updates its FAQs. You will find all kinds
interesting facts and tips there to help you. If your problem is still not 
solved, contact Technical Support online (see Accessing FAQS, Technical 
Support, and updates below) or at this number:

Technical Support (408) 461-3020.

Accessing FAQS, Technical Support, and updates
You can access information on the World Wide Web without leaving the
QuickSite program.

1. Connect with the World Wide Web.

2. In QuickSite, from the Help menu, click Site Technologies Technica
Support and Updates.

3. Select the appropriate option.

What if your computer hangs up?
Here are some troubleshooting tips.

If your computer hangs up during routine QuickSite operations

1. Make sure you have enough RAM. QuickSite needs 16 MB to run.

2. Try to open another project file. The first project file may have becom
damaged or QuickSite may be damaged.

3. If the second project file works properly, then the first project file wa
damaged, not QuickSite. Restore your project file from a backup or l
the .dbf file into Excel and save it.
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If you believe Quicksite is damaged

1. Backup your project files to another folder, then uninstall QuickSite 
through the Windows Control Panel.

2. Run ScanDisk to check for disk corruption and optionally run a 
Windows defragmentation program to optimize your disk.

3. Make sure you have 25 MB of hard disk space and reinstall QuickS
into the default directory.
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The Basics of Web Site Creation

Chapter 2 gets you started with QuickSite. We describe here the basic 
to create and publish a Web site and guide you through the process of 
creating a new Web site and explain how QuickSite projects are structu
and how the Project View, QuickSite’s main window, reflects that structu

The basic steps to site production
To create and publish a Web site with QuickSite, follow these basic step

1. Plan the site structure and contents.

2. Use QuickSite to create a new Web site project. See Creating a new 
Web site project, page 2-2.

3. Set QuickSite preferences. See Setting/resetting preferences, page 2-21.

4. Design professional-looking Web pages with QuickSite’s Layout 
Designer and/or HTML Editor or use a third-party editor. See Exploring 
the Layout Designer, page 3-1 and Using QuickSite’s HTML Editor, 
page 3-14.

5. Optionally add a catalog. See Building a commerce catalog, page 4-5.

6. Optionally add advertising. See Adding advertising, page 4-16.

7. Build and test the project. See Building and testing a project, page 3-21.

8. Publish the Web site. See Publishing your site, page 3-24.

9. Promote your site. See Promoting your site, page 4-14.
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Now that you know what needs be done, let’s see how QuickSite can he
you do it.

Creating a new Web site project
For every new Web site, you need to create a new project (QuickSite 
automatically creates a new project database for you.). A project is the set 
of documents that makes up your Web site. QuickSite stores these 
documents in project files (with .dbf, .fpt, and .ini extensions). The project 
files contain information about all of the files, links, graphics, web pages
and other items that you use to create and manage your Web site. 

When you build a project, QuickSite takes all of the information in your 
project files and generates the HTML (hypertext markup language) files 
make up your Web site. 

Follow the steps below to create a practice site. 

Tip If you want to import an existing Web site instead of creating a new one
you can use the Site Import Wizard. It must be a site that was not creat
using QuickSite. See Importing a site, page 4-4.

Create a new project
1. The first time you start QuickSite after installation, it prompts you to

use the New Project Wizard. Click Yes. 

Tip QuickSite will not automatically display this prompt again. Instead y
can open the New Project Wizard, from the File menu. Just click Ne
Project there.

The Create a New Project box opens.
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2. Type a project name, at least three consecutive characters (maximu
eight). Do not include a file extension. As an example, type mysite.

Tip Also, do not name a project index, contents, or library. And, you cannot 
use a number for the first three characters of the project name.

3. Click Create.

QuickSite creates the project files, using the project name you enter
and stores them in a QuickSite subdirectory of the same name.

Using the project name you entered, QuickSite creates a subdirecto
the QuickSite directory (default c:\qs) and adds empty project files 
(.dbf, .fpt, and .ini) to that directory. For example, for project name 
mysite, QuickSite would create subdirectory c:\qs\mysite and project 
files mysite.dbf, mysite.fpt, and mysite.ini.

4. At the prompt to use the New Project Wizard, click Yes.

If you were to click No, you could create a site without the wizard (b
you would have to manually insert pages and components, and def
page style and preferences).
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Using the New Project Wizard
The New Project Wizard asks you, step-by-step, to make decisions abo
the:

• Web site structure (branching from home page).

• Home page (title and introductory text).

• Default preferences for page components (auto-updating, header a
footer lines, and e-mail address).

• Page styles (background, header and footer lines, and bullets).

• Page layout (center page titles or not).

Selections you make in the New Project Wizard can always be changed
later. When finished with the wizard, you will have a fully-functioning, 
fully-adaptable Web site that could be published on the World Wide We

Selecting the Web site structure
The New Project Wizard first lets you select the Web site structure. The
Web site structure defines the way your site is organized and determine
how easily users can navigate pages to find the information they want. 
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1. Click the radio button next to the option for the Web site structure yo
want to use. When the radio button is black, , the option is selected. 
You can choose from:

Any of the three Web site structures (each with a home page and 
different pages under it).

A library of predefined Web sites, such as Small Business, Catalog 
Sales, and Personal Web Site, as provided by QuickSite.

The Site Architect, a new feature that lets you layout your Web site 
a diagram.

2. For this practice site, select the third Web site structure, with home 
page, four text pages, form, file, and URL components. 

3. Click Next to define the home page.

Defining the home page
The New Project Wizard asks for the home page title.

1. Type a name for your home page, such as My Home Page. The title
be up to 64 characters.

2. Click Next.
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The New Project Wizard asks you to enter introductory text for your
home page.

3. Type some text here, such as Welcome to my home page. 

If you have a text file with content for the home page, you can impor
here. Just click Import, select the .txt file to import, and click OK. 
QuickSite imports the text you selected and displays it in the Web S
Introduction window.

4. Click Next to define default settings for the Web pages.
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Defining autodate and header/footer line 
settings
By default, QuickSite selects all options in this wizard box. Selected opti
have a checkmark (✔).

1. Keep the default settings. This makes your Web page design consis
and easier to navigate.

The default settings produce the following results when you build yo
Web site:

✔ Autodate Each Page 

QuickSite automatically informs your Web site visitors when your sit
last changed. The date that is generated appears automatically at t
bottom of each page in your Web site.

✔ Include Heading Line On Each Page

A header line appears as a horizontal rule directly below the title of e
page. 

✔ Include Footer Line On Each Page

A footer line appears as a horizontal rule directly below the body of 
each page. 

2. Click Next to define your e-mail address.
QuickSite 3.0 Getting Started Guide 2-7



Using the New Project Wizard The Basics of Web Site Creation

. 
ge 
ite. 

u or 

age 

h to 
 
, a 
Specifying your e-mail address
The New Project Wizard asks you to specify your return e-mail address
This address is linked to the Send E-Mail navigation button on every pa
unless you do not include navigation buttons when you build the Web s
See Building and testing a project, page 3-21. 

1. Type an e-mail address where your Web site visitors can contact yo
your Webmaster, such as myname@aol.com. If you do not know the 
address, you can leave it blank for now and add it later. See Setting/
resetting preferences, page 2-21.

2. Click Next to define your Web page style.

Defining Web page styles
The New Project Wizard opens the Page Style box, also known as the P
Style Wizard. 

Tip You can access the Page Style Wizard from the Wizards menu if you wis
change overall page style later. Or you can use the Graphics Properties
Wizard (also in the Wizard menu) to change style on an individual page
menu section, or the entire site. 

Click Next to select a background style for your site.
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Select a background
In the next Page Style box, you can select a background for your Web s

An attractive background can add visual appeal to your Web site. You a
not limited to the backgrounds provided with QuickSite. You can copy yo
own background files (JPG, GIF, or PNG) into the gifs folder in your 
QuickSite folder (for example, c:\qs\gifs) so they are accessible from the
New Project Wizard.

Tip To optimize Web page readability, select a background with light color a
simple texture, such as gray or white.

1. Click Background.

The Select Image File box opens a list of background files in the 
QuickSite-provided Gifs folder. 

2. Click the different files to see thumbnails of what they look like.

3. Click the one you want, such as qs_chlk.jpg, and click Select to select 
it.

The Page Style box reopens with the background filename listed.

4. Click Next to select header and footer line styles.
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Select header and footer line styles
The next Page Style box opens, where you can select the color of heade
footer lines on your Web pages.

Tip QuickSite provides several attractive header and footer line colors. The
default line color contrasts with the current background (that is, dark on
light background and light on dark background). For consistency, we 
recommend selecting the same color for both lines.

1. In the Header Line box, scroll and click the header line style you wa

2. In the Footer Line box, scroll and click the footer line style you want

3. Choose Next to select a bullet style.

Select a bullet style
In the next Page style box, you can select the color for bullets in your W
site. By default, the bullets appear to the left of hypertext menu links on
your Web pages. 
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1. In the Bullet List Item box, scroll and click a bullet color from the list

2. Click Next to select the page title layout.

Select page title layout
The last Page Style box opens and displays the Center Page Titles opt
The default is to align titles on the left side of a page.
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1. Select (✔) or deselect the Center Page Titles option as desired.

2. Click Save to save your Web site project settings and automatically 
generate the project files containing the pages for your Web site.

3. Since you selected a background for your Web site, QuickSite asks
if you want to copy the background file to your project directory. Clic
Yes.

QuickSite closes the New Project Wizard and displays a QuickCues 
with informative tidbits about QuickSite features. 

4. Click on the tabs and read the QuickCues information. Then click th
close button, , in the upper right-hand corner of QuickCues to see
Project View.

Tip You can access QuickCues anytime in the Project View. Just click the ri
mouse button to bring up a menu where you can select the QuickCues
option.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help book/topic

Site creation with the New Project 
Wizard

Creating a Web site/Using the New 
Project Wizard

Site creation without the New Project 
Wizard 

Creating a Web site/Creating a new 
project without the Wizard

Define page style for the entire site Creating a Web site/Using the Page S
Wizard

Define page styles for individual pages Creating a Web site/Using the Graph
Properties Wizard
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What’s in a QuickSite project?
QuickSite Web site projects are made up of project items, such as different 
types of pages (home, menu, text, form) and page components (paragr
images, tables, scripts, catalog, etc.). The project items are organized i
hierarchical structure designed for optimum efficiency and ease of use.
Project View is the cornerstone of your project. It shows what items (pa
and components) the project contains. Through the Project View, you 
manage and update your Web site project. 

The Project View
The Project View displays an outline your Web site structure. It is kind of
asset list from which you create and maintain Web pages.

The Project View above is for the practice site structure you selected in
New Project Wizard. See Selecting the Web site structure, page 2-4. 
Indented items are subordinate items in this structure. You can see at a
glance which item is at the top level of the structure — the Home Page.
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The Home Page has subpages (in the example above, Text Page 1 and
Page 2) and links to all Menu Pages. Each Menu Page has subpages.

The Project View identifies each item in your Web site. What it does not
is show is the actual linking hierarchy  of the pages. To see that or organiz
the site pages in the superior context of a diagrammatic layout, you can
switch the view to the Site Architect. See Using the Site Architect.

What you can do in the Project View
Drag and drop to re-structure your site. Click on an item and drag and 
drop it to another position in the project. That’s all it takes to restructure
your site! QuickSite will automatically change the links in your site to ref
to the page in its new position.

Insert and delete pages and other components. Click on the Insert menu 
and review the different types of components that you can insert into yo
project. They include text (HTML) pages, menu pages, forms, tables, 
images, and more. You can delete components by simply selecting the 
and pressing the Del key. It’s easy to insert or remove items and, Quick
automatically takes care of the links.

Right-click for special commands. Select a text page and click with the 
right mouse button. Notice that a context-sensitive menu appears, givin
you access to the Layout Designer and HTML Editor, as well as the ins
content Library and a series of other commands. You can access comm
commands in the Project View and some dialogs without moving your 
mouse to the toolbar or main menu.

Add To-Do lists to your pages. Select a page and double click the colum
between the “X” and “File” columns. A To-Do list pops up for that page.
You can enter items that need to be completed for that page so you don
forget. You can have a To-Do list for each item in your project.

Edit component properties. Select a page and click the Page Properties
button. Take a look at the General, Layout, Links, and Graphics tabs. T
Page Properties dialog lets you change settings for pages without ente
page designers (discussed later), saving you precious time.
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Change a component’s page status. Have a page that’s under 
construction? Want to hide a page from casual visitors to your site? Wan
completely suspend the inclusion of a page or section of your site? All y
have to do is double-click a page’s Status column to change its status fr
Active (a green check mark) to Under Construction, Hidden, or Suspend
If you double-click a menu page, QuickSite automatically changes the 
status of each of the menu’s sub-pages. Changing the status of entire 
sections in your site is as easy as double-clicking.

Tip All pages you want to display on the Web browser need to have their pa
status set as Active (green checkmark), .

Change the names of generated HTML files. Select a page, hold the Ctrl
key down, and right-click on the page’s “File” column. A dialog appears
allowing you to change the name of the HTML file that QuickSite 
generates. Even if the structure of your site changes, the name of this p
will remain as you specified it.

Change the titles of pages and components. Select a page, hold the Ctrl 
key down, and right-click on the page’s “Title” column. A dialog appears
allowing you to change the name of the page or component without ente
the Page Properties dialog.

Add New! And Hot! icons to items. To automatically place New and Hot 
icons next to links for a page the next time your site is built, double-click 
page’s “New” or “Hot” columns. This makes it a simple matter to highlig
changes in your site for frequent visitors.

What the Project View tells you
The Project View gives the following information: 

This column Tells you...

Type Page type. 

Status (not labeled) Page status (Active, In Construction, Hidden, or 
Suspended). See For more information..., page 2-16.

Title Web page title.
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Tip The Project View optionally displays these additional columns if you set
them as preferences from the Edit menu. See Setting/resetting preferences, 
page 2-21.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

New New! icon, optionally selected by clicking column. 
Puts New! icon next to hyperlinks to this page.

Hot HOT! icon, optionally selected by clicking column. 
Puts Hot! icon next to hyperlinks to this page.

Link Page type icon(s) show the pages to which this item is 
linked. 

X The Delete web page tool displays when a page is 
marked for deletion. Double-click to mark a page for

deletion when the project is built or compressed. See 
Building and testing a project, page 3-21 and For more 
information..., page 2-16. 

To-do list (not 
labeled)

 The To-do list tool displays if the page has a To-Do
list. Double-click to display the To-Do list. See 

Visualizing To-Do lists, page 2-20.

This column Tells you...

File HTML file associated with this page.

Date Date when this page was last saved.

Time Time when this page was last saved.

To learn about See this Help book/topic

Project View structure and page and 
status icons 

Working in the Project View/Project 
View Basics/About the Project View
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Using the Site Architect 
QuickSite’s Site Architect displays your Web site structure as a hierarch
diagram, making it easy for you to define and visualize page organizatio
lets see and define actual topic paths, how the home, menu, and text p
are linked together. In comparison, the Project View shows only relative
linking of pages in a list format.

Where to access the Site Architect
• You can select the Site Architect when you create a site through the N

Project Wizard. See Selecting the Web site structure, page 2-4.

• You can access the Site Architect anytime from the View menu in th
Project View. 

Before you use the Site Architect
• When you build the site, select Include navigation text and deselect

Include navigation buttons. See Building and testing a project, page 3-
21.

Changing page status Working in the Project View/Working 
with project items/Changing the status of
an item

Navigating the Project View Working in the Project View/Project 
View Basics/Moving around the Project 
View/

Selecting, moving, and, marking 
project items

Working in the Project View/Working 
with project items

Changing the Project View display Working in the Project View/Changing
views

Adding sections Managing a Web site/Creating nested 
menus
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QuickSite will then automatically include text navigation bars at the 
bottom of the pages that reflect the hierarchical structure you define
the Site Architect. On each page, the text navigation bars will includ
link to the Home page, the page above (parent) and all pages below
(children). 

• You can optionally create customize text navigation bars by embedd
special page macros in your pages. These macros, ::NavBar, ::NavUp, 
and ::Nav Down, are described in the QuickSite Help. See For more 
information..., page 2-21.

View and change the topic path structure
1. In the project you created in this chapter, click the View menu, then 

click Site Architect, or click the  tool. 

2. Click Topic Path.

The Site Architect displays a diagram of the Web site hierarchy. It 
shows how pages in the site are linked together. 

3. To change the name of a page, double-click the page topic box and
another title, and click OK.

4. To add a new page under a page, right-click the page topic box and 
New Page. Name the new topic as described in step 3.
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5. To delete a page, right-click the page topic box, click Delete Page, a
click Yes.

6. To expand or contract the view for any path, click the arrow in any o
the topic boxes.

7. From the File menu, click Save and then Exit to return to the Projec
View.

Tip You can also add and delete pages and change the view (zoom, hid
toolbar, print, etc.) from menus at the top of the Site Architect.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help book/topic

The Site Architect Changing project structure/Using the 
Site Architect

Page macros Using the HTML Editor/Scripting and 
macros/Using page macros
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Visualizing To-Do lists
The To-Do List is a handy way to keep track of your Web site developm
tasks. Items with To-Do’s are marked in the Project View. 

The To-Do list icon, , displays in the column to the right of the Delete
Web Page column (X). See What’s in a QuickSite project?, page 2-13. If the 
page has a To-Do list, you double-click to display the To-Do list.

You can use QuickSite’s Visualizer tool to graphically view To-Do lists in
context with the Web site structure so you can instantly see what needs 
done.

Create a To-Do list
1. Double-click a page in the Project View where you want to create a 

Do list. 

2. Right-click and select To-Do List.

The To-Do List text entry window opens.

3. Type in your To-Do notes using standard Windows editing keys and
tools in the tool bar.

4. Click the Save changes tool, ,to save your To-Do list.

5. Click the Close editor tool, ,to close the To-Do list.

Visualize which page topics are in the To-Do list 
1. From the View menu, click Visualize. 

2. Click To-Do Items.

The Visualizer displays a diagram of the Web site hierarchy, like in t
Site Architect. Using the Site Architect, page 2-17.

In addition, the Visualizer highlights pages that are in the To-Do List 
you can instantly see what pages need attention. 
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For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

Setting/resetting preferences
When you create a Web site with the New Project Wizard, you need to 
certain preferences, such as project and publishing preferences. Prefer
determine QuickSite’s performance in creating your Web site project, 
building and testing your Web site, and so on.

Access preference settings
1. From the Edit menu, click Preferences.

The Preferences box opens to the QuickSite tab.

To learn about See this Help book/topic

Using To-Do lists Project View basics/Using to-do lists

Project View basics/Visualizing the to-do 
list

preference tabs
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2. To access other preferences, just click the related tab.

3. Click Edit QS.INI to edit the qs.ini file. 

Tip IN the Project tab, you can access the PROJECT INI file with the Ed
Project INI button. You can edit macros and user-definable variables
the project INI. You can also insert an [AddIns] section in the projec
INI to expand support of custom libraries. This section presently 
contains several INI variables: AlternateGraphicsPath, CopyToPubl
See latest README documentation for new variables.

4. Be sure to click Save before you exit the Preferences box.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help book/topic

Setting QuickSite program preferences Setting/resetting preferences/To set 
preferences in the QuickSite tab

Setting Project preferences Setting/resetting preferences/To set 
preferences in the Project tab

Setting Publish preferences Setting/resetting preferences/To set 
preferences in the Publish tab

Setting default graphics Setting/resetting preferences/To set 
preferences in the Std Graphics tab

Editing the QS INI file Setting/resetting preferences/Setting an
changing preferences

Setting/resetting preferences/Editing the
Project and QuickSite INI files

Using QS.INI to define macro 
variables

Using the HTML Editor/Scripting and 
macros/Defining macro variables

PROJECT.INI variables Setting/resetting preferences/Editing th
Project and QuickSite INI files
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Opening and closing a project
The mechanics of opening and closing a project are simple.

Open a project
You can open an existing QuickSite project file to inspect or edit its 
contents. Any changes you make during your editing session are saved
automatically.

1. In the File menu, click Open Project or click the Open project file ico
.

2. The Select a Project box opens and lists projects (projectname.dbf 
files) in the current directory.

3. Select the Directory and File Name of the project you want to open.

4. Click OK.

QuickSite opens and displays the project in the Project View.

Close a project and the Project View
When you close a project, QuickSite automatically saves it.

• From the File menu, click Close Project or click the  tool.

QuickSite saves any changes and closes the project file, then close
Project View.

Close a project and keep Project View open
• From the File menu, click Open Project.

QuickSite automatically saves and closes the current project, then o
the next one you select.
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Quitting your QuickSite session
You can quit QuickSite without closing the project file.

• From the File menu, click Exit.

QuickSite saves any changes, closes the project file (if you have no
then quits.
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Designing Web Pages

Chapter 2 guided you through the process of creating a basic Web site 
framework with QuickSite and structure it with the New Project Wizard a
Site Architect. Now let’s learn how to use some of QuickSite’s page des
features to enter content and enhance the appearance of this practice s
without knowledge of HTML coding!

QuickSite has so many features that a single tour can only touch the sur
Therefore we have selected features to demonstrate in Chapter 2 that 
demonstrate the potential of QuickSite’s unique page designers, known
the Layout Designer and the HTML Editor.

Chapter 3 continues our walkthrough with some special features that sh
the variety of Web site development capabilities that QuickSite brings its
customers. 

Exploring the Layout Designer
With QuickSite’s Layout Designer you can actually see what your page 
layout is going to look like before it is built. The Layout Designer gives yo
full control over the placement of text, images, and advanced objects on
your pages—without having to write a single line of HTML code!
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The Layout Designer canvas
The Layout Designer canvas is the main work area where you compose te
and add graphics. Horizontal and vertical toolbars give you access to 
Layout Designer features and a preview box lets you preview fonts. Menus 
provide alternative access to Layout Designer feature.

Page layout is a snap. You just insert and edit objects (text, images, for
ActiveX, Java applets, and audio/video clips) to form the page layout. Y
can also conveniently or drag’n drop or paste from other applications. 

canvas

horizontal toolbar
menus

vertical toolbar

preview box
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To give you some idea of what you can accomplish with the Layout 
Designer, see the sample home page below. 

Open the Layout Designer
To open the Layout Designer, go to the Project View and do one of the 
following. 

• Click the page you want to design and, from the Edit menu, click Lay
Designer.

• Right-click the page, then click Layout Designer. 

• If the default page editor is Layout Designer, double-click the page. T
Layout Designer is made the default through Preferences. From the
menu, click Preferences, select Layout Designer as Default page Ed
and click save.

custom text style 
and page layout

custom header

custom rule line

aligned and
sized graphic
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Turning on/off Layout Designer tools
You can control what toolbars are displayed. Just select options from th
View menu or click the Text, Colors, and Images buttons to turn on or o
vertical toolbars on the right side of the canvas. 

For instance, click Color Bar to display the vertical color selector. Then 
drag and drop and color from the color selector to the canvas. 

Then click the Setup button to open a dialog where you can define the p
background setup in one place.

Try dragging and dropping a color from here to the canvas. You can Th
toolbar is the starting point for easy page design. It enables instant inse
of 

• Text and image objects.

• Tables.

• Form elements (push buttons, radio buttons, check boxes, and form
selection, form text, and form edit boxes).

• Multimedia files.

• ActiveX controls.

• Java applets.

We demonstrate the insertion of only text, image, table, and form objec
here. For information on all Layout Designer features, refer to the online
Help. 

Add text to layout objects
You can place text and other objects anywhere on the Layout Designer
canvas. QuickSite gives you the ability to stylize text without writing cod
to get the look you want. 

1. To create a text object, click the Text tool, , click in the page area
and drag out a rectangle for the object. Then type the word Welcome!.

2. Double-click inside the text object to open the Text Properties box, 
where you can also type or edit text and control its format.
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3. Click the Bold and Italic tools in the Text Properties toolbar. Then cli
the font size tool, , to increase the text size. Note the other text 
formatting tools in the toolbar. 

4. Click OK.

The text object appears on the layout canvas. 

5. Click outside the text object and drag it to the desired position. To se
another object, click the Pointer tool, , and click the object.

Working with images in layout
Adding images to your layout is a snap. You can also set properties for 
images, including links, image maps, sizing, alignment, and more.

Use the Image tool

You can add images to the layout object with the Image tool.

1. In the Layout Designer toolbar, click the Image tool, .

On the layout canvas, drag the mouse to form a rectangle area and
release the mouse button.

2. In the Image Properties box, click Browse to select an image file an
click OK.

The Image Properties box closes and the image object you selected
appears on the canvas. 

Drag and drop an image from the vertical toolbar

A quick way to insert an image is to drag and drop it from a picklist in th
vertical toolbar. This method is especially handy if you know what the 
images are by their names.

1. If the image picklists are not displayed, click the Images button.

2. Drag and drop any of the images from the QuickSite Gifs list or the 
Project list to the canvas. 
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Drag and drop an image from Internet Explorer

You can drag and drop images from any drag-enabled Windows applica
such as Microsoft Internet Explorer. See Creating links in Layout, page 3-9. 

1. Launch Internet Explorer and browse a Web site that contains imag
you would like to place in your layout. Note that many images on th
Web are protected by copyright. You should only use images in you
site for which you have rights.

2. Position Internet Explorer so you can see QuickSite Layout Designe
behind it.

3. Hold down the left mouse button on the desired Internet Explorer 
image, drag it to the Layout Designer canvas, and release the mous
button.

The image appears on the canvas. 

4. Reposition the image as desired by dragging it.

Change image properties

You can change the image size, alignment, and other properties.

1. Double-click any image object on the layout designer canvas to ope
the Image Properties box.

2. In the Size, Align, and Misc tabs, change image property options.

Of special note, the Misc tab has options for border display, image m
information, link specification (type a URL or file name here or click 
Project Links to select a project item), alternate text, and backgroun
color. 

3. Click OK.

4. Adjust the border around the image object by dragging the object 
handles. 
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Changing background color in Layout
The initial background color for your layout is the default browser color,
gray. Changing colors for the background of Layout Designer objects is
simple matter of dragging and dropping from the Layout Designer’s colo
selector in the vertical toolbar. 

1. Click the Welcome text object on the canvas. 

2. Drag a color from the color selector onto the background of the obje

The background color of the object changes.

Changing text color in Layout
You can change text color in much the same way you do background co
Just drag the color directly onto one of the characters in the text. 

For added control in coloring small text objects, double-click the text obj
and, in the Text Properties box, highlight the text. Then click the text co
tool, , and select a color. 

You can use the background color tool, , in Text Properties to change
background color for a text object. 

Creating tables in Layout
The Layout Designer has a powerful table editor where you can paste t
you have copied from other applications. 

1. Click the Table tool in the Layout Designer toolbar, .

2. Drag out a fairly large rectangle on the layout designer canvas.

The Table Properties box opens. You can change the table settings 
such as number of rows/columns and border size. 

3. Click OK to accept the defaults.

A 4x3 table appears on the Layout Designer canvas. Notice how yo
can drag the row and column borders to change row height and colu
width, 
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4. Click in a table cell and type some text. Then double-click to open th
Text Properties box, where you have a larger area for editing text an
can select options to control text style, alignment, and color. 

Click to close OK to close the Text Properties box.

Tip Click outside the table on the layout canvas and then right-click the 
table object. Note the various table editing options you can select.

Dragging and dropping text from external 
applications
The layout designer allows you to drag and drop text and image objects
from OLE-compliant applications to layout objects. As we demonstrated
earlier in Drag and drop an image from Internet Explorer, page 3-6, you can 
drag and drop images from Internet Explorer. You can also use the sam
method to drag and drop text from Internet Explorer and other applicatio

Drag and drop from Excel

1. Launch Microsoft Excel and select a range of cells.

2. Position the Excel window so that you can see Layout Designer beh
it.

3. Click and hold on the border of the selected cells in Excel, drag it ov
the layout designer, and release the mouse button.

Drag and drop from Word

1. Launch Microsoft Word and select some text.

2. Position the Word window so that you can see the Layout Designer
behind it.

3. Select and drag the text in Word or Excel to the layout designer and
release the mouse button.
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Creating links in Layout
One of QuickSite’s outstanding features has always been the way it han
links. This includes the Layout Designer, which lets you create project a
library links. Since QuickSite manages these links, they will never be 
broken. If the name, location, or content of the item to which the link ref
ever changes, QuickSite ensures that all references to this link will be 
updated and maintain their integrity. This completely eliminates the nee
for hand-coding and tracing broken links.

Create a link to another page in the current project:

1. Create a text object in the Layout Designer and click the Project but
(on the right).

A list opens with the pages to which you can create a link in the lay

2. Double-click the page to which you would like to create a link.

The Layout Designer inserts the name of the linked page, surrounde
carets (^). When you later build the page, QuickSite automatically 
substitutes the HTML code necessary to create a link to the approp
page.

3. Click the Save tool in the Layout Designer toolbar, , to save the w
you have done so far and, from the File menu, click Exit.

4. In the Project View, right-click on the layout page and click Page 
Properties. In Page Title, type Layout Page as the title for the page.
While in Page Properties, look at the tabs to see all the properties y
can change for an individual page. We will not go into these in deta
here. Page properties are fully documented in QuickSite Help.

Create a link to an external site

1. In the Project View, click Text Page 1 and, from the Insert menu, clic
URL Component.

This inserts an Untitled URL Component in the Project View.

Double-click the Untitled URL Component to open its designer and 
specify a name (such as Site Technologies) and URL (such as 
www.sitetech.com).
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2. Click Save to close the URL component designer and double-click t
reopen Layout Page. 

3. Create a text object. See Add text to layout objects, page 3-4.

4. Click the Project button to display the list of available project links.

5. Double-click the URL component you created in step 1.

The name of the linked URL appears on the canvas, surrounded by
carets (^). When the page is built, QuickSite will substitute the HTM
code that links to the desired URL.

Inserting form objects
Form objects are HTML-coded FORM elements that allow Web site 
visitors to enter data and interact with the Web site. Data entered into th
form object is sent to a program on the server for processing. The visito
browser must support FORM elements in order to display form objects.

You can insert a number of form objects through Layout Designer and n
have to know HTML code to do it. However, to make form objects perfo
properly, the QuickSite user must know how to define them. Such 
information can be gotten from the World Wide Web. See the sample fo
on the following page.
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Insert a pushbutton object

Web visitors can press a pushbutton to perform some action while readi
form.

1. In the Layout Designer, click the Insert pushbutton tool, .

2. Click the point on the canvas where you want to insert the form 
pushbutton object.

A red rectangle appears at the insertion point and the Form Button 
Properties box opens.

3. Under Control Name, type the object name, for example, you might
name a pushbutton Submit if it’s going to be used to process incoming
data. A unique name is required for each form object.

The object name is not visible on the Web page. It is used to identify
object for scripting applications.

4. Under Value, type the object’s value, for example, the value for a sub
pushbutton might be Send Message. The value is processed when the
Web visitor clicks the button. It also appears as a title on the pushbu
QuickSite 3.0 Getting Started Guide 3-11
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5. Click to select the pushbutton type: Submit or Reset.

6. Form properties define the form attributes for the page and are 
required to make the form object work properly. If you have multiple 
form objects on a page, you only have to specify form properties for 
one of the objects.

To specify form properties, click Form Properties and fill in these 
boxes: 

Action

The URL (Uniform Resource Locator) of the CGI (Common Gatewa
Interface) script that processes the form data, for example, http://
formaction.cgi.

EncType

Data encoding type. Generally, leave as the default value. If you do
know specifically the type is different, do not change it.

Event Statements

Script statements that define what to do when an event happens, fo
example, 

OnSubmit=functionname

will excite a function with given name when the Submit button is 
pressed. 

Method

Determines what is to be done to the object specified by the URL. C
Get or Post. 

Get tells the server to get the object from the server. 

Post tells the server to post data to an object on the server. 

Consult your Internet Service Provider (ISP) for the preferred metho

7. Click OK to close the Form Properties box.

8. Click OK to close the Form Button Properties box.

The pushbutton appears on the canvas. The functions you specified
work when you build and test the page.
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Tip To reopen the box for this or any object you create, just double-click
object.

Inserting ActiveX and Java objects
ActiveX controls let you add dynamic content, such as animated button
timers, and charts, to your Web pages. 

Much is being said and written today about ActiveX applications. Consu
the World Wide Web for more about ActiveX.

http://www.activex.com/

http://www.microsoft.com/intdev/controls/ctrlref-f.htm

http://www.microsoft.com/activex/gallery/

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help topic

Layout Designer interface Using the Layout Designer/Layout 
Designer basics/(all topics)

Horizontal and lines in Layout Using the Layout Designer/Creating a 
custom layout/Adding horizontal and 
vertical rule lines

Form objects in Layout Using the Layout Designer/Inserting 
interactive objects/Inserting form objects

ActiveX and Java objects in Layout Using the Layout Designer/Inserting 
interactive objects/Inserting an ActiveX 
control object

Using the Layout Designer/Inserting 
interactive objects/Inserting a Java objec
QuickSite 3.0 Getting Started Guide 3-13
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Using QuickSite’s HTML Editor
QuickSite’s HTML editor complements the Layout Designer. When 
revisions to HTML or new tags appear, no WYSIWYG editor can 
immediately support those tags without modification to the editor by its 
publisher. At the same time, many Web developers actually prefer to wo
in raw HTML mode. QuickSite provides an HTML editor that allows 
advanced authors to write their own code and provides an efficient codi
environment.

Opening the HTML editor
1. In the Project View, right-click Layout Page.

By default, QuickSite launches the Layout Designer when you doub
click a page. Right-click opens the HTML Editor. 

Audio and video clips in Layout Using the Layout Designer/Inserting 
interactive objects/Inserting an audio clip 
object

Using the Layout Designer/Inserting 
interactive objects/Inserting a video clip 
object

Plug-in objects in Layout Using the Layout Designer/Inserting 
interactive objects/Inserting a plug-in 
object

Converting a layout object to HTML Using the HTML Editor/HTML Editor 
basics/Converting layout objects to 
HTML code
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Tip To change the default setting so double-clicking opens the HTML 
Editor, all you have to do is go to Preferences in the Edit menu and 
change Default Page Editor to HTML editor.

2. Note that the HTML Editor does not display the content you created
the Layout Designer for this page. However, when the page is built 
tested on the browser, any HTML that you created in the HTML edit
will appear before the Layout Designer content. 

After we write some HTML, we will demonstrate how you can make
the Layout Designer content appear at a specific position in the HTM
Editor content.
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Write some HTML
You can type HTML code directly into the HTML Editor by hand, use the
toolbar to insert frequently-used tags, or display the HTML tags floating
window to automatically type other HTML tags for you.

1. In the HTML editor, type something like Welcome to my page. I’m 
creating my own HTML!

2. Select Welcome and click the Bold button in the editor’s toolbar.

3. QuickSite surrounds the selected text with the <b></b> HTML tags 
for bold text. Notice that the HTML code has been color-coded in blu
This makes it easy to distinguish your content text from the HTML 
code.

4. Select (highlight) the word creating and click the HTML Templates 
Toolbox button in the toolbar.

The HTML Tags box lists HTML tags and other special information 
that can be inserted into your page by double-clicking. The tags are
divided into categories. By default, all categories are listed. 

5. To display individual categories in the HTML Tags list, click the Sele
Menu Category button. Continue clicking this button to view the 
different tag categories.

6. Scroll down the list until you find the BIG - Larger Text tag and doub
click.

The <BIG> tag appears in the HTML Editor, bracketing the selected
word, as <BIG>creating</BIG>.

7. With the HTML Tags list still open, select the words. my own HTML!, 
in the HTML Editor.

8. Click the Select Menu Category button in the HTML Tags window un
the Special Text Formatting category displays.

9. Double-click the FONT COLOR tag to insert around the selected te
<FONT COLOR=>my own HTML!<FONT COLOR>.

10. Click to place the insertion point after the “ ” sign in COLOR=.
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11. Click on the Select Menu Category in the HTML Tags window once 
more to show the Special Markup category.

12. Double-click the Color Picker, choose a color, and click OK.

The hexadecimal equivalent of the color you selected, such as #FF0000 
for red, is inserted as the COLOR= attribute, COLOR=#FF0000. 

Modify the HTML tags list
You can edit the HTML tags list so that you are not left behind when 
modifications to HTML or proprietary tags are introduced.

Add an HTML tag

• To add a tag, select the tag below where you want the new tag to ap
and click the Add New Category or Menu Option button. 

The Edit Menu Item dialog appears, and you can specify the code o
text that QuickSite will enter when you double click the new tag in th
floating tags window.

Tip You can also add new categories of tags and reorganize the conten
the tags window by cutting, copying, and pasting items.

Edit an HTML tag

• To edit an existing tag, simply right-click its name in the floating tag
window.

Validate HTML code
QuickSite points out errors in HTML code on-the-fly, before you test or 
publish your site so you can identify code that may be problematic for 
specific browsers.

• In the HTML Editor, type some incorrect HTML, such as

<BOLD>I want this text to be bold.<BOLD>

(where the last tag should be </BOLD>.)
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Notice that QuickSite has underlined your code in red! A red underl
indicates that the tag you have typed is not recognized by QuickSite
HTML validation facility.

You can optionally turn off error highlighting by deselecting 
(unchecking) Highlight HTML Errors from the View menu. 

About Meta tags
QuickSite now generates Meta tags for search engines for every page. T
tags provide tags for basic identification and the nature of the site 
construction. Users should continue to use the special Meta tags featur
(right- click on the Project View) to define keyword and description tags 
your Web site.

Insert paragraph components
QuickSite has made it easier to work with paragraphs. From the insert 
paragraph components in home or menu pages as well as text pages.

You can also now use the !INCLUDE command to insert a paragraph component 
into any page, for example, to add insert the My Paragraph component
the HTML Editor you would type at the point of insertion

!INCLUDE “My Paragraph”

If the paragraph text needs to be changed, you only need to change it i
paragraph component. QuickSite will automatically make the changes f
you, everywhere the !INCLUDE command occurs for the paragraph.

Create library and project links
The HTML Editor lets you create library and project links in much the sa
way as you do in the Layout Designer. See Creating links in Layout, page 3-
9.

1. In the HTML Editor, click the Library and Project Links tool, .

2. Click Library Links and double-click Guestbook Image in the list.

QuickSite inserts the name of the library item surrounded by carets,
^Guestbook Image^ on the page. 
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3. Click the  tool again and, this time, click Project Links and double
click Text Page 2.

The select page appears as a linked item, ^Text Page 2^ on the page.

When QuickSite builds the site, it will automatically substitute the 
appropriate HTML to create these links. You can also change the 
content of the item which the link refers, and the content will be 
updated when you next build the project. Once QuickSite generates
link, it will never be broken!

Change position of Layout Designer content on 
the page

Now back to the Layout Designer item you created in Exploring the 
Layout Designer, page 3-1. Since you now have added content to the
Layout Page in the HTML Editor we can demonstrate how easy it is
move the layout portion you made in the Layout Designer anywhere
the page. 

Remember, by default, content you add in HTML Editor will come 
before the layout component unless you tell it QuickSite you want th
layout component elsewhere on the page.

1. To mark where the layout object is to appear on the page, to within y
custom HTML code, click the scrolling style box in the HTML Editor
toolbar (set by default as Paragraph) 

2. Select Layout Object (at the bottom of the list). 

QuickSite inserts a marker 

<!--QUICKSITE LAYOUT_OBJECT-->

where the layout object will appear when you build and test the site
QuickSite 3.0 Getting Started Guide 3-19



Using QuickSite’s HTML Editor Designing Web Pages

any 

 

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help book/topic

HTML Editor basics Using the HTML Editor/HTML Editor 
basics

Customizing the HTML tags list Using the HTML Editor/Working with 
HTML/Customizing the HTML tags list

Paragraph components Changing project structure/Inserting 
paragraph components

Script templates Using the HTML Editor/Scripting and 
macros/Creating script and using script 
templates

Using the HTML Editor/Scripting and 
macros/Customizing the Script templates
list

Customized headers and footers Using the HTML Editor/HTML Editor 
basics/Customizing headers and footers

Spell-checking Using the HTML Editor/HTML Editor 
basics/Checking spelling

Customizing the HTML tags list Using the HTML Editor/Working with 
HTML/Customizing the HTML tags list

Meta tags Using the HTML Editor/Working with 
HTML/Embedding Meta tags

Using the HTML Editor/Working with 
HTML/Automatically generating Meta 
tags

Style sheets Using style sheets/(all topics)

Checking URLs Adding file and URL links/Verifying 
URLs
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Building and testing a project
Its time to build and test the project you have been working on. When y
build a Web site, QuickSite takes all the information in the project file (su
as links, text, and graphics) and creates an entire Web site with all the 
necessary HTML files. When you test the project, you preview the entir
Web site locally on your Web browser. This test version of the Web site 
looks just like it will on the World Wide Web.

Select page features
You can select which text and graphic features to include in your Web pa
when you build and test your site.

1. From the Project menu, click Build Web Site, or click the Build Web 
Site tool, .

The Web Site Construction Options box opens.

For this practice build and test, we will leave the default settings as 
The QuickSite Help provides a full description of these settings and
those on the other tabs in the Web Site Construction Options box. 

Tip A new option, Force links and files to lower case, takes care of the 
problem of some servers not supporting case-sensitivity.
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2. Select Build/Test.

3. QuickSite launches your Web browser, such as Netscape Navigator
test the site. Your Web browser automatically displays the home pa
for your project. If you have two browsers, click Yes to the prompt to
view the second browser so you can witness QuickSite’s dueling 
browsers feature in action. See Dueling browsers, page 3-22.

4. Examine the pages in the site and review what you have content yo
gave added so far.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

Dueling browsers
To ensure you are implementing features supported by most browsers,
advantage of QuickSite’s dueling browsers. Dueling browse technology 
you compare your Web site in two browsers at the same time.

1. Install two browsers on your computer. Most people install Netscape
Navigator and Internet Explorer. 

2. Once the browsers are set up, launch QuickSite and select Preferen
from the Edit menu.

3. Specify the locations of your browsers in QuickSite’s preferences un
Primary Web browser and Secondary Web browser.

4. When you are ready to build your site, in the Web Site Construction
Options box, click the Performance tab and select Launch 2nd brow
Building and testing a project, page 3-21.

To learn about See this Help book/topic

Build and testing a single Web page Building and testing a Web site/Buildi
and testing a single Web page.
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5. Click Build/Test.

When QuickSite finishes building your site, the two browsers are 
launched so you can see what your site looks like in both at the sam
time.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

Viewing Project View and browser side-by-side
When testing, you can view both the QuickSite Project View and the 
browser side-by-side. To do this, click the  button in the top right-han
corner of each control panel. Click the icon again to restore the window
full desktop size and a single window view.

You can adjust the size and position of the windows with the Size and M
options, accessed by clicking the QuickSite icon and the browser icon in
upper left-hand corner of the respective window.

Tip When QuickSite and the browser are side-by-side, the browser may sto
refreshing its screen as you work in the Project View. To make the brow
refresh again, you must build or build/test the project.

To learn about See this Help book/topic

Viewing dueling browsers Setting/resetting Preferences/To set 
preferences in the QuickSite tab.
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Publishing your site
With QuickSite, you no longer have to manage files and transfer them t
your Web server manually. At publish time, QuickSite automatically logs
onto your server and uploads your site’s content. All you need to do is 
specify your publishing preferences, and QuickSite will do the rest.

Note To automatically publish your site, you need FTP access to the server 
directory where your site will reside when it is published. See your ISP 
(Internet Service Provider) or server administrator.

1. Open the project file you want to publish.

2. From the Edit menu, click Preferences. 

3. Click the Publishing tab.

4. Specify your user ID and password, your Web server’s FTP address
and FTP target directory. You can obtain this information from your I
or server administrator.

5. If you are creating a Web site for your corporate intranet , you may 
have direct file access to the server on which your site will reside. 
Instead of transferring your site files via FTP, you can copy the site 
the server directly from your machine. 
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To have QuickSite do this for you, under NetHost File-based Intrane
and Staging Support, in Target Directory, type or browse the drive a
path (for example, n:\server\site\myproj\) of the appropriate network 
or local server directory in Target directory. Then select the Enable 
checkbox. 

6. Click Save. 

7. In the Project View, from the Project menu, click Publish, or click the
Publish tool, . 

8. Click Build when the Web Site Construction Options box opens.

QuickSite makes the appropriate connection to your ISP or server a
uploads all of your Web site files to their appropriate location via FT

During this process, the Publish dialog indicates the progress of the
transfer.

For more information...
Access QuickSite Help from the Help menu. Click Contents and select 
of the following related topics.

To learn about See this Help book/topic

Publishing Publishing and promoting a Web site/
Publishing on the World Wide Web
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Working with Special Features

Chapter 4 expands your QuickSite experience. Now that you created, 
designed, built, and tested your first Web site project with QuickSite, let
look at some diverse features that will help customize your Web site: 

Using libraries
You don’t need to spend time developing forms, images, JavaScripts, a
other content when you can add them to your project instantly with 
QuickSite’s libraries. QuickSite provides instant content that you can dr
directly into your site.

Insert library content
In this example, you will insert a guest book page, complete with a form 
graphics.

1. Create a QuickSite project or open an existing one.

2. Click on the page below which you would like to insert a guest book

Libraries and templates Project reports

Site imports Macros

Commerce catalog production Automation scripting

Scrolling banners Application Program Interface (API) calls

Rotating advertisements
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3. From the Library menu, click Open Library.

The QuickSite library list opens. As you can see, the library comes w
dozens of useful components.

4. Double-click the Guest Book item. 

QuickSite automatically inserts a quest book page into your project.

5. Build and test your project to see the results. Building and testing a 
project, page 3-21.

Add to the QuickSite library
You can add to QuickSite’s library through the Copy to Library option in t
Library menu. 

You can also create your own custom libraries from scratch. Libraries g
you the ability to store reusable components for easy access.

Edit a library
The Library menu option, Edit Library, now displays all libraries that resi
in the QuickSite program folder (default c:\qs). This includes the QuickS
library, named library.dbf, and any custom ones you have created as add

Open an add-in library
A new Library menu option, Open Add-In Library, lets you open any of t
add-in libraries as a project so you can build specialty content and have 
access to the components. 

Add a site template
You can add to the template collection by simply copying a QuickSite 
project into the next numbered Site folder under the Sites folder 
(c:\qs\Sites\Site_0x). Site folders must all have the name numbering for
Site_0x, such as Site_01, Site_02, etc.) This template will automatically
available from the library of predefined sites in QuickSite’s New Project 
Wizard.
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Insert a site template
A template is a page element, such as a form, that you can add to a pa
You can also insert a template as a whole page in the Project View. Of n
is the new Guestworld template, which has been added to the QuickSite 
library. The template has two links, one to sign the guestbook and one 
view the guestbook. 

Insert the template in a page

1. Open the HTML Editor

2. Click the Library and project links tool, .

3. Click Library Templates.

4. Scroll to the bottom of the list and click GuestWorld Template.

The template appears in the page.

Insert the template as a page

1. In the Project View, click the page below which you want to insert th
template.

2. From the Library menu, click Open Library.

3. Scroll to the bottom of the list and click GuestWorld Template.

The template appears as a page in the Project View.

Use and deploy the template

Build and test the site if you want to see the template links. To actually 
make the links functional, you must visit the GuestWorld site and get an
owner ID. Your owner ID must be inserted into the GuestWorld template
See http://www.guestworld.com for more details. 

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.
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Importing a site
If you have been working on a Web site using other Web development to
QuickSite lets you import your site so that you can start managing it mo
efficiently in minutes. The site that you import must be resident on your
local machine and not be created by QuickSite. 

If you need to import a site from the Web, use a tool that downloads site
and transfers them to your local hard disk. Once you have the site on y
local machine, identify its home page HTML file and follow this procedu

1. From the File menu in a new, empty project, click Site Import.

The Site Import Wizard opens.

2. Click the Browse button and locate the home page HTML file for the
non-QuickSite site you wish to import (the home page is often calle
index.htm).

3. Specify other site import options and click Import.

To learn about See this Help topic

Libraries Working with libraries/(all topics)

Library links Adding project and library links/Adding 
QuickSite library links

Templates Adding project and library links/Using 
library content as templates

Creating a Web site/Making Web site 
structure templates

Add-in libraries Working with libraries/Creating a custom
library

Working with libraries/Opening an add-
in library
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QuickSite imports the site and all its content and stores the informa
for the site in the current QuickSite project database. Now you are re
to use QuickSite features to enhance and manage your imported si

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

Building a commerce catalog
If you need to offer products and services on the Internet, QuickSite 3.0
gives you the tools to quickly and easily transform your raw product 
information into lively, interactive on-line catalogs.

The catalog project
To demonstrate how easy it is to set up and create your own catalog an
order form with QuickSite, let’s look at a sample catalog project. 

1. Use the New Project Wizard to create a new project. Name the proj
Catalog. See Creating a new Web site project, page 2-2.

2. In the Select Web Site Structure box, click Select from a predefined
of libraries and click Next.,

3. Select Catalog Sales and click Next.

4. Optionally add an email address and click Next.

The new site, with Bay Discount Auto Broker as the home page, op
in the Project View.

To learn about See this Help book/topic

Site import options Using the HTML Editor/Importing text 
and files/Importing a Web site
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5. Build and test the project to see what it looks like. See Building and 
testing a project, page 3-21.

The Catalog Manager
The information for each product in your catalog is stored in a database
which you can access using QuickSite’s Catalog Manager.

1. In the Project View, click the Catalog Manager tool, , to display th
product database.
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Several categories and products are listed in the Catalog Manager.

2. Double-click Sports Cars, the first category in the list, to open the 
Category box. The Category box is where you can change the 
description for any category in the catalog. 
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3. Click the category buttons in the left panel to move to other categor
in the catalog. When done, click Save or the Close button at top 

4. Double-click 1979 Ferrari 308 GTS, a product under the Sports Car
category.

The Product box opens. You can specify information here concernin
the description, pricing, specials, effective dates, product images, a
more. QuickSite lets you use category and product templates to acc
the information you create in the Catalog Manager.

5. After exploring the Product box, click Save or click the Close button
top.

6. Close the Catalog Manager.

Category and product templates
Once you have a database of product information, how will you present
products on your Web site? When creating a catalog, it is critical to pres
products in a meaningful manner that makes it convenient to browse 
through the products. In the past, building a commerce-oriented site ha
required expensive HTML, CGI, Java Script, or other advanced 
development efforts. With QuickSite, all you need are a couple of templa
and you have the basis for your catalog.
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When building a project, QuickSite looks at the selected category and 
product templates and automatically creates category pages for each 
category, and product pages for each product. The advantage of using 
templates to present your products is that you have control over the look
contents of your product pages. And QuickSite automatically creates th
product pages for you!

When you create a template, you design it to your taste and include 
references to Catalog Manager database fields (see below) for which 
QuickSite substitutes the appropriate product or category information w
the project is built.

The Bay Discount Auto Broker project gives you examples of creating 
templates using two different methods—the HTML Editor and the Layou
Designer.

A closer look at the category template

Category templates display product lists from which you can link to 
product pages and are stored in your project’s Configuration Section (a
bottom of the Project View). The default category template used in the B
Discount Auto Broker project was created in QuickSite’s HTML editor. I
could also have been created in Layout Designer.

1. Right-click Default Category Template in the catalog project and clic
HTML Editor to open the template. 
QuickSite 3.0 Getting Started Guide 4-9
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Notice the HTML editor HTML code for a table. Look for the black-
colored text items in the editor (assuming default HTML color coding
on) and you will see QuickSite’s caret linking technology in action.

Three Catalog Manager database fields are referred to in this text: 
^:thumbnail:^, ^^:prod_name:^^, and ^:price:^. When QuickSite 
builds the project, it substitutes the actual contents of database fields
these identifiers. (Note that prod_name is surrounded by double carets
so that QuickSite not only inserts the name for the product, but the l
to its page as well!) 

2. Close the HTML Editor.
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A closer look at the product template

For the product template example, the Layout Designer was used to pro
a customer template. The Layout Designer lets you take advantage of 
QuickSite’s caret linking technology, and you can also design your page
WYSIWYG environment.

1. In the Project View, double-click Product Template in the Configurati
Section to open the template in the Layout Designer for the templat

When QuickSite automatically generates product pages, it substitut
product information from the catalog for each of the database field 
identifiers that it finds in the page layout.

2. Close the Layout Designer.
QuickSite 3.0 Getting Started Guide 4-11
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Catalog components
The sample catalog project consists of a home page, some form pages
some catalog components. 

• Catalog components, identified in the Project View by the  icon, are
typically used to organize products into categories on your Web site

• The category template determines the page layout of the catalog 
component. 

• The product template determines the page layout and database field
for the product pages.

• Links to catalog components are automatically created from the hom
page, but you can also create your own links as project links. See 
Creating links in Layout, page 3-9.

When you create a project, you insert catalog components and specify s
criteria for the products they should contain. When QuickSite builds you
project, it automatically creates pages under each catalog component t
correspond to the catalog component’s criteria.

1. In the Project View, right-click the Sports Cars category.

2. Click Catalog Component Properties.
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The Sports Cars catalog component includes cars in the Sports Ca
category, uses the Default Category Template as its layout, and 
generates individual product pages based on the Product Template 

3. After building the project, you can double-click a catalog componen
icon to see the pages QuickSite has automatically generated for the
products in this component.

OrderEasy commerce support
QuickSite makes it easy to host a catalog with full commerce support u
OrderEasy, a new resource on the World Wide Web..

The OrderEasy library provides sample category and product page 
templates for the OrderEasy commerce catalog system. Additional con
specific to the InternetMall/OrderEasy support may be added to this libr
See Using libraries, page 4-1.

A sample project, OESAMPLE, installed with QuickSite demonstrates 
OrderEasy. OrderEasy is available at http://www.sitetech.com/oe/oedocs. A 
complete FAQ site that answers many questions concerning small busin
commerce is available at http://www.sitetech.com/oe/oefaqs. 

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

To learn about See this Help book/topic

Catalog creation Adding a catalog/Creating a catalog

Catalog data imports Adding a catalog/Importing a catalog

Catalog publication Adding a catalog/Uploading catalog da

Catalog maintenance Adding a catalog/Cleaning out image 
files

QuickSite Commerce Partners and 
OrderEasy commerce support

Adding a catalog/Setting up a commerce
site
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Promoting your site
Make the World Wide Web aware of your new catalog by letting QuickS
Users who have created new Web sites typically ask themselves, “ I’ve 
my Web site, now how is anyone going to find out about it?” Then they g
to their favorite search engine, fill out the forms, and register their site. I
only takes one registration to realize that getting information about their
new site published on several search engines could take hours. 

Luckily, QuickSite offers its Site Promotion Wizard, the way to 
autmatically register your site with 15 of the most popular indexes and 
search engines.

1. In the Project View, from the Wizards menu, click Site Promotion 
Wizard.

The Site Promotion Wizard opens.

2. Click on each tab and enter contact information, search keywords a
site description, and search engine categories.

QuickSite launches your primary browser and initiates a series of fo
that register you with the appropriate search engines and indexes.

3. Follow the instructions in your browser.

Note Your browser must support JavaScript for the Site Promotion Wizard
register your site.

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

To learn about See this Help book/topic

Site promotion Publishing and promoting a Web site/
Promoting a Web site
4-14 QuickSite 3.0 Getting Started Guide
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Adding scrolling content
QuickSite 3.0 automatically generates Smooth Scroll II applet code (fro
OpenCube) to produce scrolling content. 

To see this feature in action,

1. In the Project View, from the File menu, click Open Project and sele
OPENCUBE, a sample project provided with QuickSite.

2. Build and test the project. 

If the scrolling box is empty, you'll need to download a demo of the 
Smooth Scroll II applet from OpenCube's Web site at http://
www.opencube.com/web_effects.htm. 

Creating frames
Frames let you present multiple pages within a single browser window. 
QuickSite’s Frame Designer lets you create frames with ease—and with
the worry of missing a link to a framed document.

1. Create or open a project that has at least two text pages. Opening and 
closing a project, page 2-23.

2. Right-click the home page or menu page and click Frame Propertie
Frames can only be applied to the home or menu pages.

The Frame Designer opens.

3. Select a frame layout and specify the contents, widths, heights, and
margins for up to four frames.

4. For the contents of each frame you can type a URL, select an existi
page from the current project, or create a new page in the current 
project. 

5. Build and test your site to see the results. See Building and testing a 
project, page 3-21.
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Once frames have been applied to a menu or home page, the Fram
Designer becomes default editor for that page.

Tip To remove the frames, select Abandon Frame Definition in the Fram
Designer and click OK. You can then access the page contents from
HTML editor or Layout Designer.

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

See also FAQs (Frequently Asked Questions) about frames on the Site
Technologies Web site. From the Help menu, click Site Technologies 
Technical Support and Updates and click FAQs to access the FAQs me

Adding advertising
You can add rotating advertising banners to your Web pages. QuickSite
AdStream feature provides the ability to create up to five linked advertis
panels. Each panel is made from an ordinary text page in QuickSite and
be programmed to display for a specific number of seconds. 

AdStream panels are designed to be applied to a frame page. To see a
example of how AdStream works, open the sample project, AdStream, 
while you follow the how-to steps below.

1. In the Project View, click Open Project and click ADSTREAM.

Build and test the site to see what the advertising looks like. See 
Building and testing a project, page 3-21.

2. Double-click the home page. Notice that it was created in the Frame
Designer, signified by the  icon, and has three frame pages. Fram
is the main frame, linked to static Frame 3. Frame 2 displays the 

To learn about See this Help book/topic

Frame design Using the Frame Designer/Defining 
frames with the Frame Designer
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rotating advertising panels. See Adding scrolling content, page 4-15, for 
more on frame definition. The following steps explain how advertisin
was added to Frame 2. 

Click Cancel to close the home page and, in the Ad Panels section,
double-click the Ad Panel pages to examine them. The Ad Panel pa
are the advertising panels, displayed in rotation in Frame 2. They w
created in Layout Designer but also could have been created in the
HTML Editor. 

For demonstration purposes, the Ad Panel pages just contain the a
panel name and number of seconds they will display. You can, of 
course, add any advertising content you want to your ad panels.

3. Right-click the Frame 2 page and click AdStream properties. 

The AdStream box opens. This is where up to five advertising pane
are selected and number of seconds the advertisement will display 
defined. Notice that panel has an Adv tab.

4. Click the Adv  tabs and see the settings for each of advertising pan
When done, click Save.

Tip You can cancel the advertising by selecting Abandon AdStream 
Definition whenever you want. You can always turn it back on later b
deselecting the Abandon AdStream Definition option.

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

To learn about See this Help book/topic

Advertising and AdStream Adding advertising banners/Adding 
advertising
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Generating project reports
QuickSite Developer lets you run a variety of reports to help keep track
your Web site project. You can preview these reports through QuickSite
print them to an online printer or a file.

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

Automating your work
Web site developers who want to ease their Web site maintenance and
automation to their work have a full toolchest of features with QuickSite
Page macros, QuickSite macros, and automated scripting are at your 
fingertips.

Page macros
QuickSite supplies page macros which automatically return the correct 
information. You just type the macros anywhere appropriate in the page
During the build process, QuickSite interprets the macros. If you use pa
macros, such as for site title, a page title, or email address, and make 
changes in the site to those elements, the macros return the updated 
information without you having to manually change it every occurrence.

For example, ::SiteTitle page macro provides a way to dynamically insert th
Web site title (the name you gave your project) into the page content. W
you build the page it replaces the macro name with the current Web site
project title. If you change the title of your Web site, QuickSite updates 
occurrences of the Web site title automatically. 

To learn about See this Help book/topic

Advertising and AdStream Generating reports/Running project 
reports
4-18 QuickSite 3.0 Getting Started Guide
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QuickSite macros
QuickSite macro variables are now available to power users. The value
assigned to the variable is automatically transposed in a page whereve
macro is encountered by the QuickSite publishing engine. Macro variab
greatly easy the task of maintaining Web pages and duplicate content t
appears in multiple places in a site. A single change to the variable will 
update every occurrence in the entire site.

Macro variables are defined in the QuickSite INI (qs.ini) and Project INI 
(projectname .ini) files. See Setting/resetting preferences, page 2-21.

Automation scripts
QuickSite’s powerful automation script language allows you to add scrip
in your Web site project to tell QuickSite how to perform certain 
programmable actions in an automated sequence. 

• You can create and use automation scripts in your QuickSite projec
pages. 

• You can type in your own QuickSite automation scripts, or you can a
existing scripts from a library. Automation scripts are input as text-bas
pages in a special Configuration Section at the bottom of the QuickS
Project View. 

• You can edit an automation script, replace it, and change its locatio
the Project View just as you would any text page. 

Before you create automation scripts, you need to create a Configuratio
Section for the scripts in the Project View. 

For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

To learn about See this Help topic

Page macros Using the HTML Editor/Scripting and 
macros/Using page macros
QuickSite 3.0 Getting Started Guide 4-19



Application Program Interface (API) calls Working with Special Features

ith 
that 
 

s by 

ite. 
 

ge 
Application Program Interface (API) calls
QuickSite’s revolutionary XPE (eXtensible Publishing Engine) makes it 
possible to update Web site data from external sources at build time. W
the XPE, you can launch externally-created applications and functions 
retrieve data from existing sources during the normal course of building
your Web site.

The QuickSite XPE interface enhances Web page generation capabilitie
providing two external API gateways that can be utilized from inside 
virtually any Web page in a QuickSite project file. 

The API gateway commands are:

::WinExec( ) - This command provides the ability to call an external 
application that performs data acquisition or analysis outside of QuickS
::WinExec may be embedded in the text entry window of any QuickSite
Page Designer. 

::WinCall( ) - This command calls a single function in a dynamic link 
library (DLL) and inserts the return value of the function into the Web pa
text from where it was called. ::WinCall performs in a manner similar to 
::WinExec. 

QuickSite macro variables Using the HTML Editor/Scripting and 
macros/Defining macro variables

Automation scripts Using the HTML Editor/Scripting and 
macros/Using automation scripts

See also Appendix A: Automation 
Scripting.
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For more information...
Access QuickSite Help from the Help menu. Then click Contents and se
any of the following related topics.

Where to go from here
This concludes your guided tour of QuickSite. If you have worked throu
the walkthroughs in this and the previous chapters, you should have a g
idea what QuickSite offers. 

And there is even more! We encourage you to browse the QuickSite He
Contents to envision the entire scope of QuickSite. You will find in-depth
topics on all aspects of QuickSite in the Help.

You can access QuickSite Help from the Help menu. Also most QuickS
dialog boxes have a Help button and you can press the F1 to access co
sensitive Help.

Be sure to check the Site Technologies Web site at http://
www.sitetech.com for update information.

To learn about See this Help book/topic

API calls The Extensible Publishing Engine (XPE)
and API calls/Using QuickSite API 
gateway commands
QuickSite 3.0 Getting Started Guide 4-21
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Appendix A: Automation 
Scripting

QuickSite’s powerful automation script language allows you to add scrip
in your Web site project to tell QuickSite how to perform certain 
programmable actions in an automated sequence. 

Using automation scripts
You can create and use automation scripts in your QuickSite project pa
For a description of automation scripts, what they are and how to write 
them, see About autoscripting, page A-5.

Creating a Configuration Section for scripts
Before you create automation scripts, you should create a Configuratio
Section for the scripts in the Project View. 

1. In QuickSite, open a project or create a new QuickSite project.

2. From the Insert menu, click Configuration Section.

QuickSite adds a page, named Configuration Section, to the bottom
the Project View. The Configuration Section page is non-editable. It
sole purpose to demarcate a section for automation scripts, custom
headers and footers, and other support items placed there to reduc
clutter in the main Project View. For more on the role of custom head
and footers, see the QuickSite Help.
QuickSite 3.0 Getting Started Guide A-1
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QuickSite considers all items in the Configuration Section as 
Suspended, regardless of their page status setting (Active, Hidden, 
Pages in the Configuration Section are never built as HTML files an
only serve as support items in the project.

3. Create or add scripts to the Configuration Section (see Creating 
automation scripts below).

Creating automation scripts
You can create automation scripts using the appropriate QuickSite scrip
commands. For a complete list of the QuickSite automation script 
commands see Automation script commands, page A-5.

1. Create a Configuration Section for the scripts (see Creating a 
configuration section for scripts on page 2-1).

2. From the Insert menu, click Configuration Component.

A dropdown menu lists the script types. 

3. Click a script type. For example, click OnOpen Script.

QuickSite adds an empty page for the selected script to the 
Configuration Section and inserts a default title in the Project View.

4. Double-click the script page.

The Script Editor opens. 

5. Type in the script and use the tools as needed to create the script. 

6. When done, click the Save page changes tool, , then the Close t
. 
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Adding existing scripts
You can add existing automation scripts that you previously saved in a 
library.

1. Create a Configuration Section for the scripts (see Creating a 
Configuration Section for scripts, page A-1.

2. From the Insert menu, click Configuration Component.

A menu lists the script types.

3. Click a script type.

QuickSite adds an empty page for the selected script to the 
Configuration Section.

4. Double-click the script page.

QuickSite opens the Script Editor. 

5. Click the Library and project links tool, , then click Library 
Templates. 

6. In the library templates box, double-click the desired template.

QuickSite inserts the template in the Script Editor.

7. When done, click the Save tool, , then the Close tool, . 

Editing automation scripts
You can edit an automation script, replace it, and change its location in 
Project View just as you would any text page. See QuickSite Help for 
details.

Tip For best results, keep automation scripts in the Configuration Section. T
ensures the scripts will not be displayed on your Web site when it is 
published.
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Running automation scripts
You can run your automation scripts from the QuickSite menu.

1. In the Project View, click the right mouse button and in the popup 
menu, click Run Automation Script. Or from the Project menu, click
Run Automation Script.

QuickSite displays a list of the existing scripts in your project.

2. Double-click the script you want to run.

QuickSite runs the script.
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About autoscripting
You can type in your own QuickSite automation scripts, or you can add
existing scripts from a library. Automation scripts are input as text-base
pages in a special Configuration Section at the bottom of the QuickSite
Project View. 

Automation script commands
The table below lists the automation script commands currently availab
for use in scripting. The following symbols are used to describe the 
commands:

[ ] Optional argument.

| Literal constant choice, for example On|Off.

< > Variable.

c,n,d Format: c=character, n=numeric, d= date (mmddyy).

Script command Function

Build project Builds the current project.

Compress project Runs the Project | Compress Project File menu opti

Copy to <cTarget> Copies the current project to the specified target pa
and filename. Do not include file extensions or copy 
c:\filename.

Edit|Design Launches the appropriate page/component Designe
on the current record. Use either Edit or Design to 
perform the same action.

Note: The launch operation suspends the automatio
script when the Designer opens. 

Collapse [Site|Section] Collapses all menu pages in the specified scope (site
menu section). See the Set Scope To command.

Delete page Deletes page targeted by the Seek command (see 
below). 
QuickSite 3.0 Getting Started Guide A-5



About autoscripting Appendix A: Automation Scripting

 or 

o 

d. 

if 

r 

for 

s 
Expand [Site|Section] Expands all menu pages in the specified scope (Site
Menu section). See the Set Scope To command.

Go top Moves the position of the cursor in the Project View t
the home page.

Import project <cProject> Imports the specified project at the current cursor 
location.

Insert menu Inserts menu targeted by the Seek command (see 
below).

Publish project Builds and publishes the current project to the pre-
configured Web site location.

Quit Exits from QuickSite.

Run <command> Runs a command.

Seek <cPageTitle> Targets a page or component in the project by title. 

Set <apiField> to <value> Sets the value of any of twelve API fields in the 
QuickSite project file database to the value specifie
The API fields include:

API_C1 API_D1 API_L1 API_N1 API_C2 API_D2 
API_L2 API_N2 API_C3 API_D3 API_L3 API_N3

SeeAPI fields reserved for developers, page A-11. 

Set background to 
[<cGifFile>|

<cJpgFile>]

Sets background choice to the specified file scope (G
or Jpg).

Set copyright to <cName>. Sets the copyright preference item to a new value fo
the current project.

Set copyright [On|Off] Enables or disables the project build option for 
inclusion of the preferences copyright.

Set email to <cName> Sets the e-mail address preference to a new value 
the current project.

Set filename to 
<cFileName>

Sets the output name of the current page and block
any attempt by QuickSite to use the internally 
generated name.
A-6 QuickSite 3.0 Getting Started Guide



Appendix A: Automation Scripting About autoscripting

.

 

 

 
f 

 for 

. 
Set HomeContents [On|Off] Enables or disables the project build option for the 
placement of the contents button on the home page

Set HTML extension 
[On|Off]

Sets the preference item that enables internally 
generated calls to the full HTML file extension.

Set logo [On|Off] Enables or disables the project build option for 
inclusion of the QuickSite logo.

Set MenuContents [On|Off] Enables or disables the project build option for the 
placement of contents buttons on menu pages.

Set NavButtons [On|Off] Enables or disables the project build option for 
inclusion of navigational buttons.

Set scope to [Site| 
Section|Page]

Sets the current scope of the project. By default, the
scope is based on the current Page. A section is 
defined as all pages and components within a 
contained menu section. 

Set status to 
[Active|Hidden|

Construction|

Suspended]

Changes the status of all pages in the current page
status scope.

Set step [On|Off] Processes each command and displays debugging
information. This is normally placed in the first line o
the script.

Set TextContents [On|Off] Enables or disables the project build option for the 
placement of contents buttons on the text pages.

Set Webauthor to <cName>Sets the web author preference item to a new value
the current project.

Set WebAuthor 
[On|Off]

Enables or disables the project build option for the 
Web site author.

Skip [<nValue>] Moves the position of the cursor in the project view 
relative to the current position.

Wait [<nSeconds>] Suspends the script process with a dialog message
This is a modal dialog and will suspend any further 
script operation in QuickSite unless a wait time 
<nSeconds> is specified.
QuickSite 3.0 Getting Started Guide A-7
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Automation script conventions
QuickSite’s automation script is an intuitive language with only a few 
conventions you should know about:

• QuickSite automation scripting supports plain language text commands. 
Therefore, delimiting characters, [ ] and < >, may be omitted from the 
script command syntax 

• QuickSite automation scripting is case-insensitive.

• Comments may be placed on the same line after script commands. U
two forward slashes, //, to mark the beginning of a comment.

Launch directives
You may place QuickSite launch directives in the Windows interface as 
Shortcuts or Run commands.

The first argument of a launch directive is always the project file with a f
path.

The optional second argument may be a reference to a page title in the
project or a filename containing script commands. The argument name m
not contain a space, as QuickSite creates an additional argument after 
space. For example enter ^MyScript^ instead of ̂My Script^.

A launch directive example

where

qs  tells Windows to open QuickSite.

argument1 tells QuickSite to open project file mypro.dbf.

When [DATE <ddate>] Date-based script, where DATE <=, >=, <, >, or ==. 
Defines the date that script is set to execute, in mm/
yy format. 

argument 1 argument 2

qs c:\qs\myproj\mypro.dbf ^MyScript^
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argument 2 tells QuickSite to launch the MyScript script.

Some automation script examples
The QuickSite automation script example below is designed to be run in
timed environment and is triggered by the holiday Halloween (see Event-
driven scripts, page A-9 and Time-driven scripts, page A-11. 

seek My Halloween Section // locate page 

set status to Active // change page status

build project // build current project

quit // exit QuickSite

The following QuickSite automation script example automates building a
publishing a Web site project. The script trigger may be an event-based
script, clicking the Run Automation Script option (see Running automation 
scripts, page A-4), or a command line argument at the beginning of the 
script.

build project // build the project

publish project // publish the project

edit // launch page designer

set status to Active // change page status

set copyright to 1996 MyCompany // set copyright preference

set copyright [on] // enable copyright

quit // quit QuickSite

Event-driven scripts
QuickSite automation scripting makes it possible for you to easily creat
event-driven scripts. When QuickSite starts, it looks for any event-driven
scripts before allowing you to view the project. If an event-based script 
not present, the user must activate the script manually.

When you input an event-driven script, you should place the script page
the Configuration Section. For more, see Creating automation scripts, page 
A-2. 
QuickSite 3.0 Getting Started Guide A-9
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The following event-driven scripts are available through QuickSite 
automation scripting:

OnOpen script

Each time the user opens a project, QuickSite runs the OnOpen script. 
example, the OnOpen script might have just this command, which woul
cause the project to be built each time the project is opened:

build project

The quit  command does not work in OnOpen scripts.

OnClose script

Each time the user clicks to close the project, QuickSite automatically 
executes all commands in the On Close script. For example, the OnClo
script might have this command:

copy to c:\backup\project_file

OnBuild script

Each time the user clicks to build the project, QuickSite automatically 
executes all commands in the OnBuild script and builds the site. For 
example, the OnBuild script might have these commands:

set logo off

set navbuttons on

OnTest script

Each time the user clicks to test the project, QuickSite automatically 
executes all commands in the OnTest script and then tests the site loca
For example, the script might enable certain pages for testing but not fo
build, or vice versa.

seek menu page 1

set status to Suspended

seek menu page 2

set status to Active
A-10 QuickSite 3.0 Getting Started Guide
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OnPublish script
Each time the user clicks to publish the project, QuickSite automatically
executes all commands in the OnPublish script and publishes the site. 
example, the script might bring in fresh copies of GIF files into the proje
directory with a .bat file, such as in this example:

run siteupdt.bat

Time-driven scripts
QuickSite has one script command that you can use to input a date as 
trigger for an event. The command syntax is 

when DATE <cDate>

For example, the time-driven command

when DATE <= 12/31/96

will prompt you to continue.

API fields reserved for developers
A QuickSite project consists of a hierarchy of item records. Each item (p
or component) is ordered in the sequence that it will appear in a Web s
Developers can view the project record structure in QuickSite’s Project 
View. 

Each field in a QuickSite item record contains the following information:

FieldName - Field name.

Type - One of these field types:

C = character.

D = date.

M = memo (text contents of this field type are stored in the .dbt project 
file.

N = numeric.

L = logical (True/False, 1/0).
QuickSite 3.0 Getting Started Guide A-11



About autoscripting Appendix A: Automation Scripting

e 
e, 

es of 
ill 

e a 
ngs. 

s in 
Wid  - Field width, in characters.

#Dec - Number of decimal places.

Description - Field description.

All QuickSite project file records have the same field structure, however th
field content differs according to QuickSite project item type – pages (hom
menu, text form) and components (paragraph, table, file, URL). 

At present a QuickSite project file database contains 64 fields. Later releas
QuickSite may contain more fields, but the QuickSite database structure w
always remain backward compatible.

Fields 47-58 of the project file are reserved for developers. They includ
variety of field types and sizes that may be employed in application setti

The developer fields listed below do not appear in the other record table
this chapter, although they are a part of every record.

Field# Field Name Type  Wid Dec

47 API_C1 C 012 000

48 API_C2 C 012 000

49 API_C3 C 032 000

50 API_N1 N 012 002

51 API_N2 N 012 002

52 API_N3 N 012 002

53 API_L1 L 001 000

54 API_L2 L 001 000

55 API_L3 L 001 000

56 API_D1 D 008 000

57 API_D2 D 008 000

58 API_D3 D 008 000
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End User Program License Agreement
PLEASE READ THIS LICENSE AGREEMENT CAREFULLY AND BE 
SURE YOU ACCEPT ITS TERMS BEFORE YOU OPEN THE SEALED 
DISKETTE PACKAGE. IF YOU OPEN THIS DISKETTE PACKAGE THIS 
WILL SIGNIFY THAT YOU CONSENT TO BE BOUND BY THE TERMS 
AND CONDITIONS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO
THESE TERMS, THEN SITE TECHNOLOGIES IS UNWILLING TO 
LICENSE THE SOFTWARE TO YOU, IN WHICH EVENT YOU SHOULD 
RETURN THE FULL PRODUCT WITH PROOF OF PURCHASE TO THE 
DEALER FROM WHICH YOU ACQUIRED IT WITHIN NINETY DAYS 
OF PURCHASE, AND YOUR MONEY WILL BE REFUNDED. 

The software which accompanies this license (“the Software”) is the prope
of SITE TECHNOLOGIES or its licensors and is protected by copyright law
While SITE TECHNOLOGIES continues to own the Software, you will hav
certain rights to use the Software after your acceptance of this license. Yo
rights and obligations with respect to the use of this Software are as follow

• You may: 
(i) use one copy of the Software on a single computer; 

(ii) make one copy of the Software for archival purposes, or copy the Software
onto the hard disk of your computer and retain the original for archival purposes; 

(iii) use the Software on a network, provided that you have a licensed copy of the 
Software for each computer that can access the Software over that network; 

(iv) after written notice to SITE TECHNOLOGIES, transfer the Software on a 
permanent basis to another person or entity, provided that you transfer all copies of 
Software and documentation and retain no copies of the Software, and the transfere
agrees to the terms of this agreement; 

(v) if a single person uses the computer on which the Software is installed at least 
of the time, then after returning the completed product registration card which 
accompanies the Software, that person may also use the Software on a single home
computer. 

• You may not: 
(i) copy the documentation which accompanies the Software; 

(ii) sublicense, rent or lease any portion of the Software; 

(iii) reverse engineer, decompile, disassemble, modify, translate, make any attemp
discover the source code or resources of the Software; or 

(iv) use a previous version of the Software after you have received an upgraded ve
as a replacement of the prior version. Upon upgrading the Software, all copies of the
version must be destroyed.

(CONTINUED)
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Limited Warranty
SITE TECHNOLOGIES WARRANTS that if you discover physical defects in
the media on which this software is distributed, or in the manual distributed w
the software, SITE TECHNOLOGIES will replace the media or manual at no
charge to you, provided you return the item to be replaced, postage prepaid,
proof of purchase during the ninety day period after you purchased the prod

Except as specifically stated above, SITE TECHNOLOGIES makes no other
warranties, expressed or implied, with respect to the software, media, or ma
including (but not limited to) implied warranties of merchantability and fitness
for a particular purpose. SITE TECHNOLOGIES reserves the right to revise 
software and manual without obligation to notify any person of such revision
no event will SITE TECHNOLOGIES be liable for loss of profits or goodwill o
other indirect, special, incidental, or consequential damages resulting from a
defect in the software, media or manual. SITE TECHNOLOGIES’ liability for
damages to you or to others will in no event exceed the total amount paid by
for the product. In particular, SITE TECHNOLOGIES shall have no liability fo
any data stored in or used with SITE TECHNOLOGIES’ products, including t
costs of recovering such data. 

The warranty and remedies set forth above are exclusive and in lieu of all oth
oral or written, expressed or implied. No SITE TECHNOLOGIES dealer, age
or employee is authorized to make any modification, extension, or addition to
warranty. Some states do not allow limitations on how long an implied warra
lasts or the exclusion or limitation of implied warranties or liability for incident
or consequential damages, so the above limitation or exclusion may not app
you. This warranty gives you specific legal rights and you may also have oth
rights which vary from state to state. 

U.S. Government Restricted Rights
RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by the 
Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) 
the Rights in Technical Data and Computer Software clause at DFARS 252.
7013 or subparagraphs (c) (1) and (2) of the Commercial Computer-Restrict
Rights clause at 48 CFR 52.227-19, as applicable. 

General
This agreement will be governed by the laws of the State of California. This 
agreement may only be modified by a written document which is signed by y
and SITE TECHNOLOGIES. Should you have questions concerning this 
agreement, or if you desire to contact SITE TECHNOLOGIES for any reaso
please write: SITE TECHNOLOGIES Customer Services, 380 El Pueblo Ro
Scotts Valley, CA 95066. 
QuickSite 3.0 Getting Started Guide
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