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Internet Valet

Internet Valet serves all your Internet needs on the Macintosh by
bringing together a variety of easy to use Internet tools and
placing them conveniently on a single palette. Once you have
obtained Internet service, Internet Valet Setup will configure the
programs on the palette for you.

With Internet Valet, you are only a few mouse-clicks away from
the Internet using these well-known Macintosh programs: PPP,
Eudora, Enhanced Mosaic, NewsWatcher, Fetch, TurboGopher,
and MicroPhone Telnet.

Starting Internet Valet
1 Double-click the Internet Valet icon.

The Internet Valet icon is located in the Internet Valet Folder.

Internet Valet will start and you will see your palette of Internet
programs. These programs are often referred to as “clients.”
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Using Internet Valet
To use one of the programs in Internet Valet, just double-click its
icon on the palette.

Note: These programs will not work properly until you have
connected to the Internet. Internet Valet comes with PPP to establish
an Internet connection using a modem.

Internet Valet will also work with any TCP/IP connection via
network or SLIP. If you have this type of Internet connection, you
should connect as you normally would without using the PPP
portion of Internet Valet.
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PPP

PPP is the way your Macintosh connects directly to the Internet
with your modem. Before you can use other programs on the
palette, you must connect to the Internet.

PPP was created at the University of Michigan and is licensed
from Merit Network, Inc.

Starting PPP
1 Double-click the PPP icon.

PPP will start and its window will appear.
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Connecting to the Internet
1 Click the Connect button.

PPP will attempt to connect to your Internet service.

2 If the PPP connection has been established successfully, you

can close the PPP window by clicking the close box in the

upper left corner of the window.

Once PPP is up, you can access the various features of the Internet
with the other clients on the palette.

Note: If your modem does not dial, then there may be a problem
between your Macintosh and the modem. If the modem dials, but
PPP status remains down, there may be a problem with your Internet
configuration or your Internet service provider.
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Disconnecting from the Internet
1 Double-click the PPP icon on the palette.

2 Click the Disconnect button.

PPP will disconnect from your Internet service and hang up your
modem.

PPP Settings
Clicking the Settings button will display PPP’s settings. Internet
Valet Setup configures PPP for you automatically, so you should not
change the settings unless you know that it is necessary.

Note: For advanced users, the original Config PPP control panel is
located in the Internet Valet Extras folder in the Internet Valet
Folder.

Network and SLIP Connections
Internet Valet will also work with any TCP/IP connection via
network or SLIP. If you have this type of Internet connection, you
should connect as you normally would without using the PPP
portion of Internet Valet.

Once you are connected, you can use any of the other programs on
the Internet Valet palette.

PPP 11



 



Eudora

Eudora offers a simple interface for sending and receiving
electronic mail messages (email). It is one of the most popular
programs for Internet email on the Macintosh.

This freeware version of Qualcomm’s Eudora has been licensed
by Software Ventures Corporation.

Starting Eudora
1 Double-click the Eudora icon.

Eudora will start and display whatever windows were open when it
was last quit.
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Creating a New Message
1 Select New Message from the Message menu.

A window will appear in which you can compose a new message.

Note: For information about the buttons above the address header,
use Balloon Help by selecting Show Balloons from the Help menu.

2 In the To field, type the email address of the recipient.

To address the message to more than one recipient, use a comma to
separate email addresses.

Note: You can also address the message to other recipients in the
Cc (carbon copy) and Bcc (blind carbon copy) fields.

3 In the Subject field, type the subject of your message.

Note: Eudora fills in the From field for you. To change your email
address, select Settings from the Special menu, click the Personal
Information icon, and fill in the “Return address” field.
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4 In the message area, compose your message.

You can type and edit the body of your message normally with your
keyboard and mouse.

5 To send your message, click the Send button.

A window will display the status of the message. If you wish to
cancel sending, click Stop.

Note: You can also save the message without sending it by selecting
Save from the File menu. This will save the message to your Out
mailbox, where you can resume working on it later.

Attaching a File to a Message
When composing a new message, you can attach a file to it.
However, it is up to the recipient to extract the file from your
message.

1 Select Attach Document from the Message menu.

The message to which you are attaching the file must be the
frontmost window.

2 In the file dialog, locate the file you wish to attach and click

Open.

The path and filename of the attachment will appear in the message
header in the Attachments field.

Note: You can attach more than one file to a message by repeating
these steps.
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Checking for New Messages
Before you can read incoming email messages on your Macintosh,
Eudora must get them from your Internet service provider’s POP
mail server.

1 Select Check Mail from the File menu.

If you have not yet checked for new messages this session, Eudora
will prompt you for your password.

2 When prompted for your password, enter the password for

your email account and click OK.

If you have a shell account, the password for your email account is
usually the same.

Note: If you would like Eudora to always remember your
password, select Settings from the Special menu, click the Checking
Mail icon, and check the “Save password” checkbox.
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3 Eudora will tell you whether or not you have any new

messages. Click OK.

If there is new mail, Eudora will open your In mailbox for you.

Note: Once Eudora has successfully retrieved your messages, it will
delete them from the POP server to save space. If you do not want
Eudora to do this, select Settings from the Special menu, click the
Checking Mail icon, and check the “Leave mail on server” checkbox.
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Auto-Checking for New Messages
Eudora can automatically check for new messages, even when it is
running in the background. To do this, you must set how often you
would like Eudora to check for new messages.

1 Select Settings from the Special menu.

2 Click the Checking Mail icon.

3 Specify how often (in minutes) you wish Eudora to check

for new messages and click OK.
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Reading a Message
To read an email message in any mailbox, just double-click the
message. All incoming messages are stored in the In mailbox.

Attachments to incoming messages are processed automatically and
stored in the Attachments Folder in the Eudora Folder in your
System Folder.

Printing a Message
1 In a mailbox, select the message(s) that you wish to print.

To select more than one message, hold down the command key
when clicking the mouse.

Note: If you are already reading the message you wish to print, just
select Print from the File menu.

2 Select Print from the File menu.

Note: You can also save an email message as a text file on your
Macintosh by selecting Save from the File menu.
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Deleting a Message
You can delete messages that you do not wish to keep. This will
save space on your hard disk as well as keep your mailboxes from
becoming cluttered.

1 In a mailbox, select the message(s) that you wish to delete.

To select more than one message, hold down the command key
when clicking the mouse.

Note: If you are already reading the message you wish to delete,
just select Delete from the Message menu.

2 Select Delete from the Message menu.

This will move the message(s) to the Trash mailbox. To recover a
message from the Trash mailbox, you can transfer it back to another
mailbox. For more information, see the section Using Mailboxes.

3 To permanently erase all the messages in your Trash

mailbox, select Empty Trash from the Special menu.

Note: Be sure that you are selecting Empty Trash from Eudora’s
Special menu. Selecting Empty Trash from the Finder’s Special menu
will not empty your Trash mailbox.
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Replying to a Message
You can respond to a message you have received by replying to it.
Replying can be more useful and more convenient than creating a
new message for your response.

1 If you are reading the message to which you wish to

respond, select Reply from the Message menu.

You may also select Reply from the Message menu when you select
a message in a mailbox.

Note: You cannot reply to a message in your Out mailbox.

2 Compose your reply.

The body of the message to which you are replying is automatically
included. These lines are prefaced with a > symbol and can be
modified just like normal text. You should compose your reply
above these lines or insert your comments between them.

3 Click the Send button to send your reply.

Note: You can also save the message without sending it by selecting
Save from the File menu. This will save the message to your Out
mailbox, where you can resume working on it later.
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Forwarding/Redirecting a Message
You can pass on a message you have received to other people by
forwarding or redirecting it. Forwarding is useful when you want
someone else to have a copy of a message you received. Redirecting
is useful when you receive a message that you feel is intended for
someone else.

1 If you are reading the message you wish to pass on, select

Forward or Redirect from the Message menu.

You may also select Forward or Redirect from the Message menu
when you select a message in a mailbox.

2 In the To field, type the email address of the recipient.

To address the message to more than one recipient, use a comma to
separate email addresses. You can also address the message to
other recipients in the Cc (carbon copy) and Bcc (blind carbon
copy) fields.

Note: When redirecting, the From field displays the original
sender’s address by way of your address. A reply by a recipient of
your redirected message will only go to the original sender.

3 Edit the message.

The body of the message being forwarded or redirected is
automatically included and can be edited just like normal text. The
lines of a forwarded message are prefaced with a > symbol. The
lines of a redirected message are not prefaced with a > symbol.

4 When you are finished, click the Send button.

Note: You can also save the message without sending it by selecting
Save from the File menu. This will save the message to your Out
mailbox, where you can resume working on it later.

22 Easy Reference



Using Mailboxes
Eudora organizes and stores your email messages in mailboxes. To
move a message from one mailbox to another, select the message
you wish to move and, from the Transfer menu, select the mailbox to
which you wish to move it. Transferring a message to New will
allow you to create a new mailbox.

In mailbox

The In mailbox is where all incoming messages are stored. To open
your In mailbox, select In from the Mailbox menu. Unread messages
are marked with a bullet in the leftmost column.

Out mailbox

The Out mailbox is where messages you have created are stored
when you save them. These could be messages you plan to resume
or they could be messages that are queued to be sent at a later time.
To open your Out mailbox, select Out from the Mailbox menu.
Sendable messages are marked with a bullet in the leftmost column.
Sent messages are marked with an “S” in the leftmost column.

Trash mailbox

Deleted messages are moved to the Trash mailbox. If you change
your mind about deleting a message, you can transfer it back to
another mailbox. To open the Trash mailbox, select Trash from the
Mailbox menu. To permanently erase the messages in your Trash
mailbox, select Empty Trash from the Special menu.

Other mailboxes

You can create your own mailboxes to sort and archive your
messages. To create and organize your mailboxes, see the sections
Creating Mailboxes and Managing Mailboxes.
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Creating Mailboxes
There are two ways to create a new mailbox. The easier way is
described here. The other way is described in the section Managing
Mailboxes.

1 When you wish to save a message to a new mailbox, select

New from the Transfer menu.

You will be prompted to name the mailbox.

2 Type in the name for the new mailbox.

You can create a mailbox without moving the message by checking
the “Don’t transfer, just create mailbox” checkbox.

Note: You can also create folders to further sort your mailboxes. To
create a folder instead of a mailbox, check the “Make it a folder”
checkbox.

3 Click OK.

The new mailbox will be created and will be available in the
Mailbox and Transfer menus.
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Managing Mailboxes
The Mailboxes window lets you create and organize mailboxes.

1 Select Mailboxes from the Window menu.

The Mailboxes window will appear, allowing you to organize your
mailboxes. The two sub-windows allow you to move mailboxes
between folders by selecting an item and clicking the
corresponding Move button.

2 To create a new mailbox, click the appropriate New button.

Click the New button on the side which shows the location in which
you wish to make the new mailbox. To create a new folder, click the
New button and check the “Make it a folder” checkbox.

3 To rename or remove a mailbox, select it and click the

Rename or Remove button.

4 When you are finished in the Mailboxes window, click the

close box in the upper left corner of the window.
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Using Nicknames
Eudora can keep a list of nicknames which correspond to email
addresses that you commonly use. You can also create a group by
assigning multiple email addresses to a nickname.

1 Select Nicknames from the Window menu.

The Nicknames window will appear.

Type the email addresses for a nickname in the Address(es) field.
Type any notes you wish in the Notes field.

2 To add a nickname, click New.

In the New Nickname window, type a name for the nickname and
click OK. The new nickname will appear in the Nickname field.

Note: You can also add a nickname to the recipient list by checking
the “Put it on the recipient list” checkbox in the New Nickname
window. For more information about using the recipient list, see the
section Using Recipients.
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3 To rename or remove a nickname, select the nickname and

click the Rename or Remove button.

4 To send a message to a nickname, select the nickname and

click the To button.

This will create a new message addressed to the address(es) for the
nickname. You can also click the Cc and Bcc buttons to address the
message with the nickname as a carbon copy or blind carbon copy.

5 When you are finished in the Nicknames window, click the

close box in the upper left corner of the window.

Using Recipients
In the Message menu, the submenus New Message To, Reply To,
Forward To, and Redirect To will start a new message to the
recipient specified.

To add a recipient to the available list, highlight any email address
in any text area and select Add as Recipient from the Special menu.
Be sure that you highlight only the email address and that the
address is complete.

You can also add a nickname to the recipient list by checking the
“Put it on the recipient list” checkbox when creating a new
nickname. For information about creating nicknames, see the section
Using Nicknames.

To remove a recipient from the list, select the recipient to be deleted
from the Remove Recipient submenu in the Special menu.
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Eudora Settings
Select Settings from the Special menu to display the Settings
window. Select a category by clicking an icon from the list on the
left side of the Settings window (use the scroll bar to see additional
icons). Categories are: Getting Started, Personal Information, Hosts,
Checking Mail, Sending Mail, Attachments, Fonts & Display, Getting
Attention, Replying, and Miscellaneous. For a description of
Eudora’s settings options, please consult the online documentation.

Online Documentation
Balloon Help is available for Eudora by selecting Show Balloons
from the Help menu. The Help menu is the question mark on the
right side of the menu bar. You can also find additional assistance
by selecting More Help in the Help menu.
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Enhanced Mosaic

Enhanced Mosaic is a graphical Web browser that enables you to
visit sites on the World Wide Web (WWW).

The original Mosaic was the first Internet Web browser. This
enhanced version of Mosaic is made by Spyglass, Inc.

Starting Enhanced Mosaic
1 Double-click the E-Mosaic icon.

Enhanced Mosaic will start and allow you to open a connection to
the Software Ventures Internet Valet home page.

Note: If E-Mosaic fails to connect, there may be a problem with
your Internet connection or the Software Ventures Web server may
be temporarily busy or unavailable.
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Navigating Web Pages
Hyperlinks

Hyperlinks are clickable text or image items on a Web page.
Clicking on a hyperlink will take you to another Web page. Text
hyperlinks are highlighted and sometimes underlined, and image
hyperlinks are surrounded by a colored border. E-Mosaic displays
hyperlinks as blue and visited links as green.

Note: On black and white monitors, only the underlines are
distinguishable.

E-Mosaic Buttons

The buttons above the Web page are shortcuts for commands in
Enhanced Mosaic’s menus. You can point to a button with your
mouse, and E-Mosaic will display its corresponding command.

Arrows

Click these buttons to move between the pages you have visited in a
session. The left arrow button returns to the page opened prior to
the current page. The right arrow button takes you to the page
opened after the current page.

Home Page

Click the house button to return to your home page. To change your
default home page, see the section Changing Your Home Page.
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Open URL

Click this button to open a Web page by specifying its URL. This is
described in the section Connecting with a URL.

Open File

Click this button to open a Web page stored on your Mac.

Reload Document

Click this button to reload the current page.

Load Images

Click this button to load any unloaded images.

Find and Find Again

Click these buttons to search for text within the current page. The
Find Again button repeats the previous find.

Print and Save

Click these buttons to print or save the current page.

Hotlist

Click the Hotlist button to display the Hotlist window. Click the
Hotlist Plus button to add the current page to the hotlist.

Help

Click this button to open the E-Mosaic help page.

Stop

Click this button to stop whatever E-Mosaic is doing.
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Connecting with a URL
Web pages and other items on the Internet have a unique URL
(Uniform Resource Locator). If you know the URL of a Web page
which you would like to visit, E-Mosaic can connect directly to it.

1 Select Open URL from the File menu or click the Open URL

button.

You will be prompted to type in a URL.

2 Type in the URL of the Web page.

A Web page URL should look like
http://servername/path/filename

3 Click Open.

E-Mosaic will attempt to connect to the URL you have specified.
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Using the Hotlist
Enhanced Mosaic can keep a hotlist of your favorite Web pages.

1 To add a Web page to a hotlist, select Add Current To Hotlist

from the Navigate menu or click the Hotlist Plus button.

This adds the current Web page to your hotlist.

2 To view your hotlist, select Hotlist from the Navigate menu

or click the Hotlist button.

The Hotlist window will appear.

3 To connect to a hotlist item, just double-click it.

You can also select a hotlist item and click the Go To button.

4 To edit a hotlist item, select it and click Edit.

You can change the Title and URL of the hotlist item.

Note: You can also delete items by clicking the Delete button.

5 To close the Hotlist window, click Close.
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Turning Off Graphics
By default, Enhanced Mosaic automatically loads all graphics for
each Web page before displaying any of them. If you do not want to
see any graphics, you can save time by having E-Mosaic not load
them automatically.

1 Select Preferences from the Edit menu.

The Preferences window will appear.

2 Uncheck the Load Images Automatically checkbox.

To turn graphics back on, check the “Load Images Automatically”
checkbox.

Note: You can always load images manually. To load all images on
a page, click the Load Image button. To load an individual image,
double-click its place-holder.
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Changing Your Home Page
The Web page that E-Mosaic opens at startup is your home page.
You can change the home page to be your favorite starting point.

1 Select Preferences from the Edit menu.

The Preferences window will appear.

2 In the Home Page field, type the URL of the Web page you

wish to use as your home page and click OK.

E-Mosaic will now use the specified URL as your home page.

Note: If you leave the Home Page field blank, E-Mosaic will open
the file initial.html located in the E-Mosaic Folder.
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Online Documentation
Balloon Help is available for Enhanced Mosaic by selecting Show
Balloons from the Help menu. The Help menu is the question mark
in the upper right of the menu bar.

A help page is also available by selecting Enhanced Mosaic Help
from the Help menu or by clicking the Question Mark button.
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NewsWatcher

NewsWatcher provides an interface for you to read and post
articles on Usenet newsgroups. There are thousands of different
newsgroups on the Internet that discuss a diverse range of
topics.

NewsWatcher was created at Northwestern University and is the
most popular news reader for the Macintosh.

Starting NewsWatcher

1 Double-click the NewsWatcher icon.

NewsWatcher will start and automatically open a connection to your
news server. The Full Group List and the Subscribed Newsgroups
window will appear. If there are any new newsgroups since the last
time you used NewsWatcher, they will be displayed in the New
Groups window.

Note: If NewsWatcher fails to connect, there may be a problem with
your Internet connection or your news server may be temporarily
unavailable.
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Subscribing to Newsgroups
You must subscribe to a newsgroup in order to keep track of which
articles are new.

1 In the Full Group List, select the newsgroup(s) to which you

wish to subscribe.

To select more than one newsgroup, hold down the command key
when clicking the mouse.

2 Select Subscribe from the Special menu.

This will add the newsgroup(s) to the Subscribed Newsgroups list.
To remove a newsgroup, select it in the Subscribed Newsgroups
window and select Unsubscribe from the Special menu.

Note: You can make more newsgroup lists in addition to the
Subscribed Newsgroups list. However, you cannot select Subscribe
from the Special menu when more than one newsgroup list is open.

3 Select Save from the File menu.

You must save the Subscribed Newsgroups list before quitting
NewsWatcher.

Note: To open other newsgroup lists which you have created, select
Open from the File menu in NewsWatcher. You can also double-
click any newsgroup list icon in the Finder to start NewsWatcher
with that newsgroup list.
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Finding a Newsgroup
You can try to find a news topic by searching for keywords in the
names of newsgroups.

1 When the Full Group List is the frontmost window, select

Find from the Edit menu.

The Find window will appear.

2 Type the keyword(s) you wish to search for and click Find.

Make sure that the checkbox “Start at beginning” is checked in
order to search the entire window.

Note: Find will search for text in the frontmost window. You can
use Find to search for text in a newsgroup window or in an article.
If you are searching for keywords in an article’s header, such as the
subject, you should use the Search command described in the
section Searching News Articles.
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Opening a Newsgroup
To read the articles in a newsgroup, you must first open the
newsgroup.

1 From the Subscribed Newsgroups window, double-click the

newsgroup you wish to read.

A window will appear with the name of the newsgroup as its title.

Note: If you open a newsgroup from the Full Group List, all of the
articles in that newsgroup will be displayed, and you will not be
able to mark the articles you have read.
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Reading a News Article
1 In a Newsgroup window, double-click the article you wish

to read.

A window will appear with the subject of the article as its title.

Note: In the newsgroup window, some articles have turndown
triangles followed by a number which indicates the number of
replies posted to that article. Click the triangle to display the replies.

2 To reply to an article, select Reply from the News menu.

To compose and send your reply, see the section Posting News.

Note: You can also forward or redirect the article as a message by
selecting Forward or Redirect from the News menu.

3 If you do not want to read an article select Mark Read from

the News menu.

NewsWatcher retrieves and displays only those messages that you
have not read. Marking an article as read will keep NewsWatcher
from retrieving it again, even though you haven’t really read it. This
is useful for filtering old messages that you do not want to read
from new messages.
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Printing a News Article
1 In a newsgroup window, select the article(s) that you wish

to print.

To select more than one article, hold down the command key when
clicking the mouse.

Note: If you are already reading the article you wish to print, just
select Print from the File menu.

2 Select Print from the File menu.

The article(s) will be printed by the printer selected in your Chooser
(in the Apple menu).

Note: You can also save an article as a text file on your Macintosh
by selecting Save from the File menu.
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Posting a Message
1 Select New Message from the News menu.

A window will appear in which you can create a new message.

Note: This is the same window you will see when you select Reply,
Forward, or Redirect from the News menu.

2 Select one or more destinations for your message by

clicking the News, Mail, or Self icons.

The News icon will post the message as a news article; the Mail icon
will send the message via email; and the Self icon will send the
message to yourself via email.

Note: If you are replying to an article, and your reply is not
intended for everyone, you should only use the Mail icon to send an
email message. Posting your reply with the News icon would be
inappropriate because it will add your message to the newsgroup.

3 In the message area, compose your message.

You can type and edit the body of your message normally with your
keyboard and mouse.

4 When you are finished, click Send.
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Searching News Articles
NewsWatcher can search for keywords in the headers of news
articles.

1 Select Search from the Special Menu.

A search window will appear.

2 In the Header field, select the part of the header you wish to

search.

3 In the Containing field, type the keywords you wish to

search for.

4 Click Search.
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Extracting Binaries
Binaries are files which can be attached to news articles. There are
two ways to extract binaries from news articles.

Note: NewsWatcher must launch a helper application, such as
StuffIt Expander, to decompress and/or decode attachments.
(StuffIt Expander is available on the Software Ventures FTP server.)

1 If an article has an attachment, click the small file icon or

select Extract Binaries from the Special Menu.

If there are no files attached, there will not be a small file icon.

2 Or from a newsgroup window, you can select the article(s)

and select Extract Binaries from the Special menu.

NewsWatcher will tell you if it cannot find any files to extract.

Note: If NewsWatcher has problems extracting a file that has been
split into several articles, you may have to extract them manually. To
do this, select all the articles that contain parts of the file (by
holding down the command key when clicking the mouse) and
select Extract Binaries Manually from the Special menu. Use the
mouse to put the parts in order and click Extract.
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NewsWatcher Preferences
There are many different categories of preferences within
NewsWatcher. To change any of these preferences, select
Preferences from the File menu, and select a category from the
Topic popup menu.

Information about NewsWatcher’s preferences is available in
NewsWatcher’s official documentation.

More Documentation
The official NewsWatcher documentation is available on the
Software Ventures FTP server (ftp.svcdudes.com) in the directory
/pub/mac/valet/documentation/
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Fetch

Fetch provides a simple interface to do FTP with your Macintosh.
FTP stands for File Transfer Protocol and is the way files are
transferred over the Internet. Fetch can run in the background, so
you can use other applications during long file transfers.

Fetch was created at Dartmouth University.

Starting Fetch
1 Double-click the Fetch icon.

Fetch will start and present you with the Open Connection window.

2 To open a connection to the Software Ventures FTP server,

click OK.

This is the default Shortcut. You can also click the Shortcuts popup
menu to select an alternate FTP server. To change the default
Shortcut, see the section Using Shortcuts.

Note: If Fetch fails to connect, there may be a problem with your
Internet connection or the Software Ventures FTP server may be
temporarily busy or unavailable.
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Connecting to an FTP Server
1 Select Open Connection from the File Menu.

This will bring up the Open Connection window. Clicking the Open
Connection button on the main Fetch window will do the same
thing.

2 In the Host field, type the FTP server address.

You can type either the domain name or the IP address of the FTP
server. Domain names are usually groups of words separated by
periods. There are no @ symbols in domain names, only in email
addresses.

3 In the User ID field, type your username.

If you are connecting to an FTP server on which you have a personal
account, type your username for that account. If you are connecting
to a public FTP server, use “anonymous” as your User ID.
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4 In the Password field, type your password.

If you are connecting to an FTP server on which you have a personal
account, type your actual password for that account. If you are
connecting as “anonymous,” you are expected to enter your email
address as the password.

Note: If you leave the Password field blank, Fetch will use the
email address set in the Default Password field in Preferences.
Internet Valet Setup will automatically configure this for you.

5 If you know the directory which you would like Fetch to

open, type its path in the Directory field.

This is optional. If you leave this field blank, Fetch will open the
default directory of the FTP server.

6 Click OK.

Fetch will attempt to open a connection with the information you
have provided.

Note: Popular FTP sites which support anonymous logins are often
quite busy. If Fetch cannot open a busy FTP server, try again later.

Navigating on an FTP Server
Fetch lists the files and folders of an FTP directory on the left side
of the main Fetch window. The name of the directory being viewed
appears in a popup menu above its contents. You can use this menu
to open a parent directory. In the contents window, double-clicking
a folder will open that directory and double-clicking a file will
download it using the selected transfer format.
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Getting a File
Getting or downloading a file refers to transferring a file from the
remote FTP server to your Macintosh.

1 In the main Fetch window, select the file(s) you wish to get.

To select more than one file, hold down the command key when
clicking the mouse.

Note: In order to download an entire directory, you must use the
command Get Directories and Files from the Remote menu. You
cannot get a directory with the Get File button.
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2 Select a transfer format by clicking its radio button.

In most cases, you should use Automatic.

Automatic - Fetch will automatically choose either Text or Binary
depending upon the type of the file to be transferred. This is the
recommended setting.

Text - Fetch will download the file as if it were ASCII text. This will
translate all CR LF pairs to CR only for the Macintosh. Use this
format for text files.

Binary - Fetch will download the file and attempt to filter it with a
known Macintosh binary format. If the file does not match a known
format, Fetch will treat the file as raw data.

Note: Although BinHexed files (.hqx) are technically text files, you
can use Automatic to have Fetch decode them for you.

3 Click the Get File button.

After Fetch has retrieved some information about the file you wish
to download, you will be prompted with a standard file dialog.

4 In the file dialog, select a location on your Macintosh, name

the file, and click Save.

The status and progress of the transfer is displayed on the right side
of the main Fetch window.

Note: Many files are stored in compressed format. You will need a
decompressing program, such as StuffIt Expander, to decompress
these files before you can use them. You can get StuffIt Expander
from the Software Ventures FTP server (ftp.svcdudes.com).
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Putting a File
Putting or uploading a file refers to transferring a file from your
Macintosh to the remote FTP server.

1 In the main Fetch window, open the directory on the FTP

server to which you wish to put the file.

2 Click the Put File button.

A standard file dialog will appear.

3 Select the file you wish to put on the FTP server.

To put more than one file at a time, or to put an entire folder with its
contents, you must use the command Put Folders and Files from the
Remote menu.

4 Click Open.

This selects the file you wish to transfer. If a folder is selected, the
file dialog will display the contents of that folder.

Note: To transfer a folder and its contents, you must use the
command Put Folders and Files from the Remote menu.

5 Assign a filename for the file being transferred.

You do not need to rename the file unless you want to. However,
remember to use filenames that will also be convenient for non-
Macintosh users.
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6 Select a transfer format in the Format popup menu.

Fetch will set the recommended transfer format for you. You do not
need to change this unless you know that it is necessary.

Text - Fetch will transfer the file as if it were ASCII text. This will
add linefeeds (LF) to all Macintosh carriage returns (CR). This is the
recommended transfer format for files of type TEXT.

Wrapped Text - In addition to the regular Text transfer format,
Fetch will also wrap all lines at the length specified in Preferences.

Raw Data - Fetch will transfer only the data fork of the file as
binary data.

MacBinary II - Fetch will transfer both the resource and data forks
of a Macintosh file. This is the recommended transfer format for
binary Macintosh files.

BinHex - Fetch will convert a Macintosh binary file into a text file
and append the proper BinHex suffix to the filename.

AppleSingle - Fetch will transfer the file in Apple’s format for
storing a Macintosh file on non-Macintosh machines.

7 Click OK.

Fetch will upload the file. The transfer status and progress can be
seen on the right side of the main Fetch window.

Disconnecting from an FTP Server
1 Select Close Connection from the File menu.

Clicking the Close Connection button on the main Fetch window will
do the same thing.
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Using Shortcuts
When you are in the Open Connection window, you can select an
FTP server from the Shortcuts popup menu. You can modify the list
of Shortcuts to include your favorite FTP sites.

1 Select Edit Shortcuts from the Customize menu.

2 Use the New, Change, and Remove buttons to create,

modify, and delete entries in your Shortcuts list.

When creating or modifying a Shortcut, you will be presented with a
window similar to the Open Connection window.

3 To set the default Shortcut, select a Shortcut and click the

Make Default button.

The default Shortcut is marked with a checkmark and is the Shortcut
which initially appears in the Open Connection window.

4 When you are finished editing the Shortcuts list, click OK.
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Preferences
Fetch has five categories of preferences which you can configure:
General, Uploading, Downloading, Formats, and Miscellaneous. To
change any of these preferences, select Preferences from the
Customize menu and select a category from the Topic popup menu.
For complete descriptions of all the Preferences options, select
Fetch Help from the Windows menu.

Online Documentation
For more help with Fetch, select Fetch Help from the Windows
menu. Balloon Help is also available for Fetch by selecting Show
Balloons from the Help menu. The Help menu is the question mark
on the right side of the menu bar.
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TurboGopher

TurboGopher is the fastest Macintosh Gopher client available
and will run in the background, so you can use other applications
during longer searches.

Gopher was originally created at the University of Minnesota to
be used as a campus-wide information search and retrieval
system. Now, Gopher is supported widely throughout the Internet.

Starting TurboGopher
1 Double-click the TurboGopher icon.

TurboGopher will start and automatically open a connection to the
University of Minnesota Gopher server.

Note: If TurboGopher fails to connect, there may be a problem with
your Internet connection or the University of Minnesota may be
temporarily busy or unavailable.
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Connecting to a Different Gopher Server
1 Select Another Gopher from the Gopher menu.

A window will prompt you for a Domain Name and Port.

2 In the Domain Name field, type the name of the Gopher

server you wish to open.

You can type either the domain name or the IP address of the
Gopher server. Domain names are usually groups of words
separated by periods. There are no @ symbols in domain name
addresses, only in email addresses.

3 Do not change the Port settings.

The default Port is 70. Do not change this unless you know that it is
necessary.

4 Click OK.

TurboGopher will attempt to open the Gopher server you have
specified.
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Navigating Gopherspace and Items
To navigate through Gopherspace, just double-click the item or
folder that interests you. You can also use the arrow keys on the
keyboard to change the selected item and press the Return key to
open it.

Folders

When you double-click a folder icon, TurboGopher will display its
contents in a new window.

Text Files

When you double-click a text document icon, you will see text
information. To save this information to a text file on your
Macintosh, select Save As from the File menu.

Searches

Question mark icons represent search directories. When you
double-click a Search icon, you will be prompted with a Find What?
dialog. Type the keywords you would like to search for and click
Find.

Phone Books

Phone book icons represent electronic phone books. When you
double-click a phone book icon, a dialog will prompt you for a
name, address, or phone number. The default lookup dialog
searches for someone by name. To specify exactly which fields to
search, click the More Choices button.
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Macintosh Files

Disk icons represent archived Mac files. When you double-click a
disk icon, the file will be transferred to your Macintosh. You will be
asked to name the file and specify a location on your Macintosh to
save the file.

Note: Many of these items are stored in compressed format. You
will need a decompressing program, such as StuffIt Expander, to
decompress these files before you can use them. You can get StuffIt
Expander from the Software Ventures FTP server.

Graphics, Sound, and Movie Files

Starburst icons represent graphics or picture files (GIF, JPEG, PICT,
etc.); speaker icons represent sound files (SND, AIFF, WAV, etc.);
and movie strip icons represent movies (MOV, QT, etc.). When you
double-click one of these icons, the file will be transferred to your
Macintosh. You will be asked to name the file and specify a location
on your Macintosh to save the file.

Note: You will need an appropriate program to view a graphics
file, play a sound file, or show a movie file.

Other Files

Icons with a tiny “PC” are MS-DOS items. Icons with a “UX” are
UNIX items. You can retrieve these items, but they will still remain
in PC or UNIX format.

Inaccessible Items

Sad face icons are items that cannot be opened. The item is either
damaged or still under construction.
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Creating a Bookmark
You can mark a frequently visited Gopher location with a
bookmark. Bookmarks save the information necessary to return to a
specific location in Gopherspace.

1 To make a bookmark for the frontmost Gopher window,

select Save As from the File menu.

A standard Macintosh file dialog will appear.

2 In the file dialog, select a location on your Macintosh and

click Save.

You may also rename the bookmark if you wish.

Using a Bookmark

From the Finder, you can double-click the icon representing a
bookmark you have saved. In TurboGopher, you can select Open
from the File menu to open a bookmark.
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Using URLs
If you know the URL of a particular Gopher server or item, you can
go directly to it.

1 Select Use Uniform Resource Locator from the Gopher

menu.

You will be prompted to type in a Gopher URL.

A Gopher URL should look like
gopher://servername/path/filename

2 Type in the URL of the directory or item and click OK.

TurboGopher will attempt to connect to the URL you have specified.
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Searching with Veronica
Veronica is a Gopher location which contains Search items that
allow you to search for keywords across a large section of
Gopherspace.

1 In the Home Gopher window, double-click the folder Other

Gopher and Information Servers.

2 In the Other Gopher and Information Servers window,

double-click “Search titles in Gopherspace using Veronica.”

In this window there are many Search items you can use to find
something in Gopherspace. For more information about Veronica,
double-click the item “Frequently Asked Questions (FAQ) about
Veronica.”
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Changing the Home Gopher
TurboGopher will connect to the Home Gopher whenever it is
started or when you select Home Gopher from the Gopher menu.
The default Home Gopher is the University of Minnesota.

1 To change your Home Gopher, select Preferences from the

Gopher menu.

2 In the Home Server field, type the address of the Gopher

server you would like to use as your Home Gopher.

You can type either the domain name or the IP address of the
Gopher server. Domain names are usually groups of words
separated by periods. There are no @ symbols in domain name
addresses, only in email addresses.
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Gopher FAQ
For more help with TurboGopher, you can consult Frequently Asked
Questions (FAQ) about Gopher.

1 Select Show Bookmark Worksheet from the Gopher menu.

2 In the Bookmark Worksheet window, double-click the

Information About Gopher folder.

3 In the Information About Gopher window, double-click the

text file “Frequently Asked Questions about Gopher.”
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MicroPhone Telnet

MicroPhone is one of the most popular data communications
programs for the Macintosh. With the MP Telnet Tool,
MicroPhone Telnet can access text-based services on the
Internet, including your own shell accounts.

MicroPhone was created by Software Ventures Corporation and
can also be used to call many online services, bulletin board
systems (BBS), mainframes, and other personal computers.

Starting MicroPhone Telnet
1 Double-click the MicroPhone Telnet icon.

MicroPhone will start and present you with a connection window.
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Using MicroPhone Telnet
To use MicroPhone Telnet, you can click the buttons on the button
bar below the terminal window.

Telnet - Click the Telnet button to open a Telnet connection with
the current Telnet window.

Close - Click the Close button to close the current Telnet window.

New - Click the New button to open another Telnet connection in a
new Telnet window. You can have multiple concurrent Telnet
sessions by opening additional Telnet connections in new windows.
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Making a New Connection
1 Click the Telnet button to bring up the connection window.

2 In the Host field, type the host address.

You can type the domain name or the IP address of the Telnet host.

The Username and Password fields are optional.

3 Click Connect to begin your Telnet session.

Note: To connect to a preconfigured Telnet host, select it from the
Shortcuts popup menu and click the Connect button.
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Saving a Shortcut
You can save a frequently used Telnet connection as a Shortcut.

1 In the connection window, click the Shortcuts button.

2 In the Name field, type the name for the Shortcut.

Note: Shortcuts must have different names. If you use the name of
an existing Shortcut, clicking Save will replace it.

3 In the Host field, type the host address.

The Username and Password fields are optional.

4 Click Done.

Your new Telnet settings will appear in the Shortcuts popup menu.

Note: To edit or remove a Shortcut, select the Shortcut you wish to
modify from the popup menu and click Save after making any
changes or Delete to remove the Shortcut.
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Changing Terminal Settings
You can change the terminal emulation and font size, as well as
other display settings by selecting Terminal from the Settings menu.

Most Telnet services on the Internet support VT102 for the Terminal
Type. You should not change this unless you know that it is
necessary.

If the Delete key on your Macintosh keyboard does not seem to
work with a particular Telnet service, try switching the option in the
Delete Key popup menu. The choices are Backspace and Delete.
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Glossary

ASCII American Standard Code for Information Interchange. ASCII
usually refers to a standard representation of letters, numbers, and
other text characters.

Bcc Blind carbon copy. A way of copying an email message
anonymously to other recipients. Addresses in the Bcc field will
not appear in the heading of the message. See also Cc.

BinHex A format for converting binary files to text so that they can be
stored and exchanged with other computers. This file format is
commonly used when sending Macintosh files across the Internet,
such as in email messages.

Cc Carbon copy. A way to specify additional recipients of an email
message without directly addressing it to them. Addresses in the Cc
field appear in the heading of the message. See also Bcc.

Client Most Internet applications are what are known as client-server
applications. The Internet client is the program on your Macintosh
which you use for browsing, reading, etc. The Internet server is the
program on the remote machine which provides access to the
information stored there.

Data Fork One of two halves of a Macintosh file. The other half is the
resource fork. Other machines, such as PC’s, only have the
equivalent of the data fork, and can not use Macintosh files unless
they are converted properly.

Domain Name Domain names are names used to organize and identify
computers. Domains are organized both by geographic location
and affiliation. For example, “edu” is a domain for educational
institutions in the US, and “au” is one for computers in Australia.
Subdomains of domains are separated by periods.
“support.apple.com” is a subdomain of “apple.com”, which is a
subdomain of the “com” domain. Individual computers form the
bottom level of the hierarchy of domain names.
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DNS Domain Name System. DNS is a protocol for converting machine
names to IP addresses (and vice versa). Machine names are easier
to remember for people, but IP addresses are required for the
computer programs. DNS allows users to type a name and have the
program convert it into an IP address automatically.

Email Electronic Mail. A method for sending and receiving messages and
other information between computers.

Eudora A popular program for sending and receiving email.

FAQ Frequently Asked Questions. FAQ files provide the answers to the
most common questions on a given subject. Most Usenet
newsgroups have their own FAQ file, and many others can be
obtained via FTP or over WWW.

Fetch A popular Macintosh FTP client.

FTP File Transfer Protocol. An Internet protocol for transferring files
between computers. FTP is the primary means by which files are
shared on the Internet.

Gopher A standard Internet protocol for information search and retrieval.
Gopher's main advantage is that the information that is available
(commonly referred to as Gopherspace) is organized
hierarchically. This makes searching for information easier than on
the World Wide Web.

HTML HyperText Markup Language. The language used to define the
styles, hyperlinks and other formatting in World Wide Web pages.

HTTP HyperText Transfer Protocol. The protocol used by the World
Wide Web to transfer Web pages to your Macintosh.

Hyperlink A pointer from one electronic document to another. In Enhanced
Mosaic, you can follow a hyperlink from one Web page to another
by simply clicking on the highlighted word or icon.

Internet The network of millions of computers which connects
governments, institutions, organizations and companies worldwide.
With a lowercase “i”, internet meant a collection of networks,
usually of different kinds. This term has fallen out of common
usage as the Internet has become more popular.
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IP Internet Protocol. A network protocol which main purpose is
directing information from one computer to another on the
Internet.

IP Address A numerical address which uniquely identifies each computer on
the Internet. The form of an IP address numbers between 0 and 255
separated by periods. For example, the machine www.svcdudes.com
has the IP address 198.6.226.3.

MacBinary A file format that contains complete Macintosh file information.
This includes the file’s data fork, resource fork, name, modification
date, and other Finder information.

MacTCP System software from Apple which allows your Macintosh to talk to
other machines on the Internet. MacTCP is required in order to
use PPP or any other Internet clients.

MicroPhone The most popular program for modem and Internet
communications on the Macintosh. With the MP Telnet Tool,
MicroPhone supports the Telnet protocol, allowing you to access
any machine on the Internet, including your own shell accounts.

Mosaic A popular program for browsing sites on the World Wide Web.
Mosaic was the first Internet Web browser ever made.

Network Protocol A protocol defining how different machines on a network talk to
each other.

News See Usenet News.

Newsgroup One of the thousands of discussion topics in Usenet news.
Newsgroups are named by subject. For example, the group
“comp.sys.mac.comm” covers communications issues with
Macintosh computers.

Pathname A complete description of a file’s location. In the Macintosh file
system, the pathname is designated by starting with the highest
level and separating each part of the path with a colon (:). A
sample pathname could be: “Macintosh HD:Old Letters:Letter to
Mary.” This is the pathname for the file “Letter to Mary” in the
folder “Old Letters” on the volume called “Hard Disk.”

Port Some network protocols, including TCP, use port numbers to
identify the program that owns a connection. For example, when
connecting to an FTP server, you usually connect to port 21, while
Gopher connections usually use port 70.
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POP Point of Presence. A collection of hardware and software used to
provide access to the Internet. Internet service providers have
many points of presence where people can call in with their
modems and connect to the Internet.

POP3 Post Office Protocol version 3. A simple protocol used for copying
email from a mail server to another machine. POP3 does not allow
full send and receive capabilities, but is useful for copying email
from a mail server to your Macintosh.

PPP Point to Point Protocol. A network protocol used for connecting
two machines. PPP can be used with the modem connection
between your Macintosh and your Internet service provider in
order to connect your Macintosh to the Internet.

Protocol A set of rules that defines how computers communicate with each
other. See also Network Protocol.

Resource Fork One of the two halves of a Macintosh file. The other half is the data
fork. Other machines, such as PC’s, only have the equivalent of the
data fork, and can not use Macintosh files unless they are
converted properly.

Server Most Internet applications are what are known as client-server
applications. The Internet client is the program on your Macintosh
which you use for browsing, reading, etc. The Internet server is the
program on the remote machine which provides access to the
information stored there.

Service Provider Internet service providers are companies which provide access to
the Internet. Typical home users call the service provider with a
modem. If the service provider’s point of presence is within a local
telephone call, you only pay their service charge. Otherwise, you
will pay telephone charges as well.

SLIP Serial Line Internet Protocol. A protocol for connecting a
computer to the Internet by modem. The use of SLIP is
diminishing, as people use PPP instead.

SMTP Simple Mail Transfer Protocol. A protocol supported by most mail
servers on the Internet for sending and receiving email. When
retrieving email to your Macintosh, usually you use the simpler
POP3 protocol.
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TCP Transmission Control Protocol. A network protocol used on the
Internet. Most Internet protocols for applications such as email
and FTP use TCP because it takes care of getting your data from
one computer to another exactly as you sent it.

Telnet A simple Internet protocol for tasks such as remote login. Telnet is
used for services that only require text, not graphics or other
binary information.

Unix A popular operating system developed by AT&T and used
primarily by academic and research institutions. Most of the
machines on the original Internet were Unix machines.

URL Uniform Resource Locator. A standard way of locating resources on
the Internet. The general form is <protocol:location>. The URL for
Internet Valet’s World Wide Web home page is:
<http://www.svcdudes.com/valet/>.

Usenet News The Internet discussion forums. There are thousands of newsgroups
that discuss a diverse range of topics. You can read what’s there, or
post your own questions and comments.

Valet, Internet Your servant for the Internet, providing you with everything your
computer needs to use on the Internet.

Veronica A Gopher location which contains search items that allow you to
search for keywords across a large section of Gopherspace.

WAIS Wide Area Information Servers. An Internet database which you
can search on hundreds of different topics.

Web World Wide Web. See WWW.

WWW World Wide Web. The World Wide Web is the collection of Web
servers supporting the HTTP protocol for information exchange.
Pointers between Web pages are in the form of hyperlinks. The
information available on the World Wide Web is broad and is
expanding very rapidly. The main advantage of WWW is ease of
use. The main disadvantage is the lack of central organization. This
sometimes makes it difficult to locate specific information.
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SOFTWARE LICENSE AGREEMENT

PLEASE READ THIS LICENSE AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE. IF YOU DO NOT
AGREE TO THE TERMS OF THIS LICENSE, PROMPTLY RETURN THE UNUSED SOFTWARE TO
THE PLACE WHERE YOU OBTAINED IT AND YOUR MONEY WILL BE REFUNDED.

1. License. The application, demonstration, system and other software accompanying this License,
whether on disk, in read only memory, or on any other media (the “Software”) and the related
documentation are licensed to you by Software Ventures Corporation (“SVC”). You own the disk on
which the Software are recorded but SVC and/or SVC’s Licensors retain title to the Software, and related
documentation. This License allows you to use the Software on a single computer and make one copy of
the Software in machine-readable form for backup purposes only. You must reproduce on such copy the
SVC copyright notice and any other proprietary legends that were on the original copy of the Software.
You may also transfer all your license rights in the Software, the backup copy of the Software, the related
documentation and a copy of the License to another party, provided the other party reads and agrees to
accept the terms and conditions of this License, and you notify SVC.

2. Restrictions. The Software contains copyrighted material, trade secrets and other proprietary material.
In order to protect them, and except as permitted by applicable legislation, you may not decompile,
reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may
not modify, network, rent, lease, loan, distribute or create derivative works based upon the Software in
whole or in part. You may not electronically transmit the Software from one computer to another or over a
network.

3. Termination. This License is effective until terminated. You may terminate this License at any time by
destroying the Software, related documentation and all copies thereof. This License will terminate
immediately without notice from SVC if you fail to comply with any provision of this License. Upon
termination you must destroy the Software, related documentation and all copies thereof.

4. Export Law Assurances. You agree and certify that neither the Software nor any other technical data
received from SVC, nor the direct product thereof, will be exported outside the United States except as
authorized and as permitted by the laws and regulations of the United States and the laws and regulations
of the jurisdiction in which you obtained the Software.

5. Government End Users. If you are acquiring the Software on behalf of any unit or agency of the
United States Government, the following provisions apply. The Government agrees:
(i) if the Software is supplied to the Department of Defense (DoD), the Software is classified as
“Commercial Computer Software” and the Government is acquiring only “restricted rights” in the Software
and its documentation as that term is defined in Clause 252.227-7013(c)(1) of the DFARS; and
(ii) if the Software is supplied to any unit or agency of the United States Government other than DoD, the
Government’s rights in the Software and its documentation will be defined in Clause 52.227-19(c)(2) of the
FAR or, in the case of NASA, in Clause 18-52.227-86(d) of the NASA Supplement to the FAR.
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6. Limited Warranty on Media. SVC warrants the diskettes on which the Software is recorded to be free
from defects in materials and workmanship under normal use for a period of ninety (90) days from the
date of purchase as evidenced by a copy of the receipt. SVC’s entire liability and your exclusive remedy
will be replacement of the diskettes not meeting SVC’s limited warranty and which is returned to SVC or
an SVC authorized representative with a copy of the receipt. SVC will have no responsibility to replace a
disk damaged by accident, abuse or misapplication. ANY IMPLIED WARRANTIES ON THE DISKETTES,
INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE, ARE LIMITED IN DURATION TO NINETY (90) DAYS FROM THE DATE OF DELIVERY. THIS
WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY ALSO HAVE OTHER RIGHTS WHICH
VARY BY JURISDICTION.

7. Disclaimer of Warranty on Software. (For the purposes of provisions 7 and 8, SVC, SVC’s Licensor’s
and the Directors, Officers, Employees, and Agents of SVC and SVC’s Licensors are collectively referred to
as “SVC”) You expressly acknowledge and agree that use of the Software is at your sole risk. The Software
and related documentation are provided “AS IS” and without warranty of any kind. SVC EXPRESSLY
DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. SVC DOES NOT
WARRANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET YOUR REQUIREMENTS,
OR THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT
DEFECTS IN THE SOFTWARE WILL BE CORRECTED. FURTHERMORE, SVC DOES NOT WARRANT OR
MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE
SOFTWARE OR RELATED DOCUMENTATION IN TERMS OF THEIR CORRECTNESS, ACCURACY,
RELIABILITY, OR OTHERWISE. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY SVC OR
AN SVC AUTHORIZED REPRESENTATIVE SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE
SCOPE OF THIS WARRANTY. SHOULD THE SOFTWARE PROVE DEFECTIVE, YOU (AND NOT SVC OR AN
SVC AUTHORIZED REPRESENTATIVE) ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING,
REPAIR OR CORRECTION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.

8. Limitation of Liability UNDER NO CIRCUMSTANCE INCLUDING NEGLIGENCE, SHALL SVC BE LIABLE
FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR
INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION, EVEN IF SVC OR AN SVC
AUTHORIZED REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME
JURISDICTIONS DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY FOR INCIDENTAL OR
CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU.
In no event shall SVC’s total liability to you for all damages, losses and causes of action (whether in
contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.

9. Controlling Law and Severability. This License shall be governed by and construed in accordance
with the laws of the United States and the State of California, as applied to agreements entered into and to
be performed entirely within California between California residents. If for any reason a court of
competent jurisdiction finds any provision of this License, or portion thereof, to be unenforceable, that
provision of the License shall be enforced to the maximum extent permissible so as to effect the intent of
the parties, and the remainder of this License shall continue in full force and effect.

10. Complete Agreement. This License constitutes the entire agreement between the parties with respect
to the use of the Software, the related documentation, and supersedes all prior or contemporaneous
understandings or agreements, written or oral, regarding such subject matter. No amendment to or
modification of this License will be binding unless in writing and signed by a duly authorized
representative of SVC.
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IMPORTANT

The use of this product is subject to the license agreement found in the back of the Easy
Reference manual. Do not use this product until you have read the license agreement. By
using the software, you are agreeing to be bound by the terms of the agreement.

TRADEMARKS

Internet Valet and MicroPhone are registered trademarks of Software Ventures Corporation.

Apple and Macintosh are registered trademarks of Apple Computer, Inc.
Power Macintosh and the Accelerated for Power Macintosh sticker are trademarks of Apple
Computer, Inc.

The following products are provided under license.  The product names are trademarks of
the respective licensors.

Eudora Qualcomm, Inc.
Enhanced Mosaic Spyglass, Inc.
NewsWatcher Northwestern University
Fetch Dartmouth College
TurboGopher University of Minnesota
MacTCP Apple Computer, Inc.
MacPPP Merit Network, Inc.
Square One Binary Software, Inc.

All other product names are trademarks or registered trademarks or trade names of their
respective companies.

COPYRIGHTS

Copyright © 1995. All rights reserved.
Internet Valet is a product of Software Ventures Corporation.

The Internet Valet palette is based on Binary Software’s Square One,
copyright © 1995 Binary Software, Inc., all rights reserved. Square One original concept,
design, and programming by Jud Spencer. Reproduced under license.

Enhanced Mosaic, copyright 1994, 1995 Spyglass, Inc.
Copyright 1993-95 Board of Trustees of the University of Illinois.
NCSA Mosaic was developed by the National Center for Supercomputing Applications at the
University of Illinois at Urbana-Champaign. Enhanced versions developed by Spyglass, Inc.

No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval
system, or translated into any language or computer language, in any form or by any means,
electronic, mechanical, magnetic, chemical, optical, manual or otherwise, except as provided
in the license agreement governing the computer software and documentation or by prior
written permission from Software Ventures Corporation.



How to Contact
Software Ventures Corporation

Corporate Offices (510) 644-3232
(510) 848-0885 fax
sales@svcdudes.com

Upgrades (800) 782-9333
(510) 601-1088 fax
upgrades@svcdudes.com

Software Ventures BBS (510) 849-1912

Software Ventures Home Page http://www.svcdudes.com
Software Ventures FTP Site ftp.svcdudes.com

PSINet InterRamp Customer Support

24 hours every day (717) 770-1701
PSINet InterRamp Home Page http://www.interramp.com
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