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This manual assumes the operator is already 
comfortable with the Macintosh Computer - It uses 
the menus, dialog boxes and commands in the 
standard ways.

This program requires system software version 
6.0.2 or greater (including system 7) and at least 
512k of memory.
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This manual and the software described in it are 
copyrighted with all rights reserved.  You are 
permitted to use this program only on the number of 
systems specified on the purchase agreement.
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Overview

The section titled Getting Started will allow you to 
begin using this program immediately.  The rest of 
the manual describes each feature of the program in 
detail.  If you have any questions and cannot find 
the information in the manual, please feel free to 
contact me for assistance.

Lawrence Goerzen
Northern Light
26 Gair Dr.
Etobicoke, Ontario
Canada
M8W  4P4

MacGradeBook will allow you to create individual 
student reports, averages, class lists, class marks 
and blank mark sheets.  You can create your own 
headers and footers, format the student report in any 
way that suits your needs, add a special comment to 
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the parent or student (from the included sample list 
or generate your own comments), add graphics, 
change the type face -- you can even add items from 
a draw or paint program.

A unique feature of this program is that it has the 
ability to make every comment seem personal by 
allowing you to include a student name and gender 
specific pronouns into standardized comments.  You 
can use the built in comments or define any number 
of standard comments of your own.

When you have developed a report form that you 
like, you can save it in a template and then reuse it 
again and again.

The student marks can be percentages or any other 
system of marks that you define.

MacGradeBook is organized around a class of 
students, the information for which it stores in a 
file.  Within each class information is stored about 
the students, the assignments, the marks the 
students received for each assignment and the 
format in which the marks should be printed.  
Unlike a paper mark book MacGradeBook places 
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these assignments in categories, each of which is 
given a weighting toward the student’s average or 
final mark.  Assignments can be added to categories 
at any time.  The average or final mark is updated 
instantly when a new assignment is added, giving a 
current indication of a student’s overall progress.

Throughout the term you can print individual 
student reports showing progress to date for one or 
more students or the class list with current averages 
for everyone.  These are handy for parent 
conferences, guidance counselor's inquiries, 
department meetings, etc.

Even if you don’t use the program to create report 
cards for your students, the advantages of a 
computerized “smart” grade book should be of help 
to you.

Getting  Started

This section will walk you through 
the creation of your first class 
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mark book and the printing of a 
report card.  You will need to 
create a document and enter into it 
four things;  a list of students, at 
least one category, a list of 
assignments and the individual 
marks each student received for 
each assignment.

Start a Document For a New Class

When you double click on the MacGradeBook icon it opens a new 
document for you.  If you opened the program by double clicking on 
an existing class document (i.e., the sample classes provided) you can 
start a new document by selecting New from the File menu.
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The new document will  display an empty data window that we will 
now fill.

Load a Template

A template defines a style of mark book.  Eventually you will 
probably define one or two templates of your own that contain the 
setups you use most frequently, but for now we will use the 
predefined template that came with your MacGradeBook program.

1 Select Standard from the Utilities menu.

2 Click on Load when you are asked for confirmation.

After doing this, no changes will be visible on the screen because this 
template contains no assignments or categories, only a default student 
report format.

Add the Teacher's Name

After loading the template the basic format of the report that will be 
generated is there, however, it still needs to be customized.  This 
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customization can be included in a new template so that it will only 
need to be done once.

1 Select Format from the Window menu

2 Move the cursor over the text "teacher name" and click once.  A 
dotted box with 8 black squares along the edges will appear 
around the text 

3 Select all of the "teacher name" text and then type in your name 
as the teacher for this class.

4 Move the cursor over the text "school name" and click once.

5 Select all of the "school name" text and then type in the name of 
your school.

6 Beside the text "class" is the token "@r" that does not need to be 
changed.  It will be replaced by the name you are going to give 
this document that will also be the name of this class.
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7 Now go back to the data window by selecting Data from the 
Window menu.

Name The Document

We will now give our document a name.  The name we give the 
document is usually also the name of the class (e.g., Math 30, 
English, etc.).

1 Select Save As from the File menu.

2 Use the file list and directory pop-up menus to go to the 
directory that you want the document to be saved in.

3 Enter the name of the document.

4 Click on the Save button.

In naming the document we have also saved the changes made so far. 
As more data is entered into a document it should be saved 
periodically to prevent data loss if there is a power failure.  To do this 
select Save from the File menu.

Create a List of Student Names

The next thing we are going to do is create a list of students.  This list 
can be changed, added to or deleted from at a later time so don’t 
worry if you make any mistakes.

1 Select Student from the Edit menu.  This will open a dialog box 
in which you will enter the student information.
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2 Enter student name and ID if desired.  The student's family name 
should be entered in the Last Name field and all other names in 
the Given Names field.

3 To move to the next box press Tab or use the mouse and click in 
the desired box.  Don’t press the Enter or Return key until all 
information for this student has been entered -- doing so will 
save all the data entered so far for this student and create a new 
record for the next student.

4 When all data for a student has been entered, click on the New 
button or press Return or Enter to save the data and create a 
new record for the next student.

5 Repeat steps 2 - 4 until all the students have been entered.  
When the data has been entered for the last student, instead of 
pressing Enter or Return, click the OK button to accept the 
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student list.  If Enter or Return was pressed too many times there 
will be blank student entries in the list of students at the top of 
the dialog box -- these can be deleted by clicking on the entry in 
the list and then clicking the Delete button.

After OK was pressed you will be back at the data window.

If you want to add to, delete from the list or change the data for any 
student or students, select Student from the Edit menu again.  To 
change the data for a student click on that student in the student list 
and then change any of the information as desired.  Selecting any 
other student or clicking on OK will save the data for the student.

To delete a student select the student in the list and click on the 
Delete button.

To add a new student click on the New button or press Enter or 
Return.  The new student will be inserted in the student list in front 
of the student that was selected.

It is a good idea to periodically save the work that you’ve done, 
especially after entering a significant amount of data.  Select Save 
from the File menu.
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Define Categories

A Category defines a type of assignment such as quiz, essay or 
attendance, etc.  Each category contains one or more assignments.  
For example, category "Quiz" could contain assignments Chapter1, 
Chapter2, etc.  The student receives marks for each assignment which 
are then combined to produce a mark for the category.  You can 
define as many categories as you like but there must be at least one.  
Each category has a fixed weighting towards the final mark, i.e. 
quizzes, no matter how many there are, could be worth 10%.

1 Select Category from the Edit menu which will open a dialog 
box in which you can add, delete or change categories.

2 Enter the name of the category.  e.g. Quiz, Attendance, etc.

3 Press the Tab key to go to the next field.

4 Enter the weight that should be given to this category towards 
the final mark.  The weight given will be the number entered 
divided by the total of all weights.

5 Click on the New button to create a new blank category or go to 

MacGradeBook



Teacher's PET

step 7 if finished.

6 Repeat steps 2 through 5 for as many categories as you wish to 
define.

7 Click on the OK button to accept the categories and return to the 
main data window.

The data window will now display the categories you have entered.  
Changes can be made at any time by, again, selecting Category from 
the Edit menu.

Define Assignments

An assignment is anything a student receives a mark for.  For 
example, if one of the categories is “quiz” then each quiz is an 
assignment.

1 Select Assignment from the Edit menu.
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2 Enter the name of the assignment.  e.g. quiz # 1, Chapter 4, etc.

3 Press the Tab key to move to the next field.

4 Enter the maximum mark for this assignment.

5 Select the category to which this assignment belongs.

6 Click on the New button to create another assignment or go to 
step 8 if finished.

7 Repeat steps 2 through 6 until all assignments have been 
entered.

8 Click on the OK button to accept the list of assignments.

The Next and Previous buttons can be used to move forward and 
backward through the list of assignments to check or change them.
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After returning to the data window you will now see the assignments 
entered displayed along the top as column headings.

Enter Marks

The data window will now display the assignments entered along the 
top of the window and the students along the left side.  To enter the 
marks each student received for each assignment:

1 Use the mouse to select the mark box for the first student in the 
column for the first assignment.

2 Enter the student's mark for that assignment.

3 Press Return or Enter which enters the mark and moves to the 
next student.

4 Repeat steps 2 and 3 for all students.

5 Repeat steps 1 through 4 for all assignments.

To change the mark for any student click on the box for the mark you 
wish to change and then change it.
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Print a Student Report

If you select Format from the Window menu you can see the marks 
entered for the currently selected student as they will be printed in the 
student report.  The tokens (@r, @c, etc.) are expanded when the 
actual printing takes place.
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You can either print a single student report or all student reports.  To 
print a single report select the desired student then select Print 
Report from the File menu.  To print all the student reports select 
Print All Reports from the File menu.

The  Data  Window

The data window is the first 
window that appears when a 
document is opened and is an 
array of marks for the class 
showing each student’s mark for 
each assignment.  This is where 
the information for the class, the 
students, the assignments and the 
individual marks for each 
assignment are entered and edited. 
The students in the class are listed 
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along the left side followed by the 
average of their marks.  The 
assignments for the class are listed 
along the top.  The mark each 
student received for each of the 
tests are shown in the main data 
array.  To the right of the marks 
array (you may have to scroll the 
window to see it) the combined 
marks for each category are listed.
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Item "Chapter 1" is a member of 
category "Quiz".  Jane Doe received 
45/56 and Billy Smith 37/56 for a 
class average of 41/56.

Billy Smith has an overall
average of 74.25%. Jane Doe received 100% and Billy 

Smith 90% for category 
"Attendance", for a class average of 
95%.  Attendance counts for 1/3 or 
0.33 of the students overall average.

Students

To add or delete students or to change any of the student information 
stored select Student from the Edit menu which will open the main 
student information dialog box.  You can also delete students by 
selecting one or more students in the data window and selecting Cut 
Student from the Edit menu.  For more information see 
"Rearranging Students & Assignments".
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The dialog box contains a list of students, one of which is selected, 
and the following fields that contain the information about the 
selected student:

Last Name The student’s surname or family name.

Given Names Any other names the student may have.  The first, 
second, third names, etc. should be separated by a space.

ID NumberThis can be any string of characters (letters, numbers, or 
symbols).

Male/Female This is used in standard comments to determine 
which form of a word to use (i.e. He or She).

As with almost all other Macintosh dialog boxes, pressing the Tab 
key will advance the cursor to the next text field.

Clicking on the Delete button will delete the currently selected 
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student.

Clicking on the New button or pressing Enter or Return will insert a 
new student in front of the currently selected student.

All changes made while within the dialog box can be canceled by 
clicking on the Cancel button.  To accept the changes, including any 
new or deleted students, click on the OK button.

The only student information that is not accessible through this dialog 
box are student comments which are described in detail in the chapter 
on the “Student Report”

Categories

Student marks are often divided into categories which are then 
combined to produce the final mark.  Categories can be such things 
as “Final Exam”, “Quizzes”, “Essays”, “Attendance”, etc. each of 
which is considered to be a ‘Category’ by this program.  Any number 
of categories may be defined as long as there is at least one.  Each 
category can contain any number of assignments.

For each category a number of fields must be defined:

Name   This is the name of the category and can be any string of text.

Weight   Each category has a weight associated with it that is used 
when calculating the final mark.  For example, if "Quiz" has a 
weight of 1 and "Essay" has a weight of 2, the quizzes, 
regardless of how many there are, will be worth 1/3 of the final 
mark and the Essays will be worth 2/3.  The exact value of the 
weights is not important only the ratio between them is.

Print Detailed Marks   For each category you can specify whether 

MacGradeBook



Teacher's PET

or not you want to include the marks for each assignment in that 
category in the student report.  If printing detailed marks, a box 
appears in the format window (and in the printed student report) 
that contains the marks the student received for each assignment 
in this category.  If not, only the final mark for the category 
appears in the summary box which is always in the format 
window.  A non-detailed category is used when there are too 
many assignments in a category for a printout of them to provide 
useful information (i.e. attendance record, weekly quizzes).  It 
would also be used if there was only one assignment in a 
category such as in the case of a final exam, where a list of 
marks would be redundant.  When a detailed results box for a 
category is added to the format window it is placed in the upper 
left corner.  If you turn detailed printing on for several 
categories, their boxes will all appear in the same place.  Since 
this is likely not where you want it to be, you need to go to the 
format window (see the Student Report section of this manual) 
and move it into position prior to printing any student report.

Detailed marks for 
category "Quiz"

Summary box

Raw Scores.  Within each category marks may be calculated using 

MacGradeBook



Teacher's PET

raw scores or by averaging.  Raw scores allow each assignment 
in a particular category to have a different weight within that 
category.  Averaging gives each assignment within the category 
the same weight.  An example will illustrate the difference:

Quiz #1 result = 30/40

Quiz #2 result = 5/20

Raw scores checked:

Mark for quizzes
= (30 + 5) / (40 + 20) = 35/60
= 53.33 %

Raw scores unchecked:

Mark for quizzes
= (30/40) + (5/20) = 0.75 + 0.25
= 50.00 %

Assignments

An assignment, as it is used in this program, refers to any single thing 
for which the student receives marks.  This can include weekly 
quizzes, daily assignments, attendance, projects, etc.  For example, in 
the case of quizzes, each quiz is an assignment and “quizzes” as a 
whole, is a category.
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For each assignment several things need to be entered:

Name.  This is the name of the assignment and can be any text.  e.g. 
"quiz #3", "Chapter 7", etc.

Maximum Score.  Each assignment has a maximum score which is 
used to determine the mark for that test.  Since it is possible to 
give a student a mark that is greater than the maximum, it means 
that the student may end up with an average that is greater than 
100%.

Category.  Every assignment has a category associated with it that 
determines how the mark for that assignment will be included in 
calculating the student's average.

To add or delete assignments, or to change any of the information for 
an assignment, select Assignment from the Edit menu which will 
open the assignment definition dialog box.  Assignments can also be 
deleted by selecting the assignment or assignments in the data 
window and selecting Cut Assignment from the Edit menu (see 
"Rearranging Students & Assignments").  You will not be able to 
open the assignment dialog box unless at least one category has been 
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defined.

Marks

A mark is the score a student received for a given assignment and is 
entered in the rectangle located at the intersection of the student row 
and the assignment column.  To enter a mark select the square with 
the mouse or arrow keys and type in the mark.  All marks should be 
entered as raw scores, that is to say, if the student received 182 out of 
a possible 225 for an assignment the mark that should be entered is 
182.

If you don't want to enter a mark, the mark square can be left blank 
(or made blank by selecting it and pressing the Backspace key or 
selecting Clear from the Edit menu) in which case this mark will not 
be included in any averaging.  This is different than a mark of zero 
which will be counted when calculating the student's average.

Whenever one or more students or assignments are selected, Clear 
Marks appears on the Edit menu.  Selecting this will clear all marks 
in the selected area.

Rearranging Students & Assignments

Sorting Students

This is the usual way the student list is rearranged.  To do a sort, 
select Sort Students from the Utilities menu.  You can do the sort 
based on any one of several different factors:

- Student name
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- Student ID number

- Student average

The sort can be done in ascending or descending order - if in 
ascending order the lowest student (name starting with ‘A’, lowest 
average, etc.) will be placed at the start (top) of the list.

Name and ID sorts are done on a character by character basis with 
numbers coming before letters.  This can cause some confusion if the 
student ID numbers are, in fact, numbers (they can be any 
combination of symbols, numbers and letters - “AD-103B” is a valid 
student ID number).  If one student has an ID number of 78 and 
another has 104, the second one will be seen as smaller because 1 is 
less than 7.

Cut, Copy & Paste Students

Students can also be moved around using Cut, Copy & Paste 
commands.  First select a student by clicking on the name of that 
student in the data window and then drag the mouse up or down until 
all of the desired students have been selected.  Next select Cut 
Student or Copy Student from the Edit menu to transfer the 
student(s) to the clipboard.  Click on the student you wish to paste the 
selected student(s) above and select Paste Student from the Edit 
menu.

Students can also be cut, copied and pasted between documents.  To 
copy an entire class to another document select Select All Students 
from the Edit menu and then select Copy Student from the same 
menu.

Cut, Copy & Paste Assignments

Assignments can also be moved around using Cut, Copy & Paste 
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commands.  First select an assignment by clicking on the name of 
that assignment in the data window and then drag the mouse right or 
left until all of the desired assignments have been selected.  Next 
select Cut Assignment or Copy Assignment from the Edit menu to 
transfer the assignment(s) to the clipboard.  Click on the assignment 
you wish to paste the selected assignment(s) to the left of, and select 
Paste Assignment from the Edit menu.

Multiple Terms

When a single class spans several terms each term should be treated 
as a separate class.  The final averages for each term can then be 
combined in another class to produce an overall final mark.  
Combining is done by using the Copy Averages command in the 
Edit menu to copy the final marks from each term into another class 
which will produce the final grade.

For example a class might span a full year and consist of 3  terms, 
each term being worth 30% with a final exam worth 10%.  You 
would create 3 classes called “Term1”, “Term2” and “Term3” and fill 
them in as the term progresses in the normal way.  Take care that the 
list of students in each class is the same and in the same order as this 
is important when the final grade is produced.  Use Select All 
Students and then Copy Student to put a copy of the list of students 
into the clipboard.  Next create a fourth class called “Final” and 
select Paste Student from the Edit menu.  With the “Final” class still 
open, open the “Term1” class and select Copy Averages for the Edit 
menu.  Select the “Final” class from the Window menu and then 
select Paste Assignment form the Edit menu.  The averages from 
“Term1” will appear as an Assignment named “Term1” of category “ 
”.  Change the name of the category “Term” and the weight to 90.  
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While still in the category dialog box create a new category called 
“Final Exam” and give it a weight of 10.  Now repeat Copy Averages 
and Paste Assignment for the other 2  terms.  The “Final” class will 
now contain 3 assignments in category “Term” and one in category 
“Final Exam” and the student averages will be the overall final 
marks.

The  Student  Report

The format, header and footer 
windows are used to design the 
student report.  What appears in 
the format window is what will be 
printed as the main body of the 
student report.  The data in the 
header and footer windows will 
appear at the top and bottom of 
every page of the report.  You may 
tailor your reports to suit your 
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needs and the needs of your 
students or their parents.  Together 
the three windows present a 
standard form into which the 
program inserts student specific 
data (via Tokens as discussed later 
in this section) when the report is 
printed.

You can move between the four 
windows (header, footer, format 
and data) by going to the Window 
menu and selecting the window 
you want.  If you resize the 
windows so that more than one is 
visible at a time, you can switch 
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between them by clicking on the 
desired window.  The current 
window has a check mark to the 
left of it.  At the bottom of the 
menu is a list of currently open 
documents which you can switch 
between in the same way.

Everything that appears in these 
windows takes the form of a box 
of which there are four types: 
summary, category, text and 
picture.
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Text

Picture

Summary

Category

Summary Box

This box appears once and only once in the format window and 
contains a summary of the student's marks including the average for 
each category and the overall average.  It has a fixed size and shape 
but can be moved anywhere within the window.   For each category 
the name of the category is listed on the left side with the mark for 
the category, its weight and the resultant percentage of the final mark 
on the right.  The last line gives the student's overall average.

The marks displayed or printed can be percentages or "custom 
grades" as defined by you.  For example, you could define the mark 
"B+" to be printed whenever the student's mark is between 80% and 
84.99%.

To make any changes to the custom grades or to change the summary 
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box format select Configure Summary from the Utilities menu.

Defining Custom Grades

Custom grades can be defined at any time but will not be used unless 
the Use Custom Grades box is checked.

Each entry in the table of custom grades has two parts:

Custom Grade Text
This is the text that is to be printed for this grade.  It can 
be any combination of characters such as “B+” or “3.5”, 
etc..

Minimum mark
This is the lowest mark, as a percentage, for which this 
grade can be applied.  If the student's mark is between 
this value and the minimum mark of the next higher 
grade in the table, the grade name will be used instead of 
the mark.
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To add a grade, click on the New button and enter the name and 
minimum values for it.

To delete a grade, click on the grade to be deleted and then click on 
the delete button.

To change anything about a grade, click on that grade in the table and 
make any changes to the name or minimum.

Customizing The Format

The format of the summary box is controlled by the two check boxes:

Use Custom Grades
If this box is checked the grades that appear in the 
custom table will be used.  If not, the grades will be 
presented as percentages (as they appear in the data 
window).  The table of custom grades will still be there, 
it just will not be used.

If student averages are included when printing a student 
list, custom grades or percentages will be used based on 
this check box.

Include Overall Grade
If this box is checked the last line in the summary box 
will show the student's overall average.  If not, an overall 
mark will not be included nor will the weighting of the 
categories as this is no longer relevant.

Suppression of the overall grade is useful when 
categories are being used to represent different subjects, 
say Math, English, etc.

Summary Box Examples:
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1 NO Use Custom Grades
YESInclude Overall Average

2 NO Use Custom Grades
NO Include Overall Average

3 YESUse Custom Grades
NO Include Overall Average

4 YESUse Custom Grades
YESInclude Overall Average

Category Boxes

One of these boxes will be present in the format window for each 
category that has Print Detailed Marks checked in the category 
dialog box (see the The Data Window - Categories section of this 
manual).  They include the name of the category and the student's 
mark for each assignment within that category.  These boxes have a 
fixed size and shape but can be moved anywhere within the format 
window.

When a category box first appears in the format window it is placed 
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in the upper left corner.  If several boxes are turned on they will be 
placed in the same upper left corner.  These boxes should be moved 
to a better location before printing any student reports.

When positioning the summary or category boxes keep in mind that 
the summary box will grow in length when new categories are added 
and the category boxes will grow when new assignments are added.

Text Boxes

These boxes can contain any text.  They are used to enter any text 
that should appear on all reports such as the name of the school or 
teacher, the date, etc.  The text can include any tokens (see Tokens 
for more information) for text that need to change automatically.  
Text boxes can be stretched horizontally or vertically to suit almost 
any desired layout for the report.  Text boxes can also be given a 
single line border by selecting Border from the Style menu.  When 
you give a text box its size and shape, keep in mind that any tokens 
included in it will expand when printed - any text that goes beyond 
the end of the box will be truncated.

Initially there aren't any text boxes in the windows - they can be 
added by selecting Add Text Box form the Edit menu.  A text box 
can be deleted by first selecting it and then selecting Delete Text Box 
from the Edit menu.

Text boxes can be of any size or shape and can contain any text in 
any font, size,  style, line spacing or justification.  These are used to 
add any text to the report card such as class name, teacher name, etc.  
Any of the tokens (as previously defined) can be included any 
number of times in any number of text boxes.
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Picture Boxes

If you go into almost any draw or paint program you can copy a 
picture into the clipboard and then  paste it into any of the format, 
header, or footer windows by selecting Paste Picture from the Edit 
menu.  These boxes have a fixed size and shape which is defined 
when the picture is transferred to the clipboard but can be moved 
anywhere within the window.

Moving & Shaping Boxes

Whenever the cursor passes over a box it will change shape to 
indicate what sort of action will take place if the button is pressed.  If 
the cursor is a standard up and left pointing arrow it is not over a box. 
If it’s a hand, click and drag will move the box.  For the text boxes, 
this area is near the edge of the box but not on any of the black 
squares. For the other boxes, it's the entire box.  If an I-beam cursor 
appears the cursor is over an area where standard text editing may 
occur.  Clicking on the box will enable the standard flashing vertical 
bar indicating where text insertion will be.  If the cursor changes to a 
two headed arrow, the edge of the box that the cursor is over may be 
stretched or contracted in the direction of the arrows.  The two 
headed arrows appear whenever the cursor is over one of the eight 
small black boxes along the edge of a text box when it's selected.

Fonts

The font, size and style of text in a box can be set to any that are 
available on the system being used.  Just select what you want from 
the Font, Size or Style menus.  What you select will be applied to all 
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text within the box.  If you want one bit of text to have one font and 
another one something different, you must place the text in different 
boxes.  When the selection you make expands or contracts the text, 
the summary and category boxes will be adjusted in size accordingly 
- the text boxes will not and will have to be stretched manually to 
ensure that all text is displayed.

Tokens

Tokens are place holders that can be entered in text to indicate where 
variable data should go when the report cards are printed.  When the 
report is printed the tokens are replaced by the data they represent 
(i.e. date, student name, etc.).  All tokens consist of a 2 character 
sequence that begins with the '@' character.  All tokens can be used in 
any text box, either in the header and footer or in the main document. 
The second character can be upper or lower case which has no effect 
on the text that is inserted except for the pronoun tokens.  Tokens are 
used when you wish to personalize by including the student's name 
and the occasional he/she . In doing this the student will feel more 
like you are speaking directly to him/her and yet allow you to do this 
with ease.  You may use tokens anywhere in the comments or text 
boxes.

@C Comment
All text entered in the student's comment field.  This text 
may contain any other tokens except for another 
comment token.

@D Date
The date the file was last saved.

@F First Name
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The first name of the current student (the one whose 
report is being printed).  This is defined as all of the text 
in the student's Given Names field up until the first non-
alphabetic character (usually the space between the first 
& second names).

@G Given Names
All text entered in the Given Names field for the current 
student.  This will be the first and any middle names the 
student may have.

@H his/her
This is replaced with "his" or "her" as appropriate for the 
student.  If 'H' is used the first character will be 'H' and if 
'h' is used it will be 'h'.

@L Last Name
This is the last name or family name of the student.

@M him/her
This is replaced with "him" or "her" as appropriate for 
the student.  If 'M' is used the first character will be 'H' 
and if 'm' is used it will be 'h'.

@N Number of pages
Total number of pages in the report.  The number of the 
current page in multi-page report card.  This is normally 
used in the header or footer of the document.  For 
example:

Page @p of @n becomes Page 1 of 3

@P Page Number
The number of the current page in the report.
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@R Name of the File
The name of the class or file.  This can be used when 
creating a standard template file for the name of the 
specific class it is being used for.

@S he/She
This is replaced with "he" or "she" as appropriate for the 
student.  If 'S' is used the first printed character will be 'S' 
or 'H' and if 's' is used the first printed character will be 
's' or 'h'.

@T Time
The time when this class was last saved.

The following example will help to illustrate how tokens can be used 
in a student report.  In a text box in the format window we enter:

It has been a very interesting term so far and I look 
forward to seeing you and @f at the Parent-Teacher night 
on March 5.  @c

And in the student comment for student John Doe (this standard 
comment  is used for John and several other students):

@f has been getting by with @h studies but @s could be 
doing much better if @s would attend more classes.

When the student report is printed the text in the text box will read:

It has been a very interesting term so far and I look 
forward to seeing you and John at the Parent-Teacher 
night on March 5.  John has been getting by with his 
studies but he could be doing much better if he would 
attend more classes.
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Headers & Footers

The header and footer windows contain text that will appear at the 
top (header) and bottom (footer) of each page of the report card.  This 
is usually the place for page numbers and possibly such things as 
student name, class name, school name or text like “Report Card for 
March”.  You can include any number of text or picture boxes, 
however, keep in mind that these will occupy the top and bottom of 
every page of the reports so they should not take up very much of the 
page.

Comments

A student comment is anything that you want to say to a specific 
student or student’s parents in the student report.  It is inserted 
wherever the ‘@c’ token is found in the report text.  When entering 
comments a list of standard comments appears that can be used for 
quick entry.  Each time a standard comment title is clicked on, the 
text for that comment is pasted into that student's comment wherever 
the cursor is.  It is possible to include several standard comments and 
some custom text in the comment for a given student.

Each standard comment consists of the text of the comment and its 
title which will appear in the standard comment list in the student 
comment dialog box.  To include student specific information in a 
standard comment tokens must be used.  These are described fully in 
the section on Tokens.  Included in this program is a default bank of 
standard comments.  You may add to or edit these as you please.

Comments for a Specific Student

To add student specific comments select Student Comment from the 
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Edit menu.  This will open a dialog box with the list of students at 
the top and a list of standard comments at the left.  There is also a 
large text area that contains the comment for the student.

The text that appears in the standard comment list is not the text that 
will be inserted. It is just a short reference to the text - its title.

To add or change the comment for a student select the student from 
the student list.  The current comment for that student will appear in 
the comment area.  Now select as much of this comment as you 
would like to have replaced with a new comment (possibly all of it).  
Now click on the desired standard comment from the list at the left.  
The text for that standard comment will replace the selected text in 
the student's comment.  You can now use standard editing methods to 
change the text to anything you like, however, this is usually not 
required.

The Document Comment Bank

Every document has its own bank of standard comments.  Whenever 
a new document is created a set of standard comments is loaded from 
the default comment bank stored in the MacGradeBook program.  
When you make changes to a documents comment bank those 
changes only appear within that document.  If you want those 
changes to be available to all documents you have to update the 
default MacGradeBook comment bank.

Every standard comment has two parts, its text and its title.  The text 
is what will be inserted in the student comment when the comment is 
selected.  The title is what appears in the standard comment list.

To add, change or delete a document standard comment, select 
Standard Comment from the Edit menu which will open the 
standard comments dialog box.  You can also get to this dialog box 
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by clicking on the Standard Comments button from the student 
comments dialog.  This dialog box contains a list of comments on the 
left and two fields -  one for the comment title and one for the text.

To change a comment select that comment from the list and change 
the text or title as needed.

To add a new comment select the comment you wish the new 
comment to appear above and then click on the New button.  Now 
enter the title and text of the new comment.

To delete a comment select that comment and click on the Delete 
button.  To change the order of the comments use the Cut and Paste 
buttons.

When finished click OK to keep the changes or Cancel to throw 
them away.

The Program Comment Bank
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Normally any change made to the bank of standard comments 
remains a local change within the document and does not effect any 
other MacGradeBook document.  However, when you create new 
standard comments it is often useful to have these comments 
available to other documents - to make them part of a master bank of 
comments.

This can be done from the standard comments dialog box by clicking 
on the Add Comment To Defaults button.  This will add the 
currently selected comment to the MacGradeBook default comment 
bank.  An updated list of comments can be added to any document by 
pressing the Revert To Default button which will replace the 
documents comments with a copy of the defaults.

After a while the default comment bank will likely contain some 
comments that need to be deleted or changed.  To do this go to the 
standard comments dialog box -- if you are already there save any 
changes that may have been made to the documents comment bank 
by clicking on OK and then coming back to the comment dialog box.

Now press Revert To Default which will load a copy of the program 
comment bank.  Make all desired changes to the comments and then 
press Make Default which will replace the program comment bank 
with the revised comments that you are working on.

Now press either Cancel to keep the documents original comments, 
or OK to update the document with the new set of comments.

The default comment bank and all of the templates are stored in a file 
called “MacGradeBook Prefs” located in the system folder.  Should 
you ever want to return MacGradeBook to the state it was in when 
you received it, you can delete this file -- a new one will be created 
with the original comments and templates the next time the program 
is run.
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Printing Reports

When a student report is printed the program replaces all of the 
tokens in the Header, Footer and Format windows with data specific 
to the student for whom the report is being issued.  It then prints the 
report with the data from the format window making up the body of 
the document and the data from the Header and Footer windows 
appearing at the top and bottom of every page.

To print the report for one student select that student in the data 
window and then select Print Report from the File menu.

To print reports for the entire class select Print All from the File 
menu.

See the next section on Student Lists to find out how to print a 
summary of the entire class.

Student  Lists

A printed list of the students in a 
class can, optionally, include for 
each student any or all of:

Name
ID number
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Current overall average
Selected assignments
Selected categories
Column headings
Title text
Empty boxes for adding other 

data

To generate a student list select 
Print Student List from the File 
menu.
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Select those that you wish to be 
part of the list.  To select an 
assignment click on its name 
which will select that assignment 
and de-select all other 
assignments.  If you wish to select 
more than one assignment hold 
down the shift key while clicking 
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on additional assignment names.  
Select categories in the same way.

To deselect an assignment or 
category while shift-click on it 
which will toggle from selected to 
deselected.

A quick way to select all 
assignments associated with a set 
of categories is to select the 
categories and then click on the 
“>>” button which will select all 
of the associated assignments.  
This can be useful for such things 
as printing class attendance 
results.  You can avoid including 
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the overall category marks by 
shift-clicking on them.

When everything is selected click 
on the OK button.  A standard 
print dialog box will open -- 
proceed as usual.

Examples:

To generate a list of students and 
their grades check all boxes with 
Empty Boxes = 0.  The title is 
"Math 30 - Mid Term".

Or the same without borders.
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Or to create a blank mark sheet 
select only names, title, headings 
and borders.  In this case Empty 
Boxes = 5.

Graphs

Class Results For An Assignment

To obtain a graph of the scores a class received for a particular 
assignment, select the assignment in the data window and then select 
Graph from the Window menu.
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Category Assignment

Number of 
students in each 
range of marks

Maximum 
mark for 
assignment

Showing Position In The Class

To add a line showing where a particular student is in the class, select 
that student’s mark for the assignment in the data window.  Then 
select Graph from the Window menu.
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This is also the form the graph will take if you select a student prior 
to selecting Graph from the Window menu.  In this case, however, 
the marks displayed will be overall student averages.

Templates

Templates are standard forms that 
can be loaded to quickly start a 
new class or to apply a standard 
format to an existing class.  When 
you create a template you save 
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some attributes of the current 
document in the MacGradeBook 
program.  When you later have 
another class that you wish to have 
the same attributes, you can select 
that template and have all of your 
categories, assignments, the report 
format or other setups appear 
immediately.

You create a template by selecting 
Create Template from the 
Utilities menu.
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A dialog box opens that allows 
you to specify the name of the 
template and several aspects of the 
document that you can save in the 
template.  Click on the check 
boxes for the ones that you want, 
enter the name of the template and 
click on Save to create the 
template.  If you go to the Utilities 
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menu you will see the new 
template listed at the bottom of the 
menu along with the other 
templates.

NOTE:   If you include 
Categories & Assignments in a 
template when you apply the 
template, all assignments in the 
document will be overwritten with 
the assignments from the template. 
Since these new assignments have 
no marks all marks in the 
document will be cleared.  This 
type of template is used to 
initialize a new class with a 
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standard set of categories and 
assignments.

You apply a template by selecting 
one from the list of available 
templates at the bottom of the 
Utilities menu.

You can delete a template by 
selecting Delete Template from 
the Utilities menu.  this will open 
a dialog box in which you can 
choose which templates to delete.

The default comment bank and all 
of the templates are stored in a file 
called “MacGradeBook Setup” 
located in the system folder.  

MacGradeBook



Teacher's PET

Should you ever want to return 
MacGradeBook to the state it was 
in when you received it, you can 
delete this file -- a new one will be 
created with the original 
comments and templates the next 
time the program is run.

When Things Don’t Work

If you are having difficulty 
accomplishing something with this 
program or it seems to be acting 
strange there are a number of 
things that you can do.
The Manual

The more obscure aspects of the program are explained in detail in this manual.  This can 
often be the fastest and easiest way to find the answers that you want.  Be sure to check 
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not only the main section that talks about what you are doing, but also other sections that 
seem related, even though only slightly.  Everything can be seen from many different 
view points and it is possible that the manual was written from a different one than the 
one your using now.

Technical Support

Feel free to contact me at any time for help with anything.

Lawrence Goerzen
Northern Light
26 Gair Dr.
Etobicoke, Ontario
Canada
M8W  4P4

If you have found what seems to be a bug in the program there are some steps that you 
can take that will make the bug much easier to fix.

- Write down exactly what the problem is.

- Write down exactly what needs to be done to see the problem.  This is a set of 
instructions that anyone who knows the program could follow and recreate the 
problem.

- Follow your own instructions a few times to make sure nothing has been left out.

- Contact me and tell me about it.

User  Evaluation

I would appreciate any comments 
you might have about the 
MacGradeBook program.   This 
could include any bugs you have 
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found, any features you would like 
added or deleted, or anything you 
like or don’t like about the product 
or the manual.  Even any 
suggestions you might have in 
regard to other products that you 
would like to see are appreciated.

Please mail any suggestions to:

Lawrence Goerzen
Northern Light
26 Gair Dr.
Etobicoke, Ontario
Canada
M8W  4P4
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