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Installation guide 

This chapter explains how to install the components of 
Publisher and what system requirements you need to be able 
to run and install them successfully. It also explains some of 
the common terms and phrases used in this guide. 

Before you begin 
Before you begin to install Publisher, please: 

��read the greenstreet.htm file on the Publisher CD. To read 
this file, open it in a web browser such as Internet Explorer. 
This file contains information on installing and registering 
Publisher. 

��read the README file on the Publisher CD. To read this 
file, open it in a text editor such as Windows WordPad. 

��familiarise yourself with the styling conventions used in this 
guide. They are described at the end of this chapter. 

��ensure your computer meets the requirements listed in the 
appropriate sections. 

What you need to run Publisher 
To install and run the components of Publisher you need a 
Pentium® P166 Processor, running Windows® 95, NT 4.0, 
ME, XP or 2000 with the following configuration: 

��a CD-ROM drive; 

��at least 16 Mbytes of Random Access Memory; 

��an SVGA video card capable of 256 colours at 800 x 600 
resolution; 

��a mouse or other Windows-compatible pointing device. 

The installation requires approximately 170 Mbytes. 

If you are unsure if your computer meets these requirements, 
consult your dealer or the person who installed it. 
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Installing Publisher 
If you are installing Publisher for the first time, insert the CD 
into your CD-ROM drive. Publisher is installed automatically. 

The installation will copy all components onto your hard disk, 
with the exception of some photos, clipart and sample 
documents in order to save disk space. You can load these items 
from the CD. 

Using this guide 
This guide has been designed to help you begin work with 
Publisher. It includes a suite of tutorials to help you get started. 
The contents pages at the beginning of the guide will help you 
find the section you’re looking for. 

Styling conventions 
This guide consistently uses specific text formats and visual cues 
to help you distinguish between different types of information. 

Keys on the computer keyboard are represented like this: 
ENTER. Sometimes you will need to hold down one key while 
you press another one, e.g. hold down CTRL and press G. This is 
shown as CTRL G. 

Where possible, when a tool is named in the text, the tool is 
illustrated in the margin. 

Text that you enter is shown as: enter this text. 

The names of menu commands, dialog boxes, tools and options 
are shown in bold text, for example, select Open from the File 
menu. 

��Any notes in the text are identified by the use of grey 
shading, i.e. the text you are reading now. Notes are items to 
which you should pay particular attention. 

 



Using this guide: 3 

Installation guide: 1 

Common terms and phrases 
The following terms are used to tell you to do something, 
usually with the mouse, although sometimes there are keyboard 
shortcuts. 

Click Press and release the left mouse 
button quickly. 

Right-click Press and release the right mouse 
button quickly. 

Double-click Click the left mouse button quickly 
twice in succession. 

SHIFT-click Hold down SHIFT as you click the 
left mouse button. 

Drag Move the mouse while pressing 
down the left mouse button, e.g. to 
move a frame. 

Select Click on a tool, object or menu 
command to select it. 

Check Select an option shown as a small, 
square box on a dialog box. These 
options are known as check boxes 
and can be checked (ON), or 
cleared (OFF). 

 When a check box is on, a ✓  is 
displayed in the box. Sometimes a 
third state is available; when this is 
selected, the check box is shaded 
grey. 

Clear Turn off a check box. 

 

 

Checked 

Cleared 
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Where to go now 
If you are a newcomer to Microsoft Windows, refer to your 
Microsoft Windows User’s Guide or online Help for a basic 
introduction to using Windows. If you are new to Publisher or 
any of its components, the tutorials in this guide will help you 
learn how to use it to its full potential. 

 

To start any of the Publisher programs you can either use the 
Start Menu or click on the Program Launcher icon in the right 
hand end of your taskbar to display a menu of the installed 
programs, allowing you to select and run any one of them. 
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Welcome to Publisher 

Publisher is a sophisticated desktop publishing application 
for Windows that is powerful and easy to use. With 
Publisher installed on your PC, you will soon be able to 
create professional looking documents. This chapter 
explains how to run Publisher and goes on to describe how 
to start work. 

Starting Publisher 
If you haven’t already installed Publisher, do so now. (Refer to 
Chapter 1 for details). Once Publisher is installed, you are ready 
to start it. To start Publisher: 

1. Turn on your PC to run Windows. 

2. From the Start menu, locate the program folder where you 
installed Publisher. 

3. Click on the Publisher icon. 

After a moment, the Publisher desktop appears and you are 
presented with the Startup dialog box. 

 

From this dialog box, you have the option of: 

��starting a new document 

��opening an existing document 

��opening a tutorial document 

��quickstarting a document. 
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Starting a new document 
The Starting a new document option gives you total control 
over the creation of your document. 

Using a document style 
1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Start a new document. The New 
Document dialog box appears. 

��If Publisher is running, select New from the File menu. The 
New Document dialog box appears. 

2. From the Category window, select the type of document 
you want. The styles available are displayed in the 
Templates and Designs window. 

3. From the Templates and Designs window, select the 
template or design on which you want to base your new 
document. 

4. Click on New. One of the following will occur: 

��If a blank page style is selected, an untitled blank document 
is created, based on the template selected. 

��If any other category is selected, the New Document 
Wizard is launched. Follow the instructions to create a new 
document based on the options you specify. 

��Once a document is opened, you can alter its style using the 
Document Restyling dialog box. 

 



Starting Publisher: 7 

Welcome to Publisher: 2 

Using a blank page 
To start a new document from a blank page, follow the steps 
below: 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Start a new document. The New 
Document dialog box appears. 

��If Publisher is running, select New from the File menu. The 
New Document dialog box appears. 

2. From the Category window, select Blank Page. 

3. From the Templates and Designs window, select the 
template you want to use. 

4. Click on New. An untitled blank document is created, based 
on the chosen template. 

��Once a document is opened, you can alter its page 
orientation through the Orientation tab on the Page dialog 
box and its page size through the Document Restyling 
dialog box. 

Using an existing document 
You can use any existing document as a type of template on 
which to base your new document. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Start a new document. The New 
Document dialog box appears. 

��If Publisher is running, select New from the File menu. The 
New Document dialog box appears. 

2. Click on the Browse tab. The drives and folders available are 
displayed in the left-hand pane; the same as in Windows 
Explorer. 

3. In the Name box, type the path to the folder where the 
document you want is stored. 
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��If you are not sure of the path, use the navigation tree in the 
left-hand pane to locate the document you want. 

4. From the preview area, select the document on which you 
want to base your new document. 

5. Click on New. An untitled document is created based on the 
original document. 

The information line indicates the progress of the open 
operation. 

Opening an existing document 
To open one of the sample documents supplied with Publisher, 
or a document you have previously saved, follow the steps 
below: 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

2. Double-click on Open an existing document. The Open 
Document dialog box appears. 

��If Publisher is running, select Open from the File menu. 
The Open Document dialog box appears. 

3. Click on the Browse tab. The drives and folders available are 
displayed in the left-hand pane; the same as in Windows 
Explorer. 

4. In the Name box, type the path to the folder where the 
document you want is stored. 

��If you are not sure of the path, use the navigation tree in the 
left-hand pane to locate the document you want. 

5. Use the preview area to navigate to the document you want 
to open. 

��To navigate to a recently used document, use the preview 
area on the Recently used tab. 

6. Click on Open. The document is opened in Publisher. 
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The information line indicates the progress of the open 
operation. 

Quickstarting a document 
The fastest way to create a new document with Publisher is 
through Quickstart. Quickstart simply creates a blank untitled 
document based on the default template. This option is only 
available from the Startup dialog box. 

1. Open Publisher. The Startup dialog box appears. 

2. Click on Quickstart to select it. 

3. Click on Next. An untitled blank document is created. 

Bypassing the Startup dialog box 
You can bypass the Startup dialog box when loading Publisher. 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. In the Startup group box, select Blank Page or Open Last 
Document from the drop-down list box. 

3. Click on OK. 

When you next load Publisher, the default template, or the last 
document you worked on will appear in the work area. 
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The Publisher desktop 
The Publisher desktop contains all the tools and commands you 
need to create professional quality documents. Some of the 
main features of the desktop are identified in the illustration 
below: 

 
The rulers 
The rulers are displayed along the top and left-hand edges of the 
work area. Thin hairlines on the rulers follow the mouse pointer 
movements to indicate the pointer’s current position. 

The unit of measurement used by the rulers is shown in the top 
left-hand corner where they intersect; to change the unit, click 
in this intersection area. A list of available units is displayed in 
the ruler shortcut menu; click on one to select it. Alternatively, 
you can specify the units using the Document tab on the 
Preferences dialog box. You can also turn the rulers on and off 
using the Controls tab on the Preferences dialog box. 

 

rulers

work area

pasteboard

view size controls

page indicator

colour bar

multiple document
interface
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The contents box 
The contents box holds a list of all the objects in your Publisher 
document, such as pictures, text and OLE objects. It also has 
tools for some of the things you will do most frequently with 
objects in your document, such as importing or deleting. 

You can move the contents box around the window by dragging 
its title bar, resize it in the same way as any other window, or 
‘dock’ it in one of the window borders. To turn the display of 
the contents box on and off: 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. Click on the Controls tab. 

3. In the Show Controls group box, click on Contents Box. 

4. Click on OK. The contents box is displayed. 

The pasteboard 
The pasteboard appears around the document page: you can use 
it as a storage area for any items you have not finally placed in 
your document. Any items on the pasteboard are saved with 
your document. You can also change the colour of the 
pasteboard, through the View tab of the Preferences dialog box. 

The work area 
The work area is the area where your document is displayed. 
Depending on the selected view size, you may be able to see all, 
or just part of your document. 

The view size controls 
The view size controls at the bottom left of the document 
window let you adjust the view size of the current page. To 
increase the view size, click on the ‘plus’ tool to the right; to 
decrease the view size, click on the ‘minus’ tool to the left. The 
view size will increase or decrease to the next standard view. 

When you click on the centre control (which shows the view 
size as a percentage), the view size popup menu appears, from 
which you can select a view size. 
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The page indicator 
To the left of the view size controls is the page indicator; this 
shows which page you are currently working on. 

There are two tools on each side of the page indicator, which 
take you to the first, previous, next, or last page. 

Click on the Add Page tool (+) at the right-hand end of the 
page indicator to add a page to your document. 

Click on the centre control to display the Go To Page dialog 
box, from which you can go to a specified page number or to 
the master page(s). 

The colour bar 
Running along the bottom of the Publisher desktop is the 
colour bar. Use this to select a colour for your text, frames and 
graphics. 

You can edit a colour by right-clicking on it in the colour bar to 
display the colour shortcut menu and then selecting Edit colour 
to display the Edit Colour dialog box. You can create a new 
colour by clicking on the + button to the right of the colour bar 
to display the Add Colour dialog box. 

Click on the X button to the left of the colour bar to return the 
fill style of the selected object to none, or the selected text to the 
colour selected in the current paragraph style. Right-click on the 
X button to display the colour shortcut menu with further 
options. 

To turn the display of the colour bar on and off: 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. Click on the Controls tab. 

3. In the Show Controls group box, click on Colour Bar. The 
colour bar is displayed when this option is checked. 

4. Click on OK. The colour bar is displayed. 
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The multiple open document interface 
Each open document in Publisher has its own window, rulers, 
view size controls, page indicator and buttons, and title bar. 
These document windows can be moved and resized 
individually. 

The Toolbox, colour bar, toolbars, information line and menu 
bar all work with the active document window. 

There are options in the Window menu to cascade and tile 
document windows and to arrange the icons of minimised 
document windows. There is also a list of open documents, so 
you can select a document straight from the menu. A tick is 
placed next to the active document. 

You can close a document window by doing any of the 
following: 

��double-clicking on the window’s Control-menu icon 

��selecting Close from the window’s Control-menu 

��clicking on the window’s Close button 

��pressing CTRL F4. 

Hints and tips for beginners 
Publisher incorporates a number of helpful hints and tips to 
help you create great documents. 

ToolTips 
ToolTips appear when you pause the mouse pointer over a tool. 
The ToolTip tells you the name of the tool under the pointer. 

You can turn ToolTips on and off via the Options menu. 

Pop-up Hints 
Pop-up Hints are suggestions for how to carry out an action in a 
more efficient way. They appear at relevant moments when you 
are using the program and have a link to an appropriate topic in 
the online Help. 
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An hourglass timer indicates how long before the Hint 
disappears. Clicking on the hourglass causes the timer to pause. 
Clicking on the hourglass again restarts the timer from the 
beginning. 

To move a Pop-up Hint: 

1. Move the mouse pointer over the Hint until the mouse 
pointer changes to a four-headed arrow. 

2. Press and hold down the left mouse button. 

3. Drag the Hint to its new position. 

4. Release the mouse button. 

You can turn Pop-up Hints on and off, and define how often 
they recur, through the Ease-of-use tab on the Preferences 
dialog box. Click on an individual Hint to remove it. 

Using online Help 
Publisher offers you a complete online guide to every aspect of 
using the program, providing you with all the information you 
need. 

Think of the Help as your user guide: there are topics and an 
index, and instead of cross-references there are jumps. Anything 
you would expect to find in a user guide is there. 

One of the many features in Publisher 4 are the online tutorials. 
These are the same as the tutorials in this manual, but are 
presented in an online format for those who prefer to work this 
way. 
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Exiting Publisher 
You can exit Publisher by doing any of the following: 

��selecting Exit Publisher from the File menu 

��double-clicking on the program’s Control-menu icon 

��selecting Close from the program’s Control-menu 

��clicking on the program’s Close button 

��pressing ALT F4. 
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Upgrading to Publisher 4? 

If you are upgrading to Publisher 4, you will soon notice the 
extensive improvements that have been made. Not only is 
there a whole range of new features and functionality, but 
the existing features have been made even easier to use. 

What’s new in Publisher 4? 
Here are just a few of the improvements to be seen in Publisher 
4 that are covered in more detail further on in this chapter: 

��spreadsheeting 

��charts and graphs 

��mail merge and AddressBook 

��PowerText 

��HTML export 

��ease-of-use features 

��single-use tools and frame properties 

��working with documents 

��Help. 

These are just the changes you will notice as soon as you start 
work. There are also many other changes that have been made 
behind-the-scenes, to make Publisher work better for you and 
make it run more smoothly. 

Spreadsheeting 
Spreadsheets are a powerful way of allowing easy entry and 
manipulation of data in a table format. They are especially 
useful for financial planning and budgeting. 

Publisher 4 features full formula support, delivering a fully 
workable spreadsheet for use in your documents. 
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Entering a formula into a table 
1. Select the cell you want to enter a formula into. 

2. Type =. A broken blue border is added to the cell, indicating 
that a formula is being entered. The Formula Tools appear. 

3. In the Formula Tools, click on the Insert Formula button. 
The Function Wizard appears. 

4. In the text box, type one or more words to describe the 
function you are looking for. The list box is updated with a 
selection of functions related to the word(s) you enter. 

5. To limit your search further, select an option from the drop-
down list box. 

��If you do not want to limit your search, make sure All 
functions is selected in the drop-down list box. 

6. Select the function you require from the list box. The syntax 
for the function appears in the Syntax preview area. 

7. Click on OK. The formula is written into the cell, ready for 
you to enter the appropriate cell references over the greyed 
out areas. 

For a detailed explanation of how to use spreadsheets in your 
documents, refer to the online Help. 

Charts and graphs 
Charts are the perfect tool for displaying data in a visual way. 
They provide a useful complement to a table, or can be used as a 
separate feature. 

With Publisher 4 you can create charts from scratch and also 
generate them from existing data. Those created from existing 
data automatically update if the data they are based on is 
changed. A wizard is used to guide you through the process of 
generating a chart, which means all you have to do is select the 
options you want and the wizard creates a chart for you, based 
on the options selected. 
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The properties of charts and graphs are completely 
customisable. As well as bar charts and pie charts there is a range 
of other types available, such as lines charts, scatter charts, and 
area charts. The charts and graphs can be 2D or 3D and a 
legend can be attached. The colours can be changed and titles 
customised. 

Charts and graphs are placed in the contents box, allowing them 
to be placed in more than one frame. 

More detailed information about charts and graphs can be 
found in the online Help. 

Mail merge and AddressBook 
Mail merge is a useful and convenient way of creating standard 
documents with varying information, both quickly and easily. 

The Mailing List dialog box from Publisher 3 has now been 
replaced with AddressBook. Each record now has separate tabs 
for Home, Work, and Notes, giving greater organisational 
capacity. Within these tabs there is also a much wider range of 
fields, for example fields for mobile phone numbers and URL 
addresses, as well as a field for a formatted address – useful when 
creating envelopes. 

When records are added, they are filed in an alphabetical tree 
structure so you can quickly locate records you want to amend. 

A much improved PowerText 
Several significant changes have been made to PowerText, now 
with its own menu bar, making it an even more versatile and 
powerful product. 

Layers are now more sophisticated, with up to twenty-five layers 
supported, each with its own tab. 

Pictures can now be imported into PowerText and are treated in 
the same way as other PowerText items. It is now possible to 
drag-and-drop other PowerText items and pictures directly into 
PowerText from outside the program. 

To help you use the program, PowerText has its own dedicated 
Help covering everything you need to know to get the very best 
out of this powerful utility. 
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HTML export 
Using a simple, yet intuitive, dialog box, your document can be 
exported as a set of HTML pages with supporting files. Just 
select a folder to place your pages in and away you go – it 
couldn’t be easier! 

In the vast majority of cases, the exported document will 
resemble the original document. This is possible because the 
exporter works in conjunction with the Document Restyler to 
overcome any difficulties in exporting. You can then edit the 
files further, or you can put them straight on the Web as they 
are. 

More information can be found on HTML export in the online 
Help. 

Ease-of-use features 
To enable you to get the most out of the product, Publisher 
now includes an expanded range of ease-of-use features. These 
are useful for beginners and upgraders alike. As an upgrader they 
will help you discover the potential of the new features on offer 
with Publisher 4. 

Pop-up Hints 
Pop-up Hints are suggestions for how to carry out an action in a 
more efficient way. They appear at relevant moments when you 
are using the program and have a link to an appropriate topic in 
the online Help. 

 

An hourglass timer indicates how long before the Hint 
disappears. Clicking on the hourglass pauses the timer. Clicking 
on the hourglass again restarts the timer from the beginning. 

As with dialog boxes, Pop-up Hints can be moved by clicking 
and dragging. 
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You can turn Pop-up Hints on and off and define how often 
they recur, through the Preferences dialog box. Click on an 
individual Hint to remove it. 

Tours 
Tours are a new feature in Publisher 4. They are a series of short 
graphical introductions to all the key features of the program. 
Tours are accessible from the Help menu. 

 

The left-hand pane contains a list of all the tours. Clicking on a 
tour displays it. Use the navigation buttons to cycle through the 
pages of a tour. 

For more information on a feature, click on Help/Info. 

Frames 
Frames are a crucial element in the design of a successful DTP 
document – they are an integral part of page layout. Several 
improvements have been made to frames to make them even 
more flexible and user-friendly. 

Single-use tools 
In Publisher, frames can be used to contain any type of content. 
In Publisher 4, it is still possible for a frame to contain any 
content, but each frame tool now has a specific use and it is best 
to match the right tool to the right content. The tools are listed 
overleaf: 
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��The Pointer tool is used to select a frame on the page. It can 
also be used to drag and stretch frames and to edit text. 

��The Text tool is used to create a frame designed to contain 
text. A white, borderless frame is created and the text cursor 
appears, ready for you to enter text. 

��The Box, Rounded Box, Ellipse and Star tools are used to 
create frames in their respective shapes. When you use one 
of these tools, any changes you make to its border and its 
background style and colour are ‘remembered’. The next 
time you draw a frame using one of these tools, the same 
border and background are used. 

��Only the Box tool supports decorative borders. 

��The Line, Curve and Pencil tools are used to draw lines 
directly on the page, which can be made into frames by 
joining the points. 

For more information on single-use tools and on frames 
generally, refer to the online Help. 

Frame properties 
Publisher has always given its users maximum control over 
frame properties. Now the options are even more 
comprehensive, with several key additions and improvements 
introduced in the Frame Properties dialog box. 

Size and position 
There is now a Resize frame constraints group box, giving you 
control over frame resizes. You can now choose between 
preserving the current aspect ratio and preserving the picture’s 
aspect ratio. 

��All options on the Frame Text tab in Publisher 3 are now 
featured on the Size and Position tab. 
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Border styles 

The Border Styles tab of the Frame Properties dialog box has 
been radically changed. Decorative borders are now depicted 
exactly as they appear in the frame, giving you a better idea of 
what the border will look like. To help you identify them, all 
decorative borders are now labelled. 

A new Edges group box has been added, to let you select the 
edges of the frame you want the border to appear on. The 
default varies, depending on which border is selected. 

Picture composition 
The Frame Picture tab of the Frame Properties dialog box has 
been replaced by two other tabs. The first of these is the Picture 
Composition tab. 

The Picture Composition tab deals with all aspects of a picture 
not relating to its colour, or certain aspects relating to its size 
(see above). All the options from Publisher 3 are present in 
Publisher 4: resizing, flipping, tiling, and changing the picture 
angle. 

Picture colour 
The second tab replacing the Frame Picture tab is the Picture 
Colour tab. 

The options available for customising the colour of pictures in 
your documents have been greatly extended, with the 
manipulation of picture colour being divided into three groups: 
colour, balance, and transparency. 

��In the Colour group box, there is a drop-down list of four 
colour options which can be applied to a picture: None, 
Mono, Duotone, and Custom. Selecting Mono lets you 
select the colour of the picture from the Override drop-
down colour palette, which appears beneath the drop-down 
list box. Selecting either Duotone or Custom lets you 
customise the colour of the picture using the Shadow, 
Midtone, and Highlight drop-down colour palettes, which 
appear beneath the drop-down list box. If you are happy 
with the picture colour the way it is, make sure None is 
selected. 
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��In the Balance group box, there are three sliders to control 
the level of brightness, contrast, and saturation. 

��Transparency is a brand new feature. It lets you make frames 
see-through, so that anything beneath the frame is visible 
through it. 

There are four options available from the drop-down list 
box, in the Transparency group box: None, White, Colour 
range and All except colour range. The last three options 
offer you a choice as to how Publisher handles the 
transparency. White makes anything white in the picture 
transparent; Colour range lets you select the range of 
colours to be made transparent; All except colour range lets 
you select the one colour not to be made transparent. If you 
don’t want the picture to be transparent, make sure None is 
selected. 

The slider bar lets you decide how exact the transparency 
will be, in relation to the colour you have selected. The 
closer to Exact the slider is, the closer a colour must be to 
your selected colour before it is made transparent. The closer 
to Loose the slider is, the less exactly like your selected 
colour a colour has to be before it is made transparent. 

Fade 
With Publisher 4’s new fade functionality, you can achieve 
professional looking fade effects, which can make your 
documents stand out. 

To apply a fade to a frame, follow the steps below: 

1. Select the frame to which you want to apply a fade. 

2. Right-click on the frame. A shortcut menu appears. 

3. Select Frame Properties, the Frame Properties dialog box 
appears. 

4. Click on the Fade tab. 

5. From the Fade Type group box, select the fade type you 
want to use. 

��Any changes you make when inside this dialog box, take 
effect immediately. 
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��Some fade types give you the option of setting the angle of 
the fade, using the Angle arrow. 

6. Use the Fade chart to precisely set the strength and extent of 
the fade. 

7. Click on the Close button in the top right-hand corner of 
the dialog box. 

For more information on frame properties, refer to the online 
Help. 

Working with documents 
Many changes have been made in Publisher 4 which affect the 
way you work generally with your documents. 

Multiple open documents 
In Publisher 4 you can have more than one document open at 
the same time. A new window containing your new / opened 
document is created within the program, without closing any 
other open document. 

A document window behaves in the same way as most program 
windows – it can be resized, maximised, minimised and closed 
using the buttons on its title bar. A Next option has also been 
added to the Control-menu of each document window, letting 
you cycle through all open document windows. Each window 
has its own rulers, view size controls, page indicator and buttons 
and title bar. 

The Toolbox, colour bar, toolbars, information line and menu 
bar all work with the active document window. 

A new Window menu is also available, which can be used to 
control various aspects of your open documents. There are 
options to cascade and tile windows within the program and 
arrange icons. There is also a list of open windows, so you can 
select a window straight from the menu. A tick is placed next to 
the active window. 

If you try to exit Publisher without saving all your open 
documents, you will be prompted to save for each open 
document window. 
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User definable guides 
Page layout is a crucial element of any well produced document. 
In Publisher this is achieved through the use of frames and their 
positioning on the page using the grid and column guides. With 
Publisher 4, there is a more flexible way of arranging frames on 
the page – user definable guides. 

User definable guides give you maximum control over where 
you place your frames. They are completely customisable and 
therefore allow greater flexibility when aligning frames on the 
page. 

User definable guides can be customised in many different ways: 
they can be positioned vertically and horizontally; they can be 
used on a master page and thereby used on all pages; their 
colour can be customised through the Preferences dialog box; 
they can be moved or deleted quickly and easily. 

Document creation and restyling 
To help you style your documents there is now a series of 
sample files and wizards. 

Creating a document of a particular type runs a wizard to guide 
you through the process of creating a new document based on 
the type you selected. Similarly, opening a sample file results in 
the appropriate wizard being run to add content and restyle it. 
There are several new sample files available, including postcards. 

There are pages in the wizard to control the layout, page size, 
information, colour and text style of your document. With 
some document types there is also a Custom page, which lets 
you enter custom details to be inserted into the document. 

If you want to change the style of a document after you have 
created it, there is now a Document Restyler available, accessible 
from the Page menu. Instead of a wizard, a dialog box appears, 
with tabs containing different options depending on the 
document type selected. These options are largely identical to 
those found in the Document Creation Wizard. 

More information can be found on document creation and 
restyling in the online Help. 



Getting help: 27 

Upgrading to Publisher 4?: 3 

Getting help 
A newly expanded and now HTML based online Help system is 
available to offer you step-by-step instructions about working in 
Publisher 4. 

The Help Assistant has been removed, although the tutorials are 
still available online. 

All the improvements and additions made are geared to make 
working with Publisher 4 easier and more effective. Once you 
are accustomed to these changes you will soon notice how much 
quicker and easier it is to create eye-catching and dynamic 
documents, whether it is for home or business use. 
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Publisher tutorials – an introduction 

This chapter introduces the theme behind the Publisher 
tutorials. 

The theme 
The Publisher tutorials are designed around an amateur 
dramatics society, its committee, and the problems they face. 
The list below shows the members of the committee of the St 
Ives Players. As you will see in the tutorials, they have chosen 
‘Macbeth’ as this year’s show. 

 

Position Role / Needs 

President Head of the society; wants to 
produce a newsletter. 

Secretary In charge of internal 
communications and 
external correspondence; 
wants to introduce memos. 

Treasurer In charge of the society’s 
accounts; needs to produce a 
report for the AGM. 

Publicity Officer Responsible for advertising 
the society and publicising 
the show; wants to create 
posters and fliers as part of a 
publicity campaign. 
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Social Secretary Organises social events for 
the society; wants to design 
envelopes for sending 
invitations to a party. 

Programme Editor Plans and produces the 
programme for the show; 
needs to plan the layout of 
the programme. 

 

As you work through the tutorials, you can see how the various 
members of the committee achieve their very different objectives 
using Publisher. 
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Creating a memo 

The Secretary has decided to tackle the problem of notes 
and messages getting lost or misdirected, by creating a 
memo sheet and issuing copies to all committee members. 

In this tutorial you will learn how to create a standard 
memo. The skills it teaches you include how to: 

��set up column guides 

��draw frames 

��copy and paste frames 

��resize frames 

��type in and format text. 

All of these aspects provide the basis for a well presented 
document. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 1 – creating a 
memo.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 1 – creating a memo. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 
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4. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

5. Click on the View tab. 

6. In the Graphic Markers group box, check the Guides and 
Frame Outlines check boxes. 

7. Make sure the Printer Margins check box is cleared. 

8. Click on OK. The column guides are visible but the printer 
margins are not visible, giving you a clearer space to work in. 

 

Guides and margins 
In Publisher there are two kinds of guides: user definable guides 
and column guides. In this tutorial you will be dealing with 
column guides. User definable guides are covered in Chapter 8. 

Column guides are represented by grey dotted rectangles with 
an equal amount of space between each column. They appear 
on each page, but are not printed. 

The column guides cannot be resized or repositioned directly 
using the mouse; you can change the number of columns and 
the space between them using the Margins & Columns tab on 
the Page dialog box. 

Margins are used to give the page an imaginary white frame, 
balancing the features on the page and making them stand out. 
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Setting the column guides 
1. From the Page menu, select Margins & Column Guides. 

The Page dialog box appears with the Margins & Columns 
tab selected. 

2. In the Column Guides group box, type 2 in the Number 
of Columns spin box. 

3. In the Columns Gap spin box, type 0.64. 

4. Click on OK. The column guides change on the page and 
your document should now look like the picture below: 

 

Using frames to create a page layout 
Use the column guides you have just set to help you draw and 
position your frames. Before you start to draw your frames, you 
need to switch on the Snap to Guides and Snap to Grid 
commands. 

To turn on frame snapping, follow the steps below: 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears with the Document tab 
selected. 

2. In the Grid group box, make sure the Snap to Guides and 
Snap to Grid check boxes are checked. 

��If the Snap to Guides and Snap to Grid check boxes are 
already checked, it means the commands are already turned 
on. 
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3. In the Grid Size spin box, make sure 0.10 is selected. 

4. Click on OK. 

When you draw or resize a frame with Snap to Guides and 
Snap to Grid turned on, the horizontal and vertical edges of the 
frames are drawn to the column guides and grid, ensuring that 
accurate and consistent frames are created. 

Drawing frames 
To draw your first frame, follow the steps below: 

1. Make sure the top of the page is visible. 

��Use the scroll bar at the right-hand side of the desktop to 
scroll up or down. 

2. From the Toolbox, select the Text tool. The mouse pointer 
now has a box when you move it over the page or 
pasteboard. 

3. Position the frame cursor in the top left-hand corner of the 
right column guide. 

 

4. Press and hold down the left mouse button. The mouse 
pointer changes to a crosshair. 

5. Drag the frame cursor diagonally down and to the right, so 
that it covers all the right column guide down to just above 
the top of the RE: frame. 

6. Release the mouse button. A frame is drawn on the page 
with eight handles around it, indicating it is selected. The 
text cursor appears inside, ready for you to enter text. 
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7. Make sure CAPS LOCK is selected on your keyboard. 

8. Type MEMO. The text appears in the frame. 

You now need to draw a frame alongside the TO: frame. 

1. From the Toolbox, select the Box tool. 

2. Position the frame cursor at the top right-hand corner of the 
TO: frame, inside the left column guide. 

 

3. Press and hold down the left mouse button. The mouse 
pointer changes to a crosshair. 

4. Drag the frame cursor diagonally down and to the right 
until the frame is the same height as the TO: frame and 
reaches to the right-hand edge of the left column guide. 

5. Release the mouse button. A frame is drawn next to the TO: 
frame with eight handles around it, indicating it is selected. 

 

In the next stage of this tutorial you will make two copies of this 
frame. 

Copying and pasting frames 
To copy and paste the selected frame, follow the steps below: 

1. Make sure the second frame you drew is still selected. 

2. In the General Tools, click on the Copy tool to make a copy 
of the frame. 
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3. In the General Tools, click on the Paste tool. A copy of the 
frame is pasted on top of, and slightly below and to the right 
of, the original. 

4. Click on the Paste tool once more. The two copies are 
staggered on top of the original frame with the top frame 
selected. 

You are now going to drag the frames to their new positions. 

Dragging frames 
To move the frames you have copied, follow the steps below: 

1. From the Toolbox, select the Pointer tool. 

2. Position the mouse pointer over the selected frame. The 
mouse pointer changes to a four-headed arrow. 

3. Press and hold down the left mouse button. 

4. Drag the frame down so it is below the original frame and 
level with the CC: frame, as shown below: 

 

5. Release the mouse button. The selected frame appears in the 
new position. 

6. Select the other pasted frame on top of the original. The 
mouse pointer changes to a four-headed arrow. 

7. Drag this pasted frame so it is below the frame you have just 
moved and level with the FROM: frame, as shown below: 
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��Don’t worry if you can’t get the pasted frames exactly level 
with the existing frames; just position them as accurately as 
possible. 

8. Click away from the page to make sure nothing is selected. 

The top of your document should now look like the picture 
below: 

 

Resizing frames 
You have decided the RE: frame is too big and you would like 
to increase the space available for the actual memo. 

To resize the RE: frame, follow the steps below: 

1. Click on the View Size control above the colour bar at the 
bottom of the desktop. A popup menu appears. 

2. From the popup menu, select 75%. The page is displayed at 
75% view size, making all of the RE: frame visible. 

3. Select the RE: frame. 

4. Position the mouse pointer over the middle handle on the 
bottom of the frame. The mouse pointer changes to a 
vertical two-headed arrow. 

5. Press and hold down the left mouse button. 

6. Drag the arrow up until the frame is around 2.5 cm high. 

��The exact measurements of the frame are shown at the right-
hand end of the information line. 

7. Release the mouse button. The frame is now resized as 
shown in the picture overleaf: 
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Formatting text 
You are now going to format the text you typed. 

1. Double-click on MEMO to select it. 

2. From the Font drop-down list box in the Text Tools, select 
Arial. The text changes to the selected font. 

3. From the Point Size drop-down list box in the Text Tools, 
select 72. The size of the text increases. 

4. In the Text Tools, click on the Underline tool. The text is 
now underlined. 

5. In the Paragraph Tools, click on the Centred tool. The text 
is now centred between the vertical sides of the frame. 

6. In the colour bar at the bottom of the desktop, click on 
100% Blue. The text changes colour. 

��If you cannot see the colour you need, use the left and right 
arrows at each end of the colour bar to scroll along the 
selection. 

��When you move the mouse pointer over a colour, its name 
appears in the information line. 

7. Click away from the page to make sure nothing is selected. 
The changes you have made to the text are now fully visible 
and the top of your document should now look like the 
picture below: 
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For a better view of the finished memo, you are going to hide 
the frames and guides, and change the view size. Follow the 
steps below: 

1. From the View menu, select Scale. A submenu appears. 

2. From the submenu select Fit Page. The whole page is now 
visible in the work area. 

3. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

4. Click on the View tab. 

5. In the Graphic Markers group box, clear the Guides and 
Frame Outlines check boxes. 

6. Click on OK. This gives you a better idea of what the 
finished document would look like if it were printed out. 

 

This tutorial has explained how to work with frames and text. 
You can now go on to create similar documents of your own, 
using the skills you have learnt from this tutorial. 

To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Making a poster for the show 

The Publicity Officer wants to make a poster advertising the 
show. 

This tutorial explains about frames and their properties and 
how you can use them to make your documents look more 
stylish and professional. You will learn how to: 

��add colour to a frame 

��add a border 

��draw a round frame 

��size and align frames 

��import a picture. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 2 – making a poster 
for the show.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 2 – making a poster for the show. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 



42: Adding colour to frames 

6: Making a poster for the show 

4. In the extended General Tools, click on the Fit Page tool. 
The whole page is now visible in the work area. 

��To extend the General Tools, click on the right arrow at the 
right-hand side of the toolbar. 

You will notice that there are already some frames drawn with 
text and a border. You will now go on to add the finishing 
touches to the poster. 

Adding colour to frames 
You are now going to add some colour to the large frame 
covering the page. To add a graduated fill style: 

1. Select the large frame covering the page. 

��This frame is locked and so the frame cursor appears similar 
to a No Entry sign and the frame handles have a cross 
through them. 

2. From the Frame menu, select Properties. The Frame 
Properties dialog box appears. 

3. Click on the Background tab. 

4. In the Style group box, click on the second fill style from 
the left on the bottom row. 

 

��Any changes you make when inside this dialog box, take 
effect immediately. 

5. In the Attributes group box, from the top drop-down 
colour palette, select Dark Yellow. 
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��When you move the mouse pointer over a colour, the colour 
name appears in the information line. 

6. Drag the tint slider to the left until it displays a 25% tint. 

��Use the left and right arrow keys on your keyboard to move 
the slider by increments of 1%. 

7. From the bottom drop-down colour palette, select Dark 
Yellow. 

Adding a border 
You are now going to add a border to the frame to which you 
have just added colour. 

1. On the Frame Properties dialog box, click on the Border 
Styles tab. 

2. In the Style group box, click on the Decorative radio 
button. 

3. From the drop-down list box, select Historic. 

4. From the preview box, select columns. 

��Use the scroll bar at the bottom of the preview box to view 
the range of borders available. 

5. Check the Colour Override check box. 

6. In the drop-down colour palette, make sure Black is selected. 

7. Drag the tint slider to the left until it displays a 50% tint. 

8. Click on the Close button in the top right-hand corner of 
the dialog box. 
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In the previous tutorial you learnt how to draw rectangular 
frames. In the next section you will learn how to draw a round 
frame. 

Drawing a round frame 
1. From the extended Toolbox, select the Ellipse tool. The 

mouse pointer now has a circle when you move it over the 
page or pasteboard. 

��To extend the Toolbox, click on the down arrow in the 
bottom right-hand corner of the Toolbox. 

2. Position the frame cursor just below the bottom left-hand 
corner of the dark green frame. 

3. Press and hold down the left mouse button. The frame 
cursor changes to a crosshair. 

4. Drag the crosshair down and to the right, until it is 
immediately above the top right-hand corner of the bottom 
frame. 

5. Release the mouse button. A round frame with eight handles 
is drawn roughly in the middle of the page. Don’t worry 
about its exact size or position, you will change these in the 
next few sections. 

��Publisher ‘remembers’ the properties selected for the last 
frame and applies them to new frames created. If you want 
to clear a frame, click on the Clear Colour button at the far 
left-hand end of the colour bar. 
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Sizing frames 
1. Make sure the round frame is still selected. When the frame 

handles around the frame are visible, the frame is selected. 

2. From the Frame menu, select Properties. The Frame 
Properties dialog box appears. 

3. Click on the Size and Position tab. 

4. In the Size and Position group box, in the Width spin box, 
type 15. 

5. In the Height spin box, type 15. 

6. Click on the Close button in the top right-hand corner of 
the dialog box. 

Aligning frames 
To precisely position the frame you have drawn, you can align it 
with another frame, or to the page. To align the round frame to 
the page, follow the steps below: 

1. Make sure the round frame is still selected. 

2. Hold down CTRL and select the frame with the ‘columns’ 
border. 

3. Release CTRL. 

4. From the Frame menu, select Align. The Align Frames 
dialog box appears. 

5. In the Alignment group box, under Align these frames 
with, make sure the Page is selected. 

6. From the Horizontal drop-down list box, select Centre. 

7. From the Vertical drop-down list box, select Centre. 

��Any changes you make when inside this dialog box, are 
shown in the preview area. 

8. Click on OK. The round frame is now positioned directly in 
the centre of the large bordered frame. 

9. Click away from the page to deselect all frames. 
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Your page should now look like the one below: 

 

Nudging frames 
You will notice that the round frame you’ve drawn is 
overlapping text in the rectangular frame towards the top of the 
page. You are now going to bring the rectangular frame forward 
so it is in front of the round frame. To bring the frame forward, 
follow the steps below: 

1. Select the rectangular frame at the top of the page. 

2. From the Frame menu, select Bring to Front. The 
rectangular frame is brought to the front of the page. 

Importing a picture 
Pictures and graphics play an important part in document 
design. They help to break up long pieces of text, provide focal 
points of interest for the reader and help to convey important 
information. To add a picture to your poster: 

1. Select the round frame. 

2. From the Edit menu, select Insert. The Insert submenu 
appears. 

3. From the Insert submenu, select Picture. The Import 
Picture dialog box appears. 

4. Double-click on the PROGRAM FILES folder, then the 
GREENSTREET folder, then the PUBLISHER 4 folder 
and finally the TUTORIALS folder. 

5. Select Poster.jpg. 
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6. Click on Open. The picture is now imported into the 
selected frame. 

Click away from the page to make sure nothing is selected. Your 
finished poster should look like the picture below: 

 

To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Designing a newsletter 

The President wants to design a newsletter, so all the 
members of the society can be kept informed of past and 
future events. 

This tutorial shows how to add the finishing touches to a 
document. It teaches you how to: 

��edit text 

��flow text into frames 

��insert tabs 

��insert and edit a design snippet 

��add page numbers 

��print your document as a booklet. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 3 – designing a 
newsletter.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 3 – designing a newsletter. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 
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4. In the extended General Tools, click on the Fit Page tool. 
The first page is now displayed in the centre of the work 
area. 

��To extend the General Tools, click on the right arrow at the 
right-hand side of the toolbar. 

Changing the font size 
1. Right-click on the main article text. The text shortcut menu 

appears. 

2. From the text shortcut menu, select Select all text. All the 
text in the frame is now selected. 

3. In the Text Tools, select 11 from the Point Size drop-down 
list box. The text is now larger and no longer fits the frame. 

Flowing text into frames 
If you import text into a frame that is too small, you can select 
or draw another frame in which to flow the remainder of the 
text. Flowing text is also useful in cases such as this one, where 
you have changed the point size of a piece of text and it no 
longer fits its frame. 

1. Make sure the frame with the main article text is still 
selected. 

2. Position the mouse pointer over the Story flow tool at the 
bottom of the frame. The mouse pointer changes to the 
story flow cursor. 

3. Click on the Story flow tool. The text is no longer selected. 

4. Position the story flow cursor over the frame immediately to 
the right. 

5. Click the mouse button. The text flows into the frame. 
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Using tabs 
Tabs are very useful for lining up text accurately. You can also 
apply leaders, that lead your eyes across the page to the tab 
position. 

Positioning a tab 
1. Right-click on the text in the frame beneath the main title 

frame. The text shortcut menu appears. 

 

2. Select Select all text. All the text in the frame is now 
selected. 

3. On the tab bar in the top ruler, position the mouse pointer 
over the number 16. 

 

4. Click the left mouse button. A tab stop appears. 

Editing a tab stop 
1. Right-click on the tab stop. The tab stop shortcut menu 

appears. 

2. Select Properties. The Tab Stop dialog box appears. 
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3. From the Type drop-down list box, make sure Left is 
selected. 

4. In the Tab Position spin box, make sure 16 is displayed. 

5. In the Leader Character text box, type a full stop (.). 

6. In the Leader Spacing text box, type 3. 

7. Click on OK. Your tab stop is now set. 

Inserting a tab 
1. From the View menu, select Scale. The Scale submenu 

appears. 

2. From the submenu, select Fit Window. The width of the 
page now fits the width of the work area. 

3. Position the mouse pointer at the end of the first line of text. 

 

4. Click the mouse button. The text insertion point appears at 
the end of the first line of text. 

5. On your keyboard, press TAB. A row of dots appears at the 
end of the line of text. 

6. Type 2. 

7. Repeat steps 3-6 with the second and third lines of text, 
inserting the numbers 3 and 4 respectively. Your frame of 
text should look like the picture below: 
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Inserting a design snippet 
If you find you constantly use the same combination of frames 
in your documents, you can save them as a design snippet. 
Instead of recreating the frame combination in another 
Publisher document, you just insert the design snippet, saving 
both time and effort and ensuring accuracy. 

1. From the File menu, select Insert Design Snippet. The 
Insert Design Snippet dialog box appears. 

2. Double-click on the Bubbles folder. 

3. Double-click on the design snippet with four white bubbles. 
After a few moments the design snippet appears on the page. 
Don’t worry about its position, you will change that next. 

4. Drag the design snippet, so that the largest bubble is 
covering up part of the first paragraph of main article text, as 
shown below: 

 

��When you drag an object or piece of text onto the edge of 
the work area, the screen scrolls with it. 

Editing a design snippet 
1. Right-click on the text in the largest bubble in the design 

snippet. The text shortcut menu appears. 

2. Select Select all text. All the text in the design snippet is 
now selected. 

3. Make sure CAPS LOCK is selected on your keyboard. 
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4. Type TO BE OR NOT TO BE? Your text appears in the 
frame, overwriting the text already there. Not all the text is 
visible because the currently selected font is too large for the 
bubble. 

5. Select all the text you have just typed. 

6. From the Point Size drop-down list box in the Text Tools, 
select 14. The text is now fully visible. 

You are now going to repel the main article text around the 
large bubble in the design snippet. This means that text will no 
longer be hidden beneath the shape, but instead will be 
positioned around the shape, or ‘repelled’ by it. 

1. Move the mouse pointer over the frame with the selected 
text until it turns into a four-headed arrow. 

2. Click the mouse button. The frame remains selected, but the 
text is deselected. 

3. Press the TAB key on your keyboard. The largest frame on 
the page is selected. 

��The TAB key can be used to cycle through frames. 

4. Keep pressing the TAB key until the design snippet is 
reselected as a whole. The largest bubble is also selected. 

5. From the Frame menu, select Properties. The Frame 
Properties dialog box appears. 

6. Make sure the Shape tab is selected. 

7. In the Repel group box, select Frame Repels Text. 

��Any changes you make when inside this dialog box, take 
effect immediately. 

8. In the Vertical Padding spin box type 0.3. 

9. In the Horizontal Padding spin box type 0.3. 
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10. Click on the Close button in the top right-hand corner of 
the dialog box. 

Your picture should now look like the one below: 

 

Page numbering 
You are now going to add page numbers to the newsletter. 
Follow the steps below: 

1. From the Page menu, select Page Numbers. The Page 
dialog box appears with the Page Numbers tab selected. 

2. Check the Insert Page Numbers check box. 

3. From the Position drop-down list box, make sure Bottom 
of Page (in Footer) is selected. 

4. From the Alignment drop-down list box, make sure Centre 
is selected. 

5. In the Style group box, click on the third style of page 
numbers: I II III. 

6. Click on OK. The page number appears in the centre of the 
footer on each page. The view changes to display the page 
number of the current window. 
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Booklet printing 
If you want to turn your finished document into a booklet, you 
need to select Booklet Printing when printing it out. It 
automatically arranges the pages to print in such an order, that 
when you fold them into a booklet, the pages are in their 
original order. The pages automatically resize to fit into half the 
printed page. There are on-screen prompts to tell you when to 
turn the paper over. 

1. From the File menu, select Print. The Print dialog box 
appears. 

2. Click on the Paper tab. 

3. From the Paper Mapping list box, select Booklet printing. 

4. In the Paper Sides group box, make sure the Pause 
Between Sides check box is checked. 

5. Click on Print. 

6. Follow the on-screen prompts. Your newsletter will now be 
printed in booklet form. 

You have made all the necessary changes to the newsletter and 
can now go on to create a newsletter for yourself. 

To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Editing a programme 

The Programme Editor is working on pages of the 
programme for the show: the President has written a letter 
for inclusion in the programme and there are some adverts 
that need to be aligned. 

You will learn how to: 

��import text 

��format text 

��set user definable guides. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 4 – editing a 
programme.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 4 – editing a programme. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 
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Importing text 
1. Position the mouse pointer in the top left-hand corner of the 

empty frame on page 4. The mouse pointer changes to an I-
beam. 

2. Click the left mouse button. The frame is selected with the 
text cursor inside, ready for you to import text. 

3. From the File menu, select Import Text File. The Import 
Text dialog box appears. 

4. In the Look In drop-down list box, select the drive you 
installed Publisher on to. This would normally be C. 

5. From the Files of type drop-down list box, select Plain 
text(.txt). 

6. Double-click on the PROGRAM FILES folder, then the 
GREENSTREET folder, then the PUBLISHE 4 folder and 
finally the TUTORIALS folder. 

7. Select Letter.txt. 

8. Click on Open. The text is imported into the frame. 

You are now going to format the imported text. 

Editing a paragraph style 
You are now going to change the font, point size and colour of 
the text. To do this, follow the steps below: 

1. In the Paragraph Tools, click on the Edit Paragraph Style 
tool. The Edit Paragraph Style ‘normal’ dialog box appears 
with the Font tab selected. 

2. From the Font drop-down list box, select Arial. 

3. From the Point Size drop-down list box, select 14. 

4. From the Colour drop-down palette, select Dark Blue. 

��When you move the mouse pointer over a colour, its name 
appears in the information line. 

5. Click on OK. The dialog box closes and the text appears as 
you have specified. 
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Setting user definable guides 
You are now going to create a set of user definable guides which 
you will use to align the adverts on page 5. 

User definable guides (user guides) allow greater flexibility when 
aligning frames on the page. Column guides are more limited in 
that they only allow you to align frames to predefined positions. 

1. Click on page 5. The frame containing the imported text is 
deselected and page 5 is now active. 

��The sections of the rulers not relating to a selected page are 
greyed out to show which page is active. 

2. Move the mouse pointer over the horizontal ruler directly 
above page 5. The mouse pointer turns into a user guide 
position indicator with a vertical bar, indicating that a 
vertical user guide is to be created. 

3. Press and hold down the mouse button. The indicator turns 
into a vertical line with two horizontal arrows. 

4. Move the indicator so that it is roughly 1 ½ cm from the 
left-hand edge of page 5. A line appears down the page, 
indicating where the user guide will appear. 

��The exact position of the user guide is shown at the right-
hand end of the information line. 
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��If you try to position the user guide outside the page, the 
indicator changes into a cursor similar to a No Entry sign, 
indicating that this is not possible. 

5. Release the mouse button. The user guide appears on the 
page, marked by a grey dotted line and two grey handles. 

 

6. Now create three more user guides, 7cm and 8cm from the 
left-hand edge of page 5 and another approximately 1 ½ cm 
from the right-hand edge of the page. 

The middle two user guides now need to be positioned more 
precisely. 

1. Right-click on the handle at the top of the middle-left user 
guide. The user definable guide shortcut menu appears. 

2. From the shortcut menu, select User Guide Properties. 
The User Guide Properties dialog box appears. 

3. In the Position group box, type 6.72. 

4. Click on OK. The user guide is repositioned. 

5. Now repeat steps 1 to 4 for the middle-right user guide, 
setting its position to 8.07. 

You have now set four vertical user guides. The next step is to 
set horizontal user guides. 
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1. Position the mouse pointer over the vertical ruler. The 
mouse pointer turns into a user guide position indicator 
with a horizontal bar, indicating that a horizontal user guide 
is to be created. 

2. Press and hold down the mouse button. The indicator turns 
into a horizontal line with two vertical arrows. 

3. Move the indicator so that it is approximately 1 ½ cm from 
the top of the page. 

4. Release the mouse button. The user guide appears on page 
5. 

 

5. Repeating steps 1 to 4, create three more user guides, 10 cm 
from the top of the page, 11 cm from the top of the page 
and 1 ½ cm from the bottom of the page. 

Now you are going to change the colour of the user guides to 
make them stand out from the column guides. This will make 
moving the frames easier. 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. Click on the View tab. 

3. From the list box in the Colours group box, select User 
guides colour. 

4. From the drop-down palette, select Red. 

5. Click on OK. The dialog box closes and the user guides are 
now red. 
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Your page should now look like the one below: 

 

Aligning the frames to the user guides 
To align the adverts to the user guides, follow the steps below: 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. In the Grid group box, check the Snap to Guides check 
box. 

3. Click on OK. 

4. Click on the frame containing the guitar to select it. 

5. Move the frame so the top left-hand corner fits exactly into 
the intersection of the user guides at the top left of the page. 
Don’t worry that some of the frames overlap, you will 
change this next. 

��The frame will snap to the user guides when you move the 
frame near them, helping you to position the frame 
precisely. 

6. Now move the other two frames on the page in the same 
way, so your page looks like the one overleaf: 
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For a better view of the finished pages, you are going to hide the 
frames and guides. To hide the frames and guides, follow the 
steps below: 

1. From the Options menu, select Preferences. The 
Preferences dialog box appears. 

2. Click on the View tab. 

3. In the Graphic Markers group box, clear the Guides and 
Frame Outlines check boxes. 

4. Click on OK. The guides and frame outlines are now 
hidden. 

 

This tutorial has explained how to import text and create user 
definable guides to control the layout of frames on your page. 
These are highly useful techniques, which can be found behind 
many successful desktop published documents. 
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To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Designing a flier 

As part of her advertising campaign for the show, the 
Publicity Officer has designed a flier to whet the public’s 
appetite. 

This tutorial describes how to turn an ordinary document 
into a professional-looking flier. It covers fades and also 
other aspects of editing pictures. It also gives you an 
introduction to PowerText. You will learn how to: 

��create PowerText 

��add a background texture 

��rotate frames 

��edit a picture 

��group frames. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 5 – designing a 
flier.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 5 – designing a flier. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 
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4. From the View menu, select Scale. The Scale submenu 
appears. 

5. From the submenu select Fit Page. The whole page is now 
visible in the work area. 

 

You will notice some pictures are partly on the pasteboard as 
well as on the page. These frames have a shaded background. 
The pasteboard is a useful place to put pictures and other 
objects before you decide where to position them on the page. 

Creating PowerText 
The first step is to create a title for the flier using PowerText. 

1. Select the frame with two grey borders at the top of the 
page. 

2. From the Toolbox, select the PowerText tool. The 
PowerText Gallery appears. 

3. Click on the Home folder button to make sure the default 
folder is selected. 

4. Click on the 3D folder and select 3d03.ptx from the 
preview area. 

5. Click on New. PowerText is launched and the 3D text layer 
appears in the PowerText preview window, ready for you to 
begin work. 

Entering text 
1. In the text box, highlight the existing text. 

2. Make sure CAPS LOCK is selected on your keyboard. 
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3. Type MACBETH. 

��Any changes you make in PowerText are displayed in the 
preview window. 

Changing the font 
1. Make sure the Font tab is selected. 

2. From the Font list box, select Goudy Old Style. 

Choosing the letter spacing 
1. Click on the Spacing tab. 

2. In the Letter Spacing group box, click on the Tight button. 

Changing the text effect 
1. Click on the Effect tab. 

2. From the Choose an effect box, select the effect in the top 
left-hand corner 

Changing the text colour 
1. Click on the 3D Lighting tab. 

2. In the Text Colour group box, drag the Brightness slider to 
the right until it is approximately halfway between Dim and 
Bright. 

3. From the Colour drop-down palette, select Dark Blue. 

4. Drag the tint slider to the left until it displays a 50% tint. 

 

5. In the Spotlight group box, drag the Brightness slider to 
the left until it is approximately halfway between Dim and 
Bright. 

6. From the Colour drop-down palette, select Blue. 

7. Drag the tint slider to the left until it displays a 25% tint. 
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8. In the Spotlight group box, click on the Straight On tool, 
next to the Direction arcball. 

Changing the orientation 
1. Click on the 3D Orientation tab. 

2. In the Perspective group box, drag the slider to the left, 
until your PowerText effect looks similar to the example 
below: 

 

3. Click on the Close button in the top right-hand corner of 
the PowerText title bar. You return to your document and 
the PowerText is placed in the selected frame. 

 

Adding a background texture 
You are going to add colour to the circle in the bottom right 
corner of the page, using a background texture. Follow the steps 
below: 

1. Select the circle at the bottom right-hand corner of the page. 

2. From the Frame menu, select Properties. The Frame 
Properties dialog box appears. 

3. Click on the Background tab. 
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4. From the Style box, select the tenth style from the left on 
the bottom row. The texture appears in the selected frame. 

��Use the scroll bar at the bottom of the preview box to view 
the range of backgrounds available. 

5. In the Attributes group box, select Mono from the drop-
down list box. The drop-down colour palette is now active. 

6. From the drop-down colour palette, select Cornflower Blue. 
The texture changes colour to Cornflower Blue. 

��When you move the mouse pointer over a colour, the colour 
name appears in the information line. 

7. Drag the tint slider to the left until it displays a 50% tint. 

8. Click on the Close button in the top right-hand corner of 
the dialog box. 

Rotating a frame 
1. Make sure the round frame is still selected. 

2. Position the mouse pointer over the rotate handle, on the 
top right-hand corner of the frame. The mouse pointer 
changes to a circular arrow. 

3. Press and hold down CTRL on your keyboard. 

4. Press and hold down the left mouse button. 

5. Drag the rotate handle in a clockwise direction, so that the 
text is at an angle of 45 degrees. A pair of arrows at right-
angles to each other appear on the shape, to help you 
calculate the angle. 

6. Release CTRL. 

7. Release the mouse button. The frame is now rotated, and 
should look like the picture below: 
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Editing pictures 
Even simple pictures can be made to look professional with 
Publisher’s picture editing facilities. 

In the next two sections you will make changes to the photo in 
the centre of the page. 

Fade 
1. Select the photo of the skull. 

2. From the Frame menu, select Properties. The Frame 
Properties dialog box appears. 

3. Click on the Fade tab. 

4. In the Fade Type group box, select the fade type in the 
middle of the top row. 

5. Make sure the Angle arrow points straight down. 

6. On the Fade chart, drag the top-left-hand marker one 
square to the right. The chart should look like the one 
below. 
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Picture colour 
1. Make sure the photo of the skull is still selected. 

2. On the Frame Properties dialog box, click on the Picture 
Colour tab. 

3. In the Colour group box, select Custom from the drop-
down list box. 

4. Check the Midtone check box. 

5. From the Midtone drop-down colour palette, select Red. 

6. From the Highlight drop-down colour palette, select Red. 

7. In the Balance group box, drag the Brightness slider 
approximately one centimetre to the left, towards Min. 

8. Drag the Contrast slider all the way towards Max. 

9. Drag the Saturation slider all the way towards Max. 

10. Click on the Close button in the top right-hand corner of 
the dialog box. 

Grouping frames 
When frames are grouped together, they act as one object. This 
can be useful if you want to move more than one frame at a 
time. 

1. Select the candle. 

2. Drag-and-drop the candle on top of, and slightly to the right 
of, the parchment, as shown below: 

 

3. Select the hat. 

4. Drag-and-drop the hat on top of, and slightly below, the 
parchment and candle, as shown below: 
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5. Making sure the hat is still selected, hold down CTRL on 
your keyboard. 

6. Select the parchment and the candle. 

7. Release CTRL. All three frames are now selected. 

8. From the Frame menu, select Group. The frame handles 
change to indicate the frames are now grouped. 

 

9. Drag-and-drop the grouped frames over the right side of the 
photo, as shown below. 

 

Click away from the page to deselect any frames. 

Your finished flier should look like the picture below: 
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This tutorial has explained how to use PowerText and how to 
work with background textures, fades and picture colour. The 
next tutorial explains how to use document restyling and mail 
merge. 

To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Producing a set of envelopes 

The Social Secretary wants to produce envelopes to send 
invitations out to members of the society, inviting them to 
the Director’s party. 

This tutorial gives you an introduction to document 
restyling. It will also describe how to use the mail merge 
function within your documents. You will learn how to: 

��restyle a document 

��use mail merge 

��print a mail merge document. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 6 – producing a set 
of envelopes.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 6 – producing a set of envelopes. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 
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Restyling a document 
Document restyling lets you change the layout of your open 
document. The restyling options available depend on the style 
chosen, but generally include layout, graphics, colour schemes 
and text styles. 

To restyle your document, follow the steps below: 

1. From the Page menu, select Document Restyler. The 
Document Restyling and Document Type dialog boxes 
appear. 

2. In the Document Type dialog box, select Envelope from 
the Document type drop-down list box. 

3. Clear the Display Headers and Footers check box. 

4. Click on OK. The Document Type dialog box closes. 

��Use the scroll bar at the side of the tab to view the range of 
layouts. 

5. Click on Plain Envelope. 

��Any changes you make in this dialog box are shown in the 
preview area, but the document is not restyled until you 
click on OK. 

6. Click on the Page Size tab. 

7. From the Page Size list box, select Envelope No 10. 

8. Click on the Text Style tab. 

9. From the list box, select Contemporary. A description of 
the fonts and paragraph attributes used in the style appears 
at the bottom of the tab and the style is previewed in the 
preview box. 

10. Drag the Scale slider to 120%. 

11. Click on OK. The dialog box closes and your document is 
restyled as you have specified. 
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Using mail merge 
This is an easy way of inserting varying information, such as 
names and addresses, into a document. You simply need to 
create a mailing list containing all the information and then 
insert a field, or fields, into your document corresponding to the 
information in your mailing list. When you print the document, 
you are asked to select which records from your mailing list you 
want to print. 

Creating a mailing list 
1. From the File menu, select Mail Merge AddressBook. 

AddressBook opens. 

2. Click on Add. A new record is created ready for you to enter 
your details. 

3. Use the TAB key on your keyboard to move the text 
insertion point to the Title text box. 

4. Type Mr. 

5. In the First Name text box, type John. 

6. In the Last Name text box, type Smith. 

7. In the first Address text box, type 2,Church Close. 

8. In the City text box, type Cambridge. 

9. In the Postcode text box, type CB6 4YK. 

10. Click on Add. The record is written to the AddressBook file 
and a new record is opened. 
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��Records are filed in alphabetical order. A plus sign (+) 
appears in the AddressBook tree next to the letter 
corresponding to the Last Name in the record. 

11. Enter a second and third set of details in exactly the same 
way for the following people. After the final record, do not 
click on Add. The last record you enter will be filed 
automatically when you save the file. 

 

Mr Paul Turner  Miss Kate Jones 
5,Acacia Avenue  10,Mill Street 
Cambridge   Cambridge 
CB4 2TH   CB1 5QZ 

 
12. From the AddressBook File menu, select Save As. The Save 

As dialog box appears. 

13. Select the drive and folder in which you want to save your 
AddressBook file. 

14. In the File name text box, type a name for your file. The 
filename is given the .MDB file extension. 

15. Click on Save. Your AddressBook file is saved to the 
location you selected. 

16. Click on the Close button. 

Inserting a field 
To insert these mail merge fields into your document, follow 
the steps below: 

1. Position the mouse pointer in the top left-hand corner of the 
empty rectangular frame. The mouse pointer changes to an 
I-beam. 

2. Click the left mouse button. The frame is selected with the 
text cursor inside, ready for you to insert a field. 

3. From the Text menu, select Insert. The Insert submenu 
appears. 
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4. From the Insert submenu, select Mail Merge Field. The 
Insert Mail Merge Field dialog box appears. 

5. From the Field to Insert list box, select Formatted Home 
Address. 

��If you cannot see the field, use the scroll bar to view more of 
the fields. 

6. Click on OK. The first record you entered into 
AddressBook appears in the frame. 

 

Printing your document 
1. From the File menu, select Print. The Print dialog box 

appears. 

��If you have the stationery available and your printer 
supports it, you may want to print the documents on actual 
envelopes. To do this, use the Print Setup dialog box. 

2. In the Mail Merge Selection group box, make sure All 
Records is selected. 

3. Click on Preview. You are shown exactly how the document 
will be printed out. 

4. Click on Print. Your documents will now be printed. A 
copy of each mail merge entry appears on a separate A4 sized 
page. 

��For more information on printing, refer to the section 
‘Printing your document’ in the chapter entitled ‘Saving and 
Printing’. 
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To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Creating a report 

The Treasurer needs to create a report to accompany his 
speech to the AGM. 

This tutorial shows you how to finish compiling a report. 
You will learn how to: 

��edit a spreadsheet 

��create a chart. 

Before you start 
To work through this tutorial, you need to create a new 
document based on the document Tutorial 7 – creating a 
report.dtp. 

1. Do one of the following: 

��If Publisher is not already running, open it. The Startup 
dialog box appears. 

Double-click on Run a tutorial. The Tutorials dialog box 
appears. 

��If Publisher is running, select Tutorials from the Help 
menu. The Tutorials dialog box appears. 

2. Select Tutorial 7 – creating a report. 

��If you cannot see the file, use the scroll bar to view more of 
the files. 

3. Click on Open. An untitled document appears in the work 
area ready for you to begin work. 

Editing a spreadsheet 
It is easy to manipulate data using a spreadsheet. Data is entered 
and formulas are applied to make calculations. The data is 
displayed clearly in a table. 

The needs of a Treasurer illustrate the most common uses of 
spreadsheeting – financial planning and budgeting. 
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Inserting a row 
The Treasurer has forgotten to take advertising costs into 
account and needs to insert a new row to enter this data. 

1. Click in the cell containing the text Miscellaneous, in the 
first column on the left. The column and row headings 
appear around the table and the cell is surrounded by a grey 
border, indicating it is selected. The text insertion point 
appears. 

 

2. From the Table menu, select Insert Rows. The Insert 
Rows dialog box appears. 

3. Make sure 1 is displayed in the Rows to insert spin box. 

4. In the Add New Rows group box, make sure Below current 
row is selected. 

5. Click on OK. A new row is inserted below the 
Miscellaneous cell and is given the number 8 as a row 
heading. 

 

Entering data 
The column and row headings provide a useful way of 
identifying cells through a grid reference system. For example, 
the cell containing the text Sponsorship may be referred to as 
C4, because it is in column C and row 4. 

1. Select cell A8. 

2. Type Advertising. 

3. Using the arrow keys on your keyboard, select cell B8. 
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4. Type 1097.32. 

5. Select cell B9. 

Your table should now look like the one below: 

 

Using formulas 
Now all the data has been entered into the table, you need to 
use simple formulas to calculate Total Costs, Total Revenues 
and Total Profits. 

1. Make sure cell B9 is still selected. 

2. Type =. A broken blue border is added to the cell, indicating 
that a formula is being entered. The Formula Tools appear. 

��If the formula you enter is part of a function, the 
spreadsheet displays the function in ‘ghost’ form beneath the 
text you are entering, as a guide. You do not have to copy 
the function. 

3. Type sum(b2:b8). 

4. Press ENTER on your keyboard. The contents of cells B2 
down to B8 are added (or summed) together and the result 
displayed in the cell. The Formula Tools disappear and cell 
B10 is now selected. 
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You are now going to calculate Total Revenues. A quicker way 
of applying the previous formula is to use Table Sum, which 
adds together all numerical values above its own cell, in the 
same column. 

1. Select cell D9. 

2. From the Table menu, select Insert Table Sum. The 
formula is applied and the result displayed in the cell. 

 

Next, you need to subtract Total Costs (cell B9) from Total 
Revenues (cell D9) to give Total Profits (cell D10). 

1. Select cell D10. 

2. Type =. A broken blue border is added to the cell, indicating 
that a formula is being entered. The Formula Tools appear. 

3. Click in cell D9. D9 appears in the formula. 

4. Type -. 

5. Click in cell B9. B9 appears in the formula. 

6. Press ENTER on your keyboard. The formula is applied and 
the result displayed in the cell. 
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Formatting a table 
You are now going to increase the width of column A, to 
increase the space available for entries in that column. 

1. Move the mouse pointer over the border between column 
heading A and column heading B. The mouse pointer turns 
into a two-headed arrow. 

2. Hold down the mouse button and drag the column border 
to the right, until it is directly underneath the left-hand edge 
of the letter A, in the title frame. 

 

3. Release the mouse button. The column is resized, with each 
entry now fitting on a single line. 
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To make the numbers reflect monetary values, you are going to 
format the cells containing numbers, so that the numbers are 
displayed to two decimal places. 

1. Select cell B2. 

2. Click and drag the I-beam down column B to cell B9. The 
grey border is extended down the column, indicating which 
cells are being selected. 

3. Release the mouse button. Cells B2 down to B9 are selected. 

4. Right-click on the cells. The Table shortcut menu appears. 

5. Select Cell Properties. The Table Cell Properties dialog 
box appears. 

6. Click on the Format tab. 

7. From the Style list box, select Number. 

8. Make sure 2 is displayed in the Decimal Places spin box. 
The numbers in the selected cells are now displayed to two 
decimal places. 

��Any changes you make when inside this dialog box, take 
effect immediately. 

9. Now repeat the above procedure with cells D2 to D10. 

��If you can’t see the changes being made to the selected cells, 
you can move the dialog box to one side by dragging its title 
bar. 

10. Click on the Close button in the top right-hand corner of 
the dialog box. 

To make the costs and revenues stand out, you are going to add 
colour to the numbers in columns B and D. 

1. Click on column heading B. Column B is selected. 

2. In the colour bar, click on 100% Red. The column title and 
the numbers change colour. 
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��When you move the mouse pointer over a colour, the colour 
name appears in the information line. 

��If you cannot see the colour you need, use the left and right 
arrows at each end of the colour bar to scroll along the 
selection. 

3. Now do the same with column D. 

Your completed table should now look like the one below: 

 

Creating a chart 
A chart is a good way of presenting data in a simple and visual 
way. 

In this section you are going to create a chart based on the Costs 
data in the table, to accompany the text immediately beneath 
the table. 

1. Select cells A2 down to A8 and B2 down to B8. 

2. From the Toolbox, select the Chart tool. The Create New 
Chart wizard appears. 

Chart Type 
1. Make sure the 3D Chart check box is checked. 

2. Click on Bar3d1 to select it. The selected chart appears in 
the preview area. 
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3. Click on Next. The Data Source page appears. 

Data Source 
1. In the Table Data group box, make sure the Series titles 

from data check box is cleared. 

��Any changes you make are shown in the preview area, but 
the chart is not created until you click on Finish. 

2. Click on Next. The Labels and Titles page appears. 

Labels and Titles 
1. In the Titles group box, type Costs in the Main text box. 

2. In the X Axis text box, type Expenditure Items. 

3. In the Y Axis text box, type Cost (£). 

4. Click on the Properties button for the Main Title. The 
Text Properties dialog box appears. 

5. In the Font and Style group box, select 24 from the Point 
Size drop-down list box. 

6. Click on OK. 

��Any changes you make are shown in the Preview box. 

7. Select the same point size for the X axis and Y axis. 

8. In the Axis and Data labels group box, make sure the Show 
Item Labels and Show Axis Values check boxes are 
checked. 

9. Click on the Properties button for the Item Labels. The 
Text Properties dialog box appears. 
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10. In the Font and Style group box, select Arial from the Font 
drop-down list box. 

11. From the Point Size drop-down list box, select 12. 

12. In the Text Angle group box, type 270. 

13. Click on OK. 

14. Click on the Properties button for the Axis Values. The 
Text Properties dialog box appears. 

15. In the Font and Style group box, from the Font drop-down 
list box, select Arial. 

16. From the Point Size drop-down list box, select 12. 

17. Click on OK. 

 

18. Click on Next. The Legend Box page appears. 

Legend Box 
1. Clear the Display Legend Box check box. 

2. Click on Next until the 3D Properties page appears. 

3D Properties 
1. In the View group box, make sure Rotated View is selected. 

2. In the Orientation group box, click on Reset. 

3. Drag the Perspective slider to the right until it is 
approximately halfway between Low and High. 

4. Drag the Depth slider to the left until it is approximately 
halfway between Thin and Thick. 
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��Clicking on the <<Prev button lets you return to earlier 
pages in the wizard. 

5. Click on Finish. The wizard closes and the chart appears on 
the page. Don’t worry about its size and position, you will 
change these next. 

Resizing and moving a chart 
You are now going to resize and move the chart, placing it 
immediately below the table in the empty space. Follow the 
steps below: 

1. In the extended General Tools, click on the Fit Page tool. 
The whole page is now visible in the work area. 

2. Move the mouse pointer over the frame containing the chart 
you have just created. The mouse pointer changes to a four-
headed arrow. 

3. Right-click. A shortcut menu appears. 

4. From the shortcut menu, select Frame Properties. The 
Frame Properties dialog box appears. 

5. Click on the Size and Position tab. 

6. In the Size and Position group box, type the following 
amounts in the appropriate boxes: 

��Left: 1.81 

��Top: 13.11 

��Width: 9.55 

��Any changes you make when inside this dialog box, take 
effect immediately. 
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7. Click on the Close button in the top right-hand corner of 
the dialog box. 

8. Click away from the page. Your page should look like the 
one below: 

 

Well done! You are now familiar with the essentials of editing a 
spreadsheet and creating a chart. 

To save your document, select Save As from the File menu and 
refer to the section ‘Saving your document’ in the chapter 
entitled ‘Saving and Printing’. 
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Saving and printing 

This chapter explains how to: 

��save your document as a .DTP file 

��print your document to your default printer 

��use a professional printer 

��print colour separations. 

Saving your document 
Saving your document makes a permanent record of it on disk. 
None of the changes you make are recorded on disk until the 
document is saved. If there is a system crash, or you close your 
document without saving the changes, any changes made since 
the last save are lost. 

To save the document in the active window, select Save from 
the File menu. If the document is untitled when you try to save 
it, Publisher prompts you to specify a name for the document 
by displaying the Save Document As dialog box. 

Sometimes you may want to save a document to a new file. For 
example, if you have made your document by modifying an old 
one, you may want to save it without overwriting the original on 
disk. The Save As command saves the document as a new file, 
prompting you for a new name. The original file is then closed. 

To save your document as a new file: 

1. From the File menu, select Save As. The Save Document 
As dialog box appears. 

2. Select the drive and folder in which you want to save your 
document. 

3. In the File name text box, type a name for your document. 
The filename is given the .DTP file extension. 

4. Click on Save. 

If you have typed a filename that already exists, a message 
appears asking if you want to overwrite the existing document 
or choose another filename. Select the appropriate option. 
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��A large document may take a long time to save. 

Printing your document 
You can choose to print your document to your default printer, 
or to print it as colour separations if you want your document to 
be professionally reproduced. 

Printing your document to your default printer 
If your default printer is a colour printer, you can print the 
colours available in Publisher. Depending on the type of printer 
you are using, you may be able to see more colours on the screen 
than your printer can print. 

If you are printing to a monochrome printer, the colours will be 
printed in black and shades of grey. Follow the steps below to 
print your current document to the default printer: 

1. In the General Tools at the top of the desktop, click on the 
Print tool. The Print dialog box appears. 

2. In the Printer group box, make sure your default printer is 
selected. 

3. To use a different printer, click on the Printer Setup button 
to display the Print Setup dialog box. In the Printer group 
box, select a different printer from the drop-down list box 
then click on OK. 

4. In the Copies group box, in the Number spin box, type the 
number of copies. 

5. In the Page Selection group box, specify if you want to 
print all of the pages in your document, the current page, or 
a range of pages. Specify a range of pages to be printed using 
the From and To spin boxes. 

6. Click on the Paper tab. 

7. In the Paper Mapping group box, specify how you want to 
position your page on the paper. 

8. Click on the Options tab. 

9. In the Print group box, check the check boxes of the items 
you want to print. 
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10. When you are satisfied with your choices, click on Print. 

The Printing box appears, indicating the progress of the print 
job. To abandon the printing job, click on Cancel. 

If your document fails to print, the cause is often a simple 
mechanical problem such as the printer being disconnected or 
the paper being jammed. Refer to the online Help for more 
information on solving printing difficulties. 

Before going ahead with printing, it is often useful to preview 
the document so you can see exactly how it will look on paper. 
The Preview option is available via the Print dialog box and 
General Tools and lets you easily go back and change any print 
options. This is particularly useful when you are printing colour 
separations. 

Commercial reproduction 
If you need a higher quality print, a large number of copies, 
thick or special paper, or better colour or black and white 
reproduction, you will need to produce professionally printed 
artwork. You will therefore need to use a commercial 
phototypesetter and printer. We will refer to the Service Bureau 
as the phototypesetter and the Printer as the commercial printer, 
although some bureaus provide both services. 

When choosing a bureau, you will need to contact one that uses 
PCs and has experience of producing output from other PC 
products. If in doubt, ask them if they can output PostScript 
files on a PC disk created in a Windows application. However, 
you may be able to use a printer that uses only MACs, by giving 
them a PS (PostScript) file. 

If your local printer is not familiar with your product, you may 
find it helpful to produce a simple trial document to find which 
method works best. 

Preparing your document for commercial reproduction 
Before you produce your document, you should decide on the 
quality of paper you want your document to be printed on, how 
many copies you need and how many colours you will be using. 
At this point, contact your printer who will be able to advise 
you on the best way of reproducing the document you have 
planned. 
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Colours and colour separations 

You can mix any colour using the Edit Colour and Add Colour 
dialog boxes and any one of the colour models (RGB, CMYK, 
or HLS).  

��Due to the nature of colour, you cannot rely on your PC 
monitor to match or judge colour. Do not use your screen 
colours as a guide to your printed colours. 

There are two ways of producing separations for a document to 
produce colour. 

Spot Colour - each colour in your document is printed as a 
unique single separation. This method is generally used when 
the document only uses 1, 2 or 3 colours, or when you need a 
specific colour e.g. a corporate company colour “red”. 

Process Colour - produces only four separations, Cyan, 
Magenta, Yellow and Black, which are referred to as “process” 
colours. Publisher will calculate what percentages of the four 
colours are needed to produce the colours in your document. 
This method is more appropriate when you are including colour 
photographs or using a large number of colours. 

In some circumstances you may need to combine spot and 
process colours in your document; your printer will be able to 
advise you if this is necessary. 

��Do not authorise a print run until you have seen a proof of 
your document and you are happy with the colours. Most 
commercial printers will produce one, but make sure you 
ask. Make sure you check the document carefully, as 
mistakes can be expensive. 
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Producing colour separations 
You have three methods you can use to produce your colour 
separated document: 

��print your colour separations directly from Publisher and use 
them as camera-ready art; 

��if you are including photographs, print your colour 
separations directly from Publisher and have your bureau 
scan and strip the photographs in; 

��save your document as a PostScript (.PS) file and give this to 
your printer on disk for them to print. 

Including photographs in your Publisher document 
Today it is easy to include high quality images in your 
document. You can load a photo from the PictureBrowser or 
have it scanned at a bureau. However, high quality photos in 
your document can cause the size of the file to become very 
large. 

If your document is a catalogue or brochure with a large 
number of images, you may find it easier to use low resolution 
images to position the images and then let your bureau strip-in 
the high resolution photos. With this process, all of the photos 
in your document are removed before the separations are 
produced, leaving just a thin box for positioning. The bureau 
then produces the separations for you and strips the pictures in 
place. This is a service that most bureaus can provide. 

What to ask the printer 
You will need to find out from the printer which printer driver 
you need to output to. Commercial printers have high quality 
printers such as Linotronics; you will have to select this as your 
output printer if you are going to print separations. If you do 
not have a match for a particular printer version (e.g., you have 
Linotronic 300 and not 350), you can contact the printer 
manufacturer to find out which equivalent driver will work or 
they might send you a new one. 

You should also check if you need to change the screen 
frequency and angles from those set by default in the program. 
You should not change these values unless directed to do so by 
your printer. 
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What to tell the printer 
Give the printer a proof of your document and mark this with 
stripping instructions and colour references. You should also 
produce a list of instructions with details of your job such as the 
number of colours and colours used, dpi, screen frequencies, 
photo references, number of copies and any other details. The 
clearer your instructions are, the better the results are likely to 
be. 

You should place the whole job in a folder for the printer. This 
should include: 

��your job instructions; 

��the disk(s) with the separations; 

��your desktop printer proof; 

��any hard copy of photos if they are to be stripped in. 

Printing colour separations 

To print colour separations, you must have a PostScript  
printer selected as the default printer. You do not need to have a 
PostScript printer, but the printers you have set up in Windows 
must include a PostScript printer. 

To add a PostScript printer to your Windows setup, refer to the 
Microsoft Windows User’s Guide or online Help. To print 
colour separations: 

1. In the General Tools at the top of the desktop, click on the 
Print tool. The Print dialog box appears. 

2. Make any selections you need in the Print dialog box. 

3. Click on the Separations tab. 

4. Check the Print Separations check box. The Separations 
tab becomes active. 

5. From the Type of Separations drop-down list box, select 
the type of separations you want to print. 

6. In the Separations to Print list box, select which colour 
separations you want to print by clicking on the colour 
name as necessary. The separations selected for printing are 
checked. 

 



Printing your document: 99 

Saving and printing: 12 

��Colours only appear in the Separations to Print list box if 
they have been saved as spot colours in the Edit Colours 
dialog box, or if they are one of the four process colours. 

7. Click on the Halftone Screen Settings button. The 
Halftone Screen Settings dialog box appears. Change your 
separation settings as directed by the printer. 

��Do not adjust these values unless directed to do so by your 
printer. 

8. Click on OK to return to the Separations tab on the Print 
dialog box. 

9. Click on Print to print the selected separations to the 
selected printer. 

Printing colour separations to disk 
Supplying your document on disk will allow the printing bureau 
to produce a better quality reproduction of your document than 
if you had supplied it to them on paper. To print your 
document to disk as colour separations: 

1. In the General Tools, click on the Print tool. The Print 
dialog box appears. 

2. On the General tab, in the Printer group box, check the 
Print To File check box. 

3. Make any other selections you need in the Print dialog box. 

4. Click on the Separations tab. 

5. Check the Print Separations check box. The Separations 
tab becomes active. 

6. From the Type of Separations drop-down list box, select 
the type of separations you want to print. 

7. In the Separations to Print list box, select which colour 
separations you want to print by clicking on the colour 
name as necessary. The separations selected for printing are 
checked. 
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��Colours only appear in the Separations to Print list box if 
they have been saved as spot colours in the Edit Colours 
dialog box, or if they are one of the four process colours. 

8. Click on the Halftone Screen Settings button. The 
Halftone Screen Settings dialog box appears. Change your 
separation settings as directed by the printer. 

��Do not adjust these values unless directed to do so by your 
printer. 

9. Click on OK to return to the Separation tab on the Print 
dialog box. 

10. If you want to create a separate file on disk for each colour 
separation, check the Output Individual Separation Files 
check box. 

11. Click on Print to print your selected separations to disk. 
The Filename for disk output dialog box appears. 

12. Select the drive and folder in which you want to print your 
file. 

13. In the File name text box, type a name for your file. 

14. Click on Save. 

If the file is very big, you can use a compression program such as 
PKZIP to reduce its size and save disk space. Check with your 
bureau to find out which utility they use. If the file is still too 
big, you may have to make each separation a separate file and 
then compress it. PKZIP and other utilities are capable of 
making files save over a number of disks if necessary. 

Once you have worked out a method both you and your service 
bureau/commercial printer are happy with, you will be amazed 
by the high quality reproductions you can obtain. 
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