
How do I start work?

You can start work in any of the following ways:
By running the PagePilot to create a logo
By creating a new picture from a template
By creating a new picture from a blank page
By opening an existing picture.

These options can all be reached from the New Picture Options dialog box. This dialog box appears when you 
start greenstreet Draw, and when you start a brand new picture.

If you have not used greenstreet Draw before, it is easiest to start work by either running the PagePilot or loading a 
template. These options give you pre-defined guidelines within which you can work; i.e. some of the work involved 
in laying out the picture has already been done for you.

Running the PagePilot for logos

Run the PagePilot to create a logo quickly and easily. After guiding you through some simple selections, the 
PagePilot will create the logo for you. You can make changes to your logo when the PagePilot has created it.

Loading a template

You can load a template on which to base your new picture. This option is useful if you want to use a pre-defined 
layout for commonly used pictures, such as certificates or invitations. Several templates are supplied with 
greenstreet Draw to get you started; you can add to them by designing your own when you are ready. If you use a 
particular template more frequently than any other, you may find it useful to make it the default template.

Starting from a blank page

Starting from a blank page gives you greater control over the layout of your picture than either templates or pilots, 
but it needs more initial planning. You can plan your layout and the size of your paper before you begin to draw, or 
you can change it afterwards in the Page Format dialog box.

Opening an existing picture

You can open an existing picture to continue working on it. There are several sample pictures supplied with 
greenstreet Draw. You can modify these for your own needs, or just look at them for ideas of what you can do in 
greenstreet Draw.
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How do I start to draw?

Pictures in greenstreet Draw are made up of individual components, such as layers, text and graphics. Before you 
start work, you decide on the page, paper size and overall layout of your picture, either by using a template or the 
PagePilot, or by designing your own page layout. (However, you can change your mind about the page layout later, 
and change it in the Page Format dialog box.)

greenstreet Draw is WYSIWYG; this means that you can see what your picture will look like before you print it out.

You can build up your picture using a variety of techniques. Most designs can be started from basic geometric 
shapes which you can reshape and manipulate: greenstreet Draw has tools for drawing all the basic shapes. For 
precision drawing, you can use the Pencil tool, which is like using an ordinary pencil for drawing on paper.

Objects

greenstreet Draw pictures can consist of up to five types of object:
Basic shapes: Boxes, rounded boxes, ellipses, arcs, pie slices, polygons and stars. Basic shapes are 

created with the Shape tools.
Paths: Consisting of straight or curved lines joined together at points. Paths are created with the Drawing 

tools.
Text objects: Created with the Text tool.
Images: These are bitmap pictures created with a painting package and imported into greenstreet Draw.
Groups: These are sets of objects that you have grouped together so that operations apply to them as if they 

were a single object.

Drawing a simple shape

To draw a shape, click on the tool for that shape, and then click on the picture window and drag the shape to the 
size you want.

For instance, to draw a rectangle, click on the Box tool. Then click on the picture, and drag the rectangle until it is 
the correct size.

To draw a line, select the Pencil tool, and then click and drag it on the picture. To draw a straight line, hold down 
Shift while you drag.

Creating more complex shapes

With greenstreet Draw, you can create complex shapes and manipulate them to get exactly the result you want. 
Most of the Drawing Tools are self-explanatory, but some allow you to perform advanced drawing techniques.

The Corner tool is for drawing straight lines with corners in them. The Curve tool is for drawing smoothly curved 
paths. The Connect tool is used for making smooth connections between corner and curve points. The Bezier tool 
is a combination of all three of these, and you use it to draw smoothly connecting straight lines and curves without 
having to change tools.

Using layers

greenstreet Draw allows you to build up your pictures in layers. A simple picture can be created on a single layer, 
but more complex pictures are easier to work with if you build them up over several layers. You could, for example, 
use one layer for all the background objects, and another layer for the foreground objects. Pictures such as 
technical drawing plans are easier to work with if they are created on several layers.

When you create a picture on several layers, you can work on one layer at a time. Working with individual layers 
helps you to focus on precise details without being distracted by the rest of the picture. If you try to create a 
complex picture on a single layer, you will probably encounter problems when moving objects to different positions, 
selecting objects for patterns and colours, and trying to see objects that are hidden by others.
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How do I colour my picture?

Adding colour to your drawing is simple with the colour bar.

greenstreet Draw shapes have a line style (the colour of the edge) and a fill style (the colour filling the shape). 
To change the colour of a shape's line style, select the shape and then click with the right mouse button on 

the colour you want in the colour bar.
To change the colour of a shape's fill style, select the shape and then click with the left mouse button on the 

colour you want in the colour bar.
To remove a line or fill style from a shape, select the shape and then click with the appropriate mouse button 

on the X button at the end of the colour bar.

Colour and colour separation

You can add colour to any aspect of your picture. You can use and modify the colours supplied in the standard 
colour palette, or start from scratch with no colours and mix your own. You can save colours with pictures and 
templates or within their own palette files.

If high quality colour reproduction is important to you, when you have created your colour picture, you can print it as 
colour separations for professional printing.
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What is everything on the desktop?

At first glance the greenstreet Draw desktop may appear busy, but once you know what the tools and buttons 
represent, you will soon be able to find your way around.

The area in which you create pictures is called the picture window.

Across the top of the window is the title bar, showing the title of the picture you are working on.

Across the bottom of the window is the information line, used for displaying messages, tips and other information.

Just above the information line is the colour bar, which shows the colours you can use in your picture.

Along the edges of the picture window are the rulers, to help you measure and position objects in your picture.

Down the left-hand side of the greenstreet Draw window (although you can put it wherever you like) is the toolbox. 
This contains the tools you need to add objects to your drawings.

To manipulate your drawing and perform numerous other functions, greenstreet Draw has five shortcut toolbars. 
These toolbars are designed to help you work more quickly, as you do not need to open a menu each time you want 
to perform a task.

To find out what a tool does, point the cursor at it. After a few moments a yellow ToolTip appears, displaying the 
name of the tool or button you are pointing at. The tool name will also appear in the information line along the 
bottom of the greenstreet Draw desktop.

To get information about any part of the desktop, click on the What's This? tool, and then click on the relevant part 
of the desktop.
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Can I customise the desktop?

Everyone has their own way of working, so the greenstreet Draw desktop can be changed and rearranged to suit 
your own preferences.

Moving the toolbox and toolbars

The toolbox and toolbars can be either 'docked' (attached to the edge of the picture window) or 'floating' (shown in a 
floating toolbox which can be positioned anywhere on the picture window itself).

To move the toolbox or a toolbar, click on it, hold down the mouse button and drag it to your preferred position. If 
you drag it to the edge of the desktop, the toolbar will dock there; if you leave it in the middle of the desktop, it will 
float.

You can also determine the positioning of the toolbox or a toolbar by clicking on it with the right mouse button and 
selecting a position from the shortcut menu that appears.

If you prefer to use the greenstreet Draw default arrangement of the toolbars, select Reset Toolbars from the 
Options menu (or from the shortcut menu that appears when you right-click on any of the toolbars). This moves the 
toolbars back to their default positions.

If you want to position the toolbars yourself, but would like each toolbar to be given a “weighting” so that, for 
instance, the more important ones are put above and to the left of others, select Auto Arrange Toolbars from the 
Options menu (or from the shortcut menu that appears when you right-click on any of the toolbars).

Changing the size of the toolbox and toolbars

Each toolbar can also be viewed in various sizes. To the right of each toolbar is a pair of buttons which you can use 
to change the size of the toolbar. Click on the right change toolbar size button to expand the toolbar, and click on 
the left one to compress it.

If you cannot see the tool you want on a toolbar, it could be that the toolbar is too small to display it. Expand the 
toolbar to display all of its tools.

Hiding and displaying the toolbox, toolbars and nudge control

To hide the toolbox, a toolbar, or the nudge control, select Show Controls from the View menu. If an item has a tick 
next to it, it will be displayed on the desktop. Click on an item to remove its tick, and click again to replace it.

Arranging picture windows

You can have more than one picture open at once. Having multiple pictures open allows you to cut, copy and paste 
objects between pictures with ease. You can also drag an object from one picture, and drop it into another.

You can also open more than one window on a picture, by selecting New Window from the Window menu. This 
lets you see different areas of the same picture at the same time.

When you open several picture windows at a time, some windows overlap or hide others. You can use the Cascade 
and Tile commands in the Window menu to rearrange all the windows so that some part of each window is visible.
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How do I create special effects?

One of the strengths of greenstreet Draw is the ease with which you can create eye-catching and professional-
looking special effects. In most cases, you simply select the object you want to manipulate, and then select the 
effect you want.

Blending

By blending objects, you can create three-dimensional effects, highlight effects, and effects of one object 
transforming into another. For example:

Transforming
greenstreet Draw offers four types of object transformation: Scaling, rotating, skewing and reflecting. For example:

You can transform objects quickly by using the Transform Tools, or you can obtain more accurate effects by using the 
various transform dialog boxes.
Combining paths
By combining paths, you can create a compound path from two or more closed paths. For example:

Joining text to a path
By joining text to a path, you can create the effect of text flowing around a circle, along a wavy line, or around any 
shape you have drawn. For example:

You can easily separate the text and the path if you later change your mind
Creating patterns
You can create patterns from groups of objects in your picture. greenstreet Draw creates the pattern by tiling the 
group of objects. The patterns you create can be used as fill styles to fill other objects. For example:
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What if I make a mistake?

If you are new to design and illustration, particularly on a computer, you may need to try something more than once 
before you get the desired effect. greenstreet Draw lets you undo commands so that you can try something 
different.

To undo the last command, select Undo from the Edit menu. You can undo up to the last fifty commands.

If you undo a command and then change your mind, you can redo it by selecting Redo from the Edit menu.

Shortcuts:
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Help and Hints

There are some additions to the standard Help system and its related functions, to help you find the information you 
want more quickly and more easily.

If you hold the pointer over a toolbar button for more than a few moments, a small flag appears under the button 
with a brief (one or two word) description of the button’s function. These flags are known as ToolTips. To turn 
ToolTips on and off, click on ToolTips in the Options menu.

Getting Started Hints appear whenever you select a tool from the toolbox. These hints give a basic introduction to 
each of the tools or sets of tools. Once you have read a Getting Started Hint, you can stop it appearing again by 
checking the Don't display this screen again check box on the hint itself. To turn all the Getting Started Hints on 
and off, click on Getting Started Hints in the Options menu.

greenstreet Draw is supplied with a PagePilot which helps you create logos. At the end of the PagePilot, there is a 
set of cue cards, which guide you through the basic steps of finalising the logo. To turn the cue cards on and off, 
click on Cue Cards in the Options menu.
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Menus: Information

Some menu commands may appear in grey. This indicates that they are not available at the moment, although they 
may become available once you have carried out another command. For example, the Paste command in the Edit 
menu is not available until you have used the Cut or Copy command and therefore have an object to paste.

Some menu commands are followed by ..., which indicates that clicking on that command will display a dialog box. 
Other menu commands are followed by an arrowhead, which indicates that clicking on that command will display a 
submenu.

Many of the commands can also be carried out using the keyboard. If a keyboard shortcut is available, it is listed 
beside the command in the menu. The ^ symbol represents Ctrl.
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Keyboard shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to using the 
mouse.

greenstreet Draw provides its own additional equivalents and shortcuts.
 Function key shortcuts
 Additional keyboard shortcuts
 Additional menu command shortcuts
 Text editing shortcuts



Function key shortcuts

Press To

F1 Start the Help facility

Shift F1 Display the Help pointer so that you can ask for help

F2 Save the picture in the active window

F3 Undo the last command

F4 Redo the last Undo command

F5 Repeat the last transformation

F6 Toggle the display of the picture in the active window between outline and preview format

F7 Display the picture in the active window at its actual size 

Shift F7 Display the picture in the active window in whole page view

F8 Enlarge the picture in the active window (to the next standard magnification)

Shift F8 Reduce the picture in the active window (to the next standard magnification)

F10 Pass control to the menu bar



Additional keyboard shortcuts

Press To

Enter Select the pointer tool

Space Deselect all points (leaves paths selected)

Esc Deselect all selected objects

Del Delete all selected objects

Backspace Delete all selected points on paths

 ¯ ¬ ® When no object is selected, scroll the active window: Up, down, left or right

If scroll lock is off and one or more objects is selected, nudge the object(s)

PgUp Scroll the active window up by a screen

PgDn Scroll the active window down by a screen

Ctrl PgUp Scroll the active window left by a screen

Ctrl PgDn Scroll the active window right by a screen

Tab Select the next object in the stacking order

Shift Tab Select the previous object in the stacking order



Additional menu command shortcuts

Press To

Alt A Select all the objects in the picture in the active window

Ctrl A Display the Align dialog box

Ctrl B Move the selected objects to the back of the picture

Ctrl C Copy the selected objects to the Clipboard without removing them from the picture

Ctrl F Move the selected objects to the front of the picture

Ctrl G Group the selected objects

Ctrl H Hide the selected objects

Ctrl I Display the Object Properties dialog box for the selected object

Ctrl J Join two end points, or join text to a path

Ctrl L Lock the selected objects

Ctrl M Combine the selected paths to create a compound path

Ctrl N Unlock the selected objects

Ctrl P Print the current drawing

Ctrl S Split a path at the selected points, or separate text from a path

Ctrl U Ungroup the selected group

Ctrl V Paste the contents of the Clipboard into the picture in the active window

Ctrl W Show all hidden objects

Ctrl X Cut the selected objects from the picture to the Clipboard

Ctrl Y Redo the last action

Ctrl Z Undo the last action



Text editing shortcuts

These shortcuts are available only when the text tool is selected and the text cursor is put within a text object.

Press To

Alt ¬ ® Rotate the text insertion point clockwise or anti-clockwise to enter text at an angle

Enter Insert a line break

Space Insert a space

Esc Deselect any text and return the text insertion point to an upright position if it has been rotated

Del Delete the text selection or the character to the right of the text insertion point

Backspace Delete the text selection or the character to the left of the text insertion point

¬ ® Move the text insertion point left or right one character, or when there is a text selection, move the 
text insertion point to the start or end of the selection and deselect the text

 ¯ Move the text insertion point up or down one line

Shift click Select the text between the position of the text insertion point and the position of the click



Toolbars: Information

There are five toolbars and a toolbox in greenstreet Draw.

Toolbox

General Tools

Object Tools

Text Tools

Transform Tools

Align Tools

If you click the right mouse button on a toolbar, a shortcut menu of options for configuring the toolbar and its 
position appears.

If you can not see all the tools in a toolbar, click on the right-pointing arrowhead to expand the toolbar. To 
collapse a toolbar, click on the left-pointing arrowhead.

If you point at a button and leave the pointer there for a couple of seconds, a ToolTip appears below the 
button, telling you the name of the button. You can turn ToolTips on and off in the Options menu.

If you point at a disabled button (i.e. one that is not currently available), a message appears in the 
information line explaining why the shortcut is disabled. If you click on a disabled button, this message appears in a 
message box on the desktop.

You can choose which tools to display by selecting Show Controls from the View menu, and making your 
choice from the submenu that appears. Tools that are displayed have a tick next to them; click to remove the tick, and 
click again to replace it.

If you want the Text Tools to replace the Object Tools when the Text tool is selected, select Switch Object 
And Text Tools from the Options menu. If this option is not selected, the Text and Object toolbars will both be 
shown.

Some of the toolbars can be docked at any edge of the desktop, or displayed in floating boxes. To move a 
toolbar, click on it, hold down the mouse button and drag it to your preferred position. If you drag it to the edge of the 
desktop, the toolbar will stay there; if you leave it in the middle of the desktop, it will float.

When you close greenstreet Draw, the position of the toolbars is remembered; when you next load 
greenstreet Draw they will be displayed in the same position.
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Toolbox

There are four groups of tools in the greenstreet Draw toolbox. The complete set of tools is listed below. Click on a 
tool to popup a description of its function.

Shape tools

Drawing tools

Transformation tools

Other tools

Note:

Although only six tools are displayed initially down the left-hand side of the desktop, you can click on the 



black arrow symbol to the right of some of the tools, to display more tools within that group.

You can also display the full selection of tools by expanding the toolbox. Click on the right Change Toolbar 
Size button to expand the toolbox.

The mouse pointer changes to a different shape depending on which tool is selected.
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General Tools

The following are available in the General Tools. Click on a button to popup a description of its function.

 

 

 

 

 

 

 

 

 

 

Note:

The full selection of tools is available only when the toolbar is fully expanded. Click on the right Change 
Toolbar Size button to expand the toolbar.
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Object Tools

The following are available in the Object Tools. Click on a button to popup a description of its function.

 

 

 

    Related Topics



Transform Tools

The following are available in the Transform Tools. Click on a button to popup a description of its function.

 

 

 

 

Note:

The full selection of tools is available only when the toolbar is fully expanded. Click on the right Change 
Toolbar Size button to expand the toolbar.
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Text Tools

The following are available in the Text Tools. Click on a button to popup a description of its function.

 

 

 

 

 

 

 

 

 

 

Note:

The full selection of tools is available only when the toolbar is fully expanded. Click on the right Change 
Toolbar Size button to expand the toolbar.

When you expand the Text toolbar to its largest size, the Increase Width and Decrease Width shortcuts become a 
Text Width editable field.

Similarly, the Raise Text and Lower Text shortcuts become a Raise/Lower Text editable field.

And the Kern Together and Kern Apart shortcuts become a Kern Text editable field.
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Align Tools

The following are available in the Align Tools. Click on a button to popup a description of its function.

 

 

 

 

 

Note:

The full selection of tools is available only when the toolbar is fully expanded. Click on the right Change 
Toolbar Size button to expand the toolbar.
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Nudge control

The nudge control lets you 'nudge' the selected object up and down, or left and right; you can use the cursor keys 
for the same effect. The nudge control can be hidden by selecting Nudge from the Show Controls submenu of the 
View menu.

Note:

The nudge control is disabled when you do not have anything selected in your drawing.
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Picture window

The greenstreet Draw picture window is your 'drawing board'. You can draw your pictures anywhere in the picture 
window, but only the objects in the page box will be printed out.

Note:

You can change the size of the picture window by dragging the sizing border.

You can make the picture window take up the full greenstreet Draw main window by clicking on the 
Maximise button.

You can have more than one picture window open at a time.
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Information line

The information line displays information about many aspects of the desktop and the picture on which you are 
currently working.

The information line changes depending upon what you are doing at the time and where on the desktop the 
mouse pointer is positioned.

You can turn the information line off by selecting Information Line from the submenu that appears when 
you select Show Controls from the View menu. This is a toggle command: If you click on it when the information line 
is displayed, it turns it off: If you click on it when the information line is hidden, it turns it on.

You can choose whether to display the information line on startup by setting your preferences.

The information displayed is listed below:

When the pointer is in the work area

The position of the mouse pointer.

The format of any selected objects, e.g. box, star, open or closed path, etc. and the number of points on the 
path. (Click on the object information to display the relevant object properties dialog box.)

The selected tool and hints on how to use it

The current active layer of your picture (only when the picture is multi-layer).

When the pointer is over the toolbox or toolbars

A prompt for how to reposition either the toolbox or the toolbars.

A prompt for how to use the tool at which you are pointing, or why the tool is currently disabled

When the pointer is over the colour bar

Prompts for how to use the colour bar.

The name of the colour at which you are pointing.

A prompt for how to use the x and + buttons at either end of the colour bar.

When a menu command is selected

A prompt for how to use the command that you have selected, or why the command is currently disabled.

During a dialog box

A prompt for how to display the help for that dialog box.

During a transformation

The skew or scale factors, or the angle of rotation or reflection, or the displacement of an object being 
moved.

When importing or exporting a graphic

The percentage of the import complete, or the path and filename of the exported file.
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Rulers

The rulers help you to size and position the objects you draw. They are displayed along the top, and down the left-
hand side of the picture window. As you move the mouse pointer, thin hairlines on the rulers indicate the pointer's 
current position.

You can turn the rulers on and off by selecting Rulers from the submenu that appears when you select 
Show Controls from the View menu. The command is checked when the rulers are displayed.

You can choose whether to display the rulers for new windows that you open by setting your preferences 
from the Options menu.

You can change the units used by the ruler by clicking on the ruler units box and selecting the unit of 
measurement that you want.

The units available are :

Centimetres

Inches/tenths

Inches/eighths

Picas and points
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Ruler units

You can change the unit of measurement used by the rulers by clicking on the units box and selecting the units of 
measurement that you want.

The units available are :

Centimetres

Inches/tenths

Inches/eighths

Picas and points

All the dialog boxes that you display after this change will default to the unit of measurement that you have 
chosen.
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Title bar

The title bar is at the top of each window and dialog box, e.g:

Drag the title bar if you want to move a window or dialog box around the desktop.

Double-click on the title bar to maximise the window, just as if you had clicked on the Maximise button.
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Minimise button

Click on this button to reduce the window to an icon.

You can then restore the window by double-clicking on the icon, or by clicking on the icon and selecting 
Restore from the shortcut menu that appears.

You can also minimise the window using the Control menu.
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Maximise button

Click on this button to increase the window to its maximum size.

You can also maximise the window using the Control menu.
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Restore button

Click on this button to restore the window to its original size and position.

You can also restore the window using the Control menu.
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Control menu

The Control menu is represented by an icon at the top left-hand corner of each window and dialog box. 

You use the Control menu's commands to position windows and dialog boxes.

These commands allow you to move windows, change their size and close them.
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Close button

Click on this button to close the window.

You can also close the window using the Control menu.
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Scroll bar

The scroll bars are at the right, and at the bottom of the picture window, and are used to move different areas of the 
picture into view. Use the scroll bar on the right for vertical movement, and the scroll bar at the bottom for horizontal 
movement.

The position of the scroll box in the scroll bar indicates the area of the page that is currently in view. To scroll around 
the page you can either:

Drag the scroll box along the scroll bar; this moves the picture by the suggested amount in the direction you 
drag it.

Click on the scroll arrows at either end of the scroll bar; this moves the picture a small amount in the 
specified direction.

Click on the scroll bar itself beside the scroll box; this moves the picture one window to the left, to the right, 
up or down.
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Sizing border

Drag the sizing border to change the size of the picture window. The pointer changes to a two-way arrow when the 
sizing border is selected.

If you have grabbed the sizing border at one of the corners, you can size the window both horizontally and vertically 
at the same time.
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Picture icon

This picture icon represents a picture that you have minimised. To restore a picture from an icon, click on the 
Restore button or double-click on the title bar. The picture window is displayed in the same position as it was before 
it was minimised. Changes made to the picture while the window was minimised will also be displayed, e.g. if you 
have amended the picture via another window open on the same picture.

Icons can be dragged around the desktop.
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Set View Size control

There is now a Set View Size control at the left of the horizontal scroll bar on the picture window.

This shows the current magnification level of the picture, and lets you quickly increase or decrease the 
magnification by clicking on the buttons at each end of the control.

If you click on the Set View Size control, a shortcut menu appears. From this menu you can select one of the 
standard view sizes: 25%, 50%, 100%, 2x, 4x, 8x, 16x, Whole Page, Page Width or Zoom To Selection.

Shortcuts:
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General tab help topic



Click on a tab card to display the corresponding options.



New Picture Options dialog box - General



Click on this button to modify how greenstreet Draw starts up and starts a new picture, and to set general controls.



This box previews the options that you have selected in the dialog box.



New Picture Options dialog box: Open an Existing File tab card



Select the file you want to open by clicking on the filename in this list box. This box lists the twenty pictures you 
have most recently worked on.



Click on this button if the picture you want is not shown in the list box. The Open dialog box appears so that you 
can browse your disk drives and folders for the file you want to open.



These four text boxes display information about your selected file.



New Picture Options dialog box: Start A New Picture tab card



Choose to start your new picture using a blank page or a template.



Select a pre-defined page size or template to start your picture.



Click on this button to display either the Custom Page Size dialog box or the Select a template dialog box 
depending on the option you selected in the Category group box.



Click on this button to remove the selected page size or template from the list box. You cannot delete any of the pre-
defined page sizes.



This group box is shown if you have chosen to start with a blank page. Select the orientation of your picture.



This group box is shown if you have chosen to start with a blank page. Specify whether your picture will be single or 
multi-layered, and whether you will be using colour separation.



This check box is shown if you have chosen to start with a blank page. Check this box if you want the standard 
selection of colours to be available in your new picture.



Click on this button to display the Open dialog box, so that you can browse your disk drives and folders for the 
template that you want to load without adding it to the list of templates.



This box displays information about the selected template.



Check this box to make the selected template into the default template so that it is loaded automatically whenever 
you use the default template.



This box displays the path and filename of the selected template.



New Picture Options dialog box: Run a PagePilot tab card



Start the PagePilot by double-clicking on its name in this list box.



This box displays information about the PagePilot.



Custom Page Size dialog box



Give your new page size a name, so that you will be able to recognise and choose it in future.



Specify the height of your page in this box. (The maximum values are 76 cm [30 inches)



Specify the width of your page in this box. (The maximum values are 76 cm [30 inches)



Change the units for your page dimensions by using this drop-down list box.



General dialog box options



This area displays a preview of the selected file.



Click on this button to view summary information about your selected file.



Save As dialog box



Click on this button to enter more details about the picture you are saving. The Summary Info dialog box appears 
for you to enter the details you want.



Check this box to make the template you are saving the default template.



Summary Info dialog box



Type in the title of the picture.



Type in details of the picture's subject matter.



greenstreet Draw automatically inserts the name you entered during installation. You can edit this name if needed.



Type in any keywords that you want to associate with the picture. Some utilities are able to search your system for 
files by looking for keywords.



Type in any information that you want to note about the picture.



Export to File dialog box



This check box is available if you selected an object before displaying the Export to File dialog box. To export the 
selected objects only, clear this check box; to export the whole picture, check this check box.



Select the number of colours in which you want to export your picture using this drop-down list box. 

If you are exporting a colour picture but want the colours to be converted into shades of grey in the exported file, 
select Monochrome.



If you have chosen to export the picture in a bitmap file format, you can specify the resolution of the file using this 
text box. (Minimum resolution 10 dots per inch, maximum 1000 dots per inch.)



Import from File dialog box



Check this box if you are importing a line-art file that you want to have smoothed. Some line-art files represent 
curves with a series of short straight lines; smoothing the line-art file will smooth these straight lines into curves, 
making the image clearer.

This check box is enabled only when you are importing a line-art file.



This spin box is enabled if you have checked the Smoothing check box. Type in a smoothing value or use the 
arrows.



Page Format dialog box



Select a pre-defined page size from the list box or type a new name in the Page Sizes box to create a new page 
size. 



Click on this button to add a new page size to the list in the Page Sizes list box. You must enter a name for the new 
page size in the Page Sizes box for this button to be enabled.



Click on this button to delete a selected page size. You cannot delete any of the pre-defined page sizes.



Select the orientation of your picture using these options.



Specify whether your picture will be single or multi-layered, and whether you will be using colour separation.



Print Options dialog box



Select to print your picture to the selected printer or to disk so that it can be printed at a later date, e.g. by a 
professional print bureau.



In this spin box, type in the number of copies you want to print or use the arrows to set the number of copies you 
need.



Click on this button to change the settings of the current printer or to select another printer. The Print Setup dialog 
box appears for you to set up the printer you want.



Select the scaling option that you want. You can choose to scale your picture so that it fits the page, choose to print 
the picture at its actual size, or you can specify your own scaling percentage using the spin box.



Select the layer or layers that you want to print. You can choose to print all of the layers, the current layer shown on 
the desktop or you can specify a range of layers to print using the text boxes.



Check this check box to print Layer Zero of your picture.



This group box displays the size of the picture, the size of the paper currently selected for the default printer and the 
number of pages on which the picture will be printed, e.g. If the picture is larger than the page, it will be printed as 
tiles over several pages.



Check this box to change the orientation of the page between landscape and portrait without transforming the 
picture.



This box is automatically checked if your picture is larger than the paper it is being printed on. greenstreet Draw will 
then print your picture in portions (tiles) which you align using the crop and registration marks that are printed on 
each sheet. 



Check this box to improve the quality of grey scales when printing a colour picture on a monochrome printer. This 
option is only available when you are printing to a non-PostScript printer or a monochrome printer.



Check this box to print objects that have been hidden in your picture.



Check this box to print crop and registration marks. When tiling your picture, crop and registration marks will be 
printed even if this check box is cleared.



Check this box to print your picture as a mirror image. This may be necessary when preparing a picture for 
commercial printing. This option is only available when printing to a PostScript printer.



Check this box to print your picture as a negative image. This may be necessary when preparing a picture for 
commercial printing. This option is only available when printing to a PostScript printer.



Check this box to print your picture as colour separations. This option is only available when Colour Separation has 
been specified on the Page Format dialog box, and is only available for PostScript.



Colour Separation dialog box



Displays the four process colours and any spot colours that you have created. The selected separations are 
indicated by an asterisk (*).



Select which separations you want to print. Highlight a separation in the list box and check the This separation 
check box to add it to the list. To remove a separation from the list, select the separation and clear the This 
separation check box.

To add or remove all separations, check or clear the All or No separations check box as necessary.



This text box specifies the angle of the selected separation. Adjust this value if requested by your print bureau.



This spin box specifies the frequency of the selected separation. Adjust this value if requested by your print bureau.



Preferences dialog box



Startup tab card



Select whether you want to make the New Picture Options dialog box appear or make the default template be 
loaded automatically every time you run greenstreet Draw.



Check this box to display the colour bar along the bottom of the greenstreet Draw desktop.



Check this box to display the greenstreet Draw window across the full area of your screen.



Check this box to display the information line along the bottom of the greenstreet Draw desktop.



In this spin box, type the number of files you want listed on the New Picture Options dialog box when opening a 
template or an existing picture. You can enter any number between 0 and 20.



In this spin box, type the number of recently used picture files you want listed in the File menu. You can enter any 
number between 0 and 20.



New Window tab card



Check this box to display the new window in the full area of the greenstreet Draw desktop.



Check this box to set the view size of the window to whole page view.



Check this box to display the new window in preview format.



Check this box to display the rulers in the new window.



Check this box to display the grid in the new window.



Check this box to cause objects to align to the grid when they are drawn, sized or moved.



Choose whether to display the Open dialog box when you select Open from the File menu (this is chosen by 
default) or the Open an Existing File tab card of the New Picture Options dialog box.



 Display tab card



Clear this box to turn off the display of the blue page box when your picture is displayed in preview format.



Check this box to allow text to be greeked when your picture is displayed in preview format.



Select whether you want to redraw your pictures more quickly but less accurately or more slowly but more 
accurately when they are displayed in preview format.



If this box is checked, text is displayed using Windows vector fonts; if the box is cleared, text is displayed using its 
true outline. Text will be redrawn quicker when Vector Font is checked, but more accurately when it is cleared.



Use this spin box to specify the size (in pixels) below which text will be greeked. Text below this point size will 
always be greeked when your picture is displayed in outline format. Greeking speeds up the redrawing of text by 
showing a character as a single line stroke instead of its true shape.



Check this box to use the greenstreet Draw handler to display embedded files in your picture. Using the greenstreet 
Draw handler allows faster and more accurate rendering of the embedded file. Clear this check box to display a 
Windows Metafile version of embedded files.

We recommend that you leave this box checked unless you experience problems when displaying or printing 
embedded greenstreet Draw pictures. 



General tab card



Check this box if you want greenstreet Draw to save a backup copy of your documents.



Choose to either have the nudge control snap items to the grid as you move them or nudge items by the amount 
specified in the text box.



Change the units for your nudge settings using this drop-down list box. 



In this spin box, specify the distance (in pixels) within which you must click in order to select the object. 



In this spin box, specify how close together end points must be before greenstreet Draw will join them with a path.



Blend dialog box



In this spin box, type the number of blend stages you need or use the arrows to adjust the value.



This value controls by how much the object is transformed at the first blend stage, i.e. the proportion of the 
transformation done in these steps.

The default value depends on the number of blend stages chosen and is calculated so that the blend will be even 
and gradual. Normally this value will not need to be changed but you can adjust it if necessary. 



This value controls by how much the object is transformed at the last blend stage, i.e. the proportion of the 
transformation done in these steps.

The default value depends on the number of blend stages chosen and is calculated so that the blend will be even 
and gradual. Normally this value will not need to be changed but you can adjust it if necessary.



Grid dialog box



Check this box to display a grid for the picture in the active window.



Check this box to ensure that objects align to the grid when they are drawn, moved or sized.



Check this box to align the grid to the top left-hand corner of the page.



Check this box to align the grid to the ruler origin. If the ruler origin is at the top left-hand corner of the page, this 
control is disabled.



From this drop down list box, select a unit of measurement for the grid. The grid units can be different from the ruler 
units.



Specify the width of each individual grid cell using this text box.



Specify the height of each individual grid cell using this text box.



Specify the number of sub divisions across each individual grid cell using this text box.



Specify the number of sub divisions down each individual grid cell using this text box.



Click on this button will copy the horizontal settings to the vertical settings to create a square grid.



Layers dialog box



Lists the currently available layers, with the current layer highlighted. To make another layer the current layer, click 
on it in the list box.



Displays the name of the current layer. To rename a layer, edit the name in this box; to add a new layer, enter a new 
name for the layer in this box.



Displays the number of the current layer. To add a new layer, type in a new layer number in this spin box or use the 
arrows to adjust the figure.



Click on this button to add a new layer to the list in the Layers list box. You must enter a name and number for the 
new layer in order to enable this command.



Click on this button to delete the current layer. The layer will be removed from the Layers list box. You cannot 
delete layer zero or any layer containing objects and you must select another layer before clicking on OK, otherwise 
the deleted layer will be recreated.



Displays the number of objects on the current layer.



Align dialog box



Click on this option to make the selected objects align to each other. If one of the selected objects is locked when 
you align to each other, all the objects will align to the locked object.



Click on this option to make the selected objects align to the page. If one of the selected objects is locked when you 
align to the page, the locked object will not move to the new position.



Choose whether to align your selected objects horizontally to the left, centre, right or not at all.



Choose whether to align your selected objects vertically to the top, middle, bottom or not at all.



This preview box illustrates how your objects will align, given the selection that you make.



General Properties dialog box Info



Displays the layer on which the selected object, bitmap, group, path or EPS file is currently displayed. To move the 
object to another layer, type the layer number in the text box. If the layer number you enter does not exist, it will be 
created. This option is only available when your picture is multi-layered.



Use this text box to specify the horizontal position of your shape, bitmap, group, path or EPS file. The co-ordinates 
are specified from the ruler origin.



Use this text box to specify the vertical position of your shape, bitmap, group, path or EPS file. The co-ordinates are 
specified from the ruler origin.



Select the horizontal position of the left, centre or right of the object, bitmap, group, path or EPS file.



Select the vertical position of the top, middle or bottom of the object, bitmap, group, path or EPS file.



Use this group box to specify the exact dimensions of the object, bitmap, group, path or EPS file. Alter the values in 
the text boxes to resize the object, bitmap or path precisely.



Check this box to lock the selected object, bitmap or path. When an object, bitmap, group, path or EPS file is 
locked, several options on this dialog box become disabled because they do not apply to a locked object, bitmap or 
path.



Select a unit of measurement to be used in the Position and Size group boxes.



Shape Properties dialog box



Displays the current shape of the selected object and allows you to change it using the drop-down list box.



Use this text box to define various attributes which may differ depending on the type of shape selected.



Shows the amount of angle between the start and end angles of an arc or pie.



Element Properties - Bitmap Image dialog box



Check this box to invert the colours of the selected bitmap. This option is only available when a two colour bitmap is 
selected.



Path Properties dialog box



Check this box to apply the current fill style to all the enclosed areas that have been created by the path crossing 
over itself. This option is enabled only when a closed path is selected.



Check this to close an open path.



Change the type of selected points, e.g. from corner points to connector points by selecting a different option.



Check this box to let you edit points with the path being restricted to greenstreet Draw's automatic curvature.



Text on a Path dialog box



Check this box to display the path to which the text is joined.



Clear this box to split the text and the path back into two separate objects.



Check this box to reverse the direction in which the text flows along the path.



Select this option to produce the effect of the characters hanging down from the path.



Select this option to produce the effect of the path running through the characters at half the height of the upper 
case characters in the selected font.



Select this option to produce the effect of the characters standing on the path. (This is the default alignment).



Select this option to produce the effect of the path running through the characters at the height of the top of a lower 
case x character in the selected font.



Select this option to produce the effect of the path running through the characters at half the height of a lower case 
x character in the selected font.



Select this option to produce the effect of the path following the bottom of the descender characters in the selected 
font.



Select a text orientation from the range available 



Click on this button to display the Spacing dialog box from where you can change the spacing of the text.



Click on this button to display the Path Properties dialog box for the path to which the text is joined.



Spacing dialog box



Adjust the leading (spacing) between the lines of text using this spin box.



Adjust the minimum spacing between the words in the text using this spin box.



Adjust the maximum spacing between the words in the text using this spin box.



Adjust the minimum spacing between the letters in the text using this spin box.



Adjust the maximum spacing between the letters in the text using this spin box.



Text Properties dialog box



Click on this button to display the Spacing dialog box from where you can change the spacing of the text object.



Move Objects to Layer dialog box



Displays all the layers in your picture. To move the selected objects to another layer, click on the layer name to 
which you want to move them.



Displays the layer on which the selected objects are currently displayed. To move the objects to another layer, type 
the layer number in the To Layer box. If the layer number you enter does not exist, it will be created.



General transformation dialog box information



Select this option to transform the object(s) at the point where you double-clicked the mouse to display this dialog 
box, at the central point of the XY Location or at the precise position specified in the Across and Down boxes.



Use this text box to specify how far you want to transform your object across.



Use this text box to specify how far you want to transform your object down.



Select a unit of measurement to be used in the Across and Down text boxes.



Check this box to transform a copy of the selected object(s) while leaving the original unchanged.



Reflect dialog box



Select the axis that you want the object(s) to be reflected across.



Rotate dialog box



Specify the angle that you want. You can enter the angle into the spin box, use the arrows to increase or decrease 
the value, or drag the radius in the circle.



Skew dialog box



Specify the horizontal skew factor by entering a value directly into the spin box or by using the arrows to increase or 
decrease the value.



Specify the vertical skew factor by entering a value directly into the spin box or by using the arrows to increase or 
decrease the value.



Scale dialog box



Select this option to scale the object(s) equally in both vertical and horizontal directions. Specify the uniform scaling 
percentage in the adjacent spin box.



Select this option to scale the object(s) differently in vertical and horizontal directions, then set the horizontal (X) 
and the vertical (Y) scale factors separately using the text boxes.



Move Objects dialog box



Type the amount by which you want to move the object(s) horizontally and select whether they should move to the 
left or the right. To move the object(s) in a diagonal direction, move the objects both horizontally and vertically.



Type the amount by which you want to move the object(s) vertically and select whether they should move upwards 
or downwards. To move the object(s) in a diagonal direction, move the objects both horizontally and vertically.



Select a unit of measurement to be used in the Horizontal and Vertical group boxes.



Check this box to move a copy of the selected object(s) while leaving the original unchanged.



Rounded Box dialog box



Type the corner radius you want. Reduce the corner radius to make the box more square; increase the corner 
radius to make the box more circular.



Select a unit of measurement to be used in the Default Corner Radius text box.



Freehand dialog box



Type the smoothness value in the spin box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the movements of the pencil tool; increasing the 
smoothness will produce a path that does not follow the movements of the pencil tool so closely.



Autotrace dialog box



Type the smoothness value in the spin box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the original bitmap; increasing the smoothness 
will produce a path that does not follow the original bitmap so closely.



Polygon dialog box



Type the number of sides you want in the spin box or use the arrows to increase or decrease the number.



This preview box illustrates the shape that your polygon will adopt.



Star dialog box



Type the number of points you want in the spin box or use the arrows to increase or decrease the number of points.



Type the inner radius in the text box. Reduce the inner radius to make the star more pointed; increase the inner 
radius to make the star less pointed.



Drag the slider to increase or decrease the inner radius. Reduce the inner radius to make the star more pointed; 
increase the inner radius to make the star less pointed.



Line Ends dialog box



From this list box select an arrowhead for the start of your line.



From this list box select an arrowhead for the end of your line.



From this list box select an end style for the line style: Butt, round or square.



From this list box select a join style for the line style: Mitre, round or bevel.



This text box displays the minimum angle at which joins will be mitred when the selected join style is Mitre. Specify 
the angle that you want by typing it in the box. Joins below this angle will be bevelled instead of mitred.



Edit Colour and New Colour dialog box



This text box displays the name of the selected colour or indicates that the colour is unnamed. If you want the 
rename the colour, enter a name in the text box. If you do not name your colour, it will still be added to the colour 
bar and marked as unnamed.



Select the colour model that you want to use and mix the colour you want with the slider controls.



This preview box displays the colour as it is mixed or selected. Click on the colour blocks around the preview box as 
an alternate to choosing a colour model and mixing a colour.



This check box appears only when your picture has been set up for colour separation. Check this box to save the 
colour as a spot colour.



Tile Pattern dialog box



Specify the size of the tiles by entering a percentage in the spin box, or by using the arrows to increase or decrease 
the percentage. 



Set the horizontal offset of the pattern by entering a value in each text box. The offset determines the alignment of 
the pattern when it is applied to an object. 



Set the vertical offset of the pattern by entering a value in each text box. The offset determines the alignment of the 
pattern when it is applied to an object.



Select a unit of measurement to be used in the Horizontal and Vertical text boxes.



PostScript Halftone Screen dialog box



Clear this box to enable the Screen group box; you can then enter values other than the defaults.



From this list box select the shape you want. A PostScript printer can print a halftone fill style in any of the shapes 
listed; each shape will produce a different effect.



Change the frequency of the selected shape by entering a value directly into the spin box or by clicking the arrows 
next to the box. The frequency determines the density of the shape.



Change the angle of the selected shape by entering a value directly into the spin box or by clicking the arrows next 
to the box. The angle determines the position at which the shape will be printed.



PostScript Styles dialog box



From this list box select a PostScript style.



This box displays information about the selected style; not all styles have associated information.



These spin boxes display style-specific parameters that can be edited; not all styles have associated parameters.

The available parameters depend on the selected style. Many styles allow you to edit their length and width; some 
styles provide other parameters that can be edited.



Name Style dialog box



Type a name for the new line or fill style.



Edit Colours dialog box



This list box displays the colour palette for the active window. Select the colour that you wish to edit or delete. Spot 
colours are indicated by a dot next to their names.



Choose the order in which to sort the colours in the Names list box by clicking on your preferred option.



Specify the number of tints of each colour you would like shown on the colour bar.



Click on this button to display the New Colour dialog box. From this dialog box you can create a new colour.



Click on this button to display the Edit Colour dialog box. From this dialog box you can edit the colour selected in 
the Names list box.



Click on this button to delete the colour(s) selected in the Names list box. You cannot delete the colour Black.



Click on this button to display the Load Colours dialog box. From this dialog box you can load a saved palette. This 
will be merged in with your existing colours.



Click on this button to display the Save Colours dialog box. From this dialog box you can save the colour palette for 
use with other pictures.



This preview box displays a sample of the selected colour.



Line Style popup



Displays the named line styles available to the picture in the active window. Click on a named style to apply it to a 
selected object, or select the style that you want to edit or base a new style on.



Click on this button to display the Name Style dialog box. From this dialog box you can name a new line style, or 
rename an existing style that you have modified.



Click on this button to delete the line style currently selected in the Named Style drop-down list box.



Set a separate style for the left end, body and right end of the line; click on the section you want to drop-down a list 
of available styles. Each line end can have one of eleven styles, including different arrowheads. The body can have 
one of eight styles, including custom and PostScript.

As you specify aspects of the line style, these three section boxes act as a preview box to display the line style you 
have set.



Drag the slider along the scale to alter the width of the line. The width that you choose appears in units in the Width 
box.



This text box displays the precise line width for the selected line style. Edit the value in this box to change the line 
width precisely.



Click on the arrow to drop-down the colour palette, then select the colour that you want. The currently selected 
colour is marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of colour. Hold down Ctrl whilst dragging 
the slider to change the tint by increments of 10%. The tint that you choose appears in the Tint box as a 
percentage.



This spin box displays the minimum angle at which joins will be mitred when the selected join style is Mitre. Specify 
the angle that you want by typing it in the box. Joins below this angle will be bevelled instead of mitred.



These text boxes are enabled only when you have selected Custom for the body of the line. Use these boxes to 
specify the length of the dashes and gaps for your custom line style.



This button is enabled only when you have selected PostScript for the body of the line. Click on this button to 
display the PostScript Styles dialog box from where you can select a PostScript line style.



This check box is only displayed when the page format has been set up for colour separation. Check this box to 
enable overprinting when producing colour separations.



Fill Style popup



Displays the name of your current style or pattern. Edit the name if necessary in this text box.



Click on this button to display the Name Style dialog box. From this dialog box you can name a new fill style, or 
rename an existing style that you have modified.



Click on this button to delete the fill style currently selected in the Named Style drop-down list box.



From this list box, select one of nine fill styles.



This preview box displays the fill style or pattern you have chosen.



Specify the angle of the style by entering a value in the spin box, or by using the arrows to increase or decrease the 
angle.



Click on the arrow to drop-down the colour palette, then select the colour you want. The currently selected colour is 
marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of colour. Hold down Ctrl whilst dragging 
the slider to change the tint by increments of 10%. The tint that you select appears in the Tint box as a percentage.



This second colour palette appears if you have selected a graduated fill style. Click on the arrow to drop-down the 
colour palette, then select the "to colour" you want. The currently selected colour is marked by a frame. The colour 
of the fill style will then fade from the other colour to this colour according to the selected graduation.



Click on this button to apply the current line or fill style to any selected objects. This line or fill style is then the 
default style and is applied to any new objects that you draw.



Click on this button to reduce or expand the popup. 



This button is enabled only when you have selected a PostScript fill style. Click on this button to display the 
PostScript Styles dialog box from where you can select a PostScript fill style.



Click on this button to display the PostScript Halftone Screen dialog box from where you can set up a halftone fill 
style. This button is disabled when you have selected a PostScript fill style.



This check box is only displayed when the page format has been set up for colour separation. Check this box to 
enable overprinting when producing colour separations.





Click on a tab for more glossary entries:

- A -

Active window

Alignment

Align to page

Align to rulers

Align

Arc

Arrowhead

Auto curvature

Auto scroll

Autotrace

Axis

- B -

Background

Baseline

Basic shape

Bezier path

Bevel

Bitmap

Blend

Blend stages

Bold

Box

Butt

- C -

Cascade

Character

Check box

Clipart

Clipboard

Closed path

CMYK

Colour model

Colour bar

Colour palette

Colour separation



Command

Compound path

Compress

Connect point

Container

Control lines

Control menu

Control points

Convert to path

Copy

Corner point

Corner radius

Crop marks

Curve point

Custom page

Cut

Cylindrical



Click on a tab for more glossary entries:

- D -

Defaults

Dialog box

Dither

Dock

DPI

Duplicate

- E -

Ellipse

Embed

Ends

EPS

EPSF

Expand

Export

- F -

File

File extension

File format

Fill style

First point

Fixed point

Floating toolbox

Folder

Font

Foreground

Freehand path

Frequency



Click on a tab for more glossary entries:

- G -

General Tools

Greeking

Grid

Group

- H -

Hairline

Halftone

Handles

Hidden objects

HLS

Hue

- I -

Icon

Import

Information line

In-place editing

Insertion point

Intersection area

Italic



Click on a tab for more glossary entries:

- J -

Join

Join range

Justification

- K -

Kerning

Keyboard shortcuts

Keyboard shortcuts

- L -

Landscape

Layer zero

Leading

Letter spacing

Lightness

Line-art

Line style

Linear

Link

List box

Locked objects

Lower

Logarithmic

- M -

Magnification

Menu

Menu bar

Metafile

Mitre

Multi-layer



Click on a tab for more glossary entries:

- N -

Negative

- O -

Object

OLE

Open path

Outline format

Overprint

- P -

Page box

PagePilot

Paste

Paste inside

Path

Pattern

PCX

Pica

Picture window

Pie slice

Pixel

Point

Pointer

Polygon

Portrait

PostScript

PostScript fill style

PostScript line style

Preferences

Preview format

Preview box

Printable area

Printing to disk

Process colour



Click on a tab for more glossary entries:

- R -

Radial

Raise

Redo

Reflect

Reflection axis

Registration

Registration marks

Reversed

RGB

Rotate

Round box

Round

Ruler

Ruler origin

- S -

Saturation

Scale factor

Scaling (printing)

Scanner

Screen

Scroll bar

Select

Selection frame

Selection range

Skew

Snap control

Spherical

Split path

Spot colour

Square

Standard view size

Star



Click on a tab for more glossary entries:

- T -

Template

Text frame

Text object

Text on a path

Text Tools

TIFF

Tiling

Tint

Title bar

Toggle

Toolbox

Trace

Transform

Trap

Typeface

- U -

Undo

Ungroup

- V -

Vector font

Vector-based

View size



Click on a tab for more glossary entries:

- W -

Work area



The window or icon that you are currently using or that is currently selected. Only one window or icon can be active 
at a time. When a window is active, its title bar is highlighted to differentiate it from other windows; when an icon is 
active, its label is highlighted.



The positioning of text: Left aligned, right aligned, centred or justified.



A setting that makes the grid align with the top left-hand corner of the page.



A setting that makes the grid align with the ruler origin.



The positioning of objects relative to each other or to the page.



A curve that is a segment of the circumference of an ellipse.



An arrow symbol that you can select for each end of a line style.



The production of a smooth curve through a point that depends on the position of adjacent points. A point has auto 
curvature when it is created.



The ability of the picture window to scroll automatically when you drag the pointer beyond the borders.



To trace an outline around an imported bitmap automatically.



The line in which objects are reflected in a reflect transformation. The reflection axis passes through the fixed point.



The name of layer 10.

The unset bits in a bitmap.



An imaginary line on which text rests.



A box, round box, ellipse, arc, pie slice, polygon or star, created with one of the shape tools.



A smooth curve, defined by control points.



A style of line join in which the corner is cut off.



A picture composed of individual pixels (dots) created with a paint program or with a scanner. In contrast, 
greenstreet Draw creates pictures using vector-based graphics.



The insertion of intermediate paths between two paths or basic shapes, with a transition of line styles and fill styles 
from one end to the other.



One of the intermediate paths inserted between two paths or basic shapes during a blend operation.



A weight of text characterised by thick heavy lines.



A rectangle or square drawn using the Box tool.



A squared-off end type for a line style, which does not project beyond the end of the line.



An overlapping arrangement of windows on the desktop, with the title bar and left-hand edge of each window 
remaining visible.



Any single letter, number, punctuation mark, or symbol.



A small, square box displayed in a dialog box that can be selected or cleared. When a check box is selected, a    
appears in the box.

A check box represents an option that you can turn on or off.



Files imported into greenstreet Draw to provide convenient, ready-made components of pictures.



A temporary storage location used to transfer data within and between programs. The Cut and Copy commands 
transfer data to the Clipboard, and the Paste command inserts the data at your selected position.



A path with no end points. Closed paths can be filled.



A colour model of subtractive mixing with cyan, magenta, yellow and black used to make any other colour. Black is 
used to replace equal mixtures of the other three colours to produce better dark colours.



A method of describing a colour as a mixture of other colours (e.g. RGB and CMYK), properties of the colour (e.g. 
HLS) or with reference to a standard set of colours.



The line of colours shown at the foot of the greenstreet Draw window. You can add colours to the colour bar, edit 
existing colours and delete colours from it. You can also change the number of tints of each colour that are shown in 
the colour bar.



A set of colours available to your greenstreet Draw pictures. You can create more colours to add to the colour 
palette, or you can delete colours if you do not want to use them. When you save a picture, the colour palette is 
saved as part of the picture, with any changes that you have made. Each picture can be saved with a different 
selection of colours in the palette, and the picture’s palette is displayed in the colour bar at the foot of the 
greenstreet Draw window.



A technique used in colour printing. A colour picture is separated into a number of components, each of which is 
printed using a single colour. The combination of separate components reconstitutes the original full colour picture.

The colour of each separation depends on the colour model used.



A word or phrase - usually found in a menu - that you choose to open a dialog box or carry out an action.



A path made by combining a number of closed paths.



To compress the character width of your text selection, or to preset the width before typing text.



The type of point drawn by the Connect tool to provide a smooth transition from a straight to a curved line.



A Windows program, e.g. greenstreet Publisher, that can accept linked or embedded objects from other programs.



Lines used to connect control points to points on paths. The length and direction of the control lines control the 
direction and curvature of the path at the point.



 A standard Windows menu displayed by clicking on the Control-menu icon at the top left-hand corner of any 
window. The Control menu contains commands you can use to manipulate the window.
Icons and some dialog boxes also have a Control menu.



+-shaped handles at the end of control lines. The handles are dragged to change the length and direction of the 
lines.



A command used to change basic shapes and text objects into paths.



To put a copy of the selected object(s) onto the Clipboard so that you can transfer it to another location.



The type of point drawn by the Corner tool used to connect straight sections of a path.



The radius used to create the curvature of a round box.



Hairlines drawn on a printout to mark the edge of the picture when the printout is tiled or printed on paper larger 
than the picture.



The type of point drawn by the Curve tool to connect curved sections of a path smoothly without a corner.



A user-defined page size.



To move the selected object(s) from your picture onto the Clipboard so that you can transfer it to another location.



A graduated fill style comprising of symmetrical bars fading from one colour at each edge of the object to another 
colour in the centre.



Settings that are supplied with greenstreet Draw. For example, if you start a new picture without specifying a paper 
size, greenstreet Draw uses its default setting, that is Letter.



A window that appears temporarily to supply information to greenstreet Draw. When a dialog box appears, all 
interaction with greenstreet Draw must be through the dialog box.



Part of a structure for organising your files on a disk. A folder can contain files and other folders called subfolders.



To create the illusion of a colour by placing dots of other colours very close together. In greenstreet Draw, a colour is 
dithered when the display device does not support that colour.



You can move the toolbox and five toolbars around the desktop and leave them wherever you like. When they are 
attached to the edge of the window, they are docked. When they are away from the edge and displayed in a box, 
they are floating.



The number of dots (pixels) per inch that a printer can produce. Most laser printers print at 300 dpi. High-resolution 
phototypesetters provide 1270 and 2540 dpi.

The higher the dpi, the sharper the picture.



To make a copy of a greenstreet Draw object on the screen without using the Clipboard.



A regular oval drawn using the Ellipse tool. The most regular oval is a circle.



To copy a greenstreet Draw object into another program, e.g. greenstreet Publisher, using OLE. By embedding an 
object, you can edit it without having to leave the container program.

When you embed an object, a copy of the object file is made and stored within the container program: The original 
object file is not altered in any way and remains available for future use.



A component of a line style allowing the ends of an open path to be made round, square or butt.



To expand the character width of your text selection, or to preset the width before entering text.



Encapsulated PostScript - a file format that is interpreted by a PostScript printer.



Encapsulated PostScript Format - a line-art format that can be handled by greenstreet Draw.



To save all or part of a picture in one of a number of file formats used by other programs.



A picture or document stored on a hard or floppy disk, or any other media.



The full-stop and up to three characters at the end of a filename. An extension usually identifies the kind of 
information a file contains. For example, files that you create using greenstreet Draw have the .ART extension.



The way in which information is structured in a file. Programs always store files in a particular format. A format 
readable by one program may not be readable by another program.



The attribute of closed paths, text objects and basic shapes specifying how the space enclosed by their outlines 
should be filled. Fill styles can have different colours, and can be plain or graduated from one colour to another in a 
number of different styles.

Patterns comprising of tiled groups of objects can be used to define fill styles. A range of predefined PostScript fill 
styles can be used with PostScript printers.



The point on a path or basic shape that is used as the reference point for a blend if no points are selected.



The point around which the scale, rotate, reflect and skew transformations are performed.



The optional display of the greenstreet Draw toolbox in a moveable window.



This is used in greenstreet Draw to mean the style of type e.g. Autumn, Brushwood, or Cambridge. Elsewhere this 
may be called a typeface, with the term 'font' reserved for a particular weight, size and style of typeface.



The name of layer 100.

The set pixels of a bitmap.



A path drawn by dragging the Pencil tool.



The density of dots used to produce a screen for halftone printing or colour separation.



The representation of text by simple strokes.



An optional overlay of crossed lines to help accurate positioning of an object in a picture. Precise positioning is 
assisted by the option of making objects snap to the grid when they are created, moved or transformed.



A set of objects grouped together so that they behave as a single object.



A line displayed or printed at the finest resolution possible of the particular screen or printer.



The printing of shades of grey on a black and white printer, using different densities of black dots.



Small boxes or circles that are displayed on selected objects. Handles can be dragged to change the shape of the 
object.



Objects that have been hidden using the Hide command. You can choose whether or not to print hidden objects.



A colour model using Hue, Lightness and Saturation to specify a colour.



The position of a colour along the colour spectrum from 0 to 360 degrees where red is 0, yellow is 60, green is 120, 
cyan is 180, blue is 240, magenta is 300 and red is 360, again.



A graphical representation of a disk drive, a folder, a program, a picture window or other object that you can select 
and open.



An electronic typesetter than can handle graphics as well as type. Imagesetters typically have a resolution of 600 
dpi (dots per inch) or better.



To load a graphic into greenstreet Draw in one of a number of file formats used by other programs, usually to 
provide convenient, ready-made components of pictures.



A bar at the foot of the greenstreet Draw desktop giving information on layers and objects:



To edit an embedded greenstreet Draw object without having to open greenstreet Draw. The greenstreet Draw 
menus, toolbars and other controls necessary to edit the object temporarily replace the existing menus and controls 
of the container program.

Linked greenstreet Draw objects cannot be edited in-place.



The vertical line that indicates where text editing will take place.



The point where the rulers intersect. This intersection area displays the currently selected unit of measurement.



A style of text characterised by letters slanting to the right.



A command joining together the open ends of paths or joining text to a path.

A property of a line style specifying how line segments are joined at corner points.



The distance used to determine whether end points should be joined together by a path using the Join command or 
when using a path tool.



The layout of text across a text frame or along a path so that it fills the width of the frame or the length of the path. 
Justified text in a text frame will have straight left- and right-hand edges.



Increasing or reducing the space between characters.



An alternate to using the mouse for selection. Keyboard shortcuts are shown on screen by underlining a letter in 
menu titles, dialog boxes and so on.



A means of carrying out a command from the keyboard without displaying a menu first. Shortcuts are a replacement 
for several mouse selection operations. If there is a keyboard shortcut, it is shown after the command in the menu. 
Not all menu commands have keyboard shortcuts.



The orientation of a page in which the horizontal size is greater than the vertical.



The lowest layer in a picture. Layer zero is used to store bitmaps for tracing or templates for positioning objects.

By default, layer zero is not printed.



The spacing between lines of text. The name comes from the use of strips of lead to separate lines in traditional 
printing methods.



The amount of space automatically inserted between characters to achieve justified lines of text.



Pictures defined as a series of straight and curved lines rather than dots. Drawing packages produce line-art. 
Compare with bitmap.



The percentage by which a colour approaches black (0 percent) and white (100) percent.



The attribute of paths, text objects and basic shapes specifying how the line or outline should be drawn. Line styles 
can have different widths and colours.

Custom line styles can be made up of different patterns of dashes. A range of predefined PostScript line styles can 
be used with PostScript printers.



A graduated fill style flowing in a single direction fading from one colour to another.



To create a reference in a container program, e.g. greenstreet Publisher, to a greenstreet Draw object.

By creating links between files, you save time and ensure consistency in your work. You can share information from 
one file with several others, and you need only maintain the original: The others are automatically updated.



Within a program window or a dialog box, a type of box that lists available options. If all the options do not fit in the 
list box, the box becomes scrollable.



Objects that have been locked using the Lock command. Locked objects cannot be manipulated in any way, but 
they can be hidden.



A graduated fill style where one colour fades away quickly and then tapers off to the final colour.



To lower the characters in your text selection below the baseline, or to preset the position before typing.



The view size of the picture in the active window.



A list of available commands in greenstreet Draw. Menu names are displayed in the menu bar near the top of the 
desktop.



The horizontal bar containing the names of the greenstreet Draw menus. The menu bar is displayed below the title 
bar:



A type of file format for line-art.



A style of line-join in which the lines extend to a point at the join.



A greenstreet Draw picture with more than one layer.



A print option interchanging black and white. This may be needed when printing to a file for use by a commercial 
printer.



 A basic shape, path, text object, imported bitmap or group.



A way to transfer and share files between programs. OLE (Object Linking and Embedding) provides a means to 
create files consisting of multiple sources of information from different programs.



 A path with two separate end points.



A simplified picture display allowing rapid redrawing.



A property that can be given to line styles and fill styles when the page format has colour separation selected. When 
a line or fill style without the overprint property overlaps another object, the colour lying under the line or fill is 
removed when colour separations are produced. This is sometimes called under colour removal. However, if a line 
or fill style has the overprint property selected, it is printed on top of the underlying object without under colour 
removal.



The blue rectangular outline on the work area marking the position of the page, which is specified using the Page 
Format dialog box.



A PagePilot is a feature that can quickly create a certain kind of picture, such as a logo. It does this by asking you 
questions and using your answers to automatically lay out and format the type of picture you specify. 



To insert the contents of the Clipboard into a picture.



To paste an object that has been cut from a picture inside a closed path. 

Paste inside inserts the object in the picture but makes visible only those parts of it lying within the closed path.



A straight or curved line consisting of one or more segments joined together at points.



A group of objects tiled to use as a fill style.



A standard file format for bitmaps.



A typesetting unit, equal to 1/6 inch.



A window on the greenstreet Draw desktop containing a work area for a picture. There can be several picture 
windows open on the desktop at the same time. 

 These may contain different pictures or different views of the same picture.



A segment of a circle or other ellipse, drawn using the Pie tool.



One of the dots making up a picture displayed on the screen.



The corner, curve and connector points used to define paths.

The unit used to measure text: 1 point = 1/72 inch.



The arrow-shaped cursor on the screen that follows the movement of the mouse and indicates which area of the 
screen will be affected when you press the mouse button.

The pointer will change shape when performing certain tasks and when changing tools.



A regular shape with three or more sides, drawn using the Polygon tool.



The orientation of a page in which the vertical size is greater than the horizontal.



A language used to describe how text and graphics should be printed on a page. PostScript printers are able to 
interpret the language to produce printed output. The PostScript page description does not depend on the resolution 
or other properties of the printer, so the same PostScript description can be printed out on any PostScript printer, 
imagesetter or film recorder using its full resolution.



A fill style with a PostScript definition, which can be printed on a PostScript printer but not displayed on screen.



A line style with a PostScript definition, which can be printed on a PostScript printer but not displayed on screen.



A set of values and selections used to configure the desktop when greenstreet Draw starts up.



A screen display representing the printed form of a picture as closely as possible.



A box in some dialog boxes showing the effect of selecting items.



The area of the page that the printer can print to, marked by the page box.



To send output for printing to a disk instead of a printer so that the picture can be printed at another time or on 
specialist commercial printing equipment.



A colour model of subtractive mixing with cyan, magenta, yellow and black used to make any other colour. Black is 
used to replace equal mixtures of the other three colours to produce better dark colours.



A graduated fill style comprising of circles with equal graduation intervals from the centre to the circumference.



To raise the characters in your text selection above the baseline, or to preset the position before typing text.



To redo an edit or transformation that has been undone with the Undo command.



A transformation performed with the Reflect tool or one of the reflect buttons in the Transform Tools.



The line in which objects are reflected in a reflect transformation. The reflection axis passes through the fixed point.



The alignment of the tiles in a tiled picture to make up the complete picture.

The alignment of colour separations to reconstitute the full colour version.



Marks on printouts used to assist registration.



An option in printing producing a reversed bitmap. This can be useful when preparing a picture for some kinds of 
commercial printing.



A colour model for additive mixing, in which Red, Green and Blue are mixed to produce any colour.



A transformation performed with the Rotate tool or one of the rotate buttons in the Transform Tools.



A box with rounded corners.



A type for the Join and Ends properties of a line style.



Optionally displayed rules at the top and left-hand side of each picture window.



The point on the desktop that measures zero on both horizontal and vertical rulers.



The intensity of a colour, or how much hue is present or absent. Completely saturated colour is colour at its most 
intense (100 percent). At its least intense, a colour is grey (0 percent).



To increase or decrease the size of an imported bitmap or line-art.



The percentage by which a scaling operation changes the size of a picture or selected objects. There may be 
different scale factors for the vertical and horizontal directions.



The application of a scale factor to change the size of a picture when it is printed.



A device used to convert a picture on paper to a bitmap in a computer.



Traditional printing technology uses a mesh screen in a process camera to convert shades of grey to different sized 
dots. In electronic publishing the screen frequency, angle and type refer to the density, angle and shape of the dot 
pattern calculated to represent grey shades for black and white printing or different colour intensities for colour 
separations.



A bar that is displayed at the bottom and/or right edge of a window whose contents are not entirely visible.



Choose an object on which your next action will be carried out.

Choose a command, option button or check box.



A rectangle dragged out with the Pointer tool to select any item in the rectangle when the mouse button is released.



The distance around the Pointer tool within which an object will be selected if the mouse button is clicked.



Tools that perform common commands such as Cut, Copy, Paste and Transform Again. Click on a button to 
perform the command. 

The General Tools can be docked at any edge of the desktop, or they can be displayed in a floating box.



A transformation performed using the Skew tool or one of the skew buttons in the Transform Tools.



A box which allows you to adjust the tint of a colour on a scale from 0% to 100% (or from 0 to 255 or 360) in drop-
down colour palettes.



Force objects to align to the grid.



A graduated fill style comprising of circles with increasing graduation intervals from the centre to the circumference.



Break a path at a selected point. An open path is split into two shorter open paths; a closed path becomes an open 
path; a compound path cannot be split until it has been ungrouped into separate paths; text on a path is separated 
from the path.



A colour specified as a spot colour can have its own separation when it is printed instead of being made up of a 
mixture of process colours.



 One of the types for the Ends property of a line style. Unlike the butt end style, square line ends project half the 
line's width beyond the end of the line.



You can view your picture at a custom magnification, or at one of the standard view sizes: 25%, 50%, 100%, 2x, 4x, 
8x, 16x, Whole Page, Page Width or Zoom To Selection.



A regular shape with three or more radiating points, drawn using the Star tool.



A file type for storing pictures used as a basis for other pictures.

The name of layer zero.



A set of text functions that are displayed when the Text tool is selected. Use the Text Tools to set the font, size, style 
and alignment of text, to adjust the set width and kerning, to raise or lower the text, and to turn autokerning on or off.
The Text Tools can be docked at the top or bottom of the desktop, or they can be displayed in a floating box.



A box marking the boundary of a text object.



A text item in a picture. A text object can be manipulated in the picture in the same way as any other object.



Text flowing along a path.



Tagged Image File Format - a standard file format, often used to store scanned bitmaps.



Placing shapes adjacent to each other. In greenstreet Draw objects can be tiled to make pattern fill styles, printouts 
can be tiled to produce a picture larger than the size of the paper, and picture windows can be tiled so that they are 
all visible on the desktop.



The proportion of hue in a defined object. The remaining portion is white.



The horizontal bar that contains the title of the window or dialog box.



A command that is turned on or off using the same action. For example, you can turn the display of the information 
line on and off by selecting Information Line from the submenu that appears when you select Show Controls from 
the View menu.



The display of greenstreet Draw buttons at the edge of the work area, or floating on the desktop. greenstreet Draw 
has five toolbars: The General Tools, the Transform Tools, the Align Tools, the Object Tools, and the Text Tools.



The display of greenstreet Draw tools at the edge of the work area, or in the floating toolbox.



To construct a path around a bitmap, either manually or automatically.



To edit an object by moving, scaling, skewing, rotating or reflecting it.



A device to overcome the effect of imperfect registration when printing spot colour separations for superimposed 
objects. The foreground object is given an overprinted outline (i.e. under colour removal is not applied to the 
outline). This must be wide enough to cover any gaps that might appear because of imperfect registration between 
the foreground and background separations.



The style of type e.g. Brushwood. greenstreet Draw more commonly uses the term font to refer to the style of type.



To undo the last edit or transformation and restore the picture to its former state.



Separate a group into individual objects.

Change a basic shape into a path.



 A font using lines instead of filled outlines.



Describing a drawing as a series of lines and arcs instead of as a bitmap.



The magnification of a greenstreet Draw picture.



What You See Is What You Get: The ability to show on screen an accurate representation of what will be printed.



The area within which a greenstreet Draw picture is created.







Understanding PagePilots

A PagePilot is a mechanism that guides you through making basic choices about the type of picture you want and 
how you want to lay it out; it is an easy way of creating a picture quickly when you don't know how to use 
greenstreet Draw.

greenstreet Draw has a PagePilot which helps you create logos.

When you run the PagePilot, you are presented with a series of questions. When you have chosen answers to 
these questions, the PagePilot automatically creates your logo to match the format and layout you have chosen.

At the end of the PagePilot, you can choose to create the logo or go back through the questions and change the 
options you chose. If you choose to create the logo, you can watch as greenstreet Draw brings all the items 
together to make your logo.

When your logo has been created, you can work on it in the same way as other greenstreet Draw pictures, tailoring 
it precisely to your needs. Cue cards are provided to help you with the basic steps needed to complete your logo.

    Related Topics



To run the PagePilot

1. From the File menu, select New. The New Picture Options dialog box appears.

2. Select the Run A PagePilot tab card.

3. Select the PagePilot. Information about the PagePilot appears on the tab card.

4. Click on OK.

The PagePilot will now run and present you with the first question about the layout of your logo. Select the option 
you want and then continue through the remaining questions. You can go back to an earlier question if you want to 
change something.

    Related Topics



Starting a new picture

There are three different ways that you can start a new picture:

By running the PagePilot

By using a template

By starting from a blank page

To start a new picture, select New from the File menu. The New Picture Options dialog box appears, giving you 
the three choices above. Select the tab card you want.

Running the PagePilot

Run the PagePilot if you want greenstreet Draw to help you create a logo. You will be asked a series of questions 
about the layout and design of your logo, then greenstreet Draw will create it automatically for you. When the 
PagePilot has finished, you can edit the logo to tailor it precisely to your own needs.

Using a template

Templates are useful if you regularly create pictures using common elements. By saving the common elements in a 
template file, each time you need to draw another picture, you can load the template and use it as a basis instead of 
having to start completely from scratch. Use a template if you want to create a new picture based on a template that 
you have previously designed and saved.

Starting from a blank page

If you want to start completely from scratch, without any pre-set options, start your new picture from a blank page. 
You can specify the picture's page size, orientation and attributes using the Start A New Picture tab card.

You can modify your preferences to suit the way you start new pictures.

If the new picture window hides other pictures that you already have open, select Tile or Cascade from the 
Window menu to bring these pictures back into view.

    Related Topics



To start a new picture from a template

1. From the File menu, select New. The New Picture Options dialog box appears.

2. Select the Start A New Picture tab.

3. From the Category group box, select Template.

4. From the Template list box, select the template you want to load. A preview of the template appears in the dialog 
box, along with any notes that were saved with it.

5. Click on OK. The template is loaded and you can begin to create your picture.

There is also a Browse button on the Start A New Picture tab card. This button lets you load a template by its file 
name instead of through the category structure.

1. From the File menu, select New. The New Picture Options dialog box appears.

2. Select the Start A New Picture tab.

3. Click on Browse; the Open dialog box appears.

4. Open the folder in which the template was saved.

5. Select the template.

6. Click on Open to load the template.

    Related Topics



Opening an existing picture: Information

A picture that has already been created in greenstreet Draw can be reopened so that you can continue working on 
it.

The quickest way to open a picture is to select its filename from the list of recently used pictures in the File menu.

If the picture you want to open isn't listed in the File menu, select Open from the File menu and choose the picture 
you want using either the Open dialog box or the Open an Existing File tab card of the New Picture Options 
dialog box.

Use the Preferences dialog box to determine whether the Open dialog box or the Open an Existing File 
tab card appears when you select Open from the File menu (the Open dialog box is chosen by default).

When you first load greenstreet Draw, the New Picture Options dialog box may appear (depending on your 
preferences). From this dialog box you can open an existing picture by selecting the Open An Existing File tab 
card. This tab card lists the most recently used pictures; if the picture you want isn't listed, click on Browse and 
select the picture using the Open dialog box.

Note:

If there is an empty picture window selected when you open a picture, the picture is put in this window.

The appearance of the picture window is determined by your preferences. You can change your preferences 
using the Preferences dialog box.

If the picture window hides other pictures that you already have open, select Tile or Cascade from the 
Window menu to bring these pictures back into view.

If you need to open a backup file, change *.art in the File Name box to *.bak.

    Related Topics



To open an existing picture

1. From the File menu, select Open. The Open dialog box appears.

2. Select the disk drive and folder where you have saved the picture.

3. From the Files of Type drop-down list box, select the type of file that you have saved the picture as.

4. From the Folders list box, select the picture you want to open.

5. Click on Open.

The picture appears in the greenstreet Draw window.

Shortcut:

    Related Topics



To open a recently used picture

1. From the menu bar, select the File menu.

The pictures that you have used most recently are listed beneath the Print Setup command.

2. Click on the picture you want to open.

Note:

You can use the Preferences dialog box to change the number of pictures that are listed in the File menu.

    Related Topics



To change the page format

1. From the File menu, select Page Format. The Page Format dialog box appears.

2. The Page Sizes list box lists the page sizes available. Click on the page size that you want.

3. Select the picture orientation you want by clicking on the Portrait or Landscape option as appropriate.

4. If you intend to create a complicated picture using several layers, check the Multi-Layer check box in the Picture 
Attributes group box.

5. If you intend to print the picture using colour separations, check the Colour Separation check box.

6. To confirm your choices and return to the picture window, click on OK.

    Related Topics



To create a custom page size

1. From the File menu, select Page Format. The Page Format dialog box appears.

2. Type a name for the new page size in the Page Sizes box.

3. Type the dimensions you want in the Height and Width boxes in the Custom Page group box. You can change 
the current unit of measurement by selecting a different unit from the Units drop-down list box.

4. To add the new page size to the list, click on the Add button.

Note:

The maximum page size you can create is 30 inches [76 cm].

    Related Topics



To delete a custom page size

1. From the File menu, select Page Format. The Page Format dialog box appears.

2. From the Page Sizes list box, select the custom page size that you want to delete.

3. To delete the page size from the list, click on the Delete button.

4. To close the dialog box, click on OK.

Note:

You cannot delete the greenstreet Draw predefined page sizes; only custom page sizes can be deleted.

    Related Topics



To change the view size of your picture

1. From the toolbox, select the Magnifier tool.

2. Click on the point of your picture that you want to appear at the centre of the window. Your picture is then 
magnified to the next standard view size. Each subsequent click will increase the view size to twice the previous 
size.

To reduce the view size of your picture, hold down Shift and click on the point of your picture that you want to 
appear at the centre of the window. The picture is then reduced to the next standard view size. Each subsequent 
click will display your picture at half its previous size.

Note:

The maximum magnification is 1600%.

The minimum magnification is 12%.

To magnify a specific area of the picture, select the Magnifier tool and drag the mouse pointer over the area 
that you want to magnify.

Use the Set View Size control to change the view size of your picture to a specific magnification.

You can also change the view size of your picture through the View menu.

Double-clicking on the Magnifier tool will display the whole page of your picture.

Shortcuts:
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To use preview and outline format

From the View menu, select Preview.

This command is ticked when the picture is displayed in preview format. Select the command again to remove the 
tick and display the picture in outline format. 

Note:

When a picture is displayed in outline format, all the objects in the picture are drawn with the same thin line 
style, and without their colours, patterns, fill styles or other line styles. This lets the screen be redrawn quickly to 
update any edits that you make.

When a picture is displayed in preview format, all colours, patterns, fill styles and line styles applied to 
objects will be drawn. This gives you a WYSIWYG display (What You See on the screen Is What You Get on the 
printed page).

We recommend that you display your picture in outline format as much as possible and only use preview 
format when it is essential that you see all the colours, patterns, fill styles and line styles.

Shortcut:



Displaying your picture in multiple windows

You can have more than one window open on a picture. For example, you could:

Highly magnify one window to make detailed changes, and view the effect of the changes on the whole 
picture in another window.

Work with the grid displayed in one window, and without it in another.

Work in outline format in one window to edit your picture quickly, and in preview format in the other window 
to give you a WYSIWYG display (What You See on the screen Is What You Get on the printed page).

Work on a single layer in one window, with a view of the complete picture in another. 

If the picture window hides other pictures that you already have open, select Tile or Cascade from the 
Window menu to bring these pictures back into view.

You can have up to eight windows open on any one picture.
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To open a new window of your picture

From the Window menu, select New Window.

The picture appears in the new window, overlapping the original.

The title bar of the new window indicates which view of the picture it is. For example, if the title of the original picture 
window is POSTER.ART, the new window is POSTER.ART:2, the next window POSTER.ART:3, and so on.
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To work with multiple pictures

1. Open the picture that you want to work on. A new picture window is opened and becomes the active window.

2. If the picture window hides other pictures that you already have open, select Tile or Cascade from the Window 
menu to bring these pictures back into view.

Note:

The current preferences determine the appearance of the new window.

Having multiple pictures open allows you to cut, copy and paste objects between pictures with ease. You 
can also drag an object from one picture, and drop it into another.

You can have up to twenty windows or twenty pictures open at once.
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To rearrange windows

When you open several picture windows at a time, some windows overlap or hide others. You can use the Cascade 
and Tile commands in the Window menu to rearrange all the windows so that some part of each window is visible.

To cascade windows

From the Window menu, select Cascade.

All the picture windows are resized and layered within the greenstreet Draw work area so that each title bar is 
visible, making it easy for you to select any of the windows.

To tile windows

From the Window menu, select Tile.

All the picture windows are resized and arranged side-by-side in the greenstreet Draw work area so that no 
windows overlap and each window's contents are visible.

Note:

If you open another picture window after you use the Cascade or Tile command, it overlaps the rearranged 
windows. To include it among the rearranged windows, select the Cascade or Tile command again.
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To switch between windows

Do one of the following:

When the pictures are tiled, click anywhere in the window. The title bar of the previous window is disabled 
and the selected window is highlighted to show it is now the active window.

When the pictures are cascaded, either click on the title bar to bring the window you want to the front, or 
press Ctrl Tab to switch between windows.

When the pictures are full screen, use the Window menu to select the picture you want to view.

Note:

When you move from one window to another:

The tool that is currently selected does not change.

The current line, fill and colour attributes are specific to a picture, so they may change from window to 
window if the window contains different pictures.

The information line changes to display information about the active window.
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To reduce a window to an icon

Do one of the following:

Click on the Minimise button 

Select Minimise from the Control menu of the window that you want to iconise.

The window is ionised and put at the bottom of the greenstreet Draw desktop.

To restore a window from an icon, do one of the following:

Click on the icon and select Restore from the Control menu

Double-click on the icon.

The window is displayed in the same position it was in before it was minimised.

Note:

Icons can be dragged around the desktop. If the icon cannot be seen, it is probably hidden behind one of the 
open windows.

Changes made to the picture while the window was reduced will also be displayed, e.g. if you have edited 
another window on the same picture.
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To save a picture

1. From the File menu, select Save As. The Save As dialog box appears.

2. Select the file format in which you want to save the picture by selecting Picture or Template from the Save as 
Type drop-down list box.

3. From the Folders list box, select the folder in which you want to save the picture.

4. Type a name for the picture in the File Name box. The file extension is added if you do not type it.

5. Click on Save. The picture is saved to the file of that name and the file name appears in the title bar.

If you type a file name that already exists, you will be asked if you want to overwrite the existing file. Click on Yes 
or No as appropriate.

Note:

You can also save a picture by selecting Save from the File menu.

You can save information about a picture by typing the details into the Summary Info dialog box. You can 
open this dialog box by clicking on the Summary Info button in the Save As dialog box, or by selecting Summary 
Info from the File menu. When you save the picture, the information in the Summary Info dialog box is saved as 
well.

Shortcut:
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To create a backup copy when saving

1. From the Options menu, select Preferences. The Preferences dialog box appears.

2. Select the General tab card.

3. In the File Options group box there is a check box labelled Create .BAK Files. Check this box to create backup 
(.BAK) files.

When you next save your picture, the previous version is renamed as <FILENAME>.BAK and the latest version, 
with your most recent changes, is saved as <FILENAME>.ART (where <FILENAME> is the name of your picture).
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To close a picture

1. Select the window containing the picture that you want to close.

2. Do one of the following:

From the File menu, select Close.

From the picture window's Control menu, select Close.

Click on the Close button in the top right-hand corner of the picture window.

Double-click on the Control-menu icon.

The window is removed from the desktop.

Note:

If the picture has been changed since it was last saved a message appears asking if you want to save your 
changes.

When there is more than one window open on a picture, Close from the File menu will close all the windows 
displaying the picture; Close from the picture window's Control menu will close the current window only.

Keyboard Shortcut: Ctrl F4 closes the active window.
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To set your preferences

1. From the Options menu, select Preferences. The Preferences dialog box appears.

This dialog box is divided into tab cards containing options for:

greenstreet Draw's behaviour on startup

greenstreet Draw's behaviour when you open a new picture window

The way greenstreet Draw displays your pictures

General greenstreet Draw settings.
2. Select the tab card of the preferences you want to set.
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To exit greenstreet Draw

Do one of the following:

From the File menu, select Exit greenstreet Draw.

From the Control menu, select Close.

Click on the Close button in the top right-hand corner of the window.

Double-click on the Control-menu icon.

Note:

If there are any open pictures with unsaved changes, a message appears giving you the option to save the 
pictures before you exit greenstreet Draw.

The layout of the desktop is saved until you next run greenstreet Draw, e.g. the position of the toolbox and 
text controls will be remembered.

Keyboard Shortcut: Alt F4 exits greenstreet Draw.
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To use layers

1. From the File menu, select Page Format. The Page Format dialog box appears.

2. Check the Multi-layer check box, then click on OK. The picture now has a default of three layers:

0:    Zero (template)

10:    Background

100:    Foreground
You can add up to 200 layers if you need them.

Note:

If you begin drawing a picture on a single layer and later decide that it would be easier to use several layers, 
you can still select Multi-layer as above. However, if you change a multi-layered picture back to being single-layered, 
all objects not on layer 100 will be lost.
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To use Layer Zero

From the View menu, select Layer Zero.

Every layered picture has a layer zero. Layer zero has two main uses:

a) To contain objects that you want to trace around.

b) To create templates that you can save for use in future pictures.

Note:

When you import a graphic for tracing it is put on layer zero.

Objects on layer zero are not printed out by default.
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To add layers

1. From the View menu, select Layers. The Layers dialog box appears.

All the layers of the picture in the active window are listed.

2. Select the number of the layer you want to add by clicking on the arrows next to the Layer Number spin box, or 
by typing the number directly into the box.

3. Click in the Name box and enter a name for the new layer. This is not obligatory, but helps when there are a lot of 
layers.

4. Click on Add Layer to add the layer to the list in the Layers box.

5. To add the layer to your picture, click on OK.

The new layer becomes the current layer.

Note:

You can have up to two hundred layers in a picture.
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To move between layers

1. From the View menu, select Layers. The Layers dialog box appears.

2. From the Layers list box, select the layer you want to move to.

3. Click on OK. The selected layer becomes the current layer.

Note:

You can also move between layers by clicking on the layer box in the information line, and selecting the 
layer you want from the shortcut menu that appears.
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To display the current layer

In the View menu, deselect All Layers.

All the layers except the current layer are hidden.

Note:

The All Layers command is ticked when all the layers in your picture are displayed.
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To delete layers

1. From the View menu, select Layers. The Layers dialog box appears.

2. Select the layer that you want to delete form the Layers list box.

3. Click on Delete Layer. The layer is removed from the Layers list box.

4. From the Layers box, select the layer that you wish to become the current layer in your picture. If you do not 
select a layer, greenstreet Draw will recreate the layer that you have just deleted and make it the current layer 
again.

5. To confirm that the appropriate layer has been deleted and return to your picture, click on OK

Note:

You cannot delete layer zero.

The information line displays the name and number of the current layer.
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To save a template

1. From the File menu, select Save As. The Save As dialog box appears.

2. From the Save as Type drop-down list box, select Template (*.tem).

3. Select a disk drive and folder in which to save the template.

4. Type a name for the template in the File Name text box. The template is automatically given the .TEM file 
extension, unless you specify another.

5. If you want to make this template into the default template, which is then loaded automatically whenever you start 
greenstreet Draw or open a new picture, check the Make Default Template check box.

6. If you want to save some information about the template, click on the Summary Info button to display the 
Summary Info dialog box.

7. To save the template, click on Save.
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To open a template

1. From the File menu, select Open. The Open dialog box appears.

2. From the Files of Type drop-down list box, select Template (*.tem).

3. Select the disk drive and folder in which you previously saved the template. The templates in the selected folder 
are listed in the Folders list box.

4. From the Folders list box, select the name of the template that you want to open. The template appears in the 
preview box.

5. To open the template, click on Open.

The template appears in the active window and you can now begin creating a new picture based upon this 
template.

Note:

If, at step 1 above, the New Picture Options dialog box appears, you have changed your preferences. You 
can open a template through this dialog box using the Start a New Picture tab card.

The original default template (DEFAULT.TEM) is saved in the GREENSTREET\DRAW30\SAMPLES sub 
folder. You can load this template again if you want to continue working with the original default template.

When you open a template, its filename remains "Untitled" until you save the picture.
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To draw a basic shape

1. From the toolbox, select the shape tool that you want to use. When you move the mouse pointer into the work 
area, it changes to a different shape, depending on the tool you have selected.

2. Press the left mouse button and drag the pointer diagonally across the desktop. An outline of the shape is drawn 
as you drag the mouse.

3. Release the mouse button when the outline is the size and shape you want.

Note:

The shape is drawn with the current line style and fill style (except arcs, which are not given fill styles).

Eight handles appear around the edge of the shape, indicating that the shape is selected. When an ellipse, 
arc or pie slice is selected, the handles appear around an invisible box that follows the circumference of the shape.

When arcs and pie slices are selected, two hollow round handles at either end of their arc segment are also 
displayed. These handles represent the start and end angles of the shape.

When you draw a shape extending beyond the displayed area of the picture, greenstreet Draw auto scrolls 
the work area to keep the shape in view.

Shape tools:
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To draw a shape with equal dimensions

1. From the toolbox, select the shape tool that you want to use.

2. Hold down Ctrl, then press the left mouse button and drag the pointer across the desktop. Do not release Ctrl 
until you have released the mouse button.

The shape is drawn with its width equal to its height.

Note:

You can press Ctrl part way through a drag, to ensure that the shape has equal dimensions.

You can press Ctrl and Shift simultaneously to draw a shape from its centre and with equal dimensions.

Shape tools:
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To draw a shape from its centre

1. From the toolbox, select the shape tool that you want to use.

2. Hold down Shift, then press the left mouse button and drag the pointer across the desktop. Do not release Shift 
until you have released the mouse button. The shape is drawn with its centre at the point where you began to 
drag.

Note:

You can press Shift part way through a drag, to ensure that the shape is drawn from its centre.

You can press Shift and Ctrl simultaneously to draw a shape from its centre and with equal dimensions.

Shape tools:
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To specify the curvature of a round box before you draw it

The curvature of a round box is determined by its corner radius. You can edit the corner radius to make the shape 
more circular or more square.

1. Double-click on the Rounded Box tool. The Rounded Box dialog box appears.

2. In the Default Corner Radius text box, enter the size of the corner radius you want.

If you want, you can select another unit of measurement from the Units drop-down list box.

3. Click on OK.

Note:

When you next draw a round box it will be given the corner radius that you have just specified. 

The curvature that you specify will remain the same until you change it again; subsequent round boxes will 
be drawn with this curvature.
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To change the curvature of a round box 

1. Select the Pointer tool and right-click on the round box whose curvature you want to change. The basic shape 
shortcut menu appears.

2. From the shortcut menu, select Object Properties. The Shape Properties dialog box appears.

3. In the Corner Radius text box, enter the curvature you want.

4. Click on OK.

The round box is redrawn with the curvature that you have just specified.

Note:

You can also display the Shape Properties dialog box by selecting the round box and then selecting 
Properties from the Object menu.

You can also specify the curvature of a round box before you draw it, using the Rounded Box dialog box.

Shortcut:
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To specify the number of sides on a polygon before you draw it

When you draw a polygon it is automatically given five sides. 

1. Double-click on the Polygon tool. The Polygon dialog box appears.

2. Enter the number of sides you want the polygon to have (it must be a number between 3 and 100). The preview 
box illustrates what the polygon shape will be.

3. Click on OK to close the dialog box.

Note:

When you next draw a polygon it will be given the number of sides that you have just specified.

The number of sides that you specify will remain the same until you change them again; subsequent 
polygons will be drawn with this number of sides.
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To change the number of sides on a polygon 

1. Select the Pointer tool and right-click on the polygon whose shape you want to change. The basic shape 
shortcut menu appears.

2. From the shortcut menu, select Object Properties. The Shape Properties dialog box appears.

3. In the Sides text box, enter the number of sides you want.

4. Click on OK.

The polygon is redrawn with the number of sides that you have just specified.

Note:

You can also display the Shape Properties dialog box by selecting the polygon and then selecting 
Properties from the Object menu.

You can also specify the number of sides on a polygon before you draw it, using the Polygon dialog box.

Shortcut:
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To specify the number of points on a star before you draw it

1. Double-click on the Star tool. The Star dialog box appears.

2. In the No. of Points text box, enter the number of points you want the star to have (it must be a number between 
3 and 100). The preview box illustrates what the star will look like.

3. Click on OK to close the dialog box.

Note:

When you first draw a star it is automatically given five points. 

When you next draw a star it will be given the number of points that you have just specified.

The number of points that you specify will remain the same until you change them again; subsequent stars 
will be drawn with this number of points.
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To change the number of points on a star

1. Select the Pointer tool and right-click on the star whose shape you want to change. The basic shape shortcut 
menu appears.

2. From the shortcut menu, select Object Properties. The Shape Properties dialog box appears.

3. In the Points text box, enter the number of points you want.

4. Click on OK.

The star is redrawn with the number of points that you have just specified.

Note:

You can also display the Shape Properties dialog box by selecting the star and then selecting Properties 
from the Object menu.

You can also specify the number of points on a star before you draw it, using the Star dialog box.

Shortcut:
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Specifying the inner radius of a star before you draw it

1. Double-click on the Star tool. The Star dialog box appears.

2. Adjust the inner radius by dragging the slider or by typing the value in the Star Inner Radius text box. Increasing 
the value will make the points of the star less pointed. The preview box illustrates what the star will look like.

3. Click on OK to close the dialog box.

Note:

When you next draw a star it will be given the inner radius that you have just specified.

The inner radius that you specify will remain the same until you change it again; subsequent stars will be 
drawn with this inner radius.
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To change the inner radius of a star

1. Select the Pointer tool and right-click on the star whose shape you want to change. The basic shape shortcut 
menu appears.

2. From the shortcut menu, select Object Properties. The Shape Properties dialog box appears.

3. In the Inner Radius text box, enter the inner radius that you want.

4. Click on OK.

The star is redrawn with the inner radius that you have just specified.

Note:

You can also display the Shape Properties dialog box by selecting the star and then selecting Properties 
from the Object menu.

You can also specify the inner radius of a star before you draw it, using the Star dialog box.

Shortcut:
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To change the angle of an arc or pie slice manually

1. Draw an arc or pie slice. There is a round handle at either end of the arc or pie slice, representing the start and 
end angles.

2. Select the Pointer tool; press the left mouse button and drag the start or end handle to adjust the arc segment of 
the arc or pie slice.

As you drag either of the handles, the information line displays the angle that you are adjusting. The information 
line also displays the percentage that the arc or pie slice occupies of the whole ellipse of which it is a segment.

3. When the arc or pie slice is the shape you want, release the mouse button.
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To change the angle of an arc or pie slice

1. Select the Pointer tool and right-click on the arc or pie slice whose angle you wish to change. The basic shape 
shortcut menu appears.

2. From the shortcut menu, select Object Properties. The Shape Properties dialog box appears.

3. In the Start Angle and End Angle text boxes, enter the values you want. The percentage of the arc or pie slice is 
updated to reflect the changes you make to the start and end angles.

4. Click on OK to close the dialog box.

The arc or pie slice is redrawn with the start and end angle that you have just specified.

You can also display the Shape Properties dialog box by selecting the arc or pie slice and then selecting 
Properties from the Object menu.

You can also change the angle of an arc or pie slice manually.

Shortcut:
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To use the Pencil tool

1. From the toolbox, select the Pencil tool. The pointer changes shape to a pencil when you move it into the work 
area.

2. Press the left mouse button and drag the pencil around the work area in the shape of the path you want to draw. 
A line is drawn, following the movements of the pencil.

Note:

When you release the mouse button, a path is created consisting of a number of line segments joined 
together at points; this is know as a freehand path. Because the path is selected, these points are indicated by small 
black squares.

If no line is drawn through the points you have no line style selected. From the Line menu, select Solid.

    Related Topics



To draw a straight path with the Pencil tool

1. From the toolbox, select the Pencil tool, and position the pointer where you want the first line to begin.

2. Hold down Shift, then press the left mouse button and drag the mouse pointer to where you want the first line 
segment to end.

3. Still holding down Shift, release the mouse button. A straight line is drawn between the two points. Without 
moving the mouse, press the button again and then drag to the next end point.

4. Repeat Step 3 until you have drawn the whole path, then release Shift.

Hold down Ctrl to restrict the angle of the path to multiples of 45 degrees.
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To erase a freehand path

You can erase a freehand path while you are still drawing it.

Hold down Alt and move the pointer back over the path that you have just drawn. The mouse pointer 
changes shape to an eraser.

Note:

The first point on the freehand path is not erased; to erase this point, ensure that no other objects are 
selected, then press Delete.

You cannot erase a freehand path in this way if you have already finished dragging the pointer and released 
the mouse button.
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To smooth a freehand path

1. Double-click on the Pencil tool. The Freehand dialog box appears.

2. Adjust the smoothness value by clicking the arrows or by typing the value in the Smoothness spin box.

3. Click on OK to confirm the new value.

Note:

The smoothness value determines how precisely a freehand path follows the movements of the pointer. A 
smoothness value of 1 will produce a path that follows the movements of the pointer closely, making the path appear 
rough with numerous points; a smoothness value of 9 will produce a path that does not follow the movements of the 
pointer closely but smoothes out the path so that it has fewer points.
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To use the Corner tool

1. From the toolbox, select the Corner tool. The pointer changes shape to a cross with a box at its centre when you 
move it into the work area.

2. Position the pointer where you want to start the path and click the mouse button. An empty box is displayed, 
indicating that a point has been drawn and is selected.

3. Move the pointer to the next position and press the mouse button. When you release the mouse button, a path is 
drawn between the two points.

4. Repeat Step 3 until the path is complete, for example:

Note:

You can delete the last point you have drawn by pressing Backspace.

Hold down Ctrl to restrict the angle of the path to multiples of 45 degrees.

When you have finished drawing the path, you can deselect the last point by pressing the space bar, then 
continue drawing another path. To deselect the whole path, press Esc.

If no line is drawn through the points, you have no line style selected. From the Line menu, select Solid.
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To use the Curve tool

1. From the toolbox, select the Curve tool. The pointer changes shape to a cross with a circle at its centre when you 
move it into the work area.

2. Position the pointer where you want to start the path and click the mouse button. A circle is displayed, indicating 
that a point has been drawn and is selected.

3. Move the pointer to the next position and press the mouse button. When you release the mouse button, a path is 
drawn between the two points.

4. Repeat Step 3 until the path is complete. For example:

Note:

You can delete the last point you have drawn by pressing Backspace.

When you have finished drawing the path, you can deselect the last point by pressing the space bar, then 
continue drawing another path. To deselect the whole path, press Esc.

If no line is drawn through the points, you have no line style selected. From the Line menu, select Solid.

You can change the curvature of the line between two points by adjusting the control points.
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To use the Connect tool

1. From the toolbox, select the Connect tool.

2. Click the mouse pointer where you want to position the connect point.

Normally, when you insert a curve point after a corner point, the line between them will be angular instead of a 
smooth progression from a straight to a curved line. When you insert a connect point between a corner and a curve 
point, the three points will be joined smoothly.

Note:

When you insert a connect point between a corner and a curve point, you can adjust how the curve joins into 
the straight line by selecting the connect point and dragging its control points.

If no line is drawn through the points, you have no line style selected. From the Line menu, select Solid.
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To use the Bezier tool

Using the Bezier tool, you can draw straight lines and curves connecting smoothly without having to change tools. 
When you click the mouse button, it creates a corner point; when you drag the mouse, it creates a curve point.

It is also possible to control the curvature of curves going into and out of a corner point by using Shift:

1. From the toolbox, select the Bezier tool, then drag the pointer to create a curve point and define its incoming 
direction.

2. Notice that the point has two control points that rotate as you adjust them. Without releasing the mouse button 
hold down Shift. One of the control points is now stationary but the other can be moved.

3. Drag the pointer again to define the outgoing curve direction. Release the mouse button and Shift to place the 
point.

The curve follows the direction of the control point that you adjusted.

Note:

When you hold down Ctrl while using the Bezier tool, the control lines are put at angles of 0, 45 or 90 
degrees. This helps you to determine the curvature of line segments in a bezier path.
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Drawing multiple paths

When you want to end one path and start a new one of the same type, press the space bar. greenstreet Draw then 
deselects the last end point so that you can begin a new path that will not be joined to the previous end point. 
Pressing the space bar to start new paths is similar to the way you would press the space bar to separate words if 
you were typing text.

You can also deselect the path by clicking the right mouse button away from the path, by selecting the Pointer tool 
and clicking away from the path, or by pressing Esc.
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To use corners and curves together

1. Ensure that the last point on the path is selected.

2. From the toolbox, select the Drawing tool you want to use, and continue drawing the path.

The new points will join to the existing path.

Note:

A path can be a mixture of corners and curves; it does not have to be either a curve path or a corner path. You can 
create a path containing every type of point if you want.
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To control the angle of a path

Hold down Ctrl as you drag the mouse to draw the path.

You can control freehand, corner, curve and connect paths so that the next point on the path is at an angle of 0, 45, 
or 90 degrees to the previous point.

Note:

When you hold down Ctrl while using the Bezier   tool  , the control lines are put at angles of 0, 45 or 90 
degrees. This helps you to determine the curvature of line segments in a bezier path.

When you release Ctrl, you can continue drawing your path without any angle constraints.
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To create a shape from a path (closing a path)

1. Draw the path using the Drawing tools.

2. As soon as you move the end point of the path within the join range of the start point, the path will close. For 
example:

Note:

The path is automatically filled with the currently selected fill style.

The two end points will be joined together only if they are both within the join range. You can edit the join 
range in the Preferences dialog box to make it larger or smaller.

You can also close a path using the Path Properties dialog box. This method will close a path even if the 
open ends are not within the join range.

Shortcut:

    Related Topics



To convert a shape into a path

Basic shapes such as boxes and ellipses, are formed from closed paths and can be converted back into those 
paths.

1. Select the shape you want to convert into a path.

2. From the Object menu, select Ungroup. The shape is converted into a path of the same shape, and the handles 
are replaced by points that can be edited. For example:

Note:

You can also convert a shape into a path by right-clicking on the shape to display the basic shape shortcut 
menu, then selecting Convert to Path.

An ungrouped shape does not lose its fill style or colour.

Shortcut:

    Related Topics



To use Undo and Redo

As you create a picture, you will inevitably want to undo some changes that you make. greenstreet Draw lets you 
undo commands so that you can try something different.

To undo the last command, select Undo from the Edit menu.

To redo the last undo command, select Redo from the Edit menu.

Note:

You can undo up to the last fifty commands. If you undo a command by mistake, you can redo it.

There are some commands that cannot be undone or redone, for example, you cannot undo a change in 
view size.

Shortcuts:

    Related Topics



To create a text object

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools at the top of the desktop are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. Click the mouse button at the point where you want to insert the text object. A thin vertical line appears; this is the 
text insertion point.

3. Type the text that you want. The text that you type appears in the current line and fill styles. To start a new line of 
text, press Enter.

Note:

The text you have typed becomes an object in its own right - a text object.

    Related Topics



Creating a text object: Hints

You can create text objects in your picture, then manipulate them like any other object.

If you drag the I-beam, instead of clicking it, a text frame follows the movements of the mouse pointer and 
when you start typing text, the text is automatically formatted to fit the width of the frame.

If you hold down Alt and press the left or right arrow key, you can change the angle of the I-beam so that 
when you click, you can type text into your picture at an angle. Each time you press the arrow keys, the cursor moves 
through 1/16th of a circle. (Press Esc to move the I-beam back to an upright position.)

Once you have created a text object, you can edit it by selecting the Text tool and clicking the I-beam on the 
object that you want to edit. The text insertion point is put within the text. If you have created rotated text, the text 
insertion point is rotated and positioned in the text at the correct angle.

You can use the standard editing keys to edit the text, e.g. Backspace, Delete and the arrow keys to move 
up and down lines and between characters. You can also cut, copy and paste highlighted text selections within your 
text objects.

You can choose to have both the Text Tools and the Object Tools displayed at the same time. Click the right 
mouse button over either toolbar, and deselect Switch Object And Text Tools from the shortcut menu that appears.

The fonts supplied with greenstreet Draw are now grouped into categories. This makes it easier to select a 
font because you don't have to scroll through long lists of meaningless font names.

    Related Topics



To use text from other programs

1. Open the program containing the text.

2. Cut or copy the text onto the Clipboard.

3. Open the greenstreet Draw picture into which you want to paste the text, then select the Text tool from the 
toolbox.

4. Click the mouse button at the point where you want to paste the text. A thin vertical line appears; this is the text 
insertion point.

5. To insert the text into your picture, select Paste from the Edit menu.

The text can now be edited in the same way as text that you enter directly into your picture.

Shortcut:

    Related Topics



To resize text manually

1. Select the Pointer tool.

2. Select the text object whose size you want to change. Handles are displayed around the text frame to show that 
the object is selected.

3. Click on one of the solid handles around the text frame. Without releasing the mouse button, hold down Shift and 
drag the handle.

dragging a corner handle will resize the height and width of the text.

dragging a side handle will resize either the height or width of the text.

4. When the text frame is the correct size, release the mouse button, then the Shift key.

Note:

If you hold down Ctrl instead of Shift, the text is resized while retaining its original proportions.

If you do not hold down either Shift or Ctrl, the text is reformatted to fit the new width of the text frame, not 
resized.

    Related Topics



To resize text

1. Select the Pointer tool and right-click on the text object whose size you want to change. The text shortcut menu 
appears.

2. From the shortcut menu, select Object Properties. The Text Properties dialog box appears.

3. In the Size group box, type the dimensions that you want. Change the position of the text object by adjusting the 
dimensions in the Position group box.

4. Click on OK to close the Text Properties dialog box and redraw the text object at the size you have specified.

Note:

You can also display the Text Properties dialog box by selecting the text object and then selecting 
Properties from the Object menu.

You can also resize text manually.

Shortcut:

    Related Topics



To change the font and point size

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.) 

2. To preset the font and point size, go to Step 3 below. To alter text that you have already created, drag the I-beam 
over the characters to select them.

3. To choose a font for your text, click on the arrow next to the Typeface drop-down list box in the Text Tools. A list 
of the font groups available on your setup drops down.

4. Click on the font group that you want to open, then select the font that you want to use. To close a font group, 
click on the category name (shown in bold).

5. To choose a point size for your text, either click on the arrows next to the Text Size spin box to increase or 
decrease the point size, or type the size directly into the box

Note:

If you select a small point size, greenstreet Draw may not be able to display the text and will simulate it by 
greeking.

Text tools:

  

    Related Topics



To use bold and italic

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.)

2. To preset the text style, go to Step 3 below. To alter text that you have already created, drag the I-beam over the 
characters to select them.

3. To style your text in bold, italic or bold italic, click on the Bold and/or Italic buttons from the Text Tools.

Note:

You can choose to have both the Object Tools and the Text Tools displayed at the same time. Click the right 
mouse button over either toolbar, and click on Switch Object And Text Tools from the shortcut menu that appears.

Text tools:

    Related Topics



 To change the alignment of text

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.)

2. To preset the alignment, go to Step 3 below. To alter text that you have already created, put the text insertion 
point within the text.

3. Click on the button of the alignment that you want: Flushed left, centred, flushed right or justified.

Note:

You cannot align individual characters; alignment settings apply to the whole text object only.

Text tools:

    Related Topics



To expand and compress text

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.)

2. To preset the width, go to Step 3 below. To alter text that you have already created, drag the I-beam over the 
characters to select them.

3. Click on the Increase Width button to make the characters wider; each click will expand the characters by 10%, 
or

Click on the Decrease Width button to make the characters narrower; each click will compress the characters by 
10%.

Note:

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can type the precise percentage by which you want to increase 
or decrease the width of the text in the Text Width spin box.

Text tools:

  

    Related Topics



To raise and lower text

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.)

2. To preset the position of text, go to Step 3 below. To alter text that you have already created, drag the I-beam 
over the characters to select them.

3. Click on the Raise Text button to raise the characters above the baseline; each click will raise the characters by 
1 point, or

Click on the Lower Text button to lower the characters below the baseline; each click will lower the characters by 
1 point.

Note:

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can type the precise number of points by which you want to 
raise or lower the text in the Raise/Lower Text box.

You can choose to have both the Object Tools and the Text Tools displayed at the same time. Click the right 
mouse button over either toolbar, and deselect Switch Object And Text Tools from the shortcut menu that appears.

Text tools:

  

    Related Topics



To kern text

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area. (Notice also that the Object Tools are replaced by the Text Tools, if you have selected this in the Options 
menu.)

2. Drag the I-beam over the characters that you want to kern, or put the text cursor between the two characters to 
be kerned.

3. Click on the Kern Together button to move the characters closer together; each click will decrease the space 
between the characters by 1%, or

Click on the Kern Apart button to move the characters wider apart; each click will increase the space between 
the characters by 1%.

Note:

You cannot preset kerning values.

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can type the precise percentage by which you want to kern the 
text in the Kern Text box.

Text tools:

  

  

    Related Topics



Kerning text: Information

Kerning is a term used for reducing or increasing the space between characters. The kerning controls are useful for 
fine-tuning the appearance of text, particularly text in large point sizes such as headings.

Some letter pairs are nearly always kerned to improve their appearance, e.g. VA, Ta. Some fonts have kerning 
information built into them and will automatically kern letter pairs such as these if kerning is enabled. To 
automatically kern these fonts, click on the Autokern button; click on it again to turn autokerning off.

    Related Topics



To change the letter spacing of text

1. Select the Pointer tool and select the text object whose spacing you want to change. Handles are displayed 
around the text frame to show that the object is selected.

2. Press the left mouse button and drag one of the hollow handles on the left or right edges of the text frame. The 
pointer changes shape to an A..B..C symbol.

drag the handle outwards to increase the letter spacing, or

drag the handle inwards to decrease the letter spacing.

3. Release the mouse button. The text object is redrawn with the letter spacing you have chosen. For example:

Note:

For precise adjustments to letter spacing, word spacing and line spacing, right-click the Pointer tool on the 
text object whose spacing you want to change to display the text shortcut menu. Select Text Spacing from the 
shortcut menu to display the Spacing dialog box, then set the values you want.

Shortcut:

    Related Topics



To change the word spacing of text

1. With the Pointer tool, select the text object whose word spacing you want to change.

2. Press the left mouse button and drag one of the hollow handles on the edges of the text frame. When you have 
begun the drag, hold down Shift. The pointer changes shape to an AB..CD symbol.

drag the handle outwards to increase the word spacing, or

drag the handle inwards to decrease the word spacing.
3. Release the mouse button, then the Shift key. The text object is redrawn with the word spacing you have 
chosen. For example:

Note:

For precise adjustments to letter spacing, word spacing and line spacing, right-click the Pointer tool on the 
text object whose spacing you want to change to display the text shortcut menu. Select Text Spacing from the 
shortcut menu to display the Spacing dialog box, then set the values you want.

Shortcut:

    Related Topics



To change the line spacing

1. With the Pointer tool, select the text object whose line spacing you want to change.

2. Press the left mouse button and drag one of the hollow handles on the top or bottom edges of the text frame. The 
pointer changes shape to several short horizontal lines. (These handles are only visible when you have typed 
more than one line of text.)

drag the handle outwards to increase the line spacing, or

drag the handle inwards to decrease the line spacing.

3. Release the mouse button. The text object is redrawn with the line spacing you have chosen. For example:

As you drag the handle, the information line indicates by how much you are changing the line spacing.

Note:

For precise adjustments to letter spacing, word spacing and line spacing, right-click the Pointer tool on the 
text object whose spacing you want to change to display the text shortcut menu. Select Text Spacing from the 
shortcut menu to display the Spacing dialog box, then set the values you want.

    Related Topics



To join text to a path

1. Create a text object, preferably with only one line of text.

2. Draw the path or shape that you want to join the text to.

3. Select the Pointer tool, then hold down Shift and click on both the text object and the path to select them.

4. From the Object menu, select Join. The text is redrawn flowing along the path, for example:

Note:

Text can be joined to an open path or a closed path.

If the text object has more than one line of text, only the first line is joined to the path.

If you are in preview format, the path is not displayed. You can change this and other settings using the Text 
on a Path dialog box.

Shortcut:

    Related Topics



To edit text on a path

1. From the toolbox, select the Text tool. The pointer changes shape to an I-beam when you move it into the work 
area.

2. Click on the text object that you want to edit.

3. The selected text is hatched out and an upright copy appears temporarily while you carry out your edits.

4. Once you have finished editing, click elsewhere on the desktop, or press Esc. The edited text flows along the 
path again.

    Related Topics



To change the display of text along a path

1. From the toolbox, select the Pointer tool.

2. Right-click on the text object that you have joined to a path to display the text shortcut menu.

3. From the shortcut menu, select Object Properties. The Text on a Path dialog box appears.

4. Decide how the text should be joined to the path, whether the path should be displayed, in which direction the 
text should flow, how the text should align with the path, e.g. Top, 1/2 x-height etc. and what the text orientation 
should be.

5. Click on OK when you have made your changes.

Note:

If you want to have a gap between the text and the path on which it rests, you must raise the text above the 
baseline.

You can also display the Text on a Path dialog box by selecting the text object and then selecting 
Properties from the Object menu.

Shortcut:

    Related Topics



 To convert text to paths

1. From the toolbox, select the Pointer tool, then select the text object that you want to convert into a path.

2. From the Object menu, select Ungroup. The text object is redrawn as individual paths that can then be edited.

Note:

Once a text object has been converted into a path, you can select and edit individual points on the path to 
modify the shape of the characters.

You can also convert a text object into a path by right-clicking the Pointer tool on the text object to display 
the text shortcut menu, and selecting Convert to Paths.

An ungrouped text object does not lose its fill style or colour.

Certain letters when ungrouped produce compound paths, e.g. B or D. Ungroup these again to produce 
separate closed paths.

Shortcut:

    Related Topics



To select/deselect objects

1. From the toolbox, select the Pointer tool.

2. Position the pointer over the object you want to select and click the left mouse button. The object's handles are 
displayed, indicating that it is selected.

To deselect objects

Deselect individual objects by holding down Shift then clicking the Pointer tool on the objects that you want 
to deselect.

Deselect all selected objects by clicking away from them, or by pressing Esc. 

Note:

Any previously selected objects are deselected as soon as you select another object.

When you select an object, that object's line and fill styles become the default for any new objects that you 
create.

    Related Topics



Selecting/deselecting objects: Information

How to select several objects

You can select several objects at the same time by holding down Shift as you click on each object.

You can select several objects by dragging the Pointer tool diagonally over the objects you want to select. A 
selection frame appears as you drag. All the objects within (or partially within) this selection frame are selected when 
you release the mouse button.

How to select objects using Tab

When you have selected a single object, you can use Tab to select the next object and Shift Tab to select the 
previous object. When using Tab and Shift Tab to select objects, the objects are selected in their stacking order.

How to select all the objects in a picture

From the Edit menu, select Select All.

Press Alt A.

Hidden objects and objects on layers that are not currently visible will not be selected.

    Related Topics



To select/deselect points

1. From the toolbox, select the Pointer tool, then select the path containing the point.

2. Position the pointer over the point you want to select. The pointer changes shape to an arrow with a solid black 
box at its base.

3. Click the Pointer tool on the point.

To deselect a point

Deselect individual points by holding down Shift then clicking on the points that you want to deselect.

Deselect all the selected points but leave the paths selected by pressing the space bar.

Deselect all the selected points and paths by clicking away from them, or by pressing Esc. 

Note:

When a point is selected, it is identified as a curve point, corner point or connect point by either a hollow 
circle, box or triangle.

    Related Topics



Selecting/deselecting points: Information

How to select additional points

1. After selecting a point, position the Pointer tool over the next point you want to select.

2. Hold down Shift, then click the Pointer tool on the points in turn to make up the selection.

You can press Shift and click on as many points as you want.

How to select points using the selection frame

1. Select the Pointer tool.

2. Press the left mouse button and drag the pointer diagonally across the points that you want to select. A selection 
frame appears as you drag. All the points within this selection frame are selected when you release the mouse 
button.

You can select more points without deselecting any already selected by holding down Shift while dragging a 
selection frame.

    Related Topics



To group objects

1. From the toolbox, select the Pointer tool, then select all the objects you want to group.

2. From the Object menu, select Group. The selected objects are grouped together and displayed within a 
surrounding box that has eight handles around it.

Note:

Once you have created a group, the objects within it can be manipulated as a whole, e.g. moved, 
transformed, copied and pasted. You cannot blend groups of objects, or apply line and fill styles to them.

When a group is selected, the information line indicates that the selected object is a group, and how many 
objects are within the group. If you have one group and one other object selected, the information line informs you 
that there are two objects selected.

Objects on different layers can be grouped into the same group. The group is created at the top of the 
current layer. The component objects are returned to their layers when you ungroup the group.

Shortcut:

    Related Topics



To ungroup objects

1. Select the group that you want to ungroup.

2. From the Object menu, select Ungroup. The group separates into its component objects, which remain 
selected.

You can also ungroup a group by right-clicking the Pointer tool on the group and selecting Ungroup from 
the shortcut menu that appears.

You can ungroup basic shapes and text to convert them into paths for editing.

Shortcut:

    Related Topics



To move objects 

1. From the toolbox, select the Pointer tool, then select the object that you want to move.

2. When the pointer changes shape to an arrow with a selected rectangle at its base, press the left mouse button 
and drag the object to its new position. As you drag the object, the original object and an outline of its new 
position are displayed.

3. Release the mouse button to redraw the object in its new position.

Note:

To move an object with a tool other than the Pointer tool, press the right mouse button and drag the object 
to its new position. As you drag the object, the original object and an outline of its new position are displayed. 

After releasing the right mouse button, select Move from the shortcut menu that appears.

The information line displays the displacement of the object, as you drag it.

Press Ctrl and drag the object to restrict movement of the object to an angle of 0, 45 or 90 degrees.

Press Alt and drag the object to make a copy of it when you release the mouse button.

You can also move an object using the Nudge Control or the Move Objects dialog box.

    Related Topics



To move objects using the nudge control

The nudge control lets you 'nudge' the selected object up and down, or left and right, in the same way as the cursor 
keys.

To nudge an object (or several objects, or group of objects), select it and then click on the appropriate part of the 
nudge control, to move in the appropriate direction.

Note:

You can specify the way in which the nudge control works (whether objects are nudged to grid divisions, or 
by a specific amount) in the General tab card of the Preferences dialog box.

The nudge control is disabled when you do not have anything selected in your drawing.

    Related Topics



To move objects using the Move Objects dialog box

1. Right -click the Pointer tool on the object and select Move/Copy from the shortcut menu that appears. The 
Move Objects dialog box appears.

2. Enter the horizontal and vertical dimensions by which you want to move the object and select the direction in 
which you want it to move.

3. To make a copy of the object and move the copy without moving the original, check the Copy Objects check 
box.

4. Click on OK to close the dialog box and move the object as you have specified.

Note:

You can also move multiple objects using this method.

You can create several copies of the same object and space them uniformly. Use the Move Objects dialog 
box to create the first copy, specifying the position of the copy in relation to the original. Then select Transform 
Again from the Edit menu (or press F5) to create another copy that will be spaced equidistant from the previous 
object. Keep pressing F5 until you have created all the copies that you need.

To move an object with a tool other than the Pointer tool, press the right mouse button and drag the object 
to its new position. As you drag the object, the original object and an outline of its new position are displayed.

After releasing the right mouse button, select Move from the shortcut menu that appears.

Shortcut:

    Related Topics



To position objects

1. From the toolbox, select the Pointer tool, then select the object that you want to position.

2. Right-click the Pointer tool on the object and select Object Properties from the shortcut menu that appears. The 
object properties dialog box for the selected object appears.

3. In the Position group box, specify the exact position for the object. The co-ordinates are specified from the ruler 
origin.

4. You can specify the position relative to the left, centre or right of the object horizontally, and the top, middle or 
bottom of the object vertically. Click on the drop-down list boxes to select an option.

Note:

The co-ordinates are specified from the top left-hand corner of the page, i.e. top left is given the co-ordinate 
0,0.

The relevant object properties dialog box can also be displayed by selecting Properties from the Object 
menu.

You cannot position multiple objects in this way. (Although you can position a group of objects.)

Shortcut:

    Related Topics



To move objects between layers

1. From the toolbox, select the Pointer tool, then select the object that you want to move to another layer.

2. From the Object menu, select To Layer. The Move Objects to Layer dialog box appears.

3. Select the target layer by clicking on the layer name in the Layer Names list box, or by selecting the layer 
number from the To Layer spin box. If the layer does not exist it will be created.

4. Click on OK.

Note:

If you create a new layer, its number is added to the list of layers.

The object remains selected, and the current layer does not change.

If only the current layer is displayed, the object will be hidden from view (though its selection handles remain 
visible until it is deselected).

You can also move objects between layers through the Object Properties dialog box.

    Related Topics



To move objects between layers using the Object properties dialog box

1. Select the object that you want to move to another layer.

2. Right-click the Pointer tool on the object and select Object Properties from the shortcut menu that appears. The 
object properties dialog box for the selected object appears.

3. Specify the target layer number in the Layer Number text box, then click on OK. If the layer does not exist, it is 
created.

Note:

You cannot move multiple objects in this way.

The relevant object properties dialog box can also be displayed by selecting Properties from the Object 
menu.

Shortcut:

    Related Topics



To display the rulers

1. From the View menu, select Show Controls.

2. Select Rulers from the submenu that appears.

You can use the rulers at the top and left-hand edges of your picture window to help size and position objects more 
accurately.

Note:

The command is ticked when the rulers are displayed. You can choose whether or not to have the rulers 
displayed for each window.

    Related Topics



Using the rulers: Information

You can use the rulers at the top and left-hand edges of your picture window to help size and position objects more 
accurately.

When the rulers are displayed, the unit of measurement used by the rulers is indicated at the top left-hand corner, 
where they intersect. To change the ruler units, click in this intersection area. A list of ruler options appears and you 
can select the unit of measurement that you prefer.

Alternately, you can change the units by selecting Units from the Options menu, and selecting the unit you want 
from the submenu.

You can move the rulers' origin, which is useful for precise sizing and positioning of the objects in your picture. To 
move the rulers' origin, click in the intersection area and select Adjust Ruler Origin, then click at the point where 
you want to origin to be, e.g. the top left-hand corner of the page box.

You can set the ruler origin back to its original position by clicking on the intersection area and selecting 
Reset Ruler Origin from the shortcut menu that appears.

Ruler units are assigned to a picture window. Changing the units in one window will not affect the units in 
another window.

Any dialog boxes that refer to unit of measurement will automatically use the unit of the rulers in the active 
window.

    Related Topics



To use the grid and snap control

1. From the View menu, select Grid. The Grid dialog box appears.

2. Check the Show Grid check box to display a grid.

3. Check the Snap to Grid check box to make objects align with the grid when the are drawn, moved or sized.

4. Check the Align to Page check box to make the grid align to the top left-hand corner of the page or check the 
Align to Ruler check box to align the grid to the ruler origin. (If the ruler origin is at the top left-hand corner of the 
page, Align to Ruler is disabled.)

5. From the Units drop-down list box, select the unit of measurement that you want the grid to use. This can be a 
different unit from the one used in the rulers.

6. In the Spacing group box, type the width and height of each grid cell. 

7. In the Divisions group box , specify the number of subdivisions across and down each cell. The greater the 
number of grid divisions, the finer the snapping control.

7. Click on the Copy button to copy the horizontal settings to the vertical settings, creating a square grid.

8. Click on OK to close the dialog box and create the grid you have just specified.

Note:

When Snap to Grid is on, objects will 'jump' to align themselves to the grid dimensions whenever they are 
drawn, moved, resized or transformed.

Shortcuts:

    Related Topics



To lock/unlock objects

Locking an object

1. From the toolbox, select the Pointer tool, then select the object that you want to lock.

2. From the Object menu, select Lock. The object's handles change colour, and the padlock in the information line 
and Object Tools indicates that the object is now locked.

Unlocking an object

1. Select the object that you want to unlock.

2. From the Object menu, select Unlock. The object's handles change back to their original colour, and the padlock 
in the information line and Object Tools indicates that the object is unlocked.

Note:

You can lock and unlock any type of object except individual points on a path.

You can also lock/unlock an object by checking/clearing the Locked check box in the Object Properties 
dialog box or by clicking on the Padlock icon in the information line next to the object description box

While an object is locked, you cannot manipulate it in any way.

Locked objects will remain locked when you save your picture.

Shortcuts:

    Related Topics



To hide/redisplay objects

1. From the toolbox, select the Pointer tool, then select the object that you want to hide.

2. From the Object menu, select Hide. The selected object is no longer displayed, and everything behind the object 
is visible.

To redisplay hidden objects.

From the Object menu, select Show All. All hidden objects are redisplayed, and become selected.

Note:

If Show All is disabled, there are no hidden objects in your picture.

If you have more than one object selected when you select Hide, all the selected objects are hidden.

You cannot select a hidden object.

When you print a picture that contains hidden objects, you can choose whether they should be printed or not 
in the Print Options dialog box.

When you save your picture the hide attribute is lost: When you next open the picture, the previously hidden 
objects will be displayed.

Keyboard Shortcuts: Ctrl H hides the selected objects; Ctrl W redisplays them.



To align objects 

1. From the toolbox, select the Pointer tool, then select the objects that you want to align.

2. From the Align Tools, click on the tool you want, e.g:

 

 

 

Using the Align Tools you can align the object(s) to each other or to the page in a variety of ways.

Note:

You can also align objects through the Align dialog box. To open the Align dialog box, select Align from the 
Object menu.

    Related Topics



To align objects using the Align dialog box

1. From the toolbox, select the Pointer tool, then select the objects that you want to align.

2. From the Object menu, select Align. The Align dialog box appears.

3. Select whether you want to align the objects to Each other or to the Page.

4. Make your selections from the Horizontal and Vertical group boxes. The preview box illustrates how your 
objects will align given the selections that you have made.

5. Click on OK. The objects are aligned according to your selections.

Note:

If only one object is selected, you can only align to page.

If one of the selected objects is locked when you align to each other, all the objects will align to the locked 
object; if one of the selected objects is locked when you align to the page, the locked object will not move to the new 
alignment position.

Shortcut:

    Related Topics



To overlap objects

Bringing an object to the front

1. From the toolbox, select the Pointer tool, then select the object that you want to bring to the front of your picture.

2. From the Object menu, select Bring To Front. The selected object is put on top of the objects that previously 
overlapped it and remains selected.

Sending an object to the back

1. Select the object that you want to send to the back of your picture.

2. From the Object menu, select Send To Back. The selected object is put beneath the objects that it previously 
overlapped and remains selected.

Note:

When a picture has more than one layer, Bring To Front and Send To Back apply to the current layer only. 
Sending an object to the back sends it to the back of the current layer.

Shortcuts:

    Related Topics



To cut objects

1. From the toolbox, select the Pointer tool, then select the object that you want to cut from the picture.

2. From the Edit menu, select Cut.

The selected object is removed from the picture and put on the Clipboard.

The object can then be put back into the same picture or another by using the Paste command.

Shortcut:

    Related Topics



To copy objects

1. From the toolbox, select the Pointer tool, then select the object that you want to copy.

2. From the Edit menu, select Copy.

The selected object is copied to the Clipboard, but not removed from the picture. 

The copy of the object can then be put back into the same picture or another by using the Paste command.

Note:

To copy an object within greenstreet Draw, we suggest that you press Alt and drag-and-drop a copy of the 
object, rather than use the Clipboard.

To copy an object with a tool other than the Pointer tool, press the right mouse button and drag the object to 
its new position. As you drag the object, the original object and an outline of its new position are displayed. 

After releasing the right mouse button, select Copy from the shortcut menu that appears.

Shortcut:

    Related Topics



To paste objects

1. Cut or copy an object to the Clipboard.

2. From the Edit menu, select Paste. The object on the Clipboard is copied into the picture.

Note:

The Paste command places an object into the picture at the position from which it was copied or cut. If the 
object is from a different picture, the object will be put in the current picture at the same position.

You cannot use the cut, copy and paste commands on individual points on a path. If you do have a point 
selected and use one of these commands, the whole path, not just the selected point, will be cut, copied or pasted. To 
delete a point, select it and press Backspace.

Shortcut:

    Related Topics



To paste inside an object

1. Cut or copy the object that you want to paste inside another object, onto the Clipboard.

2. Select the path that you want to paste the object inside.

3. From the Edit menu, select Cut+Paste Special. The Cut+Paste Special submenu appears.

4. Select Paste Inside. The object is pasted inside the closed path at its original position on the page.

If you cannot see the object inside the closed path, move the path over the position in which the object was put 
before you cut it to the Clipboard.

5. Manipulate the path so that the object appears as you want it.

Note:

If the Paste Inside command is disabled, either you do not have a single closed path selected, or the 
Clipboard is empty.

To paste inside a basic shape, e.g. a star or a circle, ungroup the shape to a path first.

You cannot select or manipulate an object that has been pasted inside a path.

    Related Topics



To cut from inside an object

1. Select the path you want to cut from. The path must have had something pasted inside it.

2. From the Edit menu, select Cut+Paste Special. The Cut+Paste Special submenu appears.

3. Select Cut Contents. The object is removed from within the path, and copied to the Clipboard. The path remains 
selected.

Note:

If you have just performed the Paste Inside command, you can also use the Undo command to cut the 
object from inside the path. 

To edit the object, paste it into your picture and make your edits. If you want, you can then cut and paste it 
back inside the path as described above.

    Related Topics



To paste in front of an object

1. Cut or copy the object that you want to paste onto the Clipboard.

2. Select the object that you want the pasted object to appear in front of. Make sure you have only one object 
selected.

3. From the Edit menu, select Cut+Paste Special. The Cut+Paste Special submenu appears.

4. Select Paste in Front.

The pasted object is displayed in front of the one you selected and behind any objects that were previously in front 
of the selected one.

    Related Topics



To paste behind an object

1. Cut or copy the object that you want to paste onto the Clipboard.

2. Select the object that you want the pasted object to appear behind. Make sure you have only one object 
selected.

3. From the Edit menu, select Cut+Paste Special. The Cut+Paste Special submenu appears.

4. Select Paste Behind.

The pasted object is displayed behind the one you selected, and in front of any objects that were previously behind 
the selected one.

    Related Topics



To insert a point

1. From the toolbox, select the Pointer tool, then select the path that you want to edit. The points on the path are 
displayed as small black boxes.

2. Select any of the drawing tools except the Pencil tool. Which tool you use depends upon the type of point that 
you want to insert. Use the Corner tool to insert a corner point, the Connect tool to insert a connect point, or the 
Curve tool to insert a curve point.

3. Position the tool on the path where you want to insert a point, and click the mouse button. A point is inserted on 
the path. The new point is selected and any other points on the path that were previously selected are 
deselected. You can manipulate the point as you would any other.

Note:

If you do not click exactly on the path when you try to insert a point in it, the path is deselected and a point 
appears on its own. The information line will indicate that there is an open path of 1 point.

    Related Topics



To add a point to the end of a path

1. From the toolbox, select the Pointer tool, then select the path to which you want to add a point. The points on the 
path are displayed as small black boxes.

2. Select the point at one end of the open path. Ensure that only one point is selected.

3. Select the drawing tool for the point you wish to add. Use the Corner tool to add a corner point, the Connect tool 
to add a connect point, or the Curve tool to add a curve point.

4. Click where you want to add the point. A point is added and the path drawn between the existing end point and 
the new point. The new end point is selected and the old end point deselected.

Note:

To close an open path, repeat Steps 1 to 3 above, and then click on the other end point of the open path.

    Related Topics



To delete a point

1. From the toolbox, select the Pointer tool, then select the path from which you want to delete a point. The points 
on the path are displayed as small black boxes.

2. Select the point or points that you want to delete.

3. Right-click the pointer on one of the selected points to display the path shortcut menu.

4. Select Delete Points. The selected points are deleted from the path and the path is redrawn without them.

Note:

You can also delete points by selecting the points that you want to delete, then pressing Backspace.

Deleting a point on a closed path does not convert it into an open path.

    Related Topics



To move a point

1. From the toolbox, select the Pointer tool, then press the left mouse button and drag the point to its new position.

2. Release the mouse button when the point is in the right place. The path is redrawn through the new point.

Note:

While you drag the point, both the new path shape and the original are displayed.

When you have more than one point selected, drag one of them to its new position; the selected points 
remain in the same position relative to each other, and the other points are redrawn.

You cannot make a copy of an individual point on a path. When you move a point, holding down Alt as you 
drag will make a copy of the whole path, even if you only move one of the points.

You can also move a point using the Nudge Control.

    Related Topics



To adjust control points

1. From the toolbox, select the Pointer tool, then select the point that you want to adjust. The control points and 
control lines of the selected point appear.

2. Point at one of the control points, then press the left mouse button and drag the control point to its new position. 
The new path and the original are displayed.

3. Release the mouse button when you have the shape you want. The path is redrawn.

Note:

Not all points on a path have control points. A curve point always has control points; a connect point may 
have one or two control points, depending upon the style of the adjacent points. A corner point does not have control 
points by default.

If no control points are displayed when you select the point, either they do not exist, or they are hidden by 
the point to which they belong. You can make the control points appear by holding Ctrl while you drag the pointer 
away from the point.

    Related Topics



To change a point style

1. From the toolbox, select the Pointer tool, then select the point or points that you want to change.

2. Right-click the Pointer tool on one of the selected points. The path shortcut menu appears.

3. From this shortcut menu, select Object Properties. The Path Properties dialog box appears.

The Points Selected group box tells you how many points are selected and indicates their style. If the selected 
points have different styles, the group box does not indicate a style.

4. Select the point style you want.

5. If you want the path to be drawn smoothly through the point, check the Auto Curvature check box.

6. Click on OK. The style of the point is changed, and the path is redrawn if the style change affects it. The points 
remain selected.

Note:

You can also display the Path Properties dialog box by selecting the point, then selecting Properties from 
the Object menu.

Shortcut:

    Related Topics



To split a path

1. From the toolbox, select the Pointer tool, then select the path that you want to split.

2. Select the point at which you want to split the path, or if there is no point at the place where you want to split the 
path, insert a point there.

3. Right-click the Pointer tool on the selected point. The path shortcut menu appears.

4. From the path shortcut menu, select Split Path. The two sub-paths are redrawn and the end points of the two 
new paths become selected.

Note:

The split path may still look like a single path. Deselect one of them, then drag one away from the other to 
avoid confusion.

You can turn a closed path into an open path by splitting the path. This change is indicated in the information 
line.

You cannot split points on a compound path: You must first ungroup it into separate paths.

Shortcut:

    Related Topics



To join one path to another

1. From the toolbox, select the Pointer tool.

2. Select a path, then press the left mouse button and drag the path so that the end point is close to the end point of 
the path that you want to join it to.

3. Select the two end points that you want to join.

4. From the Object menu, select Join. The two paths are joined together and become one object.

Note:

The end points of the paths must be within the user defined join range to enable the Join command. You 
can change the join range in the Preferences dialog box.

You cannot join more than two paths together at the same point.

You can only join paths at their end points.

Shortcut:

    Related Topics



To combine paths (compound paths)

1. From the toolbox, select the Pointer tool, then select the paths that you want to combine.

2. From the Object menu, select Combine. The paths are combined to produce a compound path.

Note:

The compound path may not appear any different than the original paths. This depends upon what attributes 
you had selected for each path. Fill styles and colours may change depending upon where the combined paths were 
in relation to each other, e.g. inside or overlapping.

Compound paths can only be made up of closed paths. You cannot combine an open path, a group, a 
bitmap, a basic shape or text (unless it is ungrouped).

Keyboard Shortcut: Ctrl M

    Related Topics



To blend objects

1. From the toolbox, select the Pointer tool.

2. Hold down Shift and click on the two objects that you want to blend. The objects are selected.

3. From the Edit menu, select Blend. The Blend dialog box appears.

4. In the No. of Blend stages check box, type the number of blend stages you want.

5. Adjust the values of the First Stage and the Last Stage as necessary. Normally these values should remain at 
the defaults, which depend on the number of blend stages.

6. Click on OK. The two objects are blended together.

Note:

If the two objects are coloured, each blend stage is given an intermediate colour.

You can only blend between two paths or shapes. You cannot use blend on bitmaps, groups of objects, or 
text (unless it is ungrouped).

Always try a smaller rather than a larger number of blend stages first, because a blend with many stages 
may take a long time to display.

    Related Topics



To change the blend effect

You can change the effect of a blend by changing the reference points of a transformation.

1. Select the two paths to blend.

2. Select a point on one or both of the paths. If you only specify one point, greenstreet Draw automatically uses the 
first point on the other path as the reference point.

3. From the Edit menu, select Blend, and specify your blend needs. You can create interesting blend effects. For 
example:

Note:

If you do not specify a reference point, the first points on the paths are used.

    Related Topics



To scale an object

1. Select the object that you want to scale, then select the Scale tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be. The fixed point is the origin of 
the transformation and appears as a small +.

3. Drag the pointer in the appropriate direction:

To change the height of the object, drag the pointer vertically

To change the width of the object, drag the pointer horizontally

To change both the height and width, drag the pointer diagonally.
An outline of the scaled object follows the movements of the pointer so that you can see the effect you are 

creating.
4. Release the mouse button when the object is scaled as you want. The object is redrawn with the scaling 
factor you have specified.

Scaling tools:

    Related Topics



Scaling an object: Hints

You can use the Double Size and Halve Size tools to exactly double or halve the size of a selected object 
(or several objects, or group of objects).

When you scale an object, the information line displays the current scaling factor in the horizontal (sx) and 
vertical (sy) directions.

The fixed point for the origin of transformation can be anywhere in the picture window.

If not all the points on a path are selected, only the selected points will be scaled.

You can scale the whole picture by selecting Select All from the Edit menu to select all the objects in the 
picture, then applying the transformation to them.

If the object you have scaled is a text object, you can still edit the text using the Text tool.

To scale an object more accurately, select the object then double-click the Scale tool anywhere in the picture 
window. The Scale dialog box appears enabling you to make precise changes to the size of the object.

    Related Topics



To rotate an object

1. Select the object that you want to rotate, then select the Rotate tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be. The fixed point is the origin of 
the transformation and appears as a small +. The fixed point can be anywhere in the picture window.

3. Drag the pointer in any direction. An outline of the rotated object follows the movements of the pointer so that you 
can see the effect you are creating.

4. Release the mouse button when the object is rotated as you want. The object is redrawn with the rotation you 
have specified.

Rotate Tools:

    Related Topics



Rotating an object: Hints

For greater control when rotating, drag the pointer further away from the fixed point.

When you rotate an object, the information line displays the current angle of rotation.

If not all the points on a path are selected, only the selected points will be rotated.

You can rotate the whole picture by selecting Select All from the Edit menu to select all the objects in the 
picture, then applying the transformation to them.

If the object you have rotated is a text object, you can still edit the text using the Text tool.

To rotate an object more accurately, select the object then double-click the Rotate tool anywhere in the 
picture window. The Rotate dialog box appears enabling you to make precise changes to the angle of rotation.

    Related Topics



To skew an object

1. Select the object that you want to skew, then select the Skew tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be. The fixed point is the origin of 
the transformation and appears as a small +. The fixed point can be anywhere in the picture window.

3. Drag the pointer in the appropriate direction:

Dragging the pointer to the right skews the points above the fixed point to the right, and points below the 
fixed point to the left. Dragging to the left reverses this effect.

Dragging the pointer upwards skews the points to the right of the fixed point upwards, and points to the left 
of the fixed point downwards. Dragging downwards reverses this effect.

An outline of the skewed object follows the movements of the pointer so that you can see the effect you are 
creating.
4. Release the mouse button when the object is skewed as you want. The object is redrawn with the size and 
shape you have specified.

Skew Tools:

    Related Topics



Skewing an object: Hints

When you skew an object, the information line displays the current skew factor in the horizontal (sx) and 
vertical (sy) directions.

If not all the points on a path are selected, only the selected points will be skewed.

You can skew the whole picture by selecting Select All from the Edit menu to select all the objects in the 
picture, then applying the transformation to them.

If the object you have skewed is a text object, you can still edit the text using the Text tool.

To skew an object more accurately, select the object then double-click the Skew tool anywhere in the picture 
window. The Skew dialog box appears enabling you to specify the exact horizontal and vertical skew factors you 
want.

    Related Topics



To reflect an object

1. Select the object that you want to reflect, then select the Reflect tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be. The fixed point is the origin of 
the transformation and appears as a small +. The fixed point can be anywhere in the picture window.

3. Drag the pointer in any direction. An outline of the reflected object follows the movements of the pointer so that 
you can see the effect you are creating.

4. Release the mouse button when the object is reflected as you want. The object is redrawn with the angle of 
reflection you have specified.

Reflect Tools:

    Related Topics



Reflecting an object: Hints

For greater control when reflecting, drag the pointer further away from the fixed point.

When you reflect an object, the information line displays the current angle of reflection.

If not all the points on a path are selected, only the selected points will be reflected.

You can reflect the whole picture by selecting Select All from the Edit menu to select all the objects in the 
picture, then applying the transformation to them.

If the object you have reflected is a text object, you can still edit the text using the Text tool.

To reflect an object more accurately, select the object then double-click the Reflect tool anywhere in the 
picture window. The Reflect dialog box appears enabling you to specify which axis the object is reflected across.

    Related Topics



To copy as you transform

Hold down Alt as you click on the tool you want in the Transform Tools, or as you drag the pointer of the 
selected transform tool around the fixed point.

Note:

Release the mouse button before releasing Alt.

Holding down Alt and Ctrl while you drag creates a copy of the transformed object and restricts the angle of 
transformation to multiples of 45 degrees.

    Related Topics



To control the angle of transformation

Hold down Ctrl as you drag the pointer of the selected Transform tool around the fixed point.

The angle of a transformation is restricted to multiples of 45 degrees.

Note:

Release the mouse button before releasing Ctrl.

Holding down Ctrl and Alt while you drag restricts the angle of transformation to multiples of 45 degrees and 
creates a copy of the transformed object. 

You can use the Transform Tools to quickly and easily transform objects by specified amounts at the click of 
a button.

    Related Topics



To repeat a transformation

From the Edit menu, select Transform Again.

Note:

If you hold down Alt during the original transformation, repeating the transformation again will produce a 
copy of the transformed object and transform it again.

You can repeat a transformation on another object. For example, if you scale a polygon, you can then select 
a star and perform the same transformation on it by selecting Transform Again from the Edit menu.

Shortcut:

    Related Topics



To display the colour bar

1. From the View menu, select Show Controls.

2. From the Show Controls submenu, select Colour Bar.

This command is ticked when the colour bar is displayed.

Note:

To close the colour bar, select Colour Bar again.

Use the scroll arrows at either end of the colour bar to browse through all the available colours.

The information line displays the name of the colour currently under the mouse pointer.

    Related Topics



To use the colour bar

You can use the colour bar in a number of ways:

To change the fill colour of an object, select the object, then click the left mouse button on the colour you 
want.

To give an object no fill style, select the object, then click the left mouse button on the X button at the left-
hand end of the colour bar.

To change the colour of an objects line style, select the object, then click the right mouse button on the 
colour you want.

To give an object no line style, select the object, then click the right mouse button on the X button at the left-
hand end of the colour bar.

To change the "to colour" of a graduated fill style, select the object, hold down Shift, then click the left 
mouse button on the colour you want. (If you are using a mouse with three buttons and have a suitable Windows 
driver, you can use the middle button to select the "to colour".)

To edit a colour in the colour bar, double-click on the appropriate colour to display the Edit Colour dialog 
box.

To add a new colour to the colour bar, click on the + button to display the New Colour dialog box.

    Related Topics



Colour bar: Information

The colour bar is displayed at the bottom of the desktop, and it contains the colours available to the picture in the 
active window.

Any new colours you create will be added to the colour bar.

You can turn the colour bar on and off by selecting Colour Bar from the submenu that appears when you 
select Show Controls from the View menu. The command is ticked when the colour bar is displayed.

The colour bar displays a number of tints of each colour; you can specify the number of tints in the Edit 
Colours dialog box.

    Related Topics



To apply colour

1. Select the object that you want to colour.

2. To change the colour of the object's line style, select Colour from the Line menu to display the drop-down colour 
palette, then click on the colour you want.

Alternately, if you have the colour bar displayed at the bottom of the desktop, click the right mouse button on the 
colour you want.

3. To change the colour of the object's fill style, select Colour from the Fill menu to display the drop-down colour 
palette, then click on the colour you want. When an object has a graduated fill, i.e. a fill style fading from one 
colour to another, select To Colour from the Fill menu, then click on the 'to' colour you want.

4. The selected object is given the colours you have specified.

Note:

You can also use the colour bar to apply colour to an object.

If the colours aren't displayed, your picture is in outline format. From the View menu, select Preview to 
change the display to preview format.

Clicking on the X button at the left-hand end of the colour bar turns the fill or line style off depending on 
whether you click the left or right mouse button on it.

Shortcut:

    Related Topics



To create a new colour

1. From the Edit menu, select Edit Colours. The Edit Colours dialog box appears.

2. Scroll through the list of colours and select the colour on which you want to base your new colour.

3. Click on Add. The New Colour dialog box appears.

4. In the Name text box, type a name for the colour.

5. In the Model group box, select a colour model, then modify the colour as necessary. Refer to the dialog box help 
for more information on mixing colours.

6. If your page format has been set up for colour separation, the Spot Colour check box appears on this dialog 
box. Check this box to save the colour as a spot colour.

7. Click on OK to confirm the new colour and return to the Edit Colours dialog box.

8. Click on OK in the Edit Colours dialog box to confirm your edits.

Note:

When you create a new colour, the colour is added to the colour bar.

The New Colour dialog box can also be displayed by clicking on the + button to the right-hand end of the 
colour bar.

Shortcut:

    Related Topics



To edit an existing colour

1. From the Edit menu, select Edit Colours. The Edit Colours dialog box appears.

2. Scroll through the list of colours and select the colour on which you want to base your new colour.

3. Click on Edit. The Edit Colour dialog box appears.

4. In the Model group box, select a colour model, then modify the colour as necessary. Refer to the dialog box help 
for more information on mixing colours.

5. If your page format has been set up for colour separation, the Spot Colour check box appears on this dialog 
box. Check this box to save the colour as a spot colour. 

6. Click on OK to confirm the new colour and return to the Edit Colours dialog box.

7. Click on OK in the Edit Colours dialog box to confirm your edits. 

Note:

When you create a new colour, the colour is added to the colour bar.

When you edit an existing colour, any objects styled with that colour are redrawn and styled with the edited 
colour.

The Edit Colour dialog box can also be displayed by double-clicking on a colour in the colour bar.

Shortcut:

    Related Topics



To delete an existing colour

1. From the Edit menu, select Edit Colours. The Edit Colours dialog box appears.

2. Scroll through the list of colours in the Names box and select the colour(s) that you want to delete. The colour 
appears in the preview box.

3. Click on Delete. The colour is removed from the Names box and the preview box becomes empty.

4. Click on OK to confirm the deletion and remove the colour from the colour bar and palette.

Note:

You can delete any colour except Black. When you delete a colour, it is removed from the colour bar of the 
picture in the active window, and also from its associated colour palette.

When you delete a colour that is applied to an object in your picture, the colour used for the object is 
replaced with black.

Shortcut:

    Related Topics



To save a colour palette

greenstreet Draw is supplied with a default colour palette. You can create more colours to add to this colour palette 
or you can delete colours if you do not want to use them.

1. From the Edit menu, select Edit Colours. The Edit Colours dialog box appears.

2. Modify the colour palette as necessary by adding new colours or deleting colours that you do not want to use.

3. When the colour palette contains all the colours that you want to save, click on Save. The Save Colours dialog 
box appears.

4. Select the disk drive and folder in which you want to save the colour palette.

5. Type a name for the colour palette in the File Name text box. Colour palettes are given the file extension .COL 
by default, but you can change this to another file extension if you prefer.

5. Click on Save to save the colour palette and return to the Edit Colours dialog box.

6. Click on OK to close the Edit Colours dialog box and continue working with the colour palette you have just 
saved.

Note:

You can load the saved palette into greenstreet Draw when you begin a new picture or when you want to 
add more colours to an existing picture.

Shortcut:

    Related Topics



To load a colour palette

1. From the Edit menu, select Edit Colours. The Edit Colours dialog box appears.

2. Click on Load. The Load Colours dialog box appears.

3. Select the palette that you want to load and click on Open.

The colours in the palette are added to the list of colours in the Names box on the Edit Colours dialog box.

4. Click on OK to close the Edit Colours dialog box.

Note:

Colours in the palette that you are loading do not overwrite existing colours of the same name.

Shortcut:

    Related Topics



To apply line styles

1. Select the object that you want to style.

2. From the Line menu, select Popup Lines. The Line Style popup appears.

3. Select a line style from those listed in the Line Style popup.

4. Click on Apply to give the line style to the selected object.

Note:

If the line style isn't displayed, the picture may be in outline format. Select Preview from the View menu to 
change the display to preview format.

You can choose not to have a line style for a selected object by selecting None from the Line menu, or by 
clicking the right mouse button on the X at the left-hand end of the colour bar.

The current line style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this line style.

You can also select a line style from the Named Style submenu in the Line menu.

Shortcuts:

 

    Related Topics



To apply fill styles

1. Select the object that you want to style.

2. From the Fill menu, select Popup Fills. The Fill Style popup appears.

3. Select a fill style from those listed in the Fill Style popup.

4. Click on Apply to give the fill style to the selected object.

Note:

You cannot apply fill styles to open paths, arcs or groups.

If the fill style isn't displayed, the picture is in outline format. Select Preview from the View menu to change 
the display to preview format.

You can choose not to have a fill style for the selected object by selecting None from the Fill menu, or by 
clicking the left mouse button on the X at the left-hand end of the colour bar.

The current fill style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this fill style.

You can also select a fill style from the Named Style submenu in the Fill menu.

Shortcuts:

 

    Related Topics



To create a new line style

1. From the Line menu, select Popup Lines. The Line Style popup appears.

2. Below the Name and Delete buttons are three Style drop-down list boxes. From these list boxes select the line 
style that you want and whether you want arrowheads at the beginning or end of the line.

If you have selected Custom from the centre drop-down list box, click on >> to expand the popup. You can then 
type the lengths of the dashes and gaps for your new line style.

3. Change the width of the line style by dragging the Width control, or by typing the precise size in the Width text 
box.

4. From the drop-down colour palette, select the colour that you want. Change the tint of the colour by dragging the 
Tint selector.

5. From the Ends drop-down list box, select the style of line end that you want. 

6. From the Join drop-down list box, select the style of line join you want. If you have selected a Mitre line join, click 
on >> to expand the popup, then enter the minimum angle at which you want joins to be mitred. Joins below this 
angle will be bevelled instead of mitred.

7. If your page format has been set up for colour separation, the Overprint check box appears. Check this box to 
enable overprinting when producing colour separations.

8. Click on Name. The Name Style dialog box appears, where you can type a name for your style. 

9. Click on OK to save the line style.

    Related Topics



Creating a line style: Information

When you create a new line style, the line style is added to the list in the Line Style popup.

When you edit an existing line style, any objects styled with that line style are redrawn with the edited style.

When you create a line style for a selected object, you do not have to give a name to the style. However, if 
you do not give the style a name, the style will not be added to the list in the Line Style popup.

When you save a picture, it is saved with the line styles currently listed in the Line Style popup. If you want 
to use the new line style in other pictures you must save it into a template.

    Related Topics



To create a PostScript line style

1. From the Line menu, select Popup Lines. The Line Style popup appears.

2. Below the Name and Delete buttons are three Style drop-down list boxes. From the centre drop-down list box 
select PostScript.

3. Click on >> to expand the popup, then click on PostScript. The PostScript Styles dialog box appears.

4. Scroll through the list of available PostScript line styles in the Styles list box and select a style.

5. If necessary, change the values in the boxes below the Description box.

6. Click on OK to confirm the PostScript line style you have selected and return to the Line Style popup. Select the 
other settings on the Line Style popup as you want.

7. Click on Name. The Name Style dialog box appears. Type a name for the line style in the Name box.

8. Click on OK to save the line style.

Note:

The PostScript line style is added to the list of styles in the Line Style popup. Since PostScript line styles 
cannot be displayed on screen it is represented by a criss-cross line style.

Any object that is styled with that line style will be drawn with a criss-cross line style, but it will print correctly.

You can only print PostScript line styles to PostScript printers.

    Related Topics



To create a new fill style

1. From the Fill menu, select Popup Fills. The Fill Style popup appears.

2. Below the Name and Delete buttons there is the Style list box. From this list box, select the type of fill style that 
you want, e.g. plain, linear or radial.

When you select a linear, logarithmic or cylindrical style, an arrow appears over the fill style in the preview box. 
Drag this arrow to adjust the angle of the fill style. Press Ctrl while dragging to restrict the angle to multiples of 15 
degrees.

3. From the drop-down colour palette, select the colour that you want. Change the tint of the colour by dragging the 
Tint selector.

If you have selected a graduated fill style, you can choose 'from' and 'to' colours for the fill style and specify the 
Tint of each. The fill will then be a blend from one colour to the other.

4. If your page format has been set up for colour separation, the Overprint check box appears. Check this box to 
enable overprinting when producing colour separations.

5. Click on Name. The Name Style dialog box appears, where you can type a name for the fill style.

6. Click on OK to save the fill style.

Shortcut:

    Related Topics



Creating a fill style: Information

When you create a new fill style, the fill style is added to the list in the Fill Style popup.

When you edit an existing fill style, any objects styled with that fill style are redrawn with the edited style.

When you create a fill style for a selected object, you do not have to give a name to the style. However, if 
you do not give the style a name, the style will not be added to the list in the Fill Style popup.

When you save a picture, it is saved with the fill styles currently listed in the Fill Style popup. If you want to 
use the new fill style in other pictures you must save it into a template.

    Related Topics



To create a halftone fill style

1. From the Fill menu, select Popup Fills. The Fill Style popup appears.

2. Click on >> to expand the popup, and then click on Halftone. The PostScript Halftone Screen dialog box 
appears. (If Halftone is disabled you have PostScript selected in the Style list box.)

3. If you do not want to use the default settings, clear the Default settings check box. The Screen group box is 
enabled.

4. Scroll through the list in the Type box and select the shape you want. 

5. Change the frequency of the selected shape by clicking the arrows next to the Frequency spin box, or by typing 
a value directly into the box. Change the angle at which the shape will be printed by clicking the arrows next to 
the Angle spin box, or by typing a value directly into the box.

6. Click on OK to confirm the halftone selections you have made and return to the Fill Style popup. Select the other 
settings on the Fill Style popup as you want.

7. Click on Name. The Name Style dialog box appears, where you can type a name for the fill style.

8. Click on OK to save the fill style.

Note:

You can only print halftone fill styles to PostScript printers.

Shortcut:

    Related Topics



To create a PostScript fill style

1. From the Fill menu, select Popup Fills. The Fill Style popup appears.

2. Below the Name and Delete button is the Styles list box. From this list box select PostScript.

3. Click on >> to expand the popup, then click on PostScript. The PostScript Styles dialog box appears.

4. Scroll through the list of available PostScript fill styles and select a style.

5. If necessary, change the values in the boxes below the Description box.

6. Click on OK to confirm the PostScript fill style you have selected and return to the Fill Style popup. Select the 
other settings on the Fill Style popup as you want.

7. Click on Name. The Name Style dialog box appears. If necessary, type a name for the fill style in the Name box.

8. Click on OK to save the fill style.

Note:

The PostScript fill style is added to the list of styles in the Fill Style popup. Since PostScript fill styles cannot 
be displayed on screen it is represented by the letters PS on a black background.

Any object that is styled with a PostScript fill style will be represented on screen by a diagonal striped fill 
style, but it will be printed correctly.

You can only print PostScript fill styles to PostScript printers.

    Related Topics



To delete line and fill styles

1. Select Popup Lines from the Line menu, or Popup Fills from the Fill menu, to display the Line or Fill Style 
popup.

2. Select the line or fill style that you want to delete.

3. Click on Delete to delete the style. The style is then removed from the list of available styles.

Note:

When you delete a style that is applied to objects in your picture, the style is not lost from those objects but it 
becomes unnamed and is no longer listed in the popups.

Shortcuts:

    Related Topics



To create a pattern

1. Select the group of objects you want to make into a pattern.

2. From the Fill menu, select Pattern. The Tile Pattern dialog box appears.

3. Type a name for the pattern in the Name box.

4. Make any adjustments you need to the scale, angle and offsets.

5. Click on OK. The pattern is added to the list of fill styles in the Fill menu and the Fill Style popup.

    Related Topics



Creating patterns: Information

The Pattern command in the Fill menu is disabled if you do not have a group of objects selected.

To edit a pattern, select the pattern from the list in the Fill Style popup, then click on Pattern. The Tile 
Pattern dialog box appears. Make the necessary changes and click on OK.

You can delete a pattern in the same way as any other fill style.

To make a pattern from a group of objects that includes an imported bitmap, you must first autotrace the 
bitmap then include the traced path in the group rather than the actual bitmap.

To make a pattern from a text object, you must group the text object.

    Related Topics



To import greenstreet Draw's clipart

Click on the Utilities button in the General Tools and select the Picture Browser icon.

From the Picture Browser you can locate and select a piece of greenstreet Draw clipart to import into your picture.

Note:

The Picture Browser is a separate utility that is supplied with greenstreet Draw. Refer to the Help supplied 
with the Picture Browser for further information on how to use it.

You can also run the Picture Browser from the Start menu.

Shortcut:

    Related Topics



To import graphics

1. From the File menu, select Import File. The Import from File dialog box appears.

2. Select the disk drive and folder in which the graphic has been saved.

3. From the Files of Type drop-down list box, select the type of file you want to import. The files of that type in the 
current folder are displayed in the Folders list box.

4. From the Folders list box, select the file that you want to import.

5. Click on Open.

Note:

To import a bitmap for tracing, select For Tracing before clicking on OK. This places the bitmap on Layer 
Zero (the picture must be multi-layered for this check box to appear).

To smooth line-art during import, select Smoothing and an appropriate Smoothness setting before clicking 
on OK. Use smoothing if you are likely to ungroup the line-art you are importing.

Imported line-art appears as a group of objects.

You can also drag a graphic file from Windows Explorer and drop it into your greenstreet Draw picture. Refer 
to your Microsoft Windows 95 User's Guide for further information.

Shortcut:

 

    Related Topics



To colour a bitmap

1. Select the bitmap you want to colour.

2. Select a colour from the colour bar. The bitmap is redrawn in the selected colour.

A second colour can be applied by specifying a fill style for the bitmap:

1. Select the bitmap.

2. Give the bitmap a graduated fill style. The foreground of the bitmap is coloured with the "from" colour, and the 
background is coloured with the "to" colour.

Note:

You can only colour monochrome bitmaps.

An autotraced path can be manipulated and coloured like any greenstreet Draw object, but the original 
bitmap can only have one foreground colour and one background colour.

    Related Topics



To transform a bitmap

When you have imported a bitmap it can be transformed in the same way as any other greenstreet Draw object, but 
the effect of the skew, rotate and reflect transformations are not displayed. These transformations are represented 
by a box rather than the transformed bitmap itself.

The box is labelled with the file name of the bitmap, and a flag indicates the current orientation. If you print the 
picture, the bitmap will be transformed correctly.

Note:

Transformed bitmaps can only be printed to a PostScript printer.

Scaled bitmaps are displayed correctly.

    Related Topics



 To autotrace a bitmap

1. When you import the bitmap you want to trace make sure that the For Tracing check box in the Import from File 
dialog box is checked.

1. From the toolbox, select the Autotrace tool. 

2. Click on (or near) the edge of the bitmap. A path is drawn around the bitmap.

This path can now be manipulated like any other object

    Related Topics



Autotracing a bitmap: Information

Only one area of the bitmap will be autotraced; if the bitmap consists of more than one area, the area 
nearest to the point at which you clicked will be autotraced. You must autotrace each area individually.

You can autotrace a hole in a bitmap by clicking anywhere within the hole. This creates a closed path.

If you click and drag across a section of the bitmap, only part of the bitmap will be autotraced. This creates 
an open path.

If a fill style is selected, the path will be filled.

Not all bitmaps will autotrace well. A high-contrast, well defined bitmap will autotrace well; a low-contrast 
bitmap will not.

You can adjust the accuracy of the Autotrace tool by double-clicking on the tool in the toolbox. The 
Autotrace dialog box appears. Adjust the smoothness value as necessary and click on OK.

    Related Topics



To export graphics

1. Select the objects that you want to export.

2. From the File menu, select Export to File. The Export to File dialog box appears.

3. Select the disk drive and folder in which you want to save the graphic.

4. Select the file format to export to by clicking on the Save as Type drop-down list box. All the files of this type are 
listed in the Folders list box.

5. Select the number of colours in which you want to export the graphic from the Colours drop-down list box.

6. If you want to export the whole picture, check the All Objects check box. If you leave this box cleared, only the 
selected objects will be exported.

7. If you are exporting in one of the bitmap file formats, you can specify its resolution. Enter the value in the 
Resolution box. This box is disabled if the graphic is not being exported in a bitmap file format.

8. In the File Name text box, type the file name that you want to export the graphic to, then click on OK.

Note:

You must export your file as an Encapsulated PostScript file if you want it printed by a printing bureau.

If you omit the file extension, it is added automatically.

We recommend that you use OLE to transfer and copy greenstreet Draw objects to other Windows 
programs. Where this isn't possible an alternate route is to use the Windows Clipboard.

Shortcut:

    Related Topics



Using OLE

OLE is a feature that allows you to transfer and share files between Windows programs. You can link or embed a 
greenstreet Draw picture into any program that accepts OLE objects, e.g. greenstreet Publisher, and then edit it 
without leaving that program.

Applications that support OLE fall into two categories:

Programs whose objects can be embedded or linked into other files, called servers

Programs that can accept embedded or linked objects, called containers.

Some programs may be both a server and a container; others are either one or the other. greenstreet Draw is a 
server program only; you can link or embed greenstreet Draw pictures into a container, but you cannot embed other 
OLE objects into greenstreet Draw.

greenstreet Draw supports OLE 2, which allows in-place editing and dragging and dropping of greenstreet Draw 
objects into OLE containers.

Refer to the documentation of your other Windows programs to establish their level (if any) of OLE support.

greenstreet Draw uses a special handler to display embedded files in your picture. Using the greenstreet Draw 
handler allows faster and more accurate rendering of an embedded file. If the greenstreet Draw handler is 
deselected, greenstreet Draw displays a Windows Metafile version of embedded files.

We recommend that you have the greenstreet Draw handler selected at all times unless you experience problems 
when displaying or printing embedded greenstreet Draw pictures.

    Related Topics



To embed an existing greenstreet Draw object

1. Start greenstreet Draw and open the picture containing the object that you want to embed.

2. Select the object or picture, then select Copy from the Edit menu.

3. If it is not already running start the OLE container, e.g. greenstreet Publisher, and open the file into which you 
want to embed the object.

4. In the container, select Paste Special from the Edit menu. The Paste Special dialog box appears.

5. Select greenstreet Draw Picture from the As list box, then click on Paste.

6. Click on OK to embed the object.

Most OLE containers will embed the object if you select Paste directly from the Edit menu; please refer to 
the documentation of your container for further details. 

When you embed a greenstreet Draw object, a copy of the object file is made and stored within the OLE 
container: The original file is not altered in any way and remains available for future use.

The command names in the container will differ when embedding to an OLE container; please refer to the 
documentation of your container for further details.

Please refer to the documentation of your OLE container for details of how to edit an embedded greenstreet 
Draw object.

Shortcut:

    Related Topics



To embed a new greenstreet Draw object

1. Start the OLE container and open the file into which you want to embed the greenstreet Draw object.

2. From the Edit menu, select Insert Object. The Insert Object dialog box appears listing all the programs on your 
computer that support OLE.

3. From the Object Type list box, select greenstreet Draw Picture and click on OK.

greenstreet Draw will either be opened in a separate window for you to create your picture, or the greenstreet Draw 
menus and toolbars will replace those of the container, allowing you to create your picture within the container 
window; this is called in-place editing. Please refer to the documentation of your OLE container for specific details of 
that particular program.

When you embed a greenstreet Draw object, a copy of the object file is made and stored within the OLE 
container: The original file is not altered in any way and remains available for future use.

The command names in the container will differ when embedding to an OLE container; please refer to the 
documentation of your container for further details.

Please refer to the documentation of your OLE container for details of how to edit an embedded greenstreet 
Draw object.

    Related Topics



To link a greenstreet Draw object

1. Start greenstreet Draw and create the object, or open the picture that contains the object you want to link.

If you have opened an existing picture and do not want it changed, save it under a new name before proceeding. 
If you are creating a new object, you must save it to a file before you can create a link with the container.

2. Select the object or picture, then select Copy from the Edit menu.

3. If it is not already running, start the OLE container and open the file into which you want to link the object.

4. In the OLE container, select Paste Special from the Edit menu. The Paste Special dialog box appears.

5. Select greenstreet Draw Picture from the As list box, then click on Paste Link.

6. Click on OK to link the object.

Note:

The command names on the Paste Special dialog box will differ when linking to an OLE container; please 
refer to the documentation of your container for further details.

Please refer to the documentation of your OLE container client program for details of how to edit a linked 
greenstreet Draw object.

Shortcut:

    Related Topics



To drag-and-drop a greenstreet Draw object

1. Start greenstreet Draw and ensure that the OLE container is running either as a window or an icon.

2. Arrange the windows on your screen so that both greenstreet Draw and the container window or icon are visible.

3. In greenstreet Draw, create the object, or open the picture that contains the object you want to link or embed.

4. Select the object, then press the left mouse button and drag the object onto the container window or icon.

5. To embed the object in the container, release the mouse button; to link the object in the container, hold down Ctrl 
Shift and then release the mouse button.

Note:

Please refer to the documentation of your OLE container for full details of its drag-and-drop support; the 
precise method for dragging and dropping may differ slightly in some containers. For example, you may find that the 
key-combination used for linking isn't Ctrl Shift.

You can also drag-and-drop objects between picture windows within greenstreet Draw.

    Related Topics



To send your picture to an electronic mail program

From the File menu, select Send Mail. A copy of your picture is saved as a temporary file and your MAPI 
compatible electronic mail program (e.g. Microsoft Network) is started.

When your electronic mail program appears on the desktop, a new message is created and the temporary 
file is attached to it, leaving you to type the address and message text.

    Related Topics



To setup up your printer

1. From the File menu, select Print Setup. The Print Setup dialog box appears.

2. In the Printer group box, select the printer you want to use from the Name drop-down list box.

3. Click on Properties to display a dialog box providing various options for the selected printer. This dialog box 
originates from the printer driver and is specific to the selected printer.

Select the appropriate options on this dialog box, then click on OK to return to the Print Setup dialog box.

4. From the Size drop-down list box, specify the paper size that you want to print to.

5. From the Source drop-down list box, select the paper source.

6. From the Orientation group box, select portrait or landscape.

7. Click on OK again. The new printer will remain selected until you change it.

Note:

The default paper size depends on your printer driver’s default paper size.

The Print Setup dialog box can also be displayed by clicking on Print Setup in the Print Options dialog 
box.

    Related Topics



To print a picture

1. From the File menu, select Print. The Print Options dialog box appears.

2. From the Output group box choose whether to print the picture to disk or to the specified printer and the number 
of copies to be printed.

3. Click on Print Setup to display the Print Setup dialog box. From this dialog box you can specify a different 
printer and the paper source, orientation etc.

4. In the Scaling group box, select the scale size that you want for your printed picture. Select Fit Page to scale the 
picture so that the whole page fits into the printable area, select Actual Size to print the picture at its actual size 
or select Scale and enter a value to scale the picture to a specific size.

5. From the Layers group box, select which layers of the picture to print (if you have set your picture to be multi-
layered).

6. In the Picture to Page group box, the number of pages that your picture will be printed over is given. If this is 
more than one, check the Allow Tiling check box so that the picture is printed in tiles tiling over several pages.

Each tile of a tiled picture is printed with crop and registration marks so that you can align the tiles to create the 
complete picture.

From the same group box, you can check the Flip Orientation check box if you need to print a landscape picture 
onto a portrait page, or vice versa.

7. From the Options group box, check the options that you want.

8. Click on OK to print the picture.

Note:

If part of your picture seems to be missing, check that all the objects in the picture are within the page box.

Shortcut:

    Related Topics



To print to disk

1. From the File menu, select Print. The Print Options dialog box appears.

2. In the Output group box, select Print to Disk.

3. Select any other options you want on this dialog box and click on OK. The Print to Disk dialog box appears.

4. Specify a folder and name for the file.

5. Select the format for the file from the Save as Type drop-down list box.

6. Click on OK. The file is printed to disk with the name you have chosen.

Note:

You will need to print your picture to disk as a PostScript file (.EPS) if you intend having it printed by a printer 
bureau.

If you want to print the file out at a later date, exit to the DOS prompt and use the DOS COPY command to 
print the file. (Refer to your DOS manual for details of the COPY command).

To print your picture to disk as a PostScript file you must have a PostScript printer driver selected.

Shortcut:

    Related Topics



To use crop and registration marks

1. From the File menu, select Print. The Print Options dialog box appears.

2. Check the Crop & registration marks check box in the Options group box.

3. Select any other options as necessary, then click on OK.

Note:

When the picture is printed you can cut along the crop marks to produce the correctly sized paper. For 
example, when a picture designed to fit on a note size page is printed on letter size paper, the crop marks indicate 
where the paper must be cut.

Crop marks will be printed only if the picture is tiled or if the picture is smaller than the paper on which it is 
printed. 

A tiled picture is automatically given crop and registration marks even when they aren't selected.

Shortcut:

    Related Topics



To print reversed and negative pictures

1. From the File menu, select Print. The Print Options dialog box appears.

2. Check the Reversed and/or Negative check boxes as necessary in the Options group box.

3. Select any other options you need, then click on OK.

When you prepare a picture for commercial printing, you may need to produce your artwork as a negative and/or 
reversed image. Check with your commercial printer to determine the type of artwork necessary for your job.

Note:

When printing to film, you will probably need to select Reversed and Negative; when printing to paper, you 
won't usually need either of these settings.

Reversed and Negative are only available when printing to a PostScript printer.

Shortcut:

    Related Topics



To print in halftone

1. From the File menu, select Print. The Print Options dialog box appears.

2. Check the Halftone Screen check box in the Options group box.

3. Select any other options you need, then click on OK.

Note:

When printing a colour picture on a monochrome printer, the grey scales that represent the colours are 
sometimes badly contrasted. Creating a halftone screen improves the way that colours are represented to produce a 
smooth grey scale effect.

The Halftone Screen option is disabled when printing to a PostScript printer. However, you can give 
individual fill styles halftone attributes using the PostScript Halftone Screen dialog box.

Shortcut:

    Related Topics



To print colour separations

1. Ensure that the picture is prepared for colour separation by checking the Colour Separation check box in the 
Page Format dialog box.

2. To print a colour as an individual separation, ensure that it has been saved as a spot colour in the Edit Colours 
dialog box. To avoid misalignment of spot colour separations, select overprinting for individual line and fill styles.

3. From the File menu, select Print. The Print Options dialog box appears.

4. Check the Colour Separation check box in the Options group box, and select any other options that you want. 
If this check box is disabled, you do not have a PostScript printer selected.

5. Click on OK. The Colour Separation dialog box appears.

6. In the Separations list box, select which separations you want to print by checking or clearing the This 
separation check box as necessary. The separations selected for printing are indicated by an asterisk (*).

7. As each separation is selected, the Angle and Frequency of the separation appears in the Halftone Screen 
group box. Do not adjust these figures unless advised to do so by your print bureau.

8. When all the separations are selected, click on OK.

Note:

You can only print colour separations to a PostScript printer or to disk as a PostScript file.
 

    Related Topics



To solve printing difficulties

When your printer won't print, the cause is often a simple mechanical problem such as the printer being 
disconnected or the paper being jammed.

Use the following checklist to help find the problem:

Is the printer plugged in, switched on and on-line?

Is the correct printer selected on the Print Setup dialog box?

Are the settings correct? For example, have you chosen a paper source that has paper in it?

Is the printer jammed, or do you need to add paper?

Is the printer active?

Is the printer correctly set up on the Windows Control Panel?

Do you have the correct cable for your printer and is it properly connected to your computer?

Is the ribbon correctly threaded (if your printer uses one) or do you need to change it? Do you need to 
change the ink cartridge?

If you complete this checklist and still can't print anything, quit greenstreet Draw and try to print a file from a different 
program. If this prints correctly, contact Customer Services; it may be that greenstreet Draw is having difficulty 
printing to that particular printer. However, if you can't print from another program the problem may lie in the printer, 
printer cable or your Windows setup. Try connecting the printer again, and if that doesn't help, contact your printer 
manufacturer or dealer.

    Related Topics



File menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to create a new picture. The New Picture Options dialog box appears, giving you a 
choice of running a pilot, loading a template, starting from a blank page, or reading more about these options in the 
New User Guide.



Click on this menu command to open a picture that you have previously saved. The Open dialog box appears 
unless you have changed the settings in the Preferences dialog box so that the Open an Existing File tab card of 
the New Picture Options dialog box appears.



Click on this menu command to save the picture in the active window with its current filename. If the picture is 
untitled, the Save As dialog box appears and you must type a name for the picture. Click on the Summary Info 
button if you want to save information about the picture, such as the creator, a title, and any keywords.



Click on this menu command to name a new picture or to save the picture in the active window under a different 
filename. The Save As dialog box appears. Click on the Summary Info button if you want to save information about 
the picture, such as the creator, a title, and any keywords.



Click on this menu command to close the active window. If there are any unsaved changes, a message appears 
asking if you want to save the changes. Click on Yes or No as appropriate, or Cancel to abandon the Close 
command.



Click on this menu command to import a graphic file into your picture. The Import from File dialog box appears. 
Select the format of the graphic that you want to import then select the filename.



Click on this menu command to save all or part of a picture in a variety of formats. The Export to File dialog box 
appears. Select the format in which you want to save the picture then enter a filename. You can then import the file 
into other pictures or programs.



Click on this menu command to save the current picture to a temporary file and start up your electronic mail 
program. Once your electronic mail program has opened, a new message will be created and the temporary file will 
be attached to it.

In order for this option to be enabled, you need to have a MAPI-compatible electronic mail program installed e.g. 
Microsoft Exchange.



Click on this menu command to enter or view information about the current picture e.g. date saved, author etc. The 
Summary Info dialog box appears. You can also access this dialog box from the Save As dialog box so that you 
can enter information about the current picture when you save it, and from the Open dialog box.



Click on this menu command to select the page format for the picture in the active window. The Page Format dialog 
box appears.

Select the page size and orientation, specify whether the picture will be single or multi-layered, and whether you will 
be using colour separation.



Click on this menu command to print the picture in the active window. The Print Options dialog box appears, from 
where you can make several choices about how your picture is printed, e.g. number of copies to print, crop and 
registration marks, colour separation etc.



Click on this menu command to select which printer your picture is printed to and to control the printer's settings. 
The Print Setup dialog box appears. 

You can set up any of the printers listed on this dialog box to print your greenstreet Draw pictures.



These commands are the filenames of the most recently opened pictures. Select the command that is associated to 
the picture that you want to open. The picture appears in a window on the greenstreet Draw desktop.

You can have up to 20 recently opened pictures listed in the File menu. Specify the number on the Startup 
tab card of the Preferences dialog box.



Click on this menu command to close greenstreet Draw. If there are any open pictures with unsaved changes, a 
message appears giving you the option of saving the pictures before greenstreet Draw is closed.



Edit menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to abandon the last command. You can undo up to fifty commands.

You cannot undo commands that do not change your pictures' content, e.g. opening a picture, scrolling the window, 
changing view size or making selections on a dialog box.



Click on this menu command to abandon the previous Undo command. You can redo up to fifty Undo commands.



Click on this menu command to remove the selected objects from the picture and put them on the Clipboard ready 
to be pasted to another location. Cut is available only when there are unlocked objects selected.



Click on this menu command to copy the selected objects to the Clipboard without removing them from the picture. 
Copy is available only when there are unlocked objects selected.



Click on this menu command to put the contents of the Clipboard into the active window. You can repeatedly paste 
the contents of the Clipboard until you cut or copy another object. Paste is available only when there is something 
on the Clipboard to be pasted.



Edit menu: Cut+Paste Special

Click on this menu command to display a submenu that allows you to cut and paste objects relative to other objects, 
e.g. inside a closed path, in front of selected objects, or behind selected objects.

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to put the contents of the Clipboard inside the selected closed path. The pasted 
objects will be clipped by the shape of the path.



Click on this menu command to remove the objects that were pasted inside the selected closed path and put them 
on the Clipboard.



 Click on this menu command to put the contents of the Clipboard in front of the selected object, but behind any 
objects that are already in front of the selected object.



Click on this menu command to put the contents of the Clipboard behind the selected object, but in front of any 
objects that are already behind the selected object.



Click on this menu command to delete the contents of the Clipboard.



Click on this menu command to add, modify or delete the colours in your picture. The Edit Colours dialog box 
appears.

You can save colour palettes that you can later load into new pictures that you create.



Click on this menu command to select all the objects in the active window except hidden objects and objects on 
layers that are not currently visible.



Click on this menu command to repeat the last transformation that you carried out. The transformation is performed 
on the currently selected objects. If the original transformation created a copy of the object while transforming, 
repeating it will also create a copy.



Click on this menu command to blend two selected objects together. The Blend dialog box appears. Enter the 
number of blend stages you need to determine the number of intermediate paths drawn between the two objects. 
Any applied line styles, fill styles and colours will be blended.



View menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to toggle between preview format and outline format for the picture in the active 
window. A picture displayed in preview format will show all applied line styles, fill styles and colours; a picture 
displayed in outline format will represent all objects in the same thin line style without any applied line styles, fill 
styles or colours. When the command is ticked, the picture is displayed in preview format.



Click on this menu command to display a picture's colours as shades of grey when displayed in preview format. 
This lets you see what the picture will look like when printed on a monochrome printer. When the command is 
ticked, the colours are displayed as shades of grey.



Click on this menu command to toggle between hiding or displaying layer zero for the picture in the active window. 
Layer zero usually contains objects that you intend to trace around. When the command is ticked, layer zero is 
displayed.

The command is disabled if your picture has been drawn on a single layer only.



Click on this menu command to toggle between displaying all the layers or just the current layer of the picture in the 
active window. When the command is ticked, all the layers are displayed.

The command is disabled if your picture has been drawn on a single layer only.



Click on this menu command to display the picture in the active window at its actual view size.

You can also achieve this by selecting 100% from the submenu that appears when you click on the Set View Size 
control at the left of the horizontal scroll bar.



Click on this menu command to display the picture in the active window so that its whole page is in view.

You can also select this command from the submenu that appears when you click on the Set View Size control at 
the left of the horizontal scroll bar.



Click on this command to increase the view size of the picture in the active window to the next standard view size.



Click on this command to decrease the view size of the picture in the active window to the next standard view size.



View menu: Show Controls

Click on this menu command to display a submenu that allows you to change the display of the desktop.

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to turn the display of the General Tools on and off. This command is ticked when the 
General Tools are displayed.



Click on this menu command to turn the display of the Transform Tools on and off. This command is ticked when the 
Transform Tools are displayed.



Click on this menu command to turn the display of the Object Tools on and off. This command is ticked when the 
Object Tools are displayed.



Click on this menu command to turn the display of the Align Tools on and off. This command is ticked when the 
Align Tools are displayed.



Click on this menu command to turn the display of the nudge control on and off. Initially it is displayed at the top 
right of the greenstreet Draw window, but it can be made to float on the greenstreet Draw desktop. This command is 
ticked when the nudge control is displayed.



Click on this menu command to turn the display of the rulers on or off for the picture in the active window. When the 
command is ticked, the rulers are displayed along the top and down the left-hand side of the picture window.



Click on this menu command to turn the display of the colour bar on or off. When the command is ticked, the colour 
bar is displayed at the bottom of the greenstreet Draw desktop.



Click on this menu command to turn the display of the information line on or off. When the command is ticked, the 
information line is displayed at the bottom of the greenstreet Draw desktop.



Click on this menu command to turn the display of all controls on or off.



Click on this menu command to display the Grid dialog box. A grid can help you align objects and judge their size. 
Any settings that you select apply to the picture in the active window only, you can have different settings for each 
picture window. The grid does not form part of your picture and is not printed.



Click on this menu command to add or delete layers, to rename a layer or to make another layer the current layer 
for the picture in the active window. The Layers dialog box appears.

The command is disabled if your picture has been drawn on a single layer only. It can be enabled by checking the 
Multi-layer check box in the Page Format dialog box.



Object menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to move the selected objects to the front of their layer.



Click on this menu command to move the selected objects to the back of their layer. 



Click on this menu command to move the selected objects to a specific layer. The Move Objects to Layer dialog 
box appears. Select the layer to which you want to move the objects. If the layer does not exist, it will be created.

The command is disabled if your picture has been drawn on a single layer only.



Click on this menu command to merge the selected objects into a group. You can then manipulate all the objects 
together as a single object.

Locked objects cannot be grouped.



Click on this menu command to separate a group of objects into its components. The Ungroup command has 
different effects depending on the type of object that you have selected:

Ungrouping a group separates it into its constituent objects.

Ungrouping a shape converts it into a path.

Ungrouping a text object converts each character into a path.

Ungrouping a compound path converts it into a number of simple paths.



Click on this menu command to join two objects together. The Join command has different effects depending on the 
type of objects you have selected:

When the end points of open paths are selected and within the join range, the Join command joins the end 
points together. When you join together the end points of an open path, it becomes a closed path. The Join 
command will only work when you have two points selected that are within the join range.

When a text object and a path are selected, the Join command flows the text along the path.



Click on this menu command to break a path at the selected point or points. An open path will be split into two 
shorter paths, while a closed path will become an open path. You cannot split a compound path.

If you have text on a path selected, the Split command separates the text from the path. 



Click on this menu command to combine two or more paths into a compound path, i.e. a path consisting of more 
than one contour. The area that can be filled depends on the combination of subpaths.



Click on this menu command to lock the selected objects in place. A locked object cannot be moved, transformed or 
included in a group. When you lock an object the colour of its handles change to indicate that the object is locked.

Locked objects will remain locked when you save your picture.



Click on this menu command to unlock the selected objects.



Click on this menu command to hide the selected objects from view, making it easier to edit the picture behind and 
around the object. Hidden objects cannot be selected.

When you save your picture the hide attribute is lost: When you next open the picture, the previously hidden objects 
will appear.



Click on this menu command to redisplay all the hidden objects in your picture.



Click on this menu command to align the selected objects to each other or to the page. The Align dialog box 
appears.

If one of the selected objects is locked when you align objects to each other, all the objects will align to the locked 
object. If one of the selected objects is locked when you align objects to the page, the locked object will not be 
realigned.



Click on this menu command to display a dialog box providing information about the selected objects. The 
information in this dialog box varies depending on the objects that are selected.



Line menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



 Click on this menu command to display the Line Style popup. This allows you to create, modify or delete line styles 
and apply them to selected objects.

The Line Style popup can be resized, allowing you to view more line styles simultaneously. To close the popup, 
click on the Control-menu icon.



Click on this menu command to turn the line style off for the selected object, or for objects that you are about to 
draw. The command is ticked when there is no line style selected.

You can also right-click on the X button at the left-hand end of the colour bar to turn off the line style.



Click on this menu command to apply a solid line style to the selected object, or to objects that you are about to 
draw. The command is ticked when a solid line style is selected.



Click on this menu command to apply a dashed line style to the selected object, or to objects that you are about to 
draw. Select one of four dashed styles from the submenu that appears. The command is ticked when a dashed line 
style is selected.



Click on this menu command to apply a very fine line style to the selected object, or to objects that you are about to 
draw. The command is ticked when a hairline line style is selected.



Click on this menu command to apply a line style with a 1pt width to the selected object, or to objects that you are 
about to draw. The command is ticked when a 1pt line style is selected.



Click on this menu command to apply a different width to the line style of the selected object, or to objects that you 
are about to draw. Select one of six widths from the submenu that appears. The command is ticked when one of 
these widths is selected.



Click on this menu command to display a drop-down colour palette. Click on a colour within the palette to apply that 
colour to the line style of the selected object, or to objects that you are about to draw.

When you want to create a new colour, click on the + button. The New Colour dialog box appears from where you 
can mix a new colour to add to your picture.



Click on this menu command to display the Line Ends dialog box. Choose the type of arrowhead design you want 
(if any) for each end of the line, and the shape of the line ends and joins. Arrowheads are not displayed on closed 
paths and shapes.



Click on this menu command to display a list of all the named line styles for the picture in the active window. Click 
on a line style within that list to apply it to the selected object, or to objects that you are about to draw.



Fill menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to display the Fill Style popup. This allows you to create, modify or delete fill styles 
and apply them to selected objects.

The Fill Style popup can be resized, allowing you to view more fill styles simultaneously. To close the popup, click 
on the Control-menu icon.



Click on this menu command to turn the fill style off for the selected object, or for objects that you are about to draw. 
The command is ticked when there is no fill style selected.

You can also left-click on the X button at the left-hand end of the colour bar to turn off the fill style.



Click on this menu command to apply a plain fill style to the selected object, or to objects that you are about to draw. 
The command is ticked when a plain fill style is selected.



Click on this menu command to apply a linear fill style to the selected object, or to objects that you are about to 
draw. The command is ticked when a linear fill style is selected.



Click on this menu command to apply a logarithmic fill style to the selected object, or to objects that you are about 
to draw. The command is ticked when a logarithmic fill style is selected.



Click on this menu command to apply a cylindrical fill style to the selected object, or to objects that you are about to 
draw. The command is ticked when a cylindrical fill style is selected.



Click on this menu command to apply a radial fill style to the selected object, or to objects that you are about to 
draw. The command is ticked when a radial fill style is selected.



Click on this menu command to apply a spherical fill style to the selected object, or to objects that you are about to 
draw. The command is ticked when a spherical fill style is selected.



Click on this menu command to apply a random fill style to the selected object, or to objects that you are about to 
draw. The command is ticked when a random fill style is selected.



Click on this menu command to tile a selected group of objects and save them as a fill style. The Tile Pattern dialog 
box appears. Type a name for the pattern and adjust the Scale and Angle values as necessary. The pattern is 
added to the list of fill styles and can be applied to a selected object in the same way as a fill style.

The command is disabled until you have selected one or more objects and grouped them.



Click on this menu command to display the drop-down colour palette. Click on a colour within the palette to apply 
that colour to the fill style of the selected object, or to objects that you are about to draw.

When you want to create a new colour, click on the + button. The New Colour dialog box appears, from where you 
can mix a new colour to add to your picture.

When applying a colour to a graduated fill style, this is the 'from' colour, i.e. the colour of the fill style will fade 'from' 
this one to the next.



Click on this menu command to apply a 'to' colour to a graduated fill style. The drop-down colour palette appears. 
Click on a colour within the palette to apply that colour to the fill style of the selected object, or to objects that you 
are about to draw. The fill style will fade to this colour according to your chosen graduation.

When you want to create a new colour, click on the + button. The New Colour dialog box appears from where you 
can mix a new colour to add to your picture.



Click on this menu command to display a list of all the named fill styles for the picture in the active window. Click on 
a fill style within that list to apply it to the selected object, or to objects that you are about to draw.



Options menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Options menu: Units

Click on this menu command to display a submenu that allows you to select the unit of measurement you want to 
use for the active picture.

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to show all rulers and measurements in centimetres. This includes measurements 
given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for each 
picture you have open, and the rulers and dialog boxes will change as you switch between pictures.



Click on this menu command to show all rulers and measurements in inches divided into tenths. This includes 
measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for each 
picture you have open, and the rulers and dialog boxes will change as you switch between pictures.



Click on this menu command to show all rulers and measurements in inches divided into eighths. This includes 
measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for each 
picture you have open, and the rulers and dialog boxes will change as you switch between pictures.



Click on this menu command to show all rulers and measurements in picas and points. This includes 
measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for each 
picture you have open, and the rulers and dialog boxes will change as you switch between pictures.



Click on this menu command to specify options that include the way in which greenstreet Draw starts up, the display 
of each new picture window, the display quality of a picture in preview format, and so on. The Preferences dialog 
box appears.



Click on this menu command to return the toolbars to their default positions and settings. You can then drag them 
around to position them as you want.

This command is also available in the shortcut menu that appears when you right-click on any of the toolbars.



Click on this menu command to give each of the docked toolbars a weighting or importance. When auto 
arrangement is turned on and you drag the docked toolbars around, they snap to one end or the other of the 
docking area, depending on the toolbar. This is designed to help you position the toolbars for ease of use.

This command is also available in the shortcut menu that appears when you right-click on any of the toolbars.



When you select the Text tool, the Text Tools appear.

Click on this menu command if you want the Text Tools to replace the Object Tools. Deselect this option if you want 
the Text Tools to be shown in addition to the Object Tools.



Window menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to open a new window on the current picture.

You can have up to eight windows open on any one picture, and up to twenty windows open in total.



Click on this menu command to arrange the picture windows so that they overlap, with the title bar and left-hand 
edge of each window remaining visible.



Click on this menu command to arrange the picture windows so that they are all visible on the desktop and do not 
overlap.



greenstreet Draw displays a listing of currently open picture windows at the bottom of the Window menu. Select 
one of these pictures to make that picture active. The currently active window is marked with a tick.

You can have up to twenty pictures, or twenty windows, open at any one time.



Help menu

Click on the command for which you want Help.

Hint: 

When you highlight a menu command in greenstreet Draw, the information line at the bottom of the desktop 
displays a prompt for how to use that command.

    Related Topics



Click on this menu command to display the Help Topics dialog box. From this dialog box, you can select the area 
of greenstreet Draw you want help on.



Click on this menu command to display the Search dialog box. From this dialog box you can search for and select 
the specific subject on which you need help. It is similar to using the index of a book to look up a subject about 
which you want information.



Click on this menu command to display information aimed specifically at new users of greenstreet Draw.



Click on this menu command to display information that explains the features that are new in this version of 
greenstreet Draw.



Click on this menu command to display a list of general topics that explain 'how to' carry out tasks in greenstreet 
Draw. Select the general topic you want to learn about then select the more precise topic from the list that appears.



Click on this menu command to display information that explains what all the greenstreet Draw buttons do. Select 
whether you want to look at information about the toolbox, one of the toolbars or the nudge control. The appropriate 
set of tools or buttons is then displayed; click on the buttons to popup a brief explanation of each one.



Click on this menu command to display Help on every menu command in greenstreet Draw. Click on the menu that 
you want to look at, then select the specific command in that menu. The information displayed will explain what the 
command is for and when to use it.



Click on this menu command to display a list of the keyboard shortcuts available in greenstreet Draw.



Click on this menu command to open a small window containing definitions of all the terms and phrases you are 
likely to encounter when using greenstreet Draw. Click on a word to popup its definition.



Click on this menu command to display any last-minute information that is not explained in the greenstreet Draw 
main help. We recommend that you read this information carefully.



Click on this menu command to display information about using greenstreet Draw Help and learn how to navigate 
your way around the Help information available.



Click on this menu command to display the Help pointer. Position the pointer over an item on the greenstreet Draw 
desktop, for example, a tool or menu command, and click the mouse button. Help appears about the item you 
select.



Click on this menu command to turn the display of the ToolTips on or off. ToolTips appear when you rest the pointer 
over a button or tool for a couple of seconds, and they give the name of the button or tool.

This command is ticked when the ToolTips are displayed.



Click on this menu command to turn the display of the getting started hints on or off. These hints appear when you 
select a tool from the toolbox. This command is ticked when the getting started hints are displayed.



Cue cards appear at the end of the PagePilot to help you with the basic steps of finalising your logo. Click on this 
menu command to turn the display of cue cards on or off. When the command is ticked, cue cards will appear at the 
end of the PagePilot.



Click on this menu command to display the greenstreet Draw billboard. This shows the version number of your copy 
of greenstreet Draw and a copyright notice.



Click on this menu command to display the picture in the active window at quarter its actual size.



Click on this menu command to display the picture in the active window at half its actual size.



Click on this menu command to display the picture in the active window at its actual size.

You can also achieve this view by selecting Actual Size from the View menu.



Click on this menu command to display the picture in the active window at twice its actual size.



Click on this menu command to display the picture in the active window at four times its actual size.



Click on this menu command to display the picture in the active window at eight times its actual size.



Click on this menu command to display the picture in the active window at sixteen times its actual size.



Click on this menu command to display the picture in the active window so that its whole page is in view.

You can also achieve this view by selecting Whole Page from the View menu.



Click on this menu command to display the picture in the active window so that the width of the page takes up the 
full width of the window.



Click on this menu command to display the picture in the active window so that the selected object(s) take up as 
much of the view as possible. This command is disabled if you have no objects selected.



A Fill style with this name already exists. Do you wish to overwrite it?

You have tried to save a fill style with a name that you’ve already used. If you do not want to overwrite the existing 
file, click on No then enter a different name on the Name Style dialog box. If you do want to overwrite the existing 
file, click on Yes; any objects filled with the original style will now be filled with the new fill style.



A Line style with this name already exists. Do you want to overwrite it?

You have tried to save a line style with a name that you’ve already used. If you do not want to overwrite the existing 
line style, click on No then enter a different name on the Name Style dialog box. If you do want to overwrite the 
existing line style, click on Yes; any objects drawn with the original style will now be drawn with the new line style.



Abandon Printout?

Your picture has not yet finished printing - do you really want to abandon it? Click on No to let printing resume. Click 
on Yes to abandon printing.



Bitmap too complex for Autotrace

greenstreet Draw has run out of memory while trying to trace a path over the bitmap you are autotracing. Try to free 
more memory for greenstreet Draw then autotrace the bitmap again. If you still get this message, try any of the 
following:

Autotracing the bitmap in sections

Increasing the smoothness of the autotrace tool to make the traced path less detailed (double-click on the 
Autotrace tool to display the Autotrace dialog box)

Tracing the bitmap manually using the drawing tools.



Cannot Align: No objects selected

You have not selected any objects so there are no objects to align. Select the objects you want to align then try 
using the Align command again. Bear in mind that if one of the selected objects is locked, it will not move; instead 
the other objects will align to it.



Cannot Copy: No unlocked objects selected

You haven’t selected any objects to copy, or the objects that you have selected are locked. Either select the objects 
you want to copy, or unlock the objects that you have already selected. Then try the Copy command again.



Cannot create Printer Device Context!

greenstreet Draw has tried to print your picture but couldn’t. This could be for several reasons:

You do not have a printer selected

You have too many files open in greenstreet Draw or Windows so there is not enough memory for 
greenstreet Draw to print the picture

Your Windows system resources are running low so there is not enough memory for greenstreet Draw to 
print the picture

Your printer driver is causing the error

There are several measures you can take to try to fix this problem. Start with the first suggestion then if it doesn’t fix 
the problem, work your way through the other suggestions:

Set up your printer again using the Print Setup command in the greenstreet Draw File menu

Close greenstreet Draw then restart it and try printing the picture again

Close greenstreet Draw and Windows, the restart them and try printing the picture again

Try printing another Windows application such as Write. If that doesn’t work the problem lies in your printer 
driver, not greenstreet Draw. Try reinstalling your printer driver. If the problem persists, contact your printer 
manufacturer for assistance

Contact technical support.



Cannot Cut: No unlocked objects selected

You haven’t selected any objects to cut, or the objects that you have selected are locked. Either select the objects 
that you want to cut, or unlock the objects that you have already selected. Then try the Cut command again.



Cannot Group: No objects selected

You haven’t selected any objects to group, or the objects that you have selected are locked. Either select the 
objects you want to group, or unlock the objects that you have already selected. Then try the Group command 
again.



Cannot Join: Select two nearby path ends, or path and text

This message can be displayed for several reasons:

The end points on the path that you are trying to join are not close enough together. Either move the points 
closer together or adjust the Join Range setting on the General tab of the Preferences dialog box so that they are 
within the range for being joined.

You do not have any end points on the paths selected. Except when joining text to a path, you must select 
an end point on each path that you want to join; the two points will be replaced with one point, joining the paths 
together.

You have tried to join more than two paths together. In this case make sure you only have two paths 
selected then try the Join command again.

The objects you have tried to join are not open paths, e.g. they may be shapes that haven’t been 
ungrouped. In this case, select each object and click on the Ungroup button to ensure that each object is an open 
path, not a shape. If one of the objects is text, do not ungroup it. Now try the Join command again.



Cannot Lock or Unlock: No objects selected

You haven’t selected any objects to be locked or unlocked. Select some objects then try again.



Cannot Move To Back: No unlocked objects selected

You haven’t selected any objects to move to the back, or the objects that you have selected are locked. Either 
select the objects that you want to move, or unlock the objects that you have already selected. Then try the Send 
To Back command again.



Cannot Move To Front: No unlocked objects selected

You haven’t selected any objects to move to the front, or the objects that you have selected are locked. Either 
select the objects that you want to move or unlock the objects that you have already selected. Then try the Bring To 
Front command again.



Cannot Paste: Nothing on clipboard to paste

There’s nothing on the clipboard for greenstreet Draw to paste into the picture. Either you haven’t yet cut or copied 
anything to the clipboard, so there’s nothing for greenstreet Draw to paste. Or maybe you deleted an object instead 
of cutting it; deleted objects cannot be pasted back into the picture.

Alternatively, greenstreet Draw may not be able to interpret the item on the clipboard.



Cannot perform Print Setup. Check that a printer is selected in the Windows Control Panel.

greenstreet Draw has been unable to find a printer in your Windows setup. Using the Windows Control Panel, check 
that you have installed at least one printer and that one is setup as the default printer. When you have setup a 
default printer, try selecting the Print Setup command again.



Cannot read “FILENAME”!

This message occurs when greenstreet Draw cannot find one of its program files. The file might have been deleted 
after you installed greenstreet Draw or the installation was not completed successfully. To overcome this problem, 
reinstall the greenstreet Draw program.



Cannot Redo: There is nothing to redo.

You have not yet done a command that can be redone. Commands that cannot be undone or redone include file 
operations, changing view size, selecting tools, moving the floating toolbox and toolbars, and moving between 
picture windows.



Cannot Show Object Properties: No objects selected

You have not selected an object so greenstreet Draw cannot display the relevant object properties dialog box. 
Select the object that you want information about, then try the Properties command again.



Cannot Split: Select text on a path or the point at which to split path

This message can appear for a couple of reasons:

You have selected a path but not the point at which you want to split the path. Select the point on the path 
and then try the Split command again.

The object that you are trying to split is not a path. It maybe a shape that has not yet been ungrouped into a 
path. Ungroup the object and select at least one point on it, then try the Split command again.



Cannot Transform Again: No transformation to repeat

You have not yet carried out a transform command (rotating, reflecting, skewing, scaling or moving) so there is no 
transformation for greenstreet Draw to repeat. When you have transformed an object, try the Transform Again 
command again.



Cannot Undo: There is nothing to undo.

You have not yet carried out a command that can be undone. Commands that cannot be undone or redone include 
file operations, changing view size, selecting tools, moving the floating toolbox and toolbars, and moving between 
picture windows.



Cannot Ungroup: Select an unlocked group or shape to ungroup

This message can appear for several reasons:

You haven’t selected any objects to ungroup, or the objects that you have selected are locked. Either select 
the objects that you want to ungroup, or unlock the objects that you have selected. Then try the Ungroup command 
again.

The object that you have selected is already ungrouped.

The object cannot be ungrouped, e.g. bitmap images or EPSF files.



CommDlg error code

This message may occur if your computer system is very short of memory or other system resources when you try 
to open or save a file.

Your copy of the file COMMDLG.DLL is out of date. You have probably installed some software after greenstreet 
Draw and it has copied an old version of COMMDLG.DLL into your \WINDOWS\SYSTEM folder. Install the 
greenstreet Draw program again to copy the latest file back onto your Windows setup. Also, check that there isn’t a 
version of COMMDLG.DLL in your \WINDOWS folder or elsewhere in your search path - if there is, delete it.



Error - unable to ... create window/undo command/redo command

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try again.

Error - unable to execute command.

This message can appear for three reasons:

You have tried to open a faulty file.

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try 
again.

There is a problem with the greenstreet Draw program. If the message persists, contact Customer Services 
noting precisely what it is you do that causes the message to appear.



Error code ‘NNN’

This message can occur for two reasons:

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try 
again.

There is a problem with the greenstreet Draw program. If the message persists, note precisely what you do 
before the message appears and the error number displayed on the message, then contact Customer Services.



Error during registration: file ‘FILENAME’ not found. Check installation.

Some files are missing from your greenstreet Draw installation. greenstreet Draw may be able to run without them, 
but you will not be able to use greenstreet Draw OLE features or run the PagePilot. We recommend that you 
reinstall the greenstreet Draw program to ensure that the files are installed and greenstreet Draw can run properly.



Error: this file needs a more up-to-date version of the program!

The picture you are trying to open was created in a later version of greenstreet Draw and cannot be opened in this 
version. Either upgrade your copy of greenstreet Draw or work on the picture using the copy of greenstreet Draw in 
which it was created.

For upgrade details, contact Customer Services.



Error: Too many objects to cut or copy

The objects you have selected are too large. Select fewer objects then try the cut or copy command again.



Error: Unable to print

This message can occur for a number of reasons. Use the checklist below to work out what is going wrong:

Is the printer plugged in, switched on and on-line?

Is the correct printer selected on the Print Setup dialog box? Are the settings correct? For example, have 
you chosen a paper source that has paper in it?

Is the printer jammed, or do you need to add paper?

Is the printer active? (Check this using the Windows Print Manager.)

Is the printer correctly set up on the Windows Control Panel?

Is the printer capable of printing graphics?

Do you have the correct cable for your printer and is it properly connected to your computer?

Is the ribbon correctly threaded (if your printer uses one) or do you need to change it? Do you need to 
change the ink cartridge?

Are your system resources running low? Have you got loads of files and programs open? If necessary, close 
Windows, restart greenstreet Draw, and then try printing again.

If you complete this checklist and still can’t print anything, quit greenstreet Draw and try to print a text file from 
WordPad in the Windows Accessories program group. If this prints correctly, contact Customer Services; it may be 
that greenstreet Draw is having difficulty printing to that particular printer. However, if you can’t print from WordPad 
the problem may lie in the printer, cable or your Windows setup. Try connecting the printer again, and if that doesn’t 
help, contact your printer manufacturer or dealer.



File “FILENAME” is the wrong version - please check your installation

The filename specified is out of date. Somehow, an old version of a greenstreet Draw file has replaced the latest 
version of the same file. To correct this, reinstall the greenstreet Draw program to ensure that you are using the 
latest version.



Incorrect File Type!

You have tried to import a file but you have selected the wrong file format on the Import From File dialog box. 
Import the file again selecting All Files from the List Files of Type on the Import from File dialog box. If this 
message appears again, then the file may have been saved with a misleading filename extension, e.g. it may be 
a .BMP file but have the extension *.TIF. Make sure that the filename extension reflects the true format of the file 
then import it again.



No default printer selected. Use the Windows Control Panel to select a printer. Until you select a printer, 
text will be formatted using the screen only.

This message appears if you do not have a default printer set up in Windows. Use the Windows Control Panel to 
set up a default printer. Until you set up a default printer, you will not be able to see the page box indicating the 
printable area of the page in greenstreet Draw and if you are using a PostScript printer you will not be able to select 
options for printing colour separations. Also, you will not be able to print from greenstreet Draw until you have set up 
a default printer.



Not enough disk space to print

When greenstreet Draw prints a picture, it creates temporary files on your hard disk. These temporary files are 
created on the disk pointed to by the SET TEMP command in your AUTOEXEC.BAT file. At the moment there is not 
enough free space for these temporary files.

If your SET TEMP command points to a RAM disk, we recommend that you change the SET TEMP command to 
point to an area on your hard disk. If your SET TEMP command already points to an area on your hard disk, clear 
some disk space and try to print again. (For details of how to edit your AUTOEXEC.BAT file, refer to your DOS 
manual.)

Bear in mind that the more complicated your picture (e.g. the more fonts and clipart in it), the more disk space 
greenstreet Draw will need to print it.



Not enough memory for freehand/trace

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try again.



Not enough memory to ... create window/execute command/undo command/redo command.

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try again.



Not enough memory to perform Blend

There is not enough memory to carry out your command. Free some memory then try again.



Not enough memory to print

There is not enough memory to carry out your command. Free some memory then try again.



Note - file “FILENAME” is read only

The file you are opening is read-only. If you make any changes to it, they cannot be saved under the same 
filename.

The file may be read-only because it is on a network or because you have set it to read-only by mistake. If you have 
the appropriate rights to the file, you can change it from being read-only by using Windows Explorer (using the 
Properties command in the File menu).



Object Too Complex

You have tried to import a line-art file (metafile) that is too complicated for greenstreet Draw to handle. You will not 
be able to import this file into greenstreet Draw.



OLE libraries are out of date

Some of the greenstreet Draw program files are out of date. Install the greenstreet Draw program again to ensure 
that you have the appropriate versions of these files.



Only Paths and Shapes can be Blended

The objects you are trying to blend are not paths or shapes. If you are trying to blend an imported file, you must 
ungroup it into paths first then select the two paths that you want to blend.



Only Paths with more than one point can be Blended

You are trying to blend a path of one point with another path or shape. A single point cannot be blended with 
another path or shape. Either select a different path, or join more points to the single point before trying the Blend 
command again.



Only the first 500 fonts will be used

You have over 500 fonts in your Windows setup but greenstreet Draw will only use the first 500. If there are some 
fonts that you cannot see, remove some other ones so that they become available. Use the ATM Control Panel to 
remove ATM fonts and the Windows Control Panel to remove TrueType fonts.



Replacing font <name1> with <name2>

This message appears when you open a picture that used fonts which are currently not available on your setup. 
The message shows you which font on your setup is being used to replace each font originally in the picture. When 
you save the picture, the current fonts will be saved in it, replacing the original fonts.



Resolution must be between 10 and 1000 dpi

You must set a resolution value between 10 and 1000 when exporting bitmaps from greenstreet Draw. Try again 
with an appropriate value.



 Save clipboard?

You have copied something onto the clipboard. Do you want to save it before closing the current picture? If you 
choose to save the contents of the clipboard, you will be able to paste it back into a picture when you next run 
greenstreet Draw or into another application.



Spot colours must be named

You must name any spot colours so that you can select them when printing colour separations.



There is already a fill style “FILL NAME”

This message appears when you create a fill style and try to give it a name you’ve already used for another fill 
style. Try again with a different name.



There is too much text on the clipboard to paste.

You are trying to paste too much text into greenstreet Draw at once. Try again by breaking down the text into 
several sections then copying each section to the clipboard in turn and pasting it into greenstreet Draw one at a 
time.



This colour already exists in the palette.

This message can appear in two instances:

You have already created an unnamed colour with the same RGB value as another unnamed colour already 
in the palette, i.e. the colour already exists but is unnamed.

From the Edit Colours dialog box, you have chosen to Add a colour then entered a name that already 
exists. Try again with a different name.

Click on OK to overwrite the existing colour, or click on Cancel to give the new colour a different name.



This file was created using one or more fonts which are not currently installed. Substitute fonts will be 
used. If you save the file, these substitutions will be made permanent.

The picture you are opening was created using fonts that are not currently available on your setup. greenstreet 
Draw will substitute the unavailable fonts with the closest match it can find. If you save the picture, the original fonts 
will be permanently replaced by the matching fonts available on your setup.



This line style must be given a name

Enter a name for the line style you have created before clicking OK.



This name is too long - truncate to ‘xxx’?

The name you have entered for the line style, fill style or colour is too long. greenstreet Draw will truncate it if you 
click on Yes; or you can enter a different name if you click on No.



This program may only be used by one network user at any one time

A greenstreet Draw Network License Pack has not yet been installed so this copy of greenstreet Draw cannot be 
run by more than one network user at any one time. If you would like a Network License Pack, contact Customer 
Services for details.

If you have already installed a Network License Pack and this message is still appearing, the network license 
installation was probably unsuccessful or a component of it has been erased. Reinstall the Network License Pack 
and try again.



Too many people are already running greenstreet Draw on the network - contact network supervisor

All the network licenses are already being used. Contact your network supervisor about having a license assigned 
specifically to you or purchasing more licenses. For details of purchasing more licenses, contact Customer 
Services.



Unable to create dialog box 

There is not enough memory for greenstreet Draw to carry out your command. Free some memory, then try again.

If the message persists, restart Windows and greenstreet Draw.



Unable to create main window

There is not enough memory for greenstreet Draw to carry out your command. Free some memory then try again.



Unable to create toolbars - please check your installation

Either your installation of greenstreet Draw has been unsuccessful, or some component has been erased or 
corrupted. Install the greenstreet Draw program again.



Unable to find a match for font <name1>:using <name2> as a replacement.

greenstreet Draw has been unable to find a similar font on your setup to replace that originally used in the picture. 
Another font will be used that may not be a good match for the original. When the picture is open you can change 
the fonts yourself.



Unable to find fonts - please check your installation

greenstreet Draw has been unable to find any fonts on your setup. Check that you haven’t turned off both your 
TrueType and ATM fonts. If they are enabled, run the greenstreet Draw installation again and choose the initial 
fonts.



Unable to find import libraries - please check your installation

Either your installation of greenstreet Draw has been unsuccessful, or some component has been erased or 
corrupted. Install the greenstreet Draw program again.



Unable to import file ‘FILENAME’: unknown or ambiguous file type

When importing the file, you have selected the wrong file format on the Import From File dialog box. Import the file 
again, choosing the true file format from the List Files of Type box on the Import from File dialog box.



Unable to load Automation Type Library: Check Installation

Either your installation of greenstreet Draw has been unsuccessful, or some component of it has been erased or 
corrupted. Install the greenstreet Draw program again.



Unable to lock file “FILENAME” - file in use

The file you are trying to open is already being used by another user. Try again later.



Unable to open file

An error has occurred when trying to read network license information. Install greenstreet Draw again and, if you 
are using a network license version of greenstreet Draw, inform you network administrator of this error.



Unable to open ‘FILENAME’, because it is already being used by another program or user

The file you are trying to open is already being used by another user. Try again later.



Unable to open more than 8 windows for a single file

You cannot open more than eight windows on a picture. Close any that you don’t need so that you can then open 
another one.



Unable to run because SHARE is not installed. Include the line ‘SHARE /L:500 /F:5100’ in your 
AUTOEXEC.BAT field. Refer to your DOS manual for more information.

greenstreet Draw cannot run properly unless SHARE.EXE is set up on your PC. SHARE.EXE is supplied with DOS. 
For full details of how to check if SHARE.EXE is installed on your PC and how to set it up in your AUTOEXEC.BAT 
file, read the README file that gets installed with greenstreet Draw in the greenstreet program group.



Warning: this file is in an out-of-date format (but it should work!)

The picture you are opening was created in an earlier version of greenstreet Draw but it should work in this version. 
For safety, save it under a different filename so that you have the original file to go back to if necessary.



You should select at least one colour to be printed.

You have chosen to print spot colours but you haven’t selected any of the spot colours for printing. Choose the spot 
colours that you want to print then try again.



You must give this fill style a name

Enter a name for the fill style you have created before clicking OK.



Freeing Memory

In many instances, greenstreet Draw displays an error message because there is not enough memory to carry out 
your command. There are several things you can do to free up more memory:

Close any unnecessary picture windows

Close any unnecessary applications

Remove any unnecessary fonts from your Windows setup

Close and restart Windows

If you are using ATM, reduce the size of its font cache

Increase the amount of virtual memory using the Windows Control Panel

If you regularly experience memory problems, you should consider adding more memory to your computer. The 
more memory your computer has, the better your applications will perform. Contact your computer dealer for details 
of upgrading your memory.



Are you sure you want to remove this template from the list?

You have chosen to remove the selected templates from the list of templates available. Do you really want to 
remove it from the list? Clicking on Yes will remove the template from the list but will not delete the actual template 
from the disk, so you could add it again later.



There is already a line style “LINE NAME”

This message appears when you create a line style and try to give it a name you’ve already used for another line. 
Try again with a different name.



Cannot set Text Spacing: No unlocked text objects selected.

The text object whose spacing you are trying to adjust is locked. Unlock it and try again.



Cannot run Keypad: Keypad.exe not found.

The Keypad program cannot be found on your system. Check that the installation is complete.

If you have not installed Keypad, run the greenstreet Draw install program again and choose to install 
Keypad.

If Keypad is already installed, re-install it to ensure that the installation is complete and has not become 
corrupted.



Cannot run SnapShot: Snapshot.exe not found.

The SnapShot program cannot be found on your system. Check that the installation is complete.

If you have not installed SnapShot, run the greenstreet Draw install program again and choose to install 
SnapShot.

If SnapShot is already installed, re-install it to ensure that the installation is complete and has not become 
corrupted.



Save changes in “FILENAME”?

You have tried to quit greenstreet Draw or close a drawing without saving the changes you have made.

To save the changes

Click on Yes.

To discard the changes

Click on No.

To continue without quitting greenstreet Draw or saving the changes

Click on Cancel.



Are you sure you want to remove this page size from the list?

You have selected a custom page size in the Start A New Picture tab of the New Picture Options dialog box, and 
then clicked on the Delete button to remove the custom page size from the list.

To remove the page from the list

Click on Yes.

To leave the page in the list

Click on No.



Cannot Align Objects Left: Select two or more objects to align

In order to use the Align Objects Left tool, you need to have two or more objects selected. Select the objects you 
want to align then try using the Align Objects Left tool again. Bear in mind that if one of the selected objects is 
locked, it will not move; instead the other objects will align to it.

If you want to align an object to the left of the page, use the Align To Page Left tool instead.



Cannot Align Objects Centre: Select two or more objects to align

In order to use the Align Objects Centre tool, you need to have two or more objects selected. Select the objects 
you want to align then try using the Align Objects Centre tool again. Bear in mind that if one of the selected 
objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the centre of the page, use the Align To Page Centre tool instead.



Cannot Align Objects Right: Select two or more objects to align

In order to use the Align Objects Right tool, you need to have two or more objects selected. Select the objects you 
want to align then try using the Align Objects Right tool again. Bear in mind that if one of the selected objects is 
locked, it will not move; instead the other objects will align to it.

If you want to align an object to the right of the page, use the Align To Page Right tool instead.



Cannot Align Objects Top: Select two or more objects to align

In order to use the Align Objects Top tool, you need to have two or more objects selected. Select the objects you 
want to align then try using the Align Objects Top tool again. Bear in mind that if one of the selected objects is 
locked, it will not move; instead the other objects will align to it.

If you want to align an object to the top of the page, use the Align To Page Top tool instead.



Cannot Align Objects Middle: Select two or more objects to align

In order to use the Align Objects Middle tool, you need to have two or more objects selected. Select the objects 
you want to align then try using the Align Objects Middle tool again. Bear in mind that if one of the selected 
objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the middle of the page, use the Align To Page Middle tool instead.



Cannot Align Objects Bottom: Select two or more objects to align

In order to use the Align Objects Bottom tool, you need to have two or more objects selected. Select the objects 
you want to align then try using the Align Objects Bottom tool again. Bear in mind that if one of the selected 
objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the bottom of the page, use the Align To Page Bottom tool instead.



Cannot Align To Page Left: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Align To Page Centre: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Align To Page Right: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Align To Page Top: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Align To Page Middle: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Align To Page Bottom: No unlocked objects selected

You haven’t selected any objects to align, or the objects that you have selected are locked. Either select the objects 
you want to align, or unlock the objects that you have already selected. Then try to align them again.



Cannot Reflect Horizontally: No unlocked objects selected

You haven’t selected any objects to reflect, or the objects that you have selected are locked. Either select the 
objects you want to reflect, or unlock the objects that you have already selected. Then try to reflect them again.



Cannot Reflect Vertically: No unlocked objects selected

You haven’t selected any objects to reflect, or the objects that you have selected are locked. Either select the 
objects you want to reflect, or unlock the objects that you have already selected. Then try to reflect them again.



Cannot Rotate 45 Degrees Left: No unlocked objects selected

You haven’t selected any objects to rotate, or the objects that you have selected are locked. Either select the 
objects you want to rotate, or unlock the objects that you have already selected. Then try to rotate them again.



Cannot Rotate 45 Degrees Right: No unlocked objects selected

You haven’t selected any objects to rotate, or the objects that you have selected are locked. Either select the 
objects you want to rotate, or unlock the objects that you have already selected. Then try to rotate them again.



Cannot Rotate 90 Degrees Left: No unlocked objects selected

You haven’t selected any objects to rotate, or the objects that you have selected are locked. Either select the 
objects you want to rotate, or unlock the objects that you have already selected. Then try to rotate them again.



Cannot Rotate 90 Degrees Right: No unlocked objects selected

You haven’t selected any objects to rotate, or the objects that you have selected are locked. Either select the 
objects you want to rotate, or unlock the objects that you have already selected. Then try to rotate them again.



Cannot Rotate 180 Degrees: No unlocked objects selected

You haven’t selected any objects to rotate, or the objects that you have selected are locked. Either select the 
objects you want to rotate, or unlock the objects that you have already selected. Then try to rotate them again.



Cannot Double Size: No unlocked objects selected

You haven’t selected any objects to double in size, or the objects that you have selected are locked. Either select 
the objects whose size you want to double, or unlock the objects that you have already selected. Then try to double 
their size again.



Cannot Halve Size: No unlocked objects selected

You haven’t selected any objects to halve in size, or the objects that you have selected are locked. Either select the 
objects whose size you want to halve, or unlock the objects that you have already selected. Then try to halve their 
size again.



Cannot Skew Left: No unlocked objects selected

You haven’t selected any objects to skew, or the objects that you have selected are locked. Either select the objects 
you want to skew, or unlock the objects that you have already selected. Then try to skew them again.



Cannot Skew Right: No unlocked objects selected

You haven’t selected any objects to skew, or the objects that you have selected are locked. Either select the objects 
you want to skew, or unlock the objects that you have already selected. Then try to skew them again.



Cannot Skew Up: No unlocked objects selected

You haven’t selected any objects to skew, or the objects that you have selected are locked. Either select the objects 
you want to skew, or unlock the objects that you have already selected. Then try to skew them again.



Cannot Skew Down: No unlocked objects selected

You haven’t selected any objects to skew, or the objects that you have selected are locked. Either select the objects 
you want to skew, or unlock the objects that you have already selected. Then try to skew them again.



Error - page size too large

The maximum page size you can create is 76 x 76 cms (30 x 30 inches). You have entered dimensions greater than 
this - try again with smaller dimensions.



You must give this page size a name

You have not given your custom page size a name. Click on OK to return to the Custom Page Size dialog box, and 
then enter a name for your page size.



A page size with this name already exists

You have tried to save a page size with a name that is already used for one of the standard page sizes. You cannot 
overwrite the standard page sizes that are provided with greenstreet Draw. Click on OK to return to the Custom 
Page Size dialog box, and then enter a different name.



You must enter a non-zero size for the page

The width and/or the height dimension of your custom page size is zero. You must enter a non-zero size for the 
page. Click on OK to return to the Custom Page Size dialog box, and then amend the height and/or width 
dimensions of your page as appropriate.



You must give a Halftone fill style a name

You have not given your halftone fill style a name. Click on OK to return to the Name Style dialog box, and then 
enter a name for your fill style.



You must give a PostScript fill style a name

You have not given your PostScript fill style a name. Click on OK to return to the Name Style dialog box, and then 
enter a name for your fill style.



A custom line style must have some dashes and gaps

You have not given your custom line style any dashes and gaps. This results in no line style being created. Click on 
OK to return to the Line Style popup, and then enter some dash and gap values as appropriate.



A PostScript line style must be given a name

You have not given your PostScript line style a name. Click on OK to return to the Name Style dialog box, and then 
enter a name for your line style.



There is insufficient memory to display the <name> dialog box

There is not enough memory for greenstreet Draw to display this dialog box. Free some memory and then try again.



The full path name of the print-to-disk file must not exceed 31 characters

You have entered a path name for your print-to-disk file that is too long; you must enter a path name that does not 
exceed the 31 characters allowed by Windows' printer drivers. A path name includes the drive (e.g. C:\), the folder 
(e.g. \greenstreet\DRAW) and the file name and extension (e.g. MYFILE.EPS).

Click on OK to return to the Print To Disk dialog box, then enter a path name that contains 31 characters or less.



A page size with this name already exists. Do you want to replace it?

You have tried to save a page size with a name that you've used already. If you do not want to overwrite the existing 
page size, click on No then enter a different name in the Custom Page Size dialog box. If you do want to overwrite 
the existing page size, click on Yes. Any pictures based on the original page size will now be based on the new 
page size.



Printout Aborted

You have chosen to abandon your printout. greenstreet Draw displays this message to confirm that your printout 
has been aborted.



Not enough disc space to ... create window/execute command/undo command/redo command

While you are working in greenstreet Draw, it creates temporary files on your hard disk. These temporary files are 
created on the disk pointed to by the SET TEMP command in your AUTOEXEC.BAT file. At the moment there is not 
enough free space for these temporary files.

If your SET TEMP command points to a RAM disk, we recommend that you change the SET TEMP command to 
point to an area on your hard disk. If your SET TEMP command already points to an area on your hard disk, clear 
some disk space and try again. (For details of how to edit your AUTOEXEC.BAT file, refer to your DOS manual.)



Error - unable to ... create window/execute command/undo command/redo command - text object would be 
too large

You have tried to perform a text edit that would result in your text object being taller or wider than the work area.



Windows 95 new error messages



Too many people are already running greenstreet Draw on the network - contact network supervisor

All the network licenses are already being used. Contact your network supervisor about having a license assigned 
specifically to you or purchasing more licenses. For details of purchasing more licenses, contact Customer 
Services.



This copy of greenstreet Draw can only be used by one user at a time

A greenstreet Draw Network License Pack has not yet been installed so this copy of greenstreet Draw cannot be 
run by more than one network user at any one time. If you would like a Network License Pack, contact greenstreet 
Customer Services for details.

If you have already installed a Network License Pack and this message is still appearing, the network license 
installation was probably unsuccessful or a component of it has been erased. Reinstall the Network License Pack 
and try again.



Your folder is right protected or your disk may be full

The folder may be read-only because it is on a network or because you have set it to read-only by mistake. If you 
have the appropriate rights to the file, you can change it from being read-only by using Windows Explorer (using the 
Properties command in the File menu).

Your disk may also be full. Check your disk space using Windows Explorer (using the Properties command in the 
File menu).



No network licensing support available

The license data file is invalid or missing from the greenstreet Draw program directory. Reinstall the Network 
License Pack and try again. If you still have problems after reinstalling, contact Technical Support.



Invalid license data file

The license data file installed is not for greenstreet Draw, is invalid or corrupt. Reinstall the Network License Pack 
and try again. If you still have problems after reinstalling, contact Technical Support.



You do not have rights to write in this folder

The folder you are attempting to save to has been set to read only. If you have the appropriate rights to the folder, 
you can change it from being read-only by using Windows Explorer (using the Properties command in the File 
menu).

If you are attempting to save the file to a folder on a network, you may not have rights to do so or the folder may be 
right-protected. Contact your network supervisor for details.



Unable to validate user license

The license data file installed is not for greenstreet Draw, is invalid or corrupt. Reinstall the Network License Pack 
and try again. If you still have problems after reinstalling, contact Technical Support.



If you overwrite this file, you will not be able to open it in an earlier version of greenstreet Draw. Save your 
changes with a new filename to keep the original file.

This file was created with an earlier version of greenstreet Draw. If you save this file now, you will not be able to 
open it in an earlier version of greenstreet Draw.

If you save the file under a different filename, you will keep the original file and still be able to open it in an earlier 
version of greenstreet Draw.



The program has not been installed correctly, or you have removed some items which are essential for 
correct operation. Please re-install the program.

This message occurs when greenstreet Draw cannot find one of its program files. The file might have been deleted 
after you installed greenstreet Draw, or the installation was not completed successfully. To overcome this problem, 
reinstall greenstreet Draw.



Unable to import “FILENAME” - unsupported file format

You have tried to import a file that is not supported by greenstreet Draw. Try saving the file again using the 
application in which it was created or edited, but use a format supported by greenstreet Draw. The formats 
supported by greenstreet Draw include:

Computer Graphics Metafile Version 1.0 (CGM Metafile) (.cgm)
This is the format used by the greenstreet Draw clipart, it is also the import format for reading clipart files saved in the 
'Computer Graphics Metafile' (CGM) format, based on ISO 8632. Text font information is not preserved.

EPSF PostScript (.eps)
When you import an EPSF file, it is kept internally by the program in EPSF format. EPSF files can only be printed 
properly on a PostScript printer.

Graphical Environment Manager (GEM) 4.0 (.gem)
There are various different versions of this standard (relating to different versions of GEM), but this import format can 
handle them all. Text font information is not preserved.

Joint Photographic Expert Group (JPEG) Bitmap (.jpg)
This import format is for reading bitmap files saved in JFIF formats of JPEG. It can handle grey scale and 24-bit 
images.

PCX - PC Paintbrush (ZSOFT Corp) (.pcx)
This import format can handle black-and-white, 8-colour, 16-colour, 256-colour and 24-bit files.

Targa Bitmap (.tga)
This import format can handle all formats of Targa files. It can handle 8-bit, 16-bit, 24-bit and 32-bit compressed and 
uncompressed files.

Tagged Image File Format (TIFF) Bitmap (.tif)
This import format can handle black-and-white, grey scale, palette-colour, and 24-bit rgb files. It can accept files using 
the 'packbits', 'ccitt' and LZW compression.

Windows Bitmap (.bmp)
This import format can read black-and-white, 16-colour, 256-colour, and 24-bit rgb files but not 32 colour 24-bit rgb 
files.

Windows Metafile (.wmf)
Text font information is not preserved.



An error occurred connecting to MAPI

greenstreet Draw has encountered an error while trying to connect to your MAPI electronic mail program. Check 
that you electronic mail program is operational then try sending your file again. If the problem persists, contact 
Technical Support.





Edit Colours tool: This is an alternative to the Edit Colours command in the Edit menu.

Click on it to display the Edit Colours dialog box where you can add, modify or delete named colours.



Fill Styles tool: This is an alternative to the Popup Fills command in the Fill menu.

Click on it to turn the display of the Fill Style popup on or off.



Line Styles tool: This is an alternative to the Popup Lines command in the Line menu.

Click on it to turn the display of the Line Style popup on or off.



Cut tool: This is an alternative to the Cut command in the Edit menu.

Click on it to remove selected objects from your picture and put them on the Clipboard, ready for pasting.

Keyboard shortcut:    Ctrl X



Copy tool: This is an alternative to the Copy command in the Edit menu.

Click on it to copy selected objects from your picture and put them on the Clipboard, ready for pasting.

Keyboard shortcut:    Ctrl C



Paste tool: This is an alternative to the Paste command in the Edit menu.

Click on it to paste the contents of the Clipboard into your picture.

Keyboard shortcut:    Ctrl V



Undo tool: This is an alternative to the Undo command in the Edit menu.

Click on it to undo the last command. You can undo up to the last fifty commands.

Keyboard shortcuts:    F3 or Ctrl Z



Redo tool: This is an alternative to the Redo command in the Edit menu.

Click on it to redo the last command that was undone.

Keyboard shortcuts:    F4 or Ctrl Y



Transform Again tool: This is an alternative to the Transform Again command in the Edit menu.

Click on it to repeat the last transformation on the selected object.

Keyboard shortcut:    F5



Preview tool: This is an alternative to the Preview command in the View menu.

Click on it to toggle between displaying the picture in the active window in preview or outline format.

Keyboard shortcut:    F6



Actual Size: This is an alternative to the Actual Size command in the View menu.

Click on it to view the picture in the active window at its actual size.

Keyboard shortcut:    F7



Whole Page tool: This is an alternative to the Whole Page command in the View menu.

Click on it to view the whole page of the picture in the active window.

Keyboard shortcut:    Shift F7



Show Grid tool: This is an alternative to the Show Grid check box in the Grid dialog box.

Click on it to turn the display of the grid on or off for the picture in the active window.



Snap to Grid tool: This is an alternative to the Snap to Grid check box in the Grid dialog box.

Click on it to turn snap control on or off for the picture in the active window.



To Front tool: This is an alternative to the Bring To Front command in the Object menu.

Click on it to move the selected object(s) to the front of their layer.

Keyboard shortcut:    Ctrl F



To Back tool: This is an alternative to the Send To Back command in the Object menu.

Click on it to move the selected object(s) to the back of their layer.

Keyboard shortcut:    Ctrl B



Group tool: This is an alternative to the Group command in the Object menu.

Click on it to group the selected objects together.

Keyboard shortcut:    Ctrl G



Ungroup tool: This is an alternative to the Ungroup command in the Object menu.

Click on it to ungroup the selected group.

Keyboard shortcut:    Ctrl U



Join tool: This is an alternative to the Join command in the Object menu.

Click on it to join two paths together or to join text to a path.

Keyboard shortcut:    Ctrl J



Split tool: This is an alternative to the Split command in the Object menu.

Click on it to split a path at the selected point or to split text from a path.

Keyboard shortcut:    Ctrl S



Lock/Unlock tool: This is an alternative to the Lock and Unlock commands in the Object menu.

Click on it to lock objects so that they cannot be manipulated; click on it again to unlock the selected objects.

This is the same as clicking on the padlock in the information line.

Keyboard shortcuts:    Ctrl L and Ctrl N



Align tool: This is an alternative to the Align command in the Object menu.

Click on it to display the Align dialog box for adjusting the alignment of the selected object(s).

Keyboard shortcut:    Ctrl A



Utilities tool: Click on this tool to drop-down a list of the utilities that you installed with greenstreet Draw. You can 
then select the utility that you want to use.



Object Properties tool: This is an alternative to the Properties command in the Object menu.

Click on it to display the Properties dialog box for the selected object; the options on this dialog box vary depending 
on the type of object selected. If more than one object is selected the Multiple Objects dialog box appears 
informing you how many objects are currently selected.

Keyboard shortcut:    Ctrl I



What's This? Tool: Click this tool to display the help pointer. Position the pointer over an item in the greenstreet 
Draw window, e.g. a tool or the information line, and click the mouse button. A window or popup of help information 
about the item you selected appears.

Keyboard shortcut:    Shift F1



Typeface drop-down list box: Select a different typeface for your text selection, or preset the typeface before 
typing text.

Click on the arrow next to the Typeface box to drop-down a list of the fonts that are available to your setup. Click on 
the font that you want to use.



Text Size box: Choose a different point size for your text selection, or preset the point size before typing text.

Click on the arrows next to the Text Size box to increase or decrease the point size by one point; alternatively, type 
the size directly.



Bold tool: This Text tool is used to style your text selection in bold, or to preset the style of text before typing.

Click on it to turn bold text styling on or off.



Italic tool: This Text tool is used to style your text selection in italic, or to preset the style of text before typing.

Click on it to turn italic text styling on or off.



Autokern tool: This Text tool is used to automatically kern your text selection.

Click on it to turn autokerning on or off.



Left-align Text tool: This Text tool is used to align the selected text object to the left, or to preset the alignment to 
the left before typing text.

Click on it to give your text a flushed left alignment.



Centre Text tool: This Text tool is used to align the selected text object to the centre, or to preset the alignment to 
centred before typing text.

Click on it to give your text a centred alignment.



Right-align Text tool: This Text tool is used to align the selected object to the right, or to preset the alignment to 
the right before typing text.

Click on it to give your text a flushed right alignment.



Justify Text tool: This Text tool is used to align the selected object to the left and right, or to preset the alignment to 
the left and right before typing text.

Click on it to give your text a fully justified alignment.



Increase Width tool: This Text tool is used to expand the characters in your text selection, or to preset the width 
before typing text. You can only preset the width if the text insertion point is on the page.

Click on it to expand the characters by 10%.

When the Text Tools are fully expanded, you can enter the exact percentage by which you want to expand your text.



Decrease Width tool: This Text tool is used to compress the characters in your text selection, or to preset the width 
before typing text. You can only preset the width if the text insertion point is on the page.

Click on it to compress the characters by 10%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to compress your 
text.



Raise Text tool: This Text tool is used to raise the characters in your text selection above the baseline, or to preset 
the position before typing text. You can only preset this if the text insertion point is on the page

Click on it to raise the characters by 1 point.

When the Text Tools are fully expanded, you can enter the precise number of points by which you want to raise your 
text.



Lower Text tool: This Text tool is used to lower the characters in your text selection below the baseline, or to preset 
the position before typing text. You can only preset this if the text insertion point is on the page.

Click on it to lower the characters by 1 point.

When the Text Tools are fully expanded, you can enter the precise number of points by which you want to lower 
your text.



Kern Together tool: This Text tool is used to reduce the space between the characters in your text selection, 
moving them closer together. You can only preset this if the text insertion point is on the page.

Click on it to reduce the space by 1%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to reduce the 
space.



Kern Apart tool: This Text tool is used to increase the space between the characters in your text selection, moving 
them wider apart. You can only preset this if the text insertion point is on the page.

Click on it to increase the space by 1%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to increase the 
space.



Text Spacing tool: This Text tool displays the Spacing dialog box. From this dialog box you can set parameters 
controlling the spacing of letters, words and lines of a text object.



KeyPad tool: This Text tool runs the separate KeyPad utility that is supplied with greenstreet Draw.

Use KeyPad to insert characters that are not available to your keyboard, e.g. decorative characters from fonts such 
as Dingbats and Wingdings.



Pointer tool: Use this tool to select objects and points on paths, and to manipulate objects by, for example, moving 
or stretching them.

Whichever tool is selected, if you click or drag using the right mouse button, you will be able to select and drag 
objects as though you had temporarily switched to the pointer tool.



Text tool: Use this tool to create and style text. You can then manipulate text objects like any other object in your 
picture, for example, skew, blend, colour them etc. When you select the text tool, the Text Tools are displayed.



Box tool: Use this tool to draw squares and rectangles.



Round Box tool: Use this tool to draw squares and rectangles with round corners. The curvature of a round box 
can be increased to make the shape more circular, or decreased to make the shape more square.



Ellipse tool: Use this tool to draw ellipses such as ovals and circles.



Arc tool: Use this tool to draw arcs. The direction in which you drag the mouse determines whether the arc is 
drawn clockwise or anticlockwise.

Arcs are quarter-ellipses when you first draw them. You can adjust the start and end angles of an arc, making it 
more acute or obtuse.



Pie tool: Use this tool to draw pie slices. The direction in which you drag the mouse determines whether the pie 
slice is drawn clockwise or anticlockwise.

Pie slices are quarter-ellipses when you first draw them. You can adjust the start and end angles of a pie slice, 
making it more acute or obtuse.



Polygon tool: Use this tool to draw polygons. When you draw a polygon it is automatically given five sides. You can 
change the number of sides on a polygon before or after you draw it to give it a different shape.

Note:

The minimum number of sides is 3 and the maximum is 100.



Star tool: Use this tool to draw stars. When you draw a star it is automatically given five points. You can change the 
number of points and the star's inner radius before or after you draw it to give it a different shape.

Note:

The minimum number of points is 3 and the maximum is 100.



Pencil tool: This tool is like the pencil on your desk. As you drag the Pencil tool around the desktop, a freehand 
path is drawn following the movements of the tool.



Bezier tool: This tool combines the functions of the Corner, Curve and Connect tools in one tool. Use the Bezier 
tool to draw straight lines and curves connecting smoothly without having to change tools. By adjusting the points 
and control points you can change the shape of a bezier path. 

You can join the two ends of a bezier path to create a closed path that can then be given a fill style.



Corner tool: Use this tool to draw angular paths. By adjusting the points you can change the shape of a path. 

You can join the two ends of a path to create a closed path that can then be given a fill style.



Curve tool: Use this tool to draw smoothly curved paths. By adjusting the points and control points you can change 
the shape of the path. 

You can join the two ends of a path to create a closed path that can then be given a fill style.



Connect tool: Use this tool to make smooth connections between corner and curve points. Normally, when you 
insert a curve point after a corner point, the line between them will be angular instead of a smooth progression from 
a straight to a curved line, but if you insert a connect point between a corner and a curve point, the three points will 
be joined smoothly.

You can join the two ends of a path to create a closed path that can then be given a fill style.



Scale tool: Use this tool to distort the objects in your picture by stretching or squeezing them.

You can preserve the aspect ratio of an object that you scale and you can copy an object as you scale it.



Rotate tool: Use this tool to move an object around the fixed point. Rotating paths, text and other objects can 
create interesting effects.

You can restrict the angle of rotation to multiples of 45 degrees, and you can copy an object as you rotate it.



Skew tool: Use this tool, for example, to create three dimensional or shadow effects that look especially interesting 
when skewing text objects.

You can restrict the angle that you skew an object to multiples of 45 degrees, and you can copy an object as you 
skew it.



Reflect tool: Use this tool to produce mirror images of objects. Interesting effects can be achieved by reflecting 
text, paths, shapes and other objects.

You can restrict the angle of reflection to multiples of 45 degrees, and you can copy an object as you reflect it.



Autotrace tool: Use this tool to automatically trace a path around the outline of an imported bitmap.



Magnifier tool: Use this tool to magnify selected areas of your picture.



Open tool: This is an alternative to the Open command in the File menu.

Click on it to open an existing picture.

Keyboard shortcut:    Ctrl O



Save tool: This is an alternative to the Save command in the File menu.

Click on it to save the current picture under its current name. If you have not yet given it a name, you will be 
asked for a name before the picture is saved.

Keyboard shortcut:    F2



Load Default Template tool: Click on this tool to load the default template, ready to start a new picture.

You nominate which template is going to be the default one in the Start A New Picture tab of the New Picture 
Options dialog box.



Import tool: This is an alternative to the Import File command in the File menu.

Click on it to import graphics from another source into your greenstreet Draw picture.



Export tool: This is an alternative to the Export to File command in the File menu.

Click on it to export your greenstreet Draw picture to another program.



Print tool: This is an alternative to the Print command in the File menu.

Click on it to print the picture in the current greenstreet Draw window.

Keyboard shortcut:    Ctrl P



Reflect Horizontally tool: Use this tool to reflect the selected object horizontally across a vertical axis.



Reflect Vertically tool: Use this tool to reflect the selected object vertically across a horizontal axis.



Rotate 45 Degrees Right tool: Use this tool to rotate the selected object 45 degrees to the right.



Rotate 45 Degrees Left tool: Use this tool to rotate the selected object 45 degrees to the left.



Rotate 90 Degrees Right tool: Use this tool to rotate the selected object 90 degrees to the right.



Rotate 90 Degrees Left tool: Use this tool to rotate the selected object 90 degrees to the left.



Rotate 180 Degrees tool: Use this tool to rotate the selected object 180 degrees.



Double Size tool: Use this tool to double the size of the selected object.



Halve Size tool: Use this tool to halve the size of the selected object.



Skew Right tool: Use this tool to skew the selected object to the right.



Skew Left tool: Use this tool to skew the selected object to the left.



Skew Up tool: Use this tool to skew the selected object upwards.



Skew Down tool: Use this tool to skew the selected object downwards.



Align Objects Left tool: Use this tool to align selected objects to the left edge of the left-most of them.



Align Objects Centre tool: Use this tool to align selected objects to the horizontal centre of the selection.



Align Objects Right tool: Use this tool to align selected objects to the right edge of the right-most of them.



Align Objects Top tool: Use this tool to align selected objects to the top edge of the top-most of them.



Align Objects Middle tool: Use this tool to align selected objects to the vertical centre of the selection.



Align Objects Bottom tool: Use this tool to align selected objects to the bottom edge of the bottom-most of 
them.



Align to Page Left tool: Use this tool to align selected objects to the left edge of the page.



Align to Page Centre tool: Use this tool to align selected objects to the horizontal centre of the page.



Align to Page Right tool: Use this tool to align selected objects to the right edge of the page.



Align to Page Top tool: Use this tool to align selected objects to the top edge of the page.



Align to Page Middle tool: Use this tool to align selected objects to the vertical middle of the page.



Align to Page Bottom tool: Use this tool to align selected objects to the bottom edge of the page.



Kern Text box: This Text tool is used to set the space between the characters in your text selection precisely, 
moving them closer together or further apart.

Click on the arrows next to the Kern Text box to increase or decrease the point size by 1%; alternatively, type the 
percentage directly into the box.



Text Width box: This Text tool is used to set the width of characters in your text selection precisely, making them 
wider or narrower.

Click on the arrows next to the Text Width box to increase or decrease the character width by 1%; alternatively, 
type the percentage directly into the box.



Raise/Lower Text box: This Text tool is used to precisely raise the characters in your text selection above the 
baseline, or lower them below the baseline.

Click on the arrows next to the Raise/Lower Text box to raise or lower the text by one point; alternatively, enter the 
number of points directly.



Change Toolbar Size tools: These tools are used to change the size of the toolbar.

Click on the right-facing arrow to expand the toolbar. When the toolbar is at its largest size, this button is disabled.

Click on the left-facing arrow to collapse the toolbar. When the toolbar is at its smallest size, this button is disabled.



General Tools: Tools that you are likely to need whatever you are doing in the program, e.g. Copy, Paste, and 
Undo.



Align Tools: Tools for aligning objects, e.g. Align Objects Left, Align To Page Centre.



Transform Tools: Tools for manipulating objects, e.g. Reflect Horizontally, Rotate 180 Degrees, and Skew 
Down.



Object Tools: Tools for rearranging and working with objects, e.g. To Front, Group, and Object Properties.



Text Tools: Tools for working on text, e.g. Typeface, Bold, Kern Together, and Text Spacing.



Set units: Click here to display a shortcut menu from which you can select a different unit of measurement and 
reset or adjust the ruler origins.



Rulers: Use the rulers to help you when sizing and positioning objects.



Zoom Out tool: Click on this tool to reduce the magnification to the next standard view size.



Set View Size: Click here to display the view size shortcut menu from which you can select a different view size.



Zoom In tool: Click on this tool to increase the magnification to the next standard view size.





ATM and TrueType

The fonts that are supplied with greenstreet Draw are TrueType fonts, but greenstreet Draw can also use ATM fonts. 
However, if you have the same font installed in both ATM format and TrueType format, you should remove the ATM 
version of the font to ensure you obtain the best possible performance from greenstreet Draw.

To remove ATM fonts from your setup:

1. In the ATM Control Panel, select the fonts you want to remove.

2. Click on the Remove button. A message appears for each selected font asking you to confirm that you want to 
remove the font.

3. Click on Yes to remove the font.

4. To remove the remaining fonts without confirming each one, check the No confirmation to remove fonts check 
box.

5. When all the fonts have been removed, click on the Exit button to close the ATM Control Panel, then exit 
Windows.

When you restart Windows the new ATM settings will take effect.

    Related Topics



Bitmap and vector graphics

There are many different graphics packages currently available for the PC: Art packages, illustration packages, 
painting packages, drawing packages, design packages and many more. These packages handle graphics in 
different ways. One of the main distinctions between them is how they create and manipulate graphics.

There are currently two types of graphics you should be aware of: Bitmap and vector.

Most graphics-handling programs are optimised towards one of these two types. Programs that draw are normally 
best at handling vector graphics, while programs that paint prefer bitmap graphics. greenstreet Draw is optimised 
towards vector-based graphics, although it can also handle bitmapped graphics.

Bitmaps are simpler than vector graphics, but are much less flexible and generally of poorer quality.

Your screen display

To understand the difference between bitmaps and vector graphics, you need to understand how your computer 
screen display an image.

Your screen display is made up of thousands of tiny dots called pixels. An image is generated by colouring or filling 
in these pixels. The more pixels your display contains, the more detail it can show. The amount of detail your display 
can show is usually called the resolution.

Bitmapped images

Bitmapped images are created by filling individual pixels with colour. The location and colour of every pixel is 
recorded as a unique item or 'bit' of information in a 'bit mapped' graphics file.

If you reduce the size of a bitmap image on your screen, your PC will try to squeeze the bitmap into the smaller 
area by ignoring some of the pixels. The smaller image will consequently lose its crispness, and the overall 
appearance will probably not be as good.

You get a similar effect if you display bitmaps generated at low resolution on screens with a higher resolution.

However, there are various programs that allow you to tidy up or edit bitmaps, such as Microsoft Paint, which is 
supplied with Windows 95.

Vector-based graphics

A vector is a path between two points. It has certain properties, such as length, shape and thickness. A vector-
based graphics file - which may contain hundreds of vector paths - tells your PC exactly how to plot and draw each 
path individually.

The PC recalculates and redraws each path individually whenever you enlarge, reduce or otherwise manipulate the 
graphic. This means that the properties of each path are maintained however you manipulate the image, or 
whatever resolution of screen you are using.



Imports and exports

This section provides information about the import and export formats that are supported by greenstreet Draw.

Imports

Computer Graphics Metafile Version 1.0 (CGM Metafile) (.cgm)
This is the format used by the greenstreet Draw clipart, it is also the import format for reading clipart files saved in the 
'Computer Graphics Metafile' (CGM) format, based on ISO 8632. Text font information is not preserved.

EPSF PostScript (.eps)
When you import an EPSF file, it is kept internally by the program in EPSF format. EPSF files can only be printed 
properly on a PostScript printer.

Graphical Environment Manager (GEM) 4.0 (.gem)
There are various different versions of this standard (relating to different versions of GEM), but this import format can 
handle them all. Text font information is not preserved.

Joint Photographic Expert Group (JPEG) Bitmap (.jpg)
This import format is for reading bitmap files saved in JFIF formats of JPEG. It can handle grey scale and 24-bit 
images.

PCX - PC Paintbrush (ZSOFT Corp) (.pcx)
This import format can handle black-and-white, 8-colour, 16-colour, 256-colour and 24-bit files.

Targa Bitmap (.tga)
This import format can handle all formats of Targa files. It can handle 8-bit, 16-bit, 24-bit and 32-bit compressed and 
uncompressed files.

Tagged Image File Format (TIFF) Bitmap (.tif)
This import format can handle black-and-white, grey scale, palette-colour, and 24-bit rgb files.    It can accept files 
using the 'packbits', 'ccitt' and LZW compression.

Windows Bitmap (.bmp)
This import format can read black-and-white, 16-colour, 256-colour, and 24-bit rgb files but not 32 colour 24-bit rgb 
files.

Windows Metafile (.wmf)
Text font information is not preserved.

Exports

Bitmap Formats
When exporting to a bitmap format, the results should match the original picture accurately. If you choose to export 
'selected objects only' then the bitmap will be just big enough for those objects. If you do not, it will enclose the 
whole page. Remember that the higher the resolution you select, the larger the file produced. A Letter size page in 
black-and-white at 300dpi will take up about 1 megabyte of disk space.

Line-Art formats
greenstreet Draw has some features that are not supported by many line-art file formats. Most cannot represent 
graduated fills, thick dotted lines, custom line styles, patterns, or objects that have been pasted inside other objects.

Computer Graphics Metafile Version 1.0 (CGM Metafile) (.cgm)
No graduated fills. No thick, dotted lines. No custom line styles. No patterns. No objects that have been pasted inside 
other objects. Bezier curves are converted into sequences of straight lines.

EPSF PostScript (.eps)
Everything except 'Random Fill' is supported.

Graphical Environment Manager (GEM) 4.0 (.gem)
Linear and Radial graduated fills are supported. No objects that have been pasted inside other objects.    Bezier 
curves are represented as curves in this format.

PCX - PC Paintbrush (ZSOFT Corp) (.pcx)
Black-and-white, 16-colour and 256-colour files only. 

Targa Bitmap (.tga)
256-colour files only.

Tagged Image File Format (TIFF) Bitmap (.tif)
Black-and-white, 16-colour and 256-colour files only.



Windows Bitmap (.bmp)
Black-and-white, 16-colour and 256-colour files only.

Windows Metafile (.wmf)
This format does not actually support graduated fills, but they are simulated by the export code, and should work in 
most cases. No patterns. No objects that have been pasted inside other objects.    Bezier curves are converted into 
sequences of straight lines. 
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Printing

Microsoft Windows Printing System

This printer driver does not support ATM fonts. If you want to print greenstreet Draw pictures using ATM fonts, you 
must first ungroup the text into a path.

PostScript Printers

The program has been tested with the regular Windows driver for PostScript (v3.5) The 'random' pattern fill prints as 
plain grey: Use the special PostScript textures if necessary.

When preparing PostScript files for a typesetting bureau, check with the printer to see what sort of typesetter they 
are using, and discuss the correct printing options to use. If you select 'Linotronic 300' in the driver's printer type, 
you will be able to choose the 'Letter extra' size which allows a little extra room around a Letter size page for crop 
marks and captions.

If you are printing to a PostScript printer which does not have the usual set of built-in fonts, you may need to modify 
the DRAW30.INI file to make some fonts work properly. We assume that PostScript printers have the following 
fonts: Courier, Times, Helvetica, Avant Garde, Bookman, Century Schoolbook, Helvetica Narrow, Palatino, Symbols, 
Zapf Chancery and Zapf Dingbats.

If your PostScript printer does not contain one or more of these fonts, you can make greenstreet Draw print the 
fonts correctly by removing the corresponding line from DRAW30.INI. The program will then download the font to 
the printer, rather than assume that the font is built-in.

For example, if your printer does not have Helvetica Narrow, open your DRAW30.INI file and delete or comment out 
the line in the [PSfonts] section referring to that font (insert a semicolon at the start of the line to comment out the 
line):

[PSfonts]
; Sans Narrow=Helvetica-Narrow,,-Bold,-Oblique,-BoldOblique

Note that because greenstreet Draw downloads fonts to the printer, a job containing many different fonts may take a 
long time to print, or even exhaust the printer's memory. We suggest you avoid including many different fonts in a 
job printed on a PostScript printer.

General notes for other printers

If you do not get good results with the printer driver supplied with your printer, you may find that one of the standard 
drivers supplied by Windows would work better - for example most 24-pin dot matrix printers can be driven using 
the standard Epson 24-pin (LQ-compatible) driver.

    Related Topics



New Picture Options dialog box

This dialog box appears when you start greenstreet Draw, or when you select New from the File menu. It lets you 
choose how to start work on a new picture. The dialog box is divided into four tab cards.

New Picture Options dialog box: Run A PagePilot tab card

New Picture Options dialog box: Start A New Picture tab card

New Picture Options dialog box: Open An Existing File tab card

New Picture Options dialog box: New User Guide tab card

Click on Preferences to modify how greenstreet Draw starts up and starts a new picture, and to set general 
controls.
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New Picture Options dialog box: Run a PagePilot tab card

Select a PagePilot list box

Start the PagePilot by double-clicking on its name in this list box.

Comments box

Displays information about the PagePilot.
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New Picture Options dialog box: New User Guide tab card

This tab card appears when you click on the New User Guide tab card in the New Picture Options dialog box.

It gives a brief introduction to each of the three tabbed functions in the dialog box. These are:

Run A PagePilot tab card

Start A New Picture tab card

Open An Existing File tab card.
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New Picture Options dialog box: Start A New Picture tab card

Use this dialog box tab card to start a new picture, using either a blank page or a template.

Category group box

Choose to start your new picture with a blank page or a template.

Blank Page list box

This box is shown if you have chosen to start with a blank page. Select a pre-defined page size, or click on Add to 
display the Custom Page Size dialog box so that you can create a new page size.

use the Add button to create your own custom page size.

use the Delete button to delete a selected page size. The page size is then removed from the list of 
available sizes. You cannot delete any of the pre-defined page sizes.

Orientation group box

This box is shown if you have chosen to start with a blank page. Select the orientation of your picture, i.e. Portrait 
(vertical) or Landscape (horizontal).

Picture Attributes group box

This box is shown if you have chosen to start with a blank page. Specify whether your picture will be single or multi-
layered, and whether you will be using colour separation.

Standard Colours check box

This check box is shown if you have chosen to start with a blank page. Check this box if you want the standard 
selection of colours to be available in your new picture.

Template list box

This box is shown if you have chosen to start with a template. Select a template by clicking on its description or 
filename in this list box. This box lists the templates you have added by using the Add button.

Add button

Click on the Add button if the template you want is not in the list box. The Select a template dialog box appears so 
that you can browse your disk drives and folders for the file that you want to add to the list.

Delete button

Click on the Delete button to remove the selected template from the list box. A message appears asking you to 
confirm that you want to remove the template. If you click on Yes, the template is removed from this list; it is not 
deleted from your disk.

Browse button

Click on the Browse button to display the Open dialog box, so that you can browse your disk drives and folders for 
the template that you want to load without adding it to the list of templates.

Template Description box

This box is shown if you have chosen to start with a template. It displays information about the selected template.

Make Default check box

This check box is shown if you have chosen to start with a template. Check the Make Default check box to make 
the selected template into the default template so that it is loaded automatically whenever you use the default 
template.

Path and filename box

This box is shown if you have chosen to start with a template. It displays the path and filename of the selected 
template.
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New Picture Options dialog box: Open an Existing File tab card

Select A File To Open: List box

Select the file you want to open by clicking on the filename in this list box. This box lists the twenty pictures you 
have most recently worked on.

Browse button

Click on the Browse button if the picture you want is not shown in the list box. The Open dialog box appears so that 
you can browse your disk drives and folders for the file you want to open.

Title: Displays the title that you have entered on the Summary Info dialog box.

Subject: Displays the subject that you have entered on the Summary Info dialog box.

Author: Displays the author's name that you have entered on the Summary Info dialog box.

Comments: Displays any comments you have entered on the Summary Info dialog box.
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Custom Page Size dialog box

This dialog box appears when you select the Start a New Picture tab card of the New Picture Options dialog box, 
choose to start with a blank page, and then click on the Add button. It allows you to create your own custom page 
size.

Name text box

Give your new page size a name, so that you will be able to recognise and choose it in future.

Dimensions group box

Specify the Height and Width dimensions (the maximum values are 30 inches [76 cm]). You can change the units 
for these dimensions by using the Units drop-down list box.
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Select a template dialog box

This dialog box appears when you select Template from the Category group box on the New Picture Options 
dialog box, and then click on the Add button.

From this dialog box you can locate and load a template on which to base your picture. The template will be loaded 
and added to the list of templates on the New Picture Options dialog box.

Look in drop-down list box

Select a disk drive and folder. Click on the arrow to the right-hand side of the Look in list box to drop-down a list of 
all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. Select the template you want 
to load by clicking on the filename or by entering the filename in the File Name text box.

If necessary, use the scroll bar to display more files.
File Name text box
Displays the name of the select template. If you have not selected a template, you can type the known filename in 
this box.
Files of Type drop-down list box
Select the file format of the picture you want to open, i.e. Template. Files of the selected format in the current folder 
are displayed in the Folders list box.
Summary Info button

Displays the Summary Info dialog box.
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Open dialog box

This dialog box appears when you select Template from the Category group box on the New Picture Options 
dialog box, and then click on the Browse button.

From this dialog box you can locate and load a template on which to base your picture. The template will be loaded 
but will not be added to the list of templates on the New Picture Options dialog box.

Look in drop-down list box

Select a disk drive and folder. Click on the arrow to the right-hand side of the Look in list box to drop-down a list of 
all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. Select the template you want 
to load by clicking on the filename or by entering the filename in the File Name text box.

File Name text box

Displays the name of the selected template. If you have not selected a template, you can type the known filename 
in this box.

Files of Type drop-down list box

Select the file format of the picture you want to open, i.e. Template. Files of the selected format in the current folder 
are displayed in the Folders list box. 

Summary Info button

Displays the Summary Info dialog box.
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Open dialog box

This dialog box appears when you select Open from the File menu, or when you click on the Browse button on the 
Open An Existing File tab card of the New Picture Options dialog box.

Use the Preferences dialog box to determine whether the Open dialog box or the Open an Existing File 
tab card of the New Picture Options dialog box appears when you select Open from the File menu.

From this dialog box you can locate and load an existing picture so that you can continue to work on it.

Look in drop-down list box

Select a disk drive and folder. Click on the arrow to the right-hand side of the Look in list box to drop-down a list of 
all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. Select the template or picture 
you want to load by clicking on the filename or by entering the filename in the File Name text box.

File Name text box

Displays the name of the selected picture or template. If you have not selected a picture or template, you can type 
the known filename in this box.

Files of Type drop-down list box

Select the file format of the picture you want to open, i.e. Picture or Template. Files of the selected format in the 
current folder are displayed in the Folders list box.

Summary Info button

Displays the Summary Info dialog box.

If you need to open a backup file, change *.art in the File Name text box to *.bak.
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Save As dialog box

This dialog box appears when you select Save As from the File menu, or when you select Save for an untitled 
picture.

From this dialog box you can specify the disk, folder and filename in which to save your picture.

Save in drop-down list box

Select a disk drive and folder in which you want to save your picture. Click on the arrow to the right-hand side of the 
Save in list box to drop-down a list of all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. If you want to overwrite a file, 
select the picture you want to overwrite by clicking on the filename or by entering the filename in the File Name text 
box.

File Name text box

Type the filename in which you want to save your picture or, if the file already exists, select it by clicking on the 
filename in the Folders list box.

Save as Type drop-down list box

Select the file format in which you want to save your picture, i.e. Picture or Template. Files of the selected type in 
the current folder are displayed in the Folders list box. When you click on OK, greenstreet Draw warns you if you try 
to overwrite an existing file.

Make Default Template check box

This check box appears if you have selected Template(*.tem) from the Save as Type drop-down list box. Check 
this box to make the template you are saving the default template.

Summary Info button

Click on this button if you want to enter more details about the picture you are saving. The Summary Info dialog 
box appears for you to enter the details you want.
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Summary Info dialog box

This dialog box appears when you select Summary Info from the File menu, or when you are saving a picture 
using the Save As command and click on the Summary Info button on the Save As dialog box, or when you click 
on the Summary Info button on the Open dialog box.

The Summary Info dialog box lets you view information about the current picture.

File Name: Displays the name of the current picture.

Folder: Displays the folder in which the current picture has been saved.

Template: Displays the template (if any) associated with the picture.

Title text box

Type the title of the picture.

Subject text box

Type details of the picture's subject matter.

Author text box

greenstreet Draw automatically inserts the name you entered during installation. You can edit this name if 
necessary.

Keywords text box

Type any keywords that you want to associate with the picture. Some utilities are able to search your system for 
files by looking for keywords.

Comments text box

Type any information that you want to note about the picture.

Created: Displays the date and time at which the picture was first saved.

Last Saved: Displays the date and time at which the picture was most recently saved.

Last Printed: Displays the date and time at which the picture was most recently printed.

Total Editing Time: Displays the total amount of time that has been spent editing the picture.
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Export to File dialog box

This dialog box appears when you select Export to File from the File menu.

From this dialog box you can save all or part of your picture to a file in a variety of formats. This file can then be 
imported into other pictures or programs.

From this dialog box you can also choose to export to an .EPS file. Exporting to an .EPS file enables the file to be 
printed by a    colour printer. This option requires no colour separation.

Save in drop-down list box

Select a disk drive and folder in which you want to save your picture. Click on the arrow to the right-hand side of the 
Save in list box to drop-down a list of all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. If you want to overwrite a file, 
select the picture you want to overwrite by clicking on the filename or by entering the filename in the File Name text 
box.

File Name text box

Type the filename in which you want to export your picture or, if the file already exists, select it by clicking on the 
filename in the Folders list box.

If necessary, use the scroll bar to display more files.

Save as Type drop-down list box

Select the file format in which you want to export your picture. Files of the selected type in the current folder are 
displayed in the Folders list box. When you click on OK, greenstreet Draw warns you if you try to overwrite an 
existing file.

All Objects check box

Available only if you selected an object before displaying the Export to File dialog box. To export the selected 
objects only, clear the All Objects check box; to export the whole picture, check the All Objects check box.

Colours drop-down list box

Select the number of colours in which you want to export your picture. Click on the arrow to the right-hand side of 
the Colours list box to drop-down a list of all the options available.

If you are exporting a colour picture but want the colours to be converted into shades of grey in the exported 
file, select Monochrome.

Resolution text box

If you have chosen to export the picture in a bitmap file format, you can specify the resolution of the file. Click in the 
box and type the resolution. (Minimum resolution 10 dots per inch, maximum 1000 dots per inch.)
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Import from File dialog box

This dialog box appears when you select Import File from the File menu.

From this dialog box you can import a line-art or bitmap file into your picture.

Look in drop-down list box

Select a disk drive and folder. Click on the arrow to the right-hand side of the Look in list box to drop-down a list of 
all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. Select the file you want to 
import by clicking on the filename or by entering the filename in the File Name text box.

File Name text box

Displays the name of the selected file. If you have not selected a picture or template, you can type the known 
filename in this box.

Files of Type drop-down list box

Select the file format of the file you want to import. Files of the selected format found in the current folder are 
displayed in the Folders list box.

Smoothing check box

Check this box if you are importing a line-art file that you want to have smoothed. Some line-art files represent 
curves with a series of short straight lines; smoothing the line-art file will smooth these straight lines into curves, 
making the image clearer.

This check box is enabled only when you are importing a line-art file.

Smoothness (1-9) spin box

This box is enabled if you have checked the Smoothing check box. It controls the amount of smoothing: A larger 
number gives larger line segments and fewer points on each path. Type in the number you want, or use the arrows 
to select it.
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Page Format dialog box

This dialog box appears when you select Page Format from the File menu. From this dialog box you can specify 
the page size and related attributes for your picture.

Page Sizes list box

Select a pre-defined page size or type a new name in the Page Sizes box to create a new page size. When you 
create a new page size you must specify its dimensions in the Custom Page group box.

Custom Page group box

Specify the dimensions of a your new page size and add the page size to the list in the Page Sizes list box, or 
delete a custom page size:

Specify the Height and Width dimensions (the maximum values are 30 inches [76 cm]). You can change the 
units for these dimensions using the Units drop-down list box. 

Use the Add button to add a new page size to the list in the Page Sizes list box. You must type a name for 
the new page size in the Page Sizes box for the Add button to be enabled.

Use the Delete button to delete a selected page size. The page size is then removed from the list of 
available sizes. You cannot delete any of the pre-defined page sizes.

Picture Orientation group box

Select the orientation of your picture, i.e. Portrait (vertical) or Landscape (horizontal).

Picture Attributes group box

Specify whether your picture will be single or multi-layered, and whether you will be using colour separation.
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Print Options dialog box

This dialog box appears when you select Print from the File menu.

From this dialog box you can choose how to print your picture, e.g. to paper or to disk.

Output group box

Displays the currently selected printer.

Print to Disk: Select this option to print your picture to disk so that it can be printed at a later date, e.g. by a 
professional print bureau. When you click on OK the Print to Disk dialog box appears from where you must specify a 
filename and folder in which to print the file.

Copies spin box: Type the number of copies you want to print or use the arrows to set the number of copies 
you want.

Print Setup button: Click on this button to change the settings of the current printer or to select another 
printer. The Print Setup dialog box appears for you to set up the printer you want.

Scaling group box

Use scaling if you want to enlarge or reduce the size of the picture on printing.

Fit Page button: Click on this button to scale your picture so that it fits the paper size. If your picture is larger 
than the paper, your picture will be scaled down; if your picture is smaller than the paper, your picture will be scaled 
up.

Actual Size button: Click on this button so that it prints at actual size. You may need to use tiling to print the 
whole picture if your picture is larger than the paper size.

Scale button: Click on this button then type a scaling value into the % spin box or use the arrows to select 
the value you want. When the picture is scaled, it is scaled by the same amount in both dimensions.

Layers group box

When you are printing a multi-layer picture, the Layers group box is enabled.

All button: Click on this to print all layers in the picture.

Current button: Click on this to print the current layer of the picture.

From button: Click on this button then type the range of layers that you want to print. To print one specific 
layer, type the same layer number in both the From: and to: boxes.

Print Layer Zero check box: Select this check box to print layer zero of your picture.

Picture to Page group box

Picture: Displays the size of the picture.

Page: Displays the size of the paper currently selected for the default printer.

Number of Pages: Displays the number of pages on which the picture will be printed, e.g. If the picture is larger 
than the page, it will be printed as tiles over several pages.

Flip Orientation check box: Check this check box to change the orientation of the page between landscape 
and portrait without transforming the picture.

Allow Tiling check box: This box is automatically checked if your picture is larger than the paper it is being 
printed on. greenstreet Draw will then print your picture in portions (tiles) which you align using the crop and 
registration marks that are printed on each sheet. If your picture is larger than your paper size and you do not check 
the Allow Tiling box, greenstreet Draw will only print the top left-hand portion of the picture.

Options group box

Halftone Screen check box: Check this box to improve the quality of grey scales when printing a colour 
picture on a monochrome printer. This option is only available when you are printing to a non-PostScript printer or a 
monochrome printer.

Include Hidden Objects check box: Check this box to print objects that have been hidden in your picture.

Crop & Registration Marks check box: Check this box to print crop and registration marks. When tiling your 
picture, crop and registration marks will be printed even if this check box is cleared.

Reversed (Mirror Image) check box: Check this box to print your picture as a mirror image. This may be 
necessary when preparing a picture for commercial printing. This option is only available when printing to a 



PostScript printer.

Negative (White-on-Black) check box: Check this box to print your picture as a negative image. This may 
be necessary when preparing a picture for commercial printing. This option is only available when printing to a 
PostScript printer.

Colour Separation check box: Check this box to print your picture as colour separations. When you click on 
OK the Colour Separation dialog box appears from where you must choose the separations to print. This option is 
only available when Colour Separation has been specified on the Page Format dialog box, and is only available for 
PostScript.
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Colour Separation dialog box

This dialog box appears when you check the Colour Separation check box on the Print Options dialog box, then 
click on OK.

From this dialog box you can select which colour separations you want to print.

To display this dialog box you must have checked the Colour Separation box on the Page Format dialog 
box, and you must have a PostScript printer selected.

Separations list box

Displays the four process colours and any spot colours that you have created. The selected separations are 
indicated by an asterisk (*).

Print group box

Select which separations you want to print. Highlight the separation in the Separations list box and check the This 
separation check box to add it to the list. To remove a separation from the list, select the separation and clear the 
This separation check box.

To add or remove all separations, check or clear the All or No separations check box as necessary.

Halftone Screen group box

Displays the Angle and Frequency of the selected separation. These values can be adjusted if requested by your 
print bureau.
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Preferences dialog box

This dialog box appears when you select Preferences from the Options menu, or click on the Preferences button 
on the New Picture Options dialog box. From this dialog box you can control various greenstreet Draw settings.

The dialog box is divided into tab cards. Click on the tab card that you want Help with:

Preferences dialog box: Startup tab card

Preferences dialog box: New Window tab card

Preferences dialog box: Display tab card

Preferences dialog box: General tab card
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Preferences dialog box: Startup tab card

This tab card provides options to control the way greenstreet Draw starts up.

Startup Options group box

Display New Picture Options Dialog box button: Click on this button to make the New Picture Options 
dialog box appear every time you run greenstreet Draw. This option is preferable if you are unsure how you want to 
start work, or if you do not always start work in the same way.

Load Default Template button: Click on this button to make the default template be loaded automatically 
every time you run greenstreet Draw. 

Startup Display group box

Show Colour Bar check box: Check this box to display the colour bar along the bottom of the greenstreet 
Draw desktop.

Maximise Program Window check box: Check this box to display the greenstreet Draw window across the 
full area of your screen.

Show Info Line check box: Check this box to display the information line along the bottom of the 
greenstreet Draw desktop.

Number of Recently Used Files group box

In Dialog box: Type the number of files you want listed on the New Picture Options dialog box when 
opening a template or an existing picture. You can type any number between 0 and 20.

In File Menu box: Type the number of recently used picture files you want listed in the File menu. You can 
type any number between 0 and 20.
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Preferences dialog box: New Window tab card

This tab card provides options to control greenstreet Draw's behaviour when you open a new picture window.

New Window Settings group box

Provides options allowing you to control the display of each new picture window opened on the greenstreet Draw 
desktop.

Full Screen check box: Check this box to display the new window in the full area of the greenstreet Draw 
desktop.

Whole Page check box: Check this box to set the view size of the window to whole page view.

Preview check box: Check this box to display the new window in preview format.

Show Rulers check box: Check this box to display the rulers in the new window.

Show Grid check box: Check this box to display the grid in the new window.

Snap to Grid check box: Check this box to cause objects to align to the grid when they are drawn, sized or 
moved.

Open File group box

Provides options allowing you to determine what is displayed when you select Open from the File menu.

Standard 'Open File' dialog box check box: Check this box to display the Open dialog box when you 
select Open from the File menu (this is chosen by default).

'Open an Existing File' dialog box check box: Check this box to display the Open an Existing File tab 
card of the New Picture Options dialog box when you select Open from the File menu.
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Preferences dialog box: Display tab card

This tab card provides options to control how greenstreet Draw displays your work at various points in the program.

Preview group box

Display Page Outline check box: Clear this box to turn off the display of the blue page box  when your 
picture is displayed in preview format.

Allow Greeking check box: Check this box to allow text to be greeked when your picture is displayed in 
preview format.

Display Fills group box

This option lets you control the display quality of your picture when working in preview format.

Faster button: Select this option to redraw your pictures more quickly but less accurately when displayed in 
preview format

Smoother button: Select this option to redraw your pictures more slowly but more accurately when 
displayed in preview format.

Text group box

Use Vector Font For Outline Text check box: Determines how text is displayed when viewing your picture 
in outline format. If the box is checked, text is displayed using Windows vector fonts; if the box is cleared, text is 
displayed using its true outline. Text will be redrawn quicker when Vector Font is checked, but more accurately when 
it is cleared.

Greek Below box: Displays the size (in pixels) below which text will be greeked. If you do not want text 
below this size to be greeked when your picture is displayed in preview format, clear this check box. Text below this 
point size will always be greeked when your picture is displayed in outline format. Greeking speeds up the redrawing 
of text by showing a character as a single line stroke instead of its true shape.

Ole handler group box

Use OLE handler for embedding check box: Check this box to use the greenstreet Draw handler to display 
embedded files in your picture. Using the greenstreet Draw handler allows faster and more accurate rendering of the 
embedded file. Clear this check box to display a Windows Metafile version of embedded files.

We recommend that you leave this box checked unless you experience problems when displaying or 
printing embedded greenstreet Draw pictures. 
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Preferences dialog box: General tab card

File Options group box

Create .BAK Files check box: Check this check box if you want greenstreet Draw to save a backup copy of 
your documents.

Nudge Settings group box

In this box, you specify how the nudge control is to work.

Nudge To Grid Divisions button: Click on this button if you want the nudge control to make items snap to 
the grid as you move them.

Nudge By button: Click on this button if you want the nudge control to move items by a specified amount, 
and type the amount in the text box. You can change the units for this using the Units drop-down list box.

Nudge drop down list box: Change the units for your nudge settings using this drop-down list box. 

Ranges group box

Selection Range spin box: Specifies the distance (in pixels) within which you must click in order to select 
the object. Type a value or click the arrows to make the selection range larger or smaller.

Join Range spin box: Specifies how close together end points must be before greenstreet Draw will join 
them with a path. Type a value or click the arrows to make the join range larger or smaller.
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Print to Disk dialog box

This dialog box appears when you check the Print to Disk check box on the Print Options dialog box, then click 
on OK.

From this dialog box you can print your picture to a file on a disk, instead of printing it to paper. You will need to print 
your picture to disk if you intend having it printed by a professional print bureau.

Save in drop-down list box

Select a disk drive and folder to which you want to print your picture to. Click on the arrow to the right-hand side of 
the Save in list box to drop-down a list of all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. If you want to overwrite a file, 
select the picture you want to overwrite by clicking on the filename or by entering the filename in the File Name text 
box.

File Name text box

Type the name of the file to which you want to print your picture to or, if the file already exists, select it by clicking on 
the filename in the Folders list box.

If necessary, use the scroll bar to display more files.

Save as Type drop-down list box

Select the file format in which you want to print your file to disk. The files of this format in the current folder are 
displayed in the Folders list box.

You must print your picture to disk as a PostScript file (.EPS) using a PostScript printer driver if you intend 
having it printed by a professional print bureau.
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Print Setup dialog box

This dialog box appears when you select Print Setup from the File menu, or when you click on the Print Setup 
button on the Print Options dialog box.

From this dialog box you can select and set up any of the printers you have installed to print your greenstreet Draw 
picture.

Printer group box

Name drop-down list box: This box displays the name of the selected printer. To select a different printer, 
click on the arrow to the right-hand side of the Name box to drop-down a list of the available printers. Click on a 
printer name to select it.

Properties button: Click on this button to display the Properties dialog box for the printer you have 
selected. The options on this dialog box depend on which printer is selected.
Paper group box

Size drop-down list box: Click on the arrow to the right-hand side of the Size box to drop-down a list of 
available paper sizes. Select the size of the paper loaded in your printer.

Source drop-down list box: Click on the arrow to the right-hand side of the Source box to drop-down a list of 
available paper sources for your selected printer. Select the source from which your printer loads paper.
Orientation group box

Portrait: Select this option to print your picture in portrait (vertical) orientation.

Landscape: Select this option to print your picture in landscape (horizontal) orientation.
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Blend dialog box

This dialog box appears when you select two objects, then select Blend from the Edit menu.

From this dialog box you can blend two objects together, controlling the number of blend stages.

No. of Blend stages spin box

Type the number of blend stages you want, or use the arrows to adjust the value.

First Stage and Last Stage boxes

These values control by how much the object is transformed at the first and last blend stages respectively, i.e. the 
proportion of the transformation done in these steps. The default values depend on the number of blend stages 
chosen and are calculated so that the blend will be even and gradual. Normally these values will not need to be 
changed but you can adjust them if necessary.

    Related Topics



Grid dialog box

This dialog box appears when you select Grid from the View menu.

From this dialog box you can display a grid to help you align objects and judge their size when creating your picture.

Show Grid check box

Check this box to display a grid for the picture in the active window.

Snap to Grid check box

Check this box to ensure that objects align to the grid when they are drawn, moved or sized.

Align to Page check box

Check this box to align the grid to the top left-hand corner of the page.

Align to Ruler check box

Check this box to align the grid to the ruler origin. If the ruler origin is at the top left-hand corner of the page, Align 
to Ruler will be disabled.

Spacing group box

Use this group box to type the width and height of each grid cell.

Divisions group box

Use this group box to specify the number of sub divisions across and down each individual grid cell. Clicking on the 
Copy button will copy the horizontal settings to the vertical settings to create a square grid.

Units drop-down list box

Click on the arrow to the right-hand side of the Units box to drop-down a list of available units; select a unit of 
measurement for the grid. The grid units can be different from the ruler units.
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Layers dialog box

This dialog box appears when you select Layers from the View menu. If your picture is not multi-layered, the 
Layers command will be disabled.

From this dialog box you can add or delete layers, rename a layer, or make another layer the current layer.

Layers list box

Lists the currently available layers, with the current layer highlighted. To make another layer the current layer, click 
on it in the list box.

Name text box

Displays the name of the current layer. To rename a layer, edit the name in this box; to add a new layer, type a new 
name for the layer in this box.

Layer Number spin box

Displays the number of the current layer. To add a new layer, type a new layer number in this box or use the arrows 
to adjust the figure.

Add Layer button

Click on this button to add a new layer to the list in the Layers list box.

You must type a name and number for the new layer in order to enable this command.

Delete Layer button

Click on this button to delete the current layer. The layer will be removed from the Layers list box.

You cannot delete Layer Zero or any layer containing objects.

You must select another layer before clicking on OK, otherwise the deleted layer will be recreated.

Number of objects in layer: Displays the number of objects on the current layer.
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Align dialog box

This dialog box appears when you select Align from the Object menu.

From this dialog box you can align objects to each other or to the page. You can align a number of objects to the 
left, centre or right, and to the top, middle or bottom. A preview box shows how the alignment will take effect.

Each other or Page

Click on Each other or Page to select whether objects are aligned to each other or to the page.

If one of the selected objects is locked when you align to each other, all the objects will align to the locked 
object.

If one of the selected objects is locked when you align to the page, the locked object will not move to the 
new position.

Horizontal group box

Click on Left, Centre, Right, or Off.

The preview box illustrates how your objects will align, given the selection that you make.

Vertical group box

Click on Top, Middle, Bottom, or Off.

The preview box illustrates how your objects will align, given the selection that you make.
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Shape Properties dialog box

This dialog box appears when you select a basic shape, then select Properties from the Object menu. It also 
appears when you right-click the Pointer tool on a basic shape and select Object Properties from the shortcut 
menu that appears.

From this dialog box you can view information about the selected shape and change some of its attributes.

Shape group box

Use this group box to change the attributes of the selected shape.

Shape drop-down list box: Displays the current shape of the selected object and allows you to change it with 
the drop-down list box. Click on the arrow to the right-hand side of the Shape box to drop-down a list of basic shapes; 
click on a shape to change the shape of the selected object.

Layer Number text box: Displays the layer on which the selected object is currently displayed. To move the 
object to another layer, type the layer number in the Layer box. If the layer number you type does not exist, it will be 
created. This option is only available when your picture is multi-layered.

Corner Radius text box: This box is available when the selected object is a round box; it allows you to 
change the corner radius of the box.

Start Angle and End Angle text boxes: These boxes are available when the selected object is an arc or a 
pie slice; they allow you to change the appearance of the shape by altering its angles.

Sides text box: This box is available when the selected object is a polygon; it allows you to change the 
number of sides on the polygon.

Points and Inner Radius text boxes: These boxes are available when the selected object is a star; they 
allow you to change the number of points on the star and specify how pointed it is.

Position group box

Displays the object's position. Use this group box to specify exactly where the object should be positioned in your 
picture. You can specify the position of the left, centre or right of the object in the horizontal dimension, and the top, 
middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the object's dimensions. Use this group box to specify the exact dimensions of the object. Alter the value in 
the Width and Height text boxes to resize the object precisely.

Locked check box

Check this box to lock the selected object. When an object is locked, several options on this dialog box become 
disabled because they do not apply to a locked object.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.
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Group of Objects dialog box

This dialog box appears when you select a group of objects, then select Properties from the Object menu. It also 
appears when you right-click the Pointer tool on a group of objects and select Object Properties from the shortcut 
menu that appears.

From this dialog box you can view information about the selected group and change some of its attributes.

Objects group box

Number of Objects in Group: Displays the number of objects in the group.

Locked check box: check this box to lock the selected group. When a group is locked several options on 
this dialog box become disabled because they do not apply to locked objects.

Layer Number text box: Displays the layer on which the selected group is currently displayed. To move the 
group to another layer, type the layer number in the Layer box. If the layer number you type does not exist, it will be 
created. This option is only available when your picture is multi-layered.

Position group box

Displays the group's position. Use this group box to specify exactly where the group should be positioned in your 
picture. You can specify the position to the left, centre or right of the group in the horizontal dimension, and the top, 
middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the group's dimensions. Use this group box to specify the exact dimensions of the group. Alter the value in 
the Width and Height text boxes to resize the group precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.
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Element Properties - Bitmap Image dialog box

This dialog box appears when you select an imported bitmap, then select Properties from the Object menu. It also 
appears when you right-click the Pointer tool on an imported bitmap and select Object Properties from the shortcut 
menu that appears.

From this dialog box you can view information about the selected bitmap and change some of its attributes.

Bitmap group box

Filename: Displays the filename of the selected bitmap.

Size in pixels: Displays the size of the selected bitmap in pixels.

No. of colours: Displays the number of colours in the selected bitmap.

Layer Number text box: Displays the layer on which the selected bitmap is currently displayed. To move the 
bitmap to another layer, type the layer number in the Layer box. If the layer number you type does not exist, it will be 
created. This option is only available when your picture is multi-layered.

Negative check box: Check this box to invert the colours of the selected bitmap. This option is only available 
when a two colour bitmap is selected.

Locked check box: Check this box to lock the selected bitmap. When a bitmap is locked several options on 
this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the bitmap's position. Use this group box to specify exactly where the bitmap should be positioned in your 
picture. You can specify the position of the left, centre or right of the bitmap in the horizontal dimension, and the top, 
middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the bitmap's dimensions. Use this group box to specify the exact dimensions of the bitmap. Alter the value 
in the Width and Height text boxes to resize the bitmap precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.
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Element Properties - PostScript dialog box

This dialog box appears when you select an imported PostScript EPSF (.EPS) file, then select Properties from the 
Object menu. It also appears when you right-click the Pointer tool on an imported EPS file and select Object 
Properties from the shortcut menu that appears.

From this dialog box you can view information about the selected EPS file and change some of its attributes.

PostScript group box

Filename: Displays the filename of the selected EPS file.

Layer Number text box: Displays the layer on which the selected EPS file is currently displayed. To move 
the EPS file to another layer, type the layer number in the Layer text box. If the layer number you type does not exist, 
it will be created. This option is only available when your picture is multi-layered.

Locked check box: Check this box to lock the selected EPS file. When an object is locked several options 
on this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the EPS file's position. Use this group box to specify exactly where the EPS file should be positioned in 
your picture. You can specify the position of the left, centre or right of the EPS file in the horizontal dimension, and 
the top, middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the EPS file's dimensions. Use this group box to specify the exact dimensions of the EPS file. Alter the 
value in the Width and Height text boxes to resize the EPS file precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.

    Related Topics



Path Properties dialog box

This dialog box appears when you select a path or a point on a path, then select Properties from the Object menu. 
It also appears when you right-click the Pointer tool on a path or point and select Object Properties from the 
shortcut menu that appears.

From this dialog box you can view information about the selected path and change some of its attributes.

Path group box

Pasted: Indicates how many objects (if any) are pasted inside the closed path.

Contours: Indicates how paths are within a path. This is useful when a compound path is selected.

Layer No. text box: Displays the layer on which the selected path is currently displayed. To move the path to 
another layer, type the layer number in the Layer box. If the layer number you type does not exist, it will be created. 
This option is only available when your picture is multi-layered.

Winding Fill check box: Check this box to apply the current fill style to all the enclosed areas that have been 
created by the path crossing over itself. This option is enabled only when a closed path is selected.

Locked check box: Check this box to lock the selected path. When the path is locked, several options on 
this dialog box become disabled because they do not apply to locked objects.

Path Closed check box: Check this to close an open path.

No. Points Selected group box

When the path has some points selected, this group box indicates how many points are selected and of which type. 
You can change the type of selected points, e.g. from corner points to connector points. You can also turn the auto 
curvature of the selected points on or off. Turning Auto curvature off lets you edit points without the path being 
constrained to greenstreet Draw's automatic curvature.

Position group box

Displays the path's position. Use this group box to specify exactly where the path should be positioned in your 
picture. You can specify the position of the left, centre or right of the path in the horizontal dimension, and the top, 
middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the path's dimensions. Use this group box to specify the exact dimensions of the path. Alter the value in 
the Width and Height text boxes to resize the path precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.

    Related Topics



Text on a Path dialog box

This dialog box appears when you select text on a path, then select Properties from the Object menu. It also 
appears when you right-click the Pointer tool on the text on a path and select Object Properties from the shortcut 
menu that appears.

From this dialog box you can view information about the selected text on a path and change some of its attributes.

Options group box

Show Path check box: Check this box to display the path to which the text is joined.

Joined check box: Clear this box to split the text and the path back into two separate objects.

Reverse Direction check box: Check this box to reverse the direction in which the text flows along the path.

Locked check box: Check this box to lock the selected path. When the path is locked, several options on 
this dialog box become disabled because they do not apply to locked objects.

Align text to path using group box

Use this group box to change the way in which text flows along the path by selecting a different alignment position.

Top: Produces the effect of the characters hanging down from the path.

1/2 Cap-height: Produces the effect of the path running through the characters at half the height of the 
upper case characters in the selected font.

Baseline: Produces the effect of the characters standing on the path. (This is the default alignment).

x-height: Produces the effect of the path running through the characters at the height of the top of a lower 
case x character in the selected font.

1/2 x-height: Produces the effect of the path running through the characters at half the height of a lower 
case x character in the selected font.

Descender: Produces the effect of the path following the bottom of the descender characters in the selected 
font.

Text Orientation group box

Use this group box to create different effects by changing the text orientation.

Rotate baseline: The characters are positioned perpendicular to the path. (This is the default orientation).

Skew baseline: The vertical elements of the characters remain vertical while the horizontal elements are 
parallel to the path.

Upright: The characters follow the path but remain upright.

Skew vertical: The horizontal elements of the characters remain horizontal while the vertical elements are 
at right angles to the path.

Spacing button

Click on this button to display the Spacing dialog box from where you can change the spacing of the text.

Path Info button

Click on this button to display the Path Properties dialog box for the path to which the text is joined.
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Spacing dialog box

This dialog box appears when you right-click the Pointer tool on a text object, then select Text Spacing from the 
shortcut menu that appears. It also appears when you click on the Spacing button in the Text Properties and the 
Text on a Path dialog boxes.

From this dialog box you can set parameters controlling the spacing of letters, words and lines of a text object.

All the options on this dialog box can be changed by entering the value in the appropriate box, or by using 
the arrows to scroll to the value you want.

Leading spin box

Adjust the leading (spacing) between the lines of text. 

Word Space spin boxes

Adjust the minimum and maximum spacing between the words in the text.

Letter Space spin boxes

Adjust the minimum and maximum spacing between the letters in the text. 

Reset button

Click on this button to set all the values back to their defaults.
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Text Properties dialog box

This dialog box appears when you select a text object, then select Properties from the Object menu. It also 
appears when you right-click the Pointer tool on a text object and select Object Properties from the shortcut menu 
that appears.

From this dialog box you can view information about the selected text object and change some of its attributes.

Text group box

Spacing button: Click on this button to display the Spacing dialog box from where you can change the 
spacing of the text object.

Layer Number text box: Displays the layer on which the selected text object is currently displayed. To move 
the object to another layer, type the layer number in the Layer box. If the layer number you type does not exist, it will 
be created. This option is only available when your picture is multi-layered.

Locked check box: Check this box to lock the selected text object. When an object is locked, several 
options on this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the object's position. Use this group box to specify exactly where the object should be positioned in your 
picture. You can specify the position of the left, centre or right of the object in the horizontal dimension, and the top, 
middle or bottom in the vertical dimension. The co-ordinates are specified from the ruler origin.

Size group box

Displays the object's dimensions. Use this group box to specify the exact dimensions of the object. Alter the value in 
the Width and Height text boxes to resize the object precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.
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Multiple Objects dialog box

This dialog box appears when you select more than one object, then select Properties from the Object menu. It 
also appears when you right-click the Pointer tool on two or more selected objects and select Object Properties 
from the shortcut menu that appears.

From this dialog box you can see how many objects are currently selected, and the range of layers in which they 
are positioned.
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Move Objects to Layer dialog box

This dialog box appears when you select To Layer from the Object menu, or when you press Ctrl T. If your picture 
is not multi-layered, or you have not selected an object, the To Layer command will be disabled.

From this dialog box you can move selected objects to a specific layer.

To Layer spin box

Displays the layer on which the selected objects are currently displayed. To move the objects to another layer, type 
the layer number in the To Layer spin box. If the layer number you type does not exist, it will be created.

Layer Names list box

Displays all the layers in your picture. To move the selected objects to another layer, click on the layer name to 
which you want to move them.
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Reflect dialog box

This dialog box appears when you double-click the Reflect tool on one or more selected objects.

From this dialog box you can reflect object(s) across a reflection axis.

Reflect across group box

Select the axis that you want the object(s) to be reflected across. This can be a Vertical or Horizontal axis, or if you 
select Angled Axis, you can specify an angle in the box provided, or drag the radius in the circle.

Fixed Point group box

Select the origin (fixed point) of the reflection.

Mouse Click: Reflects the object(s) at the point where you double-clicked the mouse to display this dialog 
box

Centre of Selection: Reflects the object(s) at the central point of the selection.

XY Location: Reflects the object(s) at the precise position specified in the Across and Down boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down text boxes. Click 
on the arrow to the right-hand side of the Units box to drop-down a list of available units. You can then select a 
different unit of measurement.

Copy Objects check box

Check this box to reflect a copy of the selected object(s) while leaving the original unchanged.
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Rotate dialog box

This dialog box appears when you double-click the Rotate tool on one or more selected objects.

From this dialog box you can rotate object(s) accurately.

Rotation group box

Specify the angle of rotation. You can type the angle into the Angle spin box, use the arrows to increase or 
decrease the value, or drag the radius in the circle.

Fixed Point group box

Select the origin (fixed point) of the rotation.

Mouse Click: Rotates the object(s) at the point where you double-clicked the mouse to display this dialog 
box

Centre of Selection: Rotates the object(s) at the central point of the selection.

XY Location: Rotates the object(s) at the precise position specified in the Across and Down boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down text boxes. Click 
on the arrow to the right-hand side of the Units box to drop-down a list of available units. You can then select a 
different unit of measurement.

Copy Objects check box

Check this box to rotate a copy of the selected object(s) while leaving the original unchanged.
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Skew dialog box

This dialog box appears when you double-click the Skew tool on one or more selected objects.

From this dialog box you can skew object(s) accurately.

Skew group box

Specify the Horizontal and Vertical skew factors by entering a value directly into the spin boxes or by using the 
arrows to increase or decrease the value.

Fixed Point group box

Select the origin (fixed point) of the skew.

Mouse Click: Skews the object(s) at the point where you double-clicked the mouse to display this dialog 
box

Centre of Selection: Skews the object(s) at the central point of the selection.

XY Location: Skews the object(s) at the precise position specified in the Across and Down boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down text boxes. Click 
on the arrow to the right-hand side of the Units box to drop-down a list of available units. You can then select a 
different unit of measurement.

Copy Objects check box

Check this box to skew a copy of the selected object(s) while leaving the original unchanged.
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Scale dialog box

This dialog box appears when you double-click the Scale tool on one or more selected objects.

From this dialog box you can change the size of object(s) accurately.

Scaling group box

Select Uniform to scale the object(s) equally in both vertical and horizontal directions, then set the percentage by 
which you want to scale using the spin box. Select Non Uniform to scale the object(s) differently in vertical and 
horizontal directions, then set the horizontal (X) and the vertical (Y) scale factors separately using the spin boxes.

Fixed Point group box

Select the origin (fixed point) of the scale.

Mouse Click: Scales the object(s) at the point where you double-clicked the mouse to display this dialog 
box

Centre of Selection: Scales the object(s) at the central point of the selection.

XY Location: Scales the object(s) at the precise position specified in the Across and Down boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down text boxes. Click 
on the arrow to the right-hand side of the Units box to drop-down a list of available units. You can then select a 
different unit of measurement.

Copy Objects check box

Check this box to scale a copy of the selected object(s) while leaving the original unchanged.
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Move Objects dialog box

This dialog box appears when you right-click the Pointer tool on one or more selected objects, then select 
Move/Copy from the shortcut menu that appears, or when you select an object, then double-click on the Pointer 
tool in the toolbox.

From this dialog box you can move and position object(s) accurately. 

Horizontal group box

Type the amount by which you want to move the object(s) horizontally and select whether they should move to the 
left or the right.

Vertical group box

Type the amount by which you want to move the object(s) vertically and select whether they should move upwards 
or downwards.

To move the object(s) in a diagonal direction, move the objects both horizontally and vertically.

Units drop-down list box

Displays the unit of measurement used in the Horizontal and Vertical group boxes. Click on the arrow to the right-
hand side of the Units box to drop-down a list of available units. You can then select a different unit of 
measurement.

Copy Objects check box

Check this box to move a copy of the selected object(s) while leaving the original unchanged.
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Rounded Box dialog box

This dialog box appears when you double-click on the Round Box tool.

From this dialog box you can adjust the curvature (corner radius) given to a round box when it is drawn.

Default Corner Radius text box

Type the corner radius you want.

Reduce the corner radius to make the box more square; increase the corner radius to make the box more 
circular.

Units drop-down list box

Displays the unit of measurement used in the Default Corner Radius text box. Click on the arrow to the right-hand 
side of the Units box to drop-down a list of available units. You can then select a different unit of measurement.

Any round boxes that you now draw will be given the corner radius that you have specified until you change 
it again.

To change the corner radius of an existing round box, double-click the Pointer tool on the round box and 
select Object Properties from the shortcut menu that appears. You can then change the corner radius of the box in 
the Shape Properties dialog box.
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Freehand dialog box

This dialog box appears when you double-click on the Pencil tool.

From this dialog box you can adjust the smoothness value; this determines the accuracy at which a path follows the 
movements of the pencil.

Smoothness spin box

Type the smoothness value in the box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the movements of the pencil tool, 
making the path appear rough with many points. 

Increasing the smoothness will produce a path that does not follow the movements of the pencil tool so 
closely, but smoothes out the path so that it has fewer points.

Any freehand paths that you now draw will be given the smoothness value that you have specified until you 
change it again.
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Autotrace dialog box

This dialog box appears when you double-click on the Autotrace tool.

From this dialog box you can adjust the smoothness value; this determines the accuracy at which a path is 
autotraced.

Smoothness spin box

Type the smoothness value in the box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the original bitmap.

Increasing the smoothness will produce a path that does not follow the original bitmap so closely but 
smoothes out the path so that it has fewer points.

Any paths that you now autotrace will be given the smoothness value that you have specified until you 
change it again.
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Polygon dialog box

This dialog box appears when you double-click on the Polygon tool.

From this dialog box you can specify the number of sides given to a polygon when it is drawn.

No. of Sides spin box

Type the number of sides you want, or use the arrows to increase or decrease the number.

The preview box illustrates the shape that your polygon will adopt.

Any polygons that you now draw will be given the number of sides that you have specified until you change 
them again.

To change the number of sides on an existing polygon, right-click the Pointer tool on the polygon and select 
Object Properties from the shortcut menu that appears. You can then change the number of sides in the Shape 
Properties dialog box.
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Star dialog box

This dialog box appears when you double-click on the Star tool.

From this dialog box you can specify the number of points given to a star when it is drawn and how pointed the star 
will be.

No. of Points spin box

Type the number of points you want, or use the arrows to increase or decrease the number of points.

Star Inner Radius text box

Type the inner radius, or drag the slider to increase or decrease the inner radius.

Reduce the inner radius to make the star more pointed; increase the inner radius to make the star less 
pointed.

The preview box illustrates the shape that the star will adopt.

Any stars that you now draw will be given the number of points and the inner radius that you have specified 
until you change them again.

To change the number of points and the inner radius of an existing star, right-click the Pointer tool on the star 
and select Object Properties from the shortcut menu that appears. You can then change the number of points and 
the inner radius in the Shape Properties dialog box.
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Line Ends dialog box

This dialog box appears when you select Ends from the Line menu.

From this dialog box you can specify the way the ends of the selected line style, and any subsequent line styles, are 
drawn.

Arrowheads drop-down list boxes

Click on the arrow to the right-hand side of each list box to drop-down a list of available arrowheads. You can then 
choose the type of arrowhead you want (if any) for either end of the line style.

Ends drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available end styles. You can then 
choose the end for the line style: Butt, round or square.

Join drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available join styles. You can then 
choose the join for the line style: Mitre, round or bevel.

Do not Mitre angles below text box

Displays the minimum angle at which joins will be mitred when the selected join style is Mitre. Specify the angle that 
you want by typing it in the box. Joins below this angle will be bevelled instead of mitred.

The line style of any objects that you now draw will be given the line ends that you have specified until you 
change them again.
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Edit Colour dialog box

This dialog box appears when you select Edit Colours from the Edit menu, then select the colour that you want to 
edit and click on the Edit button. It also appears when you double-click on a colour in the colour bar.

From this dialog box you can modify an existing colour. The colour appears in the preview box, which illustrates 
your changes as you edit the colour.

Name text box

Displays the name of the selected colour, or indicates that the colour is unnamed. If you want to rename the colour, 
type a new name in the Name box.

Model group box

Select the colour model that you want to use.

RGB: This colour model uses a proportion of red, green and blue to mix any other colour.

CMYK: This colour model uses a percentage of cyan, magenta, yellow and black to mix any other colour.

HLS: This colour model uses hue, lightness and saturation to mix any other colour.

Slider controls

Use the slider controls to mix the colour that you want.

Colour blocks

Eight colour blocks are displayed around the preview box. You can click on these colour blocks as an alternate to 
choosing a colour model and mixing a colour. For example, click on the blue colour block to make your colour more 
blue.

Spot Colour check box

This appears only when your picture has been set up for colour separation. Check this box to save the colour as a 
spot colour. The colour can then be printed as an individual separation giving a cleaner, brighter effect.

To save a colour as a spot colour, the colour must be named.

When you click on OK, any objects already using the colour you have edited will be redrawn with the edited 
colour.
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New Colour dialog box

This dialog box appears when you select Edit Colours from the Edit menu, then click on the Add button in the Edit 
Colours dialog box. It also appears when you click on the + button at the right-hand end of the colour bar.

From this dialog box you can create a new colour. The colour you create appears in the preview box, which 
illustrates your changes as you mix the colour.

Name text box

Type a name for the colour in the Name text box. If you do not name your colour, it will still be added to the colour 
bar and marked as unnamed.

Model group box

Select the colour model that you want to use.

RGB: This colour model uses a proportion of red, green and blue to mix any other colour.

CMYK: This colour model uses a percentage of cyan, magenta, yellow and black to mix any other colour.

HLS: This colour model uses hue, lightness and saturation to mix any other colour.

Slider controls

Use the slider controls to mix the colour that you want.

Colour blocks

Eight colour blocks are displayed around the preview box. You can click on these colour blocks as an alternate to 
choosing a colour model and mixing a colour. For example, click on the blue colour block to make your colour more 
blue.

Spot Colour check box

This appears only when your page format has been set up for colour separation. Check this box to save the colour 
as a spot colour. The colour can then be printed as an individual separation giving a cleaner, brighter effect.

To save a colour as a spot colour, the colour must be named.

When you click on OK, the colour is added to the colour bar and can be applied to objects in your picture.
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Tile Pattern dialog box

This dialog box appears when you select Pattern from the Fill menu. It also appears when you select an existing 
pattern in the Fill Style popup and click on the Pattern button.

From this dialog box you can create a pattern from a group of objects by tiling the group into a fill style, or you can 
edit an existing pattern.

Name text box

Type a name for the pattern.

Scale spin box

Specify the size of the tiles by entering a percentage in the box, or by using the arrows to increase or decrease the 
percentage. The preview box will display the pattern you are creating.

When you type a low percentage, a message may be displayed in the preview box stating that the pattern is 
too small to be displayed on screen. The pattern will however be printed correctly.

Angle spin box

Specify the angle of the tiles by entering a value in the box, or by using the arrows to increase or decrease the 
angle. You can also adjust the angle by dragging the radius of the circle.

Offset group box

Horizontal and Vertical text boxes: Set the horizontal and vertical offsets of the pattern by entering a value 
in each box. The offsets determine the alignment of the pattern when it is applied to an object. By adjusting the 
offsets of patterns, you can change the way in which patterns align with each other when they are applied to 
overlapping objects.

Units drop-down list box: Displays the unit of measurement used in the Horizontal and Vertical boxes. 
Click on the arrow to the right-hand side of the Units box to drop-down a list of available units. You can then select a 
different unit of measurement.
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PostScript Halftone Screen dialog box

This dialog box appears when you expand the Fill Styles popup and click on the Halftone button. The Halftone 
button is disabled when you have a PostScript fill style selected.

From this dialog box you can create a halftone fill style. This is useful when you want to print the fill style on a 
PostScript printer at the best possible quality.

Default Settings check box

Clear this box to enable the Screen group box; you can then type values other than the defaults.

Screen group box

Type list box: Select the shape you want. A PostScript printer can print a halftone fill style in any of the 
shapes listed; each shape will produce a different effect.

Frequency spin box: Change the frequency of the selected shape by clicking the arrows next to the box, or 
by entering a value directly into the box. The frequency determines the density of the shape.

Angle spin box: Change the angle of the selected shape by clicking the arrows next to the box, or by 
entering a value directly into the box. The angle determines the position at which the shape will be printed.
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PostScript Styles dialog box

This dialog box appears when you expand the Line or Fill Style popup, then click on the PostScript button.

From this dialog box you can create a PostScript line or fill style. PostScript styles cannot be displayed on screen 
and can only be printed to a PostScript printer.

Styles list box

Select a PostScript style from the list box.

Description group box

Displays information about the selected style; not all styles have associated information.

Parameter spin boxes

Display style-specific parameters that can be edited; not all styles have associated parameters.

The available parameters depend on the selected style. Many styles allow you to edit their length and width; 
some styles provide other parameters that can be edited. For example, the Bricks fill style displays information about 
the width and height of each brick and the thickness of the mortar between the bricks. You can edit these values to 
create a different pattern.
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Load Colours dialog box

This dialog box appears when you select Edit Colours from the Edit menu, then click on the Load button on the 
Edit Colours dialog box.

From this dialog box you can load a colour palette.

Look in drop-down list box

Select a disk drive and folder. Click on the arrow to the right-hand side of the Look in list box to drop-down a list of 
all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. Select the colour you want to 
load by clicking on the filename or by entering the filename in the File Name text box.

File Name text box

Displays the name of the selected colour. If you have not selected a picture or template, you can type the known 
filename in this box.

Files of Type drop-down list box

As colour palettes are all saved as .COL files, this is the only file format available. All .COL files in the current folder 
are displayed in the Folders list box.
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Save Colours dialog box

This dialog box appears when you select Edit Colours from the Edit menu, then click on the Save button on the 
Edit Colours dialog box.

From this dialog box you can specify the disk drive, folder and filename in which to save a colour palette.

Save in drop-down list box

Select a disk drive and folder in which you want to save your colour. Click on the arrow to the right-hand side of the 
Save in list box to drop-down a list of all the disk drives and folders available.

If necessary, use the scroll bar to scroll through the list of drives and folders and select the one you want.

Folders list box

Displays all the folders in the path from the root to the current folder, and a list of all sub-folders contained in the 
current folder. Click on any folder to select it; double-click to make it the current folder. If you want to overwrite a file, 
select the picture you want to overwrite by clicking on the filename or by entering the filename in the File Name text 
box.

File Name text box

Type the filename in which you want to save your colour palette. If the file already exists, select it by clicking on the 
filename in the Folders list box.

Save as Type drop-down list box

As colour palettes are all saved as .COL files, this is the only file format available. All .COL files in the current folder 
are displayed in the Folders list box but are disabled; when you click on OK, greenstreet Draw warns you if you try 
to overwrite an existing file. 
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Name Style dialog box

This dialog box appears when you click on the Name button in the Line Style or the Fill Style popup.

From this dialog box you can save a line or fill style with a name.

Name text box

Type a name for the new line or fill style.

When you save a picture, it is saved with the line and fill styles that have been named. If you want to use 
these line and fill styles in other pictures, you must save them into a template.

You do not have to name a line or fill style. However, if you do not name a style it will not be added to the list 
in the menu or popup and will not be saved as part of a template.
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Edit Colours dialog box

This dialog box appears when you select Edit Colours from the Edit menu.

From this dialog box you can create new colours, edit existing colours, delete colours, save colours in a colour 
palette and load an existing colour palette.

This dialog box allows you to select several colours at once, which is useful when you want to delete more than one 
at a time.

Names list box

Displays the colour palette for the active window. Select the colour that you wish to edit or delete. Spot colours are 
indicated by a dot next to their names. The selected colour appears in the preview box at the bottom of the dialog 
box.

If necessary, use the scroll bar to view more colours.

Sort by name/Sort by colour buttons

Choose the order in which to sort the colours in the Names list box by clicking on your preferred option.

Colour Bar group box

Tints of each colour spin box: Specify the number of tints of each colour you would like shown on the 
colour bar.

Add button

Click on this button to display the New Colour dialog box. From this dialog box you can create a new colour.

Edit button

Click on this button to display the Edit Colour dialog box. From this dialog box you can edit the colour selected in 
the Names list box.

Delete button

Click on this button to delete the colour(s) selected in the Names list box. You cannot delete the colour Black.

Load button

Click on this button to display the Load Colours dialog box. From this dialog box you can load a saved palette. This 
will be merged in with your existing colours.

Save button

Click on this button to display the Save Colours dialog box. From this dialog box you can save the colour palette for 
use with other pictures.
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Line Style popup

This popup appears when you select Popup Lines from the Line menu.

From this popup you can apply a line style to selected objects, or create and name a new line style. Click on an 
area of the popup below to see a description of its function.

The Line Style popup is left open on the desktop and can be resized and positioned as you want. To close the 
popup, click on its Control-menu icon.

The current line style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this line style.
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Click on this button to close the popup. You can also close the popup using the Control menu.



Displays the named line styles available to the picture in the active window. Click on a named style to apply it to a 
selected object, or select the style that you want to edit or base a new style on.



Click on this button to display the Name Style dialog box. From this dialog box you can name a new line style, or 
rename an existing style that you have modified.

For more information on the Name Style dialog box, refer to its Help.



Click on this button to delete the line style currently selected in the style list box.



Set a separate style for the left end, body and right end of the line; click on the section you want to drop-down a list 
of available styles. Each line end can have one of eleven styles, including different arrowheads. The body can have 
one of eight styles, including custom and PostScript.

As you specify aspects of the line style, these three section boxes act as a preview box to display the line 
style you have set.



Drag the slider along the scale to alter the width of the line. The width that you choose appears in units in the Width 
box: You can type directly into this box to obtain a precise line width.



Displays the precise line width for the selected line style. Edit the value in this box to change the line width 
precisely.



Click on the arrow to drop-down the colour palette, then select the colour that you want. The currently selected 
colour is marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of colour. Hold down Ctrl whilst dragging 
the slider to change the tint by increments of 10%. The tint that you choose appears in the Tint box as a 
percentage.



Click on the arrow to the right-hand side of the list box to drop-down a list of available end styles. You can then 
select the end for the line style: Butt, round and square.

If you choose a dashed or dotted line style, the line end will apply to each dash or dot along the path.



Click on the arrow to the right-hand side of the list box to drop-down a list of available join styles. You can then 
select the join for the line style: Mitre, round or bevel.



Displays the minimum angle at which joins will be mitred when the selected join style is Mitre. Specify the angle that 
you want by typing it in the box. Joins below this angle will be bevelled instead of mitred.



Click on this button to apply the current line style to any selected objects. This line style is then the default style and 
is applied to any new objects that you draw.



Click on this button to reduce the Line Style popup. When the popup is reduced, click on the >> button to expand it.



These boxes are enabled only when you have selected Custom for the body of the line. Use these boxes to specify 
the length of the dashes and gaps for your custom line style.



This button is enabled only when you have selected PostScript for the body of the line. Click on this button to 
display the PostScript Styles dialog box from where you can select a PostScript line style.

For more information on the PostScript Styles dialog box, refer to its Help.



This check box is only displayed when the page format has been set up for colour separation. Check this box to 
enable overprinting when producing colour separations.



Fill Style popup

This popup appears when you select Popup Fills from the Fill menu.

From this popup you can apply a fill style to selected objects, or create and name a new fill style. Click on an area of 
the popup below to see a description of its function.

The Fill Style popup is left open on the desktop and can be resized and positioned as you want. To close the 
popup, click on its control-menu icon.

The current fill style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this fill style.
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Displays the named fill styles available to the picture in the active window. Click on a named style to apply it to a 
selected object, or select the style that you want to edit or base a new style on.



Click on this button to display the Name Style dialog box. From this dialog box you can name a new fill style, or 
rename an existing style that you have modified.

For more information on the Name Style dialog box, refer to its Help.



Click on this button to delete the fill style currently selected in the style list box.



Choose one of nine fill styles: None, plain, linear, logarithmic, cylindrical, radial, spherical, random or PostScript.



Displays the fill style you have chosen. If you have chosen a linear, logarithmic or cylindrical style, an arrow appears 
over the fill style in the preview box. Drag this arrow to adjust the angle of the fill style. The angle is given in the 
angle box.

Press Ctrl whilst dragging the arrow to restrict the angle to multiples of 15 degrees.



Displays the angle of rotation for the selected linear, logarithmic or cylindrical line style. Edit the value in this box to 
give the fill style a precise rotation.



Click on the arrow to drop-down the colour palette, then select the colour you want. The currently selected colour is 
marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of colour. Hold down Ctrl whilst dragging 
the slider to change the tint by increments of 10%. The tint that you select appears in the Tint box as a percentage.



If you have selected a graduated fill style, a second colour palette appears. Click on the arrow to drop-down the 
colour palette, then select the "to colour" you want. The currently selected colour is marked by a frame. The colour 
of the fill style will then fade from the other colour to this colour according to the selected graduation.

Drag the slider along the tint selector to increase or decrease the density of the "to colour". Hold down Ctrl whilst 
dragging the slider to change the tint by increments of 10%. The tint that you select appears in the Tint box as a 
percentage.



Click on this button to apply the current fill style to any selected objects. This fill style is then the default style and is 
applied to any new objects that you draw.



Click on this button to reduce the Fill Style popup. When the popup is reduced click on the >> button to expand it.



This button is enabled only when you have selected a PostScript fill style. Click on this button to display the 
PostScript Styles dialog box from where you can select a PostScript fill style.

For more information on the PostScript Styles dialog box, refer to its Help.



Click on this button to display the PostScript Halftone Screen dialog box from where you can set up a halftone fill 
style. This button is disabled when you have selected a PostScript fill style.

For more information on the Halftone Screen dialog box, refer to its Help.



This check box is only displayed when the page format has been set up for colour separation. Check this box to 
enable overprinting when producing colour separations.



greenstreet Software Ltd. has accumulated a vast wealth of knowledge in the field of graphics and desktop 
publishing software development. For full information on the company and its product availability (including language 
information), please view the greenstreet.htm file included on the root of your CD. You will need to use an 
appropriate browser such as Microsoft Internet Explorer or Netscape Navigator to view this document.
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greenstreet® Publisher 4 Gold is the latest version of our award-winning desktop publishing package for 
Windows. The program combines powerful desktop publishing features with extreme ease-of-use at an 
astoundingly low price:

No experience necessary! Simply tell the program what type of document you want and the New document 
wizard will create instant designs for you.

Create professionally printed stationery using your desktop printer - simply use one of the templates for 
business cards, letterheads and envelopes included with the product.

Call on professional power as you need it – greenstreet Publisher has all the features you'll want to use as 
you become more experienced.

greenstreet is a registered trademark of greenstreet Software Limited.



greenstreet® Draw is our drawing and illustration package for Windows. The program combines powerful drawing 
features and ease-of-use at an affordable price:

No design experience necessary! greenstreet Draw's PagePilot will create logos in minutes.

Experiment with a host of stunning effects, e.g. blends, skews, rotations and patterns, then use them to liven 
up your DTP, WP and other Windows documents with the help of OLE2 technology.

Produce professional-looking documents in an instant. With a combination of shapes, text, clipart and 
special effects, it's easy to create posters, report covers, presentation slides and more!

Ideal for beginners, but includes comprehensive design features for professionals too, such as full colour 
separation.

Use greenstreet Draw as the ideal partner to greenstreet Publisher to produce striking documents.

greenstreet is a registered trademark of greenstreet Software Limited.






