
To show or hide the toolbar
On the View menu, click Toolbar.

When the command has a check mark next to it, the toolbar is displayed.

Note

The toolbar buttons are shortcuts for various menu items.

{button ,AL("Displaying the status bar;Running in No Title mode")} Related Topics



To show or hide the status bar
On the View menu, click Status Bar.

When the command has a check mark next to it, the status bar is displayed.

Note

The status bar displays the total number of active processes, the total number of active threads, and the system time.

{button ,AL("Displaying the toolbar;Running in No Title mode")} Related Topics



To run Performance ’95 in No Title mode
On the View menu, click No Title.

Tips
While in No Title mode, menu items can still be selected by using the accelerator keys noted next to each item.
The Performance ’95 window cannot be moved while in No Title mode. Therefore, you should place the Performance ’95 

window where you want it to be before entering No Title mode.
Press Ctrl+N to return from No Title mode. Apart from closing the application (by pressing Alt+F4) and restarting it, there is 

no other way to return from No Title mode.

{button ,AL("Displaying the toolbar;Displaying the status bar")} Related Topics



To zoom in or out
On the View menu, click Zoom In, Zoom Out, or Zoom 100%.

Tips
You can also zoom in or out by clicking the Zoom In, Zoom Out, or Zoom 100% buttons on the toolbar.
Zoom In and Zoom Out can be repeatedly selected for higher degrees of zooming.



To set fonts

1 On the View menu, click Fonts.

2 From the displayed Modify Fonts dialog box, select the item to modify, and then click Modify.

3 Click the options you want.

Tips
You can also modify fonts by clicking the Fonts button on the toolbar.
When returned to the Modify Fonts dialog box, you can select another item to modify, or close the box to return to the 

main display.
As each item is modified, the formatting is applied in the main display in the background.
You can click Undo All to undo all changes made since the Modify Fonts dialog box was opened.

{button ,KL("Setting table properties")} Related Topics



To set table properties
On the View menu, click Properties, and then click the options you want.

Tips
You can also set table properties by clicking the Properties button on the toolbar.
The table background color is visible when the display is larger than the table.

{button ,KL("Setting fonts")} Related Topics



To adjust a column’s width
Click on the column’s right border and drag it to the desired location.

Tip
To restore all columns’ widths, click on View, and then click on Resize Table.

{button ,AL("rows, adjusting heights;Resize Table command;columns, moving")} Related Topics



To adjust a row's height
Click on the row’s bottom border and drag it to the desired location.

Tip
To restore all rows’ heights, click on View, and then click on Resize Table.

{button ,KL("columns, adjusting widths;Resize Table command")} Related Topics



To resize table cells
On the View menu, select Resize Table.

Tips
Use Resize Table any time the table cells need adjusting.
If you accidentally or temporarily change the size of a row or column, use Resize Table to restore it to the appropriate 

size.

{button ,AL("rows, adjusting heights;columns, adjusting widths")} Related Topics



To save user settings
On the File menu, click Save.

Tip
User settings are automatically saved when Performance ’95 is closed.

{button ,KL("Restoring user settings to their default state")} Related Topics



To restore user settings to their default state
On the File menu, click Reset.

Tip
Once the settings are reset, Performance ’95 will be closed and will need to be manually reopened.

{button ,KL("Saving user settings")} Related Topics



To filter the display
On the Display menu, click Filter and then select the processes that you want to exclude from the display.

You can also choose to automatically exclude all new processes.
The Demo Version uses the filtering dialog to display CPU and memory information for one process.

Tips
You can also filter the display by clicking the Filter button on the toolbar.
You can automatically filter new processes by checking the Filter new processes checkbox.



To display threads
To display a particular process’ threads, right-click on that process’ row header, and then click Expand.

To display all threads, click on the Display menu, and then click Expand All.

Tips
You can also display a particular process’ threads by double-clicking on that process’ row header.
You can also display all threads by clicking the Expand All button on the toolbar.
Displaying only pertinent threads will reduce Performance ’95’s own CPU utilization requirements.

{button ,AL("Hiding threads;Minimizing CPU utilization requirements")} Related Topics



To hide threads
To hide a particular process’ threads, right-click on that process’ row header, and then click Collapse.

To hide a specific thread, right-click on that thread’s row header, and then click Hide.

To hide all threads, click on the Display menu, and then click Collapse All.

Tips
You can also hide a particular process’ threads by double-clicking on that process’ row header, or a specific thread by 

double-clicking on that thread.
You can also hide all threads by clicking the Collapse All button on the toolbar.
Displaying only pertinent threads will reduce Performance ’95’s own CPU utilization requirements.

{button ,AL("Displaying threads;Minimizing CPU utilization requirements")} Related Topics



To select columns for display
On the Display menu, click Select Columns, and then select the columns to be displayed.

Tips
You can also select columns for display by clicking the Select Columns button on the toolbar.
Displaying only needed columns will reduce Performance ’95’s own CPU utilization requirements.

{button ,AL("Specifying a display format;Minimizing CPU utilization requirements")} Related Topics



To specify a display format
Right-click on the header of the column to format, and then click a display format from the list. A check mark appears next 

to the item.

{button ,AL("Selecting columns for display;Sorting the display")} Related Topics



To move a column
Click on the column’s header and drag it to the desired header location.

When dragged to the left, the column appears to the left of the column to which it was dragged; when dragged to the right, it 

appears to the right of that column.

Tip
The Process column is fixed and cannot be moved.

{button ,AL("landi;lowell")} Related Topics



To sort the display
Click on the header of the column to sort by. A plus sign appears, indicating that it is the sort column in ascending order.

Click a second time on the header to reverse the sort order. A minus sign appears, indicating descending order.

Tips
You can also sort the display by right-clicking on the header of the sort column, and then clicking Sort Ascending or Sort 

Descending.

{button ,KL("Specifying a display format")} Related Topics



To set the display update frequency

1 On the Display menu, click Set Frequency.

2 Enter the desired frequency in the Display Update Frequency field.

Tips
You can also set the display update frequency by clicking the Set Frequency button on the toolbar.
Setting the display update frequency to 60 seconds and manually updating the display when needed will minimize the use 

of system resources.
Clicking Default will restore the frequency to its factory-default setting.

{button ,AL("Setting the file logging frequency;Setting the Data Resolution mode;Manually updating the display;Minimizing CPU 

utilization requirements")} Related Topics



To set the Data Resolution mode
On the Control menu, select Operating Mode, and set the Data Resolution mode to either Normal or High.

Tips
Setting the Data Resolution mode to High may significantly and adversely impact system performance, and should only 

be used on high-end systems, if at all.
All items in the display can be immediately updated by clicking Refresh All on the Display menu.
Clicking Default restores the Data Resolution mode to its factory-default setting.

{button ,AL("Setting the display update frequency;Manually updating the display")} Related Topics



To manually update the display
To update a particular process or thread, right-click on that item’s row header, and then click Refresh.

To update all items, click on the Display menu, and then click Refresh All.

Tips
You can also update all items by clicking the Refresh All button on the toolbar.

{button ,AL("Setting the display update frequency;Setting the Data Resolution mode")} Related Topics



To copy data to the Windows 95 clipboard
On the Edit menu, click Copy.

Tips
You can also copy data to the clipboard by clicking the Copy button on the toolbar.
Once data is copied to the clipboard, it can be pasted into any Windows application.
The CPU Utilization column will not be copied if displayed in Bar Graph mode. Change to Decimal mode before copying to 

the clipboard.

{button ,KL("Specifying a display format")} Related Topics



To set the file logging frequency

1 On the Display menu, click Set Frequency.

2 Enter the desired frequency in the File Logging Frequency fields.

Tips
You can also set the file logging frequency by clicking the Set Frequency button on the toolbar.
Clicking Default restores the frequency to its factory-default setting.
Once the file logging frequency is set, you must enable file logging to begin logging to a file.

{button ,AL("Setting the display update frequency;Logging data to a file")} Related Topics



To log data to a file

1 On the File menu, click Log Data.

2 In the Look In box, click the drive that contains the file to which data will be logged.

3 Below the Look In box, click the folder that contains the file.

4 Click the file’s name, or type it in the File Name box.

5 Click Overwrite File to overwrite an existing file, or Append to File to append the data to the end of an existing file.

6 Click Begin to begin logging to the file.

Tips
The file logging frequency is set via the Set Frequency function.
To end file logging, click File, then click Log Data, and then click End.

File logging is also automatically disabled when Performance ’95 is closed.
Performance ’95 can be minimized while file logging is in progress to minimize consumption of system resources.

{button ,AL("Setting the file logging frequency;Minimizing CPU utilization requirements")} Related Topics



To preview the display before printing
On the File menu, click Print Preview.

Tips
Data will continue to be updated while in Print Preview mode.
Click Close to return from Print Preview mode.

{button ,KL("Printing the display")} Related Topics



To print the display
On the File menu, click Print.

Tips
You can also print the display by clicking the Print button on the toolbar.
The CPU Utilization column will be blank if printed in Bar Graph mode. Change to Decimal mode before printing to print 

values.
The text of the thread row headers may not print if formatted as white text. Change to black text before printing to print 

values.
To configure the current printer, click on File, and then click on Print Setup.

{button ,AL("Specifying a display format;Previewing the display before printing")} Related Topics



To examine a process’ or thread’s properties

1 On the Control menu, click Master Control.

2 To view a process’ properties, click on the process in the Name column of the Master Program Control dialog box, and then 

click Properties.

To view a thread’s properties, click on the process to which the thread belongs in the Name column of the Master Program 

Control dialog box, and then click Properties.

Tips
You can also access the Master Program Control dialog box by clicking the Master Control button on the toolbar.
You can also examine a process’ properties by right-clicking on the process’ row header and then clicking Properties.

You can also examine a thread’s properties by right-clicking on the row header of the process to which the thread belongs, 

and then clicking Properties.
The Properties dialog box is not automatically refreshed. Click Refresh to refresh the dialog box.

{button ,AL("set process;set thread level;terminate")} Related Topics



To set a process’ base priority class

1 On the Control menu, click Master Control.

2 Click on the process in the Name column of the Master Program Control dialog box, and then click Priority.

3 Select a base priority class from the list.

Tips
You can also access the Master Program Control dialog box by clicking the Master Control button on the toolbar.
You can also set a process’ base priority class by right-clicking on the process’ row header and then clicking Priority.

{button ,AL("examine;set thread level;terminate")} Related Topics



To set a thread’s base priority level

1 On the Control menu, click Master Control.

2 Click on the thread in the Name column of the Master Program Control dialog box, and then click Priority.

3 Enter the base priority level.

Tips
You can also access the Master Program Control dialog box by clicking the Master Control button on the toolbar.
You can also set a thread’s base priority level by right-clicking on the thread’s row header and then clicking Priority.

{button ,AL("examine;set process;terminate")} Related Topics



To terminate an application

1 On the Control menu, click Master Control.

2 Click on the process to terminate in the Name column of the Master Program Control dialog box, and then click Terminate.

Tips
You can also access the Master Program Control dialog box by clicking the Master Control button on the toolbar.
You can also terminate an application by right-clicking on the process' row header and then clicking Terminate.
The Terminate function should only be used when you are unable to close the program using normal methods.

{button ,AL("examine;set process;set thread level")} Related Topics



To minimize Performance ’95’s own CPU utilization requirements

Perform one or more of the following:
Display only pertinent column items.
Display only pertinent threads, rather than all threads.
Hide some or all of the memory utilization items.
Sort the table to keep the data you are interested in near the top, then resize the table to display only the first few rows.
Lengthen the display update and file logging intervals.
Minimize Performance ’95 when the display is not being monitored.

Tips
If Performance ’95 is not being continually monitored, the display update frequency can be set to 60 seconds (the 

maximum allowed), and the display can be manually updated when needed.
File logging can be used to track system performance while Performance ’95 is minimized.

{button ,AL("Selecting columns for display;Hiding threads;Sorting the display;Manually updating the display;Setting the display 

update frequency;Setting the file logging frequency;Logging data to a file")} Related Topics



To improve Performance ’95’s responsiveness

1 If threads are not showing, right-click on the PERF95.EXE process row header, and click Expand to display its threads.

2 Right-click on the first PERF95.EXE thread and select Priority. The first thread will be the one with the smallest Universal 

Thread Index.

Be sure to only right-click on the first PERF95.EXE thread. Modifying any other thread will adversely affect your system 

performance.

3 From the displayed Set Thread Priority dialog box, change the Base Priority Level value from 8 to 9.

{button ,KL("threads, setting base priority levels ")} Related Topics



The Universal Thread Index is the value following “Thread” in the row header.



Row headers are the items on the far-left of the rows.



The memory utilization items are Private Code, Private Data, Shared Code and Shared Data.



The Data Resolution mode determines how often memory utilization items are updated. Normal Resolution mode updates one 

process’ memory utilization items at each screen update; High Resolution mode updates all processes’ memory utilization items 

at each screen update.



The frequency at which items in the display are updated.



The frequency at which data is logged to a file, when file logging is enabled.



The display format specifies how the data in the column will be displayed. Some typical display formats are Text, Decimal and 

Hexadecimal.



A process will have a value in the Process column.



A thread will have values in the Index and Thread columns.



When Performance ’95 is run in No Title mode, the toolbar, status bar, title bar, and menu bar are hidden. Only the scroll bars (if 

any) are visible. This allows for maximum compactness of size.





No Help topic is associated with this item.



Modify the font for Column heads, Process Row heads, Thread Row heads or Table cells.



Modify the currently selected font.



Undo changes made to any of the fonts.



Provide additional help for this dialog box.



Check this to display vertical lines.



Check this to display horizontal lines.



Choose the color for the horizontal and vertical table lines.



Choose the color for the table background.



This column displays the process name for a process, and "Thread" followed by the universal thread index for a thread. The 

column is mandatory, and cannot be removed.



Check to include Process and Thread IDs.



Check to include Parent Process IDs.



Check to include the number of threads in a process.



Check to include the current priority level for a thread and a copy of the priority class for a process.



Check to include the base priority level for a thread and the priority class for a process.



Check to include the total running time (since Performance '95 started).



Check to include the total CPU time used (since Performance '95 started).



Check to include the current CPU utilization percentage (a process' percentage is the sum of its threads' percentages).



Check to include the amount of private memory used for program code.



Check to include the amount of private memory used for program data.



Check to include the amount of shared memory used for program code.



Check to include the amount of shared memory used for program data.



Enter the display update frequency.



Enter the display update frequency.



Enter the file logging frequency.



Enter the file logging frequency.



Enter the file logging frequency.



Enter the file logging frequency.



Reset the display update frequency and the file logging frequency to the factory default values.



Provide additional help for this dialog box.



Select a process or thread from the table.



Change the execution priority for the currently selected process or thread.



Terminate the currently selected process.



Display properties for the currently selected process.



Refresh the table.



Provide additional help for this dialog box.



Close the dialog box.



Select Normal data resolution (recommended).



Select High data resolution (not recommended).



Reset Analysis and Data Resolution modes to the factory default values.



Select the priority class for the process.



Provide additional help for this dialog box.



Provide additional help for this dialog box.



This is the process name.



This is the process name.



This is the process ID.



This is the process ID.



This is the ID of the process’s parent.



This is the ID of the process’s parent.



This is the priority class for the process.



This is the priority class for the process.



This is the amount (in kilobytes) of private code and read-only memory in use by the process.



This is the amount (in kilobytes) of private code and read-only memory in use by the process.



This is the amount (in kilobytes) of private data and read-write memory in use by the process.



These are all the threads owned by the process. The columns are:

Universal Index Thread ID CPU Utilization Base Priority 

Level

Current Priority 

Level

This ID is 

assigned in 

increasing order

This ID indirectly 

addresses 

system data 

structures.

Percentage CPU 

time used at last 

refresh.

Base execution 

priority level for 

the thread.

Current 

execution priority 

for the thread.

Note: Click on any column header to sort the table. The dividers between columns can be dragged to change the column 

widths.



These are all the threads owned by the process.    The columns are:

Universal Index Thread ID CPU Utilization Base Priority 

Level

Current Priority 

Level

This ID is 

assigned in 

increasing order

This ID indirectly 

addresses 

system data 

structures.

Percentage CPU 

time used at last 

refresh.

Base execution 

priority level for 

the thread.

Current 

execution priority 

for the thread.

Note: Click on any column header to sort the table. The dividers between columns can be dragged to change the column 

widths.



This is the percentage CPU time used by the process at the last refresh.



This is the percentage CPU time used by the process at the last refresh.



This is the total CPU time (in seconds) used by the process since Performance '95 started.



This is the total CPU time (in seconds) used by the process since Performance '95 started.



This is the total time the process has been running since Performance '95 started.



This is the total time the process has been running since Performance '95 started.



Refresh all the data in this display.



Provide additional help for this dialog box.



This is the parent process for this thread.



This is the parent process for this thread.



This is the ID for this thread.



This is the ID for this thread.



Enter the new base priority level for this thread.



Provide additional help for this dialog box.



Choose the file logging mode. Overwrite will first erase the file if it already exists; Append will add to the end of the    file if it 

already exists.



Open the file in append mode. If the file already exists, new log data will be appended to the end of the file.



Open the file in overwrite mode. If the file already exists, it will first be erased and then overwritten with the new log data.



Begin or end file logging.



Lists the available background colors for the specified font.



Lists the available background colors for the specified font.



Shows a sample of how text will appear with the specified color settings.



Modify Fonts Dialog Box

This dialog box lists the items whose fonts can be modified. To modify a font item, select the item from the list, and click Modify. 

You will be brought into the Fonts dialog box for that item, from which font information can be selected.

When you are returned to this dialog box, you can select another item to modify, or close the box to return to the main display.

As each item is modified, the formatting is applied to the item in the main display in the background.

Clicking Undo All will undo all changes made since the dialog box was opened.



Set Frequency Dialog Box

This dialog box allows you to set the frequency at which the display is updated and data is logged to a file (when file logging is 

enabled).
To set the frequency at which the display is updated, enter a value between 1 second and 60 seconds in the Display 

Update Frequency field.
To set the frequency at which data is logged to a file, enter a value between 5 seconds and 60 minutes in the File Logging 

Frequency field.

The file logging frequency must be a multiple of the display update frequency. If it is not, the value will be rounded down to 

the nearest multiple of the display update frequency when the dialog box is closed.

Clicking Default will restore both of these items to their factory-default settings.



Master Program Control Dialog Box

This dialog box lists all active processes and threads, along with their IDs and indexes. From here, you can examine process 

and thread properties, adjust execution priorities, and terminate applications.
To view a process' properties, click on the process in the Name column, and then click Properties.
To view a thread’s properties, click on the process to which the thread belongs in the Name column, and then click 

Properties.
To set a process' priority class, click on the process in the Name column, and then click Priority.
To set a thread’s base priority level, click on the thread in the Name column, and then click Priority.
To terminate an application, click on the process to terminate in the Name column, and then click Terminate.



Set Process Priority Dialog Box

This dialog box allows you to change a process priority class. Select a value from the Base Priority Class list box and click OK.

The four priority classes are:
Idle    The Idle priority class is intended for processes whose threads will execute only when no other thread requires the 

CPU. Background tasks such as spoolers and screen savers are usually assigned an Idle priority.
Normal    The Normal priority class is the default class for most processes.
High    The High priority class is recommended for processes having threads that need to respond quickly to system or 

application events.
Realtime    The Realtime priority class is the highest priority class, and is generally not recommended for use by 

programs, due to its extremely high priority level.



Set Thread Priority Dialog Box

This dialog box allows you to change a thread’s base priority level. Enter a value in the Base Priority Level text box and click 

OK.

The base priority level is usually set to a predefined offset from the process priority class, but may take on any value from 0 to 

31. Windows 95 uses base priority levels to determine when and for how long threads execute.

Refer to the Performance ’95 User’s Guide for more information on base priority levels.



Terminate Process Dialog Box

Clicking OK from this dialog box will terminate the selected application immediately, usually bypassing any closing dialog boxes 

or other standard program closing features. This should only be used when you are unable to close the application using 

normal methods, such as when it is frozen.



Process Properties Dialog Box

Each of the items in this dialog box corresponds to an item in the main display for the selected process. The Threads area lists 

all threads associated with the process, along with some of the threads’ properties. This provides a convenient way to view 

process and thread properties without having to have all items showing in the main display.



Filter Dialog Box

This dialog box lists all active processes along with their IDs.From here, you can select individual processes to be filtered 

(excluded) from the display.

Note: The Performance ‘95 demo version uses this dialog box to display CPU and memory information for a single process.
To exclude a process, click on the process in the Name column and then click Exclude.
To include a process, click on the process in the Name column and then click Include.
To start filtering, click Filter On.
To stop filtering, click Filter Off.
To refresh the list of processes, click Refresh List.
To clear all filter selections, click Clear All.
To automatically exclude new processes, check the Filter new processes checkbox.



Filter Dialog Box

This dialog box lists all active processes along with their IDs.From here, you can select individual processes to be filtered 

(excluded) from the display.

Note: The Performance ‘95 demo version uses this dialog box to display CPU and memory information for a single process.
To exclude a process, click on the process in the Name column and then click Exclude.
To include a process, click on the process in the Name column and then click Include.
To start filtering, click Filter On.
To stop filtering, click Filter Off.
To refresh the list of processes, click Refresh List.
To clear all filter selections, click Clear All.
To automatically exclude new processes, check the Filter new processes checkbox.



Include the currently highlighted process in the display.



Exclude the currently highlighted process from the display.



Closes this dialog box and activates filter selections.



Closes this dialog box and deactivates all filtering.



Select a process from the table.



Refresh the table.



Clear all filter selections.



Closes this dialog box without saving any changes you have made.



Provide additional help for this dialog box.



Select a process from the table.



Refresh the table.



Closes this dialog box and saves any changes you have made.



Closes this dialog box without saving any changes you have made.



Provide additional help for this dialog box.



Automatically exclude all new processes from the display.






