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About BROWSER

About BROWSER from the Help menu displays a welcome screen showing the BROWSER software version 
number and application copyright information. 

See also: Help Menu



Application Window

All actions occur in the BROWSER software application window. You display the contact sheet window in the 
application window, and the window also contains the BROWSER software menus. 

See also: Contact Sheet Window



Backing Up Catalog Files

You should have at least one up-to-date backup copy of each catalog saved on your hard disk. The backup should be 
stored on a different medium from your working catalog.



Catalog Menu
The Catalog menu commands allow you to view thumbnail information.

Get Info Sheet (CTRL+I) displays file information, user information, keywords, and the caption for a 
thumbnail selected from the contact sheet window.



Clear

You use Clear from the Edit menu to remove the selected thumbnail and all associated image information from the 
catalog. Clear does not place the thumbnail or the image information on the Clipboard.You can reverse the clear 
action by immediately choosing Undo from the Edit menu (CTRL+Z).

See also: Delete Thumbnails



Clipboard
The Clipboard provides a temporary storage area for photos that you have copied from a photo window.

The Clipboard holds only one object at a time, which it stores in the application memory. The size of the photo that 
you can transfer to the Clipboard depends on the amount of available application memory. Copying a high-
resolution (large) photo to the Clipboard requires a large amount of memory. If you do not have sufficient 
application memory for the size of the photo being copied, save the photo to a file and then import the photo into 
your application, rather than copying it to the Clipboard.

Choose Show Clipboard from the Edit menu to see the contents of the Clipboard.



Close

You use Close from the File menu (CTRL+F4) to close the active contact sheet window. If any changes were made 
to a catalog since the last save, BROWSER software displays a dialog box asking you if you want to save the 
changes before closing. If no changes were made, BROWSER software closes the window without displaying a 
dialog box.

You use Close from the photo window Control-menu (CTRL+F4) to close the active photo window.



Contact Sheet Window

You use the contact sheet window to view, assemble, and search multimedia content files that are stored on KODAK 
Photo CD and Catalog CD discs.

Thumbnails display in the order in which they were placed on the Photo CD disc. You use Thumbnail Layout from 
the File menu to select thumbnail resolution and to change contact sheet window defaults. 

If all thumbnails are not visible in the contact sheet window, you can see additional thumbnails by using the window 
scroll bar or by using the PAGE UP and PAGE DOWN keys to advance up one row or down one row. You can also 
resize the contact sheet window by clicking the Maximize button in the upper-right corner of the contact sheet 
window, by double-clicking the window title bar, or by dragging the corner or border of the window.

To view file information, user information, keywords, and the caption for a selected thumbnail, select one or more 
thumbnails from the contact sheet window and choose Get Info Sheet from the Catalog menu (CTRL+I).

See also: Get Info Sheet
Thumbnail Layout



Copy

You use Copy from the Edit menu (CTRL+C) to copy an entire photo or a portion of a photo that is displayed in a 
photo window. Photos copied to the Clipboard can be pasted into WINDOWS software applications that support the 
Clipboard copy and paste functions. You can also use Copy to move thumbnails between catalogs. 

Using the Copy command makes a copy of the selected photo, or one or more thumbnails, and all associated image 
information, and places it on the Clipboard without removing the content files from the source catalog. Choose 
Show Clipboard from the Edit menu to see the contents of the Clipboard.

You use the copy keyboard accelerator CTRL+C to copy caption text from the Caption field. Caption text can pasted 
into the another Caption field in the same catalog or into the Caption field in another catalog.



Copy Entire Photo 
You can copy the entire photo displayed in a photo window to the Clipboard.    Photos copied to the Clipboard can 
be pasted into any application that supports WINDOWS software copy and paste functions. To copy a displayed 
photo, choose Copy from the Edit menu (CTRL+C) to copy the photo to the Clipboard without first drawing a Copy 
Marquee. 

Using the Copy command makes a copy of the selected photo and places it on the Clipboard without removing the 
photo from the photo window. Choose Show Clipboard from the Edit menu to see the contents of the Clipboard.

See also: Copy Portion of a Photo



Copy Portion of a Photo

You can copy a portion of the photo from a photo window to the Clipboard. A photo copied to the Clipboard can be 
pasted into any application that supports WINDOWS software copy and paste functions.

To copy a portion of the photo, create a selection region by clicking the arrow cursor in the upper-left corner of the 
area you want to copy and dragging the cursor down and to the lower-right corner of the photo. Choose Copy from 
the Edit menu (CTRL+C). Only the portion of the photo within the copy marquee copies to the Clipboard. To 
remove the copy marquee, click the arrow cursor anywhere outside the marquee

Choose Show Clipboard from the Edit menu to see the contents of the Clipboard. 

See also: Copy Entire Photo



Copy Thumbnails Between Catalogs
You use Copy from the Edit menu (CTRL+C) to copy one or more thumbnails from one catalog or contact sheet 
window to another. Using the Copy command makes a copy of the selected thumbnail and all associated image 
information and places it on the Thumbnail Clipboard without removing the thumbnail from the source catalog. You 
can also move thumbnails between catalogs by using the drag-and-drop method.

You use Preferences from the File menu (CTRL+K) to select whether BROWSER software automatically creates 
and copies any missing field names from the source catalog into the destination catalog or if only matching fields are 
copied.

To paste the copied thumbnail from the Clipboard, click the title bar of the destination catalog and choose Paste 
from the Edit menu (CTRL+V)

See also: Drag-and-Drop to Move Thumbnails
Preferences



Cut

You use Cut from the Edit menu (CTRL+X) to remove the selected thumbnail and all associated image information 
from a catalog. You use the keyboard accelerator CTRL+X to cut caption text from the Caption field. To reverse the 
Cut action, choose Undo from the Edit menu (CTRL+Z).

Cut places the thumbnail and image information on the Clipboard. The selection remains on the Clipboard until you 
cut or copy another selection. Choose Show Clipboard from the Edit menu to see the contents of the Clipboard (note 
that the thumbnail clipboard is a private format and is not displayable). You can paste a cut thumbnail from the 
Clipboard into another catalog.

See also: Delete Thumbnails

Crop

You use Crop from the Edit menu to remove areas of a displayed photo that you do not want to include in the final 
output. To reverse the crop action or to remove the crop marquee, choose Undo from the Edit menu (CTRL+Z).

To crop a photo, first create a selection region on the photo by clicking the arrow cursor in the upper-left corner of 
the area you want to crop and dragging the cursor down and to the lower-right corner of the photo drawing. 

Adjust the crop marquee by placing the arrow over the edge of the marquee and dragging the marquee edge inward 
to reduce the marquee and outward to enlarge it. To adjust the marquee without adjusting its size, click the arrow 
inside the marquee and, while holding down the mouse button, drag the marquee to position it. 

Choose Crop from the Edit menu to crop the photo. 

The cropped photo replaces the original photo in the photo window. The cropped photo can be saved to your hard 
disk, copied to the Clipboard, or printed.



Delete Thumbnails

You can select thumbnails in the contact sheet window and remove them from your catalog. To delete thumbnails, 
click the thumbnail to select it and choose Cut or Clear from the Edit menu. 

Clear removes the selected thumbnail and all associated image information from the catalog, but does not place 
it on the Clipboard.

Cut (CTRL+X) removes the selected thumbnail and all associated image information from the catalog and 
places it on the Clipboard. 

You can reverse the clear or cut action by immediately choosing Undo from the Edit menu (CTRL+Z).



Deselect Thumbnails 

You can use both keyboard and mouse actions, as well as the Deselect command from the Display/Select menu to 
deselect thumbnails from the active contact sheet window. When you deselect thumbnails, the highlighted border 
around all deselected thumbnails is removed.

To deselect a single thumbnail or all the thumbnails:

Individual Thumbnails Hold down the SHIFT key and click the thumbnails that you want to exclude from 
your selection. You can also use the keyboard arrow keys to deselect thumbnails. Hold down the SHIFT key, use 
the arrow keys to move the selection frame to the thumbnail you want to deselect, and press the SPACE BAR to 
deselect each thumbnail.

All Thumbnails Choose Deselect from the Display/Select menu to cancel all thumbnail sections. You can also 
click any one of the selected thumbnails to deselect all the thumbnails with the exception of the thumbnail on 
which you clicked.



Display All

You use Display All from the Display/Display menu to display all thumbnails in the contact sheet window and to 
redisplay all thumbnails in the contact sheet window following a search.



Display Menu

The Display menu commands allow you to search the catalog database; to display, select, and mark thumbnails; to 
sort thumbnails using BROWSER software assigned fields; and to set and start a slide show.

Search (CTRL+F) allows you to search the information assigned each thumbnail during indexing.

Display provides a cascading list of display commands that you use to select thumbnails for display in the 
contact sheet window.

Select provides a cascading list of commands that you use to select thumbnails for    display in the contact sheet 
window.

Mark provides a cascading list of commands that you use to place a semipermanent checkmark on all the 
thumbnails or only on selected thumbnails.

Sort By provides a submenu of fields that can be used to sort thumbnails in the catalog. 

Set Slide Show provides a dialog box that you use to select the timing of the slide show, choose whether you 
want a sound file to accompany the slide show, and determine how the thumbnails will appear in the slide show.

Start Slide Show (CTRL+L) begins the slide show.



Display Marked

You use Display Marked from the Display/Display menu to change the contact sheet window to display only those 
thumbnails that are currently marked.



Display Selected

You use Display Selected from the Display/Display menu to change the contact sheet window to show only those 
thumbnails that are currently selected.



Drag-and-Drop to Move Thumbnails

You can move thumbnails from one catalog or contact sheet window to another. To move thumbnails, select the 
thumbnails, hold down the mouse button, and drag the thumbnails from the source catalog to the destination catalog. 
A marquee containing a parachute icon indicates that the thumbnails are selected and being transferred. 

The thumbnails and all associated image information transfer to the destination catalog and also remain in the source 
catalog.

You use Preferences from the File menu (CTRL+K) to select whether BROWSER software automatically creates 
and copies any missing field names from the source catalog into the destination catalog or if only matching fields are 
copied.

See also: Copy Thumbnails Between Catalogs

Preferences



Edit Menu

The Edit menu provides commands to undo or redo the last action for supported features; to cut, copy, paste, and 
clear thumbnails; to crop a photo; and to show the contents of the Clipboard.

Undo (CTRL+Z) cancels the effects of the last action. 

Cut (CTRL+X) removes the selected thumbnail and all associated image information from a catalog and places 
it on the Clipboard. 

Copy (CTRL+C) puts a duplicate of the selected thumbnail or the displayed photo in a photo window on the 
Clipboard. The original thumbnail or photo remains unchanged.

Paste (CTRL+V) places the contents of the Clipboard in the destination catalog or document.

Clear removes the selected thumbnail and all associated image information from the catalog, but does not place 
the thumbnail and image information on the Clipboard.

Crop removes areas of a displayed photo that you do not want to include in the final output.

Show Clipboard displays the Clipboard and allows you to see the current contents of the Clipboard. 



Exit

You use Exit from the File menu (ALT+F4) to exit the BROWSER software application.



File Menu

The File menu provides commands allow you to open a new contact sheet window or an existing catalog; to load 
digitized images in a contact sheet that are stored on a Photo CD Master disc or a Photo CD Catalog disc; to close 
the active window; to save catalogs and selected thumbnails to the hard disk; to customize contact sheet window 
settings; to assign catalog merge options; and to quit the application.

New (CTRL+N) opens an empty contact sheet window on the program desktop. You can create your own 
project catalogs by copying images from different Photo CD or Photo CD Catalog disks to this new contact 
sheet, then saving it

Open (CTRL+O) opens an existing catalog saved to your disk. 

Load Contact Sheet loads images that are stored on the Photo CD disc in a new contact sheet window.

Close (CTRL+F4) closes the active window.

Save (CTRL+S) allows you to save changes to an existing catalog file by replacing the previous version with 
the current version.

Save As allows you to save a new catalog or to save changes to an existing catalog by renaming the catalog and 
by    changing its location. You can save the catalog to the hard disk or to another storage medium. 

Save Selected As allows you to save a catalog of thumbnails selected from the contact sheet window. 

Thumbnail Layout you to change contact sheet window display preferences, including thumbnail size, tile 
width and height, thickness of the decorator frame, background and font color, and fonts used to display 
thumbnail labels. You can also assign up to four labels to display on the thumbnails.allows 

Preferences (CTRL+K)  allows you to assign catalog merge options that control how thumbnails and the data 
indexed about them are handled when you copy thumbnails between catalogs.

Exit (ALT+F4) exits the BROWSER software application. 



File Types

You can save a photo displayed in the photo window in any one of these file types:

BMP MICROSOFT WINDOWS software device-independent bitmap

GIF Graphics Interchange Format

PCX PC Paintbrush

PICT MACINTOSH Picture

TGA Targa File Format

TIFF Tagged Image File Format

WPG WordPerfect Graphics

See also: Save Object As



Get Info Sheet

You use Get Info Sheet from the Catalog menu (CTRL-I) to view file information, user information, keywords, and 
the caption for thumbnails selected from the contact sheet window.

Use the drop-down list box at the top to select the kind of information you wish to view, and use the VCR - like 
controls to move through the selected thumbnails. 

> Moves forward by one

< Moves back by one

>> Moves to the end of the selection

<< Moves to the beginning of the selection.

See also: Contact Sheet Window



Help Menu

The Help menu provides four commands:

Index (F1) provides an overview of Help topics. When you click Search in the Help window, BROWSER 
software displays an alphabetical listing of Help topics that provides information on specific software features, 
menus, commands, and procedures.

Using Help provides instructions on using WINDOWS software Help functions.

Ordering Help provides instructions on ordering high resolution originals of the images displayed on Photo CD 
Catalog disks. It is grayed out when other disks are viewed.

About BROWSER displays a welcome screen showing the BROWSER software version number and 
application copyright information.



Introduction

KODAK BROWSER Photo CD Image Manager is a graphical database application that allows you to display, 
search, and retrieve thousands of digitized images that are stored on KODAK Photo CD Master discs or Photo CD 
Catalog discs bearing the Photo CD symbol. KODAK Photo CD discs provide an ideal medium for storing high-
quality photographic images captured with 35mm film. 

Photo CD Master discs store images at five resolutions.

Photo CD Catalog discs store thousands of low-resolution images.

BROWSER software allows you to create an unlimited number of multimedia catalog files; to store up to    30,000 
files in each catalog, to search the database; to display, and copy thumbnails in the contact sheet window; to display, 
zoom, crop, and copy photos displayed in a photo window; and to create slide shows.



Inverse Selection

You use Inverse Selection from the Display/Select menu to deselect thumbnails already selected and select those 
thumbnails that were not previously selected.



Load Contact Sheet
You use Load Contact Sheet from the File menu to load images stored on the Catalog CD or Photo CD disc into a 
contact sheet window. Load Contact Sheet provides a convenient way to start a new catalog file or to browse 
through the images stored on a Photo CD or Catalog CD disc.



Mark
A thumbnail can be marked with a semipermanent check mark. This mark stays on the thumbnail when it is saved as 
part of a catalog. To mark a thumbnail, first select it then pick Mark Selected from the Display menu.
See Also:

Mark AllMark Selected



Mark All

You use Mark All from the Display/Mark menu to place a checkmark on all the thumbnails displayed in the contact 
sheet window.



Mark Selected

You use Mark Selected from the Display/Mark menu to place a checkmark on all the thumbnails you have selected.



New

You use New from the File menu (CTRL+N) to open an empty contact sheet window in the application window. 
You use the empty contact sheet window to create a new catalog by adding images that are stored on Photo  CD 
Master discs or Photo CD Catalog discs.



Objects Menu

The Objects menu commands allow you to save a photo or a photo of a thumbnail selected from the contact sheet 
window in another image file format, and to set PCD resolution and color.

Save Object As saves a photo displayed in a photo window or a thumbnail selected in the contact sheet window 
to the hard disk as a BMP, GIF, PCX, PICT, TGA, TIFF, or WPG file type.

Set PCD Resolution provides five different resolutions to change the display size of the photo in a photo 
window. By default, BROWSER software displays a photo in a resolution of 256 pixels by 384 pixels. 

Set PCD Color provides four color palettes, three gray palettes, monochrome, and an optimum setting in which 
to display a photo in a photo window. By default, BROWSER software uses Full Color if your system is 
configured with a 24-bit or 16-bit display card, and 256 Colors if your system is configured with an 8-bit display 
card.



Open

You use Open from the File menu (CTRL+O) to open an existing catalog. BROWSER software automatically 
displays a contact sheet window and loads the catalog using the default settings saved with the catalog.

Catalog Files on a hard disk contain three elements; .CAT which contains the data, .CAI containing the indexing 
information and .JPS containing the thumbnails. Note that these three elements of a Catalog File should never be 
separated. The .CAT file appears in the File Open dialog for the purpose of opening hard disk catalogs.

The List Files of Type drop-down list box also provides two other file types:

IRT is a database that exists on Catalog Photo CD discs and which can be used to directly open Catalog Photo 
CD images, but the preferred method is to use Load Contact Sheet from the File menu.

OVERVIEW.PCD is the file that contains the thumbnails of the images on the Photo CD or Photo CD Catalog 
disc. Opening it will load the contact sheet, but without loading any database information in the case of a 
Catalog Photo CD. In the case of a Photo CD Catalog disk, several small images may be found stored in each 
thumbnail or image.

OVERVIEW.CAT is the file that contains the thumbnails of the individual images on a Photo CD Catalog disc. 
Opening it will load the contact sheet, and also open the database.



Paste

You use Paste from the Edit menu (CTRL+V) to paste a thumbnail into the active contact sheet window that was 
copied or cut to the Clipboard. You also use Paste to transfer a photo from the Clipboard into another catalog or 
document.

You use the keyboard accelerator CTRL+V to paste caption text that you have copied or cut from the caption field. 



Photo Window

BROWSER software lets you view a photo in a photo window in one of the five supported PCD resolutions. To 
display a photo, double-click a thumbnail in the contact sheet window.. You can display multiple photo windows by 
holding down the SHIFT key and clicking each thumbnail that you want to display in a photo window. Double-click 
the last thumbnail in your selection. Multiple photo windows display in a cascade format.

You use Set PCD Resolution from the Objects menu to determine the size of the photo to be displayed in the photo 
window. You use Set PCD Color from the Objects menu to determine the image type. Once a photo is displayed in a 
photo window, you can copy it to the Clipboard, print it, or use Save Object As from the Objects menu to save the 
photo in one of the available file types  (BMP, GIF, PCX, PICT, TGA, TIFF, and WPG).

Choose Get Info Sheet from the Catalog menu to view file information, user information, keywords, and the caption 
for a photo displayed in a photo window. 

See also: Contact Sheet Window

Set PCD Color

Set PCD Resolution



Preferences 

You use Preferences from the File menu (CTRL+K) to assign catalog merge options. Catalog merge options control 
how thumbnails and the data indexed about them are handled when you copy thumbnails between catalogs.

Copy Only Matching Fields copies only matching fields when you copy thumbnails between catalogs. All 
other fields are ignored.

Create Missing Fields in Destination Catalog automatically creates and copies any missing field names from 
the source catalog into the destination catalog. By default, BROWSER software activates this check box.



Project Catalog

You can save your own Project Catalogs on your hard disk by opening a New Contact Sheet in the file menu, 
and copying thumbnails to it from one or more Photo CD Catalog or other Photo CD disks. This allows you to 
build up personalised catalogs containing your favorite photos from a range of Photo CD Catalogs, and to 
build separate catalogs for each of your fields of interest.

As an additional advantage, catalogs saved to your hard disk open more rapidly than those on Photo CD 
Catalog disks, and you can set your own Contact Sheet Preferences (File Menu).



Reordering Thumbnails

You can reorder thumbnails in the contact sheet window using the Sort By command from the Display menu or 
manually reposition the thumbnails by using the drag-and-drop method. Reordering thumbnails is helpful when you 
want to control the order in which thumbnails display during indexing or in a slide show, or the order in which they 
are saved in a catalog.

The Display/Sort By menu displays a dialog box listing fields that you can use to sort thumbnails in the catalog. To 
change the sort order, select the field name and click Sort. To reverse the sort action, choose Sort By from the 
Display menu and click Unsort.

To manually reposition thumbnails, select a thumbnail from the contact sheet window, hold down the mouse button, 
and drag the thumbnail to the new position. A rectangular marquee containing a cross-hair icon indicates the position 
of the thumbnail as you drag it across the catalog.

See also: Drag-and-Drop to Move Thumbnails
Sort By



Save

You use Save from the File menu (CTRL+S) to save changes to an existing catalog file. Save replaces the previous 
version with the current version. If you make several additions or changes to a catalog, it is a good practice to make 
saves at regular intervals.

When you choose Save, a progress indicator appears showing that the catalog is being saved to the current filename. 
You can continue working on the catalog after the save is completed.



Save As

You use Save As from the File menu to save a catalog to your hard disk or to other storage medium. The Save As 
dialog box allows you to select the drive and directory where you want the catalog saved and to name the catalog. 
You can also use the Save As command to make a duplicate copy of an existing catalog.

When you use Save As, the current catalog is renamed to the name under which you saved it. Subsequently, you can 
use Save to save modifications under the same name.

Save As will save the whole catalog, even if only a selection (for example, the results of a search) is currently 
displayed. To save a selection, see Save Selected As.



Save Object As

You use Save Object As from the Objects menu to save a photo of Photo CD images to your hard disk.Photos can be 
selected from the contact sheet window or a photo can first be viewed in a photo window. Optionally, the photo may 
be cropped prior to saving. BROWSER software saves the photo in the resolution and image type currently selected 
in Set PCD Resolution and Set PCD Color from the Objects menu. 

The Save Object As dialog box allows you to select a directory, to name the file, and to select a file type. Photos can 
be saved as BMP, GIF, PCX, PICT, TGA, TIFF, or WPG file types, regardless of their original format.

In some cases the format may not support the image type selected in Set PCD Color, in which case the nearest 
alternative will be used. For instance, BROWSER Software will save a 256 color .TGA file if the non-existant 16 
color version is requested.

Care should be used in selecting resolution and image type to ensure that quality is good enough for the desired use. 
If the image is subsequently to be loaded into any other software at a different scale, it should be saved in Full Color 
or 256 shades of gray modes, even though this uses more hard disk space. The reason for this is the fact that all other 
image types (256 Color, 16 Color etc.) use a "dithered" dot structure to create a wider range of colors, and this dot 
structure creates very rough looking scaled imagess. If you must use a different image type, be sure to use the same 
setting as your graphics board. For instance, use Full Color or 16 colors for a 16 color VGA graphics board. 

See also: Set PCD Color
Set PCD Resolution



Save Selected As

You use Save Selected As from the File menu to save a catalog of thumbnails selected from the contact sheet 
window. The Save Selected As dialog box allows you to select the drive and directory where you want the catalog 
saved and to name the catalog.

To save the results of a search as a Sub-Catalog, pick Select All from the Display menu, then Save Selected As. 
Remember that Save As saves the whole catalog, even though part of the catalog may not currently be displayable 
on the Contact Sheet.



Saving Catalogs

BROWSER software does not automatically save catalogs, so you can always revert to the previously saved catalog 
by not saving any changes you made to a catalog. It is a good practice, however, to save a catalog after changing 
catalog settings and moving thumbnails between catalogs.

Whenever you save a catalog, BROWSER software creates three files for each catalog. These files each use the 
filename assigned the catalog and BROWSER software assigns each file with a different file extension (CAI, JPS, 
and CAT). Each of these files must be in the directory in order to open a saved catalog.

In addition, BROWSER software makes a temporary update in the catalog database for each thumbnail as soon as 
you advance from the thumbnail or click OK during indexing. Clicking OK in the Index dialog box closes it, and all 
changes can be searched immediately. However, your catalog is not updated. To update the catalog, make sure you 
save the changes when you close the catalog.

To save a part of a Catalog, see Save Selected As.



Search

You use Search from the Display menu (CTRL+F) to tell BROWSER software how you want the results of the 
search shown, to set the scope of the search, and to construct search statements. You click the Action Button to start 
the search. The action the button takes depends on the selection made in the search results pop-up menu.

Search Entry Area

You use the entry area to complete search statements. BROWSER software always provides a text edit box so you 
can key in a subject to complete your search statement. Text and List fields also generate entry helper drop-down list 
boxes, so that values can be selected using the mouse.

Search Fields

You use the field list drop-down list box to control which fields are displayed in the list. BROWSER software 
provides three options:

File Fields contains information about the content file, such as file size or creation date.

Catalog Fields lists user-defined fields, including Keywords and Caption fields.

All Fields combines Catalog Fields and User Fields into one list of fields.

Search Options

By default, BROWSER software searches the entire catalog to locate thumbnails matching your search statement. 
You use the Options pop-up menu to narrow or enlarge the results of a search.

Search Entire Catalog conducts a search of the entire active catalog.

Search Displayed List conducts a search only of the thumbnails displayed as a result of the previous search. 
You use these thumbnails for a new search and include additional search qualifications. In this case, BROWSER 
software narrows the selection of displayed thumbnails to only those matching the new search statement.

Add to Displayed List keeps the thumbnails displayed in the contact sheet window and enlarges the selection 
by searching the entire catalog using a new search statement. BROWSER software adds thumbnails matching 
the new search statement to the displayed list. 

Search Query Links

You use the Query Link drop-down list box from the Search dialog box (CTRL+F) to change the conjunction 
between search elements and to join multiple search statements.

And links words or phrases of equal rank. When you use And, the search results contain only thumbnails that 
match all the criteria connected by And. You can also use the And option button located above the entry helper 
menu in the Search dialog box to link words or phrases in the search statement.

But Not selects thumbnails that meet a certain set of criteria while excluding those that meet another set of 
criteria. The search results exclude thumbnails that meet the criteria following the But Not.

Or broadens the search to retrieve thumbnails that meet either of the two surrounding search criteria. You can 
also use the Or option button located above the entry helper list to connect the two search statements.

Search Results



The results of a search can be displayed, counted, selected, or marked. By default, BROWSER software 
displays the results of your search in the contact sheet window. You use the search results drop-down list box to 
change how BROWSER software returns the results of the search.

Count counts all thumbnails that match the search statement and displays the number matching the search 
statement in the upper-right corner of the Search dialog box.

Display shows all thumbnails in the contact sheet window that match the search statement.

Mark places a checkmark on each of the thumbnails that matches the search statement. Any previously marked 
thumbnails also remain marked.

Select highlights each of the thumbnails that matches the search statement. Any previously selected thumbnails 
are deselected unless they match the search statement.

Search Statements

When constructing search statements, you apply the same basic rules as you do when writing sentences. You can 
construct a simple search statement or a sophisticated search statement. You use a selection from each of the three 
columns in the Search dialog box to construct the search statements.

Simple Search Statement contains a subject (Column 1 of the search dialog box), a verb (Column 2 of the 
search dialog box), and a subject descriptor (Column 3 of the search dialog box)connected by the Or and And 
option buttons.

An example of a simple search statement is: Location equals GENESEO, NY Or ROCHESTER, NY.

Sophisticated Search Statement provides the ability to search on more than one field and to include more than 
one search verb and subject descriptor as search qualifiers. A sophisticated statement is made up of two or more 
simple search statements linked by the conjunctions And, Or, and But Not.

An example of a sophisticated search statement is: Photographer equals FINK, ALAN But Not ORIENTATION 
equals VERTICAL.

BROWSER software allows you to enter additional search lines for sophisticated searches, to clear search 
statements, and to start the search action. You select Add Query to generate an additional search statement line. You 
use Clear Query to remove the highlighted search statement.

Search Verb List

You use the search verb list to select the verb phrase element of the search statement. The verb list changes 
depending on the field you select. By default, BROWSER software displays the most likely choice. 

Begins with returns thumbnails that begin with the subject (Text and List fields).

Between returns thumbnails that fall between the two dates entered (Date field).

Contains returns thumbnails that have the subject residing within the field (Text and List fields).

Does not contain returns all thumbnails except those that have the subject residing within the field (Text and 
List fields).

Does not equal returns all thumbnails except those that exactly match the subject (Text, List, and Number 
fields).

Ends with returns thumbnails that end with the subject (Text and List fields).



Equals returns thumbnails that match exactly the subject (all fields).

Is after returns thumbnails that come after the search date (Date fields).

Is before returns thumbnails that come before the search date (Date fields).

Is greater than returns thumbnails with a higher number than the number entered (Number fields).

Is greater than or equal to returns thumbnails with a number larger than or equal to the number entered 
(Number field).

Is lower than returns thumbnails with a lower number than entered (Number fields).

On or after returns thumbnails that fall on or after the date entered (Date field).

On or before returns thumbnails that fall on or before the date entered (Date field).



Select

A thumbnail is selected on the contact sheet by clicking on it with the mouse or by moving the cursor to it using the 
arrow keys and pressing the Space bar. The selected thumbnail has a red border around it. To select multiple 
thumbnails, hold down the shift key while making the selections.

See Also:Select All



Select All

You use Select All from the Display/Select menu to select all thumbnails displayed in the contact sheet window.



Select Marked

You use Select Marked from the Display/Select menu to select all previously marked thumbnails displayed in the 
contact sheet window.



Select Unmarked

You use Select Unmarked from the Display/Select menu to select all thumbnails displayed in the contact sheet 
window that have not been marked.



Set PCD Color

You use Set PCD Color from the Objects menu to select the image type you want to open in a photo window. You 
must select PCD Color before you double-click the thumbnail in the contact sheet window`or choose Save Object As 
from the Objects menu. 

BROWSER software provides four color palettes, three gray palettes, monochrome, and an optimum setting in 
which to display a photo in a photo window or save a photo to your hard disk. By default, BROWSER software uses 
Full Color if your system is configured with a 24-bit or 16-bit display card, and 256 Colors if your system is 
configured with an 8-bit display card.

Full Color displays images in full RGB color (24-bit color)..

256 Colors displays images using a color palette of 256 colors (8-bit color).

16 Colors displays images using a color palette of 16 colors (4-bit color).

4 Colors displays images using a color palette of 4 colors.

256 Shades of Gray displays images using a color palette of 256 evenly stepped shades of gray (8-bit gray 
scale).

16 Shades of Gray displays images using a color palette of 16 evenly stepped shades of gray (4-bit gray scale).

4 Shades of Gray displays images using a color palette of 4 shades of gray.

Monochrome displays images as black and white.

Optimum Colors uses a palette that best displays the selected image.



Set PCD Resolution

You use Set PCD Resolution from the Objects menu to determine the display resolution (size) of a photo you want 
to open in a photo window or save to your hard disk. You must select PCD Resolution before you double-click the 
thumbnail in the contact sheet window or choose Save Object As from the Objects menu. By default, BROWSER 
software displays a photo using a resolution of 256 pixels by 384 pixels. Other resolutions supported by BROWSER 
software include:

128 by 192 pixels

256 by 384 pixels

512 by 768 pixels

1024 by 1536 pixels

2048 by 3072 pixels



Set Slide Show

You use Set Slide Show from the Display menu (CTRL+L) to select the timing of the slide show, to choose whether 
you want a sound file to accompany a slide show, and to determine how the thumbnails will appear in the slide 
show. The Set Slide Show dialog box contains several option buttons and check boxes that you use to select slide 
show preferences.

Fit in Window displays the thumbnails to fit the window size of your monitor. The default size is 256 pixels by 
384 pixels. You use Set PCD Resolution from the Objects menu to change the display size.

Loop Mode continuously displays thumbnails one after the other during the slide show. By default, BROWSER 
software activates this checkbox.

Random Overlay displays the thumbnails on the screen in random positions. Thumbnails remain on the screen 
as each new thumbnail displays.

Seconds allows you to enter the number of seconds you want to elapse before the next thumbnail displays on 
the screen. The default interval is 10 seconds. This feature applies only if you select Timer from the Timing 
section of the dialog box.

Set stores the slide show preferences so that you can use other features before starting the slide show.

Start Show immediately begins the slide show using the thumbnails you selected in the active contact sheet 
window.

Timer controls the length of time thumbnails display on the screen before BROWSER software automatically 
displays the next thumbnail. By default, BROWSER software sets the timer at 10 seconds.

Wait for a Click displays the thumbnails on the screen until you click the mouse button to advance the next 
thumbnail. By default, BROWSER software activates this option button.



Splash Screens
When BROWSER Software is opened, a splash screen showing the BROWSER Logo and Version number is 
displayed; in addition, when a Photo CD Catalog Disk is opened, a second splash screen representative of the photos 
on the disk is displayed. This should serve as a reminder that the photos on the disk are Copyrighted and should not 
be used without the owner's permission.



Thumbnail Layout

You use Thumbnail Layout from the File menu to change the width and height of the tile area, choose the size of the 
thumbnail, select the thickness of the decorator frame, assign up to four labels to appear below each thumbnail, 
change background and text color, and choose a font and font size. When you first open a Catalog, values used are 
those which were stored with the catalog.

Background Color allows you to change the default background for the contact sheet window or for an existing 
catalog. You can select either one of the WINDOWS software Basic Colors or Custom Colors, or you can define 
a custom color.

Decorator Type allows you to select whether your thumbnail displays in the contact sheet window with or 
without a slide mount surrounding the thumbnail. By default, BROWSER software selects Slide Mount.

Decorator Size allows you to select the size of the slide mount that surrounds the thumbnail. By default, 
BROWSER software uses a slide mount size of 140 pixels for a thumbnail size of 112 x 75 pixels.

Labels allows you to assign up to four labels to display below each thumbnail. List box selections include 
information from the File Fields and Catalog Fields. By default, BROWSER software does not assign labels.

OK applies the changes only for the active contact sheet window.

Save Defaults saves the current settings as the default.

Text Font and Color allows you to change text color, to select the font used to show labels on the decorator 
slide, and to set font size and color. BROWSER software uses the WINDOWS software Font dialog box to 
customize text and font selections.

Thumbnail Size provides a drop-down list box of resolutions from which you select the size in which 
thumbnails display in the contact sheet window. The default size is 112 x 75 pixels. Size selection also controls 
the size that BROWSER software uses to build any new thumbnails for content files added to the catalog.

Tile Height changes the height of the space allocated to each thumbnail in the contact sheet window. By default, 
BROWSER software uses 170 pixels.

Tile Width changes the width of the space allocated to each thumbnail in the contact sheet window. By default, 
BROWSER software uses 170 pixels.

Use Defaults uses the most recently defined default settings and applies them to the current contact sheet 
window.



Show Clipboard

You use Show Clipboard from the Edit menu to see the current contents of the Clipboard. 



Sort By

You use Sort By from the Display menu to sort thumbnails in the contact sheet window using BROWSER software 
defined fields. Not all fields provide good candidates for sorting. You should determine if the values in the field will 
generate your desired results before selecting the field.

To change the sort order, select the field name in the Sort Using Field list box. Click Sort. To reverse the sort action, 
choose Sort By from the Display menu and click Unsort.



Start Slide Show

BROWSER software allows you to present a slide show of content files contained in a contact sheet window. The 
contact sheet window containing the thumbnails you want to include in your slide show must be the active window 
in order to present a slide show. You can select all the thumbnails in the contact sheet window for the slide show, or 
you can select specific thumbnails by holding down the shift key and clicking each thumbnail you want to include in 
the slide show. 

If you have saved a catalog containing Photo CD images, you must have the original Photo  CD disc in the CD-
ROM drive.

You use Start Slide Show from the Display menu (CTRL+L) to begin the slide show.You use the Slide Control 
directional icons to start and stop the slide show and to advance or reverse the direction of the thumbnails.You can 
stop the slide show at any time by touching the space bar if necessary to retrieve the control bar, and selecting Quit.

The Control Bar has the following control buttons:

Quit stops the slide show and returns to the application window.

Hide removes the Slide Control from the slide show window.

Play (Timer mode only). Starts automatic playing of the slides

Reset displays the first thumbnail in the slide show.

Prev Shows previous slide.(You can use the right hand mouse button if the control bar is hidden)

Next Shows next slide.(Use the right hand mouse button if the control bar is hidden).

See also: Set Slide Show



Undo

You use Undo from the Edit menu (CTRL+Z) to cancel the effect of the last action. The Undo command is black if 
available. If the most recent action cannot be reversed, the Undo command is dimmed.



Unmark All

You use Unmark All from the Display/Mark menu to remove the checkmarks from all thumbnails displayed in the 
active contact sheet window.



Unmark Selected

You use Unmark Selected from the Display/Mark menu to remove the checkmarks from only those marked 
thumbnails you selected in the active contact sheet window before marking. 



Windows Menu

The Windows menu contains the commands to arrange windows in the application window and lists all open 
windows. The Windows menu also contains the Zoom In and Zoom Out commands when you have a photo 
displayed in a photo window.



Zoom In

You use Zoom In from the Windows menu to enlarge the photo or a selected portion of the photo by a factor of two 
(to a maximum of 16:1). You can also use the plus key (+) from the numeric keypad or use the keyboard command 
ALT+W+I and press the ENTER key to zoom in on a photo.



Zoom Out

You use Zoom Out from the Windows menu to reduce the photo or a selected portion of the photo by a factor of two 
(to a minimum of 1:16). You can also use the minus key from the numeric keypad or the keyboard command 
ALT+W+O to zoom out on a photo.





An Accelerator Key is a keyboard action which executes a Windows command. Most acceleator keys are underlined 
in menu items.



A Catalog is a collection of photos and associated indexing information which can be searched and displayed by 
Kodak Browser and Shoebox software. A Photo CD Catalog is a catalog published on a Kodak Photo CD disc.



A thumbnail is a postage stamp sized version of a photo, many of which can be displayed on a Shoebox Contact 
Sheet for visual browsing and comparison.



A Microsoft Windows standard for displaying multiple related Child documents (such as Contact Sheet windows) 
within one parent window. All menus are in the parent window.



At any moment, only one control in one window is active - this control is often highlighted, and the window is 
always on top of the heap. The window and control have the FOCUS



A project is a "view" of the catalog which can be saved or retrieved. It is a selected or restricted version of an 
original catalog, and the original catalog disk must be loaded for the view to be seen.



The decorative surround around a thumbnail - may be changed using "Thumbnail Settings"



Used in conjunction with cut and paste commands to pass images between Windows applications



To cut the useful part from a photo and reject the rest.



A sister Kodak software product to Browser, Shoebox permits the creation of User catalogs, including the ability for 
the user to define his own fields.



Photo CD resolution is one of the sizes, from 128 x 192 pixels to 2048 x 3072 pixels, at which photos are stored on 
Photo CD disks.



A Kodak standard for economically storing high quality images on Compact Disks. Photo CD's contain only 
rudimentary indexing information. See also Catalog.






