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PDACookbook™ Quick Start Documentation 
 
 
Introduction: 
 
PDACookbook™ allows easy recipe management, meal planning, shopping list management, and 
more from any Palm OS® handheld, Pocket PC or Windows Mobile handheld, and Windows PC. The 
Plus version includes PC desktop companion software with additional features. The Lite version runs 
only on Palm OS® handheld computers, and is intended primarily for Mac users. This document 
provides information on the handheld software, as the PC software has its own complete help file 
system. You may want to print this document for easier reference. The handheld screenshots are 
taken from a Palm OS® handheld, but they look almost identical on a Pocket PC or Windows Mobile 
handheld.. 
 

Installation: 
 
To install the Plus version on a PC, download the setup file.  If this file is in ZIP format, you will need 
to first unzip the file with an unzip utility. Then, double click the .exe setup file to start the PC installer. 
The installer will install both PC and handheld software components. Palm OS® users will need to 
hotsync once the installer is finished to install the handheld files to your handheld. 
 
To install the Lite version, simply download the ZIP file to your PC.  Then, unzip the file with an unzip 
utility such as Winzip (www.winzip.com).  Once unzipped, install all *.prc and *.pdb files to your 
handheld using the Install Tool that was installed with your handheld desktop software. 
 

Registration: 
 
The software is initially installed as a trial version. After purchasing, a 5-digit registration code is 
provided. This 5-digit code is entered in the blank area on the startup screen on the handheld or on 
the PC software from the Help menu. Once the registration code is entered the handheld, tap 
Register. For Palm OS®, on the next hotsync, the registration code will be transferred to the PC. The 
Plus version, if installed, will detect this code and unlock the full PC version. The registration code 
unlocks the full version features. No additional installation is required. 
 

Getting Started: 
 
The following screens and descriptions explain many of the features in PDACookbook™. The 
software was designed to be easy and intuitive, so it will be easy to get started. This documentation 
will help explain some of the advanced features. 
 
To start the software on the handheld, tap the PDACookbook™ icon. On Palm OS® handhelds, this 
icon may be in the Unfiled category. From the Home (icon) screen on your handheld, tap the drop 
down list in the upper right corner, then select Unfiled to list an uncategorized icons. A category can 
be assigned to the icon to make it easier to find. Consult your handheld manual for how to categorize 
icons. On Pocket PC handhelds, tap the Start menu icon in the upper left, then select Programs from 
the list displayed.  The PDACookbook icon will be available from that screen of icons. 



Page 2 - Copyright 2001-2005 WakefieldSoft, LLC. 

Recipe List Screen: 
 

 

Upon startup, the list of recipes is displayed.  From this screen, the user 
may scroll through the recipe list with the onscreen scrollbar or the 
hardware scroll buttons.  Tap a letter in the Quick Nav Bar to go to the 
first recipe starting with that letter. Also, the Quick Find Area can be used 
to jump to a certain recipe by entering the first few letters in the recipe 
title. Simply tap any recipe in the list to view the recipe’s details. 
 
The buttons at the bottom of this screen will create a new blank recipe; 
view the Menu Planner screen, view the Shopping List screen, and view 
the Filter Recipes screen to search the list of recipes. 
 

 

Recipe Viewer Screens: 
 
From any of the four recipe viewer screens (Ingredients, Instructions, Nutrition, and Miscellaneous), a 
series of buttons are available at the bottom of each screen.  The Done button will save the recipe 
and return to the list of recipes screen. The Menu button will prompt to add the current recipe to the 
Menu Planner, and the user may select a date for the recipe after tapping the Menu button. The Del 
button will delete the recipe being viewed. The Copy button will make a copy of the recipe being 
viewed, and changes can be made to this recipe copy before saving. 
 
Ingredients Tab: 
 

 

 
From the Ingredients (Ingr) tab, the ingredients for the recipe can be 
viewed. In addition, there are several graphical buttons above the list of 
ingredients that are helpful. The buttons, from left to right, will: 
 
- Add the selected ingredient to the Shopping List. 
- Add all ingredients for this recipe to the Shopping List. 
- Open the Edit Ingredients screen to allow ingredients to be added, 

reordered, deleted, or modified. 
- Toggle the ingredient view from a column view to a wrapped text view. 

Although some ingredients may be truncated in the column view, 
all ingredient text can be seen in the wrapped text view. This can 
also be set in preferences. 

 
Instructions Tab: The Instructions (Instr) tab lists the instructions. Instructions can be added or edited. 

This screen is self-explanatory. 
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Nutrition Tab: 
 

 

 
From the Nutrition (Ntrn) tab, the nutritional information for the recipe can 
be viewed. In addition, there are several graphical buttons above the list 
of nutritional items that are helpful. Nutritional information is not 
calculated by the software, but can be entered by the user. The buttons, 
from left to right, will: 
 
- Open the Edit Nutrition screen to allow nutritional information to be 

added, reordered, deleted, or modified. 
- Toggle the nutrition view from a column view to a wrapped text view. 

Although some nutritional items may be truncated in the column 
view, all nutrition text can be seen in the wrapped text view. 

 
Miscellaneous Tab: 
 

 

 
From the Miscellaneous (Misc) tab, information on the number of 
servings can be entered, rating, source, and categories (up to 6) can be 
assigned to each recipe. 
 
Also, by changing the number of servings, then tapping the Scale button, 
the ingredient quantities will be changed to reflect the new number of 
servings. Scaling can be done as fractions or decimal – see Preferences. 
 
The Edit button above the list of categories will open the Edit Categories 
screen to allow categories for that recipe to be changed. 
 

 

Editing Ingredients: 
 

 

From the Recipe Viewer, Ingredients tab, tapping the Edit Ingredients 
icon will display the Edit Ingredients screen. This screen can be used to 
Add new ingredients or modify and Update ingredients. Other icons will 
add one or all ingredients to the shopping list, move ingredients up or 
down, and delete the selected ingredient. 
 
To enter a new ingredient, use the drop down arrows to select items from 
the Qty, Units, or Ingredient master lists. Text may also be entered 
directly. Then tap Add to add the ingredient to the list. 
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Editing Nutritional Items: 
 

 

From the Recipe Viewer, Nutrition tab, tapping the Edit Nutrition icon will 
display the Edit Nutrition screen. This screen can be used to Add new 
nutritional items or modify and Update nutritional items. Other icons will 
move an item in the list up or down, and delete the selected item. 
 
To enter a new nutritional item, enter the quantity, use the drop down 
arrows to select items from the Units or Nutrition items master lists. Text 
may also be entered directly. Then tap Add to add the item to the list. 

 

Menu Planner: 
 

 

To view the Menu Planner, tap the Menu button on the main recipe list 
screen. A screen listing all recipes that have been added to the menu will 
be displayed. 
 
The buttons at the bottom of this screen will allow the user to edit the 
menu, view the selected recipe, delete the selected item from the menu, 
or clear all items from the Menu Planner. 
 
To add a recipe to the Menu Planner, tap the Menu button while viewing 
any recipe’s details.  Menu items can also be edited to specify a Meal 
and change the date. 
 
The shopping bag icon at the top of the screen will add all ingredients for 
the menu recipes to the Shopping List. 

 
Shopping List: 
 

 

To view the Shopping List, tap the Shop button on the main recipe list 
screen. A screen listing all items that have been added to the Shopping 
List will be displayed. 
 
The buttons at the bottom of this screen will allow the user to add or edit 
items on the Shopping List, view the selected item in a message box to 
see all text of the item, delete the selected item (useful after buying the 
item at the store), or clear all items from the Shopping List. 
 
To add items to the Shopping List from a recipe, tap the appropriate 
icons while viewing any recipe’s ingredient details (Ingr tab). Items can 
also be added from the Menu Planner for all menu recipes. 
 
To export the shopping list for import into HandyShopper2 or 
SplashShopper, choose the menu, then File, then Export Shopping List 
to Memo. 
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Filtering Recipes (Search): 
 

 

To filter (search) the list of recipes, tap the Filter button on the main 
recipe list screen. The Filter Recipes screen at the left will be shown. 
 
Enter any text that filtered recipes should match. The type of search 
(AND or OR) can also be specified. 
 
Note: The filter function must search every recipe to determine if it 
matches the criteria. On some handhelds, this could take tens of 
seconds or more.  

 

Menu Options: 
 

A menu system is available to perform additional functions on the handheld. To view the menu 
system, tap the Menu silkscreen icon (just below the Home silkscreen icon). Also, on some 
handhelds, the title bar for the application can be tapped while the application is running to display the 
menu system. 
 
File Menu:  
 
The File menu offers the following options: 
Export Recipe to Memo/Note – while viewing any recipe, select this 

option to export the recipe as text to a new memo (Palm OS®) or note 
(Pocket PC). 

Beam Recipe – (Palm OS only) - while viewing any recipe, select this 
option to beam the current recipe to another PDACookbook™ user. 
When the receiving user starts PDACookbook™ on their handheld 
again, the new recipe will be imported with no additional work. 

Import MealMaster Memos – (Palm OS only) – this option will scan 
memos on the handheld and import those containing meal master 
recipes. This is useful to import recipes on the Lite version. 

Export Menu to Memo/Note – selecting this option will export the current 
Menu Planner contents to a new memo (Palm OS®) or note (Pocket 
PC). 

Beam Menu – (Palm OS only) - selecting this option will beam the Menu 
Planner to another PDACookbook™ user. If accepted, this will replace 
the receiver’s current Menu Planner. 

Export Shopping List to Memo/Note – selecting this option will export 
the current Shopping List contents to a new memo (Palm OS®) or 
note (Pocket PC). The memo can be imported into HandyShopper2 or 
SplashShopper – see documentation with those programs. 

Beam Shopping List – (Palm OS only) - selecting this option will beam 
the Shopping List to another PDACookbook™ user. If accepted, this 
will replace the receiver’s current Shopping List. 

Export Ingr List to Memo/Note – selecting this option will export the 
master ingredient list to a new memo (Palm OS®) or note (Pocket 
PC). The memo can be imported into HandyShopper2 or 
SplashShopper – see documentation with those programs. 

Preferences – selecting this option will display the preferences screen to 
change some of the available options. 
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Edit Menu:  
 
The Edit menu offers the following options: 
Cut/Copy/Paste – standard functions using graffiti 
Edit Quantities List – selecting this option will display the screen to allow 

the user to edit the master list of quantities. 
Edit Units List – selecting this option will display the screen to allow the 

user to edit the master list of units. 
Edit Ingredients List – selecting this option will display the screen to 

allow the user to edit the master list of ingredients. 
Edit Nutritional List – selecting this option will display the screen to allow 

the user to edit the master list of nutritional items. 
Edit Categories List – selecting this option will display the screen to allow 

the user to edit the master list of categories. 
Edit Sources List – selecting this option will display the screen to allow 

the user to edit the master list of sources. 
Edit Ratings List – selecting this option will display the screen to allow 

the user to edit the master list of ratings. 
Edit Aisles List – selecting this option will display the screen to allow the 

user to edit the master list of aisles. 
Edit Meals List – selecting this option will display the screen to allow the 

user to edit the master list of meals. 
 

 
 

 

 

View Menu:  
 
The View menu offers the following option: 
Equivalents – selecting this option will display a list of commonly used 

equivalents. This list can be edited. 
On Screen Keyboard – (Palm OS only) - selecting this option will display 

the on screen keyboard on supported devices. 

 
 

 

 

Help Menu:  
 
The Help menu offers the following options: 
Help – selecting this option will display the help file available on the 

handheld. 
About – selecting this option will display the About screen, including the 

version number. 
Register – (Pocket PC only) - selecting this option will display the 

Registration screen for entering the registration code. 
Close – (Pocket PC only) - selecting this option will shutdown the 

application on the Pocket PC, rather than hide it. 
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PDACookbook Desktop: 
 

The Plus version includes PC desktop software to manage information from the PC. The PC software 
includes all of the features on the handheld software, plus other features specific to the desktop 
software. Features available only on the desktop software include printing selected recipes, printing all 
recipes, printing the menu planner, printing the shopping list, importing recipes from MealMaster or 
MasterCook, exporting recipes in those formats, attaching pictures to a recipe, and smart ingredient 
pasting, for easy ingredient entry from any text recipe (internet, text file, etc.). Consult the help file on 
the PC desktop software for further information on the desktop features. 
 

 
 

 

Conclusion: 
 
If you are just evaluating or have already purchased PDACookbook™ – Thanks! 
 
If you have questions about the software, or cannot find an answer to a problem at our site, please 
email our support staff. We will work hard to resolve your issue and answer your questions. 
 
 

 
 


