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Introduction to CorelMOVE!

This document provides a quick introduction to CorelMOVE! It is not intended as 
a replacement for the documentation. It will, however, give beginners an 
overview on the use of the application. Consult the User's Manual for further 
details on the use of CorelMOVE!

A CorelMOVE! animation is composed of the following components:

PROPS: A prop is an object that remains stationary through a portion or all of the 
animation. Props are composed of single cels (one bitmapped image). Using 
transitions effects, the creator has the ability to modify the way a Prop appears 
and disappears during the animation.

ACTORS:  An Actor can be composed of a single cel (one bitmapped image) or  
multiple cels (several bitmapped images).  When the cels of the multi-cel Actor 
are viewed in quick succession, the changes in each bitmapped image creates 
the illusion of movement.

PATH:  To create movement of an Actor across the screen, a Path is applied. 
Single cel Actors will follow the Path, but will not change in appearance as they 
move. Multi cel Actors will follow the Path created, changing cels at each node 
along the Path. For example, if the Path you create has 5 nodes, and the Actor 
has five cels, cel one of the Actor will fall on node one, cel two will fall on node 
two. The closer the nodes are to each other on a Path, the slower the actor will 
move across the screen.  The further they are spaced, the faster the actor will 
move.
SOUNDS:  Just as a movie has a soundtrack and sound effects, so can a 
CorelMOVE! animation. Using CorelMOVE!'s own Sound Recorder, sounds can 
be created in .WAV format and used throughout the animation.

TIMELINES:  Timelines allow the creator of the animation to view and modify the 
entrance and exit of components during the animation.

CUES:  Adding a cue to an animation allows the viewer of the animation to cause 
an action to be performed, according to certain conditions, as specified by the 
creator of the animation.



Getting Started

Double click on the CorelMOVE! icon to launch the application. Under the File 
menu, select New.  The default file name is UNTITLED.CMV. Assign a name for 
your animation choose and the directory where you would like it to be placed. 
The working screen will appear.
Under Display, select Animation Info. Use this dialogue box to assign a size for 
your working screen in pixels, the number of frames in the animation, and speed 
of animation.

Props can be created using CorelMOVE!'s own Paint Toolbox, or those from 
another application.  

Click on the Prop tool on the toolbar. A dialogue box will cue you to select the 
creator application, be it CorelMOVE! or another application. Select 
CorelMOVE!, and  assign a name to the Prop. The name you create will be 
used to identify this Prop throughout your animation. The Paint Toolbox will 
then be displayed. 

Create a Prop, choosing different tools, line thicknesses and colours. Then,  
click on Apply Changes under the File menu of the Paint Toolbox and select 
Exit. 

Your prop will be placed  on the screen, and may be moved to the desired 
spot on the screen. Note that by default the Prop will be placed on the current 
frame, and will stay on screen for the remainder of the animation.

Props are static objects, but certain transition effects will produce movements.

Double click on the Prop on your working screen. This will bring up the Prop 
Information dialogue box. Transition effects are added through this dialogue 
box. 

Click on Edit and assign an entrance and exit effect. Try the different transition 
effects. The Preview button will give you an idea of what your transitions will 
look like. The Prop Information dialogue box will also allow you to change the 
frame for the entrance and exit of the prop. 

Change the entrance and exit frames by typing a new number in the 
appropriate boxes.  Play the animation to view the entrance and exit of your 
Prop. The Timeline Rollup will display where different objects will appear and 
disappear in your animation. 

Activate the Timelines Rollup from the icon at the bottom of your screen. Note 
that your Props enter and exit on specific frames during your animation. Try 
modifying the entrance and exit of object in your animation by placing your 
cursor at the end of the displayed time bar and dragging along the time line of 



your animation. You can also access Prop Information by double clicking on 
the object in the Timelines Rollup to modify it entrance and exit frame. 

You can remove objects from your animation by hitting delete, or choose not 
to display them by clicking on the icon buttons at the top of the Rollup.

Props can also be imported in other bitmap formats.

Under the File menu, select Import.  Select Prop, and set the path to import 
APPLE.PCX from the \COREL4\PHOTOPNT\SAMPLES directory.  Imported 
bitmaps will be large. The image can be scaled by editing it in the Paint 
Toolbox. Note that the Apple will be placed over top of other props in your 
animation. You can change its order using the Arrange menu.

Actors can be created with either single cels (one bitmap image) or multiple cels 
(several bitmap images).

Click on the Actor tool on the toolbar. A dialogue will appear prompting you for 
the creating application. Select CorelMOVE! and assign a name for your 
Actor. The Paint Toolbox will appear.  

Create an Actor in the Paint window. Note that the cel counter indicates cel 1 
of 1. This indicates it is a single cel Actor. Under the File menu select Apply 
Changes, then Exit from the Paint Toolbox. Move the Actor to a position off 
the screen by clicking on the object and dragging.

The only movement allowed for a single cel Actor is movement along a Path. A 
Path is created by adding nodes across your screen along which your Actor will 
move. The number of nodes along the Path will determine the speed of the 
movement of the Actor.  Fewer nodes means faster movement.

With the Actor selected, click on the Path tool. This will activate the Path Edit 
dialogue box. Click at points along the screen to create a Path.  Play your 
animation.

Note how the Actor will follow along the Path, then pause on the last point on the 
Path for the remaining frames of your animation. Points along the Path can be 
modified by selecting the actor, and then the path tool. 

If the Actor is off the screen, use the frame selector to move until the Actor is 
displayed on screen. Click on the Actor with the Pointer tool, then click on the 
Path tool to highlight the Path nodes created. 

Move the points around the Path by clicking and dragging on the points, and 
add new points by clicking along the Path.  (To prevent adding points to the 
end of your Path, select the point to the left of where you would like the add 
the new point, then click on the Path to add the point) 



The distances between the points can be averaged through the Path Point 
Distribution button in the Path Edit menu. Bumps along the Path can be 
smoothed by clicking on the  Path Point Smoothing icon on the Path Edit 
menu. 

Actors can edited at any time by double clicking on them on your working 
screen. If you have indicated a entrance and exit cel, the Actor will only be 
available for double clicking by moving to that cel range.

A single cel Actor simply moves along the path; multi celled Actors will play 
through their cels as they move along the same Path.

Click on the Library Roll-Up at the bottom of the screen. Click on the arrow 
pointing to the right to bring up the Edit menu. Open the SAMPLE.LIB file 
from the \COREL4\MOVE\ directory. Scroll through the list of samples. Look 
for a sample Actor called Octopus Running. 

Click on the Play button in the Rollup to view the Actor. Click on Place to 
apply the Actor to your working screen. Double click on the Octopus and 
select Edit Actor to load the Octopus in the Paint Toolbox. Note the cel 
counter at the lower left hand corner. This counter will indicate the number of 
cels in the Actor.  

Click on the arrows to move through the cels. Note how each individual cel, 
when viewed in quick succession creates the illusion of movement for the 
Octopus. Click on File, then Exit to return to your working screen.

The Actor will play through its cels repeatedly in a stationary position, until a Path 
is applied. After a Path is applied the octopus will play through its cels along the 
Path, one cel per node on the Path. If the Path is longer than the number of cels 
of the Actor, the Actor will play through its cel continually to the end of the Path.

Click on the Octopus to select it, then drag it to a position off the left hand 
side of the page. Create a Path for the Octopus by clicking at points across 
the screen, so the Octopus will run across the screen from left to  right.  Play 
the animation.

Movement of the Actor along the Path will be jerky if distances between the 
nodes of the Path are uneven. Clicking on the Path Point Distribution icon in 
the Path Edit window will even the distances between the nodes. 

To slow the movement of the Octopus along the screen, click on the +/- tool to 
add further nodes to the Path. Access the Timelines Rollup and take a look at 
how the animation is progressing. Note how Actor and Props are described 
with different symbols in the Rollup.



Other applications, such as CorelDRAW! can be used to create Actors and 
Props.

Create a new Actor by clicking on the Actor tool. Select CorelDRAW! as the 
creator application and click OK. Note the Frame Select Rollup on the 
CorelDRAW! screen. This Rollup allows you to add multiple cels to your 
Actors. 

Click on Frame 1 in the Roll-Up, draw an object on that frame. Click on the 
arrow pointing to the right, and Insert additional cels. Click on the additional 
frames one by one, and create objects on those frames. 

Under the File menu, select Exit and Return to CorelMOVE!, selecting Yes to 
Update the Embedded Object. The objects you created in CorelDRAW! are 
now part of your CorelMOVE! animation. 

To edit your Actor, double click on the Actor and select Edit. This will relaunch 
CorelDRAW! and allow you to make changes to the Actor. Selecting File; Exit 
and Return will return you to the CorelMOVE! working screen.

If your system has sound capabilities through a sound board such as a Sound 
Blaster, you can add sound files in a.WAV format to your CorelMOVE! 
animations. 

Under the File menu, select Import and Sound. Locate an existing .WAV file 
(there are usually some samples in your Windows directory) and click OK. 
The Sound will be placed on the current cel. 

Access the Timelines Rollup, and locate the Sound file you just added.  Again, 
the object is placed on your current frame, and plays from that point in your 
animation.  

If you have a microphone, you can click on the Sound tool, and use the 
CorelMOVE!  Sound Recorder to create your own sounds. Sound files are 
added to the current cel, and will play for the duration of the Sound file. If the 
number of frames remaining in the animation is smaller than the Sound file, 
the sound will stop at the end of the animation. 

It is possible to create an interactive animation presentation by adding Cues to 
the animation. Adding a cue creates a condition that if activated will execute a 
certain action.

Move to Frame One of the animation. Create a Prop called Button. Create a 
Cue that will end the animation when the Button Prop is clicked with the 
mouse. Click on the Cue tool to activate the dialogue box. Assign a name to 



the Cue. Click on the Always button under Condition. In the drop down menu 
select the If Then Else condition. Click on the Time Delay button and select 
Mouse Click On. Click on the Anything button and select Prop Named. Click 
on the list of props and select the prop named Button. Under Action, click on 
Continue and select End Animation.  Examine the Timelines Rollup and see 
how things have come together. Play the animation.  During the playback, 
click on the Button prop and the animation should end.

Play the animation one final time, then under the File menu, select Save.

The above instructions will give you an idea of the functionality of the 
CorelMOVE! application. With a little practice you will be able to create 
interesting and amusing animations for playback or use during  presentations.

The CorelMOVE! documentation will provide full instructions on the use of the 
different tools and functions. Don't forget that On-Line Help is always 
available in CorelMOVE! by clicking SHIFT+F1.


