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The online help for WebRecord is divided into the following sections:

Overview: This topic provides a brief description of the product and its primary features 
and benefits.

Getting Started: This topic describes how to start using WebRecord Interactive Printing for the 
first time.

What you need to know: These topics describe (as briefly as possible) everything you need to know 
about WebRecord Interactive Printing to make optimal use of the product.

Using WebRecord: These topics provide a more detailed description of how to use WebRecord 
Interactive Printing on a daily basis, and how to change the default settings to 
suit your needs.

Reference: These topics describe the various components of the WebRecord window and 
the WebRecord commands. Supported protocols and MIME types are listed, 
and an explanation of how indexing and referencing work is provided.

Trademarks

All brand names and product names are trademarks, registered trademarks or service marks of their 
respective companies.



Overview

WebRecord enables fast, formatted printing of World-Wide-Web pages. It can operate in the background 
while you surf from page to page using your Web browser, or fetch and print Web pages without your 
even visiting them.

Features and Benefits

The primary features of WebRecord Interactive Printing are:

Intelligent page formatting: Reduces the number of (paper) pages to be printed by 
using a neat and economical layout with a density suited to 
printing rather than online viewing.

Time-saving: Avoids the slow visit-and-print, visit-and-print cycle you 
experience when you want to print from your browser. You 
can select Web pages for printing without even visiting 
them by choosing the appropriate command from the Fetch 
menu.

Quality printing: Produces quality color printouts using high quality graphics.

Indexing: Automatically produces a table of contents that lists each 
Web page to be printed, and the WebRecord page on 
which it appears.

Automatic cross-referencing: Inserts cross-reference page numbers into the text to make 
internal hyperlinks visible on printed pages, and provides a 
list of external links (that is, those not included in the 
printed pages) under the heading: References.

Automatic tracking: Automatically tracks sites you visit using Netscape 
Navigator 2.0 or higher, or Microsoft Internet Explorer 3.0 
or higher.

Getting Started

1. Start Canon WebRecord from the Windows 95 Start menu.

The WebRecord window is displayed, and WebRecord attempts to fetch three default Web pages via 
your Internet connection. If you experience a problem at this stage, but your normal Internet browser is 
operating correctly, the most likely cause is your proxy settings (See: Specifying proxy settings for 
details).

Each of the three default pages displayed in the print preview area is already selected for printing (as 
indicated by the tick in the check box to the left of each page in the print list area).

2. Select Print from the File menu if you want to print these pages on your color printer.

More information:

WebRecord commands

Print list area

Print preview area

Status bar



What you need to know

In normal use, WebRecord runs alongside your Internet browser, which is likely to be the main focus of 
your attention. WebRecord is independent of your browser, but if you are using Netscape Navigator 2.0 or 
higher, or Microsoft Internet Explorer 3.0 or higher, WebRecord tracks locations you visit and 
automatically adds them to its print list.

The WebRecord print list is a list of Web locations you can chose to print. At your leisure you can:
select (tick) locations for inclusion in your printout, or deselect (untick) them;
rearrange the print list order by dragging and dropping listed items;
change the appearance of your printout by using various WebRecord options (see below).

At any time, you can print your current selection in either a full-feature or a simplified format.

Most of WebRecord’s operation is automatic. You will be able to use many of its features without any 
instruction, but a brief examination of the information provided in this section will ensure that you are 
aware of all of WebRecord’s features. Links are provided to other help topics, in case you require 
additional details.

The basics

For everyday operation of WebRecord you might want to know how to:
get URLs into the WebRecord print list, or
change the appearance of your printout.

To customize your use of the WebRecord interface, see:
WebRecord interface and performance choices.

For details of network connection and configuration options, see:
Specifying proxy settings.

What to read next:

How to get URLs into the WebRecord print list



How to get URLs listed in the WebRecord print list

The complete list of ways to add Web locations to the WebRecord print list is:
Visit the location in Netscape 2.0 (or higher) or Microsoft Internet Explorer 3.0 (or higher) while 

WebRecord is running. WebRecord automatically adds the location to its print list (except for raw images 
in Netscape, for which you must use one of the following methods).

Drag and drop a hyperlink directly from the main window of Netscape Navigator or Microsoft 
Internet Explorer into the WebRecord print list. This achieves the same effect as clicking the link, except 
that your browser display remains the same.

Enter a URL directly (for example, http://www.canon.com/) by choosing Location… from the 
Fetch menu.

Copy and paste a URL from another application or text field. Multiple lines of text can be pasted 
into the WebRecord print list, and each will be treated as a separate URL. (This also works in reverse: 
listed items can be selected and copied to the clipboard, then saved in a text file. This is a handy way of 
saving a large print list for later restoration.)

Add a local file by choosing Open… from the File menu.
Add a local file name (or file names) by dragging and dropping from, for example, Windows 

Explorer to the WebRecord print list.
Drag and drop an Internet shortcut from the desktop to the WebRecord print list.
Have WebRecord automatically add pages linked to a selected Web page via one of the many 

options on the Fetch menu. This menu includes options such as Directly Linked Pages, which adds all 
pages referred to by hyperlinks in the selected page to the WebRecord print list. The option: All Linked 
Pages On Same Host adds the same pages, but continues adding pages that are referred to on these 
pages, and so on, provided that the pages are on the same host. The depth of these fetches and other 
useful fetches available on the Fetch menu is limited by a WebRecord option. 
(See: Fetching linked pages.)

WebRecord also obeys all the recommendations for robot Web engines when fetching.

What to read next:

How to change the appearance of your printout



How to change the appearance of your printout

There are two aspects to consider here: firstly, you can change your print list to reflect what you want 
printed; and secondly, you can change the characteristics and appearance of your printout.

You change your print list by:
Ticking and unticking listed items. Ticked items are included in the printout; unticked ones are 

ignored.
Rearranging items by dragging-and-dropping. Multiple items can be selected by using the Shift 

and Ctrl keys, which allow you to move multiple items simultaneously, following the usual Windows 
conventions.

Deleting items from the print list by selecting them and using the Delete key. This is useful for 
removing clutter from the list.

You change the characteristics and appearance of your printed WebRecord output by:
Enabling or disabling the Contents command on the Options menu. If this option is ticked, a table 

of contents is included at the start of each printout, listing the titles of web locations included in the 
printout and the WebRecord page number on which they start.

Enabling or disabling the References command on the Options menu. If this option is ticked, 
hyperlinks within the printed Web locations are annotated with WebRecord page numbers or bibliography 
references as appropriate (page numbers are prefixed by a p). A bibliography or list of external references 
is included at the end of the printout under the title: References.

Changing the paper size or page orientation via Page Setup… on the File menu. Each time you 
start WebRecord, the paper size and page orientation default to the settings of your default printer. You 
might therefore want to make changes to your page and print setup before printing.

Changing the number of columns per page by choosing Settings… from the Options menu and 
entering the required number on the Appearance tab. You can set a suitable default value for both portrait 
and landscape pages; WebRecord automatically chooses the appropriate one, depending on your current 
page setup.

Changing the base font size by choosing Settings… from the Options menu and entering the 
required size on the Appearance tab. This field gives you a measure of control of text size. The base font 
is a nominal size, relative to the printout of a normal single-column page. The actual size of text will vary 
relative to other settings, but this setting allows an overall control.

Changing the background of your printout from sand-colored to white, by choosing Settings… 
from the Options menu then selecting No background color from the Print style drop-down list on the 
Appearance tab.

Full-feature or simplified printout?

You can choose between a full-feature (normal) printout, with or without a sand-colored background, or a 
simplified printout. If you want a simplified printout, choose Settings… from the Options menu, then 
select the Simplified option from the Print style drop-down list on the Appearance tab. 

A simplified print:
is faster and uses less ink than a full-feature print;
does not include background textures and colors.

Given these limitations, simplified printing is a better choice for PostScript printers, which can be very 
slow when dealing with high volumes of bitmap data. The normal print mode is recommended for color 
bubble jet and ink jet printers (see: Printing WebRecord pages).

What to read next:

WebRecord interface and performance choices



WebRecord interface and performance choices

Several aspects of WebRecord’s operation can be adjusted to cope with slow machines, machines with 
only small amounts of memory, or machines with only small amounts of free disk space. (Even if you do 
not fall into any of these categories, you might want to make one or more of the adjustments suggested 
here simply because you prefer an alternative mode of operation.)

To adjust WebRecord’s interface and performance you can:
Turn off Show Print Preview from the Options menu. 

If the Show Print Preview option is enabled, WebRecord displays representations of the pages 
that are selected for printing in the print list, in the pane below the print list.

Because these representations are regenerated each time the print list changes, you might want 
to disable this option if its selection adversely affects the performance of your machine. In 
addition, the page representations occupy storage space; if your machine is low on disk space on 
the drive where WebRecord is installed, you might want to untick Show Print Preview. 

Finally, the page previews are sized to fit your WebRecord window. If you make the WebRecord 
window very wide, both of the above problems become worse, because WebRecord has to 
enlarge the page previews.
Turn off Auto Tick New URLs from the Options menu. 

If Auto Tick New URLs is enabled, new URLs added to the print list are automatically ticked or 
selected for printing. This means that WebRecord fetches them immediately, and, if the print 
preview option is enabled, regenerates the print preview. You might want to turn this option off so 
that you have an opportunity to decide which items you want to print before any time or network 
bandwidth is used to fetch them.
Select the Simplified option from the Print style drop-down list on the Appearance tab, accessed 

via the Settings… option on the Options menu. 

Full-feature (normal) prints can be slow on some printers; for example, PostScript printers. Full-
feature prints are likely to use more machine resources and more ink. Choosing simplified printing 
produces a print of lower quality and fewer features, but might be quicker and more economical.
Reduce (or increase) the value of the Simultaneous connections field on the Fetching tab 

accessed via the Settings… option on the Options menu. 

Specifying a large number of simultaneous connections might speed up the fetching of pages, but 
too high a value might have adverse effects. A common symptom of too high a value in this field 
is: missing images and failed fetches which subsequently succeed if the page is re-fetched. The 
cause of these failures is often a limitation on the number of simultaneous operations that can be 
performed by intermediate proxy servers involved in your network connection.

More Information:

The WebRecord window

Printing WebRecord pages



Using WebRecord

This section describes how to perform the following tasks:
Specify WebRecord settings
Fetch Web pages
Print Web pages
Change the appearance of printed pages
Disable automatic selection for printing
Disable the print preview facility
Delete URLs from the print list



Specifying WebRecord settings

Before you start using WebRecord, there are various settings you might want to specify. You do this by 
choosing Settings … from the Options menu.

The three WebRecord Settings dialog tabs enable you to:
specify settings affecting the appearance of your printouts;
specify settings relating to fetching Web pages;
specify proxy settings.

From the Options menu, you can also enable or disable various WebRecord functions. You can:
Select or deselect the Show Print Preview option, depending on whether you want to view the 

print preview or not;
Select or deselect the Auto Tick New URLs option, depending on whether you want every Web 

page you visit, or every URL you add to the print list, to be automatically selected for printing or not;
Select or deselect the Contents option, depending on whether you want a table of contents 

automatically generated and added to the beginning of your printout or not;
Select or deselect the References option, depending on whether you want internal references 

made visible, and a References section listing external references added to the end of your printout, or 
not.

If you have a slow machine, a machine with limited amounts of memory, or a machine with limited 
amounts of free disk space, see WebRecord interface and performance choices for useful setup tips.

More information:

The print preview area

The print list area

About indexing

About referencing



Specifying appearance settings

To specify settings that affect the appearance of your printout, choose Settings … from the Options 
menu, then the Appearance tab of the WebRecord Settings dialog. On this tab you can specify the 
following:

the base font size;
the number of columns per page, in portrait or landscape format;
the number to be used as the first in the sequence of page numbers;
whether you want a full-color printout with the default background, a full-color printout with a white 

background, or a simplified printout—see Printing WebRecord pages;
if you are running Japanese Windows, you can choose the character encoding option relevant to 

the document you are fetching;
whether you want extra margin space on your printout—see Wide Margins.

More information:

The Appearance tab

How you can change the appearance of the printed page



Specifying fetch settings

To specify settings that relate to fetching Web pages, choose Settings … from the Options menu, then 
the Fetching tab of the WebRecord Settings dialog. On this tab you can specify the following:

the number of connections to be allowed at any one time;
the level of linkage to which WebRecord is to go when you choose any of the All Linked Pages 

options from the Fetching menu.

More information:

WebRecord interface and performance choices

The Fetching tab

Fetching linked pages



Specifying proxy settings

To specify proxy settings, choose Settings … from the Options menu, then the Proxies tab of the 
WebRecord Settings dialog. On this tab you can specify whether to use Internet Explorer 3.0+ proxy 
settings (which you can modify from this tab by clicking the Examine/Modify button), Netscape 2.0+ proxy 
settings, or settings specified here. 

Note: If you have a direct connection to the Internet, you need to ensure you do not have a proxy server 
specified.

If you choose the Use these Proxy Settings option, you can then either deselect the Connect to the 
Internet through a proxy server option, or specify the following proxy settings on this tab:

the name of a proxy server;
the names of servers that are not to be accessed via the proxy server (if only the special name 

<local> is specified, access to all local network hosts will bypass the proxy server automatically).

You can use the following guide to determine which proxy settings to use:
if you have Internet Explorer 3.0+ installed on your computer, and it is able to access the Internet 

correctly, select the Use Internet Explorer 3.0+ settings option;
otherwise, if you have Netscape 2.0+ installed on your computer, and it is able to access the 

Internet correctly, select the Use Netscape 2.0+ proxy settings option;
otherwise, select the Use these proxy settings option and consult your system administrator or 

Internet service provider for the values to enter.

If you are unable to make the second or third options operate, install Internet Explorer 3.0+, get it 
operational, then select the Use Internet Explorer 3.0+ settings option.

More information:

The Proxies tab



Fetching Web pages

If you are using Netscape Navigator 2 or higher, or Microsoft Internet Explorer 3 or higher, WebRecord 
automatically tracks your movements on the Internet and adds the URLs of the Web pages you visit to its 
print list. Provided that the Auto Tick New URLs option is enabled (that is, selected on the Options 
menu), WebRecord automatically fetches these pages, as well as all associated graphics. If this option is 
disabled when you go to a Web page using either of these browsers, you can initiate a fetch subsequently 
by ticking the check box to the left of the listed item.

An animation is displayed while WebRecord is fetching Web pages. The status bar at the bottom of the 
window acts as a progress indicator. When WebRecord has finished fetching a page, a status of Fetched 
is displayed in the Status column in the print list area (provided that the fetch was successful).

More information:

Alternate ways of fetching Web pages

Fetching linked pages

Re-fetching Web pages

Displaying fetch status details

Pausing fetching

Canceling fetching

Status bar

Fetching animation



Alternate ways of fetching Web pages

There are alternate ways of fetching a Web page (for example, if you are not using Netscape Navigator or 
Microsoft Internet Explorer):

You can choose Open… from the File menu to open an html file.
You can choose Location… from the Fetch menu, then enter the URL of the location you 

require.
You can copy and paste one or more URLs from a document into the print list area of the 

WebRecord window.
You can drag and drop a hyperlink directly from the main window of your browser into the 

WebRecord print list.
You can add a local file name (or file names) by dragging and dropping from, for example, 

Windows Explorer to the WebRecord print list.
You can drag and drop an Internet shortcut from your desktop to the WebRecord print list
After you have fetched a Web page, you can fetch linked pages.



Opening an html file

You open an html file by choosing Open from the File menu, then finding or entering the name of the file 
you want to open and clicking the Open button. The URL is then displayed in the WebRecord print list 
area.



Copying and pasting URLs

You can copy URLs from another application and paste them into the WebRecord print list area, rather 
than retyping them. Multiple lines of text can be pasted into the WebRecord print list area, and each will 
be treated as a URL. 

This also works in reverse: listed items can be selected and copied to the clipboard, then saved in a text 
file. This is a handy way of saving a large print list for later restoration.



Fetching linked pages

After you have fetched one or more Web pages, you can fetch all linked pages, or a subset of linked 
pages, by selecting one or more URLs in the print list area, then doing one of the following:

choosing the required command from the Fetch menu;
using the right mouse button to pop up a menu from which you can choose the required option.

If, for example, you want to fetch all pages that are linked to the selected URL, as well as all pages linked 
to those pages, you choose the All Linked Pages option. WebRecord then fetches all linked pages, to 
the maximum fetch depth specified on the Fetching tab of the WebRecord Settings dialog.

The Disallowed Pages dialog box

The Disallowed Pages dialog box is presented if WebRecord is disallowed from fetching one or more 
pages linked to a selected Web page when you choose one of the Linked Pages commands. You can, 
however, select pages listed in this dialog box to add to your print list.



Displaying fetch status details

You can display fetch status details while you are fetching one or more Web pages, to view the progress 
of the fetch in detail. To display the Fetch Status window, choose Show Fetch Status from the Options 
menu.

The Fetch Status window comprises five columns, in which the following information is displayed while a 
fetch is in progress:

Name: the name of the file being fetched.
Internet Address: the URL of the Web page being fetched.
Size: the size of the file being fetched; if this information is not supplied by the server from which 

the file is being fetched, then unknown is displayed.
Status: the status of the fetch; that is, percentage complete or amount of data fetched so far.
Reason for fetch: variable.

When no fetch is in progress, the Status column in this window indicates a status of (idle).



Opening a Web page in your browser from the print list

After you have fetched a number of linked Web pages, you might want to view one of these pages. You 
display the page by simply double-clicking its URL in the print list area, and it will be opened in your 
browser. If you do not have a browser open, WebRecord opens your default browser to display the 
chosen Web page.



Pausing fetching

To pause fetching, choose Pause from the Fetch menu. The specific fetches in progress continue until 
complete, before pausing takes effect.



Re-fetching Web pages

If you want to ignore the data in cache and re-fetch one or more Web pages from scratch, you select the 
listed page or pages you want to re-fetch, then do one of the following:

choose Re-fetch from the Fetch menu
use the right mouse button to pop up a menu from which you can choose Re-fetch

If you want to re-fetch all the Web pages in your print list that are selected for fetching and printing 
(ticked), do one of the following:

choose Re-fetch All from the Fetch menu
with your cursor positioned in the print list area, and no pages selected, use the right mouse 

button to pop up a menu from which you can choose Re-fetch All



Canceling fetching

To cancel fetching, choose Cancel from the Fetch menu. The fetch process is immediately canceled.



Printing WebRecord pages

To print the selected pages, you simply choose Print from the File menu and click OK. However, before 
printing, you need to ensure that:

the spool settings for your printer are set to spool print jobs, rather than to print directly to the 
printer (this speeds up WebRecord printing);

you set the page settings you require (see: Changing the appearance of the printed page);
the Web pages you want to print are selected (that is, the check box to the left of these items is 

ticked).

Note: Each time you start WebRecord, the paper size and page orientation default to the settings of your 
default printer.

Changing the background color to white

If you want a printout with a plain white background rather than the default sand-colored background, 
choose Settings from the Options menu, then display the drop-down Print style list on the Appearance 
tab and click No background color.

Producing a simplified printout

If your printer is not a bubble jet or an ink jet printer, or if you require a quick printout, you can request a 
simplified printout. You do this by choosing Settings from the Options menu, then displaying the drop-
down Print style list on the Appearance tab and clicking Simplified.

Your simplified printout will have the following characteristics:
it prints faster and uses less ink than a full-feature print;
it does not include background textures and colors.



Changing the appearance of printed pages

You can change the appearance of printed pages by:
Changing the page orientation
Changing the page layout
Changing the base font size
Changing the number of the first page
Changing the print style
Increasing the margin size
Reordering the print list
Suppressing the Contents section
Suppressing the References section



Changing the page orientation

If you want to print your page in landscape rather than portrait format, choose Page Setup from the File 
menu and change the orientation to Landscape. 



Changing the page layout

To change the number of columns displayed on the page, choose Settings from the Options menu, then 
change the number of columns for either portrait or landscape format, as appropriate, on the Appearance 
tab tab. If you click the Apply button, you can view the changed layout before clicking the OK button to 
exit the WebRecord Settings dialog.



Changing the base font size

To change the base font size to be used for printing a Web page, choose Settings from the Options 
menu, then select a point size from the Base font size drop-down list, or enter a new value in this field on 
the Appearance tab tab. If you click the Apply button, you can view the change before clicking the OK 
button to exit the WebRecord Settings dialog.



Changing the number of the first page

To change the number that appears on the first page of your printout (in the bottom right-hand corner), 
choose Settings from the Options menu, then enter a number in the Start page numbers from: field on 
the Appearance tab tab. If you click the Apply button, you can view the change before clicking the OK 
button to exit the WebRecord Settings dialog.



Changing the print style

The default print style is full color, with a sand-colored background.

Changing the background color to white

If you want a printout with a plain white background, choose Settings from the Options menu, then 
display the drop-down Print style list on the Appearance tab and click No background color.

Producing a simplified printout

If your printer is not a bubble jet or an ink jet printer, or if you require a quick printout, you can request a 
simplified printout. You do this by choosing Settings from the Options menu, then displaying the drop-
down Print style list on the Appearance tab and clicking Simplified.

The simplified printout has the following characteristics:
it prints faster and uses less ink than a full-feature print;
it does not include background textures and colors.



Increasing the margin size

If your printer cuts off part of your printed page, or you require an extra-wide margin for binding purposes, 
you can enable the Wide margins option. This will ensure that a reasonable amount of space is left 
between the edge of the paper and the printed material. If this option is not enabled, the printed area is 
the entire area of the sheet of paper on which your printer is capable of printing.

To change the wide margins setting, choose Settings from the Options menu, then tick the Wide margins 
box on the Appearance tab. If you click the Apply button, you can view the change before clicking the OK 
button to exit the WebRecord Settings dialog.



Suppressing the generation of a table of contents

To suppress the generation of a table of contents for your selected pages, you do one of the following:
go to the Options menu and deselect Contents;
position the cursor in the print preview area, click the right mouse button to pop up a menu, then 

deselect Contents.

More information:

About indexing



Suppressing referencing

To suppress the generation of a list of external hyperlinks that are referenced on your selected page or 
pages, and the cross-referencing of internal references, you do one of the following:

go to the Options menu and deselect References;
position the cursor in the print preview area, click the right mouse button to pop up a menu, then 

deselect References.

More information:

About referencing



Reordering pages in the print list

To change the order in which pages are displayed and printed, you click a title (or the WebRecord icon 
next to it) in the print list area, then drag and drop it in the required position. Before you release the left 
mouse button, a line appears in the new position so that you can ensure you are dropping the selected 
page in the right place. 

You can drag and drop more than one consecutive page simultaneously by using the Shift and Ctrl keys 
and following the usual Windows conventions.



Disabling automatic selection for printing

To disable automatic selection for printing, you do one of the following:
go to the Options menu and deselect Auto Tick New URLs;
position the cursor in the print list area with no URLs selected; click the right mouse button to pop 

up a menu, then deselect Auto Tick New URLs.

The Web pages you visit will continue to be added to the print list, but will not automatically be selected 
for fetching and printing (that is, the check box beside each new entry will be unchecked). 

More information:

WebRecord interface and performance choices



Disabling the print preview facility

To disable the automatic print preview facility—that is, to hide the print preview area—you do one of the 
following:

go to the Options menu and deselect Print Preview;
position the cursor in the print preview area, click the right mouse button to pop up a menu, then 

choose Hide.

More information:

WebRecord interface and performance choices



Deleting URLs from the print list

To delete a single URL from the print list, you click the name of the URL you want to delete, then use the 
Delete key, or choose Delete from the Edit menu.

If you want to delete a number of consecutive URLs (but not all URLs), use the Shift key to select these 
URLs before using the Delete key.

To delete all URLs in the print list, you do one of the following:
go to the Edit menu and select Delete All;
position the cursor in the print list area with no URLs selected, then use the right mouse button to 

pop up a menu from which you can choose Delete All.



Dialog boxes, secondary windows, and fields

This topic is purely for grouping dialog box and field descriptions in the HDK3 organizer.



The WebRecord Window pop-ups

This is purely a grouping topic.



The menu bar

You access WebRecord commands from these menus, or from pop-up menus displayed when you use 
the right-hand mouse button in the print list area or the print preview area of the WebRecord window. For 
a detailed description of the commands, see: the WebRecord commands.



The print list area

The print list area is located below the menu bar in the WebRecord window. It contains a list of Web 
pages. (Items remain on this list from session to session unless manually deleted.)

The print list is laid out in columns with the following headings:
Title:    under which Web page titles are listed.
Status:  under which WebRecord progress is reported while a Web page is being fetched.
Location: under which Web page URLs are listed.

There is a check box to the left of each item in the print list; when the box is checked, this indicates that 
the Web page is selected for printing.

For a complete list of the ways you can add items to the print list, see:
How to get URLs into the WebRecord print list.

For details of the commands you can issue from the print list area, see: the print list pop-up menus.



The print list items being fetched

These items have been selected for printing and are being fetched.



The print preview area

The print preview area is below the print list area. 

If the Print Preview option is enabled (that is, selected on the Options menu), WebRecord displays the 
Web pages you have selected (in the print list area) in the preview area. WebRecord arranges the Web 
pages in the preview area in the order they are listed in the print list area, provided that they are ticked 
there. The preview shows you exactly what your printed pages will look like, depending on which print 
style you have selected—see Printing WebRecord pages.



The page number

The WebRecord page number.



The Contents section

If the Contents option is enabled (that is, selected on the Options menu), WebRecord supplies a table of 
contents at the start of the printout. The Contents section lists the Web pages you have selected for 
printing in the print list, and shows the number of the WebRecord page on which the representation of the 
Web page begins.



The References section

If the References option is enabled (that is, selected on the Options menu),a numbered list of all external 
URLs referenced is displayed in a References section at the end of the printout. The number that is 
inserted after the hyperlink text in the body of the printout represents the position of the URL for that 
reference in the References list.



The fetching animation

An animation is displayed while fetching is in progress.



The status bar

The status bar is located below the print preview area. Various progress messages are displayed on the 
left-hand side of the status bar, to indicate the status of WebRecord processing. The amount of disk 
space WebRecord is using after it has fetched a Web page is displayed in the right-hand corner of the 
status bar. 



Appearance tab fields

This is purely a grouping topic.



Base font size

This field gives you a measure of control of text size. The base font is a nominal size, relative to the 
printout of a single-column, A4 page. That is, if you choose single-column, A4 layout, the base font will be 
the size you specify; otherwise, the actual size of the base font will vary, depending on the other settings 
you specify.

You can select a value from the drop-down list, or enter the value you require. 



Columns on portrait pages

If your page orientation is set to Portrait in the Print Setup dialog box (reached via the File menu), this 
value determines the number of columns that WebRecord uses when laying out the print preview and 
printing the selected locations. You can select a value from the drop-down list, or enter the value you 
require. 



Columns on landscape pages

If your page orientation is set to Landscape in the Print Setup dialog box (reached via the File menu), 
this value determines the number of columns that WebRecord uses when laying out the print preview and 
printing the selected pages. You can select a value from the drop-down list, or enter the value you 
require.



Start page numbers from

This is the number that is displayed in the bottom right-hand corner on the first page of your printout. You 
enter the value that you require.



Print style

If you do not want to print a full color printout, you can select an alternative style from the drop-down list. 

If you select No background color, the sand-colored background is replaced by a white background.

If you request a simplified printout, the results are:
 printing is faster and uses less ink than a full-feature print;
background textures and colors are not included.

It is a good idea to select Simplified if you are going to print your Web page display on a Postscript printer 
rather than a bubble jet or an ink jet printer.



Assume new documents are

Select the appropriate value from the drop-down list to indicate the character type used to encode a Web 
page. Unless you are using Japanese Windows, the correct setting is Latin-1. The Japanese Shift-JIS, 
Japanese EUC, and UTF8 Unicode options are there to enable WebRecord to render Japanese 
characters, if the fonts are present.

Your selection is applied to any new URLs added to the print list.



Fetching tab fields

This is purely a grouping topic.



Simultaneous connections

The number of connections allowed at any one time. WebRecord supports numerous connections to an 
Internet server at any one time, which enables it to receive text and images simultaneously. 

Specifying a large number of simultaneous connections might speed up the fetching of pages, but too 
high a value might have adverse effects and slow data transmission. A common symptom of too high a 
value in this field is: missing images and failed fetches which subsequently succeed if the page is re-
fetched. The cause of these failures is often a limitation on the number of simultaneous operations that 
can be performed by intermediate proxy servers involved in your network connection.



Maximum fetch depth

The level of linkage to which WebRecord goes to retrieve linked pages when you issue one of the All 
Linked Pages commands from the Fetch menu. For example, if set to 4, WebRecord retrieves linked 
pages up to four levels away from the selected page or pages.



Proxies tab fields

This is purely a grouping topic.



Use Internet Explorer 3.0+ settings

If you select this option, WebRecord uses the proxy settings specified via the Windows Control Panel. 
These are the same settings which Internet Explorer 3.0+ uses. Note that this control panel is only 
available if Internet Explorer 3.0+ has been installed. See: Specifying proxy settings.



Copy Netscape 2.0+ proxy settings

If you select this option, WebRecord copies the proxy settings specified on the Proxies tab of the 
Netscape Preferences dialog. See: Specifying proxy settings.



Use these proxy settings

If you select this option, WebRecord uses the proxy settings specified on this tab. See: Specifying proxy 
settings.



The Examine/Modify ... button

This button enables you to display the Windows 95 Internet Properties dialog, where you can browse or 
modify your proxy settings. Note that the Internet Properties dialog is only available if Internet Explorer 
3.0+ has been installed.



The Connect to the internet through a proxy server check box

This check box is only enabled if you select Use these proxy settings. If you click this check box, you 
can then enter the name of a proxy server, and the names of servers that are not to be accessed via the 
proxy server. See: Specifying proxy settings.



Using this proxy server

The name of the server that is to act as the proxy between your PC and the Internet. See: Specifying 
proxy settings.



Except for addresses starting with

The names of servers that are not to be accessed via the proxy server. These must be separated by a 
semi-colon; for example: 

server1;server2;server3

Entering the special name of <local> alone will prevent the use of the proxy server for all local (intranet) 
addresses.



Reference topics

This section provides:
a detailed description of the components of the WebRecord window;
a menu by menu description of the WebRecord commands;
an explanation of how WebRecord generates a table of contents;
an explanation of how WebRecord makes hyperlinks visible;
a description of the Disallowed Pages dialog box;
a list of supported protocols and MIME types.



The WebRecord window

The WebRecord window comprises the following components:
the title bar, where the application name and icon are displayed;
the menu bar, from which you access the WebRecord commands;
the print list area, from which you select Web pages for printing;
the print preview area, where a preview of the pages to be printed is displayed;
the status bar, where progress messages and disk space usage are displayed.



The print list area

The print list area is located below the menu bar in the WebRecord window. It contains a list of Web 
pages. Items remain on this list from session to session unless manually deleted.

The print list is laid out in columns with the following headings:
Title:    under which Web page titles are listed.
Status:  under which WebRecord progress is reported while a Web page is being fetched.
Location: under which Web page URLs are listed.

There is a check box to the left of each item in the print list; when this box is checked, this indicates that 
the Web page is selected for fetching and printing.

For a complete list of the ways you can add items to the print list, see:
How to get URLs into the WebRecord print list.

For details of the commands you can issue from the print list area, see:
the print list pop-up menus.



The print preview area

The print preview area is below the print list area in the WebRecord window. 

If the Print Preview option is enabled (that is, selected on the Options menu), WebRecord displays the 
Web pages you have selected (in the print list area) in the preview area. WebRecord arranges the Web 
pages in the preview area in the order they are listed in the print list area, provided that they are ticked 
there.

More information:

Contents section

Reference section

Print preview pop-up menu



The WebRecord commands

The WebRecord commands are grouped on the following menus:
The File menu
The Edit menu
the Fetch menu
the Options menu
the Help menu
the print list pop-up menus
the print preview pop-up menu



The File menu

The commands on this menu are:

Open … Opens an html file.

Page Setup … Enables you to specify a printer name and properties, as well as paper size 
and page orientation.

Print Prints the URLs that are ticked in the print list.

Exit Exits the application.

The Edit menu

The commands on this menu are:

Copy URL Copies one or more highlighted URLs to the Windows clipboard.

Paste URL Pastes one or more URLs from the Windows clipboard into the WebRecord print 
list area.

Delete Deletes one or more URLs from the WebRecord print list area.

Tick Causes the check box to the left of the title of one or more URLs to be ticked, 
and the URL or URLs to be fetched and selected for printing.

Untick Causes the check box to the left of the title of one or more URLs to be unticked, 
resulting in the URL or URLs no longer being selected for printing.

Encoding        
>

Unless you are using Japanese Windows, the correct setting is Latin-1. The 
Japanese Shift-JIS, Japanese EUC, and UTF8 Unicode options are there to 
enable WebRecord to represent Japanese characters, if the fonts are present.

Delete All Deletes all URLs that are displayed in the print list area.

Tick All Causes the check boxes to the left of the titles of all listed URLs to be ticked, 
and the URLs to be fetched and selected for printing.

Untick All Causes the check boxes to the left of the titles of all listed URLs to be unticked, 
resulting in no URLs being selected for printing.

Properties … Displays the title, MIME type, and status of one or more selected URLs, as well 
as details of all associated images.

The Fetch menu

The commands on this menu are:

Location … Enables you to enter a URL to be fetched without you even 
visiting the site.

Directly Linked Pages Fetches all Web pages directly linked to the selected URL or 
URLs.

All Linked Pages In Same
Directory

Fetches all Web pages linked (directly or indirectly) to the 
selected URL or URLs, to the maximum fetch depth specified on 
the Fetching tab of the WebRecord Settings dialog, provided 
that they are in the same directory.

All Linked Pages In Same
& Sub Directories

Fetches all Web pages linked (directly or indirectly) to the 
selected URL or URLs, to the maximum fetch depth specified on 



the Fetching tab of the WebRecord Settings dialog, provided 
that they are in the same directory or one of its 
subdirectories.

All Linked Pages On Same
Host

Fetches all Web pages linked (directly or indirectly) to the 
selected URL or URLs, to the maximum fetch depth specified on 
the Fetching tab of the WebRecord Settings dialog, provided 
that they are on the same host.

All Linked Pages Fetches all Web pages linked (directly or indirectly) to the 
selected URL or URLs, to the maximum fetch depth specified on 
the Fetching tab of the WebRecord Settings dialog.

Pause Pauses fetching when the fetch or fetches currently in progress 
are completed.

Cancel Cancels all fetching.

Re-fetch Ignores the previously fetched data in the local cache and re-
fetches one or more selected Web pages.

Re-fetch All Ignores the previously fetched data in the local cache and re-
fetches all Web pages in the print list area that are selected for 
fetching and printing (ticked).

More information:

Fetching Web pages



The Options menu

The first five commands on this menu are enabled if ticked, disabled if not ticked. The commands are:

Show Fetch Status If enabled, displays the Fetch Status window, which shows the status 
of URLs currently being fetched.

Show Print Preview If enabled, displays the print preview area; if disabled, hides this area.

Auto Tick New URLs If enabled, ticks the check box to the left of the title of each new Web 
page added to the print list. This automatically selects the Web pages 
for fetching and printing.

Contents If enabled, generates a table of contents for the selected Web pages.

References If enabled, generates a list of external references (that is, links to 
external locations) that appear on the selected Web pages and makes 
internal references visible—see About referencing.

Settings … Lists commands for changing the appearance of your printout, and for 
specifying fetch and proxy settings.

More information:

The WebRecord Settings dialog box



The Help menu

The commands on this menu are:

Help Topics Provides access to the list of WebRecord online help topics.

What you need to
know

Provides access to a brief overview of the full WebRecord functionality; 
for users who want to know everything the product does without having to 
sift through all the help.

Contents Provides access to a high-level summary of the contents of the online 
help.

Using WebRecord Provides access to a description of various tasks, from specifying settings 
to how to use the product.

Reference Provides access to reference topics.

Register Enables you to pay for and register your limited version of WebRecord, in 
order to obtain a full and unrestricted version of the product. (This option 
is not displayed if you have already purchased the product.)

About WebRecord Provides access to WebRecord product details, such as the version 
number.

The print list pop-up menus

There are two pop-up menus that can be accessed from the print list area by using the right mouse 
button:

1. If your mouse pointer is in the print list area, but no URL is selected

2. If your mouse pointer is in the print list area, and one or more URLs is selected



Print list pop-up menu (no URLs selected)

If no URL is selected when you click the right mouse button in the print list area, you can do the following:

Paste URL Paste one or more URLs from the Windows clipboard into the 
WebRecord print list area.

Delete All Delete all URLs that are displayed in the print list area.

Tick All Select all URLs displayed in the print list area for printing.

Untick All Deselect all URLs displayed in the print list area.

Pause Fetching Pause fetching when the fetch currently in progress is complete.

Re-fetch All Ignore the data in cache and re-fetch all Web pages in the print list area 
that are selected for fetching and printing (ticked).

Show Fetch Status Display the Fetch Status window, which shows the status of URLs 
currently being fetched.

Show Print Preview Select (tick) to display the print preview area; deselect (untick) to hide 
the print preview area.

Auto Tick New URLs Select (tick) to enable the automatic selection for fetching and printing of 
each new Web page added to the print list; deselect (untick) to disable 
this facility.

Print list pop-up menu (URLs selected)

If one or more URLs is selected when you click the right mouse button in the print list area, you can do 
the following:

Copy URL Copy one or more selected URLs to the Windows clipboard.

Delete Delete one or more selected URLs from the WebRecord print 
list area.

Tick Select one or more URLs for fetching and printing by ticking the 
check box to the left of the title of the URL or URLs.

Untick Deselect one or more URLs in the print list that you do not want 
to print by unticking the check box to the left of the title of the 
URL or URLs.

Encoding        > Unless you are using Japanese Windows, the correct setting is 
Latin-1. The Japanese Shift-JIS, Japanese EUC, and UTF8 
Unicode options are there to enable WebRecord to represent 
Japanese characters, if the fonts are present.

Directly Linked Pages Fetch all Web pages directly linked to the selected URL or 
URLs.

All Linked Pages in Same
Directory

Fetch all Web pages linked (directly or indirectly) to the selected 
URL or URLs, to the maximum fetch depth specified on the 
Fetching tab of the WebRecord Settings dialog, provided that 
they are in the same directory.

All Linked Pages in Same
& Sub Directories

Fetch all Web pages linked (directly or indirectly) to the selected 
URL or URLs, to the maximum fetch depth specified on the 
Fetching tab of the WebRecord Settings dialog, provided that 
they are in the same directory or one of its subdirectories.



All Linked Pages on Same
Host

Fetch all Web pages linked (directly or indirectly) to the selected 
URL or URLs, to the maximum fetch depth specified on the 
Fetching tab of the WebRecord Settings dialog, provided that 
they are on the same host.

All Linked Pages Fetch all Web pages linked (directly or indirectly) to the selected 
URL or URLs, to the maximum fetch depth specified on the 
Fetching tab of the WebRecord Settings dialog

Re-fetch Ignore the data in cache and re-fetch one or more selected Web 
pages.

Properties Display the title, MIME type, and status of one or more selected 
URLs, as well as details of all associated images.

The print preview pop-up menu

By using the right mouse button to display this pop-up menu when your mouse pointer is positioned in the 
print preview area, you can do the following:

Contents Enable or disable the generation of a table of contents for the selected Web 
pages.

References Enable or disable the visibility of internal references, and the generation of a 
list of external references (that is, links to external locations) that appear on 
the selected Web pages—see About referencing.

Hide Choose this option to hide the print preview area.

The WebRecord Settings dialog box

This dialog box comprises three tabs:
Appearance
Fetching
Proxies



The Appearance tab

This tab enables you to customize the appearance of the printed page.

More information:

Base font size

Columns on portrait pages

Columns on landscape pages

Start page numbers from

Print style

Assume new documents are

Increasing the margin size



The Fetching tab

This tab enables you to select (from drop-down lists of valid values) or enter the number of simultaneous 
connections that WebRecord can establish, and the maximum fetch depth (or number of levels of linkage) 
to which it will penetrate when you select one of the All Linked Pages commands from the Fetch menu.

More information:

Simultaneous connections

Maximum fetch depth

WebRecord interface and performance choices



The Proxies tab

This tab enables you to identify a proxy server through which you connect to the Internet for security 
purposes. If you have a direct connection to the Internet, you need to ensure you do not have a proxy 
server specified. 

You configure a proxy by doing one of the following:
Setting Internet properties from your control panel (requires Internet Explorer 3.0+);
Specifying network preferences in Netscape 2.0+;
Specifying proxy details on the WebRecord Proxies tab.

See: Specifying proxy settings.

More information:

Use Internet Explorer 3.0+ settings

The Examine/Modify button

Use Netscape 2.0+ proxy settings

Use these proxy settings

Connect to the internet through a proxy server

Using this proxy server

Except for addresses starting with



The Disallowed Pages dialog box

The WebRecord fetch operation is a robotic crawler, and as such is constrained by certain rules; for 
example, servers can disallow a robotic crawler from accessing specific directories.

This dialog box is presented if WebRecord is unable to fetch one or more pages linked to a selected Web 
page. Even though the WebRecord fetch operation is unable to access the listed pages, you yourself can 
select one or more pages listed in this dialog box to add to your print list, and select the page or pages for 
printing.



About indexing

If the Contents option is enabled (that is, selected on the Options menu), WebRecord supplies a table of 
contents at the start of the printout. The Contents section lists the Web pages you have selected for 
printing (in the print list above), and shows the WebRecord page number on which the representation of 
the Web page begins.



About referencing

If the References option is enabled (that is, selected on the Options menu), hyperlinks are made visible 
by:

page references being automatically inserted after internal hyperlinks;
a numbered list of all external URLs referenced being displayed in a References section at the 

end of the printout.

Internal hyperlinks

In the case of links to locations within the selected Web pages, the number of the WebRecord page on 
which the destination of the link is located is inserted after the hyperlink text, preceded by the letter p.

External hyperlinks

In the case of links to locations outside the selected Web pages, the number that is inserted after the 
hyperlink text represents the position of the URL for that reference in the References list.

For example, the number 2 after the hyperlink The latest information on all Canon web sites indicates that 
the associated URL is positioned second in the References list.



Supported protocols and MIME types

WebRecord supports the following Protocols:
http
file (that is, a local file on disk)

WebRecord supports the following MIME types:
 text/html (HTML 2.0 with some HTML 3.0 features)
 text/plain
 image/gif 
 image/tiff
 image/pcd (PhotoCD)
 image/bmp (Windows bitmap)
 image/fxp (FlashPix)
 image/jpeg (including progressive jpegs)

WebRecord does not support, and will ignore:
Java
Plug-ins (for example, Shockwave and QuickTime)

WebRecord will print frames as individual web pages.






