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To reply by mail to the author

1 Open or select the message you want to reply to.

2 On the Mail menu, click Reply To Author. 

To send the message to other individuals, type the e-mail name of each recipient in the To or Cc box, separating each name by 

a semicolon ( ; ).

3 Type your message.

4 On the File menu, click Send Message.

Tips
To select a name from your Internet Mail Address Book, click the Mail menu in the main window, and then click Choose 

Recipients.
In the Select Recipients dialog box, you can also insert a name in the Add To box by double-clicking it in the Display 

Name list.
To see more options for replying to messages, in the main window click the Mail menu in the main window, click Options, 

and then click the Send tab.



To forward a message

1 Open or select the message you want to forward.

2 On the Mail menu, click Forward.

3 Type the e-mail name of each recipient, separating each name by a semicolon ( ; ).

4 Type your message.

5 On the File menu, click Send Message.

Note
To deliver outgoing messages and check for new messages immediately, click the Mail menu in the main window, and 

then click Send And Receive Mail.



To change the priority of an outgoing message

In the outgoing message window, click the Mail menu, click Set Priority, and then click High, Normal, or Low.

Note
This setting changes the priority for the current message only.

Related Topics

Replying to a message

Sending a message



To delete a message

1 Open or select the message you want to delete.

2 On the File menu, click Delete.

Notes
To restore a deleted message, open the Deleted Items folder, and then copy or drag the message to the Inbox or other 

folder.
If you don't want messages saved in the Deleted Items folder when you quit Internet Mail, click the Mail menu, click 

Options, and then click the Read tab. Select the following check box: Empty Messages From The 'Deleted Items' Folder Upon Exit.

Related Topic

Deleting folders



To save copies of outgoing mail messages

1 In the main window, click the Mail menu, and then click Options.

2 Click the Send tab, and then select the following check box: Save Copy Of Sent Messages In The 'Sent Items' Folder.

Tips
You cannot delete the Sent Items folder.
If you want to save a copy of only the current message, type your e-mail name in the Cc box in the message window.



To automatically mark messages as read

1 On the Mail menu, click Options.

2 On the Read tab, select the following check box: Mark Message As Read After Previewed For x Second(s).

3 Specify the number of seconds.



To customize the Internet Mail window

To adjust the area for the preview pane and message list, drag the divider between the preview pane and the message 
list. 

To hide the toolbar or status bar, click the View menu, and then clear the check mark for each item you don't want to appear.

To hide the header information, click the View menu, click Preview Pane, and then clear the check mark for Header 

Information.



To send outgoing messages immediately

1 On the Mail menu, click Options.

2 On the Send tab, select the Send Messages Immediately check box. 

In an outgoing message window, when you click the File menu and then click Send Message, Internet Mail immediately sends 

any messages in your Outbox to your mail server, and checks for incoming messages.

Tip
If you don't want messages sent immediately, clear this check box. When you click    Send Message, Internet Mail stores 

messages in your Outbox until you choose the Send And Receive command or quit Internet Mail.



To delete a folder 

1 In the folder tree, click the folder you want to delete.

2 On the File menu, click Folder, and then click Delete.

Note
You cannot delete or rename the Deleted Items, Inbox, Outbox, or Sent Items folders.



To insert your signature into all outgoing messages

1 On the Mail menu, click Options.

2 On the Signature tab, click Text, and then type the text you want to appear at the bottom of your message. 

3 Click Add Signature To The End Of All Outgoing Messages.

Tips
You can also insert the contents of a text file as your signature.
If you choose not to insert your signature in all outgoing messages, you can still insert it in an individual message by 

clicking the Insert menu in an outgoing message and then clicking Signature.



To add a contact to your Address Book

1 On the File menu, click Address Book.

2 Click New, and then type the contact's first name, last name, and e-mail name.



To edit a contact in your Address Book 

1 On the File menu, click Address Book.

2 Click the name you want in the Address Book list, and then click Properties.

3 Modify the information as needed. 

Tip
To delete a contact, select the contact in the Address Book list, and then click Delete.



To send a message to a contact in your address book 

1 In an outgoing message window, click the Mail menu, and then click Choose Recipients.

2 Select the name you want, and then click Add To or Add CC.

3 Click OK.

Tip
In the Select Recipients dialog box, you can also insert a name in the Add To box by double-clicking it in the Display 

Name list.



To print a message

1 Open or select the message you want to print.

2 On the File menu, click Print.



A header is the row of information about a message that is displayed in the message list and above the message in a message 

window. The header contains information about the item, such as the sender, the subject, and the time and date the message 

was received or sent.



To send a message

1 On the Mail menu in the main window, click New Message.

2 In the To box, type the e-mail name of each recipient, separating each name by a semicolon ( ; ).

To send copies, type the e-mail name of each recipient in the Cc box, separating each name by a semicolon.

3 In the Subject box, type the subject of the message.

4 Type your message.

5 On the File menu, click Send Message. 

Your e-mail is delivered to your mail server the next time Internet Mail checks for new mail.

Tips
To send a file with your message, click the Insert menu, click File Attachment, and then double-click the file you want to 

send.
To check for new messages and deliver outgoing messages immediately, click the Mail menu in the main window, and 

then click Send And Receive Mail.

Related Topics

Changing the priority of an outgoing message

Sending messages to contacts from your address book



To automatically check for new messages

1 On the Mail menu, click Options.

2 On the Read tab, select the following check box: Check For New Messages Every x Minutes.

3 Specify how often you want Internet Mail to check for new messages.

Tips
When this check box is selected, Internet Mail also checks for new messages whenever you start the program.
To check for messages immediately, click the Mail menu, and then click Send And Receive Mail.



To edit your mail account information

1 On the Mail menu, click Options, and then click the Server tab.

2 Change your account information as needed, and then click OK.

Related Topics

Skipping Internet Mail logon

Setting up Internet Mail for multiple users



To read your messages

To view the message in a separate window, double-click the message in the message list.

To view the message in the preview pane, click the message in the message list.

Tips
 To display the preview pane, click the View menu, click Preview Pane, and then click Split Vertically or Split Horizontally.

To display or run an attachment from the preview pane, click the file attachment icon in the preview pane header 
information, and then double-click the file name.

Related Topic

Automatically checking for new messages



To add a folder

1 On the File menu, click Folder, and then click Create.

2 Type the name.



To switch to another folder

Click the folder in the folder tree.



To filter incoming messages

1 On the Mail menu, click Inbox Assistant.

2 Click Add.

3 Type the criteria you want the incoming message to match.

4 Click the folder you want the matching incoming messages moved to.

Tips
You can filter matching incoming messages to automatically go to your Deleted Items folder.
You can specify multiple rules for incoming messages.
To change the priority in which messages are sorted in the list, click the up or down arrows next to the rules list to move 

the highest priority rules to the top and lowest to the bottom.
If an incoming message matches more than one rule, then it is sorted according to the first rule it matches in your list.



To skip the Internet Mail logon 

On the Mail menu, click Skip Logon.

The next time you log on to Internet Mail, Internet Mail will start without prompting you for a logon name or password.

Caution
If there are other users on this computer, selecting Skip Logon will enable them to open your mail account without logging 

on. This command is unavailable if there is more than one Internet Mail account set up on this computer.

Related Topic

Setting up Internet Mail for multiple users



To set up Internet Mail for multiple users

You can set up Internet Mail so that you can log on to different mail accounts, such as when you have multiple accounts, or when 

several people share the same computer and have separate mail accounts.

To set up several accounts for yourself

1 On the Mail menu, make sure Skip Logon is not selected, and then quit Internet Mail.

2 Log on to Internet Mail with the user name and password, and then follow the instructions on your screen to set up the mail 

account. 

3 If you want to set up additional accounts, quit Internet Mail, and then repeat steps 1 and 2.

To set up your own account when others share this computer

1 On the Mail menu, make sure Skip Logon is not selected, and then quit Internet Mail.

2 Log on to Internet Mail with the user name and password, and then follow the instructions on your screen to set up the mail 

account. 

Notes
The Skip Logon command is unavailable if there is more than one Internet Mail account set up on this computer.
Once you've set up Internet Mail for multiple users, to log on as a different user, just quit Internet Mail, and then log on 

again with a different user name and password. You do not need to shut down your computer to log on as a different Internet Mail 
user.

Related Topics

Skipping Internet Mail logon

Editing your mail account information



Welcome to Internet Mail 

With an Internet connection and Microsoft Internet Mail, you can exchange e-mail messages with anyone on the Internet. 

Internet Mail fully supports Internet standards, including SMTP, POP3, and MIME.

Microsoft Internet Mail is fast, friendly, and easy to use. Here are a few of the features that make sending and receiving 

messages on the Internet easy and fun.

Save e-mail addresses in your Address Book, and insert them into messages

You can save first names, last names, and Internet e-mail names in the Address Book. Once they are in the Address Book, you 

can insert them into messages. 

Do everything from the main window 

You can view and respond to messages and switch folders all from the Internet Mail window. Just by clicking a toolbar button, 

you can reply to, forward, or create messages. All of these commands and more are also available from the menus.

Browse your messages quickly and easily 

The mail folder tree enables you to switch quickly between mail folders. The message list and preview pane enable you to view a 

list of messages and preview the messages at the same time in one window.

Or, if you prefer, you can view a message in a separate window and use its toolbar to go to the next or previous message.

Create your own folders to organize your messages 

You can add folders to organize and sort your messages. After you receive messages, you can move them to any folder you 

want. You can even create folders within folders. 

Sort the message list 

You can sort messages by columns, such as by subject, sender, or time it was received or sent. 

Add your personal signature to your messages

You can insert text or a text file as your personal signature. And you can choose to insert your signature in all outgoing 

messages, in an individual message, or not at all.



Using keyboard shortcuts for Internet Mail

You can use shortcut keys to choose commands and navigate through the preview pane and the message list.

Mail: main window, view message window, and send message window

To do this Press this

Open Help topics F1

Mail: main window and view message window 

To do this Press this

Print the selected 

message

CTRL+P

Send and receive mail CTRL+M

Delete a message DEL or CTRL+D

Open a new message CTRL+N

Reply to the author CTRL+R 

Forward a message CTRL+F

Reply to all CTRL+SHIFT+R

Mail message window    sending only

To do this Press this

Check names CTRL+K or ALT+K

Send a message CTRL+ENTER or ALT+S



Getting started with Internet Mail

If you are new to e-mail or Internet Mail, here's a quick look at how to get from installing Internet Mail to receiving, viewing, and 

sending e-mail. You may already have completed part of this process when you installed Internet Mail. The steps listed below are 

explained in separate procedures in Internet Mail Help.

Set up your Internet connections

Before you can send and receive e-mail, you must have access to the Internet through an Internet service provider or through an 

Internet gateway (proxy server) in your organization. After you have an Internet connection, you can set up specific Internet Mail 

settings. Usually, you connect to the Internet in one of the following ways:
Over phone lines, using a modem. You can manually establish a connection, or you can use dial-up scripting to 

automatically connect when you start Internet Mail. Your Internet service provider can provide you with the phone number, modem 
settings, and network protocols required to access the provider.

Through a local area network (LAN). Your organization might provide external access to the Internet from your computer 
through a LAN. Your system administrator can provide you with account information and network protocols to access the mail 
servers.

Add mail server names 

You will need the mail server names, your account name, and password. You must specify an incoming and an outgoing mail 

server. This information is provided to you by your Internet service provider, or by your system administrator if you are using 

Internet Mail on a LAN. There are two ways to specify this information:
In the Internet Mail Configuration Wizard, the first time you start Internet Mail after installing it. 
In Internet Mail, through the Options command on the Mail menu. Click the Server tab to add or change settings for mail 

servers and account information.

Read messages

When you start Internet Mail, it connects to your mail server, logs on to your e-mail account, and downloads any new messages 

into your Inbox folder. In addition to your Inbox folder, Internet Mail includes several other mail folders and also enables you to 

create your own. You can organize your messages by moving them to other folders or deleting them.

Messages are stored on your computer; in addition, there is an option to store copies of your messages on your mail server. Not 

all mail servers support this option; for more information, contact your Internet service provider or system administrator. 

Send messages

You can create new messages, or forward or reply to messages you've received. Internet Mail includes an Address Book, so you 

can store and select from e-mail names of people you communicate with regularly. When you send a message, Internet Mail 

checks all of the names in the To and Cc boxes to make sure they match contacts in your Address Book or that they are properly 

formatted Internet e-mail names. 

Related Topics

Editing your mail account information

Setting up Internet Mail for multiple users

Reading your messages

Sending a message



Identifying Internet Mail message-list icons

The following icons indicate whether messages have files attached, whether they are marked as read or unread, and their 

priority.

This icon Indicates

The message has one or more files attached.

The message has been marked high priority by 
the sender.

The message has been marked low priority by 
the sender.

The message has been read. The heading 
appears in light type.

The message has not been read. The heading 
appears in bold type.



Mail Logon Dialog Box

Internet Mail stores each new user's name and password on your computer. The user name and password are usually provided 

by your Internet service provider or system administrator. Each user has a separate set of preferences, mail folders, and 

message store.

User Name

Specifies your account name. This is usually the same as the part of your e-mail address to the left of the at sign ( @ ).

Password

Provides a space for you to type the password assigned to you by your service provider. For security, the actual characters 

are not displayed in this space; each character is represented by an asterisk ( * ).

Create New User

Enables you to specify a new user on this computer. 



Address Book Dialog Box

Using the Address Book, you can store the name and e-mail address information for your contacts. Use the Address Book dialog 

box to view, add, remove, or edit contact information. 

Display Name

Lists the friendly name (as opposed to an e-mail name) that you have assigned to each contact. 

E-Mail Address

Lists the Internet e-mail address for each contact.

New

Click this to create and add a new contact. 

Delete

Click this to delete the selected contact from your Address Book.

Properties

Click this to change the display name and e-mail address information for the selected contact.



New Address Book Entry Dialog Box

Use this dialog box to add new e-mail contacts to your Address Book.

Display Name

Provides a space for you to type the friendly name for this contact.

E-Mail Address

Provides a space for you to type the Internet e-mail address for this contact.



Edit Address Book Entry Dialog Box

Use this dialog box to edit existing e-mail contacts in your Address Book.

Display Name

Provides a space for you to type the friendly name for this contact.

E-Mail Address

Provides a space for you to type the Internet e-mail address for this contact.



Columns Dialog Box

Use this dialog box to add or remove columns in your message list and to change the order in which they appear.

Available

Lists the available columns that you can add to your message list.

Displayed

Lists the columns currently displayed in your message list and the order in which they appear.

Add

Moves the selected column from the Available Columns list to the Displayed Columns list.

Remove

Moves the selected column from the Displayed Columns list to the Available Columns list.

Move Up

Moves the selected column up one in the Displayed Columns list, and to the left when viewing your message list.

Move Down

Moves the selected column down one in the Displayed Columns list, and to the right when viewing your message list.

Reset

Restores the column settings to what they were when you first installed Internet Mail.



Options Dialog Box Send Tab

Use this tab to change settings for sending and composing messages.

Save Copy of Sent Messages in the 'Sent Items' Folder

Specifies whether you want to save copies of the messages you send in the Sent Items folder. If you clear this check box, you 

can still save a copy of a message by including yourself on the To or Cc line of the message.

Include Message in Reply

Specifies whether to include the text of the original message when you reply to a message. You can edit or cut any of its text. 

If you clear this check box, the body of your message contains only the text you type or paste.

Send Messages Immediately

Specifies whether Internet Mail should immediately forward to your mail server any messages you send. If you clear this check 

box, messages you send by using the Send Message command are placed in your Outbox and are not actually sent until you 

click the Mail menu and then click Send And Receive Mail. 

Settings

Click this to change MIME message format settings.

Indent the Original Text with 'X' When Replying to or Forwarding a Message

Specifies whether to indent the beginning of each line of original text included in your reply, preceded by the character 

indicated. This distinguishes the text you type from the text in the original message. If you clear this check box, the original 

text and the text you add appear the same.



Options Dialog Box Read Tab

Use this tab to specify your preferences for reading and checking for new messages.

Mark Message as Read after Previewed for 'XX' Second(s)

Specifies whether a message should be marked as read after you have previewed it for the number of seconds indicated. If 

you clear this check box, messages are not marked as read unless you open the message in a message window, scroll the 

message in the preview pane, or select the message in the list, then click the Edit menu, and then click Mark As Read.

Check for New Messages Every 'XX' Minute(s)

Specifies whether to check your mail server for new messages at the interval of minutes indicated. It also sends any 

messages in the Outbox at the same time. If you clear this check box, you can check for new messages only by clicking the 

Mail menu and then clicking Send And Receive Mail. 

Empty Messages from The 'Deleted Items' Folder on Exit

Specifies whether Internet Mail should permanently delete messages from the Deleted Items folder when you quit Internet 

Mail. If you clear this check box, deleted messages stay in the Deleted Items folder until you open that folder, select the 

messages, and then delete them.



Options Dialog Box Server Tab

Use this tab to specify settings used to connect to your mail server and access your e-mail account. 

Name

Provides a space to specify the friendly name (as opposed to the e-mail name) associated with your e-mail address. When 

you send e-mail, this name appears in the From field of your outgoing messages.

Organization

Provides a space to specify your group or organization.

E-mail Address

Provides a space to specify the e-mail address that people should use when sending mail to you at this account. The e-mail 

address must be in the following format: name@company    for example, PatSmith@acme.com.

Outgoing Mail (SMTP)

Provides a space to specify your SMTP server for outgoing messages.

Incoming Mail (POP3)

Provides a space to specify your POP3 server for incoming messages.

POP3 Account

Provides a space to specify your account name. This is usually the same as the part of your e-mail address to the left of the at 

sign ( @ ).

Password

Provides a space for you to type the password assigned to you by your Internet service provider. For security, the actual 

characters are not displayed in this space; each character is represented by an asterisk ( * ).

Server Port Numbers

Outgoing Mail (SMTP)

Specifies the port number you connect to on your outgoing mail (SMTP) server. This port number is usually 25.

Incoming Mail (POP3) 

Specifies the port number you connect to on your incoming mail (POP3) server. This port number is usually 110.

Use Defaults

Restores the server port numbers to their original settings.

Leave a Copy of Messages on Server

Specifies whether Internet Mail should store on your server a copy of all sent and received messages. If your Internet service 

provider does not allow you to save messages on the server, Internet Mail notifies you.

If you clear this check box, incoming messages are deleted from your server after you receive them on your computer. 

Outgoing messages are not saved on your server, but they are saved on your computer if you have selected that option. To 

specify that all outgoing messages should be saved on your computer, click the Message menu, click Options, click the Send 

tab, and then select the check box labeled Save Copy Of Sent Messages In The 'Sent Items' Folder.



Options Dialog Box Fonts Tab

Use this tab to specify how messages will appear when you are viewing them on your computer. This does not affect how 

outgoing messages will appear when other people receive them.

Default Font

Displays how your text appears on your computer.

Change

Click this to change the font characteristics, such as font, font style, and size. This affects how text is displayed when viewing 

and composing messages, but does not affect how outgoing messages will appear to recipients.



Options Dialog Box Signature Tab

Use this dialog box to specify settings for Auto Signature.

No Signature

Specifies that no signature should be added to your messages.

Text

Specifies that the text you type here should be used as a signature in your outgoing messages.

File

Specifies that you want to insert the contents of a text file as your signature. You can type the path and file name of the file you 

want to use, or you can click Browse and locate the file.

Add Signature to the End of All Outgoing Messages

Specifies whether to add your signature to all outgoing messages. If you clear this check box, an outgoing message does not 

contain your signature unless you specifically add it to an individual message.

Don't Add Signature to Replies and Forwards

Specifies whether to add your signature to all outgoing messages except replies or forwards. This check box is unavailable, 

unless the check box above it has been selected.



Select Recipients Dialog Box

Use this dialog box to select names from your Address Book to send the message to.

Type Name or Select from List

Provides a space for you to type the names of contacts or groups you want to see in the list. If you do not type anything, the 

list displays all names in the Address Book.

Name List

Displays all names and corresponding e-mail names in the Address Book, or those matching the name you type in the Type 

Name Or Select From List box. 

To

Adds the contact selected in the Address Book list to the To box of your outgoing message.

CC

Adds the contact selected in the Address Book list to the CC box of your outgoing message.

New Contact

Click this to add information about a new contact to the Address Book. 

Properties

Click this to edit or view properties for the selected contact.



Inbox Assistant Dialog Box

Use this dialog box to add, remove, or display rules to filter and organize incoming mail messages.

Rules List

Displays the rules you have set up to filter incoming messages.

Move Up

Moves the selected rule up one in the Rules list. The rule is applied to messages before all rules listed below it and after all 

rules listed above it.

Move Down

Moves the selected rule down one in the Rules list. The rule is applied to messages before all rules listed below it and after all 

rules listed above it.

Add

Click this to add a new rule to the Rules list.

Remove

Click this to remove the selected rule from the Rules list.

Properties

Click this to view and edit the rule selected in the Rules list.



Inbox Assistant Properties Dialog Box

Use this dialog box to filter and organize incoming mail messages. You can specify that incoming messages matching your 

criteria be moved to another folder.

You can specify more than one value within a condition by separating each value by a semicolon ( ; ). This creates an "or" 

condition; each message must meet one of the conditions to be included in the search result. 

For example, you can search for messages from one person or another by separating the two names by a semicolon in the From 

box:

Johndoe@anyorg.com;Janedoe@anyorg.com

When a Message Arrives that Meets the Following Criteria

Specifies all of the conditions a message must match in order for the action specified below to be processed on the message. 

If you specify multiple conditions, messages must meet each condition for the corresponding action to occur.

To

Specifies to move messages addressed to the name(s) that you type or enter here. 

Type the name(s), or click the Address Book button to select the name(s) from the Choose Recipient dialog box. To find 

messages addressed to more than one name, separate the names by a semicolon (;).

Cc

Specifies to move messages addressed on the Cc line to the name(s) that you type or enter here. 

Type the name(s), or click the Address Book button to select the name(s) from the Choose Recipient dialog box. To find 

messages addressed to more than one name, separate the names by a semicolon.

From

Specifies to move messages from the name(s) that you type or enter here. 

Type the name(s), or click the Address Book button to select the name(s) from the Choose Recipient dialog box. To find 

messages addressed to more than one name, separate the names by a semicolon.

Subject

Specifies to move messages containing the text that you specify in the message's subject line. Type the complete or partial 

text of the subject that you want to find. To find messages containing more than one subject, separate the subjects by a 

semicolon.

Move To

Moves the message(s) to the specified folder. 




