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File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Build 
SCR/EXE

Build and save the current document as a .SCR or .EXE file.

1, 2, 3, 4 List of your four most recent screen saver documents; click to open.
Exit Exits Screen Saver Studio.



Edit menu commands

The Edit menu offers the following commands:

Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Insert Inserts data from the clipboard into the document.
Edit Segment Edit the contents of the selected segment.
Clear Segment Clear the contents of the selected segment.
Delete 
Segment

Removes the currently selected segment.

Insert Segment Inserts a new segment in front of the selected segment (duplicates the contents of the previous 
segment).



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Preview Preview the current screen saver document.
Show 
Background

Draw the backgrounds behind each segment in the list.

Element Determines which segment element should be displayed in the list.
Resolution View 1, 2, 4, 8, 16, or 32 segments at once.
Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays information about Screen Saver Studio.



New command (File menu)

Use this command to create a new document in Screen Saver Studio.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing document.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

Drives
Select the drive in which Screen Saver Studio stores the file that you want to open. 

Directories
Select the directory in which Screen Saver Studio stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the active document to its current name and directory.    When you save a 
document for the first time, Screen Saver Studio displays the Save As dialog box so you can name your 
document.    If you want to change the name and directory of an existing document before you save it, 
choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    Screen Saver Studio displays the Save As 
dialog box so you can name your document. 

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name
Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    Screen Saver Studio adds the extension you 
specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Build SCR/EXE (File menu)

Use this command to create a screen saver file (and possibly a program to easily install it, too).    For 
more information, see Building New Screen Savers (.SCR files) or Programs (.EXE files).

Shortcuts

Toolbar:
Keys: CTRL+B



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four documents you 
closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your Screen Saver Studio session.    You can also use the Close command on 
the application Control menu.    Screen Saver Studio prompts you to save documents with unsaved 
changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on the clipboard.    
This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if there is no 
data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This command is 
unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Paste Insert command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point. This command is 
unavailable if the clipboard is empty or if there are already 32 segments in the list (32 is the max).

Shortcuts

Toolbar:
Keys: CTRL+A



Edit Segment (Edit menu)

Use this command to edit the currently selected segment.    This command is unavailable if you are at the 
End of List. Whenever you are editing or previewing a segment, all graphics will appear in the rainbow 
palette. See Building New Screen Savers (.SCR files) or Programs (.EXE files) for more information on 
palettes.

Shortcuts

Toolbar:
Keys: ENTER



Clear Segment (Edit menu)

Use this command to clear the current segment of all graphical content.    This command is unavailable if 
you are at the End of List.

Shortcuts

Toolbar:
Keys: SHIFT+ENTER



Delete Segment (Edit menu)

Use this command to delete (remove from the list) the current segment.    This command is unavailable if 
you are at the End of List or if you have only one segment in the list.

Shortcuts

Toolbar:
Keys: DELETE



Insert Segment (Edit menu)

Use this command to insert a new segment.    If it is not the first segment in the list, then the contents of 
the previous segment will be copied to the new segment. This command is unavailable if there are 
already 32 segments in the list (32 is the max).

Shortcuts

Toolbar:
Keys: INSERT



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in Screen Saver Studio, such as File Open.    A check mark appears next to the menu item 
when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in Screen Saver Studio,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    Screen Saver Studio displays the Open dialog box, in which you 
can locate and open the desired file.

Save the active document or template with its current name.    If you have not named the 
document, Screen Saver Studio displays the Save As dialog box.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Places the contents of the clipboard segment over the current segment

Inserts the contents of the clipboard segment before the current segment

Edits the current segment.

Clears the current segment.

Removes the current segment.

Inserts a new segment before the current one

Previews the current screen saver

Creates a screen saver file and possibly a program to that will install it for you.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to 
the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Screen Saver Studio window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you 
depress them, before releasing them.    If after viewing the description of the toolbar button command you 
wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.

NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.



Preview (View menu)

Use this command to see what the screen saver would look like if you built it right now. Whenever you are 
previewing or editing a segment, all graphics will appear in the rainbow palette. See Building New Screen 
Savers (.SCR files) or Programs (.EXE files) for more information on palettes.

Shortcuts

Toolbar:
Keys: CTRL+P



Show Background (View menu)

Determines whether or not each segment's background will be displayed behind whichever 
graphical element you have chosen in the segment list



Element (View menu)

Determines which graphical element (graphics 1-10 or text) will be displayed for each segment in 
the segment list.



Resolution (View menu)

Determines how many segments will be visible in the segment list at any given time.



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using Screen Saver Studio and various types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Screen Saver 
Studio.



Context Help command 

Use the Context Help command to obtain help on some portion of Screen Saver Studio.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark. 
Then click somewhere in the Screen Saver Studio window, such as another Toolbar button.    The Help 
topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title 
bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll bars 
indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to other 
parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave in your 
application. >>



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 
border you want to move. 

2. Press a DIRECTION key to move the border.

3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Screen Saver Studio window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    Screen Saver Studio determines which 
window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    Screen Saver Studio determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

Choose the font you want your text to appear in. If you are sending the final screen saver to 
someone else, and the font you choose here is not installed on their system, Screen Saver Studio will 
choose the best font it can and will substitute it. If the look of the font is important, then try a face name 
like Arial (or any of the others that come with Windows), or use a paint program to create a .BMP file that 
contains the text and use it as a graphic.

Also, if you change the color of the text to black, it will become invisible even if the background of 
the current segment is not black.



Choose Color dialog box

Choose the color you want to be the background.



Find command (Edit menu)

<< Write application-specific help here. >>



Find dialog box

<< Write application-specific help here. >>



Replace command (Edit menu)

<< Write application-specific help here. >>



Replace dialog box

<< Write application-specific help here. >>



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item changes to 
Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should modify a 
document using your application. 

If your application supports multiple document types and you want to have a distinct help topic for each, 
then use the help context i.d. generated by running the MAKEHELP.BAT file produced by AppWizard.    
Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the help 
context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the first 
document type supported by your application.    AppWizard produces an alias in the .HPJ file for your 
application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the AFX_HIDP_xxx 
values from the [ALIAS] section of your .HPJ file, and author a topic for each AFX_HIDP_xxx value.    For 
example, AFX_HIDP_INVALID_FILENAME is the help topic for the Invalid Filename message box. >>



Introduction

Screen Saver Studio is an exciting new utility for Windows that enables computer users--no 
matter what their level of computing expertise--to create professional-looking screen savers for home or 
office. If you can click your mouse you can create a screen saver that your friends, associates, or clients 
will love. To get you started we have provided you with a useful set of graphics (.BMP files) and 
animations (.ANM files). But if you have the artistic ability to create your own graphics, you will have even 
more design options.



Screen Saver Studio Concept

The best way to explain the concept behind Screen Saver Studio, is to compare it to something 
more familiar--like movie-making. Imagine that you want to use Screen Saver Studio to make a movie 
(i.e., a screen saver). As the movie's director you will decide which elements to use in your movie, when 
they will appear on-screen, and how they will interact with each other. Screen Saver Studio program is 
your script--complete with up to 32 acts (or segments) that play out in order on your screen. The graphics 
and animation files are your actors. And the "Build SCR/EXE" command in the File Menu is the "final cut" 
of the finished product. You can then distribute your "movie" by copying it to a diskette or by sending it 
electronically as an e-mail attachment.



Creating a New Screen Saver Studio Document

When you launch Screen Saver Studio, a new screen saver document (Untitled) is automatically 
opened. It is not necessary to select New (Ctrl+N) in the File Menu or to select Open (Ctrl+O). The only 
time you will use the New command is when you create more than one screen saver per session.    You 
will only use the Open command to open previously saved screen saver documents.

A screen saver document is NOT a screen saver. To return to the movie-making analogy used 
above, a screen saver document is the edited together film segments that will serve as the "master", 
which is used to make additional prints or copies of the finished movie.    To create a screen saver from 
your finished screen saver document, you will need to select "Build SCR/EXE" in the File Menu (see 
Building New Screen Savers (.SCR files) or Programs (.EXE files)). But more about that later. To create 
your first screen saver, follow the steps described below.

Easy 15-Step Screen Saver Creation Tutorial

STEP 1 - Highlight Segment #1 if it is not already highlighted. Press Enter or click the Edit Segment Icon 
(the eighth one from the left) to edit or add graphics and/or animations to Segment #1.

STEP 2 - Take a moment to study the Segment #1 dialog box which is now on your screen. You will see: 
Update Rate (in milliseconds) that may be increased or decreased to set the overall speed of the screen 
saver;    Graphics, which allows you to determine the set of graphics and/or animations which appear on 
your screen for the duration of Segment #1; Audio, which allows you to select a sound file (.WAV format) 
that will play during Segment #1; Text, which allows you to enter text for display during Segment #1; 
Duration, which allows you to set the duration of Segment #1 (in seconds, graphic cycles, segment cycles 
or endless loop); Background, which allows you to select a background color or graphic for Segment #1 
of your screen saver; and Clear, which clears any previous settings for Segment #1. The OK button saves 
changes made to the settings in this dialog box. The Cancel button cancels any changes made to the 
settings.

STEP 3 - Select the Background button to select a background for your screen saver.

STEP 4 - The Background dialog box which appears on your screen allows you to select a solid color for 
your screen saver background or a graphic that will be tiled to fit your screen. For the purposes of this 
tutorial, click the radial button beside Tiled Graphic, click the Select button, select a .BMP graphic file to 
serve as your background, then click OK. Note: you may use any of the .BMP graphics which came with 
this program or any of the wallpapers located in your Windows directory. The background you selected 
should now be visible behind the Segment #1 dialog box. If not, repeat steps 3 and 4.

STEP 5 - Select the Graphics button in the Segment #1 dialog box to add moving graphics to your screen 
saver.

STEP 6 - Click on the first <empty> graphic slot in the Graphics for Segment #1 dialog box (or press 
Space Bar) to add a graphic to your screen saver, and select a .BMP graphic to move around on your 
screen. Note: do not select a full screen graphic.

STEP 7 - Now you should define the characteristics of the graphic. This includes: Speed, which 
determines how fast the graphic will move across or around on your screen; Motion, which determines 
how the graphic will act on-screen--stationary, bouncing, move to the left, move to the right, move up or 
move down; and the Number of Graphics that are on-screen at once--from 1 to 50. For the purpose of this 
tutorial, choose a medium speed, a bouncing action, and 5 graphics, then press OK. Note:    The Keep 
Black Transparent check box should remain checked if you were using any of the graphics that came with 
Screen Saver Studio. When using graphics that utilize true black as part of the graphic, this setting may 
not be desirable.



STEP 8 - Fading for Graphic settings determine how your graphic "arrives" on screen--instantaneously, 
random blocks that gradually fill in, etceteras. Explore each of these settings in turn at a later date to find 
out which ones you like best. For now, select a medium speed, an instantaneous fade in, an 
instantaneous fade out, and no transparent fade. Check Keep Old Coordinates (at top of dialog box) to 
insure smooth visual transition and avoid "jumping" graphics as Segment #1 loops indefinitely. Press OK.

STEP 9 -You should now see the results of Steps 1-8. To add text to your creation, select the Text button 
in the Segment #1 dialog box.

STEP 10 - The settings in Text for Segment #1 dialog box allow you to add a text message to your screen 
saver. Type a message in the Design Text field. Click the Font button to choose a font, size, and color. 
Leave Keep Background Transparent checked (default setting). Choose a medium Speed. Set Left for the 
Motion. Choose a medium speed for Fading Effect. Set Fade In and Fade Out as instantaneous. Leave 
Transparent Fade checked (default setting). Check Keep Old Coordinates (at top of dialog box) to insure 
smooth visual transition and avoid "jumping" text as Segment #1 loops indefinitely. Press OK.

STEP 11 - You should now see your text added to the ongoing action. Select the Duration button to set 
how long the segment should last:    a) stop after x seconds, b) stop after x graphic cycles, c) stop after x 
text cycles, and d) repeat indefinitely. Select stop after x seconds and click OK.

STEP 12 - Select the Audio button to add sound effects to your screen saver. Click the Select button and 
choose a sound file (.WAV format) from the files you received with Screen Saver Studio or in your 
Windows directory. Click the Test button to hear the sound you have selected. If your sound file is large 
you may wish to check "allow interruption of sound or stop sound at end of segment". Otherwise, skip 
those choices. There are four possible sound effect Actions--Once, Continuously, Associate With A 
Graphic, or Association With Text. Select Associate With Text and press OK.

STEP 13 - Press OK in the Segment #1 dialog box to end the creation/editing session and return to the 
program's main screen. Select Save in the File Menu to save your screen saver document in an editable 
format. Note: this is not a screen saver, but a document containing your instructions for creation of a 
screen saver.

STEP 14 - To create a Windows-ready screen saver module (.SCR file), select Build SCD/EXE File 
(Ctrl+B) in the File Menu, name your new screen saver, and save it into your Windows directory.

STEP 15 - Exit Screen Saver Studio or press Alt+Tab to access your Windows desktop. You can then 
activate your new screen saver by selecting it the same way you normally select a screen saver. (i.e., 
Windows 3.1 users should double-click the Control Panel then the Desktop icons in the Main Program 
Group; Windows 95 users should right-click on the desktop, select Properties, then select Screen Saver). 
If your new screen saver does not appear in the list of available screen savers, use the Windows Find File 
option to locate the .SCR file you created. Move it into your Windows directory then make it your current 
screen saver as previously described.



Creating New Graphics and Animations

If you have an art program or a scanner, you can create new graphics for Screen Saver Studio. 
You just need to know and keep in mind a few technical details. The first thing to know is that you must 
save the graphics out in BMP format. (Either RGB or RLE encoded if you are presented with a choice of 
BMPs when you save your creation.)

The next thing to consider is the color depth. Though Screen Saver Studio will work with BMPs 
using 16 million (true color) or 65 thousand (high color), it is usually best to use 256 color BMPs. This is 
both because of the intense memory use associated with higher color graphics - you may find that 
running your screen saver continually runs your hard drive as the swap file is accessed - and the fact that 
higher color graphics will look bad when run on lower color machines. The exception to using higher color 
BMPs is when you are designing a photograph slide show that shows non-moving BMPs and you know 
what machine it will be running on.

The third thing to consider when making graphics that will be moved around on the screen is that 
smaller is better. Make them just large enough to get the desired effect across. This is both for memory 
usage as well as the fact that moving full screen BMPs around is inherently slow.

The final thing to remember is to be careful when using true black (color zero). True black can be 
made transparent, so a white disk surrounded by black can be made to look like a disk moving across the 
background. If you put another black disk inside the white disk, it will look like a doughnut because the 
background will show through the hole. If you want a white disk with a black center that stays black, you 
need to make the center disk "not quite black". i.e. RGB values of 0,0,1 or a very deep purple, etc.

Animation files (ANM) are canned routines that you can download from the Softdisk store at: 
www.downloadstore.com



Adding a Background Graphic or Color to a Segment

The background is the mat on which all other actions take place. It can be as simple as a solid 
color, or as pretty as a full screen scanned-in photo in BMP format. Backgrounds always appear 
instantaneously at the beginning of the segment and remain for the entire segment.

After choosing the segment you want to work with, you'll see the Segment dialog. Click the 
Background button to select a background.

To select a solid color for this segment's background, click the radial button beside Solid Color 
and then click the select button. Now click on the color you want for this segment.

To select a .BMP graphic as the segment's background, click the radial button beside Tiled 
Graphic and click the Select button. You may select any of the .BMP graphics which came with this 
program or browse your system to load any other BMP you have. BMPs will be tiled - that is, repeated 
over and over again until the whole screen is filled in.

It is important to remember when working with "full screen" BMPs, that you do not know what 
resolution the end user of your screen saver will be running in. If you have a "full screen" 600x480 BMP 
background and they are in 800x600 resolution, your background will be tiled - which may be undesirable. 
Similarly, if you have an 800x600 BMP and the end user is in 600x480 resolution, they will only see the 
upper left hand corner of the background. (See Adding Graphics to a Segment for further considerations.)



Adding Graphics to a Segment

Graphics are the "actors" in your movie. There can be up to 10 different graphics per segment 
and up to 50 copies of each graphic. Graphics can be static BMPs or they can be special "animations" 
that are contained in a single segment. They can be given different movement commands and can enter 
and exit the screen with a variety of fade effects.

In general, graphics appear at a random location off the screen and then move onto the screen. 
When the screen saver proceeds to the next segment, graphics will again be randomly generated off the 
screen and move onto the screen. If you want the graphics in one segment to continue moving smoothly 
in the next segment without generating new random coordinates, check the Keep Old Coordinates box.

There are 10 slots for graphics in each segment. The slot a graphic is in has some effect on how 
it acts on the screen. Graphics that appear in slot 10 will always be at the lowest depth (just above the 
background) whereas those in slot 1 will always be on top. When two graphics pass over each other, the 
one in the lower numbered slot (towards the top of the list) will be over the higher numbered one. Slot #1 
is also the "key" slot - this is the slot that determines the duration of the segment and is the one a sound 
can be associated with. It is also this graphic that determines the 256 color palette if applicable. (See the 
palette section in Building New Screen Savers (.SCR files) or Programs (.EXE files))

Double-click on a graphic slot in the "Graphics For Segment" dialog box to add or change a 
graphic, then browse to select a .BMP or ANM file for the slot. You will see a reduced version of the BMP 
or ANM that is highlighted as a visual aid.

The Define Graphic settings are in effect for both BMPs and ANMs. The Speed bar determines 
how fast the graphic will move across or around on your screen. The speed number is actually how many 
pixels the graphic moves every time it is updated.

The Motion pull down menu determines how the graphic acts on-screen: stationary- the graphic 
is centered in the middle of the screen. If the graphic is larger than the screen resolution, ALL edges will 
be clipped and you will only see the center portion. bouncing- the graphic will move around the screen 
and when it reaches an edge, it will bound off in the opposite direction. left, right, up or down- the 
graphic will move from off the screen, onto, across, then off the screen in the indicated direction. After it 
exits the screen, it will reappear coming in on the original edge again.

No. of    Graphics sets the number (1 - 50) of this graphic that will be generated. All of these 
graphics will initially be positioned randomly, except for stationary graphics. For unmoving graphics, the 
first one will be centered on the screen. Any others will be placed randomly. For moving graphics, at least 
one will move according to the speed bar. Any others will move at the same speed, or slower.

The Keep Black Transparent check box should be checked if you want "masked" graphics 
instead of rectangular block graphics. When using graphics that utilize true black as part of the graphic, 
this setting may not be desirable.

The Fading for Graphic settings are available only when working with BMPs, not ANMs. These 
controls allow you to determine how your graphic "arrives" on screen--instantaneously, random blocks 
that gradually fill in, etc. Explore each of these settings to find out which works best for the effect you want 
at a particular time. The Effect slide bar changes the rate at which the effect occurs - at the slow end it 
will take a lonnng time for the graphic to fade; at the high end it is almost instantaneous.

The Transparent Fade checkbox here is similar to the Keep Black Transparent box. You normally 
want this on unless you are working with only one graphic on a black background.

The Clear button at the bottom of the Graphics for Segment will clear the currently high-lighted 
graphic to <none>. It will not change the settings in the Define Graphics or Fading for Graphics boxes.

The Default Clear button resets the highlighted graphic slot to exactly what is in that slot in the 



previous segment. It changes ALL settings! This is because you usually want to work with the previous 
segment data, but modify it in a slight way - say by changing the direction of travel from down to left. This 
is an easy way to recover if you change the data in a slot and then decide you want what was there 
originally.



Adding Text to a Segment

Each segment can have one text message associated with it. Text will always appear over all 
graphics - it is the top-most layer. Just like a graphic, you can make the text move and control how it 
enters and exits the screen. In general, the text appears at a random location off the screen and then 
move onto the screen. When the screen saver proceeds to the next segment, text will again be randomly 
generated off the screen and moves onto the screen. If you want the text in one segment to continue 
moving smoothly in the next segment without generating new random coordinates, check the Keep Old 
Coordinates box.

Click in the define text box and then enter your text. As you type, you will remain on the same line 
and the text will scroll to the left. Only press <Enter> if you want two or more distinct lines of text to 
appear.

You can control the Font and color of the text by clicking on the Font... button. This calls up the 
standard font selection dialog that lets you select the font, style, size, effect and color of the text. It is 
important to know that Screen Saver Studio does NOT incorporate the font or a picture of it in the actual 
finished screen saver. This means that if you use a special font and then run the screen saver on a 
system that does not have that font, the text will be displayed using Windows attempt to recreate the font 
- and the results may not be acceptable.

The Keep Background Transparent should be kept checked unless you want a black rectangle 
drawn around your text.

The Speed slide bar sets how fast the text moves around on the screen. The number is the 
actual number of pixels that the text moves each update.

The Motion pull down menu determines how the text acts on screen: bouncing- the text block 
moves around the screen and when it reaches an edge, it bounces off in the opposite direction. left, 
right, up or down- the text will move from off the screen, onto, across, then off the screen in the indicated 
direction. After it exits the screen, it will reappear coming in on the original edge again. stationary- the 
text block is centered in the middle of the screen. If the text block is too large to fit on the screen, the 
edges will be clipped and you will only see the center portion. stationary left, right, up or down- the text is 
placed to the left, right, above or below the key graphic for the segment. (If there is no key graphic, these 
act just like stationary.)

The Fading for Text settings allow you to determine how your text "arrives" on and leaves the 
screen--instantaneously, random blocks that gradually fill in, etc. Explore each of these settings to find out 
which works best for the effect you want at a particular time. The Effect slide bar changes the rate at 
which the effect occurs - at the slow end it will take a lonnng time for the text to fade; at the high end it is 
almost instantaneous.

The Transparent Fade checkbox here is similar to the Keep Background Transparent box. You 
normally want this on unless you are working with text on a black background.

The Clear button at the bottom of the Text for Segment clears only the text in the define text box. 
It will not change any of the other settings.

The Default Clear button resets the Text for Segment of this segment to exactly what is in text 
box of the previous segment. It affects ALL settings! This is because you usually want to work with the 
previous segment data, but modify it in a slight way - say by changing the direction of travel from down to 
left. This is an easy way to recover if you change the data and then decide you want what was there 
originally.



Adding Audio to a Segment

Sounds can make your screen saver come alive! If you have WAV files, you can easily add them 
to your screen saver.

Click on the Select button to browse your system for WAV files. After you select one, you can 
click on the Test button to make sure it's the one you want.

When the Allow Interruption of Sound box is checked, if an old sound is playing when a new 
one is started, the old one will be stopped and the new one played. Otherwise, the old one continues until 
it is finished.

The Stop Sound at End of Segment checkbox, if checked, will make sure that the sound will be 
ended when the current segment ends, even if the duration of the sound is longer than the segment.

The Action pull down menu lets you pick when to play the sound. Once- the sound is played once 
at the beginning of the segment. Continuously- the sound starts at the beginning of the segment and 
continually loops. (So check to hear if your sound loops nicely.) Associate with Graphic- plays the sound 
whenever a "key" graphic exits or bounces off the edge of the screen. Associate with Text- plays the 
sound when the text exits or bounces off the edge of the screen.

The Clear button at the bottom of the Audio for Segment clears selected WAV file to <none>. It 
will not change any of the other settings.

The Default Clear button resets the Audio for Segment of this segment to exactly what is in audio 
box of the previous segment. It affects ALL settings! This is because you usually want to work with the 
previous segment data, but modify it in a slight way - say by changing the sound from a bing to a boop. 
This is an easy way to recover if you change the data and then decide you want what was there originally.



Setting the Duration of a Segment

As you create segments, an important consideration becomes setting how long each segment 
lasts. This is an art more than a science because of the vagaries of different systems. You can set the 
length of the segment, excluding the fading effects in one of 4 different ways:

Stop after x seconds. After ALL graphics and text have fully faded onto the screen, wait this 
many seconds then begin fading out all graphics and text. When the last one disappears, the segment 
ends.

Stop after x graphic cycles. After ALL graphics and text have fully faded onto the screen, wait 
until a "key" graphic has exited or bounced off the screen this many times, then begin fading out all the 
graphics and text. When the last one disappears, the segment ends.

Stop after x text cycles. After ALL graphics and text have fully faded onto the screen, wait until 
the text block has exited or bounced off the screen this many times, then begin fading out all the graphics 
and text. When the last one disappears, the segment ends.

Repeat This Faded In Frame Forever. After ALL graphics and text have fully faded onto the 
screen, just keep doing what they're doing. They never fade out (even if set to do so) and the segment 
never ends.

NOTE! It is entirely possible to set conditions for various text and graphic elements which keep 
any segment from ever ending even when it should! If your segment is supposed to end but never 
proceeds when previewing it, you need to check to see if you have stationary text and the stop after x text 
cycles checked, for example.

The Default Clear button resets the Duration for Segment of this segment to exactly what is in the 
duration settings of the previous segment. If affects ALL settings!



Adding Segments to a Screen Saver Document
You can create complex and interesting screen savers with Screen Saver Studio by creating up to 

32 different segments that "play" in segment order (1-32) on your screen. To insert or add a segment to 
your screen saver document, return to the main program interface (if necessary) and click on the segment 
that will follow or come after the new segment you want to insert. If you want the new segment to be last, 
click on End Of List before inserting.

To create a new segment, press Insert on your keyboard or click the Insert New Segment Icon in 
the Toolbar (the eleventh icon from the left). NOTE:    each time you insert or add a new segment with this 
icon or with the Insert key, the new segment is automatically filled with the contents of the previous 
segment.

If you want to insert a new segment that is a duplicate of some other segment in your document, 
simply select that segment and copy it to the clipboard by pressing Ctrl+C or clicking the copy icon in the 
Toolbar (the fifth icon from the left). Select the segment that will follow the segment you wish to insert, 
then click the Insert New Segment And Paste Icon in the Toolbar (the seventh one from the left) or select 
Paste Insert from the Edit Menu.

See also Inserting Segments.



Editing Segments

To edit a previously created segment, simply double-click on that segment from the main menu 
(or select it and press Enter). The Segment dialog box which appears on your screen will allow you to 
Clear the contents of the segment and start over or edit any of these parts of the segment--Graphics, 
Audio, Text, Duration, and Background.

Here is also where you set the Update rate. This is how often the system attempts to redraw 
every object on your screen. The default of 200 milliseconds means that every 2 tenths of a second, the 
screen saver will erase then move and redraw ALL of your graphics.

Whenever you are editing or previewing a segment, all graphics will appear in the rainbow 
palette. See Building New Screen Savers (.SCR files) or Programs (.EXE files) for more information on 
palettes.



Deleting Graphics in Segments

To delete the graphics in a segment (including the background), double-click on that segment 
from the main menu (or select it and press Enter). The Segment dialog box which appears on your screen 
will allow you to Clear the contents of the segment and start over, or to edit the segment.



Deleting Segments

To delete a segment, simply click on that segment from the main menu and press Delete or click 
the Delete Segment Icon in the Toolbar (the tenth icon from the left).



Inserting Segments

You can create complex and interesting screen savers with Screen Saver Studio by creating up to 
32 different segments that "play" in segment order (1-32) on your screen. To insert or add a segment to 
your screen saver document, return to the main program interface (if necessary) and click on the segment 
that will follow or come after the new segment you want to insert. If you want the new segment to be last, 
click on End Of List before inserting.

To create a new segment, press Insert on your keyboard or click the Insert New Segment Icon in 
the Toolbar (the eleventh icon from the left). NOTE:    each time you insert or add a new segment with this 
icon or with the Insert key, the new segment is automatically filled with the contents of the previous 
segment.

If you want to insert a new segment that is a duplicate of some other segment in your document, 
simply select that segment and copy it to the clipboard by pressing Ctrl+C or clicking the copy icon in the 
Toolbar (the fifth icon from the left). Select the segment that will follow the segment you wish to insert, 
then click the Insert New Segment And Paste Icon in the Toolbar (the seventh one from the left) or select 
Paste Insert from the Edit Menu.

If your segment will continuously "loop" (repeat) or transition into the next segment, check Keep 
Old Coordinates in the Graphics and/or Text dialog boxes to insure smooth visual transition and avoid 
"jumping" or disappearing graphics. As a segment ends, Screen Saver Studio remembers the final X-Y 
coordinates for each graphic or piece of text and applies them to the beginning of the next segment. 
When properly formatted, the resulting screen saver will be a seamless merging of up to 32 different 
segments.



Saving Screen Saver Documents

Once you have completed your screen saver document and are satisfied with the Preview (Alt 
V+P), choose Save (Ctrl+S) in the File Menu to save the document. Though it is possible to build a 
screen saver module or program without saving the current document, we recommend saving every 
document in case you want to change it or duplicate the effects you have achieved with different graphics. 
Use the Save As command in the File Menu when you want to create a copy of an open screen saver 
document.



Building New Screen Savers

After you have completed and saved your screen saver document to disk, you are ready to build 
a Windows-ready screen saver module (.SCR file) or a runnable program (.EXE file). Select Build 
SCR/EXE File in the File Menu (Ctrl+B).

Enter the Selection name which will be seen when you are selecting the Screen Saver from the 
control panel. This name is not limited to 8 characters since it is NOT the file name. In the description box, 
enter any information you want to appear when the user selects the Settings button for the screen saver.

The radio button for the 256 color palette determines whether your final screen saver uses a 
single, predefined "rainbow" palette that makes a good approximation for most graphics, or a dynamic 
palette generated from the key graphic for each segment. The disadvantage of the latter is that you may 
see a "palette flicker" as the screen saver moves from one segment to another. (You can get rid of 
"palette flicker" by making sure each segment ends up faded completely to black.) If you are using high or 
true color images (.BMPs that have more that 256 colors) and you know that your screen saver will be 
running on systems in 256 color mode, you may want to select the rainbow palette. Most high 
color .BMPs do not have palettes of their own, so the rainbow palette provides more colors to match to. 
Remember, this palette selection only has meaning when you are in 256 color video mode when the 
screen saver kicks in. For all other video setups, this setting is simply ignored.

After you click OK, you are presented with a standard Save As... dialog. Name the SCR file, 
choose the directory where you want to save it (usually Windows if you want to use it as a screen saver) 
then click OK.

After the SCR is saved, you are asked if you want to make an EXE of the screen saver. Do this if 
you want to give your screen saver away to friends. It makes an EXE file that not only installs the SCR file 
into the Windows directory, but also makes it the default screen saver! If you make an EXE, you get the 
chance to save it wherever and under whatever name you want.

Exit Screen Saver Studio or press Alt+Tab to access your Windows desktop. You can then 
activate your new screen saver by selecting it the same way you normally select a screen saver. (i.e., 
Windows 3.1 users should double-click the Control Panel then Desktop icons in the Main Program Group; 
Windows 95 users should right-click on the desktop, select Properties, then select Screen Saver). If your 
new screen saver does not appear in the list of available screen savers, use the Windows Find File option 
to locate the .SCR file you created. Move it into your Windows directory then make it your current screen 
saver as previously described.



Opening Previously Saved or Recently Saved Documents

Save your current screen saver document (if necessary), then press Ctrl+O or choose Open in 
the File Menu. Locate the previously saved screen saver document you wish to open and press OK. 
Alternatively, if the document you wish to open is a recently saved or edited file, it may be listed in the File 
Menu just above the Exit command. Screen Saver Studio will always retain the names of the last four 
documents opened or saved in that section of the File Menu.



Viewing the Background of a Segment

From Screen Saver Studio main screen, it is possible to view your segments without a 
background. Simply select Show Background in the View Menu to "uncheck" or turn off that option. Select 
Show Background again to "check" or turn on that option. Though you may not use this feature very often, 
it can reduce the display time for large screen saver documents and it will make a selected segment 
easier to spot.



Viewing the Graphics in a Segment

There are two ways to view any of the graphic "slots" in a segment without editing the segment. 
1) Click on a "graphic #" or the "text" tab to the left of the main screen - the views of each segment now 
show the graphic associated with that "slot", 2) Or select Element in the View Menu. If there is no graphic 
associated with a slot, you will see the background instead (unless background is checked off.)



Viewing a Preview of the Current Screen Saver

To preview the screen saver scripted by your current screen saver document, select Preview in 
the View Menu (Alt V+P) or click the Preview Icon in the Toolbar (the twelfth one from the left). Press 
Alt+F4 or click Close in the title bar's close box to end the Preview and return to your screen saver 
document.

Whenever you are previewing or editing a segment, all graphics will appear in the rainbow 
palette. See Building New Screen Savers (.SCR files) or Programs (.EXE files) for more information on 
palettes.



Viewing the Segments in a Document

When you create a new screen saver document, the main screen enables you to view four 
segments per screen. You can change this default to 1, 2, 8, 16, or 32 segments. If your screen savers 
are usually only one segment, you will be able to see more of it by viewing only one segment. Conversely, 
you will want to view more segments to keep scrolling to a minimum if working with large multi-segment 
screen saver documents.

In the lower left hand corner of the main screen is a little ruler that not only tells you how many 
segments are being displayed but also lets you click on a vertical line to change the number of segments 
you are viewing.



Distributing

Your purchase of Screen Saver Studio grants you the right to freely distribute the files you create 
to friends, family members, business colleagues, clients, and customers as long as there is no charge. If 
you wish to sell your screen savers, you must obtain a licensed version of Screen Saver Studio. Visit 
www.downloadstore.com or call 1-800-831-2694 for more information.




