
Welcome to Microsoft Internet Explorer

The Internet is a collection of computer networks that connects millions of computers around the world, including the one on your 

desktop. It is also a vast source of information that is constantly changing and expanding. Since its creation in the 1960s, the 

Internet has grown exponentially and is now used by millions of people, from those in commercial and educational institutions to 

individual consumers.

Once you are connected to the Internet, you can use Internet Explorer to view a huge variety of information. You can also 

incorporate this information into your documents or save it to a file on your computer.
Begin exploring the Internet by clicking an item in the Internet Explorer main window.



What’s new in Microsoft Internet Explorer?

    For Web browsers
    For Web authors
    For Web site administrators



For Web browsers

For more convenient Web browsing, you can now download files from the Internet in a separate window while you 
continue browsing other Web pages.

The new resizable toolbar provides you with Links, which give you fast and easy access to great Internet pages with 
content that is updated regularly.

With the industry-standard Internet ratings support, parents can filter out Web sites that could be inappropriate for their 
children.

Internet Explorer also provides support for ActiveX documents. This means that you can view documents such as 
Microsoft Office files right in Internet Explorer, without starting another program, such as Microsoft Word.



For Web authors

Internet Explorer provides support for all of the latest HTML authoring features, including some features that are unique to 
Internet Explorer, such as borderless frames, floating frames, and HTML style sheets.

Internet Explorer also provides support for ActiveX controls, which enable you to add custom capabilities, such as sound, 
animations, and 3-D graphics.

For even more exciting Web pages, you can now use Visual Basic Scripting Edition and JScript to create sophisticated 
pages with information that is active rather than static.



For Web site administrators

SSL 2.0, SSL 3.0, and PCT security provide ultra-secure transactions over the Internet. For example, this new feature of 
Internet Explorer enables you to make secure credit-card purchases from a catalog on a Web page.



To view a page on the Internet

Click any hyperlink on your start page. A hyperlink can be a picture, a 3-D image, or colored text (usually underlined).

If you want to go to the next page, click the        button on the toolbar.
If you want to return to the previous page, click the        button on the toolbar.

Tip
You can see whether an item on a page is a hyperlink by moving the mouse pointer over the item. If the pointer changes 

to a hand, the item is a hyperlink.



Tips for viewing and organizing pages

You can speed up the time it takes to display a page by not displaying pictures, sounds, or video. 
You can cancel a page that is taking too long to display by clicking the 

    button on the toolbar.
Internet Explorer keeps track of the last five pages you viewed. They are added to the Go menu so that you can easily 

return to them.
If you plan to view a page often, you might want to add it to your collection of favorite pages, or create a shortcut to it on 

your desktop.
You can save the current page to a file on your computer by clicking the File menu and then clicking Save As File.

For step-by-step procedures, click Related Topics below.

{button ,AL("a_display_fast;a_save_page;a_view_history;a_collect_favorites;a_create_shortcut")} Related Topics



To go to a specific place or page 

In the Address box, type the address of the page you want to open, or click the down arrow to select it from the list, and 
then press ENTER.

Tips
To display the page in a new window, click the File menu, and then click New Window before typing the address.
You can also go to a specific page by clicking the File menu, clicking Open, and then typing the address in the text box.



To return to a page you've already seen

On the Go menu, click the page in the list that you want to go to.

Notes
This list is emptied when you quit Microsoft Internet Explorer.
For a complete list of all the pages you've viewed in all sessions, click the Go menu, and then click Open History Folder. 

Then double-click the page you want to open.

{button ,AL("a_set_history;a_move_pages")} Related Topics



To return to the start page

Click the 
    button on the toolbar.

Tip
If you can't see the toolbar, click the View menu, and then click Toolbar.

{button ,AL("a_homepage_change;a_view_pages;a_goto_page ")} Related Topics



To change your start page

1 Go to the page you want to appear when you first start Microsoft Internet Explorer.

2 On the View menu, click Options.

3 Click the Navigation tab, and then click Use Current.

Tips
If you are familiar with authoring Web pages, try creating your own start page, with hyperlinks to your favorite Web sites.
To restore your original start page, click Use Default.

{button ,AL("a_return_home;a_searchpage_change")} Related Topics



To go to the search page

Click the 
    button on the toolbar.

Tip
If you can't see the toolbar, click the View menu, and then click Toolbar.

{button ,AL("a_searchpage_change;a_view_pages;a_goto_page")} Related Topics



To change your search page

1 Go to the page you want to use as your search page.

2 On the View menu, click Options.

3 On the Navigation tab, select Search Page from the Page list.

4 Click Use Current.

Tip
To use your original search page, click Use Default.

{button ,AL("a_return_search;a_homepage_change")} Related Topics



To create a collection of favorite pages

1 Go to the page you want to add to your collection of favorite pages.

2 On the Favorites menu, click Add To Favorites.

3 Type a new name for the page if you want to.

Tips
To store your page in a different folder, click the Create In button in the Add To Favorites dialog box.
To open one of your favorite pages, click the 

    button on the toolbar, and then click the page you want to open.
To keep track of your favorite pages, you can organize them into folders.

{button ,AL("a_view_pages;a_goto_page;a_move_pages")} Related Topics



To organize your favorite pages into folders

1 On the Favorites menu, click Organize Favorites.

2 To create a new folder in which to store shortcuts to your pages, click    , type a name for the folder, and then press ENTER.
3 Drag the shortcuts in the list to the appropriate folders.

Tips
You might want to organize your pages by topic. For example, you could create a folder named Art Pages for storing 

information about art exhibits and reviews and a folder named Flying for storing information about aviation.
If the number of shortcuts or folders makes dragging impractical, you can use the Move button instead.

{button ,AL("a_move_files;a_fcab_create_folder")} Related Topics



To create a shortcut to a page on your desktop

1 Go to the page you want to create a shortcut to.

2 On the File menu, click Create Shortcut.

Tip
If the Internet Explorer window is not maximized, you can create a shortcut by dragging a hyperlink from the Internet 

Explorer window to the location you want, such as your desktop.

{button ,AL("a_view_pages;a_goto_page")} Related Topics



To save the current page on your computer

1 On the File menu, click Save As File.

2 Double-click the folder you want to save the page in.

3 In the File Name box, type a name for the page, and then click Save.

Note
Internet Explorer saves only the text on a page, not the graphics.

{button ,AL("a_saveas_item")} Related Topics



To save a page or picture without opening it

1 Right-click the hyperlink for the item you want.

2 Click Save Target As.

3 In the File Name box, type a name for the item, and then click Save.

Notes
Internet Explorer saves a copy of the page or picture rather than a shortcut to it.
You can use this method to download a copy of an item without opening it.
To save a copy of the hyperlink instead, just drag the hyperlink to the location you want, such as your desktop. A shortcut 

to the Web page will appear.

{button ,AL("a_save_page;a_create_shortcut")} Related Topics



To search for text on a page

1 On the Edit menu, click Find (On This Page).

2 Type the text you want to find.

3 Change any settings as needed.

4 Click Find Next.

{button ,AL("search_internet")} Related Topics



To copy information from a page into a document

1 Select the information you want to copy.

To copy the contents of an entire page, click the Edit menu, and then click Select All.

2 On the Edit menu, click Copy.

3 Open the document where you want the information to appear, and then click the location where you want to place it.

4 On the Edit menu in that document, click Paste.

Tip
You cannot copy information from one Web page into another.

{button ,AL("a_view_pages")} Related Topics



To change how a page is displayed

1 On the View menu, click Options.

2 On the General tab, change the settings as needed.

Notes
For Help on an item, click 

    at the top of the dialog box, and then click the item.
Some pages use predetermined colors and fonts instead of the ones you specify. 



To display text larger or smaller

1 On the View menu, point to Fonts.

2 Click the font size you want.

Notes
You can also change your font size by clicking the 

    button on the toolbar. 
Some pages use predetermined font sizes instead of the size you specify.

{button ,AL("a_changefonts_propfixed;a_change_appearance")} Related Topics



To display previously viewed pages faster

1 On the View menu, click Options.

2 Click the Advanced tab, and then click Settings.

3 To create more space to store pages temporarily, move the slider to the right.

4 To prevent Internet Explorer from updating pages in the Temporary Internet Files folder, click Never.

Tips
You can delete the pages stored in the Temporary Internet Files folder by clicking Empty Folder. However, pages will take 

longer to display because they are opened from the Internet instead of from your hard disk.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("a_display_fast")} Related Topics



To display pages faster

1 On the View menu, click Options.

2 On the General tab, clear one or more of the Show Pictures, Play Sounds, or Play Videos check boxes.

Tips
If the Show Pictures or Play Videos box is cleared, you can still display an individual picture or animation by right-clicking 

the icon in the Web page that represents that picture or animation and then clicking Show Picture.
If the pictures on the current page are still visible after you clear the Show Pictures check box, you can hide them by 

clicking the View menu and then clicking Refresh.

{button ,AL("a_disk_cache")} Related Topics



To start a program when you open a particular type of file

1 On the View menu, click Options.

2 Click the Programs tab, and then click File Types.

3 If you want to open a new type of file that Internet Explorer doesn't yet recognize, click New Type.

If you want to change the program that starts when you open a certain type of file, click the type, and then click Edit.

4 Type a description for the file type, and then specify its content type and extension.

5 To define a new action for this file type, click New. 

To modify an action for an existing file type, click the command that you want to modify, and then click Edit.

6 Specify the action that you want to define, such as Open or Print, and the program that should complete this action.

Tip
For Help on an item, click 

    at the top of the dialog box, and then click the item.



To view the source file for the current page

Click the View menu, and then click Source.

Tips
If you create your own Web pages, this is a good way to see how other Web pages are constructed.
You can edit the page by saving it to your computer and then making the changes you want. After you edit the page, you 

can open it in Internet Explorer to view your changes.

{button ,AL("a_save_page")} Related Topics



To use a graphic image as desktop wallpaper

1 Go to the page that contains the image you want to use.

2 Right-click the image, and then click Set As Wallpaper.



To configure your computer for Internet access by using a proxy server

1 Obtain the proxy system address from your network administrator.

2 On the View menu, click Options.

3 Click the Connection tab.

4 In the Proxy Server area, select the Connect Through A Proxy Server check box.

5 Click Settings, and then type the appropriate proxy system address or addresses supplied by your system administrator.

Notes
Microsoft Internet Explorer works only with proxy servers that are compliant with the CERN proxy server standard.
If you are using Windows 95 and your computer is not yet configured to connect to the local area network (LAN), run the 

Internet Connection wizard. To do this, click the Start button, point to Programs, point to Accessories, point to Internet Tools, and 
then click Get On The Internet.

For Help on an item, click 
    at the top of the dialog box, and then click the item.



Overview: Security on the Internet

The Internet works by sending information from computer to computer until the information reaches its destination. When data is 

sent from point A to point B, every computer in between has an opportunity to look at what's being sent. This can pose a security 

problem.

For example, you are viewing a clothing catalog on the World Wide Web and you decide to buy a shirt. This requires that you 

type information into an order form, including your credit-card number. You know the clothing company in question is reputable, 

so you type your credit-card number and other information, and then send the completed form. Your information passes from 

computer to computer on its way to the clothing company. Unfortunately, one of the computers in between has been infiltrated by 

criminals who watch the data passing through that computer until they see something interesting, such as your credit-card 

number.

How often does something like this happen? It's hard to say, but the important thing is that it's technically possible. And, as the 

Internet grows, it could happen more and more.

How does Microsoft Internet Explorer help protect you and your data?

Many Internet sites are equipped to prevent unauthorized people from seeing the data sent to or from those sites. These are 

called "secure" sites. Because Internet Explorer supports the security protocols used by secure sites, you can send information 

to a secure site with safety and confidence. (When you are viewing a page from a secure site, Internet Explorer displays a "lock" 

icon on the status bar.)

Internet Explorer can also notify you when you are about to do something that might pose a security risk. For example, if you are 

about to send your credit-card number to a nonsecure site, Internet Explorer can warn you that the site is not secure. If the site 

claims to be secure but its security credentials are suspect, Internet Explorer can warn you that the site might have been 

tampered with or might be misrepresenting itself. To specify when Internet Explorer should warn you, click the View menu, click 

Options, and then click the Security tab.

{button ,AL("privacy;certs;active;certover")} Related Topics



Overview: Security certificates

There are two different types of certificates, personal and Web site.

A personal certificate is used when you send personal information to a client authentication server that requires a certificate. For 

example, a personal certificate would contain information such as your username and password.

A Web site certificate is used when a secure Web site sends Internet Explorer a certificate that provides certain information about 

security for that Web site. A certificate is issued to a particular organization for a specific period of time. When you try to open 

that organization’s Web site, Internet Explorer verifies the Internet address stored in the certificate and that the current date 

precedes the expiration date. If not, Internet Explorer can display a warning. For example, a Web site certificate would contain 

information verifying that the site is secure and genuine. This ensures that no other Web site can assume the identity of the 

original secure site.

{button ,AL("certs")} Related Topics



To set levels for Internet privacy

1 On the View menu, click Options.

2 Click the Security tab.

3 In the Privacy area, click the options you want.

Tip
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("secover;certs;active")} Related Topics



To view security certificates

1 On the View menu, click Options.

2 Click the Security tab.

3 In the Certificates area, click the Personal, Sites, and Publishers buttons to set the options you want.

Tips
When you select these options, Internet Explorer will use personal and Web site security certificates you have installed on 

this computer before you send and receive information between secured Web sites.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("privacy;secover;active;certover")} Related Topics



To view multimedia and other active content

1 On the View menu, click Options.

2 Click the Security tab.

3 In the Active Content area, select the check boxes you want.

Tips
When you select these options, Internet Explorer automatically displays items that show active content (for example, a 

vertical marquee or an animation).
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("privacy;certs;secover")} Related Topics



An Internet site address typically starts with a protocol name followed by the organization that maintains the site; the suffix 

identifies the kind of organization. For example, "http://www.yale.edu/" identifies the Web server at Yale University. "http://www" 

indicates that it is a Web server that uses the http protocol, and ".edu" identifies Yale as an educational institution. Generally, 

commercial site addresses end with .com and government site addresses end with .gov. 

If the address points to a specific page, additional information—such as a port name, the directory in which the page is located, 

and the name of the page file—is included. Web pages authored by using HTML (Hypertext Markup Language) often end with an 

.htm or .html extension. 



The content type specifies the MIME (multipurpose Internet mail extension) type for the file.

The MIME type enables an Internet browser, such as Microsoft Internet Explorer, or an Internet mail viewer, such as Microsoft 

Internet Mail and News, to associate a MIME type with a file type, specifying which program should run when a file of a specific 

type is opened over the Internet. 



Many sites on the Internet are now equipped to communicate in such a way that no one can see what you are sending and 

receiving. These are called "secure" sites. When you are viewing pages from a secure site, Internet Explorer displays a "lock" 

icon on the status bar. Internet Explorer can also notify you when you are about to do something that might pose a security risk.



A search page provides an organized way to find and go to other Internet sites. Many search pages provide searching 

capabilities, such as the ability to search by topic or by keyword. Others might provide a well-organized list of hyperlinks to 

selected Internet sites. You can quickly go to the search page by clicking the Search button on the toolbar.



This is the first page that opens when you start Internet Explorer.

A start page can be a page on the Internet or a page on your computer. You can change your start page at any time.



To use the Links toolbar

Click the word Links on the toolbar, and then click one of the links.

Tips
The Links section of the toolbar opens specific Web pages on the Internet where information is updated regularly.
To enlarge or reduce the Links section of the toolbar, click the word Links.



To change the appearance of the toolbar

You can move the Address or Links section of the toolbar by dragging it up, down, left, or right.
To make more room on your screen, you can hide toolbar button labels. To do this, drag the thick bar at the bottom edge 

of the toolbar upward until the button labels are hidden.



To send a shortcut in e-mail

1 On the File menu, point to Send To.

2 Click the destination you want.

Note
To include this shortcut in an e-mail message, you must have an e-mail program installed.

{button ,AL("a_create_shortcut")} Related Topics



To search the Internet

Click the 
    button on the toolbar.

The search programs that are available vary depending on your Internet service provider.

Tip
You can change your search page at any time.

{button ,AL("a_searchpage_change")} Related Topics



The Temporary Internet Files folder is the place on your hard disk where pages are stored as you view them.



Keyboard shortcuts

Viewing documents

To do this Press this

Go to next page SHIFT+BACKSPACE

Go to previous page BACKSPACE

Display a shortcut menu for a hyperlink SHIFT+F10

Move between frames SHIFT+CTRL+TAB

Scroll toward the beginning of a document UP ARROW

Scroll toward the end of a document DOWN ARROW

Scroll toward the beginning of a document in 

larger increments

PAGE UP

Scroll toward the end of a document in larger 

increments

PAGE DOWN

Move to the beginning of a document HOME

Move to the end of a document END

Working with Internet Explorer

To do this Press this

Refresh the current page F5

Stop downloading a page ESC

Go to a new location CTRL+O

Open a new window CTRL+N

Save the current page CTRL+S

Print the current page or active frame CTRL+P

Activate a selected hyperlink ENTER

Using Accessibility features in Internet Explorer

In addition to Microsoft Windows, Windows NT, and Windows 95 accessibility products and services, the following features make 

Internet Explorer more accessible for people with disabilities.

Keyboard access    All features in Internet Explorer are accessible to you by using the keyboard or the mouse. Internet Explorer 

supports Dvorak keyboard layouts, which make the most frequently typed characters more accessible.

For more information about keyboard access, look for Keyboard Shortcuts in the Help Contents.

Navigating the document    With Internet Explorer 3.0, you can explore the Web from the keyboard by pressing TAB and 

SHIFT+TAB to navigate forward and backward between screen elements such as:
Hyperlinks that are text or images
Hotspots on image maps
The address bar
Frames

Highlighting box    As you move to or click a hyperlink or image, a one-pixel border appears around it so you can see what is 

selected.

Adjustable font sizes    You can customize the size of fonts displayed on your computer’s screen.

High-contrast users    Internet Explorer not only responds to your high-contrast settings, but also allows for further 

customization.



A proxy server acts as a security barrier between your internal network and the Internet, keeping other people on the Internet 

from gaining access to confidential information on your internal network.



To display text in a different font

1 On the View menu, click Options.

2 On the General tab, click the fonts you want in the Proportional Font and Fixed-Width Font boxes.

Tips
Some pages use predetermined colors and fonts instead of the ones you specify.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("a_changefonts;a_change_appearance")} Related Topics



To change the number of pages in the History list

1 On the View menu, click Options.

2 Click the Navigation tab.

3 In the History area, change the number of days that Internet Explorer keeps track of your pages.

Tip
For Help on an item, click 

    at the top of the dialog box, and then click the item.



To use the IntelliMouse pointing device

In Internet Explorer you can use IntelliMouse to perform these functions:
Hyperlink jumps. You can jump to any hyperlink by pointing to it, and then "datazooming" forward. To return to the 

previous topic, datazoom back. To datazoom, you press and hold down SHIFT while rotating the wheel button.
Scrolling. You can scroll through a Web page by rotating the wheel button forward or back.
Panning. You can continuously scroll through the current Web page by holding down the wheel button while moving the 

mouse.

Tip
For more information about IntelliPoint software and IntelliMouse, see your IntelliMouse documentation.



Help is available for each setting in this box. Click        at the top of the dialog box, and then click the setting or button you want 

information about.



Specifies whether graphical images should be included when pages are displayed.

Pages that contain several graphical images sometimes display very slowly. If you want to display pages more quickly, make 

sure this check box is cleared.

When this check box is cleared, you can still display an individual image by right-clicking the icon that represents the graphic and 

then clicking Show Picture.



Specifies whether music and other sounds can play when pages are displayed.

Pages that contain audio clips sometimes display very slowly. If you want to display pages more quickly, make sure this check 

box is cleared.

If a RealAudio is installed, or if an AVI is playing, sound may not be disabled.



Specifies whether video clips and other animations can play when pages are displayed.

Pages that contain video clips or other animations sometimes display very slowly. If you want to display pages more quickly, 

make sure this check box is cleared.

When this check box is cleared, you can still play an individual animation by right-clicking the icon that represents the animation 

and then clicking Show Picture.



Click this to use the colors you select to display text and the background of a page.

If this check box is cleared, Internet Explorer uses the current color settings specified in Windows Display properties.



Specifies the color you want to use to display text and background of a page.

To select a color, click the box, and then click the color you want.



Specifies the color you want to use for visited and nonvisited hyperlinks.

Try using a combination of colors and underlining to make hyperlinks easy to find.



Specifies whether all hyperlinks on a page should have underlines.



Specifies whether to display the standard toolbar.



Specifies whether to display a toolbar that contains your favorite Web sites.



Specifies whether to display a toolbar that shows the Web site address. For example, http://www.microsoft.com/.



Specifies whether to display background graphics for all toolbars.



Specifies whether to display the names of the buttons in each toolbar.



Specifies the name of the font you want to use when displaying proportionally spaced text on a page.

Most pages contain text that uses this font.



Specifies the name of the fixed-width font you want to use.

Some pages contain text that must be displayed in a nonproportional (fixed-width) font.



Click this to change your font settings and language defaults.



Specifies the default language. In the list, click the language you want to use.



Lists the installed character sets on your computer. After you select a character set, you can change the font.



Specifies the name of the font you want to use when displaying proportionally spaced text on a page.

Most pages contain text that uses this font. To change the font, select one from the list.



Specifies the name of the fixed-width font you want to use.

Some pages contain text that must be displayed in a nonproportional (fixed-width) font. To change the font, select one from the 

list.



Specifies that you can select your default MIME (Multipurpose Internet Mail Extensions) type character set for the selected 

default font. In the list, click the character set you want to use.



Specifies whether you connect to the Internet by using the Dial-Up Networking connection you specify.

When this check box is selected, a prompt appears if you try to view something on the Internet but have not yet established a 

connection. You can then connect to the Internet immediately from the prompt.

If you have direct access to the Internet through a local area network (LAN), you can clear this check box.

Note    This option is unavailable unless you have Dial-Up Networking installed.



Lists the Dial-Up Networking connections that you have set up. Click the connection you want to use to connect to the Internet.

If you don’t have any connections set up, the Make New Connection wizard appears.



Click this to change phone number, modem, and other advanced settings (such as TCP/IP protocol information) for the selected 

Dial-Up Networking connection.



Click this to create a new Dial-Up Networking connection by using the Make New Connection wizard.



Specifies whether to disconnect from the Internet if you have not actively used your computer for the specified time. You can type 

a number or click the arrows to choose the number of minutes.

Use this option to save money on Internet connection fees (if your service provider charges an hourly rate).

If this check box is clear, you must disconnect from the Internet manually by clicking the Disconnect button in the Connected To 

window.



Specifies whether you want Internet Explorer to perform a security check of your password information before you dial.



Specifies whether you want to connect to the Internet through a proxy server on your local area network (LAN).

A proxy server acts as a security barrier between your internal network and the Internet, keeping other people on the Internet 

from gaining access to confidential information on your internal network.



Click this to specify your proxy server settings.



Provides a space for you to type the address and port number of the proxy server you want to use to access the Internet over 

HTTP, Secure, FTP, Gopher, and Socks protocols.

Use this option only if you are connecting to the Internet through a proxy server on your local area network (LAN). For more 

information, contact your network administrator.



Specifies whether you want to use the same proxy server to access the Internet over all protocols.

If there is only one proxy server that you use, make sure this check box is selected.



Provides a space for you to type the protocols that should not be used over your proxy server.

If you have a computer on your Intranet    that you want to connect to, make sure that you type its address in this box. For 

example, if a computer is named Joe1, type this into the box.

You can use wild cards to match domain and host names or addresses—for example, www.*.com; 128.*.240.*; *.mygroup.*; *x*, 

etc.



Specifies whether you do want to use the proxy server for all local (intranet) addresses.



Displays the page you are currently viewing as the start page, search page, or a page on the Links section of the toolbar.

The start page is the page you see each time you start Internet Explorer. You can return to the start page at any time by clicking 

the          button on the toolbar.
The search page is the page you see when you click the          button on the toolbar.
You can also specify that a hyperlink on the Links section of the toolbar points to one of your favorite Web pages.



Displays the name of the selected page.



Displays the Internet address for the page. You can change the address for a page by typing it in the box.



Sets the current item as the start page, search page, or page on the Links section of the toolbar.



Returns to your default setting for the default start page, search page, or page on the Links section of the toolbar.



Specifies the number of days that Internet Explorer should keep track of your viewed pages in the History list.

Internet Explorer keeps track of pages you view in this and previous sessions. If you are low on disk space, you might want to 

decrease this number.



Displays your History list folder, which holds the shortcuts to the most recently viewed pages.



Empties the folder for the History list. This folder stores shortcuts to the pages you viewed during this and previous sessions.



Specifies the Internet e-mail program you want to use with Internet Explorer.



Specifies the Internet newsreader program you want to use with Internet Explorer.



Click this to associate a program with a file type in order to open or run a file.



Specifies whether you want Internet Explorer to remain your default Internet browser, even if you install additional Web browsing 

software.

When this check box is selected, each time Internet Explorer starts it checks to make sure it is still registered as the default 

Internet browser. If another program is registered as the default browser, Internet Explorer asks whether you want to restore 

Internet Explorer as your default browser.



Click this to start Content Advisor. This feature is useful if you have children and want to control what kinds of material they can 

view on the Internet.



Click this to modify the Content Advisor ratings for Internet Web sites.



Click this to view the personal security certificates you have installed on this computer. These certificates are only used with 

client authentication servers that require personal certificates.



Click this to use security certificates sent from secure Web sites before you send information. Secure Web sites send Internet 

Explorer a certificate that provides certain information about security for that site. Certificates are issued to a particular 

organization for a specific period of time. Internet Explorer verifies the Internet address stored in the certificate and that the 

current date precedes the expiration date. If there is a problem, Internet Explorer can display a warning. Viewing information 

almost never presents a security risk, but sending information, such as your credit-card number, often does. Therefore, you 

might want to disable the warnings for viewing Web pages but retain them for sending information.



Click this to display the certificate publishers in Internet Explorer.



Specifies whether Internet Explorer should automatically download any active content to your computer. This content includes 

animations, multimedia files, and more.



Specifies whether Internet Explorer should automatically use items that show active content (for example, a vertical marquee, or 

an animation).



Specifies whether Internet Explorer automatically runs ActiveX scripts from Web sites.



Specifies whether Internet Explorer automatically runs Java(tm) programs.



Click this to control how potential security problems (caused by active content on Web pages) will be dealt with.



Lists the security certificates installed on your computer.



Click this to view detailed information about a security certificate.



Click this to delete the selected certificate. You might want to do this if the security certificate is out of date or the Web site is no 

longer valid.



Specifies that you want Internet Explorer to accept and use a new secure certificate from the Web site you are currently viewing.



Specifies that you want Internet Explorer to accept, but not use, a new secure certificate from the Web site you are currently 

viewing.



Specifies that you do not want Internet Explorer to accept and use a new secure certificate from the Web site you are currently 

viewing.



Specifies that secured information is not saved to your hard disk. This is useful if you are using Internet Explorer from a shared 

server and you do not want other people to see your secure information.



Specifies that you want to send and receive secured information through SSL2 (Secured Sockets Layer Level 2), the standard 

protocol for secure transmissions. All secure Web sites support this protocol.



Specifies that you want to send and receive secured information through SSL3 (Secured Sockets Layer Level 3), a proprietary 

protocol that is intended to be more secure than SSL2. If you select this check box, some Web sites might not support this 

protocol.



Specifies that you want to send and receive secured information through PCT (Private Communications Technology), a 

proprietary protocol developed by Microsoft that is significantly more secure than SSL2. If you select this check box, some Web 

sites might not support this protocol.



Specifies that you want to be notified about any potential security problems from a Web site. Active content that might pose a 

security problem is not downloaded, and you are not able to view it.



Specifies that you want to be warned about any potential security problems from a Web site. You can then choose whether or not 

to download or view active content.



Specifies that you do not want to be warned about potential security problems from a Web site. All active content is automatically 

downloaded to your computer. This option is not recommended.



Specifies whether you want to be warned before sending data to an Internet site that is not secure.

When you select this check box, you can then specify when Internet Explorer warns you.



Specifies that you want to be notified only when you are about to send more than one line of text to an Internet site that is not 

secure.

Typically, this level of security is sufficient for everyday use.



Specifies that you want to be notified every time you are about to send data to an Internet site that is not secure (even if you are 

sending only a small amount of data).

Typically, this level of security is necessary only if you are sending highly confidential information, such as a credit-card number.



Specifies whether Internet Explorer should warn you if you are switching between Internet Web sites that are and are not secure.



Specifies whether Internet Explorer should warn you if the uniform resource locator (URL) in a security certificate of an Internet 

site is not valid.



Specifies whether Internet Explorer should warn you if you are receiving a "cookie" from an Internet site. For example, if you 

subscribe to an online magazine, the Web site might download information to your computer so that you could be identified the 

next time you go to that site.



Click this to display your Temporary Internet Files folder, which holds the disk cache. The disk cache is the space on your hard 

disk that stores pages as you view them.



Click this to define the amount of disk space you want to make available for your temporary Internet files, to move the location of 

the files, and to empty the folder containing the files.



Click this to define the cryptography protocols.



Specifies whether to show a focus around the selected graphic or URL (uniform resource locator) on a page.



Specifies whether to show the full Internet address or URL (uniform resource locator) for a page on the status bar.

For example, the full address for the Microsoft home page on the World Wide Web is http://www.microsoft.com/.



Specifies whether Internet Explorer should create all Java(tm) programs automatically via its internal Java compiler. For 

example, when you are visiting a Web site that has Java programs, Internet Explorer will automatically create and run them for 

you.



Specifies whether a special type of scrolling is used to display content at a predefined speed.



Specifies whether Internet Explorer can view HTML (Hypertext Markup Language) style on Web sites.



Specifies whether Internet Explorer should create a log of all Java(tm) program activity.



Specifies that when you return to a page you viewed previously, Internet Explorer should check to see whether it changed since 

you last viewed it. If the page has changed, Internet Explorer displays the new page and stores it in the disk cache. Internet 

Explorer checks for changes once per session. Selecting this option can slow down browsing between viewed pages.



Specifies that when you return to a page you viewed previously, Internet Explorer should not check to see whether the page has 

changed since you last viewed it. Selecting this check box can speed up browsing between viewed pages.

If you want to view possible updates to a specific page when this check box is selected, click the View menu, and then click 

Refresh.



Specifies that when you return to a page you viewed previously, Internet Explorer should never check to see whether the page 

has changed since you last viewed it. Selecting this check box does speed up browsing between viewed pages.



Specifies the percentage of disk space to use for the Temporary Internet Files folder.

When you view a new page on the Internet, Internet Explorer stores it on your hard disk temporarily in a disk cache. This 

increases the speed at which pages are displayed when you browse the Internet.

The more disk space you allot to the disk cache, the more pages Internet Explorer can store on your disk. If you are low on disk 

space, you might want to set this option to a lower percentage.



Click this to specify a different folder for the disk cache.

Note    The new location does not become active until after you restart your computer.



Click this to delete the contents of the Temporary Internet Files folder or folders.

This option is useful if disk space is low and you don't want to browse through the pages you viewed previously.



Provides a space for you to type the complete Internet address of the document or folder you want to open.



Click this to browse through folders to find the file you want.



Provides a space for you to type the text you want to search for on the current page. You can type a single word or a phrase.



Specifies whether to begin searching at the top of the current page for the text you typed in the Find box. When this check box is 

not selected, Internet Explorer begins searching from the current location on the page.



Specifies whether to find only those occurrences of text on the current page whose characters match the uppercase and 

lowercase characters you type in the Find box.



Finds the next occurrence of the text on the current page.



Sets the left margin of the page. The margin you set here is never printed on.



Sets the top margin of the page. The margin you set here is never printed on.



Sets the right margin of the page. The margin you set here is never printed on.



Sets the bottom margin of the page. The margin you set here is never printed on.



Provides a space for you to type header text that will appear left-aligned at the top of the page.

To print specific information as part of the header, include the following characters as part of the text.

Type this To print this

&w Window title

&u Page address (URL)

&d Date in short format (as specified by 

Regional Settings in Control Panel)

&D Date in long format (as specified by 

Regional Settings in Control Panel)

&t Time in the format specified by 

Regional Settings in Control Panel

&T Time in 24-hour format

&p Current page number

&P Total number of pages

&& A single ampersand (&)

Provides a space for you to type header text that will appear right-aligned at the top of the page.

To print specific information as part of the header, include the following characters in the text.

Type this To print this

&w Window title

&u Page address (URL)

&d Date in short format (as specified by 

Regional Settings in Control Panel)

&D Date in long format (as specified by 

Regional Settings in Control Panel)

&t Time in the format specified by 

Regional Settings in Control Panel

&T Time in 24-hour format

&p Current page number

&P Total number of pages

&& A single ampersand (&)

Provides a space for you to type footer text that will appear left-aligned at the bottom of the page.

To print specific information as part of the footer, include the following characters in the text.

Type this To print this

&w Window title

&u Page address (URL)

&d Date in short format (as specified by 

Regional Settings in Control Panel)

&D Date in long format (as specified by 

Regional Settings in Control Panel)

&t Time in the format specified by 

Regional Settings in Control Panel

&T Time in 24-hour format

&p Current page number

&P Total number of pages

&& A single ampersand (&)

Provides a space for you to type footer text that will appear right-aligned at the bottom of the page.



To print specific information as part of the footer, include the following characters in the text.

Type this To print this

&w Window title

&u Page address (URL)

&d Date in short format (as specified by 

Regional Settings in Control Panel)

&D Date in long format (as specified by 

Regional Settings in Control Panel)

&t Time in the format specified by 

Regional Settings in Control Panel

&T Time in 24-hour format

&p Current page number

&P Total number of pages

&& A single ampersand (&)

Displays the name of the current page you are viewing. You can change the name. Internet Explorer creates a shortcut to this 

page in your Favorites folder.

To add the shortcut to another folder or a new folder, click Create In.



Click this to save the current page in another or new folder.



Click this to display the Create New Folder dialog box where you can specify the name of a new Favorites folder.



Displays a list of folders inside your Favorites folder.



Click this to move the selected item(s) to a new location.



Click this to rename the selected item. Type the new name.



Deletes the selected item(s).



Opens the selected item.



Closes the dialog box. 




