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Help on Help: A quick overview

The PhotoPlus online help system is designed to work for you. For suggestions based on your specific needs, see the Where do 
I begin...? section below. Whatever your background, you'll find it easy to navigate through online help: 

· To begin learning about PhotoPlus tools and menus, just move the mouse pointer around the screen. Watch the HintLine 
window at the lower right for capsule descriptions of various features.

· For help on interface elements like toolbars and tab windows, click the  Context Help button on the top toolbar, then click 
on an element.

· For help on dialog boxes, click their Help button.

· Choose Contents (click button above, or select the Help menu item) to display the main help menu screen, including links to 
the Welcome and Support pages.

· Choose Index (click button above, or select the Help menu item) to pop up the alphabetical list of help topics.

· Choose Effects Gallery (also a Help menu item) to display a visual sampler of color adjustments and special effects —cross-
referenced to help topics.

· Choose Visual Reference or How To to peruse help information using either a graphical or step-by-step approach—
whichever you prefer. Each section displays its own table of contents in the main window, while help topics appear in a second 
window. Extensive cross-references make sure all the information is interlinked.

Note: Both the Visual Reference and HowTo sections display their tables of contents in the main window, while help topics 
appear in a second window. 

· To make more room on-screen while you are reading help topics, click the main window's  Minimize button.

· To restore the main window, click the PhotoPlus 5 Help button on the Windows Taskbar.

Where do I begin...?

If you have the PhotoPlus Companion, that's the logical starting point for learning about PhotoPlus. Its chapter sequence 
begins with basic concepts and proceeds gradually through various tools and features—and the final chapter provides useful 
background on color theory and terminology. Hands-on Projects are integrated each step of the way.

In online help, you'll find much of the same coverage—minus the tutorials and the ease of flipping through pages. Whatever your 
starting level, we recommend you begin by reading the Overview of key concepts, and then branch out from there using the help 
options described above. The Color concepts topic provides more theoretical material that's sure to prove valuable as you 
continue to work with digital pictures. 

For a quick summary of PhotoPlus features, see the next topic, Welcome to PhotoPlus 5. (You can click the links there to learn 
more about specific features of interest.)



Welcome to PhotoPlus 5!

    Welcome to PhotoPlus 5.0 from Serif—the best value in image creation and editing software for any 
home, school, organization, or growing business. PhotoPlus is your number one choice for working with photographs and paint-type 
images, whether for the Web, multimedia, or the printed page. 
PhotoPlus has the features you'll need... from importing or creating pictures and animations, through manipulating colors and effects 
all the way to final export. Built-in support for TWAIN scanners and cameras makes it easy to bring in your own photos, while 
comprehensive import filters let you open just about any standard bitmap image.

Once you've got your image into PhotoPlus, you can enhance and alter its onscreen appearance with a diverse toolkit of 
functions and effects. A full range of export options (with special attention to Web graphics), plus powerful optimization 
capabilities, round out this high-performing package. 

Here's a more detailed summary of what you'll find (click the links to display related help topics):

· Powerful Image Export Optimizer 
The Export Optimizer lets you see how your image will look (and how much space it will take up) before you save it! Its multi-
window display provides side-by-side WYSIWYG previews of image quality at various output settings, so you can make the 
best choice every time.

· Web Animation Tools 
Now it's easy and fun to create and edit animations for the Web. You can import and export animated GIFs and even let 
PhotoPlus create entire animations for you automatically. As a bonus, we've included hundreds of sample animations to get 
you started.

· Editable Text 
Add formatted color text to an image, reposition and scale it, integrate it with your design. Text layers keep the contents 
separate so you can go back and alter the words or formatting at any time!

· Image Enhancement
Apply professional, darkroom-style color and histogram adjustments to your images. 

· Special Effects Filters
A wild and whimsical assortment for instant creativity! PhotoPlus even lets you design your own custom filters.

· Unique Selection Options
PhotoPlus goes beyond well the basic rectangle and lasso tools, adding more than a dozen completely customizable selection 
shapes like polygons, spirals, and stars. Or define a selection shaped like text—using any font and style! Advanced options let 
you fine-tune the selection and its properties for precise effects.

· Smart Shapes
Choose from a panoply of fully adjustable filled shapes to produce chevrons, hearts, badges, teardrops, moons, zigzags, and 
many more. Just drag sliders to control each shape's appearance!

· Image Slicing and Image Maps
Now it's not just the pros who can use these techniques to add links to Web graphics! Simply click to subdivide images into 
segments—each with its own hyperlink and popup text—or add hotspots to specific regions. PhotoPlus outputs the required 
HTML code and lets you preview the results directly in your Web browser.

· Advanced Tools and Features
Built-in support for most pressure-sensitive graphics tablets. RGB, CMYK, HSV, and Grayscale color modes. Robust and 
convenient layer management with pop-up preview and masking support.

· Professional Output Options
Output using CMYK separations or print directly to your desktop printer with useful controls. Include registration marks, crop 
marks, file information, grayscale and color bars, and tile or scale your output if required.

· All in a Productive MDI Interface
Open and view multiple images and edit them simultaneously. Dockable, floating tab windows work in conjunction with 
convenient toolbars. The Layer Manager provides full control over all planes. Each document stores a massive undo range 
with dynamic memory and disk management, compressing information for optimized performance. And PhotoPlus remembers 
your preferred export settings, so your creative flow is undisturbed.

And that's only part of the story!

The PhotoPlus feature set includes all the standard capabilities you'd expect in a photo editor. Tools like Paintbrush, Airbrush, 
Clone, Smudge, and Erase. Customizable brush tips and opacity. Flip, rotate, and crop. Anti-aliasing. TWAIN support for scanner 
and digital camera input. A full range of supported file formats for both import and export. In short, more features for the price 
than allowed by law in some jurisdictions (but don't tell anyone)...
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Visual Reference {button Effects Gallery,JI(`>Second',`Gall_Menu')} 

{button How To...,JI(`>Main',`Step_by_Step')} 

MENUBAR - Click a menu name for details:

 

TOOLBARS and TAB WINDOWS - Click an element for details:

 



File Menu
Commands for opening, saving, and printing image files. 
Shortcut: Alt+F

New
Displays the Startup Wizard, which gives you six options: (1) open a saved 
image file; (2) create a new picture; (3) create a new animation; (4) import from 
a TWAIN source (such as a scanner); (5) view the PhotoPlus samples gallery; 
or (6) access online resources. (See the How To topic Starting with a new 
picture or animation.)
Tip: You can also use the New button on the Standard toolbar, or press 
Ctrl+N.

Open...
Displays a standard Windows dialog which allows you to open an existing 
image file of any supported format. (See the How To topic Opening an existing 
file.)
Tip: You can also use the Open button on the Standard toolbar, or press 
Ctrl+O.

Close
Closes the current image file. If it's still unsaved ("Untitled") or there are 
unsaved changes, you'll be prompted to save changes.

Save
Saves the current image as a PhotoPlus (.SPP) file under its current name. If 
it's still unsaved ("Untitled"), the Save As... dialog automatically appears. (See 
the How To topic Saving a file.) To save the image in another format, use 
File/Export....
Tip: You can also use the Save button on the Standard toolbar, or press 
Ctrl+S.

Save As...
Displays a dialog prompting you to enter a directory and file name for the 
image file, then saves it as a PhotoPlus (.SPP) file under that name. To save 
the image in another format, use File/Export....

Save Original...
Saves the current image under its original name, using the original file format 
(such as .BMP or .JPG) rather than the PhotoPlus format.

Save Original As...
Displays a dialog prompting you to enter a directory and file name for the 
image file, then saves it using the original file format.

Import >
Displays a submenu with the following choices:

· Select Source
Displays a dialog that lets you choose a TWAIN source (such as a scanner or 
digital camera) from those currently set up on your computer. For instructions 
on setting up a TWAIN device, see the documentation supplied with the device.

· Acquire
Displays the acquisition dialog associated with the selected TWAIN source. 
(See the How To topic Acquiring a TWAIN image.)

Export…
Displays a dialog that lets you save the current image in a file format other than 
the native PhotoPlus (.SPP) format. Enter the desired file name. To set export 
options, click the dialog's Optimizer button. (See the How To topic Exporting to 
another file format.)

Export Optimizer…
Displays the Export Optimizer dialog, which lets you preview and select various 
export formats and options. Click the dialog's Export button to continue 
exporting the current image. (See the How To topic Exporting to another file 
format.)

Preview in Browser...
Exports the image as a temporary file, then opens the file for preview in your 
World Wide Web browser.

Print...
Displays a standard dialog box for printing the current image. The Properties 
button displays a standard Windows printer setup dialog. The Options button 



lets you control scaling, tiling, color separations, and other useful features. 
(See the How To topic Printing.)
Tip: You can also use the Print button on the Standard toolbar, or press 
Ctrl+P.

Preferences...
Displays a dialog that lets you customize a wide range of PhotoPlus settings, 
including undo, plug-in, layout, and startup options. (See the How To topic 
Setting PhotoPlus preferences.)

Recent Files List
Lists the names of the four most recently saved PhotoPlus files. Click a file 
name to open that file. 

Exit
Closes PhotoPlus. You'll be prompted to save changes made since the last 
save.



Edit Menu
Commands for Clipboard (cut & paste) and related actions. 
Shortcut: Alt+E

Undo <action>
Undoes the most recent change to the current image. Undo is grayed out when 
not available. To set undo options, choose Preferences... from the File menu. 
Tip: You can also use the Undo button on the Standard toolbar, or press 
Ctrl+Z.

Redo <action>
Reverses the most recent undo action. Grayed out when not available. 
Tip: You can also use the Redo button on the Standard toolbar, or press 
Ctrl+Y.

Cut
Deletes the contents of the selected region of the active layer (or of the whole 
layer if there's no selection) and places a copy on the Windows Clipboard. On 
the Background layer, the cut region exposes the current background color. On 
other layers, it exposes transparency.
Tip: You can also use the Cut button on the Standard toolbar, or right-click on 
the object, or press Ctrl+X.

Copy
Copies the contents of the selected region of the active layer (or of the whole 
layer if there's no selection) to the Windows Clipboard. 
Tip: You can also use the Copy button on the Standard toolbar or press 
Ctrl+C. To duplicate a selection on the same layer, hold down the Alt key and 
drag with the Move tool.

Copy Merged
Copies the contents of the selected region (on all visible layers) to the Windows 
Clipboard. 
Tip: You can also press Shift+Ctrl+C.

Paste >
Displays a submenu with the following choices:

· As New Image
Creates a new image file from the contents of the Windows Clipboard. 
Tip: You can also use the Paste button on the Standard toolbar, or press 
Ctrl+V.

· As New Layer
Inserts the contents of the Windows Clipboard as a new layer above the active 
layer in the current image.
Tip: You can also press Ctrl+L.

· Into Selection
Inserts the contents of the Windows Clipboard centered in the current 
selection, replacing it. Grayed out if nothing is selected, or if the active layer is 
a text layer.
Tip: You can also press Shift+Ctrl+L.

Clear
Deletes the contents of the selected region without placing a copy on the 
Windows Clipboard. On the Background layer, the deleted region is replaced 
with the current background color. On other layers, it is replaced with 
transparency. 
Tip: You can also press the Delete key. If you accidentally delete a selection, 
immediately choose Undo from the Edit menu.



Image Menu
Commands for manipulating properties of the active layer or a selected region. Click green links for How To topics, red for Effects 
Gallery examples. 
Shortcut: Alt+I

Adjust >
Displays a submenu with the following choices: 

· Brightness/Contrast...
Displays a dialog that lets you vary the brightness and/or contrast. (See topic or 
example.)

· Hue/Saturation/Lightness...
Displays a dialog that lets you vary the hue, saturation, and/or lightness values. 
You can also colorize an image; this varies only the hue. (See topic or 
example.)

· Replace Color...
Displays a dialog that lets you vary the hue, saturation, and/or lightness of a 
portion of the color range. (See topic or example.)

· Gamma...
Displays a dialog that lets you vary the distribution of lightness (luminance) 
values in the red, green, and blue channels, either separately or linked. 
Gamma adjustment can correct the appearance of an image on a particular 
color monitor. (See topic or example.)

· Threshold...
Displays a dialog that lets you create a monochromatic (black and white) 
representation. You can adjust the threshold or transition point while viewing a 
plot of lightness levels. (See topic or example.)

· Equalization
Applies a filter that evenly distributes the lightness levels. (See topic or 
example.)

· Stretch
Applies a filter that spreads out the lightness levels. (See topic or example.)

· Negative Image
Inverts each color, replacing it with an "opposite" value. Especially useful for 
creating a positive image from a scanned photographic negative. (See topic or 
example.)

· Grayscale
Removes color information while retaining light and dark gradations, yielding a 
256-shade grayscale image. (See topic or example.)

Flip Horizontally >
Displays a submenu with the following choices:

· Image
Flips the entire image left to right. 

· Layer
Flips the active layer left to right.

· Selection
Flips the selection left to right.

Flip Vertically >
Displays a submenu with the following choices:

· Image
Flips the entire image top to bottom.

· Layer
Flips the active layer top to bottom.

· Selection
Flips the selection top to bottom.

Rotate...
Displays a dialog that lets you rotate the image, layer, or selection through a 
preset or variable angle, either clockwise or counter-clockwise.

Image Size...
Displays a dialog that lets you change the pixel size and/or print size of the 
whole image. You can vary width and height independently or maintain a fixed 
aspect ratio. In addition, you can select from several different resampling 



methods. For details, see the How To topic Resizing and scaling.

Canvas Size...
Displays a dialog that lets you change the width and/or height of the image 
canvas (frame) by adding or subtracting pixels at the image edges. Rather than 
scaling the image (as with the Image Size command), the Canvas adjustment 
extends or crops from the image borders. For details, see the How To topic 
Resizing and scaling.

Crop to Selection
Eliminates the portion of the image (on all layers) outside the edges of the 
selection. This reduces the canvas size without changing the image content 
within the selected region.

Histogram...
Displays the Histogram window, which provides image statistics and a graph of 
the distribution of Red, Green, Blue, or Lightness (luminance) values. The 
histogram is useful for evaluating the kinds of image adjustments that may be 
needed. (See the How To topic Reading the histogram.)

Blur >
Displays a submenu with the following choices: 

· Blur...
Displays a dialog that lets you apply a basic variable Blur effect. (See topic or 
example.)

· Gaussian Blur...
Displays a dialog that lets you apply the Gaussian Blur effect, which averages 
pixel values along a Gaussian or bell-shaped curve. (See topic or examples.)

· Soften
Applies a subtle blur effect. (See topic or example.)

· Blur Effects...
Displays a dialog that lets you apply one of these four effects:

1 Motion Blur
Blurs to simulate motion. (See topic or example.)

2 Radial Blur
Blurs the image to simulate a rotating camera. (See topic or example.)

3 Zoom Blur
Blurs the image to simulate a zooming camera. (See topic or example.)

4 Fragment
Blurs the image to simulate a hand-held camera. (See topic or example.)

Edge >
Displays a submenu with the following choices: 

· Enhance
Sharply emphasizes both horizontal and vertical edges. (See topic or example.)

· Find Horizontal
Isolates horizontal edges. (See topic or example.)

· Find Vertical
Isolates vertical edges. (See topic or example.)

· Find All
Isolates both horizontal and vertical edges. (See topic or example.)

Noise >
Displays a submenu with the following choices: 

· Add...
Displays a dialog that lets you add noise (grain). (See topic or examples.)

· Median Cut...
Displays a dialog that lets you apply the Median Cut effect, which results in 
broader areas of similar color for a "blotchy" or oil paint appearance. (See topic 
or example.)

Other >
Displays a submenu with the following choices: 

· Solarize...
Displays a dialog that lets you apply the Solarize effect. Solarization is a 
darkroom technique in which a partially developed image is re-exposed to light, 
producing dramatic changes in mid-tone regions. (See topic or example.)



· Posterize...
Displays a dialog that lets you apply the Posterize effect. You can specify the 
number of tonal levels (lightness values). PhotoPlus then maps pixels to the 
nearest level. (See topic or example.)

· Emboss...
Displays a dialog that lets you apply the Emboss effect, which remaps contours 
to simulate a bas-relief impression. (See topic or example.)

· Mosaic...
Displays a dialog that lets you apply the Mosaic effect, which breaks the image 
into blocks of uniform color for a tiled appearance. (See topic or example.)

· Sharpen...
Displays a dialog that lets you sharpen the image. (See topic or example.)

Custom...
Displays a dialog that lets you define custom filters. (See the topic Defining 
custom filters.)



Layers Menu
Commands for manipulating layers in the image.
Shortcut: Alt+L

See Also:

· The sequence of How To topics on "How to Work with Layers and Masks," starting with Basics of using layers

· The Visual Reference topic on the Layer Manager tab

New...
Displays a dialog that lets you specify the name and opacity for a new layer. 
Click OK to add the layer above the active layer.
Tip: You can also right-click a layer name on the Layer Manager tab and 
choose New....

Duplicate
Clones the contents of the active layer onto a new layer.

Delete
Deletes the active layer.
Tip: You can also right-click a layer name on the Layer Manager tab and 
choose Delete.

Properties...
Displays a dialog that lets you view and/or change the name and opacity of the 
active layer. 
Tip: You can also right-click a layer name on the Layer Manager tab and 
choose Properties.

Add Mask >
 Displays a submenu with the following commands for adding a mask to an 
active layer other than the Background (see the How To topic Basics of using 
masks): 

· Reveal All
Creates a mask that reveals the entire layer.

· Hide All
Creates a mask that hides the entire layer.

· Reveal Selection
Creates a mask that reveals the selected region and hides the remaining 
portion of the layer.

· Hide Selection
Creates a mask that hides the selected region and reveals the remaining 
portion of the layer.

Delete Mask
Removes the mask from the active layer and cancels the mask's effects, if any. 
(To remove the mask and update the layer, choose Delete Mask.)

Edit Mask
Check to make the active layer's mask available for editing. Uncheck to stop 
working on the mask and edit the active layer directly.

View Mask
Check to reveal the active layer's mask as a grayscale plane. Darker mask 
values impose transparency on the corresponding layer pixels (hiding them), 
while lighter values impose opacity (revealing pixels). Thus a Hide All mask 
initially appears as pure black, while a Reveal All mask appears white. View 
Mask is mainly used for checking purposes—normally you'll edit while viewing 
the layer, rather than the mask.

Disable Mask
Check to temporarily switch off the active layer's mask so you can see how the 
layer looks without the mask's effects. Uncheck to enable masking again. Note 
that disabling the mask is not the same as canceling Edit Mask mode—it only 
affects your view of the layer, not which plane (mask or layer) you're working 
on.

Merge Mask
Imposes the mask's effect onto the active layer, permanently updating it and at 
the same time removing the mask. (To remove the mask without updating the 
layer, choose Delete Mask.) 



Merge Down
Combines the active layer with the visible layer below it, forming a new single 
layer.

Merge Visible
Combines the visible layers into a single layer.

Merge All
Combines all layers, visible and invisible, into a single layer.

Arrange >
Displays a submenu with the following choices: 

· Bring to Top
Moves the active layer to the top of the layer stack.

· Move Up
Moves the active layer up one level in the layer stack.

· Move Down
Moves the active layer down one level in the layer stack.

· Send to Bottom
Moves the active layer to the bottom of the layer stack.



Select Menu
Commands for defining and modifying a selection within the image.
Shortcut: Alt+S

See Also:

· The sequence of How To topics on "How to Manipulate All or Part of an Image," starting with Making a selection

 

Select All
Selects the entire active layer. 
Tip: You can also press Ctrl+A.

Deselect
Selects nothing.
Tip: Clicking with any selection tool has the same effect of canceling the 
selection. You can also press Ctrl+D.

Invert
Selects the portion of the active layer outside the current selection. Unselected 
pixels become selected, and vice versa. 
Tip: You can also press Ctrl+Shift+I.

Modify >
(See the How to topic Modifying a selection)
Displays a submenu with the following choices: 

· Contract...
Displays a dialog that lets you shrink the borders of the selection by a specified 
number of pixels. 

· Expand...
Displays a dialog that lets you expand the borders of the selection by a 
specified number of pixels.

· Feather...
Displays a dialog that lets you blur outward from the edges of the selection by a 
specified value.

· Grow
Extends the selection to include adjacent pixels that are close in color value, as 
determined by the Color Selection tool's tolerance setting on the Tool 
Properties tab.

· Similar
Extends the selection to include pixels anywhere in the active layer (not just 
adjacent) that are close in color value, as determined by the Color Selection 
tool's tolerance setting on the Tool Properties tab.

Show Marquee
Check to show the marquee defining the edges of the selection. Uncheck to 
hide the marquee (without changing the selected region, which remains 
actively selected). 



View Menu
Commands for setting display options. 
Shortcut: Alt+V

See Also:

· The sequence of How To topics on "How to Configure the Workspace," starting with Working with PhotoPlus windows

Normal Viewing (1:1)
Restores the zoom view to 100%.

Zoom In >
Displays a submenu that lets you increase the zoom ratio at which your image 
is displayed, in a range from 2:1 to 16:1.
Tip: You can also left-click with the Zoom tool.

Zoom Out >
Displays a submenu that lets you decrease the zoom ratio at which your image 
is displayed, in a range from 1:2 to 1:16.
Tip: You can also right-click with the Zoom tool.

Grid 
When checked, the alignment grid is visible. Uncheck to hide the grid.

Rulers
When checked, rulers are visible at the top and left of the document window. 
Uncheck to hide rulers. (See the Visual Reference topic Using the rulers and 
grid.)

Tool Properties Tab
Check to show the Tool Properties tab window. Uncheck to hide it.

Brush Tip Tab
Check to show the Brush Tip tab window. Uncheck to hide it.

Layer Manager Tab
Check to show the Layer Manager tab window. Uncheck to hide it.

Color Tab
Check to show the Color tab window. Uncheck to hide it.

Tools Toolbar
Check to show the Tools toolbar. Uncheck to hide it.

Standard Toolbar
Check to show the Standard toolbar. Uncheck to hide it.

Hintline
Check to show the HintLine. Uncheck to hide it.



Window menu
Commands for arranging image windows. 
Shortcut: Alt+W

New Window
Open another window for the active image.

Cascade
Arranges the windows as overlapping tiles.

Tile
Arranges the windows as horizontal, non-overlapping tiles. Useful for side-by-
side comparisons.

Arrange Icons
Arranges the minimized windows.

Window List
Shows the names of open image windows, with the current window checked. 
Click a window's name to work on that image.



Help Menu
Help, hints, tips, and options for learning PhotoPlus. 
Shortcut: Alt+H

See Also: 

· The introductory topic Help on Help. 

Contents
Displays the main Help contents page.

Index
Displays the index of Help topics.

Effects Gallery
Displays the PhotoPlus Effects Gallery, which includes examples of image 
effects, with links to related Help topics.

Visit the PhotoPlus Web Site
Connects to the World Wide Web and displays the PhotoPlus Web site section 
in your Web browser. (By default, this feature activates periodically. To change 
the defaults, choose Preferences... from the File menu and use the Startup 
tab.)
Hint: You can also access the PhotoPlus Web site via the Startup Wizard's 
Online Resources option.

Visit the Serif Web Site
Connects to the World Wide Web and displays the Serif Home Page in your 
Web browser. 
Hint: You can also access the Serif Web site via the Startup Wizard's Online 
Resources option.

Registration Wizard...
Helps you to register your personal copy of PhotoPlus.

About PhotoPlus...
Displays version and copyright information.



 Standard toolbar

 

 
New
the Startup Wizard, which gives you six options: (1) open a saved image 
file; (2) create a new picture; (3) create a new animation; (4) import from a 
TWAIN source (such as a scanner); (5) view the PhotoPlus samples 
gallery; or (6) access online resources. (See the How To topic Starting with 
a new picture or animation.)
Tip: You can also press Ctrl+N or use menu command File/New.

 
Save
Click to save the current image as a PhotoPlus (.SPP) file under its current 
name. If it's still unsaved ("Untitled"), the Save As... dialog automatically 
appears. (See the How To topic Saving a file.) To save the image in another 
format, use File/Export....
Tip: You can also press Ctrl+S or use menu command File/Save.

 
Open
Click to display a standard Windows dialog which allows you to open an 
existing image file of any supported format. (See the How To topic Opening 
an existing file.)
Tip: You can press Ctrl+O or use menu command File/Open.

 
Print
Click to display a standard dialog box for printing the current image. The 
Properties button displays a standard Windows printer setup dialog. The 
Options button lets you control scaling, tiling, color separations, and other 
useful features. (See the How To topic Printing.)
Tip: You can also press Ctrl+P or use menu command File/Print.

 
Copy
Click to copy contents of the selected region (on the active layer only) to 
the Windows Clipboard. 
Tip: You can also press Ctrl+C or use menu command Edit/Copy.

 
Paste as New Image
Click to create a new image file from the contents of the Windows 
Clipboard. 
Tip: You can also press Ctrl+V or use menu command Edit/Paste.

 
Undo
Click to undo the most recent change to the current image. Undo is grayed 
out when not available. 
Tip: You can also press Ctrl+Z or use menu command Edit/Undo.

 
Redo
Click to undo the most recent Undo action. Undo is grayed out when not 
available.
Tip: You can also press Ctrl+Y or use menu command Edit/Redo.

 
Context Help
Click to display a special cursor, then click on a toolbar or tab to display the 
associated Help topic. Clicking other interface elements displays the 
introductory section of the How To menu.

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Tools toolbar Click a tool icon:

 

 
Zoom Tool
Click to use the Zoom tool to change your view of the image in its window.
· To zoom in, left-click on the image.
· To zoom out, right-click on the image.

 
Pan Tool
Click to use the Pan tool to move the image in relation to its window. 
Select the tool, then drag the image.

 
Crop Tool
Click to use the Crop tool to crop the image. Select the tool and drag out a 
selection rectangle, adjust the edges as needed, then double-click in the 
rectangle to crop to the specified size.
· To constrain the selection to a square, hold down the Ctrl key while 
dragging. 
Tip: You can use Image/Crop to Selection or Image/Canvas Size... to 
crop the image, or Image/Image Size... to scale the image to smaller or 
larger dimensions. (See the How To topic Changing image and canvas 
size).

 
Move Tool
Click to use the Move tool to move the contents of the selection, or the 
entire active layer if nothing is selected. Select the tool, then drag to move.
· To duplicate the contents of the selection on the same layer, press the Alt 
key and click, then drag with the Move tool. 
Tip: You can also press the Ctrl key and drag with any selection tool (see 
below).
(See the How To topic Manipulating a selection.) 

 
Standard Selection Tools
Click the down arrow button to display a flyout menu of selection tools, 
as detailed below. Click the larger button to choose the most recently 
used selection tool. 
· Set Tool Properties tab options as needed.
· To constrain the selection's proportions (for example, to a square or 
circle), hold down the Ctrl key while dragging.
· To add to the existing selection, hold down the Shift key while 
dragging.
· To subtract from the existing selection, hold down the Alt key while 
dragging. 
· To move the selection (not its content) after it's defined, drag from its 
center.
· To move the contents of the selection, press the Ctrl key, then drag 
from the center of the selection. To duplicate, press Ctrl+Alt.
(See the How To topic Making a selection.)

 Rectangle
Click to select the tool. Drag on the image to define a rectangular selection 
region on the active layer. 

 Ellipse
Click to select the tool. Drag on the image to define an elliptical selection 
region on the active layer.

 Freehand
Click to select the tool. Hold down the left mouse button and draw on the 
image to outline a selection region on the active layer. Release the mouse 
button to close the selection curve.

 Polygon
Click to select the tool. Draw a series of line segments on the image to define 
a polygonal selection region on the active layer. Release the mouse button to 
define the end point of each segment. Double-click to close the polygon.

 
Adjustable Selection Tools
Click the down arrow button to display a flyout menu of 
selection tools. Click the larger button to choose the most 



 

recently used selection tool. Drag out a shape on the 
image, then adjust its handles to fine-tune the shape. 
Double-click within the shape to select the region on the 
active layer. 
· Set Tool Properties tab options as needed. 
· To constrain the selection's proportions, hold down the 
Ctrl key while dragging.
· To add to the existing selection, hold down the Shift key 
while dragging.
· To subtract from the existing selection, hold down the Alt 
key while dragging. 
· To move the selection (not its content) after it's defined, 
drag from its center
· To move the contents of the selection, press the Ctrl key, 
then drag from the center of the selection. To duplicate, 
press Ctrl+Alt.
(See the How To topic Making a selection.)

 
Color Selection Tool
Click to use the Color Selection tool to select a region based on color 
similarity. Clicking on a pixel selects any adjacent pixels on the active layer 
whose color falls within a specified range (tolerance) with respect to the 
clicked pixel.
· Set Tool Properties tab options as needed. You can adjust the tolerance 
and sample pixels on either the active layer or all layers.
· To add to the existing selection, hold down the Shift key and click.
· To subtract from the existing selection, hold down the Alt key and click.
· Use menu items on the Select/Modify flyout to expand or shrink the 
selection, select similar pixels elsewhere in the image, etc. 
· To move the selection (not its content) after it's defined, drag from its 
center.
· To move the contents of the selection, press the Ctrl key, then drag from 
the center of the selection. To duplicate, press Ctrl+Alt.
(See the How To topic Making a selection.)

 
Color Pickup Tool
Click to use the Color Pickup tool to choose new foreground or 
background colors from the colors available in the image. Left-click on an 
image color to define it as the foreground color; right-click to define the 
background color. The current foreground and background colors are 
shown as swatches on the Color tab.
· Alternatively, you can use the Color tab to define colors using a color 
spectrum.
Tip: To switch temporarily to the Color Pickup tool from most of the creation 
tools, press the Alt key.
(See the How To topic Choosing colors.)

 
Paintbrush Tool
Click to use the Paintbrush tool to draw freehand lines on the active layer. 
Left-drag to paint in the foreground color. If there is a selection, the tool 
only affects pixels within the selected region.
· Set Tool Properties tab options as needed. 
· Choose a brush size from the Brush Tip tab.
(See the How To topic Painting, drawing, airbrushing, and smudging.)

 
Clone Tool
Click to use the Clone tool to duplicate part of the active layer. The tool 
works like a brush that lets you "pick up" the image from one place and 
"paint" it onto another place—even between images. To define the pickup 
origin, Shift-click with the tool. Click again where you want to start the 
copy, then drag to paint the copy onto the new location. Repeat as needed. 
A crosshair marks the pickup point, which moves relative to your brush 
movements. If there is a selection, the tool only affects pixels within the 
selected region.
· Set Tool Properties tab options as needed. Check "Aligned" to keep the 
pickup point moving between brush strokes. Uncheck to reset the pickup 
point to the initial origin between brush strokes. 
· Choose a brush size from the Brush Tip tab.
(See the How To topic Cloning a region.)

 
Smudge Tool
Click to use the Smudge tool to simulate smudging by picking up color 



from the click point and "pushing" it in the brush stroke direction. If there is 
a selection, the tool only affects pixels within the selected region.
· Set Tool Properties tab options as needed.
· Choose a brush size from the Brush Tip tab.
(See the How To topic Painting, drawing, airbrushing, and smudging.)

 
Eraser Tool
Click to use the Eraser tool to erase part of the active layer. Left-drag the 
tool like a brush. On the Background layer, erased pixels reveal the current 
background color. On other layers, erasing exposes transparency. If there 
is a selection, the tool only affects pixels within the selected region.
· Set Tool Properties tab options as needed.
· Choose a brush size from the Brush Tip tab.
(See the How To topic Erasing.)

 
Airbrush Tool
Click to use the Airbrush tool to "spray paint" on the active layer. Left-drag 
to paint in the foreground color. If there is a selection, the tool only affects 
pixels within the selected region.
· Set Tool Properties tab options as needed. 
· Choose a brush size from the Brush Tip tab.
(See the How To topic Painting, drawing, airbrushing, and smudging.)

Flood Fill Tool
Click to use the Flood Fill tool to replace an existing color region with 
the foreground color. Clicking with the tool on a pixel fills any adjacent 
pixels whose color falls within a specified range (tolerance) with 
respect to the clicked pixel. If there is a selection, the tool only affects 
pixels within the selected region.

· Set Tool Properties tab options as needed. You can adjust the 
tolerance and sample pixels on either the active layer or all layers.
(See the How To topic Filling a region.)

 
Text Tools
Click the down arrow button to choose either of the text tools. Click 
the larger button to select the most recently used text tool. (See the 
How To topic Creating text.)

 Text Tool
Click to use the Text tool to create text. Click with the tool to display the Add 
Text dialog. Type or revise your text, set color and formatting options, then 
click OK. The new text appears on a separate text layer. To edit existing text, 
click on it with the Text tool.

 Text Selection Tool
Click to use the Text Selection tool to create a selection in the form of text. 
Click with the tool to display the Add Text dialog. Type your text, format as 
needed, and click OK. 

 

 

Shape Tools
Click the down arrow button to display a flyout menu of 
adjustable shapes. Click the larger button to choose the 
most recently used shape. Drag out a shape on the image, 
then adjust the handles to fine-tune the shape. Double-
click within the shape to draw it. 
· Set Tool Properties tab options as needed. 
· To constrain the shape's proportions, hold down the Ctrl 
key while dragging.

 
Line Tool
Click the button, then click and drag to draw a straight line using the 
foreground color.
· Set Tool Properties tab options, such as line weight, as needed. 
· To constrain the angle of the line to 15-degree increments, hold down the 
Shift key as you drag. 

 
Image Slice Tool
Click to use the Image Slice tool to divide the image into sections, which 
can be exported separately as GIFs or JPGs (to be reassembled 
seamlessly in a Web browser). Click with the tool to place a horizontal slice 
guide (a red line) on the image. Shift-click to place a vertical guide. To 
move a guide, simply drag it. To delete a guide, drag it to the top or bottom 
of the image.



(See the How To topic Slicing images)

 
Image Map Tools
Click to display a flyout menu of tools for creating and editing image 
maps—that is, graphics with overlaid hotspots for use on Web pages. 
(See the How To topic Creating image maps.)

 Image Map Selection
Choose this tool to select an existing hotspot. Drag an edge to resize the 
hotspot, or drag from the center to move it. Right-click to delete, set layer 
options, or access hotspot properties (popup text and target URL).

 Image Map Rectangle
Choose this tool to draw a rectangular hotspot.
· To constrain the hotspot to a square, hold down the Ctrl key while dragging.

 Image Map Circle
Choose this tool to draw a circular hotspot.

 Image Map Polygon
Choose this tool to draw a polygonal hotspot as a series of line segments. 
Release the mouse button to define the end point of each segment. Double-
click to close the polygon.

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 HintLine

 Image Information
Displays a continuously updated readout of useful data about 
the pixel directly below the cursor position. The readout varies 
depending on the selected tool or mode—most often it shows 
the pixel's position (with 0,0 as the top left corner of the image). 
When you use the Color Selection tool, the readout shows color 
values and opacity.

HintLine
Displays helpful, context-sensitive messages about PhotoPlus 
interface elements, as well as status information for selected 
operations.

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Layer Manager tab

 

The Layer Manager tab 
includes controls for creating, 
deleting, arranging, merging, and 
setting properties of layers in the 
image.

(See the series of How To topics 
starting with Basics of using 
layers.)

 Layer Name
Typically, each image has a Background layer, and may also 
have one or more standard (transparent) layers. To work on a 
layer, click its name; the currently active layer is highlighted. 
The ordering of layer names reflects how layers are stacked in 
the image. To change a layer's position in the stack, drag its 
name up or down. Right-click layer names for more options. 

 

Layer Preview
Appears when you pause the mouse pointer over a layer 
name. The window provides a quick view of the layer's 
contents—even if the layer is hidden.

 
Hide/Show Layer
Click (push button down) to make a layer's contents visible; click again to 
make the layer invisible.

 Protect Transparency
Click (push button down) to prevent further editing of transparent regions 
on a layer.

 Link/Unlink Layer
Click (push button down) to link a layer to the active layer. When two or 
more layers are linked, they move as one when manipulated with the Move 
tool.

 
Opacity
Enter a value (from 0-100), or click the down arrow and 
use the popup slider, to set the layer's overall opacity. 
Note that this setting does not affect the transparency of 
individual pixels on the layer. (See the How To topic 
Adjusting opacity/transparency.)

 
New Layer
Click to display a dialog that lets you set properties (name and opacity) for 
a new layer. The new, empty layer appears above the active layer in the 
stack.
Tip: You can also right-click a layer name and choose New..., or choose 
New from the Layers menu.

 
Delete Layer
Click to delete the active layer. 
Tip: You can also right-click a layer name and choose Delete or choose 
Delete from the Layers menu.



For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Tool Properties tab

 

The Tool Properties tab lets you 
customize the settings for many of 
the tools on the Tools toolbar. The 
master table below explains the 
various tool properties.

Property: Associated Tools: Choices and Function:

Aligned Clone On/off; "on" keeps a fixed distance 
between the origin point and 
brush tip on separate strokes; 
"off" keeps the origin point fixed

Antialias Standard and Adjustable 
Selection, Shape, Line 

On/off; produces smooth edges by 
making edge pixels semi-
transparent

Color Paintbrush, Airbrush On/off; whether stylus (pen) 
pressure has an effect

Fade Paintbrush, Eraser, Airbrush Number of steps; fade-out rate 
simulates brush strokes. For 
continuous flow, set to 0.

Feather Standard and Adjustable 
Selection 

Pixel value; varies sharpness of 
selection's edges by transition 
with surrounding region

Opacity Paintbrush, Clone, Smudge, 
Eraser, Fill, Shape, Line 

Percent; lower value yields more 
transparent color in line or shape. 

Opacity Paintbrush, Clone, Smudge, 
Eraser, Airbrush 

On/off; whether stylus (pen) 
pressure has an effect

Pressure Airbrush Percent

Size Paintbrush, Clone, Smudge, 
Eraser

On/off; whether stylus (pen) 
pressure has an effect

Tolerance Color Selection, Fill Color value (0-255); tool affects 
pixels within this range of the 
pixel clicked

Use All Layers Color Selection, Fill On/off; apply tool to all layers 
below the click point, or just the 
active layer

Weight Line Pixel value; line thickness

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Color tab

The Color tab lets you select 
foreground and background colors 
and change the color mode.

(See the How To topic Choosing 
colors.)

 

Foreground/Background swatches
The left swatch shows the foreground color, and the right swatch 
shows the background color. The white-outlined swatch is the one 
currently selected for editing; click either swatch to select it. 
· To swap foreground and background colors, click the double arrow.
· To define or apply custom colors using the Adjust Color dialog, 
double-click either swatch. (See the How To subtopic, Precise color 
definition.)

 
Color Spectrum
Displays the current color spectrum. As you move the 
dropper cursor around the spectrum, the preview swatch 
on the left shows the color at the cursor position. Left-
click in the spectrum to set a new foreground color. Right-
click to set a new background color. 

 
Color Values
Show the current color component values of the selected color (top 
swatch). You can change the value by typing a specific value or by 
dragging the corresponding color slider. 

 Color Sliders
Drag a slider to "remix" the selected color (top swatch) by 
changing one of its components. The corresponding color 
value box updates interactively, as does the selected 
color's swatch.

 Color Mode Selector
Click the down arrow and choose from the menu to 
change the current color mode to one of the following:
· RGB (Red, Green, Blue)
· CMYK (Cyan, Magenta, Yellow, Black)
· HSL (Hue, Saturation, Lightness)
· Grayscale

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Brush tip tab

The Brush Tip tab lets you choose 
and customize brush tips for the 
painting tools. 

· Click a brush tip to select it.

· Double-click a brush tip to customize it. The Brush Options dialog (see below) appears.

· Right-click a brush tip for other options, including Delete and New Brush....

Using the Brush Options dialog

The Brush Options dialog lets you customize a brush or add    a new one. Brush options include:

Diameter Size of the brush itself

Hardness Size of the hard center of the brush, as a percentage of the 
diameter. The value determines the size of the brush's soft 
edge

Spacing Distance between the brush marks in a stroke

Angle For an elliptical brush, the degree by which its long axis is offset 
from the horizontal

Roundness Brush shape, expressed as a ratio between the brush's width 
and length. 100% is fully round; 0% is linear.

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.



 Animation tab

 
The Animation tab provides controls for editing GIF animation files, and is only available in Animation mode. (See the series of 
How To topics beginning with Getting started with animation.)

· To resize the Animation tab, drag one of its edges.

 

Frame thumbnail 
Thumbnails represent the sequence of frames in the animation. 
Each frame is a different state of the image, defined in terms of 
which layers are shown or hidden, the position of content on 
each shown layer, and the opacity of each shown layer. 

· To select a frame, click its thumbnail. 
· To select multiple frames, hold down the Ctrl key when selecting each one. 
· To select a range of adjacent frames, hold down the Shift key and click the 
first and last thumbnail in the range. 
· To select all frames, right-click any thumbnail and choose Select All.
· To reposition a frame in the sequence, drag its thumbnail and drop it before 
or after another frame.

 
Show/Hide Captions 
Click (push button down) to display each frame's caption under its 
thumbnail. Click again to hide captions.

 
Delete Frame 
Click to delete the selected frame(s). To delete a single frame, you can 
also right-click it and choose Delete.

 
New Frame 
Click to clone the selected frame as a new frame. You can also right-
click a thumbnail and choose New Frame.

 
First Frame
Click to select the first frame of the sequence.

 
Previous Frame 
Click to select the previous frame of the sequence. If the first frame was 
selected, you'll cycle back to the last frame.

 
Play 
Click to play the sequence by stepping rapidly through the frames.

 
Stop 
Click to halt playback.

 
Next Frame 
Click to select the next frame of the sequence. If the last frame of the 
sequence was selected, you'll cycle forward to the first frame.

 
Last Frame 
Click to select the last frame of the sequence.

 
Frame Delay 
Shows the delay interval (in milliseconds) for the 
selected frame. If greater than 0, the animation will 
pause accordingly on that frame during playback. To 
change the interval, enter a new value.



 
Loop 
· Click the left (Fixed Loop) button to have the 
sequence repeat a certain number of times and end 
displaying the first frame. Enter the number of times 
in the box. 
· Click the right (Endless Loop) button to have the 
sequence repeat forever.

For hints on using toolbars and tabs, see the How To topic Working with the toolbars and tabs.
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Troubleshooting and support

Troubleshooting a problem

Don't panic! Remember that all technical problems, no matter how bizarre they may seem, have a cause and a solution. By 
patiently applying a logical approach, you can often identify the source of the problem and fix it yourself. In general, try 
simplifying your PC's setup until the problem is no longer present. Then, incrementally restore the original setup, testing to see 
which component makes the problem recur. Be careful!

Initially, try to establish:

· Is the problem most likely arising within PhotoPlus? 

· Is it a Windows problem? 

· Or is it a "hardware" problem having to do with your PC or its peripherals? 

· Have you made any recent changes to your system configuration that might be responsible for the problem?

·

If it's a PhotoPlus issue, perhaps there's a procedure you need to know more about. Check online Help for information on the 
specific task you're trying to accomplish.

For Windows or hardware issues, click the Start button and choose Help for troubleshooting information—or check the specific 
manuals for the peripheral. 

Printing problems with Windows are generally caused by using an incorrect or outdated printer driver, or a third-party printer 
driver. Make sure that you use the Windows printer driver designed specifically for your printer. To check printer drivers, click 
Start, choose Settings > Printers.

Contacting Serif technical support

Our support mission is to provide fast, friendly technical advice and support from a team of on-call experts. Serif customers are 
entitled to free, unlimited phone support for the first 30 days following receipt of the product. After that time, pricing policies (per-
call or per-year) go into effect.

Technical support is provided by telephone and e-mail, as well as through FAQs on our Web site (see below).

USA Technical Support (603) 886-6642

e-mail: support@serif.com

UK Technical Support (0870) 727 3380

e-mail: support@serif.co.uk

International Technical Support +44 (115) 914 5472

Please do not fax technical support queries.

On the World Wide Web:

Support area main page http://www.serif.com/html/support.htm 

Frequently Asked Questions http://www.serif.com/html/faq.htm

Forums http://www.serif.com/html/forums.htm

Newsgroups http://www.serif.com/html/newsgroups.htm

Additional Serif contact information

Main office (USA, Canada):

The Software Center, PO Box 803, Nashua NH 03061, USA

Main (603) 889-8650

Registration (800) 232-2897

Sales (800) 55-SERIF or 557-3743

Technical Support (603) 886-6642

Customer Service (800) 489-6720

General Fax (603) 889-1127

Sales Fax (603) 886-4919



European office (UK, Europe):

The Software Centre, PO Box 2000, Nottingham, NG11 7GW, UK

Main (0115) 914 2000

Registration (UK only) (0870) 727 3379

Registration (International) +44 (115) 914 5471

Sales (0800) 376 7070

Technical Support (UK only) (0870) 727 3380

Technical Support (International) +44 (115) 914 5472

Customer Service (0115) 914 9090

General Fax (0115) 914 2020

On-line product and company information

Internet http://www.serif.com 

International enquiries

Please contact our main or European office as appropriate.



An overview of key concepts  

If you're new to photo editing programs, or perhaps have only worked with a basic painting program like Microsoft Paint, a 
number of the concepts in PhotoPlus may be new to you. Don't be daunted! Many thousands of artists have made the leap, and 
the rewards are well worth it. This topic collects in one place some of the background material that's scattered elsewhere in 
PhotoPlus online help—in hopes that it will provide a concise introduction and save you some "head-scratching" later on. Click 
the green, underlined links for more details on any concept.

You should also peruse the separate topic on Color concepts, which likewise tries to bring together terms and definitions related 
to electronic color theory. Understanding these will help you exploit all the creative possibilities PhotoPlus opens up. 

Image size and canvas size

This is sometimes a tricky distinction if you haven't encountered 
it before, but it's an important one when working with digital 
pictures. You probably know that image dimensions are given in 
pixels (think of pixels as the "dots of paint" that comprise a 
screen image)—say, 640 wide by 480 high. If you want to 
change these dimensions, there are two ways to go about it, 
and that's where image and canvas come into play.

Changing the image size (I) means scaling the whole image or just a selected region up or down. Changing the canvas size (C) 
means adding or taking away pixels at the edges of the image—rather like adding a border around a mounted photo, or taking a 
pair of scissors and cropping the photo to a smaller size. Either way, after resizing the image and canvas dimensions are once 
again the same. Both concepts are discussed in Changing image and canvas size.

Interacting tools and tabs 

The Tools toolbar is at the heart of PhotoPlus. Among its 
many offerings you'll find several basic painting/drawing 
tools, plus tools for erasing, filling a region, and cloning a 
region).

As you try each of these tools, keep in mind that the Tool Properties tab and Brush Tip tab extend each tool's functionality by 
letting you customize its settings. Only with the aid of the tabs can you choose a wide brush as opposed to a pencil point, or 
experiment with the full range of effects each tool can command. 

Making a selection

 

In any photo editing program, the selection tools are as 
significant as any of the basic brush tools or commands. 
The basic principle is simple: quite often you'll want to 
perform an operation on just a portion of the image.

The wide range of selection options in PhotoPlus lets you:

· Define just about any selection shape

· Modify the extent or properties of the selection

· Carry out various manipulations on the selected pixels, including cut, copy, paste, rotate, adjust colors, apply special effects, 
etc. 

Although the techniques for using each selection tool vary a bit, the end result of making a selection is always the same: a 
portion of the active layer has been roped off from the rest of the image. The boundary is visible as a broken line or marquee 
around the selected region. 

Foreground and background colors

 

At any given time, PhotoPlus allows you to work with two 
colors—a foreground color and a background color. 
These are always visible as two swatches on the Color tab.

Electronic artists expend much of their creative energy deciding which of the millions of available colors should fill those two 
slots. The actual steps involved, however, can be quite simple. Both the simple steps and more complex options (for custom 
color definition) are covered in the topic Choosing colors.

Layers



If you're accustomed to thinking of pictures 
as flat illustrations in books, or photographic 
prints, the concept of image layers may 
take some getting used to.

In a typical PhotoPlus image—for example, a photograph you've scanned in, a new picture file you've just created, or a bitmap 
file you've opened—there is one layer that behaves like a conventional "flat" image. This is called the Background layer, and 
you can think of it as having paint overlaid on an opaque, solid color surface. 

On top of the Background layer, you can create any number of new layers in your image. Each new one appears on top of 
another, comprising a stack of layers that you can view and manipulate with the Layer Manager tab. We call these additional 
layers standard layers to differentiate them from the Background layer. Standard layers behave like transparent sheets through 
which the underlying layers are visible.

There's a third kind of layer, called a text layer, which resembles a standard transparent layer but can only contain text. Text 
layers keep blocks of text editable so you can go back and change the font or retype characters. (For details, see the topic 
Creating text.)

With few exceptions, you will work on just one layer at any given time, clicking in the Layer Manager tab to select the current or 
active layer. Selections and layers are related concepts. Whenever there's a selection, certain tools and commands operate 
only on the pixels inside the selection—as opposed to a condition where nothing is selected, in which case those functions 
generally affect the entire active layer.

If your image has multiple layers, and you switch to another layer, the selection doesn't stay on the previous layer—it follows you 
to the new active layer. This makes sense when you realize that the selection doesn't actually include image content—it just 
describes a region with boundaries. And following the old advice "Don't confuse the map with the territory," you can think of the 
selection as a kind of outline map, and the active layer as the territory.

Opacity and transparency

 

Opacity   and   transparency   are complementary—two sides of the 
same coin. They both refer to the degree to which a particular 
pixel's color contributes to the overall color at that point in the 
image.

Varying opacity is rather like lighting a stage backdrop (scrim) in a theater: depending on how you light the fine gauze sheet, you 
can render the backdrop image either visible or invisible. Fully opaque pixels contribute their full color value to the image. Fully 
transparent pixels are invisible: they contribute nothing to the image.

You'll mainly encounter these terms in two contexts. First, as a property of the pixels laid down by individual paint tools, which 
can be more or less opaque, depending on the tool's opacity setting. Second, as a property of individual layers, where opacity 
works like a "master setting" that you can vary after paint has been laid down.

Saving and exporting

Saving a file in PhotoPlus means storing the image in the 
native PhotoPlus file format, using the .SPP extension. This 
format preserves image information, such as multiple layers, 
masks, or image map data, that would be lost in conversion 
to another graphic format.

On the other hand, suppose you've opened a .BMP or .JPG file and want to save it back to its original format. In this case, use 
the Save Original command.

In yet another instance, you may be ready to save an .SPP file (or convert some other image type) to one of the standard 
graphic formats. In PhotoPlus, this is known as exporting. PhotoPlus include a powerful Export Optimizer that serves as your 
"command center" for exporting images to various formats. It not only provides a variety of options for each supported format, 
but lets you compare image quality using different settings and even retains your preferred settings for each format!



Starting with a new picture or animation

PhotoPlus deals with two basic kinds of image files. We'll differentiate them as pictures (still images) and animations (moving 
images). The two types are closely related, and creating either from scratch in PhotoPlus involves the same series of steps.

To create a new picture or animation:

1 The first time you launch PhotoPlus, you'll see the Startup Wizard, with a menu of six choices. Click Create New Picture or 
Create New Animation.
OR

During your PhotoPlus session, choose New... from the File menu (or click the  New button on the Standard toolbar). If 
the Startup Wizard is turned on, click Create New Picture or Create New Animation.

2 The New Image dialog appears. If the Startup Wizard is turned off, check (or uncheck) the "Animation" box to specify which 
type of image file PhotoPlus should create. 

3 In the dialog, set width, height, and resolution values for the new image file. 
Tip: Although you can resize the image canvas area (width x height) later, it's usually best to allow some extra canvas area at 
first. Leave the resolution at 96 pixels per inch unless you're sure a different value is required.

4 Select a background type in the "Background" drop-down list. 
·    When painting a picture from scratch, you'll normally choose White. 
·    When creating an animation, Transparent is often called for. 
·    You can also choose Background Color, to use the current background color shown on the Color tab.

5 When you've made your selections, click OK.

6 The new image opens in a separate image window.

As you become more accustomed to PhotoPlus menus, you may find you no longer need the Startup Wizard screen.

To turn off the Startup Wizard:

· Choose Preferences... from the File menu, click the Startup tab, and uncheck Use Startup Wizard. 



Acquiring a TWAIN image

If your scanner or digital camera supports the industry-wide TWAIN standard, you can bring pictures from these devices directly 
into PhotoPlus.

To set up your TWAIN device for importing:

· See the documentation supplied with the device for operating instructions. 

To import a TWAIN image:

· The first time you launch PhotoPlus, you'll see the Startup Wizard, with a menu of six choices. Click Import From TWAIN.
OR
During your PhotoPlus session, choose Import from the File menu, then select Acquire. 

· Complete the procedure using the acquisition dialog associated with the selected TWAIN source.

If you have more than one TWAIN-compatible device installed, you may need to select which source you wish to scan with. 

To select a different TWAIN source for scanning:

· Choose Import from the File menu, then select Select Source from the submenu.

More about scanned images...

For line art and halftone images, scan at the highest resolution possible and (if saving) save as a black-and-white TIFF or PCX. 

For photographic images, scan using grayscales and save as a grayscale TIFF file. If you have a color scanner, save a color 
TIFF. You can resize these images and still maintain reasonable quality, provided you don't make them significantly larger than 
the original. In general, the number of grayscales or colors is a more important issue than the actual resolution (dpi).

Scanned images, especially color, can get very large and you need to take this into consideration. Large files take a long time to 
load, save and print and eat your disk space!



Opening an existing file

You can use the Startup Wizard to access image files recently viewed in PhotoPlus, or use a standard file dialog to open any 
image file. PhotoPlus supports all the standard image formats for print and Web graphics, in addition to its native .SPP format.

To open a recently viewed image file using the Startup Wizard:

· On the Startup Wizard screen (at startup time or via File/New...), click Open Saved Work. You'll see a list of recently opened 
files. To see a preview of any file, click its name in the list. 

· To open a selected file, click OK. 
OR 
Click Browse to locate a different file. To narrow or expand the list of file types shown in the Open dialog, select from the 
"Files of type" list. Select the folder and file name and click the Open button.

The image opens in a separate image window.

Note: Recently viewed files also appear at the bottom of the File menu. Simply select the file name to open it.

To open any image file:

· Choose Open... from the File menu. 

OR
Click the  Open button on the Standard toolbar.

· In the Open dialog, select the folder and file name. To open multiple files, press the Ctrl or Shift key when selecting their 
names. To display a thumbnail of each image as its name is selected, check Show preview (this may slow down the display 
somewhat). Note that the dialog also displays image dimensions and bit depth information.

· Click the Open button to open the desired image.

The image opens in a separate image window.



Saving a file

PhotoPlus offers several save/export options, and it's a good idea to learn about all of them...

Saving a file in PhotoPlus means storing the image in the native PhotoPlus file format, using the .SPP extension. This format 
preserves image information, such as multiple layers, masks, or image map data, that would be lost in conversion to another 
graphic format.

On the other hand, suppose you've opened a .BMP or .JPG file, done some editing (without adding layers), and now wish to 
save it back to its original format. In this case, use the Save Original command—but note some limitations below.

In yet another instance, you may be ready to save an .SPP file (or convert some other image type) to one of the standard 
graphic formats. In PhotoPlus, this is known as exporting—and it's covered in the next topic. 

To save the image as a PhotoPlus file:

· To save using the current base name (shown in the window titlebar), choose Save... from the File menu. 

OR 

· Click the  Save button on the Standard toolbar.

OR 

· To save under a different base name, choose Save As... from the File menu. The window titlebar is updated accordingly.

Note: If the current window is untitled or non-native, the Save As dialog appears automatically, using the base name shown in 
the titlebar.

To save the image in its original file format:

· To save using the current base name (shown in the window titlebar), choose Save Original... from the File menu. 

OR 

· To save under a different base name, choose Save Original As... from the File menu. The window titlebar is updated 
accordingly.

Notes:

· If the current image uses features that can only be preserved in the native PhotoPlus (.SPP) format, you'll be given the option 
of doing a native save in addition to the original format save.

· Save Original uses the same file name as, and thus overwrites, the file you originally loaded. Although the file format and 
number of colors (bit depth) will match those of the originally loaded image, other properties may have changed. For example, 
Save Original doesn't preserve the specific colors (palette) used in 256-color images, but applies its own dithered, optimized 
palette. Chances are you'll be quite happy with the results—but for greater control over image properties, you may wish to use 
the Export Optimizer (see next topic).



Exporting to another file format

Exporting an image means converting it to a specified 
graphic file format other than the native PhotoPlus (.SPP) 
format. Note that only the .SPP format preserves image 
information, such as multiple layers, masks, or image map 
data, that would be lost in conversion to another format. 

To learn about saving in the native format, or in the original format of a non-native image, see the previous topic.

For a discussion of basic color concepts in PhotoPlus, see the topic Color concepts. For details on Web graphics, see the topic 
Image formats for the World Wide Web.

PhotoPlus include a powerful Export Optimizer that serves as your "command center" for exporting images to various formats. 
It not only provides a variety of options for each supported format, but lets you compare image quality using different settings 
and even retains your preferred settings for each format! You can access the Export Optimizer at any time—not just at export 
time—to take advantage of its comparison capabilities.

To export an image:

· Choose Export... from the File menu. The Export dialog appears, with the file's current base name shown.

· Change the base name if desired.

· Choose a file format from the "Save as type" drop-down list.

· To open the Export Optimizer to fine-tune export settings, click Optimizer. (See below for details.)

· Click Save.

You can also open the Export Optimizer first and (at your option) proceed to the exporting step after checking your settings.

To open the Export Optimizer directly:

· Choose Export Optimizer... from the File menu. 

The Export dialog includes additional options for use with Web images (see Slicing images and Creating image maps). You also 
have the option of previewing Web images directly in your browser.

To preview an image in your Web browser:

· Choose Preview in Browser... from the File menu. PhotoPlus exports the image as a temporary file, then opens the file for 
preview in your World Wide Web browser.

Using the Export Optimizer

The Export Optimizer consists of a left-hand settings region and a right-hand preview display, with additional buttons along the 
bottom of the dialog. In animation mode, there's an extra tab for changing output settings. (For a discussion of standard settings 
and options, see the subtopic on Optimizing images in the "Color concepts" topic. For additional information on specific Web 
graphics formats, see Image formats for the World Wide Web.)

 

To adjust the preview display:

· Click one of the View buttons to select Single, Double, or Quad display. The multi-pane (Double and Quad) settings let you 
compare different export settings for one or more file formats.

· To change the display scale, click the Zoom In or Zoom Out button. The current ratio appears just to the right of the buttons.



· To display a different portion of the image, drag the image in the active preview pane. 

To compare export settings:

· Set the preview display for either Double or Quad view. 

· Click one of the display panes to select it as the active pane.

· On the Options panel, choose an export format and specific settings. Each time you make a new choice, the active pane 
updates to show the effect of filtering using the new settings, as well as the estimated file size.

· To compare settings, select a different display pane and repeat the process. The Export Optimizer lets you experiment freely 
and "eyeball" the results.

To proceed with exporting:

· Make sure the active preview pane is using the settings you want to apply to the image.

· Click the dialog's Export or OK button to display (or redisplay) the Export dialog. 

Note: The Export Optimizer saves settings for particular formats according to the most recent update to the Options tab. In other 
words, if you have two or more preview windows displaying the same file format, the settings for the last of them you click in will 
be those associated with exporting in that format. 



Printing

For professional printing, PhotoPlus supports scaling, tiling, printer marks, and color separations.

To set up your printer or begin printing:

· Click the  Print button on the Standard toolbar. 

OR

· Choose Print... from the File menu.

The Print dialog appears.

To print:

1. If necessary, click the Properties... button to select a printer or set up the printer for the correct page size, etc.

2. If necessary, click the Options... button to set special print options (see below).

3. Select the number of copies.

4. Click OK. 

The image will be printed in color on a color printer or in shades of gray on a black and white printer.

Note: The printed size depends on the dimensions you've specified in the Image Size dialog (choose Image Size... from the 
Image menu). For details, see the topic Changing image and canvas size.

Setting print options

Use the Layout, Output, and Separations tabs on the Options dialog to select from a range of printing choices. 

Note: Print options are reset each time PhotoPlus is restarted. Changes you make during a session are "remembered" for the 
duration of the session.

Layout tab (scaling and tiling)

The Preview window shows a line view of your publication setup.

· Set the "Scale" option to specify a custom scaling percentage. The default is 100% or normal size. To scale your work to be 
printed at a larger size, specify a larger value; to scale down, specify a smaller value. Select "Reduce to fit" to adjust artwork 
automatically to fit neatly on the printed page.

· Check the "Tile" option to print large (or enlarged) pages using multiple sheets of paper. Each section or tile is printed on a 
single sheet of paper; the various tiles can then be joined to form the complete page. Use this option for printing at larger sizes 
than the maximum paper size of your printer, typically for creating banners and posters. To simplify arrangement of the tiles 
and to allow for printer margins, you can specify an overlap value.

Output tab (file information and printer marks)

· Check boxes to include file information and/or printer marks on the printout. 

Note: The printer page size must be at least 1" x 1" larger than the actual artwork being printed, to ensure that the information is 
entirely visible on the final print. For PostScript printing, the Windows printer driver normally has some "extra" page sizes which 
can be used with standard artwork paper sizes. 

Color Separations tab (CMYK process color)

An offset press needs one independent plate for each color that will print on the job. PhotoPlus will let you print color separations 
which are used when printing the job to an imagesetter. If the job is created properly, you then get, for each page, one complete 
negative for each color.

· Check the "Print Separations" box to specify that color separations are to be printed. This option is only available if the 
currently selected Windows printer is a PostScript printer.

Normally, process color output gives you four sheets or "separations" per publication page: one each for the Cyan, Magenta, 
Yellow, and blacK (CMYK) ink components in the image. Only these color separations will be printed. 

· To select or deselect a color, click on it.

· Select a screen from the drop-down list appropriate for the paper type you'll be using, or choose "Custom" and click the 
Properties button to define a custom screen.



Closing files and exiting

To close a single image window (file):

· Choose Close from the File menu.

OR

· Click the Close button on the window's titlebar.

You'll be prompted to save changes made since the last save.

To close PhotoPlus:

· Choose Exit from the File menu.

For each open file, you'll be prompted to save changes made since the last save.



Working with PhotoPlus windows

PhotoPlus provides a multiple-document interface (MDI) that lets you open more than one image at a time. Each image appears 
in its own image window with the file name displayed in the window's titlebar. The image windows are surrounded by the 
PhotoPlus main window, which includes the toolbars and tab windows (see next topic) and whose titlebar displays the name of 
the active image—the image in the currently selected image window.

The Window menu lets you arrange the open image windows in various ways:

· Click Cascade to arrange the windows as overlapping tiles.

· Click Tile to arrange the windows as non-overlapping tiles. This is a useful mode when you need to make side-by-side 
comparisons of two images.

· Click Arrange Icons to arrange any minimized windows along the bottom of the workspace.

The Window menu also lists the names of open windows, with the current window checked. You can click a window's name, or 
use Alt+W plus the window's number on the menu, to switch into another window.



Working with the toolbars and tabs

The toolbars and tab windows (tabs for short) group together related controls and settings, and are essential features of the 
PhotoPlus environment. This topic provides basic information and tips on how to arrange these elements to best suit your needs. 
(To learn about each toolbar and tab, consult the Visual Reference.)

When you first launch PhotoPlus, it opens 
with the toolbars and tabs all visible in 
default positions, with certain tabs "docked" 
or joined together. You can hide, show, or 
move them individually as needed, and dock 
or undock the tabs.

Chances are you'll want to keep the Tools toolbar visible, but if your display area is large enough you might consider moving it to 
a horizontal position alongside the Standard toolbar—or "floating" it as a separate palette. Remember, there's nothing fixed about 
the PhotoPlus interface, so feel free to try different arrangements until you're satisfied!

To show or hide toolbars and tabs:

· To show/hide a particular toolbar or tab, check or uncheck its item on the View menu. (You can also close any tab window by 
clicking the  Close button on its titlebar.)

· To hide all visible tabs (not toolbars), press the Tab key. Press Tab again to show the tabs.

To move a toolbar:

· Click on a neutral portion of the toolbar and drag to the new position. You can float toolbars anywhere in the main window or 
dock them at the top, bottom, left, or right edge of the window.

· To move a floating toolbar, click on its titlebar and drag to move it.

To resize a floating toolbar:

· Click one of its edges and drag.

To dock/undock a tab:

· Click on the tab's label and drag to the new position, either floating independently or docked in a window next to another tab.

To move a tab window:

· Click on its titlebar and drag to the new position.



Zooming and panning

Zooming (changing the relative size of the image in relation to its window) and panning (moving the image in relation to its 
window) are essential when you're operating at different levels of detail, or on different portions or an image. PhotoPlus provides 
standard Zoom and Pan tools.

To zoom: 

1 Choose the  Zoom tool from the Tools toolbar.

2 To zoom in, left-click on the image. To zoom out, right-click on the image. 

The current zoom ratio appears in the titlebar of the image window, next to the file name.

To select a specific zoom ratio:

· Choose Zoom In or Zoom Out from the View menu and select a ratio from the submenu.

· To restore a 1:1 ratio, choose Normal Viewing from the View menu.

To pan:

Choose the  Pan tool from the Tools toolbar. 
Drag the image to move it in relation to its window.



Using the rulers and grid

 

As an aid to precise alignment and spacing, PhotoPlus 
gives you the option of displaying horizontal and vertical 
rulers, and/or a set of grid lines spaced according to ruler 
gradations. With the rulers turned on, you can track the 
current cursor position by watching the small markers 
that appear along the edges.

To hide or show the rulers:

· Check or uncheck Rulers on the View menu.

To hide or show the grid:

· Check or uncheck Grid on the View menu.

To set display units and grid color/spacing:

· Choose Preferences... from the File menu and select the Layout tab.



Setting PhotoPlus preferences

The Preferences dialog lets you customize a wide range of PhotoPlus settings, including Undo, transparency display, plug-in 
filters, layout options, and the Startup Wizard. As a rule, Preference settings are global—that is, changing them affects all open 
windows, and when you close PhotoPlus, your current Preference settings remain in effect the next time you open the program.

To set PhotoPlus options:

1. Choose Preferences... from the File menu.

2. Click one of the four tabs and set your preferences. Settings include:

3. Undo tab: Set options for the Undo function (see below).
Transparency tab: Set the grid size and colors of the "checkerboard" pattern denoting transparency; double-click a color 
sample to adjust the color.
Layout tab: Set display units for the ruler, and spacing and color for the alignment grid (see the previous topic).
Startup tab: Check or uncheck to set whether the Startup Wizard appears when you start PhotoPlus. We recommend you 
retain the Startup Wizard until you've had a chance to explore PhotoPlus sample files. You can also set the interval at which 
the Online Resources reminder appears, or turn it off. (Note that these resources are also accessible via the Help menu.)

Note on Undo in PhotoPlus:

Unlike most programs, which allow only a limited number of "undo" operations without regard to system resources, the Undo 
function in PhotoPlus actively monitors available system resources in relation to the demands of each operation. This allows you 
thousands of undo's for smaller images! For greatest efficiency, the function intelligently compresses operational data. You can 
use the dialog's slider control to adjust the tradeoff between compression and speed. The memory setting lets you assign a 
certain percentage of system RAM to the undo function (the default is 50%)—adjust this higher or lower depending on the 
demands of the applications currently in use. The disk space setting (default 128MB) allows PhotoPlus to utilize a hard disk 
buffer if the RAM limit is reached, allowing even more undo's. If you use this option, set the value no higher than available disk 
capacity.



Color concepts

It's always difficult to draw a line between concepts you should understand when you're getting started, and those that can wait 
until you absolutely need them. Here we've collected a few key terms and concepts relating to color, and presented them roughly 
in order of priority, trying to keep it simple without oversimplifying. So we suggest you just begin at the beginning, and treat this 
as a reference section you can revisit at any time. 

For a similar treatment of PhotoPlus terms, see An overview of key concepts. For additional information on specific Web 
graphics formats, see Image formats for the World Wide Web.

Bitmaps

First of all, PhotoPlus is all of the following things and more: a "photo editor," a "paint program," a "bitmap editor." It lets you 
create and manipulate images called "bitmaps," "paint-type" images," or "raster graphics." Don't be overwhelmed by the jargon—
all these terms communicate a single concept! Bitmaps (let's settle on that term) are digital pictures (which may or may not be 
photographs) represented by lots of colored dots ("pixels") on a computer screen ("raster"). You create these images by 
"painting" or filling in regions on the screen, regions that can be as small as a single pixel or as large as the whole screen (or 
larger).

Bit depth

A bitmap is basically a bunch (literally a "map") of numbers that tell each dot (pixel) on a computer monitor what color it should 
be. And since computer numbers consist of binary digits (1's and 0's, or "bits"), each pixel in effect has one or more bits backing 
it up, telling it what to do. From this fact arises the concept of bit depth (also known as "pixel depth"), one of the essential 
attributes of any bitmap image. Bitmaps not only have height and width, they have depth. The more bits assigned to each pixel, 
the more possible color states the pixel can be told to take—the greater its "color depth." 

For example: If you're only using 1 bit per pixel, the pixel can only be ON or OFF, in other words "1" or "0," the two states of the 
bit—hence white or black (monochrome). 

 

By comparison, a bit depth of 4 bits per pixel can store 
16 values; 8 bits per pixel, 256, and so on. 16-bit 
images have roughly "thousands" of values to describe 
each pixel's color, and 24-bit images have "millions."

Of course, the appearance of a bitmap on a screen depends not only on the bit depth of the picture but on that of the computer 
screen displaying it. Just a few years ago (in the "old days"), many monitors were limited to 16 colors, and 256 was a big deal. 
There were "VGA" and "SVGA," and today the choices include "High Color" (16 bit) and "True Color." 

Just because you may have a higher-end system, don't forget that many others do not. A 24-bit image with millions of colors may 
look abysmal on a 256-color monitor—a key consideration when it comes to creating graphics for the Web, as opposed to CMYK 
separations for a print publication. In print publishing, designers must worry about whether the colors specified in their electronic 
images will produce "true" output when reproduced in ink, under standard lighting conditions. In Web or CD-ROM publishing, the 
main worry is how to optimize or reduce the file size as far as possible, while maintaining some semblance of quality in the 
image (more about optimizing below). Fortunately, PhotoPlus includes tools to support all these needs.

Bit depth in PhotoPlus

One of the main differences between PhotoPlus and most other paint programs is that we've put aside the restrictive notion of 
working with a limited number of colors. You can work on any image in 24-bit mode, accessing the full color spectrum via the 
Color tab. Native format (.SPP) images are stored in this mode. When and if the time comes to save in a different format, and 
reduce colors, PhotoPlus provides the Export Optimizer for maximum quality control.

While novices will appreciate the ease of use this approach brings, more experienced users may at first need to adjust to the 
absence of color swatches and the constraints of working in 256-color mode. Still, we're confident that the benefits of 
concentrating on image production first, and color reduction last, will soon become apparent!

Tip: You can use the Open dialog to browse images on your system. The dialog displays the bit depth and dimensions (as well 
as an optional preview thumbnail) of any selected image in a supported format. 

Resolution

Bitmaps are created at a fixed resolution, measured in dpi (dots per inch) and hence lose quality if resized upwards. Resizing 
downwards is a different matter, which is why it's always a good idea to scan pictures at higher dpi settings and scale down later. 
The reproduction quality of bitmaps can vary dramatically, and depends on factors such as the dpi stored in the original file, the 
dpi used for reproduction (printing), the bit depth, and the scaling factor used in reproduction. 

High resolution bitmaps compensate for quality problems, but tend to be very large files.

Color modes



The PhotoPlus Color tab includes a control that lets you select one of four color modes: RGB, HSL, CMYK, or Grayscale. You 
should know something about these modes, even if you only have occasion to work in one or two of them. Much of the 
terminology overlaps. Let's consider these, starting with the simplest.

A grayscale image looks like what we would call a "black and white" photograph, which properly speaking has many levels of 
black, white, and gray (not just two, as in a monochrome line drawing). In PhotoPlus, Grayscale mode stores 256 shades of gray 
or levels of lightness. A value of 0 represents pure black, a value of 255 pure white. Sometimes we speak of the "tones" in a 
grayscale image—it's just another word for the different "values" or "lightness levels."

To understand HSL, imagine the difference between watching a TV program on a black and white set as opposed to a color set. 
It's the same color signal, right? But the black and white set doesn't reproduce the color. What it does pick up is the grayscale or 
lightness channel of the signal. In the same way, any color image in PhotoPlus has a channel that stores lightness information: 
the "L" in HSL, which stands for Lightness. To repeat—and this is important when it comes to understanding topics like masking  
—lightness and grayscale values (and for that matter tones, luminance, and brightness) refer to the same basic information. 

The additional Hue and Saturation channels in HSL mode together store all the color information that's missing from a simple 
grayscale image. Like Lightness/Grayscale values, Hue and Saturation channel values are expressed in numbers, ranging from 
0 to 255. (If you're alert, you'll note that 256 is equivalent to 8 bits of information, so H+S+L has three 8-bit channels totaling 24 
bits—which is where the "24" in "24-bit" comes from.)

Hue refers to the color's tint—what most of us think of as rainbow or spectrum colors with name associations, like "blue" or 
"magenta." A color wheel (like the one in the PhotoPlus Adjust Color dialog) is useful for representing the spectrum of hues as a 
continuous cycle, like a clock. The hue "red" is arbitrarily assigned the value 0 at a certain position, and the values run around 
the circle. Saturation describes the color's purity—a totally unsaturated image has only grays. 

RGB mode is much less intuitive than HSL as a method of mixing colors, but it's the standard way of describing colors the way 
they're displayed on computer monitors—as mixtures of separate Red, Green, and Blue components. Anyone who's seen (in a 
museum, perhaps) a demonstration of three projector beams, one of each color, merging to produce a pool of white light, has 
seen a primitive version of the RGB system. On computers, as with the HSL system, 8 bits are used to encode each of the three 
channels, for a total of 24 bits, and with 256 possible levels (0-255) for each channel. An RGB value of "0,0,0" represents pure 
black, while a value of "255,255,255" represents pure white.

To quickly get a feel for the HSL and RGB color mode variables, double-click either the foreground or background color swatch 
on the Color tab and try mixing your own colors using the Adjust Color dialog. (For details, see the subtopic Precise color 
definition in the next topic.)

Finally, CMYK is a color model used for preparing printed work, where ink on paper is the medium that determines color 
reproduction. It's based on the "subtractive" principle by which our perception of a pigment's color depends on the light 
wavelengths it absorbs and reflects. Traditional color printing creates colors by mixing inks and absorbing light, so that your eyes 
can mix the reflected light. 

The four process inks are Cyan, Magenta, Yellow, and Black (Black is referred to as Key). Mix the four process inks, and you get 
black. No ink gives you white (or the color of the paper). In PhotoPlus, the C, M, Y, and K channel values are given percentages, 
from 0 to 100%. PhotoPlus supports CMYK output of process color separations (for details, see the Printing topic).

Color mode tips 

· The color mode setting (on the Color tab) determines how image data gets pasted from the Windows Clipboard—in other 
words, as grayscale values in Grayscale mode, or as full 24-bit color in any of the other modes. 

· If you start editing a layer mask (which represents opacity values by shades of gray), the Color tab switches temporarily to 
Grayscale mode. Applying the Image/Adjust/Grayscale filter, however, doesn't affect the color mode.

· You can use the Color Pickup tool as a probe to read component values in an image. Move the tool around the image and 
watch the HintLine. Depending on the color mode, you'll see a readout of values (R, G, B, H, S, L, O, etc.) under the current 
cursor position. By the way, the "O" represents Opacity. 

Optimizing images

In a perfect world, there would be just one digital picture format that everybody used. Infinite storage capacity and bandwidth 
would allow full-color images to be stored and transmitted instantly, uncompressed... but let's leave that for a sci-fi novel. The 
reality is that at least hundreds of picture formats have been created, with more ever on the way. A dozen or so are currently in 
widespread use among computer professionals. The tradeoff between image quality and file size will remain a fact of life. Hence 
the need to optimize images—that is, achieve the best quality in the least file size, and within whatever other constraints (such 
as number of colors) the job may impose.

PhotoPlus features a powerful Export Optimizer that serves as your "command center" for exporting images to various formats. 
It not only provides a variety of options for each supported format, but lets you compare image quality using different settings 
and even retains your preferred settings for each format. You can access the Export Optimizer at any time—not just at export 
time—to take advantage of its comparison capabilities. While the visual comparisons speak for themselves, some of the 
available settings may need some explanation...

Palettes

The PhotoPlus Export Optimizer offers two standard Palette options when you export using 8 bits or less. A color palette (no 
relation to a "floating" palette) is a table of color values that gets stored with any image having 256 colors or less. This could 



mean a .BMP, .GIF, .PCX, or .WMF image—plus quite a few more. Computer users with high-color monitors may not give it 
much thought, but in the realm of 256-color displays, palettes can make a great deal of difference. Windows itself reserves 
"slots" for its own "system" colors, and each application must "declare" a palette while the graphics system tries to ensure 
peaceful coexistence. When several colorful applications are in use, and you switch from one you another, you sometimes see 
the ghastly result of palettes clashing as neither application wants to relinquish its hold on a scarce system resource. 

To avoid that kind of calamity when displaying Web pages, both Netscape and Microsoft browsers use the same Web-safe 
palette of 216 colors to display images. You may be interested to know that the Web-safe palette is based on RGB values that 
are either 0, or divisible by 51. Permissible values are in the series 0, 51, 102, 153, 204, 255. So, for example, the RGB definition 
"0,102,51" would be a safe Web color, while "0,102,52" would not.

If you're exporting at 256 colors or less, and Web display is not an issue, there's no question you should choose the Optimized 
setting—as a quick side-by-side comparison in the preview window will always confirm. The program will always do a better job 
when it's allowed to select a range of color values that best match those in the 24-bit version, rather than having to apply the 
same 216 colors every time. 

Note: When you open an image that already has an associated palette, PhotoPlus doesn't attempt to hold on to the palette—it 
always re-optimizes, even if you use the Save Original command. Usually this yields the best possible results; but if keeping 
exactly the same image palette is essential to your particular application, our advice would be to export from PhotoPlus in 24-bit 
mode and use a third-party program to apply the palette.

Dithering

Dithering (not to be confused with "showing flustered excitement or fear") comes into play with images being reduced to 256 
colors or less. It's a method of approximating colors outside the actual image palette—for example, by alternating pixels of red 
and blue from within the palette to produce the visual impression of a purple color that's not in the palette. Applications (including 
Web browsers) use dithering in 256-color mode if the images being displayed include colors outside the application palette. This 
can degrade solid-color areas and is one of the main reasons to export Web-bound images using the Web-safe palette.

When you're exporting to 256 colors or less, PhotoPlus lets you choose whether or not to use dithering. If you have an image 
with few colors, and preserving areas of solid color is essential, you should opt for no dithering—and the export filter will pick 
"nearest-match" color values from the palette being applied. You may see some color shifting, but the solid color areas will be 
preserved. For photographic images, on the other hand, dithering is clearly the best choice. With the "optimized palette" option, 
you can choose either ordered or error diffusion dithering. The former produces a discernibly patterned effect, while the latter 
tends to average away the patterns for a more natural result.

 
Compression

Compression schemes, which apply different algorithms to encode the image information with fewer total bits and bytes, are 
used in many formats. With some, like .BMP and .TIF, the Export Optimizer gives you a choice of compression scheme. In 
general, use the default setting unless you know for a fact that some other scheme is called for. 

The .JPG format, widely used for photographs (and detailed in Image formats for the World Wide Web), is unusual in that you 
can set the level of quality desired using a slider. As you might expect, the highest-quality setting uses least compression, with 
no loss of image quality but the largest file size. The lowest-quality setting applies maximum compression for smallest size, but 
yields rather poor quality. With the aid of the Export Optimizer, you can judge for yourself—but another factor to keep in mind is 
the number of times you expect to be re-exporting a particular image. A photograph may look fine the first time you export it at 
JPG level 6, but after several such saves, you'll really see the quality loss. As a rule, keep images in the native .SPP format, or 
export them using only lossless compression schemes, until it's time for the final export.



Choosing colors

At any given time, PhotoPlus allows you to work with just two colors—a foreground color and a background color. These are 
always visible as two swatches on the Color tab:

 Here, for example, the foreground color is gray and the background color is green. Now, a few things to 
remember about how these colors are used:

· When you paint with one of the brush tools, or draw a line or shape, left-dragging (that is, dragging with the left mouse button 
down) applies the foreground color.

· When you cut, delete, or erase an area on the Background layer, the area exposes the background color—as if that color were 
there "behind" the portion of the image being removed. (By the way, layers other than the Background behave differently: on 
these, a removed area exposes transparency.)

· To swap foreground and background colors, click the double arrow next to the Color tab swatches.

Electronic artists expend much of their creative energy deciding which of the millions of available colors should fill those two 
slots. The actual steps involved, however, can be quite simple.

To define foreground and background color:

1. Select the  Color Pickup tool on the Tools toolbar.

2. Left-click with the tool anywhere on an image to "pick up" the color at that point as the new foreground color. (To set a new 
background color, first swap foreground and background colors using the Color tab as noted above.) 
Tip: To switch temporarily to the Color Pickup tool from a paint, line, shape, fill, or text tool, hold down the Alt key, then click 
to define the foreground color.

OR

1. On the Color tab, move the mouse pointer (dropper cursor) around the  Color Spectrum. As you 
move the dropper cursor around the spectrum, the preview swatch above the spectrum shows the color at the cursor 
position.

2. Left-click in the spectrum to set a new foreground color. Right-click to set a new background color. 

OR

1. On the Color tab, click either the foreground or the background swatch. A white border around the box tells you it's selected. 

2. Use the slider(s) or enter numeric values in the boxes to define a specific color. The selected swatch updates instantly.

The Color tab makes it possible to set the working color mode to any one of the following: RGB (Red, Green, Blue); HSL (Hue, 
Saturation, Lightness); CMYK (Cyan, Magenta, Yellow, Black); or Grayscale. (For a discussion of the various color modes, see 
the subtopic Color modes in the previous topic.)

To set the color mode:

· Click the  down arrow on the Color tab and choose from the menu.

Precise color definition

The Adjust Color dialog, which you can access via the Color tab and from other dialogs, provides another way of modifying the 
foreground or background color, and also lets you define and store a set of custom colors using a color wheel. 

To display the Adjust Color dialog from the Color tab:

· Double-click either the foreground or background swatch.

Here's a visual guide to using the Adjust Color dialog:

 

The color wheel displays hues around the outer circle. 

1    Click with the dropper cursor to select a hue. 
The inner square updates to show gradations of saturation 
and lightness for the selected hue. 
2    Click in the square to complete the HSL color definition.

 

Below the color wheel, the sample boxes display the Current 
Color (continuously updated) and the Old Color. 



At the left, six boxes show RGB and HSL values for the 
current color. 

·    To define a color using RGB or HSL values, type new 
values into the boxes. The color wheel displays the new color. 

 
Below the HSL boxes, another box displays the hexadecimal 
value (used in HTML) for the current color.

·    Click OK to confirm the new color definition, or Cancel to 
abandon changes.

 

For quick color selection, you can also define and maintain a 
list of custom colors you use frequently. 

·    To update the current color from your Custom Colors list, 
click a color swatch.

 
·    To add the current color to the swatch panel, click the Add 
Custom button.

 
·    To delete a swatch from the panel, select it and click the 
Delete Custom button.



Painting, drawing, airbrushing, and smudging

PhotoPlus provides three basic painting/drawing tools on the Tools toolbar (see also the following topics on Erasing, Filling a 
region, and Cloning a region):

 Paintbrush tool for drawing freehand lines on the active layer

 Airbrush tool for "spray painting" on the active layer

 Smudge tool for picking up color from the click point and "pushing" it in the brush stroke direction

All three tools work in basically the same way. You can set tool properties including opacity, fade, airbrush pressure, and stylus 
options. (See the Visual Reference topic Tool Properties tab.)

You can also choose a brush tip. The brush tip determines 
the thickness of the drawn line. (See the Visual Reference 
topic Brush Tip tab.)

To use the painting/drawing tools:

1. Select the tool from the Tools toolbar.

2. Change properties, if necessary, on the Tool Properties tab.

3. Choose a brush tip on the Brush tip tab.

4. Drag with the tool on the active layer, holding the left mouse button down to paint in the foreground color. 

Notes and Tips: 

· If there is a selection, the tools only affect pixels within the selected region.

· To draw a "pencil" line, choose a single-pixel brush. 

· To draw straight lines, use the Line tool.

· To switch temporarily to the Color Pickup tool from the Paintbrush or Airbrush tool, press the Alt key. Then left-click to define 
the foreground color, or right-click to define the background color.

· For continuous paint flow, set the Fade property to 0. Non-zero values produce a "dot trail" effect.

· For best results with the Smudge tool (to avoid "dots" on extended strokes), set the brush tip's "Spacing" property to 1.



Erasing

Use the  Eraser tool on the Tools toolbar like a brush, to replace colors in an image either with the 
background color or with transparency. You can set tool properties including opacity, fade, and stylus options, and choose a 
brush tip. (For details, see the Visual Reference topics Tool Properties tab and Brush Tip tab.)

To erase:

1. Select the tool from the Tools toolbar.

2. Change properties, if necessary, on the Tool Properties tab.

3. Choose a brush tip on the Brush tip tab.

4. Drag with the tool on the active layer. On the Background layer, erased pixels expose the current background color. On 
other layers, they expose transparency.

Notes and Tips: 

· If there is a selection, the Eraser tool only affects pixels within the selected region.

· You can also completely remove part of an image by making a selection, then pressing the Delete key.



Filling a region

Flood Fill

The Flood Fill tool      is found on the Tools toolbar. It replaces an existing color region with the 
foreground color. How large a region is "flooded" with the fill color depends on the difference between the color of the pixel you 
initially click and the color of surrounding pixels. 

You can use the Tool Properties tab to set a tolerance value—how much of a color difference the tool looks for. With a low tolerance 
setting, the tool "gives up easily" and only fills pixels very close in color to the one you click (a setting of 0 would fill only pixels of the 
same color; 255 would fill all pixels). As the tolerance increases, so does the tool's effect on pixels further in color from the original 
pixel, so a larger region is flooded.

The Tool Properties tab also includes a "Use All Layers" option. If checked, the Fill tool samples pixels on all layers (both shown 
and hidden) underlying the click point, as if the layers were merged into one. If unchecked, it only samples pixels on the active 
layer. In either case, it only fills pixels on the active layer. 

To apply a flood fill:

1. Select the tool from the Tools toolbar.

2. Set tolerance and layer fill options on the Tool Properties tab.

3. Click with the tool where you want to start the fill. 

Notes and Tips: 

· If there is a selection, the Fill tool only affects pixels within the selected region.

· To switch temporarily to the Color Pickup tool from the Flood Fill tool, press the Alt key. Then left-click to define the foreground 
color, or right-click to define the background color.



Cloning a region

Use the  Clone tool on the Tools toolbar to duplicate part of the active layer.

 

The tool is essentially a high-tech version of a 
"pantograph"—the device with two connected stylus 
points, one that traces an original drawing, the other that 
draws an exact duplicate somewhere else. 

It works like a brush that lets you pick up the image from one place and put it down in another place—even between images. For 
example, you can brush away skin blemishes by cloning some "good skin" over them, or remove an unwanted object from an 
image by extending some foliage to cover it. The tool works well either on large areas, or zoomed-in to the pixel level.

To tell the Clone tool exactly where to start picking up the image, you Shift-click to define a pickup point (let's call it point A). Your 
next click (say, at point B) defines a "putdown" or painting point—and begins the first brush stroke. During the stroke, imagine 
you have one brush picking up the image from point A, while another puts it down at point B. As long as the mouse button is 
down, the A-B distance stays the same, and the two points move as if locked together. The A point—marked by a crosshair 
cursor—follows the stroke of the B brush and the region surrounding A is cloned. 

The Tool Properties tab includes an Aligned option that affects what happens if you use more than one brush stroke. There are 
two possibilities when you click to begin a second stroke: 

 
Aligned

1      The pickup point resets itself at a new point "A," a 
fixed distance form the brush tip—maintaining the same 
separation between the cursors as on the first stroke.

 
Non-aligned

OR

2     The pickup point resets itself to the original point "A."

In the first case (called "aligned" because the two cursors remain in A-B alignment), subsequent brush strokes extend the cloned 
region rather than producing multiple copies. In non-aligned mode, you begin cloning the same pixels all over again from the 
original pickup point. 

To clone a region:

1. Select the tool from the Tools toolbar.

2. Change properties, if necessary, on the Tool Properties tab. For example, reducing the tool's Opacity setting results in a 
"ghosted" copy of the original pixels.

3. Choose a brush tip on the Brush tip tab.

4. To define the pickup origin, Shift-click with the tool. 

5. Click again where you want to start the copy, then drag to paint the copy onto the new location. Repeat as needed. A 
crosshair marks the pickup point, which moves relative to your brush movements.

Notes and Tips: 

· If there is a selection, the Clone tool only affects pixels within the selected region.



Creating text

Use the  Text Tools flyout on the Tools toolbar to select from two text tools. One is for entering solid, 
colorful text on a new layer. In PhotoPlus, solid text is editable: as long as it remains on a separate layer, you can go back and 
change its properties at any time. The other text tool lets you create a selection in the shape of text with which to manipulate 
content on an existing layer.

To create new text:

1. Click the Text Tools button and choose the standard  Text tool. 

2. Click with the tool where you want to insert text (it can be moved later). The Add Text window opens.

3. Type your text into the window.

4. To apply formatting (pointsize, bold/italic, alignment), click the top buttons as needed. Formatting is applied to all the text in 
the window, so you don't need to select the text first.

5. To apply semi-transparent edges to the characters, check the Anti-Aliased box. Anti-aliasing is generally recommended 
with text sizes 14pt or larger.

6. To set text color, click the  Adjust Color button. (For details on using the Adjust Color dialog, see the subtopic Precise 
color definition.) You won't see the effect of the new color until you close the Add Text window.

7. When you're done, click OK. The text appears on a new transparent layer in the image. You can now use the Move tool or 
other tools and commands to manipulate it, just like the contents of any layer.

The Layer Manager tab designates text layers with a  symbol. In order to keep text editable, only one block of text can 
occupy a text layer, and various functions—such as painting functions or the Paste Into Layer command—are disabled on text 
layers. If you cut/copy a text layer and paste it elsewhere as a new layer, it becomes a standard layer and its text is no longer 
editable. To convert any text layer to a standard layer, right-click on the layer name and choose Render Text Layer from the 
menu.

Tip: To switch temporarily to the Color Pickup tool from the Text tool, press the Alt key. Then left-click to define the foreground 
color, or right-click to define the background color.

To edit existing text:

1. On the Layer Manager tab, double-click the name of the text layer to be edited. 
OR
With the text layer to be edited as the active layer, choose the standard 

 Text tool and move the mouse pointer over the text until it changes to the 

 (I-beam) cursor, then click on the text.

The Add Text window appears, with the text block displayed.

2 Make your formatting or color changes and click OK.

To create a text selection:

1. Click the Text Tools button and choose the  Text Selection tool.

2. Click at the location on the image where you want to begin the selection. The Add Text window appears.

3. Type your text into the window and apply formatting, just as when creating solid text.

4. When you're done, click OK. A selection marquee appears on the active layer. In effect, the portion of the layer inside the 
text selection turns into a "fill" for the selection. 

5. You can now cut, copy, move, modify, and apply various effects to the selection. (For details, see the topics Modifying a 
selection and Manipulating a selection.)

Note: Unlike solid text, the text selection doesn't occupy a separate layer. Nor can you edit a text selection after you've created 
it.



Creating straight lines and shapes

In addition to the various brush tools, the PhotoPlus Tools toolbar includes the  Line tool for drawing 
straight lines, and the 

 Shape Tools flyout featuring an assortment of tools for creating rectangles, ellipses, polygons, and other 
shapes. Each shape is adjustable, so you can experiment before committing to a particular figure—with innumerable possibilities!

To draw a straight line:

1. Select the Line tool from the Tools toolbar.

2. Set Tool Properties tab options, such as line weight, as needed.

3. Click and drag to draw a straight line using the foreground color.

4. To constrain the angle of the line to 15-degree increments, hold down the Shift key as you drag.

To create a shape:

1. Click the Shape Tools button's down arrow to display the flyout, then select a shape. (To choose the most recently used 
shape, just click the larger button.) 

2. Set Tool Properties tab options—weight (thickness), opacity, anti-alias, and stylus settings—as needed.

3. Drag out a shape on the image, then adjust the shape's handles to fine-tune it. To constrain the shape's proportions, hold 
down the Ctrl key while dragging.

 

4 When you're satisfied, double-click within the shape to draw it, or click outside the shape to cancel it.

Tip: To switch temporarily to the Color Pickup tool from the Line tool or a shape tool, press the Alt key. Then left-click to define 
the foreground color, or right-click to define the background color.



Making a selection

In any photo editing program, the selection tools are as significant as any of the basic brush tools or commands. The basic 
principle is simple: quite often you'll want to perform an operation on just a portion of the image. The wide range of selection 
options in PhotoPlus lets you:

· Define just about any selection shape (covered in this topic)

· Modify the extent or properties of the selection (see next topic)

· Carry out various manipulations on the selected pixels, including cut, copy, paste, rotate, etc. (see Manipulating a selection) 

Selection tool options

We'll begin by introducing the various selection tools and their common features (click the links for more details on each tool).

 The Standard Selection Tools flyout includes 

 Rectangle, 

 Ellipse, 

 Freehand, and 

 Polygon selection shapes. Choose a tool, then drag on the image to define a selection region. (The 
Polygon Selection tool lets you draw a series of line segments; double-click to close the polygon.)

 The Adjustable Selection Tools flyout provides 16 different variable shapes, including pie, star, arrow, 
heart, spiral, wave, and so on. Choose a tool, drag out a shape on the image, then adjust the handles to fine-tune the shape. 
Double-click within the shape to select the region.

 The Color Selection tool lets you select a region based on the color similarity of adjacent pixels. It works 
much like the fill tool, but the result is a selected region rather than a region flooded with a color. 

With this tool, you can use the Tool Properties tab to set a tolerance value—how much of a color difference the tool looks for. 
With a low tolerance setting, the tool "gives up easily" and only includes pixels very close in color to the one you click (a 
setting of 0 would select only pixels of the same color; 255 would select all pixels). As the tolerance increases, so does the 
tool's effect on pixels further in color from the original pixel, so a larger region is selected.

The Tool Properties tab also includes a "Use All Layers" option. If checked, the Color Selection tool samples pixels on all 
layers (both shown and hidden) underlying the click point, as if the layers were merged into one. If unchecked, it only samples 
pixels on the active layer. In either case, the actual selection only applies to pixels on the active layer.

 The Text Selection tool lets you create a selection in the form of text. Click with the tool to display the Add 
Text dialog. Type your text, format as needed, and click OK.

Selection basics
Although the techniques for using each tool vary a bit, the end result is always the same: a portion of the active layer has been 
roped off from the rest of the image. The boundary is visible as a broken line or marquee around the selected region. 

The cursor over the selection changes to the Move 
Marquee cursor, which lets you reposition just the 
marquee as needed without affecting the underlying 
pixels.

Whenever there's a selection, certain tools and commands operate only on the pixels inside the selection—as opposed to a 
condition where nothing is selected, in which case those functions generally affect the entire active layer. 

 

For example, when there's a selection, the brush tools only work 
inside the selection; the color simply doesn't affect outside pixels. If 
you apply an adjustment from the Image menu, it only affects the 
selected region.

Sometimes the marquee gets in the way—for example, if you're trying to achieve precise alignment in a small area. You can hide 
or show the marquee as you see fit, without altering the selection itself.

· To hide or show the marquee, uncheck or check Show Marquee on the Select menu. 

You may occasionally (especially if the marquee is hidden) find yourself using a tool or command that seems to have no effect... 
it's probably because there's still a selection somewhere, and you're trying to work outside the selection. In this case, just cancel 
the selection.

· To cancel the selection (select nothing), simply click with a selection tool anywhere outside the selection or choose Deselect 
from the Select menu. You can also press Ctrl+D.



The opposite of selecting nothing is selecting everything:

· To select the entire active layer, press Ctrl+A, or choose Select All from the Select menu.

Finally, here's an important point: If your image has multiple layers, and you switch to another layer, the selection doesn't stay on 
the previous layer—it follows you to the new active layer. This makes sense when you realize that the selection doesn't actually 
include image content—it just describes a region with boundaries. And following the old advice "Don't confuse the map with the 
territory," you can think of the selection as a kind of outline map, and the active layer as the territory. Political boundaries may 
change... but the landscape remains. 



Modifying a selection

Once you've used a selection tool to select a region of the active layer (see the previous topic), you can carry out a number of 
additional steps to fine-tune the selection before you actually apply an effect or manipulation to the selected pixels (see next 
topic). This topic deals with these ways of modifying the selection.

Moving the selection (marquee)

Sometimes, for example with a text selection, you need to adjust the position of the marquee without affecting the underlying 
pixels. Any time you're using one of the selection tools, the cursor over a selected region changes to the 

 Move Marquee cursor. This indicates you can drag the marquee outline to reposition it. 
Bear in mind the distinction between the "selection" as an outline, and the image content inside the selection. You'd use the Move 
tool to drag the image content around, as covered in the next topic. 

Tip: As a shortcut if you're working with any one of the selection tools, you can press the Ctrl key to switch temporarily to the 
Move tool. Press Ctrl+Alt to duplicate. Release the key(s) to revert to the selection tool.

Making the selection larger or smaller

If the selection you've made isn't quite the right shape, or doesn't quite include all the necessary pixels (or perhaps includes a 
few too many), you can continue to use the selection tools to add to, or subtract from, the selected region.

To add to the existing selection with a selection tool:

· Select the tool and drag while holding down the Shift key. The newly selected pixels don't have to adjoin the current selection
—it's possible to select two or more separate regions on the active layer.

To subtract from the existing selection with a selection tool:

· Select the tool and drag while holding down the Alt key.

The Modify item on the Select menu provides a submenu with several functions that can save you the trouble of hand-drawing 
to change the selection boundaries:

· Choose Contract... to shrink the borders of the selection, or Expand... to extend its borders. Each command displays a dialog 
that lets you enter a specific pixel value. 

· Grow and Similar both expand the selection by seeking out pixels close (in color terms) to those in the current selection. 
Grow only adds pixels adjacent to the current selection, while Similar extends the selection to any similar pixels in the active 
layer. 
Both commands use the tolerance setting entered for the Color Selection tool on the Tool Properties tab; this determines how 
much of a color difference the tools look for. With a low tolerance setting, they only include pixels very close in color to those 
already selected. As the tolerance increases, a larger region is selected. Typically when using these tools, you'll start by 
selecting a very small region (the particular color you want to "find" in the rest of the image).

Anti-aliasing and feathering

Anti-aliasing and feathering are different ways of controlling what happens at the edges of a selection. Both produce softer 
edges that result in smoother blending of elements that are being combined in the image. You can turn either option on or off for 
the Standard and Adjustable Selection tools, using the check boxes on the Tools Properties tab. 

· Anti-aliasing works as for the Line tool, producing smooth edges by making the selection's edge pixels semi-transparent. (As 
a layer option, it's not available on the Background layer, which doesn't support transparency.) 

· Feathering reduces the sharpness of a selection's edges, creating a smooth transition to the surrounding area, You can apply 
feathering "after the fact" to an existing selection (but before applying any editing changes) using the Select menu's Feather... 
command. In the dialog, enter the width (in pixels) of the transition area. A higher value produces a wider, more gradual fade-
out. 

Inverting the selection

The Invert command on the Select menu (shortcut Ctrl+Shift+I) selects the portion of the active layer outside the current 
selection. Unselected pixels become selected, and vice versa. 



Manipulating a selection

Once you have selected precisely the pixels you want to work on (as explained in the two previous topics), the question arises, 
what can you do with the selection—or technically speaking, with the pixels you've outlined? This topic will provide some basic 
answers. 

Note: A great many PhotoPlus adjustments and effects can be applied directly to selections. (See the several following topics as 
well as those in the section on How to Apply Image Effects.)

Using the Move tool

The  Move tool (unlike the Move Marquee cursor associated with the selection tools) is for pushing 
actual pixels around. With it, you can drag the content of a selection from one place to another, rather than just moving the 
selection outline. To use it, simply click on the selection and drag to the new location. The selected part of the image moves also.

· If nothing is selected, dragging with the Move tool moves the entire active layer.

 

n The "hole" left behind when the image content is 
moved exposes the current background color (on the 
Background layer), or transparency (on standard 
layers), shown with a "checkerboard" pattern.

· To duplicate the contents of the selection on the active layer, press the Alt key and click, then drag with the Move tool. 

· As a shortcut if you're working with any one of the selection tools, you can press the Ctrl key to switch temporarily to the Move 
tool. Press Ctrl+Alt to duplicate. Release the key(s) to revert to the selection tool.

Cut/Copy/Delete/Paste

Cut and copy operations involving the Clipboard work just as in other Windows programs. 

· To copy pixels in the selected region, press Ctrl-C or click the  Copy button on the Standard toolbar. 
(You can also choose Copy from the Edit menu.)

· To cut the selected pixels, press Ctrl-X or choose Cut from the Edit menu.

· To delete the selected pixels, press the Delete key or choose Clear from the Edit menu.

Note: Cut or deleted pixels expose the current background color (on the Background layer) or transparency (on standard layers) 
with transparency. If you want to create transparency on the Background layer, first "promote" it to a standard layer by right-
clicking its name on the Layer Manager tab and choosing Promote to Layer.

· If nothing is selected, a cut or copy operation affects the whole active layer, as if Select All were in effect.

When pasting from the Clipboard, PhotoPlus offers several options.

· To paste as a new image in an untitled window, press Ctrl+V or click the  Paste button on the 
Standard toolbar. (You can also choose Paste> As New Image from the Edit menu.)

· To paste as a new layer in the current image, press Ctrl+L or choose Paste> As New Layer from the Edit menu.

· To paste into the current selection, press Shift+Ctrl+L or choose Paste> Into Selection from the Edit menu. The Clipboard 
contents appear centered in the currently selected region. (This choice is grayed out if there's no selection, or if the active 
layer is a text layer.)

· To duplicate part of the active layer on the same layer, press the Alt key and click, then drag with the Move tool. (Or if you're 
working with a selection tool, press Ctrl+Alt and drag to duplicate.)

Creating a mask from a selection

Masking is a relatively advanced technique that's described in detail in the topic Basics of using masks. In brief, masks let you 
paint on, adjust, or otherwise manipulate any standard layer without permanently affecting it. Just as a selection is a "map" 
outlining a region of pixels, a mask is a map of variations in opacity. 

For example, a very simple mask might look like a 100% opaque rectangle blocking the whole layer, but with a 100% transparent 
"hole" in the middle. With the mask enabled, painting on the layer would only affect pixels inside the "hole." In this case, the 
mask would function much like a selection—pixels outside the "hole" region would be unaffected.

Suffice it to say that a selection, which lets you isolate specific parts of the active layer, often makes an ideal basis for a mask. 
Once you've created, modified, and manipulated a selection, it's easy to turn it into a mask.

To create a mask from a selection:

1. Choose Add Mask from the Layers menu.

2. To create a mask revealing the selected region, choose Reveal Selection from the submenu. Pixels outside the selection will 



be 100% masked.
OR
To create a mask hiding the selected region, choose Hide Selection from the submenu. Pixels outside the selection will be 
revealed.



Changing image and canvas size

Changing the image size (top example below) means scaling the whole image (or just a selected region) up or down. Resizing is 
actually a kind of distortion because the image content is being stretched or squashed. However, especially when downsizing, 
the distortion is subtle because the program does a good job of resampling the image—that is, recalculating how to distribute 
the image pixels. 

 Changing the canvas size (bottom example) just involves 
adding or taking away pixels around the edges of the image. It's 
like adding to the neutral border around a mounted photo, or 
taking a pair of scissors and cropping the photo to a smaller 
size. In either case, the remaining image pixels are undisturbed 
so there's no distortion.

Note that once you've changed either the image size or the canvas size, the image and canvas are exactly the same size again!

Changing image size

The Image Size dialog lets you specify a new size for the whole image, in terms of its screen dimensions and/or printed 
dimensions.

To resize the whole image:

1. Choose Image Size... from the Image menu.

2. To specify just the printed dimensions, uncheck Resize layers. Check the box to link the Pixel Size (screen) settings to the 
Print Size settings.

3. To retain the current image proportions, check Maintain aspect ratio. Uncheck the box to alter the dimensions 
independently.

4. If adjusting screen dimensions:
· Select a preferred scale (either "Pixels" or "Percent") in the drop-down list.
· Select a resampling method. As a rule, use Nearest Pixel for hard-edge images, Bilinear Interpolation when shrinking 
photos, and Bicubic Interpolation when enlarging photos.

5. If adjusting printed dimensions, select your preferred units of measurement and resolution.

6. Enter the new values and click OK.

Changing canvas size

PhotoPlus provides several ways of changing the canvas size. If you just want to reduce the canvas area, you can use the Crop 
tool or the Image/Crop to Selection command. To either enlarge or reduce the canvas, the Image/Canvas Size... command 
provides a dialog that lets you specify where pixels should be added or subtracted.

To crop the image with Crop tool:

1. Select the  Crop tool from the Tools toolbar.

2. Drag out a rectangle and adjust the edges as needed. To constrain the region to a square, hold down the Ctrl key while 
dragging.

3. Double-click in the rectangle to crop to the designated size.

Note: Cropping with the Crop tool affects all image layers. Everything outside the designated region is eliminated. If there's a 
marquee-based selection, it is ignored and deselected during cropping.

To crop the image to the selection:

· Choose Crop to Selection from the Image menu.

Note: Cropping to the selection affects all image layers. Everything outside the selected region is eliminated.

To use the Canvas Size dialog:

1. Choose Canvas Size... from the Image menu.

2. Enter new Width and/or Height values (the current values are also shown for comparison).

 

3 In the Anchor box, click to position the image thumbnail with respect 
to edges where pixels should be added or subtracted. For example, if 
you want to extend the canvas from all sides of the image, click the 
center anchor point.

4 Click OK.



Note: If the canvas size is increased, the new canvas area is filled (on the Background layer) with the current background color 
and (on standard layers) with transparency.



Flipping and rotating

Flipping and rotating are standard manipulations that you can carry out on the whole image, the active layer, or just on a 
selection. Flips are used to change the direction of a subject's gaze, fix composition, and so on. Among other things, rotating can 
restore proper vertical alignment in a scanned image that wasn't aligned correctly on the scanner. In PhotoPlus, flipping is carried 
out with a single menu command, while rotating involves using a dialog.

To flip:

· Choose either Flip Horizontally or Flip Vertically from the Image menu, then select Image, Layer, or Selection from the 
submenu.

To rotate:

1 Choose Rotate... from the Image menu. 

2 In the Rotate dialog, set the rotation angle (90, 180, or 270 degrees, or enter a custom angle) and the direction (clockwise or 
counter-clockwise).

Select Image, Layer, or Selection and click OK. 



Adjusting image colors
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The PhotoPlus Image menu includes a wide variety of color adjustment functions that you can apply to the active layer or to a 
selection. Some adjustments—to brightness, contrast, hue, and so on—are usually carried out in order to improve a deficient 
image, while others fall more into the category of special effects (see also the topic Applying special effects). The histogram is a 
window that displays statistics and image color values, helping you to evaluate the kinds of image adjustments that may be 
needed.

For an introduction to PhotoPlus color concepts and terminology, see the topic Color concepts.

Note: This Help Topics window includes subtopics (as shown by the menu links above) that explain each color adjustment 
function. The Effects Gallery window is designed to work in conjunction with these subtopics, providing "before/after" 
illustrations for each one. Clicking the green links in either window brings up help topics, while clicking red links displays Gallery 
examples. 



Brightness/Contrast adjustment
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

Brightness refers to overall lightness or darkness, while contrast describes the tonal range, or spread between lightest and 
darkest values. This is a "quick and dirty" way of correcting an image, for example one that was not properly scanned. 

To adjust Brightness and Contrast:

1. Choose Adjust from the Image menu, then select Brightness/Contrast... from the submenu. The Brightness and Contrast 
Filter dialog appears.

2. Adjust the Brightness slider left or right to lower or raise brightness (as a percentage from -100 to +100). Adjust the Contrast 
slider to lower or raise contrast (also as a percentage). The active layer or selection updates each time you release the 
mouse button. (You can also select a slider and use the keyboard arrows.)

3. Click OK to apply the adjustment, or Cancel to abandon changes.



Hue/Saturation/Lightness adjustment
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

Hue, saturation, and lightness are components of a standard color model that's used (along with RGB and other models) to 
identify colors. Generally speaking, Hue refers to the color's tint—what most of us think of as rainbow or spectrum colors with 
name associations, like "blue" or "magenta." Saturation describes the color's purity—a totally unsaturated image has only grays. 
Lightness is what we intuitively understand as relative darkness or lightness—ranging from full black at one end to full white at 
the other. The Hue/Saturation/Lightness adjustment lets you alter these components independently.

You can use the filter to also colorize an image (typically a grayscale image) by adjusting only its hue. 

For a firsthand look, experiment with the separate Hue, Saturation, and Lightness sliders in the dialog and compare the "Before" 
and "After" spectrum bars. 

To adjust Hue, Saturation, and Lightness:

1. Choose Adjust from the Image menu, then select Hue/Saturation/Lightness... from the submenu.

2. Adjust the Hue slider left or right to change the hue (values range from -180 to +180). Adjust the Saturation slider to change 
saturation (-255 to +255). Adjust the Lightness slider to change lightness (-255 to +255). The active layer or selection updates 
each time you release the mouse button. (You can also select a slider and use the keyboard arrows.)

3. To add color to a grayscale image, check Colorize and adjust the Hue slider (Saturation and Lightness are disabled).

4. Click OK to apply the adjustment, or Cancel to abandon changes.

Tip: You can use the Color Pickup tool to probe actual brightness levels in an image. On the Color tab, switch to the HSL color 
mode, then observe the HintLine's "L" (Lightness) value as you move the Color Pickup tool around.



Replace Color adjustment
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The Replace Color adjustment is used mainly for color correction. You can "tag" one or more ranges of the full color spectrum 
that require adjustment in the image, then apply variations in hue, saturation, and/or brightness to just those color regions. 

To replace color:

1. Choose Adjust from the Image menu, then select Replace Color... from the submenu. The Replace Color Filter dialog 
appears, with the image visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only. 

3. To view the in-range regions of the image, check Show Selected Regions. In-range areas appear as white, those out of 
range as black. (Before you've tagged a color range, the entire preview window will appear white.)

4. Click the  Initial Colors button and then drag across a section of the image to tag a color range. A scroll bar appears 
below the Color Range spectrum bars, showing which portion of the color spectrum has been tagged.

5. To tag additional color ranges, click the  Add Colors button and again drag across a section of the image. An additional 
scroll bar appears with each selection.

6. Drag the Hue, Saturation, and Brightness sliders (or enter specific values) to adjust the tagged color ranges. Each time you 
release the mouse button, the lower spectrum bar updates, providing a before/after comparison, and the preview window 
shows the effect on the image. (You can also select a slider and use the keyboard arrows.)

7. You can drag the Color Range scroll bars and buttons as needed to fine-tune the tagged colors.

8. Click OK to apply the adjustment, or Cancel to abandon changes.



Gamma adjustment
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

Without getting too technical, gamma describes a curve comparing how evenly darks and lights from some source, such as an 
image, are reproduced in some other form, such as a computer display. A gamma of 1.0 describes a "perfect" straight line—no 
portion of the brightness range is being accentuated or diminished. Because the phosphors on computer screens don't respond 
in a straight-line way across the brightness range, computer monitors can introduce a certain amount of gamma distortion. 
Sometimes the distortion is worse in one channel (e.g. red) than another (e.g. blue).

Gamma adjustment in the image itself can compensate for the effect of a particular monitor (or perhaps an error introduced by 
an artist working on an uncalibrated monitor). The corrected image will appear truer to the depicted scene or original picture. The 
PhotoPlus Gamma Correction Filter dialog lets you vary the distribution of lightness values in the red, green, and blue channels, 
either separately or linked. 

To adjust gamma:

1. Choose Adjust from the Image menu, then select Gamma... from the submenu. The Gamma Correction Filter dialog 
appears, with the image visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the 
current layer only, check Preview Current Layer Only.

3. The dialog initially displays a gamma curve of 1.0 for all three channels. To adjust the gamma in a single channel, drag its 
slider and a separate curve appears. To adjust the channels together, check the Link Channels box. The resulting change 
appears in the preview window. (You can also select a slider and use the keyboard arrows.)

4. Click OK to apply the adjustment, or Cancel to abandon changes.



Threshold and Grayscale adjustments
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The Threshold and Grayscale adjustments both remove color information from the active layer or selection.

· The Threshold adjustment lets you quickly create a monochromatic (black and white) rendering. You can adjust the threshold 
(transition point between black and white) while viewing a plot of brightness levels. Besides being a nice special effect, you 
can use the dialog without actually applying the adjustment, just as a way to quickly identify the darkest and lightest portions of 
the image—not always easy to judge in full color.

· The Grayscale adjustment retains light and dark variations, yielding a 256-shade grayscale rendering.

To convert to monochromatic (with threshold adjustment):

1. Choose Adjust from the Image menu, then select Threshold... from the submenu. The Threshold Filter dialog appears, 
and the active layer or selection is immediately converted to a monochrome rendering using an estimated threshold value.

2. Drag the slider left or right to adjust the threshold value if necessary. The current threshold value appears at the upper right, 
and the image updates. (You can also enter a new value directly into the box.)

3. Click OK to apply the adjustment, or Cancel to abandon changes.

To convert to grayscale:

· Choose Adjust from the Image menu, then select Grayscale. (No dialog appears.)



Equalization and Stretch adjustments
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch 
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The Equalization and Stretch adjustments work without dialogs to normalize the distribution of brightness levels in the active 
layer or selection. Both commands affect the image histogram.

· Equalization applies a filter that evenly distributes the lightness levels between existing bottom (darkest) and top (lightest) 
values. It evens out "bumps" or "dips" in the histogram.

· Stretch applies a filter that establishes new bottom and top values and spreads out the existing lightness levels between them. 
It extends the histogram's distribution.

To equalize:

· Choose Adjust from the Image menu, then select Equalization from the submenu.

To stretch:

· Choose Adjust from the Image menu, then select Stretch from the submenu.

Tip: You can use the Color Pickup tool to probe actual lightness levels in an image. On the Color tab, switch to the HSL color 
mode, then observe the HintLine's "L" (Lightness) value as you move the Color Pickup tool around.



Negative Image adjustment
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The Negative Image adjustment inverts each color in the active layer or selection, replacing it with an "opposite" value. It can be 
used as a special effect, or for creating a positive image from a scanned photographic negative.

To apply the Negative Image adjustment:

· Choose Adjust from the Image menu, then select Negative Image from the submenu.



Reading the histogram
Brightness/Contrast Hue/Saturation/Lightness Replace Color
Gamma Threshold & Grayscale Equalization & Stretch
Negative Image Histogram
                                        — Click green for help topic, red for Image Gallery —

The Histogram window provides image statistics and a graph of the distribution of Red, Green, Blue, or Lightness (luminance) 
values in the active layer or selection. The histogram doesn't carry out any adjustments by itself, but it is useful for evaluating the 
kinds of image adjustments that may be needed. For example, you can see at a glance if true "bottom" and "top" (dark and light) 
values are present. If not, you may wish to apply the Stretch adjustment.

To read the histogram:

· Choose Histogram... from the Image menu.

· Select Red, Green, Blue, or Lightness channel display. The window shows the distribution of color values in the channel. For 
each Level of gray (from 0-255), the height of the curve shows the number of pixels (Count) at that level.

· Read image statistics below the value window. 
· The count and level readout updates at the right as you move the mouse pointer over the distribution, showing the pixel 
count at each gray level.
· The Mean is the average lightness (brightness or luminance) value in the distribution.
· The Standard Deviation reflects the average difference of all pixels from the mean value. In general, a higher number 
indicates a wider spread. (Usually the curve's general shape is enough to convey what you need to know about how lightness 
values are distributed.) 
· Pixels equals the total number of pixels in the image or selection. 



Applying special effects
Blur & Sharpen Edge Noise Solarize & 

Posterize Emboss Mosaic 
                — Click green for help topic, red for Image Gallery —

The PhotoPlus Image menu includes a number of commands that apply special effects to the active layer or selection. As with 
the image adjustment filters (see the topic Adjusting image colors), you can use these effects to improve the image, but more 
often the emphasis here is on the wild and wacky (or shall we say, creative) possibilities.

By the way, if you missed the introduction to PhotoPlus color concepts and terminology, see the topic Color concepts.

Note: This Help Topics window includes subtopics (as shown by the menu links above) that explain each special effect. The 
Effects Gallery window is designed to work in conjunction with these subtopics, providing "before/after" illustrations for each 
one. Clicking the green links in either window brings up help topics, while clicking red links displays Gallery examples.



Blur and Sharpen effects
 Blur & Sharpen    Edge Noise  Solarize 
& Posterize Emboss Mosaic 

                — Click green for help topic, red for Image Gallery —

Basic Blur

The Blur effect smoothes the active layer or selection by softening hard edges and contours with abrupt color transitions.

To apply the effect:

1. Choose Blur from the Image menu, then select Blur... from the submenu. The Blur Filter dialog appears, with the image 
visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the 
current layer only, check Preview Current Layer Only.

3. Adjust the Intensity slider (or enter a specific value from 0 to 40) to vary the effect, as the preview window updates. (You 
can also select the slider and use the keyboard arrows.)

4. Click OK to apply the effect, or Cancel to abandon changes.

Gaussian Blur

The Gaussian Blur effect smoothes the active layer or selection by averaging pixels using a weighted curve. It's especially 
useful for removing a moiré (interference) pattern from scanned images.

To apply the effect:

1. Choose Blur from the Image menu, then select Gaussian Blur... from the submenu. The Gaussian Blur Filter dialog 
appears, with the image visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the 
current layer only, check Preview Current Layer Only.

3. Adjust the sliders (or enter specific values) to vary the effect as the preview window updates. (You can also select a slider 
and use the keyboard arrows.)
· Radius (0 to 100) controls the amount of blurring. 
· Falloff (0 to 100%) controls the degree of weighting or localization of the effect, as shown in the inset graph.

4. Click OK to apply the effect, or Cancel to abandon changes.

Soften

The Soften effect works without a dialog to apply a subtle blurring effect in a single pass. You can repeat the effect for increased 
softening. 

To apply the effect:

· Choose Blur from the Image menu, then select Soften from the submenu. 

Motion Blur

The Motion Blur effect applies straight streaks to the image to simulate the effect of camera or subject movement.

To apply the effect:

1. Choose Blur from the Image menu, then select Blur Effects... from the submenu. The Blur Effects Filter dialog appears, with 
the image visible in the preview window.

2. Select Motion as the Blur Type.

3. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

4. Adjust the Intensity slider (or enter a specific value from 0 to 40) to control the amount of blurring as the preview window 
updates. (You can also select the slider and use the keyboard arrows.)

5. Adjust the dial at the lower right to control the direction of the effect.

6. Click OK to apply the effect, or Cancel to abandon changes.

Radial Blur

The Radial Blur effect applies concentric streaks to the image to simulate a rotating camera or subject.



To apply the effect:

1. Choose Blur from the Image menu, then select Blur Effects... from the submenu. The Blur Effects Filter dialog appears, with 
the image visible in the preview window.

2. Select Radial as the Blur Type.

3. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

4. Adjust the Intensity slider (or enter a specific value from 0 to 40) to control the amount of blurring as the preview window 
updates. (You can also select the slider and use the keyboard arrows.)

5. Adjust the dial at the lower right to control the direction of the effect.

6. Click OK to apply the effect, or Cancel to abandon changes.

Zoom Blur

The Zoom Blur effect applies converging streaks to the image to simulate a zoom lens.

To apply the effect:

1 Choose Blur from the Image menu, then select Blur Effects... from the submenu. The Blur Effects Filter dialog appears, with 
the image visible in the preview window.

2 Select Zoom as the Blur Type.

3 To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

4 Adjust the Intensity slider (or enter a specific value from 0 to 40) to control the amount of blurring, as the preview window 
updates. (You can also select the slider and use the keyboard arrows.)

5 Adjust the dial at the lower right to control the direction of the effect.

6 Click OK to apply the effect, or Cancel to abandon changes.

Fragment

The Fragment Blur effect breaks up the image to simulate a jittery hand-held camera.

To apply the effect:

1. Choose Blur from the Image menu, then select Blur Effects... from the submenu. The Blur Effects Filter dialog appears, with 
the image visible in the preview window.

2. Select Fragment as the Blur Type.

3. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

4. Adjust the Intensity slider (or enter a specific value from 0 to 40) to control the amount of blurring, as the preview window 
updates. (You can also select the slider and use the keyboard arrows.)

5. Adjust the dial at the lower right to control the direction of the effect.

6. Click OK to apply the effect, or Cancel to abandon changes.

Sharpen

The Sharpen effect enhances differences between adjacent pixels of different colors. 

To apply the effect:

1. Choose Other from the Image menu, then select Sharpen... from the submenu. The Sharpen Filter dialog appears, with the 
image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Intensity slider (or enter a specific value from -100 to +100) to vary the degree of sharpening, as the preview 
window updates. (You can also select the slider and use the keyboard arrows.)

4. Click OK to apply the effect, or Cancel to abandon changes.



Edge effects
Blur & Sharpen Edge Noise Solarize & 
Posterize Emboss Mosaic 

                — Click green for help topic, red for Image Gallery —

Enhance Edges

The Enhance Edges effect locates and emphasizes both vertical and horizontal edges in the active layer or selection.

To apply the effect:

· Choose Edges from the Image menu, then select Enhance Edges from the submenu. 

Find Horizontal

The Find Horizontal Edges effect isolates horizontal edges in the active layer or selection.

To apply the effect:

· Choose Edges from the Image menu, then select Find Horizontal from the submenu. 

Find Vertical

The Find Vertical Edges effect isolates vertical edges in the active layer or selection.

To apply the effect:

· Choose Edges from the Image menu, then select Find Vertical from the submenu. 

Find All

The Find All Edges effect isolates all edges in the active layer or selection.

To apply the effect:

· Choose Edges from the Image menu, then select Find All Edges from the submenu. 



Noise effects
Blur & Sharpen Edge Noise Solarize & 
Posterize Emboss Mosaic 

                — Click green for help topic, red for Image Gallery —

Add Noise

The Add Noise effect introduces pixels with randomly distributed color levels into the active layer or selection, increasing 
graininess.

To apply the effect:

1. Choose Noise from the Image menu, then select Add... from the submenu. The Noise Filter dialog appears, with the image 
visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Percentage slider (or enter a specific value from 0 to 100) to control the amount of noise added, as the preview 
window updates. (You can also select the slider and use the keyboard arrows.)

4. Adjust the dial at the lower right to control the direction of the effect.

5. Click OK to apply the effect, or Cancel to abandon changes.

Median Cut

The Median Cut effect broadens color regions in the image, introducing an "oil paint" effect.

To apply the effect:

1. Choose Noise from the Image menu, then select Median Cut... from the submenu. The Median Filter dialog appears, with 
the image visible in the preview window.

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Intensity slider (or enter a specific value from 0 to 40) to control the amount of noise added, as the preview 
window updates. (You can also select the slider and use the keyboard arrows.)

4. Adjust the dial at the lower right to control the direction of the effect.

5. Click OK to apply the effect, or Cancel to abandon changes.



Solarize and Posterize effects
Blur & Sharpen Edge Noise Solarize & 
Posterize Emboss Mosaic 

                — Click green for help topic, red for Image Gallery —

Solarize 

The Solarize filter is similar to the Negative Image function, but lets you set the lightness value above which colors are inverted 
in the active layer or selection. 
(Solarization is a darkroom technique in which a partially developed image is re-exposed to light, producing dramatic changes in 
mid-tone regions.)

To apply the effect:

1. Choose Other from the Image menu, then select Solarize... from the submenu. The Solarize Filter dialog appears, with the 
image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Threshold slider (or enter a specific value from 0 to 255) to control the lightness above which colors are inverted, 
as the preview window updates. At a value of 0, the effect is the same as the Negative Image function. (You can also select 
the slider and use the keyboard arrows.)

4. Click OK to apply the effect, or Cancel to abandon changes.

Posterize

The Posterize filter reduces the number of lightness levels in each color channel, painting the active layer or selection in fewer 
colors with more abrupt color boundaries. 

To apply the effect:

1. Choose Other from the Image menu, then select Posterize... from the submenu. The Posterize Filter dialog appears, with 
the image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Levels slider (or enter a specific value from 2 to 64) to control the number of color levels, as the preview window 
updates. (You can also select the slider and use the keyboard arrows.)

4. Click OK to apply the effect, or Cancel to abandon changes.



Emboss effect
Blur & Sharpen Edge Noise Solarize & 
Posterize Emboss Mosaic 

                — Click green for help topic, red for Image Gallery —

The Emboss filter re-maps contours to simulate a bas-relief effect in the active layer or selection. 

To apply the effect:

1. Choose Other from the Image menu, then select Emboss... from the submenu. The Emboss Filter dialog appears, with the 
image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Depth slider (or enter a specific value from 0 to 100) to control the intensity of the effect, as the preview window 
updates. (You can also select a slider and use the keyboard arrows.)

4. Adjust the dial at the lower left to control the Direction of the effect.

5. Click OK to apply the effect, or Cancel to abandon changes.



Mosaic effect
Blur & Sharpen Edge Noise Solarize & 
Posterize Emboss Mosaic

                — Click green for help topic, red for Image Gallery —

The Mosaic filter breaks the active layer or selection into blocks of uniform color for a tiled appearance. 

To apply the effect:

1. Choose Other from the Image menu, then select Mosaic... from the submenu. The Mosaic Filter dialog appears, with the 
image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. Adjust the Tile Size slider (or enter a specific value from 0 to 40) to control the size of same-color blocks, as the preview 
window updates. (You can also select the slider and use the keyboard arrows.)

4. Click OK to apply the effect, or Cancel to abandon changes.



Defining custom filters

In addition to using the built-in set of PhotoPlus filters, you can define your own using the Custom Filter dialog. User-defined 
filters use a process called convolution to alter the lightness value of each image pixel, one at a time. You plug in numbers that 
specify exactly how each pixel's value will change, and how neighboring pixel values are taken into account.

Each pixel's starting value can be multiplied, divided, added to, or subtracted from. The dialog includes a matrix that lets you 
enter different multipliers for the target pixel and its neighbors, so the new calculated value for the target pixel is the sum of the 
math carried out on both it and its neighbors.

Let's run through the steps involved, and then look at an example...

To apply a custom filter:

1. Choose Custom... from the Image menu. The Custom Filter dialog appears, with the image visible in the preview window. 

2. To see a different part of the image, drag it with the hand cursor. Click the Zoom buttons to zoom in or out. To view the current 
layer only, check Preview Current Layer Only.

3. To apply a custom filter, click its name in the Custom Filters list. Initially, one custom filter (Sample Blur) appears there. Click 
OK.

To modify or define a new custom filter:

1. Open the Custom Filter dialog.

2. To modify an existing filter, click its name in the Custom Filters list. To define a new filter, click the  New Filter button. 
(To delete a selected filter, click the 

 Delete Filter button.)

3. Type a name for the new filter in the Filter Name box and click elsewhere to enter it in the list. All values are reset to 0.

4. Enter new Filter Matrix, Divisor, and/or Bias values (see "Filter Math" below), as the preview window updates. 

5. When you're done entering values, click OK to apply the new filter to the active layer or selection, or Cancel to close the 
dialog without applying the filter. Either way, any newly defined filters are saved.

Filter Math: A Working Example

Let's look at the values initially displayed for the Sample Blur filter.

 

When a filter is applied to an image, each pixel's brightness value is recalculated according to a formula. The filter does the math 
for each target pixel in turn, storing each new value separately before displaying the preview (which then shows all the new 
values). 

The cells in the Filter Matrix represent a target pixel (at the center of the matrix) and its surrounding pixels. The whole numbers 
in these cells are multipliers ("coefficients") by which each pixel's brightness will be multiplied. The filter zips along, pixel by pixel, 
takes the sum of all these multiplications and comes up with a new value for each target pixel. 

If the cell's value is 0, the corresponding pixel makes no contribution to the recalculated value of the target pixel. In the Sample 
Blur filter, you can see that only the pixels immediately adjacent to the target pixel (those outlined above with a red box) have an 
effect. If you think about it, you'll realize that the net result of this filter is to average in the brightness values of a pixel's neighbors 
with its original value, producing a general blurring effect.

If we consider the matrix values as numerators, the Divisor works like a denominator in the recalculations. First the pixel 
multiplication is carried out, then the result is divided by the Divisor. In other words, a divisor of 1 has no effect at all, while a 
divisor of 9 reduces the recalculated brightness of each target pixel to 1/9 of what it would otherwise be.

In the Sample Blur filter, the divisor of 9 compensates for nine pixels (those marked off by the red box) having been summed—



each contributing its actual brightness (multiplied by 1)—in the recalculation, thereby giving an average value. The Divisor can 
also let you apply fractional changes rather than just whole-number changes. For example, if the Divisor is 100, then a net matrix 
value of 150 actually counts as 1.5, and so on. 

The Bias is an offset (either positive or negative) that gets added to the recalculated value. This means that positive numbers 
have an overall brightening effect, while negative numbers darken the image.



Basics of using layers

If you're accustomed to thinking of pictures as flat illustrations in books, or as photographic prints, the concept of image layers 
may take some getting used to. In fact, layers are hardly unique to electronic images. The emulsion of photographic film has 
separate layers, each sensitive to a different color—and we've all noticed multiple-image depth effects like shop window 
reflections or mirrored interiors. There is still something magical about being able to build up an image in a series of planes, like 
sheets of electronic glass, each of which can vary in transparency and interact with the layers below to produce exciting new 
images and colors.

 This topic introduces the basic idea of 
layers as implemented in PhotoPlus. The 
topics that follow delve into the creative 
possibilities of layers.

Kinds of layers

In a typical PhotoPlus image—for example, a photograph you've scanned in, a new picture file you've just created, or a standard 
bitmap file you've opened—there is one layer that behaves like a conventional "flat" image. This is called the Background layer, 
and you can think of it as having paint overlaid on an opaque, solid color surface. 

You can create any number of new layers in your image. Each new one appears on top of the currently active layer, comprising a 
stack that you can view and manipulate with the Layer Manager tab. We call these additional layers standard layers to 
differentiate them from the Background layer. Standard layers behave like transparent sheets through which the underlying 
layers are visible. (Text layers, which differ from the other two types of layers, are covered in the topic Creating text.)

A key distinction is that pixels on the Background layer are always opaque, while those on standard layers can vary in opacity (or 
transparency—another way of expressing the same property). A couple of examples will show how this rule is applied in 
PhotoPlus:

· Suppose you are creating a new picture image. The New Image dialog provides three choices for Background: White, 
Background Color, and Transparent. If you pick White or Background Color, the Layer Manager shows a single layer in the 
new image named "Background." If you pick Transparent, however, the single layer is named "Layer 1"—and in this case, the 
image (typically an animation file) has no Background layer. 

 n If you cut, delete, or move a selection on the 
Background layer, the "hole" that's left exposes the 
current background color (as shown on the Color 
tab). The same operations on a standard layer 
expose a transparent hole.

Tip: If you want to manipulate the Background layer using transparency, you can either duplicate it or use the Promote to Layer 
command (see below).

Tip: To adjust the grid size and colors of the "checkerboard" pattern denoting transparency, choose Preferences... from the File 
menu and select the Transparency tab.

Operations involving layers

Many standard operations, such as painting, selecting and moving, Clipboard actions, adjusting colors, applying effects, and so 
on, are possible on both the Background layer and standard layers. 

Others, such as rearranging the order of layers in the stack, varying layer opacity (transparency), masking, or creating animation 
frames, only work with standard layers. 

See the linked topics for details on these operations.

Once an image has more than just a background layer, the layer information can only be preserved by saving the image in the 
native PhotoPlus (.SPP) format. Exporting the image to standard "flat" bitmap formats requires that multiple layers first be 
merged (see the next topic).

Here's a brief summary of the commands you'll need to create new standard layers and set layer properties. See also the Visual 
Reference topic on the Layer Manager tab.

To carry out basic layer operations:

· To create a new standard layer, click the  New Layer button on the Layer Manager tab.

· To select a layer, click on its name in the Layer Manager tab. The selected layer is now the active layer.

· To clone the active layer and its contents as a new standard layer, choose Duplicate... from the Layers menu.



· To convert the Background layer to a standard (transparent) layer, right-click "Background" on the Layer manager tab and 
choose Promote to Layer. The layer's name changes from "Background" to "Layer <number>."

· To remove the active layer, click the  Delete button on the Layer Manager tab. (You can delete the 
Background layer, as long as it's not the only layer.)

· To make a layer's contents visible or invisible, click the  Hide/Show Layer button next to its name on 
the Layer Manager tab. The icon switches between an open and closed eye. Shortcut: Left- or right-click a hidden layer's 
name to make the layer visible again. 

· To prevent further editing of transparent regions on a standard layer, click the  Protect Transparency 
button next to its name on the Layer Manager tab.

· To convert any text layer to a standard layer, right-click on the layer name and choose Render Text Layer from the menu.

 n For a visual preview of layers (including hidden layers) in 
the image, pause the mouse pointer over a layer name 
and the Layer Preview window appears. It's especially 
handy if you're working with many similar layers, image 
fragments, and/or hidden layers. 



Manipulating layers

The previous topic provides an overview of image layers and how to create them in PhotoPlus. This topic looks at some of the 
creative options available involving the Background (opaque) and standard (transparent) layers, such as:

· Moving the contents of one or more layers

· Clipboard operations involving layers

· Rearranging standard layers in the stack 

· Merging layers

Note: Commands on the Image menu, such as color adjustments and special effects, typically are applied to the current 
selection; if there's no selection, they affect the active layer (the one currently selected in the Layer Manager tab). Click the 
links for details on the many available options.

For details on using text layers, which behave differently from the other two types of layers, see the topic Creating text.

For details on masking, which lets you manipulate a layer's contents without permanently affecting it, see the topic Basics of 
using masks.

To move the contents of the entire active layer:

· With nothing selected (press Ctrl+D to remove any selection), drag with the  Move tool. 

Note that layer content moved in this way outside the image window (canvas area) survives—you can drag it back inside the 
window later if desired. The Layer Manager tab's Preview Window lets you see the entire layer's contents.

You can link one or more layers to the active layer so that when you drag with the Move tool, the contents of all linked layers 
move together.

 
To link other layers to the active layer:

· Click the  Link Layer button next to the layer's name on the Layer Manager tab. 

The link button is always "down" for the active layer; you can see which others are linked to it by checking to see which other 
layers also have "down" link buttons. Once layers are linked, they remain so regardless of which layer in a linked group is active.

· To unlink a layer from the active layer, click its link button again (so it's now "up"). 

To copy (or cut) the contents of the entire active layer to the Clipboard:

· To copy, select nothing and click the  Copy button (or press Ctrl+C or use menu command 
Edit/Copy). 

· To cut, select nothing and press Ctrl+X or use menu command Edit/Cut.

Note: Cut or deleted pixels expose the current background color (on the Background layer) or transparency (on standard layers).

· To paste as a new layer from the Clipboard, press Ctrl+L or choose Paste> As New Layer from the Edit menu.

Note: If you cut/copy a text layer and paste it elsewhere as a new layer, it becomes a standard layer and its text is no longer 
editable.

To move a standard layer up or down in the layer stack:

· Click on the layer's name in the Layer Manager tab and drag up or down. A black line "drop target" appears between layers as 
you drag. Drop the layer on a target to relocate it in the stack.

OR

· Select the layer and choose Arrange from the Layers menu, then choose from the submenu:
· Bring to Top places the layer on the top of the stack.
· Move Up moves the layer up one in the stack.
· Move Down moves the layer down one in the stack.
· Send to Bottom places the layer just above the Background layer (if present) in the stack.

Note: You cannot move a standard layer below the Background layer, nor can you move the Background layer itself. To turn the 
Background layer into a standard layer, either use Layers/Duplicate to clone it, or right-click its name and choose Promote to 
Layer. The former action keeps the original Background layer in place; the latter removes it.



Merging layers combines multiple layers into one, decreasing the memory required to store the image. Once layers have been 
merged, they become a single layer and their previous contents are no longer separately editable.

To merge layers:

· To merge the active layer with the layer below it, choose Merge Down from the Layers menu.

· To merge just the currently visible layers into a single layer, choose Merge Visible from the Layers menu.

· To merge all image layers into a single layer, choose Merge All from the Layers menu. This is called flattening the image 
because the result is a "flat" file with just a Background layer.

· To copy the selection (or image, if there's no selection) to the Clipboard in flattened form without physically merging its layers, 
choose Copy Merged from the Edit menu.



Adjusting opacity/transparency

First, a word on terminology. In this overview, we'll be using the term "opacity," which is standard in PhotoPlus as in other photo 
editors. But note that opacity and transparency are essentially the same (just different ends of the same scale). They both 
describe the degree to which a particular pixel's color contributes to the overall color at that point in the image. (Pixels are the 
"dots of paint" that comprise a bitmap image in PhotoPlus.) For color basics, see the topic Color concepts. For information on 
transparency in Web graphics, see the topic Image formats for the World Wide Web.

Varying opacity is rather like lighting a stage backdrop (scrim) in a theater: depending on how you light the fine gauze sheet, you 
can render the depicted scene either visible or invisible. Fully opaque pixels contribute their full color value to the image. Fully 
transparent pixels are invisible: they contribute nothing to the image. You'll primarily encounter opacity in one of these two 
contexts:

· As a property of the pixels laid down by individual tools (Paintbrush, Clone, Eraser, Airbrush, Fill, Smudge, Shape, and Line). 
When you paint on-screen with one of these tools, you're applying pixels—pixels that are more or less opaque, depending on 
the tool's opacity setting. Note that once you've applied paint to a region, that's it—you've changed the opacity of pixels there. 
Subsequently changing a tool's opacity setting won't alter brush strokes you've already laid down! 

· As a property of individual standard layers. The layer's opacity setting affects all the pixels on the layer, and is cumulative 
with the opacity of individual pixels already there. It's like a "master setting" that you can vary after paint has been laid down.

To set a tool's opacity:

· Select the tool and enter a percentage value on the Tool Properties tab.

To set a layer's opacity:

· Right-click its name in the Layer Manager tab and choose Properties..., then enter a percentage value.

To read the opacity values of pixels on the active layer:

1. Set the Color Mode to "RGB" on the Color tab.

2. Select the  Color Pickup tool from the Tools tab and move it around the image. 

3. Note the value shown for "O" (Opacity) on the HintLine. The readout updates constantly, showing the opacity value of each 
pixel under the cursor.

Opacity in action

Opacity crops up as a concept quite often in PhotoPlus operations. Here's a handy summary, with links to other topics where you 
can explore these features in more detail.

· Transparency is denoted by a "checkerboard" grid pattern, light gray and white by default. To adjust the grid size and colors, 
choose Preferences... from the File menu and select the Transparency tab.

· Although pixels painted onto the Background layer can vary in opacity, once laid down they are fully opaque. Pixels on 
standard layers can vary in opacity, because standard layers have a "master" opacity setting that you can vary. (See the topic 
Basics of using layers.) 

· Cut, deleted, or selected-and-moved pixels expose the current background color (on the Background layer) or transparency 
(on standard layers). 

· If you want to manipulate Background layer content using transparent pixels, you can either duplicate it or use the Promote to 
Layer command (right-click on the layer's name).

· To prevent further editing of transparent regions on a standard layer, click the Protect Transparency button next to its name 
on the Layer Manager tab.

· You can use anti-aliasing and feathering to produce smooth, semi-transparent edges on selections for smooth transitions to 
surrounding pixels. (See the topic Modifying a selection.)

· Masking lets you paint on, adjust, or otherwise manipulate any standard layer without permanently affecting it. Just as a 
selection is a "map" outlining a region of pixels, a mask is a map of variations in a layer's transparency. (See the topic Basics 
of using masks.)

· When creating an animation, you can vary the opacity of a single layer between frames—for example, to make an object 
"fade in" or "fade out." (See the topic Getting started with animation.)



Basics of using masks

Note: If you're unfamiliar with selections, layers, and opacity, you're not quite ready for masking. First review the topics Making a 
selection, Basics of using layers, and Adjusting opacity/transparency.

Masking in a program like PhotoPlus is a bit more complicated than applying masking tape to the screen! But fundamentally the 
concept is the same: you can hide certain parts of an image—in this case by rendering them transparent, hence invisible. To do 
that, you create a mask on a standard layer. 

 
By changing the grayscale values on the mask (using the paint tools and other devices), you can impose corresponding changes in 
the opacity of the underlying layer's pixels. For example, by "blacking out" on the mask, you render the layer's underlying pixels 
transparent, and they disappear from the image. Because you're working with 256 levels of gray (i.e. opacity), tremendous variations 
are achievable.
Besides the creative possibilities, including vignetting and multi-layer montage masking and beyond, a great feature of working on a 
mask is that it is "temporary." If you don't like the way things are going, you can abandon your changes and start over without ever 
having affected the actual pixels on the layer!

A couple of things worth noting: 

· Mask information, like layer information, can only be preserved by saving the image in the native PhotoPlus (.SPP) format. 

· Each standard layer can have one mask at any given time. The Background layer can't have one because it doesn't support 
transparency. 

The three basic steps in using a mask:

1. Create the mask on a layer.

2. Edit the mask itself to "preview" changes to the layer.

3. Merge the mask with the layer to make the changes permanent, or delete the mask without applying changes.

1    Creating the mask

Before you can use a mask, you have to create it on a particular layer. The mask can start out as transparent (revealing the 
whole layer), opaque (hiding the whole layer), or—if you create it from a selection—a bit of both (with only the selected region 
hidden or revealed). The choice depends on how you want to work with the layer's contents. By darkening portions of a clear 
mask, you can selectively fade underlying layer pixels. By lightening an opaque mask, you selectively reveal layer pixels.

To create a mask:

1. Select the layer where you want to create the mask, and select specific region(s) if desired.

2. Choose Add Mask from the Layers menu and then one of the following from the submenu:
· Reveal All for a transparent mask over the whole layer
· Hide All for an opaque mask over the whole layer
· Reveal Selection for an opaque mask with transparent "holes" over the selected region(s)
· Hide Selection for a transparent mask with opaque "blocks" over the selected region(s)

On the Layer Manager tab, a  appears next to the layer name, indicating that a mask now exists. 

2    Editing on the mask

In Edit Mask mode, you can use the full range of painting tools, selection options, flood fills, and effects to alter the mask's 
grayscale values. These manipulations cause corresponding changes in opacity, which in turn change the appearance of the 
pixels on the layer itself. 

Remember, as long as you are editing the mask, you're only seeing a preview of changes on the layer. No permanent changes 
will be applied until you actually merge the mask with the layer. You can switch out of Edit Mask mode at any time to work 
directly on the layer (or any other part of the image), then switch back to resume work on the mask.

To edit the active layer's mask:

· Check Edit Mask on the Layers menu. (Uncheck to discontinue editing the mask.)



The image window's titlebar shows "[MASK]," indicating that a mask is currently being edited. The Color tab switches to 
Grayscale mode when you're editing a mask, and reverts to the previous setting when you exit Edit Mask mode. This means 
anything you paste from the Clipboard onto the mask will automatically be converted to grayscale.

In Edit Mask mode, you're normally viewing not the mask, but rather the effects of changes "as if" you were making them on the 
layer below. Adding a Reveal All mask can be a bit confusing, because there's initially no evidence the mask is there at all (i.e. 
the layer appears exactly the same as it did before you added the mask)! 

It's sometimes helpful to switch on the View Mask setting, which hides the layer and lets you see only the mask, in all its 
grayscale glory. For example, a Reveal All mask appears pure white in View Mask mode—the white represents a clear mask with 
no effect on the underlying layer pixels' opacity. View Mask can also be useful in the latter stages of working on a mask, to locate 
any small regions that may have escaped your attention.

To view the active layer's mask:

· Check View Mask on the Layers menu.

White or light portions of the mask reveal layer pixels (make them more opaque). Black or dark portions hide layer pixels (make 
them more transparent).

You can disable the mask to see how the layer looks without the mask's effects. Note that disabling the mask is not the same as 
canceling Edit Mask mode—it only affects your view of the layer, not which plane (i.e. mask or layer) you're working on.

To disable the active layer's mask:

· Check Disable Mask on the Layers menu. (Uncheck to enable masking again.)

3    Applying changes to the layer

When you're satisfied with the appearance of the layer as seen with the mask enabled, you can merge the mask with the layer to 
make the changes permanent. Merging the mask is optional; the effects of unmerged masks will appear in an exported image—
but merging reduces the .SPP file's size and makes the layer available for further masking. Of course, you can choose to delete 
a mask without applying changes... perhaps to try again. In either case, whether merged or deleted, the old mask is no longer 
present and the layer is ready to accept a new mask.

To impose the mask's effects onto the layer:

· Choose Merge Mask from the Layers menu. At the same time, the layer is removed.

To remove the mask and cancel its effects on the layer:

· Choose Delete Mask from the Layers menu.



Getting started with animation

Animation creates an illusion of motion or change by displaying a series of still pictures, rapidly enough to fool the eye—or more 
accurately, the brain. With PhotoPlus, it's easy to create and edit images with multiple frames, then export them as animated 
GIFs that a Web browser can play back. You use exactly the same tools and interface as for creating standard, multi-layer 
PhotoPlus images, with an extra tab window that includes all the additional controls you need to set up frames, add special 
effects, and preview the animation. Once you're satisfied, use the Export Optimizer to output to the .GIF file format.

This topic will introduce a few basic concepts that will help you to quickly master the mechanics of animation, which are covered 
in the next topic. (If you're not already familiar with the concept of layers, we suggest you first look at Basics of using layers.)

The .GIF format is what makes Web animation possible, for a couple of reasons. First, it's universally supported by Web 
browsers. Second, it's a multi-part format, capable of encoding not just one image but multiple images in the same file. A .GIF 
animation player or Web browser can display these images in sequence, in accordance with certain settings (looping, frame 
delay, etc.) included in the file. The result—it moves!

PhotoPlus gives you the choice of either creating your animations from scratch, then exporting to .GIF, or starting out by 
importing a .GIF animation and then editing it. (Click the links for details.) Either way, once PhotoPlus detects an animation file, it 
switches on the Animation tab. If the image file is new, you'll see a single, blank frame, labeled "Frame 1." If you've imported an 
animation, the tab displays each frame separately. Animation files can have one layer, or many (see below), but all their layers 
are standard (transparent) layers; there's no Background layer.

Note: By the way, PhotoPlus ships with a bonus collection of .GIF animations! You'll find them on your PhotoPlus CD in the 
\Serif\Animations folder.

Layers and frames

Animations are defined by the Animation tab working together with the Layer Manager tab. Let's consider this little animated 
GIF of a rotating spiral. Here's how its frames appear when it's imported into PhotoPlus. If you inspect each frame, you can 
"animate" the sequence in your mind's eye. In what direction is the spiral rotating?

 
In this file (as in any imported .GIF animation) the individual frames each occupy one layer in the PhotoPlus image. 

 

On the Layer Manager tab, the layer stack for this animation 
corresponds to the frame sequence, with default names—in 
this case, "Frame 1 of 6" through "Frame 6 of 6." 

If you select Frame 1 on the Animation tab, you'll see that on 
the Layer Manager (see left) only the "Frame 1" layer is 
marked as shown, with an open-eye button; the other layers 
are all hidden, with closed-eye buttons. 

If you then select Frame 2, only the "Frame 2" layer will be 
shown, and the rest will be hidden. And so on with the other 
frames.

The above example, with its one-to-one correspondence between frames and layers, is easy to grasp—but don't make the 
mistake of thinking that a "frame" is just another name for a "layer." Frames in PhotoPlus are actually much more versatile!

Key point: A so-called "frame" is really just a particular state or snapshot of the various layers in the image, in terms of three 
layer properties: 

1. Shown/Hidden: Which layers are shown and which are hidden 

2. Position: The position of the contents of each "shown" layer 

3. Opacity: The opacity setting of each "shown" layer

As you switch between frames, you switch between states. In the simple example above, the six frames define six states in 
terms of Property 1—each of the six frames defines a different layer as "shown." We could rearrange the stacking order of the 
layers, or rename them—the animation itself wouldn't change. 

When you create a new frame on the Animation tab, you're not adding a new layer. The new frame merely enables you to define 
a new state of the layers that already exist. Of course, you could go on and create an additional layer (using the Layer Manager), 
but then all your animation frames would need to take that layer into account—in other words, hide it when it wasn't needed.

Single-layer animation

Let's look at a different example. This one shows a bouncing ball, and although it has four frames it only has one layer:



 
In this animation, the four frames define four states in terms of Property 2—the position of the layer contents. The image was 
created from scratch in PhotoPlus, starting with a dark blue circle on a white square. Besides Frame 1, three additional frames were 
created, and then, stepping from one frame to the next, the layer was dragged slightly in each frame (with the Move tool) to 
reposition its contents in the window. In each of the four frames, you can see where the opaque white square sits in relation to the 
transparent background pixels. 

We'll leave it to you to imagine a third example, varying only opacity on a single layer: say, some text (like "CLICK HERE") 
blinking on and off. Two frames could accomplish that—in one, the layer set to 0% opacity, and in the other, to 100%.

Additional notes

· In practice, you can use one, two, or even all three of the above approaches when creating a given piece of animation. Just 
remember that a separate layer is only required for each element that moves independently, or each differently-drawn state of 
a given element. An element that doesn't change its shape or color, but merely moves about or changes opacity (appears or 
disappears), can be animated on a single layer.

·  With a little forethought and sketching, you can figure out in advance how many layers you'll need. Then you can set up the 
image with the right number of layers to begin with. 

· Animations, which depend on at least one transparent layer, can only be preserved by saving the image in the native 
PhotoPlus (.SPP) format. The image can be exported and then re-imported, but any layer properties will be lost in the 
conversion.

· Although .SPP animations and .SPP pictures share the same file extension, there's no direct conversion option—a file either 
has animation properties, or it doesn't. To convert an .SPP picture file to an animation, or extract a single frame from an 
animation to a picture, first create a new image window and then use conventional copy/paste commands to copy elements 
and/or layers from one file to the other.



Working with animation frames

This topic covers the basic mechanics of creating and arranging animation frames using the Animation tab. It assumes you've 
read the previous topic for background, and that you know how to create a new animation (or import an existing animated .GIF). 
The next topic goes on to deal with creative options such as special effects, delays, and loops.

 The Animation tab displays a sequence of frame thumbnails. 
Each frame is a different state of the image, defined in terms of 
which layers are shown or hidden, the position of content on 
each shown layer, and the opacity of each shown layer (see the 
previous topic).

To create a new frame:

· Click the  New Frame button (or right-click a thumbnail and choose New Frame).

The previously selected frame is cloned as a new frame, immediately following it in the sequence.

To build the animation:

1. Create the number of image layers you'll need (as few as possible).

2. Create enough frames to define the separate states of the animation. 

3. Step through the frames, adjusting layer content and state for each frame. You can delete or reposition frames as needed, 
and preview the animation at any time. 

4. Save the animation as a regular PhotoPlus (.SPP) file, and export it to the .GIF format.

To select a single frame:

· To select any one frame, click its thumbnail. 

· To select the first frame of the sequence (rewind), click the  First Frame button.

· To select the previous frame of the sequence, click the  Previous Frame button. 
If the first frame was selected, you'll cycle back to the last frame of the sequence.

· To select the next frame of the sequence, click the  Next Frame button. 
If the last frame of the sequence was selected, you'll cycle forward to the first frame.

· To select the last frame of the sequence, click the  Last Frame button.

To select more than one frame:

· To select multiple frames, hold down the Ctrl key when selecting each one. 

· To select a range of adjacent frames, hold down the Shift key and click the first and last thumbnail in the range.

To delete one or more frames:

· Select the thumbnail(s) and click the  Delete Frame button. (To delete a single frame, you can also 
right-click it and choose Delete.)

To reposition a frame in the sequence:

· Drag its thumbnail and drop it before or after another frame.

To play back the animation:

· Click the  Play button.

To stop the animation:



· Click the  Stop button.

To export the animation as a .GIF file:

· Choose Export... from the File menu.

(For details on exporting, see the topic Exporting to another file format. For specifics on the .GIF format, including transparency 
options, see the topic Image formats for the World Wide Web.)

To preview the animation in your Web browser:

· Choose Preview in Browser... from the File menu. PhotoPlus exports the image as a temporary file, then opens the file for 
preview in your World Wide Web browser.



Image formats for the World Wide Web

Here are some notes on the principal file formats used for Web pictures and animation—.GIF, .JPG, and .PNG—and the options 
you'll encounter in the PhotoPlus Export Optimizer. (For background on the color terminology here, see the topic Color concepts 
and specifically the subtopic Optimizing images.)

.GIF format

The .GIF (Graphics Interchange Format) file format is universally supported in Web browsers for both static and animated Web 
graphics. It's a lossless format (there's no image degradation) with excellent compression but a limitation of 256 colors. Use it 
for non-photographic images with sharp edges and geometrics—for example buttons, bursts, decorative elements, and text 
graphics. It's suitable for grayscale photos as well.

In PhotoPlus, you can take advantage of the fact the GIFs, unlike other 256-color formats, don't insist on using 8-bit pixels. If the 
number of colors in the image is 128, GIFs can encode using 7 bits; with 64 colors, 6 bits, and so on. The Export Optimizer lets 
you specify not the bit depth, but the number of colors, in each exported GIF. 

The .GIF format supports "binary" transparency. That is, any portion of the image may be either fully opaque or fully transparent. 
Typically, this is used to eliminate the box-shaped frame around the graphic that would otherwise be present. Elements with 
rounded edges, such as characters or shapes, preserve their contours over any background color or pattern. 

If you're producing transparent GIFs, try to avoid anti-aliasing and feathering (i.e. turn them off in the Tool Properties tab). The 
semi-transparency these functions impart may look fine in PhotoPlus, but remember that .GIF wants "all or nothing." Pixels that 
aren't 100% transparent will end up opaque, and the exported graphic will display sharp or even ragged edges when viewed 
over a Web page background.

Finally, .GIF is a "multi-part" format, which means one file can store multiple images. That's what makes it the preferred format 
for Web animations. 

Recommended export settings

Number of colors: 256 is the maximum supported by the format. You can select a lower value from the list, or type in a specific 
value. Try typing successively lower values and use the multiple view feature to arrive at the lowest file size that preserves an 
acceptable appearance. For animations, 256 colors (8 bits) is the only available setting. 

Dithering (None, Ordered, Error diffusion): Dithering schemes substitute pixel patterns for original colors to preserve apparent 
coloration when the actual number of colors in the image is being reduced. Choose Ordered (not available for animations) for a 
more regular dot pattern, and Error diffusion for a more adaptive dot pattern. 

Palette (Web-safe, Optimized): Choose Optimized to let the PhotoPlus export filter determine the best colors to apply, but 
without regard for standard colors. Choose Web-safe to reduce the colors to only those found in the 216-color palette used by 
Web browsers. This will ensure that an image you place on a Web page won't change its appearance when viewed by users of 
most other systems or browsers.

GIF Options (Transparent, Interlaced): .GIF files support transparency—one reason they're commonly used over backgrounds 
on Web pages. PhotoPlus gives you the option of exporting GIFs with or without a transparent background. Check Transparent 
to turn clear "checkerboard" regions of your graphic (those with no pixels or 0% opacity) into transparent regions in the GIF. All 
other regions will become opaque. If unchecked, transparent regions will become white. Check Interlaced to use an image 
format that will display "progressively" in a browser: first a low-quality image will display, followed by an improved image as the 
complete GIF is loaded.

.JPG format

The .JPG or .JPEG (Joint Photographic Experts Group) file format, like .GIF, is universally supported in Web browsers. 
Unlike .GIF, it encodes 24-bit images but is a lossy format depending on the selected compression setting. .JPG is clearly the 
format of choice for full-color photographic images. For "black and white" (256-level, 8-bit grayscale) photos, it has no particular 
advantages over .GIF.

The unique aspect of exporting as a JPG is in fact the slider control you use to chose one setting from 10 possible levels. At one 
end of the scale, the export applies maximum compression and produces an extremely small (but quite ugly) image. At the other 
end, there is effectively no loss of quality, but file sizes are relatively much larger, although still compact compared to BMPs, for 
example. 

When choosing a quality setting for .JPG export, keep in mind the number of times you expect to be re-exporting a particular 
image. A photograph may look fine in the Export Optimizer the first time you export it at JPG level 6, but after several such 
saves, you'll really see a quality loss.

PNG format

For Web graphics, the new .PNG (Portable Network Graphics, pronounced "ping") format has a number of advantages over .GIF
—the main ones, from an artist's perspective, being "lossless" 24-bit images and support for variable transparency. 
Whereas .GIF supports simple binary ("on-off") transparency, .PNG allows up to 254 levels of partial transparency for normal 
images. The image file includes an "alpha channel" that directs pixels in the foreground image to merge with those in a 



background image. Most commonly used with 24-bit images, anti-aliasing creates the illusion of smooth curves by varying pixel 
colors-—for rounded images that look good against any background, not just against a white background. It's especially useful 
for the small graphics commonly used on Web pages, such as bullets and fancy text.

.PNG's most obvious drawback at the present time is that the major Web browsers don't yet provide full .PNG support—but this 
will change, we hope, as more graphic artists become aware of the format's advantages.



Slicing images

Image slicing and image maps (see the next topic) are two convenient ways to create navbars (navigation bars) and clickable 
graphics for Web pages. With image slicing, a graphic is carved up into smaller graphics—each of which can have its own link, 
like any Web graphic—and PhotoPlus saves the sections as separate files when you export the image. The process also outputs 
HTML tags describing a table containing the separate image files, so that a Web browser can reassemble them seamlessly. The 
result appears as a single larger graphic, but with different regions linked to different targets.

For example, this menubar graphic...

 
...can be "sliced" into four separate graphics, each linked to a different Web page.
The Image Slice tool lets you cut up the image into sections which can be exported using the .GIF or .JPG format. You can specify 
alternate text and URL links for each of the image sections individually. (For details on exporting and the Export Optimizer, see the 
topic Exporting to another file format. For information on the .GIF and .JPG formats, see the previous topic.)

To slice the image:

· Choose the  Image Slice tool from the Tools toolbar.

· To place a horizontal slice guide on the image, click with the tool. Shift-click to place a vertical guide. A red guide line appears 
with each click.

· To move a guide, simply drag it. 

· To delete a guide, drag it out of the image window.

To specify the alternate text and/or link:

· Right-click an image slice and enter the alternate text and link (URL) information in the dialog.

To export a sliced image:

· When exporting, check the Create Image Slices box on the Export dialog and use either the .GIF or .JPG format.

· Since exporting slices creates multiple files, you may wish to create a separate folder for them.

The output consists of a series of image files (for example, MYFILEH0V0.GIF, MYFILEH0V1.GIF, etc.) and a single HTML file 
(for example, MYFILE.HTM). The HTML file contains the tags for the set of image slices, ready to be pasted into the source code 
for the Web page.



Creating image maps

Image maps and image slicing (see the previous topic) are two convenient ways to create navigation bars and clickable 
graphics for Web pages. Whereas image slicing subdivides an entire graphic into smaller graphics and exports them separately, 
image maps consist of hotspots that you draw with special tools over selected parts of an image. 

 
You assign each hotspot its own target—for example, the URL of a Web page. Hotspots aren't attached to a particular image, but 
become part of a larger "map" that gets exported along with an image and turns into HTML code. It's then up to the Web developer 
to embed the image map code properly into the Web page. (For details on exporting and the Export Optimizer, see the topic 
Exporting to another file format. For information on the .GIF and .JPG formats, see Image formats for the World Wide Web.)

Image maps are useful if you want to define isolated and/or irregularly shaped clickable regions on a Web graphic, as opposed 
to subdividing the entire graphic into rectangular image slices. 

The  Image Map Tools flyout on the Tools toolbar displays a flyout menu of tools for creating and editing 
image maps. You generally draw the hotspots

To draw a hotspot:

1. Click the Image Map Tools flyout and choose the  Rectangle, 

 Circle, or 

 Polygon tool. 

2. Use the tool to draw a hotspot on the active layer. To draw a polygon, drag and release the mouse button to define each line 
segment; double-click to close the polygon.

Tip: When using the Rectangle tool, hold down the Ctrl key while dragging out to constrain the hotspot's shape to a square.

To edit a hotspot:

1. Click the Image Map Tools flyout and choose the  Image Map Selection tool.

2. To resize the hotspot, drag from an edge.

3. To move the hotspot, drag from the center.

4. Right-click the hotspot to delete it, set layer options, or access hotspot properties (popup text and target URL). Previously-
used URLs are saved and can be selected from the drop-down list in the dialog.

To export an image map:

· When exporting, check the Create HTML for Image Maps box on the Export dialog. 

The output consists of an image file and an HTML file with the same base name. The HTML file contains the tags for the image 
map, ready to be pasted into the source code for the Web page.



Using shortcuts

Tool shortcuts

Selection tools

· To constrain the selection's proportions (for example, to a square or circle), hold down the Ctrl key while dragging.

· To add to the existing selection, hold down the Shift key while dragging.

· To subtract from the existing selection, hold down the Alt key while dragging.

· To move the contents of the selection, press the Ctrl key and click, then drag the selection.

· To duplicate the contents of the selection, press Ctrl+Alt and click, then drag the selection.

Move tool

· To duplicate the contents of the selection, press the Alt key and click, then drag the selection.

Crop tool

· To constrain the selected region to a square, hold down the Ctrl key while dragging.

Shape tools

· To constrain the shape's proportions, hold down the Ctrl key while dragging.

· To pick up colors, hold down the Alt key and left-click to set foreground color, right-click to set background color.

Line tool

· To constrain the angle of the line to 15-degree intervals, hold down the Shift key while dragging.

· To pick up colors, hold down the Alt key and left-click to set foreground color, right-click to set background color.

Paintbrush, Airbrush, Fill, and Text tools

· To pick up colors, hold down the Alt key and left-click to set foreground color, right-click to set background color.

Clone tool

· To define the pickup origin, Shift-click with the tool.

Image Slice tool

· To draw a vertical slice guide, hold down the Shift key and click.

Image Map rectangle tool

· To constrain the hotspot to a square, hold down the Ctrl key while dragging.

Menu shortcuts

Every menu item has a keyboard shortcut (useful in the event your mouse stops working!). 

To display a menu:

· Press the Alt key followed by the underlined letter in the menu name. The menu appears. For example, pressing Alt+F 
displays the File menu.

To select an item from a displayed menu:

· Press the key underlined in the menu item. For example, pressing Alt+F+S is the same as choosing Save from the File menu.

Here's a summary of shortcuts for commonly used PhotoPlus menu items:

Ctrl+Z Undo last action

Ctrl+Y Redo last undone action

Ctrl+C Copy selection or layer to Clipboard



Shift+Ctrl+C Copy merged (all layers as one) to Clipboard

Ctrl+X Cut selection to Clipboard

Ctrl+V Paste from Clipboard as new image

Ctrl+L Paste from Clipboard as new layer

Shift+Ctrl+L Paste from Clipboard centered into selection

Ctrl+D Deselect pixels (select nothing)

Shift+Ctrl+I Invert selection

Ctrl+A Select all

Ctrl+N New image

Ctrl+O Open file

Ctrl+P Print

Ctrl+S Save

Ctrl+F4 Close current image window

Alt+F4 Exit PhotoPlus

·

· Other keyboard shortcuts

F1 Display the Help Contents screen

Tab Show/hide all visible tabs (not toolbars)

Alt+Tab Switch between image windows

·
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