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Introduction

Netmail electronic mail processing software is suited for both corporate and home use.

Netmail allows automatic sorting of incoming messages based on preset criteria and their 
placement in individual folders or mailboxes where they can be viewed at a later time. In such a 
system only those folders can be viewed, for example, where only the most important messages 
are directed. The mail filter processes incoming messages based on header fields, for example, 
using the sender's address or the content of the Subject field. Advanced filters can be applied 
both to any field of the message header or the body of the message itself.

The program supports various national message codings. This means you'll be able to maintain 
correspondence in almost any language.

Netmail can store information on many e-mail accounts. If you have several external mailboxes 
at different ISPs you will not need to enter a new password and adjust the settings every time. 
All you have to do is choose the connection profile through which you want to exchange 
messages. You can also create different mailboxes for different messages within the program.

Netmail supports modern electronic messaging standards both in ordinary text message format 
and graphic html pages. Such messages can be viewed in different modes, for example, as an 
initial text or in html format. 

Options are also provided for standard e-mail clients: support of attachments, message sorting 
by date, subject, address or other fields, message searches based on key words, etc.

The software will be useful for both electronic business professionals and all those who 
can set up a message exchange with existing customers and potential clients on a 
professional level.



<Starting up work with the software>

To use the software you will need to make certain initial settings.

Then the software is up and running. Now you will need to enter the parameters without which it 
will be impossible to send or receive messages. You will need to find out this information from 
your Internet provider (supplier of Internet services). It is individual to every user.

Following installation the software the database will be located by default in the same directory 
with the program. You can move it to any other directory and reset the path in the Preferences 
menu.

After installing and starting the software select select Preferences from the Main menu. 

The Settings dialog is then displayed.

Netmail can store information on many e-mail accounts. Enter the so-called electronic mail 
server connection profile fields:

· Name - Enter your real name here. It is placed in the From field of your outgoing mail 
messages, along with your return address.
· Used ID - type your login name for this account
· Return address:    Normally, NetMail uses your POP account as your return address. If you 
wish to use a return address other than your POP account, enter it here.
· Smtp server - here you enter the name of the outgoing mail server. To send mail, a 
computer with an SMTP (Simple Mail Transfer Protocol) server program is necessary.    You 
need not have a login on this computer, but you must have access to it through your network. 
Otherwise, specify the name of the computer that you want to use as your SMTP server.
· Pop3 - name of the incoming mail server. To receive mail with NetMail, you must have an 
account on a computer that runs a Post Office Protocol version 3 (POP3) server. 
· SMTP port - usually 25
· POP3 port - usually 110
· Password – your email account password

You will need to receive this information from your provider (ISP). It is individual to every user.

You can enter several of such profiles into the software. The profile where you place the cursor 
mark will be the active one where you will be receiving and from which you will be sending 
messages. In case you need to receive mail at another external mailbox, just add the new 
profile or select one from the list. Thus, if you need to receive mail from different providers (ISP) 
you can check it without entering the user's name and password repeatedly by simply placing 
the cursor mark on the right line.

Options    Settings

Then set the following parameters to send and receive mail. Let's start from the top

Attachment directory and database path
Before downloading messages define the path to the directory where you are going to store the 
attachments. Never open attachments received from unfamiliar sources. First check the 



directory with the attachments using an anti-virus program before you open the files.
Select the path to the datebase. You can locate it in any directory on your computer's hard drive. 
By default the database will be located in the same directory with the mail software.

Charset
The program supports various national message codings. This means you'll be able to maintain 
correspondence in almost any language.
This option is required to select the coding of messages being sent. You will need to select the 
appropriate coding for various national languages.

Delete messages from the server
If this option is not highlighted then even if you have read messages they will physically stay on 
the server and not be deleted.

Load only N.. lines from each message
Sometimes messages are too large but you need to read all your mail at once. To be able to do 
this you can enter a limit on the size of the message and just load the headers first and only 
then load the selected messages you need to view separately.

A message consists of two parts: systemic data and the body of the message. The first part 
contains the subject of the message, the recipient's address, the date and other system fields.
The body of the message contains both the text and the coded attachments to the letter. This 
can be either files, programs or html documents.
The software provides for the filtering capability for both messages already received and 
messages which are only on the server for the time being.



<Checking For and Receiving Electronic Mail>

To receive messages:

· Set the connection profile - see previous paragraph on settings
· Select the Check Mail menu. The receiving message indicator will appear.
· The list of recent incoming messages will appear in the received messages window

The POP server is the machine where your mail is received and stored until it is transferred to 
the NetMail program on your PC. Your POP server account is specified in the General setting in 
the Preferences dialog (Tools / Preferences menu).

There are two methods to check your designated POP server to see if you have new mail. One 
method is automatic and the other is manual. 

You may check for mail manually at any time by selecting Check Mail from the File menu. 

A Progress window is displayed momentarily at the top of the screen as the POP server is 
checked. If there is a problem reaching the POP server, an error message alert is displayed. To 
rectify the problem, review the POP server field in the Preferences dialog for correctness.

If there is no mail waiting at your account on the POP server, the "No New Mail" alert is 
displayed.    Click OK. You may check for mail again later. 
If there is new mail, it is transferred automatically from the POP server to NetMail on your PC. A 
progress window is displayed at the top of your screen allowing you to monitor the mail transfer. 

Mail arrives in the In mailbox.    Unread messages in the In mailbox are designated by a bullet 

(.) in the far left column of the message summary. Double-click anywhere on a message 
summary to open the message. Incoming messages are saved indefinitely in the In mailbox 
until they are deleted or transferred to another mailbox.

Stopping a Mail Check
If you want to stop a mail check in the middle (because it is taking longer than anticipated), click 
the Stop button in the progress window.



<Viewing Received Electronic Messages>

You may check for mail manually at any time by selecting Check Mail from the File menu. 

A Progress window is displayed momentarily at the top of the screen as the POP server is 
checked. If there is a problem reaching the POP server, an error message alert is displayed. To 
rectify the problem, review the POP server field in the Preferences dialog for correctness.
If there is no mail waiting at your account on the POP server, the "No New Mail" alert is 
displayed.    Click OK. You may check for mail again later. 
If there is new mail, it is transferred automatically from the POP server to NetMail on your PC. A 
progress window is displayed at the top of your screen allowing you to monitor the mail transfer. 

Mail arrives in the In mailbox.    Unread messages in the In mailbox are designated by a bullet 

(.) in the far left column of the message summary. Double-click anywhere on a message 
summary to open the message. Incoming messages are saved indefinitely in the In mailbox 
until they are deleted or transferred to another mailbox.



<Reply. Answering a message>

Select any message and press the "Reply" button. A new message window will appear with the 
text of the previous message.
The original sender's address automatically placed in the To: field of the header. The original 
sender's text is also automatically included at the beginning of the reply message (prefixed by 
">" at the beginning of each line). This text may be edited or deleted as needed. Additional text 
may be entered into the reply just as in any outgoing message. The reply can then be saved for 
further changes, or simply sent.
An incoming message for which the Reply command has been used is identified by an "R" in its 
message summary.



<Forward. Transferring messages to a different mailbox>

Messages may be transferred between any two mailboxes. For any current message, select the 
mailbox to which the message should be transferred from the Transfer menu. The message is 
transferred from its previous location to the selected mailbox.

Highlight the message with the following keys:
· Shift + arrow;
· Shift + Page Up / Page Down;
· Shift + left mouse button;
· Ctrl + left mouse button.
Press the "Transfer" button and select the mailbox you want to transfer the message to.



<Deleting a message>

A message can be deleted both inside the program and on the server with the help of 
corresponding keys and menu items. For any current message, choose Delete from the 
Message menu.    After being deleted in the program the messages first go to the Trash Box. 
The Trash Box can be emptied with "Delete All" button.



<Creating New Messages. Sending Electronic Mail>

To send a new outgoing message select the "New Message" from the File menu. 

A new message window will appear. 

An outgoing message is a message you send to someone else. A message consists of two 
parts: message header and the body of the message. The first part contains the subject of 
the message, the recipient's address, the date and other system fields.

The body of the message contains both the text and the coded attachments to the letter. This 
can be either files, programs or html documents.

Message Header
Outgoing message headers consist of fields: To, Subject, Cc, Bcc and Attachments. 

Type the electronic address to which you want to send the message in the "To" field.    There 
are also two additional fields to type in the "bcc" blind copy address and the "cc" ordinary copy 
address. Bcc - you need to send the letter to several addresses at the same time. Just enter the 
addresses in a sequence, separated by a comma. The recipients will only see the address of 
the first recipient. As a rule providers limit the use of this sending method to 10-20 addresses.
To move the insertion point from field to field, press the [tab] key or click in the desired field with 
the mouse. When entering information into the fields, you can use the standard Windows text-
editing tools provided under the Edit menu.

Here is a brief description of the intended contents of each field:
To: 
The intended recipient's e-mail address, or a mailing list you have. Multiple addresses are 
allowed, but must be separated by commas.
Cc:
E-mail address of person to whom a copy of the message is to be sent. Multiple addresses are 
allowed but must be separated by commas. This field may be left blank.
Bcc:
"Blind" carbon copy. Like addresses listed in the Cc: field, addresses listed here receive copies 
of the message. Unlike addresses listed in the Cc: field, addresses listed here do not appear in 
the message header of the recipients. This is useful when you want to send a copy of a 
message to someone without everyone else knowing you did so.    Multiple addresses are 
allowed but must be separated by commas.    This field can be left blank.
Subject: 
Type in the subject of your message.
Brief text indicating the contents of the message. This field can be left blank.

Message Text (Message Body)
After filling in the fields, move the insertion point to the space below the message header. 
Message text - you can enter it in the standard text format or in html format. Select the text or 
html message format. Be careful, it is highly recommended to use the most basic format and 
attach complex letters to the message since many users may not have software capable of 
supporting html. The text message is typed into the text window.

Attachments:    List of documents being sent along with the message. 
Any file can be attached to and sent with a NetMail message. 



An attachment can be added by pressing the "Attach" button in the lower part of the screen.

The Attach file dialog is displayed. Once the desired file is located, select it and click on the OK 
button to attach the file to the message.
Several attachments can be added to a single letter. After that press the "Save" button. Then 
press the "Send" button. The message will be sent and saved in the outbox. 

Saving an Outgoing Message for Later Changes

Sometimes it is convenient to save an outgoing message either as a safeguard when typing 
long messages, or so you can return to it later to edit or add more text. 

The outbox can be accessed through the mailbox menu item. All messages sent can be viewed 
in this mailbox.

A message can be created and saved without sending it right away. To save the message while 
the outgoing message window is open, select Save from the File menu. In the future it can be 
opened and edited. Only unsent messages can be edited. Sent messages are not subject to 
editing. However, you can use the "Send Again" button and the software will create an exact 
copy of the selected message which you will be able to edit.

Address book - The program's address book contains information about your    recipients or 
mailing list.



<Sending a message>

Select a message and press the "Send" button or Select Send Immediately from the File menu 
to immediately send a current message.    A message sending dialog box will appear. You will 
only be able to send an unsent message. Sent messages will need to be created again using 
the "Send Again" button. Many servers require identification, so before sending mail you will 
need to check mail with the help of the "Check Mail" menu item and use the special 
"Preferences" option.



<Address book>

There are two modes for viewing: form mode and table mode. Data can be entered and edited 
only in form mode. In this mode a number of fields will be shown which may be needed to 
record data on the addressee.

· The form mode
· The table

To enter data into the fields press "Edit" to edit, "New" to add and "Delete" to delete. 

A filter can be used to search for and select addresses. Press the filter button and type in the 
parameters. The filter can be set for a complete match or for content of a value. After the filter is 
applied only addresses that fit its parameters will be shown. To remove the filter you will need 
either to press the filter button again and clear all the parameters or close the form and open it 
again. 

Another import function allows to connect your corporate data base with the electronic mail 
exchange system. Thus, if you already have your address book data in MS Excel format you 
can store the data as a text delimited file or in .dbf format and then import into any Netmail 
address book. 



<Finding Text Within Messages and Mailbox>

NetMail incorporates a Find function that searches for specific text within a single message, 
multiple messages for selected mailboxes. To display the Find submenu of commands, select 
Find from the Edit menu.

Finding Text Within One Message
To search for text within a single message, open the message and make sure it is current. Then, 
select Find from the Edit menu and select the Find command from the submenu. The Find 
dialog is displayed, with the blinking insertion point located in the text field. 

Type the text you want to find in the text field. When finished entering the desired text, click the 
Find button. 
Starting at the beginning of the open message, NetMail searches the current message for the 
specified text. If no match is found, the not found alert is displayed.
To continue searching in the same message for the next occurrence of the text, click the Find 
button in the Find dialog, or select the Find Again (F3) command from the Edit menu. These 
commands are equivalent and limit the search to the same message. Repeating these 
commands cycles through the matches in the open message only.



<Filters and message processing>

In the previous section we described address book filters. The software also has filters against 
external messages. 

Netmail allows automatic sorting of incoming messages based on preset criteria and their 
placement in individual folders or mailboxes where they can be viewed at a later time. In such a 
system only those folders can be viewed, for example, where only the most important messages 
are directed. The mail filter processes incoming messages based on header fields, for example, 
using the sender's address or the content of the Subject field. Advanced filters can be applied 
both to any field of the message header or the body of the message itself.

The options can be set in such a way that they will work after each message is received. The 
filter can also be used manually. Use the "Add", "Delete" or "Edit" rules.

Then indicate which word the message subject field should contain or an address to filter 
messages. By filtering a message can be moved to a specified mailbox.
You can filter data depending on a subject of the message and text, contained in it.
Consistently you can impose different filters on the same mailbox.

The rule may be temporarily blocked. The rule can be used by pressing the "Apply" or "Apply 
This" button. The progress bar will reflect performance process.



<Mailboxes. Editing mailbox titles>

Mailboxes and mail folders provide a structured way for NetMail users to organize received 
messages.    The Mailboxes window allows you to create new mailboxes and folders and to 
remove and rename them. You may also want to move mailboxes and folders from one folder to 
another one. 

Clicking on any of the mailboxes in a list opens that mailbox window on the screen. Individual 
messages can be selected, opened, and otherwise manipulated from there.

By default the program contains only three mailboxes:

· In - where received messages are stored;
· Out - where sent messages are stored;
· Trash - where deleted messages are stored.

The names assigned to mailboxes can be edited in the program, i.e. you can delete or move 
them, etc. The list of entered mailboxes is shown in the main menu.

When you select a mailbox from the main menu it will show the list of messages corresponding 
to that mailbox.

Creating a Mailbox

To create a new mailbox, select New... from the Mailbox menu. The New Mailbox Dialog is 
displayed.

Type in the new mailbox name and click OK. The mailbox is created and added to the Mailbox 
and Transfer menus.
You can also create mailboxes using the Mailboxes window under the Tools menu 

Creating a Mail Folder
NetMail allows you to create mail folders in which you may keep one or more mailboxes and 
even other subfolders that hold additional mailboxes. In other words, not only can mailboxes be 
organized into folders, but folders can be contained one within another.

To create a new mail folder, select New... from the Mailbox menu. The New Mailbox Dialog is 
displayed. Type the name of the new mail folder and check the Make it a Folder option. Click 
OK to create the folder.

Creating a Mailbox Within a Folder
To create a new mailbox within a particular folder, select that folder from under the Mailbox 
menu and choose New... from the submenu that is displayed. The New Mailbox Dialog is 
displayed. Type in the new mailbox name and click OK. The mailbox is created and added to 
the Mailbox and Transfer menus. You can also create subfolders in the same manner. Just 
check the Make it a Folder option.



<NetMail Menu Commands>

File
This menu provides basic file and mail program functions.
New Message
Open new message composition window.
Reply
Reply to the sender of the current message.
Send Again
Resend a message rejected by the mail system. Be sure to fix whatever caused the problem before you 
queue the message.
Send Immediately
Save the message in the Out mailbox and send it immediately.
Send Queued Messages
Send all messages that have been queued for delivery.
Check Mail
Pick up new mail from the POP server.    The time in parentheses (if displayed) indicates the next time 
NetMail will automatically check for mail.
Attach File...
Attach file(s) to the current message.
Close
Close the current window.
Save
Save changes to the contents of the topmost window.    This applies to composition windows
Delete
Transfer the current message to the Trash mailbox; also used for deleting messages from the Trash 
mailbox.
Print...
Print the current message(s), 
Exit
Exit the NetMail application.
Edit
This menu provides text editing and sorting tools. 
Undo
Reverse the last editing action taken on a piece of text.
Cut
Delete selected text and place it on clipboard.
Copy
Copy selected text and place it on clipboard.
Paste
Place contents of clipboard at insertion point.
Clear
Delete selected text.
Select All
Select entire contents of message or mailbox.
Find 
Search for designated text or character string within message(s).
Sort submenu
Sorts message summaries in a mailbox.    Hold down the [Shift] key to reverse the order of the sort.
Mailbox
This menu lets you open a mailbox, or bring an open mailbox to the front.
In
Open mailbox where incoming messages are stored until deleted or transferred to another mailbox.
Out
Open mailbox where messages you compose are stored, and where queued messages are held until 



actually sent, and where copies of sent messages may be initially stored.
New...
Display New Mailbox dialog to create a new mailbox. 
[Your Mailboxes]
Mailboxes you create are also displayed in this menu.
Transfer
This menu lets you transfer current message(s) to the selected mailbox.
In
Transfer the current message(s) to the In mailbox.
Trash
Transfer the current message(s) to the Trash mailbox. 
New...
Display New Mailbox dialog to create a new mailbox.    Current message(s) may be transferred into it. 
[Your Mailboxes]
Transfer the current message(s) to the selected mailbox that was previously created by you.



<WARRANTY DISCLAIMER>

THE SOFTWARE IS PROVIDED AS IS WITHOUT WARRANTY OF ANY KIND. TO THE 
MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, VISTA, FURTHER DISCLAIMS ALL 
WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT. 
THE ENTIRE RISK ARISING OUT OF THE USE OR PERFORMANCE OF THE PRODUCT 
AND DOCUMENTATION REMAINS WITH RECIPIENT. TO THE MAXIMUM EXTENT 
PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL VISTA BE LIABLE FOR ANY 
CONSEQUENTIAL, INCIDENTAL, DIRECT, INDIRECT, SPECIAL, PUNITIVE, OR OTHER 
DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR 
OTHER PECUNIARY LOSS) ARISING OUT OF THIS AGREEMENT OR THE USE OF OR 
INABILITY TO USE THE PRODUCT, EVEN IF HAS BEEN ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGES.



<Copyright>

NetMail is copyright of InternetSoft Corporation. 1998 - 2003. 
www.internet-soft.com    All rights reserved.




