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For information on how to use Help, press F1 or select Using Help from the Help menu.



Edit Menu

The Edit menu provides commands to undo edits, access the clipboard, and to delete text.

ndo Undo the previous operation.
t Delete selected text and move it to the clipboard.
Co Copy selected text to the clipboard.
Paste Move text from the clipboard to the current document.
Clear All Delete all text in document.
Delete Delete selected text.




File Menu

The File menu provides commands for creating new files, opening existing files, saving files, printing files,
and exiting the application.

New Create a new, untitled, document.

Open Open an existing file.

Close Close the current document.

Save Save the current document if its contents have changed.
Save As Save the current document under a new name.

Print Print the current document.

Print Preview View a sample printout of the current document.

Print Setup Set printer characteristics.

Exit Exit jedit application.



Search Menu

The Search menu provides commands to find and replace text.

ind Find a pattern of text.
Replace Replace one pattern of text with another.
Next Find and/or replace the next occurrence of text pattern.



Window Menu

The Window menu provides commands to control the position and layout of application's windows.

Cascade Resize and position all windows in an overlapping pattern.
Tile Resize and position all windows in an non overlapping pattern.
Arrange Icons Align all iconized windows along a grid.

Close All Close all windows.



Help Menu
The Help menu provides access to the help system and the about dialog.

Contents Help topic contents.



Copying Text

To copy text to a document from the clipboard, position the cursor at the desired insertion point, and
choose Edit|Copy from the menu.



Deleting Text

To delete text from a document, select the text, and choose Edit|Cut or Edit|Delete from the menu. Cut
will put the deleted text in the clipboard, and Delete will simply delete it.




Exiting

To exit the application, choose File|Exit from the menu.



Edit Window

The edit windows in this application allow reading, editing, printing and saving text files up to 64K
characters in size.



Drag/Drop from the File Manager

Afile can be opened into an editor in the application by dragging the file from the File Manager, and
dropping it on jedit's main window.



Printing

There are three commands on the File menu which support printing of documents from the application.
File|Print Setup is used to select and configure a printer device. File|Print Preview displays a special
preview window which shows how the document will appear when printed. File|Print causes the current
document to be printed.



Edit Copy Command

The Edit|Copy command leaves the selected text intact and places an exact copy of it in the clipboard.
To paste the copied text into another document, choose Edit|Paste.




Edit Cut Command

The Edit|Cut command removes the selected text from your document and places the text in the
clipboard. Choose Edit|Paste to paste the cut text into another document. The text remains selected in

the clipboard, and can be pasted multiple times.




Edit Paste Command

The Edit|Paste command inserts the text currently selected in the clipboard into the current window at the
cursor position.



Edit Undo Command

The EditjUndo command restores the file in the current window to the way it was before your most recent
edit operation. Undo inserts any characters you deleted, deletes any characters you inserted, replaces
any characters you overwrote, and moves your cursor back to a prior position.



Edit Clear All Command

The Edit|Clear All command deletes the entire contents of the current document. Use Edit|Undo to
restore the contents.



Edit Delete Command

The Edit|Delete command deletes the currently selected text from the current document. The text is not
placed in the clipboard. Use the EditjlUndo command to restore the text.



File Close Command

File|Close closes the currently active window.



File Exit Command

The File|Exit command exits jedit. If you've modified documents without saving, you'll be prompted to
save before exiting.



File New Command

The File]New command opens a new, untitled document, and makes it the active window. The application
prompts you to name untitled documents when they are closed.



File Open Command

The File|Open command displays the Open a File dialog box so you can select a file to load into a new
document window. You can also create a new document by naming a file that doesn't currently exist.



File Print Command

The File|Print command prints the contents of the active window. Use File|Print Preview to see how the
document will be laid out on printer pages. Use File|Print Setup to select a printer, and to set printer
options.



File Print Preview Command

File|Print Preview opens a special window that shows how the active document will appear when printed.
The preview window shows one or two pages of the active document as they would be laid out on printer
pages. Controls on the window allow you to page through the pages of the document.



File Print Setup Command

The File|Printer Setup command displays the Printer Setup dialog box which allows you to select and
configure the printer to be used to print documents in the application.



File Save Command

The File|]Save command saves the document in the active window to disk. If the document is unnamed,
the Save File As dialog box is displayed so you can name the file, and choose where it is to be saved.



File Save As Command

The File|Save As command allows you to save a document under an new name, or in a new location on
disk. The command displays the Save File As dialog box. You can enter the new file name, including
the drive and directory. All windows containing this file are updated with the new name. If you choose
an existing file name, you are asked if you want to overwrite the existing file.



Search Find Command

The Search|Find command searches the current document for a text pattern. The command displays the
Find dialog which controls the search process. Options in the dialog determine whether only whole
words are to be matched, whether the case of characters is significant, and whether the search should be
conducted forwards or backwards through the document. As each match is found, it is highlighted in the
document.



Search Next Command

The Search|Next command repeats the last Find or Replace operation.



Search Replace Command

The Search|Replace command searches the current document for a text pattern, and replaces
occurrences of the of the pattern with new text. The command displays the Replace dialog which
controls the search/replace process. Options in the dialog determine whether only whole words are to
be matched, and whether the case of characters is significant. The dialog is also used to specify the
pattern to search for, and the text to replace occurrences with.



Window Arrange Icons Command

The Window|Arrange Icons command arranges all iconized windows into rows along the bottom of the
application's main window.



Window Cascade Command

The Window|Cascade command arranges all document windows from the top-left position of the
application's main window so that the title bar of each is visible.



Window Close All Command

The Window|Close All command closes all document windows open in the application.



Window Tile Command

The Window|Tile command arranges all document windows side-by-side in a non-overlapping pattern.



Window Help table of contents

The Help|Contents displays the help contents page.






The Toolbar

The Toolbar is a row of buttons at the top of the main window which represent application commands.

Clicking one of the buttons is a quick alternative to choosing a command from the menu.
the toolbar activate and deactivate according to the state of the application.
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utton Action Menu Equivalent

Create a new document File|New

Locate and open a file File|Open

Save the file in the active window File|Save
Cut selected text to Clipboard  Edit|Cut

Copy selected text to Clipboard Edit|Copy

Paste text from Clipboard Edit|Paste

Undo previous editor action Edit|Undo

Search for text Search|Eind

Repeat last Find or Replace operation Search|Next
Print the active window File|Print

Preview the printout of the active window File|Print Preview

Display help file contents Help|Contents

Buttons on



Windows Keys

Cursor Movement Keys
Dialog Box Keys
Editing Keys

Help Keys

Menu Keys

System Keys

Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s)

Function

Arrow key
End or Ctrl+Right Arrow
Home or Ctrl+Left Arrow

Pape Up or Page Down

Moves the cursor left, right, up, or down in a field.
Moves to the end of a field.
Moves to the beginning of a field.

Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

Tab Moves from field to field (left to right and top to bottom).

Shift+Tab Moves from field to field in reverse order.

Alt+letter Moves to the option or group whose underlined letter matches the one
you type.

Arrow key Moves from option to option within a group of options.

Enter Executes a command button.
Or, chooses the selected item in a list box and executes the command.

Esc Closes a dialog box without completing the command. (Same as Cancel)

Alt+Down Arrow
Alt+Up or Down Arrow

Spacebar

Ctrl+Slash
Ctrl+Backslash
Shift+ Arrow key
Shift+ Home
Shift+ End

Opens a drop-down list box.
Selects item in a drop-down list box.

Cancels a selection in a list box.
Selects or clears a check box.

Selects all the items in a list box.

Cancels all selections except the current selection.
Extends selection in a text box.

Extends selection to first character in a text box.

Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.

Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the Help
window is already open, pressing F1 displays the "Using Windows Help"
topics.

In some Windows applications, pressing F1 displays a Help topic on the
selected command, dialog box option, or system message.

Shift+F1 Changes the pointer to m- S0 you can get Help on a specific command,
screen region, or key. You can then choose a command, click the screen
region, or press a key or key combination you want to know more about.

(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function
Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter matches the

Alt+Letter key
Left or Right Arrow
Up or Down Arrow

Enter

one you type, when a menu has focus.

Pulls down the menu whose underlined letter matches the one you type.
Moves among menus of the main menu bar.

Moves among menu items within a drop-down menu.

Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Ctrl+Esc Switches to the Task List.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+Tab Swit(_:hes to the next application window, restoring applications that are
running as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application. (See Help

Keys)



Text Selection Keys

Key(s)

Function

Shift+Left or Right Arrow
Shift+Down or Up
Shift+End

Shift+Home

Shift+Page Down

Shift+Page Up

Ctrl+Shift+Left or Right Arrow
Ctrl+Shift+Up or Down Arrow

Ctrl+Shift+End
Ctrl+Shift+Home

Selects text one character at a time to the left or right.
Selects one line of text up or down.

Selects text to the end of the line.

Selects text to the beginning of the line.

Selects text down one window.

Or, cancels the selection if the next window is already
selected.

Selects text up one window.

Or, cancels the selection if the previous window is
already selected.

Selects text to the next or previous word.

Selects text to the beginning (Up Arrow) or end (Down
Arrow) of the paragraph.

Selects text to the end of the document.

Selects text to the beginning of the document.



Window Keys

Key(s) Function

Alt+Spacebar Opens the Control menu for an application window.

Alt+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+Tab Switches to the next application window, restoring applications that are
running as icons.

Alt+Enter Switches a non-Windows application between running in a window and
running full screen.

Arrow key Moves a window when you have chosen Move from the Control menu.

Or, changes the size of a window when you have chosen Size from the
Control menu.









