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Commands
File menu
Options menu
Navigate menu
Window menu
Help menu



File menu commands

The File menu offers the following commands:

Open Open a HTML file from local disk.
Reload Reload the current HTML file.
Setup 
Homepage

Setup your own home page.

Setup Hot List 
File

Setup current hot list file.

Edit HTML 
Source

Edit the current HTML file source.

Edit 
Configuration 
File

Edit the I-View configuration file.

Edit Hot List 
File

Edit the current hot list file.

Save As HTML Save the current HTML file with images to disk.
Save As ASCII Save the current HTML file as a plain text file to disk.
Print Prints the current HTML document.
Print Preview Displays the current HTML file as it would appear when printed.
Print Setup Selects a printer and printer connection.
Exit Exit I-View





Navigate menu commands

The Navigate menu offers the following commands:

Home Go back to home page.
Previous Go to previous HTML page.
Next Go to next HTML page.
Hot List Open the hot list.



Options menu commands

The Options menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Font Setup text fonts for I-View Browser.
Save 
Settings On 
Exit

Save settings on exit I-View. 



Window menu commands

The Window menu offers the following commands, which enable you to arrange I-View Browser windows:

Cascade Arranges Browser windows in an overlapped fashion.
Tile Arranges Browser windows in non-overlapped tiles.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with I-View: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of I-View.



Exit command (File menu)

Use this command to end your I-View session.



Toolbar command (Options menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in I-View, such as Navigate Home Page. 

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in I-View,

To hide or display the Toolbar, choose Toolbar from the Options menu.



Status Bar command (Options menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to 
the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the I-View window.    To display or hide the status bar, use the 
Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you 
depress them, before releasing them.    If after viewing the description of the toolbar button command you 
wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.

NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.





Cascade command (Window menu)

Use this command to arrange Browser and Terminal windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange Browser and Terminal windows in a non-overlapped fashion.





1, 2, ... command (Window menu)

I-View displays Browser windows at the bottom of the Window menu.    A check mark appears in front of 
the document name of the active window.    Choose a document from this list to make its window active. 



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using I-View and various types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of I-View.



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    I-View determines which window is 
next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    I-View determines which window is 
previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the help 
context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the first 
document type supported by your application.    AppWizard produces an alias in the .HPJ file for your 
application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the AFX_HIDP_xxx 
values from the [ALIAS] section of your .HPJ file, and author a topic for each AFX_HIDP_xxx value.    For 
example, AFX_HIDP_INVALID_FILENAME is the help topic for the Invalid Filename message box. >>

  





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where you may 
specify the range of pages to be printed, the number of copies, the destination printer, and other printer 
setup options.



Print dialog box

The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection.    Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so you can select a printer and printer connection.

Print Range
Specify the pages you want to print:

All Prints the entire document.
Selection Prints the currently selected text.
Pages Prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that I-Comm is sending output to the printer.    The page 
number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When you choose 
this command, the main window will be replaced with a print preview window in which one or two pages 
will be displayed in their printed format.    The print preview toolbar offers you options to view either one or 
two pages at a time; move back and forth through the document; zoom in and out of pages; and initiate a 
print job.



Print Preview toolbar

The print preview toolbar offers you the following options:

Print
Bring up the print dialog box, to start a print job.

Next Page
Preview the next printed page.

Prev Page
Preview the previous printed page.

One Page / Two Page
Preview one or two printed pages at a time.

Zoom In
Take a closer look at the printed page.

Zoom Out
Take a larger look at the printed page.

Close
Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a Print Setup 
dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use.    Choose the Default Printer; or choose the Specific Printer option 
and select one of the current installed printers shown in the box.    You install printers and configure 
ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of 
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

  





Open command (File menu)

Use this command to open a HTML file on local disk.This command presents a file selection dialog, 
where you may specify the file you want to open.





View HTML source command (File menu)

Use this command to view the current HTML file source. 





Reload command (File menu)

Use this command to reload the current HTML file.



Setup Hot List File command (File menu)

Use this command to select current hot list file. This command presents a file selection dialog, where you 
may specify the hot list file you want to use. 





Save As HTML command (File menu)

Use this command to save the current HTML with inline images to disk. This command presents a file 
selection dialog, where you may specify the directory and file name you want to save to.    The saved files 
can be viewed later using I-View or other WEB browser. 





Save As ASCII command (File menu)

Use this command to save the current HTML file in plain text format to disk. This command presents a file 
selection dialog, where you may specify the directory and file name you want to save to. 





Setup Homepage command (File menu)

Use this command to setup your own homepage. This command presents a file selection dialog, where 
you may specify the file you want to use as homepage. 





Edit Hot List File command (File menu)

Use this command to edit the current hot list file. I-View hot list file is in plaintext format.    The first item of 
each line is HTTP address, the remaining text on each line is the title of current hot list.    You can change 
the title text. 





Edit Configure File command (File menu)

Use this command to edit I-View configuration file "i-view.ini". 





<< Write application-specific help here. >>

  





Font command (Options menu)

Use this command to change I-View Browser font.      This command presents a font selection dialog, 
where you may specify fonts you want to use for I-View Browser.





Save Settings On Exit command (Options menu)

Use this command to enable or disable setting save on exit I-View.



<< Write application-specific help here. >>

  





Home Page command (Navigate menu)

Use this command to go back the home page.





Previous command (Navigate menu)

Use this command to goto the previous HTML page. 





Next command (Navigate menu)

Use this command to goto the next HTML page. 





Hot List command (Navigate menu)

Use this command to open the hot list. 





<< Write application-specific help here. >>

  




