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Help on using Help

Help is easy to use.    There are five basic steps.

1. Go to the Help window while using the application.

2. Read text, and, if necessary, use scroll bars or PgDn to see more.

3. Click on hotspots for additional information.

4. Use the buttons located at the top of the Help window to navigate through the Help.

5. On the File menu, choose the Exit command to leave Help and return to the application.



Getting to the Help window from the application

You can get Help in several ways:

· On the Help menu, choose the Contents command to go to the main Help topic.

· On the Help menu, choose the Search command and search for Help on a topic.

· Press the F1 key to get Help related to what you are doing.

· Press the Shift+F1 key to turn your mouse cursor into the context sensitive Help cursor .    
Then, click on an item in the application to get related Help.

____________
Tip

Within the ProShare application, Shift+F1 context-sensitive Help is not available for the following 
interface elements:

· the main window's menu bar

· the control menu on the main window, on the floating Annotation toolbox, and on the Data Capture 
toolbox

· the title bar and the minimize button on the Data Capture toolbox



Hotspots

Hotspots can be in text or in a picture.    In text, sometimes called click text, the hotspots are a different 
color (usually green) and either dashed- or solid-underlined.

In both text and pictures, the mouse pointer changes to a pointing hand  when you go over a 
hotspot.

With either text or a picture hotspot, click on the hotspot to go to the related information.
Some hotspots show the related information in a pop-up window.    Click outside the pop-up window to 
close it.

Other hotspots move you to another Help topic.    Choose the Go Back button (at the top of the Help 
window) to return from the jump.

Choose one now to see the difference.    Dashed underlines are pop-up windows.    Solid underlines    
move you to a related screen. 



Button bar

Located at the top of the Help window, these buttons provide the most common navigation and search 
functions.

Move to the main Help topic.

Return to the last Help screen you saw.

Display a window listing the topics you've seen. (Choose any to return there).

Search for a string and then go to a topic containing the string.

In some sections the forward and backward arrows are activated.    Like pages in a 
section of a book, flip to preceding and following topics.

Go to an outline of the Help in the Bookcase window.



Dashed-underline pop-up Help

Right!    This is a pop-up Help topic.    Click outside this window to make the pop-up go away.



Solid-underline jumps

You clicked on a word or phrase identified by a solid underline and jumped to a new topic.    Your 
original topic is gone...but not for long.    See the Go Back button at the top of the Help window?    Click 
on that (or press the B key) to return to where you were.



Searching in Help

In the Search dialog box, type in the word or words that you want to find and click OK.    You get a 
Search Results dialog box.    From there, choose topics that you want to go to.    The Search Results 
dialog box remains on the screen so you can return to it and choose another topic without having to do 
the search again.    Choose Cancel to remove this dialog box.

You can use wildcard characters (*) when you type in the word or words that you want to find.    For 
example:

Bee*

This phrase finds all words that start with Bee.

You can use search operators like AND, OR, NOT, and NEAR when you type in the word or words that 
you want to find.    You can enter an operator in uppercase or lowercase:

AND connects topics finding all phrases connected by AND.    If a phrase does not appear in quotes, 
any space between words in the phrase is assumed to represent an implicit AND.    For 
example:

Bees love honey

This phrase finds any topic containing the three words "Bees," "love," and "Honey."    This is the 
same as specifying Bees AND love AND Honey.    However, when quotes are used, Viewer 
searches for the entire phrase. For example:

"Bees love honey"

This phrase finds any topic containing the phrase "Bees love Honey."

OR The OR operator selects topics containing either phrase connected by OR operators.    For 
example:

Bees OR honey

This query displays topics containing either the word "Bees" or the word "Honey."

NOT The NOT operator selects any topic that does contain the phrase preceding NOT, but doesn't 
contain the phrase following NOT.    For example:

Bees NOT Honey

This query finds topics containing the word "Bees" but not the word "Honey."

NEAR The NEAR operator selects any topic in which one phrase appears within a certain number of 
words of the second phrase.    The default value is 8 words.    For example:

Bees NEAR honey

This query finds any topic in which the word "Bees" appears within 8 words before or after the 
word "Honey."    To change the default value, choose the Options button in the Search dialog 
box and enter a new number in the NEAR Means Within box.    Words that are next to each 
other are within one word of each other.

You can choose the Hints button in the Search dialog box to get a reminder of these operators.

Searching in the Help window

In the Help window, you search the single Help file that you are currently viewing.    This Help file may 
be divided into groups that are listed in the Search dialog box.    If groups appear, you can restrict the 
search by checking the groups to be searched.

Searching in the Bookcase window



In the Bookcase window, you can search the Help file that you are currently viewing as well as any 
other Help file that is registered in your ICOMM.INI file.    The Help files appear in the main Search 
dialog box.    You can restrict the search by checking the files to be searched.



Bookcase window

In the Bookcase window, you see an outline of all the Help files, i.e., books, that are registered in 
ICOMM.INI.    You can expand and collapse items in the outline by double-clicking the titles with a book 
icon.    On titles that have a page icon, double-click to jump to the topic in the associated Help file.

You can print multiple topics using the Print button in the Bookcase window.    When you click the Print 
button, all topics that are subordinate to the currently highlighted topic are printed.

Searching works the same in the Bookcase window and the Help window, except that you can search 
across separate Help files from the Bookcase Search.    When you click the Search button, you get a 
Search dialog similar to the Search dialog in the Help window.



Chapter 1:    Welcome to ProShare™ Personal 
Conferencing

Important

This version 
(1.6) of the 
ProShare 
Personal 
Conferencin
g software 
cannot 
connect with 
version 1.5 
because the 
connection 
methods 
have 
changed. 
However, 
you can 
open a 
version 1.5 
meeting file 
with version 
1.6, which 
automaticall
y converts it 
to the 1.6 
format.

For more 
information

See the 
online Help 
for complete 
information 
on using the 
ProShare 
software.

The ProShare Personal 
Conferencing software is a 
Windows program that two 
people can run simultaneously 
on their computers. The 
computers can be anywhere, 
connected by modem or by 
network*. The conferencing 
participants converse over the 
phone while they see the same 
information on their connected 
computers. When the 
conference connection is made, 
each conference participant 
typically uses a second phone 
line connected to a telephone 
for talking to the other person 
during the conference.

1-1 Where to go from here

The ProShare Personal 
Conferencing software has an 



easy-to-use interface and 
extensive online Help. If you 
prefer to read before you start, 
this guide will help you with the 
basic concepts of the software. 
Otherwise, from the Help menu, 
choose the Tutorial to open an 
easy-to-follow meeting file 
describing how to use the 
conferencing software.

*Novell NetWare 3.11 or greater, 
supported NetBIOS networks, or 
supported TCP/IP protocols.

1-2

Note

Check the 
README.W
RI file for 
current 
product 
information 
before you 
use the 
ProShare 
software. To 
do this, 
double-click 
the Read Me 
icon in the 
ProShare 
program 
group.

ProShare program 
group

Installing the software creates 
the ProShare program group. 
This group contains the icons 
shown below. (The Address 
Book comes with the ProShare 
Premier Edition software only.)

1-3 Using the online manual 
and Help

This manual contains enough 
information to get you started 
with the ProShare software. For 
complete information, refer to 
the online Help.

To access Help:

· From the ProShare 
software, press the F1 key 



to get context-sensitive help 
for the currently selected 
menu, menu command, or 
dialog box. Each dialog box 
also has a Help button; 
choosing the Help button is 
the same as pressing F1. 
To access the main Help 
window, from the Help 
menu in the ProShare 
program, choose the 
Contents command.

Online 
manual icon To access the online manual:

· In the ProShare program 
group, double-click the 
ProShare Manual icon to 
open the online manual. In 
the Contents listing, click 
any topic to see a 
discussion of that item.

To use the Bookcase feature 
of Help and the online 
manual:

· In Help or the online 
manual, click the Bookcase 
button at the top of the 
window to open the 
Bookcase window. The 
Bookcase displays Intel 
Help and online manual 
files in outline format. 



Open and close items in 
the outline by double-
clicking the titles that have 
a book icon. Double-click 
page icons to jump to that 
topic. The selected Help or 
online manual topic 
appears in a second 
window.

From the Bookcase window 
you can select any Help or 
online manual topic to print. 
Click the Print button to 
print the selected Help 
topic.    When you do this, 
all topics that are 
subordinate (which appear 
indented) to that topic are 
also printed.

To navigate within Help and 
the online manual:

· Use the Browse buttons 
(>> and <<) at the top of 
the window to move 
forward and backward 
through topics.

· Use the Go Back button to 
return to the previously 
displayed topic.

· Use the History button to 
see a list of all the topics, 
bookmarks, and commands 
you've selected since 
entering the Help or online 
manual.    To quickly display 
any of these topics, double-
click the desired item.

For more 
information

See the 
topics Button 
Bar and 
Hotspots 
within online 
Help.

· To see more of a Help or 
online manual topic, use 
the scroll bars on the side 
of a topic window or press 
your PgDn key.

· Click hotspots to learn 
more about a topic. A 
hotspot is easily identified 
by the cursor    it turns into 
a small pointing hand when 
positioned over a hotspot. 
Click once to make the 



topic appear. Most of the 
graphics that appear in the 
online help have hotspots.

· Use the Bookmark menu to 
quickly return to a topic you 
have marked.

To search within Help and the 
online manual for any text of 
interest:

Tip

When you 
search for a 
topic from 
Bookcase, 
the search 
can locate 
pertinent 
topics from 
both the 
online Help 
and online 
manual in a 
single 
search.

· From the Help menu, 
choose the Search for Help 
On command, or choose 
the Search button at the top 
of the Help, online manual, 
or Bookcase window. You 
can use the * wildcard 
character and search 
operators within your 
search text to pinpoint the 
topics of interest.

· Once the Search dialog box 
is open, type in the text you 
want to locate. Select the 
topic groups to be 
searched, and click OK. 

· When the search is 
complete, the Search 
Results dialog box appears. 
Double-click the topic to 
display it.

1-4 If you are new to 
Windows

Documentation for the 
ProShare conferencing 
software uses the following 
terms that have special 
meanings in the Windows 
environment.

Choose Pick an item that 
begins an action 
(including menu 
commands and 
buttons).

Select Mark an item by 
highlighting it 
(including check 
boxes, list boxes, 



and radio 
buttons).

Click Press the left 
mouse button 
once.

Double-click Press the left 
mouse button 
twice in rapid 
succession 
without moving 
the mouse.

Drag Press and hold 
down the left 
mouse button 
while moving the 
mouse.

Dialog box A window where 
you edit 
information or 
select options.    
Dialog boxes can 
be moved, but 
not sized or 
minimized.    The 
most common 
way to exit a 
dialog box is by 
clicking OK or 
Cancel.

Tip

Press 
Ctrl+Esc to 
display the 
Windows 
Task 
Manager, 
which lists 
all open 
applications.

To choose applications in 
Windows:

· Hold down the Alt key and 
repeatedly press the Tab 
key to cycle through the 
names of the applications 
open on your computer 
(including Program 
Manager). Release the Alt 
key to bring the last-named 
application to the top.



Chapter 2:    Getting started

Program 
icon To launch the ProShare Personal 

Conferencing software, open the 
ProShare program group and 
double-click the program icon. The 
notebook and floating Data Capture 
toolbox appear.

Note

Each 
conference 
participant 
can 
customize 
the notebook 
to suit 
personal 
needs. 
These 
customizatio
ns do not 
affect what 
the other 
participant 
sees.    See 
the manual 
Chapter 5 
Setting your 
notebook 
preferences.

You can either set up your notebook 
with all the graphics, documents, 
notes, and files you plan to discuss 
during your conference, and then 
connect to your colleague's 
computer; or you can connect to 
your colleague''s computer first, and 
then bring the information of interest 
into your notebook.

2-1 Bringing information into 
your notebook

Any information that you can see on 
your computer screen can be placed 
into the notebook for use during a 
conference. To place information into 
the notebook, you can use the 
following methods:

· Open an existing conference file 
using the Open command.

· Take a picture of all information 
within the highlighted window of 
any Windows-based application 
using the snapshot tool in the 
Data Capture toolbox.

· Capture a portion of information 
appearing on your screen using 
the crop tool in the Data Capture 
toolbox.

· Import a document or a graphic 
file created by another 



application using the Import 
command.

· Print from a Windows application 
directly into the notebook using 
the ProShare print capture 
driver.

To open an existing meeting file 
and place it in your notebook:

1. From the File menu, choose 
Open.

2. Specify the drive, directory, and 
name of the .MTG file to be 
placed into your notebook, then 
choose OK.

Snapshot 
tool To take a snapshot of another 

window:

1. With the desired information 
displayed on the screen (of any 
Windows-based application), 
click the snapshot tool in the 
Data Capture toolbox.

2. Position the camera cursor over 
the open window. The region of 
the window to be captured is 
highlighted with diagonal lines.

3. Click again to pop up a menu of 
destination selections.

Concept

All items that 
appear in 
the 
notebook, 
including 
imported 
graphics, 
text, and 
snapshots, 
are 
bitmapped 
objects.    A 
bitmap is like 
a picture of 
the original 
object.

4. Choose a destination:

· To place the snapshot on a 
new page in the notebook, 
choose New Page or press 
Enter.

· To place the snapshot on the 
displayed page, choose 
Current Page.

· To place the snapshot on a 
new private page in the 
notebook, choose New 
Private Page. (This selection 
is only available when the 
private pages are 
independent from the public 
pages.)

· To place the snapshot on the 
displayed private page of the 
notebook, choose Current 
Private Page.



The image is captured at the instant 
you select a destination. This is 
useful to know if you are capturing a 
video or animated image.

Crop tool
To place a portion of the screen 
into your notebook:

1. With the desired information 
displayed on your computer 
screen, click the crop tool in the 
Data Capture toolbox.

2. Position the crosshair cursor at 
one corner of the information to 
be captured. Press and hold 
down the left mouse button while 
dragging the crosshair cursor to 
the opposite corner of the 
information. Release the mouse 
button. A popup menu of 
destination selections appears. 

3. Select the desired destination. 
The picture of the captured 
information appears in the upper 
left corner of the selected 
notebook page.

To import information into your 
notebook:

1. From the File menu, choose 
Import. The Import dialog box 
appears.

Concept

When the 
ProShare 
software 

2. Specify the drive, directory, and 
name of the file you want to 
place into your notebook, then 
choose OK. The Import As 



opens 
certain types 
of graphics 
or text files, 
it places the 
image or text 
directly onto 
a new 
notebook 
page. (The 
types 
supported 
appear in 
the Import 
Using dialog 
box, shown 
below.) 
However, 
when a non-
supported 
file is 
opened, the 
ProShare 
software 
starts the 
application 
that 
originally 
created the 
file and then 
prints the file 
(using the 
special 
ProShare 
application 
print driver) 
directly onto 
the pages of 
the 
notebook.

dialog box appears:

Note

The 
ProShare 
Print 
Capture 
driver is 
limited to 
printing files 

3. If you are importing a graphics 
file, select the graphic file format 
that matches the extension of 
the graphics file.

If you are importing a text file, 
select Text File (ASCII).
The imported text appears in the 



in 16 colors, 
with the 
exception of 
files with the 
extensions 
listed in the 
Import Using 
dialog box. If 
you would 
like to 
capture an 
image with 
more than 
16 colors 
(and it is not 
one of those 
listed in the 
Import Using 
dialog box), 
open the 
image in its 
parent 
application, 
and then 
take a 
snapshot of 
the image 
using the 
Data 
Capture 
toolbox.

notebook with the same color 
and attributes as the text 
annotation tool. Choose Print 
Capture to make the imported 
text appear and format as it 
would if printed.

For all other files, select the Print 
Capture driver.

4. Choose OK.

When you choose Print Capture, the 
ProShare software locates the 
application that created the file, and 
opens the file within that application. 
The file is then printed into your 
notebook, and the original file and its 
application is subsequently closed.

To print from a Windows 
application directly into the 
notebook:

1. Run the Windows application, 
and open the document.

2. From the File menu of the 
application, choose Print Setup. 
The Print Setup dialog box 
appears. The following 
illustration displays a typical 
Print Setup dialog box.

3. Select PSDATA Capture Driver, 
then choose OK.

Concept

Windows 
applications 
vary in the 
options 
displayed in 
their Print 
dialog 
boxes. 
Some 

4. From the File menu, choose 
Print. The following illustration 
displays a typical Print dialog 
box.



experimentat
ion may be 
needed to 
determine 
what works 
best with the 
document 
you want to 
print to the 
ProShare 
notebook

5. Select the options you want, and 
then choose OK.

The ProShare notebook is 
opened (if it is not currently 
running) and the document is 
printed to the notebook. The 
notebook remains the active 
window after the printing 
completes.

6. At this point, you can return to 
the originating application or 
remain in the ProShare 
application.

Chapter 3:    Connecting
Note

To change 
your 
conference 
connection 
or modem 
settings, 
choose the 
Setup 
command 
from the 
Conference 
menu to 
open the 

You defined your conferencing setup 
during the installation of the 
ProShare software, but you can use 
the Conference Setup dialog box to 
either verify or reset it. Before 
initiating your conference 
connection, call your colleague on 
the telephone and make sure he or 
she is running the correct version of 
the ProShare conferencing software, 
and their machine is set to receive 



Conference 
Setup dialog 
box. To 
change your 
modem 
settings, 
click the Set 
Modem 
button to 
open the Set 
Modem 
dialog box.

the modem or network call.

Tip

If you want 
to conduct a 
conference 
with 
someone 
who does 
not yet own 
ProShare 
Personal 
Conferencin
g software, 
you can 
send that 
person a 
Jump Start 
version. 
Jump Start 
is a limited 
version of 
the software 
that 
operates 
using 
modems and 
networks.    
See the 
topic 
Working with 
someone 
who doesn't 
have the 
ProShare 
application 
within the 
online Help.

You can connect with your colleague 
either before or after you place the 
desired conferencing information 
into your notebook. However, you 
cannot share a Windows application 
with your colleague until after your 
computers are connected with the 
ProShare software.

If you are initiating the conference, 
your colleague's computer must be 
ready to receive your connection as 
described below under "Receiving a 
connection."

3-1 Initiating the connection

1. From the Conference menu, 
choose Connect. The Connect 
dialog box appears.



Note

If you have 
Premier 
Edition, use 
Address 
Book to 
store names, 
phone 
numbers, 
and network 
addresses 
used by the 
ProShare 
Premier 
software.    
See below, 
"Using 
Address 
Book 
(Premier 
Edition) for 
basic 
instructions. 
See Address 
Book Help 
for complete 
details.

To add a new person to the 
list:

2. Click the Add Name button. The 
Add Participant Name dialog box 
appears. Type the name of the 
person and choose OK.

3. Repeat step 2 to add and store 
the names of your colleagues.

The ProShare software 
maintains a list of the people 
with whom you have recently 
connected. Each entry includes 



the person's modem telephone 
number, network addressing 
information, or both. When you 
want to reconnect with anyone 
on the list, scroll through the 
Participant Name list and select 
the name.

4. In the Connect dialog box, select 
the connection method to be 
used for this call: either Modem 
or Network. When you select the 
Modem connection method, the 
Modem Connection Details 
dialog box appears:

Concept

You can use 
any 
combination 
of 
parentheses, 
hyphens, or 
spaces as 
separators in 
the phone 
number.    
For 
example, 
you could 
enter

1-
(503)555-
1212 or 

1-503-
555-1212 or 

1503555121
2 
to specify 
the same 
phone 
number.    If 
you need a 

For a modem connection:

· Type the phone number of 
the modem to which you 
want to connect. Be sure to 
include the area code and 
any required long-distance, 
international, or other 
access codes.

· Select a baud rate from the 
drop-down list if the current 
rate is not correct for this 
connection. Choose OK.

For a network connection:

If you choose Network in the 
Connect dialog box, the Network 
Connection details dialog box 
appears.

· Position the cursor on the 
Connect Using list and 
select the type of network to 
be used for the connection. 



dialing 
pause, insert 
a comma.

(If you are using just one 
type of network, the drop-
down list does not appear.)

This Network Connection 
Details dialog box appears 
when you select the 
NetWare network 
connection method:

If you 
cannot 
connect 
with the 
other 
computer:

· Make sure 
your 
colleague 
has 
started the 
correct 
version of 
the 
ProShare 
software 
on his or 
her 
computer.

· Use the 
Communi
cations 
Test 
program 
in the 
ProShare 
program 
group to 
test a 
modem or 
your 
computer'
s access 
to the 
network.

· For a NetWare connection, 
click the Search button and 
select the server and name 
of your colleague. The 
network address fills in 
automatically. (If you don't 
know the user name or 
server for your colleague, 
ask your colleague to 
choose the Setup command 
from the Conference menu. 
Your colleague can tell you 
his or her address. Enter the 
address in the Net Address 
box as described by your 
colleague.) Once the 
settings are made, choose 
OK.

A Network Connection 
Details dialog box similar to 
the following appears when 
you select the NetBIOS or 
TCP/IP network connection 
method:



· Make sure 
your 
colleague'
s 
Conferenc
e Setup 
selections 
are set 
appropriat
ely. (See 
the 
Receiving 
a 
connectio
n section 
following.)

· If 
connectin
g with 
modems, 
make sure 
you have 
the 
appropriat
e COM 
port 
selected, 
and make 
sure you 
dialed the 
correct 
telephone 
number 
(including 
the area 
code, if 
necessary
). See the 
topic 
Troublesh
ooting 
within the 
online 
Help for 
assistanc
e if you 
cannot 
connect 
with 
modems.



Important

When 
connecting 
over a 
NetBIOS or 
TCP/IP 
network, the 
address 
name is 
case 
sensitive.

· For a NetBIOS connection, 
enter the network address of 
your conferencing colleague. 
(If you don't know the 
network address for your 
colleague, ask your 
colleague to choose the 
Setup command from the 
Conference menu. Your 
colleague can tell you his or 
her address. Enter the 
information in the address 
box as described by your 
colleague.) Once the 
network address is entered, 
choose OK.

· For a TCP/IP connection, 
enter the TCP/IP host 
address of your colleague's 
computer; for example, 
johnd.intel.com.

5. Choose the Connect button to 
establish the connection from 
your computer to your 
colleague's computer.

3-2 Receiving a connection
Tip

Configure    
your 
Conference 
Setup dialog 
box for each 
type of 
connection 
you plan to 
use.    As 
shown here, 
you can 
configure for 

You defined your conferencing setup 
during the installation of the 
ProShare software, but you can use 
the Conference Setup dialog box to 
either verify it or change it. The 
following procedure explains how to 
change your conference setup.

1. From the Conference menu, 
choose Setup to open the 



modem, 
NetWare 
network, 
NetBIOS 
network, and 
TCP/IP 
protocol. 
Your 
selections let 
ProShare 
know which 
connections 
to listen to 
for incoming 
conference 
calls.

Conference Setup dialog box.

2. Make sure the appropriate 
Modem and Network check 
boxes are selected. Your 
selections should include the 
connection methods your 
colleagues will be using to 
conference with you. If you 
select a network connection, the 
network information for your 
system appears. If you select 
Modem, your modem baud rate 
and COM port appear.

If you need to change modem 
settings, choose Set Modem and 
continue to the next step. 
Otherwise, skip to step 4.

3. The Set Modem dialog box 



appears when you choose the 
Set Modem button.

· Select your modem type or a 
type compatible with your 
modem.

· Select the baud rate.

· Identify your modem's COM 
port number.

· If you are accessing a 
modem or modem pool 
connected through a 
network, select the Use 
Int14 check box.

· If you are using a custom 
high-speed driver with your 
modem, select Use High 
Speed Baud Rates and then 
select the baud rate to use.

· Only if necessary, change 
the default modem 
commands for Initialize, Dial, 
and Answer. To do this, 
select Customize Modem 
Strings. See the online 
Troubleshooting Help or 



your modem documentation.

· If the settings you made 
here are to be permanent, 
select the Permanent 
Changes check box. 
Otherwise, these changes 
apply to this session only.

· After you have made all your 
changes, choose OK to exit 
the Set Modem dialog box 
and return to the Conference 
Setup dialog box.

4. Select the Permanent Changes 
check box in the Conference 
Setup dialog box and choose 
OK. This saves your total 
configuration for the next time 
you start a conference. 
Otherwise, these changes apply 
to this session only.

5. By telephone, tell your colleague 
that your computer is ready to 
receive.

3-3 Using the Address Book 
(Premier Edition)

Concept

Address 
Book comes 
with the 
ProShare 
Premier 
Edition 
software. 
Use it to 
store the 
modem 
numbers or 
network 
addresses 
you've 
entered.    
Address 
Book stores 
the 
information 
and passes 
it to the 
conferencing 
software, 
which 
subsequentl
y establishes 
the meeting 
connection.

Address Book is a telephone 
directory for your computer. Use 
Address Book to store names, 
addresses, telephone numbers, and 
network addresses. Although the 
primary purpose of Address Book 
discussed here is to store and 
connect to the people you 
conference with using the ProShare 
application, you can also use it as 
your central telephone directory.

Note
To open Address Book:



All 
addresses 
are initially 
stored in 
PROSHARE
.ABF, and 
can be 
accessed by 
the 
ProShare 
software 
Connect 
dialog box 
and the 
ProShare 
Premier 
Edition 
Address 
Book. You 
can also 
create and 
name 
other .ABF 
files.

· Double-click the Address Book 
icon in the ProShare program 
group, or

· From the Conference menu in 
the ProShare software, choose 
Address Book.

The following Address Book 
window appears.

Tip

Press F1 for 
online help 
at any time 
while using 
the Address 

When you start Address Book from 
the ProShare Premier application for 
the first time, a default Address Book 
file (PROSHARE.ABF) is opened. 
You can add entries to this file or you 



Book.
can create new Address Book files. 
The entries you make in Address 
Book files can be used by the 
ProShare Premier application to 
initiate conferences via modem or 
network.

To create a new file, from the File 
menu, choose New. To open a 
different Address Book file, from the 
File menu, choose Open. You can 
have up to four Address Book files 
open at the same time and switch 
among them by selecting the file 
name from the bottom of the File 
menu.

To add a person to the Address 
Book:

1. Click the Add button on the 
Address Book toolbar, or from 
the Edit menu choose Add 
Individual, to display the 
following dialog box.



2. Enter the requested information 
in each field.
You can leave all fields blank, 
except the first and last name 
fields.

3. In the Connections section of the 
dialog box, choose New.
The New Connection dialog box 
appears.

4. Select the transport. If it is a 
phone, select the uses for this 
phone number.
For example, if this person has a 
modem with a voice phone 
attached, select Data 
Conference and Voice.

Note

Choose 
Phone for 
modem, fax 
modem, 
ISDN, or 
voice phone 
numbers.

5. Repeat steps 3 and 4 for each 
connection method to be defined 
for the individual.

6. Choose OK to accept the 
individual and his or her 
associated connection methods 
into the current Address Book 



file.

Note

Use the Dial 
button or 
command to 
connect, 
regardless of 
the method 
of 
connection.

To connect using the Address 
Book:

1. Highlight the name of your 
colleague in the Name List.

2. In the connection list at the 
bottom of the screen, highlight 
the modem phone number or 
network address.

3. Click the Dial button on the 
toolbar, or from the Call menu, 
choose Dial.

For complete details on using 
the Address Book, see the 
online Help.



Chapter 4:    Conducting the conference

Concept

Marks you 
make on 
your 
notebook 
pages with 
any of the 
annotation 
tools are 
each 
considered 
an object, 
including 
text 
annotations 
and images 
brought in.

During a conference you can:

· View, share, and revise 
information.

· Take notes in a private 
workspace.

· Send files to and receive files 
from the other participant.

· Work interactively on a 
document with the other 
participant from within a shared 
application, and more. 

All the methods for placing 
information into your notebook 
before you begin the conference can 
also be used to bring in additional 
information during a conference.

4-1 Annotating and marking a 
page

Annotating the notebook is as easy 
as using a pen or highlighter on 
paper. Once you make a mark in the 
notebook, you can move, copy and 
paste, resize, or delete it.

All of the annotation tools, except 
the selection pointer, can be 
customized by either double-clicking 
the tool in the Annotation toolbox, or 
by choosing the Configure Tool 
command from the Toolbox menu. 
See the online Help for full details.



To use the annotation tools: 

· The selection pointer selects an 
object when you click it. To 
select multiple objects, press 
and hold the Shift key as you 
click each object. You can also 
click in an area and drag the 
mouse to create a selection 
rectangle. All objects that are 
totally within the selection 
rectangle are selected.

· The remote pointer points to 
items in your notebook during a 
conference. To use the remote 
pointer so both participants can 
see the pointer moving around 
the page, be sure the remote 
pointer tool is selected, and the 
mouse button is held down as 
you move the cursor.

Tip

You can 
easily 
change the 
color of any 
of the 
annotation 
tools by 
double-
clicking the 
tool to 
display the 
Configure 
Tool dialog 
box.

· The text tool adds typed text to 
the page. To do this, select the 
text tool,    place the cursor 
where you want to start the new 
text, and type. Press the Enter 
key when you reach the edge of 
the page to start the next line; 
otherwise, the text runs off the 
visible right edge of the 
notebook page. (A scrollbar 
appears so you can scroll the 
window to see the text.)

· The highlighter colors items on 
the notebook page for emphasis. 
To highlight information, select 
the highlighter tool and then click 
and drag the highlighter over the 
information.

· The pen draws freehand objects 
on the page. To use the pen, 
select the pen tool, and then 
click and drag.

· The rectangle draws rectangles 
and squares on the page. To 
draw a rectangle, select the 
rectangle tool and then click and 
drag. To draw a square, press 
and hold the Shift key as you 
click and drag.

· The ellipse draws ellipses and 
circles on the page. To draw an 



ellipse, select the ellipse tool 
and then click and drag. To draw 
a circle, press and hold the Shift 
key as you click and drag.

· The line draws straight lines on 
the page. To draw a line, select 
the line tool and then click and 
drag. To snap a line to 45 
degree increments, press and 
hold the Shift key as you click 
and drag.

Tip

To move 
multiple 
objects, 
Shift+click 
each one, 
then drag 
the mouse. 
Release the 
mouse when 
the objects 
are 
positioned.

To move an object on the page:

1. Select the object by clicking on it 
with the selection pointer. Black 
handles appear on all sides of 
the object.

2. Drag the object (not by the 
handles, but so that the 
selection pointer is within the 
hangles) to the desired location 
and release the mouse button.

Tip

To delete    
multiple 
objects, 
Shift+click 
each one, 
then press 
the Delete 
key or from 
the Edit 
menu, 
choose 
Delete.

To delete an object on the page:

1. Select the object by clicking on it 
with the selection pointer. Black 
handles appear on all sides of 
the object.

2. Press the Delete key, or from the 
Edit menu, choose Delete.

Tip

To resize an 
object 
proportionall
y, choose 
the Resize 
command 
from the Edit 
menu. You 
can also 
hold down 
the Shift key 
while 
dragging a 
handle on 
the selected 
object.

To resize an object:

1. Select the object by clicking on it 
with the selection pointer. Black 
handles appear on all sides of 
the object.

2. Place the mouse cursor on one 
of the handles until the cursor 
changes to a double-ended 
arrow. Hold down the mouse 
button and drag the handle to 
resize the object.

Text Tip

If you begin 
to type when 
a text 
annotation is 
selected, the 

To edit a text annotation

1. Select the text annotation tool. 
The cursor changes to an I-
beam.



new text 
appends to 
the end of 
the text 
selection.

2. Click in the text annotation at the 
point where you want to edit.

3. Edit the text, using the arrow 
keys to move through the 
annotation and the Delete or 
Backspace key to delete text.

4-2 Recording private notes

During your meeting, you can make 
notes in your private workspace    
that cannot be seen by the other 
participant.

Tip

If you still 
need to see 
a larger area 
of your 
notebook 
pages after 
you've 
selected the 
Full Screen 
setting from 
the View 
menu, you 
can turn off 
the Status 
bar, the 
Spiral, the 
Attendee 
Status Bar, 
and the 
Private Title 
bar by first 
choosing the 
Preferences 
command 
from the 
View menu.

To open the private workspace:

· From the View menu, choose 
Private Workspace. The private 
workspace appears at the 
bottom of your notebook.

To record information in the 
private workspace:

· Use the annotation tools inside 
the private workspace.

· When using the snapshot or 
crop tool in the Data Capture 
toolbox, choose Current Private 
from the popup destination 
menu.

· From the Edit menu, choose 
Paste, then Private, to paste 
information from the Windows 
Clipboard into the current private 
page.

Tip

You can 
adjust the 
proportions 
between 
public and 
private 
pages by 
dragging the 
cursor up or 
down at the 
dividing line 
between the 
two 
workspaces. 
For more 
information, 
see the topic 
Working in 
the private 
workspace 

To link or unlink your private and 
public pages:

You can link your private pages to 
your public pages so that both parts 
of the notebook track together as 
you change pages. When the pages 
are linked, only the public page tabs 
appear at the right edge of the 
notebook page.

Not linking your public and private 
pages makes them independent 
from each other. In this case, when 
you move to another public page, 
your private notebook page does not 
simultaneously change. When the 



within the 
online Help. pages are independent, separate 

page tabs appear for both the public 
and private pages of the notebook.

1. From the View menu, choose 
Preferences. The Preferences 
dialog box appears.

2. Select Link Public and Private 
Pages to link your private pages 
to your public pages.

See Setting notebook preferences in 
Chapter 5 for details on the 
Preferences dialog box, or press F1 
for online help.

4-3 Managing your notebook 
pages

Use the tabs on the right edge of the 
notebook pages to switch the current 
page, add a new page, or 
synchronize the other participant's 
notebook to the same page.

Concept

Scrolling 
tabs (that is, 
the scrolling 
up-arrow tab 
and the 
scrolling 
down-arrow 
tab) appear 
when your 
notebook 
cannot 
display all 
page tabs at 
once.

To switch from page to page:

· Click the numbered tab of the 
page you want to display, or

· Press the Ctrl+PgUp or 
Ctrl+PgDown keys until the 
desired page highlights.

To add a new page:

· Click the new page tab (the tab 
with a + on it). A new tab 
appears with a new page 
number.



To scroll a hidden page tab into 
view:

· Click either the scrolling up-
arrow tab or the scrolling down-
arrow tab until the desired page 
tab appears. Click and hold the 
scrolling tabs to move the page 
tabs into view at an accelerated 
rate. Note that these actions 
don't change the currently 
displayed page, they only move 
more page tabs into view.

Tip

The 
Attendee 
Status bar, 
directly 
above the 
notebook 
page, shows 
the number 
of the public 
page that is 
currently 
being 
viewed by 
each 
conference 
participant.

To synchronize the other 
participant's notebook with yours:

· Double-click the tab of the page 
you want to be the current page 
in both participants' notebooks, 
or

· From the Edit menu, choose 
Synchronize Pages.

To move to the page the other 
participant is on:

· Double-click the page number in 
the Attendee Status bar.

4-3-1 Using the Page Sorter
Tip

To work on a 
group of 
pages in the 
Page Sorter 
dialog box, 
either select 
each page 
with 
Ctrl+Click, or 
select a 
range of 
pages by 
using 
Shift+Click 
to specify 
both the 
starting page 
and the 
ending page. 
Each 
selected 
page is 
highlighted 
with a heavy 
border. You 
can then 
move, 
reorder, 

Use the Page Sorter to view, 
reorder, print, or delete the notebook 
pages. From the View menu, choose 
Page Sorter to open the Page Sorter 
dialog box. This displays thumbnail 
sketches of the pages from either 
your public or private workspace. 
The thumbnails are ordered 
sequentially.

The following Page Sorter window 
shows that the current notebook 
contains multiple public pages:



delete, or 
print the 
pages as a 
group.

To switch between viewing the 
public pages and the private 
pages:

1. Select the Private Pages check 
box to display the thumbnail 
sketches of your private pages. 
When no check mark is 
showing, the thumbnails are of 
your public pages.

2. Use the scroll bars below the 
thumbnails to determine which 
pages appear in the viewing 
area.

To reorder the pages:

You can reorder the pages within the 
private and public workspace, but 
you cannot move a page between 
the private and public workspaces.

1. Select the page to be moved. A 
heavy border appears around 
the page.

2. Drag the page to where you 
want it to appear among the 
pages and release the mouse 
button.

For more 
information

See the 
topic Print 
Setup dialog 
box within 
online Help.

To delete a page:

1. Select the page or pages to be 
deleted.

2. Choose the Delete button to 
delete the page from your 
notebook.



To go to a page:

1. Double-click the page in the 
Page Sorter dialog box.

To print a page:

1. Select the page or pages to be 
printed.

2. Choose the Print button to print 
the page on your current printer.

4-4 Transferring and receiving 
files

During a conference you can send 
or receive files from the other 
participant's computer. Once begun 
by the sender and acknowledged by 
the recipient, the file transfer 
process occurs in the background, 
so that the meeting participants can 
continue using other conferencing 
features.

To select 
multiple 
files:

Control+click 
to select 
multiple non-
consecutive 
files to 
transfer. 
Shift+click to 
select 
multiple 
consecutive 
files.

To transfer a file:

1. From the File menu choose 
Transfer. The File Transfer 
dialog box appears.

2. Select the files you want to 
transfer, then choose OK.



The first of the specified files 
appears in the status bar of the 
sender's notebook page (lower 
right corner). When the receiver 
clicks OK to begin the transfer, 
all the specified files are sent

3. From the File menu, choose 
Transfer Status to display a 
dialog box showing the progress 
of the file transfer.

To receive a file:

1. Shortly after the sender initiates 
a file transfer, the File Transfer 
Receipt dialog box appears on 
the receiver's screen:

2. Specify the drive and directory 
where you want the file or files 
placed. If you want to overwrite 
an existing file, select the 
Overwrite Old Files box. 
Otherwise, a dialog box appears 
prompting you for a name for 
any duplicate file name.

3. Choose OK.

4-5 Using embedded 
information

Concept

To use 
shared OLE 
with the 
ProShare 
software, the 
application 
that creates 

Use the Windows Object Linking and 
Embedding (OLE) feature to embed 
into your notebook a graphic, 
document, or other object created 
with another application. Either 
participant can then edit or revise 



the OLE 
object must 
be an OLE 
server. Not 
all Windows 
applications 
support this 
function. For 
shared OLE 
to work 
properly, the 
application 
invoked by 
shared OLE 
must be the 
same 
version on 
the systems 
of both 
participants.

In general, 
the format 
listed at the 
top of the 
Data Type 
list in the 
Paste 
Special 
dialog box is 
OLE-
enabled.    
Only those 
formats 
indicated by 
the word 
Object are 
editable. 
Also, the 
appearance 
of the 
shared OLE 
object within 
the 
ProShare 
notebook is 
dependent 
upon the 
parent 
application.

the embedded information in the 
ProShare software. To change 
information you embedded within the 
notebook, double-click the shared 
OLE object to launch the originating 
application from within the ProShare 
application, make your changes, exit 
or update the file, and continue the 
conference.

To embed an object:

1. Open the application program 
and create the desired object.

2. Use the application's menus and 
commands to cut or copy the 
desired object to the Windows 
Clipboard.

3. From the Edit menu in the 
ProShare application, choose 
Paste Special. The Paste 
Special dialog box appears.



4. Choose the application object 
data type.

5. Choose Paste to embed the 
object.

Important

If you paste 
a portion of 
a 
spreadsheet 
into the 
notebook as 
a shared 
OLE object, 
be aware 
that the 
entire 
spreadsheet 
is displayed 
when you 
launch the 
application.

Important

Only one 
participant at 
a time can 
edit an 
embedded 
object in the 
shared 
notebook.

To edit an embedded object:

1. Choose the selection pointer 
tool.

2. Double-click the embedded 
object in the ProShare notebook 
to start the originating 
application.

3. Make the desired changes to the 
object in the application.

4. Save or update the object to 
reflect your changes.
You must update the changes 
you've made, or they will be lost.

4-6 Sharing applications 
(Premier Edition only)

Concept

An 
application 
being shared 
within the 
ProShare 
Premier 
software 
works as it 
does when 
run directly 
from 
Windows. 
The major 
exception is 
that now 
both you and 
the other 
participant 
can 
simultaneou
sly interact 
with the 
application 
to create or 
revise the 
same 
information 
or object.

At any time during a meeting, either 
participant can share one or more 
Windows applications with the other 
participant. The shared application 
resides and runs on one computer, 
but can be used simultaneously from 
both systems. Sharing is useful 
when both participants want to work 
together to create or revise a file 
created in the application.

The participant who starts the 
application is the host and the 
person who views and optionally 
interacts with the application is the 
guest.

To share an application:

1. Be sure a conference 
connection is established 
between both computers using 
the Premier Edition of the 
ProShare software.



2. From the Program Manager, the 
host starts the applications to be 
shared.

Share 
Application 
tool

3. From the notebook, the host 
clicks the Share Application tool 
in the Data Capture toolbox. 
(You can also start sharing by 
choosing the Share Application 
View command from the 
Application menu.) The Share 
Application View dialog box 
appears on the host's computer.

Concept

The Share 
Application 
View dialog 
box lists all 
shareable 
Windows 
applications 
currently 
running on 
the host's 
computer. 

4. The host clicks the name or icon 
of the application to be shared 
and chooses OK.

Title bar 
Sharing 
Mode Icon

When an application is shared, a 
sharing mode icon appears in the 
title bar of the shared application on 
the host's computer to show that the 
application is visible to the guest. 
This icon shows whether the guest 
has permission to interact with the 
application: two arrows on the icon 
indicate both participants can 
interact, and one arrow indicates 
only the host can interact with the 
shared application. The host controls 
the interaction setting. 



You can share multiple Windows 
applications by repeating steps 2 
through 4 above. You are limited by 
the resources of your system. See 
the online Help for information on 
increasing system resources, 
especially if you are on a network.

4-6-1 The Sharing Window

The guest sees the shared 
application within the Sharing 
window, separate from the notebook 
window, on his or her computer. The 
sharing mode icon appears in the 
title bar of any shared applications 
within the Sharing window.

The Sharing window appears in the 
upper left corner of the guest's 
screen the first time you share an 
application. Thereafter, the Sharing 
window opens where it was when 
you previously ended a sharing 
session. Move and resize the 
Sharing window as you do any 
window, except in the following 
situation.

As the guest, you can never make 



the Sharing window larger than the 
screen on the host's system, or 
larger than the video resolution of 
the host's system. As an example, if 
the host system displays the shared 
application at 640 x 480 pixels, then 
the Sharing window on the guest 
system appears at 640 x 480, 
regardless of the video resolution of 
the guest system.

To alternate the guest's Sharing 
window between full screen and 
normal size:

· From the Sharing window's 
control menu, choose the Full 
Screen command to enlarge the 
Sharing window to full screen, or

· Use Ctrl+Alt+F to alternate the 
Sharing window between full 
screen and normal size.

Full screen mode differs from the 
Windows maximized condition in 
that the title bar of the Sharing 
window is not displayed in full 
screen mode.

4-6-2 Setting the sharing mode

To set the sharing mode:

The host controls whether the guest 
has permission to interact with the 
shared application. Interactive is the 
default sharing mode. When 
interactive sharing is enabled, any 
mouse or keyboard action performed 
by either participant within the 
shared application is reflected on the 
screens of both participants. This 
can make the cursor jump around 
when both participants attempt a 
different action at the same time. To 
avoid this problem, talk on the 
telephone as you share the 
application, and take turns using the 
mouse or making changes.

Sharing 
mode tool As the host, you set the sharing 

(interactive) mode for the guest by 
either of the following methods:

· Choose the Sharing Mode tool in 



the Data Capture toolbox to 
alternate between interactive 
and View-only mode, or

· From the Application menu of 
the ProShare notebook, choose 
Host and Guest Edit to enable 
interactive mode, or choose 
Only Host Edits to enable view-
only mode.

View-only 
cursor When view-only mode is enabled or 

when the Sharing window is not the 
top-most, active window, the guest's 
cursor changes to the View-only 
cursor inside the Sharing window. 
This cursor indicates to the guest 
that work cannot be performed by 
the guest at this time within the 
shared application. The host cannot 
see the guest's cursor when it is in 
View-only mode.

Stop Sharing 
tool To stop sharing:

Either the host or the guest can stop 
sharing an application.

· Choose the Stop Sharing button 
in the Data Capture toolbox. 
(You can also use the Stop 
Sharing Application command 
from the Application menu.) This 
action stops sharing of all 
applications. Note that the 
applications remain open on the 
host's machine until specifically 
closed.

· You can also stop sharing an 
application by closing that 
application. This action is the 
only way to stop sharing one 
application when more than one 
is being shared.

4-6-3 More about application 
sharing

When application sharing begins, 
the sharing mode icon appears in 
the title bars of the shared 
applications. Otherwise, everything 
about the shared application 
appears and works as usual.



For example, if the shared 
application is WordPerfect, the host 
sees:

The guest sees the shared 
application within the Sharing 
window:



Note

Areas of the 
host's 
screen that 
are not part 
of the 
shared 
application 
appear black 
to the guest

When a portion of the host's shared 
application window becomes 
covered by another window that is 
not part of a shared application, the 
guest's Sharing window reflects the 
obscured area with green diagonal 
lines (see next illustration). The 
green diagonal lines show the guest 
that the information under the 
obscured area might not match the 
data in the shared application on the 
host's system. The guest may be 
able to click in an area of the shared 
application that is not covered by the 
diagonal lines to make the Sharing 
window active and update the 
guest's screen. (This won't work if 
the obscuring item on the host's 
screen requires an action from the 
host to make the obscuring item go 
away, such as a system error 
message dialog box.)

For example, if the host moves 
another window on top of the right 
side of the shared application, the 
guest sees:



After the host moves the obscuring 
window, or the guest clicks in the 
non-obscured area of the window, 
the guest sees the obscured area of 
the shared application in real time 
again.

4-6-4 The Pan Window
Guest's Pan 
Window

A Pan 
window 
indicates to 
the guest 
that the 
Sharing 
window 
cannot show 
all of what 
the host 
sees of the 
shared 
application. 
The outer 
edge of the 
Pan window 

When the guest's Sharing window is 
smaller than the shared application 
window on the host's screen (or if 
the shared application display would 
exceed the guest's screen 
resolution), the Pan window appears 
on the guest's screen. The Pan 
window shows a thumbnail size and 
shape of the shared application, as 
the host sees it. In the Pan window, 
the part of the application currently 
visible to the guest is outlined in 
gray. The guest can drag the gray 
outlined window to make other areas 



corresponds 
to the outer 
edges of the 
host's 
shared 
application 
window.

of the application visible. A black dot 
within the window indicates the 
current location of the guest's cursor 
in relation to the application as seen 
by the host.

The guest can minimize the Pan 
window, but not close it. If the guest 
is able to enlarge the Sharing 
window so that it encompasses the 
entire shared application (as seen by 
the host) the Pan window closes.

4-7 The shared document
Note

If either the 
host or the 
guest closes 
a shared 
application, 
the host is 
prompted to 
save the 
document 
before the 
application 
closes.

Once you have stopped sharing an 
application, the document that you 
were working on resides on the 
host's computer. The host should 
save the document, with a different 
name if desired, before closing the 
application. If the guest wants a 
copy of the document, the host must 
use the Transfer command from the 
File menu to send it to the guest. 
See the section Transferring and 
receiving files, earlier in this chapter, 



for details on how to do this.

Chapter 5:    Concluding the conference

5-1 Disconnecting
Note

The notes 
you made on 
your private 
pages are 
retained only 
in the .PRV 
file that you 
save. The 
other 
participant 
does not 
have access 
to your 
private 
notes.

To end a conference and break the 
connection between the two 
computers, either participant can 
choose Disconnect on the 
Conference menu.

5-2 Saving your notebook
Concept

Once saved, 
the .MTG file 
can be 
opened in a 
later 
conferencing 
session for 
further 
discussion. 
Once 
opened, the 
saved file is 
placed into 
the public 
pages of 
your 
notebook 
exactly as it 
was when 
you 
performed 
the save.    
See Section 
2-1 for 
instructions 
on opening a 
conference 
file.

You can save the contents of your 
notebook, including all public and 
private notes. The public pages are 
saved in a meeting file with 
the .MTG file extension; your private 
pages are saved in a private file with 
the same name as the meeting file 
but with a .PRV file extension. Such 
files can be used in future 
conferences.

To save the public pages of your 
notebook:

1. From the File menu, choose the 
Save As command. The Save As 
dialog box appears.



Important

If you open a 
version 1.5 
meeting file, 
it is 
automaticall
y converted 
to version 
1.6 format. It 
cannot be 
subsequentl
y opened in 
version 1.5.

2. Specify the drive, directory, and 
a .MTG file in which the public 
pages of the notebook are to be 
saved, then choose OK. Your 
private pages are saved 
automatically with the same 
filename but with a .PRV 
extension. 

5-3 Printing your notebook

To print your notebook pages:

1. Choose the Print command from 
the File menu. The Print dialog 
box appears.



Note

Press F1 for 
detailed help 
on the 
options in 
the Print 
dialog box.

2. Check the printer named at the 
top. To specify another printer, 
choose the Setup button.

3. From the Print selections, select 
either Public, to print pages from 
the public workspace; Private, to 
print pages from the private 
workspace; or Both, to print 
pages from both workspaces. In 
a linked notebook (where private 
pages are an extension to the 
public pages), each private page 
is printed after its corresponding 
public page. In an independent 
notebook (where private pages 
are independent of the public 
pages), private pages are 
printed after all public pages 
have been printed.

4. From the Print Range selections, 
select the desired pages.

5. Select the desired Print Quality. 
The list contains settings 
supported by the printer named 
at the top.

6. From the Scaling selections, 
select the desired scaling.

7. Enter the number of copies to 
print.

8. Select Collate Copies if you are 
printing multiple copies and you 



want each copy of the notebook 
to finish printing before the next 
copy is printed.

9. Select Print to File if you want to 
create a print file rather than 
send the output directly to a 
printer. Then, when you choose 
OK in step 11, the Print to File 
dialog box appears and prompts 
you to enter the filename. (You 
can precede the filename with 
drive and path designations. 
Otherwise the file is saved to 
your current directory.

10. Select Include Page Numbers if 
you want page numbers printed 
at the bottom of each page.

11. Choose OK.

5-4 Setting notebook 
preferences

Each conference participant can 
customize his or her notebook to suit 
personal tastes. These 
customizations do not affect what 
the other participant sees during the 
conference. Once set, these 
preferences are in effect for every 
session until you specifically change 
any of them.

To set notebook preferences:

1. From the View menu choose 
Preferences. The following 
dialog box appears:



Tip

When 
conferencing 
or sharing 
applications, 
you'll 
achieve 
better 
performance 
by putting 
both 
systems at 
the same 
video 
setting. 
Using the 
16.7 million 
colors 
setting can 
significantly 
slow 
performance
.

Display Graphics Using

Select the number of colors to use in 
the color palette of the ProShare 
application. For example, if you 
choose 256 colors, any image you 
bring into your notebook is displayed 
in 256 colors, even if the image 
contains millions of colors. The 
exceptions to this are images 
brought into the notebook using the 
print capture option. See page 7 for 
details. The selection you make here 
applies only to what appears in your 
notebook, and is dependent on the 
color capability of your video card.

Connection Merge Controls

These options refer to the 
information in the receiver's 
notebook. The assumption is that the 
caller's notebook always merges 
with the receiver's, so these options 
allow the receiver of a call to 
determine whether merging occurs. 

Merge files on connection: always 
merges the receiver's notebook with 
that of the caller.

Close file on connection: always 
closes the current file (prompting to 
save) on the receiver's computer 
before displaying the caller's file.

Prompt on connection: lets the 
receiver choose what to do with his 



or her current file at the time the 
connection is made.

Miscellaneous

If you would like to know who is 
trying to connect to you, select 
Enable Call Screening. This lets you 
screen incoming conference calls, 
either over a modem or network, and 
lets you allow the connection or not.

The ProShare software 
automatically compresses files 
during a transfer. The JPEG 
algorithm compresses more, but it 
can cause some loss of resolution. 
Select Use JPEG compression to 
enable the use of the JPEG 
algorithm.

Press F1 for details on the other 
options in the Preferences dialog 
box.




