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FirstClass™ System Overview

FirstClass™ is an electronic messaging and conferencing system, designed for ease of use and 
high speed. It can be used as an electronic mail system,  a bulletin board system or a combination 
of both. With FirstClass™ you can do the following:

  •  Send and receive mail & files to/from other users 
  •  Browse, contribute and subscribe to special interest "Conferences"
  •  Browse the user directory
  •  Exchange files using the attachment feature
  
All of this is presented in the familiar Macintosh graphical user interface so you don’t have to 
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learn a new system in order to enjoy FirstClass.

The FirstClass DeskTop

After you login to FirstClass a window is opened with the title "DeskTop". This is your 
FirstClass DeskTop and it is your starting point in the system. It is similar to the Macintosh 
desktop since all conferences and files can be accessed by starting at the desktop. When you first 
login you will see a number of items on the desktop: your MailBox where private messages are 
sent and received, the News conference, accessible to all users, where public information is 
posted, the Help folder where the online help documents are stored and the Conferences icon 
which provides access to all the public (or "open") conferences. You can double click on any of 
these icons to open them up and browse the information contained within.

FirstClass allows you to have multiple windows open at once so you can quickly switch between 
tasks. You can be reading your mail, then switch to a conference, then check out the information 
in News - each in a different window.

The FirstClass Menus

The top bar of the screen contains the pull-down menus for FirstClass. The menus are grouped 
according to the functions they provide: 

File provides commands to operate on files such as Delete or Close.

Edit provides editing commands such as Cut and Paste as well as commands to change personal 
information such as your logon password. 
Message provides the electronic mail commands such as "Send" to send a message.

Conference provides commands for conferences.

View provides commands to change the way you view the information on the screen. It also 
provides a handy "Tile Windows" function which arranges all your windows in a tile pattern on 
the screen to reduce clutter.

Logging Out

To log out of FirstClass just choose "Quit" from the File menu.

FirstClass Electronic Mail

With FirstClass electronic mail you can:
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  •  Read your mail   
  •  Compose and send mail
  •  Address mail to users by name using the user directory
  •  Reply to or Forward a message
  •  Attach files to messages and send them to others
  •  Organize your messages into Folders
  •  Track which messages have been read
  •  Include font, size and style information in your message
  •  Search on message subject, content and to/from names

All of this is presented in the familiar Macintosh graphical user interface so you don’t have to 
learn a new system in order to enjoy FirstClass.

Reading your mail

When you first login to FirstClass you will see an icon labeled "MailBox". This holds all your 
incoming and outgoing mail and you can open it by double clicking on the icon with your mouse. 
When you open your mailbox you see a summary of your mail and any folders which you have 
created. For incoming messages the summary shows the sender, the subject of the message, the 
time it arrived and a black flag if the message has not been read. For outgoing messages the 
summary shows the first recipient, the subject of the message, the time it was last updated and a 
white flag if the message has not yet been sent. To read a message double click on the message 
that interests you. A new window will be opened which has two panels; the upper panel shows 
the envelope information (To:, From:, Subject etc.) while the lower panel contains the message 
contents. You can scroll either of these  panels independently. 
Composing and Sending Mail

Creating a New Message

To compose a new message, select "New" from the Message menu. (Note that "New" is also  
available under the "File" menu for Macintosh compatibility). A new, empty message is created 
and displayed in a new window. The window has two panels; the upper panel shows the envelope 
information (To:, From:, Subject etc.) while the lower panel contains the message contents. You 
can scroll either of these  panels independently. 

Addressing the Message

The envelope panel contains a field where you can fill in a message subject, and "To:" and 
"Copies:" fields where you can enter a list of recipients. To address the message move the cursor, 
using the mouse, to the To: line and type in the last name of your intended recipient. If you are 
unsure of the name just type in the first few characters - the system will search for the name in its 
user directory and fill in the full name for you. If multiple names are  found, for example if you 
entered "smith", then a window is opened showing the matches and you can select from the list 
using your mouse. 

Completing and Sending
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To enter the contents of the message use the mouse to move the cursor into the lower panel and 
type in the text of the message. When you are finished pick "Send" from the Message menu and 
your message will be delivered. Note that the "Unsent" flag is removed from the summary line 
after you send the message.

Tracking your Message using History

You can use the Message History feature to find out who has read your message. Select or open 
your message, pull down the Message menu and choose History. A window will appear showing 
those people who have read the message.

Conferencing
 
Conferences are special interest bulletin boards that you can browse and submit items to. With 
conferences you can:
 
   • Browse conferences
   • Contribute items to a conference
   • Search for posted items
   • View the list of subscribers 
   
All of this is presented in the familiar Macintosh graphical user interface so you don’t have to 
learn a new system in order to enjoy FirstClass.

Browsing a Conference

All users have a "Conferences" icon on their desktop. By double clicking on this icon you can 
see all the public or "open" conferences. You may freely browse any of these conferences by 
double clicking on the one that interests you. When you open a conference by double clicking, 
all the current items are summarized in a list. The summary shows the author of the item, the 
subject and the date that it was submitted. To view the item simply double click on it.

A conference may have sub-conferences, i.e. special areas of interest within the general topic of 
the conference. These are displayed in the upper half of the conference window as icons, and can 
be opened in the same way as the main conference by double clicking.

The conference summary also shows a black flag against each item that you have not yet read. 
You can read the items in any order, and FirstClass will remember which items you have opened, 
and remove the flag on those items.

Contributing to a Conference

FirstClass uses its mail system to submit items to conferences. To add an item to a conference 
you simply send a message addressed to that conference. FirstClass makes this easy by providing 
automatic addressing:

First Class Client’s Manual for version 2.0 page 



—  —

If you wish to submit an item to a conference, and you are currently in that conference, then 
simply pick "New" from the Message menu. A new message is created and automatically 
addressed to the Conference you are in. If you are not in the  conference you wish to submit to 
then open your MailBox and select "New". Enter the name of the conference in the "To:" field 
and press ENTER or RETURN.

The message is now addressed to the conference. Fill in the subject and the content of your 
message and when you are finished pick "Send" from the Message menu. Your message will 
arrive in the Conference and a copy will also be retained in your MailBox. 
Replying to a Conference Item

You may wish to respond to an item in a conference. To do this, first select the item that interests 
you by clicking on it once with the mouse. Now pick "Reply" from the Message menu and 
FirstClass will create a reply message addressed to the Conference with the subject already filled 
in. You need only add the content of the message and  then send it by picking "Send" from the 
Message menu.

Using the Directory to address messages

The user directory contains the names of all registered users and all public conferences. This 
allows you to address a message using only the person’s normal name.  To address a message 
simply enter the name of the person or conference in the "To:" or "Copies" field and FirstClass 
will search the directory for the name and fill in the full name.

Example : John Appleby

If you are unsure of the spelling of this name you can just type a few characters of the first or last 
name and the system will display any names that start with the characters you have typed, so you 
can pick the one you want. For example, typing:

ap

Might result in a list of names (or conferences):

John C. Appleby
Susan Apton
AppleSoftware

You can select the name you want by clicking on it with the mouse, and closing the directory 
window. Names can also be abbreviated so you can type "j appleby" or simply "appleby" to 
match John C. Appleby. You can also abbreviate either name,  for example "jo app" would match 
John C. Appleby in our example.

Browsing the Directory

You can browse the directory by pulling down the Message menu and selecting "Directory...". 
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This will present you with a dialog box where you can enter a name or the first few characters of 
the name(s) you want to look for. Click on the Search button to get a list of all matching names.

Addressing mail via a Gateway

If you are allowed to use gateways, you may address mail to other sites and systems. To do this 
you simply add a comma (,) to the name and follow it by the site you wish to send to. For 
example if John Appleby is on the system “Crystal Systems”  then his address would be:

John Appleby,Crystal Systems.

If your system is equipped with a gateway to a non-FirstClass system (e.g. the UNIX Internet), 
the you may address mail using the name of the foreign system:

jappleby@soft.com,Internet

In this case the format of the address preceding the comma is determined by the addressing 
conventions of the non-FirstClass system.

Sending to a Mail List

If your system has mail lists defined, you may send mail to a group of people by using a mail list 
which contains their names. Simply enter the name of the mail list in the To: or Cc: list. 
Example: Technical Support.

File Transfer

You can share files with other people using the File Transfer features. You can "attach" a file that 
is on your disk to a message and send it along with the message to one or more users. The 
recipients can then save the attached file onto their disk. The message can contain descriptive 
information about the attached files.

Files can also be placed on the server directly, without being attached to a message. You can 
transfer these files to your computer using the Download feature. If you have a file which you 
wish to make available to others then you can Upload this file. Although these features can be 
useful, most users will find the attachment feature easier to use, since attached files can be 
described in the message that they are attached to.

When files are transferred via phone lines the system takes care of the file transfer protocol so 
that you don’t have to worry about it. 

Any file that can be created on a Macintosh can be transferred without loss of information. This 
includes graphics, sound and special application dependent files (spreadsheets, word processor 
documents etc.).

See the “Files” help folder for more information.
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About Preferences

Each user may set preferences, to customize the way that FirstClass operates and appears. To 
open your preferences, pull down the Edit menu and choose Preferences. A scrolling window 
will appear containing your preferences.

Message List Preferences

Show conference items in reverse order

This option reverses the sorting order, and the order that items are sent from the server, when 
conferences are displayed. When you do not have write permission to a conference, the 
View/Sort options are not saved. This option allows you to have the newest items sent first, 
which is very useful if the conference has a lot of items in it and you are connecting via modem.

Show only unread items in conferences and mailbox 

This option sends only the items you have not seen (those items with an “Unread Flag” on) from 
the server. It is useful when you only want to see new items in a conference, and when a 
conference has become very large. It also operates on your mailbox, however outgoing messages 
are also shown. Note that use of this option can make conferences appear to be empty, if there 
are no unread items in them.

Chat Preferences

Don’t accept invitations

This option prevents other users from inviting you to chat, if you wish to work undisturbed. Your 
name will appear in italics in invitation lists, and if users try to invite you they are informed that 
you do not wish to chat at this time.

Sounds during chat and invite

This option can be used to turn chat sounds on and off.

Searching for files and mail

FirstClass contains a powerful built-in search feature. You can search within messages and 
documents for a word, or you can search for items based on the subject, file name, attachment 
name, to/from names and even the content of the item.

Searching within a message or document

If you have a message or document open (such as this one), you can search for words within the 
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text by pulling down the File menu and choosing Find F. Enter the text you are searching for in 
the dialog box that appears, and press the Find button. FirstClass will scroll the document to the 
position where the words appears, and highlight it for you. To find the next word pull down File 
and choose Find Again G.

Searching for messages and documents

You can search for an item within your mailbox, within a conferences, or within a set of 
conferences. To begin a file search, open the target object that you wish to search, for example: 
your mailbox. Pull down the File menu and choose Find F. A search form will appear, which 
allows you to specify the search criteria. The search form contains a box to enter the text to 
search for, and a set of checkboxes which control where to look. The checkboxes have the 
following effect:

Search subject/file name: search in the Subject  field of messages and in the file name  field of 
files and documents. This is the fastest of the search options.

Search sub conferences & folders: If the search encounters a sub-folder or conference, it will 
continue searching inside the folder. This allows you to search large portions of system, and it 
may take a long time. As an example, you could search the help system (where this file resides), 
including the subfolders by checking this option.

Search content of documents: Search the text contained in the message or document. This option 
will make the search take longer because each message or document must be opened and 
searched.

Search attachment names: Search the text in the attachment name  field of any message with 
attachments. If you are looking for an attachment only, check this box (and possibly the Search 
sub conferences & folders box) only.

Search “From” name: Search in the From  field of messages. This can be used to show all 
messages from a specified person.

Search “To/CC” names: Search in the To  or Cc  list of messages. This can be used in your 
mailbox to show all messages sent to a particular person.

The search starts when you press the Search button. A new window is opened (the search list ), 
which is used to display items which match the search criteria. Searching is performed in the 
background  so you can continue to do other things while the system is searching. You may open 
items in the search list as soon as they appear, without waiting for the search to finish. The 
current conference or folder being searched is displayed in the top right corner of the search list. 
When the search is complete, a beep sounds and the top right corner will appear blank.

Conferencing Help
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What are Conferences?

Conferences are special interest bulletin boards that you can browse and send items to. 
Conferences are used to allow a group of people with a common interest exchange ideas, 
questions, information and files. You can "send" an item to a conference using the mail system, 
and you can browse a conference using the point and click technique of the Macintosh.

If you use a conference frequently you can make an “alias” to it on your desktop.

Browsing a Conference

All users have a "Conferences" icon on their desktop. By double clicking on this icon you can 
see all the public conferences. You may freely browse any of these conferences by double 
clicking on the one that interests you. When you open a conference by double clicking, all the 
current items are summarized in a list. The summary shows the author of the item, the subject 
and the date that it was submitted. To view the item simply double click on it.

A conference may have sub-conferences, i.e. special areas of interest within the general topic of 
the conference. These are displayed in the upper half of the conference window as icons, and can 
be opened in the same way as the main conference by double clicking.

The conference summary also shows a black (red) flag against each item that you have not yet 
read. You can read the items in any order, and FirstClass will remember which items you have 
opened, and remove the flag on those items.

Participating in a Conference

FirstClass uses its mail system to submit items to conferences. To add an item to a conference 
you simply send a message addressed to that conference. FirstClass makes this easy by providing 
automatic addressing:

If you wish to submit an item to a conference, and you are currently in that conference, then 
simply pick "New" from the Message menu. A new message is created and automatically 
addressed to the Conference you are in. If you are not in the  conference you wish to submit to 
then open your MailBox and select "New". Enter the name of the conference in the "To:" field 
and press ENTER or RETURN.

The message is now addressed to the conference. Fill in the subject and the content of your 
message and when you are finished pick "Send" from the Message menu. Your message will 
arrive in the Conference and a copy will also be retained in your MailBox.

Replying to a Conference Item

You may wish to respond to an item in a conference. To do this, first select the item that interests 
you by clicking on it once with the mouse. Now pick "Reply" from the Message menu and 
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FirstClass will create a reply message addressed to the Conference with the subject already filled 
in. You need only add the content of the message and  then send it by picking "Send" from the 
Message menu.

Making an alias to a conference

If you participate in a particular conference frequently then you may wish to create an “alias” to 
that conference.  There are a number of advantages to aliases; first the conference appears on 
your desktop for convenient access and second you are notified of any new items in the 
conference by a flag which appears beside the conference icon, when on your desktop.

To create an alias to a conference, select the conference by clicking on it once, pull down the 
Conference menu and choose Make Alias. The conference will now appear on your desktop. If 
you decide that you are no longer interested in the conference you can remove the alias from 
your desktop by pulling down the File menu and choosing Delete.

About Public Conferences

Any conferences under the "Conferences" icon are considered to be Public Conferences, since 
anyone on the system may browse and contribute to them. The administrator can create a new 
public conference in Conferences for you. You may freely browse and submit items to a Public 
Conference and you can delete any item which you have contributed, however you may not 
delete items contributed by others.

About Private Conferences

Private Conferences are not accessible by all users. If you are granted access to a private 
conference then it will appear on your desktop. If you do not have access then there is no way for 
you to browse or contribute items to it. The administrator can set up private conferences and 
grant access to a particular group of individuals. 

If you do have access to a private conference then you can do anything that you can do in a 
Public Conference, including browsing, contributing, deleting and downloading.

Supervised Conferences & Permissions

Some conferences have restrictions as to what can be posted and who can post items. A 
conference may have no restrictions, it may require that items with attachments require approval 
or it may be that all items require approval.

If you post an item to a conference and it requires approval then the item will be displayed in 
italics until the conference  Administrator approves it. Noone may open the item until it has been 
approved. Once approved you may open it and/or save any attached files.

To check the permissions of a conference, select the conference from the conference list, pull 
down the Conference menu and choose Permissions. A window will appear showing the 
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permissions for the conference you have selected.

Conference Info

Conference Info is similar to the résumé feature for users. It provides information about the 
purpose of a conference. You can view the conference info file by selecting the Conference, 
pulling down the Conference menu and choosing Conference Info. You can also double click on 
a conference name in a directory list or in the address part of a message to get the info file.

About the News Conference

News is a conference that everyone has on their desktop. It is a good place to post messages that 
are of interest to all users and it is a conference that you should browse frequently.  If a black 
flag is shown beside the News icon then this indicates that News contains some items which you 
have not yet seen will be displayed. 

Reading the News

To browse the News Conference just double click on the News icon (as with any conference). A 
list of the current news items will be displayed. If you have not seen an item yet then a small 
black (red) flag will appear beside that item. After you read the item, the flag is removed. 

Message Threading

When you reply to a message, FirstClass threads  the reply to the original message. As discussion 
progresses on a topic, a message thread is automatically constructed by FirstClass, consisting of 
all the messages on that topic. A conference may contain a number of different threads, all under 
the general topic of the conference itself.

When you open a conference, FirstClass displays all of the messages in that conference. If you 
want to follow a particular discussion thread you can use the Open Thread feature of FirstClass. 
If you have a message open, you can open the next message in the thread by pulling down File 
and choosing Open Thread. To go to the previous message in the thread, hold down the option 
key while choosing Open Thread. These two functions are also available on the FirstClass Palette 
as buttons. When you reach the end of the thread you will hear a beep.

Threading can also be used in your mailbox, to find the original message when you receive a 
reply. If you receive a message which is a reply to something you have sent, use the Previous in 
Thread (Option Open Thread) feature to find your original message.

Messaging Help

About Electronic Mail

Electronic Mail lets you exchange messages and files between other people. Incoming mail 
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arrives in your "MailBox", and you can create "Outgoing mail" and address it to others. 

Messages usually have a sender and one or more recipients. When you open a message it will 
show the date it was sent, along with the Subject and the list of recipients. 

When mail is addressed, ordinary people’s names are used for simplicity.

When a message arrives it is considered to be "Unread" until you open it by double clicking. A 
small black flag is used to mark messages as Unread.

When you create a message it normally is created in your mailbox and is marked "Unsent" with a 
small white flag. If you send it the flag is removed. This lets you create a message and then work 
on it later if desired. Once the message is sent a copy is retained in your MailBox. You can delete 

this immediately using the Delete command from the File menu or you can let it expire 
automatically. All messages expire after a pre-determined period, set by your 

administrator.Reading your Mail

Your MailBox

When you first login to FirstClass you will see an icon labeled "MailBox". This holds all your 
incoming and outgoing mail and you can open it by double clicking on the icon with your mouse. 
When you open your mailbox you see a summary of your mail and any folders which you have 
created. For incoming messages the summary shows the sender, the subject of the message, the 
time it arrived and a black flag if the message has not been read. For outgoing messages the 
summary shows the first recipient, the subject of the message, the time it was last updated and a 
white flag if the message has not yet been sent. 

Opening a message

To read a message double click on the message that interests you. A new window will be opened 
which has two panels; the upper panel shows the envelope information (To:, From:, Subject etc.) 
while the lower panel contains the message contents. You can scroll either of these  panels 
independently. 

The Open Unread Feature

You can quickly read unread mail using the Open Unread feature. If you have unread mail, as 
shown by the unread flag beside your mailbox, simply pull down the File menu and choose Open 
Unread. The first time the command is used  it will open your mailbox. Subsequent times will 
open the next unread message, and close the previously open message so you can quickly display 
all your unread messages in sequence. This feature works best with the command key equivalent 
which is Command-U.

Using the palette

FirstClass provides a palette containing buttons which allow you to quickly navigate through 
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your mailbox and conferences. There are six navigation buttons at the bottom of the palette. They 
are from top left to bottom right: Previous Unread, Next (Open) Unread, Previous in Thread, 
Next in Thread, Next, Previous.

Composing and Sending Mail

To compose a new message, select "New" from the Message menu. (Note that "New" is also  
available under the "File" menu for Macintosh compatibility). A new, empty message is created 
and displayed in a new window. The window has two panels; the upper panel shows the envelope 
information (To:, From:, Subject etc.) while the lower panel contains the message contents. You 
can scroll either of these  panels independently. The envelope panel contains a field where you 
can fill in a message subject, and "To:" and "Copies:" fields where you can enter a list of 
recipients. 

Addressing

To address the message move the cursor, using the mouse, to the To: line and type in the last 
name of your intended recipient. If you are unsure of the name just type in the first few 
characters - FirstClass will search for the name in its user directory and fill in the full name for 
you. If multiple names are  found, for example if you entered "smith", then a window is opened 
showing the matches and you can select from the list using your mouse. To enter the contents of 
the message use the mouse to move the cursor into the lower panel and type in the text of the 
message. 

Sending

When you are finished pick "Send" from the Message menu and your message will be delivered. 
Note that the "Unsent" flag is removed from the summary line after you send the message.

How to Address Messages

Messages are addressed to either people or Conferences. In either case you simply enter the 
name of the person or Conference and the user directory is searched for names that match.

◊ Example:

To address a message to "John Appleby":
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If you are unsure of the name you can just type a few characters of the last name and the 
FirstClass directory will display any names that start with the characters you have typed, so you 
can pick the one you want. So, typing:

ap

Might result in a list of names (or conferences):

John C. Appleby
Susan Apton
AppleSoftware

You can select the name you want by clicking on it with the mouse. Names can also be 
abbreviated so you can type "j appleby" or simply "appleby" to match John C. Appleby. You can 
also abbreviate the last name,  for example "appleb" would match John C. Appleby in our 
example.

See also: Using the Directory.

Using Reply and Forward

Reply

If you are responding to a message then you can use the "Reply" feature to automatically 
produce an addressed reply message with the Subject already filled in. To reply, open the 
message you wish to reply to, pull down the Message menu and select Reply. A new message 
will be created, addressed to the sender, and you can immediately begin typing your reply.

Forward

If you receive a message that you wish to send on to someone else, or if you wish to re-send a 
copy of one of your own messages, then you can use the "Forward" feature to create an 
unaddressed copy of any message. To forward a message, open the message you wish to forward, 
pull down the Message menu and select Forward. A copy of the message will be created which 
has not yet been addressed. It can be addressed using the normal method.

Expiry Dates

All messages, both incoming and outgoing, automatically expire after a predetermined period. 
The message is automatically deleted soon after the expiry date by the system. The expiry period 
for your system is set by your administrator, however you can check the actual expiry date by 
using the "Get Info" command. Select the message you wish to check, pull down the File menu 
and choose Get Info. The expiry date is shown near the bottom of the window.

You can cancel the expiry date by clicking on the expiry date field in the Get Info window. If you 
do this then the message will never expire and it is your responsibility to delete it when it is no 
longer of any value.
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Attachments: Sending Files by Mail

The "attachment" feature lets you mail files to other users, or conferences by "attaching" the files 
to a message. You then address and send the message as usual and the text of the message can 
describe the attached files. The recipients can save any or all of the attached files onto their own 
disk.

Sending a File to a User or Conference

To send a file to another user or conference, first create and address a message as usual. If you 
have not created a message before refer to the Help section on Messaging. To attach a file to the 
new message, pull down the Message menu and choose Attach. A standard file dialog will appear 
to let you pick a file to be attached. When you click on the Attach button the file will be 
transferred to the server (if you are connected by phone this may take a while). The attachment is 
shown in the header or envelope of the message. There is no limit to the number of files that you 
may attach.

You should add some descriptive text to the message to describe the attached file and then you 
can send the message. A copy of the message is delivered to each recipient and they may each 
save a copy of the attachment to their own disk.

Saving an attached file

To save a copy of an attached file on your own computer, open the message which contains the 
attached file and use the mouse to click on the attachment you wish to save. Pull down the 
Message menu and choose Save Attachment and the file will be transferred from the server to 
your computer (if you are connected by phone this may take a while).

Message History

Message history lets you track what has happened to a message. The history shows when the 
message was created, sent and who has read it.

To view the history of a message, select the message you are interested in, pull down the 
Message menu and choose History. A history window will appear showing the event (Created, 
Sent, Read, Forwarded etc.), the time it occurred and the name of the person who caused the 
event. 

Message history is ideal for finding out if your message has been received and read.

If a message has arrived from another site, the route that the message has taken will be displayed 
in the history.

About Forms
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Forms are simply messages with additional fields such as pictures, text fields, check boxes etc. 
They are used to transmit formatted information via the FirstClass mail system and can be used 
in place of paper forms. FirstClass comes with an assortment of forms which you can create and 
send. 

To create a form pull down the Message menu and move the mouse to the New Form item. A 
menu of the available forms will appear and you can choose the form that you want. A new 
empty form will be displayed in a new window. Most forms have an address area similar to a 
normal message where you can enter a Subject, To and Copies names and attach files. Forms are 
sent using the Send command; an incoming form will usually have a distinctive icon - for 
example the phone message form has a small telephone icon.

Online Services

About Chat

The Chat feature of FirstClass lets you communicate with other users directly in a forum setting. 
The other users are known as the "Chat Participants". There are two types of chat: Topic based 
and Private Chat. 

Topic Based Chats

Topic based chat appears as an icon, usually in a conference, and is named according to the topic 
which is to be discussed within. If there are currently some participants within the chat, a chat 
balloon is shown beside the chat icon. To enter a Topic based chat, simply double click on the 
icon. A chat window is opened and your entry into the chat is announced to the other 
participants.

Private Chats

Private chats can be created at any time by pulling down the Conference Menu and choosing 
Private Chat. A chat window appears with yourself as the sole participant and you may then 
invite other users into the chat. You can have more than one chat window open at once, if you 
wish.

The Chat Window

Chatting is done in a Chat Window. You type your message into a text box, and when you press 
Enter, the text appears immediately on the screen of each participant. The chat window shows 
the current list of participants, which is kept up to date as users leave or join the chat. An Invite 
button is provided to allow you to invite other people into the chat session. When you press the 
Invite button, a list of the logged-in users appears, and you may select one or more names from 
the list using the mouse. When you close the list, the selected people are presented with a chat 
invitation window, from which they may accept or decline the invitation.

There are two check boxes in the chat window: Scroll Lock and Sounds. Scroll Lock locks the 
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text part of the window so that it does not scroll as chat messages arrive. This is useful if you 
wish to copy a portion of the text to the clipboard, while a chat is active. The Sounds check box 
is used to enable the chat sounds feature, which provide sounds as chat events (such as someone 
joining the chat) occur. 

The Invitation Window

When you are invited to chat, a Chat Invitation Window will appear, accompanied by a sound. 
The invitation window shows the name of the chat and the person who is inviting you to chat. 
There are two buttons: Accept and Decline. To accept the invitation and join the chat 
immediately, press the Accept button. To decline the invitation, press the Decline button or 
simply close the invitation window. You may also leave the invitation window alone, and accept 
the invitation later (the inviter may have left by this time, however).

Chat Transcripts

To save a transcript of the chat on a local disk pull down the File menu and choose Save As... . 
The transcript will be saved in text format and will contain chat lines from the moment you 
entered the chat.

About Résumés

Résumés are used to provide other users information about yourself. You can type as much 
information as you wish into your résumé file.

To edit your résumé file go to the desktop window, pull down the Edit menu and choose Résumé. 
If this is the first time you have used the résumé feature then your file will be empty. Type in any 
information that you wish other users to know about yourself. Click on the close box to save 
your changes.

To view the résumé of someone who has sent you a message, open the message, and double click 
on the "From" name. The person’s résumé will be displayed. You can also display the résumé of 
anyone in the To: or Copies: list by double-clicking on the name you want.

You can also view résumés from a directory list window by double-clicking on any name.

Files Help

About File Transfer

You can share files with other people using the File Transfer features. You can "attach" a file that 
is on your disk to a message and send it along with the message to one or more users. The 
recipients can then save the attached file onto their disk. The message can contain descriptive 
information about the attached files.
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Files can also be placed on the server directly, without being attached to a message. You can 
transfer these files to your computer using the Download feature. If you have a file which you 
wish to make available to others then you can Upload this file. Although these features can be 
useful, most users will find the attachment feature easier to use, since attached files can be 
described in the message that they are attached to.

When files are transferred via phone lines the system takes care of the file transfer protocol so 
that you don’t have to worry about it. 

Any file that can be created on a Macintosh can be transferred without loss of information. This 
includes graphics, sound and special application dependent files (spreadsheets, word processor 
documents etc.).

Attachments: Sending Files by Mail

The "attachment" feature lets you mail files to other users, or conferences by "attaching" the files 
to a message. You then address and send the message as usual and the text of the message can 
describe the attached files. The recipients can save any or all of the attached files onto their own 
disk.

Sending a File to a User or Conference

To send a file to another user or conference, first create and address a message as usual. If you 
have not created a message before refer to the Help section on Messaging. To attach a file to the 
new message, pull down the Message menu and choose Attach. A standard file dialog will appear 
to let you pick a file to be attached. When you click on the Attach button the file will be 
transferred to the server (if you are connected by phone this may take a while). The attachment is 
shown in the header or envelope of the message. There is no limit to the number of files that you 
may attach.

You should add some descriptive text to the message to describe the attached file and then you 
can send the message. A copy of the message is delivered to each recipient and they may each 
save a copy of the attachment to their own disk.

Saving an attached file

To save a copy of an attached file on your own computer, open the message which contains the 
attached file and use the mouse to click on the attachment you wish to save. Pull down the 
Message menu and choose Save Attachment and the file will be transferred from the server to 
your computer (if you are connected by phone this may take a while).

Transferring Files to the Server

You can transfer files directly from your computer to the server and place them in a folder or 
conference. Please note that it is often preferable to enclose the files in a message as attachments 
so that descriptive information may also be included. See "Attaching Files" for more 
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information.

To upload a file first open the folder or conference that you wish to upload to. Next pull down 
the "File" menu and select "Upload". You will be presented with a dialog box which allows you 
to pick the file to be uploaded. When you click on the "Save" button the file transfer will begin. 
You are free to read your mail, browse conferences etc. while the transfer is taking place and a 
small file transfer status window will show the progress of the upload. When the transfer is 
complete the status window is removed and the file appears. You may also wish to use the "Get 
Info..." command under the File menu to add a descriptive subject to the file.

Transferring files to your Computer

If the icon and subject of a file indicate that it can be downloaded you may use the Download 
feature to copy this file to your computer.

To download a file, either double click on it or select it and pick the "Download" command from 
the "File" menu. You will be presented with a dialog box which allows you to select the name of 
the file to create on your local machine. When you click on the "Save" button the file transfer 
will begin. You are free to read your mail, browse conferences etc. while the transfer is taking 
place and a small file transfer status window will show the progress of the upload. When the 
transfer is complete the status window is removed and the file appears. You may also wish to use 
the "Get Info..." command under the File menu to add a descriptive subject to the file.

Accessing CD-ROMS using FirstClass

Your administrator can make CD-ROM disks available to you via FirstClass. The CD-ROM 
appears as a folder, which can be opened by double-clicking or using the Open command under 
the File menu. You may navigate the CDROM as in the Apple Finder®. Each folder on the CD-
ROM that you open is displayed using a summary window, with two panels. The upper panel 
contains sub-folders, while the lower panel contains any files found in the folder. If the file is a 
text file it may be viewed online by double-clicking. Other files may be downloaded to your 
local disk, also by double-clicking.

While an item is downloading you may continue to do other things such as browsing other 
folders on the CD-ROM or reading your mail.

Note that CD-ROMS are much slower than hard disks, and if you open a large folder, it may take 
several seconds for the disk to respond.

See also: File Transfer, Downloading.

Using "Get Info..."

All messages, conference items and files have properties which can be displayed and in some 
cases changed by you. The obvious properties are the name and subject information, while other 
information includes the item’s icon (picture) and the expiry date.
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This information is displayed and changed by selecting the item using the mouse (click once) 
and then by pulling down the "File" menu and selecting "Get Info...". The properties of the 
selected item are then displayed. If the item is a message in your mailbox then you can change 
the name, subject, icon and expiry date. The name and subject are displayed in the mailbox or 
conference summary.

On FirstClass every item is assigned an expiry date when it is created. On the expiry date the 
item "expires"  and it is removed from the system soon after (usually at night). This is done to 
keep the system from becoming cluttered with large numbers of old messages. If you have an 
item which you wish to keep from expiring then click on the expiry date and the item will no 
longer expire. You are responsible for making sure this item is deleted when it is no longer 
needed - so use this feature with discretion.

File Organization

FirstClass provides a number of features to help organize the information stored in conferences 
and mailboxes. It is similar to the Finder and provides the ability to create folders and move 
messages and files into these folders.

Creating Folders

To create a folder simply pull down the "File" menu and select "New Folder". You can create 
folders on your desktop and in your mailbox (for organizing your mail) and in any folders you 
have created previously. Once you have created a folder you can create messages in it for 
subsequent sending (thus you can create several "outboxes" if you wish) and also move items 
into the folder.

Moving Items into Folders

You can move any messages you have into a folder by simply dragging them as you would in the 
Finder. Moving items before they have been read is not recommended since FirstClass only 
keeps the "Unread" flags for mailboxes and conferences.

Deleting Files

On FirstClass files are deleted automatically after the expiry date, however you can delete 
messages that you are no longer interested in by selecting them (click once with the mouse) and 
selecting the "Delete" command from the "File" menu.

View and Sorting Options

Summary Windows & Panels

FirstClass provides various ways of viewing the information in your Mailbox, in Conferences 
and in Folders. The summary windows for each of these objects is usually split into two panels, 
the upper panel which contains sublists, and the lower panel which contains files and messages. 
Each panel may be viewed and sorted independently.

First Class Client’s Manual for version 2.0 page 



—  —

View by Icon

The View menu allows you to change the way the information in a summary list appears.  View 
“By Icon” shows a large icon for each object. If you have the appropriate permissions, you may 
drag the icons around and FirstClass will remember the positions of the icons. By default the 
upper panel is displayed by icon. 

Sorting Options

The other view options all provide a one-line summary of each object, showing the 
name/sender/recipient, subject and date. The views differ in the way the items are sorted: “by 
Date” sorts the items according to the date of last modification, “by Name” sorts according to the 
file name or sender/recipient, “by Subject” sorts by the subject of a message, and “by Size” sorts 
by the size of the file or message. The “Reverse Sort” option may be used with any of these 
views to reverse the order of the sort. 

If you have write permission then the view and sort options will be remembered (similar to the 
Finder®). All users can change the view and sorting for their desktop, mailbox and any folders 
they have created. 

Note: To reverse the sort order for conferences that you do not have write access to see help on 
“Preferences”.

Partial File Transfers

FirstClass allows you to resume a file transfer in the event that your connection fails. If you are 
connected via modem a file transfer may take a long time, and occasionally the connection is lost 
due to telephone line noise. If this happens, you may continue the file transfer the next time you 
connect.

Resuming a Download (Save Attachment)

When you download a file and it is interrupted, a partial file  will be left on your local disk. The 
file will have the name you selected, but will have an icon which looks like a half-filled 
FirstClass Settings document. Do not rename this file; FirstClass checks that the names match 
when attempting to restart the transfer.

To resume a transfer after downloading a file or saving an attachment, follow the following 
steps:

• Open the message containing the attachment or find the file you were downloading.

• Begin the transfer by double clicking on the attachment/file.
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• Select the partial file on your local disk. You will be asked if you wish to Replace this file; 
confirm by pressing the Replace button.

• The file transfer will resume at the point it left off.

Resuming an Attach or Upload transfer

When you attach/upload a file and it is interrupted, a partial file  will be saved on the FirstClass 
Server. The attachment/file will have the name you selected, but will have an icon which looks 
like a half-filled document. Do not rename your original file; FirstClass checks that the names 
match when attempting to restart the transfer.

To resume a transfer after attaching/uploading a file, follow the following steps:

• Open the message containing the attachment or find the file you were uploading. If the partial 
file is an attachment, select it within the message. If it is a file in a file list, select the file.

• Choose Attach or Upload and select the original file on your local disk.

• The file transfer will resume at the point it left off.

Deleting a Partial Attachment

If you wish to delete a partially transferred file from a message, select it and press the Delete key.
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