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Test Tools automates the classroom testing progress.    The flexibility and ease of 
use it offers lets you spend more time teaching and less time creating, editing, 
and grading tests.

Test Tools offers many advantages over traditional pen-and-ink testing process.    
With Test Tools you can

•    Give tests on the Macintosh screen that are graded automatically
•    Simply re-use past tests
•    Print test keys directly from the test
•    Easily include questions from your other tests or other people’s prepared 

question banks
•    Include sounds and illustrations in your tests

Structure of Test Tools
Test Tools consists of two programs, the Test Builder and the Test Taker.    Test 
Builder is where you create and modify your test.    A completed test can be 
printed out for students and a grading key printed for yourself.

The same tests may be given on the Macintosh screen with Test Taker.    
Students run Test Taker using the tests you make.    Test Taker grades the results 
automatically and gives the results to you or to the student.

Instructional Level
Test Tools may be used for all grade levels.    If you choose to give tests on the 
Macintosh screen with Test Taker, any student with a basic familiarity with how a 
Macintosh works will be able to operate the program.
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Getting Started with Test Builder

Test Builder tests are made up of items which appear one on top of another on 
the screen.    There are three kinds of items:    the header items, which appears 
only once at the top of each test, question items, and information items.    The 
five kinds of question items are multiple choice, true/false, fill-in, matching and 
essay.    The three kinds of information items are instructions, pictures, and 
sounds.    Each kind of item is described in the Quick Reference section.

Make tests by adding items to the test and filling them out.    Add items by 
selecting them from the items menu.    To make a true/false item, you would 
select True/False, type the question, and indicate what the answer is.

That is all you need to do to add a question to the test.    Notice that you do not 
need to add a question number.    This will be done by Test Builder.    When you 
print the test, the answer will not be shown, of course, just the question.    This is 
true for all question items.    You can choose a point value for the question by 
clicking on the up and down arrows.

Manipulating Items
Once you have created an item, you can change it and move it around.    To 
select an item, double-click on it.    The item will become inverted.    This means 
you can put it on the clipboard with with Cut or Copy in the Edit menu, or remove 
it with Clear.    Once an item is on the clipboard, you can paste it anywhere you 
like, in the test you copied it from or any other.

To select more than one item at a time, double-click on one item first.    Then go 
to the end of the range of items you want to select.    Hold down the shift key and 
click on that item.    All those items will be selected.    Also, once one item is 
selected, holding the command key will select the item or deselect it if it is 
already selected.
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Test Builder Quick Reference

This section describes each part of Test Builder menu by menu.

The File Menu

New
Creates an empty test to which you can add items.

Open
Displays a dialog box that allows you to select an existing test to open.

Close
Closes the currently selected test.

Save
Saves the selected test.    If you have not saved the test before, a dialog box 
appears in which you assign a name to the test and indicate where to save it.

Save As
Displays a dialog box in which you can assign a name to the test and indicate 
where to save it.

Revert
Discards all changes that have been made to the test since the last time you 
saved it.

Auto Extract
Auto Extract selectively adds questions from any test you choose into another 
test.    You can extract questions on the basis of category, difficulty, and type 
(multiple choice, matching, etc.) or any combination of the three.    Test Builder 
will look through the test you want to extract from, find the questions that meet 
your specifications, and add them to another test.
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To extract questions from another test into another test, follow this procedure:
• Select Auto Extract from the File menu.
• Choose the test from which to extract questions.
• A dialog box will appear asking what kind and how many questions you 

want to extract.    Choose how many questions of this type you wish to 
add.

• Now choose what kind of question you want to add.    The categories on 
the left are named by whomever created the test. (See Categories.)

• Click on a category and Test Builder will look for that kind of question.    
You can also specify difficulty and question type.    If one of these 
specifications doesn’t matter, choose to ignore it.

• When you have specified what kind of questions you want, click Add.    
Test Builder will then look through test test for those kinds of questions.    
If the questions you wanted weren’t in the test, it will tell you.    Otherwise, 
Test Builder will return and be ready to look for more questions following 
the same procedure.

• When you have all the questions you want, click Finish and all the 
questions that have been found will be added to the test.    To change 
your mind about adding questions, click Cancel and none will be added.

For example, say that you want to add 10 multiple choice addition questions and 
15 difficult division questions from a math test.    You would first type 10 to 
indicate how many questions you want.    Then you would click on addition and 
multiple choice to show that is the kind of question you want.    Because difficulty 
doesn’t matter this time, you would click Ignore Difficulty.    Clicking Add would 
find those ten questions in the test if they are there.    Follow the same procedure 
to get the 15 difficult division questions.    Type 15 for how many questions, then 
click on Division and Difficulty.    Because type doesn’t matter this time, click on 
Ignore type.    Now click on Add to tell Test Builder to find these questions.    The 
extraction is done, so click on Finish to put all 25 question into the current test.

Password
Password-protects a class.    When a test is password-protected, the password 
must be entered before the test is opened.

To password-protect a class, choose Password, type a password and click OK.    
You will be asked to verify the password before it is used.    To remove password 
protection from the class, click Remove Password.    If you give a test a password 
and then don’t save it, the test will not be password-protected.

Password protection is an effective means of keeping prying eyes from your 
tests, but it will not stop a determined person with extensive computer 
experience.    The best way to protect your tests is to store them on floppy disks 
and put them in a safe place.    Remember that passwords are easily forgotten—
only use them when you have a reason to do so.
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Page Setup
Displays a dialog box in which you can select paper size, orientation, and other 
printing options.    You can choose a printer with the Chooser, available in the 
Apple menu.

Print Preview
Print Preview shows how your test will look when it is printed.    Page Preview 
also gives you summary information on the number of questions, number of 
points, and number of pages in a test.    To get a preview of the test key, hold 
down the option key when you choose Print Preview.

Print Test
Prints one or more copies of the test.    For extra control over the appearance of 
the printed test, use Options in the Edit menu.

Print Key
Prints one or more copies of the test key.    The key contains only the answers to 
all the questions.

Quit
Exits Test Builder.

The Edit Menu

Undo
Undoes your last action that involved text boxes.

Cut
Removes what is currently selected and places it temporarily into a storage area 
called the Clipboard.    You can cut and paste items, text, sounds, and pictures.    
To select an item to cut, double-click on it anywhere outside of a text box.

The shift key will extend a selection.    If there is already a selection made, click 
on another item with the shift key down and all the items between the first item 
and the new item will be selected.    The command key lets you select items 
individually.    When is a selection made, click on another item with the command 
key down and the item will be selected or deselected if it is already selected.

Copy
Copies what is currently selected.    The original remains where it is.    The copy is 
placed temporarily on the Clipboard.

Paste
Inserts the contents of the Clipboard at the current location.    Clipboard contents 
can be an item, text, sound, or a picture.    Pasted items always are placed after 
the current item.

Clear
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Removes what is currently selected without storing it on the Clipboard. 

Select All
Selects the entire contents of a text box.    You can then Cut, Copy, or Clear this 
text.

Show Clipboard
Displays the contents of the Clipboard if it contains text or a picture.

Find
Asks for text to find and then finds it.    Find ignores the case of the text.    
“HELLO” works the same as “hello”.

Find Again
Finds the text you last specified with Find.

Options

Print Options
When “Blanks before questions” is checked, a short blank will appear for the 
student’s response before true/false, multiple choice, and matching questions, for 
example “_____ 10. Who is the…”    Use “Blanks before questions” when the 
student will be putting his responses on the test paper itself.

When you choose “Fill-in blanks outside,” blanks will appear after the question, 
such as “Fourscore and ___12___ years ago.    12. __________.”    Blanks 
outside can make tests easier to grade, but it is easier for students to fill in the 
wrong blank.    When you choose “Fill-in blanks inside,” blanks for the student to 
put his answer in will be put directly into the text, such as “Fourscore and 
_________ years ago.”

When you choose “Matching in columns,” there will be a left-hand column of 
sources and a right-hand column of destinations.

____ 22. Cape Town A.    India

____ 23. Havana B.    South Africa

____ 24. New Delhi C.    Cuba

When you choose “Matching separated,” destinations will appear first, followed 
by the sources.

A.    India

B.    South Africa

C.    Cuba

____ 22. Cape Town

____ 23. Havana

____ 24. New Delhi

“First question number” is the number Test Builder begins with when numbering 
questions.    If the test is the second half of a larger test, you can make sure the 

-6-



question numbers correspond by changing this number.

When “Print points on test” is checked, the student will see the point value after 
each question, such as “14.    Burma is in Africa (5 pts).”

When “Print points on key” is checked, you will see the point value of each 
question on the key when you print it, such as “14.    False (5 pts).”

When “Number Pages” is checked, a page number will appear at the bottom of 
every test page.    Numbering starts with the number you give as First Page 
Number.

Testing Options
Testing Options give you control over the way the test will be taken on the screen 
with Test Taker.

When “Timed Test” is checked, there will be an enforced time limit on the test.    
When the hours, minutes, and seconds you give run out, Test Taker ends the 
test.

When “Show Correct Answers” is checked, Test Taker will give the correct 
answers to the student after completion of the test.    Use “Show Correct 
Answers” when you want the student to see immediately what mistakes were 
made.

“Restrict Access” means that the test password is required to see the results of 
the test.    You can use this option only if the test is already password protected.

Items Menu

A single header item appear at the beginning of every test.    You cannot cut or 
copy it.

The first text box is the title of the test.    The second is the test blanks, which is 
interpreted in a special way.    Every word or words typed between curly braces 
becomes a blank.    Blanks look like “Name:__________” when printed.    When 
tests are taken on the screen,    Test Taker asks the student for what you put in 
the blank.    You may have four blanks per test.

Question Items
You can change the points value of question items by clicking in the buttons in 
the top right-hand corner of the item.    Hold down the option key while clicking 
these buttons to make the value change more quickly.

Question items may be assigned a category and difficulty.    See “Categories”.

-7-



The first text box contains the question to be answered.    The other text boxes 
are choices.    To add a new choice, click on the New Choice button.    You can 
add as many choices to the question as you like.    To remove a choice, click on 
the “X” button next to it.    (You cannot remove the last remaining choice.)    To 
designate the correct choice, click on the arrow next to it.    Only one choice can 
be correct.

Type a statement in the true/false text box, and click on true or false below.

Fill-in questions take all words enclosed in curly braces and makes them blanks. 
When the question is printed out or given in Test Taker, these words will 
disappear and be replaced with “__________”.    The words in braces will be 
given as answers on the test key.

Each blank you create counts as a question, and gets its own number.    Each 
question is worth the point value given in the corner of the item.

Matching question items consist of sources and destinations.    In Test Builder 
you type sources and corresponding destinations next to each other in a pair.    
When the student sees the question, the sources and destinations will be mixed 
around.    It is the student’s task to match them back together.

Type a source and destination together in a pair.    To add a new source and 
destination, click on the New Pair button.    You can have as many pairs in a 
matching item as you wish.

In some cases, more than one source matches a destination.    To add another 
source that corresponds to a destination, move the cursor to the destination and 
click on New Source.    Any number of sources can match one destination.    To 
remove a source or a pair, click on the “X” button next to it.    (You cannot remove 
the last remaining pair.)

You may add a choice that doesn’t match with anything, in order to make the 
student’s job of matching more difficult.    To do so, click on the Extra Destination 
button.    In the example above, Oman matches with no source, yet will be shown 
to the student with the others as if it were.

Each source you make is a question and will be given its own number.    Each of 
these questions is worth the point value given at the top of the item.

Type the essay question in the top text box, and if you wish, a model answer 
below.    Unlike all other question items, essays cannot be automatically graded 
when the test is taken on-screen.    You may wish to add extra space after the 
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text of your question in which the students can put their responses.

Instruction items give students extra information about a question.    Like all 
information items, they are not counted as questions and are not numbered.

Picture items let you put graphics in your tests.    To use a picture, go to a 
graphics application like MacPaint or Hypercard and copy the picture you want 
onto the Clipboard.    Then open Test Builder and create a picture item.    Click on 
the gray picture rectangle in the picture item so Test Builder knows where to put 
the picture.    Then choose Paste from the Edit menu.    You can later paste a new 
picture over this one, or cut or copy the picture back to the Clipboard.    Be sure 
to click on the picture rectangle before cutting, copying, or pasting pictures.

Use the caption to provide text information about the picture.

Sound items lets you add sounds to tests given with Test Taker.    They are 
omitted when the test is printed.

If you have a microphone built in to your computer, you can record sounds 
directly.    Click the Record New Sound button and record them.    If you don’t 
have a microphone, you can paste sounds in from other applications.    To paste 
in a sound, go to another application such as Hypercard and copy a sound.    
Then return to Test Builder and create a sound item.    Click on the sound icon 
and a rectangle will appear around it.    Then choose Paste from the edit menu.    
If the sound item has a sound associated with it, the sound icon will be filled in as 
it is above.

Use the Name text box to give a name the sound.

Shuffle
Shuffling a test rearranges the items in a random order.      Also, multiple choice 
choices will be randomly reordered and matching questions will have the order of 
the sources and destinations changed.

Use Shuffle when you want to create multiple versions of a test with the same 
questions.    Use Save As in the File menu if you want to save each of these 
versions separately.    (“Osmosis Test A”, “Osmosis Test B”, etc.)

Categories
Categories and difficulties are used in conjunction with Auto Extract.    Auto 
Extract can look for items of a certain category or difficulty to add to a test.    You 
can also use categories for you own information about questions.    Categories 
and difficulties are not printed on tests, and are ignored by Test Taker.
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To choose names for the categories in your test, choose Categories in the Items 
menu.    You can then choose up to five category names.

To put a question into a category, click anywhere inside the question items 
outside of buttons and text buttons while holding down the option key.    A menu 
will pop up that lets you choose the category.    The category you chose will 
appear on the top of the question item.    If you want to remove a question from a 
category, choose the blank option at the top of the pop-up menu.

To assign a difficulty level to a questions, click anywhere inside the question 
items outside of buttons and text buttons while holding down the option and 
shift keys.    You can choose a difficulty level of easy, intermediate, difficult, or 
very difficult.    If you want to remove a difficulty assignment, choose the blank 
option at the top of the pop-up menu.

Item shortcuts
To move among text boxes in an item, use the tab key.    To tab to the next item, 
hold down the shift key when you press the tab key.

You can add a new item of the same kind as the current item by holding down the 
command key and pressing the return key.

In matching and multiple choice questions, you can add new text boxes by 
holding down the option key when you press the return key.

Font Menu

Use the Font menu to change the font of the text box that has the blinking cursor 
in it.    You may have only one font in each text box.    Hold down the option key 
when choosing a font to make it the default.    The default font will be the initial 
font of all newly created text boxes.    Hold down the command key when 
choosing a font, and all the test will use that font.

Size Menu

Use the Size menu to change the font size of the text box that has the blinking 
cursor in it.    You may have only one font size in each text box.    Larger 
increases the font size by one and Smaller decreases it by one.    Use the Other 
command to set the font size directly.    Hold down the option key when choosing 
a size to make it the default.    The default font will be the initial size of all newly 
created text boxes.    Hold down the command key when choosing a size, and all 
the test will use that size.

Style Menu

Use the Style menu to change the style, alignment, or spacing of the text box that 
has the blinking cursor.    You can have many different styles at once (bold, italic, 
and condensed text) but all text in a text box will have the same appearance.    
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Text can be aligned left, right, or center.    Spacing controls how much room there 
will be between lines in a text box.    Hold down the option key when choosing 
styles, alignments, or spacing to make them defaults.    Hold down the command 
key and all the test will use the style.
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Test Taker Reference

Test Taker is a program that lets you give tests directly on the Macintosh screen. 
The student opens a test, responds to the questions, and then tells Test Taker 
when finished.    All questions except essay questions are the immediately 
graded.

You have two choices as to what happens at the conclusion of the test, which 
you decide when you make the test with Options in the Edit menu of Test Builder. 
If you choose Show Correct Answers, the right answers to every question will be 
shown after the test.    If you choose Restrict Access, the password will be 
required to see the results of the test.    You can only choose this option if the test 
is already password protected.    Results can be printed out when the test is over 
and the results are shown.

Remember that giving tests on-screen is less secure than giving them on paper. 
There is more chance for students to hide correct answers somewhere in the 
computer for other students, or to see other students taking the test, or to take 
the test more than once.    If you are concerned about cheating, choose Restrict 
Access.

Time limits can be put on tests.    Set the time limit by choosing Options in the 
Edit menu in Test Builder.    Type the hours, minutes, and seconds for the limit, 
and check Timed Test.    When the student begins the test, the timer will begin 
counting down.    When it reaches zero, the test will be automatically ended.

Students taking tests with Test Taker see one item at a time.    They answer each 
question and click Next to go on to the next question or information item.    First 
and Last take the student to the beginning or ending item of the test.    The 
student should click Finish when completed.    The results are then compiled, and 
depending on what you chose under Options in Test Builder, correct answers are 
shown or a password is requested to see the results of the test.

When the test has been completed, and Restrict Access is not chosen, the 
student can still look through the test but not change any answers.    At this time, 
the test may be printed, giving you the chance to grade any essay questions.    
You may also grade essay questions on the screen.
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