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Shareware Nntire

LanSatellite is shareware. If you decide to keep it for more than 15 days, you are obligated to
send payment of US$20 per copy to the author, at the following address:

Trygve Isaacson

1352 Rifle Range Rd.

El Cerrito, CA 94530
Include your e-mail address to receive update information!

If you have questions, suggestions, bug reports, licensing inquiries, etc., or custom recognizers
you’d like to see included, please let me know about it! You can use the address shown above,
but better yet use e-mail:

Internet: trygve@netcom.com
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LanSatellite allows you to use your Macintosh to view your AppleTalk network. Your
LanSatellite documents store information about the devices found on the network. You can print
the network data in list or icon format, and can export the data as tab-delimited text. LanSatellite
can also help alert you to network problems such as devices disappearing from the network.

Background

After seeing a few other network management-oriented applications and thinking about what
they did wrong, I decided to write an application that uses some ideas I had about implementing
network management the right way. Some of things I see done wrong in many network
management applications, and that LanSatellite does right include:

* network diagrams

You should be able to modify your network diagram. Some applications present you a phony
generated diagram and don’t let you modify it to reflect the true topology or site layout.
LanSatellite lets you drag devices around in icons views to reflect your actual network topology
or physical layout.

* device display

You should be able to see devices that were available last time you ran the application but that
aren’t there now. Some applications give you no way to save your network information and bring
it back later for additions and modifications. LanSatellite keeps your network data in documents
that you can re-open later, and to which you can accumulate new devices--you don’t lose track of
devices simply because they happen to be unavailable at the moment.

* network navigation

You should be able to easily work with the appropriate parts of the network that you care about.
Some applications let you only work on a zone at a time, which is silly because with AppleTalk
Phase 2, zone divisions are often meaningless. For example, two machines next to each other on
the same Ethernet cable may be on separate zones; all you care about is that you can put them
next to each other in your network diagram. LanSatellite lets you work with whatever zones you
care about, and lets you do so easily.

* human interface

Finally, you should be able to use the application easily, and its interface should be clean and
obvious. Some applications have awkward interfaces that make it unnecessarily difficult for you
to do what you want. LanSatellite’s interface is clean and simple, with room to grow gracefully.



Coming 5o00n

Of course, LanSatellite has plenty of room for improvement. Here’s my list of intended
upcoming features (hey, no guarantees!)...

Version 2.0: Device filtering. Echo protocol (ping). View customizing. Find and Select.
Node info.

Version 2.1: Cable drawing. AFP access. PPC port info. Alert logging and forwarding.

Version 3.0: Use built-in, SNMP MIB, and custom responders. Software distribution.

Avstem Requirements

LanSatellite requires System 7.0 or later to run. Its minimum application size is set to 1MB,
although you can get by with a bit less if your network only has a few nodes. Its preferred size is
2MB, which is plenty of room to let you monitor well over 1000 entities and 300 nodes.

LanSatellite Quick Start

It’s very easy to get LanSatellite up and running. This section explains how to get started.

When you launch LanSatellite, an untitled document is created. It has default settings all set up
for you, but searching is not turned on in case you want to change anything before searching the
network.

Selert znnes

If you just want to search your current zone, you don’t need to change anything. However, if you
want to search a different zone, or multiple zones, select Zones from the Network menu and
indicate which zones you want to search.

Enable searching

Now, just select Enable Search from the Network menu. This item turns searching on and off, as
indicated by the check mark. Searching occurs in the background. By default, the search results
are accumulated every 30 seconds.

Viewr ac desired

Sort by using the View menu commands or clicking the column headings. Expand and collapse
the hierarchy by using the View menu commands or clicking the expander triangles. In icon
views you can drag the icons around and even paste in a background picture.



Metwark Documants

LanSatellite lets you open multiple documents open at once; currently this is most useful if you
want to keep different zones separated into different documents. In addition to storing all of the
information about what’s on the network, each LanSatellite document contains setup information
about the zones being searched, how lookup occurs, what alert conditions are used, and your
view settings. The next section describes how you can configure these settings. These commands
always apply to the active, or frontmost, document.

You may notice that when you open a previously saved network document, all of the network
entities appear grayed out. This indicates that the devices have yet to be seen since the document
was opened. When you select Enable Search from the Network menu, searching begins; as soon
as an entity is found, it is drawn dark again.

Network Setup

A document’s network setup consists of a zone selection and lookup settings.

Zone selection

The Zones command on the Network menu brings up the zone selection dialog. It presents a list
showing all of the zones on your network. You simply click to select the zones you want to
search for the document. Shift-clicking extends a contiguous selection, and command-clicking
extends a discontiguous selection. The Select All (command-A) and Select None (command-
option-A) commands on the Edit menu can also be used.

Search settings

The Search Settings command on the Network menu brings up the search settings dialog. It
presents you with several values you can set depending on what your network is like and how
you want to search. In general, you’ll just want to change the Idle; in certain situations it may be
useful to change the Interval and Count. Here is what each item means:

* Idle (seconds)

This is time between network searches. Remember that searching actually occurs in the
background. Each time the Idle elapses, the current search results are extracted and accumulated
into the document. The beach ball cursor spins while this occurs. If you are searching multiple
zones, the zones are searched one at a time, one per Idle. For example, if you are searching 3
zones, and your Idle value is set to 60 seconds, the zones are searched in order, one zone each 60
seconds, each zone every 180 seconds.



* Interval (1/8 seconds) and Count

These are low-level AppleTalk NBP values, and they determine how much time devices are
given to respond to a search. The Interval describes how long the search “looks” for responses,
and the Count describes how many times it “looks” it makes during a search operation. The
longer the Interval, the more time slow devices have to respond, and the larger the Count, the
more chances they have to “beat the clock” on each search. You can multiply the Interval and
Count to determine the number of seconds each search will actually take. For example, the
default settings are Interval = 24 = 3 seconds, Count = 3, which multiplies to 9 seconds. If your
Idle setting is less than this actual search time, some Idles will have no effect (this is not really a
problem, but it’s not bad to know how to fine-tune these settings).

* Buffer Size (K)

This determines how large of a buffer is used for the search. Smaller buffers will result in fewer
devices being found on each search, with the slowest devices losing out and not being found! So
you probably don’t want to mess with this.

* Maximum to Get

This determines the limit of the number of items that will be returned on each search. As with the
Buffer Size, small values will cause slow devices to lose out, so you probably don’t want to
change this.

* Retries
This value is not currently used.

* Use Factory Settings
This button restores all search settings to their “factory defaults.”



Viewing the Network

The network document window can be viewed either as a list or as a graphical icon view. The list
view can be sorted, and the icon view allows you to arrange the icons by dragging them.

list views

To see the list view select one of the following commands from the View menu: by Name, by
Type, by Zone, by Net, or by Node. The list will be sorted by the corresponding column, and the
column heading will be underlined.

Selecting

In the list view, you select nodes by clicking on them. Shift-clicking extends the selection
contiguously, and command-clicking extends the selection discontiguously. The Select All
(command-A) and Select None (command-option-A) commands on the Edit menu can also be
used.

Expand and Collapse

Each node in the list has a little expander triangle, similar to folders in the Finder’s list views.
Clicking the triangle expands or collapses the node to show or hide the individual entities at the
node. One of the entities will always be the “physical” device whose name and type are used to
represent the node. See the section on recognition for more details on this.

You can also use the Expand Selection and Collapse Selection commands on the View menu.
These commands operate on all selected nodes (see selecting, above). For example, a quick way
to expand all nodes is to type command-A (select all), followed by command-E (expand
selection), followed by command-option-A (select none).

Finally, notice that there is a diamond mark on the View menu next to either the Expand
Selection or Collapse Selection command. This mark indicates whether newly found nodes will
appear in the list expanded or collapsed. You can change this setting by holding down the option
key while selecting the desired item from the View menu. When you do this, it won’t actually
expand or collapse anything, but will move the diamond mark; any nodes subsequently found
will appear in the appropriate state.



Sorting

There are two ways to sort the list. One is to click on the column headings; the other is to use the
View menu commands. If you hold the option key down while doing this, it will set the
secondary sort field; similarly, use the command key to indicate the tertiary sort field. Only the
primary sort field is visually indicated with the column heading underline and the check mark on
the View menu. Note that if you have a large number of nodes in the network window, and/or
you are running on a particularly slow machine, the sort may take a few seconds or more, so you
may want to set your sort order before you begin searching the network.

Irnn views

To see the icon view select by Icon or by Small Icon from the View menu. The large icon view
shows 32x32 icons with the node name and type; the small icon views show 16x16 icons with
just the name.

Default arrangement

As new nodes are found on the network, their positions in the icon views are determined by
finding the next open spot in the small icon view based on the window size. If you don’t move
any icons or resize the window, this will mean that nodes simply accumulate row by row, with
the horizontal spacing varying occasionally depending on the length of the node’s name. When
you resize the window or drag items around, the default placement information is reset, so new
nodes may fill in gaps in the icon layout at that point. Once you have over 100 nodes, new ones
are just placed at the bottom.

Selecting

You select node icons using the same selection techniques that you use in the Finder’s icon
views. To select an icon, click it. To select a group of icons, drag a selection box around them. If
you hold down the shift key when clicking an icon, its selection state is toggled. If you hold
down the shift key when dragging a selection box around some icons, the selection state of each
individual item you surround is toggled. In addition, you can use the Select All and Select None
commands on the Edit menu.

Dragqging

You drag node icons using the same drag-and-drop techniques that you use in the Finder’s icon
views. If you click an unselected icon, it becomes selected and you can drag it to its new
location. If you click a selected icon, it and any other selected items remain selected and the
entire group can be dragged. If you shift-click on an unselected icon, it becomes selected, any
other selected items remain selected, and the entire group can be dragged. If you hold the
command key down while dragging, the icons will snap to the grid.



* Version 1.0 bug note: Negative coordinate space isn’t drawn and you can’t scroll to it. So if you
drag and drop a group of icons such that some of them are moved above or to the left of the
upper left corner of the icon view area, the scroll bars won’t allow you to scroll over there. In
order to bring them back into view, you’ll have to do a Select All to select them, and then drag
everything back into positive coordinate space.

Background pictures

You can paste a background picture into either icon view, or both. For example, you can create a
floor plan picture in a drawing application, paste that picture into the icon view, and then drag
the nodes to the proper location on the floor plan.

If you just paste a picture into the small icon view, when you use the large icon view the picture
will be scaled to 200%. If you just paste a picture into the large icon view, when you use the
small icon view the picture will be scaled to 50%. But you can also paste a separate picture into
each view, in which case each view will use its own picture without scaling. This might be useful
if you want the large icon view’s background picture to contain more detail than the small icon
view’s background picture. I this case you do the scaling ahead of time in your drawing
application.

* Version 1.0 bug note: There is currently no way to remove a background picture other than to
replace it by pasting in an empty picture. Or you can use ResEdit and remove the PICT resource
from the saved document. I didn’t want to use the Clear command on the Edit menu because that
removes any selected nodes.



Alarts

LanSatellite has a way of alerting you when entities disappear from the network. This is useful
for keeping an eye on vital network services such as routers and file servers, or for just keeping
an eye on things. You can set up the network document to use certain measurements for deciding
what determines when an entity is considered to be “disappeared.”

Alert settings

The Alerts command on the Network menu brings up the alert settings dialog. It presents you
with several values you can set depending on what your network is like and how you want alerts
to appear. There are three basic choices for when to place an alert on entities in the icon or list
view. Here is what each item means:

* Never
If you select this option, there will be no alerts.

* Not seen in <n> minutes
If you select this option, if an entity has not been seen in the specified number of minutes, it will
be considered disappeared and an alert will be placed on it.

* Not seen in idle time * number of zones * <n>

If you select this option, the amount of time it takes before an entity is considered disappeared
will be based on the number of zones being searched, the Idle setting in the search settings
dialog, and a multiplier. This option allows you to change the Idle setting and number of zones
being searched and still have a reasonable alert setting despite the fact that as you increase the
Idle time and the number of zones being searched, the less often each entity gets a chance to
even be covered by a search operation. However, you’ll probably want to increase this setting if
you are searching a lot of zones.

* Use Factory Settings
This button restores all alert settings to their “factory defaults.”

Alert indicators

When an entity is considered “disappeared” according to the alert settings, a small alert icon is
placed on it. For expanded items in the list view, each individual entity can have an alert or not.
The node itself, seen in icon views or as a collapsed list view item, gets an alert placed on it only
if all of its individual entities have alerts. So an alert on a node means that every entity at that
node has “disappeared.” Alert indicators are removed as soon as the item is seen again.



If you disable searching and then re-enable it later, LanSatellite knows not to count the amount
of time searching is disabled as time that entities are not seen. If an entity is considered “seen” at
the time searching is disabled, then when searching is re-enabled, the alert interval is restarted so
that alerts don’t suddenly show up on a bunch of nodes.

Saving and re-opening a document causes the alerts to be removed. A re-opened document has
all of its entities grayed out until they are seen again.

Printing and Exporting

LanSatellite documents can be printed in any view, and can be exported as a tab-delimited text
file according the current list view sort order.

Printing

You use the standard Page Setup and Print items on the File menu to print a network document.
The document is printed using the view that is currently in use. The only difference between
what appears on screen and on paper is that for better readability, text that is dimmed on screen is
not dimmed in the printout. Icons that are dimmed on screen are also dimmed in the printout
(however, I've found that when you turn on grayscale printing on laser printers, you have to look
pretty closely to distinguish dimmed icons from undimmed icons).

Exporting

You can use the Export Text command on the File menu to export your network document as a
tab-delimited text file. The order of the items is determined by the sort order you have set up in
the list view; if you’re currently viewing an icon view, that’s OK, because there’s still a sort
order in effect even though you’re not looking at it. The text file will contain all entities, as
though you were looking at a list view with all rows expanded, but with only the actual entities
(not the added “node” items that appear when collapsed), and with each entity indicating its
zone, net, and node, rather than leaving those with the added node item (this makes the text file
sortable on all columns).



Recognition and Customizing

All of the settings and commands described so far have been things that apply on a per-document
basis; that is, each document has its own zone, search, alert, and view settings. But there are a
couple of things that are preferences that affect all documents. This section describes how you
can set these up. Currently this applies to how the raw AppleTalk NBP information is turned into
the more understandable types and icons shown by LanSatellite.

LanSatellite uses “recognizers” to determine how to display the raw NBP information it finds on
the network. If a recognizer is found for an entity, LanSatellite uses the appropriate icon and type
string when displaying the entity. In addition, the recognizer determines whether the entity is
considered “physical,” “variable,” or “logical.” These distinctions, and how you can customize
the appearance of the entities, are described below. You may want to add new recognizers if your
network has entities on it that LanSatellite doesn’t already know about, but that you do know
about. For example, if you have a new piece of equipment that shows up on the network, you can
add an icon and recognizer for it so that LanSatellite displays it nicely.

* Version 1.0 note: All icons and recognizers, including the ones you customize, are kept in
LanSatellite’s own resource fork. This has two ramifications. First, if LanSatellite is locked—or
is on a locked disk—any changes you make will not actually be saved when you OK the
recognition or icon import dialog. Second, because your recognizer changes are stored in the
application itself, when you get a new version of LanSatellite you’ll have to redo your changes.
Fortunately, you can very easily re-import any icons you’ve added, by simply running the new
version and using the Import Icons feature to import the desired icons from your old version.

Importing icons

The Import Icons command on the File menu lets you select any file from which to import icons
(color icons must be in System 7 icon family format). After you select the file, a dialog shows
you all of the icons it contains. You simply select the icons you want to import and click OK. The
icons are imported and are then available for you to use when customizing the recognizers.

You can also use the Finder to drag-and-drop any file onto the LanSatellite icon; LanSatellite
will open the file using the Import Icons command automatically. (Unless it’s a LanSatellite
network document, in which case it will open the document with the Open command, as
expected.)



Customizing the recognizers

The Recognition command on the View menu lets you add, delete, and modify recognizers. The
recognition dialog opens and shows you a list of recognizers. There are actually three lists of
recognizers, and the radio buttons at the top of the dialog lets you pick which list to view at any
given time.

Each recognizer indicates, by virtue of which type of recognizer it is, whether an NBP entity is
consider to be “physical,” “variable,” or “logical.”

* A physical entity is an entity that represents a physical device on the network. When a physical
entity is found at a node, that entity is used by LanSatellite to represent the node in icon views
and as the node item in list views. Examples of physical entities are Macintoshes, routers, and
networked modems.

* A variable entity is one that may or may not represent a physical device on the network. When a
variable entity is found at node, that entity is used by LanSatellite to represent the node only if
there is not a physical entity already found on that node. The two most common variable entities
are:

The NBP type “LaserWriter”, which is often an actual LaserWriter or other PostScript
printer, but is sometimes just a PostScript print spooling service running on a computer;
that’s why LanSatellite shows this NBP type as “PostScript Printer”.

The NBP type “Workstation”, which is the responder node found on Macs running
System 7; if LanSatellite doesn’t have a recognizer for the type of Mac by name (which
will happen when new Mac models come out), treating the Workstation entity as a
variable device allows LanSatellite to show the generic workstation Mac icon to represent
the machine.

* A logical entity is one that does not represent a physical device on the network, but rather
represents a service or other entity running on a physical device that will itself show up as an
NBP entity. When a logical entity is found at a node, that entity is used by LanSatellite to
represent the node only if there are no other entities found yet at that node. Examples of logical
entities are AFP file servers, various e-mail client software, and SNMP agents.



Dyvnamic Addressing Note

One of things about AppleTalk that makes it easy for users, but tricky for network management
software, is dynamic node addressing. In general, when a user first turns on their Macintosh, a
random AppleTalk node address is assigned to the machine. Next time, the Mac will try to use
the same address, but if some other device has taken that address, the Mac will pick another until
it finds an address that is not already in use. Since devices are always referred to by name, not
address, this works well since the user doesn’t care about a device’s address and knows its name

anyway.

But for an application like LanSatellite, this causes headaches because as it tries to keep track of
a device over time, the device may move to a new address. The application must be able to
notice when a device has moved to a new node address. It must also notice when a new physical
device has “stolen” an existing device’s node address. This can get tricky.

LanSatellite handles these situations pretty well (although I've noticed a glitch or two in version
1.0 in certain instances). In the case where a physical device moves to a new address,
LanSatellite changes all entities at the device’s old address to have the new address. In the case
where a new physical device appears at an address already occupied by a physical device,
LanSatellite marks all “old” entities at that node as having an “obsolete” address (the device is
probably powered off or gone for good). This is indicated in the list window with an asterisk next
to the node address number.



