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This program is a pre-release version of what in the near future will be a full-fledged crossword puzzle
processor. [ would first like to obtain as much feedback as possible (Please write!), so I am releasing
the first versions as public domain software. The final version will contain many additional facilities,
including, hopefully, the use of a dictionary.

I have not yet decided whether to distribute the final version via shareware of commercial publishing.
Much depends upon the response to this trial program. I hope it is strong enough to allow me to
follow the shareware route, for I feel that the shareware concept is beneficial not only to users, but to
authors as well.

If you find this program useful or entertaining, please sent $20 to
Patrick J. Stevenson
26 Roberts Street #223
Fargo, ND 58102
All who send $20 (price valid until the date of the next trial release) before the release of the final
version will be placed in a registration list. They will be notified when the final release is available
and will be able to receive it for free.

13/5/25



CrossMaster

Contents

l. Introduction

Il. Instructions

Starting / Stopping the program
Opening a crossword puzzle
Editing the puzzle text

Editing the solid cells
Resizing the puzzle

Editing the puzzle titles
Saving a puzzle

Printing a puzzle

Closing a puzzle

Creating a new puzzle

Using the current clue number
Editing clues

Switching windows

[1l. Thank You

23/5/25

Version 0.2

© © ©O© 000 0 ~N o o b~ b

e
N B O O

13



CrossMaster Version 0.2

Introduction

The idea for CrossMaster sprang during a time when my roommates and | expended a great
deal of effort toward solving the crossword puzzles that appeared in our local newspaper.
We spent hours searching our dictionary and thesaurus that we might defeat our arch rival,
the notorious Sunday crossword. Sure, we showed signs of fatigue and battlewear, but it
was the puzzle itself that really took the beating. Bloodied from our red pen, much of the
paper was unreadable or had been ripped right through. The letters that had been written
over several times all looked the same, with none resembling anything in the English
alphabet.

This weekly war seemed to be escalating, so | looked for a way to make it at least a little less
violent. | began to imagine the Macintosh, with its black-and-white screen and square pixels,
as my salvation.

Scheming and brainstorming instilled in me the seeds for a program that would turn my
computer into an efficient, effective crossword puzzle processor. It would allow me to change
a word 50 times and have it still look just as neat as the first time it was entered (and much
neater than my roommate's chicken scratch). When | selected a word in the puzzle, it would
automatically display the associated clue without my having to pour through columns of print
suitable for disclaimer terms in a legal document. With a dictionary and a nice way to print
the puzzles, the Mac would be just as helpful in creating crossword puzzles as it would be in
solving them.

Thus was born CrossMaster.
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Instructions

| have prepared a brief set of instructions that should get you started in using CrossMaster. |
am not as adept at teaching as | am at programming, so please bear with me if something is
unclear. | would be happy to answer any questions | can by mail.

| tried to set up these instructions such that you could work with a crossword puzzle as you
read them. If you have the puzzle Sample, work with that one as you proceed.

Note: Menu commands and titles are represented by the Chicago font. Any non-

alphanumeric keys to be pressed are represented by the Monaco font. Alphanumeric keys or
commands and puzzle file names are represented by underscoring.

Starting / Stopping the program

The CrossMaster program is contained in the file CrossMaster. The desktop icon looks like this:
Sy ey

355
L

CrassMaster

Any crossword puzzles created by CrossMaster will have icons that look like this:

C C

B B
LORD LWORD

5 5

Purzla 1 Puz=la -

The package | released contained the CrossMaster program and five sample crossword
puzzles. Puzzle 1 and Puzzle 2 have only the clues completed. Answer 1 and Answer 2 are
fully completed copies of Puzzle 1 and Puzzle 2. Sample is a partially completed puzzle that
you might wish to work with as you read these instructions.

To start CrossMaster, simply select the program icon and choose Open from the File menu, or
double-click on the program icon. If you would like to open a crossword puzzle when you
start the program, select or double-click on the puzzle icon instead of the program icon.
CrossMaster will be started and the crossword puzzle selected will be automatically opened.
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To quit the program once it is running, simply choose Quit from the File menu. If you are
currently working with a crossword puzzle and you have made changes since it was created
or opened, you will be asked if you wish to save those changes.

Opening a crossword puzzle

You will open a puzzle when you wish to use one that has already been created. You may
open a puzzle when you start the program as outlined above. However, if the program is
running, you must choose Open from the File menu to start using a puzzle.

When you open a puzzle, a window with the puzzle grid, text, and solid cells will be
displayed. This will be referred to as the puzzle window throughout these instructions.

Editing the puzzle text

The crossword puzzle is organized into rows and columns of cells. Each cell occupies one
square in the puzzle grid. There are two types of cells: text cells and solid cells. The solid
cells are the black or shaded cells into which no letters may be placed. The text cells are
simply all other cells in the puzzle.

The text cells are edited a word at a time. A word is a set of connected cells all in a vertical
or horizontal line. It must be at contain at least two cells. Editing text is a two-step process.

First you select the word you wish to edit, then you make the changes you wish to make.

To select a horizontal (across) word, click once on any text cell in that word. To select a
vertical (down) word, double-click on any text cell in that word.
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After you select a word, the word will be inverted. The cell on which you clicked will remain
normal. That is where any typing will go. This cell will be referred to as the cursor. After you
type a key, the cursor will move to the next cell in the word. If the cursor is at the last cell in
the word, it will move back to the first cell in the word.

Only uppercase alphabetic characters will be accepted into the puzzle. If you enter
lowercase letters, uppercase letters will be substituted. If you enter numbers or punctuation,
nothing will happen.

Along with using the mouse to select words and place the cursor, a number of non-
alphanumeric keys also let you move the current word and cursor around the puzzle. These
are listed along with their functions as follows:

Space Places a blank in the cell with the cursor and moves the cursor one cell
forward.

Backspace Moves the cursor one cell backward and places a blank in that cell.
Clear Replaces all cells in the current word with blanks.

Return Selects the next word in the puzzle moving from left to right and top to bottom
for horizontal words and top to bottom and left to right for vertical words.

Shift-Return  Selects the previous word in the puzzle, just the reverse of Return.

Tab Selects the next word in the puzzle, same as Return.

63/5/25



CrossMaster Version 0.2

Shift-Tab Selects the previous word in the puzzle, just the reverse of Tab.

Right-Arrow  If the current word is horizontal, it moves the cursor forward one cell.
Otherwise, it selects the next vertical word.

Left-Arrow If the current word is horizontal, it moves the cursor backward one cell.
Otherwise, it selects the previous vertical word.

Down-Arrow If the current word is vertical, it moves the cursor forward one cell. Otherwise,
it selects the next horizontal word.

Up-Arrow It the current word is vertical, it moves the cursor backward one cell.
Otherwise, it selects the previous horizontal word.

Enter It deselects the current word if one is selected.

Editing the solid cells

In order for me to avoid a lot of complex programming, | have created a separate editing
mode for working with the solid cells. To edit the solid cells, select Edit Solid Cells in the Edit
menu. A small dialog box will appear with two buttons: End Edit and Revert.

Clicking on a cell in the puzzle will reverse its status from text to solid or vice versa. If the
mouse button is held down, all cells over which the mouse passes will be changed (if
necessary) to the status of the initially clicked-on cell.

When a cell is switched from solid to text a blank is placed there. However, if the cell was a
text cell when the solid edit mode was begun, the character originally in the cell will be

replaced.

Choosing Revert in the dialog box will reset all puzzle cells to the status they had before the
solid edit mode was entered.
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Choosing End Edit will exit the solid edit mode so that normal text editing can resume.

Resizing the puzzle

The puzzle can assume a size anywhere from 3 * 3 to 23 * 23. You can change the size of
the puzzle by choosing Resize Puzzle in the Edit menu. A dialog box will appear with the
current size of the puzzle displayed. To change the size, simply type the new size. If the
new size is too small or large, of if the entry has non-numeric characters in it, it will not be
accepted. It must be a number from 3 to 23.

When an acceptable size is entered, the puzzle is resized. If the puzzle is to be enlarged,
blanks are placed into all new cells added to the puzzle. If the puzzle is to be reduced, all
cells outside the new side are simply removed.

After the puzzle is resized, you are placed into the solid edit mode. | decided to do this

because a change in the size of a puzzle is usually associated with a rearrangement of the
solid cells.

Editing the puzzle titles

| have allocated for each puzzle four title fields: a puzzle title, a puzzle subtitle, an author,
and a date. These will be stored with the puzzle when it is saved.

To edit the puzzle titles, choose Puzzle Titles from the Puzzle menu. A dialog box will appear
with the current values of the titles. You may enter new titles or changes those that appear.

To move through the titles, press Tab. Pressing Return will remove the puzzle titles from the
screen.

Saving a puzzle
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When you wish to place the information for a puzzle onto a disk for permanent storage,
choose Save or Save as from the File menu.

When you choose Save, the puzzle is saved to disk in the current disk/folder location and with
the current name of the puzzle. If the current name of the puzzle is untitled, you will be
prompted for a new file name.

Choosing Save as is the same as choosing Save, except that you are automatically prompted
for a new file name instead of only when the file name is untitled. Select Save as if you want
to give your puzzle a new name or save it to a different location.

Printing a puzzle

To print a puzzle, choose Print from the File menu. You will get the print job description dialog
box from which you may select print quality, number of copies, etc. Since | currently have the
program setup for printing on 8.5" * 11" paper | haven't instituted using the page setup dialog
box.

Selecting Draft for the output quality will not produce exciting results. Also, since a puzzle will
only take up one page (currently), it does not make sense to select pages to be printed. The
only choices you should have to make with the print job dialog box are between Best and
Faster output and the Number Of Copies.

When the puzzle is printed, the puzzle titles will appear on the top of the page. The puzzle

will be below the titles on the right side. The clues will be printed in up to four columns to the
left and below the puzzle.

Closing a puzzle

When you are through working with a crossword puzzle, you simply close it. To close a
puzzle, either click the mouse in the close box of the puzzle window or choose Close from the
File menu.
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As when you quit the program, if you have made changes to the puzzle since it was created
or opened, you will be asked if you wish to save those changes.

Creating a new puzzle

When you wish to start with a new puzzle, choose New from the File menu. You will be given
a puzzle of size 21 * 21 filled with blanks. You will be given the resize puzzle dialog box to
select the size you wish. After selecting the size, you will be placed into the solid edit mode.
The puzzle will be given the file name untitled.

Using the current clue number

Because of the resolution of the Macintosh screen, | have not been able to place the clue
numbers into the cells. However, | have created a dialog box to show the clue numbers.

To open the current clue number box, choose Show Current Clue Number in the Clue menu.
The dialog box that appears will always display the number and direction of the word
currently selected in the puzzle window. For a horizontal word, the clue number will be
followed with an a. For a vertical word, the clue number will be followed with a d.

You may select a word by typing the clue number into the dialog box. If you wish to specify a
direction, follow the number with either a or d. If there is only one direction available with the
entered clue number, then the word in that direction will be selected. If you do not specify a
direction and both directions are available for the entered clue number, then the horizontal
word will be selected.

Editing clues
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To view or edit the clues, choose Show Across Clues or Show Down Clues in the Clue menu. A
window will be displayed containing the clues of the direction selected. If a word of the same
direction was selected in the puzzle, then the corresponding clue will be selected.

Otherwise, the first clue in the window will be highlighted.

Clues are edited just as with any normal text editing program. Just select the text you wish to
edit or the point at which you wish to edit and make the changes you wish to make.

When you click the mouse over the numbers in the left side of the clue window, the whole
clue text will be selected. When you click the mouse in the right side of the clue window, the
cursor will be placed at the point of the click.

Each clue can be a maximum of 30 characters. (I will enlarge that in the future.)

As with the puzzle, several non-alphanumeric keys perform special functions.

Clear Deletes any text currently in the clue.

Return Selects the next clue in the list.

Shift-Return  Selects the previous clue in the list.

Tab Selects the next clue in the list.

Shift-Tab Selects the previous clue in the list.

Right-Arrow  Moves the caret one character to the right.

Left-Arrow Moves the caret one character to the left.

Down-Arrow Selects the next clue in the list.
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Up-Arrow Selects the previous clue in the list.

Selecting a clue also causes the selected word in the puzzle to change. Likewise, selecting
a different word in the puzzle also causes the currently selected clue to change.

Switching windows

Choosing Switch Window in the Puzzle menu causes the next window counter-clockwise to be
activated.
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Thank You

Thank you for using CrossMaster. A lot of time and effort were put into this program, and |
hope that it will help others as it will help me.

Version 0.1 of this program was released in March 1987. | had hoped to have version 0.2
completed in June 1987, but the task of clue management was a little larger than | had
anticipated. However, the late nights and manual study paid off.

| am quite pleased with the way in which CrossMaster is turning out. To be honest, the first
time | used version 0.2 to solve my newspaper's Sunday crossword the time | spent was cut
by at least 65%. Being able to select a word in the puzzle and have the clue for the word
appear highlighted on the screen literally saved hours that | would normally have spent clue
searching.

You are certainly free (actually you are encouraged) to make or distribute as many copies of
this program as you wish. My only conditions are that you include these instructions along
with the program, that neither the program nor these instructions be modified in any way, and
that you receive no payment or compensation for providing another person with this program
or its documentation.

Should CrossMaster become a permanent part of your software library, it is up to you to
support it. Version 0.2 is public domain or freeware, but version 1.0 will not be. | am asking
only $20 (small considering how much time it saves even if you only work with the weekend
crossword puzzle in your newspaper) to be a registered user. As a registered user, you will
be notified when newer versions are available. When version 1.0 is released, you will be
able to receive it for free. | am not sure of the price | will use, but | am told that a program
like this could be quite valuable. If registration support is strong enough, | would like to
release version 1.0 as shareware.

Once again, thanks. Please enjoy my program. I've had a lot of fun with it, and | hope you
will too.
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