
Getting Started FastTrack Schedule™

Welcome to FastTrack Schedule™

Welcome to FastTrack Schedule's "Getting Started Demo."  We have received a 
number of requests for a brief on-screen guide* through the initial start-up process of 
creating a schedule, and have included the following tutorial to offer that information.  
This is meant to be an on-screen tutorial to use as you learn to create your own 
schedules.  

Please take about 10 minutes to experiment with the tutorial.  Keep in mind that the 
manuals that accompany the program offer a complete guide to the many features that 
enable you to create, edit and enhance your schedules.  

Five example schedules have been included on this disk to show how schedules can be 
enhanced with graphics, text blocks, customized bar and milestone types, labels, and 
dates.  Look over these schedules to see the great versatility of the FastTrack Schedule 
program.  

FastTrack Schedule™  allows you to quickly and easily create and update Gantt Chart 
Schedules.  It offers a behind-the-scenes database that actually keeps track of the 
dates that your activity bars represent.  If you wish to change your schedule from a 
format of weeks to months, the program will scale all of your activities to the new format. 
You may also transfer data back and forth between other programs as ASCII Text 
making FastTrack Schedule a Gantt Chart Generator for other programs, like 
MacProject ™, or a front-end to other programs.  It also includes an outline-type level 
structure to show major phases versus sub-activities.

* You should be familiar with the basic operations of the Apple® Macintosh® computer.  You should 
know how to use windows, scroll bars and pull down menus and be able to cut, copy and paste text 
edit selections or graphics.  If you need to learn these basics, see the Macintosh manual that came 
with your system.
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To illustrate how easy it is to create presentation quality schedules, work through the 
following steps.

Step 1:  Double click the FastTrack Schedule icon.

Step 2:  After the program has loaded, Select New Schedule … from the File Menu.

Select New 
Schedule …  
from the 
File  Menu
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A schedule will appear with a format in weeks, starting with the previous month.  Of 
course, at any time, you can change the scale units, the range of the schedule and 
other information associated with the overall schedule.

Default 
format is  
weeks

To do this, Select Schedule Data … from the Options Menu to change any of these 
parameters.

Select Schedule 
Data …  from the 
Options Menu
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In this demo, a generic schedule will be created that includes major phases (Phase 1, 
Phase 2, and Phase 3) with sub-activities (Activity 1, Activity 2, and Activity 3), and 
formatted Start and Finish Date columns.

Step 3:  Add two additional columns by holding down the Option Key and clicking  
twice to the right of the Activities column.

Hold down 
the Option 
Key and 
click

Additional columns will be added wherever you click.

Additional 
columns 
added
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Step 4:  Format these columns as Start and Finish Date columns by double clicking 
in the column heading.  

Format 
these 
columns by 
double 
clicking in 
the 
column's 
heading

You will be presented with a Column Data window that allows you to format the 
columns.

Name the 
column and 
format it 
as either a 
Start Date 
or Finish 
Date 
column
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Step 5:  Enter text in the Activities column:  Phase 1, Phase 2, and Phase 3. 

Step 6:  To draw bars for these Phases, you will need the Tool Box.  Use Command T 
to open the Tool Box or select it from the Options Menu.  

Select 
Show Tool 
Box  from 
the Options  
Menu
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Choose the drawing tool and the bar you would like to appear.  

Select the 
drawing 
tool and 
the bar 
type

Draw bars of approximately 4 weeks next to all three activities.  You will be setting 
guidelines for each phase's duration.  

Draw bars of 
approximately 
4 weeks in 
length

Dates are 
automatica lly 
entered in the 
formatted 
date columns
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Typically, these phases would be made up of sub-activities, so insert spaces for the next 
level of activities.  Hold down the Option Key and click to insert spaces.

Hold down 
the Option 
Key and 
click to 
insert 
spaces

Insert three spaces under Phase 1, Phase 2 and Phase 3.

Insert 3 
spaces 
under each  
phase
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Step 7:  Tab over to create a second level.  Enter Activity 1, Activity 2, and Activity 
3.

Enter 
Activity 1, 
Activity 2, 
and 
Activity 3

Step 8:  Using the guidelines set, estimate approximately how much time is needed for 
the completion of each activity.  Draw 3 bars that will fit between the start and finish 
of the first phase bar.
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Step 9:  To save time, copy all of the sub-activities and insert them beneath the 
remaining phases.  Hold down the Command Key and drag the cursor down the 
activity column until all three activities are selected.  

Hold down 
the 
Command 
Key and 
drag the 
cursor 
down the 
activities

Use Command C to Copy the rows.  Select the 3 spaces beneath Phase 2 and 
paste the copy.  Do the same with the 3 spaces beneath Phase 3.
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Step 10:  Next, create a temporary link between the three activities in both Phase 2 and 
Phase 3 and adjust the bars to fit into the Phase time constraints.  

To do this, select the Arrow Tool and drag a box around the three activity bars.  

Using the 
Arrow 
Tool, drag 
a box 
around the 
three bars

Drag the top bar to the right until its start point is directly below the phase start point.  

Drag the 
top bar 
until it is 
under the 
start point 
of Phase 2
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All three bars will automatically shift to the new position.

Do the same thing for the Activities in Phase 3.
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Now delete the guideline bars for the major phases.  Use the Arrow Tool to select the 
bars and delete with the Backspace or Delete Key.

Delete the 
guideline 
bars for 
each major 
phase

At times you may only want to look at the major phases of your schedule.  FastTrack 
Schedule allows you to collapse sub-level activities so that you may view only the 
higher level information.  

Step 11:  To collapse an activity, place the cursor to the right of the activity 
column and click.  

Place the 
cursor to 
the right 
of the 
activity 
and click
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The sub-level activities will be hidden from view.

All three 
major 
phases 
have 
been 
collapsed

To view the sub-level activities again, place the cursor in the same position and click.

Step 12:  You may add labels to some of the activities to enhance your schedule.  
Select the Text Tool from the Tool Box.

Select 
the Text 
Tool
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Click in the first activity row to create a text block.

With the 
Text Tool, 
click next to 
the first 
activity to 
create a 
text block

Type in "Concepts" in the text block.
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Select the Arrow Tool from the Tool Box, click on the block you just created and 
size (by grabbing the lower right handle) until the block is a good size.

Select the 
Arrow Tool, 
click on the 
block and 
size it

Step 13:  A status report can also be placed within the schedule.  Place the cursor at 
one of the activity grid lines.  The cursor will change to allow you to expand the grid 
line.

Drag 
down to 
expand 
activity 
area
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Drag one of the activity cell grids down to expand the activity area.

Select the Text Tool, click in the activity area to create a text block and Type in 
"Meeting with Graphics Dept to discuss additions to design."

Select the 
Text Tool, 
click in the 
activity and 
type

FastTrack Schedule™ Getting Started



Getting Started FastTrack Schedule™
Drag and resize the box to place it within the activity area.  Hold down the Caps 
Lock Key to move it to the schedule area or back to the activity area.

With the 
Arrow Tool, 
select the 
text block  
to resize and 
position it

The text block can be enhanced with borders and shadows.  To do this, you would go to 
Item Border under the Options Menu.

Step 14:  A schedule can also be enhanced with graphics.  Open the Scrapbook, 
select any graphic and copy it.  Go back into FastTrack Schedule and paste the 
graphic on the schedule.
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Step 15:  You may also design your own bar and milestone types to create different 
effects.  Double click on an empty bar cell in the Tool Box.

Double click 
on an empty 
bar cell in 
the Tool Box

The Bar Setup window will appear.  The Bar Setup window is where you can define all 
aspects of each bar or milestone type.  
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Select the Start Point area.  Choose an existing point type; fill the point with color  
and/or a pattern.  Repeat with the End Point and the bar if desired.  Clicking OK 
will automatically include the new bar type in the Tool Box.

You can change any of the bar types on your schedule by selecting the bars and 
clicking on a new bar type.  In the following example, two of the bar types were changed 
in the demo schedule.
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You can also customize bar and milestone types.  In addition, you can choose to have 
the date displayed on the bars or milestones.  See examples of various bars and 
milestones in the Example Schedules included on this demo disk.

Now that you have created a schedule, you have the ability to view it in a number of 
different ways.  For instance, if you want to see this project schedule in months vs. 
weeks, you can easily change the scale.  

Step 16:  To change the scale, select Schedule Data … from the File Menu and click  
Months.  Click OK to return to the schedule.

Click Months 
to change the 
scale of the 
schedule
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You can stretch out the scales and the bars automatically conform to the new scale.  
Place the cursor over the second vertical grid within the top date scale until the 
cursor changes to a cross hair with arrows pointing to the left and right.

Place the 
cursor 
over the 
second 
vertical 
grid to 
expand 
the scale

Drag the cursor to make the scale larger or smaller—in this case, drag to make the 
scale larger.
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Step 17:  FastTrack Schedule also offers an extensive Page Preview.  Select Preview 
… from the File Menu.

Select Page 
Preview … 
from the 
File  Menu
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Page Preview not only lets you see what your schedule will look like on paper, it is 
actually a second layer that allows you to place titles, notes, graphics, page numbers 
and dates.

Select the Text Tool and click to create a text block in the in the upper right hand 
corner.

Select the 
Text Tool 
and create 
a text 
block in 
the upper 
right 
corner
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Type "My Project Schedule".  You can change the font, style, and size.  Zoom out by 
holding down the Command Key and clicking.
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Step 18:  In the Page Options window, the schedule can be arranged in different ways.  
For instance, you have the option of deleting the unused grids at the bottom of your 
schedule. 

Select Page Options … from the File Menu and deselect "Fill Page."

Select Page 
Options … 
from the 
File  Menu
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Page Preview will show the schedule as it then appears.

From the Page Options window, you can also:
• Manipulate margins and alignment.
• Change between standard and wall chart layout
• Choose a variety of additional options such as:

–Print back to front
–Scales on every page
–Break page at activities
–Activities on every page
–Break page at columns
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You can use the extra space on the page to add additional text information or graphics 
to the schedule.  For example, you may wish to add notes concerning the project or 
additional graphics to enhance the schedule.  

Text blocks, 
enhanced with 
borders and 
shadows (and 
color), have 
been added to 
the schedule 

Graphic 
enhancements

In summary, FastTrack Schedule's flexibility gives you the power to take project 
activities and organize them in multiple levels, design custom bar and milestones, place 
labels and text where appropriate and enhance presentation further by adding a second 
layer for titles, graphics, and status reports!
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Thank you for ordering the FastTrack Schedule Demo Disk.  We hope you will enjoy 
using it.  If you have any questions or wish to purchase the program, call (703) 450-
1980 or (800) 346-9413.  Again, we hope you enjoy the program.
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