
Apple File Exchange Intro

Quick Summary
Apple File Exchange is a free utility program, included with your system software, that allows 

the Mac user to move the contents from a DOS or Apple II (ProDos) disk to the Mac desktop (or to 
other folder locations within the Mac.) It is used with Apple’s SuperDrive floppy drive. That’s the 
floppy drive that can read high-density 1.4 Meg floppy disks as well as 800K disks (SE30 and later 
models of the Mac.) The Apple File Exchange interface (the “look” of the application’s windows and 
menus) has a large window containing two window panels for the “from” and “to” locations. It’s 
somewhat slow due to the number of steps needed to translate files from DOS to Mac but it’s free 
and it does the job.

There are commercial applications to mount a DOS floppy itself on the desktop giving it an icon 
which allows direct access to the files. If you work with DOS-to-Mac regularly consider these 
programs for the speed gains. (Apple’s PC Exchange, Dayna’s DOS Mounter and Insignia’s Access 
PC. )

In this document I’ll explain how to use Apple File Exchange to format a DOS disk, read a DOS 
disk and transfer its files for use on the Mac in a compatible application. I’ll give a quick tour for 
surviving on a DOS machine and I’ll use Pascal and WordPerfect files as examples of translating 
from Mac to DOS.

Tips on working with two ,or 
more, applications in System 7 

The Mac desktop, also called the Finder, is shown as active by a little Mac icon in the top right 
of the menu bar in System 7. As you read this document the icon showing in this application menu 
will be your word processing application. Pointing to this application icon with the mouse as you 
press and hold the button will cause a menu of open applications to drop down . There should be at 
least two—this application and the Finder or At Ease, a Finder substitute sold with the Performa 
line of Apple computers. There may also be other applications open. If you see an application you 
know you are not using drag the mouse cursor down until it is highlighted and release the button. 
This puts you in that application with no documents open. Choose Quit from the File menu. This 
will quit the application and return you to this document and application. This will help avoid the 
“Not enough memory” messages. (Note: there may be a screen saver, like DarkSide,    running in 
the background. Leave this one running.)

I mention this because System 7 allows you to have several applications open at the same time 
allowing you to switch between/among them. You may want to have this document available as you 
work with Apple File Exchange. You can choose Hide <<name of application>>, if working from 
the Finder. It will show At Ease if you launched the application from At Ease. You’ll need to open At 
Ease. You can then find and open Apple File Exchange and both will be running. You can use this 
application menu to switch back and forth.



Using Apple File Exchange

Finding the application
I have Apple File Exchange in a “utilities” folder. Yours may be located elsewhere, including the 

System Folder or its own folder. It can be found in System 7 by choosing Find… in the File menu 
from the Mac desktop and typing in the word exchange    before clicking the Find button. You can 
also access the Find… dialog box by pressing the key sequence Command-F. (The Command key 
has an open apple icon and a quadrille or “cloverleaf” symbol. It’s next to the spacebar.) If 
something other than the application comes up—this document, for example—choose Find Again 
from the File menu or press Command-G. Continue pressing Command-G, or choosing Find Again 
in the File menu, until the application appears or a beep sounds indicating no more items. If it isn’t 
found it needs to be installed on your hard drive.

Utilities folder showing Apple File Exchange and translators. 

(Note: the DD on these files is for Disk Doubler, a compression utility to gain space on the hard 
drive. Auto Doubler uses it to compress and decompress automatically.)

If you insert a DOS disk or a new, blank disk into the Mac the following Alert box will appear:

Non-Mac disk Alert box.

If you want to use this disk as a Mac disk choose Initialize. This will set up a Macintosh file 
directory. If you know it contains DOS files or want to use it on a DOS machine choose Eject. 
(Another option is that it is a Mac disk with problems. Eject it and use recovery utilities or see a 
friend with utilities to regain your data before copying    the files to a newly formatted disk.)

If it is a DOS disk or you want to format it for use in a PC launch Apple File Exchange and then 
insert the disk. If it is blank (or is a Mac disk with problems—see above) you will be greeted with the 
following screen:



Blank disk Alert box.

Notice that you have the option of formatting it as a DOS disk. I have selected that choice 
above. I would then select the Initialize button to format it.

==================================================================
A Quick Intro to DOS

DOS Naming conventions
DOS allows 11 characters for the name of a disk (its label.) A space is a legal character in a 

label. The names of directories (comparable to folders on the Mac) and files can only have eight or 
fewer characters and NO spaces. Files can also have a period followed by a three character 
extension. Names are shown in all capital letters on a PC. Ex. PJC DISK (a disk label), MC3FILES 
(a directory), CIRCLES.PAS (a Pascal file.) I can add numerals after that last name to denote 
different versions of a current working file. Note that adding the numeral makes the name eight 
characters. You will need to get creative with your abbreviations. You can enter the name in lower 
case letters. DOS will change it.

A VERY Basic DOS Primer
Since DOS seems to be everywhere you’ll probably have to deal with it at some point. This is 

especially true if you are studying programming with Pascal. (Although there is a more modest 
educational version of THINK Pascal from Symantec called Macintosh Pascal.) It is also true of 
electronic bulletin boards (BBSs) accessible with a modem that knowledge of DOS is helpful. A 
book recommended to me for survival in DOS is DOS For Dummies by Dan Gookin (IDG Books.) I 
highly recommend it as very readable. 

If Windows is running follow the instruction windows, if any, and double-click on something you 
want to open. If a window shrinks to postage stamp size double-click to resize it. In Windows Turbo 
Pascal has an icon similar to the Mac. Close and Zoom boxes on the Mac are replaced by minus 
signs and arrows, respectively. There is no equivalent to the Apple or application menus and most 
things aren’t as familiar or intuitive as the Mac.

If you start in DOS (nearly blank screen and typed commands) you will see the C-prompt (C> or 
C:\>) . This is the “root directory” similar to your Mac’s main hard drive window. To change drives 
(i.e. read your disk in the floppy drive A) type the drive letter and a colon after the current drive 
prompt (C>a:). You’re drive may also be designated the “b:” drive if there is a 5-1/4” floppy drive as 
the A drive on the machine. The hard drive is usually divided between “c:” and “d:” (Changing back 
to the hard drive from the A drive is A:\>c: ) You can tell if you are in a subdirectory if the C-prompt 
(or A-prompt) is followed by “back-slashes”    and names (see next paragraph.)

You can list the files in a directory with the command “dir” This gives size, date and other 
characteristics of the files. Listing file name and extensions only is done with the command “dir/w” 
The “/w”    is a “switch” to show the names in wide format. A directory name will have brackets 
around it. Ex: [MC3FILES] Typing cd mc3files at the prompt followed by a <Return> will put you in 



that directory (A:\MC3FILES>). Typing a file name and <Return> might launch the appropriate 
application and open the file if it is in that directory. It does in WordPerfect ( Ex: C:
\WP\WP51>CVRLTR.WP) and Turbo Pascal.

The extensions added to file names usually tell their function or creator.

Ex: LETTER.WP (WordPerfect file)
LETTER.BK (WordPerfect backs up automatically. This is that file.)
CIRCLES2.PAS (Turbo Pascal file)
EMPINFO.TXT (ASCII text file)
XXXX.COM (System command file)
WP.EXE (program execution file. This one will start WordPerfect.)
CONFIG.SYS (system configuration file.)
AUTOEXEC.BAT (a series of command files run as a batch on startup.)

If you are lost deep in subdirectories you can jump to the top by typing cd\ (back-slash) to get 
to the root directory (top level.) Now, aren’t you glad you have a Mac?

==================================================================



Working in the Apple File
Exchange Windows

Moving Files
Now that you have a formatted and named DOS disk created in AFE, or have inserted    a DOS 

disk after launching the program, it will appear in AFE’s main window which is shown on the right 
below:

Main AFE window with source drive and destination drive windows. 

To move up a level in the windows above you would point to the window label (Ex: 
programming    above the left panel) with the mouse as you press and hold the button. This will 
cause a menu of higher level folders to drop down. Drag to the folder you want and release the 
mouse button to move to that level. You can try something similar now by choosing Save As… 
under the File menu and holding the mouse button down on the label above the window panel. 
Choose the Cancel button to dismiss the window. (See the next to last illustration in this document 
for the Save As… window.)

In the window above PJC DISK is my DOS formatted floppy disk with Pascal files and a 
subdirectory MC3FILES    (shown as a folder). Programming is a folder on my hard drive Macintosh 
HD. I have created a new folder called DOS transfer files for incoming and outgoing files (see New 
Folder button.)



In DOS if you haven’t saved files to a particular directory you need to copy them from the 
current directory to the desired directory using the proper command and path i.e copy <<name of 
file (in current dir.)(to)new directory(new name-optional)>> (Ex: A:\>copy circles.pas \mc3files) 
Note: that is a space after the command copy as well as after filename (before the backslash.) 
Then you can delete them from the previous directory. Similar rules apply in AFE but the files need 
to be moved twice. I moved the above Pascal files to the transfer folder on my hard drive by 
selecting that folder as shown above and clicking on the Open button below the window. I then 
moved the files from floppy window after highlighting them by shift-selecting (select one, press Shift 
and select others) and using the Translate button. I then deleted the files showing at the same level 
as the MC3FILES directory on the floppy using the Remove button and answering Yes to the Alert 
window that followed. Don’t select    the directory to translate or delete (Ex: MC3FILES.)

I then selected and opened the MC3FILES folder and moved the files residing in the hard drive 
transfer folder to that window with Translate. (These actions would leave only MC3FILES in the 
right window above the next time you insert your disk.)

AFE translation progress window.

Opening And Working With
Translated DOS files

I can use the translated DOS files by opening a compatible application, THINK Pascal, and 
opening a file from the DOS transfer files  folder. In THINK Pascal the steps would be: 1)Launch 
THINK Pascal which shows a standard Open dialog box, 2) Choose the check box Instant Project, 



name the new project and press the Create button, 3)choose Add File… from the Project menu 
selecting the transferred file and 4)select the project files window (ends in .¹) and highlight the name 
of the template window (ends in .p and has “enter your declarations here,” etc.) and select Remove 
in the Project menu. The project is now ready to Check Syntax, Compile, Run, etc.

Going From Mac to DOS
As a matter of course, before I close a project or quit the program, I generally choose Remove 

Objects (the object code created by the compiler. In DOS it’s the separate (filename).EXE file.) 
This command is located in the Project menu . This results in smaller files (source code only) on 
my hard disk. After quitting I return to my programming folder where I have the items listed By 
Name (set in View menu in Finder.) If I hold the Option key and drag the source code file (ends 
in .p) to the DOS transfer files folder it will add a copy of that file to the folder without the word 
“copy” after the name which is what you get from Duplicate in the File menu. After checking for the 
8-character DOS name limitation I can open AFE and insert my DOS disk and open the MC3FILES 
folder and translate it. I can then quit AFE and head to class.

What About Other File Types?

Using Save As to change a word processing file to a DOS compatible format.

If you are moving a word processing file, for example, you need to use Save As… in the File 
menu in that application and select a compatible PC format in the drop down menu under the listing 
window. As an example I have saved this file in WordPerfect PC 4.2 format. I abbreviated the 
name to DOS convention and I’m ready to move it with Apple File Exchange.

The same is true of a Microsoft Excel Mac file. You can save it in WK1 format which Lotus 1-2-3 
can open.

Conclusion
I hope you have found this information useful. There are other features of Apple File Exchange 

that you can read about by choosing About Apple File Exchange in the Apple menu (top left of 
your screen.) You can then highlight a list topic you want to explore and select the About button on 
the right to learn more. I have used the default translations each time I have used it. These retain 
format settings. The other option is usually a plain text translation.



About Apple File Exchange window.

Created in ClarisWorks from System 7 screenshots (Command-Shift-3) cut and pasted with 
selection rectangle from TeachText 7.0 which opens “Picture 1” screenshot.
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