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Chapter 1 - Introduction

 

�  

 

Welcome to Microspot MacDraft Personal Edition

 

This User Guide has information about the features and capabilities of Microspot 
MacDraft Personal Edition. It is laid out to let you refer directly to a particular feature and 
obtain detailed instructions about its use.

Before you proceed you should be comfortable with terms such as click, drag, select and 
choose. You should also be familiar with the general methods used in most Macintosh

 

® 

 

applications such as moving, resizing and scrolling a window. If you are not, refer to your 
Macintosh owner’s guide.

 

Hardware and software requirements

 

• Macintosh System Mac OS X (10.1 recommended)

• Any Macintosh computer (including iMacs and iBooks) with G3-233 MHz 
processor or faster

• 128 MB RAM

• CD-ROM (to install).

 

Installing Microspot MacDraft Personal Edition

 

You must run MacDraft from your hard disk.

 

To install Microspot MacDraft

 

1. Insert the MacDraft CD into the CD drive.

2. Double-click the MacDraft Installer.

3. Follow the instructions that appear.

The MacDraft software and its supplemental files will be installed where you 
specify on your hard disk.

 

Starting Microspot MacDraft Personal Edition

 

The first time you launch MacDraft you must enter a name and valid serial number to 
enable the software.
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To enable Microspot MacDraft

 

1. Double-click the MacDraft application icon to launch the software.

2. Enter a name and valid serial number (the organization name is optional) into the 
dialog that appears.

3. The serial number must be valid for the version you are using. This will be 
supplied with the program or upgrade when purchased.

4. Only when you have typed in your serial number, the 

 

OK

 

 button becomes 
available. Click it to open the application.

If you click the 

 

Cancel

 

 button, the application will run in demo mode and some of 
the features and menu options will be dimmed.

 

�  

 

The Help menu

 

The 

 

Help

 

 menu is used to open the MacDraft manual, product registration and upgrade 
information.
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Microspot MacDraft manual

 

The MacDraft

 

 

 

Manual in pdf format will be included on disk with the application and 
Adobe

 

™

 

 Acrobat

 

™ Reader. The manual will be installed on your hard drive during the 
installation process.

Choose MacDraft Manual from the Help menu and Acrobat Reader will launch and open 
the manual. You can then navigate through and read the manual on screen or print 
sections for your reference.

Registration information
You can register MacDraft by filling in and returning the registration card included in the 
product box.

Alternatively you can register your product via the Internet.

To register via the Internet

1. Choose Registration Information from the Help menu.

The following dialog appears.

2. Click the Connect button to direct your web browser to go to the Microspot 
product registration web page, then follow the registration instructions.

Once you have registered MacDraft, Microspot will be able to send you 
information about upgrades and new products. Alternatively, contact Microspot 
via telephone, fax or email.
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Upgrade information
You can also obtain information (if any) about upgrades from the MacDraft web page by 
choosing Upgrade Information from the Help menu.

�  Document handling

MacDraft allows you to have up to 16 documents open at the same time. You can open 
documents from the desktop or from within the application. See Appendix C - File formats 
on page C-1 for information about opening and saving documents in different formats.

Creating a new document

To open a new document when launching Microspot MacDraft

• When you launch MacDraft, the application automatically opens with a new 
document.

To open a new document when Microspot MacDraft is already running

• Choose Drawing from the New submenu in the File menu.

NOTE: If the application is already running, but no documents are open, double-clicking 
the application icon opens a new document.

Opening an existing document
Existing documents can be opened from the Finder or from MacDraft’s File menu.
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Opening a document from the Finder

To open an existing document from the Finder

• In the Finder, locate the document you want to open and double-click it.

NOTE: If a document is already open, double-clicking its name in the Finder 
brings that document window to the front.

Opening a document from the File menu
You can open a document from the File menu, even if you already have another document 
open.

To open a document from the File menu

1. Choose Open from the File menu.

The standard open dialog appears. Locate the document you want to open and 
either double-click its name or click once its name and then click the Open button.

2. To show only files of a particular type, select the desired type from the Show pop-
up menu.
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�  The Microspot MacDraft environment

The document window
The MacDraft document window allows you to access your document for viewing, 
creating and editing the drawing area. It is designed to offer you a drawing area with all 
of the essential features of MacDraft within easy reach of your mouse.

When you open the MacDraft application, the following screen appears.

Fill and line indicators
The two small boxes in the lower left corner of the window are the Fill and Line Indicator 
boxes.

• The Fill Indicator shows the color, shade of gray, or pattern that will be used to fill 
the objects you draw.

• The Line Indicator shows line weight that will be used to draw lines and object 
borders.

See The fill and line indicator boxes on page 3-2 for more information.

Fill indicator box Line indicator box
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The drawing area
The drawing area is the part of the window that shows dotted line divisions. These 
divisions are called grid lines. In English units, the distance between the grid lines 
represents one inch; in decimal feet, one tenth of a foot; and in metric units, two 
centimeters. You can use the grid lines as visual aids to assist you in your drawing (see 
Grid lines on page 6-18).

When you create a new document, MacDraft shows a document based on a single sheet of 
paper for the current output device. 

NOTE: As MacDraft Personal Edition has a limited drawing size, if you have a printer that 
can print to large paper sizes, the drawing size may not be as great as a single page.

You can change the size of your document at any time to include multiple pages (up to the 
drawing size limit), allowing you to create larger drawings (see Changing the drawing size 
on page 1-22).

When you first open your document, you will see only the upper left corner of the total 
drawing area.

The menu bar
The menu bar across the top of the screen contains all the MacDraft pull-down menus 
available.

As with most Apple Macintosh applications, clicking a title in the menu bar gives a drop-
down list of the options available (see File menu on page A-1).

Using hierarchical menus
MacDraft uses hierarchical menus. These submenus list further options available. For 
example, the Border Position submenu in the Options menu lists the possible positions 
for object borders (see Border positions on page 3-38).

A rightward pointing triangle beside a menu item indicates that more options relating to 
that menu item are available.
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To choose an option from a submenu

1. Choose the menu item that contains the submenu you want to access.

2. Drag horizontally across and down the submenu until the item you want is 
highlighted, then click the desired item.

Using keyboard command equivalents
Certain menu items can be chosen directly from the keyboard. The Command key symbol 
and a keyboard character appear beside menu items that can be chosen from the 
keyboard.

Choose these menu items by holding down the Command key, then pressing the relevant 
character key on the keyboard. For example, to choose Duplicate (from the Edit menu), 
hold down the Command key and press D (uppercase or lowercase). The Edit menu is 
highlighted for a moment, and a duplicate of the selected object appears (see Appendix B - 
Special usage of keys on page B-1).

The palettes
MacDraft’s most important tools appear in three floating palettes: The Tool Palette and 
the Dimension Palette. The Attribute, Resize and Alignment palettes control various 
attributes of the objects created using the other palettes.

The palettes are called floating palettes because they can be moved around the screen, and 
they float above the drawing area, allowing you to draw beneath them.

Tool palette

Dimensions
palette

Attributes
palette

Resize paletteAlignment palette
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Using palettes

Displaying a palette

To display a palette

• Choose the palette’s name from the Window menu, or

• Choose the palette’s name from the pop-up menu at the bottom left of the 
document window.

The palette appears, and a checkmark appears against its name in the list. 
Checkmarks appear beside the names of palettes that are currently displayed.

Hiding a palette

You can hide a palette when you no longer need it.

To hide a palette

• Click the palette’s close box in the top left corner the palette window, or

• Choose the palette’s name from the Window menu, or

• Choose the palette’s name from the pop-up menu at the bottom left of the 
document window.

The palette disappears, and the checkmark beside the palette’s name in the list will 
be removed.

Moving a palette

You can move a palette around the screen to place it in a more convenient position.
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To move a palette

1. Position the cursor on the top or left part of the palette, or any other part that 
doesn’t hold an icon, and hold down the mouse button.

The cursor will change into a four headed arrow, indicating that the palette can be 
moved in any direction.

2. Drag the palette to the desired location and release the mouse button.

Using the palette tools

The palettes function like boxes of tools that you can use to enter text, draw different 
objects and lines, and change objects. Each tool is represented by an icon in a palette. To 
use a tool, you activate, or select, the appropriate icon.

You can activate any tool in a palette by positioning the pointer on the icon and clicking it. 
As long as the icon is highlighted, you can draw the object or perform the action 
associated with the icon.

When you start to use MacDraft, each tool has the default current option shown in the 
palette. To change the current option for a tool, choose the desired option from a pop-up 
menu that shows the options available.

Pop-up menus

Each palette holds icons that represent certain tools or functions. Some tools and functions 
have more than one option associated with them. These options relate either to how the 
objects are created or to different characteristics of the objects. For example, in the Tool 
palette the square-corner rectangle options relate to how you create a rectangle; either 
from a corner or from its center. On the other hand, the rounded-corner rectangle options 
relate to the characteristics of the rectangles’ corners; proportional, constant, or elliptical.

The options for each function and tool can be selected from pop-up menus.

Icons used to open pop-up menus have clipped corners (which appear black). Unlike pull-
down menus, which are opened by clicking a word in the menu bar, pop-up menus are 
opened by clicking an icon in the palette and holding down the mouse button.

To choose an option from a pop-up menu

1. Click the appropriate icon in the palette and hold down the mouse button.

A pop-up menu appears.
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2. Holding down the mouse button, drag to the menu item that represents the 
desired option.

As you drag, the menu items will be highlighted.

3. When the desired menu item is highlighted, release the mouse button.

The pop-up menu disappears and the tool icon will be changed to show you the 
currently selected option.

Tool options

Some tools have options associated with them. These can be displayed by holding down 
the Option key and clicking the tool icon, or by selecting the tool and choosing Tool 
Options from the Options menu. See details of individual tools for information about any 
options available.
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The Microspot MacDraft palettes
Following are brief descriptions of the tools available on the Tool, Accessory and 
Dimension palettes.

Tool palette

Pointer tool

Use to move and change the shape of objects, make menu choices and activate palette 
functions.

Rotation tool

Use to rotate a selected object freely (see Rotate tool and Rotate command on page 5-34).

Selection tool

Use to select objects by drawing a selection rectangle around them (see Selecting multiple 
objects on page 1-27).

Hand tool

Use to change the position of a drawing as an alternative to using the scroll bars (see 
Changing the position of the drawing in the document window on page 2-97).

Line tool

Use to draw straight lines at any angle (unconstrained lines) or lines that are restricted to a 
certain angle (constrained lines) (see Drawing basic lines on page 2-4).

Rotation tool

Hand tool

Special line tool

Text tool

Rounded-corner
rectangle tool
Arc tool

Freehand tool

Marker symbol tool

Attribute tool

1:1 tool

Pointer tool

Selection tool

Line tool
Square-corner
rectangle tool

Regular polygon tool

Circle tool

Polygon tool

Parallel line tool

Zoom tool

 
90˚ rotation tool
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Special line tool

Use to draw lines that are perpendicular to, tangent to or offset from some other object, or 
lines that start at the mid, end or center point of an existing object (see Drawing special lines 
on page 2-46).

Square-corner rectangle tool

Use to draw squares and rectangles with square corners (see Square-corner rectangles on 
page 2-7).

Text tool

Use to add text to a drawing or edit existing text (see Text on page 4-1).

Regular polygon tool

Use to draw symmetrical objects with from 3 to 16 equal sides, such as triangles, 
hexagons, and octagons (see Drawing regular polygons on page 2-13).

Rounded-corner rectangle tool

Use to draw rounded-corner rectangles or squares (see Rounded-corner rectangles on page 2-
9).

Circle tool

Use to draw circles by diameter (D), by radius (R) or by three (3) points; and concentric 
circles (see Drawing circles on page 2-16).

Arc tool

Use to draw arcs by radius (R) or three points (3); elliptical arcs (E); and offset arcs (see 
Drawing arcs on page 2-24).

Polygon tool

Use to draw objects with two or more sides (see Drawing irregular polygons and polylines on 
page 2-33).

Freehand tool

Use to draw freehand lines and shapes, including Bezier and spline curves (see Drawing 
freehand lines, shapes and curves on page 2-37).

Parallel line tool

Use to draw parallel line figures (both single segments and open or closed parallel 
polygon figures) and extrudes pairs of lines from straight edges (see Drawing parallel line 
objects on page 2-55).

Marker symbol tool

Use to draw a standard marker symbol (see The Marker Symbol on page 2-68).
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90° rotation tool

Use to rotate selected objects by 90° (see Rotate by 90° tool on page 5-32).

Attribute tool

Use to copy and assign object attributes (see Copying attributes using the Attributes tool on 
page 3-41).

Zoom tool

Use to zoom in or out on areas of a drawing (see Zooming in or out on a drawing on page 2-
99).

1:1 tool

Select to return to a single magnification view of the current drawing area (see 1:1 tool on 
page 2-106).

Dimension palette

Horizontal dimension tool

Use to draw horizontal dimension lines (see Horizontal dimension objects on page 4-15).

Vertical dimension tool

Use to draw vertical dimension lines (see Vertical dimension objects on page 4-16).

Slope dimension tool

Use to draw sloped dimension lines (see Slope dimension objects on page 4-17).

Perpendicular dimension tool

Use to draw dimension lines perpendicular to straight lines and edges (see Perpendicular 
dimension objects on page 4-18).

Diameter dimension tool

Use to draw diameter dimension objects (see Diameter dimensions on page 4-20).

Horizontal dimension

Slope dimension

Diameter dimension

Circle center mark

Vertical dimension

Perpendicular dimension

Radial dimension

Angular dimension
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Radial dimension tool

Use to draw radial dimension objects (see Radius dimensions on page 4-19).

Circle center mark tool

Use to draw center mark for circles, arcs and ellipses (see Circle center marks on page 4-21).

Angular dimension tool

Use to draw angular dimension objects (see Angular dimension objects on page 4-22).

The Window menu
You can have up to 16 document files open at one time in MacDraft. The Window menu 
provides you with options for displaying multiple document windows and for moving 
easily to a particular open drawing.

Displaying multiple document windows

Tiling windows

If you want to see the contents of several document windows at the same time, you can 
choose to show all the windows on the screen at the same time by using the Tile 
command.

To tile windows

• Choose Tile Windows from the Window menu.
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The open documents will be reduced in size, if necessary, and displayed next to 
each other across and down the screen.

Stacking windows

If you want to keep the drawing windows open at a reasonable size, and be able to easily 
click a document to bring it to the front of the open documents, you can choose to stack 
the windows.

To stack windows

• Choose Stack Windows from the Window menu.
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The open documents will be displayed one above the other, and slightly offset 
from each other.

Switching to a particular open drawing

To switch to a different drawing or symbol library

1. Open the Window menu.
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At the bottom of the Window menu, all the open MacDraft documents will be 
shown, with the active (topmost) drawing indicated by a checkmark.

2. Select the name of the drawing you want to work on.
The drawing you choose becomes active and will be shown in front of the other 
document windows.

�  Getting started

MacDraft is a software tool that emulates a drafting board while giving you the 
advantages of creating and working with scaled images on a computer. You can easily 
make changes without physically erasing or discarding sheets of paper.

One of MacDraft’s greatest strengths as a drafting and design tool is the way it allows you 
to define your drawing environment. Using simple menu commands and palette choices, 
you can specify the default scale, drawing units and page setup you need for the drawing. 

The scaled environment automatically keeps track of the size and area of the objects you 
draw. You can display their dimensions using the Show Size feature (see Show Size on page 
6-1), the various dimension tools (see Dimension objects on page 4-13), or the on-screen 
rulers (see Rulers on page 6-8).

Setting the units
With MacDraft you can draw using either feet and inches (English) or metric units. 
MacDraft offers the most commonly used English and metric unit scales. Once you choose 
a unit system for your drawing you can define the scale you want to use.

To set the units for a drawing

1. Open the Layout menu and choose Set Scale/Units.
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The Document Scale & Units dialog appears.

2. Click the button beside English or Metric, depending on the type of units you want 
to use in the document.

Whether you use the English or Metric system, you can choose the basic units for 
the drawing: Decimal Inches, Decimal Feet & Inches, Decimal Feet, Fractional 
Inches or Fractional Feet & Inches in English drawings; Millimeters, Centimeters, 
Decimeters or Meters in metric drawings.

3. If necessary, change the units in the Units pop-up menu.

NOTES:
• In metric drawings, you can choose Hide Metric Units, which prevent the unit 
abbreviations (mm, cm and so on) from appearing when dimensions are displayed 
on the drawing.
• You can also control the number of places displayed behind the decimal point in 
both metric and English decimal drawings (see Document units and scale on page 6-
21).
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Setting the scale
Before starting a drawing, you need to determine the sizes of the objects and the paper 
you are going to use. For large drawings it is impractical to draw objects at their actual 
sizes; it is necessary to reduce them, yet still maintain their proper proportions.

A scale, the ratio of the object’s size on the drawing to its size in the real world, 
accomplishes this. For example, if you choose a scale ratio of one-quarter inch equals one 
foot (1/4” = 1’), a line drawn ten inches long on a drawing would represent a 40 foot line 
in the real world.

NOTE: When you paste an existing object into a drawing with a different scale, the size 
the object is drawn at will automatically adjust to conform to the scale of the new 
drawing.

To specify the default scale

1. Open the Layout menu and choose Set Scale/Units. The Document Scale & Units 
dialog appears.

2. Click the Default Scale pop-up menu. The Default Scale pop-up menu shows the 
scales available for the chosen unit system.

3. Select the scale you want.

The new scale will be displayed.
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4. Click the OK button to close the dialog and apply the changes.

Setting the drawing page size
You can set a drawing’s page size, page orientation and total size depending on your 
needs.

If necessary, you can create a drawing that will print over several sheets of paper, up to the 
drawing size limit of MacDraft Personal Edition.

The choice of page size is subject to the page sizes available with the currently active 
printer or printing device. For example, if the printer you’ve selected supports only letter-
size and legal-size paper, you cannot print to larger or smaller sheets (see Drawing layout 
on page 8-1).

To set your drawing’s page size and orientation

1. Choose Page Setup from the File menu.

The Page Setup dialog appears. 

2. Select the paper size you want for printing your drawing.

3. Select the page orientation (horizontal or vertical) you want for printing your 
drawing.

4. Click the OK button to close the dialog.

Your drawing will now have the desired page size and orientation assigned.

NOTE: As MacDraft Personal Edition has a limited drawing size, if your printer 
can print to large paper sizes, the drawing size may not be as great as a single 
page.
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Changing the drawing size
Open the Layout menu and choose Drawing Size. A dialog appears displaying the 
current total drawing size in the form of a block diagram.

This diagram represents the maximum drawing size available; each block represents a 
single page. The blocks that are darkened indicate the current drawing size. You can 
control the overall size and shape of the drawing by clicking in the diagram.

To change the drawing size

1. Click one of the page blocks and hold down the mouse button.

2. Drag until you have activated the number of page blocks required for the drawing 
size you want and release the mouse button.

3. Click the OK button to close the dialog.

The MacDraft drawing window generally shows only a portion of the overall drawing. 
Therefore, when you change the drawing size it might not be noticeable in the window 
until you zoom out or scroll to another area of the drawing (see Zooming in or out on a 
drawing on page 2-99).

Rulers and cursors
MacDraft’s on-screen rulers can help you draw and position objects in precise locations on 
your drawing. They appear along the top and left sides of the drawing window, and 
reflect the current position of the window during scrolling. At magnified views (zoomed 
in or out), they change size accordingly.
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The rulers are especially useful in conjunction with MacDraft’s crosshair drawing cursor. 
The crosshair cursor extends horizontally and vertically across the window, into the 
rulers, when a drawing tool is active.

Rulers
The rulers can show either on-screen sizes (standard rulers) or values that match the 
current scale and units. For example, on a 1/8” = 1' scale, the major scale ruler divisions 
will be in increments of eight (8 ft., 16 ft., and so on) (see Rulers on page 6-8).

To display Microspot MacDraft’s rulers

• Choose Show Rulers from the Layout menu.

The rulers will be displayed and a checkmark appears by the Show Rulers 
command in the Layout menu.

To display scale rulers (if Show Rulers is on)

• Choose Scale Rulers from the Layout menu.

To display standard rulers (if Show Rulers is on)

• Choose Standard Rulers from the Layout menu.

Cursors

To activate the crosshair cursor

• Choose Cross Cursor from the Options menu.

When a drawing tool is selected, the crosshair cursor appears. A checkmark 
appears by the Cross Cursor command in the Options menu.
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To activate the small cursor

• Choose Cross Cursor from the Options menu again.

The checkmark disappears from the Cross Cursor command in the Options menu. 
When a drawing tool is selected, the cursor appears as a small plus sign.

Starting a drawing
With these settings in place, you’re ready to start drawing. The settings you defined: units, 
scale, page setup, drawing size, rulers and drawing cursor remain active until you change 
them.

(For details on using MacDraft’s drawing tools see Chapter 2 - Creating and editing objects on 
page 2-1, Chapter 3 - Changing the appearance of objects on page 3-1, and Chapter 4 - Annotating 
your drawing on page 4-1.)

�  Selecting objects

You must always select an object before you can make any changes to it. Two fundamental 
principles of using MacDraft are as follows:

1. You select an item.

2. You choose what to do to the item you have selected. 

For example, if you want to change the pattern of an object, you first select it, then 
choose a menu command to change it.

You can select a single object which you want to change or (for some operations) you can 
select multiple objects in order to make the same change to each selected object 
simultaneously. 

Once you have selected an object, small black squares appear on its borders or at each end. 
These squares are called edit handles. For example, a selected rectangle will have eight 
edit handles; a selected line will have one handle at each end point. The following 
procedures will show you various ways of selecting objects on your drawing.

Activating the pointer mode
Before you can select an object on your drawing, you must first activate the pointer. The 
pointer is used to resize, edit and move objects on a drawing.
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Choosing the pointer

To choose the pointer

Position the cursor on the Pointer icon in the Tool palette and click it.

NOTE: When you move the cursor over the Tool palette, the cursor will 
temporarily turn into the arrow pointer to allow you to select a tool.

NOTE: You can also return to the pointer mode by clicking an unused area of the 
drawing (except when the Text tool is active).

Selecting an object

An object is anything that you have created, including rectangles, circles, lines, arcs,
freehand shapes and text.

To select an object

1. Return to the pointer mode by clicking the Pointer icon or by clicking a blank area 
of your drawing.

2. Position the tip of the pointer on the object and click.
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3. The object is selected and selection handles appear.

NOTE: To select a non-filled object, position the pointer exactly on the edge of the object.

Selecting hidden objects

To select an object hidden behind other objects

1. Position the pointer over the hidden object’s estimated location.

2. Double-click this place (once to select the front object and then once again to select 
the object hidden behind it).

3. You should now see the handles of the hidden object showing through the visible 
object.

Once the hidden object is selected, you can move it or choose Bring to Front from the 
Arrange menu to move it in front of other objects (see Moving objects backwards and forwards 
on page 5-21).
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Selecting multiple objects
Select multiple objects to make the same change to all the selected objects at the same 
time.

To select multiple objects using the Pointer

1. Select the first object by clicking it.

2. Press and hold down the Shift key.

3. Select additional objects by clicking them, then release the Shift key.

To select multiple objects using the Selection tools

1. Click the Inclusive Selection tool in the Tool palette.

2. Position the pointer above and to the left (for example) of the objects to be selected.

3. Holding down the mouse button, drag diagonally across until you have enclosed 
all the objects you want to select in a selection box and release the mouse button.
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NOTE: If you choose the Exclusive Selection tool and drag out a selection 
box to select multiple objects, all objects that the selection box touches will be 
selected, not just those that are completely enclosed.

Deselecting objects
You can use the Shift-click method to deselect selected objects. This capability allows you 
to exclude a specific object from a selection.

To deselect an object

1. Return to the pointer mode by clicking the Pointer tool.

2. Hold down the Shift key.

3. Click the object you want to deselect and release the Shift key.

The edit handles will no longer appear on the deselected object.

Select none
To deselect all selected objects, use the Select None command.

To select none

1. Hold down the Shift key.

The Select All command in the Edit menu will be changed to Select None.

2. Choose Select None from the Edit menu.

All objects in the document will be deselected.

Selecting all objects in a document

To select all objects in the document

• Open the Edit menu and choose Select All.

Notice that all objects and text in the document are selected. If you choose Select 
All while you are in the text mode and have an insertion point selected in a text 
block, the entire text block will be selected.
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Selecting text on your drawing

The two techniques for selecting text are: using the I-beam pointer (the text cursor) to
select all or part of a piece of text; and using the arrow pointer to select a whole text object.
The steps for each are outlined below. For more details about selecting text, see Selecting/
editing text on page 4-4.

Using the I-beam pointer to select text

1. Activate the Text tool in the Tool palette by clicking it.

2. Position the I-beam pointer on one side of the text you want to select.

3. Holding down the mouse button, drag the cursor through the character(s) until all 
the text you want to select is highlighted, and release the mouse button.

Using the arrow pointer to select text

• Click with the pointer on a text object.

Notice that edit handles appear around the text.

�  Saving and exporting

Saving documents
The Save function allows you to save a new document or any changes you have made to 
an existing document.

Saving a document in MacDraft format

Saving and naming an untitled document

When you first create a new document it will have the name untitled# (# indicates the 
number of your new document, for example untitled3).

To save and name the document

1. Choose Save or Save As from the File menu.

The standard Save dialog appears.

2. Specify the location to save the document and enter a name for it.
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You may use any character or symbol on the keyboard (except a colon {:} and {/}) 
You can also use uppercase or lowercase characters, with spaces between words.

NOTE: If you are running MacDraft under A/UX®, be sure to observe the standard 
Unix limitations on file names.

3. Click the Save button.

The document will be saved at the location, and with the name, specified.

Saving changes made to a previously saved document

While working on your document, you should save it regularly to avoid possible losses.

To save changes made to a previously saved document

• Select Save from the File menu.

The document on the disk will be updated to include the changes you have made.

Saving a copy of a document

By using the Save As command you can save an existing document using another name 
without altering your original document.

To save a copy of a document

1. Choose Save As from the File menu.

The standard Save dialog appears.

2. Specify a location and enter a name for the new document.

3. Click the Save button.

The document will be saved with the name and at the location specified.

Saving a document in another format

NOTE: See Appendix C - File formats on page C-1 for information about opening and saving 
documents in different formats.
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Saving a document as stationery

MacDraft allows you to save stationery files which can act as templates for new 
documents. For example, you can create a file containing certain images, text and settings, 
then save it as a stationery file. When you open that stationery file, MacDraft gives you a 
new untitled drawing containing the images, text and settings from the stationery file. You 
can then add to the drawing as required for a specific situation.

Using stationery files is similar to creating a pad of stationery, perhaps featuring a 
company logo at a particular scale, then tearing off sheets of paper to use as the basis for 
new drawings.

Settings that are saved in a stationery document include the scale, units, grid snap, fill 
patterns and colors in the document.

To save a document as stationery

1. Choose Save As from the File menu.

2. In the standard Save dialog that appears, choose Stationery from the Format pop-
up menu.

3. Enter a name for the file.

4. Click the Save button.

To ‘tear off’ a piece of stationery to use it for a new document

• Double-click the stationery document’s icon.

A new untitled document appears. The new document will contain the settings 
and objects defined for the stationery document.

Saving a document in another format

See Appendix C - File formats on page C-1 for information about opening and saving 
documents in different formats.

To save a document in another format:

To save a document in another format, choose Save from the File menu then select the 
desired format from the Format pop-up menu in the standard Save dialog that appears. If 
appropriate an extension will automatically be added to the file name and the file will be 
saved in the specified format.

To open a document in another format:

To open files in another format, launch MacDraft and choose Open from the File menu. In 
the standard Open dialog, select the desired file format from the Format pop-up menu, 
then choose the file to open.
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Exporting a document
The Export File command in the File menu can be used to export files in any format 
supported by QuickTime Graphic Exporters, for example JPEG and BMP formats.

To export files

1. Choose Export File from the File menu.

A standard dialog appears.

2. Select the appropriate file format from the pop-up menu at the bottom of the 
dialog.

The relevant extension will be added to the file name and the file will be exported 
in that format. See your QuickTime documentation for further details.

�  Closing documents

Closing MacDraft documents

To close the current document

1. Open the File menu and choose Close.

If the document contains unsaved changes, a dialog appears asking if you want to 
save changes made to your document before closing it.

2. Click one of the following buttons:

• Click the Save button to close the document and save the changes.
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• Click the Don’t Save button to close the document without saving the changes.

• Click the Cancel button to return to the document.

To close all documents

1. Hold down the Option key.

The Close command in the File menu will be changed to Close All.

2. Choose Close All from the File menu.

If any documents contain unsaved changes, dialogs appear asking if you want to 
save changes made to your documents before closing them.

3. Click one of the following buttons:

• Click the Save button to close the document and save the changes.

• Click the Don’t Save button to close the document without saving the changes.

• Click the Cancel button to return to the document.

All the open documents will be closed.

�  Quitting Microspot MacDraftPersonal Edition

When you are finished using MacDraft you can quit the application and return to the 
desktop.

To quit MacDraft

1. Open the MacDraft application menu and choose Quit MacDraft.

If your open document contains unsaved changes, a dialog appears giving you the 
chance to save changes made to your document before quitting.

2. Click one of the following buttons:

• Click the Save button to save the changes before quitting.

• Click the Don’t Save button to quit MacDraft without saving the changes.

• Click the Cancel button to avoid the Quit command and return to the document.
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Chapter 2 - Creating and editing objects

�  Getting started

The drawing environment
When you open a new document in MacDraft, the following conditions are preset unless 
you use stationery (see Saving a document as stationery on page 1-31):

• Document size is (at most) a single sheet of paper.

NOTE: As MacDraft Personal Edition has a limited drawing size, the drawing size 
may not be as great as a single sheet of paper if the paper size chosen is larger than 
the drawing size limit.

• Scale is set at 1:1 (one inch equals one inch).

• Grid lines are shown on the drawing area.

• Snap Grid is turned on.

• All lines and borders of objects will be drawn with an one-pixel, solid-black line.

• All closed rectangles, circles, arcs polygons and freehand objects will be shaded 
with a white fill. Open objects will have no fill.

The method of drawing most objects is very similar: choose the tool, decide on a starting 
point, press and hold down the mouse button, then drag to create the object. Drawing 
polygons, arcs and curves is a little different. Step-by-step instructions on how to draw 
and change the size of each type of object are in the following pages.

NOTES:
• See Chapter 6 - Drawing aids on page 6-1 for details of several useful features that make 
your drawing tasks easier.
• See Cursors on page 1-23 for details of the crosshair cursor which can be of use when 
drawing objects. 

Cancelling actions
The current action can be cancelled (in most cases), while it is in progress.

To cancel the current action while it is in progress

• Hold down the Command key and press the period key (.), or
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• Press the Escape key

For example, when drawing a rectangle using a rectangle drawing tool, press Escape or 
Command-period to cancel the entire drawing operation.

Choosing drawing tools
The tools used to create objects are located on the Tool palette.

Displaying the Tool palette
If the Tool palette is not shown, you can open it in the following way.

To open the Tool palette

• Choose Tool from the Window menu, or

• Choose Tool from the pop-up menu at the bottom left of the document window.

The Tool palette appears

Selecting tools
The palette holds icons that represent certain tools. Some tools are stacked with related 
tools. These provide different ways of creating the same type of object, or create similar 
objects with slightly different characteristics. For example, the different square-corner 

Rotate tool

Hand tool

Special line tools 

Text tool

Arc tools

Freehand tools

Marker symbol tool

Attributes tool

1:1 tool

Rounded-corner rectangle tools

Pointer tool

Line tools

Square-corner rectangle tools

Regular polygon tools

Circle tools

Polygon tools

Parallel line tools

                 Zoom tool

Rotate 90° tool

Selection tool
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rectangle tools relate to how you create a rectangle; either from a corner or from its center. 
On the other hand, the rounded-corner rectangle tools relate to the characteristics of the 
rectangles’ corners; proportional, constant, or elliptical.

When you start to use MacDraft, each tool has the default option shown on the palette.

To use a tool, you activate, or select, the appropriate icon. As long as the icon is 
highlighted, you can draw the object associated with the icon.

You can activate any visible tool in the Tool palette by positioning the pointer on the icon 
and clicking it. To change the current tool in a set, choose the desired item from a pop-up 
menu that shows the tools available.

To exit a drawing tool mode, click the Pointer icon in the Tool palette.

Pop-up menus

The tools in a tool set are accessed by pop-up menus.

Icons used to access pop-up menus have clipped corners. Pop-up menus are opened by 
clicking an icon in the palette and holding down the mouse button. 

To select an option from a pop-up menu

1. Click the appropriate icon in the Tool palette and hold down the mouse button.

A pop-up menu appears.

2. Drag to the menu item that represents the desired tool.

As you drag, the menu items will be highlighted.

3. When the desired menu item is highlighted, release the mouse button.

The pop-up menu disappears and the tool icon will be changed to show you the 
currently selected tool.



2 - 4               Chapter 2 - Creating and editing objects

Tool options

Some tools have options associated with them. These can be displayed by holding down 
the Option key and clicking the tool icon, or by selecting the tool and choosing Tool 
Options from the Options menu. See details of individual tools for information about any 
options available.

�  Drawing basic lines

MacDraft has two types of line tools: constrained and unconstrained. The constrained line 
tools are used to draw straight lines that snap to specified angle increments; the 
unconstrained line tool is used to draw straight lines at any angle.

Constrained lines can be drawn at increments of 5°, 15°, 30°, 45° and 90°.

NOTE: The final point of a line can be snapped to the mid point, end point or center point 
of some existing objects (see Line snapping on page 6-20).

Choosing line tools
Line tools are chosen from the Line tools pop-up menu in the Tool palette.

To choose a line tool

1. Hold down the mouse button on the line icon on the Tool palette.

The Line tools pop-up menu appears.

2. Drag until the type of line you want is highlighted, and release the mouse button.

The tool you choose appears on the Tool palette.

Unconstrained line tool

Constrained line tools
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Drawing unconstrained lines

To draw an unconstrained line

1. Click the Unconstrained line tool in the Tool palette. (If the Unconstrained line 
tool is not visible, select it from the Line pop-up menu.)

2. Position the cursor at the point on the drawing that you want the line to begin.

3. Holding down the mouse button, drag in any direction until the line is the length 
you want and release the mouse button.

NOTE: If you hold down the Shift key while you draw using the Unconstrained line tool, 
the line will snap to 45˚ angles.

Drawing constrained lines

To draw a constrained line

1. Choose the line tool showing the desired angle of constraint from the Line pop-up 
menu in the Tool palette.

2. Position the cursor at the point on the drawing that you want the line to begin.

3. Holding down the mouse button, drag until the line is the length you want and 
release the mouse button.

The line will be drawn at the angle specified. The diagram below shows a line 
constrained to 45˚.

NOTE: If you hold down the Shift key while you draw using a constrained line tool, the 
line can be drawn at any angle.
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Changing the length of a line
It is easy to edit a line to change its length.

To change the length of a line

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the line you want to change.

3. Position the tip of the pointer on one of the line’s handles.

4. Holding down the mouse button, drag until the line is the length you want and 
release the mouse button.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a line, the end of the line will snap to the nearest grid intersection point.

• Hold down the Command key when drawing or resizing a line to avoid the line 
snapping to the grid.

• Hold down the Option key when drawing a line and the line length will snap to 
the nearest grid increment.

If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw an unconstrained line, it will snap to the angular grid.

• Hold down the Shift key when drawing an unconstrained line to avoid the line 
snapping to the angular grid.

NOTE: The Constrained line tools are not affected by the angular grid.
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�  Drawing rectangles

Rectangles can be drawn with square or rounded corners.

Square-corner rectangles
Square-corner rectangles can be drawn in two ways: from the corner (Diagonal) or from 
the center (Centered).

Choosing square-corner rectangle tools

To choose a square-corner rectangle tool

1. Hold down the mouse button on the Square-corner rectangle tool in the Tool 
palette.

The Square-corner rectangle pop-up menu appears.

2. Choose either the Diagonal or the Centered tool and release the mouse button.

Drawing a square-corner rectangle from its corner
When you use the Diagonal tool for drawing a square-corner rectangle, you choose the 
position of one corner of the rectangle, then drag out the rest of the rectangle from that 
corner point.

To draw a rectangle from its corner

1. Choose the Diagonal square-corner rectangle tool from the Square-corner 
rectangle pop-up menu.

2. Position the cursor where you want one corner of the rectangle to appear on the 
drawing.

3. Press and hold down the mouse button.

DIAGONAL CENTERED
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4. Drag in any direction until the rectangle is the desired size, then release the mouse 
button.

NOTE: Hold down the Shift key while drawing a rectangle and it will be restricted to a 
square.

Drawing a square-corner rectangle from its centre
When you use the Centered tool to draw a square-corner rectangle, you center the 
rectangle round a specified point on the drawing.

To draw a rectangle from its center

1. Choose the Centered square-corner rectangle tool from the Square-corner 
rectangle pop-up menu.

2. Position the cursor where you want the center of the rectangle to appear on the 
drawing.

3. Press and hold down the mouse button.

4. Drag in any direction until the rectangle is the desired size and release the mouse 
button.

NOTE: Hold down the Shift key while drawing a rectangle and it will be restricted to a 
square.

Changing the size of a square-corner rectangle
It is easy to edit a rectangle to change its size.
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To change the size of a rectangle

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the rectangle to resize.

3. Position the tip of the pointer on one of the edit handles.

4. Holding down the mouse button, drag until the rectangle is the size you want and 
release the mouse button.

The rectangle will be resized either diagonally or by its center, depending on the 
tool originally used to draw it.

NOTE: Hold down the Shift key and resize a rectangle using one of the corner edit 
handles and it will be restricted to its original proportions.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a rectangle, the corners of the rectangle will snap to the nearest grid intersection 
points.

Hold down the Command key when drawing or resizing a rectangle to avoid the corners 
snapping to the grid.

Rounded-corner rectangles
Rounded-corner rectangles can be drawn with proportional (P), constant (C) or elliptical 
(E) corners. The type of rounded-corner rectangle you choose to draw will be determined 
by the way you wish the size and shape of the corners to change when you edit the 
rectangle.

• Rounded-corner rectangles with proportional corners
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When you resize a rounded-corner rectangle with proportional corners, the radius 
of the corners will remain proportional to the size of the rectangle as shown below.

• Rounded-corner rectangles with constant corners

When you resize a rounded-corner rectangle with constant corners, the corners 
will always have the same radius regardless of the size of the rectangle.

• Rounded-corner rectangles with elliptical corners

When you draw a rectangle with elliptical corners, the major and minor axes of the 
elliptical arcs that form the corners are determined by the size of the rectangle; the 
size of the elliptical arcs on the corners grows or shrinks in proportion to the 
rectangle’s size.

Choosing a rounded-corner rectangle tool
Choose the desired tool from the Rounded-corner rectangle pop-up menu.

To choose a rounded-corner rectangle tool

1. Click the Rounded-corner rectangle tool in the Tool palette and hold down the 
mouse button.
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The Rounded-corner rectangle pop-up menu appears.

2. Holding down the mouse button, drag through the menu until the tool you want is 
highlighted, and release the mouse button.

The icon representing the tool you selected (P for proportional, C for constant, or E 
for elliptical) appears on the palette.

Drawing a rounded-corner rectangle
All the rounded-corner rectangles are drawn in the same way.

To draw a rectangle with the chosen corner style

1. Choose the desired tool from the Rounded-corner rectangle pop-up menu.

2. Position the cursor at the point you want one corner of the rectangle to appear on 
your drawing.

NOTE: As the rectangle has rounded-corners this point will determine the corner 
position for the rectangle’s bounding frame.

3. Press and hold down the mouse button.

4. Drag in any direction until the rectangle is the desired size and release the mouse 
button.

NOTE: Hold down the Shift key as you draw a rounded-corner rectangle and the shape of 
the rectangle will be restricted to a rounded-corner square.

Proportional corners

Constant corners

Elliptical corners
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Editing rounded-corner rectangles

Changing the size of rounded-corner rectangles

Rounded-corner rectangles can be resized in the same way as square-corner rectangles (see 
Changing the size of a square-corner rectangle on page 2-8).

Changing the corner shape of rounded-corner rectangles

When you select a rounded-corner rectangle, an extra edit handle called the corner-edit 
handle appears, normally inside and near the upper left corner.

This edit handle is used to change the shape of the corners.

To change the corner shape of proportional and constant-corner rectangles

With proportional and constant-corner rectangles, you can drag the corner-edit handle in 
a diagonal direction to change the radius of the corner arc and reshape the rectangle.

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the rectangle you want to change.

3. Position the tip of the pointer on the corner-edit handle.

4. Hold down the mouse button and drag in one of the following directions:

• Drag downwards to the right to increase the radius of the corners.

• Drag upwards to the left to decrease the radius of the corners.

5. When the corners are the desired shape, release the mouse button.

To change the corner shape of elliptical-corner rectangles

When you draw a rectangle with elliptical corners, the elliptical arcs at the corners cover 
90°. By dragging the corner-edit handle, you can change the radius of the arcs to change 
the shape of the corners. The arcs will still cover 90°.

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the elliptical-corner rectangle you want to change.

3. Position the tip of the pointer on the corner-edit handle.



Chapter 2 - Creating and editing objects 2 - 13

4. Holding down the mouse button, drag until the corners are the shape you want 
and release the mouse button.

Unlike other rectangles with rounded corners, you can drag the corner-edit handle 
on elliptical-corner rectangles in any direction. The direction in which you drag the 
handle determines the shape of the corners. The figure below shows how you can 
use the corner-edit handle to reshape the corners.

• If you drag the handle to the extreme upper left corner, the corners appear almost 
square.

• If you drag the handle to the center, the entire rectangle appears as an ellipse.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a rectangle, the corners of the rectangle will snap to the nearest grid intersection 
points.

Hold down the Command key when drawing or editing a rectangle to avoid the edit 
handles snapping to the grid.

�  Drawing regular polygons

A regular polygon is a closed object with equal sides and angles of equal length. The tools 
can be preset to draw shapes with from 3 to 16 sides.

Depending on which regular polygon tool you select, you can draw a regular polygon 
from edge to edge, center to edge, vertex to vertex, or center to vertex.

Choosing a regular polygon tool
Choose the desired tool from the Regular polygon tool pop-up menu.

To choose a regular polygon tool

1. Click the Regular polygon tool in the Tool palette and hold down the mouse 
button.
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The Regular polygon tool pop-up menu appears.

2. Hold down the mouse button, drag through the menu until the tool you want is 
highlighted, and release the mouse button.

The icon representing the tool you selected appears on the palette.

Setting the number of sides
The number of sides can be set before drawing the object.

To set the number of sides before drawing a regular polygon

1. Make sure that nothing is selected on the drawing.

• Press and hold down the Option key, then click the Regular polygon icon in the 
Tool palette, or

• Click the Regular polygon icon in the Tool palette and select Tool Options from 
the Options menu.

The Regular Polygon dialog appears.

2. Enter the number of sides desired, then press the OK button.

Drawing a regular polygon

To draw a regular polygon

1. Choose the desired tool from the Regular Polygon pop-up menu.

2. According to the tool chosen, position the cursor at the point you want the center, 
edge or vertex of the polygon to appear on your drawing.

Edge to edge

Center to edge

Vertex to vertex

Center to vertex
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3. Holding down the mouse button, drag until the polygon is the desired size and 
release the mouse button.

NOTE: When you release the mouse button, the polygon is drawn as a single 
grouped object. If necessary, use the Ungroup command in the Arrange menu to 
ungroup the polygon for reshaping, breaking into separate items and so on (see 
Grouping and ungrouping objects on page 5-26). Changing fills and line attributes (see 
Chapter 3 - Changing the appearance of objects on page 3-1), and resizing can be 
performed while the object is still grouped.

NOTE: Hold down the Shift key while drawing a regular polygon, and the angle of the 
diameter or radius of the polygon will snap to 45° increments.

Changing the size of a regular polygon
It is easy to edit a regular polygon to change its size.

To change the size of a regular polygon

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the regular polygon to resize.

3. Position the tip of the pointer on one of the edit handles.

4. Holding down the mouse button, drag until the regular polygon is the size you 
want and release the mouse button.
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NOTE: Resize a regular polygon using one of the corner edit handles and it will be 
restricted to its original proportions.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a regular polygon, the cursor will snap to the nearest grid intersection point.

• Hold down the Command key when drawing or editing a regular polygon to 
avoid the cursor snapping to the grid.

If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw a regular polygon, its diameter or radius will snap to the angular grid.

• Hold down the Shift key when drawing a regular polygon to avoid its diameter or 
radius snapping to the angular grid.

�  Drawing circles

You can draw a circle by its diameter (D), by its radius (R), by three points (3) or concentric 
to an existing circle.

Choosing circle tools
Choose how you want to draw circles by selecting one of the tools in the Circle pop-up 
menu.

To choose a circle tool

1. Click the Circle icon in the Tool palette and hold down the mouse button.

The Circle pop-up menu appears.

2. Holding down the mouse button, drag through the menu until the option you 
want is highlighted and release the mouse button.

Circle drawn 
by diameter

Circle drawn by three points

Circle drawn by radius

Concentric circle tool
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3. The tool you selected appears in the Tool palette.

NOTE: The other tools in this pop-up menu are used to draw ellipses (see Drawing ellipses 
on page 2-21).

Drawing a circle by diameter

To draw a circle by diameter

1. Choose Diameter from the Circle pop-up menu.

2. Position the cursor at the point you want to begin drawing the circle.

3. Holding down the mouse button, drag until the circle is the size you want, and 
release the mouse button.

NOTE: Hold down the Shift key while drawing a circle by diameter and the diameter will 
be restricted to 45° increments.

Drawing a circle by radius

To draw a circle by radius

1. Choose Radius from the Circle pop-up menu.

2. Position the cursor at the point you want the center of the circle to be on your 
drawing.
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3. Holding down the mouse button, drag until the circle is the desired size, and 
release the mouse button.

NOTE: Hold down the Shift key while drawing a circle by radius and the radius will be 
restricted to 45° increments.

Changing the size of a circle drawn by diameter or radius
After you have drawn a circle by diameter or radius, you can change its size by dragging 
one of its edit handles.

To change the size of a circle drawn by diameter or radius

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the circle you want to change.

3. Position the tip of the pointer on one of its handles.

4. Press and hold down the mouse button, drag the handle until the circle is the 
desired size, and release the mouse button.

The circle will be resized either by diameter or by radius, depending on the tool 
originally used to draw it.

Drawing a circle by three points
Use the Circle by three points tool to draw a circle that passes through three specific 
points on your drawing.
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To draw a circle by three points

1. Choose the Circle by three points tool from the Circle pop-up menu in the Tool 
palette.

2. Position the cursor on the first point through which you want the circle to pass.

3. Press and hold down the mouse button.

4. Drag to the second point through which you want the circle to pass and release the 
mouse button.

5. Without pressing down the mouse button, move the cursor to the third point 
through which you want the circle to pass and click this point.

Three edit handles appear on the circle. The edit handles correspond to the three 
points used to define it.

Changing the size of a circle drawn by three points
You can change the size of a circle drawn by three points by moving its edit handles.

To change the size of a circle drawn by three points

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the circle you want to resize.

3. Position the cursor on one of the edit handles.

4. Press and hold down the mouse button.

5. Drag until the circle is the size you want and release the mouse button.
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The circle will be redrawn to pass through the three points represented by the edit 
handles.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a circle drawn by three points, the edit handles will snap to the nearest grid 
intersection point.

Hold down the Command key when drawing or editing a circle to avoid the edit handles 
snapping to the grid.

Drawing concentric circles
With MacDraft’s Concentric circle tool, you can create new circles concentric to existing 
circles (sometimes called offset circles). The concentric circle will be of the same type and 
have the same line weight, line style and pen model as the original circle.

Concentric circles can be drawn in relation to any existing circle. Once drawn, a concentric 
circle is an independent circle that can be edited, moved or changed as required.

NOTE: The parent circle for the concentric circle must be in place before you choose the 
concentric circle tool.

To draw a concentric circle
Drawing a concentric circle from an existing circle takes two steps: Selecting the parent 
circle then clicking to specify the distance between the two.

To draw a circle concentric to an existing circle

1. Choose the Concentric circle tool from the Circle tools pop-up menu in the Tool 
palette.

The cursor will now read ‘Click Circle’, to let you know that you need to select a 
parent circle.

2. Click the parent circle.
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The cursor will now read ‘Anchor’ and appears near a dotted copy of the parent 
circle to help you judge the distance between them.

3. Move the cursor until the concentric circle is the desired diameter, then click. As 
you move the cursor, the dotted sketching circle follows it.

The concentric circle is drawn.

The cursor returns to ‘Click Circle’, to let you draw more concentric circles.

4. To exit the offset cursor mode, click the Pointer icon on the Tool palette.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
a concentric circle, the radius of the concentric circle will snap to the nearest grid 
increment.

�  Drawing ellipses

MacDraft provides two methods of drawing ellipses: diagonal and centered. The two 
types of ellipses differ in the way you draw and edit the ellipse. The ellipse tools are 
located in the Circle pop-up menu in the Tool palette. When drawn, an ellipse has eight 
edit handles, four on its circumference and four defining its bounding rectangle.

Choosing an ellipse tool

To choose an ellipse tool

1. Click the Circle tool in the Tool palette and hold down the mouse button.
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The Circle pop-up menu appears.

2. Holding down the mouse button, drag until the ellipse tool you require is 
highlighted, and release the mouse button.

The icon representing the tool selected appears in the Tool palette.

Drawing a diagonal ellipse
To draw a diagonal ellipse click a starting point and drag until the ellipse is the desired 
size and shape.

To draw a diagonal ellipse

1. Choose the Diagonal ellipse tool from the Circle pop-up menu.

2. Click the point you want a corner of the ellipse’s bounding rectangle to appear on 
your drawing.

3. Holding down the mouse button, drag in a diagonal direction until the ellipse is 
the desired size, and release the mouse button.

NOTE: Hold down the Shift key as you draw an ellipse and the shape of the ellipse will 
be restricted to a circle.

Drawing a centered ellipse
To draw an ellipse from its center, you first specify its center point, then drag to define its 
overall size and shape. The ellipse is projected from the specified center point.

Diagonal ellipse

Centered ellipse
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To draw a centered ellipse

1. Choose the Centered ellipse tool from the Circle pop-up menu.

2. Click the point you want to be the ellipse’s center.

3. Holding down the mouse button, drag until the ellipse is the desired size, and 
release the mouse button.

NOTE: Hold down the Shift key as you draw an ellipse and the shape of the ellipse will 
be restricted to a circle.

Changing the size of an ellipse
You change the size of an ellipse by dragging one of its eight edit handles.

To change the size of an ellipse

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the ellipse you want to resize.

3. Position the tip of the pointer on one of the edit handles, then press and hold down 
the mouse button.

4. Holding down the mouse button, drag the handle until the ellipse is the size you 
want, and release the mouse button.

NOTE: Hold down the Shift key and resize an ellipse using one of the corner edit handles 
and it will be restricted to its original proportions.
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Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize an ellipse, the edit handles will snap to the nearest grid intersection point.

Hold down the Command key when drawing or editing an ellipse to avoid the edit 
handles snapping to the grid.

�  Drawing arcs

You can draw circular and elliptical arcs; circular arcs can be drawn by radius or by three 
points. You can also draw arcs concentric to existing circular arcs.

NOTE: When an arc is drawn with a fill, it appears as an object shaped like a piece of pie. 
To draw only the arc line, make sure that no objects are selected, then choose “*” (for No 
fill) from the Fill Color submenu or “N” (for No fill) from the Fill Pattern submenu before 
you draw the arc. See Object fill color on page 3-7 and Object fill patterns on page 3-25 for more 
information.

Choosing an arc tool
Choose the arc tool required from the Arc pop-up menu in the Tool palette.

To choose an arc tool

1. Click the Arc tool in the Tool palette and hold down the mouse button.

The Arc pop-up menu appears.

2. Holding down the mouse button, drag through the menu until the desired tool is 
highlighted, and release the mouse button.

The icon representing the tool chosen appears in the Tool palette.

Arc by radius

Arc by 3 points

Elliptical arc

Concentric arc
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Arc by radius

Drawing an arc by radius
To draw an arc by radius, first define a radius, then project the arc the desired number of 
degrees around a circle.

To draw an arc by its radius

1. Choose Arc by radius from the Arc pop-up menu in the Tool palette.

2. Position the cursor where you want to begin the radius of the arc, then press and 
hold down the mouse button.

3. Holding down the mouse button, drag in any direction to draw a line that 
represents the radius of the arc.

4. Release the mouse button.

A dotted circle appears. This is the circle from which you will be able to define a 
segment for the arc.

5. Without pressing the mouse button, move the cursor away from the end of the 
radius line until you have created an arc of the desired number of degrees and 
click this place.

NOTE: If you drag outside the border of the arc, a line extending from the arc’s 
border to the cursor will be drawn. This line allows you to align the ending point 
of the arc with other points on your drawing.

NOTE: Hold down the Shift key while defining the arc’s radius to restrict the radius to an 
angle of increments of 45°.
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Changing the size of an arc drawn by radius
You can change the size of an arc drawn by radius either by changing the length of the 
radius or by changing the length of the arc. The following steps and diagrams will show 
you both methods, as well as their effect on the shape of the arc.

Changing the radius of an arc drawn by radius

To change the radius

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the arc you want to change.

3. Position the tip of the pointer on the edit handle in the middle of the arc’s border, 
then press and hold down the mouse button.

4. Drag until the radius is the length you want and release the mouse button.

Changing the length of an arc drawn by radius

To change the length

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the arc you want to change.

3. Position the tip of the pointer on one of the handles at either end of the arc, then 
press and hold down the mouse button.

4. Drag until the arc is the length you want, then release the mouse button.

NOTE: You cannot create a complete circle using the arc tool. If you drag past the 
beginning of the arc, it will collapse back to a shorter length.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
an arc by radius, the cursor will snap to the nearest grid intersection point.

• Hold down the Command key when drawing or resizing an arc drawn by radius 
to avoid the cursor snapping to the grid.
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If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw or edit an arc by radius, the radius line will snap to the angular grid.

• Hold down the Shift key when drawing or editing an arc by radius to avoid the 
radius line snapping to the angular grid.

Arc by three points

Drawing an arc by three points
When drawing an arc by three points, you specify three points on the drawing through 
which you want the arc to pass. This tool is useful when you do not know the length of the 
radius of an arc, but do know that the arc should pass through three different points in a 
drawing.

To draw an arc by three points

1. Choose Arc by 3 points from the Arc pop-up menu in the Tool palette.

2. Position the cursor on the first point through which you want the arc to pass, then 
press and hold down the mouse button.

3. Drag to the second point through which you want the arc to pass.

4. Release the mouse button.

5. Without pressing the mouse button, move the cursor to the third point through 
which you want the arc to pass, and click this point.

NOTE: You cannot create a complete circle by using the arc tool. If you drag past the 
beginning of the arc, it will collapse back to a shorter length.

Changing the size of an arc drawn by three points
You can change the size of an arc drawn by three points by moving any one of the three 
handles that represent the three points originally used to define the arc.

To change the size of an arc drawn by three points

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the arc you want to resize.
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3. Position the tip of the pointer on the edit handle you want to move, then press and 
hold down the mouse button.

4. Drag the handle to a new location on the drawing.

5. Release the mouse button.

Elliptical arcs

Drawing an elliptical arc
You can use the Elliptical Arc tool to create elliptical arcs of a specific size and length. 
When you create an elliptical arc, you define an ellipse, then project an arc that is a portion 
of the ellipse. The actual size of the arc is determined by the size of the ellipse and the arc’s 
length is determined by the number of degrees you project it during creation.

To draw an elliptical arc

1. Choose Elliptical arc from the Arc pop-up menu in the Tool palette.

2. Position the cursor on the point to be used as the center point for the ellipse that 
will be used to define the arc, then press and hold down the mouse button.
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3. Drag until you have created an ellipse that is the size and shape you want, and 
release the mouse button.

4. Without pressing down the mouse button, move the cursor until you have 
projected an arc that is the length you want and click this point.

NOTE: A line will extend from the center of the ellipse to the cursor. This is used to 
define the ending angle of the arc. If you drag outside the ellipse, the line will 
extend past the ellipse’s border; this allows you to align the ending angle of the arc 
with other points on your drawing.

The elliptical arc will be drawn.

Changing the starting angle of an elliptical arc
Part of the process of defining elliptical arcs involves defining the starting angle of the arc. 
The starting angle of the elliptical arc is determined by the position of the cursor when 
you release the mouse button after defining the initial ellipse, however, by using the Shift 
key to constrain the size of the ellipse, you can change the position of the starting angle 
without changing the size of the ellipse.
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To change the starting angle of the arc

1. Choose Elliptical arc from the Arc pop-up menu in the Tool palette.

2. Position the cursor on the point to be used as the center point for the ellipse that 
will be used to define the arc, then press and hold down the mouse button.

3. Drag until you have created an ellipse that is the size and shape you want, then 
(without releasing the mouse button) hold down the Shift key.

4. Drag the line that marks the starting angle to a new position.

The line marking the starting angle of the arc will follow the cursor’s movement, 
but the ellipse will not be resized.

5. Release the mouse button and the Shift key when the line is in the desired position 
for the starting angle of the arc.

6. Without pressing down the mouse button, move the cursor until you have 
projected an arc that is the length you want, then click this place.

Editing an elliptical arc
There are two ways you can edit an elliptical arc: you can change its shape and you can 
change its length. When you change its shape, you change the major and minor axes of the 
arc. When you change its length, you either increase or decrease the number of degrees 
the arc is projected.

Changing the shape of an elliptical arc

You can change the arc’s shape, without moving its end points, by dragging the edit 
handle in the middle of the arc’s border.

To change the shape of an elliptical arc

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the elliptical arc you want to change.

3. Position the tip of the pointer on the edit handle located in the center of the arc’s 
border, then press and hold down the mouse button.

4. Drag until the elliptical arc is the shape you want, and release the mouse button.
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Changing the length of an elliptical arc

You can use the edit handles on the end points of an elliptical arc to change its length.

To change the length of an elliptical arc:

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the arc you want to change.

3. Position the tip of the pointer on one of the handles at either end of the arc, then 
press and hold down the mouse button.

4. Drag until the arc is the length you want, and release the mouse button.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
an elliptical arc, the cursor will snap to the nearest grid intersection point.

• Hold down the Command key when drawing or resizing an elliptical arc to avoid 
the cursor snapping to the grid.

If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw or edit an elliptical arc, the line of the ending angle will snap to the 
angular grid.

• Hold down the Shift key when drawing or editing an elliptical arc to avoid the line 
of the ending angle snapping to the angular grid.

Concentric arcs
Using the Concentric arc tool you can create new arcs that are concentric to existing 
circular arcs. The concentric arc will be the same type (radial or three-point) and have the 
same line weight, line style and pen model as the original arc.

Concentric arcs can be created from any circular arc. Once drawn, a concentric arc is an 
independent object that can be edited, moved or otherwise manipulated as required.

NOTE: The “parent” arc for the concentric arc must be in place before you choose the 
Concentric arc tool. 
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Drawing a concentric arc
Drawing a concentric arc requires two steps: selecting the source arc and specifying the 
offset distance.

To draw an arc concentric to an existing arc

1. Choose the Concentric arc tool from the Arc pop-up menu.

The cursor now reads “Click Arc”, to let you know that you need to select an arc.

2. Click the source arc.

The cursor now reads “Anchor” and appears near a dotted copy of the source arc, 
which helps you to position the concentric arc.

3. Move the cursor until the concentric arc is in the desired position.

As you move the cursor, the ‘ghost’ arc gets larger or smaller.

The concentric arc is drawn. The cursor returns to “Click Arc”, allowing you to 
create more concentric arcs if desired.

NOTE: To exit the Concentric arc tool, click the Pointer icon in the Tool palette.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
a concentric arc, the radius of the arc will snap to the nearest grid increment.

To change the increment, choose a different value from the Layout menu’s Set Grid 
submenu.

Concentric arc
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�  Drawing irregular polygons and polylines

You can draw two types of multi sided irregular shapes: closed polygons and open 
polylines. Drawing irregular polygons and polylines is discussed in this section, 
information about drawing regular polygons can be found earlier in this chapter (see 
Drawing regular polygons on page 2-13).

A polygon is a closed object made of three or more sides. It can be a complex, irregularly 
shaped object made up of many straight line segments. A polyline is an open object made 
of at least two straight line segments. The line segments used for either type of object can 
be of any length and drawn at any angle.

Choosing polygon tools
The type of multisided shape you can draw depends on the tool you choose from the 
Polygon pop-up menu in the Tool palette.

To choose a polygon tool

1. Click the Polygon tool in the Tool palette and hold down the mouse button.

The Polygon pop-up menu appears.

2. Holding down the mouse button, drag until the Irregular polygon or Polyline tool 
is highlighted.

3. Release the mouse button.

Drawing an irregular polygon or polyline
To draw an irregular polygon or polyline, you position the cursor and click to define the 
end points of the lines that make up the shape.

To draw an irregular polygon or a polyline

1. Choose the Irregular polygon or Polyline tool from the Polygon pop-up menu in 
the Tool palette.

2. Place the cursor at the point you want to begin drawing the object, then press and 
hold down the mouse button.

Irregular polygon Polyline
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3. Drag until you have created a line that is the desired length and angle for the first 
side or line segment of the object.

4. Release the mouse button.

5. Without pressing down the mouse button, move the cursor to draw the second line 
segment.

6. When the second line is the desired length and angle, click this point.

7. Without pressing the mouse button, move the cursor to draw the next line 
segment.

8. When the line is the desired length and angle, click this place.

You may decide that you want to change a line segment after you have drawn it. 
You can change the length and orientation of the last line segment drawn by using 
the Dynamic Editing feature.

9. To change the last line segment drawn, move the cursor back to the last defined 
point and click it.

The previous line will reattach to the cursor, allowing you to move the end of the 
line to a new position on the drawing.

10. Move the cursor to a new position on the drawing and click it.

The line will be drawn to the new position.

11. Continue to draw the rest of the object.

12. When you reach the last point to be placed, double-click the point.
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This double-click action completes the object. 

• If you are drawing an irregular polygon, the last point you clicked will be 
connected to the starting point of the shape by a straight line.

• If you are drawing a polyline, the object remains open.

NOTES:
• Hold down the Shift key while drawing an irregular polygon or polyline and the angle 
of the current line segment will snap to increments of 45°.
• The final point of a polyline can be snapped to the mid point, end point or center point 
of some existing objects (see Line snapping on page 6-20).

Changing the shape of an irregular polygon or a polyline
Irregular polygons and polylines, like other objects, have handles when they are selected. 
Unlike most objects, they have two different kinds of handles: major (the handles on the 
vertex points or corners) and minor (the handles at the mid points of the line segments).

A major handle is used to move the end point of a line, which could change both the 
length and angle of the lines connected at that handle. A minor handle is used to move a 
line segment without changing its length or angle.

Changing the shape using the major handles

To change the shape using the major handles

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the irregular polygon or polyline you want to change.

3. Position the tip of the pointer on one of the major handles, then press and hold 
down the mouse button.

4. Drag the handle to a new location on the drawing, and release the mouse button.
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When you move the handle, the connecting lines will follow. As soon as you 
release the mouse button, both lines will be redrawn according to the new handle 
location. 

Changing the shape using the minor handles

To change the shape using the minor handles

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the irregular polygon or polyline you want to change.

3. Position the tip of the pointer on one of the minor handles, then press and hold 
down the mouse button.

4. Drag the line to a new location, and release the mouse button.

As you drag the minor handle, the line moves, but its length and angle remain the 
same.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or edit an irregular polygon or polyline, the ends of the line segments or the edit handles 
will snap to the nearest grid intersection points.

• Hold down the Command key when drawing or editing an irregular polygon or 
polyline to avoid the lines or edit handles snapping to the grid.

• Hold down the Option key when drawing an irregular polygon or polyline and 
the line lengths will snap to the nearest grid increment.
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If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw an irregular polygon or polyline, the line segments will snap to the 
angular grid.

• Hold down the Shift key when drawing an irregular polygon or polyline to avoid 
the line segments snapping to the angular grid.

�  Drawing freehand lines, shapes and curves

At times you may want to draw an object that has a different shape to those provided for 
you in the Tool palette. For this reason, four freehand drawing tools are provided: 
Freehand lines, Freehand shapes, Bezier curves and Spline curves.

• The Freehand lines tool is used to draw open freehand objects.

• The Freehand shape tool is used to draw closed freehand objects.

• The Bezier curve tool is used to draw curves that are defined by four control 
points. The curve passes through only two of the control points, the other two 
control points are used to define the shape of the curve.

• The Spline curve tool is used to draw curves that are fitted to a series of defined 
points on your drawing. The curve passes through all the defined (or control) 
points.

Choosing a freehand drawing tool
Draw either an open freehand line, a closed freehand shape, a Bezier curve or a spline 
curve by choosing the appropriate tool from the Freehand drawing tools pop-up menu in 
the Tool palette.

To choose a freehand drawing tool

1. Click the Freehand drawing tool in the Tool palette, then press and hold down the 
mouse button.

The Freehand drawing tools pop-up menu appears.
Freehand line

Freehand shape Spline curve

Bezier curve
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2. Drag until the Freehand line, Freehand shape, Bezier curve or Spline curve tool is 
highlighted.

3. Release the mouse button.

The icon representing the tool chosen appears in the palette.

Freehand lines or shapes

Drawing a freehand line or shape

To draw a freehand line or shape

1. Choose the Freehand line or Freehand shape tool from the Freehand drawing 
tools pop-up menu.

2. Position the cursor at the point you want to begin drawing, then press and hold 
down the mouse button.

3. Drag the cursor in any direction, creating a line just as you would with a pencil. 

4. When you have completed the freehand line or shape, release the mouse button.

• If you are using the Freehand line tool the object remains open.

• If you are using the Freehand shape tool, the start and end points of your freehand 
line will be automatically joined by a straight line.

Correcting a freehand line or shape while drawing
When you are using the Freehand line or the Freehand shape tool, you can erase portions 
of the line that you are drawing by using the Shift key.

To correct a freehand line

1. When you have made an error while drawing a freehand line, continue to hold 
down the mouse button, but stop drawing the line by ceasing to move the mouse.

2. Press and hold down the Shift key.

Open freehand Closed freehand
shape shape
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An icon of an inverted pencil with eraser appears at the end of your freehand line.

3. Using the mouse to move the eraser, retrace the portion of the line that you want to 
delete. The line will be erased.

4. Release the Shift key to continue drawing the object.

Drawing a straight line as part of a freehand object
The constrained drawing mode for a freehand tool allows you to draw straight line 
segments as part of a freehand object.

To draw a straight line as part of a freehand object

1. Start drawing an object using the Freehand line or Freehand shape tool.

2. When you want to draw a straight line, hold down the Option key and drag the 
cursor in any direction until you have created a straight line that is the required 
length.

3. Release the Option key.

Changing the shape of a freehand object
You can drag the edit handles of a freehand object to change its shape.

To change the shape of a freehand object

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the freehand object you want to change by clicking it.

3. Position the tip of the pointer on one of its edit handles, then press and hold down 
the mouse button.
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4. Drag the handle until you have created the shape you want, and release the mouse 
button.

5. Continue to move other edit handles in the same way until you have obtained the 
shape you want.

Bezier curves
Drawing using the Bezier curve tool gives you a great deal of flexibility in creating 
original designs that feature elegant S shapes and loops.

A Bezier curve is a type of curve defined by four points, called “control points.” Two 
control points define the end points of the curve, the others define the direction in which 
the curve is projected. When you select a Bezier curve, the four control points are 
represented by edit handles on the screen: two handles appear on the end points of the 
curve and two other handles appear on either side of the curve. 

The two handles on the end points are called “end point handles,” and the other two 
handles are called “direction point handles.” You can move the handles to modify and 
change the size of the Bezier curve.

When you create a Bezier curve, direction lines are used to indicate the slope and direction 
of the curves you draw. A direction line is a line between two control points, and is 
tangent to an end point.

Direction point handles

End point handle

End point handle

Joint control handle

Direction point handles
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You can draw a series of Bezier curves using the Bezier curve tool. Each individual curve 
actually passes through only the two end control points. The direction lines define the 
overall shape of the curve. When you draw a series of curves, the curves are connected at 
“joints” or end control points that are shared by two curves.

Creating Bezier curves

To create a Bezier curve

1. Choose the Bezier curve tool from the Freehand drawing tools pop-up menu in 
the Tool palette.

2. Position the cursor at the point you want the curve to begin, then press and hold 
down the mouse button.

This defines the first end control point of the curve.

3. Drag in the direction you want to project the curve.

A line with a handle at either end will be projected, the curve’s start point being at 
the center of the line. This is a direction line. One of the handles will be attached to 
the cursor. By dragging the handle, you indicate the direction and slope of the 
curve. For example, if you drag the handle down all the way to the lower right 
corner of the screen, a curve sloping toward the lower right corner will result.

4. Release the mouse button.

The position of the cursor when you release the mouse button defines the first 
direction point.

5. Without pressing down the mouse button, move the cursor to the point you want 
the second end control point (the end point of the first curve and the start point for 
a next curve) to be, then press and hold down the mouse button. As you move the 
cursor the curve appears on the screen.

6. Holding down the mouse button, drag to define the curve’s second direction point 
(this will also define the first direction point of the next curve).
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The first direction point of the next curve is associated with the handle that is 
attached to the cursor. The second direction point of the first curve is associated 
with the handle at the opposite end of the direction line.

The curve’s shape will change as you define the second direction point.

7. Release the mouse button.

8. To continue drawing curves, repeat steps six and seven above.

9. When you have defined the control handle for the curve’s final point, double-click 
to complete the shape.

Correcting a Bezier curve while drawing
When you are using the Bezier curve tool, you can erase portions of the curve that you are 
drawing by using the Shift key.

To correct a Bezier curve

1. When you have made an error while drawing a Bezier curve, continue to hold 
down the mouse button, but stop drawing the curve by ceasing to move the 
mouse.

2. Press and hold down the Shift key.

An icon of an inverted pencil with eraser appears at the end of your Bezier curve.

3. Using the mouse to move the eraser, retrace the portion of the curve that you want 
to delete. The curve will be erased.

4. Release the Shift key to continue drawing the object.

NOTE: You can also press the Backspace (Delete) key to delete the last point placed.
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Drawing straight line segments
While drawing Bezier curves, you can draw straight line segments by clicking the mouse 
button instead of dragging the cursor with the mouse button held down.

To create a straight line segment

1. While drawing a Bezier curve, and after you have drawn at least one complete 
curve, move the cursor and click the new place.

The resulting line will be curved, but the next line will be straight.

2. Without pressing and holding down the mouse button, move the cursor to where 
you want the end point of the line to be, then click this point.

3. Continue moving the cursor and clicking to create a series of straight line 
segments.

Modifying Bezier curves
You can modify a Bezier curve by dragging the edit handles. Edit handles appear on 
Bezier curves that are selected. When you move the end point handles, you move the end 
point of the curve; when you drag a direction handle, it exerts a “pull” on the curve 
closest to it and so changes its shape.

Moving the end point of a Bezier curve

To move the end point a Bezier curve

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the Bezier curve object you want to change by clicking it.

Edit handles appear on the selected curve.

3. Position the tip of the pointer on one of the handles at either end of the curve, then 
press and hold down the mouse button.

4. Drag until the curve is the length you want, and release the mouse button.

Changing the shape of a Bezier curve

To change the shape of a Bezier curve

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.
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2. Select the Bezier curve object you want to change by clicking it.

Edit handles appear on the selected curve.

3. Position the cursor on one of the direction handles, then press and hold down the 
mouse button.

4. Drag until the curve is the shape you want, and release the mouse button.

The curve will be reshaped to reflect the new position of the direction handle.

NOTE: Hold down the Shift key while selecting and moving the direction handle, 
and the direction handle and its opposite direction handle will pivot around the 
point on the curve. This will change the shape of the two curves controlled by 
those two direction control points, and will keep the curve smooth.

NOTES:
• If you drag a direction handle for the end point of a straight line segment, you 
reshape the straight line segment, causing it to become curved.
• You can create sharp corners on a Bezier curve by pulling both direction handles 
to one side or by dragging the direction handles of a direction line on top of an end 
control point.

Spline curves
You can draw a type of curve that passes through a series of defined points on your 
drawing. This type of curve, called a spline curve, allows you to pick a series of points on 
a drawing and fit a curve to those points.
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Drawing a spline curve

To draw a spline curve

1. Choose the Spline curve tool from the Freehand drawing tools pop-up menu in 
the Tool palette.

2. Position the cursor at the point you want the spline curve to start, then press and 
hold down the mouse button.

3. Drag until you reach one of the points through which you want the curve to pass.

4. Release the mouse button.

A straight line appears between the starting point and the cursor to show you the 
slope of the curve segment.

5. Without pressing and holding down the mouse button, move the cursor to the next 
point you want the curve to pass through and click it.

A curve will be drawn through the three points defined so far.

6. Continue moving the cursor and clicking the mouse button until you have defined 
all the points the curve is to pass through.

NOTE: Press the Backspace (Delete) key at any time to delete the last point placed.

7. When you reach the last point, to complete the spline curve either

• Double-click this point or,

• Hold down the Command key and click this point.
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The completed spline curve will be drawn. Edit handles appear on the control 
points used to define the curve.

NOTE: To make the spline curve a closed object, finish the curve on the starting 
point.

Changing the shape of a spline curve
You can change the shape of a spline curve by dragging its control points.

To change the shape of a spline curve

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the spline curve object you want to change by clicking it.

3. Position the cursor on one of the edit handles (the edit handles represent the 
control points that were used to define the curve), then press and hold down the 
mouse button.

4. Drag to reposition the control point and modify the curve.

5. When the curve is the shape you want, release the mouse button.

�  Drawing special lines

MacDraft provides a selection of special line tools to make it easy to draw lines in relation 
to existing objects. Lines can be drawn perpendicular to existing lines or edges; from the 
mid, end and center points of existing objects; at a tangent to, or at a tangent between, 
existing circles or arcs; offset from existing lines.

Choosing special line tools
To draw a perpendicular line; a mid point, end point, or center point line; a tangent line; 
or an offset line, choose the appropriate tool from the Special line tools pop-up menu in 
the Tool palette.
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To choose a special line tool

1. Click the Special line tool in the Tool palette, then press and hold down the mouse 
button.

The Special line tools pop-up menu appears.

2. Drag until the desired tool is highlighted.

3. Release the mouse button.

The icon representing the tool chosen appears in the palette.

Perpendicular lines
The Perpendicular line tool is used for drawing lines perpendicular to existing lines, or 
perpendicular to the edges of polygons, circles, circular arcs or square-cornered 
rectangles.

Once a perpendicular line is drawn, it becomes a normal unconstrained line. You can edit 
it, resize it, or move it away from its original position.

NOTE: The “anchoring” object for the perpendicular line must be in place before you 
choose the Perpendicular tool.

Drawing a line perpendicular to an existing object takes two steps: selecting the object to 
draw the line perpendicular to and specifying the end point.

Perpendicular line

Mid point line

End point line

Center point line

Tangent from

Tangent between

Offset line
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Drawing perpendicular lines

To draw a line perpendicular to an existing object

1. Choose the Perpendicular line tool from the Special line tools pop-up menu in 
the Tool palette.

The cursor will now read “Click Line/Arc”, to let you know that you need to select 
a line, circular arc or the edge of an object.

2. Click the line, arc or object edge that the line is to be drawn perpendicular to.

The cursor will now read “Click Point”, to let you know that you need to select an 
end point for the perpendicular line.

3. Move the cursor to the point where you want the perpendicular to end.

The perpendicular line’s starting point slides along the anchoring edge or line as 
you move the cursor.

NOTE: It is possible to draw a perpendicular line from a point not on the original 
shape, but on an invisible line or circle extended from it.

4. Click to specify the end point of the line.
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The perpendicular line is drawn.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
a perpendicular line, the end of the line will snap to the nearest grid intersection point.

• Hold down the Command key when drawing a perpendicular line to avoid the 
line snapping to the grid.

• Hold down the Option key when drawing a perpendicular line and the line length 
will snap to the nearest grid increment.

Mid point, end point and center point lines
The Mid point, End point and Center point line tools are used to draw lines from the mid 
point, or end point of an existing straight edge or circular arc, or from the center of an 
existing object. These tools are found in the Special line tools pop-up menu in the Tool 
palette.

Once a line is drawn with a Mid point, End point or Center point line tool, it becomes a 
normal unconstrained line and can be edited, resized and moved.

The Mid point and End point line tools can be used with straight-edged objects (lines, 
polylines, polygons and square-corner rectangles) and circular arcs. Any of these objects 
can be part of a group. The Center point line tool can be used with any individual shape.

NOTE: The “anchoring” object for the line must be in place before you choose the Mid 
point, End point or Center point line tool.

Drawing Mid point, End point and Center point lines
Drawing a line from the mid, end or center point of an existing object takes two steps: 
selecting the object to draw the line from and specifying the end point.

All of these lines are drawn in the same way.
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To draw a line from the mid, end or center point of an existing object

1. Choose the Mid, End or Center point line tool from the Special line tools pop-up 
menu in the Tool palette.

The cursor will now read “Click Line/Arc” or “Click Object”, to let you know that 
you need to select a line, edge, circular arc or object.

2. Click the line, edge arc or object that the line is to be drawn in relation to.

The cursor will now read “Click Point”, to let you know that you need to select an 
end point for the line.

3. Move the cursor to the point where you want the line to end.

4. Click to specify the end point of the line.

The line will be drawn.

NOTE: The final point of a mid point, end point or center point line can be snapped to the 
mid point, end point or center point of some existing object (see Line snapping on page 6-20).

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
a mid, end or center point line, the end of the line will snap to the nearest grid intersection 
point.

• Hold down the Command key when drawing a mid, end or center point line to 
avoid the line snapping to the grid.

• Hold down the Option key when drawing a mid point, end point or center point 
line and the line length will snap to the nearest grid increment.

Mid point line

End point line

Center point line
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Tangent lines
MacDraft provides two ways to draw tangent lines from circles and circular arcs. The 
Tangent from tool draws a tangent from a circle or arc to any point, and the Tangent 
between tool draws a tangent from one circle or arc to another. Both of these tools are 
located in the Special line tools pop-up menu in the Tool palette.

Once a tangent is drawn, it becomes a normal unconstrained line. You can edit and resize 
it or even move it away from its original position if necessary.

NOTE: The circles or arcs the tangent line is to be drawn in relation to must be in place 
before you choose a tangent line tool.

Drawing a tangent from a circle or arc to a point
Drawing a tangent from a circle or arc to a point involves two steps: selecting the object 
the line is to be drawn at a tangent to, then specifying the end point for the tangent line.

To draw a tangent from a circle or arc to a point

1. Select the Tangent from tool from the Special line tools pop-up menu in the Tool 
palette.

The cursor now reads “Click Circle/Arc,” to let you know that you need to select a 
circle or arc.

2. Click the circle or arc.

The cursor now reads “Click Point,” to let you know that you need to select an end 
point for the tangent line.

3. Move the cursor; the tangent's starting point slides around the circle or arc.

Tangent from
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NOTE: When drawing a tangent line from an arc, it is possible to draw a tangent 
line from a point not on the visible arc, but on its “invisible circle.”

4. Position the cursor on the point you want the tangent line to end and click it. 

The tangent line is drawn.

NOTE: Normally the tangent will be drawn clockwise away from the arc or circle. You can 
draw the tangent counterclockwise by holding down the Option key before selecting the 
circle or arc, and keeping the Option key held down until the end point is specified.

Drawing a tangent between circles or arcs
Drawing a tangent from a circle or arc to another circle or arc involves two steps: selecting 
the first object, then selecting the second object.

The tangent’s final position depends on which half of each object you click. 

To draw a tangent from a circle or arc to another circle or arc

1. Choose the Tangent between tool from the Special line tools pop-up menu in the 
Tool palette.

The cursor now reads “1st Circle/Arc”, to let you know that you need to select a 
circle or an arc.

Tangent between
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2. Click the circle or arc near the desired starting point for the tangent.

The cursor now reads “2nd Circle/Arc”, to let you know that you need to select 
another object.

3. Move the cursor to the other object the tangent is to be drawn to and click close to 
the point you want the tangent line to end.

 The tangent line is drawn.

NOTE: The final path of the tangent is determined by which half of each object you 
select. For any pair of circles or arcs, there are four possible tangent arrangements, 
as shown below.
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Offset lines
MacDraft’s Offset line tool is used to create single lines parallel to existing straight lines 
or edges. The offset line will have the same length, angle, line weight, line style and pen 
model as the original line or edge.

NOTE: Parallel line objects can be created using the Parallel line tools, see Drawing parallel 
line objects on page 2-55.

Offset lines can be created from any straight line or from any edge of a polygon, polyline 
or square-cornered rectangle. Once drawn, an offset line is an independent straight line 
object that can be edited, moved or otherwise manipulated as required.

NOTE: The “parent” object for the offset line must be in place before you choose the offset 
line tool. 

Drawing an offset line from an existing object
Drawing an offset line from an existing object involves two steps: selecting the source line 
or edge and specifying the offset distance.

To draw an offset line from an existing object

1. Select the Offset line tool from the Special line tools pop-up menu in the Tool 
palette.

The cursor now reads “Click Line/Edge”, to let you know that you need to select a 
line or the straight edge of an object.

2. Click the line or edge.
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The cursor now reads “Click Point” and appears near a dotted copy of the source 
line, helping you to determine the offset distance.

3. Move the cursor to the desired position for the offset line and click it.

The offset line is drawn.

The offset is a normal unconstrained line, which you can edit or alter as needed. 
You can also use it as the base for a new offset line.

4. To exit the Offset line tool, click the Pointer icon in the Tool palette.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
an offset line, the offset distance for the line will snap to the nearest active grid line.

• Hold down the Command key when drawing an offset line to avoid the offset 
distance for the line snapping to the grid.

• Hold down the Option key when drawing a line and the offset distance for the line 
will snap to the nearest grid increment.

�  Drawing parallel line objects

MacDraft’s Parallel line tools are used to draw single sets of parallel lines or polygons 
and polylines with double lines. You can use parallel lines to create drawings of such 
things as walls, beams and frames. Various options can be set to specify how the parallel 
lines should be drawn.

Choosing parallel line tools
You can use parallel line tools to draw a single set of straight lines, polylines or polygons, 
parallel line objects can also be extruded from existing straight edged objects. The 
appropriate parallel line tool is chosen from the Parallel line tools pop-up menu in the 
Tool palette.
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To choose a parallel line tool

1. Press and hold down the mouse button on the Parallel line tool in the Tool palette.

The Parallel line tools pop-up menu appears.

2. Holding down the mouse button, drag until the desired tool is highlighted, and 
release the mouse button.

The tool chosen appears in the Tool palette.

Parallel line tool options
Various options (alignment, end caps, line joints and distance between lines) can be set for 
parallel line objects. These options are found in the Parallel Line Setup dialog.

The parallel line tool options can be set as defaults to be used for all parallel objects 
drawn, or can be changed for some individual existing objects.

NOTE: Parallel line options for extruded parallel line objects cannot be changed once they 
have been drawn.

Setting default parallel line tool options

To set parallel line tool options to be used for all parallel line objects drawn

1. Ensure that nothing is selected on the drawing.

2. Either:

Parallel line

Parallel polyline

Parallel polygon

Extrude parallel line

Extrude parallel polyline
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• Press and hold down the Option key and click the Parallel line tools icon in the 
Tool palette, or

• Select a Parallel line tool in the Tool palette and choose Tool Options from the 
Options menu.

The Parallel Line Setup dialog appears.

3. Set the various options as desired. A complete description of the options available 
and their effects on parallel line objects follows later in this section.

4. Click OK to close the dialog.

The options set will be used for all parallel line objects drawn.

Setting parallel line tool options for selected objects

To set parallel line tool options for selected objects

1. Select the parallel line object you wish to change the attributes of.

2. Either:

• Press and hold down the Option key and click the Parallel line tools icon in the 
Tool palette, or

• Select a Parallel line tool in the Tool palette and choose Tool Options from the 
Options menu.

The Parallel Line Setup dialog appears.

3. Set the various options as desired. A complete description of the options available 
and their effects on parallel line objects follows later in this section.

4. Click OK to close the dialog.

The selected object will be changed to reflect your choices.

NOTE: Parallel line options for extruded parallel line objects cannot be changed 
once they have been drawn.

Alignment
There are three alignment choices for parallel line objects: left, center and right. The 
alignment options are represented by three icons at the top of the Parallel Line Setup 
dialog. The small arrow indicates what part of the line is active.
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Select the desired option by clicking the appropriate icon in the Alignment section of the 
Parallel Line Setup dialog.

Alignment controls how parallel lines, polylines and polygons are drawn and how editing 
affects them. Specifically, the alignment options determine what is the leading edge of the 
parallel line object and what part of the shape is active. For example, when align left is the 
current option, the left parallel line will be drawn on the grid and edit handles appear on 
the left line when the parallel lines are selected.

How the alignment options affect parallel lines

Align center

When Align Center is on, the cursor appears between the lines during drawing. The 
center of the two lines will lie on the grid. When the parallel lines are selected, the edit 
handles appear between the ends of the line segments.

Align left

The Align Left option is used to specify which of the parallel lines is active. The active line 
is the one that lies on the grid and is used to edit the parallel lines. If you draw parallel 
lines while the Align Left option is on, the active line is determined by the direction you 
first drag during the creation of the shape. In general, if you drag up, the left line is active. 
If you drag down, the right line is active.

Align right

As with Align Left, the Align Right option determines which of the two lines is active. 
When the Align Right option is on, the direction in which you first drag during creation 
determines which line is active. In general, if you drag up, the right line is active. If you 
drag down, the left line is active.

Alignment and parallel polylines

The active alignment option determines how the parallel lines pivot around each ending 
point. When you define the ending point for a side, the end point of the active line (or the 
center of the two lines in the case of center alignment) is used as the ending point of the 
side. The inactive line pivots around the ending point, following the movement of the 
mouse.
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End caps
You can draw parallel lines and polylines with butt end caps, that is, with line segments 
that join the ends of parallel lines. You can choose to draw parallel lines and polylines 
with no end caps, with an end cap at either end or with end caps at both ends. Extruded 
parallel lines and polylines can be drawn with or without a final end cap.

Select the appropriate icon from the End Caps section in the Parallel Line Setup dialog.

• Parallel lines drawn without end caps.

• End caps at the start of the parallel lines. (That is, the end at which you pressed and 
held down the mouse button and started to draw the lines.)

NOTE: Extruded parallel lines cannot have end caps at the start of the parallel line 
segment.

• End caps at the end of the parallel lines. (That is, the end at which you finished 
drawing the line or shape.)

• End caps at both ends of the parallel lines.

NOTE: Extruded parallel lines cannot have end caps at the start of the parallel line 
segment.
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Line joints
You can choose to draw parallel polyline shapes and polygons with line joints at the 
corners. When you choose this option, a line is drawn between the inside and outside 
lines where the sides meet. (This feature can be used to indicate miter joints.)

Select the appropriate icon from the Line Joints section in the Parallel Line Setup dialog.

NOTE: Extruded parallel lines cannot be drawn with line joints

Line width
You can specify the distance between parallel lines by entering a value in the Line Width 
field in the Parallel Line Setup dialog. The values you enter for the distance are real-
world values that reflect the current size units. For example, if you are working on a 
document in which Fractional Feet & Inches and the scale 1/4” = 1' were currently 
defined, if you entered “6” as the distance, the distance between the lines would represent 
6 inches in the real world.

NOTE: You can use patterns and colors to fill the gap between parallel lines. See Parallel fill 
pattern on page 3-27 and Parallel fill color on page 3-9.

Parallel lines
You can set the options for parallel lines (alignment, end caps, line joints and distance 
between lines) in the Parallel Line Setup dialog (see Parallel line tool options on page 2-56).

With
line joints line joints

Without
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Drawing a single set of straight parallel lines

To draw a single set of parallel lines

1. Choose the Parallel line icon from the Parallel line tools pop-up menu in the Tool 
palette.

2. Position the cursor on the point you want the parallel lines to start, then press and 
hold down the mouse button.

3. Drag until the lines are the desired length, and release the mouse button.

When you release the mouse button, edit handles appear at the ends of the parallel 
line object. These can be used to change the length and orientation of the lines.

NOTES:
• Hold down the Shift key while drawing a single set of parallel lines and angle of 
the lines will snap to 45° increments.
• The final point of a parallel line can be snapped to the mid point, end point or 
center point of some existing objects (see Line snapping on page 6-20).

Editing a pair of parallel lines

To edit a pair of parallel lines

1. Return to the pointer mode by clicking the Pointer tool in the Tool palette.

2. Select the parallel lines to be edited.

3. Position the cursor on one of the edit handles, then press and hold down the 
mouse button.

4. Drag in any direction until the lines are the desired length and orientation, and 
release the mouse button.

Parallel line
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Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or resize a single parallel line, the end of the parallel line will snap to the nearest grid 
intersection point.

• Hold down the Command key when drawing or resizing a parallel line to avoid 
the line snapping to the grid.

• Hold down the Option key when drawing a parallel line and the line length will 
snap to the nearest grid increment.

If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw a parallel line, it will snap to the angular grid.

• Hold down the Shift key when drawing a parallel line to avoid the line snapping 
to the angular grid.

Parallel polylines and parallel polygons
You can draw two types of multi sided irregular shapes using parallel lines: closed 
polygons and open polylines. A parallel polygon is a closed object made of three or more 
sides. It can be a complex, irregularly shaped object made up of many straight parallel line 
segments. A parallel polyline is an open object made of at least two straight parallel line 
segments. The line segments used for either type of object can be of any length and drawn 
at any angle.

You can set the options for parallel polylines and polygons (alignment, end caps, line 
joints and distance between lines) in the Parallel Line Setup dialog (see Parallel line tool 
options on page 2-56).

Drawing polygons and polylines with parallel lines
To draw an irregular polygon or polyline with parallel lines, you position the cursor and 
click to define the end points of the parallel lines that make up the shape.

To draw a polygon or a polyline with parallel lines

1. Choose the Parallel polygon or Parallel polyline tool from the Parallel line tools 
pop-up menu in the Tool palette.

2. Place the cursor at the point you want to begin drawing the object, then press and 
hold down the mouse button.

Parallel polyline

Parallel polygon
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3. Drag until you have created a parallel line that is the desired length and angle for 
the first side or line segment of the object.

4. Release the mouse button.

5. Without pressing and holding down the mouse button, move the cursor to draw 
the second parallel line segment.

6. When the second parallel line is the desired length and angle, click this point.

7. Without pressing the mouse button, move the cursor to draw the next parallel line 
segment.

8. When the parallel line is the desired length and angle, click this point.

You may decide that you want to change a parallel line segment after you have 
clicked to define its end point. You can change the length and orientation of the last 
parallel line segment drawn by using the Dynamic Editing feature.

9. To change the last parallel line segment drawn, move the cursor back to the last 
defined point and click it.

The previous parallel line will reattach to the cursor, allowing you to move the end 
of the parallel line to a new position on the drawing.

10. Move the cursor to a new position on the drawing and click it.

The parallel line will be drawn to the new position.

11. Continue to draw the rest of the object.
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12. When you reach the last point to be placed, double-click this place.

This double-click action completes the object.

• If you are drawing a parallel polygon, the last point you clicked will be connected 
to the starting point of the shape by a straight parallel line.

• If you are drawing a parallel polyline, the object will remain open.

NOTES:
• Hold down the Shift key while drawing a parallel polygon or polyline and the angle of 
the current parallel line segment will snap to increments of 45°.
• The final point of a parallel polyline can be snapped to the mid point, end point or 
center point of some existing objects (see Line snapping on page 6-20).

Changing the shape of parallel polygons and polylines
You can edit parallel polygons and polylines in the same way as you would normal 
polygons and polylines, see Changing the shape of an irregular polygon or a polyline on page 2-
35 for details.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or edit a parallel polygon or polyline, the ends of the parallel line segments or the edit 
handles will snap to the nearest grid intersection points.

• Hold down the Command key when drawing or editing a parallel polygon or 
polyline to avoid the lines or edit handles snapping to the grid.

• Hold down the Option key when drawing a parallel polygon or polyline and the 
line lengths will snap to the nearest grid increment.
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If there is an angular snapping grid set for the document (see Angle snap on page 6-16), 
when you draw a parallel polygon or polyline, the line segments will snap to the angular 
grid.

• Hold down the Shift key when drawing a parallel polygon or polyline to avoid the 
line segments snapping to the angular grid.

Extruding parallel lines and parallel polylines
MacDraft’s Extrude parallel line and Extrude parallel polyline tools are used to draw 
parallel lines or parallel polylines from existing straight-edged objects, such as lines, 
rectangles or polygons. Although the extruded lines are actually separate line segments, 
they give the appearance of parallel lines.

Lines can also be extruded from parallel-line objects, although the parallel line object must 
be broken down into its individual line components first. This is useful in adding interior 
walls to a floor plan, for example.

The Extrude parallel line and Extrude parallel polyline tools are located in the Parallel 
line tools pop-up menu in the Tool palette.

You can set the options for extruded parallel lines and polylines (alignment, end caps, line 
joints and distance between lines) in the Parallel Line Setup dialog (see Parallel line tool 
options on page 2-56).
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Extruding parallel lines from an edge or line

To extrude parallel lines from a straight-edged object or line

1. Choose the Extrude parallel line tool from the Parallel line tools pop-up menu in 
the Tool palette.

2. Position the cursor over the edge you wish to extrude the parallel lines from, then 
press and hold down the mouse button.

3. Drag until the extruded lines are the desired length and orientation, then release 
the mouse button.

The extruded parallel line segment appears on the drawing. It is added to the 
earlier object as a pair of line segments.

NOTE: Hold down the Option key to constrain the extruded parallel line to be 
perpendicular to the original edge and make its length snap to the currently active 
grid-snap distance.

Extruding parallel polylines from an edge or line

To extrude parallel polylines from a straight-edged object or line

1. Choose the Extrude parallel polyline tool from the Parallel line tools pop-up 
menu in the Tool palette.

2. Position the cursor over the edge you wish to extrude the parallel polylines from, 
then press and hold down the mouse button.

3. Drag until you have created an extruded parallel line that is the desired length and 
angle for the first segment of the object.

4. Continue to draw the extruded parallel polylines as per the instructions for 
drawing parallel polylines (see Drawing polygons and polylines with parallel lines on 
page 2-62).

Extrude parallel line

Extrude parallel polyline
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Extruding parallel lines or polylines from a parallel object

To extrude parallel lines or polylines from a parallel-line object

1. Choose the Extrude parallel line or Extrude parallel polyline tool from the 
Parallel line tools pop-up menu in the Tool palette.

2. Position the cursor over the parallel line object you wish to extrude the parallel 
lines or polylines from, then press and hold down the mouse button.

An alert appears asking if you wish to break the parallel line object into individual 
lines.

3. Click the Break Up button to break up the parallel line object and continue 
drawing the extruded parallel line or polylines.

The dialog will close and you will return to the drawing with the Extrude parallel 
line or Extrude parallel polyline tool still active.

4. Position the cursor over the line you wish to extrude the parallel lines or polylines 
from, then press and hold down the mouse button.

5. Continue drawing as for extruded lines, see Extruding parallel lines from an edge or 
line on page 2-66, or polylines, see Extruding parallel polylines from an edge or line on 
page 2-66.

Snap to grid
If there is a snapping grid set for the document (see Grid snap on page 6-14), when you draw 
or edit an extruded parallel line or polyline, the ends of the parallel line segments or the 
edit handles will snap to the nearest grid intersection point.

• Hold down the Command key when drawing or editing an extruded parallel line 
or polyline to avoid the lines or edit handles snapping to the grid.

Extrude parallel polyline

Extrude parallel line
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• Hold down the Option key when drawing an extruded parallel line or polyline 
and the initial parallel line segment will be constrained to be perpendicular to the 
original edge, and the line lengths will snap to the nearest grid increment.

�  The Marker Symbol

The Marker Symbol tool is used to add a registration-type marker to a drawing in one 
simple step.

Select the Marker tool, then click the drawing one or more times to add as many markers 
as you need; each marker is centered on the point you click. Leave the Marker Symbol 
tool by holding down the Command key and clicking a blank area of the drawing or by 
clicking the Pointer tool in the Tool palette.

Once a marker symbol is drawn, it exists as a group. It can be ungrouped to a circle and 
two crossed lines (see Grouping and ungrouping objects on page 5-26).

Adding marker symbols to a drawing

To add marker symbols to a drawing

1. Choose the Marker symbol tool from the Miscellaneous tools pop-up menu in the 
Tool palette.

2. Place the cursor where you want the marker symbol to appear on the drawing and 
click this place.

The marker symbol appears on the drawing centered on the point specified.

3. To add more marker symbols, repeat steps 2 as many times as necessary.

4. When you have finished adding markers, click the Pointer tool in the Tool palette, 
or hold down the Command key and click a blank area of the drawing.

Marker symbol tool
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�  Datum points

Each object in MacDraft has a datum point; this is a reference point used when you paste 
the object, rotate it, or manipulate it in other ways. For example, the datum point for a 
rectangle is the top left corner.

Grouped objects also have datum points. The default datum point for a grouped object is 
the default datum point of the item in the group that is farthest back on the drawing.

�  Reshaping objects

There may be occasions when you want to reshape an object so that straight lines and 
sharp corners become curved lines and rounded corners; the irregular lines of an object to 
smooth lines. You can accomplish this conversion by using the Reshape submenu in the 
Edit menu.

The objects that the Reshape command can modify are polygons (drawn with the 
irregular polygon tool), polylines, freehand lines and freehand shapes.

Reshaping an object

To reshape an object

1. Select the object you want to reshape by clicking it.

2. Open the Edit menu and drag down until Reshape is highlighted.

Object on the back plane
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The Reshape submenu appears.

3. Choose Smooth or Unsmooth (detailed explanations of the choices follow) and 
release the mouse button.

The object will be reshaped as you requested.

Reshape options
The Smooth and Unsmooth commands affect different shapes in different ways.

Reshaping polygons and polylines
A polygon can be smoothed to a curve that lies inside the original object (intersecting the 
midpoints of each line segment). When the smoothed polygon is selected, its original 
shape appears as a ghost outline.

A polyline can be smoothed to a curve that intersects the midpoints of each line segment 
of the original object, except for the segments closest to the ends. That is, the curve will 
skip over the first and last midpoints of the original polyline.

NOTE: A polygon or polyline can be smoothed only once.

If you select a polygon or polyline that has been smoothed using the Smooth command, 
and choose Unsmooth, the object will revert to its original shape.

Polyline Smoothed polyline

Selected smoothed polyline
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Reshaping freehand lines and shapes
A freehand line or shape can be smoothed to a curve that lies close to the original object 
and passes near to the original vertices (the new edit handles appear at the old vertices). 
This new shape can be smoothed repeatedly until the desired effect is obtained.

If you select a freehand line or shape that has been smoothed using the Smooth 
command, and choose Unsmooth, the last stage in the smooth process will be undone.

�  Resizing objects

Objects can be resized manually by dragging their edit handles, as discussed in the 
sections about drawing the various types of objects. MacDraft also includes a Resize 
palette. This provides a method for resizing objects by typing exact size values and gives 
you more precise control over the size of objects on your drawing.

Displaying the Resize palette

To display the Resize palette

• Choose Resize from the Palettes submenu in the View menu, or

• Choose Resize from the pop-up menu at the bottom left of the document window.

The Resize palette appears.

Freehand shape Smoothed freehand shape

Close button
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The Resize palette shows the size values and position of the currently selected object, if 
nothing is selected, the palette will not show any values. The palette can be positioned 
anywhere on screen as needed.

Resizing objects
Different types of objects are resized in different ways. For example, you can resize a 
rectangle by specifying the exact height and width of the rectangle, whereas resizing an 
arc includes entering various angle values and a radius length. The individual sections 
following describe the resizing options for the different types of objects and the 
information you can enter to resize them.

You can resize objects by entering absolute or relative values for the whole object or, for 
some objects, a selected point on the object. Measurements are defined in the current 
layer’s scale and units, and changes are applied relative to the object’s datum point (see 
Datum points on page 2-69), unless the Select Point button is used. When relative values are 
entered, positive values increase measurements, negative values decrease them.

NOTE: When objects are resized, any dimension objects linked to them will be 
automatically resized as well.

Absolute resize values

• For a whole object, enter the values for the desired dimensions for the object.

• For a point on the object, enter the values for the desired location of the point.

Relative resize values

• For a whole object, enter values to be added to the current dimensions of the object.

• For a point on the object, enter values to move the point by.
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Resizing a whole object by absolute values

In general terms, to resize an object by changing its absolute size values

1. Select the object you want to resize.

2. Ensure the Absolute radio button is on.

3. Enter the new size values (such as Width and Height) that you want for the object.

4. Click the Apply button or press the Return or Enter key.

The new size will be applied to the object.

NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds.

Resizing an object by changing the absolute values of one point

To resize an object by editing a single edit handle

1. Select the object you want to resize.

2. Ensure the Absolute radio button is on.

3. Click the Select Pt button on the Resize palette.

A select point gun sight cursor appears on the drawing.

4. Position the cursor on the point (edit handle) you want to edit and click it.
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The Resize palette shows the location of the point.

5. Enter values for the new location for the edit handle and click the Apply button or 
press the Return or Enter key.

The new values will be applied to that edit handle, moving it and so resizing the 
object.

NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds.
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Resizing a whole object by relative values

In general terms, to resize an object by changing its relative size values

1. Select an object. Its current measurements are shown in the Resize palette.

2. Click the Relative button in the Resize palette.

3. Enter values to increase (positive numbers) or decrease (negative numbers) the 
measurements to be changed.

4. Click the Apply button or press the Return or Enter key.
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The measurement changes are applied to the object, making the appropriate 
dimensions larger or smaller.

NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds.

Resizing an object by changing the relative values of one point

To resize an object by editing a single edit handle

1. Select an object. Its current measurements are shown in the Resize palette.

2. Click the Relative radio button in the Resize palette.

3. Click the Select Pt. button in the Resize palette.

The select point gun sight cursor appears on the drawing. 

4. Position the cursor on the point (edit handle) you want to edit and click it.

Zeros are shown in the Resize palette for the horizontal and vertical changes, 
showing that no new values have been entered.

5. Enter values to increase (positive numbers) or decrease (negative numbers) the 
point’s position.



Chapter 2 - Creating and editing objects 2 - 77

6. Click Apply or press the Return or Enter key.

The measurement changes are applied to the selected point, moving it and so 
resizing the object.

NOTE: If the resize operation requires the object to be enlarged beyond the drawing area, 
a system beep sounds.

Resize units
The Resize palette uses the scale and units of the current layer. When you select an object 
with the Resize palette visible, the values shown will reflect the scale. When you enter 
values to resize an object, you should use values appropriate to the current scale.

WARNING: If you enter unscaled units in a scaled drawing (for example, a width “4" ” in 
a 1/8”=1' drawing), you may get unexpected results (in that example, the four inches 
would appear in the drawing as 1/24 of an inch on screen and on paper).

If you don’t specify units with the values you enter, MacDraft will interpret the values 
according to the document’s current size units. The size units are set using the Document 
Scale and Units dialog (see Document units and scale on page 6-21).

Below are some examples of valid size and coordinate entries for some of the available 
types of size units.

Decimal feet and inches

12.0'
110.3'
10'
10 in
12.3 is interpreted as 12.3'
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Fractional feet and inches

23" = 1’11”
1 3/4”
1' 10-3/8”

Fractional inches

1"
123-3/4”
15 1/2
1/2
2-1/4
You can enter values greater than 12 inches if fractional inches are the current size units.

Resizing lines and parallel lines
Lines drawn with the unconstrained, constrained, parallel and special line tools can all be 
resized in the same way.

Length & angle

Changes the desired length and angle of the line. The specified angle is measured relative 
to the X-axis and the last point drawn on the line, this “finishing point”, will normally be 
the one that moves.

Select point

Allows you to select which end point of the line moves when you apply a new length or 
angle value.

NOTE: If you change the angle of a constrained line, it will become an unconstrained line, 
as constrained and special lines are only constrained when they are first entered.
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Resizing rectangles

Square corner rectangles

Width and height

Changes the width and height of a rectangle. For example, to enlarge a 1" x 1" rectangle to 
3" x 3", enter 3" in both fields. A diagonally drawn rectangle will be resized by shifting its 
bottom edge or right-hand edge (or both).

Select point

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

Rounded-corner rectangles
With proportional and constant corners
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Width, height, and radius

Changes the width and height of a rectangle and the radius of the corner arc. Normally, 
the width and height values resize the rectangle by shifting its bottom edge or right-hand 
edge (or both).

Select point,

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

With elliptical corners

Width, height, X-radius and Y-radius

Changes the width and height of a rectangle, and the vertical and horizontal radii of the 
elliptical corner arc. Normally, the width and height values resize the rectangle by shifting 
its bottom edge or right-hand edge (or both).

Select point

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

Resizing regular polygons
Regular polygons are resized in the same way as groups (see Resizing groups on page 2-86).
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Resizing circles

Drawn by diameter

Diameter

Changes the diameter of the circle. The last point drawn normally moves as the circle is 
resized.

Select point

Allows you to select which end of the diameter line moves when you apply a new 
diameter value.

Drawn by radius

Radius

Changes the radius of the circle. The handle on the circle’s circumference normally moves 
as the circle is resized.

Select point

Allows you to select which end of the radius line moves when you apply a new radius 
value. For example, if you click Select Pt and select a radial circle’s center handle, then 
enter a new radius, the center handle moves as the circle is resized.
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Drawn by three points

X and Y locations

Changes the X and Y coordinates for the circle’s three edit handles. Absolute coordinates 
you specify are measured from the zero origins of the rulers.

Select point

Use of the Select Pt button has no additional effect on this object.

Resizing ellipses

Width and height

Changes the width and height of an ellipse. A diagonally drawn ellipse will normally be 
resized by shifting its bottom right edit handle, a centered ellipse will normally be resized 
without the center point moving.
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Select point

Allows you to select what portion of the ellipse moves when you apply a new width or 
height (or both). For example, if you click Select Pt and select the ellipse’s top middle 
handle, then enter a new height, the top moves up.

Resizing arcs

Drawn by radius

1st A°

Changes the angle of the arc’s starting point, measured in relation to the X-axis.

End A°

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

Radius

Changes the radius of the arc.

Select point

Use of the Select Pt button has no additional effect on this object.
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Drawn by three points

X & Y locations

Changes the X and Y coordinates for the arc’s three edit handles. Absolute coordinates 
you specify are measured from the zero origins of the rulers.

Select point

Use of the Select Pt button has no additional effect on this object.

Elliptical arcs

1st A°

Changes the angle of the arc’s starting point, measured in relation to the X-axis.
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End A°

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

X-radius and Y-radius

Changes the horizontal and vertical radius of the arc.

Select point

Use of the Select Pt button has no additional effect on this object.

Resizing polygons and polylines, (including parallel polylines 
and polygons) freehand shapes and curves
Because of the complexity of these objects, you can edit them only by using the Select 
Point cursor.

For example, if an object has several edit handles, each handle cannot be shown in the 
Resize palette. Instead, you use the Select Point button to select a single handle, then 
specify a new location for it on the drawing.

X and Y coordinates

Changes the X and Y coordinates of a selected handle. Absolute values are measured from 
the zero origins of the rulers.

Select point

Allows you to select the handle to edit.

NOTE: The Resize palette treats the direction handles on Bezier curve objects like any 
other edit handles.
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Resizing groups

Percent

Changes the size of the group proportionally by a percentage of its current size. Absolute 
values larger than 100% or positive relative values increase its size; absolute values 
smaller than 100% or negative relative values reduce it. Normally, the lower right corner 
moves as the group becomes larger or smaller.

Width and height

Changes the width and height of the group. A group will normally be resized by shifting 
its bottom edge or right-hand edge (or both).

Select point

Allows you to select which corner of the groups bounding frame moves when you resize 
it. For example, if you click Select Pt and select the top left handle of the groups bounding 
frame, then enter an absolute percentage value of 200%, the top edge moves up and the 
left edge moves left.

Resizing groups manually
There may be times when you would like to enlarge or reduce the size of a grouped object. 
MacDraft gives you the ability to change a group’s size proportionally or non-
proportionally (vertically or horizontally) by dragging the groups edit handles.

By changing the size of a group proportionally, you can maintain the original shapes of 
the individual objects within the group. Objects within the group become larger or smaller 
without becoming distorted.

To resize a group of objects proportionally

1. Select the group you want to resize.
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2. Position the tip of the pointer on one of the edit handles on the corners of the 
group.

3. Press and hold down the mouse button.

4. Drag until the group is the size you want, and release the mouse button.

5. The grouped object will be changed in size proportionally to its original size.

To resize a group of objects non-proportionally

1. Select the group you want to resize.

2. Position the tip of the pointer on one of the edit handles on the corners of the 
group.

3. Press and hold down the mouse button and press the Option key.

4. Holding down the mouse button and the Option key, drag until the group is the 
size you want, and release the mouse button and Option key.

Resizing dimension objects
When objects are resized, any dimension objects linked to them will be automatically 
resized as well. Also, when dimension objects are resized, if they are linked to an object, 
the object will also be resized. 

Linear and radial dimensions

Length

Changes length of the dimension object. Normally, the first reference point (the left end of 
a diameter or the center of a radius) remains fixed.

Select point

Allows you to select which reference point moves when you apply a new length.
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Angular dimensions

1st A°

Changes the angle of the dimension’s starting point, measured in relation to the X-axis.

End A°

Changes the angle of the dimension’s ending point, measured in relation to the X-axis.

Radius

Changes the radius of the dimension object.

Select point

Use of the Select Pt button has no additional effect on this object.

�  Expand and contract objects

All MacDraft objects can be increased or reduced in size by multiplying or dividing the 
object’s dimensions by specified values. You can choose whether or not to maintain the 
object’s proportions. The Expand and Contract commands in the Edit menu are used to 
resize objects in this way.

Expand

To resize an object using the Expand command

1. Select the object to be expanded.

2. Choose Expand from the Edit menu.
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The Expand dialog appears.

3. To maintain the object’s proportions, ensure that the Linked checkbox is on.

4. To change the object’s proportions, click the Linked checkbox to turn this option 
off.

5. Enter a value to multiply the X dimension of the object by.

NOTE: If the Linked checkbox is on, the same value will automatically be entered 
in the Y field.

6. Enter a different value to multiply the Y dimension of the object by, if necessary.

7. Click the OK button.

8. The dimensions of the object are multiplied by the specified values and the object 
is expanded around its center point.

NOTE: The screen shot below shows a copy of the original shape in front of the 
expanded shape.

Contract

To resize an object using the Contract command

1. Select the object to be contracted.

2. Choose Contract from the Edit menu.
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The Contract dialog appears.

3. To maintain the object’s proportions, ensure that the Linked checkbox is on.

4. To change the object’s proportions, click the Linked checkbox to turn this option 
off.

5. Enter a value to divide the X dimension of the object by.

NOTE: If the Linked checkbox is on, the same value will automatically be entered 
in the Y field.

6. Enter a different value to divide the Y dimension of the object by, if necessary.

7. Click the OK button.

8. The dimensions of the object are divided by the specified values and the object 
contracts around its center point.

NOTE: The screen shot below shows a copy of the original shape behind the 
contracted shape.

�  Editing bitmap images

There may be occasions when you want to enlarge, reduce, distort or clip the shape of a 
bitmap image produced from a program such as MacPaint®. MacDraft allows you to 
enlarge or reduce the size of a bitmap image without distorting the image; to change the 
size of a bitmap image in one direction only; and to clip an image.
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Resizing bitmap images

To resize a bitmap image in one direction only

1. Select the bitmap image you want to resize.

2. Position the cursor on one of the edit handles in the middle of the bitmap’s 
bounding box, (that is, one of the handles on the top, bottom, left or right side).

3. Press and hold down the mouse button.

4. Drag until the bitmap image is the size you want.

5. Release the mouse button. The image will be resized in the direction chosen.
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To resize a bitmap image in two directions without maintaining its proportions

1. Select the bitmap image you want to resize.

2. Position the cursor on one of the corner edit handles.

3. Press and hold down the mouse button.

4. Drag until the bitmap image is the size you want.

5. Release the mouse button. The image will be resized, in two directions, but it could 
be distorted.

To resize a bitmap image while maintaining its proportions

1. Select the bitmap image you want to resize.

2. Position the cursor on one of the corner edit handles.
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3. Hold down the Shift key, then press and hold down the mouse button.

4. Holding down the mouse button and the Shift key, drag until the bitmap image is 
the size you want.

5. Release the mouse button and the Shift key. The image will be resized, and its 
proportions maintained.

NOTE: Bitmap and pixel map objects can be made “palette resizable” by grouping them to 
themselves. For example, place a bitmap image into your drawing, select it, and choose 
Group from the Arrange menu (see Grouping and ungrouping objects on page 5-26). You can 
now resize the group using the Resize palette (see Resizing groups on page 2-86).
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Clipping bitmap images

To clip a bitmap image

1. Select the bitmap image you want to clip.

2. Position the cursor on one of the edit handles.

3. Hold down the Shift and Option keys, then press and hold down the mouse 
button.

4. Holding down the mouse button and the Shift and Option keys, drag to select a 
portion of the bitmap.

5. Release the mouse button and the Shift and Option keys. The image will be 
clipped, and only the portion selected will be shown.
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MacDraft doesn’t normally discard the unseen part of a cropped image; you can move the 
edit handles back out any time to reveal the unclipped image.

However, if you save a drawing with a cropped image in the PICT or enhanced PICT 
formats (see PICT or enhanced PICT documents on page C-2) or use the Copy command to 
copy it to the Clipboard or another application (see Cut/copy and paste on page 5-6), the part 
of an image outside the cropped edge will be lost.

On the other hand, cutting a cropped image from a drawing, pasting it to the Clipboard, 
then copying it back into MacDraft will reduce the document’s size on disk, because the 
cropped data discarded during the cut/paste operation will no longer be stored.

NOTES:
• MacDraft does not allow cropping of grouped objects. You must ungroup any bitmap 
image you wish to crop (see Grouping and ungrouping objects on page 5-26).
• Some pixel maps and bitmaps, when ungrouped, become a set of several objects that 
together form one image. Each of these objects can be cropped individually.
• If a bitmap has a very low resolution (for example, if it has been resized to be much 
larger than it was originally), it may resize itself slightly during cropping. This is because 
its own pixels may be larger than the standard screen pixels. The image will expand or 
shrink so that none of its own large pixels are split by the cropped edge.
• MacDraft stores each pixel map only once in each document file. This means that you 
can copy a pixel map within a MacDraft drawing without increasing the drawing’s size on 
disk. 

�  Reversing changes

If you do something unintentionally or want to correct a mistake, MacDraft allows you to 
reverse certain actions. The Undo command reverses execution of the last action; the Redo 
command executes the previously reversed action; the Revert command returns you to 
the last saved version of the document.

NOTE: In most cases, in order to undo or redo a command, you must choose Undo or 
Redo before you perform any other action. However, there is an exception to this rule. You 
can switch back and forth between documents, performing actions on the various open 
documents and MacDraft will remember the last action performed in each document. This 
allows you to return to an open document and undo or redo the last action you performed 
in it.
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Undo
If you choose a command or perform an action and then wish that you had not done so, in 
most cases you can choose Undo to reverse the action or the effects of the command.

To undo an action or command

• Open the Edit menu and choose Undo.

If the action or command can be undone, the command will be listed beside Undo 
at the top of the Edit menu (Undo Delete after a deletion, for example).

If the action or command cannot be undone, Undo will be dimmed in the Edit 
menu.

Redo
You can use the Redo command to re-execute an action or command that you just 
reversed using the Undo command. By using Undo and Redo you can experiment with 
your drawing and MacDraft’s features. For example, you could delete an object, observe 
the effect on your drawing, and choose Undo to reverse the deletion. If you then decided 
that the deletion produced the desired effect, you could choose Redo and the same object 
would be re-deleted.

To redo an action or command

• Open the Edit menu and choose Redo.

The action or command you just reversed by choosing Undo will be listed beside 
Redo at the top of the Edit menu (Redo Delete after undoing a delete, for 
example).
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Revert
If you execute a command that cannot be undone using the Undo command, or you make 
changes you are unable to delete but do not wish to save, you can eliminate any unsaved 
changes by reverting to the last saved version of your document.

To revert to a previously saved version of your document

1. Open the File menu and choose Revert.

A dialog appears asking you to confirm that you want to proceed. The dialog will 
show you the date and time when the document was last saved.

2. Click one of the following buttons

• Revert: To revert to the last saved version of the document.

• Cancel: To return to the current version of your document.

WARNING: If you revert to a previously saved version of the document, all 
changes made since the last time it was saved will be deleted.

�  Drawing views

MacDraft offers various features for changing the view of your drawing. Using these 
features you can move the drawing in the document window so that you view a different 
part of the drawing, or you can zoom in or out on a portion of the drawing to see it in 
more detail or to see an overall view. Any view can be saved.

Changing the position of the drawing in the document window
To change the position of the drawing within the document window, you can scroll the 
drawing, use the Hand tool or use the arrow keys on the keyboard.

NOTE: You can easily return to the top left corner of your drawing by using the Home 
View command (see Home view on page 2-106).

Scrolling
Scrolling in MacDraft drawings is accomplished just as it is in other Macintosh document 
windows by using the scroll bars at the edges of the windows. See your system 
documentation for details.
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The Hand tool
The Hand tool provides an alternative method of moving the drawing within the 
document window. 

To use the Hand tool

1. Click the Hand tool in the Tool palette.

The cursor turns into a hand.

2. Position the cursor over the drawing area, then press and hold down the mouse 
button.

3. Drag in any direction.

Hand tool
Pointer tool
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The view moves with the hand.

4. Release the mouse button when the desired section of the drawing is shown in the 
document window.

NOTE: You can also activate the Hand tool by pressing the space bar while the 
Pointer tool is on.

Zooming in or out on a drawing
When you work with a large document you may need to see the entire drawing at one 
time or you might need to obtain a close up view of a particular area so that you can add 
small details. MacDraft gives you the possibility to change the view of your drawing in 
either of these cases by providing features that allow you to zoom in or out on an area of 
the drawing. Zoom controls are provided via the Zoom tool in the Tool palette, by 
commands in the View menu and by a pop-up menu at the bottom of the document 
window. There are also features that allow you to easily return to a preset or saved view.

MacDraft usually allows you to magnify a drawing up to 32 times, or down to -8 times its 
normal size.
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NOTE: The current magnification of the drawing view is shown at the bottom of the 
document window.

NOTE: If you zoom out several consecutive times, and have text on your drawing, the text 
becomes too small to be displayed and only its edit handles will be shown.

Using the Zoom tool

Click the Zoom tool in the Tool palette to select it.

NOTE: You can also activate the Zoom tool by holding down the Shift key and clicking 
the Pointer tool at any time.

Zoom in

To use the Zoom tool to zoom in on an area of the drawing

1. Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to show that 
you are about to increase the magnification of the drawing.

Zoom tool
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2. Position the cursor over the area of the drawing you wish to zoom in on and click.

The magnification of the drawing view will be increased one level, and the view 
will be centered around the position of the cursor.

3. Continue clicking to zoom in further.

Zoom out

To use the Zoom tool to zoom out on an area of the drawing

1. Select the Zoom tool.

2. Press and hold down the Option key.

The cursor will change to a magnifying glass with a minus sign inside it to show 
that you are about to decrease the magnification of the drawing.

3. Position the cursor over the area of the drawing you wish to zoom out on and click.
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The magnification of the drawing view will be decreased one level, and the view 
will be centered around the position of the cursor.

4. Continue clicking to zoom out further.

Marquee zoom

The Zoom tool can also be used to perform marquee zooms.

To use the Zoom tool to perform a marquee zoom

1. Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to show that 
you are about to increase the magnification of the drawing.

2. Position the cursor over the drawing.

3. Press and hold down the mouse button, and drag over the area you want to zoom 
in on.

The inner rectangle shown in the screen shot above is the area selected with the 
Zoom tool. The outer rectangle represents the actual area that will be shown in the 
document window when the mouse button is released.
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4. Release the mouse button to display the portion of the document selected.

Zoom commands
The Zoom commands are found in the Zoom submenu in the View menu.

NOTE: You can choose Zoom commands several consecutive times, each time further 
increasing or decreasing the level of magnification of your view.

Zoom out

To use the Zoom out commands

• Choose Zoom Out 2X or Zoom Out 4X from the Zoom submenu in the View 
menu.

The magnification of the drawing view will be decreased by the specified amount.
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Zoom In

To use the Zoom in command

1. Choose Zoom In 2X or Zoom In 4X from the Zoom submenu in the View menu.

The view finder box and a cross cursor appears on your drawing. This gives you a 
visual indication of the portion of your drawing that will be included in the 
magnified view.

2. Move the cursor to position the view finder over the area of the drawing you want 
to zoom in on and click.
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The magnification of the drawing view will be increased by the specified amount, 
and the selected portion will be shown in the document window.

NOTE: If the complete zoomed in view will fit in the document window, the view finder 
will not be displayed; the new view will be displayed immediately.

Magnification pop-up menu
The current magnification of the drawing view is shown at the bottom of the document 
window. If you click this area, a magnification pop-up menu appears.
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• Choose a magnification value from this pop-up menu to zoom in or out on your 
drawing.

Restore previous zoom
The Restore Previous Zoom function allows you to return to the previous magnification 
of your drawing, regardless of the current magnification.

To return to the previous magnification

• Choose Restore Previous Zoom from the View menu.

The view will zoom in or out to the previous magnification.

NOTE: You can use this command to alternate between two magnification levels. 
For example, you could do some detailed editing at high magnification, use 
Restore Previous Zoom to examine the whole image, then use Restore Previous 
Zoom again to zoom back in and continue the detailed work.

Home view
The view which appears on the screen when you first open a MacDraft document is called 
the Home View. This view shows the an unmagnified view of the upper left corner of the 
document.

To display the home view

• Choose Home View from the View menu.

An unmagnified view of the upper left corner of the document is shown.

1:1 tool
You can easily return to an unmagnified view of the current area of the document by using 
the 1:1 tool in the Tool palette. This is useful if you have zoomed in on a detail and now 
want to see it at single magnification, but don’t want to return to the upper left corner of 
the drawing as when using the Home View command (see Home view on page 2-106).

To return to an unmagnified view of the current working area

• Click the 1:1 tool on the Tool palette.

The view will be changed to an unmagnified view of the current area.

1:1 tool
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Interrupting the screen redraw
If you are working on a large, complicated drawing and you perform an action (such as 
zooming) that requires the screen to be redrawn, it may take some time for the screen 
redraw to be completed. If you decide that you want to interrupt the screen redraw before 
it is completed, you can do so.

To interrupt the screen redraw

1. Press and hold down the Command key.

2. While holding down the Command key, press and hold down the period key (.) on 
the keyboard.

To redo the screen redraw

1. Press and hold down the Option key.

2. Click the Pointer tool icon in the Tool palette.
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Chapter 3 - Changing the appearance of objects

In many drawings, you may want to change the appearance of objects to help differentiate 
between them. You can change their appearance by filling objects with washes (solid fills) 
and patterns; by drawing lines and object borders with different colors, patterns, line 
weights, line styles and pen styles; by drawing lines with different end marks; and by 
choosing different positions for object borders.

You can define attributes for fills and lines that will be applied to all objects you draw or 
you can change the attributes of existing objects.

When the application is launched, the default values are white fill, black pen, no pattern, 
line weight 1 point, plain line style.

�  Object attributes

Most attributes are chosen from various pop-up menus on the Attribute palette or the 
indicator boxes at the bottom left of the document window. Others are chosen from the 
Options menu.

The Attributes palette

Displaying the Attribute palette

To open the Attribute palette

• Choose Attribute from the Palettes submenu in the View menu, or

• Choose Attribute from the pop-up menu at the bottom left of the document 
window.

Fill color Fill pattern

Parallel line fill Parallel line pattern

Pen fill Pen pattern

Line weight

Line style
End marks

Close button
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Selecting attributes using the Attributes palette
Selecting attributes is discussed in detail in later sections of this chapter, but in general:

• Change the attributes of existing objects by selecting the object, opening the 
appropriate menu in the Attribute palette, then making your choice.

• Change the drawing’s default attributes (the fill, line weight and so on that will be 
applied to all new objects you draw) by making sure nothing is selected, then 
opening the appropriate menu and choosing an attribute.

The fill and line indicator boxes offer an alternative method of selecting some attributes.

The fill and line indicator boxes
The default attributes for the fill color or pattern and the line weight are shown in the Fill 
and Line indicator boxes in the lower left corner of the document window.

Selecting attributes using the fill and line indicator boxes
The Fill and Line indicator boxes can be used to select attributes by accessing the 
appropriate pop-up menu and selecting the desired attribute.

Opening the attribute pop-up menus from the fill and line indicator boxes

To open the Fill color and pattern pop-up menus

• Click the Fill color/pattern box.

• Hold down the Command key and click the Fill color/pattern box to open the 
alternate pop-up menu.

To open the Parallel line fill color and pattern pop-up menus

• Hold down the Option key and click the Fill color/pattern box.

• Hold down the Option and Command keys and click the Fill color/pattern box to 
open the alternate pop-up menu.

To open the Pen color and pattern pop-up menus

• Hold down the Control key and click the Fill color/pattern box.

• Hold down the Control and Command keys and click the Fill color/pattern box to 
open the alternate pop-up menu.

Fill color/pattern Line weight
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To open the Line weight pop-up menu

• Click the Line weight box.

To open the Line style pop-up menu

• Hold down the Option key and click the Line weight box.

Default attributes
The attributes that you can select for objects before you draw them are Fill color and 
pattern, and Parallel line fill color and pattern. The pen attributes (that is, the attributes 
associated with lines and object borders) that you can define for objects before you draw 
them include pen style, color and pattern, line weight (thickness), line style (solid and 
dashed lines), end marks (symbols at the ends of lines), and border position. The option 
for each of these attributes that is currently active is called the ‘default attribute’.

The current default fill and pen attributes appear on the lines and borders of the objects 
you draw. 

NOTE: You cannot apply both a fill color and fill pattern to an object unless you define a 
colored fill pattern (see Customizing patterns on page 3-13).

When nothing is selected on the drawing, the default attributes are shown on the 
Attributes palette. When an object is selected, the Attributes palette shows the attributes 
of that object.

Setting default attributes

To change the current default attributes for fills and lines

1. Activate the Pointer tool on the Tool palette.

NOTE: Make sure that nothing is selected on the drawing.
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2. From the pop-up menus on the Attribute palette (or the fill and line indicator 
boxes), choose the fill and/or line attributes you want to apply to all objects you 
create.

The attributes you choose will automatically be applied to all objects until you 
make other choices for the default attributes.

Selecting attributes for specific objects
You can change the fill and line attributes for selected objects without affecting the default 
fill and line attributes.

To define the fill and/or line attributes for selected objects

1. Select the object or objects you want to change.

2. From the pop-up menus on the Attribute palette (or the fill and line indicator 
boxes), choose the fill and/or line attributes you want to apply to the selected 
objects.

The chosen attributes will be applied only to the selected objects. The default 
attributes will not be changed.

�  Using color

With MacDraft you can use color in a variety of ways: to fill objects with solid colors, to fill 
objects with color patterns, to draw the borders of objects and to color text. The use of 
solid colors is referred to as a “wash,” and the use of colors to draw lines and object 
borders is referred to as the “pen color.” The color you choose for the pen is applied to text 
as well. You can also use colors in fill patterns and to fill the gaps between parallel lines.
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Choosing the number of colors to display
A color Macintosh system is capable of reproducing over 16 million colors, but the 
number of colors you can display depends on the amount of video RAM (Random Access 
Memory) in your computer, and on the specification of your monitor.

There are certain trade-offs to be aware of in choosing the number of colors to set your 
monitor to display. If you choose to display millions of colors, the rate at which the screen 
is redrawn will be slowed down. If you choose to display fewer colors, the screen redraw 
will be faster, but there will be fewer color choices available to you, and the system may 
not be able to display all of the colors used in an existing document. The system will 
attempt to display all the colors used in an existing document by using a process called 
‘dithering’. With dithering, the system clumps together pixels of different colors to 
simulate the specified color.

To set the number of colors to display

The display choices available to you will be determined by the specifications of your 
monitor and the system software you are running. Refer to the system software 
documentation for details of setting the number of colors to display on your monitor.

NOTE: If you want to use only grayscale, but you have a color or true monochrome 
monitor, you will still be able to access color items, such as Edit Colors (see Editing colors 
on page 3-6), but in 256 shades of gray.

The color table
The color table contains the colors used in a document. Each new document contains a 
number of preset colors, which you can edit. The preset colors and the colors you edit or 
create are stored in the document’s color table.

The color table is represented on your screen as a submenu that shows all the preset colors 
and all the colors that have been used in the document.

The colors in the color table can be chosen from the Attribute palette, the Fill indicator 
box and the Edit Colors command in the Options menu.
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NOTE: When you paste objects from a different document that has colors that are not 
present in the target document’s color table, the colors from the source document are 
preserved in the objects that are pasted, but are not added to the target document’s color 
table.

Editing colors
You can edit the existing colors in the color table to add your own colors.

When you edit an existing color, the existing color is replaced with the new color in the 
color table.

NOTE: If you edit a color that has been used in the document, the objects that contain the 
edited color will be updated with the new color.

To edit a color in the color table

1. Choose Edit Color from the Options menu.

The color table appears.

2. Holding down the mouse button, drag through the table until the color you want 
to edit is highlighted.

3. Release the mouse button.

The Color Picker dialog appears.

NOTE: You cannot edit the No fill (*), the solid white or the solid black colors. If 
you try to edit one of these colors, the Color Picker dialog will not open, and an 
alert will inform that you are unable to modify this fill.
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4. Use the controls in the Color Picker dialog to choose a new color.

NOTE: The Color Picker dialog is specific to the operating system. For full details 
on how to use it refer to the operating system documentation.

5. When you have chosen a new color, click the OK button to close the Color Picker 
and return to MacDraft.

The new color you chose replaces the color you selected to edit.

Object fill color
You can use a solid color to fill the interiors of objects. Filled objects are opaque and you 
can select them by clicking their borders or anywhere within them. If a filled object is on 
top of another object, it hides the object beneath it from view. 
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Selecting the fill color

To select the fill color

1. Open the Fill Color pop-up menu in the Attribute palette.

2. Drag until the fill color you want is highlighted.

3. Release the mouse button. The selected fill color will be shown on the Attribute 
palette.

NOTES:
• If you choose ‘* ‘(for No fill) from the Fill Color submenu as the current fill color, 
the objects you draw will be wire frame shapes.
• You must draw polylines, freehand lines and curves with No fill if you want end 
marks to appear on the lines (see End marks on page 3-36).

You can change the fill color before or after you draw the object.

Drawing an object with a selected fill color

To draw an object with a selected fill color

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Select the desired fill color from the Fill Color pop-up menu in the Attribute 
palette.

3. Draw an object.

The object will be drawn with the specified fill color.

The Fill Color Indicator box in the lower left corner of the window will change 
color to indicate the color you chose.

NOTE: The chosen fill color will be used for objects until you choose another fill 
color as the default.
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Changing the fill color of an existing object

To change the fill color of an existing object

1. Select the object to change the fill color of.

2. Choose the desired fill color from the Fill Color pop-up menu in the Attribute 
palette.

The fill of the selected object will be changed to reflect the chosen fill color.

Parallel fill color
MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and closed 
parallel polygons) can include fill colors (including No Fill) between their component 
edges (see Drawing parallel line objects on page 2-55).

NOTE: In addition to parallel fills, parallel objects can also have pen colors, patterns and 
object fills.

Selecting the parallel fill color

To select the parallel fill color

1. Open the Parallel Fill color pop-up menu in the Attribute palette.

2. Drag until the parallel fill color you want is highlighted.
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3. Release the mouse button. The selected parallel fill color will be shown on the 
Attribute palette.

You can change the parallel fill color before or after you draw the parallel line 
object.

Drawing a parallel line object with a selected fill color

To draw a parallel line object with a selected fill color

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Select the desired parallel fill color from the Parallel Fill color pop-up menu in the 
Attribute palette.

3. Draw a parallel line object.

The object will be drawn with the specified fill color.

NOTE: The chosen parallel fill color will be used for objects until you choose 
another parallel fill color as the default.

Changing the fill color of an existing parallel line object

To change the fill color of an existing parallel line object

1. Select the parallel line object to change the fill color of.

2. Select the desired parallel fill color from the Parallel Fill color pop-up menu in the 
Attribute palette.

The fill of the selected parallel line object will be changed to reflect the chosen fill 
color.
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Pen color
This section describes how to use colors to draw lines, borders and text. You use the Pen 
Color pop-up menu in the Attribute palette to choose pen colors. You can use different 
pen colors to help distinguish between objects.

Selecting the pen color for lines, borders and text

To select the pen color

1. Open the Pen Color pop-up menu in the Attribute palette.

2. Drag until the pen color you want is highlighted.

3. Release the mouse button. The selected pen color will be shown on the Attribute 
palette.

NOTE: If you choose ‘* ‘(for No ink) from the Pen Color submenu as the current 
pen color, the lines, borders or text you draw will be invisible. Edit handles appear 
on selected objects drawn with no ink, but the lines, borders or text will not appear 
on the screen or on printed drawings.

You can change the pen color before or after you draw the object or enter the text.

Drawing a line or object, or entering text, with a selected pen color

To draw a line or object, or enter text, with a selected pen color

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Select the desired pen color from the Pen Color pop-up menu in the Attribute 
palette.

3. Draw a line or object or enter the text.
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The line, object or text will be drawn with the specified pen color.

The Line Indicator box in the lower left corner of the window will change color to 
indicate the color you chose.

NOTE: The chosen pen color will be used for lines, borders and text until you 
choose another pen color as the default.

Changing the pen color of an existing line, object or piece of text

To change the pen color of an existing line, object or piece of text

1. Select the line, object or text to change the pen color of.

2. Choose the desired pen color from the Pen Color pop-up menu in the Attribute 
palette.

The line or border of the selected object, or the selected text, will be changed to 
reflect the chosen pen color.

�  Using patterns

Fill patterns provide an effective way to distinguish between objects. Two reasons you 
might want to use different fill patterns within a drawing would be to improve its 
esthetics or to add meaningful information to the drawing. In a technical drawing, an 
architect or engineer might use a variety of fill patterns and inks to differentiate between 
various object types or textures within the drawing. MacDraft offers a menu selection of 
standard fill patterns to complement your drawing. You can use the existing patterns, 
customize them or create your own. You can have up to 64 patterns in each MacDraft 
document.
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Customizing patterns
The Edit Patterns feature allows you to change the patterns available in the pattern fill 
submenus from the Attribute palette. When a pattern is edited, the pattern fill submenus 
will be updated to show the new pattern, and the new pattern will be saved with the 
document. If a pattern that has been used to fill objects is edited, the objects will be 
changed to reflect the revised pattern.

The Edit Pattern dialog

Opening the Edit pattern dialog

To open the Edit Pattern dialog

1. Open the Options menu and drag until Edit Pattern is highlighted.

The Edit Patterns submenu appears.

2. Holding down the mouse button, drag until the pattern you want to edit is 
highlighted and release the mouse button.
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The Edit Pattern dialog appears.

NOTE: You cannot edit the No fill (“N”), the solid white or solid black patterns. If 
you try to do so, the Edit Pattern dialog will not open, and an alert appears 
informing that the selected pattern may not be edited.

The edit pattern field

The large box in the center of the Edit Patterns dialog is the edit pattern field. It shows a 
magnified view of the bits that make up the pattern. The pattern is edited within this field.

Pattern preview

The box in the upper left corner of the Edit Pattern dialog shows a preview of the pattern 
as it appears on the drawing. It is updated as the pattern is edited in the Edit Pattern field.

The pattern grid

The pattern grid can be defined as 8 x 8, 16 x 16 or 32 x 32 grid squares.

To specify the pattern grid

• Click the 8 x 8, 16 x 16, or 32 x 32 buttons on the left of the Edit Pattern dialog.

NOTE: 16 x 16, or 32 x 32 patterns will not be printed on some printers or output 
devices.



3 - 15 Chapter 3 - Changing the appearance of objects

Scale

Scale turned off

Grid size increased

If the Scale box is turned off, as the grid size is increased, the pattern is replicated to fill 
the new area.

For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 16, then to 32 
x 32. At each stage, four copies of the contents of the Edit Pattern field are used to fill the 
new grid. Notice that although the contents of the Edit Pattern field change, the Pattern 
Preview field remains the same.

Grid size decreased

If the Scale box is turned off, as the grid size is decreased, the pattern is divided and 
applied to the new area.

For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 x 16, then to 
8 x 8. At each stage, the contents of the top left quarter of the Edit Pattern field are used to 
fill the new grid.

Scale on

Grid size increased

If the Scale box is on, as the grid size is increased, the pattern in the Edit Pattern field 
remains the same, but is divided up into more squares.
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For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 16, then to 32 
x 32. At each stage, the contents of the Edit Pattern field remain the same, but the pattern 
is divided into more grid squares. Notice that the contents of the Pattern Preview field are 
scaled up at each stage.

Grid size decreased

If the Scale box is on, as the grid size is decreased, the pattern in the Edit Pattern field 
remains the same but is divided into less grid squares. Colors are averaged out in this 
process.

For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 x 16 then to 
8 x 8. At each stage, as four grid squares are combined to make one new grid square, the 
average color of the four squares is used for the new square. Notice that the contents of 
the Pattern Preview box are scaled down at each stage.

Color mode

Patterns can be edited in two modes: black and white, and color/grayscale. If you have a 
monochrome system, color options will still be available in the Edit Pattern dialog, but as 
colors/grayscales cannot be seen, they cannot be used effectively. In this case, patterns 
will consist of black and white bits, the black bits representing the pattern design and the 
white bits the background. If you have a color system, you can edit patterns using an 
unlimited number of colors.

Pattern editing tools

The tools at the right of the pattern edit field are used to edit the current pattern.



3 - 17 Chapter 3 - Changing the appearance of objects

The Overlay tool

The Overlay tool is used to apply a pattern over the one in the Edit Pattern field.

To apply a pattern over the one in the Edit Pattern field

1. Click the Overlay tool and hold down the mouse button.

The Fill Patterns submenu appears.

2. Holding down the mouse button, drag the cursor over the pattern you wish to 
apply, and release the mouse button

The selected pattern will be applied over the current contents of the Edit Pattern 
field using the current color.

 The Invert tool

The Invert tool is used to invert the color of the bits in the Edit Pattern field. In black and 
white mode, this action will change all the black bits to white and all the white bits to 
black. If color bits are included in the pattern, when the Invert tool is used, each bit will be 
changed to the color on the opposite side of the color wheel to the original color, and the 
brightness will also be inverted. For example, a light pink color will become a dark green/
blue, while a dark red will become a light green/blue.

To invert the color of the bits in the Edit Pattern field

• Click the Invert tool.



Chapter 3 - Changing the appearance of objects 3 - 18

 The color of the bits in the Edit Pattern field will be inverted

The Flip horizontal tool

The Flip Horizontal tool is used to flip the pattern in the Edit Pattern field around the 
vertical axis.

To flip the pattern in the Edit Pattern field around the vertical axis

• Click the Flip Horizontal tool.

The pattern will be flipped.

 The Flip vertical tool

The Flip Vertical tool is used to flip the pattern in the Edit Pattern field around the 
horizontal axis.

To flip the pattern in the Edit Pattern field around the horizontal axis

• Click the Flip Vertical tool.
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The pattern will be flipped.

The Pencil tool

The Pencil tool is used to add or delete individual bits or series of bits, or to draw lines in 
the Edit Pattern field.

To add bits to the Edit Pattern field one at a time

1. Click the Pencil tool and move the cursor over the Edit Pattern field.

2. Click the Edit Pattern field to add a square of the current color.

To add a series of bits

1. Click in the Edit Pattern field and drag, holding down the mouse button.

2. Bits showing the current color will be added to the pattern as you drag.

3. Release the mouse button when you are finished.

To draw lines

• Constrain the movement of the Pencil tool to a horizontal or vertical direction by 
holding down the Shift key while you drag.

To delete black bits in Black and White mode

• Select the Pencil tool and click the black bits you want to delete.

To delete color bits in the Color mode

• Hold down the Command key, then click the color bits to be deleted.

The Eye dropper tool

You can use the Option key to change the pencil tool to an eye dropper, and use this to 
choose the color of any bit in the Edit Pattern field as the current color.
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1. Select the Pencil tool, hold down the Option key and move the pointer into the 
Edit Pattern field.

The pointer will change to an Eye Dropper tool.

2. Click the Eye Dropper tool on the bit of the color you require to be the current 
color.

The current color will be changed to reflect your choice.

The Finger tool

The Finger tool is used to blend together the current color and the color of any bit in the 
Edit Pattern field, or the colors of adjacent bits in the Edit Pattern field.

To blend the current color with the color of any bit in the Edit Pattern field

1. Select the Finger tool.

The Finger cursor shows the current color, which is the first of the two colors to be 
used in the blending process.

2. Move the cursor over the Edit Pattern field and click the bit with which you want 
to blend the current color.

The bit clicked will change to a new color that is the average of the Finger cursor 
color and the color of the bit clicked. The Finger cursor color will also be updated 
to show the new color.

To blend the colors of a series of bits

1. Select the Finger tool.

2. Click in the Edit Pattern field and, holding down the mouse button, drag the 
Finger cursor across bits of varying colors.

The average of the color values of the Finger cursor color and the bits dragged 
across will be calculated, and applied to the bit.



3 - 21 Chapter 3 - Changing the appearance of objects

NOTE: If you hold down the Shift key while dragging, the movement of the 
Finger cursor will be constrained to a horizontal or vertical direction.

When you release the mouse button, the Finger cursor shows the color last applied 
to a bit. To reset the Finger cursor color to the current color, click the Finger tool 
icon again. To reset the Finger cursor color to a color in the pattern, hold down the 
Option key and click one of the colors in the pattern.

NOTE: The Finger tool can be selected in Black and White mode, but the mode is 
automatically changed to color.

The Paint bucket tool

The Paint Bucket tool is used to change bits in the Edit Pattern field to the current color.

To change bits in the Edit Pattern field to the current color

1. Click the Current Color button and choose the color from the Pattern Color pop-
up menu.

2. Click the Paint Bucket icon and then click a bit in the Edit Pattern field.

The bit clicked and all bits of the same color connected to it, are changed to the 
current color.

3. If you hold down the Option key with the Paint Bucket tool selected, the tool will 
be changed to the Eye Dropper tool. Click a bit in the Edit Pattern field with the 
Eye Dropper tool to select the color of that bit as the current color.

The Hand tool

The Hand tool is used to move the pattern within the Edit Pattern field.
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To move the pattern within the Edit Pattern field

1. Click the Hand tool and move the cursor over the Edit Pattern field.

2. Holding down the mouse button, drag the pattern to reposition it within the Edit 
Pattern field, and release the mouse button.

The Black and White tool

This tool is used to convert patterns to black and white.

To convert patterns to black and white

• Click the Black and White tool.

Any bits used in the pattern that are more than 50% saturated will be changed to 
black. Bits that are less than 50% saturated will be changed to white.

The Current color tool

You can work with only one color at a time while editing patterns. The selected color is 
called the current color and is shown in the tool palette of this dialog. With this tool you 
open the Pattern Color menu.
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To change the current color

1. Click the Current Color button and hold down the mouse button.

The Pattern Color pop-up menu appears

2. Holding down the mouse button, drag to select the color you want to use, and 
release the mouse button.

The selected color will be shown on the Current Color tool. This color will be used 
for pattern editing until another color is chosen.

NOTE: The current color is always black when you operate in black and white 
mode.

Choosing a color which is not available in the Pattern Color menu

The Other button in the Pattern Color pop-up menu allows you to select colors that are 
not available in the Pattern Color menu.

To choose a color which is not available in the Pattern Color menu

1. Click the Current Color button and hold down the mouse button.

The Pattern Color pop-up menu appears

2. Click the Other button.
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The Color Picker dialog appears.

3. Select a color from the Color Picker.

4. Click OK to close the Color Picker dialog and return to the Edit Pattern dialog.

The color selected from will be shown on the Current Color button.

Clearing the current pattern

At times, you may want to clear all the bits from the Edit Pattern field and start afresh 
rather than alter an existing pattern.

To clear all the bits from the Edit Pattern field

• Click the Clear button

The field will be cleared.

Filling the entire field

If you need to fill the entire field with the current color you can do this with one mouse 
click using the Fill button.

To fill the entire field

• Click the Fill button.

The entire Edit Pattern field will be filled with the current color.

Revert

• Click the Revert button to return to the pattern you originally selected to edit. Any 
changes you have made will be lost.
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Undo

• Click the Undo button to remove the effects of your last action only.

Cancel

• Click the Cancel button to close the Edit Pattern dialog and return to your 
MacDraft drawing without making any changes to the fill patterns.

OK

• Click the OK button to close the Edit Pattern dialog and return to your MacDraft 
drawing accepting the changes you have made to the selected fill pattern. The fill 
submenu will be updated to show the new pattern, and the new pattern will be 
saved with the document. If a pattern that has been used to fill objects is edited, the 
objects will be changed to reflect the revised pattern.

Object fill patterns
You can use a pattern to fill the interiors of objects. Filled objects are opaque and you can 
select them by clicking their borders or anywhere within them. If a filled object is on top of 
another object, it hides the object beneath it from view.

Selecting the fill pattern

To select the fill pattern

1. Open the Fill Pattern pop-up menu in the Attribute palette.

2. Drag until the fill pattern you want is highlighted.

p
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3. Release the mouse button. The selected fill pattern will be shown on the Attribute 
palette.

NOTES:
• If you choose ‘N ‘(for No fill) from the Fill Pattern submenu as the current fill 
pattern, the objects you draw will be wire frame shapes.
• You must draw polylines, freehand lines and curves with No fill if you want end 
marks to appear on the lines (see End marks on page 3-36).

You can change the fill pattern before or after you draw the object.

Drawing an object with a selected fill pattern

To draw an object with a selected fill pattern

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Select the desired fill pattern from the Fill Pattern pop-up menu in the Attribute 
palette.

3. Draw an object.

The object will be drawn with the specified fill pattern.

The Fill Pattern Indicator box in the lower left corner of the window will change to 
indicate the pattern you chose.

NOTE: The chosen fill pattern will be used for objects until you choose another fill 
pattern as the default.

Changing the fill pattern of an existing object

To change the fill pattern of an existing object

1. Select the object to change the fill pattern of.
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2. Select the desired fill pattern from the Fill Pattern pop-up menu in the Attribute 
palette.

The fill of the selected object will be changed to reflect the chosen fill pattern.

Parallel fill pattern
MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and closed 
parallel polygons) can include fill patterns (including No Fill) between their component 
edges.

NOTE: In addition to parallel fills, parallel objects can also have pen colors and patterns, 
and object fills.

Selecting the parallel fill pattern

To select the parallel fill pattern

1. Open the Parallel Fill Pattern pop-up menu in the Attribute palette.
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2. Drag until the parallel fill pattern you want is highlighted.

3. Release the mouse button. The selected parallel fill pattern will be shown on the 
Attribute palette.

You can change the parallel fill pattern before or after you draw the parallel line 
object.

Drawing a parallel line object with a selected fill pattern

To draw a parallel line object with a selected fill pattern

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Select the desired parallel fill pattern from the Parallel Fill pattern pop-up menu in 
the Attribute palette.

3. Draw a parallel line object.

The object will be drawn with the specified fill pattern.

NOTE: The chosen parallel fill pattern will be used for objects until you choose 
another parallel fill pattern as the default.

Changing the fill pattern of an existing parallel line object

To change the fill pattern of an existing parallel line object

1. Select the parallel line object to change the fill pattern of.
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2. Choose the desired parallel fill pattern from the Parallel Fill pattern pop-up menu 
in the Attribute palette.

The fill of the selected parallel line object will change to reflect the chosen fill 
pattern.

Pen pattern
This section describes how to use patterns to draw lines and borders. Use the Pen Pattern 
pop-up menu in the Attribute palette to choose pen patterns. You can use different pen 
patterns to help distinguish between objects.

Selecting the pen pattern for lines and borders

To select the pen pattern

1. Open the Pen Pattern pop-up menu in the Attribute palette.
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2. Drag until the pen pattern you want is highlighted.

3. Release the mouse button. The selected pen pattern will be shown on the Attribute 
palette.

NOTE: If you choose ‘N ‘(for No ink) from the Pen Pattern submenu as the current 
pen pattern, the lines and borders you draw will be invisible. Edit handles appear 
on selected objects drawn with no ink, but the lines or borders will not appear on 
the screen or on printed drawings.

You can change the pen pattern before or after you draw the object.

Drawing a line or object with a selected pen pattern

To draw a line or object with a selected pen pattern

1. Return to the pointer mode. (Make sure that nothing on the drawing is selected.)

2. Choose the desired pen pattern from the Pen Pattern pop-up menu in the 
Attribute palette.

3. Draw a line or object.

The line or object will be drawn with the specified pen pattern.

The Line Indicator box in the lower left corner of the window will change pattern 
to indicate the pattern you chose.

NOTE: The chosen pen pattern will be used for lines and borders until you choose 
another pen pattern as the default.
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Changing the pen pattern of an existing line or object

To change the pen pattern of an existing line or object

1. Select the line or object to change the pen pattern of.

2. Choose the desired pen pattern from the Pen Pattern pop-up menu in the 
Attribute palette.

The line or border of the selected object will be changed to reflect the chosen pen 
pattern.

�  TLine and border attributes

The attributes that define the appearance of lines and borders are sometimes referred to as 
the ‘pen model’ or simply, the ‘pen’. The attributes for the pen include pen style, line 
weight, line style and end marks. The border position of an object can also be specified. 
The various options for each attribute are selected using pop-up menus in the Attribute 
palette or, in the case of pen style and border position, from the Options menu.

Pen color or pattern are discussed in other sections of this chapter; see Pen color on page 3-
11 and Pen pattern on page 3-29.

NOTE: Many of the pen model attributes you choose do not affect only lines, they also 
affect the borders of objects. For example, when you select a certain line weight and color, 
these attributes will be applied to line segments used to draw rectangles, circles, polygons 
and so on.
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Line weight
Line weight refers to the thickness of lines and borders. Line weight is measured in pixels 
(picture elements).

There are eleven different line weights. They vary in size from hairline to 13 pixels. The 
numbers beside the line weights indicate the number of pixels that make up the line 
weight. 

NOTE: Although the hairline, 0.5 and 0.75 line weights appear as one point thick on the 
screen, they will print at their designated weights on any printer with a resolution of 300 
dpi or more.

Selecting line weights

To select the line weight

1. Open the Line Weight pop-up menu in the Attribute palette.

2. Drag until the line weight you want is highlighted.

3. Release the mouse button. The selected line weight will be shown on the pop-up 
menu.

You can change the line weight before or after you draw the line or object.
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Drawing a line or object with a selected line weight

To draw a line or object with a selected line weight

1. Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.)

2. Choose the desired line weight from the Line Weight pop-up menu in the 
Attribute palette.

3. Draw a line or object.

The line or object will be drawn with the specified line weight.

NOTE: The chosen line weight will be used for lines and borders until you choose 
another line weight for the default line weight attribute.

Changing the line weight of an existing line or object

To change the line weight of an existing line or object

1. Select the line or object to change the line weight of.

2. Choose the desired line weight from the Line Weight pop-up menu in the 
Attribute palette.

The line or border of the selected object will be changed to reflect the chosen line 
weight.
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NOTE: For information about how to make line weights appear either magnified or at 
their normal size while in a zoomed in view, see Home view on page 2-106.

Line style
The term ‘line style’ refers to whether a line is solid or one of an assortment of dashed 
lines. You can use the preset line styles provided with MacDraft or customize them to 
make your own. You can use line styles in object borders and straight lines.

Selecting line styles

To select the line style

1. Open the line style pop-up menu in the Attribute palette.

2. Drag until the line style you want is highlighted.

3. Release the mouse button. The selected line style will be shown on the pop-up 
menu.

You can change the line style before or after you draw the line or object.
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Drawing a line or object with a selected line style

To draw a line or object with a selected line style

1. Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.)

2. Choose the desired line style from the line style pop-up menu in the Attribute 
palette.

3. Draw a line or object.

The line or object will be drawn with the specified line style.

NOTE: The chosen line style will be used for lines and borders until you choose 
another line style for the default line-style attribute.

Changing the line style of an existing line or object

To change the line style of an existing line or object

1. Select the line or object to change the line style of.

2. Choose the desired line style from the line style pop-up menu in the Attribute 
palette.

The line or border of the selected object will be changed to reflect the chosen line 
style.
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End marks
End marks are symbols on the ends of lines that are used for annotating drawings. You 
can make end marks appear on lines by using a set of end marks in combination with the 
Line tools, the Polyline tool, the Freehand Line tool, the Bezier curve tool or the Spline 
tool.

Selecting end marks

To select end marks

1. Open the end marks pop-up menu in the Attribute palette.

2. Drag until the desired end marks are highlighted.

• Drag down the left side of the pop-up menu to choose a left end mark; it appears at 
the beginning of a line.

• Drag down the right side of the pop-up menu to choose a right end mark; it 
appears at the end of a line.

• Drag down the centre of the pop-up menu to choose both left and right end marks; 
these appear at each end of a line.

3. Release the mouse button. The selected end marks will be shown on the pop-up 
menu.

You can change the line style before or after you draw the line or object.
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NOTE: Polylines, freehand lines, Bezier curves or splines must contain No Fill if you wish 
to add end marks to them. See Drawing irregular polygons and polylines on page 2-33 and 
Drawing freehand lines, shapes and curves on page 2-37 for details of drawing these objects.

Drawing a line or object with selected end marks

To draw a line or object with selected end marks

1. Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.)

2. Choose the desired end marks from the end marks pop-up menu in the Attribute 
palette.

3. Draw a line or object.

The line or object will be drawn with the specified end marks.

NOTE: The chosen end marks will be used for lines and borders until you choose 
other end marks for the default end marks attribute.

Changing the end marks of an existing line or object

To change the end marks of an existing line or object

1. Select the line or object to change the end marks of.

2. Choose the desired end marks from the end marks pop-up menu in the Attribute 
palette.
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The line or border of the selected object will be changed to reflect the chosen line 
weight.

Border positions
There are three types of border position: Line Inside, Line Centered and Line Outside. 
The border position options apply to objects only, not to lines.

All three border positions affect objects differently, these differences are discussed later in 
this chapter. In general though, border position is important with regard to how objects 
are aligned. MacDraft uses the position of an object's edit handles to align objects. It is 
important to keep this in mind when you align objects, as border position controls the 
position of the edit handles relative to the width (that is the line weight) of the border (see 
Aligning objects on page 5-27).

Line inside Line centered Line outside



3 - 39 Chapter 3 - Changing the appearance of objects

Border position applies only to square-corner and rounded-corner rectangles, parallel line 
objects, circles and arcs. You can draw these objects with a certain border position or 
change the border position of selected objects.

Selecting border positions

To select a border position

1. Open the Border Position submenu in the Options menu.

2. Drag until the desired border position is highlighted.

3. Release the mouse button. A checkmark appears next to the selected border 
position on the submenu.

You can change the border position before or after you draw the line or object.

Drawing an object with a selected border position

To draw an object with a selected border position

1. Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.)

2. Choose the desired border position from the Border Position submenu in the 
Options menu.

3. Draw an object.

The object will be drawn with the specified border position.

NOTE: The chosen border position will be used for objects until you choose 
another border position as the default.
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Changing the border position of an existing object

To change the border position of an existing object

1. Select the object to change the border position of.

2. Choose the desired border position from the Border Position submenu in the 
Options menu.

The border of the selected object will be changed to reflect the chosen border 
position.

How border position affects objects
Border position determines the location of the edit handles on the border of an object, and 
as MacDraft uses the edit handles as reference points for alignment and size calculations, 
border position affects the alignment and size readings of objects. (See Aligning objects on 
page 5-27 and Show Size on page 6-1.)

Line Inside

When you draw an object with the border position Line Inside, the border 
of the object appears between the cursor and the object during creation. 
When you select an object created with the border position Line Inside, 
the edit handles appear on the outside of the object. When Show Size is 
on, the size shown represents the entire object, including its borders.

Line Centered

When you draw an object with the border position Line Centered, the 
cursor appears centered within the object’s borders during creation. 
When you select an object created with the border position Line 
Centered, the edit handles appear in the center of the object’s borders. 
When Show Size is on, the size shown is the size of the object measured 
from the center of the object’s borders.
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Line Outside

When you draw an object with the border position Line Outside, the 
border of the object appears outside the cursor during creation. When 
you select an object created with the border position Line Outside, the 
edit handles appear on the inside of the object. When Show Size is on, 
the size shown is the size of the object’s interior, excluding the object’s 
borders.

�  Copying attributes

An object’s graphic attributes (fill, pen color or pattern, line weight and line style etc.) and 
object information can be copied and applied to another object using either the Attributes 
tool or the Copy Attributes and Apply Attributes commands in the Edit menu. The 
Apply Attributes command can be used to apply changes to all of the objects selected, 
while the Attributes tool applies changes only to the object clicked.

Any settings for applying attributes will be stored only while the application is running.

Copying attributes using the Attributes tool

To copy attributes using the Attributes tool

1. Click the Attributes tool in the Tool palette

2. Click an object.

The default attributes will be applied to the object.

3. With the Attributes tool still selected, hold down the Option key and click an 
object.
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The cursor turns into an empty eye dropper.

The object’s pen and fill attributes will be copied

4. Release the Option key, the cursor turns into a full eye dropper.

5. Click another object to apply the copied pen and fill attributes to it.

NOTES:
• Attributes will be applied only to the object clicked, even if that object is part of a 
group.
• The apply action can be undone by selecting Undo Eye Dropper from the Edit 
menu immediately after the apply action.
• Hold down the Command key and click in the drawing window with the 
Attributes tool, and the tool reverts to the Arrow tool.
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Checking and changing attributes before applying them
You can check and, if necessary, change copied attributes before applying them. There are 
two ways of doing this when you use the Attributes tool. The first is to use the Apply 
Attributes dialog, in which case any changes will be applied to that action only. The 
second is to use the Attributes Options dialog, in which case the settings remain as 
specified until changed or until the application is closed.

Using the Apply Attributes dialog

To open the Apply Attributes dialog before applying attributes to an object

1. Select the Attributes tool and hold down the Shift key.

The full eye dropper icon is followed by three dots to show that the Apply 
Attributes dialog will appear when an object is clicked.

2. Click an object.

The Apply Attributes dialog appears.

3. Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to the object you have clicked. Any 
changes made to the Apply Attributes dialog relate to this apply action only.

Using the Attributes Options dialog

To open the Attributes Options dialog

1. Hold down the Option key and click the Attribute tool, or select the Attribute tool 
and choose Tool Options from the Options menu.
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The Attribute Options dialog appears.

2. Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to objects. Settings remain as 
specified until changed or until the application is closed, rather than just for the 
next use of the tool.

Copying attributes using the Edit menu

To copy attributes using the Edit menu

1. Select the object from which you want to copy attributes.

2. Open the Edit menu and choose Copy Attributes.

The object’s graphical attributes and object information will be stored.

3. Select the object or objects to which you want to apply these attributes.
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4. Open the Edit menu and choose Apply Attributes.

The copied attributes will be applied to the selected object or objects.

NOTE: The apply action can be undone by choosing Undo Apply Attributes from the 
Edit menu immediately after the apply action.

Checking and changing the attributes before applying them
As when using the Attributes tool, there are two ways of checking and changing the 
attributes before applying them when you use the Edit menu. You can use the Apply 
Attributes dialog, or use the Attributes Options dialog.

Using the Apply Attributes dialog 

To open the Apply Attributes dialog before applying attributes to an object

1. Hold down the Shift key when you choose the Apply Attributes command in the 
Edit menu.

The Apply Attributes dialog appears.

2. Click the Object Fill, Pen Thickness  and Parallel Fill boxes to specify that these 
attributes should be applied to the selected object or objects. Any changes made to 
the Apply Attributes dialog relate to this apply action only.
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Using the Attributes Options dialog 

To open the Attributes Options dialog

1. Choose Attributes Options from the Edit menu.

The Attributes Options dialog appears.

2.  Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to objects. The settings remain as 
specified until changed or until the application is closed, rather than just for the 
next use of the Apply Attributes command.

�  Picture backgrounds

Transparent picture backgrounds
There may be occasions when you position a picture object on top of another object, and 
want the lower object to show through the background of the foremost object. MacDraft 
allows you to do this using the Fill Pattern pop-up menu in the Attributes palette.

To make the background of a superimposed picture transparent

1. Select a superimposed picture.

In the example below, a stylized picture of the sun has been placed on top of a 
picture of the world map. Note that the opaque white background of the sun 
picture is obscuring part of the map.
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2. Choose ‘*’ (for ‘No Fill’) from the Fill Color pop-up menu, or ‘N’ (for ‘No Fill’) 
from the Fill Pattern pop-up menu in the Attributes palette.

The background of the foremost picture becomes transparent, allowing the picture 
beneath to be shown through.

Opaque picture backgrounds
The background of a picture can be given a colored or patterned fill in the same way as 
other objects. Select the picture and choose a color from the Fill Color submenu or a 
pattern from the Fill pattern submenu in the Attributes palette. See Object fill color on page 
3-7 and Object fill patterns on page 3-25 for details.
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Chapter 4 - Annotating your drawing
Annotation describes or gives information about an object in a drawing. In MacDraft, 
annotation is of three kinds: text, dimension objects and area calculation.

�  Text

Text, in a MacDraft document, consists of all letters, punctuation and numbers. Once text 
is created, it is recognized as a single object and you can then use most functions with it, 
such as moving and duplicating.

The Text function allows you to use a variety of fonts, styles, and character sizes. You can 
arrange text lines with single spacing, one and a half spacing, or double spacing. Text can 
also be justified within each individual text block and all text can be hidden or displayed.

Entering text
You can enter text in two ways: using the regular text mode or the paragraph text mode.

In the paragraph text mode, you drag to define a text rectangle of a certain size (either 
with the Text tool or another drawing tool), and the text you enter into the rectangle 
automatically “wraps” when it reaches the side of the rectangle.

Regular text
In the regular text mode, you click the drawing to define an insertion point, then type in 
the text. You define the end of a line of text by pressing the Return key.

To enter regular text (i.e. text that does not automatically “wrap”)

1. Activate the Text icon in the Tool palette by clicking it.
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Notice that when you activate the text icon and then move the cursor onto the 
drawing area, the cursor turns into an I-beam pointer. The I-beam pointer indicates 
that you are in the text insertion mode.

2. Position the I-beam pointer where you want to begin inserting text and click.

A flashing vertical bar appears at the point where you clicked to show that you can 
now begin typing.

3. Enter the text by typing on the keyboard.

You can continue to enter text in various places on your drawing by moving the I-
beam pointer to the desired place, clicking it, and typing. 

NOTES:
• If you make a typing mistake as you are entering text, simply use the Delete key 
to remove the error and then type the correct character.
• To start a new line in the same text block, just press the Return key and continue 
to type.

4. After you have finished entering text, click the Pointer tool.

Paragraph text
On many occasions, you may wish to enter a paragraph of text and restrict it to a certain 
rectangular shape, such as a column. MacDraft’s paragraph text feature allows you to 
define a rectangle of any size, then type text into it. As you enter the text into the rectangle, 
the words will automatically wrap around to the next line when the letters reach the edge 
of the rectangle. If you type to the bottom of the rectangle, the text will be scrolled within 
the rectangle to keep the line you are typing visible. Paragraph text cannot extend beyond 
the drawing edge.

Entering paragraph text

You can define the paragraph text rectangle by drawing a rectangle with the Text tool, by 
drawing a rectangle or other shape, or by selecting an existing rectangle or other shape. (If 
you draw or select a non-rectangular object and start typing, the text appears in a 
rectangle superimposed over the object.)

NOTES:
• If you draw or select a rectangle and enter text, the text and the rectangle are 
automatically linked.
• Non rectangular objects remain separate objects from the text object; you can move and 
reshape them separately.
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To enter paragraph text with the Text tool

1. Activate the Text tool.

2. Position the I-beam pointer where you want to begin entering text.

3. Press and hold down the mouse button.

4. Drag in a diagonal direction until you have defined a rectangle that is the size you 
want, and release the mouse button.

5. Start entering text from the keyboard.

6. When you are finished, click the Pointer tool to end the text entry.

To enter paragraph text with the Circle (or other drawing) tool

1. Activate the Circle tool (or other drawing tool).

2. Position the pointer where you want to begin entering text.

3. Press and hold down the mouse button.

4. Drag in a diagonal direction until you have defined an object that is the size you 
want, and release the mouse button.

5. Start entering text from the keyboard.

6. When you have finished, click the Pointer tool to end the text entry.

To enter paragraph text feature into an existing rectangle or other shape

1. Select the object.

2. Start entering text from the keyboard.

3. When you are done, click the Pointer tool to end the text entry.
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Reshaping a block of paragraph text

To reshape a block of paragraph text

Once the paragraph of text is entered, you can reshape the paragraph using the edit 
handles. 

1. Return to the pointer mode.

2. Select the paragraph of text by clicking it.

3. Edit handles appear on the text block.

4. Position the tip of the pointer on one of the edit handles.

5. Press and hold down the mouse button.

6. Drag until the paragraph is the shape you want.

7. Release the mouse button.

NOTE: If you select regular text (entered using the Text tool) and try to reshape the 
paragraph using the edit handles, you will actually resize the font rather than the 
paragraph.

Selecting/editing text
Sometimes you need to edit text you have previously entered on your drawing. MacDraft 
gives you various ways to edit text: replacing an existing word or line of text by selecting 
it and retyping in its place; inserting characters or words at the end of existing text or at 
any selected point in the text; and backspacing to delete text.

Before you can edit a piece of text, you must select it. You can select text by using the 
pointer while in the pointer mode, or by using the I-beam pointer. (When you select text 
using the pointer mode, any changes you make will affect the entire text block.)
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Selecting text

Using the I-beam pointer

To select text

1. Click the Text tool icon in the palette.

2. Position the I-beam pointer to either side of the text you want to change.

3. Press and hold down the mouse button.

4. Drag through all the text you want to edit, and release the mouse button.

Notice that the text becomes highlighted as you drag through it. Using this 
method of selecting allows you to select a single character or an entire block of text.

To select a word:

• Position the I-beam pointer on the word you want to select and double-click.

To extend the selection of text

1. Position the I-beam pointer on the first word you want to select.

2. Double-click and, after the second click, hold down the mouse button.

3. Drag through the text until all the words you want to select are highlighted, then 
release the mouse button.

To select a range of text

1. Position the I-beam pointer at the starting point for the range and click.

2. Press down the Shift key.

3. Position the I-beam pointer on the ending point for the range.

4. Still holding down the Shift key, click this point.

5. Release the mouse button and the Shift key.

The text between the specified starting and ending points will be selected.
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Using the Arrow tool

To select text

1. Position the pointer tip on the block of text that you want to select and click it.

Notice that a rectangle and/or a set of edit handles appears around the text, 
indicating that it is selected. This method of selecting text allows you to change the 
text attributes (including the font, size, and style) of the selected text block (see 
Formatting text on page 4-8).

If you select text in this way and immediately start typing, the new text is 
automatically added to the end of the existing text.

Selecting rotated text for editing

To select rotated text

1. Activate the Text tool in the palette.

2. Click the block of rotated text you want to edit.

The text will temporarily be rotated to zero degrees (horizontal orientation) 
allowing you to edit it.

3. When you are through editing the text, click the Pointer tool.

Once you click the Pointer tool, the text returns to its rotated position.

NOTE: If you print rotated text on a printer that is not PostScript®-compatible, the text 
will print out at the resolution of the printer hardware. 

Selecting all text

You can select all the text in the active document if you want to make a global change to 
text attributes.

To select all text in the active document

1. Return to the pointer mode.

2. Open the Text menu, from the menu bar or the Text tool, and choose Select All 
Text.
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Editing text

Replacing existing text

Once you have selected any portion of text, you can immediately replace it by simply 
typing in the new text. As soon as you begin typing, the old text disappears. As you enter 
the new text, all of the non-selected text in the line will automatically adjust to make room 
for the text you are entering.

Inserting text into existing text

On many occasions you may need to insert a single character, word or sentence into an 
existing piece of text.

To insert text

1. Activate the Text tool in the palette by clicking it.

2. Position the I-beam pointer on the desired insertion point and click it.

3. Type in the character or words that you wish to insert. (Keep in mind that you can 
press the Delete key to delete characters or words.)

In this mode, you can continue to pick insertion points in other pieces of text on 
your drawing and edit them as well. 

4. Once you have completed all the editing that you want to do, click the Pointer icon 
in the palette.

Deleting selected text

There are two simple ways to delete text that you have selected. Either:

• Open the Edit menu and choose Cut or Clear, or

• Press the Delete key.
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Formatting text
You can choose the way you want to present text either before entering the text, or by 
changing the text after it has been entered. There are many options to choose from to 
obtain the effect that you desire. MacDraft allows you to use many different font types, 
sizes and styles for text. You can format text by choosing options from the Text menu in 
the menu bar or the Text tool in the Tool palette.

Formatting text before entering it

To format text before entry

1. Make sure that no text is selected on the drawing before you make each choice.

2. Choose the text attributes you want from the Text menu’s submenus.

The current attributes for text, such as font, size, and style are marked with 
checkmarks in the appropriate menus. These checkmarks show you what 
attributes will be applied to the text you enter.

Formatting existing text
You can change the font, size and style of any existing text. You can change the text 
attributes for a given piece of text by selecting the text and then opening the submenu 
associated with the attribute you want to change.

To format existing text

1. Select the text you wish to change (see Selecting text on page 4-5).

2. Choose the text attributes you want from the Text menu’s submenus.
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Each time you make a choice from the Text menu, the selected text will change to 
reflect that choice.

Define attributes for text

To define the font

1. Open the Font submenu from the Text menu.

2. Holding down the mouse button, drag until the font you want is highlighted, and 
release the mouse button.

To define the point size for text

1. Open the Text menu’s Size submenu.

2. Holding down the mouse button, drag until the size you want (measured in 
points) is highlighted, and release the mouse button; or choose Other… to enter a 
point size (up to 1024 point) that is not listed in the submenu.

NOTE: The font size of regular text can also be adjusted by clicking the text and dragging 
one of its edit handles to resize the text.
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To define the type style:

1. Open the Text menu’s Style submenu.

2. Holding down the mouse button, drag until the style you want is highlighted, and 
release the mouse button.

You can make several different choices from the Style submenu. Each choice has an 
additive effect on the appearance of text. For example, you could choose Bold and then 
Italic to create Bold/Italic text.

To justify text

1. Open the Text menu’s Justification submenu.

2. Holding down the mouse button, drag until the type of horizontal justification you 
want (Left, Center, or Right) is highlighted, and release the mouse button.

3. Repeat steps 1 and 2 to choose the desired vertical justification (Top, Middle or 
Bottom).

To set the line spacing

MacDraft offers you flexibility in choosing line spacing (also known as “leading”) options 
to suit your needs. You can have one, one and a half, or two spaces between lines of text.

1. Choose Line Spacing from the Text menu.

2. The Line Spacing submenu appears
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3. Holding down the mouse button, drag until the line spacing you want is 
highlighted, and release the mouse button.

Changing the case of text

On some occasions you may enter a piece of text in one case, such as lowercase, and then 
decide that you want it in uppercase or in title format. You could clear the text and reenter 
it; however, MacDraft allows you to change the case of existing text.

To change the case of existing text

1. Select the text that you want to change by clicking it.

2. Open the Text menu’s Case submenu.

3. Holding down the mouse button, drag until the case option you want is 
highlighted.

The results of each choice are as follows:

• UPPERCASE: Converts all selected text to uppercase.

• lowercase: Converts all selected text to lowercase.

• Title Text: Capitalizes the first character of each word in selected text.

Positioning text

Moving text

Once you have created a block of text, you can move it to a different location on your 
drawing if necessary. Notice that when you create a line of text and then click anywhere 
else, the text becomes surrounded by a box or edit handles. This indicates that MacDraft 
recognizes the piece of text as an object. You can move the text just as you would move 
any other object.
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NOTE: Text can also be rotated and flipped. See Rotating objects on page 5-32 and Flipping 
objects on page 5-41.

To move a piece of text

1. Position the cursor over the text block.

2. Press and hold down the mouse button until the white arrow pointer appears.

3. Drag the text to its new position, and release the mouse button.

Aligning Text

There are two ways to align text. Justifying text within the text block (see To justify text on 
page 4-10), and aligning text with an object or another piece of text that is treated as an 
object(see Aligning objects on page 5-27).

Hiding/displaying all text

Hiding text
At times, you may want to temporarily hide all of the text on a document. If you choose to 
hide all the text, and then print the document, the text will not appear on the output. You 
might use this feature to hide all the text before you produce a test print of a drawing to 
shorten the printing time. If you are working on a complex drawing with many elements, 
you could use this feature to minimize the amount of time it takes to redraw the screen 
after you scroll or zoom.

To hide all text

• Open the Text menu and choose Hide Text.

All the text on the drawing will be temporarily removed from the screen and from 
any printed output until you choose to redisplay the text. A checkmark appears 
beside Hide Text in the Text menu.

Redisplaying text
When you want to make the text visible again on the screen and on your output, you can 
choose the Hide Text command again.

To redisplay all text:

• Open the Text menu and choose Hide Text again.

The checkmark disappears from beside Hide Text in the Text menu, and the text in 
the drawing will be visible again.
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�  Dimension objects

About dimension objects
MacDraft’s Dimension tools allow you to add dimension lines to your drawing so that 
you can display and print the sizes of (or distances between) various lines and objects. 
Dimensions show sizes and distances in real-world units according to the scale of the 
drawing. In addition, MacDraft can show and print the size of an angle. Angular 
dimensions appear in degrees of arc, regardless of the scale of a drawing.

The Dimension palette
The dimension objects are created and controlled using the tools and pop-up menus of the 
Dimension Palette.

To display the Dimension palette

• Choose Dimension from the Window menu, or

• Choose Dimension from the pop-up menu at the bottom left of the document 
window.

To close the Dimension palette

• Click the palette’s close button.

Types of dimension objects
The dimension tools can create linear (horizontal, vertical, sloped, or perpendicular), 
radial (radius or diameter), and angular dimensions. In addition the Dimension palette 
includes a Circle center mark tool, for marking the center of a circle, arc, or ellipse.

Vertical dimension
Perpendicular dimension

Radial dimension

Horizontal dimension

Diameter dimension

Angular dimensionCircle centre mark

Sloped dimension
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Linear dimensions

Linear (horizontal, vertical, sloped, or perpendicular) dimensions can consist of a single 
dimension span. 

Linear dimensions can use existing vertices, corners, and so on as their points of reference. 
If the Snap to Object feature is active, the dimension tools will snap the reference points 
to existing corners and handles (see Snap to object on page 6-19).

Radial dimensions

Radial dimensions appear as straight lines (like linear dimensions), but measure the 
radius or diameter of an existing circle, ellipse, or arc. 
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Angular dimensions

Angular dimensions measure the angle of arc between any two straight lines or edges of 
square-cornered rectangles, polygons, or polylines (single-line or parallel). The lines or 
edges need not intersect.

Drawing dimension objects
MacDraft’s dimension objects include linear (horizontal, vertical, sloped, or 
perpendicular), radial (radius or diameter), and angular dimensions.

Once created, dimension object’s attributes, such as color, line style, text font, and so on 
can be controlled in the standard fashions (see Chapter 3 - Changing the appearance of objects 
on page 3-1).

NOTE: Dimension objects are drawn using the current default pen model. Hold down the 
Control key when drawing dimension objects to draw the lines using ‘hairline’ weight.

A dimension object can be independently resized and edited much like other MacDraft 
shapes.

Linear dimensions

Reference points

The user-defined reference points for linear dimensions can be either part of existing 
objects (on corners or edges) or independent points on the drawing.

To show an object’s size precisely, it is usually necessary to put the dimension’s reference 
points on the object’s corner points (or other edit handles).

Horizontal dimension objects
The horizontal dimension tool creates dimension lines that are constrained to horizontal 
orientation. When edited, moved, or resized, horizontal dimension objects retain their 
original angle of orientation.
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To draw a single horizontal dimension line

1. Choose the Horizontal dimension tool from the Dimension palette.

The cursor will now read “1st point.”

2. Click the first point for the dimension line (an object's corner, if desired).

The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

4. Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the horizontal distance between the 
two points displayed where you specified.

5. Click the Arrow tool to leave dimension mode.

Vertical dimension objects
The vertical dimension tool creates dimension lines that are constrained to vertical 
orientation. When edited, moved, or resized, vertical dimension objects retain their 
original angle of orientation.



Chapter 4 - Annotating your drawing 4 - 17

To draw a single vertical dimension line

1. Select the Vertical dimension tool from the Dimension palette.

The cursor will now read “1st point.”

2. Click the first point for the dimension line.

The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

4. Click the drawing where you want the text value to appear.

The dimension object will be complete, with the vertical distance between the two 
points displayed where you specified.

5. Click the Arrow tool to exit dimension mode.

Slope dimension objects
The slope dimension tool is used to create dimension lines running in any direction on a 
drawing. Slope dimensions can be edited, moved, or resized, and the angle changed.

To draw a single slope dimension line

1. Select the Slope dimension tool from the Dimension palette.

The cursor will now read “1st point”.
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2. Click the first point for the dimension line.

The cursor will now read “2nd Point”.

3. Click the second point for the dimension line.

The cursor will now read “Anchor”, and include an outline of the dimension’s text 
box.

4. Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the distance between the two points 
displayed where specified along the slope.

5. Click the Arrow tool to exit dimension mode.

Perpendicular dimension objects
The perpendicular dimension tool creates dimensions perpendicular to lines or to the 
edges of square-cornered rectangles, polygons, and polylines (single-line or parallel-line). 
When edited, moved, or resized, perpendicular dimension objects retain their original 
angles of orientation.

To create a perpendicular dimension line

1. Select the Perpendicular dimension tool from the Dimension palette.

The cursor will now read “Click Line/Edge.”

2. Click the line or edge for the first point of the dimension line.

The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.
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4. Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the perpendicular distance from the 
edge of the object to the point you chose.

5. Click the Arrow tool to exit dimension mode.

NOTE: If you hold down the Option key while drawing a perpendicular dimension line, 
its length will be constrained to increments of the current snap-grid distance.

Radial dimension objects
MacDraft’s radial dimension tools let you display and print the radius or diameter of a 
circle, arc, or ellipse.

NOTES:
• Radial dimensions are not rotated together with the ellipses and elliptical arcs after 
dimensions are applied.
• Also, ellipses or elliptical arcs can display a radius or diameter only along their major 
and minor axes.

Radius dimensions

To apply a radius dimension to an object 

1. Select the Radius dimension tool from the Dimension palette.

The cursor will now read “Click Circle/Arc”.
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2. Click the circle, arc, or ellipse.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

NOTE: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point where 
the dimension text is to appear. This option does not work with ellipses and 
elliptical arcs.

3. Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the radial distance shown where you 
specified.

4. Click the Arrow tool to exit dimension mode.

Diameter dimensions

To draw a diameter dimension

1. Select the Diameter dimension tool from the Dimension palette.

The cursor will now read “Click Circle/Arc.”

2. Click the circle, arc, or ellipse.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.
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NOTE: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point where 
the dimension text is to appear.

3. Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the diameter distance appearing 
where you specified.

4. Click the Arrow tool to exit dimension mode.

Circle center marks
MacDraft’s Dimension palette includes a special tool for indicating the center of circles, 
ellipses, and arcs.

NOTE: Circle center marks cannot be applied to ellipses and elliptical arcs that have been 
rotated.

To apply a Circle center mark

1. Choose the Circle center mark tool in the Dimension palette.

The cursor will read “Click Circle/Arc”.

2. Click the circle, arc, or ellipse.
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The Circle Center mark appears over the object

3. Click the Arrow tool to exit dimension mode.

Angular dimension objects
MacDraft’s Angular dimension tool lets you display and print the angles between 
different lines or edges, whether they intersect or not. You can apply an angular 
dimension object to any pair of straight lines or edges of square-cornered rectangles, or to 
polygons or polylines (single-line or parallel-line).

To apply an angular dimension

1. Decide which two lines or edges you want to apply the dimension object to.

2. Select the Angular dimension tool from the Dimension palette.

The cursor will now read “Click 1st Line”.

3. Click the first line or edge.

The cursor will now read “Click 2nd Line”.

4. Click the second line or edge.

The cursor will now read “Anchor”, and include an outline of the dimension’s text 
box.

5. Click the drawing where you want the text value to appear.
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The dimension object will be complete, with the angle between the two edges 
displayed where you specified.

6. Click the Arrow tool to exit dimension mode.

NOTE: To display the obtuse rather than acute angle between two lines or edges, hold 
down the Option key after selecting the second edge, while clicking the point where the 
dimension text is to appear.

�  Area calculation

MacDraft’s automatic Area Calculation feature can determine and show the area of a 
selected object for you. If you later change the size of the object, the size shown changes 
automatically.

This feature can calculate the areas of simple objects, like rectangles and circles, or 
complex objects, such as complex polygons and freehand shapes. When the area of an 
object is calculated, it always reflects the current scale and units of the drawing.

Show Area

To calculate the area of an object

1. Select the object whose area you want to determine.

2. Open the View menu and choose Show Area.

The result of the area calculation will be shown in approximately the center of the 
object.
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Modifying area calculation values
MacDraft allows you to change the appearance and/or positioning of area calculation 
values. The current font attributes, including font type and size, are used for these values. 
MacDraft uses the Macintosh system font (usually 13-point Lucida Grande) as the preset 
font and size when you create a new document. There may be times when this font size is 
inconvenient, such as when area values are shown on small objects, and the size of the text 
value overwhelms the size of the object. 

MacDraft gives you the flexibility to change the value’s font type and size. In addition, it 
allows you to separate the values from their related objects and move them to any location 
on your drawing. In the case of small objects with area values, you can move the area 
values away from the object. If you want to tidy up your drawing, you can move these 
values into an information table. If you change the size of an object, the calculated value in 
the table will be updated automatically to reflect the object’s or line’s new size.

Changing font attributes

To change the font attributes before you use show area

1. Return to the pointer mode and make sure that no objects on the drawing are 
selected.

2. Open the Text menu’s Font submenu and choose the font you want.

3. Open the Text menu’s Size submenu and choose the text size you want.

4. Implement the area calculation feature.

The area calculation value text (and any subsequent text entered) will be shown in 
the font and at the text size specified (see Define attributes for text on page 4-9).

To change the font attributes for existing area calculation values

1. Select the area calculation value you want to change.

2. Open the Text menu’s Font submenu and choose the font you want.

3. Open the Text menu’s Size submenu and choose the text size you want.

The area calculation value text selected will be shown in the font and at the text 
size specified (see Define attributes for text on page 4-9).

NOTE: If you are printing to a PostScript printer, choose a laser printer font to obtain a 
high-quality output.
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Moving area calculation values
Area calculation text can be moved away from an object, but if the object is subsequently 
moved, the area calculation text maintains its position relative to the object. For example: 
If you moved the area calculation text from the center of a rectangle, repositioned the text 
above the rectangle, then moved the rectangle, the text would follow the movement of the 
rectangle and remain above it.

Alternatively, the area calculation text can be detached from an object and placed in a 
fixed location. If the object is moved the area calculation text remains in its specified 
position. This unique feature offers an extreme level of flexibility, especially if you want to 
place the values into an information table.

In both cases, the area calculation value remains associated with the object, and will be 
updated if the object is edited.

Moving attached area calculation values

Use this method if you want the area calculation text to remain attached to the object it is 
associated with. The text maintains its position relative to the object.

To move an attached area value

1. Position the cursor on the area value.

2. Press and hold down the Shift key.

3. Press and hold down the mouse button.

4. Release the Shift key.

5. Holding down the mouse button, drag the value to the desired location, then 
release the mouse button.

6. The area value text will be shown at the specified location, but maintains its 
position relative to the object if the object is moved.

NOTE: To constrain the movement of the value to a horizontal or vertical direction, keep 
holding the Shift key down as you drag the value to its new location.
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Detaching and moving area calculation values

Use this method if you want the area calculation text to be detached from the object it is 
associated with. The text remains in the fixed position even if the object is moved. The 
value remains associated with the object and will be updated if the object is edited.

To detach and move area calculation values

1. Select the area value you want to detach and move.

2. Open the Arrange menu and choose Ungroup.

3. Click a blank part of the drawing to deselect the object and value.

4. Position the cursor on the text value.

5. Press and hold down the mouse button.

6. Holding down the mouse button, drag the text to the desired location (into an 
information table, for example), and release the mouse button.

7. The text remains in the position specified even if the object is moved.

Hide Area
If a selected object shows an area calculation, the View menu command Hide Area will be 
available.

To hide the area calculation display

1. Select the object with the area you wish to hide.

2. Open the View menu and choose Hide Area.

The area calculation for the selected object will be no longer shown.
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Chapter 5 - Transforming and arranging objects
Once created, objects in your MacDraft drawing can be moved, duplicated, transformed, 
and arranged in many different ways. To avoid objects being altered in error, items can be 
locked. These features are discussed in this chapter.

MacDraft offers several useful drawing aids that help you to position objects easily (see 
Chapter 6 - Drawing aids on page 6-1).

�  Moving objects

You may create an object, then decide you want to move it to a new location on your 
drawing or into a different drawing. MacDraft provides several different methods of 
moving objects: drag and drop; cut/copy and paste; the Move command; the Resize 
palette; the arrow keys. Objects can also be removed permanently from the drawing using 
the Clear function.

Drag and drop
Drag and drop can be used to move objects to/from a MacDraft document to/from a 
variety of locations.

Drag and drop an object or group of objects from a MacDraft document to:

• The same document window (to move or copy the object or group).

• Another MacDraft document window.

• A Media Assistant Lite catalog. See Chapter 7 - Symbol libraries on page 7-1 for more 
information about using symbol libraries and Media Assistant Lite.

• The desktop to create a picture clipping.

• Any application that accepts PICT data by drag and drop.

Drag and drop an object or group of objects into a MacDraft document:

• Any PICT file can be dragged directly into a MacDraft document window.

• Items in other image and graphics file formats, such as JPEG and GIF files, can be 
dragged into MacDraft from a Media Assistant Lite catalog.
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The drag and drop process
In its simplest form, drag and drop can be used to move an object or group of objects 
within a MacDraft document. To perform other drag and drop actions, you must press 
additional “modifier” keys. The modifier keys required to perform specific actions are 
described later in this chapter.

To use drag and drop

1. Select the object you want to move by clicking it.

2. Position the cursor over the object.

3. Press down a modifier key if required (see next section).

4. Press and hold down the mouse button until the white arrow pointer appears.

NOTE: Be careful not to position the pointer on an edit handle when you move an 
object. Edit handles are for changing the size and shape of an object (see Chapter 2 - 
Creating and editing objects on page 2-1).

5. Holding down the mouse button, drag the object to its new location.
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6. Press down a modifier key if required (see next section).

7. Release the mouse button.

When you drag objects, “ghost” images of the objects will be visible as you drag 
them. The original stays in place until you release the mouse button.

Drag and drop modifier keys
Various keys perform a special function when used during the process of clicking the 
object(s) to be dragged. Once the drag action is started, these modifier keys have no effect 
and can be released. The same modifier keys may perform other functions when used 
during the process of releasing the mouse button to drop the dragged object(s).

Using drag and drop within a MacDraft document

To move an object within a MacDraft document using drag and drop

• No modifier key is required.

To copy an object within a MacDraft document using drag and drop

• Hold down both the Option and the Command keys at any time.

The original object selected remains in place, and a copy of it will be placed at the 
new location.

To constrain the movement of an object

• Hold down the Shift key while dragging an object to constrain the object's 
movement to either a horizontal or vertical direction.

NOTE: If you drag an object beyond the borders of the drawing area, the drawing 
automatically scrolls.



5 - 4 Chapter 5 - Transforming and arranging objects

Using drag and drop to copy an object out of a MacDraft document
• Hold down the Command key to turn Autoscroll off and allow an object to be 

dragged out of the active MacDraft document.

The object can then be dropped into another MacDraft document window, a Media 
Assistant Lite catalog, onto the desktop (to create a picture clipping), or into any 
other application that accepts PICT data by drag and drop.

To drag an object from the active MacDraft document to another document

1. Select the Arrow tool.

2. Hold down the Command key, click the object and, holding down the mouse 
button, drag the cursor over the destination document window.

A gray rectangle appears, showing the bounding frame of the object being 
dragged. If more than one object is dragged, a second rectangle, encompassing all 
the objects being dragged, is also shown. The maximum size of these rectangles is 
the size of the source document window.

3. Release the mouse button to drop a copy of the object into the second document.

The object remains the same size when placed in the new document, but may be 
displayed at a different scale according to the current view scale set for each 
document.
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NOTE: Press and hold down the Shift key and then release the mouse button to 
drop the dragged object(s) unscaled if the current scale of the destination MacDraft 
document differs from the scale of the object.

NOTE: It may be difficult to accurately place an object when using drag and drop 
to copy an object into a document with a different view scale. Objects dropped will 
always be aligned to the active grid, and MacDraft places the part of the object that 
was clicked in the original document, at the point that the mouse button is released 
in the new document, or as close to it as grid constraints allow (see Positioning 
objects on page 6-14).

PICT format

When dragging an object out of MacDraft to the desktop or to another application, the 
object is in PICT format, with extra MacDraft information held in special PICT comments 
within the PICT data. Objects can be dragged between MacDraft and the Clipboard (for 
example) without loosing any data, but applications are not required to preserve the extra 
data and may choose to remove it, especially if the object is edited. This means that an 
object brought back into MacDraft may not be as expected.
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Using drag and drop with multiple objects
To move multiple objects or grouped objects, simply select the objects or group you want 
to move, then drag the objects or group to a new position.

Alternatively, hold down the Shift key to drag only the object or group clicked, rather 
than all of the selected objects. 

Cut/copy and paste
By using the Cut, Copy and Paste functions, you can remove or copy objects from one 
location on your drawing, then paste them into another location in the same drawing, a 
different drawing, or a different application. 

The Cut function deletes selected objects from the drawing and places them on the 
Clipboard.

The Copy function makes a copy of selected objects and places the copy on the Clipboard, 
while leaving the original objects in place.

You can place several objects on the Clipboard as long as they are selected and cut or 
copied at the same time. The objects are stored on the Clipboard until you are ready to 
paste them onto the drawing, or until you use Cut or Copy function again.

NOTE: If you hold down the Option key, the Cut and Copy commands change to Cut 
Special and Copy Special. These commands can be used to place objects on the 
Clipboard as enhanced PICT images, allowing high quality PostScript® printing from 
other applications (see Enhanced PICT on page 5-10).

Using cut/copy and paste within a single MacDraft document

Cut and paste

To cut and paste an object

1. Select the object you want to move.

2. Open the Edit menu and choose Cut.

The selected object is removed from the drawing.

3. Click the place where you want to paste the cut object.

4. Open the Edit menu again and choose Paste.

The object reappears at the location where you clicked.
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You can continue to paste objects that have been cut into as many areas on your 
drawing as you like by simply selecting the insertion point and choosing Paste 
from the Edit menu. The objects remain on the Clipboard until you cut or copy a 
different object on your drawing, then the first object will be replaced with the new 
object on the Clipboard.

Copy and paste

The Copy and Paste functions allow you to make a copy of an object and paste the copy 
into another area of the drawing without affecting the status of the original.

To copy an object and paste the copy into a different location

1. Select the object you want to copy.

2. Open the Edit menu and choose Copy.

A copy of the object will be stored on the Clipboard for your use.

3. Click the place where you want to paste the copy.

4. Open the Edit menu again and choose Paste.

The object will be pasted in at the new location.

You can continue to paste objects that have been copied into as many areas on your 
drawing as you like by simply selecting the insertion point and choosing Paste 
from the Edit menu. The objects remain on the Clipboard until you cut or copy a 
different object on your drawing, at that time the first object will be replaced with 
the new object on the Clipboard.

Using cut/copy and paste to transfer items from one MacDraft document to
another
MacDraft allows you to cut/copy and then paste all or part of a drawing into another 
MacDraft document.

To cut or copy part of a drawing

1. Select all or the part of the drawing you wish to place in another document.

2. Open the Edit menu and choose Cut or Copy.

The selected objects will be stored on the Clipboard.

To paste objects into a different MacDraft document

1. Open the document into which you wish to paste the objects stored on the 
Clipboard.

2. Click the place where you want to paste the objects into the drawing.
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3. Open the Edit menu and choose Paste.

The objects that you cut or copied will be pasted into the specified location.

NOTE: When you cut or copy objects from one drawing and paste them into 
another drawing, the objects that you pasted take on the scale of the new drawing. 
For example, if you copy an object from a drawing with a scale of 1" = 20', then 
paste it into a drawing with a scale of 1" = 10', the object would appear twice as 
large as it did on the original drawing. In reality, the object is still the same size, but 
it is represented at the new scale. To avoid this use the Paste Unscaled feature (see 
Paste unscaled on page 5-8).

Paste unscaled

If you hold down the Shift key, the Paste command in the Edit menu changes to Paste 
Unscaled. Use the Paste Unscaled command to paste an object into a document and have 
it appear at its original size, regardless of any differences in view scale between the object 
and the destination document window.

Repeated paste
You may often want to use an object on your drawing in more than one location. To 
accomplish this you can use either the Copy and Paste functions, as described above, the 
Duplicate function (see Duplicating objects on page 5-17) or the Repeated Paste function. 
These functions save you the time of redrawing the object again and again.

The Repeated Paste function is used to paste multiple copies of the same object into 
various locations on a drawing. When using Repeated Paste, any object on the Clipboard 
is pasted into the drawing at each point you click. While in this mode, you can scroll the 
window and continue to paste in objects.

To use the repeated paste function

1. Cut or copy the object you want to paste.

2. Select the Repeated Paste tool in the Tool palette or open the Edit menu and 
choose Repeated Paste.

The cursor changes to an “X”. 

3. Click the point you want to paste the object.
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4. Continue to move the cursor and click the areas on the drawing until you’ve 
pasted as many copies of the object as you want into your document.

A copy of the object appears at each point you click the drawing. The object’s 
datum point will be used as the reference point for the paste operation (see Datum 
points on page 2-69).

5. Click the Pointer tool when you have finished pasting.

Viewing the Clipboard
You may sometimes want to see exactly what information, if any, is stored on the 
Clipboard.

To view the Clipboard

1. Open the Edit menu and choose Show Clipboard.

The Clipboard appears.

Using cut/copy and paste to transfer items from MacDraft to other
applications
At times you may want to use MacDraft in conjunction with other applications, such as a 
word processor or a chart program. For example, you may want to paste a chart into 
MacDraft to enhance its graphics appearance, then paste it into a page layout document.

Images can be pasted into another application’s document then printed, at the same sharp 
PostScript resolution available within MacDraft, using the enhanced PICT format.
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Enhanced PICT

An enhancement of the standard PICT image format allows high-resolution printing of 
PICT images in other applications. Enhanced PICT files combine PICT information with 
the PostScript® code that produces high-quality laser output.

With a color PostScript printer, an enhanced PICT image can be printed in color, even in 
an otherwise black-and-white word processing document.

Fills and lines in enhanced PICT images can be in any of the RGB color combinations 
possible with the Macintosh Color Picker and can be printed to a color PostScript printer.

NOTE: Enhanced PICT objects can only be printed reliably using Apple Computer’s 
LaserWriter printer driver, version 6.0 or later

Transferring objects from Microspot MacDraft

To transfer objects to other applications using PICT

1. Select the object or objects you want to move.

2. Open the Edit menu and choose Cut or Copy.

The selected objects will be placed on the Clipboard.

3. Switch to another application.

Once you leave MacDraft, all objects on the Clipboard will be converted to the 
PICT format.

4. In the new application, open the Edit menu and choose Paste.

The cut or copied objects appear as a PICT image in the new application’s 
document window.

To transfer objects to other applications using enhanced PICT

1. Select the object or objects you want to move.

2. Hold down the Option key.

3. Open the Edit menu and choose Cut Special or Copy Special.

A message reading Creating Enhanced PICT Clipboard... appears.

The selected objects will be placed on the Clipboard both as an image and as 
PostScript® code.

4. Switch to another application.
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Once you leave MacDraft, all graphic objects on the Clipboard will be converted 
to the PICT format, with the PostScript code for the original MacDraft image 
attached.

5. In the new application, open the Edit menu and choose Paste.

The cut or copied objects appear as a PICT image in the new application’s 
document window. When you print the document to a PostScript-compatible 
printer however, the printed output has the same high resolution as MacDraft 
printing.

The Move command
With the Edit menu’s Move command, you can move objects or groups with great 
precision by entering values from the keyboard.

Objects can either be moved to a specific location (absolute move), or moved by a 
specified amount (relative move). The setting for Absolute or Relative mode in the Move 
dialog will be stored for subsequent openings of the dialog, until the application is closed.

The coordinates or distances are shown in the current layer's scale and units.

The Move a Copy option places a copy of the selection in a specified location while 
leaving the original in place.

The datum point of the selected object or group (see Datum points on page 2-69) is used as 
the reference for moving. Therefore, to move an object, you specify the desired location 
(the X and Y coordinates) of the object’s datum point. If you select multiple objects or 
groups, MacDraft uses the datum point of the top left item as the reference.

Absolute move

To move objects or groups to a particular location on the drawing

1. Select the objects or groups you want to move.

2. Open the Edit menu and choose Move.

The Move dialog appears.



5 - 12 Chapter 5 - Transforming and arranging objects

3. Click the Absolute radio button if necessary. The current location of the selection 
will be shown.

4. Type in the X and Y coordinate values for the new location.

5. To leave the original in place, moving only a copy, click the Move a Copy 
checkbox.

6. Click one of the following buttons:

• Apply: To apply the changes and leave the dialog open.

• Close: To close the dialog without applying the changes.

• Done: To apply the changes and close the dialog.

The selection (or a copy of it) is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the coordinate 
system is the upper left corner of the window. The rulers along the top and left sides of the 
window are used to control the zero origins. In this default coordinate system, X values 
increase from left to right and Y values increase from top to bottom. 

You can change the zero origins of the rulers (see Rulers on page 6-8).

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Relative move
In relative movement, positive values for distance move items to the right (in the ∆X field) 
or downward (in the ∆Y field). Negative values move items to the left or upwards.

To move items relative to their original position

1. Select the objects or groups you want to move.

2. Open the Edit menu and choose Move. The Move dialog appears.
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3. Click the Relative radio button if necessary. The starting position will be shown as 
zeroes in the ∆X (horizontal change) and ∆Y (vertical change) fields.

4. Enter values to move the selection by into the ∆X and ∆Y fields.

5. To leave the original in place, moving only a copy, click the Move a Copy 
checkbox.

6. Click one of the following buttons:

• Reverse: To apply the entered values as though they were negative amounts.

• Apply: To apply the changes and leave the dialog open.

• Close: To close the dialog without applying the changes.

• Done: To apply the changes and close the dialog.

The selection (or a copy of it) is moved to the new location.

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

The Resize palette
Most of the controls on the Resize Palette are discussed in Chapter 2 (see Resizing objects on 
page 2-71). However the Resize palette can also be used to move a single object or group, 
and these controls are discussed in this section.

To display the Resize palette

• Choose Resize from the Window menu, or
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• Choose Resize from the pop-up menu at the bottom left of the document window.

NOTE: The Select Pt button is not relevant to the move operation.

Moving objects using the Resize palette
The Resize palette’s Position X and Y fields can be used to move a selected object or group 
to an absolute position on the drawing or by relative horizontal and vertical distances. All 
movement is defined in the units and scale of the document.

Absolute move

To move objects or groups to a particular location on the drawing

1. Select the objects or groups you want to move.

2. Open the Resize palette

3. Click the Absolute radio button if necessary. The current location of the selection 
appears.

Close button
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4. Type in the X and Y position values for the new location.

5. Click the Apply button.

The selection is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the coordinate 
system is the upper left corner of the window. The rulers along the top and left sides of the 
window are used to control the zero origins. In this default coordinate system, X values 
increase from left to right and Y values increase from top to bottom. 

You can change the zero origins of the rulers (see Rulers on page 6-8).

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Relative move

In relative movement, positive values for distance move items to the right (in the X field) 
or downward (in the Y field). Negative values move items to the left or upwards.

To move items relative to their original position

1. Select the objects or groups you want to move.

2. Open the Resize palette.

3. Click the Relative radio button if necessary. The starting position will be shown as 
zeroes in the X (horizontal change) and Y (vertical change) fields.
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4. Enter values to move the selection by into the X and Y fields.

5. Click the Apply button.

The selection is moved to the new location.

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Moving using the arrow keys
Selected objects and groups can be moved using the arrow keys on the keyboard.

When a grid is on (see Grid snap on page 6-14), each press of an arrow key moves (or 
“nudges”) the current selection one grid increment in the appropriate direction: left, right, 
up, or down. If no grid is on, the selection moves one screen pixel (1/72 of an inch) for 
each keystroke.

Press and hold down the Command key and press an arrow key to release the selection 
from an active grid and allow the selection to be moved one pixel at a time.

The Clear function
Objects can be removed permanently from the drawing using the Clear function. The 
object can only be recalled by using Undo before you perform any other action.

NOTE: You can also press the Delete key to delete selections.
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Using the Clear function

To clear a single object

1. Select the object to be deleted from the drawing by clicking it.

2. Open the Edit menu and choose Clear.

The selected object will be removed from the drawing.

To clear multiple objects

1. Select the objects to be deleted from the drawing by Shift-clicking them, or by 
using the selection rectangle (see Selecting objects on page 1-24).

2. Open the Edit menu and choose Clear.

The selected objects will be removed from the drawing.

To clear the entire contents of a document

There may be times when you want to throw away all the contents of the drawing and 
start over again. To accomplish this:

1. Open the Edit menu and choose Select All.

 All the objects on the drawing will be selected.

2. Open the Edit menu again and choose Clear.

All the objects on the drawing will be removed. 

�  Duplicating objects

Objects can be duplicated by using the Duplicate command.

The Duplicate command
The Duplicate command is used to make an exact copy of any object or line on the 
drawing. The duplicate object is placed in front of the original in a slightly offset position, 
and is selected. You can then drag the duplicate into the desired position on your 
drawing.
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Using the Duplicate command

To duplicate an object

1. Select the object you want to duplicate.

2. Open the Edit menu and choose Duplicate.

The object is duplicated. The duplicate object is placed in front of the original in a 
slightly offset position and is selected.
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3. To make a second or third duplicate, simply choose the Duplicate command again, 
and again. Each new duplicate appears in front of the previous one in a slightly 
offset position.

NOTES:
• Hold down the Shift key and the Duplicate command changes to Duplicate without 
offset. Use this option to create a duplicate that is placed directly on top of the original.
• Hold down the Control key to avoid duplicating locked objects. All other objects in the 
selection will be duplicated.

Auto-spacing of duplicate objects
If you want to create a row or column of identical, evenly spaced objects, the Duplicate 
function incorporates an auto-spacing feature that allows you to determine the distance 
and angle you want between objects. You can then make new duplicates that will be 
automatically placed at that distance and angle.
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To use auto-spacing during creation

1. Select the object to be duplicated.

2. Open the Edit menu and choose Duplicate.

3. Position the cursor over the selected duplicate, hold down the mouse button, drag 
the duplicated object to the desired position relative to the original, and release the 
mouse button. (Alternatively move the duplicate using the arrow keys.)
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4. Open the Edit menu and choose Duplicate again.

Notice that the second duplicate is automatically placed in the same position 
relative to the first duplicate as the first duplicate is to the original.

5. Keep choosing Duplicate to produce as many duplicates as you need.

�  Arranging objects

You can use some of the commands in the Arrange menu to manipulate the positions of 
objects. You can perform the following actions using these commands: move objects 
backwards and forwards; group and ungroup objects; distribute objects. The tools in the 
Alignment palette can be used also to distribute and align objects.

Moving objects backwards and forwards
When you create multiple objects  in a document, the newest object created appears on the 
top plane, while the oldest object appears on the bottom plane, that is, each new object 
appears on the plane above the previous object. At times, you might want to move an 
object in front of or behind other objects in the document. The functions that allow you to 
do this are Bring to Front, Send to Back, Move Forward One, and Move Back One.

Bring to front
If an object is currently behind other objects, you can move it in front of the other objects 
on the layer by using the Bring to Front function.
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To bring an object to the front

1. Select the object you want to move to the foreground.

2. Open the Arrange menu and choose Bring to Front.

The selected object will be moved in front of the other objects.
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Send to back

To reposition an object behind all other objects on the layer

1. Select the object you want to move to the background.

2. Open the Arrange menu and choose Send to Back.

The selected object will be moved behind the other objects.
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Move forward one

To move an object forward one level

1. Select the object you want to move forward.

2. Open the Arrange menu and choose Move Forward One.

The selected object will be moved forward one level.
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Move back one

To move an object back one level

1. Select the object you want to move back one level.

2. Open the Arrange menu and choose Move Back One.

The selected object will be moved back one level.
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Grouping and ungrouping objects

Grouping objects
In a drawing that contains several individual objects, you might want to group some 
objects together so that you can treat them as a single object. When objects are grouped 
together, most functions you choose will be performed on the entire group just as though 
it were a single object.

To group several objects together

1. Select all the objects that you want in the group.

2. Open the Arrange menu and choose Group.
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Notice that the objects are now surrounded by a single set of edit handles. This 
indicates that all objects within the edit handles are part of this group and will be 
treated as a single object. You can perform any function on the group, such as 
move, duplicate or fill, and the entire group responds to that command. Once you 
have grouped several objects, you cannot reposition or edit any individual object 
or piece of text within the group unless you first ungroup the objects.

Ungrouping objects
If you no longer require a set of objects to be grouped, or if you need to edit one of the 
individual objects, you can use the Ungroup function to return the objects to their 
individual status.

To ungroup objects:

1. Select the group of objects by clicking one of the objects.

2. Open the Arrange menu and choose Ungroup.

Notice that each object has its own set of edit handles again. This is an indication 
that the objects are no longer part of a grouped set, and that you can now select 
and edit each object individually.

Aligning and distributing objects

Aligning objects

Alignment palette

The Alignment palette provides tools for you to carry out alignments.

To display the Alignment palette

• Choose Alignment from the Palettes menu in the View menu, or

• Choose Alignment from the pop-up menu at the bottom left of the document 
window

Align Bottom Edges Align Top Edges

Align Horizontal CentersAlign Left Edges Align Right Edges

Align Vertical Centers
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NOTE: The remaining buttons are used to distribute objects along a line (see Distributing 
objects on page 5-29).

To use the Alignment palette

1. Select the object(s) to be aligned.

2. In the Alignment palette, click the desired alignment button.

The cursor will be displayed as ‘Click Reference Object’.

3. Click the object to align the other object(s) with.
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The selected object(s) will be aligned with the reference object according to the 
alignment tool chosen.

NOTE: To align objects to one element of a group (rather than to the group as a 
whole), hold down the Option key when the click reference object cursor appears, 
then click the element of the group to which you want to align the other objects.

Distributing objects
Objects can be positioned and aligned along a defined line. This can be done using the 
Distribute on Line command or using options in the Alignment palette.

Distribute on Line command

The Distribute on Line function allows you to position and align selected objects along a 
line that you define. The objects are distributed according to their level on the drawing, 
i.e. the object farthest back appears on the distribution line first, and the foremost object 
appears last. By default, the objects automatically align themselves along their centers, 
and will be equally spaced apart on the line. You can also choose to align the objects 
according to their datum points.
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To distribute objects on a line

1. Select the objects to be distributed.

2. Open the Arrange menu and choose Distribute on Line.

3. Move the pointer to the point on your drawing where you would like to place the 
first object. 

4. Press and hold down the mouse button.

5. Drag in the direction you want to distribute the objects.

6. Release the mouse button.
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The objects will be distributed along the line you specified. Their center points will 
be spaced equally apart along the line.

NOTES:
• To align objects according to their datum points, press and hold down the 
Option key before you open the Arrange menu and choose Distribute on Line.
• To constrain the line the objects are to be distributed along, hold down the Shift 
key as you define the line and it will snap to 45-degree increments.

Alignment palette

The distribute controls in the Alignment palette distribute objects in the same way as the 
distribute command, but the line is defined for you.

To display the Alignment palette

• Choose Alignment from the Window menu, or
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• Choose Alignment from the pop-up menu at the bottom left of the document 
window.

To use the distribute controls in the Alignment palette

1. Select the objects on the drawing to be distributed.

2. Click the appropriate button to distribute the objects horizontally or vertically by 
center or by datum point.

The objects will be distributed along a line in the manner specified.

�  Transforming objects

Objects can be transformed by rotating or flipping them.

Rotating objects
MacDraft provides several tools and commands that can be used to rotate objects freely or 
by specified amounts.

Rotate by 90° tool
The MacDraft Tool palette includes a Rotate by 90°tool:

Distribute horizontally

Distribute vertically

Distribute horizontally

Distribute vertically

by center

by center

 by datum

 by datum
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To rotate an object 90° anti-clockwise around its center

• Select an object in the drawing then click the Rotate 90° tool.

To rotate an object 90° clockwise around its center

• Select an object in the drawing and holding down the Shift key, click the Rotate 
90° tool.
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To rotate an object 90° anti-clockwise around its datum point

• Select an object in the drawing and holding down the Option key, click the Rotate 
90° tool. In this example the datum point is marked by a small circle (see Datum 
points on page 2-69).

Rotate tool and Rotate command
The Rotate tool and Rotate command allow you to rotate objects by any angle you want. 
You can rotate objects in various increments using the mouse; to enter a specific value 
through the keyboard, use the Rotate Options (see Rotate options on page 5-38).

You can rotate single objects, multiple objects, or grouped objects. Unless you specify 
otherwise, selected single or multiple objects will rotate around their individual centers. If 
you wish you can also specify the center of rotation for selected objects.

To enter rotation mode

• Choose Rotate from the Arrange menu, or

• Click the Rotate tool in the Tool palette
 

To exit rotation mode:

• Click the Pointer tool.
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Rotating an object

To rotate an object in five-degree increments (the default)

1. Select the object to be rotated.

2. Choose the Rotate tool or the Rotate command from the Arrange menu.

3. Position the cursor in the window, then press and hold down the mouse button. 

The cursor changes into a rotation indicator.

4. Holding down the mouse button, drag in a circular direction until you have 
rotated the object the desired number of degrees, and release the mouse button.

To see the exact number of degrees an object is being rotated, open the Show Size 
window (see Show Size on page 6-1).

To rotate an object in one-degree increments

• Press and hold down the Command key while rotating an object.

Changing the rotation units

To rotate an object in minutes or decimal fractions

1. Press and release the Shift key while rotating an object.

2. Continue to drag in a circular direction to rotate the objects in minutes. 
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The number of degrees remains fixed.

To rotate an object in seconds

1. Press and release the Shift key twice while rotating an object.

2. Continue to drag to rotate the objects in seconds.

As you rotate the object in seconds, the number of degrees and minutes are 
constrained.

Returning to previous rotation units

You can return to the previous rotation units (from seconds to minutes, and minutes to 
degrees) by using the Command key.

To return to the previous rotation units

• Press the Command key while in the rotation mode.

Rotating multiple objects

When rotating multiple objects, by default each object rotates around its individual center.

Rotating grouped objects

When rotating a grouped object, all the objects in the group rotate around the center of the 
group, unless you specify a different center of rotation.

Rotating text

The rotation feature works exactly the same way when you rotate a text block as it does 
when you rotate other objects. (See Selecting rotated text for editing on page 4-6 for 
information about selecting and editing rotated text blocks.)

Rotating bitmaps

Bitmaps can be rotated only in 90-degree increments.

Rotate your bitmap image in the same way you would rotate another object. When you 
release the mouse button the bitmap will rotate to snap to the nearest 90-degree 
increment.

Choosing the centre of rotation

Objects are usually rotated about their centers, however you can also specify any point on 
the drawing as the center of rotation.
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To rotate objects around a specified point

1. Select the objects you want to rotate.

2. Choose the Rotate tool or the Rotate command from the Arrange menu.

3. Position the cursor on the point you want to use as the center of rotation.

You can use the scroll controls to move to a part of the drawing that is outside your 
current view.

4. Press and hold down the Option key.

5. Press and hold down the mouse button.

6. Holding down the mouse button and the Option key, drag in a circular direction 
until you have rotated the object the desired number of degrees.

7. Release the mouse button and the Option key.

Rotate to zero command
The Rotate to zero command allows you to return an object to its original angle of 
rotation.
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To return an object to its original angle of rotation

1. Select a rotated object.

2. Choose Rotate to Zero from the Arrange menu.

The object will be returned to its original angle of rotation.

Rotate options
You can use the keyboard to directly enter the rotation values in degrees, minutes, and 
seconds using the Rotate Options dialog.

The Rotate Options dialog

To display the Rotate Options dialog

1. Select the object or objects you want to rotate.
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2. Choose Rotate Options from the Arrange menu.

The Rotate Options dialog appears.

Amount of rotation

The fields available to enter the rotation amount vary depending on the Angular Display 
option selected in the Document Scale and Units dialog (see Document units and scale on 
page 6-21). The above screen shot shows the field that appears when decimal degrees are 
selected.

To enter an amount for rotation, double-click the appropriate field and type in a value.

Direction of rotation

The default direction for rotation is counterclockwise. To rotate an object in a clockwise 
direction, click the Clockwise checkbox.

Center of rotation

The default center of rotation is the center of the selected object or objects. To rotate objects 
about their datum points, click the Datum of object(s) radio button (see Datum points on 
page 2-69). To rotate objects about a specified reference point, click the A reference point 
radio button.

If the A reference point radio button is on, the Rotate Options dialog disappears and the 
Rotation cursor will be shown over the drawing. Click the point you want to use as the 
center of rotation.
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To rotate an object or objects

1. Select the object or objects you want to rotate.

2. Choose Rotate Options from the Arrange menu.

The Rotate Options dialog appears.

3. Enter the desired angle of rotation.

4. Specify the direction and center of rotation.

5. Click the Rotate button.
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6. Specify the reference point to rotate about if necessary.

The selected object or objects will be rotated the specified number of degrees, 
minutes, and seconds around the requested center of rotation. 

Flipping objects
Sometimes you may want to display the reverse image of an object. For this, MacDraft has 
the Flip Horizontal and Flip Vertical commands.

You can duplicate an object and then use one of the Flip functions to create the other side 
of that object for the sake of symmetry, as well as convenience.

NOTE: Pictures can be flipped as well as objects, however text is treated slightly 
differently (see Flipping text on page 5-43).
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Flipping an object or picture

To flip an object horizontally

1. Select the object you want to flip.

2. Open the Arrange menu and choose Flip Horizontal.

The object will be flipped about its vertical axis.
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To flip an object vertically

1. Select the object that you want to flip.

2. Open the Arrange menu and choose Flip Vertical.

The object will be flipped about its horizontal axis.

Flipping text
Text is not flipped in the same way as objects, as often it does not make sense to produce a 
mirror image of text. However you may well want to flip a group that includes text, and 
have the text shown in its correct position and orientation in relation to the objects in the 
group. If you do want to produce a mirror image of text, use the Mirror text style (see 
Define attributes for text on page 4-9).

• Flip horizontal: The position of the text in the group is flipped, but the text 
remains at the same orientation.
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• Flip vertical: The position of the text in the group is flipped, and the text is rotated 
through 180°.

�  Lock and Unlock

You may sometimes want to make sure that objects on your drawing are not moved or 
changed by mistake. To do this you can use MacDraft’s Lock feature to make sure certain 
objects remain unchanged.

Locking and unlocking objects

Locking objects
Locked objects on the drawing cannot be edited, moved, copied, pasted, or deleted. None 
of MacDraft’s functions affect locked objects.

To lock objects

1. Select the objects you want to lock.

2. Open the Arrange menu and choose Lock.

The objects will be locked and the edit handles are dimmed to indicate this.

Original group Flip horizontal Flip vertical
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Unlocking objects
You may later realize that you need to edit locked objects. To do this, you must first unlock 
them.

To unlock objects

1. Select the locked objects you want to unlock.

2. Open the Arrange menu and choose Unlock.

The objects will be unlocked and the edit handles will be shown normally to 
indicate this.
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Chapter 6 - Drawing aids
MacDraft offers several useful features that make your drawing tasks much easier: show 
size, rulers, cursor position indicator, grid snap, angle snap, grid lines, snap to object and 
line snapping, and document units and scale. This chapter discusses these drawing aids in 
detail.

�  Show Size

MacDraft is a precision drawing application designed to help you create detailed 
drawings. The Show Size function makes it easier to draw objects precisely because it 
provides a continuous display of an object’s size as you draw or resize it. It also shows the 
degree of rotation as you rotate objects.

The units displayed in the Show Size palette are determined by the current options 
chosen in the Document Scale & Units dialog (see Document units and scale on page 6-21).

Displaying the Show Size palette

To open the Show Size palette

• Choose Show Size from the Window menu, or

• Choose Show Size from the pop-up menu at the bottom left of the document 
window.

The Show Size palette appears.
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Using Show Size with drawing tools

Line tools
When using line tools (including the Perpendicular, Tangent, Parallel, and Extrude tools), 
the Show Size palette displays the length (X) of the line and the angle(A°) at which the 
line is drawn.

Square-corner rectangles
When drawing square-corner rectangles, the Show Size palette displays the width (X) 
and height(Y) of the rectangle.

Text tool
When drawing a rectangle to define the block for paragraph text, the Show Size palette 
displays the width (X) and height(Y) of the rectangle.
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Regular polygons

Side to side

When drawing a regular polygon from side to side, the Show Size palette displays the 
side to side diameter (D) of the polygon.

Center to side

When drawing a regular polygon from center to side, the Show Size palette displays the 
center to side radius (R) of the polygon.

Vertex to vertex

When drawing a regular polygon from vertex to vertex, the Show Size palette displays 
the vertex to vertex diameter (D) of the polygon.
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Center to vertex

When drawing a regular polygon from center to vertex, the Show Size palette displays 
the center to vertex radius (R) of the polygon.

Rounded-corner rectangles

Proportional- and constant-corner rectangles

When drawing a proportional- or constant-corner rectangle, the Show Size palette 
displays the height(Y) and width(X) of the rectangle, and the radius(R) of the corners.

Elliptical-corner rectangles

When drawing a proportional- or constant-corner rectangle, the Show Size palette 
displays the height(Y) and width(X) of the rectangle, and the radius(R) of the corners.

When drawing an elliptical-corner rectangle, the Show Size palette displays the height 
(Y) and width(X) of the rectangle, and the major and minor radii of the arcs on the corners.
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Circles and ellipses

Circles by diameter

When drawing a circle by diameter, the Show Size palette displays the diameter (D) of the 
circle.

Circle by radius

When drawing a circle by radius, the Show Size palette displays the radius (R) of the 
circle.

Ellipses

When drawing an ellipse, the Show Size palette displays the width(X) and height (Y) 
diameters of the ellipse.
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Concentric circles

When drawing a concentric circle, the Show Size palette displays the radius (R) of the 
circle.

Arcs

By radius

As you drag to create the radius of an arc, the Show Size palette displays the length of the 
radius(R) and the starting angle(A˚). The starting angle is the angle between the line 
attached to the cursor and the X-axis.

Once you release the mouse button and move the mouse to create the arc, the Show Size 
palette changes to display: the difference between the starting angle and the ending angle 
of the arc, i.e., the actual number of degrees through which the arc passes(∆A˚); the angle 
between the ending angle (shown on-screen by the line attached to the cursor) and the X-
axis (A˚).

Arcs by three points

As you create an arc by three points, the Show Size palette does not become active until 
you are moving from the second to the third point in the arc. At that time, it shows the 
entire arc angle (A°).
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Elliptical arcs

When you start drawing an elliptical arc, the Show Size palette displays the height(Y) and 
width(X) of the ellipse used to define the size of the arc. It also shows you the starting 
angle (A˚), which is the angle between the line attached to the cursor and the X-axis.

When you finish defining the size and the starting angle of the arc, the window shows 
you: the difference between the starting angle and the ending angle, i.e. the actual number 
of degrees through which the arc passes(∆A˚); the angle between the ending angle (shown 
on-screen by the line attached to the cursor) and the X-axis (A˚).

Irregular polygons
When using irregular polygon or polyline tools (including the double-line polygon or 
polyline tools), the Show Size palette displays the length (X) of the line and the angle(A°) 
of the line, for each side of the polygon as it is drawn.

Using Show Size with rotation
When rotating an object, the Show Size palette displays how much you have rotated the 
object(A°).
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Angles of rotation range from zero to 360 degrees, moving counterclockwise from a 
rightward-pointing or “due East” orientation.

You can rotate objects in degrees, minutes and seconds, or in degrees and decimal 
fractions (see Rotating objects on page 5-32).

Hiding the Show Size palette

To remove the Show Size palette from the screen

• Click the palette’s close box, or

• Choose Show Size from the Palette submenu in the View menu, or

• Choose Show Size from the pop-up menu at the bottom left of the document 
window.

The Show Size palette disappears, and there will no longer be a checkmark against its 
name in the Window menu.

�  Rulers

Rulers are used as drawing aids to help you position objects in precise locations on your 
drawing. Rulers appear along the top and on the left side of the drawing window.

The displayed rulers reflect the current position of the window during scrolling, and their 
scale reflects the current magnification level.

Displaying rulers

To display rulers

• Open the Layout menu and choose Show Rulers.
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The rulers will be displayed, and a checkmark appears by the Show Rulers 
command in the Layout menu.

Types of rulers
MacDraft offers two types of rulers: standard and scale.

Standard rulers
Standard rulers show the actual size of the drawing in the units specified in the Set Scale 
and Units dialog (see Units on page 6-22).

To display standard rulers (if Show Rulers is checked)

• Open the Layout menu and choose Standard Rulers.

The rulers show the actual size of the drawing, in this example, in inches.

Scale rulers
Scale rulers reflect the current drawing scale of your document. For example, on a 1/4” = 
1' scale, the major ruler divisions will be in increments of four: 4 ft., 8 ft., and so on (see 
Document units and scale on page 6-21).

To display scale rulers (if Show Rulers is active)

• Open the Layout menu and choose Scale Rulers.

The rulers show the drawing measurements according to the scale specified.
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In this example, the scale is 1/4" = 1' and the size units are set at fractional feet and inches 
(see Units on page 6-22).

Setting the rulers’ zero points
There may be occasions when you want to change the zero point of the rulers from the 
upper left corner of your drawing to some other convenient point on the drawing. For 
instance, you may want to set the zero point of the rulers to one edge of an object so that 
you can position other objects relative to that particular point. For this reason, MacDraft 
allows you to change the zero points of the rulers. 

When you change the zero point of one or both of the rulers, the positioning of the new 
zero point is dependent upon the grid snap (see Using the grid snap function on page 6-15). 
You can change the zero point of either the top or left ruler independently, or change the 
zero points of both rulers at the same time.
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Setting the zero points of the rulers independently

To change the zero point of either the top or the left edge ruler independently of the other

1. Position the tip of the pointer on either ruler, at the place you want the new zero 
point for that ruler to be, and click.

The zero point is repositioned as specified.

To change the zero point of either the top or the left edge ruler back to the upper left corner

1. Hold down the Option key.

2. Position the tip of the pointer on the ruler you want to change and click.

The zero point for that ruler reverts to the upper left corner, while the other ruler’s 
zero point stays unchanged.

Setting the zero points of both rulers simultaneously
You can change the zero points of both rulers simultaneously by using the cursor. In this 
way, you can easily align the zero points of both rulers to a particular point on your 
drawing.
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To set the zero points for both rulers at the same time

1. Position the tip of the pointer in the box where the two rulers cross at the upper left 
corner of the drawing window.

2. Press and hold down the mouse button.

3. Drag diagonally downward and to the right until the cursor is positioned on the 
new zero point you want for both rulers.

4. Release the mouse button.

The zero points of both rulers are repositioned as specified.

To reset the zero points of both rulers to the upper left corner of your drawing

• Click the small box where the two rulers cross at the upper left corner of the 
drawing window.

The zero points will be reset.
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�  Cursor position indicator

The cursor position indicator shows the position of the cursor (that is, the crosshair cursor, 
the arrow pointer, and the various other cursor icons) on your drawing. This allows you to 
determine accurately the starting and ending points of an object, and also gives you the 
ability to discover the precise position of any point on your drawing.

The cursor position indicator shows the absolute position of the cursor in relation to the 
zero origin. The zero origin of the cursor position (X=0, Y=0) is determined by the zero 
points on the rulers. Therefore, if you move the zero points on the rulers, the zero origin of 
the cursor position indicator also changes. This feature is very useful, especially when you 
want to make measurements relative to a specific point on your drawing (see Setting the 
rulers’ zero points on page 6-10).

The cursor position indicator reflects the drawing environment. The X/Y position of the 
cursor’s position is displayed according to the scale of the drawing and in the size units 
that are currently selected (see Document units and scale on page 6-21).

Activating the cursor position indicator

To activate the cursor position indicator

• Open the View menu and choose Show Cursor Position.

The X/Y position of the cursor will be shown on the bottom left edge of the 
document window as shown below.

As you move the cursor around on your drawing, the cursor position indicator 
shows the cursor’s X/Y position relative to the zero points of the rulers.

Cursor position
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NOTE: If you click the cursor position indicator, the Palette menu appears 
providing an additional method of opening/closing palettes.

Hiding the cursor position indicator

To hide the cursor position indicator

• Open the View menu and choose Show Cursor Position.

The cursor position disappears, and the checkmark will be removed from the 
Show Cursor Position command in the View menu.

�  Positioning objects

MacDraft provides several features to aid in the precise positioning of objects: grid snap, 
angle snap, grid lines, snap to object and line snapping. The grid snap and angle snap 
features allow you to superimpose an invisible network of “magnets” over your drawing 
so that objects can be drawn, moved, or resized precisely and easily. Grid lines provide 
visual guidelines that assist you in drawing. Snap to object allows you to position one 
object directly next to another, and line snapping allows you to snap the end of lines to a 
specified point on another object.

For more information about drawing objects, see Chapter 2 - Creating and editing objects on 
page 2-1.

Grid snap
You should set the grid snap to the smallest length you need in or between objects in your 
drawing. For example, if you wanted to draw a line that is 5 3/4 inches long, you should 
set the grid snap to one-quarter inch. With the grid snap set this way, the cursor will snap 
to every quarter-inch increment as you draw the line.

Values shown in the Set Grid submenu will be always given in the current scale and unit 
system (see Document units and scale on page 6-21).

Setting the grid snap
Before you set the grid snap, you should choose a scale to be used for your drawing. The 
grid snap setting should be appropriate for that scale (see Document units and scale on page 
6-21). 
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To choose a new grid snap

1. Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu appears. A checkmark indicates the document’s current 
grid snap.

The Set Grid submenu shows the grid spacing for the current scale. Each scale has 
its own set of possible grid spacings. For example, a scale of 1:1 (1"=1") in 
fractional units will have increments as small as 1/64th of an inch and as large as 
1/4 of an inch.

2. Holding down the mouse button, drag through the submenu until the grid snap 
you want is highlighted, and release the mouse button.

The grid snap remains as set until it is changed again.

Using the grid snap function
When a grid snap other than None is chosen, any object you draw or move will 
automatically be positioned to the nearest grid snap position. You will not be able to begin 
or end a draw or move action between the grid snap positions. For example, if you were 
moving an object with the grid spacing set at 1/4 inch, the object would move in quarter-
inch increments. For information about the affects of grid snap on specific objects see 
Chapter 2 - Creating and editing objects on page 2-1.

You can activate or deactivate the grid snap to suit your needs at the time.

Turning the grid snap off and on

At times you may want to turn off the grid snap when you draw or move objects.

To turn off grid snap

1. Open the Layout menu and drag until Set Grid is highlighted.
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The Set Grid submenu appears.

2. Choose None to turn off the grid snap.

To turn on grid snap

1. Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu appears.

2. Choose the desired grid snap.

Releasing objects from the grid snap

You can temporarily suspend the grid snap function by holding down the Command key 
as you move or draw an object. This technique allows you to position an object on a 
location that does not fall at a grid snap point.

WARNING: If you turn the grid snap off while drawing or moving an object, that object 
will be removed from the grid. This means that it will be difficult for you to draw lines or 
borders tangential to the object, or align the object with other objects.

Snapping edges and lines along their lengths

As you draw an object with grid snap on, its edges get longer by small increments as they 
jump to the closest grid snap point. Rather than a line or edge snapping to the grid, hold 
down the Option key as you draw and the line or edge length will snap to increments of 
the current grid snap. For example, if the current grid snap is 1/4" and you draw a 30˚ line 
while holding down the Option key, the line length will grow in quarter-inch increments.

Angle snap
You should set the angle snap to the angle you need in or between objects in your 
drawing. For example, if you wanted to draw a line at an angle of 14 °, you should set the 
angle snap to 2°. With the angle snap set this way, the cursor will snap to two degree 
increment as you draw the line.

Setting the angle snap

To choose a new angle snap

1. Open the Layout menu and drag until Set Angle Snap is highlighted.
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The Set Angle Snap submenu appears. A checkmark indicates the document’s 
current angle snap.

The Set Angle Snap submenu shows the possible angle choices.

2. Choose the angle snap you want.

The angle snap remains as set until it is changed again.

Using the angle snap function
When an angle snap other than None is chosen, objects you draw or edit (that angle is 
relevant to) will be positioned automatically to the nearest angle snap position. You will 
not be able to draw lines between the angle snap positions. For information about the 
affects of angle snap on specific objects see Chapter 2 - Creating and editing objects on page 2-1.

You can activate or deactivate the angle snap to suit your needs at the time.

Turning the angle snap off and on

At times you may want to turn off the angle snap when you draw objects.

To turn off angle snap

1. Open the Layout menu and drag until Set Angle Snap is highlighted.

The Set Angle Snap submenu appears.

2. Choose None to turn off the angle snap.
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To turn on angle snap

1. Open the Layout menu and drag until Set Angle Snap is highlighted.

The Set Angle Snap submenu appears.

2. Choose the angle snap you want. 

Releasing objects from the angle snap

You can temporarily suspend the angle snap function by holding down the Shift key as 
you draw an object. This technique allows you to draw an object at an angle that is not an 
angle snap line.

Grid lines
Grid lines provide visual guidelines that assist you in drawing.

Hide/show the grid lines

The grid lines are shown by default, but you can hide them if you wish.

To hide grid lines

• Open the Layout menu and drag until Hide Grid Lines is highlighted.
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The grid lines are hidden and a checkmark appears by Hide Grid Lines in the 
Layout menu.

To show grid lines

• Open the Layout menu and drag until Hide Grid Lines is highlighted.

The grid lines will be shown again, and the checkmark will be removed from 
beside Hide Grid Lines in the Layout menu.

Snap to object
The snap to object feature allows you to position one object directly next to another. When 
snap to object is enabled, the cursor will snap to the vertices of existing objects. For 
example, you could draw a line and make one of its end points coincide precisely with the 
corner of a rectangle.

By default, the Snap to Object function is active when you open a new MacDraft 
document.

To turn off snap to object

• Open the Layout menu and choose Snap to Object.

The checkmark will be removed from the command, and snap to object will be 
turned off.

To turn on snap to object 

• Open the Layout menu and choose Snap to Object.

Snap to object will be turned on, and a checkmark appears next to its name in the 
Layout menu.
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Line snapping
MacDraft is able to snap the final point of a line to the mid point or end point of a straight 
edge or circular arc, or to the center of an object. This is done by holding down the M, E or 
C key while drawing a line.

NOTE: These snap keys can be used when drawing unconstrained lines (see Drawing basic 
lines on page 2-4), including lines drawn with the Mid point, End point and Center point 
line tools and Tangent from line tool (see Drawing special lines on page 2-46).

The mid point and end point snap keys, M and E, can be used when drawing a line to 
straight edged objects (lines, polylines, polygons and square-corner rectangles); any of 
these objects can be part of a group. The end point key, E, can also be used to snap the end 
of a line to the end of a circular arc. The center key, C, can be used to snap the end of a line 
to the center of any closed shape, including shapes within groups, but not with text 
objects, dimension objects, bitmap or pixel objects.

Drawing a line to the mid point of an existing edge, line or arc

To draw a line to the mid point of an existing edge or line

1. Choose a line tool from the Tool palette and begin drawing the line (see Drawing 
unconstrained lines on page 2-5).

2. Press and hold down the “M” key. The cursor will read “Mid?”.

3. Still holding down the “M” key, bring the cursor near to the edge or line you wish 
to snap the end point of the line to.

The line will snap to the mid point of the existing edge or line that is near the 
cursor.

4. Finish the line by releasing the mouse button.

Mid?
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The line appears on the drawing between the starting point and the mid point of 
the specified edge or line. The cursor reverts to the line tool, allowing another line 
to be drawn.

A line can be drawn to an end point of an existing edge, line, arc or center of an 
object in the same way, by holding down the “E” or “C” key instead of the “M” 
key.

�  Document units and scale

When setting up the drawing environment, you can choose the units in which you want to 
work. The units chosen affect the Show Size palette, the grid lines and grid snap, the scale 
options and rulers, dimension and area calculations and the units of rotation. The unit 
options can be set in the Document Scale and Units dialog.

Displaying the Document Scale and Units dialog
1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog appears.

2. Make any changes as discussed in the next section, and click the OK button to 
close the dialog and apply the changes.
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Units

English or metric units

To choose the units

• Click the radio button beside English or Metric, depending on the type of units 
you want to use in the document.

Unit size

To select the unit size

1. Click the unit size pop-up menu.

2. Choose the unit size option you want. Your choice appears on the button.

The numerical values shown on the drawing reflect the chosen units.

Decimal places
If you chose a metric or decimal English unit size, you can also specify the number of 
decimal places that you want to be displayed in numerical values. You can choose either 
one, two, three, or four places behind the decimal point, as well “None” (no places) to 
show integers only. Values will be rounded off to the selected number of decimal places. 
The default number of places behind the decimal is two. In larger scales, the number of 
decimal places allowed for display may be reduced automatically.

To change the number of decimal places

1. In the Document Scale and Units dialog click the Places button.
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The decimal places pop-up menu appears.

2. Choose the desired number of decimal places.

Once you have made your choice and closed the dialog, all numerical values will 
be rounded off to the selected number of decimal places.

Hide metric units
In some metric drawings, showing the units may be unnecessary. MacDraft allows you to 
hide the unit names so that areas and dimensions are shown in numerals only.

To hide metric units

1. In the Document Scale & Units dialog, click the Metric units checkbox. The Hide 
Metric Units check button becomes available.

2. Click the Hide Metric Units checkbox.

The option will be on, and the unit names will not be shown with the drawing’s 
dimension line and area values.

Scales
Before starting a drawing, you need to determine the sizes of the objects, and the paper 
you are going to use. For large drawings it is impractical to draw objects at their actual 
sizes; it is necessary to reduce them, yet still maintain their proper proportions.

A scale accomplishes this. A scale is the ratio of the object’s size on the drawing to its size 
in the real world. For example, if you choose a scale ratio of one inch equals ten feet (1" = 
10'), a line drawn ten inches long on a drawing would represent a 100-foot line in the real 
world. To avoid having to calculate the size of each object to the scale of the drawing, use 
the Show Size function (see Show Size on page 6-1).

MacDraft offers 25 different Feet & Inches scales and 22 Metric scales for your use. This 
versatility allows you to create a drawing at one scale, and then have it automatically 
converted to a different scale.
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You can also have multiple drawings, all at different scales, displayed on the screen at the 
same time. This makes it easy for you to copy and paste between drawings. When you 
paste an object into a drawing with a different scale, the object automatically adjusts in 
size to conform to the scale of the new drawing (see Cut/copy and paste on page 5-6). 
Alternatively you can use the Paste Unscaled command to paste an object into another 
document at its original size (see Paste unscaled on page 5-8).

Specifying the scale

To specify the default scale

1. In the Document Scale & Units dialog, click the Default Scale button to open the 
Scale pop-up menu. The options available depend on the units chosen.

2. Choose the scale you want.

The new scale will be shown in the Default Scale button.

3. Click the OK button to close the dialog and apply the changes.

The dialog disappears and your drawing now reflects the new scale
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If you create a drawing at one scale, and then decide later to change to a new scale, simply 
follow the steps outlined above to choose a new scale. In most cases the appearance of the 
objects on the drawing will either grow or shrink depending on the new scale chosen, 
however if there is text on the document you can choose if you want the text to be scaled 
or not.

Scaling text
If you change the scale of a document that contains text, an alert appears asking if you 
want to scale the text or not.

• Click Yes if you want the text to be resized according to the new scale, or

• Click No if you wish the text to be shown at the size it currently is on screen.

Angular display
The Angular Display choices let you specify the units in which you want rotation and 
angular dimensions to be shown and calculated.

You can choose to display the rotation units in decimal degrees (e.g. 63.58˚), in degrees 
and minutes (e.g. 51˚ 14'), in degrees, minutes and seconds (e.g. 47˚ 22' 30"), or in user 
defined units.

See Angular dimension objects on page 4-22 and Rotating objects on page 5-32 for information 
on using angular dimensions and rotating objects.



Chapter 6 - Drawing aids 6 - 26

Setting the rotation units

To specify the rotation units

• In the Document Scale & Units dialog, click one of the radio buttons in the 
Angular Display section, depending on the type of units you want to use in the 
document.

User defined units

If you click User defined units, you can specify the number of units to a circle by typing a 
value in the Units to a circle field.

With a value of 16 units to a circle, at one decimal place, 90° will be displayed as 4.0.

Decimal places

If you choose decimal degrees or user defined units for the units of angular display, you 
can also select the number of decimal places you would like to be displayed for angular 
values.

To change the number of decimal places

1. Click the Places button.
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The decimal places pop-up menu appears.

2. Choose the desired number of decimal places.

Once you have made your choice and closed the dialog, all angular values will be 
rounded off to the selected number of decimal places.
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Chapter 7 - Symbol libraries

�  Symbol libraries

Symbol libraries give you the ability to save, catalog, and reuse standard images or 
symbols. Previously created symbols can be taken out of symbol libraries and placed 
directly into your drawings. You can also create your own electrical and architectural 
symbols or commonly used images; these can then be stored in easy-to-access libraries, 
and inserted into drawings as required. The symbols in the libraries retain all their 
drawing attributes, such as their scale, and rotation.

Symbol libraries available
Microspot offers four sets of Microspot Symbol Libraries. These contain graphic images 
ready for use in MacDraft documents, or other applications, and provide you with many 
of the elements you need to complete or embellish your drawings quickly and easily.

Each component has been professionally drawn, using vectors rather than bitmaps, 
providing you with the highest possible quality of printing. Once placed in a drawing, a 
symbol can easily be edited to suit your own needs.

Sample library
A sample Media Assistant Lite library ‘MacDraft Libraries Sampler’ is included with 
MacDraft. To use any of the items in the library, simply drag and drop them into your 
MacDraft drawing.
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Library contents

Graphics Volume 1

Over 200 images of people, cars, trucks, trees and other landscape elements. This set is 
ideal for architects, illustrators and designers as well as for general graphics and 
presentations.

Graphics Volume 2

Contains over 200 graphic elements to help you create professional-looking 
organizational charts, design computer logic diagrams, embellish business charts, or add 
character to your correspondence and presentations.
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Architecture

A comprehensive set of over 1100 commonly used symbols for the creation of residential 
and light commercial construction drawings. These libraries provides architects, 
engineers and constructors with symbols that address the 16 standard specification 
formats used in construction drawings.

Electronic Schematic

Incorporates over two hundred symbols for a wide array of electronic components and 
elements used to create schematic diagrams. Everything from vacuum tubes to transistors 
and logic gate symbols is included.
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Volume 5

Over 200 images including computers and peripherals; road signs and lights; landscape 
elements; stars; signs to write on; maps; furniture and installations.

Purchasing symbol libraries
Contact your local supplier, or Microspot to purchase drafting symbol libraries. For 
contact details (see Registration information on page 1-3).

Microspot Media Assistant Lite
MacDraft Symbol Libraries are currently provided in Microspot Media Assistant catalogs. 
The Media Assistant Lite application is provided on your MacDraft CD and its features 
are discussed in depth in the Media Assistant Lite on-line manual. You can open the 
manual from the Media Assistant Lite application’s Help menu. A very brief description 
of using the MacDraft symbol libraries is provided here.

Open a catalog from within Microspot MacDraft
Media Assistant catalogs can be opened directly from within the MacDraft application.

To open a catalog

1. Open the File menu and select Open.



Chapter 7 - Symbol libraries, layers, slide shows 7 - 5

The standard open dialog appears.

2. Choose Libraries from the Show pop-up menu at the top of the dialog.

3. Locate the Media Assistant catalog you wish to use and click the Open button.

Media Assistant Lite will be launched and the selected catalog will appear.

Adding items to a catalog
If you draw an object or group of objects in your MacDraft document, and wish to store 
that object or group for use in other documents, it is easy to do so using one of the 
following methods.
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Using drag and drop

To drag and drop an object into an open catalog

1. Hold down the Command and Shift keys.

2. Click the object or group in your MacDraft drawing.

3. Still holding down the Command and Shift keys, drag the selection over the 
catalog window. 

4. Release the mouse button and the Command and Shift keys.

A copy of the object or group will be stored in the catalog.

Using Cut/Copy and Paste

To Cut/Copy and Paste an object into an open catalog

1. Click the object or group in your MacDraft drawing.

2. Choose Cut or Copy from the Edit menu. 

3. Click the Media Assistant Lite catalog you wish to store the object in.

4. Choose Paste from the Edit menu.

A copy of the object or group will be stored in the catalog.

Retrieving data
When you want to use a symbol or graphic stored in a catalog in a MacDraft document, 
you can retrieve items for use in the following ways:

Using drag and drop

To drag and drop an item out of a catalog into an open MacDraft document

1. Click the required item in the catalog to select it.

2. Holding down the mouse button, drag the item over the MacDraft document 
window.

3. Release the mouse button.

A copy of the item will be placed in the MacDraft document.

Using Cut/Copy and Paste

To Cut/Copy and Paste an item from a catalog into an open MacDraft document

1. Click the required item in the catalog to select it.
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2. Choose Cut or Copy from the Edit menu.

3. Click the MacDraft document you wish to place the item in.

4. Choose Paste from the Edit menu.

The item or a copy of it will be placed in the MacDraft document.

NOTE: Hold down the Shift key to choose Paste Unscaled from the MacDraft Edit 
menu (see Paste unscaled on page 5-8).

Saving catalogs
Media Assistant Lite has an auto save feature that automatically saves catalogs each time 
a new item is added or items are changed, so there is no need to save the catalogs.
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Chapter 8 - Drawing layout and printing

�  Drawing layout

Using MacDraft Personal Edition, you can create drawings of a limited size. If you wish to 
produce larger drawings, you must upgrade the Microspot MacDraft or Microspot PC 
Draft application. Contact your local supplier or Microspot for details (see Upgrade 
information on page 1-4).You define the desired drawing size by using Page Setup options 
in conjunction with the Drawing Size feature. The Page Setup dialog, opened by 
choosing the Page Setup command in the File menu, determines the size of the individual 
pages that make up the overall drawing area. The Drawing Size feature in the Layout 
menu, has a graphical interface that lets you select the number of pages needed to achieve 
the desired overall size of the drawing.

Before you define the overall size of your drawing using the Drawing Size feature, you 
should select the printer to be used, and set the Page Setup information for that printer in 
the Page Setup dialog.

Choosing your printer

To choose a printer

1. Launch the Print Center application.

The Printer List window appears listing the available printers.

2. Select the printer you want to set as the default printer.
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The printer name will be highlighted.

3. Choose Make Default from the Printers menu.

A mark appears next to the printer name indicating that it is the default printer.
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4. If you have changed the selected printer, an alert appears warning you to check 
your Page Setup options.

To add a printer

1. Launch Print Center.

The Printer List window appears.

2.  Click the Add Printer button.
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The sheet appears.

If your printer is connected directly, choose the appropriate setting from the pop-
up menu at the top of the dialog.

If the printer is connected over the network, choose Apple Talk from this pop-up 
menu.
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The connected printer appears in the list and will be highlighted.

3. Click the Add button. 

4. The printer appears in the Printer List dialog and will be set as the default printer.

5. Quit Print Center.

NOTE: For further information about choosing your printer, see the documentation 
provided with your printer/printer driver.
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Defining your page setup
The Page Setup options allow you to specify how you want your document to appear on 
the printed page. The Page Setup options available will be determined by the printer you 
selected in the Print Center (see Choosing your printer on page 8-1). The Page Setup dialog 
for the LaserWriter® is shown below.

Displaying the Page Setup dialog

• From within MacDraft, open the File menu and choose Page Setup.

A Page Setup dialog similar to the one below appears.

Page Setup options
Refer to your printer or printer driver documentation for complete details of the Page 
Setup options available. The most important choices: Paper, Orientation and Scale are 
discussed in the following sections.

When you have finished specifying the Page Setup options, click the OK button to close 
the Page Setup dialog.

Paper

Selecting the paper size

1. Click the Paper pop-up menu to display the paper sizes available for your printer.

2. Select the size of the paper that you will be printing on.
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NOTES:
• As MacDraft Personal Edition only allows you to produce drawings of a relatively small 
size, you may not be able to produce a drawing as large as your paper size.
• As most printers require some margin around the edges of the printed page, you will 
not be able to print to the full size of the paper. MacDraft will show appropriate page 
drawing areas (or block sizes) which take into account the required printer margins.

Orientation

Selecting the page orientation

• Click the Portrait icon to print objects vertically on the page.

• Click one of the Landscape icons to print objects horizontally on the page.

Scale

Selecting the scale

Enter a percentage value into the Scale text box to reduce or enlarge the printout of your 
drawing.

Defining your drawing size
Once you have specified the Page Setup options you are ready to define the overall size of 
the drawing.

To set the size of your drawing

1. Open the Layout menu and choose Drawing Size.
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A dialog appears, displaying the current total drawing size in the form of a block 
diagram.

The diagram is divided into blocks and represents the maximum drawing size 
available, each of the blocks representing a single page. The blocks that are 
darkened indicate the current drawing size.

2. Position the cursor on one of the darkened page blocks.

3. Press and hold down the mouse button.

4. Holding down the mouse button, drag until you have activated the number of 
page blocks required to make up the drawing size you want, then release the 
mouse button.

5. Click the OK button to close the Drawing Size dialog.
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NOTE: The MacDraft drawing window generally shows only a portion of the overall 
drawing. Therefore, when you change the drawing size it may not be noticeable until you 
zoom out or scroll to another area of the drawing.

Hiding and displaying page breaks
Page breaks are visual aids that can be useful when you create a large drawing. They can 
help you locate a particular area of the drawing quickly, and they allow you to see if an 
object happens to fall on the edge of a page, so you can move it if necessary. The page 
breaks are shown by default.

To hide page breaks

• Open the Layout menu and choose Hide Page Breaks.

A checkmark appears against the command in the menu to show that it is active.

To display page breaks

• Open the Layout menu and choose Hide Page Breaks again.

The checkmark will be removed from the command in the menu to show that it is 
inactive.
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�  Printing

Microspot MacDraft printing options
MacDraft gives you options to choose how pages are printed. For example, you can 
specify the order in which pages in a document are printed and whether or not 
registration marks are printed.

These options are set in the Drawing Size dialog.

Opening the Drawing Size dialog

To open the dialog

• Open the Layout menu and choose Drawing Size.

The Drawing Size dialog appears.

Specifying how pages are numbered
You can choose to number pages by column or by row. In either case, page one appears in 
the upper left corner of the document. Page numbers are not added to the document with 
these options but, as the pages are printed in number order, this setting affects the print 
order of the pages.

To number pages

• In the Drawing Size dialog, click one of the Page Numbering buttons, either by 
column (in ascending order from top to bottom), or by row (from left to right).
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Printing in reverse order
If your printer produces pages face up, it is useful to be able to print pages in reverse 
order so that the printed pages end up in order, starting with page one on the top.

To print the pages in the document from the last page to the first page

• In the Drawing Size dialog, click the checkbox beside Print Last Page First.

The pages will be printed in reverse order.

Printing registration marks
If required, you can print crop marks at the corners of each printed page to show the 
edges of the drawing area.

To print pages with registration marks

• In the Drawing Size dialog, click the checkbox beside Print Registration Marks.

Printing a document
Before you print, make sure that you have chosen the printer you want to use from the 
Print Center (see Choosing your printer on page 8-1), and have specified appropriate Page 
Setup options (see Defining your page setup on page 8-6).

Choosing your printing options
The printing options available will be determined by the printer selected in the Print 
Center. See your printer or printer driver documentation for details.

To choose your printing options

1. Open the File menu and choose Print.
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A dialog similar to the one below appears.

2. Set the print options according to your requirements then click the Print button to 
produce your printed document.
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Appendix A - Menus

�  File menu

New

Use to create a new untitled document or symbol library.

Open

Opens the standard Open dialog allowing you to locate and open other MacDraft 
documents, or Media Assistant Lite catalogs.

Close

Closes the document. Before closing, a dialog will ask if you want to save the changes 
made to the document.

Hold down the Option key and this command changes to Close All. Use to close all open 
documents. Again dialogs appear asking if you want to save any changes made to 
documents.

Save

Saves your drawing to disk. If the drawing has not been saved before, you will be asked to 
name the document and specify a location to save it. The drawing remains open.

Save As

Opens the Save dialog used to save a copy of the current drawing under a different name 
or in a different location. You will be asked to name the document and/or specify a 
location to save it. A copy of the drawing will be saved with the new name and/or in the 
new location.
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Revert

Reverts to the last saved version of the document. An alert appears, giving you the date 
and time the document was last saved, and asking you to confirm that you wish to return 
to the last saved version.

Export File

Opens the Export File dialog used to export a file in any format supported by QuickTime 
Graphic Exporters.

Page Setup

Opens the Page Setup dialog used to specify how you want your document to appear on 
the printed page. Options include paper size, orientation and scale.

Print

Opens the Print dialog used to print out the drawing. The printing options available will 
be determined by the selected printer, but usually include page range, number of copies 
and so on.
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�  Edit menu

Undo/Redo

Undo reverses the last operation performed. Redo performs an operation that was 
reversed by using the Undo command.

Cut

Removes a selected object from the drawing and places it on the Clipboard.

Hold down the Option key and this menu item changes to Cut Special. This command is 
used to place objects on the Clipboard as enhanced PICT images.

Copy

Copies a selected object from the drawing and places it on the Clipboard.

Hold down the Option key and this menu item changes to Copy Special. This command 
is used to place objects on the Clipboard as enhanced PICT images.

Paste

Pastes an object from the Clipboard onto the drawing at the point where you click.
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Hold down the Shift key and this menu item changes to Paste Unscaled. Use this 
command to paste an object into a document and have it appear at its original size, 
regardless of any differences in view scale between the object and the destination 
document window.

Clear

Removes a selected object from the drawing.

Repeated Paste

Use to repeatedly paste an object onto a drawing.

Copy Attributes

Use to copy an object’s graphic attributes (fill, pen color or pattern, line weight and line 
style etc.) and object information.

Apply Attributes

Use to apply copied attributes to selected objects.

Hold down the Shift key when you choose Apply Attributes and the Apply Attributes 
dialog appears. Use the Apply Attributes dialog to check and change the attributes before 
applying them to an object. Any changes made to the Apply Attributes dialog relate to 
the current apply action only.

Attributes Options

Opens the Attributes Options dialog used to check and, if necessary, change copied 
attributes before applying them. The settings remain as specified until changed or until 
the application is closed.

Duplicate

Use to make an exact copy of any object or line on the drawing.

Hold down the Shift key and this menu item changes to Duplicate Without Offset. Use 
this option to create a duplicate that is placed directly on top of the original.

Hold down the Control key and this menu item changes to Duplicate Unlocked. Use this 
command to avoid duplicating locked objects. All other objects in the selection will be 
duplicated.

Select All

Selects all the objects on the active layer.

Hold down the Shift key and this menu item changes to Select None. Use this option to 
deselect all selected objects.
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Move

Opens the Move dialog which allows you to move objects or groups with precision by 
entering values from the keyboard.

Expand

Opens the Expand dialog used to increase the size of an object by multiplying its 
dimensions by specified values.

Contract

Opens the Contract dialog used to reduce the size of an object by dividing its dimensions 
by specified values.

Reshape

Use the commands in the Reshape submenu to reshape an object so that straight lines and 
sharp corners become curved lines and rounded corners, or to reverse the smoothing 
action.

Show Clipboard

Opens the Clipboard window.
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�  Text menu

Font

The Font submenu lists the fonts installed on your system. Select the font you want to use 
from the list.

Size

The Size submenu lists the text sizes available. Select the text size you want to use from 
the list.
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Style

The Style submenu lists text styles. Select the text style to use from the list.

Justification

The Justification submenu provides options for justifying text. Select a horizontal and/or 
vertical justification option for text.

Line Spacing

The Line Spacing submenu lists line spacing options for text. Select the line spacing you 
want to use from the list.

Case

The Case submenu lists the case options available for text. Select the case option you want 
to use from the list.

Select All Text

Selects all text objects in the current layer.
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Hide Text

Hides text on the drawing. When this option is on, text is also omitted from printed 
output.

�  Options menu

Border Position

Opens a submenu that lists the options available for border positions. Choose the desired 
option from the submenu.

Edit Colors

Opens the colors palette. Select a color from the palette to edit it.
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Edit Patterns

Opens the patterns palette. Select a pattern from the palette to edit it.

Cross Cursor

Choose to activate and deactivate the crosshair-style drawing cursor. When Cross Cursor 
is active, the cursor appears as a large crosshair cursor which extends into the drawing’s 
rulers. When Cross Cursor is off, the cursor is displayed as a small cross.

Tool Options

Opens the Tool Options dialog for the selected tool (if available).

�  View menu

Zoom

Use the options in the Zoom submenu to increase or decrease the current magnification by 
a factor of two or four.
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Restore Prev. Zoom

Changes the view back to the previous level of magnification.

Home View

Changes view to display an unmagnified view of the upper left corner of drawing.

Show Cursor Position

Choose Show Cursor Position to show or hide the cursor position indicator. When Show 
Cursor Position is on, the X and Y coordinate position of the cursor will be displayed at 
the bottom left of the document window. When Show Cursor Position is off, this display 
does not appear.

Show Area

Calculates the area value of a selected object and displays the result in the center of the 
object.

Hide Area

Hides the result of the area calculations for a selected object.

�  Arrange menu

Bring To Front

Moves the selected object to the front of the active layer.
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Send To Back

Moves the selected object to the back of the active layer.

Move Forward One

Moves the selected object forward one level on the active layer.

Move Back One

Move the selected object back one level on the active layer.

Group

Links two or more objects so that they can be treated as a single object.

Hold down the Shift key and this command changes to Ungroup.

Ungroup

Converts grouped objects to their original individual state.

Rotate

Use to freely rotate a selected object.

Rotate To Zero

Choose to return rotated objects to their original orientations.

Rotate Options

Opens the Rotate Options dialog used to specify rotation for a selected object by entering 
precise units of rotation.

Flip Horizontal/Flip Vertical

Flips selected objects horizontally/vertically.

Distribute On Line

Distributes selected objects along a straight line, and spaces them equally about their 
centers or datum points.

Lock

Restricts objects so that they cannot be changed.

Unlock

Returns locked objects to their original condition so that they can be changed.
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�  Layout menu

Set Scale/Units

Opens the Set Scale/Units dialog which lets you choose the units, default scale and 
dimension standards for a drawing.

Set Grid

This submenu allows you to choose from the various grid snap options available in 
English or metric scales. The options reflect the current scale and size units chosen.



A - 13 Appendix A - Menus

Set Angle Snap

This submenu allows you to choose from the various angle snap options available.

Show Rulers

Choose to display or hide the rulers on the top and left sides of the drawing.

Scale Rulers

When Show Rulers is on, choose Scale Rulers to display rulers based on the current scale 
of the drawing. The scale rulers also reflect the current size units.

Standard Rulers

When Show Rulers is on, choose Standard Rulers to display the standard rulers which 
show the actual size of the drawing in the units specified in the Set Scale and Units 
dialog.

Snap to Object

Choose to turn Snap To Object on or off. When Snap to Object is on, objects you draw or 
move snap to the vertices of nearby objects on the drawing. When Snap to Object is off, 
objects you draw or move do not snap to nearby objects.

Hide Grid Lines

Choose to hide or show the grid lines.

Hide Page Breaks

Choose to show or hide the page boundary lines.
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Drawing Size

Opens the Drawing Size dialog which allows you to set the size of the drawing.

�  Window menu

Show/Hide All Palettes

Choose to show or hide all the application palettes.

Tool

Choose to show or hide the Tool palette.

Attribute

Choose to show or hide the Attribute palette.

Dimension

Choose to show or hide the Dimension palette.

Show Size

Choose to show or hide the Show Size palette.

Resize

Choose to show or hide the Resize palette.
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Alignment

Choose to show or hide the Alignment palette.

Tile Windows

Select to display open documents next to each other across and down the screen.

Stack Windows

Select to display open documents one on top of the other, and slightly offset from each 
other.

[Drawing Names]

Open drawings are listed at the bottom of the Window menu. Select the drawing name to 
make it the active document.

�  Help menu

MacDraft Manual

Choose to open the MacDraft manual in Adobe Acrobat Reader.

Registration Information

Opens the Registration dialog used to register your product via the Internet.

Upgrade Information

Opens the Upgrade Information dialog used to obtain information (if any) about 
upgrades from the Microspot web pages.
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Appendix B - Special usage of keys

�  Command keys

MacDraft Menu
Hide MacDraft Command H
Quit MacDraft Command Q

File menu
New Drawing Command N
Open Command O
Close Command W
Close All Command Option W
Save Command S
Save As Command Shift S
Page Setup Command Shift P
Print Command P

Edit menu
Undo/Redo Command Z
Cut Command X
Cut Special Command Option X
Copy Command C
Copy Special Command Option C
Paste Command V
Paste Unscaled Command Shift V
Clear Command Backspace
Duplicate Command D
Duplicate Without Offset Command Shift D
Duplicate Unlocked Command Control D
Select All Command A
Select None Command Shift A
Move Command Shift M
Smooth Command -
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Unsmooth Command Shift -

View menu
Zoom In 4X Command 1
Zoom In 2X Command 2
Zoom Out 2X Command 3
Zoom Out 4X Command 4
Restore Prev. Zoom Command [
Home View Command H

Arrange menu
Bring To Front Command F
Send To Back Command B
Move Forward One Command Shift F
Move Back One Command Shift B
Group Command G
Ungroup Command Shift G
Ungroup Command U
Rotate Command R
Rotate To Zero Command Shift R
Rotate Options Command Option R
Distribute On Line Command Shift T
Lock Command L
Unlock Command Shift L

Window menu
Minimize Window Command M
Show/Hide All Palettes Command Option K
Show/Hide Tool Palette Command Option 0
Show/Hide Attribute Palette Command Option 1
Show/Hide Dimension Palette Command Option 3
Show/Hide Show Size Palette Command Option 4
Show/Hide Resize Palette Command Option 5
Show/Hide Alignment Palette Command Option 6
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Notes
There are many Command Key, Command Shift Key and Command Option Key 
equivalents available. The following may be help you to remember them.

A Command Shift Key combination usually denotes doing the opposite of, or something related to, 
the equivalent Command Key combination. For Example,

Command A is Select All; Command Shift A is Select None.

Command R is Rotate; Command Shift R is Rotate To Zero.

Command P is Print; Command Shift P is Page Setup…

Command S is Save; Command Shift S is Save As…

A Command Option Key combination usually denotes choosing options for the related Command 
Key combination. For Example,

Command A is Select All; Command Option A is Select Special…

Command R is Rotate; Command Option R is Rotate Options…
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Appendix C - File formats

�  Supported file formats

MacDraft supports document files in the formats listed below.

Opening and saving MacDraft documents and stationery is discussed in Chapter 1 (see 
(see Document handling on page 1-4) and (see Saving and exporting on page 1-29)), symbol 
libraries and are discussed in Chapter 7 (see Symbol libraries on page 7-1). Files in other 
formats can be exported using the Export command (see Exporting a document on page 1-
32), and can be brought into a MacDraft document using copy and paste or drag and drop 
(see Drag and drop on page 5-1). The conversion issues involved in opening/saving or 
importing/exporting the remaining file formats are discussed in this appendix.

Microspot MacDraft can read files in the following formats

• MacDraft/PC Draft

• Stationery

• PICT

• Enhanced PICT

• Libraries

Microspot MacDraft can write files in the following formats

• MacDraft/PC Draft

• Stationery

• PICT

• Enhanced PICT

Microspot MacDraft can export files in the following formats

• BMP

• JPEG

• MacPaint

• PhotoShop

• PICT

• PNG

• QuickTime Image

• SGI Image
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• TGA

• TIFF

Opening documents in other formats
Many Documents in formats other than the MacDraft format can be opened directly from 
within MacDraft.. To open a document in a format other than Microspot MacDraft format

1. Choose Open from the File menu.

2. A standard Open dialog appears, listing documents in the current directory.

3. If necessary, open the Show pop-up menu, and select either the specific document 
format required, or All.

4. Locate the document you want to open.

5. Click the document name to select it.

6. Click the Open button.

MacDraft converts the drawing, and opens it in an untitled window.

NOTE: Large or complicated drawings may take some time to convert.

�  PC Draft

Microspot PC Draft 5.0
Exchanging documents between MacDraft Personal Edition 5.0 and PC Draft Personal 
Edition 5.0 presents no problems, as MacDraft and PC Draft documents are now fully 
interchangeable.

�  PICT or enhanced PICT documents

Saving a document in PICT or enhanced PICT format
Saving a document as a PICT allows you to transfer images into other applications that 
support the PICT format.
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The major benefits of using the PICT format are that it makes it easier to use graphics with 
certain page layout programs. Many word processors and page layout products can open 
PICT and enhanced PICT files directly, treating them as graphics inserted in text 
documents.

In addition, IDD (the original developers of MacDraft) developed an enhancement of the 
PICT format, allowing higher resolution printing of PICT images in other applications. 
Enhanced PICT files combine PICT information with the PostScript® data that produces 
quality laser output.

With enhanced PICT, images can be pasted into another application’s documents, then 
printed at the same sharp PostScript resolution available within MacDraft.

NOTE: The commands Cut and Copy, when used with the Option key, can move 
enhanced PICT images of MacDraft objects into the Clipboard and other applications (see 
The Move command on page 5-11).

To save a document in PICT or enhanced PICT format

1. Choose Save As from the File menu.

2. Choose PICT or enhanced PICT from the Format pop-up menu in the Save dialog.

3. Enter a new name for the document unless you intend to replace the existing 
MacDraft document with the PICT or enhanced PICT document.

4. Click the Save button.

When you choose to save a MacDraft document in the PICT or enhanced PICT 
format, some of the MacDraft attributes may be lost. However, this is usually not 
important for page layout programs, because these programs address a document 
merely as a picture.

In a document saved in the enhanced PICT format, the onscreen PICT image might 
not reflect all the attributes of a MacDraft image. However, the PostScript code 
embedded in the file has all the MacDraft attributes, so the printed output looks 
like the original MacDraft drawing.

The PICT format icon has a different appearance from a MacDraft drawing icon. 
The different icons are to help you distinguish between standard MacDraft 
drawings and PICT documents (including enhanced PICT documents).

NOTE: Because enhanced PICT files include both PICT images and PostScript 
printing code, those documents will often take considerably more disk space than 
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other MacDraft files. The more complicated the image, with more shapes and more 
edit handles, the larger the file will be.

Opening a document saved in PICT or enhanced PICT format
You can open a MacDraft file saved in the PICT or enhanced PICT format from the 
desktop by double-clicking, or from within MacDraft.

NOTE: MacDraft enhanced PICT files have the same icon as MacDraft PICT files as they 
are PICT files that contain PostScript data.

To open a document saved in PICT or enhanced PICT format

1. Open the File menu and choose Open.

2. Choose PICT or enhanced PICT from the Show pop-up menu in the standard 
Open dialog.

3. Locate and click the name of the document that you want to open.

4. Click the Open button.

MacDraft documents saved as PICT will not loose any information when reopened 
in MacDraft (unless edited in another application first).

NOTE: The two known outstanding exceptions to this are: Area calculations and 
Point to Point dimension lines. The displayed Area calculations loose their links to 
the parent objects, and Point to Point dimension lines will be broken into text and 
line objects.
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Numerics
1 to 1 tool, using to change drawing view  2-106

A
absolute resize  2-72
adding

marker symbols to drawing  2-68
text to drawing  1-13

aligning
objects  5-27

using the Alignment palette  5-27
parallel lines, options for  2-57
text  4-12

Alignment palette, show/hide  A-15
angle snap  6-16

releasing objects from  6-18
setting  6-16, A-13
turning off and on  6-17
using  6-17

angular
dimension objects, resizing  2-88
display, choosing units for  6-25

annotating drawing  4-1
see also area calculation, dimensioning, text

appearance, changing an object’s  3-1
see also fills, colors, patterns, pen, lines, border position

application requirements  1-1
arcs

by radius
changing the length of  2-26
changing the radius of  2-26
changing the size of  2-26
drawing  2-25

Index
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resizing  2-83
snapping to grid  2-26

by three points
changing the size of  2-27
drawing  2-27
resizing  2-84

choosing tools for drawing  2-24
concentric

drawing  2-31
snapping to grid  2-32

drawing  2-24
the Arc tool  1-13

elliptical
changing the length of  2-31
changing the shape of  2-30
changing the starting angle of  2-29
drawing  2-28
resizing  2-84
snapping to grid  2-31

area, see Show Area
Arrange menu  A-10, B-2
arranging objects  5-1, 5-21

bring to front  5-21, A-10
move back one  5-25, A-11
move forward one  5-24, A-11
send to back  5-23, A-11

Attribute palette, show/hide  A-14
attributes

see also fills, colors, patterns, pen, lines, border position
applying  A-4

using the Attribute tool  1-14
changing  3-1

before applying  A-4
using the Apply Attributes dialog  3-43, 3-45
using the Attribute Options dialog  3-43, 3-46

using the Attributes palette  3-1
using the fill and line indicator boxes  3-2
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checking before applying  A-4
using the Apply Attributes dialog  3-43, 3-45
using the Attribute Options dialog  3-43, 3-46

copying  3-41, 3-43, A-4
using the Attribute tool  1-14, 3-41
using the Edit menu  3-44

default  3-3
setting  3-3

displaying in the fill and line indicator boxes  1-6
options  A-4
selecting

for specific objects  3-4
using the Attributes palette  3-2
using the fill and line indicator boxes  3-2

B
backgrounds, of pictures  3-46
Bezier curves, see curves, Bezier
bitmap images

clipping  2-94
editing  2-90
resizing  2-91
rotating  5-36

BMP format, exporting in  1-32
borders

see also lines
border position  3-38, A-8

changing  3-40
drawing with a selected  3-39
how it affects objects  3-40
line centered  3-40
line inside  3-40
line outside  3-41
selecting  3-39

bring to front  A-10
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C
calculating area  4-23
cancelling actions  2-1
case, of text  A-7
catalogs, see symbol libraries
center point

lines, see lines, center point
snap end of line to, see lines, snapping, to center point

centered ellipse, see ellipses, centered
changes

reversing  2-95
redo  2-96
revert  2-97
undo  2-96

saving  1-30
changing

drawing size  1-22
drawing view, see view, changing
line length  2-6
object attributes

using the Attributes palette  3-1
using the fill and line indicator boxes  3-2

size of square corner rectangle  2-8
the appearance of objects  3-1

circles
add dimension objects using the Circle center mark tool  1-15
by diameter

changing the size of  2-18
drawing  2-17
resizing  2-81

by radius
changing the size of  2-18
drawing  2-17
resizing  2-81

by three points
changing the size of  2-19
drawing  2-18
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resizing  2-82
choosing tools for drawing  2-16
concentric

drawing  2-20
snapping to grid  2-21

drawing  2-16
using the Circle tool  1-13

snapping to grid  2-20
clear objects  A-4

using the Clear function  5-17
Clipboard

show/hide  A-5
viewing the  5-9

clipping bitmap images  2-94
closing

all documents  A-1
the current document  1-32, A-1

colors
choosing the number of colors to display  3-5
color table  3-5
editing  3-6
object fill  3-7
parallel fill  3-9
pen  3-11

command keys  1-8, B-1
concentric arcs, see arcs, concentric
concentric circles, see circles, concentric
constrained lines, see lines, constrained
contracting objects  2-89, A-5
copy  5-6, A-3

an object out of a MacDraft document using drag and drop  5-4
attributes  3-41, A-4

using the Attribute tool  1-14
enhanced PICT  A-3
objects on drawing  A-3
of a document, saving  1-30
special  A-3
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copy and paste
to move items within a MacDraft document  5-7
to transfer items from MacDraft to another application  5-9

using enhanced PICT  5-10
to transfer items from one MacDraft document to another  5-7
using with Microspot Media Assistant catalogs

to add items  7-6
to retrieve data  7-6

creating
a new document  1-4, A-1
objects  2-1

cursor  1-23
cross cursor, show/hide  A-9
position indicator  6-13

hide  6-14, A-10
show  6-13, A-10

curves
Bezier

changing the shape of  2-43
correcting while drawing  2-42
drawing  2-40
drawing straight line segments  2-43
modifying  2-43

freehand
drawing  2-37
resizing  2-85

spline
changing the shape of  2-46
drawing  2-44

cut  5-6, A-3
enhanced PICT  A-3
special  A-3

cut and paste
using to remove items in a MacDraft document  5-6
using to transfer items from MacDraft to another application  5-9

using enhanced PICT  5-10
using to transfer items from one MacDraft document to another  5-7
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using with Microspot Media Assistant catalogs
to add items  7-6
to retrieve data  7-6

D
datum points of objects  2-69
default attributes  3-3
defaults, setting for parallel line tool options  2-56
deleting text  4-7
deselecting objects  1-28
diagonal ellipses, see ellipses, diagonal
Dimension palette  1-14

show/hide  A-14
dimensioning

about dimension objects  4-13
angular dimension objects  4-15, 4-22

Angular dimension tool  1-15
choosing units for  6-25
resizing  2-88

circle dimension objects  4-21
Circle center mark tool  1-15

Dimension palette  1-14, 4-13
drawing dimension objects  4-15–??
horizontal dimension objects  4-15

Horizontal dimension tool  1-14
linear dimension objects  4-14, 4-15

reference points  4-15
resizing  2-87

perpendicular dimension objects  4-18
Perpendicular dimension tool  1-14

radial dimensions  4-14, 4-19
diameter dimension objects  4-20

Diameter dimension tool  1-14
radius dimension objects  4-19

Radius dimension tool  1-15
resizing  2-87
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resizing dimension objects  2-87
slope dimension objects  4-17

Slope dimension tool  1-14
types of dimension objects  4-13
vertical dimension objects  4-16

Vertical dimension tool  1-14
displaying

multiple document windows  1-15
page breaks  8-9
palettes  1-9
rulers  6-8
text  4-12
Tool palette  2-2

distributing objects  5-29
using the Alignment palette  5-31
using the Distribute on line command  5-29, A-11

document
close  A-1
close all  A-1
new

creating  A-1
creating from stationery  1-31

opening existing  1-4, A-1
from the File menu  1-5
from the Finder  1-5

revert to last saved version  A-2
save  A-1
save as  A-1
units and scale  6-21

displaying the Document Scale and Units dialog  6-21
units  6-22

decimal places  6-22
English or metric units  6-22
hide metric units  6-23
unit size  6-22

windows  1-6
displaying multiple  1-15
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drag and drop
using to move objects  5-1
using with Microspot Media Assistant catalogs

to add items  7-6
to retrieve data  7-6

drawing
aids  6-1
area  1-7
dimension objects  4-15–4-22
environment  2-1
layout  8-1
objects, using snap to object  6-19
page size, setting  1-21
position, changing using the Hand tool  1-12
scale, setting  1-20
select  A-15
size  8-7, A-14

changing  1-22
tools

choosing  2-2
using show size with  6-2

units, setting  1-18
duplicating objects  5-17, A-4

auto-spacing of objects  5-19
Duplicate command  5-17, 5-18
duplicate unlocked  A-4
without offset  A-4

E
edges, snapping along their lengths  6-16
Edit menu  A-3, B-1
editing

colors  3-6, A-8
objects  2-1
patterns  3-13, A-9
text  4-7
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using the Text tool  1-13
ellipses

centered  2-22
changing the size of  2-23
choosing tools for drawing  2-21
diagonal  2-22
drawing  2-21
resizing  2-82
snapping to grid  2-24

elliptical arcs, see arcs, elliptical
enabling the application  1-1
end caps, for parallel lines  2-59
end marks, of lines  3-36
end point lines, see lines, end point
end point, snap end of line to, see lines, snapping, to end point
enhanced PICT format  C-2

copy  A-3
cut  A-3
opening a document in  C-4
saving a document in  C-2

expanding objects  2-88, A-5
exporting

documents  1-32
in BMP format  1-32
in JPEG format  1-32

F
file formats

opening documents in other  C-2
supported  C-1

File menu  A-1, B-1
fill

object fill
color  3-7

changing an existing object  3-9
drawing with a selected fill color  3-8
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selecting  3-8
pattern  3-25

changing an existing object  3-26
drawing with a selected fill pattern  3-26
selecting  3-25

parallel fill
color  3-9

changing an existing object  3-10
drawing with a selected fill color  3-10
selecting  3-9

pattern  3-27
changing an existing object  3-28
drawing with a selected fill pattern  3-28
selecting  3-27

fill and line indicator boxes  1-6, 3-2
accessing attribute pop-up menus via  3-2
selecting attributes using  3-2

flipping objects  5-41
flipping an object or picture  5-42
flipping text  5-43
horizontally  A-11
vertically  A-11

font
select  A-6
size, select  A-6
style, select  A-7

formats
saving documents in other  1-30
supported file  C-1

formatting text  4-8
freehand curves

drawing  2-37
resizing  2-85

freehand drawing tools, choosing  2-37
freehand lines

changing the shape of  2-39
correcting while drawing  2-38
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drawing  2-37, 2-38
drawing a straight line as part of  2-39
reshape

smooth  2-71
unsmooth  2-71

freehand shapes
changing the shape of  2-39
correcting while drawing  2-38
drawing  1-13, 2-37, 2-38
drawing a straight line as part of  2-39
reshape

smooth  2-71
unsmooth  2-71

resizing  2-85

G
grid

lines  6-18
show/hide  6-18, A-13

snap  6-14, 6-15
releasing objects from  6-16
setting  6-14, A-12
snapping edges and lines to  6-16
turning off and on  6-15

grouping objects  5-26, A-11
groups, resizing  2-86

H
Hand tool, using to change drawing view  2-98
help  1-2
Help menu  A-15
hidden objects, selecting  1-26
hiding

Alignment palette  A-15
area calculations  4-26, A-10
Attribute palette  A-14
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Clipboard  A-5
cross cursor  A-9
cursor position indicator  6-14, A-10
Dimension palette  A-14
grid lines  6-18, A-13
metric units  6-23
page breaks  8-9, A-13
palettes  1-9, A-14
Resize palette  A-14
rulers  A-13
Show Size palette  6-8, A-14
text  4-12, A-8
Tool palette  A-14

hierarchical menus  1-7
Home View  A-10

selecting to change drawing view  2-106
horizontal justification of text  A-7

I
images, bitmap

clipping  2-94
resizing  2-91

increasing object size, see expanding objects
installing the application  1-1
interrupting the screen redraw  2-107
irregular polygons, see polygons, irregular

J
JPEG format, exporting in  1-32
justifying text  A-7

K
keys

Command  1-8, B-1
special usage of  B-1
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L
Layout menu  A-12
libraries, see symbol libraries
lines

attributes for  3-31
basic  2-4
center point  2-49

snapping to grid  2-50
changing the length of  2-6
choosing tools for drawing  2-4
constrained  2-4, 2-5
drawing

using the Line tool  1-12
using the Special line tool  1-13

end marks  3-36
changing  3-37
drawing with selected end marks  3-37
selecting  3-36

end point  2-49
snapping to grid  2-50

freehand
changing the shape of  2-39
correcting while drawing  2-38
drawing  2-37, 2-38
drawing a straight line as part of  2-39
reshape

smooth  2-71
unsmooth  2-71

grid lines, show/hide  6-18
mid point  2-49

snapping to grid  2-50
offset

drawing  2-54
snapping to grid  2-55

parallel, see parallel lines
perpendicular

drawing  2-47
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snapping to grid  2-49
resizing  2-78
snapping

to center point  6-20
to end point  6-20
to grid  2-6, 6-16
to mid point  6-20

spacing for text  A-7
special  2-46

choosing tools for drawing  2-46
style  3-34

changing  3-35
drawing with a selected line style  3-35
selecting  3-34

tangent  2-51
between circles or arcs  2-52
from a circle or arc to a point  2-51

unconstrained  2-4, 2-5
weight  3-32

changing  3-33
drawing with a selected line weight  3-33
selecting  3-32

locking objects  5-44, A-11

M
MacDraft format, saving documents in  1-29
magnification pop-up menu, using to change drawing view  2-105
manual, online  1-3, A-15
marker symbols  2-68

adding to drawing  2-68
using the Marker symbol tool  1-13

marquee zoom  2-102
menu

Arrange  A-10, B-2
Edit  A-3, B-1
File  A-1, B-1
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Help  A-15
Layout  A-12
Options  A-8
Text  A-6
View  A-9, B-2
Window  A-14, B-2

menu bar  1-7
menus

hierarchical  1-7
pop-up  2-3

Microspot Media Assistant  7-4, 7-4–??
adding items to a catalog  7-5

using cut/copy and paste  7-6
using drag and drop  7-6

opening catalogs  7-4
retrieving data

using cut/copy and paste  7-6
using drag and drop  7-6

saving catalogs  7-7
mid point lines, see lines, mid point
mid point, line snapping to, see lines, snapping to mid point
moving

objects  5-1–5-17, A-5
move back one  5-25, A-11
move forward one  5-24, A-11
to back  A-11
to front  A-10
using drag and drop  5-1–5-6

modifier keys  5-3
PICT Format  5-5
the drag and drop process  5-2
to copy an object out of a MacDraft document  5-4
with multiple objects  5-6
within a MacDraft document  5-3

using the arrow keys  5-16
using the Move command  5-11

absolute move  5-11
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relative move  5-12
using the Resize palette  5-14

absolute move  5-14
relative move  5-15

palettes  1-9
show area calculation values  4-26
text  4-11

multiple objects, selecting  1-27

N
naming an untitled document  1-29
new document, creating  1-4, A-1
number of sides, setting for regular polygons  2-14

O
object attributes, see attributes
objects, changing the appearance of  3-1
offset lines, see lines, offset
online manual  1-3, A-15
opening

documents in enhanced PICT format  C-4
documents in PICT format  C-4
existing documents  1-4, A-1

from the File menu  1-5
from the Finder  1-5

Options menu  A-8
options, tool  1-11

P
page breaks, showing and hiding  8-9, A-13
page setup, set options  A-2
page size, setting the drawing  1-21
palette

Alignment, showing and hiding  A-15
Attribute, showing and hiding  A-14
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Dimension  1-14
showing and hiding  A-14

Resize  5-13
displaying  2-71
showing and hiding  A-14

Show Size  6-1
showing and hiding  A-14

Tool  1-12
displaying  2-2
showing and hiding  A-14

palette tools  1-10
palettes  1-8, 1-12

hide  1-9
hide all  A-14
move  1-9
show  1-9
show all  A-14
using  1-9

parallel fill, see fill, parallel fill
parallel line objects, drawing  2-55

using the Parallel line tool  1-13
parallel lines

choosing tools for drawing  2-55
drawing  2-61
editing  2-61
extruding  2-65

from a line or edge  2-66
from a parallel object  2-67
snapping to grid  2-67

resizing  2-78
snapping to grid  2-62
tool options  2-56

alignment  2-57
end caps  2-59
line joints  2-60
line width  2-60
setting  2-57
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setting defaults  2-56
parallel polygons

changing the shape of  2-64
drawing  2-62
resizing  2-85
snapping to grid  2-64

parallel polylines
changing the shape of  2-64
drawing  2-62
extruding  2-65

from a line or edge  2-66
from a parallel object  2-67
snapping to grid  2-67

resizing  2-85
snapping to grid  2-64

paste
see also copy and paste, cut and paste
objects into drawing  A-3
repeated paste  5-8, A-4
unscaled  5-8, A-3

patterns
editing  3-13, 3-25, A-9
object fill  3-25
parallel fill  3-27
pen  3-29
using  3-12

PC Draft
4.3.5 file format  C-2
file format  C-2

pen
color  3-11

changing an existing line/border  3-12
drawing with a selected pen color  3-11
selecting  3-11

pattern  3-29
changing an existing line/border  3-31
drawing with a selected pen pattern  3-30
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selecting  3-29
perpendicular lines, see lines, perpendicular
PICT format  C-2

opening a document in  C-4
saving a document in  C-2

picture backgrounds  3-46
opaque  3-47
transparent  3-46

pointer
choosing the  1-25
mode, activating  1-24

polygons
irregular

changing the shape of  2-35
using major handles  2-35
using minor handles  2-36

choosing tools for drawing  2-33
drawing  1-13, 2-33
reshape

smooth  2-70
unsmooth  2-70

resizing  2-85
snapping to grid  2-36

parallel, see parallel polygons
regular

changing the size of  2-15
choosing tools for drawing  2-13
drawing  1-13, 2-13, 2-14
resizing  2-80
setting the number of sides  2-14
snapping to grid  2-16

polylines
changing the shape of  2-35

using major handles  2-35
using minor handles  2-36

drawing  2-33
parallel, see parallel polylines
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reshape
smooth  2-70
unsmooth  2-70

resizing  2-85
snapping to grid  2-36

pop-up menus  2-3
for tools  1-10

positioning
borders  A-8
objects  6-14
text  4-11

printing  8-10–8-12
choosing your printer  8-1
defining Page Setup

displaying the Page Setup dialog  8-6
orientation  8-7
paper  8-6
scale  8-7

defining page setup  8-6
options  8-10, 8-11, A-2

display the Drawing Size dialog  8-10
registration marks  8-11
reverse order  8-11
specifying how pages are numbered  8-10

Q
quitting the application  1-33

R
rectangles

drawing  2-7
round corner  2-11

changing the corner shape of  2-12
changing the size of  2-12
choosing tools for drawing  2-10
drawing  1-13, 2-9
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snapping to grid  2-13
with constant corners  2-10

resizing  2-79
with elliptical corners  2-10

resizing  2-80
with proportional corners  2-9

resizing  2-79
square corner

changing size of  2-8
choosing tools for drawing  2-7
drawing  1-13, 2-7

diagonally  2-7
from center  2-8

resizing  2-79
snapping to grid  2-9

redo  2-96, A-3
registering the application  1-3, A-15
registration marks, printing  8-11
regular polygon, see polygons, regular
relative resize  2-72
releasing objects from

angle snap  6-18
grid snap  6-16

removing, objects from drawing  A-3, A-4
repeated paste  5-8
requirements, application  1-1
reshaping

a block of paragraph text  4-4
freehand lines  2-71
freehand shapes  2-71
objects  2-69

smooth  2-69, A-5
unsmooth  2-69, A-5

polygons  2-70
polylines  2-70

Resize palette
displaying  2-71
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moving objects using  5-13
showing and hiding  A-14

resize units  2-77
resizing

bitmap images  2-91
dimension objects  2-87
groups  2-86
objects  2-72

absolute resize  2-72
by changing the absolute values of one point  2-73
by changing the relative values of one point  2-76
displaying the Resize palette  2-71
relative resize  2-72
resize units  2-77
whole object by absolute values  2-73
whole object by relative values  2-75

restore previous zoom  A-10
to change drawing view  2-106

reversing changes  2-95
redo  2-96
revert  2-97
undo  2-96

revert  2-97
to last saved version of document  A-2

rotating
bitmaps  5-36
objects  5-32–5-41, A-11

centre of rotation, choosing the  5-36
choosing units for angular display  6-25
grouped objects  5-36
multiple objects  5-36
rotate options  5-38, A-11

amount of rotation  5-39
center of rotation  5-39
direction of rotation  5-39
the Rotate Options dialog  5-38

units of rotation, changing the  5-35
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using show size with rotation  6-7
using the Rotate by 90° tool  1-14, 5-32
using the Rotate command  5-34
using the Rotate to zero command  5-37, A-11
using the Rotate tool  1-12, 5-34

text  5-36
round corner rectangles, see rectangles, round corner
rulers  1-23, 6-8

hide  A-13
show  6-8, A-13
types  6-9

scale  6-9, A-13
standard  6-9, A-13

zero points, setting  6-10
independently  6-11
simultaneously  6-11

S
saving

changes  1-30
copy of a document  1-30, A-1
document as stationery  1-31
document in another format  1-30, 1-31
documents  1-29, A-1
in enhanced PICT format  C-2
in MacDraft format  1-29
in PICT format  C-2
untitled document  1-29

scale  6-23
angular display  6-25

setting the rotation units  6-26
decimal places  6-26
user defined units  6-26

document  6-21
paste unscaled  5-8
rulers  6-9, A-13
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scaling text  6-25
setting for drawing  1-20, 6-24

screen redraw, interrupting  2-107
scrolling, to change drawing view  2-97
selecting

all objects  1-28, A-4
font  A-6

size  A-6
style  A-7

hidden objects  1-26
multiple objects  1-27
no objects  1-28, A-4
objects  1-24, 1-25

deselecting  1-28
using the Selection tool  1-12

text  1-29, 4-5
all  A-7

tools  2-2
send to back  5-23, A-11
setting

angle snap  6-16
grid snap  A-12
the drawing page size  1-21
the drawing scale  1-20
the drawing units  1-18

shapes, freehand, see freehand shapes
show

Alignment palette  A-15
area calculation  A-10
Attribute palette  A-14
Clipboard  A-5
cross cursor  A-9
cursor position  A-10
Dimension palette  A-14
grid lines  6-18, A-13
page breaks  A-13
palettes  A-14
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Resize palette  A-14
rulers  A-13
show size  A-14
text  4-12, A-8
Tool palette  A-14

show area  4-23
hide  4-26, A-10
modifying calculation values  4-24

changing font attributes  4-24
detaching  4-26
moving  4-25, 4-26

show  A-10
show size  6-1

the Show Size palette
hide  6-8, A-14
show  6-1, A-14

using with drawing tools  6-2
arcs  6-6
circles and ellipses  6-5
irregular polygons  6-7
line tools  6-2
regular polygons  6-3
rounded-corner rectangles  6-4
square-corner rectangles  6-2
text tool  6-2

using with rotation  6-7
size

see also show size
changing drawing  1-22
of objects

decreasing  2-89
increasing  2-88

Slope dimension tool  1-14
smooth objects  A-5

unsmooth objects  2-69
snap

set angle  A-13
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to object  6-19, A-13
snap to grid, set  A-12
snapping lines

to center point  6-20
to end point  6-20
to mid point  6-20

special lines, see lines, special
spline curves, see curves, spline
square corner rectangles, see rectangles, square corner
stacking windows  1-16, A-15
standard rulers  6-9, A-13
stationery

saving a document as  1-31
using for a new document  1-31

style, font, select  A-7
switching between drawings  1-17
symbol libraries  7-1

libraries available  7-1
Architecture  7-3
Electronic Schematic  7-3
Graphics Volume 1  7-2
Graphics Volume 2  7-2
Volume 5  7-4

Microspot Media Assistant  7-4
purchasing  7-4
sample library  7-1

T
tangent lines, see lines, tangent
text  4-1

aligning  4-12
case, selecting  A-7
deleting  4-7
editing  1-13, 4-7
entering  1-13, 4-1

paragraph text  4-2
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regular text  4-1
formatting  4-8

before entering  4-8
changing the case  4-11
define attributes  4-9
existing  4-8

hiding  4-12, A-8
inserting into existing text  4-7
justifying  A-7
line spacing, selecting  A-7
moving  4-11
positioning  4-11
replacing  4-7
reshaping a block of paragraph text  4-4
rotating  5-36
scaling  6-25
selecting  1-29, 4-5

all  4-6, A-7
rotated text for editing  4-6
using the Arrow tool  4-6
using the I-beam pointer  4-5

showing  4-12, A-8
Text menu  A-6
tiling windows  1-15, A-15
tool options  1-11, 2-4, A-9

for parallel lines  2-56
alignment  2-57
end caps  2-59
line joints  2-60
line width  2-60
setting  2-57
setting defaults  2-56

Tool palette  1-12
hide  A-14
show  2-2, A-14

tools
palette tools  1-10
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pop-up menus for  1-10
selecting  2-2

transforming objects  5-1, 5-32

U
unconstrained lines see lines, unconstrained
Undo  2-96, A-3
ungrouping objects  5-26, 5-27, A-11
units

choosing for angular display  6-25
document, setting  1-18, 6-21
resize  2-77

unlocking objects  5-44, 5-45, A-11
unscaled, Paste Unscaled  5-8, A-3
unsmoothing objects  A-5
untitled documents, saving  1-29
upgrade information  1-4, A-15

V
vertical justification of text  A-7
view  2-97

changing
by scrolling  2-97
by zooming in  2-99, 2-100, 2-104
by zooming out  2-99, 2-100, 2-101, 2-103
using marquee zoom  2-102
using the 1 to 1 tool  1-14, 2-106
using the Hand tool  2-97, 2-98
using the Home View command  2-106
using the Magnification pop-up menu  2-105
using the Restore Previous Zoom command  2-106
using the Zoom commands  2-103
using the Zoom tool  1-14

Home View  A-10
View menu  A-9, B-2
view, changing using the Hand tool  1-12
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viewing the Clipboard  5-9

W
Window menu  1-15, A-14, B-2
windows, document  1-6

stacking  1-16, A-15
switching between  1-17
tiling  1-15, A-15

Z
zero points of rulers, setting  6-10
zoom  1-14, A-9

commands  2-103
in  2-100, 2-104
marquee zoom  2-102
out  2-99, 2-100, 2-101, 2-103
restore previous  2-106, A-10
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