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CHAPTER 1 - GETTING STARTED

� Introduction

Thank you for choosing PhotoFix, the affordable, easy to use alternative to today's 
complex photo retouching applications for the Macintosh®. Designed for novices as 
well as professionals, PhotoFix provides all the tools you need to enhance scanned or 
Photo CD images and produce professional quality artwork. 

PhotoFix includes a wide range of painting, drawing and retouching tools, as well as 
numerous editing functions like cloning, feathering and masking.

� Requirements

Microspot PhotoFix minimally requires:

• Macintosh System Mac OS X (10.0.4 or later recommended)

• Any Macintosh computer (including iMacs and iBooks) with G3-233 MHz 
processor or faster

• 128 Mb RAM

• 12.5 Mb free hard disk space

• Color monitor, 800 x 600 (1024 x 768 recommended)

• QuickTime 5.0 

� Installation

To install Microspot PhotoFix double-click the PhotoFix installer icon and follow the 
instructions in the dialogs that appear. PhotoFix and its associated files will be 
installed in the specified location on your hard disk.
Microspot PhotoFix 1 - 1



The Microspot PhotoFix folder will contain the following items:

Figure 1.1

Also, an alias to the application will be placed on the desktop.

� Working Efficiently

File size is an important parameter that affects the overall time it takes to edit your 
image. Make sure you choose a resolution that is suitable for your printer since the 
higher the resolution, the larger the size of the file and thus the longer the calculation 
time is. 

� Documentation

The PhotoFix online manual in PDF format is installed with the application. The 
PhotoFix Manual file is placed in the same folder as the PhotoFix application in order 
to be accessed from within the application.
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Choose PhotoFix Manual from the Help menu and a default system application for 
reading pdf files will open the online manual. You can then navigate through and read 
the manual on screen, or print sections for your reference.

� Technical Support

You register your product in order to receive technical support, as well as upgrade and 
new product information. In North America, South America and Australasia, please 
contact:

Macro Enter Corp.

1756 Costa del Sol
Boca Raton FL 3343
USA

Phone: +1 (561) 395-9996
FAX: +1 (561) 395-9941

email: sales@macroenter.com
Web Page: www.macroenter.com

Elsewhere in the world, please contact:

Microspot Limited

Concorde House
10-12 London Road
Maidstone
Kent ME16 8QA
England

Tel: +44 (0)1622 687771
Fax: +44(0)1622 690801

email: sales@microspot.co.uk
Web Page: www.microspot.co.uk
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� Tutorial

Even if you do not read the Reference section of this manual, we strongly recommend 
you run through the PhotoFix tutorial in order to gain a working knowledge of the 
product's powerful features.
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CHAPTER 2 - TUTORIAL

� Setting PhotoFix Preferences

EXERCISE: Customize PhotoFix General Preferences.

1.  To launch the application open the PhotoFix folder and double-click the 
application icon. 

2.  Choose Preferences from the PhotoFix application menu.
3.  Choose General to show the General Preferences dialog.

Figure 2.1
4.  Unit. Choose Inches from the pop-up menu. (You can also show units of 

measure in pixels or centimeters.)
5.  Image Icon. Choose the Miniature option to show file icons as miniature 

representations of the images they contain. If you choose the Standard 
option, files are shown with the PhotoFix icon and will show the format type 
(PICT, TIFF, JPEG, BMP, etc.) 

6.  Default Palette. This allows you to set a default palette for use with new 
documents. The options are Bitmap, Grayscale, System or RGB color. 
Choose RGB color.

7.  Click OK.
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EXERCISE: Customize PhotoFix Memory and Plug-ins Preferences

1.  Choose Preferences from the PhotoFix application menu.
2.  Choose Memory and Plug-ins to show the Memory and Plug-ins 

Preferences dialog.

Figure 2.2
3.  Scratch Disk/Folder. To choose a different scratch disk (the place where 

PhotoFix will save any temporary items) or folder, click the pop-up menu 
and choose Other. Choose the PhotoFix folder using the dialog that appears.

IMPORTANT: You must choose a scratch disk or folder other than the 
default Temporary Items folder if you turn on the When Power Failure 
option (discussed  in Step 4). This is very important since the Temporary 
Items folder is automatically put in the Trash upon startup. 

Save Open Images

An important benefit of PhotoFix’s unique virtual memory management is the ability 
to recover unsaved data. If you turn on the When “Quit Special” option, PhotoFix will 
allow you to quit without saving changes to your work, then later open the same file 
with your changes intact. 

4.  Click the When “Quit Special” option to turn it on. To ensure recovery of 
unsaved data after a power failure or computer crash, also click the When 
Power Failure option. 

5.  Plug-ins Folder. Use the pop-up menu to choose the plug-ins folder.
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Multiple Undos

PhotoFix allows you to specify up to 32 levels of Undo. While defining multiple levels 
of Undo is practical for design and creation, specifying fewer levels of Undo 
minimizes disk transfers, saving time and energy. 

Keep in mind that Multiple Undo files take up disk space. If you need to increase your 
free disk space, you can delete temporary Undo files using the Memory Space option 
from the Edit menu.

6.  Set Multiple Undos at 6.
7.  Click OK.

� PhotoFix Palettes

EXERCISE: Explore the PhotoFix palettes.

1.  In order to show the PhotoFix palettes, you must first open a document. 
Choose Open from the File menu, then open the Tutorial Images folder in 
the Microspot PhotoFix folder. Double-click any image.

See Chapter 4 - Palettes on page 4 - 1 for more details about the PhotoFix palettes. 
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Tool Palette

          Figure 2.3
2.  When you double-click a tool, a Tool Settings dialog appears, use this to 

configure the chosen tool for your particular needs. 

NOTE: For more information about any tool, click the desired tool, then 
choose Tool Info from the Help menu.

                                   Lasso
Rectangular Selection Tool
            Oval Selection Tool

                            Line Tool
 Rectangular Drawing Tool
                                  Pencil
                       Paint Bucket
                              Airbrush
                            Blur Tool
                         Dodge Tool
                     Gradient Tool

                          Zoom Tool

 Magic Wand
 Crop Tool
 Straighten/Rotate Tool

 Oval Drawing Tool
 Text Tool
 Paint Brush
 Eraser
 Clone Tool

 Sharpen Tool
 Burn Tool
 Color Sampler

 Hand Tool
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Color Palette

    Figure 2.4
3.  If the bottom portion of the Color Palette is not visible, click the disclosure 

triangle next to the Color Controls to extend the palette.
4.  Click the Foreground Color Indicator and drag the Brightness Adjuster 

slider to the center. 
5.  Drag the small circle in the Color Picker to see how the foreground color 

changes. Slide the Brightness Adjuster from left to right to view the 
changes in shades. (This can be done for the Background Color Indicator, 
as well.) Notice how the Gradient Preview shows the gradient between the 
foreground and background colors.

6.  Use the Four Color Gradient Sampler to mix colors. Click a color in the 
Color Picker, then move the pointer to one of the four squares in the Four 
Color Gradient Sampler and click again. (Note that the pointer will change 
from a Color Sampler to a Paint Bucket). Repeat this procedure until each 
square contains a different color. 
You can now use the Color Sampler tool to sample any color from the Four 
Color Gradient Sampler, then apply it to your document using one of the 
painting or drawing tools.

                     Color Picker

           Brightness Adjuster

 Foreground Color Indicator

 Background Color Indicator

       Gradient Preview

       Color Storage Area

   Switch Foreground/Background Colors

 Change Foreground to Black/
 Background to White

       RGB Profile of Current Color

 Four Color Gradient Sampler
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Info Palette

 Figure 2.5

Image Controls

Two other useful controls can be found at the bottom of PhotoFix image windows.

Figure 2.6

PhotoFix provides a convenient pop-up menu so you can easily zoom in for close-up 
views, or zoom out to fit an entire image on your screen. You can use the View/Change 
Resolution pop-up menu to increase or decrease an image's resolution, and therefore 
its physical dimensions, while maintaining its file size. 

7.  Close the document. Do not save it.

 Image Size

 Position of Pointer Relative to

 Top Left Corner of the Image

 File Format

 Image Mode Palette pop-up menu

 Selection Area Size

 Type of compression

Zoom In & Zoom Out
View/Change Resolution
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� Creating a New Image

EXERCISE: Design a postcard.

1.  Choose New... from the File menu. 

Figure 2.7
2.  Give the new file a resolution of 72.00 dpi. 
3.  Choose Postcard from the Format options, then choose Empty (white) 

from the Contents options. Click OK.
4.  To add colors to the Color Palette, start by dragging the Brightness 

Adjuster slider to the center, then click a color in the Color Picker. Move 
the pointer to the Color Storage Area, position it over one of the squares 
and hold down the Option key. When the pointer changes to a Paint Bucket, 
click the square to save the chosen color.                                                                      
Repeat these steps until you have several colors to choose from.
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Figure 2.8
5.  Apply a color to the entire image by choosing the Paint Bucket tool and 

moving it to the Color Storage Area. (The pointer will change to a Color 
Sampler tool.) Click a color, move the Paint Bucket to the canvas and click 
again.

Figure 2.9
6.  Double-click the Line tool and set vertical and horizontal line thickness at 1.
7.  To make the foreground color black, go to the Color Palette and click the 

Change Foreground to Black and Background to White option. Then 
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hold down the Shift key and draw two parallel horizontal lines in the top left 
corner of the image. 

8.  Click the Rectangular Drawing tool and draw a square in the top right corner 
of the image.

9.  Choose the Text tool and click the image. When the Text Settings dialog 
appears, enter an address in the textbox. Choose a font and any other 
attributes, click the Floating Selection radio button, then click OK.

Figure 2.10
Microspot PhotoFix 2 - 9



10.  The pointer will become a Hand tool when you move it over the text. Drag 
the text to the center of the card. Choose Select None from the Selection 
menu to deselect the text.

Figure 2.11

NOTE: If the Text Settings dialog reappears as you attempt to move the 
text, click Cancel. Or, if you accidentally place the text in the wrong spot, 
choose Undo from the Edit menu until the text starts floating again. You 
can then reposition it.

11.  Choose Save As from the File menu and name your file “Postcard Back.” 

File Format

PhotoFix allows you to save files in the following formats: JPEG/JFIF, Windows BMP, 
PICT, PICT with Alpha Channel, PICT with Quick-Time compression, TIFF, TIFF 
with Alpha Channel, EPS, EPS with mask, and PhotoFix internal format. If you are 
planning to place images in a layout application, saving them as TIFF files will allow 
you to modify their brightness and contrast within the layout application.

Compression Format

You can also compress images to save disk space. In some cases, a compressed file 
may take up to 10 times less space than the same uncompressed file. JPEG 
compression offers the greatest reduction in file size, however it also proportionately 
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reduces the quality of the image. You may want to try each of the compression modes, 
then choose the one that best suits your needs.

12.  Save the file and choose a type of compression (if desired) by clicking the 
Format Options button.

Figure 2.12
13.  Close the file. 

� Making a Constrained Selection

EXERCISE: Add a graphic to the front of your postcard.

1.  Choose Open from the File menu and open the Tutorial Images folder. 
Double-click image 021 to open it. If necessary, zoom out so you can see the 
entire image.

2.  Click the Rectangular Selection tool and configure it as shown below. (Note 
that the dimensions shown are relative, not actual.)

Figure 2.13
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3.  The pointer will become a cross with a small “c” next to it to remind you that 
a constraint is applied. Drag the Rectangular Selection tool to define a large 
section of the image, then choose Copy from the Edit  menu to copy the 
image in postcard proportions.

Figure 2.14
4.  Choose New from the File menu. When the New Image dialog appears, 

choose Postcard for the Format, then click OK. 
5.  When the new (empty) file appears, choose Select All from the Selection 

menu. Then choose Paste from the Edit menu to place the image in postcard 
proportions.

6.  Choose Select None from the Selection menu, then go to the File menu and 
save the image as “Postcard Front.” 

7.  Close the file. 

� Image Correction

EXERCISE: Automatically correct an image's brightness and contrast. 

1.  Open image 013. If necessary, zoom out so you can see the entire image.
2.  Using the Crop tool, select the entire image except for the black frame. 

(Adjust the corners by dragging them into position.) Move the pointer inside 
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the selected area. When it becomes a pair of scissors, click to remove the 
black frame.

Figure 2.15
3.  Choose Settings - Brightness/Contrast & RGB from the Image menu. 

Click Auto to automatically correct the image.

Figure 2.16
4.  Close the file. Do not save it.

EXERCISE: Manually correct an image's brightness and contrast. 
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1.  Open image 100 from the Tutorial Images folder.
2.  Crop the image to delete its border.
3.  Choose Settings - Levels from the Image menu (Command-L).
4.  Choose the RGB option from the Channel pop-up menu.

Figure 2.17
5.  Black Point. Choose the Black Point color sampler (on the left) and click a 

place on the image that should be black. (The shadow between the wing and 
the body.) The color of the pixel you selected becomes the target black. 

6.  White Point. Choose the White Point color sampler (on the right) and click a 
place on the image that should be white (the small spots on the wall to the 
left.) This color becomes the target white.

7.  Neutral (Gray) Point. Choose the Gray Point color sampler (in the middle) 
and click a place in the image that should be gray (the wall behind the eagle.) 
This color becomes the target gray.

8.  Click OK to apply your changes to the image.

White Point Color Sampler

Black Point Color Sampler
Gray Point Color Sampler
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Threshold Mode

If you have difficulty with identifying an image’s white or black points, there is an 
easy way to make them more apparent. While in the Levels dialog, hold down the 
Option key and move the white handle on the Input slider to the left. The preview will 
become black. As you continue to move the slider to the left, color points will appear. 
The first pixels you see are the brightest in the image, which you can now easily 
sample.

Figure 2.18

Repeat the process, this time dragging the black handle on the Input slider to 
determine the image’s black point.

Gamma 

Adjusting gamma allows you to change the brightness of the midtones without 
significantly affecting the image’s hightones and shadows. To modify Gamma, drag 
the gray handle on the Input slider. The new Gamma value appears in its text box.

Output 

Output sliders are used to reduce image contrast, and therefore have the opposite 
effect from the Input sliders. 
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Reset 

Clicking the Reset button restores the original image.

� Simple Image Retouching

EXERCISE: Remove a hair (or scratch) from an image.

1.  Open image 034.
2.  Choose the Zoom tool and click the center of the image. You will see a black 

hair that needs to be removed.

Figure 2.19
3.  Click the Clone tool. Set the Diameter at 8 pixels, and the Opacity at 100.
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Figure 2.20
4.  Move the Clone tool to a part of the sky which has colors similar to the area 

around the hair. Hold down the Option key (the arrow at the bottom of the 
Clone tool will become white) and click once. Release the Option key and 
move the pointer close to the hair. 

5.  Hold down the mouse button and drag the Clone tool across the hair. 
6.  The hair will gradually disappear as it is covered with the pixels copied from  

the portion of the image you chose to clone from.

Figure 2.21
7.  Repeat Step 4 by starting from new reference points until you cannot see the 

effect of cloning.
8.  Close the file. Do not save it.
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In addition to removing unwanted items, the Clone tool is very useful for duplicating 
items. Try repeating this exercise, but instead of removing the hair, duplicate it 
elsewhere in the sky.

� Rotating and Straightening Images

EXERCISE: Rotate the same image using two different methods. 

1.  Open image 015. If necessary, zoom out so you can see the entire image.
2.  Rotate the image by choosing Rotate +90° from the Image menu. Choose 

Undo from the Edit menu.
3.  To manually rotate the same image: Go to the Tool Palette and click the 

Straighten/Rotate tool. Two perpendicular crossbars will appear on the 
image.

Figure 2.22
4.  Position the pointer on one of the crossbars. (The pointer will become a 

curved line with arrows at both ends.) 
5.  Drag the crossbar 90° clockwise. 
6.  Release the mouse button, then click the image.
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Figure 2.23
7.  The image will be rotated 90° clockwise.
8.  Close the file. Do not save it.

EXERCISE: Straighten an image. 

1.  Open image 023.
2.  You will see that the line created by the city lights is not perfectly horizontal. 

To correct this, click the Straighten/Rotate tool and position the pointer over 
the small circle where the crossbars intersect.

3.  Drag the circle as close as possible to the city lights line, then position the 
pointer on one of the crossbars. Drag and rotate  one of the crossbars 
counterclockwise until the horizontal crossbar is aligned with the city lights 
line.
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Figure 2.24
4.  Release the mouse button, hold down the Option key and click the image. 

The city lights are now perfectly horizontal. You can straighten the entire 
image on your screen by using the Crop tool to delete the outside edges of 
the image.

Figure 2.25
5.  Close the file. Do not save it.
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� Working With Selections

EXERCISE: Define a selection, create a mask and feather its edges, then blend it 
back into the image.

1.  Open image 089. If necessary, zoom out so you can see the entire image.
2.  Double-click the Rectangular Selection tool and choose No Constraint in 

the Settings palette that appears. Use the Rectangular Selection tool to select 
the duck and its reflection. (This is an example of a binary selection, in 
which only a portion of an image is selected.)

Figure 2.26

If this binary selection is copied and pasted onto another image, the result 
will be the same as sticking a small picture on top of a big one. The borders 
of the small picture will be seen, resulting in a poorly finished montage. 

To make professional-quality montages, you must progressively feather a 
selection's borders and/or apply transparency effects.

3.  Choose Feather/Transparency from the Selection menu. Enter a radius of 
15 pixels, then click OK.
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Figure 2.27

A progressive transparency is created around the selection border. These 
pixels will form an area where the borders of the pasted image and those of 
the background will blend together.

4.  To understand this visually, choose Separate Mask from the Selection 
menu. Before feathering (see left image), the mask is binary and has solid 
black edges. After feathering (see right image), the edges of the mask's 
border are softened into a graduated grayscale. 

Figure 2.28
5.  Close the mask window (do not save the mask) and return to the image. With 

the duck and its reflection still selected, move the pointer inside the selected 
area until it becomes a Hand tool. Hold down the Option key and press the 
mouse button. A plus sign will appear, which means that the selection has 
been duplicated so you can move it without leaving a blank area. 
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6.  Drag the selection to the upper left corner of the image. Release the mouse 
button and choose Flip Horizontal from the Image menu.

Figure 2.29
7.  Click outside of the selection to deselect it. Next, use the Lasso tool to select 

the duck's head (but not its beak). Then hold down the Command key and 
use the Lasso to select (or actually subtract) the duck's eye. (Holding down 
the Command key while using a selection tool allows you to subtract pixels 
from a selection, whereas holding down the Shift key lets you add pixels to a 
selection.)

8.  Choose Settings - Bright/Cont & RGB from the Image menu. Modify the 
color of the duck's head by decreasing the Green color value and increasing 
the Blue color value. Click OK to view the results, which demonstrate that 
only the selected area is affected by the correction.
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Figure 2.30
9.  Close the file. Do not save it.

EXERCISE: Copy, resize and paste one image into another.

1.  Open images 089 and 014.
2.  Select the duck and its reflection with the Lasso. Go to the Selection menu 

and choose Feather/Transparency. Enter a radius of 8 (pixels) and click 
OK.

Figure 2.31
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3.  Copy the selection, then use the Window menu to open image 014. Click  the 
Rectangular Selection tool and choose Clipboard from the pop-up menu.

4.  Draw a selection area on the water, then choose Paste from the Edit menu. 
Click outside the selection to deselect it. The duck has been proportionately 
resized and smoothly integrated into its new environment.

Figure 2.32 
5.  Close both files. Do not save them.

� Applying Gradients

EXERCISE: Apply a gradient to an image.

1.  Open image 016. If necessary, zoom out so you can see the entire image.
2.  Click the Magic Wand, then configure it as shown below.
Microspot PhotoFix 2 - 25



Figure 2.33
3.  Click the sky to select it. If the sky is not properly selected, use the Lasso and 

Shift/Command keys to add or subtract pixels.

Figure 2.34
4.  Choose the Color Sampler tool and click the sky to select a color for the 

foreground. To define a second color, make sure that the Brightness 
Adjuster is not set to the minimum or maximum position and click the 
Background Color Indicator in the Color Palette and choose a color from 
the Color Picker (adjust brightness, if necessary) or the Color Storage 
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Area. You will see a preview of your gradient effect on the top right side of 
the Color Palette.

Figure 2.35
5.  Choose the Gradient tool. With the sky still selected, click in the top left 

corner and drag the Gradient tool to the bottom right corner to apply the 
gradient.

Figure 2.36
6.  Choose Invert from the Selection menu to select the remainder of the image.
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7.  Choose Settings - Brightness/Contrast & RGB from the Image menu. 
Click Auto to correct the image, then click OK.

Figure 2.37
8.  Test PhotoFix’s ability to perform Multiple Undos by choosing Undo from 

the Edit menu to undo the Auto Brightness/Contrast & RGB corrections. 
Choose Undo again to deselect the inverted portion of the image, then again 
to remove the gradient.

9.  Choose Redo from the Edit menu three times to replace the gradient, 
reselect the inverted portion of the image and redo the Auto Brightness/
Contrast & RGB corrections.

10.  Do not close the file as you will need it for the next exercise.

EXERCISE: Apply a gradient to floating text.

1.  Using the Color Palette, choose white as the foreground color (simply slide 
the Brightness Adjuster all the way to the right). Then choose the Text tool 
and click the upper left side of the sky.
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2.  Type “How would you like to spend your vacation here?”. Choose the font 
and attributes shown below, then click OK.

Figure 2.38
3.  The text will appear as a floating selection. Move the pointer over the text. 

When it changes to a Hand tool, drag the text to center it near the top of the 
image. (Note that you can also use the keyboard's directional arrow keys to 
move the text.) 

NOTE: If the Text Settings dialog reappears as you attempt to move the text, 
click Cancel. Or, if you accidentally place the text in the wrong spot, choose 
Undo from the Edit menu until the text starts floating again. You can then  
reposition it.

4.  Without deselecting the floating text, select a foreground and a background 
color for the text gradient. Choose colors that are very different from the 
color of the sky.
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5.  Using the Gradient tool, click the left edge of the text and drag the pointer 
across to the right edge. Preview the gradient effect by choosing Hide Edges 
from the Selection menu.

Figure 2.39
6.  Choose Select None from the Selection menu to place the text.
7.  Close the file. Do not save it.

� Photo Montages & Masks

EXERCISE: Replace the sky in one image with the sky from another image

1.  Open images 016 and 026. If necessary, zoom out so you can see each image 
completely.

2.  Set the Magic Wand's tolerance at 8, then click the sky in image 016 to select 
it.
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Figure 2.40
3.  Choose Separate Mask from the Selection menu.
4.  Choose 026 from the Window menu, then go to the Selection menu and 

choose Load Mask. Click the From Image radio button and choose the 
untitled mask from the pop-up menu. 

5.  Click OK. The borders of the selected mask will appear on image 026.

Figure 2.41
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6.  Choose Copy from the Edit menu. Return to image 016 and choose Paste.

Figure 2.42
7.  Choose None from the Selection menu. A sunset now replaces the sky found 

in the original image.
8.  Close the files and the mask. Do not save them.

EXERCISE: Create, edit and use a grayscale mask to modify the colors of an 
image.

1.  Open image 013. If necessary, zoom out so you can see the entire image.
2.  Crop out the black borders, then choose Select All from the Selection menu. 
3.  Choose New from the File menu. Choose Custom for the format, then 

choose Grayscale from the Palette pop-up menu. Click OK.
4.  When the new document appears, zoom out, then go to the color palette and 

click Change Foreground to Black and Background to White.
5.  Click the Gradient tool and apply a gradient from the bottom left to the top 

right corner.
         Chapter 2 -Tutorial2 - 32



Figure 2.43
6.  Return to image 013. Use the Selection menu to load the untitled mask. 
7.  Click the Paint Bucket and set its tolerance at 100%.
8.  Use the color palette to select a shade of gray for the foreground, then click 

the sky. 

Figure 2.44

Notice how the fog is thicker towards the top right corner of the image. This 
is because the darker portions of the mask protect the image from the gray 
paint, whereas the lighter portions allow the paint to show through. As in this 
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example, you can apply different special effects by creating, editing and 
applying masks to your images.

9.  Close the file. Do not save it.

� Retouching RGB Layers

EXERCISE: Remove a dominant color from an image.

1.  Open image 001 and crop out the black frame.
2.  Choose Settings - Bright/Cont & RGB from the Image menu, then click 

Auto to automatically correct the image. Click OK.
3.  This image has a dominant yellow color (which is quite common with 

scanned and PhotoCD images.) To correct this, choose Separate RGB 
Layers - Red - Green - Blue from the Image menu.

4.  To decrease the yellow, you will need to modify the red and green layers. 
Since the blue layer is not useful in this case, close the 001.B window. Do 
not save it.

5.  Click the 001.G layer, then choose Settings - Bright/Cont & RGB from the 
Image menu. Decrease the Brightness value by 9%.

6.  Click the 001.R layer and choose Settings - Bright/Cont & RGB from the 
Image menu. Decrease the Brightness value by 5%.

7.  Return to image 001 and choose Load RGB Layers from the Image menu.
8.  Make sure the 001.R layer is chosen in the Red pop-up menu, and the 001.G 

layer is chosen in the Green pop-up menu. Click OK to replace the original 
layers with the new ones. You will see that the yellow dominance has been 
diluted.

9.  Try undoing and redoing the Load RGB Layers operation to see how it 
affects the image. 

10.  Close the file and layers. Do not save them.
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� Converting Color Modes

EXERCISE: Convert an image from RGB to 256 Indexed colors.

Why: If your printer cannot print 16 million colors, you may want to reduce the pixel 
depth of your image to save disk space. For example, a 24 Bit RGB image may use 1 
Mb of disk space, whereas the same image in 8 Bit Indexed mode may take up just 
333K of disk space.

Modes
• Bitmap. Images are coded with 1 bit, meaning that pixels can only be either black 

or white. A binary mask (with no progressive borders), for example, is in bitmap 
mode.

• Grayscale. Images are coded with 8 bits and contain 256 shades of gray. Thus, 
progressive masks are created in grayscale mode.

• Indexed. Images are offered three depth options: 8 Bit (256 colors); 4 Bit (16 col-
ors); and 2 Bit (4 colors). The Indexed mode allows you to choose the System 
color palette, which converts an image's colors using the Macintosh system color 
palette.

Note: Adaptive palette is not currently available in the Mac OS X version of the 
software.

• RGB. Images contain up to 16 million colors, and so offer full color.

1.  Open image 012 and crop the black border.
2.  Choose Mode - Indexed from the Image menu. Choose 4 Bit and click the 

System palette. 
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3.  Undo and Redo the mode change to compare the look of the two images. 
Keep an eye on the file size indicator in the bottom right corner of the 
window so you can also compare the changes in file size. 

Figure 2.45
4.  Experiment with different image modes by continuing to Undo and Redo the 

mode change.
5.  Close the file. Do not save it.

� Creating a Customized Palette

EXERCISE: Customize an Indexed palette and apply color effects to a grayscale 
image.

1.  Open image 012.
2.  Convert the image to grayscale by choosing Mode - Grayscale from the 

Image menu.
3.  Use the Color Sampler to select a dark shade of gray from the color palette.
4.  Hold down the Option key (note that the pointer changes to NEW when 

positioned on the foreground or background color, and MIX when placed on 
the color palette) and double-click the foreground color to show the Color 
Picker. 
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5.  Drag the Brightness Adjuster slider to the middle. Click a shade of green, 
then click OK. Green will replace all pixels in the image that have the same 
value as the shade of gray you choose in the color palette.

Figure 2.46
6.  Hold down the Option key and click the darkest tone in the color palette. The 

pointer changes to MIX. All of the intermediary tones, ranging from the first 
gray you selected to black, have been mixed with the green color.

Figure 2.47

Repeat these steps with other colors to customize an Indexed palette and create 
original, surrealistic images. Avoid using too many colors; simplicity is recommended. 
The best results are obtained using soft, progressive tones.
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7.  Close the file. Do not save it.

� Quit Special

EXERCISE: Use PhotoFix’s “Quit Special” option to quickly open an image.

1.  Open any file. Keep track of how long it takes the file to open.
2.  Choose Quit from the PhotoFix application menu to quit PhotoFix. When 

the dialog appears, click the Quit Special option. (Note that if you did not 
turn on this option as explained in the Setting PhotoFix Preferences  on page 
2 - 1 you must first do so.)

Figure 2.48
3.  Double-click the PhotoFix application. When the dialog appears, click Open 

Fast. The file will open very quickly, no matter how large it is.

Figure 2.49

The Quit Special feature can be very useful if you often need to quit PhotoFix in order 
to work in other applications, then return to a PhotoFix document. 
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Quit Special also works when there is a power failure, or when your computer 
crashes, as long as you have not chosen the Temporary Items folder as the scratch disk 
or folder in the Memory and Plug-ins Preferences dialog. See Setting PhotoFix 
Preferences  on page 2 - 1 for further details.

� Printing Your Image

Follow the steps below to print an image:
1.  Open image 080 and crop its black border.
2.  Choose Page Setup from the File menu and configure as follows:              

Paper: US Letter or A4                                                                                             
Scale: 100%                                                                                              
Orientation: Landscape

3.  Click OK to close the Page Setup dialog.
4.  Choose Page Format from the File menu. Set Scale at 50%, then drag the 

image to position it wherever you want on the page. Click OK. 
5.  Choose Print from the File menu to print a copy of your image.
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CHAPTER 3 - MENUS

PHOTOFIX APPICATION MENU

Figure 3.1

� About PhotoFix

Choose About PhotoFix to show a dialog containing information about the 
application.

� Enter Serial Number

While running the PhotoFix demo version you may enter a valid serial number to get 
the full version of the application. Choose Enter Serial Number from the PhotoFix 
application menu, and enter a name and valid serial number (the organization name is 
optional). 
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� Preferences  

General Preferences

Figure 3.2

Unit 
Allows you to show units of measure in pixels, inches or centimeters. 

Image Icon 
Choose the Miniature option to show file icons as miniature representations of the 
images they contain. Choose the Standard option to show files with the PhotoFix 
icon and format type. 

Default Palette 
Allows you to set the palette that will be used when opening new documents. The 
options are Bitmap, Grayscale, System or RGB color. 

Tool Spacing 
Allows you to set the distance between two tool marks. For example, if you choose 
the Paint Brush and set Tool Spacing at 110%, there will be a gap between each 
mark left by the brush. Smaller spacing percentages produce continuous patterns. 
Spacing should be based on the desired effect and on the shape of the choosen tool.
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Show Tool Area
Allows you to see the tool’s size and shape on the image before you apply it.

Black Background
Makes the border space around the image black. (The default is gray.)

Memory and Plug-ins Preferences

Figure 3.3

Scratch Disk/Folder
Allows you to choose the disk and folder where backup files will be stored 
temporarily. The default setting is a Temporary Items folder, however we do not 
recommend using the default if you plan to use the When “Quit Special” or 
When Power Failure options (See Save Open Images on page 3 - 3 for more 
details.) since the contents of the Temporary Items folder are automatically put 
into the trash during startup.

Save Open Images 

When “Quit Special” 
Turning this option on allows you to quit the program at any time without 
saving changes to your image. When you reload PhotoFix, you can quickly 
reopen the same image with your changes intact. Note that Multiple Undos are 
lost when this option is turned on.

When Power Failure
This option saves your work in case a power failure or system crash occurs. 
When you restart your machine and reopen the file you were working in, any 
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changes you made before the power failure or system crash occurred will be 
intact.

Plug-ins Folder 
Allows you to choose the Plug-ins folder you wish to use (Acquisition plug-ins, 
Export plug-ins or plug-in Filters.)

Multiple Undos 
Lets you choose from 1 to 32 levels of Undo. The default setting is 32.

� Quit PhotoFix 

Quits the program. If any open files have not been saved, an alert will appear asking  if 
you wish to save the changes made.
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FILE MENU

Figure 3.4

� New 

Allows you to create a new image. 
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� Open

Allows you to open an image. The PhotoFix Open dialog shows a preview of the 
selected image. 

  Figure 3.5

The date and hour of creation, graphic format, creator (software) code, image size, and 
resource size (in bytes) are displayed at the bottom of the dialog.

Graphic Formats

PhotoFix recognizes the following graphic formats: PICT, PICT with alpha channel, 
PICT with QuickTime compression, TIFF, TIFF with Alpha Channel, EPS with mask, 
JPEG/JFIF, GIF, Windows BMP, the super fast PhotoFix file format and any other 
format supported by the QuickTime Graphic Importer.
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� Image Browser

Launches your prefered Image browser application. The first time you choose this 
option choose your prefered Image Browser, for example Apple iPhoto or Microspot 
PhotoXtra.

� Open Album

Choose Open Album to open a Image Browser album from within PhotoFix. Select an 
album from the Open dialog that appears, PhotoFix will open the image Browser 
application and the relevant album.

� Close 

Closes the active window. Choose the Close option while holding down the Option 
key to close all application windows.

� Save

Saves image modifications. 

� Save As

Saves image modifications as a new file. PhotoFix can save the following file formats: 
PICT, PICT with Alpha Channel, PICT with QuickTime compression, TIFF, TIFF 
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with Alpha Channel, EPS, EPS with mask, JPEG/JFIF, Windows BMP and PhotoFix 
internal format.

Figure 3.6

EPS Format

PhotoFix’s EPS format supports paths (EPS masks) which are very useful with page 
layout software like QuarkXPress and Adobe PageMaker. When an EPS mask is saved 
with an RGB or CMYK image, only the contents of the mask are displayed on your 
screen and printed with an EPS printer or imagesetter. See Pen Tool on page 4- 2 for 
more details. 

�  Acquisition Profile

PhotoFix can create a profile to correct your scanner’s response in the black and white 
points, as well as its response curve in the red, green and blue color bands. These 
corrections will allow you to remove any color casts, to obtain pure whites and deep 
blacks, and to correct your scanner’s nonlinear color response. Once you create and 
select a profile, it will be applied to your scanned images automatically. In most cases, 
the result will be closer to the original image. If you do not like the corrections that are 
made to your scan, you can undo them by choosing Undo Filtering from the Edit 
menu.

NOTE: If you have a 10 or 12 bit scanner (refer to your scanner specifications sheet) 
we strongly recommend that you correct its response using the scanner’s driver 
options.
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Profile Creation
Even if a list of lab-tested scanners is available with your software, it is better to 
create a profile which corresponds to your own source.

Using the Supplied Target
1.  Choose Acquisition Profile from the File menu. Make sure that no profile is  

choosen in the Acquisition Profile dialog. Also, make sure that the Color 
Palette is open and extended so you can see the RGB Profiles at the bottom. 

2.  Choose Acquire from the File menu, then choose your scanner. Scan the 
target supplied with PhotoFix in color at 72 dpi.

Figure 3.7
3.  Go to the Settings option from the Image menu and choose Levels.

Figure 3.8
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4.  Double-click the first eyedropper (which represents black) to show the Color 
Picker dialog.

Figure 3.9
Choose the Apple RGB profile on the left side of the dialog, then use the 
slider controls to set each of the RGB values at 4 and click OK. When you 
are returned to the Levels dialog, double-click the middle eyedropper (which 
represents gray) and set the RGB values at 50. Do the same for the white 
eyedropper, setting the values at 97, or whatever your personal preference is 
for displaying white print. See Filter Menu on page 3 - 34 for more details.

5.  Use the black point eyedropper in the Levels dialog to click the black square 
in the scanning target. Then use the white point eyedropper to click the white 
square.

6.  Put the middle eyedropper on the gray square in  the scanning target (do not 
click) and look at the RGB Profile section of the Color Palette. The color 
value for each of the RGB channels should be approximately 125 - 130.
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Figure 3.10
7.  If the value of any channel does not fall into this range, choose the 

corresponding Red, Green or Blue channel from the Channels pop-up 
menu in the Levels dialog. Modify the channel’s Gamma value by moving 
the middle gray control on the Input slider. Measure the channel’s new value 
by placing the pointer on the gray square in the scanning target while 
holding down the Option key.

8.  If necessary, repeat this procedure for each of the channels until you obtain a 
value of 125 -130.

9.  Click Save and enter a name for your new profile
10. Click OK to apply the corrections to the image. 
11. Choose the Acquisition Profile from the File menu, then choose New 

Profile .
12. From now on, this profile will be applied to each scanned image. Don’t 

forget that you can Undo it if you do not like its effect on the image.
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� Acquire 

Allows you to acquire images using plug-ins from sources such as external acquisition 
devices, scanners and special decompression software.

� Export 

Allows you to export images in special formats using external plug-ins such as CMYK 
Separation and compression software.

� Page Setup

Allows you to configure parameters such as paper size, layout and orientation.
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� Page Format 

Figure 3.11

The Page Format dialog lets you preview, resize and position images on a page. Note 
that page size and orientation are dependent upon the choices you make in the Page 
Setup dialog. 

Click the Frame checkbox to add a frame to your print. To add the name of the file to 
your print, click the Name checkbox. Use the Scale pop-up menu to reduce the size of 
your image. To increase the image size, return to the Page Setup dialog.

Images are placed in the center of the page, however you can drag and reposition them 
wherever you like. Click the Center button to return an image to the center of the 
page. Image position and size are located in the information block in the Page Format 
dialog.

� Print

Opens the Print dialog so that you can print your image.
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EDIT MENU

   Figure 3.12

� Undo 

Cancels the previous operation. PhotoFix supports multiple undo operations, so files 
are saved each time an editing action is carried out. The Undo command can be used 
to work backwards through the processes performed, undoing one action after another. 
The number of times the Undo command can be used will be determined by the value 
set for multiple undos in the Preferences dialog. See Preferences on page 3 - 2 for 
more details.

� Redo 

Restores an operation cancelled by using the Undo command. As PhotoFix supports 
multiple undo operations, files are saved each time an editing action is carried out. The 
Undo command is used to work backwards through the processes performed, undoing 
one action after another.

The Redo command is used to restore these actions again, in turn.
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� Cut 

Cuts the selected part of an image and places it into the Clipboard. 

� Copy 

Copies the selected part of an image and places it into the Clipboard. 

� Paste 

Pastes the contents of the Clipboard into an image. If a portion of the image has been 
selected, the Clipboard contents will be pasted inside the selection.

� Clear 

Erases the selected part of an image and replaces it with the current background color.

Fill With

Figure 3.13

Foreground color 
Fills a selection with the Color palette’s foreground color.

Background color 
Fills a selection with the Color palette’s background color.
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Pattern 
Fills a selection with a pattern copied using the Copy Pattern option from the 
Edit menu.

Copy Pattern

Figure 3.13

This option allows you to copy a selection as a pattern and apply that pattern to another 
image or selection. Use a selection tool to define a pattern, then use a selection tool 
again to define where you want to apply the pattern. Choose the Fill With option from 
the Edit menu, then choose Pattern to fill the selection with the pattern.

Memory Space

Figure 3.14
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Application Memory 
Indicates used memory size.

Scratch Disk Space 
Indicates the amount of free disk space, as well as the amount being used by image 
and undo files. 

Erase Multiple Undo Files 
Erases saved Multiple Undos to free disk space. Once the Multiple Undo files 
have been erased, you will not be able to use the Undo command to cancel the 
actions performed before these files were erased.
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IMAGE MENU
Among other options, the Image menu offers you several different ways to correct 
images. These methods range from selecting automatic correction options to manually 
defining color, contrast and brightness values.

Figure 3.15

� Settings 

Figure 3.16

Negative 

Inverts image colors.
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Bright/Cont and RGB

Allows you to adjust image colors, brightness and contrast. You can either click the 
Auto button to automatically make corrections, or use the sliders to make manual 
corrections.

Figure 3.17

Blur/Blur a lot/Sharpen/Sharpen a lot 

Internal filters available in the RGB and grayscale modes.

AutoFix

The AutoFix option allows you to correct contrast, color, brightness and sharpness 
with a single keystroke. It defines the lightest and darkest pixels in each channel as 
white and black, then dynamically redistributes the intermediary pixel values. AutoFix 
also adjusts the contrast of edge detail, and therefore enhances sharpness. 
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Figure 3.18

Holding down the Option key when choosing AutoFix allows you to customize its 
settings to produce specific effects or apply corrections to a set of images.

Figure 3.19

Clipping 

Clipping defines the number of extreme pixels (as a percentage of the total image) 
which will have a value that exceeds the target value. This feature is useful for 
producing sparkles or shadows.
Microspot PhotoFix 3 - 20



Strength

Enter a Strength value from 1 to 500. The higher the percentage, the stronger the 
effect of the filter.

Radius

Enter a Radius value from 1 to 250 to determine the number of pixels used for 
calculating the sharpness of each point. Radius value should be adapted to image 
resolution. A radius of 1 on a 72 dpi image has an equivalent effect of a radius of 4 
on a 288 dpi image.

Threshold

Threshold specifies the difference in brightness levels between adjacent pixels 
(from 0 to 255) before sharpening is applied to an edge. Lower values produce a 
more pronounced effect.

Histogram 

A histogram is a graphic representation of the pixel value distribution in an image 
from the lowest (0 at the left) to the highest (255 at the right). 

Figure 3.20

When you show a histogram of an RGB image, for example, you can view the 
distribution of all pixels within the image, or use the Channel pop-up menu to view 
the Red, Green, Blue, RGB, Hue, Saturation and Grayscale pixel distributions 
individually.
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Hue/Saturation 

Figure 3.21

Before/After

The Before and After images show your document as it is currently and as it will 
be if you apply the specifed Hue and Saturation changes.

Scale

The Scale controls determine how the Before and After images are shown. Click 
the Fit button to scale the images so that they fit the area provided. Use the “+” and 
“-” buttons to increase and decrease the scale of the images as desired.

Hue

The Hue adjustment area shows how colors will be mapped. In the initial position 
the two color lines are identical, with each color in the top color line being mapped 
to the same color in the bottom color line. Move the Hue slider bar to the left or 
right to move the bottom color line and so change the colors in the image.
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Saturation

Move the Saturation slider bar to the right or left to increase or decrease the 
vibrancy of the colors in the image.

Levels

The Levels option is probably the most efficient for correcting common image 
weaknesses in black, white, neutral (gray), brightness, contrast and color gamma 
(linearity):

Figure 3.22

Auto Option

Click the Auto button to automatically enhance image contrast and brightness. You 
can view the corrections in the preview window on the left side of the dialog.

Auto Levels Settings

To set Clipping values, as well as to use the Color Picker to define color targets 
for correcting weaknesses in the darkest, lightest and neutral points within an 
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image, open the Levels dialog, then click the Options button to show the Auto 
Levels Settings dialog.

Figure 3.23

Clipping 
This option defines the number of extreme pixels (as a percentage of the entire 
image) which will have a value exceeding the target value. This feature is very 
useful for producing sparkles or shadows.

Color Targets
Click the Black, Grey or White button in the Auto Levels Settings dialog to 
choose a color picker for setting your targets. When the dialog appears, choose 
either the Apple RGB color picker and set target values for Red, Green and 
Blue, or the Apple HSV color picker and set target values for Hue, Saturation 
and Value.

Figure 3.24
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We recommend that you set the values based upon how you plan to use your 
image. If you plan only to show your image on the screen, set the brightness of 
the target points as follows: 

Black: Red = Green = Blue = 0 or Hue = Saturation = Value = 0%

White: R = G = B = 100 or H = 0; S = 0; Value = 100%

Gray: R = G = B = 50% or H = 0; S = 0; Value = 50%

If you intend to print your image, set the brightness of the target points as 
follows: 

Black: R = G = B = 3 or Hue = Saturation = Value = 3%

White: R = G = B = 97 or H= 0; S = 0; Value = 97%

Gray: R = G = B = 50% or H = 0; S = 0; Value = 50%

When you have finished, click OK in both the Color Picker and Auto Levels 
Settings dialogs.

� Mode

This option allows you to choose whether the image mode is RGB, indexed, grayscale 
or bitmap. Note that this item is also found in the Info palette. See Image Modes on 
page 4 - 17 for more details.

Figure 3.25

Bitmap Mode

Black and white images.
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Grayscale Mode

8 bit images that contain up to 256 shades of gray.

Indexed Mode

8 bit images that contain up to 256 colors.

RGB Mode (Red, Green, Blue)

24 bit images that contain up to 16.7 million colors.

Converting Image Modes

Grayscale to Bitmap Mode

If you would like to convert a grayscale image to black and white, choose the 
Bitmap option from the Mode submenu to show the Bitmap Mode dialog. 

Figure 3.26

You can convert a grayscale image to black and white either by Dithering black 
and white points, or by adjusting the Threshold so bright grays become white 
and dark grays become black. A higher Threshold value will convert brighter 
pixels to black.
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RGB to Indexed Mode

If you don't have a printer that prints millions of colors, you may want to 
convert RGB images to the Indexed mode in order to save disk space. To do so, 
choose the Indexed option from the Mode submenu.

Figure 3.27

Color Combinations

• 8 Bits (256 colors) offers the highest quality conversion from RGB to Indexed 
color.

• 4 Bits (16 colors) further reduces the size of the image, as well as its quality.

• 2 Bits (4 colors) offers the greatest reduction in both size and quality.

Note: Adaptive palette option is not currently available in the Mac OS X 
version of the software.

Other 
Choose the Other option to use a saved custom color palette. See Creating 
Custom Color Palettes on page 4- 19 for more details.

Dithering
Click in the Dithering checkbox to dither colors.
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� Separate RGB Layers 

Separates the image into three different layers (Red, Green and Blue.) You can 
correct, edit, save and load each layer back into the image, thus replacing the original 
layers.

Figure 3.28

� Load RGB Layers

Applies modified layers to the image.

� Flip Horizontal/Flip Vertical/Rotate +90°/Rotate -90° 

Allows you to flip or rotate an image or a selected portion of an image.

� Free Rotation

When a rotation angle is entered in the Free Rotation dialog, an image or the selected 
portion of an image will be rotated with 1/100 degree precision. Note that you can also 
rotate images using the Rotate tool.
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� Crop 

Deletes all but the selected part of an image. To crop an image, use the Rectangular 
selection tool to define the portion you wish to keep, then choose the Crop option. You 
can also crop images using the Crop tool.

� Resize

Allows you to modify the size and resolution of the image or the canvas (page).

Figure 3.29

Image

Click Image to resize your image. 
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Canvas

Click Canvas to increase the size of the document without changing the size of your 
image. This allows you to add borders or additional images to a document without 
affecting the size of the original image.

When you choose Canvas, you can also reposition your image on the canvas by 
clicking the desired square in the canvas representation shown in the Image Position 
field.

Keep: Proportions 

When turned on, any changes made to one dimension of an image will 
proportionately modify the other dimension. This prevents an image from 
becoming distorted.

Keep: File Size 

When turned on, any changes made to the dimensions of an image will also modify 
its resolution, and vice-versa. This prevents an image from taking up additional 
memory.

NOTE: If you choose Resize and keep neither Proportions nor File Size, you can 
distort an image and change its file size by changing its dimensions and 
resolution.

� Distortion

Figure 3.30

The Distortion options allow you to change the shape of a selection. Follow the steps 
below to distort the shapes of selections within images:

1. Use the Rectangular Selection tool to define a selection.
2. Choose Distortion from the Image menu, then choose a distortion option.
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3. Handles will show at the four corners of your selection. Drag the handles to 
create a distorted shape, then click inside the selection to apply the 
distortion. Click outside the selection to cancel the distortion effect.

Scale

The Scale option lets you modify the length or width of a selection. 

Figure 3.31

If you hold down the Option key, you can scale your selection without changing its 
original proportions.

Figure 3.32

Skew

The Skew option lets you slant a selection vertically or horizontally. If you release the 
mouse button and drag another handle, it will move independently.

Figure 3.33
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Perspective 3D

The Perspective 3D option distorts an image by giving it a three-dimensional effect. 
You will achieve different effects depending upon whether you choose to distort a 
floating selection (see the graphic on the left) or non-floating selection (see the graphic 
on the right).

Figure 3.34

Perspective 2D

The Perspective 2D option lets you create a perspective effect in two dimensions. 
When you drag on one handle, the other end of the line moves in the opposite 
direction.

Figure 3.35
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Distort 3D

The Distort 3D option lets you distort a selection three-dimensionally by creating a 
vanishing effect at the close handles angle.

Figure 3.36

Distort 2D

The Distort 2D option lets you distort a selection in two dimensions by moving any 
handle in any direction.

Figure 3.37

NOTE: When distorting selections, make sure that none of the corners inside the 
surrounding polygon exceed 180 degrees as this will produce unpredictable results.
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FILTER MENU

Figure 3.38

The Filter menu allows you to apply a wide range of special effects to your images.

� Add

Figure 3.39

Noise

This option applies random pixels to an image. You can enter a value between 1 and 
999 in the Add Noise dialog.

Figure 3.40

Monochrome

Click the Monochrome option to apply filtering to the tonal elements in the image 
without changing the colors.
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Unsharp Mask

The Unsharp Mask filter sharpens areas in the image where significant color changes 
occur, by adjusting the contrast of edge detail to increase an image’s sharpness. This 
filter can be useful for sharpening an image that has become blurry from interpolation 
or scanning.

Figure 3.41

Strength
Enter a Strength value from 1 to 500. The higher the percentage, the stronger the 
effect of the filter is.

Radius
Enter a Radius value from 1 to 250 to determine the number of pixels used for 
calculating the sharpness of each point. The Radius value should be adapted to 
image resolution. A radius of 1 on a 72 dpi image has an equivalent effect of a 
radius of 4 on a 288 dpi image.

Threshold
Threshold specifies the difference in brightness levels between adjacent pixels 
(from 0 to 255) before sharpening is applied to an edge. Lower values produce a 
more pronounced effect.
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� Effect

Figure 3.42

Custom Blur

The Custom Blur filter allows you to choose an exact blur strength. By entering a 
value for the Radius, you can determine the number of pixels that will be used for 
calculations. The larger the radius, the stronger the effect.

Figure 3.43

Motion Blur

The Motion Blur filter produces a blurred effect similar to taking a picture of a 
moving object.

Figure 3.44
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Angle 

In degrees, the Angle determines the direction in which the object appears to be 
moving.

Length

Specified from 1 to 64, the Length determines the intensity of the blur.

Posterize

Figure 3.45

The Posterize filter lets you modify the number of grays or colors in an image. It’s 
useful for creating special effects, such as in large, flat areas in a photograph, to make 
them look more like a painting.

Figure 3.46

Before applying the Posterize filter to an image, we recommend you to first convert 
the image to a limited number of grayscales (such as six.) Retouch the image, if 
necessary, then fill each gray level with a solid color (using the paint bucket, for 
example.)
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� Distortion

Figure 3.47

Distortion 2D/Distortion 3D

These filters produce the same effects as the distortion tools described in the Image 
menu section. See Distortion on page 3 - 30 for more details. However, if you choose 
the Distortion options from the Filters menu, you can use the dialog below to enter 
precise horizontal (to the right for positive numbers) and vertical (down for positive 
numbers) displacements for each corner of a selection.

Figure 3.48
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Shrink

The Shrink filter bends an image inwards or outwards with respect to one or more 
axes. You can enter positive (Shrink effect) or negative (Stretch effect) values in the 
Shrink dialog.

Figure 3.49

Vertical Effect

Specifies the strength of the effect of shrink or stretch vertically.

Horizontal Effect

Specifies the strength of the effect of shrink or stretch horizontally.

Number of Waves

Corresponds to the number of axes used to shrink or stretch the image. For 
example, choosing one wave will shrink or stretch an image with respect to one 
axis situated at the middle of the image.

Spherize

The Spherize filter wraps an image around a spherical shape. It is useful for giving 
objects and text a three-dimensional effect.

Figure 3.50
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Vertical Effect 

Allows you to specify the vertical effect strength.

Horizontal Effect 

Allows you to specify the horizontal effect strength.

Note that negative values undo the effects applied by previous use of the Spherize 
filter.

� Remove

Figure 3.51

Dust and Scratches

This filter allows you to easily remove dust or scratches from an image. We 
recommend selecting the area where you want the filter to be applied rather than 
applying the filter to the entire image.

Figure 3.52

Scratch Thickness

Determines (from 1 to 16) the width of the scratches and dust that will be 
eliminated.
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Threshold
Determines how different the value of pixels need to be (from 0 to 255) in order 
for the filtering to apply. Note that low values may alter uniform color areas in 
the image.

Noise

The Noise filter detects areas where significant color changes occur and blurs them 
without altering the edges. This has the effect of removing noise while preserving 
detail.

Figure 3.53

Radius

The radius (in pixels) determines the noise calculation area. Higher values produce 
stronger effects.

� Using Third Party Filters

If you want to use filters in addition to those supplied with PhotoFix, you can choose a 
Plug-ins folder without quitting the application. Choose Preferences from the 
PhotoFix menu, then choose Memory and Plug-ins Preferences and use the Plug-
ins Folder pop-up menu to choose a Plug-ins folder. 
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SELECTION MENU

Figure 3.54

� Invert

Selects the complementary portion of an image.

� Border

Lets you define a border for the active selection, which is useful for creating frames 
and painting outlines.

� Grow 

When the Magic Wand has been used to make a selection, this option increases its 
tolerance and therefore “grows” the size of the selection.
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� Similar 

When the Magic Wand has been used to make a selection, this option selects all pixels 
in an image that have the same color or light characteristics as the selection. This is 
useful for modifying color or brightness.

� Float

The Float option allows you to duplicate a selected portion of an image so you can 
retouch and move it without altering the original image. The Defloat option integrates 
the floating selection into the image.

� Feather/Transparency

Figure 3.55

Border Feathering

Allows you to set the number of transition pixels that will be feathered around the 
edges of a selected image.
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Image Transparency

Allows you to increase or decrease the opacity of a selected image.

� Separate Mask 

Creates either a bitmap or grayscale image of the active mask. If you haven't feathered 
the mask, or created it in grayscale mode, it will be bitmapped. If you have feathered 
the mask, it will be created in grayscale.

� Load Mask

After separating (and possibly editing) a mask, this option allows you to load it and 
use it to edit an image.

� Hide Edges 

Hiding a selection's edges allows for precise retouching of its borders, and makes it 
easier to see modifications. 

� Select None

Deactivates all active selections.

� Select All 

Selects the entire image.
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VIEW MENU

Figure 3.56

� Zoom In 

Enlarges the image to a factor of x16.

� Zoom Out 

Reduces the image to a factor of ÷32.

� Show/Hide Colors 

Shows or hides the Color palette. 

� Show/Hide Info

Shows or hides the Info palette.
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� Show/Hide Tools 

Shows or hides the Tool palette.

� Show/Hide Tool Settings

Shows or hides the Tool Settings palette. The settings used for the painting and editing 
tools appear in the Tool Settings palette. To show the Tool Settings palette, either 
choose the Show Tool Settings option from the View menu or double-click any tool.
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WINDOW MENU

Figure 3.57

� Adjust Window 

Adjusts the window to fit the displayed image.

� Next Window

Allows you to choose and view another image if you have more than one image file 
open.
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HELP MENU

Figure 3.58

� Tool Info

Shows any help available for the selected tool.

� PhotoFix Manual

Choose PhotoFix Manual from the Help menu and a default system application for 
the PDF files will open the online manual. You can then navigate through and read the 
manual on screen, or print sections for your reference.

� Registration Information

Choose Registration Information to register your product via the Microspot web 
page.

� Upgrade Information

Choose Upgrade Information to obtain product upgrade information (if any) from 
the Microspot web page.
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CHAPTER 4 - PALETTES

TOOL PALETTE

NOTE: For further information about any tool, choose Tool Info from the Help menu 
in the top right corner of your screen.

�  Lasso/Pen 

The Lasso tool allows you to create selections of any shape by dragging the pointer 
around the desired area. You can also make polygonal selections and selections with 
straight edges.

To draw a selection with straight edges:
1.  Start drawing any shape using the Lasso tool.
2.  Without releasing the mouse button, hold down the Option key. 
3.  Release the mouse button where you want to begin your straight selection.
4.  When you move the pointer, you will notice that the additional selection is straight.
5.  Click as many times as you need to create straight edges.

                                   Lasso
Rectangular Selection Tool
            Oval Selection Tool

                            Line Tool
 Rectangular Drawing Tool
                                  Pencil
                       Paint Bucket
                              Airbrush
                            Blur Tool
                         Dodge Tool
                     Gradient Tool

                          Zoom Tool

 Magic Wand
 Crop Tool
 Straighten/Rotate Tool

 Oval Drawing Tool
 Text Tool
 Paint Brush
 Eraser
 Clone Tool

 Sharpen Tool
 Burn Tool
 Color Sampler

 Hand Tool
4 - 1               Chapter 4 - Tool Palettes



6.  Release the Option key and the mouse button to finish the selection:

Figure 4.1

To select an entire image, double-click the Lasso icon. To add pixels to a selection, 
hold down the Shift key and continue to drag. To subtract pixels from a selection, hold 
down the Command key and drag around the area you want to eliminate. 

To copy a selection, hold down the Option key and drag the selection to the desired 
area. To select only the overlapping area between two selections, drag the pointer to 
make a selection, hold down the Shift and Option keys, then drag the pointer again so 
it intersects your initial selection. To move the selection outline, hold down the Option 
and Command keys and drag the selection outline to the desired area. 

Saving Selections

PhotoFix allows you to save defined selections within an image. To do so, you should 
save the image in PICT format using the alpha channel option.

Pen Tool

The Lasso can also behave like the Pen tool. To activate the Pen tool, double-click the 
Lasso tool and click the Polygonal EPS mask option when the Settings palette 
appears.

Figure 4.2

The pointer will become a Pen tool with which you can draw polygonal selections. To 
close a path, return to the starting point. When a small circle appears next to the Pen 
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icon, click. You can now use this path as an EPS mask. If you save the image in the 
EPS with mask format then import it into any EPS-compatible page layout program, 
only the contents of the mask will be shown, and printed on a PostScript printer.

�  Magic Wand 

When you choose the Magic Wand and click anywhere within an image, it 
automatically selects adjacent pixels of similar color, brightness or hue.

Figure 4.3

Use the Tolerance slide bar to adjust the Magic Wand's tolerance. 

Figure 4.4

When Tolerance is set at 0%, the Magic Wand will only select adjacent pixels with the 
exact same color or brightness. When Tolerance is set at 100%, it will select all 
adjacent pixels regardless of their color, brightness or hue. 
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The Magic Wand is very useful for editing and retouching images. By default, it will 
select adjacent pixels with the same color. If you want it to select adjacent pixels with 
the same brightness, click the Light radio button. To select adjacent pixels with the 
same hue, click the Hue radio button. To ensure a smooth selection outline, click the 
Smooth checkbox.

To add pixels to a selection, hold down the Shift key and click the desired area. To 
subtract pixels from a selection, hold down the Command key and click the area you 
want to eliminate. To copy a selection, hold down the Option key and drag the 
selection to the desired area. To select only the overlapping area between two 
selections, click the desired area, hold down the Shift and Option keys, then click an 
area that borders your initial selection. To move the selection outline, hold down the 
Option and Command keys and drag the selection outline to the desired area. 

�  Rectangular Selection Tool

The Rectangular Selection tool allows you to make rectangular selections. Choose the 
tool, click the image, then drag over the desired area to make a rectangular selection.

To make selections with specific constraints, click the Constraint option and choose a 
size from the pop-up menu. (Note that the units shown are proportions, not specific 
units of measure.) You may also choose Other from the Size pop-up menu, then enter 
your dimensions in the Settings dialog that automatically appears. 

Figure 4.5

Using a constrained size allows you to configure the Rectangular Selection tool to 
select images or portions of images in predefined proportions. You can then paste your 
selections into new or existing documents while maintaining the same proportions.
Microspot PhotoFix                                4  - 4 



To add pixels to a selection, hold down the Shift key and continue to drag. To subtract 
pixels from a selection, hold down the Command key and drag around the area you 
want to eliminate. To copy a selection, hold down the Option key and drag the 
selection to the desired area. To select only the overlapping area between two 
selections, drag the pointer to make a selection, hold down the Shift and Option keys, 
then drag the pointer again so it intersects your initial selection. To move the selection 
outline, hold down the Option and Command keys and drag the selection outline to the 
desired area. 

�  Crop Tool 

The Crop tool lets you remove unwanted parts of an image. Choose the Crop tool, then 
drag an outline around the area you want to save. If you need to adjust your selection, 
simply move the corners of the selection area. When you have finished, click inside 
your selection to crop it (the tool will change to a pair of scissors).

�  Oval Selection Tool

The Oval Selection tool allows you to make oval-shaped selections. The tool works the 
same way as the Rectangular Selection tool, except that the selection will be oval or 
circular rather than rectangular or square.

To add pixels to a selection, hold down the Shift key and continue to drag. To subtract 
pixels from a selection, hold down the Command key and drag around the area you 
want to eliminate. To copy a selection, hold down the Option key and drag the 
selection to the desired area. To select only the overlapping area between two 
selections, drag the pointer to make a selection, hold down the Shift and Option keys, 
then drag the pointer again so it intersects your initial selection. To move the selection 
outline, hold down the Option and Command keys and drag the selection outline to the 
desired area. 
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�  Straighten/Rotate Tool 

The Straighten/Rotate tool allows you to straighten or rotate an entire image, or 
selected portions of an image. When you click the Straighten/Rotate tool, two 
perpendicular crossbars, with a circle where the lines intersect, will appear in the 
center of your image. 

Figure 4.6

To rotate an entire image, position the pointer on one of the crossbars and drag it to the 
desired angle. Release the mouse button and click the image. To rotate just a portion of 
an image, use a Selection tool to define an area, then follow the steps described above.

To straighten an entire image, click the Straighten/Rotate tool and position the pointer 
over the small circle where the crossbars intersect. Drag the circle to a reference point 
in the image, then position the pointer on one of the crossbars. Holding down the 
mouse, drag and rotate one of the crossbars until the horizontal line is at an angle that 
will be horizontal after the image is straightened.

Release the mouse button, hold down the Option key and click the image to straighten 
it. To straighten just a portion of an image, use a Selection tool to define an area, then 
follow the steps described above.
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�  Drawing Tools 

To set the line thickness of the Line, Oval and Rectangular Drawing tools, click the 
desired tool and enter your specifications in the Settings dialog that appears. For the 
Oval and Rectangular Drawing tools, you can also click the Fill checkbox to draw 
filled shapes.

Figure 4.7

�  Line Tool 

The Line tool allows you to draw straight lines simply by dragging the pointer. 
Holding down the Shift key allows you to draw a vertical or horizontal line, or line at 
45°.

�  Oval Drawing Tool 

The Oval Drawing tool lets you draw empty or filled ovals by dragging the pointer. To 
draw a circle, hold down the Shift key while drawing. 
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�  Rectangular Drawing Tool 

The Rectangular Drawing tool allows you to draw empty or filled rectangles by 
dragging the pointer. To draw a square, hold down the Shift key while drawing.

�  Text Tool

The Text tool lets you add text to your image. Click the Text tool to show the Text 
Settings dialog. 

Figure 4.8

Choose a font, size, etc., then click the Floating Selection radio button if you would 
like to be able to move your text around before placing it permanently on the image. 
Click the Mask radio button to paint the text area, or to invert the selection and paint 
the background. Note that if you move the mask, it erases the area beneath it. Click the 
Anti-aliasing checkbox to soften the edges of very large text. When you have finished, 
click OK to return to the image and place your text.
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�  Pencil 

The Pencil tool is used for drawing dots, curves and lines. Use the Tool Settings dialog 
to adjust its diameter, then drag to apply the pencil. To draw straight horizontal or 
vertical lines, hold down the Shift key while drawing. If you have a graphic tablet, you 
can adjust the Pencil tool's opacity by varying the pressure on the pen. 

�  Paint Brush 

The Paint Brush tool lets you paint with brushes of various shapes and widths. You can 
choose a shape and radius for the tool, as well as change the Opacity controls for 
bright and dark tones.

You can also modify the shape of the Paint Brush to create custom and special effect 
tools:
1.  Use a selection tool to define a shape. 
2.  Choose the Copy Pattern option from the Edit menu to copy your selection. 
(Color patterns will be converted to grayscales. Black and white patterns will trace 
neatly since white is considered transparent.)
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3.  Choose the Paint Brush tool and click the Change the Shape option in the Settings 
palette. 

Figure 4.9
4.  The Brush Shape dialog will appear.

Figure 4.10
5.  Click Load Pattern.
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6.  Click OK. The new brush shape will appear in the Settings palette.

Figure 4.11

Use the Reset Shape option to return tools to their original settings. Note that the 
maximum diameter of any tool is 256 pixels.

Pressure Sensitivity

If you have a graphic tablet, you can adjust the Paint tool’s opacity by varying the 
pressure on the pen. Increase the pressure to apply more opaque paint. Decrease the 
pressure to apply more transparent paint.

�  Paint Bucket 

When you choose the Paint Bucket tool and click an image or a selection within an 
image, the current foreground color will be spread over adjacent pixels with similar 
colors. You can set the Paint Bucket tool's Tolerance from 0% to 100%. At 0%, paint 
will be spread only on adjacent pixels with exactly the same color. At 100%, paint will 
be spread on all adjacent pixels, regardless of their color.
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�  Eraser 

The Eraser tool allows you to remove undesired parts of an image and replace them 
with the background color. You can also double-click the Eraser tool icon to erase an 
entire image, or the contents of a selection. 

�  Airbrush 

The Airbrush tool is used to spray a fine-grained paint on your image. Use the 
Diameter controller to set the Airbrush width, then choose a paint flow setting:

• Natural Flow. Sprays paint as you press the mouse button. The faster the mouse is 
moved, the lighter the paint flow.

• Regular Flow. Sprays paint of an equal thickness on all areas, regardless of the 
speed of the mouse.

Figure 4.12
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The Flow controller allows you to adjust the flow speed, which is measured on a scale 
from 1 to 10. You can use the Pressure controller for either the Regular or Natural 
Flow setting to control the strength of the paint flow. When you have finished 
configuring the tool, click the image to begin painting. 

�  Clone Tool 

The Clone tool allows you to precisely duplicate portions of an image. Begin by 
choosing a reference point (the section you want to duplicate or clone from). Hold 
down the Option key (a small, white arrow will appear at the bottom of the tool) and 
click the Clone tool. 

Move the Clone tool to the area where you want to begin cloning. Drag the tool to 
replicate the pixels around your reference point. The pixels you replicate depend on 
the direction you move the pointer. Keep an eye on the crosshairs near your reference 
point as they will be your guide.

Use the Tool Size controller to set the size of the area to be reproduced, and the 
Opacity controller to adjust the opacity of the area to be reproduced.

Figure 4.13

Clone Align

Click the Clone Align checkbox to allow for continuous cloning of an image, no 
matter how often you start and stop. Turning the Clone Align option off means that 
whenever you start cloning, it will always begin from your initial reference point. 
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�  Blur and Sharpen Tools 

Use the Blur tool to blur an image, or the Sharpen tool to increase the detail of an 
image. The Tool Size controller allows you to adjust the radius of each tool, while the 
Pressure slide bar lets you adjust the tools' effects.

Figure 4.14

When you have finished configuring the selected tool, click OK to return to your 
image. Choose either the Blur or Sharpen tool and drag the tool over the portion of the 
image you want to modify.
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�  Dodge and Burn Tools

Use the Dodge tool to lighten areas of your image, and the Burn tool to darken your 
image. Use the Tool Size controller to adjust the Dodge and Burn tools' diameters, and 
the Exposure controller to adjust their respective effects.

Figure 4.15

After configuring, drag the desired tool over the portions of the image you want to 
modify. 

�  Gradient Tool 

The Gradient tool allows you to apply graduated colors to selected areas and masks. 
Before using the Gradient tool, you should go to the color palette and choose the 
foreground and background colors you want to blend. (For a preview of the gradient 
produced by the colors you choose, look at the top right corner of the color palette.) 

Using the Gradient tool, drag in the selected area to apply the gradient. The foreground 
color will begin where you initially click. The background color will be applied where 
you release the mouse button.
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�  Color Sampler Tool

The Color Sampler lets you pick up colors from within your image and apply them to 
other areas. Click the Color Sampler, then click anywhere in your image. The color 
you have picked up will be shown as the foreground color in the color palette. You can 
then choose a painting or drawing tool to apply this color to your image. 

The Color Sampler tool can also be used to sample colors from the Color Storage 
Area, the Gradient Preview and the Four Color Gradient Sampler found in the 
color palette.

NOTE: You can turn any painting or drawing tool into a Color Sampler by holding 
down the Option key. 

�  Zoom Tool 

The Zoom tool lets you enlarge (zoom in) or reduce (zoom out) your view of an image. 
Alternatively you can choose these options from the View menu, use the pop-up menu 
in the bottom left corner of the window, or use the key sequences Command + to zoom 
in, and Command - to zoom out.

�  Hand Tool 

The Hand tool allows you to move an image in any direction so you can view an area 
that is outside of the window. 
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INFO PALETTE

Figure 4.16

�  Image Modes

PhotoFix offers four image modes:

• Bitmap. Black and white images.

• Grayscale. 8 Bit images that contain up to 256 shades of gray. 

• Indexed. 8 Bit images that contain up to 256 colors. 

• RGB. 24 Bit images that contain up to 16.7 million colors. 

 Image Size

 Position of pointer relative to

 top left corner of the image

 Image Mode Palette pop-up menu

Selection Area Size

File Format
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Converting Image Modes

If you don't have a printer that prints millions of colors, you may want to convert RGB 
images to the Indexed mode in order to save disk space. To do so, choose Mode from 
the Image menu. Then, choose the Indexed option to show the following dialog.

Figure 4.17

Color Combinations

• 8 Bits (256 colors) offers the highest quality conversion from RGB to Indexed 
color.

• 4 Bits (16 colors) further reduces the size of the image, as well as its quality.

• 2 Bits (4 colors) offers the greatest reduction in both size and quality.

Other 

Choose the Other option to open a saved custom color palette (described in 
the next section).
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Creating Custom Color Palettes

When you have finished selecting your color combination, click OK. If the Colors 
palette is not already shown, choose it from the View menu.

Figure 4.18

When you click a color in the Indexed Color Palette, it will appear in the 
Foreground Color Indicator. To create a customized color, double-click the 
Foreground Color Indicator to show the Color Picker.

Figure 4.19
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Click the Color Wheel to select a different color, and/or use the slider control to 
change the shade of your color. Click OK when you have finished. When you return to 
the Indexed Color Palette, you will see that the color you originally selected has been 
replaced by your customized color.

Figure 4.20
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Follow the same steps to add additional custom colors. When you have finished, click 
the Save button to show the following dialog.

Figure 4.21

Choose a name and location for your custom color palette. Whenever you want to use 
any of the custom color palettes you have saved, you can either choose the Other 
option from the Indexed Colors dialog (See Figure 4.17 on page 4 - 18.), or click the 
Load button in the Indexed Color Palette (See Figure 4.24 on page 4 - 23.)
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COLOR PALETTES
PhotoFix offers a different color palette for each image mode. 

� Bitmap Palette

   Figure 4.22

� Grayscale Palette

Figure 4.23

 A vailable  Colors

 Switch  F  oreground/
 Background Colors

 Change F  oreground to Black
 & Background to White

Foreground
Color Indicator 
Background
Color Indicator

Foreground
Color Indicator 
Background
Color Indicator

A                             vailable Colors

 Switch F oreground/
 Background Colors

 Change F  oreground to Black
& Background to White
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� Indexed Color Palette

Figure 4.24

Available Colors

 Switch F oreground/
Background Colors

 Change F  oreground to Black
& Background to White

       

Foreground
Color Indicator

Background
Color Indicator

Save Custom Color PalettesLoad Custom Color Palettes
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� RGB Color Palette

    Figure 4.25

NOTE: If the bottom portion of the RGB color palette is not visible, click the small 
triangle next to the Color Controls to extend the Palette.

The RGB color palette allows you to choose colors, preview the effects of gradients 
and choose intermediate colors from the blending of up to four colors. To change the 
foreground color, make sure that the Brightness Adjuster slider is not set to minimum 
or maximum position and drag the small circle in the middle of the Color Picker. To 
change a color's shade, drag the Brightness Adjuster from left to right (this can be 
done for the Background Color Indicator, as well). 

When you move the pointer to the Color Storage Area, it becomes a Color Sampler 
tool. Click any color in the Color Storage Area and it will become either the 
foreground or background color, depending upon which one is currently selected.

The Gradient Preview shows the gradient between the foreground and background 
colors, whereas the Four Color Gradient Sampler allows you to mix colors. To do 
so, click a color in the Color Storage Area, then move the pointer (which changes 
from a Color Sampler tool to a Paint Bucket) to one of the four squares in the 

Color Picker

Brightness Adjuster

Foreground Color Indicator

Background Color Indicator

Gradient Preview

Color Storage Area

Switch Foreground/Background Colors

Change Foreground to Black/
Background to White

RGB Profile of Current Color

Four Color Gradient Sampler
Microspot PhotoFix                                4  - 24 



Gradient Sampler and click again. Repeat this procedure until each square contains a 
different color.

Storing New Colors

You can also store new colors in the Color Storage Area. Choose the Color Sampler 
tool, then click the desired color. Move the tool over the desired square in the Color 
Storage Area, hold down the Option key and click to replace the existing color.

Figure 4.26
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VIEW SCALE AND RESOLUTION
Click in the bottom left corner of the window to show a pop-up menu which lets you 
increase or decrease your view of an image.

Figure 4.27

Click in the bottom right corner of the window to modify an image's resolution. Note 
that you can also change resolution by choosing the Resize option from the Image 
menu.
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CHAPTER 5 - DRAG AND DROP

PhotoFix implements Drag and Drop which allows graphics to be moved or copied 
with remarkable ease. Drag and Drop can be used within PhotoFix, between PhotoFix 
and PhotoXtra or iPhoto, or between PhotoFix and other applications that support 
Drag and Drop.

For example:

• A selection can be dragged from one area of the current PhotoFix document to 
another area of the same document, or to a second PhotoFix document.

• A selection can be dragged out of a PhotoFix document to a PhotoXtra album to 
be stored.

• An image can be dragged out of a PhotoXtra iPhoto album to a PhotoFix 
document. Album items in PhotoFix, PICT or any other graphics file format (if 
these can be converted into PICT via QuickTime®), can be dragged directly to 
PhotoFix. 

• A drawing can be dragged out of MacDraft® (Microspot's 2D drawing and 
drafting application) and into a PhotoFix document to be enhanced.

• A selection can be dragged out of a PhotoFix document to the desktop to create a 
picture clipping.

Note: Although many of the above examples refer to MicrospotTM  products, Drag 
and Drop can also be used between PhotoFix and many other applications that 
support Drag and Drop, such as the Finder, AppleWorksTM etc.

To drag a selection from one PhotoFix document to another:

1.  Make your selection in the document and, with the marquee tool still selected, click 
the selection.
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2.  Hold down the mouse button and drag the cursor over the destination document 
window. A transparent copy of the selected area appears.

3.  Release the mouse button to place a copy of the selection in the new document.

4.  The real size of the selection is preserved, regardless of the resolution of the 
destination document.

A selection can be dragged from one PhotoFix document to a selection in 
another:

1.  Select an area in the destination document.
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2.  Make your selection in the originating document and, with the marquee tool still 
selected, click the selection.
3.  Hold down the mouse button and drag the cursor over the destination document 
window. A transparent copy of the selected area appears.
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4.  Release the mouse button when the cursor is over the selected area in the 
destination document to place a copy of the selection into the destination selection. 
The selection is scaled and/or distorted to fill the destination selection.

The selection in the destination document can be made up of several unconnected 
areas:

1.  Select an area in the destination document and add further areas to the selection by 
holding down the Shift key and making additional selections.

2.  Make your selection in the originating document and, with the marquee tool still 
selected, click the selection.
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3.  Hold down the mouse button and drag the cursor over the destination document 
window. A transparent copy of the selected area appears.

4.  Release the mouse button when the cursor is over one of the selected areas in the 
destination document to drop a copy of the selection into the destination selection.
5.  The selection is scaled and/or distorted to fill a bounding rectangle that would 
encompass all the selected areas in the destination document, and the destination 
selection is used to clip the image.
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INDEX
Numerics
3D effect, create using the spherize filter 3 - 39
A
Acquire

images from scanners etc 3 - 9
plug-ins 3 - 12

Acquisition profile
create using supplied target 3 - 9

Add, filter
noise 3 - 34
unsharp mask 3 - 35

Adjust
image colors, brightness and contrast

automatically 3 - 19
manually 3 - 19

Adjust window command 3 - 47
Airbrush tool 4 - 12

diameter controller 4 - 12
flow controller 4 - 13
natural flow 4 - 12
pressure controller 4 - 13
regular flow 4 - 12

Apply
color to the entire image 2 - 8
graduated colors to selected areas 4 - 15

Auto option 3 - 23
AutoFix option 3 - 19

customize settings 3 - 20
B
Background color 2 - 26
Bend image, using shrink filter 3 - 39
Blur 3 - 19

custom blur 3 - 36
image 4 - 14
motion blur 3 - 36

Blur tool 4 - 14
I



pressure controller 4 - 14
tool size controller 4 - 14

Border, define for selection 3 - 42
Bright/cont & RGB 2 - 23, 2 - 34

adjust green layer 2 - 34
adjust red layer 2 - 34

Burn tool 4 - 15
exposure controller 4 - 15
tool size controller 4 - 15

C
Cancel previous operation 3 - 14
Canvas

modify resolution 3 - 30
modify size 3 - 30

Change
colors in an image, using the hue/saturation dialog 3 - 22
foreground color to black and background color to white 2 - 8
painting or drawing tool into color sampler tool 4 - 16
vibrancy of colors in an image, using the hue/saturation dialog 3 - 23

Choose
plug-ins folder 3 - 41
plug-ins to use 3 - 4

Clear command 3 - 15
Clipboard 2 - 25
Clone image, continually 4 - 13
Clone tool 2 - 16, 4 - 13

clone align 4 - 13
set opacity 4 - 13
set reference point 4 - 13
set size 4 - 13

Close
active window 3 - 7
all application windows 3 - 7

Close command 3 - 7
Color modes, converting 2 - 35
Color palette

add colors to 2 - 7
background color indicator 2 - 5
II



bitmap palette 4 - 22
brightness adjuster 2 - 5, 2 - 7
color picker 2 - 5, 2 - 7
color sampler tool 2 - 5, 2 - 8
color storage area 2 - 7, 2 - 8
extend 2 - 5
foreground color indicator 2 - 5
four color gradient sampler 2 - 5
gradient preview 2 - 5
grayscale palette 4 - 22
hide 3 - 45
indexed color palette 4 - 23
RGB color palette 4 - 24
set the palette that will be used when opening new documents 3 - 2
show 2 - 3, 3 - 45

Color sampler tool 2 - 26, 4 - 16
Colors

adding to grayscale palette 2 - 36
Compression format 2 - 10
Convert

grayscale image to black and white 3 - 26
RGB images to indexed mode 3 - 27

Copy
graphics, using drag and drop 5 - 1
part of an image 3 - 15
selection as a pattern 3 - 16

Copy command 3 - 15
Copy pattern command 3 - 16
Correct images, using image menu options 3 - 18
Create

custom color 4 - 19
custom color palettes 4 - 19

Crop command 3 - 29
Crop tool 2 - 12, 2 - 20, 4 - 5
Custom blur effect 3 - 36

choose strength 3 - 36
Custom color palette, create 2 - 36
Cut command 3 - 15
III



D
Darken areas of image 4 - 15
Deactivate active selection 3 - 44
Delete all but the selected part of an image 3 - 29
Distort

apply the distortion 3 - 31
define a selection 3 - 30

Distort 2D 3 - 33
with precise control 3 - 38

Distort 3D 3 - 33
with precise control 3 - 38

Distortion 3 - 30
Distortion options 3 - 38

distort 2D 3 - 33, 3 - 38
distort 3D 3 - 33, 3 - 38
perspective 2D 3 - 32
perspective 3D 3 - 32
scale 3 - 31
shrink 3 - 39
skew 3 - 31
spherize 3 - 39

Documentation 1 - 2
PhotoFix manual 1 - 2

Dodge tool 4 - 15
exposure controller 4 - 15
tool size controller 4 - 15

Draw
circles 4 - 7
dots, curves and lines 4 - 9
lines 4 - 7

at 45° angle 4 - 7
straight 4 - 7

ovals 4 - 7
rectangles 4 - 8
squares 4 - 8

Drawing tools 4 - 7
draw filled shapes 4 - 7
tool settings 4 - 7
IV



Duplicate portions of an image, using clone tool 4 - 13
Dust and scratches, remove 3 - 40

set scratch thickness 3 - 40
set threshold 3 - 41

E
Edit menu 3 - 14
Effect 3 - 36

custom blur 3 - 36
motion blur 3 - 36
posterize 3 - 37
remove 3 - 40

EPS format 3 - 8
EPS mask, create using pen tool 4 - 3
Erase

entire image 4 - 12
part of an image 3 - 15
selection 4 - 12

Eraser tool 4 - 12
Export

images 3 - 12
Export command 3 - 12
F
Feather selection 3 - 43

set level 3 - 43
set transparency 3 - 44

Feather/Transparency command 3 - 43
Feather/transparency command 3 - 43
File

icons 3 - 2
size 1 - 2, 2 - 36

File format 2 - 10
File menu 3 - 5
Fill adjacent pixels of similar colors with foreground color 4 - 11
Fill with

background color 3 - 15
foreground color 3 - 15
pattern 3 - 16

Fill with command 3 - 15
V



Filter menu 3 - 34
add 3 - 34
effect 3 - 36

Flip
horizontal 3 - 28
vertical 3 - 28

Float selection 3 - 43
Free rotation 3 - 28
G
General preferences dialog 2 - 1
Gradient

apply 2 - 25, 2 - 32
to floating text 2 - 28

Gradient tool 2 - 27, 2 - 32, 4 - 15
Graphic formats supported 3 - 6
Grayscale image

apply color effects to 2 - 36
convert file to 2 - 36

Grow selection 3 - 42
H
Hand tool 4 - 16
Help

PhotoFix manual 3 - 48
tool info 3 - 48

Help menu 3 - 48
PhotoFix manual 3 - 48
registration information 3 - 48
tool info 3 - 48
upgrade information 3 - 48

Hide
colors 3 - 45
edges of selection 3 - 44
info palette 3 - 45
tool palette 3 - 46
tool settings palette 3 - 46

Histogram, view channels 3 - 21
Hue/saturation

hue 3 - 22
VI



saturation 3 - 23
scale 3 - 22

I
Image

modify the size and resolution 3 - 29
resize 2 - 24
retouching 2 - 16

remove scratches etc. 2 - 16
Image border, set to black 3 - 3
Image contrast and brightness, automatically enhance 3 - 23
Image controls 2 - 6

view/change resolution 2 - 6
zoom in/out 2 - 6

Image correction 2 - 12, 3 - 23
auto option 2 - 13, 2 - 28, 3 - 23
automatic 2 - 12, 3 - 23

define clipping 3 - 24
define color targets 3 - 23
set clipping values 3 - 24
set target values 3 - 24
set the brightness of the target points 3 - 25

levels 2 - 14
black point 2 - 14
gamma 2 - 15
gray point 2 - 14
output 2 - 15
reset 2 - 16
threshold mode 2 - 15
white point 2 - 14

manual 2 - 13
Image menu 3 - 18
Image mode 4 - 17

bitmap 3 - 25, 4 - 17
choose 3 - 25
convert 3 - 26, 4 - 18

color combinations 4 - 18
grayscale to bitmap 3 - 26
RGB to indexed 3 - 27
VII



grayscale 3 - 26, 4 - 17
indexed 3 - 26, 4 - 17
RGB 3 - 26, 4 - 17

Increase
size of the document 3 - 30

Indexed colors, convert to 2 - 35
Indexed palette, customize 2 - 36
Info 2 - 6
Info palette 3 - 45, 4 - 17

hide 3 - 45
show 3 - 45

Installation 1 - 1
Introduction 1 - 1
Invert

image colors 3 - 18
selection 3 - 42

L
Lasso/pen tool 2 - 23, 2 - 24, 4 - 1
Launch application 2 - 1
Layers

apply modified layers to the image 3 - 28
separate the image into red, green and blue 3 - 28

Layout, configure 3 - 12
Levels

auto levels settings 3 - 23
clipping 3 - 24
color targets 3 - 24

set black point 3 - 10
set gray point 3 - 10
set RGB value for black 3 - 10
set RGB value for gray 3 - 10
set RGB value for white 3 - 10
set white point 3 - 10

Lighten areas of image 4 - 15
Line tool 2 - 8, 4 - 7
Load

custom color palette 4 - 21
RGB layers 2 - 34, 3 - 28
VIII



Load mask command 2 - 31
M
Magic wand tool 2 - 25, 2 - 30, 4 - 3

set tolerance 4 - 3
Mask

create bitmap or grayscale image of the active mask 3 - 44
grayscale

create 2 - 32
edit 2 - 32

load 2 - 31, 3 - 44
separate 3 - 44

Memory space 3 - 16
application memory 3 - 17
erase multiple undo files 3 - 17
scratch disk space 3 - 17

Menus 3 - 1
Mode, image 3 - 25
Monochrome 3 - 34
Motion blur 3 - 36

set angle 3 - 37
set length 3 - 37

Move
graphics, using drag and drop 5 - 1
image in window 4 - 16

N
New command 3 - 5
New image

contents 2 - 7
create 2 - 7, 3 - 5
dialog 2 - 7
format 2 - 7

postcard 2 - 12
resolution 2 - 6

Next window command 3 - 47
Noise, remove 3 - 41

set radius 3 - 41
IX



O
Open

image, quickly 2 - 38
Open album command 3 - 7
Open command 3 - 6
Orientation, configure 3 - 12
Oval drawing tool 4 - 7
Oval selection tool 4 - 5
P
Page format command 3 - 13
Page setup command 3 - 12
Paint brush tool 4 - 9

modify shape 4 - 9
pressure sensitivity 4 - 11

Paint bucket tool 4 - 11
set tolerance 4 - 11

Paint with brushes of various shapes and widths 4 - 9
Palettes 2 - 3, 4 - 1

color palettes 4 - 22
info palette 4 - 17
tool palette 2 - 4, 4 - 1
view scale and resolution 4 - 26

Paper size, configure 3 - 12
Paste

inside the selection 3 - 15
into an image 3 - 15

Paste command 2 - 25, 2 - 32, 3 - 15
Pen tool 4 - 2

activate 4 - 2
close path 4 - 2
draw polygonal selections 4 - 2

Pencil tool 4 - 9
pressure sensitivity 4 - 9
set diameter 4 - 9

Perspective 2D 3 - 32
Perspective 2D effect 3 - 32
Perspective 3D 3 - 32
Perspective 3D effect 3 - 32
X



PhotoFix appication menu 3 - 1
PhotoFix manual 3 - 48
Pixel value distribution, graphic representation of 3 - 21
Posterize 3 - 37
Posterize filter 3 - 37
Preferences 3 - 2

general preferences 3 - 2
black background 3 - 3
default palette 3 - 2
image icon 3 - 2
setting 2 - 1
tool area 3 - 3
tool spacing 3 - 2
unit 3 - 2

memory and plug-ins preferences 2 - 2, 3 - 3
multiple undos 2 - 3, 3 - 4
plug-ins folder 3 - 4
quit special 2 - 2
save open images 2 - 2, 3 - 3

when “quit special” 3 - 3
when power failure 3 - 3

scratch disk/folder 2 - 2, 3 - 3
when power failure 2 - 2

setting 2 - 1
Print command 3 - 13
Printing 2 - 39
Q
Quit PhotoFix command 3 - 4
Quit program 3 - 4
Quit special 2 - 38

dialog 2 - 38
R
Rectangular drawing tool 2 - 9, 4 - 8
Rectangular selection tool 2 - 11, 2 - 21, 2 - 25, 4 - 4

constraint 2 - 12
no constraint 2 - 21

Redo command 2 - 28, 3 - 14
Remove
XI



color casts, when scanning 3 - 8
dominant color 2 - 34
dust and scratches 3 - 40
noise 3 - 41
part of an image 3 - 15
parts of an image and replace them with the background color 4 - 12
unwanted parts of an image, using the crop tool 4 - 5

Replace
layers 2 - 34
part of an image with the current background color 3 - 15

Reposition image on canvas 3 - 30
Resize 3 - 29

canvas 3 - 30
image 3 - 29
keeping file size 3 - 30
keeping proportions 3 - 30

Resolution, change 4 - 26
Restore cancelled operation 3 - 14
RGB color palette

change a color's shade 4 - 24
change the foreground color 4 - 24
extend 4 - 24
gradient preview 4 - 24
mix colors 4 - 24
storing new colors 4 - 25

RGB layers, retouching 2 - 34
Rotate

+90° 2 - 18, 3 - 28
-90° 3 - 28
image 2 - 18
image/selection 4 - 6

S
Save

custom color palette 4 - 21
image as a new file 3 - 7
image modifications 3 - 7
open files when qiuting 3 - 4
when a power failure or system crash occurs 3 - 3
XII



Save as
EPS 3 - 8

with mask 3 - 8
JPEG/JFIF 3 - 8
PhotoFix 3 - 8
PICT 3 - 7
TIFF 3 - 7
Windows BMP 3 - 8

Save as command 3 - 7
Save command 3 - 7
Scale 3 - 31
Scanner, correct response 3 - 8
Select

adjacent pixels of similar color, brightness or hue 4 - 3
colors from within image 4 - 16
complementary portion of an image 3 - 42
entire image 4 - 2
foreground color 4 - 16
similar 3 - 43

Select all command 3 - 44
Select none command 2 - 12, 2 - 30, 3 - 44
Selection

add to 4 - 2, 4 - 4, 4 - 5
adjust crop tool selection 4 - 5
border 3 - 42
change the shape of 3 - 30
copy 4 - 2, 4 - 4, 4 - 5, 4 - 9
define border 3 - 42
distort

floating selection 3 - 32
giving 3D effect 3 - 32
in two dimensions 3 - 32
non-floating selection 3 - 32
to create a perspective effect in 2D 3 - 32

drag from one PhotoFix document to a selection in another 5 - 2
drag from one PhotoFix document to another 5 - 1
drag into selection made up of several unconnected areas in another document 5 - 4
feather 2 - 21
XIII



fill with
background color 3 - 15
foreground color 3 - 15
pattern 3 - 16

flip 3 - 28
floating 4 - 8
hide edges 2 - 30
increase size 3 - 42
invert 2 - 27
make

constrained 2 - 11, 4 - 4
using oval selection tool 4 - 5
using rectangular selection tool 4 - 4
using the lasso/pen tool 4 - 1
with straight edges 4 - 1

modify the length or width 3 - 31
move outline 4 - 2, 4 - 4, 4 - 5
rotate 3 - 28
save 4 - 2
save as mask 2 - 22
scale, maintaining proportions 3 - 31
slant vertically or horizontally 3 - 31
subtract from 4 - 2, 4 - 4, 4 - 5
working with 2 - 21

Selection menu 3 - 42
border 3 - 42
feather/transparency 3 - 43
float 3 - 43
grow 3 - 42
hide edges 3 - 44
invert 3 - 42
load mask 3 - 44
select all 3 - 44
select none 3 - 44
separate mask 3 - 44
similar 3 - 43

Separate
RGB layers 3 - 28
XIV



Separate mask command 2 - 22, 2 - 31, 3 - 44
Separate RGB layers, choose 2 - 34
Settings 3 - 18

AutoFix 3 - 19
blur/blur a lot 3 - 19
bright/cont and RGB 3 - 19
histogram 3 - 21
hue/saturation 3 - 22
levels 3 - 23
negative 3 - 18
sharpen/sharpen a lot 3 - 19
tool palette 3 - 46
tool settings palette 3 - 46

Sharpen 3 - 19
image 4 - 14

Sharpen tool 4 - 14
set pressure 4 - 14
set size 4 - 14

Show
colors 3 - 45
help available for the selected tool 3 - 48
info palette 3 - 45
PhotoFix manual 3 - 48
tool palette 3 - 46
tool settings palette 3 - 46
tool size and shape 3 - 3

Shrink 3 - 39
horizontal effect 3 - 39
number of waves 3 - 39
vertical effect 3 - 39

Skew 3 - 31
Special effects

apply to images 3 - 34
Spherize 3 - 39

set horizontal effect 3 - 40
set vertical effect 3 - 40

Spray paint on image using airbrush tool 4 - 12
Straighten
XV



image 2 - 19, 2 - 20
image/selection 4 - 6

Straighten/rotate tool 2 - 18, 2 - 19, 4 - 6
Strength 3 - 35
subtract 4 - 2
T
Technical support 1 - 3
Temporary backup files, select location to store 3 - 3
Text

add to image 4 - 8
anti-alias 4 - 8
floating selection 2 - 29
mask 4 - 8
position 2 - 10, 2 - 29

Text tool 2 - 9, 2 - 28, 4 - 8
settings dialog 2 - 9

attributes 2 - 9
floating selection 2 - 9
font 2 - 9

text settings dialog 4 - 8
Third party filters, using 3 - 41
Threshold 3 - 35
Tool info 2 - 4, 3 - 48, 4 - 1
Tool palette 4 - 1

hide 3 - 46
show 3 - 46

Tool palettes 4 - 1
Tool settings palette 2 - 4

hide 3 - 46
show 3 - 46

Tool spacing, set the distance 3 - 2
Tutorial 1 - 4, 2 - 1
U
Undo

corrections made through acquisition profile 3 - 8
erase saved files to free disk space 3 - 17

Undo command 2 - 3, 3 - 14
Undos, multiple 3 - 4
XVI



set level 3 - 4
Unsharp mask 3 - 35

set radius 3 - 35
set strength 3 - 35
set threshold 3 - 35

V
View

another open PhotoFix image 3 - 47
View menu 3 - 45

show/hide colors 3 - 45
show/hide info 3 - 45
show/hide tool settings 3 - 46
show/hide tools 3 - 46
zoom in 3 - 45
zoom out 3 - 45

W
When “quit special” 3 - 3
When power failure 3 - 3
Window menu 3 - 47

adjust window 3 - 47
next window 3 - 47

Working efficiently 1 - 2
Z
Zoom in 3 - 45

on image 4 - 16
Zoom out 3 - 45

on image 4 - 16
Zoom tool 2 - 16, 4 - 16
XVII
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