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Introduction

About Sound Studio

Welcome to Sound Studio
Sound Studio is an audio recording and editing app for the Mac OS. It allows you to
take full advantage of your Mac's built-in sound recording and playback capabilities,
to digitize your collection of vinyl and tapes, to do live recording of audio, to edit new
and pre-existing digital audio, and to save your audio in AIFF or Sound Designer II
format to be used in other audio apps. And it all costs just US$35, if you decide to
keep it beyond the 14-day trial period.

Features
Recording:

•  CD-quality recording on most Macs (44.1kHz, 16-bit stereo)
•  Records from any Sound Manager input device
•  Can record while playing back other sound files
•  Can record while you work in other applications

Editing:
•  See what you're editing in the waveform display window
•  Standard cut/copy/paste editing, to and from other applications Single-channel

editing allows left or right channel to be edited independently
•  Filters which can apply effects to the audio
•  Pitch-shifting
•  Resampling

Application:
•  Opens and saves in AIFF, Windows WAVE, System 7 Sound, and Sound

Designer II file formats
•  Uses little RAM: 6MB RAM lets you open several files up to 2 GB in size each.

Requirements
•  Mac OS 8.5 or later
•  PowerPC Macintosh, including G3/G4
•  6 MB free RAM
•  Hard disk space for working with audio files

Filters
Volume Control:

•  Amplify (increase or decrease volume)
•  Normalize
•  Fade In / Fade Out
•  Noise Gate

Special Effects:
•  Backwards
•  Delay
•  Echo
•  Invert: (180° phase change)
•  Swap Channels (of stereo audio)

Equalization:
•  Smooth
•  Emphasize
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License and Registration
Felt Tip Sound Studio is distributed as shareware. You can use it on 14 different days
before you're required to either register it or remove it from your hard disk.
Registration is US$35 and gets you a single-user license code which is good for all 1.x
versions of Sound Studio (that is, any version number less than 2.0, but not including
version 2.0). Site licenses and world-wide licenses are available, and other licensing
schemes are possible. Please see the Felt Tip Web site to register or for details on
licensing.

http://www.felttip.com/register/

Once you have received your license code, you can personalize your copy of Sound
Studio by going to the Register menu and selecting “Enter License Code.” In the
dialog that appears, you can enter the name you registered with and the license code
that matches that name. You can also enter your company’s or organization’s name in
the dialog, but this is optional.

What's Included?
The Sound Studio folder should include:

1. About Sound Studio: a short document describing Sound Studio

2. User's Manual: this document

3. Felt Tip Sound Studio: the application

4. How to Register: describes registering, the process of obtaining a license
for this application

5. Register Sound Studio: an app you can use to begin registration

6. Release Notes: describes the historical changes between each version of this app

If you are missing any of these items from your Sound Studio folder, please download
the complete package from:

http://www.felttip.com/products/soundstudio/

About this User’s Manual

This document has two major parts:
1. Getting Started

2. Reference for Sound Studio

The first part, “Getting Started,” describes how to install Sound Studio and set it up,
and what system requirements are needed and what is recommended.

The second part, “Reference for Sound Studio,” is an item-by-item description of each
menu and window item in Sound Studio. It contains more detailed and complete
information than the other parts of this document.

If you are using Adobe Acrobat, be sure to open the document map on the left side of
this window. It will allow you to more easily navigate this document.

http://www.felttip.com/register/
http://www.felttip.com/products/soundstudio/
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Getting Started

This chapter describes how to install Sound Studio on your Mac and set it up for the
first time. It also contains information on the minimum system requirements to run
Sound Studio.

Installing Sound Studio
You can get the latest version of Sound Studio from the Felt Tip Software Web site:
http://www.felttip.com/soundstudio/

Sound Studio is distributed as a StuffIt 5 archive. You will need Aladdin’s StuffIt
Expander 5.0 or later to decompress the archive, or a compatible decompression
utility. Once you have decompressed the archive, you will have the Sound Studio
folder on your hard disk.

You can get Aladdin StuffIt Expander from:
 http://www.aladdinsys.com/expander/

You can install Felt Tip Sound Studio by dragging the entire Sound Studio folder to
any place on your hard disk. However, the application does not rely on any of the files
in the folder, and does not need to be placed in any specific location on your hard
disk.

Requirements
Sound Studio has the following system requirements:

•  Mac OS 8.5 or later, for the Appearance Manager and Navigation Services
•  Power Macintosh, including the G3/G4 and PowerPC PowerBooks.
•  6 MB of available RAM
•  Hard disk to use as a scratch disk

Also, it is recommended that you have the following:
•  Mac OS 9 or later
•  16- or 32-bit graphics display
•  Sound input device, such as the built-in microphone or the sound input port.
•  Available hard disk space approximately twice the size of the audio files you will

be working with.

Setting Up Sound Studio
Scratch Disk
The first time you launch Sound Studio, you will want to set up your scratch disk.
Choose “Preferences” from the Edit menu, select the name of the disk you want to use
as your scratch disk. This is where Sound Studio stores audio data while it is
recording and editing. You will want to select a disk with sufficient available disk
space and speed.

Other than the scratch disk, there is nothing else you need to set up in Sound Studio.

http://www.felttip.com/soundstudio/
http://www.aladdinsys.com/expander/
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Reference for Sound Studio

This chapter describes in detail each of the commands in Sound Studio, and the parts
of its windows.

Balloon Help has been built into the menus of Sound Studio. To turn on Balloon Help,
choose “Show Balloons” from the Help menu. Then select any menu item and help
will be shown next to the item.

This chapter is organized into two sections, “Commands” and “Windows,” with
several sub-sections:

•  “File Commands” describes the File menu, which allow the filing of audio files
and changing the properties of the entire file. This includes resampling and
pitch-shifting.

•  “Edit Commands” describes the Edit menu, which allow you to insert, remove,
silence audio, as well as normal copy-and-paste to and from other applications.

•  “Filter (Effects) Commands” describes the Filter menu, which allows you to
apply filters or effects to the audio.

•  “Document Window” describes the features of the parts of the main document
windows, where you record, edit and play back an audio file

•  “Sound Input Palette” describes the features of the floating palette window
which allows you to set various sound input settings.

Commands in Sound Studio

This section describes the menu commands in Sound Studio. It describes how each of
the commands works, and contains tips on getting the most out of each command.

File Commands
This sub-section describes the commands in the File menu of Sound Studio

New
Asks you what sound settings to give the new file, and creates a new, empty audio file
which can be recorded or pasted into. Depending on which model Macintosh you
have, not all of the sound settings are compatible for recording. For example, on most
newer Macs you can only record at 44.1kHz. If you select a different sample rate, your
new window will have its Record button disabled. To allow recording, after you have
created a new file, go to the Resample command and select a compatible sample rate.

Open
Opens an existing AIFF, Windows WAVE, System 7 Sound, or Sound Designer II
audio file. Sound Studio can open audio files saved with an 8 or 16 bit sample size,
one or two channels, and any sample rate up to 65335 Hz.

Close
Closes the active window, asking to save changes if the window hasn’t been saved.
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Save / Save As
A normal save will save the active window in the same format it was last saved as,
which is AIFF by default. Disabled if no changes have been made to the window.

Save As will ask you where you want to save the active window, and allows you to
change the file format to AIFF, Windows WAVE, System 7 Sound, or Sound Designer
II.

Revert
Discards all changes you’ve made to the active window, and reloads the last saved
version of the window.

Resample
Changes the sample rate, sample size (8 or 16 bits), and number of channels (mono
channel or stereo) of the active window, without changing the pitch or the overall
duration of the entire audio file. This command is a bit slower than the other
commands in this application, so it’s advised that you use it with small or empty files
only.

In the Resample dialog, there is a sample rate field where you can type in a sample
rate or select a pre-defined one from a pop-up list. Not all rates are supported by all
Macs, so for some rates you will see an alert saying that you can’t record at that rate.
This does not affect the editing or saving functions of Sound Studio, only recording.

Change Pitch and Duration
Changes the sample rate of the active window without touching the actual audio data,
resulting in audio that runs at a different speed and has a higher or lower pitch, based
on your new settings. Both pitch and duration are simultaneously changed.

Preferences
Shows the preferences dialog, where you can select which disk to use as your scratch
disk, and whether to scroll the window while playing in order to keep up with the
green playback marker.

Quit
Closes all open windows, asking to save those with unsaved changes, closes the
sound input driver, and quits the application. When Sound Studio is launched, it
automatically tries to open the default sound input driver, and presents an alert if it
couldn’t open it.

Edit Commands
This sub-section describes the commands in the Edit menu, which allow you to undo
your last action, put and retrieve audio data on the clipboard, insert silence in and
remove selections from the audio, and make parts of the audio silent.

Undo / Redo
After you have done something that can be undone, you can use this command to
undo that action. This item toggles between undo and redo, where redo repeats your
action after you undo it. With this command you can switch between the before and
after states of a filter or edit, and compare how they sound.

Cut / Copy / Paste
These commands behave like standard clipboard commands, moving data to and
from the clipboard so that it can be used elsewhere in Sound Studio and in other
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applications. The paste command does not overwrite existing sound data, but it does
replace the current selection with audio from the clipboard.

Clear
Removes the selected audio and moves the audio after it to fill in the gap. If you want
to remove audio without changing the timing of the audio, use the “Silence”
command instead.

Select All
Selects the entire sound file from beginning to end. If only one channel of a stereo file
was selected, it only selects the entirety of that channel, and not the other channel.

Silence
Makes the selected part of audio silent, so that it has zero amplitude. This creates a
silent passage in your audio. The first and last 0.5 milliseconds of the selection will be
blended (cross-faded) between the existing audio and silence, to create a smooth
transition. The duration of the blending is not adjustable.

Insert Time
Inserts an amount of silence, which you specify in a dialog, at the insertion point or in
place of your selection, and moves the audio after it to accommodate the new silence.

Crop
This command keeps your selection and discards the unselected remainder.

Filter (Effects) Commands
This sub-section describes the Sound Studio filters, found in the “Filter” menu. All the
filters work on the selected part of the audio only, or the entire file if there is no
selection.

Except for the “Swap Channels” and “Backwards” filters, all the filters below will
blend (cross-fade) the first and last 0.5 milliseconds of the selection between the
existing audio and the new, amplified audio, to create a smooth transition. The
duration of the blending is not adjustable.

Amplify
This is the volume control knob for the sound. 100% equals the current volume. Turn
it up, get a louder sound. Turn it down, it's quieter. You want to be sure not to turn it
up too much or it will clip the sound. Clipping is when the waveform tries to be
bigger than the height of the channel it is in, and since there's no more room
(headroom), the parts that don't fit simply get chopped off. Unless you want that kind
of distortion, you should try not to amplify it too much.

If you're trying to get the sound volume to a specific peak loudness, try the Normalize
filter.

Power user note: you can go past 200% by typing in the desired amplification, for
example for 4x amplification, just type in 400% in the input field, and it'll amplify at
400%.

Backwards
I don't know if anybody really uses this filter for anything but having fun. It turns
your sound around so that it plays backwards. The effect is the same as playing a tape
backwards.
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Delay
This filter mixes a single copy of your selection with itself, but at a lower volume and
offset by the amount of time you specify. It's kind of like having a tape loop which
records what you say and plays it back a certain amount of time later, or shouting
across a valley and hearing your reflected echo once -- but it reflects the sound only
once, unlike a true echo.

You can control how long of a delay you want (you can use decimal numbers such as
1.345 here), and the strength, or the volume, of the delayed sound.

Echo
This filter is just like Delay except it keeps repeating itself over and over at lower and
lower volumes until it dies out. It's like a real echo, one you'd get if you were to shout
inside a canyon. The controls are pretty much the same as for Delay. Note that the
echo will end abruptly at the end of the selection unless you first insert silence at the
end of the sound file and select the audio plus the silence when applying the echo
filter.

Emphasize
This is an equalization filter which emphasizes the high tones (treble) in a sound. It
tends to make sounds more crisp, but also introduces more noise.

Fade In/ Fade Out
This pair of filters do what they say: they fade in from silence and fade out to silence.
The fade is a linear fade, so if you have a constant volume sine wave and you fade it
out, you'll see it taper off at the same rate throughout the entire fade to silence. You'll
want to select just the part that you want to fade. For example, if you wanted to start
fading out at five seconds before the song ends, you would select the last five seconds
and apply the Fade Out filter.

Invert
This filter simply turns your waveform upside down. You won't hear a difference
after you've applied the filter. If you consider waves which go above the centerline of
the display to be positive and waves which go below to be negative, the Invert filter
just makes the positive parts negative and vice-versa. This filter is useful when you
have a stereo file and one of its channels is inverted relative to the other. The audio
will sound like it's coming from the sides when you listen to it in stereo, with no audio
coming from the center. This filter will be useful in the future when you can select
each channel individually.

Noise Gate
This is a more complex filter. It silences passages of audio which fall below a certain
'threshold' volume for a certain length of time (the 'attack'). If the noise level is high,
increase the threshold. If you end up silencing too much of your audio, decrease the
threshold. If short lengths of noise are not being silenced, decrease the attack. If there
is too much noise hanging around the edges of the audio, increase the attack.

Normalize
This filter brings the volume of your audio as high as it can without clipping. This
way, you can make sure you're using all the bandwidth (height of the channel) that
you can get. Adjusting the 'Normalize to' value changes the maximum amount of
bandwidth you want to use. At 50%, the sound volume will be brought up (or down)
so that only half of the available bandwidth will be used.

The 'Adjust tracks individually' option controls whether you want to treat the two left
and right tracks as independent audio tracks or as one stereo track. If the audio you're
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editing already has its balance between the left and right sides perfectly set, then you
want to leave this option off. However, if one side is much louder than the other and
you want them balanced, select this option.

Smooth
This is the complementary filter to Emphasize. This one reduces the high tones (treble)
in the sound file, making it less bright. It can also help reduce perceived noise in the
audio by smoothing out the waveform.

Swap Channels
This filter simply swaps the left channel with the right channel, in case you had the
left and right cables mixed up when you recorded the audio.

Windows in Sound Studio

This section describes the windows in Sound Studio, and the controls, views, and
other items in them. Information on dialog boxes is found with their corresponding
commands.

Document Window
The document window is the window you see when you create a new file or open an
existing one. It is the main working area where you will record, edit, and play back
your audio.

The descriptions below start with the items at the top left of the window and work
their way first to the left, and then down.

Transport Controls
The transport controls are in the upper left corner of the window and control both
playback and recording of audio. The stop and pause buttons work while playing or
recording, but the play and record buttons can only be used one at a time.
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 (keyboard equivalent: Space Bar, while playing, or Command-Period)

The stop button will end playback or recording.

 (keyboard equivalent: Space Bar)

The play button will start playback from the current insertion point. If you have made
a selection, it will only play the selected part of the audio file. Currently, single-
channel playback of stereo files is not supported. Stereo files will play in stereo
regardless of which channel is selected.

 (keyboard equivalent: P)

The pause button will pause playback or recording until the button is pressed again.

 (no keyboard equivalent)

The record button will start recording from the sound input and append the audio
data to the end of the current file.

Time Displays
The “elapsed” time displays the amount time from the beginning of the audio file to
the insertion point or left edge of the selection. The “remaining” time displays the
amount of time from the insertion point or left edge of the selection to the end of the
audio file. The “total” time displays the amount of time from the beginning to the end
of the file.

Playback Volume Control
The playback volume control is a logarithmic slider with a percentage readout which
controls the playback volume of the audio file. It only affects the volume which Sound
Studio plays, and its setting is not saved with the file.

Double-click on the slider to reset it to 100%. The slider has a range from 0% to 300%.
At volumes above 100%, clipping may occur on playback.

Waveform Overview
This area in the top half of the window shows the entire audio file, and has a box
which defines the current area being shown in the Waveform Main View below. Drag
the left and right edges of the box to resize it.

Double-clicking on the overview sets the zoom level to “Fit On Screen.”

Waveform Main View
This area in the bottom half of the window is where you will edit the audio waveform.
It shows the area outlined by the Waveform Overview above. In this view you can
select audio data for editing and for applying filters.

Double-clicking on the view selects all of it.

Modifier keys. You can use several modifier keys by holding down these keys while
clicking and dragging the mouse. Holding down the shift key allows you to extend
the selection. Holding down the command key allows you to scroll the view by
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dragging left and right. Holding down the option key  lets you zoom in, while holding
down both the option and control keys lets you zoom out.

Single-channel selection. For stereo files, clicking in the top half of the left channel
selects the left channel, and clicking in the bottom half of the right channel selects the
right channel. Clicking in the middle of the view selects both channels. When you
have made a single channel selection, subsequent selections will generally be kept in
the same channel.

Ruler. The ruler along the top of the view has markings in minutes, seconds and
milliseconds.

Playback Marker (the Green Line)
While playing back the audio, this green line shows you where the playback head
currently is. Some time drift may occur since the timer is only about 99% accurate.

Sample Size / Sample Rate Display
In the lower left corner of the window is a button which shows the file’s sample size (8
or 16 bit) and sample rate (in kilohertz). Clicking on this button brings up the
Resample dialog.

Zoom Pop-up Menu
The Zoom button, located next to the Sample Size/Rate Display, shows the zoom
ratio, or how many samples each pixel (dot) represents. A ratio of 1:1 means that you
are seeing every sample, while a ratio of 1:100 means that each pixel (dot) represents
100 samples in the audio file.

Clicking on this button reveals the pop-up menu where you can select a predefined
zoom ratio. You can also change the zoom using the View menu, by changing the box
in the Waveform Overview, or by option-clicking and command-option-clicking the
Waveform Main View.

Sound Input Palette
The sound input palette is a floating window that shows the current levels at the
sound input, and lets you control the input gain (amplification), the input source, and
whether or not to play the input signal through your selected sound output device
(usually your speakers or headphones).

You can show and hide the Sound Input palette by using the Window menu.
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Level Meter
The level meter, at the top of the palette window, shows the current levels in the left
and right sound input channels. When there’s one bar, that means there’s no signal at
the inputs, and when the bar lights up all the way to the right, that means the signal is
saturating the input. The bars turn yellow at approximately 70% and red at 90%. The
levels are not exact, since it only reports the levels that the Sound Manager drivers
report, on a scale of 0-255.

Input Gain Control
The input gain control is directly under the level meter, and controls the gain, or
amplification, at the sound input, before the audio is digitized. You want increase the
gain as much as possible without going into the red on the level meter and possibly
causing clipping.

Double-clicking on the control will return it to the zero position.

The dB markings on the control are only approximate. On Macs produced in the past
two years, the actual gain spans about 46.5 dB, and other Macs can have either 46.5 dB
or 22.5 dB gain. You will have to experiment to determine the actual effect of the input
gain.

For programmers, the slider range corresponds to an input gain setting of 0.5 to 1.5,
with 1.0 being at the center.

Input Source Pop-up Menu
The input source pop-up menu is labeled “Source” and contains a list of input sources
provided by the current default sound input driver.

You can change the current input driver by opening the Sound control panel in the
System and selecting a different driver. You will have to quit and relaunch Sound
Studio to use the new drier.

Play-Through Checkbox
The play-through checkbox is labeled “Play sound through output device” and when
checked, does what it says. When it is on and your speaker is in near your
microphone, you may get feedback. However, if you’re not recording from a
microphone, or you are using headphones, you can turn this on to hear what you are
recording.
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