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• Drawing By 
Example

• Template 
Structure
The most common question asked about any CAD o
drawing program is "How do I draw something? Whe
do I start?". The first thing you should do is learn the
features of the program. This is covered in the 
VectorWorks User’s Manual. It is especially importan
to familiarize yourself the first three chapters, 
Introduction, Getting Started, and Organizing Your 
Drawing, as they contain summaries of the core 
VectorWorks concepts. Once you understand the bas
of the application, you need to pool your knowledge 
and use all of those features together to accomplish 
given task. What is the task? This question must be 
answered before you begin to draw. Understanding 
what you are going to draw will help you to pick a 
starting point and in VectorWorks that is a template. W
have provided a series of templates that cover a broa
base of tasks and can serve as a basis for most thin
that you will draw. 

DRAWING BY EXAMPLE

The best way to describe how to draw is to show it 
through examples. Examples can be shown or creat
through exercises. Each exercise in this manual 
provides methodologies for a variety of tasks. It also
brings a level of reality to the process. We certainly c
not cover every possible need but can provide a broa
spectrum of exercises which many people will find 
useful across many industries.
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These exercises are written under the assumption that you have read
User’s Manual and understand the operation of the features referred 
The procedures should be followed sequentially even through headers
break the numbering scheme. 

Note: If at any time while performing the exercises in this manual you do no
understand how to use a tool, refer to the VectorWorks User’s Manua

Each exercise has an accompanying sample file which is located in th
Learning Exercises folder in your VectorWorks Toolkit folder. The samp
file is the completed drawing that you will be creating. You can use th
sample file as a point of reference to verify that you are executing the
steps correctly. You can also use this file to import the resources nee
for the exercise.

TEMPLATE STRUCTURE

VectorWorks’s templates are designed to make drawing most efficient
we provide layers, classes and sheets, we use a drawing methodolog
is sheet based. Each of the exercises is based on the concept that 
switching between the provided sheets will hide and show the necess
layers and classes. Each sheet contains a title block that tells you the 
of the sheet. Remember that a sheet is a combination of visible layers
classes and is what you desire as printed output.

Each exercise is structured similarly to make them easy to follow. The
proceed in the order they are to be performed. In most cases, this is 
structured in a linear fashion in which the next procedure builds on th
steps performed in the previous. The results of the steps are illustrate
help ensure you get the correct results for each step.
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 and 
heets.
Note: If you add any layers or classes you will also need to add those layers
classes to the desired sheets. Otherwise they will not appear in the s

Sheets Pop-Up 
for selecting 
sheets

Used to reassign 
an object’s layer 
and class

Layer Pulldown 
for switching the 
active layer

Class Pulldown 
for switching the 
active class
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This module combines many tools and techniques to create a small house in VectorWorks.  Although this 
module is architectually based, it can be performed by any VectorWorks user.  It shows concepts that apply 
to all disciplines and provides a concept that most users can relate to.

The structure of the exercises in the Level 1 Module is that all of the provided exercises are based on the 
2D Drafting Plan which you will create. You must complete the 2D Drafting Plan exercise before moving 
on to other exersises in this module.  Other exercises can then be completed in any order.

In this module you will design a  simple 4 room house.  You will then calculate the amount of concrete 
needed to pour the concrete slab, calculate the amount of paint needed to paint the interior walls, count the 
number of windows and doors and create detailed reports and schedules based on generated data.  You will 
then transform your design into a high powered presentation. 

Level 1 Module - 2D House Exercises
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In this Exercise

• AEC Setup 
Assistant

• Foundation 
Plan

• Floor Plan

• Roof Plan

• Front 
Elevation

• Annotations

• Dimensions

• Revising Your 
Drawing
In this exercise we will build a simple house with fou
rooms over a crawl space. We will produce a 
Foundation Plan, a Floor Plan, a Roof Plan, and a Fr
Elevation. The completed file is located in Learning 
Exercises in your VectorWorks Toolkit folder and is 
entitled 2D_House_Sample.mcd. It may be used as 
reference while drawing.

SET UP

It is important to set up your drawing before beginnin
to draw. The AEC Setup Assistant will create all the 
necessary layers and classes needed to follow the 
instructions in this exercise. Although we do not use 
the layers and classes provided while performing thi
exercise, they are there for future use.

1. Select New from the File Menu.

2. Click the Use Document Template  radio button.

3. Select the AEC Setup Assistant.sta  template from the 
New dialog.

4. From the File menu, select Workspaces  and then 
AEC.

5. Select AEC Project Setup  from the AEC menu.

The AEC Setup Assitant dialog appears.

6. Click Yes.

By clicking Yes, you are given full instructions for eac
step as you proceed through the setup. Once familia
with the setup process, click the No button to skip the
instructions during future sessions.

7. Enter the criteria as detailed below:
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For Step 1, enter 1 for Number of Floors. Accept all other defaults. 

Accept the defaults for Step 2. 

For Step 3, change the printable area from US Arch D to US Arch C . 

Accept the defaults for Step 4. 

For Step 5, select Foundation Plan , Resid Floor Plan , and Roof Plan . 

For Step 6, enter 10’0"  in the Roof field, -6’0"  in the Foundation field, 
1’0"  in the Typical Slab Thickness field, select the Platform Framing  
checkbox, and 10’0"  in the Clg Ht AFF field. Accept all other defaults. 

Accept the defaults for Step 7. 

For Step 8, select Elevations . Enter 1 in the Qty field and 1/4 in the scale 
field.

For Step 9, select Title block along the bottom . Accept all other 
defaults.

In the Go Back dialog, click OK.

You end up with a drawing file that uses feet and inches as the unit an
in a 1/4 inch scale. It has also added a variety of layers, classes and s
(Foundation Plan, Resid Floor Plan, and Roof Plan). You are now read
draw.

8. Browse the different sheets provided using the View bar.

You can look at the sheet’s information using the Edit Sheet option. 
Notice that some of the visibility settings for the classes and layers ar
different.

9. Click Fit to Window on the View bar.

10. From the Palettes menu, select Constraints .

Sheets Menu
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11. Click each of the following constraint buttons: Snap to Objects , Snap to 
Grid , Constrain Angle , Snap to Intersection , and Smart Points  as 
shown.

12. From the Palettes menu, select Resources .

13. Using the file tree locate the file 2D_House_Sample.mcd  in the Learning 
Exercises folder in Toolkit. Select it and press the Enter button  on the 
Resources palette.

14. From the Show  pulldown, select Symbols .

15. Select all of the listed symbols and click Import .

16. From the Palettes menu, open Walls, Dimensioning, Editing, Object 
Info,  and LE House Wall Styles .

If any of the palettes are already open, there is no need to open them
again. You may move palettes by clicking on the title bar and moving 
them to the desired location.

17. Select Save As  from the File menu and name the file 2Dhouse.mcd .

FOUNDATION PLAN

In the Foundation Plan you draw the necessary structural elements to
support the house. You will also find out how to get the square footag
the slab.

1. Select the sheet entitled Foundation Plan .

Symbol Icon

Foundation 
Plan Sheet
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lan. 
Notice that the sheet is displayed and its title block says Foundation P
You are also placed in the Mod-Foundation layer.

Draw the Footings

1. From the Classes pulldown, select Structural-Footings .

Mod-Foundation Layer

Foundation Sheet
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2. Click the Wall tool .

3. Click the Top Control Line  mode button.

4. Click Footings 20in. from the LE House Wall Styles palette.

This wall style draws a 20" wide footing.

5. Using the values on the rulers, click the mouse to start drawing your wall 
at -40’0"  on the horizontal ruler and 20’0"  on the vertical ruler. 

-40’0" (X) and 20’0" (Y) will show in the Data Display Bar.

6. Press the Tab key until the L (length) field is highlighted. Enter 30’10" into 
the field and press the Enter key. Move the cursor to the right until you see 
the cue Horizontal/ Length and click to set the wall.

Footings
20in.

Wall Tool

Cursor 
Location

Tip:  It is always a 
good idea to draw 
clockwise.

Enter the desired length in the L (Length) 
field and press the Enter key to set.
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7. Tab into the L field and enter 24’10" . This time, after you press Enter, 
move the mouse downwards and click when the Vertical/Length cue 
appears.

8. Drag the mouse up to the start point of the first footing. When the cue 
Point appears, move the mouse down so that a dashed line appears 
displaying the Align H cue. Move the mouse back down so that the footing 
is once again horizontal and you get the Horizontal/ Align H cue. Click 
once to set the footing.

9. Draw a vertical wall up toward the beginning of the top horizontal footing 
until the Point  cue appears and click.

The Point cue appears when you are over the exact point at which yo
started that line and tells you that the footings will be joined correctly.
This completes your rectangle of foundation footings.

Click the Tab key until you highlight the L (length) 
field. Enter 24’10" and click the Enter key.
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10. With all four walls still selected, enter -10"  in the delta Z field of the Object 
Info. palette.

This drops the walls 10" below the ground plane. Your drawing opera
is now complete for foundation footings.

11. Click the 2D Selection tool  to deactivate the wall style tool.

12. Select Save.

Walls

1. Select the Wall-Ext-Masonry  class from the Classes pulldown in the 
Data Display bar.

2. Click the Wall  tool.

3. Click the Center Control Line  mode button which is the second mode 
button.

4. Click the Wall Prerefences  button on the mode bar.

The Wall Preferences dialog appears.

5. Uncheck Auto Join .

6. Click OK.

7. Click Block 10in. from the LE House Wall Styles palette.

8. Move the cursor to the upper left intersection of the foundation footings 
until you see the Corner cue and click.

Block 
10in.
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9. Click at each wall corner until you reach the original Corner cue to 
complete the foundation walls.

10. Click the Wall  tool.

11. Click the Wall Prerefences  button on the mode bar.

12. Check Auto Join .

13. Click OK.

14. Select the 2D Selection tool  to deactivate the Wall tool.

15. Select Save.

Create the Slab

1. With the four walls just drawn still selected, select Combine Into Surface  
from the Tool menu. 

2. Place the paint bucket cursor into the middle of the four walls and click.

A solid white polygon is created. 

3. Right-click (Windows) or Control-click (Macintosh) anywhere in the 
drawing area to invoke the Edit menu and select Deselect All .
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4. Click only on the just created polygon.

5. From the Object Info palette, select the Class pulldown then select 
Structural-Slab .

This changes the class the polygon is in. Choosing a class or layer fr
the Object Info palette changes the layer or class an Object is in . 
Choosing a layer or class from the pulldowns on the Data Display bar
changes the layers or class that you are currently viewing and drawing 
in . This polygon represents the slab.

FLOOR PLAN

In the floor plan you create all the information necessary to build a sin
floor of a building. We will now use the offset tool to create the first flo
perimeter

1. With the polygon still selected, click the Offset  tool from the Editing 
palette.

2. Click the Offset Preference  button.

3. Enter 10"  in the Offset field then click OK.

4. Click anywhere outside of the polygon. 

A new polygon that is 10" wider is created.

Offset 
Tool
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5. With the polygon still selected, click the Class pulldown and select None  
in the Object Info. palette.

6. From the Edit menu, select Cut .

This removes the polygon from the drawing and places it in the clipbo

7. Select the Resid FloorPlan-1  sheet. 

You are placed in the Mod-Floor-1 layer. The sheet is displayed and i
title block shows FloorPlan-1.

8. Select the Mod-Slab-1  layer from the Layers pulldown in the Data Display 
bar.

9. Select Paste in Place  from the Edit menu.

The polygon is pasted in exactly the same location on the Resid 
FloorPlan-1 Sheet as it was on the Foundation Plan sheet.

10. From the Model menu, select Floor .

11. Enter -12"  for the bottom Z and 12"  for the thickness.

12. Click OK.

A floor is created from the polygon according to your specifications.

Draw the walls

Exterior

1. Select the Mod-Floor-1 layer from the Layers pulldown in the Data 
Display bar.

2. Click the Wall tool .

3. Select the Top Control Line  mode which is the first mode button.

4. Select the Stud 2x6 Wood  wall style.
Stud 2x6 
Wood
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5. Trace the polygon by clicking at each corner where the Point  cue 
appears.

6. Click the 2D Selection  tool to deactivate the Wall Style tool.

7. Select Save.

Interior

8. Click the Wall  tool.

9. Click Center Control Line  mode.

10. Select the Stud 2x4 Wood  wall style.

11. Bring the cursor near the right hand vertical wall until the wall is 
highlighted. Use the SmartCursor to find the Center  cue and thus the 
center of the wall and click.

12. Using the L (length) data display bar field, draw a wall 14’6.5’’  long from 
the wall into the house.

13. Draw a vertical wall upwards until the top horizontal wall is highlighted and 
click.

Stud 2x4 
Wood
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The highlight signifies that the walls will join correctly. Also note the 
Object/Vertical cue.

14. Click the Wall  Join Tool . Make sure that the Standard Wall Join mode is 
on in the Mode bar. Click anywhere on the interior vertical wall and drag 
towards the bottom exterior wall until it is highlighted and click. Notice that 
a feedback segment is shown.

Wall Join 
Tool
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The short vertical wall is extended the full width of the house and is 
joined correctly at top and bottom. The interior connection has been 
changed and needs to be joined. 

15. Click the Wall Join Tool  and drag from the interior vertical wall to the 
interior horizontal wall.

The intersection that was broken is cleaned up.

16. Click the Stud 2x4 Wood  wall style.

17. Bring the cursor near the horizontal interior wall until the wall is 
highlighted. Use the SmartCursor to find the Center  cue and thus the 
center of the wall and click

With the Wall Join 
tool, click on the 
interior horizontal 
wall and then drag 
to the interior 
vertical wall.

The intersection is 
cleaned up.
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18. Using the Vertical cue, draw a vertical wall to the top exterior wall.

19. Click the 2D Selection tool  to deactivate the Wall Style tool.

20. Select Save.

Add Doors And Windows

1. Click the 2D Selection tool and ensure that Enable Wall Insertion  mode 
is on in the Data Display bar.

2. From the Resource  palette, select the file 2Dhouse.mcd (this file) from 
the bottom of the file tree list.

3. Click the Entrance Door 1  symbol.

The symbol appears in lower right window of the Resource palette.

4. Click the Select  button.
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Notice that a representation of the door is shown in the lower left wind
This indicates that the symbol is now active and ready to be placed in 
drawing.

5. Click the Symbol  tool.

As you bring the cursor into the drawing area an outline of the selecte
symbol appears, becoming part of the cursor.

6. Change the insertion point to Center , the 2nd symbol insertion mode 
button.

7. Move the cursor along the bottom exterior wall of the room to the left. 
When the Center  cue appears, click.

The symbol is placed and can now be oriented.

8. Orient the symbol so that the arc faces the left ruler and click.

This creates a left handed inward swinging door.

9. Move the cursor away from the wall to see the inserted symbol.

10. Choose the Interior Door 1 symbol from the Resource Palette and make 
it active.

2D Symbol 
Insertion Tool
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11. Place it at the Center  of the horizontal interior wall of the room to the right 
as a left hand inward swinging door.

12. Using this same symbol place a door at the Center  of the bottom vertical 
interior wall as a right hand inward swinging door.

13. Select the Simple Window  Plug-In tool from the AEC palette.

14. Click on the Simple Window Preferences  button in the mode bar.

15. Enter the parameters exactly as shown in the picture below.

16. Click OK.

Simple 
Window

Config: Double Hung

Width: 3’0"

Height: 4’0"

Elevation: 2’8"

Offset: 0"

Casing Face: 2"

Casing Depth: 5"

Use Wall Depth: leave unchecked

Sash Thk: 2"

Draw WallLines: leave unchecked

Has Sill: leave unchecked

Has Trim 1: leave unchecked

Has Trim 2: leave unchecked

Draw 3D Detail: leave checked

Num H Mullions: 2

Num V Mullions: 2

Trim: None

Mullions: None

Glazing: Style-Glazing 2
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17. Place the window on screen by double clicking on a blank area in the 
drawing.

18. With the newly created window selected, select Create Symbol  from the 
Organize menu. 

19. In the dialog that appears, name the symbol Window Unit . Use the 
defaults for the rest of the symbol creation options.

20. Click OK.

21. In the Resource palette select the new window symbol and make it active.

22. Click the Symbol Insertion Tool .

23. On the bottom exterior wall to the right of the door, locate the Center  cue 
and click twice.

The first click sets the location and the second the orientation. 

Note: VectorWorks has redefined the center caused by the break in the wal
where the door was placed.

Front View Top View
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24. Continue to place the windows, centered, for as many as shown in the 
illustration.

25. Select Save.

ROOF PLAN

There are many types of roofs and methods to place them. We will cr
a gable roof from the walls already in your drawing.

1. Use Marquee selection to select all the walls.

2. Select Create Roof from Walls  from the AEC menu. 

The Create Roof dialog appears.

3. Enter 18"  in the Eave Overhang  field. Enter 0"  in the Bearing Height  
field.

4. Click the Vertical  radio button at the top of the Eave Profile section.

5. Enter 12" in the Thickness  field
2-18 Learning Exercises Manual
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6. Enter Mod-Roof  in the Layer Name field..

7. Click OK.

The roof is placed in the Mod-Roof layer upon creation and this layer
now the active layer.

Note: In order for the roof to be created properly, all walls must be joined 
correctly.

8. Select the roof.

9. Place the cursor over the right selection handle until a hand cursor 
appears and click.

Click Here
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The Edit Roof dialog appears.

10. Click Gable End  in the Edit Roof Settings dialog

11. Enter 3"  in the eave overhang field.

12. Click OK.

The hip roof section right is made into a gable with a 3" overhang.

13. Select Save.

FRONT ELEVATION

Elevations are orthographic projections which show one side of your 
design. The design should be as complete as possible before you cre
elevations. We will create a Front Elevation, although elevations can b
created from any view.

1. Select the Elevations-1  sheet. 
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You are placed in the Mod-Elevation-1 layer. The title block shows 
Elevation-1.

2. Select Create Layer Link  from the View menu and choose the Mod-
Floor-1, Mod-Slab-1, and Mod-Roof layers.

3. Click OK on Windows/ Link  on the Macintosh.

4. Select Front  from Standard Views in the View menu.

The elevation (in wireframe) is displayed.

5. Select the Roof Plan  sheet.

6. Switch to the Mod-Roof  layer.

7. Place the cursor over the left selection handle on the roof until a hand 
cursor appears and click.

8. Click Gable End  in the Edit Roof Settings dialog

9. Enter 3" in the eave overhang.

10. Click OK.

11. Switch to the Elevations-1  sheet to view your change.
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Editing the Elevation

12. Marquee select everything on the Elevation sheet.

13. Select Convert Copy to Lines  from the Tool menu.

14. Select Hidden Line Rendering .

15. Click OK.

16. Select Right  from Standard Views in the View menu.

Move the Front Elevation over to the left if necessary, to see both ima
clearly. To do this, click and drag the Elevation to one side.

17. Marquee select the Side Elevation view of the house.

18. Select Unlock from the Edit menu.

19. Select Convert to Lines from the Tool menu.

20. Select Hidden Line Rendering .

21. Click OK.

The unlocked layer link will be converted into a grouped set of lines. Th
can be ungrouped and then manipulated as individual pieces.
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22. Select Top/Plan  from Standard Views in the View menu.

23. Select Sheet-Elevation-1  from the Layers menu.

24. Select Level Marker  from Create Markers in the AEC menu.

25. Enter Finished Floor  in the Level Name field and 100’-0"  in the Elevation 
field.
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26. Place the Level Marker as shown.

27. Select Reference Marker  from Create Markers in the AEC menu.

Click on the point you want to start 
the marker. Drag to and click on the 
point you want to end the marker.
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28. Enter Side Elevation  in the Drawing Title field, 2 in the Reference # field, 
and A2 in the Reference Page # field. The program automatically senses 
the Drawing Scale and enters it for you.

29. Place the Reference Marker as shown.

30. Select Save.

Click on the point where you 
want to place your marker.
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ANNOTATIONS AND DIMENSIONS

For this exercise we place annotations, dimensions and finishes last.
ensures a clean process for creating the plans in this exercise.

Annotations

1. Select the Resid Floor Plan-1  sheet.

2. Select Sheet-FloorPlan-1  from the Layers pulldown in the Data Display 
bar.

3. Select Room Name  from Create Markers in the AEC menu.

Use this command to create the names for each room.

4. Enter Living Room  in the Room field.

5. Click OK.

6. With the bulls eye cursor, click in center of the Living Room to place the 
name.
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7. Finish naming each room using the Room Name command as shown 
below.

Note: General notes are added using the Text tool.

Dimensions

1. Open the Dimensioning  palette .

2. Click the Constrained Linear Dimensioning Tool.

3. Click the Constrained Chain Dimension  mode, which is the second 
mode button.

4. Move the cursor towards the lower left corner of the exterior walls and 
when the Point  cue appears, click.

Constrained Line 
Dimensioning 
Tool
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5. Trace the wall segment to the center of the first window where the Locus  
cue appears and click.

6. Move the cursor down and away from the wall until delta Y is about -4 feet 
and click.

7. Click on the Locus  cue for the center of each window and door along that 
wall to dimension.

8. At the end of the wall double-click to end the chain dimension.

Repeat for the other walls, if desired.
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Note: Dimensions are placed in the dimension class by the program.

REVISING YOUR DESIGN

A design is rarely perfect the first try. It is important to know how to go
back and modify what you’ve done. Here we will make some 
modifications to our interior walls, add some kitchen appliances and p
in a skylight.

Move An Interior Wall

1. Switch to the Mod-Floor-1  layer from the Layers pulldown in the Data 
Display bar.

2. Click the 2D Selection tool and ensure that Enable Interactive Scaling  
mode is on in the Data Display bar.

3. Click the vertical wall that separates the living room from the bedroom.

4. Click on the handle at the top of the wall and drag the wall down and just 
past the horizontal interior wall.

5. Click the Wall Join tool to join the interior vertical wall to the interior 
horizontal wall.
Learning Exercises Manual 2-29



Revising Your Design
2D Drafting Plan
6. Click anywhere on the interior vertical wall and drag towards the interior 
horizontal wall until it’s highlighted and click.

7. Select the Wall Heal  tool.

The Wall Heal tool cleans up old intersections and unjoins walls.

8. Drag a marquee around the open area along the top exterior horizontal 
wall.

Wall Heal Tool

With the Heal Wall tool, 
drag a marquee around 
the open area in the 
wall.
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Adding Kitchen Symbols

1. In the Resources palette, select the Kitchen Cabinet Unit  symbol and 
make it active.

2. Click the 2D Symbol Insertion tool .

3. Click on the drawing area near the corner of the Kitchen.

4. Click the 2D Selection tool .

5. If on, deselect the Enable Wall Insertion Mode .

6. Click on the upper right corner of the Kitchen Cabinet Unit symbol and 
drag the symbol to the upper inside corner of the kitchen. Release when 
the Point  cue appears.

Click and drag the symbol to the 
desired location. Uses the cues to 
help snap the symbol into place.
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7. Select the Stove  symbol from the Resource Palette and make it active.

8. Click the 2D Symbol Insertion tool .

9. Double click on the drawing area near the Kitchen Cabinet Unit symbol.

This places an instance of the symbol on screen

10. Click the 2D Selection tool .

11. Drag the Stove symbol to the provided locus point.

12. Select the Kitchen Sink  symbol from the Resource Palette and make it 
active.

13. Click the 2D Symbol Insertion tool .

14. Click on the drawing area near the Kitchen Cabinet Unit symbol.

15. Rotate the Kitchen Sink symbol until it faces left. Click to set the symbol’s 
direction.

Provided Locus Point

Click to insert the symbol. 
Rotate the symbol into the 
desired position and click again 
to set.
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16. Click the 2D Selection tool .

17. Drag the symbol as shown to the provided locus point.

18. Select the Refrigerator  symbol in the Resource Palette and make it 
active.

19. Click the 2D Symbol Insertion tool .

20. Double click on the drawing area near the Kitchen Cabinet Unit symbol to 
place.

21. Drag the symbol as shown to the provided locus point.

22. Select the Kitchen Cabinet Unit  symbol in your drawing.

23. Select Send to Back  from Send in the Tool menu.
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24. Select Save.

Adding a Skylight

1. Select the Roof Plan  sheet.

You are now in the Mod-Roof layer.

2. In the Resources palette, select the Skylight  symbol.

3. Insert the skylight symbol on the rear of the building’s roof (center toward 
the edge of the roof) as shown.

The Edit Roof Element dialog appears.

4. Click the Edit  Skylight  radio button.

5. Enter 13’0"  in the Offset from Corner field.

Symbol being 
placed.
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6. Enter 5’0" in the Offset from Building Line field.

7. Click OK.

The skylight opening is created in the roof.

CONCLUSION

Congratulations! You have completed a 2D design in VectorWorks. 
Throughout this exercise you have used a combination of tools and 
techniques. Although this was an architecturally based exercise, you 
use these same tools and techniques and apply them to any drawing
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The remainder of this module contains exercises which will use and b
upon the work you have done to complete this exercise.
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In this Exercise

• Creating a 
Worksheet

• Estimating 
Cement Needed

• Estimating Paint 
Needed

• Estimating Totals

• Placing a 
Worksheet on the 
Drawing
In this example we will create a worksheet which use
VectorWorks’s spreadsheet capabilities. We will 
determine how many cubic yards of concrete are 
needed to pour the slab and how many gallons of pa
are needed to paint the interior of the house. The 
completed file is located in Learning Exercises and i
entitled Spreadsheet_Sample.mcd. It may be used a
reference while drawing.

SETUP

Since we are using the file created in the 2D Drafting
exercise we do not need use the Setup Assistant. Th
are a few procedures we still need to do though.

1. Open 2D_House_Sample.mcd  from the Learning 
Exercises folder in your VectorWorks Toolkit.

2. Select Fit to Window .

3. Select Save As and name the file Spreadsheet.mcd .

4. Select Sheet-FloorPlan-1  from the Layer pulldown in 
the Data Display bar.

CREATE THE WORKSHEET

We will create a worksheet that can then be formatte
to obtain the desired results.

1. Select Resources  from the Palettes menu.

2. Click the New button located on the right side of the 
palette.
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The Create Resource dialog box appears.

3. Click the Worksheet  radio button.

4. Click Create .

The Create Worksheet dialog box appears.

5. Enter Example Worksheet  for the name of the worksheet. Accept the 
default settings for the number of Rows and Columns for the worksheet.

6. Click OK.

Your new blank worksheet and the worksheet dialog box appears in t
Drawing Area.

You can now assign names and functions to your columns, as well as
select whether you want individual rows to be spreadsheet or databa
rows.

7. Select Save.
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FORMAT COLUMNS AND ROWS

Once the worksheet is created you need to format the rows and colum
that you have created. It is at this time that you make the worksheet l
like you want, including adding headers to the columns and rows. 
VectorWorks worksheets are similar to Microsoft® Excel spreadsheet
when considering formatting rows, columns and cells. The cell is sele
by clicking, but data can only be entered in the Worksheet Entry dialo
box.

1. Click Column A, Cell 1 (A1).

2. In the Worksheet Entry dialog box enter Item .

3. Click the check mark  on the Worksheet Entry dialog box to confirm.

4. Click B1 and enter Area . Click the check mark.

5. Click C1 and enter Factor . Click the check mark. 

6. Click D1 and enter Extension . Click the check mark. 

7. Click E1 and enter Paint . Click the check mark. 

All of your headers are now added.

8. Click A1 and drag to E1 to select all five cells.

9. Select Style  then Bold  from the Text menu.

This simultaneously formats all five cells to have a bold type face.

Tip:  If you make a 
mistake while entering 
data into the Worksheet 
Entry dialog box, click 
the X button to erase it.
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10. With the cells still highlighted, click the down arrow button at the top left 
corner of the worksheet window. This brings up the Worksheet Menu. 
Select Alignment .

11. Click Center .

12. Click OK.

13. With the cells still highlighted, select Border  from the Worksheet Menu.

14. Click Bottom .

15. Click OK.

16. Select Save.

ESTIMATING CONCRETE NEEDED

There are many ways to calculate data in VectorWorks worksheets. T
calculate the amount of concrete needed to pour the slab of our four r
house, you will use a combination of spreadsheet capabilities.

Note: All formulas must begin with the equals sign (=).

1. Click A3 and enter Basement Slab . Click the check mark.

2. Click B3 and enter = in the Worksheet Entry dialog box.

Worksheet Menu
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The equal sign indicates the beginning of a formula which VectorWork
will use to calculate the result instead of entered text.

3. Select Paste Function  from the Worksheet Menu.

4. Select Area .

5. Click Done .

The Worksheet Entry dialog box is now updated to show the Area 
function.

6. Select Paste Criteria  from the Worksheet Menu.

7. Select Kind /is /Polygon  from the 3 pulldown menus.

8. Click More Choices .

9. Select Layer /is /Mod-Foundation .
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10. Click OK.

11. Click at the end of the formula in the Worksheet Entry dialog box and 
enter /144.

We divide by 144 to represent square feet instead of square inches.

12. Click the check mark.

The Area function calculates the total area of all polygon objects in th
Foundation layer and places it in the cell.

13. With the cell still selected, select Number  from the Worksheet Menu.

14. Click Decimal .

15. Enter 2 in Dec. and [space key]sq ft  in Trailer.

This does not change the value in the cell. It instead modifies the way
information in the cell is displayed.

16. Click OK.

17. Click C3 and enter 4" . Click the check mark.

The quotation indicates inches. This is the thickness of your slab.

18. With the cell still selected, select Number  from the Worksheet Menu.
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19. Click Decimal .

20. Enter 2 in Dec. and [space key]ft  in Trailer.

21. Click OK.

22. Click D3 and enter = B3*C3/9.

After typing in the equals sign (=), you can simply click in the cell that
you want to add to the equation rather than typing in the dialog box.

23. Click the check mark.

The value of cubic yards of concrete needed to pour the slab is place
cell D3.

24. With the cell still highlighted, select Number  from the Worksheet Menu.

25. Click Decimal .

26. Enter 2 in Dec. and [space key]cu yd  in Trailer.

27. Click OK.

28. Select Save.

ESTIMATING PAINT NEEDED

We can estimate the amount of paint in gallons that is needed to pain
of the interior walls of our house using similar worksheet functions.

Estimating The Exterior Walls

1. Click A5 and enter Exterior Walls . Click the check mark.

2. Click B5 and enter = in the Worksheet Entry dialog box.

3. From the Worksheet Menu select Paste Function .

4. Select Length .

5. Click Done .

6. From the Worksheet Menu select Paste Criteria  and select Class is 
Wall-Ext-Frame .
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7. Click More Choices .

8. Select Layer/ is/ Mod-Floor-1 .

9. Click OK.

10. Enter /12 after the formula that appears. Click the check mark.

We divide by 12 to represent feet and inches instead of inches only.

11. With the cell still selected, select Number  from the Worksheet Menu.

12. Click Decimal .

13. Enter 2 in Dec. and [space key]lin ft  in Trailer.

14. Click OK.

15. Click C5 and enter 10’.Click the check mark.

This is the height of all exterior walls.

16. With the cell still selected, select Number  from the Worksheet Menu.

17. Click Decimal .

18. Enter 2 in Dec. and [space key]ft  in Trailer.

19. Click OK.

20. Click D5 and enter =B5*C5. Click the check mark.

This is the total linear length of all walls times the height which will yie
the square footage.

21. With the cell still highlighted, select Number  from the Worksheet Menu.

22. Click Decimal .

23. Enter 2 in Dec. and [space key]sq ft  in Trailer.

24. Click OK.

25. Click E5 and enter =D5/250. Click the check mark.

250 is the estimated coverage in square feet of one gallon of paint. T
formula divides your square footage referenced by cell D5 by the 
coverage.

26. With the cell still highlighted, select Number  from the Worksheet Menu.

27. Click Decimal .

28. Enter 2 in Dec. and [space key]gal  in Trailer.

29. Click OK.
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Estimating the Interior Walls

1. Click A7 and enter Interior Walls . Click the check mark.

2. Click B7 and enter = in the Worksheet Entry dialog box.

3. From the Worksheet Menu select Paste Function .

4. Select Length .

5. From the Worksheet Menu select Paste Criteria  and select Class is 
Wall-Int-Full .

6. Click More Choices .

7. Select Layer/ is/ Mod-Floor-1 .

8. Click OK.

9. Click at the end of the formula and enter *2/12 in the Worksheet Entry 
dialog box. Click the check mark.

Each interior wall has two sides so the value of linear length is multipl
by 2. We divide by 12 to represent feet and inches instead of inches o

10. With the cell still selected, select Number  from the Worksheet Menu.

11. Click Decimal .

12. Enter 2 in Dec. and [space key]lin ft  in Trailer.

13. Click OK.

14. Click C7 and enter 10'. Click the check mark.

This is the height of all the interior walls.

15. With the cell still selected, select Number  from the Worksheet Menu.

16. Click Decimal .

17. Enter 2 in Dec. and [space key]ft  in Trailer.

18. Click OK.

19. Click D7 and enter =B7*C7. Click the check mark.

20. With the cell still highlighted, select Number  from the Worksheet Menu.

21. Click Decimal .

22. Enter 2 in Dec. and [space key]sq ft  in Trailer.
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23. Click OK.

24. Click E7 and enter =D7/250. Click the check mark.

25. With the cell still highlighted, select Number  from the Worksheet Menu.

26. Click Decimal .

27. Enter 2 in Dec. and [space key]gal  in Trailer.

28. Click OK.

FINDING ESTIMATE TOTALS

Using the information gathered earlier, we can find the total estimated
amount of painted need for our house.

1. Click A9 and enter Total . Click the check mark.

2. Click E9 and enter =E5+E7. Click the check mark.

3. With the cell still highlighted, select Number  from the Worksheet Menu.

4. Click Decimal .

5. Enter 2 in Dec. and [space key]gal  in Trailer.
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6. Click OK

7. Click D9 and enter =D5+D7. Click the check mark.

8. With the cell still highlighted, select Number  from the Worksheet Menu.

9. Click Decimal .

10. Enter 2 in Dec. and [space key]sq ft  in Trailer.

11. Click OK.

12. Select Save.

PLACING ON THE DRAWING

When your worksheet is complete you can place it on your drawing a
object. It can then be moved about just like any other object can be.
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1. Close the Example Worksheet by clicking on the close box.

2. In the Resources Palette, click Example Worksheet .

3. Click the On Drawing  checkbox.

The worksheet is placed on the drawing as an object.

4. Click on the object and move it to the bottom right corner of the drawing 
area.

5. Select Save.

Click the Close box.
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In this Exercise

• Creating List 
Reports

• Creating 
Schedule Reports

• Recalculating 
Database record 
information
In this example we will create a worksheet which use
VectorWorks’s database capabilities. We will create a
list of symbols, attach database record information a
create a schedule. The completed file is located in 
Learning Exercises and is entitled 
Database_Sample.mcd. It may be used as a referen
while drawing.

SETUP

Since we are using the file created in the 2D Drafting
exercise we do not need to run the Setup Assistant. 
There are a few procedures we still need to do thoug

1. Open 2D_House_Sample.mcd  from the Learning 
Exercises folder in your VectorWorks Toolkit.

2. Select Fit to Window .

3. Select Save As and name the file Database.mcd .

4. From the Layers pulldown, select Sheet-FloorPlan-1 .

5. From the Palettes menu, open Object Info , 
Resources , and AEC 2D Tools .

CREATE A LIST REPORT

We will create a worksheet that can then be formatte
to obtain the desired results.

1. Select Create Report  from the Organize menu.

2. Enter List Report  for the title.

3. Select Symbols  in the List All pop-up.
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4. Click Summarize Items With the Same:. The Symbol Name item in the 
pulldown list should already be selected.

5. Click OK.

Your new worksheet appears in the Drawing Area. All the symbols ar
listed and the total quantity for each is displayed. The symbols are lis
for the entire drawing not just the ones that you see in the Floor Plan
sheet.
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Modify the List Report

1. Click the Zoom In Tool .

2. Drag a marquee around the bathroom and kitchen area.

3. From the Resource palette, locate the file Database.mcd  (this one) from 
the file tree.

4. Select the symbol Window 2  and click the Select button to make it active.

5. Select Mod-Floor-1  from the Layer pulldown in the Data Display bar.

6. Click the 2D Symbol Insertion Tool .

7. Using the Center cue, place the symbol into the bathroom’s top exterior 
wall.

Using the Center cue, place 
the symbol in the wall.
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8. Select Recalculate  from the Worksheet menu.

Window 2 is now added to the worksheet with the value 1.

Note: To get an itemized (not summarized) list, click in row 2 and then drag
Sum  icon in cell A onto the bar where the other icons are. Move it back
cell A to summarize the list again.

9. Select Save.

Sum Icon
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CREATE A SCHEDULE

You can create a variety of schedules that use the objects you have al
created. By attaching database data to objects you can keep an accu
and up to date record of them.

Create an Equipment Schedule

All schedules in the Create Schedule menu are created similarly (exc
the Room Schedule).

1. Close the List Report worksheet.

2. Select Create Record  from the AEC Menu.

The Create Record dialog appears.

3. Select Equipment Record  from the pulldown list.

4. Click OK.

An alert dialog appears informing you that the Equipment Record has
been created. Click OK to continue.

5. Click the 2D Selection Tool .

6. Click on the Stove symbol in the kitchen.

7. In the Object Info palette, click the Data Tab.

8. Click the checkbox next to Equipment Record .

This automatically attaches that record to the stove symbol.

9. Click the item field called Description in the list and in the data entry area, 
enter Stove .

Data 
Entry 
Area
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10. Continue filling out each field as listed below:

11. From the AEC 2D Tools palette, click the ID tool.

12. Click below the stove to place the marker.

Manuf./Supplier: Acme

Stock #: 12345

Size: 22 7/8"D. X 30 1/8"W.

Wattage: -

Amperage: -

Gas: 1/2"

Water: -

Sewer: -

Accessories: -

Remarks: - Data Entry Area

ID Tool

Click Here
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13. Click on the Stove .

The ID Label dialog appears.

14. Select Equipment  from the ID Type pulldown. Enter EQ in the Prefix field 
and 1 in the Label field. Leave the Suffix field empty.

15. Click OK.

The ID Marker is updated.
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16. Click Fit to Window  on the View Bar.

17. Select Create Schedule  from the AEC Menu.

The Create Schedule dialog appears.

18. Select Equipment Schedule  from the pulldown list.

19. Click OK.

20. Click on the drawing (as indicated in graphic) to place the schedule on the 
drawing.

Click on drawing to place 
the schedule.
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The location of your click represents the top left corner of the schedu
placed on the drawing.

21. Close the floating worksheet.

By closing the worksheet, the on drawing schedule will switch from 
showing a large X to showing the information from the worksheet.

Creating a Room Schedule

This method for creating a Room schedule is slightly different than ot
schedules since it represents an area and not an object.

1. Click the Room ID  tool.

2. Click below the Living Room text to place the marker.

The Room Finish ID Label dialog appears.

3. Enter 101 in the Label field. Leave the other fields empty.

4. Click OK.

5. In the Object Info palette, click the Data Tab.

The record Room Finish Record  is already attached to the ID.

6. Click the Room Name field in the list and in the data entry area, enter 
Living Room .

Schedule on drawing with worksheet open.

Schedule on drawing with worksheet closed.

Room ID Tool
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Note: We have pre-filled the information for the other rooms in this file. This
will give you an idea of how the entire schedule would typically look.

7. Continue filling out each field as shown.

8. From the AEC Menu, select Create Schedule .

9. In the Create Schedules dialog box, select Rm Finish Schedule  from the 
pulldown list.

10. Click OK.

11. Click under the Equipment Schedule to place.

Floor Finish: Carpet

Base Material: Wood

North Wall Finish: Gyp. Bd.

East Wall Finish: Gyp. Bd.

South Wall Finish: Gyp. Bd.

West Wall Finish: Gyp. Bd.

Ceiling Material: Gyp. Bd.

Ceiling Height: 10’-0"

Remarks: -
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12. Close the floating worksheet.

Modify Your Schedules

After you’ve created you schedules you may want to change objects 
your drawing or the record data associated with them. Once recalcula
the worksheet will display the correct new information.

Removing A Database Record Field From Your Worksheet.

1. In the Resource palette, highlight the Equipment Schedule .

2. Click the Open  button.

3. Scroll over to column K and click the K cell.

The entire column is highlighted.
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4. Click on the worksheet menu and select Delete .

The original K column is deleted and the L column is moved into it’s 
place.

5. Close the floating worksheet.

Click on the K in the column header.
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1. From the Resource palette, highlight Rm Finish Schedule .

2. Click the Open  button.

3. Click the 2D Selection Tool .

4. Click the Living Room ID  marker.

5. Click the Data Tab  in the Object Info. palette.

6. Highlight the Floor Finish  field.

7. Change the info. in the data entry field to Wood .

8. From the Worksheet menu, select Recalculate .
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The worksheet is updated with the correct values.

9. Close the worksheet.
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In this Exercise

• Creating a Sheet

• Setting a 3D View

• Walkthough

• Adding Light

• Creating an 
Orbital Animation

• Create an Along 
Path Animation
In this example we will perform the steps necessary 
create a variety of ways to present your project to yo
client. We will create a sheet with a 3D view, render, 
and animate your drawing. The completed file is 
located in Learning Exercises and is entitled 
Presentation_Sample.mcd. It may be used as a 
reference while drawing.

SETUP

Since we are using the file created in the 2D Drafting
exercise we do not need to run the Setup Assistant. 
There are a few procedures we still need to do thoug

1. Open 2D_House_Sample.mcd  from the 
Learning_Exercises folder.

2. Select Fit to Window .

3. Select Save As and name the file Presentation.mcd .

4. From the Palettes menu, open 3D Tools  and the 
Object Info. palettes.

CREATE A SHEET

We will create a sheet that contains a rendered 3D vie

1. Select Layer Options then Active Only  from the 
Organize menu.

2. From the View menu, select Set 3D View .

3. Click in the upper left corner area of the living room.
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4. Click the upper right corner of the kitchen.

The Set 3D View dialog window appears.

5. Enter 60"  in View Height and 48"  in Look Toward Height . Select 
Normal  from the Perspective pulldown.

6. Click OK.

First Click

Second Click
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7. From the View menu, select Rendering then Solid .

8. From the View Bar, select Save Sheet .

9. Enter Kitchen  for the Sheet Name.

10. Click OK.
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Walking Through The Model

1. Click the Walkthrough Tool  from the 3D Tools palette.

With the walkthrough cursor, click on the screen and drag it in the 
direction you want to go. Left to go left, right to go right, up to go forwa
and down to go backwards. Holding the mouse in the center of the sc
stops the motion.

2. With the Walkthrough cursor , right-click (Win) or click (Mac) and hold in 
the center of the screen.

3. Slowly move the cursor upwards about 1" from the center to start moving 
forward in the model. You increase your velocity by moving the cursor 
farther from the center of the screen. Once the motion starts, stop moving 
the mouse upwards. Continue to hold down the mouse button down.

4. Release the mouse button when you get close to the sink. 

Walkthrough Tool

Walkthrough Cursor
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The drawing will stop moving and the file will re-render. 

5. Click and hold the Walkthrough tool in the center of the screen and move 
the cursor to the right until motion begins.

6. Release the mouse button when the refrigerator comes in view.

7. Click and hold the Walkthrough tool in the center of the screen and move 
the cursor to the left until motion begins.
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8. Release the mouse button when the stove reaches the center of the 
screen.

Note: If at any point you can’t see anything, you may have traveled too far a
through the other side of a wall.

9. Select Kitchen  from the from the Saved Sheet list to restore the kitchen 
view created earlier.

Editing A Sheet

1. Right-Click (Win) or Control-Click (Mac) in the drawing area. This brings 
up the Edit menu .

2. Choose Select All .

3. From the Tool menu, select Convert Copy to Polygons . 

4. In the dialog, accept the default setting (Hidden Line Rendering) and click 
OK.
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5. With the copy still selected, select the Layer pulldown and then select 
Sheet-FloorPlan-1  from the Object Info. palette. 

The copy’s type will be listed as Group in the Object Info. palette.

6. Select Edit Sheet  from the View Bar.

7. In the Edit Sheet dialog, select Resid  Floor Plan-1  and click the Edit 
button.

The Edit Save Sheet dialog appears.

8. Check the Restore View field.

9. Click OK.

ADDING LIGHT

We will add a light source to the drawing to create shading when the 
model is rendering. This same lighting will also show as the model tu

1. Select the Resid Floor Plan-1 from the Sheet menu on the View Bar.

2. Select Fit to Window .

3. Select Sheet-FloorPlan-1  from the Layers pulldown in the Data Display 
bar.

4. Drag the Perspective View copy to the right so that it does not obscure the 
floor plan.
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5. Select the layer entitled Mod-Floor-1 from the Layers pulldown in the 
Data Display bar.

6. Select Layer Options  then Active Only  from the Organize menu.

7. Select the Light Tool  from the 3D Tool palette.

Because you have selected a 3D tool while in a 2D mode, you will be
asked if you want to switch the drawing into the 3D mode to use the t
Click Yes Always .

8. Click near the lower left corner of the house.

The Light Preferences dialog appears.

9. Accept the defaults in the Light Preferences dialog by clicking OK.

10. From the View menu, select Standard Views  then Left Isometric .

11. Select Save.

Light Tool

Click Here
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CREATE THE ORBIT ANIMATION

We will create an orbital animation of your drawing which rotates abou
given point. You will be able to view your drawing on all sides and eve
see through the windows. Since you added light you will also see the
effect of the light as the model turns.

1. From the View menu, select Rendering  then Shaded Solid .

2. From the Model menu, select Create Animation .

When the Create Animation dialog appears, accept all defaults.

3. Click Preview .

This will show you a preview of the animation in wireframe mode.

4. When the animation has stopped, click Save Movie.

5. Enter LearningMovie1.mov  for the name.

6. Click Save.

A dialog appears displaying how long the generation will take. Upon 
completion you are returned to your drawing.

7. Hide VectorWorks.

8. Locate the file LearningMovie1.mov  on your system and open it using 
your QuickTime Movie Player.

You house is shown in the movie window.
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9. Click the Play  button to start the movie.

The house rotates about the ground plane. Notice the way the light is 
as the house moves. 

CREATE AN ALONG PATH ANIMATION

1. From the View menu, select Standard Views  then Top/Plan .

2. From the View menu, select Set 3D View .

3. Click on the lower left side of the screen.

4. Drag and click closer to the left exterior wall.

5. Enter 60"  in View Height and 48"  in Look Toward Height . Select 
Normal  from the Perspective pulldown.

Play Button

First Click

Second Click
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6. Click OK.

7. From the View menu, select Rendering then Shaded Solid .

8. From the View bar, select Save Sheet .

9. Name this sheet View1 .

10. Click OK.

11. From the View menu, select Standard Views  and then Top/Plan .

12. From the View menu, select Set 3D View .

13. Click on the lower right side of the screen.

14. Drag and click closer to the right exterior wall.

First Click

Second Click
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Create An Along Path Animation
Presentations in VectorWorks
15. Enter 20’0"  in View Height and 12’0"  in Look Toward Height . Select 
Normal  from the Perspective pulldown.

16. Click OK.

17. From the View menu, select Rendering  then Shaded Solid .

18. From the View bar, select Save Sheet .

19. Name this sheet View2 .

20. Click OK.

21. From the Model menu, select Create Animation .

22. From the Camera pulldown, select Move Along Path .

23. Enter 3 in the Duration field.

24. Click the Options  button next to the Camera pulldown.
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Create An Along Path Animation 5
Presentations in VectorWorks
25. Click New in the Select Animation dialog.

26. In the New Animation Name dialog, enter Flyby .

27. Click Create .

28. Click Edit  in the Select Animation dialog.

29. Click the Zoom Out button to show the entire 3 sec duration on screen.

Click New

Zoom Out Button
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Create An Along Path Animation
Presentations in VectorWorks
30. From the list of sheets on the left, drag View1  into the Edit window.

31. Drag View2  to the end of the Edit window.

32. Click the Preview  button.

33. Once the preview is finished being presented, click Done .

34. Click Save Movie  in the Create Animation dialog.

35. Enter LearningMovie2.mov  for the name.

36. Click Save.

Upon completion you are returned to your drawing.

37. Hide VectorWorks.

38. Locate the file LearningMovie2.mov on your system and open it using 
your QuickTime Movie Player

Your house is shown in the movie window.

39. Click the Play  button to start the movie.
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This module combines many tools and techniques to create a mechanical part in VectorWorks.  Although 
this module is mechanically based, it can be performed by any VectorWorks user.  It shows concepts that 
apply to all disciplines and provides a concept that most users can relate to.

The structure of the exercises in this Level 1 Module is that all of the provided exercises are based on the 
2D Mechanical Draft  which you will create. You must complete this exercise before moving on to other 
exersises in this module.  Other exercises can then be completed in any order.

In this module you will design a  butterfly valve.  You will create a draft which shows a top, front and side 
view.  You will then dimension the drawing and make a 3D model of it. 

As of this printing only the 2D drafting exrecise is provided. 

Level 1 Module - Mechanical Exercises
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In this Exercise

• Creating the 
Top View

• Creating The 
Front View

• Creating The 
Side View
In this example we will create a butterfly valve used 
combustion engines using VectorWorks’ 2D 
capabilities. We will create guides, use cues, and us
standard and plug-in tools. This exercise focuses on
traditional drafting techniques in 2D. This exercise is
not optimized for conversion into 3D. In order to 
simplify this exercise, we have provided certain 
numeric values for you. In the real world, you may 
have to calculate these values on your own.

The completed file is located in your Learning 
Exercises folder and is entitled 
Mechanical2D_Sample.mcd. It may be used as a 
reference while drawing.

SETUP

It is important to set up your drawing before beginnin
to draw. In this exercise we will be using a template 
with most of your options pre-set. Although we do not 
use all the classes provided while performing this exercise
they are there for future use.

1. Select New from the File Menu.

2. Click the Use Document Template  radio button. From 
the template pulldown, select ME_Detail-A3.sta .

3. In the View bar, click Fit to Window .

4. From the File menu, select Workspaces  and then 
Mechanical Eng .

5. From the Palettes menu, open 2D Tools , Object Info , 
Editing , Constraints , and Attributes .
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Setup
Mechanical 2D Drafting
6. Click each of the following buttons on the Constraints palette: Snap to 
Grid , Snap to Objects , Constrain Angle , Snap to Intersection , Smart 
Points  and Smart Edge  as shown. 

7. On the Constraints palette, double click Snap to Grid .

The Set Grid dialog appears.

8. Change the Snap Grid X value to 1. Uncheck Show Grid Lines .

9. Click OK.

10. On the Constraints palette, double click Smart Edge .

The Edge Snaps dialog appears.

11. Uncheck Use 2nd Vector , Use Floating Edge  and, Snap to Bisector . 

Snap to 

Smart 
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Setup 6
Mechanical 2D Drafting
In this particular exercise you will use the "T" key on the keyboard to 
manually set Edges.

12. Click OK.

13. From the File menu, select Preferences  and then VectorWorks 
Preferences .

The VectorWorks Preferences dialog appears.

14. Check Eight Selection Handles .

15. Click OK.

16. From the Page menu, select Set Print Area .

The Print Area dialog appears.

17. Uncheck Show Page Breaks .

18. Click OK.

19. From the Data Display Bar, click the Classes  pulldown then select 
Classes . 
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Setup
Mechanical 2D Drafting

eady 

eed 
This brings up a dialog. Notice that there are a number of classes alr
created in this file. Each class has its own color, line style, and line 
weight.

20. Click Cancel .

21. Click the Zoom In  tool.

22. Using the rulers, move the cursor to an X of -50 and a Y of -50 then click. 
Drag the mouse diagonally and marquee the upper left portion of the 
drawing area.

Note: There will be times throughout this exercise where you may find the n
to zoom in or out to better see and snap to objects.

23. From the File menu, select Save As and name the file Mechanical.mcd .

Zoom In 
Tool

Click Here
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Create The Top View 6
Mechanical 2D Drafting

is 

 be 
hat 
rt of 
d to 

pe.

 

CREATE THE TOP VIEW

We will start by creating the Top View of this object. We will later use th
view to help create the Front View.

Creating The Centerlines

Centerlines are used to visually divide objects in half. Centerlines can
any shape (lines, circles, etc...). Centerlines differ from Guidelines in t
they are specifically for bisecting objects and remain on screen as pa
the final drawing. Guidelines on the other hand, are working lines use
aid in drawing but are not part of the final drawing. Guidelines are 
typically hidden or deleted from view. Guidelines can also be any sha

1. Click the Line tool .

2. Utilizing the Data Display Bar, move the cursor until X is -125 and Y is 120 
then click.

3. Drag downwards a little bit then press the Tab key  until the L (length) field 
is highlighted. Enter 140 then press the Enter key . With the line now 
drawn (notice the Vertical/ Length cue) click on the screen to end.

4. With the line selected, select the Class  pulldown and then select 
Centerlines  from the Object Info. palette.

Note: At this point (or later in the exercise) a dialog will appear asking if you
want the attribute change to take place, click Yes Always . 

Line Tool

Tip:  To keep lines 
constrained while 
drawing, hold the 
Shift key down

First Click

Second Click
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Create The Top View
Mechanical 2D Drafting
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Selecting Yes Always allows any object made in one class to take on th
attributes of another. The program will not ask again about such chan
in that session. Clicking Yes will only allow that particular change to take
place. The dialog will appear for each attempt to change attributes af
that. No Always disallows any attempt to change the pre-assigned clas
attributes for that session. No disallows the change to take place for that
instance.

5. Click the Line  tool .

6. Move to an X of -175 and a Y of 50 and click.

7. Drag to the right a little bit then press the Tab key until the L (length) field 
is highlighted. Enter 100 then press the Enter key. With the line now 
drawn (notice the Horizontal/ Length cue) click on the screen to end.

8. With this line selected, select the Class  pulldown and select Centerlines  
from the Object Info. palette. 

9. From the File menu, select Save.

Creating The Body

1. Double click the Ellipse tool .

First Click Second Click

Ellipse Tool
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Create The Top View 6
Mechanical 2D Drafting
2. Enter in a diameter of 72.

3. Click OK.

4. Move the mouse to the intersection of the two Centerlines. When the 
Center cue appears, click.

5. Double click the Ellipse tool .

6. Enter in a diameter of 50.

7. Click OK.

8. Move the mouse to the intersection of the two Centerlines. When the 
Center cue appears, click.

9. Click the 2D Selection  tool .

10. Hold down the Shift key and click on the first (larger) circle.

Both circles are now selected.

2D Selection 
Tool
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Create The Top View
Mechanical 2D Drafting
11. From the Attribute palette, select the Fill Style  pulldown then select 
Solid .

12. With the two circles still selected, select Clip Surface  from the Tool menu.

13. Right Click (Win)/ Control Click (Mac) on the screen and select Deselect 
All  from the Edit menu.

14. Click on the inner circle then press the Delete key  to remove it.

This area is the body

15. Select Save from the File menu.

Creating The Front Boss

1. Double click the Smart Edge  constraint. 

2. Enter 42 in the Snap Offset field.

3. Click OK.

4. Click the Rectangle tool .

5. Move to the horizontal centerline and press the T key. 

Body

Rectangle 
Tool
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Create The Top View 6
Mechanical 2D Drafting
A guide line appears along its length.

6. Move to the intersection of the horizontal centerline and the right center of 
the body (Arc End cue) then downwards without clicking. When the 
Offset/ Align H  cue appears click.

7. Moving up and to the left, click at the left center (Arc End cue) of the body.

8. Click the 2D Selection tool .

9. With the rectangle still selected, move the mouse to its Top Center (Top 
Center cue). When the Reshape cursor appears, click.

Guide Line
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Create The Top View
Mechanical 2D Drafting
10. Drag the rectangle’s top down until it reaches the bottom of the body (Arc 
End cue) then click.

This rectangle is the Front Boss.

11. From the Tool menu, select Send  and then Send to Back .

12. From the File menu, select Save.

Creating the Tapped Holes

1. Double click the Smart Edge  constraint .

2. Enter 16.45 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the vertical centerline. Press the T key.

Front Boss
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Create The Top View 6
Mechanical 2D Drafting
6. Move the cursor to the left until the Offset cue appears. Click and draw a 
vertical line starting just below the bottom of the rectangle. Drag up to the 
bottom of the body (Object /Parallel or Object /Vertical cue) and click to 
end.

7. With the line still selected, select the Class  pulldown then select 
Centerlines  from the Object Info. palette.

8. From the Design menu, select Drafting Aids and then Holes .

The Holes dialog appears.

9. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 4 in the Diameter field and 12 in the Total Depth field.
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Create The Top View
Mechanical 2D Drafting
10. Click OK.

11. Click at the intersection of the vertical line you just drew and the bottom of 
the Front Boss (Object/ Object cue).

12. From the Editing palette, click the 2D Rotate tool .

13. Click at the intersection of the tap hole and the bottom of the Front Boss 
(Top Center cue).

14. Drag horizontally to the right of the tap hole and click.

15. Drag left until you see the tap hole mirror in the upward direction then click 
to set.

16. Select the 2D Selection tool .

17. Hold down the Shift Key  and click on the small vertical centerline.

18. From the Editing palette, click the Mirror  tool . Click the Mirror and 
Duplicate mode  in the Mode Bar.

19. Move the cursor to the bottom of the large vertical centerline and click.

2D Rotate 
Tool

Mirror Tool
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Create The Top View 6
Mechanical 2D Drafting

e.
20. Move vertically then click to set the mirror axis.

This creates a mirror image of the tap hole to the right of the centerlin

21. From the Design menu, select Drafting Aids  and then Holes .

22. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 4 in the Diameter field and 12 in the Total Depth field.

23. Click OK.

24. Click at the intersection of the large vertical centerline and the bottom of 
the Front Boss (Bottom Center cue).

25. Click the 2D Rotate tool from the Editing palette.

26. Click at the intersection of the tap hole and the bottom of the Front Boss 
(Top Center cue).

27. Drag horizontally to the right of the tap hole and click.

First Click

Second Click
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Create The Top View
Mechanical 2D Drafting
28. Drag horizontally left until you see the tap hole mirror in the upwards 
direction then click to set.

29. Click the 2D Selection tool .

30. Hold down the Shift key  and click on the left and right tap holes.

31. From the Object Info. palette, select the Class  pulldown then select 
Dashed Lines .

32. From the File menu, select Save.

Creating The Drilled Hole

1. Double click the Smart Edge  constraint.

2. Enter 10 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the large vertical centerline. Press the T key.
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Create The Top View 6
Mechanical 2D Drafting
6. Move the cursor to the left until the Offset cue appears. Click and draw a 
vertical line starting inside of the body and extending down to the outer 
edge of the circle (Object/ Vertical cue or Object/ Parallel). Click to end.

7. Move the cursor over the large vertical centerline. Press the T key.

8. Move the cursor to the right until the Offset cue appears. Click and draw a 
vertical line starting inside of the body and extending down to the outer 
edge of the circle (Object/ Vertical cue or Object/ Parallel). Click to end.

9. Double click the Smart Edge  constraint.

10. Enter 31 in the Snap Offset field.

11. Click OK.

12. Click the Line tool .

13. Move the cursor over the horizontal centerline and click the T key.

14. Move the cursor upward until the Offset cue appears. Click and draw a 
horizontal line the approximate width between the two vertical lines. Click 
to end.

15. Click the 2D Selection  tool .

Look for the 
Horizontal or 
Perpendicular cue.
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Create The Top View
Mechanical 2D Drafting

l 
16. Hold the Shift key  down and click on the left vertical line.

17. From the Tool menu, select Join .

18. Click on the right vertical line. Hold the Shift key  down and click on the 
horizontal line.

19. From the Tool menu, select Join .

20. Hold the Shift key  down and click on the left vertical line.

21. From the Object Info. palette, select the Class  pulldown and select 
Dashed Lines .

22. Click on the horizontal centerline. Hold down the Shift key and click on the 
two vertical lines.

23. From the Tool menu, select Trim .

24. Click on the horizontal centerline.

The two vertical lines are now split where they intersect the horizonta
centerline.
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Create The Top View 6
Mechanical 2D Drafting
25. Right Click (Win)/ Control-Click (Mac) in the drawing area to bring up the 
Edit dialog. Select Deselect All.

26. Click on the top left vertical line.

27. Move the cursor over the bottom handle of this vertical line. When the 
Arrow cursor changes into the Resize cursor, click and drag vertically 
upwards to the edge of the inner circle. Click when the Object/ Vertical 
cue appears.

28. Repeat procedure for right upper vertical line.

29. Click on the bottom left vertical line.

30. Move the cursor over the top handle of this vertical line. When the Arrow 
cursor changes into the Resize cursor, click and drag vertically 
downwards to the edge of the inner circle. Click when the Object/ Vertical 
cue appears.

31. Repeat procedure for right lower vertical line.

32. From the File menu, select Save.

2D Selection 

Resize 
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Create The Top View
Mechanical 2D Drafting
Creating The Counter Bore

1. Double click the Rectangle  tool.

2. Enter 25.5 for delta X and 7 for delta Y. Click the Bottom Center  
alignment radio button. Select the Class pulldown and select Dashed 
Lines .

3. Click OK.

4. Move to the bottom of the rectangle under the outer circle until the Bottom 
Center cue appears then click.

5. From the File menu, select Save.

Creating The Upper Ears

1. Click the Arc tool .

2. Move the cursor to the intersection of the two main centerlines. When the 
Center cue appears, click.

Arc Tool
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Create The Top View 6
Mechanical 2D Drafting
3. Drag the cursor up and to the right past the circle.

4. Press the Tab key  until the L (length) field is highlighted. Enter 45. Press 
the Enter key  on the Numeric keypad to set. 

5. The A (Angle) field is now highlighted. Enter 45. Press the Enter key  on 
the Alpha-Numeric keypad to set. Click on the screen to set the beginning 
of the arc, then drag left a little bit. 

6. Click the Tab key  to activate the Sweep  field in the Data Display bar.

7. Enter 90 and press the Enter key . Click in the drawing to set the arc.

8. With the arc selected, select Guides  then Make Guide from the Edit 
menu.

9. Double click the Ellipse tool .

10. Enter a radius of 9.5.
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Create The Top View
Mechanical 2D Drafting
11. Click OK.

12. Move the cursor to the intersection of the vertical centerline and the guide 
arc. Click when the Object/Object cue appears.

13. Click the Rectangle tool .

14. Move to the left side of the small circle just drawn. When the Center Left 
cue appears, click. Drag to the opposite side until the Center Right cue 
appears. Drag down, using the Align H cue to keep you aligned with the 
Right Center of the circle, until the rectangle is just between the inner and 
outer circle then click.

15. Select the 2D Selection  tool .

16. Hold down the Shift key  and click on the small circle.
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Create The Top View 6
Mechanical 2D Drafting

 be 
Note that circles have a center and single side handle which may not
obvious during this part of the exercise.

17. From the Tool menu, select Add Surface .

This is now one of the upper ears.

18. With the inner ear still selected, select Duplicate Array  from the Edit 
menu.

The Duplicate dialog appears.

19. Click the Circular Array  radio button. Enter 120 in the Angle field. Click 
the Next Mouse Click  radio button.

20. Click OK.

Inner Ear
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Create The Top View
Mechanical 2D Drafting
21. Move the cursor to the intersection of the centerlines (Center cue) and 
click.

22. Click the 2D Selection tool .

23. Click the top upper ear. Hold down the Shift key  and click on the body.

24. From the Tool menu, select Add Surface .

25. Hold down the Shift key  and click on the left ear.

26. Select Add Surface  from the Tool menu.

27. With the polyline still selected, select Send  and then Send to Back from 
the Tool menu.

28. Click on the rectangle (Front Boss). Select Send  and then Send to Back 
from the Tool menu.
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Create The Top View 6
Mechanical 2D Drafting
29. From the Design menu, select Drafting Aids  and then Holes  from the 
pulldown.

30. Click the Tapped  radio button for Type, the No radio button for Show 
Center Mark. Enter 8 in the Diameter field. Click the Top view  radio 
button for View.

31. Click OK.

32. Click at the center of the arc guide (Center cue).

33. With the tapped hole still selected, select Duplicate Array  from the Edit 
menu. All settings should be the same as you used previously, so there is 
no need to change anything.

34. Click OK.

35. Move to the intersection of the centerlines (Center cue) and click.

36. From the File menu, select Save.
Learning Exercises Manual 6-23



Create The Top View
Mechanical 2D Drafting
Creating The Lower Ears

1. Click the Arc tool .

2. Move the cursor to the intersection of the centerlines (Center cue) and 
click.

3. Drag the cursor up and to the right of the polyline. Press the Tab key  until 
the L field is highlighted. Enter 50. Press the Enter key  on the Numeric 
keypad to set.

4. The A (Angle) field is now highlighted. Enter 45. Press the Enter key  on 
the Alpha-Numeric keypad to set. Click on the screen to set the beginning 
of the arc, then drag left a little bit.

5. Press the Tab key  to highlight the Sweep  field in the Data Display bar. 
Enter 90 and press the Enter key  on the Alpha-Numeric keypad. Click on 
the drawing to end the arc.

6. With the arc selected, select Guides  then Make Guides from the Edit 
menu.

7. Double click the Ellipse tool .

8. Enter a radius of 12.5.

9. Click OK.
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Create The Top View 6
Mechanical 2D Drafting
10. Move to the intersection of the vertical Centerline and the new guide arc. 
When the Object/Object cue appears, click.

11. Click the Rectangle tool .

12. Move to the left side of the new circle. When the Center Left cue appears, 
click on the drawing. Drag to the opposite side of the circle until the 
Center Right cue appears. Drag down, using the Align H cue to keep you 
aligned with the right center of the circle, until the rectangle intersects the 
outer circle (Object/ Align H cue) then click.

13. Click the 2D Selection tool .

14. Hold down the Shift key  and click on the circle.
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Create The Top View
Mechanical 2D Drafting
15. Select Add Surface  from the Tool menu.

This is one of the lower ears.

16. While the ear is still selected, select the Fill pulldown then select Solid 
from the Attributes palette.

17. Double click the Ellipse tool .

18. Enter a diameter of 10.5.

19. Click OK.

20. Click at the center of the second arc guide.

21. Click the 2D Selection tool .

22. Hold down the Shift key  and click on the ear.

23. From the Tool menu, select Clip Surface .

24. Hold down the Shift key  and click on the ear.

Clicking on an object already selected, deselects it.

Lower Ear
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Create The Top View 6
Mechanical 2D Drafting
25. With only the smaller circle now selected, press the Delete key  to remove 
it.

26. Click on the ear.

27. From the Edit menu, select Duplicate Array .

28. In the Circular Array  section, enter 2 in the Number field.

29. Click OK.

30. Move the cursor to the intersection of the two main centerlines (Center 
cue) and click.

31. Click the 2D Selection tool .

32. Hold down the Shift key and click on the top ear.

33. From the Tool menu, select Send  and then Send to Back .

34. From the File menu, select Save.
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Create The Front View
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wn 
CREATE THE FRONT VIEW

Using the Top view as a guide, we will now create the Front View.

Creating the Centerlines

1. Click the Line  tool .

2. Move to the bottom of the vertical centerline. When the Point cue appears, 
move downwards, keeping the Align H cue on.

3. Using the Data Display Bar, move the cursor down until X is -125 and Y is 
-30 then click.

Depending on your zoom factor, you may need to scroll the screen do
or zoom out at this point.

4. Drag down a little bit then press the Tab key  until the L (length) field is 
highlighted. Enter 90 then press the Enter key . Click to finish the line.

5. With the line still selected, click the Class  pulldown from the Object Info. 
palette then select Centerline .

6. Using the Data Display Bar, move the cursor until X is -175 and Y is -75 
then click.

7. Drag to the right a little bit then press the Tab key  until the L (length) field 
is highlighted. Enter 100 then press the Enter key . Click to finish the line.

8. With the line still selected, click the Class  pulldown from the Object Info. 
palette then select Centerline .

9. From the File menu, select Save.

Click Here
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Creating the Body

1. Double click the Rectangle tool .

2. Enter 72 for delta X and 60 for delta Y. Select the Center  alignment 
button.

3. Click OK.

4. Using the Center cue, click at the intersection of the centerlines.

5. With the rectangle selected, select the Fill  pulldown then select Solid  
from the Attribute palette.

6. Double click the Rectangle tool .

7. Enter in 58 for delta X and 2 for delta Y. Click the Top Center  alignment 
radio button.

8. Click OK.

9. Move to the bottom center (Bottom Center cue) of the rectangle and click.

10. With this rectangle selected, click the Fill  pulldown then select Solid  from 
the Attribute palette.
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Create The Front View
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11. Select Save from the File menu.

Creating The Front Boss

1. Double click the Ellipse tool .

2. Enter 50 in the diameter field.

3. Click OK.

4. Using the Center cue, click in the middle of the first rectangle.

5. From the File menu, select Save.

Creating The Counter Bore

1. Double click the Ellipse tool .

2. Enter 25.5 in the diameter field. 

3. Click OK.

4. Using the Center cue, click in the middle of the first rectangle.
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5. From the File menu, select Save.

Creating The Drilled Hole

1. Double click the Ellipse tool .

2. Enter 20 in the diameter field.

3. Click OK.

4. Using the Center cue, click in the middle of the first rectangle.

5. From the File menu, select Save.

Creating The Bolt Circle

1. Double click the Ellipse tool . 

2. Enter 38 in the diameter field. Select the Class pulldown then select 
Centerlines .

3. Click OK.

4. Using the Center cue, click in the middle of the first rectangle.
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 need 
5. From the Design menu, select Drafting Aids then Holes .

6. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 4 in the Diameter field. Select the Top View  radio 
button for View.

7. Click OK.

8. Click at the top center of the Bolt Circle (Top Center cue).

9. With the tapped hole still selected, select Duplicate Array  from the Edit 
menu.

All settings should be the same as you used previously so there is no
to change anything.

10. Click OK.

11. Move to the center (Center cue) of the first rectangle and click.

12. From the File menu, select Save.

Front Boss

Counter Bore

Drilled Hole

Bolt Circle
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Creating the Front View of the Ears

1. Click the Line  tool .

2. In the Top View drawing, move the cursor to center of the hole in the right 
lower ear. When the Center cue appears, click.

3. Draw a horizontal line to the right of the outer ear approximately 25mm  
long. Click to end.

4. With the line selected, select Guides  then Make Guide from the Edit 
menu.

5. Find the intersection of the lower ear and this guideline (Object/ Object 
cue). Click and draw a vertical line down to the bottom of the Front View 
drawing (about where the vertical centerline ends). Click to end.

6. With the line selected, select Guides  then Make Guide from the Edit 
menu.

Click Here
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Create The Front View
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7. Returning to the Top View drawing, use the Corner cue to find the 
intersection of the right lower ear and the outer circle of the body. Click 
and draw a vertical line down to the bottom of the Front View drawing. 
Click to end.

8. With the line selected, select Guides  then Make Guide from the Edit 
menu.

9. Click the Rectangle tool .

10. In the Front View drawing, find the intersection of the left guideline and the 
bottom of the first rectangle (Object/Object cue). At the intersection click 
to start the rectangle.

11. Move upwards then press the Tab key until the delta Y field is highlighted. 
Enter 8 and press the Enter key .

Click Here

Click Here
6-34 Learning Exercises Manual



Create The Front View 6
Mechanical 2D Drafting
12. Move over to the right guideline until the Object/ Horizontal cue appears 
(you may have to move upwards a bit). Click to set the rectangle.

13. With this rectangle selected, select the Fill  pulldown then select Solid  
from the Attribute palette.

14. Select the Line tool .

15. In the Top View drawing, locate the intersection of the guideline and the 
circle in the right lower ear. When the Object/ Object cue appears move 
downwards.

Click Here

Start Here
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Create The Front View
Mechanical 2D Drafting
16. With the Align H cue active, move down until you reach the top of the 
rectangle just drawn in the Front View (Object/ Align H cue) and click. 
Draw a vertical line extending to the bottom of the rectangle (Object/ 
Vertical cue). Click to end.

17. In the Top View drawing, use the Center cue to find the left end of the 
guideline in the right lower ear. Move to the left until the Object/ Align V 
cue appears then move downwards.

18. With the Align H cue active, move down until you reach the top of the 
rectangle just drawn in the Front View (Object/ Align H cue) and click. 
Draw a vertical line extending to the bottom of the rectangle (Object/ 
Vertical cue). Click to end.

19. Click the 2D Selection tool .

20. Hold down the Shift key  and click on the right vertical line inside the 
rectangle.

21. From the Object Info. palette, select the Class  pulldown then select 
Dashed Lines .

Start Here
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Create The Front View 6
Mechanical 2D Drafting
22. Hold down the Shift key  and click the rectangle.

23. From the Organize menu, select Group .

24. With this new group still selected, click the Mirror  tool  from the Editing 
palette. Click the Mirror and Duplicate mode  in the Mode Bar.

25. Move to the center of the body rectangle (Center cue) and click.

26. Keeping the drag line vertical, click at the bottom of the Front View vertical 
centerline (Point cue).

27. From the File  menu, select Save.

Creating the Upper Ears

1. Click the Line tool .

2. In the Top View drawing, move the cursor to center of the hole in the left 
inner ear. When the Center cue appears, click.
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Create The Front View
Mechanical 2D Drafting
3. Draw a horizontal line to the left of the inner ear approximately 25mm  
long. Click to end.

4. With the line selected, select Guides  then Make Guide from the Edit 
menu.

5. Find the intersection of the inner ear and this guideline (Object/ Object 
cue). Click and draw a vertical line down to the middle of the Front View 
drawing (about where the horizontal centerline is). Click to end.

6. With the line selected, select Guides  then Make Guide from the Edit 
menu.

7. Returning to the Top View drawing, use the Corner cue to find the 
intersection of the left inner ear and the outer circle of the body. Click and 
draw a vertical line down to the middle of the Front View drawing. Click to 
end.

Click Here

Click Here
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Create The Front View 6
Mechanical 2D Drafting
8. With the line selected, select Guides  then Make Guide from the Edit 
menu.

9. Click the Rectangle tool .

10. In the Front View drawing, find the intersection of the right guideline and 
the top of the first rectangle (Object/Object cue). At the intersection click 
to start the rectangle.

11. Move downwards then press the Tab key until the delta Y field is 
highlighted. Enter -15 and press the Enter key .

12. Move over to the left guideline until the Object/ Horizontal cue appears 
(you may have to move downwards a bit). Click to set the rectangle.

13. With this rectangle selected, select the Fill  pulldown then select Solid  
from the Attribute palette.

14. Click the Line tool .

15. In the Top View drawing, move the cursor to center of the hole in the left 
inner ear. When the Center cue appears, move the mouse downwards 
without clicking.

Click Here

Click Here
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Create The Front View
Mechanical 2D Drafting
16. In the Front View drawing, click just above the rectangle and draw a 
vertical line that goes through the rectangle and ends just below it. Click 
to end.

17. With the line still selected, select the Class  pulldown then select 
Centerlines from the Object Info. palette.

18. From the Design menu, select Drafting Aids  and then Holes  from the 
pop-out.

19. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 8 in the Diameter field and 15 in the Total Depth field. 
Click the Side view - thru hole  radio button.

20. Click OK.

21. Move to the intersection of the top of the rectangle just drawn and the 
small vertical centerline (Object/ Object cue) and click.

22. With the Tapped Hole still selected, select the Class  pulldown then select 
Dashed Lines from the Object Info. palette

23. Click the 2D Selection tool .
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Create The Section View 6
Mechanical 2D Drafting
24. Hold down the Shift key  and click on the small vertical centerline and on 
the rectangle.

25. From the Organize menu, select Group .

26. With this new group still selected, click the Mirror  tool  from the Editing 
palette.

27. Move to the top of the vertical centerline (Point cue) and click.

28. Keeping the drag line vertical, drag downwards and click near the middle 
of the body rectangle.

29. Click the 2D Selection tool .

30. Click on the main vertical centerline. Hold down the Shift key  and click 
the main horizontal centerline.

31. From the Tool menu, select Send  then Send to Front .

32. From the File menu, select Save.

CREATE THE SECTION VIEW

Using the Front view as a guide, we will now create the Section View.

Creating The Horizontal Guides

1. Click the Line tool .
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Create The Section View
Mechanical 2D Drafting
2. Using the Corner cue, find the top right corner of the upper right ear and 
click. Draw a horizontal line approximately 170mm . Click to end.

3. Find the top center of the Front Boss (Top Center cue) and click. Draw a 
horizontal line that ends around the same distance as the previous line 
then click.

Click Here

Click Here
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Create The Section View 6
Mechanical 2D Drafting
4. Find the bottom right of the upper right ear (Bottom Right cue) and click. 
Draw a horizontal line that ends around the same distance as the 
previous line then click.

5. Find the bottom center of the Front Boss (Bottom Center cue) and click. 
Draw a horizontal line that ends around the same distance as the 
previous line then click.

Click Here

Click Here
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Create The Section View
Mechanical 2D Drafting
6. Find the top right of the lower right ear (Top Right cue) and click. Draw a 
horizontal line that ends around the same distance as the previous line 
then click.

7. Find the bottom right of the lower right ear (Bottom Right cue) and click. 
Draw a horizontal line that ends around the same distance as the 
previous line then click.

8. Find the bottom right of the lower most rectangle (Bottom Right cue) and 
click. Draw a horizontal line that ends around the same distance as the 
previous line then click.

Click Here

Click Here

Click Here
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Create The Section View 6
Mechanical 2D Drafting
9. Click the 2D Selection tool .

10. With the bottom-most horizontal line still selected, hold down the Shift 
key  and click on the other 6 horizontal lines.

11. From the Edit menu, select Guides  and then Make Guide .

12. From the File menu, select Save.

Creating The Centerlines

1. Click the Line tool .

2. Utilizing the Data Display Bar, move the cursor until X reads 20 and Y 
reads -30 then click.

3. Drag vertically downwards then press the Tab key  until you highlight the L 
field.

4. Enter 90 then press the Enter key . Click to end.

5. With this line selected, select the Class  pulldown then select Centerlines 
from the Object Info. palette.

6. Move to the left of the vertical centerline. When X reads -25 and Y reads -
75 click.

7. Drag horizontally a little bit to the right then press the Tab key  until you 
highlight the L field.

8. Enter 90 then press the Enter key . Click to end.

9. With this line selected, select the Class  pulldown then select Centerlines 
from the Object Info. palette.

10. From the File menu, select Save.
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Create The Section View
Mechanical 2D Drafting
Creating The Left Side Guides

1. Double click the Smart Edge constraint .

2. Enter 25 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the vertical centerline and press the T key.

6. Move to the left of the centerline until the Offset cue appears. Starting at 
the top horizontal guideline (Object/ Offset cue), click and draw a vertical 
line that ends at the bottom horizontal guideline (Object/ Vertical cue). 
Click to end.

7. Double click the Smart Edge constraint .

8. Enter 42 in the Snap Offset field.

9. Click OK.

10. Move the cursor over the vertical centerline and press the T key.
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Create The Section View 6
Mechanical 2D Drafting
11. Move to the left of the centerline until the Offset cue appears. Click at the 
top Boss guideline (Object/ Offset cue). Drawing vertically, click to end at 
the bottom Boss guideline (Object/ Vertical cue).

12. Double click the Smart Edge constraint .

13. Enter 36 in the Snap Offset field.

14. Click OK.

15. Move the cursor over the vertical centerline and press the T key.

16. Move to the left of the centerline until the Offset cue appears. Click and 
draw a vertical line starting at the top horizontal guideline (Object/ Offset 
cue). Click to end at the bottom guideline of the lower ear (Object/ Vertical 
cue).

17. Double click the Smart Edge constraint .

18. Enter 29 in the Snap Offset field.

19. Click OK.
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Create The Section View
Mechanical 2D Drafting
20. Move the cursor over the vertical centerline and press the T key.

21. Move to the left of the centerline until the Offset cue appears. Click and 
draw a vertical line starting at the bottom guideline of the lower right ear 
(Object/Offset cue). Click to end at the bottom horizontal guideline 
(Object/ Offset cue).

22. From the File menu, select Save.

Creating The Left Side of the Body

1. Click the 2D Polygon tool .

2D Polygon Tool
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Create The Section View 6
Mechanical 2D Drafting
2. Move to the intersection of the top body guideline and the vertical line 
closest to the vertical centerline (Object/ Object cue) then click.

3. Moving in the left direction, trace the outline of the four vertical lines as 
shown.

At the last click location, the polygon is closed indicating that the 
operation is finished. 

Click Here
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Create The Section View
Mechanical 2D Drafting
4. With the polygon still selected, select the Fill  pulldown then select Hatch 
from the Attributes palette. Select the Hatch  Pattern pulldown then select 
Aluminum-3 x 45 .

5. From the File menu, select Save.

Create the Tapped Hole

6. Double click the Smart Edge constraint .

7. Enter 11 in the Snap Offset field.

8. Click OK.

9. Click the Line tool .

10. Move the cursor over the top horizontal guideline and press the T key.

11. Move downwards until the Offset cue appears. Click and draw a line that 
starts to the left and goes through the polygon as shown. Click again to 
end.
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Create The Section View 6
Mechanical 2D Drafting
12. With this line selected, select the Class  pulldown from the Object Info. 
palette then select Centerlines .

13. From the Design menu, select Drafting Aids  and then Holes  from the 
pop-out.

14. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 4 in the Diameter field and 12 in the Total Depth field.

15. Click OK.

16. Click at the intersection of the new horizontal centerline and the left side 
of the polygon (Object/Object cue).

17. From the Editing palette, click the 2D Rotate tool .

18. Click at the intersection of the tap hole and the left side of the polygon 
(Top Center cue).

19. Drag to the right of the tap hole and click.

20. Rotate the line upwards until the tap hole is facing into the polygon then 
click to set.

21. With the tap hole still selected, select the Fill pulldown and select Solid 
from the Attribute palette.
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Create The Section View
Mechanical 2D Drafting
22. Select the 2D Selection tool .

23. Click on the centerline of the tap hole just drawn.

24. From the Tool menu, select Send  then Send to Front .

25. From the File menu, select Save.

Creating The Right Side Guidelines

1. Double click the Smart Edge constraint .

2. Enter 25 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the vertical centerline and press the T key.

6. Move to the right of the centerline until the Offset cue appears. Click on 
the top horizontal guideline (Object/ Offset cue. Click to end at the bottom 
horizontal guideline (Object/ Vertical cue).

7. Double click the Smart Edge constraint .

8. Enter 36 in the Snap Offset field.

9. Click OK.

10. Move the cursor over the vertical centerline and press the T key.
6-52 Learning Exercises Manual



Create The Section View 6
Mechanical 2D Drafting
11. Move to the right of the centerline until the Offset cue appears. Click on 
the bottom guideline of the upper ear (Object/ Offset cue). Click to end at 
the top guideline of the lower ear (Object/ Vertical cue).

12. Double click the Edge Snap constraint .

13. Enter 54.5 in the Snap Offset field.

14. Click OK.

15. Move the cursor over the vertical centerline and press the T key.

16. Move to the right of the centerline until the Offset cue appears. Click on 
the top horizontal guide line. Click to end at the bottom guideline of the 
upper ear.

17. Double click the Smart Edge constraint .

18. Enter 62.5 in the Snap Offset field.

19. Click OK.

20. Move the cursor over the vertical centerline and press the T key.
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Create The Section View
Mechanical 2D Drafting
21. Move to the right until the Offset cue appears. Click on the top guideline of 
the lower ear (Object/ Offset cue). Click to end at the bottom guideline of 
the lower ear (Object/ Vertical cue).

22. Double click the Smart Edge constraint .

23. Enter 29 in the Offset field.

24. Click OK.

25. Move the cursor over the vertical centerline and press the T key.

26. Move to the right of the centerline until the Offset cue appears. Click on 
the bottom guideline of the lower ear (Object/Offset cue). Click to end at 
the bottom body guideline (Object/ Offset cue).

27. From the File menu, select Save.

Creating the Right Side of the Body

1. Click the 2D Polygon tool .
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Create The Section View 6
Mechanical 2D Drafting
2. Move to the intersection of the top body guideline and the vertical line 
closest to the vertical centerline (Object/ Object cue) then click.

3. Moving in the right direction, trace the outline of the five vertical lines as 
shown.

Click Here
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Create The Section View
Mechanical 2D Drafting
At the last click location, the polygon is closed indicating that the 
operation is finished.

4. With the polygon still selected, select the Fill  pulldown then select Hatch 
from the Attributes palette. Select the Hatch  Pattern pulldown and select 
Aluminum-3 x 45 .

5. From the File menu, select Save.

Creating the Drilled Hole

1. Double click the Smart Edge constraint .

2. Enter 50 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the vertical centerline and press the T key.
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Create The Section View 6
Mechanical 2D Drafting
6. Move to the right until the Offset cue appears. Click and draw a line that 
starts above and goes through the lower ear of the polygon as shown. 
Click again to end.

7. With this line still selected, select the Class pulldown then select 
Centerline from the Object Info. palette.

8. Double click the Smart Edge constraint .

9. Enter 5.25 in the Snap Offset field.

10. Click OK.

11. Click the Rectangle tool .

12. Move the cursor over the vertical centerline just created and press the T 
key.

13. Move to the left until the Offset cue appears. Move to the intersection of 
the top of the lower ear and the offset line (Object Offset cue) then click.

14. Move downwards to the bottom of the ear (Object/ Vertical cue).
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Create The Section View
Mechanical 2D Drafting
15. Moving right along the bottom of the ear, click to end when the Object/ 
Offset cue appears.

16. With the rectangle still selected, select the Fill pulldown then select Solid 
from the Attributes palette.

17. Select the 2D Selection tool .

18. Click on the centerline of the rectangle just drawn.

19. From the Tool menu, select Send  then Send to Front .

20. From the File menu, select Save.

Creating the Tapped Hole

1. Double click the Edge Snap constraint .

2. Enter 45 in the Snap Offset field.

3. Click OK.

4. Click the Line tool .

5. Move the cursor over the main vertical centerline and press the T key.
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Create The Section View 6
Mechanical 2D Drafting
6. Move to the right until the Offset cue appears. Click and draw a line that 
starts above the upper ear and goes through it as shown. Click again to 
end.

7. With the line still selected, select the Class pulldown then select 
Centerline from the Object Info. palette.

8. From the Design menu, select Drafting Aids  and then Holes .

9. Click the Tapped  radio button for Type and the No radio button for Show 
Center Mark. Enter 8 in the Diameter field and 15 in the Total Depth field. 
Select the Side View - thru hole  radio button for View.

10. Click OK.

11. Click at the intersection of the vertical line just drawn and the top of the 
polygon (Object/ Object cue).

12. With the tap hole still selected, select the Fill  pulldown then select Solid 
from the Attributes palette.

13. Select the 2D Selection tool .

14. Click on the centerline of the tap hole just drawn.

15. From the Tool menu, select Send  then Send to Front .
Learning Exercises Manual 6-59



Create The Section View
Mechanical 2D Drafting
16. From the File menu, select Save.

Finishing the The Section View

Create the Counter Bore

1. Double click the Rectangle tool .

2. Enter 7 for delta X and 25.5 for delta Y. Click the Left Center  alignment 
radio button.

3. Click OK.

4. Move to the intersection of left side of the left polygon and the horizontal 
centerline (Center cue) then click.

5. With this rectangle still selected, select the Fill  pulldown then select Solid 
from the Attribute palette.

6. From the File menu, select Save.

Create the Drilled Hole

1. Double click the Rectangle tool .

2. Enter 67 for delta X and 20 for delta Y.

3. Click OK.
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Create The Section View 6
Mechanical 2D Drafting
4. Click at the center right of the rectangle just created (Center Right cue).

5. With the rectangle still selected, select the Fill  pulldown then select Solid  
from the Attribute palette.

6. From the File menu, select Save.

Creating the Bored Hole

1. Select the Rectangle tool .

2. Click at the top right of the left polygon (Point cue). Drag diagonally to the 
bottom left on the right polygon then click (Point cue).
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Create The Section View
Mechanical 2D Drafting
3. With the rectangle still selected, select the Fill  pulldown then select Solid 
from the Attribute palette.

4. Click the 2D Selection tool .

5. Click on the main vertical centerline. Hold down the Shift key  and click 
the main horizontal centerline.

6. From the Tool menu, select Send  then Send to Front .

7. From the Edit menu, select Guides  and then Hide Guides .

8. From the File menu, select Save.
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