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OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME JURISDICTIONS. THE ABOVE EXCLUSION MAY NOT
APPLY TO YOU.

IN NO EVENT WILL CE SOFTWARE’S LICENSOR(S), AND THEIR DIRECTORS, OFFICERS, EMPLOYEES OR 
AGENTS (COLLECTIVELY CE SOFTWARE’S LICENSOR) BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, 
INCIDENTAL OR INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS
INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE LIKE) ARISING OUT OF THE USE OR INABILITY
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LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY 
TO YOU. CE Software’s Licensor’s liability to you for actual damages from any cause whatsoever, and regardless of t
of the action (whether in contract, tort [including negligence], product liability or otherwise), will be limited to $50.

This CE Software publication was created electronically using Adobe® FrameMaker®.

Art was produced using Adobe Photoshop®. 
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Use the following table as a guide to locate information about each QuicKeys plug-in. The plug-ins are listed in alphabetical order.

Use this QuicKeys Shortcut... If you want to automate these tasks...

Advanced Text Tools 

See page 72 for more information.

Reformat a block of text to remove unwanted line breaks and spaces. 

Change a block of text to title case, uppercase, or lowercase. 

Remove quote marks from an E-mail message that was forwarded to you.

Alias Keystroke

See page 95 for more information.

Reassign keystrokes built into the applications you use so they make sense to you.

App Switcher

See page 96 for more information.

Switch between applications that are open on your desktop.

Apple Events

See page 131 for more information.

Trigger an Apple Event.

AppleScript

See page 136 for more information.

Trigger an AppleScript script.

Audio CD Player

See page 115 for more information.

Play, pause, stop, eject, or skip to the next track on your audio CD.

Button

See page 97 for more information.

Select a button in an open dialog or window that you specify.
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Choosy

See page 121 for more information.

Switch your default printer.

Click

See page 98 for more information.

Replace a mouse click with a keystroke or other QuicKeys trigger.

Decision

See page 144 for more information.

Indicate how your Sequence should proceed when certain conditions are met.

DoScript

See page 137 for more information.

Trigger DoScript AppleEvents.

File Handler 

See page 80 for more information.

Rename, move, or change the attributes of selected files.

File Launch

See page 85 for more information.

Open applications and documents.

File Recall

See page 87 for more information.

Search for files modified within a specified amount of time.

FKeys

See page 101 for more information.

Trigger your Fkeys applications.

Folders

See page 89 for more information.

Switch between folders during the course of your computer work.

Use this QuicKeys Shortcut... If you want to automate these tasks...
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GoSub

See page 152 for more information.

Perform a user-defined Shortcut before proceeding with a Sequence.

Instant E-mail Action 

See page 127 for more information.

Send a selected file to a friend.

Open a message window that contains user-specified text.

Acknowledge QuickMail Pro notification.

Jump

See page 144 for more information.

Jump to another step in your Sequence.

Mac OS Specials

See page 101 for more information.

Turn balloon help on and off.

Switch to the next application listed in your application menu.

Start or stop File Sharing and program linking.

Menu

See page 103 for more information.

Select an item from a menu without using your mouse.

Message

See page 152 for more information.

Display a modal window during a Sequence. 

Mounty

See page 123 for more information.

Connect to or disconnect from a network volume.

Mousies

See page 105 for more information.

Close, zoom, and collapse windows.

Scroll through an open document.

Use this QuicKeys Shortcut... If you want to automate these tasks...
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Network Switcher

See page 125 for more information.

Switch between network configurations.

Pop-up Menu

See page 149 for more information.

Select an item in a pop-up menu.

Powerbook Specials

See page 107 for more information.

Spin down your hard drive.

Shut down your Powerbook.

Toggle backlighting and dimming.

Project Saver

See page 92 for more information.

Create and launch user-defined projects.

Real Time

See page 38 for more information.

Record your actions in “real time.“

Repeat

See page 151 for more information.

Replay a particular Shortcut in a Sequence.

Scrap Ease

See page 108 for more information.

Control QuicKeys’ version of the system clipboard.

Screen Ease

See page 110 for more information.

Change your screen settings for different monitors. 

Use this QuicKeys Shortcut... If you want to automate these tasks...
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Sequence

See page 139 for more information.

Display the Sequence Editor, which you can use to combine Shortcuts and 
recorded tasks.

Sound

See page 116 for more information.

Plays sound files.

SpeakEase

See page 116 for more information.

Set up your computer so it speaks user-specified words or phrases.

SpeakerChanger

See page 117 for more information.

Adjust the volume of your computer.

Specials

See page 111 for more information.

Shut down or restart your computer.

Select the rear window or second window on your desktop.

Open the QuicKeys Editor or the QuickReference Card.

Start or stop a Sequence or Real Time recording.

Insert single or double quickquotes.

Type Date/Time

See page 70 for more information.

Types the date and time in a specific format.

Type Text

See page 69 for more information.

Types text you specify.

Use this QuicKeys Shortcut... If you want to automate these tasks...
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View Switcher

See page 113 for more information.

Control the way you view open windows (e.g. in list form, arranged alphabetically).

Wait

See page 145 for more information.

Pause a Sequence until a particular condition has been met.

Web Launcher

See page 129 for more information.

Open a specified URL in your default Web browser.

Open selected text as a URL.

Display a list of Netscape Bookmarks or Internet Explorer Favorites.

Use this QuicKeys Shortcut... If you want to automate these tasks...
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WELCOME TO QUICKEYS

QuicKeys® for Macintosh™ is software that 
enables you to create custom keyboard actions, 
menu commands, and toolbars so you can 

perform routine tasks with a single mouse click or keystroke. 
The tasks that QuicKeys automates are called Shortcuts. 
QuicKeys Shortcuts are similar to macros, but are much easier 
to create. 

QuicKeys automates common computer tasks such as 
opening folders you frequently use or logging into your 
favorite database application. To create a QuicKeys Shortcut, 
you simply define the task you want to perform. You then 
replace the task with a trigger. Triggers  can be a keystroke, a 
QuicKeys toolbar, a timed trigger, or a QuicKeys icon. 

QuicKeys also provides you with a powerful and versatile 
recording function that is ideal for automating lengthy or 
complex tasks. Tell QuicKeys to watch your actions on the 
Mac and it can then play those actions back whenever you 
want. These recorded actions are called Sequences , and they 
can mimic virtually any multi-step task you complete on your 
computer.

QuicKeys toolbars make using your Shortcuts and Sequences 
easy. Toolbars work much like the toolbars you use in your 
other applications, except that you call the shots with 
QuicKeys toolbars. You specify what each toolbar button 
does, which icon is used, and when the toolbar is displayed. 
In other words, QuicKeys toolbars give you complete control. 
And, like the recording feature, toolbars save you time by 
making your interaction with your computer more efficient.

However you use it, QuicKeys’ powerful automation 
solutions enable you to assign particularly unrewarding, 
repetitive tasks to your computer so you have time for more 
important things.

WHAT QUICKEYS CAN DO FOR YOU
Think of something you do on a daily basis. Chances are 
QuicKeys can automate whatever task you thought of. For 
example, if you frequently switch between printers on your 
network, QuicKeys can do that for you with a single 
keystroke. You’ll save precious seconds each time you switch 
printers, which really adds up by the end of the week. 

QuicKeys can also perform multi-step tasks for you. For 
example, if you routinely change graphics from one format to 
another, direct QuicKeys to watch and record your actions as 
you complete the task, then assign a trigger that tells 
QuicKeys when  to repeat your actions. You will learn all about 
triggers later in this manual, but for now just think of triggers 
as the mouse clicks or keystrokes that communicate to 
QuicKeys that it’s time to start specific tasks. 

When you trigger a Shortcut, QuicKeys not only remembers 
and performs the steps required for that task, but it does so 
quickly and accurately. If you complete a task without error 
once, QuicKeys can replicate it thousands of times with no 
mistakes.

The time and frustration you can save are easy to measure. 
The real advantage of QuicKeys, however, is intangible. After 
you install and customize QuicKeys, your computer work 
flows more smoothly. Instead of working in one application 
and then spending valuable time searching for another, 
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applications and data appear and disappear automatically as 
they are needed. The different parts of your computer merge 
in ways that make sense to you so you can finally complete a 
day’s work in a day’s time. How many other applications do 
you know of that can add such value to your computing 
experience?

WHAT’S NEW IN QUICKEYS 4.0
Now that you have QuicKeys 4.0, you probably want to find 
out more about the new features it offers. This section 
acquaints you with all the new functionality in QuicKeys 4.0 
and points you to the sections of the User Guide that discuss 
how to take advantage of the new features.

INTERFACE CHANGES
The QuicKeys interface has been redesigned so it is easier and 
more intuitive to use. Chapter 4 of the QuicKeys User Guide 
discusses the QuicKeys interface in greater detail, but this 
section provides a general introduction to the changes made 
in version 4.

• There is now a Keysets tab that displays all your Shortcuts. 
You can view different Shortcut Sets in the Keysets tab by 
selecting different Sets from the Set pop-up menu. 

• A built-in toolbar has been added to the Editor so you can 
simply click a button to display the new Setup Assistant or 
print a Shortcut.

• The Define menu has been reorganized and renamed 
“Create” so it is easier to use.

• The icons for some Shortcuts have been improved so they 
are easier to recognize.

• The Process Swap plug-in has been renamed App 
Switcher.

• The Text plug-in has been renamed Type Text.

• Embedded toolbars are now called Docked toolbars.

Figure 1: The QuicKeys Editor.
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• The Filter palette has been moved to the bottom of the 
QuicKeys Editor. Click the Info  drop-down arrow to 
display it.

• The Extension Manager is now called the Plug-in Manager 
and QuicKeys extensions are now referred to as plug-ins.

• The Configure QuicKeys dialog has been updated and 
improved. 

• The Sequence Editor offers an icon toolbar rather than a 
menu bar, making it easier to modify Sequences. 

QUICKEYS ARCHITECTURE
If you’re upgrading from a prior version of QuicKeys, you 
will discover that you can now click outside the QuicKeys 
Editor while QuicKeys is active. When you click outside the 
Editor, the Editor is minimized to a small, floating window on 
your desktop called the QuicKeys palette. To re-open the 
Editor, click on the QuicKeys palette. To close the Editor, click 
the close box on the QuicKeys palette.

CONTEXTUAL MENUS
With Apple®’s release of OS 8.0, contextual menus made their 
debut on the Macintosh. QuicKeys takes advantage of the 
contextual menu technology in version 4.0 so you can speed 
up the process of creating Shortcuts. Using the contextual 
menu option, you can Control+click a file, folder, or string of 
text to create File Launch, Folders, Web Launch, or Type Text 
Shortcuts.

Figure 2: The Info pane of the QuicKeys Editor.

Figure 3: The Sequence Editor.

Figure 4: The QuicKeys Editor when it is minimized on your desktop.
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QUICKEYS SETUP ASSISTANT
The QuicKeys Setup Assistant was developed to lead users 
through the process of creating QuicKeys Shortcuts. To launch 
the Setup Assistant, select Setup Assistant  from the QuicKeys 
menu and answer the questions in each consecutive panel that 
appears. 

QUICKEYS TOOLBARS
Another significant change in QuicKeys 4.0 is increased 
toolbar functionality. A collection of new features make the 
toolbars an invaluable asset to your QuicKeys experience. 
Read Chapter 6 of the User Guide for more detailed 
information about QuicKeys toolbars.

• Some toolbar buttons now offer a pop-up arrow you can 
use to display a menu of plug-in related options.

• You can Control+click the title bar or an area of the 
QuicKeys toolbar that does not contain a toolbar button to 
display a contextual menu for the toolbar.

• You can Control+click a QuicKeys toolbar button to 
display a contextual menu for editing the selected button.

• Drag a file, folder, or selected text to an existing toolbar 
button to add a File Launch, Folders, or Type Text Shortcut 
to the toolbar.

• Drag a file or folder to a File Handler or Folders button on 
your toolbar and select the action you want performed in 
the drop-down window that appears.

Figure 5: The QuicKeys Setup Assistant.

Figure 6: The toolbar pop-up menu for the Change Folder plug-in.

Figure 7: The drop-down window for the File Handler 
toolbar button.
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• The numbers 0-9 display on Click-N-Go toolbars so you 
know which number to press on your keyboard to trigger 
Shortcuts in the corresponding position.

• You can now use the QuicKeys toolbar contextual menu to 
change the attributes of toolbars. New attribute choices 
include large or small button icons, button titles, and large 
or small fonts for button titles.

• You can now clean up icons on your toolbar by selecting 
Clean Up Buttons  in the contextual toolbar menu.

• For Universal-scope toolbars, you can use the contextual 
toolbar menu to choose whether or not you want your 
toolbar to always remain on top of other open windows.

NEW PLUG-INS
QuicKeys 4.0 offers a suite of new plug-ins that further extend 
your productivity potential. These plug-ins are discussed 
throughout the manual, so look in the User Guide index to 
find out where you can read more about these plug-ins.

• Advanced Text Tools—Use this plug-in to create Shortcuts 
that reformat text; quote text; remove quotes from text; 
change text to uppercase, lowercase, or title case; or cipher 
and decipher text.

• Audio CD Player—Use this plug-in to create Shortcuts 
that enable you to play, stop, pause, skip tracks, adjust 
volume, and eject your CDs in your CD-ROM drive.

• File Handler—Use this plug-in to create Shortcuts that 
enable you to lock, unlock, rename, move, or modify the 
type and creator of selected files.

• File Recall—Use this plug-in to create Shortcuts that 
search your local drives for files modified within a user-
defined period of time.

• Instant E-mail—Use this plug-in to create Shortcuts that 
automate your E-mail tasks.

• Network Switcher—Use this plug-in to create Shortcuts 
that switch between different network settings, making it 
easy to plug into different network environments.

• Password Vault—Use this plug-in to create Shortcuts that 
store your passwords safely.

• Project Saver—Use this plug-in to create Shortcuts that 
keep track of all the files in your current projects.

• View Switcher—Use this plug-in to create Shortcuts that 
make your Macintosh look the way you want on a per-
folder basis.

• Web Launcher—Use this plug-in to create Shortcuts that 
launch your favorite Web sites.

Figure 8: A Click-N-Go toolbar.
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USING THE QUICKEYS USER GUIDE
Read this section to learn how the QuicKeys instructions are 
organized and to become acquainted with the conventions 
used in this manual. Knowing how the manual is set up will 
help you use it more efficiently.

ORGANIZATION
Chapters 1–6 of this manual introduce QuicKeys and guide 
you through basic concepts necessary to operate the software. 
The remaining chapters of the manual contain reference 
material for using each of the QuicKeys plug-ins available in 
the Create menu. Use the index to locate specific information 
and use the table of contents to become acquainted with the 
organization of each chapter of the manual. A glossary is 
located on page 199 if you need assistance with an unfamiliar 
term.

ASSUMPTIONS
This documentation assumes you are familiar with the 
Macintosh operating system and accompanying hardware. If 
you need assistance with standard Macintosh procedures, 
consult the documentation that came with your computer. 

CONVENTIONS

• A right-arrow character (>) indicates the hierarchy of 
menu and submenu options.

• The first time a QuicKeys-specific term is used, it is 
displayed in italics .

• When you must type text or select specific options, the 
options appear in Helvetica font. For example, select Print 
from the File menu.

• A ❖ symbol indicates a note that provides supplemental 
information about the topic being covered.

• A ▲ symbol indicates an important statement that requires 
special attention.

• A ! symbol indicates a warning that should be read before 
continuing to operate the component being discussed.

• Variable text is contained within opposite-facing arrow 
characters. For example, look in the <hard drive>:System 
Folder:Preferences: folder for the file.

CONTACTING CE SOFTWARE
If you have questions about QuicKeys that are not addressed 
in the manual, use this section to learn how to contact CE 
Software™.

TECHNICAL SUPPORT
CE Software offers online, fax, and telephone support. Visit 
the Technical Support Web page at http://help.cesoft.com/ for 
information about the various support options.

Contact Information
The Technical Support Department is available Monday 
through Friday from 8:00 A.M. to 5:00 P.M. Central Time. CE 
Software Technical Support can be reached by:

• Phone: 515-221-1803

• Fax: 515-221-1806

• Web page: http://help.cesoft.com/ 

• E-mail: ceonline@cesoft.com

Before You Call
Check the following Web sites for technical information:

• Have you checked the QuicKeys Web site for updates and 
product information at http://www.quickeys.com/

• Have you checked the CE Software Technical Support Web 
page or newsgroups at http://help.cesoft.com/
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When You Call
To help our Technical Support team assist you as quickly as 
possible, please have the following information available 
when you speak with, or write to, a Technical Advisor:

• Product name and version (e.g.  QuicKeys 4.0)

• Computer type and model (e.g.  Macintosh G3)

• Operating system and version (e.g.  Mac OS 8.5)

PRODUCT FEEDBACK
What do you think of QuicKeys? We want to know and we 
encourage you to submit your ideas to feedback@cesoft.com  so 
we can consider them for the next version of QuicKeys.

USER GUIDE FEEDBACK
We also welcome feedback about the documentation that 
accompanies QuicKeys. Please E-mail us at 
manuals@cesoft.com with your comments and suggestions.

The most current version of this manual is available online at 
http://www.cesoft.com/  and can be viewed with Adobe® Acrobat 
Reader 3.0 or greater. Visit http://www.adobe.com/  to download a 
free copy of Acrobat Reader.

SALES AND CUSTOMER SERVICE 
CE Software’s Sales and Customer Service staff can answer 
your questions about product availability, upgrades, product 
prices, damaged disks, customer registration, and general 
policies. 

Contact Information
The CE Software Customer Service department is open 
Monday through Friday from 8:00 A.M. to 5:00 P.M. U.S. 
Central Time. If you have a question about your CE Software 
product, please have your serial number ready when you call. 
For customers outside the U.S., please contact your local 
distributor.

• Phone: Domestic orders 800-523-7638

• International orders: 515-221-1801

• Fax: International and Domestic orders 515-221-2258

• Online: http://www.cesoft.com/service/cshome.html

Ownership Transfer
If you transfer ownership of a CE Software product, please    
E-mail us at sales@cesoft.com or send a letter with the product 
name, serial number, your name, and the new owner’s name 
and address to:

CE Software, Inc.
Attn: Ownership Transfer
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.

Change of Address
If you change your address, please E-mail us at 
sales@cesoft.com or send a letter indicating your old and new 
address to:

CE Software, Inc.
Attn: Change of Address
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.
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CHAPTER 2

• • • • • •
INSTALLING AND OPENING QUICKEYS

The steps involved in getting started with QuicKeys include 
making sure your computer meets specific requirements, 
installing QuicKeys on your hard disk, and opening the 
QuicKeys Editor. This chapter explains how to accomplish 
these tasks.

SYSTEM REQUIREMENTS
The minimum requirements your computer must meet to 
install and operate this product include:

• Macintosh-compatible running OS 8.0 or greater (OS 8.5 
recommended).

• A PowerPC™ processor. 

• 16 megabytes (MB) of RAM (32 MB recommended).

• One CD-ROM drive.

• At least 8 MB of available hard disk space.

• Some QuicKeys plug-ins require an Internet connection.

INSTALLING QUICKEYS
 ▲ CE Software strongly recommends that you disable your 

non-system extensions and anti-virus software before 
installing QuicKeys. If you are upgrading QuicKeys, see 
page 10 for additional recommendations.

To install QuicKeys:

1. Insert the QuicKeys CD into your computer’s CD-ROM 
drive. 

2. Double-click the QuicKeys installer that appears on your 
desktop. A QuicKeys logo window appears.

3. Click Continue .

4. Read the ReadMe file that appears and click Continue .

5. Read the license and warranty agreement that appears. 
Click Agree if you agree to the terms and want to proceed 
with installation. A registration dialog appears.

Figure 9: The QuicKeys logo window appears during installation.
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6. Type your name, company name, and activation key at the 
prompt. Your activation key is located on your registration 
card. If you do not have an Activation Key, choose the 
Install 30 day demo option.

7. Click OK when you are finished.

8. At the prompt, choose whether you want to use the Easy  or 
Custom  installation. Custom installation enables you to 
install the minimum files necessary to run QuicKeys on 
your computer.

9. A prompt appears alerting you that you must restart your 
computer to proceed with installation. Click Yes to 
proceed. A status window tracks the progress of the 
installation process. 

10.When installation is complete, click the Restart button at the 
prompt.

THE INSTALLED QUICKEYS TOOLBAR
After you restart your computer, a QuicKeys toolbar appears 
on your desktop. Use the toolbar to become acquainted with 
QuicKeys toolbars and Shortcuts. See Chapter 6 for detailed 
information about toolbars. 

Clicking the default toolbar buttons, from left to right 
respectively, triggers the following tasks.

UPGRADING QUICKEYS
The procedure for upgrading QuicKeys is similar to the 
procedure for installing a new copy of QuicKeys. The main 
difference between first-time installations and upgrades is CE 
Software’s recommendation to back up previous Shortcuts. 
See the next section for more information on backup 
procedures. 

Figure 10: The QuicKeys registration dialog.

• Open the 
QuicKeys Editor.

• Play CD.

• Display the CE 
Software Web site.

• Lock selected files.

• Type Date. • View current 
window as a list.

• Display the 
previous application.

• Open Recent Files.

Figure 11: This toolbar appears by default after installing QuicKeys.
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During installation, the installer replaces old QuicKeys 
components and plug-ins (extensions) with new components 
and plug-ins. If you have QuicKeys plug-ins on your 
computer from prior installations and those plug-ins are no 
longer installed with QuicKeys, the installer leaves them on 
your computer.

 ▲ The CE Toolbox extension has not been installed since 
QuicKeys 3.5; however, it is not removed when you 
upgrade because other software packages may use it. 
Keep CE Toolbox installed only if you use Alarming 
Events™, DiskTop™, In/Out™, or QM Server™. If you 
do not use any of these applications, remove CE Toolbox 
prior to running the installer.

EXPIRED DEMOS
If you chose to install the demo the first time you installed 
QuicKeys, you will eventually see a prompt that tells you 
your demo has expired. When you see this prompt, you have 
two options: you can purchase a full version of QuicKeys or 
you can delete QuicKeys from your hard drive.

To turn a demo installation into a non-expiring installation, 
click the Register button when you see the expiring demo alert 
and enter the serial key at the prompt. If you do not want to 
wait until you see the expiring demo alert, simply install your 
newly-purchased QuicKeys software and enter the activation 
key at the prompt.

OPENING THE QUICKEYS EDITOR
By default, QuicKeys places an icon in the menu bar of your 
screen during installation. The menu that appears when you 
click this icon is called the QuicKeys menu. Use this menu to 
open the QuicKeys Editor.

To open the QuicKeys Editor:

1. Click the QuicKeys icon in the menu bar. The QuicKeys 
menu appears.

2. Select QuicKeys Editor  to display the QuicKeys Editor. See 
page 21 for more information on the QuicKeys Editor.

BACKING UP SHORTCUTS
CE Software recommends backing up your QuicKeys Folder 
when you upgrade or as part of your routine data backups. 
Backing up your entire QuicKeys Folder enables you to 
archive every piece of QuicKeys data such as Shortcuts, 
Sequences, toolbars, preferences, and Scrap Ease clips.

To back up the QuicKeys Folder:

1. Navigate to the QuicKeys Folder. It is located in the 
:System Folder:Preferences: folder on your startup disk.

2. Copy the QuicKeys Folder to another drive or to 
removable media. Your QuicKeys backup is complete 
when the folder has been copied.

Figure 12: The QuicKeys menu.
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 ▲ CE Software does not  recommend copying only the 
Keysets folder to archive your Shortcuts and Sequences. 
The link between the Keysets folder and the Sequences 
folder may not be preserved, making your Sequences 
unusable. 

FILES INSTALLED BY QUICKEYS
Use this section to learn where files are placed when you 
install QuicKeys. QuicKeys also offers some example 
Shortcuts and Sequences on the QuicKeys CD.

STARTUP DISK
<Startup Disk>:QuicKeys:QuicKeys Setup Assistant, 

QuicKeys License Agreement, QuicKeys 
ReadMe, What’s New in 4.0

<Startup Disk>:QuicKeys:Utilities:QuicKeys Registration, QK 
Plug-in Manager

SYSTEM FOLDER
<Startup Disk>:System Folder:Control Panels:QuicKeys

<Startup Disk>:System Folder:Preferences:QuicKeys Folder: 
Omitted File List, Toolbar Icons

<Startup Disk>:System Folder:Preferences:QuicKeys 
Folder:Extensions: 

<Startup Disk>:System Folder:Preferences:QuicKeys 
Folder:Backgrounders:QuicKeys 
Backgrounder

<Startup Disk>:System Folder:Contextual Menus:QuicKeys 
CM Plug-in

• Advanced Text Tools
• Advanced Text Tools 

Helper
• Alias Keystroke
• App Switcher
• Apple Events
• AppleScript
• AppleScript Helper
• Audio CD Player
• Batch Processor
• Button
• Choosy
• Click
• Date & Time
• Decision
• DoScript
• File Handler
• File Handler Helper
• File Launch
• File Recall
• File Recall Helper
• FKeys
• Folders
• GoSub
• Instant E-mail
• Instant E-mail Helper
• Jump
• Mac OS Specials

• Menu
• Message
• Message Helper
• Mounty
• Mousies
• Network Switcher
• Password Vault
• Pause
• Pop-up Menu
• PowerBook Specials
• Project Launcher
• Project Saver
• QK AppleEvent 

Helper
• QT Movie
• Repeat
• Scrap Ease
• Scrap Ease Helper
• Screen Ease
• Sound
• Speak Ease
• SpeakerChanger
• Specials
• Type Text
• View Switcher
• Wait
• Web Launcher
• Web Launcher Helper
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CHAPTER 3

• • • • • •
QUICKSTART

This chapter is designed to get you started using QuicKeys as 
quickly and easily as possible. Use the glossary or index at the 
back of this User Guide to look up any concepts or terms you 
do not understand in this chapter.

SHORTCUTS AND SEQUENCES
Shortcuts and Sequences are the foundation of QuicKeys. 
QuicKeys Shortcuts  automate simple one-step tasks, such as 
choosing a network printer. QuicKeys Sequences  automate 
longer, more complicated multi-step tasks, such as launching 
a database application, searching for a specific item, and 
printing out the selected database records. Some Shortcuts are 
created using the Setup Assistant, but the majority of 
Shortcuts are created using the Shortcut Properties dialog. 

USING QUICKEYS
QuicKeys is a powerful software tool you can use to automate 
your computer. It’s a tool, however, that is only as effective as 
you make it. Once you install QuicKeys, start making a 
mental note of the tedious, routine tasks you perform on your 
computer and earmark those tasks for some attention from 
QuicKeys. Each time you think of something that QuicKeys 
could make easier for you, create a Shortcut or Sequence that 
automates that task or series of tasks.

When you create a QuicKeys Shortcut or Sequence, you can 
choose the trigger that launches it. In other words, you need 
to specify the “signal” that tells QuicKeys when  to perform the 
Shortcut or Sequence. For example, if you want QuicKeys to 
open a database application and enter the current date and 
time, you need to tell QuicKeys when to begin. You can use a 
keystroke (such as F5), or a number of other available 

QuicKeys triggers (such as toolbars, the QuicKeys menu, or 
timed triggers) to communicate with QuicKeys that you want 
to begin the Shortcut or Sequence. It’s kind of like having a 
personal assistant inside your computer that understands a 
language of triggers you  choose.

That’s all there is to using QuicKeys: thinking of tasks to 
automate, creating QuicKeys Shortcuts or Sequences to 
replace those tasks, and triggering the tasks. You spend a few 
minutes telling QuicKeys what you want, but from that point 
on you save hours, days, maybe even weeks with a Shortcut 
or Sequence that only took you a couple of minutes to set up. 
It’s a pretty good return for a small investment of time. In fact, 
after using QuicKeys for a few weeks, you will probably be 
amazed when you recall how much of your day was once 
spent searching through folders, rearranging windows on 
your desktop, or clicking the same options in countless 
windows.

YOUR FIRST SHORTCUTS
This section guides you through the process of creating your 
first QuicKeys Shortcuts from beginning to end. First, you 
create a Type Text Shortcut using the QuicKeys Setup 
Assistant. Then, you create a File Launch Shortcut using the 
QuicKeys Shortcut Properties dialog. 
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SETTING UP A TYPE TEXT SHORTCUT

1. Select Setup Assistant  from the QuicKeys menu.

2. Read the first Setup Assistant panel and click the right 
arrow button.

3. Select the Text Tools option and click the right arrow 
button.

4. Select Type Text from the list of available plug-ins and click 
the right arrow button.

5. Type the text you want QuicKeys to type for you in the text 
field and click the right arrow button.

Figure 13: The Setup Assistant can be 
opened from the QuicKeys 
menu.

Figure 14: The Setup Assistant prompts you for text if you are 
setting up a Type Text Shortcut.
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6. Type the name of the Shortcut in the Name box. For 

example, name this Shortcut “Signature Line.”

7. Select the Show in QuicKeys menu  check box so you can 
trigger this Shortcut from the QuicKeys menu.

8. Click the right arrow button to continue to the next Setup 
Assistant panel.

9. Click the Create Shortcut button to build this Type Text 
Shortcut and click the right arrow button.

10.Click Continue  in the final Setup Assistant panel to create 
additional Shortcuts or click Quit to close the Setup 
Assistant.

Triggering Your Type Text Shortcut
To use the Type Text Shortcut you just created, launch a text 
editor or word processing application, such as SimpleText or 
Microsoft® Word. Position your cursor in the document 
window that appears and select your Type Text Shortcut from 
the QuicKeys menu. Your signature line is instantly typed into 
the open document.

 ▲ When the QuicKeys Editor is visible, you are in “edit 
mode.” This means that you cannot trigger QuicKeys 
Shortcuts or use QuicKeys toolbars until you close the 
Editor.

SETTING UP A FILE LAUNCH SHORTCUT

1. Select QuicKeys Editor  from the QuicKeys menu in the upper 
right corner of your screen.

2. In the QuicKeys Editor, click the Keysets tab.
Figure 15: Specify a name and a trigger for your Shortcut in this 

panel of the Setup Assistant.

Figure 16: Click the Keysets tab in the QuicKeys Editor.
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3. Select Create  > File Tools  > File Launch .

4. In the standard Open window that appears, navigate to 
where SimpleText resides on your hard drive, select 
SimpleText, and click the Select “SimpleText” button. The 
Shortcut Properties dialog appears with SimpleText 
selected as the target file to launch. 

5. Position your cursor in the Keystroke box and press the 
key combination you want to use to trigger this Shortcut. 
For example, press the Shift key and the F10 key 

simultaneously.The name of the file you selected appears 
in the File field. 

6. Click OK when you are finished.

Your new SimpleText Shortcut immediately appears in the 
Keysets tab. 

Triggering Your File Launch Shortcut
If SimpleText is not currently open, press Shift+F10. 
SimpleText immediately launches.

See page 40 for more information on Shortcut triggers.

Figure 17: Navigate to the file you want to launch and click 
Open. Figure 18: The File Launch Shortcut Properties dialog.
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YOUR FIRST TOOLBAR

In this section, you create a QuicKeys toolbar that provides 
you with another way of triggering the Shortcuts you created 
in the previous section of this chapter.

1. Open the QuicKeys Editor.

2. Click the Toolbars tab in the Quickeys Editor.

3. Click the New  button in the Toolbars tab to create a new 
QuicKeys toolbar.

4. Type a name for the QuicKeys toolbar at the prompt and 
click OK. The new toolbar appears on your desktop and the 
toolbar name is listed in your Toolbars tab.

5. Drag your File Launch and Type Text Shortcuts from the 
Shortcuts list in the Toolbars tab to the QuicKeys toolbar 
displayed on your desktop.

6. Close the QuicKeys Editor. Your toolbar remains on your 
desktop. Click a button on your toolbar when you want to 
trigger the Shortcut represented by that button.

YOUR FIRST RECORDINGS
In this section, you use QuicKeys’ recording feature to record 
single-step and multi-step tasks.

SINGLE-STEP SHORTCUTS

1. Select Finder  from the application menu in the menu bar. 

2. Select Record One Shortcut  from the QuicKeys menu.

3. Select Page Setup  from the Finder’s File menu. Immediately 
after the Page Setup dialog displays, QuicKeys displays a 
Menu Shortcut Properties dialog pre-filled with your menu 
selection.

Figure 19: Type a name for your toolbar at the 
prompt.

Figure 20: If you completed all the steps provided thus 
far in this chapter, your first toolbar should 
look like this illustration.
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4. Assign a keystroke to your new Shortcut and click OK.

You just created a keystroke that opens the Page Setup dialog 
without having to know which QuicKeys Shortcut to use. 
That’s just one of the advantages of using the QuicKeys’ 
recording feature.

RECORDING MULTI-STEP SHORTCUTS
Multi-step Shortcuts, or Sequences, are more complicated 
than Shortcuts because they require planning. The example 
used in this section is relatively simple, but the power and 
flexibility of QuicKeys Sequences is almost limitless once you 
understand how to use them.

In this example, you create a Sequence that logs into your 
E-mail account. This example uses QuickMail™ Pro as the E-
mail client, but you can adapt the instructions to whatever E-
mail software you are using.

5. Launch QuickMail Pro.

6. Select Record Sequence  from the QuicKeys menu. If you are 
using the default QuicKeys preferences, a recording 
toolbar appears.

7. Type your E-mail password at the prompt.

8. Press your Return  key on your keyboard to select the OK 
button in the login screen. The main mail window appears.

9. Select Stop Recording  from the QuicKeys menu.

10.The Sequence Editor appears. Type a name for your 
Sequence in the Name  box.

11. Position your cursor in the Keystroke  box and press the keys 
you want to use to trigger this Shortcut. For example, press 
Command+Control+F5.

12.Click OK when you are done. The Sequence Editor 
disappears, leaving the QuicKeys Editor open on your 
desktop.

13.Make sure your new E-mail Sequence is part of the 
Universal Set. If it’s in another Set, use the cut/paste 
function to move it to the Universal Set.

FINE-TUNING YOUR SEQUENCE
This particular Sequence requires some modifications when 
recording is complete. You must first replace the Type Text 
Shortcut with a Password Vault Shortcut to keep your 
password secure. Then, you must add two User-timed Pause 
steps to your Sequence to make sure your Sequence waits for 
the E-mail password.

Figure 21: The recording palette.

Figure 22: The Sequence Editor.
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To replace the Type Text Shortcut with a Password Vault 
Shortcut:

1. Open your E-mail Sequence.

2. Position the insert arrow above the Type Text step and 
select Create > Sequence Tools  > Password Vault .

3. Type your E-mail password in the Password  box of the 
Shortcut Properties dialog that appears and click OK. The 
Password Vault Shortcut appears as a step in your 
Sequence.

4. Select the Type Text step in the Sequence that types your 
password and click the trash icon to delete it. The 
Password Vault Shortcut has now replaced the Type Text 
Shortcut in your Sequence, making your password more 
secure.

To add a User/Timed Pause to your Sequence:

1. Open your E-mail Sequence.

2. Position the insert arrow above the Password Vault step.

3. Select Create  > User/Timed Pause .

4. Choose to pause for 1.0 second and click OK.

This Sequence may be not be applicable to all QuicKeys users, 
but it’s a good illustration of how Sequences can help you in 
your everyday work. For tips on how you can ensure 
successful Sequences during a QuicKeys recording, see 
page 143.

EDITING A SHORTCUT
To edit QuicKeys Shortcuts:

1. Open the QuicKeys Editor and select the Shortcut you 
want to modify. 

2. Double-click the Shortcut or press Command+M to display 
the Shortcut Properties dialog. 

3. Make changes in the Shortcut Properties dialog and click 
OK when you are finished.

DELETING A SHORTCUT
To delete QuicKeys Shortcuts:

1. Open the QuicKeys Editor and select the Shortcut you 
want to delete. 

2. Select Delete from the Edit menu. 

3. Select the Delete button at the prompt if you are certain you 
want the selected Shortcut removed from your keyset. 

 ▲ There is no “Undo” function when you choose to delete 
a Shortcut.

Figure 23: Type the password you want to keep secure in the Password 
box.
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CLOSING QUICKEYS
To close the QuicKeys Editor, you can either click the Editor’s 
close box or select Close from the File menu. If you click 
outside the Editor, the Editor will be replaced by a minimized 
QuicKeys palette (shown in Figure 24) that remains active 
while you work in other applications. 

Click the QuicKeys palette to re-open the QuicKeys Editor.  

Figure 24: The QuicKeys palette appears when you click outside the 
QuicKeys Editor.
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CHAPTER 4

• • • • • •
QUICKEYS OVERVIEW

Part of understanding any piece of software requires knowing 
its different components and how they fit together. This 
chapter provides an overview of the QuicKeys architecture. 
Reviewing this chapter will acquaint you with the capabilities 
of QuicKeys so you can take full advantage of the software’s 
power and flexibility.

THE QUICKEYS EDITOR
Use the QuicKeys Editor as your control center for creating, 
modifying, and deleting Shortcuts and Sequences. Open the 
QuicKeys Editor by selecting QuicKeys Editor from the QuicKeys 
menu in the menu bar or by pressing the 
Option+Control+Return keys simultaneously. 

The QuicKeys Editor has five parts that display when the 
Editor is opened: the Keysets tab, the Toolbars tab, an 
information pane, a built-in toolbar, and a menu bar. By 
default the QuicKeys Editor displays the Keysets tab.

When the QuicKeys Editor is visible, you are in “edit mode.” 
This means that you cannot trigger QuicKeys Shortcuts or use 
QuicKeys toolbars until you close the Editor.

The QuicKeys Editor Tabs

Figure 25: View all your Shortcuts and their properties from the Keysets tab, 
shown on the left. Create, edit, and delete toolbars from the 
Toolbars tab, shown on the right.
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THE KEYSETS TAB
When you click the Keysets tab, all of your Shortcuts display. 
You can create, edit, or delete your Shortcuts from this central 
location. 

• Double-click a Shortcut in the Keysets tab to display the 
Shortcut Properties dialog where you can edit the Shortcut.

• Click a column heading to choose how you want your list 
of QuicKeys Shortcuts sorted.

• Type the first few characters of a Shortcut name to select a 
particular Shortcut. This feature is commonly referred to as 
the “Type To” function.

• Click in the Keystroke column and press the keystroke you 
want to use to trigger the selected Shortcut.

• When the Keysets tab is selected, the Create menu is 
available. The Create menu can be used as the starting point 
for creating all your QuicKeys Shortcuts. 

• Use the Set menu to specify the range of operation for a 
particular Shortcut. For example, you can create a Type 
Text Shortcut that only works in your E-mail application.

• Click an icon in the QuicKeys’ built-in toolbar to launch 
the Setup Assistant, display the Plug-in Manager, cut, copy 
paste, or print.

• Click in the QuicKeys comment column to write a note to 
yourself or another user about the selected Shortcut. 

The Sets Pop-Up Menu
Specify which Shortcuts and Sequences are visible in the 
Keysets tab by choosing which QuicKeys Set you want to 
view. A QuicKeys Set is a collection of Shortcuts and 
Sequences that function in a specific context. For example, 
Shortcuts in the Finder Set only work when the Finder is the 
active application. 

The ability to separate your Shortcuts into Sets is invaluable 
because it helps you organize what would otherwise be an 
endless list of QuicKeys Shortcuts. Additionally, Sets enable 
you to use the same keystroke for different Shortcuts. You can 
read more about QuicKeys Sets on page 45.Figure 26: Use the Keysets tab to view, create, or edit your Shortcuts.
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Click the Info arrow 
to display the 
Shortcuts filter.
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Shortcut Options
There are three columns in the QuicKeys Editor you can use to 
quickly change the attributes for a selected QuicKeys 
Shortcut: the QuicKeys menu column, the timed triggers 
column, and the comment column. 

• When you click in the QuicKeys menu column, the 
corresponding Shortcut is immediately accessible from the 
QuicKeys menu.

• When you click in the timed trigger column, the Timer 
Options dialog shown in Figure 58 on page 40 displays. 
When you close the Timer Options dialog, the selected 
Shortcut is immediately set to be triggered at the time you 
specified.

• When you click the QuicKeys comment column, a 
Comment dialog appears. Type information you want to 
keep with the selected Shortcut and click OK. Display the 

comment by clicking on the comment icon in the QuicKeys 
Editor. 

THE TOOLBARS TAB
When you click the Toolbars tab, you see a list of all your 
QuicKeys toolbars. Toolbars have buttons that represent 
specific tasks on the computer. Many applications provide 
toolbars that perform functions, such as printing, when you 
click the standard Print icon. QuicKeys toolbars are different, 
however, because you  specify the appearance and 
functionality of the toolbar.

Click in one of these columns to 
quickly set up additional options 
for individual Shortcuts.

Figure 27: You can set up certain Shortcut attributes directly in the 
QuicKeys Editor.

Figure 28: This dialog appears when you click in a cell of the Comment 
column in the QuicKeys Editor.
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Toolbars are a valuable asset if you have created several 
QuicKeys Shortcuts. They provide a quick and easy way of 
triggering your Shortcuts. You don’t have to remember a 
keystroke and you don’t have to fill up your QuicKeys menu 
if you use toolbars to trigger at least some of your Shortcuts. 

• Click the New button to create a new toolbar.

• Drag Shortcuts from the Shortcut area of the Toolbars tab 
to the active toolbar to create toolbar buttons.

• Click a toolbar listed in the Toolbars tab of the QuicKeys 
Editor to make that toolbar active on your desktop. When 
a toolbar becomes active, you can edit, delete, or rename it.

• Select a toolbar from the Toolbars list to make the Toolbar 
Options area of the Toolbars tab active.

• See Chapter 5 for more detailed information about 
toolbars.

THE QUICKEYS INFO PANE
When you click the Info arrow at the bottom of the QuicKeys 
Editor, an additional pane of information appears. The 
information includes a Shortcuts filter, your name, your 
QuicKeys buffer status, and the number of Shortcuts that 
reside in the displayed Set. 

Shortcuts Filter
Each button on the Shortcuts filter represents a type  of 
QuicKeys plug-in. By default, all buttons in the filter list are 
selected. However, when you click one of the buttons in the 
filter list, the Shortcuts represented by that plug-in no longer 
appear in the QuicKeys Editor. This feature enables you to 
filter which Shortcuts are shown or hidden in the QuicKeys 
Editor.

Figure 29: Use the Toolbars tab to create, edit, or delete toolbars.

Shortcuts you can 
drag to toolbars.

QuicKeys 
Toolbars 
pane

Toolbar 
Options 
pane

Set 
Menu

Figure 30: When you click the Info arrow at the bottom of the QuicKeys 
Editor, this information pane appears. In this illustrations, all 
the buttons are pressed (or shaded), so all plug-ins are 
displayed in the QuicKeys Editor.
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Clicking the corresponding icon in the Shortcuts Filter 
controls whether the following plug-ins are displayed in the 
QuicKeys Editor.

Click Show All to display all  the Shortcuts you have created in 
the QuicKeys Editor Shortcut list. Click Show None and select a 
plug-in button in the Shortcuts filter to show only the 
Shortcuts created by the selected plug-in.

Standard Plug-ins
There are two types of QuicKeys plug-ins: Built-in plug-ins 
and Standard plug-ins. The main difference between the two 
types of plug-ins is that Built-in plug-ins cannot be turned off. 
Built-in plug-ins include: Alias Keystroke, Button, Click, 
FKeys, Menu, Mousies, Specials, and File Launch.

When the Standard plug-ins button is selected (shaded) in the 
Shortcuts filter, all Shortcuts created with Standard plug-ins 
appear in the QuicKeys Editor. 

Buffer
The Buffer status bar indicates how much memory you are 
using for Shortcuts based on the memory you set aside in the 
Configure QuicKeys dialog. See page 47 for more information.

• Alias Keystroke • Standard plug-ins

• Button • Specials

• Menu • File Launch

• Click • Type Text

• Mousies • FKeys

• Date/Time • Real Time

• Sequence
Figure 31: The System Tools and File Tools submenus are divided into 

two sections. The top section indicates plug-ins that are 
built into QuicKeys. The bottom section indicates plug-ins 
that use the standard plug-in architecture. 

Built-in 
plug-ins

Standard 
plug-ins
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QUICKEYS BUILT-IN TOOLBAR
Some applications have a built-in toolbar in the main window 
that enables you cut, copy, and paste with a click of your 
mouse. QuicKeys’ built-in toolbar includes these functions as 
well as two QuicKeys-specific buttons. 

 ▲ Do not confuse QuicKeys’ built-in toolbar with the 
custom toolbars you can create with the QuicKeys—the 
built-in toolbar is part of the interface and cannot be 
edited while QuicKeys toolbars only exist if you  create 
them or QuicKeys installs them.

Setup Assistant Button
The Setup Assistant button launches the Setup Assistant. The 
Setup Assistant guides you through the process of setting up 
QuicKeys Shortcuts. It is an excellent tool for users who are 
new to QuicKeys or any of the QuicKeys plug-ins.

You can use the Setup Assistant to create the following 
Shortcuts:

Setup 
Assistant

Plug-in 
Manager

Cut, Copy, 
Paste, Print

Figure 32: The built-in QuicKeys Editor 
toolbar.

The About 
box display

• Choosy • Type Date/Time

• File Launch • Folders

• Mac OS Specials • Menu

• Mousies • SpeakerChanger

• Specials • Advanced Text Tools

• Type Text

The Setup Assistant button.

Figure 33: Click the Setup Assistant button in the QuicKeys Editor to 
launch the Setup Assistant.
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Plug-in Manager Button
QuicKeys plug-ins (formerly known as QuicKeys extensions) 
can be turned on or off individually using the Plug-in 
Manager. You may want to disable individual Shortcuts if you 
cannot use some of the functionality available in QuicKeys. 
For example, if you do not have Internet access, you may 
want to turn off the Web Launcher Shortcut to streamline your 
Shortcut options and reduce the amount of memory QuicKeys 
uses. See page 51 for more information on the Plug-in 
Manager.

Figure 34: Use the Setup Assistant if you want to be guided through 
the process of creating Shortcuts. 

Figure 35: The Plug-in Manager button is located in the QuicKeys 
Editor’s built-in toolbar.

The Plug-in Manager button

Figure 36: This dialog appears when you click the Plug-in Manager 
button. Use the Plug-in Manager to turn plug-ins on and off. 
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Cut, Copy, Paste, and Print Buttons
A group of buttons in the built-in QuicKeys toolbar are 
standard Macintosh toolbar buttons. You can use them to cut, 
copy, paste, or print Shortcuts and Sequences.

QuicKeys About Button
The button on the end of the application toolbar looks like the 
QuicKeys logo. When you click this button, the QuicKeys 
About box appears. Open the About box for distributor and 
contact information.

THE QUICKEYS MENU BAR
The QuicKeys Menu bar offers four different menus: File, 
Edit, Create, and Options. The QuicKeys-specific menu items 
are discussed later in this manual, but this section provides a 
brief description of each option.

File Menu
The File menu contains your standard Macintosh options 
along with some QuicKeys-specific items.

Figure 37: Clicking the cut, copy, paste, and print buttons in the QuicKeys 
Editor is often quicker than selecting the same options from the 
File and Edit menus.

Figure 38: Click the QuicKeys logo in the QuicKeys Editor to view the About 
box.

Figure 39: Control QuicKeys with the menu items available in each QuicKeys 
Editor menu.

The QuicKeys menu bar

Figure 40: The QuicKeys Editor File menu
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New Set
Creates a custom Set of QuicKeys Shortcuts and Sequences. 
See page 45 for more information.

Open Set
Opens a user-created QuicKeys Set of QuicKeys Shortcuts and 
Sequences. See page 45 for more information.

Close Set
Closes the selected user-created QuicKeys Set. See page 45 for 
more information.

Delete Set
Deletes the selected user-created QuicKeys Set. See page 45 
for more information.

Save Set
Saves the selected Set of QuicKeys Shortcuts and Sequences to 
a location you specify. See page 45 for more information.

Make Icon
Creates a Finder icon for the selected Shortcut so you can 
launch the Shortcut like an application. See page 40 for more 
information.

Import Shortcuts/Toolbars
Imports selected Shortcuts or toolbars. This menu changes 
depending upon whether the Keysets tab or Toolbar tab is 
active. When the Keysets tab is active, you can import selected 
Shortcuts. When the Toolbar tab is active, you can import 
selected toolbars. See page 51 for more information.

Export Shortcuts/Toolbars
Exports selected Shortcuts or toolbars. This menu changes 
depending upon whether the Keysets tab or Toolbar tab is 
active. When the Keysets tab is active, you can export selected 
Shortcuts. When the Toolbar tab is active, you can export 
selected Toolbars.

Page Setup
Opens the Page Setup window for your printer. This menu 
item is only available when the Keysets tab is active.

Print
Prints a list of Shortcuts and Sequences from the active 
QuicKeys Set. This menu item is only available when the 
Keysets tab is active.

Quit
Closes the QuicKeys Editor. Choosing this option does not  
affect your ability to trigger Shortcuts.

Edit Menu
The QuicKeys Edit menu follows the Mac interface standards.

Cut
Removes a selected item and stores it in the system clipboard.

Copy
Duplicates the selected item and stores a copy of the item in 
the system clipboard.

Paste
Pastes the item from the clipboard to the selected QuicKeys 
window.

Clear
Deletes the selected item.

Delete
Deletes the selected item.

Undefine
Removes the keystroke assignment for the selected Shortcut 
or Sequence.

Figure 41: The QuicKeys Editor Edit menu.
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Modify
Opens the Shortcut Properties dialog for the selected Shortcut 
or Sequence.

Select All
Selects all entries in the active QuicKeys window.

Create Menu
The Create menu lists all your QuicKeys plug-ins. Each plug-in 
is categorized by functionality in the Create menu’s 
submenus.

Sequence
Opens the Sequence Editor. See page 140 for more 
information.

Real Time
Begins recording your actions using Real Time recording. See 
page 38 for more information.

System Tools
Opens the Shortcut Properties dialog for Buttons, Clicks, Alias 
Keystroke, Mac OS Specials, Mousies, Menu Selection, Popup 
Menu, PowerBook Specials, App Switcher, Scrap Ease, Screen 
Ease, View Switcher, and Specials. See Chapter 8 for more 
information.

File Tools
Opens the Shortcut Properties dialog for File Handler, File 
Launch, File Recall, Folders, Batch Processor, and Project 
Saver. See Chapter 8 for more information.

Text Tools
Opens the Shortcut Properties dialog for Advanced Text Tools, 
Date/Time, and Text. See Chapter 7 for more information.

Scripting Tools
Opens the Shortcut Properties dialog for AppleEvents, 
AppleScript, and DoScript. See Chapter 13 for more 
information.

Multimedia Tools
Opens the Shortcut Properties dialog for Audio CD Player, 
Sound, SpeakEase, SpeakerChanger, and QT Movie. See 
Chapter 10 for more information.

Network Tools
Opens the Shortcut Properties dialog for Choosy, Mounty, and 
Network Switcher. See Chapter 11 for more information.

Sequence Tools
Opens the Shortcut Properties dialog for Password Vault, 
Decision, Jump, Repeat, Wait, GoSub, and Message. See 
page 144 for more information.

Internet Tools
Opens the Shortcut Properties dialog for Instant E-mail, 
Phone Dialer, and Web Launcher. See Chapter 12 for more 
information.

Other Tools
Opens the Shortcut Properties dialog for plug-ins installed 
with prior versions of QuicKeys. This submenu is only 
available for users who upgrade QuicKeys from a previous 
version.

Figure 42: The QuicKeys Editor Create menu.
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Options Menu
The Options menu enables you to manage basic QuicKeys 
operations.

Sort
Sorts your Shortcuts by type, name, or key.

Show Toolbar Hot Help
Displays the Shortcut name when your cursor is positioned 
over a QuicKeys toolbar button if toolbar titles are not 
displayed. See page 60 for more information on toolbar titles.

Lock Editor
Password-protects the QuicKeys Editor. See page 52 for more 
information.

Memory Usage
Displays how memory is allocated between Shortcut Sets. See 
page 53 for more information.

Compress Sets
Cleans out your QuicKeys data so outdated or fragmented 
information does not use up disk space or memory. See 
page 53 for more information.

Configure QuicKeys
Shows a dialog that enables you to customize certain aspects 
of QuicKeys. See page 47 for more information.

Configure QuickReference Card
Displays the QuickReference Card Options dialog so you can 
choose how the QuickReference card looks and behaves. See 
page 50 for more information.

About QuicKeys
Displays distributor and contact information.

THE SEQUENCE EDITOR
The Sequence Editor appears when you finish recording a 
QuicKeys Sequence or when you select Sequence from the 
Create menu. The Sequence Editor enables you to consolidate 
Shortcuts into more advanced Sequences. 

For example, you can create a Sequence that launches your ftp 
application; types your host name, user name, and password; 
and clicks OK in the appropriate dialogs. Using this example, 
the Sequence contains four separate Shortcuts that each 
complete a single task.

Figure 43: The QuicKeys Editor Option menu.

Figure 44: When Show Toolbar Hot Help is selected and toolbar 
titles are not shown, your toolbars display helpful 
pop-up text.
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See page 139 for more detailed information about Sequences.

QUICKEYS PLUG-INS
QuicKeys plug-ins are software components that add specific 
functionality to QuicKeys. There are several plug-ins available 
in QuicKeys that can be turned on or off individually using 
the Plug-in Manager. See page 51 for information on the 
Plug-in Manager.

THE QUICKEYS BACKGROUNDER
The QuicKeys Backgrounder is a background application that 
is launched at startup. The Backgrounder is necessary for 
drag-and-drop functionality in toolbars, displaying additional 
step information in Sequences, logging Sequences, scripting 
QuicKeys, and receiving Apple Events.

The only time you may need to quit the Backgrounder is 
when you install new software that requires you exit all 
applications. To restart the Backgrounder, you can either 
double-click the Backgrounder application or restart your 
computer. The Backgrounder is located in the 
:System Folder:Preferences:QuicKeys Folder: Backgrounders: 
folder on your startup disk.

DISPLAYING THE QUICKEYS BACKGROUNDER
By default, the QuicKeys Backgrounder is hidden from view, 
so you cannot see it in the application menu. To show the 
QuicKeys Backgrounder, uncheck the Hide QuicKeys Backgrounder 
check box in the QuicKeys Options dialog. See page 49 for 
more information.

 ▲ If you create a QuicKeys toolbar that does not  use the 
Always On Top setting discussed on page 62, the QuicKeys 
Backgrounder must be displayed.

Figure 45: The Sequence Editor.

Figure 46: This alert appears when you uncheck the 
Hide QuicKeys Backgrounder option in the 
Configure QuicKeys dialog.
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HIDING THE QUICKEYS BACKGROUNDER

There are two ways to hide the QuicKeys Backgrounder: in 
the Options dialog or in the Backgrounder menu.

To hide the Backgrounder using the Options dialog:

1. Open the Quickeys Editor.

2. Select Configure QuicKeys from the Options menu.

3. Select the Hide QuicKeys Backgrounder check box.

4. Click OK.

To hide the Backgrounder using the Backgrounder menu:

1. Select QuicKeys Backgrounder from the application menu. The 
QuicKeys Backgrounder becomes the active application.

2. Select Hide QuicKeys Backgrounder from the File menu.

THE QUICKEYS CONTROL PANEL
The QuicKeys control panel is the on/off switch for the 
QuicKeys Editor. You can use the QuicKeys control panel to 
enable and disable QuicKeys or to open the QuicKeys Editor, 
which is the control center for the Shortcuts and Sequences 
you create with QuicKeys.

TURNING QUICKEYS ON AND OFF
There are two radio buttons in the QuicKeys control panel 
dialog: On and Disable Until Restart. By default, the On button is 
selected. When the Disable Until Restart option is selected, your 
computer ignores all of your QuicKeys triggers. For example, 
if F5 is supposed to launch your E-mail application, but the 
Disable Until Restart radio button is selected in the control panel, 
nothing would happen when you press F5. 

You probably won’t use the Disable Until Restart option very 
frequently, but it can be very useful on a temporary basis if 
you are experiencing keystroke conflicts with other 
applications. 

OPEN QUICKEYS EDITOR
Open the QuicKeys Editor directly from the QuicKeys control 
panel by clicking the Open QuicKeys Editor button. This option is 
useful if you experience computer problems that cause the 
QuicKeys menu to remain dimmed.

SHOW STARTUP ICON
Check or uncheck the Show Startup Icon option to specify 
whether or not the QuicKeys icon appears with all the other 
System icons at the bottom of your screen when you restart 
your computer. By default, the Show Startup Icon option is 
checked.

Figure 47: The QuicKeys control panel.
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THE QUICKEYS MENU
By default, a QuicKeys icon displays in the upper right corner 
of your menu bar immediately after installation. When you 
click that icon, the QuicKeys menu appears. 

Using the QuicKeys menu you can: 

• Open the QuicKeys Editor.

• Launch the Setup Assistant.

• Open the QuickReference Card.

• Display and edit QuicKeys toolbars.

• Control QuicKeys recording.

• Trigger Shortcuts.

❖ The QuicKeys menu can only display plug-in icons. 
It cannot display application-specific icons.

ADDING SHORTCUTS TO THE QUICKEYS MENU
Add Shortcuts to the QuicKeys menu by selecting the Include in 
QuicKeys menu check box in the Setup Assistant or in the 
Shortcut Properties dialog. See Figure 54 on page 37.

Additionally, you can select the QuicKeys menu column in the 
QuicKeys Editor. Figure 27 on page 23 shows the QuicKeys 
menu column.

CONTEXTUAL MENUS
With their debut in version 8.0 of the Macintosh operating 
System, contextual menus made it much easier for Mac users 
to manipulate items on the computer. QuicKeys takes 
advantage of this technology by adding a QuicKeys option to 
the Mac’s contextual menu. You can create the following 
Shortcuts using contextual menus:

SELECTING FILES AND FOLDERS
If you Control+click an application file in the Finder, the Create 
QuicKey option appears in the contextual menu. 

Figure 48: By default, the QuicKeys menu appears in the upper right corner 
of your desktop.

These Shortcuts are 
scoped to Adobe 
PhotoShop. They only 
appear in the 
QuicKeys menu when 
PhotoShop is the 
active application.

These Shortcuts 
are Universal in 
scope.

• File Launch • Folders

• Web Launcher • Type Text

Figure 49: When the file you Control+click is supported by QuicKeys, 
Create QuicKey is an option in contextual menus.
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If you select Create QuicKey from the contextual menu, a 
simplified version of the Shortcut Properties dialog appears. 
Select the Shortcut type and Shortcut trigger and click OK. 

❖ There may only be one type of Shortcut available in 
the Type pop-up menu (shown in Figure 50), 
depending on what type of file you 
Control+clicked.

EDITING TOOLBARS
You can Control+click the empty space or title bar in a 
QuicKeys toolbar to change your toolbar options. This 
capability makes it possible to edit your toolbar properties 
without having to open the Toolbars tab of the QuicKeys 
Editor.

Figure 50: This dialog appears when you select Create QuicKey in a 
contextual menu.

Figure 51: Control+click an empty space or the title bar in a QuicKeys 
toolbar to display the menu shown above.
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EDITING TOOLBAR BUTTONS
You can Control+click buttons on a QuicKeys toolbar to edit 
your toolbar buttons.  

USING QUICKEYS
There are two basic steps involved in using QuicKeys: setting 
up Shortcuts and triggering Shortcuts. This section provides 
general information about this process. For information on 
setting up specific Shortcuts and Sequences, look at the table 
of contents and turn to the relevant chapters in this manual. 
For example, go to Chapter 8 for detailed information on 
setting up a File Launch Shortcut.

CREATING SHORTCUTS
There are four methods you can use to set up QuicKeys 
Shortcuts and Sequences: 

• Use the Setup Assistant to be guided through the process 
of creating a Shortcut one step at a time.

• Direct QuicKeys to record your actions so that you can 
choose to replay them in the future.

• Create a single Shortcut manually by selecting an option 
from the Create menu.

• Use the QuicKeys contextual menu.

• Dragging and dropping files or folders onto a QuicKeys 
toolbar.

Your changes are automatically saved when you exit the 
QuicKeys Editor, regardless of which method you use to 
create your Shortcuts and Sequences.

Using the Setup Assistant
When you begin creating Shortcuts, you will probably use the 
Setup Assistant because it provides the most basic method for 
creating Shortcuts. Open the Setup Assistant by clicking the 
Setup Assistant button. Choose an option in each consecutive 
panel. By the time you reach the last Setup Assistant window, 
you have created a QuicKeys Shortcut.

A Setup Assistant session  begins when you click the arrow in 
“Welcome to the QuicKeys Setup Assistant” panel and ends 
when you click Continue or Quit in the last panel. You can 
complete several sessions when the Assistant is launched.

Figure 52: The toolbar button contextual menu.

Figure 53: A panel in the Setup Assistant.
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If you click the close box in the Setup Assistant before you 
reach the last Assistant window, or you select Quit from the File 
menu, an alert appears asking you to verify that you want to 
quit the Assistant. If you select Quit at the prompt, the 
selections you made in your most recent Setup Assistant 
session are not  saved by QuicKeys.

When the Setup Assistant is the active application on your 
desktop, QuicKeys is disabled. This means that you cannot 
use QuicKeys toolbars or other QuicKeys components while 
the Setup Assistant is in the foreground. See page 26 for more 
information on which Shortcuts can be created with the Setup 
Assistant.

Using QuicKeys Recording
QuicKeys also has a powerful feature called recording  that 
enables your computer to memorize tasks you want to 
automate. QuicKeys can record Shortcuts, Sequences, and 
Real Time Shortcuts. When you record a Shortcut, you are 
recording a single-step  task. When you record a Sequence, you 
are recording a multi-step  task. When you use Real-Time, you 
can record both single-step and multi-step tasks in real time.

Recording One Shortcut
Recording a single-step Shortcut is one of the simplest tasks 
you can perform with the QuicKeys recording feature. If you 
want to create a Shortcut, but you don’t want to open the 
QuicKeys Editor, you can select Record One Shortcut from the 
QuicKeys menu. QuicKeys watches you complete one task 
and then it displays a Shortcut Properties dialog that 
corresponds to the task you completed. For example, if you 
select an item from a menu, QuicKeys displays the Shortcut 
Properties dialog for the Menu plug-in.

One of the advantages of recording a Shortcut rather than 
selecting a Shortcut from the Create menu is that you don’t 
have to know what type  of QuicKeys Shortcut you want to 
create. In other words, if you aren’t familiar with all of the 
Shortcuts available in QuicKeys, you may not know which 
Shortcut to pick from the Create menu. With the recording 
feature, everything is done for you. 

To record a Shortcut:

1. Select Record One Shortcut from the QuicKeys menu. A 
microphone icon appears over the Apple menu indicating 
that your next action will be recorded.

2. Complete the task you want to automate. For example, 
select Page Setup from the File menu of Microsoft Word. A 
Shortcut Properties dialog appears in front of the Page 
Setup dialog. 

3. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

Figure 54: The options in the Shortcut Properties dialog are slightly 
different for each QuicKeys plug-in. This graphic shows the 
options available for the File Handler plug-in.
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4. Click OK when you are done. The Shortcut dialog 
disappears, leaving the QuicKeys Editor open on your 
desktop. Click outside the QuicKeys Editor window to 
close the Editor window.

Recording Real Time Shortcuts
Real Time recording enables you to record a series of 
Shortcuts in “real time.” Real Time recording tracks your 
mouse movements, clicks, and keystrokes. When triggered, 
Real Time plays back your actions at the same speed you 
recorded them. So, if you paused before clicking a particular 
menu option, that pause becomes part of the Real Time 
recording. 

Real Time recording is different from other types of recording 
because it tracks your keyboard selections and screen 
coordinates. This capability is useful for selecting submenus 
that Sequence recording and standard QuicKeys Shortcuts 
can’t locate. Unlike Sequences that keep track of which 
dialogs, applications, and menus appear on your screen, 
RealTime recording pays no attention to what’s on your 
screen—it only cares where your mouse button is clicked and 
what keys you press. 

Before you make your first Real Time recording, keep in mind 
that you cannot edit Real Time, so your movements on screen 
must be as deliberate and as well-planned as possible.

To make your first Real Time recording:

1. Select Record Real Time from the QuicKeys menu. A recording 
toolbar may appear, depending on how you have set up 
your QuicKeys options.

2. Complete the tasks you want to automate.

3. When you are finished completing the tasks you want 
automated, select Stop Recording from the QuicKeys menu or 
click the stop button in the Recording toolbar. The Real 
Time dialog appears. 

4. Type a name for your Real Time Sequence in the Name box.

5. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut. For example, press 
Command+Option+F10.

Pause, Stop, Cancel, Insert

Figure 55: The Recording toolbar.

Figure 56: The Real Time Shortcut Properties dialog.
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6. Click the Record More button if you want to add more steps 

to the Real Time Sequence. Once you add steps to a Real 
Time Sequence, you cannot delete them unless you delete 
the entire Shortcut.

7. Click OK when you are done. The Real Time dialog 
disappears, leaving the QuicKeys Editor open on your 
desktop. Click outside of the QuicKeys Editor window to 
automatically close the Editor window.

See Chapter 14 for more information on recording multi-step 
Shortcuts.

Using the Shortcut Properties Dialog
When you are familiar with QuicKeys, you may prefer to 
create single-step Shortcuts using the options in the Create 
menu. When you select an option from the Create menu, a 
Shortcut Properties dialog for the selected menu item appears.

Using Contextual Menus
When you Control+click a file that is supported by QuicKeys, 
you can select Create QuicKey from the contextual menu that 
appears. You can create File Launch, Type Text, and Folders 
Shortcuts using contextual menus. 

Dragging Files to QuicKeys Toolbars
When you drag-and-drop files or folders to a QuicKeys 
toolbar, QuicKeys automatically creates toolbar button 
triggers that act on those files or folders. For example, if you 
drag a SimpleText document to a QuicKeys toolbar, QuicKeys 
automatically places a File Launch Shortcut on the toolbar 
that launches that particular SimpleText document. See 
Chapter 6 for more information on QuicKeys toolbars.

TRIGGERING SHORTCUTS
QuicKeys makes customizing the way you work easy. You can 
use any or all of the following triggers for each QuicKeys 
Shortcut.

Keystroke
Use key(s) on the keyboard to trigger your QuicKeys 
Shortcuts. For example, use Shift+F7 to launch your E-mail 
application.

Toolbars
Create QuicKeys toolbars so you can point and click to trigger 
Shortcuts. See Chapter 6 for more information.

Figure 57: The options in the Shortcut Properties dialog depend upon 
which plug-in you are using.



40 Chapter 4
QuicKeys Overview

• • • •
Timed triggers
Use the specific date, time of day, or repeating interval to 
automatically trigger QuicKeys Shortcuts. Set up timed 
triggers by clicking the Set Timer button in the Shortcuts 
Properties dialog or by clicking in the timer column of the 
QuicKeys Editor. You can set up Shortcuts that are triggered X 
seconds after startup or you can select the exact date and time 
Shortcuts are triggered.

QuicKeys menu
Depending on how your preferences are set, you can open the 
QuicKeys menu when you click the QuicKeys icon in the 
desktop menu bar or when you select it from the Apple menu. 
See page 33 for more information.

Make Icon
Use the Make Icon option to create a little standalone application 
that, when launched, triggers the QuicKeys Shortcut. 
QuicKeys must be loaded for this type of QuicKeys trigger to 
work, but otherwise it functions much the same as an 
ordinary application.

To make a Shortcut into an icon:

1. Select the Shortcut(s) and choose Make Icon from the File 
menu. QuicKeys prompts you with a Save dialog. Notice 
that QuicKeys places bullet symbols in the filename of 
your Shortcut so you can recognize it as a QuicKeys file on 
your hard drive.

2. Select a the location on your hard drive where you want to 
display your QuicKeys icon.

3. Select the Save Shortcut Data in QK Icon check box to save all 
Shortcut attributes in the icon file. Checking this option 
makes your Shortcut completely self-contained and mobile 

Figure 58: Use the Timer Options dialog to set up 

Figure 59: A Save dialog appears when you select the Make Icon 
option in the File menu.



41• • • •

because the Shortcut trigger and Shortcut name are saved 
within the icon. 

4. Click the Save button. A QuicKeys icon appears in the 
location you specified.

See page 48 for more information on setting Make Icon 
options.

Figure 60: The Make Icon option makes 
Shortcuts look and act like 
applications.
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CHAPTER 5
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MANAGING QUICKEYS

This chapter discusses standard procedures for managing 
QuicKeys on a day-to-day basis. It also provides information 
on turning individual Shortcuts on and off, resolving 
keystroke conflicts, and importing and exporting Shortcuts.

SAVING SHORTCUTS
Your Shortcuts are automatically saved whenever you close 
the QuicKeys Editor.

EDITING SHORTCUTS
To edit QuicKeys Shortcuts, open the QuicKeys Editor and 
double-click the Shortcut you want to edit. Make changes in 
the Shortcut Properties dialog that appears and click OK when 
you are finished.

DELETING SHORTCUTS
To delete QuicKeys Shortcuts, open the QuicKeys Editor and 
select the Shortcut you want to delete. Select Delete from the Edit 
menu. Click the Delete button in the alert window that appears.

 ▲ There is no “Undo” function if you delete a Shortcut.

PRINTING SHORTCUTS
If you want to print a list of your Shortcuts, choose the keyset 
you want to print and select Print from the File menu. The 
following information in the selected Set is printed:

• Keystroke.

• Icon representing Shortcut type.

• Shortcut name.

• Comments.

MANAGING KEYSTROKE ASSIGNMENTS
If you have created several Shortcuts, you may find it difficult 
to keep track of all your keystroke assignments. If it becomes 
hard to remember which key combinations trigger your 
favorite Shortcuts, you can either print a list of your Shortcuts 
or view the QuickReference Card.

PRINTING KEYSTROKE ASSIGNMENTS
To print a list of keystroke assignments in a QuicKeys Set, 
open the QuicKeys Editor and select the QuicKeys Set you 
want to print. Choose Print from the File menu and click OK in 
the Print dialog that appears. The keystroke, Shortcut type, 
Shortcut name, and a comment line are printed for the 
QuicKeys Set you selected.
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VIEWING THE QUICKREFERENCE CARD
QuicKeys provides another solution to “keystroke overload” 
with the QuickReference Card. The QuickReference Card is a 
modal window that displays QuicKeys Shortcuts and their 
corresponding keystroke assignments for your Universal and 
active applications Sets. You can trigger Shortcuts by clicking 
them in the QuickReference Card, or you can simply use the 
QuickReference Card to view the Shortcuts you have created.

By default, the QuickReference Card can be opened by 
selecting QuickReference Card from the QuicKeys menu or by 
pressing Option+Control+Space. The QuickReference Card 
closes when you press the OK button or when you click a 
Shortcut listed in the QuickReference Card window.

You can choose which QuicKeys Shortcuts appear in the 
QuickReference Card using the filtering toolbar at the bottom 
of the QuickReference Card window. Each button on the 
toolbar represents a type of QuicKeys plug-in. By default, all 
plug-ins display in the QuickReference Card. 

• Click Show all to display all the Shortcuts.

• Click on one of the filter buttons to display only the 
Shortcuts represented by that button. 

• Press the Shift key down and click multiple filter buttons 
to display multiple Shortcut types. A black outline 
highlights the selected plug-ins in the filter.

• Click the arrow button to scroll through the 
QuickReference Card.

CLEARING KEYSTROKE ASSIGNMENTS
There are three areas where you can delete your keystroke 
assignment for a particular Shortcut: from the QuicKeys 
Editor Keysets tab and from the Shortcut Properties dialog. 

• To delete a keystroke assignment from the QuicKeys 
Editor Keysets tab, click in the Keystroke column and press 
the Delete key on your keyboard. The keystroke cell 
becomes blank.

• To delete a keystroke assignment from the Shortcut 
Properties dialog, position your cursor in the keystroke 
box of the Shortcut Properties dialog and press the Delete 
key on your keyboard. The keystroke is replaced by the 
word “unassigned” to indicate that the Shortcut no longer 
has a keystroke trigger assigned to it.

• Select the Shortcut in the QuicKeys Editor and select 
Undefine from the Edit menu.

RESOLVING KEYSTROKE CONFLICTS
Keystroke conflicts occur when a keystroke in one QuicKeys 
Shortcut Set conflicts with a keystroke in another QuicKeys 
Set. Conflicts can also occur between QuicKeys keystrokes 
and keystrokes that are built into another application. For 
example, let’s say the F5 keystroke is assigned to two different 
QuicKeys Shortcuts. One keystroke opens Photoshop and is 
part of the Universal Set. The other keystroke changes the 
layout of a document and can only be triggered in a specific 
database application. What happens when you press F5?

Figure 61: The QuickReference Card.
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QuicKeys follows specific rules of priority to resolve 
keystroke conflicts. When the same keystroke is used for 
several different tasks, the resulting Shortcut depends upon 
where the keystroke falls in the following hierarchy:

A. Application-specific keystrokes

B. Universal keystrokes

C. Keystrokes defined within a particular application

Applying this information to the above example, if the 
database program is the active application, F5 formats a 
database document. If the database program is not  the active 
program, F5 starts Photoshop. 

If you don’t want to change assigned keystrokes to avoid 
these conflicts, you can either use the QuicKeys Specials 
plug-in to turn your keystrokes on and off for a brief period of 
time or you can substitute QuicKeys keystrokes for the 
keystrokes that are built into the applications you use. 

Turning Off Keystroke Assignments
If keystroke conflicts only occur in applications you seldom 
use, the best way to avoid them is to turn your QuicKeys 
keystrokes on and off using the Specials plug-in. This feature 
enables you to briefly disable a QuicKeys keystroke while you 
work in an application that uses conflicting keystrokes.

For example, you may want to disable QuicKeys keystrokes 
while working in Microsoft Excel if Excel uses Command+I to 
insert cells, but you have directed QuicKeys to use 
Command+I to change selected text to italics in your 
Universal Set.

 When you are finished working in the application, you can 
turn QuicKeys keystrokes back on. See page 111 for more 
information.

Reassigning Built-in Application Keystrokes
If keystroke conflicts occur in applications you use on a daily 
basis, you need to change either the keystroke that you 
assigned with QuicKeys or the keystroke your applications 
use. You can change your QuicKeys keystrokes simply by 
opening the QuicKeys Editor, positioning your cursor in the 
Keystroke column and pressing a different keystroke when 
you see the blinking cursor. 

To change your built-in application keystrokes, you can use 
the Alias Keystroke Shortcut. See page 95 for more 
information.

WORKING WITH QUICKEYS SETS
You can specify the range of operation for a particular 
QuicKeys Shortcut by choosing a QuicKeys Set. These Sets 
make it easier to manage QuicKeys because they enable you 
to categorize your Shortcuts. You can place a Shortcut in the 
Universal Set so it can be triggered at any time, or you can 
make a Shortcut application-specific so it only works in a 
selected application. 
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When you open the QuicKeys Editor, you can choose to view 
three different kinds of Sets: Active Sets, Inactive Sets, and 
Custom Sets.

ACTIVE SETS
There are only two active Sets at any one time in QuicKeys: 
the Universal Set and the current application Set. Shortcuts 
can only be triggered if they are in an active Set. On a Mac, the 
active application is denoted by a checkmark in the 
application menu. In QuicKeys, the active application is 
displayed in the Sets pop-up menu of the QuicKeys Editor. 
Shortcuts listed in an application Set can only be triggered 
when the application is frontmost on the desktop. For 
example, if the Finder is the active application, only Universal 
and Finder-specific shortcuts can be triggered.

Selecting the Universal Set
Use the Universal Set when you want to be able to trigger a 
Shortcut at any time, regardless of what application you are in 
or whether or not the Finder is active.

INACTIVE SETS
Inactive Sets include all QuicKeys Sets that reside in your 
Keysets folder, with the exception of the active application Set 
and the Universal Set. 

Selecting an Application Set
There are two different application Sets: an active application 
Set and a standard application Set. The active application Set 
enables you to assign Shortcuts to the application that is active 
on your desktop. The standard application Set enables you to 
choose which application Set you want to view. The 
application list contains:

• Applications that currently have QuicKeys Shortcuts 
assigned to them.

• Applications that are currently launched.

• The Finder.

CUSTOM SETS
Sets that are not stored in the Keysets folder are called Custom 
Sets. To open custom Sets, you must select Open Set from the File 
menu and navigate to the location of the Set.

Creating a Custom QuicKeys Set
You can create custom QuicKeys Sets for applications, such as 
computer games. For example, if you are an avid fan of 
computer games, you may find that you cannot interrupt a 
game to make a QuicKeys Shortcut. If this occurs, you can 
“trick” the game by creating a custom QuicKeys Set. 

Figure 62: Choose which Set you want a particular Shortcut to belong to 
using the Set pop-up menu.
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To create a custom QuicKeys Set:

1. Open the QuicKeys Editor.

2. Select New Set from the File menu.

3. Type a name for your custom Set. If you are using the 
Shortcuts for a game, the name of your custom Set must 
match the name of the game you are trying to automate 
with QuicKeys.

4. Choose to store the Set in the Keysets folder. The 
Keysets folder is located in the :System 
Folder:Preferences:QuicKeys Folder: on your startup disk.

5. Click Save to save your Set to the Keysets folder. The 
QuicKeys Editor appears with the name of your new Set 
displayed in the Sets pop-up menu.

6. Add Shortcuts to your custom Set.

The next time you open the computer game, it automatically 
recognizes the Shortcuts you have assigned to it using 
QuicKeys.

Opening Custom QuicKeys Sets
To open a custom QuicKeys Set:

1. Open the QuicKeys Editor.

2. Select Open Set from the QuicKeys Editor File menu.

3. Navigate to the custom QuicKeys Set you want to display 
and click Open. The selected Set appears in the QuicKeys 
Editor.

Saving Sets
To save a custom QuicKeys Set, select Save from the File menu.

CHANGING SET ASSIGNMENTS
To change Set assignments, use the cut, copy, and paste 
options to remove Shortcuts from one Set and add them to 
another Set.

CLOSING SETS
To close a custom QuicKeys Set so it no longer appears in the 
QuicKeys Editor, select a Set from the Set pop-up menu and 
choose Close Set from the File menu.

HIDING QUICKEYS
When you click outside of the QuicKeys Editor, the Editor 
window is replaced by a small, boxed QuicKeys logo called 
the QuicKeys palette. When you click on the QuicKeys 
palette, the QuicKeys Editor reappears. This functionality 
enables you to “hide” the QuicKeys Editor without closing it.  

CUSTOMIZING QUICKEYS
There are several different ways to customize QuicKeys. You 
can make changes in the Configure QuicKeys dialog, set 
QuickReference Card preferences, disable/enable QuicKeys 
plug-ins, install third-party plug-ins, and sort your Shortcut 
list.

SETTING QUICKEYS OPTIONS
You can customize what you see when you run QuicKeys by 
selecting or clearing options in the Configure QuicKeys 
dialog. 

Figure 63: The QuicKeys palette appears when you click outside the 
QuicKeys Editor.
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QuicKeys Menu
Use the QuicKeys menu options to select where to display the 
QuicKeys menu. You can choose to display the QuicKeys 
menu in the Apple Menu, in the menu bar at the top of your 
screen, or you can choose to hide the QuicKeys menu. The 
Menu Bar option places the QuicKeys icon on the right side of 
the Macintosh menu bar. When you change the location of the 
QuicKeys menu, you must restart for the change to take effect.

QuicKeys Popup Menu
Use the QuicKeys Menu options to select which key(s), in 
combination with a mouse click, display(s) the QuicKeys 
pop-up menu. For example, if you select the Shift check box, 
the QuicKeys menu appears whenever you press the Shift key 
and your mouse key simultaneously. By default, you can only 
open the QuicKeys pop-up menu by clicking the QuicKeys 
icon in the menu bar.

Make Icon Options
Use the Make Icon options to adjust the appearance of 
QKIcons. Select Bullets in Name to add bullets to the QKIcon 
filename. Select Use Custom Icons to display an icon that 
represents the type of Shortcut selected, rather than a generic 
QuicKeys icon. See page 40 for instructions on using the Make 
Icon option.

Sequence/Recording Options
Choose whether you want the Record and Playback palettes 
to display when you are recording or playing back a 
Sequence. 

Select Use Sequence Log to provide a log of the last Sequence you 
triggered. This feature is useful when you are troubleshooting 
a Sequence or when you need to create a building block for a 
QuicKeys script. The log file is stored in the System 
Folder:Preferences:QuicKeys: folder.

❖ The QuicKeys Backgrounder must be running for 
the Use Sequence Log feature to function.

Keyset Management
Use these options to set compression and memory allocation 
preferences. Select Compress files automatically on startup to remove 
unused Sequence and Real Time data from their respective 
folders when your computer is restarted. To keep things 
running smoothly, CE Software recommends leaving this 
option selected. 

Figure 64: The Configure QuicKeys dialog.

Figure 65: The recording and playback 
palettes.



49• • • •

Select Confirm file Shortcuts when compressing files to clean up 
QuicKeys at the system level. This option links unattached 
File Launch Shortcuts and cleans up empty space that is 
fragmented as a result of editing Shortcuts or Sequences. 

Specify how much memory you want to reserve for new 
Shortcuts. By default, 32K is allocated for new QuicKeys 
Shortcuts. Shortcuts vary in size depending on their 
complexity, so you need to rely primarily on the QuicKeys 
Memory Usage window or persistent buffer alerts to determine 
how much of a memory buffer should be set in QuicKeys. 
When you are setting your QuicKeys buffer size, keep in mind 
that every time you open an application, you open its 
associated QuicKeys Shortcut Set, increasing the amount of 
memory QuicKeys requires.

Hide QuicKeys Backgrounder
By default, the Hide QuicKeys Backgrounder check box is checked in 
the Options dialog. When this option remains checked, the 
QuicKeys Backgrounder application is invisible to you when 
it is running. If you uncheck this option, the QuicKeys 
Backgrounder appears in your application menu. See page 32 
for more information on the QuicKeys Backgrounder.

Whether or not the QuicKeys Backgrounder is visible is 
largely a personal preference, but this option does affect some 
QuicKeys toolbars. If you have a toolbar that does not use the 
Always On Top option and you keep the default QuicKeys Editor 

settings, the alert shown in Figure 66 appears. If you select Yes 
in this alert window, the Hide QuicKeys Backgrounder option is 
automatically unchecked in the Options dialog so you are able 
to see all your toolbars.

International Launching
Use this dialog to specify the equivalent of various menu 
items in a non-English System.

Figure 66: This alert window appears if you uncheck the Always On Top 
option for a QuicKeys toolbar.

Figure 67: The International Launching window.
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Speed Settings
Use the Speed Settings dialog to fine-tune the dragging, 
clicking, or recording speeds in QuicKeys. This feature is 
useful for applications that are particularly slow or for 
creating Real Time Shortcuts for tasks that require slower 
movements. The best way to determine which speeds work 
best for your environment is to experiment with the different 
options.

SETTING QUICKREFERENCE CARD PREFERENCES
Customize the appearance of the QuickReference Card by 
making changes in the QuickReference Card Options window.

Sort by
Sorts Shortcuts in the QuickReference Card window by 
Shortcut type, Shortcut name, or keystroke.

Display these Shortcuts
Choose which plug-ins are displayed in the QuickReference 
card by clicking an icon in the QuickReference Card Options 
window. A black square highlights each plug-in chosen to 
display in the QuickReference Card. By default, all icons are 
highlighted.

List
Choose which types of Shortcuts display in the 
QuickReference Card from the List options. You can choose to 
display Application-specific Shortcuts, Universal Shortcuts, or 
both types of Shortcuts.

Expand to fill screen
Expands the QuickReference Card window so it covers your 
desktop.

Figure 68: The Speed Settings window.

Figure 69: The QuickReference Card Options window.
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DISABLING/ENABLING PLUG-INS

If you find that you do not have a need for some of the 
plug-ins installed with QuicKeys, you can turn those plug-ins 
off so they no longer display in the QuicKeys Editor. For 
example, if you don’t use your CD-ROM drive for music CDs, 
you can disable the CD player plug-in.

To disable/enable QuicKeys plug-ins:

1. Click the Plug-in Manager button  in the QuicKeys 
Editor.

2. In the Plug-in Manager window, select the Shortcuts you 
want to disable or enable and click the Turn off/Turn on button.

3. Click Done when you are finished.

4. Restart your computer to make your changes take effect. 

Turn off
Select extensions you don’t use very often and click the Turn off 
button to save memory and make your machine run faster. 
Restart your computer to make these changes effective.

Get Info
Displays a brief description of the selected extension.

SORTING INFORMATION
Specify how Shortcuts are sorted in the Keysets tab of the 
QuicKeys Editor. Just click the category by which you want 
your Shortcuts sorted.

IMPORTING SHORTCUTS
Import QuicKeys Shortcuts when you receive them from 
other QuicKeys users. When you import Shortcuts, you 
import all the attributes originally assigned to the particular 
Shortcuts.

To import Shortcuts:

1. Open the QuicKeys Editor.

2. Open the Set into which you want to import Shortcuts.

3. Select Import Shortcuts from the File menu. A standard Open 
dialog appears.

4. Navigate to the folder where the Shortcuts are stored.

Figure 70: The Plug-in Manager.
Figure 71: This dialog appears when you import 

Shortcuts.
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5. Click the Import without Keystrokes option if you want to assign 
your own keystroke to the Shortcut.

6. Click Open. The Shortcuts are imported into the QuicKeys 
Set you selected.

EXPORTING SHORTCUTS
Export Shortcuts when you want to share them with other 
QuicKeys users.

To export individual Shortcuts and Sets:

1. Open the QuicKeys Editor.

2. Select the Set that contains the Shortcuts you want to 
export.

1. Select Export Shortcuts in the File menu.

2. Navigate to the drive where you want to store your 
selected Shortcut(s).

3. Choose Save Selected Shortcuts to export only the Shortcuts 
selected in the QuicKeys Editor or choose Save Entire Set to 
save all the Shortcuts in the selected Set.

4. Click Open. The Shortcuts are immediately exported to the 
location you specified.

EXPORT OPTIONS

Save Selected Shortcuts
Exports only the Shortcuts you select.

Save Entire Set
Exports all the Shortcuts in the selected Set.

LOCKING THE EDITOR
Use the Lock Editor option to secure your Shortcuts or to 
standardize Shortcuts across a group of users. If you use 
Shortcuts that log into password-protected network volumes, 
you may want to restrict people from seeing the specific steps 
that comprise the Shortcut. Likewise, if you are a systems 
administrator and you don’t want users editing a 
standardized set of Shortcuts, you can lock the QuicKeys 
Editor on each of the machines on your network.

To lock the QuicKeys Editor:

1. Open the QuicKeys Editor.

2. Select Lock Editor from the Options menu.

3. Type your password in the Enter Password box.

4. Re-type your password in the Re-enter Password box to verify 
the spelling.

5. Click OK when you are finished.

Figure 72: This dialog appears when you choose to export one or 
more Shortcuts.

Figure 73: The QuicKeys Editor Password dialog.
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Once you have locked the QuicKeys Editor, you cannot access 
the QuicKeys Editor again without entering the password you 
selected. After you unlock QuicKeys, the Editor remains 
unlocked until you again specify a password in the QuicKeys 
Editor Password dialog. 

CHECKING MEMORY USAGE
Select Memory Usage from the Options menu to see how QuicKeys 
is using memory. If the Buffer Size and the Used categories are 
close in number of bytes, you should increase the buffer size. 
See the section on keyset management on page 48 for 
information on changing the buffer size setting.

You can get a general idea of whether or not QuicKeys needs 
more memory by looking at the Buffer status bar area in the 
Info pop-up window in the Quickeys Editor. See Figure 75. 

COMPRESSING SETS
QuicKeys Sets are stored in the Keysets folder as individual 
files. When you add or delete a Shortcut, QuicKeys adds it to 
or deletes it from the appropriate Set. 

In contrast, QuicKeys stores Sequences in both the Keysets 
folder and the Sequences folder, while Real Time Shortcuts are 
stored in both the Keysets folder and in the Macros folder. 
When you delete a Sequence or Real Time Shortcut, the file 
stored in the Keysets folder is deleted, but the file stored in the 
Sequences or Macros folders are not  deleted.

The Compress Sets command removes those Sequences and Real 
Time recordings if their corresponding Shortcut files have 
been deleted. Selecting this option is a good way to streamline 
the disk space QuicKeys uses.

❖ By default, Sets are compressed at startup.

Figure 74: The Memory Usage window.

Figure 75: Track the memory buffer size in the Buffer status bar.
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QUICKEYS TOOLBARS

QuicKeys toolbars are floating windows with custom buttons 
that represent Shortcuts or Sequences. For example, some 
applications contain toolbars that allow you to cut, copy, and 
paste selected items just by clicking the corresponding icons. 
Similarly, QuicKeys offers toolbars that allow you to trigger 
QuicKeys Shortcuts by clicking a QuicKeys toolbar button. 

THE TOOLBARS TAB
QuicKeys toolbars have two components: the toolbar itself 
and the buttons on the toolbar. You can create or edit both of 
these components using the Toolbars tab of the QuicKeys 
Editor. The Toolbars tab is divided into four panes: the 
Toolbars pane, the Toolbar Options pane, the Shortcuts pane, 
and the Instruction pane. See Figure 77. 

Figure 76: This illustration shows two ways to display the same floating 
QuicKeys toolbar.

When toolbar buttons have a pop-up 
arrow, you can click the arrow to display 
of menu of Shortcut-related options.

Control+click the title bar or an area of 
the QuicKeys toolbar that does not 
contain a toolbar button to display a 
contextual menu.

Click and drag a corner of the QuicKeys 
toolbar to resize it. Click-N-Go toolbars 
cannot be resized.

Figure 77: The QuicKeys Editor Toolbars tab.

Toolbars 
Pane

Toolbar 
Options Pane

Shortcuts 
Pane

Instruction 
Pane
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THE TOOLBARS PANE
The Toolbars pane shows the toolbars you have created along 
with the attributes for each toolbar. 

Toolbar Type column
Indicates whether a toolbar is Floating, Docked, or Click-N-
Go by the icon displayed in the Type field.

S/H column
The Show/Hide column enables you to control whether the 
toolbar is visible or not after you close the QuicKeys Editor.

Name column
Displays the name of your QuicKeys toolbars.

New button
Click the New button to create a new QuicKeys toolbar.

Rename button
Click the Rename button to rename an existing QuicKeys 
toolbar.

Delete button
Click the Delete button to permanently delete a QuicKeys 
toolbar.

THE TOOLBAR OPTIONS PANE
When you create a QuicKeys toolbar, you can choose how you 
want the toolbar to look and function. 

Toolbar Type
There are three different QuicKeys toolbar types: Click-N-Go, 
Docked, and Floating. This section discusses each toolbar type 
and provides examples of when to use one style over another.

Click-N-Go
A Click-N-Go toolbar closes immediately after you click a 
button on it. This type of toolbar is useful if you want to 
preserve desktop space. For example, if you don’t want to 
remember which keystroke starts one of the 15 applications 
installed on your computer, you can create a Click-N-Go 
toolbar that enables you to start each of these applications by 
clicking the corresponding button on the toolbar. All you have 

Figure 78: The Toolbars pane of 
the Toolbars tab.

Floating

Docked

Click-N-Go

A check mark 
indicates toolbars set 
to display on your 
desktop when the 
Editor is closed.

When you select a toolbar 
name, the corresponding 
toolbar appears on your 
desktop for editing.

Figure 79: The Toolbar Options pane 
of the Toolbars tab.
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to remember is the keystroke that opens the Click-N-Go 
toolbar. You can also select the toolbar from the QuicKeys 
menu. Then click the toolbar button, and watch as the toolbar 
disappears just as the selected Shortcut is triggered.

If you are familiar with the Softkeys function in previous 
versions of QuicKeys, you will see some of the same 
functionality in QuicKeys Click-N-Go toolbars. You can type 
the corresponding position number (1-0) to trigger a Shortcut 
on a Click-N-Go toolbar. For example, if your FileMaker® Pro 
File Launch Shortcut is the first Shortcut listed on a toolbar, 
press 1 to open it.

❖ Click-N-Go toolbars must use the Always On Top 
setting discussed on page 62.

Docked
A Docked, or embedded, toolbar attaches to the edge of the 
screen. This type of toolbar is useful when you want to keep 
your toolbar in the same position whenever you start a 
specific application. For example, if you have several 
Shortcuts that automate Microsoft Word, you can place them 
on an application-specific, Dockable toolbar so they are 
accessible whenever Microsoft Word is open. 

You can drag Docked toolbars from one side of your screen to 
another to move them. An outline of the toolbar moves with 
your cursor to show you where the toolbar will be placed.

Floating
A Floating toolbar can be moved anywhere on your screen. 
This type of toolbar is useful if you want complete flexibility 
when you position your toolbars on your desktop. The benefit 
of using a Floating toolbar is that your Shortcuts are only a 
click away, but your toolbar never interferes with your work. 

Figure 80: A Click-N-Go toolbar appears when it is triggered and 
disappears when you select a button from the toolbar, 
press the Esc key, or click outside the Click-N-Go 
toolbar.

With Click-N-Go toolbars, you can 
press the number (0-9) on your 
keyboard that appears on the 
toolbar button you want to select. 
The Shortcut represented by the 
toolbar button is immediately 
triggered. This feature enables you 
to keep your hands on the 
keyboard rather than having to 
switch to the mouse. 

Figure 81: A Docked toolbar “sticks” to the side of your screen at 
all times.
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For example, if you are creating an advertisement for your 
company picnic, you can have a Universal, Floating toolbar 
with buttons that start PageMaker®, open a specific project 
folder on your hard drive, change the view of the pamphlet to 
75 percent, and save your work. 

You can move a Floating toolbar anywhere on your desktop 
by clicking on the title bar of the toolbar and dragging it to 
another desktop location. You can resize a Floating toolbar by 
clicking on the lower right corner of the toolbar and dragging. 
You can also click the collapse button on the upper right 
corner of a toolbar to toggle between showing and hiding the 
toolbar buttons.

Toolbar Scope
Toolbar Scope is the range of operation for a toolbar. For 
example, you can choose whether a specific toolbar only 
displays when Microsoft Word is active, or whether it appears 
regardless of which application is active. The two static items 
in the Set list are Universal and Finder scope. Select Universal 

when you want the selected toolbar to display regardless of 
which applications are open. The other options in the Scope 
list are dependent upon the applications you have open and 
the applications that have Shortcuts assigned to them.

Keystroke
Position your cursor in the Keystroke box and press the keys you 
want to use to open the selected toolbar. Figure 82: A Floating toolbar can appear anywhere on your 

desktop. It behaves much like a standard Finder 
window.

Figure 83: When a toolbar is scoped to a particular application, it only 
appears when that application is active.

The “Links” toolbar 
option shown in this 
illustration is scoped to 
Adobe Photoshop®. 
This means the “Links” 
toolbar can only be 
selected from the 
QuicKeys menu when 
Adobe Photoshop is 
the active application.

Figure 84: Use the Keystroke box to 
set keystroke triggers.
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Show Large Icons
Select the Show Large Icons check box when you want your 
toolbar button icons to be larger.

Show Toolbar Titles
Select the Show Toolbar Titles check box when you want the name 
of each Shortcut to display in the corresponding button. When 
this option is not selected, only the toolbar button icons 
display.

❖ If you have Show Toolbar Titles selected for a particular 
toolbar and Show Toolbar Hot Help selected for all  your 
toolbars, the toolbar hot help does not appear for 
the toolbar that displays toolbar titles.

Figure 85: The same toolbar using small and large icons.

If you Control+click an area of a 
QuicKeys toolbar that does not 
contain a toolbar button, a menu 
appears that enables you to switch 
between large and small toolbar icons.

Figure 86: A Floating toolbar that displays toolbar titles.

If you Control+click the title bar 
or an area of a QuicKeys toolbar 
that does not contain a toolbar 
button, a menu appears that 
enables you to switch between 
large and small font in your 
toolbar titles.
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THE SHORTCUTS PANE
The Shortcuts pane displays all of the Shortcuts you have 
created with QuicKeys. You can add toolbar buttons to 
toolbars displayed on your desktop using this area of the tab. 
Just select the Set that contains the Shortcuts you want to use 
and drag the Shortcuts to a toolbar displayed on your 
desktop.

THE INSTRUCTION PANE
The Instruction pane contains an option to Show Toolbar Hot 
Help and it provides instructions for using the Toolbars tab. 

Show Toolbar Hot Help
Select the Show Toolbar Hot Help check box when you want the 
name of each Shortcut to display when you position your 
cursor over a toolbar button. When you select this check box, 
it applies to all toolbars. 

❖ If you have the Show Titles option selected for a 
particular toolbar, toolbar hot help does not appear 
because the information is redundant.

CREATING TOOLBARS
The Toolbars tab of the QuicKeys Editor is the control center 
for your QuicKeys toolbars. It is the only place from which 
you can create QuicKeys toolbars and it enables you to 
manage every aspect of your toolbars from a single window. 
The number of toolbars you can create is limited only by the 
memory you have allocated to QuicKeys. See page 47 for 
more information.

To create a QuicKeys Toolbar:

1. Open the QuicKeys Editor and click the Toolbars tab.

2. Click the New button.

3. Type a name for the Toolbar at the prompt and click OK. 
The toolbar appears on your desktop and the toolbar name 
displays in the Toolbars pane of the Toolbars tab.

4. With the toolbar still selected in the Toolbars pane, select 
the attributes for your toolbar in the Toolbar Options pane. 
By default, the toolbar attributes are set to Floating and 
Universal.

5. If you want to display the toolbar by pressing a keystroke, 
position your cursor in the Keystroke box and press the keys 
you want to use to open the toolbar.

6. Select the Show Large Icons check box if you want to make the 
buttons on your toolbar larger.

Figure 87: The Shortcuts pane 
of the Toolbars tab.

Figure 88: The Instruction pane 
of the Toolbars tab.
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7. Select the Show Toolbar Titles check box if you want to display 

the Shortcut name in the toolbar button.

8. Select the Show Toolbar Hot Help button to display Shortcut 
names when you position your cursor over corresponding 
buttons. If you select this check box, it affects all  your 
QuicKeys toolbars.

9. Click a different tab or close the QuicKeys Editor to save 
your new toolbar.

ADDING BUTTONS TO TOOLBARS
You can add buttons to your toolbars a number of different 
ways, depending upon whether or not the QuicKeys Editor is 
open on your desktop. 

If the QuicKeys Editor is open:

• Drag a Shortcut from the Shortcuts pane of the Toolbars 
tab to the QuicKeys toolbar that appears on your desktop.

If the QuicKeys Editor is closed:

• Drag a file to a QuicKeys toolbar to create a File Launch 
Shortcut.

• Drag selected text to a QuicKeys toolbar to create a Type 
Text Shortcut.

• Drag a folder to a QuicKeys toolbar to create a Folders 
Shortcut.

• Drag a URL to a QuicKeys toolbar to create a Web 
Launcher Shortcut.

TRIGGERING SHORTCUTS WITH 
TOOLBARS

There are four ways you can trigger Shortcuts with QuicKeys 
toolbars:

• Click a toolbar button. The Shortcut represented by the 
selected toolbar button immediately springs into action.

• Drag a file, folder, or selected text to an existing toolbar 
button. For example, if you drag a SimpleText file over a 
toolbar button that launches Microsoft Word, the contents 
of the SimpleText file appear in Microsoft Word.

• Select an option from a toolbar pop-up menu. For example, 
if you have a Specials Shortcut on a toolbar, click the pop-
up arrow to display a list of Shortcuts you can trigger.

Figure 89: You can restart your computer by selecting Restart 
in a Specials toolbar pop-up menu.
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• Drag a file or folder to the arrow on a File Handler or 
Folders toolbar button and select the action you want 
performed in the drop-down window that appears. For 
example, if you drag a Microsoft Word document to a File 
Handler button on your toolbar, you can choose which File 
Handler action to perform on the file.

• Press the number on your keyboard (0-9) that corresponds 
with the toolbar button you want to select. (This only 
works for Click-N-Go toolbars.)

DISPLAYING TOOLBARS
You can display, or trigger, toolbars using one of the following 
methods.

• Press the keystroke you assigned to it.

• Open the QuicKeys menu and select it from the Toolbars 
submenu.

❖ When the QuicKeys Editor is open, only one toolbar 
can be displayed at a time.

ALWAYS ON TOP
When you Control+click the title bar or an area of an open 
toolbar that does not  contain a toolbar button, you see a 
contextual menu. One of the options in the contextual menu is 
Always On Top. When this option is checked, the selected 
QuicKeys toolbar always stays in the foreground, regardless 
of which application is active or how many windows are 
open. If this option is not  selected, the toolbar retreats into the 
background as you open windows or switch applications.

If the Hide QuicKeys Backgrounder check box is checked in the 
QuicKeys Editor Options dialog and you uncheck the Always On 
Top option in the contextual menu, the alert shown in 
Figure 92 appears. If you select Yes in this alert window, the 
Hide QuicKeys Backgrounder option is automatically unchecked in 
the Options dialog so you are able to see all your toolbars.

Figure 90: The File Handler toolbar button supports dynamic 
menu selections.

Figure 91: Click-N-Go toolbars enable you to select toolbar 
buttons by pressing the corresponding number 
on your keyboard.

Figure 92: This alert window appears if the QuicKeys Backgrounder is 
hidden and you uncheck the Always On Top option for a 
QuicKeys toolbar.
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EDITING TOOLBARS

After you create a QuicKeys toolbar, you may want to 
rearrange the way the buttons are positioned or adjust the size 
or location of the toolbar. This section tells you how to 
accomplish these tasks and more. 

ADJUSTING TOOLBAR SIZE
Position your cursor on the lower right edge of the toolbar 
and drag the toolbar to the size you prefer.

CHANGING TOOLBAR ICONS AND FONT SIZE
To change toolbar icon size or title font:

1. Control+click the title bar or an area of an open toolbar that 
does not  contain a toolbar button.

2. Select Large Icons, Small Icons, Large Font, or Small Font in the 
contextual menu that appears. Your toolbar changes 
immediately. 

RE-ARRANGING TOOLBAR BUTTONS
You can rearrange the buttons on a toolbar by dragging them 
to the area of the toolbar where you want them displayed. As 
you drag a button, a gray outline appears to indicate where 
the button will be positioned when you release your mouse.

CHANGING TOOLBAR STYLE AND SCOPE
If you want to change toolbar style or scope, follow the steps 
in this section. You can change the style of toolbars using the 
contextual menu or the QuicKeys Editor.

Using the Contextual Menu

1. Control+click the title bar or the area of an open toolbar 
that does not  contain a toolbar button.

2. Select Docked, Floating, or Click-N-Go in the contextual menu 
that appears. Your toolbar changes immediately. 

Using the QuicKeys Editor

1. Select Edit Toolbars from the QuicKeys menu.

2. Select the toolbar you want edit in the Toolbars pane.

3. Select the Docked style in the Type pop-up menu.

4. Select Universal in the Scope pop-up menu.

PLACING TOOLBARS ON TOP
By default, QuicKeys toolbars are set to always display on top 
of other windows that appear on your desktop. If you want to 
change this setting for one of your Universal-scoped toolbars, 
Control+click an area of an open toolbar that does not  contain 
a toolbar button and select Always On Top from the contextual 
menu that appears. When there is no longer a check mark next 
to the Always On Top option, your QuicKeys toolbar behaves like 
all other windows and retreats into the background as you 
open new windows.

Figure 93: Control+click an area of a QuicKeys toolbar that does not 
contain a toolbar button to display the contextual menu shown 
here. Items in the menu that have a check mark are chosen as 
attributes for that particular toolbar.
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If you Control+click a toolbar on your desktop that is scoped 
to an application, you cannot uncheck the Always On Top option. 
Scoped toolbars must always remain on top since they are 
only displayed when that particular application is active.

❖ The QuicKeys Backgrounder must be running for 
the Always On Top feature to function properly.

CLEANING UP TOOLBARS
If you have rearranged the buttons on your toolbars, you may 
find that your toolbar buttons are not evenly spaced. To fix 
this, Control+click the title bar or an area of the toolbar that 
does not contain a toolbar button and select Clean Up Buttons 
from the contextual menu that appears. Your toolbar buttons 
are instantly arranged in an orderly fashion on your toolbar.

HIDING TOOLBARS
To hide a QuicKeys toolbar, Control+click the title bar or an 
area of the toolbar that does not  contain a toolbar button. In 
the contextual menu that appears, click Hide.

If you are trying to close a Dockable or Floating toolbar you 
can also click the close box on the toolbar to hide it.

To display the toolbar again, select it from the Toolbars 
submenu in the Quickeys menu or press the keystroke you 
assigned to the toolbar.

IMPORTING TOOLBARS
When the Toolbars tab is displayed in the QuicKeys Editor, 
the File > Import Toolbar option is enabled. You can import 
toolbars that your friends and co-workers send to you. 

To import a QuicKeys toolbar:

1. Open the QuicKeys Editor and select the Toolbars tab.

2. Select Import Toolbar from the File menu. A standard Open 
dialog appears.

3. Navigate to the location of your toolbar on your hard 
drive.

4. Select the toolbar you want to import.

5. Click the Import without Keystrokes check box if you do not  want 
to preserve the keystroke that was originally assigned to 
this toolbar.

6. Click the Open button. The new toolbar is immediately 
available in the Toolbars tab. The attributes of imported 
toolbars are set to the scope and type that were specified 
when the toolbars were created.

Figure 94: Use this window to navigate to the 
toolbars you want to import.
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EXPORTING TOOLBARS

You may want to export your toolbars to share them with 
your colleagues or to archive them. When you export a 
toolbar, a copy of the toolbar is made and saved to a drive or 
folder you specify. The original toolbar remains listed in the 
Toolbars tab of the QuicKeys Editor.

To export your QuicKeys toolbars:

1. Open the QuicKeys Editor and select the Toolbars tab.

2. Select Export Toolbar from the File menu. A standard Save 
dialog appears.

3. Navigate to the drive or folder where you want to store 
your toolbar.

4. Click Save to save the toolbar to the chosen location.

❖ To use the exported toolbars that have been 
archived or sent to another QuicKeys user, the 
recipient of the exported toolbars must use the 
QuicKeys import feature.

CLOSING TOOLBARS
To close a QuicKeys toolbar, use one of the following 
methods.

• Uncheck the toolbar by selecting it in the Toolbars 
submenu of the QuicKeys menu.

• Select the Toolbars tab in the QuicKeys Editor and click in 
the S/H (Show/Hide) column to toggle between showing 
and hiding the selected toolbar.

• Press the keystroke assigned to the toolbar again.

• Click the close box if it is a Dockable or Floating toolbar.

• Control+click an area of the toolbar that does not contain a 
toolbar button and select Hide from the contextual menu 
that appears.

DELETING TOOLBARS
To delete a QuicKeys toolbar:

1. Select the Toolbars tab in the QuicKeys Editor.

2. Select the toolbar you want to delete from the list of 
toolbars.

3. Click the Delete button. 

4. Click OK at the prompt to remove the toolbar

WORKING WITH TOOLBAR BUTTONS
After creating a QuicKeys toolbar and adding toolbar buttons, 
you may want to rearrange the buttons or change the button 
icons. This section provides information on completing these 
tasks.

DISPLAYING BUTTON TITLES
Button titles are the names of your Shortcuts represented by 
toolbar buttons. For example, if you have a Shortcut named 
“FileMaker Pro,” the button title for that Shortcut is 
“FileMaker Pro.” To display button titles on a toolbar, 

Figure 95: Use this dialog to set the destination for 
your exported toolbars.
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Control+click the area of an open toolbar that does not  contain 
any toolbar buttons. Choose Show Button Titles from the 
contextual menu that appears to toggle between showing and 
hiding your toolbar button titles.

CHANGING BUTTON FONT SIZE
To change the size of the font titles in your toolbar buttons, 
Control+click the area of an open toolbar that does not  contain 
any toolbar buttons. Choose whether you want to use Small 
Font or Large Font from the contextual menu that appears.

CHANGING BUTTON ICONS
There are two types of custom icons: icons from the 
applications installed on your computer and icons you 
import. The icons from your installed applications are 
supplied to QuicKeys dynamically. However, you can also 
import icons to use in toolbars. 

Using Icons Supplied with QuicKeys
QuicKeys offers a variety of icons you can use in your 
toolbars. 

To select an icon from QuicKeys’ icon list:

1. Control-click a button on the toolbar displayed on your 
desktop.

2.  Select Choose Icon from the contextual menu that appears.

3. In the icon list, choose the icon you want to use in place of 
the toolbar button you selected and click the Select button. 

The icon you chose immediately replaces the icon in the 
toolbar button.

Adding Icons to the Icon List
If you find an icon you would like to use in a QuicKeys 
toolbar, use the copy/paste function or the import option to 
add it to your toolbar icon list. 

To paste an icon into your icon list:

1. In the Finder, select the icon you want to use and press 
Command+I to get information on the icon.

Figure 96: Control+click a toolbar button to change the toolbar 
button icon or to delete the toolbar button.

Figure 97: Icons in the icon list are installed with 
QuicKeys or taken from other 
applications installed on your 
computer.



67• • • •

2. Select the icon from the Information dialog that appears 

and press Command+C to copy it to your clipboard. See 
Figure 98.

3. Close the Information dialog.

4. Control+click a button on a QuicKeys toolbar and select 
Choose Icon from the contextual menu that appears.

5. In the icon list that appears, click the Paste button. The icon 
you selected in the Information dialog appears in the icon 
list.

6. Click the Select button in the icon list to replace the existing 
toolbar icon with the icon you copied from the clipboard.

To import an icon into your icon list:

1. Control+click a button on a QuicKeys toolbar and select 
Choose Icon from the contextual menu that appears.

2. In the icon list that appears, click the Import button.

3. Navigate to the location of the icon family you want to 
import and select a file from the icon family.

4. Click Open. An Import Status window appears while the 
icon family is imported into the QuicKeys icon list.

5. Choose one of the newly imported icons from the icon list 
and click Select.

Using Default Icons
If you want to return to the toolbar icon that was originally 
placed on the button, Control+click the toolbar button you 
want edit and select Use Default Icon from the contextual menu 
that appears. The icon on the selected toolbar button 
immediately switches back to the default icon.

DELETING TOOLBAR BUTTONS
You can delete toolbar buttons with the contextual menu or in 
the QuicKeys Editor.

FROM THE CONTEXTUAL MENUS

1. Control+click the QuicKeys toolbar button you want to 
remove.

2. Select Delete Button from the contextual menu that appears.

3. Click OK in the alert window that appears. The button is 
immediately removed from the toolbar.

❖ Only the toolbar button is removed. The actual 
Shortcut is still available in the QuicKeys Editor.

FROM THE QUICKEYS EDITOR

1. Open the Toolbars tab in the QuicKeys Editor.

2. In the Toolbars pane, click the toolbar you want to display.

3. When the toolbar appears on your desktop, drag a button 
off the toolbar to delete it.

Figure 98: In this illustration, the square around the icon indicates 
that the icon has been selected and is ready to be copied 
to the clipboard.
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TEXT TOOLS

The QuicKeys Type Text, Type Date/Time, and Advanced 
Text Tools Shortcuts save you time by typing the information 
you need with a QuicKeys trigger. This chapter provides 
instructions for using these Shortcuts to type text, type the 
date and time in a specified format, reformat selected text, and 
much more.

TYPE TEXT
The Type Text Shortcut is useful when you want to type 
frequently-used text with a simple trigger. For example, you 
can use this Shortcut to type your signature line in E-mail 
messages or to enter common information into databases. The 
text limit for the Type Text plug-in is 255 characters. If you 
have larger sections of text you want to paste, use the Scrap 
Ease plug-in discussed on page 108.

SETTING UP TYPE TEXT SHORTCUTS
There are three ways to create QuicKeys Type Text Shortcuts: 
use the Setup Assistant, use the Shortcut Properties dialog, or 
use the contextual menu.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions. 

Using the Shortcut Properties Dialog

To create a Type Text Shortcut:

1. Select Create > Text Tools > Type Text.

Figure 99: The Type Text Setup Assistant.
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2. Type the text you want to use when you trigger this 
Shortcut. 

3. If you want to choose a keystroke to trigger this Shortcut, 
click in the Keystroke box and press the key(s) you want to 
use. For example, press the Command key, the Option key, 
and the S key simultaneously.

4. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

5. Close the QuicKeys Editor and open your word processing 
or E-mail application. Position your cursor in the 
document and press the keystroke or other trigger you 
assigned to this Shortcut. The text you specified is instantly 
typed into the open document.

Using the Contextual Menu
When you Control+click a file in the Finder of Mac OS 8.0 or 
greater, a contextual menu appears. QuicKeys places an 
option on the contextual menu you can use to create a Type 
Text Shortcut.

To create a Type Text Shortcut:

1. Press the Control key at the same time you click a block of 
selected text in a word processing or text editing 
application.

2. Select Create QuicKey from the contextual menu that appears. 
A Shortcut dialog appears.

3. Choose Type Text from the Type pop-up menu.

4. Type a name for the Shortcut.

5. Position your cursor in the Keystroke box and press the 
key combination you want to use to trigger this Shortcut.

6. Click OK when you are finished. Your new Shortcut is 
immediately available to you using the trigger you 
specified.

TYPING THE DATE AND TIME
The Type Date/Time Action is useful when you want to insert 
the date and/or time into documents. For example, you can 
use this Shortcut to insert the date and time in your weekly 
reports.

The date and time formats are governed by the format 
selected in the Date/Time control panel. If the format is 
changed in the control panel, the format of the Shortcut will 
reflect those changes.

Figure 100: The Type Text Shortcut Properties dialog.
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SETTING UP TYPE DATE/TIME SHORTCUTS

There are two ways to create QuicKeys Type Text Shortcuts: 
use the Setup Assistant or use the Shortcut Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions. 

Using the Shortcut Properties Dialog

To create a Date/Time Shortcut:

1. Select Create > Text Tools > Type Date/Time.

2. Select the date and time format you want to use when you 
trigger this Shortcut. 

3. If you want to choose a keystroke to trigger this Shortcut, 
click in the Keystroke box and press the key(s) you want to 
use.

4. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

5. Close the QuicKeys Editor and open your word processing 
or E-mail program. Position your cursor in the document 
and press the keystroke or other trigger you assigned to 
this Shortcut. The date/time is inserted using the format 
you specified.

Figure 101: The Type Date/Time Setup Assistant.

Figure 102: The Type Date & Time Shortcut Properties dialog.
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ADVANCED TEXT TOOLS
The Advanced Text Tools Shortcut is useful when you want to 
manipulate blocks of text. For example, use this Shortcut to 
eliminate those pesky quote marks from your E-mail 
messages before you forward the message to another person. 
The tasks available using the Advanced Text Tools include:  

SETTING UP ADVANCED TEXT TOOLS SHORTCUTS
There are two ways to create QuicKeys Advanced Text Tools 
Shortcuts: use the Setup Assistant or use the Shortcut 
Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

To create an Advanced Text Tools Shortcut:

1. Select Create > Text Tools > Advanced Text Tools.

2. Select an option in the Action pop-up menu and complete 
any other options that appear as a result of your selection. 
For example, specify a quote character and line length if 
you select Quote.

• Reformat Text • Upper Case

• Quote Text • Lower Case

• Remove Quotes • Title Case

Figure 103: The Advanced Text Tools Setup Assistant.
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3. Type a name for the new Shortcut in the Name field.

4. If you want to choose a keystroke to trigger this Shortcut, 
click in the Keystroke box and press the key(s) you want to 
use. 

5. Click OK. Your new Shortcut immediately appears in the 
Keysets tab of the QuicKeys Editor.

6. Close the Quickeys Editor and open a word processing 
document that already contains text. 

7. Select a block of text and press the keystroke you assigned 
to this Shortcut. The block of text you selected is 
immediately changed, depending on what type of Shortcut 
action you chose.

ADVANCED TEXT TOOLS OPTIONS
This section describes the Shortcut-specific properties 
available with the Advanced Text Tools plug-in.

Prompt for Action
If you select this check box, QuicKeys prompts you to select a 
formatting type when you trigger the Advanced Text Tools 
Shortcuts.

Reformat
Removes carriage returns and white space from selected text. 
This is especially useful for people who want to copy text 
from a Web page or an E-mail message.

Figure 104: The Shortcut Properties dialog for the Quote plug-in.

Figure 105: Text that has not been reformatted.
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Quote
Inserts a pre-specified character at the beginning of each line 
of selected text. For example, this option is useful if you want 
to forward a message from a client to your manager and you 
need to distinguish your comments from the customer’s 
comments.

Character
Specify a character for the Quote Text option. You can specify 
up to five characters in this field.

Line Length
Specify the number of consecutive characters the Quote Text 
option counts before inserting the pre-specified quote 
character.

Remove Quotes
Deletes the quote character inserted at the beginning of each 
line of selected text. This option is useful when E-mail reply 
text needs to be copied to a word processing document.

Uppercase
Converts all selected text to uppercase characters. For 
example, the sentence you just read would look like this after 
selecting it and triggering the Uppercase option: CONVERTS 
ALL SELECTED TEXT TO UPPERCASE CHARACTERS.

Lowercase
Converts all selected text to lowercase characters. For 
example, the sentence you just read would look like this after 
selecting it and triggering the Lowercase option: converts all 
selected text to lowercase characters.

Title Case
Converts all selected text to title case characters. For example, 
the sentence you just read would look like this after selecting 
it and triggering the Title Case option: Converts All Selected 
Text To Lowercase Characters.

Figure 106: Text that has been reformatted.

Figure 107: This is an illustration of what quoted text looks like. In 
this example, the greater than (>) character is used to 
distinguish the customer’s comments from the sender’s 
comments.



75• • • •

Cipher Text
Safeguards selected text. This process scrambles the text so the 
content remains secure. For example, this option would be 
useful if you were sending an E-mail message over the 
Internet and you wanted to make the text of the message more 
difficult to access.

❖ Only QuicKeys 4.X or QuicKeys® PowerPak users 
can decipher scrambled text.

Decipher Text
Deciphers text that has been scrambled with the Cipher Text 
option.
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CHAPTER 8

• • • • • •
FILE TOOLS

All computer users must learn how to manipulate files and 
folders early in their computer experience. Navigating 
through countless directories searching for that one file soon 
becomes second nature out of necessity, but such tasks can 
also become quite time-consuming. Quickeys can automate 
these tedious processes with plug-ins such as Batch Processor, 
Open, Folders, File Handler, and Recent Files.

BATCH PROCESSOR
The Batch Processor Shortcut can be an invaluable tool if you 
routinely perform the same actions on multiple files. The 
Batch Processor runs a sequence of steps on a group of files 
you specify. For example, you can convert a group of graphics 
from PICT to GIF format, or you can format a series of 
desktop publishing documents.

 ▲ To use the Batch Processor plug-in, you must be familiar 
with QuicKeys Sequences. For more information on 
Sequences, see Chapter 14.

SETTING UP BATCH PROCESSOR SHORTCUTS
Three basic operations must be completed to create a Batch 
Processor Shortcut: specify the files to be processed, create a 
Sequence that processes the files, and specify the Batch 
Processor trigger. The following series of steps takes you 
through each of these operations. If you have any difficulty 
with your Batch Processor Shortcut, make sure you read 
through the Batch Processor guidelines that follow this 
section.

To set up a Batch Processor Shortcut:

1. In the Finder, create a source folder containing all the files 
that are part of the batch processing job.

2. Create a destination folder anywhere on your hard drive 
where the files will be stored after they are processed.

3. Open one of the files you want to process and, using the 
file as a “test subject,” create a Sequence containing all the 
steps you want to perform on the files in the source folder. 
Make sure the Sequence contains a step that saves the file 
to the destination folder you created in Step 2.

4. Open your new Sequence and insert a Pause for your first 
step. See page 154 for more information on Pauses.

5. Click OK to close the Sequence Editor.

6. In the QuicKeys Editor, select the Keysets tab and choose 
Create > File Tools > Batch Processor.
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7. In the Batch Processor Shortcut Properties dialog, click the 
Select Folder button.

8. Navigate to the source folder you created in Step 1 and 
click Open.

9. Check the Backup Source Folder check box in the Shortcut 
Properties dialog to make a copy of your files before 
processing them. This option ensures that your original 
files will not be affected if something goes wrong during 
the batch process.

10.Click the Select Application button and locate the application 
you want to use to process the selected files.

11. Click the Select Sequence button.

12.Choose the Sequence you created in Step 3. Click the 
Universal radio button if your Sequence is part of the 

Universal Set or click the application-specific radio button 
if your Sequence is scoped to a particular application. 

13.Click OK when you are finished selecting a Sequence. The 
Shortcut Properties dialog again appears.

14.Type a name for this Shortcut in the Name box.

15.Specify a trigger for this Shortcut and click OK. 

TRIGGERING BATCH PROCESSOR SHORTCUTS
When you’re ready to process the selected files, trigger the 
Batch Processor Shortcut. An icon resembling a cassette 
flashes over the Apple icon during playback. QuicKeys takes a 
moment to sort out the different components of the project so 
give it time to get started after you trigger the Shortcut. When 
the process is finished, your altered files are located in the 
destination folder you created in Step 2 and your original files 
remain in the source folder.

Batch Processor Guidelines
Remember the following guidelines when you create a 
Sequence for the Batch Processor.

Figure 108: The Batch Processor Shortcut Properties dialog. Figure 109: Select a Sequence from 
the Sequence list.
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• Do not include the Open File step as part of your 

Sequence; the Batch Processor plug-in performs this action 
as part of its standard operation.

• The Batch Processor plug-in cannot work smoothly with 
applications that display splash screens or informational 
dialogs. For example, a “Tip of the Day” window displays 
by default when you launch Microsoft Word. To avoid 
conflicts in your batch process, adjust your respective 
application preferences to avoid displaying these types of 
prompts.

• You must typically include the Save command in the 
Sequence.

• Test your Sequence before using it in the Batch Processor.

• Do not save the files to the source folder or you will create 
an endless loop.

• Create a Folder Shortcut if you want all your processed 
files sent to the destination folder.

The Batch Processor Results Window
When your batch processing job is finished, the Results dialog 
displays. It shows the number of files processed and the 
number of files skipped. A file is skipped when it is locked, 
busy, or cannot be opened by the specified application. The 
Results dialog automatically closes after 15 seconds if you 
don’t click OK.

The Batch Processor plug-in also keeps a log of its progress so 
you know the cause of any problems that occur during the 
playback of the Shortcut. To see the log report, double-click 
the log file. It is located in the folder level above the source 
folder. The file is named <source folder name>.processed.log. The log 
report can be opened in any word processor or text editor.

Figure 110: The Batch Processor Results window.
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FILE HANDLER
The File Handler Shortcut is useful when you want to rename, 
move, or edit the attributes of selected files. Attributes can be 
anything from security access to file types. This feature is 
extremely valuable if you ever work with large batches of 
files. 

For example, some Web sites make heavy use of scanned or 
digital photographs. Often, these are delivered in large 
batches to Web Site Managers to be posted on the Web. 
QuicKeys makes it possible to rename all the images at once 
with numerical or alphabetical modifiers, so that files named 
001.jpg, 002.jpg, etc, can be renamed chicago001.jpg, 
chicago002.jpg, etc. This helps identify the batch of images. 

Additionally, files can be locked and unlocked by QuicKeys 
with a single keystroke or mouse click. This is valuable when 
you want to lock a batch of original images to ensure that 
modifications are made only to copies. The tasks, or Shortcuts, 
available with File Handler include:

 ▲ Each of the File Handler shortcuts must be triggered in the 
Finder.

SETTING UP FILE HANDLER SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > File Handler.

3. Select an option from the Action pop-up menu. For example, 
choose Lock Selected Files.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke to the Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Select a file on your hard drive. Press the keystroke or 
other trigger you assigned to this Shortcut. The action you 
selected for this Shortcut should immediately alter the 
selected file.

Using Drag-and-Drop
If you have a File Handler Shortcut on one of your QuicKeys 
toolbars, you can use drag-and-drop functionality to make 
creating File Handler Shortcuts even easier. Just drag a file to a 
File Handler button on your toolbar and select the action you 

• Lock Selected Files • Unlock Selected Files

• Rename Selected Files • Move Selected Files

• Set File Type • Set File Creator

Figure 111: The File Handler Shortcut Properties dialog.
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want performed in the drop-down window that appears. For 
example, if you drag a Microsoft Word document to a File 
Handler button on your toolbar, you can choose which File 
Handler action to perform on the file.

FILE HANDLER OPTIONS
This section describes the Shortcut-specific properties 
available with the File Handler plug-in.

Lock/Unlock Selected Files
With a Mac computer, you can protect a file by selecting it, 
clicking the Get Info option, and selecting the Locked check box in 
the Info dialog. When a file is locked, you can open and copy 
its contents, but you can’t change or delete the file. QuicKeys 
simplifies this process by allowing you to lock and unlock files 
with a single keystroke.

Rename Selected Files
Typically, if you want to rename a large number of files, you 
must select each file and type a new name for it. You can avoid 
that long process by using QuicKeys to append text or 
numbers to multiple files automatically. Use it with the Batch 
Processor plug-in (discussed on page 77) so you can move on 
to other projects while QuicKeys finishes the tedious tasks.

Prefix Text
Select Prefix Text when you want to insert specific characters at 
the beginning of a filename. For example, change “First File” 
to “QKFirst File.”

Figure 112: The File Handler toolbar button supports 
dynamic menu selections.

Figure 113: Rename selected files with user-specified prefix text.
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Prefix Variable
Select Prefix Variable when you want to insert alphanumeric 
characters at the beginning of a filename. For example, change 
“First File” to “AAAFirst File.”

Text & Variable
Select Text & Variable when you want to replace existing 
filenames with both user-specified text and  alphanumeric 
characters. For example, change “First File” to “QuicKeysA.”

Figure 114: Rename selected files with one of four available variable 
formats.

Figure 115: Rename selected files with Text and one of four available 
variable formats.
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Variable & Text
Select Variable & Text when you want to replace existing 
filenames with both alphanumeric characters and  user-
specified text. For example, change “First File” to 
“1QuicKeys.”

Append Text
Choose Append Text when you want to add user-specified text to 
selected filenames. For example, change “First File” to “First 
FileQK.”

Figure 116: Rename selected files with Text and one of four available 
variable formats.

Figure 117: Add user-specified text to the end of selected filenames.
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Append Variable
Choose Append Variable when you want to add one of the four 
available variable formats to selected filenames. For example, 
change “First File” to “First File1.”

Move Selected Files
When working with computers, there are many times when 
you need to move files around to organize them or make them 
more accessible. With the Move Select Files component of the File 
Handler plug-in, you can move selected files to the Desktop, 
Trash, to a user-specified folder, up one folder level, or out of 
all folders to the main level of the drive.

Figure 118: Add one of the four available variable formats to the end of 
selected filenames.

Figure 119: Choose where you want to move your selected files.
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Set File Type/Creator
Type and Creator files consist of four characters that the Mac 
recognizes and links to a specific application. Most 
applications have at least two “types” associated with them. 
For example, SimpleText uses “TEXT” for “read/write” files 
and “ttro” for “read only” files. If you want to change 
SimpleText “read only” files to “read/write” files quickly, you 
can use a Set File Type shortcut to assign the file “read/write” 
attributes with a single keystroke.

❖ These shortcuts do not  alter the contents of your 
files.   

 

FILE LAUNCH
The File Launch Shortcut is useful when you want to open 
applications and documents with a trigger. For example, you 
can use this Shortcut to open a report you frequently need to 
edit.

❖ The File Launch plug-in can only display 
application-specific icons if you are using system 8.5 
or greater. 

SETTING UP FILE LAUNCH SHORTCUTS
There are four ways to create QuicKeys File Launch Shortcuts: 
use the Setup Assistant, use the Shortcut Properties dialog, 
use the contextual menu, or use drag-and-drop functionality.

Figure 120: Choose the file type or creator you want to use for your 
selected files.

Example File Types: Example Creator Codes:

XLS5 — Microsoft Excel XCEL — Microsoft Excel

TEXT — SimpleText Read/Write ttxt — SimpleText 

ttro — SimpleText Read Only

W6BN — Microsoft Word 6 MSWD — Microsoft Word

8BPS — Adobe Photoshop 8BIM — Adobe Photoshop
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Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > File Launch. A standard Open dialog 
appears.

3. Navigate to the file you want to launch with this Shortcut 
and click Open. The Shortcut Properties dialog appears with 
the file you selected listed in the Name field.

4. Click the Include in QuicKeys menu check box.

5. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

6. Close the QuicKeys Editor.

7. Select this Shortcut from your QuicKeys menu. The file 
you specified immediately opens.

Using the Contextual Menu
When you Control-click a file in Mac OS 8.0 or greater, a 
contextual menu appears. QuicKeys places an option in the 
contextual menu you can use to create a File Launch Shortcut.

To create a File Launch Shortcut:

1. Press the Control key at the same time you click a file.

Figure 121: The File Launch Setup Assistant.

Figure 122: The File Launch Shortcut Properties dialog.
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2. Select Create QuicKey from the contextual menu that appears. 

A Shortcut Properties dialog appears.

3. Choose File Launch from the Type pop-up menu.

4. Position your cursor in the Keystroke box and press the key 
combination you want to use to trigger this Shortcut.

5. Click OK when you are finished. Your new File Launch 
Shortcut is immediately available to you using the trigger 
you specified.

Using Drag-and-Drop
If you have a QuicKeys toolbar displayed on your desktop, 
you can drag a file to the toolbar to create a File Launch 
Shortcut. Once you drag the file to the toolbar, a button 
displays on the toolbar with the file’s name used for the 
button title. Click the button when you want to launch the file.

❖ The QuicKeys Backgrounder must be running for 
the drag-and-drop feature to work.

FILE RECALL
The File Recall Shortcut gives you more precise control of the 
files you want to locate than what is provided by the Mac. It 
enables you to find up to 100 recently modified files by 
searching modification dates using a time interval you specify. 
For example, if you download a new shareware application 
from the Internet and cannot find it when you search for it the 
next day, the File Recall plug-in can find it for you. You can 
choose from the following modification intervals when you 
direct the File Recall plug-in to locate files:

SETTING UP FILE RECALL SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > File Recall. The Shortcut Properties 
dialog appears.

3. Select an option from the Show Files Modified area of the 
dialog. For example, select In last 5 minutes to display a list of 
all the files modified in the last five minutes.

4. Type a name for the Shortcut in the Name box.

Figure 123: QuicKeys appears in some 
contextual menus. • Files modified in the 

last 5 minutes
• Files modified in the 

last 24 hours

• Files modified in the 
last 15 minutes

• Other (in minutes)

• Files modified in the 
last hour
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5. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Press the keystroke you assigned to this Shortcut. The 
status bar shown in Figure 125 appears. When QuicKeys is 
done with its search, a list of all the files modified in the 
interval you specified appears.

9. Select which document you want to open from the list 
QuicKeys prepares for you and click OK.

FILE RECALL OPTIONS
This section describes the Shortcut-specific properties 
available with the File Recall plug-in.

Omitting files from your search
You can omit specific files from File Recall’s scan for recently 
modified files. For example you probably don’t want to open 
Netscape® cache files, so you can exempt them from the File 
Recall scan. See page 167 for more information.

Other
1,440 (24 hours) is the maximum number of minutes you can 
enter in the Other box.

Figure 124: The File Recall Shortcut Properties dialog.

Figure 125: The status bar shown here appears when you 
trigger File Recall Shortcuts.

Figure 126: Select a document from the 
File Recall list.
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FOLDERS

The Folders Shortcut is useful if you frequently switch 
between folders during the course of your computer work. 
For example, if you are a Web Site Manager, your Web sites 
contain hundreds, if not thousands, of files and dozens of 
folders. Maneuvering to open or save a file within the Open 
and Save dialogs requires either a lot of mouse movement or 
keyboarding. QuicKeys increases your productivity by 
enabling you to set up Shortcuts to folders. With a simple 
Folders keystroke, you can move deep into the folder 
hierarchy and save countless hours.

SETTING UP FOLDERS SHORTCUTS
There are four ways to create QuicKeys Folders Shortcuts: use 
the Setup Assistant, use the Shortcut Properties dialog, use the 
contextual menu, or use drag-and-drop functionality. 

 ▲ When you specify a folder for the Folders Shortcut, keep 
in mind that pressing the Select button in an Open or 
Save dialog chooses the folder that is displayed in the 
destination pop-up list, even if you have a folder 
highlighted. You must open  the folder you want to select 
for QuicKeys to recognize it as the target folder.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > Folders. The Shortcut Properties 
dialog appears.

Figure 127: The Folders Setup Assistant.



90 Chapter 8
File Tools

• • • •
3. Select a folder location option. For example, select Open 
Folder and click the Select Folder button to choose the folder 
you want to open.

4. Select the Open Folder in Open/Save Dialog check box to open the 
selected folder only when an open or save dialog is in the 
foreground. See page 91 for information on the other 
options in this dialog.

5. In the Name box, type a name for the Shortcut.

6. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

8. Close the QuicKeys Editor.

9. Launch an application and select Open from the File menu. 
Press the keystroke you assigned to this Shortcut. The 
contents of the folder you specified appears. 

10.Select the file you are looking for and click OK.

Using the Contextual Menu
When you Control-click a file in the Finder, a contextual menu 
appears. QuicKeys places an option on the contextual menu 
you can use to create a Folders Shortcut.

To create a Folders Shortcut with the contextual menu:

1. Press the Control key at the same time you click a folder.

2. Select Create QuicKey from the contextual menu that appears. 
An abbreviated Shortcut Properties dialog appears.

3. Choose Folders from the Type pop-up menu.

4. Type a name for the Shortcut.

5. Position your cursor in the Keystroke box and press the key 
combination you want to use to trigger this Shortcut.

6. Click OK when you are finished. Your new Shortcut is 
immediately available to you using the trigger you 
specified.

Figure 128: The Folders Shortcut Properties dialog.

Figure 129: This dialog appears after you select 
a QuicKeys option from a contextual 
menu.
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Using Drag-and-Drop
If you have a Folders Shortcut on one of your QuicKeys 
toolbars, you can use drag-and-drop functionality to make 
creating Folders Shortcuts even easier. Just drag a file or folder 
to a Folders button on your toolbar and select the action you 
want performed in the drop-down window that appears. 

For example, if you drag a folder to a Folders button on your 
toolbar, you can choose to put the folder in the trash, Startup 
Items folder, Shutdown Items folder, System Folder, Apple 
Menu Items folder, Control Panels folder, Extensions folder, or 
the Preferences folder.

FOLDERS OPTIONS
This section describes the Shortcut-specific properties 
available with the Folders plug-in.

Open Folder
Select this option to jump to a specified folder. When you 
trigger a Folders Shortcut before  you ask your application to 
open a document, the contents of the selected folder appears 
in a standard Open dialog. Additionally, if you choose to 
switch to a folder that resides on an unmounted drive, 
QuicKeys prompts you for a user name and password and 
mounts the drive so it can display the contents of the selected 
folder.

Select Folder
Click this button to navigate to the folder you want to jump to 
when you trigger a Folders Shortcut.

Open Folder in Finder
Select this option to bring the specified folder to the 
foreground in a Finder window.

Do Not Switch to Finder
Select this option to open the specified folder in a Finder 
window at the Finder level. If this option is selected and 
another application, such as Microsoft Word is active, the 
folder window displays behind the Microsoft Word 
document.

Open folder in Open/Save dialog
Select this option to open the specified folder when a standard 
Open or Save dialog is in the foreground.

Restore Folder Location in Open/Save Dialog
Select this option to return to the folder that was current when 
you triggered your first Folders Shortcut. QuicKeys 
remembers the last-used Folders Shortcut until you restart. 
After you restart, triggering this Shortcut selects the startup 
disk.Figure 130: The Folders toolbar button supports dynamic 

menu selections.
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PROJECT SAVER
This plug-in may be one of the most valuable time-savers in 
QuicKeys. Imagine you are working on a project late in the 
afternoon and you remember that your kid’s soccer game 
starts in 30 minutes. You trigger your Project Saver Shortcut 
and shut down your computer. The next morning when you 
come into work, you simply restart your computer and press 
the Project Saver trigger again. In an instant each file that you 
were using the previous afternoon is open and ready to go.

SETTING UP PROJECT SAVER SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > File Tools > Project Saver. The Shortcut Properties 
dialog appears.

3. Select an option from the Action pop-up list. For example, 
select Create Project.

4. In the Name box, type a name for the Shortcut.

5. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Trigger the Project Saver Shortcut you created. The dialog 
shown in Figure 132 appears.

9. Type a name for the project and click OK. All the documents 
and applications that were open at the time you triggered 
the Create Project Shortcut are preserved under the project 
name you typed.

PROJECT SAVER OPTIONS
This section describes the Shortcut-specific properties 
available with the Project Saver plug-in.

Create Project
Select this option when you want QuicKeys to remember all 
the applications that are currently open. When you trigger this 
Shortcut, you must specify a name for the project and click OK.

Launch Project
Select this option when you want QuicKeys to display a list of 
available projects. When you select a project from this list and 
click the Launch button, all the applications and files that 
pertain to the selected project are launched.

Create Startup Project & Shutdown
Select this option when you want QuicKeys to memorize all 
the files that are currently open and then shut down your 
computer. 

Figure 131: The Shortcut Properties dialog for the Project Saver 
plug-in.

Figure 132: Type the name of your project at the prompt.
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Before your computer shuts down, an alias of the Project 
Saver Info file is placed in your Startup Items folder so 
QuicKeys can open the appropriate files upon restart. 
Immediately after your computer is restarted and the selected 
files are opened, the alias is deleted from the Startup Items 
folder. The project folder that contains the actual Info file is 
preserved in the <startup drive>:System 
Folder:Preferences:QuicKeys Folder:Projects folder. See the 
section in this chapter on “Editing Project Saver Shortcuts” for 
information on editing the contents of an existing project 
folder.

Close All Applications
Select this option to close all your applications with a 
QuicKeys trigger.

PROJECT SAVER TIPS

• The Project Saver plug-in depends on valid desktop files, 
so if you have difficulty using the Project Saver plug-in, try 
rebuilding your desktop. To rebuild your desktop, restart 
your computer and press the Command key and the 
Option key as your computer restarts. Do not release the 
Command+Option keys until you are prompted to rebuild 
your desktop files.

• In certain applications, Project Saver cannot recognize 
which files are open due to the way some applications 
handle files. Consequently, Project Saver Shortcuts do not 
work for all applications.

• See page 167 for information on omitting specific files from 
the Project Saver’s scan for recently modified files. For 
example, you probably don’t want Project Saver to include 
Netscape cache files as part of the project files it 
“memorizes” and opens.

EDITING PROJECT SAVER SHORTCUTS
When you want to edit existing projects you have created 
with the Project Saver Extension, open the :System 
Folder:Preferences:QuicKeys Folder:Projects folder and make 
the necessary changes to the appropriate project folder. The 
individual project folders should only contain aliases of 
applications and documents.

DELETING PROJECTS
To delete individual projects within the Project Saver 
Shortcut:

1. Trigger the Launch Project Shortcut.

2. In the project list that appears, select the project you want 
to delete.

3. Click the Delete button.

Figure 133: The Project Saver project 
list.
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CHAPTER 9
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SYSTEM TOOLS

System Tools are invaluable if you like to control or change 
the appearance and behavior of the Mac environment, but you 
don’t like digging around in the system preferences. You can 
use the System Tools plug-ins to change your screen settings, 
cut and paste text and graphics, control your PowerBook 
computer, and much more. The System Tools include:

ALIAS KEYSTROKE
To truly personalize your computer, you need to be able to 
choose how you interact with it. QuicKeys gives you this 
ability with the Alias Keystroke plug-in. This plug-in provides 
a way to change keystroke assignments built into your 
applications with QuicKeys keystrokes that make sense to 
you. For example, if you upgrade one of your applications 
only to find that your favorite built-in keystrokes have been 
changed, you can just change them right back to what you’re 
accustomed to using with the Alias Keystroke Shortcut.

SETTING UP ALIAS KEYSTROKE SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Alias Keystroke.

3. Position your cursor in the Key to type box and press the 
keystroke you want to replace. For example, if you want to 
use F5 instead of Command+I, type Command+I in this 
box.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke to the Shortcut. For example, if you 
want to use F5 instead of Command+I, type F5 in this box.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

• Alias Keystroke • App Switcher

• Button • Click

• FKEYs • Mac OS Specials

• Menu • Mousies

• PowerBook Specials • Scrap Ease

• Screen Ease • Specials

• View Switcher

Figure 134: The Alias Keystroke Shortcut Properties dialog.
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7. Close the QuicKeys Editor.

8. Press the keystroke or other trigger you assigned to this 
Shortcut. 

APP SWITCHER
App Switcher enables you to move between applications with 
a keystroke rather than a series of mouse clicks. You can create 
App Switcher Shortcuts that switch to particular applications, 
move through all open applications in succession, or toggle 
between two open applications.

SETTING UP APP SWITCHER SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > App Switcher. The Shortcut 
Properties dialog appears.

3. Select an option from the Action menu and make selections 
for any additional options that appear. 

4. Type a name for the Shortcut in the Name box.

5. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Launch a few applications. Press the keystroke or other 
trigger you assigned to this Shortcut. The application you 
selected for this Shortcut should display immediately.

APP SWITCHER OPTIONS
This section describes the Shortcut-specific properties 
available with the App Switcher plug-in.

Switch To
Choose this option to display the specific application you 
chose from the Application pop-up list of the Shortcut Properties 
dialog.

Switch Back
Choose this option to move from your current application to 
the previous application displayed.

Select Application from List
Choose this option to display a list of applications you can use 
to make a different application active.

Figure 135: The App Switcher Shortcut Properties dialog.
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Previous Application
Select this option to display the previous application listed in 
the application menu.

Next Application
Select this option to display the next application listed in the 
application menu.

Application
When the Switch To option is selected in the Action pop-up list, 
the Application pop-up list is enabled. Use this list to select 
which application you want to switch to when you trigger the 
App Switcher Shortcut. The Application list includes all the 
applications that are currently open on your computer.

Hide Other Applications
Hides other application windows when you toggle to a 
different application.

Don’t Hide Other Applications
Leaves windows visible when you toggle to a different 
application.

BUTTON
The Button Shortcut clicks radio buttons and check boxes in 
the frontmost window. For example, you might want a 
Shortcut that clicks the Cancel button in a dialog when you 
press Alt+Ctrl+C. 

❖ The Button Shortcut is especially useful in QuicKeys 
Sequences. See page 139 for more information on 
Sequences.

SETTING UP BUTTON SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Button.

3. Choose under what condition the button will be clicked. 
For example, select Always click button to always click the 
active button in a dialog.

4. Type the name of the button you want to select in the Name 
box. The name you type must match the button name 
exactly .

5. Assign a keystroke to the Shortcut.

Figure 136: In this example, FrameMaker is the “next” application 
and Photoshop is the “previous” application.

Figure 137: The Button Shortcut Properties dialog.
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6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Trigger this Shortcut whenever the button you specified 
appears in the frontmost dialog.

BUTTON OPTIONS
This section describes the Shortcut-specific properties 
available with the Button plug-in.

Always click button
Select this option to click the specified button, regardless of 
whether it is enabled or disabled. If you select this option, you 
can toggle check boxes with the same keystroke.

Only click if button is on
Choose this option to click the specified button only if it is 
currently selected.

Only click if button is off
Choose this option to click the specified button only if it is not  
currently selected.

CLICK
The Click Shortcut enables you to mimic a mouse click with a 
keystroke. This Shortcut is especially useful in QuicKeys 
Sequence Shortcuts because there are times when there is no 
keyboard equivalent for the option you want to select. For 
example, you can use the Click Shortcut to shrink a document 
window to its smallest size. Just choose the Click option from 
the Create menu and drag the window to the size you want to 
use. QuicKeys records your action and inserts the information 
from your mouse action into the Click dialog that appears.

SETTING UP CLICK SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Click. The Editor disappears 
briefly while you use your mouse to perform the Click 
action you want to record.

3. The Shortcut Properties dialog appears pre-filled with the 
coordinates and options you selected during your click 
movements.

4. Assign a keystroke to the Shortcut.

5. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

6. Close the QuicKeys Editor.

7. Trigger this Shortcut whenever you want to perform a 
click.

CLICK OPTIONS
This section describes the Shortcut-specific properties 
available with the Click plug-in.

Figure 138: The Click Shortcut Properties dialog.

‘
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Click
When you select the Click button in the Shortcut Properties 
dialog, the Click Location dialog shown in Figure 139 appears. 
The left section of the dialog displays where you pressed 
down on the mouse button. The right section of the dialog 
displays where you released the mouse button. QuicKeys 
automatically completes the Click Location dialog with the 
coordinates retrieved from the Click Shortcut you recorded. 

If you make a Click Shortcut without a drag, the release 
coordinates are always 0,0.

Screen
For both sections of the dialog you can choose whether the 
click coordinates are relative to the screen or to the frontmost 
document. When you choose Screen, the coordinates are 
measured from the top left corner of the entire screen. 

Document
For both sections of the dialog you can choose whether the 
click coordinates are relative to the screen or to the frontmost 
document. When you choose Document, the coordinates are 
measured from the extreme corners of the frontmost 
document window underneath the title bar. For example, the 
coordinates for clicking a window’s close box are X = 4, Y = -7.

Mouse Position
In the “click” section of the dialog, this coordinate represents a 
point measured from where the mouse cursor was when you 
pressed it. In the “release” section of the dialog, this 
coordinate represents the cursor’s location when you let go of 
the mouse button relative to where the button was pushed 
down. Consequently, the “click” section coordinates are 
typically set at 0,0 since it’s the starting point of the 
measurement.

Window
When you click the Window button, the Window dialog 
appears. Use this dialog to select the window in which the 
Click Shortcut performs the click. 

Any
Select Any if the click is made regardless of what is displayed 
on the screen.

Mouse click 
coordinates

Mouse release 
coordinates

Choose whether 
coordinates are relative to 
your entire screen or the 
frontmost document.

The Mouse position button 
represents a point 
measured from where 
the mouse cursor was 
when you pressed it.

Figure 139: The Click Location dialog enables you to specify screen 
coordinates for your Click Shortcuts.

Figure 140: In this example, the Click Shortcut first looks for a window 
named “Navigator,” then it looks for a window named “Info,” 
then it looks for a window named “Options.”
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Name
Select Name if you want to specify the name of the document 
you want to click on. If you want to select a window that has a 
dynamic name, list a series of comma-delimited names in this 
box. QuicKeys looks at the first name listed and if it cannot 
find that window name it proceeds to the next listed window 
name and so on. This feature is extremely effective if you try 
to click in one of PhotoShop’s floating tool palettes.

Position
Select this option if you want the click to occur in the window 
that is as many layers back from the front as the number you 
enter in the text box.

Control area
This option controls how the Click Shortcut locates a target if 
the click occurs in a control area (a button or a scroll bar). This 
option is used primarily when the control button doesn’t have 
a name.

None
This option is automatically selected if you haven’t clicked in 
a control area.

Name
Select Name if you want to specify the name of the control area 
you want to click on.

Position
Select this option if you want the click to occur in the control 
area that is as many layers back from the front as the number 
you enter in the text box.

FKEYS
FKEYs are small applications that are either built into your 
system or provided by a third-party. QuicKeys provides an 
FKEYs plug-in that enables you to launch your FKEYs with a 
QuicKeys trigger. 

Setting Up FKEYs Shortcuts

1. Open the QuicKeys Editor and select the Keysets tab.

Figure 141: The Control Area dialog.
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2. Select Create > System Tools > FKEYs. The Shortcut Properties 

dialog appears.

3. Select an option from the FKEY choices menu.

4. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

5. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

6. Close the QuicKeys Editor.

7. Press the keystroke or other trigger you assigned to this 
Shortcut. The FKEY you selected for this Shortcut should 
react immediately to the trigger.

MAC OS SPECIALS
The Mac OS Specials plug-in is a collection of Mac tools that 
automate tasks you may perform frequently on your 
Macintosh. The tasks available with Mac OS Specials include:

SETTING UP MAC OS SPECIALS SHORTCUTS
There are two ways to create QuicKeys Mac OS Specials 
Shortcuts: use the Setup Assistant or use the Shortcut 
Properties dialog.

Figure 142: The FKEYs Shortcut Properties dialog.

• Balloon Help On • Balloon Help Off

• Toggle Balloon Help • Next Application

• Previous Application • Start File Sharing

• Stop File Sharing • Start Program Linking

• Stop Program Linking
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Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Setting Up Mac OS Specials Shortcuts

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Mac OS Specials. The Shortcut 
Properties dialog appears.

3. Select an option from the Action menu.

4. Type a name for the Shortcut in the Name box.

5. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Press the keystroke or other trigger you assigned to this 
Shortcut. The action you selected for this Shortcut should 
react immediately to the trigger.

MAC OS SPECIALS OPTIONS
This section describes the Shortcut-specific properties 
available with the Mac OS Specials plug-in.

Balloon Help
Choose from three Mac OS Specials options that offer balloon 
help options: Balloon Help On, Balloon Help Off, and Toggle 
Balloon Help.

Figure 143: The Mac OS Specials Setup Assistant.

Figure 144: The Mac OS Specials Shortcut Properties dialog.
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Next Application
Use this option to switch to the application listed below the 
active application in the program menu.

Previous Application
Use this option to switch to the application listed above the 
active application in the program menu.

Start/Stop File Sharing
Choose this option to start or stop File Sharing with a simple 
keystroke.

Start/Stop Program Linking
Choose this option to start or stop Program Linking with a 
simple keystroke.

MENU
You can select any item from a menu without using a mouse 
now that you have the Menu plug-in at your disposal. The 
Menu plug-in is useful when you want to avoid using your 
mouse, or when you want to select a menu item that does not 
have a keystroke assigned to it. For example, if you don’t 
want to flip to the Finder to launch an application, you can 
put an alias of the application in the Apple menu and use a 
Menu Shortcut to launch it.

SETTING UP MENU SHORTCUTS
There are two ways to create QuicKeys Menu Shortcuts: use 
the Setup Assistant or use the Shortcut Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Setting Up Menu Shortcuts

1. Launch the application you want to use for the Menu 
Shortcut.

2. Open the QuicKeys Editor and select the Keysets tab.

3. Select Create > System Tools > Menu. Your cursor turns into a 
menu icon as a little instruction box appears.

Figure 145: The Menu Setup Assistant.

Figure 146: When this window 
appears, use your mouse 
to select a menu item.
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4. Using your mouse, select the menu item you want to use 
for this Shortcut. You can select both active and dimmed 
menu items. The Shortcut Properties dialog appears as 
soon as you make your selection.

5. The fields in the Shortcut Properties dialog are pre-filled 
with information taken by QuicKeys while you recorded 
your menu selection. 

6. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

8. Close the QuicKeys Editor.

9. Press the keystroke or other trigger you assigned to this 
Shortcut. QuicKeys instantly selects the menu item you 
specified.

MENU OPTIONS
All of the options available in the Menu dialog can be divided 
into three categories: items you can select from a menu, 
menus you can select, and modifier keys you can use to select 
special menu items.

Select from Menu
The top of the Menu dialog enables you to select menu items. 
You can choose by Text to select an item from the menu based 
on your text specifications, or you can choose by Position to 
select an item from the menu based on the item’s position in 
the menu. It is sometimes useful to select menu items by 
position because some menu items are not static (e.g . Show 
Toolbar/Hide Toolbar).

Search
The middle section of the Menu dialog enables you to specify 
how to search for menus. You can choose to look in menus 
that have a specific name, look in all menus, or you can 
restrict the menu search to the Apple menu.

Use Modifiers
The bottom of the Menu dialog enables you to select modifier 
keys that must be pressed while you select a menu item. These 
modifer keys cause certain menu items to change their form 
while the menu item is selected.

Don’t display message...
By default, if the Menu Shortcut cannot locate the menu or 
menu item you want it to find, it displays an alert window. If 
you do not  want the alert window to display, check this 
option.

Items you can 
select from a 
menu

Menus you 
can select

Modifiers you can use 
to select menu items

Figure 147: The Menu Shortcut Properties dialog.
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MOUSIES

The Mousies plug-in is useful for controlling the appearance 
and behavior of the Mac without having to use your mouse. 
The controls available with Mousies include:

SETTING UP MOUSIES SHORTCUTS
There are two ways to create Mousies Shortcuts: use the Setup 
Assistant or use the Shortcut Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

To create a Mousies Shortcut:

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Mousies.

• Close window • Zoom window

• Collapse window • Home

• End • Line up

• Line down • Page up

• Page down • Column left

• Column right • Page left

• Page right

Figure 148: The Mousies Setup Assistant.
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3. Select an option from the Action pop-up menu. 

4. Choose a keystroke or some other type of trigger for this 
Shortcut.

5. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

6. Close the QuicKeys Editor and press the keystroke or other 
trigger you assigned to this Shortcut. The action you 
specified should take effect immediately.

MOUSIES OPTIONS
This section describes the Shortcut-specific properties 
available with the Mousies plug-in.

Close window
Closes the active window.

Zoom window
Enlarges the frontmost window.

Collapse window
Uses the “window shade” feature to collapse the open 
window into the title bar.

Home
Jumps to the top of the scroll box within the vertical scroll bar.

End
Jumps to the bottom of the scroll box within the vertical scroll 
bar.

Line up
Jumps up one line.

Line down
Jumps down one line.

Page up
Jumps to the top of the current page.

Page down
Jumps to the bottom of the current page.

Column left
Jumps one column to the left.

Column right
Jumps one column to the right.

Page left
Jumps to the left page of a document.

Page right
Jumps to the right page of a document.

Figure 149: Select a Mousies action from the Action pop-up menu.
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POWERBOOK SPECIALS

PowerBook Specials are a suite of Shortcuts for Powerbook 
users. 

SETTING UP POWERBOOK SPECIALS SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Powerbook Specials. The Shortcut 
Properties dialog appears.

3. Select an option from the Action menu.

4. Type a name for the Shortcut in the Name box.

5. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Press the keystroke or other trigger you assigned to this 
Shortcut. The action you selected for this Shortcut should 
react immediately to the trigger.

POWERBOOK SPECIALS OPTIONS
This section describes the Shortcut-specific properties 
available with the Powerbook Specials plug-in.

Spin Down Hard Drive
Turns off your PowerBook’s hard drive when it is not in use. 
The hard drive automatically turns itself back on when you 
need it.

Show Cursor Location
Places a flashing circle around the cursor for a few seconds to 
help you pinpoint the cursor’s location.

Shut Down
Turns off your PowerBook.

Sleep
Puts your PowerBook in sleep mode.

Battery Desk Accessory
Displays the battery desk accessory so you can check your 
power reserves.

Toggle Backlighting
Turns backlighting on and off.

Backlighting On
Turns backlighting on.

Backlighting Off
Turns backlighting off.

Toggle Dimming
Controls the screen’s brightness.

Dim Screen
Returns the screen’s brightness to its normal setting.

Figure 150: Choose the task you want to complete from the Action pop-
up menu.
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Undim Screen
Increases the screen’s brightness.

Disable Processor Rest
Restores power requirements to their standard operating 
level.

Enable Process Rest
Reduces overall power requirements without putting the 
computer to sleep.

SCRAP EASE
If you ever use a word processor or an E-mail application, you 
probably also use the Command+X, Command+C, and 
Command+V key combinations to cut, copy, and paste text 
and graphics to and from your system clipboard. But were 
you ever frustrated by the fact that you can only store one 
item in the clipboard? Or that the items you save to the 
clipboard disappear after restart? QuicKeys solves these 
problems with the Scrap Ease plug-in.

For example, you can store any item you add to Scrap Ease for 
as long as you want. For times when the Type Text Shortcut 
can’t hold enough text, use the Scrap Ease plug-in. You have 
much better control and functionality with the Scrap Ease 
Shortcut than you have with comparable system tools.

1 
Select a block of 
text, or a graphic to 
add to your 
QuicKeys clipboard.

2
Select the QuicKeys 
Scrap Ease “copy” 
trigger to add the 
selected item to the 
QuicKeys clipboard. 

Figure 151: To use the QuicKeys Scrap Ease Shortcut, you first add Scrap 
Ease items to your clipboard collection. 

3
The selected item is added to 
the QuicKeys clipboard. 
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The QuicKeys clipboard can store and display any type of 
information supported by the original file. For example, if you 
copy text from an application that supports stylized text, the 
QuicKeys clipboard preserves all styles applied to the text in 
the original application.

SETTING UP SCRAP EASE SHORTCUTS
Figures 151 and 152 provide a general illustration of how the 
QuicKeys Scrap Ease plug-in works. First, you create a 
QuicKeys Shortcut that copies clips to your QuicKeys 
clipboard. Then, after you have added a few clips to your 
QuicKeys clipboard, you create a QuicKeys Shortcut that lets 
you paste these items into open documents. 

The Scrap Ease plug-in extends the functionality of the 
system’s Cut and Paste features, so you can maintain and use 
frequently-used files, text, and graphics with ease.

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Scrap Ease. The Shortcut 
Properties dialog appears.

3. Select an option from the Action menu.

4. Type a name for the Shortcut in the Name box.

5. Position your cursor in the Keystroke box and press the keys 
you want to use to trigger this Shortcut.

QuicKeys Scrap Ease vs. the System Clipboard

You can add hundreds of 
items to the QuicKeys 
clipboard.

The system clipboard allows one item in 
the clipboard.

You can keep items in the 
QuicKeys clipboard for as 
long as you want.

The system clipboard only holds an item 
until you restart your machine or copy 
another item to your clipboard.

5
The item you select is 
pasted into your open 
document. 

4
After you add clips to the 
QuicKeys clipboard, select the 
“paste” trigger and choose 
which Scrap Ease item to 
paste.

Figure 152: When you have items in your Scrap Ease clipboard, you can 
then paste them into your documents with a simple QuicKeys 
trigger.

Figure 153: The Scrap Ease Shortcut Properties dialog.
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6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Press the keystroke or other trigger you assigned to this 
Shortcut. The action you selected for this Shortcut should 
react immediately to the trigger.

SCRAP EASE OPTIONS
This section describes the Shortcut-specific properties 
available with the Scrap Ease plug-in.

Copy
Copies selected items to the QuicKeys clipboard so they can 
be used again.

Paste
Pastes items from the QuicKeys clipboard list into open 
documents.

Type
Types text stored in the QuicKeys clipboard list into open 
documents.

Edit Clip List
Displays a window where you can delete clips stored in the 
QuicKeys clip list. This button is only available after you have 
added a clip to the QuicKeys clipboard.

Choose clip when playing Shortcut
Displays a list of available clips for you to choose from when 
you trigger Paste or Type Shortcuts.

Use the clip
Select a clip from this pop-up list to insert it into an open 
document when you trigger Paste or Type Shortcuts.

SCREEN EASE
The Screen Ease plug-in is useful if you need to change your 
screen settings for different applications or different monitors. 
For example, if you use your laptop computer with a desktop 
monitor when you are at work, you may want to create a 
Screen Ease Shortcut that automatically switches between 
laptop screen settings and the desktop screen settings. The 
settings available in the Screen Settings Shortcut depend upon 
the capabilities of your monitor and video card.

SETTING UP SCREEN EASE SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Screen Ease. The Shortcut 
Properties dialog appears.

3. Select an option from the Screen area of the dialog.

4. Select an option from the Settings area of the dialog.

5. Type a name for the Shortcut in the Name box.

Figure 154: The Screen Ease Shortcut Properties dialog.
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6. Position your cursor in the Keystroke box and press the keys 

you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

8. Close the QuicKeys Editor.

9. Press the keystroke or other trigger you assigned to this 
Shortcut. The screen options you selected for this Shortcut 
should react immediately to the trigger.

SCREEN EASE OPTIONS
This section describes the Shortcut-specific properties 
available with the Screen Ease plug-in.

Screen options
Choose the screen to which you want to make changes. For 
example, if you have two monitors hooked up to your Mac, 
use these options to choose the screen containing the mouse, 
all screens, or the screen you specify.

Settings
Set the depth and mode of the specified screen. Click the Make 
Changes Permanent check box if you want to retain your changes 
after restarting.

SPECIALS
QuicKeys contains a variety of time-saving plug-ins that 
enable you to work more efficiently on your computer. One of 
these time-savers is a grab bag of useful tools called the 
Specials plug-in. There are Specials for controlling the 
operation of your computer, switching desktop windows, 
changing typography, and manipulating QuicKeys 
functionality.

SETTING UP SPECIALS SHORTCUTS
There are two ways to create QuicKeys Specials Shortcuts: use 
the Setup Assistant or use the Shortcut Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Setting Up the Specials Shortcut

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > Specials. The Shortcut Properties 
dialog appears.

Figure 155: The Specials Setup Assistant.



112 Chapter 9
System Tools

• • • •
3. Select an option from the Action pop-up menu.

4. Type a name for the Shortcut in the Name box.

5. Position your cursor in the Keystroke box and press the 
keys you want to use to trigger this Shortcut.

6. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

7. Close the QuicKeys Editor.

8. Press the keystroke or other trigger you assigned to this 
Shortcut. The action you selected for this Shortcut should 
react immediately to the trigger.

SPECIALS OPTIONS
This section describes the Shortcut-specific properties 
available with the Specials plug-in.

Shut Down
Shuts down your computer.

Restart
Restarts your computer.

Launch
Displays a standard Open dialog so you can choose to open 
another file or application. 

Select Rear Window
Brings the window at the bottom of the desktop window stack 
to the top.

Select Second Window
Displays the previously active window.

QuickQuotes
Creates a single curly quote rather than a single straight 
quote. If you create a QuickQuotes Shortcut, you must trigger 
it with a keystroke.

Double QuickQuotes
Creates a double curly quote rather than a double straight 
quote. If you create a Double QuickQuotes Shortcut, you must 
trigger it with a keystroke.

Open QuicKeys Editor
Displays the QuicKeys Editor.

Open QuickReference Card
Opens the QuickReference Card.

Toggle QuicKeys On/Off
Alternately puts QuicKeys to sleep and wakes it up.

Start/Stop Sequence
Alternately stops and starts a QuicKeys Sequence recording.

Start/Stop Real Time
Alternately stops and starts a QuicKeys Real Time recording.

Pause/Unpause Sequence
Alternately stops and starts a Sequence during recording or 
playback.

Figure 156: Select an action for the Specials plug-in to complete.
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VIEW SWITCHER

Use the View Switcher to make your Macintosh look the way 
you want on a per-folder basis. You no longer have to wade 
through Finder menus to view the contents of one window in 
a list and the contents of another window as icons. Instead, 
you can change the view of the frontmost window with a 
simple QuicKeys trigger. This allows you to keep your fingers 
on your keyboard rather than constantly switching back to 
your mouse.

SETTING UP VIEW SWITCHER SHORTCUTS
In the following example instructions, files and folders in your 
frontmost Finder window appear as large icons arranged by 
name when you trigger the View Switcher Shortcut.

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > System Tools > View Switcher.

3. Choose Icons in the Style pop-up menu.

4. Select Large in the Icon Size pop-up menu.

5. Select Name in the Arrangement pop-up menu.

6. Type a name for the new shortcut in the Name box.

7. Assign a keystroke for the Shortcut.

8. Click OK in the View Switcher dialog.

9. Click the close box in the QuicKeys Editor to quit 
QuicKeys.

10.Open a window in the Finder and trigger the Shortcut you 
just created. The window adjusts based on the viewing 
preferences you specified.

VIEW SWITCHER OPTIONS
This section describes the Shortcut-specific properties 
available with the View Switcher plug-in.

Style
Choose the style of open Finder windows. You can view your 
files as icons, as buttons, or as a list.

Icon Size
Choose whether your icons appear large or small.

Arrangement
Choose how you want the files and folders in your Finder 
windows arranged. You can organize them by name, date 
modified, date created, size, kind, and label.

Figure 157: The View Switcher Shortcut Properties dialog.
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CHAPTER 10

• • • • • •
MULTIMEDIA TOOLS

You can use QuicKeys to play your CDs, play sounds from 
your system, and play QuickTime movies. This chapter 
provides instructions for setting up Audio CD Player, Sound, 
SpeakEase, SpeakerChanger, and QT Movie Shortcuts to 
control all these tasks. 

AUDIO CD PLAYER
With QuicKeys you can control your internal CD-ROM player 
without the CD application being active using the following 
actions:

SETTING UP AUDIO CD PLAYER SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create  >  Multimedia Tools  >  Audio CD Player.

3. Choose an option in the Action pop-up menu. For example, 
choose Play CD.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke or another type of trigger to the 
Shortcut.

6. Click OK to close the Shortcut Properties dialog.

7. Click the close box in the QuicKeys Editor to quit 
QuicKeys.

8. Insert an audio CD in your CD-ROM drive and trigger the 
action you selected. Depending on the option you selected 
in Step 3, the CD should react immediately to the trigger.

• Play CD • Pause CD

• Stop CD • Next Track

• Previous Track • Louder

• Softer • Eject CD Figure 158: The Audio CD Player Shortcut Properties dialog.
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SOUND
You can use the Sound Shortcut to play certain sounds when 
you perform a System activity. You can install a number of 
sounds on your Mac, depending on your memory resources, 
and they are all available when you set up the QuicKeys 
Sound Shortcut.

SETTING UP SOUND SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > Multimedia Tools > Sound.

3. Choose an option in the Play Sound pop-up menu. For 
example, choose Droplet. You can hear a sample of each 
sound by selecting it from the Play Sound pop-up menu.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke or another type of trigger to the 
Shortcut.

6. Click OK to close the Shortcut Properties dialog.

7. Click the close box to close the QuicKeys Editor.

8. Trigger the Sound Shortcut to hear the sound you selected.

SPEAK EASE
The Speak Ease plug-in only works if you have speech 
software installed on your Macintosh. With Speak Ease, you 
can make your computer speak specific words or phrases by 
typing or pasting them into a text field. When you trigger a 
Speak Ease Shortcut, your Mac speaks the words you 
provided. The Speak Ease plug-in can also speak the contents 
of the clipboard.

SETTING UP SPEAK EASE SHORTCUTS

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > Multimedia Tools > SpeakEase.

3. Choose a voice from the Voice pop-up menu. For example, 
choose Zarvox. 

4. If you select Speak Clipboard, make sure the text you want the 
selected voice to speak is copied to the clipboard. If you 

Figure 159: The Sound Shortcut Properties dialog.

Figure 160: The Speak Ease Shortcut Properties dialog.
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select Speak Text, type the text you want the selected voice to 
speak in the text pane of the dialog.

5. Type a name for the Shortcut in the Name box.

6. Assign a keystroke or another type of trigger to the 
Shortcut.

7. Click OK to close the Shortcut Properties dialog.

8. Click the close box to close the QuicKeys Editor.

9. Trigger the Speak Ease Shortcut to make the selected voice 
speak the text you provided.

SPEAKERCHANGER
The SpeakerChanger plug-in is useful if you want to adjust 
the volume of your speakers. When you use this plug-in to 
change speaker volume, your changes are retained even after 
you restart.

SETTING UP SPEAKER CHANGER SHORTCUTS
There are two ways to create QuicKeys Speaker Changer 
Shortcuts: use the Setup Assistant or use the Shortcut 
Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > Multimedia Tools > SpeakerChanger.

Figure 161: The SpeakerChanger Setup Assistant.
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3. Choose an option from the Set Volume options or from the 
Adjust Volume options. For example, choose 50% from the Set 
Volume options. 

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke to the Shortcut.

6. Click OK to close the Shortcut Properties dialog.

7. Click the close box to close the QuicKeys Editor.

8. Play an audio CD and trigger the SpeakerChanger Shortcut 
to increase or decrease the speaker volume. A beep signals 
the new volume level if the Play Sound When Adjusting Volume 
check box is selected.

SPEAKERCHANGER OPTIONS
This section describes the Shortcut-specific properties 
available with the SpeakerChanger plug-in.

Off
Turns off the speaker volume.

10%-100%
You can choose to increase or decrease the speaker volume by 
10%, 20%, 40%, 50%, 60%, 80%, or 100%. 

Louder/Softer
Adjusts the volume so it is either louder or softer.

Play sound when adjusting volume
When you have this option selected and you change the 
speaker volume, a beep indicates the new volume level. When 
you hear two beeps, you have hit the maximum volume 
setting. If the menu bar flashes without any beeps, you have 
reduced the volume setting to zero.

QT MOVIE
You can use the QuickTime movie plug-in to play multimedia 
files such as video, animation, sound, music, text, pictures, 
and 3D graphics. For example, you can download one of 
Apple’s TV commercials from their Web site and use 
QuickTime to view it. QuicKeys and QuickTime are partnered 
in this plug-in so you can trigger multimedia files at any time 
with a simple keystroke.

 ▲ You must have QuickTime installed on your computer to 
use this plug-in.

1. Open the QuicKeys Editor and select the Keysets tab.

2. Select Create > Multimedia Tools > QT Movie.

Figure 162: The SpeakerChanger Shortcut Properties dialog.
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3. Click the Select button to display a standard Open dialog. 

(The Select button becomes a Change button once you have 
selected a file.)

4. Navigate to the multimedia file you want to trigger with 
QuicKeys and select Open.

5. Type a name for the Shortcut in the Name box.

6. Assign a keystroke or another type of trigger to the 
Shortcut.

7. Click OK to close the Shortcut Properties dialog.

8. Click the close box to close the QuicKeys Editor.

9. Trigger the QT Movie Shortcut to launch your QuickTime 
movie.

QT MOVIE OPTIONS
This section describes the Shortcut-specific properties 
available with the QT Movie plug-in.

Show QuickTime Controller
Check this option if you want the QuickTime movie to appear 
within a window that offers playback controls.

Play QuickTime soundtrack if available
Check this option to play audio if it accompanies a QuickTime 
movie.

Figure 163: The QT Movie Shortcut Properties dialog.
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CHAPTER 11

• • • • • •
NETWORK TOOLS

If your computer does not have access to other computers or 
the Internet, the information in this chapter will probably not 
be applicable to you. If, however, your computer is on a 
network, there are several network tasks that QuicKeys can 
help you with. These tasks include choosing printers and 
network drives.

CHOOSY
The Choosy plug-in is useful if you frequently switch between 
printers on your network. For example, this plug-in can be 
extremely useful in QuicKeys Sequences when you want to 
send a fax and switch back to your regular printer once the fax 
is sent.

SETTING UP CHOOSY SHORTCUTS
There are two ways to create a QuicKeys Choosy Shortcut: use 
the Setup Assistant or use the Shortcut Properties dialog.

Using the Setup Assistant
To use the Setup Assistant, select the Setup Assistant button in 
the QuicKeys Editor or select Setup Assistant from the QuicKeys 
menu. Read each panel of the Setup Assistant and follow the 
instructions.

Using the Shortcut Properties Dialog

To create a Choosy Shortcut:

1. Open the QuicKeys Editor.

2. Select Create > Network Tools > Choosy.

Figure 164: The Choosy Setup Assistant.
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3. Check the Change printer to check box and select an available 
printer driver from the pop-up list. Boxes for the printer 
zone and printer name appear.

4. Click the Choose Printer button to display a list of AppleTalk 
zones on your network.

5. Select the zone where your printer resides. A list of printers 
in the selected zone appears in the Select Printer section of the 
window.

6. Select a printer and click OK. The zone and printer you 
selected appear in the Shortcut Properties dialog.

7. Check the Report Printer Selection check box so you are notified 
when Choosy has successfully selected a different printer.

8. Type a name for this Shortcut in the Name box.

9. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

10.Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

11. Close the QuicKeys Editor and select your Choosy trigger. 
Your default printer is instantly changed and a window 
reports the new printer selection. 

CHOOSY OPTIONS
This section describes the Shortcut-specific properties 
available with the Choosy plug-in.

Background printing
With background printing, you can use your computer to do 
other work while documents are printing. It takes longer and 
requires more disk space to print a document with 
Background printing enabled, so if you frequently print high-
color graphics you may want a Choosy Shortcut that simply 
turns background printing on and off.

Choose Printer
Click the Choose Printer button to specify the printer you want to 
select with the Choosy Shortcut.

Zone name
When you click the Choose Printer button and select an 
AppleTalk zone, the Zone name in the Shortcut Properties 
dialog is automatically filled. An asterisk appears in this box 
when you only have one network available.

Figure 165: The Choosy Shortcut Properties dialog.

Figure 166: Choose a zone and a printer.
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Printer name
When you click the Choose Printer button and select an 
AppleTalk zone and printer, the Printer name in the Shortcut 
Properties dialog is automatically filled.

Report printer selection
Check this option when you want to be notified that your 
default printer has been successfully changed.

MOUNTY
The Mounty plug-in is useful when you want to mount and 
dismount network volumes quickly and easily. Once you set 
up a couple of Mounty Shortcuts, you can finally say goodbye 
to endless Chooser dialogs and password prompts you’ve had 
to wade through for years.

The Mounty Shortcut includes the following options:  

SETTING UP MOUNTY SHORTCUTS
When you set up a Mounty Shortcut you must specify a 
network volume, so make sure you know the exact spelling 
and capitalization of the volume you want to mount or 
dismount before you begin.

1. Open the QuicKeys Editor.

2. Select Create > Network Tools > Mounty.

3. In the Shortcut Properties dialog, select the networking 
protocol you want to use. For example, select Server IP. 

4. Choose which volume you want to mount. 

• If you select AppleTalk, click Choose Server to select the 
server you want to mount or dismount.

• If you select Server IP, type the domain name of the 
server you want to mount or dismount in the Server 
Address field. Then type the name of the server volume 
in the Volume field. Click Verify to make sure the server is 
available.

5. Type the name of the volume in the Volume box.

6. Select your connection preferences from the When connecting 
pop-up list.

7. If applicable, type your name and password information in 
the Name, Password, and Volume Password boxes.

8. Type a name for this Shortcut in the Name box.

9. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

• Toggle Mount/Dismount • Mount Only

• Dismount Only

Figure 167: The Mounty Shortcut Properties dialog.
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10.Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

11. Close the QuicKeys Editor and press your Mounty trigger. 
The network volume you specified is either mounted or 
dismounted instantly.

MOUNTY OPTIONS
This section describes the Shortcut-specific properties 
available with the Mounty plug-in.

Toggle Mount/Dismount
Switches between mounting and dismounting the specified 
network volume using the same trigger.

Mount only
Mounts the specified network volume.

Dismount only
Dismounts the specified network volume.

AppleTalk
If the network volume you want to mount/dismount is part 
of an AppleTalk network, select AppleTalk.

Choose Server
Click the Choose Server button to navigate to the server you 
want to mount with the Mounty Shortcut.

Zone
The Zone box is automatically filled with information retrieved 
from the AppleTalk zone selection you made when you 
pressed the Choose Server button.

Server
The Server box is automatically filled with information 
retrieved from the server list selection you made when you 
pressed the Choose Server button.

Volume
Type the volume name of the server you want to mount or 
dismount in the Volume box. Make sure you type the name 
exactly as it appears—including capitalization.

Server IP
If the network volume you want to mount or dismount 
supports AppleShare IP, select Server IP. 

Server Address
Type the alphanumeric domain name or numeric IP address 
(i.e. 504.167.2.000) of the server you want to mount or 
dismount.

Volume
Type the volume name of the server you want to mount or 
dismount in the Volume box. Make sure you type the name 
exactly as it appears—including capitalization.

Connect as Guest
Connects you to the specified server with guest access.

Remember Name and Password
Connects you to the specified server automatically using the 
name and password you provide when you set up the 
Mounty Shortcut.

Ask for Name and Password
Prompts you for your user name and password before 
mounting the specified server.

Ask for Password
Prompts you for your password before mounting the 
specified server.
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NETWORK SWITCHER

Network Switcher enables users to switch between different 
network settings so it is easy to plug into different network 
environments. You can change settings for AppleTalk, 
modems, Open Transport/PPP, and TCP/IP on the fly. This 
capability makes Network Switcher indispensable for 
PowerBook users who use the same computer on the network 
at the office and for dial-up connections from home.

SETTING UP NETWORK SWITCHER SHORTCUTS

 ▲ You must be using Open Transport 1.1.1 or greater for 
this plug-in to work properly.

1. Create whatever TCP/IP, OT/PPP, AppleTalk, or modem 
configurations you need to connect from your various 
work environments.

2. Open the QuicKeys Editor and select the Keysets tab.

3. Select Create > Network Tools > Network Switcher.

4. Select your networking method in the Settings pop-up 
menu.

5. Select the appropriate networking configuration in the 
Configuration pop-up menu.

6. Type a name for the Shortcut in the Name box.

7. Assign a keystroke or another type of trigger to the 
Shortcut.

8. Click OK in the Shortcut Properties dialog.

9. Click the close box in the QuicKeys Editor to close 
QuicKeys. 

When you connect to a different network environment, trigger 
the Network Switcher Shortcut. Your networking preferences 
are automatically changed and you’re instantly set up for the 
new network environment.

NETWORK SWITCHER EXAMPLES
If you use a PowerBook and frequently travel between two 
offices, you can set up one Shortcut that specifies TCP/IP 
settings for Site A and another Shortcut that specifies 
AppleTalk settings for Site B. When you plug into the network 
at either site, you can simply select the appropriate Network 
Switcher Shortcut and access the network.

Another example of how you can use Network Switcher 
might be if the desktop computer at your office uses TCP/IP 
for intranet access and you want to connect to your Internet 
account via a modem. You could have Network Switcher 
change the network settings so you can quickly and easily 
connect to your Internet account.

NETWORK SWITCHER OPTIONS
This section describes the Shortcut-specific properties 
available with the Network Switcher plug-in.

Figure 168: The Network Switcher Shortcut Properties dialog.



126 Chapter 11
Network Tools

• • • •
Settings
Choose the networking or communication method your 
network supports using the Settings menu. You can choose 
from TCP/IP, OT/PPP, AppleTalk, or modem settings.

Configuration
The options available in the Configuration pop-up list contain 
settings you create at the system level. For example, you can 
view all your AppleTalk configurations by opening the 
AppleTalk control panel and selecting Configurations from the 
File menu.
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CHAPTER 12

• • • • • •
INTERNET TOOLS

The Internet has become an integral part of many people’s 
computing experience. Anticipating your Internet needs, the 
makers of QuicKeys have developed the Instant E-mail and 
Web Launcher plug-ins. 

INSTANT E-MAIL
It seems like E-mail is suddenly the preferred mode of 
communication as more and more people are purchasing 
Internet services. So, why not make using E-mail as efficient 
as possible? QuicKeys helps you make the best use of your 
time by providing the ability to create and send messages and 
selected files with a simple QuicKeys trigger.

The options available with the Instant E-mail plug-in include:

 ▲ The Instant E-mail plug-in only works with the E-mail 
clients listed in the E-Mail Client pop-up menu: QuickMail 
Pro, Claris® E-mailer, Netscape Messenger™, Eudora™ 
Lite/Pro, and Outlook Express.

SETTING UP INSTANT E-MAIL SHORTCUTS

1. Open the QuicKeys Editor.

2. Select Create > Internet Tools > Instant E-mail.

3. In the Shortcut Properties dialog, select the E-mail client 
you want to use. For example, select QuickMail Pro. 

4. Select the task you want to complete from the Action 
pop-up menu. 

5. Type a name for this Shortcut in the Name box.

6. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

• Sending a recently 
modified file

• Sending selected text

• Opening a message 
window with 
user-specified text

• Acknowledging 
QuickMail Pro 
notification

• Checking the server 
for waiting mail with 
QuickMail Pro

• Sending mail with 
QuickMail Pro

• Sending selected 
files

Figure 169: The Instant E-mail Shortcut Properties dialog.
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8. Close the QuicKeys Editor and press your Instant E-mail 

trigger. The action you specified is instantly put into 
motion.

INSTANT E-MAIL OPTIONS

E-mail Client
Select the E-mail client you use from this pop-up list. 
QuickMail Pro is the only E-mail client option that supports 
the Check Mail, Send Mail, and Acknowledge Notification actions.

Send Text
Enables you to send pre-specified text via E-mail. Type the 
text you want to send in the text box that appears when you 
select Send Text. The text box can hold up to 255 characters.

Send Selection
Encloses and sends the selected file or text. This option does 
not support stylized text.

Send Finder Selection
Creates a new message and attaches each of the files you have 
selected. All you have to do is address and send the message. 

Send Recent Document
Displays a list of documents modified within a user-specified 
amount of time. You can select the file you want to send from 
the list and it is instantly enclosed in an E-mail message. 
When you Shift- or Control-click, you can select multiple 
items for inclusion in the message.

When you select Send Recent Document from the Action list, you 
must select the interval you want QuicKeys to use when it 
scans for recently modified files. The maximum number of 
minutes you can enter in the Other box for these options is 1,440 
(24 hours). 

You can omit specific files from Send Recent Document’s scan for 
recently modified files. For example, you probably don’t want
to open Netscape cache files, so you may want to exempt 
them from the Recent Document results. See page 167 for more 
information.

 ▲ Netscape Messenger and Outlook Express do not  
support the Send Recent Document shortcut.

Check Mail
QuickMail Pro sends and receives mail at user-specified 
intervals. However, when you are expecting an important 
message, you can use the Check Mail Shortcut to force 
QuickMail Pro to look for new mail on the mail server.

 ▲ Check Mail only works with QuickMail Pro.

Send Mail
QuickMail Pro sends and receives mail at user-specified 
intervals. However, when you need to send urgent mail 
immediately, you can use the Send Mail Shortcut to force instant 
connections to the mail server.

 ▲ Send Mail only works with QuickMail Pro.

Acknowledge Notification
If you use QuickMail Pro, you are probably familiar with the 
audible and visual notification it provides when you receive 
mail. Sometimes when you are working to meet a deadline, or 
you just can’t be interrupted, this notification is distracting. 
So, instead of permanently disabling mail notification in your 
mail preferences, you may want to acknowledge that you 
have received mail to halt notification until the next time you 
download mail.

 ▲ Acknowledge Notification only works with QuickMail Pro.
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WEB LAUNCHER

The Web Launcher Shortcut is useful when you want to open 
Uniform Resource Locators (URLs) with a single keystroke. 
Web Launcher is handier than bookmarks because you don’t 
have to use your mouse and your Internet browser doesn’t 
even have to be launched. The Web Launcher plug-in includes 
the following options:

SETTING UP WEB LAUNCHER SHORTCUTS

1. Open the QuicKeys Editor and click the Keysets tab.

2. Select Create > Internet Tools > Web Launcher.

3. Select an action from the Action pop-up menu. If you select 
Open URL, you must type the URL.

4. Type a name for the Shortcut in the Name box.

5. Assign a keystroke to the Shortcut.

6. Click OK to close the Shortcut Properties dialog.

7. Click the close box in the QuicKeys Editor to quit 
QuicKeys.

8. Trigger the Web Launcher Shortcut. The Web Launcher 
action you specified is performed immediately.

WEB LAUNCHER OPTIONS
This section describes the Shortcut-specific properties 
available with the Web Launcher plug-in.

Open URL
Type a URL in the URL box if you are creating an Open URL 
Shortcut. For example, type http://www.cesoft.com to open CE 
Software’s Web page. The URL you specify must be fully 
qualified. For example, it must include a prefix such as http:// 
or mailto: in the address. 

Show dialog
Select this option if you want to be prompted for a URL. If you 
want the Open URL box to be prefilled with a URL prefix, type 
the URL prefix in the URL box.

Open Text Selection as URL
When you create a Web Launcher Shortcut using this option, 
you can select a block of text and trigger the Shortcut to open 
the text as a URL. 

Open URL from Netscape 
Use this option to open a list of Netscape bookmarks.

Open URL from Explorer
Use this option to open a list of Internet Explorer favorites.

• Open URL • Open Text Selection as 
URL

• Open URLs from 
Internet Explorer

• Open URLs from 
Netscape Navigator

Figure 170: The Web Launcher Shortcut Properties dialog.
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CHAPTER 13

• • • • • •
SCRIPTING TOOLS

AppleScript enables applications to share information and 
data to perform complex operations. AppleScript uses 
AppleEvents to accomplish such communication. QuicKeys 
combines these powerful scripting tools to provide Shortcuts 
that work with Apple Events, AppleScript, and application-
specific scripting languages.

The QuicKeys Backgrounder is the target for all Apple Events 
sent to QuicKeys, so it must be running for QuicKeys 
scripting to function properly.

INTERAPPLICATION COMMUNICATION 
TOOLS

QuicKeys has four tools for creating Shortcuts that make use 
of InterApplication Communication (IAC):

• QuicKeys Backgrounder is a background application that 
acts as a mediator, transparently passing Apple Events 
between QuicKeys, the system software, and applications. 
QuicKeys Backgrounder must be running for QuicKeys 
Script to work and for your computer to be able to receive 
Apple Events.

• The Apple Events plug-in adds basic IAC capabilities to 
your Shortcuts. It handles the predefined events in suites, 
unique events for a particular program, and custom events 
of your own creation.

• The AppleScript Extension works with the AppleScript 
language. Use it to incorporate AppleScripts into your 
Sequences.

• The DoScript Extension is another tool for sending scripts 
between applications. In this case, the script in question is 
written in the scripting language of a particular 

application. For example, you might create a Shortcut that 
sends information to FileMaker. Put the commands in a 
FileMaker script, then use DoScript to send that script to its 
host application.

APPLE EVENTS
Apple Events are commands, queries, and responses that are 
sent along Apple’s IAC channel. For example, Apple Events 
are used when you choose to print a document from another 
application. To use Apple Event Shortcuts, applications must 
be written to support Apple Events as a communication 
protocol.

There are categories, or suites, of Apple Events. Suites are 
standard predefined events. Required Suites are events the 
Finder sends to applications. These events include:

To receive an Apple Event an application must be designated 
to recognize Apple Events and it must be running when the 
event is sent. Use the File Sharing control panel to configure 
the target computer for receiving Apple Events from a remote 
computer by selecting Program Linking. Additionally, the 
user sending the Apple Event must be set up on the target 
machine to access to File Sharing. File Sharing privileges are 
established in the Users & Groups control panel. 

• Open Document

• Print Document

• Quit
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QuicKeys knows which applications can accept Apple Events 
and which cannot. To see a list of these applications, use the 
Send Event To pop-up menu in the Apple Events Shortcut 
Properties dialog shown in Figure 171.

SETTING UP APPLE EVENTS SHORTCUTS

1. Select Create > Scripting Tools > Apple Events.

2. Choose an application process from the Send Event to 
pop-up list. For example, select Finder. When you choose an 
application, a Select Event button appears. 

3. Click the Select Event button to display the suite of events 
supported by the application you selected. QuicKeys gets 
the list of available suites and events from the target 
application. It queries the target’s AETE resource to see 
which events it supports. If the target doesn’t have an 

AETE, you need to supply QuicKeys with all the 
information in the event.

4. Select the event suite you want to use from the Suite pop-up 
list. The Suite pop-up menu contains all the event suites 
supported by the target application. The Events list shows 
the events in the selected suite. If the target application 
doesn’t have an AETE resource, the only item in the Suite 
menu is Required Suite and the only events are Open, Print, Quit, 
and Custom Event.

5. Click the event you want to send to the designated 
application and click the Select Event button. If the Events list 
doesn’t show the event you want, select a different suite in 
the pop-up menu. Once you make your selection, the 
Shortcut Properties dialog displays again with the event 
parameters listed in the middle of the dialog.

6. In the Shortcut Properties dialog, select a parameter and 
click Edit if there are required parameters that must be 
modified. Make any necessary changes to the parameter 
and return to the Shortcut Properties dialog.

Figure 171: The Apple Events Shortcut Properties dialog.

Currently running 
applications.

These two options let 
you send events 
elsewhere.

Figure 172: Select an event suite in the Events window.
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7. Select what type of information you want returned from 

the target application using the Return Value pop-up menu. 

8. Type a name for this Shortcut in the Name box.

9. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

10.Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

11. Close the QuicKeys Editor and press your Apple Events 
trigger. The Event you specified is immediately sent to the 
application you chose in the Apple Event Shortcut.

APPLE EVENTS OPTIONS
This section describes the Shortcut-specific properties 
available with the Apple Events plug-in.

Send Event To
Choose to send the event to an application, a remote 
application, or some other file. If you choose Remote Application, 
you must choose the computer, the zone, and the application 
you want to receive the Event. If you select Other, a standard 
Open window appears so you can select the file you want to 
receive the Event. After you select an option from this pop-up 
menu, a Select Event button appears. Click the Select Event button 
to display a list of supported Apple Events. 

Select Event
Choose which Apple Event Suite you want to use in the Suite 
pop-up menu and then select an event. Click the Tech Info 
button to view more information on the event you selected or 
click the Select Event button to display the selected event in the 
Shortcut Properties dialog.

Figure 173: The Apple Events Shortcut Properties dialog displays the 
event parameters after you select them.

Figure 174: Select an event from the Events list.
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Tech Info
Click this button to display a window with information 
pertaining to the selected Event.

Event Class
A four-letter code that identifies the class of event within the 
suite.

Event ID
A four-letter code that specifies a particular event within a 
class.

Reply Type
The data type the event produces.

Application’s state
The effect that the event has on the target application.

Direct Parameter Type
A word or code identifying one of the 19 categories of 
parameters. The direct parameter is the first one in the list. 

Other Parameters
A list of additional parameters, if any.

Parameters
A parameter is a piece of information that an Apple Event 
delivers to the target application. Parameters give additional 
details about the function of the event. For example, the 
PrintDocuments event tells the target application to print one 
or more documents. It has one parameter: a list of documents.
Some events have several parameters, some don’t have any at 
all. When you choose an Apple Event in the Events window, 
its parameters appear in a list.

Editing Parameters
In some cases, you may need to edit the parameters to tailor a 
Shortcut to your needs. For example, you may need to modify 
a parameter to include the name of a QuicKeys Shortcut.

To edit a parameter, open the Shortcut Properties dialog for 
the Apple Events plug-in and click the Edit button shown in 
Figure 176. When you click the Edit button, a Parameter 
Specifier window appears. The details in the Parameter 

Figure 175: The Technical Information window for a selected event.

Figure 176: When you select an event, a parameter field appears in the 
Apple Events Shortcut Properties dialog.
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Specifier window vary according to the type of parameter you 
select. For example, if you select a parameter that is an 
“Object” type, an Object Specifier dialog appears when you 
try to edit the selected parameter.

The available Parameter Specifier windows may contain a 
combination of the following details.

Number
The position of this parameter in the list of parameters. The 
number of parentheses is the total number of parameters.

Name
The parameter’s name in the AETE resource.

Description
The purpose of the parameter, also from the AETE resource.

Keyword
The four-letter code of the parameter.

Type
One of the 19 categories of parameters, as found in the AETE 
resource.

Required/Not Required
This check box indicates whether or not this parameter is 
mandatory.

Next
Displays the Parameter Specifier window for the next 
parameter in the list.

Previous
Displays the Parameter Specifier window for the previous 
parameter in the list.

Get Parameter Value From
Click the Clipboard button to get data from the Clipboard at 
runtime. This option is useful if the information is not always 
the same. Click the Data button and type the information in the 
field if the data is always the same.

Return Value
In the Shortcut Properties dialog, you must specify what 
information you want the selected Apple Event to return to 
the source application. 

Ignore
Sends the Event to the target application, but does not wait for 
a response.

Figure 177: The Parameter Specifier window for the “Object” 
parameter type. 

Figure 178: The Return Value options.
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Wait
Sends the Event to the target application and waits until it’s 
complete, but throws away the response.

Type
Types the provided text in the current window.

Display Full
Displays a dialog describing the Event that was sent, plus the 
response (if possible).

Clipboard
Places the response on the Clipboard.

Display Minimal
Displays a dialog showing the response (if possible).

APPLESCRIPT
AppleScript is a programming language designed for 
controlling applications via Apple Events. It provides fairly 
simple commands you can use to customize and automate 
your Mac.

The AppleScript system extension must be in the Extensions 
folder of your System folder for QuicKeys’ AppleScript 
Shortcuts to work. 

SETTING UP APPLESCRIPT SHORTCUTS

1. Select Create > Scripting Tools > AppleScript.

2. Choose an option from the Select Script to Execute area of the 
Shortcut Properties dialog. For example, select File. 

3. Specify the file or type the text you want to execute.

4. Choose how you want to handle the results of the script. 
For example, you can ignore the results or you can send the 
results to the system clipboard.

5. Type a name for this Shortcut in the Name box.

6. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

7. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

8. Close the QuicKeys Editor and press your AppleScript 
trigger. The script you specified executes immediately.

APPLESCRIPT OPTIONS
This section describes the Shortcut-specific properties 
available with the AppleScript plug-in.

File
Select File if you have a text file that you want to execute using 
QuicKeys. Files can be up to 32K.

Figure 179: The AppleScript Shortcut Properties dialog.
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Select File
Click the Select File button to navigate to the file you want to 
execute. Click Open when you have select the file.

Text (no script entered yet)
Select Text to display an editable text box.

Modify Text
Type your script in the Modify Text box. The script can be no 
more than 2K.

Ignore
Sends the Event to the target application, but does not wait for 
a response.

Wait
Waits for the script to complete before continuing.

Type
Types the provided text in the current window.

Display
Displays a dialog showing the response (if possible).

Clipboard
Places the response on the Clipboard.

Script Uses Clipboard
You can incorporate the contents of the clipboard into your 
AppleScript if you have this check box selected. To access the 
clipboard, use the following commands.

on open QKClipboard

...

QKClipboard

...

end open

DOSCRIPT
The DoScript Shortcut sends a text script written with any 
application-specific scripting language to that application 
using the doscript Apple Event. The receiving application 
must support Doscript in order to recognize the commands. 
DoScript is executed by target applications, whereas 
AppleScripts are executed by the AppleScript system 
extension.

SETTING UP DOSCRIPT SHORTCUTS

1. Open the QuicKeys Editor.

2. Select Create > Scripting Tools > DoScript.

3. Choose the target for your script by clicking the Send Script 
To button. For example, select Finder. 

4. Specify the file or type the text you want to execute.

5. Choose how you want to handle the results of the script. 
For example, do you want to ignore the results or do you 
want to send the results to the system clipboard?

Figure 180: The DoScript Shortcut Properties dialog.
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6. Type a name for this Shortcut in the Name box.

7. Position your cursor in the Keystroke box and press the 
key(s) you want to use to trigger this Shortcut.

8. Click OK. Your new Shortcut immediately appears in the 
Keysets tab.

9. Close the QuicKeys Editor and press your DoScript trigger. 
The script you specified executes immediately.

DOSCRIPT OPTIONS
This section describes the Shortcut-specific properties 
available with the DoScript plug-in.

File
Select File if you have a text file that you want to execute using 
QuicKeys. Files can be up to 32K.

Select File
Click the Select File button to navigate to the file you want to 
execute. Click Open when you have selected the file.

Text (no script entered yet)
Select Text to display an editable text box.

Modify Text
Type your script in the Modify Text box. The script can be no 
more than 2K.

Ignore
Sends the Event to the target application, but does not wait for a 
response.

Type
Types the provided text in the current window.

Display
Displays a dialog showing the response (if possible).

Clipboard
Places the response on the Clipboard.

Script Uses Clipboard
You can incorporate the contents of the Clipboard into your 
DoScript script if you have this check box selected. To access 
the Clipboard, you need to enter ^C^ in your script.

❖ The “C” must be capitalized.
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CHAPTER 14
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SEQUENCES AND SEQUENCE TOOLS

QuicKeys Shortcuts are great for simple, one-step tasks. 
However, there are times when repetitive tasks require several 
consecutive steps. For these situations, QuicKeys offers 
Sequences. Sequences are collections of Shortcuts that you put 
together to complete a multi-step task. Sequences can be as 
easy or complex as you need and creating them is much easier 
than the alternative—learning a scripting language.

An example of a simple multi-step task you can replace with a 
QuicKeys Sequence is the practice of logging into your E-mail 
account and checking for new mail. Figure 181 illustrates how 
QuicKeys Sequences can help you automate this task. This 
particular Sequence enables you to grab a cup of coffee when 
you get into the office while QuicKeys prepares your list of 
mail. All you have to do is select the assigned QuicKeys 
trigger. When you return to your desk, your mail will be ready 
for you to read and QuicKeys will have retreated into the 
background until you direct it to complete other tasks.

 

OVERVIEW OF SEQUENCES
Building Sequences can be challenging unless you have a 
multi-step task clearly mapped out in your mind. Even then, 
it’s important to know how QuicKeys Sequences work so you 
can make the most of their power and flexibility.

There are two basic tasks you must complete when you build 
a Sequence: 

• You must record or manually create each individual 
Shortcut you want to include in the Sequence.

• You must test and adjust your Sequence. 

Combine 
these steps 
using the 
Sequence 
Editor or 
QuicKeys 
recording.

Figure 181: This example illustrates how QuicKeys Sequences can simplify 
routine multi-step tasks.

1. Start your 
E-mail 
application.

2. Type your 
user name and 
password at the 
prompt.

4. Check for 
new mail.

3. Click the OK 
button to close 
the login 
window.

Replace the 4-step task 
with a QuicKeys trigger 
such as a keystroke, a 
toolbar button, an item 
in the QuicKeys menu, 
or a timed trigger.
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As you begin building Sequences with QuicKeys, remember 
that Sequences can be created a number of different ways and 
still be successful.

RECORDING SEQUENCES
Recording is an easy way of creating multi-step Shortcuts. 
There are two ways you can begin the recording process:

• From the QuicKeys menu.

• With a Start Recording Shortcut created using the Specials 
plug-in.

When you start recording, a flashing microphone appears 
over the Apple menu icon. If you are using your default 
QuicKeys preferences, a recording palette also displays. When 
one or both of these items appear, QuicKeys starts watching 
everything you do on your computer. When you finish the 
tasks you want QuicKeys to record, click the Stop button on 
the recording palette or select Stop Recording from the 
QuicKeys menu. The Sequence Editor automatically displays. 
Every task you just completed is listed in the Sequence Steps 
tab of the Sequence Editor.

THE SEQUENCE EDITOR
The Sequence Editor enables you to modify, or fine-tune, your 
Sequences. When the Sequence Editor appears, you can name 
the Sequence like you name your standard Shortcuts and 
assign the Sequence a trigger. The QuicKeys Editor consists of 
two tabs: the Sequence Steps tab and the Import Steps tab. 
This section discusses the Sequence Editor in detail.

Pause, Stop, Cancel, Insert

Figure 182: The Recording toolbar.

Figure 183: The Sequence Editor.

Click this check box to display 
additional information about 
the Sequence steps.

 

Insert 
arrow

Icon 
bar

Sequence 
Steps tab

Import 
Steps tab
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THE SEQUENCE STEPS TAB

The Sequence Steps tab displays all the steps in your 
Sequence. At the top of the tab is an icon bar that contains all 
of the controls for manipulating your Sequence. The red 
arrow in the Sequence Steps tab is called the insert arrow . Drag 
the insert arrow to a different step in the Sequence when you 
need to insert another Shortcut or a pause in the Sequence. 
The new item is inserted wherever the arrow is located.

If you want to add to your Sequence, position your insert 
arrow at the end of your Sequence and click the Record More 
button. The Recording Palette appears and QuicKeys 
immediately starts watching your actions. Your new 
recording is added to the end of the Sequence.

You can also insert a keystroke in your Sequence. Just click the 
Insert Keystroke button and press a key at the prompt. The key 
you select is inserted as a step where the insert arrow is 
located.

Icon Bar
The icon bar is located at the top of the Sequence Steps tab. It 
contains a series of icons that enable you to manipulate your 
Sequences with a click of your mouse. When your mouse 
pointer pauses over a button on the icon bar, a hot help 
caption appears.

Click the Create button to display the Create pop-up menu. 
When you select a plug-in from the Create menu, a Shortcut 
Properties dialog appears. When you complete the dialog, the 
Shortcut you created appears in the step of the Sequence 
where the insert arrow is located.

Figure 184: The Sequence Editor Sequence Steps tab.

Figure 185: The Sequence Editor icon bar.

Figure 186: Click the Create button to display the Create 
pop-up menu.
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Show Additional Step Info
If the QuicKeys Backgrounder is running, you can click the 
Show Additional Step Info check box in the Sequence Editor to view 
detailed information on each step of your Sequence.

THE IMPORT STEPS TAB
Use the Import Steps tab to add existing Shortcuts to your 
Sequence. Just select the QuicKeys Set you want to use from 
the Set pop-up list and drag the Shortcut to the step in the 
Sequence where you want it.

CREATING SEQUENCES WITHOUT 
RECORDING

After you become more familiar with QuicKeys, you may find 
that it is not necessary to use the recording feature because 
you have already created all of the Shortcuts you want in your 
Sequence. If you choose to create the Sequence from scratch, 
you can use the following methods to assemble your 
Sequence.

• Select plug-ins from the Create menu.

• Cut and paste Shortcuts into the Sequence using the cut 
and paste buttons.

• Use the Import Steps tab. 

When you are finished collecting the main pieces of your 
Sequence, use the Sequence tools discussed on page 144 to 
add the finishing touches to your Sequence.

Sequence Editor Icons

Click the Modify button to 
edit the selected Shortcut 
in the Sequence.

Click the Delete button to 
delete the selected 
Shortcut from the 
Sequence.

Click the Cut button to 
remove the selected 
Shortcut from the 
Sequence and store it in 
the system clipboard.

Click the Select All button 
to select all the steps in 
the Sequence.

Click the Copy button to 
copy the selected 
Shortcut to the System 
clipboard.

Click the Print button to 
print the steps of the 
Sequence.

Click the Paste button 
paste items from the 
system clipboard to the 
part of the Sequence 
where the insert arrow is 
located.

Click the Page Setup 
button to open the Page 
Setup dialog.

Figure 187: The Import Steps tab of the Sequence Editor.
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FINE-TUNING SEQUENCES

If your Sequence does not behave as you anticipated, you may 
need to fine-tune your Sequence without  the recorder. The 
Sequence Editor gives you the tools to do this. Fine-tuning a 
Sequences requires rearranging and inserting steps, as well as 
using Sequence tools.

INSERTING STEPS
You can insert Steps, or Shortcuts, by selecting them from the 
Create menu and creating them in the Shortcut Properties 
dialog that appears. You can insert steps that pause your 
Sequence, select a specific window, display a custom dialog, 
and much more. See page 144 for more information on these 
types of Sequence tools.

You can also drag and drop Shortcuts from the Shortcut list to 
the insert arrow in the Sequence Editor. To do this, the Import 
Steps tab must be selected. 

REARRANGING STEPS IN THE SEQUENCE
Rearrange Sequence steps in the Sequence Editor using cut 
and paste functionality. Select the step in the Sequence you 
want to move and click the Cut icon. Move the insert arrow to 
the step in the Sequence where you want to insert the step and 
click the Paste icon. The selected Shortcut appears in the new 
location in your Sequence.

DELETING SEQUENCE STEPS
To delete steps in a Sequence, open the QuicKeys Editor and 
select the step you want to remove. Then select Delete from the 
Edit menu. 

 ▲ When you delete a Sequence step, there is no undo 
option, but if you press Cancel in the Sequence Editor, 
QuicKeys ignores your changes.

TIPS FOR BUILDING SEQUENCES
There are some methods you can use when you build 
Sequences to help ensure they function properly. This section 
provides some basic tips for building QuicKeys Sequences.

• Use the keyboard to select options whenever possible. 
Keyboard selections are more reliable than mouse clicks.

• Make your movements slow and deliberate while 
recording.

• Insert Pauses as steps in your Sequences if you are having 
problems getting your Sequences to play back correctly.

• Do not grab a scroll bar to scroll through a list in a 
Sequence. Instead, use the Page Up and Page Down keys.

• If you have a choice, use cut and paste rather than
drag-and-drop.

• You can record several small Sequences and combine them 
in the Sequence Editor to make a large, complex Sequence. 
This method makes it easy to pinpoint problems that may 
occur in your Sequence.

• When you record a Sequence, that Sequence is 
automatically scoped to the last application used by the 
Sequence. To change the scope of the Sequence, cut the 
Sequence from the Set in which it resides and paste it into 
another Set.

SAVING SEQUENCES
When you click OK in the Sequence Editor, your Sequence is 
automatically saved.
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TRIGGERING SEQUENCES
Press the keystroke you assigned to your new Sequence. 
When the Sequence is triggered, the Playback palette appears 
if you are using QuicKeys’ default palette settings. You can 
use this palette to pause or stop the Sequence at any time. 
Figure 64 on page 48 shows the dialog you can use to set the 
QuicKeys palette settings. 

DELETING SEQUENCES
To delete Sequences, open the QuicKeys Editor and select the 
Sequence you want to remove. Select Delete from the Edit menu. 
Click the Delete button in the alert window that appears.

 ▲ There is no “undo” function if you choose to delete a 
Shortcut or Sequence from the Quickeys Editor.

SEQUENCE TOOLS
Sequence tools consist of Shortcuts that are used primarily in 
Sequences. They enable you to fine-tune each step of your 
QuicKeys Sequence. These Shortcuts can be categorized in 
two distinct groups: conditional Sequence tools and 
unconditional Sequence tools.

Decision, Jump, and Wait are conditional Sequence tools. You 
can use these three plug-ins when you want QuicKeys to test 
for certain conditions before proceeding with the Sequence. 
The other four Sequence tools (Pop-up Menu, GoSub, 
Message, and Repeat) are unconditional plug-ins that enhance 
the power and flexibility of your Sequences. This section 
discusses each of the seven Sequence tools and how you use 
them.

CONDITIONAL SEQUENCE TOOLS
Conditional Sequence tools enable you to set up conditions 
that must be met before the Sequence can proceed. These 
Sequence tools include:

• Decision

• Jump

• Wait

Decision
Use the Decision Shortcut to set up conditional branching in 
your Sequences. Conditional branching enables you to 
indicate how your Sequence should proceed when certain 
conditions are met. For example, when certain conditions are 
met, the Sequence does X, but when these same conditions are 
not  met, the Sequence branches to Y. 

When a Decision Shortcut in a Sequence is finished, the 
sequence continues from the step after Decision. If you don’t 
have any steps after Decision, the Sequence terminates. 

Using Decision

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Decision Shortcut.

2. Position the insert arrow in the location you want to insert 
the Decision Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Decision.

4. Complete the Shortcut Properties dialog and click OK.

Jump
Use the Jump Shortcut to jump to another step in your 
Sequence. When the conditions you set in the Jump Shortcut 
are true, your Sequence jumps to the step you specified. When 
the conditions you set in the Jump Shortcut are false, your 
Sequence simply moves to the step that follows the Jump step.
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Using Jump

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Jump Shortcut.

2. Position the insert arrow in the location you want to insert 
the Jump Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Jump.

4. Complete the Shortcut Properties dialog and click OK.

Wait
Use the Wait Shortcut to pause a Sequence until a particular 
condition has been met.

Using Wait

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Wait Shortcut.

2. Position the insert arrow in the location you want to insert 
the Wait Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Wait.

4. Complete the Shortcut Properties dialog. 

5. Click OK when you are finished.

Decision, Jump, and Wait Options
This section describes the Shortcut-specific properties 
available with the Decision, Jump, and Wait plug-ins.

(When/Until) Button
When you select the Button option in the When pop-up menu, a 
series of Button-specific options appear.

Button Name
Type the name of the button you want the Shortcut to look for. 

Match exactly
Select this check box if the button name must match the 
characters supplied in the Button Name box. The search is not 
case sensitive. 

Exists
Use the options in the Exists pop-up list to specify whether or 
not the button should exist.

Enabled
Use the options in the Enabled pop-up list to specify whether 
QuicKeys determines that the button name you provided 
should be enabled, should be dimmed, or whether its status 
matters at all.

Figure 188: The Button options in the Decision Shortcut Properties 
dialog.
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Selected
Use the options in the Selected pop-up list to specify whether 
QuicKeys determines that the button name you provided 
should be selected by default, should not  be selected by 
default, or whether its status matters at all.

(When/Until) Cursor
When you select the Cursor option from the When pop-up menu, 
a series of cursor-specific options appears.

Cursor
Select what kind of cursor QuicKeys should be looking for. If 
you select Other, you can pick from a variety of cursors.

Check Cursor Outline
Select this option if you want QuicKeys to look only at the 
outline of the cursor. For example, if you want QuicKeys to 
search for a spinning beach ball, you probably want to select 
this option since the interior of the beach ball cursor changes.

Check Cursor
Select this option if you want QuicKeys to look for the cursor 
you specify.

Figure 189: The Cursor options in the Decision Shortcut Properties 
dialog.

Figure 190: The cursor window.
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(When/Until) Menu
When you select the Menu option from the When pop-up 
menu, a series of Menu-specific options appear.

Browse for Menu Item
Click this button to record your menu selection. A window 
appears telling you to select a menu item and QuicKeys 
watches as you pick the menu item you want to use.

Menu Name
Type the name of the menu that you want the Shortcut to look 
for.

Match exactly
Select these check boxes if the menu name and item name 
QuicKeys searches for must exactly match the characters 
supplied in the Menu Name and Item Name boxes. The search is 
not case sensitive. 

Item Name
Type the name of the menu item that you want the Shortcut to 
look for.

Exists
Use the options in the Exists pop-up list to specify whether or 
not the button should exist.

Enabled
Use the options in the Enabled pop-up menu to specify whether 
QuicKeys determines that the menu and/or item name you 
provided should be enabled, should be dimmed, or whether 
its status matters at all.

Checked
Use the options in the Checked pop-up menu to specify 
whether QuicKeys determines that the menu/item name you 
provided should have a check mark next to it by default, 
should not  be selected by default, or whether the presence of a 
check mark matters at all.

(When/Until) Other
When you select the Other option from the When pop-up menu, 
a series of miscellaneous options appear.

Figure 191: The Menu options in the Decision Shortcut Properties 
dialog.

Figure 192: The Other options in the Wait Shortcut Properties dialog.
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Beep Sound
This option is only available for the Wait Shortcut. Use this 
condition to make the Wait Shortcut pause for a beep sound 
before the Sequence proceeds.

User Action
This option is only available for the Wait Shortcut. Specify a 
user action that must occur before the Sequence proceeds. 

Time/Date
Select the date and time you want the Shortcut to check before 
proceeding to the true or false branch.

Application
Type the name of the application you want to make sure is/is 
not running before proceeding to the true or false branch of 
the Sequence.

Clipboard
Specify what type of data should or should not be in the 
system clipboard before the Shortcut can proceed. By default, 
QuicKeys performs an ASCII comparison. Check the Numeric 
Comparison check box if you want QuicKeys to instead do a 
numeric comparison. For example, in an ASCII comparison, 
0200 is smaller than 2. In a numeric comparison, 0200 is larger 
than 2.

(When/Until) Window
When you select the Window option from the When pop-up 
menu, a series of Window options appear.

Window
Choose the position of the window the Shortcut must look for.

Name
Specify the name of the window the Shortcut must look for.

Type
Specify the type of window the Shortcut must look for.

Wait Until Window
Specify the status of the window the Shortcut must look for.

If true...
This option is only available in the Decision Shortcut 
Properties dialog. Type the name of the Shortcut you want 
QuicKeys to branch to if all the conditions you set forth are 
true.

Figure 193: The Window options in the Jump Shortcut Properties dialog.
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If false...
This option is only available in the Decision Shortcut 
Properties dialog. Type the name of the Shortcut you want 
QuicKeys to branch to if all the conditions you set forth are 
false. 

Jump To
This option is only available in the Jump Shortcut Properties 
dialog. Type the step number you want to jump to or choose 
to jump to the end of the Sequence when the conditions in the 
Jump Shortcut are true.

UNCONDITIONAL SEQUENCE TOOLS
The unconditional Sequence tools available in QuicKeys 
enable you to fine-tune your Sequence without having to set 
up specific conditions. These Sequence tools include:

Pop-up Menu
Use the Pop-up menu to select an item in a pop-up menu. This 
Shortcut is extremely useful because it enables you to select 
items within dialogs that may appear during your Sequence. 
The Pop-up Menu plug-in is also useful outside of Sequences.

Using Pop-up Menu

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Pop-up Menu Shortcut.

2. Position the insert arrow in the location you want to insert 
the Pop-up Menu Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > 
Pop-up Menu.

4. Complete the Shortcut Properties dialog and click OK.

Pop-up Menu Options

Select Pop-up Menu
Click this button to record your pop-up menu selections. Your 
selection populates the Name and Position boxes in the 
Shortcut Properties dialog.

Match exactly
When this check box is selected, the name and position of the 
menu you want to locate must be typed exactly as it appears in 
the software. The search is not case sensitive.

Find Menu By Name
Locates the menu item in the pop-up menu by name.

Find Menu By Position
Locates the menu item by screen coordinates.

Click Location X/Y
The screen coordinates based on the origin you select. For 
example, if you select From Top Left of Window, the origin of the 
coordinates is the top left of the window in the foreground. 

• Pop-up Menu • Password Vault

• Repeat • GoSub

• Message • User/Timed Pause
Figure 194: The Pop-up Menu Shortcut Properties dialog.
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Use modifiers
Select which modifier keys must be selected when you choose 
a particular pop-up menu item.

Password Vault
The Password Vault plug-in can be used in Sequences for 
storing secure information, such as E-mail passwords. If your 
passwords are entered as asterisks rather than identifiable 
characters, no one standing behind you can see the passwords 
you enter to access network volumes, E-mail, etc. This plug-in 
is not  a substitute for encryption software—it simply allows 
you to safely incorporate passwords into the Sequences you 
build.

Using Password Vault

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Password Vault Shortcut.

2. Position the insert arrow in the location you want to insert 
the Password Vault Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Password 
Vault.

4. Complete the Shortcut Properties dialog. Your password 
will initially appear in plain text.

5. Click OK when you are finished.

Substituting Password Vault for Type Text
If you record a Sequence that logs into a secured network area, 
QuicKeys inserts a Type Text Shortcut in your Sequence in the 
step where you typed your password. Because the Type Text 
plug-in displays your password in plain text within 
QuicKeys, you may want to substitute your Type Text 
Shortcut with a Password Vault Shortcut. 

When you open a Password Vault Shortcut within QuicKeys, 
your password is displayed in bullets, making it more secure  
if you share your computer and must leave the QuicKeys 
Editor unlocked. 

Figure 195: The Password Vault Shortcut Properties dialog.
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To substitute the Password Vault Shortcut for the Type Text 
Shortcut in your Sequence:

1. Open a Sequence that types a password in one of the steps. 
Passwords are typically recorded by QuicKeys as Type Text 
Shortcuts.

2. Position the insert arrow above the Type Text step of the 
Sequence and select Create > Sequence Tools > Password Vault.

3. Type your password in the Password Vault Shortcut 
Properties dialog that appears and click OK. A Password 
Vault Shortcut appears in your Sequence.

4. Highlight the Type Text Shortcut that enters your 
password and select Delete from the Edit menu. The 
Password Vault Shortcut has now replaced the Type Text 
Shortcut.

5. Click OK in the Sequence Editor.

Password Vault Options
This section describes the Shortcut-specific properties 
available with the Password Vault plug-in.

Password
The password you want the Sequence to enter for you.

Repeat
A Repeat Shortcut can be used in Shortcuts and Sequences. In 
Shortcuts, Repeat can be used to replay a particular Shortcut 
as many times as you specify. In Sequences, Repeat can be 
used to cycle through a particular section of the Sequence as 
many times as you specify—you just have to specify where 
the loop begins and where it ends.

Using Repeat

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Repeat Shortcut.

2. Position the insert arrow in the location you want to insert 
the Repeat Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Repeat.

4. Complete the Shortcut Properties dialog. 

5. Click OK when you are finished.

Repeat Options
This section describes the Shortcut-specific properties 
available with the Repeat plug-in.

Repeat Shortcut
Repeats the Shortcut you specify.

Play the Shortcut X
Type the name of the Shortcut you want repeated.

X Times
Choose how many times you want the specified Shortcut 
repeated.

Begin Repeat in Sequence
Indicates where Repeat will begin when it repeats a series of 
steps in a Sequence. 

Figure 196: The Repeat Shortcut Properties dialog.
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❖ You must create an End Repeat Shortcut in your 
Sequence to terminate a Begin Repeat Shortcut.

Repeat Items between Begin and End X times
Choose how many times you want the series of steps in a 
Sequence repeated.

End Repeat in Sequence
Indicates where Repeat will end when it repeats a series of 
steps in a Sequence.

Prompt for Repeat Count
Displays a prompt where you can choose how many times 
you want the Shortcut or steps in the Sequence to repeat.

GoSub
Use the GoSub Shortcut to perform a Shortcut you specify 
before proceeding with the Sequence.

Using GoSub

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a GoSub Shortcut.

2. Position the insert arrow in the location you want to insert 
the GoSub Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > GoSub.

4. Complete the Shortcut Properties dialog.

5. Click OK when you are finished.

GoSub Options
This section describes the Shortcut-specific properties 
available with the GoSub plug-in.

Shortcut to Play
Type the name of the Shortcut you want GoSub to perform 
before proceeding with the Sequence. You must type the name 
exactly  as it appears in your QuicKeys Editor Shortcuts list 
because the name is sensitive to spaces.

Message
Use the Message Shortcut to display a modal window during 
a Sequence. 

Using Message

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a Message Shortcut.

2. Position the insert arrow in the location you want to insert 
the Message Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > Message.

4. Complete the Shortcut Properties dialog.

5. Click OK when you are finished.

Figure 197: The GoSub Shortcut Properties dialog.
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Message Options
This section describes the Shortcut-specific properties 
available with the Message plug-in.

Message to Display
The text you type in this box displays in a modal window 
similar to the one in Figure 198.

Text Entry Field
Choose where you want to store the information provided by 
the user in the Message Shortcut’s modal window. You can 
store the information in the clipboard, you can type it as text 
with or without a carriage return, or you can play a particular 
Shortcut by name.

Display OK Button
Choose this option to display an OK button in the modal 
window that appears.

Display Cancel Button
Choose this option to display a Cancel button in the modal 
window that appears.

Continue automatically after X seconds
Check this option if you want the Sequence to proceed if 
there’s no user input in the modal window after a specified 
number of seconds.

Figure 198: The Message Shortcut displays a modal window that 
requires user input during the playback of a 
Sequence.

Figure 199: The Message Shortcut Properties dialog.



154 Chapter 14
Sequences and Sequence Tools

• • • •
User/Timed Pause
Use a User/Timed Pause Shortcut to halt a Sequence at a 
particular step and wait.

Using User/Timed Pause

1. Open the Sequence Editor to display the Sequence in 
which you want to insert a User/Timed Pause Shortcut.

2. Position the insert arrow in the location you want to insert 
the User/Timed Pause Shortcut.

3. In the Sequence Editor, select Create > Sequence Tools > User/
Timed Pause.

4. Select User/Timed Pause from the Create menu.

5. Complete the Shortcut Properties dialog.

6. Click OK when you are finished.

User/Timed Pause Options
This section describes the Shortcut-specific properties 
available with the User/Timed Pause plug-in.

Pause for X second(s)
Specify how many seconds you want to wait before allowing 
the Sequence to proceed. This option is a valuable 
troubleshooting tool when you sense that QuicKeys is not 
working at the same pace as the applications it is attempting 
to manipulate.

Pause and wait for user
Choose this option if you want QuicKeys to require user input 
before proceeding with the Sequence. For example, you might 
want to pause your Sequence to enter a document name. 
When you have provided the necessary information, just 
press the Pause button on the Playback palette to resume the 
Sequence. 

❖ See page 48 for instructions on displaying the 
Playback Palette. 

Figure 200: Select a plug-in from the Sequence Tools submenu.

Figure 201: Set the length of a pause in 
the Pause dialog.

Pause Stop Edit

Figure 202: The Playback Palette.
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APPENDIX A
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QUICKEYS EXAMPLES

Learning software is usually much easier when you can 
reference existing examples of how to use it. This appendix 
provides some examples of how you can use QuicKeys. While 
these particular examples may not directly apply to how you 
intend to use QuicKeys, they do  provide striking illustrations 
of how QuicKeys can save time for just about anyone who 
uses a computer.

❖ Since QuicKeys functionality is based on the 
applications and file locations on a specific 
computer, please note that these examples are only 
meant to be a springboard for your own ideas. They 
are not meant to be recreated without modifications. 

USING QUICKEYS FOR DESKTOP 
PUBLISHING

If you are a graphic designer or prepress expert, this example 
is for you. Imagine for a moment all the projects you receive 
from clients. Each project probably uses different paper sizes 
that must be specified in the Page Setup dialog and making 
those changes can really be time-consuming. QuicKeys can 
help free up some of your time by automating the process of 
changing page attributes for different print jobs.

HOW TO CREATE THE SEQUENCE
This Sequence was created using QuicKeys recording. The 
Sequence is scoped to FrameMaker, so it only works when 
FrameMaker is the active application. Additionally, the 
Sequence uses the LaserWriter 8 printer driver.

1. Select Start Recording from the QuicKeys menu.

2. Press Shift+F8 to open FrameMaker’s Page Setup dialog.

3. In the Page Setup dialog, select a paper size from the Paper 
pop-up menu.

4. Press the Return key on your keyboard to close the Page 
Setup dialog. (A button click is more reliable than a mouse 
click when recording Sequences.)

5. Select Stop Recording from the QuicKeys menu. The Sequence 
Editor appears with the Sequence shown in Figure 203.

6. Type a name for the Sequence in the Name box.

7. Select the Include in QuicKeys menu check box and click OK. 
Since the Shortcut is scoped to FrameMaker, it will only 
appear in the QuicKeys menu when FrameMaker is the 
active application.

Figure 203: This Sequence changes your page size in the LaserWriter 8 Page 
Setup dialog.
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USING QUICKEYS WITH E-MAIL 
SOFTWARE

Checking electronic mailboxes has become as commonplace 
as checking the mailbox at your home. Since reading and 
responding to mail now dominates a lot of computer users’ 
time, it is a perfect candidate for automation using QuicKeys. 

This section provides two examples for using QuicKeys and 
E-mail together. The first example automates the process of 
switching between E-mail accounts. The second example uses 
AppleScript to share information between FileMaker Pro, 
QuicKeys, and your E-mail software.

CHANGING E-MAIL IDENTITIES
One task that system administrators must frequently perform 
is switching between E-mail accounts. Administrators may 
have to assume several different electronic identities. For 
example, an administrator may have to send mail as both the 
systems administrator and as an individual who works for 
Company X, depending on who is receiving the 
administrator’s messages. This process of changing your E-
mail identity can be quite time-consuming, so it is an ideal 
candidate for automating with a QuicKeys Sequence.

In this example, an administrator changes the account 
properties in Microsoft Outlook Express to change his identity 
from Joe.Smith@cesoft.com to administrator@cesoft.com.

First, look at the illustration of the Sequence in the Sequence 
Editor shown in Figure 204. Then, look at the instructions that 
explain how this Sequence was created to get a feel for how 
you can automate a task like this on your  computer.

How To Create the Sequence
This particular Sequence was created with the recording 
feature. Here’s a play-by-play of how this Sequence was built:

1. Open Outlook Express. 

2. Select Start Recording from the QuicKeys menu.

3. Select Change Current User from the File menu. A prompt 
appears asking you to verify that you want to close the 
current account.

4. Press the return key to select Yes at the prompt.

5. Use your mouse to select a user from the window that 
appears.

6. Press the Return key to choose the OK button in the Select a 
user window.
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7. Select Stop Recording from the QuicKeys menu. The Sequence 

Editor appears. 

8. Name the Sequence Change mailuser.

9. Select the Include in QuicKeys menu check box to trigger this 
Sequence from the QuicKeys menu.

10.  Click the OK button.

AUTOMATING E-MAIL CONTENT
If you are in sales or technical support, there are probably 
times when you have to E-mail customers information from 
your database. For example, if a customer reports a problem 
and the problem is fixed in the next software release, you may 
want to paste the customer’s report into an E-mail message 
and alert the customer that the problem has been fixed and he 
can download the new software from your Web site. 
QuicKeys can do all this for you using AppleScript.

AUTOMATING MESSAGE CONTENT
This Shortcut was created using an AppleScript script. 
QuicKeys is set up to launch the script when the Ext. bug Msg. 
Shortcut is selected from the QuicKeys menu.

1. Open the QuicKeys Editor.

2. Select Create > Scripting Tools > AppleScript.

3. Select the Text radio button and click the Modify Text button 
that becomes enabled.

Figure 204: This Sequence changes logs into a different mail account 
for you.
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4. Write your script in the dialog that appears or copy it from 
the Script Editor. Figure 205 shows the script in the Script 
Editor.

5. Click OK in the Script dialog when you are finished writing 
the script. The AppleScript Shortcut Properties dialog 
displays the first line of the script in the Text field of the 
dialog.

6. Select Ignore in the Results pop-up menu.

7. Click OK when you are finished. 

Figure 205: This script copies information from a database and pastes it 
into an E-mail message.

Figure 206: This Shortcut launches the script shown in Figure 205.
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When you trigger this Shortcut, an E-mail message similar to 
the one in Figure 207 appears.

USING QUICKEYS WITH APPLESCRIPT 
AND FILEMAKER

This section provides two different examples that each 
automate the same task: logging into a FileMaker network 
database. The first example shows how to use QuicKeys 
recording to automate your database logins. The second 
example shows how to use AppleScript to automate your 
database logins.

RECORDING FILEMAKER DATABASE LOGIN
This Sequence was recorded with QuicKeys and then 
modified by removing unnecessary Waits and replacing Click 
Shortcuts with Button Shortcuts where appropriate.

1. Launch FileMaker Pro.

2. Select Record Sequence from the QuicKeys menu. If you are 
using the default QuicKeys settings, a recording palette 
appears on your desktop.

3. In FileMaker Pro, select Open from the File menu.

4. Click Hosts in the Open dialog that appears. A Hosts window 
appears.

Figure 207: You can automate the contents of an E-mail message using 
AppleScript and FileMaker Pro.

Figure 208: Click Hosts to see a list of network 
database hosts.
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5. Select a volume and a host and click Open.

6. Type your password at the prompt and click OK.

7. Select Stop Recording from the QuicKeys menu. The Sequence 
Editor appears. 

8. Remove any unnecessary Wait Shortcuts.

9. Replace Click Shortcuts with Button Shortcuts if 
applicable. For example, a Button Shortcut would be more 
reliable than a Click Shortcut to select the Hosts button in 
step 4. 

10.Replace your Type Text Shortcut with a Password Vault 
Shortcut so your password is not in plain text. See page 150 
for more information on this process. 

When you are finished, your Sequence looks similar to the one 
shown in Figure 211.

SCRIPTING FILEMAKER DATABASE LOGIN
This Sequence opens a password protected database over the 
network using FileMaker's “getURL” AppleScript command 
and QuicKeys' AppleScript plug-in. FileMaker doesn't 
support AppleScripting of the password for “getURL,“ so you 
must manually insert a QuicKeys Password Vault Shortcut in 
the Sequence.

1. Open the QuicKeys Editor.

2. Select Create > Sequence. The Sequence Editor appears.

3. Select Create > Scripting Tools >  AppleScript in the Sequence 
Editor.

Figure 209: Select a host in this window.

Figure 210: Type your database password at 
this prompt.

Figure 211: This Sequence logs into a network database.
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4. In the AppleScript Shortcut Properties dialog, select the Text 

radio button and click the Modify Text button that becomes 
enabled. The Script dialog appears.

5. Write your script in the Script dialog or copy it from the 
Script Editor. Figure 212 shows the script in the Script 
dialog.

6. Click OK when you are finished with your script. The 
AppleScript Shortcut Properties dialog appears with the 
first line of the script listed in the Text field.

7. Type a name for the Shortcut in the Name box. For 
example, type FMP-get URL.

8. Select Ignore from the Results pop-up menu and click OK to 
close the Shortcut Properties dialog and display the 
Sequence Editor.

Inserting Password Information

1. With the Sequence Editor still open, position your insert 
arrow below the FMP-get URL Shortcut.

2. Select Create > Sequence Tools > Password Vault to open the 
Password Vault Shortcut Properties dialog.

3. Complete the Password Vault dialog and click OK. The 
Password Vault Shortcut appears immediately after the 
Startup Script Shortcut.

4. In the Sequence Editor, position your insert arrow in the 
step before the Password Vault Shortcut and select Create > 
Sequence Tools > Wait.

5. In the Wait dialog, choose to have QuicKeys wait until a 
dialog with specific attributes appears.

Figure 212: This script logs into a network database.

Figure 213: The AppleScript Shortcut Properties dialog as it appears after 
you select a script.
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6. Insert a Button Shortcut at the end of the Sequence that 
uses the Always Clicks Button option. 

7. Type a name and a keystroke for the Sequence in the 
appropriate boxes. The finished script will look similar to 
the one shown in Figure 214.

8. Click OK in the Sequence Editor when you are finished.

USING DOSCRIPT WITH FILEMAKER
1. Write a FileMaker Pro script and name the script “Startup.” 

When you are finished, the script should be available from 
FileMaker Pro’s Script menu.

2. Open the QuicKeys Editor.

3. Select Create > Scripting Tools > DoScript in the Sequence Editor.

4. Select the Text radio button and click the Modify Text button.

5. Type Startup in the Script dialog that appears and click OK. 
This will cause the DoScript plug-in to start the FileMaker 
script named "Startup." Any FileMaker script may be 
started by placing its name in a DoScript shortcut that is 
pointed at FileMaker. This feature only works in the 
frontmost window of FileMaker.

6. In the DoScript Shortcut Properties dialog, select Ignore 
from the Results pop-up window.

7. Position your cursor in the Keystroke box and press 
Control+F1.

8. Position your cursor in the Name box and type Startup Script.

9. Click OK when you are finished.

Figure 214: The finished scripted database login.

Figure 215: The FileMaker Pro Script menu.

Figure 216: The name of the script appears in the DoScript Shortcut 
Properties dialog after it is selected.
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USING QUICKEYS FOR WEB 
DEVELOPMENT

The Web site manager job is one of today’s least well-defined 
jobs. It crosses the boundaries of marketing, advertising, and 
technology. The nature of the job places Web site managers at 
the heart of many of the company’s critical activities and the 
end results are seen by thousands, perhaps even millions, of 
people.

While the tools for creating Web sites and Web pages have 
evolved significantly in the past few years, the fact remains 
that there is still substantial room for increased productivity. 
Most Web site managers have to use a variety of tools to 
handle the myriad tasks of creating and maintaining a web 
site. A typical toolkit may look something like this:

While some tools combine a few of these functions, there is 
still no single solution that embraces all of the features and 
functions listed above. As a consequence, using these tools 
collectively is a challenge. However, QuicKeys for Mac can 
help you meet the challenges facing most Web site managers 
by providing measurable improvements in productivity, 
fewer errors, and general workload reduction.

SOLUTIONS FOR WEB SITE MANAGERS
The key to effective Web site management is to be organized 
and to work quickly and accurately. The challenge is to 
effectively use the wide array of tools to manage the contents 
so that the site is up-to-date and works correctly. QuicKeys 
can act as a major productivity enhancer in this environment.

QuicKeys doesn’t represent one specific solution, but rather a 
collection of solutions that, applied to the Web site manager’s 
tasks, can yield substantial savings in time and greater 
efficiency.

The most powerful aspect of QuicKeys for the Web site 
manager is the ability to record a sequence of actions and then 
play them back. For example, launching an FTP client, typing 
in user and password information, changing directories, and 
even moving files around can all be part of a QuicKeys 
Sequence. You can customize your favorite page editor so that 
changing typeface, font size and style is no longer a series of 
mouse clicks, but rather a faster and more reliable QuicKeys 
Sequence, all driven from a single key press. Image editors 
can replay Sequences that change image sizes, bit-depth and 
other elements and then saves and names the files.

The recording feature of QuicKeys can create very long and 
involved Sequences. One of the biggest strengths of this 
function is that it provides an automation solution that works 
with virtually all of the applications a Web site manager must 
use. And best of all, no scripting or programming is necessary 
to get a Sequence recorded.

To illustrate a small sample of what QuicKeys recording can 
do for you as a Web site manager, the following section details 
the creation of a Sequence that starts the Fetch application and 
logs into a frequently used FTP site.

To get a feel for how this Sequence was built, look at the 
illustration of the Sequence in the Sequence Editor shown in 
Figure 219. Then look at the instructions that explain how this 
Sequence was created to get a feel for how you can automate a 
task similar to this on your  computer.

• Text editor • Java Editor

• Page editor • FTP client

• Browser(s) • Graphics editor

• E-mail client
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HOW TO CREATE THE SEQUENCE
The following is a play-by-play of how this Sequence was 
built.

Open a frequently-used FTP site

1. Launch the Fetch application.

2. Select Start Recording from the QuicKeys menu.

3. In the New Connection dialog that appears when you open 
Fetch, type your login information. Press the tab key to 
move between dialog entries.

4. Press the return key when you complete the New 
Connection dialog. A list of directories appears.

5. Select the directories you want to open with the “Type to” 
feature. In other words, press “I” and “N” on your 
keyboard to select the “Info” directory shown in 
Figure 218.

6. Press the Return key when the directory you want to open 
is selected.

Figure 217: The Fetch login dialog.

Figure 218: The list of directories shown in a Fetch dialog.
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7. Select Stop Recording from the QuicKeys menu. The Sequence 

Editor appears.

8. Name the FTP Sequence Fetch FTP and assign it a trigger.

9. Click the OK button to save your new Sequence and close 
the Sequence Editor.

10.Click the close box to close the Editor window.

Figure 219: The steps required to automate the process of logging into 
an FTP site.
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OMITTING MODIFIED FILES

The Project Saver plug-in, File Recall plug-in, and a 
component of the Instant E-mail plug-in all scan your local 
drives looking for recently modified files. There may be 
occasions when you do not want certain files to be selected in 
these scans, such as when you have been exploring several 
Web sites that have been cached on your system. This 
appendix provides instructions for omitting unwanted files 
from your scans of recently modified files.

ADDING FILES TO THE OMITTED FILE LIST
1. Open the :System Folder:Preferences:QuicKeys 

Folder:Omitted File List. The Omitted File List opens in a 
text editor, such as SimpleText.

2. Supply Type and Creator Code information in the left column. 
See 

❖ If you do not know Type and Creator codes for your 
applications, you can locate this information with 
shareware, such as FileTyper, or you can extract the 
information using the File Handler dialog shown in 
Figure 111 on page 80.

3. Type two backslashes to comment out the description of 
the File Type and Creator.

4. Insert a carriage return at the end of the entry.

5. Save the file and close it.

Type and 
Creator 
codes

Comment 
character

This description of Type and Creator codes 
has been commented out. You can type 
this information after the comment 
characters to help you keep track of which 
files are being omitted.  

Figure 220: The omitted file list.
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FORMAT
The format of the Omitted File List is:

<four character file type><four character file 
creator><//><Comment of any length><carriage 
return>
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APPENDIX C 

• • • • • •
QUICKEYS SCRIPT

QuicKeys Script is a scripting language based on QuicKeys 
commands. When you create macros in the Script Editor or 
any other OSA-compliant editor (Open Scripting 
Architecture), QuicKeys Script is one of the scripting 
languages you can choose. QuicKeys Script is easy to 
understand because English-like QuicKeys commands are 
used to create a QuicKeys Script. QuicKeys Script is displayed 
in QuicKeys Sequences when you select the option to “Show 
Additional Information” in the Sequence Editor.

 ▲ The QuicKeys Backgrounder must be running for 
QuicKeys Script to function properly.

WHO CAN USE QUICKEYS SCRIPT?
You can use QuicKeys Script with any OSA-compliant 
scripting editor. The most common scripting editor is Apple’s 
Script Editor. Once you are familiar with the Script Editor’s 
interface you can record scripts in QuicKeys Script. If you are 
unfamiliar with these, consult Apple documentation before 
reading about QuicKeys Script. You do not have to be a 
computer programmer to use QuicKeys Script. However, if 
you are an advanced user, you may wish to write and edit 
scripts using the Language Syntax Reference section of this 
document.

WHEN TO USE QUICKEYS SCRIPT AND 
APPLESCRIPT

The Script Editor allows you to record and edit scripts in 
either QuicKeys Script or AppleScript. As a QuicKeys user, 
you will find the commands used in QuicKeys Scripts 
familiar. The commands use QuicKeys terminology, such as 
the names of shortcuts and plug-ins. Follow the guidelines 
below when determining whether you should use QuicKeys 
Script or AppleScript when creating a script. 

QUICKEYS SCRIPT
Use QuicKeys Script to create scripts for any program, 
regardless of whether it supports AppleScript. 

APPLESCRIPT
Use AppleScript to create scripts only for applications that 
support the AppleScript language. The program’s packaging 
usually indicates if it supports AppleScript. 

 QUICKEYS SCRIPT RECORDING
QuicKeys is a powerful program, even without its added 
scripting capabilities. However, you can handle some tasks 
better using a script editor. 

USING THE SCRIPT EDITOR
In the following example, you will create a QuicKeys Script 
script in the Script Editor that takes information on the 
Clipboard and pastes it in the Scrapbook.
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Creating a Script

1. Open the Script Editor.

2. Type a meaningful description of the script in the 
Definition field. For this example, type Copy to Scrapbook.

3. Select QuicKeys from the pop-up menu at the bottom of the 
Editor window.

4. Put meaningful information onto the Clipboard. You need 
to have information on the Clipboard for this example. To 
do this:

•Open any word processor.

•Type some text to activate the Copy command in the Edit 
menu.

•Highlight the text, and then select Copy in the Edit menu. 
You now have information on the Clipboard.

5. Return to the Script Editor.

Recording a Script

1. Click the Record button to begin recording the script.

•Open the Scrapbook in the Apple menu.

•Select Paste in the Edit menu. The information you 
copied in Step 4 should appear in the Scrapbook.

•Select Close in the File menu.

2. Click in the Script Editor window so it is the frontmost 
window, and then click the Stop button. The script has 
been written for you in the Script Editor window.

Playing a Script
Click the Run button to play your script. Playing the script 
verifies the accuracy of the script. To cancel playback, press 
Command-Period.

You will notice that the Check Syntax button is unavailable 
since you have not made any changes to the script. If you do 
make changes, the Check Syntax button becomes available
so you can check the script for errors.

The Result window is empty because the script does not 
produce a result.

If you would like to use this script later, select Save or Save As in 
the File menu.

Refer to the Language Syntax Reference section to better 
understand the script you just recorded.

❖ If the script does not play correctly, you will need to 
edit the script. Read each command line of the 
script, and refer to the Language Syntax Reference 
section for descriptions of the commands.

QUICKEYS SCRIPT WRITING AND EDITING
Knowing how to edit a script can be a time-saver. You can add 
commands to and remove commands from a script, or create a 
script without recording. Otherwise, start over and record 
your script from the beginning.

This example describes how to use the Script Editor to write a 
script that turns your desktop grid on. Turning the grid on 
snaps icons on the desktop to an organized position. If you do 
not have a script to do this for you, you must open the View 
Options dialog and select the Always snap to grid radio button.

SETTING THE OPTIONS

1. Open the Script Editor to create a new script.

2. In the Definition field, type Turn on grid.

3. Select QuicKeys from the pop-up menu at the bottom of the 
window.
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WRITING THE SCRIPT

The following script assumes you are displaying Finder 
windows using the as Icons view.

1. Click in the script window to type the script.

❖ You must use smart quotes (" "), as opposed to 
typographer’s or curly quotes, when writing a 
script.

2. In line 1 of the script, use the QuicKeys App Switcher 
Shortcut to make the Finder active. 

3. In line 2, type Menu "View Options" from "View". This command 
selects the View Options option from the View menu.

4. In line 3, type: Wait Window Name_is "View Options". This 
command uses a Wait shortcut to wait for the View Options 
window to appear. 

5. In line 4, type: Button "Always snap to grid". This command 
enables the Always snap to grid option using a Button Shortcut. 

6. In line 5, type Button "OK" to click the OK button in the View 
Options window. 

TESTING THE SCRIPT
Click the Run button to try the script. Notice how the icons on 
your desktop snap into position when the grid is turned on. If 
your script is not working properly, make sure you typed each 
line correctly. Now that you have learned how to write a basic 
script, practice writing and editing others. Refer to the 
instructions and examples in the following section as needed.

 LANGUAGE SYNTAX REFERENCE

BUILT-IN COMMANDS

Figure 221: The Snap To Grid script in the Script Editor.

AliasKeystroke

Types a keystroke.

Keyword Usage Description

AliasKeystroke Required Command 

ModKey Optional Which Modifiers to depress

%keycode Required Which key to type using Macintosh 
key code values. To get the correct 
keycode, put the Script Editor into 
Record mode and record the 
keystroke.

(asciicharacter) Ignored A user readable value. 

Usage

AliasKeystroke CMD-OPT %0 (A) 
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Button

Clicks the mouse on a button on the front window.

Keyword Usage Description

Button Required Command 

"Button Title” Required Name of button to access

ButtonTest Optional Only click based on current value

Usage

Button "OK"

Button "Font Substitution?" If_Off 

Click

Depresses and releases the mouse at defined locations. If a 
ButtonSpec is included, the starting coordinate is ignored.

Keyword Usage Description

Click Required Command 

MouseLoc Required Location of start of click

-MouseLoc Optional Location of click release (used for 
dragging)

#clicks Optional Number of times the mouse is 
clicked

ModKey Optional Which Modifiers to depress

WindowSpec Optional Which Window to click in

ButtonSpec Optional Which button to click in

Usage

Click (10,10 Top_Left) - (0,0 Mouse) #2 Window #1 ("Untitled-1") 
Button#1 ("OK")

Click (100,100 Screen) - (20,20 Screen) SHIFT-OPT

Click (-10,-10 Bottom_Right) - (-100, -100 Mouse) Window 
"MyDocument"
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DateTime

Type the current date or time.

Keyword Usage Description

DateTime Required Command 

ShortDate OnlyOne Displays the date in the format set 
in the Date/Time control panel.

Long_Date OnlyOne Displays the date in the format set 
in the Date/Time control panel.

Long_Date_Abbr OnlyOne Displays the date in the format set 
in the Date/Time control panel.

Long_No_Date OnlyOne Date as April 6, 1999

Short_No_Date OnlyOne Date as Apr 6, 1999

Long_Alt OnlyOne Date as 6 April 1999

Short_Alt OnlyOne Date as 6 Apr 1999

YYMMDD OnlyOne Date as 99/04/06

Short_Time OnlyOne Displays the time in the format set 
in the Date/Time control panel.

Long_Time OnlyOne Displays the time in the format set 
in the Date/Time control panel.

TwentyFourHr OnlyOne Time as 15:50

Usage

DateTime Long_Day 

DateTime HHMM

FileLaunch

Open a file or folder.

Keyword Usage Description

FileLaunch Required Command 

"Path" OnlyOne Full path of the application,  
document, or folder

System_Folder OnlyOne The system folder

Trash_Folder OnlyOne The trash folder

Apple_Menu_
Folder 

OnlyOne The Apple menu items folder

Control_Panels_Fo
lder

OnlyOne The Control Panels folder

Extensions_
Folder 

OnlyOne The extensions folder

Preferences_
Folder 

OnlyOne The preferences folder

Usage

FileLaunch "Harddisk:System Folder:Control Panels:QuicKeys"

FileLaunch "Harddisk:CalendarMaker"

FileLaunch Control_Panels_Folder

FileLaunch System_Folder
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FKey

Causes an FKEY installed in the system to execute.

Keyword Usage Description

FKEY Required Command 

#identifier Required Which FKEY to execute

Usage

FKEY #3 ; Trigger the screen shot

Menu

Selects a menu item.  If #MenuItemPosition is specified, the "Menu Item 
Title" is ignored. 

Keyword Usage Description

Menu Required Command 

"Menu Item Title" Required The title of the menu item

#MenuItem Position Optional Select menu item by position

Exactly Optional The title must match exactly

From "Menu Title" Optional Which menu to find menu item

Apple_Menu Optional Find in Apple Menu

ModKey Optional Which Modifiers to depress

Ignore_Errors Optional Do not report error messages

Usage

Menu "DiskTop" Apple_Menu

Menu "Save" Exactly From "File" Ignore_Errors
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Mousies

Perform mouse actions on the front window.

Keyword Usage Description

Mousies Required Command 

Close_Window OnlyOne Click in the close box of the front 
window

Zoom_Window OnlyOne Click in the zoom box of the front 
window

Collapse_Window OnlyOne Click in the collapse box of the front 
window

Line_up OnlyOne Click in the up arrow of a scroll bar

Line_Down OnlyOne Click in the down arrow of a scroll 
bar

Page_up OnlyOne Click in the page up area of a scroll 
bar

Page_Down OnlyOne Click in the page down area of a 
scroll bar

Home OnlyOne Drag the thumb to top of scroll bar

End OnlyOne Drag the thumb to the bottom of a 
scroll bar

Column_Left OnlyOne Click in the left arrow of a scroll bar

Column_Right OnlyOne Click in the right arrow of a scroll bar

Page_Left OnlyOne Click in the page left area of a scroll 
bar

Page_Right OnlyOne Click in the page right area of a 
scroll bar

Usage

Mousies Close_Window

Mousies Zoom_Window

Mousies Home

Mousies
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Pause

Pauses the system. Useful if QuicKeys is operating too quickly during a 
script.

Keyword Usage Description

Pause Required Command 

Secs.tenths OnlyOne Pause in seconds dot tenths of a 
second

And_Wait OnlyOne Pause the sequence indefinitely

Usage

Pause 3.0

Specials

A collection of actions to control QuicKeys.

Keyword Usage Description

Specials Required Command 

Editor OnlyOne Open the QuicKeys Editor

Transfer OnlyOne Display a file selection dialog and 
launch selection

Shut_Down OnlyOne Shutdown the system

Restart OnlyOne Restart the system

Select_Rear_
Window

OnlyOne Select the rear window of current 
application

Select_Second_
Window

OnlyOne Select second window of current 
application

QuickQuotes OnlyOne Performs the QuickQuotes action

Double_
QuickQuotes

OnlyOne Performs the Double QuickQuotes 
action

Quick_Reference OnlyOne Display the QuickReference card

Toggle_QuicKeys OnlyOne Enable / Disable QuicKeys

Usage

Specials Restart

Specials Select_Rear_Window
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PLUG-IN COMMANDSTypeText

Type a series of characters into the front most window.

Keyword Usage Description

TypeText Required Command 

"Characters to type" Required The text to type

Usage

TypeText "Clive Brown\RCE Software, Inc\R515-221-1801\R"

TypeText "Sincerely,\RClive Brown\R"

AppSwitcher

Control the front application.

Keyword Usage Description

AppSwitcher Required Command 

"Process Name" OnlyOne Name of application to bring to 
front

Back OnlyOne Switch to application in back

Ask OnlyOne Display a window asking the user 
for application

Previous OnlyOne Switch to application that 
previously was in front

Next OnlyOne Switch to next application

Hide Optional Hide current application

Usage

AppSwitcher "Finder" Hide

AppSwitcher Ask
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AppleScript

Execute an AppleScript. If Open_Clipboard is specified, the script 
routine On Open QkClipboard is called, and provides a variable titled 
"QKClipboard" which contains the clipboard.

Keyword Usage Description

AppleScript Required Command 

PathToScript Optional File name of the AppleScript

Open_Clipboard Optional Call the script routine "On Open 
QkClipboard"

Wait_Result OnlyOne Waits for the result before allowing 
QuicKeys to continue.

Ignore_Result OnlyOne Ignores the result.

Type_Result OnlyOne Types the results of the script. 
Waits for the result before allowing 
other Quickeys actions to 
continue.

Display_Result OnlyOne Displays the results of the script. 
Waits for the result before allowing 
other Quickeys actions to 
continue. 

Clipboard_Result OnlyOne Places the results of the script 
onto the clipboard. Waits for the 
result before allowing other 
Quickeys actions to continue.

Embedded
AppleScript

Optional The AppleScript, terminated with 
««.»» and a return.

Usage

AppleScript "Harddrive:MyScripts:BackUp"

AppleScript Display_Result Open_Clipboard On open QKClipboard

Beep 3
set x to QKClipboard & "'s length is " & Length of QKClipboard
x
end open
««.»»

**Note: You must have a Return after the »» characters.

AppleScript
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Choosy

Change the current printer. Network printers will require specifying the 
printer name and zone.

Keyword Usage Description

Choosy Required Command 

"PrinterDriver
Name"

Required The name of the printer driver

Printer "Printer 
Name"

Optional The network name of the printer

Zone "Zone Name" Optional The network zone for the printer

Report_Success Optional If specified, report that the 
selection was made

Usage

Choosy "StyleWriter"

Choosy "LaserWriter" Printer "Main LaserWriter" Zone "Second Floor"

Decision

Perform a branch operation

Keyword Usage Description

Decision Required Command 

System
Condition

Required What type of condition to examine

True_Shortcut 
"name"

Optional If condition is true, branch to this 
shortcut

False_Shortcut 
"name"

Optional If condition is false, branch to this 
shortcut

Usage

Decision Button "Replace" exact enabled True_Shortcut "Replace" 
False_Shortcut "Remove"
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Folders

Change the folder shown in the Open and Save As dialogs.

Keyword Usage Description

Folders Required Command 

"Path to Folder" OnlyOne Change to this folder

Restore OnlyOne Change back to previous folder

Usage:

Folders "Harddisk:Applications:"

Folders Restore

GoSub

Call another sequence.

Keyword Usage Description

Gosub Required Command

"Sequence Name" Required Name of sequence to run

Usage:

Gosub "SetUpPrinter"

Gosub "LogOnSequence"
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Jump

Jump over a few steps based on condition.

Keyword Usage Description

Jump Required Command

SystemCondition Required What type of condition to examine

Step ## Required Step number to go to if the condition 
is true

Usage:

Menu "Save As"

Button "Save"

Pause 0.5

Jump button "Replace" not_exists Step 1

Button "Replace"

Message

Display a dialog box.

Keyword Usage Description

Message Required Command

"Message Text" Required Text to display in a dialog box

Cancel Optional Show a Cancel button

Continue ## Optional Hide dialog and continue after ## 
seconds

Usage:

Message "Preparing to run sequence" Continue 10

Message "Shall I erase your floppy disk?" Cancel
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Mounty

Mount a file server. To mount the volume using AppleTalk, the Zone 
and Server parameters must be specified.  To mount the volume using 
TCP/IP, the Server_Addr parameter must be supplied.

Keyword Usage Description

Mounty Required Command

As_Guest Optional Mount using the guest account

Ask_Password Optional Ask for the password

Ask_User Optional Ask for the user name

Zone "Zone Name" Required
(AT)

The AppleTalk zone the server is 
in

Server "Server 
Name"

Required
(AT)

The network name of the server

Volume "Volume 
Name"

Required The volume of the server to 
mount

User "User Name" Optional The account name to connect to 
the server

Password "password" Optional What password to use

Volume_Password Optional Password for volume access

Server_TCP_
Address

Required
(IP)

TCP/IP Address for server

Usage:

Mounty Ask_User Zone "R&D" Server "PlantsServer" Volume "MPW 
Tools" 

PowerBook

A collection of actions for PowerBook users.

Keyword Usage Description

PowerBook Required Command

Sleep OnlyOne Put PowerBook to sleep

Shutdown OnlyOne Shutdown PowerBook

Show_Cursor OnlyOne Show location of the cursor

Spindown OnlyOne Spin harddisk off

Toggle_
Backlighting

OnlyOne Toggle Backlighting setting

Battery OnlyOne Show Battery

Backlighting_On OnlyOne Turn backlighting on

Backlighting_Off OnlyOne Turn backlighting off

Toggle_dimming OnlyOne Toggle dimming

Dim OnlyOne Dim the screen

Undim OnlyOne Stop dimming the screen

Disable_rest OnlyOne Disable resting

Enable_rest OnlyOne Enable Resting

Usage:

PowerBook Sleep

PowerBook Toggle_Backlighting

PowerBook Show_Cursor
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PopUp

Make a selection from a popup menu.

Keyword Usage Description

Popup Required Command

"Menu Item Title" OnlyOne Text of menu item

#MenuItem 
Position

OnlyOne Index of menu item

Exactly Optional Text must match exactly

MouseLoc Required Where to click to make menu appear

Usage:

Popup "Internal" (338,42 Top_Left)

Popup "QuicKeys" (100,100 Screen)

Repeat Begin

Start repeating a series of steps (a Repeat End statement is required).

Keyword Usage Description

Repeat Begin Required Command

#Count Required The number of times to repeat

Ask_User Optional Prompt the user for number of times 
to repeat

Usage:

Repeat Begin ask user
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Repeat End

Stop repeating a series of steps.

Keyword Usage Description

Repeat End Required Command

ScrapEase

Move clippings to and from QuicKeys clipboards.

Keyword Usage Description

ScrapEase Required Command

Copy OnlyOne Store selection into QuicKeys 
clipboard

Paste OnlyOne Paste from QuicKeys clipboard

Type OnlyOne Type from the QuicKeys clipboard

"Name of Clipping" Optional Name of clipping to paste / type

Ask_User Optional Ask the user for which clipping to 
paste / type

Usage:

ScrapEase Copy

ScrapEase Type "Sample Paragraph One"

ScrapEase Paste Ask_User
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ScreenEase

Change monitor settings.

Keyword Usage Description

ScreenEase Required Command

MonitorSpec Optional Supply to change only some 
monitors

B_W OnlyOne Change to Black & White

Grays OnlyOne Change to grayscale settings

Color OnlyOne Change color settings

Depth OnlyOne Change screen depth

MonitorDepth
Spec

Required New settings value

Permanent Optional Will changes last over restart

Usage:

ScreenEase B_W

ScreenEase Color

ScreenEase Monitor #3 Depth Increase Permanent

Sound

Play a sound.

Keyword Usage Description

Sound Required Command 

"Name of sound" Required Name of sound to play

Usage

Sound "Wild Eep"
Sound "Droplet"
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SpeakEase

Speak text.

Keyword Usage Description

SpeakEase Required Command 

Speak_Clipboard OnlyOne Speak the contents of the 
clipboard

"Text to speak" OnlyOne What text to speak

Voice "Voice Name" Optional What voice to use to speak

Usage

SpeakEase "The download has finished"

SpeakEase Speak_Clipboard Voice "Zarvox"

SpeakerChanger

Change computer volume.

Keyword Usage Description

SpeakerChanger Required Command 

Up OnlyOne Increase volume

Down OnlyOne Decrease volume

Volume #n OnlyOne Set volume to range (0 thru 7)

Beep Optional Play a sound after volume is 
changed

Usage

SpeakerChanger Up Beep

SpeakerChanger Down

SpeakerChanger Volume 0

SpeakerChanger Volume 7
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MacOS

Collection of controls for the system.

Keyword Usage Description

MacOS Required Command 

Show_Balloons OnlyOne Show balloon help

Hide_Balloons OnlyOne Hide balloon help

Toggle_Balloons OnlyOne Toggle balloon help

Next_Application OnlyOne Go to next application

Last_Application OnlyOne Go to previous application

Start_FileSharing OnlyOne Turn on file sharing

Stop_FileSharing OnlyOne Turn off file sharing

Usage

MacOS Start_FileSharing

MacOS Next_Application

Wait

Wait for a condition to be true.

Keyword Usage Description

Wait Required Command

SystemConditionSpec OnlyOne What system 
condition to wait for

Usage

Wait Application "Finder"

Wait Application "Word" running

Wait Window name_is "Untitled_1"

Wait Cursor is_not watch
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ApplicationConditionSpec

Check to see if an application is running.

Keyword Usage Description

Application Required Command

"Application Title" Required Title of Application

running OnlyOne true is application is running

not_running OnlyOne true if application is not running

ButtonSpec

Define a specific button to click. 

Keyword Usage Description

Button Required Start of structure

"Button Title" Optional Title of Button

#control  number Required Which control (in control list) to 
check

ButtonTest Optional Control when to click
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ButtonTest

Only click or select a button based on its current state.

Keyword Usage Description

If_Off OnlyOne Only if control is currently off 
(unchecked)

If_On OnlyOne Only if control is currently on 
(checked)

ButtonConditionSpec

Check to see if a button exists, is enabled, etc.

Keyword Usage Description

Button Required Command

"Button Title" Required Title of Button

exact Optional Match title exactly

not_exists OnlyOne true if button does not exist

enabled OnlyOne true if button is enabled

not_enabled OnlyOne true if button is not enabled

selected OnlyOne true if button is selected

not_selected OnlyOne true if button is not selected
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ClipboardConditionSpec

Check to see if the clipboard exists, contains text, etc.

Keyword Usage Description

Clipboard Required Command

empty OnlyOne true if clipboard is empty

not_empty OnlyOne true if clipboard is not empty

text OnlyOne true if clipboard contains text

not_text OnlyOne true if clipboard does not contain 
text

type OnlyOne true if clipboards type matches 
Compare String

not_type OnlyOne true if clipboard type does not 
match Compare String

equals OnlyOne true if clipboard value equals 
Compare String

not_equals OnlyOne true if clipboard value does not 
equal Compare String

contains OnlyOne true if clipboard value contains 
Compare String

not_contains OnlyOne true if clipboard value does not 
contain Compare String

greater_than OnlyOne true if clipboard value is greater 
than Compare String

less_than OnlyOne true if clipboard value is less than 
Compare String

greater_than_
equal

OnlyOne true if clipboard value greater than 
or equal to Compare String

less_than_equal OnlyOne true if clipboard value less than or 
equal to Compare String

"CompareString" Optional Text for comparison

Numeric Optional Number for comparison

ClipboardConditionSpec



191• • • •

CursorSpec

Definition of a cursor.

Keyword Usage Description

Ball OnlyOne A beachball cursor is being shown

Watch OnlyOne A watch cursor is being shown

Other "Hex Cursor" OnlyOne An alternate cursor is being 
shown; defined in hex values

CursorconditionSpec

Check to see if a button is enabled, etc.

Keyword Usage Description

Cursor Required Command

is_not OnlyOne true if cursor specified is not visible

changes OnlyOne true if cursor specified changes

CursorSpec Optional Definition of the cursor to check

Ignore_outline Optional Look at content of the cursor, not 
just its shape

Check_Cursor Optional Look at the shape and content

DateTimeConditionSpec

Check to see if a button exists, is enabled, etc. The ”Until” keyword is 
used for Wait Shortcuts and the “If_After” keyword is used for Jump and 
Decision Shortcuts.

Keyword Usage Description

Until HH:MM OnlyOne true if after hour and minute 
specified

Until HH:MM:SS OnlyOne true if after hour, minute and 
seconds specified

Until MM/DD/YY Optional true if after date specified

If_After HH:MM OnlyOne true if after hour and minute 
specified

If_After HH:MM:SS OnlyOne true if after hour, minute and 
seconds specified

If_After MM/DD/YY Optional true if after date specified

AM Optional Time specified is morning

PM Optional Time specified is afternoon
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EdgeDefinition

Define the point of origin for coordinates.

Keyword Usage Description

Mouse OnlyOne Relative to the current mouse 
position

Screen OnlyOne Relative to the complete screen

Top_Left OnlyOne Relative to the top left corner of the 
front window

Top_Right OnlyOne Relative to the top right corner of 
the front window

Bottom_Left OnlyOne Relative to the bottom left corner 
of the front window

Bottom_Right OnlyOne Relative to the bottom right corner 
of the front window

EventConditionSpec

Return true if this event has occurred.

Keyword Usage Description

Click OnlyOne true if a click has occurred

return OnlyOne true if return has been pressed

enter OnlyOne true if enter has been pressed

space OnlyOne true if space has been pressed

escape OnlyOne true if escape has been pressed

tab OnlyOne true if tab has been pressed

any_key OnlyOne true if any key has been pressed



193• • • •

MenuConditionSpec

Check a menu item.

Keyword Usage Description

Menu Required Command

"Menu Title" Required Title of the menu

Item Required Command

"Menu Item" Required Title of menu item

exact_menu Optional The menu title must match exactly

exact_item Optional The menu item must match exactly

checked OnlyOne true if menu item is checked

not_checked OnlyOne true if menu item is not checked

enabled OnlyOne true if menu item is enabled

not_enabled OnlyOne true if menu item is not enabled

item_exists OnlyOne true if menu item exists

item_not_exists OnlyOne true if menu item does not exist

ModKey

Defines a series of modifiers to depress for various actions.  

NOTE: If multiple keywords are used they must be delimited with a 
dash.

Keyword Usage Description

CMD Optional Depress Command Key

OPT Optional Depress Option Key

SHIFT Optional Depress Shift Key

CTRL Optional Depress Control Key

Examples:

CMD-SHIFT ; Depress Both the Command and Shift Keys
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MonitorSpec

Specify a specific monitor.

Keyword Usage Description

Monitor #n OnlyOne Which monitor to change

Monitor_Mouse OnlyOne Monitor defined by mouse location

MonitorDepthSpec

Settings for a monitor.

Keyword Usage Description

1 OnlyOne Change to B&W

4 OnlyOne Change to 4 colors

16 OnlyOne Change to 16 colors

256 OnlyOne Change to 256 colors

Thousands OnlyOne Change to Thousands

Millions OnlyOne Change to Millions

Decrease OnlyOne Decrease Setting

Increase OnlyOne Increase Setting

Minimum OnlyOne Set to minimum supported setting

Maximum OnlyOne Set to maximum supported setting
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MouseLoc

Define a location on the screen for mouse clicking.

Keyword Usage Description

( Required Start of structure

X Offset Required Pixels from left edge

Y Offset Required Pixels from top edge

EdgeDefinition Required Define where coordinates are 
relative to

) Required End of structure

SystemCondition

Only click or select a button based on its current state.

Keyword Usage Description

ApplicationCondition
Spec

OnlyOne Check to see if an application is 
running

ButtonCondition
Spec

OnlyOne Check a button

Clipboard
ConditionSpec

OnlyOne Check the clipboard

MenuCondition
Spec

OnlyOne Check a menu item

DateTime
ConditionSpec

OnlyOne Check the time

Window
ConditionSpec

OnlyOne Check a window

Beep OnlyOne Check for a beep (Wait only)

Event
ConditionSpec

OnlyOne Check for an event (Wait only)

CursorConditionSpec OnlyOne Check the cursor
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WindowConditionSpec

Check the settings of a window.

Keyword Usage Description

Window Required Command

any_window Optional Check for any open window, rather 
than just first

name_is OnlyOne name of window matches 
CmpTitle

name_is_not OnlyOne name of window does not match 
CmpTitle

name_contains OnlyOne name of window contains 
CmpTitle

name_not_
contains

OnlyOne name of window does not contain 
CmpTitle

"CmpTitle" Optional Title used for previous settings

dialog OnlyOne front window is a dialog box

not_dialog OnlyOne front window is not a dialog box

system OnlyOne front window is a system window 
(driver, desk acc.)

not_system OnlyOne front window is not a system 
window

document OnlyOne front window is a document

not_document OnlyOne front window is not a document

not_exists OnlyOne true if window does not exist (Wait 
only)

changes_order OnlyOne true if windows change order (Wait 
only)

WindowSpec

Define a specific window to click in.  NOTE: The Window Title, if 
specified, overrides the window position setting.

Keyword Usage Description

Window Required Start of structure

"Window Title" OnlyOne Title of window

#window number OnlyOne Which window (from front window) 
to click
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GLOSSARY

application toolbar—The bar of graphical buttons available in 
the interface of some applications that enables you to 
complete basic functions, such as printing, with a mouse click.

clip—Items stored in the QuicKeys clipboard for the Scrap 
Ease plug-in.

clipboard—The system’s holding area for an item selected 
using the cut or copy feature.

contextual menu—The menu that appears when you Control-
click your mouse.

dialog—Part of the software interface that contains command 
buttons and various kinds of options through which you can 
carry out a particular command or task.

filters—QuicKeys filters enable you to choose which Short-
cuts you view within the QuicKeys Editor and the QuickRef-
erence Card.

plug-in—QuicKeys components, such as File Launch, that 
add functionality to QuicKeys.

properties—Attributes or characteristics of a Shortcut. 

QuicKeys toolbar—The toolbar that is part of the QuicKeys 
Editor that enables you to cut, copy, and print with a mouse 
click.

QuicKeys Editor—The main component of the QuicKeys 
interface where you create and edit Shortcuts and toolbars. 

QuickReference Card—The dialog that displays all of your 
Shortcuts and keystrokes.

QuicKeys menu—The menu that appears when you click the 
QuicKeys icon in the menu bar. The QuicKeys menu can also 
be available in the Apple menu if you choose to place it there. 

recording—When you start recording, QuicKeys watches 
your actions so it can play them back when you trigger the 
Shortcut.

scope—The range of operation for a Shortcut. For example, 
you can create Shortcuts that only work when Microsoft Word 
is active or Shortcuts that work in any active window on your 
computer.

Sets—The grouping of Shortcuts that only work in a specific 
context. For example, you can create Shortcuts that only work 
when Microsoft Word is active.

Setup Assistant—The Mac supports assistant windows that 
help you with certain application-specific tasks. For example, 
the QuicKeys Setup Assistant helps set up certain Shortcuts.

Sequence—A series of Shortcuts that execute sequentially.

Shortcut—The QuicKeys equivalent of a single-step task.

toggle—Turns a particular mode on or off. For example, you 
can toggle keystrokes on or off.

toolbar—The graphical palettes you can use to trigger Short-
cuts.

timed triggers—Triggers that start Shortcuts at a specific date 
and/or time.
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trigger—Keystrokes and menu selections that signal QuicK-
eys to start a Shortcut. 

URL—Uniform Resource Locator. A reference to a resource on 
the Internet. For example, CE Software’s URL is 
http://www.cesoft.com/
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Now that you know how to save time on your 
Mac...

•  •  •  •  •  •
how about filling the PC world in on your secret?

So you’re flipping through your QuicKeys 4.0 User’s Guide thinking about all the time QuicKeys 
can save you on your Mac. Then you start thinking how great it would be if something like this 
was available for your PC. Well guess what? IT IS!

You already know that QuicKeys 4.0 for Macintosh is 
loaded with new features and benefits. So is QuicKeys 
for Windows. 

QuicKeys for Windows includes all your 
favorite automation features:

• Launch programs with the press of a key.
• Access commonly-used documents, files and 

folders quickly and easily.
• One-key access to the menus you use most, in all 

your programs.
• Let QuicKeys built-in task recorder create 

Actions and Sequences easily.
• Customize your own toolbars—the way you 

want them.

Plus, cool new capabilities you’ll love:
• Launch any Web site with one click.
• Zip and E-mail any file in a single step.
• Automate opening and closing the QuicKeys 

Editor and save time creating new Actions.
• Control windows, pull-down menus, navigate 

directories—all with hot keys instead of the 
mouse.

• Leave the control panel behind. Switch monitor
settings and your PC’s volume quickly and 
easily.

  

Order QuicKeys for 
Windows and save!

Need an automation boost for your PC? Know any 
Windows users who could use a little automation? Shar
your secret with the rest of the world. Get QuicKeys for 
Windows for only $29.95.

Special offer for QuicKeys for Mac users:
Call 1-800-579-1152 and mention program K2293 to 
order at only $29.95 per copy.
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	5. Choose one of the newly imported icons from the icon list and click Select.


	Using Default Icons


	Deleting Toolbar Buttons
	From the Contextual Menus
	1. Control+click the QuicKeys toolbar button you want to remove.
	2. Select Delete Button from the contextual menu that appears.
	3. Click OK in the alert window that appears. The button is immediately removed from the toolbar.

	From the QuicKeys Editor
	1. Open the Toolbars tab in the QuicKeys Editor.
	2. In the Toolbars pane, click the toolbar you want to display.
	3. When the toolbar appears on your desktop, drag a button off the toolbar to delete it.


	Chapter�7

	Text Tools
	Type Text
	Setting Up Type Text Shortcuts
	Using the Setup Assistant
	Figure 99:� The Type Text Setup Assistant.

	Using the Shortcut Properties Dialog
	To create a Type Text Shortcut:
	1. Select Create > Text Tools > Type Text.
	2. Type the text you want to use when you trigger this Shortcut.
	Figure 100:� The Type Text Shortcut Properties dialog.

	3. If you want to choose a keystroke to trigger this Shortcut, click in the Keystroke box and pre...
	4. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	5. Close the QuicKeys Editor and open your word processing or E-mail application. Position your c...


	Using the Contextual Menu
	To create a Type Text Shortcut:
	1. Press the Control key at the same time you click a block of selected text in a word processing...
	2. Select Create QuicKey from the contextual menu that appears. A Shortcut dialog appears.
	3. Choose Type Text from the Type pop-up menu.
	4. Type a name for the Shortcut.
	5. Position your cursor in the Keystroke box and press the key combination you want to use to tri...
	6. Click OK when you are finished. Your new Shortcut is immediately available to you using the tr...




	Typing the Date and Time
	Setting Up Type Date/Time Shortcuts
	Using the Setup Assistant
	Figure 101:� The Type Date/Time Setup Assistant.

	Using the Shortcut Properties Dialog
	To create a Date/Time Shortcut:
	1. Select Create > Text Tools > Type Date/Time.
	2. Select the date and time format you want to use when you trigger this Shortcut.
	Figure 102:� The Type Date & Time Shortcut Properties dialog.

	3. If you want to choose a keystroke to trigger this Shortcut, click in the Keystroke box and pre...
	4. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	5. Close the QuicKeys Editor and open your word processing or E-mail program. Position your curso...




	Advanced Text Tools
	Setting Up Advanced Text Tools Shortcuts
	Using the Setup Assistant
	Figure 103:� The Advanced Text Tools Setup Assistant.

	Using the Shortcut Properties Dialog
	To create an Advanced Text Tools Shortcut:
	1. Select Create > Text Tools > Advanced Text Tools.
	2. Select an option in the Action pop-up menu and complete any other options that appear as a res...
	Figure 104:� The Shortcut Properties dialog for the Quote plug-in.

	3. Type a name for the new Shortcut in the Name field.
	4. If you want to choose a keystroke to trigger this Shortcut, click in the Keystroke box and pre...
	5. Click OK. Your new Shortcut immediately appears in the Keysets tab of the QuicKeys Editor.
	6. Close the Quickeys Editor and open a word processing document that already contains text.
	7. Select a block of text and press the keystroke you assigned to this Shortcut. The block of tex...



	Advanced Text Tools Options
	Prompt for Action
	Reformat
	Figure 105:� Text that has not been reformatted.
	Figure 106:� Text that has been reformatted.

	Quote
	Character
	Line Length
	Figure 107:� This is an illustration of what quoted text looks like. In this example, the greater...

	Remove Quotes
	Uppercase
	Lowercase
	Title Case
	Cipher Text
	Decipher Text


	Chapter�8

	File Tools
	Batch Processor
	Setting Up Batch Processor Shortcuts
	To set up a Batch Processor Shortcut:
	1. In the Finder, create a source folder containing all the files that are part of the batch proc...
	2. Create a destination folder anywhere on your hard drive where the files will be stored after t...
	3. Open one of the files you want to process and, using the file as a “test subject,” create a Se...
	4. Open your new Sequence and insert a Pause for your first step. See page�154 for more informati...
	5. Click OK to close the Sequence Editor.
	6. In the QuicKeys Editor, select the Keysets tab and choose Create > File Tools > Batch Processor.
	7. In the Batch Processor Shortcut Properties dialog, click the Select Folder button.
	Figure 108:� The Batch Processor Shortcut Properties dialog.

	8. Navigate to the source folder you created in Step�1 and click Open.
	9. Check the Backup Source Folder check box in the Shortcut Properties dialog to make a copy of y...
	10. Click the Select Application button and locate the application you want to use to process the...
	11. Click the Select Sequence button.
	12. Choose the Sequence you created in Step�3. Click the Universal radio button if your Sequence ...
	Figure 109:� Select a Sequence from the Sequence list.

	13. Click OK when you are finished selecting a Sequence. The Shortcut Properties dialog again app...
	14. Type a name for this Shortcut in the Name box.
	15. Specify a trigger for this Shortcut and click OK.


	Triggering Batch Processor Shortcuts
	Batch Processor Guidelines
	The Batch Processor Results Window
	Figure 110:� The Batch Processor Results window.



	File Handler
	Setting Up File Handler Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > File Tools > File Handler.
	3. Select an option from the Action pop-up menu. For example, choose Lock Selected Files.
	Figure 111:� The File Handler Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke to the Shortcut.
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Select a file on your hard drive. Press the keystroke or other trigger you assigned to this Sh...
	Using Drag-and-Drop
	Figure 112:� The File Handler toolbar button supports dynamic menu selections.


	File Handler Options
	Lock/Unlock Selected Files
	Rename Selected Files
	Prefix Text
	Figure 113:� Rename selected files with user-specified prefix text.

	Prefix Variable
	Figure 114:� Rename selected files with one of four available variable formats.

	Text & Variable
	Figure 115:� Rename selected files with Text and one of four available variable formats.

	Variable & Text
	Figure 116:� Rename selected files with Text and one of four available variable formats.

	Append Text
	Figure 117:� Add user-specified text to the end of selected filenames.

	Append Variable
	Figure 118:� Add one of the four available variable formats to the end of selected filenames.


	Move Selected Files
	Figure 119:� Choose where you want to move your selected files.

	Set File Type/Creator
	Figure 120:� Choose the file type or creator you want to use for your selected files.



	File Launch
	Setting Up File Launch Shortcuts
	Using the Setup Assistant
	Figure 121:� The File Launch Setup Assistant.

	Using the Shortcut Properties Dialog
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > File Tools > File Launch. A standard Open dialog appears.
	3. Navigate to the file you want to launch with this Shortcut and click Open. The Shortcut Proper...
	Figure 122:� The File Launch Shortcut Properties dialog.

	4. Click the Include in QuicKeys menu check box.
	5. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	6. Close the QuicKeys Editor.
	7. Select this Shortcut from your QuicKeys menu. The file you specified immediately opens.

	Using the Contextual Menu
	To create a File Launch Shortcut:
	1. Press the Control key at the same time you click a file.
	2. Select Create QuicKey from the contextual menu that appears. A Shortcut Properties dialog appe...
	Figure 123:� QuicKeys appears in some contextual menus.

	3. Choose File Launch from the Type pop-up menu.
	4. Position your cursor in the Keystroke box and press the key combination you want to use to tri...
	5. Click OK when you are finished. Your new File Launch Shortcut is immediately available to you ...


	Using Drag-and-Drop


	File Recall
	Setting Up File Recall Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > File Tools > File Recall. The Shortcut Properties dialog appears.
	3. Select an option from the Show Files Modified area of the dialog. For example, select In last ...
	4. Type a name for the Shortcut in the Name box.
	Figure 124:� The File Recall Shortcut Properties dialog.

	5. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke you assigned to this Shortcut. The status bar shown in Figure�125 appears....
	Figure 125:� The status bar shown here appears when you trigger File Recall Shortcuts.

	9. Select which document you want to open from the list QuicKeys prepares for you and click OK.
	Figure 126:� Select a document from the File Recall list.


	File Recall Options
	Omitting files from your search
	Other


	Folders
	Setting Up Folders Shortcuts
	Using the Setup Assistant
	Figure 127:� The Folders Setup Assistant.

	Using the Shortcut Properties Dialog
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > File Tools > Folders. The Shortcut Properties dialog appears.
	3. Select a folder location option. For example, select Open Folder and click the Select Folder b...
	Figure 128:� The Folders Shortcut Properties dialog.

	4. Select the Open Folder in Open/Save Dialog check box to open the selected folder only when an ...
	5. In the Name box, type a name for the Shortcut.
	6. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	7. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	8. Close the QuicKeys Editor.
	9. Launch an application and select Open from the File menu. Press the keystroke you assigned to ...
	10. Select the file you are looking for and click OK.

	Using the Contextual Menu
	To create a Folders Shortcut with the contextual menu:
	1. Press the Control key at the same time you click a folder.
	2. Select Create QuicKey from the contextual menu that appears. An abbreviated Shortcut Propertie...
	Figure 129:� This dialog appears after you select a QuicKeys option from a contextual menu.

	3. Choose Folders from the Type pop-up menu.
	4. Type a name for the Shortcut.
	5. Position your cursor in the Keystroke box and press the key combination you want to use to tri...
	6. Click OK when you are finished. Your new Shortcut is immediately available to you using the tr...


	Using Drag-and-Drop
	Figure 130:� The Folders toolbar button supports dynamic menu selections.


	Folders Options
	Open Folder
	Select Folder
	Open Folder in Finder
	Do Not Switch to Finder
	Open folder in Open/Save dialog
	Restore Folder Location in Open/Save Dialog


	Project Saver
	Setting Up Project Saver Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > File Tools > Project Saver. The Shortcut Properties dialog appears.
	3. Select an option from the Action pop-up list. For example, select Create Project.
	Figure 131:� The Shortcut Properties dialog for the Project Saver plug-in.

	4. In the Name box, type a name for the Shortcut.
	5. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Trigger the Project Saver Shortcut you created. The dialog shown in Figure�132 appears.
	Figure 132:� Type the name of your project at the prompt.

	9. Type a name for the project and click OK. All the documents and applications that were open at...

	Project Saver Options
	Create Project
	Launch Project
	Create Startup Project & Shutdown
	Close All Applications

	Project Saver Tips
	Editing Project Saver Shortcuts
	Deleting Projects
	To delete individual projects within the Project Saver Shortcut:
	1. Trigger the Launch Project Shortcut.
	2. In the project list that appears, select the project you want to delete.
	Figure 133:� The Project Saver project list.

	3. Click the Delete button.



	Chapter�9

	System Tools
	Alias Keystroke
	Setting Up Alias Keystroke Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Alias Keystroke.
	Figure 134:� The Alias Keystroke Shortcut Properties dialog.

	3. Position your cursor in the Key to type box and press the keystroke you want to replace. For e...
	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke to the Shortcut. For example, if you want to use F5 instead of Command+I, t...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke or other trigger you assigned to this Shortcut.


	App Switcher
	Setting Up App Switcher Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > App Switcher. The Shortcut Properties dialog appears.
	Figure 135:� The App Switcher Shortcut Properties dialog.

	3. Select an option from the Action menu and make selections for any additional options that appear.
	4. Type a name for the Shortcut in the Name box.
	5. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Launch a few applications. Press the keystroke or other trigger you assigned to this Shortcut....

	App Switcher Options
	Switch Back
	Select Application from List
	Previous Application
	Figure 136:� In this example, FrameMaker is the “next” application and Photoshop is the “previous...

	Next Application
	Application
	Hide Other Applications
	Don’t Hide Other Applications


	Button
	Setting Up Button Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Button.
	Figure 137:� The Button Shortcut Properties dialog.

	3. Choose under what condition the button will be clicked. For example, select Always click butto...
	4. Type the name of the button you want to select in the Name box. The name you type must match t...
	5. Assign a keystroke to the Shortcut.
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Trigger this Shortcut whenever the button you specified appears in the frontmost dialog.

	Button Options
	Always click button
	Only click if button is on
	Only click if button is off


	Click
	Setting Up Click Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Click. The Editor disappears briefly while you use your mouse t...
	3. The Shortcut Properties dialog appears pre-filled with the coordinates and options you selecte...
	Figure 138:� The Click Shortcut Properties dialog.

	4. Assign a keystroke to the Shortcut.
	5. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	6. Close the QuicKeys Editor.
	7. Trigger this Shortcut whenever you want to perform a click.

	Click Options
	Click
	Figure 139:� The Click Location dialog enables you to specify screen coordinates for your Click S...

	Screen
	Document
	Mouse Position
	Window
	Figure 140:� In this example, the Click Shortcut first looks for a window named “Navigator,” then...

	Any
	Name
	Position
	Control area
	Figure 141:� The Control Area dialog.

	None
	Name
	Position


	FKEYs
	Setting Up FKEYs Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > FKEYs. The Shortcut Properties dialog appears.
	Figure 142:� The FKEYs Shortcut Properties dialog.

	3. Select an option from the FKEY choices menu.
	4. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	5. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	6. Close the QuicKeys Editor.
	7. Press the keystroke or other trigger you assigned to this Shortcut. The FKEY you selected for ...


	Mac OS Specials
	Setting Up Mac OS Specials Shortcuts
	Using the Setup Assistant
	Figure 143:� The Mac OS Specials Setup Assistant.

	Setting Up Mac OS Specials Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Mac OS Specials. The Shortcut Properties dialog appears.
	3. Select an option from the Action menu.
	Figure 144:� The Mac OS Specials Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke or other trigger you assigned to this Shortcut. The action you selected fo...


	Mac OS Specials Options
	Balloon Help
	Next Application
	Previous Application
	Start/Stop File Sharing
	Start/Stop Program Linking


	Menu
	Setting Up Menu Shortcuts
	Using the Setup Assistant
	Figure 145:� The Menu Setup Assistant.

	Setting Up Menu Shortcuts
	1. Launch the application you want to use for the Menu Shortcut.
	2. Open the QuicKeys Editor and select the Keysets tab.
	3. Select Create > System Tools > Menu. Your cursor turns into a menu icon as a little instructio...
	Figure 146:� When this window appears, use your mouse to select a menu item.

	4. Using your mouse, select the menu item you want to use for this Shortcut. You can select both ...
	Figure 147:� The Menu Shortcut Properties dialog.

	5. The fields in the Shortcut Properties dialog are pre-filled with information taken by QuicKeys...
	6. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	7. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	8. Close the QuicKeys Editor.
	9. Press the keystroke or other trigger you assigned to this Shortcut. QuicKeys instantly selects...


	Menu Options
	Select from Menu
	Search
	Use Modifiers
	Don’t display message...


	Mousies
	Setting Up Mousies Shortcuts
	Using the Setup Assistant
	Figure 148:� The Mousies Setup Assistant.

	Using the Shortcut Properties Dialog
	To create a Mousies Shortcut:
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Mousies.
	3. Select an option from the Action pop-up menu.
	Figure 149:� Select a Mousies action from the Action pop-up menu.

	4. Choose a keystroke or some other type of trigger for this Shortcut.
	5. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	6. Close the QuicKeys Editor and press the keystroke or other trigger you assigned to this Shortc...



	Mousies Options
	Close window
	Zoom window
	Collapse window
	Home
	End
	Line up
	Line down
	Page up
	Page down
	Column left
	Column right
	Page left
	Page right


	Powerbook Specials
	Setting Up Powerbook Specials Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Powerbook Specials. The Shortcut Properties dialog appears.
	3. Select an option from the Action menu.
	Figure 150:� Choose the task you want to complete from the Action pop- up menu.

	4. Type a name for the Shortcut in the Name box.
	5. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke or other trigger you assigned to this Shortcut. The action you selected fo...

	PowerBook Specials Options
	Spin Down Hard Drive
	Show Cursor Location
	Shut Down
	Sleep
	Battery Desk Accessory
	Toggle Backlighting
	Backlighting On
	Backlighting Off
	Toggle Dimming
	Dim Screen
	Undim Screen
	Disable Processor Rest
	Enable Process Rest


	Scrap Ease
	Figure 151:� To use the QuicKeys Scrap Ease Shortcut, you first add Scrap Ease items to your clip...
	Figure 152:� When you have items in your Scrap Ease clipboard, you can then paste them into your ...

	QuicKeys Scrap Ease vs. the System Clipboard
	Setting Up Scrap Ease Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Scrap Ease. The Shortcut Properties dialog appears.
	3. Select an option from the Action menu.
	Figure 153:� The Scrap Ease Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke or other trigger you assigned to this Shortcut. The action you selected fo...

	Scrap Ease Options
	Copy
	Paste
	Type
	Edit Clip List
	Choose clip when playing Shortcut
	Use the clip

	Screen Ease
	Setting Up Screen Ease Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Screen Ease. The Shortcut Properties dialog appears.
	3. Select an option from the Screen area of the dialog.
	Figure 154:� The Screen Ease Shortcut Properties dialog.

	4. Select an option from the Settings area of the dialog.
	5. Type a name for the Shortcut in the Name box.
	6. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	7. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	8. Close the QuicKeys Editor.
	9. Press the keystroke or other trigger you assigned to this Shortcut. The screen options you sel...

	Screen Ease Options
	Screen options
	Settings


	Specials
	Setting Up Specials Shortcuts
	Using the Setup Assistant
	Figure 155:� The Specials Setup Assistant.

	Setting Up the Specials Shortcut
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > Specials. The Shortcut Properties dialog appears.
	3. Select an option from the Action pop-up menu.
	Figure 156:� Select an action for the Specials plug-in to complete.

	4. Type a name for the Shortcut in the Name box.
	5. Position your cursor in the Keystroke box and press the keys you want to use to trigger this S...
	6. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	7. Close the QuicKeys Editor.
	8. Press the keystroke or other trigger you assigned to this Shortcut. The action you selected fo...


	Specials Options
	Shut Down
	Restart
	Launch
	Select Rear Window
	Select Second Window
	QuickQuotes
	Double QuickQuotes
	Open QuicKeys Editor
	Open QuickReference Card
	Toggle QuicKeys On/Off
	Start/Stop Sequence
	Start/Stop Real Time
	Pause/Unpause Sequence


	View Switcher
	Setting UP View Switcher Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > System Tools > View Switcher.
	3. Choose Icons in the Style pop-up menu.
	Figure 157:� The View Switcher Shortcut Properties dialog.

	4. Select Large in the Icon Size pop-up menu.
	5. Select Name in the Arrangement pop-up menu.
	6. Type a name for the new shortcut in the Name box.
	7. Assign a keystroke for the Shortcut.
	8. Click OK in the View Switcher dialog.
	9. Click the close box in the QuicKeys Editor to quit QuicKeys.
	10. Open a window in the Finder and trigger the Shortcut you just created. The window adjusts bas...

	View Switcher Options
	Style
	Icon Size
	Arrangement



	Chapter�10

	MultiMedia Tools
	Audio CD Player
	Setting Up Audio CD Player Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > Multimedia Tools > Audio CD Player.
	3. Choose an option in the Action pop-up menu. For example, choose Play CD.
	Figure 158:� The Audio CD Player Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke or another type of trigger to the Shortcut.
	6. Click OK to close the Shortcut Properties dialog.
	7. Click the close box in the QuicKeys Editor to quit QuicKeys.
	8. Insert an audio CD in your CD-ROM drive and trigger the action you selected. Depending on the ...


	Sound
	Setting Up Sound Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > Multimedia Tools > Sound.
	Figure 159:� The Sound Shortcut Properties dialog.

	3. Choose an option in the Play Sound pop-up menu. For example, choose Droplet. You can hear a sa...
	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke or another type of trigger to the Shortcut.
	6. Click OK to close the Shortcut Properties dialog.
	7. Click the close box to close the QuicKeys Editor.
	8. Trigger the Sound Shortcut to hear the sound you selected.


	Speak Ease
	Setting Up Speak Ease Shortcuts
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > Multimedia Tools > SpeakEase.
	3. Choose a voice from the Voice pop-up menu. For example, choose Zarvox.
	Figure 160:� The Speak Ease Shortcut Properties dialog.

	4. If you select Speak Clipboard, make sure the text you want the selected voice to speak is copi...
	5. Type a name for the Shortcut in the Name box.
	6. Assign a keystroke or another type of trigger to the Shortcut.
	7. Click OK to close the Shortcut Properties dialog.
	8. Click the close box to close the QuicKeys Editor.
	9. Trigger the Speak Ease Shortcut to make the selected voice speak the text you provided.


	SpeakerChanger
	Setting Up Speaker Changer Shortcuts
	Using the Setup Assistant
	Figure 161:� The SpeakerChanger Setup Assistant.

	Using the Shortcut Properties Dialog
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > Multimedia Tools > SpeakerChanger.
	3. Choose an option from the Set Volume options or from the Adjust Volume options. For example, c...
	Figure 162:� The SpeakerChanger Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke to the Shortcut.
	6. Click OK to close the Shortcut Properties dialog.
	7. Click the close box to close the QuicKeys Editor.
	8. Play an audio CD and trigger the SpeakerChanger Shortcut to increase or decrease the speaker v...


	SpeakerChanger Options
	Off
	10%-100%
	Louder/Softer
	Play sound when adjusting volume


	QT Movie
	1. Open the QuicKeys Editor and select the Keysets tab.
	2. Select Create > Multimedia Tools > QT Movie.
	3. Click the Select button to display a standard Open dialog. (The Select button becomes a Change...
	Figure 163:� The QT Movie Shortcut Properties dialog.

	4. Navigate to the multimedia file you want to trigger with QuicKeys and select Open.
	5. Type a name for the Shortcut in the Name box.
	6. Assign a keystroke or another type of trigger to the Shortcut.
	7. Click OK to close the Shortcut Properties dialog.
	8. Click the close box to close the QuicKeys Editor.
	9. Trigger the QT Movie Shortcut to launch your QuickTime movie.
	QT Movie Options
	Show QuickTime Controller
	Play QuickTime soundtrack if available


	Chapter�11

	Network Tools
	Choosy
	Setting Up Choosy Shortcuts
	Using the Setup Assistant
	Figure 164:� The Choosy Setup Assistant.

	Using the Shortcut Properties Dialog
	To create a Choosy Shortcut:
	1. Open the QuicKeys Editor.
	2. Select Create > Network Tools > Choosy.
	3. Check the Change printer to check box and select an available printer driver from the pop-up l...
	Figure 165:� The Choosy Shortcut Properties dialog.

	4. Click the Choose Printer button to display a list of AppleTalk zones on your network.
	5. Select the zone where your printer resides. A list of printers in the selected zone appears in...
	Figure 166:� Choose a zone and a printer.

	6. Select a printer and click OK. The zone and printer you selected appear in the Shortcut Proper...
	7. Check the Report Printer Selection check box so you are notified when Choosy has successfully ...
	8. Type a name for this Shortcut in the Name box.
	9. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	10. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	11. Close the QuicKeys Editor and select your Choosy trigger. Your default printer is instantly c...



	Choosy Options
	Background printing
	Choose Printer
	Zone name
	Printer name
	Report printer selection


	Mounty
	Setting Up Mounty Shortcuts
	1. Open the QuicKeys Editor.
	2. Select Create > Network Tools > Mounty.
	3. In the Shortcut Properties dialog, select the networking protocol you want to use. For example...
	Figure 167:� The Mounty Shortcut Properties dialog.

	4. Choose which volume you want to mount.
	5. Type the name of the volume in the Volume box.
	6. Select your connection preferences from the When connecting pop-up list.
	7. If applicable, type your name and password information in the Name, Password, and Volume Passw...
	8. Type a name for this Shortcut in the Name box.
	9. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	10. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	11. Close the QuicKeys Editor and press your Mounty trigger. The network volume you specified is ...

	Mounty Options
	Toggle Mount/Dismount
	Mount only
	Dismount only
	AppleTalk
	Choose Server
	Zone
	Server
	Volume
	Server IP
	Server Address
	Volume
	Connect as Guest
	Remember Name and Password
	Ask for Name and Password
	Ask for Password


	Network Switcher
	Setting Up Network Switcher Shortcuts
	1. Create whatever TCP/IP, OT/PPP, AppleTalk, or modem configurations you need to connect from yo...
	2. Open the QuicKeys Editor and select the Keysets tab.
	3. Select Create > Network Tools > Network Switcher.
	Figure 168:� The Network Switcher Shortcut Properties dialog.

	4. Select your networking method in the Settings pop-up menu.
	5. Select the appropriate networking configuration in the Configuration pop-up menu.
	6. Type a name for the Shortcut in the Name box.
	7. Assign a keystroke or another type of trigger to the Shortcut.
	8. Click OK in the Shortcut Properties dialog.
	9. Click the close box in the QuicKeys Editor to close QuicKeys.

	Network Switcher Examples
	Network Switcher Options
	Settings
	Configuration


	Chapter�12

	Internet Tools
	Instant E-mail
	Setting Up Instant E-mail Shortcuts
	1. Open the QuicKeys Editor.
	2. Select Create > Internet Tools > Instant E-mail.
	3. In the Shortcut Properties dialog, select the E-mail client you want to use. For example, sele...
	4. Select the task you want to complete from the Action pop-up menu.
	Figure 169:� The Instant E-mail Shortcut Properties dialog.

	5. Type a name for this Shortcut in the Name box.
	6. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	7. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	8. Close the QuicKeys Editor and press your Instant E-mail trigger. The action you specified is i...

	Instant E-mail Options
	E-mail Client
	Send Text
	Send Selection
	Send Finder Selection
	Send Recent Document
	Check Mail
	Send Mail
	Acknowledge Notification


	Web Launcher
	Setting Up Web Launcher Shortcuts
	1. Open the QuicKeys Editor and click the Keysets tab.
	2. Select Create > Internet Tools > Web Launcher.
	3. Select an action from the Action pop-up menu. If you select Open URL, you must type the URL.
	Figure 170:� The Web Launcher Shortcut Properties dialog.

	4. Type a name for the Shortcut in the Name box.
	5. Assign a keystroke to the Shortcut.
	6. Click OK to close the Shortcut Properties dialog.
	7. Click the close box in the QuicKeys Editor to quit QuicKeys.
	8. Trigger the Web Launcher Shortcut. The Web Launcher action you specified is performed immediat...

	Web Launcher Options
	Open URL
	Show dialog
	Open Text Selection as URL
	Open URL from Netscape
	Open URL from Explorer


	Chapter�13

	Scripting Tools
	InterAPplication Communication Tools
	Apple Events
	Setting Up Apple Events Shortcuts
	1. Select Create > Scripting Tools > Apple Events.
	2. Choose an application process from the Send Event to pop-up list. For example, select Finder. ...
	Figure 171:� The Apple Events Shortcut Properties dialog.

	3. Click the Select Event button to display the suite of events supported by the application you ...
	4. Select the event suite you want to use from the Suite pop-up list. The Suite pop-up menu conta...
	Figure 172:� Select an event suite in the Events window.

	5. Click the event you want to send to the designated application and click the Select Event butt...
	6. In the Shortcut Properties dialog, select a parameter and click Edit if there are required par...
	7. Select what type of information you want returned from the target application using the Return...
	Figure 173:� The Apple Events Shortcut Properties dialog displays the event parameters after you ...

	8. Type a name for this Shortcut in the Name box.
	9. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	10. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	11. Close the QuicKeys Editor and press your Apple Events trigger. The Event you specified is imm...

	Apple Events Options
	Send Event To
	Select Event
	Figure 174:� Select an event from the Events list.
	Tech Info
	Event Class
	Event ID
	Reply Type
	Application’s state
	Direct Parameter Type
	Other Parameters
	Figure 175:� The Technical Information window for a selected event.


	Parameters
	Figure 176:� When you select an event, a parameter field appears in the Apple Events Shortcut Pro...
	Editing Parameters
	Figure 177:� The Parameter Specifier window for the “Object” parameter type.

	The available Parameter Specifier windows may contain a combination of the following details.
	Number
	Name
	Description
	Keyword
	Type
	Required/Not Required
	Next
	Previous
	Get Parameter Value From

	Return Value
	Figure 178:� The Return Value options.
	Ignore
	Wait
	Type
	Display Full
	Clipboard
	Display Minimal



	AppleScript
	Setting Up AppleScript Shortcuts
	1. Select Create > Scripting Tools > AppleScript.
	2. Choose an option from the Select Script to Execute area of the Shortcut Properties dialog. For...
	3. Specify the file or type the text you want to execute.
	Figure 179:� The AppleScript Shortcut Properties dialog.

	4. Choose how you want to handle the results of the script. For example, you can ignore the resul...
	5. Type a name for this Shortcut in the Name box.
	6. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	7. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	8. Close the QuicKeys Editor and press your AppleScript trigger. The script you specified execute...

	AppleScript Options
	File
	Select File
	Text (no script entered yet)
	Modify Text
	Ignore
	Wait
	Type
	Display
	Clipboard
	Script Uses Clipboard


	DoScript
	Setting Up DoScript Shortcuts
	1. Open the QuicKeys Editor.
	2. Select Create > Scripting Tools > DoScript.
	3. Choose the target for your script by clicking the Send Script To button. For example, select F...
	4. Specify the file or type the text you want to execute.
	Figure 180:� The DoScript Shortcut Properties dialog.

	5. Choose how you want to handle the results of the script. For example, do you want to ignore th...
	6. Type a name for this Shortcut in the Name box.
	7. Position your cursor in the Keystroke box and press the key(s) you want to use to trigger this...
	8. Click OK. Your new Shortcut immediately appears in the Keysets tab.
	9. Close the QuicKeys Editor and press your DoScript trigger. The script you specified executes i...

	DoScript Options
	File
	Select File
	Text (no script entered yet)
	Modify Text
	Ignore
	Type
	Display
	Clipboard
	Script Uses Clipboard


	Chapter�14

	Sequences and Sequence Tools
	Figure 181:� This example illustrates how QuicKeys Sequences can simplify routine multi-step tasks.
	Overview of Sequences
	Recording Sequences
	Figure 182:� The Recording toolbar.


	The Sequence Editor
	Figure 183:� The Sequence Editor.
	The Sequence Steps Tab
	Figure 184:� The Sequence Editor Sequence Steps tab.
	Icon Bar
	Figure 185:� The Sequence Editor icon bar.
	Figure 186:� Click the Create button to display the Create pop-up menu.
	Sequence Editor Icons

	Show Additional Step Info

	The Import Steps Tab
	Figure 187:� The Import Steps tab of the Sequence Editor.


	Creating Sequences Without Recording
	Fine-Tuning Sequences
	Inserting Steps
	Rearranging Steps in the Sequence
	Deleting Sequence Steps

	Tips for Building Sequences
	Saving Sequences
	Triggering Sequences
	Deleting Sequences
	Sequence Tools
	Conditional Sequence Tools
	Decision
	Using Decision
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Decision Shortcut.
	2. Position the insert arrow in the location you want to insert the Decision Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Decision.
	4. Complete the Shortcut Properties dialog and click OK.


	Jump
	Using Jump
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Jump Shortcut.
	2. Position the insert arrow in the location you want to insert the Jump Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Jump.
	4. Complete the Shortcut Properties dialog and click OK.


	Wait
	Using Wait
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Wait Shortcut.
	2. Position the insert arrow in the location you want to insert the Wait Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Wait.
	4. Complete the Shortcut Properties dialog.
	5. Click OK when you are finished.


	Decision, Jump, and Wait Options
	(When/Until) Button
	Figure 188:� The Button options in the Decision Shortcut Properties dialog.

	Button Name
	Match exactly
	Exists
	Enabled
	Selected
	(When/Until) Cursor
	Figure 189:� The Cursor options in the Decision Shortcut Properties dialog.

	Cursor
	Figure 190:� The cursor window.

	Check Cursor Outline
	Check Cursor
	(When/Until) Menu
	Figure 191:� The Menu options in the Decision Shortcut Properties dialog.

	Browse for Menu Item
	Menu Name
	Match exactly
	Item Name
	Exists
	Enabled
	Checked
	(When/Until) Other
	Figure 192:� The Other options in the Wait Shortcut Properties dialog.

	Beep Sound
	User Action
	Time/Date
	Application
	Clipboard
	(When/Until) Window
	Figure 193:� The Window options in the Jump Shortcut Properties dialog.

	Window
	Name
	Type
	Wait Until Window
	If true...
	If false...
	Jump To


	Unconditional Sequence Tools
	Pop-up Menu
	Using Pop-up Menu
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Pop-up Menu Sho...
	2. Position the insert arrow in the location you want to insert the Pop-up Menu Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Pop-up Menu.
	4. Complete the Shortcut Properties dialog and click OK.

	Pop-up Menu Options
	Select Pop-up Menu
	Figure 194:� The Pop-up Menu Shortcut Properties dialog.

	Match exactly
	Find Menu By Name
	Find Menu By Position
	Click Location X/Y
	Use modifiers

	Password Vault
	Using Password Vault
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Password Vault ...
	2. Position the insert arrow in the location you want to insert the Password Vault Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Password Vault.
	4. Complete the Shortcut Properties dialog. Your password will initially appear in plain text.
	Figure 195:� The Password Vault Shortcut Properties dialog.

	5. Click OK when you are finished.

	Substituting Password Vault for Type Text
	To substitute the Password Vault Shortcut for the Type Text Shortcut in your Sequence:
	1. Open a Sequence that types a password in one of the steps. Passwords are typically recorded by...
	2. Position the insert arrow above the Type Text step of the Sequence and select Create > Sequenc...
	3. Type your password in the Password Vault Shortcut Properties dialog that appears and click OK....
	4. Highlight the Type Text Shortcut that enters your password and select Delete from the Edit men...
	5. Click OK in the Sequence Editor.

	Password Vault Options
	Password

	Repeat
	Using Repeat
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Repeat Shortcut.
	2. Position the insert arrow in the location you want to insert the Repeat Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Repeat.
	4. Complete the Shortcut Properties dialog.
	5. Click OK when you are finished.

	Repeat Options
	Repeat Shortcut
	Play the Shortcut X
	X Times
	Figure 196:� The Repeat Shortcut Properties dialog.

	Begin Repeat in Sequence
	Repeat Items between Begin and End X times
	End Repeat in Sequence
	Prompt for Repeat Count

	GoSub
	Using GoSub
	1. Open the Sequence Editor to display the Sequence in which you want to insert a GoSub Shortcut.
	2. Position the insert arrow in the location you want to insert the GoSub Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > GoSub.
	4. Complete the Shortcut Properties dialog.
	5. Click OK when you are finished.

	GoSub Options
	Shortcut to Play
	Figure 197:� The GoSub Shortcut Properties dialog.


	Message
	Using Message
	1. Open the Sequence Editor to display the Sequence in which you want to insert a Message Shortcut.
	2. Position the insert arrow in the location you want to insert the Message Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > Message.
	4. Complete the Shortcut Properties dialog.
	5. Click OK when you are finished.

	Message Options
	Message to Display
	Figure 198:� The Message Shortcut displays a modal window that requires user input during the pla...

	Text Entry Field
	Figure 199:� The Message Shortcut Properties dialog.

	Display OK Button
	Display Cancel Button
	Continue automatically after X seconds

	User/Timed Pause
	Using User/Timed Pause
	1. Open the Sequence Editor to display the Sequence in which you want to insert a User/Timed Paus...
	2. Position the insert arrow in the location you want to insert the User/Timed Pause Shortcut.
	3. In the Sequence Editor, select Create > Sequence Tools > User/ Timed Pause.
	Figure 200:� Select a plug-in from the Sequence Tools submenu.

	4. Select User/Timed Pause from the Create menu.
	5. Complete the Shortcut Properties dialog.
	6. Click OK when you are finished.

	User/Timed Pause Options
	Pause for X second(s)
	Figure 201:� Set the length of a pause in the Pause dialog.

	Pause and wait for user
	Figure 202:� The Playback Palette.




	Appendix�A

	QuicKeys Examples
	Using QuicKeys for desktop Publishing
	How to Create the Sequence
	1. Select Start Recording from the QuicKeys menu.
	2. Press Shift+F8 to open FrameMaker’s Page Setup dialog.
	3. In the Page Setup dialog, select a paper size from the Paper pop-up menu.
	4. Press the Return key on your keyboard to close the Page Setup dialog. (A button click is more ...
	5. Select Stop Recording from the QuicKeys menu. The Sequence Editor appears with the Sequence sh...
	Figure 203:� This Sequence changes your page size in the LaserWriter 8 Page Setup dialog.

	6. Type a name for the Sequence in the Name box.
	7. Select the Include in QuicKeys menu check box and click OK. Since the Shortcut is scoped to Fr...


	Using QuicKeys With E-mail Software
	Changing E-mail Identities
	How To Create the Sequence
	1. Open Outlook Express.
	2. Select Start Recording from the QuicKeys menu.
	3. Select Change Current User from the File menu. A prompt appears asking you to verify that you ...
	4. Press the return key to select Yes at the prompt.
	5. Use your mouse to select a user from the window that appears.
	6. Press the Return key to choose the OK button in the Select a user window.
	7. Select Stop Recording from the QuicKeys menu. The Sequence Editor appears.
	Figure 204:� This Sequence changes logs into a different mail account for you.

	8. Name the Sequence Change mailuser.
	9. Select the Include in QuicKeys menu check box to trigger this Sequence from the QuicKeys menu.
	10. Click the OK button.


	Automating E-mail Content
	Automating Message Content
	1. Open the QuicKeys Editor.
	2. Select Create > Scripting Tools > AppleScript.
	3. Select the Text radio button and click the Modify Text button that becomes enabled.
	4. Write your script in the dialog that appears or copy it from the Script Editor. Figure�205 sho...
	Figure 205:� This script copies information from a database and pastes it into an E-mail message.

	5. Click OK in the Script dialog when you are finished writing the script. The AppleScript Shortc...
	6. Select Ignore in the Results pop-up menu.
	Figure 206:� This Shortcut launches the script shown in Figure�205.

	7. Click OK when you are finished.
	Figure 207:� You can automate the contents of an E-mail message using AppleScript and FileMaker Pro.



	Using QuicKeys With AppleScript and FileMaker
	Recording FileMaker Database Login
	1. Launch FileMaker Pro.
	2. Select Record Sequence from the QuicKeys menu. If you are using the default QuicKeys settings,...
	3. In FileMaker Pro, select Open from the File menu.
	4. Click Hosts in the Open dialog that appears. A Hosts window appears.
	Figure 208:� Click Hosts to see a list of network database hosts.

	5. Select a volume and a host and click Open.
	Figure 209:� Select a host in this window.

	6. Type your password at the prompt and click OK.
	Figure 210:� Type your database password at this prompt.

	7. Select Stop Recording from the QuicKeys menu. The Sequence Editor appears.
	8. Remove any unnecessary Wait Shortcuts.
	9. Replace Click Shortcuts with Button Shortcuts if applicable. For example, a Button Shortcut wo...
	10. Replace your Type Text Shortcut with a Password Vault Shortcut so your password is not in pla...
	Figure 211:� This Sequence logs into a network database.


	Scripting FileMaker Database Login
	1. Open the QuicKeys Editor.
	2. Select Create > Sequence. The Sequence Editor appears.
	3. Select Create > Scripting Tools > AppleScript in the Sequence Editor.
	4. In the AppleScript Shortcut Properties dialog, select the Text radio button and click the Modi...
	5. Write your script in the Script dialog or copy it from the Script Editor. Figure�212 shows the...
	6. Click OK when you are finished with your script. The AppleScript Shortcut Properties dialog ap...
	Figure 212:� This script logs into a network database.

	7. Type a name for the Shortcut in the Name box. For example, type FMP-get URL.
	8. Select Ignore from the Results pop-up menu and click OK to close the Shortcut Properties dialo...
	Figure 213:� The AppleScript Shortcut Properties dialog as it appears after you select a script.

	Inserting Password Information
	1. With the Sequence Editor still open, position your insert arrow below the FMP-get URL Shortcut.
	2. Select Create > Sequence Tools > Password Vault to open the Password Vault Shortcut Properties...
	3. Complete the Password Vault dialog and click OK. The Password Vault Shortcut appears immediate...
	4. In the Sequence Editor, position your insert arrow in the step before the Password Vault Short...
	5. In the Wait dialog, choose to have QuicKeys wait until a dialog with specific attributes appears.
	6. Insert a Button Shortcut at the end of the Sequence that uses the Always Clicks Button option.
	7. Type a name and a keystroke for the Sequence in the appropriate boxes. The finished script wil...
	Figure 214:� The finished scripted database login.

	8. Click OK in the Sequence Editor when you are finished.



	Using DoScript With FileMaker
	1. Write a FileMaker Pro script and name the script “Startup.” When you are finished, the script ...
	Figure 215:� The FileMaker Pro Script menu.

	2. Open the QuicKeys Editor.
	3. Select Create > Scripting Tools > DoScript in the Sequence Editor.
	4. Select the Text radio button and click the Modify Text button.
	5. Type Startup in the Script dialog that appears and click OK. This will cause the DoScript plug...
	6. In the DoScript Shortcut Properties dialog, select Ignore from the Results pop-up window.
	Figure 216:� The name of the script appears in the DoScript Shortcut Properties dialog after it i...

	7. Position your cursor in the Keystroke box and press Control+F1.
	8. Position your cursor in the Name box and type Startup Script.
	9. Click OK when you are finished.

	Using QuicKeys For Web Development
	Solutions for Web Site Managers
	How to Create the Sequence
	Open a frequently-used FTP site
	1. Launch the Fetch application.
	2. Select Start Recording from the QuicKeys menu.
	3. In the New Connection dialog that appears when you open Fetch, type your login information. Pr...
	Figure 217:� The Fetch login dialog.

	4. Press the return key when you complete the New Connection dialog. A list of directories appears.
	Figure 218:� The list of directories shown in a Fetch dialog.

	5. Select the directories you want to open with the “Type to” feature. In other words, press “I” ...
	6. Press the Return key when the directory you want to open is selected.
	7. Select Stop Recording from the QuicKeys menu. The Sequence Editor appears.
	Figure 219:� The steps required to automate the process of logging into an FTP site.

	8. Name the FTP Sequence Fetch FTP and assign it a trigger.
	9. Click the OK button to save your new Sequence and close the Sequence Editor.
	10. Click the close box to close the Editor window.



	Appendix�b:

	Omitting Modified Files
	Adding Files to the Omitted File List
	1. Open the :System Folder:Preferences:QuicKeys Folder:Omitted File List. The Omitted File List o...
	2. Supply Type and Creator Code information in the left column. See
	Figure 220:� The omitted file list.

	3. Type two backslashes to comment out the description of the File Type and Creator.
	4. Insert a carriage return at the end of the entry.
	5. Save the file and close it.
	Format

	Appendix�C

	QuicKeys Script
	Who can use QuicKeys Script?
	When to use QuicKeys Script and AppleScript
	QuicKeys Script
	AppleScript

	QuicKeys Script Recording
	Using the Script Editor
	Creating a Script
	1. Open the Script Editor.
	2. Type a meaningful description of the script in the Definition field. For this example, type Co...
	3. Select QuicKeys from the pop-up menu at the bottom of the Editor window.
	4. Put meaningful information onto the Clipboard. You need to have information on the Clipboard f...
	5. Return to the Script Editor.

	Recording a Script
	1. Click the Record button to begin recording the script.
	2. Click in the Script Editor window so it is the frontmost window, and then click the Stop butto...

	Playing a Script


	QuicKeys Script Writing and Editing
	Setting the Options
	1. Open the Script Editor to create a new script.
	2. In the Definition field, type Turn on grid.
	3. Select QuicKeys from the pop-up menu at the bottom of the window.

	Writing the Script
	1. Click in the script window to type the script.
	2. In line 1 of the script, use the QuicKeys App Switcher Shortcut to make the Finder active.
	3. In line 2, type Menu "View Options" from "View". This command selects the View Options option ...
	4. In line 3, type: Wait Window Name_is "View Options". This command uses a Wait shortcut to wait...
	5. In line 4, type: Button "Always snap to grid". This command enables the Always snap to grid op...
	6. In line 5, type Button "OK" to click the OK button in the View Options window.
	Figure 221:� The Snap To Grid script in the Script Editor.


	Testing the Script

	Language Syntax Reference
	Built-in Commands
	Plug-In Commands
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	Now that you know how to save time on your Mac...
	how about filling the PC world in on your secret?
	So you’re flipping through your QuicKeys 4.0 User’s Guide thinking about all the time QuicKeys ca...



