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Chapter 1 GETTING STARTED

Introduction

Live Picture is an image composition system that lets you create new images
as well as edit or retouch existing images. With Live Picture you can create
composite images that combine digital images with painting and special
effects.

A Live Picture composite image, or simply composite, is constructed as a
sequence of layers. A layer may be an image, paint, an effect or a color
correction. When you’ve created the composite image, you then build the
output image at the desired size and resolution, outputting it either to a file in
the format of your choice or directly to a an output device.

About this Tutorial

This tutorial guides you through many of Live Picture’s essential features.
When you’ve finished the tutorial you’ll have enough information to continue
on your own. You can then refer to the User Guide to learn about additional
features and options.

The Tutorial is divided into the following chapters:

“Getting Started” gives the system requirements, shows you how to install
Live Picture and then launch the program. It also introduces you to Live
Picture’s user interface.

“The Basics” introduces you to Live Picture’s most fundamental features.
These include setting the Background color, creating a layer, using the
Monocolor and Multicolor paint layers, naming a layer, panning and
zooming, and changing the order of layers.

In the “Chevy Tutorial” you build a composite image that contains a back-
ground image, a foreground image, and text. You insert images, apply
distortion, blur and color corrections, blend the foreground and background
images and create text.

The “Rose Tutorial” is more advanced than the “Chevy Tutorial.” It teaches
you more about masks and stencils. You also learn to use Live Picture’s
automatic silhouetting feature.

Three “Gallery” images, created by experienced Live Picture users from
around the world, are presented. For each image, the key techniques are
described and you learn, layer by layer, how the image was constructed.
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System Requirements
The minimum requirements for running Live Picture are:

= Macintosh Quadra or Power Macintosh

= 24 MB RAM (available for Live Picture)

= 10 MB available hard disk space to install the Live Picture files
For optimum performance, we recommend the following configuration:
= Power Macintosh

= 48 MB RAM (available for Live Picture)

= 1-gigabyte (GB) hard disk drive for storing images

= CD-ROM drive (required to access the Live Picture Tutorial files)

= Pressure-sensitive stylus with tablet

= 24-bit graphics card (or 4 MB V-RAM on Power Macintosh 8100)
= 17" color display or larger

Conventions Used in this Tutorial

= All step-by-step procedures are numbered, so the steps needed to com-
plete a task are easily identifiable.
«  Command-K means to hold down the Command key as you press K.

= Option-K means to hold down the Option key as you press K.

= Notes or tips give additional information.

Register Your Software

We believe that it is important to provide you with good ongoing support.
We can only give this support if we know who you are. So please take a
moment to fill out the registration card that comes with your package and
return it to us promptly.

As a registered user of Live Picture you will receive information about
upgrades and new products, additional technical information about Live
Picture, and access to our technical support services.
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Install Live Picture

When you install Live Picture, the Installer creates a folder named “Live
Picture” on the destination hard disk and copies certain files and folders into
this folder. The standard installation procedure installs a “Fat Binary”
version of Live Picture that will run on either a Macintosh or a Power
Macintosh. It also installs the Apple ColorSync extension and PANTONE
color pickers. If you want more control over the installation, you can
customize the installation.

If you are upgrading from a previous version of Live Picture and want to
keep the previous version, rename your existing Live Picture folder. If you are
upgrading from a previous version of Live Picture and don’t want to keep i,
delete the folder before installing Live Picture 2.0.

Standard Installation
The standard installation will install all necessary Live Picture files, including

the Apple ColorSync extension and PANTONE color pickers.
To install Live Picture:
1 Insert the disk labeled “Program Disk 1.”

2 When the disk icon appears on the desktop, double-click it to view the
disk contents.

3 To begin installation, double-click on the Live Picture Installer icon.

The Live Picture Installation window opens. The instructions on the left
describe the installation process and how to use the buttons on the right
side of the window.

s LIWE PIGTURE™ 2.0

Live Picture™ 2.0 Installation nstall on

e

—
The instaler will create a folder named “Live Fioture Quadrag00
2.0* on your hard drive. This folder will contain a Fat Installation requires: 7.6 MB
Binary version of Live Pioture™ 2.0 that will run on bath Available on volume:  14.2 MB
&80x0 and Fower Mao based Macintosh™ computers.
Additionally, the installer will install ColorSyne™, an
Apple System Extension designed to maintain color
consistency across your systern. Click the CUSTOMIZE

3

button to override these default options.

Use the DRIVE button to select the disk where you would
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4 In the Installation window, click the appropriate button.

Click this To do this

Install Install all of the Live Picture 2.0 files (including
the ColorSync extension and PANTONE color
pickers) into a folder named “Live Picture 2.0”
on your hard disk.

Drive Switch to a different drive for installation.
Eject Eject a disk.
Quit Quit the Installer without installing Live Picture.

You can also customize the installation process. For details, see “Custom
Installation™ later in this section.

When you click Install, the Installer begins to copy the Live Picture files
onto your hard disk. A status box indicates the progress.

5 When the Installer prompts you, insert the next Installer disk.

6 After installation, click OK in response to the message that tells you
installation was successful.

Live Picture™ 2.0 was successfully installed.
Please restart your computer before starting
Live Picture.

The Installer returns you to the desktop.
7 Restart your Macintosh.

You need to restart so the ColorSync and Pantone system extensions can
take effect.

Custom Installation

You can customize Live Picture installation if you want to choose a
Macintosh, or Power Macintosh specific version of the application or select
(or deselect) other optional features.
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To do a custom installation:
1 Follow steps 1 through 3 from the previous procedure.

2 In the Installation window, click Customize.

The Custom Install window opens. The text on the left describes the
options on the right.
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3 In the window, select desired options.

Select this option To do this

68K Macintosh Install Live Picture for Macintosh computers
with 680x0 microprocessors.

Power Macintosh Install Live Picture for Power Macintosh
computers.

Both (Fat Binary) Install Live Picture for both 680x0 and Power

Macintosh computers (default).

Install PANTONE™ Install the PANTONE POCE color pickers into
your System Folder.

4 Click Default or OK to return to the Installation window.

5 To begin the custom installation, click Install. Or, click Quit to quit the
Installer without installing Live Picture.

6 To complete the installation, follow steps 5 through 7 in the previous
procedure.
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The Readme File

Immediately after installing Live Picture, be sure to read the Read Me First
document. This is a TeachText document that contains up-to-date informa-
tion on Live Picture, including any changes that were made in the program
after the User Guide and Tutorial were completed.

To read the Readme file:

= Double-click the Read Me icon in the Live Picture folder.

Read Me First!

The Tutorial Disk

The Live Picture tutorial files are located on the Tutorial Disk, included in
your Live Picture package. There is one folder for each tutorial project and
one for each gallery image. They are as follows:

Folder Type

The Basics tutorial project
Chevy Tutorial tutorial project
Rose Tutorial tutorial project
Broken Heart gallery image
Soaring Computers gallery image
Nankoweap, Grand Canyon gallery image

Each tutorial project folder contains (1) the image files in IVUE format,
(2) a lessons folder with a composite image in FITS format for each lesson,
and (3) an output file in TIFF CMYK format that you can print or view.

Each gallery image folder contains (1) the image files in IVUE format that are
used in the composite, (2) the complete composite image in FITS format, and
(3) an output file in TIFF CMYK format that you can print or view.

Install the Tutorial

The tutorial files are not copied onto your disk when you install Live Picture.
For the best performance, we recommend that before you begin to work on a
tutorial project or before you open a gallery image you copy the appropriate
folder from the Tutorial Disk onto your hard disk drive.
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If there is not sufficient space on your hard disk to copy an entire folder, there
are several options:

= You can open the image directly off the Tutorial Disk. In this case, you
don’t copy any files. However, opening and displaying the image will be
considerably slower when reading from the CD ROM.

= Copy the FITS files to your hard disk but do not copy any of the IVUE
files. The larger IVUE files remain on the Tutorial Disk.

= For each IVUE image used in the Chevy and Rose tutorial projects, a
compressed version is included on the Tutorial Disk. You can copy the
compressed images in place of the larger noncompressed image files.

Allocate the Appropriate RAM to Live Picture
After installation, the Live Picture RAM requirements should already be set
correctly. The Minimum Size and the Preferred Size setting is 24 MB. Live
Picture will make use of additional memory if it is available. Additional
memory speeds up screen rendering and the final build process.

Since the amount of RAM is a key variable that affects performance, we
recommend that you verify that RAM is properly allocated.

To Allocate RAM:

1 With the Live Picture folder open on your desktop, click the Live Picture
application icon to select it.

2 Choose Get Info from the File menu.

3 In the Get Info box, type “24000” in the Minimum Size box. (Omit this
step if a value of 24000 or slightly larger is already set.)

4 DPress Tab, and type “24000” in the Preferred Size box. (Omit this step if
a value of 24000 or slightly larger is already set.) You can enter a value
larger than 24000 if your system has additional memory that Live Picture
can use.

5 To close the Get Info box and save your changes, choose Close from the
File menu.
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+ Paint
Lighten
Darken

Some of the tools have options in
pop-up menus.

The mode toggle lets you switch
from the creative mode (left) to
the repositioning mode (right) and
vice versa.

Introducing the User Interface

The Live Picture user interface has the following principle elements:
workspace, toolbars, layer stack, and control bar.

The Workspace

The workspace is the main window where you create the composite image.
You can only use the Brush, Marquee, and other tools within the workspace.

The Toolbars

The toolbars appear vertically along the left side of the workspace. The three
toolbars are: the creative, positioning, and view toolbar.

Use this toolbar To do this

Creative Access the Brush, Marquee, Eraser and
Palette Knife tools to apply paint, effects,
distortion, color corrections and to silhouette
images. Use Tool Controls to change the color,
size, intensity and direction.

Positioning Move, scale, rotate, skew, change perspective
and flip individual layers or groups of layers.

View Create new views. Move, rename, change
dimensions, line width, and color of new and
existing views.

A toolbar consists of a series of tools. Some of the tools have options which
you can access by clicking a tool. Examples are sliders and pop-up menus.

The positioning toolbar is available when an image is first inserted and it is
also used to reposition individual layers or groups of layers. When it is used
to insert images there is an extra tool at the bottom that can be used to set
the overall image opacity.

Each of the toolbars have a toggle at the top, called the mode toggle. The
mode toggle for the creative toolbar switches to the positioning toolbar. From
the positioning toolbar, the mode toggle switches to the creative toolbar.
From the View toolbar the mode toggle switches to the creative toolbar. You
access the View toolbar from the View menu.
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Layer Stack

The layer stack is the wide vertical series of bars that runs down the right side
of your screen. Each time you add a layer, by choosing a command in the
Create menu, a new layer bar is added to the layer stack. Initially, the layer
stack contains only the Background. The Background is not a true layer; all
you can do is change its color.

The layer stack not only functions as a status display but also allows you to
select, activate, move, customize, and delete layers. The first row of a layer
bar is the layer name. Next to the name is a triangular toggle switch. Click
the toggle to reveal the layer panel which shows the layer element icons and
the hide/display toggle. If the layer is an image layer, a thumbnail of the
original source image also appears in the layer panel.

Control Bar

The control bar is the horizontal area at the top of the workspace but below
the menu bar. The control bar changes according to the active layer and the
tool you are using. It displays status information about the tools and objects
in the composite and provides a fixed location for interactions with the tool
you’re using.

Depending on the tool or mode, it lets you enter numbers, set tolerances,
select colors, and line widths. For example, when working with the position-
ing and view tools, the control bar contains numerical data about the
position of objects in your composite and offers data entry fields to precisely
define coordinates, sizes and percentages. You can perform the same opera-
tions (scale, move, resize, etc.) by entering data in the control bar fields, or by
acting directly on the object with the pointer.

What’s Ahead

In the next chapter, you begin using Live Picture as you take the introductory
lesson.

What'’s ahead...

2
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Main Window

Mode toggle Control bar Menu bar
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Workspace Layer stack

it

Toolbar

Layer Stack

Source icon

Mask icon

Layer toggle

Visibility icon

Stencil icon

Layer panel

Layer name

Source image
thumbnail
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Control bar

Creative mode

ﬁj Active Layer Tool

Positioning mode

X Point

Toolbar

Positioning mode

Creative mode

Toggle

Scale tool Toggle
Rotate tool Brush
Skew tool Eraser

Perspective tool

Palette Knife

Crop tool Marquee
Positioning Box tool Path tool
Zoom tool Zoom tool
Pan tool Pan tool

Horizontal Flip tool

Vertical Flip tool

Opacity control

Color Selector

Tool Size

Tool Style

Pressure Control

Direction Control

Creative tools

Tool controls

What’s ahead...
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The Gallery BROKEN HEART

“Broken Heart”
by Jeff Brown

HOW IT WAS CREATED

1 Beetle
Jeff’s home photo of his beetle is the
basis for this creation.

2 Insert Lamp

A photo of a cracked headlight is
inserted.

3 Distort Lamp
Using the distortion brush, Jeff bent
the metallic frame of the lamp into
the shape of a beart.

4 Add Sky
Using the image insertion brush,
Jeff blended in a beautiful sunset,
eliminating the houses in the
background.

Continued...
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“Broken Heart”
by Jeff Brown. Colour Unlimited.

About the Artist

Jeff Brown is a pioneer in digital imaging. Starting in 1980 with a ZX80
home computer, Jeff has moved to the high end of imaging at Colour
Unlimited, London, which was the first European site for the Kodak Premiere
and Barco Creator. At home, you can find Jeff using Live Picture on one of
his two Power Macs, when he’s not surfing in Cornwall, Norfolk, or on the
internet.

Overview

In Jeff’s own words: “This image just happened.” Jeff had taken several
photos of his car and was using them in Live Picture demos that he often
gives to prospective clients. In the demo he used the auto in combination with
a sunset of the Cornish seascape. While showing off Live Picture’s distortion
brush Jeff had the idea of creating a love bug. According to Jeff, this image
strikes a chord with nearly all who see it.

Layer by Layer
To get started, Jeff scanned the Beetle and Sunset photos on a Kodak Premier
film reader.
Beetle
The Beetle image was inserted, and contrast was increased using the
Brightness/Contrast IVUE Correction.
Clean Paint Chip

Using image cloning, Jeff removed a paint chip next to the license plate.

Remove Flasher

Using two Image Clone layers, Jeff removed the turn lamp (flasher for our
English readers). Then, using the scaling tool, he stretched the clone layers
to cover the flasher. First the car is cloned from the left and then from the
right.
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Remove Butt

A cigarette butt was removed from the grass by cloning.
Blacken License Plate Bottom Edge
Darken Bottom Edge

In these two layers, Jeff repaired a badly damaged license plate. First,
using paths and paint, he blacked out the license plate number. Then, he
repaired the damage to the bottom of the license plate by duplicating the
edge from the top and stretching it into place. Finally, Jeff darkened the
bottom of the license plate to fit the overall lighting scheme.

License Plate Letters

Jeff created new license plate letters using Live Picture’s Type tool.

Distort Lamp
Jeff inserted the photo of a cracked headlight and, using the distortion
brush, bent the metallic frame of the lamp into the shape of a heart.
Clean Above Lamp
Blend Body Color

First Jeff used cloning, to clean up the visible part of the lamp at the top.
Next, he used selective color correction to match the clone area to the
surrounding color.

Heart Glow

A heart was painted into the heart shaped head lamp.
Add Sky
Spot Sky

Jeff inserted the sky, and using a brush, blended in the beautiful sunset
and eliminated the houses in the background. Finally, with an Image
Clone layer, he cleaned up a couple spots in the sky.

21

What'’s ahead...

|
W



Chapter 2

The Basics




“Here Comes the Sun”
by Anna Godfrey

1 Multicolor Painting
Painting with large strokes.

2 Smudge & Blend
Detail the clouds using the
Smudge tool in the
Sharpen/Blur layer.

3 Diffuse & Push
Zoom in and billow the clouds
using Diffuse, Push, and
Smudge options.

4 Duplicate, Stretch and
Apply Perspective
Duplicate the Sharpen/Blur
layer, stretch and apply
perspective for depth and
dimension.

Chapter 2

Before you create a composite image, which you’ll do in the Chevy and Rose
tutorial projects, you need to know several basic operations: setting the
Background, creating a layer, using the Brush tool, panning and zooming,
and changing the order of layers.

Start Live Picture

Before you start the Live Picture software, make sure that you have at least
24 MB of available RAM.

To start Live Picture:

= Double-click the Live Picture application icon.

Live Picture 2.0

The first time you start Live Picture, a dialog box prompts you to
personalize your software. You only need to do this once.

Enter the following information:

Your Name:

| |
Company: | |
| |

Serial Number:

To personalize your software:

1 Type your full name in the Name box, first name followed by last name,
and press Tab.

Optionally, type your company in the Company box and press Tab.

3 Enter the Live Picture serial number located on the Live Picture Program
Disk 1.

4 Click OK.



24
.

Live Picture 2.0 Tutorial

Create
Monocolor
Multicolor
Colorize
Artwork

#2
®3

Image Insertion
Image Distortion
Image Silhouette
Image Clone

#4
#5
#6
®7

Sharpen/Blur
Sharpen/Blur +

#8

Color Correction

#9

Set the Background Color

Usually you will want to set the Background color before starting to create a
composite image. You will probably want the Background to be a neutral
color, white, gray, or black.

To set the Background color:

= Click the Color Selector and use the Eyedropper to select the color white
from anywhere on the screen.

The Background color of the composite image immediately changes to
white. If the Background color was already white, this change will not be
apparent.

When the Background is not the active layer, you must first pick the Back-
ground color using the Eyedropper, and then choose Set Background from
the Edit menu.

Layer Types

Live Picture lets you create eleven types of layers. To create a layer, you
choose one of the layer types from the Create menu. Let’s examine how to
create and use two types: Monocolor and Multicolor.

Monocolor Layers
The monocolor layer is the simplest, most basic, painting layer. In a

monocolor layer you paint with a single color, and this color can be changed
at any time.

To create and use a monocolor layer:

1 Choose New from the File menu.

A document window appears. Later you’ll learn how to use the Docu-
ment Setup command to define the document.

2 Choose Monocolor from the Create menu.

Live Picture creates a Monocolor painting layer and adds a new layer bar
to the layer stack.
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3 Select a medium brush from the Tool Size control in the tool bar.
4 Use the Color Selector to select a shade of yellow.

N. In the toolbar, the Color Selector appears as a single solid color. When
you click on it, the Color Bar appears and the Color Selector shows two
colors, the initial color and the color selected by the Eyedropper.

5 Select the Paint option from the Brush tool.
“m 6 If you are using a mouse, press the number 0.

On the mouse, you can regulate the brush pressure by the number keys.
Each of the 10 number keys will affect brush pressure, with 1 giving the
faintest stroke and 0 the most intense.

7 Draw a diagonal stroke by clicking and dragging the pointer from the
bottom left of the screen to the top right.

8 Use the Color Selector to select a red color.

The brush stroke changes to the new red color. You can change the color
of a Monocolor layer at any time in this way.
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Create

Multicolor
Colorize
Artwork

Monocolor #1

2
®3

Image Insertion
Image Distortion
Image Silhouette
Image Clone

®4
£ ]
£
®7

Sharpen/Blur
Sharpen/Blur +

#®8

Color Correction

#0

Multicolor Layers
The Multicolor layer lets you paint in any color. This approximates to

conventional painting. You can not change the color of paint strokes in a
Multicolor layer, but you can erase them with the Eraser.
To create and use a Multicolor layer:

1 Choose Multicolor from the Create menu.

Live Picture creates a Multicolor painting layer and adds a new layer bar
to the layer stack.

Select the Paint option from the Brush tool.

3 Use the Color Selector to select a green color.

> [ e

a0

4 Draw a second diagonal stroke that partially overlaps the first.

w T w

5 Use the Color Selector to select a deep blue color.

6 Then draw another diagonal stroke, this time from the bottom right to
the top left, making an X on the screen.

Change the Name of a Layer

In Live Picture you work with layers. Each time you choose a command from
the Create menu, Live Picture creates a new layer. As you will see, you can do
many things within a single layer. Thus, many of your composite images will
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have just a few layers. On the other hand, composite images that involve
many photos and substantial retouching may grow to twenty or more layers.

To manage these layers, it is a good practice to give each layer a meaningful
name.
To change the name of a layer:

1 In the layer stack, select the Monocolor layer, the first layer that you
created, by clicking it once. .
-

The layer appears framed in blue.

2 Choose Get Info from the Layer menu, or press Command-I.

The Info dialog box appears. The Info dialog box is not exactly the same
for each type of layer. However, the first field always lets you see the
current layer name and change it.

] Monocolor 1 Info =————

Name
Monocolor Red |

—

CMYK Output.
RGE

@ Use separation table

O Use exact CMYK values
Cim-m Mim-m Wi--- Koo

3 In the name box, type the name “Monocolor Red.”

4 Click the close box to close the Info dialog box.

Zooming In and Out
The Zoom tool lets you magnify (zoom into) and demagnify (zoom out from)

selected portions of the image. The Pan tool lets you move up, down, right,
and left within the workspace.

To zoom in and out:

1 In the toolbar, select the Zoom tool.

2 Click at the spot where the diagonal brush strokes intersect in the
workspace.
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This magnifies the image by a factor of two around the spot where you
clicked. Now click again at the intersection point.

LI o

note: You'll notice that you don’t see any pixels. This is true no matter
how far you zoom in. Any effects that you apply with a brush in Live
Picture, including paint, blur, and sharpen, are resolution independent.
Each time you zoom, or when you build the final output image, the
effects are regenerated at the correct size and resolution. The result is that
the quality of the image is preserved even when you resize or rescale the
image.

3 To zoom out, hold down the Option key (yow’ll notice that the ‘+* sign
changes to a ‘-’ sign in the cursor) and again click at the intersection
point.

This demagnifies the image by a factor of two. Option-click once more to
return to the original magnification.

Moving Layers

At this point, you’ve created two different layers: a Monocolor layer and a
Multicolor layer. Now youw’ll learn the basic ways of manipulating entire
layers.

To move layers:

1 In the layer stack, click and drag the second layer bar in the layer stack,
named “Monocolor Red,” above the topmost layer.

The red brush stroke moves on top of the blue and green strokes in the
workspace.



29

Chapter 2 THE BASICS

2 Click the mode toggle to switch to the repositioning tools.
A rectangular positioning box encloses the red brush stroke.

3 Drag the positioning box to the right and slightly downwards.

brush stroke is offset from the green stroke. If the red brush stroke has
changed in size, its because you grabbed a handle, one of the corner
points of the positioning box. In this case, choose Undo Scale from the
Edit menu. Then try again, this time placing the pointer in the center of
the positioning box, not on an edge or corner.

When you release the pointer, the screen redraws, or renders. The red !

TR o

note: When you zoom, pan, open or close a layer, Live Picture renders
the screen. Rendering a screen means that Live Picture is computing the
value of each pixel on the screen, taking into account the effect of each
layer. Screen rendering is very fast when there are just a few layers and
somewhat slower when there are ten or more layers. You’ll find that
image layers, artwork layers, and color correction layers take somewhat
longer to render than the other types of layers. There is an option, named
Quick Preview, found in the General Preferences, that controls the way
Live Picture renders the screen.

With Quick Preview on, Live Picture renders the screen quickly at low
resolution and then renders the screen at full resolution, filling in the
details. With Quick Preview off, the screen is rendered once at full
resolution. Experiment with both settings to see which you prefer.
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Save the Composite

As with any computer program, we recommend that you save your work
from time-to-time.

To save your work:
1 Choose Save FITS from the File menu.
A dialog box prompts you to enter a name.

2 Type “My First FITS file” and click Save.

3 LP 2.0 Tutorial —FITS Angel
0O Chevy Tutorial 1|
O Ul Images
O Untitled - 1 Desktop
e —
save as:
[My First FITs Filef | :@

Live Picture saves the composite image in the FITS file.

The Palette Knife

Before you finish, lets take a moment to explore the palette knife options.

To use the Palette Knife:
7 1 Click the mode toggle to use the creative tools.

Activate the Multicolor layer by double clicking it.

7

” Y Push .

Click the Palette Knife, and select the Push option.

h W N

With the pointer, brush up and then down, zigzagging across the blue
brush stroke. Repeat the action, brushing across the green brush stroke.

As the option name implies, this action has the effect of pushing the brush
stroke.
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4 Push ]

A | 5 Click the Palette Knife again, and this time select the Diffuse option.
6

Starting at the intersection between the blue and green strokes, brush
slowly in circles.

This has the effect of diffusing or mixing the colors.

\

Close the Composite
Before you move on to the first tutorial, close your composite.

To close the composite:

= Choose Close from the File menu. A dialog box prompts you if you want
to save these changes. Click on Don’t Save.

Now that you know a little bit about how to work in Live Picture, you are
ready to create your first composite image.

What’s ahead...
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“Soaring Computers”

by Douglas Fisher

HOW IT WAS CREATED

1 Sky
The sky is a Sharpen/Blur layer that
was created directly from a scanned
image. The result is a resolution
independent painting; zoom in and
you’ll never see a pixel.

2 Computers
Each computer was cut out using
path tools. There are five different
computers, each duplicated several
times to total 12 in the final
composite.

3 Computer Shadows
The path for each computer was used
to generate a shadow. A large feather
was used.

4 Man

Doug used Live Picture’s silbouetting
feature to mask the man.

Continued...
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“Soaring Computers”
by Douglas Fisher

About the Artist

Doug is a London based free lance photographer/designer. His commissions
range from design and advertising agencies to publishing houses. Recent
clients include British Petroleum, IBM, Philips, and authors such as Ruth
Rendell and Anne Rice. Doug’s work is bold and imaginative, often using
photo-compositing techniques to combine vivid colors, textures and superb
photography.

Overview

Soaring Computers was commissioned for IBM’s Open Options Magazine.
The brief was to illustrate the role of portable PCs in business. Doug let his
imagination soar and IBM’s portable PCs as well.

Layer by Layer

The original photos by Douglas were scanned at high resolution by Ceta
Services in London. Doug’s original version of Soaring Computers includes
7 images, yielding over 300 MB. To fit on the Tutorial Disk each of the
images was resized down. Yet there is still enough detail to let you read the
display monitor on even the smallest computer. Try zooming in to see!

Sky

Doug started by creating a blurry sky background. To do this, he first
inserted an image of a sky, color corrected, and cleaned it using image
cloning. He then created a Sharpen/Blur layer and used the Marquee’s
Blurred Fill option to create a blurred copy of the sky. Finally, he deleted
the sky image. The result is a resolution independent sky; you can zoom
in as far as you like and never see a pixel.

Building

Doug inserted the Building, color corrected it using the Color Curves, and
masked it using the Path tools.
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Computer 1-5

Five different photos were used to create the sequence of twelve portable
computers. Each computer was inserted, and masked using the path tools.
Doug then positioned the images at various angles and sizes. One interest-
ing point is that since none of the twelve computers overlap, they can
occur in any order in the layer stack.

Computer Shadows

Doug then created a shadow for each computer using Monocolor black
paint layers. He used the original path for each computer to create soft
edged stencils in the black paint layers. The shadow layers were then
moved together and underneath the computer layers and grouped.

Man

Doug silhouetted the man using Live Picture’s automatic masking feature.

What'’s ahead...
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1 Distortion
The Chevy is inserted, cropped
around the headlamp and then
distorted.

2 Color effects

The lamp is changed to black
and white, colorized and

blurred.

3 Text
Text is added to the back-
ground image, large fuzzy red
text, and smaller hard edged
black text.

4 Color Correction
Using Selective Color
Correction, the red Chevy
becomes a purple Chevy.

This tutorial project will familiarize you with basic Live Picture concepts and
features.

All the files you need for the tutorial are found in the Chevy Tutorial folder
on the Tutorial Disk.

File or folder name Description

57 Chevy Image file in IVUE format

57 Chevy /C Compressed image file in IVUE format
Chevy TIFF Output file in TIFF CMYK format that can be

printed or viewed

Chevy Lessons This folder contains one reference file for each
lesson (except for the first). It also includes
Chevy Final, the final FITS file.

In the folder named Chevy Lessons you will find a reference file for each
lesson. The reference file is the FITS file that you can use to start the lesson.
For example, if you are about to begin lesson 8, you can choose Open FITS
in the File menu. When the Open dialog box appears, select the folder named
Chevy Lessons and then double click on Chevy 8. Then you can follow the
instructions in lesson 8.

Each of the FITS files is sized for a 13" monitor. If you are working with a
larger monitor, open a FITS file and click the grow box in the document
window or use the resize box to increase the size of the window. Next,
choose Go To in the View menu and select the Double Page view to magnify
and center the image.

If you continue from one lesson to the next, then you do not have to load the
FITS file for the new lesson since you will already have created it.
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Lesson 1: Set Up a New Document

To begin, you will start Live Picture and use the Document Setup command
to define the layout of the composite image.

To start Live Picture:

= Double-click the Live Picture icon to start the program.

To set up a new document:
1 Choose Document Setup in the File menu.

The Document Setup dialog box appears. This dialog box lets you define
the initial view, background color, and document resolution. You can
redefine these values later.

Document Setup

& Define Initial View
Size Orientation
Width: Units

()

2 Ifitis not already selected, click Define Initial View to select it.

Live Picture will create a starting view at the dimensions you now specify.
(Views are described further in the next lesson.)

3 Enter Width and Height values of 17" x 11" and set the Resolution to 400.
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4 Click New.

The workspace appears. The initial view, a rectangular box, is visible in
the center of the window. The initial view size, units, and resolution are
stored in the Live Picture Preferences file. Live Picture applies them when
you choose New from the File menu.

note: The document resolution is the number of pixels assigned to each
unit (inch, centimeter, or millimeter). For example, if you plan to output
to a dye sublimation printer that prints at 300 dots per inch (dpi), you
will probably want to set the document resolution at 300 dpi. Then,
when you work in Live Picture, one inch on the rulers corresponds to one
inch on the output page.

When you change the document resolution, the underlying composite
image is not resampled, interpolated, or changed in any way. The docu-
ment resolution is used when you build the output image. For example, if
you built the image that you just set up at 100% scaling (17" x 11" x
400 dpi) the resulting file would be approximately 87 MB. Document
resolution is also used to specify the feathering of mask and stencil edges.

5 Choose Show Rulers from the View menu.
The rulers display in the workspace.

You will be working with a precise layout in the tutorial. So, you should
turn on the rulers whenever you begin a new lesson.
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Lesson 2: Working with Views

In addition to the initial view, you can create new views. A view defines a
rectangular area that can later be output using the Build command. You can
also use views as preset display areas which you can access by choosing Go
To from the View menu. This lets you directly display a selected area,
avoiding multiple zoom and pan steps.

Views are not a part of the composite image. They do not appear in the

output image.

Change the Name of a View
Each view has a name. A default name is assigned when the view is created.

It is a good practice to change the initial name to one that is meaningful.
To change the name of a view:
1 Choose Add/Edit from the View menu.

Live Picture places you in the view mode where you can add, edit, delete,
and change the name of views.

2 Click in the view box titled “View 1” to change it.
The view box is selected and the name field changes color.

3 Type the name “Double Page,” and press Return.

ITEE———=—

| PR P ST
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4 Click outside the view box to deselect the view.
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Add a New View
Since you will be working with a double page spread, you need to create a

new view to divide the two pages.
To add a new view:

1 In the center of the workspace, click and drag downwards to create a
rectangular box. This box can be any size and shape.

Live Picture creates a new view.

N

Click in the X field of the X-point in the control bar.

w

Type the value 8.5, and press Tab to move to the next field. Continue,
typing in the following values: Y=0, W=8.5, H=11. Remember to press
Tab after typing each value to move to the next entry field.

4 DPress Return.

Live Picture creates a view using the X-point, and dimensions that you
entered.

Mr—

i
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3 Click in the view box and type the name “Gutter.”

4 Click the mode toggle to return to the creative toolbar.

note: You use the mode toggle to switch between toolbars. In this step,
you use it to switch from the view tools to the creative tools. Later you will
use it to switch from the positioning tools to the creative tools and back
again. The frontmost icon indicates the current toolbar and the backmost
indicates the toolbar that will be available when you click the toggle.
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Lesson 3: Insert an Image

Probably the most fundamental task in Live Picture is to insert, or place, an
image into the composite. To do this, you create an image layer by choosing a
command from the Create menu. Once the image opens and appears in the
workspace you can position and crop it.

Open an Image

1 Pull down the View menu. If Auto View is checked then choose Auto
View to deselect it. If it is already deselected then go to Step 2.

When Auto View is on (checked), Live Picture creates a view that exactly
surrounds each inserted image. In this tutorial, you will be inserting
images into the double page layout that you’ve just created. So you won’t
need this capability.

2 Choose Image Distortion from the Create menu.

The Insert Image dialog box appears. You use this dialog box to preview
image files and to select one image to insert into the Live Picture composite.

=3 IWUE v = Quadra%00
T

D Corvette

D Sneakers Desklop

2]

Cancel

i

Open

File

Size: 25.1 MB
Dimensions: 1.4 1 2.1 in.

Resolution: 1500 dpi

[ Aute Insert [JUse Alpha Channel Preview

note: Each time you choose a command from the Create menu Live
Picture creates a new layer. The basic types of layers are paint
(Monocolor, Multicolor, Colorize, and Artwork), image (Insert Image,
Image Distortion, Image Silhouetting, and Image Cloning), filter (Blur and
Blur More), and Color Correction.

3 In the dialog box, deselect Auto Insert.

If Auto Insert is selected, then click it to turn Auto Insert off.

note: With Auto Insert off, you can use the positioning tools to
precisely define the image scaling, cropping, rotation, etc. With it on, Live
Picture bypasses the positioning tools and opens the image, centered in
the workspace at 100% opacity.
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4 Locate and select the IVUE file named 57 Chevy.
57 Chevy is found in the folder named Chevy Tutorial.
5 Click Open.

The image opens and displays in the workspace.

note: Each IVUE file contains a single digital image, or photo. The
IVUE file is organized or formatted in a way that enables Live Picture to
open and display the image on the screen very fast. A digital image must
be acquired or converted to IVUE format before it can be used with Live
Picture. This is done either within Live Picture using the commands in the
Converter menu or by using a separate application, named the Image
Vue. Image Vue is included with your Live Picture software.

Crop and Flip the Image

Once the image opens, Live Picture switches to the image insertion mode
where a set of image positioning tools is available. First you’ll crop the image
and then flip it.

To crop the image:

1 Click the Crop tool.

2 Move the pointer to the handle in the upper left corner. Click the crop-
ping box and drag it inwards until the crop is just above and to the left of

the headlight.

Double Page

' A 7|
|
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3 Move the pointer to the bottom right corner handle, and click the handle

and drag it inwards until the cropping box just surrounds the headlight.

This cropping does not have to be precise so feel free to experiment by
dragging each of the handles to get a feeling for how you crop images in
Live Picture. You can move the entire cropping box, dragging it, directly
over the headlight. When the Crop tool is selected the image does not
move when the cropping box moves. The cropping box moves over the
surface of the image, acting like a window.

Click the horizontal flip tool (topmost of the two flip tools) to flip the
image horizontally.

Position and Scale the Image

Next, you will scale and position the image to fit precisely inside the double-
page view.

Verify that the image opacity is set to 100%.

The opacity is shown on the opacity tool, at the bottom of the toolbar. If
the opacity is not 100% then click the tool and, using the opacity slider,
set it to 100%.

Click the Scale tool (top tool in the toolbar).

Drag the X-point, the X icon found in the center of the image, to the top
left corner of the image.

The X-point snaps in place into the corner handle.
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note: LThe X-point defines a fixed point for scaling, rotation, and
skewing operations; that is, the image rotates (scales, skews) around this
point. The X-point is also used in cropping, but only when you enter
values in the control bars. It is not used when you crop with the pointer.

4 Click in the X Point X field in the control bar.

Type the following values: X=0, Y=0, W=17, H=11. Press Tab to move
from one entry field to the next.

Rotate

Skewr

6 Press Return.

it
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This accomplishes two actions at once. First, the entire image moves to
the origin (X=0, Y=0) and the image scales to 11" x 17", fitting precisely
into the layout.

7 Click the mode toggle to switch to the creative toolbar.

At this point the image is “pasted” into the workspace. Live Picture
creates a mask that defines the opacity of the image at each point. In this
case, the mask is 100% opaque inside the cropping rectangle and trans-
parent (0% opaque) outside it. The image opacity can subsequently be
modified using the Brush, Eraser, or Marquee.
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Lesson 4: Color Correct an Image

Live Picture has two types of color corrections: IVUE corrections that work
on a single image layer and a Color Correction layer that operates across all
layers in the composite. Here you will use just two of the IVUE corrections:
Black & White and Brightness/Contrast. You can freely experiment with the
IVUE corrections without worrying about damaging the composite—if you
run into trouble just select Undo Corrections from the IVUE Corrections
submenu in the Layer menu. Later in this tutorial you’ll use the Color
Correction layer.

To Change the image to black and white:

= Choose IVUE Correction from the Layer menu, and then choose
Black&White from the Presets submenu.

& File Edit Create Uiew Mask _Converter Batch
= ate

3 [P

The 57 Chevy immediately changes to black and white.

note: If the IVUE Corrections command is not available in the Layer
menu, then you must select the layer that contains the 57 Chevy image.
This is accomplished by clicking once on the layer named 57 Chevy. The
layer bar is highlighted in blue.

If the Presets are not available within the IVUE Corrections submenu,
then you have to use the Files & Folders Preferences in the Edit menu to
select the Color Presets folder. You will find the folder named Color
Presets in the Live Picture folder. After selecting the Color Presets folder
you must quit Live Picture and launch the program again before the
change takes effect.
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Select another color preset and see the result. Do this as many times as
you like. Make sure to select Black & White again before going on to the
next step.

To adjust brightness and contrast:

1 Choose Brightness/Contrast from the IVUE Correction submenu.

2 In the dialog box, use the Brightness slider (top slider) to increase the
brightness to 40.

The After view of the 57 Chevy updates immediately to reflect the
change.

Click Preview to see the effect on the composite.

4 Click OK to accept the effect and to apply it to the composite image.



48
|

Live Picture 2.0 Tutorial

e

hand
al
Shimmer

Lesson 5: Distort an Image

This lesson introduces you to Live Picture’s image distortion feature, which
lets you use a brush to selectively distort the shape of an image.

Live Picture’s approach to distortion is unique for two reasons. First, you can
apply distortion with a brush (not using a selection area or grid), and sec-
ondly, you can gradually and selectively reverse the distortion using the
Eraser. Thus, there is no penalty for mistakes.

1 Choose Display from the View menu, and then choose Gutter from the
submenu.

This turns off the visual display of the Gutter view. The view is still
accessible with the Go To command or when you build the image. You
can turn back on the visual display using the Display command.

2 Click the Brush in the toolbar and select the Freehand option.

Click Tool Size and select a medium size brush.

4 Brush over the image to distort it.

Take some time and experiment with the different Brush options: Radial and
Shimmer. Also, explore the Undistort option of the Eraser, and the Blend
option of the Palette Knife.

When you move the Radial Brush in a clockwise direction, it diminishes the
effect. When you move it counterclockwise, it enlarges the effect. The Blend
option smooths the distortion effect and the Undistort Eraser option lets you
selectively reverse the effect. If you want to start over, click the Marquee,
select the Undistort option, and drag out a rectangle over the entire image.
This eliminates all distortion. Your distortion may not look exactly like what
you see in the figure, but it gives you an idea of what is possible.
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Lesson 6: Blur an Image
Until this point you having been working within a single image layer. Now

yow’ll add a second layer: Sharpen/Blur.
To blur the image:
1 Choose Sharpen/Blur from the Create menu.

After a few seconds a new layer appears in the layer stack at the right.

Fli-seoenry 2 Click the Marquee and select the Blurred Fill option.

Blurred Fill
3 Click on the opacity (%) icon in the Marquee and adjust the slider to
50%.

If you hold down the Shift key while moving the slider, it is constrained
by increments of 10.

4 Starting at the upper left corner, drag out a rectangle that entirely covers
the Double Page view.

The rectangle should be slightly bigger than the view to ensure that it
covers the view entirely. Release the pointer to apply the blur effect.

If you make a mistake and want to redo this, then choose Undo Marquee
from the Edit menu. Then repeat step 4.

mote: There are several ways to control the intensity of the blur effect.
Using opacity is the most basic, since the strength or maximum effect can
be set to any percentage value. Alternatively you can use the Pressure
Control (second tool from the bottom) which offers four pressure settings.
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7

Lighten . |

Lesson 7: Colorize an Image

Next you will selectively lighten the image. In the language of digital imaging,
this is referred to as “blowing out the highlights.” In the world of photogra-
phy this is similar, although not identical, to dodging.

Like all effects in Live Picture, you can selectively lighten and darken using a
brush. Live Picture’s brushes are resolution independent. This means that
they work at the same speed regardless of the size of the image. For example,
you can use a 100,000-pixel airbrush on a 75 Mb image in real-time.

To colorize an image:

1 Choose Colorize from the Create menu.

After a moment or two a new layer is added to the layer stack on the
right.

Click the Brush and select the Lighten option.

Reduce the brush pressure by moving the slider on the Pressure Control
all the way to the left.

4 Click the Tool Size tool and drag to select a medium brush (for example,
select the fifth from the left to start).

5 DPaint over the areas that are already highlighted to further accentuate
them.

If you want to remove an effect, hold down the Command key and the
Brush becomes the Eraser. Brush with the Eraser to remove the effect.
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Lesson 8: Working with Images

Live Picture’s strength is its ability to create “composite images,” images that
are created using one or more photos. Live Picture lets you quickly open,
display, position, and crop images - getting them into place before you turn to
the creative tools to ghost, blur, blend, mix, and perform other subtle imaging
effects. In this chapter youw’ll insert, reposition, and recrop the 57 Chevy. In
the next chapter, you’ll learn how to blend this image with the background.

To insert an image:

1 Choose Image Insertion from the Create menu.

The Insert Image dialog box appears. If the Auto Insert box is selected
(an ‘X inside it) then click on the box to turn the feature off.

2 Locate and select the file 57 Chevy, and click Open.

The image displays on the screen and the image insertion tools appear. A
new layer is added to the layer stack.

To position the image:

.—=3 1 Drag the X-point to the lower left handle and release it when it snaps into
H the handle.

2 Click in the X Point X field in the control bar.

3 Type the values X=0, Y=11. Then press Return.

The image positions so that it fits into the lower left hand corner.
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To Crop the image:
_ 1 Click the Crop tool in the toolbar.
2 Click in the Size W entry field in the control bar.
3 Type the values W=9, H=11. Press Return to crop the image.

fi=———— thoyg =—-———— 0
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4 Click on the mode toggle to return to the creative toolbar.
There is a slight delay while Live Picture pastes down the image.
5 Change the name of the layer to Chevy.

To do this you press Command-I, type the new layer name Chevy, and
click in the close box of the Info dialog box.
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Lesson 9: Blending Images

Next you’ll use a gradient box to blend, or fade, the red Chevy in the fore-
ground with the background image. This technique, also referred to as
ghosting, is accomplished by changing the opacity of the foreground image
smoothly from 100% to 0%. In Live Picture, opacity changes can be made
using a brush, which produces a nonuniform blend, or, as is shown in this
lesson, it can be done using a gradient box.

1 If the rulers are not on, turn them on by choosing Show Rulers from the
View menu.

v Fill
Erase
Gradient »

a 2 Click the Marquee tool, choose Gradient, and then select the Horizontal

option.

Horizontal
4 Point: . . .. . .
= 3 Using the rulers as a guide, position the pointer at 6" horizontal, 0"

vertical, and drag out a rectangle that ends at exactly the right edge of the
red chevy, 9" horizontal, 11" vertical.

Try to be as precise as possible in aligning the right edge of the gradient
with the red Chevy.

Double Page

4 Click in the opacity control on the right.

Initially, the opacity value is set to 100%. When you click, the entry field
changes color.
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5 Type the value 0 and click in the gradient box to apply the gradient.

6 If the gradient is satisfactory then click outside the gradient box to accept it.

i p: The right edge of the gradient will be visible unless it coincides
exactly with the edge of the red Chevy. If this happens, you can use the Fill
option, also available from the Marquee, to return the Chevy to 100%
opacity. Then try repeating steps 2 through 5. If the right edge of the opacity
gradient is still visible, use the Eraser and lightly erase the line.
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Lesson 10: Working with Text

Live Picture lets you create text and apply it in any type of layer. Live Picture
treats text as paths, linked curves that can be scaled and manipulated. Once
you have entered the text and positioned it, you apply it to a layer by con-
verting it to a mask or stencil. With this approach the text remains scalable; it
can be resized, rotated, and skewed without loss of quality. By way of
contrast, other image editors convert text to pixels, which are not scalable.

To turn on a view:

i «Double Page

Gutter

= Choose Display from the View menu, and select the view named Gutter.

Hide Al
Add/Edit #E
Delete »
Shoot 4
« Auto Uiew

The Gutter view displays. You will use this view as a visual cue.

To enter text:

“ IS |:| 1 Click Path tool, and then select the Type tool (T).

The cursor changes to an I-beam.

2 Click anywhere inside the workspace.

The Type Tool dialog box appears. There may be a delay as it reads the
font information from the Macintosh system. The length of this delay
depends on the number of fonts that are installed in your system.

3 Set the following values: Font=Helvetica, Style=Bold, Units=Points,
Size=96. Then type the text “1957” in the box.

Type Tool

Font; size: [5 |=)
Style: Leading: Auto [¥]
it spacing Auto 5]

1957

4 Click OK.

The text, in path form, appears beginning at the point where you initially

clicked.
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If a layer bar is selected, then shift-click the layer bar to deselect it.

To prepare for the next step, you want the text to be the only object that
is selected.

Click the mode toggle to switch to repositioning mode.

The repositioning tools appear and a positioning box surrounds the text.
Next you’ll reposition and scale the text.

In the control bar, enter the following values: X=12.75, Y=5.5, W=7.5,
H=9.8. Press Return.

The text is repositioned to fill the right page. In fact, not all Helvetica
fonts are identical. So if your result appears different, then place the
cursor inside the text positioning box and move it so that the text appears
centered within the right page.

To fill the text with color:

1

Choose Monocolor from the Create menu.

A new painting layer is created. As you learned in the introductory lesson,
only a single color can be used in a Monocolor layer. This color can be
changed, even after you’ve finished painting and closed the layer. You will
use this layer to fill the text with a pale red color.

Click the Marquee tool and select the Fill option. (This is the default
choice.)
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3 Click the opacity control of the Marquee tool and drag to 60%.

4 Click the Color Selector and with the Eye dropper, select a red color from
the car.

5 Draw out a rectangle that covers the text.

When you release the pointer, a rectangle of red appears that covers the
text. If it doesn’t entirely cover the text, draw out another rectangle larger
than the last.

6 Choose Path -> Stencil from the Mask menu.
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7 In the dialog box, move the slider to approximately 40 pixels.

Convert Path

’

note: Lhe feather value you set is 40 pixels at the document resolution
you entered when using Document Setup. Thus, the feather is 40 pixels/400
pixels/inch = 0.1 inches. Changing the Document Setup doesn’t affect the
feathering of masks and stencils that have already been created.

8 Click OK to create a stencil.

The text path fills with a translucent red.

Often, when working with text you will want to turn on Antialiasing in
the View menu. Antialiasing ensures that sharp, or hard, text edges are
precisely rendered on-screen. This slows down the screen display some-
what, so you may want to use this feature selectively, for example, to
preview the final result. For the highest quality output when using hard
edged text, select the Antialiasing option in the Build dialog box.

Antialiasing was not turned on in this example because a soft, feathered
edge is used. Thus, edge precision was not necessary.

9 Change the name of the layer to “1957 Red Text.”

Remember, to change a layer name press Command-I and use the Info
dialog box.
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Lesson 11: Entering More Text

In the previous lesson, you created text by converting a path to a stencil and
then filling the stencil with color. In this lesson, you will convert text paths to
a mask. In the terminology of Live Picture, the mask contains opacity
information that is used to reveal the source. Thus, converting a path to a
mask reveals the colored paint at full opacity. This is the simplest way to fill
text with a single color.

To enter more text:

1

Choose Monocolor from the Create menu.

A new monocolor painting layer is created. You will use this layer to
create some additional text.

mote: You can apply text in any type of layer. For example, if you
create text in an image layer, then the image itself is used to fill the text.
This gives the effect of the image appearing through a text outline.
Interesting effects can also be achieved by using text in Sharpen/Blur and
Artwork layers.

Click on the Path tool and select the Type tool (if it is not already selected).
Click anywhere towards the bottom of the image.

The Type Tool dialog box will appear.

In the Type Tool dialog box, set these options:

= Select Helvetica Bold for Font and Style.

= Set Size to 96 points.

= Set Spacing to 125.

Type the word Chevy in the text box and then click OK.

Type Tool

Font; size: [96|[=]
Style: Leading: Auto lzl

spocing: [125 [7]

Chery

(aneer) (o)




60
|

Live Picture 2.0 Tutorial

6 Click the Color Selector and, using the Eyedropper, select the color black
from somewhere on the screen.

The gradient strip in the color bar always contains some black.

8 Select the Create Hard Edged Mask option, and then click OK.

The text transforms to a mask and fills with black at full (100%) opacity.
When using the Path->Mask command the mask is always created at
100% opacity.

9 Click the mode toggle to switch to repositioning mode.
The text is surrounded by a positioning box.

10 Click in positioning box and drag the text so that it is centered at the
bottom of the right page, as shown in the following figure.
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Double Fage

When you select a layer and reposition it, you are manipulating the mask,
stencil, and source material (paint, image, effect or color correction) at the
same time. It is also possible to select layer elements (source, mask,
stencil) individually. Further, you can select multiple layers to be reposi-
tioned together.

Unlike conventional pixel-based image editors, when you scale a paint
layer in Live Picture you are not stretching pixels. Rather, the paint is
regenerated mathematically at the new size.

11 Change the name of the layer to “Chevy Text.”

Press Command-I to rename the layer.
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Lesson 12: Merge a FITS File

The Merge command lets you insert a preexisting composite image, a FITS
file, into an already open composite. This approach offers many possibilities.
For example, you can silhouette a complicated image once and then save it as
a single layer in a FITS file. Later you can insert it into a composite image
using Merge and then scale and position it.

Merge also makes it possible for more than one person to work on the same
image at the same time. For example, one person can be color-correcting and
silhouetting images while the other creates the overall composite, merging the
images one-by-one.

To merge position and resize:

1 Choose Merge from the File menu. First make sure that the Fit in Win-
dow checkbox is on.

=3 Chevy Tutorial ¥ = Robert's 16... Preview
@ Chevy Correction [+

(T Cheuy Lessons

B Route Sign Desktop

[} Route Sign plain _—

| I open I

@}

B Fit In Window

note: Lhe Fit in Window option ensures that the FITS file being
merged appears in the workspace. In effect, it reconciles the position of
the FITS file to be merged with the FITS file that is open. If the file to be
merged uses the same document setup as the open file then it may not be
necessary to use this feature.

2 Locate and select the file named Route Sign.

You will find it in the Chevy Lessons folder. An image of a black and
white route, or highway, sign appears. The route sign is enclosed by a
positioning box. You’ll note that the color of the layer bar is different
from the others. This is because it represents a group of layers.

To position and resize:

1 Click in a corner handle and drag the handle inward, shrinking the insignia
in size. Continue until it looks approximately like the following image.

2 Drag the positioning box until the route sign is squarely in the center on
the right page.
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Lesson 13: Create a Drop Shadow

In this lesson, you’ll learn to create a drop shadow for an object. First, you
create a mask or path for the object. You then copy the mask, or apply the
path, to a paint layer, thus creating a mask or stencil. The paint layer is then
repositioned. In this lesson, you use an existing path to create the drop
shadow. The first step is to ungroup the layers that compose the Route Sign
to retrieve the path.

To ungroup layers:

= With the topmost layer named Route Sign selected, choose Ungroup from
the Layer menu.

The two layers, named Black and White, which formed the group are
added to the layer stack and the group layer bar disappears. Having been
ungrouped, you can now edit the two layers. Both layers are selected.

To retrieve a path:

1 Command-click on the layer Black.
The layer is deselected and White remains selected.
2 Choose Stencil->Path from the Mask menu.

The Compute Path dialog box appears.

Compute Path

3 Click the Retrieve Original Path option.
4 Click OK.

The path that was originally used to outline the sign is retrieved and
appears.
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To create the drop shadow:
1 Choose Monocolor from the Create menu.

A new layer bar appears on the layer stack. Verify at this point that the
Color Selector is set to black. If it isn’t, set the color to black.

Click the Marquee and select the Fill option.

d [ Fin
Erase
Gradient b

2
3  Set the Marquee opacity value to 50%.
4

Draw a rectangle that entirely covers the Route Sign (and the path).

5 Select Path->Stencil from the Mask menu.

The Convert Path dialog box appears.

Convert Path =—F"——

r

[Cancer | [_ox_

6 In the dialog box drag the slider until the feather is approximately 50
pixels.

7 Click OK.

The path is used to create a stencil, which cuts out the black paint. If the
borders of the Route Sign look coarse, you can select Antialiasing from
the View menu. Antialiasing provides better edge definition, thus
improving the screen display.
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8 DPress Command-I.
9 When the Info dialog box appears, rename the layer to Shadow.
10 Click in the close box to close the Info dialog box.

You have now created the drop shadow for the Route Sign. However, it lies
above the Route Sign rather than below it. In the next step, you will change
the order of the layer, moving it below the route sign.

To move the shadow behind the route sign:

» Drag the Shadow layer bar downward until it is between the White and
Chevy Text layers.

The screen redraws and the shadow disappears beneath the sign. Now
you’ll use the positioning tools to offset the shadow slightly.

To reposition the shadow:

1 If the Shadow layer is not selected, click the Shadow layer bar to select it.

It appears framed in blue.

2 Click the mode toggle to switch to the repositioning toolbar.
A positioning box appears that encloses the Route Sign.

3 Drag the positioning box slightly down and to the right.

The shadow will appear on the right side of the Route Sign. Continue to
drag the shadow until it appears just where you like it.
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Lesson 14: Change the Color of the Chevy

You will now change the color of the Chevy, using Live Picture’s Color
Correction layer. A Color Correction layer lets you make color changes that
affect all the layers beneath it. First you select the colors to be changed and
then you define the color transformation. Then you apply the correction, or
color change, with a Brush or Marquee on selected portions of the image.

By contrast, you can apply IVUE Corrections only to single images and their
effect is global. This means that all pixels in the IVUE image are affected.
To begin a color correction:
1 Choose Color Correction from the Create menu.

A new layer bar appears on the layer stack.

2 Click the Selective Correction button in the control bar.

Tolerance

The Selective Color Correction dialog box appears.

Selective Color Correctiol

B Covirnsy ~]

Preview
cancel

note: Lhe Selective Color Correction dialog box is divided into four
parts. The Before preview in the top left shows the composite image prior
to the color correction. The After preview on the top right shows the
result when the color transformation is applied selectively to regions of
the composite. On the bottom left are the controls that let you select the
range of colors to be transformed. You define selectivity in the Hue-
Saturation-Value (HSV) color space. You use the controls on the right to
define the transformation.
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To select the Before color:

1 Click the Before color box on the left hand side and drag the Eyedropper
to a red color in the car, just above the headlamp.

2 Release the pointer to select the color.

To select the After color:

= Click in the After color box on the right side and use the Eyedropper to
pick a purple color. Release the pointer to select the color.

Working in the Hue (H), Saturation (S), Value (V) color space you will now
select all the red areas of the car.

To define the color selection:

1 On the left side of the screen, reduce the range of hues (H) by dragging
the left slider further to the left and the right slider slightly more to the
right.

Since the Chevy’s red color falls in a relatively restricted range of hues you
can get away with working only with Hue selectivity. When working with
images that contain many colors you will want to work with Saturation
and Value selectivity as well.

When you selected purple as the After color, you specified a shift in hue.
Now, you will experiment with color transformation.
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Fill
[EI TN - Horizontal |
Vertical ._

To define the color transformation:

1

On the After side of the dialog box, click the S box to select it and drag
the Saturation slider part way to the left to desaturate, or remove color,
from the car.

The purple color becomes less intense.

| [Cshittusu v

Py

gul:-:—

=S \:—E
N — T

6

Experiment further with Saturation by moving the slider to various points
and observing the result.

What happens when you move the slider all the way to the left, where S=0?
When you’ve finished experimenting with saturation, deselect the S box.

Drag the slider under the Hue bar to various settings and observe the
change in hue when you release the pointer.

When you’ve finished experimenting with hue, click the After color, drag
out the small color bar and select a purple value again.

Click OK to return to the workspace.

Now you’ll apply the color correction using the Marquee.

To apply the color correction:

1
2
3

Click the Marquee, select Gradient, and then select the Vertical option.
Drag a gradient box that covers the double-page view.
In the highlighted box, type 0.

This sets the opacity at the top of the gradient to 0% and 100% at the
bottom.
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4 Click inside the gradient box to preview the gradient. Click outside the
box to apply it.

wote: You can also apply the color correction using the Brush. To experi-
ment further, use the Erase option of the Marquee to erase the gradient
(or choose Undo Marquee from the Edit menu). Then select a medium Brush
and brush in the color correction. Of course you can't create a smooth
gradient with the Brush, but you can produce other interesting effects.
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Lesson 15: Build an Output File

In the previous lessons, you’ve constructed a composite image. Next you’ll
use the Build command to create an output file.

1

Choose Build from the File menu.

The Build dialog box appears.

Set the following values in the Build dialog box.
= Scaling: 33%

= Antialiasing: On

= Color model: CMYK

=  Exportto: TIFF

Outputsize ===

[ Double Page |
Width: 17 Width: [5.61 2249 Pixels
Height: 11 Height: |3.63 1452 Pixels
Scaling

Lnaling: [33 |7 Resolution: dpi Size: 12728 K

-Bﬂll:h
Noise: El % Export to: [_TIFF - (Baten )
[JUse compressed files Color model: [_CMYE_ ¥
[ Antialiasing

[ Server
O tipning Path I Build l

3 Click Build.

A new dialog box appears for you to name the output file.
Type “Chevy TIFF” (or any other name you like), and click Save.

A progress bar indicates elapsed time and percentage complete. You can
interrupt the build by clicking Command-Period. A dialog box appears
and you can either Resume or Stop the build. Interrupting the build lets
you leave Live Picture temporarily to use your computer for other
purposes. When you return, you can continue the build by clicking
Resume. Or, you can terminate the build by clicking Stop.

You’ve just completed the Chevy Tutorial. You can choose Close in the File
menu to close the image. Or, you can continue to explore the image. The
final version of this tutorial project is included in the Chevy Lessons folder
under the name Chevy Final.
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What'’s ahead...
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“Nankoweap,
Grand Canyon”

by Joseph Holmes

HOW IT WAS CREATED

1 Nankoweap

The original photo had too-dark
shadow areas, very pale highlights,
and severe color imbalance.

2 Lighten all but water

A Color Correction layer was used to
lighten all the colors in the image,
except the water.

3 +Saturation overall

Saturation was increased uniformly
across the entire image.

4 Boats
We zoomed to show the extraordi-
nary detail that a 300 MB scan
affords.

Continued...
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“Nankoweap, Grand Canyon”
by Joseph Holmes

About the Artist

Joseph Holmes is a landscape photographer who is quickly making the
transition to digital imaging. His photographs are frequently used in calen-
dars and art posters. Holmes’ last book, Natural Light, was The Nature
Company’s first book and his original photographic prints were their best
selling limited edition artwork for several years running. Holmes makes
extensive use of lighting and color correction techniques to bring his dramatic
vision of nature to life. He is now working on a series of books to feature his
photographs that he is producing digitally using Live Picture.

Overview

In this work, Holmes uses Live Picture to go beyond what could be achieved
using a conventional Cibachrome process. The photo was shot in 1981 at
Nankoweap during a three week rafting trip in the Grand Canyon. Although
the original image was of poor quality due to harsh lighting and a complete
lack of filtration, Holmes felt that if he could get the picture to match his
original vision he would have the greatest photo ever of the Grand Canyon.

The results? In Holmes own words, “I have tried to get this image to look
right and realize its full potential for nearly fourteen years now, by a long list
of complicated procedures, and only now has it finally looked just right.”
The image has been published as a 26" x 32" poster by Image Conscious in
San Francisco.

Layers by Layer

The original photo was a 4" x 5" transparency that had large and very dark
areas of shadow, very pale highlights, with severe color imbalance. It was
scanned on an Optronics ColorGetter, yielding a 220MB image file, suitable
for art quality poster printing.

Nankoweap

Joe inserted the image and color corrected it using Color Curves to
improve the tone and color. The shadows were opened and crossovers
were corrected, mainly by adding red and yellow to the shadows.
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Correct sunny cliffs
Lighten all but water

Using a Color Correction layer, Joe adjusted the hue and brightness of the
sunny areas and brushed in the correction. You can open the Selective
Color Correction dialog box and see the exact color settings that were
used. Joe then used another Color Correction layer to lighten all the
colors in the image, except the water. Using HSV color selection, he
selected all colors except a narrow range of bright unsaturated blue. He
then increased the lightness, or value, by 10% and applied the correction
across the entire image.

Sharpen right cliff tops
Lighten and darken

Joe slightly sharpened the tops of the sunny cliffs to correct a mild focus
problem. He then used the Lighten and Darken options in the Colorize
layer to open up the foreground boulder shadows and darken the water
highlight areas.

+Saturation overall
—Saturation bluer reds

Joe used a Color Correction layer to increase saturation uniformly across
the entire image. This offset the loss of saturation that resulted from the
scanning process. He then slightly desaturated the bluish red areas near
the tops of the more distant cliffs using a Color Correction layer.

Dim lower right

A Colorize layer was used and the Darken option applied with a brush at
7% to selectively darken the lower right region.

+Saturate blues
Lighten rock

Joe increased saturation in the brighter regions of the water. He then
added a Colorize layer and using the Lighten option, opened the shadows

in the big boulder in the lower right. What's chead...
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“The Rose”

by Anthony Redhead

1 Temple
The original photo of the
Temple is positioned and
cropped.

2 Temple Background
Temple is duplicated, changed
to black and white, cropped
and a white gradient applied.

3 Rose
A Rose is inserted and
silhouetted using Live Picture’s
automasking feature.

4 Inverted Rose

The Rose is merged on top of
Temple Background and
inverted.

Chapter 4

The Rose Tutorial is a complete project. It builds upon what you learned in
the Chevy Tutorial, but it does not require that you have completed the
Chevy Tutorial beforehand.

The Rose Tutorial introduces you to Live Picture’s powerful silhouetting
feature. Image silhouetting is an alternative to path tools for creating
complex masks.

In addition, the Rose Tutorial gives you more practice copying masks and
stencils between layers.

All the files you need for the tutorial are found in the Rose Tutorial folder on
the Tutorial Disk.

File or folder name Description

Rose, Temple Image files in IVUE format

Rose/C, Temple/C Compressed image files in IVUE format
Rose TIFF Output file in TIFF CMYK format that can be

printed or viewed

Rose Lessons This folder contains one reference file for each
lesson (except for the first). It also includes
Rose Final, the final FITS file.

In the folder named Rose Lessons you will find a reference file for each
lesson. The reference file is the FITS file that you can use to start the lesson.
For example, if you are about to begin lesson 3, you can choose Open FITS
in the File menu. When the Open dialog box appears, select the folder named
Rose Lessons and then double click on Rose 3. Then you can follow the
instructions in lesson 3.

Each of the FITS files is sized for a 13" monitor. If you are working with a
larger monitor, open a FITS file and click the grow box in the document
window or use the resize box to increase the size of the window. Next,
choose Go To in the View menu and select the Rose view to magnify and
center the image.

If you continue from one lesson to the next, you do not need to load the FITS
file for the new lesson since you will already have created it.
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Lesson 1: Set Up a New Document
First you will start Live Picture and use the Document Setup command to

define the layout of the composite image.
To start Live Picture:

= Double-click the Live Picture icon.

To setup the new document:
1 Choose Document Setup from the File menu.

The Document Setup dialog box appears. This box lets you define the
initial view, background color of the workspace, and the resolution (in
pixels) assigned to the rulers.

Document Setup

& Define Initial View

Size Orientation
Width: units
set Background Color ... Resolution:

2 Ifitis not already selected, click Define Initial View.

Live Picture creates the first view at the specified dimensions. A view
defines the layout of the composite image that you will create in this
tutorial.

3 Enter the dimensions of the initial view. Click the Width box and type 8.
Press Tab, and in the Height box type 11.

4 Choose Inches from the Units pop-up menu.
5 Type 300 in the Resolution box.

This sets the workspace rulers to 300 pixels per inch (ppi).
6 Click New.

A new document with an initial view that is 8 inches wide by 11 inches

high.
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The initial view size, units and resolution are saved in the preferences.
The next time you create a document using the same settings, choose
New from the File menu.

Change the name of the view

Each view has a name. An initial, or default, name is assigned by Live
Picture. But it is a good practice to rename views that you define, giving them
names that are more meaningful. Since there is only one view in this tutorial,
name it simply “Rose.”

To change the name of the view:
1 Choose Add/Edit from the View menu.

Live Picture places you in view mode where you can add, edit, and delete
views.

Click the name of the view “View 1.”

N

The view box is selected and the name field changes color.

3 Type the name “Rose” and press Return.

4 Click outside the view box to deselect the view.
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Lesson 2: Insert an Image

Live Picture was designed to be the ultimate tool for creating composite
images. By composite image we mean images that combine one or more
photos and may also include painting, color changes and special effects. This
lesson focuses on the first step in creating a composite image by showing you
how to insert, position, scale and crop a scanned image. Live Picture’s unique
contribution is to let you perform these actions in real-time, that is, with no
delay, regardless of the size of the image.

To open the image:

1 Choose Image Insertion from the Create menu.

The Insert Image dialog box appears for you to preview and select image
files to be inserted into the composite.

‘3 Rose Tutorial ¥ = Roberts 16...
D rese E

O Rose Tutorial Lessons
O Temple Desktop

H Gl

File
size: 69.28 MB

Dimensions: 2.7 8 2.13in,
Resolution: 1540 dpi

O Aute Insert [JUse Alpha Channel Preview

2 Deselect Auto Insert, if it is selected.

Auto Insert bypasses the positioning tools and opens the image, centers it,
and inserts it automatically at 100% opacity into the workspace. In this
lesson you will position the image precisely rather than use Auto Insert.

3 Locate the file named “Temple.”

Temple is a pixel image file in the IVUE format. It is located in the folder
named Rose Tutorial.

4 Double-click on the name “Temple” in the list of files to open and display
the image.

You can also select the name Temple by clicking it once. Then open the
file by clicking again or pressing Return.
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Scale the image
Once you’ve opened an image, Live Picture switches to the insertion mode

where a set of image positioning tools is available. You’ll use the Scale and
Crop tools to fit Temple precisely inside the view.
To scale the image:
1 Choose Show Rulers from the View menu.
Displaying the rulers is useful when you perform precise positioning.
2 Verify that the Opacity control is set to 100%.

The Opacity control is at the bottom of the toolbar. If the opacity is not
100%, then set it to 100%.

If it’s not already selected, click the Scale tool.

4 Click the bottom center handle of the positioning box and drag it up or
down (as necessary) to scale the image until it just covers the bottom of
the view.

The image should cover the view on the top and bottom. Don’t worry
about making it fit exactly. You’ll notice that when the cursor is placed on
a handle it changes to an icon representing the scale tool.
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Click the right center handle and drag it to scale the image horizontally
inwards until it just covers the right and left sides of the view.

At this point the image should entirely cover the view. Again, don’t try to
make it fit exactly.

You can experiment freely with the Scale tool at this point. If you drag one of
the corner points, the image retains its width-height proportion as you scale
it. Click a middle point on either side to scale horizontally, or click a middle
point on the top or bottom to scale vertically.

Crop the image
Now that the image has been scaled up and covers the entire view, you’ll crop
it precisely to the dimensions of the view.

To crop the image:

st

Click the Crop tool.

When the Crop tool is selected, the Size W and H fields (width and
height) in the control bar show the dimensions of the cropping box. The
cropping box is the rectangular area of the image that is visible.

Click in the Size W entry field and type 8 for width.
Press Tab and type 11 in the H field for height.
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4 DPress Return.

The image crops to the same dimensions as the view. Portions of the
image outside the cropping box are no longer visible. Now you will move
the box precisely over the Rose view.

Position the image
1 Drag the X-point to the top left handle and release the pointer.

The X-point is marked by a cross and is initially found in the center of the
image. When the X-point gets near to the handle it snaps into place.

2 Click in the X coordinate field in the control bar and type 0.

Press Tab to move to the Y coordinate and type 0.

4 Press Return.

The cropping box will align itself to exactly cover the view. Although the
cropping box moves, the underlying image does not.

Fis Click the mode toggle to access the creative tools.

At this point, Live Picture creates both a mask and stencil for the image.
The stencil corresponds to the cropping box and defines the visible
portion of the image. The mask defines the opacity of the image at each
point. You can modify the mask and stencil independently.
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Change the Name of a Layer
Live Picture automatically creates a layer named “Insert Temple” that is now

at the top of the layer stack.
To change the name of the layer:
1 Press Command-I to open the Info dialog box.

2 In the Name box, type “Temple” for the new name.

EM=———— Insert Temple Info
Name
“Hemple
—Image Position
Origin H -0.057 Size W 8.117 Scale WV 58.6% Aotate 0°
¥ -0.191 H 11.385 H 104.1 Skew ©0°
—lmage File
Name: Robert's 16B YMF:LP 2...:Rose Tutorial:Temple
Size: 69.28 MB
Dimensions: 2.7 % 2.13 in.
Resolution: 1540 dpi Substitute Image...

3 Click the close box.
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Lesson 3: Duplicate a Layer, Change Color and Cropping

In this lesson you’ll create a duplicate version of the Temple. Then you’ll
change it to black and white, redefine its cropping, and finally you’ll save the
image.

Duplicate a Layer

At this point the layer named “Temple” should be selected. You can tell that
a layer is selected if it is framed in blue. If Temple isn’t selected, then click its
layer bar to select it.

To duplicate a layer:

= Option-drag the layer named “Temple” slightly upwards and release the
pointer.

First, the frame will change color. Then, a duplicate layer is added on top
of the previous one and a new layer bar is added to the layer stack. The
new layer is now selected.

Change Image to Black & White
Next, you will use a Preset to change Temple to black and white.

To change the image to black and white:

1 Choose IVUE Correction from the Layer menu and then choose
Black&White from the Presets submenu.

The top image of the temple turns to Black& White. Now change the
name of this layer to distinguish it from the color layer below it.

2 Press Command-I and, in the Info dialog box, type the name “Temple
B&W.”

3 Then click the dialog box’s close box.
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Recrop the Image

At this point the black and white version of the Temple is lying directly on
top of the color version. You will recrop the black and white temple to yield
the effect of a single image where part is black and white and part color.

To recrop the image:

1

Lo

If the topmost layer “Temple B&W? is not selected (framed in blue) then
select it in the layer stack by clicking once on its layer bar.

Click the mode toggle to switch to positioning mode.

The positioning toolbar appears and the positioning box surrounds the
Temple image.

Click the Crop tool.

The width and height of the cropped image appear in the control bar.
Drag the X-point to the top left handle and release the pointer.

The X-point snaps into place as it gets near to the handle.

Click in the Size W field in the control bar, type 3 and press Return.

By recropping the image you have redefined the size of the stencil. The
new stencil lets you see only a 3" strip on the left side of the black and
white version of the temple image.

Scale Rotate

Skew
Lbsiin

Ll

[

Rosg
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Lesson 4: Create a Gradient
To complete the background part of this composite you’ll use a vertical

gradient on the black and white temple.
To create a gradient:
1 Choose Monocolor from the Create menu.

Live Picture creates a new layer and a layer bar is added to the layer
stack.

2 Choose Show Coordinates from the View menu.

The X-Y coordinates of the cursor appear in the upper right corner of the
control bar.

- 3 Click the Color Selector and position the Eyedropper over the color
white, which you find inside the gradient strip. Release the pointer to pick
white.

The gradient strip runs above the color bar. Among the colors in this strip
you will always find white (and black). Note that the RGB value for
white is R=255, G=255, B=255. You can also select a white from any-
where else on the screen.

EETTmy roizona | 4 Click the Marquee, and then select the Gradient Vertical option.

Vertical ._

5 Draw a gradient box from approximately the point x=0, y=5 to the point
x=3.3, y=11.5. To do this you position the cursor to the first point (x=0,
y=35), then you click and drag with the pointer downwards and to the
right until the coordinates are approximately (x=3.3, y=11.5). Release the
pointer to finish.

If the box doesn’t look something like this picture, click outside the
gradient box and try again.
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g 6 Set the top opacity value to 0%.
7

S

b Cradien

¥ Temple B&5W

Click inside the gradient box to apply the white gradient. Click outside
the box to deselect the gradient box.

8 Press Command-I and, in the Info dialog box, type the name “Gradient”.

Copy a Stencil
The white gradient overlaps the color temple somewhat, which looks messy.
You can use a stencil to clean this up.

To copy a stencil:
1 Click the layer toggle in the layer bar named Gradient to open it.
2 Click the layer toggle in the layer bar named Temple B&W to open it.

3 Option-drag the stencil icon from the layer named Temple B&W on top
of the stencil icon of the Gradient layer. Release the pointer.

When you copy the stencil you’ll notice several things. First, when you
Option-click the stencil icon it is immediately framed in red. Then, the
stencil icon that you drag to changes color to show that the copy opera-
tion can be performed. When you release the pointer, the stencil icon
inside the Gradient layer changes to show that it now has a stencil.

You have just copied the cropping box (stencil) from the Temple B&W
layer to the Gradient layer. The stencil only allows the white to show
inside the cropping box. You could have accomplished the same thing by
creating a new path using the path tools, and then converting it to a
stencil.

The first three icons in the layer bar are used to manipulate the layer ele-
ments. The layer elements are the source, the mask, and the stencil. The
source is the basic material of the layer. For example, the source material for
the Monocolor and Multicolor layers is paint.

The mask element defines the opacity of the source material at each point in
the layer. The source is visible at points where the opacity is greater than 0%.
If the opacity is 100% then it is impossible to see through the source to
lower layers.
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The third layer element, the stencil, is not always present. The stencil defines
an outline or shape that further constrains the visible area, defining an
exterior and an interior region. By dragging down the menu associated with
the stencil icon you can either select the stencil’s interior or its exterior to be
visible, or you can toggle the stencil on and off.

The fourth icon, the eye, indicates whether the layer is visible or invisible
(showrhide). By clicking the eye you can turn the layer off and on.

For more information on layer elements see Chapter 3 in the Live Picture
User Guide.

Save your work
As with any application program, it is a good practice to save your work

frequently.

To save your work:

1 Choose Save FITS in the File menu.
A standard Save dialog box appears.

2 Click New to create a new folder. At the prompt, type the name “My
Rose.” Press Return or click Create.

A new folder is created where you will save working files.

3 In the Name box, type “Temple Background.”

4 Press Return or click Save.

If you want to quit Live Picture at this point, choose Quit from the File
menu.

5 Choose Close from the File menu.

You’ve now created a composite background image that combines two
images and to which you’ve added a white gradient. This image will be used
as the background later in the tutorial.
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Lesson 5: Silhouette an Image

This lesson introduces you to some of Live Picture’s tools for silhouetting
images. To silhouette an image means to separate one or more objects in the
image from the background.

The Image Silhouette layer lets you access many powerful tools and options.
But for this tutorial you will work with a relatively simple example of a rose
on top of a blue background.

It is difficult to tell you exactly how to use a Brush, so it is possible that your
results will vary somewhat from the example. If at any point your results are
very different from what you see here, then just start over from the beginning
of the lesson.

Create a New Document
You will create a new document using the Document Setup dialog box

options that were previously defined and then insert the image to be
silhouetted.

To create a new document:

1 Choose New from the File menu.

A new document appears that uses the previous document setup. This is
important because when you later merge the two files, they will have a
common layout.

2 Choose Hide All from the View menu.

During silhouetting, it’s best to work with an uncluttered screen.

To open an image:
1 Choose Image Silhouette from the Create menu.

The Insert Image dialog box appears.

3 Rose Tutorial ¥ — Robert's 16...
D Rose

[ Rose Tutorial Lessons
0 Temple Deskiop

5' Open |

2]

]

File

Size: 69.28 MB
Dimensions: 2.7 # 2.13 in.
Resolution: 1540 dpi

[ Aute Insert [JUse Alpha Channel Preview
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2 Select the Auto Insert option.

When you silhouette an image, it must be entirely visible on the screen.
You cannot pan or zoom during the actual image silhouetting. This
approach lets you silhouette images very quickly. Once you’ve silhouetted
the image, you can pan and zoom freely while you refine the mask that
has been created.

3 Double-click the file name “Rose” to open the image.

Mask the Outside

There are four steps in silhouetting: (1) define the outside of the object to be
silhouetted, (2) define the inside of the object, (3) retouch the mask, and

(4) compute the mask. In fact, you can move freely between steps 1-3,
changing, revising, improving the mask, before computing.

To mask the outside:

TS 1 Click the Tolerance control in the control bar and set it to 40%.

The default setting is 40% but you should set it just to get acquainted
with this useful option. A higher tolerance means that more colors are
selected when you brush. A lower tolerance selects fewer colors.

Hold down the shift key as you move the slider to constrain it to incre-
ments of 10.

oy 2 Click the Outside color box, just to the right of the word “Outside” in
the control bar.

A red frame appears around the outside color box. Now you will mask
the blue area outside the rose. It’s easier to create the outside mask first
because it consists of a single color.

mey 3 In the Outside color palette, select the color yellow.

E You don’t want to use the color green since the object you are masking,
the rose, contains green. It’s best to pick a color that strongly contrasts.
ZRuty 4 Click the Brush, and verify that the Auto option is selected.

Fill
Selective
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5 Draw a line in the bottom left of the image making sure to stay in the
blue region, and carefully avoiding the green stem. With this action you
are selecting a range of colors to include in the mask exterior.

When you release the pointer, Live Picture changes the blue background
to yellow for all colors in the selected color range. If you made a mistake
and touched the green or red part of the rose, choose Undo Brush Stroke
from the Edit menu.

6 If all the blue has not been covered, paint carefully over the blue areas not
yet covered.

Continue until all blue areas outside the rose have been painted.
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Mask the Inside
1 Click the Inside box in the control bar.

A red frame appears around the inside color box.
2 Make sure that Exclusivity is set On.

Exclusivity On means that no part of the image exterior will be included
in the mask that you are now going to create.

T 3 Set the Tolerance to 100%.

With Tolerance set to 100% as you brush, all colors will be included in
the mask.

4 Brush over the rose.

Because Exclusivity is on, you don’t have to worry about brushing in the
yellow area. The rose should now be covered with transparent red.

m 5 Click the Compute Mask control in the control bar.

The Compute Mask Options dialog box appears.

Compute Mask Options

Computing Mode: ( Compute ]
Edge Precision: O Hard edge
Maximum transition edge: El pirels
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6 Set the mask parameters and click Preview.
The parameters to be used are:
= Computing Mode: Color Compensation
= Edge Precision: High
= Hard Edge: Off
= Maximum Edge Transition: 20 pixels

Live Picture performs a rapid computation of the mask, at screen resolu-
tion, and displays the result.

wote: Lhe color compensation option ensures that the masked image
merges nicely with any background. It does this by color compensating the
edge of the masked image to slightly reflect the ambient background color.
Images silhouetted with this feature will not look cut out when they are set
against very different backgrounds.

Retouch the Mask

It is common for an object to contain traces of the color of its surroundings.
If you look closely, you’ll see that the rose contains the reflected blue of the
background on several of its leaves and on its stem. This can cause problems
since it is difficult to determine the boundary of an object if the same color is
found both inside and outside of it.

The retouching step lets you intervene in trouble spots like this one to make
minor modifications to the mask before initiating the final computation.
To retouch the mask:
1 Click Retouch in the Compute Mask Options dialog box.
2 Select the smallest brush from the Tool Size control.
3 Click the Brush.

Set the brush opacity to 100%, if necessary.

4 Brush slowly and selectively over the leaves and the flower. Try to be
accurate in this step; however, you shouldn’t need to spend more than a
few minutes.
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Brushing over a leaf forces the mask to 100% opacity at this spot. Brush
only in the center of each leaf, being careful not to go outside the leaf;
otherwise you’ll bring back the blue background.

If necessary, use the Eraser to eliminate the blue background. Click the
Eraser, and brush carefully on areas where the blue is present.

For example, in this image we’ve found that there is often a trace of blue
around the clipped base of the rose stalk, on the far left. This should be
eliminated using the Eraser.

Compute the Mask

1

Click the Compute Mask control in the control bar.
The Compute Mask Options dialog box appears.
Click Compute.

Live Picture computes the full-resolution mask. A small square zips across
the screen, showing you the line that is being computed. This may take a
few minutes.

Press Command-I to open the Info dialog box. Type “Rose” for the new
layer name, and then click the close box.

Choose Save FITS from the File menu.
Type the name “Rose Masked” and click Save.

Choose Close from the File menu.
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Lesson 6: Merge a FITS File

At this point you’ve created two different composites, the Rose Masked and
Temple Background, each saved in a different file. Now you’ll merge the two
files together.

You could have inserted and silhouetted the rose directly on top of the temple
background. However, the fact that you’ve created a separate file for the rose
means that it can be used conveniently in other composite images.

Open a FITS File

1
2

Choose Open FITS in the File Menu.

Locate and select the file named “Temple Background” by double-
clicking it.

You will find Temple Background in the folder named “My Rose” where
you saved it.

Live Picture opens and displays Temple Background.
Choose Merge from the File menu.

In this case, the option Fit To Window is not necessary and should not be
checked, since both composites were created using the same document
setup.

Double-click “Rose Masked.”

The silhouetted rose appears on top of the Temple Background and
enclosed in a positioning box. Next you’ll rotate the rose.

In the control bar, click the downward triangle next to Rotate, and then
select -90° from the pop-up menu.

The rose rotates -90° counterclockwise. Now scale the image so that it fits
inside the view.

Click a corner handle and drag inwards until the rose fits inside the view.

The rose should now be centered inside the view. If it is not, drag it to the
center of the view. Don’t worry if the positioning box slightly overlaps the
view.
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Lesson 7: Create a Drop Shadow
There are many ways to create drop shadows in Live Picture. We’ll use

perhaps the simplest method in which you apply an existing mask of an
object to a layer of transparent black paint and then reposition the black
shadow.

To create a drop shadow:

1 Select Monocolor from the Create menu.

A new layer is created and a layer bar is added to the layer stack.

2 Press Command-I to open the Info dialog box. Type “Rose Shadow” for
the new layer name, and then click the close box.

3 If the Color Selector is not black, set it to black by picking black off the
gradient strip or anywhere else on the screen.

HEE s Y

4 Click the Marquee and select the Fill option.
5 Set the Marquee opacity to 70%.
6 Draw a gradient box that entirely covers the rose.

If you make a mistake and the gradient box doesn’t entirely cover the
rose, choose Undo from the Edit menu and try again.

7 Option-click the layer toggle in any layer bar.

All of the layer bars open up.

97
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8 Option-drag the mask icon in the Rose layer to the stencil icon in the
Rose Shadow layer above it.

When you Option-click on the mask icon it is framed in red. The stencil
icon in the Rose Shadow layer changes color when the Rose mask is
positioned on top of it.

ip: If you had copied the mask from the Rose layer to the mask of
the Rose Shadow layer, the shadow would have become opaque; that is, it
would have lost the 70% opacity setting. This is because the mask of a
silhouetted image, the Rose in the case, is 100% for the interior region.

When a mask is copied to a stencil, the outline of the object is used to
define the stencil. The existing mask, which in this case is 70% transpar-
ency, is retained.
To position the shadow:
1 Click the mode toggle to access the positioning tools.

2 With the Rose Shadow layer selected, drag the positioning box slightly to
the right to give the effect of a shadow.

P 3 Click the mode toggle to return to the creative tools.

4 Drag the top layer bar, Rose Shadow, down between the Rose and
Gradient layers.

The Rose Shadow moves below the rose.
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Lesson 8: Copy and Invert an Image
You’ll now make a duplicate of the Rose layer and invert its color. You’ve

already used one IVUE color correction, the Black& White preset. Now you’ll
use a second to invert the Rose.

To make an inverted copy of the Rose:

1 If the layer bars are closed at this point, press the Option key and click
the layer toggle in any of the layer bars.

All layers open immediately.

2 Duplicate the Rose layer by holding down the Option key, clicking the
Rose layer, and dragging it upwards slightly, until the frame changes
color. Release the pointer.

A new layer bar appears at the top of the layer stack.

3 Choose IVUE Corrections from the Layer menu and then choose Invert.

The top Rose image immediately inverts.

%
’T
=1
-]
=5
’»7
=9
]

note: Invert and all the other IVUE Corrections act on a single IVUE
image. You can apply an IVUE Correction to any image layer. It doesn’t
have to be the top layer. No other layers are affected. You can remove the
correction by choosing Undo Corrections from the IVUE Corrections
submenu. Undo Corrections removes all IVUE Corrections that have been
made to an image but does not affect IVUE Corrections made to images
in other layers.

4 Press Command-I to open the Info dialog box. Type “Inverted Rose” for
the new layer name, and then click the close box.
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5 Option-drag the stencil icon from the layer named Temple B&W to the
Inverted Rose stencil icon.

In doing this you copy the stencil from the black and white temple to the
inverted rose image. This stencil defines a rectangle that covers the
leftmost three inches of the composite. As a result, you will only see the
inverted rose within this stencil, above the black and white temple.

6 Choose Save FITS As from the File menu.
7 Name this image “Rose Final” and click Save.

At this point you’ve created the final image. But, rather than stop here,
you will examine some of the interesting properties of this image.
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Lesson 9: Reposition Layer Elements

After completing a version of your project, your client may want to change
the position, size, or color of one of the elements in the composite. Because of
its unique layering capability, Live Picture lets you make such changes
immediately.

To reposition selected layer elements:
1 Option-click a layer toggle in any layer bar.
All the layer bars will close at once.

2 Click on the Inverted Rose layer triangle to open the layer.

3 Shift-click the Rose Shadow layer and the Rose layer. Then, while still
holding down the Shift key, hold down the Option key and click the
source and mask elements in the Inverted Rose layer.

4 Click the mode toggle to access the positioning tools.

The positioning toolbar appears and a positioning box appears around
the rose.

5 Move the rose and shadow around by dragging the positioning box.

Of course youw’ll notice that the Rose appears inverted within the black
and white box and everywhere else it is normal colored. You can use any
of the positioning tools—scale, rotate, flip, etc.—at this point. Take your
time and experiment with the positioning tools.

The secret to this effect is that the Inverted Rose is on top of the Rose but it is
only visible through its narrow rectangular stencil. Everywhere else, you see
the (noninverted) Rose. Because you did not select the stencil of the Inverted
Rose to be repositioned, the stencil does not move as you move the Rose and
Inverted Rose.

You’ve now completed the Rose tutorial. You can use this completed image
as a starting point to create your own variations.

What'’s ahead...
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“Broken Heart,” 12, 19-21
Brown, Jeff, 19-21
Brush tool
color correction and, 69
creating layers and, 25, 26

distortion effects and, 48

lightening/darkening effects and, 50
location of, on the toolbar, 18
modifying image opacity and, 45
regulating brush pressure, 25
silhouetting and, 90, 92, 94-95
Build (command), 70
Build dialog box, 58, 70

C
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Brightness/Contrast, 20, 4647
copying images and, 99



IVUE color correction, 20, 46-47, 66, 835,
99-100

undoing, 46, 69, 99
Color Correction dialog box, 66

Color Correction layers, 42. See also color
correction

basic description of, 46, 66-69

in “Nankoweap, Grand Canyon,” 73, 74-75
Color Presets folder, 46
Color Selector (tool control)
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Create Hard Edged Mask, 60
creative mode, basic description of, 17
creative toolbar, basic description of, 14
cropping. See also Crop tool
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duplicating. See copying
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edge definition
antialiasing and, 64
precision settings, 94
Eraser tool
distortion effects and, 48
gradients and, 54
lightening/darkening effects and, 50
location of, on the toolbar, 18
opacity and, 45
silhouetting and, 95
Exclusivity On, 92
Eyedropper
color correction and, 67
creating layers and, 25
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handling text and, 57, 60
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F
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Get Info, 13

ghosting, definition of, 53

Gofrey, Anna, 23

Goto, 40

Go To (command), 48, 77

gradient boxes
basic description of, 53-54, 87-89
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Holmes, Joseph, 73-75
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75

1
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Image Clone layers, 20, 21, 42

Image Distortion layers, 42
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Image Vue, 43

Info dialog box, 52, 58, 85, 88, 95, 97, 99
Insert Image dialog box, 42, 80, 90-91
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inserting preexisting images into FITS files, 62
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scaling images and, 81

installation, 9-13
Custom, 10-11
the Read Me First document and, 12
Standard, 9-10
Tutorial, 12-13

inverting images, 99-100

IVUE files, 12-13, 43, 77, 80
contents/formatting of, 43
converting files to, 43
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keyboard conventions, 8
Kodak Premiere, 20

L

layer(s). See also layers (listed by type)
applying text to, 59
copying, 85-86
creating, 24-25, 26, 42
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layer bar, 15, 56
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types of, 24, 42

ungrouping, 63

layers (listed by type)
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Blur layers, 42

Color Correction layers, 42, 46, 66-69, 73,
74-75

Colorize layers, 42, 75
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56-61, 64, 87-88, 97

Multicolor layers, 26, 28-29, 42, 88
Sharpen/Blur layers, 23, 33, 49, 59
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Live Picture

basics, 21-35

“Fat Binary” version, 9
installing, 9-13
quitting, 46, 88
resolution quality in, 28
serial number, 23
starting, 23-24

system requirements, 8

user interface, overview of, 14-17
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[\ | Monocolor layers, 24-25, 42
main window, diagram of, 16 creating drop shadows and, 64, 97
Marquee tool creating gradients and, 87, 88
blending images and, 53, 54 handling text and, 56-61
blurring images and, 49 moving, 28-29
color correction and, 68—69 in “Soaring Computers,” 35
distortion effects and, 48 Multicolor layers, 26, 42
drop shadows and, 97 creating gradients and, 88
Erase option, 69 moving, 28-29
gradients and, 87 N
Fill option, 54, 56-58, 64, 97 naming
location of, on the toolbar, 18 layers, 15, 16, 26-27, 58, 84
opacity settings, 45, 57, 64 views, 40-41, 79
text and, 56-58 “Nankoweap, Grand Canyon,” 12, 72-75
mask(s) Natural Light (Holmes), 74

automatic, 35, 77 The Nature Company, 74

computing, 91, 93-95
o

opacity, 44, 60
Auto Insert and, 42, 80
blur effects and, 49
changing, through ghosting, 53

converting paths to, 59-61

creating drop shadows and, 97, 98
that define image opacity, 45, 83, 88
hard-edged, 60, 94

icon, location of, on the layer stack, 16
retouching, 91, 94-95

memory

color correction and, 68-69
control, location of, on the toolbar, 18, 81
document resolution and, 39 drop shadows and, 98
gradients and, 88
masks that define, 45, 83, 88
silhouetting and, 95
Open dialog box, 37, 77
opening
FITS files, 37, 77, 96
images, basic description of, 42-43, 80, 90

system requirements and, 8, 13
menu bar, location of, 16
menus, pop-up, tool options in, 14
merging FITS files, 62, 96
Minimum Size settings, 13
mode toggle, 29, 30

basic description of, 14, 41

. . L reference files, 37
location of, in the main window, 16 >
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Option key, 28

Optronics ColorGetter, 74
output files, building, 70
Outside color box, 91

Outside color palette, 91

P

Palette Knife
basic description of, 30-31
Blend option, 48
location of, on the toolbar, 18
panning. See also Pan tool
actions, avoiding multiple, 40
rendering a screen and, 29
silhouetting and, 91
PANTONE color pickers, 9, 10, 11
Pan tool. See also panning
basic description of, 27-28
location of, on the toolbar, 18
pasting images, 45, 52
Path->Mask, 60
paths
converting, to masks, 59-61
converting, to stencils, 55-58, 64
retrieving, 63
text, 55-58
Path->Stencil, 57, 64
Path tool, 59
perspective, applying, 18, 23
Perspective tool, 18
pixels. See also resolution

feather value settings and, 58
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pop-up menus, tool options in, 14
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positioning images, 51, 83. See also positioning
tools

basic description of, 4445
merging FITS files and, 62
positioning layer elements, 101
positioning shadows, 65, 98

positioning tools. See also positioning images
basic description of, 14, 17, 44-45
bypassing, 42, 80

Preferred Size settings, 13

preset layers, 4647

Pressure Control (tool control), 18, 49

previewing
brightness/contrast adjustments, 47

color corrections, 66

Q

quitting Live Picture, 46, 88

R
Radial Brush, 48

RAM (random-access memory), 8, 13
Read Me First document, 12
Redhead, Anthony, 37, 77
rendering

controlling, with Quick Preview, 29

definition of, 29
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resolution. See also pixels
definition of, 39
quality, in Live Picture, 28, 34
screen rendering and, 29

setting, in the Document Setup dialog box,
38, 39,58

retrieving paths, 63
RGB (Red-Green-Blue) color space, 87
“The Rose,” 12, 13, 23, 77-101
Rotate tool, 18
rotating images, 18, 45, 96
rulers

blending images and, 53

displaying, 39

setting, 78, 79

S
Save dialog box, 88

saving
copied images, 100
FITS files, 30, 62, 88, 95
merged images, 62
Scale tool, 81, 82
basic description of, 44—45
building output files and, 70
document setup and, 39
location of, on the toolbar, 18
scaling images, 61, 39—-435. See also Scale tool
scanning photographs, 74
screen. See pixels; resolution

Selective Color Correction dialog box, 37,
66,75

serial numbers, 23

setup. See Document Setup dialog box

shadows
creating, 63-66, 97

moving, 65

in “Soaring Computers,” 33, 34, 35

Sharpen/Blur layers, 23, 33, 49, 59
Shimmer, 48
Show Rulers, 39
silhouettes
basic description of, 90-96
in “The Rose,” 77
in “Soaring Computers,” 33, 35
skewing, 18, 45
Skew tool, 18
“Soaring Computers,” 33-35
software
personalizing, 23
registering, 8
Source icon, 16
source image thumbnail, 15, 16
starting Live Picture, 23-24
stencil(s)
copying, 88-89, 100
creating, 83
filling, with color, 56-58
icon, location of, 16
redefining the size of, 86
in “Soaring Computers,” 35
Stencil->Path, 63
stylus, 8

system requirements, 8
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technical support, 8
text
creating/applying, 37, 55-62
entering, 55
filling, with color, 56-58
TIFF format, 12, 37, 70, 77
toggle
location of, on the toolbar, 18
switches, on the layer stack, 15
Tolerance control, 91-92
toolbars
basic description of, 14
diagram of, 17

switching between, using the mode toggle,
14, 41

Tool Size (tool control), 16, 48, 50, 94
creating layers and, 25
location of, on the toolbar, 18

Tool Style (tool control), 18

Type tool, 21, 55, 59

Type Tool dialog box, 55, 59

U

undo actions
for blur effects, 49
for color corrections, 46, 69, 99
for distortion effects, 48
for drop shadow effects, 97
for lightening/darkening effects, 50
for silhouetting effects, 92, 95

units of measurement, 39
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\"/
Vertical Flip tool, 18

view(s). See also panning; previewing; zooming
Auto View feature, 42
defining initial, 38, 78, 79
changing the name of, 40-41, 79
creating new, 40—41

deselecting, 40
Double Page view, 37, 49
Gutter view, 48, 55
as preset display areas, 40
turning on/off, 48, 55
view toolbar, 14
Visibility icon, 16
W
window, main, 16
workspace
basic description of, 14
diagram of, 16
pasting images into, 45, 52
XYZ
X-point
adding new views and, 41
positioning images and, 44-435, 51, 83
zooming
actions, avoiding multiple, 40
basic description of, 27-28
rendering screens and, 29
silhouetting and, 91
Zoom tool
basic description of, 27-28

location of, on the toolbar, 18
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