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Welcome to Suitcase™ 10! Suitcase 10 is a
powerful font management utility that makes
working with fonts faster and easier than ever
before. 

With Suitcase you can group fonts and open
them only when you need them, saving
valuable system resources. You can even have
Suitcase open fonts automatically when an
application is launched. 

Included with Suitcase 10 for Macintosh are
these utilities: MenuFonts, a control panel that
allows you to view fonts in font menus in
WYSIWYG format, FontBook from LemkeSoft, a
utility that allows you to preview and print
your fonts in any of 24 different templates, and
Suitcase XT, an XTension™ for QuarkXPress
that automatically opens missing fonts in
QuarkXPress documents.

Suitcase 10 also offers the ability to keep fonts
synchronized with other Suitcase users (Suitcase
9.0 or later) when using a Suitcase Server.
(Suitcase Server is sold separately. Visit our website
http://www.extensis.com, or call 1-800-796-9798.)

System and Software
Requirements

This Suitcase package is for Macintosh, but
Suitcase is also available for Windows!
Contact your local retailer, or visit our
website at http://www.extensis.com, or call
1-800-796-9798.

To install and use Suitcase, you will need the
following:
• Macintosh® PowerPC® or compatible
computer

• 32MB RAM

• 8MB free hard drive space

• Mac OS® System 8.6 through 9.1

• Adobe Type Manager® (ATM) Light 4.6 or
higher

• To use Suitcase Online Help: Suitcase requires
version 4.0 or later of Netscape Navigator/
Communicator or Microsoft Internet Explorer.

Installation
You can find instructions for quick and easy
installation on the CD-ROM that is included
with your product or, if you downloaded an
Extensis product installer from our web site,
running the installer will place an informational
Read Me on your hard drive.

Registration
It is important to register your copy of Suitcase
so we can provide you with the best possible
service. Registered users of Suitcase are eligible
for technical support, information regarding
new versions and products, discounts and
special offers on new products. 

Your registration number is located inside the
CD package, or was sent to you via email if you
purchased through our website. Enter that
number to personalize your copy of Suitcase. 

If you choose not to personalize your copy,
Suitcase will run in a demonstration mode that
allows you to use the product for 30 days. You
can purchase this product in the US at 1-800-
796-9798 or 1-503-274-2020. In Europe call +44
(0)1604 636 300.

Introducing Suitcase 10

http://www.extensis.com
http://www.extensis.com


6

Technical Support 
For questions regarding Suitcase, please first
refer to this guide and Suitcase Online Help,
which describes the features and basic
operations. We invite you to visit the Suitcase
page on the Extensis website
(http://www.extensis.com) for frequently asked
questions (FAQs) and troubleshooting tips.

If you have a question which is not addressed in
this manual or on the Extensis website,
Technical Support is available by phone at (503)
274-7030 Monday through Friday 8:00 a.m. to
5:00 p.m. Pacific time. When calling for
technical support, please be at your computer
and have the following information available:
your Extensis Suitcase registration number, your
computer configuration and your question or a
description of the difficulty you’re
experiencing—what specifically occurs and
when. Take note of any displayed error numbers
or messages and any other information you
think may be relevant.

Extensis Technical Support can also be
reached by:
Fax: (503) 274-0530
E-mail: support@extensis.com
Internet: http://www.extensis.com/support

Visit Our Website 
For Frequently Asked Questions (FAQs),
troubleshooting information, and other 
up-to-date information about Suitcase, please
visit our web site: http://www.extensis.com

Using this Quick Start
Guide
This Quick Start Guide provides an overview of
Suitcase to help you get “up and running”
quickly. 

When describing keyboard shortcuts,
“Command” refers to the � key. References to
menu selections are shown as Menu >
Command. 

Information preceded with the network icon
( ) indicates a Suitcase Server related feature,
available only when connected to a Suitcase
Server (sold separately).

For more information on specific Suitcase
features, refer to the following:

• Suitcase Online Help—which includes
comprehensive information on Suitcase

• Suitcase MenuFonts HTML Help

• Suitcase User Guide in PDF format on the
Extensis CD

• Read Me—located in your Suitcase folder, this
text file gives you late-breaking information.

For a complete list of keyboard shortcuts,
refer to the “Tips and Shortcuts” section of
Suitcase Online Help.  

http://www.extensis.com/support
http://www.extensis.com
http://www.extensis.com


Suitcase 10 New Feature
Summary
The following list highlights some of the major
new features in Suitcase 10:

• Auto Activation—Automatically activates fonts
when a document using those fonts is opened.

• Control Strip Access—Allows you to activate
font sets instantly from the Mac OS Control
Strip.

• Collect for Output—Gives you an easy way to
collect fonts for specific jobs.

• Multiple Master Fonts—Includes support for
Multiple Master fonts.

• Contextual Menus—Allows you to access
common Suitcase commands from Contextual
menus using a two-button mouse or the Control
key.

• Font Tracking—Keeps track of font problems.

• Activate on Demand—Ensures that the font
you need will be opened immediately.

• Create Empty Suitcase—Allows you to create
an empty suitcase to facilitate font organization.

• Includes a copy of FontBook from LemkeSoft—
This utility allows you to preview and print your
fonts in any of 24 different templates.

Suitcase Server
Enhancements
Requires Suitcase Server software (sold
separately).

• Select Server Sets—Allows network users to
selectively choose which Server Sets to
download.

• Job Fonts Folder—Allows the shared fonts
administrator to quickly make fonts available to
networked users by just dropping a folder of
fonts into the Server fonts folder—without ever
opening the Administrator application.

7



Managing fonts with Suitcase is easy! All you
need to do is add them to Suitcase (tell Suitcase
where to find them) and then “activate” them
(tell Suitcase to make them available to the
system, just as if they had been stored in the
System Folder’s Fonts folder). 

Note: If you wish to use Suitcase to manage fonts
currently stored in the system’s Fonts folder, they
must be removed from that folder and then added
to Suitcase. For information on how to do this,
including which fonts need to remain in the System
Folder Fonts folder, see Suitcase Online Help.

Overview
To add fonts to Suitcase, you need to first open
the Suitcase application (you can do this from
the Apple menu, or by double-clicking the
Suitcase icon in the Suitcase folder). Then use
the Add command or button inside Suitcase to
tell Suitcase which fonts you want to work with,
or simply drag and drop fonts, suitcases, or
folders of fonts into the Sets or Fonts pane,
depending on what you want to do. 

The fonts that you add will not be activated
until you tell Suitcase to do so. Fonts are
activated by choosing either of two states:

• Permanent—which tells Suitcase to activate
the selected fonts immediately and reactivate
them automatically each time the system is
started

• Until Restart—which tells Suitcase to activate
the fonts until the system is shut down. These
fonts will not be reactivated when the system is
started up again. However, Suitcase remembers
these fonts and allows you to easily activate
them again at any time.

No matter which activation state you choose,
when you are finished using a font or set of
fonts you can deactivate them at any time by
opening the Suitcase application and using the
“Deactivate” command.

Note: All fonts opened in Suitcase remain active
until you deactivate (close) them, or until the
system is shut down or restarted.

You can use Suitcase’s powerful “sets” feature to
group your fonts so that you can activate and
deactivate multiple fonts at the same time, or
you can simply add fonts to Suitcase “loose”
(without inclusion in a Suitcase Set). 

You can also create “Application Sets” by
dragging application icons into the Sets window,
then adding the desired fonts to the set. Fonts
in Application Sets are opened automatically
each time the application is launched.

To make things even simpler, you can enable
the “Activate fonts when added to Suitcase”
preference (Edit > Preferences: General) which
instructs Suitcase to activate fonts when they are
added to Suitcase. Fonts will be activated
according to the default activation preference.

Once a font has been added to Suitcase, even if
you deactivate it the font name remains in
Suitcase. This allows you to easily reactivate that
font in the future. If you wish, you can remove
fonts from inclusion in the Suitcase Font
Database by selecting them in the Fonts pane
and using the “Remove” command.

If you work in a production environment,
where each job often requires a completely
different set of fonts, you can use the Activate
on Demand feature to ensure that the correct

8
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fonts are used when you start that job. Activate
on Demand tells Suitcase to activate the fonts
that are being added and to resolve any font
conflicts immediately and automatically.

If your workgroup is connected to a Suitcase
Font Server, font sets on the server will be
automatically downloaded for you. Changes to
Server Sets will be made for you automatically
the next time Suitcase connects to the Server.

Tools and Panes
The Suitcase window provides access to: the
Toolbar, the Sets pane, the Fonts pane, and the
Preview pane. The Suitcase window is shown on
page 10.

To open a pane: Choose it from the View
menu.

• Toolbar: Provides access to the most
commonly used Suitcase commands: New Set,
Add to Suitcase, Remove, Activate Permanently,
Activate Until Restart, and Deactivate. Hold the
mouse over a button to display Hot Help about
that command.

• Sets pane: Lets you organize your fonts by
creating groups (called “sets”) that you can
activate or deactivate at the same time.

• Fonts pane: Displays a list of fonts that have
been added to Suitcase. The list can be filtered
via a pop-up menu.

• Preview pane: Allows you to instantly view
and compare type faces using any of four
different display modes.

• Resize Vertical and Horizontal: Lets you
change pane size. By moving the resize bar all
the way to the top, bottom, right, or left, you
can hide or show the different panes. Each

pane has a minimum size–be sure to drag the
bar far enough to open them.

Drag the appropriate resize bar (see figure
on page 10) to change pane size. Drag the
bar all the way to the top, bottom, or side
to hide the appropriate pane.

• Control Strip: You can open and close font
sets from the Mac OS Control Strip. You will
need to create font sets before you can use this
feature.

The Basics:Adding and
Activating Fonts

To add and activate fonts:

1 Open Suitcase.

Choose “Suitcase” from the Apple menu, or
double-click the Suitcase application icon, or
press the Suitcase keyboard shortcut (default is
�-Option-S).

2 Add fonts for Suitcase to control.

Click the “Add to Suitcase...” button on
the Toolbar, choose the “Add Fonts...”
command on the File menu, or press �L to
locate fonts. Or choose “Add Fonts...” from the
contextual menu in the Fonts pane, or simply
drag and drop fonts, suitcases, or whole folders
(including subfolders) of fonts into the Fonts
pane or the Sets pane.

The selected fonts will be added to the Suitcase
Fonts Database and listed in the Fonts pane. If
you don’t see the fonts listed, choose “Show
Suitcase Fonts” from the pop-up menu in the
Fonts pane, or from the Suitcase View menu.

3 Activate the fonts.

9
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Select the fonts that you want to activate. On
the Toolbar, click either the “Activate
Permanently” (green) button or the “Activate
Until Restart” (yellow) button. Or click the
cursor in the Status column to activate or
deactivate a font or set. When held over the
Status column, the cursor changes color to
show the state of change when you click.

The fonts will be made available to your
applications just as if they were opened by the
system by being in the System Folder’s Fonts
folder at startup time.

Note: If one font in a suitcase is selected to be
activated or deactivated, all the fonts in the
suitcase will do the same.

When activating fonts by clicking in the
Status column, Option-click to change
activation state from the default. You can
change the Default Activation State in Edit
> Preferences > General.

You can also activate font sets from the
Mac OS Control Strip. Only sets are
displayed in the Control Strip, so you will
need to create sets before you can use this
feature. See page 13 for information on
creating sets.

4 Deactivate (close) the fonts when you are
done using them.

To close fonts manually at any time, select the
fonts or sets that you want to close, then click
the Deactivate (red) button on the Toolbar, or
press �K. Or click in the Status (left-most)
column for the desired font or set. 

To automatically activate fonts when you
add them to Suitcase, select the “Activate
fonts when added to Suitcase” option in
the General tab of the Suitcase Preferences
(Edit > Preferences > General, or press
�Y).

Font Activation Commands
and States
You can see at a glance the status of any font or
set by looking at the icon displayed in the Status
column( ). The color of the icons displayed
in the Status column coordinates with the icons
on the Toolbar that you use to change
activation state.

Activation States

Three buttons in the Toolbar affect activation
state. You change activation state of selected
fonts or sets by clicking these buttons, or by
choosing the appropriate command from the
File menu. These same three activation
commands can be invoked by clicking the
cursor in the Status column of the desired font
or set, or by choosing a set from the Control
Strip. 

The three font activation commands are:

• Activate Permanently: (green icon)
Fonts activated Permanently will be activated
immediately, and will remain active until the
system is shut down. They will be activated
automatically each time the system is started or
restarted.

• Activate Until Restart: (yellow icon)
Fonts activated Until Restart will be activated
immediately, and remain active until the system
is shut down. These fonts will not be reactivated
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when the system is restarted. The fonts will
remain in Suitcase so that you can activate them
again when you wish to do so.

• Close/Deactivate: (red icon) Fonts that
have been closed will no longer be available to
your applications. To view the list of closed
fonts, choose “Closed Fonts” from the pop-up
menu in the Font pane.

Status Icons

Icons in the Status column of the Sets window
indicate the status of each set, and each
individual font in the set.

• Activated Permanently: (green) is the
status associated with fonts opened by the
“Activate Permanently” command or button. 

• Activated Until Restart: (yellow circle) is
the status associated with fonts opened by the
“Activate Until Restart” command or button.

• Auto Activated: (yellow diamond) is the
status displayed for a font that was
automatically activated by Suitcase due to a
request from an application.

• Inactive/closed: (no icon) is the status
associated with fonts that have been closed
using the Deactivate command or button, or
that have not been reactivated after system
restart.

• Mixed Set: is the status displayed for a set
when the set contains fonts with different
states, such as some active and some inactive,
or some Activated Permanently and others
Activated Until Restart.

• System Font: indicates that the font
resides in the System Folder’s Fonts folder.
Fonts in this folder are activated by the Mac OS

when the system is started up and therefore
cannot be controlled by Suitcase. To give
Suitcase control of fonts in the system’s Fonts
folder, move them to another folder. See
Suitcase Online Help for information and cautions
about moving fonts out of the System Folder.

• Missing Font: is the status displayed for a
font when the original font file cannot be
found. Typically this means that the font has
been moved or renamed since it was added to
Suitcase. For help in relocating missing fonts, see
Suitcase Online Help.

• Corrupt Font: is the status displayed for
a font that has crashed the system. Suitcase
will not allow any font to load that crashes the
system. Open Suitcase and remove the font,
then replace it with a copy of the original font.

12



Suitcase Sets
Sets are simply collections of fonts— an
organizational tool for you to use to group fonts
in ways that make them easier for you to work
with. You use Sets to tell Suitcase “activate all
these fonts at the same time,” rather than
having to specify activation instructions for
each font individually.

Using the Control Strip, you can activate
or deactivate font Sets without opening the
Suitcase application.

To create a new set:

• Drag and drop folders of fonts into the Sets
pane. 

A set will be created with the same name as the
top-level folder, with the fonts already added
to the set. 

— or —

• Use the “New Set” button or command to
create a set. Add fonts to the set by dragging
and dropping them onto the set icon in the
Sets pane, or select the set, then use the “Add
to Suitcase...” button or the “Add Fonts to
Selected Set...” command (from the File menu
or contextual menu).

You can activate or deactivate all the fonts in a
set at once, or click the expand arrow to work
with individual fonts in the set. Activating and
deactivating all the fonts in a set is the same as
with individual fonts (step 3, page 11), except
that your actions affect all the fonts in the set. 

To change the name of a set:

• Highlight the set name, then enter the
desired name. 

Application Sets

A special type of set, called an Application Set,
lets you open fonts automatically whenever a
particular application is opened. 

When you quit the application, the fonts in
the application set remain available until you
deactivate them in Suitcase, or until you shut
down your computer. 

To create an Application Set:

• Drag and drop the application icon into the
Sets pane, or choose “New Application Set...”
from the File menu, then locate and choose
the application that you want to use.

The application’s icon will be displayed instead
of the folder icon for this set. For example: .

You add fonts to an Application set the same
way you add them to a regular set.

13



Activate on Demand
If you are working in a production
environment, such as a Service Bureau or
commercial print shop for example, you  may
need to activate fonts supplied by customers
“temporarily.” For example, just while that job
is being output.

Opening fonts using this command tells
Suitcase that if a font conflict exists (that is, if
another font by that name has already been
activated) you want the newly selected font to
be activated. If Suitcase finds a conflict, you will
not be presented with a dialog asking you to
choose, the fonts you selected will simply be
activated and any others closed.  

Temporary fonts are deactivated (closed) when
the system is shut down, or when another
Temporary font with the same name (but from a
different location) is added and activated.
Temporary fonts are removed from Suitcase
automatically when the system is restarted or by
pressing �-, (Command-Comma).

To activate fonts on demand:

• Open Suitcase. Press and hold the
Command (�) key, then drag and drop the
fonts into the Suitcase Fonts pane. 

Fonts added temporarily are displayed in red
type on Suitcase font lists. Deactivate these
fonts as you would any others.

To view the list of fonts added
temporarily:

• Choose “Show Temporary Fonts” from the
Edit menu, or press �3, or choose “Temporary
Fonts” from the pop-up menu in the Fonts
pane.

To deactivate and remove ALL fonts added
temporarily, press �-, (Command-
Comma) or choose ‘Remove Temporary
Fonts’ from the from the Edit menu. A
confirmation dialog will be displayed. To
bypass the confirmation dialog, press �-
Option-, (Command-Option-Comma).
To remove some of the Temporary fonts
and not others, select the fonts you want
to remove and choose ‘Remove Selected
Items’ from the Edit menu or from the
contextual menu.

14
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Previewing Fonts
Suitcase gives you four different ways to view
text in selected font faces:

• Waterfall

• Alphabet

• Paragraph

• QuickType

Views and point sizes are easily selected from
pop-up menus in the Preview Window. 

QuickType™ View

QuickType view lets you enter preview text “on
the fly” by typing into a text box at the top of
the Preview window. Text for the other three
views can be changed in the Preferences dialog
(Edit > Preferences: Preview Text).

To change views in the Preview pane:

• Choose a new view from the pop-up menu
in the Preview pane.

You can select multiple fonts or sets for
previewing. To select items contiguously,
press and hold the Shift key while
selecting. To select non-contiguously, press
and hold the � key while selecting items.

Automatically Activating
Fonts When You Open a
Document
Suitcase adds the powerful ability to
automatically activate fonts required by a
document when you open that document,
saving you both time and frustration.

Note: The fonts required by the document must be
in Suitcase before Suitcase will be able to activate
them.

When Auto Activation is enabled and  there are
multiple instances of a font in Suitcase, the first
instance of the font will be activated. Suitcase
will present a dialog informing you that more
than one instance of the font exists.

You can disable Auto Activation, or set options
for this feature, in the General tab of the
Suitcase Preferences (Edit > Preferences >
General).

To enable Auto Activation in PageMaker,
first open PageMaker. Choose File >
Preferences > General. Click the Map Fonts
button. From the Font Matching Preferences
dialog, select ATM Font Matching.

Due to the manner in which Adobe
applications (such as Photoshop and
Illustrator) request fonts from the
operating system, the Suitcase Auto
Activation feature does not currently
support these applications. We suggest
creating Application Sets to automatically
open fonts in these applications.
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Resolving Font Conflicts
and Duplicate Fonts
When two or more fonts have identical names
there is a font conflict. In a font conflict the
Mac OS cannot determine which font to use
and chooses arbitrarily. 

One of the important advantages of using
Suitcase is to help guarantee that your
documents maintain font consistency each time
you open and work with them. 

If a duplicate font conflict occurs:

Suitcase will warn you that a duplicate font was
found, and will display a dialog allowing you to
choose which font will be activated. 

You can resolve the conflict by choosing which
suitcase you wish to have activated. 

If the duplicate font is part of a suitcase of fonts,
some of which you need to have open, you may
need to remove the font from the suitcase
before working with that document.

In the event you have more than one font
conflict, hold down the Option key when
clicking “Keep Active” or “Activate
Instead” and Suitcase will resolve the
remaining conflicts.

Identifying and Removing
Corrupt Fonts
Corrupt fonts will often cause a system crash
when the font is displayed, either in a
document or in the Preview pane in Suitcase.
This is a Mac OS issue and has little to do with
how Suitcase manages fonts.

However, if the crash occurs in Suitcase, the font
will be marked in the Suitcase Fonts list with a
warning icon ( ). When the system is restarted
Suitcase will permanently disable the font so
that it can no longer cause problems.

If you see a corrupted font in the Fonts List you
will need to remove it from Suitcase and replace
it with a copy of the original uncorrupted font.
You should remove the corrupted font from
your system as well. 

To find out more about a corrupt font (such as
the pathname of the font so you can remove it
from your hard drive), select it in Suitcase, then
choose “Get Info” from the File menu or from
the contextual menu, or press �I, or press �R
to reveal the font in the Finder.

16



Viewing Lists of Fonts
You can view the fonts that Suitcase controls in
a number of ways: 

• Suitcase Fonts—lists all the fonts that Suitcase
controls.

• Fonts in Selected Sets—lists all fonts in sets
you have selected.

• Open Fonts—lists all fonts that are currently
active (open).

• Closed Fonts—lists all fonts that are currently
inactive (closed).

• Temporary Fonts—lists all fonts that will be
removed from Suitcase when the system is
restarted.

• Auto Activated Fonts—lists all fonts that have
been activated automatically.

• System Folder Fonts—lists all the fonts in the
System Folder’s Fonts folder. These fonts are
activated by the Mac OS at system startup time
and cannot be controlled by Suitcase.

• Missing Fonts—lists fonts that have been
moved or renamed and are therefore no longer
available to be activated by Suitcase.

• All Fonts—lists all the fonts in Suitcase.

• Server Fonts—lists all the fonts downloaded
from the Suitcase Server.

To view a font list:

Select the desired list from the pop-up menu in
the Fonts pane, or select it from the View menu,
or press the appropriate keyboard shortcut.

Collecting Fonts for
Output
You can use Suitcase to collect fonts and copy
them together into a folder, for example if you
need to send certain fonts to your print vendor
with your job.

To collect fonts for output:

1 Select the fonts and/or sets that you want to
collect.

2 Choose “Collect Fonts for Output...” from
the Tools menu, or press �D.

3 Locate or create the folder where you want
to put the collected fonts, then click Choose to
choose that folder.

4 Click “Collect.”

The screen fonts and any associated printer
fonts will be collected and placed together at
the top level of the chosen folder.

Creating an Empty
Suitcase
To create an empty suitcase for moving or
rearranging fonts, choose “Create Empty
Suitcase...” from the Tools menu (Tools > Create
Empty Suitcase, or press �H).
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Suitcase XT
Suitcase XT is an XTension to QuarkXPress that
automatically locates missing fonts and opens
them. 

This XTension works hand in hand with
Suitcase and Apple’s FontSync technology to
open missing fonts: When you open a
document with missing fonts, Suitcase XT looks
for those fonts in Suitcase. If the fonts are
found, they will be automatically opened. If the
missing fonts are not found in Suitcase, a dialog
box will be displayed giving you the option to
replace the font(s).

Suitcase XT works with QuarkXPress versions
4.0.3 and higher. For the latest QuarkXPress
updaters, visit the Quark web site:
http://www.quark.com

Getting Started with Suitcase XT

Note: The Suitcase XT XTension is automatically
installed by the Suitcase installer.

Suitcase XT works automatically “behind the
scenes” each time you open a QuarkXPress
document (provided that the XTension is
enabled with the QuarkXPress Extensions
Manager. 

To change Suitcase XT options:

• Choose “Suitcase XT” from the Edit >
Preferences menu in QuarkXPress.

Suitcase MenuFonts
You can display open fonts in the font menus of
applications in WYSIWYG format by enabling
the Suitcase MenuFonts control panel. This
allows you to see the fonts “as they really are” so
that font selection is easier. 

Note: Prior to Suitcase 8, the WYSIWYG Menus
feature was a part of the Suitcase application, and
accessed from the Suitcase Preferences window.
This feature is now handled by the Suitcase
MenuFonts control panel.

With Suitcase MenuFonts, you can immediately
see the font type of listed fonts (PostScript Type
1 and Type 3, TrueType, Multiple Master,
Bitmapped), you can group fonts into family
submenus, and more.

Suitcase MenuFonts is not compatible with
other similar menu font utilities (such as
Adobe Type Reunion and Action Menus).
You must disable or remove these utilities
to use Suitcase MenuFonts.

Getting Started with Suitcase
MenuFonts

The Suitcase MenuFonts control panel is
available as a custom install option. 

To use Suitcase MenuFonts:

• Simply select the Font menu in any
application.

To change Suitcase MenuFonts options:

• Open the Suitcase MenuFonts control panel
in the Control Panels folder in the System
Folder.
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If your workgroup has access to a server running
Suitcase Font Server software, you can connect
to the Suitcase Server and have fonts
downloaded to your computer.

You do this through the Suitcase Preferences.

For more information on working with a
Suitcase Server, see Suitcase Online Help.

Suitcase Server
Related Preferences

Options in the Server Connection tab of the
Suitcase Preferences dialog (Edit > Preferences >
Server Connection) allow you to connect with a
server running Suitcase Font Server software.

Note: You must have TCP/IP services active to
access the Server. Standard AppleTalk connectivity
is not supported. Contact your System
Administrator for assistance with network setup.

Using these options you can connect with the
Server and determine at what intervals to
connect to the Server for updates.

You can also update your fonts from the Server
manually by selecting “Synchronize with
Server” from the Tools menu, or press �U.

If you only want to update font files from
the Server manually, choose "Never" in the
"check for update" pop-up menu in the
Server Preferences tab (Edit > Preferences
> Server Connection).

Subscribing to Server
Sets

New in Suitcase 10 is the ability for Suitcase
network users to selectively choose which Server
Sets to have downloaded to their computer. This
allows you to select only the font sets that you
need to work with, saving both time and disk
space.

To select Server Sets, choose “Subscribe to
Sets...” from the Tools menu, or press �B.

Only the Server Sets that you select will be
downloaded to your computer. These sets will
continue to be updated at the interval set in
Server Client Preferences, as long as the Set is
selected.

Creating Server Sets
on the Fly

Suitcase makes it easy to create Server Sets
without even opening the Server Administrator
application: simply drag and drop folders of
fonts into the Job Fonts folder on the Suitcase
Server to instantly create a new Server Set.
Suitcase will name the set with the folder name.

Users will see sets created this way when they
subscribe to Server Sets.

To maintain the same font download
functionality as Suitcase Server version 8
or version 9, place Server fonts in the
"Always Download" folder (SuitcaseFonts:
Always Download)
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